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1.0 Stormwater Design - Introduction

The 12d drainage module contains functions to perform the following steps in the drainage design 

and documentation process. This user manual will lead the user through the steps itemised below:

s set drainage defaults and layout a drainage network,

s use the powerful 12d drainage network editor to avoid service clashes, grade pipes, 

align obverts, minimise depth and many other design tools,

s automatically assign names to the pit/pipes in the network,

s designate catchment areas and produce catchment plans,

s transfer data to and from electronic spreadsheets to enable the user to easily review 

the data and add user defined data to the 12d pipe network. This data may include 

such data as pipe bedding types and trench width,

s create pit setout schedules to export to spreadsheets or word processors for final for-

matting,

s Running the 12d storm analysis calculations,

s produce long section drainage profiles including HGL data, flows, invert levels and 

service crossings,

s create plan drawings with pipe sizes, flows, pit symbols, linestyles for pipe sizes, 

design parameters for pit and pipes and user defined data,

s locate pits/manholes at exact chainage and offset locations.

In addition to this manual there is the Stormwater Design - Part2 training manual which includes 

the following topics.

s drainage trench excavation volume calculations

s pipe and pit quantity calculations

s customising the drainage.4d file

s design or evaluate the drainage system using 12d sotrm analysis or create input files 

for the XP SWMM/RAT2000, Micro drainage, Drains and PCdrain drainage design 

packages,

s read the output from the drainage design packages (automatic if using 12d Drainage), 

update the drainage network and store the hydraulic data, such as hgl (hydraulic grade 

line) levels, peak pipe flows and pipe capacities,

s pit inlet capacity calculations and bypass flow

s flooded width analysis and flooding at SAG pits

s creating drainage symbols with grates and upstream side inlets,

s detailed drainage plan labelling and long sections with hatching under roads.

In this document, the generic term pit refers to manholes, inlets, catch basin and manholes. When 

the term manhole is used on the 12d menu system it refers to any type of pit. Pit types, dimen-

sions and inlet capacities of the pits are set in the drainage.4d file.
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2.0 Using the Course Notes

Areas markered in yellow (grey for black and white prints) are the exact steps required to complete 

the tasks. The numbers in the panels are the order to preform the tasks and they are always written to 

the right of the button, drop down or data field.

The additional text explains in more detail the tasks you are preforming.

3.0 Setup Files and Their Locations

The drainage module consists of the optional 12d Drainage Analysis, utilities, startup configuration 

files for RAT2000, XP SWMM and the 12d drainage configuration file (drainage.4d).

All setup files have been configured for the training version. However, when you start working on 

real projects you may want customise the drainage module. More - Customising the drainage 

module

The drainage.4d file contains pipe types (RCP, Class 2 etc.) and example pit inlet capacites for inlet 

pits. Detailed pit type descriptions and internal pit dimensions can be included in this file to be 

inserted into your pit schedules. For PCdrain and Drains users there are routines to read your gully 

pit/database files and create the drainage.4d file More.

REVIEW THIS DATA CAREFULLY! The drainage.4d file may be customised for any additional 

inlet capacity data you may have.

To edit the drainage.4d file, from the main menu select

Design->Drainage-Sewer->More->Edit drainage.4d

You must restart 12d for these changes to become active. Select Project->Restart!

Select the Find button to search the 12d path for the 

current drainage.4d file. Select the More info button 

and then Open to edit the file.
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4.0 Survey data and design surfaces (TINs)

We will begin a 12d project from the beginning by first creating the project and then reading in 

the survey and design data. The data can then be triangulated so that we have a final surface to 

measure pipe cover from and set structure cover levels to.

Start up the 12d model by selecting the 12d icon from your desktop.

The project selection panel will appear. The bottom corner of the panel is shown below

12d will first look in your working folder for any input data files and output files will be created 

here unless you specify another folder. 12d stores it’s data in a folder not a single file. Therefore, 

a folder named Stormwater Part 1 will be created when you select Proceed.

12d model will load and you will see the following panel.

1) LB to browse to the working folder indicated.

2) Type a project name for your work Stormwater Part 1 for example.

3) Select Proceed.
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4.1 Importing the Raw Survey Data

You have created a new project into which we will import the survey data. From the main menu 

select.

Enter data as desired. This data is both for refer-

ence and can be included on your drawings.

Later these details can be changed via

Project=>Management=Details Editor

File I/O->Data Input->12da/4da data

1) LB the folder icon to display the file list. 

Select the file existing survey.

2) LB Read to read the data

3) LB Finish to remove the panel

The data will not appear on the view until 

it is added. 
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Add the data to the view

LB the + then select EXISTING SURVEY.

Next LB Fit on the plan view tool bar. You should see the following survey data. 
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4.2 Creating the existing Ground Surface

From the main menu select

1) LB the toggle button

2) LB Z values

Use your mouse wheel to zoom in 

and read the z values.

Now we will display the z values for 

the survey data.

Tins=>Create=> Triangulate data

1) Type a name for the new tin then press Enter

2) LB Remove Bubbles because the data con-

tains contours.nd LB EXISTING SURVEY

Preserve strings will make one side of a triangle 

follow the string thereby preserving the levels 

along the string.

Weed tin removes all duplicate points from the 

tin database.

The Cell method is a good speed enhancement 

for data that is in a grid type pattern.

Triangle data is used for string that form trian-

gles (tins imported from other packages).
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4.3 Viewing the Ground Surface Tin

The tin will be shown with the tin edges turned on. This is the default when you have all tin dis-

play modes turned off. 

1) LB the Data tab

2) LB the model icon and DLB 

EXISTING SURVEY

3) LB Triangulate to create the 

new tin.

4) LB Finish

The tin will be stored in the model tin exist-

ing. A tin, like all 12d strings, must be stored 

in a model. 12d prefixes all its tins with tin for 

data management.

1) Move your pointer over the “+” sign on the plan view title toolbar

2) press the t key (all of the models beginning with lower case t will appear)

3) Double click on tin existing survey

4) LB Finish
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1) LB the toggle button

2) LB Tin contours.

The contours are displayed with 

their default colours and increment 

(1 unit).

1) LB the toggle button

2) LB Tin flow.

Flow arrows are now visible at the 

centre of every triangle.

Display Contours

Display Flow Arrows

1) LB the View menu button

2) Walk right (do not select) on settings.

3) Walk right on Tins.

4) LB Contours

Change Contour Intervals and 
Colours
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Change the Flow Arrow Length and Colour

Select the Menu button on the plan view tool bar and then walk right on.

Settings=>Tins=>Flow Arrows and the following dialog will appear. Remember to 

walk right!

4.4 Inquiring about Heights on the Surface

The elevation anywhere on the tin can be obtained by simply moving the pointer over the desired 

spot. To obtain the tin elevations select,

1) Type a new Cont inc

2) Type a new Bold inc.

3) LB Set to see the new contours.

4) LB Finish when done.

1) Type a new Arrow length

2) LB the colour icon to select a new Col-

our for arrows.

3) LB Set to see the new flow arrows.

4) LB Finish when done.

Tins=>Inquire=>Height
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You will see that data in the panel change as you move the pointer around the screen. Move the panel 

to the bottom right corner of the screen and leave it there.

4.5 Viewing the Surface Tin in a 3d Perspective

To create a 3d perspective view select

4.6 Reducing the number of points for the 12d Practice Version

We can delete the survey data to save space for those using the practice version of 12d. If you have a 

full version of 12d this is not required. From the main menu select.

and the following dialog will appear.

View=>New=>Perspective Open GL

1) Add the model tin existing surface to the view.

2) Toggle the contours on.

3) Toggle the shading on (note that the contours are no longer seen).

4) Use the Orbit control (planet on the toolbar) and zoom wheel to move around the 

view.

Models=>Delete=>Delete a Model

1) LB the model icon and select EXISTING SURVEY

2) LB Delete and then confirm each panel

3) LB Finish



Revised 17 Sept 2007 12d Stormwater Design Course Notes - Part 1 Page 15 of 102

12d Solutions Pty Ltd

COURSE NOTES

STORMWATER DESIGN

4.7 Importing the Road Design Centre lines

Repeat the process of importing 12da data.

4.8 Using Create Roads

We are going to create the roadways from the road centre lines (vertical grading has already been 

done). First we will need the road templates that we will read from a templates file.

Now we are ready to create the road strings and design tin.

File I/O->Data Input->12da/4da data

1) LB folder icon and select road design

2) LB Read (the data will not appear on 

the view yet).

3) LB Finish

Remove all of the models from the view.

Hint: (- button on view tool bar).

Add the Road Centrelines model onto the 

plan view.

Toggle the Z value off.

File IO=>Templates input

1) LB folder icon and select lib and select Road templates

2) LB Read

3) LB Finish

Design=>Roads=>Create=>Create Roads - Manager
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To view the road strings, add on all of the Road * models. To view the tin add on the tin design 

model.You can also add the tin design model onto the perspective view. Important: On the 

OpenGL perspective view, 12d will show the tin data with the greatest z values (when viewed from 

the top side).

1.  Type a new Function name of design

2. LB the Outputs tab.

3. Type a new Model for the Road polygons,

4. LB the Create button TWICE.

5. LB the Finish button.

6. Add tin design onto the plan view.
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4.9 Creating a Super Tin from the Survey and Design Data.

The drainage fs tin may be used to set pipe inverts, pit levels, sag catchment overflow points and 

catchment slopes for tc strings. Therefore, the tin often needs to include several tins combined 

into one tin. To create a tin that is the combination of the survey data and the road design data you 

will need to create a 12d super tin. From the main menu

- tin 1 is the tin on the bottom (like the levels in a building) and tin 2 is above. i.e. wherever tin 2 

exists it will be used. If there is no tin 2 at a location then tin 1 will be used.- tin flow arrows 

are not available,

- contours can be displayed but not created for export.

4.10 Changing the Colour of a Tin

To emphasise the super tin is just the 2 tins “glued” together, we will change the colour of the 

existing tin and see how the super tin changes colour as well.

Tins=>Create=>supertin

7.  Type a New tin name of combined

8. RB in the cell and select the existing tin.

9. RB in the cell and select the design tin.

10.LB the Create button TWICE.

11.LB the Finish button.

12.Add tin combined onto the plan view.

Notes about super tins:

- tin colour is only used in section views,

- the super tin is the 2 tins “glued” together,

- the super tin is Opaque so it will “cover up” 

other models already on the view. Use 

the Menu button on the View toolstrip 

and select Models->models to back 

and select the super tin.
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Toggle the Tin solid on and note the colours of the super tin.

Tins=>Colour=>Colour of tin

1. LB tin icon and select the existing tin

2. LB colour icon and select dark green

3. LB Colour

4. LB Finish
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5.0 Drainage Layout

Before creating drainage strings in12d we should set default values for the pit and pipes. This 

ensures that most of the pit and pipes will have the desired type, size etc and then we only need to 

modify the pit and pipes that are different to the default values.

Where a drainage designer chooses to start their design is a depends a great deal on the project 

and the designer. Identifying overland flow routes is essential because it is on these routes that the 

inlets are to be placed. Inlet structures are then placed at critical locations (sag points, flattening of 

grades, upstream of pedestrian crossings etc.). and then the spacing of additional inlets is deter-

mined by the size of the catchments. Finally, the pipe drainage system can be created linking the 

drainage structures.

5.1 Setting Drainage Defaults

The defaults for the drainage network are accessed through three panels; pipe defaults, manhole 

defaults and Tin defaults.

5.1.1 Tin Default

Warnings about using tins. If you place a pit outside the tin boundary:

s then no elevation will be set for the top of the pit, (it can be set later manually or by 

linking it to a design string).

s Pipe invert levels cannot be set using the default cover. Pipe invert levels must be set 

manually as 12d cannot automatically determine cover levels without a TIN.

s Finally, if your drainage design package accepts surface levels along the string, then 

an error message will be displayed at export time. The message will say that the sur-

face level string is shorter than the pipe length.

Design =>Drainage-Sewer =>Defaults=>Tin

The default TIN is used to set the initial manhole cover 

and setout levels, and using with the default cover (yet to 

come), the pipe invert levels. Super tins may be used if 

you want to place manholes on both the existing and the 

design ground surface (see Creating Super tins).

1. LB the tin icon and select the combined tin.

2. LB the Set button

3. LB the Finsih button.
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5.1.2 Manhole (Pit) Defaults

Notes on pit Diameters

The pit diameter is specified in metres/feet not mm/inches. Although most stormwater pits are rec-

tangular, 12d uses circular pits to eliminate problems showing the alignment of the pit. If the actual 

size and orientation of the pit are needed on the final drawings, a symbol may be used in the drainage 

plot annotations. For rectangular pits, dimensions and a detailed description can be added to your 

drainage.4d file (mhsize command) so that they can be added to your pit schedules.

The diameter can also be set in the drainage.4d file via the mh_diam command.

The Diameter is used for:

1. for visual service clash identification in long section drawings,

2. to clip the pipe lines drawn in the plan annotations so that symbols can be inserted in the space 

created,

3. maximum distance the bypass flow strings can be drawn from an inlet centre.

The minimium drop will be used to set the invert level of the outlet pipe relative to the invert level of 

the inlet pipe. The drop should always be entered as a positive value.The network editor has many 

more options for aligning the pipe inverts at the pits.

Generally, do not use a default name. Leave all of the pits unnamed and then use the Set Pit Names 

function on the drainage network editor.

The pit type is selected from a list by selecting the icon beside the Type. This list is obtained from 

the drainage.4d file. This pit type will be used by 12d storm analysis, ILSAX, PCdrain and RAT-

HGL, RAT2000 and XP SWMM to identify the inlet capacity. This value is not exported to the 

Drains program but it will determine the pit family. See Drainage Import/Export. It is best to set 

this to the most common pit type and then change the few that are different later in the network edi-

tor.

You must click the Set button to set the default values. Finish alone will not set the defaults.

Design =>Drainage-Sewer =>Defaults=>Manholes

1. Type the desired diameter.

2. LB the Type drop down and select the 

most common manhole type.

3. LB the Set button.

4. LB the Finish button.
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5.1.3 Pipe Defaults

The pipe diameter is set in metres or feet not mm or inches. Set this to a minimum pipe diameter 

for your project and then your drainage design package can increase them if required. To model 

an existing system enter the most common pipe size and then alter other pipes as required in the 

network editor.

Allowing for Pipe Thickness

When 12d set the pipe inverts it checks the minimum cover from the obvert of the pipe to the fin-

ished ground surface at both pits. 

Cover = surface level - diameter - invert

Therefore, an allowance for pipe thickness should be added to the minimum cover.

If the grade of the pipe is less than the minimum grade, the grade of the pipe is increased. Finally, 

12d checks if there is anywhere along the pipe length that has less than the minimum cover. If 

there is such a low point in the design surface, the pipe is shifted vertically downwards to achieve 

the cover required. 12 defines cover as

When using the network editors to change the pipe diameters the invert levels will remain fixed 

and the obverts will change. The inverts may be reset using Regrade Network on the network 

editor.

The list of available pipe types is set in the drainage.4d file.

5.2 String Colour and pit Label Text Size/location (string defaults)

12d can automatically label the pits at a fixed offset from the pit using view text OR you can use 

the network editor Plot to create text labels that can be moved/rotated etc.

For view text, the default line colour and text size are set by selecting

The following panel will appear.

1. Type the design pipe diameter.

2. Type the minimum grade (1 in xxx)

3. Type the minimum cover (include pipe thick-

ness (see below).

4. LB the Type drop down and select the most 

common pipe type.

5. LB the Set button.

6. LB the Finish button.

Project=>Management =>Defaults
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1. LB colour icon to set the default colour of the 

drainage string and manhole labels.

2. Type the height of the text in pixels

3. LB the Set button. This will set the defaults for this 

project only.

4. LB the Finish button.

Optionally, you may LB the Write button 

to set the defaults for other projects. The 

following panel will appear. Selecting 

Current folder will save ALL these 

defaults for projects in this working folder 

only. The defaults set in the user or setups 

directories will not be used if you select 

this option.

Selecting User folder will save your 

defaults so that all other 12d projects will 

use this defaults. This is the most common 

option (unless your network administrator 

has not given you write access to this area 

(check Properties).

Select Write then Finish
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5.3 Importing Drainage Layouts from AutoCAD

We are now going to import a pipe layout that was drawn in AutoCAD along with the overland 

flow routes and catchment areas (These could have been created in 12d as well). When these were 

drawn the following rules were followed:

1.Strings are drawn where the pipes are NOT to setout x,y locations,

2.Polylines are used in AutoCAD,

3.lines drawn from upstream to downstream (direction of flow),

4.a vertex was placed at every pit location.

To import the AutoCAD drawing, from the main menu select

5.4 Create the drainage strings from the dwg strings

12d will convert the import strings into 12d drainage strings. The default pipe, pit and tin data will 

File IO->Data Input=>DWG/DXF/DXB

1. LB the folder icon and select the drainage data file

2. Type a prefix for the models. It will help organise 

the layers from AutoCAD as every layer goes into a 

separate model in 12d. Specifying a prefix causes 

all of the layer names to be prefixed with this text 

and therefore kept together in the model list. The 

prefix used is dwg<space>.

3. LB Read button. If you select the Read button 

more than once the data will be imported again and 

you will get duplicate, triplicate...etc data. 

4. LB Finish

The models that have been created are,

dwg d catchments

dwg d overland flow

dwg drainage network

1. Remove all of the models from the view

2. add the model dwg drainage network

This is a 2d drainage layout that we will use to locate 

the pits in our drainage design.
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be used to set the levels for the network.

From the menu select

The following panel will appear.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source source box model

data source for strings to be converted

Model for drainage strings model box

The new drainage strings will be added to this model. If it does not exist it will be created.

Flow direction choice box same as string direction

same as string direction if the strings have been drawn in the direction of water flow

opposite to string direction if the strings are drawn opposite to the direction of flow.

Process button

Coverts the strings to the drainage strings.

Finish button

Removes the panel from the screen.

Important notes:

The imported strings must all be drawn in the same direction. Either all in the direction the water 

flows or all opposite the direction of flow..

Pits are created at all vertices on the strings. 

Trunk lines must have a vertex where the branch lines join.

Design=>Drainage-Sewer=>Create from strings
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String names can be used to control the order in when the drainage lines are numbered. These 

names will be transferred to the 12d drainage strings. Later, the string names can be changed in 

the Drainage Network editor.

The drainage lines must have string names to use the Set Pit Names feature on the network edi-

tor.

Pits can always be renamed in 12d after the import is complete.

5.5  Drawing the Drainage Network in 12d

The following method of drawing the drainage pipe systems has proved very efficient in the past. 

However, many people will have their own, “tricks of the trade”. Therefore, the rational behind 

the following procedure will be important for the user to understand when they want to try out 

their own procedures.

Key Points

1. Draw the pipes where they actually are! Do not place the pit centres at the setout point and 

have the pipes in the wrong location (pipe cover will be affected). Use setout strings for setout 

points!

2. Drawing all drainage lines in the same direction may help you keep your drainage work organ-

ised. Either draw all string uphill to downhill (flow same as string direction) OR downhill to 

uphill (flow opposite to string direction).

3. The Drainage Network Editor Regrade Pipes is the key to setting pipe invert levels! Use this 

after modifying the drainage plan layout as it will update all initial grading described below.

However, 12d will perform an initial grading as as you draw the string. If you choose opposite 

to string direction then will need to select Pipe=>Default Grading then Grade to have acheive 

this initial estimate. If you create branch lines before the trunk lines the initial grading will 

ensure the trunk line inverts remain below the branch line. 

5.6 Pit Levels (cover level, grate level and setout level)

12d has 3 levels for every pit, cover, grate and setout.

s Cover level is used for the section views and long section drawings,

s Grate level is the reference elevation for freeboard calculations,

s Setout level construction setout levels

These levels can be set to be dependant on each other or completely independant. Also there are 

several options for determining these levels. These are described below,
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Pit Level (z) Options

There are currently 9 modes for determining the pit levels.

5.7 Pit Setout strings

The centre of the pit (x,y and z) need not be the pit setout point used in the setout tables.The con-

struction setout location can also be set independently of the pit centre. It is recommended that you 

place the pit centre so that the pipes are shown in their actual location and then use the desired option 

for setout. With the pipe in the proper location, the pipe cover and service clashes will be calculated 

correctly. The default settings for the pit setout location are found on the network editor-defaults-

pits-setout data.

Cover RL - this ensures the level is the same as the Cover RL (not available 

for Cover level).

FS tin -The level is obtained from the finished surface tin at the pit centre.

NS tin -The level is obtained from the existing surface tin at the pit centre.

Setout String - The pit centre is dropped perpendicular onto the setout string 

and the level is obtained from the elevation on the string.

Sz + Setout String an offset is added to the level from Setout string described above.

Max Obvert- all connecting pipes, usually open channels, are checked for the highest obvert.

DS Invert - the invert of the outlet pipe (there is only one).

Sump Invert - the lowest pipe invert plus the Sump offset.

Manual - The user must manually type in the cover levels (rarely used as a default).

Road Centre Line

Road Chainage and offset

Setout String

x y from setout string

Pit Centre

x y at pit centre
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Setout x,y Options

Option 1 Pit Centre

The x,y location will be the centre of the pit.

Option 2 Road Centre Line

The road chainage and offset are measured perpendicular to the road centre line out to 

the pit centre or setout point.

Option 3 Setout string

The pit centre is dropped perpendicular onto the set out string to obtain the x and y.

Example

In the diagram below the setout point is lip of kerb. The setout x,y location level z will be 

obtained from the setout string and the pipe will be shown at its proper position.
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5.8 Creating the Drainage Strings in 12d

Drainage strings can also be created in 12d. A drainage string is created by selecting

TIP: If you have already created a drainage string, click the Same as button and select the drainage 

string to obtain the panel values from that string. After selecting the string, change the string Name. 

Additional Notes

Name:

Each drainage string in the model must have a unique Name if you plan on using the Set Pit Names 

option after all of the strings have been drawn. The name of the string should be kept short, <B> for 

example, as it will be used as the prefix or suffix for the pit names. Examples of pit naming schemes 

available for a string labelled, <B>, are B1, B2, B3 … ,or 1B, 2B,3B…or 1/B,2/B, 3/B… etc.

Sequential numbering all of the pits (1,2,3 etc.) is also an option. The pits on the string named 1 will 

be labelled first and then 2 and so on. If you insert a new string with a name in the middle an existing 

series (i.e. add a new string 2 when strings 1,2 and 3 already exist) then name the new string 1.1 (for 

this example) and then use the Strings=>User=>Set String Name by number command.

Flow direction:

It should be same as string direction if drawing uphill to downhill or opposite to string direction if 

drawing downstream to upstream. All of the strings in the model can have their direction changed 

later using the Design=>Drainage-Sewer=>More=>Reverse all strings command.To graphically 

check the flow direction of all strings see Flow in the Wrong Direction.

Design =>Drainage-Sewer =>Create

1. Type a string name (used for pit naming later).

2. Type a new model name for the network

3. LB the Colour icon and select colour (optional).

4. Leave unless drawing in uphill direction.

5. From the default, leave as is.

6. Existing tin can be used for long section dwg levels

7. Select if creating more than 1 string.

8. LB the Create button, the menu below will appear..
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The Create Drainage String panel will appear again for you to create additional drainage strings. 

5.9 Additional Notes for Junction Pits

Key Points

1. The branch line must Point Snap onto the centre of a pit on the trunk line.

2. All strings must be in the same model.

3. The downstream end of the string (depends on flow direction) must join onto the trunk line.

We are going to place our manholes on the back of kerb near the vertices of the 

layout that we imported. Name the eastern branch line 2, the west branch line 3 

and finally the trunk line running from east to west 1.. The drawing below 

shows the manhole names. You will not see these names as you draw the 

strings but we will create them later.

To create your first manhole on line 1, select 

1. Edits =>Append. A +MH will appear with your pointer.

2. LB and accept each manhole location starting at 1-1.

3. LB the Finish button after the last manhole is placed (1-4).

1. Begin creating line 2 in a similar fashion and place the manhole 2-1.

2. To connect to line 1, a point snap is required to the centre of manhole 1-2. This creates a junc-

tion pit.

3. LB the Finish button after the junction manhole is placed.

4. Repeat for line 3.
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Trunk drainage lines are created the same way as the branch lines except special care must be used 

when placing the junction pits. When placing the junction pit on top of the branch line turn the point 

snap on and the line snap off (the F3 and F4 keys are convenient for this). Zoom into the branch line 

junction pit so that you can snap onto the centre of the pit. 

A pit contains three points; one at each point where the pipes join (invert level points) and the one 

you want to snap onto at the centre of the pit (setout level point). In the figure below, the blue line is 

being placed to join the magenta line. Note that the diamond indicates that there is a point snap and 

the information panel indicates that we are snapping to line 2. The information panel also indicates 

the snap was a point snap.

You can tell that you have created a junction pit correctly when you profile the trunk line and you can 

see the branch lines joining at the junction pit. If the branch lines are not shown then one of three 

things have gone wrong.

1) centre of the pits did not align, Use Strings=>Points Edit=>Move to move the branch string 

pit

2) the “downstream end” of the branch line must be the junction pit. With the direction of flow for 

the string set to “same as string direction” the junction pit must be at the high chainage end of 

the string. If the direction of flow for the string set to “opposite to string direction” the junc-

tion pit must be at the low chainage end of the string. To check the flow direction see Flow in 

the Wrong Direction.

3) The branch string and the trunk string have not been created in the same drainage model. From 

the main menu select Strings->Inquire (F2) and select the strings to check their models. If this 

is the problem, use Strings=>Edit=>Change and specify the correct drainage model (enter the 

model BEFORE picking the string) or Strings=>Edit=>Duplicate to duplicate one of the 

strings into the correct model.

5.10 Exact Methods for Placing Pits

To place your pits on a kerb line string, turn the line snap on and the point snap off,. Keep the 

height snap off.

For locating pits at specific x, y coordinates, simply start typing the x coordinate instead of clicking 

onto a location. An input panel will appear for you to enter the x and y coordinate separated by a 

space.
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To place the pits at a specified distance from a point use the RB and select 

Snaps Cad=>Points=>Locate Offset. Follow the prompts given in the message area (bottom left 

corner of the screen). You will need experience with the 12d “directional pick” to use this capabil-

ity.

5.11 Flow in the Wrong Direction

The direction of flow is used by 12d to determine where the outlet is on the drainage line.

5.12 Drainage Section Views (downhill left to right OR right to left)

The long section views and the profile plots are running downhill from left to right. If you want 

them downhill from right to left use the reverse function.

To reverse only one string, from the main menu select

Strings =>Strings Edit =>Reverse

and pick the drainage strings to reverse. This will also change the drainage flow direction attribute 

from same as string direction to opposite to string direction. 

The direction of flow will be indicated with the arrow on the manhole when using the 

Drainage Network Editor. No arrow will appear if the outlet is selected. If you find the 

arrow is pointing in the wrong direction use the Strings->Properties->String option from 

the main menu. Select the string and then change the Flow direction value to the other 

value.
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To reverse all of the strings in a model select the Reverse all strings option,

Design =>Drainage-Sewer =>More=>Reverse all strings

5.13 Moving, Adding and Deleting Pits

The best way to edit the plan layout of the drainage is via the Strings->Points Edit commands.

The Append, Between, Delete, Insert and 

Move commands are the most common.

The Move command has an extra option for 

moving junction pits. Selecting All points with 

the same coordinate will move all points on the 

view that are at the same x,y coordinate. The 

point selected will move first and the others will 

follow after the new location has been accepted.
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5.14 Drainage Split and Join

To change the pipe route between the pits use the String split/join from the Drainage menu not 

the one on the Strings->Strings edit.

Split Option

Join Option

The spit must be done at a pit.

1. Type a new name for the upstream string (optional).

2. Type a new name for the downstream string 

(optional).

3. LB the Split button and then select the pit where the 

split is to occur.

This routine will add a new pipe between the 2 

strings if required. The properties and attributes of 

the new joined string (and the new pit at the join) will 

come from the upstream string if Join US to DS is 

selected. Join DS to US will cause the properties and 

attributes to come from the ds string. Upstream and 

downstream is deternined by the flow direction.

1. Select either of the join option buttons.

2. Pick and accept the drainage strings in the order 

indicated on the option button (follow the mes-

sages in the 12d message area).
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6.0 Drainage Network Editor

The drainage network editor is used to automatically or manually change the attributes of your drain-

age network. These abilities include:

General

s Changing the vertical alignment of the network

s Setting pit names

s Service Clash Checking

Hydrology

s Catchment Areas

s Checking the Automatic Catchment Linking

s Global and Defaults Tab for C values and Tc calcs

s Drainage Templates

s Bypass flow routes

Hydraulics

s Grate Levels

s Outlet and Tailwater Conditions

The drainage network editor is accessed through the main menu by selecting

The bottom section of the network editor panel is shown below. You can change tabs but no data can 

be entered in the panel until a drainage pit or pipe has been selected.

The pit that was selected is highlighted with a circle and an arrow shows the direction of flow (see 

image below). The option buttons on the drainage editor now become active.

Design=>Drainage-Sewer=>Network Editor

1. Pick and accept a drainage string and the network will be loaded into the panel.
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6.1 Moving through the Drainage Network

There are 3 ways to change pits in the network editor. Non of these methods will work if you are 

on the Defaults or Global tabs. If the editor finds an error on a pit, it will take you to the error and 

you must correct the error before moving to the next pit.

Try all 3.

6.2 Auto-Apply, Auto-Pan, Auto-Profile and Auto-Redraw

With Auto-Apply (A) enabled, the Apply button need not be selected after making changes in the 

editor settings.

Auto-Pan is always on and any plan view showing active drainage network selected will always 

auto pan if the selected pit is not in the view. With the Auto-Profile (P) enabled, the same will 

happen for the section view. The image below has the auto profile turned off (note the blue trim 

on the P button).

1. Pick Edit Button - Pick and pit or pipe in section or plan view

2. GoTo List - Select the pit from a list of pit name

3. Next and Previous Buttons - loop through all of the pits in the network
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With Auto-Redraw (R) enabled, the editor will regenerate the section view when changes are made 

in the vertical. This saves selecting Regen on the section views.

6.3 Set Pit Details

Selecting Set Pit Details will set the cover levels and setout coordinates for all of the pits in the net-

work. Other attributes are set as well but they will be discussed later.

6.4 Regrade Pipes

Selecting the Regrade Pipes button regrades all of the pipe in the network. Minimum grade and 

cover are checked and trunk lines are lowered to accept incoming branch lines. Grade is calculated 

using the pit centre to centre distance. Locks and explicit settings for pit and pipes will be discussed 

later in these notes.

To inquire about the cover on a pipe use the following option.

6.5 Set Pit names (and pipes)

Use the drainage network editor to manually change explicit ones or quickly change all the names 

using a different naming method. 

The pit names are based on the string names so make sure the string names are set. To view string 

names on the plan view, go to the Plan View tool bar and select Toggle=>Names. If they do not 

Tins->Inquire->Depth from string

1. LB to select the tin

2. LB to select the 

string.

3. Move the pointer in 

plan or section to 

monitor the data.
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appear see Displaying View Text. 

6.6 Set Pit Names using Pit Type

Currently all of the pits have the default pit type. To exclude the outlet headwall from the number-

ing we can change its type to HW and then set the pit names again.

The string names may be 

changed in the String field.

Pit names may be changed 

in the Pit field.

1. Select Set Pit Names and the following panel will appear.

1. Select Sequential Numbering to 

number the manholes starting at 

First Pit Number.

2. Change the Default naming parame-

ters. 

Map pit numbers to letters causes 

the first pit to be A instead of 1.

Min digits in pit numbers set to 2 

causes 1 to be 01.

3. Run will update the quick text pit 

names on the plan view.

Try other settings!

You may find you want to change 

some of the string names back in the 

network editor.

4. Back to the Editor return to the 

main editor panel.
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1. Move to the outlet using any of the 3 methods.

2. On the pit tab change the type to HW.

1. Move to the outlet 

using any of the 3 

methods.

2. Change the pit type 

to HW

3. LB Select Pit 

Names

1. Type the file name for the pit 

selection scheme.

2. LB the folder icon and select 

Open.
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1. RB to select the Pit type

2. Type the Pre text

3. LB Write to save the settings to the file.

4. LB Finish to return to the panel.

1. Type Pre text for those not 

included in the pit naming file.

2. LB Run to name the pits

3. LB Back to Editor to return to the 

main panel.

Note that the headwall still get the 

sequential numbering continued from 

the last numbering method. To start 

at a new number the Sub sequence 

group number would have to be 

included in the file.
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6.6.1 Trouble Shooting Displaying View Text

After you have named the pits in your network, the names should appear beside each pit in plan. If 

they do not appear then some 12d settings have been changed.

You can change the text size for each string by selecting Strings->Editor and then pick-accept the 

drainage string. The text size is set from the selection Utilities->Size.

The offset from the pit is set by selecting Strings->Properties->Strings, picking the drainage string 

and setting the values for Delta x, and Delta y.

Note: Auto pit names are NOT shown in the section view.

Trouble shooting auto pit names not being displayed

Problem: Plan text is toggled off

Solution: select Toggle on the plan view title area 

Problem: Small text is turned off

Solution: select the Menu button on the plan view title area and select Settings 

=>Text => Text

 - if these values are too large the text will not appear on the screen. Either 

decrease these values or increase the text size.

Check that the Text is toggles on. If it is on then walk right and ensure the 

text is turned on or n/a for your drainage network.
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Problem: string text size is 0

Solution: Each drainage line can have its own size of the text. To change it, select 

Strings=>Editor then pick-accept the drainage string. The text size is set 

from the selection Utilities=>Size. If this is set to zero the labels are not 

drawn.

6.7 Labelling the Pits and Pipes

To label the pits and the pipes use Drainage Plan Annotations. This may be accessed from one of 

three locations. 

Location 1: From the plan toolbar

Note (The following panel has been reduced in size).

Select drop down and change to full

Quick threshold and None threshold if these values are too 

large the text will not appear on the screen. Either decrease 

these values or increase the text size.

Select the plot button and 

then Drainage plan
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Location 2: The Plot Button on the Drainage Network Editor

The following panel will be displayed.

Select your 

drainage 

model

Enter a model 

name for the 

new labels

Select Plot

Now add the 

drainage 

labels model 

onto the plan 

view.

This option can plot both the long section 

and plan at the same time. Select a ppf 

file from the library (drainage_design).

Enter a model for the plan annotations.

Select Full clean model beforehand if 

you have not manually moved any of 

your manhole labels.

Turn off the long section plot for now.

Select Plot.

Now add the Model for plan annota-

tions onto the plan view.

Note: if you rename the manholes you 

will need to replot these labels!
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The text properties can all be customised using the plot parameter file but this will be discussed 

later in the plotting section. These labels are not automatically updated when you change the 

names or pipe diameters. You must rerun the plot routine to update the labels.

6.7.1 Turn off View Text Pit Labels

To turn off the automatic view text pit labels for this view select Toggle=>Text and then walk 

right to select the drainage model. Do not click on Text, rather walk right. If you click Text you 

will toggle on/off all of your text on the view, not just the drainage model.
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6.7.2 Moving Text

The labels created may be manually moved using the CAD toolbar but if the model is relabelled the 

text will return to its original location! Text moved via the Drafting->Multi string translate will 

remain in the moved position when Smart Clean is selected in the Plan Annotation panel.

To move a pre-defined Group of text select

Drafting->Multi string translate

6.8 Catchment Areas

Key Points

1. You can enter the catchment area manually (ha or acres) and have no drainage string.

2. When drawing catchment polygons, start near the inlet for auto linking.

3. 3 catchment sets are available and all catchment polygons must be in these models.

4. Specify catchment models via Network Editor->Global->Utility Models Catchment file.

Before selecting text turn on your teXt snap.

To move a single line a text use the CAD 

toolbar. Select the Move text justify but-

ton. To use this toolbar you must DRAG 

the Create text button to the right 

and then release when the pointer is on the 

Move Text Justify Point.

Select Group and then pick and accept one of the 

text items in the group. Move it to its new location 

and accept.

Note: To move another group you must select the 

Group button again.
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5. Network Editor Set Catchment button links the polygons and calculates the areas

6. Once a string has been linked to a inlet, it will remmain linked until it is deleted or the link has 

been cleared (Clear Catchment Links on the Globals->Utility Models tab).

7. Manual linking available via Network Editor->Catchments->Pick button.

8. Manholes (set via cap_config in drainage.4d or Inlet config on the Pit->Main tab cannot have 

linked catchments.

9. Use the CAD polygon tool for drawing catchments OR close the string for SAG pits

10.You may fill the strings using “Utilities->Super strings->Fills”

11.You can disable the auto selection of a string via Right mouse on the pick button then select 

Clear.

The catchment strings may be drawn in a CAD package and then imported into 12d or drawn 

inside 12d. The strings may be easily drawn in 12d with the tin contours and/or flow arrows dis-

played in the plan view.

When a catchment string is created to define the area for an inlet then all other data entry types 

will be ignored and the area from the string will be used.

There are 3 sets of catchments and it is up to the user to decide how they are to be used (roads, lots 

and park land for example). Often set 1 will be all the impervious areas and set 2 the pervious and 

set 3 for special areas. Each set has its own percent impervious. The 3 catchment sets are drawn in 

three different models.

If exporting to external drainage design programs, the package may not accept all three sets so 

check the interface notes before defining the catchments.

Set Catchments - Auto Linking

In each set/model, 12d will automatically link the catchment string to the inlet that is closest to the 

first point on your catchment string. This is the preferred method. If this is not possible, then an 

inlet may be manually linked to a catchment string using the Catchment manual link.

Linking Rules

1. If an area is typed in before Set Catchments is selected, a catchment string will not be linked to 

this inlet-catchment set. Erase the typed input if you want a link to occur.

2. Strings will link to the inlet closest it’s vertex 1.

3. If more than one string trys to link to an inlet, the closest vertex 1 point will be linked.

4. If an inlet has a string linked and a new string is drawn with a closer vertex 1, the new string 

will NOT replay the old string. Use the manual pick or Network Editor->Global->Utility Mod-

els Clear Catchment Links to start new.

Also see Checking the Automatic Catchment Linking

Drawing Catchment Strings in 12d

Before creating the catchment string set the CAD control bar data.
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Now to create the catchment string use the Create line string button on the CAD toolbar. 

There is no need to go “overboard” with the accuracy of the catchment strings (except maybe with 

SAG pit catchments near the low points). From experience, it is more important to spend time verify-

ing catchments in the field than spending a lot of time getting them “exactly” placed on the catch-

ment plan. If you want to use the drawing as a catchment plan submission then the extra care in 

creating the strings may be warranted. Continue selecting and accepting the points on the catchment 

string and the press ESC to finish creating this string. You are now ready to create the next catch-

ment string.

SAG inlet catchments: DO NOT START AT THE INLET, just start nearer to this inlet than 

any other! If you start at the inlet then move out to the crest of the catchment, the catchment over-

flow level cannot be determined from the catchment string.

Once the catchments are drawn they become linked to the drainage network in the Drainage net-

work editor. We will label the catchment with the inlet name and area at the same time.

Start the Drainage network editor and move to the Global Tab and then the Utility Models sub tab.

Solid Translucent Fill for the Catchment Areas

Super strings may have a translucent fill add to them so that you can see if areas have been missed or 

if they overlap.

From the main menu select

Type the name of a model for the catchment strings

DRAG the Create line button and release at 

the Create Line String button.

The first point should always be placed near 

the inlet. 12d will assume that the catchment 

will drain to the inlet closest to this first point.

Utilities=>Super strings=>Fills
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1. Select the catchment model.

2. Change the action to Set.

3. Select a colour for the catchments.

4. Type a blending value between 0 and 1 

(1 is opaque).

5. LB the replace option.

6. LB Change.

7. LB Finish

Note that the edges are no longer visible. 

Adding the edges to the fills

To view the edges go to the View Menu button and 

select Settings->Faces

1. LB Draw Edges

2. LB Set

3. LB Finish
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Every inlet can have 3 catchments, row 1 is catchment set 1, row2 for catchment set 2 and row 3 for 

catchment set 3. 

The Auto-rename catchment polygons will set the name of the catchment string to the pit name 

that it is linked to. If it is not linked to any inlet it will be named “not used”. The model can be 

checked for not used strings by selecting Models->String Info Table.

To label the catchment areas with the names of the inlets they are linked to we need a catchment 

labels model and a textstyle favourite. We need to create a label textstyle favourite if you do not have 

any favourites defined.

Enter a 

filename 

for the 

catch-

ment file.

Select 

More 

info but-

ton.

Select 

Open.

RB click 

to select 

the model 

of the 

catch-

ments 

used in 

the CAD 

control 

bar 

above.
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Select the textstyle button and then the drop down for Favourites. Now select Edit.

Select Set to store the textstyle favourite for this session only. To permanently save this text-

style favourite and have access to it in all of your projects select Write and the following 

Enter the data as show. Some data you will have to type on the keyboard (type) and other 

you may use the right mouse button (RB) and then select browse.

Type RB RBTypeRBType RB
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Label Catchments

Select the User folder.

Select Write to save the favourite to the 

User folder.

If you are in a network environment and 

want to see if you have write access to 

this files select the Properties button.

Finally select Set catch-

ments. This will link the 

catchments to the inlets and 

label the catchments. Now 

add the model labels onto the 

plan view.
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There are some cases where linking the closest inlet to vertex 1 is not feasible. In these cases you 

may manually link the inlet to a catchment.

Catchment manual link

The manual links are used when the first point on the catchment string is closest to the wrong 

inlet. Note that the following restrictions still apply.

1. The string selected for catchment 1 must be in the model for set 1. To check if you have 

selected a valid string select the Set Catchments button.

2. If the catchment string has already been linked to another inlet (automatic or manual) then the 

new link will be created and the old link erased.

3. If you change the catchment model for one of the sets on the Network Editor->Global->Util-

ity Models->catchments than all of the manual links in that set will be erased.
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Checking the Automatic Catchment Linking

The automatic inlet-catchment linking is easily checked by specifying a Catchment labels model 

with Labels textstyle on the Global->Utility models tab and selecting the Set Catchments button 

on the network editor. Also once the Set Catchments has been selected, the catchment is indicated 

when the inlet is selected using the network editor. Since there may be three catchments per inlet the 

catchment data last viewed in the editor is the catchment that is highlighted.

Finally, as mentioned above, the Auto-rename catchment polygons on the Global->Utility Models 

tab will set the name of the catchment string to the pit name that it is linked to. If it is not linked to 

any inlet, it will be named “not used”. The model can be checked for not used strings by selecting 

Models->String Info Table.

First change to the Catch-

ment tab.Move to the desired 

inlet. The inlet will be circled 

in the plan view and its name 

shown in the Current Pit 

field.

Now select the Catchment 

polygon button and pick the 

desired catchment string.

NOTE! If you decide to enter 

a value and NOT use the 

selected string RB on the but-

ton and select Clear.

If the Auto apply tick box is 

not selected then you will 

have to select the Apply but-

ton for the manual link to 

become active.

After the Set Catchment but-

ton is selected the measured 

catchment area will be shown 

in the Catchment area field 

using the units specified in 

the Global-Utility models-

Units field.
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Reseting All Catchment links to Start Over

6.9 Network Editor - Global, Default Settings and Explicit Settings

Design values for the hydrology and hydraulics calculations are set either globally (one value for 

the entire network) or via Defaults for the pits or pipes. Defaults values may be overridden by 

explicit settings found on the catchment, pits or pipes tab. Explicit pit/pipe settings need only be 

specified if the default value is not desired.

6.10 Network Editor - Hydrology

The network editor edits both the network and catchment data and it has already been introduced 

in the previous sections. This section will discuss the Global, Defaults and explicit setting for 

the hydrology parameters. The parameters described on the defaults tab will also be found on the 

Catchment or Pit tabs.

6.10.1 Catchment Areas

The catchment areas have already been discussed in the previous section. There is no default 

catchment area to apply to all catchments (as would be expected).

Note! If a catchment string is linked to the pit and the Set catchments button is 

selected, this string area will override any manual value that you type into the drain-

There may be occa-

tions where you will 

want to clear all of the 

catchment links and 

begin with a fresh 

start. Select Clear 

Catchment Links on 

Network Editor-

>Global->Utility 

Models.
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age area field. To ensure manual entry is maintained, RB select the string selection but-

ton and select Clear.

6.10.2 Coefficients of Runoff

Global Settings

Runoff C methods 

include Direct and ARR 

1987. For the ARR 

1987.

Direct: There is a global 

impervious C value for 

both the minor and major 

storms.

ARR 1987: The com-

posite C value is calcu-

lated using the 1hr-10yr 

intensity, the percent 

impervious, ARR fre-

quency factors and the 

return period specified 

when hydrology runs are 

made. No C values are 

entered if this method is 

used!
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Default Settings

The Direct method has 

both defaults and 

explicit settings on 

Catchment tabs (see 

below).
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Explicit Settings

6.10.3 Percent Impervious

The default percent impervious for the network is set on the Defaults->Catchment Defaults tab and 

the explicit settings are on the Catchment tab (see above). The percent impervious is used to deter-

mine the area for the impervious and pervious components and the composite C value if using the 

ARR 1987 method for calculating runoff coefficients.

6.10.4 Times of Concentration

There are several methods for entering times of concentration for the catchment areas (see list 

below). Default and explicit settings (catchment tabs) are entered/calculated for both the methods 

and values for the pervious and impervious areas. Since each catchment may use a different tc 

method, all of the tc parameter fields on the defaults tab are active. They must be filled in even if you 

do not plan on using that value.

Explicit settings over ride 

the default settings for the 

catchment selected. If the 

explicit fields are blank 

then the default values 

are being used.
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1. Direct method requires minor and major tc values.

2. Friend, Kinematic Wave, Bransby Williams and QDUM methods require the retardance, 

length and slope of the catchments to be entered. Default values must be entered but the 

optional explicit settings for slope and length can be entered on the catchment tabs or a catch-

ment characteristic strings may be drawn (see Catchment Tc path strings). The length of this 

string is used for the length parameter and the design tin is used with the string to calculate the 

slope using the equal area method.

3. Data for the remaining methods is entered in a similar fashion.

6.11 Tc Path Strings

These strings are used to calculate the time of concentration for the impervious and pervious 

areas. For each catchment set, they are drawn in two models; one for the impervious paths and 

one for pervious paths. The models are specified using the Catchment file field on the network 

editor (Global->Utility model tab). The 3 rows in the catchment file correspond to the 3 catch-

ments available for each inlet. Therefore it is possible to have a maximum of 6 Tc paths models!

Key Points

1. Each Catchment set may have 2 Tc paths models. Pervious and impervious paths are kept in 

separate models.

2. End the Tc path string near the inlet that it is to be linked to.

3. Enter the paths models via Catchment file field on the network editor (Global->Utility 

model tab)

4. You must select a Tc method (explicit or implicit) via the Defaults->Catchments tab or the 

Catchments Tabs. Just specifying the models is NOT enough!
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5. Select Set Catchments to perform the calculations of length and slope.

The tc strings can be drawn in the same way as the catchment strings but make sure that you change 

the model name first! The tc string model is then entered in either the impervious or pervious paths 

model columns (You could have up to 6 tc string models!).

6.11.1 Catchment slope (equal area)

The length of this string is used for the length parameter and the design tin is used with the string to 

calculate the slope using the equal area method. These strings are drawn from upstream to down-

stream, finishing nearest to the inlet they are to be linked to.
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The equal area slope is calculated when Set Catchments is selected. After the export the slope 

string, it may be profiled to see the slope (see below).

6.12 Network Editor - Hydraulics

This section will discuss the hydraulic Global, Defaults and explicit settings for the hydraulic 

parameters. The explicit settings for the parameters described on the defaults tab will also be 

found on the Pit or Pipe tabs.
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6.12.1 Cover RL mode, Grate RL mode and Sump offset

Both Cover RL and Grate RL modes has the same options with the exception that the Grate RL 

mode can be set to the Cover RL model so that both always have the same level.

The Sump offset creates a sump below the lowest pipe invert connecting to the pit. It is generally 

zero or negative.

6.12.2 Pit Losses Ku, and Direct Flow

The Pit loss Ku is used to model the energy losses through the pits. Three methods are available, 

Direct (user entered), Ku,Kw via charts (may be negative), or Ku,Kw >0 via charts where all neg-

ative values are changed to zero.

The cover level is used 

for the top of the man-

hole structure and is used 

in the long section plot-

ting. It should not be 

confused with the grate 

rl mode or the Setout Z 

mode.

The grate level is set via the Grate rl mode.This level is used by 12d when 

determining the freeboard level and when calculating depth of flooding at 

SAG pits. The grate level is often exported to other design packages. 

Most Grate RL modes need no explanation. The Sz + Setout string is a good 

option when the grate level is a constant offset from the setout string.

The Direct flow (cms/cfs) 

is water flowing into the 

manhole. It is added to the 

approach flow and is sub-

ject to pit inlet capacity. 

This field will be disabled 

if the inlet type is set to a 

manhole.
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Ku config has 4 options: Preferred, Good, Fair and Poor. The settings have no effect for 100% 

grate flow, straight through and 90° bends. For pipes with bends they determine the charts to use. 

The following are guidelines in selecting the Ku config.

Preferred water impacts the opposite wall where it exits

Good water impacts the side wall where it exits

Fair water impacts the side wall and exits on the end

Poor water impacts the opposite wall of the pit and exits on the side wall.

Introduction to 12d Ku/Kw Calculations

The following description is a very general overview of the Ku calculations in 12d. For a detailed 

description please see the 12d forum site http://forums.12dmodel.com/.

When 12d uses the Ku and Kw Charts, the values of upstream pipe angle, (Qgrate/Qoutlet),

(Upstream diameter/outlet diameter) and (pit depth/outlet diameter) are calculated and used in the 

Ku/Kw charts. Three cases exist which determine which chart is used.

Case 1 - Pits with 100% Grate Flow

The angle between the ground approach flow and the exit pipe is measured. Charts, compiled 

from Sangster et al (1958) are used; G1 is used for angles less than 15 degrees (rare) and G2 for 

angles > 15 degrees. 12d’s names G1 and G2 can be referenced to other publications in the table 

below.

Case 2 - Pits with More than 50% Through Flow

12d has 10 charts (T1-T10) compiled from the Hare (1981) and cross referenced to the QUDM 

and ACTDS Charts. In general T10 charts have greater losses than T1 charts.

12d Chart Cross References

Case 3 - Pits with between 0 and 50% Through Flow

With the flow condition between grate flow and through flow, a K value interpolation is per-

formed based on the percentage through flow.

Ku Config 0° 22.5° 45° 67.5° 90°
Preferred T1 T2 T4 T8 T10

Good T1 T2 T5 T8 T10
Fair T1 T3 T6 T9 T10
Poor T1 T3 T7 T9 T10

12d Pit Config G1 G2 T1 T2 T3 T4 T5 T6 T7 T8 T9 T10

QUDM Ku Chart # 32 32 33 34 35 37 37 38 40 42 44 46

QUDM Kw Chart # 32 32 33 34 36 37 37 39 41 43 45 47

ACTDS Ku Chart # 1 1 2 13 14 10 9 16 18 20 22 7

ACTDS Kw Chart # 1 1 2 13 15 10 9 17 19 21 23 8

ACTDS Pit Type # 1 2 3 11 12 8 7 13 14 15 16 6
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6.12.3 Pipe Friction Method, Roughness Values and Direct pipe flow

Direct pipe flow is flow at the upstream end of the pipe that is included in the pipe flow calculations 

but is not included in the upstream pit losses nor restricted by the pits inlet capacity.

6.12.4 Design mode, Freeboard Limit and Flow-depth limit

The default friction loss 

method and pipe rough-

ness method areset here 

(Colebrook or Man-

ning).

The ranges for pipe peak 

velocities are used for 

checking purposes only. 

If the velocities are out-

side this range, warning 

messages will be given in 

the output window.

The Design mode has 4 

options.

Pressurised Pipe: Free-

board Design does not 

use partial depths in the 

pipes and pipe sizes 

selected by checking the 

pit freeboard.

Part-full Pipe: Free-

board Design is similar 

to option 1 except grad-

ual varied flow and 

hydraulic jumps are cal-

culated in the pipes. 

Critical depth is the min-

imum depth at the 

upstream end of the 

pipe.
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Part-full Pipe: Flow-depth Design is the similar to option 2 except the pipe sizes are selected by 

checking the normal depth in the pipe against the Flow-depth limit. Freeboard is also checked in 

this mode and if required the pipe will increase in size.

Open Channel: Freeboard Design is similar to option 2 except depths at the upstream end of the 

pipe may be less than critical depth for steep pipes (supercritical flow at the entrance).

The Freeboard limit is used for all Design modes. The freeboard is measured down from the 

grate level (Cover RL plus Grate offset).

The Flow-depth limit at pipe entrance (%) is used in Design mode 3. If the flow depth in the 

pipe is greater than this value the pipe size is increased.

6.12.5 Outlet and Tailwater Conditions

The most downstream pit on each network requires tailwater conditions. Often the invert level on 

the downstream end of the last pipe also needs to have the invert level locked to either discharge 

into a waterway or join into an existing drainage system. When the most downstream pit is 

selected the following fields will become active on the Network Editor - Pit - Main tab. If these 

field are not active and you think you are at the outlet see Flow in the Wrong Direction.

6.13 Pipe Design Parameters - Sizes, Invert alignment, Min Cover, Max Height

The invert levels during design are controlled by the pipe sizes, max pipe height, min pipe cover 

and invert alignment mode.

Minimum will use the 

least of the Critical or 

Normal depths. If a fixed 

level is available for the 

minor and/or major 

storms, these value may 

be entered here.

The Ko is the loss coefi-

cient for the exit losses 

into the downstream sys-

tem.
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6.13.1 Invert Alignment Modes

NOTE! Invert design parameters are set on the Pipe-Design tab not the Pit tab. The Alignment 

mode refers to the DOWNSTREAM INVERT ONLY.

1. The initial pipe grade is set as the Minimum grade (Minimum Grade mode) or the grade 

between the ground levels at the pits (Minimum Depth mode). Even in the Minimum depth 

mode the minimum grade constraint is checked.

2. 12d shifts the pipe down so that there is at least the Pipe cover limit along the pipe. The Pipe 

cover limit should include an amount for the pipe thickness.

3. Inverts are moved down if required according to the setting in Align mode. 

Obverts are aligned using OL-OL Drop  with a zero drop in the Drop file. Similarly the inverts 

are aligned with the IL-IL Drop mode. Min drop ensure that the inverts drop a minimum of the 

specified drop in the file but the drop may well be more than the Alignment drop specified. As 

the inverts are moved down the minimum pipe grade is maintained.

NOTE! If Obvert Drop is selected and the downstream pipe is a smaller pipe then the inverts 

will be aligned!

12d has 4 design modes 

for setting the pipe inverts 

upstream and down-

stream of the manholes. 

These work together with 

the 2 pipe cover modes as 

follows. 

The tin specified in the 

Global-Main Finished 

Surface Tin field is used 

for these calculations. The 

description below 

assumes that none of the 

inverts have been manu-

ally locked.
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6.13.2 Pipe sizes, Max pipe height and Multiple Pipes and Box Culverts

The 12d design engine will select pipe sizes from the file specified on the Drainage Network 

Design panel, Preferred pipes file field list. See selecting pipe sizes. However, the maximum 

pipe height allowed before multiple pipes are used and the selection of box culverts is set on the 

pipe->main and pipe >design tabs respectively.

The Drop file contains the drops that change 

with the pipe deflection angle. A sample file is 

included in the library.

If only one drop value is to be used set the 

deflection angle to 180 degrees.

#Pipes specifies the 

number of identical pipes. 

The pipe flow is divided 

by this value when calcu-

lating losses.

To specify a box culvert 

in your network, select 

the pipe segment and 

enter a width for the pipe.
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For box culverts, the design engine increases the widths and maintains the height through the availa-

ble sizes. Once the maximum height has been reached, the next culvert height and minimum width is 

checked.

6.13.3 Pipe Size Design

6.14 Road Design File for Pit Setout - x,y, level, road chainage and setout offset

The road design file is used to automatically link the pit to a road setout string and a road centre line 

string. Explicit picking of these strings may be found on Pits->Setout->String selection. These 

strings may be used calculate road grades and crossfalls (bypass model required) and/or construction 

setout data.

The construction setout point defines the location on the pit to be printed in the pit schedules, plot-

ted on the plan annotations or listed on the drainage long sections. The setout point and level can 

be set to the centre of the pit or it can be linked to a road design string. The cover rl plus the Grate 

offset determines the grate level for surcharging calculations.

The centre of the pit or setout point can also be dropped perpendicular onto the road centre line to 

obtain the road chainage and offset distance.

Key Points in Using Setout Strings

1. Enter the road models and the strings names (identifies) via the Network Editor->Global-Utility 

Models tab, Road design file.

On the Pipe->Design tab 

the Lock Pipe size pre-

vents the 12d design 

engine from resizing the 

pipe. 

Max pipe height can be 

set for each pipe segment 

(there is no default for 

this value). If the 12d 

design engine requires a 

larger pipe, then multiple 

pipes will be selected.
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2. Specify how these strings are to be used. On the Defaults->Pits-Setout data area or Pits-

>Setout tab. 

Select Setout string for the XY or Z setout modes .

Select centre string for Road ch mode to calculate road chainages and offsets.

3. Select the Set Pit Details button.

4. Once a string has been linked to a pit, it will remmain linked until it is deleted or the link has 

been cleared (Clear Road Links on the Globals->Utility Models tab).

5. Manual string selection is available on the Pit->Setout tab.

Setout xy mode - Pit 

centre is the centre 

point of the manhole 

(the intersection of the 

joining pipes). Often the 

setout point for a man-

hole or catch basin is not 

the centre of the man-

hole but rather a point 

on the kerb or back on 

the foot path. The setout 

string option will drop 

the centre point of the 

manhole onto the closest 

string in the Road 

design model list speci-

fied on the Global-

>Utility models tab. 

Setout z mode options 

are listed in the panel. 

This levels are used in 

the pit schedules.
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IMPORTANT! If no ID is entered then this model will NOT be searched! 

The Centre string ID is used in the same way to find the centre line string. If needed, this string is 

used for road chainage and to determine which direction to measure the crossfall (between the setout 

string and the centre string).

The distances and searches are optional. The setout and centre search distances are the maximum 

distance that the routine will look when trying to locate the setout and centre line strings respectively. 

The grade offset it the distance upstream from the setout point that the road grade measurement will 

start and the Xfall offset is the distance from the setout point to the start of the crossfall measure-

Type a file name, select 

the folder icon and then 

select Open from the drop 

down

The following editor will 

appear.

RB select this 

box and 

choose the 

models con-

taining the 

setout strings. 

In the Setout 

string ID box 

enter the string 

name prefix 

(wild card * 

allowed) to 

limit the selec-

tion for setout 

string.
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ment. The measurements will be taken over a distance of slope measurement distance with the 

actual levels taken from the finished surface tin specified on the Global-Main tab.

Repeat this for each road string model used in the design. Remember to select Write when fin-

ished!

Select the Set Pit Details button on the bottom of the panel the calculate these values.

Explicit settings for the setout strings and the auto calculated values are found on the Pit-Setout 

tab. If the manual mode is selected the Easting and Northing locations may be picked in plan 

view or typed into the input boxes.

The setout level defines the level of the pit to be printed in the pit setout tables and in the drainage 

longsection plots. The FS Tin selection obtains the level from the FS tin, specified on the Global-

Main tab, at the centre point of the pit.The Setout String location obtains the z level from the 

setout string as described in the section above. Explicit settings and the auto calculated value are 

found on the Pit-Setout tab.

If Road chainage mode is set to Centre string, then the Centre String ID in the Road design 

file (shown above) is used to select the road string to measure the chainage and offset from. The 

values and explicit settings for the road chainage and offset are found on the Pit->Setout tab.

6.15 Calculate Bypass flow routes

This option is required for pit inlet capacity calculations and is covered in the Drainage Part 2 

training.

As an introduction, the bypass strings determine the downstream bypass inlet for each inlet. Inlet 

capacity is determined from commands in the drainage.4d file. Road grade and crossfall measure-

ments require the inlet to be linked to a setout string and pond depth measurements require a link 

to catchment string.
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7.0 Service and Utility Clashes

We will import some services from a 12da file. From the main menu select,

WARNING!

12d service clash routines notify the user of crossing services but not parallel services that are close 

to each other. To view parallel services, add the services model onto a section view, profile a drain-

age string and then set the corridor value for the section view.

File I/O->Data Input->12da/4da data

1. LB the Folder icon

2. Select the service filee

3. LB the Read button.

4. LB the Finish button.

5. Add the model services onto the plan and 

section views.
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Settings->Corridor and 

then set the Width left and 

Width Right to the desired 

clearance. If the service can 

be seen then it is within the 

tolerance. 11 is used in this 

example only so that you 

can see the service on the 

other side of the road.

Use the Next and Prev but-

ton to switch drainage 

strings.

To obtain a report of all strings 

inside or crossing the drainage 

string profiled, select the View 

menu button then Utilities-

>Report
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To quickly move to the section view of the string, use the pit selection dropdown beside the pick but-

ton. With auto profile on the section view will update to this string.

The service clash 

model list is entered on 

the Global-Utilities 

Model field.

To create a list enter a 

list name, select the 

folder icon and then 

select Open.

In the Service model column RB to select the 

model. Enter Minimum Clearance for the serv-

ices in this model. Include an extra amount for 

the thickness of the drainage pipe. If different 

clearances are required for different services 

then place the services in different models. 

Warnings will be issued when you Regrade 

Pipes, Set Pit details, Import or Storm Analy-

sis. Cover levels or fixed inverts can be used to 

avoid the services.
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TIP: often changing the Grade mode to Min grade on a branch line will raise the downstream 

invert. This may allow the entire trunck line to rise and thus reduce excavation costs. This is espe-

cially true if the service clash is near the upstream end of the pipe.

Once the invert levels have been reset by selecting Regrade pipes, the output window will indi-

cate the final clearance.

After a pipe design run in Storm Analysis, details of the service clash data will again be listed in 

the output window.

The most common method 

to avoid the clash is to 

increase the Pipe cover 

limit for this pipe segment 

so that the pipe is pushed 

down. 

If the clash problem is 

above the pipe then the 

Max pipe height may be 

used and multiple pipes are 

selected.

This method is preferred 

over locking the inverts as 

this leaves more flexibility 

for aligning the inverts.
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8.0 Drainage Design in 12d Drainage Design

12d has a sophisticated rational method hydrology and hydraulic grade line pipe design engine. In 

addition it has the capability to export this data to several other popular drainage packages. Regard-

less of the design method selected the drainage network in 12d is updated from the design so that 

drainage plans, long sections and pit schedules can be quickly produced.

8.1 12d Rational Method Hydrology - Drainage Rainfall Editor

The Drainage Rainfall Editor is used to input rainfall IFD data using several methods. The data is 

stored in Meteorology files (each file is for a specific location) that can be shared between 12d 

projects. The data is edited using an editor similar to those used for the plot parameter files (ppf). 

Seven methods for entering/calculating the rainfall intensities are shown in the panel below. From 

the main menu select,

Design->Drainage-Sewer->Rainfall Editor

Data is entered using one (or more if desired) input methods and then saved by entering a Meteorol-

ogy file name and selecting Write. The standard 12d system file search paths are used (project 

folder, user library folder and then library folder).

8.1.1 IFD Tables

IFD tables are often available from meteorological services. The table input format follows. The first 

row is used to define up to 9 return periods and the following rows list the rainfall intensities for the 

duration entered in the first column.

Select the folder icon and then walk right on the Lib item to display a list of sample files. 

Select a file the select Read. YOU MUST SELECT THE READ BUTTON!
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Hint: to increase the size of the grid control select another method, ARR 1987 for example, 

and then select IFD table again.

8.1.2 Australian Rainfall and Runoff 1987 Method

The rainfall intensities and other factors from Volume 2 of ARR 1987 are entered in this table.



Revised 17 Sept 200712d Stormwater Design Course Notes - Part 1 Page 76 of 102

12d Solutions Pty Ltd

COURSE NOTES

STORMWATER DESIGN

8.1.3 Australian Rainfall and Runoff 1977 Method

The seven coefficients for each return period from ARR 1977 are entered in this table.
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8.2 Drainage Network Design

The Storm Analysis button on the Network Editor executes the 12d drainage design, plots the 

drainage long section and plan annotation and prepares the hydrology and hydraulic design tables. 

From the Drainage Net-

work Editor select 

Storm Analysis. The 

following design panel 

will appear.
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Storm Factors

The valid ARI will depend of the method selected but you cannot extrapolate beyond your data. 

Select the folder icon on the Rainfall location file and then walk right on the Lib line to select one 

of the rainfall files in the 12d library. If the file has only one type of rainfall definition then the Rain-

fall method field will be completed. Otherwise select the Rainfall method desired.

Storm event type determines which set of design values (minor or major) will be used for this run. 

Pipe travel time method should be set to the authorities requirements.

Enable the 12d rational method engine partial area calculations by selecting the Partial area effects 

box.

Network Design Factors

Modify Pipe Sizes

These values control the values to be designed in the run. Consider bypass flows causes the engine 

to use the bypass flow routes and inlet capacity data from the drainage.4d file.

Ensure Pipe Q < Qcap will increase the pipe size if this criteria is violated.
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Modify pipe inverts will allow the design engine to shift the inverts if required (usually pipe size 

changes).

If Modify pipe sizes is selected then a files containing the available pipe sizes must be supplied. 

The pipe sizes in this file are in the Units specified in the drainage network editor. To create a new 

file, enter the file name and then select the folder icon followed by the Edit line. The following 

panel will appear.

The Upsize only selection will stop pipes in the system from being reduced in the design. Regard-

less of this selection, the 12d design engine will not allow a smaller pipe to be selected in the 

downstream direction.

Pipe Sizes too Large?

A few comments on why you may have large pipes in your design. After cheking the design dis-

charge consider the following.

If one pipe is sized large then 12d will not allow a smaller pipe downstream. So when pipes seem 

large, check the most upstream large pipe. HGL restraints will require you to look downstream of 

the large pipe.

Check List

1.High roughness values, accidentally setting roughness to Manning with a 0.6 roughness 

value (Colebrook)!

2.Grate levels not set correctly. Freeboard is measured from these levels.

3.Pipe min pipe cover set very close to freeboard. 

4.Selecting [b]Ensure Q<Qcap[/b] in the storm analsys dialog. This is required by some 

authorities but can cause larger pipes in flat areas.

5.NOT selecting [b]Modify pipe sizes[/b]  in the storm analsys dialog. 12d will not change 

the pipe size.

6.Selecting [b]Only allow pipes to upsize[/b]  in the storm analsys dialog. 12d will not 

check if a smaller pipe will do.

The diameters/heights are required and the 

width is optional to specify a box culvert.

YOU MUST SELECT THE WRITE BUT-

TON!
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Generate Results in Plan

This selection automatically runs the drainage plot annotation function. A Drainage plan ppf must 

be entered and samples are supplied in the 12d library. A Model for plan results is required if this 

option is selected. The Full clean model before hand tick box forces the model to be cleaned before 

the labels are created. When not selected a “Smart clean” is performed.

Generate Results in Long Section

This selection automatically runs the drainage long section plotter. A Drainage long section ppf is 

required and examples are found in the 12d library. A Model stem for long section results is 

required if this option is selected. In almost all cases the Clean model before hand tick box should 

be selected.

Generate hydrology report

8.3 The Run Button and HGL data on the Section View

When the Run button is selected the discharges are calculated, the HGL check is performed and the 

pipes sizes and inverts are designed (if selected). The plan and long section drawings will also be 

The hydrology report may be 

formatted for inserting into a 

12d model/text editor (format-

ted) or spreadsheet (comma or 

tab delimited). In almost all 

cases Overwrite existing 

report file will be selected.
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updated with the new data (if selected). 

8.4 Importing Text into a 12d model

Formatted text may be inserted into a 12d model by selecting

Drafting->Text and Tables->Create edit paragraph text

The HGL values will also be available on the 12d section views when profiling the drain-

age strings. The colour of the HGL line may be changed via the view’s menu button then 

Settings->Drainage.
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Generate hydraulic report

Change to File.

Select the folder icon and then pick the formatted 

text file. It will be displayed then select Set. 

Next select the location in plan for the text.

The font selected must be a fixed space font or the 

data will not align properly.

Select the Font to display the following panel.

Enter a Text Model for the report.

The Text Style must be a fixed space font.

Select Set then Finish.

Now add the Text Model onto the 

The hydraulic report may be 

formatted for inserting into a 

12d model/text editor (format-

ted) or spreadsheet (comma or 

tab delimited). In almost all 

cases Overwrite existing 

report file will be selected.
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If you want both the hydrology and hydraulic report in the same file, enter the same file name in 

both file fields but turn of the Overwrite existing report file for the hydraulic report.

8.4.1 Design Results

Results from the design runs are shown in several forms:

1. Hydrology and hydraulic reports

2. Drainage plan annotations

3. Drainage longsections

4. Hydraulic Grade line on the Section view

5. Output window data - Service/utility clashes

Samples of the hydrology and hydraulics report are shown below.
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9.0 Drainage Templates (Saving Defaults and Globals)

The default and global settings may be saved as a template for other projects/networks. After setting 

the globals and defaults for a network follow these steps.

1. Export the model using File IO->Data output->12da/4da data. 

2. Start a new 12d project.

3. Import the file created in step 1 using File IO->Data input->12da/4da data.

4. Clean the model to remove the old networks Models->Clean.

Since the global and default values are stored as model attributes, they will be remain with the net-

work model. Cleaning does not remove the attributes.
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10.0 Drainage Data Input and Output to Spreadsheets

Spreadsheets are an effective method to manage the numerous variables urban drainage designers 

create in the modelling process. Spreadsheet data can be transferred to and from 12d in tab delim-

ited files and stored within 12d as “user definable attributes”. These attributes are linked to the pit 

and pipes within a network. Drainage long section plots can display the pipe attributes in the 

“arrows” data area and pit attributes in the bubbles area. Drainage plan drawing can also show 

these pit and pipe attributes.

Drainage strings will be created if they do not exist in the model but pits cannot be added to exist-

ing strings.

See also

12d to spreadsheet transfers

Spreadsheet to 12d update and create

Spreadsheet options

10.1 12d to spreadsheet transfers

This interface is accessed the Import/Export button on the Drainage Network Editor.
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Select Spreadsheet clipboard

These options are not used for 

spreadsheet export.

Usually leave this off! Select 

to export the junction pit at the 

end of all drainage lines (very 

rarely needed).

You may also select to limit the 

output if desired. If you like 

using spreadsheets for data 

entry, the PCdrain data and 

ILSAX data formats are useful 

for adding data for the first time 

for either program.

Select Run to place the data on 

the clipboard.
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11.0 Manhole/Pit Schedules

Manhole/pit schedules or construction tables are generated in tab or space delimited formats.

This panel is accessed from the menu selection

Design => Drainage => Reports => Pit schedule

This routine prints the calculations from the last time Set Pit Details was selected in the Drainage 

Network Editor.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Drainage model name input box drainage network

model containing the drainage strings

Pit schedule file name input box pit report

file to be created

Report Format choice box Road chainge.,Easting...

file format

Data delimiter choice box Tab, Space

tab delimiters are best for spreadsheets and space for some text editors

Repeat header for each line tick box selected

when selected, the column headings will be printed each drainage line 

Process button

Create the pit report
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Finish button

remove the panel from the screen

Notes:

The columns of data may be separated by spaces or a tab. (tab is used for spreadsheet transfers). The 

internal width and length data are retrieved from the drainage.4d file for the pit type specified. If 

you want a longer description for the pit then the type used inside 12d this can also be entered in the 

drainage.4d file. The remarks for each pit are entered as user defined pit attribute named remarks 

and may be set using the attribute editor (on the drainage menu) or via a spreadsheet.

Easting Northing Sample

.PIT SCHEDULE                                                             

  Pit                                INTERNAL           INLET          OUTLET                  PIT   

  No    TYPE    EASTING NORTHING    WD       LEN     DIA   INV LEV   DIA   INV LEV  FIN RL    

DEPTH         REMARKS       

   B1   SA2    5302.458 7336.936  450.000  900.000                    375   28.210   29.387    1.177                      

   A2   SA2    5264.372 7322.036  450.000  900.000    375   27.470                   28.646    1.226                      

   C1   SA2    5224.155 7336.936  450.000  900.000                    375   26.690   27.863    1.173                      

   A3   SA2    5187.910 7322.036  450.000  900.000    375   25.930                   27.158    3.628                      

   A1   SA2    5309.458 7321.100  450.000  900.000                    225   28.550   29.577    1.027                      

   A2   SA2     5264.372 7322.036  450.000  900.000    225   27.470    375   27.420   28.646    1.226                      

   A3   SA2     5187.910 7322.036  450.000  900.000    375   25.930    375   23.530   27.158    3.628                      

  A4   SA2   5157.411 7321.332  450.000  900.000   375   23.090                26.714    3.624 outlet to 

existing system 

NOTE:

1. ALL SETOUT POINTS QUOTED TO CENTRE OF PIT

Road Chainage Offset Example

DRAINAGE LINE A

PIT PIT LOCATION LOCATION OFFSETS

No. EASTING NORTHINGSTATION CTRL OFFS TYPE REMARKS

A/1 5354.629 7336.936 231.171 d002 -7.450

A/2 5340.691 7320.911 217.233 d002 8.575

A/3 5293.458 7320.886 170.000 d002 8.600

A/4 5250.131 7320.886 126.673 d002 8.600

A/5 5217.194 7322.036 93.736 d002 7.450

A/6 5183.458 7322.036 60.000 d002 7.450

A/7 5152.699 7322.036 29.241 d002 7.450

Notes
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The Set pit details must be run at least once to before printing the report. If the pits are moved or the 

designed strings changed then this option must re rerun.

The easting northing data obtained for the road design string option is obtained by dropping the pit centre 

perpendicular onto the selected road design string. This data is stored as pit attributes setout x and setout 

y. It is calculated when the Set Pit Detail is selected in the Drainage Network editor.
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12.0 Long Section Plotting

Detailed description of the 12d drainage long section plotting may be found in the 12d Reference 

manual. The long section plots are customised using the drainage plot parameter files (drainppf). 

Title blocks, user defined text may be added and then plotted directly or to various file formats (dwg, 

dgn etc.). From the main menu

Design=>Drainage-Sewer=>Plots=>Longsections

See Also

Set Pit Details to set road chainage and name data

To access the 

drainppf files sup-

plied select the 

icon and then 

walk right on Lib 

to select this 

drainppf file.

Select Read

Enter a new name 

for this drawing 

and select Write. 

This will save the 

setting we are 

about to make 

should you want 

to replot this long 

section.

This section view 

determines the 

additional mod-

els (such as serv-

ices) to show plot. 

These are referred 

to as corridor 

models. The ver-

tical exaggera-

tion is also 

obtained from this 

view.
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The network model field will be completed with the model of the string being profiled. If this 

is not your drainage network model then select it now.

When Plotter Type is set to model then plot file stem is the model name prefix for plots that 

will be created. The first sheet of plots will be in model plot1, the second in plot2 etc.

The plot height determines how much room is left vertically for the actual plot. This specifies 

the total height of the plot. 12d then constructs the box area and arrow area on the bottom and 

then arrow area on the top. The amount left over is used for the long section itself. 

To stop datum breaks from occurring increase this height, increase your plot scale or decrease 

your vertical exaggeration. If there is too much white space in the graph area then reduce this 

value.
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The +Drainage plot+title block+User title info allow you to enter the text for the title block. 

The list displayed is retrieve from the title file selected above. Enter the data for the plot and then 

select Write to save the changed to the local drainppf file you entered earlier.

Select Plot and the plots will be send to the plot file stem entered. These models may be added 

(one at a time) to a plan view to inspect them before plotting to paper or exporting to other draw-

ing packages.
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13.0 Working with Kerb/Lip Strings

The reference point for kerb inlet pits is usually on the kerb lip string or a fixed distance off the 

string. The rest of the strings only complicate the picture so we will take copies of the kerb strings 

to be placed in another model. Isolating the kerb strings into a separate model and joining them 

together is the recommended way to work with them. This may take a few minutes but sometimes 

you have even less time than that. So first lets look at how to pick kerb strings quickly.

13.1 Picking kerb strings - name snap

Strings generated by 12d have specific names attached to them. The lip string is often called 

“lok”. Therefore, if we could restrict our string selection to those strings named “lok” it would 

make placing the pits very efficient. We are going to do this with the Name snap.

There are 3 types off snap tool bars available. Standard, vertical and horizontal. To obtain the 

standard snaps toolbar select, Utilities=>Snaps=>Snaps and the following snap toolbar will 

appear.

Leave the panel up to remind your erase the lok entry and select Set again so that you will once 

again be able to pick any string.

When creating a junction pit you will have to snap to a drainage line that is not named lok. There-

fore, if you have 2 Snap Name panel open, a second one that is blank, you can turn the name snap 

on and off quickly.

Select Name and the following panel will appear.

Enter lok and select Set. Now only strings with this name will be 

selected.
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13.1.1 Placing a pit at a Specific Control String Chainage

When appending or moving drainage pits, the following steps will place the pit at a specific chainage 

along the control string.

1. RB and then select Snaps cogo=>Create=>Perpend from the menu. Messages indicating 

what to be done next are given in the bottom left corner of the 12d window.

2. LB select but do not accept the road centre line (control string).

3. To place the pit across from chainage 2100 Type ch2100 then press enter.

Short Cut: Just before selecting the string RB then select Find by name from 

the menu. This will display the Snap Name panel.
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4. MB accept the inserted point. This identifies the point on the control string. Next

5. LB select the lip line then MB accept. The construction point will be displayed on the lip 

line

6. MB accept the construction point to place the pit.

13.1.2 Placing a pit at a Specific Distance/Offset along the kerb string

When appending drainage pits, the following steps will place the pit at a specified distance along 

a string and if desired an offset. 



Revised 17 Sept 200712d Stormwater Design Course Notes - Part 1 Page 98 of 102

12d Solutions Pty Ltd

COURSE NOTES

STORMWATER DESIGN

1. RB and then select Snaps Cad=>Points=>Locate Offset from the menu. Messages indicating 

what to be done next are given in the bottom left corner of the 12d window.

2. When you select the string to measure the distance along, do not click but rather drag in the 

direction you want to offset. Next MB accept 

3. LB select then MB accept the control point to measure the distance from. (If this point is not on 

the string selected in step 2 the point will be dropped perpendicularly onto that string).

4. Type the distance along the string then press Enter (a negative value would go in the opposite 

direction to the drag in step 2).

5. Type the offset distance from the string then press Enter (positive is defined using a right hand 

rule method from the direction in step 2).

6. MB accept the construction point to place the pit.

13.2 Locating Crests and Sag Points

This step will place tick marks at the crest and sag points of your kerb strings. It is an optional step 

but it will help ensure that a drainage inlet is always placed at SAG inlet locations. 

If your road designer has given you kerb inverts strings split into numerous sections, use the “head to 

tail” feature described in section 4.2 above before using this section. The crests and sag locations 

along the design string can be identified using the selection

Strings =>Label => Chainages
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To get a clear picture of what the kerbs look like in profile lets create a section view and profile 

the kerb string.

Enter the view for the road strings.

Select crests/sags from drop down list.

Enter a model to contain the text labels. A ,1 

after the model name, requests that the model 

be added to view 1. This saves you adding the 

model to the view later to see the labels.

Select icon to define the text style.

Select the Marks property sheet 

Type the same model name as above for the 

tick marks.

LB to select ticks centred from the drop 

down list.

5m white marks stand out well on the screen.

Select Label to create the labels.

Select Finish to remove the panel.
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To obtain more working area, hide the Output Window (Window=>Output window).

From the main menu select,

View=>New=>Section View

Now Select Profile on the section view tool bar and then pick the kerb string in the plan view. 

Your screen should now look like the following.

x

Place your pointer in the section view and notice how the cross in the plan view indicates your posi-

tion in plan.
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14.0 Training Check List

Network plan - convert from strings

- insert, append, delete and move pits

Network Vertical - Set Pit Details and Regrade pipes

- Pipe alignment modes

Set Pit Names

Catchments - draw, label, link and check

- tc strings

Hydrology - Area, Tc, C values with defaults

Hydraulics - setout to grate

- method (pipe full or HGL)

- available pipe sizes and box culverts

Services - over and under drainage pipes

Road strings - rotate symbols

- x,y and/or z for setout

- road grade and crossfall for inlet capacity

- road chainage from centre line

12d design engine understanding the reports

Setout pit schedules - easting, northing and road centre line

Drawings Long Section plotting

Plan drawings

Kerb Strings - select by name

- crests and sags
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THE END


