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Disclaimer
12d Model is supplied without any express or implied warranties whatsoever.

No warranty of fitness for a particular purpose is offered.

No liabilities in respect of engineering details and quantities produced by 12d Model are accepted.

Every effort has been taken to ensure that the advice given in this manual and the program 12d MODEL is 
correct, however, no warranty is expressed or implied by 12D SOLUTIONS PTY LTD

Copyright
This manual is copyrighted and all rights reserved.

This manual may not, in whole or part, be copied or reproduced without the prior consent in writing from 
12D Solutions Pty Ltd.

Copies of 12d Model software must not be released to any party, or used for bureau applications without 
the written permission of 12D Solutions Pty Ltd.

Copyright (c) 1989-2007 by 12d Solutions Pty Ltd

Sydney, New South Wales, Australia.

ACN 101 351 991
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  Preface

Introduction
12d Model is an interactive graphics program designed to process survey data, quickly build terrain, 
conceptual and detail design models.

Data is easily read in, triangulated and contoured to build an initial terrain model. Roads, platforms, 
channels or other design features can be added interactively and a merged model containing the initial 
terrain and the new design features formed to produce conceptual design models.

All Models can be examined in plan, section or perspective views. The number and type of views 
displayed on the screen is totally user defined.

By using a mouse and flexible on-screen menus, 12d Model is easy to use and requires a minimum of 
training.

This document is the 12d Model Reference manual.

Reference Manual in PDF Form
12d Model V8.0 has an on-line help available for all panels and menus. 

However, because Microsoft’s Help system only allows individual topics to be printed, the entire 
12d Model Reference manual has also been supplied as a PDF file. The PDF file can be used to print out 
large sections of the manual. Adobe’s PDF format can be read by Adobe Acrobat or the free Acrobat 
Reader

The PDF file for the 12d Model Reference manual is called

12dm_8.0_ref.pdf

and is in the folder on the 12d Model CD called

Documentation\Reference_Manual

If you do not have an Acrobat Reader installed, it is available on the 12d Model CD under Install.

Training Manuals in PDF Form
12d Model is supplied with a very comprehensive on -line Reference manual which describes the function 
of each menu option in detail. It is a Reference manual however and makes no attempt to describe how to 
use 12d for production surveying and civil engineering work.

The 12d Model installation CD also contains two (2) Training manuals:

Getting Started for Design manual

Getting Started for Surveying manual

The Getting Started for Design manual is available as a printed manual and as a PDF file on the 12d 
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Model Installation CD.

The Getting Started for Surveying has the first seven chapters in common with the Getting Started for 
Design manual (installing 12d Model, on-line help and basic modelling) but then diverts to cover topics 
from the direction of a Surveying whereas the Getting Started for Design manual continues on with 
alignment design techniques. 

The Getting Started for Surveying manual is available as a printed manual and as a PDF file on the 12d 
Model Installation CD. It is common to all 12d Model users.

Training Material
The training tutorials assumes that a series of files are already on your hard disk. These tutorial files are 
automatically installed from the CD during installation of the 12d Model software. 

Using the Practise and Small Versions of 12d Model
The Practise version of 12d Model is limited to a maximum of 5,000 points. Following the procedures as 
stated in the training manuals may create projects with more than 5,000 points. 

Where appropriate, the text will suggest how to vary the input for each instruction so that the example 
feature can be completed within the limits of the 12d Model Practise version. 

The number of points used at any time in the Practise and small release versions can be displayed by the 
option

Projects => Check points

The easiest way to reduce the current point count is to delete any unwanted models with 

Models => Delete

The installed icon on your desktop for running the practise version of 12d with these training files is 
labelled ’12d v8.00 Practise Training’.

Please Note: Projects created by Practise versions of 12d Model cannot be accessed by Release versions of 
12d Model and vice-versa.
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1 Installation of 12d Model 8 Release Version
The 12d Model 8 Installation CD can be used to install the Release and Practise versions of 12d Model 8.

The Practise version is limited to a maximum of 5,000 points and creates projects that cannot be accessed 
by the Release versions of 12d Model and vice-versa. However the Practise version can be used free of 
charge by 12D Solutions customers and registered Practise Users.

These notes are for installing the Release version of 12d Model 8. There are separate notes for installing 
the Practise version.

For a new installation of the Release version of 12d Model 8, the user is provided with

one dongle

one 12d Model 8 Installation CD

an email or a floppy with the file  nodes.4d on it

Please check that you have all three items before commencing the installation.

For existing 12d Model 7.0 users, the user is provided with

one 12d Model 8 Installation CD

an email or a floppy with the file  nodes.4d on it

For existing users, the dongle you already have for 12d Model 7 will work with the new version of 
12d Model 8. If 12d Model 8 is already running on your computer, please uninstall it before installing a 
new version of 12d Model 8.

Important Note on Nodes.4d 

Because most new computers do not have a floppy disk drive, the 12d Model 8 nodes.4d file will 
normally be emailed to you rather than sent on a floppy disk. Before installing 12d Model 8, you must 
copy the 12d Model 8 nodes.4d into a folder that can be accessed during the installation.

During the installation of 12d Model 8, you will be asked to browse to the folder containing the 
nodes.4d file.

Please do not change the name of the nodes.4d file. The installation and 12d Model will only search 
for a file called nodes.4d.

Extra Notes for All Installations
1. A three-button mouse is essential.

2. The Installation CD contains extra information other than just the installation version of 12d Model. 
For example, documentation, source to macros and plot parameter files.

The extra data can be copied from the Installation CD but the copied files may only have a “read only” 
attribute set. This means that the files can not be edited or modified in any way.

To change the attribute so that a file can be modified, select the file in Explorer, bring up the Properties 
sheet and under the General tab sheet change the “read only” box so that it is not ticked on.

Selecting OK or Apply will then modify the attribute of the file.
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Installing the Release Version of 12d Model 8

These notes are for installing the Release version of 12d Model 8. There are separate notes for installing 
the Practise version.

A. Disk Space required for installing 12d Model 8

Approximately 400 megabytes of disc space will be required for the installation to succeed. After 
installation this can be reduced to a minimum of 60 megabytes.

B. Before installing from the CD

For Windows 2000, XP: 

Reboot the PC before installing 12d Model from the CD.

Your login must have Administrator privileges.

C. Do not attach the dongle before installing dongle drivers

USB dongles must not be attached to the computer before the dongle drivers are installed.

D. Using the email and/or floppy with the nodes.4d on it

If you have a nodes.4d floppy disk, it should be inserted into the floppy drive before 12d Model is 
installed. The 12d Model 8 installation program will copy the nodes.4d file from the floppy disk.

The nodes.4d file does not have to be on a floppy disk- it can be in any folder. This may be the case if you 
do not have a floppy drive or if the nodes.4d file was emailed to you.

If you don’t have the nodes.4d file on a floppy disk but in a folder instead, then during the installation of 
12d Model you will be asked to Browse to the folder containing the nodes.4d file. The 12d Model 8 
installation program will copy the nodes.4d file from the selected folder.

E. Starting the Installation of 12d Model 8

Insert the 12d Model 8 Installation CD into the CD drive.

On inserting the CD, the 12d Model Installation program automatically begins.

If it doesn’t, simply double click on the program "setup.exe" from the CD.
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F. Installing

The 12d Model Release screen will appear.

The Steps on the 12d Release tab of the Installation CD will lead you through the installation of the 
Release version of 12d Model. 

NOTE - If the dongle drivers and the Camtasia codec are already installed on your computer then you can 
proceed to Install 12d Model 8 Release.
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Step 1. Install the Hardlock and Wibu Dongle Drivers

You need to have System Administrator rights to install the dongle drivers.

Both the Hardlock and the Wibu dongle drivers should be installed even if you only have one type of 
dongle.

On the 12d Model Release screen, click on Hardlock driver:

The script to install the hardlock dongle drivers begins.

Select language Language for hardlock installation

select US English and then OK to continue

Hardlock Device Driver Installation Installing dongle drivers

select Next to continue
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Hardlock Device Driver Installation Finish installing dongle drivers

select Finish to continue

The Hardlock dongle drivers have now been installed.

The 12d Model Release screen will then appear.
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On the 12d Model Release screen, click on Wibu driver:

The script to install the Wibu dongle drivers begins.

Under Windows XP you may get an Open File - Security Warning

select Run to continue

WIBU-KEY Setup Welcome to WIBU-KEY Software Setup

select Next to continue
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WIBU-KEY Setup Language Selection

tick language and then select Next to continue

WIBU-KEY Setup Installation folder

select Next to continue

WIBU-KEY Setup Installation folder doesn’t exist

click Yes to continue
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WIBU-KEY Setup Component Selection

make sure nothing is ticked and then select Next to continue

WIBU-KEY Setup Tasks to be Performed

select Next to continue
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WIBU-KEY Setup Tasks done

select Next to continue

WIBU-KEY Setup Setup Complete

select Finish (leave  "Yes, I want to view the Readme text now" unticked) 
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Setup OK Setup OK

click OK

The WIBU dongle drivers have now been installed.

The 12d Model Release screen will then appear.
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Step 2. Check the dongle

The 12d Model dongle (Hardlock or Wibu) can now be attached to the computer.

For USB dongles:

Warning: you must have System Administrations rights the first time you attach 
a USB dongle to any USB port:

When a USB dongle is attached for the first time to any USB port, Windows will detect that it is new 
hardware and needs to load the dongle drivers for that USB port - this will require System 
Administration rights.

Since the dongle drivers have already been loaded onto your computer, when the USB dongle is 
attached to a new USB port, it will be recognised as new hardware

 and Windows should automatically install the correct dongle driver.

IMPORTANT NOTE IF THE WIBU DONGLE IS NOT RECOGNISED:

 If the WIBU dongle is not recognised and you get the "Found New Hardware" screen
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please go to the section “Wibu XP SP2 Problems” on how to find the Wibu drivers

NOTE - even though your dongle is working on one USB port and then you no longer need System 
Administration rights to attach the dongle to that USB port, if you try and attach the dongle to a new 
USB port, you will need System Administration rights to install the dongle drivers on the new USB 
port.

The dongle must be attached to the USB port at all times, otherwise 12d Model will stop running.

For Parallel dongles: 

Attach the dongle to the printer port. The dongle must be attached to the printer port at all times, 
otherwise 12d Model will stop running.

Important Note - the 12d parallel dongle must be before any Rainbow dongles (e.g. AutoCad).
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On the 12d Model Release screen, click on Check:

The dongle checking program begins. 

Installation Installation message

Tick "Local" and select Next

The computer/network will be checked for dongles.
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Check Report

The correct dongle number should be displayed and also a check on the date in the computer is correct.

 select Finish

This completes the dongle Check.

The 12d Model Release screen will then appear.
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Step 3. Install Camtasia Codec

You need to have System Administrator rights to install the dongle drivers.

The Camtasia Codec is used for displaying the images on the 12d Model Training CDs and DVDs.

On the 12d Model Release screen, click on Camtasia Codec:

The Camtasia Codec installation begins. 

Installation Installation message

Select Install to continue with the installation

Installation Complete

Select OK.

This completes the installation of the Camtasia Codec.

The 12d Model Release screen will then appear.
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Step 4. Installing 12d Model 8 Release Program files

Insert the floppy disk with the nodes.4d file on it into the floppy drive.

During the installation, the nodes.4d file will be copied from the floppy disk, or if you do not have a floppy 
disk, from the folder on your computer containing the nodes.4d file.

Note that if you do not have a nodes.4d file, you can use a Custom install but you will need a nodes.4d file 
before 12d Model can be used.

On the 12d Model Release screen, click on Install 12d Model 8 Release:

The 12d Model 8 installation begins. 

Welcome Welcome message

Select Next to continue with the installation

Software License Agreement 12D Solutions license agreement

If you agree with the License conditions, click on I accept the terms in the license agreement.

Select Next to continue with the installation
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Setup Type

select Complete select Next to continue with the installation

Authorisation file Folder containing the authorisation file nodes.4d

select Change

Authorisation file Browse to the Folder containing the file nodes.4d
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select the folder containing the nodes.4d file and then select OK

Authorisation file Folder containing the authorisation file nodes.4d

select Next to continue with the installation

Start Copying Files Begin the installation

select Install to continue the installation

The software will be copied and installed onto the computer.
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Setup Complete End of installation

Select Finish to complete the installation

The 12d Model Release screen will then appear.

Select Exit at the bottom right hand corner of the screen to end the installation.

This completes the installation for new Installations of 12d Model.
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 Icons Created by Installing 12d Model 
The installation loads the appropriate components and creates the icons

The 12d Model 8 icon attaches to the folder 12djobs.

The 12d Model 8 Training icon attaches to the folder containing the data to use with the Getting Started for 
Design, Getting Started for Surveying and other training manuals.

Release

12d Model 8

12d Model 8 Training
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12d Model 8 Not Authorising
error_authorizing_release_version

When installing the Release version of 12d Model on the computer, a nodes.4d is normally installed at the 
same time. The nodes.4d file must match the dongle attached to the printer/USB port and contains the 
codes for which modules are authorized for the user.

If the nodes.4d file is valid, then when 12d Model 8 is started by double clicking on the 12d Model 8 or the 
12d Model 8 Training icon, the 12d Model splash screen will appear and then the initial 12d Model screen 
with the Project Selection panel.

If the Project Selection panel appears, then 12d Model is authorized and ready to use.

If there is an error with the nodes.4d file, then the Error Authorizing Release Version panel appears with 
possibly an error message in the panel message area.

recent projects list

description of

authorized

recent project
highlighted

client name
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If there is no error message on the panel or it is still not obvious what the problem is, please check the list 
of possible errors in the next section, “Possible Problems When Authorizing the Release Version” 

For example, in the above panel the dongle number is blank which means no dongle has been detected.

If there is still a problem, information can be recorded and emailed to 12D Solutions (to help debug the 
problem) by clicking on the Email Info button to bring up the Email Information on 12d Model to 12D 
Solutions panel.
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Fill in all the fields and then click on Email to try and automatically send an email to 12D Solutions.

If the Email button does not send an email, the Save button can be used to write the information out to a 
file called 12d_auth.txt. This file can then be emailed to support@12d.com.
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Possible Problems When Authorizing the Release Version
1. There is no nodes.4d file in the correct area on your computer.

The nodes.4d file is normally in the folder Program files\12d\12dmodel\8.00

If you do not have the correct nodes.4d file. Contact your local distributor.

2. There is no dongle on your computer or on the network. 

Please attached the dongle and retry starting up 12d Model.

3. The dongle number does not come up in the Dongle field of the Error Authorizing Release Version 
panel. Please check

(a) the dongle is firmly attached to the computer.

(b) if it is a parallel dongle, the dongle is before any Rainbow dongles. For example, before any 
AutoCAD dongle.

(c) your computer has the latest dongle drivers installed. These can be obtained from Updates section of 
the web site www.12d.com

If the dongle number still does not come up in the Error Authorizing Release Version panel, please 
click on the Email info button to bring up the Email Information on 12d Model to 12D Solutions 
panel. Fill in the panel and click on Email to send the information to 12D Solutions and then contact 
12D Solutions or your local distributor.

4. The dongle number in the nodes.4d file does not match the dongle on the computer.

You do not have the correct nodes.4d file. Contact your local distributor.

5. The date on your computer is not the correct date.

Change the date on your computer and retry starting up 12d Model.

6. The date on your computer is the correct date but is not between the start and end dates given for your 
dongle in the nodes.4d file.

You do not have the correct nodes.4d file. Contact your local distributor.

7. 12d Model is still not running.

Please click on the Email info button to bring up the Email Information on 12d Model to 12D 
Solutions panel. Fill in the panel and click on Email to send the information to 12D Solutions and then 
contact 12D Solutions or your local distributor.
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Wibu XP SP2 Problems
First we installed the WIBU drivers using the WIBU-KEY Setup (Version 5).

Now that the WIBU drivers have been successfully installed, the WIBU USB dongle is attached to the 
USB port. 

Windows XP realises new hardware has been attached to the USB port and the Found New Hardware 
(WIBU-BOX/RU) message is displayed

Unfortunately, XP SP2 does not find the WIBU-BOX/RU drivers and install them 
and you get the Found New Hardware Wizard instead:
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Click on "No, not this time" and select Next to continue

try  "Install the software automatically" and select Next to continue
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NOTE: XP now finds "C:\windows\inf" but for some reason can’t when it first detects the new hardware 
(as it used to do in earlier XP’s and Win 2000).

choose either location and select Next to continue
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select Finish

The New hardware has now been installed
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2 Installation of 12d Model 8 Practice Version
The Practise version is limited to a maximum of 5,000 points and creates projects that cannot be accessed 
by the Release versions of 12d Model and vice-versa. However the Practise version can be used free of 
charge by 12D Solutions customers and registered Practise Users.

These notes are for installing the Practise version of 12d Model 8. There are separate notes for installing 
the Release version.

The Practise version must be Registered with 12D Solutions once it is installed on a computer. A new 
Registration is required for each computer that the Practise version is run on.

The 12d Model 8 Installation CD can be used to install the Practise versions of 12d Model 8.

Or

The file 12dModel 8 Practise.exe can be down loaded from the web site www.12d.com. The file 12dModel 
8 Practise.exe is a self-extracting file for installing the Practise version of 12d Model.

Extra Notes for All Installations
1. A three-button mouse is essential.

2. The 12d Model Installation CD contains extra information other than just the installation version of 
12d Model. For example, extra documentation, course notes and source code to macros.

The extra data can be copied from the 12d Model Installation CD but the copied files may only have a 
“read only” attribute set. This means that the files can not be edited or modified in any way.

To change the attribute so that a file can be modified, select the file in Explorer, bring up the Properties 
sheet and under the General tab sheet change the “read only” box so that it is not ticked on.

Selecting OK or Apply will then modify the attribute of the file.
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Installing the Practise Version of 12d Model 8

These notes are for installing the Practise version of 12d Model 8. There are separate notes for installing 
the Release version.

A. Disk Space required for installing 12d Model 8

Approximately 200 megabytes of disc space will be required for the installation to succeed. After 
installation this can be reduced to a minimum of 60 megabytes.

B. Before installing from the CD or the Web

For Windows 2000, XP: 

Reboot the PC before installing 12d Model from the CD or the Web.

Your login must have Administrator privileges.

C. Installing 12d Model from the Web

The self-extracting file 12dModel 8 Practise.exe can be down loaded from the web site www.12d.com and 
used to install the Practise version of 12d Model.

After down loading 12dModel 8 Practise.exe, double-click on 12dModel 8 Practise.exe and the 
installation software will be automatically extracted from the file and fires up the Install 12d Model 
Practise screen.

Please go to section “12d Model Practise" Screen” 

D. Installing Using the 12d Model 8 Installation CD

Insert the 12d Model 8 Installation CD into the CD drive.

On inserting the CD, the 12d Model Setup program automatically begins.

If it doesn’t, simply double click on the program "setup.exe" from the CD.

The 12d Model Release front screen will appear.
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Click on the 12d Practise tab

The 12d Model Practise screen will appear.
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E. 12d Model Practise" Screen

The 12d Model Practise screen:

Note - when installing from the web, the tabs with "12d Release","12d Practise", "Other Software" and 
"Documentation" will not appear. The extra tabs only appear if you are installing from the 12d Model 
Installation CD.

The Steps on the 12d Practise tab of the Installation CD will lead you through the installation of the 
Practise version of 12d Model. 

The names of each screen and the required response are given in the order in which the screens appear. 
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Step 1. Install Camtasia Codec

Install the drivers for use with displaying the 12d Model Training CDs and DVDs.

Note - you need Administrator rights to install the Camtasia Codec.

Click on Camtasia codec:

Installation Installation message

Select Install to continue with the installation

Installation Complete

Select OK.

This completes the installation of the Camtasia Codec.

The 12d Model Practise screen will then appear.
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Step 2. Install 12d Model 8 Practise

Install the 12d Model Practise software and Training area.

Click on 12d Model 8 Practise:

Welcome Welcome message

Select Next to continue with the installation

Warning for commercial competitors

12D Solutions warning

The 12d Model Practise version and all documentation are supplied by 12D Solutions Pty Limited for the 
use of 12d Model Customers and genuine prospects only. The use of the 12d Model practise versions by 
commercial competitors to 12d Model is strictly prohibited.

Select Next to continue if you are a 12d Model Customers or a genuine prospect
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Software License Agreement 12D Solutions license agreement

If you agree with the License conditions, click on I accept the terms in the license agreement

Select Next to continue with the installation

Setup Type

select Complete select Next to continue with the installation
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Ready to Install Begin the installation

select Install to continue the installation

The software will be copied onto the computer and installed.

Setup Complete End of installation

Select Finish to complete the installation

The 12d Model Practise screen will then appear.
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Select Exit at the bottom right hand corner of the screen to end the installation.

For Practise versions, the software needs to be authorised by emailing information about your computer to 
12d Solutions. 

The form for the required information is automatically created when an unauthorised 12d Model Practise 
version is started up. The form can be emailed to 12D Solutions from the 12d software.
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 Icons Created by Installing 12d Model Practise
The installation loads the appropriate components and creates the icons

The 12d Model 8 Practise icon attaches to the folder 12d Model 8 Practise.

The 12d Model 8 Practise Training icon attaches to the folder containing the data to use with the Getting 
Started for Design, Getting Started for Surveying and other training manuals.

Practise

12d Model 8 Practise

12d Model 8 Practise Training
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Authorizing the Practise Version of 12d Model 8
authorization_request_form

accept_code

Warning

The 12d Model Practise version and all documentation is supplied by 12D Solutions Pty Ltd for the use of 
12d Model Customers and genuine prospects only. The use of the 12d Model Practise version by 
commercial competitors to 12d Model is strictly prohibited.

The Practise version is limited to a maximum of 5,000 points and creates projects that cannot be accessed 
by the Release versions of 12d Model and vice-versa. However the Practise version can be used free of 
charge by 12D Solutions customers and registered Practise Users.

The Practise version needs to be Registered with 12D Solutions once it is installed on a computer and a 
new Registration is required for each computer the Practise version is run on.

The installation creates the two icons

The 12d Model 8 Practise icon attaches to the folder 12d Model 8 Practise.

The 12d Model 8 Practise Training icon attaches to the folder containing the data to use with the Getting 
Started for Design, Getting Started for Surveying and other training manuals.

After installing the Practise version of 12d Model on the computer, fire up 12d Model Practise by double 
clicking on the 12d Model 8 Practise icon

12d Model Practise will then start up and the Authorize Request Form panel will be displayed. 

Practise

12d Model 8 Practise

12d Model 8 Practise Training
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Fill in the details (all those in black type must be filled in) and then either

(a) click on the Email button to send the information to 12D Solutions Pty Ltd.

or if this fails

(b) click on the Save button. A file called 12d_auth.12d8r is then written out. Please email this file (as an 
attachment) to authorize@12d.com

 Then click on the Finish to exit 12d Model.

On receiving your request, 12D Solutions will generate an authorization code and send an email back to 
you with an attachment called 12d_auth.12d8c

When you receive the email with the file 12d_auth.12d8c attached to it, double click on the attached file 
12d_auth.12d8c, click on Open it and finally click on OK.
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.

12d Model Practise will then start up and 

validate the 12d_auth.12d8c file, and if it is valid

save the authorization code away as the file practise.4d in the folder 

Program files\12d Model 8 Practise\12d model\8.00

and then bring up the Accept Code panel with the practise.4d updated message.

.

 Click on OK and 12d Model Practise will open and display the project Road.

Note: if you already have a pratise.4d file in the folder then the Accept Code panel will be brought up, 
stating that the practise.4d file already exists, and asking to overwrite it.

.

 Click on Yes and the new authorization code will be saved away as the file practise.4d in the folder 

Program files\12d Model 8 Practise\12d model\8.00
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The Accept Code panel then comes up with the practise.4d updated message.

.

 Click on OK and 12d Model Practise will open and display the project Road.

.

To exit 12d Model Practise, click on Project =>Exit
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If 12d Model Practise does not start up correctly, please go to the next section “Possible Problems When 
Authorizing the Practise Version” 

Possible Problems When Authorizing the Practise Version
1. The date on your computer is not the correct date.

2. The computer your are authorizing is not the same one that the Authorisation Request Form was 
generated for.

The 12d_auth.12d8c and the generated practise.4d file are only valid for the computer that the 
Authorisation Request Form was generated on. If you want the Practise version to run on another 
computer, you need to generate a new Authorisation Request Form on that computer and send it to 12D 
Solutions.

3. If you change your network card after generating the Authorisation Request Form then the 
authorization will stop working. A new Authorisation Request Form needs to sent to 12D Solutions.

4. If the file 12d_auth.12d8c does not appear as an attachment then your email system can’t handle 
MIME attachment. Please contact 12D Solutions at authorize@12d.com
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3  Tools and Concepts
The Mouse

The mouse is used extensively in 12d Model.

12d Model can be operated with either a two or a three button mouse but a three button mouse 
is preferred.

In this manual the buttons will be denoted by

LB = the left button

MB = the middle button

RB = the right-button

12d Model monitors the mouse being pushed down and when it is subsequently released as 
separate events. Unless otherwise specified in the manual, clicking a button will mean pressing 
the button down and releasing it again. The position of the mouse is normally taken as being 
when the button is released.

In screen messages, the effect of pressing each button on the mouse is shown by enclosing the 
effect for each button in square brackets ([]) in left-to-right button order. That is

[left button effect] [middle button effect] [right button effect]

Empty brackets, [], indicate that pressing the button has no effect at that time.

NOTE: If the Middle button is also a wheel, then the wheel can be used in some 12d Model operations 
such as zoom.

Please continue to the next section “The Keyboard”.

The Keyboard
For clarity, the characters and special keys on the keyboard will be enclosed in the angle brackets 
< >. For example, the delete key is <del>.

When two or more keys are to pressed down together, they will be shown in angle brackets 

LB MB RB
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separated by a plus sign (+).For example, <ctrl> + <d> means that the control key and d are 
pressed down together.

In 12d Model, the escape key (normally labelled "esc" on the keyboard and denoted by <esc> in 
this manual) is used to stop drawing in a view or to break out of computer intensive options 
("escape" or "abort" the option) but still remain in 12d Model. Options which can be terminated 
by <esc> are noted in the manual.

Please continue to the next section “Screen Layout”.
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Screen Layout
Inside the 12d Model screen are six distinct areas (main menu, top tool bar area, side tool bar 
area, view area, output window and status bar) which create and control nine associated objects 
(panels, tool bars, control bars, floating menus, plan views, section views, perspective views, 
hidden perspective views and OpenGL perspective views) displayed on the screen.

The main areas and their purposes are:

(a)  Main Menu

The Main Menu is at the top of the 12d Model screen and is a standard Microsoft type menu. 
Options are selected in the standard Microsoft way and bring up 12d Model panels and 
floating menus.

(b) Views Area

The Views Area displays the 12d Model drawing views for seeing and examining the data. 
There is no limit to the number of plan, section or perspective and hidden perspective views 
that can be created, overlapped or iconized.

(c) Output Window

The Output Window displays 12d Model system and error messages. The Output Window 
can be turned on/off from the Main menu.

(d) Status Bar

The Status Bar displays message prompts and the x, y and z co-ordinates of the cursor when 
it is in a drawing view. The Status Bar can be turned on/off from the Main menu.

(e) Top Tool Bar area

The Top Tool bar area is below the Main Menu and contains the CAD control bar, Text control 
bar and the snaps toolbar.

(f) Side Tool Bar area

The Side Tool bar area is on the far left side and the CAD tool bar and other tool bars defined 
in Toolbars.4d
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Please continue to the next section “Main Menu”.

snaps toolbar
screen maximise
minimise buttons

view coordinates boxscreen message box

drop down
main menu bar

view title

view type
and name

view workbook tabs

status bar (contains
screen message box and
view coordinates box)

view button

output
window

area

area

CAD control bar

Text control bar

CAD

top tool
bar area

side tool
bar area

tool bar

view icons
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Main Menu
At the top of the 12d Model window is the Main menu, a standard Microsoft type menu.

.

Options can be selected in the standard Microsoft way and bring up 12d Model panels 
(dialogues) or create floating menus.

The Main menu can be moved around, or docked on any of the four sides of the window.

If the window is not wide enough, the Main menu will automatically wrap around onto two or 
more lines.

Please continue to the next section “Floating Menus”.

Floating Menus
As well as the standard Microsoft type menu, 12d Model has the concept of floating (tear away) 
menus.

The presence of a floating menu on the Main menu is indicated by a menu item enclosed in 
square brackets [ ]. Selecting a menu item in square brackets will create a floating menu of that 
name.

For example, selecting [Project] from the top menu Project creates the floating menu called 
Projects.

A floating menu can be moved around the screen, even outside the 12d Model window, and will 
stay up until the [X] button is selected on the top right hand side of the floating menu.

A floating menu created from the Main menu usually contains the same items and walk-right 
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menus as the Main menu but has the distinct advantage that it doesn’t disappear when the 
cursor is moved to select other menus from the Main menu.

Floating menus or just Menus, consist of a menu title area and a series of options, called menu 
buttons, lined up under the menu title.

For example, the Projects menu looks like 

no_option

An option on the menu is invoked (or selected) by clicking LB whilst over the option.

If no option exists, a No Option panel is placed on the screen. The panel will remain until the OK 
or [X] button is selected.

walk-right menu indicators

menu-title area

menu buttons
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A ">" on a menu-option indicates that there is a walk-right menu attached to that button.

The walk-right menu only appears as the cursor moves over the >.

The walk-right menu can consist of further menu options and walk-rights.

If a walk-right menu is showing and the user wanders back into the menu where the walk-right 
originated, the walk-right menu will collapse back to the >.

Moving a Menu

A menu can be moved (dragged) by holding down LB anywhere in the menu title area (except 
on the [X] button) and then moving the cursor with the LB still depressed. A menu outline 
appears and moves with the cursor to indicate where the new menu position will be. The menu 
is finally positioned when LB is released.

When an expanded walk-right menu is moved, a copy of the walk-right menu will be moved 
and placed on the screen as a new floating menu. The original menu still contains the walk-right 
menu.

Dumping a Menu
menu_panel_dump

An image of the menu can be written out to disk in either bmp, tif, colour postscript or a screen 
layout file. This is called dumping the menu.

The dump option is invoked by clicking the middle mouse button (MB) anywhere in the menu 
title area. The Menu/Panel Dump panel is then displayed

.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Format input screen layout file bmp, colour postscript,
tif, screen layout file

format for writing the image to disk.

File input

disk file to write the dump image to.

Dump button

dump the menu image to disk.
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Deleting a Menu
A floating menu is deleted by selecting the [X] button in the menu-title area.

Please continue to the next section “12d Model Menu”.
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12d Model Menu
The 12d Model menu familiar from 12d Model version 3.20 is available by selected 12d Model 
Menu on the Projects menu.

Selecting 12d Model Menu again will remove the 12d Model menu.

All of the options down the 12d Model menu are also available in the same order going across 
the Main menu.

Please continue to the next section “Toolbars and Controlbars”.

Toolbars and Controlbars

Toolbars
Options can be grouped together on toolbars. Toolbars are made up entirely of icons and each icon 
can have a 12d Model option attached to it.

Toolbars have unique names which are displayed on the top of the toolbar when it is not docked.

Toolbars can also have one level of Flyouts of other toolbars and when a flyout exists, there is a 
small arrow on the bottom right of the icon to indicate a flyout exist. The tool tip for the icon gives 
the name of the flyout toolbar. The actual icon itself is the icon of the first item on the flyout 
toolbar.

For example, the CAD toolbar is entirely made up of flyout toolbars.

click on 12d Model menu
 

brings up the old menu

arrow in right bottom
corner indicates a
flyout toolbar

tooltip gives the
name of the
flyout toolbar

name of the toolbar
is displayed when the
toolbar is not docked

the icon displayed is the
first icon o the flyout
toolbar
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To display and select from a flyout toolbar, hold down LB whilst over the icon on a toolbar with 
a flyout menu and the flyout menu will appear. Whilst still holding down LB, move along the 
flyout toolbar to the appropriate option and then release LB. The option attached to the 
highlighted icon will then be selected.

Note - if LB is released whilst a icon with a flyout toolbar is highlighted, the first option on the 
flyout tool bar is selected.

All the toolbars in 12d Model are defined in a file with the default name toolbars.4d (for the 
definition of toolbars, see the section “User Defined Toolbars”in the Appendix “Functions Keys, 
Menus, Toolbars”.

The list of all defined toolbars is given by selecting View =>Toolbars from the main menu which 
brings up the Customize panel. A toolbar is shown with a tick if it is already on the screen.

Ticking on a toolbar in the list brings up the toolbar in the top left hand corner of the screen. The 
toolbar can then be moved or docked.

release the mouse left
button and the highlighted
toolbar option is selected

hold down the left mouse
button and the flyout
toolbar will appear

continue to hold down
LB whilst going over
the flyout

Customize lists all 
the toolbars and 
controlbars with a 
tick to indicate 
that they are 
already on the 
screen

Click on Close to 
remove the 
Customize panel

Click on 
Toolbars to 
bring up the 
Customize 
panel
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Ticking off a toolbar in the list removes the toolbar from the screen.

Important Note - the toolbars are not active whilst the Customize panel is on the screen. Close the Customize 
panel as soon as you finished with it.

What toolbars are on the screen and their position is recorded with the project so that when a project is 
existed and later started again, the final position of the toolbars is restored.

Also at any time, a workspace file can be read in and define a new setup and position of toolbars. For more 
information on using workspace files, please go to the section “Workspace”in the chapter “Projects”.

For links to the options on each Toolbar, go to “Options on Toolbars”

Controlbars
Controlbars can have icons on them but they also have controls such as a model box on them.

Controlbars are not user defined and there are only three of them in 12d Model - the Cad Controlbar, Symbol 
Controlbar, and Text Controlbar.

This default position of the controlbars is on the top left hand side of the screen under the main menu.

Although not toolbars, the Controlbars do appear in the Toolbars list in the Customize panel and can be turned 
on/off and docked just like toolbars.

Important Note - the toolbars are not active whilst the Customize panel is on the screen. Close the Customize 
panel as soon as you finished with it.

The controlbars are used by CAD toolbars and the Strings Create options. Strings created by the CAD toolbars 
and Strings Create options use values in the controlbars to define string attributes such as name, model and 
colour.

Like toolbars, the type and position on the screen of controlbars is recorded with the project so that when a 
project is exited and then started later, the final position of the controlbars is restored.

Also at any time, a workspace file can be read in and define a new setup and position of the controlbars. For 
more information on using workspace files, please go to the section “Workspace”in the chapter “Projects”.

The three Controlbars will be described in detail in the section “CAD, Symbol and Text Controlbars” in the 
chapter “Strings”:

Snap Toolbar
The Snaps (Horiz) menu has been replaced by the Snaps Toolbar which has the default position at the top left hand side 
of the 12d Model screen, under the controlbars.

CAD controlbar Symbol control bar Text control bar
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Snaps are documented in the section “Snaps”.

snaps toolbar
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Panels
After a menu option has a been selected, extra information is often required before the operation 
represented by the menu option can begin.

For example, before the contour option can proceed, the required contour interval must be 
supplied.

In 12d Model, an object called a panel is used to collect and validate any extra information 
required to run the option.

For example, the Model Information panel is

A Panel consists of four types of areas.

Panel title area

Contains the title (name) of the panel, the buttons to minimize and restore the panel, and the [X] 
button. In the example above, the panel title is model information.

Panel fields

These are both input and output areas for the panel.The user can type answers into some fields 
(input and output fields) or the program may display special information in the fields (output 
only fields). In the example, Model is an input/output field, xmin is only an output field.

If the panel field is optional, then the description text is greyed out - entering data into the field 
will cause the text to be redrawn in black. 

If there are choices available to select from for the panel field, a + is displayed at the right hand 
side of the field. Selecting the + brings up a panel field pop-up (documented below).

Message area

Each panel has its own area where 12d Model displays messages for the option.

Messages are used for a variety of purposes including

▲ indicating the next step in a complex option

▲ reporting errors

▲ giving progress in time consuming operations

panel-title area

panel name buttons to minimize/restorepanel system menu

message area

panel buttons

panel fields

maximize and delete 
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▲ informing that an option has completed successfully.

Most messages are sent to the panel message area but a few are displayed in the Status Bar.

Panel buttons

Buttons are used on the panel to select things or control the processing of the panel. Almost 
every panel has minimize and restore button, and a Finish and [X] buttons which when selected 
will end the option and remove the panel from the screen. All panels also has a Help button 
which brings up on-line help about the panel.

The minimize, restore, Finish, [X] and Help buttons will not be documented for each panel. 

Data Entry in a Panel
To help save the user time, many panel fields have default answers.

However, any panel field value can be replaced by typing in new information (typed input) or 
when available, by selecting an answer from the panel field pop-up or using special name 
completion characters.

All panel fields are validated before the option runs and any error messages displayed in the 
panel message area.

Typed input

To type information into a panel field, move the cursor to the position for the information, left 
click to get focus in the panel field and then start typing. The information will go into the field 
starting at the input-position indicator (a upright bar in the panel field).

The input-position indicator can be moved by 

▲ clicking LB when the cursor is at the new position for input

▲ using the keys   ->, <-, home and end

The backspace key, <backspace>, will delete one character before the input-position indicator 
and the delete key, <del>, will delete one character after the input-position indicator.

The user can move to any field in the panel by using the mouse. The <tab> key will move the 
cursor to the next panel field or button and <shift>+< tab> will move the cursor to the previous 
panel field or button.

Note - the entire field is used as the answer, not just up to the input-position indicator. The input-
position indicator indicates where the characters will go when typing, not the end of the data.

Pop-Up Lists and Menus

The panel field pop- up list or menu, or panel field pop-up, is raised by clicking LB on the [+] or 
other choice icons at the right of the panel field.

A panel field pop-up consists of a list of choices which may be displayed as either a menu or a 
list.
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For a pop-up list, an answer is chosen from the list by double clicking LB over the required 
answer.This answer is then displayed in the panel field and the pop-up list disappears.

For a pop-up menu, an answer is chosen from the pop-up menu by clicking LB over the required 
answer.This answer is then displayed in the panel field and the pop-up menu disappears.

The pop-up list or menu can also be removed without a selection by clicking LB on the [X] on the 
pop-up list or menu, by clicking LB again on the icon or [+] for the panel field, or by simply 
typing into any visible part of the panel field that the pop-up is for (some of the field may be 
obscured by the pop-up itself).

The pop-up lists and menus and the choice icons are described in more detail in the section on 
Special Panel Fields.

Name completion

To help speed data entry a process called name completion is available in most panel fields. 
<ctrl> + <d> is the special key combination used for name completion and how it works will 
now be described.

If one or more characters have been typed into a panel field and the <ctrl> + <d> combination is 
pressed, then 12d Model checks to see how many answers in the available pop-up start with the 
same typed characters. If a unique match exists, then it will be placed into the panel field. If more 
that one match exists, a pop-up menu with all the matches will be presented for the user to select 
from.

Name mapping

When typing a string name into a panel field, a name mapping file can be specified and is used 
to fill out information such as colour, model etc. for given string names.

The name mapping works in two ways. After typing part or all of a string name,

(a) if <enter> is entered, the name map file is searched for a match in the first column (the key).
If a match is found, the name, colour, model, style etc. from the other columns in the name 
mapping file are used to fill out the panel fields.
The key can contain wild cards and/or characters.

(b) if <ctrl> + <d> is entered, the second column of the name mapping file is searched for a list 
of completions which is written to the field if it is unique or displayed in a pop-up if there is 
more than one match. If a * is found in the second column, the first column is used for 
matching. When an entry is selected from the completion list, the name, colour, model, style 
etc. from the columns in the name mapping file are used to fill out the panel fields.

If a name mapping file exists, then the [+] for the name panel field will include the entries from 

Pop up menu from

Pop up list from

clicking on choice icon

 clicking on folder icon
for ’File’ field

for ’Format’ field
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the first column of the name mapping file. If an item is selected from the list, then the name, 
colour, model, style etc. from the columns in the name mapping file are used to fill out the panel 
fields

The name mapping file is pointed to by the environment variable

NAME_MAPPINGS_4D

or is if the environment variable is not set, the default name is names.4d.

During a 12d Model session, the name mapping file can be changed by the Name Settings tab on 
the option Utilities=>Defaults. Note that this new name mapping file is not saved with the 
project.

Validation

After the panel field information is entered, an <enter> key requests that the panel field 
information be validated. Any error message will be displayed in the panel’s message area. If 
there is no error, the cursor will move onto the next panel field. If an error occurs, the cursor will 
remain in the invalid panel field.

New panels or menus can be fired up before completing panels or menus already on the screen. 
This gives the user full control over the work flow, rather than being locked in by fixed 
sequences in a program.

Panel System Menu
The Panel System menu is brought up by clicking LB on the windows icon on the left hand 
corner of the panel title area.

The Panel System menu has options to move, minimize, close and dump the panel.

Dumping a Panel
An image of the panel can be written out to disk in either bmp, tif, jpeg, postscript or as a screen 
layout file or a dialog default file. This is called dumping the panel.

The dump option is selected from the panel system menu which is invoked by clicking the left 
mouse button (LB) on the Windows icon on the left of the panel title area. The Menu/Panel Dump 
panel is then displayed

.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Format input screen layout file bmp, tif, jpeg, postscript,
screen layout file,
dialog default file

format for writing the image to disk.

File input

disk file to write the dump image to.

Dump button
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dump the panel image to disk.

Moving a Panel
A panel can be moved (dragged) by holding down LB anywhere in the menu title area (except 
over the windows icon on the left and the minimize, restore and [X] buttons on the right) and 
then moving the cursor with the LB still depressed. A panel outline appears and moves with the 
cursor to indicate where the new panel position will be. The panel is finally positioned when LB 

Minimizing and Maximizing a Panel
The panel can be minimized (iconized)/restored and maximized using the standard Windows 
minimize/restore and maximize buttons on the top right hand corner of the panel.

Resizing Some Panels
Some panels can be resized in width and have a Resize motif on the bottom right hand corner. For 
example

.

Deleting a Panel
Three methods are available for deleting a panel - picking the [X] button in the panel title area, 
using the finish button or by selecting close from the panel system menu.

ok_panel

OK Panel
The OK panel requires the selecting of the button OK. 

yes_no_panel

Yes-No Panel
The yes no panel requires the selecting of the button yes or no. 

yes_no_cancel_panel

Yes-No-Cancel Panel
The yes no cancel panel requires the selecting of the button yes, no or cancel. 

yes_no_all_cancel_panel

Yes-No-All-Cancel Panel
The yes no all cancel panel requires the selecting of the button yes, no, all or cancel. 

stretched panel

resize motif
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The next section is “Views”.
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Views
Views are the screen drawing areas for 12d Model and come in three flavours - plan, perspective 
and section.

Views can be created and deleted as required by the user and there is no limit to the number of 
views on the screen. Views can be overlapped and minimized.

Each view has a unique name of up to two hundred characters. The view type and name are 
displayed on the top left corner of the view in what is called the view-title area.

 There is an option to list all the views available in a 12d Model session (the view list). The view 
list (or a restriction to those of a specific view type) is also used in various pop-ups and walk-
right menus.

As for menus and panels, each view has a view title area which is used to display the view type 
and name.

View System Menu
The view system menu is brought up by clicking LB on the windows icon on the left hand corner 
of the view title area.

The view system menu has options to move, minimize, close and dump the view.

View Buttons
On the row under the view type and name, are a number of options called view buttons.

The view buttons act like menu items and are activated by clicking LB when the cursor is above 
the button.

view type

view button

and name
buttons to minimize/restore,

view-title area

view system

views

maximize, and delete 

area

area

minimized
view

view

tabs

menu

workbook
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The function of each view button will be described elsewhere in this manual.

View Workbook
If the View workbook mode is turned on, a workbook tab for each view is created at the bottom 
of the Views Area.

If the view is not minimized, then selecting the workbook tab for the view will bring the view to 
the top of the other views. If any of the views are maximized, then selecting any of the workbook 
tabs will bring that view to the top already maximized.

The View Workbook Mode toggles is toggled on/off by the option View => Workbook Mode on 
the Main menu.

Dumping a View
view_dump

An image of the view can be written out to disk in either bmp, tif, postscript format or as a screen 
layout file. This is called dumping the view.

The Dump option is selected from the view system menu which is invoked by clicking the left 
mouse button (LB) on the Windows icon on the left of the view-title area. The View Dump panel is 
then displayed

.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

View input view option is available views
picked from

Plan view buttons

Menu Fit
Pan

Zoom
Shrink

Toggle
Refresh

Plot

Add
Remove

Previous

View Buttons

View system menu
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the view to dump out in the specified format.

Include title tick-cross

if tick, the view title area is included in the dump.

Format input gif bmp, tif, jpeg, postscript

the format to dump the view out in.

File input *.gif

the file to dump the view images out to

Dump button

dump in the given format the image of the view given in the view field to the file given in the file field.

Moving a View
A view can be moved (dragged) by holding down LB anywhere in the view-title area (except 
over the windows icon on the left and the minimize, restore and [X] buttons on the right) and 
then moving the cursor with the LB still depressed. A view outline appears and moves with the 
cursor to indicate where the new view position will be. The view is finally positioned when LB is 
released.

Resizing View
A view can be resized using the standard Windows resize methods.

Minimizing and Maximizing a View
A view can be minimized (iconized), restored and maximized using the standard Windows 
minimize/restore and maximize buttons on the top right hand corner of the view.

Deleting a View
Picking the [X] button in the view-title area or selecting close from the view system menu will 
delete the view.

View Menu
If RB is clicked in the view title area or the view buttons area, a new menu called the View menu will 
appear. To remove the View menu, select [X] from the View menu or click RB again in the view 
title area or the view button area.

Because of the differences between plan, perspective and section views, the options on the View 
menu vary for each view type. For example, the perspective View menu is 
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The View menus will be discussed in the chapter “View Menus”.

Please continue to the next section “Status Bar”.

Status Bar
The Status Bar is used to display many of the messages generated by 12d Model options (each 
panel also has its own special message area) and the dynamic co-ordinate position of the cursor 
as it moves around in any view on the screen.

The co-ordinate values displayed depends on the view type. For example, the world co-ordinate 
(x,y) position of the cursor is displayed when inside plan views, and a (chainage,height) position 
when in a section view.

The messages are displayed on the left hand side of the Status Bar and the view co-ordinates on 
the right hand side of the Status Bar.

The Status Bar is toggled on/off by the option View => Status Bar on the Main menu.

Please continue to the next section “Output Window”.

Output Window
The Output Window displays 12d Model system and error messages.

The Output Window is toggled on/off by the option Window => Output Window on the Main 
menu.

If an error message is sent to the Output Window and the Output Window it is turned off, then 
the Output Window is automatically toggled on to indicate an error has occurred. 

Hence the Output Window can be left turned off and it will reappear when an error message 
occurs.

Please continue to the next section “Data Types”.
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Data Types

Strings
12d Model uses the string as one of its basic modelling elements.

A string is simply an ordered series of vertices or points.

Apart from the first and last vertex in a string, each vertex in a string has a unique previous 
vertex (predecessor) and a unique next vertex (successor). The previous and next vertices for a 
vertex are called its string neighbours. 

The lines joining a vertex with its neighbours are called string links or segments. Segments may 
be straight or arcs, visible or invisible.

The string has an implied direction starting from the first vertex of the string and always 
proceeding to the successor vertex in the string.

The ordering along a strings allows each vertex to be given a vertex index where the first vertex 
has vertex index 1. Note that if additional vertices are inserted or vertices deleted then the vertex 
indices will change. Also note that for super strings, a vertex may have a point id (vertex id, point 
number) which is not the same thing as the vertex index.

A string which has the same first and last vertex is called a closed string otherwise a string is said 
to be open.

Strings are very useful in the modelling of terrain and design surfaces. 12d Model uses a number 
of different types of strings and they are defined as:

2d or contour string

 the z-value is the same at every vertex in the string.

3d string

 the z-value can vary for each vertex in the string.

4d string

the string has (x,y,z) values at each vertex plus text defined at each string vertex. Useful for such 
things as survey stations.

alignment string

this string holds both the horizontal and vertical information needed in defining entities such as 
the centre line of a road. Horizontal intersection points (HIP’s), circles and leading and trailing 
spirals are stored to define the plan geometry. Vertical intersection points (VIP’s) and parabolic 
curves are stored to define the vertical geometry of the string. Alignment strings are essential for 

Vertices forming a string

denotes a string vertex

vertex A

previous vertex next vertex
to vertex A to vertex A

first vertex
last vertex

vertex index 1

vertex
index 2

vertex
index 3

neighbours of A

string links or segments
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describing roads.

arc string

 an arc in a plan projection but with a linearly varying z-value on the circumference. So the arc 
string is actually a 3d helix. The centre point of the arc is for display purposes only.

circle string

 a circle with a constant z-value around the circumference. The centre point of the circle is for 
display purposes only.

drainage and sewer string

 special string made up of straights, arcs and manholes.

feature string

 a circle with a z-value at the centre point but only null values on the circumference.

If a feature string is given a world line style, then the style is centred on the centre point of the 
feature string and scaled up to the radius of the feature string. 

If a feature string is given a screen or paper line style, then the style is wrapped around the 
circumference of the feature string.

interface string

an interface string is a special string constructed from a string and a surface. Each vertex of the 
interface string records whether the corresponding vertex on the original string was above or 
below the surface.

pipe string

 a 3d string with a diameter.

pipeline string

 an alignment string with a diameter.

polyline string

 similar to a 3d string except that there can be straights or arcs joining the string vertices.

super string

a super string is a general purpose string. Each link has visibility, colour and breakline flags and 
values for diameter, radius, text and an unlimited number of user definable attributes. Each 
vertex has tinability, symbol with its own size and rotation, z-value, text and an unlimited 
number of user definable attributes. Segments can be lines, arcs or spirals. Each segment has 
colour, diameter, visibility, tinability, text and an unlimited number of user defined attributes.

super alignment string

like an alignment string, this string holds both the horizontal and vertical information needed in 
defining entities such as the centre line of a road. However the super alignment is not restricted 
to just IP methods for constructing the horizontal and vertical geometry of the string.

control station

control stations are used in the survey reduction option where a name of a station can be given in 
the 12d survey field file and the co-ordinates of the station can given by the control station of that 
name in the specified model of control points. In 12d Model, a Control station is represented by a 
one vertex 4d or super string and the name of the control station is the name of the one vertex 
string. Usually the point id for the vertex of the super string, or the text for the 4d string, is also 
the Control station name.

text string
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 a text string has an (x,y) position and contains characters and information about how the 
characters are displayed (textstyle, units, height, offset, raise, justification, angle, slant and x 
factor).

String Chainage
Every vertex along a string has a unique chainage value. This chainage is calculated by taking 
the start chainage defined for the first vertex of the string, and adding to it the plan distance 
along the string from the start vertex to the selected vertex on the string.

Breakline Type
When triangulating data, the sides of non-crossing strings can be preserved as the sides of 
triangles. Such strings in 12d Model are called breakline or line strings. Non-breakline strings 
are called point strings.

For triangulation purposes, each of the string types 2d, 3d, 4d and polyline can be used as either 
breaklines (line strings) or not (point strings).

Line strings are useful in describing terrain features such as ridge lines and creek beds or design 
features such as the edge of a building platform. Point strings can represent information such as 
spot heights.

Alignments, arcs, circles, pipelines, interfaces, drainage and sewer strings can only be breakline 
strings. Feature strings can only be point strings with a z-value at the centre of the circle.

Tinable
For a super string, the concept of breakline has been extended to a property called tinable which 
can be set independently for each vertex and each segment of the super string.

If a vertex is tinable, then the vertex is included in triangulations. If the vertex is not tinable, then 
the vertex is ignored when triangulating.

If a segment is tinable, then the segment is used as a side of a triangle during triangulation. That 
is, the segment is used as a breakline. This may not be possible if there are crossing tinable 
segments.

Note that for a segment to be used as a side of a triangle, then its end vertices must also be 
tinable.

Linestyle and Colour

angle

offset

raise
Te

xt
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All strings (except text) can be given a user defined linestyle or simply style.The style describes 
how the string is drawn on the screen and on plots. The default style is 1.

A style can also be continuous or just at the vertices of a string, regardless of the breakline type of 
the string. A breakline string (line string) with default style 1 will be drawn with solid lines 
between the nodes, and a non breakline string (point string) with default style will be drawn 
with crosses at the string nodes with no visible lines between the nodes.

Strings have a default colour but how that colour is used depends on the breakline type and style 
of the string. For example, a line string with default style 1 is drawn with the string’s links in the 
string colour and for a point string with default style 1, crosses are drawn at each string point in 
the string colour. However, styles can have their own colours which override the default colour 
of the string. Interface strings have two colours (red and green) which are used to represent cut 
and fill information.

Hence, 2d, 3d and 4d strings with default styles appear on the screen as

point string (non breakline string)

each string link is considered to be an invisible line. String values are not defined along the 
string links.

line string (breakline string)

each string link is considered to be a solid line. String values are defined along the string links by 
linear interpolation between the end points of the string link.

Name and Model

Strings have a text name of up to two hundred alphanumeric characters, spaces and dots (.). The 
string name does not have to be unique and can be blank. When strings are created, they are 
stored in models. A string is in one and only one model. Models are discussed in the next 
section.

Models
Within a 12d Model project, information is collected in units called MODELS. Models contain 
strings and tins (see the next section).

Each model has a unique user-defined text name of up to two hundred alphanumeric characters 
and spaces.

For convenience, model names should reflect the nature of the information in the model. For 
example, a model containing terrain data could be called terrain. design could be another model 
containing design data.

Each model has minimum and maximum x, y and z values which define a bounding box which 
encloses all the data in the model (the model bounding box). The size of the model bounding box 
is automatically updated as new data is added to the model, but not adjusted as data is deleted. 
A re-calculation of the model bounding box is performed by the calc extents buttons on the 
model and view information panels.

There is an option to list all the models available in a 12d Model session (the model list). The 
model list is also used in various pop-ups and walk-right menus.

Displaying Models

The screen display areas in 12d Model are the views. Models are displayed in views by “adding” 
the model to the view. Similarly, when a model is “removed” from a view, it is no longer 
displayed in that view.
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There are options in the 12d Model menu and on each view to add and remove models from 
views.

Tins
To form a continuous surface representing the data in a model, a process called triangulation is 
used. Triangulation creates a web of non-overlapping triangles whose nodes are the model data 
points. Because the data points are normally irregularly spaced, the triangulation is referred to as 
a TIN - a Triangulated Irregular Network.

For 2d, 3d, 4d and interface strings, all non null points are included in the triangulation. For 
super strings, only vertices that are tinable are included in a triangulation.

To allow the triangulation to accurately represent features such as ridge lines and creek beds, the 
links of breakline strings (line strings) are preserved as edges of triangles in the tin.

For a super string, only segments that are tinable and whose end vertices are also tinable, are 
included as break lines.

Each tin is given a unique user-defined name of up to two hundred alphanumeric characters and 
spaces.

Unlike strings, tins can be in more than one model, or even no model at all. However, to be 
displayed in a view or used for profiling on a section view, tins need to be in at least one model. 
It is suggested that each tin be in its own model called “tin tin_name”. This makes it easy to 
know the model a tin is in, and also to see which models contain tins and obtain lists of all tins 
when using <ctrl> + <d> for name completion.

There is an option to list all the tins available in a 12d Model session (the tin list) which also 
displays the models the tin is in as a walk-right. The tin list is also used in various pop-ups and 
walk-right menus.

Tins can be “added” and “removed” from models with options in the triangles option in the 
12d Model menu. If a tin is to displayed in a view, it must be “added” to a model that is being 
displayed in that view.

Tins can only be deleted by using the Triangles=>Delete options - for safety, they are not deleted 
when any model containing them is cleaned or deleted.

WARNING

Tins are stored with copies of the points that were triangulated. If the original points are then 
modified, the triangulation will not reflect this change.

Templates
Templates are used as a quick and easy method for defining design details along a string for use 
in conceptual and detail designs, and visualizations. Templates are stored with each project but 
can be written out and read in using a readable file format.

Projects
In 12d Model, information is organised into projects.

When 12d Model begins, the user specifies the name of the project to work on. A project name 
can be up to two hundred alphanumeric characters and spaces.

All the information created for that project is kept together in a special folder called the project 
area.

The project area contains all the models, templates and tins associated with the project. Copies of 
models and tins created in other projects can be added to another project from within 12d Model.

External data files can be read into the project (imported) using special input options. Similarly, 
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output options are provided to write data out for use in other software packages (exported).

Please continue to the next section “Tick Box”.
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Tick Box
Many items require a mode to be either on or off.

In 12d Model, there is a special box with a tick to indicate that the setting is on and nothing to 
indicate that the setting is off.

In a tick box, the tick is changed to the nothing state by clicking LB in the box surrounding the 
tick or clicking LB on the item name field for the tick box.

Please continue to the next section “Picking Strings”.

tick box ticked on

tick box ticked off

item name field
for a tick box

Click LB anywhere
in the item name field
or in the box itself
to toggle between
tick or no tick
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Picking Strings
In many 12d Model options, the user is required to “pick” the string to be used in the option, or 
to get information about a string.

After any option requiring a pick is selected, a message regarding the function of the mouse 
buttons is written to the screen message area.

<option> [picks][fast][menu]

There are three picking method available in 12d Model:

(a) fast pick where the pick and the accept occur as one operation

(b) fast accept where the if there is only one item satisfying the snap conditions then it is 
automatically accepted but if there is more than one, the tentative pick mechanism is used

and

(c) tentative picks with a separate pick and accept mechanism

Fast pick will be documented first, followed by fast accept and tentative pick (pick and accept).

Fast Pick
To fast pick a string, simply move the cursor near the string and click MB or type <enter>. The 
nearest string to the cursor satisfying the snap conditions is selected.

Fast pick is used when the F snap is on.

Various snap modes can be set for the fast pick. The available snaps are point (vertex), line, grid, 
tin and cursor. One or more snaps can be set simultaneously. The snaps are described in more 
detail in the section “Snaps”.

Fast Accept
To fast accept a string, simply move the cursor near the string and click LB or type <enter>. If 
there is only one string satisfying the snap conditions, then it is automatically accepted. 

If there is more than one string satisfying the snap conditions, the nearest string to the cursor 
satisfying the snap conditions highlighted and an information menu containing information 
about the selected string is displayed.

If the correct string has been tentatively picked, click MB or type <enter> accepts the string. If 
the incorrect string is tentatively picked, click LB and the next closest string satisfying the snap 
conditions will be highlighted. See the section “Tentative Pick” for more information on tentative 
picking.

Fast accept is used when the A snap is on.

Various snap modes can be set for the fast pick. The available snaps are point (vertex), line, grid, 
tin and cursor. One or more snaps can be set simultaneously. The snaps are described in more 
detail in the next major section “Snaps”.

Tentative Pick
information_al information_poly
To tentatively pick (or tentatively select) a string, move the cursor near the string and click LB. 
The nearest string to the cursor satisfying the snap conditions (see the next section on Snaps) is 
highlighted and an information menu containing information about the selected string is 
displayed (the information varies for each string type- see the section “String Information”in the 
chapter “Strings”).
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The information menu disappears if the cursor is moved slightly.

The string name, the string model and the mouse button functions are also displayed in the 
Status Bar when the picked string is highlighted:

<option> [selects][accepts][menu] “model->string name”

If the correct string has been tentatively picked, click MB or type <enter> to accept the string. If 
the information menu was still up, it disappears when the string is accepted.

Note - if the information menu does not appear when a string is highlighted, then the information 
snap may be set to off. See the section “Snaps”.

Tentative Picking and Repicking
If one string is tentatively picked (and highlighted) but another string was intended to be picked, 
click LB again without moving the cursor and the next nearest string to the current cursor 
position will be selected, highlighted and an information menu put up for it. Any strings already 
rejected during the pick will be ignored. Continuing to click LB again without moving the cursor 
will sequentially pick the next nearest string and ignore the earlier rejected strings.

To allow all strings to be eligible for picking again, simply move the cursor a small distance (the 
reset distance - default five pixels) and start picking again. This will automatically reset the 
rejection list.

Pick Ops Menu
pick_ops

Options to allow all strings to be eligible for picking again, to cancel the pick operation and to 
accept a picked string are all available from the Pick Ops menu.

The Pick Ops menu appears whenever RB is clicked whilst in the pick option. The Pick Ops menu 
is
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To allow all strings to be eligible for picking again, select Restart from the Pick Ops menu. This 
has the same effect as moving the cursor the reset distance.

To cancel the pick without selecting any string, select Cancel from the Pick Ops menu.

Selecting Accept from the Pick Ops menu, accepts the current picked string. This is the same as 
clicking MB without calling up the Pick Ops menu.

The Find by name option allows the user to specify a string name to restrict the pick by. This 
options is also available in the snap option and will be described there.

Selecting Info will redisplay the information menu for the string.

If Vertex/HIP/VIP number, is selected, the enter vertex/hip/vip number box is displayed.

Typing the number into the box terminated by <enter> will move the pick position to that vertex 
or IP point.

If Chainage is selected, the Enter Chainage box is displayed.

Typing a chainage into the box terminated by <enter> will move the pick position to that 
chainage on the tentatively selected string.

Alignment and 
Pipeline strings

For most other 
string types
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enter_relative_vertex_index

If -(n) vertices or +(n) vertices is selected, the Enter relative vertex index box is displayed.

Typing a positive/negative number into the box terminated by <enter> will move the pick 
vertex to that many vertices after/before the selected position on the tentatively selected string.

The left and right arrow keys (<-, ->) can also be used to move the pick position to the previous 
or following vertex respectively.

To remove the Pick Ops menu without selecting an option, either select the [X] button from the 
Pick Ops menu title area or simply click RB again whilst the cursor is in a view.

Various snap modes can be set for the pick. The available snaps are point, line, grid, tin and 
cursor. One or more snaps can be set simultaneously. The snaps are described in more detail in 
the next section.

Picking with Direction
Picking a string is one operation where 12d Model is monitoring the cursor position when 
button LB (or MB for fast pick) is pushed down and also the cursor position when button LB 
(MB) is subsequently released.

The pick position is taken as the cursor position when button LB (MB) is released, but the 
difference between the down and up positions for button LB (MB) defines a direction vector or 
sense to the pick. This direction is called the picking direction or picking sense.

The picking direction is used in a number of 12d Model options.

For example, in the information panel displayed for any picking operation, if the picking 
direction is the same as the string direction, a +ve is displayed at the bottom of the panel. If the 
directions are opposite, then a -ve is displayed in the panel.

Important Note
If a string was picked with direction, then to automatically reset the rejection list, the cursor must 
be move fifty (50) pixels rather than the five required for a non-directional pick.

Summarising the 12d Model Picking Mechanisms
Tentative picking - pick and accept as separate operations

LB - left button select the next nearest string.
moving the cursor more than five pixels resets the rejection list for
 a non-directional pick.
moving the cursor more than fifty (50) pixels resets the rejection

 list for a directional pick.

MB - middle button accept the current selected (highlighted) string - ends the pick.

RB - right button brings up the Pick Ops menu.

Typing <enter> same as MB: accepts the current selected (highlighted) string - ends
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the pick

Fast accepting - pick and accept in one operation if there is only one item satisfies the snap 
conditions or a tentative pick if more than one item.

LB - left button select the next nearest string. If there is only one item possible then
it is automatically accepted. Otherwise it is the same as for a
tentative pick.
moving the cursor more than five pixels resets the rejection list for
 a non-directional pick.
moving the cursor more than fifty (50) pixels resets the rejection

 list for a directional pick.

MB - middle button accept the current selected (highlighted) string - ends the pick.

RB - right button brings up the Pick Ops menu.

Typing <enter> same as MB: accepts the current selected (highlighted) string - ends
the pick

Fast picking - pick and accept in one operation

MB - middle button pick and accepts the nearest string.
or

Typing <enter> same as MB: pick and accepts the nearest string - ends 
the pick.

Please continue to the next section “X Y Z and Ch Ht Typed Input Box”.
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X Y Z and Ch Ht Typed Input Box
Many 12d Model options use a cursor select (picking) in a view to pick strings, obtain information 
about a string, get an x, y and z co-ordinates for a new vertex etc.

In most cases, typed input can also be used to enter the information instead of using the cursor 
select. For example, an exact values for the x, y (and possibly z) co-ordinates could be typed in or 
a chainage and a height typed in rather than picking a position on a view.

Typed input is available in 12d Model whenever a cursor select is used.

To use typed input, simply begin typing the values. As soon as a character is typed, a special 
typed-input box appears on the screen and the typed characters are automatically placed in it.

Alternatively, instead of clicking LB to select a string, click RB to bring up the Pick Ops menu 
and then select Typed Input from the Pick Ops. This will also bring up the typed input box.

Depending on the view type that the cursor is over, the typed input box will be either an Enter X Y 
Z or an Enter Ch Ht box. If the focus is on a Plan or Perspective view, then an Enter X Y Z box 
comes up. If the focus is on a Section view, then an Enter Ch Ht box appears. These are also called 
the XYZ typed input box and the Chainage Height typed input box respectively.

The x, y (and possibly z) co-ordinate values or chainage height required by the box are simply 
typed in, each value being separated by one or more spaces.

An <enter> terminates the typed input and sends the entered values to the option. The typed-
input box then disappears.

If the user wishes to abort the typed input and return to mouse input, simply select the [X] 
button on the typed input box, or type <enter> with no values in the typed input box.

The Enter X Y Z/Ch Ht box can be moved (dragged) to a new position on the screen in the 
standard way.

The default mode for the Enter X Y Z box is to receive absolute x, y and z values.

However, by typing special character codes before the values, the Enter X Y Z box can be used to 
enter data in a variety of formats including relative co-ordinates and bearing-distance 
combinations.

The full list of typed input codes now follows (the text will be given in lower case, but it can be 
typed in either upper or lower case).

▲ actual x actual y actual z

x y z
              or

a x y z

▲ relative x  relative y relative z

r x y z

▲ bearing in degrees-minutes-seconds distance actual z

bd ddd.mmssfff distance

where ddd.mmssfff is the bearing expressed in degrees,
minutes and seconds as
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ddd whole degrees

. separator between degrees and minutes

mm whole minutes

ss whole seconds

fff fractions of seconds (as many as required)

▲ bearing in decimal degrees distance actual z

dbd ddd.dd distance z

▲ angle in degrees-minutes-seconds distance actual z

ad ddd.mmss distance z

▲ angle in decimal degrees distance actual z

dad ddd.dd distance z

The default mode for the Enter Ch Ht box is to receive chainage and height values.

However, by typing special character codes before the values, the Enter Ch Ht box can be used to 
enter data in a variety of formats including grade distance and slope distance.

The full list of typed input codes now follows (the text will be given in lower case, but it can be 
typed in either upper or lower case).

▲ actual chainage actual height

chainage height
              or

a chainage height

▲ relative chainage relative height

r chainage height

▲ slope and distance

sd slope distance

where slope is 1 vertical in slope horizontal units

▲ grade and distance

gd grade distance

where grade is 1/slope as a percentage

Please continue to the next section “Tentative Typed Inputs”.

Tentative Typed Inputs
If the string has been tentatively selected (by clicking LB and highlighting the string but not yet 
accepting it), then further typed inputs are available which then work for the highlighted string 
only.

The Tentative typed inputs are:

CHchainage go to the given chainage

Vvertex-index go to vertex index
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HPnumber go to horizontal IP number "number"

VPnumber go to vertical IP number "number"

+ go to the next vertex

-> (right arrow) go to the next vertex

+number go forward number vertices

- go back to the previous vertex

<- (left arrow go back to the previous vertex

-number go backward number vertices

When a string is tentatively selected, the above typed input options are also available as menu items 
from the Pick-Ops menu. This has been documented in the section “Pick Ops Menu” in this 
chapter.

Please continue to the next section “Picking Point Ids (Point Numbers, Vertex ids)”.
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Picking Point Ids (Point Numbers, Vertex ids)
When a 12d Model option uses a cursor select (picking) in a plan view to pick strings, then typed 
input can be used to select a point id (point number, vertex id) which exists in any model on the 
view (note that a point id can be numeric or alphanumeric).

When over the plan view, instead of clicking LB to select a string, simply type:

number to select a numeric point id

or

Ptext to select an alphanumeric point id of name text.

This will bring up the Enter X Y Z box and the typed information will go into the box. Type 
<enter> and the view will then be searched for the given point number.

If the point id exists, then a large cross will be drawn over the vertex on the view and the string 
containing the point id will be highlighted.

Note that if a string is tentatively selected (i.e. highlight but not yet accepted), then 

Vn will select the nth vertex of the tentatively selected string (vertex index of n)

Please continue to the next section “Snaps”.
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Snaps
In most 12d Model options, the mouse is used to pick data from a string displayed on the screen.

Unfortunately different options usually require different data so an easy method is needed to 
help select from all the strings on the screen, a specific string or part of a string.

In 12d Model, Snaps are used as part of the string picking mechanism (discussed in the previous 
sections) to help filter out what data is interactively selected on a view.

Using the 12d snaps it is possible to

▲ restrict any string picks to selected string names and/or models

▲ set modes which are used to determine what parts of strings are used for picking

▲ set the search distance for picking vertices (point snap tolerance)

▲ set the search distance for picking (snap tolerance)

▲ give the name of a tin to be used to set z-values at a (x,y) position

▲ set whether the user is prompted for a new height (z-value) after every point edit

▲ turn off the information menu when picking

Point and Line Snaps
When trying to interactively pick a string in 12d Model, the user moves the cursor near the string 
in a view and clicks LB (or the MB for a fast pick). 12d Model then makes a search of all the 
strings on the view to make a selection.

The help restrict the search, only strings that are partially or totally within an x and y distance 
called the snap tolerance of the cursor are eligible for picking. That is, only strings that have part, 
or all, of them within the snap box can be selected.

For strings inside the snap box, 12d Model has two snap modes, point and line, to specify which 
parts of the strings can be selected.

If point snap is set on, the vertices (points) of a string can be selected. If only point snap is on, 
then the string containing the closest vertex to the cursor is selected.

If line snap is set on, then the position on the string that is determined by dropping the cursor 
perpendicularly onto the string, can be selected. Note that there is usually no string vertex at the 
perpendicular position (line snap position). If only line snap is on, then the string containing the 
closest perpendicular position to the cursor is selected.

snap tolerance
cursor position

distance
string is outside the
snap tolerance and
can’t be picked

string is partially within
the snap box and
is eligible for picking

denotes a string vertex

Snap Box
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Since in general it is rare for a vertex of a string to be closer to the cursor than the line snap 
position, then with only the above definitions and point and line snap both on, the line snap 
position usually wins. Hence to pick a vertex, line snap would have to be turned off. Since this 
can lead to line snap being regularly toggled on and off, another distance called the point snap 
tolerance has been introduced to give vertices priority over line snaps when both snaps are on.

When point snap is set on, any vertex of a string that is within an x and y distance called the point 
snap tolerance of the cursor when LB is clicked, is considered for selection before any other type 
of snap is considered. That is, any vertices in the point snap box are selected before any line snap 
positions.

In the area between the point snap box and the snap box, vertices and line snap positions are 
treated equally and the closest one to the cursor is selected.

The other types of snaps are not as complicated and will be discussed in the following sections.

denotes a string vertex

the position on the segment
of the string which is the
cursor position dropped
perpendicularly onto the string

line snap position -

snap tolerance

point snap
tolerance

line snap position

this vertex is selected rather
than the line snap position
because it is inside the
point snap box

Point Snap Box and Snap Box
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Setting Snaps
Snaps can be toggled on and off from the snaps tool bar, or the snap settings can be set from the 
Snaps menu under Utilities on the Main menu.

The Snaps (Vert) option brings up a Snaps toggle menu similar to the Snaps toolbar except that the Snaps (Vert) 
runs vertically rather than horizontally. Either can be used to toggle the snaps on and off.

The option Utilities=> Snaps =>Snaps option brings up a menu that provides tick boxes to turn 
the various snap modes on or off plus it is used to set the snap tolerance value, the point snap 
tolerance value, the tin for tin snaps and string and/or model names for restricting the snaps.

Any combination of snap modes and names can be set.

The Snaps menu is

snaps toolbar

The menu Utilities =>Snaps is:

Point
Line
TeXt

The Snaps (Vertical) menu Grid
Cursor
Height
Tin
Segment
Info
Data tip
Fast pick
fast Accept
Konstruction

Snaps toolbar
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The snaps point, line, grid, cursor, tin and info are all set on or off using the tick-cross boxes.

The snap tolerance is displayed on the Tolerance line of the menu.

The point snap tolerance is displayed on the Pt tolerance line of the menu.

When a select with snap is made, the type of snap is given in the Information panel and also 
graphically displayed by changing the shape of the snap cursor. The shape of the snap cursor is 

a diamond for a point snap
   square for a line snap
   circle for a cursor snap
   circle for a grid snap
   squiggles under a line for a tin snap.

Each of these snaps/settings will now be discussed.

Point Snap - diamond

When point snap is set on, any vertex of a string within the point snap box around the cursor 
when LB is clicked, is considered for selection before any other type of snap is considered. 
Centres of circles, centres of arcs and arc end points are considered to be vertices.

Note that if there are no vertices within the point snap box then any vertices within the snap box 
of the cursor are considered for selecting

Line Snap - square

When line snap is set on, the cursor only needs to be within the tolerance distance of any visible 
segment of a string when LB is clicked, and that string is considered for selection. Also arcs and 
circles are considered for selection.

Note that if a non-zero point snap tolerance is given and point snap is set on, then any vertices 
that are closer than the point snap tolerance to the cursor will be considered for snapping before 
any line snap is considered.

Grid Snap - circle

When grid snap is set on, the cursor will snap to the intersection of any grid lines that are 
displayed in a view.

point snap on/off
line snap on/off
text snap on/off
grid snap on/off
allow cursor point on/off
ask for z value at each point in edits
name of tin to snap to
tin snap on/off
turn segment snap on/off
restriction on string names
restriction on model names
set snap tolerance
set point snap tolerance
bring up info panel on/off
turns data tips on/off
turns fast pick snap on/off
turns fast accept snap on/off
turns fast construction snap on/off
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Cursor Snap - circle

If cursor snap is set on and the other snaps are either not set on or have failed, the cursor position 
is used for the (x,y) and possibly the z value of the pick.

Tin Snap - squiggles under a line

Tin snap means that when an (x,y) point is selected, the z-value for the point is taken to be the z-
value on the tin at the same (x,y) position.

To use tin snap, the name of the tin to snap to must first be given. Then, snapping to that tin is 
controlled by the state of the tin snap tick box.

If the tick box is on (a tick), snapping to the tin is used.If the tick box is off, no tin snaps are used.

The name of the tin to snap to is set by selecting the Tin " " item on the Snaps menu to bring up the 
Snap Tin panel.

Model

The user can restrict the snap to only strings from a specific model. The name of the model to 
restrict the snap to is set by selecting the Model " " item on the Snaps menu to bring up the Snap 
Model panel.

Name

The user can restrict the snap to only strings of a specific name. The name of the strings to restrict 
the snap to is set by selecting the Name " " item on the Snaps menu to bring up the Snap Name 
panel.

 When 12d Model creates a new project, line and point snap are set to on and all other snaps set 
off.

Point Snap Tolerance

Point snap tolerance is not a tick box but a menu item. The point snap tolerance value is the 
distance to be used for considering vertices over anything else when point snap is on.

The point snap tolerance distance is given in screen units (pixels). There are one thousand pixels 
per screen width, hence a point snap tolerance of say 10 means that the point snap distance about 
a vertex is one hundredth of the screen width.

The point snap tolerance is given in terms of screen units rather than world units because it is a 
distance on the screen, independent of any co-ordinate system being used in a view.

The current point snap tolerance value is displayed as Pt tolerance on the Snap menu.

The Point snap tolerance is modified by selecting the Pt tolerance item on the Snaps menu to bring 
up the Point Snap Tolerance panel.

Snap Tolerance

Snap tolerance is not a tick box but a menu item. The snap tolerance value is the distance to be 
used for considering data when snaps are on.

The snap tolerance distance is given in screen units (pixels). There are one thousand pixels per 
screen width, hence a snap tolerance of say 50 means that the snap distance about a point, line 
etc. is one twentieth of the screen width.

Snap tolerance is given in terms of screen units rather than world units because it is a distance on 
the screen, independent of any co-ordinate system being used in a view.

The current snap tolerance value is displayed as Tolerance on the Snap menu.

The Snap tolerance is modified by selecting the Tolerance item on the Snaps menu to bring up the 
Snap Tolerance panel.

Height
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If height is set, then when creating and/or editing strings, the z-value for a vertex is displayed.

Info

If info is set, then the information panel comes up whenever a string is picked.

Data Tip

If data tip is set, then data tipping for strings occurs.

Fast Snap

If fast snap is set, then fast picking is allowed.

NOTE: The Text snap (X) and Segment snap (S) are currently under development.

Summarising, the available snap modes are

▲ point - diamond cursor

▲ line - square

▲ grid - circle

▲ cursor - circle

▲ tin - squiggles under a line

▲ name

▲ model

On starting up a new project, point and line snap are on, all others off, point tolerance is set to 10 
and tolerance is set to 50.

When an existing project is saved, the snap settings, point snap tolerance, snap tolerance and 
positions of any snaps menus on the screen, are also saved.
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Expressions in Panel Fields

Non Bearing/Angle Panel Fields
Whenever a real value such as height or width is required in a box (other than an angle or 
bearing panel field), mathematical expressions can be typed in and then evaluated by 12d Model 
when <enter> is pressed. See the section “Expressions in Bearing, Angle Panel Fields” for what is 
allowed in angle/bearing panel fields.

Expressions can be made up from the operators

* multiply
/ divide
+ addition
-  subtraction 

where * and / take precedence over + and -.

Nested brackets "(" and ")" are supported to any level.

The following functions are also supported

sin
cos
tan
sqrt
square
null

Note that for the trigonometric functions, the angle is in degrees, minutes and seconds (see 
section on Angles and Bearings) and is either a cartesian angle or a bearing depending on the 
setting of the Angle mode in the System Settings tab of Utilities=>Defaults.

For example, cos(90) is 0 for a Cartesian angle of 90 or 1 for a bearing of 90 degrees.

Examples of expressions are:

10.0 + 19.7

sin(90.30)

(10 + sin(45))/3.0

After the expression has been evaluated, it is still possible to bring back the last expressions, 
make modifications to the expression and then re-evaluate it.

To get the last expression, simply click on the [+] button at the end f the field to bring up the 
measures menu and select Last expression from it. The last expression is then returned to the 
panel field ready for modifications.

Warning
Expressions are not supported for bearing/angle boxes - 

Please continue to the next section “Special Panel Fields”.
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Special Panel Fields

Pre*Postfix Panel Fields
In many options in 12d Model, text needs to added to the beginning (prefix) of name and also 
added to the end (postfix) of a name. For example, the 

Instead of needing a panel field for the prefixed text and another for the postfixed text, 
12d Model often used a special shorthand notation called pre*postfix to combine the two into 
one text field.

When the word "pre*postfix" is used on a panel field, it has the special meaning that for any text 
type into the panel field, any text before the * is considered to be text for prefixing, and any text 
after the * is taken to be text for postfixing. Note that spaces are significant.

Hence "E * m" means that "E " is prefix text and " m" is postfix text.

If prefix text only is required, just give the text since the * is not required at the end of the text. 
For example "E " or "E *" will prefix the text "E ".

If postfix text only is required then the text must be preceded by a *. For example "* m" will 
postfix the text " m".

For example, if a panel field had

Pre*postfix for models new * data

then "new " would be added to the beginning of the model names and " data" would be added to 
the end of the model names.

Data Source
select_choice

Many options contain the panel field Data source which may have one or more of the selection 
choices:

string, model, view, window, rotated window, polygon, lasso, model list, filter, favourites

Depending on the choice, the next panel field will be changed to suite the choice.

For example, for the choice Model, the next field will be Model.



Chapter 3  Tools and Concepts

May 2007 Page 123Special Panel Fields

 

In the documentation for a panel with a data source, only the panel for Data Source type Model 
will be shown.

Data Target
Many options contain the panel field Data target which may have one or more of the selection 
choices:

move to original model(s)/replace // process the original data and leave in models
move to one model // move the processed data to one model
move to many models // move processed data to models with the same

// names as the original models except the model
// names are pre/postfixed by given text.

copy to original model(s)/replace // process copies of the data and leave in models
copy to one model // process copies of the data and place in one model
copy to many models // process copies of the data and place in models with

// the same names as the original models except the
// model names are pre/postfixed by given text.

Depending on the choice, the next panel field will be changed to suite the choice of target.

For example, for the choice Copy to one model, the next field will be Copy to model.

data source

data

select
create
window

select

string
existing

window

polygon
existing

create
rotated

create
lasso filter

source

types

select

model
existing

select

view
existing

selected

favourites

model
list
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In the documentation for a panel with a data target, only the panel for Data Target type Copy to 
Model will be shown.

data source

data

select
create
window

select

string
existing

window

polygon
existing

create
rotated

create
lasso filter

source

types

select

model
existing

select

view
existing

selected

data
target
types

process original
data and leave results
in the original models

process original data
and move results
to one model

process original
data and move results
to new models with
the same names except
pre/postfixed by
given text

process copies of the
data and leave results
the original models

process copies of the
data and place results
in one model process copies of the

data and place results
in new models with
the same names except
pre/postfixed by
given text

favourites

model
list
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Pop-Up Lists and Menus
select_colour   select_linestyle   select_model   select_name   select_text_style    

select_tin   select_choice   choice   choice_measure   select_view    select_symbol    

If there are choices available to select from for the panel field, there is a [+] or another special icon 
displayed at the right hand side of the panel field.

For example, icons that may be used in place of the + are:

Clicking LB on the one of the above icons or a [+] brings up a the panel field pop-up list or pop 
up menu.

A panel field pop-up consists of a list of choices which may be displayed as either a menu or a list

choicemodel

file tin textstyle info

line weight

view

line style polygon symbol

XYZ X

colour when
none selected

project

chainage 

selectstring name

selected colour

angle

date/time function typed input

ID plotter/printer

Z Y

same as
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For a pop-up list, an answer is chosen from the list by double clicking LB over the required 
answer.This answer is then displayed in the panel field and the pop-up list disappears.

Pop-up list from 
clicking on the 
folder icon for the 
File field

Pop-up menu 
from clicking on 
the choice icon for 
the Format field

Pop-up list from              
clicking on colour icon 
for the Colour field
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At the bottom of some pop-up lists is a [Sameas] button. If [Sameas] is selected then an object with 
the require property is selected using the mouse and the value from the selected item is written 
to the panel field.

For some options, more than one selection from a list can be made. In that case, simply use the 
standard Microsoft methods for multiple selections and then click on Select.

For a pop-up menu, an answer is chosen from the pop-up menu by clicking LB over the required 
answer.This answer is then displayed in the panel field and the pop-up menu disappears.

If there are more than twenty five choices to be displayed in a pop-up menu (or the number 
Popup length in the panel Defaults), the list of choices will be split up alphabetically into sub-lists 
with walk-rights to access each of the sub-lists, A pop-up list has scroll bars on the list if it is 
longer than the pip-up length.

The pop-up list or menu can also be removed without a selection by clicking LB on the [X] on the 
pop-up list or menu, by clicking LB again on the choice icon or [+] for the panel field, or by 
simply typing into any visible part of the panel field that the pop-up is for (some of the field may 
be obscured by the pop-up itself).

textstyle_info
textstyle_data
select_textdata

Textstyle Info and Textstyle Data
There is now a textstyle info panel field for 

defining the text parameters. Clicking on 
the textstyle info icon brings up the Select 

Textdata pop-up menu which lists the textstyle favourites. By clicking on [Edit], the Textstyle Info 
panel is brought up and all the definitions for the text style can be modified and written to the 
textstyle info panel field by clicking on Set.
Textstyle favourites are defined in the Browse option Projects=>Browse=>Textstyle data favourites 
and documented in the section “Textstyle Data Favourites” in the chapter “Projects”.

Note that there is a Textstyle Data panel that is identical to the Textstyle Info panel except that it 
doesn’t have the Colour field. The Textstyle Data panel is brought up by clicking on the A on the 
Text toolbar.
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Scrolling Panel Tables
Many 12d Model panels include tables or lists of information which hold an unlimited number 
of lines or rows. The tables may have more than one column but the number of columns is fixed 
for that table.

Such tables are displayed and edited in a scrolling panel table.

For example, the Fixed Template panel can contain an unlimited number of lines (rows) defining 
fixed links for the template.

Normally a set number of lines of the table are displayed in the scrolling panel table and once 
the number of lines exceeds the set number, the up and down arrows on the right hand side of 
the scrolling panel table are needed to scroll the lines up or down to see the extra information.

Each column of the panel table normally has a column header such as width and height in the 
above example of the Fixed Template scrolling panel table.

The numbers on the left hand side of the scrolling panel table indicate the line (row) numbers of 
the information being displayed and the line numbers are also buttons which when selected, 
bring up the Edit Line n panels. For example

The options on the Edit Line n panel have the following functions:

clear clear the current line
copy copy the current line into the next line; all following lines are pushed

down
delete delete the current line
insert insert a blank line; the current line and all following lines are pushed

down
up swap the current line with the preceding line
down swap the current line with the following line
Also, when the number on the left is selected, typing <del> will delete the line

<insert> will insert a line.

column
headers

rows
lines or
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File Box
12d Model panels frequently include a field for entering a file name. This type of panel field is 
called a file panel field or box, or simply file box.

When RB is clicked on the [+] at the right of the panel field to bring up the list of available files, 
the pop-up menu can contain up to five different types of items:

(a)  list of local files satisfying the file ending for the file box

(b)  [Lib] button

(c) [User lib] button

(d) [Browse] button

(e) [Edit] button for some special files which have an internal 12d Model editor

(f) [Edit file]

For example, 

The special menu items, [Lib], [User Lib], [Browse], [Edit] and [Edit file], in the file box pop-up list 
and menu have the following meanings:

[Lib] the walk-right lists all files satisfying the file box ending, in the library 
pointed to by the environment variable LIB_4D (see Appendix A)

[User Lib] the walk-right lists all the files satisfying the file box ending, in the user 
library pointed to by the environment variable USER_LIB_4D (see Appendix 
A)

[Browse] selecting browse brings up the Microsoft File Browser which can be used to 
search for a file with a specified ending in the local or other directories. 

local files
walk-right of files in the library
walk-right of files in user library
browse for the file
edit with special 12d Model editor
edit the file whose name is in the file bo

pop up list pop up menu
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[Edit] selecting edit will bring up the special 12d Model editor for the file. For 
example, for map file. The edit only exists when a special 12d Model editor 
exists for the file type.

[Edit file] selecting edit filet when there is a file name already in the file box, will edit 
the file using the editor pointed to by the EDITOR_4D environment variable.

Model Panel Field
12d Model panels frequently include a field for entering the name of a model. These fields are 
called model panel fields or simply model fields.

Because models are often required to be displayed on views and hence, need to be added to a 
view, there is a short-hand method for adding models to views when using a model field.

After the model name is entered into the model field, the name of the view that the model is to be 
added to is typed in, preceded by a comma. If the model is to be added to more than one view, 
simply type in each of the view names separated by commas.

For example, to add the model fred to the views 1, 3, and 5, type

fred,1,3,5

into the model field.

Alternatively, the view names can be enclosed in round brackets.

For example,

fred (1,3,5)

String Select Panel Field
There is a special panel field called a string select panel field, which consists of a button and an 
information area. It is used for selecting a string and recording the string name in the panel 
field. 

The field name is raised slightly acts as a button which highlights as the cursor moves over it. 
Like a button, it is activated by clicking LB on the highlighted field name and a string select 
operation then begins (see the section on picking strings).

Once a string is selected, the name of the string is written into the information area of the 
string select panel field.

Field Name name of selected string written here
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string select
fields
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Same As for Panel Fields
For most panel fields/ input boxes, clicking the middle mouse button (MB) in the field will 
activate a same as pick which allows the user to get information from other objects.

After clicking MB, simply select a string, plot frame etc. from a view and the appropriate value 
will be extracted from the selected item and piped into the panel field.

At present same as picks works for

models
colours
justify
text styles
text units
names
plotter (from plot frames)
sheet size (from plot frames)
line styles

Please continue to the next section “Measures”.
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Measures
measures

measure_x

measure_y

measure_z

Whenever a real value is required in a box (e.g. height, width), the pop-up menu on the [+] 
button includes a measures menu. 

The measures menu allows the user to pick a selected measure value from existing strings, and 
the picked value is displayed and piped into the panel field.

For example, the x, y, or z coordinate of a point or the plan distance between two points.

If default values already exist for the pop-up menu, the options on the measures menu will be 
added to the bottom of the default list.

The measures functions support dynamic measures to give the user more visual feedback. This 
includes the drawing of a rubber line in the case of Point Point and String to Point measures, or 
a cross in the case of At Point. 

The measures and their dynamic aspect can be easily explored via the option

Utilities=>Measure=>Value

The walk-right Measure menus are documented in the next four sections.

The stand alone measures menus is

For the option At point, go to section “Measure At Point”
 Point to point  “Measure Point to Point”
 String from point  “Measure String from Point”
 String to point  “Measure String to Point”
 Last expression  “Last Expression”

If information on measures is not required, please continue to the next section “Text Units”.

Measure At Point
measure_point
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The At Point measures calculate and display the picked measure at a selected point.

For example, X gets the x-coordinate of a selected point.
Bearing gets the instantaneous bearing of a selected point.

The dynamic aspect of the at point measures is as follows:

after the desired at point option is picked and the string for the at point measure is 
tentatively selected but not yet accepted, and if the cursor is moved around, then the 
cursor position is dynamically dropped perpendicularly onto the highlighted string and a 
cross displayed on the string at the dropped point, and the picked measure value is 
dynamically displayed in the panel field.

For example, if the x measure was picked from the Measure Point menu and a string highlighted 
but not yet accepted, then as the cursor is moved around the screen, the cursor position is 
dropped perpendicularly onto the highlighted string and displayed as a cross and the x-
coordinate of the cross is displayed in the panel field.

Measure Point to Point
measure_point_to_point

The Point to Point measures calculate and displayed the picked measure between two selected 
points.

For example, Length gets the plan distance between two selected points.
X-fall % gets the % cross fall of the line joining two selected points.

get x co-ordinate of selected point
y co-ordinate
z co-ordinate
chainage at the point
instantaneous angle
instantaneous bearing
cross-fall of selected point
slope at the point
radius (0 if no curve)

get 2d length between selected points
3d length
delta x
delta y
delta z
delta chainage
angle of line joining selected points
bearing of line
cross-fall of line
slope of line
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The dynamic aspect of the point to point measures is as follows:

after the desired point to point measure is picked, and the first point for the point to point 
measure is selected, then a rubber line is dynamically drawn between the selected point 
and the current cursor position and the picked measure value is dynamically displayed in 
the panel field.

Further, if the selected string for the second point is tentatively selected but not yet 
accepted, and if the cursor is moved around, then the cursor position is dynamically 
dropped perpendicularly onto the highlighted string and the picked measure value to the 
second string is dynamically displayed in the panel field.

For example, if the length measure was picked from the Measure Point to Point menu and the first 
point selected, then a rubber line is dynamically drawn between the selected point and the 
cursor position and the plan length from the selected point to the current cursor position is 
dynamically displayed in the panel field.

If a string is selected for the second point but not yet accepted, the cursor position is dynamically 
dropped onto the highlighted string and the plan distance from the first point to the dropped 
point is dynamically displayed in the panel field.

point 2: at cursor position

The point to point measures are calculated between point 1 and point 2

point 1
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Measure String from Point
measure_string_from_point

 

The String from Point measures calculate the picked measure from the selected string by taking the 
current cursor position and dropping it perpendicularly onto the selected string and using the 
dropped point on the string to get the measure value.

For example, X gets the x-coordinate from the string of the cursor dropped onto the
selected string.

Z gets the z-coordinate from the string of the cursor dropped onto the
selected string

Bearing gets the instantaneous bearing from the string of the cursor 
dropped onto the selected string.

The dynamic aspect of the string from point measures is as follows:

after the desired string from point measure is picked and the string for the string from 
point measure is selected, then as the cursor is moved around, a rubber line is 
dynamically drawn between the cursor and the cursor position dropped perpendicularly 
onto the selected string, and the picked measure value of the dropped cursor position is 
dynamically displayed in the panel field.

For example, if the z measure was picked from the Measure String from Point menu and a string 
selected, then as the cursor is moved around the screen, the cursor position is dropped 
perpendicularly onto the selected string. The perpendicular line is dynamically redrawn and the 
z-coordinate of the dropped point on the string is dynamically displayed in the panel field.

get x co-ordinate of point dropped onto string
y co-ordinate
z co-ordinate
chainage at the point
instantaneous angle
instantaneous bearing
cross-fall of selected point
slope at the point
radius (0 if no curve)

selected string

point 1: at cursor position

point at cursor position dropped
perpendicularly onto selected string

The string from point measures are calculated at point 2

point 2
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Measure String to Point
measure_string_to_point

 

The String to Point measures are similar to the point to point measures and calculate the picked 
measure from a point and the point dropped perpendicularly onto the selected string.

For example, Length gets the plan distance between the point and the point dropped
 perpendicular on a selected string.

Bearing gets the bearing of line joining the point and the point dropped
 perpendicularly onto a selected string

The dynamic aspect of the string to point measures is as follows:

after the desired string to point measure is picked, and a string selected, then a line is 
dynamically drawn between the cursor position and the cursor position dropped 
perpendicularly onto the selected string. The string to point value is dynamically displayed 
in the panel field as the cursor is moved around.

Further, if the cursor position is on a string which has been selected but not accepted and 
the cursor is moved around, then the cursor is constrained to remain on the tentatively 
selected string. It is dynamically dropped perpendicularly onto the original string and the 
measure value to the dropped point displayed in the panel field.

Hence the selected point is constrained to remain on the tentatively picked string and the 
measure dynamically calculated and displayed.

get 2d length between selected points
3d length
delta x
delta y
delta z
delta chainage
angle of line joining selected points
bearing of line
cross-fall of line
slope of line

selected string

point 1: at cursor position

point at cursor position dropped
perpendicularly onto selected string

The string to point measures are calculated between point 1 and point 2 

point 2
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For example, if the length measure was picked from the Measure String to Point menu and the 
first string selected, then a line is dynamically drawn perpendicularly between the selected 
string and the current cursor position and the plan length from the string to the current cursor 
position is dynamically displayed in the panel field.

If a string is tentatively selected (picked but not yet accepted), the cursor position is dynamically 
dropped onto the first string and the plan distance measured perpendicularly from the point to 
the first string is dynamically displayed in the panel field.

Last Expression
Brings up the last expression or real value typed into the box. For example, if 3*4 was typed and 
<enter> pressed, 12 will be displayed. The Last Expression pop-up will bring back the 3*4.

first selected string

point 1: at cursor position

point at cursor position dropped
perpendicularly onto selected string

The string to point measures where point 1 is constrained to be on a 
tentatively selected string.

point 2

on a tentatively selected string
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Text Units
Text occurs in 12d Model in three ways -

▲ user defined text strings

▲ automatic text such as grid values, x-section and long-section plot annotation.

▲ text within linestyles.

The most difficult thing about text is that because of the different uses of text, there needs to be 
more than one systems of units to define text heights.

The height of text for a given textstyle is defined to be the height of a capital A. However, in 
12d Model, there are three methods of defining the units for measuring this height.

▲ world units - the units used for data

▲ screen units - pixels (the screen is 1000 pixels wide)

▲ plot paper units - millimetres.

World Units

World units are the units of user data. For most users, the base unit for user data is metres. 
However 12d Model is a dimensionless system and the base unit is totally dependent on the 
user.

The height of world text when displayed in a view depends upon on the text height and the scale 
of the view.

When plotted, the height that world text appears on a plot sheet is the same as for any data 
defined in world units - the height depends on the scale used for the plot.

Text heights that are only given in world units have (w) after them.

For some text, the choice of units is either world or pixels. The text parameters then have a (u) 
after them.

Screen Units - pixels

When screen units (pixels) are used, the text is a fixed height on the screen. If the user zooms in 
on text given in pixels, the text remains the same height.

To have a height on a plot, screen unit text needs a height defined in millimetres.

For some screen text, both a pixel and a millimetre height is supplied when the text is defined.

For text with only a pixel height, there is a plotting multiplication parameter called pixels-to-
millimetres which is used to convert pixel heights to plot paper heights. The value of pixels-to-
millimetres is set using the plots=>pixels to mm option and is stored for the project.

Text heights that are only given in pixels have a (pix) or (p) after them.

For some text, the choice of units is either world or pixels. These text parameters then have a (u) 
after them.

Plot Paper Units - millimetres

Text defined in plot paper units (millimetres) has a well defined height on a plot sheet. When a 
view scale is set for a plan view, then paper text will draw at the correct size for that scale.

Text heights that are only given in millimetres have (mm) after them.
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Special Text Characters
There are special text characters that do not appear on the standard keyboard but can still be 
entered into text strings with textstyles using true type fonts.

The special characters are entered by holding down the Alt key and typing in certain numbers on 
the number pad whilst the Alt key is still being held down). The character will appear when the 
Alt key is released.

Some commonly used special characters and their Alt codes are

Squared character ² Alt 0178

Cubed character ³ Alt 0179

 Middle dot character · Alt 0183

 Large diameter character Ø Alt 0216

 Small diameter character ø Alt 0248

 Degree character ° Alt 0176

 Copyright character © Alt 0169

 Registered character ® Alt 0174

 British Pound character £ Alt 0163

 Japanese Yen character ¥ Alt 0165

The Alt values come from the character map for Windows. This can be quickly viewed by

run charmap.

NOTE - these values may depend on the true typed font used in the textstyle.

Please continue to the next section “Bearings and Angles”.



Chapter 3  Tools and Concepts

May 2007 Page 143Bearings and Angles

Bearings and Angles
Many panels and options take angles or bearings as input. The 12d Model default for angles or 
bearings is in degrees, minutes and second (dms).

To save typing, this is written in the form

ddd.mmssfff

where ddd.mmssfff is the angle or bearing expressed in degrees, minutes and seconds as

ddd whole degrees

. separator between degrees and minutes

mm whole minutes

ss whole seconds

fff fractions of seconds (as many as required)

Notes

1. the decimal point . indicates where the degrees stops and the minutes begin

2.  if there is only whole degrees, the .mmssfff can be omitted. However, if there are any 
minutes, seconds or fractions of seconds, there must be two digits of whole minutes

3. if there are no seconds or fractions of seconds, then the ssfff can be omitted. However, if there 
are any seconds or fractions of seconds, there must be two digits of whole seconds

4. there are as many digits of fractions of seconds as required (possibly none).

For example

35 is 35 degrees

35.09 is 35 degrees and nine minutes

35.0901 is 35 degrees, nine minutes and one second

35.090107 is 35 degrees, nine minutes and 1.07 seconds

Expressions in Bearing, Angle Panel Fields
Because bearings (angles) and numbers can not be used interchangeably in mathematical 
expressions, only a limited number of expressions can be supported in a bearing or angle panel 
field.

Bearings (angles) can be added or subtracted from other bearings (angles) but a number can not 
be added or subtracted from a bearing (angle). So the addition and subtraction of bearings 
(angles) is supported but addition/subtraction of a bearing (angle) and a number is invalid.

Bearings (angles) can not be multiplied or divided by another bearing (angle) but a bearing 
(angle) can be multiplied or divided by a number. However because the input of a bearing 
(angle) in degrees, minutes and seconds looks like a decimal number (see the previous section 
“Bearings and Angles”), a rule must be made to distinguish between bearings (angles) and 
numbers for multiplication and division. In 12d Model, the bearing (angle) is on the left of the 
number it is being multiple or divided by.

So in a bearing (angle) panel field and grid, the following is supported:

(a) add or subtract bearings (angles) i.e. bearing + bearing or bearing - bearing is allowed

(b) type bearing*number + bearing *number - note that the number is on the right of the *

(c) type bearing *number - bearing *number - note that the number is on the right of the *

(d) type bearing /number + bearing *number - note that the number is on the right side of the /

(e) type bearing /number + bearing *number - note that the number is on the right side of the /
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Because a user often wishes to add or subtract 90 degrees from a bearing or angle, the Page 
Down/Page Up keys have a special meaning when the focus in on the bearing (angle) panel 
field. For a bearing (or angle) panel field (but not for a grid):

(f) Page up - subtracts 90 degrees to the bearing/angle

(g) Ctrl + page up - subtracts 15 degrees to the bearing/angle

(h) Shift + page up - subtracts 10 degrees to the bearing/angle

(i) Shift + Ctrl + page up - subtracts 6 degrees to the bearing/angle

(j) Page down - adds 90 degrees to the bearing/angle

(k) Ctrl + page down - adds 15 degrees to the bearing/angle

(l) Shift + page down - adds 10 degrees to the bearing/angle

(m) Shift + Ctrl + page down - adds 6 degrees to the bearing/angle

Please continue to the next section “Precision”.

Precision
Double precision variables are used throughout 12d Model for all co-ordinate values and 
calculations.

Although this increases the time taken for calculations, it is more than offset by the increase in 
the accuracy of the data and the results of any calculations.

Because of the accuracy of double precision variables (fourteen significant figures), there is no 
practical restriction on the co- ordinate area covered by projects.

The default number of decimal places for displaying values in the information menu is three (3).
This number of decimal places is controlled by the display precision field in the System Settings 
tab of the Defaults panel (option Utilities=>Defaults).

The default number of decimal places for displaying values in boxes and panels is four(4).
This number of decimal places is controlled by the box precision field in the System Settings tab of 
the Defaults panel (option Utilities=>Defaults).

Please continue to the next section “Colours”.
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Colours
edit_colours

The palette of colours available for elements drawn in a view depends on the 12d colour 
definition file, colours.4d (see section “Colours” in Appendix “Set Ups”. A default file is 
distributed with 12d Model and resides in the set_ups folder. Up to 10,240 colours can be defined.

In this manual, colours will be referred to by names. However, 12d Model stores colours by the 
colour number. This is independent of the colour names and if a different colours.4d is used, the 
colours on the screen may change. 

Note: colour numbers can be used instead of a colour name in any panel fields. 

Please check your colours.4d file if your screen colours do not match those mentioned in this 
manual.

The colour names are used (sorted into alphabetical order) in colour pop-ups. When a large 
number of colours have been defined, the pop-up list can get unwieldy so there is a default 
parameter, display colours (in the panel brought up by Utilities =>Defaults), which gives the 
number of colours to use in a pop-up. 

The order that the colours are taken from the colour file for the pop-up is not the colour number 
but the pop-up number order which can be completely different. This means that the user can add 
extra colours after the standard 2000 12d Model colours number and easily have the new colours 
come up in the colours pop-up.

Hence it is possible to have thousands of defined colours for shades and plots, but still have only 
a selected sixteen displayed in colour pop-ups.

WARNING
Do no change the colour numbers and definitions for colour numbers 0 to 2000 - they are 
restricted for 12D Solutions use only. 

In the 12d Model database, only the colour number is saved so if any of the first 2000 colour 
numbers are changed then the display of colours in existing projects may change.

Editing Colours
To add/modify colours to the 12d Model colours.4d file, bring up the Edit Colours panel by 
clicking on the [Edit} section of the Select Colours pop-up.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Grid Cells

Colour No. integer 

number of the colour. A unique integer value between 0 and 10,239.

Pop-up No. integer

the colours are selected for the pop-up by this number. It is a unique integer - positive, 0 or negative.

Colour name text

text name for the colour.

Colour Group text

group for the colour.

Red/Green/Blue integer

amount of red/green/blue in the colour. Value is between 0 and 255.

Pen No. text box

pen number to map the colour to.

Comment text box

optional comment.

Buttons

Sort button

sort the table with respect to the column given in the adjacent field.
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Picker button

if a row of the table is highlighted, selecting Picker brings up the Color Picker to interactive define the 
RGB for new colours.

Write button

write the table out to a colours.4d file.

Please continue to the next section “Defaults”.
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Defaults

Default Panel Values
When a 12d Model panel starts up, the standard paths are searched for a dialogue default file to use 
to set default values for the panel fields. Not all the panel field values need to be in the ddf.

If a ddf file is not found, the 12d Model system defaults are used.

The dialogue default file has the same contents as a screen layout files but the file name ends in.ddf 
and must have the unique panel name as given by the panel dump option.

A dialogue default file can be created for a panel by using the panel dump option and selecting the 
format ’dialogue default file’. The ddf file is a text file and can be edited to add/change/remove 
information in the file.

The panel dump option is selected from the panel system menu which is invoked by clicking the 
left mouse button (LB) on the Windows icon on the left of the panel title area. The Menu/Panel 
Dump panel is then displayed. For example, for the contour a tin panel:

Defaults
Many panels and operations in 12d Model require settings which are almost always the same. To 
save repetitious typing, 12d Model provides a number of user defined defaults that are used 
throughout 12d Model.

For example, the chord to arc tolerance, point cross size and highlight cross size and colour.

Certain default values are read in from a file when a new project is created. These defaults can 
also be modified inside 12d Model using the Defaults panels.

The lay out of the file used to define the default values for a new project is given in the 
appendix Set Ups.

Default File Ending
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In any panel pop-up requiring a file name, default file endings are used to restrict the names of 
the files selected from the current folder to be displayed in the pop-up.

The list of special file endings is given in the appendix Special File Formats

Please continue to the next section “Plotters”.
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Plotters
select_plotter

When creating a plot, 12d Model can either drive the plotter directly using Windows printer 
drivers or plot indirectly by creating a computer disk file (the plot file) containing the relevant 
plotter instructions for producing the plot, or in the case of the plotter type model, a 12d Model 
model is created.

If a plot file is created then there is a variety of formats available, each with its own special file 
ending.

In the plotting options, the choice of plotters that is available through the pop-up menu can be 
the default 12d Model list or a user defined list of plotters.

The default 12d Model list is

When the plot file is created, it can be passed to a user specified program or batch file which can 
automatically direct the plot file to a plotter.

See the appendices “Set Ups” and “Plotters and Plotting” for more information on plotters and 
defining plotters.
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Miscellaneous Panels
enter_value

The value is entered into the typed-input box, terminated with <enter>.

The Enter Value typed-input box then disappears.

new_length

The length is entered into the typed-input box, terminated with <enter>.

The New Length typed-input box then disappears.

 new_radius

The radius is entered into the typed-input box, terminated with <enter>.

The New Radius typed-input box then disappears.
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No Option Available
no_licence_available

no_license_available

visualisation_module

12d Model consists of a base module of varying point sizes and optional modules.

If a module has not been purchased and any options included in that option are selected then a 
No licence available message will be displayed.

The missing module can be purchased by contacting your 12d Model distributor or 
12D Solutions Pty Ltd.
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No Information Available
dongle_missing

save_project_poll

There is no information available on this panel or menu.
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Options on Toolbars
For general information Toolbars and Controlbars, go to “Toolbars and Controlbars”

Each Toolbars is described in detail in:

Cad in the section “CAD Options” 
Cad Arcs “CAD Arcs” 
Cad Circles “CAD Circles”
Cad Controlbar “CAD, Symbol and Text Controlbars” 
Cad Delete “CAD Delete”
Cad Fills “CAD Fills” 
Cad Holes “CAD Holes” 
Cad Images “CAD Images” 
Cad Intersect “CAD Intersect”
Cad Lines “CAD Lines”
Cad Modify “CAD Modify”
Cad Points “CAD Points”
Cad Polygons “CAD Polygons”
Cad Segment “CAD Segment Edits”
Cad String “CAD Edit Strings”
Cad Symbols “CAD Symbol”
Cad Text “CAD Text”
Cad Vertex “CAD Edit Points”
H “Snap Toolbar”
Measure edits “Measure Edits Toolbar”
Menu Bar can’t be turned off - all the options in 12d Model
Options turns off the area for docking toolbars on left hand side of 12d Model window
Road “Road Toolbar”
Snaps Cad
Snaps Cad Arcs
Snaps Cad Circles
Snaps Cad Intersect
Snaps Cad Lines
Snaps Cad Points
Strings Edits “String Edits Toolbar”
Super alignment tools “Super Alignment Tools Toolbar”
Survey reductions “Survey Reductions Toolbar”
Symbol Controlbar “CAD, Symbol and Text Controlbars” 
Text Controlbar “CAD, Symbol and Text Controlbars” 
Tin Utility “Tin Utility Toolbar”
Traverse Spreadsheet “Traverse Spreadsheet Toolbar”
Visualisation “Visualisation Toolbar”
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Measure Edits Toolbar
measure_edits

Position of option on menu: various

The Measure Edits toolbar is:

For String inquire go to the section “Inquire”
Measure bearing/distance  “Bearing and Distance”
Measure value  “Value”
Measure plan area  “Plan Area”
Measure surface area  “Surface Area”
Measure xfall  “X Fall by Strings”
Measure angle  “Angle by 3 Points”
Match properties  “Match”
Measure menu  “Measure”

 Options on Toolbar

string inquire

measure bearing/distance

measure value

measure plan area

measure surface area

measure xfall

measure angle by 3 points

match properties

measure menu



12d Model Reference Manual

Page 156 May 2007Options on Toolbars

Road Toolbar
road

Position of option on menu: various

The Road toolbar is:

For Create pads go to the section “Allotment Pad Create”
Edit pads  “Allotment Pad Edit”
Create special chainage file  “Special Chainages File”
Special chainage file for kerb return “Kerb Special Chainages File”
Setout points using super string  “Create Setout Points Using Super String”
Label chainage & offsets  “Chainage/Offset Label Inquire”
Create/edit dimensions  “Create/Edit Dimensions”
Create/edit traffic island  “Create Combined Traffic Island”

Road widening min/max cross falls “Road Widening with Minimum and Maximum Crossfall”
Convert polyline to alignment  
Overlay design  “Overlay Design”
Setup for create roads  “Create Roads - Setup”
Create roads  “Create Roads - Manager”
Modify kerb return chainages  “Intersection MTF Update”
Create kerb return using computators 

 Options on Toolbar

create pad

edit pad

special chainage file

special chainage file for kerb returns

set out points using super string

label chainage and offset

create/edit dimensions

create/edit traffic island

road widening with min/mac xfall

convert polyline to alignment

overlay design

set up for create roads

create roads

modify kerb return chainages

create kerb return using computators
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String Edits Toolbar
string_edits

Position of option on menu: various

The String edits toolbar is:

For Edit string go to the section “Editor”
Edit vertex  “Edit Vertex”
Edit segment properties  “Segment”
Edit vertex properties “Vertex”
Change string “Change”

 Options on Toolbar

edit string

edit vertex

edit segment properties

edit vertex properties

change strings
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Super Alignment Tools Toolbar
string_edits

Position of option on menu: various

The Super Alignment Tool toolbar is:

For Create super alignment go to the section “Create - Super”
Edit super alignment  
Turn fixed/float to IP  
Dereference a super alignment
Parallel a super alignment
Split a super alignment
Join a super alignment
Change style of a super alignment
Explode labelling of a super alignment
Constrain super alignment moves
Define road design parameters
Create/edit a super alignment style “Super Alignment Style”
Tabulate a super alignment “Alignment & Super Alignment Table”

 Options on Toolbar

create super alignment

edit super alignment

resolve a super alignment

turn fixed/floating super alignment to IP super alignment

dereference a super alignment

parallel a super alignment

split a super alignment

join a super alignment

change style of a super alignment

explode the labelling of a super alignment

constrain super alignment moves

define road design parameters

create/edit a super alignment style

tabulate a super alignment 



Chapter 3  Tools and Concepts

May 2007 Page 159Options on Toolbars

Survey Reductions Toolbar
survey_reductionss

Position of option on menu: various

The Survey Reductions toolbar is:

For Survey menu go to the section “Survey”
Create control stations  “Create - Control Stations”
Bearing/distance entry  “Plane Bearing/Distance Entry”
Traverse adjustment  “Traverse Adjustment”
Horizontal least squares  “Least Squares Network”
Level network adjustment  “Level Network”
Set default data collector  “Setup”

 Options on Toolbar

survey menu

create control stations

bearing/distance entry

traverse adjustment

horizontal least squares adjustment

level nets adjustment

set up data collector

download survey data

convert raw survey fie to 12d field file

survey data reduction function

quick change code

join surveyed strings

insert target height

start new survey strings

auto order survey shots

order by survey point ids

reset order to original order

edit survey data

edit survey field data by string

lock a function

edit a text file
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Set default data collector  “Setup”
Download from data collector  “Download Raw”
Convert data collector file to field file “Convert Raw”
Create survey data reduction function “Create Survey Function”
Survey code change  “Quick Change”
Join strings  “Join Two Strings of Same Feature Code”
Insert target height  “Insert Target Height”
Start new string  “New String”
Auto order string points  “Auto Order”
Order by points  “By Points”
Remove ordering  “Remove Order”
Edit survey data  “Field Data”
Edit field data by picking a string “Field Data by String”
Lock a function  “Lock”
Edit a report file  “Edit”
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Tin Utility Toolbar
tin_utility

Position of option on menu: various

The Tin Utility toolbar is:

For Create at tin go to the section “Triangulate Data”
Null by angle and length  “Null by Angle and Length”
Tin to tin depth polygons  “Depth Range Polygons”
Contour, smooth and label  “Contour, Smooth and Label”
Intersect two tins  “Intersection”
Translate/copy a tin  “Translate/Copy”

 Options on Toolbar

create a tin

null a tin by angle and length

tin to tin depth polygons

contour, smooth and label a tin

intersect two tins

translate/copy a tin
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Traverse Spreadsheet Toolbar
traverse_spreadsheet

Position of option on menu: various

The Traverse spreadsheet toolbar is:

For Edit traverse spreadsheet go to the section “TSS Edit”
Create a traverse spreadsheet  “TSS Create”
Traverse spreadsheet utilities  “TSS Utilities”
Lot check for traverse spreadsheet “Lot Check”
NZ traverse spreadsheet report  “NZ TSS Report”
Traverse spreadsheet report  “Standard TSS Report”
Traverse spreadsheet drafting  “TSS Drafting”
TSS radiation tables drafting  “TSS Radiation Table Drafting”
Read Landonline XML  “Landonline XML Read”
Write Landonline XML  “Landonline XML Write”
Set up tss parameters  “TSS Parameters”

 Options on Toolbar

edit traverse spreadsheet

create a traverse spreadsheet

traverse spreadsheet utilities

lot check for tss

New Zealand traverse spreadsheet report

standard traverse spreadsheet report

drafting of traverse spreadsheet

drafting of radiation tables

read a Landonline XML file

write a Landonline XML file

set up parameters for traverse spreadsheet
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Visualisation Toolbar
visualisation

Position of option on menu: various

The Visualisation spreadsheet toolbar is:

For Tin render settings go to the section “Render Settings”
Create roadside furniture “Roadside Furniture”
Create trees and shrubs “Trees/Shrubs as Faces and Billboards”
Create houses “Houses”
Create fences “Fences”
Create forest “Create Forest”
Create clouds “Clouds”
Create/edit texture map file “Texture Map Edit”
Change polygon drape “Render Drape”
Create and place billboards “Create Billboards”

Change super string billboards “Add and Remove Billboard from Super String”

 Options on Toolbar

tin render settings

create roadside furniture

create trees and shrubs

create houses

create fences

create forest

create clouds

create/edit a texture map file

change polygon drape

create and place billboards

change super string billboards
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3  Starting Up

Initial Screens
When 12d Model is installed from the 12d Installation CD, the 12d icons 12d Model 8 and 12d 
Model 8 Training.

The 12d Model icons are shortcuts to start 12d Model and then attach to a particular folder. 

For example, 12d Model 8 starts 12d Model and attaches to the folder C:\12djobs

project_selection

Clicking on any of the 12d Model icons starts 12d Model. First the 12d Model splash screen will 
appear and then the initial 12d Model screen with the Project Selection panel.

Note
If this does not work, please contact your 12d Model administrator to check the procedure to be 
used on your system. For a detailed description on how to install 12d Model, please refer to the 
Installing 12d Model chapter in the Getting Started manuals.

The user specifies which project is to be worked on by providing 

(a) the name of the folder that the project is to be placed in (working folder)

recent projects list

description of highlighted
recent project

authorized client name
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(b) the name of the project inside the working folder (working project).
If no folder is given, the project is assumed to be in the folder the user is currently in. 

If the project does not exist, a new project is created.

The description of the functions of the fields and buttons in the Project Selection panel are:

Field Description Type Defaults Pop-Up

Client name display only

authorized 12d Model client.

Recent projects list output recent projects

names and folders of project recently select. Single clicking on an entry in the list displays the projects 
description in the Project description area. Double clicking on an entry in the list changes the project

Project description output

description of the project highlighted in the Recent projects list.

Folder input current folder Microsoft browser

name of the folder to become the working folder.

Project  input none projects in folder

name of the project to become the working project in the folder given in the folder field.

Proceed button

after selecting this button, the working folder is changed to the folder specified in the folder field. The 
working project is set to the project given in the project field. If the folder or project does not exist, it 
will be created.

Cancel button

end the program.

Note: This panel a resizable panel.

To select a project is the Recent projects list, simply double click on the entry in the list and 
12d Model will open the project up.

Alternatively, the Folder and Project fields can be used to select another project.
If the initial folder in the Folder field is not the required folder, clicking LB on the folder icon on 
the right side of the field will bring up the Microsoft browser which is used to navigate to the 
folder where either the new project is to be created, or an existing project resides.
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If the folder containing existing projects is selected, then a list of projects in the folder is 
displayed and the required project can be selected from the list.

Alternatively, the actual project can be selected by double clicking on the project name in the 
browser.

In either case, selecting the project fills in the Project field. Selecting Proceed then opens the 
project.

list of projects
in the folder
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If a new project is required, then after the folder to contain the project is selected, the name of the 
new project is typed into the Project field and Proceed selected.
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Organizing Working Areas
For each project, 12d Model creates a unique sub-folder of the working folder with the name 
consisting of the project_name followed by ".project". For example, "Olympic.project".

This sub-folder is called the project area. All the internal 12d Model information for that project 
is kept inside the project area.

All outputs, reports and plots are written to the working folder and are not held inside the 
project area. 

Hence to get a complete backup of the project and all associated information, it is best to backup 
the entire working folder.

The project name, which can be up to 256 alphanumeric characters and can include spaces, must 
be unique within the working folder but other folders may include 12d Model projects with the 
same name - these projects are distinct and are not related in any way.

There is no limit to the number of projects in a particular working folder but because all the 
outputs, reports and plots for each project in the same working folder would be mixed in 
together, it is recommended to have each distinct project in its own working folder.

If unrelated 12d Model projects are going to be created, then it is suggested that they each have 
their own working folder. That way the inputs files, output files, plots, reports etc. from the 
separate projects do not end up in the same working folder. Each separate working folder can 
also then be easily backed up. 

As an example, if three unrelated projects - olympics, airport, and dam - are to be created in a 
folder called 12djobs, it is suggested that three sub folders of 12djobs are first created to use as 
the working folders - e.g. olympics, airport and ’dam works’.

The 12d Model projects would then be created inside the appropriate working folder - e.g. the 
projects dam, spill and access relating to the job dam works would be created inside the folder dam 
works.

Project Shortcuts
The list of most recent projects makes it very easy for 12d operators to get into their projects.

However if there is a folder of projects, or even a particular project, that a user wants to get into 
by simply double clicking on an Icon on the screen, then a Windows shortcut can be used to do 
it.

To set up a 12d icon on the desktop, it is easiest to copy either the 12d Model 8 or 12d Model 8 
Training icons that are already on the screen. Rename the copied icon to say dam.

The Properties for the icon dam must now be modified. To display the properties of an icon, click 
RB over the icon and select Properties from the menu. Click on the Shortcut tab

working folders

olympic.project
dam.project

airport.projectproject folders

12djobs

damolympic airport

spill.project access.project
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The Properties for the icon dam can now be modified.

If an icon is to start in a given folder, then the Start in field is set to the desired folder.

For example, if the 12d Model project dam was in the folder "12djobs\dam works", set the Start 
in for the icon dam to:

"C:\12djobs\dam works"

The icon dam would then automatically start in the folder C:\12djobs\dam works.

Note that if the pathname for Start in contain spaces, then it must be enclosed in double quotes 
(").

If the dam icon was double clicked on, it would now attach to the working folder dam works

Only the appropriate project would then need to be selected from the project field of the 12d 
Model Project Selection panel

Further, if a project such as dam already exists in the folder, the by setting the Target field, the 
icon can be set so that 12d Model starts up in that existing project.

If the Target for the shortcut has the project_name added after the path to 12d.exe, then 
12d Model will actually start up with that project opened. The project_name can be a pathname.

For example, the Target:

"C:\12d\12dmodel\8.00\nt.x86\12d.exe"    dam

would automatically open the project dam in the Start in folder of the shortcut.

Note that if either the pathname for the Target or the project_name contain spaces, then they 
must be enclosed in double quotes (").

The following picture shows the Properties setting for Target and Start in for the dam icon so 
that double clicking on dam would automatically start 12d Model with the project dam in the 
folder dam works:
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Environment Variables Shortcut
If a file of 12d Model environment variables has been set up by the user (see section 
“Environment Variables” in Appendix “Set Ups”), then instead of setting the environment 
variable ENVIRONMENT_4D to point to the file or setting it up with the default name, env.4d, 
the environment file can be passed to 12d Model using the Target of the icon properties.

For example, the Target:

C:\12d\12dmodel\8.00\nt.x86\12d,exe  -env F:\12d\env.4d

would fire up 12d using the file of environment variables called F:\12d\env.4d 

The Target:

C:\12d\12dmodel\8.00\nt.x86\12d.exe  -env F:\12d\env.4d dam

would fire up 12d using the file of environment variables called F:\12d\env.4d and also 
automatically open the project dam in the start in folder of the shortcut.

Again if any of the pathnames contain spaces, then they must be enclosed in double quotes (").
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Error Logging File
When 12d Model starts up, it tries to create an error logging file, called

log?????.4de

 where ????? is a hashed number using your login name, process id & the current time.

When 12d Model terminates, the error log file is deleted if no errors were logged.

The folder that the error log file is created in is given by the environment variable LOG_DIR_4D

If LOG_DIR_4D is not used, 12d Model tries to create the log file in the current folder, the HOME 
folder, the TMP folder and the TEMP folder.

If creating a error log file fails in all these areas, 12d Model will not start up. This should never 
happen.
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Running Macros and Chains on Start Up
To allow for tailoring 12d Model when a new project is created or an existing project opened, 
12d Model runs user supplied files of macros and/or chains.

For new projects, the default name of the file is

macros.4d

This can be changed to a different file by setting the environment variable

RUN_MACROS_4D     file_of_macros_to_run

For existing projects, the default name of the file is

project_macros.4d

This can be changed to a different file by setting the environment variable

RUN_PROJECT_MACROS_4D     file_of_macros_to_run

(the environment variables can be set on the Extra A tab of the env.4d editor - see “env.4d”)

The files consist of macros and/or chains, one per line, where 

for macros, just the name of the macro is needed on the line

and for chains, the command run_chain name_of_the_chain is needed on the line. 

The macros and chains are run in the order that they occur in the file.
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4 12d Model Help
The 12d Help can be accessed by selecting 12d Model on the Help menu item on the main 12d Model 
menu.

 

Alternatively, individual topics for a panel or menu can be invoked by using the F1 key or the Help button 
on any 12d Model panel.

More information on the Help system will now be given.

Contents
The Contents allows you to look at the overall structure of the Help and access any part of it.

Warning - only topics in the Help can be accessed through the Contents list so any folders in the Content 
folders must be expanded until topics are displayed. Topics can be easily identified because they have a 
question mark beside them indicating that Help is available.

For example, double clicking on ’Tools and Concepts’ expands the next level of ’Tools and Contents’.

Help on Microsoft’s help system
12d Model help
12d macro programming language help

links to web site www.12d.com
12d Model modules authorized
email details of your 12d Model to 12D Solutions
dongle testing panel
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Double clicking on the topic ’Picking Strings’ will then display the topic.

The Contents then disappear leaving Help open at the selected topic.

Double clicking on ’Contents’ on the top of the Help will bring the Contents listing back up.
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Index
The Index option searches through all entries in the Index of the Help.

As the first few characters of the required entry are typed in, the matching index entries are displayed.

Double clicking on the displayed entries will go to the topic in the Help containing the selected index 
entry. If more than one topic includes the index entry, then the list of topics is displayed.

If the index has sub-indices, they can be searched by first typing in the main index followed by a comma, 
then a space and the first few characters of the sub-index.
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Find
The most powerful searching method for the Help system is Find. 

Simply click on the Find tab to search for words or phrases that may be contained in a Help topic.

If Find is being invoked for the first time, the ’Find Setup Wizard’ runs to create an index of every word in 
the Help.

From then on, selecting the Find tab goes straight to the Find screen.
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Panel Help Button
Every panel has a Help button which when selected goes to the topic describing that panel.

Help button to go
directly to the Help
topic for the panel.



12d Model

Page 180 February 2007F1 Key

F1 Key
Another method of invoking Help is by using the F1 key as follows: 

when a menu or panel is on the screen and has focus (the menu or panel title area will be highlighted), 
pressing F1 will bring up the help for that menu or panel.

Warning - some of the items on the Strings menu automatically start up a string select and change the 
focus from the panel to a View. This means that pressing F1 will bring up the Help for the View and not the 
Help for the panel. 

To get Help for such a panel, click on the panel to bring the focus back to the panel before pressing F1. The 
top of the panel will highlight showing that it has focus.

Navigating in Help
Once at a topic in the Help, the <<  and  >> buttons at the top of the Help topic will go to the previous 
and next Help topics respectively. 

Individual Help topics can be printed by clicking Print at the top of the Help page.

Because it is difficult to print large sections of Microsoft’s Help system, a PDF file of the entire 12d Model 
Reference Manual has been created and can be used to print out large sections of the manual.

The 12d Model Reference Manual PDF file is on the 12d Model 8 Installation CD in the folder 
Documentation\Reference_Manual.

go back one topic go to next topic
print the
current topic
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5  View Menus
perspective_opengl_view_help

section_view_help

perspective_view_help

hidden_perspective_view_help

plan_view_help

Views are the screen drawing areas for 12d Model and come in three flavours - plan, perspective 
and section. Views can be created and deleted as required by the user and there is no limit to the 
number of views on the screen. The views can overlap and be minimized.

Each view has a unique name of up to two hundred characters.

Each view has a view title area which is used to display the view name and a view button area 
which displays the view buttons.

view type

view

and name
buttons to minimize/restore,

view-title

view system

views

maximize, and delete 

area

view

tabs

menu

workbook

area

button
area
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The View Buttons are documented in the section “View Buttons”  

If the Menu button is selected in the view button area of any view, or if RB is clicked in the view-title 
area or in the view-button area, a new menu called the View menu appears.

Because of the differences between plan, perspective and section views, the options on the View 
menu vary for each view type. The plan, perspective and section View menus are

Plan view buttons

Menu Fit
Pan

Zoom
Shrink

Toggle
Refresh

PlotAdd
Remove

Previous

perspective

Menu Refresh
PlotAdd

Remove

Eye

Walk
Joy

Drive

view buttons

Orbit
Fit

Pan
Zoom

Shrink

Toggle

Previous

Section view

Menu Fit
Pan

Zoom
Shrink

Toggle
Refresh

Plot

Add
Remove

Previous buttons

Exaggeration

Profile
Previous string

Next string

Regenerate

Plan View Menu Perspective View Menu Section View Menu
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The View menu is removed by selecting the [X] button or if the View menu hasn’t been moved, by 
simply clicking RB again in the view-title or view button area. If the View menu has been moved, 
clicking RB will warp the cursor to the moved View menu.

For further documentation on the options on the View menus, please see:
for the option Models, go to the section “Model Ops” .

 Settings,  “Plan View Settings”  
or “Perspective View Settings”  or “Section View Settings” .

 Redraw,  “Redraw” .
 Fit,  “Fit” .
 Previous,  “Previous” .
 Zoom, “Zoom” .
 Joy,  “Joy” .
 Profile,  “Profile” .
 Regenerate,  “Regenerate” .
 Pan,  “Pan” .
 Utilities,   “Plan Utilities” 

or “Perspective Utilities”  or “Section Utilities” .
 Delete,  “Delete” .

The option Models which is common to each menu will be discussed first, followed by the 
special options for each of the view menus.

Please continue to the next section “Model Ops” .

Model Ops
view_model_ops_menu

Position of menu: Plan View Menu     View =>Models

Position of menu: Section View Menu     View =>Models

Position of menu: Perspective View Menu     View =>Models

Walking right on Models brings up the Model Ops walk-right menu which is used to add and 
remove models from the view.

These options are the same for Plan, Perspective and Section views.

The Model Ops walk-right is
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For the option Models, go to the section “Models” .
Add model “Add Model” .
Add all models “Add All Models” .
Remove model  “Remove Model” .
Remove all models “Remove All Models” 
Add tin models “Add Tin Models” .
Remove tin models “Remove Tin Models” .
Model order “Model Order” .
Models to front “Models to Front” .
Models to back “Models to Back” .
Calc extents  “Calc Extents” .

Models
models_to_add

Position of menu: Plan View Menu     View => Models =>Models

Position of menu: Section View Menu     View => Models =>Models

Position of menu: Perspective View Menu     View => Models =>Models

Models is a walk-right option which lists the models currently attached to that view.

If a model is selected from the displayed list, the model will be redrawn on the view. It will also 
be brought to the top of the display list, i.e., it is in the foreground and all the other models on the 
view are drawn before it.

Add Model
Position of menu: Plan View Menu     View => Models =>Add model

Position of menu: Section View Menu     View => Models =>Add model

Position of menu: Perspective View Menu     View => Models =>Add model

The Add model menu item operates two ways.

The Add model walk-right brings up the Models to Add list which is a list of all the models not 
currently added to the view.
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By double clicking on one of the models from the Models to Add list, it is added to the view. The 
list is then removed. To add a number of models from the list to the view, select the models in the 
list in the standard Microsoft way and then click on Select.

If the Models to Add list has been moved or pinned, models can be selected from the list and 
added to the view and the Models to Add list will remain with the selected models removed from 
the list. When all the required models have been added, delete the list using the [X] button.

If Add model itself is activated (by clicking LB when Add model is highlighted), the Add Model to 
a View panel appears. The Add Model to a View panel can be used to create new models as well as 
add existing models to any view. Wild cards and characters are allowed for adding models.

Any models added to a view are immediately drawn on the view.

Add All Models
Position of option on menu: Plan View Menu     View => Models =>Add all models

Position of option on menu: Section View Menu     View => Models =>Add all models

Position of option on menu: Perspective View Menu     View => Models =>Add all models

The Add all models option adds all the models to the view.

Remove Model
models_to_remove

Position of menu: Plan View Menu     View => Models =>Remove model
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Position of menu: Section View Menu     View => Models =>Remove model

Position of menu: Perspective View Menu     View => Models =>Remove model

The Remove model menu item also operates in two ways. The Remove model walk-right brings 
up the Models to Remove list which is a list of all the models currently added to the view. 

By double clicking on one of the models from the Models to Remove list, it is removed from the 
view. The list is then removed. To remove a number of models on the list from the view, select the 
models in the list and then click on Select.

If the Models to Remove list has been moved or pinned, models can be selected from the list and 
removed from the view and the Models to Remove list will remain with the selected models 
removed from the list. When all the required models have been removed, delete the list using the 
[X] button.

If Remove model itself is activated, the Remove Model from a View panel appears. The Remove 
Model from a View panel can be used to remove any models from any view. Wild cards and 
characters are allowed for removing models.

NOTE
Models still exist after they are removed from a view. Models can only be deleted from 
12d Model by using the Models=>Delete option.

Remove All Models
Position of option on menu: Plan View Menu     View => Models =>Remove all models

Position of option on menu: Section View Menu     View => Models =>Remove all models

Position of option on menu: Perspective View Menu     View => Models =>Remove all models

The Remove all models option removes all the models from the view and clears the view.

Add Tin Models
tin_models_to_add

Position of menu: Plan View Menu     View => Models =>Add tin models

Position of menu: Section View Menu     View => Models =>Add tin models

Position of menu: Perspective View Menu     View => Models =>Add tin models

The Add tin models walk-right brings up the Tin Models to Add list of all tins in the project whose 
models have not been added to the view
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By double clicking on one of the tins from the Tin Models to Add list, all the models in the tin are 
added to the view. The list is then removed. To add the models from a number of tins from the 
list to the view, select the tins in the list in the standard Microsoft way and then click on Select.

If the Tin Models to Add list has been moved or pinned, tins can be selected from the list and their 
models added to the view and the Tin Models to Add list will remain with the selected tins 
removed from the list. When all the required tins have been added, delete the list using the [X] 
button.

Any models added to a view are immediately drawn on the view.

Remove Tin Models
tin_models_to_remove

Position of menu: Plan View Menu     View => Models =>Remove tin models

Position of menu: Section View Menu     View => Models =>Remove tin models

Position of menu: Perspective View Menu     View => Models =>Remove tin models

The Remove tin models walk-right brings up the Tin Models to Remove list of all tins whose 
models are currently added to the view. 

By double clicking on one of the tins from the Tin Models to Remove list, all the models in the tin 
are removed from the view. The list is then removed. To remove the models from a number of 
tins on the list from the view, select the tins in the list and then click on Select.

If the Tin Models to Remove list has been moved or pinned, tins can be selected from the list and 
removed from the view and the Tin Models to Remove list will remain with the selected tins 
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removed from the list. When all the required tins have been removed, delete the list using the [X] 
button.

Model Order
model_order

Position of menu: Plan View Menu     View => Models =>Model order

Position of menu: Section View Menu     View => Models =>Model order

Position of menu: Perspective View Menu     View => Models =>Model order

The Model order options displays the list of all models on a view in the reverse model drawing 
order. That is, the first model on the list is the last model drawn and hence the most visible 
model.

Selecting Model order brings up the Model Order panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model

list of models on the view in the reverse drawing order. That is, the first model on the list is drawn last 
and so is the most visible.

Up Arrow, Down Arrow

when a model name is highlighted, clicking the Up/Down arrow will change the order of the 
model.
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Delete

when a model name is highlighted, clicking the Delete icon will remove the model from the view.

when a model name is highlighted, clicking on the Cross will remove the model from the view.

Auto update view tick box tick
if tick then the view is redrawn each time a model is moved in the list or added/removed from the list.

Update button
redraws the view using the new model order.

Models to Front
models_to_front

Position of menu: Plan View Menu     View => Models =>Models to front

Position of menu: Section View Menu     View => Models =>Models to front

Position of menu: Perspective View Menu     View => Models =>Models to front

Models to front is a walk-right option. When the walk-right is chosen, the list of models currently 
attached to that view is displayed.

If a model is selected from the displayed list, the model will be the last to be drawn on the view. 
Hence, it is in the foreground and all the other models on the view are drawn before it.

Models to Back
models_to_back

Position of menu: Plan View Menu     View => Models =>Models to back

Position of menu: Section View Menu     View => Models =>Models to back

Position of menu: Perspective View Menu     View => Models =>Models to back

Models to back is a walk-right option. When the walk-right is chosen, the list of models currently 
attached to that view is displayed.

If a model is selected from the displayed list, the model will be the first to be drawn on the view. 
Hence, it is in the background and all the other models on the view are drawn after it.

Calc Extents
Position of option on menu: Plan View Menu     View => Models =>Calc extents

Position of option on menu: Section View Menu     View => Models =>Calc extents

Position of option on menu: Perspective View Menu     View => Models =>Calc extents

For each model on the view, the size of the x, y, z box required to enclose the data in the model is 
calculated.That is, the option calculates the model bounding box for each model on the view.
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Redraw
Position of option on menu: Plan View Menu     View => Models =>Redraw

Position of option on menu: Section View Menu     View => Models =>Redraw

Position of option on menu: Perspective View Menu     View => Models =>Redraw

As its name implies, this option redraws all the models on the view using the current drawing 
parameters. This is the same as clicking MB in the view title area.

NOTES

1. When a model is removed from a view, it is “undrawn”, that is, drawn in black. This may also 
black out important details of other models still attached to the view. If this happens, use the 
redraw option to refresh the view.

2. Clicking MB in the view-title area is the easiest method of redrawing a view.

Fit
Position of option on menu: Plan View Menu     View => Models =>Fit

Position of option on menu: Section View Menu     View => Models =>Fit

Position of option on menu: Perspective View Menu     View => Models =>Fit

When the fit option is chosen, 12d Model calculates viewing parameters which will allow all the 
models attached to the view to be fully displayed. The view is then redrawn using these new 
drawing parameters.

Note if the data does not fill the view after a fit, then a calc extents may be needed to re-calculate 
the model bounding boxes.

Previous
Position of option on menu: Plan View Menu     View => Models =>Previous

Position of option on menu: Section View Menu     View => Models =>Previous

Position of option on menu: Perspective View Menu     View => Models =>Previous

Each time a view has its viewing parameters changed, the old set is recorded as the previous 
parameter set.The previous option sets the viewing parameters back to this previous parameter 
set.

The view is then redrawn using those settings. The last set then becomes the old set.

Delete
view_menu_delete_view

Position of option on menu: Plan View Menu     View =>Delete

Position of option on menu: Section View Menu     View =>Delete

Position of option on menu: Perspective View Menu     View =>Delete
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This option is used to delete the view and remove it from the screen.

After selecting the Delete option, a Delete View yes-no panel appears.

If Yes is selected, the view is deleted and removed from the screen.

Selecting No removes the Yes-No pop-up and leaves the view as it is.
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Plan View Menu
plan_view_menu

Position of menu: Plan View Menu     View

The plan view menu is

For the option Models, go to the section “Model Ops” 
Settings “Plan View Settings” .
Redraw “Redraw” .
Fit “Fit” .
Previous “Previous” .
Pan “Pan” .
Utilities “Plan Utilities” .
Delete “Delete” .

Plan View Settings
plan_view_settings_menu

Position of menu: Plan View Menu     View => Settings

If the Settings option is picked rather than moving onto the walking right, then the toggle menu 
from the toggle walk-right menu is displayed on the screen. The toggle menu will be described 
in the next section.

The view settings walk-right menu for the plan view is
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For the option Toggle, go to the section “Plan Toggle” 
Culling “Culling” 
Faces “Faces” 
Linestyles “Linestyles” 
Rotate “Rotate” 
Sewer “Sewer” 
Plotting scale “Plotting Scale” 
Text “Text” 
Tins “Tins” 
Vertices “Vertices” 
Point/vertex id’s “Point/Vertex Id’s” 
Vertex indices “Vertex Indices” 
Z values “Z Values” 
Names “Names” 
Attributes “Vertex Attributes” 
Arc centres  “Arc Centres” 
Work plane “Work Plane” 
Rasters  “Rasters” 
Grid  “Grid” 
Colour “Colour” 
Drawing filter “Drawing Filter” 
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Plan Toggle
plan_view_toggle_menu

Position of menu: Plan View Menu     View => Settings =>Toggle

The toggle walk right brings up the toggle plan view menu.

Selecting any options from this menu will toggle the option on/off.

Culling
culling_plan_view

Position of option on menu: Plan View Menu     View =>Settings => Culling

The culling option is used to suppress the drawing of strings whose on-screen extent is less than 
a user defined pixel size.

Selecting culling raises the culling plan view panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to set cutting for. 

Use culling tick-cross
if tick, a string is not drawn on the plan view whenever the string’s extent box when drawn on the 
view would be smaller than the culling size given in the culling size field.
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Culling size input 10
pixel size used for culling

Cull button
record the culling size given in the culling field. If the use culling field is set to tick, the recorded culling 
size will be used whenever the plan view is redrawn.

Faces
face_flags_for_view

Position of option on menu: Plan View Menu     View =>Settings => Faces

The faces option allows the user to specify how faces are displayed in the plan view and on any 
plan view plots. 

Selecting faces fires up the face flags for view panel.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to set for drawing faces. 

Draw fill tick-cross tick
if tick, all faces in the view are drawn in their fill colour.

Draw edges tick-cross
if tick, all face edges in the view are drawn.

Draw hatch tick-cross
if tick, all faces in the view are drawn in their hatch pattern.

Set button
set the draw fill/edges/hatch fields to the value in the panel fields. The plan view is then redrawn using 
this value.

Linestyles
linestyles_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Linestyles

The linestyles option allows the user to specify how linestyles (styles) are displayed in the plan 
view and on any plan view plots. 

If linestyles are not used for drawing in a view then all strings are drawn according to their 
breakline type. That is, line strings are drawn with solid lines for each line in the string and point 
strings with only crosses at the string points. This style is the default style, 1.
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Selecting linestyles fires up the linestyles for view panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify draw linestyle flag for. 

Draw linestyles tick-cross tick
if tick, all strings in the view are drawn with linestyles.
If no tick, all lines strings are drawn as solid lines and point strings with crosses at their vertices.

Set button
set the draw linestyles field to the value in the panel field. The plan view is then redrawn using this 
value.

Rotate
rotate_plan_view

Position of option on menu: Plan View Menu     View => Settings => Rotate

The rotate option is used to rotate a plan view through a user supplied angle about the centre 
point of the plan view.

After selecting the rotate option, the rotate plan view panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to set rotation angle for. 

Rotate angle input 0 angles
angle (in degrees) to rotate the view to.

Rotate button
rotate the view about the view centre point until the angle the view makes with the positive x axis is the 
angle given in the rotate angle field.
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Sewer
sewer_annotations_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Sewer

This is part of the optional sewer module.

The sewer option allows the user to specify how sewer text is displayed in the plan view and on 
any plan view plots. 

Selecting sewer fires up the sewer annotations for plan view panel.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to set sewer annotation information for. 

Draw text tick-cross
if tick, sewer text annotation will be drawn for any sewer strings in the plan view.

Colour input red available colours
the colour for any sewer text annotation.

Height input default text height

the height for any sewer text annotation.

Angle input 0
the angle for any sewer text annotation.

Offset input 0
the offset for any sewer text annotation.

Set button
set the values in the panel fields and then redraw the view.

Plotting Scale
plan_plotting_scale

Position of option on menu: Plan View Menu     View => Settings => Plotting scale

The plotting scale option is used to set a scale for the plan view which is used to determine the 
size to draw any paper text on the plan view.

After selecting the plotting scale option, the plan plotting scale panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to set the scale for. 

Scale input 250
"1 in" to use to calculate a drawing size for any paper text on the view.

Set button
set the plotting scale for the view.
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Text
plan_view_text_settings_menu
Position of menu: Plan View Menu     View => Settings =>Text

The text option allows the user to specify whether the text from any strings (text strings, 4d 
strings and survey strings) in models on the plan view is

(a) not drawn at all

or

(b) if drawn and the text is defined in world units, then the text can be drawn in full, quick 
mode or not at all depending on the display size of the text on the screen. This stops the 
drawing of world text when its display size is small on the screen (e.g. when zooming out).

(c) if drawn and the text is defined in pixel units, then when the screen scale is such that the 
height of the text in world units is too large, then the text is not drawn. This stops the 
drawing of pixel text when its displaying world size is large in proportion to other world 
units (e.g. when zooming out).

Hence the text option tries to control the drawing of both pixel and world text in models on the 
view so that the text stops displaying in the view as the user zooms out

The choice of drawing text in full, quick mode or not at all also applies to the Vertex numbers 
and Z values text turned on by view settings (view text).

Depending on whether the environment variable plan_table_settings_4d is zero or not, the Text 
option draws/doesn’t draw text for any model on the view, or the drawing of text can be set for 
individual models.

If the environment variable plan_table_settings_4d is set to 0:

The options in the text walk-right are used to display/not display text for all models on the plan 
view and the walk-right menu only contains the two options, Text and Single.

Selecting Single brings up the Model Text for Plan View panel, without the Model field and is only 
used to set a maximum height, not parameters for individual models.

If plan_table_settings_4d is non-zero: 

The options in the text walk-right can be used to specify for individual models if the text in the 
model is display/not display text on the plan view.

For any setting plan_table_settings_4d, if Text is selected without walking right, then the Plan Text 
panel is brought up (documented in the next section).

The text walk-right menu is

Text
plan_text

Position of option on menu: Plan View Menu     View => Settings => Text => Text

The Text option allows the user to specify how text is displayed in the plan view and on any plan 
view plots. Text can be drawn in full, quick mode consisting of the bottom half of a rectangle 
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indicating the height and the length of the text, or not drawn at all.

This setting also applies to the z-values and vertex numbers controlled by view settings.

There are also two text threshold values (quick and none) designed for use with world text. 
When the screen size of text drops below the thresholds, the mode of display is automatically 
adjusted.

Hence when the screen size of world text gets small, the text can be drawn as quick text or even 
not displayed at all.

Selecting Text fires up the Plan Text panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify text drawing flags for. 

Text draw mode input full full, quick, none
if full, any text in the plan view will drawn as expected.
 If quick, the text will not be drawn but replaced by a three sided box to indicate where the text is.
 If none, nothing is displayed where the text would have been.

Quick threshold (pix) input 4.5
if the screen size of text displayed on the plan view goes below this pixel size, then the text is 
automatically drawn in quick mode.

None threshold (pix) input 2
if the screen size of text displayed on the plan view goes below this pixel size, then the text is not drawn.

Set button

set the text draw mode and thresholds to the values given in the panel fields. The plan view is then 
redrawn using the new values.

Note
The Text=>Text option applies to all text on the view. That is, for any text from strings in models 
on the view, or for the z-values and vertex numbers text controlled by view settings (view text). 
The Single and Table options of Text are only for text in models. There are Single and Table options 
for view text under the Vertex no.s and Z values Settings options.

Single
model_text_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Text => Single

The Single option allows the user to stop drawing any text from models on the view (world or 
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pixel), or if text is drawn, set a maximum equivalent world size that is used as an upper limit for 
drawing pixel text in the model.

Selecting Single fires up the Model Text for Plan View panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify model text drawing flags for. 

Model input
the model to set the Draw text and Height max parameters for.

Draw text tick-cross tick
If not tick, then no text from strings in models (text, 4d and survey strings) is drawn. 
if tick, any text from strings in models (text, 4d and survey strings) will then be checked against the 
height max for pixel text, or text drawn mode for world text, to see if it is drawn.

Height max (w) input 0
if non-zero, then when the screen scale is such that the height of any string text defined in pixels 
converted to a world size is greater than height max (w), then the text is not drawn. Hence on zooming 
out, any pixel text in the models will eventually stop drawing.

Set button

set the text draw mode and thresholds to the values given in the panel fields. The plan view is then 
redrawn using the new values.

Table
model_text_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Text => Table

The Table option displays a list a models on the view with their draw flag. The draw flag can be 
toggled to allow the drawing/stop drawing text from the model on the view (world or pixel).

Selecting Table fires up the Model Text Table for Plan View panel.



12d Model Reference Manual

Page 202 March 2007Plan View Menu

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify model text table drawing flags for. 

Draw tick-cross
If not tick, then no text from strings in models (text, 4d and survey strings) is drawn. 
if tick, any text from strings in models (text, 4d and survey strings) will then be checked against the 
height max for pixel text, or text drawn mode for world text, to see if it is drawn.

Model input
the model to set the Draw flag for.

Set button
set the text draw flags for the models in the table.

Toggle
plan_view_toggle_model_text

Position of menu: Plan View Menu     View => Settings => Text => Toggle

Walking-right on the Toggle option displays a list a models on the view with their text draw flag. 
The text draw flag can be toggled on/off by selecting the model on the list. Note that [n/a] 
means that the model has not been individually set on or off and the general Text toggle is used 
for the model.
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Tins
plan_view_tin_settings_menu
Position of menu: Plan View Menu     View => Settings => Tins

The options on the tins walk-right menu control the display of tins on the view.The tins walk-
right menu is

Contours
tin_draw_contours_for_view

Position of option on menu: Plan View Menu     View => Settings => Tins => Contours

Position of option on menu: Perspective View Menu     View => Settings => Tins => Contours

The Contours option defines contour and bold increments and colours, and also whether these 
contours are displayed for the triangles from any tins on the view. Because the contours are just 
drawn separately for each triangle, they are know as quick or fast contours.

Selecting Contours fires up the Tin Draw Contours for View panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify fast contour drawing parameters for. 

Draw triangles contours tick-cross
if tick, the contours for any triangles in any tins on the view are displayed.

Cont inc input 1.0
increment between contoured values.

Cont ref input 0.0
reference value for the contour increments.

Cont colour input cyan available colours
colour of the contours
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Bold inc input 5.0
increment for the bold contours. If the bold increment is blank or zero, then no bold contours are drawn. 
If the bold increment is non-zero, it must be an integer multiple of the contour increment

Bold colour input magenta available colours
colour of the bold contours

Set button
set the value in the panel and then redraw the plan view.

Edges
tin_draw_edges_for_view
Position of option on menu: Plan View Menu     View => Settings => Tins => Edges

Position of option on menu: Perspectives View Menu     View => Settings => Tins => Edges

The edges option allows the user to specify whether the edges of triangles from any tins on the 
view are displayed. Selecting edges fires up the tin draw edges for view panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify tin edge drawing flag for. 

Draw triangles edges tick-cross
if tick, the edges of any triangles in any tins on the view are displayed.

Set button
set the value and then redraw the plan view.

Flow Arrows
tin_draw_flow_arrows_for_view
Position of option on menu: Plan View Menu     View => Settings => Tins => Flow arrows

Position of option on menu: Perspective View Menu     View => Settings => Tins => Flow arrows

The flow arrows option defines the colour and length of flow arrows, and also whether the flow 
arrows are displayed for the triangles from any tins on the view. Selecting flow arrows fires up the 
tin draw flow arrows for view panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify tin arrow drawing flag for. 

Draw triangles flow arrows       tick-cross
if tick, the flow arrows for any triangles in any tins on the view are displayed.

Arrow length (w) input
length in world units to draw flow arrows.

Colour for arrows input cyan available colours
colour for the arrows.

Set button
set the value in the panel and then redraw the plan view.
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Mesh
tin_draw_mesh_for_view

Position of option on menu: Plan View Menu     View => Settings => Tins => Mesh

Position of option on menu: Perspective View Menu     View => Settings => Tins => Mesh

The mesh option defines a rectangular mesh, and also whether the mesh is displayed for the 
triangles from any tins on the view. Selecting mesh fires up the tin draw mesh for view panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify tin mesh drawing flag for. 

Draw triangles mesh  tick-cross
if tick, a rectangular mesh for any triangles in any tins on the view are displayed.

Mesh x input 100
the distance between the x mesh lines. If this value is zero, the x mesh lines will not be drawn.

Mesh y input 100
the distance between the y mesh lines. If this value is zero, the y mesh lines will not be drawn.

Bold x input 100
the distance between the bold x mesh lines. If this value is zero, the bold x mesh lines will not be drawn.

Bold y input 100
the distance between the bold y mesh lines. If this value is zero, the bold y mesh lines will not be drawn.

Mesh colour input dark green available colours
colour that the mesh is drawn in.

Bold colour input dark green available colours
colour that the bold mesh is drawn in.

Set button
set the value in the panel and then redraw the plan view.
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Solid
tin_draw_solid_for_view

Position of option on menu: Plan View Menu     View => Settings => Tins => Solid

The solid option allows the user to specify whether the triangles from any tins on the view are 
displayed as solid colour. Selecting solid fires up the tin draw solid for view panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify tin solid drawing flag for. 

Draw triangles solid tick-cross
if tick, any triangles in any tins on the view are displayed in solid colour.

Set button
set the value and then redraw the plan view.
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Vertices
plan_view_vertices_settings_menu

Position of menu: Plan View Menu     View => Settings => Vertices

The Vertices option allows the user to specify whether crosses at the vertices of strings are

(a) not drawn at all

or

(b) if set to draw, then only drawn if equivalent world size is not too large. This stops the 
drawing of crosses when the displaying world size is large in proportion to other world 
units (e.g. when zooming out).

Hence the Vertices option tries to control the drawing of vertex crosses on the view so that the 
crosses stop displaying as the user zooms out

Depending on whether the environment variable plan_table_settings_4d is zero or not, the Vertices 
option draws crosses for string vertices for any model on the view, or the drawing of crosses can 
be set for individual models.

If the environment variable plan_table_settings_4d is set to 0:

the Vertices option is used to display/not display crosses at the vertices of strings in all models 
on the plan view. For a text string, a cross is placed at the text justification position.

Selecting Vertices brings up the Crosses at String Vertices for Plan View panel, without the Model 
field.

If plan_table_settings_4d is non-zero: 

the Vertices option then has a walk-right menu with options to specify for each model on the plan 
view whether crosses at the vertices of strings in the model are

(a) not drawn at all

or

(b) if set to draw, then the crosses are only drawn if equivalent world size is not too large. This 
stops the drawing of crosses when its displaying world size is large in proportion to other 
world units (e.g. when zooming out).

If Vertices is selected without walking right, the Crosses at String Vertices for Plan View panel is 
brought up (documented in the next section).

The Vertices walk-right menu is

Single
crosses_at_string_vertices_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Vertices => Single

The Single option is used to set parameters for drawing crosses at vertices of strings for all 
models not defined in the Table option or for a single model on the plan view. For a text string, a 
cross is placed at the text justification position.

After selecting the Single option, the Crosses at String Vertices for Plan View panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify string vertices drawing parameters for.

Model input
if blank, then all models not mentioned in the Table option use these parameters for drawing crosses on 
a view.
If non blank, then this model only will be set to draw crosses with the parameters on this panel.

Draw crosses tick-cross
If tick, vertex crosses for the model will be checked against the Size max (w) before being drawn.
If not tick, then no vertex crosses for strings in the given model are drawn on the plan view. 

Colour input default pt colour available colours
colour of the crosses

Size (p) input default text height
size in pixels that the crosses are drawn on a plan view

Size max (w) input 0
if non-zero: when the cross is displayed on a plan view then there is an equivalent size of the cross in 
world units that matches the display size. If Size max (w) has a non-zero value, then if the equivalent 
world size of the cross on the plan view is greater than Size max (w), then the cross is not drawn. Hence 
zooming out will eventually stop the crosses from drawing.

Size (w) input 0
size in world units of the cross when plotted or output.

Angle input 0
angle in degrees that the cross is rotated about the (x,y) position of the string vertices.

Set button
set the values in the panel and then redraw the plan view.

Size max (w) button
sets Size max (w) to be the world size of crosses as they are currently displayed on the given plan view. 
Hence if any further zoom out is done, the crosses will stop drawing. The set button must then be 
clicked to set the values for the view.
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Reset button
reset all the parameters so no models are individually set for the view.

Table
crosses_at_string_vertices_table_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Vertices => Table

The Table option displays a list of models on the view with their vertex drawing parameters 
which can then be modified from the table.

Selecting Table fires up the Crosses at String Vertices Table for Plan View panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify string vertices drawing parameters for. 

Draw tick-cross
If not tick, then no vertex crosses from strings in the given model are drawn on the plan view. 
if tick, any cross for vertices in the model will be checked against the Sz max (w) to see if it is drawn.

Model input
the model to set the parameters for.

Colour input default pt colour available colours
colour of the crosses at the vertices

Size input default text height
size in pixels that the crosses are drawn on a plan view.
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Sz max (w) input 0
if non-zero:
the size of the crosses in world units is greater than Sz max (w), then the crosses are not drawn. Hence 
zooming out will eventually stop the crosses from drawing.

Angle input 0
angle in degrees that the cross is rotated about the (x,y) position of the string vertices.

Set button

set the vertex cross drawing parameters for the models in the table.
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Toggle
plan_view_toggle_vertices

Position of option on menu: Plan View Menu     View => Settings => Vertices => Toggle

Walking-right on the Toggle option displays a list of models on the view with their vertex cross 
draw flag. The vertex cross draw flag can be toggled on/off for the model by selecting the model 
on the list.

Note that [n/a] means that the model has not been individually set on or off and the general 
Vertex toggle is used for the model.

Point/Vertex Id’s
plan_view_vertex_ids_settings_menu

Position of menu: Plan View Menu     View => Settings => Point/Vertex id’s

The Point/Vertex Id’s option allows the user to specify whether the point/vertex id (a point 
number recorded for a vertex) for any super string vertex are

(a) not drawn at all

or

(b) if set to draw, then only drawn if the equivalent world size is not too large. This stops the 
drawing of point/vertex id’s when the displaying world size is large in proportion to other 
world units (e.g. when zooming out).

Hence the Point/Vertex id’s option tries to control the drawing of point numbers on the view so 
that the numbers stop displaying as the user zooms out

Note - Point/Vertex id’s (numbers) are not to be confused with vertex indices which are simply 
the position of the vertex in the string.

Depending on whether the environment variable plan_table_settings_4d is zero or not, the Point/
Vertex Id’s option draws point/vertex numbers for string vertices for any model on the view, or 
the drawing of vertex id’s can be set for individual models.

If the environment variable plan_table_settings_4d is set to 0:

the Point/Vertex id’s option is used to display/not display vertex numbers at the vertices of 
strings in all models on the plan view.

Selecting Point/Vertex id’s brings up the Vertex ID’s for Plan View  panel, without the Model field.
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If plan_table_settings_4d is non-zero: 

the Point/Vertex id’s option then has a walk-right menu with options to specify for each model on 
the plan view whether point numbers for strings in the model are

(a) not drawn at all

or

(b) if set to draw, then the point numbers are only drawn if the equivalent world size is not too 
large. This stops the drawing of numbers when the displaying world size is large in 
proportion to other world units (e.g. when zooming out).

If Point/Vertex id’s is selected without walking right, the Vertex ID’s for Plan View  panel is brought 
up (documented in the next section).

The Point/Vertex id’s walk-right menu is

Single
vertex_id_s_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Point/Vertex id s => Single

The Single option is used to set parameters for drawing point/vertex id’s (numbers) of strings 
for all models not mentioned in the Table or set the parameters for an individual model on the 
plan view.

After selecting the Single option, the Vertex ID’s for Plan View panel is displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify point/vertex id’s (number) drawing parameters for. 

Model input
if blank, then all models not mentioned in the Table option use these parameters for drawing point 
numbers on a view.
If non blank, then this model only will be set to draw point/vertex id’s with the parameters on this 
panel.

Draw numbers tick-cross
If tick, point/vertex id’s (numbers) will be checked against the Height max (w) before being drawn.
If not tick, then no point/vertex id’s for strings are drawn on the plan view. 

Colour input default pt colour available colours
colour of the point/vertex id’s (numbers)

Text style input 1 available text styles
textstyle of the point/vertex id’s (numbers)

Height (p) input 8
height in pixels that the point/vertex id’s (numbers) are drawn on a plan view.

Height max (w) input 0
 if non-zero: when the point/vertex id’s (numbers) is displayed on a plan view then there is an 
equivalent height of the id’s (numbers) in world units that matches the display size. If Size max (w) has 
a non-zero value, then if the equivalent world size of the id’s (numbers) on the plan view is greater than 
Size max (w), then the id’s (numbers) is not drawn. Hence zooming out will eventually stop the point/
vertex id’s (numbers) from drawing.

Height (w) input 2
height in world units of the point/vertex id’s (numbers) when plotted or output.

Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the string vertices.

Offset (p) input default text height
distance in pixels that the text is drawn from the (x,y) position of the string vertices.

Offset (w) input default text height
distance in world units that the text is drawn from the (x,y) position of the string points when plotted

Set button
set the values in the panel and then redraw the plan view.

Size max (w) button
when clicked, size max (w) is set to be the world size of point id’s (numbers) displayed on the given 
plan view. Hence if any further zoom out is done, the point id’s (numbers) will stop drawing. The set 
button must then be clicked to set the values for the view.

Reset button
reset all the parameters so no models are individually set for the view.

Table
vertex_id_s_table_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Point/Vertex id’s => Table

The Table option displays a list of models on the view with their point id’s (numbers) drawing 
parameters which can then be modified from the table.

Selecting Table fires up the Vertex ID’s Table for Plan View panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify point id’s (numbers) drawing parameters for. 

Draw tick-cross
If not tick, then no point numbers for strings in the given model are drawn on the plan view. 
if tick, point id’s (numbers) for strings in the model will be checked against the Ht max (w) to see if they 
are drawn.

Model input
the model to set the parameters for.

Colour input default pt colour available colours
colour of the point id’s (numbers)

Text style input 1 available text styles
textstyle of the point id’s (numbers)

Height input 8
height in pixels of the point id’s (numbers).

Ht max (w) input 0
if non-zero: when the plan view is such that the height of the point id’s (numbers) in world units is 
greater than Height max (w), then the point id’s (numbers) are not drawn. Hence as one zooms out, the 
point id’s (numbers) will eventually stop drawing.

Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the string vertices.
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Offset input default text height
distance in pixels that the text is drawn from the (x,y) position of the string vertices.

Set button
set the values in the panel and then redraw the plan view.

Toggle
plan_view_toggle_vertex_id_s

Position of menu: Plan View Menu     View => Settings => Point/Vertex id’s => Toggle

Walking-right on the Toggle option displays a list of models on the view with their point/vertex 
id’s (numbers) draw flag. The point/vertex id’s (numbers) draw flag can be toggled on/off for 
the model by selecting the model on the list. Note that [n/a] means that the model has not been 
individually set on or off and the general Point/vertex id’s toggle is used for the model.

Vertex Indices
plan_view_vertex_indices_settings_menu

Position of menu: Plan View Menu     View => Settings => Vertex Indices

The Vertex Indices option allows the user to specify whether the vertex indices (position of the 
vertex in the string) for all vertices of strings are

(a) not drawn at all

or

(b) if set to draw, then only drawn if the equivalent world size is not too large. This stops the 
drawing of vertex indices when the displaying world size is large in proportion to other 
world units (e.g. when zooming out).

Hence the Vertex Indices option tries to control the drawing of vertex indices on the view so that 
the indices stop displaying as the user zooms out

Note - vertex indices are not to be confused with point/vertex numbers which may not be defined 
for a vertex in the string.

Depending on whether the environment variable plan_table_settings_4d is zero or not, the Vertex 
indices option draws vertex indices for string vertices for any model on the view, or the drawing 
of vertex indices can be set for individual models.

If the environment variable plan_table_settings_4d is set to 0:

the Vertex Indices option is used to display/not display vertex indices at the vertices of strings in 
all models on the plan view.
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Selecting Vertex Indices brings up the Vertex Indices for Plan View panel, without the Model field.

If plan_table_settings_4d is non-zero: 

the Vertex Indices option then has a walk-right menu with options to specify for each model on 
the plan view whether vertex indices for strings in the model are

(a) not drawn at all

or

(b) if set to draw, then the vertex indices are only drawn if the equivalent world size is not too 
large. This stops the drawing of indices when the displaying world size is large in 
proportion to other world units (e.g. when zooming out).

If Vertex Indices is selected without walking right, the Vertex Indices for Plan View panel is 
brought up (documented in the next section).

The Vertex Indices walk-right menu is

Single
vertex_indices_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Vertex indices => Single

The Single option is used to set parameters for drawing vertex indices of strings for all models 
not mentioned in the Table or set the parameters for an individual model on the plan view.

After selecting the Single option, the Vertex Indices for Plan View panel is displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify vertex indices drawing parameters for. 

Model input
if blank, then all models not mentioned in the Table option use these parameters for drawing vertex 
indices on a view.
If non blank, then this model only will be set to draw vertex indices with the parameters on this panel.

Draw numbers tick-cross
If tick, vertex indices will be checked against the Height max (w) before being drawn.
If not tick, then no vertex indices for strings are drawn on the plan view. 

Colour input default pt colour available colours
colour of the vertex indices

Text style input 1 available text styles
textstyle of the vertex indices

Height (p) input 8
height in pixels that the vertex indices are drawn on a plan view.

Height max (w) input 0
if non-zero: when the plan view is such that the height of the vertex indices in world units is greater 
than Height max (w), then the vertex indices are not drawn. Hence as one zooms out, the vertex indices 
will eventually stop drawing.
 if non-zero: when the vertex indices are displayed on a plan view then there is an equivalent height of 
the number in world units that matches the display size. If Size max (w) has a non-zero value, then if 
the equivalent world size of the number on the plan view is greater than Size max (w), then the number 
is not drawn. Hence zooming out will eventually stop the vertex indices from drawing.

Height (w) input 2
height in world units of the vertex indices when plotted or output.

Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the string vertices.

Offset (p) input default text height
distance in pixels that the text is drawn from the (x,y) position of the string vertices.

Offset (w) input default text height
distance in world units that the text is drawn from the (x,y) position of the string points when plotted

Set button
set the values in the panel and then redraw the plan view.

Size max (w) button
when clicked, size max (w) is set to be the world size of vertex indices displayed on the given plan 
view. Hence if any further zoom out is done, the vertex indices will stop drawing. The set button must 
then be clicked to set the values for the view.

Reset button
reset all the parameters so no models are individually set for the view.

Table
vertex_indices_table_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Vertex indices => Table

The Table option displays a list of models on the view with their vertex indices drawing 
parameters which can then be modified from the table.
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Selecting Table fires up the Vertex Indices Table for Plan View panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify vertex indices drawing parameters for. 

Draw tick-cross
If not tick, then no vertex indices for strings in the given model are drawn on the plan view. 
if tick, vertex indices for strings in the model will be checked against the Ht max (w) to see if it is drawn.

Model input
the model to set the parameters for.

Colour input default pt colour available colours
colour of the vertex indices

Text style input 1 available text styles
textstyle of the vertex indices

Height input 8
height in pixels of the vertex indices.

Ht max (w) input 0
if non-zero: when the plan view is such that the height of the vertex indices in world units is greater 
than Height max (w), then the vertex indices are not drawn. Hence as one zooms out, the vertex indices 
will eventually stop drawing.

Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the string vertices.
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Offset input default text height
distance in pixels that the text is drawn from the (x,y) position of the string vertices.

Set button
set the values in the panel and then redraw the plan view.

Toggle
plan_view_toggle_vertex_indices

Position of menu: Plan View Menu     View => Settings => Vertex Indices => Toggle

Walking-right on the Toggle option displays a list of models on the view with their vertex indices 
draw flag. The vertex indices draw flag can be toggled on/off for the model by selecting the 
model on the list. Note that [n/a] means that the model has not been individually set on or off 
and the general Vertex Indices toggle is used for the model.
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Z Values
plan_view_z_values_settings_menu

Position of menu: Plan View Menu     View => Settings => Z values

The Z values option allows the user to specify whether the z co-ordinate for all vertices of strings 
are

(a) not drawn at all

or

(b) if set to draw, then only drawn if the equivalent world size is not too large. This stops the 
drawing of z values when the displaying world size is large in proportion to other world 
units (e.g. when zooming out).

Hence the Z values option tries to control the drawing of vertex z values on the view so that the 
numbers stop displaying as the user zooms out

Depending on whether the environment variable plan_table_settings_4d is zero or not, the Z values 
option draws z values for string vertices for any model on the view, or the drawing of vertex z 
values can be set for individual models.

If the environment variable plan_table_settings_4d is set to 0:

the Z values option is used to display/not display vertex z values at the vertices of strings in all 
models on the plan view.

Selecting Z values brings up the Z Values for Plan View panel, without the Model field.

If plan_table_settings_4d is non-zero: 

the Z values option then has a walk-right menu with options to specify for each model on the plan 
view whether vertex z values for strings in the model are

(a) not drawn at all

or

(b) if set to draw, then the z values are only drawn if the equivalent world size is not too large. 
This stops the drawing of numbers when the displaying world size is large in proportion to 
other world units (e.g. when zooming out).

If Z values is selected without walking right, the   Z Values for Plan View panel is brought up 
(documented in the next section).

The Z values walk-right menu is

Single
z_values_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Z values => Single

The Single option is used to set parameters for drawing vertex z values of strings for all models 
not mentioned in the Table or for an individual model on the plan view.

After selecting the Single option, the   Z Values for Plan View panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify vertices z values drawing parameters for. 

Model input
if blank, then all models not mentioned in the Table option use these parameters for drawing vertex z-
values on a view.
If non blank, then this model only will be set to draw vertex z-values with the parameters on this panel.

Draw z values tick-cross
If tick, vertex z values will be checked against the Height max (w) before being drawn.
If not tick, then no vertex z values for strings are drawn on the plan view. 

Colour input default pt colour available colours
colour of the z values

Text style input 1 available text styles
textstyle of the z values

Height (p) input 8
height in pixels of the z values.

Height max (w) input 0
if non-zero: when the plan view is such that the height of the z values in world units is greater than 
Height max (w), then the z values are not drawn. Hence as one zooms out, the z values will eventually 
stop drawing.

 Height (w) input 2
height in world units of the z values when plotted or output.
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Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the string vertices.

Offset (p) input default text height
distance in pixels that the text is drawn from the (x,y) position of the string vertices.

Offset (w) input default text height
distance in world units that the text is drawn from the (x,y) position of the string points when plotted 
or output.

Decimal places input 3
number of decimal places when displaying the z value

Show null z’s tick box
if tick, null z values are displayed as null. If not tick, no z value is displayed at null z-values.

Set button
set the values in the panel and then redraw the plan view.

Size max (w) button
when clicked, size max (w) is set to be the world size of vertex z-values displayed on the given plan 
view. Hence if any further zoom out is done, the vertex z-values will stop drawing. The set button 
must then be clicked to set the values for the view.

Reset button
reset all the parameters so no models are individually set for the view.

Table
z_values_table_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Z values => Table

The Table option displays a list of models on the view with their vertex z value drawing 
parameters which can then be modified from the table.

Selecting Table fires up the Z Values Table for Plan View panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify vertices z values drawing parameters for. 

Draw tick-cross
If not tick, then no vertex z values for strings in the given model are drawn on the plan view. 
if tick, z values for strings in the model will be checked against the Ht max (w) to see if it is drawn.

Model input
the model to set the parameters for.

Colour input default pt colour available colours
colour of the z values

Text style input 1 available text styles
textstyle of the z values

Height input 8
height in pixels of the z values.
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Ht max (w) input 0
if non-zero: when the plan view is such that the height of the z values in world units is greater than Ht 
max (w), then the z values are not drawn. Hence as one zooms out, the z values will eventually stop 
drawing.

Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the string points.

Offset input default text height
distance in pixels that the text is drawn from the (x,y) position of the string points

Decimal places input 3
number of decimal places when displaying the z value

Nulls yes-no no yes, no
if tick, null z values are displayed as null. If not tick, no z value is displayed at null z-values.

Set button
set the values in the panel and then redraw the plan view.

Toggle
plan_view_toggle_z_values

Position of menu: Plan View Menu     View => Settings => Z values => Toggle

Walking-right on the Toggle option displays a list of models on the view with their vertex z 
values draw flag. The vertex z value draw flag can be toggled on/off for the model by selecting 
the model on the list.

Note that [n/a] means that the model has not been individually set on or off and the general 
Z values toggle is used for the model.
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Names
plan_view_string_names_settings_menu

Position of menu: Plan View Menu     View => Settings => Names

The names option allows the user to specify whether the string name is drawn at each string 
vertex. The string names can be

(a) not drawn at all

or

(b) if set to draw, then only drawn if the equivalent world size is not too large. This stops the 
drawing of string names when the displaying world size is large in proportion to other 
world units (e.g. when zooming out).

Hence the Names option tries to control the drawing of string names on the view so that the 
numbers stop displaying as the user zooms out

Depending on whether the environment variable plan_table_settings_4d is zero or not, the names 
option draws string names for string vertices for any model on the view, or the drawing of string 
names at vertices can be set for individual models.

If the environment variable plan_table_settings_4d is set to 0:

the names option is used to display/not display the string name at the vertices of strings in 
all models on the plan view.

Selecting names brings up the Plan String Names for Plan View panel, without the Model field.

If plan_table_settings_4d is non-zero: 

the names option then has a walk-right menu with options to specify for each model on the plan 
view whether string names are drawn at vertices for strings in the model are

(a) not drawn at all

or

(b) if set to draw, then the string names are only drawn if the equivalent world size is not too 
large. This stops the drawing of names when the displaying world size is large in proportion 
to other world units (e.g. when zooming out).

If Names is selected without walking right, the Plan String Names for Plan View panel is brought 
up (documented in the next section).

The Names walk-right menu is

Single
plan_string_names_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Names => Single

The Single option is used to set parameters for drawing the string name at each vertex of strings 
for any models not mentioned in the Table, or for an individual model on the plan view.

After selecting the Single option, the Plan String Names for Plan View panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify string name drawing parameters for. 

Model input
if blank, then all models not mentioned in the Table option use these parameters for drawing the string 
name at each vertex on a view.
If non blank, then this model only will be set to draw the string name at each vertex with the 
parameters on this panel.

Draw names tick box
If tick, string names for the model will be checked against the Height max (w) before being drawn.
If not tick, then no string names for strings in the given model are drawn on the plan view. 

Colour input default pt colour available colours
colour of the string names.

Text style input 1 available text styles
textstyle of the string names.

Height (p) input 8
height in pixels of the string names.

Height max (w) input 0
if non-zero: when the plan view is such that the height of the string names in world units is greater 
than Height max (w), then the string names are not drawn. Hence as one zooms out, the string names 
will eventually stop drawing.

 Height (w) input 2
height in world units of the string names when plotted or output.

Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the string vertices.
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Offset (p) input default text height
distance in pixels that the text is drawn from the (x,y) position of the string vertices.

Offset (w) input default text height
distance in world units that the text is drawn from the (x,y) position of the string vertices when plotted 
or output.

Set button
set the values in the panel and then redraw the plan view.

Size max (w) button
when clicked, size max (w) is set to be the world size of string names as displayed on the given plan 
view. Hence if any further zoom out is done, the vertex string names will stop drawing. The set button 
must then be clicked to set the values for the view.

Reset button
reset all the parameters so no models are individually set for the view.

Table
string_names_table_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Names => Table

The Table option displays a list of models on the view with their string names drawing 
parameters which can then be modified from the table.

Selecting Table fires up the String Names Table for Plan View panel.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify string names drawing parameters for. 

Draw tick-cross
If not tick, then no string names for strings in the given model are drawn on the plan view. 
if tick, string names for strings in the model will be checked against the Ht max (w) to see if it is drawn.

Model input
the model to set the parameters for.

Colour input default pt colour available colours
colour of the string names

Text style input 1 available text styles
textstyle of the string names

Height input 8
height in pixels of the string names.

Ht max (w) input 0
if non-zero: when the plan view is such that the height of the string names in world units is greater 
than Ht max (w), then the string names are not drawn. Hence as one zooms out, the string names will 
eventually stop drawing.

Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the string vertices.

Offset input default text height
distance in pixels that the text is drawn from the (x,y) position of the string vertices

Set button
set the values in the panel and then redraw the plan view.

Toggle
plan_view_toggle_string_names

Position of menu: Plan View Menu     View => Settings => Names => Toggle

Walking-right on the Toggle option displays a list of models on the view with their string names 
draw flag. The string name draw flag can be toggled on/off for the model by selecting the model 
on the list.

Note that [n/a] means that the model has not been individually set on or off and the general 
names toggle is used for the model.
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Vertex Attributes
plan_view_attributes_settings_menu

Position of menu: Plan View Menu     View => Settings => Attributes

The Attributes option allows the user to specify whether the vertex attributes are drawn at each 
string vertex. The vertex attributes can be

(a) not drawn at all

or

(b) if set to draw, then only drawn if the equivalent world size is not too large. This stops the 
drawing of attributes when the displaying world size is large in proportion to other world 
units (e.g. when zooming out).

Hence the Attributes option tries to control the drawing of attributes on the view so that the text 
stops displaying as the user zooms out

Depending on whether the environment variable plan_table_settings_4d is zero or not, the attributes 
option draws attributes string vertices for any model on the view, or the drawing of attributes at 
vertices can be set for individual models.

If the environment variable plan_table_settings_4d is set to 0:

the Attributes option is used to display/not display the attributes at the vertices of strings in 
all models on the plan view.

Selecting Attributes brings up the Attributes for Plan View panel, without the Model field.

If plan_table_settings_4d is non-zero: 

the Attributes option then has a walk-right menu with options to specify for each model on the 
plan view whether attributes are drawn at vertices for strings in the model are

(a) not drawn at all

or

(b) if set to draw, then the attributes are only drawn if the equivalent world size is not too large. 
This stops the drawing of attributes when the displaying world size is large in proportion to 
other world units (e.g. when zooming out).

If Attributes is selected without walking right, the Attributes for Plan View panel is brought up 
(documented in the next section).

The Attributes walk-right menu is

Single
Position of option on menu: Plan View Menu     View => Settings => Attributes => Single

The Single option is used to set parameters for drawing the attributes at each vertex of strings for 
any models not mentioned in the Table, or for an individual model on the plan view.

After selecting the Single option, the Attributes for Plan View panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify attribute drawing parameters for. 

Model input
if blank, then all models not mentioned in the Table option use these parameters for drawing the 
attributes at each vertex on a view.
If non blank, then this model only will be set to draw the attributes at each vertex with the parameters 
on this panel.

Draw attributes tick box
If tick, attributes for the model will be checked against the Height max (w) before being drawn.
If not tick, then no attributes for strings in the given model are drawn on the plan view. 

Colour input default pt colour available colours
colour of the attributes.

Text style input 1 available text styles
textstyle of the attributes.

Height (p) input 8
height in pixels of the attributes

Height max (w) input 0
if non-zero: when the plan view is such that the height of the attributes in world units is greater than 
Height max (w), then the attributes are not drawn. Hence as one zooms out, the attributes will 
eventually stop drawing.

 Height (w) input 2
height in world units of the attributes when plotted or output.
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Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the string vertices.

Offset (p) input default text height
distance in pixels that the text is drawn from the (x,y) position of the string vertices.

Offset (w) input default text height
distance in world units that the text is drawn from the (x,y) position of the string vertices when plotted 
or output.

Decimal places input 3
number of decimal places to use for real attributes.

Show null z’s tick box
if tick, real attributes that are null z values are displayed as null. If not tick, no real attribute is 
displayed when it has a null z-value.

Set button
set the values in the panel and then redraw the plan view.

Size max (w) button
when clicked, size max (w) is set to be the world size of attributes as displayed on the given plan view. 
Hence if any further zoom out is done, the vertex attributes will stop drawing. The set button must 
then be clicked to set the values for the view.

Reset button
reset all the parameters so no models are individually set for the view.

Table
attributes_table_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Attributes => Table

The Table option displays a list of models on the view with their attributes drawing parameters 
which can then be modified from the table.

Selecting Table fires up the Attributes Table for Plan View panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify vertex attribute drawing parameters for. 

Draw tick-cross
If not tick, then no attributes for strings in the given model are drawn on the plan view. 
if tick, vertex attributes for strings in the model will be checked against the Ht max (w) to see if it is 
drawn.

Model input
the model to set the parameters for.

Colour input default pt colour available colours
colour of the vertex attributes

Text style input 1 available text styles
textstyle of the vertex attributes

Height input 8
height in pixels of the vertex attributes

Ht max (w) input 0
if non-zero: when the plan view is such that the height of the vertex attributes in world units is greater 
than Ht max (w), then the vertex attributes are not drawn. Hence as one zooms out, the vertex 
attributes will eventually stop drawing.

Angle input -45
angle in degrees that the text is rotated about the (x,y) position of the vertex attributes.
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Offset input default text height
distance in pixels that the text is drawn from the (x,y) position of the string vertices

Precision input 3
number of decimal places to use for any real attributes

Null tick box
if tick, real attributes that are null z values are displayed as "null". If not tick, no real attribute is 
displayed when it has a null z-value.

Set button
set the values in the panel and then redraw the plan view.

Toggle
plan_view_toggle_attributes

Position of menu: Plan View Menu     View => Settings => Names => Toggle

Walking-right on the Toggle option displays a list of models on the view with their vertex 
attribute draw flag. The vertex attribute flag can be toggled on/off for the model by selecting the 
model on the list.

Note that [n/a] means that the model has not been individually set on or off and the general 
attributes toggle is used for the model.
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Arc Centres
arc_centres_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Arc centres

The arc centres option allows the user to specify whether the centres of arcs and circles are 
displayed on the view. 

Selecting Arc centres fires up the Arc Centres for Plan View panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to modify arc centres flag for. 

Draw arc centres tick-cross tick
if tick is selected, any arcs or circles on the view will also have their centres drawn. Otherwise the 
centres are not displayed.

Set button
set the draw arc centres mode to the value in the draw arc centre tick-cross panel box. The plan view is 
then redrawn using the mode.

Work Plane
work_plane

Position of option on menu: Plan View Menu     View => Settings => Work plane

A plane not perpendicular to the (x,y) plane, can be used to define a unique z-value for any (x,y) 
co-ordinate pair. This fact is often invaluable when trying to defined three dimensional points 
using two-dimensional views.

In 12d Model, a work plane can be defined by giving three non-colinear points. If the work-plane 
is used in a plan or perspective view, then the (x,y,z) values are restricted to lie in the defined 
work plane.

The work plane option is used to define and set work planes.

After selecting the work plane option, the work plane panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input available views
name of the view to get or set the work plane in.

User work plane input ignore work plane     ignore work plane
    use work plane

the work plane is used or not depending on this field value.

Pt 1/2/3 xyz input/output 0 0 0
points in the work plane

Set button
A plane is defined by the three points given in the Pt xyz fields. This plane is set as the work plane for 
the view given by the view field. Although the work plane is set, it is not active unless the use work 
plane field is set to use work plane.

Get button
get the three points of the defined work plane for the view given in the view field. The points are 
displayed in the Pt xyz fields of the panel.

Rasters
draw_rasters_for_plan_view

Position of option on menu: Plan View Menu     View => Settings => Rasters

The Rasters option is used to turn on or off the drawing of any rasters in models on the view.

After selecting the Rasters option, the Draw Rasters for Plan View panel is displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to toggle the drawing of rasters on or off.

Draw rasters tick box tick
if tick, draw any rasters in any models on the view.

Set button
set the draw rasters mode.

Grid
grid_on_view

Position of option on menu: Plan View Menu View => Settings => Grid

Section View Menu View => Settings => Grid

Perspective View Menu View => Settings => Grid

A regular grid of x (East) and/or y (North) lines can be displayed in a view. The grid is set in a 
plane of constant z (the level of the grid). The x and y spacing for the grid lines can be set and 
labelled independently.

For a plan or section view, the grid covers the entire view. However, for a perspective view, the 
grid only covers the maximum extents of the models in the view.

 If the grid mode is set to 

full lines solid lines are drawn at the grid x (East) and y (North)spacing
crosses crosses are drawn at the intersection of the grid x and y spacing

marks lines are drawn at the beginning/end of the grid at x and y spacing

On selecting the option, the Grid on View panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views

the name of the view to define a grid for.

Grid draw tick-cross

if tick, the grid is drawn according to parameters in the rest of the panel.

Grid mode input full lines full lines, crosses, marks

the style of the grid being drawn - full lines, crosses or marks.
If full lines, then solid lines are drawn at the grid x and y spacing. 
If crosses, then crosses of size cross size are drawn at the intersection of the grid x and y spacing.
If marks, then solid lines size cross size are drawn at the beginning/end of the grid at the x and y 
spacing. 

Grid x input 100

the distance between the x (East) grid lines. If this value is zero, the x grid lines will not be drawn.

Grid y input 100

the distance between the y (North) grid lines. If this value is zero, the y grid lines will not be drawn.

Grid level input 0

the (x,y) grid is set in a plane of constant z. The grid level is the value of the constant z. This will only 
be used for a perspective view.

Grid colour input dark green available colours
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colour that the grid is drawn in.

Text x input text at bottom text off,
text at top,
text at bottom,
text at top and bottom

the x (East) grid lines can be labelled with their x value. If the grid lines are labelled, the labels can be 
drawn on the top, the bottom or both ends of the x-grid lines 

Text y input text at left text off,
text at left,
text at right,
text at left and right

the y (North) grid lines can be labelled with their y value. If the grid lines are labelled, the labels can be 
drawn on the left, the right or both ends of the y-grid lines 

Text style input 1

the text style of any grid labels.

Pre*postfix x input

prefix/postfix (pre*post) to be applied to the value of x (East). If pretext only, just give the text. If post 
text is required, precede it by a *. For example E*m will place E before the x value and m after the 
number.

Pre*postfix y input

prefix/postfix (pre*post) to be applied to the value of y (North). If pretext only, just give the text. If post 
text is required, precede it by a *. For example N*m will place N before the y value and m after the 
number.

Text height (pix) input 10.0

height in screen pixels of any grid labels.

Text plot height (mm) input 10.0

height in millimetres of any grid labels in a plot.

Text colour input yellow available colours

colour that any grid labels are drawn in.

Cross size (pixels) input 5.0

size in screen pixels of grid crosses.

Cross plot size (mm) input 1.0

size in millimetres of grid crosses in a plot.

Set button

the grid parameters are set to the values given in the panel. The grid is then redrawn in the view.

Note - If the view name is selected from the pop-up, or a <enter> is done after the view name is 
entered into the view field, the data for the grid on the named view is placed in the panel fields.

Colour
view_background_colour

Position of option on menu: Plan View Menu     View => Settings => Colour

The Colour option is used to set the background colour for the view.

WARNING - in 12d Model V5, the background colour is not saved for the view. It defaults to the 
default background colour (black or set by the environment variable 
BACKGOUND_COLOUR_4D) each time the project is opened.
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After selecting the Colour option, the View Background Colour panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to set the background colour for.

Colour colour box black available colours
if tick, draw any rasters in any models on the view.

Set button
set the background colour.

Drawing Filter
view_drawing_filter

Position of option on menu: Plan View Menu View => Settings => Drawing filter

Position of option on menu: Perspective View Menu View => Settings => Drawing filter

The Drawing filter option is used to set a filter on the view so that only the data satisfying the filter 
is drawn.

NOTE: the filter is not saved with the project.

After selecting the Drawing filter option, the View Drawing Filter panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View view box current view available views
name of the view to apply the drawing filter to.

Data filter view box current view available views
only the data satisfying the drawing filter is drawn on the view.

Set button
apply the drawing filter to the view.

Clear button
clear the drawing filter being applied to the view.
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Zoom
Position of menu: Plan View Menu     View => Settings => Zoom

The zoom option operators in the same way for Plan and Section views.

The zoom option can be selected in three ways. By clicking LB on zoom on a view button area, 
selecting the zoom option itself by clicking LB when the zoom option is highlighted on the zoom 
menu, or by activating the zoom option’s walk-right menu, zoom ops.

The zoom uses either a dynamics zoom or a zoom box 

Dynamic Zoom
After selecting the zoom option, dynamic zoom is selected by clicking MB or by typing ’d’.

Then press LB at the point that is to stay put during the dynamic zoom and then move the mouse 
up to zoom in or move the mouse down to zoom out. Another point can be selected to 
dynamically zoom in or out about.

The dynamic zoom continues until either RB is clicked, or MB is clicked (or ’d’ typed) to place 
the zoom option into zoom box mode.

Zoom Box
Position of option on menu: Plan View Menu     View => Settings => Zoom =>Zoom

After selecting the zoom option, the user can define the zoom box by 

(a) pressing down LB at one corner of the box and dragging the mouse and releasing LB when 
at the other corner of the zoom box

or

(b) picking two points from any plan views (by clicking LB in a plan view for each point) to 
define the diagonally opposite points of the zoom box. Note that the two points do not have 
to be from the same plan view.

Next the user selects the view (by clicking LB in the view) which is to be redrawn using this 
rectangle as the new drawing limits.

Often the same view is chosen for both defining the rectangle and redrawing. However, the 
power of the option is that the area to be “zoomed in” or “blown up” can be selected from one 
view and the zoomed area displayed in another view. The other view may not only be different 
to the views used to defined the zoom box, but may also have different models attached to it.

It is a useful technique to have a master view displaying the entire area of interest in one view, 
and use it to define zoom-rectangles for use in viewing smaller regions of data in other plan 
views.

To cancel the zoom after the zoom operation has been selected, click RB.

Next step messages - sent to the screen message area

<View Zoom> [Select][][] select 1st corner of box - RB to cancel
<View Zoom> [Select][][] select 2nd corner of box - RB to cancel
<View Zoom> [Select][][] select destination view - RB to cancel

WARNING - this option can not be applied to a perspective view.

Please continue to the next section “Zoom Ops menu” .

Zoom Ops menu
Section_View_Zoom_Menu
plan_view_zoom_menu
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Position of menu: Plan View Menu     View => Settings => Zoom

The zoom walk-right menu is

The by String, by Model and by View options use the x and y extents of the String, Model or View 
to define the display area for the view. These options will be described in more detail.

The option zoom is the same operation as the option just discussed, factor - to enlarge or reduce 
the view by a given magnification/reduction factor, and a number of preset view magnification 
and reduction factors.

By String, by Model and by View
plan_zoom_by_view
plan_zoom_by_string
plan_zoom_by_model
Position of option on menu: Plan View Menu View => Settings => Zoom =>by string

Position of option on menu: Plan View Menu View => Settings => Zoom =>by model

Position of option on menu: Plan View Menu View => Settings => Zoom =>by view

The three zoom options by String, by Model and by View work in a similar manner. After 
selecting the option, the Plan Zoom by String/ Model/ View panel is brought up.

a string defines the extent of the view
a model defines the extent of the view
a view defines the extent of the view
two point zoom - see previous section
two point shrink
zoom by a user supplied factor
zoom into the view by factor of 2
zoom into the view by factor of 3
zoom into the view by factor of 4
zoom into the view by factor of 8
zoom out of the view by a factor of 8
zoom out of the view by a factor of 4
zoom out of the view by a factor of 3
zoom out of the view by a factor of 2
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For by String, the user selects a string using the String button and the data on the view is redrawn 
so the selected string is fitted to the view, adjusted by the Zoom factor given in the panel.

Note that the selected string can be from a different view.

For by Model, the user enters a model name into the Model field and then selects the Zoom button. 
The data on the view is redrawn so the specified model is fitted to the view, adjusted by the Zoom 
factor given in the panel.

Note that the specified model does not have to be on the view.

For by View, the user enters a view name into the View field and then selects the Zoom button. The 
data on the view is redrawn so the specified view is fitted to the current view, adjusted by the 
Zoom factor given in the panel.

Note that the specified view does not have to be on the current view.

Shrink
Position of option on menu: Plan View Menu     View => Settings => Zoom =>Shrink

Shrink is the opposite of zoom: instead of the information in the view box being expanded to fill 
the view, the information in the view is shrunk to fit into the zoom box.

After selecting the shrink option, the user picks two points from any plan views (by clicking LB 
in a plan view for each point) to define the diagonally opposite points of a rectangle. Note that 
the two points do not have to be from the same plan view.

Next the user selects the view (by clicking LB in the view) which is to be redrawn by shrinking 
the data on the view to fit into this rectangle.

To cancel the zoom after the zoom operation has been selected, click RB.

WARNING - this option can not be applied to a perspective view

Factor
zoom_plan_view
zoom_section_view

Position of option on menu: Plan View Menu     View => Settings => Zoom => Factor

Position of option on menu: Section View Menu     View => Settings => Zoom => Factor

On selecting the factor option, the zoom plan view panel is displayed.

This option is used to magnify or reduce the information in the view by a user given amount.

The field and buttons in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
name of the view to set zoom factor for. 
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Zoom factor input 1.0
factor to magnify/reduce the information inside the view by. The value can be greater than 1.0 (zoom 
in) or less than 1.0 (zoom out).

Zoom button
the information displayed in the view is magnified/reduced by the factor given in the zoom factor field.

WARNING - this option can not be applied to a perspective view.

Pre-set Zoom Factors
Upon selecting a particular zoom factor (e.g. 4 x in), the user is asked to indicate a point in a view 
which is to become the new view-centre. The user then indicates (by clicking LB in the view) 
which view is to be redrawn with this point as the new centre and with the selected zoom factor 
applied to that view.

To cancel the zoom after the zoom operation has been selected, click RB.

Next step messages - sent to the screen message area

<View Magnify> [Select][][] select new centre of view - RB to cancel
<View Magnify> [Select][][] select destination view - RB to cancel

Pan
plan_view_pan_menu
section_view_pan_menu

Position of menu: Plan View Menu View => Settings => Pan

Position of menu: Section View Menu View => Settings => Pan

The Pan walk-right menu for Plan and Section views are

Pan operates the same way for Plan and Section views.

The pan option can be selected in four ways:

(a) by clicking LB on Pan on a view button area

(b) by clicking on <Control> LB whilst in the view

make selected point the new view centre
pick a point and the place it is to be moved to on the screen
repeated pan
repeated pan delta
autopan for plan locked to plan view
autopan for plan locked to section view

Plan View Pan Menu

make selected point the new view centre
pick a point and the place it is to be moved to on the screen
repeated pan
repeated pan delta
autopan for plan locked to section view
autopan for section locked to section view
autopan for perspective locked to section view

Section View Pan Menu
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(c) selecting the Pan option itself by clicking LB when the Pan option is highlighted on the Pan 
menu

(d) by activating the Pan option’s walk-right menu, Pan Ops.

The pan uses either a dynamics pan or two point mode.

Dynamic Pan
After selecting the pan option, dynamic pan is selected by clicking MB or by typing ’d’.

Then press LB at the point that is to be dragged across the view during the dynamic pan and 
then move the mouse to the new position for the point. Another point can then be selected to 
dynamically pan.

The dynamic pan continues until either RB is clicked, or MB is clicked (or ’d’ typed) to place the 
pan option into two point mode.

After activating the pan walk-right menu, the user is presented with the option pan (which is the 
same operation as the option just discussed), pan delta, and many pans and many pans delta.

Pan
Position of option on menu: Plan View Menu View => Settings => Pan => Pan

Position of option on menu: Section View Menu View => Settings => Pan => Pan

After selecting the pan option, the user is asked to indicate a point in a view which is to become 
the new view-centre. The user then indicates (by clicking LB in the view) which view is to be 
redrawn with this point as the new centre.

To cancel the pan after the pan operation has been selected, click RB.

Next step messages - sent to the screen message area

<View Pan> [Select][][] select new centre of view - RB to cancel
<View Pan> [Select][][] select destination view - RB to cancel

Pan Delta
Position of option on menu: Plan View Menu View => Settings => Pan => Pan delta

Position of option on menu: Section View Menu View => Settings => Pan => Pan delta

After selecting the pan delta option, the user is asked to indicate a point in a view and the point 
on a view where the first point will be moved to. The user then indicates (by clicking LB in the 
view) which view is to be redrawn with the new position of the point on the view.

To cancel the pan delta after the pan delta operation has been selected, click RB.

Next step messages - sent to the screen message area

<View Pan> [Select][][] select 1st position of pan - RB to cancel
<View Pan> [Select][][] select 2nd position of pan - RB to cancel
<View Pan> [Select][][] select destination view - RB to cancel

Many Pans
Position of option on menu: Plan View Menu View => Settings => Pan => Many pans

Position of option on menu: Section View Menu View => Settings => Pan => Many pans

The many pans option is simply one pan operation followed by another.

After one pan operation has been performed, a new pan operation is begun.

The sequence is terminated by clicking RB.

Many Pans Delta
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Position of option on menu: Plan View Menu View => Settings => Pan => Many pans delta

Position of option on menu: Section View Menu View => Settings => Pan => Many pans delta

The many pans delta option is simply one pan delta operation followed by another.

After one pan delta operation has been performed, a new pan delta operation is begun.

The sequence is terminated by clicking RB.
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Autopan Plan View Locked to a Plan View
autopan_plan_view_from_plan_view

Position of option on menu: Plan View Menu View => Settings => Pan => Autopan plan view

The Autopan plan view option locks a target plan view to a source plan view. As the cursor is 
moved in the source plan view, the target plan view is automatically panned to keep the cursor 
in the middle of it. The target plan view keeps its scale.

Selecting Autopan plan view fires up the Autopan Plan View from Plan View panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Lock to view tick box tick

Source plan view view box current view available plan views
plan view to lock the target plan view to. 

Lock to view tick box tick

Target plan view view box available plan views
plan view to lock the source plan view. As the cursor moves in the source plan view, the target view is 
automatically panned so that the cursor is in the centre of the target plan view.

Autopan Section View Locked to a Plan View
autopan_section_view_from_plan_view

Position of option on menu: Plan View Menu View =>Settings =>Pan =>Autopan section view

The Autopan section view option locks a target section view to a source plan view. As the cursor 
is moved in the source plan view, the cursor position is dropped onto the profiled string in the 
target section view and the target section view is automatically panned to keep the dropped 
cursor in the middle of it. The target section view keeps its scale.

Selecting Autopan section view fires up the Autopan Section View from Plan View panel.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Lock to view tick box tick

Source plan view view box current view available plan views
plan view to lock the section view to. 

Lock to view tick box tick

Target section view view box available section views
section view to lock the source plan view. As the cursor is moved in the source plan view, the 
cursor position is dropped onto the profiled string in the target section view and the target 
section view is automatically panned to keep the dropped cursor in the middle of it. The 
target section view keeps its scale.
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Autopan Plan View Locked to a Section View
autopan_plan_view_from_section_view

Position of option on menu: Section View Menu View => Settings => Pan => Autopan plan view

The Autopan plan view option locks a target plan view to a source section view. As the cursor is 
moved in the source section view, the target plan view is automatically panned to keep the 
cursor in the middle of it. The target plan view keeps its scale.

Selecting Autopan plan view fires up the Autopan Plan View from Section View panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Lock to view tick box tick

Source section view view box current view available plan views
section view to lock the target plan view to. 

Lock to view tick box tick

Target plan view view box available plan views
plan view to lock the source section view. As the cursor moves in the source section view, the target 
view is automatically panned so that the cursor is in the centre of the target plan view.

Autopan Section View Locked to a Section View
autopan_section_view_from_section_view

Position of option on menu: Section View Menu View =>Settings =>Pan =>Autopan section view

The Autopan section view option locks a target section view to a source plan view. As the cursor 
is moved in the source section view, the cursor position is dropped onto the profiled string in the 
target section view and the target section view is automatically panned to keep the dropped 
cursor in the middle of it. The target section view keeps its scale.

Selecting Autopan section view fires up the Autopan Section View from Section View panel.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Lock to view tick box tick

Source section view view box current view available section views
section view to lock the target section view to. 

Lock to view tick box tick

Target section view view box available section views
section view to lock the source section view. As the cursor is moved in the source section view, the 
cursor position is dropped onto the profiled string in the target section view and the target 
section view is automatically panned to keep the dropped cursor in the middle of it. The 
target section view keeps its scale.

Autopan Perspective View Locked to a Section View
autopan_perspective_view_from_section_view

Position on menu: Section View Menu View => Settings => Pan => Autopan perspective view

The Autopan perspective view option locks a target perspective view to a source section view. As 
the cursor is moved in the source section view, the eye and target for the perspective view is 
automatically changed. Only the eye and target positions are modified for the target perspective 
view.

Selecting Autopan perspective view fires up the Autopan Perspective View from Section View 
panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Lock to view tick box tick

Source section view view box current view available section views
section view to lock the target perspective view to. 

Lock to view tick box tick

Target perspective view view box available perspective views
perspective view to lock to the source section view. As the cursor moves in the source section view, the 
eye and target position for the target perspective view is calculated from the (x,y,z) of the profiled string 
in the section view, and the eye and target information in the panel.
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Plan Utilities
plan_view_utilities_menu

Position of menu: Plan View Menu     View => Settings => Utilities

The utilities menu contains miscellaneous options involving the plan view. The utilities walk-
right menu is

For the option New view, go to the section “New View” 
Dump “Dump” 
Plot “Plan Plot” 
Plot frames “Plot Frames” 
View to raster “Create Raster from Plan View” 
Info “View Info” 

New View
plan_view

Position of option on menu: Plan View Menu     View => Settings => Utilities => New view

The new view option displays the current view setting and permits the user to specify new x and 
y minimum and maximum values as the viewing parameters.

Selecting new view fires up the plan view panel.

Because the aspect ratio of the view may be different from the aspect ratio defined by the user 
supplied x and y minimums and maximums, slightly more data than the specified range may 
need to be drawn in the view. However, the view will always include the user given range.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

View input/output current view available views
view to set min and max for. 

x min/max input/output current x min/max
minimum/maximum x co-ordinate for the view

y min/max input/output current y min/max
minimum/maximum y co-ordinate for the view

View button
define the view parameters according to the information in the panel. If the box given by the x and y 
values in the panel is not the same shape as the view itself (that is, has the same aspect ratio), the x and 
y values will be modified so that the x and y values match the view shape. The final x and y values are 
displayed in the panel.
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Dump
view_dump

Position of option on menu: Plan View Menu     View => Settings => Utilities => Dump

This option is used to write the image of the view out to disk in a user selected format.

After selecting the dump option, a view dump panel appears.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

View input view option available views
picked from

view to dump out in the specified format.

Include title tick-cross
if tick, the view title area is included in the dump.

Format input gif gif, xwd, colour postscript
the format to dump the view out in.

File input *.gif
the file to dump the view images out to

Dump button
dump in the given format the image of the view given in the view field to the file given in the file field.
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Plan Plot
plan_plot

Position of option on menu: Plan View Menu     View => Settings => Utilities => Plot

The plot option writes out all the information displayed in the plan view to either a plot file (in a 
user selected format) or to a 12d Model model. The user selects a scale for the plot and the sheet 
width and height are calculated by 12d Model.

After selecting the plot option, the plan plot panel is displayed.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

View view box current view available views
view to plot. 

Plotter type input hp hp, dxf, postscript etc.
format for the plot information.

Plot file input depends on plotter type
stem of the name of the file to write the plot of the view to. The name ending is added automatically and 
depends on the plotter type.

Clean model beforehand choice box do not clean
prompt for clean
always clean

only applicable if plotting to a model.

if always clean, the model is cleaned before the plot is created.
If prompt for clean, the user is prompted that the model will be cleaned before the plot is created.
If do not clean, the model is not cleaned before the plot is created.

Scale 1: input
if a value is entered by the user and an <enter> given, the sheet width and height required by the plot 
are calculated and displayed in the sheet width and sheet height fields.
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Sheet width (mm) output
if a value is entered by the user and an <enter> given, the scale and height required by the plot are 
calculated and displayed in the scale and sheet height fields. The units for sheet width are 
millimetres.

Sheet height (mm) output
if a value is entered by the user and an <enter> given, the scale and width required by the plot are 
calculated and displayed in the scale and sheet width fields. The units for sheet height are millimetres

Title and border tick-cross
if tick, a border and two lines of title are placed on the bottom of the plot.

Title line 1/2 input
first/second line of title information.

Title height (mm) input 10
height (in millimetres) to draw the two lines of title information.

Title colour input cyan available colours
colour used for the border and the title information.

Rectangle button
create a rectangle (parallel to the x,y axis) that the plot is restricted to.

Rotated Rectangle button
create a rotated rectangle that the plot is restricted to.

Plot button
write out the plot of the information displayed in the view to the file given in the plot file field. The 
format of the file is given by the plotter type.
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Plot Frames
Position of option on menu: Plan View Menu     View => Settings => Utilities => Plot frames

To create plan plots of an arbitrary size, rotation and scale, 12d Model uses plot frames.

Basically a plot frame consists of a sheet size (in mm), margins within the sheet and a scale for 
the plot. This will define a plotting area in world co-ordinates (the plot frame).

The plot frame can be arbitrarily positioned and rotated on a plan view.

This option is documented in the section “Plotting Old Plot Frames”  of the chapter “Plots” 
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Create Raster from Plan View
create_raster_from_plan_view

Position of option on menu: Plan View Menu     View => Settings => Utilities => View to raster

Position of option on menu: Strings =>Raster => Plan to raster

This option creates a 12d raster of a user specified pixel size, for the image on a plan view. This is 
useful for creating a 12d raster from an ECW file to use in draping on a tin in visualisations.

On selecting the View to Raster option, the Create Raster from Plan View panel is displayed.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

Source Details

View view box current view available views
view to create raster from. 

Null colour colour box available colours

colour to set to no pixel in the raster

World Location

Anticlockwise rotation angle box

the world rotation of the selected rectangle.
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X/Y co-ordinate real box

the world x/y co-ordinate of the corner of the bottom left corner of the rectangle.

Width/height real box

the width/height in world units of the rectangle.

New Raster Details

Model for raster model box available models

name of the model for the raster element.

Raster name text box

the name for the raster.

Raster pixel size input

the size (in world units) for each pixel in the created raster.

Width/Height in pixels output only

the width/height in pixels of the created raster.

Show border tick-cross tick

if tick then the border of the created raster element is displayed.

Colour for border input default colour available colours

the colour of the border for the created raster.

Rectangle button

create a rectangle (parallel to the x,y axis) that the created raster is restricted to.

Rotated Rectangle button
create a rotated rectangle that the created raster is restricted to.

Create button
create a 12d raster from the image on the plan view.
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View Info
plan_viewing_information 

Position of option on menu: Plan View Menu     View => Settings => Utilities => Info

This option displays information about the world and pixel size of a plan view.

On selecting the Info option, the Plan Viewing Information panel is displayed.



12d Model Reference Manual

Page 262 March 2007Perspective View Menu

Perspective View Menu
perspective_view_menu
Position of menu: Perspective View Menu     View

The perspective view menu is

For the option Models, go to the section “Model Ops” .
Settings “Perspective View Settings” .
Redraw “Redraw” .
Fit “Fit” .
Previous “Previous” .
Eye/Target “Eye/Target” .
Joy “Joy” .
Utilities “Perspective Utilities” .
Delete “Delete” .

Perspective View Settings
perspective_view_settings_menu

Position of menu: Perspective View Menu     View =>Settings

If the settings option is picked rather than moving onto the walking right, then the toggle menu 
from the toggle walk-right menu is displayed on the screen. The toggle menu will be described 
in the next section.

The settings walk-right menu for the perspective view is

For the option Toggle, go to the section “Perspective Toggle” .
Culling “Culling” .
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Faces “Faces” .
Hide “Hide” .
Planes “Clipping Planes” .
Exaggeration “Exaggeration” .
Tins “Tins” .
Shade “Shade” .
Work Plane “Work Plane” .
Grid “Grid” .
Colour “Colour” .
Drawing filter “Drawing Filter” 

Perspective Toggle
perspective_view_toggle_menu

Position of menu: Perspective View Menu     View =>Settings =>Toggle

The toggle walk right brings up the toggle perspective view menu.

Selecting any options from this menu will toggle the option on/off.
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Culling
culling_perspective_view
Position of option on menu: Perspective View Menu     View =>Settings =>Culling

The culling option is used to suppress the drawing of strings whose on-screen extent is less than 
a user defined pixel size.

Selecting culling raises the culling perspective view panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set culling parameters for. 

Use culling tick-cross

if tick, a string is not drawn on the perspective view whenever the string’s extent box when drawn on 
the view would be smaller the culling size given in the culling size field.

Culling size input 10

pixel size used for culling

Cull button

record the culling size given in the culling field. If the use culling field and redraw the view.

Faces
face_flags_for_view

Position of option on menu: Perspective View Menu     View =>Settings =>Faces

The faces option allows the user to specify how faces are displayed in the perspective view and 
on any perspective view plots.

Selecting faces fires up the face flags for view panel.
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The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to face flags for. 

Draw fill tick-cross tick
if tick, all faces in the view are drawn in their fill colour.

Draw edges tick-cross

if tick, all face edges in the view are drawn.

Draw hatch tick-cross

if tick, all faces in the view are drawn in their hatch pattern.

Set button
set the draw fill/edges/hatch fields to the value in the panel fields. The plan view is then redrawn.

Hide
hide_view

Position of option on menu: Perspective View Menu     View =>Settings =>Hide

When looking across a landscape, part of the terrain is often hidden by other parts of the terrain. 
For example hills in the foreground will hide hills behind them.

In 12d Model, a landscape is represented by a triangulated surface (a tin) and a tin can be used by 
a hidden line algorithm to determining what is visible is a scene.

The hide option in 12d Model uses a tin to define a surface and processes any strings on the 
perspective against the tin to determine what is visible or hidden. 

Only strings that lie on the tin can be sensibly processed. For example, contours, meshes, draped 
strings and any of the data that was used to create the tin.

When viewing a terrain from an eye point, the ridge lines are the edges of transition between 
visible and invisible areas. The hide option displays the ridge lines to delineate the hidden 
regions.

Once the hide option is set on, a hide will be done on the view whenever the view parameters are 
changed. If a model is added to the view when hide is set on, the strings in the model are 
processed and only the visible sections displayed in the view.

Note - strings can still be selected in a hidden view.

Selecting hide raises the hide view panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set hide parameters for. 

Tin input available tins
the name of the triangulated surface (tin) to be used for determining what is visible or not.

Hide view tick-cross
if tick, then the view is processed when the set button is selected.

Ridges colour input available colours
the colour for the ridge lines.

Set button
record the answers for the hide view, tin and ridges colour fields and then process the perspective view 
using the new parameters. The view type will be changed to hidden.

WARNING - a hide can be very slow for large tins and/or large data sets.
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Clipping Planes
clipping_planes_for_view

Position of option on menu: Perspective View Menu     View =>Settings =>Planes

The perspective viewing direction is defined by specifying an eye and target point.

The three dimensional view is then projected onto a plane at right angles to the eye-target line, 
and at a user defined distance from the eye-point. This plane is called the focal plane and the 
distance from the eye-point to the focal plane is the focal distance. 

The projection of all the data onto the focal plane is what is seen on the screen in a perspective 
view. Moving the focal plane has the same effect as varying the telephoto lens on a camera - it 
gives the impression of zooming into and out of the view.

It is not always desirable to include all the data in the perspective view. For example, data 
behind the viewer is not normally required to be seen. The user can specify the position of two 
planes (called the front and back clipping planes) parallel to the focal plane. Only data lying 
between the clipping planes will be seen. Thus the view is “clipped” using the front and back 
clipping planes.

The distance to the clipping planes is measured from the eye point along the line joining the eye 
and target points (the eye-target line).

Selecting planes fires up the clipping planes for view panel. This panel allows the user to set the 
focal distance and the front and back clipping plane distances.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set clipping plane for. 

Front dist input/output
distance from the eye point to the front clipping plane. If this field is blank, no front clipping plane is 
used.

Back dist input/output
distance from the eye point to the back clipping plane. If this field is blank, no back clipping plane is 
use.

Focal dist input/output
distance from the eye point to the focal plane. This distance must be non-zero.

Set button
set the distances to the front and back clipping planes and the focal plane. If the front or back clipping 
distance is blank, that plane is not set. After the set button is chosen, the view is redrawn using the new 
parameters,
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Exaggeration
perspective_view_exaggeration

Position of option on menu: Perspective View Menu     View =>Settings =>Exaggeration

The exaggeration option allows the user to specify the vertical exaggeration in the perspective 
view. The heights (z values) are multiplied by the vertical exaggeration value before drawing on 
the perspective view.

Selecting exaggeration fires up the perspective view exaggeration panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set exaggeration for. 

Vertical exaggeration input 10 1,5,10
value to multiply the heights (z values) by before drawing in the perspective view.

Set button
set the vertical exaggeration to the value in the vertical exaggeration field.

Tins
perspective_view_tin_settings_menu

Position of menu: Perspective View Menu     View =>Settings =>Tins

The options on the tins walk-right menu control the display of tins on the view.The tins walk-
right menu is

Contours
Position of option on menu: Perspective View Menu     View =>Settings =>Tins =>Contours

The contours option defines contour and bold increments and colours, and also whether these 
contours are displayed for the triangles from any tins on the view. The panel is the same as for 
the plan view option. If shade is set on, the triangles will be drawn in back to front order. 

Edges
Position of menu: Perspective View Menu     View =>Settings =>Tins =>Edges
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The edges option allows the user to specify whether the edges of triangles from any tins on the 
view are displayed. The panel is the same as for the plan view option. If shade is set on, the 
triangles will be drawn in back to front order. 

Flow Arrows
Position of option on menu: Perspective View Menu     View =>Settings =>Tins =>Flow arrows

The flow arrows option defines the colour and length of flow arrows, and also whether the flow 
arrows are displayed for the triangles from any tins on the view. The panel is the same as for the 
plan view option. If shade is set on, the triangles will be drawn in back to front order. 

Mesh
Position of option on menu: Perspective View Menu     View =>Settings =>Tins =>Mesh

The mesh option defines a rectangular mesh, and also whether the mesh is displayed for the 
triangles from any tins on the view. The panel is the same as for the plan view option. If shade is 
set on, the triangles will be drawn in back to front order. 

Shade
shade_view

Position of option on menu: Perspective View Menu     View =>Settings =>Tins =>Shade

Position of option on menu: Perspective View Menu     View =>Settings =>Shade

In 12d Model, a landscape is represented by a triangulated surface - a tin. Each triangle in the tin 
is a part of a plane and has its own colour.

In a perspective view, each triangle can be drawn with a colour that is modified depending on 
the angle that the triangle makes with the sun (a point light source at infinity). This is called a flat 
shade.

If the triangles are drawn in a back to front order, then when the shaded landscape is drawn, any 
triangles in the foreground obscure triangles in the background and it looks like a hidden view.

If shade is set for a view, all the triangles in all the tins on the view are drawn as shaded triangles 
and the triangles are drawn in a back to front order.

Once the shade is set on, a shade will be done on the view whenever the view parameters are 
changed. A plot of the shaded view can be made using the dump option on the view.

Selecting shade fires up the shade view panel:

The fields and buttons used in this panel have the functions.
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Field Description Type Defaults Pop-Up

View input/output current view available views
view to set shade parameters for.

Shade tins tick-cross
if tick, draw all the tins on the perspective view in shade mode.

Angle input 45
angle of the sun (measured from the horizon).

Set button
record and redraw the view using the current parameters.

Shade
Position of option on menu: Perspective View Menu     View =>Settings =>Shade

This is exactly the same option as the shade described in the previous section “Shade” .
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Eye/Target
perspective_view

Position of option on menu: Perspective View Menu     View =>Eye/Target

The Eye/Target option displays the current eye and target co-ordinates and also allows the user 
to specify new eye and target points. The points can be chosen from any plan view using the 
cursor or by typed-input.

The view is projected onto a focal plane using a perspective transformation, and clipped using 
front and back clipping planes. The focal distance and the front and back clipping plane 
distances are set and modified in the planes option.

Selecting new view fires up the perspective view panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set perspective parameters for.

Eye X Y Z input/output current eye position xyz ops menu

co-ordinates of the eye viewing point. New values can be typed, or a point selected using the xyz ops 
pop-up menu.

Target X Y Z input/output current target position xyz ops menu

co-ordinates of the target viewing point. New values can be typed, or a point selected using the xyz ops 
pop-up menu.

Move dist input/output
distance to move the eye point along the eye-target line in the direction of the target point. The target 
point is also moved the same distance along the eye-target line so that the eye-target distance is kept 
constant.

View button
define the perspective parameters according to the information in the panel. If the move distance is non-
zero, then the eye and target points are both moved along the eye-target line by the distance given in the 
Move field. In this case, the new eye and target positions will be written to the eye and target fields.

Eye & Target button
allows the user to define the (x, y) position of the eye and target points using the cursor and views.

After selection the button, the user is asked to select the eye position from a view by clicking LB in a 
view. A level input box is then displayed on the screen for the user to enter the level (z value) for the eye 
point. The level is recorded and the level box removed after a <enter> is entered in the level input box.

The user is then asked to select the target point from any view by clicking LB at the position of the 
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target point. A level input box is then displayed for the user to enter the level (z value) for the target 
point.

After the target point is defined, the view is redrawn using the new eye and target positions.

How to Use the Panel and Panel Messages

(a) The eye and target points are set by using typed-input, the xyz ops pop-up menu in either 
the eye XYZ or target XYZ fields, or the eye & target button.

When the view button is selected, the perspective viewing parameters are calculated according to 
the information in the panel. If a non-zero move distance is given, the eye and target points are 
both moved along the eye-target line through the move distance The new values for the eye and 
target points are written into the panel. If no errors are detected in calculating the new viewing 
parameter, the view is redrawn using the new parameters.
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Joy
joy_view

Position of option on menu: Perspective View Menu     View =>Joy

The hardest thing in a perspective view is finding a good viewing position. The joy option makes 
it easy to construct a new perspective viewing position relative to the existing position.

The panel can be used to move the eye or target point by rotating them through a given angle to 
the left, right, up or down, or to move one towards or away from the other. It is also possible to 
move the eye and target points keeping the distance between them the same.

Selecting joy fires up the joy view panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set joy parameters for.

Move input eye eye, target, eye & target
move the eye point, the target point or both.

Mode input step step, continuous
in step mode, the view is modified each time an appropriate button is picked. In continuous mode, after 
the view is redrawn, the picked joy option is continually re-applied until either a new joy button is 
picked, button LB is clicked anywhere else in the joy panel.

Angular step input 45
angle in degrees that is used with the joy buttons up, down, left and right when moving just the eye or 
target point.

Distance input 100
distance used to move the eye or target point.

Joy buttons up,down,left,right,in,out
The joy buttons are used to modify the perspective parameters and then redraw the view with 
the new parameters.
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The effect of each joy button depends on whether the move field is set to eye, target or eye & 
target.

move field set to eye

up/down button

rotate the eye-target line about the target point up/down by the angle given in the angle step 
field. That is, the eye point is moved upwards/downwards, the target point kept fixed.

left/right button

rotate the eye-target line about the target point to the left/right by the angle given in the angle 
step field. The target point kept fixed.

in/out button

move the eye point towards/away the target point along the eye-target line by the distance 
given in the distance field. The target point kept fixed.

move field set to target

similar to the movements when the move field is set to eye except the eye point is kept fixed and 
the target point is moved.

move field set to eye & target

up/down/left/right button

the eye and target points are both moved up/down/left/right by the distance given in the 
distance field. That is, the entire eye-target line is moved up/down/left/right and neither the eye 
or target point is kept fixed.

in/out button

move the eye and target points along the eye-target line by the distance given in the distance 
field. The direction is towards/away the target point.

How to Use the Panel

(a) The move, mode, angular step and distance field are given the desired values and then one of 
the joy buttons (up, down, left, right, in or out) is selected. The perspective view is then 
redrawn 

(b) If the mode is set to continuous, once drawing is completed, the selected joy option will be 
re-applied. This sequence is repeated until either a new joy button is picked, button LB is 
clicked anywhere else in the joy panel or a c key is typed.
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Orbit
joy

Position of option on menu: Perspective View Menu     View =>Orbit

The orbit option quickly rotates the data around in the perspective view.

Selecting Orbit fires up the Orbit panel.

To use Orbit:

Orbit radio button on:    Flip orbit direction radio button off:

when the left button is clicked in the perspective view, the orbit circle appears and
holding LB down and moving up in the orbit circle tilts the object up
holding LB down and moving down in the orbit circle tilts the object down
holding LB down and moving left rotates the object to the left
holding LB down and moving right rotates the object to the right

Orbit radio button on:    Flip orbit direction radio button on:the movement is reversed
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Pan radio button on:

holding LB down and moving up in the view raises the object
holding LB down and moving down in the view lowers the object
holding LB down and moving left in the view pans the object to the left
holding LB down and moving right in the view pans the object to the right 

Zoom radio button on:

holding LB down and moving up in the view zooms into the object
holding LB down and moving down in the view zooms out from the object

Zoom to window radio button on:

when a zoom box is drawn on the view, the perspective is modified so that the contents of the zoom box 
fill the entire view.

Shrink to window radio button on:

when a zoom box is drawn on the view, the perspective is modified so that the contents of the window 
are shrunk to fit into the zoom box.

Swivel camera radio button on:

holding LB down moves the target point.
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Perspective Utilities
perspective_view_utilities_menu

Position of option on menu: Perspective View Menu     View => Utilities

The utilities menu contains miscellaneous options involving the perspective view.

The utilities walk-right menu is

For the option String drive, go to the section “String Drive” .
String walk “String Walk” .
String movie “String Movie” .
Tin shade “Tin Shade” .
Dump “Dump” .
Plot “Perspective Plot” .

String Drive
perspective_view_drive_menu

Position of menu: Perspective View Menu     View => Utilities =>String drive

The string drive option makes it easy to construct the perspective view one gets when moving 
along a string (for example, driving along a road centre line).

The two options on the string drive walk-right menu are

 and they specify the positioning of eye and target points by:

along string - the eye and target points are automatically moved along the selected string

fixed target - the eye point automatically moves along the selected string but the target point is a 
selected fixed point.

Note - the string drive option can be aborted by pressing the <esc> key or clicking RB.

String Drive - Along String

string_drive_for_view

Position of option on menu: Perspective View Menu     View => Utilities =>String drive =>Along 
string

Selecting along string fires up the string drive for view panel.
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For string drive along a string, a selected string is used to provide the (x, y, z) positions for the 
eye and target points. 

The z-values can be adjusted by typing in a non-zero value for the eye and target heights in the 
string drive panel. These heights are relative to the z-values of the points on the string and are 
added to the z-values.

Like the new view option, the view is projected onto a focal plane and “clipped” using front and 
back clipping planes.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set drive parameters for.

Eye height input 1.3
height of the eye viewing point above the picked string

Eye offset input 0
offset of the eye viewing point from the picked string

Target height input 0.3
height of the target viewing point above the picked string

Target offset input 0
offset of the target viewing point from the picked string

Target distance input 40
distance (in string chainage) from the eye point to the target point.

Speed (kph) input 100
speed in kilometres per hour (that is, one thousand base units per hour) that the eye-target points move 
along the string.

String to drive along string select

a string to drive along is selected from any view. The string must have z-values.
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Chainage input/output  0
the chainage that the eye point is at on the string. The chainage is updated as the eye and target points 
are automatically moved along the string. The drive can be set to start at a specific start chainage by 
simply entering the start chainage into the chainage field and then selecting the drive button.

Repeat tick box
if tick, the drive starts again at the beginning of the string.

Drive button
When the drive button is selected, the eye and target points are placed above the string as specified in 
the panel fields, and the view redrawn. The eye and target points are then moved along the string at the 
given speed until either reaches the end of the string. The chainage of the eye point is continually 
updated.

Notes

▲ the target distance and speed can be positive or negative.

▲ the eye and target points are shown on any view displaying the string being driven along. 
The eye point is drawn as a red cross, the target point, a green cross.

▲ if the front distance for the clipping plane of the perspective view is set to zero by the user, 
it is automatically reset to 2 so that the red cross drawn at the eye point is not visible in the 
perspective view.
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String Drive - Fixed Target

string_drive_fixed_target_for_view
Position of option on menu: Perspective View Menu     View => Utilities =>String drive =>Fixed 
target

Selecting fixed target fires up the string drive fixed target for view panel.

For string drive fixed target, a selected string is used to provide the (x, y, z) positions for the eye 
point, and the target is a selected fixed point. The z-value for the eye is adjusted by adding to it 
the eye height in the eye height field in the string drive fixed target panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set drive parameters for.

Target xyz box
a fixed target point is selected from any view. The point’s co-ordinates are displayed in the X, Y, Z 
coordinates panel fields.

Eye height input 1.3
height of the eye viewing point above the picked string

Eye offset input 0
offset of the eye viewing point from the picked string

Speed (kph) input 100
speed in kilometres per hour (that is, in one thousand of the base units per hour that the eye point 
moves along the string.

String to drive along string select
a string to drive along is selected from any view. The string must have z-values.

Chainage input/output  0
the chainage that the eye point is at on the string. The chainage is updated as the eye point 
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automatically moves along the string. The drive can be set to start at a specific start chainage by simply 
entering the start chainage into the chainage field and then selecting the drive button.

Target button
a fixed target point is selected from any view. The point’s co-ordinates are displayed in the target panel 
field.

Repeat tick box
if tick, the drive starts again at the beginning of the string.

Drive button
When the drive button is selected, the eye point is placed above the string at the chainage given in the 
chainage field, and the view redrawn. The eye point is then moved along the string at the given speed 
until it reaches the end of the string. The chainage of the eye point is continually updated.

Notes

▲ the speed can be positive or negative.

▲ the eye point is shown on any view displaying the string being driven along. The eye 
point is drawn as a red cross, the target point, a green cross.

▲ if the front distance for the clipping plane of the perspective view is set to zero by the user, 
it is automatically reset to 2 so that the red cross drawn at the eye point is not visible in the 
perspective view

String Walk
perspective_view_walk_menu

Position of menu: Perspective View Menu     View => Utilities =>String walk

The string walk option makes it easy to construct the perspective view one gets when walking 
along a string (for example, walking along a road centre line).

The two options on the string walk walk-right menu are

 and they specify the positioning of eye and target points by:

along string - the eye and target points are automatically moved along the selected string

fixed target - the eye point automatically moves along the selected string but the target point is a 
selected fixed point.

String Walk - Along String
string_walk_for_view

Position of option on menu: Perspective View Menu     View => Utilities =>String walk =>Along 
string

Selecting along string fires up the string walk for view panel
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For string walk along a string, a selected string is used to provide the (x, y, z) positions for the 
eye and target points. 

The z-values can be adjusted by typing in a non-zero value for the eye and target heights in the 
string walk panel. These heights are relative to the z-values of the points on the string and are 
added to the z-values.

Like the new view option, the view is projected onto a focal plane and “clipped” using front and 
back clipping planes.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set walk parameters for.

Eye height input 1.3
height of the eye viewing point above the picked string

Eye offset input 0
offset of the eye viewing point from the picked string

Target height input 0.3

height of the target viewing point above the picked string

Target offset input 0
offset of the target viewing point from the picked string

Target distance input 40
distance (in string chainage) from the eye point to the target point.

String to walk along string select
a string to walk along is selected from any view. The string must have z-values.

Walk dist input 10
distance to move the eye point along string from the previous eye point chainage. The target point is 
also moved the same distance along the eye-target line so that the eye-target distance is kept constant.
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Chainage input/output  0
the chainage that the eye point is at on the string. The chainage is updated whenever the walk button is 
activated. The eye point can be set to a specific chainage by simply entering the chainage into the 
chainage field and selecting the walk button.

Walk button
the perspective parameters are defined according to the information in the panel. The first time the walk 
button is selected, the eye point is placed above the string at the chainage given in the chainage field. 
For subsequent selections of the walk button, the eye and target points are moved along the eye-target 
line by the chainage distance given in the walk dist field.

The view is redrawn with the new view parameters and the new eye-chainage displayed in the panel 
message area and the chainage field.

Notes

▲ the target and move distances can be positive or negative.

▲ the eye and target points are shown on any view displaying the string being walked along. 
The eye point is drawn as a red cross, the target point, a green cross.

▲ if the front distance for the clipping plane of the perspective view is set to zero by the user, 
it is automatically reset to 2 so that the red cross drawn at the eye point is not visible in the 
perspective view.

String Walk - Fixed Target

string_walk_fixed_target_for_view

Position of option on menu: Perspective View Menu     View => Utilities =>String walk =>Fixed 
target

Selecting fixed target fires up the string walk fixed target for view panel.

For string walk fixed target, a selected string is used to provide the (x, y, z) positions for the eye 
point, and the target is a selected fixed point. The z-value for the eye is adjusted by adding to it 
the eye height in the eye height field in the string walk fixed target panel.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

View input/output current view available views
view to set walk parameters for.

Target xyz box
a fixed target point is selected from any view. The point’s co-ordinates are displayed in the X, Y, Z 
coordinates panel fields.

Eye height input 1.3
height of the eye viewing point above the picked string

Eye offset input 0
offset of the eye viewing point from the picked string

Walk dist input 10
distance to move the eye point along string from the previous eye point chainage.

String to walk along string select
a string to walk along is selected from any view. The string must have z-values.

Chainage input/output  0
the chainage that the eye point is at on the string. The chainage is updated as the eye point 
automatically moves along the string. The walk can be set to start at a specific start chainage by simply 
entering the start chainage into the chainage field and then selecting the walk button.

Walk button
the perspective parameters are defined according to the information in the panel. The first time the walk 
button is selected, the eye point is placed above the string at the chainage given in the chainage field. 
For subsequent selections of the walk button, the eye point is moved along the string by the chainage 
distance given in the walk dist field.

The view is redrawn with the new view parameters and the new eye-chainage displayed in the panel 
message area and the chainage field.

Notes

▲ the walk distance can be positive or negative.

▲ the eye point is shown on any view displaying the string being walked along. The eye 
point is drawn as a red cross, the target point, a green cross.

▲ if the front distance for the clipping plane of the perspective view is set to zero by the user, 
it is automatically reset to 2 so that the red cross drawn at the eye point is not visible in the 
perspective view
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String Movie

perspective_view_movie_menu

Position of menu: Perspective View Menu     View => Utilities =>String movie

The string movie option makes it easy to construct and save to disk the sequence of perspective 
views one gets when walking along a string (for example, walking along a road centre line).

The screen images are automatically written out to disk in gif format so that they can be replayed 
at a later time.

This is especially useful when it takes a while to construct each view, for example, when hidden 
line is turned on.

Under NT/95, the screen images are written to an avi file. 

Under Unix, the screen images are written to a gif file and there can be up to 99,999 of them in 
the one movie.

The two options on the string movie walk-right menu are

 and they specify the positioning of eye and target points by:

along string - the eye and target points are automatically moved along the selected string

fixed target - the eye point automatically moves along the selected string but the target point is a 
fixed selected point.

Note - the string movie option can be aborted by pressing the <esc> key or clicking RB.

String Movie - Along String
string_movie_for_view

Position of option on menu: Perspective View Menu     View => Utilities =>String movie =>Along 
string

Selecting along string fires up the string movie for view panel



12d Model Reference Manual

Page 286 March 2007Perspective View Menu

For string movie along a string, a selected string is used to provide the (x, y, z) positions for the 
eye and target points. 

The z-values can be adjusted by typing in a non-zero value for the eye and target heights in the 
string movie panel. These heights are relative to the z-values of the points on the string and are 
added to the z-values.

Like the new view option, the view is projected onto a focal plane and “clipped” using front and 
back clipping planes

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set movie parameters for.

Eye height input 1.3
height of the eye viewing point above the picked string

Eye offset input 0
offset of the eye viewing point from the picked string

Target height input 0.3
height of the target viewing point above the picked string

Target offset input 0
offset of the target viewing point from the picked string

Target distance input 40
distance (in string chainage) from the eye point to the target point.

Movie string string select
a string to drive along is selected from any view. The string must have z-values.
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Start chainage input/output  0
the chainage that the eye point starts on the string for the movie.

End chainage input/output  0
the chainage to stop the movie at. 

Speed (kph) input 10
speed in kilometres per hour (that is, one thousand base units per hour) that the eye-target points move 
along the string.

Frames/sec) input 5
number of frames per second to produce for the movie.

Movie file stem input 4d-
each frame of the drive in the view is written to disk in avi format using the movie file stem plus the 
ending .avi as the file name.

Show movie tick box tick
if tick, after all the views along the string are written to disk, a new window, the same size as the 
perspective view, will be created and movie then run.

Turn off screen saver tick box tick
if tick, the screen saver is disabled so it doesn’t come on whilst creating the movie.

Movie button
the perspective parameters are defined according to the information in the panel. When the movie 
button is selected, the eye point is placed above the string at the chainage given in the chainage field. 
The view is drawn with these view parameters. After that view is processed and written to disk, the eye 
and target points are moved along the eye-target line and frames written out to simulate the given 
speed.

Show button
This button is used to display a previously created movie. If selected, the movie created with the stem 
given in the movie file stem field is displayed. If Unix, there is a pause between each frame by the 
number of seconds given in the delay field.

Displaying the Movie

If a movie has just been created and the show movie field is set to tick, or an existing movie name 
is given in the movie file stem field and the show button is selected, then a new window will be 
created and the movie will be displayed frame by frame. Outside of 12d Model, the movie can be 
displayed by simply double clicking on the avi file.

Notes

▲ the target and move distances can be positive or negative.

▲ the eye and target points are shown on any view displaying the string being walked along. 
The eye point is drawn as a red cross, the target point, a green cross.

▲ if the front distance for the clipping plane of the perspective view is set to zero by the user, 
it is automatically reset to 2 so that the red cross drawn at the eye point is not visible in the 
perspective view.

▲ the movie can also be displayed from outside 12d Model by simply double clicking on the 
avi file

movie-file-stem.avi

String Movie - Fixed Target

string_movie_fixed_target_for_view
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Position of option on menu: Perspective View Menu     View => Utilities =>String movie =>Fixed 
target

Selecting fixed target fires up the string movie fixed target for view panel.

For string movie fixed target, a selected string is used to provide the (x, y, z) positions for the eye 
point, and the target is a selected fixed point. The z-value for the eye is adjusted by adding to it 
the eye height in the eye height field in the string movie fixed target panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set movie parameters for.

Eye height input 1.3
height of the eye viewing point above the picked string

Eye offset input 0
offset of the eye viewing point from the picked string

Target xyz box
a fixed target point is selected from any view. The point’s co-ordinates are displayed in the X, Y, Z 
coordinates panel fields.

Movie string string select
a string to drive along is selected from any view. The string must have z-values.

Chainage input/output  0
the chainage that the eye point starts on the string for the movie.



Chapter 5  View Menus

March 2007 Page 289Perspective View Menu

Speed (kph) input 10
speed in kilometres per hour (that is, one thousand base units per hour) that the eye-target points move 
along the string.

Frames/sec) input 5
number of frames per second to produce for the movie.

Movie file stem input 4d-
each frame of the drive in the view is written to disk in avi format using the movie file stem plus the 
ending .avi as the file name.

Show movie tick box tick
if tick, after all the views along the string are written to disk, the movie is then run.

Turn off screen saver tick box tick
if tick, the screen saver is disabled so it doesn’t come on whilst creating the movie.

Movie button
the perspective parameters are defined according to the information in the panel. When the movie 
button is selected, the eye point is placed above the string at the chainage given in the chainage field. 
The view is drawn with these view parameters. After that view is processed and written to disk, the eye 
and target points are moved along the eye-target line by the chainage distance given in the step 
distance field and the new view drawn and processed.

This sequence is repeated until the end of the string is reached or the c key is pressed.

Show button
This button is used to display a previously created movie. If selected, the movie created with the stem 
given in the movie file stem field is displayed. If Unix, there is a pause between each frame by the 
number of seconds given in the delay field.

Tin Shade

tin_shade_view

Position of option on menu: Perspective View Menu     View => Utilities =>Tin shade

In 12d Model, a landscape is represented by a triangulated surface - a tin. Each triangle in the tin 
is a part of a plane and has its own colour.

In a perspective view, each triangle can be drawn with a colour that is modified depending on 
the angle that the triangle makes with the sun (a point light source at infinity). This is called a flat 
shade.

If the triangles are drawn in a back to front order, then when the shaded landscape is drawn, any 
triangles in the foreground obscure triangles in the background and it looks like a hidden view.

If shade is set for a view, all the triangles in all the tins on the view are drawn as shaded triangles 
and the triangles are drawn in a back to front order.

Once the shade is set on, a shade will be done on the view whenever the view parameters are 
changed. A plot of the shaded view can be made using the dump option on the view.

The tin shade option draws the selected tin over the perspective view as a shade. The selected tin 
does not have to be on the view for the shade to function.

When the view is refreshed, the shade is lost (the shade option under settings is used for setting 
a shade permanently on). A plot of the shaded view can be made using the dump option on the 
view. 

Selecting tin shade option fires up the tin shade view panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set shade parameters for.

Tin input available tins
name of the tin to be used for the shade.

Angle input 45
angle of the sun.

Shade button
draw the given tin on the view as a shaded tin.

Dump
Position of option on menu: Perspective View Menu     View => Utilities =>Dump

This option is used to write the view image out to disk in a user selected format. It is the same as 
the dump option for a plan view.

Perspective Plot
perspective_plot

Position of option on menu: Perspective View Menu     View => Utilities =>Perspective plot

The plot option is used to make a plot file of all the information displayed in the perspective 
view.

The user simply gives a sheet width and height and 12d Model calculates the scaling factor 
required to best fit the plot of the view to the sheet.

After selecting the plot option, the perspective plot panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set perspective plot parameters for.

Plotter type input hp hp, dxf, postscript etc.
file format for the plot information.

Plot file input depends on
plotter type

stem of the name of the file to write the plot of the view to. The name ending is added automatically and 
depends on the plotter type.

Clean model beforehand choice box do not clean
prompt for clean
always clean

only applicable if plotting to a model.

if always clean, the model is cleaned before the plot is created.
If prompt for clean, the user is prompted that the model will be cleaned before the plot is created.
If do not clean, the model is not cleaned before the plot is created.

Sheet width/height (mm) input
if a value is entered by the user and an <enter> given, the height/width required by the plot is 
calculated and displayed in the sheet height/width field. The units for sheet width and height are 
millimetres.

If both Sheet width and height are given with no <enter>, then a scaling factor is calculated by 
12d Model to best fit the plot of the view to a rectangle of size given by the sheet width and height.

Title and border tick-cross
if tick, a border and two lines of title are placed on the bottom of the plot

Title line 1/2 input
first/second line of title information
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Title height (mm) input 10
height (in millimetres) to draw the two lines of title information

Title colour input cyan available colours
colour used for the border and the title information

Plot button
write out the plot of the information displayed in the view to the file given in the plot file field. The 
format of the file is given by the plotter type
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Section View Menu
section_view_menu

Position of menu: Section View Menu     View

The section view is used to display string profiles and sections through tins and service items. 
The horizontal units are taken to be the chainage along a particular string called the primary 
string for the view. The z-values (heights) are the vertical units for the section. Hence, the section 
view is a (chainage, z-value) diagram with respect to the primary string on the view. The 
primary string’s model and name is displayed in the view title area of the section view.

Since a tin represents a two dimension continuous surface, sectioning through a tin along a 
string appears as a continuous line string in a section view. For example, the natural surface on a 
road long-section is the section of the road centre-line through the natural surface tin.

When a corridor is set, any strings in models added to the section view (service items) will be 
drawn on the section view wherever they are inside the corridor.

A section view has a vertical exaggeration and whenever a string is profiled on the view, the 
vertical exaggeration is displayed inside square brackets after the view name in the view title 
area. For example [10x] is a vertical exaggeration of 10.

The section views menu is

For the option Models, go to the section “Model Ops” 
Settings “Section View Settings” 
Redraw “Redraw” 
Fit “Fit” 
Previous “Previous” 
Pan “Pan” 
Profile “Profile” 
Regenerate “Regenerate” .
Plotting “Section Plotting” 
Utilities  “Section Utilities” 
Delete “Delete” 
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Section View Settings
section_view_settings_menu

Position of menu: Section View Menu     View => Settings

If the settings option is picked rather than moving onto the walking right, then the toggle menu 
from the toggle walk-right menu is displayed on the screen. The toggle menu will be described 
in the next section.

The settings walk-right menu for the section view is

For the option Toggle go to the section “Section Toggle” 
Corridor “Corridor” 
Draw tolerance “Draw Tolerance” 
Drainage “Drainage HGL” 
Extend “Extend” 
Grade annot  “Grade Annotation” 
Exaggeration “Exaggeration” 
Grid “Grid” 
Colour “Colour” 
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Section Toggle
section_view_toggle_menu
Position of menu: Section View Menu     View => Settings =>Toggle

The toggle walk right brings up the toggle section view menu.

Selecting any options from this menu will toggle the option on/off.

Corridor
section_corridor

Position of option on menu: Section View Menu     View => Settings =>Corridor

The standard section view is designed to profile any selected string and create and display 
sections along the profiled string through any tins in any models added to the section view.

Hence the section view is like a vertical ribbon tracing out the path of the primary string.

The corridor option extends the ribbon to the left and right and projects any strings in any 
models added to the section view back onto the section view.

Consequently, the section view will display any strings or parts of strings that cross the corridor, 
run parallel to the primary string but stay within the corridor as well as displaying the standard 
sections through any tins in any models added to the section view.

The corridor is particularly useful for examining any clashes of strings with the primary string.

For example, services such as telephone cables, water and gas pipes and electricity cables could 
be modelled as 3d or pipe strings and added to the section view.

The section view with non-zero corridor widths would then display any of the services that lie 
within the corridor about the chosen primary string.

Selecting corridor fires up the section corridor panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults

View input/output current view available views
view to set corridor parameters for.

Width left/right input 0.01

width of the corridor to the left/right of the primary string.

Overlap left/right input 0.01

for each straight/arc in the primary string, extend the straight/arc to the left/right by the value of the 
overlap left/right field before drawing the straight/arc. Section through the extended string.

Chord/Arc tolerance input 0.02

value of the chord to arc ratio to be used when approximating circles in alignments, arcs and pipeline 
strings.

Set button

define the corridor parameters according to the information in the panel. The section view for the new 
corridor will then be calculated and displayed.

Defaults button

reset the corridor settings to the default values.

Draw Tolerance
service_draw_tolerance

Position of option on menu: Section View Menu     View => Settings =>Draw tolerance

It is possible for the bits of services displayed on a section view to be very small and possibly too 
small to be easily seen. This is often the case for strings that are perpendicular to the corridor.

To overcome this visualization difficulty, a tolerance can be defined for the section view and 
when the size of any piece of a service is below the tolerance, it will be drawn as a cross.

Selecting draw tolerance fires up the service draw tolerance panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults

View input/output current view available views
view to set service parameters for.

Tolerance (pix) input 4
if the size of any piece of a service is below this tolerance, it will be drawn as a cross.

Set button
set the service draw tolerance.

Drainage HGL
drainage_annotations

Position of option on menu: Section View Menu     View => Settings =>Drainage annotations

If the data exists in the drainage string, the HGL line can be drawn when profiling a drainage 
string.

Selecting Drainage annotations fires up the Drainage Annotations panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults

View input/output current view available views
view to set HGL parameters for.

Show HGL tick box tick
if tick then the HGL line is drawn for any drainage strings that are profiled (and have GHL data)

HGL colour colour box available colours
colour to draw the HGL line

Set button
set the HGL drawing parameters
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Extend
section_profile_extend

Position of option on menu: Section View Menu     View => Settings =>Extend

When displaying the profile of a string on a section view, the user often wishes to see sections 
through the information before the string begins and after the string ends. This is particularly 
useful if it is intended to extend the string in either direction.

The extend option allows the user to extend the profile length.

Selecting extend fires up the section profile extend panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults

View input/output current view available views
view to set extension parameters for.

Extend left input 0
pre-extend the profile by this distance before sectioning through any tins or models on the view.

Extend right input 0
post-extend the profile by this distance before sectioning through any tins or models on the view.

Set button
define the profile length according to the length of the primary string plus the two extend lengths. The 
section view for the new length will then be calculated and displayed.

Geometry Annotation
section_geometry_annotations

Position of option on menu: Section View Menu     View => Settings =>Geom annot

The geom annot option allows the user to specify whether horizontal geometry and/or vertical 
geometry is displayed for any alignment and pipeline strings profiled in the section view and 
hence on any section view plots. 

Selecting geom annot fires up the section geometry annotations panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set alignment geometry parameters for.

Show HG tick-cross tick

if tick, the value of the radii and spiral lengths for any horizontal curves selected as the primary string 
will be shown plus an arrow indicating the chainage extent of the radii.
If no tick, the horizontal geometry will not be displayed in the section view or on any plots of the 
section view.

Show VG tick-cross tick

if tick, the value of the curve length for any vertical curves selected as the primary string will be 
shown, plus an arrow indicating the chainage extent of the curve length. The percentage grades for any 
vertical straights will also be displayed with an arrow indicating the chainage extent of the vertical 
straight.
If no tick, the vertical curve lengths and percentage grades will not be displayed in the section view or 
on any plots of the section view.

Text style input 1

text style to be used for all text in the geometry annotation.

View text ht (pix) input 10
height (in pixels) to draw the geometry annotation values in the section view (the screen width is 
approximately 1000 pixels).

Plot text ht (mm) input 10
height (in mm) to draw the geometry annotation values on any plots of the section view.

Text colour input cyan available colours
colour of the geometry annotation values drawn on the screen and any plots.
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Arrow colour input green available colours
colour of the HG arrows drawn on the screen and any plots.

HG view arrow ht (pix) input 3
height (in pixels) of the arrow head above the arrow line when drawing the HG arrows in the view.

HG plot arrow ht (mm) input 1.5
height (in mm) of the arrow head above the arrow line when drawing the HG arrows on any plots of the 
section view.

VG view arrow ht (pix) input 3
height (in pixels) of the arrow head above the arrow line when drawing the VG arrows in the view.

VG plot arrow ht (mm) input 1.5
height (in mm) of the arrow head above the arrow line when drawing the VG arrows on any plots of the 
section view.

Draw grades as 1 in tick box
if tick, grades are drawn as 1:in values.
if not tick, grades as drawn as percent (%)

Set button
set the section settings values to the values in the above panel fields. The section view is then redrawn 
using these values.
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Grade Annotation
section_grade_annotations

Position of option on menu: Section View Menu     View => Settings =>Grade annot

The grade annot option allows the user to specify whether the grades and plan widths of string 
links are displaced for strings profiled in the section view. 

Selecting grade annot fires up the section grade annotations panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set grade annotation parameters for.

Show grade tick-cross tick
if tick, the value of the grades (in percent grade) and plan widths of string links for any strings selected 
as the primary string will be shown plus an arrow indicating the chainage extent of the grade.
If no tick, the grades and widths will not be displayed in the section view or on any plots of the section 
view.

Text style input 1
text style to be used for all text in the grade annotation.

Text ht (pix) input 8
height (in pixels) to draw the grade annotation values in the section view (the screen width is 
approximately 1000 pixels).

Text colour input cyan available colours
colour of the grade annotation values drawn on the screen and any plots.

Arrow ht (pix) input 3
height (in pixels) of the arrow head above the arrow line when drawing the arrows in the section view.

Arrow colour input cyan available colours
colour of the arrows drawn on the screen.

Set button
set the section settings values to the values in the above panel fields. The section view is then redrawn 
using these values.



12d Model Reference Manual

Page 302 March 2007Section View Menu

Exaggeration
section_view_exaggeration

Position of option on menu: Section View Menu     View =>Settings =>Exaggeration

The exaggeration option allows the user to specify the vertical exaggeration for the section view. 
The heights (z values) are multiplied by the vertical exaggeration value before drawing on the 
section view.

Whenever a string is profiled on the section view, the vertical exaggeration is displayed inside 
square brackets after the view name in the view title area. For example [10x] is a vertical 
exaggeration of 10.

Selecting exaggeration fires up the section view exaggeration panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set exaggeration parameters for.

Vertical exaggeration input 10 1,5,10
value to multiply the heights (z values) by before drawing in the section view.

Set button
set the vertical exaggeration to the value in the vertical exaggeration field.



Chapter 5  View Menus

March 2007 Page 303Section View Menu

Profile
section_view_profile_menu

Position of menu: Section View Menu     View => Profile

The profile option is used to display a long-section view of a selected string. That is, the co-
ordinate system for the section view is defined in terms of the chosen string by

(a) the chainage along the selected string defines the horizontal axis for the section view 
(b) the vertical axis is the z-axis (heights).

Hence a (chainage,height) diagram of the selected string is drawn in the section view. The scale is 
automatically chosen so that all of the selected string fits into the section view.

The string selected to be profiled is called the primary string for the section view.

The model and name of the primary string is displayed in the section view’s title area (after the 
vertical exaggeration).

The primary string is drawn on the section view in the primary string’s colour.

If the primary string is an alignment or pipeline string, the radii and chainage extent of any 
horizontal curves can be displayed in the section view plus any vertical curve lengths and 
percent-grades of vertical straights. For other strings, the grade and widths of each string link 
can be displayed.

For any tins in the models added to the section view, the section along the primary string 
through the tin will be calculated and drawn on the section view in the same colour as the tin 
colour. Any strings (service items) in models added to the section view, the parts of the strings in 
any corridor defined for the primary string will be calculated and drawn on the section view in 
the same colour as the strings.

Each time a new primary string is chosen with the profile option, the sections along the new 
primary string are calculated and displayed for all the tins and strings in the models added to 
the section view.

The profile walk-right menu is

The One string option allows one string to be profiled and then the option terminates.

The Many strings option profiles one string and then allows the user to select another string to be 
profiled without leaving the profile option. The many strings option is very useful when a 
number of strings need to be examined one after another in a section view.

The Model strings option profiles the strings from a given model, one at a time. For example, it is 
used to sequentially examine each cross-section down a road when all the cross-sections are 
stored in one model.

The 2 points option dynamically profiles between two selected points. The profile between the 
first selected point and the cursor position is dynamically recalculated as the cursor is moved 
around the view.

The Perpendicular to CL option dynamically profiles along a cross-section which is perpendicular 
to a selected string. The cross section profile is dynamically recalculated as the cursor is moved 
along the selected string.
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The one substring and many substrings options are used to section along house connections and 
property controls for sewer and drainage strings.

For the option One String, go to the section “One String” 
Many strings “Many Strings” 
Model strings “Model Strings” 
2 points “2 Points” 
Perpendicular to CL “Perpendicular to CL” 
One substring “One Substring” 
Many substrings “Many substrings” 

One String
Position of option on menu: Section View Menu     View =>Profile =>One string

After choosing the one string option, the user selects the string to be profiled. The option then 
terminates.

To cancel the option without selecting any string, click LB to bring up the pick ops menu and 
select cancel.

Many Strings
Position of option on menu: Section View Menu     View =>Profile =>Many strings

The many strings option is designed for profiled a number of strings one after another.

After choosing the many strings option, a string is selected for profiling. After the string has been 
profiled, another string is selected for profiling.

The option will keep profiling selected strings until the option is terminated by clicking LB to get 
the pick ops menu and selecting cancel.

Model Strings
profile_model_on_section

Position of option on menu: Section View Menu     View =>Profile =>Model strings

After selecting the model strings option, the Profile Model on Section panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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View input/output current view available views
view to set profile parameters for.

Model input available models

name of the model containing the strings to be profiled one at a time

Item no. input/output

number of the string in the model being profiled.

Item chainage input/output

chainage of the section string in the model being profiled. Also if a chainage is typed in followed by an 
<Enter> then the model will be searched for a X-section of that chainage and if it exists, it will be 
profiled.

Highlight tick box tick

if tick, the string being profiled in the section view is locked and highlighted on any views where it is 
visible.

Fit view tick box tick

if tick, the string being profiled is fitted to the section view.
if no tick, the same scale is used for the next section being profiled.

Autopan tick box

if tick, then if the profiled string is not visible on any plan views that the model containing the string 
is on, then the plan view is modified so that the profiled string is in the centre of the plan view.

Pick button

after selecting the pick button, a string is selected. The string is automatically profiled and its model 
becomes the model being profiled and item no. is set to the string’s number in the model.

Prev button

the previous string given by the item no. field is profiled and the item no. field decremented by one.

Next button

the next string given by the item no. field is profiled and the item no. field incremented by one.

How to Use the Panel

(a) Either a string is picked after selecting the pick button, or the name of the model containing 
the strings to be profiled is entered into the model field.

(b) The item no. field is initially set to the picked strings item no. or 0, but can be set to the 
number of any string in the model.

(c) When the prev or next button is selected, the string given by the number in the item no. field 
is decremented or incremented and the string given by the new item no. is profiled in the 
section view.

Hence with the model strings option, a number of strings in the one model can be profiled 
(one after another) by simply repeatedly selecting the prev or next buttons.

2 Points
two_point_profile_on_section

Position of option on menu: Section View Menu     View =>Profile =>2 points

After selecting the 2 points option, the two points profile on section panel is displayed.



12d Model Reference Manual

Page 306 March 2007Section View Menu

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set profile parameters for.

Start X Y Z input/output xyz ops menu

co-ordinates of the start section point. New values can be typed, or a point selected using the xyz ops 
pop-up menu.

End X Y Z input/output xyz ops menu

co-ordinates of the end section point. New values can be typed, or a point selected using the xyz ops 
pop-up menu.

Dynamic tick-cross tick

if tick, the profile will be dynamically calculated between the first selected point and the cursor 
position.

Start and End pts button

after selecting the start and end pts button, the first point of the section to be profiled is selected and its 
value written to the start xyz field. If dynamic is set on, then a profile from the first point to the cursor 
position is automatically calculated as the cursor is moved around the view. Selecting the second points 
finalises the section and the co-ordinates of the final point is written to end xyz field.

Profile button

after selecting the profile button, a section is calculated between the start xyz and end xyz points.
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Perpendicular to CL
centreline_profile_on_section

Position of option on menu: Section View Menu     View =>Profile =>Perpendicular to CL

After selecting the perpendicular to cl option, the centreline profile on section panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set profile parameters for.

LHS offset input 10
distance (in world units) to take the section to the left of the selected string.

RHS offset input 10
distance (in world units) to take the section to the right of the selected string.

String string-select
the selected string is used to specify the position where a cross-section is defined. Once the string is 
selected, then as the cursor is moved around in a view, its position will be dynamically be dropped 
perpendicularly onto the selected string, and a cross-section defined at right angle to the selected 
string. A profile along the cross-section will then be drawn in the section view. The cross-section profile 
will be dynamically modified as the cursor position is modified.

One Substring
Position of option on menu: Section View Menu     View =>Profile =>One substring

As well as profiling strings, the one substring option can profile a house connection or property 
control (substrings) in a drainage or sewer string.

After the one substring option is chosen from the menu, the user selects a substring for profiling. 
After the string or substring has been profiled, the option terminates.

Many substrings
Position of option on menu: Section View Menu     View =>Profile =>Many substrings

The many substrings option is designed for profiled a number of substrings, one after another.

After the many substring option is chosen, the user selects a substring for profiling. After the 
substring has been profiled, another string or substring can be chosen for profiling.

The option is terminated by clicking LB to get the pick ops menu and selecting cancel.
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Regenerate
Position of option on menu: Section View Menu     View =>Regenerate

The regenerate option is used to re-calculate and re-display the profile of the primary string of 
the section view.

This is necessary because modifications to the primary string or any strings or tins one the view 
may make the initial profile invalid. A regenerate is a quick method of bringing the profile up to 
date.

Section Plotting
section_view_plot_menu

Position of menu: Section View Menu     View =>Plotting

The plotting walk-right menu contains the options plot, long plot and X plot.

The plot option is used to make a plot file of all the information displayed in the section view.

The long plot option is used to make a traditional long section plot with string chainages and 
elevations displayed for each of the strings in the section view. The form of the long plot can be 
finely controlled by a file of plot parameters.

The X plot creates the traditional stacked x-section plots for each x-section string in a given 
model. The form of the x-plot can be finely controlled by a file of plot parameters.

For the option Plot, go to the section “Section Plot” 
Long plot “Long Plot” in the chapter “Plots” 
X plot “X Plot”  in the chapter “Plots” 

Drainage/Sewer  “Drainage Longsections”  in the chapter “Drainage and Sewer” 
Melbourne water “Melbourne Water”  in the chapter “Drainage and Sewer” 
Pipeline  “Plots”  in the chapter “Pipeline” 

Section Plot
section_plot

Position of option on menu: Section View Menu     View =>Plotting =>Plot

The plot option writes out all the information displayed in the section view to either a plot file (in 
a user selected format) or to a 12d Model model. The user selects a scale for the plot and the sheet 
width and height are calculated by 12d Model.

After selecting the plot option, the section plot panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input/output current view available views
view to set plot parameters for.

Plotter type input hp hp, dxf, postscript etc.
file format for the plot information.

Plot file input depends on
plotter type

stem of the name of the file to write the plot of the view to. The name ending is added automatically and 
depends on the plotter type.

Clean model beforehand choice box do not clean
prompt for clean
always clean

only applicable if plotting to a model.

if always clean, the model is cleaned before the plot is created.
If prompt for clean, the user is prompted that the model will be cleaned before the plot is created.
If do not clean, the model is not cleaned before the plot is created.

Scale 1: input
if a value is entered by the user and an <enter> given, the sheet width and height required by the plot 
are calculated and displayed in the sheet width and sheet height fields.

Sheet width (mm) output
if a value is entered by the user and an <enter> given, the scale and height required by the plot are 
calculated and displayed in the scale and sheet height fields. The units for sheet width are 
millimetres.

Sheet height (mm) output
if a value is entered by the user and an <enter> given, the scale and width required by the plot are 
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calculated and displayed in the scale and sheet width fields. The units for sheet height are millimetres

Title and border tick-cross tick
if tick then a border and two lines of title are placed on the bottom of the plot

Text style input 1
text style for the title information

Text Height (mm) input 10
height (in millimetres) to draw the two lines of title information

Title line 1/2 input
first/second line of title information

Title colour input cyan available colours
colour used for the border and the title information

Plot button
write out the plot of the information displayed in the view to the file given in the plot file field. The 
format of the file is given by the plotter type

Long Plot
Position of option on menu: Section View Menu     View =>Plotting =>Long plot

The option is for creating long section plots.

 The Long plot option is documented in the section “Long Plot” in the chapter “Plots” 

X Plot
Position of option on menu: Section View Menu     View =>Plotting =>X plot

The x plot option is for creating x-section plots.

 The option is documented in the section “X Plot” in the chapter “Plots” 

Drainage/Sewer Plot
Position of option on menu: Section View Menu     View =>Plotting =>Drainage/Sewer

The Drainage/Sewer plot option is used to make the long section plots for a drainage or sewer 
network.

This option is documented in the section “Drainage Longsections” of the chapter “Drainage and 
Sewer” 

Melbourne Water Plot
Position of option on menu: Section View Menu     View =>Plotting =>Melbourne Water

The Melbourne Water plot option is used to make the long section plots for a sewer network to 
Melbourne Water standards.

This option is documented in the section “Melbourne Water” of the chapter “Drainage and 
Sewer” 

Pipeline Plot
Position of option on menu: Section View Menu     View =>Plotting =>Pipeline

The Pipeline plot option is used to make the long section plots for a sewer network to Melbourne 
Water standards.
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This option is documented in the section “Longsections” of the chapter “Pipeline” 
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Section Utilities
section_view_utilities_menu
Position on menu: Section View Menu     View =>Utilities

The utilities menu contains miscellaneous options involving the section view. The utilities walk-
right menu is

For the option New view, go to the section  “New View” 
Report “Report” 
VG edit “VG Edit” 
Dump “Dump” 

New View
section_view

Position of option on menu: Section View Menu     View =>Utilities =>New view

The new view option displays the current minimum and maximum chainage and height values 
for the view, and permits the user to specify new values as the section’s viewing parameters.

Selecting New view fires up the section view panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults

View input/output current view available views

view to set section parameters for.

chain min/max input/output current chainage min/max
minimum/maximum string chainage for the view. Chainage is used as the x-axis co-ordinates in a 
section view.

Ht min/max input/output current height min/max
minimum/maximum height (z value) for the view. Height is used as the y-axis co-ordinates in a section 
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view.

View button
define the section view parameters according to the information in the panel. If the box given by the 
chainage and height values in the panel is not the same shape as the view itself, the chainage and height 
values will be modified so that the chainage and height values match the view shape. The final chainage 
and height values are displayed in the panel.

Report
service_items_report_on_section

Position of option on menu: Section View Menu     View =>Utilities =>Report

This report option is for producing information on all the items displayed in the section view.

After selecting the report option, the service items report on section view panel is displayed

For the profiled string, this option generates a report which includes the 

▲ section through any tins on the section view

▲ name and model of any services in the corridor defined by the section view

▲ co-ordinates and chainages of the parts of the service in the corridor, and the chainage and 
offset for each of the point of the parts projected onto the profiled string.

▲ clearance at the point where any service goes under or over the profiled string.

VG Edit 
vg_edit_string

Position of option on menu: Section View Menu     View =>Utilities =>VG Edit

The VG edit option is used to interactively create and modify the vertical geometry of a 
12d Model alignment string, or the vertical information of any string that can be edited in a 
section view (e.g. drainage string). Vertical geometry can only be created for an existing string.

After selecting the VG edit option, the VG edit string panel is placed on the screen.

The option is already in pick mode and the user simply picks and accepts the string whose 
vertical geometry is to be created and/or edited The pick & edit button only needs to be used if 
the pick was cancelled from the pick ops menu.
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Once the string has been selected, it is automatically made the primary string for the section 
view and a string profile created along the string.

As discussed in the section view profile options, for each tin in a model added to the section 
view, the section through the tin along the primary string (the selected string) is calculated and 
displayed in the section view.

The VG edit option then fires up the standard string editor which is described in detail in the 
string edit options.

Dump
Position of option on menu: Section View Menu     View =>Utilities =>Dump

This option is used to write the view out in a user selected format. It is the same as the dump 
option for the plan view and is fully documented in the plan View => Utilities section.
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View Buttons
For each view type, there are a number of selected view menu options available as buttons (view 
buttons) in the view title area.

The options on each view type are

To select one of the view buttons, click LB whilst the cursor is over the button.

Note that the view buttons do not highlight when the cursor passes over them.

If RB is clicked over any view button other than Profile on the section view, the view menu for the 
view type will be displayed.

For documentation on the Plan view buttons, go to the section “Plan View Buttons” .
Perspective view buttons, go to the section “Perspective View Buttons” .
Section view buttons, go to the section “Section View Buttons” .

Plan View Buttons

Menu

If the Menu button is selected in the view button area of any view, or if RB is clicked in the view-title 
area or in the view-button area, a new menu called the View menu appears.

Because of the differences between plan, perspective and section views, the options on the View 
menu vary for each view type. 

The plan View menus is

view
buttons

Plan view buttons

Menu Fit
Pan

Zoom
Shrink

Toggle
Refresh

PlotAdd
Remove

Previous
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The View menu is removed by selecting the [X] button or if the View menu hasn’t been moved, by 
simply clicking RB again in the view-title or view button area. If the View menu has been moved, 
clicking RB will warp the cursor to the moved View menu.

+ or Add

The + view button works in four modes.

▲ clicking LB whilst the cursor is over the + brings up the Models to Add list. This list 
contains all of the models not yet added to the view.

▲ typing a keyboard character whilst the cursor is over the + brings up a Models to Add list 
containing only those models not on the view with names beginning with the typed 
character.

▲ typing a * character whilst the cursor is over the + brings up a Add Models to View panel 
which can then be used with wild cards and characters.

▲ clicking MB whilst the cursor is over the + brings up the Add Models to View by Pick panel 
and starts up a same as for a view. Models to add to the view are then selected by simply 
picking a string from the model. See chapter Tools and Concepts for further 
documentation on same as.

▲ clicking RB whilst the cursor is over the + brings up the View panel documented earlier in 
this chapter.

For the Same as option for the + and - view buttons, please continue to the section “Same As 
for Views” .

- or Remove

The - view button works in four modes.

▲ clicking LB whilst the cursor is over the - brings up the Models to Remove list. This menu 
lists all of the models on the view.

▲ typing a keyboard character whilst the cursor is over the - brings up a Models to Remove 
list containing only those models on the view with names beginning with the typed 
character.

▲ typing a * character whilst the cursor is over the - brings up a Remove Models from View 
panel which can then be used with wild cards and characters.

▲ clicking MB whilst the cursor is over the - brings up the Remove Models from View by Pick 
panel and starts up a same as for a view. Models to remove from the view are then 
selected by simply picking a string from the model. See the next chapter for further 
documentation on same as.

▲ clicking RB whilst the cursor is over the - brings up the View panel documented earlier in 
this chapter.

For the Same as option for the + and - view buttons, please continue to the section “Same As 
for Views” .

Fit
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This is the same as fit from the view menu.
If LB is clicked on the fit, then the fit option is activated.
If RB is clicked on the fit, then the view option is activated.

Pan
This is the same as pan from the View=>Pan menu.
If LB is clicked on the Pan, then the pan option is activated.

Zoom
This is the same as the two point zoom option from the plan View=>Zoom menu.
If LB is clicked on the Zoom, then the zoom option is activated.

Shrink
This is the same as the two point shrink option from the plan View=>Zoom menu.
If LB is clicked on the shrink, then the shrink option is activated.

Previous

This is the same as previous from the view menu.
If LB is clicked on the prev, then the previous option is activated.
If RB is clicked on the prev, then the view option is activated.

Toggle

This is the same as toggle from the View=>Settings menu.
If LB is clicked on the toggle, then the toggle menu is activated.
If RB is clicked on the toggle, then the view option is activated.

The Toggle menu for the plan view types is: 

Refresh
As its name implies, this option redraws all the models on the view using the current 
drawing parameters. This is the same as clicking MB in the view title area.

Plot
plan_view_plot_menu
If LB is clicked on Plot, then the View Plotting menu for the plan view is activated.
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Perspective View Buttons

Menu

If the Menu button is selected in the view button area of any view, or if RB is clicked in the view-
title area or in the view-button area, a new menu called the View menu appears.

Because of the differences between plan, perspective and section views, the options on the 
View menu vary for each view type. 

The Perspective View menus is

The View menu is removed by selecting the [X] button or if the View menu hasn’t been moved, 
by simply clicking RB again in the view-title or view button area. If the View menu has been 
moved, clicking RB will warp the cursor to the moved View menu.

+ or Add

The + view button works in four modes.

▲ clicking LB whilst the cursor is over the + brings up the Models to Add list. This list 
contains all of the models not yet added to the view.

▲ typing a keyboard character whilst the cursor is over the + brings up a Models to Add list 
containing only those models not on the view with names beginning with the typed 
character.

▲ typing a * character whilst the cursor is over the + brings up a Add Models to View panel 
which can then be used with wild cards and characters.

▲ clicking MB whilst the cursor is over the + brings up the Add Models to View by Pick panel 
and starts up a same as for a view. Models to add to the view are then selected by simply 
picking a string from the model. See chapter Tools and Concepts for further 
documentation on same as.

▲ clicking RB whilst the cursor is over the + brings up the View panel documented earlier in 
this chapter.

For the Same as option for the + and - view buttons, please continue to the section “Same As 
for Views” .

perspective

Menu Refresh
PlotAdd

Remove

Eye

Walk
Joy

Drive

view buttons

Orbit
Fit

Pan
Zoom

Shrink

Toggle

Previous
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- or Remove

The - view button works in four modes.

▲ clicking LB whilst the cursor is over the - brings up the Models to Remove list. This menu 
lists all of the models on the view.

▲ typing a keyboard character whilst the cursor is over the - brings up a Models to Remove 
list containing only those models on the view with names beginning with the typed 
character.

▲ typing a * character whilst the cursor is over the - brings up a Remove Models from View 
panel which can then be used with wild cards and characters.

▲ clicking MB whilst the cursor is over the - brings up the Remove Models from View by Pick 
panel and starts up a same as for a view. Models to remove from the view are then 
selected by simply picking a string from the model. See the next chapter for further 
documentation on same as.

▲ clicking RB whilst the cursor is over the - brings up the View panel documented earlier in 
this chapter.

For the Same as option for the + and - view buttons, please continue to the section “Same As 
for Views” .

Fit

This is the same as fit from the view menu.
If LB is clicked on the fit, then the fit option is activated.
If RB is clicked on the fit, then the view option is activated.

Previous

This is the same as previous from the view menu.
If LB is clicked on the prev, then the previous option is activated.
If RB is clicked on the prev, then the view option is activated.

Toggle

This is the same as toggle from the View=>Settings menu.
If LB is clicked on the toggle, then the toggle menu is activated.
If RB is clicked on the toggle, then the view option is activated.

The Toggle menu for the perspective view is: 

Eye

This is the same as eye/target from the View menu.
If LB is clicked on the Eye, then the Eye-target option is activated.

Joy

This is the same as joy from the View menu.
If LB is clicked on the joy, then the joy option is activated.
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Walk

This is the same as string walk =>along string from the View =>Utilities menu.
If LB is clicked on the walk, then the walk along string option is activated.

Drive

This is the same as string drive => along string from the View =>Utilities menu.
If LB is clicked on the drive, then the drive along string option is activated.

Redraw
As its name implies, this option redraws all the models on the view using the current 
drawing parameters. This is the same as clicking MB in the view title area.

Plot

perspective_view_plot_menu
If LB is clicked on plot, then the view plotting menu for the perspective view is activated.
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Section View Buttons

Menu

If the Menu button is selected in the view button area of any view, or if RB is clicked in the view-title 
area or in the view-button area, a new menu called the View menu appears.

Because of the differences between plan, perspective and section views, the options on the View 
menu vary for each view type. 

The Section View menus is

The View menu is removed by selecting the [X] button or if the View menu hasn’t been moved, by 
simply clicking RB again in the view-title or view button area. If the View menu has been moved, 
clicking RB will warp the cursor to the moved View menu.

+ or Add

The + view button works in four modes.

▲ clicking LB whilst the cursor is over the + brings up the Models to Add list. This list 
contains all of the models not yet added to the view.

▲ typing a keyboard character whilst the cursor is over the + brings up a Models to Add list 
containing only those models not on the view with names beginning with the typed 
character.

▲ typing a * character whilst the cursor is over the + brings up a Add Models to View panel 
which can then be used with wild cards and characters.

▲ clicking MB whilst the cursor is over the + brings up the Add Models to View by Pick panel 
and starts up a same as for a view. Models to add to the view are then selected by simply 
picking a string from the model. See chapter Tools and Concepts for further 
documentation on same as.

▲ clicking RB whilst the cursor is over the + brings up the View panel documented earlier in 
this chapter.

Section view

Menu Fit
Pan

Zoom
Shrink

Toggle
Refresh

Plot

Add
Remove

Previous buttons

Exaggeration

Profile
Previous string

Next string

Regenerate
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For the Same as option for the + and - view buttons, please continue to the section “Same As 
for Views” .

- or Remove

The - view button works in four modes.

▲ clicking LB whilst the cursor is over the - brings up the Models to Remove list. This menu 
lists all of the models on the view.

▲ typing a keyboard character whilst the cursor is over the - brings up a Models to Remove 
list containing only those models on the view with names beginning with the typed 
character.

▲ typing a * character whilst the cursor is over the - brings up a Remove Models from View 
panel which can then be used with wild cards and characters.

▲ clicking MB whilst the cursor is over the - brings up the Remove Models from View by Pick 
panel and starts up a same as for a view. Models to remove from the view are then 
selected by simply picking a string from the model. See the next chapter for further 
documentation on same as.

▲ clicking RB whilst the cursor is over the - brings up the View panel documented earlier in 
this chapter.

For the Same as option for the + and - view buttons, please continue to the section “Same As 
for Views” .

[exagg]

This is the vertical exaggeration for the view.
If LB is clicked on the exaggeration, then the toggle option for the section view is activated. 
This has options to quickly change the vertical exaggeration.

Profile

section_view_profile_menu

If LB is clicked on profile, then the profile option is activated. This option is the same as 
View=>Profiling=>One string. If a string is being profiled, then the string name is displayed 
after the Section view name.

If RB is clicked on Profile, then the profiling menu is activated.

<<
Profile previous string.

>>
Profile next string.

Regen

This is the same as the option regenerate option from the section view menu.
If LB is clicked on the regen, then the regen option is activated.



Chapter 5  View Menus

March 2007 Page 323View Buttons

Fit

This is the same as fit from the view menu.
If LB is clicked on the fit, then the fit option is activated.
If RB is clicked on the fit, then the view option is activated.

Pan
This is the same as pan from the View=>Pan menu.
If LB is clicked on the Pan, then the pan option is activated.

Zoom
This is the same as the two point zoom option from the plan View=>Zoom menu.
If LB is clicked on the Zoom, then the zoom option is activated.

Shrink
This is the same as the two point shrink option from the plan View=>Zoom menu.
If LB is clicked on the shrink, then the shrink option is activated.

Previous

This is the same as previous from the view menu.
If LB is clicked on the prev, then the previous option is activated.
If RB is clicked on the prev, then the view option is activated.

Toggle

This is the same as toggle from the View=>Settings menu.
If LB is clicked on the toggle, then the toggle menu is activated.
If RB is clicked on the toggle, then the view option is activated.

The Toggle menu for the section view is: 

Refresh
As its name implies, this option redraws all the models on the view using the current 
drawing parameters. This is the same as clicking MB in the view title area.

Plot

section_view_plot_menu
If LB is clicked on plot, then the view plotting menu for the section view is activated.
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Same As for Views
add_models_to_view_by_pick remove_models_from_view_by_pick

Clicking the middle mouse button (MB) over the + or - view buttons will activate a same as pick 
which allows the user to select the model to add to (+) or remove from (-) the view by simply 
picking any string from the model to be added or removed.

After clicking MB over the + or - view button, the add models to view by pick or remove models 
from view by pick panel is brought up.

The option is already running and when a string is picked,. the model containing the string is 
added to/removed from the view. Further strings can then be selected to add or remove another 
model.

The option is terminated by selecting [X] or finish from the panels, or cancel from the pick ops 
menu.
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6  Projects
projects

The projects walk-right menu is:

For the option Change, go to the section “Change” 
Copy “Copy” 
Check points “Check Base Points” 
Details  “Details” 
Management “Management” 
Restart “Restart” 
Save “Save” 
Tree “Tree” 
Utilities “Utilities” 
Delete “Delete” 

12d Model “12d Model” 
Exit “Exit” 

Each option will now be discussed in the order that they appear on the Projects menu.

create floating Projects menu (see right)
change working directory and/or project
make a copy of a project
number of points for base point count
project description and details
edit project setup/management files
exit and restart in same project
save the working project to disk
project data and set up files in tree form
project utilities
delete a project from disk

information on 12d Model
User Projects menu

create floating 12d Model menu
exit 12d Model

on Main menu on 12d Model menu
and floating menu
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Change
change_project

Position of option on menu: Project =>Change

The change option is used to change the working directory and the working project. The panel can 
be resized.

On selecting the change option, the change project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Client name display only

authorized 12d Model client.

Recent projects list output recent projects

names and directories of project recently select. Single clicking on an entry in the list displays the 
projects description in the Project description area. Double clicking on an entry in the list changes the 
project

Project description output

description of the project highlighted in the Recent projects list.

New directory input current directorylocal directories

name of the directory to become the working directory.

New project     input projects in new directory

name of the project to become the working project in the new directory.

Change button

after selecting this button, the working directory is changed to the directory specified in the 
new directory field. The working project is set to the project given in the new project field. If the 
new directory or new project does not exist, it will be created.

Note: This is a resizable panel.

recent projects list

description of

recent project

authorized client
name

highlighted
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Copy
copy_project

Position of option on menu: Project =>Copy

The copy option is used to make a copy of any project (other than the current project) in the 
working directory.

On selecting the copy option, the copy project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Old project input none     projects in directory

name of the project to be copied.

New project input

name of the copy of the project. The new project name cannot be the same as an existing 
project in the working directory.

Copy button

after selecting this button, a complete copy of the project given in the old project field is made 
and saved under the name given in the new project field.
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Check Base Points
check_points

Position of option on menu: Project =>Check base points

The Check points option gives the number of base points used in the project and the total number 
of base points available in the customers version of 12d Model.

Note that not all vertices in all strings are "base" points and count towards the number of base 
points. For example, vertices in contours generated by the Contour option do not count as base 
points. The vertices of strings created when plotting to a model are also not counted as base 
points.

On selecting Check points from the Projects menu, the Check Base Points panel is displayed.

total number of base points availablenumber of base points
used in this project in this version of 12d Model

5M base does not give 
 total number of points

if its not a 5M base.
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Details
project_details

Position of menu: Project =>Details

A project description and project details can be defined.

The Project details walk-right menu contains various projection items.

For the option Description, go to the section “Description” 
Details  “Details” 

The options in the menu will now be described.

Description
project_description

Position of option on menu: Project =>Details =>Description

The description option is used to create and edit the project description.

On selecting the Description option, the Project Description panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Project description area input

the description for the project to be rebuilt. The description can be more than one line long.

Set button

set the project description.to be the text in the project description area.

display/modify the project description
display/modify the project details

project description area
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Note: This panel a resizable panel.

Details
enter_project_details

Position of option on menu: Project =>Details =>Details

The Details option is used to enter project details.

On selecting the Details option, the Enter Project Details panel is displayed.

What information is to be entered into the Enter Project Details panel is defined in the option

Project =>Management =>Details editor - go to “Details Editor” 

The fields and buttons used in the Enter Project Details panel have the following functions.

Field Description Type Defaults Pop-Up

Set button

set the project details to the values show in the panel. The values are stored as project 
attributes.

Load button

brings up the Projects Details Setting Reload panel that is used to load a new definition of 
project detail attributes.

project_details_settings_reload



Chapter 6  Projects

February 2007 Page 331Details

A file defining a new set of project attributes of project details can be loaded. How existing 
project details are handled depends on the value of Old details handling

Old details handling

Remove - all existing project detail attributes are removed and totally replaced by the new set 

Keep (no update) - any existing project detail are kept but their values are not updated by 
the default setting if the same attribute exists in the Settings file.

Keep (with update) - any existing project detail are kept and their values are updated by the 
default setting if the same attribute exists in the Settings file.
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Management
project_management

Position of menu: Project =>Management

Options to set up the project

The Project management walk-right menu contains various projection items.

For the option Defaults, go to the section “Defaults” 
Details editor “Details Editor” 
env.4d “env.4d” 
Projections “Projections” 
N Values “N values” 
7 Parameters “7 Parameters” 
Workspace  “Workspace” 
Tree  “Tree” 
Share settings “Share Settings” 

The options in the menu will now be described.

set default values for the project
edit the details definition file
edit the env.4d file
define/use projections
define/use N value parameters
define/use 7 value parameters
define/use workspace setup
edit items on the project tree 
set share settings for this session
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Defaults
defaults

Position of option on menu: Project =>Management =>Defaults

The Defaults option allows the user to view and modify many of the default values used in the 
current 12d Model project.

NOTE - The values in the default option panels are initially set for a new project by the values in 
the defaults.4d file. For more information on the defaults.4d file, go to the section “Defaults” in the 
Appendix “Set Ups” 

Any changes made in the Defaults panel are used in the current session for the project when the 
Set button is pressed. The values are only saved for the project if a Project =>Save is done after 
the Set.

 The Defaults panel consists of tabs for the groups of settings Defaults, System, Trash and Name.

Default Settings Tab

On selecting the Default Settings tab, the Default Settings are displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Colour colour box default colour available colours

the name of the current default colour used for line strings.

Point colour colour box def point colour available colours

the current default colour used for point strings.

Tin colour colour box def tin colour available colours

the default tin colour used in the triangulate model and view panels.

Contour colour colour box def cont colour available colours

the default contour colour used in the contour panel.

Cont bold colour colour box def cont index col available colours

the default contour bold colour is used in the contour panel.

I/O null height input -999.0

this field contains the value of the value recognised as a null height when reading in and writing out 
data.

Text height (pixels) input  8

the default text height used in the sewer option and other panels.

Chord/Arc tolerance input  0.1

the maximum value of a chord to arc distance. If this distance is exceeded when approximating curves 
by chords, extra points are inserted into the curve so that the chords all have chord/arc distances less 
than this value. A value of zero disables the chord/arc test.

Culling tick box

the culling setting for any new perspective or plan views.

Culling size (pix) input  5

the culling size for any new perspective or plan views.

Corner angle input  15

when applying templates or calculating interfaces along a string, extra sections may be required at 
string vertices with no horizontal curve on them. If the corner angle is non-zero, extra sections are 
added in at multiples of the corner angle value for the plan angle at the vertex.

Weed tolerance input  0

if two points on a string (with the same bearing) are closer that this distance then the second point is 
left out. This applies to the extra points added in at chainage points in interfacing and corner angles.

Section view exagg input 10

the vertical exaggeration used for any new section views.

Perspective view exagg input 1

the vertical exaggeration of any new perspective.

Cut volume sign choice box negative negative, positive

the sign (positive or negative) used for cut volumes and areas. The sign for fill is the opposite.

Load button

read the default values from the current default.4d file for the project. The values are not used for the 
project until the Set button is pressed. The values are not saved for the project until a ’Project =>Save’ 
is done after the Set.

Set button

when set is selected, the defaults are set to the values given in the corresponding fields of this panel. 
These are not saved unless a ’Project =>Save’ is done after the Set.
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Write button

write the values in the panel to the defaults.4d file.
The values are not used for the project until the Set button is pressed. The values are not saved for the 
project until a ’Project =>Save’ is done after the Set. For more information on the Write button, go to 
the section “Writing Set Up Files”  in the Appendix “Set Ups” .

Systems Settings Tab

On selecting the System Settings tab, the System Settings are displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Angle mode choice box  bearings cartesian, bearings

specifies whether bearings or cartesian angles are used in reporting the instantaneous direction of the 
selected string in the information menu.

Cross size (pixels) input/output 2

the size in pixels that crosses (for points etc.) are drawn on the screen.

Cross size (mm) input/output 2.5

the size in millimetres that crosses (for points etc.) are drawn on any plots.

Highlight cross size input/output 8

the size in pixels of the cross used for highlighting objects in views.
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Highlight cross colour colour box yellow available colours

the colour of the cross used for highlighting objects in views.

Highlight colour colour box white available colours

the colour used to display objects in views when they are highlighted.

Display colours input/output 0

the number of colours from the top of the colour map file, colour_map.def, that are displayed in a 
colour pop-up. If 0, all colours are displayed.

Save interval (min) input/output 5

the number of minutes that elapse after a save before the save project reminder panel comes up. If 0, 
the panel never comes up.

Display precision input/output 3

the number of decimal places used for values displayed in the information menus.

Box precision input/output 4

the number of decimal places used for values displayed in boxes and panels.

Popup length input/output 28

the maximum number of items in a pop-up before breaking the pop-up into walk-rights.

Display reports tick box tick

if tick, as soon as a report is produced, it will be displayed in the editor defined by the environment 
variable, EDITOR_4D.

Display edit info tick box tick

if tick, the edit info panel is automatically displayed whenever a string is created or edited.

Print reports tick box tick

if tick, as soon as a report is produced, it will be passed to the script/program defined by the 
environment variable, PRINTER_4D.

Send plots tick box tick

if tick, as soon as a plot is produced, it will be passed to the script/program defined by the environment 
variable, PLOTTER_4D.

Plan crosses tick box

This option is experimental - at the moment things will look messy when editing in a section view with 
plan crosses turned on.
if tick, when the cursor is in a plan or perspective view, it is projected onto any section views as well.

Function results tick box tick

if tick, function results such as volumes will be displayed on the screen every time a recalc is done.
if not tick, no function results as displayed on a function recalc.

Load button

read the default values from the current default.4d file for the project. The values are not used for the 
project until the Set button is pressed. The values are not saved for the project until a ’Project =>Save’ 
is done after the Set.

Set button

when set is selected, the defaults are set to the values given in the corresponding fields of this panel. 
These are not saved unless a ’Project =>Save’ is done after the Set.

Write button

write the values in the panel to the defaults.4d file.
The values are not used for the project until the Set button is pressed. The values are not saved for the 
project until a ’Project =>Save’ is done after the Set. For more information on the Write button, go to 
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the section “Writing Set Up Files”  in the Appendix “Set Ups” 
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Trash Settings Tab

On selecting the Trash Settings tab, the Trash Settings are displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Trash mode choice box  trash string keep string, trash string,
delete string

In many string options, new strings are created from existing strings. What happens to the original 
strings may be determined by the trash mode.
If set to keep string, the original strings will not be touched
    trash string, the original strings will be moved to the trash model
    delete string, the original strings will be deleted.

Trash model model box Trash Model available models

the model that trashed strings are put into. This model needs to be cleaned or deleted to permanently 
remove the strings.

Load button

read the default values from the current default.4d file for the project. The values are not used for the 
project until the Set button is pressed. The values are not saved for the project until a ’Project =>Save’ 
is done after the Set.

Set button

when set is selected, the defaults are set to the values given in the corresponding fields of this panel. 
These are not saved unless a ’Project =>Save’ is done after the Set.
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Write button

write the values in the panel to the defaults.4d file.
The values are not used for the project until the Set button is pressed. The values are not saved for the 
project until a ’Project =>Save’ is done after the Set. For more information on the Write button, go to 
the section “Writing Set Up Files”  in the Appendix “Set Ups” 

Names Settings Tab

On selecting the Name Settings tab, the Name Settings are displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Names input *.mf files

name of the mapping file used as the default name mapping file.

Load button

read the default values from the current default.4d file for the project. The values are not used for the 
project until the Set button is pressed. The values are not saved for the project until a ’Project =>Save’ 
is done after the Set.

Set button

when set is selected, the defaults are set to the values given in the corresponding fields of this panel. 
These are not saved unless a ’Project =>Save’ is done after the Set.
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Write button

write the values in the panel to the defaults.4d file.
The values are not used for the project until the Set button is pressed. The values are not saved for the 
project until a ’Project =>Save’ is done after the Set. For more information on the Write button, go to 
the section “Writing Set Up Files”  in the Appendix “Set Ups” .



Chapter 6  Projects

February 2007 Page 341Management

Details Editor
project_details_editor

Position of option on menu: Project =>Details =>Management =>Details editor

The Details Editor s option creates the files used to define the project attributes displayed in the 
Project Details panel.

On selecting the Details Editor option, the Project Details Editor panel is displayed.

The items defined in the Project Details Editor panel can be of type Text (e.g. fred), Integer (e.g. 
11) or Real (e.g. 23.15).

The fields and buttons used in the Enter Project Details panel have the following functions.

insert a new item

delete an item

move an
item up

move an
item down
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Field Description Type Defaults Pop-Up

Set button

 the values in the panel are set as the project details setup

Write button

writes out a project details file.

When inserting a new "detail", the following is displayed 

l

Field Description Type Defaults Pop-Up

Type choice box Text Text, Integer, Real

 the detail can be text, an integer or a real value

Name input

name of the project attribute used to store the detail

Display name input

name to appear in the Enter Project Details panel

Description input

description that appears when the Display name is clicked in the Enter Project Details panel

Default value input

default value for the detail

Precision integer box

only for Type Real - number of decimal places

Is optional tick box tick

if tick, then the detail does not have to be filled in.
If not tick, it is compulsory to fill in the detail in the Enter Project Details panel before leaving 
the panel.
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env.4d
edit_environment_variables

Position of option on menu: Project =>Management =>env.4d

The env.4d option is used to create/update the env.4d file of environmental variables.

When the option is selected, it reads in the current env.4d file and displays in the panel, the 
values for any environment variables in the file. Hence the panel shows the values for the 
environment variables in the file, not those that are not in the file and have default values set by 
12d Model.

Hence the tick boxes in the Edit Environment Variables panel have three states rather than the 
standard two states. There is the standard tick or nothing to denote the value of the variable is 
set from the env file (or is going to be written out to the env file) or a greyed out tick or greyed out 
blank box to indicate that the value has not been set by the environment variable. Clicking on the 
tick box will toggle between the three states - on, off and no value.

After any modifications are made, the parameters are written out to an env.4d file.

Note that the env.4d file is only used when a project is loaded so the parameters written to an 
env.4d file can only take affect for the current project if a project restart is done.

On selecting the env.4d option, the edit environmental variables panel is displayed.

non greyed box indicating 
that this value has been set 
in the env file, or is to be 
written out to the env file.

greyed box indicating that this has not been set in the env file, or 
won’t be written out to the env file

Three State Tick Box
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Write button

write the values in the panel to a file. For more information on the Write button, go to the section 
“Writing Set Up Files”  in the Appendix “Set Ups” 

Note - the env.4d file is only used when a project is loaded so the parameters written to the 
env.4d file will only take affect for the current project if a project restart is done. 

For more information on the variables on the tab Dongles, go to the “Dongles tab” 
System A “System B tab” 
System A “System B tab” 
Setup A “Setup A tab” 
Setup B “Setup B tab” 
Plotting A “Plotting A tab” 
Plotting B “Plotting B tab” 
Plotting C “Plotting C tab” 
Extra A “Extra A tab” 
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Extra B “Extra B tab” 
Extra C “Extra C tab” 
OpenGL “OpenGL tab” 
Variable “Variable tab” 

The environment variables are described in more detail in the section “Environment Variables” of 
the Appendix “Set Ups” . 

Dongles tab

Common tab

Dongle order DONGLE_ORDER_4D                       Hardlock/Wibu, Wibu/Hardlock

order to search for network dongles

Time dongle access DEBUG_DONGLE_ACCESS_4D 

time between searches for a dongle

Hardlock tab

User hardlock dongle HARDLOCK_4D                        tick box

if tick, search for 12d Hardlock dongles
If no tick, don’t search for Hardlock dongles

Local local, no local 

if local, then a single user Hardlock dongle is looked for on the computer
If no local, then no single user Hardlock dongle is looked for on the computer

Network no network, network first, network last 

if no network, then no Hardlock network dongle is looked for.
If network first, then a Hardlock network dongle is looked for before a single user local 
dongle.
If network last, then a Hardlock network dongle is looked for after looking for a single user 
local dongle.

Login retries

number of retries to find a Hardlock dongle

Login wait

time in seconds to wait between Hardlock dongle retries

Disable dongle                        tick box

if tick, don’t search for a Hardlock dongle
if no tick, search for a Hardlock dongle

Debug dongle                        tick box

if tick, write out Hardlock dongle debug information

Hardlock IP/Name addresses

if non blank, a list of IP addresses and/or computer names to search for a 12d Hardlock 
network dongle.
If blank, search the entire network for a 12d Hardlock network dongle

Wibu tab

User hardlock dongle WIBU_4D                        tick box

if tick, search for 12d Wibu dongles
If no tick, don’t search for 12d Wibu dongles
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Local local, no local 

if local, then a single user Wibu dongle is looked for on the computer
If no local, then no single user Wibu dongle is looked for on the computer

Network no network, network first, network last 

if no network, then no Wibu network dongle is looked for.
If network first, then a Wibu network dongle is looked for before a single user local dongle.
If network last, then a Wibu network dongle is looked for after looking for a single user local 
dongle.

Login retries

number of retries to find a Wibu dongle

Login wait

time in seconds to wait between Wibu dongle retries

Disable dongle                        tick box

if tick, don’t search for a Wibu dongle
if no tick, search for a Wibu dongle

Debug dongle                        tick box

if tick, write out Wibu dongle debug information

Hardlock IP/Name addresses

if non blank, a list of IP addresses and/or computer names to search for a 12d Wibu network 
dongle.
If blank, search the entire network for a 12d Wibu network dongle

System A tab

Text editor EDITOR_4D

the script or program that is fired up when a report is created. It usually points to an editor.

Genio wildcard GENIO_WILDCARD_4D

Sets the ending of the files selected for the pop-up list for the File field in the Read Genio Data 
panel.

Degrees character DEGREES_CHARACTER_4D

The integer (base 10) value of the character to use as the degrees symbol.

Pre*postfix for model for tin MODEL_FOR_TIN_PREFIX_4D

Customize the default model for the tin in the panels for creating triangulations.

Amount of report header REPORT_HEADER_4D

Controls the amount of header information in reports.

Typed units mode TYPED_UNITS_MODE_4D

Controls the typed input units for feet - international and/or US.

Default table width DEFAULT_TABLE_WIDTH_4D

Gives the number of characters displayed in tables such as decisionals and mtf editor.

Default view colour DEFAULT_VIEW_COLOUR_4D

The default background colour for views.

Double confirm delete DOUBLE_CONFIRM_DELETE_4D

Controls whether the user is asked once or twice to confirm for deletes and cleans.

Use bisector section BISECTORS_4D

At a HIP with no curve on it, either two sections can be applied at the HIP point or just a single 
bisector section applied to the bisector of the change of angle through the HIP.
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Disable mtf warnings DISABLE_MTF_WARNINGS_4D

Controls whether the mtf warnings go to a file or to the output window.

Drainage flows in descending chainage DRAINAGE_FLOW_DIR_4D

Defines the default flow direction used in the creating a drainage string.

Plan table settings PLAN_TABLE_SETTINGS_4D

Defines the default flow direction used in the creating a drainage string.

Zoom origin dynamic ZOOM_ORIGIN_DYNAMIC_4D

Controls the origin of the dynamic zoom.

Zoom pan dynamic ZOOM_PAN_DYNAMIC_4D

If set then dynamic pan is the default for the pan options.

Data tool tips DATA_TIPS_4D

If set then turn on data tool tips.

Icons on views VIEW_BITMAP_BUTTONS_4D

If set then icons are used for the menu items on views.

Use new strings create NEW_STRING_CREATES_4D

If set then the string creates are for super strings.
If not set, the string creates are the non-super string creates.

System B tab

Delete walkrights distance AUTO_DELETE_WALKRIGHTS_4D

The distance in pixels that is used to collapse the cascade of walk-right menus when the 
cursor moves that distance past the end of the last walk-right menu.

Drag reset distance AUTO_RESET_SELECT_DRAG_TOLERANCE_4D

The distance in pixels to move the cursor to reset the picking rejection list for a directional 
pick. If blank then the value 50 is used.

Reset distance AUTO_RESET_SELECT_TOLERANCE_4D

The distance in pixels to move the cursor to reset the picking rejection list for a non-directional 
pick. If blank then the value 5 is used.

Weed Tolerance WEED_TOLERANCE_4D

Used in Alignment and Super strings so that when arcs have been chord-to-arc’d, the 
resulting points are weeded so that no point is closer than the weed tolerance. Is is also used 
in Apply and Apply Many so that no cross sections are closer than the weed tolerance.

Polyline draw POLYPOLYLINES_4D

Different methods that speed up drawing of polylines.

Web search WEB_SEARCH_4D

Web address that’s used in 12d option "Help =>12d on the Web =>Search the web"

Recent projects RECENT_PROJECTS_4D

Maximum number of accessed projects displayed in the Project list when 12d Model first 
starts up.

Plan plot scale DEFAULT_PLAN_PLOT_SCALE_4D

Default plot scale used on any plan views.

Toolbars file TOOLBARS_4D

The file of toolbar definitions and names.
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Textstyle favourites file TEXTSTYLE_MAPPINGS_4D

The file of textstyle favourites.

Nodes file AUTHORIZATION_4D

The authorisation file (nodes.4d file).

Show full path name SHOW_PATHS_4D

When 12d Model fires up the actual file names defined by any environment variables are 
written to the output window. This is useful for debugging.

Show Vista full path name SHOW_VISTA_VIRTUAL_STORE_PATHS_4D

For Microsoft Vista, when 12d Model fires up the actual file names defined by any 
environment variables are written to the output window. This is useful for debugging.

Only use super string USE_SUPER_STRINGS_4D

If set, super strings are created by all options.

Enable undo UNDO_4D

Allow Undos.

Tin viewport clip TIN_VIEWPORT_CLIP_4D

Ignore extra tabs in field files FLD_IGNORE_EXTERA_WORDS_4D

If set, trailing tabs are not considered words in a field file. Mainly for Leach when it can’t 
suppress trailing tabs when writing a 12d Field file.

Alignment VG Corridor fixup ALIGNMENT_CORRIDOR_FIXUP_4D

Autopan on selects AUTO_PAN_SELECT_4D

Setup A tab

Autocad template folder ACAD_SEEDFILES_4D

Folder of Autocad template files.

Microstation seed folder MS_SEEDFILES_4D

Folder of Microstation seed files.

CivilCAD folder CIVILCAD_PATH_4D

Folder of CivilCAD files.

TP Stakeout folder TP_STAKEOUT_PATH_4D

Folder of TP Stakeout files.

Xtra menu file EXTRA_OPTIONS_4D

The 12D Solutions supplied file of definitions for some menus.

Data collectors file DATA_COLLECTORS_4D

File defining the available data collectors.

Data collector DATA_COLLECTOR_4D

The data collector that is used in the Survey Data Setup panel or to use if no data collector 
has been set for a project.

Station prefix STATION_PREFIX_4D

The default prefix to use in the Survey Data Setup panel or to use if prefix has been set for the 
project.

Fonts file FONT_4D

The file of text fonts to use.
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Function keys file FUNCTION_KEYS_4D

The file of function key definitions.

Library folder LIB_4D

The 12D Solutions supplied library folder.

Linestyles file LINESTYLES_4D

The file of linestyle definitions.

Log folder LOG_DIR_4D

The folder for the 12d Model log files.

Name mappings file NAME_MAPPINGS_4D

The file of name mappings.

Printer script PRINTER_4D

Points to a script or program which can be fired up whenever a report is generated. 

Allow named point attributes ALLOW_NAMED_POINT_ATTRIBUTES_4D

Setup B tab

Use "Documents and Settings\All Users" for env.4d, user, user_lib folders

USE_ALL_USERS_PROFILE_4D

Sharelocking folder SHARE_LOCKS_FOLDER_4D

The 12D Solutions folder used keeping lock files for shares.

Setups folder SET_UPS_4D

The 12D Solutions supplied set_ups folder.

Setups file SET_UPS_FILE_4D

The file for setting up the initial screen layout for new projects.

Spirals file SPIRALS_4D

The file for spiral definitions.

Textstyles file TEXTSTYLES_4D

The file of text styles to use.

User folder USER_4D

The User folder.

User library folder USER_LIB_4D

The User Library folder.

User options file USER_OPTIONS_4D

File for the definition of user defined menus.

Vpath DOS folder VEHICLE_PATH_4D

Folder for the Queensland Main Road DOS program Vpath - for vehicle turning paths.

Vpath Windows folder WINDOWS_VEHICLE_PATH_4D

Folder for the Queensland Main Road DOS program Vpath - for vehicle turning paths.

Winter program WINTER_4D

The program WINTER for calculating N-values.

Winter data folder WINTER_4D

Folder containing the Winter data of N-values for Australia.
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New project workspace file WORKSPACE_FILE_4D

Full path name of the workspace file for new projects.

New project details file PROJECT_DETAILS_4D

Full path name of the project details file for new projects.

Report files in non Unicode format ANSI_REPORTS_4D

If set, report files are written out in ANSI from Unicode versions of 1‘2d.

Plotting A tab

Use V7 Title blocks V7_TITLE_BLOCKS_4D

Use 12d ascii for title block definitions instead of old .tf files.

Show title variables SHOW_TITLE_VARIABLES_4D

For debugging the title block file.

Binary drainage plan parameter file NEW_DRAINAGE_PLAN_PPF_4D

Default binary drainage plan ppf file.

Binary Melbourne Water parameter file NEW_DRAINAGE_MELB_PPF_4D

Default binary drainage plan ppf file.

Binary drainage parameter file NEW_DRAINAGE_PPF_4D

Default binary drainage long section ppf file.

Binary pipeline parameter file NEW_PIPELINE_PPF_4D

Default binary pipeline long section plot ppf file.

Binary plot frame parameter file NEW_PLOT_FRAME_PPF_4D

Default binary plot frame ppf file.

Binary long section parameter file NEW_LONG_SECTION_PPF_4D

Default binary long section ppf file.

Binary x- section parameter file NEW_X_SECTION_PPF_4D

Default binary x-section ppf file.

Symbol file for long and x-sections PLOT_SYMBOLS_4D

Default plot symbols file.

Plotter script PLOTTER_4D

Points to a script or program which is fired up whenever a plot is generated. 

User plotters PLOTTERS_4D

File containing the definitions of plotters.

Plotter mapping file PLOTTER_MAPPING_4D

The default plotter mapping file.

Sheet sizes file SHEET_SIZES_4D

File defining the plot sheet sizes.

DGN plot seed file DGN_PLOT_SEED_FILE_4D

Seed file to use for Microstation plots.

DWT plot template file DWG_PLOT_SEED_FILE_4D

Template file to use for AutoCAD plots.
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Acad plot unit DWG_PLOT_UNIT_FILE_4D Metric, English

Plotting B tab

Use hardware arcs HARDWARE_ARCS_4D

Use computer hardware to draw arcs (rather than software).

Write all plot parameters WRITE_ALL_PLOT_PARAMETERS_4D

Controls whether all plot parameters are written out or just those that have been used in the 
ppf file.

Show old plotting options ALLOW_OLD_PLOTTING_4D

If set then a menu with all the old Ascii plot files is displayed.

Offset chainages to output window SPECIAL_OFFSET_CHAINAGES_4D

X-section parameter file X_SECTION_PPF_4D

Default x-section ascii ppf file.

Long-section parameter file LONG_SECTION_PPF_4D

Default long section ascii ppf file.

Drainage-parameter file DRAINAGE_PPF_4D

Default drainage long section ascii ppf file.

Melbourne Water parameter file SEWER_PPF_4D

Default Melbourne Water long section ascii ppf file.

Plotting C tab

Enable Windows printers WINDOWS_PRINTERS_4D

If set, use Windows printers.

Windows 2000/XP print dialog WINDOWS_PRINT_MODE_4D = 1

Use exclusive access to printer WINDOWS_PRINT_MODE_4D = 2

Use intermediate print file WINDOWS_PRINT_MODE_4D = 4

Raster resolutions dots/inch DEFAULT_RASTER_DPI_4D

dots per inch to use for plotting rasters

Maximum time for Pdf995 (seconds) PDF995_TIME_LIMIT_4D

Extra A tab

Acad pat AUTOCAD_PATTERNS_4D

If non blank, the full path name of the AutoCAD patterns file.

Colours.4d COLOURS_4D

If non blank, the full path name of the file to use as the 12d Model colour file.

Defaults.4d DEFAULTS_4D

If non blank, the full path name of the file to use as the 12d Model defaults file.

Digitizers.4d DIGITIZERS_4D

If non blank, the full path name of the file to use as the 12d Model digitizers file.

Drainage.4d DRAINAGE_4D

If non blank, the full path name of the file to use as the 12d Model drainage file.
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Patterns.4d PATTERNS_4D

If non blank, the full path name of the file to use as the 12d Model patterns file.

Symbols.4d SYMBOLS_4D

If non blank, the full path name of the file to use as the 12d Model symbols file.

Macros.4d RUN_MACROS_FILE_4D

If non blank, the full path name of the file of macros that is run when 12d Model creates a new 
project.

Project_macros.4d RUN_PROJECT_MACROS_FILE_4D

If non blank, the full path name of the file of macros that is run when 12d Model opens an 
existing project.

Help folder HELP_4D

If non blank, the full path name of the folder containing the 12d Model help files.

Usage log folder USAGE_LOG_4D

Usage logs folder USAGE_LOGS_4D

Extra B tab

DIAMETER_LARGE_CHARACTER_4D

The integer (base 10) value of the character to use as the large diameter symbol.

CUBED_CHARACTER_4D

The integer (base 10) value of the character to use as the cubed symbol.

DIAMETER_SMALL_CHARACTER_4D

The integer (base 10) value of the character to use as the small diameter symbol.

MIDDLE_DOT_CHARACTER_4D

The integer (base 10) value of the character to use as the middle dot symbol.

SQUARED_CHARACTER_4D

The integer (base 10) value of the character to use as the squared symbol.

Extra C tab

Fast accept FAST_ACCEPT_4D

If set, the Fast Accept snap (A snap) is turned on by default.

Fast Construction snap FAST_CONSTRUCTION_SNAP_4D

If set, the Fast Construction Snap (K snap) is turned on by default.

Construction snaps model CONSTRUCTION_SNAP_MODEL_4D

If non blank, the model to use for constructions.

Plan height max HEIGHT_MAX_DEFAULT_4D

If non blank, the maximum height in pixels for a plan view.

Show help buttons HELP_BUTTONS_4D

If set, Help buttons are added to panels.

Windows printer resolution dots/mm HIMETRIC_4D 0 or 1

Use lists for popups LIST_POPUPS_4D

If set, the popup lists are scrolling lists.
If not set, the popups turn into walk-right menus when too long.
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Macro input mode MACRO_INPUT_MODE_4D

Never snap to self NEVER_SNAP_ITSELF_4D

Default pan mode PAN_MODE_4D

Short project names PROJECT_NAMES_4D

Super strings ? SUPER_STRINGS_4D

System names SYSTEM_NAMES_4D Old, New, New then Old

Warp cursor hide WARP_CURSOR_HIDE_4D

Show old grading edit options DRAINAGE_EDIT_GRADE_4D

Show full hydraulic report details FULL_HYDRAULIC_REPORT_4D

Multi-line text edits MULT_LINE_TEXT_4D

MTF extra start/end EXTRA_START_END_4D

Speed tables SPEED_TABLES_4D

Always user Super Strings advanced model SUPER_ADVANCED_MODE_4D

OpenGL tab

Use offset OPENGL_OFFSET_4D

Cache texture rasters OPENGL_CACHE_4D

User mipmaps OPENGL_MIPMAP_4D

Variable tab

Name Value

The variable tab consists of a table for specifying environment variable names (Name) and 
setting their values (Value).

This is mainly used for setting environment variables that are not already in the Edit 
Environment Variables panel.
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Projections
project_projections

Position of menu: Project =>Management =>Projections

User defined Projections can be defined using the Create/edit option. A user defined projection 
can then be set for the project (the project projection). Values from the project projection (e.g. 
scale factor) are used in various options. 

The Project projections walk-right menu contains various projection items.

For the option Set, go to the section “Set Projection” .
Create/edit  “Create/Edit Projection” .
 Delete   “Delete Projection” .
 Reset   “Reset Projection” .

The options in the menu will now be described.

Set Projection

set_projection

Position of option on menu: Project =>Management =>Projections =>Set

The Set option sets the Project projection.

On selecting the Set option, the Set Projection panel is displayed.

set the default projection for the project
create/edit project definitions
delete a project definition
reset the projection set for the project
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Datum name input all defined projections

name of the projection to be set as the Project projection.

Depending on the projection type, the relevant projection parameters are displayed.

Set button

after selecting this button, the current projection is set using the displayed values. These 
values are used for subsequent calculations in the project

Create/Edit Projection

create_edit_projection

Position of option on menu: Project =>Management =>Projections =>Create/Edit

On selecting the Create/edit option, the Create/edit Projection panel is displayed.

For more information about terminology used in this sections, see the Appendix “Geodetics 
Summary” .

Field Description Type Defaults Pop-Up

Datum name input all defined projections

name of the projection to be set as the Project projection.

Projection Type input Transverse Mercator, UTM

 RSO, General

the type of projection to be set as the Project projection.

For more information on defining a "general" projection, please go to “Defining a General 
Cartographic Projection” 

Depending on the projection type, the relevant projection parameters can be entered.
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Use known ellipsoid tick box tick

if tick, the ellipsoid for the projection has been defined previously and the parameters for the 
particular ellipsoid can be used. The values of defined ellipsoids are displayed when a 
selection is made from the ellipsoid pop-up box (e.g. GRS80).

if no tick then the ellipsoid parameters can be defined by entering the ellipsoid parameters.

Add/Modify button

after selecting this button, the user defined projection is added to the current list or the existing projection 
definition is modified. using the entered values. A number of new projections can be added by simply 
entering the relevant data and selecting the add/modify button.

Write button

after selecting this button, the user defined projections defined by the add/modify process can be written in 
various locations. This means that the defined projections will be allowed to be set in current and future 
projects. For more information on the Write button, go to the section “Writing Set Up Files”  in the 
Appendix “Set Ups” 

Defining a General Cartographic Projection

A general cartographic projection is defined by giving a series of parameters starting with the 
mandatory +proj parameter giving the projection type. For example,

+proj=projection_type e.g. +proj=tmerc or +proj=utm

To specify the Earths’s elliptical figure used in the projection, two parameters are required.

The first required value is the major semi-axis of the ellipse or equatorial radius, 

major semi-axis of the ellipse +a= value

and the second parameter can be any one of the following standard forms:

minor semi-axis of the ellipse +b= value
flattening +f= value
reciprocal flattening (i.e. 1/f) +rf= value
eccentricity) +e= value
eccentricity squared) +es= value

For example, the Australian National Spheroid (ANS) is defined by:

+a=6378160
+rf= 298.25

GRS80 is defined by:

+a=6378137
+rf= 298.257222101

WGS84 is defined by:

+a=6378137
+rf= 298.257223663

A further three parameters are common to most projections:
the central meridian +lon_0=value, and the cartesian offsets for the respective x and y axis, 
+x_0=value, +y_0=value (often referred to as false easting and northing).

central meridian +lon_0= value units in decimal 
degrees

x offset- false easting +x_0=value
y offset - false northing +y_0=value

A fourth parameter, +lat_0=value, is used to designate a central parallel and associated y axis 
origin for a projection.
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Unless a value is specified for the parameters lon_0, lat_0, x_0 and y_0, they are assumed to be 
zero.

Other parameters will depend on the particular projection used.

Transverse Mercator Projection +proj=tmerc

project +proj=tmerc
scale factor +k=value

e.g. Metro-Perth is:
+proj=tmerc +a=6378160 +rf=298.25 +lon_0=115.833333333 +lat_0=0.0 +x_0=54466.561
+y_0=3690893.265 +k=1.0

Perth Coastal Grid 1984 (PCG84) is:
+proj=tmerc +a=6378160 +rf=298.25 +lon_0=115.833333333 +x_0=40000 +y_0=3800000

+k=1.000006

Universal Transverse Mercator Projection +proj=utm

This is a special from of the Transverse Mercator Projection. The central meridian is constrained 
to 6 degree intervals starting at 3 degrees. An extra parameter exists called +zone where 
+zone=1 specifies the region from 180 degree W to 174 degrees W (equivalent to +lon_0=177 
degrees W) and proceeds easterly until +zone=60 for the region from 174 degree E to 180 
degrees E (i.e. +lon_0=177 degrees E). Hence

+zone=N N = 1, 2,... 60

which automatically defines the central meridian +lon_0= 6 x N - 183     where N = zone number.

The +south option adds a false northing of 10,000,000 m (used for AMG and MGA co-ordinates) 
for projection in the Southern Hemisphere. 

+south defines +y_0=10000000

In all cases, for a Universal Transverse Mercator projection, a false easting of 500,000 m is used.

+x_0=500000

Australian Map Grid (AMG84)

The Australian Map Grid is a Universal Transverse Mercator Projection with

(a) coordinates are in metres

(b) zones are 6 degrees wide plus overlapping belts of 80 kilometres at each grid junction

(c) AMG zones are numbered from zone 49 with central meridian 111 degrees E to zone 57 with central 
meridian 159 degrees E.

(d) the origin of each zone is the intersection of the central meridian with the equator

(e) a central scale factor, k, is defined as 0.9996

(f) a false easting of 500,000 and a false northing of 10,000,000 are used

(g) uses the Australian National Spheroid +a=6378160  +rf=298.25

For example, the definition of AMG zone 50 is:

+proj=utm +south +zone=50 +k=0.9996 + a=6378160 +rf=298.25

Map Grid of Australia (MGA94)

The Map Grid of Australia is a Universal Transverse Mercator Projection with

(a) coordinates are in metres

(b) zones are 6 degrees wide plus overlapping belts of 80 kilometres at each grid junction
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(c) MGA zones are numbered from zone 49 with central meridian 111 degrees E to zone 57 with central 
meridian 159 degrees E.

(d) the origin of each zone is the intersection of the central meridian with the equator

(e) a central scale factor, k, is defined as 0.9996

(f) a false easting of 500,000 and a false northing of 10,000,000 are used.

(g) uses GRS80 +a=6378137 +rf=298.257222101

For example, the definition of MGA zone 50 is:

+proj=utm +south +zone=50 +k=0.9996 + a=6378137 +rf=298.257222101

Lambert Conformal Conic Projection +proj=lcc

This is a special from of the Conic Projection.

There are two standard parallels +lat_1 and +lat_2 and the projection is centred on +lat_0 and 
+lon_0

For example, a Lambert Conformal Conic Conformal with standard parallels of 15 degrees South 
and 39 degrees South, centred at centred at 27degrees South 134degrees East, with a false 
origin at that point is 5,000,000m/5,000,000m and using the Australian National Spheroid (i.e. 
AGD84) is

+proj=lcc +lat_1=-15 +lat_2=-39 +lon_0=134 +lat_0=-27
+x_0=5000000 +y_0=5000000 +a=6378160 +rf=298.25 

Delete Projection

delete_projection

Position of option on menu: Project =>Management =>Projections =>Delete

The Delete option deleted a projection from the list of available projections.

On selecting the Delete Projection option, the Delete Projection panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Datum name input all defined projections

name of the projection to be deleted from the Project projection list.

Depending on the projection type, the relevant projection parameters are displayed.

Delete button

after selecting this button, the selected projection is deleted from the project projection list. 
This can be done for a number of projections by simply selecting the projection to be deleted 
and selecting the delete button.

Write button

after selecting this button, the list of projections altered by the delete process can be written in various 
locations. This means that the updated projections list will be used to set current and future projects. For 
more information on the Write button, go to the section “Writing Set Up Files”  in the Appendix “Set Ups” 

Reset Projection

project_projection_reset

Position of option on menu: Project =>Management =>Projections =>Reset

The Reset option is used to remove the projection set for the project.

On selecting the reset Projection option, the Project Projection Reset panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults pop-Up

Current projection output only

name of the projection currently set for the project.

Reset button

after selecting this button, the projection for the project is set to none. That is, no project has 
been set for the Project
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N values
project_n_value_settings

Position of menu: Project =>Management =>N values

N values are the separation distances between the geoid and the ellipsoid. In GPS surveys, 
heights are often given in ellipsoid heights whilst most other level datums are based on the geoid. 
Since most geodetic calculations are based on the ellipsoid, any observations should be reduced 
onto the ellipsoid. This reduction process takes into the consideration the heights above the 
ellipsoid. Therefore, it is necessary to convert non ellipsoid heights to ellipsoid values by adding 
the geoid-ellipsoid separations (n values). There are various methods for determining the N 
values.

An N value method can be defined using the Create/edit option. A user defined N value method 
can then be set for the project (the project N value setting). Values from the project N value 
settings are used to determine which method is used to calculate N values. These values are 
used in various options where the level values are not ellipsoid values and require the N value to 
be added to get to an ellipsoid height. 

For more information about terminology used in this section, see the Appendix “Geodetics 
Summary” .
The Project n value walk-right menu contains various projection items.

For the option Set, go to the section “Set N-Values” .
Create/edit  “Create/Edit N-Values” .
 Delete   “Delete N-Values” .
 Reset   “Reset N-Values” .

The options in the menu will now be described.

Set N-Values

set_n_value_settings

Position of option on menu: Project =>Management =>N values =>Set

The Set option sets the Project projection.

On selecting the Set option, the Set N value settings panel is displayed.

set the default N-values for the project
create/edit N-values definitions
delete a N-values definition
reset the N-values set for the project
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

N value setting name choice box all defined N value settings

name of the n value setting to be set as the Project N value setting.

N value setting type input defined N value types

Depending on the N value interpolation method, the relevant method is displayed.

Set button

after selecting this button, the current N value setting is set using the displayed values. These 
values are used for subsequent calculations in the project

Create/Edit N-Values

create_edit_n_value_settings

Position of option on menu: Project =>Management =>N values=>Create/Edit

On selecting the Create/edit option, the Create/edit N value settings panel is displayed.
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Field Description Type Defaults Pop-Up

N value setting name choice box all defined N value settings

name of the n value setting to be set as the Project N value setting.

N value setting type choice box defined N value types

There are various methods for the determination of the N values. These are given in the 
choice box:

Depending on the setting type chosen, the panel will display the appropriate fields.

No N values required: This applies to data that already has ellipsoid heights and requires no 
interpolation for N values.

For N value setting type = Constant N value 

Field Description Type Defaults Pop-Up

Constant N value input box

this N value will be used for the entire n value interpolation process. (i.e. it will not change).

For N value setting type = Winter 

This method uses the same method as the Winter interpolation software supplied by Auslig. The 
data files used should be winter compatible and reside in a directory that is pointed to by the 
WINTER_DATA_4D parameter in the env.4d file. The data files can be downloaded from the 
Auslig website.
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Field Description Type Defaults Pop-Up

Select Ausgeoid file map scale choice box 1:100,000

1:250,000

1:1,000,000

this value will be dependant on the type of files to be used by winter. The files 
themselves should be in a directory that is pointed to by the WINTER_DATA_4D 
parameter in the setup area of the env.4d file.

Use bicubic interpolation if possibletick boxticked

if ticked, the bicubic interpolation method will be used if possible. 

For N value setting type = NGS 

This method is currently under development.

For N value setting type = Plane 

This method allows a plane to be defined allowing N values to be derived from that plane.

Field Description Type Defaults Pop-Up

Origin easting input box

the origin easting value.

Origin northing input box

the origin easting value.

Corr constant input box

the constant z value of the plane.

Corr per unit easting input box

the z value correction per unit easting.

Corr per unit northing input box

the z value correction per unit nothing.

For N value setting type = Difference tin 
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This method allows value to be interpolated from a difference tin. A difference tin is simply a tin of 
difference values (N values). This tin can be re-triangulated as new points become available, 
thus introducing more points than a regular grid.

Field Description Type Defaults Pop-Up

Difference tin tin box Available tins

the difference tin from which the N values will be interpolated.

Add/Modify button

after selecting this button, the user defined N value settings are added to the current list or the existing N 
value settings is modified. using the entered values. A number of new settings can be added by simply 
entering the relevant data and selecting the add/modify button.

Write button

after selecting this button, the user defined N value settings defined by the add/modify process can be 
written in various locations. This means that the defined N value settings will be allowed to be set in 
current and future projects. For more information on the Write button, go to the section “Writing Set Up 
Files”  in the Appendix “Set Ups” 

Delete N-Values

Delete_N_value_setting

Position of option on menu: Project =>Management =>N value =>Delete

The Delete option deleted a projection from the list of available projections.

On selecting the Delete option, the Delete N value setting panel is displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

N value setting name input all defined N value settings

name of the setting to be deleted from the N value setting list.
Depending on the setting type, the relevant setting parameters are displayed.

Delete button

after selecting this button, the selected N value setting is deleted from the setting list. This can 
be done for a number of n value settings by simply selecting the projection to be deleted and 
selecting the delete button.

Write button

after selecting this button, the list of n value settings altered by the delete process can be 
written in various locations. This means that the updated n value settings list will be used to 
set current and future projects. For more information on the Write button, go to the section “Writing 
Set Up Files”  in the Appendix “Set Ups” 

Reset N-Values

Project_N_value_setting_Reset

Position of option on menu: Project =>Management =>N values =>Reset

The.Reset option is used to remove the projection set for the project.

On selecting the reset option, the Project N value setting reset panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Current N value setting output only

name of the n value setting, set for the project.

Reset button

after selecting this button, the N value setting for the project is set to none. That is, no N value 
setting has been set for the Project
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7 Parameters
project_7_parameter_settings

Position of menu: Project =>Management =>7 parameters

Seven (7) parameter transformations are used to transform data between two ellipsoids. They 
are also known as 7 parameter similarity transforms, Bursa-Wolf, 7 parameter Helmert 
transformations.

Warning: the definition and hence sign of some terms varies between countries.

In 12d Model, the seven parameter similarity transformations are used in the General 
Transformation option Survey =>Conversions =>General transformations (see “General 
Transformations” in the chapter “Survey” ) and the transformation is applied in the Global XYZ 
system.

The 7 parameters walk-right menu contains options to create and delete seven parameter 
transformation setting.

For the option Create/edit, go to the section “Create/Edit 7 Parameters” 
 Delete   “Delete 7 Parameters” 

The options in the menu will now be described.

Create/Edit 7 Parameters

add_modify_seven_parameter_details

Position of option on menu: Project =>Management =>7 parameters=>Create/Edit

On selecting the Create/edit option, the Add/Modify Seven Parameter Details panel is displayed.

create/edit 7 parameter definitions
delete 7 parameter definitions
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Field Description Type Defaults Pop-Up

Conversion name choice box all defined 7 param settings

name of the 7 parameter setting to be created/edited.

DX, DY, DZ input box

the translations for the 7 parameter transformation.

rX (arc seconds), rY (arc seconds, rZ (arc secondsinput box

the rotations, in arc seconds, for the 7 parameter transformation.

Scale input box

the scale for the 7 parameter transformation.

Use Position Vector Transformation sign convention (European) tick box

if tick, the European Position Vector Transformation convention is used.
If not tick, PVT sign is not used (mainly not used for USA).

Depending on the sign convention, some of the parameters will have the opposite sign.

Add/Modify button

after selecting this button, either the new 7 parameter set is created or an exiting one 
modified. To save the setting list, use the Write button.

Write button

after selecting this button, the user defined 7 parameter settings are written out to the file 
"7params.4d" in the user selected folder. This means that the 7 parameter settings will be 
available in the current and future projects. For more information on the Write button, go to the 
section “Writing Set Up Files”  in the Appendix “Set Ups” 

Delete 7 Parameters

Delete_seven_parameter_details

Position of option on menu: Project =>Management =>7 parameters =>Delete

The Delete option deleted a seven parameter set from the list of available seven parameter 
settings.

On selecting the Delete option, the Delete 7 Parameter Details panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Conversion name input all defined 7 param settings

name of the 7 parameters setting to be deleted from the 7 parameter settings list.
The relevant setting parameters are displayed.

Delete button

after selecting this button, the selected 7 parameter setting is deleted from the setting list. 
This can be done for a number of 7 parameter sets by simply selecting the name to be 
deleted and selecting the delete button. To save the modified setting list, use the Write button

Write button

after selecting this button, the user defined 7 parameter settings are written out to the file 
"7params.4d" in the user selected folder. This means that the 7 parameter settings will be 
available in the current and future projects. For more information on the Write button, go to the 
section “Writing Set Up Files”  in the Appendix “Set Ups” 
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Workspace
project_workspace

Position of menu: Project =>Management =>Workspace

Options to set up the project

The Project Workspace walk-right menu contains various projection items.

For the option Setup, go to the section “Workspace Setup” 
Load “Workspace Load” 

Workspace Setup

workspace_setup

Position of option on menu: Project =>Management =>Workspace =>Setup

The workspace file is used to define the position of toolbars and output window for a new 
projects.

Once inside an existing project, the workspace file is no longer used and the final positions of the 
toolbars and output window are recorded inside the project so they come up in the same final 
position as when the project is reopened.

The Workspace Setup option allows the user to define new workspace setup files that can be 
loaded at any time in an existing project or used as the default workspace file used for all new 
projects.

On selecting the Setup option, the Workspace Setup panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Write button

write out the current toolbar configuration to a .4dw file.

Load button

read in the workspace.4dw file in the current project folder.

create/edit workspace files
list and load workspace files
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Clear button

remove all the current toolbars and read in the default workspace.4dw file

Workspace file file box current workspace file *.4dw files

name of the workspace file to re imported/exported

Import button

read in and use the workspace file given in the Workspace file field.

Export button

write the current toolbar settings out to the workspace file given in the Workspace file field.

Workspace Load

project_workspace_load

Position of menu: Project =>Management =>Workspace >Load

This option displays and selects a project workspace file to set up the icons etc. on the screen.

The Project Workspace Load walk-right menu contains further walk-rights to display the workspace 
files in the local project, the set ups folder and the user folder.

To load a workspace file, simply click on the name in the walk-right lists.

list and load workspace files in the project
list and load workspace files in the set ups folder
list and load workspace files in the user folder



Chapter 6  Projects

February 2007 Page 371Management

Tree
Position of option on menu: Project =>Tree

Position of option on menu: Project =>Management =>Tree

For documented on this option, go to the section “Tree” 

Share Settings
project_share_settings
Position of option on menu: Project =>Management =>Share settings

There are three environment variables that control the auto-synchronizing of any shared models 
or tins added to this project.

SHARE_CHECK_INTERVAL_4D number_of_seconds
AUTO_MODEL_SYNC_4D 1 or 0
AUTO_TIN_SYNC_4D 1 or 0

This option will temporarily modified the values for this session. When the project is restarted, 
the values will revert to those given by the environment variables.

Selecting Share settings, brings up the Project Share Settings panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Interval to check for updates input

time in seconds to check if any of the shared models or tins added to the project have been 
updated in the server projects. 

The environment variable controlling this when the project starts up is

SHARE_CHECK_INTERVAL_4D number_of_seconds

The value is only modified for this session. To permanently change the value, please modify   
the environment variable.

Autosync tins tick box

if tick, the server projects for any shared tins added to this project are checked to see if they 
have been modified (checked every SHARE_CHECK_INTERVAL seconds). If any tins have 
been modified, they are re-copied to this project.

The environment variable controlling this when the project starts up is

AUTO_TIN_SYNC_4D 1 or 0

The value is only modified for this session. To permanently change the value, please modify   
the environment variable.
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Autosync models tick box

if tick, the server projects for any shared models added to this project are checked to see if 
they have been modified (checked every SHARE_CHECK_INTERVAL seconds). If any 
models have been modified, they are re-copied to this project.

The environment variable controlling this when the project starts up is

AUTO_MODEL_SYNC_4D 1 or 0

The value is only modified for this session. To permanently change the value, please modify   
the environment variable.

Set

set the values in the panel for this session. The values will revert back to the ones given by 
the environment variables when the project is restarted. 

The values are only modified for this session and will evert back to the ones given by the 
environment variables when the project is restarted. To permanently change the value, please 
modify the environment variable.
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 Restart
Position of option on menu: Project =>Restart

The Restart option exits the current 12d Model project and then restart using the same project. 
Useful for testing changes to set up files etc.

It will prompt if project Save is required.

Save
save_project

Position of option on menu: Project =>Save

The Save option saves the working project to disk.

On the Save from the Main menu, simply select the option and the project is saved.

On selecting Save from the floating Projects menu, the save project panel is displayed.

The position of the save project panel is also saved and the panel automatically placed on the 
screen when the project is started up again.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Save button

after selecting this button, the working project is saved to disk.
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Tree
project_tree

Position of option on menu: Project =>Tree

Position of option on menu: Project =>Management =>Tree

The Tree option is under continual development and being extended with each version of 
12d Model.

Tree is used to drill down through information about the data in the project (for example models, 
tins and views) and also to interactive create/edit/edit most of the set-up information that is 
contained in text files. These include:

(a) Name mapping (file names.4d) documented in the section “Name Mappings” 

(b) Plotters set-ups (file plotters.4d) which in not yet documented. See the section “Plotters” .

(c) Survey data collectors (file survey.4d) documented in the section “Survey Data Collectors” 

(d) Linestyles (file linestyl.4d) documented in the section “Linestyles” 

(e) Symbols (file symbols.4d) documented in the section “Symbols” 

(f) Patterns (file patterns.4d) which in still under development and not yet documented. See the section 
“Patterns” 

(g) Textstyles (file textstyl.4d) documented in the section “Textstyles” 

(h) Textstyle data favourites (file textstyle_names.4d) documented in “Textstyle Data Favourites” 

(i) Sheet sized (file sheets.4d) documented in the section “Sheet Sizes” 

On selecting the Tree option, the Project Tree panel is displayed.

Note: This is a resizable panel.

Clicking on the ’+’ expands the browse tree to show what items are available to get more 

click on + to expand the browse tree
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information on.

Again clicking on the + for any of the items in the expanded list then further expands the browse 
tree to show more items available to get information on.

For the items Name mappings, Plotters, Survey data collectors, Textstyles and Textstyle data 
favourites, once they are expanded then the items displayed need no further expansion (there is 
no + displayed in front of the items) and double clicking on the expanded items brings up the 
create/edit panels for the item.

For example, clicking on + for Survey data collectors and then double clicking on a data collector 
brings up the Survey.4d Create/Edit panel.
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For the option Name mappings, go to the section “Name Mappings” 
 Plotters   “Plotters” 
Survey data collectors  “Survey Data Collectors” 
 Linestyles   “Linestyles” 
 Symbols   “Symbols” 
 Patterns   “Patterns” 
 Textstyles   “Textstyles” 
 Textstyle data favourites  “Textstyle Data Favourites” 
 Sheet sizes   “Sheet Sizes” 
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Name Mappings
names_4d_create_edit

Position of option on menu: Project =>Tree

The name mapping file is used in all panel fields requiring the name of a string and the name field 
in the CAD Controlbar. 

After the string name is typed, if the <Enter> is pressed then each section of the name mapping 
file being used for the project is searched for matches with the key. 

If there is a match of the string name with a key, then the name, model, colour point/line type etc. 
for that key will be used in the appropriate panel fields, or toolbar fields, that go with the string 
name.

Click on Name mapping to expand the items and then double click LB on Create name mapping 
to create/edit the name mapping file names.4d.

Double clicking LB on any of the items below Create name mapping will also create/edit the 
names.4d file.

In either case, the Names.4d Create/Edit panel will then appear.

Buttons

Set button

sets the definition for this editing session of the project - the information will be lost when the 
project is exited.

Write button

write the information to the file names.4d. The file can then be used when projects are started. 
The information won’t be used for the current session unless the Set button is selected as 
well. For more information on the Write button, go to the section “Writing Set Up Files”  in the 
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Appendix “Set Ups” 

Basic Tab

Key input

the string name is searched against the list of keys for the Basic tab until a first match is 
found. If a match is found, then any non-blank data in the grid is used to fill out the appropriate 
panel fields or toolbar fields.The key can include wild cards (*) or wild characters  (?)

Name input

if not blank, name used to replace the string name by. This is usually blank.

Model model grid available models

if not blank, model to use

Colour colour grid available colours

if not blank, colour to use

Point Line point/line grid point/line

if not blank, point-line type to use

Weight input

if not blank, weight to use for strings with linestyle 1

Comment input

user comment

Symbols Tab
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Key input

the string name is searched against the list of keys for the Symbols tab until a first match is 
found. If a match is found, then any non-blank data in the grid is used to fill out the appropriate 
panel fields or toolbar fields.The key can include wild cards (*) or wild characters

Tinable Tab
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Key input

the string name is searched against the list of keys for the Tinable tab until a first match is 
found. If a match is found, then any non-blank data in the grid is used to fill out the appropriate 
panel fields or toolbar fields.The key can include wild cards (*) or wild characters

Tinable tinability grid

if no, the entire string is non tinable. That is, the vertices are not included in any triangulation.

If yes, the entire string is tinable. That is, the vertices are used in any triangulation and the 
segments between the vertices are used as breaklines.

If points, the vertices of a string are tinable but the segments are not. That is, the vertices are 
used in any triangulation but the segments between the vertices are used as breaklines.

Text Data Tab
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Key input

the string name is searched against the list of keys for the Text Data tab until a first match is 
found. If a match is found, then any non-blank data in the grid is used to fill out the appropriate 
panel fields or toolbar fields.The key can include wild cards (*) or wild characters
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Plotters
User defined plotters can be set up in 12d Model and the information is stored in the file 
plotters.4d which is fully documented in the section “User Defined Plotters” of the Appendix 
“Plotters and Plotting” .

The interactive editor Plotters on the Browse option is not yet fully implemented or documented.
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Survey Data Collectors
survey_4d_create_edit

Position of option on menu: Project =>Tree

Click on Survey data collectors to expand the item and then double click LB on Create data 
collector to create a new data collector, or double click LB on an existing data collector in the list 
to edit an existing data collector definition.

The Survey.4d Create/Edit panel will then appear.

This option is fully documented in the “Data Collector Definitions”  section of the Appendix “12D 
Survey Guide” .



12d Model Reference Manual

Page 384 February 2007Tree

Linestyles
linestyle_create_edit_delete

Position of option on menu: Project =>Tree

Click on Linestyles to expand the item and then double click LB on Create linestyle to create, edit 
or delete linestyles, or double click LB on an existing textstyle in the list to edit an existing 
linestyle definition. The Linestyle Create/Edit/Delete panel will then appear.

The linestyle can be created interactively in 12d Model by drawing the new linestyle using strings 
containing lines, arcs, circles and text. This information can then be used to create the linestyle.

To edit a linestyle, the current definition is written to a model which can then be edited to create 
the modified linestyle.

The definition of a linestyle includes:

(a) a unique name

(b) the Group to show the linestyle under in the linestyle pop-up

(c) the linestyle type

All the information for linestyles is stored in the text file linestyl.4d but the Linestyle Create/Edit/Delete 
panel is normally used to create and modify the file rather than using a text editor. (the file 
linestyl.4d is fully documented in the “Line Styles” section of the Appendix “Line styles, Symbols 
and Textstyles” ).

The Linestyle Create/Edit/Delete panel is:
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Option choice box Create Create, Edit, Delete

type of edit

Linestyle name input available linestyles

name of the linestyle to be created, edited or deleted.

Group input available groups

name of the group for the linestyle - can be a new group name.

Linestyle type choice box world user, pixel, world, paper,
 2 point, group

type of the linestyle.

For Option choice "Create" - Data input

Data input source box model

data to be used to create the linestyle.

For Option choice "Edit" - Edit line work

Model for linestyle model box available models

model to write the linestyle out to so that it ca be edited.

Write out linestyle button

when selected, the linestyle is written out to the Model for linestyle.

For Option choice "Delete"
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Linestyle to delete linestyle box available linestyles

name of the linestyle to delete.

Linestyle to replace it with linestyle box 1 available linestyles

when the linestyle is deleted, any string with that linestyle has to have a new linestyle. This is 
the linestyle that is set for strings with the deleted linestyle

For the Linestyle type - User, Pixel, World, Paper

No imbedded colours in linestyle tick box tick

if tick then no colours from the data are used in the linestyle.
If not tick then any colours used in the data are used in the linestyle

Origin x/y double box

if non blank, the x/y value for the origin of the linestyle.
If blank, a value is calculated by 12d.

Factor double box

if non blank, the linestyle is factored up by this value.
If blank, the factor is taken to be 1.

Length double box

if non blank, the linestyle is repeated after this length.
If blank, the linestyle length is calculated by 12d.

Mode choice box use string pt/line type
only at vertices, repeat style

if "use string pt/line type", then if the string pt/line type is "line" then the linestyle is repeated 
after the Length value. If the string pt/line type is  "point", then the linestyle is only drawn at 
each vertex of the string.
If "only at vertices", then the linestyle is only drawn at each string vertex regardless of the 
strings pt/line type.
If "repeat style", then the linestyle is repeated after the Length value regardless of the strings 
pt/line type.

For the Linestyle type - 2 point

No imbedded colours in linestyle tick box tick

if tick then no colours from the data are used in the linestyle.
If not tick then any colours used in the data are used in the linestyle

Origin x/y double box

if non blank, the x/y value for the first origin of the linestyle.
If blank, a value is calculated by 12d.

Origin 2 x/y double box

if non blank, the x/y value for the second origin of the linestyle.
If blank, a value is calculated by 12d.

Stretch in choice box one direction one direction, both directions 

if "one direction", the linestyle is only stretched along the axis joining the two original points. 
The linestyle is not stretched perpendicular to that axis.
If "both directions", the linestyle is stretched in all directions.

Drawn on choice box every line/arcevery line/arc,
every second line/arc

if "one direction", the linestyle is only stretched along the axis joining the two original points. 
The linestyle is not stretched perpendicular to that axis.
If "both directions", the linestyle is stretched in all directions.
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For Linestyle type - Group

Linestyle grid

list of linestyles that make up the this one linestyle.

Buttons

Process button

process the data in the panel fields. The internal definitions of the linestyles is modified. The 
definitions are not written to the linestyle file.

Write button

write the modifications to the file linestyl.4d file. This files can then be used when projects are 
opened up. The information won’t be used for the current session unless the Process button is 
selected as well. For more information on the Write button, go to the section “Writing Set Up Files”  
in the Appendix “Set Ups” 

This option updates the files linestyles.4d which is fully documented in the “Line Styles” section 
of the Appendix “Line styles, Symbols and Textstyles” .
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Symbols
symbol_create_edit_delete

Position of option on menu: Project =>Tree

Click on Symbols to expand the item and then double click LB on Create symbol to create, edit or 
delete symbols, or double click LB on an existing symbol in the list to edit an existing symbol 
definition. The Symbol Create/Edit/Delete panel will then appear.

The symbol can be created interactively in 12d Model by drawing the new symbol using strings 
containing lines, arcs, circles and text. This information can then be used to create the symbol.

To edit a symbol, the current definition is written to a model which can then be edited to create 
the modified symbol.

The definition of a symbol includes:

(a) a unique name

(b) the Group to show the symbol under in the symbol pop-up

(c) the symbol type

All the information for linestyles is stored in the text file symbols.4d but the Symbol Create/Edit/Delete 
panel is normally used to create and modify the file rather than using a text editor. (the file 
symbols.4d is fully documented in the “Line Styles” section of the Appendix “Line styles, Symbols 
and Textstyles” ).

The Symbol Create/Edit/Delete panel is:
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Option choice box Create Create, Edit, Delete

type of edit

Symbol name input available symbols

name of the linestyle to be created, edited or deleted.

Group input available groups

name of the group for the symbol - can be a new group name.

Symbol type choice box world pixel, world, paper
type of the symbol.

For Option choice "Create" - Data input

Data input source box model

data to be used to create the symbol.

For Option choice "Edit" - Edit line work

Model for symbol model box available models

model to write the symbol out to so that it ca be edited.

Write out symbol button

when selected, the symbol is written out to the Model for symbol.

For Option choice "Delete"



12d Model Reference Manual

Page 390 February 2007Tree

Symbol to delete symbol box available symbols

name of the linestyle to delete.

Symbol to replace it with symbol box 1 available symbols

when the symbol is deleted, any vertex of a string with that symbol has to have a new symbol. 
This is the symbol that is set for strings with the deleted symbol

No imbedded colours in symbol tick box tick

if tick then no colours from the data are used in the symbol.
If not tick then any colours used in the data are used in the symbol

Origin x/y double box

if non blank, the x/y value for the origin of the symbol.
If blank, a value is calculated by 12d.

Factor double box

if non blank, the symbol is factored up by this value.
If blank, the factor is taken to be 1.

Length double box

if non blank, the symbol is repeated after this length.
If blank, the symbol length is calculated by 12d.

Process button

process the data in the panel fields. The internal definitions of the symbols is modified. The 
definitions are not written to the symbol file.

Write button

write the modifications to the file symbols.4d file. This files can then be used when projects 
are opened up. The information won’t be used for the current session unless the Process 
button is selected as well. For more information on the Write button, go to the section “Writing Set 
Up Files”  in the Appendix “Set Ups” 

This option updates the files symbols.4d which is fully documented in the “Symbols” section of 
the Appendix “Line styles, Symbols and Textstyles” .
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Patterns
pattern_create_edit_delete

Still under development

Position of option on menu: Project =>Tree
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Textstyles
create_edit_textstyle

Position of option on menu: Project =>Tree

Click on Textstyles to expand the item and then double click LB on Create textstyle to create a 
new textstyle, or double click LB on an existing textstyle in the list to edit an existing textstyle 
definition. The Create/Edit Textstyle panel will then appear.

The textstyle definition includes 

(a) a unique name

(a) the font used for textstyle - this may be a true type font

(b) mappings of textstyle names when reading in data from AutoCAD and Microstation

(c) mappings of textstyle names when writing data out to AutoCAD, Microstation and 12d Model Mod-
els.

All the information for textstyles and fonts is stored in text files (textstyl.4d and fonts.4d) but the Create/
Edit Textstyle panel is normally used to create and modify the files rather than using a text editor. 
(the files textsyles.4d and fonts.4d which are fully documented in the “Textstyles and Fonts” 
section of the Appendix “Line styles, Symbols and Textstyles” ).

The Create/Edit Textstyle panel is:

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Texstyle name input available textstyles

name of the textstyle to be defined or edited.

Font section
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Font name output recent projects

name of the font to be used for the textstlye.

True type font tick box tick

if tick then the font is a true type font. The next box asks for the True Type Font name.
If not tick then the font needs an SHP file to define the characters. The next box asks for the 
SHP name.

TTF name input available true type fonts

name of the true type font.

SHP name input available SHP files

name of the SHP file to define the characters.

Fixed section

Input/Output section

Model tab

Hardware text tick box tick

if tick then any 12d Model text is written out to a model as text strings.
If not tick then each characters of a text string is turned into individual lines and arcs (i.e. 
each character is stroked).

DXF tab

Hardware text tick box tick

if tick then any 12d Model text is written out to the DXF file as text.
If not tick then each characters of a text string is turned into individual lines and arcs (i.e. 
each character is stroked).

Input name input

when a DXF file is read in, any text in the DXF file with style of this ’Input name’, is converted to 12d 
Model text strings with the textstyle ’Textstyle name’.

Output name input

if the ’Hardware text’ flag is set to tick - when data is written out to a DXF file, any 12d Model text 
with the textstyle of the name in the field ’Textstyle name’,  is converted to DXF text with style of this 
’Output name’.

If the ’Hardware text’ flag is not set to tick, then this field is ignored.

DWG tab

Hardware text tick box tick

if tick then any 12d Model text is written out to the DWG file as text.
If not tick then each characters of a text string is turned into individual lines and arcs (i.e. 
each character is stroked).

Input name input

when a DGN file is read in, any text in the DGN file with style of this ’Input name’, is converted to 
12d Model text strings with the textstyle ’Textstyle name’.

Output name input

if the ’Hardware text’ flag is set to tick - when data is written out to a DWG file, any 12d Model text 
with the textstyle of the name in the field ’Textstyle name’,  is converted to DWG text with style of this 
’Output name’.

If the ’Hardware text’ flag is not set to tick, then this field is ignored.

DGN tab

Hardware text tick box tick

if tick then any 12d Model text is written out to the DGN file as text.
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If not tick then each characters of a text string is turned into individual lines and arcs (i.e. 
each character is stroked).

Input name input

when a DGN file is read in, any text in the DGN file with style of this ’Input name’, is converted to 
12d Model text strings with the textstyle ’Textstyle name’. For DGN, the text style must be a number 
between 1 and 64.

Output name input

if the ’Hardware text’ flag is set to tick - when data is written out to a DGN file, any 12d Model text 
with the textstyle of the name in the field ’Textstyle name’,  is converted to DGN text with style of this 
’Output name’. For DGN, the text style name must be a number between 1 and 64.

If the ’Hardware text’ flag is not set to tick, then this field is ignored.

Other tab

Hardware text tick box tick

if tick then any 12d Model text is written out to the file as text.
If not tick then each characters of a text string is turned into individual lines and arcs (i.e. 
each character is stroked).

Input name input

when a file is read in, any text in the file with style of this ’Input name’, is converted to 12d Model 
text strings with the textstyle ’Textstyle name’.

Output name input

if the ’Hardware text’ flag is set to tick - when data is written out to a file, any 12d Model text with 
the textstyle of the name in the field ’Textstyle name’,  is converted to text with style of this ’Output 
name’.

If the ’Hardware text’ flag is not set to tick, then this field is ignored.

Buttons

Set button

sets the definition for this editing session of the project - the information will be lost when the 
project is exited.

Write button

write the information to the files textstyle.4d and fonts.4d files. These files can then be used 
when projects are started. The information won’t be used for the current session unless the 
Set button is selected as well. For more information on the Write button, go to the section “Writing 
Set Up Files”  in the Appendix “Set Ups” 

This option updates the files textsyles.4d and fonts.4d which are fully documented in the 
“Textstyles and Fonts” section of the Appendix “Line styles, Symbols and Textstyles” .
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Textstyle Data Favourites
textstyle_names_4d_create_edit

Position of option on menu: Project =>Tree

The textstyle data favourites option defines a set of text style parameters recorded with a user 
given name. When ever a text style needs to be defined, the name of a textstyle data favourite 
can be selected and the values of the favourite used for the text.

To define or modify a textstyle favourite, click on Textstyle data favourites in the Browse list to 
expand the item and then double click LB on Create textstyle data favourite to create/edit the 
textstyle_names.4d file.

Double clicking LB on any of the items below Create textstyle data favourite will also create/edit 
the textstyle_names.4d file.

In either case, the Textstyle_names.4d Create/Edit panel will then appear.

Buttons

Set button

sets the definition for this editing session of the project - the information will be lost when the 
project is exited.

Write button

write the information to the textstyle_names.4d file. The file can then be used when projects 
are started. The information won’t be used for the current session unless the Set button is 
selected as well. For more information on the Write button, go to the section “Writing Set Up Files”  
in the Appendix “Set Ups” 
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Sheet Sizes
sheet_sizes_file

Position of option on menu: Project =>Tree

Click on Sheet sizes to expand the item and then double click LB on Create sheet size to bring 
up the Sheet Sizes File panel to create, edit or delete sheet size definintions , or double click LB 
on an existing sheet size in the list to also bring up the  Sheet Sizes File panel.

Buttons

Set button

sets the definition for this editing session of the project - the information will be lost when the 
project is exited.

Write button

write the information to the file sheets.4d. The file can then be used when projects are started. 
The information won’t be used for the current session unless the Set button is selected as 
well. For more information on the Write button, go to the section “Writing Set Up Files”  in the 
Appendix “Set Ups” 

This option updates the file sheets.4d which is fully documented in the “Sheet Sizes” section of 
the Appendix “Set Ups” .
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Utilities
project_utilities

Position of menu: Project =>Utilities

The utilities walk-right menu contains various project items.

For the option Attributes, go to the section “Attributes” 
Projects “Projects” 
Create “Create” 
Rebuild “Rebuild” 
Zip “Zip” 

The options in the menu will now be described.

Attributes
project_attributes
Position of option on menu: Project =>Utilities =>Attributes

The Attributes options displays, creates and edits the attributes for the current project

On selecting Attributes, the Project Attributes panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Name

name of the attribute

Type integer, real, text

type of attribute - integer, real or text

Data

value for the attribute

OK button

set the attributes to the values in the panel and then exit the panel.

Apply button

set the attributes to the values in the panel but don’t exit the panel.

Projects
Position of option on menu: Project =>Utilities =>Projects

The projects walk-right menu provides a list of all the projects available in the working directory. 
Each project is contained in a sub-directory of the working directory.

Selecting a project from the walk-right list will bring up the Change Project panel with the selected 
project name already in the new project panel field.

Create
create_project
Position of option on menu: Project =>Utilities =>Create
On selecting the Create option, the Create Project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Project input

name of the new project to be created.

Create button

after selecting this button, a new project directory is created. The working project does not 
change to the new project.
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Rebuild
rebuild_project

Position of option on menu: Project =>Utilities =>Rebuild

The rebuild option is used to try and rebuild a project if some of the information has been 
corrupted.

On selecting the option, the project header file will be deleted and re-created and all the models, 
tins, templates and functions inside the project’s directory added back into the project. The view 
information for the original project will be lost.

On selecting the rebuild option, the rebuild project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Project input

the name of the project to be rebuilt.

Rebuild button

after selecting this button, the project given in the project field is rebuilt.

Note - the current (working) project cannot be rebuilt.

Zip
zip_project

Position of option on menu: Project =>Utilities =>Zip

The zip option is used to make a zipped up a copy of any project (including the saved current 
project) in the working folder.

NOTE - this only contains the information in the ".project" folder. It does not include any files in 
the working folder.

On selecting the zip option, the zip project panel is displayed. 
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Project input none  projects in directory

name of the project to be zipped up.

Zip file input *.zip

name of the zip file for the project.

Delete existing zip file first tick box tick

if tick and a zip file already exists, the existing file is deleted before the zip is done.
If no tick, any existing files of the same name in the existing zip file will be replaced and any 
new files will be added to the zip file.

Include directory containing project    tick box

if tick, the whole directory containing the project (not just the project) will be zipped.

Split zip file for floppies tick box

if tick, the zip file will be split into 1.4 Mb files.

Actually write floppies tick box

if tick, a batch file will be created and begun which asks for floppies to the inserted and then 
writes the split zip files onto them.

Delete zip file alter floppies tick box tick

if tick, delete the zip file and any split files after the floppies are created.

Zip button

after selecting this button, a zip file of the project (or directory containing the project) given in 
the project field is made.
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Delete
delete_project

Position of option on menu: Project =>Delete

On selecting the delete project option, the delete project panel is displayed.

The fields and buttons used in the delete project panel have the following functions.

Field Description Type Defaults Pop-Up

Project input available projects

name of project to delete

Delete button

after selecting this button, a yes-no pop-up menu appears to confirm that deleting the project is 
required. If deletion is confirmed, the selected project is deleted from the computer disk.
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12d Model
12d_model_info  12D_Solutions originators

Position of option on menu: Project =>12d Model

The 12d model walk-right menu and the walk-right by menu are

12D Solutions phone, fax etc.

12d Model version
date version compiled

date authorized to

12D Solutions phone, fax etc.
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12d Model Menu
12d_model

Position of option on menu: Project =>12d Model menu

Selecting the 12d Model Menu option brings up the floating 12d Model menu as described at the 
beginning of this chapter.

For the option Projects, go to the chapter “Projects” 
File I/O “File I/O” 
Edit “Edit” 
Views “Views” 
Models “Models” 
Strings “Strings” 
Triangles “Triangles” 
Survey “Survey” 
Design “Design” 
Drafting “Drafting” 
Plots “Plots” 
Reports “Reports” 
Utilities “Utilities” 
User “User” 
Help “Help” 
Save/ Exit “Save and Exit” 

Exit
Selecting Exit exists 12d Model exit

Also see the chapter “Save and Exit” 
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7  File I/O
file_i_o

Position of menu: File I/O

The facilities for reading and writing data files, layout files, textstyle definitions, template files 
into and out of 12d Model, plus screen dumps are collected under the file i/o menu.

The file i/o walk-right menu containing these options is:

The options under data input and data output and digitizer will be given in the following three 
chapters. The rest of the options will be described now.

For the option Data input, go to the chapter “Data Input” 
Data output “Data Output” 
Digitizer “Digitizer” 
Layout input, go to the section  “Layout Input” 
Layout output “Layout Output” 
Textstyle input “Textstyle Input” 
Template input “Templates Input” 
Template output  “Templates Output” 
Screen dump  “Screen Dump” .
Map file “Map File” 
Label map file “Label Map File” 
Acad output map file “AutoCAD Output Map File Create/Edit” 
Use label map file “Use Label Map File” 
Edit “Edit” 

create floating File I/O menu
read in data files
write out data files
digitizing option
read in layout files
write out layout files
read in textstyle definitions file
read in templates file
write out templates file
screen dump of window
create/edit a map file
create a label map file
ACAD output map file
use a label map file
edit a file

on 12d Model menu
and floating menu
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Layout Input
read_screen_layout

Position of option on menu: File I/O =>Layout input

The layout input option reads in a screen layout file (*.slf) which can create most menus and 
panels and place them on the screen.

The screen layout file can be created by the layout input option or by any editor. 

On selecting the layout input option, the read screen layout panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Layout file input *.slf

the name of the file to read the screen layout information from.

Read button

after selecting this button, the screen layout file will be read in.
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Layout Output
write_screen_layout

Position of option on menu: File I/O =>Layout Output

The layout output option writes out information on almost all the objects on the screen, and for 
views, their sizes.

The layout file can be read back in with the layout input option to recreate most menus and 
panels on the screen (not views). Since the layout file is editable, users can create their own 
special layout files.

The view size information is helpful in building up a set_up_file to define the initial screen 
layout.

On selecting the layout output option, the write screen layout panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Layout file input *.slf

the name of the file to print the screen layout information to.

Save button

after selecting this button, the screen layout information will be printed out.

Textstyle Input
read_textstyles_definitions

Position of option on menu: File I/O =>Textstyle Input

When 12d Model starts up, a textstyles definition file can be automatically read in. The textstyles 
definitions file defines the textstyles and fonts used in the project.

It is possible to redefine the textstyles by reading in another textstyles definitions file using the 
textstyle input option.

On selecting the textstyle input option, the read textstyles definitions panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Textstyle file input *.tsf

the name of the file to read the textstyle information from.

Read button

after selecting this button, the textstyles definitions file will be rad in.
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Templates Input
read_templates

Position of option on menu: File I/O =>Templates Input

This option is used to read in templates from files in the special 12d Model template format.

On selecting the templates input option, the read templates panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File input *.tpl files

name of the 12d template file to be read in

Read button

read the data in.

Note if a template already exists, then the template in the file is ignored.
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Templates Output
template_output
Position of menu: File I/O =>Templates Output
The templates output option writes out one or all templates in the 12d Model template format. 
The output walk-right menu is 

One Template
write_a_template

Position of option on menu: File I/O =>Templates Output =>One Template

This option is for writing a single template out in the special 12d template format.

On selecting the one template option, the write a template panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Template input available templates

name of the template to be written out.

File input

name of the file to write the template to.

Write button

after selecting this button, the template given in the template field will be written out to the file with 
the name given in the file field.

All Templates
write_all_templates

Position of option on menu: File I/O =>Templates output =>All templates

This option is for writing all template out in the special 12d Model template format.

On selecting the all templates option, the write all templates panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File input

name of the file to write all the templates to.

Write button

all the templates will be written out to the file with the name given in the file field.

Screen Dump
screen_dump

Position of option on menu: File I/O =>Screen dump

The 12d Model screen can be dumped to disk in either gif or colour postscript format.

On selecting the screen dump option, the screen dump panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Format input gif gif, colour postscript

format to write the screen dump out in.

File input *.gif files

file to write the screen. dump to.

Dump button

after selecting this button, the screen/window is dumped out in the selected format.
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Map File
map_file_create_edit

Position of option on menu: File I/O =>Map File

The map file option is used to create or edit the 12d Map Files which are used in many 
12d Model options.

A 12d Map file consists of tables of keys or entity-masks which are used to set many strings 
properties such as string name, colours, linestyles, symbols, models, extrusions and tinability to 
data that matches one of the keys.

When using a 12d map file, the part of the data that is matched against the keys is called the 
entity-name, and what the entity-name is depends on the option using the map file. For most 
options, the entity-name is a string name but it can vary. For example, the xyzs reader uses the 
string name in the xyzs file as the entity-name but in the DGN reader, no string name exists and 
the DGN level can be entity-name.

On selecting the map file option, the map file create/edit panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Map file input *.mf
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name of the map file to be created or edited.

Bottom buttons

Read button

read in the map file given in the map file field and load the data into the fields of the table. If the file 
doesn’t exist, an error message is given.

Write button

write out the data in the table to the file name given in the map file field. If the file already exists, a yes-
no-cancel panel checks to see if the existing file is to be over written - if no or cancel is selected, nothing 
is written out. 

Header tab

the Header tab just has lines of comment text.

Basic tab

the Basic tab sets colours, linestyles, point-line type, weight and colours for strings.

Key select name menu

key to match the string name against in the Basic tab. The key can include wild cards (*) and wild 
characters (?).
If a match occurs, then the rest of the grid fields for this line of the Basic tab of the map file are used and 
no other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of the Basic 
tab of the map file.

Name select name menu

if non-blank, the string name to be used for all strings matching the key for this line of the map file.
If blank, the original string name (which matched the key) is used.

A blank name field is written out as a * to the ascii version of the map file and a * in the ascii map file 
for name is displayed as a blank line in the map file editor.

Model select model menu

if non-blank, the model to be used for all strings matching the key for this line of the map file.
If blank, the string’s model is not modified.

A blank model field is written out as a * to the ascii version of the map file and a * in the ascii map file 
for model is displayed as a blank line in the map file editor.

Colour select colour menu

if non-blank, the colour to be used for all strings matching the key for this line of the map file.
If blank, the string’s colour is not modified.

A blank colour field is written out as a * to the ascii version of the map file and a * in the ascii map file 
for colour is displayed as a blank line in the map file editor.

Point Line point, line

if non-blank, the breakline type to be used for all the data fitting the key for this line of the map file. 
If blank, the string’s point-line type is not modified. If data is coming from a field file, then the data may 
be coded as a line or point string.

A blank point-line field is written out as a * to the ascii version of the map file and a * in the ascii map 
file for point-line is displayed as a blank in the map file editor.
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Linestyle select linestyles menu

if non-blank, the linestyle to be used for all strings matching the key for this line of the map file.
If blank, the string’s linestyle is not modified.

A blank linestyle field is written out as a * to the ascii version of the map file and a * in the ascii map 
file for linestyle is displayed as a blank line in the map file editor.

NOTE: If the point-line type is point then the linestyle is used as a symbol at each vertex of the string. 
The size of the symbol at each point is given in the linesytle definition. If a symbol at each point is 
required whose size, colour and rotation may need to be modified at each point, then the symbol tab 
must be used to place a symbol at each vertex and a world style must be used in the symbol name field 
for the symbol tab.

Weight

if non-blank, the weight to be used for all strings matching the key for this line of the map file.
If blank, the string’s weight is not modified.

A blank weight field is written out as a * to the ascii version of the map file and a * in the ascii map file 
for weight is displayed as a blank line in the map file editor.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Solid Fill tab

the Solid Fill tab sets whether super strings (closed and non-closed) are filled with a solid colour.

Key select name menu

key to match the string name against in the Solid Fill tab. The key can include wild cards (*) and wild 
characters (?).
If a match occurs, then the rest of the grid fields for this line of the Solid Fill tab of the map file are used 
and no other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of the Solid 
Fill tab of the map file.

Colour select colour menu

colour to use to fill the super string with. If the super string is not closed, the fill will apply as if the 
super string was closed.
This field can not be blank.

Blend

if non blank, the blend value to use for the solid fill.

Drape name

Drape mode choice box Colour, Colour by texture

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Bitmap Fill tab

the Bitmap Fill tab sets whether super strings (closed and non-closed) are filled with a bitmap pattern.
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Pattern Fill tab

this option is under development.

Autocad Pattern

the AutoCad Pattern tab uses a pattern from the AutoCAD pattern file to fill the selected strings

Hatch Fill tab

the Hatch Fill tab sets whether super strings (closed and non-closed) are filled with a hatch pattern. 

Symbols tab

the Symbols tab sets what symbols to be used on vertices of strings.

Key select name menu

key to match the string name against in the Symbol tab. The key can include wild cards (*) and wild 
characters (?).
If a match occurs, then the rest of the grid fields for this line of this tab of the map file are used and no 
other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of this tab of 
the map file.

Symbol select symbol menu

the name of the symbol to be used for each vertex of all strings matching the key.
This field can not be blank. If the symbol does not exist when the map file is being used, then an error 
message will be written to the output window.

Size measures menu

the size of the symbol to be used for each vertex of all strings matching the key.
This field can not be blank.

Colour select colour menu

the colour of the symbol to be used for each vertex of all strings matching the key.
This field can not be blank.

Angle measures menu

the angle of the symbol to be used for each vertex of all strings matching the key.
This field can not be blank.

Delta X measures menu

the x-distance to offset the symbol from each vertex of the strings matching the key.
This field can not be blank.

Delta Y measures menu

the y-distance to offset the symbol from each vertex of the strings matching the key.
This field can not be blank.
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Hide vertex tick box 

if tick, no default cross is placed at the vertex of the string.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Tinable tab

the Tinable tab sets whether the vertices and segments are tinable (used in triangulations), not tinable 
(not used in triangulations) or only the vertices (points) are tinable.

Key select name menu

key to match the string name against in the Tinable tab. The key can include wild cards (*) and wild 
characters (?).
If a match occurs, then the rest of the grid fields for this line of this tab of the map file are used and no 
other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of this tab of 
the map file.

Tinable yes, no, points

if yes, the vertices and segments for all the strings matching the key are tinable.
If no, the vertices and segments for all the strings matching the key are not tinable.
If points, the segments are not tinable and the vertices are tinable for all the strings matching the key.
This field can not be blank.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Vertex Text Data tab

the Vertex Text Data tab sets parameters for drawing text on the vertices of super strings.

Key select name menu

key to match the string name against in the Vertex Text Data tab. The key can include wild cards (*) 
and wild characters (?).
If a match occurs, then the rest of the grid fields for this line of this tab of the map file are used and no 
other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of this tab of 
the map file.

Delta X

vertex of string

position to place the symbol

Definition of the Parameters Delta X and Delta Y for positioning a Symbol

Delta Y
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Textstyle select text style menu

the textstyle used for any vertex text for all strings matching the key.
This field can not be blank.

Type screen, paper, world

the textstyle type used for any vertex text for all strings matching the key.
This field can not be blank.

Size measures menu

the size of the vertex text to be used for each vertex of all strings matching the key.
This field can not be blank.

Colour select colour menu

the colour of the vertex text to be used for each vertex of all strings matching the key.
This field can not be blank.

Angle measures menu

the angle of the vertex text to be used for each vertex of all strings matching the key.
This field can not be blank.

Offset measures menu

the distance to offset the text from each vertex of the strings matching the key.
This field can not be blank.

Raise measures menu

the distance to perpendicularly raise the text for each vertex of all strings matching the key.
This field can not be blank.

Slant Measures menu

the slant for the vertex text of all strings matching the key.
This field can not be blank.

X factor Measures menu

the x-factor for the vertex text of all strings matching the key.
This field can not be blank.

Justify Select Justification Choice menu

the justification for the vertex text of all strings matching the key.
This field can not be blank.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 

Angle (measured anti-clockwize)

Raise - positive is on the left of the line to the vertex
vertex of string

position to place the text

Definition of the Parameters angle, offset and raise for Positioning Vertex Text

Offset
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before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Segment Text Data tab

the Segment Text Data tab sets parameters for drawing text on the segments of super strings. The text 
is positioned about the mid point of the segment.

Key select name menu

key to match the string name against in the Segment Text Data tab. The key can include wild cards (*) 
and wild characters (?).
If a match occurs, then the rest of the grid fields for this line of this tab of the map file are used and no 
other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of this tab of 
the map file.

Textstyle select text style menu

the textstyle used for any segment text for all strings matching the key.
This field can not be blank.

Type screen, paper, world

the textstyle type used for any segment text for all strings matching the key.
This field can not be blank.

Size measures menu

the size of the segment text to be used for each segment of all strings matching the key.
This field can not be blank.

Colour select colour menu

the colour of the segment text to be used for each segment of all strings matching the key.
This field can not be blank.

Angle measures menu

the angle of the segment text to be used for each segment of all strings matching the key.
This field can not be blank.

Offset measures menu

the distance to offset the text from each segment of the strings matching the key.
This field can not be blank.

Raise measures menu

the distance to perpendicularly raise the text for each segment of all strings matching the key.
This field can not be blank.

Angle (measured anti-clockwize)

Raise - positive is on the left of the line to the vertex
midpoint of segment

position to place the text

Definition of the Parameters angle, offset and raise for Positioning Segment Text

Offset
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Slant Measures menu

the slant for the segment text of all strings matching the key.
This field can not be blank.

X factor Measures menu

the x-factor for the segment text of all strings matching the key.
This field can not be blank.

Justify Select Justification Choice menu

the justification for the segment text of all strings matching the key.
This field can not be blank.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Pipes tab

the Pipes tab sets parameters for sizing pipes and culverts for super strings.

Key select name menu

key to match the string name against in the Pipes tab. The key can include wild cards (*) and wild 
characters (?).
If a match occurs, then the rest of the grid fields for this line of this tab of the map file are used and no 
other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of this tab of 
the map file.

Justify invert, centre, obvert

the pipe/culvert justification used for all strings matching the key.
This field can not be blank.

Shape diameter, culvert

the shape of the super string segment for all strings matching the key.
This field can not be blank.

Size 1 measures menu

for a pipe shape, the diameter of the super string segment to be used for each segment of all strings 
matching the key.
For a culvert shape, the width of the super string segment to be used for each segment of all strings 
matching the key.
This field can not be blank.

Size 2 measures menu

for a culvert shape, the height of the super string segment to be used for each segment of all strings 
matching the key. Ignored for a pipe shape.
This field can only be blank for a pipe shape.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Boundaries tab
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the Boundaries tab sets a parameters for a string so that when it is part of a triangulation it is also used 
to null or reset any triangles.

Key select name menu

key to match the string name against in the Boundaries tab. The key can include wild cards (*) and 
wild characters (?).
If a match occurs, then the rest of the grid fields for this line of this tab of the map file are used and no 
other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of this tab of 
the map file.

Boundaries exclude, include

If the mode is exclude, then any triangles inside the polygon are set to null.
If the mode is include, then any triangles inside the polygon are reset so that they aren’t null.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Library Extrude tab

the Library Extrude tab applies an extrude from the 12d library to selected super strings. Note that 
extrudes can only be applied to super strings.

Key select name menu

key to match the string name against in the Library Extrude tab. The key can include wild cards (*) 
and wild characters (?).
If a match occurs, then the rest of the grid fields for this line of this tab of the map file are used and no 
other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of this tab of 
the map file.

Extrude select extrudes menu

the library extrude to apply to the super string

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

String Extrude tab

the String Extrude tab applies an extrude to selected super strings. Note that extrudes can only be 
applied to super strings.

Key select name menu

key to match the string name against in the String Extrude tab. The key can include wild cards (*) and 
wild characters (?).
If a match occurs, then the rest of the grid fields for this line of this tab of the map file are used and no 
other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of this tab of 
the map file.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
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before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Interval Extrude tab

the String Extrude tab applies an extrude to selected super strings. Note that extrudes can only be 
applied to super strings.

Key select name menu

key to match the string name against in the Interval Extrude tab. The key can include wild cards (*) 
and wild characters (?).
If a match occurs, then the rest of the grid fields for this line of this tab of the map file are used and no 
other tests for matches against keys further down in the table are made.
If a match does not occur, then a test for a match is made against the key on the next line of this tab of 
the map file.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the ascii map file 
before the comment, and a comment in an ascii map file is read in and displayed without the double 
slash.

Please see the next section “Ascii Form of the 12d Map File” for a discussion of the text form of 
the 12d map file.

Ascii Form of the 12d Map File

Basic Tab

The Basic tab enables the string name, model, colour, point-line type, linestyle and weight to be 
defined and for many applications, this is all that is required in the 12d Map file.

The Basic tab consisted of one or more lines of information. Each line begins with a key (entity-
mask) followed by a string name, model name, colour, breakline type (point or line), line style, 
weight and comment. The key can contain wild cards (*) and wild characters (?).

When a string is read in and satisfies a key, the key’s corresponding string name, model, colour, 
breakline type and style is used for that string.

For example, any entity name beginning with 31 can be created as a 12d Model string with the 
name picket, colour cyan, breakline type line, line style 1 and model fences by the map file line

31 picket fences cyan line 1

If a map file is used, as each entity is read in, the map file is searched sequentially until a match 
with a key is made and the key’s name, colour etc. used. If no match is found, the default colours 
and model (given in the read panel) are used.

Notes

1. If the entity-name is to be used as the new string name, use an asterisk (*) in place of the 
string name. For example,

fred * fences cyan line 1

2. If the default model for the reader is to be used as the model name, use an asterisk in place of 
the model name. For example,

31 31 * cyan line 1
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3. A * for colour, breakline type and linestyle means that if the entity has a colour, breakline style 
or linestyle, then it is used rather than be mapped to another one.

4. All model names used in the map file can be given an extra (common) prefix by typing the 
prefix into the prefix for models field in the read panel.

5. If any information includes a space, then it must be enclosed in quotes ". For example, the 
model name may be "trial 1" or a style "large tanks".

6. Comments can be included in the map file by preceding them with a double forward slash //. 
Anything on the line after the // is ignored.

An example of a 12d Model map file is

// 12d Model map file
// key name model colour pt-line linestyle

102 break breaks red line solid
305 fence cadast green point dash
998 bdry bound cyan line solid
spots * spot yellow point 1
PS* * * yellow point 1

Other tabs

For all tabs other than the Basic tab, the map file is broken up into sections (one section for each 
tab of the map file editor) and each section begins with a header record which is the section name 
enclosed in braces { }. For example, the symbols section has the header 

{symbol_data}

Inside each section, the data is similar to the Basic tab with lines consisting of a key (entity-mask) 
followed by the data required for that section. The key can contain wild cards (*) and wild 
characters (?).

The exact format for the map file is not required since they are created and edited from within 
12d Model by the option

 File i/o => Map file
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Label Map File
label_map_file_create_edit
Position of option on menu: File I/O =>Label Map File

The label map file option can be used to create or edit the map files used to create labelling for 
vertices.

On selecting the label map file option, the label map file create/edit panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Label map file input *.lmf

name of the label map file to be created or edited.

Bottom buttons

Read button
read in the label map file given in the label map file field and load the data into the fields of the table. If 
the file doesn’t exist, an error message is given.

Write button
write out the data in the table to the file name given in the label map file field. If the file already exists, 
a yes-no-cancel panel checks to see if the existing file is to be over written - if no or cancel is selected, 
nothing is written out. 

Header tab

lines of text that are written out at the top of the label map file.

Vertex text data tab - labelling of the text at each vertex
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Key select name menu for fields

key to be used in this line of the label map file.

Textstyle select textstyle menu for fields

textstyle for labels.

Type/Size/Colour

units for size of text labels/size of the text/ colour of the text.

Angle/Offset/Raise/Slant/X Factor/Justify

angle/offset/raise/slant/x factor/justification for the text.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the file before the 
comment, and comment in a map file is read in and displayed without the double slash.

Vertex index text data tab - labelling of the vertex index

Key select name menu for fields

key to be used in this line of the label map file.

Textstyle select textstyle menu for fields

textstyle for labels.

Type pixel, world

units for size of text labels.

Size

size of the text in the given units.

Colour select colour menu for fields

colour of the text.

Angle/Offset/Raise/Slant/X Factor/Justify

angle/offset/raise/slant/x factor/justification for the text.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the file before the 
comment, and comment in a map file is read in and displayed without the double slash.

Point id text data tab - labelling the point id at each vertex

Key select name menu for fields

key to be used in this line of the label map file.

Textstyle select textstyle menu for fields

textstyle for numbers.

Type/Size/Colour

units for size of number labels/size of the text/ colour of the number.

Angle/Offset/Raise/Slant/X Factor/Justify

angle/offset/raise/slant/x factor/justification for the number text.

Comment
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comment to be to be used in this line of the map file. A double slash // is written out to the file before the 
comment, and comment in a map file is read in and displayed without the double slash.

Height text data tab - labelling of the height of the vertex

Key select name menu for fields

key to be used in this line of the label map file.

Textstyle select textstyle menu for fields

textstyle for labels.

Type/Size/Colour

units for size of text labels/size of the text/ colour of the text.

Angle/Offset/Raise/Slant/X Factor/Justify

angle/offset/raise/slant/x factor/justification for the text.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the file before the 
comment, and comment in a map file is read in and displayed without the double slash.

Name text data tab - labelling of the string name(codes) at each vertex

Key select name menu for fields

key to be used in this line of the label map file.

Textstyle select textstyle menu for fields

textstyle for labels.

Type/Size/Colour

units for size of text labels/size of the text/ colour of the text.

Angle/Offset/Raise/Slant/X Factor/Justify

angle/offset/raise/slant/x factor/justification for the text.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the file before the 
comment, and comment in a map file is read in and displayed without the double slash.

Symbols - placing symbols at each vertex

Key select name menu for fields

key to be used in this line of the label map file.

Style select textstyle menu for fields

linestyle to apply to the vertex.

Size/Colour

size/colour of symbol.

Angle/Offset/Raise

angle/offset/raise for the symbol.

Comment

comment to be to be used in this line of the map file. A double slash // is written out to the file before the 
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comment, and comment in a map file is read in and displayed without the double slash.
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AutoCAD Output Map File Create/Edit
autocad_export_map_file_create_edit

Position of option on menu: File I/O =>AutoCAD output map file

The AutoCAD output map file option creates or edits the map files used when writing data out to 
AutoCAD using the DWG Output option (not used for plotting to AutoCAD).

On selecting the lAcad output map file option, the Autocad Export Map File Create/Edit panel is 
displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Map file input *.acadmf

name of the Autocad output map file to be created or edited.

Read button

read in the Autocad output map file given in the map file field and load the data into the fields of the 
table. If the file doesn’t exist, an error message is given.

Write button

write out the data in the table to the file name given in the map file field. If the file already exists, a yes-
no-cancel panel checks to see if the existing file is to be over written - if no or cancel is selected, nothing 
is written out. 

Grid Cells

12d Name

12d Model string names for the mapping to apply to - wild cards (*) and characters (!) can be used.
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Acad layer

AutoCAD layer to send the selected strings to. Use * to write the 12d Model model of the string out

Acad colour

AutoCAD colour to use for the selected strings - a number between 0 and 256. Use * for 12d Model 
colour number. Use BYLAYER for ACD BYLAYER

Acad linestyle

AutoCAD linestyle to use for the selected strings. User * for 12d Model linestyle or BYLAYER for 
ACD BYLAYER

Acad Textstyle

AutoCAD Textstyle to use for the selected strings. Use * for 12d Model text style

Acad lineweight

AutoCAD lineweight to use for the selected strings.
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Use Label Map File
label_data_by_label_map_file

Position of option on menu: File I/O =>Use Label Map File

Use a label map file to create text labels for all strings is the selected data source.

On selecting the use label map file option, the label data by label map file panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model
data selection type

Data source input
source of data is to be written out to a file.

Label map file input *.lmf

name of the label map file to be created or edited.

Use models for labels tick box tick

if tick, all the labels for all vertices of the strings go into the appropriate models for vertex, vertex 
numbers, point ids, height, string name (code) and symbols given in the panel fields.

if not tick, the labels for a string from a model go into the model of the same name but with a prefix/-
postfix given by the vertex, vertex ni, height and code panel fields.

Vertex text, Vertex index,
 Point id, Height, Name, Symbolmodel box available models
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if User models for labels is ticked, these models are used for the create data.

Label button

process the selected strings and label them.
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Edit
file_browse

Position of option on menu: File I/O =>Edit

Files can be searched for and then displayed in the editor using the browse option.

On selecting the Edit option, the File Browse panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder input current folder Microsoft browser

folder to search for files with the extension given in the extension field.

Extension input *.dat

wild cards and extension to limit the search of files. An <enter> needs to be typed after changing the 
extension.

File input files satisfying the folder
and extension fields.

select the file to be displayed in the editor.

Found button

display in the editor the file of the name given in the file field.

Note

The editor is pointed to by the environment variable EDITOR_4D (see Appendix A).
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8  Data Input
data_input

Position of menu: File I/O =>Data input

The facilities for reading data files into 12d Model are collected under the File i/o=>Data input 
menu.

Some of the formats are provided in the base product (xyz data, BCC Epson, 12d Model HP plots 
and 12d Model ascii files) and the rest are optional (dxf, genio, geocomp, etc.).

The default Input null value is described in the section “Input Null Value”  

The default Input null value is described in the section “Input Null Value”  

For the option 12da data, go to the section “12d Ascii Input” .
ArcView SHP  “ArcView SHP Input” .
x y z s  “X Y Z S File Format” .
x y z s pt_no  “User Format X Y Z Input” .
x y z general  “User X Y Z and Attributes Input” .
BCC Epson  “BCC Epson Input” .
Civilcad “CivilCad Input” .
DEM “DEM Input” .
DGN  “DGN Binary Input” .
DGN (complex elements)  “DGN With Complex Elements” .
DGN V8  “DGN V8” .
DWG/DXF/DXB “DWG/DXF Input” .
Genio “Genio File Format” .
Geocomp “Geocomp File Format” .

12d Model ascii file
ArcView shape files
read in x y z s data
user format x y z s point no
user format x y z s point and attributes 
BCC Epson data file
Civilcad ascii files
USGS DEM files
dgn files
dgn files with complex elements
dgn V8 files
dwg/dxf Ver 12 to 2005
genio data
Geocomp.pts,.str data
Keays data
LandXML
MapInfo
SDR Map file
TP Setout .pta file
TP Stakeout strings file
Old readers
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Keays  “Keays Input” .
LandXML  “LandXML Input” .
MapInfo  “Mapinfo Input” .
SDR Map  “SDR Map Input” .
TP Setout  “TP Setout Input” .
TP Stakeout strings  “TP Stakeout Strings Input” .
Old  “Old Inputs” .
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Input Null Value
In three dimensional data, it is possible that a point can have a valid plan position but an 
undefined height. In 12d Model, there is a special null value which is used internally when 
height is undefined (-9.9e29).

In other systems, the null value will be different.

To allow for the different null values, 12d Model has an i/o null height parameter.

As data is read in, the height is checked and if it is equal to the i/o null height, then it is replaced 
by the 12d Model null height.

The i/o null height is set in Default Settings tab of the Defaults panel in the option 
Utilities=>Defaults.

Note - some input panels have their own special null value field which is used instead of the i/o 
null height.
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12d Ascii Input
read_12D_Solutions_ascii_data

Position of option on menu: File I/O =>Data input =>12d/4da data

The 12d Ascii format is a special format defined by 12D Solutions to allow data to be easily 
transferred from other programs into 12D Solutions software such as 12d Model. The 12d Ascii 
format is given in the Appendix.

Selecting the 12d data brings up the Read 12d Solutions Ascii Data panel:

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Format choice box 12d ascii 12d ascii, 4d ascii

use 12d ascii or 4d ascii format (the only difference is the file name ending)

File to read file box *.12da or *.4da files

name of the 12d Model Ascii file to be read in.

Advanced tick box

if tick, a grid to allow multiple 12d ascii files to be read in, is opened. A wild card is used to select all 
the files to be read in.

Folder folder box

folder to search for files using the Wild card
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Wildcard input

wild card to use in search for files in the given folder

Use tick box

if tick, read in the file

Files output

name of the file in the folder

Size output

 file size

Pre*post text input

if non blank, pre*post text to use for the models in this 12d ascii file (see “Pre*Postfix Panel Fields”  
for information on using pre*postfix.
If blank, use the pre*post text from the Pre*postfix for models panel field.

Note - if a non-blank value for Pre*post is given in the column for a file then the Pre*postfix for 
models is ignored.

Map file file box     *.mf files

if non-blank, the name of the 12d map file to be used for all strings read in, including any files given 
with the Advanced mode ticked on. 
If blank, no map file is used

When using a map file, the string name is used as the entity-name for matching with the keys in the 
map file. See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Note - if a non-blank value for Pre*post is given in the column for a file then the Pre*postfix for 
models is ignored.

Use map file model when pt/line changes tick box

if not tick and the pt/line type of the string does not match that in the map file, then the string is 
placed in the  .
If tick, the .

Allow #include to be used tick box

if tick, XXXX.

Read button

read the data in.
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ArcView SHP Input
read_ArcView_shape_data

ArcView_input_mapping

Position of option on menu: File I/O =>Data input =>ArcView SHP

This Option is currently under development.

On selecting the ArcView SHP option, the Read ArcView Shape Data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File file box *.shp files

name of the ArcView shape file. 12d Model then reads this and the two (2) other files that go with the 
shape file. The two other file extensions are *.shx and *.dbf.
If no attribute is mapped to model, then the file name (minus the .shp) is used as the model for the data.

Map file file box     *.mf files

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Map button

After specifying the Shape file name, click on Map to scan the file and find the names of all the 
attributes in the shape file. An ArcView Input Mapping panel is then displayed with a list of all the 
ArcView attributes in the shape file. How the attribute are to be mapped and used in 12d Model is then 
be specified for each attribute in the panel. For example, the value of an attribute could be used for a 12d 
string name, or colour etc.
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If None is selected for an attribute, then the attribute is ignored.
Once the table is completely filled in (no field in the column titled 12d Model can be left blank) then the 
Set button must be selected and then the Finish button selected to remove the ArcView Input Mapping 
panel.

NOTE - if no ArcView attribute is mapped to Model, then the file name (minus the .shp) is used as the 
model or the data.

Read button

read the data in.
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X Y Z S File Format
read_x_y_z_s_data

The x-y-z-s format is designed so that point and line strings can be quickly and easily coded and 
entered into 12d Model. It is not intended for more complex strings such as alignments and text 
where the 12d Model ascii format is more suitable.

For the x-y-z format, point data is set out with one point of x y z data per line. The three values 
are separated by one or more spaces (free format). For example

990 3 10

112 1001 23.5

A point-string is represented in 12d Model with a cross at each point. The colour of the cross can 
be defined by including a POINT_COLOUR command on the line before the point-string begins.

For example, a two point point-string with red crosses would be coded as

POINT_COLOUR red

100.3 990.3 10

112   1001   23.5

Line string data is also set out with one point per line (in the order that the points occur in the 
string) but with a string label included at the end of each line. The string label is repeated for 
each point in the string. The line string terminates when the string label changes to another name 
for a new line string or is blank for a point string.

A line-string is drawn with a line connecting a point to its neighbouring points in the string (the 
string links). The colour of the links of the string can be set using the LINE_COLOUR command.

For example, a green, three point line-string called S1 becomes

LINE_COLOUR green

100.3   990.3 10     S1

112    1001    23.5   S1

119.3 1203.1 29.4   S1

Notes

(a) The name of the line string can include spaces but in that case the name must be enclosed in 
quotes ". For example, the string name may be "toe 1".

(b) If a string of a certain name is created and the string name reoccurs in the file, then a new 
string with the same name is created. It is not joined to the earlier string.

xyz Map File

See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

The name of the xyzs string is used as the entity-name to be used for matching with a map file. 
The map file can be used to override the breakline type of line-strings in the x-y-z file.
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X Y Z Input
Position of option on menu: File I/O =>Data input =>x y z s 

On selecting the xyzs option, the read xyzs data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File file box *.dat files

name of the data file to be read in

Map file map file box     *.mf files

if non-blank, the name of the 12d map file to be used for all strings read in.
If blank, no map file is used

When using a map file, the string name is used as the entity-name for matching with the keys in the 
map file. See the section “Map File” in chapter “File I/O”  for information about 12d map files.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix

Default line colour colour box default colour available colours

colour used for line-strings (if no colour is defined in the file)

Default point colour colour box default pt colour available colours

colour used for the crosses in point-strings (if no colour is defined in the file)

Default model for data model box available models

name of the model that the data is to be placed in. The model will be created if it does not already exist. 
This field must be filled in.

Use super strings tick box

if tick, super strings will be created.
If not tick, 3d strings will be created.

Add to view view box available views

if non blank, the default model will be automatically added to the view
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Read button

read the data into the model given in the model field.



Chapter 8  Data Input

April 2007 Page 443User Format X Y Z Input

User Format X Y Z Input
Read_x_y_z_s_pt_no

Position of option on menu: File I/O =>Data input =>x y z s pt_no

On selecting the read x,yzs,pt_no option, the read xyzs pt no panel is displayed.

This option reads data in one line at a time with the values separated by a delimiter (tab, space, 
semi-colon or comma) or the data on each line can be in fixed width columns.

In either case, the user specifies the order that the x, y, z, s and point number are in and if desired, 
only an x and y value needs to be read in.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Button on bottom

Read button

read the data into the model given in the model field.

Files tab

File to read input *.dat files

name of the data file to be read in

Advanced tick box

if tick, a grid to allow multiple files to be read in, is opened. A wild card is used to select all the files to 
be read in.



12d Model Reference Manual

Page 444 April 2007User Format X Y Z Input

Folder folder box

folder to search for files using the Wild card

Wildcard input

wild card to use in search for files in the given folder

Use tick box

if tick, read in the file

Files output

name of the file in the folder

Size output

 file size

Pre*post text input

if non blank, pre*post text to use for the models in this file (see “Pre*Postfix Panel Fields”  for 
information on using pre*postfix.
If blank, use the pre*post text from the Pre*postfix for models panel field.

Note - if a non-blank value for Pre*post is given in the column for a file then the Pre*postfix for 
models is ignored.

Basic tab

Default line colour colour box default colour available colours

colour used for line-strings (if no colour is defined in the file)

Default point colour colour box default pt colour available colours

colour used for the crosses in point-strings (if no colour is defined in the file)

Default text style input available textdatas

textdata for the point ids

Skip column headers tick box

if tick, the first line of the file is skipped.

Join all tick box

if tick, all vertices with the same string names are joined together regardless of where they are in the 
file. The order of the vertices is the order they occur in the file.
If no tick then any time a string name changes in the file, a new string is created. So if the same string 
name occurs but separated by a different string name, then more than one string of that same name will 
be created. The order of the vertices is the order they occur in the file.

Default model for data model box available models

name of the model that the data is to be placed in. The model will be created if it does not already exist. 
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This field must be filled in.

Add to view view box available views

if non blank, the default model will be automatically added to the view

Format tab

Input mode choice box delimiter delimiter, fixed width

if delimiter, the type of delimiter and the columns for the x, y and optionally z, name and point 
number are given. 

Delimiter choice box tab \f one space, tab \t,
semi colon, comma
many spaces

if fixed width, the start and end positions are given for x, y and optionally z, name and point number.

Mapfile tab

Map file file box     *.mf files

if non-blank, the name of the 12d map file to be used for all strings read in, including any files given 
with the Advanced mode ticked on. 
If blank, no map file is used

When using a map file, the string name is used as the entity-name for matching with the keys in the 
map file. See the section “Map File” in chapter “File I/O”  for information about 12d map files.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Note - if a non-blank value for Pre*post is given in the column for a file then the Pre*postfix for 
models is ignored.
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User X Y Z and Attributes Input
Read_x_y_z_General_File

Position of option on menu: File I/O =>Data input =>x y z general

On selecting the read x,y,z general option, the Read x y z s General File panel is displayed.

This option reads data in one line at a time with the values separated by a delimiter (tab, space, 
semi-colon or comma) or the data on each line can be in fixed width columns.

In either case, the user specifies the order that the x, y, z, string name, point number and 
attributes appear in the file. If desired, only an x and y value needs to be read in.

The set-ups for defining all the positions of all the data in the file can be written out to a file (.xyf) 
for re-use. 
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Parameters section

Parameter file input *.xyf files

name of the file containing the settings for how the data is positioned in the input file.

Read icon button
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read the parameter file in.

Write icon button

write the setting in the panel out to a parameter file.

Input settings section

File input *.dat files

name of the data file to be read in

Map file file box *.mf files

if non-blank, the name of the map file to be used for all strings read in. If blank, no map file is used.
The string name is used as the entity-name for matching with the keys in the map file.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Default line colour input default colour available colours

colour used for line-strings (if no colour is defined in the file)

Default point colour input default pt colour available colours

colour used for the crosses in point-strings (if no colour is defined in the file)

Default text style input available textdatas

textdata for the point ids and other text

Default model for data input available models

name of the model that the data is to be placed in. The model will be created if it does not already exist. 
This field must be filled in.

Add to view input available views

if a view name is entered, then the model will be automatically added to the view. This field can be 
blank.

Skip column headers tick box

if tick, the first line of the file is skipped.

Join all tick box

if tick, all vertices with the same string names are joined together regardless of where they are in the 
file. The order of the vertices is the order they occur in the file.
If no tick then any time a string name changes in the file, a new string is created. So if the same string 
name occurs but separated by a different string name, then more than one string of that same name will 
be created. The order of the vertices is the order they occur in the file.

Input mode choice box delimiter delimiter, fixed width

if delimiter, the type of delimiter and the columns for the x, y and optionally z, name and point 
number are given. 

Delimiter choice box tab \f one space, tab \t,
semi colon, comma
many spaces

if fixed width, the start and end column positions are given for x, y and optionally z, name and point 
number.

Column number/Start end position section

information to read in (x,y,z, attributes etc.) and its position in the input file.
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BCC Epson Input
read_bcc_epson_data
Position of option on menu: File I/O =>Data input =>BCC Epson

The BCC Epson input option is designed to read in files in the BCC (Brisbane City Council) Epson 
format.

The BCC Epson format is point based with unique point numbers for each point. It also has the 
concept of non-tinable points. Since the super string supports vertex tinability, it is the best 
string type to use for storing data coming in BCC Epson format. Also the BCC Epson point ids 
are stored as the point ids of the super string vertices.

BCC Epson breaks its data up by a feature code and a 12d Model map file can be used to define 
models, colours, linestyles etc. where the BCC feature code as the entity-name (key) in the map 
file.

The best way to read in BCC Epson data is to have a map file which maps BCC Epson feature 
codes into strings with the same name as the feature code, and also places the strings into 
sensible models.

See the section “Map File” in chapter “File I/O”  for information about a 12d map file.

Note:
All text after column 68 in the BCC Epson file is considered to be a note.

On selecting the BCC Epson option, the Read BCC Epson Data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Format input Dat files Dat files, SUR files

format to use when reading in the BCC Epson file.
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Epson file input matches the selected format

name of the BCC Epson file to be read in.

Map file input     *.mf files

if non-blank, the name of the map file to be used for all strings read in.
If blank, no map file is used.
The BCC Epson feature code is used as the entity-name to match against the key in the 12d map file.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Default model for data input available models

name of the model that any unmapped data is placed in. The model will be created if it does not already 
exist. This field must be filled in.

Null height input -999

if non-blank, any BCC Epson z values equalling this value are taken as null values.

Line colour input red available colours

colour for BCC Epson string s.

Point colour input yellow available colours

colour for BCC Epson points that are not part of strings.

Separate text from data tick box

if not tick, text is used in 4d or super stings
if tick, separate text strings are created.

Text units input pixels  pixels, world

units for the height of the text label.

Text height (u) input

height of the text (in text units).

Text offset (u) input

distance (in text units) to offset the text from its (x,y) placement position.

Text angle input

angle of the text.

Create strings as input Super Strings 3d, 4d, Polyline, Super

type of strings to create.

Read button

read the data in.
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CivilCad Input
read_civilcad_data

CivilCad input is a separate chargeable module.

Position of option on menu: File I/O =>Data input =>Civilcad

The civilcad input option is designed to read in CivilCad Version 4, 5 and some 6 ascii files.

CivilCad breaks its data up by a layer name only. By default, CivilCad layers are mapped into 
12d Model models.

CivilCad has no strings but only points, lines, arcs and circles. CivilCAD spirals are ignored. 
When reading in CivilCad data, 12d Model will try to head to tail consecutive lines from the 
same layer to create strings.

The CivilCad format is point based with unique point ids for each point. It also has the concept 
of non-contourable or non-tinable points.

Since the super string supports point tinability, it is the best string type to use for storing data 
coming in CivilCad format. CivilCad point ids are stored as the point numbers of the super 
string vertices.

In CivilCad, a layer is defined to contain only breaklines or non-breaklines. In 12d Model, this 
simply corresponds to strings having a line or point breakline type.

If a map file is used when reading CivilCad data, either the CivilCad layer name, entity code, 
layer/code or code/layer can be used as the entity-name to match against the key. 

See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Warning - CivilCad has a null value of -10,000 - these values may need to be nulled in 12d Model 
after the CivilCad data is read in.

On selecting CivilCAD, the Read Civilcad Data panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Format choice box Version 5 version 4, version 5, version 6

format of CivilCad ascii file to be read in.

Civilcad file file box *.asc

name of the Civilcad ascii file to be read in.

Map file map file box     *.mf files

if non-blank, the name of the map file to be used for all strings read in
If blank, no map file is used.
The Key for map file defines what is used to match against the key in the map file.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Key for map file choice box Layer Code, Layer,
 Code/Layer, Layer/Code

if Layer, the Civilcad layer is used as the entity-name to match against the key in the map file.
if Code, the Civilcad layer is code as the entity-name to match against the key in the map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Use CivilCad styles tick box
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if tick, then the CivilCad linestyle number is used as the 12d Model linestyle name.

Use CivilCad colours tick box

if tick, then the CivilCad colour number is used as the 12d Model colour number.

Ignore characters after delimiter tick box

if tick, r.

(V5.3x) use -10000 as null height   tick box tick

if tick, any CivilCad z values of -10,000 are taken as null values.

(V5.3x) null height input -999

the value in the CivilCAD file to use as null height if User -10000 is not ticked.

Point colours colour box yellow available colours

colour for CivilCad points that are not part of strings.

Text height (pixels) input 8

the height in pixels of any text created, or for point numbers.

Text offset (pix) input 12

the offset (in pixels) from the (x,y) co-ordinate position for any text or point numbers.

Create strings as input Super Strings Lines and Arcs
3d Strings and Arcs,
Polyline Strings
Super Strings

type of strings to create.

Match flags tick box

CivilCad data consists of individual lines and arcs. When reading CivilCad data, it undergoes head to 
tail processing and the match flags specify what CivilCad data can be joined.

Match layer/code/linetype/angles/pen tick box

if tick, then any CivilCad lines and arcs must have the same layer/code/linetype/angle/pen before they 
can be joined in the head to tail process.

Read button

read the data in.
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DEM Input
read_DEM

Position of option on menu: File I/O =>Data input =>DEM

The DEM option is designed to read in Digital Elevation Model data in the Arc/Info format.

On selecting Dem, the Read DEM panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Format choice box Arc/Info ASCII Arc/Info ASCII Grid *.dem

format of the DEM to read in.

Dem file to read file box

name of the DEM file to be read in.

Model for DEM model box available models

model to put the DEM data in.

Read button

read the data in.
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DGN Binary Input
read_dgn_data

DGN binary input is a separate chargeable module.

Position of option on menu: File I/O =>Data input =>DGN

The DGN input option is designed to read in Intergraph and Microstation binary models (.dgn 
files) up to V7. Microstation V8 has a new undocumented format.

Because of the limited number of levels available in an DGN file, the colour, linestyle and weight 
of items are often used to differentiate data types. For special files for VicRoads, there is also an 
DGN attribute which can be used to tag data.

Hence the entity-name used for matching in a map file when reading DGN files into 12d Model 
can be either the:

▲ DGN level

▲ VicRoads attribute 

▲  DGN level, colour, linestyle, weight

▲ VicRoads attribute, colour, linestyle, weight

In the DGN map file, the four level key is given as a single key made up of the four items 
separated by | (with no additional spaces) in the order:

level or VicRoads attribute | colour | line style | weight 

For example, the key

30|2|0|0 means level 30, colour 2, style 0 and weight 0

A * can be used for any of the four items to indicate that no match is required for that item.

30|*|0|* means level 30, any colour, style 0, any weight

If a map file is not used, the DGN data is read into a 12d Model string of the same name as the 
DGN level and the DGN colour numbers are mapped to 12d Model colours. All the strings 
created go to the ’Default model for data’ specified in the Read DGN Data panel.

See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Text for Points in DGN
A further complication with DGN is that many Microstation users record individual points as a 
text entity with a character from a possibly user defined DGN font to represent a symbol at the 
point. The text then often has a justification other than left-bottom.

 However, Microstation does not record the (x,y) co-ordinates of the justification point but only 
the left-bottom position to draw the symbol at. The actual (x,y) point needs to be calculated from 
the text justification and the actual symbol size.

Unfortunately this requires a knowledge of the DGN font symbol being used to calculate the true 
(x,y) position for the text justification point.

To help read in text as points so that they may be included in processes such as triangulation, in 
the DGN reader, it is possible to create 4d strings (which consist of an (x,y,z) point plus a piece of 
text) instead of a text string.

 Warning

Because of the problem with needing to know the DGN font information to correctly calculate 
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the (x,y) co-ordinate of the text, creating a 4d string instead of text will not fix the error in the 
(x,y) co-ordinates if an incorrect font is used in 12d Model.

The only safe solution is to avoid data in DGN format if the points are being represented by text.

NOTE: the format for DGN V8 has been changed and has not been published. There is a beta 
version of the DGN reader to try and read DGNV8. At this stage it is probably better to use DWG 
I/O to go in and out of Microstation V8.

On selecting the DGN option, the read DGN data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

DGN file input *.dgn files

name of the DGN binary file to be read in

Map file input *.mf files

if non-blank, the name of the map file to be used for all strings read in.
If blank, no map file is used.The DGN level is used as the string name and all strings go to the ’Default 
model for data’.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Key for mapfile input VicRoads       level, VicRoads,
                         level/colour/linestyle/weight
                          Vicroads/colour/linestyle/weight

specifies how the key from the mapfile is interpreted.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Default model for data input available models

model to use for strings not mentioned in the map file or if no map file is used.
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2d file Z values input Fixed at 0.0 fixed at 0.0,
                                   contour Z low, contour Z 

high
                                   element Z low, element Z 

high

z value to use for 2d .dgn file

Arc interval input 10

interval to use to break 3d circles are broken up into segments.

Chord-arc tolerance input 0.1

chord to arc tolerance to use when breaking 3d circles into segments.

Text as 4d strings tick box

if tick, text is read in as a 4d string (an (x,y,z) co-ordinate plus a piece of text)

Map from DGN Colours tick box

if not tick, DGN colour number n is mapped to 12d Model colour n. 
if tick, some of the DGN colours are attempted to be mapped to 12d Model colours.

Translate DGN faces to faces tick box

if tick, DGN faces are read in as 12d Model face strings.

Read button

read the data in.

Read_DGN_Data__Complex_Elements_.bmp

DGN With Complex Elements
This option reads DGN complex elements as super strings.

Note: this option is under development

NOTE: the format for DGNV8 has been changed and has not been published. There is a beta 
version of the DGN reader to try and read DGN V8. At this stage it is probably better to use 
DWG I/O to go in and out of Microstation V8.

On selecting the DGN Complex Elements option, the read DGN Data (Complex Elements) panel is 
displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

DGN file input *.dgn files

name of the DGN binary file to be read in

Map file map file box *.mf files

if non-blank, the name of the map file to be used for all strings read in.
If blank, no map file is used.The DGN level is used as the string name and all strings go to the ’Default 
model for data’.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Key for mapfile input VicRoads       level, VicRoads,
                         level/colour/linestyle/weight
                          Vicroads/colour/linestyle/weight

specifies how the key from the mapfile is interpreted.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Default model for data model box available models

model to use for strings not mentioned in the map file or if no map file is used.

2d file Z values input Fixed at 0.0 fixed at 0.0,
                                   contour Z low, contour Z 

high
                                   element Z low, element Z 

high

z value to use for 2d .dgn file

Arc interval input 10

interval to use to break 3d circles are broken up into segments.
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Chord-arc tolerance input 0.1

chord to arc tolerance to use when breaking 3d circles into segments.

Text as 4d strings tick box

if tick, text is read in as a 4d string (an (x,y,z) co-ordinate plus a piece of text)

Complex chains as super alignments tick box

if tick, DGN complex chains are read in as super alignments.

Map from DGN Colours tick box

if not tick, DGN colour number n is mapped to 12d Model colour n. 
if tick, some of the DGN colours are attempted to be mapped to 12d Model colours.

Translate DGN faces to facest tick box

if tick, DGN faces are read in as 12d Model face strings.

Read button

read the data in.

Read_DGN_V8_File__Pre_Beta___Under_Development_

DGN V8
NOTE: the format for DGN V8 has been changed and has not been published. There is a beta 
version of the DGN reader to try and read DGNV8. At this stage it is probably better to use DWG 
I/O to go in and out of Microstation V8.

Note: this option is under development

On selecting the DGN V8 option, the read DGN V8 File panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

DGN file input *.dgn files

name of the DGN V8 binary file to be read in

Index map file input *.imf files

Map file map file box *.mf files
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if non-blank, the name of the map file to be used for all strings read in.
If blank, no map file is used.The DGN level is used as the string name and all strings go to the ’Default 
model for data’.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Key for mapfile choice box        Levels
                         Level/Colour/Linestyle/Weight

specifies how the key from the mapfile is interpreted.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Read button

read the data in.
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DWG/DXF Input
read_dwg_dxf_data
DWG/DXF input is a separate chargeable option

Position of option on menu: File I/O =>Data input =>DWG/DXF

The DWG/DXF input option is designed to read most Autocad DWG and DXF files.

Each DWG/DXF item has an associated layer. By default, 12d Model creates models of the same 
name as the layers (or with an additional user supplied prefix) and the DWG/DXF items placed 
in them.

However, this can be over written using a standard 12d map file where the key is matched 
against Autocad layers rather than string names.

 See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Autocad blocks are recognised and either a point with the block name is created or the blocks are 
expanded into their components, each time they are referenced in the DWG/DXF file. 

Bulges in polylines can only be interpreted correctly when the polyline has a constant z-value. 
For this case, a 12d Model polyline string is created from the DXF polyline.

Finally, DWG/DXF POINT entities of the same layer and colour can be concatenated into one 
point string as they are read in.

On selecting the DWG/DXF option, the Read DWG/DXF Data panel is displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Format choice box DWG DWG, DXF

type of Autocad file to read in

File file box *.dwg or *.dxf files

name of the DWG or DXF file to read in

Map file map file box *.mf files

if non-blank, the name of the map file to be used for all DWG/DXF layers read in. The DWG/DXF 
layer is the entity-name for matching against the key in the map file.
 If blank, no map file is used.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Target layer input

if non-blank, only autocad items in the layer with the name given in the target layer field will be read 
in.

Null level value  input -999

z-value to treat as a null level

Default AutoCAD lineweight input 0.25

lineweight to use when it is undefined in an AutoCAD entity.

Spline approximation  input 12

splines are broken into small segments

Blocks choice box to symbols to symbols, explode, to points

if to symbols, blocks are read in as 12d Symbols of the same name.
If explode, blocks are read in and exploded into vertices and line work.
If to points, a 12d vertex is created at each block.

Names choice box layer for name no name, layer for name

if no name, strings are not given a name.
If layer for name, strings are given the name of the AutoCAD layer they were on.

Images choice box to plan images to plan images, to rasters, ignore

Only create visible symbols tick box tick

Translate 3DFaces to facest tick box

if tick, DWG/DXF faces are read in as 12d Model face strings.

User 12d ACAD colour numberst tick box

Create 2d/3d polys from ctrl points tick box

Head to tail points/lines tick tick

if tick, DWG/DXF POINT entities of the same layer and colour are concatenated into one point 
string as they are read in and DWG/DXF LINE entities of the same layer and colour are 

Only load visible layers tick tick

if tick, only DWG/DXF visible layers are read in otherwise all layers are read in.

Load paper space tick no tick

if tick, paper space data will be read in.
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Read button

read the data in.
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Genio File Format
Genio input is a separate chargeable module.

Position of option on menu: File I/O =>Data input =>Genio

The software package MX (formerly called Moss) includes a data file format called GENIO for 
use in transferring data between Moss and other programs (see the MX Manual for a partial 
description of genio). There is currently two default genio input formats - versions 6 and 7. 
12d Model recognizes both formats.

MX provides three options (001,003,017) to allow variations in the format of the genio 080 
records. 12d Model recognizes and uses each option.

MX free format (that is, using commas and the ’field-number=’ syntax) is allowed.

For example

080,ABCD, ,5=0.0

MX 2d, 3d, 4d, 6d, text and most 12d and text strings are loaded directly into 12d Model strings. 
For 5d, the strings are processed but only the 3d information is used and loaded into 12d Model. 
The MX 10d (volume string) is allowed in the genio file but will not be read into 12d Model.

In the genio file, the GENIO card defines the name of the MX model for the following strings. 
12d Model loads the strings into a 12d Model model with the same name as the MX model. 
However, 12d Model allows the user to define a map file which may over-ride the Genio card.

A genio file may contain more than one MX model, each genio model being separated by a 999 
card. 12d Model will load each separate MX model into a 12d Model model with the same name 
as the MX model.

If an error occurs whilst reading a genio record, the genio record will be skipped and, if possible, 
the next genio record read.

12d Map File

See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

The name of the MX string is used as the entity-name to be used for matching with an 12d map 
file.

The MX model given in the GENIO record is taken to be the default model for the genio reader.

Hence the genio map file can be used to over-ride the MX GENIO card and the MX default for 
point strings (this is necessary for genio files generated from non MX systems that don't use the 
correct point string convention).

For text in a Genio file (the string name for text must start with a * in the Genio file), the key in the 
map file must start with geniotext followed by the characters to match on which will be matched 
against the characters following the * in the genio string name. For example

geniotextEB* * text  yellow  point "PHCP" // matches text 
will match any Genio text with the string name starting with "*EB"

Note that * is not a wild card in the Genio string name but the "EB*" after "geniotext" is for use by 
the 12d map file and hence is an "EB" followed by a wild card. Hence it matches against any 
Genio text name starting with "*EB".

Summary

12d Model recognizes the following genio options for MX V6 and V7 formats -

GENIO
FINISH
001 format card
003 order card
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017 angle card
080 for 2d, 3d, 4d, 6d, 12d and text strings
080 the 3d information only for 5d strings
090 triangulation information
999
genio comment lines

12d Model accepts MX null values of -999.0

12d Model ignores the genio options:

080 for 10d strings

A12d map file can be used to select the colour and model for any strings read in from the MX 
genio file whose names match the keys in the map file.
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Genio Input
read_genio_data

Position of option on menu: File I/O =>Data input =>Genio

Genio input is a separate chargeable module.

For information on the Genio file format support by 12d Model, please go to the section “Genio 
File Format” 

On selecting the genio option, the read genio data panel is displayed.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

File to read file box  default *.mos files
This can be modified by the
environment variable
GENIO_WILDCARD_4D

name of the genio file to be read in

Advanced tick box

if tick, a grid to allow multiple files to be read in, is opened. A wild card is used to select all the files to 
be read in.
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Folder folder box

folder to search for files using the Wild card

Wildcard input

wild card to use in search for files in the given folder

Use tick box

if tick, read in the file

Files output

name of the file in the folder

Size output

 file size

Pre*post text input

if non blank, pre*post text to use for the models in this file (see “Pre*Postfix Panel Fields”  for 
information on using pre*postfix.
If blank, use the pre*post text from the Pre*postfix for models panel field.

Note - if a non-blank value for Pre*post is given in the column for a file then the Pre*postfix for 
models is ignored.

Map file file box *.mf files

if non-blank, the name of the 12d map file to be used for all strings read in, including any files given 
with the Advanced mode ticked on. 
If blank, no map file is used

When using a map file, the string name is used as the entity-name for matching with the keys in the 
map file. See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Note - if a non-blank value for Pre*post is given in the column for a file then the Pre*postfix for 
models is ignored.

Line colour colour box default colour available colours

colour used for line-strings

Point colour colour box default pt colour available colours

colour used for the crosses in point-strings (genio string labels starting with P).

Text height (pix) input 8

the height in pixels of any text in a moss 4d string.
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Text offset (pix) input 2

the offset in pixels of the 4d text from the (x,y) position.

Compress 3d to 2d tick box tick

if tick, convert any 3d strings with constant z-value to 2d strings.

Convert 6d to alignment tick box tick

if tick, convert any 6d strings to 12d Model alignment strings.

Local origin x y box x y selector

if non-blank, the given co-ordinates are used as a local origin when reading in the data.That is, the 
local origin values are subtracted from each data point as it is read in.

Smigs file ? tick box no tick

if tick, try to interpret the genio file as a Smigs genio file.

Use super strings tick box tick

if tick, all strings are read in as super string

Use invisible segments for discontinuities tick box

if tick, MX strings with discontinuities are read in as super strings with invisible segments.
If not tick, MX strings with discontinuities are broken into pieces when read in.

G strings to super alignments tick box no tick

if tick, MX G strings are read in as 12d super alignments

Debug G strings tick box no tick

because of the lack of documentation of the G string in MX, a G string may not be interpreted correctly. 
If tick, a super string is created with the information from the MX G string to try and help interpret 
what the data was.

Reverse calc super alignments   tick box no tick

Better way of interpreting VG tick box tick

if tick, a different method for interpreting vertical geometry in a MX G strings is used.
This may or may not be successful.

Read button

read in the genio data from the file given in the file field.

Example of Genio 12d Map File
// 
// 12d map file (for input data)
// 
// This file allows strings to be mapped to specified models/colours/string types/ styles
// as they are read in.
// 
// The columns are:
// 1        key       2        string name      3        model name
// 4        colour name (or number)     5        string type (point or line)      6        string style

//   1 2 3 4 5 6 comment
 
PHCP * mapp      yellow      point "PHCP" // horizontal control point
PVCP * mapp yellow point "PVCP" // vertical control point
PABB * struct magenta point "AB" // bottom bridge abutment
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PCBU * struct magenta point "CB" // corner of building at ns
CUL* * embank red          line "EB" // top of cutting left
RES*         * utilit       green        line  1 // reservoir
BE*          * cadast     green       line  "EP" // easement boundary
VT*          * roads yellow       line  "BB"   // vehicular track edge
WC*          * drain        cyan         line   "EP"  // watercourse drain dry
X*           * surv         red          line  "XO01" // contour depression
Z*          * cont         white        line "ZO01" // indicator contour
B*           *  cadast       green        line  1 // title boundary
F*           *  fence        magenta line "F_FENCE" // fence
R*           * rail         white  line  "RAILINE"  // top of rail
X*           * surv         red  line  "XO01" // contour depression
Z*          * cont         white line "ZO01" // indicator contour
geniotextEB* * text  yellow point "PHCP // matches text starting EB
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Geocomp File Format
Geocomp input is a separate chargeable module.

Geocomp is a software package used for manipulating and reducing survey data on a PC.

Geocomp is a point based system. The fundamental data consists of individual points with 
unique point numbers and entities such as lines and arcs defined in terms of the points.

Geocomp has an ascii data format consisting of two files - the points file and the strings file. 
These ascii files can be used to transfer data from Geocomp to 12d Model.

The Geocomp points file is a sequential list of points, one point per line. Each point consists of 
the data

easting, northing, elevation, stand-point-number

that is

x-value, y-value, z-value, stand-point-number

The line number of each point in the file is also the unique point number for that point. For 
example, the point defined on the eleventh line of the points file, is point number eleven.

The stand-point-number is the point number of the instrument station used for collecting the 
points co-ordinates. The stand-point-number is not used in 12d Model.

The Geocomp strings file defines how the Geocomp entity types are constructed from points in 
the point file. The Geocomp entity types are

Entity Number Description

1 two point lines
2 irregular lines
3 arc defined by start point, point on arc, end point
4 arc defined by start point, arc centre, end point
5 point feature
6 circle defined by centre and a point on the circle

The strings file also gives each defined entity an entity number.

The 12d Model Geocomp data reader recognises all the entity types in the strings file except for 
irregular lines (type 2).

All point numbers referred to in the strings file are references to the (implied) point numbers of 
points in the points file. Hence both files are needed to define the Geocomp data and the order of 
points in the point file is critical and cannot be modified.

The Geocomp naming convention for the two files is to use the six digit Geocomp job number as 
a name stem and append .pts for the points file and .str for the strings file.

That is,

geocomp-job-number.pts points file
geocomp-job-number.str strings file

For example

099999.pts is the point file for Geocomp job number 099999
099999.str is the strings file for Geocomp job number 099999

12d Model uses a wider data set than is directly represented in the Geocomp points and strings 
files. However, by observing a number of conventions and processing the strings file data 
according to these conventions, the Geocomp data can be sensibly passed across to 12d Model.

For example, although the Geocomp strings file only defines two-point lines, 12d Model can 
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construct strings of many points from consecutive two-point lines by joining the lines together 
whenever

(a) the second point of one line is the same as the first point of the next line in the file
and
(b) the lines have the same entity number.

The entity number of the consecutive lines is used as the 12d Model string name.

Similarly, consecutive point features with the same entity number are joined to form a 12d Model 
4d point string with the entity number as the string name.

In the Geocomp strings file, descriptive text can also be included at the end of each line defining 
an entity. The text is enclosed within double quotes ". The descriptive text is ignored for all 
entities except point features.

For a point-feature, which is represented in 12d Model as a 4d string, the descriptive text is 
recorded as the text label for that point.

By using a systematic entity and descriptive text labelling system in Geocomp, it is possible to 
sensibly transfer all of the Geocomp data to 12d Model.

Note - in Geocomp, a z-value of -9999 represents a null z-value, that is, a z-value that has not 
been defined. Any Geocomp null values are recorded as 12d Model null values.

Geocomp Map File

See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Using the conventions described in the previous section, Geocomp data can be interpreted as 
12d Model strings with entity-names corresponding to the Geocomp entity numbers.

Hence the Geocomp entity numbers are used as the entity-names for matching with a map file.

If no match is found with the map file, the default colours and model given in the Geocomp read 
panel are used. The point-line type is taken to be point for point feature entities (entity type 5) 
and line point-line type for all other entities. The geocomp entity number is used as the string 
name and the style set to 1.

WARNING

If the breakline type in the map file is set to point or line and this does not match the point or 
string type coming from the geocomp file, then the string is placed in the defaults model. This is 
a consistency check for entities that can only be a point or a line breakline type (but not both). To 
disable this feature, a * can be used in the map file for the breakline type and then the breakline 
type is determined by whether the Geocomp entity is a point feature or not.

Summary

12d Model recognizes the following Geocomp entity types

Entity Number Entity type

1 two point lines
3 arc defined by start point, point on arc, end point
4 arc defined by start point, arc centre, end point
5 point feature
6 circle defined by centre and a point on the circle

12d Model recognizes the Geocomp null values of -9999

12d Model ignores the entity type 

2 irregular lines

A Geocomp map file can be used to specify the string name, breakline type, colour, style and 
model for strings read from the Geocomp ascii files.
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Note - the breakline type of a string of Geocomp point features (entity type 5) will always be set 
to point regardless of the Geocomp map file.
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Geocomp Input
geocomp_input

read_geocomp_data

Position of option on menu: File I/O =>Data input =>Geocomp

Geocomp input is a separate chargeable module.

Although there are three Geocomp Input options, V4.0 uses super strings and supersedes V3.1 
and V3.2. More information on the Geocomp data structure is given in the previous section 
“Geocomp File Format” .

On selecting the Geocomp option, the Read Geocomp Data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Geocomp file (?.pts) file box *.pts files

name of the Geocomp points file to be read in. The corresponding strings file is also used.

Map file map file box *.mf files

if non-blank, the name of the map file to be used for all strings read in.
If blank, no map file is used.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
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Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Use mapfile model tick box no tick
 when pt/line changes

if tick, then if the geocomp.str file says the entity is a line (point) feature and the map file says it is a 
point (line), the mapfile is used.

Default model model box available models

model to use for strings not mentioned in the map file

Default line colour colour box default colour available colours

colour used for line-strings

Default point colour colour box default pt colour available colours

colour used for the crosses in point-strings.

Null level input -9999

the Geocomp z-values to be considered null z-values.

Text height (pix) input 8

the height in pixels of any text created for point number or Geocomp descriptions.

Text offset (pix) input 2

the offset (in pixels) from the (x,y) co-ordinate position for the text of a 4d string.

Automatic descriptions tick box

if tick, then the first three characters of the entity code are compared to the first 3 characters of the 20 
character description and if they are the same, the text is only characters 6 to 15 of the description.

Start of description input

the user can restrict the amount of the geocomp description that is read in. if non-blank, this is the 
number of the character position to start reading the description from. If blank, the start position is 1.

Finish of description input

 if non-blank, this is the number of the character position to end reading the description from. If blank, 
it is the end of the geocomp description.

Read irregular lines as lines tick

if tick, Geocomp irregular lines are read in as strings.

Create strings as input Super Strings Polyline Strings
Super Strings

type of strings to create.

Match angles tick tick

if tick, preference is given to joining geocomp lines of similar angles first.
if not tick, geocomp lines are joined in the order they are in the file.

Read button

read in the Geocomp data from the points file and (corresponding strings file) given in the file field.
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Keays Input
read_keays_data

Position of option on menu: File I/O =>Data input =>Keays

The Keays input option is designed to read in Keays (RoadPak) files in trf format.

The Keays data has a code and notes, and the code and notes can be used with a 12d Model map 
file to define models, colours, linestyles etc.

The Keays note is made up of individual notes separated by spaces. Each individual note (in 
order) can be used as part of the entity-name for use with the map file.

In the Keays map file, the multi-level key is given as a single key made up of the required items 
separated by | (with no additional spaces) in the order:

Code | note 1| note 2 | ... | note n

For example, the key:

BD|building| means code BD, note 1 = "building"

A * can be used for any of the items to indicate that no match is required for that item.

BD|*|top| means code BD, anything for note 1, note 2 = "top"

A * and nothing else after the code means that all notes are accepted.

BD* means code BD and any notes

A * at the end of the notes means any note is a match from that point onwards.

BD|*|top|* means code BD, anything for note 1, note2 = "top",
and any note after note 2.

If a map file is not used or no match is found in the map file, the Keays data is placed into the 
default model with its code as the string name.

See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

On selecting the Keays option, the Read Keays Data panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Keays file file box *.trf

name of the Keays trf file to be read in.

Map file map file box     *.mf files

if non-blank, the name of the map file to be used for all strings read in. If blank, no map file is used.
The Keays code and note can be used as the entity-name to match against the key in the map file.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Key for map file input code    code, code/note

if code, the Keays code is used as the key for the map file.
If code/note, the Keays code and note is used as the key for the map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Default model for data model box available models

name of the model that any unmapped data is placed in. The model will be created if it does not already 
exist. This field must be filled in.

Null height input -999

if non-blank, any Keays z values equalling this value are taken as null values.

Line colour colour box red available colours

colour for Keays string s.
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Point colour colour box yellow available colours

colour for Keays points that are not part of strings.

Text units input pixels  pixels, world

units for the height of the text label.

Text height (u) input

height of the text (in text units).

Text offset (u) input

distance (in text units) to offset the text from its (x,y) placement position.

Text angle input 0

angle of the note text.

Create strings as input Super Strings 3d, 4d, Polyline, Super

type of strings to create.

Use unique notes per string tick box

if tick, a change of code or note is used to break Keays string data into strings. This also applies to the 
point ids and notes text.

Use encryption tick box

if tick, then the last 4 characters of the code is used to denote tinability and boundary information.

Read button

read the data in.
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LandXML Input
read_landXML_file

Position of option on menu: File I/O =>Data input =>LandXML

LandXML is a format that attempts to cover some civil and surveying entities. It does not include 
any information such as colours, styles etc. but just some geometry definitions.

Unfortunately to make the format useful, every vendor has their own proprietary extensions 
which makes the format of only limited value. A different tailored LandXML reader is required 
for each vendor variation.

Also the methodology behind the LandXML model is based on US ideas of using X-sections and 
not strings to model data. 

12d Model has special LandXML readers for LINZ-XML (for LandOnline NZ) and Leica-XML.

LandXML 

One possible use of LandMXL may be to get access to data from vendors packages such as 
AutoCAD and Microstation who only have non-published proprietary formats.

This option is under continual developed as the LandXML standard keep changing.

On selecting the LandXML option, the Read LandXML File panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File file box *.xml files

name of the LandXML file to be read in

Map file map file box     *.mf files
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if non-blank, the name of the map file to be used for all strings read in.
If blank, no map file is used.

See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Load tick box

Name

Model model cell available models

model to read the data into

Colour colour cell available colours

colour to use for the strings

Linestyle linestyle cell available linestyles

linestyle to use for the strings

Weight input

weight to use for the strings

Read button

read the data into the model given in the model field.
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Mapinfo Input
read_mapinfo_mif_tab_data

mapinfo_input_mapping

Position of option on menu: File I/O =>Data input =>Mapinfo MID/MIF

This Option is currently under development.

On selecting the 12d data option, the Read 12d Solutions Ascii Data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File format choice TAB TAB, MIF

the MApInfo format

File to read file box *.tab or *.mif files

name of the MapInfo file.

Advanced tick box

if tick, a grid to allow multiple files to be read in, is opened. A wild card is used to select all the files to 
be read in.

Folder folder box

folder to search for files using the Wild card

Wildcard input

wild card to use in search for files in the given folder

Use tick box
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if tick, read in the file

Files output

name of the file in the folder

Size output

 file size

Pre*post text input

if non blank, pre*post text to use for the models in this file (see “Pre*Postfix Panel Fields”  for 
information on using pre*postfix.
If blank, use the pre*post text from the Pre*postfix for models panel field.

Note - if a non-blank value for Pre*post is given in the column for a file then the Pre*postfix for 
models is ignored.

Map file file box     *.mf files

not yet implemented.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Note - if a non-blank value for Pre*post is given in the column for a file then the Pre*postfix for 
models is ignored.

Map button

After specifying the MapInfo file format and name, click on Map to scan the file and find the names of 
all the attributes in the MapInfo file. A Mapinfo Input Mapping panel is then displayed with a list of 
all the MapInfo attributes in the file. How the attributes are to be mapped and used in 12d Model is 
then specified for each attribute in the panel. For example, the value of an attribute could be used as the 
12d string name.
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If None is selected for an attribute, then the attribute is ignored.
Once the table is completely filled in (no field in the column titled 12d Model can be left blank) then the 
Set button must be selected and then the Finish button selected to remove the Mapinfo Input Mapping 
panel.

Read button

read the data in.
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SDR Map Input
read_sdr_map_data

Position of option on menu: File I/O =>Data input =>SDR Map

The SDR Map input option is designed to read in files in the SDR Map ASCII format.

On selecting the SDR Map option, the Read SDR Map Data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

SDR Map file file box *.txt

name of the SDR Map ascii file to be read in.

Map file map file box     *.mf files

if non-blank, the name of the map file to be used for all data read in.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Key for map file choice box code    code, layer
code/layer, layer/code

if code, the SDRmap code is used as the key for the map file.
If layer, the SDRmap layer is used as the key for the map file.
If code/layer, the SDRmap code/layer is used as the key for the map file.
If layer/code, the SDRmap layer/code is used as the key for the map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
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Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Use SDR Map styles tick box

if tick, 

Ignore characters after delimiter input

if non-blank, all characters on the line after the given delimiter will be ignored.

Use SDR Map styles tick box

if tick, 

Use -10000 as null height tick box tick

if tick, any z value of -10000 is converted to a null height in 12d Model.

Null height input -999

if non-blank, any SDR Map z values equalling this value are converted to null values in 12d Model.

Point colour colour box yellow available colours

colour for SDR Map points that are not part of strings.

Text units input pixels  pixels, world

units for the height of the text label.

Text height (u) input

height of the text (in text units).

Text offset (u) input

distance (in text units) to offset the text from its (x,y) placement position.

Match flags tick box

SDRMap data consists of individual lines and arcs. When reading SDRMap data, it undergoes head to 
tail processing and the match flags specify what SDRMap data can be joined.

Match layer/code/linetype/angles/pen tick box

if tick, then any SDRMap lines and arcs must have the same layer/code/linetype/angle/pen before they 
can be joined in the head to tail process.

Read button

read the data in.
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TP Setout Input
read_tpsetout_data

Position of option on menu: File I/O =>Data input =>TP Setout

The TP Setout input option is designed to read in .pta files from TP Setout

On selecting the TP Setout option, the read TP Setout data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

TP Setout file file box *.pta

name of the TP Setout .pta file to be read in.

Basic tab

Map file map file box     *.mf files

if non-blank, the name of the map file to be used for all strings read in. If blank, no map file is used.
The TP Setout code is used as the entity-name to match against the key in the map file.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Pre*postfix for models pre*postfix box

if non-blank, a prefix and a postfix to be applied to the model names used in the mapping file.
Go to the section “Pre*Postfix Panel Fields”  for information on using pre*postfix.

Default model for data model box available models
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name of the model that any unmapped data is placed in. The model will be created if it does not already 
exist. This field must be filled in.

Null height input -9999

if non-blank, any TP Setout z values equalling this value are taken as null values.

Line colour colour box red available colours

colour for TP Setout strings.

Point colour colour box yellow available colours

colour for TP Setout points that are not part of strings.

String points tick box tick

if tick, points with the same description are joined together.
If not tick, points with the same description are not joined together. 

Textstyle data textstyle data box available textstyle datas

textstyle data used for any text labels

Coding tab

Point ids in column 5 tick box

if tick, there are points ids in column 5 of the file.

Feature code input

number of characters in the feature code

String number input

number of characters in the string number

Point ids input

number of characters in the point ids

Attributes tab

Name

Type

Data

Read button

read the data in.
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TP Stakeout Strings Input
read_tp_stakeout_binary_strings

Position of option on menu: File I/O =>Data input =>TP Stakeout strings

The TP Stakeout strings input option is designed to read in .3db files (binary strings) from 
TP Stakeout.

On selecting the TP Stakeout strings option, the Read TP Stakeout Binary Strings panel is 
displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File radio button

if on then an individual binary string file is to be read in.

File name file box     *.3db files

if non-blank, the name of the binary string file to read in.

Folder radio button

if on then the all the binary string files in the folder are to be read in.

Folder name folder box

if non-blank, all the binary string files in this folder are read in.

Default model for data input available models

name of the model to read the binary strings into.

Read button

read the data in.
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Old Inputs
old_data_input

Position of menu: File I/O =>Data input =>Old

The Old menu contains superseded options. The Old walk-right menu is

12D HP Plot File
read_4D_hp_plot_file

Position of option on menu: File I/O =>Data input =>Old =>4D HP plot

12d Model has options to create plots for HPGL compatible plotters. This option reads back into 
12d Model any plots created by 12d Model using HPGL plot options.

A plot file is only a two dimensional file defined in millimetres. When read back into 12d Model, 
the units are automatically multiplied by 1000.

In the option, the user can supply a further factor to multiply the x and y co-ordinates by and 
also a z-value which is used as a z co-ordinate for all the lines in the plot file.

On selecting the 12d HP plot option, the read 4D HP plot file panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

HP plot file input *.hp files

name of the 12d HP plot file to be read in

z value input 0.0

z co-ordinate to use for the lines read in from the plot file

Factor input 1.0

 the default units used when reading in a plot file are multiplied by 1000. They are then multiplied by 
this value.

Model for plot input available models
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name of the model that the plot file is to be placed in. The model will be created if it does not already 
exist. This field must be filled in.

Add to view input available views

if a view name is entered, then the model will be automatically added to the view. This field can be 
blank.

Read button

read the plot file into the model given in the model field.

DXF Input
read_dxf_data
Position of option on menu: File I/O =>Data input =>Old =>DXF

DXF input is a separate chargeable option

The DXF input option is designed to read most autocad DXF files (up to Version 12), including 
binary DXF which was introduced in AutoCAD Release 10 as a means of addressing the 
problems of large file sizes, slow processing and limited accuracy that occur when using the 
ASCII DXF format. 12d Model will automatically sense whether the input file is binary or ASCII.

The standard Autocad colours can be mapped to the equivalent 12d Model colours or just 
mapped on a one-to-one basis to 12d Model colour numbers.

Each DXF item has an associated layer. By default, 12d Model creates models of the same name 
as the layers (or with an additional user supplied prefix) and the DXF items placed in them.

However, this can be over-written using a standard 12d map file where the key is matched 
against Autocad layers rather than string names.

See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

 Autocad blocks are recognised and either a point with the block name is created or the blocks 
are expanded into their components, each time they are referenced in the DXF file. 

Bulges in polylines can only be interpreted correctly when the polyline has a constant z-value. 
For this case, a 12d Model polyline string is created from the DXF polyline.

Finally, DXF POINT entities of the same layer and colour are concatenated into one point string 
as they are read in.

On selecting the DXF option, the read dxf data panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

DXF File input *.dxf files

name of the DXF file to be read in

Map file input *.mf files

if non-blank, the name of the map file to be used for all DXF layers read in. The DXF layer is the entity-
name for matching against the key in the map file.
 If blank, no map file is used.
See the section “Map File” in chapter “File I/O”  for information about an 12d map file.

Prefix for models input

if non-blank, all 12d Model model names created by the reader will be prefixed by this name.

Colour for dxf black  input white available colours

if the DXF colour of an item is black, then the colour in the colour for black field is used for the item in 
12d Model.

Target layer input

if non-blank, only autocad items in the layer with the name given in the target layer field will be read 
in.

Explode blocks tick no tick

if tick, autocad blocks are exploded in 12d Model.
If not tick, blocks are not exploded and a point string is placed at the position of the block.

Map DXF colours tick no tick

if tick, the first seven DXF colours are mapped to the corresponding default 12d Model colours.
If no tick, the nth DXF colour is mapped to the nth 12d Model colour.

Create unknown textstyles tick tick

if tick, then if a textstyle in the DXF file is not already defined in 12d Model, then a new 12d Model 
textstyle of the same name is created.
If no tick, then the 12d Model textstyle "1" is used for any unknown DXF textstyles.
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Translate 3DFaces to facestick no tick

if tick, DXF faces are read in as 12d Model face strings.

Colour for large dxf colours       input red available colours

if the DXF colour is greater than the largest colour number defined in the 12d Model colour map, then 
the colour in the colour for large dxf colours field is used for the DXF colour.

Read button

read the data in.
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data_output

Position of menu: File I/O =>Data output

12d Model provides output options so that data in a model or on a view can be written out to a 
disk file. this may be to allow data to be transferred to other programs for further processing or 
simply to get a readable list of data.

The default Output null value is described in the section “Output Null Value”  

The data output walk-right menu containing these options is

For the option 12da data, please continue to the section “12d Ascii Output” .
ArcView SHP “ArcView SHP Output” 
x y z s  “X Y Z S Output” 
x y z s pt_no  “User X Y Z S Output” 
x y z s ch offset  “User X Y Z Chainage and Offset Output” 
New x y z s ch offset  “User X Y Z Chainage and Offset Output” 
x y z general  “User X Y Z S and Attributes Output” 
DGN  “DGN Output” 
DGN V8  “DGN V8” 
DWG/DXF “DWG/DXF Output” 
Genio  “Genio Output” 
LandXML  “LandXML Output” 
MapInfo “MapInfo Output” 
Civilcad V5.0  “Civilcad” 
Geocomp  “Geocomp” 
TP Stakeout triangles  “TP Stakeout Triangles Output” 

write out data in 12d Model Ascii format
ArcView SHP file
x y z s data
user specified x y z s point no data
user specified x y z chainage and offset
new user specified x y z chainage and offset
user specified x y z s point no and attribute data
DEM data
DGN binary
DGN V8
DXF/DWG file
MX (Moss)genio data
LandXML data
MapInfo data
MapInfo data (new)
Civilcad V5.0 file
Geocomp pts and str files
TP Stakeout triangles
TP Stakeout binary strings
Old formats
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TP Stakeout strings  “TP Stakeout Strings Output” .
Old  “Old Outputs” .

Output Null Value
When writing out data for other systems, it is usually not appropriate to write out the internal 
12d Model null height (- 9.9e29).

Consequently as data is written out, any 12d Model null heights are replaced by the value given 
by the I/O null height parameter.

The I/O null height is set in Default Settings tab of the Defaults panel in the option 
Utilities=>Defaults.
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12d Ascii Output
write_12d_Solutions_ascii_data

Position of option on menu: File I/O =>Data output =>12da/4da data

The 12d ascii (4D Ascii) format is a special text format defined by 4D Solutions (see the 
Appendix) for writing out 12d Model data.This option is used to write out 12d Model data in the 
12d Ascii format.

On selecting the 12d data output option, the Write 12d Solutions Ascii Data for panel is displayed 
as the default choice for Data source.

The Data source field can then be modified for either String, Model or View.

The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

Format choice 12d ascii 12d ascii, 4d ascii

use 12d ascii or 4d ascii format (the only difference is the file name ending)

Ascii file input *.12da or *.4da

name of the file for the information to be written out to in 12d Ascii format. If the file already exists, the 
data will be appended to the file.

Decimal places input 8

number of decimal places used when writing the data out.

Write button

write out, in 12d Ascii format, all the string data specified by the Data source.
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ArcView SHP Output
write_ArcView_shape_files_for

Arcview_output_mapping

Position of option on menu: File I/O =>Data output =>ArcView SHP

This Option is currently under development.

The ArcView Shape File format consists of nine different files containing different data types.

The ArcView shape format has no colour, model or layer information, string names etc. so this 
information has to be passed through as attributes for the data.

On selecting the ArcView SHP option, the Write ArcView Shape Files for panel is displayed.

The fields and buttons used in the Write ArcView Shape Files for panel have the following func-
tions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

File prefix input

prefix to use for the nine different shape files to be produced for the data.

Map button

brings up the ArcView Mapping panel which defines the ArcView attributes to write the standard 12d 
Model string header information to.

Write button

write out, in ArcView shape file format, all the string data specified by the Data source.

The fields and buttons used in the ArcView Mapping panel have the following functions.

Field Description Type Defaults Pop-Up

Id ID

if non blank, write out an integer number which increments from 1.

Model LAYER
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if non blank, write out the model of the string to this attribute.

String name NAME

if non blank, write out the name of the string to this attribute.

Colour COLOUR

if non blank, write out the colour of the string to this attribute.

Weight LINEWIDTH

if non blank, write out the weight of the string to this attribute.

Linestyle LINETYPE

if non blank, write out the linestyle of the string to this attribute.

Z value ELEVATION

if non blank, write out the first z-value of the string to this attribute.

Set button

record the attribute names given in the panel as the ones to be use when writing out the data.
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X Y Z S Output
write_xyz_file_for

Position of option on menu: File I/O =>Data output =>x y z s

The xyzs output format is identical to the input format - one point per line with the x y and z 
values separated by spaces.

A string’s colour and label are used as colour records and string labels in the output file.

At this stage, 4d, interface and alignment strings are only output as 3d strings. The use of the 
12d Model ascii file format is suggested for writing out all strings.

On selecting the xyz option, the Write XYZ File for panel is displayed.

The Data source field can then be modified for either View, String or Global.

The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

File input *.dat files

name of the file for the information to be written out to. 

Write button

write out, in x y z format, all the string data specified by the Data source.
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User X Y Z S Output
write_xyzs_pt_no_file_for

Position of option on menu: File I/O =>Data output =>x y z s pt_no

The xyzs output format is identical to the user specified input format - one point per line with 
the x y z s and point number values in a user specified order separated by either delimiters or in 
fixed width columns.

At this stage, 4d, interface and alignment strings are only output as 3d strings. The use of the 
12d Model ascii file format is suggested for writing out all strings.

On selecting the xyzs pt_no option, the Write XYZS pt_no File for panel is displayed.

The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 
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Data source input

source of data is to be written out to a file.

Output mode choice box delimiter delimiter, fixed width

if delimiter, the type of delimiter and the columns for the x, y, z, name and point number are given 
(and are all optional).
If fixed width, the start and end column positions are given for x, y, z, name and point number which 
are all optional.

Output Settings

Number of decimal places input box 3

number of decimal places to use in the x, y and z values.

Default for null value input box -999

value to write out for z when it is a null value in 12d Model.

Include column names tick box

if tick, the names x, y, z etc. are written out in the appropriate columns as the first line of the file.

File input *.dat files

name of the file for the information to be written out to.

Write button

write out all the string data specified by the Data source.
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User X Y Z Chainage and Offset Output
write_xyzch_file_for

new_write_xyzch_file_for

Position of option on menu: File I/O =>Data output =>x y z s ch offset

Position of option on menu: File I/O =>Data output =>New x y z s ch offset

The New xyz ch offset option was introduced in V7C1g and will replace the standard option.

The difference is that the new option turns off the panel fields that are not required.

The xyz and ch output option writes out the x, y, z and chainage values for each string or a 
centreline string can be selected and the x, y, z and chainage values from the original string are 
output along with the chainage and offset from the selected reference string.

On selecting the xyzs ch offset option, the Write XYZSCH File for panel is displayed.
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The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

Write button

write out all the data specified by the Data source.

General tab

Number of decimal places input box 3

number of decimal places to use in the x, y, z and chainage values.

Default for null value input box -999

value to write out for z when it is a null value in 12d Model.

Include column names tick box

if tick, the names x, y, z etc. are written out in the appropriate columns as the first line of the file.
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Output File input *.dat files

name of the file for the information to be written out to.

Report at string points tick box

if tick, the values are output for the points (vertices) of the strings from the data source. If a centre line 
has been selected, then the chainage for the centre line is calculated by dropping the string vertex onto 
the centre line.

Report at centreline chainages tick box

if tick, the specified chainages of the selected centre line (given by label mode etc.) are used and then the 
positions on the strings from the data source are calculated by going out at right angles to the centre 
line at the chainage.

Centreline string select

optional - a selected centreline to use for chainages.

Label mode input regular interval,
regular interval plus end pts
end points only
horizontal TPs,
vertical TPs,
horizontal discontinuities
vertical discontinuities
all discontinuities,
 crests/sags
all horizontal points

type of chainages to use from the centreline.

Ch interval or n/a input

the regular interval to use for chainages.

Ch reference input 0

the chainages to user are integer multiples of the chainage interval added to the reference chainage. 
For example, if the reference chainage is 23.2 and the chainage interval 10, the chainages 3.2, 13.2, 
23.2, 33.2 etc. will be used.

Start chainage input

if non-blank, the string chainage to start using.
If blank, start at the beginning of the string.

End chainage input

if non-blank, the string chainage to finish.
If blank, go to the end of the selected string.

Special chainage input

file of special chainages to use.

Chord/arc tolerance input default chord/arc tolerance

the chord to arc tolerance to use on the centreline string for determining how many points are used 
around horizontal curves.

Maximum offset from centreline

if non blank, any vertices further than this distance from the centreline will NOT be written out.
If non blank, all vertices will be written out.

Position tab

Output mode choice box delimiter delimiter, fixed width

if delimiter, then the specified data is written out, each value separated by the delimiter given in the 
Delimiter field.
If fixed width, the specified data is written out to a fixed position on the line. An end position is also 
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given.

String name

if the column number (delimiter) or start-end position (fixed width) is given, then the name of the 
string from the data source is written out. Otherwise it is not written out.

String vertex no

if the column number (delimiter) or start-end position (fixed width) is given, then the vertex number of 
the string is written out.

String point no

if the column number (delimiter) or start-end position (fixed width) is given, then the point number of 
the vertex of the string is written out.

String chainage

if the column number (delimiter) or start-end position (fixed width) is given, then the string chainage 
of the vertex of the string is written out (not the centre line chainage).

String x/y/z

if the column number (delimiter) or start-end position (fixed width) is given, then the x/y/z co-ordinate 
of the position on the string is written out (not the centre line x/y/z).

CL offset

if the column number (delimiter) or start-end position (fixed width) is given, then the offset of the 
string from the centre line is written out.

CL chainage

if the column number (delimiter) or start-end position (fixed width) is given, then the chainage of the 
centre line is written out.

CL x/y/z

if the column number (delimiter) or start-end position (fixed width) is given, then the x/y/z co-ordinate 
of the position on the centre line string is written out.
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User X Y Z S and Attributes Output
write_x_y_z_General_File_for

Position of option on menu: File I/O =>Data output =>x y z general

The xyzs output format is identical to the user specified input format - one point per line with 
the x y z s, point number and attribute values in a user specified order separated by either 
delimiters or in fixed width columns.

In either case, the user specifies the order that the x, y, z, string name, point number and 
attributes appear in the file. Only one or more of the items needs to be written out.

The set-ups for defining all the positions of all the data in the file can be written out to a file (.xyf) 
for re-use. 

At this stage, 4d, interface and alignment strings are only output as 3d strings. The use of the 
12d Model ascii file format is suggested for writing out all strings.

On selecting the xyzs general option, the Write X Y Z General File for panel is displayed.
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The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data to write section

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.
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Parameters section

Parameter file input *.xyf files

name of the file containing the settings for how the data is positioned in the output file.

Read icon button

read the parameter file in.

Write icon button

write the setting in the panel out to a parameter file.

Output settings section

Number of decimal places input box 3

number of decimal places to use in the x, y and z values.

Default for null value input box -999

value to write out for z when it is a null value in 12d Model.

Include column names tick box

if tick, the names x, y, z etc. are written out in the appropriate columns as the first line of the file.

File input *.dat files

name of the file for the information to be written out to.

Output mode choice box delimiter delimiter, fixed width

if delimiter, the type of delimiter and the columns for the x, y, z, name and point number are given 
(and are all optional).
If fixed width, the start and end column positions are given for x, y, z, name and point number which 
are all optional.

Delimiter choice box tab \f one space, tab \t,
semi colon, comma
many spaces

if Output mode is delimiter, then this is the type of delimiter to separate data in the output file.

Column number/Start end position section

information to write out (x,y,z, attributes etc.) and its position in the output file.

Write button

write out all the string data specified by the Data source.
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DGN Output
write_dgn_file_for

Position of option on menu: File I/O =>Data output =>DGN

DGN output is a separate chargeable module.

Using the DGN output option, 12d Model produces DGN binary files (*.dgn files - as defined in 
the public domain by Intergraph Corp) as used by Intergraph and Microstation. Since DGN 
supports 3D facets, the triangles created in 12d Model can be transferred to DGN for use in 
shaded models and walk-throughs.

DGN files are either 2d or 3d. 12d Model can write either type of file. If a 3d file is being written, 
the 12d Model strings will be written out as three dimensional DGN lines. The alignment strings 
and arcs will be approximated by short lines.

If a 2d file is being written, arcs in alignment strings are written out as DGN plan arcs.

When creating a DGN binary file, it is often convenient to append the information to an existing 
DGN file known as a seed file (the seed file usually contains set up information for the DGN 
drawing).

In 12d Model, the user can specify a folder containing seed files by pointing to it using the 
environment variable MS_SEEDFILES_4D. In the DGN output options, the pop-up for the seed 
file panel field displays all the files ending in .dgn in the folder pointed to by 
MS_SEEDFILES_4D.

If the environment variable MS_SEEDFILES_4D has not been set, the pop-up uses the current 
working folder to search for seed files.

It is possible to use an output map file (called a table file) with string name as the key to set DGN 
levels, colours, weight, style and special symbols (see next section). Because of the limitation of 
64 levels in DGN, using a table file is normally the best method of getting data across to DGN.

On selecting the DGN option, the Write DGN File for panel is displayed.
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The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

DGN file input *.dgn

name of the DGN file to write the model/view data out to. If the file exists, it is appended to, and the 
settings for TCB variables are read from the file. If the file does not exist, it is created with default TCB 
settings. The file is created either 2d or 3d depending on the DGN Dimension field.

DGN Dimension input 3d 2d/3d

this field controls the dimension of DGN files created for the case where the file named in the Seed file 
does not exist.

Seed file input files in the seed folder

if non-blank, this field gives the name of the DGN file to be used as a seed file for the DGN output.
The folder containing the seed files, the seed folder, is given by the environment variable 
MS_SEEDFILES_4D. 

Table file input *.tbl file

if non-blank, the file is used as an output map file between 12d Model and the .dgn binary file.

Map DGN Colours tick box

if not tick, 12d Model colour number n is mapped to DGN colour n. 
if tick, some of the 12d Model colours are attempted to be mapped to DGN colours.

Point strings as DGN lines tick box

if tick, 12d Model points go out as DGN two point strings with the same value for each point. 
if not tick, 12d Model points go out to DGN points.

TREE features as text tick box

if tick and their is a table file match for TREE, then 12d Model writes out feature strings of name 
"TREE" as text in DGN. Other feature strings go out as circles. 
if not tick, all 12d Model feature strings go out as DGN circles.

Polylines as complex elements ttick box

if tick and DGN dimension is 2d, 12d Model writes out polylines as complex elements made up of 
lines and arcs. 
if not tick, the polyline goes out as individual lines and arcs.

Output view text tick box

if tick, any view text turned on (point numbers, z-values etc.) are output as text in DGN. 
if not tick, view text is not output.

Write button

write out the all the data specified by the Data source to the file given in the DGN file field.



12d Model Reference Manual

Page 510 April 2007DGN Output

DGN Output Map File (Table File)
When using the output options to write out a DGN file, an output map file (table file) can be 
used, with string names as the key, so that the user can specify DGN level, colour, weight, style 
and some information which is placed in an DGN attribute. The format is based on the VicRoads 
specification.

The key can have wild cards (*) and wild characters (?) as for the input map files.

The table consists of lines containing either 8 or 16 free format fields. Fields 9-16 can be left off if 
they are not needed.

The key for the map is the 12d Model string name which is given as the first field of a line. The 
rest of the fields on the line are used for .dgn information.

 field 1 12d Model string name (any length but if field 2 is a *, only the first four
 characters are passed)

field 2 text of which the first four characters are used in a DGN attribute. For example,
 the VicRoads code

field 3 AS2482 feature code
field 4 description           (any length but quotes needed if there are embedded spaces)
field 5 line level            (between 1 and 64)
field 6 line colour           (between 1 and 256)
field 7 line weight           (between 1 and 7)
field 8 line style

fields 9-16 are only used for special symbols placed at points.

field 9  symbol font           (between 0 and 7)
field 10 symbol character
field 1 symbol character justification
field 12 symbol character height
field 13 symbol character width
field 14 symbol level
field 15 symbol weight
field 16 symbol colour

Field 1, the 12d Model string name, can contain wild cards * or wild characters ?.

Field 2, a text string, and the first four characters of the text is inserted into a DGN attribute. This 
DGN attribute is used by the 12d Model DGN reader for matching with a 12d Model input map 
file.

If field 2 is a * then the first four characters of the 12d Model string name is inserted as an 
Intergraph attribute.

Line strings and Text strings only use fields 1 to 8 and ignore fields 9-16 (if they exist).

Fields 9 through 16 are only used for 12d Model point strings which are then mapped with the 
specified Intergraph symbol at each point of the string. 

If either field 12 or 13 is zero, then it is interpreted to mean that only the first 8 fields are used.

If any of the fields 5 through 16 (except 9 and 11) is a *, then that field is not used in the map.

Double quotes " are entered as text as \", a ’ as \’ and a \ as \\.

An example of a map table where the first four characters of the 12d Model string names are 
passed directly through to the DGN attribute.

CONT * 50020000 "Contour - Standard   "      2        4          0        0
TOP * 25060001 "Top - Cut/fill/bank  "       2       11        1       2
TOE  * 25060002  "Toe - Cut/fill/bank  "       3      11         1      7
ES*         * 50090001    "Existing surface-spot " 4    9   1   0   110   A     7   1000    1000   4    0   9
CIND * 50080000 "Contour - Index      "           2       4        1         0
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An example of a map table where the 12d Model string names are used for mapping but 
different names go through to the DGN attribute.

101 CONT 50020000 "Contour - Standard   "      2         4         0       0
102 TOP 25060001 "Top - Cut/fill/bank  "     2          11      1         2
104    ES 50090001   "Existing surface-spot" 4    9   1   0   110   A    7   1000   1000    4    0    9

Write_DGN_V8_File__Pre_Beta___Under_Development_

DGN V8
NOTE: the format for DGNV8 has been changed and has not been published. This is a beta 
version of the DGN Write to try and write DGNV8. At this stage it is probably better to use DWG 
I/O to go in and out of Microstation V8.

Note: this option is under development

On selecting the DGN V8 option, the Write DGN V8 File panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

DGN file input *.dgn files

name of the DGN V8 binary model to be write to

Write button

read the data out.
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DWG/DXF Output
write_dwg_dxf_file_for

Position of option on menu: File I/O =>Data output =>DWG/DXF

The DWG/DXF output format is for writing data out in a format compatible with AutoCAD 
versions 2.5 to 2000.

12d Model line strings are output as POLYLINEs, point strings as a series of Autocad POINTs 
and triangles as 3DFACEs.

By default, the string or triangle colour is used in the Autocad colour record. The DXF layer used 
is the items model name with any spaces in the model name replaced by a minus (-). However, a 
DXF output map file with matches on string name can be used to give DXF layers, colours and 
line type (see next section).

At this stage, 4d, interface and alignment strings are only output as Autocad POLYLINES.

When creating an AutoCAD file, it is often convenient to use an existing AutoCAD file as a 
template or seed file (the seed file usually contains set up information for the AutoCAD 
drawing).

In 12d Model, the user can specify a folder containing seed files by pointing to it using the 
environment variable ACAD_SEEDFILES_4D. In the AutoCAD DWG/DXF output option, the 
pop-up for the seed file panel field displays all the files with the appropriate ending in the folder 
pointed to by ACAD_SEEDFILES_4D.

If the environment variable ACAD_SEEDFILES_4D has not been set, the pop-up uses the current 
working folder to search for seed files.

It is also possible to use a label map file to create labels for vertex information such as z-values, 
symbols and point numbers which are written directly to the AutoCAD file. See the section 
“Label Map File” and “Use Label Map File” for more information on the label map file.

On selecting the DWG/DXF output option, the Write DWG/DXF file for panel is displayed.
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The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

Format choice dwg dwg, dxf, bdxf

AutoCAD format of the file.

Unit choice Metric Metric, English

AutoCAD units type.

File input

name of the ACAD file for the data to be written out to.

AutoCAD version choice AutoCAD 2004 AutoCAD 12, 13, 14
AutoCAD 2000, 2002, 2004
2005, 2006, 2007

AutoCAD version of the file produced.

ACAD Template file input
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name of the file to use as the AutoCAD template

Write button

write out, in DXF format, all the data specified by the Data source, to the file given in the file field.

General tab
Dimension choice 3d 2d, 2d and contours 3d,3d

if 2d, the z-value of all the data is set to zero and arcs and curves in alignment strings are written out 
as dxf polylines with bulges for the arcs.
If 2d and contours 3d, the z-value of all the non-contour data is set to zero and arcs and curves in 
alignment strings are written out as dxf polylines with bulges for the arcs. Contours are written out as 
3d polylines.
If 3d, strings will be written out as three dimensional DXF polylines. Alignment strings and arcs will 
be approximated by short lines.

Null level value input -999

AutoCAD z-value to use for any vertices with the 12d Model null value

ACAD output map file input *.mf files

if non-blank, the name of an AutoCAD output map file to map the data. See “AutoCAD Output Map 
File Create/Edit” .

Scale for paper/pixel text 1: input 1000

scale to use to convert 12d Model paper and pixel text to ACAD world units

Symbol colour choice default default, by block, by layer

if default, use the 12d Model colour.
If By block, write out as BY BLOCK.
If By layer, write out as BY LAYER.

Colour by layer tick box no tick

if tick, the colour is set to BY LAYER

Linestyles by layer tick box no tick

if tick, the linestyle is set to BY LAYER

Features as arcs tick box no tick

if tick, feature strings output as arcs in DXF. 
if not tick, the centre of the feature string is output as a point.

Create string super text tick box no tick

if tick,

Text/Attributes
Label map file input *.mf files

if non-blank, the name of a file to be used as label map file for creating labels.

Layer name for symbols input *.mf files

if non-blank, the name of a file to be used as label map file for creating labels.

Advanced
Space in model names choice space space, underscore, hyphen

if space, then spaces in 12d Model names go out as spaces to ACAD layer names.
If underscore, then spaces in 12d Model names go out as underscores to ACAD layer names.
If hyphen, then spaces in 12d Model names go out as hyphens to ACAD layer names.

Acad point style choice style 0 Acad point styles

Point mode choice relative relative, absolute
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if relative, then 
If absolute, then .

Point size (%) input 5

Output view text tick box no tick

if tick, any view text turned on (point numbers, z-values etc.) are output as text in DXF. 
if not tick, view text is not output.

Explode interface strings tick box no tick

if tick, interface strings are broken into separate strings for the cut or fill colour.
If not tick, interface strings are written out as one string in magenta.

Use model name for mapping tick box no tick

if tick,  
if not tick, .

Use symbol name for mapping tick box no tick

if tick,  
if not tick, .

Associate vertex attributes with symbol tick box no tick

if tick,  
if not tick, .

Vertex attributes height input -999
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DWG/DXF Output Map File
See “AutoCAD Output Map File Create/Edit” .

When using the output options to write out a DWG/DXF file, an output map file can be used, 
with 12d Model string names as the entity-name to match the key, so that the user can specify 
Autocad layer, colour and style. BYLAYER can be used with colour and style.

The key can have wild cards (*) and wild characters (?) as for the input map files.The fields in the 
DWG/DXF output map file are (ACD = Autocad):

field 1 key - string name can include wild cards * and wild characters ?
field 2 new name not output to DXF
field 3 ACD layer  * for 12d Model name
field 4 ACD colour number between 0 and 256, * for 12d Model colour mapped to 
ACD,

BYLAYER for ACD BYLAYER
field 5 ACD line type  * for 12d Model linestyle, BYLAYER for ACD BYLAYER
field 6 ACD text style not yet used, * for 12d Model text style 

An example of an DWG/DXF output map file is.

// 1 2 3 4                      5                                6
// key name layer colour           linetype                  textstyle

cont* ignored CONTOURS 1                     1                                   *
EB* ignored ROAD 2                    CONTINUOUS          *
103 ignored * 3                     *                                    *
fe* ignored FENCE *                     BYLAYER                  *
SURV* ignored SURVEY BYLAYER       DASH                     *
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Genio Output
write_genio_file_for

Genio i/o is a separate chargeable module.

The Genio output option write out the strings selected by the data source, to a genio file, the 
format used by MX (formerly Moss). A genio 001 option is used to specify the record format.

Because MX and in 12d Model have different data types, not all 12d Model data can be 
transferred to MX. The user must be aware of what data can be transferred to MX.

1.  MX model names are limited to thirty two characters (in upper case). Hence the first thirty 
two characters of the 12d Model model name are converted to upper case and used as the MX 
model name.

2. MX string names can only be four characters and each string in MX must have a unique 
name. This limits MX to a maximum of 1,679,616 string. Strings can have the same name in 
the genio file but the strings will be renamed when read into MX to give each string a unique 
name.

Since 12d Model places no restrictions on string name length, the following rules are used to 
produce genio string names.

For a line-string, the first four characters of the string name are used as the genio string name. 
The four characters are mapped to upper case. Remember that MX line strings can not start 
with a P.

For a point-strings whose names start with P, the first four characters of the string name are 
used as the genio string name. Otherwise the genio string name is P plus the first three letters 
of the point-string name. The three letters are mapped to upper case.

3.  12d Model null heights go out as -999 to MX.

4. The four character limit and uniqueness for MX string names restricts the number of strings that can be 
read into MX. For example, since points strings must start with P so there can be a maximum of 46,656 
point strings. Or if a MX string must start with ABB say, then there can only be 36 distinct ABB strings 
in the MX project.

5. All MX x and y co-ordinates have to be positive. That is, all co-ordinates must be in the first 
quadrant.

6. 12d text strings go out as MX text strings but there is a maximum of 44 characters in the MX 
text string. There is no unit for height in the MX text string as well as no font.The name of a 
MX text string must start with a * so 12d Model uses * and the first three characters of the text 
string’s name.

7. 2d and 3d strings in 12d Model go out to MX as 2d and 3d strings respectively.

8. 4d strings in 12d Model go out to MX as 4d strings except that the text is restricted to four 
characters.

9. Alignment and super alignments can be written out to MX as MX 3d, 6d or 12d string.

10. For super strings:

Point id’s are ignored in all cases.
On the Genio output panel, this is a tick box Include segment text and if it is ticked then 
segment text is written out as MX text strings, otherwise segment text is ignored.
On the Genio output panel, this is a tick box Include vertex text and if it is ticked then the super 
string is written out as a MX 4d string and with the first four characters as the vertex text for a 
point.
Attributes are ignored in all cases.
Diameter and culvert width and height are ignored.
Colour and segment colour are ignored.
If there is an invisibility segment, the string is broken into two.
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Tinability is a real problem. MX has no such concept apart from the entire string being a point string or 
a line string. There is a tick box to write out non-tinable data. If a segment is non tinable, the string is 
broken into two.

Arcs in super strings or arc strings or circles are broken into line segments using the chord to 
arc tolerance in the genio output panel, or the system default if there is no value in the panel.
Super strings with a fixed z-value and no vertex text (i.e. that is no z-value at each point, just 
the one z for the entire string) go out at MX 2d strings.

Super strings with a z-value at each vertex and no vertex text (that is a z-value at each point) 
go out as MX 3d string

Super strings with a z-value at each vertex and vertex text (that is a z-value at each point and 
text at each point) go out as MX 4d strings with the four characters of the vertex text as the 
forth dimension.

On selecting the Genio output option, the Write Genio File for panel is displayed.

The fields and buttons used in the two panels panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model
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data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

File input *.mos files

name of the genio file the model/view is to be written out to. If the file already exists, the data will be 
appended to the bottom of the file.

Alignment/arc dimension input 3d 3d,6d,12d

if 3d is selected, alignment and arc strings as written out as MX 3d string as a series of straight lines 
(x, y, z at each point).
If 6d is selected, alignment and arc strings are written out as MX 6d strings (chainage, x, y, z, bearing, 
and radius at each point).
If 12d is selected, alignment and arc strings are written out as MX geometry strings (called 12d 
strings in MX). This is the only way that full horizontal and vertical geometry can be transferred to 
MX.

Chainage interval input

if 3d is selected as the Alignment/arc dimension, the alignments and arcs are approximated using the 
Chainage interval and\ the Chord/arc tolerance.

Chord/arc tolerance input

if 3d is selected as the Alignment/arc dimension, the alignments and arcs are approximated using the 
Chainage interval and\ the Chord/arc tolerance.

Terminator value input -999

value to use to terminate strings in the genio file.

Insert DELETE/CREATE tick box tick

if tick, the genio commands DELETE and CREATE are written at the top of the file to correctly define 
the moss models for the data.

77 format tick box

if tick, use the MX 77 formats for the genio strings.

Convert 2d to 3d tick box tick

if tick, write strings with a fixed z-value (2d strings) out in MX 3d string format in the genio file.

Include string numbers tick box

if tick, the MX string name includes the surveyors string number. It still can be only four characters.

Write non-tinable data tick box tick

if tick, strings that are non-tinable are written out.
If not ticked, strings that are non-tinable are not written out.

Include vertex text tick box tick

if tick, write out strings with vertex text as MX 4d string with the first four characters of the vertex 
text as the text on the MX 4d string, otherwise do not write the text out.

Include segment text tick box tick

if tick, write out segment text as text strings otherwise do not write the text out.

Combine point strings tick box

if tick, point strings of the same name in 12d are combined into one point string when written out.

Combine line strings tick box

if tick, strings of the same name in 12d are combined into one MX string (using MX discontinuities to 
separate the strings) when written out. This is trying to get over the MX four character name 
limitation.

Combine text strings tick box tick

if tick, text strings of the same name in 12d are combined into one MX text string when written out. 
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This is trying to get over the MX four character name limitation.

Combine only when needed tick box tick

if tick, when there are more strings of the same name in 12d than the MX four character name 
restriction would allow, the strings are combined into one MX string when written out. This is trying 
to get over the MX four character name limitation.

Allow non tangential alignments tick box

if tick, alignments where some elements are not tangential are written out.
if not tick, alignments with non tangential elements are not written out.

Write button

write out in genio format all the data specified by the Data source, to the file given in the file field. If the 
file already exist, the data will be appended to the file.
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LandXML Output
write_landXML_for

Position of option on menu: File I/O =>Data output =>LandXML

LandXML is a general format that attempts to cover civil and surveying entities.

Unfortunately every vendor has their own extensions which makes the format of only limited 
value unless LandXML readers are tailored for each vendor variation.

LandXML only covers some of the data in 12d Model and so is of limited value.

12d Model has special LandXML writers for LINZ-XML (for LandOnline NZ) and Leica-XML.

One benefit is that for it may allow access to data from vendors who only have non-published 
proprietary formats (AutoCAD, MIcrostation).

This option is under continual developed as the LandXML standard keep changing.

On selecting the LandXML option, the Read LandXML File panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

File input *.xml

name of the LandXML file to write to

Write button

write the selected data to a LandXML file.
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MapInfo Output
write_MapInfo_tab_mif_files_for

Position of option on menu: File I/O =>Data output =>MapInfo

This Option is currently under development.

The MapInfo MID/MIF format is used for sending data to MapInfo.

On selecting the MapInfo MID/MIF option, the Write MapInfo Tab/Mif Files for panel is displayed.

The Data source field can then be modified for either View, String or Global.

The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

Co-ordinate system choice box

MapInfo file of co-ordinate definitions. The co-ordinate system that the current data is in is selected 
from the list.

Note - data in MapInfo is stored in longitude and attitude. When MapInfo reads data in it needs to 
know the co-ordinate system that the data is in so that it can convert the data to longitude/attitude as it 
reads the file. The list of co-ordinate systems in the Co-ordinate system pop-up is in the file mapinfo.4d. 
Mapinfo.4d has exactly the same format as the file MAPINFOW.PJR used by MapInfo.

If there are any co-ordinate systems missing that are in your MapInfo system, simply copy the file 
MAPINFOW.PRJ from your MapInfo system into the 12d Model User folder and give it the name 
mapinfo.4d instead of MAPINFOW.PRJ

File format choice box TAB TAB, MIF

MapInfo format to use for writing out the data.

File choice box *.tab, *.mif files

name of the file to write the data out to.
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Colour for white colour box available colours

colour to use in MapInfo for white in 12d Model (because MapInfo has a white background).

Write button

write out, in MapInfo file format, all the string data specified by the Data source.
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Civilcad
civilcad_write_panel

Position of option on menu: File I/O =>Data output =>Civilcad V5

Civilcad output is a unsupported option supplied to users with the Civilcad input option. 
Civilcad input is a chargeable module. 

Because of the limitations of the CivilCAD ascii format, the CivilCAD output option can only 
output a limited number of 12d Model data types.

The Civilcad output option writes some 12d Model data to a CivilCAD 5.0 ascii file. Because 
CivilCAD ascii can only take points, lines between two points and arcs, only 12d Model data that 
can output that way can be written out.

The only 12d Model data types that can be written out to Civilcad ascii are:

2d strings
3d strings
arcs
circles
polylines
the line work from super strings
text

Note that the following 12d Model data that can not be output to CivilCAD ascii:

alignments
super alignments
drainage/sewer strings
pipeline strings
pipe strings
attributes
most super string properties
triangulations
rasters

On selecting the Civilcad output option, the Write CivilCAD ascii File panel is displayed.

The fields and buttons used in the two panels panel have the following functions.

Field Description Type Defaults Pop-Up
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Data to write choice Model Model, View

the type of data to be written out to a file.

Data type source input

source of data is to be written out to a file.

CivilCAD file input *.as5 files

name of the file the model/view is to be written out to. If the file already exists, the data will be 
appended to the bottom of the file.

Write button

write out in CivilCAD format the data in the model/view given in the model/view field, to the file given 
in the file field.
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Geocomp
geocomp_write_panel

Position of option on menu: File I/O =>Data output =>Geocomp

Geocomp output is a unsupported option supplied to users with the Geocomp input option. 
Geocomp input is a chargeable module. 

Because of the limitations of the Geocomp points and strings files, the Geocomp output 
option can only output a limited number of 12d Model data types.

The Geocomp output option writes some 12d Model data to Geocomp Points and Strings files. 
Because Geocomp can only take points, lines between two points and arcs, only 12d Model data 
that can output that way can be written out. 

The only 12d Model data types that can be written out to Geocomp points and strings files are:

2d strings
3d strings
arcs
circles
polylines
the line work from super strings
text

Note that the following 12d Model data types that can not be output to Geocomp:

alignments
super alignments
drainage/sewer strings
pipeline strings
pipe strings
attributes
most super string properties
triangulations
rasters

On selecting the Geocomp output option, the write Geocomp ascii file panel is displayed.

The fields and buttons used in the two panels panel have the following functions.

Field Description Type Defaults Pop-Up

Data to write choice Model Model, View

the type of data to be written out to a file.

Data type source input

source of data is to be written out to a file.
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Output file input *.as5 files

name of the file the model/view is to be written out to. If the file already exists, the data will be 
appended to the bottom of the file.

Write button

write out Geocomp Points and Strings files the data in the model/view given in the model/view field, to 
the file given in the output file field.
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TP Stakeout Triangles Output
write_tp_stakeout_binary_triangles

Position of option on menu: File I/O =>Data output =>TP Stakeout triangles

The TP Stakeout triangles option writes out a tin as a TP Stakeout binary file.

On selecting the TP Stakeout triangles output option, the Write TP Stakeout Binary Triangles panel 
is displayed.

The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

Tin input available tins

name of the tin to write out in TP Stakeout binary format.

Tin polygon selection poly string-select

if selected, only triangles with their centroid inside this string are written out.

TP Stakeout binary file input *.tsb

name of the file for the triangles.

Triangles per cell

a TP Stakeout parameter.

Write button

write out the tin in TP Stakeout binary format.
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TP Stakeout Strings Output
write_tp_stakeout_binary_strings

Position of option on menu: File I/O =>Data output =>TP Stakeout strings

Note - this is a chargeable option

The TPStakeout strings option writes out selected strings as a TP Stakeout binary file.

On selecting the TP Stakeout strings output option, the Write TP Stakeout Binary Strings panel is 
displayed.

The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Centreline string select

centreline string to use as the reference chainage for other strings.

HZA name

Folder for stings folder

name of the folder to write out the strings to.

Write button

write out the strings in TP Stakeout binary format.
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Old Outputs
old_data_output

Position of menu: File I/O =>Data output =>Old

The Old menu contains superseded options. The Old walk-right menu is
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DXF 12-14 Output
write_dxf_12_14_file_for

Position of option on menu: File I/O =>Data output =>Old =>DXF 12-14

SUPERSEDED OPTION

The DXF 12-14 output format is for writing data out in a format compatible with AutoCAD. The 
DXF file produced does not have a full DXF header with the required line types, text styles, fonts 
already defined. Hence the DXF file needs to be loaded into an existing Autocad drawing.

AutoCAD Release 10 introduced binary DXF files as a means of addressing the problems of large 
file sizes, slow processing and limited accuracy that occur when using the ASCII DXF format. 
12d Model can write binary DXF files. See the Precision field below.

12d Model line strings are output as POLYLINEs, point strings as a series of Autocad POINTs 
and triangles as 3DFACEs.

By default, the string or triangle colour is used in the Autocad colour record. The DXF layer used 
is the items model name with any spaces in the model name replaced by a minus (-). However, a 
DXF output map file with matches on string name can be used to give DXF layers, colours and 
line type (see next section).

At this stage, 4d, interface and alignment strings are only output as Autocad POLYLINES.

On selecting the DXF 12-14 output option, the Write DXF 12-14 File for panel is displayed.

The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input
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source of data is to be written out to a file.

DXF File input *.dxf files

name of the file for the information to be written out to. If the file already exists, the data will be 
appended to the file.

DXF Dimension input 2d 2d, 3d

if 3d, strings will be written out as three dimensional DXF polylines. Alignment strings and arcs will 
be approximated by short lines.
If 2d, the z-value of all the data is set to zero and arcs and curves in alignment strings are written out 
as dxf polylines with bulges for the arcs.

Decimal places input 8

the number of decimal places to be used for co-ordinates etc. in the DXF file.
If this number is negative, a binary DXF file will be written. The actual number specified becomes 
irrelevant in this case, since full precision is preserved in a binary DXF file.

Map file input *.mf files

if non-blank, the name of a file to be used as a 12d Model to DXF output map file.

Use linestyle names tick box

if tick, a 12d Model string’s linestyle name is used as the DXF element’s line type ("1" goes to 
CONTINUOUS).
if not tick, all DXF line types are CONTINUOUS.

Use blocks for point styles tick box

if tick, for each 12d Model point string, an Autocad block of the same name as the 12d Model string’s 
linestyle is places at each point.

Output table section tick box tick

if tick, an AutoCAD table section is written out at the top of the DXF file.

Map DXF colours tick box tick

if tick, a mapping is made between the first seven default 12d Model colours and the corresponding 
DXF colours. The other 12d Model colours are mapped to the DXF colour of the same colour number.
If not tick, the nth 12d Model colour is mapped to the nth DXF colour.

Features as arcs tick box

if tick, feature strings output as arcs in DXF. 
if not tick, the centre of the feature string is output as a point.

Output view text tick box

if tick, any view text turned on (point numbers, z-values etc.) are output as text in DXF. 
if not tick, view text is not output.

Write button

write out, in DXF format, the data in the model/view given in the model/view field, to the file given in 
the file field.
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DXF Output Map File
When using the output options to write out a DXF file, an output map file can be used, with 
12d Model string names as the entity-name to match the key, so that the user can specify 
Autocad layer, colour and style. BYLAYER can be used with colour and style.

The key can have wild cards (*) and wild characters (?) as for the input map files.The fields in the 
DXF output map file are (ACD = Autocad):

field 1 key - string name can include wild cards * and wild characters ?
field 2 new name not output to DXF
field 3 ACD layer  * for 12d Model name
field 4 ACD colour number between 0 and 256, * for 12d Model colour mapped to 
ACD,

BYLAYER for ACD BYLAYER
field 5 ACD line type  * for 12d Model linestyle, BYLAYER for ACD BYLAYER
field 6 ACD text style not yet used, * for 12d Model text style 

The DXF file produced needs to be loaded into an existing Autocad drawing which has the ACD 
layers and linestyles defined.

An example of an DXF output map file is.

// 1 2 3 4                      5                                6
// key name layer colour           linetype                  textstyle

cont* CONT CONTOURS 1                     1                                   *
EB* TOP ROAD 2                    CONTINUOUS          *
103 TOP * 3                     *                                    *
fe* TOP FENCE *                     BYLAYER                  *
SURV* TOP SURVEY BYLAYER       DASH                     *
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DXF Output
write_dxf_file_for

Position of option on menu: File I/O =>Data output =>Old =>DXF

SUPERSEDED OPTION

The DXF output format is for writing data out in a format compatible with AutoCAD version 15. 
The DXF file produced does not have a full DXF header with the required line types, text styles, 
fonts already defined. Hence the DXF file needs to be loaded into an existing Autocad drawing.

This option is the one used in 12d Model V3.1. It is now superseded by the DWG/DXF output 
option.

AutoCAD Release 10 introduced binary DXF files as a means of addressing the problems of large 
file sizes, slow processing and limited accuracy that occur when using the ASCII DXF format. 
12d Model can write binary DXF files. See the Precision field below.

12d Model line strings are output as POLYLINEs, point strings as a series of Autocad POINTs 
and triangles as 3DFACEs.

By default, the string or triangle colour is used in the Autocad colour record. The DXF layer used 
is the items model name with any spaces in the model name replaced by a minus (-). However, a 
DXF output map file with matches on string name can be used to give DXF layers, colours and 
line type (see next section).

At this stage, 4d, interface and alignment strings are only output as Autocad POLYLINES.

On selecting the DXF output option, the Write DXF file for panel is displayed.

The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up
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Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

DXF File input *.dxf files

name of the file for the information to be written out to. If the file already exists, the data will be 
appended to the file.

DXF Dimension input 3d 2d, 3d

if 3d, strings will be written out as three dimensional DXF polylines. Alignment strings and arcs will 
be approximated by short lines.
If 2d, the z-value of all the data is set to zero and arcs and curves in alignment strings are written out 
as dxf polylines with bulges for the arcs.

Decimal places input 8

the number of decimal places to be used for co-ordinates etc. in the DXF file.
If this number is negative, a binary DXF file will be written. The actual number specified becomes 
irrelevant in this case, since full precision is preserved in a binary DXF file.

Map file input *.mf files

if non-blank, the name of a file to be used as a 12d Model to DXF output map file.

Use linestyle names tick box

if tick, a 12d Model string’s linestyle name is used as the DXF element’s line type ("1" goes to 
CONTINUOUS).
if not tick, all DXF line types are CONTINUOUS.

Use blocks for point styles tick box

if tick, for each 12d Model point string, an Autocad block of the same name as the 12d Model string’s 
linestyle is places at each point.

Output table section tick box tick

if tick, an Autocad table section is placed at the beginning of the DXF file.

Map DXF colours tick box tick

if tick, a mapping is made between the first seven default 12d Model colours and the corresponding 
DXF colours. The other 12d Model colours are mapped to the DXF colour of the same colour number.
If not tick, the nth 12d Model colour is mapped to the nth DXF colour.

Features as arcs tick box

if tick, feature strings output as arcs in DXF. 
if not tick, the centre of the feature string is output as a point.

Output view text tick box

if tick, any view text turned on (point numbers, z-values etc.) are output as text in DXF. 
if not tick, view text is not output.

Write button

write out, in DXF format, the data in the model/view given in the model/view field, to the file given in 
the file field.
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DXF Output Map File
When using the output options to write out a DXF file, an output map file can be used, with 
12d Model string names as the entity-name to match the key, so that the user can specify 
Autocad layer, colour and style. BYLAYER can be used with colour and style.

The key can have wild cards (*) and wild characters (?) as for the input map files.The fields in the 
DXF output map file are (ACD = Autocad):

field 1 key - string name can include wild cards * and wild characters ?
field 2 new name not output to DXF
field 3 ACD layer  * for 12d Model name
field 4 ACD colour number between 0 and 256, * for 12d Model colour mapped to 
ACD,

BYLAYER for ACD BYLAYER
field 5 ACD line type  * for 12d Model linestyle, BYLAYER for ACD BYLAYER
field 6 ACD text style not yet used, * for 12d Model text style 

The DXF file produced needs to be loaded into an existing Autocad drawing which has the ACD 
layers and linestyles defined.

An example of an DXF output map file is.

// 1 2 3 4                      5                                6
// key name layer colour           linetype                  textstyle

cont* CONT CONTOURS 1                     1                                   *
EB* TOP ROAD 2                    CONTINUOUS          *
103 TOP * 3                     *                                    *
fe* TOP FENCE *                     BYLAYER                  *
SURV* TOP SURVEY BYLAYER       DASH                     *
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Genio V3.1 Output
write_genio_file_v31_for

Position of option on menu: File I/O =>Data output =>Old =>Genio V31

SUPERSEDED OPTION

Genio i/o is a separate chargeable module.

This is the genio output module from 12d Model V3.1. This module has been replaced by the 
new genio module but the genio v3.1 will be left in V4.0 in case there a any problems with the 
new module.

The genio v3.1 output option uses a non-default format to write out the strings in a model or on a 
view, to a genio file. A genio 001 option is used to specify the record format.

The first thirty two characters of the model name are converted to upper case and used as the 
Moss model name.

In Moss, string labels can have a maximum of four characters. Since 12d Model places no 
restrictions on string name length, the following rules are used to produce genio string labels.

For a line-string, the first four characters of its string name are used as the genio string label. The 
four characters are mapped to upper case.

Similarly for point-strings whose names start with P. Otherwise the genio string label is P plus 
the first three letters of the point-string name. The three letters are mapped to upper case.

The name of a Moss text string must start with a * so 12d Model uses * and the first three 
characters of the text string’s name.

An alignment string can be written out as either a moss 3d, 6d or 12 string.

On selecting the Genio V31 output option, the Write Genio File V31 for panel is displayed.

The fields and buttons used in the two panels panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

File input *.mos files

name of the file the model/view is to be written out to. If the file already exists, the data will be 
appended to the bottom of the file.
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Alignment dimension input 3d 3d,6d,12d

if 3d is selected, alignment strings as written out as a 3d string as a series of straight lines.
If 6d is selected, alignment strings are written out as Moss 6d strings.
If 12d is selected, alignment strings are written out as Moss geometry strings. This is the only way 
that full horizontal and vertical geometry can be transferred to Moss.

Insert DELETE/CREATE tick box tick

if tick, the genio commands DELETE and CREATE are written at the top of the file to correctly define 
the moss models for the data.

Write button

write out in genio format the data in the model/view given in the model/view field, to the file given in 
the file field. If the file already exist, the data will be appended to the file.
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Eagle Output
write_eagle_command_file_for

Position of option on menu: File I/O =>Data output =>Old =>Eagle

Eagle is a 3D CAD package used throughout Australia, Asia and Europe.

Using the Eagle output option, 12d Model produces an Eagle command file which is used by 
Eagle to create an Eagle model. Since Eagle supports 3D faces, the triangles created in 12d Model 
can be transferred to Eagle for use in shaded models and walk-throughs.

Instead of colours, Eagle uses pens, dash styles, line thicknesses and frags. To allow the user to 
map 12d Model colours to appropriate Eagle settings, an Eagle map file setting out the 12d 
Model and Eagle relationships can be provided.

The eagle map file is a user created file consisting of a list of 12d Model colours and the Eagle 
pen, dash style, pen thickness and frag to be used for the colour.

The map file is set out with one 12d Model colour per line. The line begins with the 12d Model 
colour followed by the Eagle pen number, dash style, thickness and frag to be used for the 12d 
Model colour. Each item is separated by one or more spaces.

For example, if the 12d Model colour red is to be mapped to Eagle pen 3, dash style 4, thickness 2 
and frag 1, then the line in the eagle map file would be 

red 3 4 2 1

If a map file is used, as each string is written out, the map file is searched sequentially until a 
colour match is made.

If no match is found, the colour of the string is used as a pen number and default values used for 
dash, thickness and frag.

Comments can be included in the map file by preceding the comment with a double forward 
slash (i.e. //). Anything on the line following the // will be ignored.

For example,

// 12d colour pen dash thick frag

red  3  4  2  1
green  4  1  1  2

On selecting the Eagle option, the Write Eagle Command File for panel is displayed.

The fields and buttons used in the two panels have the following functions.
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Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

Eagle Command File input *.cmd files

name of the Eagle command file to write the model/view out to. If the file already exists, the data will be 
appended to the bottom of it. To be consistent with the Eagle file naming convention, the file name 
should end in .cmd

Eagle model input

name of the Eagle model to be used for the data. Only the characters A-Z, a-z, 0-9 and - are allowed in 
an Eagle model name. Do not include a .mod in the name.

Map file input *.emf files

if non-blank, the name of the map file to be used for all string colours. If blank, no map file is used.

Write button

write out the data from the model/view given in the model/view field to the file given in the eagle 
command file field. The Eagle model has the name given in the Eagle model field. If the file already 
exists, the data is appended to the file.
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Eagle Binary Output
write_eagle_binary_file_for

Position of option on menu: File I/O =>Data output =>Old =>Eagle Binary

Eagle binary i/o is a separate chargeable module.

Using the Eagle binary output option, 12d Model produces Eagle binary models. Since Eagle 
supports 3D faces, the triangles created in 12d Model can be transferred to Eagle for use in 
shaded models and walk-throughs.

Since Eagle uses pens, dash styles, line thicknesses and frags rather than colours, an eagle map 
file is used to define the relationships between 12d Model colours and Eagle pens, dash styles, 
thickness and frags. The map file is the same as described in the eagle output option.

The 12d Model string name is written to the second attribute of the corresponding eagle item.

On selecting the Eagle binary option, the Write Eagle Binary File for panel is displayed.

The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be written out to a file.

Eagle model input

stem of the name of the eagle model to write the model/view data out to. Because an eagle model has a 
maximum size, more than one model may be created. The eagle model names will have a sequence 
number appended to the name stem given in the eagle model field.

Map file input *.emf files

if non-blank, the name of the map file to be used for all string colours. If blank, no map file is used.

Dimension input 3d 2d/3d

if 3d, strings will be written out as three dimensional eagle lines. The alignment strings and arcs will 
be approximated by short lines.
If 2d, the z-value of all the data is set to zero and arcs and curves in alignment strings are written out 
as eagle plan arcs.

Precision input double single/double

the precision of the eagle models.
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Write button

write out the data from the model/view given in the Model/view field to the file given in the eagle model 
field.
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digitizer

Position of menu: File I/O =>Digitizer

The Digitizer option is used with a digitizing table to create 12d Model strings from existing maps 
or plans.

Contours (2d strings), feature strings (3d strings), spot heights (points strings), 4d strings, circles, 
arcs and text can all be digitized with this option.

The digitized data can be added to a new or existing 12d Model project.

The digitizing process consists of a number of steps.

▲ providing a digitizer definition file
▲ selecting the type of digitizer to be used
▲ registering a new plan or map on the digitizer, or continuing with a previously registered 

plan (resuming).
▲ selecting a default digitizing tolerance, default model, colour and name for digitized 

strings.
▲ digitizing the information

These steps are described totally in the next five sections and are then summarized.

A summary of the step is given at the end of this chapter in the section “Summary” .

The digitizer can be set up using WinTab which is preferred method, or by using a definition in 
the 12d digitizer definitions file, digitize.4d. A quick description of the digitizer definition file is 
given in the section “Digitizer Definitions” . The format for the digitizers_definitions file is given 
in the section “Digitizer Definitions File” .

The Digitizer walk-right menu is laid out to reflect the standard sequence of digitizer operations.

For the option Setups, go to the section  “Setups” .
Defaults  “Defaults” .
Capture  “Capture” .
Buttons  “Buttons” .

Digitizer Definitions
Most digitizers now support the WinTab definition for communicating with Windows and that is 
the preferred method to be used with 12d Model.

If the digitizer supports WinTab then the WinTab drivers need to be installed before the digitizer 
can be used by 12d Model. The WinTab drivers are supplied with the digitizer, not by 12D 

define digitizers and plans
default tolerance, model, colour etc.
digitize strings
some digitizer button operations



12d Model Reference Manual

Page 544 February 2007

Solutions.

Once the WinTab drivers are installed, no further information is required by 12d Model and the 
rest of this section can be ignored.

Unfortunately if WinTab is not supported, each brand of digitizer has its own method of 
communicating with a computer and a software package.

To allow for a variety of digitizers not supported by WinTab, 12D Solutions has its own ascii 
format for defining the important features of a particular digitizer. The digitizer definitions file is 
also used to tailor digitizer button usage at a particular site.

For example, the digitizer file defines which buttons on the digitizer puck are used to:

digitize new (add) points add button
end the digitizing of a string end button
turn tolerance on/off tolerance button
delete the last digitized point delete point button

When 12d Model starts up, it checks to see if an environment variable called DIGITIZERS_4D 
exists and if it does, then the file it points to is used to provide the definitions for the digitizers.

If the environment variable is not set, then 12d Model searches for a file called digitize.4d in the 
standard 12d Model search sequence for set up files.

Only digitizers that have been defined in the digitizers definitions file can be selected for use 
from within 12d Model.

The format for the digitizers definitions file is given in the section “Digitizer Definitions File” .
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Setups
digitizer_setups

Position of menu: File I/O =>Digitizer =>Setups

The setups menu contains options to select the digitizer to be used, register the co-ordinate 
system on a new plan or map sheet and for resuming the registration for a plan or map sheet 
already registered.

The setups walk-right menu is 

Each options will now be described in detail.

Digitizer Selection
digitizer_selection

Position of option on menu: File I/O=>Digitizer=>Setups=>Digitizer selection

On selecting the digitizer selection option, the digitizer selection panel is displayed.

This panel displays the current digitizer selected and allows a different one to be selected from 
those defined in the digitizers definitions file.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Use Wintab drive tick box

if tick then user WinTab drivers.
If not ticked, then the Digitizer field is enabled and must have a digitizer selected.

Digitizer input current digitizer available digitizers

the name of the current digitizer is displayed in this field. The current digitizer is changed by selecting 
a different name from the pop-up for the digitizer field and then selecting the Set button.

This field is only used if ’Use WinTab’ driver is not ticked.

Set button

if ’Use Wintab driver’ is set to tick and the Wintab drivers exist, then the ’Wintab Monitor’ panel is 
placed on the screen. The WinTab Monitor displays the digitizer co-ordinates and the digitizer button 
being used. The information describing the use of the digitizer buttons is written to the Output 
Window (see below). Do not close the Wintab Monitor panel or the digitizer will stop being read.

define which digitizer is being used
register a new plan
resume an existing registration
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If ’Use Wintab driver’ is set to tick and the Wintab drivers don’t exist, an error message is displayed.

If ’Use Wintab driver’ is not set to tick, then after selecting this button, the digitizer given in the 
digitizer field will be used as the current digitizer.

Register Plan
digitizer_register_plan

Position of option on menu: File I/O=>Digitizer=>Setups=>Register plan
Before the information on a plan or map can be digitized, the relationship between the co-
ordinate system of the plan and the digitizer must be determined.

In 12d Model, this relationship is given by specifying the plan co- ordinates and then the position 
on the digitizer of three or more points. These special points are known as control points.

The affine transformation for the control points is then calculated and if accepted by the user, is 
used to convert digitizer co-ordinates to plan co-ordinates.

This process is called "registering a plan".

Once a plan has been registered, the information is saved to a file. This file can be used in the 
resume plan option to register the plan without having to re-enter the control points.

Warning

If the plan is moved on the digitizer, it must be re-registered since the current affine 
transformation will be invalid.

After selecting the register plan option, the digitizer register plan panel is displayed.

Typical Message to Output Window if WinTab Drivers are Installed

Interface: Wintab 32-bit Digitizer Services.
Number of devices: 1
Device  1: GTCO MM-compatible Tablet; Version 1.00.00.08; Format: MM; Firmware: MM III  
12 x 12 Tablet  by Summagraphics  Firmware Version 1.91
The default device is device 1
Number of cursors is 3
Cursor  1: 2 button stylus
Cursor  2: 4 button puck - active
Cursor  3: 16 button puck
Number of buttons on active cursor is 4
Button  1: button 1
Button  2: button 2
Button  3: button 3
Button  4: button 4
Use Button 1 for Add point to string
Use Button 2 for End string

Use Button 3 for Delete point from string
Use Button 4 for Close string
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The main purpose of this panel is to display and register the affine transformation parameters. 
The fields and buttons used in the digitizer register plan panel will be discussed after the selection 
of the control points.

After selecting the register plan option, the digitizer register plan panel is placed on the screen 
and the option sits waiting for the user to enter the information for each control point.

This is achieved by 

▲ selecting the control point with the mouse if it already exists in 12d Model, or by typing in 
its plan co-ordinates (easting northing)

and then 

▲ selecting the control point’s position on the digitizer tablet using the digitizers add point 
button. Alternatively, if the control points already exist in 12d Model, they can be selected 
rather than using typed input

This process is repeated for each control point and is terminated by selecting cancel from the 
pick ops pop-up menu instead of selecting a new control point.

The calculate button calculates the affine transformation for all the control points in the grid with 
the Use pt ticked on.

The affine parameters are

▲ the rotation of the x axis of the plan co-ordinates with respect to the digitizer x axis
▲ the rotation of the y axis of the plan co-ordinates with respect to the digitizer y axis
▲ the x and y scale factors for the plan co-ordinates with respect to the digitizer coordinates

▲ the x and y translations for the plan co-ordinates with respect to the digitizer coordinates

Once calculated, these values are displayed in the digitizer register plan panel.

If further control points are required, selecting the control button on the digitizer register plan 
panel will restart the control point picking mechanism. Each new control point will be added to 
the grid.

The new affine transformation can be calculated by selecting the calculate button on the digitizer 
register plan panel.

Finally, once the user is satisfied with the affine transformation, it can be registered and stored in 
an ascii file for future use by entering a filename into the file field of the digitizer register plan 
panel and then selecting the register button from that panel.
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Summarising, the fields and buttons in the digitizer register plan panel have the following 
functions

Field Description Type Defaults Pop-Up

Rotation x/y output

the rotation of the x/y axis of the plan co-ordinates with respect to the digitizer x/y axis

Scale x/y output

the x/y scale factor for the plan co-ordinates with respect to the digitizer coordinates

Translation x/y output

the x/y translation for the plan co-ordinates with respect to the digitizer coordinates

File input *.aff

the name of the file to record the affine parameters.

Control button

restarts the selection process for choosing more control points.

Calculate button

calculates the affine parameters based on the control point selection.

Register button

write the affine transformation to the file given in the file field and register the affine transformation as 
the current one to be used for the digitising session.

Finish button

remove the panel from the screen. 

Warning

The affine transformation must be registered using the register button before the finish button is 
selected or it will be lost.

Resume Plan
digitizer_resume

Position of option on menu: File I/O=>Digitizer=>Setups=>Resume

When digitising a large plan, it is often necessary to spread the digitising over more than one 
session in 12d Model.

If the plan has not been moved on the digitizer since it was registered, the affine transformation 
can be restored with the resume plan option rather than having to register the plan again.

On selecting the resume plan option, the digitizer resume panel is displayed.

To resume digitizing with an affine transformation recorded during an earlier registration 
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session, simply enter the name of the affine file into the file field on the digitizer resume panel and 
then select the resume button.

Warning 

If the plan is moved on the digitizer, it must be re-registered since the current affine 
transformation will be invalid.
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Defaults
digitizer_defaults

Position of menu: File I/O=>Digitizer=>Deafults

The defaults menu sets default model, colour etc. and tolerance which are used when digitizing.

The defaults walk-right menu is 

Each options will now be described.

Capture Defaults
digitizer_capture_defaults

Position of option on menu: File I/O=>Digitizer=>Deafults=>Capture defaults

For any new string a name, model, colour, breakline type and default height are needed. When 
digitizing, the same values are often required for a large number of the strings. The capture 
defaults panel is used to set default values for digitized strings.

On selecting the capture defaults option, the digitizer capture defaults panel is displayed.

In the digitizing capture options, whenever a new string is selected, the values for name, model, 
colour, breakline type and height are taken from the digitizer capture defaults panel.

Bell
Not yet implemented

Tolerance
digitizer_tolerance_defaults

Position of option on menu: File I/O=>Digitizer=>Deafults=>Bell

When points are being digitized, a new point is often only required when it is a certain distance 

default model, colour etc.
not yet used
minimum distance between points
set digitizer to stream mode
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from the previous point on the digitizer. This is especially important for steam digitizing when 
hundreds of points per second may be captured.

The tolerance option allows the user to specify the minimum plan distance (in millimetres) 
between successive digitized points in a string.

On selecting the tolerance option, the digitizer tolerance defaults panel is displayed.

The fields and buttons used in this panel have the following meanings.

Field Description Type Defaults Pop-Up

Use tolerance tick-cross tick

if tick, a new point taken from the digitizer is only accepted if it is at least the distance given in the 
distance field away from the previous recorded point in the string.

Distance (mm) input 2.5

the minimum separation distance, in millimetres, between successive digitized points in a string.

Set button

set the use tolerance and distance values.

Stream
Position of option on menu: File I/O=>Digitizer=>Deafults=>Stream

Not yet documented.
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Capture
digitizer_capture

Position of menu: File I/O=>Digitizer=>Capture

The capture menu is for digitizing strings into 12d Model.

The capture walk-right menu is 

capture
The first time any of the option from this menu is selected, the capture panel is placed on the 
screen.

This panel is used to display the transformed co-ordinates for each digitized point that passes 
the tolerance test, and some special digitizer messages (for example, tolerance on/off).

To change the type of string being captured, simply select the new type from the digitize capture 
panel. This is normally only done at the end of capturing a string, not part way through.

To terminate the digitizing session, select finish on the capture panel.

Each of the methods for capturing data available in the digitizer capture menu will now be 
described.

For the option 2d, go to the section “2d” 
3d “3d” 
4d  “4d” 
Arc “Arc” 
Circle “Circle” 
Text “Text” 

digitize 2d strings
digitize 3d strings
digitize 4d strings
digitize arcs
digitize circles
digitize text

digitize 2d strings
digitize 3d strings
digitize 4d strings
digitize arcs
digitize circles
digitize text
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2d
digitize_2d_string

Position of option on menu: File I/O=>Digitizer=>Capture=>2d

This option is used to digitize 2d strings.

On selecting the 2d option, the digitize 2d string panel is displayed.

The fields and buttons in the digitize 2d string panel have the following meanings.

Field Description Type Defaults  Pop-Up

Name input             name of new string  name from capture defaults

Model input             capture defaults model    available models

model for the new string

Colour input capture def colour    available colours

colour of the new string

Type input capture def type    point, line

breakline type of the new string.

Height input capture def height

height of the 2d string.

If the digitize 2d string panel is created by the 2d option, the values in the name, model, colour, 
type and height fields are taken from the digitizer capture defaults panel.

Any of the values in the digitize 2d string can be modified before digitizing the 2d string begins.

Digitizing begins by pressing the add button on the digitizer puck when the puck is above the 
first point of the new string.

The co-ordinates of the selected point are then displayed in the capture panel and the digitize 2d 
string panel removed from the screen.

Further points are digitized by either pressing the add button again or if stream mode is on, 
holding the add button down and moving along the string being digitized.

The 2d string is terminated when the end button is pressed on the digitizer puck.

After selecting the end button, the digitize 2d string panel is again placed on the screen with the 
filed values the same as the 2d string just digitized.

The digitizing process is repeated for the new 2d string.
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3d
digitize_3d_string

Position of option on menu: File I/O=>Digitizer=>Capture=>3d

This option is used to digitize 3d strings.

Digitizing 3d strings is similar to 2d strings except that different z-values can exist at each of the 
digitized points.

On selecting the 3d option, the digitize 3d string panel is displayed.

The fields and buttons in the digitize 3d string panel are similar to the digitize 2d string panel 
except for the fields

Field Description Type Defaults Pop-Up

Height prompt tick-cross tick

if tick, after each point is digitized, an enter height box is placed on the screen. The height of the 
digitized point is typed into the box.
If not tick, the default height is used as the z-value for the digitized point.

Default height input capture default height

height of the point if the height prompt is set to no.

If the digitize 3d string panel is created by the 3d option, the values in the name, model, colour, 
type and height fields are taken from the digitizer capture defaults panel.

As for digitizing 2d strings, any of the values in the digitize 3d string can be modified before 
digitizing begins.

Digitizing begins by pressing the add button on the digitizer puck when the puck is above the 
first point of the new string.

The co-ordinates of the selected point are displayed in the capture panel and the digitize 3d string 
panel removed from the screen.

If the height prompt field is set to tick, an enter height box is placed on the screen with the previous 
typed height in it. The height for the digitized point in typed into the box, terminated by a 
<return>. The enter height box then disappears.

Further points are digitized by either pressing the add button again or if stream mode is on, 
holding the add button down and moving along the string being digitized.

Again, if the height prompt is set to yes, the enter height box will appear after each digitized point.

The 3d string is terminated when the end button is pressed on the digitizer puck.

After selecting the end button, the digitize 3d string panel is again placed on the screen with the 
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field values the same as the 3d string just digitized.

The digitizing process is repeated for the new 3d string.

Warning

If stream digitizing is used for the 3d string, the height prompt should be set to not tick.

4d
digitize_4d_string

Position of option on menu: File I/O=>Digitizer=>Capture=>4d

This option is used to digitize 4d strings.

Digitizing 4d strings is similar to 3d strings except that as well as a different z-value at each 
point, a text string also exits at each of the digitized points.

On selecting the 4d option, the digitize 4d string panel is displayed.

The fields and buttons in the digitize 4d string panel are similar to the digitize 3d string panel 
except for the fields

Field Description Type Defaults Pop-Up

Text prompt input yes yes, no

if tick, after each point is digitized, an enter text box is placed on the screen. The text for the digitized 
point is typed into the box.
If not tick, no text is used at the digitized point.

Size (pix) input default text size

height (in pixels) of the text at each point.

Angle input 0

angle of the text at each point.

Offset (pix) input 0

offset (in pixels) of the text from the digitized point.

If the digitize 4d string panel is created by the 4d option, the values in the name, model, colour, 
type and height fields are taken from the digitizer capture defaults panel.
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As for digitizing 3d strings, any of the values in the digitize 4d string can be modified before 
digitizing begins.

Digitizing begins by pressing the add button on the digitizer puck when the puck is above the 
first point of the new string.

The co-ordinates of the selected point are displayed in the capture panel and the digitize 4d string 
panel removed from the screen.

If the height prompt field is set to tick, an enter height box is placed on the screen with the previous 
typed height in it. The height for the digitized point in typed into the box, terminated by a 
<return>. The enter height box then disappears.

If the text prompt field is set to tick, an enter text box is placed on the screen. The text for the 
digitized point is typed into the box, terminated by a <return>. The enter text box then 
disappears.

Further points are digitized by either pressing the add button again or if stream mode is on, 
holding the add button down and moving along the string being digitized.

Again, the enter height and enter text boxes will appear after each digitized point if the height 
prompt and text prompts are set to tick.

The 4d string is terminated when the end button is pressed on the digitizer puck.

After selecting the end button, the digitize 4d string panel is again placed on the screen with the 
values in the fields from the 4d string just digitized.

The digitizing process is repeated for the new 4d string.

Warning

If stream digitizing is used for the 4d string, the height prompt and text prompt should be set to 
not tick.
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Arc
digitize_arc

Position of option on menu: File I/O=>Digitizer=>Capture=>Arc

This option is used to digitize arcs by digitizing three points on the arc - the arc start point, a 
point on the arc and the arc end point.

On selecting the arc option, the digitize arc panel is displayed.

The fields and buttons in the digitize arc panel are similar to the digitize 3d string panel except for 
the field

Field Description Type Defaults

Height input capture default height

height given to the two end points of the arc.

If the digitize arc panel is created by the arc option, the values in the name, model, colour and 
height fields are taken from the digitizer capture defaults panel.

As for digitizing 3d strings, any of the values in the digitize arc panel can be modified before 
digitizing an arc begins.

Digitizing begins by pressing the add button on the digitizer puck when the puck is above the 
first point of the new arc.

The co-ordinates of the selected point are displayed in the capture panel and the digitize arc panel 
removed from the screen.

Next a point on the arc between the arc end points is digitized followed by the arc end point.

After the end point is digitized, the arc is automatically created and the digitize arc panel again 
placed on the screen with the field values the same as the arc just digitized.

The digitizing process is repeated for the new arc.

Warning

Stream digitizing should not be used for arcs.
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Circle
digitize_circle

Position of option on menu: File I/O=>Digitizer=>Capture=>Circle

The circle option is used to digitize circles by digitizing the centre point and one point on the 
circle.

On selecting the circle option, the digitize circle panel is displayed.

The fields and buttons in the digitize circle panel are the same as the digitize arc panel.

If the digitize circle panel is created by the circle option, the values in the name, model, colour 
and height fields are taken from the digitizer capture defaults panel.

As for digitizing arcs, any of the values in the digitize circle panel can be modified before 
digitizing of the circle begins.

Digitizing begins by pressing the add button on the digitizer puck when the puck is above the 
circle point of the new circle.

The co-ordinates of the selected point are displayed in the capture panel and the digitize circle 
panel removed from the screen.

Next a point on the circle is digitized. The circle is then fully defined and automatically created.

The digitize circle panel is again placed on the screen with the field values the same as the circle 
just digitized.

The digitizing process is repeated for the new circle.

Warning

Stream digitizing should not be used for circles.

Text
digitize_text

Position of option on menu: File I/O=>Digitizer=>Capture=>Text

Not yet implemented
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Buttons
digitizer_buttons

Position of menu: File I/O=>Digitizer=>Buttons

The various options on the buttons menu can be used instead of pushing buttons on the digitizer 
puck.

The main use for this is when the digitizer puck has only a small number of buttons.

The buttons walk-right menu is 

delete last point
end string
turn stream on/off
turn tolerance on/off
open string
close string
delete all points in string
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Summary
The steps for digitizing are

1. Point to digitizers definitions file

The file containing the definitions of the digitizers is created and either called digitize.4d, or 
the environment variable DIGITIZERS_4D is set to point to the file.

2. Select a digitizer

Use the menu item File I/O =>Digitizer=> Setups=> Digitizer selection

3. Register a new plan or resume an old plan

To register a new plan, use menu item File I/O =>Digitzer=> Setups=> Register plan

After selecting the option, the software is waiting for the user to give the co-ordinates and 
position of control points on the digitizer.

Control Point Loop

(a) type in easting northing of the control point

(b) pick point on the digitizer

The loop is terminated by getting up the pick ops menu with the mouse and picking Cancel

Then select calculate from the digitizer control point table panel and check the calculated affine 
parameters in the digitizer register plan panel.

Once happy with the affine parameters, save them away by typing a filename (ending in .aff) 
into the file field of the digitizer register plan panel and then select the register button.

Alternatively, to resume digitizing a previously registered plan that has not moved on the 
digitizing tablet, use menu item File I/O =>Digitizer =>Setups=> Resume plan

Type the affine file name into the file field of the digitizer resume panel and select resume.

4. Set the capture defaults

Menu items under Digitizer =>Defaults

5. Digitize a bounding polygon for the area to be digitized

Use the menu item Digitizer =>Capture =>2d

This step is not strictly necessary, however, the polygon can be used to easily fit the digitized 
data onto a view.

6. Digitize the data

Use the menu items under Digitizer =>Capture
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Digitizer Definitions File
Unfortunately, each brand of Digitizer has its own method of communicating with a computer 
and a software package.

To allow for a variety of digitizers, 4D Solutions has its own ascii format for defining the 
important features of a particular digitizer.

When 12d Model starts up, it checks to see if an environment variable called DIGITIZERS_4D 
exists and if it does, then the file it points to is used to provide the definitions for the digitizers.

DIGITIZERS_4D filename

If the environment variable is not set, then 12d Model searches for a file called digitize.4d in the 
standard 12d Model search sequence for set up files.

Only digitizers that have been defined in the digitizer definitions file can be selected for use from 
within 12d Model.

The digitizers definition file format is a simple ascii format and consists of one or more digitizer 
definitions. Each digitizer definition in the file begins with the key word digitizer followed by 
the digitizer name and then appropriate digitizer commands enclosed within curly braces { }.

Available Digitizer Commands
Commands to define communication with the digitizer:

 port  text
 baud 300 | 600 | 1200 | 2400 | 4800 | 9600 | 19200| 38400
 charbits 5 | 6 | 7 | 8
 parity none | even | odd
 stopbits 1 | 2

Commands to define the size of the digitizing area:

 xdimension integer  // length of digitizer area in mm
 ydimension integer // height of digitizer area in mm
 resolution real // resolution in mm

Commands to define contents of the text string returned when digitizing:

 stringlength integer // length of the text string returned
 buttonstart integer // position in text for button id
 buttonend integer
 xstart integer // position for x value
 xend integer
 ystart integer // position for y value
 yend integer

Command to define sequences to send to digitizer:

 startup text // digitizer start up sequence
 finishup text // digitizer finish up sequence
 pointmode text // text to put digitizer into point mode
 streammode text // text to put into stream mode (track mode)

Commands to define the meaning of the button values returned from the digitizer:

These commands may occur more than once since some digitizers have more than one return 
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value for the same thing.

 addpoint text // digitize a point
 end text // end the string being digitized
 delpoint text // delete the last point digitized
 toggletol text // toggle tolerance
 togglestream text // toggle stream mode
 clearstr text // clear all points in the current string
 openstr text // open the current string
 closestr text // closes the current string

Notes

1. spaces in text - any text string that includes spaces or only numbers, must be enclosed in 
double quotes “.

2. comments - anything after // until the end of the line is ignored.
3. blank lines - blank lines are ignored
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11  Edit
The Edit menu contains the Undo and Redo options.

Infinite Undo and Redo facilities have been implemented for many of the 12d Model options.

However, because much of the power of 12d Model comes from being able to leave options 
hanging and editing more than one string at a time, this made the standard concept of Undo/Redo 
of limited benefit to 12d Model users.

Consequently, the following methodology has been adopted for Undo and Redo in 12d Model:

Independent undo and redo lists are maintained for each string being edited and these list are 
cleared once the editor is left.

There is also a main undo/redo list which is used for all other options that can be undone. The 
main undo/redo lists are cleared when the 12d Model session is exited.

Please continue to the next section “Undo and Redo for Editors” .

Undo and Redo for Editors
Each editor contains its own Undo/Redo option on its nd Edit menu and whilst a string is being 
edited, the editor maintains its own undo/redo lists.

For example, for a 2d string, the Undo/Redo option is just above the Quit option.

As each edit is made to the string, the state of the string before the edit is added to the top of the 
string’s undo list and the redo list is emptied.

If undo is selected from the nd edit menu, the last edit operation for that string will be undone 
and the undone operation added to the top of the string’s redo list.

If another undo is selected before another edit is made to the string, what is now was last 
operation on the string will be undone (is was the second last operation before the previous 
undo) and the undone operation added to the top of the string’s redo list.
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If redo is selected from the nd edit menu, then the top operation on the redo list is redone, and 
the state of the string before the redo is added to the top of the undo list.

Hence edits for he string can be undone and redone whilst in the edit session for the string.

When the edit session is completed by selecting either quite or finish from the nd edit menu, the 
undo and redo lists for the edit session are deleted and the operations for the edit session can no 
longer be undone or redone.

Note

If more than one string is being edited at the same time, each string editor maintains its own 
undo/redo lists so that the undo/redo operations for the different strings do not get intertwined.

 Hence if undo or redo is selected from a particular strings nd edit menu, the undo or redo 
applies only to the operations performed on that particular string, no matter what other nd edit 
options where performed on other strings.

Please continue to the next section “Undo and Redo for other Options” .

Undo and Redo for other Options
undo

As well as the undo/redo lists maintained by the string editors, there is another set of undo/
redo list maintained for all other options that support undo and redo. These are called the main 
undo and redo lists.

For a description of the undo in 12d Model , please go to the section “Edit” .

The undo option which controls the main undo/redo lists, is the on the Edit menu from the main 
menu.

If undo is selected from the undo menu, the last undoable option performed (apart from editor 
operation on strings) will be undone and the undone operation added to the top of the main 
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redo list.

If another undo is selected before another undoable option is performed, what is now was last 
operation will be undone (is was the second last operation before the previous undo) and the 
undone operation added to the top of the main redo list.

If redo is selected from the undo menu, then the top operation on the main redo list is redone, 
and the state before the redo is added to the top of the undo list.

Hence many operations can be undone and redone.

When the 12d Model session is completed by selecting either exit from the 12d Model menu, the 
undo and redo lists for the session are deleted and the operations for the session can no longer be 
undone or redone.

For the option Undo, go to the section “Undo” .
Redo “Redo” 
Undo list “Undo List” 
Clear all undos  “Clear all Undos” 

For some restrictions on the Undo/Redos, please continue to the section “Some Restrictions on 
Undo and Redo” .

Undo
If undo is selected from the undo menu, the undo panel showing the last operation to undo is dis-
played.

For some restrictions on the Undo/Redos, please continue to the section “Some Restrictions on 
Undo and Redo” .

Redo
redo

If redo is selected from the undo menu, the redo panel showing the last operation to redo is dis-
played.

For some restrictions on the Undo/Redos, please continue to the section “Some Restrictions on 
Undo and Redo” .

Undo List
undo_list
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If undo list is selected from the undo menu, a list of all the items on the undo list is displayed in 
the undo list panel.

Clear all Undos
clear_all_undo_s_redo_s

Selecting clear all undo from the undo menu will bring up a clear all undo’s/redo’s yes-no panel.

If yes is selected, the main undo and redo lists will be cleared.

Some Restrictions on Undo and Redo
Undo and Redo are available for most of the Strings options and most of the Utilities options.

Undo is available for all File=> Input options but there are no Redos for these Undos.

Undo is available for all Utilities=>Global options that use the Output option with the Mode set to 
one of the three copy modes. There are no Redos with these Undos.

There are no Undos for Models=>Delete and Models=>Clean.
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12  Models
models

Position of menu: Model

In 12d Model, models contain all the terrain and design information in the form of strings and 
tins.

The models walk-right menu contains the options needed to create new models, rename models, 
report, clean models and delete models permanently from the computer disks.

The models walk-right menu is 

For the option Models, go to section “Models” 
Model info “Model Info” 
Model info table “Model Info Table” 
String info table  “String Info Table” 
Create  “Create” 
Rename “Rename” 
Global rename “Global Rename” 
Utilities “Utilities” 
Sharing “Sharing” 
Clean “Clean” 
Delete “Delete” 

Models
model_list

Position of menu: Model =>Models

The Models walk-right menu provides options to list all the models in the project and list all the 

floating Models menu

list of models and model info
information on models
in table form, gives min, max x,y,z for each model
" " gives min, max x,y,z for each string in model
create a model
rename a model
rename many models
options to add, remove and save models
sharing models
clean all items in a model

delete models from disk

on Main menu on 12d Model menu
and floating menu
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models in the project area but not added to the project (removed models).

If a model is selected from the project model list, then it is automatically loaded into the Model 
Information panel.

The models walk-right menu is 

Project Models
project_models
Position of option on menu: Model =>Models =>Project models

The project models walk-right menu provides a list of all the models in the project and if a model 
name is selected from the list, a model information panel is fired up with the selected model 
name already in the model field.

Removed Models
removed_models
Position of option on menu: Model =>Models =>Removed Models

The removed models walk-right menu provides a list of all the models in the project area that are 
not in the project.

They would be mainly models that were in the project but have been removed from the project 
but not deleted from the disk.

Model Info
model_information
Position of option on menu: Model =>Model Info
Selecting model info fires up the model information panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

list of models in project
list of non-project models
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Model input available models

input the name of the model to get information about

xmin/ymin/zmin, xmax/ymax/zmax output

returns the model limits

point id min/max output

minimum/maximum integer point id in the model

Elements output

returns the number of elements in the model

num vertices output

returns the number of vertices in the model

num null vertices output

returns the number of null vertices in the model

Info button

get the information for the model given in the Model field.

Calc Extent button

recalculate the x, y, z bounding box for the model given in the Model field.

How to Use the Panel
The model information for the model given in the model field is retrieved and placed in the 
appropriate panel fields when the model name is entered into the model field from the pop-ups, 
or a <return> is entered after entering the model name into the model field, or on selecting the 
Info button.
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Model Info Table
model_information_table

Position of option on menu: Model =>Model Info Table

The Model info table option displays the minimum and maximum x, y and z values for every 
model in the project in one scrolling table.

The models and minimum and maximum columns can be sorted into ascending or descending 
order by using bringing up the sort menu on the column header fields.

Selecting Model info table fires up the Model Information Table panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model column header  sort menu

all the models in the project are listed in the model column.

Minimum x, Minimum y, Minimum z column header  sort menu
Maximum x, Maximum y, Maximum z

the minimum/maximum values for the model are displayed in the columns

Created/Updated date

date the model was first created/updated

Update button

recalculate the minimum/maximum information in the table.

Note

This is a scrolling panel. If there is too much information to fit into the table, then the scrolling 
arrow on the right hand side of the table must be used to display the extra information.
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String Info Table
string_information_table

Position of option on menu: Model =>String info table

The string info table option displays the minimum and maximum x, y and z values for every 
string in a given model in one scrolling table.

The models and minimum and maximum columns can be sorted into ascending or descending 
order by using bringing up the sort menu on the column header fields.

Selecting string info table fires up the string information table panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model input available models

give the name of the model to calculate the minimum/maximum string information for the 
table.

Name column header  sort menu

all the strings in the selected model are listed in the name column.

Minimum x, Minimum y, Minimum z column header  sort menu
Maximum x, Maximum y, Maximum z

the minimum/maximum values for each string in the model are displayed in the columns

Created/Updated date

date the string was first created/updated

Update button

recalculate the minimum/maximum information in the table.

Note

This is a scrolling panel. If there is too much information to fit into the table, then the scrolling 
arrow on the right hand side of the table must be used to display the extra information.
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Create
create_model__and_or_view

Position of option on menu: Model =>Create

On selecting the create option, the create model panel is displayed.This panel can be used to 
create new models and add a model to a view.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model input

name of the model to be created and/or added to a model and/or view.

Add to view input available views

if non-blank, the name of the view to which the model given in the model-field will be added.

Create button

If the model given in the Model field does not exist, it will be created.
If the add to view field is non-blank, then the model given in the model field will be added to the 
view given in the add to view field.

Rename
model_rename

Position of option on menu: Model =>Rename

On selecting the rename option, the model rename panel is displayed. This panel can be used to 
change the names of existing models

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Old model input available models

name of the model to be renamed.
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New model input

new name for the model

Rename button

Change the name of the model in the old model field to the name given in the new model field.
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Global Rename
global_model_rename

Position of option on menu: Model =>Global rename

On selecting the global rename option, the Global Model Rename panel is displayed. This panel is 
used to change the names of many existing models by matching according to a "pattern" 
expression or a "regular" expression.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Match sub strings tick box

if tick, the Search expression is used to match against part of each model name.
If not tick, the Search expression is used to match against the entire model name.

Pattern expression radio button

if set on, then Pattern expressions given in the Search and Replace fields are used to modify 
model names. Pattern expressions include the standard wild card * and wild character !.

Search input

pattern to search for in the model names. For example "* tin" will select all models with a 
name ending with "tin "

Replace input

replacement for the search pattern found in the model name. For example, "tin " takes the 
matched part of the model name and adds " tin " to the front of it.

Hence the Search pattern "* tin" and Replace pattern "tin *" finds all models with names 
ending in " tin" and renames them with the name starting with "tin " (and the " tin" at the end of 
the name is dropped off). 

Regular expression radio button

if set on, then Regular expressions given in the Search and Replace fields are used to modify 
model names.
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Search input

regular expression to search for in the model names.

Replace input

replacement for the search expression found in the model name.

Test data grid

The Test data grid shows the effect of the Search and Replace on all the model names in the 
project.

The Input column shows the existing model name.
The Output column shows the name after applying the Search and Replace.
The Status column displays if their has been a match or no match.

Rename button

change the name of all the models in the project according to the selected Search and Replace 
fields.
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Utilities
model_utilities

Position of menu: Model =>Utilities

The utilities menu contains miscellaneous options involving models.

The utilities walk-right menu is 

For the option Attributes, go to “Attributes” 
Add “Add” 
Copy project model “Copy Project Model” 
Remove “Remove” 
Save “Save” 
Project model utilities “Save” 

Attributes
model_attributes
Position of option on menu: Model =>Utilities =>Attributes

The Attributes options displays, creates and edits attributes for models.

On selecting Attributes, the Model Attributes panel is displayed.

create/edit attributes for models
add removed and other project models to project
copy model from another project
remove models from project
save models to disk
add/removes, saves, cleans, deletes models
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model model box all available models

model to create/edit attributes of

Name

name of the attribute

Type integer, real, text

type of attribute - integer, real or text

Data

value for the attribute

OK button

set the attributes to the values in the panel and then exit the panel.

Apply button

set the attributes to the values in the panel but don’t exit the panel.

Add
model_adds

Position of menu: Model =>Utilities =>Add

Models can be added to the project and to views.

The model adds walk-right menu is 
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Add To Project
add_model_to_the_project

Position of option on menu: Model =>Utilities =>Add =>Add to project

The add to project option is used to add a removed model back into the project.

On selecting the add to project option, the add model to the project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Removed model input removed models

name of the model not in the project that is to be added to the project.

Add button

add the model given in the removed model field to the working project.

Add All To Project
add_all_models_to_project

Position of option on menu: Model =>Utilities =>Add => Add all to Project

The add all to project option is used to add all the removed models back into the project.

On selecting the add all to project option, the add all models to project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Add button

after selecting this button, all removed models in the working project will be added to the 
project.
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Add to View
add_model_to_a_view

Position of option on menu: Model =>Utilities =>Add =>Add to view

On selecting the add to view option, the add model to a view panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model input available models

name of the model to be added to a view.

Add to view input available views

name of the view to which the model given in the model field will be added.

Add button

add the model given in the model field to the view given by the add to view field.
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Copy Project Model
copy_project_model

Position of option on menu: Model =>Utilities =>Copy Project Model

On selecting the copy project model option, the copy project model panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder input current directories

name of the folder that the project to get the model from, is in.

Project input current projects

name of the project in the folder given in the folder field, that the model is to be copied from.

Model input available models

name of the model to be copied.

New name input

if non-blank, the new name to be given to the copied model

Copy button

copy to this project, the model given in the model field from the project given in the project field. 
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Remove
model_removes

Position of menu: Model =>Utilities =>Remove

Models can be removed from the project and from views.

The model removes walk-right menu is 

The options in the menu will now be described.

Remove Model from Project
remove_model_from_project

Position of option on menu: Model =>Utilities =>Remove =>Remove from project

On selecting the remove from project option, the remove model from project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model input available models

name of the model to be remove from the working project.

Remove button

after selecting this button, the model given in the model field will be removed from the working 
project.

Remove All Models From Project
remove_all_models_from_project

Position of option on menu: Model =>Utilities =>Remove =>Remove from all projects

On selecting the remove all option, the remove all models from project panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Remove button

after selecting this button, all models in the working project will be removed. Next, all views 
will be refreshed. Finally, unless an error occurs, the panel will be removed.

Remove From View
remove_model_from_a_view

Position of option on menu: Model =>Utilities =>Remove =>Remove from view

On selecting the remove from view option, the remove model from a view panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model input available models

name of the model to be removed from a view.

Remove from view input available views

name of the view from which the model given in the model field will be removed.

Remove button

remove the model given in the model field from the view given in the remove from view field.
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Save
model_saves

Position of menu: Model =>Utilities =>Save

Models can be saved on disk so that they can be used for future project work or in other projects.

The model saves walk-right menu is 

The options in the menu will now be described.

Save a Model
save_model

Position of option on menu: Model =>Utilities =>Save =>Save a model

On selecting the save a model option, the save model panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model input available models

name of the model to be saved.

Save button

after selecting this button, the model given in the model field will be saved to disk.

Save All Models
save_all_models

Position of option on menu: Model =>Utilities =>Save =>Save all models

On selecting the save all models option, the save all models panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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Save button

after selecting this button, all models in the working project that have been modified since 
they were last saved, will be saved to disk. Unless an error occurs, the panel will be removed 
after the saving is completed.
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Sharing
shared_models

Position of menu: Model =>Sharing

Sharing allows models from a project (the server project) to be added to other projects (client 
projects). 

Before any models can be added to a client project, they must first be tagged in the server project 
as allowed to be shared.

The Sharing walk-right menu is 

For the option Share, go to “Share Models” 
Add “Add Shared Models” 
Remove “Remove Shared Models” 
Synchronize “Synchronize Shared Models” 

Share Models
share_project_models
Position of option on menu: Model =>Sharing =>Share

Before models in a server project can be added to client projects, the models must be made 
available for sharing in the server project by using the Share option.

Selecting Share displays the Share Project Models panel.

allow models in this project to used by other projects 
add a shared model from another project
remove a shared model from another project
updated shared models from other projects
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

All the models in the project are listed in the Share Project Models panel and if a model has 
been tagged for Sharing, a tick will be displayed in the Share column of the grid.

Pattern

if a pattern is typed then all the models matching the pattern will have a tick placed in the 
Share column. If * is typed then all models are ticked for sharing.

Share grid column

tick if the model is to be made available for sharing when the Set button is pressed.

Clicking RB on Share at the top of the column brings up a menu to Toggle the ticks, Set all 
the ticks on, Clear to turn all the ticks off.

Model grid column

this column lists all the models in the project

Set button

clicking Set tags all the models with a tick in the Tick column as being available for sharing. 
Those models without a tick will not be available for sharing.

Add Shared Models
add_shared_models_to_project
Position of option on menu: Model =>Sharing =>Add

The Add option is used to add shared models (from a server project) to the project (a client 
project).

Selecting Add displays the Add Shared Models to Project panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder folder box select folder

folder to look for 12d Model projects. When a folder is selected, all the 12d Model projects in 
the folder will be displayed in a Projects pop-up list.

Project folder box select folder

12d Model project to search for shared models

Search and Replace section:

Match sub strings tick box

if tick, the Search expression is used to match against part of each model name.
If not tick, the Search expression is used to match against the entire model name.

Pattern expressions or Regular expressions can be used to create New Model Names 
when a shared model is added to the project

Search - type in the expression
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Replace - type in the expression to replace the Search expression.

Copy tick boxes in grid column

if tick, the model will be added to the project when the Add button is pressed.

Clicking RB on Copy at the top of the column brings up a menu to Toggle the ticks, Set all 
the ticks on, Clear to turn all the ticks off.

Note - a shared model that has been previously added can only be removed by using the 
Model =>Sharing =>Remove option. 

Original Model Name grid column

this column lists all the models in the server project that are available for adding to this client 
project.

New Model Name grid column

if non blank, the name to use instead of the Original Model Name when the model is added 
t the project.
If blank, the Original Model Name is used for the model when it is added to the project.

Status output grid column

displays if there is a match or no match when a pattern or regular expression is used

Add button

clicking Add adds all the models with a tick to this project (a client project).

Refresh button

clicking Refresh refreshes the list of all models available for sharing in the selected 12d 
Model project
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Remove Shared Models
remove_shared_models_from_project
Position of option on menu: Model =>Sharing =>Remove

The Remove option is used to remove shared models from the.project. The shared models would 
have been previously added to the project with the Model =>Sharing =>Add option.

Selecting Remove displays the Remove Shared Models from Project panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Search and Replace section:

Match sub strings tick box

if tick, the Search expression is used to match against part of each model name.
If not tick, the Search expression is used to match against the entire model name.

Pattern expressions or Regular expressions can be used to select and tick shared models.

Remove tick boxes in grid column

if tick, the model will be removed from the project when the Remove button is pressed.

Clicking RB on Copy at the top of the column brings up a menu to Toggle the ticks, Set all 
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the ticks on, Clear to turn all the ticks off.

Model Name grid column

this column lists all the models in this project that have been added from other (server) 
projects

Ref path

this column lists the full path name to the server project and the original model name in the 
server project

Remove button

clicking Remove removes all the models with a tick from this project (a client project).

Refresh button

clicking Refresh refreshes the list of all shared models previously added to the project
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Synchronize Shared Models
synchronize_shared_models
Position of option on menu: Model =>Sharing =>Synchronize

The Synchronize option is used to updated any added shared models. The shared models would 
have been previously added to the project with the Model =>Sharing =>Add option.

Three environment variables control the synchronization of updates of added shared models 
and tins. For more information on synchronizing, go to the section “Share Settings” .

Selecting Synchronize displays the Synchronize Shared Models panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Synchronize tick boxes in grid column

if tick and the model has changed in the server project, then it will be re-copied from the 
server project when the Synchronize button is pressed.

Clicking RB on Copy at the top of the column brings up a menu to Toggle the ticks, Set all 
the ticks on, Clear to turn all the ticks off.

Model grid column

this column lists all the models in this project that have been added from other (server) 
projects

Synchronize button

clicking Synchronize re-copies any models with a tick from the server projects

Refresh button

clicking Refresh refreshes the list of all shared models previously added to the project
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Clean
clean_model

Position of option on menu: Model => Clean

The clean option is used to delete all the strings in a model but the model itself is not deleted. 
The model is still attached to any views it had been added to.

To help protect the user against disasters, when a model is selected for cleaning, a yes-no pop-up 
menu is invoked to confirm that the user did intend cleaning out the model.

Wild cards (*) and wild characters (!) can be used to select the models to clean and then a list of 
selected models is displayed for confirmation.

If cleaning is confirmed, all the strings in the selected models are deleted.

On selecting the clean model option, the clean model panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model input available models

name of the model to be cleaned out. Wild cards * and characters ? can be used to give a list 
of models to be cleaned.

Clean button

after selecting this button, all strings in the model given in the model field will be deleted. A 
yes-no pop-up is used to confirm that cleaning is required.
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Delete
model_deletes

Position of menu: Model => Delete

Using the delete option, models can be deleted from disk so that they no longer can be accessed 
or take up disk space.

To help protect the user against disasters, when a model is selected for deletion, a yes-no pop-up 
menu is used to confirm that deleting the model is intended. If deletion is confirmed, the selected 
model is deleted from the project and the disk.

The model delete walk-right menu is 

For the option Delete a model, please continue to the section “Delete a Model” .
 Delete empty models, please continue to the section “Delete Empty Models” .
 Delete all models, please continue to the section “Delete All Models” .

Delete a Model
delete_model

Position of option on menu: Model =>Delete =>Delete a Model

The delete a model option can be used to delete a model in the working project.

Wild cards (*) and wild characters (!) can be used to select the models to delete and then a list of 
selected models is displayed for confirmation.

On selecting the delete a model option, the delete model panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model input available models

name of the model to be deleted. Wild cards * and characters ? can be used to give a list of 
models to be deleted.

Delete button

after selecting this button, the model given in the model field will be deleted from the 
computer disk. A yes-no pop-up is used to confirm that deletion is required.
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Delete Empty Models
del_empty_model_panel

Position of option on menu: Model =>Delete =>Delete Empty Models

The delete empty models option displays a list of all the empty models in the project and can 
delete selected empty models or all of them.

On selecting the delete empty models option, the delete empty models panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

List of empty models models available models

the pop-up brings up a list of all the empty models in the project. A model can be selected 
from the list and it will be deleted after selecting the delete button.

Delete button

delete the model given in the list of empty models field.

Delete all button

delete all the empty models in the project.

Delete All Models
delete_all_models

Position of option on menu: Model =>Delete =>Delete All Models

The delete all models option will delete all the models in the project. It does not delete models 
that are in the project area but not yet added to the project.

On selecting the delete all models option, the delete all models panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Delete button

after selecting this button, a yes-no pop-up is used to confirm that deletion is required. If it is, 
all models in the working project will be deleted from disk. All views will be refreshed and 
unless an error occurs, the panel will be removed.
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Project Model Utilities
project_models_utilities
Position of option on menu: Model =>Utilities =>Project model utilities

The Project Model Utilities panels can add/remove models from the project, clean and delete 
models, add/remove models from views.

On selecting Project model utilities, the Project Model Utilities panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Disk Models section

options add removed models to the project and delete removed models

Project Models section

options to save/remove/clean/delete models, add/remove models from a view

Display empty models only tick box

if tick, only empty models are listed.

Refresh button

refresh the model properties displayed in the panel

List of models removed

Tick on for the model

the options below 

Click to add ticked models

Click to delete the models 

Save the ticked models 

Remove the ticked
models from the project 

Clean the
ticked models

Delete the
ticked models

List of

Tick on for the

for the options below 
models to be used

from the project 

to be used for

to the project 

the project 
models in

Remove the
ticked models
from the view

Tick displayed
if model is
on the view
listed below

Add the
ticked models
to the view
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13  Views
views

Position of menu: View

Views are the drawing display areas in 12d Model.

The views walk-right menu contains options to list existing views and create new views. The 
view drawing and manipulation options are in the View menus attached to each view.

The views walk-right menu is

For the option New, go to the section “New” 
Toolbars  “Toolbars” 
Status bar “Status Bar” 
Views  “Views” 
View info “View Info” 
Create “Create” 
Dump “Dump” 
Rename “Rename” 
Delete “Delete” 
Models save/restore “Models Save/Restore” 
Model transfer “Models Transfer” 
Visualisation “Visualisation” 

create new views
turn Toolbars on/off
toggle Status Bar on/off
create floating Views menu (see right)

list of defined views
info about the data on the view
create plan, perspective, section views
write out a view in raster format
rename a view
delete a view
save/restore list of models on view
transfer models between views
helpful visualisation options
User defined Views menu

on Main menu on 12d Model menu
and floating menu
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New
Position of option on menu: View =>New

The New walk-right menu provides options to create views of type Plan, Section, Perspective, 
Perspective OpenGL and Perspective Hide.

After selecting one of the options, a new view of the appropriate type with the next sequential 
view number is created in the Views Area.

Toolbars
Position of option on menu: View =>Toolbars

Clicking on Toolbars brings up the Toolbars panel 
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Clicking the tick on/off for a given toolbar or controlbar in the Toolbars list turns the toolbar or 
controlbar on/off.

Status Bar
Position of option on menu: View =>New

Toggles the Status Bar on/off.

Views
view_list

Position of option on menu: View =>Views

The Views walk-right menu provides a list of the all the views defined in this session of 
12d Model.

For each view in the list, a further walk-right menu lists all the models added to that view.



12d Model Reference Manual

Page 602 April 2007View Info

View Info
view_information

Position of option on menu: View =>View Info

Selecting view info fires up the view information panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View input available views

input the name of the view to get information about

xmin/ymin/zmin, xmax/ymax/zmax output

returns the limits of all the models on the view

point id min/max output

minimum/maximum integer point id in the model

Elements output

returns the number of elements in all the models on the view

num vertices output

returns the number of points in all the models on the view

num null vertices output

returns the number of null vertices in all the models on the view

Info button

get the information for the view given in the view field.

Calc Extent button

recalculate the x, y, z bounding box for the models on the view given in the view field.

How to Use the Panel

The view information for the view given in the view field is retrieved and placed in the 
appropriate panel fields when the view name is entered into the view field from the pop-ups, or a 
<enter> is entered after entering the view name into the view field, or on selecting the info button.
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Create
view_create

Position of menu: View =>Create

The floating Create menu item operates in two ways.

First, if Create itself is activated (by clicking LB when Create is highlighted), the New View panel 
appears. The New View panel can be used to create plan, perspective and sections views.

Secondly, the Create walk-right brings up a the View Create menu. This walk-right menu has 
separate options for creating plan, perspective and section views.

The Main menu option View => Create will only work the second way

The Create walk-right menu is

The New View panel obtained by clicking LB on the Create menu item and the three options on 
the View Create menu will now be described.

For the option New view, go to the section “New View” .
Plan view “Plan, Perspective and Section Views” 
Perspective view “Plan, Perspective and Section Views” 
Perspective OpenGL view “Plan, Perspective and Section Views” 
Section view “Plan, Perspective and Section Views” 

New View
new_view

On selecting the Create option, the New View panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View name view box next view number

name of the new view to be created.

View type choice box plan plan, persp, section, persp openGL

type of the view to be created. There are three types of views - plan, perspective, perspective openGL and 
sections views.

create a plan view
create a perspective view
create a perspective OpenGL view
create a section view
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Create button

after selecting this button, a new view of the name and type given in the panel is created in the Views 
Area. The panel then disappears.
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Plan, Perspective and Section Views
new_plan_view

new_section_view

new_perspective_opengl_view   new_perspective_view

Position of option on menu:

View =>Create =>Plan/Perspective/Perspective OpenGL/Section view

On the Plan/ Perspective/Perspective OpenGL/Section view option, the New Plan/Perspective/
Perspective OpenGL/ Section view panel is displayed.

The fields and buttons used in this panels have the following functions.

Field Description Type Defaults Pop-Up

View name input next view number

name of the new plan/perspective/section view to be created.

Create button

after selecting this button, the new view of the specified name is created in the Views Area. The panel 
then disappears.

Dump
view_dump

Position of option on menu: View =>Dump

This option is used to write the view out in a user selected raster format. The option is identical 
to the Dump option on the View System menu.



12d Model Reference Manual

Page 606 April 2007Rename

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View view box available views

name of the view to be dumped

Include title tick box

if tick, include the view title area in the dump

Format choice box jpeg bmp, gif, jpeg, jpeg 2000, png, tga

format of the dump of the view

File file box

name of the file for the dump of the view

Dump button

dump the view in the given format

Rename
view_rename

Position of option on menu: View =>Rename

This option renames an existing view. 

Selecting Rename brings up the View Rename panel:

The fields and buttons used in this panels have the following functions.

Field Description Type Defaults Pop-Up
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Original view name view box available views

current name of the view

New view name view box available views

new name for the view

Rename button

rename the view
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Delete
delete_view

Position of option on menu: View =>Delete

This option deletes an existing view.

Since the easiest method to delete a view is to use the [X] in the top right hand corner of the view, 
the Delete View option is mainly used in rare cases such as when the view is not responding due a 
graphics card problem.

Selecting Delete brings up the Delete View panel:

The fields and buttons used in this panels have the following functions.

Field Description Type Defaults Pop-Up

View name view box available views

name of the view to delete

Delete button

delete the view
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Models Save/Restore
view_res_panel

Position of option on menu: View =>Models save/restore

This option is used to write out a list of models on the view and also to read in a list of models 
and add them to a given view.

On selecting the Models save/restore option, the view save/restore models panel is displayed.

The fields and buttons used in this panels have the following functions.

Field Description Type Defaults Pop-Up

Save tab tab

View to save view available views

view to write out list of model for.

File name for save file *.vml files

file for model list.

Save button

after selecting this button, the names of all the model on the view are written out to the file.

Restore tab tab

File name to restore file *.vml files

file of model list.

View to add view available views

view to add the models in the model list to.

Read button

read the list of models.

Restore button

add the models in the list just read in to the given view.
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Models Transfer
view_model_transfer_panel

Position of option on menu: View =>Models transfer

This option is used to add all the models on one view to a different view.

On selecting the models transfer option, the models transfer panel is displayed.

The user is then asked to click in the view to get the models from (source view) and then to select 
the destination view where the models are to be added to.

Note - if the destination view is a new view, click on Fit first to give the new view a valid co-
ordinate system.
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Visualisation
visualisation

Position of menu: View =>Visualisation

This is a chargeable module which uses the Perspective OpenGL view to create realistic 3d 
pictures using raster drapes, bitmaps and extrusions along super strings.

The Visualisation walk-right menu is

For the option Tin render settings, go to the section “Render Settings” in the chapter “Triangles” 
Render drape  “Render Drape” 
Texture map edit  “Texture Map Edit” 
Billboards  “Billboards” 
Extrusions  “Extrusions” 
Utilities  “Utilities” 

Tin Render Settings
Position of option on menu: View =>Visualisation => Tin render settings

This option sets texture mappings for triangles in a tin. It has already been documented as

Tins =>Edit =>Render settings

in the section “Render Settings”  of the chapter “Triangles” .

Render Drape
change_polygon_drape

Position of option on menu: View =>Visualisation => Render drape

Selecting Render drape brings up the Change Polygon Drape panel.

set rasters for draping on 
add images to billboards
edit texture map file
creating/editing with billboards
extrusions
mainly insert utilities
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The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.
Action choice box ignore set, clear, ignore

if set, .
If clear, .
If ignore, .

Drape name

Drape mode choice box colour, colour to texture

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings.

Texture Map Edit
texture_map_create_edit_delete

Position of option on menu: Visualisation =>Texture map edit

This option edits the texture mapping file which contains the texture map tables that can be 
applied to the coloured triangles of a tin in renderings.
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Each texture map table must have a unique name.

On selecting the Text map edit option, the Texture Map Create/Edit/Delete panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Texture map table

name of the texture map table inside the texture map file.

Colour colour box available colours

colour to apply the texture to.

Texture name texture box available textures

texture to apply to all triangles with the specified colour 

New button

to create a new texture map table, click on the New button and then type the texture map table name 
into the Texture map table field. Then start filling in the Colour and Texture name columns.

Update button

update the given Texture map table with the values in the Colour and Texture name columns.

Delete button

Delete the texture map table named in the Texture map table field.

Write button

write out the texture map information to the texture map file.
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Billboards
billboards

Position of menu: View =>Visualisation =>Billboards

The billboard options plane an image onto a rectangular billboard. this can be used to display 
background scenes, signs etc.

The Billboard walk-right menu is

Create “Create Billboards” .
Add/Remove “Add and Remove Billboard from Super String” .
Create forest  “Create Forest” .
Trees/shrubs  “Trees/Shrubs as Faces and Billboards” 

Create Billboards
create_and_place_billboard

Position of option on menu: View =>Visualisation => Billboards =>Create and add

This option is under development.

This option creates billboards and adds images to them.

On selecting the Create and add option, the Create and Place Billboards panel is displayed.

The fields and buttons used in this panels have the following functions.

Field Description Type Defaults Pop-Up

Naming tab tab

Image Data tab tab

create a billboard and add an image to it
add/remove a billboard to the vertices of a super string
create a forest within a polygon
place a billboard tree/shrub
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Positioning tab tab
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Add and Remove Billboard from Super String
change_super_string_billboards

Position of option on menu: View =>Visualisation => Billboards =>Add/remove from super string

Each vertex of a super string can have its own billboard.

A billboard consists of an image and a width and height.

The Add/remove from super string option places a selected billboard in a vertical plane at a user 
given distance from each vertex of a super string. The vertical plane is at a given angle or 
perpendicular to a selected string. An example could be the image on a stop sign which is in the 
vertical plane.

Selecting Global Add/remove to ss brings up the Change Super String Billboard panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.
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Action choice box ignore set, clear, ignore

if set, the billboard is placed at each vertex in the super string.
If clear, the billboard information at each vertex is cleared.
If ignore, nothing is done to the billboard information.

Billboard billboard box

billboard to be used.

Angle angle box

angle to rotation the billboard - positive is counter clockwise. This is ignored if Perpendicular is used.

Size

size of the symbol.

Colour colour box

colour for the back of the billboard.

Offset x, Offset y, Offset z

x/y/z distance to place the billboard away from the super string vertex.

Vertical tick box

if tick, the string is placed vertically and nothing else is needed.
If not tick, .

Drape name input

if Vertical is not ticked, then 

Perpendicular string select box

if a string is selected, then the billboard is placed on the line going through the vertex and 
perpendicular to the selected string. Angle is ignored.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings.
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Create Forest
create_forest

Position of option on menu: Visualisation =>Billboards =>Create forest

Create forest creates randomly placed trees and shrubs in a selected polygon.

The forest make up is controlled by a user defined forest file which gives the types and 
distribution of trees, and variation in size and spread.

Selecting Create forest displays the Create Forest panel

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Forest boundary polygon string select

polygon to create the forest within

Forest floor tin tin box available tins

 tin to use for the z-value for the base of the trees

Forest file file box .forests files

 file to give the make up of the forest. For more information, go to the section “Create Forest File” 

Trees per hectare input

density of the forest given by the number of trees per hectare

Model for forest model box available models

 model to place the trees in

Model for canopy data model box available models

 if non blank, points are created for the tops of the trees in the forest. These can be used to triangulated 
to give a top of trees tin.

Clean model (s) beforehand tick box

if tick, the forest and forest canopy models are cleaned before the option is run

Run button

run the option
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Create Forest File
forest_file

Position of option on menu: t

The Forest File gives the type and distribution of trees, and variation in size and spread.

Selecting brings up the Forest File panel

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Forest file polygon file box all .forest files

file for the forest definition

Read button

read in a forest file

Write button

write out a forest file

read in a forest file

Forest file grid:

Tree type billboard cell available billboards

 name of the billboard to place as a tree

Proportion of forest input cell

 relative density of this tree in the forest (the actual proportion is this value over the sum of all the 
proportions)

Minimum height input cell

 minimum height for this tree

Maximum height input cell

 maximum height for this tree
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%  spread variation input cell
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Trees/Shrubs as Faces and Billboards
12d_block_panel

trees_and_shrubs_panel

Position of option on menu: View =>Visualisation => Billboards =>Trees/shrubs

Position of option on menu: View =>Visualisation => Utilities =>Trees/shrubs faces

The Trees/shrubs - faces option inserts the trees and shrubs as face elements. This means that 
each tree may consist of hundreds or thousands of faces.

The Trees/shrubs option inserts the images of trees and shrubs as a fanned billboard. This means 
that each tree consists of only one points.

On selecting the Trees/shrubs faces option, the 3D Tree Insertion - Faces panel is displayed.

On selecting the Trees/shrubs option, the 3D Tree Insertion panel is displayed.
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The fields and buttons used in these panels have the following functions.

Field Description Type Defaults Pop-Up

Tree and Shrub tabs

click on the tab to display the type of tree/shrub to be inserted. The picture shows the tree height and 
spread.

Model model box available models

model to add the tree/shrub to.

Scale - Factor real value 1 measures

factor to blow the block up by.

Single radio button

if ticked then the tree is placed at the selected position.

Along a string radio button

if ticked then the tree is placed along a string. When the string is selected then a Tree Interval panel is 
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brought up to specify how the trees are placed along the string.

Select button

select the string or position for the tree.

Process button

insert the trees/shrubs.

tree_interval

Tree Interval

This panel is for specifying how often the trees/shrubs are to be inserted along the string.

Field Description Type Defaults Pop-Up

Interval type choice box by number by number
by distance
by special chg file
by vertex

if by number: an Interval number field is displayed on the panel and the tree is inserted that many 
times along the string.

if by distance: an Interval distance field is displayed on the panel and the tree is inserted with that 
distance separation along the string.

if by special chg file: a Special chg file field is displayed on the panel and the tree is inserted along the 
string at the chainages given in the file.

if by vertex: the tree is inserted at every vertex of the string.

Set button

set the parameters for tree interval to those in the panel. 
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Extrusions
extrusions

Position of menu: View =>Visualisation =>Extrusions

The billboard options plane an image onto a rectangular billboard. this can be used to display 
background scenes, signs etc.

The Billboard walk-right menu is

String along string “Extrude string” 
Library extrude “Change Library Extrude” 
Roadside furniture “Roadside Furniture” 
Create “Create Group Extrusions” 
Fences “Fences” 
Tutorial “Tutorial to Create Group Extrusions” 

Extrude string
string_extrude

Position of option on menu: View =>Visualisation => Extrude string

The Extrude option extrudes a selected super string along a super string. 

Only the (x,y) co-ordinates of the string used as the extrude as used and the (x,y) co-ordinates are 
then taken as (offset, height) in the plane perpendicular to the string to extrude along.

extrude along s string
add/remove a billboard to the vertices of a super string
insert roadside furniture
create a complicated extrusion
extrude fences along strings
tutorial on creating complicated extrusions
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On selecting the Extrude option, the String Extrude panel is displayed.

The fields and buttons in this panel have the following functions.

Field Description Type Defaults Pop-Up

String string select

super string to extrude along

Extrude string select

super string representing the extrude.

Factor input 0.1

value to factor the extrude string by.

Extrude button

Create the extrusion.

string to extrude along
closed extrude string

extrusion

+ =

string to extrude along
open extrude string

extrusion

+ =
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Change Library Extrude
change_library_extrude

Position of option on menu: Visualisation =>Library extrude

Apply or remove an extrusion from the library to a super string.

On selecting the Library extrude option, the Change Library Extrude panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.
Action choice box ignore set, clear

if set, the library extrude is applied to the super string.
If clear, all existing extrusions are removed from the super string.
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Extrude name extrude box

extrude to be applied to the super string.

Overwrite library properties tick box

if no tick, the placement properties are taken from the extrude in the library.
if tick, the placement uses the information in the grid on the panel.

Start/end chainage chainage box

start/end chainage for applying the extrusion.

Start/end chainage chainage box

start/end chainage for applying the extrusion.

Chainage interval

only applicable when the extrusion in an interval extrude.

Grid of X,Y,X against Factor, Rotate, Offset

placement information for applying the extrude.

Use extrude colour tick box

if tick, the placement uses the information in the grid on the panel.
if no tick, then the string segment colour is used for the extrusion.

Reflect extrude tick box

if tick, the extrude is reflected in the local y axis before it is applied.

Replace existing extrudes tick box

if tick, all existing extrudes are cleared before the new one is applied.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected string
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Roadside Furniture
roadside_furniture_panel

Position of option on menu: View =>Visualisation => Extrusions =>Roadside furniture

This option is for inserting extruded objects that have been supplied by 12D Solutions Pty Ltd.

It includes street lights, log barriers, park bench, posts and columns, walls, timber fences, guard 
rails, sighs etc.

The list of items that can be inserted is being continuously upgraded by 12D Solutions.

Selecting Roadside furniture brings up the Roadside Furniture panel.

Clicking on the tabs brings up the information required for that piece of roadside furniture. 

For all the tabs other than Park Bench, Street Light and Guard Rail, once a tab had been selected, 
moving the cursor over the picture brings up a special panel for the extra information required. 
For example, for the Sign tab, moving the cursor over the picture brings up the Sign Details 
panel:

sign_details
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Create Group Extrusions
extrusions_create_panel

Position of option on menu: View =>Visualisation => Extrusions =>Create

The Create option creates groups extrusions.

Selecting Create brings up the Create - Group Extrusions panel.

Tutorial to Create Group Extrusions
extrusions_tutorial_panel

Position of option on menu: View =>Visualisation => Extrusions =>Tutorial
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The Tutorial option demonstrates how to creates groups extrusions and will also create groups 
extrusions.

Selecting Tutorial brings up the Tutorial - Group Extrusions panel.
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Fences
12d_vis_fences_panel

Position of option on menu: View =>Visualisation => Extrusions =>Fences

This option is for extruded 12d Sultans supplied fences along strings.

The list of fences is being continuously upgraded by 12D Solutions.

Selecting the Fences brings up the Visualisation Fence Extrusions panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Clicking on the tabs brings up the type of fence to be extruded along selected super strings.

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of super string to extrude fences along

Process button

apply the fence to the selected super strings
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Houses
12d_vis_house_panel

Position of option on menu: View =>Visualisation => Utilities =>Houses

This option is for inserting 12d Sultans supplied houses.

The list of houses is being continuously upgraded by 12D Solutions.

Selecting the Houses brings up the Visualisation 3D Buildings panel.

The fields and buttons used in this panel have the following functions:

Clicking on the tabs brings up the type of house to be inserted.

Centre of building xyz box position select

give the x y z co-ordinates for the centre of the base of the inserted building

Orientation angle box angle select

give the angle to orient the building

Process button

insert the selected building
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Utilities
visualise_utilities

Position of menu: View =>Visualisation =>Utilities

The Utilities walk-right menu is

For Clouds go to the section “Clouds” 
Billboards on strings  “Create Billboards” 
Fences  “Fences” 
Forest  “Create Forest” 
Houses  “Houses” 
Line marking  “Line Marking” 
Roadside furniture  “Roadside Furniture” 
Trees/shrubs billboards  “Trees/Shrubs as Faces and Billboards” 
Trees/shrubs faces “Trees/Shrubs as Faces and Billboards” 

Explode text  “Explode Text” in the chapter “Utilities” 
Colour within polygon  “Colour Within Polygon” in the chapter “Triangles” 

create clouds as background
change billboards on super strings
inserting fences
create forest
insert houses
create strings for line marking
insert fences, guard rails, signs, walls etc.
insert trees and shrubs as billboards
insert trees and shrubs as faces

colour within a polygon
explode text into vectors so it can be draped onto surface
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Clouds
clouds_panel

Position of option on menu: View =>Visualisation =>Utilities =>Clouds

This option is used to create a square box around the view with the cloud image on the inside of 
it. From within a scene, this will then appears as a sky with clouds as the background.

On selecting the Clouds option, the Visualisation Clouds panel is displayed:

The fields and buttons used in this panel have the following functions:

Model model box available models

model to place the cloud square in.

Centre of cloud square xyz box position select

give the x y z co-ordinates for the centre of the cloud square.

Process button

create the cloud square.

Line Marking
line_marking_panel

Position of option on menu: View =>Visualisation => Line marking

This option is used to create polygon data in 3d representing the line marking on a road. The pol-
ygons can then be included in the design tin for triangulating and the “Colour Triangles Within a 
Polygon” option used to colour the triangles for use in shades and renderings.

The line marking polygons created by the option represents a dashed line style centred around 
the selected line marking string marking the position of the dashed line. The length and separa-
tion of the dashed lines are user defined and the width of the dash is defined by a width to the 
left and a width to the right of the line marking string.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

line marking position stringstring select

select the string to define the position of the line marking on the road. The string will also provide z-
values for use in creating the line marking.

Colour for line marking input box green available colours

colour for the line marking polygons.

Length of the line marking input box 9

length of each line mark dash.

Gap to next line marking input box 3

distance between the line marking dashes.

Width of line marking on lhs of line    input box     0.05

width of the line marking on the left hand side of the line marking position string.

Width of line marking on rhs of line    input box     0.05

width of the line marking on the right hand side of the line marking position string.

Crossfall (%) on lhs of line input box -3

cross fall for the part of the line marking on the left hand side of the line marking position string (so z-
values for the polygon can be calculated).

Crossfall (%) on rhs of line input box -3

cross fall for the part of the line marking on the right hand side of the line marking position string (so z-
values for the polygon can be calculated).

Model for line marking polygons    model box   line marking available models

model for the polygons representing the line marking.

Model for line marking centre    model box   line marking ctr available models

model for a string with just the part of the line marking position string which is inside the line marking 
polygons.



12d Model Reference Manual

Page 636 April 2007Visualisation

Create button

run the option and create the line marking polygons.

Undo button

undo the last set of polygons created since the panel was up.

Explode Text
Position of option on menu: View =>Visualisation =>Utilities =>Explode text

This option explodes text into lines and arcs. It has already been documented as

Utilities =>A-G => Explode text

in the section “Explode Text”  of the chapter “Utilities” .

Colour Within Polygon
Position of option on menu: View =>Visualisation =>Utilities =>Colour within polygon

This option colours triangles in a tin. It has already been documented as

Tins =>Colour =>Colour within polygon

in the section “Colour Within Polygon”  of the chapter “Triangles” .
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14  Strings
strings

Position of menu: Strings

Strings are the basic modelling elements of 12d Model.

The strings walk-right menu contains options to create, edit and manipulate strings in a variety of 
ways including copying, moving strings between models and deleting strings.

The strings walk- right menu is

For CAD “CAD” 
Create “Create” 
Editor “Editor” 
Points edit “Points Edit” 
Strings edit “Strings Edit” 
Cogo “Cogo” 
Convert “Convert” 
Inquire “Inquire” 
Properties “Properties” 
Label “Label” 
Rasters “Rasters” 
Utilities “Utilities” 
Delete “Delete” 

Note

For the floating menu, the strings option has another mode of operation. Rather than moving 
onto the walk-right arrow, if LB is clicked when the strings button is highlighted on the 
12d Model menu, the string inquire panel is displayed on the screen. Unfortunately this does not 
work on the Main menu.

create floating menu Strings

CAD options
create strings
editing strings
points edit
whole string edits
co-ordinate geometry
convert between string types
inquire on a string
modifying string properties
label strings
rasters
various string utilities
user define string commands
delete a string

on Main menu on 12d Model menu
and floating menu
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CAD
cad

Position of option on menu: Strings =>CAD

In 12d Model there are CAD options which are available under both the Strings =>CAD menu and 
flyouts on the CAD Toolbar which by default, is on the left hand side of the 12d Model screen.

The CAD options create and edit strings using a variety of methods and are fully described in the 
section “CAD Options” .

The strings created by the CAD menu or CAD toolbars use values in the three controlbars (Cad 
Controlbar, Symbol Controlbar, and Text Controlbar) to define string attributes such as name, 
model and colour.

So the controlbars will be described in full in the section “CAD, Symbol and Text Controlbars”  
before the CAD options.

For basic information on toolbars and controlbars, see the section “Toolbars and Controlbars”  in 
the chapter “Tools and Concepts” .

The CAD options create various elements using a number of methods. These options make use of 
Tool bars and Control bars. Tool bars just have icons on them but Control bars have icons and 
also controls such as a model box on them. The method groupings are shown on the toolbars 
(e.g. Points, Lines etc.). 

For details on each of the walk rights menus on the CAD menu, go to the section “CAD Options” 

For details on the Controlbars go to the section “CAD, Symbol and Text Controlbars” 

CAD, Symbol and Text Controlbars 
This default position of the controlbars is on the top left hand side of the screen under the main 
menu.

CAD Controlbar

The fields and buttons used in CAD controlbar have the following functions.

Field Description Type Defaults Pop-Up

name box names.4d names

name of string. If a valid name already exists in names.4d, the + button can be used to bring up a 
choice box of available names. On selection of a valid name, the rest of the values in the control bar 
will be filled out. e.g. colour, linetype etc.

CAD controlbar Symbol control bar Text control bar
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model box cogo existing models

this field can be recognised by the model icon button on the right hand side of the field. The user can select 
an existing model by selecting the model icon. If a new model is to be used, the user simply types the model 
name into the field.

colour box red standard 12d colours

this field can be recognised by the colour icon button on the right hand side of the field. The user can select 
a12d standard colour model by selecting the colour icon

input height measures menu

this field allows a height or z value to be assigned to the created elements. If a valid value exists, this value 
will be applied to the created element. This is regardless if the z value was specified in an XYZ box. If blank, 
the null value is used.

If no value is specified, the level will be interpolated where possible. A value of null can be entered into the 
height field as well so that created points will be given a null height value.

linetype box 1 valid linestyles

this field can be recognised by the linestyle icon button on the right hand side of the field. The user can 
select a valid linestyle by selecting the linestyle icon.

weight box

this field can be recognised by the weight icon button on the right hand side of the field. The user can type 
in the required weight (millimetres on the plot). If blank, no weight is assigned.

tinability box no, yes, points

the choices in this field set the tinability for the string.
If no, no vertices or segments in the string are tinable.
If yes, all vertices and segments in the string are tinable.
If point, all vertices in the string are tinable but not the segments.

button

the eye dropper allows the user to select an existing element which will define the cad control bar values.

Symbol Controlbar

The fields and buttons used in Symbol controlbar have the following functions.

Field Description Type Defaults Pop-Up

The  symbols data box allows a symbols favourite to be selected and fill the other boxes. The 
symbols data box will be described after the other controls.

symbols box valid symbols

this field can be recognised by the symbol icon button on the right hand side of the field. The user can 
select a valid symbol by selecting the symbol icon.

input size measures menu

this field gives the size of the created symbols. If a valid value exists, this value will be applied to the 
created symbol. 
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input angle measures menu

this field gives the angle of the created symbols. If a valid value exists, this value will be applied to 
the created symbol. 

Symbols data box 

on pressing the button a list of available symbols data predefined names read from the 
symbols_names.4d file are displayed. If a symbols data is selected, the values are used for the other 
Symbol Controlbar fields.

If no names exist, the user can edit the current settings by selecting the edit button and bring up the 
Symbols Information panel. This allows for definition of symbol colour, sized, rotation, offset and 
raise.

Text Controlbar
Text can occur as a text string, or on vertices and segments of a super string.

Each type of text has a vertex (these are displayed when Vertices are toggle on in a plan view), a 
justification point, a rotation, an offset and raise value.

The vertex and justification point only coincide if the offset and raise values are both zero. What 
parts of the text on a super string vertex or segment that can be independently modified depends 
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on the settings for the super string.

For the CAD text options, the created elements will have attributes as defined by the Text 
Controlbar. The default position of the Text Controlbar is in top middle of the screen under the 
main menu.

 The Text Controlbar is

The operation of the Textstyle data box is as follows:

Textstyle data box 

on pressing the button a list of available textdata predefined names read from the texstyle_names.4d 
file are displayed. 

If no names exist, the user can edit the current settings by selecting the edit button and bring up the 
Textstyle Data panel. This allows for definition of textstyle, units, height offset raise etc.

the user can select an existing textstyle by 
selecting the textstyle icon or entering a 
value into the input box to the left of the 
button. 

the user can measure a height by selecting the text 
height icon or entering a value into the input box 
to the left of the button. The value units are 
defaulted to world units. This can be changed in 
the textstyle data box

a textstyle favourite can be 
selected which then defines the 
text style and height values.

select textstyle data

select textstyletextstyle

measure for
text height height
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.

CAD Options
The CAD options are available from the CAD menu or from the CAD toolbar. The CAD toolbar is a 
flyout toolbar.

The CAD walk-right menu is

and the CAD Toolbar is

The string creation process is similar for each string type and for editing strings as well. On 
selecting the appropriate option, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.
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For the option Points please go to the section “CAD Points” .
Lines “CAD Lines” .
Intersectt “CAD Intersect” 
Circles “CAD Circles” .
Arcs “CAD Arcs” .
Polygons “CAD Polygons” .
Text “CAD Text” .
Symbols “CAD Symbol” .
Fills “CAD Fills” .
Images “CAD Images” .
Modify “CAD Modify” .
Change points “CAD Edit Points” .
Change segments “CAD Segment Edits” .
Change strings “CAD Edit Strings” .
Delete “CAD Delete” .
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CAD Points
cad_points

Position of option on menu: Strings =>CAD =>Points

The Points walk-right menu is

For the option By Selection, please go to the section “By Selection” 
Mid segment  “Mid Segment” 
Centre point  “Arc Centre” 
Mid point  “Mid point” 
Chainage  “Chainage” 
Bearing distance “Locate by Bearing/Distance” 
Offset “Create an Offset Point” 
Deflection “Create a Deflection Point” 
Drop perpendicular  “Drop Perpendicular” 
Projection “Projection Locate” 
Between points “Between Points” 
Between points (3d) “Between Points (3d)” 
Radiation “Radiation” 
Divide segment by number “Divide Segment by Number” 
Divide segment by chainage length “Divide Segment by Chainage Length” 
Divide string by number “Divide String by Number” 
Divide string by chainage length “Divide String by Chainage Length” 

By Selection
Cad_Point_Position

Position of option on menu: Strings =>CAD =>Points =>By selection

or by selection of appropriate icon from the toolbar. 

Menu of Options to Create New One Point Strings

at a user selected position
at middle of a selected segment
at the centre point of an arc
at the position of a chainage along a selected string
at a distance between two selected positions
distance between two selected positions with interpolated z
dropped perpendicularly onto a selected string
projected a chainage distance along a selected string
a given distance at right angles to a selected string
a given distance at a given angle to a selected ring
a given bearing and distance from a selected position
many points at given brgs and dists from a selected position
pts which divide selected seg into a number of equal segs
pts which divide selected seg into segs of given length
pts which divide selected string into a number of equal pieces
pts which divide selected string into pieces of given length
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This option creates a single vertex (point) string. 

On selecting By selection, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

The user can select a position with the mouse and on accepting that point (Middle mouse button 
or enter) the point is created at the selected position. The model, colour, height etc. are defined in 
the Cad Control Bar.

The snap mode will influence the mouse selection. For example if cursor snap is on, the user can 
choose a position not yet defined. If point snap is on and the selection snaps to an existing point, 
the option will place another point at that location.

The user can also activate the selection menu used with the mouse (right button) that allows 
various positioning options.

Specification of a position can also be done by the direct input of the xyz coordinate of the point 
by pressing the space bar to bring up the enter XYZ panel or by typing of the value to bring up 
the XYZ panel. NOTE: The z value will default to the value entered into the Cad Control Bar 
whether or not it is specified in the XYZ box. If no height value exists in the Cad Control Bar 
then a value will be interpolated if possible, otherwise a null value will be assigned.

Mid Segment
Cad_Point_Middle_Segment

Position of option on menu: Strings =>CAD =>Points =>Mid segment

or by selection of appropriate icon from the toolbar. 

This option creates a point in the middle of a selected line or arc segment.

On selecting Mid segment, the user is prompted to select a segment and a vertex is created at the 
mid point of the segment. The model, colour, height etc. are defined in the Cad Control Bar.

Arc Centre
Cad_Point_Centre_Segment

Position of option on menu: Strings =>CAD =>Points =>Centre point

or by selection of appropriate icon from the toolbar. 

This option creates a point at the centre of a selected arc or circle.

On selecting Centre point, the user is prompted to select an arc and a vertex is created at the 
centre of the arc. The model, colour, height etc. are defined in the Cad Control Bar.

Mid point
Cad_Point_Middle

Position of option on menu: Strings =>CAD =>Points =>Mid point

or by selection of appropriate icon from the toolbar. 

This option creates a point in the middle of two selected positions.

On selecting Mid point, the user is prompted to select the first position and then the second 
position. A vertex is created at the mid point of the two selected positions. The model, colour, 
height etc. are defined in the Cad Control Bar.

Chainage
cad_locate_chainage

Position of option on menu: Strings =>CAD =>Points =>Chainage

or by selection of appropriate icon from the toolbar. 
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This option creates a new point at the position of a user specified chainage of an existing string.

On selecting Chainage, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The user selects a valid string (left mouse button) and accepts that string (Middle mouse button 
or enter).

STEP 2:

The user enters a chainage value where a point should be placed followed by the enter key. This 
chainage is with respect to the selected string.

STEP 3:
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A new one point string is created at the positioned on the string at the given chainage.

To create another point, the user is prompted for the string as per STEP 1.

Locate by Bearing/Distance
Cad_Point_Locate_Bearing_Distance

Position of option on menu: Strings =>CAD =>Points =>Bearing distance

or by selection of appropriate icon from the toolbar. 

This option calculates a point string that is located a given bearing and distance from a start 
position.

On selecting Bearing/distance, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A start position is selected and accepted.
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STEP 2:

A bearing is selected with the mouse or entered in via the keyboard. For typed entry, simply start 
typing or press the space bar to bring up the bearing entry box. The value is entered into the 
input box followed by the enter key.

The line drawn represents the bearing value and changes with movement of the mouse. If the 
user wants to see what the current value of the bearing is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the bearing continued.

Note: The Page up and page down keys can be used when the input angle box comes up to 
add or subtract intervals of 90 degrees.

This option also allows the definition of the bearing by the selection of the 2nd point 
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perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

STEP 3:

A distance is selected and accepted with the mouse or entered in via the keyboard. For typed 
entry, simply start typing or press the space bar to bring up the distance entry box. The value is 
entered into the input box followed by the enter key.

The circle drawn represents the distance value and changes with movement of the mouse. If the 
user wants to see what the current value of the distance is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the circle continued.
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This option also allows the definition of the distance by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

The perpendicular distance shown below by the purple line will be use at the defined bearing to 
create the point.
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STEP 4:

A point string is created using the information supplied. By entry into the input boxes:

Or by using the perpendicular/tangential tools:
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Create an Offset Point
Cad_Point_Locate_Offset

Position of option on menu: Strings =>CAD =>Points =>Offset

or by selection of appropriate icon from the toolbar. 

This option creates a one point string that is located by reference to a string, a control point, a 
chainage distance along the string from the control point and an offset to the selected string. 

After selection and acceptance of a string, a control point is selected and accepted. This point is 
dropped perpendicular onto the string. The distance along the string is measured from this 
dropped point. Positive distances are in the direction that the string was picked. Finally a offset 
to the string can be specified for the placement of the new point string.

On selecting Offset, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The user selects and accepts a string with direction. This defines what side the offset applies to.



Chapter 14  Strings

May 2007 Page 653CAD

STEP 2:

The user picks and accepts a control point to be dropped onto the selected string.

STEP 3:

A distance along from the dropped point is specified. Positive distances are in the direction of 
the string selection pick. The value is entered into the input box followed by the enter key.
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STEP 4:

An offset relative to the selected string (and direction) is specified in the input box followed by 
the enter key.

STEP 5:

A point string is created using the information supplied.
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Create a Deflection Point
Cad_Point_Locate_Deflection

Position of option on menu: Strings =>CAD =>Points =>Deflection

or by selection of appropriate icon from the toolbar. 

This option creates a one point string that is located by reference to a string, a control point, a 
distance along the string from the control point, a deflection angle and deflection distance.

After selection of a string, a control point is selected. This point is dropped perpendicular onto 
the string. A distance along the string can be entered to move the measure point. Positive 
distances are in the direction that the string was picked. A deflection angle is specified which is a 
clockwise angle from the measure point. The deflection distance is the distance from the measure 
point to the point which is to be created.

On selecting Deflection, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The user selects and accepts a string with direction.
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STEP 2:

The user picks and accepts a control point to be dropped onto the selected string.

STEP 3:

A distance along from the dropped point is specified. Positive distances are in the direction of 
the string selection pick. The value is entered into the input box followed by the enter key.
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STEP 4:

A deflection angle is specified. This angle is clockwise, relative to the direction of the string 
selection pick. The value is entered into the input box followed by the enter key.

Note: The Page up and page down keys can be used when the input angle box comes up to 
add or subtract intervals of 90 degrees.

STEP 5:

A deflection distance is supplied. Positive is in the direction of the string selection pick. The 
value is entered into the input box followed by the enter key.
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STEP 6:

A point string is created using the information supplied.

Drop Perpendicular
Cad_Point_Locate_Perpendicular

Position of option on menu: Strings =>CAD =>Points =>Perpendicular

or by selection of appropriate icon from the toolbar. 

This option creates a one point string by dropping from a user selected position perpendicularly 
onto a user selected string.

On selecting Perpendicular, the user is prompted for the relevant data in the screen message box 
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located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The user selects a string and accepts (with direction) to have the point dropped onto.

STEP 2:

The user picks and accepts a position to drop onto the nominated string

STEP 3:

A point string is created at the perpendicular drop point.



12d Model Reference Manual

Page 660 May 2007CAD

Projection Locate
Cad_Point_Locate_Projection

Position of option on menu: Strings =>CAD =>Points =>Projection

or by selection of appropriate icon from the toolbar. 

This option creates a one point string that is located by firstly dropping a point onto a string and 
then giving a distance along the string from the dropped point.

On selecting Projection, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The user selects and accepts a string (with direction) to have the point dropped onto
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STEP 2:

The user picks and accepts a position to drop onto the nominated string

STEP 3:

The user is prompted for the distance along the string. Positive distances are in the direction that 
the string was picked. A value is entered into the input box followed by the enter key.

STEP 4:

The point string is created the nominated distance along the string from the dropped point.
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Between Points
Cad_Point_Between_Points

Position of option on menu: Strings =>CAD =>Points =>Between points

or by selection of appropriate icon from the toolbar. 

This option creates a one point string that is on the line between two selected positions and a 
given distance from the first point.

On selecting Between points, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The user selects a start point. Specification of a position can be done by the direct input of the xyz 
coordinate of the point by pressing the space bar to bring up the enter XYZ panel or by typing of 
the value to bring up the XYZ panel. The user can also select a point with the mouse and accepts 
that point (Middle mouse button or enter).



Chapter 14  Strings

May 2007 Page 663CAD

STEP 2:

The user picks a 2nd point and accepts that point (Middle mouse button or enter) to define the 
reference line.

STEP 3:

A distance from the 1st point to create the point is given either by selection with the mouse or by 
typing a value. To type a value, simply start typing and the input box for the distance will 
appear. Alternatively you can press the space bar to bring up the input box. Enter the value and 
then the enter key.

The circle drawn represents the distance value and changes with movement of the mouse. If the 
user wants to see what the current value of the distance is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the circle continued.
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STEP 4:

A point is created on the segment specified by the selection of the 1st and 2nd points, at the 
nominated distance. Negative distances can be entered as in this example.

Between Points (3d)
Cad_Point_Between_Points_3d

Position of option on menu: Strings =>CAD =>Points =>Between points

or by selection of appropriate icon from the toolbar. 

This option creates a one point string that is on the line between two selected positions and a 
given distance from the first point. The z-value of the string is interpolated from the two selected 
positions.

On selecting Between points (3d), the user is prompted for the relevant data in the screen 
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message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The user selects a start point. Specification of a position can be done by the direct input of the xyz 
coordinate of the point by pressing the space bar to bring up the enter XYZ panel or by typing of 
the value to bring up the XYZ panel. The user can also select a point with the mouse and accepts 
that point (Middle mouse button or enter).

STEP 2:

The user picks a 2nd point and accepts that point (Middle mouse button or enter) to define the 
reference line.

STEP 3:

A distance from the 1st point to create the point is given either by selection with the mouse or by 
typing a value. To type a value, simply start typing and the input box for the distance will 
appear. Alternatively you can press the space bar to bring up the input box. Enter the value and 



12d Model Reference Manual

Page 666 May 2007CAD

then the enter key.

The circle drawn represents the distance value and changes with movement of the mouse. If the 
user wants to see what the current value of the distance is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the circle continued.

STEP 4:

A point is created on the segment specified by the selection of the 1st and 2nd points, at the 
nominated distance. Negative distances can be entered as in this example.

Radiation
cad_radiation
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Position of option on menu: Strings =>CAD =>Points =>Radiation

or by selection of appropriate icon from the toolbar. 

This option creates a series of one point strings that are located by given bearings and distances 
from a chosen start position.

On selecting Radiation, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A start position is selected and accepted.

STEP 2:

A bearing is selected with the mouse or entered in via the keyboard. For typed entry, simply start 
typing or press the space bar to bring up the bearing entry box. The value is entered into the 
input box followed by the enter key.

The line drawn represents the bearing value and changes with movement of the mouse. If the 
user wants to see what the current value of the bearing is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the bearing continued.

Note: The Page up and page down keys can be used when the input angle box comes up to 
add or subtract intervals of 90 degrees.
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This option also allows the definition of the bearing by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

STEP 3:

A distance from the start point to create the point is given either by selection with the mouse or 
by typing a value. To type a value, simply start typing and the input box for the distance will 
appear. Alternatively you can press the space bar to bring up the input box. The value is entered 
into the input box followed by the enter key.

The circle drawn represents the distance value and changes with movement of the mouse. If the 
user wants to see what the current value of the distance is, simply press the D key (dynamic 
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value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the circle continued.

This option also allows the definition of the distance by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

The perpendicular distance shown below by the purple line will be use at the defined bearing to 
create the point.
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STEP 4:

A point string is created using the information supplied.

STEP 5

The next bearing and distance is prompted for as per step 3 and 4. Consequent points are created 
from the original start point selected.
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Divide Segment by Number 
cad_divide_segment_by_number

Position of option on menu: Strings =>CAD =>Points =>Divide segment by number

or by selection of appropriate icon from the toolbar. 

This option creates one point strings which will break up a super string segment into equal 
pieces based on a user given number of intervals. The first and last points are not created since 
they are taken to be the end points of the selected segment. So for five intervals, four new one 
point strings are created. The option works for line or arc segments of a super string.

NOTES:

1. No vertices are inserted into the selected super string - the option Strings =>Strings 
edits =>Segment strings does that.

2. This option is for super strings only.

On selecting Divide segment by number, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A super string segment is selected and accepted.
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STEP 2:

The user is prompted for the number of divisions. The value is entered into the input box 
followed by the enter key.

STEP 3:

Given the above information, the new points are created.
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Divide Segment by Chainage Length 
cad_divide_segment_by_chainage_length

Position of option on menu: Strings =>CAD =>Points =>Divide segment by chainage length

or by selection of appropriate icon from the toolbar. 

This option creates one point strings which will break up a super string segment into pieces 
based on a user given chainage length. The process starts from the 1st point of the segment and 
continues until no more pieces can be created without going past the last point of the segment 
(the last piece may not be the correct length). This options works for line or arc segments of a 
super string.

NOTES:

1. No vertices are inserted into the selected super string - the option Strings =>Strings 
edits =>Segment strings does that.

2. This option is for super strings only.

On selecting Divide segment by chainage length, the user is prompted for the relevant data in 
the screen message box located at the bottom left hand corner of the 12d Model application 
window.

STEP 1:

A super string segment is selected and accepted.
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STEP 2:

The user is prompted for the chainage distance. The value is entered into the input box followed 
by the enter key.

STEP 3:

Given the above information, the new points are created.
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Divide String by Number 
Cad_Divide_String_by_Number

Position of option on menu: Strings =>CAD =>Points =>Divide string by number

or by selection of appropriate icon from the toolbar. 

This option creates one point strings which will break up a super string into equal pieces based 
on a user given number of divisions. The first and last points are not created since they are taken 
to be the end points of the selected string. So for five intervals, four new one point strings are 
created.

NOTES:

1. No vertices are inserted into the selected super string - the option Strings =>Strings 
edits =>Segment strings does that.

2. This option is for super strings only.

On selecting Divide string by number, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A super string is selected and accepted.

STEP 2:

The user is prompted for the number of divisions. The value is entered into the input box 
followed by the enter key.
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STEP 3:

Given the above information, the new points are created.

Divide String by Chainage Length
Cad_Divide_String_by_Chainage_Length

Position of option on menu: Strings =>CAD =>Points =>Divide string by chainage length

or by selection of appropriate icon from the toolbar. 

This option creates one point strings which will break up a super string into pieces based on a 
user given chainage length. The process starts from the 1st vertex of the strings and continues 
until no more pieces can be created without going past the last vertex of the string (the last piece 
may not be the correct length).

NOTES:

1. No vertices are inserted into the selected super string - the option Strings =>Strings 
edits =>Segment strings does that.

2. This option is for super strings only.

On selecting Divide string by chainage length, the user is prompted for the relevant data in the 
screen message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A super string is selected and accepted.

STEP 2:

The user is prompted for the chainage distance. The value is entered into the input box followed 
by the enter key.
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STEP 3:

Given the above information, the new points are created.
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CAD Lines
cad_lines

Position of option on menu: Strings =>CAD =>Lines

The Lines walk-right menu is

For the option Line, go to the section “Create Line” 
Tangent “Tangent” 
Line String “Line String” 
Traverse “Traverse” 
Traverse append “Traverse Append” 
Traverse edit “Traverse Edit” 
Tape baseline “Taped Baseline” 
Tape baseline absolute “Taped Baseline Absolute” 

Create Line
Cad_Line_2_Positions

Position of option on menu: Strings =>CAD =>Lines =>Line

or by selection of appropriate icon from the toolbar. 

This option creates two vertex super strings with a line between the two vertices. 

On selecting Line, the user is prompted for the relevant data in the screen message box located at 
the bottom left hand corner of the 12d Model application window.

The user can select a position with the mouse and on accepting that point (Middle mouse button 
or enter) the point is created at the selected position. The model, colour, height etc. are defined in 
the Cad Control Bar.

The snap mode will influence the mouse selection. For example if cursor snap is on, the user can 
choose a position not yet defined. If point snap is on and the selection snaps to an existing point, 
the option will place another point at that location.

The user can also activate the selection menu used with the mouse (right button) that allows 
various positioning options.

Menu of Options to Create Strings

create a two point (vertex) super string
create tangent to two selected items (points and/or arcs)
create a many point super string
create many pt super string by bearing distances from previous pt
append to a super string using bearing distance entry
modify the bear/distance of a selected segment
create many pt super str with pts a dist along and dist offset to a 
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Specification of a position can also be done by the direct input of the xyz coordinate of the point 
by pressing the space bar to bring up the enter XYZ panel. NOTE: The z value will default to the 
value entered into the Cad Control Bar whether or not it is specified in the XYZ box. If no height 
value exists in the Cad Control Bar 

The 2nd point is selected in the same way as the 1st point. The line is created after successful 
selection and acceptance of the 2nd point. The option remains current so that a number of lines 
can be created.

Line String
Cad_Create_Line_String

Position of option on menu: Strings =>CAD =>Lines =>Line String

or by selection of appropriate icon from the toolbar. 

This option creates a string of many points.

On selecting Line String, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The position of each vertex of the string is selected and accepted in order from the first to the last 
vertex.

Traverse
Cad_Traverse

Position of option on menu: Strings =>CAD =>Lines =>Traverse

or by selection of appropriate icon from the toolbar. 

This option creates a string by giving the bearing and distance of each vertex from the previous 
vertex. The position of the first vertex is the start of the string and then the bearing and distance 
is given to define the position of the next vertex. The created vertex then become the position to 
take the next bearing and distance from.

On selecting Traverse, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A start position is selected and accepted. This becomes the first vertex of the string.
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STEP 2:

A line is drawn from the vertex to the current mouse position. If the user wants to see what the 
current value of the bearing is, simply press the D key (dynamic value). This puts the value into 
the input box where it can be accepted to create the point or the input box can be closed and the 
rubber banding (graphically changing) of the bearing continued.

For typed entry, simply start typing or press the space bar to bring up the bearing entry box. The 
value is entered into the input box followed by the enter key.

Note: The Page up and page down keys can be used when the input angle box comes up to 
add or subtract intervals of 90 degrees.

This option also allows the definition of the bearing by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
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selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

STEP 3:

A distance from the start point to create the point is given either by selection with the mouse or 
by typing a value. To type a value, simply start typing and the input box for the distance will 
appear. Alternatively you can press the space bar to bring up the input box. The value is entered 
into the input box followed by the enter key.

The circle drawn represents the distance value and changes with movement of the mouse. If the 
user wants to see what the current value of the distance is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the circle continued.
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This option also allows the definition of the distance by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

The perpendicular distance shown below by the purple line will be use at the defined bearing to 
create the point.
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STEP 4:

A point string is created using the information supplied.

STEPS 4-5:

The next bearing and distance is prompted for as per step 4 and 5. The start point is now the last 
created point. A number of segments can be entered in this way.
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Traverse Append
Cad_Traverse_Append

Position of option on menu: Strings =>CAD =>Lines =>Traverse append

or by selection of appropriate icon from the toolbar. 

This option adds vertices to the end of a super string by giving the bearing and distance of each 
vertex from the previous vertex. When a string is selected, the end of the string becomes the 
position that the bearing distance is taken from. The created vertex then become the position to 
take the next bearing and distance from.

On selecting Traverse append, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A string to append vertices to is selected and accepted. The end of this string becomes the 
position to define the first bearing distance from.

STEP 2:

A line is drawn from the last vertex to the current mouse position. If the user wants to see what 
the current value of the bearing is, simply press the D key (dynamic value). This puts the value 
into the input box where it can be accepted to create the point or the input box can be closed and 
the rubber banding (graphically changing) of the bearing continued.

For typed entry, simply start typing or press the space bar to bring up the bearing entry box. The 
value is entered into the input box followed by the enter key.

Note: The Page up and page down keys can be used when the input angle box comes up to 
add or subtract intervals of 90 degrees.
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This option also allows the definition of the bearing by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

STEP 3:

A distance from the start point to create the point is given either by selection with the mouse or 
by typing a value. To type a value, simply start typing and the input box for the distance will 
appear. Alternatively you can press the space bar to bring up the input box. The value is entered 
into the input box followed by the enter key.
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The circle drawn represents the distance value and changes with movement of the mouse. If the 
user wants to see what the current value of the distance is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the circle continued.

This option also allows the definition of the distance by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

The perpendicular distance shown below by the purple line will be use at the defined bearing to 
create the point.
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STEP 4:

A point string is created using the information supplied.

STEPS 4-5:

The next bearing and distance is prompted for as per step 4 and 5. The start point is now the last 
created point. A number of segments can be entered in this way.
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Traverse Edit
Cad_Traverse_Edit

Position of option on menu: Strings =>CAD =>Lines =>Traverse edit

or by selection of appropriate icon from the toolbar. 

This option changes the bearing and length of a selected line segment of a super string.

On selecting Traverse edit, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A line segment of a string is selected and accepted. This segment is the one to have its bearing 
distance redefined.

STEP 2:

A Bearing and then the Distance typed input boxes are presented with the current values for the 
line segment displayed. After new values are entered (or just <enter> if the original value is to be 
maintained) then the new bearing and distance values are applied to the start vertex of the 
segment to produce a new end vertex. The rest of the string keeps the same bearing/distances 
are in the original string.

Note: The Page up and page down keys can be used when the input bearing box comes up to 
add or subtract intervals of 90 degrees.

Taped Baseline
Cad_Tape_Baseline

Position of option on menu: Strings =>CAD =>Lines =>Taped baseline

or by selection of appropriate icon from the toolbar. 

This option creates a line string by entering distances between points and the offset distance to a 
user defined reference line string.

On selecting Taped baseline, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.
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STEP 1:

A start position of the reference line is selected and accepted.

Note: Originating at the start point, the reference line will extend to infinity after intercepting 
the 2nd point. The offset values are made relative to this reference line. The reference line 
will be removed once the option has been terminated.

STEP 2:

The interception point for the reference line is selected and accepted.

STEP 3:

After the start and interception points are accepted, the reference line is constructed and the 
Distance Input box appears. A distance value is to be entered into the Input box, followed by the 
enter key. For the first point, the distance entered is relative to the start point of the reference line. 
A positive value means a distance towards the intercept point (from the start point).

Note: The distance is always relative to the previously entered vertex (positive is from start 
point to intercept point along the reference line).

STEP 4:

After the distance value has been entered, the Offset Input box will appear. Type the required 
offset value into the Input box and press the enter key. 

Note: The offset distance is always relative to the reference line (negative is to the left).
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STEP 5:

Steps 3 and 4 should be repeated until the required number of vertices have been created in the 
line string.

STEP 6:

The option can be terminated by click on the close button  on the Input box, followed by the 
Esc key.

Taped Baseline Absolute
Cad_Tape_Baseline_Absolute

Position of option on menu: Strings =>CAD =>Lines =>Taped baseline absolute

or by selection of appropriate icon from the toolbar. 

This option creates a line string by entering distances from the start point and the offset distance 
to a user defined reference line string.
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On selecting Taped baseline absolute, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A start position of the reference line is selected and accepted.

Note: Originating at the start point, the reference line will extend to infinity after intercepting 
the 2nd point. The offset values are made relative to this reference line. The reference line 
will be removed once the option has been terminated.

STEP 2:

The interception point for the reference line is selected and accepted.

STEP 3:

After the start and interception points are accepted, the reference line is constructed and the 
Distance Input box appears. A distance value is to be entered into the Input box, followed by the 
enter key. For the absolute option, all distances entered are relative to the start point of the 
reference line. A positive value means a distance towards the intercept point (from the start 
point).

Note: For the absolute option, distances are always relative to the start point of the reference 
line (positive is from start point to intercept point along the reference line).

STEP 4:

After the distance value has been entered, the Offset Input box will appear. Type the required 
offset value into the Input box and press the enter key. 

Note: The offset distance is always relative to the reference line (negative is to the left).
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STEP 5:

Steps 3 and 4 should be repeated until the required number of vertices have been created in the 
line string.

STEP 6:

The option can be terminated by click on the close button  on the Input box, followed by the 
Esc key.

Tangent
Cad_Line_Tangent

Position of option on menu: Strings =>CAD =>Lines =>Tangent

or by selection of appropriate icon from the toolbar. 
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This option creates the tangential line between two elements.

NOTE: This option is for super strings only. When Selecting an arc or circle, the selection 
must be a line snap with direction. If a point is selected on the arc/circle the line will be draw 
between the selected points and not the tangent.

On selecting Tangent, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A start position of the reference line is selected and accepted.

STEP 2:

The user selects and accepts the arc/circle segment with direction. The direction is required 
because there are two possible solutions. In this case, the direction was anti clockwise.

STEP 3:

After accepting the segment, a line is draw from the 1st selected point to the tangent point. Note 
that in this example, the arc is produced around so that a solution can be found.
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CAD Intersect
cad_intersect

Position of option on menu: Strings =>CAD =>Intersect

The Intersect walk-right menu is

For the option Segments, go to the section “Intersect Segments” 
Offset segments  “Intersect Offset Segments” 
2 pts 2 bearings  “2 Points and 2 Bearings” 
2 pts 2 dist  “2 Points and 2 Distances” 
2 pts bearing distance  “2 Points, One Bearing and One Distance” 

Intersect Segments
Cad_Intersect_Segments

Position of option on menu: Strings =>CAD =>Intersect =>Segments

or by selection of appropriate icon from the toolbar. 

This option creates a point at the intersection of the projections of two line or arc segments.

On selecting Segments, the user is prompted for the relevant data in the screen message box 

Menu of Options to Create One Points Strings by Intersections

by intersecting two selected segments
by intersection two offsetted selected segments
by given bearings from two selected positions
create a point given distances from two selected positions
by select posn and bearing and another selected posn and dist
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located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st segment is selected and accepted.

STEP 2:

The 2nd segment is selected and accepted.

STEP 3:

A point is created at the intersection of the two segments (if a solution exists). Note that the 2nd 
segment in this case has been projected to enable a solution to be calculated.
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Intersect Offset Segments
Cad_Intersect_Segments_Offset

Position of option on menu: Strings =>CAD =>Intersect =>Offset segments

or by selection of appropriate icon from the toolbar. 

This option creates a point at the intersection of the offsets of two selected segments.

On selecting Offset segments, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st segment is selected and accepted with direction. This sets the positive direction of the 
offset to the right of the direction of pick. 

STEP 2:

The offset is given by into an offset input box. The positive direction is at 90 degrees to the 
direction of pick for the segment. The value is entered into the input box followed by the enter 
key.



Chapter 14  Strings

May 2007 Page 697CAD

STEP 3:

The 2nd segment is selected with direction and accepted. This sets the positive direction of the 
offset to the right of the direction of pick. 

STEP 4:

The offset is given by into an offset input box. The positive direction is at 90 degrees to the 
direction of pick for the segment. The value is entered into the input box followed by the enter 
key.
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STEP 5:

A point is created at the intersection of the projected lines offset to the segments (if a solution 
exists).

2 Points and 2 Bearings
Cad_Intersect_Bearings

Position of option on menu: Strings =>CAD =>Intersect =>2 pts 2 bearings

or by selection of appropriate icon from the toolbar. 

This option creates a point by using two points and two bearings.

On selecting 2 pts 2 bearings, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected and accepted.
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STEP 2:

A bearing from the 1st point to create the point is given either by selection with the mouse or by 
typing a value. To type a value, simply start typing and the input box for the bearing will appear. 
Alternatively you can press the space bar to bring up the input box. The value is entered into the 
input box followed by the enter key.

The line drawn represents the bearing value and changes with movement of the mouse. If the 
user wants to see what the current value of the bearing is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the line continued.

Note: The Page up and page down keys can be used when the input angle box comes up to 
add or subtract intervals of 90 degrees.

This option also allows the definition of the bearing by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. 

STEP 3:

The 2nd point to create the point from is selected and accepted.
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STEP 4:

A bearing from the 2nd point to create the point is given using the optional outlined in STEP 2 
above.

STEP 5:

The point is created if there is a valid solution.
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2 Points and 2 Distances
Cad_Intersect_Distances

Position of option on menu: Strings =>CAD =>Intersect =>2 pts 2 dist

or by selection of appropriate icon from the toolbar. 

This option creates a point using two points and two distances.

On selecting 2 pts 2 dist, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected and accepted.

STEP 2:

A distance from the 1st point to create the point is given either by selection with the mouse or by 
typing a value. To type a value, simply start typing and the input box for the distance will 
appear. Alternatively you can press the space bar to bring up the input box. The value is entered 
into the input box followed by the enter key.

The circle drawn represents the distance value and changes with movement of the mouse. If the 
user wants to see what the current value of the distance is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
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input box can be closed and the rubber banding (graphically changing) of the circle continued.

This option also allows the definition of the distance by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

STEP 3:

The 2nd point to create the point from is selected.

STEP 4:

A distance from the 2nd point to create the point is given using the optional outlined in STEP 2 
above.
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STEP 5:

As there is two solutions, the user can select the correct one depending on the method of 
construction. This can be done by the direct entry of distances or by use of the mouse.

1. Distance entry. After the entry of the 1st distance, the 2nd point is selected. Following the 
selection of the 2nd point, the 2nd radius is shown (rubber banding). The user can select one 
of the two solutions by choosing with a LB mouse click over the approximate position of the 
required solution. The solution chosen is the closest solution to the selected point. The final 
radius can then be entered via the keyboard by simply starting typing which brings up the 
radius entry panel automatically. This panel can also be activated by pressing the space bar. 

2. Use of the mouse. The 1st point is selected and the radius entered by using the mouse or by 
direct entry from the keyboard. The 2nd point is then selected and the 2nd radius is displayed 
(rubber banding). A solution can be chosen by selecting with a LB mouse click over the 
required solution. The final solution will be the closest one to the selection. MB to accept the 
intersection and create the point.

STEP 6:
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The point is created if there is a valid solution.

2 Points, One Bearing and One Distance
Cad_Intersect_Bearing_Distance

Position of option on menu: Strings =>CAD =>Intersect =>2 pts bearing distance

or by selection of appropriate icon from the toolbar. 

This option creates a point from a given point and a bearing, and a second point and a distance.

On selecting 2 pts 2 bearing distance, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected and accepted.

STEP 2:

A bearing from the 1st point to create the point is given either by selection with the mouse or by 
typing a value. To type a value, simply start typing and the input box for the bearing will appear. 
Alternatively you can press the space bar to bring up the input box. The value is entered into the 
input box followed by the enter key.

The line drawn represents the bearing value and changes with movement of the mouse. If the 
user wants to see what the current value of the bearing is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the line continued.
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Note: The Page up and page down keys can be used when the input angle box comes up to 
add or subtract intervals of 90 degrees.

This option also allows the definition of the bearing by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. 

STEP 3:

The 2nd point to create the point from is selected and accepted.

STEP 4:

A distance from the 2nd point to create the point is given either by selection with the mouse or 
by typing a value. To type a value, simply start typing and the input box for the distance will 
appear. Alternatively you can press the space bar to bring up the input box. The value is entered 
into the input box followed by the enter key.

The circle drawn represents the distance value and changes with movement of the mouse. If the 
user wants to see what the current value of the distance is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the circle continued.
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This option also allows the definition of the distance by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

A line is drawn between the two possible solutions.

STEP 5:

As there is two solutions, the user can select the correct one with the mouse.

CAD Circles
cad_circles

Position of option on menu: Strings =>CAD =>Circles

The Circles walk-right menu is



Chapter 14  Strings

May 2007 Page 707CAD

For the option 3 points, go to the section “3 Points on the Circle” .
3 tangents “Circle by 3 Tangents” .
3 tangents direction “Circle by 3 Tangents with Direction” .
2 tangents radius “Circle by 2 Tangents and a Typed Radius” .
2 tangents radius direction. “Circle by 2 Tangents and a Typed Radius with Direction” .
2 points  “Circle by 2 Diametrically Opposed Points” .
2 points, radius  “Circle by 2 Points on the Circle and a Typed Radius” .

Point, radius and Bearing “Circle by Point, Tangential Bearing at the Point and Typed Radius” 
Centre, radius  “Circle by Centre and Typed Radius” .
Centre, point  “Circle by Centre and Point on Circle” .
Centre, circumference  “Circle by Centre and Typed Circumference” .

3 Points on the Circle
Cad_Circle_3_Points

Position of option on menu: Strings =>CAD =>Circles =>3 points

or by selection of appropriate icon from the toolbar. 

This option creates the circle through three selected points.

On selecting 3 points, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter 
the 1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.
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STEP 2:

The 2nd point is selected and accepted.

After the 2nd point is accepted a circle will be displayed ‘rubber banding’ to the various 
solutions according to the position of the cursor. This will continue until the 3rd point is selected 
and accepted.

STEP 3:

The 3rd point is selected and accepted.

STEP 4:

A circle is constructed through the three selected points



Chapter 14  Strings

May 2007 Page 709CAD

Circle by 3 Tangents
Cad_Circle_3_Tangents_Logical

Position of option on menu: Strings =>CAD =>Circles =>3 Tangents

or by selection of appropriate icon from the toolbar. 

This option creates a circle that is tangential to three selected segments.

On selecting 3 tangents, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st tangent is selected with the mouse (Left Button) and accepted (Middle Button).

STEP 2:

The 2nd tangent is selected and accepted.

STEP 3:

The 3rd tangent is selected and accepted.

STEP 4:

A circle is constructed that touches each of the three selected tangents.
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Circle by 3 Tangents with Direction
Cad_Circle_3_Tangents_Directional

Position of option on menu: Strings =>CAD =>Circles =>3 tangents direction

or by selection of appropriate icon from the toolbar. 

This option creates a circle that is tangential to three selected segments. The segments are 
selected in order and with direction and the circle is to the right of the direction of the selected 
segments.

On selecting 3 tangents direction, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select and accept the 1st tangent.

Note: For this option the direction of the selected tangents is important. The circle will be 
constructed to the right of a tangent. A user may reverse the direction of a tangent by selecting 
the tangent with direction. For further notes on picking tangents with direction, see ’Picking with 
Direction’ in Chapter 3 - Tools and Concepts on page 77.

Note: The Vertex indices can be displayed by toggling the option on the Toggle Menu.

STEP 2:

The 2nd tangent is selected and accepted.

STEP 3:
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The 3rd tangent is selected and accepted.

STEP 4:

If a solution exists, a circle is constructed using the given information.

Circle by 2 Tangents and a Typed Radius
Cad_Circle_2_Tangents_Radius_Logical

Position of option on menu: Strings =>CAD =>Circles =>2 tangents radius

or by selection of appropriate icon from the toolbar. 

This option creates a circle with a given radius that is tangential to two selecting segments.

On selecting 2 tangents radius, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the 1st tangent with the mouse (Left Button) and accept it (Middle Button).

STEP 2:

Select the 2nd tangent and accept it.
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STEP 3:

After the 2nd tangent is accepted, the Radius Input box will appear. Type the radius value into 
the Input box and press the enter key. The browse button  on the Input box can be used to 
define the radius by measuring existing elements.

STEP 4:

If a solution exists, a circle is fitted touching the two selected tangents using the given radius and 
directions.

 Circle by 2 Tangents and a Typed Radius with Direction
Cad_Circle_2_Tangents_Radius_Directional

Position of option on menu: Strings =>CAD =>Circles =>2 tangents radius direction

or by selection of appropriate icon from the toolbar. 

This option creates a circle with a given radius that is tangential to two selected segments that 
are picked with direction.

On selecting 2 tangents radius direction, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select and accept the 1st tangent.

Note: For this option the direction of the selected tangents is important. The circle will be 
constructed to the right of a tangent. A user may reverse the direction of a tangent by selecting 
the tangent with direction. For further notes on picking tangents with direction, see ’Picking with 
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Direction’ in Chapter 3 - Tools and Concepts on page 77.

Note: The Vertex indices can be displayed by toggling the option on the Toggle Menu.

STEP 2:

The 2nd tangent is selected and accepted.

STEP 3:

After the 2nd tangent is accepted, the Radius Input box will appear. Type the radius value into 
the Input box and press the enter key. The browse button  on the Input box can be used to 
define the arc radius by measuring existing elements.

STEP 4:

If a solution exists, a circle is constructed using the given information.

Circle by 2 Diametrically Opposed Points
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Cad_Circle_2_Points

Position of option on menu: Strings =>CAD =>Circles =>2 points

or by selection of appropriate icon from the toolbar. 

This option creates a circle by selecting two points that define the diameter of the circle.

On selecting 2 points, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter 
the 1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

 After the 1st point is accepted a circle will be displayed ‘rubber banding’ to the various solutions 
according to the position of the cursor (cursor position taken as the other end of a diameter). This 
will continue until the 2nd point is selected and accepted.

STEP 2:

The 2nd point is selected and accepted.

STEP 3:

The circle is constructed through the two selected points. The two points define the diameter. 

Circle by 2 Points on the Circle and a Typed Radius
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Cad_Circle_2_Points_Radius

Position of option on menu: Strings =>CAD =>Circles =>2 points, radius

or by selection of appropriate icon from the toolbar. 

This option creates a circle of a given radius that goes through two selected points.

On selecting 2 points, radius, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter 
the 1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

After the 1st point is accepted a circle will be displayed ‘rubber banding’ to the various solutions 
according to the position of the cursor. This will continue until the 2nd point is selected and 
accepted.

STEP 2:

The 2nd point is selected and accepted.

STEP 3:

After the 2nd point is accepted, the Radius Input box will appear. The radius value is entered 
into the input box followed by the enter key.
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STEP 4:

If a solution exists, the circle is fitted through the two selected points using the given radius.

Circle by Point, Tangential Bearing at the Point and Typed Radius
Cad_Circle_Point_Radius_Bearing

Position of option on menu: Strings =>CAD =>Circles =>Point, radius and bearing

or by selection of appropriate icon from the toolbar. 

This option creates a circle of a given radius, a selected point on the circle and the bearing of the 
tangent to the circle at that point.

On selecting Point, radius and bearing, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter a 
1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ Input 
box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

After the 1st point is accepted, the Enter radius input box will appear. Type the radius value into 
the Input box and press the enter key. The browse button  on the Input box can be used to 
define the arc radius by measuring existing elements.
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STEP 3:

After the radius has been entered, the Enter bearing input box will appear. Type the bearing into 
the Input box and press the enter key. The browse button  on the Input box can be used to 
define the bearing by measuring existing elements.

Note: The Page Up and Page Down keys can be used when the Enter Bearing input box comes 
up to add or subtract intervals of 90 degrees.

STEP 4:

If a solution exists, a circle is fitted from the given bearing at the selected point using the selected 
radius.

Circle by Centre and Typed Radius
Cad_Circle_Centre_Radius

Position of option on menu: Strings =>CAD =>Circles =>Centre, radius

or by selection of appropriate icon from the toolbar. 

This option creates a circle of a given radius and a selected centre point

On selecting Centre, radius, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A centre point is selected with the mouse or entered in via the keyboard. To specify a centre point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter a 
centre point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.
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STEP 2:

After the centre point is accepted a circle will be displayed ‘rubber banding’ to the various 
solutions according to the position of the cursor. This will continue until a radius value is 
entered.

A radius value is selected with the mouse or entered in via the keyboard.

To specify a radius value with the mouse, a point must be selected (Left Button) and accepted 
(Middle Button). This option also allows the definition of the radius by the selection of the 2nd 
point perpendicular or tangential to a selected segment. For this, the line snap should be on. The 
user selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential 
a solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. 

To enter a radius value with the keyboard, simply start typing or press the space bar to bring up 
the Radius Input box. Type the radius value into the Radius Input box and press the enter key. 
The browse button  on the Input box can be used to define the arc radius by measuring 
existing elements.

STEP 3:

The circle is constructed through the centre point using the specified radius.

Circle by Centre and Point on Circle
Cad_Circle_Centre_Point

Position of option on menu: Strings =>CAD =>Circles =>Centre, point

or by selection of appropriate icon from the toolbar. 
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This option creates a circle by selecting a centre point and then using the cursor to select a second 
point that in on the circle.

On selecting Centre, point, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A centre point is selected with the mouse or entered in via the keyboard. To specify a centre point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter a 
centre point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

After the centre point is accepted a circle will be displayed ‘rubber banding’ to the various 
solutions according to the position of the cursor. This will continue until a radius value is 
entered.

A radius value is selected with the mouse or entered in via the keyboard.

To specify a radius value with the mouse, a point must be selected (Left Button) and accepted 
(Middle Button). This option also allows the definition of the radius by the selection of the 2nd 
point perpendicular or tangential to a selected segment. For this, the line snap should be on. The 
user selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential 
a solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. 

To enter a radius value with the keyboard, simply start typing or press the space bar to bring up 
the XYZ Input box. Type the point into the Input box and press the enter key.

STEP 3:

A circle is constructed using the two points defined by the user.
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Circle by Centre and Typed Circumference
Cad_Circle_Centre_Circumference

Position of option on menu: Strings =>CAD =>Circles =>Centre, circumference

or by selection of appropriate icon from the toolbar. 

This option creates a circle by selecting the centre point and giving a circumference value.

On selecting Centre, circumference, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A centre point is selected with the mouse or entered in via the keyboard. To specify a centre point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter a 
centre point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

After the centre point is accepted, the Circumference Input box will appear. Type the 
circumference length into the Input box and press the enter key. The browse button  on the 
Input box can be used to define the arc radius by measuring existing elements.

STEP 3:

A circle is constructed using the centre point and the given circumference.
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CAD Arcs
cad_arcs

Position of option on menu: Strings =>CAD =>Arcs

The arc options creates super string arcs, not arc strings. The options Strings =>Create =>Arcs 
create arc strings.

The Arcs walk-right menu is

For the option 3 points, please go to the section.“Arc by 3 points” 
3 tangents “Arc by 3 Tangents” 
3 tangents direction “Arc by 3 Tangents with Direction” 
2 tangents radius “Arc by 2 Tangents and a Typed Radius” 
2 tangents radius direction “Arc by 2 Tangents and a Typed Radius with Direction” 
2 points and radius “Arc by 2 Points and a Typed Radius” 
2 points and end bearing “Arc by 2 Points and an End Bearing” 
Centre, start and end “Arc by Centre, Start and End Points” 
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Centre, radius, start and end “Arc by Centre, Typed Radius, Start and End Points” 
Centre, start and sweep angle “Arc by Centre, Start point and Sweep Angle” 

Start, radius, arc l, bearing “Arc by Start Point, Typed Radius, Arc Length and Start Bearing” 
Start, radius, arc l, chord bear “Arc by Start Point, Typed Radius, Arc Length and Chord Bearing” 
Start, radius, chord len, bear  “Arc by Start Point, Typed Radius, Chord length and a bearing” 

Fillet  “Fillet by Typed Radius” .
Fillet by start point  “Fillet by Start Tangent Point” .

Arc by 3 points
Cad_Arc_3_Points

Position of option on menu: Strings =>CAD =>Arcs =>3 points

or by selection of appropriate icon from the toolbar. 

This option creates the arc through three selected points and the first and third points are the 
start and end of the arc.

On selecting 3 points, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter 
the 1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

The 2nd point is selected and accepted.

After the 2nd point is accepted an arc will be displayed ‘rubber banding’ to the various solutions 
according to the position of the cursor. This will continue until the 3rd point is selected and 
accepted.

STEP 3:

The 3rd point is selected and accepted.
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STEP 4:

An arc is constructed through the three selected points.

Arc by 3 Tangents
Cad_Arc_3_Tangents_Logical

Position of option on menu: Strings =>CAD =>Arcs =>3 tangents

or by selection of appropriate icon from the toolbar. 

This option creates an arc that is tangential to three selected segments. The first and third 
segments are the start and end of the arc.

On selecting 3 tangents, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st tangent is selected with the mouse (Left Button) and accepted (Middle Button).

STEP 2:

The 2nd tangent is selected and accepted.
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STEP 3:

The 3rd tangent is selected and accepted.

STEP 4:

The arc is constructed touching the three selected tangents.

Arc by 3 Tangents with Direction
Cad_Arc_3_Tangents_Directional

Position of option on menu: Strings =>CAD =>Arcs =>3 tangents direction

or by selection of appropriate icon from the toolbar. 

This option creates an arc that is tangential to three selected segments. The segments are selected 
in order and with direction and the arc is to the right of the direction of the selected segments. 
The first and third segments are the start and end of the arc.

On selecting 3 tangents direction, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select and accept the 1st tangent.

Note: For this option the direction of the selected tangents is important. The arc will be 
constructed to the right of the tangent. A user may reverse the direction of the tangent by 
selecting a tangent with direction. For further notes on picking tangents with direction, see 
’Picking with Direction’ in Chapter 3 - Tools and Concepts on page 77.

Note: The Vertex indices can be displayed by toggling the option on the Toggle Menu.
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STEP 2:

The 2nd tangent is selected and accepted.

STEP 3:

The 3rd tangent is selected and accepted.

STEP 4:

If a solution exists, an arc is constructed using the given information.

Arc by 2 Tangents and a Typed Radius
Cad_Arc_2_Tangents_Radius_Logical

Position of option on menu: Strings =>CAD =>Arcs =>2 tangents radius

or by selection of appropriate icon from the toolbar. 

This option creates an arc with a given radius that is tangential to two selecting segments. This is 
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the same as a fillet.

On selecting 2 tangents radius, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st tangent is selected with the mouse (Left Button) and accepted (Middle Button).

STEP 2:

The 2nd tangent is selected and accepted.

STEP 3:

After the start point is accepted, the Radius Input box will appear. Type the radius value into the 
Input box and press the enter key. The browse button  on the Input box can be used to define 
the arc radius by measuring existing elements.

STEP 4:

If a solution exists, the arc is fitted through the two selected tangents using the given radius.
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Arc by 2 Tangents and a Typed Radius with Direction
Cad_Arc_2_Tangents_Radius_Directional

Position of option on menu: Strings =>CAD =>Arcs =>2 tangents radius direction

or by selection of appropriate icon from the toolbar. 

This option creates an arc with a given radius that is tangential to two selected segments that are 
picked with direction.

On selecting 2 tangents radius direction, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select and accept the 1st tangent.

Note: For this option the direction of the selected tangents is important. The arc will be 
constructed to the right of a tangent. A user may reverse the direction of a tangent by selecting 
the tangent with direction. For further notes on picking tangents with direction, see ’Picking with 
Direction’ in Chapter 3 - Tools and Concepts on page 77.

Note: The Vertex indices can be displayed by toggling the option on the Toggle Menu.

STEP 2:

The 2nd tangent is selected and accepted.

STEP 3:

After the start point is accepted, the Radius Input box will appear. Type the radius value into the 
Input box and press the enter key. The browse button  on the Input box can be used to define 
the arc radius by measuring existing elements.
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STEP 4:

If a solution exists, the arc is fitted through the two selected tangents using the given radius.

Arc by 2 Points and a Typed Radius
Cad_Arc_2_Points_Radius

Position of option on menu: Strings =>CAD =>Arcs =>2 points and radius

or by selection of appropriate icon from the toolbar. 

This option creates an arc of a given radius that starts and ends on two selected points.

On selecting 2 points and radius, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter 
the 1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

The 2nd point is selected and accepted.

STEP 3:

After the start point is accepted, the Arc Radius Input box will appear. Type the radius value into 
the Input box and press the enter key. The browse button  on the Input box can be used to 
define the arc radius by measuring existing elements.
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STEP 4:

If a solution exists, an arc is constructed using the given information.

Arc by 2 Points and an End Bearing
Cad_Arc_2_Points_End_Bearing

Position of option on menu: Strings =>CAD =>Arcs =>2 points and end bearing

or by selection of appropriate icon from the toolbar. 

This option creates an arc that starts and end on two selected points and has a given bearing of 
the tangent at the end point (the end bearing).

On selecting 2 points and end bearing, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter 
the 1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

The 2nd point is selected and accepted.
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STEP 3:

After the 2nd point is accepted, the Enter bearing input box will appear. Type the bearing into the 
Input box and press the enter key. The browse button  on the input box can be used to define 
the bearing by measuring existing elements.

Note: The Page Up and Page Down keys can be used when the Enter Bearing input box comes 
up to add or subtract intervals of 90 degrees.

STEP 4:

If a solution exists, the arc is fitted through the two selected points with the end point of the 
given bearing.

Arc by Centre, Start and End Points
Cad_Arc_Centre_End_Points

Position of option on menu: Strings =>CAD =>Arcs =>Centre, start and end

or by selection of appropriate icon from the toolbar. 

This option creates an arc by selecting in order, the centre point and the start and end points. The 
radius of the arc is the distance between the centre and the start point.

On selecting Centre, start and end, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A centre point is selected with the mouse or entered in via the keyboard. To specify a centre point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter a 
centre point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
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Input box. Type the coordinates into the XYZ Input box and press the enter key.

After the centre point is accepted a circle will be displayed ‘rubber banding’ to the various 
solutions according to the position of the cursor. This will continue until the start point is 
selected and accepted.

STEP 2:

Select and accept the start point. This point defines the radius and the start of the arc.

STEP 3:

The end point of the arc is specified.

STEP 4:

The arc is constructed using the given information.

Arc by Centre, Typed Radius, Start and End Points
Cad_Arc_Centre_Radius_End_Points
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Position of option on menu: Strings =>CAD =>Arcs =>Centre, radius, start, end

or by selection of appropriate icon from the toolbar. 

This option allows the creation of an arc given a centre point, radius, start and end points.

This option creates an arc of a given radius by selecting in the centre point and the start and end 
positions.

On selecting Centre, radius, start, end, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A centre point is selected with the mouse or entered in via the keyboard. To specify a centre point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter a 
centre point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

After the centre point is accepted a circle will be displayed ‘rubber banding’ to the various 
solutions according to the position of the cursor. This will continue until the start point is 
selected and accepted.

STEP 2:

A radius value is selected with the mouse or entered in via the keyboard. To specify a radius 
value with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To 
enter radius value with the keyboard, simply start typing or press the space bar to bring up the 
Radius Input box. Type the radius value into the Radius Input box and press the enter key. The 
browse button  on the Input box can be used to define the arc distance by measuring existing 
elements.

STEP 3:

A start point defines the start of the sweep angle to define where to start the arc. It can be 
selected with the mouse or entered in via the keyboard. To specify a start point with the mouse, a 
point must be selected (Left Button) and accepted (Middle Button). To enter a start point with the 
keyboard, simply start typing or press the space bar to bring up the XYZ Input box. Type the 
coordinates into the XYZ Input box and press the enter key.
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STEP 4:

The end point of the arc is specified. The start and end points define the sweep angle to define 
the arc. The rubber banding of the arc will use the cursor position as the end position until a end 
point is selected and accepted. It can be selected with the mouse or entered in via the keyboard. 
To specify a start point with the mouse, a point must be selected (Left Button) and accepted 
(Middle Button). To enter a start point with the keyboard, simply start typing or press the space 
bar to bring up the XYZ Input box. Type the coordinates into the XYZ Input box and press the 
enter key. The end point does not have to be on the arc itself. It is used to define the sweep angle.

STEP 5:

The arc is constructed using the given information.

Arc by Centre, Start point and Sweep Angle
Cad_Arc_Centre_Start_Sweep

Position of option on menu: Strings =>CAD =>Arcs =>Centre, start, sweep

or by selection of appropriate icon from the toolbar. 

This option creates an arc by selecting a centre point and a start points and giving a sweep angle. 
The radius of the arc is the distance between the centre and start point.

On selecting Centre, start, sweep, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A centre point is selected with the mouse or entered in via the keyboard. To specify a centre point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter a 
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centre point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

After the 1st point is accepted a circle will be displayed ‘rubber banding’ to the various solutions 
according to the position of the cursor. This will continue until the 2nd point is selected and 
accepted.

STEP 2:

The 2nd point is selected with the mouse or entered in via the keyboard. This point defines the 
radius as well as the start point of the arc.To specify the 2nd point with the mouse, a point must 
be selected (Left Button) and accepted (Middle Button). To enter the 2nd point with the 
keyboard, simply start typing or press the space bar to bring up the XYZ Input box. Type the 
coordinates into the XYZ Input box and press the enter key.

STEP 3:

After the 2nd point is accepted, the Sweep Angle input box will appear. Type the sweep angle 
value into the input box and press the enter key. The browse button  on the Input box can be 
used to define the arc radius by measuring existing elements.

Note: The Page up and page down keys can be used when the input angle box comes up to 
add or subtract intervals of 90 degrees.

STEP 4:

The arc is created using the information supplied
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Arc by Start Point, Typed Radius, Arc Length and Start Bearing
Cad_Arc_Start_Radius_Bearing

Position of option on menu: Strings =>CAD =>Arcs =>Start, radius, arc l, bearing

or by selection of appropriate icon from the toolbar. 

This option creates an arc of a given radius, starting at a selected point and bearing of the tangent 
at the start point and going for a given arc length.

On selecting the Start, radius, arc l, bearing option, the user is prompted for the relevant data in 
the screen message box located at the bottom left hand corner of the 12d Model application 
window.

STEP 1:

A start point is selected with the mouse or entered in via the keyboard. To specify a start point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter a 
start point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

After the start point is accepted, the Arc Radius Input box will appear. Type the radius value into 
the Input box and press the enter key. The browse button  on the Input box can be used to 
define the arc radius by measuring existing elements.

STEP 3:

After the radius has been entered, the Arc Length Input box will appear. Type the arc length into 
the Input box and press the enter key. The browse button  on the Input box can be used to 
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define the arc distance by measuring existing elements.

STEP 4:

After the arc length is accepted, the Bearing Input box will appear. Type the bearing into the 
Input box and press the enter key. The browse button  on the Input box can be used to define 
the bearing by measuring existing elements.

Note: The Page Up and Page Down keys can be used when the Bearing Input box comes up to 
add or subtract intervals of 90 degrees.

STEP5:

The arc is created with the given information.

Arc by Start Point, Typed Radius, Arc Length and Chord Bearing
Cad_Arc_Start_Radius_Chord_Bearing

Position of option on menu: Strings =>CAD =>Arcs =>Start, radius, arc l, chord bearing

or by selection of appropriate icon from the toolbar. 

This option creates an arc of a given radius, starting from a selected point and with a given chord 
bearing at the start point and a given arc length.

On selecting Start, radius, arc l, chord bearing, the user is prompted for the relevant data in the 
screen message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The start point is selected with the mouse or entered in via the keyboard. To specify the start 
point with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To 
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enter the start point with the keyboard, simply start typing or press the space bar to bring up the 
XYZ Input box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

After the start point is accepted, the Arc Radius Input box will appear. Type the radius value into 
the Input box and press the enter key. The browse button  on the Input box can be used to 
define the arc radius by measuring existing elements.

STEP 3:

After the arc radius is entered, the Arc Length Input box will appear. Type the arc length into the 
Input box and press the enter key. The browse button  on the Input box can be used to define 
the arc distance by measuring existing elements.

STEP 4:

After the arc length is entered, the Chord Bearing Input box will appear. Type the bearing into the 
Input box and press the enter key. The browse button  on the Input box can be used to define 
the bearing by measuring existing elements.

Note: The Page Up and Page Down keys can be used when the Chord Bearing Input box 
comes up to add or subtract intervals of 90 degrees.
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STEP 5:

An arc is created with the given information.

Arc by Start Point, Typed Radius, Chord length and a bearing
Cad_Arc_Start_Radius_Chord_Length

Position of option on menu: Strings =>CAD =>Arcs =>start, radius, chord length, bearing

or by selection of appropriate icon from the toolbar. 

This option creates an arc of a given radius, starting from a selected point, with a given bearing 
of the tangent at the start point and a given chord length from the start point.

On selecting Start, radius, chord length, bearing, the user is prompted for the relevant data in the 
screen message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A start point is selected with the mouse or entered in via the keyboard. To specify a start point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter a 
start point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

After the start point is accepted, the Arc Radius Input box will appear. Type the radius value into 
the Input box and press the enter key. The browse button  on the Input box can be used to 
define the arc radius by measuring existing elements.
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STEP 3:

After the radius has been entered, the Chord Length Input box will appear. Type the chord length 
into the Input box and press the enter key. The browse button  on the Input box can be used 
to define the chord length by measuring existing elements.

STEP 4:

After the chord length has been entered, the Bearing Input box will appear. Type the bearing of 
the start tangent into the Input box and press the enter key. The browse button  on the Input 
box can be used to define the bearing by measuring existing elements.

Note: The Page Up and Page Down keys can be used when the Bearing Input box comes up to 
add or subtract intervals of 90 degrees.

STEP 5:

The arc is created with the given information.
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Fillet by Typed Radius
Cad_Create_Fillet_by_radius

Position of option on menu: Strings =>CAD =>Arcs =>Fillet

or by selection of appropriate icon from the toolbar. 

This option creates an arc given a fillet radius

On selecting Fillet, the user is prompted for the relevant data in the screen message box located at 
the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st segment where the fillet is to depart from is selected and accepted. This should be done 
by a pick with direction. The direction will influence the calculations as there are a number of 
solutions for intersecting segments. In the case shown, the direction was in a north-east 
direction.

STEP 2:

The 2nd segment where the fillet is to arrive from is selected and accepted. This should be done 
by a pick with direction. The direction will again influence the calculations as there are a number 
of solutions for intersecting segments. In the case shown the direction was in a south-east 
direction

STEP 3:

After the 2nd segment is accepted, the Arc Radius Input box will appear. Type the radius of the 
fillet in the Input box (positive radius for curves curving to the right) and press the enter key. The 
browse button  on the Input box can be used to define the arc radius by measuring existing 
elements.
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STEP 4:

The fillet arc is placed between the selected segments.

Fillet by Start Tangent Point
Cad_Create_Fillet_by_Start_Point

Position of option on menu: Strings =>CAD =>Arcs =>Fillet by start point

or by selection of appropriate icon from the toolbar. 

This option creates an arc that is a fillet between two selected sections and with a selected fillet 
start point (which will be a tangent point of the created arc).

On selecting Fillet by start point, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st segment where the fillet is to depart from is selected and accepted. This should be done 
by a pick with direction. The direction will influence the calculations as there are a number of 
solutions for intersecting segments. In the case shown the direction was in a north-east direction.

STEP 2:

The 2nd segment where the fillet is to arrive from is selected and accepted. This should be done 
by a pick with direction. The direction will again influence the calculations as there are a number 
of solutions for intersecting segments. In the case shown the direction was in a south-east 
direction

STEP 3:

The tangent start point of the fillet is selected and accepted.
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STEP 4:

The fillet arc is placed between the selected segments.
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CAD Polygons
cad_polygons

Position of option on menu: Strings =>CAD =>Polygons

The Cad polygons walk-right menu is

For the option Rectangles, go to the section “Create Rectangle” .
Rectangle width height “Rectangle by Width and Height” .
Rectangle 3 points “Rectangle by 3 Points” .
Parallelogram “Create Parallelogram” .
Polygon inscribe  “Polygon Inscribed in a Circle” .
Polygon circumscribe “Polygon Circumscribed About a Circle” .
Polygon freehand “Free Hand Polygon” .
Boundary polygon “Create Boundary Polygon” .
Add holes “Add Holes” 
Remove holes “Remove Holes” 

Create Rectangle
Cad_Create_Rectangle

Position of option on menu: Strings =>CAD =>Polygons =>Rectangle

or by selection of appropriate icon from the toolbar. 

This option creates a rectangle parallel to the x and y axis by selecting two end points of the 
rectangle.

On selecting Rectangle, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter 
the 1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

After the 1st point is accepted a rectangle will be displayed ‘rubber banding’ to the various 
solutions according to the position of the cursor. This will continue until the 2nd point is selected 
and accepted.
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STEP 2:

The 2nd point is selected with the mouse or entered in via the keyboard. To specify the 2nd point 
with the mouse, a point must be selected and accepted. To enter the 2nd point with the keyboard, 
simply start typing or press the space bar to bring up the XYZ Input box. Type the coordinates 
into the XYZ Input box and press the enter key.

STEP 3:

The Corner radius typed input panel is then displayed. If a radius is entered then it is used to 
fillet the four corners of the rectangle. To not fillet the rectangle corners, simply leave the Corner 
radius box empty and press the <enter> key.

STEP 4:

The rectangle is created with the given information.

Rectangle by Width and Height
Cad_Create_Rectangle_by_Width_and_Height

Position of option on menu: Strings =>CAD =>Polygons =>Rectangle Width Height

or by selection of appropriate icon from the toolbar. 

This option allows the creation of a rectangle given a start point, width and height.
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This option creates a rectangle parallel to the x and y axis by selecting a start point and giving the 
width and height of the rectangle.

On selecting Rectangle Width Height, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The start point is selected with the mouse or entered in via the keyboard. To specify the start 
point with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To 
enter the start point with the keyboard, simply start typing or press the space bar to bring up the 
XYZ Input box. Type the coordinates into the XYZ Input box and press the enter key.

This point defines the bottom left point of the rectangle.

After the start point is accepted, the width will be displayed ‘rubber banding’ to right of the start 
point (positive distance). The width is equal to the distance from the start point to the position of 
the cursor. This will continue until the width is selected and accepted.

STEP 2:

The width is selected with the mouse or entered in via the keyboard. To specify the width with 
the mouse, a point must be selected and accepted. To enter the width with the keyboard, simply 
start typing or press the space bar to bring up the Distance Input box. Type the distance into the 
Distance Input box and press the enter key. The browse button  on the Input box can be used 
to define the distance by measuring existing elements.

A negative distance (to the left of the 1st point) can be entered via the Distance Input box in two 
ways. Either type a negative distance, or use the browse button  to select a distance, then 
place a minus "-" sign in front of the distance value.

After the width is accepted, the width of the rectangle is confirmed and the height will be 
displayed ‘rubber banding’ upwards on the screen. The height is equal to the distance from the 
found width point to the position of the cursor. The rectangle will be created once the height is 
selected and accepted.

STEP 3:

The height is selected with the mouse or entered in via the keyboard. To specify the height with 
the mouse, a point must be selected and accepted. To enter the height with the keyboard, simply 
start typing or press the space bar to bring up the Distance Input box. Type the distance into the 
Distance Input box and press the enter key. The browse button  on the Input box can be used 
to define the distance by measuring existing elements.
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A negative distance (below of the 2nd point) can be entered via the Distance Input box in two 
ways. Either type a negative distance, or use the browse button  to select a distance, then 
place a minus "-" sign in front of the distance value.

STEP 4:

The Corner radius typed input panel is then displayed. If a radius is entered then it is used to 
fillet the four corners of the rectangle. To not fillet the rectangle corners, simply leave the Corner 
radius box empty and press the <enter> key.

STEP 5:

The rectangle is created with the given information.

Rectangle by 3 Points
Cad_Create_Rectangle_by_3_Points

Position of option on menu: Strings =>CAD =>Polygons =>Rectangle 3 Points

or by selection of appropriate icon from the toolbar. 

This option creates a rectangle by selecting three points. The first and second point define the 
base of the rectangle and the third point is on the opposite side of the rectangle.

On selecting Rectangle 3 points, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter 
the 1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

After the 1st point is accepted, the base of the rectangle will be displayed ‘rubber banding’ on the 
screen. The baseline length is equal to the distance from the 1st point to the position of the cursor. 
This will continue until the 2nd point is selected and accepted.
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STEP 2:

The 2nd point is selected with the mouse or entered in via the keyboard. To specify the 2nd point 
with the mouse, a point must be selected and accepted. To enter the 2nd point with the keyboard, 
simply start typing or press the space bar to bring up the XYZ Input box. Type the coordinates 
into the XYZ Input box and press the enter key. The browse button  on the Input box can be 
used to define the distance by measuring existing elements.

After the 2nd point is accepted, the baseline of the rectangle is confirmed and the height will be 
displayed ‘rubber banding’ on the screen. The height is equal to the distance from the 2nd point 
to the position of the cursor. The rectangle will be created once the height is selected and 
accepted.

STEP 3:

The height is selected with the mouse or entered in via the keyboard. To specify the height with 
the mouse, a point must be selected and accepted. To enter the 3rd point with the keyboard, 
simply start typing or press the space bar to bring up the XYZ Input box. Type the coordinates 
into the XYZ Input box and press the enter key. The browse button  on the Input box can be 
used to define the distance by measuring existing elements.

STEP 4:

The Corner radius typed input panel is then displayed. If a radius is entered then it is used to 
fillet the four corners of the rectangle. To not fillet the rectangle corners, simply leave the Corner 
radius box empty and press the <enter> key.



12d Model Reference Manual

Page 748 May 2007CAD

STEP 5:

The rectangle is created with the given information.

Create Parallelogram
Cad_Create_Parallelogram

Position of option on menu: Strings =>CAD =>Polygons =>Parallelogram

or by selection of appropriate icon from the toolbar. 

This option allows the creation of a parallelogram given 3 points.

This option creates a parallelogram by selecting three points. The first and second point define 
the base of the parallelogram and the third point is the end point of the opposite side of the 
parallelogram.

On selecting Parallelogram, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The 1st point is selected with the mouse or entered in via the keyboard. To specify the 1st point 
with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To enter 
the 1st point with the keyboard, simply start typing or press the space bar to bring up the XYZ 
Input box. Type the coordinates into the XYZ Input box and press the enter key.

After the 1st point is accepted, the base of the rectangle will be displayed ‘rubber banding’ on the 
screen. The baseline length is equal to the distance from the 1st point to the position of the cursor. 
This will continue until the 2nd point is selected and accepted.

STEP 2:

The 2nd point is selected with the mouse or entered in via the keyboard. To specify the 2nd point 
with the mouse, a point must be selected and accepted. To enter the 2nd point with the keyboard, 
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simply start typing or press the space bar to bring up the XYZ Input box. Type the coordinates 
into the XYZ Input box and press the enter key. The browse button  on the Input box can be 
used to define the distance by measuring existing elements.

After the 2nd point is accepted, the baseline of the parallelogram is confirmed and the height 
will be displayed ‘rubber banding’ on the screen. The height is equal to the distance from the 2nd 
point to the position of the cursor. The parallelogram will be created once the height is selected 
and accepted.

STEP 3:

The height is selected with the mouse or entered in via the keyboard. To specify the height with 
the mouse, a point must be selected and accepted. To enter the 3rd point with the keyboard, 
simply start typing or press the space bar to bring up the XYZ Input box. Type the coordinates 
into the XYZ Input box and press the enter key. The browse button  on the Input box can be 
used to define the distance by measuring existing elements.

STEP 4:

The Corner radius typed input panel is then displayed. If a radius is entered then it is used to 
fillet the four corners of the rectangle. To not fillet the rectangle corners, simply leave the Corner 
radius box empty and press the <enter> key.

STEP 5:

The parallelogram is created with the given information.
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Polygon Inscribed in a Circle
Cad_Create_Polygon_Inscribed_in_Circle

Position of option on menu: Strings =>CAD =>Polygons =>Polygon Inscribed

or by selection of appropriate icon from the toolbar. 

This option creates a polygon with a user defined number of sides on the inside of a a circle.

The polygon is constructed inside a circle, thus each corner of the polygon touches the 
circumference of the circle defined by the user. Conversely using the Polygon circumscribed 
option, the midpoint of each side of the polygon touches the circumference of the circle creating 
a polygon outside the circle.

On selecting Polygon inscribed, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The centre point is selected with the mouse or entered in via the keyboard. To specify the centre 
point with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To 
enter the centre point with the keyboard, simply start typing or press the space bar to bring up 
the XYZ Input box. Type the coordinates into the XYZ Input box and press the enter key.

STEP 2:

After the centre point is accepted, the Number of Sides Input box will appear. Type in the desired 
number of sides for the polygon into the Input box and press the enter key.

After the number of sides have been selected, the polygon will be displayed ‘rubber banding’ on 
the screen. The polygon will be created once the radius is selected and accepted.
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STEP 3:

Before a polygon can be created inside the circle, its radius must be defined by the user. To 
specify the radius with the mouse, a point must be selected and accepted. To enter the point with 
the keyboard, simply start typing or press the space bar to bring up the XYZ Input box. Type the 
coordinates into the XYZ Input box and press the enter key.

Note: One of the polygon’s corners will be located on the point selected to defined the circle’s 
radius 

STEP 4:

A polygon is created inside a circle with a radius defined by the user.

Polygon Circumscribed About a Circle
Cad_Create_Polygon_Circumscribed_about_Circle

Position of option on menu: Strings =>CAD =>Polygons =>Polygon circumscribed

or by selection of appropriate icon from the toolbar. 

This option creates a polygon with a user defined number of sides on the outside a circle.

The polygon is constructed outside a circle, thus the midpoint of each side of the polygon 
touches the circumference of the circle defined by the user. Conversely using the Polygon 
inscribed option, each corner of the polygon touches the circumference of the circle creating a 
polygon inside the circle.

On selecting Polygon circumscribed, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The centre point is selected with the mouse or entered in via the keyboard. To specify the centre 
point with the mouse, a point must be selected (Left Button) and accepted (Middle Button). To 
enter the centre point with the keyboard, simply start typing or press the space bar to bring up 
the XYZ Input box. Type the coordinates into the XYZ Input box and press the enter key.
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STEP 2:

After the centre point is accepted, the Number of Sides Input box will appear. Type in the desired 
number of sides for the polygon into the Input box and press the enter key.

After the number of sides have been selected, the polygon will be displayed ‘rubber banding’ on 
the screen. The polygon will be created once the radius is selected and accepted.

STEP 3:

Before a polygon can be created outside the circle, its radius must be defined by the user. To 
specify the radius with the mouse, a point must be selected and accepted. To enter the point with 
the keyboard, simply start typing or press the space bar to bring up the XYZ Input box. Type the 
coordinates into the XYZ Input box and press the enter key.

Note: One midpoint of the polygon’s side will be located on the point selected to defined the 
circle’s radius 

STEP 4:

A polygon is created outside the circle with a radius defined by the user.



Chapter 14  Strings

May 2007 Page 753CAD

Free Hand Polygon
Cad_Create_Polygon

Position of option on menu: Strings =>CAD =>Polygons =>Polygon freehand

or by selection of appropriate icon from the toolbar. 

This option creates a closed polygon from selected vertices.

On selecting Polygon freehand, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Pick and accept the position to form the vertices of the polygon. As each vertex is accepted, the 
polygon is automatically closed.

STEP 2:

The polygon is finished by pressing the <esc> key.

Create Boundary Polygon
Cad_Create_Boundary_Polygon

Position of option on menu: Strings =>CAD =>Polygons =>Boundary Polygon

or by selection of appropriate icon from the toolbar. 

This option tries to form a boundary from a selected set of segments.

On selecting Boundary Polygon, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Pick a position inside the lines to form a bounding polygon.

STEP 2:

A circle is then drawn centred on the selected position with circumference going through the 
position of the cursor. Drag the cursor out until it encloses all the data to be used to create the 
closest bounding polygon around the centre.
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STEP 3:

On accepting the circle position, an attempt is made to create the inner polygon using all the 
lines inside the circle. Parts of lines will only be used if they can be joined to the centre by a 
straight line which doesn’t cross any other side.
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CAD Text
cad_text

Position of option on menu: Strings =>CAD =>Text

The Text walk-right menu is

Text can occur as a text string, on vertices of a 4d string, and on vertices and segments of a super 
string. Each type of text has a vertex (these are displayed when Vertices are toggle on in a plan 
view), a justification point, a rotation, an offset and raise value. The vertex and justification point 

Menu of Options to Create and Manipulate Text

edit text using grips

create text string and edit using grips

create text string at a selected position

create text at a user selected super string vertex

create text at a user selected super string segment

rotate text about its vertex

rotate text about its justification points (which may be offset from the verte

move text by its vertex

move text by its justification point (the vertex does not move)

change the height of text

change the characters of the text

change the style of text

change the colour of text

reset the text justification point so that it is on top of the vertex posn

menu to make most of the above changes to one selected text

delete text
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only coincide if the offset and raise values are both zero. All text on a 4d string must have the 
same height, colour, angle, offset and raise. What parts of the text on a super string vertex or 
super string segment can be independently modified depends on the settings for the super 
string.

For some text options, the created elements will have attributes defined by the Text Controlbar 
(text type and size) and CAD Controlbar (model and colour). For more information, go to the 
section “Text Controlbar”  and “CAD Controlbar” .

)

For the option Simple edit, please go to the section.“Simple Text Edit” 
Simple create  “Simple Text Create” 
Create  “Text Create” 
Create v  “Create Text on Vertex of Super String” 
Centre s  “Text Create on Segment of Super Strings” 
Rotate v  “Rotate Text around Vertex” 
Rotate j  “Rotate Text about the Justification Point” 
Move v  “Move the Text Vertex Point” 
Move j  “Move the Text Justification Point” 
Height  “Height of Text” 
Text  “Change Text” 
Style  “Style of Text” 
Colour  “Text Colour” 
Reset j  “Reset Text Justification Point” 
Label perp. offset  “Label Perpendicular Offset” 
All  “All Text Edits” 
Delete  “Text Delete” 

Simple Text Edit
Cad_Edit_Simple_Text

Position of option on menu: Strings =>CAD =>Text =>Simple edit

or by selection of appropriate icon from the toolbar. 

This option edits text strings, and text on super string vertices or segments, using grips to 
quickly define the mode of editing (sizing, rotating or moving the justification point).

On selecting Simple edit, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

When the text to be edited is selected, grips for size, rotating and moving the justification point 
are displayed. The appropriate grip is then selected for quick editing.
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Size Grip (diamond):
If the Size grip is selected, the text size is dynamically adjusted by moving the cursor. The size of 
the text is displayed as part of the Enter height prompt in the message area.

The text size is set when a position is accepted.

An exact text size can be entered by hitting the <space bar> or by starting to type a size. This 
brings up the Enter distance typed input box. The size is typed in and the <enter> key pressed. 

To return to dynamic sizing without entering a distance, simply select the X on the top of the 
input box. The box will disappear and dynamic sizing will resume.

If the text is being dynamically sized, the current size of the text can be displayed by pressing the 
d key which brings up the Enter distance typed input box with the current text size in it.

The size can be modified and the value used by pressing the <enter> key.

To return to dynamic sizing without entering a distance, simply select the X on the top of the 
input box. 

Rotate Grip (circle):
If the Rotate grip is selected, the text bearing is dynamically adjusted by moving the cursor. The 
bearing of the text is displayed as part of the Enter bearing prompt in the message area.

The text bearing is set when a position is accepted.

grip for
moving
justification
point (square)

grip for
sizing

grip for
rotating

(diamond)

(circle)
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An exact bearing can be entered by hitting the <space bar> or by starting to type a bearing. This 
brings up the Enter bearing typed input box. The bearing is typed in and the <enter> key pressed. 

To return to dynamic rotating without entering a bearing, simply select the X on the top of the 
input box. The box will disappear and dynamic sizing will resume.

If the text is being dynamically rotated, the current bearing of the text can be displayed by 
pressing the d key which brings up the Enter bearing typed input box with the current text 
bearing in it.

The bearing can be modified and the value used by pressing the <enter> key.

To return to dynamic rotation without entering a bearing, simply select the X on the top of the 
input box. 

Justification Grip (square):
If the Justification grip is selected, the text justification point is dynamically adjusted by moving 
the cursor. The (x,y) position of the text is displayed in the message area.

The text justification point is set when a position is accepted.

An exact coordinate can be entered by hitting the <space bar> or by starting to type a coordinate. 
This brings up the Enter X Y Z typed input box. The x and y coordinates are typed in, separated by 
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a space, and the <enter> key pressed. 

To return to dynamic moving without entering a coordinate, simply select the X on the top of the 
input box. The box will disappear and dynamic moving will resume.

Simple Text Create
Cad_Create_Simple_Text

Position of option on menu: Strings =>CAD =>Text =>Simple create

or by selection of appropriate icon from the toolbar. 

This option creates text strings and then displays grips to quickly allow editing of text size, 
rotation and justification point.

The text style and height are taken from the Text controlbar and the model and colour from the 
CAD controlbar (see “CAD, Symbol and Text Controlbars” ,“Symbol Controlbar”  and “CAD 
Controlbar” ).
 

The text will be placed with the vertex and justification point at the selected position.

After defining one piece of text, the option restarts so that another of text can be defined. Picking 
Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the option.

On selecting Simple create, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

An insertion point for the text is selected and accepted and an Enter text typed input box is then 
displayed on the screen.

The text is typed into the box and the <enter> key pressed. 

The text will be placed with the vertex and justification point at the selected position and using 
values such as colour, model, text height and text style given in the CAD controlbar and Text 
controlbar (See “CAD, Symbol and Text Controlbars” )

When the text is displayed, grips for quick editing of size, rotation and moving of the 
justification point are also shown. The appropriate grip can then selected for quick editing. For 
details on using the grips, go to the section “Simple Text Create” .

text style, and sizetext model and colour
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Text Create
Cad_Create_Text

Position of option on menu: Strings =>CAD =>Text =>Create

or by selection of appropriate icon from the toolbar. 

This option creates text strings at a selected insertion point (a cursor snap is valid). 

After defining one piece of text, the option restarts so that another piece of text can be defined. 
Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

On selecting Create, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

An insertion point is selected and accepted. The text will be placed relative to the insertion point 
given other parameters such as justification, as defined in the textstyle data panel

STEP 2:

The actual text is entered into the text input box followed by the enter key.

STEP 3:

The text is created using the specified settings.

grip for
moving
justification
point

grip for
sizing

grip for
rotating
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Create Text on Vertex of Super String
Cad_Create_Text_on_Vertex

Position of option on menu: Strings =>CAD =>Text =>Create v

or by selection of appropriate icon from the toolbar. 

This option creates text at a vertex of a super string. One piece of text is allowed per super string 
vertex, so if this option is used on existing vertex text, the existing value is displayed in the text 
input box.

After defining one piece of text, the option restarts so that another piece of text can be defined. 
Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

On selecting Create v, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

An insertion point is selected and accepted. The point snap is forced on so that a vertex can be 
selected. The text will be placed relative to the insertion point given other parameters such as 
justification, as defined in the textstyle data panel

STEP 2:

The actual text is entered into the text input box followed by the enter key.

STEP 3:

The text is created using the specified settings.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.
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Text Create on Segment of Super Strings
Cad_Create_Text_on_Segment

Position of option on menu: Strings =>CAD =>Text =>Create s

or by selection of appropriate icon from the toolbar. 

This option creates text at the mid point of a selected super string segment. One piece of text is 
allowed per super string segment, so if this option is used on existing segment text, the existing 
value is displayed in the text input box.

After defining one piece of text, the option restarts so that another piece of text can be defined. 
Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

On selecting Create s, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A super string segment is selected and accepted. The line snap is forced on so that a segment can 
be selected. The text will be placed relative to the insertion point which is the midpoint of the 
segment given other parameters such as justification, as defined in the textstyle data panel

STEP 2:

The actual text is entered into the text input box followed by the enter key.

STEP 3:

The text is created using the specified settings.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.
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Rotate Text around Vertex
Cad_Rotate_Text_about_Vertex

Position of option on menu: Strings =>CAD =>Text =>Rotate v

or by selection of appropriate icon from the toolbar. 

This option rotates text about its vertex. This applies to text strings, super string segment or 
vertex text and 4d string vertex text. For super string segment text, the vertex is taken to be the 
mid point of the segment.

After defining one piece of text, the option restarts so that another piece of text can be defined. 
Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

On selecting Rotate v, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A text string to be rotated is selected and accepted.

STEP 2:

The rotation bearing (the final bearing of the text) is specified by selection and acceptance of a 
point with the mouse or by entry into an input box followed by the enter key. To bring up the 
input box start typing or press the space bar. The value is entered into the input box followed by 
the enter key.

Note: The typed bearing is not relative but absolute. i.e. the value given will not rotate the 
existing text by that amount, rather it will reposition the text at that bearing.

The line drawn represents the bearing value and changes with movement of the mouse. If the 
user wants to see what the current value of the bearing is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to specify the bearing or 
the input box can be closed and the rubber banding (graphically changing) of the angle 
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continued.

Note: The Page up and page down keys can be used when the input angle box comes up to 
add or subtract intervals of 90 degrees.

This option also allows the definition of the bearing by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

STEP 3:

The text is rotated to the specified bearing.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Rotate Text about the Justification Point
Cad_Rotate_Text_about_Justify

Position of option on menu: Strings =>CAD =>Text =>Rotate j

or by selection of appropriate icon from the toolbar. 

This option rotates text about its justification point. Note that the vertex point and the 
justification point do not coincide when either the raise or offset for the text is not zero.

Note: The typed bearing is not relative but absolute. i.e. the value given will not rotate the 
existing text by that amount, rather it will reposition the text at that bearing.

On selecting Rotate j, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The text to be rotated is selected and accepted.
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STEP 2:

The rotation bearing (the final bearing of the text) is specified by selection and acceptance of a 
point with the mouse or by entry into an angle box followed by the enter key. To bring up the 
angle box start typing or press the space bar. The value is entered into the input box followed by 
the enter key.

The line drawn represents the bearing value and changes with movement of the mouse. If the 
user wants to see what the current value of the bearing is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to specify the bearing or 
the input box can be closed and the rubber banding (graphically changing) of the bearing 
continued.

Note: The Page up and page down keys can be used when the bearing input box comes up to 
add or subtract intervals of 90 degrees.

This option also allows the definition of the bearing by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

STEP 3:

The text is rotated to the specified bearing.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.
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Move the Text Justification Point
Cad_Move_Text_Justify_Point

Position of option on menu: Strings =>CAD =>Text =>Move j

or by selection of appropriate icon from the toolbar. 

This option moves the text justification point, and hence the text with it.

On selecting Move j, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The text to be moved is selected and accepted.

STEP 2:

The new position for the text is selected and accepted.
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STEP 3:

The text is moved to the new position.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Move the Text Vertex Point
Cad_Move_Text_Vertex

Position of option on menu: Strings =>CAD =>Text =>Move v

or by selection of appropriate icon from the toolbar. 

This option moves the vertex that vertex text is attached to, and hence moves the text with it. The 
option works for text strings, vertex text for super strings and 4d string but will not work for 
segment text where there is no actual vertex at the mid segment position where the segment text 
is initially placed.

On selecting Move v, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The vertex text to be moved is selected and accepted.

STEP 2:

The new position for the vertex and the text is selected and accepted.
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STEP 3:

The vertex and the vertex text is moved to the new position.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Height of Text
Cad_Height_of_Text

Position of option on menu: Strings =>CAD =>Text =>Height

or by selection of appropriate icon from the toolbar. 

This option changes the height of text.

On selecting Height, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The text of which the height is to be changed is selected and accepted.
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STEP 2:

A height for the text is given either by selection with the mouse or by typing a value. To type a 
value, simply start typing and the input box for the height will appear. Alternatively you can 
press the space bar to bring up the input box. The value is entered into the input box followed by 
the enter key.

The circle drawn represents the height value and changes with movement of the mouse. If the 
user wants to see what the current value of the height is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the circle continued.

This option also allows the definition of the distance by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. 

STEP 3:

The text height is changed.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.



12d Model Reference Manual

Page 770 May 2007CAD

Change Text
Cad_Change_Text

Position of option on menu: Strings =>CAD =>Text =>Text

or by selection of appropriate icon from the toolbar. 

This option edits the characters of selected text.

On selecting Text, the user is prompted for the relevant data in the screen message box located at 
the bottom left hand corner of the 12d Model application window.

STEP 1:

The text to be changed is selected and accepted.

STEP 2:

The new text is entered into the text input box followed by the enter key.

STEP 3:
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The text is changed.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Style of Text
Cad_Style_of_Text

Position of option on menu: Strings =>CAD =>Text =>Style

or by selection of appropriate icon from the toolbar. 

This option changes the textstyle of selected text.

On selecting Style, the user is prompted for the relevant data in the screen message box located at 
the bottom left hand corner of the 12d Model application window.

STEP 1:

The text to be changed is selected and accepted.

STEP 2:

The new textstyle is selected from the style pop-up list.
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STEP 3:

The textstyle is changed.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Text Colour
Cad_Colour_of_Text

Position of option on menu: Strings =>CAD =>Text =>Colour

or by selection of appropriate icon from the toolbar. 

This option changes the colour of selected text.

On selecting Colour, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The text to be changed is selected and accepted.
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STEP 2:

The new colour for the text is entered into the text input box or by selecting the colour square on 
the input box to bring up the select colour choice box followed by the enter key.

STEP 3:

The text colour is changed.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Reset Text Justification Point
Cad_Reset_Text_Justify_Point

Position of option on menu: Strings =>CAD =>Text =>Reset j

or by selection of appropriate icon from the toolbar. 

This option resets the text justification point back to being the same as the vertex for vertex text, 
and to the segment mid point for segment text. That is, the offset and raise for the selected text 
are both set to zero.
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On selecting Reset j, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The text to be changed is selected and accepted.

STEP 2:

A warning message is shown giving the user the option of resetting the justification point or not.

STEP 3:

The text is reset if accepted.

Label Perpendicular Offset
Cad_Label_Perpendicular_Offset

Position of option on menu: Strings =>CAD =>Text =>Label perp. Offset

or by selection of appropriate icon from the toolbar. 

This option creates a perpendicular line from a selected segment to a selected position, and 
creates text with the value of the perpendicular distance between the segment and the selected 
position, on the line.
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On selecting Label perp. Offset, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A string is selected and accepted.

After the string is accepted a perpendicular line will be displayed ‘rubber banding’ to the 
various solutions according to the position of the cursor. This will continue until a 2nd point is 
selected and accepted.

STEP 2:

Select a 2nd point and accept it.

STEP 3:

A perpendicular line is constructed between the accepted string and point. The length value of 
this line will be displayed in text. This text can be modified or changed using the other CAD Text 
options.

STEP 4:

After the labelled perpendicular line is constructed, another perpendicular ’rubber banding’ line 
will be displayed. This will continue until the option is terminated (via the Esc key).

To create another labelled perpendicular line, select another point and accept it.
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STEP 5:

Another labelled perpendicular line is constructed. Another perpendicular ’rubber banding’ line 
will be displayed. This will continue until the option is terminated (via the Esc key).

All Text Edits
Cad_All_Text_Edits

All_Text_Edits

Position of option on menu: Strings =>CAD =>Text =>All

or by selection of appropriate icon from the toolbar. 

This option positions text using a menu made up of most of text edits already described.

On selecting All, the user is prompted for the relevant data in the screen message box located at 
the bottom left hand corner of the 12d Model application window.

STEP 1:

The text to be changed is selected and accepted.

STEP 2:

After the selection and acceptance of a piece of text, the positioning menu is shown. This also 
allows various other text editing functions such as colour, height and text.
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STEP 3:

The user can select the appropriate option from the menu and make the changes. The menu 
remains active allowing a number of operations to be made is succession.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Text Delete
Cad_Delete_Text

Position of option on menu: Strings =>CAD =>Text =>Delete

or by selection of appropriate icon from the toolbar. 

This option deletes selected text.

On selecting Delete, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The text to be deleted is selected and accepted.
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STEP 2:

The selected text is deleted. 

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.
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CAD Symbol
cad_symbol

Position of option on menu: Strings =>CAD =>Symbol

The Symbol walk-right menu is

12d Model symbols are world styles at a vertex of a super string. The symbol is attached to a 
vertex (these are displayed when Vertices are toggle on in a plan view) and has a justification 
point, a rotation, a delta x and a delta y. The vertex and justification point only coincide if the 
delta x and delta y values are both zero.

In some symbol options, the symbol type, size and angle are defined by the Symbol Controlbar and 
model and colour from the CAD Controlbar (for more information, go to the section “Symbol 
Controlbar” ). 

The symbols are defined in the symbols.4d file.

Menu of Options to Create and Manipulate Symbols

edit symbols using grips
create symbols and edit using grips
create a symbol at a selected position - a one point string is created
create a symbol at a user selected super string vertex
rotate symbol about its justification pt (which may be offset from the vertex
move symbol by its justification point (the vertex does not move)
change the height of a symbol
change the symbol
change the colour of a symbol
reset the symbol justification point so that it is on top of the vertex posn
menu to make most of the above changes to one selected symbol
delete a symbol
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For more information on the control bars, go to the sections “Symbol Controlbar”  and “CAD 
Controlbar” .

For the option Simple edit, go to the section “Simple Symbol Edit” 
 Simple create “Simple Symbol Create” 
 Create “Create Symbol” 
 Create v “Create Symbol at the Vertex of a Super String” 
Rotate j “Rotate Symbol about the Justification Point” 
Move v “Move the Symbol Justification Point” 
Move j “Move the Symbol Justification Point” 
Height “Height of Symbol” 
Symbol “Change Symbol” 
Colour “Symbol Colour” 
Reset j “Reset the Symbol Justification Point” 
All “All Symbol Edits” 
Delete “Symbol Delete” 

Simple Symbol Edit
Cad_Edit_Simple_Symbol

Position of option on menu: Strings =>CAD =>Text =>Simple edit

or by selection of appropriate icon from the toolbar. 

This option edits symbols using grips to quickly define the mode of editing (sizing, rotating or 
moving the justification point).

On selecting Simple edit, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

When the symbol to be edited is selected, grips for size, rotating and moving the justification 
point are displayed. The appropriate grip is then selected for quick editing.

Size Grip (diamond):
If the Size grip is selected, the symbol size is dynamically adjusted by moving the cursor. The size 
of the symbol is displayed as part of the Enter height prompt in the message area.

The symbol size is set when a position is accepted.

grip for
moving
justification
point (square)

grip for
sizing

grip for
rotating

(diamond)

(circle)
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An exact symbol size can be entered by hitting the <space bar> or by starting to type a size. This 
brings up the Enter distance typed input box. The size is typed in and the <enter> key pressed. 

To return to dynamic sizing without entering a distance, simply select the X on the top of the 
input box. The box will disappear and dynamic sizing will resume.

If the symbol is being dynamically sized, the current size of the text can be displayed by pressing 
the d key which brings up the Enter distance typed input box with the current dynamic symbol 
size in it.

The size can be modified and the value used by pressing the <enter> key.

To return to dynamic sizing without entering a distance, simply select the X on the top of the 
input box. 

Rotate Grip (circle):
If the Rotate grip is selected, the symbol bearing is dynamically adjusted by moving the cursor. 
The bearing of the symbol is displayed as part of the Enter bearing prompt in the message area.

The symbol bearing is set when a position is accepted.

An exact bearing can be entered by hitting the <space bar> or by starting to type a bearing. This 
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brings up the Enter bearing typed input box. The bearing is typed in and the <enter> key pressed. 

To return to dynamic rotating without entering a bearing, simply select the X on the top of the 
input box. The box will disappear and dynamic sizing will resume.

If the symbol is being dynamically rotated, the current bearing of the symbol can be displayed by 
pressing the d key which brings up the Enter bearing typed input box with the current symbol 
bearing in it.

The bearing can be modified and the value used by pressing the <enter> key.

To return to dynamic rotation without entering a bearing, simply select the X on the top of the 
input box. 

Justification Grip (square):
If the Justification grip is selected, the symbol justification point is dynamically adjusted by 
moving the cursor. The (x,y) position of the symbol is displayed in the message area.

The symbol justification point is set when a position is accepted.

An exact coordinate can be entered by hitting the <space bar> or by starting to type a coordinate. 
This brings up the Enter X Y Z typed input box. The x and y coordinates are typed in, separated by 
a space, and the <enter> key pressed. 

To return to dynamic moving without entering a coordinate, simply select the X on the top of the 
input box. The box will disappear and dynamic moving will resume.

Simple Symbol Create
Cad_Create_Simple_Symbol

Position of option on menu: Strings =>CAD =>Text =>Simple create

or by selection of appropriate icon from the toolbar. 
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This option creates symbols and then displays grips to allow quick editing of symbol size, 
rotation and justification point.

The symbol and symbol height and symbol angle are taken from the Symbol controlbar (See 
“CAD, Symbol and Text Controlbars” ) and the model and colour (if the symbol does not have an 
inbuilt colour) from the CAD controlbar (see “CAD, Symbol and Text Controlbars” ,“Symbol 
Controlbar”  and “CAD Controlbar” ).
 

The symbol will be placed with the vertex and justification point at the selected position.

After defining one symbol, the option restarts so that another symbol can be defined. Picking 
Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the option.

On selecting Simple create, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

An insertion point for the symbol is selected and accepted, the symbol is displayed on the screen.

Warning - if no symbol appears, then there is probably no symbol selected in the Symbol 
controlbar.

When the symbol is displayed, grips for quick editing of size, rotation and moving of the 
justification point are also shown. The appropriate grip can then selected for quick editing. For 
details on using the grips, go to the section “Simple Symbol Edit” .

Create Symbol
Cad_Create_Symbol

Position of option on menu: Strings =>CAD =>Symbols =>Create

or by selection of appropriate icon from the toolbar. 

This option creates a symbol (as a one vertex super string) at a selected point (a cursor snap is 
valid).

After defining a symbol, the option restarts so that another symbol can be defined. Picking 
Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the option.

On selecting Create, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

symbol name, size and anglesymbol model and default colour

grip for
moving
justification
point (square)

grip for
sizing

grip for
rotating

(diamond)

(circle)
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An insertion point is selected and accepted. A one vertex super string is created and the symbol 
placed at that vertex. The symbol is placed relative to the insertion point given in the symbol 
definition (See symbols.4d file).

STEP 2:

The symbol style (name) is entered into the input box or selected from the select symbol choice 
box. The choice box is opened by pressing the symbol icon on the right of the input box. A valid 
symbol type can be found by walking right on the symbol menu

STEP 3:

A symbol size is given either by selection with the mouse or by typing a value. To type a value, 
simply start typing and the input box for the size will appear. The user can also press the space 
bar to bring up the input box. The value is entered into the input box followed by the enter key.

The circle drawn represents the size value and changes with movement of the mouse. If the user 
wants to see what the current value of the height is, simply press the D key (dynamic value). 
This puts the value into the input box where it can be accepted to create the symbol or the input 
box can be closed and the rubber banding (graphically changing) of the circle continued.

This option also allows the definition of the size by the selection of a point perpendicular or 
tangential to a selected segment. For this, the line snap should be on. The user selects the 
segment (line or arc) and then by pressing P for perpendicular or T for tangential a solution is 
shown. As there is often two solutions with respect to arcs, the user can move the mouse to 
change from one solution to the next. 
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STEP 4:

The symbol is created together with a point super string at the selected point.

Create Symbol at the Vertex of a Super String
Cad_Create_Symbol_on_Vertex

Position of option on menu: Strings =>CAD =>Symbols=> Create v

or by selection of appropriate icon from the toolbar. 

This option creates a symbol at a vertex of a super string. One symbol is allowed per super string 
vertex, so if this option is used on existing vertex symbol, the existing value is displayed in the 
symbol input box.

After defining a symbol, the option restarts so that another symbol can be defined. Picking 
Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the option.

On selecting Create v, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

An insertion point is selected and accepted. The point snap is forced on so that a vertex can be 
selected. The Symbol will be placed relative to the insertion point given other parameters such as 
justification, as defined in the symbol definition.

STEP 2:

The symbol style is entered into the input box or selected from the select symbol choice box. The 
choice box is opened by pressing the symbol icon on the right of the input box. A valid symbol 
type can be found by walking right on the symbol menu
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STEP 3:

A symbol size is given either by selection with the mouse or by typing a value. To type a value, 
simply start typing and the input box for the size will appear. The user can also press the space 
bar to bring up the input box. The value is entered into the input box followed by the enter key.

The circle drawn represents the size value and changes with movement of the mouse. If the user 
wants to see what the current value of the height is, simply press the D key (dynamic value). 
This puts the value into the input box where it can be accepted to create the symbol or the input 
box can be closed and the rubber banding (graphically changing) of the circle continued.

This option also allows the definition of the size by the selection of a point perpendicular or 
tangential to a selected segment. For this, the line snap should be on. The user selects the 
segment (line or arc) and then by pressing P for perpendicular or T for tangential a solution is 
shown. As there is often two solutions with respect to arcs, the user can move the mouse to 
change from one solution to the next. 

STEP 4:

The symbol is created at the vertex of the super string.

Rotate Symbol about the Justification Point
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Cad_Rotate_Symbol_about_Justify

Position of option on menu: Strings =>CAD =>Symbols =>Rotate j

or by selection of appropriate icon from the toolbar. 

This option rotates a symbol about its justification point. The vertex point and the justification 
point often do not coincide. This occurs when non zero value is specified for either the x or y 
offset.

Note: The typed bearing is not relative but absolute. i.e. the value given will not rotate the 
existing symbol by that amount, rather it will reposition the symbol at that bearing.

On selecting Rotate j, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The Symbol to be rotated is selected and accepted.

STEP 2:

The rotation bearing (the final bearing of the symbol) is specified by selection and acceptance of 
a point with the mouse or by entry into an angle box followed by the enter key. To bring up the 
angle box start typing or press the space bar. The value is entered into the input box followed by 
the enter key.

The line drawn represents the bearing value and changes with movement of the mouse. If the 
user wants to see what the current value of the bearing is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to specify the bearing or 
the input box can be closed and the rubber banding (graphically changing) of the bearing 
continued.

Note: The Page up and page down keys can be used when the bearing input box comes up to 
add or subtract intervals of 90 degrees.

This option also allows the definition of the bearing by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. The example shown below is the perpendicular 
case. 

STEP 3:

The Symbol is rotated to the specified bearing.
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Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Move the Symbol Justification Point
Cad_Move_Symbol_Justify_Point

Position of option on menu: Strings =>CAD =>Symbols =>Move j

or by selection of appropriate icon from the toolbar. 

This option moves a symbol by moving its justification point.

On selecting Move j, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The Symbol to be moved is selected and accepted.

STEP 2:

The new position for the Symbol is selected and accepted.

STEP 3:

The Symbol moves to the new position.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.
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Move the Symbol Vertex Point
Cad_Move_Symbol_Vertex

Position of option on menu: Strings =>CAD =>Symbols =>Move v

or by selection of appropriate icon from the toolbar. 

This option moves a symbol by moving the vertex that the symbol is attached to. Hence the 
symbol and the justification point for the symbol will move.

On selecting Move V, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The Symbol to be moved is selected and accepted.

STEP 2:

The new position for the vertex of the Symbol is selected and accepted.

STEP 3:

The Symbol moves to the new position.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Height of Symbol
Cad_Height_of_Symbol

Position of option on menu: Strings =>CAD =>Symbols =>Height

or by selection of appropriate icon from the toolbar. 

This option changes the height of a symbol.

On selecting Height, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The Symbol of which the height is to be changed is selected and accepted.
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STEP 2:

A height for the Symbol is given either by selection with the mouse or by typing a value. To type 
a value, simply start typing and the input box for the height will appear. Alternatively you can 
press the space bar to bring up the input box. The value is entered into the input box followed by 
the enter key.

The circle drawn represents the height value and changes with movement of the mouse. If the 
user wants to see what the current value of the height is, simply press the D key (dynamic 
value). This puts the value into the input box where it can be accepted to create the point or the 
input box can be closed and the rubber banding (graphically changing) of the circle continued.

This option also allows the definition of the distance by the selection of the 2nd point 
perpendicular or tangential to a selected segment. For this, the line snap should be on. The user 
selects the segment (line or arc) and then by pressing P for perpendicular or T for tangential a 
solution is shown. As there is often two solutions with respect to arcs, the user can move the 
mouse to change from one solution to the next. 

STEP 3:

The Symbol height is changed.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.
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Change Symbol
Cad_Change_Symbol

Position of option on menu: Strings =>CAD =>Symbols =>Symbol

or by selection of appropriate icon from the toolbar. 

This option changes the actual symbol defined at a super string vertex.

On selecting Symbol, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The Symbol to be changed is selected and accepted.

STEP 2:

The symbol style is entered into the input box or selected from the select symbol choice box. The 
choice box is opened by pressing the symbol icon on the right of the input box. A valid symbol 
type can be found by walking right on the symbol menu
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STEP 3:

The Symbol is changed.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Symbol Colour
Cad_Colour_of_Symbol

Position of option on menu: Strings =>CAD =>Symbol =>Colour

or by selection of appropriate icon from the toolbar. 

This option changes the default colour of a symbol. 

Important Note: if the symbol has inbuilt colours, changing the default colour will not change 
the symbols displayed colours. For this case, the definition of the symbol itself will need to be 
changed.

On selecting Colour, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The symbol to have the default colour changed is selected and accepted.

STEP 2:

The new colour for the Symbol is entered into the Symbol input box or by selecting the colour 
square on the input box to bring up the select colour choice box followed by the enter key.
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STEP 3:

The Symbol colour is changed.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Reset the Symbol Justification Point
Cad_Reset_Symbol_Justify_Point

Position of option on menu: Strings =>CAD =>Symbol =>Reset j

or by selection of appropriate icon from the toolbar. 

This option resets justification point of a selected symbol. That is, the x and y offsets for the 
justification point are set to zero.

On selecting Reset j, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The Symbol to be changed is selected and accepted.

STEP 2:
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A warning message is shown giving the user the option of resetting the justification point or not.

STEP 3:

The symbol is reset if accepted.

All Symbol Edits
Cad_All_Symbol_Edits

All_Symbol_Edits

Position of option on menu: Strings =>CAD =>Symbol =>All

or by selection of appropriate icon from the toolbar. 

This option allows a number of symbol editing options to be done in succession using a menu 
made up of many of the options defined above.

On selecting All, the user is prompted for the relevant data in the screen message box located at 
the bottom left hand corner of the 12d Model application window.

STEP 1:

The Symbol to be changed is selected and accepted.
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STEP 2:

After the selection and acceptance of a symbol, the positioning menu is shown. This also allows 
various other symbol editing functions such as colour, height and rotate.

STEP 3:

The user can select the appropriate option from the menu and make the changes. The menu 
remains active allowing a number of operations to be made is succession.

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

Symbol Delete
Cad_Delete_Symbol

Position of option on menu: Strings =>CAD =>Symbol =>Delete

or by selection of appropriate icon from the toolbar. 
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This option deletes symbols.

On selecting Delete, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The Symbol to be deleted is selected and accepted.

STEP 2:

The selected Symbol is deleted. 

Picking Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the 
option.

CAD Holes
cad_fills

Position of option on menu: Strings =>CAD =>Holes

The Holes walk-right menu is

For the option Add holes, go to the section “Add Holes” 
Remove holes “Remove Holes” 

Add Holes
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Cad_Add_Holes

Position of option on menu: Strings =>CAD =>Polygons =>Add holes

or by selection of appropriate icon from the toolbar. 

This option adds holes to a polygon.

On selecting Add holes, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

First select the parent string. That is the polygon that is to have holes added to it.

STEP 2:

Then select the polygons that are to be the holes in the parent polygon (the child strings).

The selection of holes is terminated by pressing the <esc> key.

It is easier to see the result by colour filling the parent polygon.
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Remove Holes
Cad_Remove_Holes

Position of option on menu: Strings =>CAD =>Polygons =>Remove holes

or by selection of appropriate icon from the toolbar. 

This option removes all holes from a polygon with holes.

On selecting Remove holes, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the parent string. That is the polygon that contains holes.

STEP 2:

On selecting and accepting the string, all holes are removed from the string. Super strings are 
created for each of the hole boundaries.
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CAD Fills
cad_fills

Position of option on menu: Strings =>CAD =>Fills

The Fills walk-right menu is

For the option Solid fill, go to the section “Solid Fill” 
Solid fill many  “Solid Fill Many Strings” 

Solid Fill
Cad_Solid_Fill

Position of option on menu: Strings =>CAD =>Fills =>Solid Fill

or by selection of appropriate icon from the toolbar. 

This option fills a super string with a user defined colour and blend.

On selecting Solid Fill, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select and accept a string.

If the string selected is an enclosed shape, then the filled area is simply the closed shape. If the 
string isn’t closed (such as two perpendicular lines), for the purposes of this option, the string 
will be temporarily closed and closed area coloured.

Note: If the string selected is a straight line, then its area is zero. When the colour fill of a line 
is completed, the line will simply disappear. This is because there is no area to colour.
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STEP 2:

After the string is accepted, the Fill Colour Input box will appear. Type the name of the required 
colour into the Input box and press the enter key. The browse button  on the Input box can 
be used to define the blend by measuring existing elements.

STEP 3:

After the colour is accepted, the Blend Input box will appear. This selection determines the 
transparency of the filled colour. A value between 0 (totally opaque) and 1(totally transparent) 
must be selected.

STEP 4:

The selected super string is then filled.

Solid Fill Many Strings

Blend 0 Blend 1
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Cad_Solid_Fill_Many

Position of option on menu: Strings =>CAD =>Fills =>Solid fill many

or by selection of appropriate icon from the toolbar. 

This option fills many selected super strings with the same user defined colour and blend.

On selecting Solid fill many, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

After selecting the option, the Fill Colour Input box is displayed.

Type the name of the required colour into the Input box and press the enter key. The browse 
button  on the Input box can be used to define the blend by measuring existing elements.

STEP 2:

After the colour is accepted, the Blend Input box will appear. This selection determines the 
transparency of the filled colour. A value between 0 (totally opaque) and 1(totally transparent) 
must be selected.

STEP 3:

Select and accept a string and the string is coloured filled.

The selected super string is then filled.
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Then select and accept the next string to fill and the same colour and blend is used to colour fill 
the next string 

If the string selected is an enclosed shape, then the filled area is simply the closed shape. If the 
string isn’t closed (such as two perpendicular lines), for the purposes of this option, the string 
will be temporarily closed and closed area coloured.

Note: If the string selected is a straight line, then its area is zero. When the colour fill of a line 
is completed, the line will simply disappear. This is because there is no area to colour.

CAD Images
cad_images

Position of option on menu: Strings =>CAD =>Images

The Fills walk-right menu is

For the option Insert Image, go to the section “Insert Image” 
Move Image “Move Image” 
Rotate Image “Rotate Image” 

Blend 0 Blend 1
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Scale Image “Scale Image” 
Width Image “Width Image” 
Height Image “Height Image” 
Delete Image “Delete Image” 

Insert Image
Cad_Insert_Plan_Image

Position of option on menu: Strings =>CAD =>Images =>Insert Image

or by selection of appropriate icon from the toolbar. 

This option creates a on vertex super strings and inserts an images at the vertex.

On selecting Insert Image, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

On selecting Insert Image, the Cad Insert Plan Image panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Format Input box BMP, DIB, ECW, GIF, JPEG
JPEG 2000, PNG, TGA
TIFF, 12D

Select the type of image file to insert.

Image file Input box

Select the image filename to be inserted into the project.

X/Y co-ordinate XY Pick button

Select the x/y co-ordinate for origin (bottom left corner) of the image.

Origin X coordinate Input box

Enter the x coordinate for the bottom left of the image.

Origin Y coordinate Input box

Enter the y coordinate for the bottom left of the image.

Pixel to mm Input box

This determines the scale of the image.

Model for image Input box

Select the model for the image to be inserted into.
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Insert button

When all the fields have been entered, the insert button will display the image into the defined model.

Move Image
Cad_Move_Plan_Image

Position of option on menu: Strings =>CAD =>Images =>Move Image

or by selection of appropriate icon from the toolbar. 

This option moves an inserted image by modifying the x and y offset for the image. The vertex 
that the image is attached to does not move.

On selecting Move Image, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the vertex that the image is attached to.

Note: The position of the image is defined relative to the vertex. To select the image, the vertex 
that the image is attached to must be selected. The image itself can not be picked.

STEP 2:

After a vertex of an image is accepted, an outline of the image is displayed and moves with the 
position of the cursor. This will continue until the new position is selected and accepted.

Select the new position and accept it.

The cursor position can be selected with the mouse or entered via the keyboard. To enter a 
position with the keyboard, simply start typing or press the space bar to bring up the XYZ Input 
box. Type the coordinates into the XYZ Input box and press the <enter> key.

STEP 3:

The image is then displayed at its new position.
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Note: The CAD Move Image option only moves the image offset relative to the vertex. Use the 
option CAD Move to move the vertex (and the corresponding image moves with it).

Rotate Image
Cad_Rotate_Plan_Image

Position of option on menu: Strings =>CAD =>Images =>Rotate Image

or by selection of appropriate icon from the toolbar. 

This option rotates an image around its justification point.

On selecting Rotate Image, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the vertex that the image is attached to.

Note: The position of the image is defined relative to the vertex. To select the image, the vertex 
that the image is attached to must be selected. The image itself can not be picked.

STEP 2:

After the vertex of an image is accepted, an outline of the image is displayed. The outline is 
rotated dynamically as the position of the cursor changes. This will continue until a final position 
is selected and accepted.

Select the new rotated position and accept it.

The cursor position can be selected with the mouse or entered via the keyboard. To enter a 
position with the keyboard, simply start typing or press the space bar to bring up the XYZ Input 
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box. Type the coordinates into the XYZ Input box and press the <enter> key.

STEP 3:

The rotated image is then displayed.

Scale Image
Cad_Scale_Plan_Image

Position of option on menu: Strings =>CAD =>Images =>Scale Image

or by selection of appropriate icon from the toolbar. 

This option changes the size of an image.

On selecting Scale Image, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the vertex that the image is attached to.

Note: The position of the image is defined relative to the vertex. To select the image, the vertex 
that the image is attached to must be selected. The image itself can not be picked.

STEP 2:

After the vertex of an image is accepted, an outline of the image is displayed. The size of the 
outline is determined by the position of the cursor. Both the height and the width of the image 
increase/decrease in the same ratio so that the image is not distorted.

Select the new size as given by the cursor position, and accept it.
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The cursor position can be selected with the mouse or entered via the keyboard. To enter a 
position with the keyboard, simply start typing or press the space bar to bring up the XYZ Input 
box. Type the coordinates into the XYZ Input box and press the <enter> key.

STEP 3:

The scaled image is then displayed.

Width Image
Cad_Width_Plan_Image

Position of option on menu: Strings =>CAD =>Images =>Width Image

or by selection of appropriate icon from the toolbar. 

This option is user to increase or decrease the width of an image. The height of the image is not 
changed so the images will be stretched.

On selecting Width Image, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the vertex that the image is attached to.

Note: The position of the image is defined relative to the vertex. To select the image, the vertex 
that the image is attached to must be selected. The image itself can not be picked.

STEP 2:

After the vertex of an image is accepted, the outline of the image is displayed. The width of the 
outline is determined by the position of the cursor. Whilst the height remains constant, the width 
of the outline increases and decreases dynamically as the position of the cursor changes.
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Select the new width as given by the cursor position, and accept it.

The cursor position can be selected with the mouse or entered in via the keyboard. To enter a 
position with the keyboard, simply start typing or press the space bar to bring up the XYZ Input 
box. Type the coordinates into the XYZ Input box and press the <enter> key.

STEP 3:

The image with the new width is then displayed.

Height Image
Cad_Height_Plan_Image

Position of option on menu: Strings =>CAD =>Images =>Height Image

or by selection of appropriate icon from the toolbar. 

This option allows the user to increase or decrease the height of an image. The width of the 
image is not changed so the images will be stretched.

On selecting Height Image, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the vertex that the image is attached to.

Note: The position of the image is defined relative to the vertex. To select the image, the vertex 
that the image is attached to must be selected. The image itself can not be picked.

STEP 2:
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After the vertex of an image is accepted, the outline of the image is displayed. The height of the 
outline is determined by the position of the cursor. Whilst the width remains constant, the height 
of the outline increases and decreases dynamically as the position of the cursor changes.

Select the new height as given by the cursor position, and accept it.

The cursor position can be selected with the mouse or entered in via the keyboard. To enter a 
position with the keyboard, simply start typing or press the space bar to bring up the XYZ Input 
box. Type the coordinates into the XYZ Input box and press the <enter> key.

STEP 3:

The image with the new height is then displayed.

Delete Image
Cad_Delete_Plan_Image

Position of option on menu: Strings =>CAD =>Images =>Delete Image

or by selection of appropriate icon from the toolbar. 

This option deletes an image.

On selecting Delete Image, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the vertex that the image is attached to.

Note: The position of the image is defined relative to the vertex. To select the image, the vertex 
that the image is attached to must be selected. The image itself can not be picked.
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STEP 2:

When the selected image is accepted, it is then deleted.

Note that the vertex that the image was attached to is not deleted.

CAD Modify
cad_modify

Position of option on menu: Strings =>CAD =>Modify

The Modify walk-right menu is

For the option Move, please go to the section“Move” .
Copy “Copy” 
Array “Array” 
Rotate “Rotate” 
Mirror “Mirror” 
Mirror X axis “Mirror X Axis” 
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Mirror Y axis “Mirror Y Axis” 
Scale “Scale” 
Scale dynamic “Scale Dynamic” 

Move
Cad_Move

Position of option on menu: Strings =>CAD =>Modify =>Move

or by selection of appropriate icon from the toolbar. 

This option moves a selected string.

On selecting Move, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

A super string or circle is picked.

STEP 2:

A base position is picked and then an outline of the selected string will be drawn and moved 
with the cursor, plus a line will be drawn from the base position to the current cursor position. 

Note: The base position is not required to lie on the string itself.

STEP 3:

A final cursor position is selected which defines a distance and direction from the base position 
to the final position.

STEP 4:

On accepting the final position, selected super string is moved by the determined distance and 
direction.

Copy
Cad_Copy

Position of option on menu: Strings =>CAD =>Modify =>Copy

or by selection of appropriate icon from the toolbar. 

This option copies a super string.

On selecting Copy, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select a super string.

STEP 2:

base
position

outline of
selected string

cursor
position

selected
string
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A base position is picked and then an outline of the selected string will be drawn and moved 
with the cursor, plus a line will be drawn from the base position to the current cursor position. 

Note: The base position is not required to lie on the string itself.

STEP 3:

A final cursor position is selected which defines a distance and direction from the base position 
to the final position.

STEP 4:

On accepting the final position, a copy of the selected super string is moved by the determined 
distance and direction.

Array
Cad_Array

Position of option on menu: Strings =>CAD =>Modify =>Array

or by selection of appropriate icon from the toolbar. 

This option copies a super string a number of times.

base
position

outline of
selected string

cursor
position

selected
string

base
position

outline of
selected string

position

selected
string

final cursor

distance and direction vector
to apply to selected string

original
string

copy of
string
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On selecting Array, the Cad Array panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Rows Input box

number of rows

Columns Input box

number of columns

Row offset Input box

distance between the rows

Column offset Input box

distance between the columns

Rotation angle box

the angle to use for the rows and columns of copies

Pick button

pick the super string to copy and when it is accepted the super string is copied

STEPS:

Fill in the fields in the Cad Array panel, click on Pick and select the super string to copy.
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Rotate
Cad_Rotate

Position of option on menu: Strings =>CAD =>Modify =>Rotate

or by selection of appropriate icon from the toolbar. 

This option rotates a super string.

On selecting Rotate, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the super string to rotate.

STEP 2:

A base position is picked and then an outline of the selected string is drawn and rotated around 
the base position with the cursor, plus a line will be drawn from the base position to the current 
cursor position. 

Note: The base position is not required to lie on the string itself.

When the line has a bearing of 90 degrees, the outline will be on top of the selected string (i.e. 
there is no rotation). As the line rotates around the base position, the outline rotates around the 
base position. This rotation will continue until the final point is selected and accepted.

STEP 3:

A final cursor position is selected which defines the rotation about the base position. 

On accepting the final position, the selected string is rotated around the base position through 
the defined angle.

base
position

outline of
selected string

cursor
position

selected
string
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Mirror
Cad_Mirror

Position of option on menu: Strings =>CAD =>Modify =>Mirror

or by selection of appropriate icon from the toolbar. 

This option creates a mirrored image of a selected string.

On selecting Mirror, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select a super string to mirror.

STEP 2:

Select the 1st point of the mirror axis.

The 1st point is selected with the mouse or entered in via the keyboard. To enter a point with the 
keyboard, simply start typing or press the space bar to bring up the XYZ Input box. Type the 
coordinates into the XYZ Input box and press the enter key.

After the 1st point is accepted a line will be drawn from the 1st point to the position of the cursor. 
This line forms the mirroring axis. The outline of the reflected image will be dynamically 
displayed according to the changing cursor position.

STEP 3:
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Select and accept the 2nd point of the mirror axis.

STEP 4:

After the base point is accepted, the Delete Source String box will appear. 

Select yes if you want the original super string to be deleted when the new mirrored string is 
constructed.

Select no if you want the original super string to remain when the new mirrored string is 
constructed.

STEP 5:

The selected super string will be mirrored using the information given.

Mirror X Axis
Cad_Mirror_X_Axis

Position of option on menu: Strings =>CAD =>Modify =>Mirror X axis

or by selection of appropriate icon from the toolbar. 

This option mirrors a string through the x axis.

On selecting Mirror X Axis, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select a super string to mirror though the x axis.

Delete the source string Don’t delete the source string
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STEP 2:

After the string is accepted the position of the cursor on the y axis determines the position of the 
mirror (which runs parallel to the x axis). As the cursor moves along the y axis, a reflection of the 
selected string will be dynamically displayed. This will continue until a final position is selected, 
thus determining the mirror axis.

Select the final y-position of the mirror x-axis.

The final position is selected with the mouse or entered in via the keyboard. To enter a base point 
with the keyboard, simply start typing or press the space bar to bring up the XYZ Input box. 
Type the coordinates into the XYZ Input box and press the enter key.

STEP 3:

After the final position is accepted, a Delete Source String box will appear.

Select yes if you want the original super string to be deleted when the new mirrored string is 
constructed.

Select no if you want the original super string to remain when the new mirrored string is 
constructed.

STEP 4:

The selected super string will be mirrored using the information given.

Mirror Y Axis
Cad_Mirror_Y_Axis

Delete the source string Don’t delete the source string
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Position of option on menu: Strings =>CAD =>Modify =>Mirror Y Axis

or by selection of appropriate icon from the toolbar. 

This option mirrors a string through the y axis.

On selecting Mirror Y Axis, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select a super string to mirror though the y axis.

STEP 2:

After the string is accepted the position of the cursor on the x axis determines the position of the 
mirror (which runs parallel to the y axis). As the cursor moves along the x axis, a reflection of the 
selected string will be dynamically displayed. This will continue until a final position is selected, 
thus determining the mirror axis.

Select the final x-position of the mirror y-axis.

The final position is selected with the mouse or entered in via the keyboard. To enter a base point 
with the keyboard, simply start typing or press the space bar to bring up the XYZ Input box. 
Type the coordinates into the XYZ Input box and press the enter key.

STEP 3:

After the final position is accepted, a Delete Source String box will appear.

Select yes if you want the original super string to be deleted when the new mirrored string is 
constructed.

Select no if you want the original super string to remain when the new mirrored string is 
constructed.
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STEP 4:

The selected super string will be mirrored using the information given.

Scale
Cad_Scale

Position of option on menu: Strings =>CAD =>Modify =>Scale

or by selection of appropriate icon from the toolbar. 

This option increases or decreases the size of a string by a given scale.

On selecting Scale, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select a super string to scale.

STEP 2:

After a string is accepted, the Scale Input box will appear. Type the desired scale into the input 
box and press the enter key. The browse button  on the Input box can be used to define the 
scale by measuring existing elements.

STEP 3:

After a scale value has been entered the user is required to select an origin position.

An origin position can be selected with the mouse or entered in via the keyboard. To enter a start 

Delete the source string Don’t delete the source string
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position with the keyboard, simply start typing or press the space bar to bring up the XYZ Input 
box. Type the coordinates into the XYZ Input box and press the enter key.

The dimensions of the highlight string are defined by the scale value.

The position of the scaled highlight string moves dynamically as the position of the cursor 
moves. The origin position establishes the location of the scaled string relative to the original 
selected string.

For example, if you selected a scale of "2", the distance between the cursor and a point on the 
highlight string would be double the distance between the cursor and the corresponding point 
on the original super string.

STEP 4:

After the final position has been accepted, the original string will be removed and the newly 
scaled highlight string constructed.

Scale Dynamic
Cad_Scale_Dynamic

Position of option on menu: Strings =>CAD =>Modify =>Scale Dynamic

or by selection of appropriate icon from the toolbar. 

This option dynamically increases or decreases the size of a string.

On selecting Scale Dynamic, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select a super string to scale.
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STEP 2:

An origin point is required to be defined. An origin point can be selected with the mouse or 
entered in via the keyboard. To enter a start point with the keyboard, simply start typing or press 
the space bar to bring up the XYZ Input box. Type the coordinates into the XYZ Input box and 
press the enter key.

STEP 3:

After an origin point has been accepted, a projection point needs to be defined. The highlight 
string will be projected from the origin point. The size and position of the highlight string will 
move dynamically as the position of the cursor moves.The highlight string will increase in size if 
the cursor moves further from the origin point. Conversely, the highlight string will decrease in 
size if the cursor moves closer to the origin point. This will continue until a projection point is 
accepted.

STEP 4:

After the projection point has been accepted, the original string will be removed and the newly 
scaled highlight string will be constructed.
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CAD Edit Points
cad_edits

Position of option on menu: Strings =>CAD =>Change points

The Change points walk-right menu is

These option allow the editing of vertices on super strings.

For the option Move point, go to the section “Move a Vertex Keeping its Height” 
Move point (including ht) “Extend a Vertex and Keeping its Height” 

Menu of Options to Move Vertices

move a vertex
move a vertex along its segment - keep the same height
move a vertex along its segment - interpolate/extrapolate the height
move a vertex by a given chainage distance along a segment - keep ht
move a vertex a given chainage dist along a segment - extrapolate ht
append a vertex to an existing string
create a vertex on the segment joining two adjacent vertices of a string
insert a vertex between two adjacent vertices of a string
edit the height of a vertex
edit the point (vertex) id
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Extend point “Extend a Vertex and Keeping its Height” 
Extend point (ht) “Extend Segment and Extrapolating Heights” 
Extend point by length “Extend Segment by Length and Keeping Height” 
Extend point by length (ht)“Extend Segment by Length and Extrapolating Heights” 
Point append “Append a Vertex” 
Point between “New Vertex on a Segment (Between Two Vertices)” 
Point Insert “Insert a Vertex” 
Point Height “Change Height of a Vertex” 
Point id “Point Id” 

Move a Vertex Keeping its Height
Cad_Move_Point_on_Super_String

Position of option on menu: Strings =>CAD =>Change points =>Move point

or by selection of appropriate icon from the toolbar. 

This option moves the vertex of a super string. The height of the vertex is not modified.

On selecting Move point, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A vertex on a super string is selected and accepted.

STEP 2:

The position of the selected vertex moves with the cursor until the final position of the vertex is 
selected and accepted. Alternatively, the user can type in the final coordinate of the vertex by the 
using the Enter XYZ box. This box is brought up by simply typing a value or by pressing the 
space bar. 

STEP 3:

The selected vertex is moved to the new position.
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Move a Vertex and Modify its Height
Cad_Move_Point_on_Super_String__including_z_

Position of option on menu: Strings =>CAD =>Change points =>Move point (including z)

or by selection of appropriate icon from the toolbar. 

This option moves the vertex of a super string and the height of the vertex is taken from the 
height of the final selected position.

On selecting Move point (including ht), the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A vertex on a super string is selected and accepted.

STEP 2:

The position of the selected vertex moves with the cursor until the final position of the vertex is 
selected and accepted. Alternatively, the user can type in the final coordinate of the vertex by the 
using the Enter XYZ box. This box is brought up by simply typing a value or by pressing the 
space bar. 

STEP 3:

The selected vertex is moved to the new position and takes on the height of the string it is 
snapped to, or the Z value entered into the Enter XYZ box.
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Extend a Vertex and Keeping its Height
Cad_Extend_Point_on_Super_String

Position of option on menu: Strings =>CAD =>Change points =>Extend point

or by selection of appropriate icon from the toolbar. 

This option extends (or shortens) a segment by moving a vertex along the segment joining the 
vertex to its neighbouring vertex. The height of the vertex is not modified.

On selecting Extend point, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Most vertices are on two segments so it is necessary to indicate which segment is to be extended, 
This is done by selecting not the vertex, but by selecting on the segment that is to be extended, 
close to the vertex to be moved.

STEP 2:

As the cursor is moved, the string is redrawn reflecting the changing position of the moved 
vertex. The final position of the vertex is selected and accepted. Alternatively, the user can type 
in the final coordinate of the moved vertex into the Enter XYZ box. This box is brought up by 
simply typing a value or by pressing the space bar. 

pick here to
extend this
segment by
moving the
closest vertex

height of the vertex
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STEP 3:

The selected vertex is moved to the new position. The height of the vertex is not changed.

Extend Segment and Extrapolating Heights
Cad_Extend_Point_on_Super_String__ht_

Position of option on menu: Strings =>CAD =>Change points =>Extend point (ht)

or by selection of appropriate icon from the toolbar. 

This option extends (or shortens) a segment by moving a vertex along the segment joining the 
vertex to its neighbouring vertex. The height of the vertex is extrapolated.

On selecting Extend point (ht), the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Most vertices are on two segments so it is necessary to indicate which segment is to be extended, 
This is done by selecting not the vertex, but by selecting on the segment that is to be extended, 
close to the vertex to be moved.

the vertex height
is unchanged
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STEP 2:

As the cursor is moved, the string is redrawn reflecting the changing position of the moved 
vertex. The final position of the vertex is selected and accepted. Alternatively, the user can type 
in the final coordinate of the moved vertex into the Enter XYZ box. This box is brought up by 
simply typing a value or by pressing the space bar. 

The point selected is moved to the cursor position in a rubber banding fashion. The final position 
of the point is selected and accepted. Alternatively, the user can enter the final coordinate value 
of the moved point by the enter XYZ box. This box can be brought into view by simply typing a 
value or by pressing the space bar. 

STEP 3:

The selected vertex is moved to the new position. The height of the vertex has been extrapolated 
from the heights at either end of the original segment.

pick here to
extend this
segment by
moving the
closest vertex

height of the vertex
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Extend Segment by Length and Keeping Height
Cad_Extend_Point_by_Length

Position of option on menu: Strings =>CAD =>Change points =>Extend point by length

or by selection of appropriate icon from the toolbar. 

This option extends (or shortens) a segment by moving a vertex along the segment joining the 
vertex to its neighbouring vertex by a user defined distance. The height of the vertex is not 
modified.

On selecting Extend point by length, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Most vertices are on two segments so it is necessary to indicate which segment is to be extended, 
This is done by selecting not the vertex, but by selecting on the segment that is to be extended, 
close to the vertex to be moved.

STEP 2:

The user enters the distance to extend the segment. This value is positive in the direction that the 
string was created. 

the vertex height
has been extrapolated
from the height at
the ends of the original
segment (3 and 1) 

pick here to
extend this
segment by
moving the
closest vertex

height of the vertex

by a distance
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STEP 3:

The point selected is moved to the new position and the string topology maintained.

Extend Segment by Length and Extrapolating Heights
Cad_Extend_Point_by_Length__ht_

Position of option on menu: Strings =>CAD =>Change points =>Extend point by length (ht)

or by selection of appropriate icon from the toolbar. 

This option extends (or shortens) a segment by moving a vertex along the segment joining the 
vertex to its neighbouring vertex by a user defined distance. The height of the vertex is 
extrapolated modified.

On selecting Extend point by length (ht), the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Most vertices are on two segments so it is necessary to indicate which segment is to be extended, 
This is done by selecting not the vertex, but by selecting on the segment that is to be extended, 
close to the vertex to be moved.

the vertex height
is unchanged
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STEP 2:

The user enters the length value for which the point is to be extended by. This value is positive in 
the direction that the string was created. 

STEP 3:

The point selected is moved to the new position and the height adjusted according to the grade 
of the extended segment.

Append a Vertex
Cad_Append

pick here to
extend this
segment by
moving the
closest vertex

height of the vertex

by a distance

the vertex height
has been extrapolated
from the height at
the ends of the original
segment (3 and 1) 
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Position of option on menu: Strings =>CAD =>Change Points =>Point append

or by selection of appropriate icon from the toolbar. 

This option adds vertices to an existing super string.

On selecting Point append, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select a string by picking near the end of the string that vertices are to be added to (added to the 
beginning of the string - prepend, or added to the end of the string - append).

STEP 2:

After the string is accepted, a line is drawn from the end of the string to the current cursor 
position.

Select the position for the new vertex.

STEP 3:

After the new vertex is accepted, a line is drawn from that vertex to the current cursor position. 
That is, the process of adding points is repeated.

 

STEP 4:

This step should be repeated until the required number of vertices has been added.



12d Model Reference Manual

Page 832 May 2007CAD

STEP 5:

STEP 6:

After the required number of vertices have been added, the option is terminated for this string 
by pressing the <Esc> key.

New Vertex on a Segment (Between Two Vertices)
Cad_Between

Position of option on menu: Strings =>CAD =>Change Points =>Point between

or by selection of appropriate icon from the toolbar. 

This option adds a vertex to a string but it is constrained to be on an existing segment of the 
string. The height of the vertex is interpolated from the heights at the end of the segment.

On selecting Point between, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the string on the segment of the string that is to have a vertex added to it. The new vertex 
will be constrained to be on the segment.

STEP 2:

After the segment is accepted, a perpendicular line is drawn from the selected segment of the 
string to the position of the cursor. 
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STEP 3:

A position is selected with the mouse or typed in via the keyboard and the new vertex is created 
by dropping the position perpendicularly onto the segment.

Note - to enter via the keyboard, simply start typing or press the space bar to bring up the Enter 
XYZ Input box. Type the coordinates into the XYZ Input box and press the enter key.

Insert a Vertex
Cad_Insert

Position of option on menu: Strings =>CAD =>Change Points =>Point insert

or by selection of appropriate icon from the toolbar. 

This option inserts a vertex into to a string between two adjacent vertices but it is constrained to 
be on the existing segment joining the vertices. The height of the vertex is taken from the final 
selected position.

On selecting Point insert, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select the string on the segment of the string that is to have a vertex added to it. The new vertex 
is not constrained to be on the segment.

STEP 2:

After a string is accepted, two lines will be drawn from the cursor position to either end of the 
selected segment.
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STEP 3:

A final position is selected with the mouse or typed in via the keyboard and the new vertex is 
created at the final position.

Once the new vertex is created the original segment is no longer drawn.

Note - to enter via the keyboard, simply start typing or press the space bar to bring up the Enter 
XYZ Input box. Type the coordinates into the XYZ Input box and press the enter key.

Change Height of a Vertex
Cad_Height

Position of option on menu: Strings =>CAD =>Change Points =>Point height

or by selection of appropriate icon from the toolbar. 

This option changes the height (z value) of a vertex.

On selecting Point height, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:
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STEP 2:

Select a vertex with either the mouse or via the keyboard. 

Note - to enter via the keyboard, simply start typing or press the space bar to bring up the Enter 
XYZ Input box. Type the coordinates into the Enter XYZ Input box and press the enter key.

STEP 3:

After a point is accepted, the Height input box will appear with the current height displayed in it. 

Type the new height (z value) of the vertex into the Height input box and press the enter key. The 
browse button  on the Input box can also be used to define the point’s height.

STEP 4:

The height (z value) of selected point will have changed to the new value.

 If z values have been turned on, the new value will be displayed in the view.

To see the effects of this option, use the Toggle menu to 
toggle on Z values. The height of each vertex (z value) is 
then displayed on the plan view so any modification to 
the height will be visible.
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Point Id
Cad_Point_ID

Position of option on menu: Strings =>CAD =>Change Points =>Point id

or by selection of appropriate icon from the toolbar. 

This option changes the point id of the vertex of a super string.

On selecting Point id, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

STEP 2:

Select a vertex with either the mouse or via the keyboard. 

Note - to enter via the keyboard, simply start typing or press the space bar to bring up the Enter 
XYZ Input box. Type the coordinates into the Enter XYZ Input box and press the enter key.

To see the effects of this option, use the Toggle menu to toggle on 
Point id’s. The Point id of each vertex is then displayed on the 
plan view so any modification to the point id will be visible.
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STEP 3:

After the vertex is accepted, the Point id input box will appear. Type the point id into the input 
box and press the enter key.

STEP 4:

The point id of selected vertex is changed to the new value. If Point id’s have been turned on, the 
new value will be displayed in the view.

CAD Segment Edits
cad_segment_edits

Position of option on menu: Strings =>CAD =>Change segments

The Change segments walk-right menu is
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For the option Segment colour, go to the section “Segment Colour” 
Segment radius “Segment Radius” 
Insert 3pt curve “Insert 3pt Curve” 
Remove 3pt curve “Remove 3pt Curve” 

Segment Colour
Cad_Segment_Colour

Position of option on menu: Strings =>CAD =>Change segments =>Segment colour

or by selection of appropriate icon from the toolbar. 
This option changes the colour of a selected segment.

On selecting Segment colour, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.
STEP 1:

Select the segment of the super string that is to have a colour change.

STEP 2:

After the segment is accepted, the Colour Input box will appear. Type the desired colour into the 
Input box and press the enter key. Alternatively you can select a colour from a list by clicking the 
browse button  on the Input box.

STEP 3:

The colour of the selected segment is drawn in the new colour.
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Segment Radius
Cad_Segment_Radius

Position of option on menu: Strings =>CAD =>Change segments =>Segment radius

or by selection of appropriate icon from the toolbar. 
This option changes the radius of a segment.

On selecting Segment radius, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.
STEP 1:

Select the segment of the super string that is to have a change of radius.

STEP 2:

After the segment is accepted, the Radius box will appear. Type the desired radius into the Input 
box and press the enter key. The browse button  on the Input box can be used to define the 
radius by measuring existing elements.

STEP 3:

The selected segment is then drawn with the new radius.
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Insert 3pt Curve
Cad_Insert_3pt_Curve

Position of option on menu: Strings =>CAD =>Change segments =>Insert 3pt curve

or by selection of appropriate icon from the toolbar. 
This option allows the creation of a 3 point curve using 2 existing segments.

On selecting Insert 3pt curve, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select a vertex of a super string a vertex with a segment on either side, or segment of a super 
string.

If a vertex is selected, that vertex will be the middle vertex of the constructed 3 point curve. If a 
segment is selected, the closest vertex will become the middle vertex of the 3 point curve.

STEP 2:

After the vertex or segment is selected and accepted, an arc is through the three vertices is 
calculated and its radius used for the tow segments on either side of the vertex.
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Remove 3pt Curve
Cad_Remove_3pt_Curve

Position of option on menu: Strings =>CAD =>Change segments =>Remove 3pt curve

or by selection of appropriate icon from the toolbar. 
This option removes the arcs from either side of a selected vertex. If a segment is selected, the 
closest vertex is used and the arcs removed from either side of the vertex, 

On selecting Remove 3pt curve, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Select a vertex of a super string with arcs on one or two sides of the vertex.

STEP 2:

After the vertex is selected and accepted, arc on either side will removed (the radius is set to 
zero). Two line segments are then drawn.
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CAD Edit Strings
cad_string_edits

Position of option on menu: Strings =>CAD =>Change strings

These option are currently under development.

The Change strings walk-right menu is

Menu of Options to Edit Strings

close a string
open a string
reverse the direction of a string
copy a string
parallel a string
extend a string until it cuts a selected string
trim a string back to a selected string
extend a string by a typed chainage distance
clip a string
delete a segment from string
split a string
join two strings
join many strings
fillet and join
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For the option Close, go to the section “Close String” 
Open “Open String” 
Reverse “Reverse a String” 
Copy “Copy a String” 
Parallel “Parallel a String” 
Extend “Extend a String” 
Trim “Trim a String” 
Extend by chainage length “Extend String by Chainage Length” 
Clip “Clip String” 
Clip internal “Delete an Internal Section of a String” 
Link clip “Delete a Segment” 
Split “Split String” 
Join “Join String” 
Join many “Join String Many” 
Join fillet “Join Fillet” 
Cad cross split “Split Crossing Strings” 

Close String
Cad_String_Close

Position of option on menu: Strings =>CAD =>Change strings =>Close

or by selection of appropriate icon from the toolbar. 

This option closes an open string.

On selecting Close, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

An open string is selected and accepted.
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STEP 2:

The string is closed

After closing of a string, the option restarts so that another string can be selected. Picking Cancel 
from the Pick Ops menu, hitting <esc> or selecting another option terminates the option.

Open String
Cad_String_Open

Position of option on menu: Strings =>CAD =>Change strings =>Open

or by selection of appropriate icon from the toolbar. 

This option opens a closed string.

On selecting Open, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

A closed string is selected and accepted.

STEP 2:
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The string is opened by deleting the last segment of the closed string.

Note - this may not be where the string was selected.

After opening of a string, the option restarts so that another string can be selected. Picking 
Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the option.

Reverse a String
Cad_String_Reverse

Position of option on menu: Strings =>CAD =>Change strings =>Reverse

or by selection of appropriate icon from the toolbar. 

This option reverses the direction of a string

On selecting Reverse, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

A string is selected and accepted.

STEP 2:

The string is reversed.
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After reversing of a string, the option restarts so that another string can be selected. Picking 
Cancel from the Pick Ops menu, hitting <esc> or selecting another option terminates the option.

Copy a String
Cad_String_Copy

Position of option on menu: Strings =>CAD =>Change strings =>Copy

or by selection of appropriate icon from the toolbar. 

This option copies a string. The copied strings takes its attributes from the Cad Control Bar.

Copy is particularly helpful in backing up strings.

On selecting Copy, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

A string is selected and accepted. The copied string will take on the values in the control bar at 
the time of accepting.
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STEP 2:

A copy of the original string will be saved into the model bu hse string.

Parallel a String
Cad_String_Parallel

Position of option on menu: Strings =>CAD =>Change strings =>Parallel

or by selection of appropriate icon from the toolbar. 

This option parallel a string by a given to a selected string.

Note that if there are arcs in the string, the string can not be paralleled by a distance that would 
collapse the arcs.

On selecting Parallel, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The string to parallel is picked with direction. The direction determines what it means to parallel 
to the right or left of the string.

STEP 2:

The parallel option can be applied to all of the selected string or only part of the string.

After the string is selected, a panel is displayed asking if only part of the string is to be 
parallelled.

If only part of the string is to be paralleled (i.e. yes selected) the user picks the start and end 
positions of where the string is to be paralleled. This does not necessarily have to be at the end of 
the segments as the user can select a position anywhere on the segment to define these values. If 
the whole string is to be paralleled the user should select no.

pick with
direction
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STEP 3:

The user is prompted for the parallel distance. Positive distance is to the right of the selected 
string. Negative to the left.

STEP 4:

The user is prompted for the offset height. This height value will be added to the selected string 
values to produce the heights for the parallelled string.

STEP 5:

The paralleled string is then generated using the supplied information.
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Extend a String
Cad_String_Extend

Position of option on menu: Strings =>CAD =>Change strings =>Extend

or by selection of appropriate icon from the toolbar. 

This option extends a string to a another nominated string.

On selecting Extend, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The string to extend to is selected and accepted.

STEP 2:

The string to extend to selected and accepted
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STEP 3:

The string is extended.

Trim a String
Cad_String_Trim

Position of option on menu: Strings =>CAD =>Change strings =>Trim

or by selection of appropriate icon from the toolbar. 

This option trims a string to another nominated cutting string.

On selecting Trim, the user is prompted for the relevant data in the screen message box located at 
the bottom left hand corner of the 12d Model application window.

STEP 1:

The cutting string which will be used to define the trim extent is selected and accepted.
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STEP 2:

The string to trim is selected. The position of the pick relative to the cutting string will dictate 
which part of the string will be trimmed. In this case, the selection is above the cutting string and 
so the trim will be of the top part of the string.

STEP 3:

The string is trimmed.
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Extend String by Chainage Length
Cad_String_Extend_by_Chainage_Length

Position of option on menu: Strings =>CAD =>Change strings =>Extend by chainage length

or by selection of appropriate icon from the toolbar. 

This option extends a string by a given chainage value.

On selecting Extend by chainage length, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The string to extend is selected and accepted.

STEP 2:

The chainage length to extend the string is entered into the Length input Box. Positive is in the 
direction of the string. Negative in the opposite direction of the string.

STEP 3:

The string is extended by the given chainage amount.
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Clip String
Cad_String_Clip

Position of option on menu: Strings =>CAD =>Change strings =>Clip

or by selection of appropriate icon from the toolbar. 

This option deletes part of a string.

On selecting Clip, the user is prompted for the relevant data in the screen message box located at 
the bottom left hand corner of the 12d Model application window.

STEP 1:

The string to be clipped is selected and accepted.

STEP 2:

STEP 3:

The string is clipped.

The first and second 
positions defining what part 
of the string is to remain are 
selected and accepted. 

The positions do not have to 
be at vertices but can be 
anywhere on segments



12d Model Reference Manual

Page 854 May 2007CAD

Delete an Internal Section of a String
Cad_String_Clip_Internal

Position of option on menu: Strings =>CAD =>Change strings =>Clip internal

or by selection of appropriate icon from the toolbar. 

This option deletes an internal part of a string and leaves the two end sections.

On selecting Clip internal, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The string to be clipped is selected and accepted.

STEP 2:

The first and second position defining what part of the string is to remain is selected and 
accepted. This does not necessarily have to be at the end of the segments as the user can select a 
position anywhere on the segment to define these values.
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STEP 3:

The part of the string between the two selected clip points is deleted leaving two strings.

Delete a Segment
Cad_String_Link_Clip

Position of option on menu: Strings =>CAD =>Change strings =>Link clip

or by selection of appropriate icon from the toolbar. 

This option deletes a segment from a string.

On selecting Link clip, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The segment to be deleted is selected and accepted.

The first and second positions 
defining what part of the string 
is to be deleted are selected and 
accepted. 

The positions do not have to be 
at vertices but can be anywhere 
on the segments

first clip point

second clip point
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STEP 2:

The selected segment is deleted.

Note - unless the selected string was a closed string, two strings are produced.

Split String
Cad_String_Split

Position of option on menu: Strings =>CAD =>Change strings =>Split

or by selection of appropriate icon from the toolbar. 

This option splits one string into two strings at a given split position.

On selecting Split, the user is prompted for the relevant data in the screen message box located at 
the bottom left hand corner of the 12d Model application window.

STEP 1:

The string to be split is selected and accepted.
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STEP 2:

The split position is selected and accepted.

STEP 3:

The split is made at the position selected. If no vertex exists at that position, a vertex is created.

Join String
Cad_String_Join
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Position of option on menu: Strings =>CAD =>Change strings =>Join

or by selection of appropriate icon from the toolbar. 

This option joins two super strings together at their end points.

There are four possible ways of joining the strings and the required case is determined by 
picking the strings with direction.

On selecting the Join option, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 2:

Select and accept another super string with direction.

STEP 3:

The head of the first string (as determined by the picking direction) is then joined to the tail of 
the second string (as determined by the picking direction). 

After the strings are joined, the vertex indices will change since the order of the vertices in the 
string is now different.

The colour of the constructed line is adopted from first selected super string. The colour of the 
second string will remain unchanged.

Note: The constructed line and selected strings are stored in the model of the first selected string.

STEP 1:

Select and accept a super string with direction.

For notes on picking strings with direction, see ’Picking 
with Direction’ in Chapter 3 - Tools and Concepts on page 
77.

Note: Vertex indices can be displayed by toggling the option 
on the Toggle Menu.

pick with
direction

pick with
direction
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Join String Many
Cad_String_Join_Many

Position of option on menu: Strings =>CAD =>Change strings =>Join many

or by selection of appropriate icon from the toolbar. 

This option joins many strings together. Picking with direction is used to specify which ends of 
the strings are joined.

On selecting the Join many option, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.

STEP 2:

Select and accept another super string, again picking with direction.

STEP 3:

STEP 1:

Pick a super string with direction.

For notes on picking strings with direction, see ’Picking 
with Direction’ in Chapter 3 - Tools and Concepts on page 
77.

Note: The Vertex indices can be displayed by toggling the 
option on the Toggle Menu.

pick with
direction

pick with
direction
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The head of the first string is then joined to the tail of the second string. What is the head or tail 
of the strings is determined by the picking direction.

After the strings are joined, the vertex indices to reflect the new order of the vertices in the string. 
The colour of the constructed segment will be the same as that of the first selected super string. 
The colour of the second string will remain unchanged.

Note: The constructed segment and selected strings are stored in the model which contains the 
1st selected string.

STEP 4:

The Join Many option joins extra strings to the already selected (and joined) strings. The user may 
continue selecting additional strings to join together by select and accept additional super strings 
by picking with direction.

This option can be terminated by the user with the Esc key.

Note: Each further construction line adopts the same colour as the 1st selected string. Both the 
constructed line and selected strings are stored in the model which contains the first selected 
string.

Join Fillet
Cad_Join_Fillet

Position of option on menu: Strings =>CAD =>Change strings =>Join fillet

or by selection of appropriate icon from the toolbar. 

This option fillets, trims and joins strings.

There are eight possible ways of filleting the strings and the required case is determined by 
picking the strings with direction and by the sign of the radius.

On selecting the Join strings option, the user is prompted for the relevant data in the screen 
message box located at the bottom left hand corner of the 12d Model application window.
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STEP 2:

Select and accept another super string, again picking with direction.

STEP 3:

After the second super string is accepted, the Radius input box will appear. Type the fillet radius 
into the input box and press the enter key. The browse button  on the input box can be used 
to define the fillet radius by measurement of existing elements.

Note: A positive fillet radius value will curve to the right, where as a negative fillet radius will 
curve to the left.

A fillet arc with the radius is constructed and joined to the two strings and the ends of the two 
strings are automatically trimmed back to the arc. 

STEP 1:

Pick a super string with direction.

For notes on picking strings with direction, see ’Picking 
with Direction’ in Chapter 3 - Tools and Concepts on page 
77.

Note: The Vertex indices can be displayed by toggling the 
option on the Toggle Menu.

pick with
direction

pick with
direction
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The vertex indices will change to accommodate the new vertices in the string. The colour of the 
constructed line and 2nd selected string adopts the colour of the 1st selected super string.

Note: The constructed arc and selected strings are stored in the model of the first selected string.

Split Crossing Strings
Cad_String_Cross_Split

Position of option on menu: Strings =>CAD =>Change strings =>Cad cross split 

or by selection of appropriate icon from the toolbar. 

This option splits two crossing strings at the position of their crossing.

On selecting Cad cross split, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

Pick the first string.

STEP 2:

Pick the second string.

STEP 3:

The two strings are then split where the strings crossed. This will create four strings.
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added

four
strings
created

vertex
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CAD Delete
cad_delete

Position of option on menu: Strings =>CAD =>Delete

The Delete walk-right menu is

For the option Points, please go to the section.“Delete Vertices” .
Segments  “Delete Segments” .
Strings  “Delete String” .

Delete Vertices
Cad_Vertex_Delete

Position of option on menu: Strings =>CAD =>Delete =>Points

or by selection of appropriate icon from the toolbar. 

This option deletes vertices of super strings.

On selecting Points, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The vertex to be deleted is selected and accepted (This must be a super string).

STEP 2:

The vertex point is deleted and the string redrawn.

Menu of Options to Delete Vertices, Segments and Strings

delete a vertex
delete a segment
delete a string
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Delete Segments
Cad_Segment_Delete

Position of option on menu: Strings =>CAD =>Delete =>Segments

or by selection of appropriate icon from the toolbar. 

This option deletes segments of super strings.

On selecting Segments, the user is prompted for the relevant data in the screen message box 
located at the bottom left hand corner of the 12d Model application window.

STEP 1:

The segment to be deleted is selected and accepted. 

STEP 2:

The segment is deleted leaving two separate strings in this case.

Delete String
Cad_String_Delete

Position of option on menu: Strings =>CAD =>Delete =>Strings

or by selection of appropriate icon from the toolbar. 

This option deletes selected strings. The string type does not specifically have to be a super 
string.

On selecting Strings, the user is prompted for the relevant data in the screen message box located 
at the bottom left hand corner of the 12d Model application window.

STEP 1:

The string to be deleted is selected and accepted.
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STEP 2:

The string is deleted.

Delete Selection of Strings
Position of option on menu: Strings =>CAD =>Delete =>Selection

or by selection of appropriate icon from the toolbar. 

This option allows the deleting of selected objects specified in a source box. For help on this 
option see “Delete” .

On selecting the Delete option, the user is prompted for the relevant data in the screen message 
box located at the bottom left hand corner of the 12d Model application window.
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Create
string_create

Position of option on menu: Strings =>Create

The Create option is used to produce new strings. If a string already exists, the Editor option is 
used to modify it.

The Create walk-right menu contains options to create 2d, 3d, 4d, alignment, super alignment, 
circles, arcs, feature, pipe, polyline, super and text strings.

Each string type has its own special information so by choosing the appropriate type to be 
created, only information needed for that type of string is asked for.

Once a string has been created, it can be converted to most of the other string types using the 
string Convert option.

To create a new string of the same type and with similar header information as an existing string, 
the same as option is selected from the String Create menu.

Notes

1. Depending on its breakline (point-line) type, a string with default style ("1") is displayed with 
crosses at each of its vertex (point type) or with straight lines joining the vertices (line type).

Linestyles can be defined that drawn lines between the points even though the breakline type 
is point.

2. The string vertices are also called intersection points (IP’s).

The String Create walk-right menu is

The string creation process is similar for each string type and for editing strings as well.
For Create 2d go to “Create - 2d Super” 

3d  “Create - 3d Super” 
4d  “Create - 4d Super” 
Alignment  “Alignments” 
Super alignment  “Super Alignments” 
Arcs  “Create Arcs” 
Circles  “Create - Circles” 
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Feature  “Create - Feature” 
 Pipe  “Create - Pipe” 
Polyline  “Create - Polyline” 
Super  “Create - Super” 
Text  “Create - Text” 
Control stations  “Create - Control Stations” 
Old  “Old” 
Same as  “Create - Same As” 
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Create - 2d Super
create_super_2d_string

Position of option on menu: Strings =>Create =>2d

A 2d string consists of a series of (x,y) vertices all with the same z-value (height). 2d strings are 
often referred to as “contour strings” because contours are the most common example of a string 
with a constant height.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create 2d 
Super String panel is placed on the screen with the same information in it as the string just 
created. If any of the information needs to be modified for the new string, simply change it in the 
Create 2d Super String panel fields before selecting the Create button for the new string. Hence a 
new string of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create 2d Super String panel.

From 12d Model 8 onwards, the default is to create 2d super strings rather than the 2d strings 
used up to 12d Model 7. A 2d super string is a super string with Constant height. That is, there is 
only one z-value for the entire string. The advantage is using a 2d super string is that all the CAD 
options will work for it, vertices and segments can be assigned tinability and it can have point 
id’s for setout. 

The older 2d string create options are still available under

Strings =>Create =>Old

On selecting 2d string, the Create Super 2d String panel is displayed.

The default values for the panel fields are taken from the CAD Controlbar (see “CAD, Symbol 
and Text Controlbars” )

To create a new 2d super string (a 2d super string is a super string with the constant height flag 
set on), the panel fields are filled in and the Create button selected.

The fields and buttons used in the Create 2d Super String panel have the following functions.
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Field Description Type Defaults Pop-Up

Name input from CAD controlbar

the name of the new string

Model model box from CAD controlbar available models

name of the model that the new string is in

Colour colour box from CAD controlbar available colours

the colour of the new string

Type choice box line line, point

breakline type (point-line type) of the string

Linestyle input from CAD controlbar available line styles

line style of the string

Weight input from CAD controlbar

thickness of the string

Height input from CAD controlbar

for a 2d super string, there is only one height (z-value) for the entire string.

Tinability choice box Points and segments Points and segments
Points only
Not tinable

if Vertices and segments, all the vertices and segments of the string are set to tinable.
If Vertices only, all the vertices are set to tinable and the segments to not tinable.
If Not tinable, all the vertices or segments are set to not tinable.

Allow point ids tick box

if tick, the 2d super string can have point ids for each vertex.
If not tick, the 2d super string will not have point ids. This can be reversed if point ids are required in 
the future.

Many strings tick box

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the Create button is chosen, the Edit 2d menu is displayed.

Same as button

After the Same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Finish button

end the option, don’t proceed to the edit stage.

Edit 2d Super
On selecting the Create button in the Create 2d Super String panel the Edit 2d menu is placed on 
the screen. The Edit 2d menu for a 2d super string is
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 To create a new 2d super string, select the Append icon.

The Append option is used to add vertices to either end of an existing string, or in the case of a 
new string, places the first vertex and then begins appending vertices to the first vertex.

For all 2d strings, a cross is then drawn in each plan view that the string’s model is on, and the 
cross follows the cursor around the screen. If the string’s model is not added to any plan view, 
the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the first vertex of the string (using the appropriate snaps).

The string is then drawn from the first vertex to the cursor position, which represents the second 
vertex of the string. Clicking LB and accepting with MB selects the second string vertex and the 
process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s Edit 2d menu are usable.

The options in the Edit 2d menu are not only used for placing the initial vertices of the string, but 
for editing the string once it is created. Since the Append and other options in the Edit 2d menu 
are identical to the options used when editing an existing string, they will be discussed in detail 
in the string Editor section.

For full information in the 2d Editor, go to the section 

Create - 3d Super
create_super_3d_string

Position of option on menu: Strings =>Create =>3d

A 3d string consists of a series of (x,y,z) vertices. 

The difference between a 2d and a 3d string is that for a 3d string, the z-value (height) can vary at 
each string vertex, whereas a 2d string has a constant height for the entire string. Hence a 2d 
string is simply a special case of a 3d string where the heights at all the vertices are the same.

Creating and editing a 3d string is very similar to a 2d string. The only major difference is that a 
height is required at each string point.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create 3d 
Super String panel is placed on the screen with the same information in it as the string just 
created. If any of the information needs to be modified for the new string, simply change it in the 
Create 3d Super String panel fields before selecting the Create button for the new string. Hence a 
new string of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 

append or prepend an IP

delete an IP

move an IP
insert an IP
insert IP on line joining IP’s
extend an IP
modify the string's z-value
open a closed string
close a string
bring up Properties panel
toggle edit info panel
undo/redo
quit the create
finish the 2d create

model ->string_name for the
2d super string being edited
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Create 3d Super String panel.

From 12d Model 8 onwards, the default is to create 3d super strings rather than the 3d strings 
used up to 12d Model 7. The advantage is using a 3d super string is that all the CAD options will 
work for it, vertices and segments can be assigned tinability and it can have point id’s for setout. 

The older 3d string create option is still available under

Strings =>Create =>Old

On selecting the 3d string option, the Create 3d Super String panel is displayed.

The default values for the panel fields are taken from the CAD Controlbar (see “CAD, Symbol 
and Text Controlbars” )

To create a new 3d super string, the panel fields are filled in and the Create button selected.

The fields and buttons used in the Create 3d Super String panel have the following functions.

Field Description Type Defaults Pop-Up

Name input from CAD controlbar

the name of the new string

Model model box from CAD controlbar available models

name of the model that the new string is in

Colour colour box from CAD controlbar available colours

the colour of the new string

Type choice box line line, point

breakline type (point-line type) of the string

Linestyle input from CAD controlbar available line styles

line style of the string

Weight input from CAD controlbar

thickness of the string

Tinability choice box Points and segments Points and segments
Points only
Not tinable

if Vertices and segments, all the vertices and segments of the string are set to tinable.
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If Vertices only, all the vertices are set to tinable and the segments to not tinable.
If Not tinable, all the vertices or segments are set to not tinable.

Allow point ids tick box

if tick, the super string can have point ids for each vertex.
If not tick, the super string will not have point ids. This can be reversed if point ids are required in the 
future.

Many strings tick box

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

after the Create button is chosen, the Edit 3d menu is displayed

Same as button

after the Same as button is chosen, another string is selected and information about it is used for the 
fields in this panel

Finish button

end the option, don’t proceed to the edit stage

Edit 3d Super
On selecting the Create button in the Create 3d Super String panel the Edit 3d menu is placed on 
the screen. The Edit 3d menu for a 3d super string is

 To create a new 3d super string, select the Append icon.

The Append option is used to add vertices to either end of an existing string, or in the case of a 
new string, places the first vertex and then begins appending vertices to the first vertex.

For all 3d strings, a cross is then drawn in each plan view that the string’s model is on, and the 
cross follows the cursor around the screen. If the string’s model is not added to any plan view, 
the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the first vertex of the string (using the appropriate snaps).

The string is then drawn from the first vertex to the cursor position, which represents the second 
vertex of the string. Clicking LB and accepting with MB selects the second string vertex and the 
process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s Edit 3d menu are usable.

The options in the Edit 3d menu are not only used for placing the initial vertices of the string, but 

append or prepend an IP

delete an IP

move an IP
insert an IP
insert IP on line joining IP’s
extend an IP
modify the string's z-value
open a closed string
close a string
bring up Properties panel
toggle edit info panel
undo/redo
quit the create
finish the 2d create

model ->string_name for the
3d super string being edited
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for editing the string once it is created. Since the Append and other options in the Edit 3d menu 
are identical to the options used when editing an existing string, they will be discussed in detail 
in the string Editor section.

For full information in the 3d Editor, go to the section 

Create - 4d Super
create_super_4d_string

Position of option on menu: Strings =>Create =>3d

A 4d string consists of a series of (x,y,z) points and a text label at each point. 

Creating and editing a 4d string is very similar to a 3d string.- the major difference is that a 
height and a text label is required at each string point.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create 4d 
Super String panel is placed on the screen with the same information in it as the string just 
created. If any of the information needs to be modified for the new string, simply change it in the 
Create 4d Super String panel fields before selecting the Create button for the new string. Hence a 
new string of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create 4d Super String panel.

From 12d Model 8 onwards, the default is to create 4d super strings rather than the 4d strings 
used up to 12d Model 7. The advantage is using a 4d super string is that all the CAD options will 
work for it, vertices and segments can be assigned tinability and it can have point id’s for setout. 

The older 4d string create option is still available under

Strings =>Create =>Old

On selecting the 4d string option, the Create 4d Super String panel is displayed.

The default values for the panel fields are taken from the CAD Controlbar (see “CAD, Symbol 
and Text Controlbars” )

To create a new 4d super string, the panel fields are filled in and the Create button selected.
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The fields and buttons used in the Create 4d Super String panel have the following functions.

Field Description Type Defaults Pop-Up

Name input from CAD controlbar

the name of the new string

Model model box from CAD controlbar available models

name of the model that the new string is in

Colour colour box from CAD controlbar available colours

the colour of the new string

Type choice box line line, point

breakline type (point-line type) of the string

Linestyle linestyle box from CAD controlbar available line styles

line style of the string

Weight input from CAD controlbar

thickness of the string

Text style textstyle box

textstyle to use for text

Tinability choice box Points and segments Points and segments
Points only
Not tinable

if Vertices and segments, all the vertices and segments of the string are set to tinable.
If Vertices only, all the vertices are set to tinable and the segments to not tinable.
If Not tinable, all the vertices or segments are set to not tinable.

Allow point ids tick box

if tick, the super string can have point ids for each vertex.
If not tick, the super string will not have point ids. This can be reversed if point ids are required in the 
future.

Many strings tick box

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

after the Create button is chosen, the Edit 4d menu is displayed

Same as button

after the Same as button is chosen, another string is selected and information about it is used for the 
fields in this panel

Finish button

end the option, don’t proceed to the edit stage

Edit 4d Super
On selecting the Create button in the Create 4d Super String panel the Edit 4d menu is placed on 
the screen. The Edit 4d menu for a 4d super string is
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To create a new 4d super string, select the Append or Append + Text icon.

The Append and or Append + Text option are used to add vertices to either end of an existing 
string, or in the case of a new string, places the first vertex and then begins appending vertices to 
the first vertex. Append + Text also asks for text at each vertex.

For all 4d strings, a cross is then drawn in each plan view that the string’s model is on, and the 
cross follows the cursor around the screen. If the string’s model is not added to any plan view, 
the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the first vertex of the string (using the appropriate snaps).

If Append + text was selected, the user will then be prompted for the text to be placed at that 
vertex.

The string is then drawn from the first vertex to the cursor position, which represents the second 
vertex of the string. Clicking LB and accepting with MB selects the second string vertex and the 
process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s Edit 4d menu are usable.

The options in the Edit 4d menu are not only used for placing the initial vertices of the string, but 
for editing the string once it is created. Since the Append and other options in the Edit 4d menu 
are identical to the options used when editing an existing string, they will be discussed in detail 
in the string Editor section.

For full information in the 4d Editor, go to the section 

Alignments
alignments

Position of menu: Strings =>Create =>Alignment

The alignment walk-right menu contains options to create an alignment string, plus quick 
methods of creating an alignment string with horizontal geometry already created for culdesacs, 
circles and fillets.

append or prepend an IP

append or prepend an IP plus text

delete an IP

move an IP
insert an IP
insert IP on line joining IP’s
extend an IP
modify the string's z-value
open a closed string
close a string
bring up Properties panel
toggle edit info panel
undo/redo
quit the create
finish the 2d create

model ->string_name for the
4d super string being edited
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For Alignment go to “Create - Alignment” .
Culdesac “Create - Culdesac” 
3 centre curve “Create - three centre curve” 
Circle “Create - circle” 
Fillet “Create - fillet” 
Traffic island “Create - Traffic Island” 

Create - Alignment
create_alignment_string

Position of option on menu: Strings =>Create =>Alignment =>Alignment

An alignment string is defined by specifying both its horizontal and vertical geometry.

The horizontal geometry consists of a series of (x,y) points (called horizontal intersection points) 
with circular curves and transition spirals applied to the intersection points.

Vertical geometry also consists of a series of points but they are defined with respect to the plan 
length of the string (chainage) and height. Hence, the vertical geometry is defined by a series of 
(chainage,height) points (called vertical intersection points) and either parabolic or circular 
curves applied to the vertical intersection points.

The horizontal geometry is defined in a plan view and the vertical geometry in a section view.

Alignment strings are often referred to as “centre-line strings” because road centre-lines are 
common examples of alignment strings.

Note vertical geometry can only be added to an existing string.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create 
Alignment String panel is placed on the screen with the same information in it as the string just 
created. If any of the information needs to be modified for the new string, simply change it in the 
Create Alignment String panel fields before selecting the Create button for the new string. Hence a 
new string of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create Alignment String panel.

On selecting the alignment string option, the Create Alignment String panel is displayed.

create alignment
create culdesac
create three centred curve
create alignment forming a circle
create alignment fillet
create alignment for traffic island
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To create a new alignment string, the name, model, colour, style and transition spiral type of the 
new string are entered into the appropriate fields and the Create button selected.

The new fields and buttons used in the Create Alignment String panel have the following 
functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

Spiral type input clothoid available spirals

transition spiral type to be used for this alignment string.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the alignment edit menu and alignment edit info panel are 
displayed.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Alignment Edit
Selecting the create button in the create alignment string panel the alignment edit menu and 
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alignment edit info panel are placed on the screen.

The alignment edit menu and alignment edit info panel for an alignment string are

To begin creating an alignment string, the user must select the append=>HIPs option from the 
Alignment Edit menu and start placing points in a plan view.

 To create a new alignment string, select the Append => HIPs option from the Alignment Edit 
menu.

The Append =>HIPs option is used to add horizontal intersection points to either end of an 
existing alignment string, or in the case of a new string, places the 1st point and then begins 
appending points to the 1st point.

For all alignment strings, a cross is then drawn in each plan view that the string’s model is on, 
and the cross follows the cursor around the screen. If the string’s model is not added to any plan 
view, the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the 1st vertex of the string (using the appropriate snaps).

The string is then drawn from the 1st vertex to the cursor position, which represents the second 
vertex of the string. Clicking LB and accepting with MB selects the second string vertex and the 
process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s Alignment Edit menu are usable.

The options in the Alignment Edit menu are not only used for placing the initial vertices of the 
string, but for editing the string once it is created. Since the Append and other options in the 
Alignment edit menu are identical to the options used when editing an existing string, they will 
be discussed in detail in the string Editor section.

For full information in the Alignment Editor, go to the section “Alignment Edit” 
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Create - Culdesac
culdesac_alignment_creation

Position of option on menu: Strings =>Create =>Alignment =>Culdesac

Create an alignment string for a culdesac for user defined road widths, culdesac radius and 
offset. No vertical geometry is defined.

On selecting the Culdesac option, the Culdesac Alignment Creation panel is displayed.

The position of the panel fields indicate what the values are for. Tool tips appear when the cursor 
is passed over the panel.fields.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Offset input box

offset of the centre of the culdesac bulb. Use a negative value if the offset is to the left, positive if the 

radius of the culdesac

right fillet radius

left fillet radius

offset of the bulb
negative to the left,
positive to the right

left and right road widths

distance between the
left fillet and the bulb

right fillet and the bulb
distance between the
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offset is to the right.

Radius input box

radius of the culdesac bulb

Left/Right fillet radii input box

radii for the left and right fillets from the roads to the culdesac bulb.

Left/Right road widths input box

left and right widths of the road.

Name/Model/Colour/Style input box

name/model/colour/style of the created alignment string.

Select string select

select with direction the string to create the culdesac for.

Preview string select

draw the culdesac with the given parameters in the panel draw box.

Process button

create the alignment string

Undo button

undo the last alignment string created whilst the panel has been active.
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Create - three centre curve
3centre_curve_panel

Position of option on menu: Strings =>Create =>Alignment =>3 Centre Curve

Create an alignment string for a three centred curve for user defined parameters and selected 
strings.

On selecting the 3 centre curve option, the 3 centred curve construction panel is displayed.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Name/Model/Colour/Style input box

name/model/colour/style of the created alignment string.

R1 (intermediate) input box

radius of the intermediate curve. If a value is entered and <enter> typed, values for R2, R3, S and S1 
are computed and place in the appropriate fields

R2 (approach) input box

radius of the approach curve.

R3 (departure) input box

radius of the departure curve.

S (offset) input box

approach offset.

S1 (offset) input box

departure offset.
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Kerb line approach string select

select the approach string

Kerb line departure string select

select the departure string

Process button

create the alignment string

Undo button

undo the last alignment string created whilst the panel has been active.



12d Model Reference Manual

Page 884 May 2007Create

Create - circle
circle_align_panel

Position of option on menu: Strings =>Create =>Alignment =>Circle

Create an alignment string for a circle with a for user radius and selected centre or with a 
dynamic mode set, selected centre and interactively positioned circumference.

On selecting the curve option, the circle alignment construction panel is displayed.

The diagram indicates what the panel fields are for. Tool tips appear when the cursor is passed 
over the panel.fields.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Radius input box

the radius of the circle.

Centre pick x,y x,y,z box

if Dynamic in not ticked, select the centre of the circle.
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Name/Model/Colour/Style input box

name/model/colour/style of the created alignment string.

Dynamic tick box

if not tick, then the Centre pick x,y and radius fields are used to define the circle.
if tick, then the Pick button is used to select the centre and then the cursor is taken to be on the circle to 
dynamically define the radius.

Pick button

pick the circle centre when in dynamic mode.

Process button

create the alignment string.

Undo button

undo the last alignment string created whilst the panel has been active.
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Create - fillet
fillet_alignment_construction

Position of option on menu: Strings =>Create =>Alignment =>Fillet

Create an alignment string for a fillet with a for user radius and selected in and out strings.

On selecting the fillet option, the fillet alignment construction panel is displayed.

The diagram indicates what the panel fields are for. Tool tips appear when the cursor is passed 
over the panel.fields.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Select 1 string select

select the approach string. Pick with direction.

Radius input box

the radius of the fillet.

Select 2 string select

select the departure string. Pick with direction.

Name/Model/Colour/Style input box

name/model/colour/style of the created alignment string.

Process button
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create the alignment string.

Undo button

undo the last alignment string created whilst the panel has been active.
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Create - Traffic Island
island_drawbox_panel

Position of option on menu: Strings =>Create =>Alignment =>Traffic Island

Create an alignment string for a traffic island between user selected strings and with user 
defined offsets from the strings and nose radii. No vertical geometry is defined.

On selecting the traffic island option, the traffic island alignment creation panel is displayed.

The position of the panel fields indicate what the values are for. Tool tips appear when the cursor 
is passed over the panel.fields.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Offset from travel lines input box

offset distance from the selected travel lines.

Radius at nose input box

offset from travel line 2
offset from travel line 3
radius at nose

offset from travel line 1
offset from travel line 3
radius at nose

offset from travel line 1
offset from travel line 2
radius at nose
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radius of the corner of the traffic island between the selected travel lines.

Name/Model/Colour/Style input box

name/model/colour/style of the created alignment string.

Select strings select

select in order and with direction, the three strings to use in creating the traffic island. Terminate by 
clicking RB and selecting cancel from the pick ops menu.

Preview string select

draw the traffic island with the given parameters in the panel draw box.

Process button

create the alignment string

Undo button

undo the last alignment string created whilst the panel has been active.
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Super Alignments
super_alignments

Position of menu: Strings =>Create =>Super alignment

The Super Alignment walk-right menu contains options to create an alignment string, plus quick 
methods of creating an alignment string with horizontal geometry already created for culdesacs, 
circles and fillets.

For Super alignment, go to “Create - Super Alignment” 
Super alignment style “Super Alignment Style” 
Design parameters “Define Design Parameters” 
Resolve “Resolve a Super Alignment” 
Deref “Dereference a Super Alignment” 
Parallel “Parallel a Super Alignment” 
Split “Split a Super Alignment” 
Join “Joining Two Super Alignments” 
Fixed/floating to IP’s “Convert Fixed/Floating Elements to IP’s” 
Change style “Change the Styles for Selected Super Alignments” 
Explode labels “Explode the Super Alignments Labelling” 
Move settings “Constrain the Movement of Super Alignment Points” 

create super alignment
create super alignment style
create design parameter file

resolve a super alignment
dereference a super alignment
parallel a super alignment
split a super alignment
join two super alignments
convert fixed/floating to IP’s
change the style for super alignments
explode the labelling to text and lines
setting to lock the movement of IP’s
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Create - Super Alignment
create_super_alignment

Position of option on menu: Strings =>Create =>Alignment =>Super alignment

An super alignment string, like the alignment string, is defined by specifying both its horizontal 
and vertical geometry.

For an alignment string, the alignment consists of only horizontal and vertical intersection points 
with parametrically defined objects consisting of transition spiral-arc-transition spiral for the 
horizontal geometry and parabolas or arcs for vertical geometry. The resultant elements are 
linked tangentially to form the horizontal and vertical geometry. The intersection points can be 
moved and the 

The super alignment includes IP constructions but also allows much more complicated 
parametric design. Elements such as straights and arcs as well as intersection points can be 
defined and then joined by parametrically defined objects (consisting of combinations of 
transition spirals, arcs and straights in the horizontal geometry and parabolas, arcs and straights 
for the vertical geometry) which link tangentially to form the horizontal and vertical geometry.

For both the alignment and super alignment, the horizontal geometry is defined in a plan view 
and the vertical geometry in a section view.

Note: vertical geometry can only be added to an existing super alignment string. That is, to a 
string with some horizontal geometry.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create Super 
Alignment panel is placed on the screen with the same information in it as the string just created. 
If any of the information needs to be modified for the new string, simply change it in the Create 
Super Alignment panel fields before selecting the Create button for the new string. Hence a new 
string of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create Super Alignment panel.

On selecting the Super Alignment option, the Create Super Alignment panel is displayed.
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To create a new super alignment string, the name, model, colour, style and transition spiral type 
of the new string are entered into the appropriate fields and the Create button selected.

The fields and buttons used in the Create Super Alignment panel have the following functions.

Field Description Type Defaults Pop-Up

General tab

Name input from CAD controlbar

the name of the new string

Model input from CAD controlbar available models

name of the model that the new string is in

Colour input from CAD controlbar available colours

the colour of the new string

Linestyle linestyle box from CAD controlbar available line styles

line style of the string

Weight input 0

thickness of the string

Spiral type choice box clothoid available spirals

transition spiral type to be used for this alignment string

Close tick box

if tick, the super alignment is automatically closed.
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Sync vertical geometry tick box

if tick, when the horizontal geometry is modified, an attempt is made to modify the chainage position of 
the vertical geometry so that remains locked to the same parts of the horizontal geometry as before the 
horizontal geometry was modified.
If not tick, after horizontal geometry is modified, the vertical will possibly be moved in relation to the 
horizontal geometry because the (x,y) position for a given chainage will change.

Use chainage equalities tick box

if tick, chainage equalities can be defined and the automatic labelling of the string will use the 
equalities. The use of equalities is still under development.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string

Design tab
the Design tab is only used if a design table has been set up and is to be used for automatically 
inserting curves and transition curves in horizontal, vertical curves in the vertical and super elevation 
and widening.

Use design table tick box

if tick, the given design table is used when creating horizontal and vertical geometry.
If not tick, no design table is used with Alignment speed elements.

Design table *.design files

design table to use when creating horizontal and vertical geometry

Design speed *.design files

the general design speed for the road. This is used with the design table when creating horizontal and 
vertical geometry

Horz speed curve choice box minimum radius
maximum radius

For Alignment speed and Curve speed HIPs.

If minimum radius, when an arc is automatically placed on an HIP using the design table, the arc with 
the smallest radius for the design speed is used.
If maximum radius, when an arc is automatically placed on an HIP using the design table, the arc with 
the largest radius for the design speed is used. 

Vert speed curve choice box minimum kvalue
maximum kvalue

For Alignment speed and Speed VIPs.

If minimum kvalue, when a parabola is automatically placed on an VIP using the design table, the 
parabola with the smallest kvalue for the design speed is used.
If maximum kvalue, when a parabola is automatically placed on an VIP using the design table, the 
parabola with the largest kvalue for the design speed is used. 

Slope type choice box planar
crowned
projected

If planar, then the design table is only applied for half of the road (from the hinge string to the end of 
the fixed template). The side used is given by Highside.

If crowned, then the design table is used for each side of the roads (from the left most fixed template to 
the hinge string, and from the hinge string to the right most fixed template). 

If projected, then the design table is first applied to half of the road given by Highside (from the hinge 
string to the end of the fixed template). Then the grade from the Highside is projected through the 
hinge string and used on the other side of the road. 
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Highside choice box left edge left edge, right edge

used if the Slope type is planar or projected.

Speed lookup choice box ceiling
floor
round up
round down

Radius lookup choice box ceiling
floor
round up
round down
interpolate

For non speed HIP’s only (that is, not Alignment speed or Curve speed HIPs).
The radius has been defined by the user and 

Ease off choice box none
maximum
by length

method of transitioning between minimum and maximum super elevation.
If none, no transition is done.
If maximum, maximum back to back curves are added to the super diagram between the minimum and 
maximum super elevation and are used to transition the super.
If by length, the ease off distance is given by the Ease off length value.

Ease off length input

the length of the ease off for the transition of super elevation when the by length method is selected

Min on reverse input

if the chainage distance between two curves of opposite sign is less than the Minimum on reverse 
value then the two curves are treated as reverse curves when applying the design rules.

end of fixed
template

Planar

end of fixed
template

Crown
hinge hinge

end of fixed
template

Projected
hinge

Section View

Plan View

If this distance is less than
Min on reverse then the two curves
are treated as reverse curves
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Min on broken back input

if the chainage distance between two curves of the same sign is less than the Minimum on broken-
back value then the two curves are treated as broken-back curves when applying the design rules.

Default tab
the Default tab defines the type of HIP’s and VIP’s that are place when laying down horizontal and 
vertical geometry.

HIP type choice box No curve
Alignment speed
Curve speed
Curve length
Curve radius
Curve spiral

The default HIP type given to any placed HIP’s.

If Curve speed, the HIP is also given the speed from the Speed field on the Default tab. 
If Curve length, the HIP is also given the curve length from the Curve length field on the Default tab. 
If Curve radius, the HIP is also given the curve radius from the Curve radius field on the Default tab. 
If Curve spiral, the HIP is also given the curve radius, leading and trailing spiral lengths from the 
Curve radius, Leading spiral length and Trailing spiral length fields on the Default tab. 

Note on HIP types:
if an HIP is of type No curve, no arc is automatically placed on the HIP.
If an HIP is of type Alignment speed, arcs and spirals are automatically placed on HIP’s using the 
Design speed for the super alignment.
If an HIP is of type Curve speed, arcs and spirals are automatically placed on the HIP using the design 
table, and the speed set for the HIP.
If an HIP is of type Curve length, arcs are placed on the HIP using the length for the HIP.
If an HIP is of type Curve radius, arcs are placed on the HIP using the radius for the HIP.
If an HIP is of type Curve spiral, arcs are placed on the HIP using the curve radius, and leading and 
trailing spiral length for the HIP.

VIP type choice box No VC
Alignment speed
Speed
Length
Radius
Kvalue
Maximum length
Asymmetric
Circular arc

The default VIP type given to any placed VIP’s.

If Speed, the VIP is also given the speed from the Speed field on the Default tab. 
If Length, the VIP is also given the parabolic length from the Length field on the Default tab. 

Plan View

If this distance is less than
Min on broken-back then the two curves
are treated as broken back curves
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If Radius, the VIP is also given the effective parabolic radius from the Radius field on the Default tab. 
If Kvalue, the VIP is also given the K value from the K value field on the Default tab. 
If Asymmetric, the VIP is also given the first and second parabolic length for the Length and Length 2 
field on the Default tab. 
If Circular arc, the VIP is also given the arc radius from the Radius field on the Default tab. 

Note on VIP types:
if an VIP is of type No VC, no vertical curve is placed on the VIP.
If an VIP is of type Alignment speed, parabolic curves are automatically placed on VIP’s using the 
Design speed for the super alignment.
If an VIP is of type Speed, parabolic curves are automatically placed on the VIP using the design table, 
and the speed set for the VIP.
If an VIP is of type Length, a parabolic curve is placed on the VIP using the length for the VIP.
If an VIP is of type Radius, a parabolic curve is placed on the VIP using the effective radius for the 
VIP.
If an VIP is of type Kvalue, a parabolic curve is placed on the VIP using the kvalue for the VIP.
If an VIP is of type Max length, a parabolic curve of maximum length is placed on the VIP.
If an VIP is of type Asymmetric, two parabolic curve using lengths Length and Length 2 for the VIP 
are placed on the VIP.
If an VIP is of type Circular arc, an arc is placed on the VIP using the radius for the VIP.

Start/End tab
the Start/End tab defines where the usable horizontal and vertical geometry starts and ends for the 
super alignment. Note that the super alignment can have more horizontal and vertical geometry than is 
actually used.

Start Horizontal mode choice box default
segment
point

specifies how the start of the usable horizontal geometry is defined.

If default, the beginning of the first non invisible horizontal part is the start of the usable horizontal 
geometry.

If segment, a user selected segment of the horizontal geometry is the start of the usable horizontal 
geometry.

If point, a user selected position is dropped perpendicularly onto the super alignment to define the start 
of the usable horizontal geometry.

Start Control X/Y coordinate select x, y box

used in the segment and point cases of the Start Horizontal mode.

Start Vertical mode choice box default
relative
chainage

specifies how the start of the usable vertical geometry is defined.

If default, the beginning of the first non invisible vertical part is the start of the usable vertical 
geometry.

If relative, the chainage of the start of the usable horizontal geometry is used as the start of the usable 
vertical geometry. If the beginning of the defined vertical geometry is after this chainage, then the first 
segment is extrapolated back to the required chainage. 

If chainage, a user given chainage defines the start of the usable vertical geometry.

Start Chainage input

used in the chainage case of the Start Vertical mode.

End Horizontal mode choice box default
segment
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point

specifies how the end of the usable horizontal geometry is defined.

If default, the end of the last non invisible horizontal part is the end of the usable horizontal geometry.

If segment, a user selected segment of the horizontal geometry is the end of the usable horizontal 
geometry.

If point, a user selected position is dropped perpendicularly onto the super alignment to define the end 
of the usable horizontal geometry.

End Control X/Y coordinate select x, y box

used in the segment and point cases of the End Horizontal mode.

End Vertical mode choice box default
relative
chainage

specifies how the end of the usable vertical geometry is defined.

If default, the end of the last non invisible vertical part is the end of the usable vertical geometry.

If relative, the chainage of the end of the usable horizontal geometry is used as the end of the usable 
vertical geometry. If the end of the defined vertical geometry is before this chainage, then the last 
segment is extrapolated to the required chainage. 

If chainage, a user given chainage defines the end of the usable vertical geometry.

Start Chainage input

used in the chainage case of the End Vertical mode.

Chainage tab
defines the chainage for the string

Horizontal Chainage input 0

the user given chainage value. Where it is applied depends on the Horizontal mode

Horizontal Model choice box start point
end point
control point
start part
end part

if start point, the Chainage value is applied to the start of the usable horizontal geometry,
If end point, the Chainage value is applied to the end of the usable horizontal geometry,
If control point, a user given control point is dropped perpendicularly onto the horizontal geometry 
and that position is given the Chainage value.
If start part, the Chainage value is applied to the start of the first part of horizontal geometry, even if 
it is invisible.
If end part, the Chainage value is applied to the end of the last part of horizontal geometry, even if it 
is invisible.

Horizontal Control X/Y coordinate select x, y box

used in the control point cases of the Horizontal mode

Horizontal Chainage interval input 10

horizontal chainage interval for the string

Horizontal Chord to arc tol input 0.1

horizontal chord to arc tolerance to use for any arcs

Vertical Chainage interval input 10

vertical chainage interval for the string

Vertical Chord to arc tol input 0.1

vertical chord to arc tolerance to use for any parabolas
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Note: the horizontal and vertical intervals and chord to arc tolerances are used when the super 
alignment is approximated by straights in three dimensions.
 

Label Major Chainage interval input 10

major chainage interval to use for labelling

Label Minor Chainage interval input

minor chainage interval to use for labelling

Label Reference chainage interval input 0

reference value for the chainage labelling intervals

Label Special chainage file file box *.spc file

file of special chainages for labelling

Note: the labelling of the super alignment is given by the Label style on the General tab.

Buttons at Bottom

Create button

After the Create button is chosen, the super alignment toolbar is created. The Super Alignment Edit 
toolbar is displayed

Same as button

After the Same as button is chosen, another string is selected and information about it is used for the 
fields in this panel

Super Alignment Edit
After selecting the Create button the Super Alignment toolbar is created and placed on the screen.

The Super Alignment Edit menu is still under development and for more information on creating 
and editing the super alignment, please play the 12d Training DVD’s.

For definitions of the horizontal and vertical elements, go to “Placing Elements for Super 
Alignments” 

model ->string_name for the super alignment
string being edited
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Super Alignment Style
super_alignment_style_create_edit

Position of option on menu: Strings =>Create =>Super alignment =>Super alignment style

The super alignment styles control the way that the super alignment draws and highlights on the 
screen.

Selecting Super alignment style displays the Super Alignment Style Create/Edit panel.
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The fields and buttons used in the Super Alignment Style Create/Edit panel have the following 
functions.

Field Description Type Defaults Pop-Up

Design style choice box design styles defined in astyles.4d

all the information in the panel refers to the selected design style. Note - the design styles are stored in 
the file astyles.4d.

Use labels tick box

if tick, labels are automatically drawn when the super alignment is on a Plan view.

Use vertical symbols tick box

if tick, vertical symbols are when the super alignment is profiled on a Section view.

Draw lines between ips tick box

if tick, lines are drawn between intersection points (IP’s).

Number of decimals input

the number of decimal places to use in the chainage labels
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Direction type choice box none, at start, each segment

Unsolved label input

the label to use when a part is not solved

Unsolved textstyle input textstyle datas

the textstyle to use for the label when a part is not solved

Vertical symbol input all available symbols

Highlight thickness input

Hightlights tab
the definition of how to highlight horizontal and vertical parts of the super alignment

Tangents tab
the definition of what text, symbols and decimal places should be used in labelling tangent points, crest 
and sag points, major and minor intervals, segment radii and lengths, and special chainages.

Buttons at Bottom

Set button

clicking the Set button means that for this session, all the definitions in the panel will be used for the 
design style given in the Design style field. Unless the Write button is used to write the values out to the 
astyles.4d file, the values will be lost when the project is exited.

Write button

clicking the Set button writes out all the values in this panel to the astyles.4d file as the design style 
given in the Design style field
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Define Design Parameters
road_design_parameters

Position of option on menu: Strings =>Create =>Super alignment =>Design parameters

The design parameters table defines the use arcs, transition curves, parabolas, super elevation 
and road widening for given design speeds. The table is used to use by a super alignment in 
conjunction with user supplied information given in the Design tab of the super alignment.

Selecting Design parameters displays the Road Design Parameters panel.



Chapter 14  Strings

May 2007 Page 903Create

Resolve a Super Alignment
resolve_super_alignment

Position of option on menu: Strings =>Create =>Super alignment =>Resolve

When a super alignment is created using computators, the super alignment is defined with 
references to other strings. If the referenced strings are modified, then the super alignment will 
not automatically reflect the changes in the referenced strings.

Resolve forces the string to be resolved using the current position and properties of any 
referenced strings.

Selecting Resolve displays the Resolve Super Alignment panel.

The new fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Super alignment string select

select a super string to resolve.

Resolve button

after the Resolve button is clicked, the super alignment is resolved using the new position and 
properties of any referenced strings.
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Dereference a Super Alignment
dereference_super_alignment

Position of option on menu: Strings =>Create =>Super alignment =>Deref

When a super alignment is created using computators, the super alignment is defined with 
references to other strings. 

Deref copies any referenced strings and inserts the copies into the super alignment in place of the 
referenced string. So after running Deref that there is no longer any references to other strings in 
the super alignment.

Selecting Deref displays the Dereference Super Alignment panel.

The new fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Super alignment string select

select a super string to dereference.

Deref button

after the Deref button is clicked, any referenced strings are copied and inserted into the super 
alignment in place of the referenced strings.
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Parallel a Super Alignment
parallel_super_alignment

Position of option on menu: Strings =>Create =>Super alignment =>Parallel

Parallel parallels the horizontal geometry of a super alignment by a user given offset.

Selecting Parallel displays the Parallel Super Alignment panel.

The new fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Super alignment string select

select a super alignment to parallel

Offset input

distance to offset the selected super alignment

Model model box available models

model for the parallelled string

New super alignment properties tick box

if tick, the panel is expanded to show all the properties that can be set for the new parallelled string.

Parallel button

after the Parallel button is clicked, a dereferenced copy of the horizontal geometry of the super 
alignment is parallelled. The vertical geometry is deleted.

Extra panel fields when
New super alignment properties
is ticked on
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Same as button

after clicking Same as and then select a string. All the picked string properties will be loaded into the 
panel fields.
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Split a Super Alignment
split_super_alignment

Position of option on menu: Strings =>Create =>Super alignment =>Split

Split splits super alignment at a given chainage.

Selecting Split displays the Split Super Alignment panel.

The new fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Super alignment string select

select a super alignment to split

Chainage input

chainage to split the super alignment at

Model model box available models

model for the split string

Split button

after the Split button is clicked, the super alignment is split at the given chainage.
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Joining Two Super Alignments
join_super_alignment

Position of option on menu: Strings =>Create =>Super alignment =>Join

Join joins two super alignments at their ends.

Selecting Join displays the Join Super Alignment panel.

The new fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Super alignment string select

select a super alignment to join

Super alignment 2 string select

select a super alignment to join to the first selected super alignment

Model model box available models

model for the joined string

New super alignment properties tick box

if tick, the panel is expanded to show all the properties that can be set for the new joined string.

Join button

after the Join button is clicked, a new super alignments is created by joining the two super alignments

Same as button

after clicking Same as and then select a string. All the picked string properties will be loaded into the 
panel fields.

Extra panel fields when
New super alignment properties
is ticked on



Chapter 14  Strings

May 2007 Page 909Create

Convert Fixed/Floating Elements to IP’s
fixed_floating_to_ips

Position of option on menu: Strings =>Create =>Super alignment =>Fixed/floating to IPs

Fixed/floating to IP’s converts the fixed and floating elements of the horizontal and vertical 
geometry to horizontal and vertical intersection points joins with arcs and transitions and 
parabolas or vertical arcs respectively.

Selecting Fixed/floating to IPs displays the Fixed/floating to IPs panel.

The new fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Super alignment string select

select a super alignment to convert

Delete original string tick box

if tick, the original super alignment is deleted after the conversion is successful

Model model box available models

model for the converted string

New super alignment properties tick box

if tick, the panel is expanded to show all the properties that can be set for the new converted string.

Convert button

after the Convert button is clicked, a new super alignments is created by converting all the elements 
to IPs

Extra panel fields when
New super alignment properties
is ticked on
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Same as button

after clicking Same as and then select a string. All the picked string properties will be loaded into the 
panel fields.
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Change the Styles for Selected Super Alignments
change_super_alignment_style

Position of option on menu: Strings =>Create =>Super alignment =>Change style

Change style changes the super alignment style for all the selected super alignments.

Selecting Change style displays the Change Super Alignment Style panel.

The new fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Style SA style box available SA styles

super alignment style to apply to all the selected super alignments

Change button

after the Change button is clicked, all the selected super alignments are given the super alignment 
style
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Explode the Super Alignments Labelling
explode_super_alignment_labels

Position of option on menu: Strings =>Create =>Super alignment =>Explode labels

Explode labels creates text and lines from the automatic labelling of the selected super 
alignments.

Selecting Explode labels displays the Explode Super Alignment Labels panel.

The new fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Keep original labels tick box

Explode labels as points tick box

Explode button

create text strings for all the text in the automatic labels of the selected super alignments
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Constrain the Movement of Super Alignment Points
move_super_alignment_point_settings

Position of option on menu: Strings =>Create =>Super alignment =>Move settings

Explode labels creates The move settings constrains the movement of horizontal and vertical 
intersection points for any super alignment being edited.

Selecting Move settings displays the Move Super Alignment Point Settings panel.

The buttons are radio buttons - that is, only one can be selected:

Default

allows any movement in the selected HIP or VIP point

X-axis

constrains an HIPs to only move along the x-axis. That is, the y coordinate is fixed.
Constrains a VIPs to only move along the chainage-axis. That is, the height coordinate is fixed.

Y-axis

constrains an HIPs to only move along the y-axis. That is, the x coordinate is fixed.
Constrains a VIPs to only move along the height-axis. That is, the chainage coordinate is fixed.

Fwd Tgt

constrains an HIPs to only move along the incoming straight to the HIP.
Constrains a VIPs to only move along the incoming straight to the VIP.

Bwd Tgt

constrains an HIPs to only move along the outgoing straight from the HIP.
Constrains a VIPs to only move along the outgoing straight from the VIP.
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Create Arcs
create_arcs

Position of menu: Strings =>Create =>Arcs

The create arcs option is used to create 12d Model arcs.

A 12d Model arc consists of a radius, a centre point, and a start and end point on the arc.

The radius can be positive or negative. If the radius is positive, the arc is drawn from the start-
point to the end-point in a clockwise direction. If the radius is negative, the arc is drawn from the 
start-point to the end-point in counter-clockwise direction.

The height at the start point and at the end point can be different. In that case, the arc is still a 
plan arc but the z- value varies linearly from the start point to the end point as one moves around 
the arc. Hence the 12d Model arc string is actually a helix with its centre-line perpendicular to 
the xy-plane.

For convenient 12d Model includes a variety of methods for creating arcs.

On selecting the arcs option, the create arcs menu is displayed giving all the different methods 
for creating arcs.

Each option in the create arcs menu fires up its own special panel to collect the necessary 
information for defining the arc.

The mouse is used to select the special points required for the arc and circle definitions. For 
example, in the arc - 3 points on arc option, the three points are selected using the mouse.

Unlike the other strings created under strings=>create, the arc can be created immediately 
without needing any options from the arc editors.

Consequently, after an arc is defined, the create panel is not removed and is left on the screen to 
create another arc. Any information that needs modifying is changed in the arc panel and is used 
for the new create.

New arcs are created until either the panel is removed by selecting the finish or [X] button, or the 
create terminated by selecting cancel from the pick ops menu in which case the panel will be left 
on the screen. In the last case, the arc button is then used to begin a new create sequence.

Each of the methods for creating arcs will now be described.

Create - Arc
create_arc_string

Position of option on menu: Strings =>Create =>Arcs =>Create Arcs

Arcs and circles are normally created using the strings=>create=> arcs or strings=>create=> 
circles menu. Please see the documentation on that option for creating arcs and circles.

This option is a special arc creator so that a menu exists if the strings=>create=>same as option is 
used on an arc. It creates an arc with an initial sweep angle of 360 degrees.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
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many strings is set to tick, when the current string creation is Finished or Quit, a new Create Arc 
String panel is placed on the screen with the same information in it as the string just created. If 
any of the information needs to be modified for the new string, simply change it in the Create Arc 
String panel fields before selecting the Create button for the new string. Hence a new string of the 
same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create Arc String panel.

After selecting the option, the create arc string panel is displayed.

The new fields and buttons used in the create arc string panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

Centre input xyz ops menu

co-ordinates of the centre of the arc.

Radius input

the radius for the arc.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the arc edit menu and arc edit info panel are displayed.
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Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Note - the centre co-ordinates can either be typed into the centre panel field, or if LB is clicked on 
[+] for the centre panel field, the xyz ops menu comes up and the pick xyz option used to select a 
point as the arc centre.
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Arc Edit

Unlike the other string creates, on selecting the Create button the arc string is immediately 
created with a sweep angle of 360 degrees.The arc edit menu and arc edit info panel are also 
placed on the screen at the same time

The arc edit menu and arc edit info panel for an arc string are

For full information in the Arc Editor, go to the section “Arc Edit” 

Create Arc - Centre Point, Start Point and Sweep
arc___centre__start_point_and_sweep_angle

Position of option on menu: Strings =>Create =>Arcs =>Centre,Start,Sweep

This option defines an arc by selecting a centre point, the start point of the arc and the sweep 
angle of the arc. The sweep angle is measured in the clockwise direction.

The radius is calculated by the option and is simply the distance between the centre and start 
points. The arc end point is also automatically calculated using the known points, radius and 
sweep angle.

After selecting the option, the arc - centre, start point and sweep angle panel is displayed.

To create an arc, the name, colour, model, chainage interval and sweep angle are entered into the 
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appropriate fields and then the centre point and start point of the arc are selected with the cursor. 
The arc is then created using the information provided in the panel.

The new fields and buttons used in the arc - centre, start point and sweep angle panel have the 
following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

z mode input typed snap, typed

the method of specifying the z-value for the end points of the arc. It can be typed in or taken from the z-
value of the selected end points.

z value input  0

if the z mode method is typed, then the height (z-value) of the end points is the value in the field.

Ch interval input 10

the chainage interval used when a chord approximation is needed for the arc.

Sweep angle input

sweep angle for the arc - Note: clockwise is positive for sweep angles

Arc button

The arc button is used to begin a new create if the previous one was cancelled.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Panel Messages

Next step messages sent to the screen message area when selecting and accepting the centre point
<Arc centre> [picks][][menu]
<Arc centre> [picks][accepts][menu]

When selecting the start point of the arc
<Arc start> [picks][][menu]
<Arc start> [picks][accepts][menu]
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Create Arc - Centre Point, Start and End Points
arc___centre__start_and_end_points

Position of option on menu: Strings =>Create =>Arcs =>Centre, 2 pts on arc

This option defines an arc by selecting a centre point, a start and end points for the arc and the 
direction (clockwise, anti-clockwise) that the arc travels in. The radius is calculated by the option 
and is simply the distance between the centre and start points.

It is difficult to choose the end point correctly so that it lies exactly on the arc since it only occurs 
when the distance between the centre and selected end point is exactly the radius of the arc. 

Hence, the selected end point and arc direction is used to determine the sweep angle from the 
start point to the “end point to centre point” line. This is enough information to define the arc. 
The real end point is then calculated so that it lies on the arc.

After selecting the option, the arc - centre, start and end points panel is displayed.

To create an arc, the name, colour, model, chainage interval and direction are entered into the 
appropriate fields and then the centre point, start and end points of the arc selected with the 
cursor. The arc is then created using the information provided in the panel.

The fields and buttons used in the arc - centre, start and end points panel have the following 
functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.
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z mode input typed snap, typed

the method of specifying the z-value for the end points of the arc. It can be typed in or taken from the z-
value of the selected end points.

z value input  0

if the z mode method is typed, then the height (z-value) of the end points is the value in the field.

Ch interval input 10

the chainage interval used when a chord approximation is needed for the arc.

Direction input clockwise clockwise,
anti-clockwise

the direction for the arc

Arc button

The arc button is used to begin a new create if the previous one was cancelled.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Panel Messages

Next step messages sent to the screen message area when selecting and accepting the centre point
<Arc centre> [picks][][menu]
<Arc centre> [picks][accepts][menu]

When selecting the start point of the arc
<Arc start> [picks][][menu]
<Arc start> [picks][accepts][menu]

When selecting the end point of the arc
<Arc end> [picks][][menu]
<Arc end> [picks][accepts][menu]
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Create Arc - Centre, Radius, Start and End Points
arc___radius__centre__start_and_end_points

Position of option on menu: Strings =>Create =>Arcs =>Centre, radius, 2pts

This option defines an arc by the user setting a radius and direction of arc and then selecting the 
centre, start and end points for the arc.

Since the radius is given exactly, it is difficult to choose the start and end points so that they lie 
exactly on the arc. This only occurs when the distance between the centre and selected start and 
end points is exactly the radius of the arc.

Hence, the selected start point is dropped perpendicularly onto the arc to give the real start 
point. Similarly, for the real end point.

After selecting the option, the arc - radius, centre, start and end points panel is displayed.

To create an arc, the name, colour, model, chainage interval, radius and direction are entered into 
the appropriate fields and then the centre point, start and end points of the arc selected with the 
cursor. The arc is then created using the information provided in the panel.

The fields and buttons used in the arc - radius, centre, start and end points panel have the 
following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.
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z mode input typed snap, typed

the method of specifying the z-value for the end points of the arc. It can be typed in or taken from the z-
value of the selected end points.

z value input  0

if the z mode method is typed, then the height (z-value) of the end points is the value in the field.

Ch interval input 10

the chainage interval used when a chord approximation is needed for the arc.

Abs radius input

the absolute radius of the arc.

Direction input clockwise clockwise,
anti-clockwise

the direction for the arc

Arc button

The arc button is used to begin a new create if the previous one was cancelled.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Panel Messages

Next step messages sent to the screen message area when selecting and accepting the centre point
<Arc centre> [picks][][menu]
<Arc centre> [picks][accepts][menu]

When selecting the start point of the arc
<Arc start> [picks][][menu]
<Arc start> [picks][accepts][menu]

When selecting the end point of the arc
<Arc end> [picks][][menu]
<Arc end> [picks][accepts][menu]

Create Arc - Three Points on Arc
arc___3_points_on_arc

Position of option on menu: Strings =>Create =>Arcs =>3 pts on arc

This option defines an arc by selecting three points that lie on the arc.

The selected arc points are the start point, a point between the start and end point, and the end 
point. The three points must be selected in that order.

After selecting the option, the arc - 3 points on arc panel is displayed.
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To create an arc, the name, colour, model and chainage interval are entered into the appropriate 
fields and then three points - start point, point between the start and end point, and the end 
point- which lie on the arc are selected with the cursor.

After the three points are picked, the arc is created using the information provided in the panel.

After a arc is defined, the option does not terminate. Another arc can be created by simply 
modifying any of the information that needs changing in the arc - 3 points on arc panel and then 
selecting three points on a new arc.

The fields and buttons used in the arc - 3 points on arc panel have the following functions.

Field Description Type DefaultsPop-Up

Name input

the name of the new arc.

Model input available models

name of the model that the new arc is in.

Colour input default colour available colours

the colour of the new arc.

Style input 1 available line styles

line style of the arc.

Weight input 0

thickness of the string.

z mode input typed snap, typed

the method of specifying the z-value for the arc. It can be typed in or taken from the z-value of the 
selected end points.

z value input  0

if the z mode method is typed, then the height (z-value) of the end points is the value in the field.

Ch interval input 10

the chainage interval used when a chord approximation is needed for the arc.

Arc button

The arc button is used to begin a new create if the previous one was cancelled.
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Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Panel Messages

Next step messages sent to the screen message area when selecting and accepting the start point
<Arc start> [picks][][menu]
<Arc start> [picks][accepts][menu]

When selecting and accepting the second point
<Point on arc> [picks][][menu]
<Point on arc> [picks][accepts][menu]

When selecting and accepting the end point
<End of arc> [picks][][menu]
<End of arc> [picks][accepts][menu]
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Create Arc - Start Point, Radius, Arc Length and Start Bearing
arc___start_pt_radius_arc_length_start_bear

Position of option on menu: Strings =>Create =>Arcs =>Start, rad, arc, bear

This option defines an arc by giving the radius, the arc length and start bearing and then 
selecting a start point for the arc.

This is enough information for the option to calculate the centre and end points and the direction 
of the arc, and hence, fully define the arc.

After selecting the option, the arc - start pt, radius, arc length, start bear panel is displayed.

To create an arc, the name, colour, model, chainage interval, radius, arc length and start bearing 
are entered into the appropriate fields and then the start point of the arc selected with the cursor. 
The arc is then created using the information provided in the panel.

The new fields and buttons used in the arc - start pt, radius, arc length, start bear panel have the 
following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

z mode input typed snap, typed

the method of specifying the z-value for the end points of the arc. It can be typed in or taken from the z-
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value of the selected end points.

z value input  0

if the z mode method is typed, then the height (z-value) of the end points is the value in the field.

Ch interval input 10

the chainage interval used when a chord approximation is needed for the arc.

Radius input

radius of the arc.

Arc length input

length of the arc from the start to the end point.

Start bearing input

bearing of the tangent to the arc at the start point.

Arc button

The arc button is used to begin a new create if the previous one was cancelled.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Panel Messages

Next step messages sent to the screen message area when selecting the start point of the arc
<Arc start> [picks][][menu]
<Arc start> [picks][accepts][menu]
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Create Arc - Start Point, Radius, Arc Length and Chord Bearing
arc___start_pt_radius_arc_length_chord_bear

Position of option on menu: Strings =>Create =>Arcs =>Start, rad, arc, ch bear

This option defines an arc by giving the radius, the arc length and chord bearing and then 
selecting a start point for the arc. This is enough information for the option to calculate the centre 
and end points and the direction of the arc, and hence, fully define the arc.

After selecting the option, the arc - start pt, radius, arc length, chord bear panel is displayed.

To create an arc, the name, colour, model, chainage interval, radius, arc length and chord bearing 
are entered into the appropriate fields and then the start point of the arc selected with the cursor. 
The arc is then created using the information provided in the panel.

The new fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

z mode input typed snap, typed

the method of specifying the z-value for the end points of the arc. It can be typed in or taken from the z-
value of the selected end points.
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z value input  0

if the z mode method is typed, then the height (z-value) of the end points is the value in the field.

Ch interval input 10

the chainage interval used when a chord approximation is needed for the arc.

Radius input

radius of the arc.

Arc length input

length of the arc from the start to the end point.

Chord bearing input

bearing of the chord to the arc at the start point.

Arc button

The arc button is used to begin a new create if the previous one was cancelled.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Panel Messages

Next step messages sent to the screen message area when selecting the start point of the arc
<Arc start> [picks][][menu]
<Arc start> [picks][accepts][menu]
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Create - Circles
create_circles

Position of menu: Strings =>Create =>Circles

The create circles option is used to create 12d Model circles.

A 12d Model circle has no start and end points but is defined by a centre point and a radius. The 
circle has a constant height (z-value).

For convenient 12d Model includes a variety of methods for creating circles. On walking-right on 
the circles option, the create circles menu is displayed giving all the different methods for 
creating circles.

Each option in the create circles menu fires up its own special panel to collect the necessary 
information for defining the circle.

The mouse is used to select the special points required for the circle definitions. For example, the 
circle - centre, radius option required the value of the radius to be entered into the circle - centre 
point, radius panel and the centre point is selected using the cursor.

Unlike the other strings created under strings=>create, the circles can be created immediately 
without needing any options from the circle editor. Consequently, after a circle is defined, the 
create panel is not removed and is left on the screen to create another circle. Any information that 
needs modifying is changed in the circle panel and is used for the new create.

New circles are created until either the panel is removed by selecting the finish or [X] button, or 
the create terminated by selecting cancel from the pick ops menu in which case the panel will be 
left on the screen. In the last case, the circle button is then used to begin a new create sequence.

Each of the methods for creating circles and arcs will now be described.
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Create Circle - Centre Point, Radius
circle____centre_point__radius

Position of option on menu: Strings =>Create =>Circles =>Centre, radius

This option defines a circle by supplying a typed radius and selecting a centre point with the 
mouse

After selecting the option, the circle - centre point, radius panel is displayed.

To create a circle, the name, colour, model, chainage interval and radius are entered into the 
appropriate fields and the centre point selected with the cursor. The circle is then created using 
the information provided in the panel.

The new fields and buttons used in the circle - centre point, radius panel have the following 
functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

z mode input typed snap, typed

the method of specifying the z-value for the circle. It can be typed in or taken from the z-value of the 
selected centre point.

z value input  0

if the z mode method is typed, then the height (z-value) of the circle is the value in the field.
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Ch interval input 10

the chainage interval used when a chord approximation is needed for the circle.

Radius input 10

the radius for the circle.

Circle button

The circle button is used to begin a new create if the previous one was cancelled.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Panel Messages

Next step messages sent to the screen message when selecting and accepting the centre point are
<Circle centre> [picks][][menu]
<Circle centre> [picks][accepts][menu]
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Create Circle - Centre Point, Point on Circle
circle____centre_point__point_on_circle

Position of option on menu: Strings =>Create =>Circles =>Centre, pt on circle

This option defines a circle by selecting a centre point and a point on the circle. The radius is 
automatically calculated by the option and is simply the distance between the two selected 
points.

After selecting the option, the circle - centre point, point on circle panel is displayed.

To create a circle, the name, colour, model and chainage interval are entered into the appropriate 
fields and the centre point and a point on the circle selected with the cursor. Then the circle is 
created using the information provided in the panel.

The new fields and buttons used in the circle - centre point, point on circle panel have the 
following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

z mode input typed snap, typed

the method of specifying the z-value for the circle. It can be typed in or taken from the z-value of the 
selected centre point.

z value input  0

if the z mode method is typed, then the height (z-value) of the circle is the value in the field.
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Ch interval input 10

the chainage interval used when a chord approximation is needed for the circle.

Circle button

The circle button is used to begin a new create if the previous one was cancelled.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

How to Use the Panel to Create a Circle

(a) The panel fields are filled in with the appropriate data for use in defining the circle.

(b) The mouse is then used to select the centre point for the circle.

Messages sent to the screen message area when selecting and accepting the centre point
<Circle centre> [picks][][menu]
<Circle centre> [picks][accepts][menu

When selecting a point on the circle
<Point on circle> [picks][][menu]
<Point on circle> [picks][accepts][menu
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Create Circle - Three Points on Circle
circle___3_points_on_circle

Position of option on menu: Strings =>Create =>Circles =>3 pts on circle

This option defines a circle by selecting three points that all lie on the circle.The radius and centre 
point are automatically calculated by the option.

After selecting the option, the circle - 3 points on circle panel is displayed.

To create a circle, the name, colour, model and chainage interval are entered into the appropriate 
fields and then three points which lie on the circle are selected with the cursor. The circle is then 
created using the information provided in the panel.

The fields and buttons used in the circle - 3 points on circle panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

z mode input typed snap, typed

the method of specifying the z-value for the circle. It can be typed in or taken from the z-value of the 
selected centre point.

z value input  0

if the z mode method is typed, then the height (z-value) of the circle is the value in the field.

if the z mode method is typed, then the height (z-value) of the circle is the value in the field.

Ch interval input 10

the chainage interval used when a chord approximation is needed for the circle.
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Circle button

The circle button is used to begin a new create if the previous one was cancelled.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Panel Messages

Next step messages sent to the screen message area when selecting and accepting the 1st point
<First point on circle> [picks][][menu]
<First point on circle> [picks][accepts][menu]

When selecting and accepting the second point
<Second point on circle> [picks][][menu]
<Second point on circle> [picks][accepts][menu

When selecting and accepting the third point
<Third point on circle> [picks][][menu]
<Third point on circle> [picks][accepts][menu]

Create - Feature
create_feature_string

Position of option on menu: Strings =>Create =>Feature

A feature string consists of a centre point (x,y,z) and a user given radius.

The difference between a circle and a feature string is that for a feature string the centre point is 
considered to be a valid (x,y,z) point but all the points on the circumference of the feature string 
are null values. Feature strings can be used to represent objects such as trees.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create Feature 
String panel is placed on the screen with the same information in it as the string just created. If 
any of the information needs to be modified for the new string, simply change it in the Create 
Feature String panel fields before selecting the Create button for the new string. Hence a new 
string of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create Feature String panel.

After selecting the option, the create feature string panel is displayed.
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The new fields and buttons used in the create feature string panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

Centre input xyz ops menu

co-ordinates of the centre of the feature.

Radius input

the radius for the feature.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the feature edit menu and feature edit info panel are displayed.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Note - the centre co-ordinates can either be typed into the centre panel field, or if LB is clicked on 
[+] for the centre panel field, the xyz ops menu comes up and the pick xyz option can be used 
from it to select a point as the arc centre.

Feature Edit

Like the arc creates, on selecting the Create button the feature string is immediately created. The 
feature edit menu and feature edit info panel are also placed on the screen at the same time

The feature edit menu and panel for a feature string are

 For full information in the Feature Editor, go to the section “Feature Edit” 
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Create - Pipe
create_pipe_string

Position of option on menu: Strings =>Create =>Pipe

A pipe string is the same as a 3d string except that the pipe string also has a diameter hence the 
options for creating and editing a pipe string are almost the same as for a 3d string.

The main difference is that there are no options to open and close a pipe string and there is an 
additional option for modifying the pipe diameter.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create Pipe 
String panel is placed on the screen with the same information in it as the string just created. If 
any of the information needs to be modified for the new string, simply change it in the Create 
Pipe String panel fields before selecting the Create button for the new string. Hence a new string 
of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create Pipe String panel.

On selecting the Pipe string option, the Create Pipe String panel is displayed.

To create a new pipe string, the name, colour, model, point-line type and diameter of the new 
string are entered into the appropriate fields and the create button selected.

The new fields and buttons used in the create pipe string panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.
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Weight input 0

thickness of the string.

Diameter input 0

diameter of the pipe

Justify input invert  invert, centre, overt

justification of the pipe with respect to the co-ordinates given for the pipe string.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the pipe edit menu and pipe edit info panel are displayed.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Pipe Edit
On selecting the Create button in the Create Pipe String panel the Pipe Edit menu and Pipe Edit info 
panel are placed on the screen.

The Pipe Edit menu and panel for a pipe string are

To create a new pipe string, select the Append option from the Pipe Edit menu.

The Append option is used to add points to either end of an existing string, or in the case of a 
new string, places the 1st point and then begins appending points to the 1st point.

For all pipe strings, a cross is then drawn in each plan view that the string’s model is on, and the 
cross follows the cursor around the screen. If the string’s model is not added to any plan view, 
the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the 1st vertex of the string (using the appropriate snaps).

The string is then drawn from the 1st vertex to the cursor position, which represents the second 
vertex of the string. Clicking LB and accepting with MB selects the second string vertex and the 
process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s Pipe Edit menu are usable.

The options in the Pipe Edit menu are not only used for placing the initial vertices of the string, 
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but for editing the string once it is created. Since the Append and other options in the Pipe Edit 
menu are identical to the options used when editing an existing string, they will be discussed in 
detail in the string Editor section.

For full information in the Pipe Editor, go to the section “Pipe Edit” 
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Create - Polyline
create_polyline_string

Position of option on menu: Strings =>Create =>Polyline

A polyline string is similar to a 3d string except that it can have either straight lines or arcs 
joining the (x,y,z) points of the string. The arcs are plan arcs with possibly a different z at either 
end and the z values are linearly interpolated between the end points. Hence in a long section, 
the end points are joined by a straight lines for both line and arc segments of the polyline.

Creating and editing a polyline string is very similar to a 3d string. The only major difference is 
that a radius is required at each string segment (a radius of 0 means no arc, just a straight line).

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create Polyline 
String panel is placed on the screen with the same information in it as the string just created. If 
any of the information needs to be modified for the new string, simply change it in the Create 
Polyline String panel fields before selecting the Create button for the new string. Hence a new 
string of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create Polyline String panel.

On selecting the polyline string option, the create polyline string panel is displayed.

To create a new polyline string, the name, colour, model, point-line type and linestyle of the new 
string are entered into the appropriate fields and the create button selected.

The new fields and buttons used in the create pipe string panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.
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Weight input 0

thickness of the string.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the polyline edit menu and polyline edit info panel are displayed.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Polyline Edit
Selecting the create button in the create polyline string panel the polyline edit menu and polyline 
edit info panels are placed on the screen.

To create a new polyline string, the user must select one of the two append options (Append or 
Append + radius) on the Append walk-right of the Polyline Edit menu. The which Append option 
to simply creates points which are joined by a straight segment whereas the Append + radius 
create points with a radius for the segment.

The Append options are used to add points to either end of an existing string, or in the case of a 
new string, places the 1st point and then begins appending points to the 1st point.

For all polyline strings, a cross is then drawn in each plan view that the string’s model is on, and 
the cross follows the cursor around the screen. If the string’s model is not added to any plan 
view, the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the 1st vertex of the string (using the appropriate snaps).

If Append + radius was selected, the user will then be prompted for the radius of the segment 
being placed.

The string is then drawn from the 1st vertex to the cursor position, which represents the second 
vertex of the string. Clicking LB and accepting with MB selects the second string vertex and the 
process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s Polyline Edit menu are usable.

The options in the Polyline Edit menu are not only used for placing the initial vertices of the 
string, but for editing the string once it is created. Since the Append and other options in the 
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Polyline Edit menu are identical to the options used when editing an existing string, they will be 
discussed in detail in the string Editor section.

For full information in the Polyline Editor, go to the section “Polyline Edit” 
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Create - Super
create_super_string

Position of option on menu: Strings =>Create =>Super

A super string is a combination and generalisation of a 4d string, a pipe string and a polyline 
string.

A super strings consists of a series of (x,y) vertices, plus it can have either straight lines or arcs 
joining the vertices of the string.

At each vertex, the super string has:
height
text
visibility
tinability (contourability)
point number
symbol
user defined attributes

For each segment, the super string has:

plan radius
colour
text
tinability (breakline)
pipe diameter or box dimensions
visibility
user defined attributes

Creating and editing a super string is very similar to a polyline string in that a radius is required 
at each string segment (a radius of 0 means no arc, just a straight line). However there are many 
more choices about what is defined for each vertex and segment of the super string.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create Super 
String panel is placed on the screen with the same information in it as the string just created. If 
any of the information needs to be modified for the new string, simply change it in the Create 
Super String panel fields before selecting the Create button for the new string. Hence a new 
string of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create Super String panel.

On selecting the suer string option, the Create Super String panel is displayed.



12d Model Reference Manual

Page 944 May 2007Create

To create a new super string, the name, colour, model, point-line type and linestyle of the new 
string are entered into the appropriate fields, plus settings any required settings in the tick boxes, 
and the create button selected.

The new fields and buttons used in the create pipe string panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Style input 1 available line styles

line style of the string.
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Weight input 0

thickness of the string.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the super edit menu and super edit info panel are displayed.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Super Edit
On selecting the Create button in the Create Super String panel the Super Edit menu and Super Edit 
Info panels are placed on the screen.

To create a new super string, the user must select one of the two append options (Append or 
Append + radius) on the Append walk-right of the Super Edit menu. The Append option simply 
creates points which are joined by a straight segment whereas the Append + radius create points 
with a radius for the segment.

For all super strings, a cross is then drawn in each plan view that the string’s model is on, and the 
cross follows the cursor around the screen. If the string’s model is not added to any plan view, 
the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the 1st vertex of the string (using the appropriate snaps).

If Append + radius was selected, the user will then be prompted for the radius of the segment 
being placed.

The string is then drawn from the 1st vertex to the cursor position, which represents the second 
vertex of the string. Clicking LB and accepting with MB selects the second string vertex and the 
process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s Super Edit menu are usable.

The options in the Super Edit menu are not only used for placing the initial vertices of the string, 
but for editing the string once it is created. Since the Append and other options in the Super Edit 
menu are identical to the options used when editing an existing string, they will be discussed in 
detail in the string Editor section.
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For full information in the Super Editor, go to the section “Super Edit” 
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Create - Text
create_text_string

Position of option on menu: Strings =>Create =>Text

A text string consists of

(a) the text

(b) an (x,y) position for the text

(c) a text style

(d) a justification

(e) the height of the text in pixels or world units

(f) the x factor and slant of the text

(g) the colour of the text

(h) the angle to write the text at

The default text style uses a non-proportional font but user defined fonts can be proportional or 
non-proportional.

The justification of the text with respect to text string’s (x,y) position is user specified.

The text angle is measured in a counter- clockwise direction with respect to the horizontal axis.

Note - deleting text
Text is deleted as a normal string with the picking point at the text string’s definition point. The 
relationship of the definition point and the text depends on the text offset and justification

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create Text 
String panel is placed on the screen with the same information in it as the string just created. If 
any of the information needs to be modified for the new string, simply change it in the Create 
Text String panel fields before selecting the Create button for the new string. Hence a new string 
of the same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create Text String panel.

On selecting the text string option, the create text string panel is displayed.

To create a new text string, the name, colour, model, size, offset, justification, angle and actual 
text of the new string are entered into the appropriate fields and the create button selected.

The new fields and buttons used in the create text string panel have the following functions.
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Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Textstyle info input

textstyle information.

Text input

the actual text.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the text edit menu and text edit info panel are displayed.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Text Edit
On selecting the create button in the create text string panel the text edit menu and text edit info 
panel are placed on the screen.

The text edit menu for a text string is and the text edit panel is

To creating a new text string, the user must first select the Position option from the Text edit menu. 
Then after selecting a position, the text is created and displayed (if the model is on the view).

For full information in the Text Editor, go to the section “Text Edit” 

Create - Control Stations
Position of option on menu: Strings =>Create =>Create Control Stations

This option is documented in Survey =>Extras =>Create Control stations in the section “Create 
Control Stations”  in the Chapter “Survey” 

(x,y) position of text
define the actual text
text height
text angle
bring up attribute panel
toggle edit info panel
undo/redo
quit the create
finish the text edit
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Old
string_create_old

Position of option on menu: Strings =>Create =>Old

These old options are the string creation options that were available before 12d Model 8 was 
released.

The Create option is used to produce new strings. If a string already exists, the Editor option is 
used to modify it.

The Create walk-right menu contains options to create 2d, 3d, 4d, alignment, super alignment, 
circles, arcs, feature, pipe, polyline, super and text strings.

Each string type has its own special information so by choosing the appropriate type to be 
created, only information needed for that type of string is asked for.

Once a string has been created, it can be converted to most of the other string types using the 
string Convert option.

To create a new string of the same type and with similar header information as an existing string, 
the same as option is selected from the String Create menu.

Notes

1. Depending on its breakline (point-line) type, a string with default style ("1") is displayed with 
crosses at each of its vertex (point type) or with straight lines joining the vertices (line type).

Linestyles can be defined that drawn lines between the points even though the breakline type 
is point.

2. The string vertices are also called intersection points (IP’s).

The String Create Old walk-right menu is

The string creation process is similar for each string type and for editing strings as well.

For 2d “Create - 2d (pre V8)” 
3d “Create - 3d (pre V8)” 
4d “Create - 4d (Pre V8)” 

Create - 2d (pre V8)
create_2d_string

Position of option on menu: Strings =>Create =>Old =>2d

A 2d string consists of a series of (x,y) vertices all with the same z-value (height). 2d strings are 
often referred to as “contour strings” because contours are the most common example of a string 
with a constant height.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create 2d 
String panel is placed on the screen with the same information in it as the string just created. If 
any of the information needs to be modified for the new string, simply change it in the Create 2d 
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String panel fields before selecting the Create button for the new string. Hence a new string of the 
same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create 2d String panel.

From 12d Model 8 onwards, the default is to create 2d super strings rather than the 2d strings 
used up to 12d Model 7. A 2d super string is a super string with Constant height. That is, there is 
only one z-value for the entire string. The advantage is using a 2d super string is that all the CAD 
options will work for it and it can be given point id’s for setout. 

The older 2d string create options are still available under

Strings =>Create =>Old

On selecting the 2d string option, the create 2d string panel is displayed.

The default values for the panel fields are taken from the CAD Controlbar (see “CAD, Symbol 
and Text Controlbars” )

To create a new 2d string, the name, colour, model, point-line type and height of the new string 
are entered into the appropriate fields and the Create button selected. 

The new fields and buttons used in the create 2d string panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Type input line line, point

breakline type (point-line type) of the string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.
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Height input

height (z-value) of the entire string.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the 2d edit menu and 2d edit info panel are displayed.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

Finish button

end the option, don’t proceed to the edit stage.

2d Edit
On selecting the Create button in the Create 2d String panel the 2d edit menu and 2d Edit Info 
panel are placed on the screen.

The 2d edit menu for a 2d string is and the 2d edit info panel is

 To create a new 2d string, select the Append option from the 2d Edit menu.

The Append option is used to add points to either end of an existing string, or in the case of a 
new string, places the 1st point and then begins appending points to the 1st point.

For all 2d strings, a cross is then drawn in each plan view that the string’s model is on, and the 
cross follows the cursor around the screen. If the string’s model is not added to any plan view, 
the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the 1st vertex of the string (using the appropriate snaps).

The string is then drawn from the 1st vertex to the cursor position, which represents the 2nd 
vertex of the string. Clicking LB and accepting with MB selects the second string vertex and the 
process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s 2d Edit menu are usable.

The options in the 2d Edit menu are not only used for placing the initial vertices of the string, but 
for editing the string once it is created. Since the Append and other options in the 2d Edit menu 
are identical to the options used when editing an existing string, they will be discussed in detail 

append or prepend an IP
move an IP
insert an IP
insert IP on line joining IP’s
delete an IP
extend an IP
modify the string's z-value
open a closed string
close a string
bring up Properties panel
toggle edit info panel
undo/redo
quit the create
finish the 2d create
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in the string Editor section.

For full information in the 2d Editor, go to the section “2d Edit” 

Create - 3d (pre V8)
create_3d_string

Position of option on menu: Strings =>Create =>Old =>3d

A 3d string consists of a series of (x,y,z) points. 

The difference between a 2d and a 3d string is that for a 3d string, the z-value (height) can vary at 
each string point, whereas a 2d string has a constant height for the entire string. Hence a 2d 
string is simply a special case of a 3d string where the heights at all the points are the same.

Creating and editing a 3d string is very similar to a 2d string. The only major difference is that a 
height is required at each string point.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create 3d 
String panel is placed on the screen with the same information in it as the string just created. If 
any of the information needs to be modified for the new string, simply change it in the Create 3d 
String panel fields before selecting the Create button for the new string. Hence a new string of the 
same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create 3d String panel.

On selecting the 3d string option, the create 3d string panel is displayed.

To create a new 3d string, the name, colour, model and point-line type of the new string are 
entered into the appropriate fields and the create button selected.

To create a new 2d string, the name, colour, model, point-line type and height of the new string 
are entered into the appropriate fields and the Create button selected.

The new fields and buttons used in the create 3d string panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new string.
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Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Type input line line, point

breakline type (point-line type) of the string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the 3d edit menu and 3d edit info panel are displayed.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

3d Edit
Selecting the create button in the create 3d string panel the 3d edit menu and 3d edit info panel 
are placed on the screen.

The 3d edit menu and panel for a 3d string are

 To create the new 3d string, select the Append option from the 3d Edit menu.

The Append option is used to add points to either end of an existing string, or in the case of a 
new string, places the 1st point and then begins appending points to the 1st point.

For all 3d strings, a cross is then drawn in each plan view that the string’s model is on, and the 
cross follows the cursor around the screen. If the string’s model is not added to any plan view, 
the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the 1st vertex of the string (using the appropriate snaps).
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The string is then drawn from the 1st vertex to the cursor position, which represents the second 
vertex of the string. Clicking LB and accepting with MB selects the second string vertex and the 
process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s 3d Edit menu are usable.

The options in the 3d Edit menu are not only used for placing the initial vertices of the string, but 
for editing the string once it is created. Since the Append and other options in the 3d edit menu 
are identical to the options used when editing an existing string, they will be discussed in detail 
in the string Editor section.

For full information in the 3d Editor, go to the section “3d Edit” 

Create - 4d (Pre V8)
create_4d_string

Position of option on menu: Strings =>Create =>4d

A 4d string consists of a series of (x,y,z) points and a text label at each point. 

Creating and editing a 4d string is very similar to a 3d string.- the major difference is that a 
height and a text label is required at each string point.

The Many strings tick-box is used when more than one string of the same type is to be created, If 
many strings is set to tick, when the current string creation is Finished or Quit, a new Create 4d 
String panel is placed on the screen with the same information in it as the string just created. If 
any of the information needs to be modified for the new string, simply change it in the Create 4d 
String panel fields before selecting the Create button for the new string. Hence a new string of the 
same type can be created without going back to the Create menu.

The Same as button is used to obtain information from and existing string (not necessarily of the 
same type) and pipe it into the name, colour, model, style breakline type and height field of the 
Create 4d String panel.

On selecting the 4d string option, the create 4d string panel is displayed.

To create a new 4d string, the name, colour, model, point-line type, text size and units, offset, 
justification and angle for the new string are entered into the appropriate fields and the create 
button selected.

The new fields and buttons used in the create 4d string panel have the following functions.
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Field Description Type Defaults Pop-Up

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Type input line line, point

breakline type (point-line type) of the string.

Style input 1 available line styles

line style of the string.

Weight input 0

thickness of the string.

Textstyle info input

textstyle information.

Many strings tick

if tick then after the current string is finished, a new create panel is placed on the screen with all the 
same values for the panel fields as the current string.

Create button

After the create button is chosen, the 4d edit menu and 4d edit info panel are displayed.

Same as button

After the same as button is chosen, another string is selected and information about it is used for the 
fields in this panel.

4d Edit
Selecting the create button in the create 4d string panel the 4d edit menu and 4d edit info panel 
are placed on the screen.

The 4d edit menu and panel for a 4d string are

To create a new 4d string, the user must select one of the two Append options on the Append 
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walk-right of the 4d Edit menu which has options to simply create points or to create points and 
text at the points.

The Append and Append + text options are used to add points and text (in a plan view) to either 
end of an existing string, or in the case of a new string, places the 1st point and text and then 
begins appending points and text to the 1st point.

For all 4d strings, a cross is then drawn in each plan view that the string’s model is on, and the 
cross follows the cursor around the screen. If the string’s model is not added to any plan view, 
the model is automatically added to all plan views.

After the cross is on the screen (moving with the cursor), clicking LB and accepting with MB 
selects the 1st vertex of the string (using the appropriate snaps).

If Append + text was selected, the user will then be prompted for the text to be placed at that 
points.

The string and text is then drawn from the 1st vertex to the cursor position, which represents the 
second vertex of the string. Clicking LB and accepting with MB selects the second string vertex 
and the process repeats for subsequent string vertices.

Now that the string is created, all the edit option on the string’s 4d Edit menu are usable.

The options in the 4d Edit menu are not only used for placing the initial vertices of the string, but 
for editing the string once it is created. Since the Append and other options in the 4d edit menu 
are identical to the options used when editing an existing string, they will be discussed in detail 
in the string Editor section.

For full information in the 4d Editor, go to the section “4d Edit” 
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Create - Same As
create_same_as

Position of option on menu: Strings =>Create =>Same as

The same as option is used to create a new string of the same type and with similar header 
information as an existing string.

On selecting the same as create option, the create same as panel is displayed.

After selecting the option, the option is already running and waiting for a string to be selected.

Once a string is selected from a view, a new create nd string panel of the same type as the selected 
string and with all the header information from the selected string, is displayed on the screen.

The user then proceeds as a normal create string option.

If the pick is terminated by clicking RB to get up the pick ops menu and selecting cancel from it, 
the option can be started again by selecting the pick & create button.
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Editor
edit_string

Position of option on menu: Strings =>Editor

The string editor is used for modifying any of the 12d Model strings.

After selecting the editor option, the edit string panel is placed on the screen to record any error 
messages.

The option is already in pick mode (the pick & edit button only needs to be selected if the pick 
was cancelled) and the user simply picks and accepts the string to be edited. From the picked 
string’s type, the editor is able to determine the appropriate editor and placed on the screen.

Each string type has its own edit operations which will now be discussed in detail.

Note - if the edit menu is deleted from the screen using the menu delete option, it can be raised 
again by clicking RB in any view.

Please continue to the next section “Editor - Common Information” .
For the option Edit 2d, please go to the section “2d Edit” .

3d “3d Edit” 
4d “4d Edit” 
Alignment “Alignment Edit” 
Arcs “Arc Edit” 
Circles “Circle Edit” 
Feature “Feature Edit” 
Pipe “Pipe Edit” 
Polyline “Polyline Edit” 
Super “Super Edit” 
Text “Text Edit” 

Editor - Common Information

nd edit menu

After selecting the string to be edited, the menu containing the list of available edit options (the 
string’s nd edit menu) and an information panel, (the string’s nd edit info panel) are placed on the 
screen.

For example, the string edit menu and string edit info panel for a 2d string are
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Most of the options chosen from the nd edit menus repeat until cancelled by the user. That is, the 
option remains in force and can be applied repeatedly until terminated by the user.

For example, if the delete option is selected, any number of points can be deleted from the 
chosen string without re-selecting the delete option.

To select a new nd edit option, simply select the option from the nd edit menu. The current 
option is automatically terminated and the new option begun.

An option is also terminated when the entire string editing option is ended by selecting either 
the Quit or Finish button in the nd edit menu.

Info
Toggles the nd edit info panel on/off for the string.

Undo/Redo
An undo and redo list is defined for each editor on the screen. That is, each editor has its own 
undo/redo lists. If an option is undone, it is added to the redo list so that it can be redone.

When the editor is exited by either Quit or Finish, the undo and redo lists are deleted and are no 
longer usable.

Undo
Undoes the last editor operation for this string and adds it to the top of the redo list.

Redo
Redo the last editor operation that was undone for this string. Add the undone operation to the 
top of the undo list.

Quit
Even after points are created for the new string, the create process can be aborted by selecting the 
Quit option from the nd Edit menu. The option then terminates and no string is created.

The Quit option is used to terminate the nd string edit session without storing any of the edits. 
That is, the string is left as it was before the edit was begun.

After selecting the Quit option, a Yes-No-Cancel panel is displayed to confirm that the edit is to be 
ended. If yes is selected, the edits will be ignored and the unedited string kept.

Note that is it was a new string being created, the option is terminates by Quit and no string is 
created.

Finish
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The edit process is completed and the modified string stored in the given model when the Finish 
option is chosen from the nd Edit menu.

After selecting the Finish option, a Yes-No-Cancel panel is displayed to confirm that the edit is to 
be ended. If Yes is selected, the edits will be stored.

Notes

1. Depending on its breakline (point-line) type, a string with default style ("1") is displayed with 
crosses at each of its point (point type) or with straight lines joining the points (line type).

Linestyles can be defined that drawn lines between the points even though the breakline type 
is point.

2. The string points are called intersection points (IP’s).

3. The string nd Edit Info panel will not automatically appear if Display edit info is set to off in 
the System Settings tab of the Utilities =>Defaults panel.

Typed input
Typed input can be used wherever a select is required to obtain a co-ordinate. For example an 
(x,y), (x, y, z) or (chainage, height).

To start typed input, simply press <F7> and a special typed-input box appears on the screen

If the focus is on a Plan or Perspective view, then an Enter X Y Z box comes up. If the focus is on a 
Section view, then a Enter Ch Ht box appears. These are also called the XYZ typed input box and 
the Chainage Height typed input box respectively.

An <enter> terminates the typed input and the entered values taken as the position of the 
required point. The typed-input box then disappears.

If the user wishes to abort the typed input and return to mouse input, simply select the [X] 
button on the typed input box or type <enter> with no values in the typed input box.

Please continue to the next section “2d Edit” .
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2d Edit
2d_edit

Position of option on menu: Strings =>Editor

On 2d_edit_infopicking a 2d string, the 2d edit menu and the 2d edit info panel are placed on the 
screen.

See the earlier section “Editor - Common Information” for general information about editing 
strings.

Each option in the 2d edit menu will now be described.

Append
The append option is used to create the 1st point in a new string, to append a new intersect point 
to the end of the string or to prepend a new intersection point to the beginning of the string. In 
this option, both appending and prepending will be referred to as appending.

Existing 2d Strings
Appending a point is a two step process.

Step (a) - selecting the end to append the point to.

After the append option has been selected, the end of the string to append the point to is 
selected. Once the string end is selected, the new intersection point is assumed to be at the 
current cursor position. As the cursor is moved, the string is redrawn reflecting the changing 
position of the appended intersection point

message area 1 <Append Points>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for an IP
message area 4 select final position- after pick
Screen message area

<Select string end to append to> [picks][][menu]
<Select string end to append to> [picks][accepts][menu]

Step (b) - selecting the position for the new appended point.

A cross indicates where the cursor currently is. The position of the new appended point is set to 
the current cursor position by picking (LB) and accepting (MB).

message area 1 <Append Points>
message area 2 IP point number, x, y, z co-ords of IP
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message area 3 bearing-in, bearing out, bearing difference for closest IP
message area 4 select final position- before pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

Once a point has been appended to the string, the appended point is considered to be the 
selected string end and a new append cycle begins. That is, stage (a) is already set up. The 
current cursor position indicates the new position for the next appended point.

Hence a series of string points is easily entered by first selecting the string end that the new 
points are to be appended to (step (a)) and then moving the cursor to the position of each new 
point and selecting them in turn.

Typed input can be used in either step.

The append option is terminated by either bringing up the pick ops menu and selecting cancel 
or by selecting a new option from the 2d edit menu.

If, after bringing up the pick ops menu, it is decided to continue with the append option, simply 
select the restart option from the pick ops menu and the pick ops menu will disappear leaving 
the append option still current.

New 2d String
For creating a new string, the cursor is used to select the 1st point of the string. The option then 
continues as if appending to an existing 2d string where the end point has already been selected.

Move
The move option is for moving individual points (intersection points - IP’s) of the string.

The move cycle consists of two steps:

(a) selecting the point to be moved

(b) selecting the new position for the point.

Step (a)

First the point to be moved is selected. The selected point will then move around the view and 
the string redrawn to show the change as the cursor is moved.

message area 1 <Move Point>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for the closest IP
message area 4 select final position- after pick
Screen message area

<Select point to move> [picks][][menu]
<Select point to move> [picks][accepts][menu]

Step (b)

The current cursor position is selected as the new position for the point by selecting (LB) and 
accepting (MB). The point being moved is then anchored at the cursor position for the IP, and the 
string redrawn.

message area 1 <Move Point>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for the moved IP
message area 4 select final position- before pick, edit finished- after pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]
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Typed input can be used in either step.

Once the move cycle is completed and the point moved, the move option is still current and can 
be repeated for other points without having to re-select the move option.

The move option is terminated by selecting cancel from the pick ops menu or by selecting a new 
2d edit option.

Insert
The insert option is designed to place a new intersection point in a string between two adjacent 
intersection points (note that the inserted point does not have to be on the line joining the two 
intersection points).

Inserting a point, like moving a point, is a two step process.

Step (a) - selecting the IP’s to be on either side of the new intersection point

The two adjacent intersection points are chosen by selecting the line connecting the two 
intersection points. Once the line is selected, the new IP is assumed to be at the current cursor 
position. As the cursor is moved, the string is redrawn reflecting the changing position of the 
inserted IP.

message area 1 <Insert Point>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for closest IP
message area 4 select final position- after pick
Screen message area

<Select line to insert on> [picks][][menu]
<Select line to insert on> [picks][accepts][menu]

Step (b) - selecting the position for the new intersection point

The position of the new intersection point is selecting

message area 1 <Insert Point>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for the inserted IP
message area 4 select final position - before pick, edit finished - after pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

Once the insert cycle is completed and the point inserted, the insert option is still current and can 
be repeated for other insertions without having to re-select the insert option.

The insert option is terminated by selecting cancel from the pick ops menu or by selecting a new 
option from the 2d edit menu.

Typed input can be used in either step.

Between
The between option is similar to the insert option except that the inserted point does have to be 
on the line joining the two intersection points. To accomplish this, the cursor position is projected 
onto the IP-IP line to give the new IP point position.

The between option is terminated by selecting cancel from the pick ops menu or by selecting a 
new option from the 2d edit.

Delete
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The delete option is used to delete selected intersection points from the string.

The point to be deleted is picked (LB) and accepted (MB). When the point is accepted, it is 
deleted. The string, minus the deleted point, is then redrawn.

Once a point has been deleted, another point in the string can then be selected and deleted. 
Hence any number of points from the string can be deleted one after another.

message area 1 <Delete Points>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for closest IP
message area 5
Screen message area

<Select point to delete> [picks][][menu]
<Select point to delete> [picks][accepts][menu]

The delete option is terminated by selecting cancel from the pick ops menu or by selecting a 
new option from the 2d edit menu.

Typed input can be used to select a point for deletion.

Extend
The extend option is used to move an intersection point along the line joining the intersection 
point to its neighbouring intersection point.

That is, the bearing of the IP-IP line is kept constant and the intersection point is moved along 
that line either towards or away from its neighbouring intersection point on the IP-IP line.

Extending, like moving a point, is a two step process.

Step (a) - selecting the IP-IP line and the IP to be moved along that line

The IP-IP line and the intersection point to be moved are chosen in the one operation by picking 
(LB) and accepting (MB) a co- ordinate point near the IP-IP line and close to the intersection 
point to be moved along that line.

Once the line and intersection point (IP) are selected, the new position of the selected IP is 
assumed to be at the current cursor position projected perpendicularly onto the IP-IP line.

As the cursor is moved, the string is redrawn reflecting the changing position of the moved IP.

message area 1 <Extend Point>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for closest IP
message area 4 select final position- after pick
Screen message area

<Select line to extend> [picks][][menu]
<Select line to extend> [picks][accepts][menu]

Step (b) - selecting the final position for the intersection point

The final position for the intersection point is set to the projection of the selected cursor position 
onto the IP-IP line.

message area 1 <Extend Points>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for closest IP
message area 4 select final position - before pick, edit finished - after pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

Once the extend is completed, the extend option is still current and can be repeated without re-
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selecting the extend option.

The extend option is terminated by selecting cancel from the pick ops menu or by selecting a 
new option from the 2d edit menu.

Typed input can be used in either step.

Note - Extend can be used on the end points of the string 

Height
The height option is used to modify the height (z value) of the 2d string.

After the height option is chosen, an enter value typed-input box is displayed on the screen with 
the string’s current height (z value).

 The enter value typed-input box looks like:

The height is entered into the typed-input box, terminated by <enter>. The entered value is taken 
as the height of the 2dstring and the string redrawn with the new height. The typed-input box 
then disappears.

The height option automatically terminates and a new option is selected from the 2d edit.

Note - all the points in a 2d string have the same height.

Open
If the string is closed (that is, the end points have the same x and y values), selecting the open 
option removes the last point of the string.

If the string is not closed, the open option does nothing.

Close
Selecting the close option adds a point to the end of the string with the same co-ordinate values 
as the 1st point in the string.

Properties
2d_string_properties

Selecting Properties brings up the 2d String Properties panel which is used to modify the string’s 
header information.
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The fields in this panel are similar to those in the Create 2d String panel and the 2d string editor 
options. The only new field is

Field Description Type Defaults Pop-Up

Set button

for the 2d string being edited, set all the items in the 2d String Properties panel to the values given in 
the panel.
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3d Edit
3d_edit

Position of option on menu: Strings =>Editor

On 3d_edit_infopicking a 3d string, the 3d edit menu and 3d edit info panel are placed on the 
screen.

The difference between a 2d and a 3d string is that all points in a 2d string have the same z-value, 
whereas for a 3d string, each point can have a different z-value.

Hence most of the options in the 3d edit menu are similar to the 2d edit options of the same 
name, and only the differences for each option will be discussed. The 2d Edit options are given in 
the section “2d Edit”  

See the earlier section “Editor - Common Information” for general information about editing 
strings.

Append
The append operation for a 3d string is similar to that for a 2d string except that a height (z-
value) is required for each new point.

Since in most cases, it would be tiresome to ask for a height every time a point is added, the entry 
of a new height is controlled by the height toggle in the snaps menu. If height is toggled to on, 
then every time a point is placed or moved an enter height typed-input box is displayed on the 
screen.

The enter height typed-input box looks like:

The height is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the height of the 3d string point and the string redrawn with the new height at the point. 
The typed-input box then disappears.

When the enter height box is placed on the screen, it will already have a value in it depending on 
the circumstances preceding the operation.

For example, if a point or line was snapped to, the height at that point or line will be displayed in 
the box.
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Height
The height option is used to modify the height (z value) of any point in the string.

After the height option is chosen, the user must select which point is going to have its height 
modified.

After the point has been selected, an New height typed-input box is displayed on the screen 
with the point’s current height (z value).

The height is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the height of the point in the 3d string and the string redrawn with the new height at 
that point. The typed-input box then disappears.

The height option is terminated on selecting cancel from the pick ops menu or by selecting a 
new option from the 3d edit menu.

Properties
3d_string_properties

Selecting Properties brings up the 3d String Properties panel which is used to modify the string’s 
header information.

The fields in this panel are similar to those in the create 3d string panel and the 3dd string editor 
options. The only new field is

Field Description Type Defaults Pop-Up

OK/Apply button

for the string being edited, OK sets the string with the values in the panel fields and removes the panel. 
Apply sets the 3d string with the values in the panel fields and leaves the panel on the screen.
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4d Edit
4d_edit
Position of option on menu: Strings =>Editor
On picking 4d_edit_infoa 4d string, the 4d edit menu and 4d edit info panel are placed on the 
screen.

Only the options append, text, size and angle will be described in detail since all the other 
options are similar to the equivalent 3d string option (see the section “3d Edit” ).

See the earlier section “Editor - Common Information” for general information about editing 
strings.

Append
4d_append

 The append operation for a 4d string is similar to the 3d string case except that a height and an 
optional text label is required for each new point.

Since in many cases a text label is not required at every point of a 4d string, there is an append 
option that asks for text at every point and another that does not ask.

The 4d append walk-right is

The height question for each point is toggled on or off in the snaps menu just as it was for a 3d 
string.

The append option is terminated on selecting cancel from the pick ops menu or by selecting a 
new option from the 4d edit menu.

Text
The text option is used to modify the text label of any point in the 4d string.

After the text option is chosen, the user must select which point is going to have its text label 
modified. Once the point has been selected, an enter text typed-input box is displayed on the 
screen with the point's current text label placed in it.

append/prepend an IP and text
move an IP
insert an IP
insert IP on line between IP’s
delete an IP
extend an IP
modify the strings z-value
modify the text labels
set height of text labels
set angle of text labels
open/close and Properties
toggle info panel
undo/redo
quit the edit session
finish the edit session
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The new text label is entered into the typed-input box, terminated with <enter>. The entered 
value is taken as the text label of the point in the 4d string and the string redrawn with the new 
text at that point. The typed-input box then disappears.

The text option is terminated on selecting cancel from the pick ops menu or by selecting a new 
option from the 4d edit menu.

Text ht
All the text labels in the 4d string have the same height (given in pixel or world units). The text ht 
option is used to modify this text label height.

After selecting the option, an enter value typed-input box is displayed on the screen with the 
string’s current text label height placed in it.

The new text label height is entered into the typed-input box, terminated with <enter>.

The entered value is taken as the text label height for all the points in the 4d string and the string 
redrawn using the new height. The typed-input box then disappears.

The text ht option automatically terminates after use.

Angle
All the text labels in the 4d string are drawn rotated about their defining string point with the 
same rotation angle. The angle, in degrees, is measured in a counter-clockwise direction about 
the horizontal axis.

The angle option is used to modify the text rotation angle.

After selecting the option, an enter value typed-input box is displayed on the screen with the 
string’s current text rotation angle placed in it.

The new text rotation angle is entered into the typed-input box, terminated with <enter>.

The entered value is taken as the text rotation angle for all the points in the 4d string and the 
string redrawn using the new angle. The typed-input box then disappears.

The angle option automatically terminates after use.

Utilities
Position of option on menu: Strings =>Editor
4d_utilities
The 4d utilities walk-right is

Properties
4d_string_properties
Selecting Properties brings up the 4d String Properties panel which is used to modify the string’s 
header information.
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The fields in this panel are similar to those in the create 4d string panel and the 4d string editor 
options. The only new field is

Field Description Type Defaults Pop-Up

OK/Apply button

for the string being edited, OK sets the string with the values in the panel fields and removes the panel. 
Apply sets the string with the values in the panel fields and leaves the panel on the screen.
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Alignment Edit
alignment_edit

Alignment_edit_info

Position of option on menu: Strings =>Editor

 An alignment string is defined by specifying the horizontal and vertical geometry as separate 
operations.

The horizontal geometry consists of a series of (x,y) points (called horizontal intersection points, 
HIP’s) and circular curves and spirals applied to the intersection points.

Vertical geometry also consists of a series of points but they are defined with respect to the plan 
length of the string (chainage) and height. Hence, the vertical geometry is defined by a series of 
(chainage,height) points called vertical intersection points (VIP’s) and parabolic or circular 
curves applied to the vertical intersection points.

The horizontal geometry is defined in a plan view and the vertical geometry in a section view. 
Hence the alignment string editor can edit information for the string on both plan and section 
views.

Since a section view is only defined in relation to a specific string (called the primary string for 
the section view), the vertical geometry of the picked string can only be edited in a section view 
if the string is the primary string for that section view. That is, the string can only be edited on a 
section view if the string being edited is profiled on that section view.

On selecting an alignment string, the alignment edit menu and the alignment edit info are placed 
on the screen.

Most of the options are applicable to either horizontal or vertical geometry. The meaning of the 
option depends on whether the string is being edited in a plan or a section view. Hence the 
description of the option will often need to be split into its separate action on horizontal or 
vertical geometry.

append or prepend an IP
move an IP or TP
insert an IP
insert on IP-IP line
delete an IP
extend an IP
modify the strings z-value
circular curves, spirals
VG only, radius or length
interval, start ch, validate etc.
toggle edit info panel
undo/redo
quit the edit session
finish the edit session
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See the earlier section “Editor - Common Information” for general information about editing 
strings.

Each option will now be discussed in detail.

append

Append
The append operation for an alignment string is similar to the 3d string case except that there are 
separate append options for the horizontal and vertical geometry of the string.

The append walk-right is

Append HIPs - Horizontal Geometry
The append=>HIPs option in a plan view is used to create the 1st horizontal point in a new 
alignment string, to append a new horizontal intersect point to the end of the string or to 
prepend a new horizontal intersection point to the beginning of the string. In this option, both 
appending and prepending will be referred to as appending.

Existing Alignment String
Appending a point is a two step process.

Step (a) - selecting the end to append the point to.

After picking append=>HIPs, the end of the string to append the point to is selected. Once the 
string end is selected, the new intersection point is assumed to be at the current cursor position. 
As the cursor is moved, the string is redrawn reflecting the changing position of the appended 
intersection point

message area 1 <Append Points>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for an IP
message area 4 select final position - after pick
Screen message area

<Select string end to append to> [picks][][menu]
<Select string end to append to> [picks][accepts][menu]

Step (b) - selecting the position for the new appended point.

A cross indicates where the cursor currently is. The position of the new appended point is set to 
the current cursor position by picking (LB) and accepting (MB).

message area 1 <Append Points>
message area 2 IP point number, x, y, z co-ords of IP
message area 3 bearing-in, bearing out, bearing difference for closest IP
message area 4 select final position - before pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

Once an intersection point has been appended to the string, the appended intersection point is 
considered to be the selected string end and a new append cycle begins. That is, stage (a) is 
already set up. The current cursor position indicates the new position of the next appended 
intersection point.

Hence a series of string points is easily entered by first selecting the string end that the new 
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points are to be appended to (step (a)) and then moving the cursor to the position of each new 
point in turn and selecting them in turn.

Typed input can be used in either step.

The append option is terminated by either bringing up the pick ops menu and selecting cancel 
or by selecting a new option from the alignment edit menu.

If, after bringing up the pick ops menu, it is decided to continue with the append option, simply 
select the restart option from the pick ops menu and the pick ops menu will disappear leaving 
the append option still current.

New Alignment String
When the append=>HIPs option is selected, a cross will appear on any plan views that have the 
alignment string’s model on them.

The first horizontal intersection point is then selected by the standard pick (LB) and accept (MB). 

The option then continues as if appending to an existing alignment string where the end point 
has already been accepted.
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Append VIPs - Vertical Geometry
The append=>VIPs option is used to create and edit the vertical geometry of the picked string if 
the string is a primary string on any section view. This can be achieved by using either the VG 
edit or the profile option from the section view view=>utilities menu.

Vertical geometry can only be defined for a string with existing horizontal geometry.

On a section view, Append=>VIPs is used to create the first vertical intersection point in an 
existing string, to append a new vertical intersect point to the end of the string or to prepend a 
new vertical intersection point to the beginning of the string. In this option, both appending and 
prepending will be referred to as appending.

Existing Vertical Geometry

Appending a vertical point is the same as for a horizontal intersection point except that the co-
ordinate system is (chainage,height) rather than (x,y) values and the information messages 
displayed in the alignment edit info panel show chainage, height and percentage grade rather 
than x,y,z and bearings.

For example -

message area 1 <Append Points>
message area 2 VIP point number, chainage,height of VIP
message area 3 curve length, %grade-in, %grade-out, grade difference for an VIP
message area 4 edit finished - before pick       select final position - after pick

New Vertical Geometry

Creating the 1st vertical intersection point (VIP) in a string is similar to the 1st horizontal IP.

When the append=>VIPs option is selected, a cross will appear on any section views that have 
the alignment string profiled on them.

The 1st vertical intersection point is then selected by the standard pick (LB) and accept (MB). 

The option then continues as if appending to an existing vertical geometry where the end point 
has already been accepted.

Typed input can be used at any stage of the append.

Move
The move option allows the user to move

(a) individual horizontal intersection points (HIPs)

(b) individual tangent points (HTPs) if their is no spiral on the HIP.

(c) individual vertical intersection points or tangent points (VIPs or VTPs).

move acts on the horizontal geometry if the point to move is selected in a plan view, or the 
vertical geometry if the point to move is selected in a section view.

Move - Horizontal Geometry
The move option in a plan view is for moving individual horizontal intersection points (HIP’s) 
or horizontal tangent points (HTPs) of the string.

The move cycle consists of two steps:

(a)  selecting the point to be moved

(b) selecting the new position for the point.
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Step (a)

First the horizontal intersection or tangent point to be moved is selected. The selected point will 
then move around the view as the cursor is moved.

If a horizontal intersection point is selected, the string will be redrawn with the intersection 
point moved to the cursor position and the circular curve radius and spiral lengths left constant.

A horizontal tangent point only occurs on a line connecting two adjacent horizontal intersection 
points (the HIP-HIP line). Hence, a horizontal tangent point can only move along its HIP-HIP 
line. Moving a horizontal tangent point actually means that the radius of the circular curve at the 
tangent point is modified so that the new position of the point is still a tangent point on the 
HIP-HIP line for the new circular curve.

To guarantee that the new position for the tangent point is on the HIP-HIP line, the cursor 
position is automatically projected perpendicularly onto the HIP-HIP line to give the new 
tangent point.

message area 1 <Move Point>
message area 2 IP point number, x, y co-ords of IP, radius, start spiral, end spiral
message area 3 bearing-in, bearing out, bearing difference for the inserted IP
message area 4 select final position - after pick
Screen message area

<Select point to move> [picks][][menu]
<Select point to move> [picks][accepts][menu]

Step (b)

The current cursor position (or its projection for a HTP) is selected as the new position for the 
point by picking (LB) and accepting (MB). The point being moved is then anchored at the cursor 
position for the HIP (or at the projected point for a HTP), and the string redrawn.

message area 1 <Move Point>
message area 2 IP point number, x, y co-ords of IP, radius, start spiral, end spiral
message area 3 bearing-in, bearing out, bearing difference for the inserted IP
message area 4 select final position - before pick, edit finished - after pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

Typed input can be used in either step

Once the move cycle is completed and the point moved, the move option is still current and can 
be repeated for other points without having to re-select the move option.

move is terminated by selecting cancel from the pick ops menu or by selecting a new alignment 
edit option.

Move - Vertical Geometry
The move option is used in a section view to move individual vertical intersection points (VIP’s) 
or vertical tangent points (VTP’s).

The move cycle consists of two steps:

(a) selecting the point to be moved

(b) selecting the new position for the point.

Step (a)

First the vertical intersection or tangent point to be moved is selected. The selected point will 
then move around the view as the cursor is moved.

If a vertical intersection point (VIP) is selected, the string will be redrawn with the vertical 
intersection point moved to the cursor position and the parabolic curve length or the circular 
curve radius left constant.

A vertical tangent point (VTP) only occurs on a line connecting two adjacent vertical 
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intersection points (the VIP-VIP line). Hence, a vertical tangent point can only move along its 
VIP-VIP line. Moving a vertical tangent point actually means that the length of the parabolic 
curve at the vertical tangent point is modified so that the new position of the point is still a 
vertical tangent point on the VIP-VIP line for the new parabolic curve.

To guarantee that the new position for the vertical tangent point is on the VIP-VIP line, the 
cursor position is automatically projected perpendicularly onto the VIP-VIP line to give the new 
vertical tangent point.

message area 1 <Move Point>
message area 2 VIP point number, ch, ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 select final position - after pick
Screen message area

<Select point to move> [picks][][menu]
<Select point to move> [picks][accepts][menu]

Step (b)

The current cursor position (or its projection for a VTP) is selected as the new position for the 
point by selecting (LB) and accepting (MB). The point being moved is then anchored at the 
cursor position for an VIP (or at the projected point for a VTP), and the string redrawn.

message area 1 <Move Point>
message area 2 VIP point number, ch, ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 select final position - before pick, edit finished - after pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

Typed input can be used in either step.

Once the move cycle is completed and the point moved, the move option is still current and can 
be repeated for other points without having to re-select the move option.

The move option is terminated by selecting cancel from the pick ops menu or by selecting a new 
alignment edit option.

Insert
The insert option is designed to place a new intersection point in a string between two adjacent 
intersection points. The inserted point does not have to be on the line joining the two intersection 
points - the between option is used to guarantee that the IP is on the IP-IP line.

Inserting a point, like moving a point, is a two step process.

Step (a) - selecting the IP’s to be on either side of the new intersection point
The two adjacent intersection points are chosen by selecting the line connecting the two 
intersection points. Once the line is selected, the new IP is assumed to be at the current cursor 
position. As the cursor is moved, the string is redrawn reflecting the changing position of the 
inserted IP.

Like the move option, the insert works on the horizontal or the vertical geometry depending on 
whether a plan or section view is used to select the connecting line.

For horizontal inserts 
message area 1 <Insert Point>
message area 2 IP point number, x, y co-ords of IP, radius, start spiral, end spiral
message area 3 bearing-in, bearing out, bearing difference for the inserted IP
message area 4 select final position - after pick
Screen message area



12d Model Reference Manual

Page 978 May 2007Editor

<Select line to insert on> [picks][][menu]
<Select line to insert on> [picks][accepts][menu]

For vertical inserts 
message area 1 <Insert Point>
message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 select final position - after pick
Screen message area

<Select line to insert on> [picks][][menu]
<Select line to insert on> [picks][accepts][menu]

Step (b) - selecting the position for the new intersection point
The position of the new intersection point is set to the current cursor position by picking (LB) 
and accepting (MB).

horizontal

message area 1 <Insert Point>
message area 2 IP point number, x, y co-ords of IP, radius, start spiral, end spiral
message area 3 bearing-in, bearing out, bearing difference for the inserted IP
message area 4 select final position - before pick, edit finished - after pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

vertical

message area 1 <Insert Point>
message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 select final position - before pick, edit finished - after pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

Once the insert cycle is completed and the point inserted, the insert option is still current and can 
be repeated for other insertions without having to re-select the insert option.

The insert option is terminated by selecting cancel from the pick ops menu or by selecting a new 
option from the alignment edit menu.

Typed input can be used in either step.

Between
The between option is similar to the insert option except the inserted point does have to be on 
the line joining the two intersection points. To accomplish this, the cursor position is 
automatically projected onto the IP-IP line to give the new IP point position.

The between option is terminated by selecting cancel from the pick ops menu or by selecting a 
new option from the alignment edit menu.

Delete
The delete option is used to delete intersection points from the string.

After picking the delete option, any selected intersection point in the string is deleted. The string, 
minus the deleted point, is redrawn after each deletion.

Once an intersection point has been deleted, another intersection point in the selected string can 
selected for deletion. Hence any number of the string points can be deleted one after another.
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A horizontal intersection point is deleted if the point is chosen from a plan view and a vertical 
intersection point deleted if the point is selected from a vertical view.

For horizontal deletes

message area 1 <Delete Points>
message area 2 IP point number, x, y co-ords of IP, radius, start spiral, end spiral
message area 3 bearing-in, bearing out, bearing difference for the inserted IP
Screen message area

<Select point to delete> [picks][][menu]
<Select point to delete> [picks][accepts][menu]

For vertical deletes

message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
Screen message area

<Select point to delete> [picks][][menu]
<Select point to delete> [picks][accepts][menu]

The delete option is terminated by selecting cancel from the pick ops menu or by selecting a 
new option from the alignment edit menu.

Typed input can be used to select a point for deletion.

Extend
The extend option is used to move an intersection point along the line joining the intersection 
point to its neighbouring intersection point.

That is, in a plan view, the bearing of the HIP-HIP line is kept constant and the intersection point 
is moved along that line either towards or away from its neighbouring intersection point on the 
HIP-HIP line.

In a section view, the grade of the VIP-VIP line is kept constant and the vertical intersection point 
is moved along that line either towards or away from its neighbouring intersection point on the 
VIP-VIP line.

Extending, like moving a point, is a two step process.

Step (a) - selecting the IP-IP line and the IP to be moved along that line

The IP-IP line and the intersection point to be moved are chosen in the one operation by selecting 
a co- ordinate point near the IP-IP line and close to the intersection point to be moved along that 
line.

Once the line and IP are selected, the new position of the selected IP is assumed to be at the 
current cursor position projected perpendicularly onto the IP-IP line. As the cursor is moved, the 
string is redrawn reflecting the changing position of the moved IP.

For horizontal extends

message area 1 <Extend Point>
message area 2 IP point number, x, y co-ords of IP, radius, start spiral, end spiral
message area 3 bearing-in, bearing out, bearing difference for the inserted IP
message area 4 select final position - after pick
Screen message area

<Select line to extend> [picks][][menu]
<Select line to extend> [picks][accepts][menu]

For vertical extends

message area 1 <Extend Point>
message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
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message area 4 select final position - after pick
Screen message area

<Select line to extend> [picks][][menu]
<Select line to extend> [picks][accepts][menu]

Step (b) - selecting the final position for the intersection point

The final position for the intersection point is set to the projection of the current cursor position 
onto the IP-IP line.

horizontal -

message area 1 <Extend Points>
message area 2 IP point number, x, y co-ords of IP, radius, start spiral, end spiral
message area 3 bearing-in, bearing out, bearing difference for the inserted IP
message area 4 select final position - before pick, edit finished- after pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

vertical

message area 1 <Extend Points>
message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 select final position - before pick, edit finished- after pick
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

Once the extend is completed, the extend option is still current and can be repeated without re-
selecting the extend option.

The extend option is terminated by selecting cancel from the pick ops menu or by selecting a 
new option from the alignment edit menu.

Typed input can be used in either step.

Note - Extend can be used on the end points of the string 

height

Height
The height option is used to insert and/or modify the height of a vertical intersection point in a 
plan view, or to modify the height of a vertical intersection point in a section view.

Hence the height option is unique - it only affects the vertical geometry of the string but can be 
used in a plan or section view.

The height walk-right is

By Plan - Height in a Plan View
In a plan view, the height=>by plan option is used to create a vertical intersection point of a 
given height, or modify the height of an existing vertical point, at a selected plan position on the 
string.

After the height option is chosen, the user selects a position on the string in a plan view. The use 
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of point and line snap will important for selecting the correct position.

If a vertical intersection point already exists at the chainage of the selected position, it will be 
selected for modification. Otherwise a new vertical intersection point will be inserted into the 
vertical geometry at the chainage of the selected position. 

A new height typed-input box is then displayed on the screen with the vertical intersection 
point’s current height (z value).

The new height typed-input box looks like:

The height is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the new height of the vertical intersection point in the alignment.

The typed-input box then disappears.

By Section - Height in a Section View
In a section view, the height=>by section option can only be used to modify the height of an 
existing vertical intersection point.

After the height option is chosen, the user selects the vertical intersection point that will have its 
height modified from a section view. After selecting the VIP, a new height typed-input box is 
displayed on the screen with the point’s current height (z value).

 The new height typed-input box looks like:

The height is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the new height of the vertical intersection point in the alignment string and the string 
redrawn with the new height at that point.

The typed-input box then disappears.

For either height=>by plan or height=>by section, the height option is terminated on selecting 
cancel from the pick ops menu or by selecting a new option from the alignment edit menu.

curves

Curves
The curves option allows the user to

(a) add a circular curve of a specified radius or curve length to a horizontal intersection point

(b) add start and end transition spirals to an intersection point with and existing circular curve

(c) add a circular curve of a specified radius or curve length to a vertical intersection point

The Curves walk-right menu is

The radius option is used to create or modify the radius of a circular curve at a horizontal or 
vertical intersection point. radius acts on the horizontal geometry if the point is selected in a plan 
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view, or the vertical geometry if the point is selected in a section view.

Similarly the length option is used to set a circular curve by giving its total curve length rather 
than the radius. length acts on the horizontal geometry if the point is selected in a plan view, or 
the vertical geometry if the point is selected in a section view.

The spiral option is for adding transition spirals to a horizontal intersection point with a curve 
already on it.

Radius
In a plan view, the radius option is used to add a circular curve to an intersection point with no 
curve or to modify the radius of the circular curve if one already exists.

In a section view, the radius option is used to add a circular curve to an intersection point with no 
curve or to modify the radius of a circular curve if one already exists.

Radius is a two step process.

Step (a) - selecting the intersection point

First the intersection point whose curve is to be modified is selected.

For horizontal radius

message area 1 <Radius>
message area 2 IP point number, x, y co-ords of IP, radius, start spiral, end spiral
message area 3 bearing-in, bearing out, bearing difference for the inserted IP

For vertical radius

message area 1 <Radius>
message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 radius, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 enter value- after pick
Screen message area

<Select point to change radius> [picks][][menu]
<Select point to change radius> [picks][accepts][menu]

Step (b) - entering the new radius

after an intersection point is chosen, a new radius typed-input box is displayed on the screen 
with either the intersection point’s current curve radius or, if no curve exists, zero.

 The new radius typed-input box looks like:

The radius is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the radius of the curve at that intersection point and the string redrawn with the new 
curve. The typed-input box then disappears.

If an existing curve is to be removed from an intersection point, enter the value zero into the new 
radius typed-input box.

horizontal
message area 1 <Radius>
message area 2 IP point number, x, y co-ords of IP, radius, start spiral, end spiral
message area 3 bearing-in, bearing out, bearing diff for the inserted IP
message area 4 enter value - before value entered   edit finished- after value entered

vertical

message area 1 <Radius>
message area 2 VIP point number, Ch, Ht co-ords of VIP
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message area 3 radius, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 enter value - before value entered   edit finished- after value entered

Like most of the other alignment edit options, after a radius has been modified the option is still 
current and another intersection point can be chosen to have its curve radius modified.

The radius option is terminated by selecting a different alignment edit option.

Length
Although the circular curve on an intersection point is stored as a radius, it is possible to define 
the radius indirectly by giving the total curve length by using the length option.

The option works in plan or section views.

To use length, first select the intersection point to add a new circular curve to, or to modify the 
existing curve.

A new length typed-input box is then displayed on the screen with either the current curve 
length, or if no curve exists, zero.

The new length typed-input box looks like:

The total curve length is entered into the typed-input box, terminated with <enter>. The entered 
value is taken as the new curve length. The typed-input box then disappears.

If an existing circular curve is to be removed, zero is entered into the new length typed-input box.

Like most of the other alignment edit options, after the length has been modified the option is 
still current and another IP can be chosen to have its curve modified.

The length option is terminated by selecting a different alignment edit option.

WARNING - when length is used, the equivalent radius is computed and stored with the curve. 
If the IP is moved, the radius is kept constant and the total curve length is modified.

Spiral
In a plan view, the spiral option is used to add a start or end transition spiral (transition curve) to 
a curve on an intersection point, or to modify an existing spiral. Spiral does not work on a 
section view.

After picking spiral, select the end of the curve to add a new spiral to, or the existing spiral to be 
modified. A new length typed-input box is displayed on the screen with either the current spiral 
length, or if no spiral exists, zero.

The new length typed-input box looks like:

The spiral length is entered into the typed-input box, terminated with <enter>. The entered 
value is taken as the new spiral length. The typed-input box then disappears.

If an existing spiral is to be removed, zero is entered into the new length typed-input box.

Like most of the other alignment edit options, after the spiral has been modified the option is still 
current and another curve can be chosen to have its spirals modified.

The spiral option is terminated by selecting a different alignment edit option.

reverse_ip
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Reverse
12d Model normally creates a curve on the side of the IP that has the smallest angle. The sign of 
the radius (positive or negative) is automatically determined by 12d Model.

The Reverse option creates a circular curve that is the part left over from the standard curve.

On selecting Reverse, the Reverse IP panel is displayed.

The HIP is chosen by either typing in the HIP number in the IP number field, or by clicking on the 
123 button and then selecting the HIP. 

To change the curve from reversed/not reversed, simply tick on/off the Reversed tick box and 
then click on Set.

parabolas
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Parabolas
The parabolas option is for adding, removing or modifying parabolic curves to the vertical 
geometry. It allows the user to

(a) add a parabolic curve of a given curve length to a vertical intersection point

(b) add a parabolic curve of a given effective radius to a vertical intersection point

The parabolas walk-right menu is

The radius option is used to set a parabolic curve of given effective radius to a vertical 
intersection point.

The length option is used to set a parabolic curve of a given curve length to a vertical intersection 
point.

Note - the option only works on the vertical geometry if the VIP is selected in a section view. 
Points cannot be selected in any other view.

Radius
In a section view, the radius option is used to add a parabolic curve to an intersection point with 
no curve or to modify the radius of the parabolic curve if one already exists.

Radius is a two step process.

Step (a) - selecting the intersection point
First the intersection point whose parabola is to be modified is selected.

message area 1 <Radius>
message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 enter value- after pick
Screen message area

<Select point to change radius> [picks][][menu]
<Select point to change radius> [picks][accepts][menu]

Step (b) - entering the new radius

After an intersection point is chosen, a new radius typed-input box is displayed on the screen 
with either the intersection point’s current parabolic radius or, if no parabola exists, the last value 
entered into the radius typed-input box.

 The new radius typed-input box looks like:

The radius is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the radius of the parabola at that intersection point and the string redrawn with the new 
parabola. The typed-input box then disappears.

If an existing parabola is to be removed from an intersection point, enter the value zero into the 
radius typed-input box.

message area 1 <Radius>
message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 enter value - before value entered   edit finished- after value entered
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Like most of the other alignment edit options, after the radius has been modified the option is 
still current and another intersection point can be chosen to have its parabolic radius modified.

The radius option is terminated by selecting a different alignment edit option.

WARNING - when radius is used, the equivalent parabolic length is computed and stored with 
the curve. If the VIP is moved, the parabolic length is kept constant and the effective radius is 
modified.

Length
The length option is used to add a parabolic curve to a vertical intersection point with no curve 
or to modify the length of the parabolic curve if one already exists.

Adding or modifying curve length is a two step process.

Step (a) - selecting the vertical intersection point

First the vertical intersection point whose parabola is to be modified is selected.

message area 1 <Length>
message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 edit finished - before pick          enter value - after pick
Screen message area

<Select point to change length> [picks][][menu]
<Select point to change length> [picks][accepts][menu]

Step (b) - entering the new curve length

After a VIP is selected, a new length typed-input box is displayed on the screen with the point’s 
current parabolic curve length.

 The new length typed-input box looks like

The curve length is entered into the typed-input box, terminated with <enter>. The entered 
value is taken as the length of the parabolic curve at that vertical intersection point and the string 
redrawn with the new curve. The typed-input box then disappears.

If an existing parabola is to be removed from a vertical intersection point, enter the value zero 
into the curve length typed-input box.

message area 1 <Length>
message area 2 VIP point number, Ch, Ht co-ords of VIP
message area 3 VC length, %grade-in, %grade-out, grade diff for the moved VIP
message area 4 enter value- before value entered         edit finished- after value entered

Like most of the other alignment edit options, after the parabolic curve length has been modified 
the option is still current and another vertical intersection point can be chosen to have its 
parabola modified.

The length option is terminated by selecting a different alignment edit option.

alignment_utilities

Utilities
The utilities walk-right menu contains a number of useful miscellaneous option for the alignment string. 
The menu is
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Each of the options will now be discussed.

Move VIPs
move_vips

The move VIPs option is for moving a range of vertical intersection points (VIP’s) by a chainage 
or an elevation increment.

After selecting the option, the move VIPs panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Start VIP No. input

the VIP number of the 1st VIP in the range to be moved. If blank, then 1.

End VIP No. input

the VIP number of the last VIP in the range to be moved.If blank, then the last VIP.

Mode input move chainage move chainage
move hts

if move chainage, the chainage of all the points in the specified range are incremented by the given 
value. If move hts, the heights (elevations) of all the points in the specified range are incremented by 
the given value.

Value input 0

value to increment either the chainage or the height for all the VIPs in the specified range.

Move button

move the VIPs in the range given by the start and end ip field by the chainage or height given in the 
value field.
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Sort VIPs
sort_vips

The sort VIPs option is for sorting VIP’s into increasing chainage order.

After selecting the option, the sort VIPs panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Start VIP No. input

if non-blank, the VIP number of the 1st VIP in the range to be sorted. If blank, then 1.

End VIP No. input

the VIP number of the last VIP in the range to be sorted. If blank, then the last VIP.

Sort button

sort the VIPs in the range given by the start and end ip field into chainage order.

Chainage Insert
chainage_insert_vip

The chainage insert option inserts a vertical intersection point (VIP) at a given chainage and 
height.

After selecting the option, the chainage insert VIP panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Ch ht input

the chainage and height of the VIP to insert - separate values by spaces.

Insert button

insert the VIP point given in the Ch ht field into the alignment string.
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Grade Insert
grade_insert_vip

The grade insert option inserts a VIP at a given grade from an existing VIP. The new VIP position 
is given by either a distance from the picked VIP or at given chainage.

After selecting the option, the grade insert VIP panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Start VIP # input

the VIP number whose position is used to start the grade insert from.

Grade input

percent grade to be used.

Note  positive is up when going in the direction of increasing chainage and
negative is up when going in the direction of decreasing chainage.

Mode choice distance distance, chainage

if distance, the new VIP is inserted at the given grade and distance (given in the value field) from the 
start VIP.
if chainage, the new VIP is inserted at the chainage (given in the value field but having the given grade 
from the start VIP.

Insert button

insert the new VIP into the alignment string.

Grades Intersect
grade_intersect_vips

The grades intersect option inserts a VIP which is given by intersecting lines of given grades 
from two existing VIPs. The grades are either typed in or calculated by giving another VIP that 
the line goes through.

After selecting the option, the grades intersect VIPs panel is displayed.
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The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Start VIP # input

the VIP number which is used in defining a line.

Mode choice grade grade, VIP #

if grade, the field value is a percent grade and a line is defined as going through the start VIP and with 
the given grade.
if VIP #, the field value is the number of a VIP and a line is defined as going through the start VIP and 
this VIP.

Note for grades     positive is up when going in the direction of increasing chainage and
   negative is up when going in the direction of decreasing chainage.

Value input

if mode is grade, value is a percent grade.
if mode is VIP #, value is the number of a VIP.

Insert button

calculate the point which is the intersection of the two lines and insert it as a new VIP into the 
alignment string.

Interval
Each alignment string has a chainage interval that is used to define regular points along the 
string. The chainage interval is used for approximation the alignment in operations such as 
triangulating and applying templates to an alignment string.

After selecting the option, an enter value typed-input box is displayed on the screen with the 
string’s current chainage interval placed in it.

The new chainage interval is entered into the typed-input box, terminated with <enter>. The 
typed-input box then disappears.

The interval option terminates after use.

Start Chainage
Each alignment string has a start chainage which can be positive, negative or zero.

After selecting the option, an enter value typed-input box is displayed on the screen with the 
string’s current start chainage in it.

The new start chainage is entered into the typed-input box, terminated with <enter>. The typed-
input box then disappears.

When a new start chainage is entered, the vertical intersection points are automatically moved so 
that they retain their same relative chainage with respect to the start point on the alignment.

The start chainage option terminates after use.

Regenerate
If the horizontal geometry of an alignment string is modified, then the profile through any 
triangulations would also change. Hence, if the alignment string being edited was profiled on 
any section views, then the profile would be need to be recalculated after any horizontal 
geometry changes.

On selecting the regenerate option, any section view that has the alignment string being edited 
as its primary string (that is, as the string defining the chainage for the section view) is 
automatically re-profiled.
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Hence the regenerate option is equivalent to running the regenerate option for each section 
view with the edited alignment string as its primary string.
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Validate
When constructing horizontal and vertical geometry, it is possible to end of with invalid 
constructs such as overlapping tangent points.

On selecting the validate option, the alignment string will be checked for 

horizontal geometry checks

▲ at least two horizontal intersection points

▲ no co-incident horizontal intersection points

▲ no overlapping horizontal tangent points

vertical geometry checks

▲ at least two vertical intersection points

▲ no co-incident vertical intersection points

▲ no overlapping vertical tangent point

▲ vertical intersection points chainages are in ascending order

errors
If any errors occur, an errors menu is placed on the screen.

The errors menu remains on the screen and only disappears when either the [X] is picked or one 
of the error messages is picked with LB.

Note - the validate option is automatically run when the edit is finished.

Clear VG and Clear HG
clear_horizontal_geometry
clear_vertical_geometry

The Clear VG and Clear HG options are used to delete all the horizontal and/or vertical 
intersection points in the string.

The Clear VG option removes all the vertical geometry from the string.

The horizontal geometry still exists plus all the other string properties (model, name, colour and 
type).

The Clear HG option removes all the horizontal and vertical geometry from the string.
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The string still exists and keeps its other properties such as model, name, colour and type.

After a Clear, the horizontal or vertical geometry can be re- entered using the edit options.
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Properties
alignment_string_properties

Selecting Properties brings up the Alignment String Properties panel which is used to modify the 
string’s header information.

The fields in this panel are similar to those in the Create Alignment String panel and the 
alignment string editor options. The only new field is

Field Description Type Defaults Pop-Up

Draw ips tick tick

if tick, the horizontal and vertical intersection points are draw on plan and section views.
If no tick, the ips are not draw on the plan and section views.

OK/Apply button

for the string being edited, OK sets the string with the values in the panel fields and removes the panel. 
Apply sets the string with the values in the panel fields and leaves the panel on the screen.

Finish
The finish option is used to terminate the alignment string edits. After selecting the finish option, 
the string is checked for overlapping horizontal or vertical tangent points and any errors 
reported.



Chapter 14  Strings

May 2007 Page 995Editor

Arc Edit
arc_edit arc_edit_info

On picking an arc string, the arc edit menu and arc edit info panel are placed on the screen.

Each option in the arc edit menu will now be described.

See the earlier section “Editor - Common Information” for general information about editing 
strings.

Height
The height option is used to define the z-value at the start or end point of the arc.

The z-value at any point on the arc is an interpolation on arc length of the values at the end 
points. Hence, the arc is an arc in plan only - in three dimensions, it is a helix.

Height is a two step process.

Step (a) - selecting the start or end point of the arc

After picking height, the end point of the arc whose height is to be modified is selected.

message area 1 <Height of arc>
Screen message area

<Select point to change height> [picks][][menu]
<Select point to change height> [picks][accepts][menu]

Step (b) - entering the new height

After the start or end point of the arc is selected, an enter value typed-input box is placed on the 
screen with the points current height displayed in it.

The enter value typed-input box looks like:

The new height for the point is entered into the typed-input box, terminated with <enter>. The 
typed-input box then disappears.

The height option repeats until cancelled by the user by either bringing up the pick ops menu 
and selecting cancel or by selecting a new option from the arc edit menu.

If, after bringing up the pick ops menu, it is decided to continue with the height option, simply 
select the restart option from the pick ops menu and the pick ops menu will disappear leaving 
the height option still current.
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Typed Radius
The typed radius option is used to modify the radius of the selected arc.

After the typed radius option is chosen, an enter value typed-input box is placed on the screen 
with the arcs current radius displayed in it.

The enter value typed-input box looks like:

The arc radius is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the radius of the arc and the arc is redrawn with its new radius.

The typed-input box then disappears.

The typed radius option is automatically terminated and a new option needs to be selected from 
the arc edit menu.

Sweep Angle
The sweep angle option is used to modify the sweep angle of the selected arc.

After the sweep angle option is chosen, an enter value typed-input box is placed on the screen 
with the arcs current sweep angle displayed in it.

The enter value typed-input box looks like:

The arc sweep angle is entered into the typed-input box, terminated with <enter>. The entered 
value is taken as the sweep angle of the arc and the arc is redrawn with its new sweep angle.

The typed-input box then disappears.

The sweep angle option is automatically terminated and a new option needs to be selected from 
the arc edit menu.

Chainage interval
The ch interval option is used to modify the chainage interval of the selected arc.

After the ch interval option is chosen, an enter value typed-input box is placed on the screen 
with the arcs current chainage interval displayed in it.

The enter value typed-input box looks like:

The new chainage interval is entered into the typed-input box, terminated with <enter>. The 
entered value is taken as the chainage interval of the arc and the arc is redrawn with its new 
chainage interval.

The typed-input box then disappears.

The ch interval option is automatically terminated and a new option needs to be selected from 
the arc edit menu.
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Move End
The move end option is used to re-position either the start or the end point of the arc.

Move end is a two step process.

Step (a) - selecting the start or end point of the arc
After selecting the move end option, the end point to be move is selected.

message area 1 <Move End>
Screen message area

<Select point to move> [picks][][menu]
<Select point to move> [picks][accepts][menu]

Step (b) - selecting the new position for the end point
After selecting the end point to move, the new position for the end point is selected.

message area 1 <Move End>
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

The move end option repeats until cancelled by the user by either bringing up the pick ops menu 
and selecting cancel or by selecting a new option from the arc edit menu.

If, after bringing up the pick ops menu, it is decided to continue with the move end option, 
simply select the restart option from the pick ops menu and the pick ops menu will disappear 
leaving the move end option still current.

Radius
The radius option is used to change the radius of the arc by leaving the centre point alone and re-
positioning a point on the arc. The new position for the point will define a new radius for the arc.

Radius is a two step process.

Step (a) - selecting the point on the arc to move
After selecting the radius option, the point on the arc to be moved is selected.

message area 1 <Radius>
Screen message area

<Select point to move> [picks][][menu]
<Select point to move> [picks][accepts][menu]

Step (b) - selecting the new position for the point
After selecting the point to move, the new position for the point is selected.

message area 1  <Radius>
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

The radius option repeats until cancelled by the user by either bringing up the pick ops menu 
and selecting cancel or by selecting a new option from the arc edit menu.

If, after bringing up the pick ops menu, it is decided to continue with the radius option, simply 
select the restart option from the pick ops menu and the pick ops menu will disappear leaving 
the radius option still current.
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Move
The move option is used to change the position of the entire arc by selecting and moving the arc 
centre or any point on the arc.

Move is a two step process.

Step (a) - selecting the point on the arc to move
After selecting the move option, the point on the arc to move is selected.

message area 1 <Move>
Screen message area

<Select point to move> [picks][][menu]
<Select point to move> [picks][accepts][menu]

Step (b) - selecting the new position for the point

After selecting the point to move, the new position for the point is selected.

message area 1 <Move>
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

The move option repeats until cancelled by the user by either bringing up the pick ops menu and 
selecting cancel or by selecting a new option from the arc edit menu.

If, after bringing up the pick ops menu, it is decided to continue with the move option, simply 
select the restart option from the pick ops menu and the pick ops menu will disappear leaving 
the move option still current.

Properties
arc_string_properties
Selecting Properties brings up the Arc String Properties panel which is used to modify the string’s 
header information.

The fields in this panel are similar to those in the create arc string panel and the arc editor 
options. The only new field is

Field Description Type Defaults Pop-Up

OK/Apply button

for the string being edited, OK sets the string with the values in the panel fields and removes the panel. 
Apply sets the string with the values in the panel fields and leaves the panel on the screen.
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Circle Edit
circle_edit circle_edit_info
On picking a circle string, the circle edit menu and circle edit info panel are placed on the screen.

Each option in the circle edit menu will now be described.

See the earlier section “Editor - Common Information” for general information about editing 
strings.

Height
The height option is used to define the z-value for the entire circle.

After selecting the height option, an enter value typed-input box is placed on the screen with the 
circles current height displayed in it.

The enter value typed-input box looks like:

The new height for the circle is entered into the typed-input box, terminated with <enter>.

The typed-input box then disappears.

The height option is automatically terminated and a new option needs to be selected from the 
circle edit menu.

Typed Radius
The typed radius option is used to modify the radius of the selected circle.

After the typed radius option is chosen, an enter value typed-input box is placed on the screen 
with the circles current radius displayed in it.

The enter value typed-input box looks like:

The circle radius is entered into the typed-input box, terminated with <enter>. The entered value 
is taken as the radius of the circle and the circle redrawn with its new radius.

The typed-input box then disappears.

The typed radius option is automatically terminated and a new option needs to be selected from 
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the circle edit menu.
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Radius
The radius option is used to change the radius of the circle by leaving the centre point alone and 
re-positioning a point on the circle. The new position for the point will define a new radius for 
the circle.

Radius is a two step process.

Step (a) - selecting the point on the circle to move
After selecting the radius option, the point on the circle to be moved is selected.

message area 1 <Radius>
Screen message area

<Select point to move> [picks][][menu]
<Select point to move> [picks][accepts][menu]

Step (b) - selecting the new position for the point
After selecting the point to move, the new position for the point is selected.

message area 1 <Radius>
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

The radius option repeats until cancelled by the user by either bringing up the pick ops menu 
and selecting cancel or by selecting a new option from the circle edit menu.

If, after bringing up the pick ops menu, it is decided to continue with the radius option, simply 
select the restart option from the pick ops menu and the pick ops menu will disappear leaving 
the radius option still current.

Chainage Interval
The ch interval option is used to modify the chainage interval of the selected circle.

After the ch interval option is chosen, an enter value typed-input box is placed on the screen 
with the circles current chainage interval displayed in it.

The enter value typed-input box looks like:

The new chainage interval is entered into the typed-input box, terminated with <enter>. The 
entered value is taken as the chainage interval of the circle.

The typed-input box then disappears.

The ch interval option is automatically terminated and a new option needs to be selected from 
the circle edit menu.
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Move
The move option is used to change the position of the entire circle by selecting and moving the 
circle centre or any point on the circle.

Move is a two step process.

Step (a) - selecting the point on the circle to move
After selecting the move option, the point on the circle to move is selected.

message area <Move>
Screen message area

<Select point to move> [picks][][menu]
<Select point to move> [picks][accepts][menu]

Step (b) - selecting the new position for the point

After selecting the point to move, the new position for the point is selected.

message area 1 <Move>
Screen message area

<Select final position of point> [picks][][menu]
<Select final position of point> [picks][accepts][menu]

The move option repeats until cancelled by the user by either bringing up the pick ops menu and 
selecting cancel or by selecting a new option from the circle edit menu.

If, after bringing up the pick ops menu, it is decided to continue with the move option, simply 
select the restart option from the pick ops menu and the pick ops menu will disappear leaving 
the move option still current.

Note - the centre point of the circle can be selected and moved with the move option.

Properties
circle_string_properties
Selecting Properties brings up the Circle String Properties panel which is used to modify the string’s 
header information.

The fields in this panel are similar to those in the create circle string panel and the circle editor 
options. The only new field is

Field Description Type Defaults Pop-Up

Set button

for the circle being edited, set all the items in the circle string Properties panel to the values given in 
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the panel.
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Feature Edit
feature_edit feature_edit_info
On picking a feature string, the feature edit menu and panel are placed on the screen.

Each option in the feature edit menu is identical to those from the circle edit menu and will not 
be described again. See the section “Circle Edit” 

See the earlier section “Editor - Common Information” for general information about editing 
strings.

Pipe Edit
pipe_edit pipe_edit_info__pipe__pipe_
On picking a pipe string, the pipe edit menu and panel are placed on the screen.

The only difference between a 3d and a pipe string is that the pipe string has a diameter.

Hence most of the options in the pipe edit menu are similar to the 3d edit options of the same 
name, and only the diameter and Properties options need to be discussed. See the section “3d 
Edit” for information on the 3d string editor.

See the earlier section “Editor - Common Information” for general information about editing 
strings.

Diameter
The diameter option is used to modify the diameter of the pipe string.

After the diameter option is chosen, an enter value typed-input box is displayed on the screen 
with the string's current diameter.
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 The enter value typed-input box looks like:

The diameter is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the diameter of the pipe string. The typed-input box then disappears.

The diameter option automatically terminates and a new option is selected from the pipe edit 
menu.

Note - the pipe string has only one diameter for the entire string.

Properties
pipe_string_properties
Selecting Properties brings up the Pipe String Properties panel which is used to modify the string’s 
header information.

The fields in this panel are similar to those in the create pipe string panel and the 3d string editor 
options. The only new field is

Field Description Type Defaults Pop-Up

OK/Apply button

for the string being edited, OK sets the string with the values in the panel fields and removes the panel. 
Apply sets the string with the values in the panel fields and leaves the panel on the screen.
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Polyline Edit
polyline_edit polyline_edit_info
On picking a polyline string, the polyline edit menu and polyline edit info panel are placed on the screen.

The major difference between a polyline and a 3d string is that a polyline string can have an arc 
instead of a line joining adjacent string points. Hence most of the options in the polyline edit 
menu are similar to the 3d edit options of the same name, and only the differences for each 
option will be discussed. See the section “3d Edit” for information on the 3d string editor.

See the earlier section “Editor - Common Information” for general information about editing 
strings.

Append
polyline_appendThe append operation for a polyline string is similar to the 3d string case except 
that an arc radius can be given for each new line segment.

Since in many cases an arc radius is not required at every segment of a polyline string, there is an 
append option that asks for the radius at every point and another that does not ask.

The append walk-right is

If the append + radius option selected, then before each point is appended, an enter radius 
typed-input box is placed on the screen.

The enter radius typed-input box looks like

The radius is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the radius of the arc to the next polyline string point and the arc will be drawn correctly 
as the cursor is moved to the next point.

A radius value of 0 is taken to mean no arc.

The height question for each point is toggled on/off in the snaps menu just as it was for a 3d 
string.
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The append option is terminated on selecting cancel from the pick ops menu or by selecting a 
new option from the polyline edit menu

Extend
polyline_extend

There are two extend options for a polyline string - extend=>extend that is identical to the 3d 
string case where the z-value of the point being extended is kept constant, and a second option, 
extend=>extend ht where the z-value of the point being extended is linearly interpolated by the 
extension distance.

The extend walk-right is

Extend
extend=>extend that is identical to the 3d string case where the z-value of the point being 
extended is kept constant.

Extend by ht
extend=>extend ht not only moves the point but also linearly interpolates the z-value of the 
point being extended.

Radius
change_radius
Selecting radius brings up the change radius panel which is used to modify the radius of any arc/line 
joining adjacent polyline points.

After selecting the radius option, the user selects the arc/straight to be modified and the current 
arc radius and bulge setting will be displayed in the change radius panel.

New values can then be entered and the arc modified by selecting the set button.

If the radius is positive, the arc is drawn from the start point to the next point on the polyline in a 
clockwise direction. If the radius is negative, the arc is drawn from the start point to the next 
point on the polyline in a counter-clockwise direction. 

For a given radius (positive or negative), there are two possible cases for the arc- one where the 
arc is less than a semi-circle, the other when the arc is greater than a semi-circle.

If bulge is turned on, the larger arc is used. The default is bulge turned off.
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Utilities
polyline_utilities
The utilities walk-right menu contains a number of useful miscellaneous option for the polyline string. The 
menu is

Each of the new options will now be discussed.

Ins 3 Pt Curve
The Ins 3 Pt Curve option is used to insert a curve through three adjacent polyline points.

After selecting the option, the middle IP of the three adjacent polyline points is selected. 

When the IP is accepted, the radius required to fit a curve through the IP and the two adjacent 
IP’s is calculated, and this radius is then applied to the segments joining the adjacent IP’s.

Del 3 Pt Curve
The del 3 pt curve option is used to delete the curves on either side of a polyline point.

After selecting the option, an IP is selected and when the IP is accepted, the radii of the segments 
on either side are set to zero.

Hence the curves on either side of the IP are effectively removed.

Properties
polyline_string_properties
Selecting Properties brings up the Polyline String Properties panel which is used to modify the string’s 
header information.

Arc with bulge on

Arc with bulge off (default)

Arcs with same radius but with bulge on or off
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The fields in this panel are similar to those in the create polyline string panel and the polyline 
string editor options. The only new field is

Field Description Type Defaults Pop-Up

OK/Apply button

for the string being edited, OK sets the string with the values in the panel fields and removes the panel. 
Apply sets the string with the values in the panel fields and leaves the panel on the screen.
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Super Edit
super_edit super_edit_info
On picking a super string, the Super Edit menu and Super Edit Info panel are placed on the screen.

The super string is similar to a polyline string in that it can have an arc instead of a line joining 
adjacent string points. Hence most of the options in the super edit menu are similar to the 
polyline edit options of the same name, and only the differences for each option will be 
discussed.

See the earlier section “Editor - Common Information” for general information about editing 
strings.

super_append

Append
The Append operation for a super is the same as the polyline case and an arc radius can be given 
for each new line segment.

Since in many cases an arc radius is not required at every segment of a super string, there is an 
append option that asks for the radius at every point and another that does not ask.

The append walk-right is

If the Append + Radius option selected, then before each vertex is appended, an enter radius 
typed-input box is placed on the screen.

The enter radius typed-input box looks like

The radius is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the radius of the arc to the next super string vertex and the arc will be drawn correctly as 
the cursor is moved to the next vertex.

A radius value of 0 is taken to mean no arc.

The height question for each vertex is toggled on/off in the snaps menu just as it was for a 
polyline string.



Chapter 14  Strings

May 2007 Page 1011Editor

The Append option is terminated on selecting Cancel from the Pick Ops menu or by selecting a 
new option from the Super Edit menu

polyline_extend

Extend
There are two extend options for a polyline string - Extend=>Extend that is identical to the 3d 
string case where the z-value of the point being extended is kept constant, and a second option, 
Extend=>Extend Ht where the z-value of the point being extended is linearly interpolated by the 
extension distance.

The Extend walk-right is

Extend
Extend=>Extend that is identical to the 3d string case where the z-value of the point being 
extended is kept constant.

Extend by Ht
Extend=>Extend Ht not only moves the point but also linearly interpolates the z-value of the point 
being extended.

Please continue to the next section “Vertex” .

super_vertex

Vertex
The Vertex menu contains options to modify information at any vertex of the super string.

The Vertex walk-right is

Height
super_vertex_height
Selecting Vertex=>Height brings up the Super Vertex Height panel which is used to set the height 
value for vertices.
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As soon as Height is chosen, a <Select vertex> [Picks][][Menu] message is written to the Status Bar 
and vertices can be selected.

When the vertex to modify is selected, its vertex number, height mode and height are written to the 
appropriate panel fields. The values and modes can be changed and either OK or Apply selected 
to change the values of the vertex.

Another vertex can then be selected or the Prev and Next buttons used to move to adjacent 
vertices.

The fields and buttons used in the Super Vertex Height panel have the following functions.

Field Description Type Defaults Pop-Up

Vertex no. input selected vertex

if a vertex is selected, then its vertex number is displayed in this field. A number can also be typed in 
and any information in the panel will then be applied to that vertex if OK or Apply is selected.

Prev button

move to the previous vertex (predecessor). The information for the previous vertex is displayed in the 
panel fields. 

Next button

move to the next vertex (successor). The information for the next vertex is displayed in the panel fields. 

Height mode input no z, entire string, each 
vertex

if no z, there is no z value for the vertex.
if entire string, then the string has the same z value for each vertex.
if each vertex, then each vertex has a separate z value.

Height input height of vertex/string

the height used for the vertex or for the entire string.

OK/Apply button

for the vertex being edited, OK sets the vertex/string with the values in the panel fields and removes the 
panel. Apply sets the vertex/string with the values in the panel fields and leaves the panel on the 
screen.

Tinable
super_vertex_tinable
Selecting Vertex=>Tinable brings up the Super Vertex Tinable panel which is used to set the 
tinable flag for vertices.
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As soon as Tinable is chosen, a <Select vertex> [Picks][][Menu] message is written to the Status Bar 
and vertices can be selected.

When the vertex to modify is selected, its vertex number and tinable flag are displayed in the panel. 
The tinable flag can be changed and either OK or Apply selected to change the tinable flag of the 
vertex.

Another vertex can then be selected or the Prev and Next buttons used to move to adjacent 
vertices.

The fields and buttons used in the Super Vertex Tinable panel have the following functions.

Field Description Type Defaults Pop-Up

Vertex no. input selected vertex

if a vertex is selected, then its vertex number is displayed in this field. A number can also be typed in 
and any information in the panel will then be applied to that vertex if OK or Apply is selected.

Prev button

move to the previous vertex (predecessor). The information for the previous vertex is displayed in the 
panel fields. 

Next button

move to the next vertex (successor). The information for the next vertex is displayed in the panel fields. 

Tinable tick

if tick, the vertex is included in tins.
if not tick, then the vertex is ignored when triangulating.

OK/Apply button

for the vertex being edited, OK sets the vertex/string with the values in the panel fields and removes the 
panel. Apply sets the vertex/string with the values in the panel fields and leaves the panel on the 
screen.

Visible
super_vertex_visable
Selecting Vertex=>Visible brings up the Super Vertex Visible panel which is used to set the 
visibility flag for vertices.
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As soon as Visible is chosen, a <Select vertex> [Picks][][Menu] message is written to the Status Bar 
and vertices can be selected.

When the vertex to modify is selected, its vertex number and visibility flag are displayed in the 
panel. The visibility flag can be changed and either OK or Apply selected to change the visibility 
flag of the vertex.

Another vertex can then be selected or the Prev and Next buttons used to move to adjacent 
vertices.

The fields and buttons used in the Super Vertex Visible panel have the following functions.

Field Description Type Defaults Pop-Up

Vertex no. input selected vertex

if a vertex is selected, then its vertex number is displayed in this field. A number can also be typed in 
and any information in the panel will then be applied to that vertex if OK or Apply is selected.

Prev button

move to the previous vertex (predecessor). The information for the previous vertex is displayed in the 
panel fields. 

Next button

move to the next vertex (successor). The information for the next vertex is displayed in the panel fields. 

Visible tick

if tick, the vertex is visible.
if not tick, then the vertex is invisible.

OK/Apply button

for the vertex being edited, OK sets the vertex/string with the values in the panel fields and removes the 
panel. Apply sets the vertex/string with the values in the panel fields and leaves the panel on the 
screen.

Point no
super_vertex_point_id
Selecting Vertex=>Point no brings up the Super Vertex Point Number panel which is used to set the 
point numbers for vertices.
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As soon as Point no is chosen, a <Select vertex> [Picks][][Menu] message is written to the Status 
Bar and vertices can be selected.

When the vertex to modify is selected, its vertex number and point number are displayed in the 
panel. The point number can be changed and either OK or Apply selected to change the point 
number of the vertex.

Another vertex can then be selected or the Prev and Next buttons used to move to adjacent 
vertices.

The fields and buttons used in the Super Vertex Visible panel have the following functions.

Field Description Type Defaults Pop-Up

Vertex no. input selected vertex

if a vertex is selected, then its vertex number is displayed in this field. A number can also be typed in 
and any information in the panel will then be applied to that vertex if OK or Apply is selected.

Prev button

move to the previous vertex (predecessor). The information for the previous vertex is displayed in the 
panel fields. 

Next button

move to the next vertex (successor). The information for the next vertex is displayed in the panel fields. 

Point no. input point no of vertex

the point number used for the vertex.

OK/Apply button

for the vertex being edited, OK sets the vertex/string with the values in the panel fields and removes the 
panel. Apply sets the vertex/string with the values in the panel fields and leaves the panel on the 
screen.

Text
super_vertex_text
Selecting Vertex=>Text brings up the Super Vertex Text panel which is used to set the text for 
vertices.
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As soon as Text is chosen, a <Select vertex> [Picks][][Menu] message is written to the Status Bar 
and vertices can be selected.

When the vertex to modify is selected, its vertex number, text mode and text are written to the 
appropriate panel fields. The values and modes can be changed and either OK or Apply selected 
to change the values of the vertex.

Another vertex can then be selected or the Prev and Next buttons used to move to adjacent 
vertices.

The fields and buttons used in the Super Vertex Text panel have the following functions.

Field Description Type Defaults Pop-Up

Vertex no. input selected vertex

if a vertex is selected, then its vertex number is displayed in this field. A number can also be typed in 
and any information in the panel will then be applied to that vertex if OK or Apply is selected.

Prev button

move to the previous vertex (predecessor). The information for the previous vertex is displayed in the 
panel fields. 

Next button

move to the next vertex (successor). The information for the next vertex is displayed in the panel fields. 

Text mode input no text, entire string, each 
vertex

if no text, there is no text for the vertex.
if entire string, then the string has the same text for each vertex.
if each vertex, then each vertex has a separate text value.

Text input text of vertex/string

the text used for the vertex or for the entire string.

OK/Apply button

for the vertex being edited, OK sets the vertex/string with the values in the panel fields and removes the 
panel. Apply sets the vertex/string with the values in the panel fields and leaves the panel on the 
screen.

Text Info
super_vertex_annotate
Selecting Vertex=>Text info brings up the Super Vertex Annotate panel which is used to set the 
annotation styles for the text at vertices.
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As soon as Text info is chosen, a <Select vertex> [Picks][][Menu] message is written to the Status 
Bar and vertices can be selected.

When the vertex to modify is selected, its vertex nunber, annotate mode and annotation information 
are written to the appropriate panel fields. The values and modes can be changed and either OK 
or Apply selected to change the values of the vertex.

Another vertex can then be selected or the Prev and Next buttons used to move to adjacent 
vertices.

The fields and buttons used in the Super Vertex Annotate panel have the following functions.

Field Description Type Defaults Pop-Up

Vertex no. input selected vertex

if a vertex is selected, then its vertex number is displayed in this field. A number can also be typed in 
and any information in the panel will then be applied to that vertex if OK or Apply is selected.

Prev button

move to the previous vertex (predecessor). The information for the previous vertex is displayed in the 
panel fields. 

Next button

move to the next vertex (successor). The information for the next vertex is displayed in the panel fields. 

Annotate mode input no annotation, entire string, each 
vertex

if no annotation, then the text at the vertex is not displayed.
if entire string, then the same annotation settings are used for each vertex.
if each vertex, then each vertex has separate annotations settings.

Text style input 1  available text styles

text style for the text at the vertex.

Text units input pixels  pixels, world

units for the height of the text.

Height (u) input

height of the text (in text units).

X factor input 1

x factor of the text.

Offset (u) input 0

distance (in text units) to offset the text from its (x,y) placement position.

Raise (u) input 0

distance (in text units) to raise the text above the line for its (x,y) placement position.
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Justify input  bottom-left  bot-left/cent/right,
mid-left/cent/right
top-left/cent/right

text justification (about the offset position).

Angle input

angle of the text.

Slant input 0

slant, in degrees, of the text.

Colour input available colours

colour of the text.

OK/Apply button

for the vertex being edited, OK sets the vertex/string with the values in the panel fields and removes the 
panel. Apply sets the vertex/string with the values in the panel fields and leaves the panel on the 
screen.

Symbol Info
super_vertex_symbol
Selecting Vertex=>Symbol info brings up the Super Vertex Symbol panel which is used to set 
symbols and their display parameters at vertices.

As soon as Symbol info is chosen, a <Select vertex> [Picks][][Menu] message is written to the 
Status Bar and vertices can be selected.

When the vertex to modify is selected, its vertex nunber, symbol mode and symbol information are 
written to the appropriate panel fields. The values and modes can be changed and either OK or 
Apply selected to change the values for the vertex.

Another vertex can then be selected or the Prev and Next buttons used to move to adjacent 
vertices.

The fields and buttons used in the Super Vertex Symbol panel have the following functions.

Field Description Type Defaults Pop-Up

Vertex no. input selected vertex

if a vertex is selected, then its vertex number is displayed in this field. A number can also be typed in 
and any information in the panel will then be applied to that vertex if OK or Apply is selected.
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Prev button

move to the previous vertex (predecessor). The information for the previous vertex is displayed in the 
panel fields. 

Next button

move to the next vertex (successor). The information for the next vertex is displayed in the panel fields. 

Symbol mode input no symbol, entire string, each 
vertex

if no symbol, then there is no symbol at the vertex.
if entire string, then the same symbol and settings are used for each vertex.
if each vertex, then each vertex has separate symbols and settings.

Symbol style input 1  available line styles

line style for the symbol at the vertex.

Symbol rotation input

rotation angle of the symbol.

Symbol size (u) input

size of the symbol (in xxx units).

Symbol offset (u) input 0

distance (in xxx units) to offset the symbol from its (x,y) placement position.

Symbol raise (u) input 0

distance (in xxx units) to raise the symbol above the line for its (x,y) placement position.

Symbol colour input available colours

colour of the symbol if none is defined in the symbol definition

OK/Apply button

for the vertex being edited, OK sets the vertex/string with the values in the panel fields and removes the 
panel. Apply sets the vertex/string with the values in the panel fields and leaves the panel on the 
screen.

Attributes
super_vertex_user_attributes
Selecting Vertex=>Attributes brings up the Super Vertex User Attributes panel which is used to 
display and edit user defined attributes at vertices of the super string.
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The Prev and Next buttons are used to cycle through and display the attributes for each vertex in 
the super string in the Name/Type/Data grid.

The data in the Name/Type/Data grid can be deleted, modified or added to and then updated for 
the vertex using the OK or Apply button.

The fields and buttons used in the Super Vertex User Attributes panel have the following 
functions.

Field Description Type Defaults Pop-Up

Vertex no. input selected vertex

when the option starts, the user attributes for the first vertex is displayed. The Next and Prev buttons 
will move onto other vertices. Also a number can be typed into the field and any information in the 
panel will then be applied to that vertex if OK or Apply is selected. Typing <Enter> after entering a 
number will go to that vertex number and display the attributes.

Prev button

move to the previous vertex (predecessor). The information for the previous vertex is displayed in the 
panel fields. 

Next button

move to the next vertex (successor). The information for the next vertex is displayed in the panel fields. 

Attribute mode choice box no attributes, each vertex

if no attributes, then no vertices have user attributes.
if each vertex, then each vertex can have user attributes.
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Name/Type/Data Grid

Name input

name for the user attribute. This must be unique for all attributes at this vertex.

Type choice box integer, real, text

type of the attribute.

Data input

value for the attribute.

OK/Apply button

for the vertex being edited, OK sets the vertex with the values in the panel fields and removes the panel. 
Apply sets the vertex with the values in the panel fields and leaves the panel on the screen.

Vertex - All above
super_vertex_properties
Selecting Vertex=>All above brings up the Super Vertex Properties panel which is used to display 
all the properties for a vertex.

This option is also available from the Strings menu 

Position of option on menu: Strings =>Properties =>Vertex (all)

As soon as All above is chosen, a <Select vertex> [Picks][][Menu] message is written to the Status 
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Bar and vertices can be selected.

When the vertex to modify is selected, its vertex nunber and all other information are written to the 
appropriate panel fields. The values and modes can be changed and either OK or Apply selected 
to change the values for the vertex.

The fields in the Super Vertex Properties panel have already been described in the other Vertex 
options and so will not be described again.

Please continue to the next section “Segment” .

Segment
super_segment

The Segment menu contains options to modify information at any segment of the super string.

The Segment walk-right is

Colour
super_segment_colour
Selecting Segment=>Colour brings up the Super Segment Colour panel which is used to set the 
colour of the string segments.

As soon as Colour is chosen, a <Select segment> [Picks][][Menu] message is written to the Status 
Bar and segments can be selected.

When the segment to modify is selected, its segment number, colour mode and colour are written to 
the appropriate panel fields. The values and modes can be changed and either OK or Apply 
selected to change the values of the segment.

Another segment can then be selected or the Prev and Next buttons used to move to adjacent 
segments. The appropriate segment highlights when the Prev and Next buttons are used.

The fields and buttons used in the Super Segment Colour panel have the following functions.
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Field Description Type Defaults Pop-Up

Segment no. input selected vertex

if a segment is selected, then its segment number is displayed in this field. A number can also be typed 
in and any information in the panel will then be applied to that segment if OK or Apply is selected.

Prev button

move to the previous segment (predecessor). The information for the previous segment is displayed in 
the panel fields. 

Next button

move to the next segment (successor). The information for the next segment is displayed in the panel 
fields. 

Colour mode input string colour, each segment

if no z, there is no z value for the vertex.
if string colour, then all the segments in the string have the same colour.
if each segment, then each segment has a separate colour.

Colour input colour of segment/stringavailable colours

the colour used for the segment or for the entire string.

OK/Apply button

for the segment being edited, OK sets the segment/string with the values in the panel fields and 
removes the panel. Apply sets the segment/string with the values in the panel fields and leaves the 
panel on the screen.

Tinable
super_segment_tinable
Selecting Segment=>Tinable brings up the Super Segment Tinable panel which is used to set the 
tinable flag for segments.

As soon as Tinable is chosen, a <Select segment> [Picks][][Menu] message is written to the Status 
Bar and vertices can be selected.

When the segment to modify is selected, its segment number and tinable flag are displayed in the 
panel. The tinable flag can be changed and either OK or Apply selected to change the tinable flag 
of the segment.

Another segment can then be selected or the Prev and Next buttons used to move to adjacent 
segments.

The fields and buttons used in the Super Segment Tinable panel have the following functions.
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Field Description Type Defaults Pop-Up

Segment no. input selected segment

if a segment is selected, then its segment number is displayed in this field. A number can also be typed 
in and any information in the panel will then be applied to that segment if OK or Apply is selected.

Prev button

move to the previous segment (predecessor). The information for the previous segment is displayed in 
the panel fields. 

Next button

move to the next segment (successor). The information for the next segment is displayed in the panel 
fields. 

Tinable tick

if tick, the triangulation process tries to preserve the segment as a side of a triangle in the tin.

OK/Apply button

for the segment being edited, OK sets the segment/string with the values in the panel fields and 
removes the panel. Apply sets the segment/string with the values in the panel fields and leaves the 
panel on the screen.

Diameter
super_segment_pipe
The segments of a super string can have either a pipe or box cross section, or none.
Selecting Segment=>Diameter brings up the Super Segment Pipe panel which is used to set the 
pipe mode and size for the string segments.

As soon as Diameter is chosen, a <Select segment> [Picks][][Menu] message is written to the Status 
Bar and segments can be selected.

When the segment to modify is selected, its segment number, pipe mode and information are written 
to the appropriate panel fields and the Super Segment Pipe panel will change depending on 
whether it was a pip or box cross-section for the string.
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After any panel fields are modified, selecting either OK or Apply will change the pipe 
information for the segment.

Another segment can then be selected or the Prev and Next buttons used to move to adjacent 
segments. The appropriate segment highlights when the Prev and Next buttons are used.

The fields and buttons used in the Super Segment Pipe panel have the following functions.

Field Description Type Defaults Pop-Up

Segment no. input selected vertex

if a segment is selected, then its segment number is displayed in this field. A number can also be typed 
in and any information in the panel will then be applied to that segment if OK or Apply is selected.

Prev button

move to the previous segment (predecessor). The information for the previous segment is displayed in 
the panel fields. 

Next button

move to the next segment (successor). The information for the next segment is displayed in the panel 
fields. 

Pipe mode input no pipe or box
pipe entire string
pipe each segment
box entire string
box each segment

if no pipe or box, there is no z value for the vertex.
if string colour, then all the segments in the string have the same colour.
if each segment, then each segment has a separate colour.

Justify input  invert, centre, overt

justification of the pipe/box with respect to the co-ordinates given for the vertices of the super string.

rotation angle of the symbol.

Pipe diameter input

diameter of the pipe in world units.

Box width input

width of the box section in world units.

Box height input

height of the box section in world units.

OK/Apply button

for the segment being edited, OK sets the segment/string with the values in the panel fields and 
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removes the panel. Apply sets the segment/string with the values in the panel fields and leaves the 
panel on the screen.

Radius
super_segment_radius
When viewed in plan, the segments of a super string can be joined by string lines or arcs.
If the radius is positive, the arc is drawn from the start vertex to the end vertex of the segment in 
a clockwise direction. If the radius is negative, the arc is drawn from the start vertex to the end 
vertex on the segment in a counter-clockwise direction. 

For a given radius (positive or negative), there are two possible cases for the arc- one where the 
arc is less than a semi-circle, the other when the arc is greater than a semi-circle.

If bulge is turned on, the larger arc is used. The default is bulge turned off.

 A zero radius is interpreted to be a just a straight line segment with no arc.

Selecting Segment=>Radius brings up the Super Segment Radius panel which is used to set the 
plan radius of the segment.

As soon as Radius is chosen, a <Select segment> [Picks][][Menu] message is written to the Status 
Bar and segments can be selected.

When the segment to modify is selected, its segment number, radius and bulge are written to the 
appropriate panel fields. The values and modes can be changed and either OK or Apply selected 
to change the values of the segment.

Another segment can then be selected or the Prev and Next buttons used to move to adjacent 
segments. The appropriate segment highlights when the Prev and Next buttons are used.

The fields and buttons used in the Super Segment Radius panel have the following functions.

Arc with bulge on

Arc with bulge off (default)

Arcs with same radius but with bulge on or off
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Field Description Type Defaults Pop-Up

Segment no. input selected vertex

if a segment is selected, then its segment number is displayed in this field. A number can also be typed 
in and any information in the panel will then be applied to that segment if OK or Apply is selected.

Prev button

move to the previous segment (predecessor). The information for the previous segment is displayed in 
the panel fields. 

Next button

move to the next segment (successor). The information for the next segment is displayed in the panel 
fields. 

Colour mode input string colour, each segment

if no z, there is no z value for the vertex.
if string colour, then all the segments in the string have the same colour.
if each segment, then each segment has a separate colour.

Radius tick

if tick, the larger arc is used.
if not-tick, the smaller arc is used.

Bulge input 0

radius of the segment arc. A radius of 0 mean no arc.

OK/Apply button

for the segment being edited, OK sets the segment/string with the values in the panel fields and 
removes the panel. Apply sets the segment/string with the values in the panel fields and leaves the 
panel on the screen.

Text
super_segment_text
Selecting Segment=>Text brings up the Super Segment Text panel which is used to set the text for 
segments.

As soon as Text is chosen, a <Select segment> [Picks][][Menu] message is written to the Status Bar 
and vertices can be selected.

When the segment to modify is selected, its segment number, text mode and text are written to the 
appropriate panel fields. The values and modes can be changed and either OK or Apply selected 
to change the values of the segment.

Another segment can then be selected or the Prev and Next buttons used to move to adjacent 
segments.

The fields and buttons used in the Super Segment Text panel have the following functions.
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Field Description Type Defaults Pop-Up

Segment no. input selected vertex

if a segment is selected, then its segment number is displayed in this field. A number can also be typed 
in and any information in the panel will then be applied to that segment if OK or Apply is selected.

Prev button

move to the previous segment (predecessor). The information for the previous segment is displayed in 
the panel fields. 

Next button

move to the next segment (successor). The information for the next segment is displayed in the panel 
fields. 

Text mode input no text, entire string, each 
segment

if no text, there is no text for the segment.
if entire string, then the string has the same text for each segment.
if each vertex, then each segment has a separate text value.

Text input text of segment/string

the text used for the segment or for the entire string.

OK/Apply button

for the segment being edited, OK sets the segment/string with the values in the panel fields and 
removes the panel. Apply sets the segment/string with the values in the panel fields and leaves the 
panel on the screen.

Text Info
super_segment_annotate
Selecting Segment=>Text info brings up the Super Segment Annotate panel which is used to set 
the annotation styles for the text at segments.

As soon as Text info is chosen, a <Select segment> [Picks][][Menu] message is written to the Status 
Bar and segments can be selected.

When the segment to modify is selected, its segment nunber, annotate mode and annotation 
information are written to the appropriate panel fields. The values and modes can be changed and 
either OK or Apply selected to change the values of the segment.

Another segment can then be selected or the Prev and Next buttons used to move to adjacent 
segments.

The fields and buttons used in the Super Segment Annotate panel have the following functions.
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Field Description Type Defaults Pop-Up

Segment no. input selected vertex

if a segment is selected, then its segment number is displayed in this field. A number can also be typed 
in and any information in the panel will then be applied to that segment if OK or Apply is selected.

Prev button

move to the previous segment (predecessor). The information for the previous segment is displayed in 
the panel fields. 

Next button

move to the next segment (successor). The information for the next segment is displayed in the panel 
fields. 

Annotate mode input no annotation, entire string, each 
segment

if no annotation, then the text at the segment is not displayed.
if entire string, then the same annotation settings are used for each segment.
if each vertex, then each segment has separate annotations settings.

Textstyle info input

textstyle information.

OK/Apply button

for the segment being edited, OK sets the segment/string with the values in the panel fields and 
removes the panel. Apply sets the segment/string with the values in the panel fields and leaves the 
panel on the screen.

Visible
super_segment_visible
Selecting Segment=>Visible brings up the Super Segment Visible panel which is used to set the 
visibility flag for segments.

As soon as Visible is chosen, a <Select segment> [Picks][][Menu] message is written to the Status 
Bar and segments can be selected.

When the segment to modify is selected, its segment number and visibility flag are displayed in the 
panel. The visibility flag can be changed and either OK or Apply selected to change the visibility 
flag of the segment.

Another segment can then be selected or the Prev and Next buttons used to move to adjacent 
segments.

The fields and buttons used in the Super Segment Visible panel have the following functions.
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Field Description Type Defaults Pop-Up

Segment no. input selected vertex

if a segment is selected, then its segment number is displayed in this field. A number can also be typed 
in and any information in the panel will then be applied to that segment if OK or Apply is selected.

Prev button

move to the previous segment (predecessor). The information for the previous segment is displayed in 
the panel fields. 

Next button

move to the next segment (successor). The information for the next segment is displayed in the panel 
fields. 

Visible tick

if tick, the segment is visible.
if not tick, then the segment is invisible.

OK/Apply button

for the segment being edited, OK sets the segment/string with the values in the panel fields and 
removes the panel. Apply sets the segment/string with the values in the panel fields and leaves the 
panel on the screen.

Attributes
super_segment_user_attributes
Selecting Segment=>Attributes brings up the Super Segment User Attributes panel which is used to 
display and edit user defined attributes at segments of the super string.

The Prev and Next buttons are used to cycle through and display the attributes for each segment 



Chapter 14  Strings

May 2007 Page 1031Editor

in the super string in the Name/Type/Data grid.

The data in the Name/Type/Data grid can be deleted, modified or added to and then updated for 
the segment using the OK or Apply button.

The fields and buttons used in the Super Segment User Attributes panel have the following 
functions.

Field Description Type Defaults Pop-Up

Segment no.

when the option starts, the user attributes for the first segment is displayed. The Next and Prev buttons 
will move onto other segments. Also a number can be typed into the field and any information in the 
panel will then be applied to that segment if OK or Apply is selected. Typing <Enter> after entering a 
number will go to that segment number and display the attributes.

Prev button

move to the previous segment (predecessor). The information for the previous segment is displayed in 
the panel fields. 

Next button

move to the next segment (successor). The information for the next segment is displayed in the panel 
fields. 

Attribute mode choice box no attributes, each segment

if no attributes, then no segments have user attributes.
if each segment, then each segment can have user attributes.

Name/Type/Data Grid

Name input

name for the user attribute. This must be unique for all attributes at this segment.

Type choice box integer, real, text

type of the attribute.

Data input

value for the attribute.

OK/Apply button

for the segment being edited, OK sets the segment with the values in the panel fields and removes the 
panel. Apply sets the segment with the values in the panel fields and leaves the panel on the screen.

Segment - All above
super_segment_properties
Selecting Segment=>All above brings up the Super Segment Properties panel which is used to 
display all the properties of a segment.

This option is also available from the Strings menu 

Position of option on menu: Strings =>Properties =>Segment (all)



12d Model Reference Manual

Page 1032 May 2007Editor

As soon as All above is chosen, a <Select segment> [Picks][][Menu] message is written to the Status 
Bar and segments can be selected.

When the segment to modify is selected, its segment nunber and all other information are written 
to the appropriate panel fields. The values and modes can be changed and either OK or Apply 
selected to change the values for the segment.

The fields in the Super Segment Properties panel have already been described in the other 
Segment options and so will not be described again.

Please continue to the next section “Utilities”  for information on Utilities, Open, Close and 
Properties.
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Utilities
super_utilities
The Utilities walk-right menu contains a number of useful miscellaneous option for the super string. The 
menu is

Each of the new options will now be discussed.

Ins 3 Pt Curve
The Ins 3 Pt Curve option is used to insert a curve through three adjacent super string vertices.

After selecting the option, the middle vertex of the three adjacent super string vertices is 
selected. 

When the vertex is accepted, the radius required to fit a curve through the vertex and the two 
adjacent vertices is calculated, and this radius is then applied to the segments joining the 
adjacent vertices.

Del 3 Pt Curve
The del 3 pt curve option is used to delete the curves on either side of a super string vertex.

After selecting the option, a vertex is selected and when the vertex is accepted, the radii of the 
segments on either side are set to zero.

Hence the curves on either side of the vertex are effectively removed.

Open
If the string is closed, selecting the open option removes the segment between the 1st and last 
vertex of the super string.

If the string is not closed, the open option does nothing.

Close
Selecting the close option adds a segment between the 1st and the last vertices of the super 
string. Note that unlike other strings, no extra vertices are added.

Properties
super_string_properties
Selecting Properties brings up the Super String Properties panel which is used to modify the string’s 
header information.
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The fields in this panel are similar to those in the Create Super String panel and the Super String 
Editor options. The only new field is

Field Description Type Defaults Pop-Up

OK/Apply button

for the string being edited, OK sets the string with the values in the panel fields and removes the panel. 
Apply sets the string with the values in the panel fields and leaves the panel on the screen.
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Text Edit
text_edit text_edit_info
On picking a text string, the text edit menu and the panel are placed on the screen.

Each option in the text edit menu will now be described.

See the earlier section “Editor - Common Information” for general information about editing 
strings.

Position
The position option is used to place the text string for the first time and to re-position (move) an 
existing text string.

Position is a one step process.

After selecting the position option, the new position for the text is selected. The text is then 
redrawn at the new position.

message area 1 <Position>
Screen message area

<Select point position> [picks][][menu]
<Select point position> [picks][accepts][menu]

The position option repeats until cancelled by the user by either bringing up the pick ops menu 
and selecting cancel or by selecting a new option from the text edit menu.

If, after bringing up the pick ops menu, it is decided to continue with the position option, simply 
select the restart option from the pick ops menu and the pick ops menu will disappear leaving 
the position option still current.

Typed input can be used at any stage

Text
The text option is used to modify the text of the text string.

After the text option is chosen, an enter text typed-input box is placed on the screen with the 
string's current text displayed in it.

The enter text typed-input box looks like:

The text is entered into the typed-input box, terminated with <enter>. The entered value is taken 
as the text of the text string and the string redrawn with the new text. The typed-input box then 
disappears.
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The text option automatically terminates and a new option needs to selected from the text edit 
menu.

Text ht
The text ht option is used to modify the height of the text in the text string.

After the text ht option is chosen, an enter value typed-input box is placed on the screen with the 
string’s current text height displayed in it.

The enter value typed-input box looks like:

The text height is entered into the typed-input box, terminated with <enter>. The entered value 
is taken as the height of the text in the text string and the string redrawn with the new height.

The typed-input box then disappears.

The height option is automatically terminated and a new option needs to selected from the text 
edit menu.

Angle
The angle option is used to modify the angle that the text in the text string is drawn at.

The text angle is measured in a counter- clockwise direction with respect to the horizontal axis.

After the angle option is chosen, an enter angle typed-input box is placed on the screen with the 
string’s current text angle displayed in it.

The enter angle typed-input box looks like:

The text angle is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the angle of the text in the text string and the string redrawn with the new angle.

The typed-input box then disappears.

The angle option is automatically terminated and a new option needs to selected from the text 
edit menu.

Properties
text_string_properties 
Selecting Properties brings up the Text String Properties panel which is used to modify the string’s 
header information.
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The fields in this panel are similar to those in the create text string panel and the text string editor 
options. The only new field is

Field Description Type Defaults Pop-Up

OK/Apply button

for the string being edited, OK sets the string with the values in the panel fields and removes the panel. 
Apply sets the string with the values in the panel fields and leaves the panel on the screen.
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Points Edit
points_edit

Position of menu: Strings =>Points Edit

The points operations available in the points edit menu are similar to the create/edit options.

However, in the points edit options, the user does not begin by picking the particular string to be 
edited. Instead, the required option is selected followed by the point to be modified from any 
string.

The option can then be applied to another point on that or any other string, or another point 
operation chosen, and applied to any point.

If the user wants to make a large number of point edits to the one string, the editor option 
discussed in the last section is the easiest option to use. However, if a number of strings are going 
to be edited with the same operation or a selection of operations, then the points edit option is 
more suitable.

After selecting the points edit option, the points edit menu is displayed.

Each of the options performs the same work as the option of the same name in the Edit string 
option.
The individual options in the Points Edit menu will now be discussed in detail.

For the option Append, go to the section “Append Point” 
Between  “Between Point” 
Delete “Delete Point” 
Extend “Extend Point” 
Extend Ht “Extend Height” 
Height “Height” 
Insert “Insert Point” 
Move “Move Point” 
Add 3pt curve “Add 3 Point Curve” 
Del 3pt curve  “Delete 3 Point Curve” 
Vertex “Edit Vertex” 

Append Point
append_point

Position of option on menu: Strings =>Points Edit => Append

The append option adds additional points to the end of a string. On selecting the append option, 
an append point panel is displayed.

append to a string
insert on the line between string points
delete a string point
extend a string point
for polyline/superstring - extend point and extrapolated height
change height of a point
insert a point into a string
move a string point, or a text string
for polyline/superstring - add curve through 3 points
for polyline/superstring - delete adjacent curves
edit vertex data for a super string
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The message area of this panel informs the user of any error messages.

Once in the append option, the particular end of the string to append points to is selected using 
the standard LB and MB pick and accept sequence.

The points to be appended are then selected. The option keeps adding points to the selected 
string until the pick ops menu is brought up using RB and cancel is selected.

After the append has been completed, the option repeats. That is, the user is asked to select 
another string to append to. This continues until finish or [X] is selected from the append point 
panel.

Between Point
between_point

Position of option on menu: Strings =>Points Edit => Between

On selecting the between option, a between point panel is displayed.

The message area of this panel informs the user of any error messages. 

Once in the between option, the particular segment to insert a point on is selected using the 
standard LB and MB pick and accept sequence. The position of the point to insert is then selected 
and accepted.

After the between has been completed, the option repeats. That is, the user is asked to select 
another segment to insert a point on. This continues until finish or [X] is selected from the 
between point panel.

Delete Point
delete_point

Position of option on menu: Strings =>Points Edit => Delete

On selecting the delete option, a delete point message panel is displayed.

The message area of this panel informs the user of any error messages. 

Once in the delete option, the particular point to delete is selected using the standard LB and MB 
pick and accept sequence. When the point is accepted, it is deleted.
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After the delete has been completed, the option repeats. That is, the user is asked to select another 
point to delete (the point can be on any string). This continues until finish or [X] is selected from 
the delete point panel.

Extend Point
extend_point

Position of option on menu: Strings =>Points Edit => Extend

On selecting the extend option, a extend point panel is displayed.

The message area of this panel informs the user of any error messages. 

Once in the extend option, the particular point on a segment to extend is selected by picking the 
segment near to the point using the standard LB and MB pick and accept sequence. The position 
of the point is then moved along the segment until the final position is selected and accepted.

After the extend has been completed, the option repeats. That is, the user is asked to select 
another segment to extend a point on. This continues until finish or [X] is selected from the 
extend point panel.

Extend Height
extend_point_by_ht

Position of option on menu: Strings =>Points Edit => Extend Ht

 The extend point by height option is similar to the extend option except that the z-value of the 
moved point is modified by linearly interpolating the z-value from the original points at the end 
of the selected segment. On selecting the extend by ht option, an extend point by ht panel is 
displayed.

The message area of this panel informs the user of any error messages. 

Once in the extend point by ht option, the particular point on a segment to extend is selected by 
picking the segment near to the point using the standard LB and MB pick and accept sequence. 
The position of the point is then moved along the segment until the final position is selected and 
accepted. The z-value of the moved point is the linear interpolation of the selected segment.

After the extend point by ht has been completed, the option repeats. That is, the user is asked to 
select another segment to extend a point on. This continues until finish or [X] is selected from the 
extend point by ht panel.

Height
point_height
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Position of option on menu: Strings =>Points Edit => Height

On selecting the height option, a point height panel is displayed.

The message area of this panel informs the user of any error messages. 

Once in the height option, the particular point to modify the height for is selected using the 
standard LB and MB pick and accept sequence. When the point is accepted, the height existing 
height is displayed in a height box which can be modified and accepted by typing <enter>.

After the height has been completed, the option repeats. That is, the user is asked to select another 
point to modify the height for (the point can be on any string). This continues until finish or [X] is 
selected from the point height panel.

Insert Point
insert_point

Position of option on menu: Strings =>Points Edit => Insert

On selecting the insert option, an insert point message panel is displayed.

The message area of this panel informs the user of any error messages. 

Once in the insert option, the particular segment to identify the two points to insert the point is 
selected using the standard LB and MB pick and accept sequence. The position of the point to 
insert is then selected and accepted.

After the insert has been completed, the option repeats. That is, the user is asked to select another 
segment to insert a point on. This continues until finish or [X] is selected from the insert point 
panel.

Move Point
move_point

Position of option on menu: Strings =>Points Edit => Move

On selecting the move option, a move point panel is displayed.

The message area of this panel informs the user of any error messages. There are similar panels 
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for each of the other points edit options.

Once in the move option, the particular point to move is selected using the standard LB and MB 
pick and accept sequence. The position that the point is to be moved to is then selected and 
accepted.

After the move has been completed, the option repeats. That is, the user is asked to select another 
point to move (the point can be on any string). This continues until finish or [X] is selected from 
the move point panel.

Add 3 Point Curve
insert_3pt_curve

Position of option on menu: Strings =>Points Edit => Add 3pt Curve

On selecting the add 3pt curve option, a insert 3pt curve panel is displayed.

The message area of this panel informs the user of any error messages. 

Once in the add 3pt curve option, the middle point of the three points of the super string to fit a 
curve for, is selected using the standard LB and MB pick and accept sequence. When the point is 
accepted, the curve is fitted between it and the left and right adjacent points of the super string.

After the add 3pt curve has been completed, the option repeats. That is, the user is asked to select 
another point to add a curve to (the point can be on any super string). This continues until finish 
or [X] is selected from the insert 3pt curve panel.

Delete 3 Point Curve
delete_3pt_curve

Position of option on menu: Strings =>Points Edit => Del 3pt Curve

On selecting the del 3pt curve option, a delete 3pt curve panel is displayed.

The message area of this panel informs the user of any error messages. 

Once in the delete 3pt curve option, a vertex from a super string is selected using the standard 
LB and MB pick and accept sequence and if there is curves on both sides of the vertex, the radii 
are removed and the vertices are joined by straight line segments.

After the delete 3pt curve has been completed, the option repeats. That is, the user is asked to 
select another point on a super string to remove the curves on either side (the point can be on 
any super string). This continues until finish or [X] is selected from the delete 3pt curve panel.

Edit Vertex
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edit_vertex

Position of option on menu: Strings =>Points Edit => Vertex

The Edit Vertex option allows the quick editing of the co-ordinates, vertex id, symbol, vertex text 
and tinability of a selected string vertex. 

The name, model, colour and linestyle, which are string properties, can also be modified 
however the user has the choice of modifying the string properties for the entire string, or have 
the option remove the selected vertex from the string and only give the string properties to the 
newly created one vertex string. If a vertex is removed from the string, the adjacent vertices of 
the removed vertex can be joined.

On selecting the Vertex option, a Edit Vertex panel is displayed. 

The Edit Vertex option is already running and a super string vertex is selected.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Vertex properties

Vertex id input

the vertex id (point number) for the selected vertex. Change this to the required value.

X coordinate Measure X panel

the x coordinate (easting) of the selected vertex. Change this to the required value.

Y coordinate Measure Y panel

the y coordinate (northing) of the selected vertex. Change this to the required value.

Z coordinate Measure Z panel

the y coordinate (elevation) of the selected vertex. Change this to the required value.
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Symbol symbol box available symbols

the symbol on the selected vertex. Change this to the required symbol.

Text input

the text on the selected vertex. Change this to the required text.

Tinable tick box

ticked if the selected vertex is tinable. Change if required.

String/New vertex properties

Remove vertex from string tick box

tick if the selected vertex is to be removed from its current string. 

Join remaining points tick box

only setable if Remove vertex from string is ticked.
If tick then the vertices on either side of the removed vertex are joined.
If not ticked then the original string will be broken into two strings when the vertex is removed.

Name input

the name of the string containing the selected vertex. Change this to the required name.

Model model box available models

the model of the string containing the selected vertex. Change this to the required model.

Colour colour box available colours

the colour of the string containing the selected vertex. Change this to the required colour.

Linestyle linestyle box

the linestyle of the string containing the selected vertex. Change this to the required linestyle.

Pick button

chose Pick and then select the vertex to be edited.

Set button

apply the values in the panel to the selected vertex. Pick is still active so that another vertex can be 
selected.
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Strings Edit
strings_edit
Position of menu: Strings =>Strings Edit
The strings edit option contains operations to be applied, not to individual points of a string, but to entire 
strings.
After selecting the strings edit option, the strings edit menu is displayed.

The individual options in the strings edit menu will now be discussed in detail.

For the option Change, go to the section “Change” 
Clip  “Clip” 
 Close “Close” 
Delete “Delete” 
Duplicate “Duplicate” 
Join “Join” 
Join many “Join Many” 
Link clip “Link Clip” 
Open “Open” 
Parallel “Parallel” 
Reverse  “Reverse” 
Split “Split” 
Translate  “Translate” 
Textdata info “Textdata Info” 
Arc to chords “Arc to Chords” 
Segment strings “Segment Strings” 
Corner splays “Corner Splays” 
Surrounding polygon “Surrounding Polygon” 

Change

change string colour, type, name or model
delete or keep part of a string
connect the first and last points
delete a string
duplicate a string
join two strings to form one string
join many strings to form one string
delete a string link
disconnect the first and last points
parallel the string
reverse the order of string points
split a string into two strings
translate a string to a new position
change the text information
create inner and outer chords for an arc
segment a super string
create corner splay
form polygon from lines and arcs
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change_string

Position of option on menu: Strings =>Strings Edit =>Change

The change option can be used to change the mode, colour, style, name and point-line type of a 
string. 

On selecting the change option, the change string panel is displayed.

The change option is already is progress and if a string is selected, the model, colour, style, name 
and point-line type are changed according to the fields in the change string panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

New name input

if non-blank, the name of the selected string will be changed to the name given in the new name field.

New model input available models

if non-blank, the selected string will be moved to the model given in the new model field.

New colour input available colours

if non-blank, the colour of the selected string will be changed to the colour given in the new colour 
field.

New point-line input point, line

if non-blank, the breakline type of the selected string will be changed to the type given in the new point-
line field (point or line type).

New style input

if non-blank, the style of the selected string will be changed to the name given in the new style field.

Please continue to the next section “Clip” .

Clip
clip_string

Position of option on menu: Strings =>Strings Edit =>Clip

The clip option can be used to delete or keep part of a string.

On selecting the clip option, the clip string panel is displayed.
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After selecting the clip option, the user is asked to select the string to be clipped. The user is then 
asked to select two points on the string to define the section to be clipped.

Depending on the clip mode, either

(a) a new string is created from the section of the string between the two points

(b) two new strings are created by deleting the section of the string between the two points

(c) one new string is created by deleting the section of the string between the two points and 
then joining the two selected points.

If the 1st name, 1st model and/or 1st colour panel fields are non-blank, the values are used for 
the 1st half of the clipped string. Otherwise the values of the original string are used for the 1st 
half of the string.

If the 2nd name, 2nd model and/or 2nd colour panel fields are non-blank, the values are used for 
the second half of the clipped string. Otherwise the values of the original string are used for the 
second half of the string.

If the keep mode is set to keep string, the original string is kept
trash string, the original string is moved to the trash model
delete string, the original string will be deleted.

Hence, the fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

1st name input

if blank, the first half of the clipped string is given the name of the original string.
If non-blank, the first half of the clipped string is given the name in the 1st name field.

1st model input available models

if blank, the first half of the clipped string is placed in the same model as the original selected string.
If non-blank, the first half of the clipped string is placed in the model given in the 1st model field.

1st colour input available colours

if blank, the first half of the clipped string is given the colour of the original string.
 If non-blank, the first half of the clipped string is given the colour specified in the 1st colour field.

2nd name input

if blank, the second half of the clipped string is given the name of the original string.
 If non-blank, the second half of the clipped string is given the name in the 2nd name field.
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2nd model input available models

if blank, the second half of the clipped string is placed in the same model as the original selected string. 
If non-blank, the second half of the clipped string is placed in the model given in the 2nd model field.

2nd colour input available colours

if blank, the second half of the clipped string is given the colour of the original string.
If non-blank, the second half of the clipped string is given the colour specified in the 2nd colour field.

Keep mode input keep string delete, keep, trash string

if delete string, the string selected to be clipped is deleted.
    keep string, the selected string is not deleted.
    trash string, the string selected to be clipped is moved to the trash model. 

Clip mode input internal internal, external,
join external

if internal, a new string is created from the section of string between the two selected points.
external, two new strings are created by deleting the section of the string between the two points.
join external, one new string is created by deleting the section of the string between the two points 

and then joining the two selected points.

How to Use the Panel and Panel Messages

(a) Enter the new model, colour and name for the first and second parts of the clipped string.

(b) The string to be clipped is selected.

(c) The points to be used as the clipped point are then selected.

(d) The section of the string is then clipped between the selected points and depending on the 
clip mode, the selected string is then clipped or the clipped section kept.

Please continue to the next section “Close” .

Close
close_string

Position of option on menu: Strings =>Strings Edit =>Close

A closed string is simply a string whose 1st and last points are the same.

The close string option adds to the end of the string, a point that is identical to the 1st string 
point. This then forms a closed string.

On selecting the close option, the close string panel is displayed.

The close option is already is progress and if a string is selected, it is closed.

Please continue to the next section “Delete” .
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Delete
delete_string

Position of option on menu: Strings =>Strings Edit =>Delete

Entire strings can be deleted from the model using the delete option.

On selecting the delete string option, the delete string panel is displayed.

The delete option is already in progress and if a string is selected (LB) and accepted (MB), it is 
deleted

If the trash mode in the trash defaults panel is set to trash string, the original string is not deleted 
but moved to the trash model.

Please continue to the next section “Duplicate” .

Duplicate
duplicate_string

Position of option on menu: Strings =>Strings Edit =>Duplicate

The duplicate option is used to make a copy of the string with the option of giving the duplicate 
string a new model, colour and/or name.

On selecting the duplicate option, the duplicate string panel is displayed.

The duplicate option is already is progress and if a string is selected, then a copy of the string 
will be created and possibly given a new model, colour or name depending on the fields in the 
duplicate string panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

New name input

if the new name field is blank, the duplicate string has the same name as the original string. If the 
new name field is non-blank, then the duplicate string is given the name in the new name field.

New model input available models

if new model is blank, the duplicate string is placed in the same model as the original string. If the new 
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model field is non-blank, then the duplicate string is placed in the model given in the new model field.

New colour input available colours

if the new colour field is blank, the duplicate string has the same colour as the original string. If the 
new colour field is non-blank, then the duplicate string is given the colour specified in the new colour 
field. 

Please continue to the next section “Join” .
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Join
join_strings

Position of option on menu: Strings =>Strings Edit =>Join

The join option is used to create a new string by joining two existing strings together.

On selecting the join option, the join strings panel is displayed.

After selecting the join option, the user is asked to select in turn the two strings that make up the 
joined string.

First, the string that will become the first half of the new joined string is selected with the 
direction that the string will have as the first half of the new string.

Next, the string that will become the second half of the new joined string is selected with the 
direction that the string will have as the second half of the new string.

The end of the first selected directed string and the beginning of the second selected directed 
string are joined to form the new joined string.

If the model, colour and/or name panel fields are non-blank, their values are used for the new 
joined string. Otherwise the values from the first selected string are used for the joined string.

If the keep mode is set to keep string, the original strings are kept
trash string, the original strings are moved to the trash model
delete string, the original strings are deleted.

Hence, the fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

New name input

if the new name field is blank, the joined string is given the name of the first selected string. If the new 
name field is non-blank, the joined string is given the name in the new name field.

New model input available models

if new model is blank, the joined string is placed in the same model as the first selected string. If the 
new model field is non-blank, the joined string is placed in the model given in the new model field.

New colour input available colours

if the new colour field is blank, the joined string is given the colour of the first selected string. If the 
new colour field is non-blank, then the joined string is given the colour specified in the new colour field. 

Keep mode input keep strings delete string, keep strings

if delete string, the selected strings selected are deleted.
     keep string, the selected strings are not deleted.
     trash string, the strings selected to be joined are moved to the trash model.

How to Use the Panel

(a) Enter the new model, colour and name for the joined string.
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(b) The 1st string is selected by picking it with the required direction.
(c) The string to be joined to the 1st selected string is selected by picking it with the required 

direction.
(d) The last point of the 1st directed string and the 1st point of the second directed string are 

joined to create a new string with model, colour, name as specified in the join strings panel.

Please continue to the next section “Join Many” .

Join Many
join_many_strings

Position of option on menu: Strings =>Strings Edit =>Join many

The join many option is used to create a new string by joining two or more existing strings, or 
parts or strings, together.

On selecting the join many option, the join many strings panel is displayed.

After selecting the join many option, the user is asked to select in turn the strings that will make 
up the joined string. Using the partial mode, parts of strings can be joined.

First, the string that will become the first part of the new joined string is selected with the 
direction that the string will have as the first part of the new string.

If partial is set (tick), two points are then picked on the string and only the part of the string 
between the picked points is used in the join.

Next, the strings that will become the subsequent parts of the new joined string are selected in 
order with the direction that the strings will have in the new joined string.

Again, whenever partial is set (tick), two points are picked on the selected string and only the 
part of the string between the picked points is used in the join.

The end of each selected directed string (or partial string) is joined to the beginning of the 
subsequent selected directed string (or partial string) when forming the joined string.

If the name, model and/or colour panel fields are non-blank, their values are used for the new 
joined string. Otherwise the values from the first selected string are used for the joined string.

If the keep mode is set to keep string, the original strings are kept
trash string, the original strings are moved to the trash model
delete string, the original strings are deleted.

Hence, the fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

New name input

if blank, the joined string is given the name of the first selected string.
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If non-blank, the joined string is given the name in the new name field.

New model input available models

if blank, the joined string is placed in the same model as the first selected string.
If non-blank, the joined string is placed in the model given in the new model field.

New colour input available colours

if blank, the joined string is given the colour of the first selected string.
If non-blank, the joined string is given the colour specified in the new colour field. 

Keep mode input keep strings delete strings, keep strings

if delete string, the selected strings are deleted.
     keep string, the selected strings are not deleted.
    trash string, the strings selected to be joined are moved to the trash model.

Partial tick

if tick, two points are then picked on the string and only the part of the string between the picked points 
is used in the join.
if no tick, no extra points are required and the entire string is used.

How to Use the Panel and Panel Messages

(a) Enter the new model, colour and name for the joined string.

(b) The first string to be joined is then selected by picking the required string with the required 
direction, plus two points to restrict the string if partial is set on.

(c) The second and subsequent strings to be joined are then selected (or partial string if partial 
is set on) in order and with the required direction.

(d) The last point of each directed string is connected to the first point of the subsequent 
directed string to create a new joined string. The model, colour and name as specified in the 
join many strings panel are used for the new string.

Please continue to the next section “Link Clip” .

Link Clip
link_clip_string

Position of option on menu: Strings =>Strings Edit =>Link clip

The link clip option can be used to delete the link joining two adjacent vertices of a string.

On selecting the link clip option, the link clip string panel is displayed.

After selecting the link clip option, the user selects the link of the string to be clipped. On 
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acceptance, the selected link is deleted from the string, thus creating two new strings. 

If the 1st name, 1st model and/or 1st colour panel fields are non-blank, the values are used for 
the first half of the link clipped string. Otherwise the values of the original string are used for the 
first half of the string.

If the 2nd name, 2nd model and/or 2nd colour panel fields are non-blank, the values are used for 
the second half of the link clipped string. Otherwise the values of the original string are used for 
the second half of the string.

If the keep mode is set to keep string, the original string is kept
trash string, the original string is moved to the trash model
delete string, the original string will be deleted.

Hence, the fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

1st name input

if blank, the first half of the clipped string is given the name of the original string.
If non-blank, the first half of the clipped string is given the name in the 1st name field.

1st model input available models

if blank, the first half of the clipped string is placed in the same model as the original selected string.
If non-blank, the first half of the clipped string is placed in the model given in the 1st model field.

1st colour input available colours

if blank, the first half of the clipped string is given the colour of the original string.
 If non-blank, the first half of the clipped string is given the colour specified in the 1st colour field.

2nd name input

if blank, the second half of the clipped string is given the name of the original string.
 If non-blank, the second half of the clipped string is given the name in the 2nd name field.

2nd model input available models

if blank, the second half of the clipped string is placed in the same model as the original selected string. 
If non-blank, the second half of the clipped string is placed in the model given in the 2nd model field.

2nd colour input available colours

if blank, the second half of the clipped string is given the colour of the original string.
If non-blank, the second half of the clipped string is given the colour specified in the 2nd colour field.

Keep mode input keep string delete, keep, trash string

if delete string, the string selected to be clipped is deleted.
    keep string, the selected string is not deleted.
    trash string, the string selected to be clipped is moved to the trash model. 

Please continue to the next section “Open” .

Open
open_string

Position of option on menu: Strings =>Strings Edit =>Open

A closed string is opened by removing the last point of the string.

On selecting the open option, the open string panel is displayed.
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The open option is already is progress and if a closed string is selected, it is opened.

Please continue to the next section “Parallel” .

Parallel
parallel_string

Position of option on menu: Strings =>Strings Edit =>Parallel

Strings, or parts of strings, can be translated perpendicularly to either the left or right using the 
parallel option. The z-values of the string can also be adjusted by a constant value.

The difference between a translate and a parallel is that for a straight translate, the translation 
vector is the same for the whole string. In a parallel, the translation is at right angles to each link 
of the string and hence the translation direction varies along the string.

For example, the edge of a road is a parallel of the centre-line, not a copy of the centre-line.

On selecting the parallel option, the Parallel String panel is displayed.

The user is then asked to select the string to parallel.

If partial is not set, the string is copied parallel through the distance given in the offset field. 

If partial is set (tick), two points are then picked on the string and only the part of the string 
between the picked points is copied parallel through the distance given in the offset field.

The value in the delta ht field is then added to the z-values of the string.

The direction imposed upon the string when selecting it is used to determine what is the left and 
right side of the string in the parallel operation.

A positive offset parallels the string to the right with respect to the direction of picking. A 
negative offset parallels to the left with respect to the direction of picking.

Hence, the fields and buttons used in the parallel string panel have the following functions.

Field Description Type Defaults Pop-Up

New name input

if blank, the paralleled string is given the name of the original string.
If non-blank, the parallel string is given the name in the new name field.
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New model input available models

if blank, the paralleled string is placed in the same model as the original selected string.
If non-blank, the paralleled string is placed in the model given in the new model field.

New colour input available colours

if blank, the paralleled string is given the colour of the original string.
If non-blank, the paralleled string is given the colour specified in the new colour field.

Offset input

distance (in world units) that the string will be copied parallel through. A positive distance denotes that 
the string will be paralleled to the right of the original string.

Delta ht input

value to add to the z-values of the string.

 Partial tick

if tick, two points are then picked on the string and only the part of the string between the picked points 
is used in the parallel.
if no tick, no extra points are required and the entire string is used.

How to Use the Panel

(a) Enter the new model, colour and name for the paralleled string.

(b) Enter the offset distance for the parallel - left and right is determined by picking direction.

(c) Enter the height to add to the string’s z-values in the delta ht field.

(d) The selected string (or partial string if partial is set on) is then copied parallel as required.

Please continue to the next section “Reverse” .

Reverse
reverse_string

Position of option on menu: Strings =>Strings Edit =>Reverse

The reverse string option simply reverses the order of the points in a string.

On selecting the reverse option, the reverse string panel is displayed.

After selecting the reverse option, the user simply picks (LB) the string that is to have its point 
order reversed and on acceptance (MB) of the string, the reversing takes place.

Please continue to the next section “Split” .
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Split
split_string

Position of option on menu: Strings =>Strings Edit =>Split

The split option is used to create two new strings by splitting an existing string about a selected 
point on the string.

On selecting the split option, the split string panel is displayed.

If control point is set off, after selecting the split option, the user is asked to select the string and 
the selection point is also used as a split point. Hence the one point is used to select the string 
and as the split point.

If control point is set on, the user is asked to select the string to split and then pick the point that 
is dropped perpendicularly onto the selected string as the point on the string to be used as a split 
point. Hence the string select and the split point are selected separately.

Two strings are then created by splitting the chosen string about the split point.

If the 1st name, 1st model and/or 1st colour panel fields are non- blank, the values are used for 
the first half of the split string. Otherwise the values of the original string are used for the first 
half of the string.

If the 2nd name, 2nd model and/or 2nd colour panel fields are non-blank, the values are used for 
the second half of the split string. Otherwise the values of the original string are used for the 
second half of the string.

If the keep mode is set to keep string, the original string is kept
trash string, the original string is moved to the trash model
delete string, the original string will be deleted.

Hence, the fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

1st name input

if blank, the first half of the split string is given the name of the original string.
If non-blank, the first half of the split string is given the name in the 1st name field.

1st model input available models

if blank, the first half of the split string is placed in the same model as the original selected string.
If non-blank, the first half of the split string is placed in the model given in the 1st model field.

1st colour input available colours

if blank, the first half of the split string is given the colour of the original string.
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If non-blank, then the first half of the split string is given the colour specified in the 1st colour field.

2nd name input

if blank, the second half of the split string is given the name of the original string.
If non-blank, the second half of the split string is given the name in the 2nd name field.

2nd model input available models

if blank, the second half of the split string is placed in the same model as the original selected string.
If non-blank, the second half of the split string is placed in the model given in the 2nd model field.

2nd colour input available colours

if blank, the second half of the split string is given the colour of the original string.
If non-blank, then the second half of the split string is given the colour specified in the 2nd colour field.

Keep mode input keep string delete, keep, trash string

if delete string, the string selected to be split is deleted.
     keep string, the selected string is not deleted.
     trash string, the string selected to be split is moved to the trash model. 

Control pt tick

If tick, the user is asked to select the string to split and then pick the point that is dropped 
perpendicularly onto the selected string as the point on the string to be used as a split point.

If not tick, the user is asked to select the string and the selection point is also used as a split point. 

How to Use the Panel and Panel Messages

(a) Enter the new model, colour and name for the first and second parts of the split string.

(b) If control is on, the string is selected and then the split point is selected.
If control is off, the string is selected and the same point is to be used as the split point.

(c) The chosen string is then split about the split point and the two halves given models, 
colours and names as defined by the split string panel.

Please continue to the next section “Translate” .

Translate
translate_string

Position of option on menu: Strings =>Strings Edit =>Translate

Entire strings can be translated in the x,y and z directions using the translate option.

The translated string can either be moved or copied to its new translated position.

The difference between a copy or a move is simply that if a string is copied, a copy of the string 
is translated and the original string left untouched, whereas for a move, the actual string is 
moved from its original position to the new translated position.

On selecting the Translate option, the Translate string panel is displayed.
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The selected string is translated by using the cursor to select a position on the string (the before 
point) and then selecting the position (not necessarily on a string) that the point will be 
translated to (after point).

Hence the translate operation requires two positions - a before and an after point - for the 
translation to be defined.

The first position (the before point) is selected using the normal select procedures. The second 
position (the after point) depends entirely on the translate mode.

If the translate mode is set to 

cursor x y z or cursor x y

the cursor is used to not only select the string point but also to indicate where it is to be moved/
copied to.

typed x y z

the second point has the absolute coordinates given in the x y z field.

typed dx dy dz

the second point is defined relative to the first point by the adding the dx dy dz given in the dx dy 
dz field.

Selected strings will be translated until the option is finished.

The fields and buttons used in the translate panel have the following functions.

Field Description Type Defaults Pop-Up

New name input

if blank, the string is given the name of the original string.
If non-blank, the string is given the name in the new name field.

New model input available models

if blank, the string is placed in the same model as the original selected string. 
If non-blank, the string is placed in the model given in the New model field.

New colour input available colours

if blank, the string is given the colour of the original string.
If non-blank, then the string is given the colour specified in the new colour field.

Translate mode input cursor xy cursor xy, cursor xyz,
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typed xyz, typed dxdydz

see comments about translate mode in the general description of move/copy

x y z input

if Translate mode is Typed x y z then this field appears and the position on the string where the string 
was selected is translated to this co-ordinate.

dx dy dz input

if Translate mode is Typed dx dy dz then this field appears and the selected string is translated by the 
given dx dy dz.

Move/copy mode input move copy, move

if the mode is set to move, the string is translated as defined in the panel fields and the original string 
is deleted. If the mode is copy, the original string is left alone.

How to Use the Panel and Panel Messages

(a) Enter the new model, colour and name for the translated string.

(b) The string to be translated and its “before” point is chosen.

(c) The “after” point is chosen according to the translate mode.

(d) The selected string is then translated (moved or copied) as required.

Please continue to the next section “Textdata Info” .
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Textdata Info
change_textstyle_info

Position of option on menu: Strings =>Strings Edit =>Textdata info

The Textdata info option is used to change the information about the text for a text string, super 
strings and text for 4d strings.

Selecting the option, the Change Textstyle Info panel:

The parameters for the textstyle information are set and then any selected string is given the new 
textstyle parameters. If any of the parameters are left blank, then that parameter is not modified 
for the selected string.

To define the Textstyle info parameters, click on the text button and then the edit button.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

New textstyle info textstyle data

textstyle information to use for the selected strings.

Change button

selected strings will have their text modified by the parameters in the new textstyle info field.

Arc to Chords
arc_to_chords

Position of option on menu: Strings =>Strings Edit =>Arc to chords

The Arc to Chord option works on a super string and creates inside or outside chords for any arc 
segments in the super string.

The number of chords created can be defined by giving the number of chords required, a chord 
length to use for each chord, or an arc to chord tolerance.

On selecting the Arc to chords option, the Arc to Chords panel is displayed.
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The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Pick button

select the super string to edit.

Previous button

move to the previous segment of the super string.

Next button

move to the next segment of the super string.

Convert mode choice box inside inside
outside

create the chords on the inside or the outside of the arc.

Method choice box no. of chords no. of chords
chord length
arc to chord tolerance

method for creating the chord.

No. of Chords, Chord length, Arc to chord tolerance

value to use with the Method.

Process button

create chords for the selected segment of the super string.

Segment Strings
segment_string

Position of option on menu: Strings =>Strings Edit =>Segment string

The Segment string option works on a super string and inserts extra points on an arc or line 
segment of the super string to break it into smaller arc or line segments.

The number of arcs/lines created can be controlled by specifying either 

(a) the number of sub-segments required

(b) a single sub-segment length to break the start of the segment into that length

(c) a sub-segment length to break the segment into as many sub-segments of that length as 
possible.

On selecting the Segment strings option, the Segment String panel is displayed.
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The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Pick button

select the super string to edit.

Previous button

move to the previous segment of the super string.

Next button

move to the next segment of the super string.

Method choice box by number by number
one distance
by distance

method for creating the sub-segments.

by number - the segment is broken into No of parts equal segments
one distance - the segment is broken into two parts with the first part having the length Distance (which 

end will depend on the direction that the segment was selected.
by distance - the segment is broken into as many sub-segments of length Distance as possible (which 

end the division starts at depends on the direction that the segment was selected).

No of parts, Distance

value to use with the Method.

Current segment length output only

length of the currently selected segment of the super string.

Calc segment length output only

calculated length of the segment that will be created.

Process button

create sub-segments for the selected segment of the super string.

Corner Splays
corner_splays

Position of option on menu: Strings =>Strings Edit =>Corner splays

The Corner splays option works on a super string and creates splays between two adjacent 
straight segments.
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The number of chords created can be defined by giving the number of sub-segments required, 
one sub-segment length to beak of the segment or a sub-segment length to beak the segment into 
as many sub-segments as possible.

On selecting the Corner splays option, the Corner splays panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

No of chords

value to use with the Method.

Convert mode choice box arc length arc length
arc radius
chord length
total chords length
tangent length

method for creating the corner splays.

Arc length, Arc radius, Chord length, Total chords length, tangent length

value to use with the Convert mode.

Name input

the name of the new string.

Model input available models

name of the model that the new string is in.

Colour input default colour available colours

the colour of the new string.

Keep original string tick box tick

if tick, the original string is not modified and a new string is created with the corner splays.
If not tick, the original string is modified.

Pick button

select a super string and the splays will be created.

Surrounding Polygon
create_polygon___pick_point_inside
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Position of option on menu: Strings =>Strings Edit =>Surrounding polygon

The Surrounding polygon option works on all the super strings on the view surrounding a 
selected position (point) and, if possible, creates a closed polygon from parts of the strings 
surrounding the selected point.

A straight line must be able to be drawn from the selected point to the lines/arcs that could be 
used in the surrounding strings.

This option creates a lot/polygon by a picking inside a collection of strings and the lot/polygon 
is created from the closest strings to the picked position. The picked position must be selected so 
that all sides of the lot/polygon can be "seen" from the picked position. That is, a straight line can 
be drawn from the picked position to the lot/polygon side without cutting any other segment.

On selecting the Surrounding polygon option, the Create Polygon - Pick Point Inside panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

the name of the new created polygon.

Select a position that is inside
the polygon to be created

Created polygon

Creating a Polygon by Picking Inside the Polygon
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Model input available models

model for the created polygon.

Colour input default colour available colours

colour for the created polygon.

Pick button

pick a position on a view and the surrounding polygon will be created from all the super strings on the 
view.
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Cogo
cogo_edit_ops

cogo_edit

Position of menu: Strings =>Cogo

The cogo (co-ordinate geometry) options provide methods of constructing points, lines and arcs 
from a variety of operations such as picking, filleting, intersecting and finding tangents.

Selecting the cogo option creates the cogo edit ops menu and the cogo edit panel.

The options in the cogo edit ops menu all create either a point, string or arc and the cogo edit 
panel remains on the screen for each of the menu options and provides the string properties for 
any created objects.

All of the options chosen from the cogo edits ops menu and its sub-menus repeat until cancelled 
by the user. That is, the option remains in force and can be applied repeatedly until terminated 
by the user.

The name of the current selected option is displayed in the first message area of the cogo edit 
panel.

To select a new cogo edits ops option, simply select the new option from the cogo edit ops menu 
or sub-menus. The current option is automatically terminated and the new option begun.

An option is also terminated when either the cancel or finish button is selected in the cogo edit 
panel, or finish is elected from the cogo edit ops menu.

Each of the options in the cogo edit ops menu will now be discussed.

For the option Create ops, please continue to the section “Create Ops” .
 Intersect ops, please continue to the section “Intersect Ops” .
 Vector, please continue to the section “Vector” .
 Parallel, please continue to the section “Parallel” .
 Fillet ops, please continue to the section “Fillet Ops” .
Fillet ops (T), please continue to the section “Fillet Ops (T)” .

 Fillet ops (TJ), please continue to the section “Fillet Ops (TJ)” .
 Tangent, please continue to the section “Tangent” .

Please continue to the next section “Create Ops” .

Create Ops
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create_ops
The create ops walk-right menu is

Each of the options in the Create Ops menu will now be discussed.

For the option Create point, please go to the section “Create Point” .
Create line “Create Line” .
Create point between points “Create Point Between Points” .
Locate offset “Locate Offset” .
Locate deflection “Locate Deflection” .
Divide - no “Divide - Number” .
Divide - dist “Divide - Distance” .
Perpedn “Perpendicular” .
Projection  “Projection” .
Locate chainage “Locate Chainage” .

Create Point
After selecting the create point option, the user simply selects a point using the normal picking 
sequence.

The point will be created with name, colour and model from the cogo edit panel.

If no z-value is given in the cogo edit panel, then a null z-value is used.

If height snap is on and the point is created by snapping to an existing point or line, the z-value 
for the point is taken from the snapped point or if tin snap is on, from the underlying 
triangulation. The snapped z-value will be displayed in an enter height typed input box.

If required, this value can be modified by typing into the enter height box. If the box is empty, the 
z-value is taken from the cogo edit panel. If no value exists in the cogo edit, an error message 
please specify z value is displayed in the cogo edit message area.

The z-value in the enter height box is accepted by entering a <enter> in the box. The enter height 
box then disappears.

Screen message area

<<Create Point> Select position for point> [picks][][menu]

Create Line
After selecting the create line option, the user simply selects two points to be the end points of 
the line using the normal picking sequence.
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The line will be created with name, colour and model from the cogo edit panel.

If either end point is created by snapping to an existing point or line, the z-value for the point is 
taken from the snapped point or if tin snap is on, from the underlying triangulation. If no z-value 
exists, the z-value is taken from the cogo edit panel.

If height snap is on, the snapped z-value will be displayed in an enter height typed input box.

If required, this value can be modified by typing into the enter height box. If the box is empty, the 
z-value is taken from the cogo edit panel. If no value exists in the cogo edit, an error message 
please specify z value is displayed in the cogo edit message area.

The z-value in the enter height box is accepted by entering a <enter> in the box. The enter height 
box then disappears.

Screen message area

<<Create Line> Select 1st point on line> [picks][][menu]
<<Create Line> Select 2nd point on line> [picks][][menu]

Create Point Between Points
The create point between points option allows the user to select two point to act as the end 
points of a line and then create a new point a user supplied given distance along that line.

After selecting the create point between points option, the user simply selects two points to act 
as the end points of the line using the normal picking sequence.

An enter distance from 1st point box is then displayed on the screen and the user simply enters the 
appropriate distance into the box, terminated with a <enter>. The box then disappears.

The point is then created with name, colour and model and z-value from the cogo edit panel.

If no z-value exists in the panel, no point is created.

Screen message area

<<Between> Select 1st point> [picks][][menu]
<<Between> Select 2nd point> [picks][][menu]
<Between> Enter distance from 1st point [caret][][menu] select a button

Locate Offset
The locate offset option is used to create a point at a given perpendicular offset distance from a 
user defined point on a selected item.

The point on the item to offset from is determined by picking a control point on the item and 
projecting along the item by a given distance.

Hence the locate offset option needs

(a) a selected item

(b) a control point

(c) a projection distance

(d) an offset distance

After selecting the locate offset option, the user picks the item to project along using the normal 
picking sequence. The direction imparted when picking the item determines the sense for 
direction along the item and offset left and right.

Next a control point on the item is picked.

A distance along item box is then displayed on the screen and the user enters the appropriate 
distance into the box, terminated with a <enter>. The box then disappears. A positive distance is 
in the picking direction of the item.

Finally an offset distance box is displayed on the screen. The user enters the appropriate offset 
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distance into the box, terminated with a <enter>. The box then disappears. A positive offset is to 
the right of the item when moving in the picking direction of the item.

The appropriate point is then created with name, colour, model and z-value from the cogo edit 
panel.

If no z-value exists in the panel, no point is created.

Screen message area

<<Locate Offset> Select item to project along> [picks][][menu]
<<Locate Offset>  Select control point> [picks][][menu]
<Locate Offset> distance along item [caret][][menu] select a button
<Locate Offset> offset distance [caret][][menu] select a button

Locate Deflection
The locate deflection option is used to create a point at a given deflection angle and distance 
from a user defined point on a selected item.

The locate deflection option is very similar to the locate offset option except instead of going out 
perpendicular to the item, the user provides a deflection angle. Hence the locate offset is a 
special case of the locate deflection option when the deflection angle is ninety degrees.

The point on the item to offset from is determined by picking a control point on the item and 
projecting along the item by a given distance.

Hence the locate deflection option needs

(a) a selected item

(b) a control point

(c) a projection distance

(d) a deflection angle

(e) a deflection distance

After selecting the locate offset option, the user picks the item to project along using the normal 
picking sequence. The direction imparted when picking the item determines the sense for 
direction along the item and offset left and right.

Next a control point on the item is picked.

Boxes for the distance along item, deflection angle and deflection distance are then (sequentially) 
displayed on the screen and the user enters the appropriate values into each box, terminated 
with a <enter>. The box then disappears.

A positive distance is in the picking direction of the item and a positive angle is an angle to the 
right of the item when moving in the picking direction of the item.

The appropriate point is then created with name, colour, model and z-value from the cogo edit 
panel.

If no z-value exists in the panel, no point is created.

Screen message area

<<Locate Deflection> Select item to project along> [picks][][menu]
<<Locate Deflection>  Select control point> [picks][][menu]
<Locate Deflection> distance along item [caret][][menu] select a button
<Locate Deflection> deflection distance [caret][][menu] select a button
<Locate Deflection> deflection angle [caret][][menu] select a button
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Divide - Number
The divide - nos option is used to place points at positions which would divide an arc or a line 
into an equal number of pieces.

For example, if the option was used to show how and an arc could be divided into seven pieces, 
points would be placed at the six division marks. No point is placed at the start or end of the arc. 
Hence, the start and end points plus the division points divide the arc into the required number 
of divisions.

Since the option will only divide an arc or a line, when an item is selected only the picked line or 
arc sub-element of the item will be divided.

On selecting the divide - nos option, the user picks the item to divide using the normal picking 
sequence.

A no of divisions box is then displayed on the screen and the user enters the required number of 
divisions into the box, terminated with a <enter>. The box then disappears.

A point string is then created containing points at each of the required division positions. The 
string has the name, colour, model and z-value from the cogo edit panel.

Screen message area

<<Divide by #> Select item to divide> [picks][][menu]
<Divide by #> no division [caret][][menu] select a button

Divide - Distance
The divide - dist option is used to place points at positions which would divide an arc or a line 
into pieces of a given distance.

Note - unless the arc or line is exactly divisible by the distance, the last division will be smaller 
than the required distance.

Since the option will only divide an arc or a line, when an item is selected only the picked line or 
arc sub-element of the item will be divided.

On selecting the divide - dist option, the user picks the item to divide using the normal picking 
sequence.

A distance box is then displayed on the screen and the user enters the required distance for each 
division into the box, terminated with a <enter>. The box then disappears.

A point string is then created containing points at each of the required division positions. The 
string has the name, colour, model and z-value from the cogo edit panel.

Screen message area

<<Divide by distance> Select item to divide> [picks][][menu]
<Divide by #> distance [caret][][menu] select a button

Perpendicular
The perpend option is used to create the point which is the perpendicular projection of a selected 
point onto a selected line or arc.

Since the option can only drop a point onto an arc or a line, when the item is selected to project 
onto, only the picked line or arc sub-element of the item is used.

On selecting the perpend option, the user picks the point to drop perpendicularly.

The item to drop perpendicularly onto is then selected.

The point representing the perpendicular projection of the chosen point onto the selected item is 
then created. The created point has the name, colour, model and z-value from the cogo edit panel.



12d Model Reference Manual

Page 1072 May 2007Cogo

Screen message area

<<Perpend> Select point to drop> [picks][][menu]
<<Perpend> Select item to drop onto> [picks][][menu]

Projection
The projection option is used to create a point which is given distance along a line or arc.

Since the option can only project a point along an arc or a line, when the item is selected to 
project along, only the picked line or arc sub-element of the item is used.

On selecting the projection option, the user picks the item to project along.

A distance box is then displayed on the screen and the user enters the appropriate projection 
distance into the box, terminated with a <enter>. The box then disappears. A positive distance is 
in the picking direction of the item.

The point representing the projected point along the selected item is then created using the name, 
colour, model and z-value from the cogo edit panel.

Screen message area

<<Projection> Select item to project along> [picks][][menu]
<Projection> distance [caret][][menu] select a button

Locate Chainage
The locate chainage option is used to create a point at a given chainage on a selected string.

On selecting the locate chainage option, the user picks the item to locate the chainage on.

A locate chainage box is then displayed on the screen and the user enters the appropriate 
chainage into the box, terminated with a <enter>. The box then disappears.

A point at the given chainage on the selected item is then created using the name, colour, model 
and z-value from the cogo edit panel.

Screen message area

<<Locate chainage> Select item to locate on> [picks][][menu]
<Locate chainage> chainage [caret][][menu] select a button

Please continue to the next section “Intersect Ops” .

Intersect Ops
intersect_ops

The intersection options are for finding various intersections of lines and arcs.

Most of intersect cases can have more that one solution. For example, the intersection of a line 
with an arc.

To easily distinguish between the cases, 12d Model uses the sense of direction implied when 
picking items to determine which case was required by the user.

The intersect ops walk-right menu is
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Each of the options in the Intersect Ops menu will now be discussed.

For the option Intersect, please continue to the section “Intersect” .
Create line “Create Line” .
intersect offset “Intersect Offset” 
Bearings intersect “Bearings Intersect” .
2 pts 2 dists “Two Points, Two Distances” .

Intersect
The intersect option creates a point at the intersection of lines and arcs.

That is, it will find the intersection of

(a) a line with a line

(b) a line with an arc

or

(c) an arc with an arc

After selecting the intersect option, the user simply selects the two items to intersect using the 
normal picking sequence.

If an intersect exists, a point is created at the intersection with name, colour, model and z-value from 
the cogo edit panel.

If no z-value exists in the panel, no point is created.

When there is more than one possible solution, the order of picking and the directions imparted 
when picking the items are used to determine which solution is required.

Since the option will only intersect arcs and lines, when an item is selected only the picked line 
or arc sub-element of the item is used in the intersect.

Screen message area

<<Intersect> Select 1st item to intersect> [picks][][menu]
<<Intersect> Select 2st item to intersect> [picks][][menu]

Intersect Offset
Like the intersect option, intersect offset is for creating points at the intersection of lines and arcs.

However, before the line or arc is used, it is offset by a user supplied distance.

Hence the intersection is between displaced lines and arcs.

A practical example of intersect offset is for finding the position of a manhole in a subdivision 
which is three metres from one property line and two metres from the culdesac arc.

After selecting the intersect option, the user selects the first item to intersect using the normal 
picking sequence.
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A 1st offset box is then displayed on the screen and the user enters the appropriate offset for the 
first line into the box, terminated with a <enter>. The box then disappears. A positive offset is to 
the right of the item when moving in the picking direction of the item.

The second item to intersect is then selected and a 2nd offset box is displayed on the screen for the 
user to enter the offset for the second line.

If an intersect exists for the two offset items, a point is created at the intersection with name, 
colour, model and z-value from the cogo edit panel.

If no z-value exists in the panel, no point is created.

As in the intersect option, when more than one solutions is possible, the order of picking and the 
directions imparted when picking the items are used to determine which solution is required.

Since the option will only intersect arcs and lines, when an item is selected only the picked line 
or arc sub-element of the item is used in the intersect.

Screen message area

<<Intersect Offset> Select 1st item to intersect> [picks][][menu]
<Intersect Offset> 1st offset [caret][][menu] select a button
<<Intersect Offset> Select 2st item to intersect> [picks][][menu]
<Intersect Offset> 2nd offset [caret][][menu] select a button

Bearings Intersect
The bearings intersect option finds the intersect of the lines going through two user selected 
points at user supplied bearings.

Hence the option will calculate the point that is at given bearings from two selected points

After selecting the bearings intersect option, the user selects the first point using the normal 
picking sequence.

A bearing 1 box is then displayed on the screen and the user enters the bearing for the line 
through the point into the box, terminated with a <enter>. The box then disappears. The bearing 
is entered in degrees, minutes and seconds.

The second point is then selected and a bearing 2 box is displayed on the screen for the user to 
enter the bearing for the line through the second point.

The intersection of the two lines is then calculated and if it exists, a point is created at the 
intersection with name, colour, model and z-value from the cogo edit panel.

If no z-value exists in the panel, no point is created.

Note

The selected points do not have to be actual points in a point string. Any snap or cursor position 
is a valid point for the option

Screen message area

<<Bearings Intersect> Select 1st point> [picks][][menu]
<Bearings Intersect> bearing 1 [caret][][menu] select a button
<<Bearings Intersect> Select 2nd point> [picks][][menu]
<Bearings Intersect> bearing 2 [caret][][menu] select a button

Two Points, Two Distances
The 2 pts 2 dists option find the point that given distances from two user selected points.

This problem is equivalent to finding the intersection of two circles centred on the points and 
with radii the same as the distances.

When there is more than one solution, the solution to the right of the line joining the two points 
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is used. (the direction of the line is from the first point to the second point). To obtain the other 
solution, simply select the points in the opposite order.

After selecting the 2 pts 2 dists option, the user selects the first point using the normal picking 
sequence.

A 1st distance box is then displayed on the screen and the user enters the distance that the new 
point is from the selected point into the box, terminated with a <enter>. The box then disappears.

The second point is then selected and a 2nd distance box is displayed on the screen for the user to 
enter the distance to the second point.

The point that is the required distances from the two points is created with name, colour, model 
and z-value from the cogo edit panel. If no z-value exists in the panel, no point is created.

Note

The selected points do not have to be actual points in a point string. Any snap or cursor position 
is a valid point for the option

Screen message area

<<Locate 2 pts 2 dists> Select 1st point> [picks][][menu]
<Locate 2 pts 2 dists> 1st distance [caret][][menu] select a button
<<Locate 2 pts 2 dists> Select 2nd point> [picks][][menu]
<Locate 2 pts 2 dists> 2nd distance [caret][][menu] select a button

Please continue to the next section “Vector” .

Vector
vector_ops

The vector options are for creating points which are a given as at a given vector from another 
point.

The default definition of the vector is as (bearing, distance) but other combinations such as 
(angle, distance), relative (x,y) and absolute (x,y) are possible using normal typed input.

The methods for creating the new points are

(a) locate - create a new point using a vector

(b) radiation - the points created are all a vector from the initial point selected

(c) traverse - the last point created becomes the next point to work from

The vector walk-right menu is

Each of the options in the Vector Ops menu will now be discussed.
For the option Traverse, please go to the section “Traverse” .

Radiation  “Radiation” .
Intersect offset “Intersect Offset” 
Locate “Locate” .
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Locate
In the locate option, a point is selected and a vector supplied to produce a new point which is 
the vector away from the initial point.

The sequence is then repeated by selecting another point and giving another vector.

After selecting the locate option, the user simply selects the point to be used using the normal 
picking sequence.

A bearing distance box is then displayed on the screen and the user enters the required bearing 
and distance (separated by a space) into the box, terminated with a <enter>. The box then 
disappears.

A new point is then created which is the given bearing and distance from the selected point. The 
new point is given the name, colour, model and z-value from the cogo edit panel. If no z-value exists 
in the panel, the given z-value could be nonsense.

The sequence of picking a point and giving a vector is then repeated.

The option terminates when another cogo option is selected or the cancel button is selected on 
the cogo edit panel.

Screen message area

<<Locate> Select point> [picks][][menu]
<Locate> bearing distance [caret][][menu] select a button

Radiation
In the radiation option, a point is selected and a vector supplied to produce a new point which is 
the vector away from the initial point.

After selecting the radiation option, the user simply selects the point to be used using the normal 
picking sequence.

A bearing distance box is then displayed on the screen and the user enters the required bearing 
and distance (separated by a space) into the box, terminated with a <enter>.

A new point is then created which is the given bearing and distance from the selected point. The 
new point is given the name, colour, model and z-value from the cogo edit panel. If no z-value exists 
in the panel, the given z-value could be nonsense.

The bearing distance box remains on the screen.

If another value is entered into the box (or the previous one left) terminated by a <enter>, a new 
point is created which is the new given bearing and distance from the original selected point.

The option terminates when another cogo option is selected or the cancel button is selected on 
the cogo edit panel.

Screen message area

<<Radiation> Select point> [picks][][menu]
<Radiation> bearing distance [caret][][menu] select a button

Traverse
In the traverse option, an initial point is chosen and a vector supplied to produce a new point 
which is the vector away from the initial point.

The created point is then taken to be the start point for the next sequence of creating a new point 
by a vector.

After selecting the traverse option, the user simply selects the first point to be used using the 
normal picking sequence.



Chapter 14  Strings

May 2007 Page 1077Cogo

A bearing distance box is then displayed on the screen and the user enters the required bearing 
and distance (separated by a space) into the box, terminated with a <enter>.

A new point is then created which is the given bearing and distance from the selected point.

The new point is given the name, colour, model and z-value from the cogo edit panel. If no z-value 
exists in the panel, the given z-value could be nonsense.

The bearing distance box remains on the screen.

If another value is entered into the box (or the previous one left) terminated by a <enter>, a new 
point is created which is the given bearing and distance from the last created point.

Hence, the last created point takes the place of the original selected point.

The option terminates when another cogo option is selected or the cancel button is selected on 
the cogo edit panel.

Screen message area

<<Traverse> Select point> [picks][][menu]
<Traverse> bearing distance [caret][][menu] select a button

Please continue to the next section “Parallel” .

Parallel
Items can be translated perpendicularly to either the left or right using the parallel option (also 
known as a copy parallel operation).

After selecting the parallel option, the user simply selects the item to paralleled using the normal 
picking sequence.

A offset box is then displayed on the screen and the user enters the required offset distance into 
the box, terminated with a <enter>. The box then disappears. A positive offset is to the right of 
the item when moving in the picking direction of the item.

A new item is then created which is a copy parallel of the selected item by the given offset 
distance. The new item has the name, colour and model from the cogo edit panel.

The option terminates when another cogo option is selected or the cancel button is selected on 
the cogo edit panel.

Screen message area

<<Parallel> Select item to parallel> [picks][][menu]
<Parallel> offset> [caret][][menu] select a button

Please continue to the next section “Fillet Ops” .

Fillet Ops
fillet_ops

The fillet options are for creating an arc between lines and arcs.

That is, it will try and fit an arc between

(a) two lines

(b) a line and an arc

or

(c) two arcs
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The created arc is determined by tangents from the items it is a fillet for and another piece of 
information such as a radius or a start point.

Since the option can only fillet between arcs and lines, when an item is selected only the picked 
line or arc sub-element of the item is used in the fillet.

Most fillet cases can have more that one solution. For example, the fillet of a given radius 
between two lines can have up to four solutions.

To easily distinguish between the cases, 12d Model uses the order of picking and the sense of 
direction implied when picking the items to determine which case was required by the user.

The direction is used as follow -

the arc comes off the first item in the direction that the first item is picked and lands on the 
second in the direction that the second item is picked.

The fillet ops walk-right menu is

Each of the options in the Fillet Ops menu will now be discussed.
For the option Item Item Radius, please go to the section “Fillet Item Item Radius” .

Item Item Point  “Fillet Item Item Point” .
Intersect offset “Intersect Offset” 
3 points “Fillet Three Points” .

Fillet Item Item Radius
This fillet option creates an arc of a user given radius between two user selected items.

After selecting the fillet item item radius option, the user selects the first item to be used in the 
fillet using the normal picking sequence.

Next the second item to be used in the fillet is selected.

An enter radius box is then displayed on the screen and the user types the appropriate radius for 
the fillet into the box, terminated with a <enter>. The box then disappears.

A positive radius implies that the arc travels in a clockwise direction and a negative radius for an 
arc travelling in an anti-clockwise direction.

If a fillet exists for the two items and the radius, an fillet arc is created with name, colour, model 
and z-value from the cogo edit panel.

If no z-value exists in the panel, no arc is created.

Screen message area

<<Fillet by radius> Select 1st item> [picks][][menu]
<<Fillet by radius> Select 2nd item> [picks][][menu]
<Fillet by radius> Enter radius [caret][][menu] select a button

Fillet Item Item Point
This fillet option creates an arc between two user selected items starting at a user defined control 
point.

After selecting the fillet item item pt option, the user selects the first item to be used in the fillet 
using the normal picking sequence.
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Next the second item to be used in the fillet is selected.

Finally, a point is selected to act as the starting point for the fillet. This point, called the control 
point, must lie on the first item selected. If the selected point doesn’t lie on the first item, the 
selected point is projected perpendicularly onto the item and the projected point used as the 
control point.

If a fillet exists for the two items and the control point, a fillet arc is created with name, colour, 
model and z-value from the cogo edit panel.

If no z-value exists in the panel, a null z-value is used.

Screen message area

<<Fillet by start point> Select 1st item> [picks][][menu]
<<Fillet by start point> Select 2nd item> [picks][][menu]
<<Fillet by start point> Select start point> [picks][][menu]

Fillet Three Points
This option creates an arc between three user selected points.

After selecting the fillet 3 pts option, the user selects the three points one after another using the normal 
picking sequence.
The three arc points must be selected in the order

(a) the start point
(b) a point between the start and end point
(c) the end point

If an arc does exist containing the three points, it will be unique including its direction. The arc 
will be created with name, colour, model and z-value from the cogo edit panel.

If no z-value exists in the panel,   a null z-value is used.

Screen message area

<<Fillet 3 points> Select 1st item> [picks][][menu]
<<Fillet 3 points> Select 2nd item> [picks][][menu]
<<Fillet 3 points> Select start point> [picks][][menu]

Please continue to the next section “Fillet Ops (T)” .

Fillet Ops (T)
fillet_ops__t_

The fillet (T) options are the almost identical to the fillet options.

The only difference is that after the fillet arc is created, the original items are trimmed back to the 
start and end of the arc.

The trimmed items are not joined to the fillet arc.

The original strings obey the trash defaults from the utilities=>defaults=>trash defaults option.

That is, if the trash mode is set to keep string, the original strings are untouched.
        delete string, deleted.
       trash string, moved to the trash model.
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For information on the fillet options, see the section “Fillet Ops” 
For the option Item Item Radius, please go to the section “Fillet Item Item Radius” .

Item Item Point  “Fillet Item Item Point” .

Please continue to the next section “Fillet Ops (TJ)” .

Fillet Ops (TJ)
fillet_ops__tj_

The fillet (TJ) options are the almost identical to the fillet and fillet (T) options.

The only difference is that after the fillet arc is created, the original items are trimmed back to the 
start and end of the arc and the three items joined to form a new item.

That is, the trimmed items are joined to the fillet arc.

The original strings obey the trash defaults from the Utilities=>Defaults=>Trash defaults option.

That is, if the trash mode is set to keep string, the original strings are untouched.
        delete string, deleted.
       trash string, moved to the trash model.

For information on the fillet options, see the section “Fillet Ops” 

For the option Item Item Radius, please continue to the section “Fillet Item Item Radius” .
Item Item Point   “Fillet Item Item Point” .

Please continue to the next section “Tangent” .

Tangent
The tangent option creates tangent lines between point and arcs.

That is, tangents can be defined between

(a) a point and an arc

(b) two arcs

or

(c) two points - simply a line between the two points

Since the option can only fillet between points and arcs, when an item is selected, only the picked 
sub-arc of the item is used as an arc.

Most tangent cases can have more that one solution. For example, two tangents from a point to 
an arc.

To easily distinguish between the cases, 12d Model uses the order of picking the items and the 
sense of direction implied when picking an arc to determine which case was required by the 
user.

After selecting the tangent option, the user selects the first item to be used in the tangent 
calculations using the normal picking sequence.

Next the second item to be used is selected.
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If a tangent line exists between the two items selected, a line string is created with name, colour, 
model and z-value from the cogo edit panel.

If no z-value exists in the panel, a null z-value is used for the line.

Screen message area

<<Tangent> Select 1st item> [picks][][menu]
<<Tangent> Select 2nd item> [picks][][menu]
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Convert
convert_string

Position of option on menu: Strings =>Convert

The Convert option is used to create a new string of possibly a different string type from a chosen 
string.

Since not all string conversion are possible, or even make sense (for example, converting a 3d 
string to a text string), the list of defined conversion depends on the type of the string chosen for 
conversion.

After selecting the string to convert, a menu containing the possible conversions is raised and the 
required conversion selected from it.

After the type of conversion is selected, a string Properties panel containing the attribute 
information for the new string is displayed and can be used to modify any properties of the new 
string.

After selecting the Convert option, the Convert String panel is placed on the screen.

If a new name, model or colour is required for the converted string, the new data is entered into 
the Convert String panel. If a change isn’t required, leave the appropriate panel field blank.

The Convert option is already in progress and if a string is selected and accepted, a menu 
containing all the available conversions for that particular string type is displayed.

convert_2d_string_to
convert_3d_string_to
convert_4d_string_to
convert_Alignment_string_to
convert_arc_string_to
convert_drainage_string_to
convert_pipe_string_to
convert_pipeline_string_to
convert_super_string_to
convert_super_alignment_string_to
For example, for each string type the choices are:
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After selecting the conversion to be made, a new string of the selected type is created and given 
the model, colour and name according to the fields in the Convert String panel.

The Properties panel for the new string is also displayed and hence any of the strings properties 
can be modified for the new string.

The fields and buttons used in the Convert String panel have the following functions.

Field Description Type Defaults Pop-Up

New name input

If blank, the converted string is given the same name as the original string.
If non-blank, then the converted string is given the name in the new name field.

New model input available models

if blank, the converted string is placed in the same model as the original string. 
If non-blank, then the converted string will be placed in the model given in the new model field.
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New colour input available colours

if blank, the converted string is given the same colour as the original string.
If non-blank, then the converted string is given the colour in the new colour field.

Mode input keep string keep, delete, trash string

if delete string, the string selected to be converted is deleted.
     keep string, the selected string is not deleted.
    trash string, the string selected to be converted is moved to the trash model. 
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Inquire
string_inquire

Position of option on menu: Strings =>Inquire

The inquire option is used to obtain information about a string displayed on the screen.The 
amount and type of information varies between string types.

On selecting the Inquire option, the String Inquire panel is displayed.

The panel is used for any special messages and to end the option.

After selecting the inquire option, the strings are selected using the normal 12d Model selecting 
mechanism (LB to pick a string, MB to accept a string, RB for the pick ops menu). Whenever a 
string is picked, the information about the picked string is displayed on the screen in the 
Information menu.

An example of the Information menu for an Alignment string is

For more details on the Information menu, go to the section “String Information”  

Any number of string inquiries can be made with the option by repeated use of the mouse 
buttons LB and MB to pick and accept strings.

The inquire option is terminated by either selecting the Cancel option from the Pick Ops menu 
(raised by clicking RB) or selecting Finish or [X] from the String Inquire panel.

String Information
information
Whenever a string is picked, the information about the picked string is displayed on the screen 
in the Information menu

The Information menu displays different information depending on whether the string was 
picked in a Plan or Perspective view or in a Section view.
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For a Plan or Perspective View

The details on the Information menu can include:

model = - gives the model of the selected string
name = - "  name " " " 
type = - "  type " " " 
colour = - " colour " " " 
line style = - " line style " " " 
pt/line = - " " breakline type " " " 
# pts = - " " number of points " " " 
area = - " " area if it is a closed string
length = - " " length of the string
Snap type - e.g. Line Snap, Point Snap
x = - " " x co-ordinate of the selected position
y = - " " y co-ordinate of the selected position
prof ch = - " " chainage of the selected position on the string
prof z = - " " z-value of the selected position on the string
brg = - " instantaneous bearing of the selected position on the string
segment length - " length of the string segment containing the selected position
+ve or -ve - if the direction of the pick was the same as the direction of the

 string, then +ve is displayed otherwise the direction of the pick
is opposite to the string direction and a -ve is displayed.

For a Section View

For a section view, the x-axis of the view is defined by the chainage along the string that is 
being profiled on the section view (the profiled string). The profiled string is displayed on the 
section view.

For any tins in models added to the section view, the sections through the tins along the 

Information When Snapping to an Alignment on a Plan View

The information 
refers to the 
snapped position 
and string
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profiled string are also displayed in the section view.

Finally, any parts of any strings in models added to the section view that are in the corridor 
defined for the section view are projected onto the section view and displayed.

The details on the Information menu can include:

model = - gives the model of the selected string
name = - "  name " " " 
type = - "  type " " " 
colour = - " colour " " " 
line style = - " line style " " " 
pt/line = - " breakline type " " " 
# pts = - " number of points " " " 
area = - " area if it is a closed string
length = - " length of the string
Snap type - e.g. Line Snap, Point Snap
x = - " x co-ordinate of the selected position
y = - " y co-ordinate of the selected position
z = - " z co-ordinate of the selected position
prof ch = - " chainage of the profiled string at the selected position

Note that this is not the chainage of the selected string unless
the selected string is the profiled string

prof z = - " " z-value of the profiled string at the profile chainage of
the selected position

Note that this is not the z of the selected position unless
the selected string is the profiled string

brg = - " instantaneous bearing of the selected position on the string
segment length - " length of the string segment containing the selected position
+ve or -ve - if the direction of the pick was the same as the direction of the

 string, then +ve is displayed otherwise the direction of the pick
is opposite to the string direction and a -ve is displayed.

IMPORTANT NOTES

1.  for a string selected on a section view, the " z = " value is the z co-ordinate of the selected 
position. The "prof z = " value is the z co-ordinate of the string profiled on the section view.

2. The "prof ch = " value is the chainage of the string profiled on the section view, not the 
chainage of the selected string.
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Information When Snapping to the Primary String for a Section View

The "z=" and "prof z ="are 
the same, and are the z-
value at the primary string

Primary string 
for the section 
view

Information When Snapping to a Tin on a Section View

"z =" is the z-
value at the 
snap position

"prof z =" is the 
z-value at the 
primary string 
for the section 
view

Primary string 
for the section 
view
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Information When Snapping to a Service String on a Section View

"z =" is the z-
value at the 
snap position

"prof z =" is the 
z-value at the 
primary string 
for the section 
view

Primary string 
for the section 
view

Information for a Cursor Snap on a Section View

"prof z =" is the 
z-value at the 
primary string 
for the section 
view

"z =" is the 
z-value at 
the snap 
position

Primary 
string for the 
section view
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Properties
strings_properties

Position of menu: Strings =>Properties

The Properties walk-right menu contains options to obtain and/or modify the properties of any 
string displayed on the screen, or obtain and/or modify the vertices and segments of a super 
string.

The Properties walk-right menu is

For the option String, go to the section “String” 
Vertex “Vertex” 
Vertex (all) “Vertex - All above” 
Segment “Segment” 
Segment (all) “Segment - All above” 
Vertex/Segment “Vertex/Segment” 
Attributes “Attributes” 
Super strings “Super Strings” 
Match “Match” 

String
string_properties

Position of option on menu: Strings =>Properties =>String

The String option obtains and/or modify property information about any string displayed on the 
screen.

For example, the string’s name, colour and style are string properties. Each string type has its 
own particular set of properties.

On selecting the String option, the String Properties panel is displayed.

The panel is only used for any special messages and to end the option.

The String Properties option is automatically in a pick mode and the user selects strings using the 
normal 12d Model picking mechanism (LB to select a string, MB to accept a string, RB for the 
pick ops menu). Whenever a string is selected, the appropriate Properties panel for the string 
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type is displayed on the screen with all the picked string’s properties shown.

For example, for a 2d string, the Properties panel is

To modify any of the properties for the selected string, simply change the information in the 
appropriate panel field and select the OK or Apply button.

The Properties panel is also brought up by the Properties option on each string editor and the 
Properties panel have been shown for each string in the Editor section of the manual.

Please continue to the next section “Vertex” .

Vertex
string_vertex_properties

vertex_properties

Position of option on menu: Strings =>Properties =>Vertex

The Vertex option obtains and/or modify property information about the vertex of any super 
string displayed on the screen.

For example, the height, symbol, annotation, point no are all properties of a super string vertex.

On selecting the Vertex option, the String Vertex Properties panel is displayed.

The panel is only used for any special messages and to end the option.

The String Vertex Properties option is automatically in a pick mode and the user selects the vertex 
of a super string using the normal 12d Model picking mechanism. Whenever a vertex is selected, 
a Vertex menu showing the properties of the vertex is displayed on the screen.
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To modify any of the properties for the selected vertex, simply click on the appropriate item on 
the Vertex menu and the appropriate panel will come up to modify the vertex property.

Please continue to the next section “Segment” .

Segment
string_segment_properties

segment_properties

Position of option on menu: Strings =>Properties =>Segment

The Segment option obtains and/or modify property information about the segment of any 
super string displayed on the screen.

For example, the visibility, radius, colour, text are all properties of a super string segment.

On selecting the Segment option, the String Segment Properties panel is displayed.

The panel is only used for any special messages and to end the option.

The String Segment Properties option is automatically in a pick mode and the user selects the 
segment of a super string using the normal 12d Model picking mechanism. Whenever a segment is 
selected, a Segment menu showing the properties of the segment is displayed on the screen.

To modify any of the properties for the selected segment, simply click on the appropriate item on 
the Segment menu and the appropriate panel will come up to modify the segment property.
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Please continue to the next section “Vertex/Segment” .

Vertex/Segment
string_vertex_segment_properties

vertex_properties segment_properties

Position of option on menu: Strings =>Properties =>Vertex/Segment

This option is a combination of the Vertex and Segment options already documented.

The Vertex/ Segment option obtains and/or modify property information about the vertex or segment of 
any super string displayed on the screen.
On selecting the Vertex/Segment option, the String Vertex/Segment Properties panel is displayed.

The panel is only used for any special messages and to end the option.

The String Vertex/Segment Properties option is automatically in a pick mode and the user selects 
either the vertex or the segment of a super string using the normal 12d Model picking mechanism. 
Whenever a vertex or segment is selected, the Vertex or Segment menu showing the properties of 
the selected vertex or segment is displayed on the screen.

Attributes
string_attributes
Position of option on menu: String =>Properties =>Attributes

The Attributes options displays, creates and edits attributes for any strings in the project.

On selecting Attributes, the String Attributes panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

String tab
this tab displays/edits the attributes that apply for the entire string. All string types have these.

Name

name of the string attribute

Type integer, real, text

type of attribute - integer, real or text

Data

value for the string attribute

Segment tab
this tab displays/edits the attributes for each segment of a super string or pipe of a drainage 
or sewer string.

Segment no.

number of the segment of the string to display/edit attributes for

Prev button

go to the previous segment of the string.

Next button

go to the next segment of the string.

Name

name of the attribute for the segment
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Type integer, real, text

type of attribute - integer, real or text

Data

value for the attribute for the segment

Vertex tab
this tab displays/edits the attributes for each vertex of a super string or pit of a drainage or 
sewer string.

Vertex no.

number of the vertex of the string to display/edit attributes for

Prev button

go to the previous vertex of the string.

Next button

go to the next vertex of the string.

Name

name of the attribute for the vertex

Type integer, real, text

type of attribute - integer, real or text

Data

value for the attribute for the vertex

Pick button

pick the string to display/edit the attributes for

OK button

set the attributes to the values in the panel and then exit the panel.

Apply button

set the attributes to the values in the panel but don’t exit the panel.
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Super Strings
super_strings

Position of menu: Strings =>Properties =>Super strings

The super string has many 

The Super string walk-right menu is:

For the option Chainage interval, go to the section “Chainage Interval” .
Visible “Visible” 
Compress “Compress” 
Tinable “Tinable” 
Fills “Fills” 
Symbol “Symbol” 
Segment colour “Segment Colour” 
Height “Height” 
Attribute “Attribute” 
Vertex id “Vertex Id” 
Pipe/culvert/extrude “Pipe/Culvert” 
Radius “Radius” 
Segment geometry “Segment Geometry” 
Text “Text” 

set/reset the chainage interval and chord/arc tolerance
set visibility flags to constant/variable or clear the flag
compress a super sting
set tinability to constant/variable or clear the flag
set fill styles for the string
define symbols constant/each vertex or have no symbols
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Chainage Interval
change_super_string_chainage_interval

Position of option on menu: Strings =>Properties =>Super strings =>Chainage interval

A super string has one chainage interval value for the entire string. If the value is non-zero, then 
any line segments of the string are subdivided by the chainage interval when the super string is 
used in triangulations.

A super string also has one arc-chord tolerance value for the entire string. If the value is non-zero, 
then any curved segments are subdivided by the arc-chord tolerance when used in 
triangulations.

The Chainage interval option can set the chainage interval value and/or the chord-to-arc tolerance 
value for selected super strings.

On selecting the Chainage interval option, the Change Super String Chainage Interval panel is 
displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Interval tab

Action choice box ignore set, clear, ignore

if set, set the chainage intervals of the selected super strings to the value in Chainage interval.
If clear, set all the selected super strings to not use a chainage interval.
If ignore, don’t modify the chainage interval of the selected super strings.
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Chainage interval input

the chainage interval to use for a super string.

Chord/arc tolerance tab

Action choice box ignore set, clear, ignore

if set, set the chord/arc tolerance of the selected super strings to the value in Chord/arc tolerance.
If clear, set all the selected super strings to not use a chord/arc tolerance.
If ignore, don’t modify the chord/arc tolerance of the selected super strings.

Chord/arc tolerance input

the chord/arc tolerance to use for a super string.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings
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Visible
change_super_string_visibility

Position of option on menu: Strings =>Properties =>Super strings =>Visible

For selected super strings, the Visible option can set the flags that determine how visibility is 
defined for a super string.

Segment visibility can 

(a) be not setable at all for the string - it is always visible

(b) have one setting for the entire string - visible only

(c) have separate settings for each segment (and all set to visible)

Similarly, vertex visibility can 

(a) be not setable at all for the string - it is always visible

(b) have one setting for the entire string - visible only

(c) have separate settings for each segment (and all set to visible).

The Visible option allows any of the above cases to be set up for the selected super strings.

On selecting the Visible option, the Change Super String Visibility panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input
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source of data is to be processed.

Vertex tab

Action choice box ignore set, clear, ignore

if set, the vertex visibility can be allowed to be a constant for all vertices in the string, or to be different 
for each vertex in the string.
If clear, the vertex visibility flags are removed for the string and the string vertices are always visible.
If ignore, don’t modify the visibility flags for the vertices of the string.

Apply choice box

if Action is set, then the Apply field is used.
If Apply is constant, the string has only one visibility flag and it applies to all vertices in the string. It is 
set to visible.
If Apply is variable, each vertex in the string has its own visibility flag and each flag is set to visible.

Segment tab

Action choice box ignore set, clear, ignore

if set, the segment visibility can be allowed to be a constant for all segments in the string, or to be 
different for each segment in the string.
If clear, the segment visibility are removed for the string and the string segments are always visible.
If ignore, don’t modify the visibility flags for segments of the string.

Apply choice box

if Action is set, then the Apply field is used.
If Apply is constant, the string has only one visibility flag and it applies to all segments in the string It 
is set to visible
If Apply is variable, each segment in the string has its own visibility flag and each flag is set to visible.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings.
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Compress
compress_super_string_dimensions

Position of option on menu: Strings =>Properties =>Super strings =>Compress

The compress option removes any super string dimensions that are not needed. For example, 
dimensions such radius, variable z etc. that are not being used in the string are removed.

This reduces the storage required for the super string.

On selecting the Compress option, the Change Super String Visibility panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings
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Tinable
change_super_string_tinability

Position of option on menu: Strings =>Properties =>Super strings =>Tinable

For selected super strings, the Tinable option can set the flags that determine how tinability is 
defined for a super string and can also set whether segments or vertices are tinable or not.

Segment tinability can 

(a) be not setable at all for the string - it is always tinable

(b) have one setting for the entire string

(c) have separate settings for each segment.

Similarly, vertex tinability can 

(a) be not setable at all for the string - it is always tinable

(b) have one setting for the entire string

(c) have separate settings for each segment.

The Tinable option allows any of the above cases to be set up for the selected super strings.

On selecting the Tinable option, the Change Super String Tinability panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 
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Data source input

source of data is to be processed.

Vertex tab

Action choice box ignore set, clear, ignore

if set, the vertex tinability can be allowed to be a constant for all vertices in the string, or to be different 
for each vertex in the string.
If clear, the vertex tinability can not be modified for the string and the string vertices are always 
tinable.
If ignore, don’t modify the tinability flags for the vertices of the string.

Apply choice box

if Action is set, then the Apply field is used.
If Apply is constant, the string has only one tinability flag and it applies to all vertices in the string. The 
tinability flag it is set to the value in the Value field.
If Apply is variable, each vertex in the string has its own tinability flag. The tinability flag it is set to the 
value in the Value field.

Value choice box

if Value is on, then the tinable flag is set to tinable.
If Value’ is off, then the tinable flag is set to not tinable.

Segment tab

Action choice box ignore set, clear, ignore

if set, the segment tinability can be allowed to be a constant for all segments in the string, or to be 
different for each segment in the string.
If clear, the segment tinability can not be modified for the string and the string segments are always 
tinable.
If ignore, don’t modify the tinability flags for segments of the string.

Apply choice box

if Action is set, then the Apply field is used.
If Apply is constant, the string has only one tinability flag and it applies to all segments in the 
string.The tinability flag it is set to the value in the Value field.
If Apply is variable, each segment in the string has its own tinability flag. The tinability flag it is set to 
the value in the Value field

Value choice box

if Value is on, then the tinable flag is set to tinable.
If Value is off, then the tinable flag is set to not tinable.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings
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Fills
change_super_string_filling

Position of option on menu: Strings =>Properties =>Super strings =>Fills

For selected super strings, the Fills option can set the flags that determine how filling is defined 
for a super string. If the string is not closed, the first and last vertices are joined to define the 
region to fill.

A string can have zero, one or more types of fills from the types solid, bitmap, pattern, hatch and 
Autocad.

On selecting the Fill option, the Change Super String Filling panel is displayed.

The fields and buttons used in the panel have the following functions.
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Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Solid, Bitmap, Pattern, Hatch and Autocad Tabs

each tab defines how that type of fill is applied to the string. Zero, one or more fill types can be applied 
to a string.

Action choice box ignore set, clear, ignore

if set, this type of fill is set for the string.
If clear, this type of fill is turned off for the string.
If ignore, don’t modify this type of fill for the string.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings
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Symbol
change_super_string_symbol

Position of option on menu: Strings =>Properties =>Super strings =>Symbol

For selected super strings, the symbols option can set the flags that determine how symbols are 
defined for a super string.

A super string can have no symbols, a constant symbol definition for the entire string or different 
symbol definitions at each vertex.

On selecting the symbol option, the Change Super String Symbols panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.
Action choice box ignore set, clear, ignore

if set, a symbol can be constant for all vertices in the string, or can be different for each vertex in the 
string.
If clear, there are no symbols for the string.
If ignore, don’t modify the symbol flags for the vertices of the string.

Apply choice box constant, variable

if Action is set, then the Apply field is used.
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If Apply is constant, the string has only one symbol and it used for each vertices in the string. It is set to 
visible.
If Apply is variable, each vertex in the string has its own symbol.

Symbol symbol box

symbol to be used.

Size

size of the symbol.

Rotation angle box

angle to rotation the symbol - positive is counter-clockwise.

Colour colour box

colour for the symbol (if the symbol has no imbedded colours).

Offset

distance the centre of the symbol is from the vertex.

Raise

distance the centre of the symbol is raised off the line through the vertex with the given angle.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings
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Segment Colour
change_super_string_segment_colour

Position of option on menu: Strings =>Properties =>Super strings =>Segment colour

A super string has a default colour used for the entire string and segment colours setable for each 
segment which override the string colour for that segment.

The segment colour option can set a segment colour for every segment in the super string or 
clear all the set segment colours so that the default string colour is used.

On selecting the segment colour option, the Change Super String Segment Colour panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.
Action choice box set, clear

if set, each segment colour is set to the colour in the Colour box.
If clear, any segment colours are removed and each segment set to having no segment colour.

Colour colour box

if Action is set, then every segment is set to this colour.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings
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Height
change_super_string_height

Position of option on menu: Strings =>Properties =>Super strings =>Height

A super string can have the one height that is used for every vertex in the super string (constant 
height) or it can have a different height at each vertex.

The Height option can set the super string to either having a constant height or to allow each 
vertex to have independent heights.

On selecting the Height option, the Change Super String Height panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.
Action choice box ignore set, clear

if set, the string height can be a constant for the entire string, or to be different for each vertex in the 
string.
If clear, the entire string and each vertex has no height.

Apply choice box constant, variable

if Action is set, then the Apply field is used.
If Apply is constant, the string has only one height and no vertex has its own height. The height for the 
string is set to the height in the Height field.
If Apply is variable, each vertex in the string is set to have has its own height and it is set to the value in 
the Height field.

Height

if Action is set, then either the entire string or every vertex is set to this height.
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Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings
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Attribute
change_super_string_attribute

Position of option on menu: Strings =>Properties =>Super strings =>Attribute

A super string can have independent attributes for the entire string, independent attributes for 
each segment and for each vertex.

The Attributes option can clear the super string attributes for the entire string, each vertex and/or 
each segment.

On selecting the Attributes option, the Change Super String Attributes panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.
Vertex Action choice box ignore ignore, clear

if clear, the attributes are cleared at each vertex.
If ignore, nothing is done for the vertex attributes.

Segment Action choice box ignore ignore, clear

if clear, the attributes are cleared on each segment.
If ignore, nothing is done for the segment attributes.

String Action choice box ignore ignore, clear

if clear, the string attributes are cleared.
If ignore, nothing is done for the string attributes.

Target type
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data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings.
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Vertex Id
change_super_string_vertex_id

Position of option on menu: Strings =>Properties =>Super strings =>Vertex id

A super string has a Vertex id for each vertex.

The Vertex id option can set the Vertex ids to sequential numbers (optionally ignoring existing 
Vertex ids) or clear all the existing vertex ids for the super string.

On selecting the Vertex id option, the Change Super String Vertex Id panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.
Action choice box set, clear

if clear, the vertex ids are cleared at each vertex.
If set, the vertex id’s are given sequential numbers starting with the number given in First vertex id field.

First vertex id

if Action is set, the vertex id’s start with this value.
Replace existing vertex id’s tick box

if tick, any vertex with an existing vertex is not given a new vertex id.
If not tick, all vertices are given new vertex ids.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.
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Change button

process the selected strings.



Chapter 14  Strings

May 2007 Page 1115Properties

Pipe/Culvert
change_super_string_pipe_culvert

Position of option on menu: Strings =>Properties =>Super strings =>Pipe/culvert/extrude

Each segment of a super string can have a diameter or a rectangular cross-section (box culvert).

On selecting the Pipe/culvert option, the Change Super String Pipe/Culvert panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Justification

Action choice box set, clear, ignore

if set, the string justification is set to the type given in the Pipe level field.
If clear, the string justification information is cleared.
If ignore, nothing is done to the string justification.

Justification

if Action is set, the string justification is set to this value.
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Mode

Apply to choice box pipe, culvert

if pipe, the next section of the panel has fields for setting pipe information.
if culvert, the next section of the panel has fields for setting culvert information.

Pipe

Action choice box set, clear, ignore

if set, then the Pipe Apply field specifies how the pipe information is modified.
If clear, the pipe information is cleared at each segment.
If ignore, nothing is done to the pipe information.

Apply choice box constant, variable

if Pipe Action is set, then the Apply field is used.
    If Apply is constant, the string has only one diameter and no segment has its own diameter. The 
diameter for the string is set to the value in the Diameter field.
   If Apply is variable, each segment in the string is set to have has its own diameter and it is set to the 
value in the Diameter field.

Diameter

diameter for each pipe segment.

Culvert

Action choice box set, clear, ignore

if set, then the Culvert Apply field specifies how the culvert information is modified.
If clear, the culvert information is cleared at each segment.
If ignore, nothing is done to the culvert information.

Apply choice box constant, variable

if Culvert Action is set, then the Apply field is used.
    If Apply is constant, the string has only one width and height and no segment has its own width and 
height. The width and height for the string is set to the values in the Width and Height fields.
   If Apply is variable, each segment in the string is set to have has its own width and height and they 
are set to the values in the Width and Height fields.

Width/Height

width/height for each culvert segment.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings.
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Radius
change_super_string_radius

Position of option on menu: Strings =>Properties =>Super strings =>Radius

The Radius option clears any segment radii.
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Segment Geometry
change_super_string_segment_geometry

Position of option on menu: Strings =>Properties =>Super strings =>Segment geometry

The Segment geometry option clears any segment geometry.
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Text
change_super_string_text

Position of option on menu: Strings =>Properties =>Super strings =Text

Each vertex and segment of a super string can have its own text.

The Text option can set, clear the vertex or segment text and/or textstyle data for the super string.

On selecting the Text option, the Change Super String Text panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Vertex tab

Vertex text

Action choice box ignore set, clear, ignore

if set, the vertex text can be a constant for the entire string, or to be different for each vertex in the 
string.
If clear, the vertex text is cleared.
If ignore, nothing is done to the vertex text.
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Apply choice box constant, variable

if Action is set, then the Apply field is used.
If Apply is constant, the string has only one vertex text value and no vertex has its own vertex text. The 
vertex text for the string is set to the text in the Text field.
If Apply is variable, each vertex in the string is set to have has its own text and it is set to the value in 
the Text field.

Text

if Action is set, then either the entire string or every vertex text is set to this value.

Vertex annotation

Action choice box ignore set, clear, ignore

if set, the vertex textstyle data can be a constant for the entire string, or to be different for each vertex 
in the string.
If clear, the vertex textstyle data is cleared.
If ignore, nothing is done to the vertex textstyle data.

Apply choice box constant, variable

if Action is set, then the Apply field is used.
If Apply is constant, the string has only one vertex textstyle data and no vertex has its own vertex 
textstyle data. The vertex textstyle data for the string is set to the text in the Textstyle data field.
If Apply is variable, each vertex in the string is set to have has its own textstyle data and it is set to the 
value in the Textstyle data field.

Textstyle data

if Action is set, then the vertex textstyle data is set to this value.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected strings.
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Match
prop_match_panel

Position of option on menu: Strings =>Properties =>Match

The Match option obtains information from a selected string and uses that to set information on 
another selected string.

On selecting the Match option, the Properties Match panel is displayed.

The properties match option is automatically in a pick mode for selecting the string whose 
properties you wish mimic (source string). 

After the source string is selected, the values of the property from the source string are filled in 
on the panel and tick boxes turned on for each property. The tick boxes can be turned off if that 
property is not to be modified on the selected strings. The strings to change are then selected one 
after another.

If a new set of properties is required, selecting the Reset button is used to select a new source 
string. 

The fields and buttons in this panel have the following functions.

Field Description Type Defaults Pop-Up

Name tick box tick

if tick, set the name of the selected string to the value displayed in the Name field.

Model tick box tick

if tick, set the model of the selected string to the value displayed in the Model field.

Linestyle tick box tick

if tick, set the model of the selected string to the value displayed in the Linestyle field.

Point-Line tick box tick

if tick, set the model of the selected string to the value displayed in the Point-Line field.

Text tick box tick

if tick, set the textstyle and height of a selected string to the values displayed in the Text field.

Colour tick box tick

if tick, set the colour of the selected string to the value displayed in the Colour field.

Reset button

Select a new source string to set the values of the properties on the panel.
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Label
string_labelling

Position of menu: Strings =>Properties =>Label

The label menu contains options to label string chainages, create tadpoles for cut and fill, label 
string vertices with their x, y, z or point numbers and names.

The Label walk-right menu is

For Chainages  go to “Label Chainages” .
Cut/fill “Label Cut/Fill” .
Names “Label Names” .
Vertices “Label Vertices” .

Label Chainages
label_chainages_on_string

Position of option on menu: Strings =>Label => Chainages

The label chainages option is used to create text at regular chainages and special points on a 
string such as horizontal and vertical tangent points, crest and sag points and user selected 
points. It can also create tick marks at selected chainages.

The user has control over the label height, colour, angle, offset and the number of decimal places 
displayed, plus the size and colour of the tick marks.

As well as being used for labelling centre-lines, this option is used in conjunction with the sewer 
option to created special labels for sewer long section plots.

On selecting the Label chainages option, the label chainages on string panel is displayed.
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Individual points can be labelled by selecting them after picking the Points button.

The marks button brings up the label chainages on string (marks) panel which is used to place 
marks at the chosen chainages.

The fields and buttons used in the label chainages on string panel have the following functions.

Field Description Type  Defaults Pop-Up

Data source type

data source type.

Data source

data source for strings to label.

Label mode input regular interval,
regular interval plus end pts
end points only
horizontal TPs,
vertical TPs,
horizontal discontinuities
vertical discontinuities
all discontinuities,
 crests/sags
all horizontal points

type of labelling required.
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Ch interval or n/a input

the regular interval to use for labelling points.

Ch reference input 0

the chainages to be labelled are integer multiples of the chainage interval added to the reference 
chainage. For example, if the reference chainage is 23.2 and the chainage interval 10, the chainages 
3.2, 13.2, 23.2, 33.2 etc. will be labelled.

Start chainage input

if non-blank, the string chainage to start labelling from.
If blank, start at the beginning of the string.

End chainage input

if non-blank, the string chainage to end the labelling at.
If blank, go to the end of the selected string.

Special chainage input

file of special chainages to create labels at.

Chord/arc tolerance input default chord/arc tolerance

the chord to arc tolerance to use on the strings being labelled for determining how many points are 
labelled around horizontal curves.

Labels tab

Model for labels model box available models

if non-blank, labels are generated and placed in this model.
If blank, no labels are created (but tick marks may be).

Pre*postfix for labels input

the beginning and ending of the label to be given at each point. Spaces are significant. This uses the 
standard 12d method of pre-text*post-text. That is,’Ch * m’ would add ’Ch ’ before the value and ’ m’ 
after the label.

Textstyle info textstyle box 1 available textstyle data

textstyle data to use when creating the labels.

# dec pl for labels input 0

number of decimal places used in the labels.

Chainages tick tick

if tick, the chainage of each point is appended to the label stem to create the label for the point.
If no tick, only the label stem is used as the label.

Heights tick

if tick, the height of each point is used in the label for the point.
If no tick, heights are not used in the label.

Null heights tick

if tick and the height of a point null, (null) is used in the label for the point.
If no tick, null heights are not used in the label.

Add TC, CT etc. tick

if tick and labelling an alignment string, the critical point types are used in the label for the point.
If no tick, critical point types are not used in the label.

Marks tab

Model for marks input available models

if non-blank, tick marks are generated according to the label mode and placed in this model.
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If blank, no tick marks are created.

 Mode for marks input ticks centred ticks on lhs, ticks on rhs,
ticks centred

mode for the tick marks.

Name for marks input 1

name to give the tick marks (mainly used for mapping files)

Size for marks (w) input 1

size in world units for the tick marks

Colour for marks input orange available colours

colour of the tick marks.

Points button

pick individual positions to label with a label stem and chainage (if the chainages field is set to tick).

Label button

label the selected strings as specified by the label mode, mode for marks and other fields in the panel.

Please continue to the next section “Label Cut/Fill” .
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Label Cut/Fill
cut_fill_marks

Position of menu: Strings =>Label => Cut/Fill

The cut/fill menu contains options to create cut and fill tick marks between selected strings.

The options can generate standard tadpoles, tick marks or use user specified model as the tick 
symbol.

For each option, a reference string is selected which defines the chainages used for labelling cut/
fill. The cut/fill symbols are drawn perpendicular to the reference string.

Two strings, str1 and str2 are selected for labelling. 

The tick symbols are drawn at right angles to the reference string at a user specified chainage 
going between the two strings, str1 and str2, from the higher string point to the lower string 
point (which string is higher or lower may vary along the strings). The tick symbol is repeated at 
the given chainage interval.

 The tick symbol is drawn as a percentage of the distance from the high point to the low point 
between the two strings, str1 and str2 and this percentage is specified separately for the odd and 
even numbered ticks.

The cut/fill walk-right menu is

For the option Tadpoles, please go to the section “Tadpoles” .
Ticks  “Ticks” 
Ticks  “Ticks” 
User symbols  “User Symbols” 
From file  “From File” 

Tadpoles
label_tadpoles_marks

Position of option on menu: Strings =>Label => Cut/Fill => Tadpoles

The tadpoles option is used to generate tadpole symbols between two strings. 

On selecting the tadpoles option, the label tadpoles marks panel is displayed.
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The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Start chainage input

if non-blank, the reference string chainage to start creating tadpoles from.
if blank, the reference string start chainage is used.

End chainage input

if non-blank, the reference string chainage to end the tadpoles at.
if blank, the reference string end chainage is used.

Interval input 10

the chainage interval to use for creating tadpoles.

Maximum offset input 100

the maximum distance to search from the reference string to find strings str1 and str2.

Small tick% input 100

the percentage of the distance between the two strings, str1 and str2, that is taken up by the odd 
numbered tadpoles.

Large tick% input 100

the percentage of the distance between the two strings, str1 and str2, that is taken up by the even 
numbered tadpole.

Model for ticks input available models

the models for the tadpoles to placed into.

Colour for ticks input cyan available colours

the colour for the tadpoles.

Ref/Str1/Str button

the selected string is used as the reference/str1/str2 string.

Ticks
label_tick_marks

Position of option on menu: Strings =>Label => Cut/Fill => Ticks

The ticks option is used to generate ticks (straight lines) between two strings. 
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On selecting the ticks option, the label tick marks panel is displayed.

The fields and buttons in this panel are used in exactly the same way as for the label tadpoles 
marks panels. The only difference is that the defaults for the small tick % and large tick % panel 
fields are 25 and 75 respectively.
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User Symbols
label_symbol_marks

Position of option on menu: Strings =>Label => Cut/Fill => User symbols

The user symbols option uses a given model, the tick symbol model, as the symbol to drawn 
between the low and high points on the two strings.

The tick symbol model is aligned so that the model origin is at the high string point and the 
model’s positive x-axis goes from the high string point to the low string point.

On selecting the ticks option, the label tick marks panel is displayed.

The fields and buttons in this panel are used in exactly the same way as for the label tadpoles 
marks panels except that a tick symbol model panel field is used to specify the symbol to be drawn 
for the cut/fill tick marks.

Field Description Type Defaults Pop-Up

Tick symbol model input available models

the model to be used as the tick mark symbols.
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From File
Position of option on menu: Strings =>Label => Cut/Fill => From file

This is the same option as Drafting =>Create cut/fill symbols

Please go to the section “Label Cut/Fill” of the Chapter “Drafting” .
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Label Names
label_string_names

Position of option on menu: Strings => Label => Names

The label names option is used to label individual strings or all the strings in a model, with their 
string names.

The user has control over the label height, colour, and the distance between the labels.

On selecting the label names option, the label string names panel is displayed.

By using the pick button, individual strings can be labelled using the values in the panel fields. 
The model to label field is ignored.

If the label button is selected, then all the strings in the model given by the model to label field will 
be labelled according to the parameters in the panel fields.

The fields and buttons used in the label names panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type

data source type.

Data source

data source for strings to label.

Textstyle data input

textstyle information.

Interval (w) input 250

chainage interval in world units between the labels.

Label button

label all the strings in the model given in the model to label field.

Please continue to the next section “Label Vertices” .
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Label Vertices
label_vertices

Position of option on menu: Strings =>Label => Vertices

The label vertices option can be used to label the x, y, z, z no nulls, point numbers, id-pt no, name 
and descriptions of strings selected by the data source.

The user has control over the label height, colour, the number of decimal places, the distance 
between the labels, the distance the label is from the point position, and the angle to draw the 
label at.

On selecting the label vertices option, the label vertices panel is displayed.

Individual strings can be labelled by using the pick button and then selecting the strings, to be 
labelled using the values in the panel fields. The string model field is ignored.

If the label button is selected, then all the strings in the model given by the string model field will 
be labelled according to the parameters in the panel fields.

The fields and buttons used in the label strings panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type

data source type.

Data source

data source for strings to label.

Label mode input z x,y,z, point number, 
Vertex no
x and y
id-vertex no
z no nulls
name

type of labelling required - x, y, z, point number, vertex no. for each point in the string.

String model input available models

name of the model containing the strings to be labelled. Not used with the pick button.
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Model for labels input available models

name of the model to place the labels in.

Num dec places input 0  0,1,2,3,4,5

number of decimal places used in the x,y,z labels.

Textstyle data input

textstyle information.

Create mode input 4d 4d, text

if 4d, the vertex labels for the one string are placed in a 4d string.
    text, the vertex labels are created as individual text strings.

Chord/arc tolerance input default chord/arc tolerance

the chord to arc tolerance to use on any alignment string being labelled for determining how many 
points are labelled around horizontal curves.

Label button

label all the strings in the model given in the string model field.
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Rasters
rasters

Position of menu: Strings =>Rasters

The Rasters menu contains options for working with rasters.

The Rasters walk-right menu is

For Create go to “Create a Raster” 
Create from ECW’s “Create Rasters from ECW Files” 
Create from TABs’ “Create Rasters from TAB Files” 
Edit “Edit a Raster” 
Plan to raster “Create Raster from Plan View” in the chapter “View Menus” 
Set boundary “Set a Boundary for a Raster” 
Reset boundary “Reset the Boundary for a Raster” 

Create a Raster
create_raster_element

Position of option on menu: Strings =>Rasters =>Create

A raster element consists of a raster image and positioning information for the raster so that it 
can be mapped into world units.

A raster element is added to a model just like any other string but for convenience it is suggested 
that no other strings are in the same model as a raster.

To help speed up drawing on a view, there is toggle for displaying/not displaying rasters on 
plan views.

Raster Restrictions
(a) The Raster file must have read/write permission

(b) Rasters are only supported on Win 2000 and above.

Selecting Create brings up the Create Raster Element panel.

create a raster
create a raster from an ECW file
create a raster from an TAB file
edit a raster
convert plan view to a raster
set a boundary for a raster
remove the boundary from a raster
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The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Source Image tab

Image format choice box BMP, DIB, GIF
ECW, JPEG, JPEG 2000
PNG, TGA, TIFF

format that the original image is in. Non ECW rasters must be 24 bit colour.

Raster file file box

name of the original raster image. The file must have read/write access and be 24 bit colour.

Page

page number of the raster when the format can contain more than one image (e.g. in a TIFF)

Null colour colour box available colours

colour when there is no pixel in the raster

Temporary folder file box c:\temp select folder

folder to use as a temporary storage area whilst converting the raster to the 12d raster format. The 
temporary folder needs to have enough free disk space to convert the largest of the rasters to bmp 
format.

Width/Height in pixels output only

the width/height in pixels of the selected raster

Depth in bits output only

display the colour depth of the source data

Projection output only

display the projection of the source data if available

Location tab
The location tab supplies the information for positioning the raster in world units in 12d Model. Most 
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rasters formats, other than ECW or Geotiff, do not include this information so it must be supplied by 
other means, either in a file or by typing in a world origin, anticlockwise rotation angle and world 
width and height.

Data format choice box Raw details Raw Details, Autocad scr file
ESRI world, Geo Tiff,
Mapinfo tab

if Raw details, the location details are typed into the World Location Details section as rotation, world 
origin, world width and height.

If Autocad scr file, the location details are taken from the scr file given in Location file. An Autocad scr 
file gives the world co-ordinates of the corners of the raster starting in the bottom left hand corner, 
bottom right hand corner, top left hand corner and top right hand corner. An example of a scr file is:

line
22109.639,148090.695
23109.639,148090.695
22109.639,149090.695
23109.639,149090.695

If ESRI world, the location details are taken from the ESCRI world file given in Location file. An ESRI 
world file gives the xscale, row rotation, column rotation, yscale, x origin and y origin. For use with 
12d, the row and column rotations must be the same and yscale = - xscale.

If Geo Tiff, the Location details are taken from the geotiff file given in Location file panel field. 

If Mapinfo Tab, the location details are taken from the Mapinfo tab file given in Location file. 

Location file file box

file with the location details

Anticlockwise rotation angle box

the world rotation of the raster.

X/Y co-ordinate real box

the world x/y co-ordinate of the left hand bottom corner of the raster.

World width/height real box

the width/height in world units of the raster.

Output tab
the parameters for the created 12d raster.

Output size output

an estimate of the amount of disk space the raster will use in 12d Model

Fastest drawing speed input

only if raster is less than 24 bit depth - if selected, the raster is converted to a 24 bit image.

Minimum disk space input

only if raster is less than 24 bit depth - if selected, the raster is not converted to a 24 bit image and 
hence will take up less disk space. However it is converted at drawing time and so will be slower to 
display than a 24 bit image.

Name for raster input

the name for the raster

Model for raster input available models

name of the model for the raster element
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Show border tick tick

if tick then the border of the raster element is displayed

Colour for border input default colour available colours

the colour of the border for the raster

Tin tin box available tins

if non blank, this tin is tagged with this raster so the raster is used for draping on the tin when the tin is 
used in visualisations

Create button

after the Create button is chosen, the raster element is created.
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Create Rasters from ECW Files
create_rasters_from_ecw_files

Position of option on menu: Strings =>Rasters =>Create from ECW’s

This option attaches one or more ECW files to a model.

Selecting Create from ECW’s brings up the Create Rasters from ECW Files panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Model for ecw’s input available models

name of the model for the ECW files

Pre*post text input

if non blank, pre*post text to use for the name of the raster from the ECW file (see “Pre*Postfix Panel 
Fields”  for information on using pre*postfix)

File to read file box *.ecw files

name of the ECW file to attach to the model

Advanced tick box

if tick, a grid to allow multiple ECW files to be read in, is opened. A wild card is used to select all the 
files to be read in.

Folder folder box

folder to search for files using the Wild card

Wildcard input

wild card to use in search for files in the given folder

Use tick box

if tick, read in the file

Files output

name of the file in the folder
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Size output

 file size

Create button

after the Read button is chosen, the raster elements are created.

Create Rasters from TAB Files
create_rasters_from_tab_files

Position of option on menu: Strings =>Rasters =>Create from TAB’s

This option reads one or more rasters as define by TAB files and places them in a model.

Selecting Create from TAB’s brings up the Create Rasters from TAB Files panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

File to read file box *.ecw files

name of the TAB files to read to define rasters to read into the model

Advanced tick box

if tick, a grid to allow multiple TAB files to be read in, is opened. A wild card is used to select all the 
files to be read in.

Folder folder box

folder to search for files using the Wild card

Wildcard input

wild card to use in search for files in the given folder



12d Model Reference Manual

Page 1140 May 2007Rasters

Use tick box

if tick, read in the file

Files output

name of the file in the folder

Size output

 file size

Model for tabs’s input available models

name of the model for the rasters defined by the TAB files

Pre*post text input

if non blank, pre*post text to use for the raster for the TAB files (see “Pre*Postfix Panel Fields”  for 
information on using pre*postfix)

Mask colour colour box available colours

colour when there is no pixel in the raster

Colour for border input default colour available colours

the colour of the border for the raster

Show border tick tick

if tick then the border of the raster element is displayed

Temporary folder file box c:\temp select folder

folder to use as a temporary storage area whilst converting the raster to the 12d raster format. The 
temporary folder needs to have enough free disk space to convert the largest of the rasters to bmp 
format.

Create button

after the Read button is chosen, the raster elements are created.
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Edit a Raster
edit_raster_element

Position of option on menu: Strings =>Rasters =>Edit

The Edit option modifies the properties of any raster displayed in a 12d Model view.

Selecting Edit brings up the Edit Raster Element panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Source Image tab

Original raster file output

file that the raster originally came from

Null colour colour box available colours

colour when there is no pixel in the raster

Width/Height in pixels output only

the width/height in pixels of the selected raster

Depth in bits output only

display the colour depth of the raster

Projection output only

display the original projection of the raster (if available)

Location tab
When the raster is selected, the raw details for the raster (or ECW details) are displayed. The location 
details can then be modified and hence how the raster is positioned in world units in 12d Model is 
modified.
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Data format choice box Raw details Raw Details, Autocad scr file
ESRI world, Geo Tiff,
Mapinfo tab

if Raw details, the location details are typed into the World Location Details section as rotation, world 
origin, world width and height.

If Autocad scr file, the location details are taken from the scr file given in Location file. An Autocad scr 
file gives the world co-ordinates of the corners of the raster starting in the bottom left hand corner, 
bottom right hand corner, top left hand corner and top right hand corner. An example of a scr file is:

line
22109.639,148090.695
23109.639,148090.695
22109.639,149090.695
23109.639,149090.695

If ESRI world, the location details are taken from the ESCRI world file given in Location file. An ESRI 
world file gives the xscale, row rotation, column rotation, yscale, x origin and y origin. For use with 
12d, the row and column rotations must be the same and yscale = - xscale.

If Geo Tiff, the Location details are taken from the geotiff file given in Location file panel field. 

If Mapinfo Tab, the location details are taken the Mapinfo tab file given in Location file. 

Location file file box

file with the location details

Anticlockwise rotation angle box

the world rotation of the raster

X/Y co-ordinate real box

the world x/y co-ordinate of the bottom left hand corner of the raster

World width/height real box

the width/height in world units of the raster

Appearance tab

Name for raster input

the name of the raster element

Model for raster input available models

model for the raster element.

Show border tick tick

if tick then the border of the raster element is displayed

Colour for border input default colour available colours

the colour of the border for the raster element

Buttons at Bottom

Pick button

select the raster element to edit by clicking on the border of the raster. The details for the selected 
raster are then displayed in the panel.

Set button

give the raster element the new values from the panels fields
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NOTE: A raster is deleted by using the string Delete option. The raster is selected for deleting by 
picking on the border of the raster.
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Set a Boundary for a Raster
raster_set_boundary_string

Position of option on menu: Strings =>Rasters =>Set boundary

The Set boundary option defines a boundary polygon for the raster. Only the parts of the raster 
inside the boundary polygon are displayed. The boundary polygon can have holes.

Selecting Set boundary brings up the Raster Set Boundary String panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Raster raster select box

select the raster to have a drawing polygon set for it

Boundary string select box

select a polygon

Add button

add the selected polygon as a boundary polygon for the selected raster

Reset the Boundary for a Raster
raster_reset_boundary_string

Position of option on menu: Strings =>Rasters =>Reset boundary

The Reset boundary option removes the boundary polygon from a raster.

Selecting Remove boundary brings up the Raster Reset Boundary String panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Raster raster select box

select the raster to have its drawing polygon removed

Model for boundary model box available models

model to place the removed boundary polygon in
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Remove button

remove the boundary polygon from the selected raster
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Utilities
string_utilities

Position of menu: Strings =>Utilities

The utilities menu contains miscellaneous options involving strings.

The Utilities walk-right menu is

For Chainage go to “Chainage” .
Depth string “Depth String” 
Loop removal “Loop Removal” 
Strings from sections “Strings from Sections” 
Sections from points “Sections from Points”  in the chapter “Design” 
Developments “Developments” 

Chainage
chainage_at_point_on_string

Position of option on menu: Strings =>Utilities =>Chainage

The chainage menu option allows the user to specify the start chainage for a string by specifying 
what the chainage will be at a selected point on the string. The string’s start chainage is then 
adjusted so that the point has the given chainage.

Selecting chainage fires up the chainage at point on string panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Old chainage output

reports the initial chainage of the dropped point

New chainage input

the new chainage for the dropped point.

set string chainage at a point
calculate depth string, report offset & xfall
fit lines and arcs
remove loops from strings
create strings from labelled sections
create section from projecting points onto a line
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Pick button

two objects to pick - pick the string to modify the chainage at a point and then pick a point which will 
be dropped onto the selected string to give the point that will have its chainage modified. The existing 
chainage on the string of the dropped point is then written to the old chainage panel field.

Set button

on selecting set, the start chainage is modified so that the chainage at the picked point is the value in 
the new chainage field. The old chainage field is then updated with the new chainage.

Please continue to the next section “Depth String” .

Depth String
depth_string

Position of option on menu: Strings =>Utilities =>Depth string

The depth string option calculates the horizontal and vertical offsets and the cross-fall between 
two strings and then creates and/or reports on the string.

A reference string is selected which is used to define chainages. Lines perpendicular to the 
reference string are taken at regular chainages and intersected (in plan) with the first and second 
strings. The horizontal and vertical offsets and the cross-fall between the two strings are 
calculated at the intersection points.

On selecting the depth string option, the depth string panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Start/End chainage input

if blank, the start/end chainage of the reference string is used.
if non-blank, the given chainage is used as the start/end chainage.

Interval input

chainage interval to calculate values at.

Maximum offset input

if non-blank, the maximum distance to search from the reference string to find the 1st and 2nd strings.

Model for string input available models

if non-blank, a depth string is created and placed in this model.

Colour for string input available colours

the colour for the depth string.
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Report file input *.rpt

if non-blank, the file for the offset and cross-fall report

Ref/1st/2nd button

select the reference/first/second string.

Report button

calculate a depth string and produce an offset and cross-fall report on it.

Please continue to the next section “Loop Removal” .
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Loop Removal
loop_removal

Position of option on menu: Strings =>Utilities =>Loop removal

The loop removal option tries to remove loops from strings by deleting points from the parts of 
the string where loops occur. No new points are introduced.

The user must indicate a good part on the string before any processing can begin.

 Selecting loop removal fires up the loop removal panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model for string input available models

model for the processed string to go to.

Pick string button

pick the string to try and remove loops from.

Pick point button

pick a good point on the string.

Process button

try and remove string points from the loops in the string.

Please continue to the next section “Strings from Sections” .

Strings from Sections
Position of option on menu: Strings =>Utilities =>Strings from sections

The strings from sections option creates strings by joining the common named points on 
successive 4d strings (usually generated as sections). This option is documented under

Design => X-Sections => Strings from Sections

Please go to the section “Strings from Sections” of the Chapter “Design” .
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Developments
string_developments
copy_parallel
kerb_returns_test_
kerb_returns
user_attributes_for_string

Position of menu: Strings =>Utilities =>Developments

Some of the options under string utilities are still under development, or are being phased out 
(Cogo(trial)) and won’t be documented or released until future versions of 12d Model. The 
current options on the Developments menu are

VG detailed design option - test
HG, VG detailed design option - test
kerb return VG - test
kerb return VG - test
user attributes
Cogo superseded by CAD
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cogo
create
divide
fillet
fillet_trim
fillet_trim_join
intersect
locate
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Delete
strings_delete

Position of option on menu: Strings =>Delete

Entire strings can be deleted from 12d Model using the delete option.

Any number of strings can be deleted by successively selecting the strings.

On selecting the delete string option, the strings delete panel is displayed.

Field Description Type Defaults Pop-Up

Pick & Delete button

any selected strings are deleted.

The cycle is terminated by clicking RB to raise the pick ops menu and selecting cancel from it.
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15  Triangles
triangles

Position of menu: Tins

A tin (triangulated irregular network) is an accurate method of representing surfaces, especially 
those described by strings. 12d Model uses tins in most operations involving surfaces. For 
example, contouring, interfacing and volume calculations.

Unlike strings, tins can be in more than one model, or even no model at all. However, to be 
displayed in a view or used for profiling on a section view, tins need to be in at least one model. 
It is suggested that each tin be in its own model called “tin tin_name”. This makes it easy to 
know the model a tin is in, and also to see which models contain tins and obtain lists of all tins.

The triangles walk-right menu is

Each of these options will now be discussed.

For the option Tins, please continue to “Tins” 
Tins info “Tin Info” 
Check breaklines “Check Breaklines” 
Create “Create” 
Edit “Edit” 
Boundary, “Boundary” 
Colour, “Colour” 
Contour  “Contour” 
Drape  “Drape” 
Tin analysis “Tin Analysis” 
Inquire “Inquire” 
Null  “Null” 
Utilities  “Utilities” 

create floating Triangles menu

list of tins
information on project tins
check crossing breaklines
triangulate a model or view, supertin
modify model list etc. for tin
construct tin boundary
colour of tin, colour in polygon
contouring hts, depths, labelling
drape strings onto tin
slope, aspect, viewshed etc.
tin values at cursor position
remove unwanted triangles
various tin options
creating x-sections, mesh, long sec
tin sharing 
User menus
delete tins from disk

on Main menu on 12d Model menu
and floating menu
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“Sections”  “Sections” 
Delete “Delete” 

Tins
tin_list

Position of menu: Tins =>Tins

The tins walk-right menu provides options to list all the tins in the project (project tins) and all 
the tins in the project area but not in the project (removed tins).

The tins walk-right menu is 

list of tins in project
list of removed tins in project area
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Project Tins
Position of option on menu: Tins =>Tins => Project Tins

The project tins walk-right menu provides a list of all the tins in the project and there is a walk-
right on each tin name showing what models the tin is in. If a tin name is selected from the list of 
tins, the tin information panel is fired up with the selected tin name already in the tin field.

Removed Tins
Position of option on menu: Tins =>Tins => Removed Tins

The removed tins walk-right menu provides a list of all the tins in the project area that have been 
removed from the project (using the removed from project option).
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Tin Info
tin_information

Position of option on menu: Tins =>Tin info

Selecting tin info fires up the tin information panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Tin input available tins

input the name of the tin to get information on

xmin, xmax output

ymin, ymax output

zmin, zmax output

returns the tin x, y, z limits

Points output

returns the number of points in the tin

Tris output

returns the number of triangles in the tin

Info button

get the information for the tin given in the tin field.

Calc Extent button

recalculate the x, y, z bounding box for the tin given in the model field.

How to Use the Panel

The information for the tin given in the tin field is retrieved and placed in the appropriate panel 
fields when the tin name is piped into the tin field from the pop-ups, or an <enter> is entered 
after typing the tin name into the tin field, or on selecting the info button.
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Check Breaklines
check_breaklines_for

Position of option on menu: Tins =>Check breaklines

The check breakline option is used to test whether any of the line segments from any line strings 
in a model or view intersect (cross) the line segments from any other string in the model/view. 
This includes self intersections of strings.

The option also checks for any points with the same x and y co- ordinates (same plan position) 
but different z-values, and for totally duplicated strings.

On selecting Check breaklines option and then the appropriate Data Source in the panel, the Check 
Breaklines for panel is displayed.

The fields and buttons in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” .

Data source input

data to be processed.

Model for intersections input available models

if non-blank, check for any crossing line segments and place either a copy of the crossing segments into 
the model given in this field or a diamond depending on the state of "Simple crosses".

Model for duplicates input available models

if non-blank, copies of any strings that are completely duplicated are placed in the model given in this 
field and circles are placed in this model at any duplicate points that aren’t from an entire string.
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Model for identicals input available models

if non-blank, the duplicates of any strings are moved to model given in this field. That is, if any strings 
are identical in all ways, then the second and subsequent identical strings are moved to the Model for 
identicals. This is for the case when a second copy of some data has been supplied.

Colour for intersections input available colours

colour for the copies of the crossing segments.

Report file input

if non-blank, a report file of this name is created giving details of all the crossing breaklines and 
duplicate plan points with different z-values.

Duplicate points tick box tick

if tick, check for points with the same (x,y) position.

Duplicate strings tick box tick

if tick, check for duplicate strings.

Intersections tick box tick

if tick, check for strings that intersect (in plan).

Simple crosses tick box tick

if tick, create diamonds at the position where strings cross, otherwise create a string in the shape of a 
cross with parts of the crossing strings.

Check button

after selecting the check button, all the strings in the model/view are tested for any crossing line 
segments or duplicate points. If requested, a report is generated.

<esc> can be used to abort the checking option.
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Create
tin_create

Position of menu: Tins =>Create

The input data for a triangulation is either all the data in a selected model or all the data from all 
the models on a selected view or a list of models. The options for each method of selecting data 
are on the Create walk-right menu. 

 A SuperTin™ is a list of Tins and a Tin function creates a re-calc function name for an existing 
Tin. Each of these options are also on the Create walk-right menu.

The Create walk-right menu is

For the option Triangulate data, go to the section “Triangulate Data” .
Supertin  “Create SuperTin™” .
 Function  “Function” .

Triangulate Data
triangulate_a_data_source

Position of option on menu: Tins =>Create =>Triangulate data

For simple jobs, the data to triangulate is all in the one model. However, it often occurs that the 
data one needs to triangulate is not in one model but is in the models displayed on a particular 
view. 

The Triangulate data source option allows use to either select the data to triangulate from a single 
model, a list of models or to it uses the data points from all the models attached to a particular 
view, rather than the data from a particular model.

In each case, the models used in creating the triangulation are recorded so that the models can be 
easily retriangulated if any of the data changes.

On selecting the Triangulate data option, the triangulate a Data Source panel is displayed.

triangulate a model or view of data
create a supertin
create a triangulate function
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” .

Data source input

source of data is to be triangulated - only Model or View allowed for this option.

New tin name input

name of the tin created from the triangulation of the model/view.If <enter> is type after the name, the 
model for tin field is filled out with the name tin new_tin_name.

Tin colour input default tin colour available colours

colour to draw the triangles whenever they are displayed in a view.

Tin style input 1 available line styles

line style used for drawing sections through the tin on the section view.

Model for tin input available models

if non-blank, the created tin will be added to the model given in this field.
if blank, the name tin new_tin_name will be placed in the field when the triangulate button is selected.

Preserve strings tick box tick

if tick, all strings with breakline type line or segment type tinable will be preserved as sides of 
triangles. Otherwise, all line strings or segments of type tinable will be treated as point strings for the 
triangulation.

Remove bubbles tick box

if tick, post-processing occurs to try and stop all the points of a triangle coming from the same string. 
This helps prevents triangles with all three points coming from the one contour string and hence 
forming a flat triangle.
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Weed tin tick box

if tick, all duplicate points all removed from the tin database. This helps to reduce the size of the tin 
files if there was a large amount of duplicate data. This flag is automatically set to tick for triangle 
data.

Triangle data tick box

if tick, then it is assumed the original data was triangles and 12d will ensure that the triangles 
produced by the triangulation exactly match (including null regions) the original triangle data. Weed 
tin is automatically set to tick if face data is set to tick.

Cell method tick box

if tick, try to create the triangles in cells - an alternate method of ordering the data which is often faster 
when the data comes in lines rather than randomly.

Data polygon string-select

if a string is selected as a data polygon, only string points that are inside the data polygon are used in 
the triangulation.
If no string is selected, then all the points in all the model/view are used in the triangulation.

Null polygon string-select

if a string is selected as a null polygon, any triangle whose centroid is outside the null polygon is 
automatically nulled.

Triangulate button

Triangulate the model/view given in the model/view to triangulate field. The created tin will be stored 
with the name given in the new tin name field. The tin will be the colour given in the tin colour field. If 
the model/view for tin field is non-blank, the created tin will be added to the model given in that field - if 
the model does not exist, it will be created.

Panel Messages

Progress messages - sent to the panel message area

no of points in model/view = no. of points
no. points pts no. break lines break lines
no. points pts no. of secs s no. pts/s no. dup
break lines finished. time taken = secs

Completion message - sent to the panel message area

average no of pts per sec = no.
<esc> can be used to abort the triangulation option.
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Create SuperTin™
create_super_tin

Position of option on menu: Tins =>Create =>Supertin

The SuperTin™ option is designed to create a super triangulation from other triangulations.

With SuperTins, existing triangulations can be combined to form the equivalent of a merged 
triangulation without having to completely re-build a merged model and retriangulating it.

This means there are less steps in creating a SuperTin merged triangulation so a lot less time is 
required and there is less opportunity for errors. Also, it any of the component triangulations of 
the SuperTin are modified, then the SuperTin is also instantly modified.

The SuperTin is defined by a list of triangulations in increasing priority order. Wherever two 
triangulations overlap, the triangulation of higher priority takes precedence and is used to 
defined z-values and sections.

Hence, for any (x,y) point, the z-value on the SuperTin is defined to be the z-value from the 
triangulation of the highest priority which is under the (x,y) point.

A section through a SuperTin is made up of the sections through the triangulation of highest 
priority at each point along the section.

On selecting the Supertin option, the Create Super Tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

New tin name input

name of the tin created from the triangulation of the model/view.If <enter> is type after the name, the 
model for tin field is filled out with the name tin new_tin_name.

Tin colour input default tin colour available colours

the tin colour is used as the section colour when sectioning through the supertin.When displayed on 
plan or section views, the each tin making up the supertin is drawn in its own colour.

Tin style input 1 available line styles
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line style used for drawing sections through the SuperTin on the section view.

Model for tin input available models

if non-blank, the created SuperTin will be added to the model given in this field.
if blank, the name tin new_tin_name will be placed in the field when the create button is selected.

Tins to include table available tins

name of the tin to be included in the SuperTin.

Create button

create a SuperTin from the tins in the tins to include table. The created SuperTin will be stored with the 
name given in the new tin name field. 

Function
retriangulate_function

Position of option on menu: Tins =>Create =>Function

The function option is used to construct a function which when recalced, will run a retriangulate 
on the tin.

On selecting the function option, the retriangulate function panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input available functions

the name to give to the retriangulate function.

Tin input available tins

name of the tin to be retriangulated when the function is recalced.

Create/Set button

create or modify the retriangulate function.
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Edit
tin_edit

Position of menu: Tins =>Edit

The input data for a triangulation is either all the data in a selected model or all the data from all 
the models on a selected view

The options for both methods of selecting data are on the create walk-right menu. The create walk-right 
menu is

For the option Tin, please go to the section “Edit a Tin” .
Supertin “Edit SuperTin” .
Function “Edit Tin Function” .
Retriangulate “Retriangulate” .
Style “Style” .
Render settings “Render Settings” .
Add breaklines “Add Breaklines” .
Flip triangles “Flip Triangles” .

Edit a Tin
retriangulate_tin

Position of option on menu: Tins =>Edit =>Tin

When a tin is created, the settings and models used in the triangulation are recorded with the tin 
data. The edit=>tin option can be used to modify the models and setting used to define the tin 
and then recreate the tin from the new models and settings.

On selecting the edit=>tin option, the retriangulate tin panel is displayed.

edit a tin definition and retriangulate
edit a SuperTin definitions
modify a retriangulate function
retriangulate an existing tin
set tin style
settings for rendering V6.1
add breakline
swap triangle edges
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input

name of the tin to be retriangulated. When the tin name is given, the list of models used for the tin and 
other settings, are displayed.

Tin colour input original colour available colours

original colour of the tin - this can be modified.

Tin style input original line style available line styles

original line style of the tin - this can be modified.

Preserve strings tick box original setting

if tick, all strings with breakline type line will be preserved as sides of triangles. Otherwise, all line 
strings will be treated as point strings for the triangulation.

Remove bubbles tick box original setting

if tick, post-processing occurs to try and stop all the points of a triangle coming from the same string.

Weed tin tick box original setting

if tick, all duplicate points all removed from the tin database.

Triangle data tick box original setting

if tick, only triangles in the tin that are under the centroid of a string representing a triangle in the 
model/view are considered valid, all others are set to null. That is, any triangles not under the centroid 
of a string from the model/view will be set to null. This is extremely useful when the original string data 
represents triangles and it will ensure that the triangles produced by the triangulation will exactly 
match, including null regions, the original triangle data.Weed tin is automatically set to tick if face 
data is set to tick.

Cell method tick box original setting

if tick, try to create the triangles in cells - an alternate method of ordering the data for use when the 
triangulation takes too long by the non-cell method.
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Data polygon string-select original data polygon

if a string is selected as a data polygon, only string points that are inside the data polygon are used 
in the triangulation.
If no string is selected, then all the points in all the models are used in the triangulation.

Null polygon string-select original null polygon

if a string is selected as a null polygon, any triangle whose centroid is outside the null polygon is 
automatically nulled.

Retriangulate button

The original tin is deleted and the data in the models to include table used to create a new triangulation 
which is given the original tin name. The settings in this panel are used for the retriangulation.
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Edit SuperTin
edit_super_tin

Position of option on menu: Tins =>Edit =>Supertin

When a Supertin is created, the tins and settings used to create the SuperTin are recorded.

The edit=>supertin option can be used to modify the tins and setting used to define the SuperTin. 

On selecting the edit=>supertin option, the edit super tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Super tin name input existing SuperTins

name of the SuperTin to be modified.

Tin colour input            existing super tin colour available colours

original colour for drawing sections through the SuperTin - this can be modified.

Tin style input            existing supertin style available line styles

original linestyle for drawing sections through the SuperTin - this can be modified.

Tins to include table existing tins available tins

original tin in the SuperTin - these can be modified.

Update button

update the SuperTin definition with the information in the above panel fields.
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Edit Tin Function
Position of option on menu: Tins =>Edit =>Function

The edit=>function option is used to edit a tin function.

On selecting the function option, the retriangulate function panel is displayed which is the same as for 
the option tins=>create=>function.

Retriangulate
Position of option on menu: Tins =>Edit =>Retriangulate

When a tin is created, the settings and models used in the triangulation are recorded with the tin 
data. The retriangulate option is used to recreate the tin from the same models and settings.

The retriangulate menu item operates two ways.

(a) The retriangulate walk-right brings up the tins menu which is a list of all the existing tins.

By choosing one of the tins from the tins menu, the tin is retriangulated.

(b) If retriangulate itself is activated (by clicking LB when retriangulate is highlighted), the 
retriangulate tin panel appears. The retriangulate tin panel can be used to modify the tin 
definition and retriangulate the tin.

Style
tin_linestyle

Position of option on menu: Tins =>Edit =>Style

When a tin is created, it is given a linestyle (the tin linestyle) which is used for drawing the tin 
whenever it is profiled on a section view or plotted in long and cross section plots.

The style option is used to modify the tin linestyle.

On selecting the style option, the tin linestyle panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to modify the linestyle of.

Style input 1 available linestyles

linestyle for the tin.

Set button

set the tin linestyle to that given in the style panel field.
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Render Settings
tin_render_settings

Position of option on menu: Tins =>Edit =>Render settings

This Option is currently under development.

On selecting the Render settings option, the Tin Render Settings panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin to apply settings input available tins

name of the tin to apply the render settings to.

Model input available models

if non blank, the model of ortho-rectified rasters to be associated with the tin (and hence draped onto 
the tin in an Perspective OpenGL view).

Raster name input

if non blank, the name of an ortho-rectified raster to be associated with the tin (and hence draped onto 
the tin in an Perspective OpenGL view).

Texture mapping input

if non blank, the name of the set of colour-to-texture mappings that is defined in the file textures.4d and 
are to be used for applying textures to the coloured triangles of the tin.

Blending input

The value of blending is between 0 and 1.
0 means the tin is totally transparent (and hence invisible) and 1 means that the tin is opaque (non-
translucent) and can’t be seen through at all.

If blank, then the value is taken as 1 and the tin is opaque (non-translucent).
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Two sided tins tick box

if tick, the tin is visible when viewed from both above and below. For example, the tin used for the 
bottom of a bridge needs to be two-sided.
If non-tick, then the tin is one sided and only shows when viewed from above.
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Add Breaklines
add_breaklines_panel

Position of option on menu: Tins =>Edit =>Add breaklines

This option allows extra breaklines joining existing vertices in the tin to be created. The new 
breaklines can be added to a model so that the results can be reproduced on a retriangulation.

On selecting the Add breakline option, the Add Breaklines panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to add a breakline to.

Model for breaklines input 1 available models

if non-blank, then as breaklines as created with this option, then the breakline is automatically added to 
this model so that the breakline modifications will try to be preserved on a retriangulation (this may not 
be possible with crossing breaklines).

Breakline button

add a breakline by clicking near the two vertices of the tin that are to be connected by a breakline 
(cursor snap will do). As each breakline is added, the triangles are rearranged. If fast contours are 
turned on, the effect will be immediate. Note that you can have fast contours and tin edges toggled on 
at the same time.

Flip Triangles
flip_triangles_panel

Position of option on menu: Tins =>Edit =>Flip triangles

This option works on a triangle side and if it is possible, it finds the two triangles with this 
common side, removes the command side and replaces it with a new common side which joins 
the non common triangle points in the original triangle. Note that this can’t be done when the 
new side goes outside the two triangles.

A new breaklines can also be automatically added to a model so that the results can be 
reproduced on a retriangulation.

On selecting the Flip triangles option, the Flip Triangles panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to add a breakline to.

Model for breaklines input 1 available models

if non-blank, then as triangles are selected and flipped, then breaklines are is automatically added to 
this model so that the flip modifications will try to be preserved on a retriangulation (this may not be 
possible with crossing breaklines).

Flip button

flip a triangle by clicking near the common edge (cursor snap will do). As each flip is done, the 
triangles are rearranged. If fast contours are turned on, the effect will be immediate. Note that you can 
have fast contours and tin edges toggled on at the same time.
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Boundary
create_boundaries_for_tin

Position of option on menu: Tins =>Boundary

The boundary option is used to construct the boundary strings for a tin, i.e. the strings going 
around the edges between the null and non-null triangles in the tin.

If the tin has holes (internal null regions), then there will be more than one boundary string 
created.

Often the boundary strings is used as a first step in creating a polygon to be used to null out 
further triangles not required in the tin.

On selecting the Boundary option, the Create Boundaries for Tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to calculate the boundary strings for.

Model for boundaries input available models

the model to place the boundary strings in.

Create super string(s) tick box

if tick, the boundary string is a super string.
If not tick, the boundary string is a 3d string.

Boundaries draped tick box

if tick, the points of the boundary have the z-values from the tin.
If not tick, the z-value is set to 1.

Boundary colour input cyan available colours

the colour for the boundary strings

Create button

create the boundary polygons for the tin.
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Colour
tin_colouring

Position of menu: Tins =>Colour

When a tin is created, all the triangles have the same colour (called the tin’s base colour). This is 
the colour given by the user when creating the tin with the triangulate model or triangulate view 
panel. The base colour can be changed at any time using the colour of tin option.

However, it often necessary to colour specific triangles in some other colour than the base colour. 
The option colour within polygon is designed to do just that.

The colour menu item operates in two ways.

First, if colour itself is activated (by clicking LB when colour is highlighted), the colour of tin 
panel appears (see the next section).

Secondly, the colour walk-right brings up the tin colouring menu.

The tin colouring walk-right menu is 

For the option Colour of tin, please go to the section “Colour of Tin” .
Colour within polygon “Colour Within Polygon” 
Reset “Reset” 
Retriangulate “Retriangulate” 
Tin height colour “Tin Height Colour” 
Tins depths colour “Tins Depths Colour” .
Aspect colouring “Aspect Colouring” .
Slope colouring, “Slope Colouring” .

Colour of Tin
tin_colour

Position of option on menu: Tins =>Colour =>Colour of tin

A tin is given a base colour when it is originally constructed. The colour of tin option allows the 
user to change the base colour of the tin.

On selecting the colour of tin option, the tin colour panel is displayed.

change base colour of tin
colour triangles within a polygon
reset all triangles to base colour
colour height ranges
colour depth ranges between two tins
colour aspect ranges
colour slope ranges
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults     Pop-Up

Tin input     available tins

name of the tin to have its base colour modified. The tin must exist in 12d Model. When the tin name is 
entered, the existing colour of the tin is displayed in the tin colour panel field.

Colour input default tin colour     available colours

the new base colour for the tin given.

Colour button

colour all the base triangles with the colour given in the colour field.
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Colour Within Polygon
colour_triangles_by_polygons

Position of option on menu: Tins =>Colour =>colour within polygon

Although a tin is given a base colour when constructed, it is useful to be able to change the 
colour of selected triangles. For example, in a design tin with a road and terrain, the road and the 
terrain could be displayed in different colours. This is particularly effective in shades.

The colour within polygon option allows the user to colour all the triangles whose centroids lie 
inside (or outside) a selected polygon, or for all the polygons in a given model, with either a user 
specified colour or the colour of each polygon. If a model of polygons is used, the polygons are 
processed in the order that they occur in the model. The option can be applied any number of 
times to a tin.

On selecting the colour within polygon option, the colour triangles by polygons panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to have some of its triangles coloured. The tin must exist in 12d Model.

Use experimental fast colouring tick box

if tick, an experimental fast colouring algorithm is used.

Use polygons colour tick box

if tick, the colour of the polygons is used as the colour for the triangles.

New colour input default tin colour available colours

if use polygons colour is not set to tick, this is the colour to set all the triangles within/out a polygon to.
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Poly mode choice inside inside, outside

mode to select whether the triangles with centroids inside or outside the selected polygons are to be 
coloured.

Use a polygon tick box

if tick, then individual polygons are selected and the tin coloured within them.

Colour on accept of polygon tick box

if tick, then the colouring is done as soon as a polygon is accepted.

Polygon polygon selected button string pop-up

this is used to
(a) select an individual string to use as a polygon for colouring
(b) dynamically define a rectangle to use as a polygon for colouring
(c) dynamically define a trapezoid to use as a polygon for colouring
(d) dynamically define a lasso to use as a polygon for colouring

Use a model of polygons tick box

if tick, then all the polygons in the given model are used for colouring.

Model input available models

model of polygons which are used for selecting triangles to be coloured. Colour happens when the 
Colour button is selected.

Colour button

each string in the model of polygons is used to colour the triangles in the tin given in the tin field.

Reset
reset_colour_of_triangles

Position of option on menu: Tins =>Colour =>Reset

The reset option is used to change all the non base-coloured triangles in a tin back to the base 
colour.

On selecting the reset option, the reset colour of triangles panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to have any non base-coloured triangles reset to the base colour. The tin must exist in 
12d Model.

Reset button

change any selectively coloured triangles back to the base colour.
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Tin Height Colour
colour_height_range_for_tin

Position of option on menu: Tins =>Colour =>Tin height colour

The tin height colour option is used to calculate height bands for the tin and colour a view and/or 
create faces. The calculations can be restricted to within a user selected polygon, or if no polygon 
is selected, the entire tin is used.

The calculated heights and colours are given in a user supplied range file. A plan view can be 
temporarily coloured on the height basis using the range file. The temporary colours will 
disappear next time the view is refreshed.

For permanency, the option can also create coloured faces with the appropriate range colour. The 
faces can be displayed on any plan view using a solid fill colour or a hatch pattern.

For tin height colour, the range file consists of a list of ranges and colours, one set per line, in the 
format

lower_height       upper_height       range_colour
where this line represents all heights satisfying

lower_height <   height   <= upper_height.

On selecting the tin height colour option, the colour height range for tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the height ranges of the triangles will be calculated and a view coloured.

Range file input *.hrf

the user supplied range file is used to give the colour ranges for heights of the tin.

Plan view to paint input available views

if non-blank, the given plan view will be painted according to the range colours given in the range file.

Model for faces input available models

if non-blank, faces will be created with colours according to the range colours given in the range file.

Clean faces model beforehand tick box
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if tick, the model of faces is cleaned out before the option runs.

Select polygon string-select

if selected, this string is used as the bounding polygon for the height calculations.

Colour button

On selecting this button, the heights of the triangles of the tin within the selected bounding polygon are 
calculated.

 <esc> can be used to terminate the option during height calculations.
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Tins Depths Colour
colour_depth_range_for_tins

Position of option on menu: Tins =>Colour =>Tin depths colour

The tins depths colour option is used to calculate colour bands for the depths between two tins 
and colour a view and/or create faces. The calculations can be restricted to within a user selected 
polygon, or if no polygon is selected, the common portions of the tins are used.

The calculated depths and colours are given in a user supplied range file. A plan view can be 
temporarily coloured on the depth basis using the range file. The temporary colours will 
disappear next time the view is refreshed.

For permanency, the option can also create coloured faces with the appropriate range colour. The 
faces can be displayed on any plan view using a solid fill colour or a hatch pattern.

For tins depths colour, the range file consists of a list of ranges and colours, one set per line, in the 
format

lower_depth       upper_depth       range_colour
where this line represents all depths satisfying

lower_depth <   depth   <= upper_depth.

On selecting the tins depths colour option, the colour depth range for tins panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original/New tin input available tins

name of the original/new tin to colour depths between. Cut is when the new tin is below the original tin.

Range file input *.hrf

the user supplied range file is used to give the colour ranges for depths.

Plan view to paint input available views

if non-blank, the given plan view will be painted according to the range colours given in the range file.

Model for faces input available models

if non-blank, faces will be created with colours according to the range colours given in the range file.

Clean faces model beforehand tick box
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if tick, the model of faces is cleaned out before the option runs.

Select polygon string-select

if selected, this string is used as the bounding polygon for the height calculations.

Colour button

colour the depths between the tins within the selected bounding polygon.

 <esc> can be used to terminate the option during depth calculations.

Aspect Colouring
aspect_analysis_colour

Position of option on menu: Tins =>Colour =>Aspect colouring

The aspect colouring option is used to colour the triangles according to the aspect (direction) of 
the triangles in the tin. An aspect range file is used to define the colour ranges.

Note that the actual colours of the triangles are changed - not a face model produced.

For aspect colouring, the range file consists of a list of aspect ranges and colours, one set per line, 
in the format as for aspect analysis:

lower_bearing       upper_bearing       range_colour

where this line represents all bearings satisfying

lower_bearing <   bearing   <= upper_bearing.

For each range in the file, the boundary strings for areas of common range can be created and 
also coloured faces that can be displayed on any plan view.

On selecting the aspect colouring option, the Aspect Analysis Colour panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the aspects of the triangles will be calculated and then the tin coloured.

Range file input *.arf

the user supplied range file is used to give the colour ranges for aspects to use to colour the triangles.

Aspect button

On selecting this button, the aspects of the triangles of the tin are calculated and the triangle coloured 
according to the range file.



12d Model Reference Manual

Page 1184 March 2007Colour

<esc> can be used to terminate the option during aspect calculations.

Slope Colouring
slope_analysis_colour

Position of option on menu: Tins =>Colour =>Slope colouring

The slope colouring option is used to colour the triangles in the tin according to the slope of the 
triangles. A slope range file is used to define the colour ranges.

Note that the actual colours of the triangles are changed - not a face model produced.

For slope colouring, the range file consists of a list of ranges and colours, one set per line, in the 
format

lower_value       upper_value       range_colour
where this line represents all angle satisfying

lower_value <   value   <= upper_value.

The values can be percent cross fall, “1v in” slope or degrees (in 12d Model dms format).

The range_colour is used to colour all triangles in the tin satisfying the range.

On selecting the slope colouring option, the Slope Analysis Colour panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the slope of the triangles will be calculated and then the tin coloured.

Range file input *.arf

the user supplied range file is used to give the colour ranges for slopes to use to colour the triangles.

Slope type input percent cross fall percent cross fall,
degrees, 1v in

the units used for slope in the range file.

Slope button

On selecting this button, the slopes of the triangles of the tin are calculated and coloured according to 
the slope range file.

<esc> can be used to terminate the option during aspect calculations.



Chapter 15  Triangles

March 2007 Page 1185Contour

Contour
tin_contours
Position of menu: Tins =>Contour

The tin contours walk-right menu is 

For the option Contour, smooth and label, go to the section “Contour, Smooth and Label” 
Change  “Change Contours” 
Colour  “Colour” 
Contour “Contour” 
Depth contours  “Depth Contours” 
Label “Label Contours” 
Smooth “Smooth” 

For information on creating contours, go to the section “Creating, Smoothing and Labelling 
Contours” .

Creating, Smoothing and Labelling Contours

Creating Contours
Contours (or level lines) for a surface are the strings of constant height. Contours are often 
produced on maps and labelled with the height of the contours.

A 12d Model tin represents a surface in three dimensions and there is an option in 12d Model for 
producing the contours for the tin.

For a triangle in three dimensions, a string of constant height is actually a straight line across the 
triangle and the contour lines of different heights for a triangle are parallel lines.

create smooth and label contours
change colour/model
colour contours using a height range file
create contours
create depth contours
label contours
smooth contours

0

0

10

Contours (lines of equal height)
on the triangle with heights
0, 0 and 10 at the triangle
vertices.

The contours for a the triangle
are parallel lines.
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Because triangles in a tin have common sides, a contour of a given height for one triangle will 
connect to the contour of the same height in an adjacent triangle.

So the contour lines on adjacent triangles join up to form continuous contour strings, each 
segment of which is straight across a triangle.

The contours for a tin lie on the surface of the tin.

The options to create contours in 12d Model has five parameters to define which contours are 
calculated. They are the 

minimum contour value
maximum contour value
contour increment
contour reference
bold increment

The elevation range over which the contours are to be produced is defined by the minimum and 
maximum contour values. If the minimum (maximum) value is not specified, the tin minimum 
(maximum) z-value is used.

The increment between successive contours is given by the contour increment.

For example, if contours are required every two metres from 100.0 metres to 200.0 metres, the 
parameters needed are

contour minimum   = 100.0
contour maximum   = 200.0
contour increment = 2.0

This would be sufficient information to produce the contours

100.0, 102.0, 104.0... 198.0, 200.0.

However, 12d Model also provides a parameter to allow the following contours to be produced

101.0, 103.0, 105.0 .... 197.0, 199.0

For this and similar cases, the contour reference value is used.

When a contour reference value is specified, all the contour increments are taken from the 
contour reference value.

In the first example, the contour reference value is the default value of 0.0. In the second 
example, the contour reference value is 1.0.

If major (or bold or index) contours are required, the major contour increment is given a non- 
zero value. Major contours will be drawn at the integer multiples of the major increment instead 
of the standard contours.

For information on labelling contours, go to the section “Labelling Contours” .

For information on smoothing contours, go to the section “Smoothing Contours” .

Smoothing Contours

Contour lines on adjacent triangles in a tin join up to
form a continuous contour string.
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If the triangles in a tin, or sections of a tin, are large then the contours for that section of the tin 
may appear angular. Consequently some people like to "smooth" the contours to take out the 
angularity.

Be careful of smoothing because "smoothng" of contours produces strings that no longer sit on 
the triangulation. 

 12d Model smooths contours by apply a smoothing algorithm to each of the contour strings that 
were produced from the triangulation.

Two smoothing algorithms are available

(a) Preserve string points - this method ensures that the smoothed contour goes through all the 
vertices from the original contour string.

(b) Don’t preserve string points - this method does not have to include the vertices from the 
original contours in the smoothed contour.

For information on creating contours, go to the section “Creating Contours” .

For information on labelling contours, go to the section “Labelling Contours” .

Labelling Contours

 12d Model labels contours by placing text labels at user controlled distances along the contour 
string.

The position and frequency of the contour labels along a contour string is controlled by two 
parameters, the start distance and the separation distance.

The first contour label is placed at a chainage distance of start distance from the beginning on 
the contour and the labels are repeated at a chainage distance of separation distance from the 
previous contour label.

There is also a parameter to specify that contours are to be labelled at the start and the end 
regardless of the start distance and separation distance.

The number of decimal places used for the contour label is also user specified.

12d Model has seven methods for positioning the contour labels. They are the 

(a) above line contour direction

contour labels are created with the text parallel to the contours line and in the same direction as the 
contour string. The text is raised slightly above the contour string.

(b) above line read from below

50

50

contour
direction

(a) above line
contour direction
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contour labels are created with the text parallel to the contour line and in the same direction as the 
contour string but at an angle between -90 and +90 degrees. The text is raised slightly above the 
contour string.

(c) centre line read from below

contour labels are created with the text parallel to the contour line and in the same direction as the 
contour string but at an angle between -90 and +90 degrees. The text is centred on the contour string 
so the contour string goes through the text.

(d) line removal & centred line read from below

contour labels are created with the text parallel to the contour line and in the same direction as the 
contour string but at an angle between -90 and +90 degrees. The text is centred on the contour string 
so the contour string goes through the text. Also the contours are cut so that gaps are left for the labels. 

(e) above line facing up hill

(b) above line
read from below

50

50

(c) centred line
read from below

50

50

(d) line removal and
centre line read
from below

50

50
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contour labels are created with the text parallel to the contours line in the same direction as the 
contour string. The text is orientated so that if faces uphill. The text is raised slightly above the contour 
string.

(f) centre line facing up hill

contour labels are created with the text parallel to the contours line in the same direction as the 
contour string. The text is orientated so that if faces uphill. The text is centred on the contour string so 
the contour string goes through the text.

(g) line removal & centred line facing up hill

contour labels are created with the text parallel to the contour line. The text is orientated so that if 
faces uphill. The text is centred on the contour string so the contour string goes through the text. Also 
the contours are cut so that gaps are left for the labels.

For information on creating contours, go to the section “Creating Contours” .

For information on smoothing contours, go to the section “Smoothing Contours” .

(e) above line
facing up hill 50

60

50

60

(f) above line
facing up hill

50
60

50

60
(g) line removal and
centred line with labels
facing up hill

50
60

50
60
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Contour
contour_a_tin
Position of option on menu: Tins =>Contour =>Contours

One method of visualizing tin data is with contours. In 12d Model, contour strings can be 
produced over any user defined elevation range and at any interval.

For more information on contouring in 12d Model, go to the section “Creating Contours” 

The contour option can be applied to a tin any number of times. This may be necessary if the 
contour parameters vary over the total range to be contoured.

On selecting the contour option, the contour a tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin to contour input available tins

name of the tin to be contoured.

Contours tab

Model for conts input available models

name of the model to place the contours in.

Cont inc input 1.0

increment between contoured values.

Name input

if non-blank, name to give the contour strings.

Colour input cyan available colours

colour of the contours

Linestyle input 1 available linestyles

linestyles for the contour strings.

Weight input

if non-blank, weight to give the contour strings.
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Bold Contours tab

Model for bolds input available models

name of the model to place the bold contours in. If blank, the same model is used as for the ordinary 
contours.

Bold inc input 5.0

increment for the bold contours.
If blank or zero, then no bold contours are drawn. If non-zero, it must be an integer multiple of the 
contour increment

Bold colour input magenta available colours

colour of the bold contours

Name input

if non-blank, name to give the bold contour strings.

Colour input cyan available colours

colour of the bold contours

Linestyle input 1 available linestyles

linestyles for the bold contour strings.

Weight input

if non-blank, weight to give the bold contour strings.

Range tab

Cont min input

minimum value of the z range to be contoured. If blank, the tin’s minimum z-value is used.

Cont max input

maximum value of the z range to be contoured. If blank, the tin’s maximum z-value is used.

Cont ref input 0.0

reference value for the contour increments.

Contour button

contour the tin given in the tin field and place the contours in the model given in the model field. The 
contour range, contour increment and bold contour increment are used specify which contours are 
calculated.

Panel Messages

Progress messages - sent to the panel message area

start contouring
contouring level z-value

Completion message - sent to the panel message area

finished contouring - no. contours

<esc> can be used to abort the calculation of contours.

Depth Contours
depth_contours

Position of option on menu: Tins =>Contour =>Depth contours
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The depth contours option finds the contours lines for the difference between two tins. That is, it 
calculates the isopachs between the two tins.

On selecting the depth contours option, the Depth Contours panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original/New tin input available tins

name of the original/new tin to contour between. Cut is when the new tin is below the original tin.

Model for depth strings input available models

name of the model to contain the depth strings.

Cut/Zero/Fill strings section More tick box
if no tick then only the Colour panel field is displayed

Colour input cyan available colours

if non-blank, colour for the strings

if tick then Name, Colour, Linestyle and Weight fields are displayed
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Name input

if non-blank, name to give the strings.

Colour input cyan available colours

if non-blank, colour for the strings

Linestyle input 1 available linestyles

linestyles for the strings.

Weight input

if non-blank, weight to give the strings.

Start level input -10

the minimum depth to start the depth contours at.

End level input  10

the maximum depth to calculate the depth contours to.

Interval input  1

the interval between the depth contours.

2d/3d strings input  2d 2d, 3d original, 3d new

If 2d, the created strings are 2d strings with a z-value equal to the depth.
If 3d original/new, the depth strings are draped over the original/new tin to form 3d strings.

Calculate button

calculate the depth contours between two tins given in the panel fields. The resulting strings are added 
to the model given in the model for depth strings field.
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Label Contours
label_contours

Position of option on menu: Tins =>Contour =>Label

The label contours option can be used to label individual contour (2d) strings, or all the contour 
strings in a model.

The user has control over the label size, colour, number of decimal places, the distance between 
the labels and the distance to the first label on a string (start distance).

Note - this option cannot label fast contours. Contours strings must already exist or be generated 
using Tins => Contour=> Contour.

For more information on labelling contours, go to the section “Labelling Contours” .

On selecting the label contours option, the label contours panel is displayed.

When the label button is selected, then all the contour strings given by the data source field will 
be labelled according to the parameters in the panel fields.

The fields and buttons used in the label contours panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” .

Data source input

source of data is to be triangulated - only Model or View allowed for this option.

Model for labels input available models

name of the model to place the contour labels in.

Label method input above line contour direction
above line read from below
centred line read from below
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line removal and centred line read from below
above line facing uphill
centred line facing uphill

line removal & centred facing uphill

in all cases, contour labels are created and added to the model ’Model for contours’.

For information on each of the methods of labelling contours, go to the section “Labelling Contours” .

Original tin input  available tins

only needed for the "facing uphill" methods - name of the tin used to generate the contours. This is 
needed to calculate which direction is uphill.

Num dec places input 1  0,1,2,3,4,5

number of decimal places used in the contour label.

Textstyle data input 1 textstyle favourites

textstyle information to use for the contour labels.

Start dist (w) input 0

chainage distance to the first label on the string - world units

Separation (w) input 250

chainage interval between the labels - world units

Pick button

if a number of individual contour strings need to be labelled, the pick button is used. After pick is 
chosen, any strings selected are then labelled using the information in the panel fields. After labelling 
one string, another pick and label cycle automatically begins.

The cycle is terminated by clicking RB to raise the pick ops menu and selecting cancel from it.

Label button

label all the contour strings selected by the "Data to label" data source.
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Smooth
smooth_contours_in

Position of option on menu: Tins =>Contour =>Smooth

The smooth options are used to add extra points into a contour string (2d strings) to make a 
smoother string. 

For more information on labelling contours, go to the section “Smoothing Contours” .

On selecting Smooth, the Smooth Contours in panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” .

Data source type Model

data selection type

Data source input

data source to be smoothed.

Model for smoothed strings   input available models

model for the smoothed strings to go to

Preserve string points tick box

if tick, the smoothed contour will still contain all the original points.
if not tick, the smoothed contour may deviate from the original string points

Pass other strings tick box tick

if tick, any non-contour string is copied and added to the smoothed strings model.

Smooth button

smooth the selected contour (2d) strings.

Change Contours
change_Contours

Position of option on menu: Tins =>Contour =>Change
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The Change option is for changing the model and/or colour of contours with a given height 
interval.

The main purpose of the option is to separate contours to be used as index contours from other 
contours. For example, when contours are supplied by a third party and all the contours are in 
the same model with the same colour, change contour colour can move contours to be used as 
index contours to a different model and give them a different colour.

For this option the selection process for a Data source is extended.

After the data is selected as defined by the Data source, the two extra parameters, interval and 
reference, are used to further specify which contours are to be moved and/or coloured.

Only contour strings whose heights satisfy

height = reference + integer * interval

are selected.

For example, if the contours 5, 10, 15 etc. are required, the reference and interval would be

reference = 0
interval = 5

However, to modify the contours 6, 11, 16 etc., the required parameters are

reference = 1
interval = 5

On selecting the Change option, the Change Contours panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 
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Data source input

source of data is to be processed.

Reference input    0

the reference value to use to select contours.

Interval input  10

the interval to use to select contours.

New colour input available colours

if non-blank, then the colour of the selected strings will be changed to the colour given in the new 
colour field.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Colour button

process the selected strings
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Colour
colour_contours

Position of option on menu: Tins =>Contour =>Colour

The colour option is used to colour contours in a model according to a selected height range file.

On selecting Colour, the Colour Contours panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Contour model    input available models

model of contours to colour

Height range file    input .hrf files

height range file to specify the colour of the contour.

Interpolate colours tick box

if tick, the colour of the contour will be interpolated between the colour for the range and the colour 
for the next range in the height range file.
If not tick, all contours in the same range in the height range file will have the same colour

Colour text labels tick box tick

if tick, any text labels in the model will also be coloured.

Run button

colour the contours according to the height range file.
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Contour, Smooth and Label
tin__contour__smooth_and_label
Position of option on menu: Tins =>Contour =>Contour, smooth and label

One method of visualizing tin data is with contours. In 12d Model, contour strings can be 
produced over any user defined elevation range and at any interval.

This option creates contours and can also smooth and label them. It is a function and so if a 
function is re-run it will remove any data from its last run.

For more information on contouring, smoothing and labelling in 12d Model, go to the section 
“Creating Contours” 

On selecting the Contour, smooth and label option, the Contour, Smooth and Label panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name function box available contour fns

name of the contour, smooth and label function.

Tin to contour input available tins

name of the tin to be contoured.

Contours tab

Model for contours model box available models

name of the model to place the contours in.

Contour increment input 1.0

increment between contoured values.
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Name input

if non-blank, name to give the contour strings.

Colour input cyan available colours

colour of the contours

Linestyle input 1 available linestyles

linestyles for the contour strings.

Weight input

if non-blank, weight to give the contour strings.

Smooth contours tick box

if tick, the contours are smoothed.

Preserve string points tick box

if tick, then the smoothed string goes through the original vertices of the non smoothed contour strings.
If not tick, then the smoothed strings do not have to include the vertices from the non-smoothed 
contours.

Major Contours tab

Create major contours tick box

if tick, then major contours can be given a different name, colour, style, weight and model.

Model for major contours model box available models

if non blank, the name of the model to place the major contours in. If blank, the same model is used as 
for the ordinary contours.

Major contour increment input 5.0

increment for the major contours.
If blank or zero, then no bold contours are drawn. If non-zero, it must be an integer multiple of the 
contour increment.

Name input

if non-blank, name to give the major contour strings. If blank, the same name is used as for the 
ordinary contours.

Colour input off yellow available colours

colour of the major contours. If blank, the same colour is used as for the ordinary contours.

Linestyle input 1 available linestyles

if non blank, linestyles for the major contour strings. If blank, the same linestyle is used as for the 
ordinary contours.

Weight input

if non-blank, weight to give the major contour strings. If blank, the same weight is used as for the 
ordinary contours.

Range tab

Cont min input

minimum value of the z range to be contoured. If blank, the tin’s minimum z-value is used.

Cont max input

maximum value of the z range to be contoured. If blank, the tin’s maximum z-value is used.

Cont ref input 0.0
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reference value for the contour increments.

Labels tab

Label contours tick box

if tick, then the contours are labelled.

Label major contours only tick box

if tick, then only the major contours are labelled.

Model for labels model box available models

if non blank, the name of the model to place the contour labels in. If blank, the same model is used as 
for the contours.

Contour method input above line contour direction
above line read from below
centred line read from below

line removal and centred line read from below
above line facing uphill
centred line facing uphill

line removal & centred facing uphill

For information on each of the methods of labelling contours, go to the section “Labelling Contours” .

Decimal places

number of decimal places used in the contour label.

Textstyle data input 1 textstyle favourites

textstyle information to use for the contour labels.

Start dist (w) input 0

chainage distance to the first label on the string - world units

Separation (w) input 250

chainage interval between the labels - world units

Model of label lines model box available models

if non blank then instead of using the start distance and separation parameters to define where the 
contour labels are placed, the Model of label lines is used. In this case, a label is created where ever s 
string in the Model of label lines cuts a contour.

Label start and end tick box tick

if tick, the start and end of the contours are labelled regardless of the values of start distance and 
separation.

Process button

contour, smooth and label the tin given in the tin field and place the contours in the model given in the 
model field.
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Drape
tin_drape

Position of menu: Tins =>Drape

The drape option sections along a string and creates a new 3d-string which sits over the original 
string in plan view (with line approximations for arcs and spirals) but with z-values taken from a 
triangulated surface (a tin).

The drape alignment option takes an alignment string and creates a new alignment string with 
the identical horizontal geometry and vertical intersection points with z-values taken from a tin.

The tin drape walk-right menu is

The options in the tin contours menu will now be discussed.

For the option Drape, please go to the section “Drape” 
Alignment  “Drape Alignment (Macro)” 
Heights  “Heights for Tin Boundary” 
String heights for tin,  “Update Z-values from Tin” 

Drape
drape

Position of option on menu: Tins =>Drape =>Drape

The drape operation is simply sectioning along a string.

Draping is a very useful method for attaching a z-value for strings defined in plan only. For 
example, cadastral information often has only (x,y) co-ordinates. The drape operation could be 
used to apply z-values to the cadastral information, for example, z-values from the natural 
surface tin. The draped cadastral information would then sit on the natural surface and could be 
used effectively in perspective views as well as plan views to delineate properties etc.

Instead of simply producing a section along a string, drape can also be used to produce a face for 
every segment of the string by draping the segment onto the tin and forming a face by 
perpendicularly connecting the end points of the segment and the draped segment. For example, 
if the strings represented the tops of buildings, the created faces would be the sides of the 
buildings down to the terrain.

The data to be draped can be selected in three ways - an individual string can be selected and 
draped, all the strings in a model can be draped, or all the strings in a view can be draped.

On selecting drape, the drape panel is displayed.

drape strings and produce 3d strings
drape an alignment string and produce an alignment string
drape alignment from V7V1f
give tin heights to a tin boundary
 update z-values of strings from a tin
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The fields and buttons used in the panel have the following functions.

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

data to drape.

Tin input available tins

name of the tin to drape the strings over.

Produce faces tick-cross

if tick, drape each segment of the string to form faces. If no tick, simply drape the string onto the tin.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

models where the draped strings are placed.

Drape button

drape the strings selected by the "data to drape" data source over the tin given in the tin field.

Note: if faces rather than sections are to be produced, set the produce faces flag to yes.

<esc> can be used to abort the drape option.
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Drape Alignment
drape_alignment_many

Position of option on menu: Tins =>Drape =>Alignment

The Drape alignment operation takes an alignment/super alignment string and creates a new 
alignment/super alignment string with identical horizontal geometry and the z-value for 
vertical intersection points taken from a tin. The z-values are taken over a user specified 
chainage interval and chainage increment. Vertical intersection points outside the chainage range 
can be kept.

On selecting Alignment, the Drape Alignment Many panel is displayed.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” .

Data source input

source of data of alignment/super alignment strings to drape.

Tin input box

triangulation to take z-values from.

Chainage increment input box

the chainage interval to create VIP points for. Each created VIP point is given the z-value from the tin 
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and the (x,y) position of the VIP.

Start/End chainage input box

if non blank, the chainage range to create VIP’s over.
 If blank, use the start/end chainage of the selected string.

Reduce height by input box

if non blank, the value is subtracted from the z-value on the tin. 

Include critical points tick box tick

if tick, VIP’s are created at the horizontal tangent points.

Keep existing VIPs tick box

if tick, any existing VIP’s outside the given chainage range are kept.
If not tick, don’t create any VIP points outside the chainage range.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Drape button

create new alignment/super alignment strings with the same horizontal geometry as the selected 
strings and the z-value for VIP points taken from the given tin.
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Drape Alignment (Macro)
drape_alignment_panel

Position of option on menu: Tins =>Drape =>Alignment (macro)

This is the Drape =>Alignment option from V7C1f. It has now been superseded.

The Drape alignment (macro) operation takes an alignment string and creates a new alignment 
string with identical horizontal geometry and the z-value for vertical intersection points taken 
from a tin. The z-values are taken over a user specified chainage interval and chainage 
increment. Vertical intersection points outside the chainage range can be kept.

On selecting Alignment (macro), the drape alignment panel is displayed.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Alignment string select

alignment string to drape.

Start/End chainage input box

the chainage range to create VIP’s over. if blank, use the start/end chainage of the selected string.

Include critical points tick box tick

if tick, VIP’s are created at the horizontal tangent points.

Keep existing VIPs tick box

if tick, any existing VIP’s outside the given chainage range are kept.
If not tick, don’t create any VIP points outside the chainage range.

Ch increment input box

the chainage interval to create VIP points for. Each created VIP point is given the z-value from the tin 
and the (x,y) position of the VIP.
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Tin input box

triangulation to take z-values from.

Model for new string input box

model for the draped string.

Colour for string input box

Colour for the draped string.

Process button

create a new alignment string with the same horizontal geometry as the selected string and the z-value 
for VIP points taken from the given tin.
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Heights for Tin Boundary
or Drape Using Closest Tin Node
drape_or_closest_tin_node_panel

Position of option on menu: Tins =>Drape =>Heights for boundary

This option takes strings and for each vertex of each string, replaces the z-value by the z-value at 
the same (x,y) position from a given tin, or if there is no tin at the (x,y) position, takes the z-value 
from the closest non-null tin node to the (x,y) position.

The option is useful for taking a tin boundary with no z-values and creating z-values for each 
vertex from the tin.

On selecting Heights from boundary, the Update Z-values from Tin panel is displayed.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source choice box model model, view, string

type of the data source

Model/View/String name

source of the data to drape vertices for.

Tin

tin to drape the vertices onto.

Model for draped/node data

model for the draped strings.

Set z-null if no point found tick box tick

if tick, the vertex z-value is set to null if no tin exists at the vertex.
If not tick and the tin does not exist at the vertex, the z-value for the vertex is taken from the closest 
non-null tin node.

Process button

run the option.
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Update Z-values from Tin
string_zvalues_from_tin_panel

Position of option on menu: Tins =>Drape =>String heights from tin

The Update z-values from tin option takes a string (not an alignment string) and replaces the z-
value at a vertex by the z-value from the tin at that (x,y) position. 

On selecting Update z-values from tin, the Update Z-values from Tin panel is displayed.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source type model string, model, view

data selection type.

Data source model string, model, view

source of data to process.

Tin for z values tin box

triangulation to take z-values from.

Convert 2d to 3d tick box tick

if tick, any 2d strings are converted to 3d string so that each point can have a different z-value.

Process button

takes all strings (not an alignment string) in the data source and replaces the z-value at a vertex by the 
z-value from the tin at that (x,y) position. 
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Tin Analysis
tin_analysis

Position of menu: Tins =>Tin analysis

The tin analysis options are used to calculate the direction and slope of triangles, the intersection 
between tins, surface areas, flow arrows, ridge and valley lines and viewsheds.

The tin analysis walk-right menu is

For the options Aspect, please got to the section “Aspect” .
Slope  “Slope” 
Intersection  “Intersection” 
Surface area  “Surface Area” .
Surface area 2 “Surface Area 2” 
Viewshed “Viewshed” 
Flow arrows  “Flow Arrows” 
Ridge/Valleys “Ridge/Valleys” 
Depth range polygons “Depth Range Polygons” 
Polygons from colours “Polygons from Tin Colours” 

Aspect
tin_aspect

Position of menu: Tins =>Tin analysis =>Aspect

The tin aspect options calculate and report on the directions of the triangles. The tin aspect walk-
right menu is

The options in this menu will now be discussed.

Aspect Analysis
aspect_analysis

Position of option on menu: Tins =>Tin analysis =>Aspect => Aspect Analysis

This panel is used to calculate the aspect or direction that the triangles of a tin face. The 

colour and report for ranges of aspects
colour and report for ranges of slopes
lines of intersection between two tins
report surface area within a polygon
report surface area for a model of polygons
calculate viewshed
create flow arrows for a tin.
create ridge and valley lines for a tin
create polygons for depth ranges
creates polygons around coloured regions of tin

colour and report for ranges of aspects
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calculations can be restricted to within a user selected polygon, or if no polygon is selected, the 
entire tin is used.

The calculated aspects can be produced and reported over user supplied bearing ranges. 
Similarly, a plan view can be temporarily coloured on an aspect basis using the same range file. 
The temporary colours will disappear next time the view is refreshed.

For permanency, the option can also create coloured faces with the appropriate range colour. The 
faces can be displayed on any plan view using a solid fill colour or a hatch pattern.

For aspect analysis, the range file consists of a list of aspect ranges and colours, one set per line, 
in the format

lower_bearing upper_bearing range_colour
where this line represents all bearings satisfying

lower_bearing <   bearing   <= upper_bearing.
For each range in the file, the plan and slope areas of the triangles in the bearing range will be 
reported on, and the range_colour can be used to colour all areas on a plan view satisfying the 
range.

On selecting the aspect analysis option, the Aspect Analysis panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the aspects of the triangles will be calculated.

Range file input *.arf

the user supplied range file is used to split up the aspect report and define the range colours used for 
painting a plan view.

Plan view to paint input available views

if non-blank, the given plan view will be painted according to the range colours given in the range file.

Model for faces input available models

if non-blank, faces will be created with colours according to the range colours given in the range file.

Clean faces model beforehand tick box

if tick, the model of faces is cleaned out before the option runs.
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Report file input *.rpt

name of the file to contain the aspect report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Poly string-select

if selected, this string is used as the bounding polygon for the aspect calculations.

Aspect button

the aspects of the triangles of the tin within the selected bounding polygon are calculated.

<esc> can be used to terminate the option during aspect calculations.

Example of an Aspect Range File
//   aspect range file
// format: lower_bearing upper_bearing colour_for_range

0 45 red // colour red the triangles with bearing greater than 0 and less than or equal to 45
45 90 green // colour green the triangles with bearing > 45, and <= 90

90 123.30 "dark green" // colour dark green triangles with bearing > 90 and <=l to 123 deg 30’

Aspect Analysis 2 and 2 (new)
aspect_analysis_2

Position of option on menu: Tins =>Tin analysis =>Aspect => Aspect Analysis 2

Position of option on menu: Tins =>Tin analysis =>Aspect => Aspect Analysis 2 (new)

As with the aspect analysis option, the aspect analysis 2 option is used to calculate the aspect or 
direction that the triangles in the tin face.aspect_analysis_2_new

However, this option can also create the strings that bound the triangles in the same aspect 
range. The aspect analysis 2 (new) option is the same as aspect analysis 2 except the boundary 
polygons have slightly different names.

One restriction for this option is that the calculations can not be restricted to be within a polygon 
and the entire tin is used.

For aspect analysis 2, the range file consists of a list of aspect ranges and colours, one set per line, 
in the format as for aspect analysis:

lower_bearing       upper_bearing       range_colour

where this line represents all bearings satisfying

lower_bearing <   bearing   <= upper_bearing.

For each range in the file, the boundary strings for areas of common range can be created and 
also coloured faces that can be displayed on any plan view.

On selecting the aspect analysis 2 option, the Aspect Analysis 2 panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the aspects of the triangles will be calculated.

Range file input *.arf

the user supplied range file is used to split the triangles into groups of common aspects so that 
boundary strings can be created and the range colours used for faces and the boundary strings.

Model for faces input available models

if non-blank, a faces will be created (with the colour given in the range file) for each triangle.

Model for boundaries input available models

if non-blank, for each range of aspects in the range file, boundary strings will be created for regions of 
common aspect. The boundary strings are given the name "aspect boundaries" plus the number of the 
entry in the range file. Many of the boundaries will exist twice since they are the upper boundary for 
one range and the lower boundary for the next range but will have a different colour and name. For 
aspect analysis 2 (new), the boundary name also has the addition of "face" and a number to more 
clearly differentiate the boundaries of the same range.

Boundaries as faces tick box

if tick, output the regions of common aspect as faces.

Boundary colour input cyan available colours

not used - was the colour for the aspect boundaries.

Aspect button

On selecting this button, the aspects of the triangles of the tin are calculated and the appropriate 
boundaries and faces created.

<esc> can be used to terminate the option during aspect calculations.

Slope
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tin_slope
Position of menu: Tins =>Tin analysis =>Slope
The tin slope options calculate and report on the slopes of the triangles. The tin slope walk-right 
menu is

The options in this menu will now be discussed.

Slope Analysis
slope_analysis

Position of option on menu: Tins =>Tin analysis =>Slope =>Slope analysis

This panel is used to calculate the slopes of triangles in the tin. The calculations can be restricted 
to within a user selected polygon, or if no polygon is selected, the entire tin is used.

The calculated slopes can be produced and reported over user supplied slope ranges. Similarly, a 
plan view can be temporarily coloured on a slope basis using the same range file. The temporary 
colours will disappear next time the view is refreshed.

For permanency, the option can also create coloured faces with the appropriate range colour. The 
faces can be displayed on any plan view using a solid fill colour or a hatch pattern.

For slope analysis, the range file consists of a list of ranges and colours, one set per line, in the 
format

lower_slope       upper_slope       range_colour
where this line represents all slopes satisfying

lower_slope <   slope   <= upper_slope.

The slopes in the file can be percent cross fall, “1v in” slope or degrees (in 12d Model dms 
format) but they must all be of the same type in the file.

Note - if "1v in" is used, the range is converted to:

smaller_slope_as_percent_cross_fall <   slope   <= larger_slope_as_percent_crossfall

 For each range in the file, the plan and slope areas of the triangles in the range will be reported 
on, and the range_colour used to colour all areas on a plan view satisfying the range.

On selecting the Slope analysis option, the Slope Analysis panel is displayed.

colour and report for ranges of slopes
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the slopes of the triangles will be calculated.

Range file input *.srf

the user supplied range file is used to split up the slope report and define the range colours used for 
painting a view.

Slope type input percent cross fall,
degrees, 1v in

the units used for slope in the range file.

Plan view to paint input available views

if non-blank, the given plan view will be painted according to the range colours given in the range file.

Clean faces model beforehand tick box

if tick, the model of faces is cleaned out before the option runs.

Model for faces input available models

if non-blank, faces will be created with colours according to the range colours given in the range file.

Report file input *.rpt

name of the file to contain the slope report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Poly string-select

if selected, this string is used as the bounding polygon for the slope calculations.

Slope button

On selecting this button, the slopes of the triangles of the tin within the selected bounding polygon are 
calculated.
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 <esc> can be used to terminate the option during slope calculations.

Example of a Slope Range File
//   slope range file in percent cross fall
// format: lower_slope upper_slope colour_for_range

0 5 red // colour red the triangles with slope greater than 0% and less than
// or equal to 5% x-fall

5 10 green // colour green the triangles with slope > 5%,  and <= 10% x-fall

10 300 "dark green" // colour dark green triangles with slope greater than 10%
// and less than or equal to 300% x-fall

//   slope range file in "1v in" slopes
// format: lower_slope upper_slope colour_for_range

0 20 red // colour red the triangles with slope greater than flat and
// less than or equal to 1:20

20 10 green // colour green the triangles with slope between 1:20 and equal to 1:10

10 1 blue // colour blue triangles with slope between 1:10 and equal to 1:1

Slope Analysis 2 and 2 (new)
slope_analysis_2

slope_analysis_2_new

Position of option on menu: Tins =>Tin analysis =>Slope =>Slope analysis 2

Position of option on menu: Tins =>Tin analysis =>Slope =>Slope analysis 2 (new)

As with the slope analysis option, the slope analysis 2 option is used to calculate the slope of 
triangles in the tin.However, this option can also create the strings that bound the triangles in the 
same slope range.

 The slope analysis 2 (new) option is the same as slope analysis 2 except the boundary polygons 
have slightly different names.

One restriction for this option is that the calculations can not be restricted to be within a polygon 
and the entire tin is used.

The range file for slope analysis 2 has the same format as for slope analysis.

For each range in the file, the boundary strings for areas of common range can be created and 
also coloured faces that can be displayed on any plan view.

On selecting the Slope analysis 2 option, the Slope Analysis 2 new panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the slopes of the triangles will be calculated.

Range file input *.srf

the user supplied range file is used to split the triangles into groups of common slopes so that boundary 
strings can be created and the range colours used for faces.

Slope type input percent cross fall,
degrees, 1v in

the units used for slope in the range file.

Model for faces input available models

if non-blank, a faces will be created (with the colour given in the range file) for each triangle.

Model for boundaries input available models

if non-blank, for each range of slopes in the range file, boundary strings will be created for regions of 
common slope. The boundary strings are given the name "slope boundaries" plus the number of the 
entry in the range file. Many of the boundaries will exist twice since they are the upper boundary for 
one range and the lower boundary for the next range but they will have a different colour and name. 
For slope analysis 2 (new), the boundary name also has the addition of "face" and a number to more 
clearly differentiate the boundaries of the same range.

Boundaries as faces tick box

if tick, output the regions of common aspect as faces.

Boundary colour input cyan available colours

colour for the slope boundaries.

Slope button
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On selecting this button, the slopes of the triangles of the tin are calculated and the appropriate 
boundaries and faces created.

<esc> can be used to terminate the option during slope calculations.

Intersection
tin_tin_intersection

Position of option on menu: Tins =>Tin analysis =>Intersection

The intersection option finds the lines of intersection between two tins.

On selecting the intersection option, the Tin Tin Intersection panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original tin input available tins

name of one of the tins to be intersected.

New tin input available tins

name of the other tin to be intersected.

Model for intersection input available models

name of the model to contain the intersection strings.

Colour for intersection input default colour available colours

colour to make the intersection strings

Calculate button

calculate the intersection between two tins given in the panel fields. The resulting intersection strings 
are added to the model given in the model for intersection field.
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Surface Area
surface_area_within_a_polygon

Position of option on menu: Tins =>Tin analysis =>Surface area

The surface area option is used to calculate the surface area of a tin within a user selected string.

On selecting the surface area option, the surface area within a polygon panel is placed on the screen.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

the tin to calculate the surface area on.

Report file input *.rpt files

if non-blank, the name of the file to write the surface area within the selected polygon to.

Poly button

select the string to find the slope area within.

Area button

calculate the surface area of the tin within the selected polygon.

Surface Area 2
surface_area_within_a_model_of_polygons

Position of option on menu: Tins =>Tin analysis =>Surface area 2

The surface area 2 option is used to calculate the surface area of a tin within each polygon in a model.

On selecting the surface area 2 option, the Surface Area Within a Model of Polygons panel is placed on 
the screen.

The fields and buttons have the following functions.



Chapter 15  Triangles

March 2007 Page 1221Tin Analysis

Field Description Type Defaults Pop-Up

Tin input available tins

the tin to calculate the surface area on.

Model input available models

the model of polygons for calculating surface area within.

Report file input *.rpt files

if non-blank, the name of the file to write the surface area within each polygons in the model, plus the 
total of the surface area.

Area button

calculate the surface area of the tin within each polygons in the model, and sum the areas.

Viewshed
viewshed

Position of option on menu: Tins =>Tin analysis =>Viewshed

This panel is used to calculate the points that are visible and invisible from a user selected eye 
position. This is equivalent to calculating the points that can or can not see a selected point.

The calculations are made along rays emanating from the eye point from a minimum to a 
maximum distance from the eye point. The rays are created at regular angular steps from a start 
angle to an end angle.

On selecting the viewshed option, the Viewshed panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to be used for the viewshed analysis.
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Start angle input    0

the angle to begin taking sight rays emanating from the eye point.

End angle input  359.30

the angle to stop taking sight rays emanating from the eye point.

Step angle input    5

the angle between successive sight rays emanating from the eye point.

Minimum distance input

if non-blank, the minimum distance from the eye point along the sight ray to begin recording visible/
invisible points.
If blank, the minimum distance is zero.

Maximum distance input

the maximum distance from the eye point along the sight ray to record visible/invisible points.
If blank, the entire tin is considered.

Model for sections input available models

the model for the visible/invisible sight strings.

Colour of visible bits input  default line colour

if non-blank, the colour for the visible parts of the rays.
If blank, the visible parts are not created.

Colour of invisible bits input  default point colour

if non-blank, the colour for the invisible parts of the rays.
If blank, the invisible parts are not created.

Eye XYZ input/output xyz ops menu

the XYZ co-ordinates of the eye point.

Eye button

if picked, an eye point is selected and then the height displayed in an enter height input box. If 
required, a new height can be typed into the enter height box. After typing an <enter> into the input 
box, the box is removed from the screen and the x, y and height is piped into the eye XYZ panel field.

Viewshed button

On selecting this button, the lines of sight emanating from the eye XYZ point are calculated.

<esc> can be used to terminate the option during viewshed calculations.

Flow Arrows
flow_arrows

Position of option on menu: Tins =>Tin analysis =>Flow arrows

The flow arrows option draws arrows indicating the flow direction across triangles in a tin.

The flow arrows can be drawn for selected points, for all the triangles within a polygon, or if no 
polygon is selected, for all triangles in the tin.
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The arrows are drawn at the centroid of the triangle and have a fixed user given length.

On selecting the flow arrows option, the flow arrows panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to calculate flow arrows for.

Arrow length (w) input

length in world units to draw the flow arrows.

Colour for arrows input cyan available colours

colour for the arrows.

Model for arrows input available models

model to put flow arrows in. Must be non-blank.

Pick button

after selecting pick, a flow arrow is drawn at each selected point. This continues until cancel is 
selected from the pick ups menu.

Poly button

if a polygon is selected, then the spot heights will be restricted to within the polygon.
If no polygon is selected, the spot heights will be calculated over the entire tin.

Flow button

calculate the flow arrows for all the triangles in the tin, or if a polygon has been selected, for the 
triangles whose centroid is inside the polygon.

Ridge/Valleys
tin_ridges_and_valleys

Position of option on menu: Tins =>Tin analysis =>Ridges/Valleys

In the ridge/valleys option, ridge and valley lines are calculated for the given tin.

On selecting the ridge/valley option, the tin ridges and valleys panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to calculate ridge and valley lines for.

Ridge model input available models

if non-blank, the name of the model to contain the ridge lines. If blank, the ridge lines are not created.

Colour for ridges input default colour available colours

colour for the ridge lines

Valleys model input available models

if non-blank, the name of the model to contain the valley lines. If blank, the valley lines are not created.

Colour for valleys input default colour available colours

colour for the valley lines

Calculate button

ridge and valley lines will be calculated for the given tin and placed in the ridge and valley models.

Depth Range Polygons
tin_tin_depth_range_polygons

Position of option on menu: Tins =>Tin analysis =>Depth range polygons

In the Depth range polygons option, polygons are created around the regions given by a depth 
range file.

On selecting the Depth range polygons option, the Tin Tin Depth Range Polygons panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original/New Tin tin box available tins

name of the original/new tin for determining depths between.

Range file input *.drf

the user supplied range file for splitting up the depths.

Model for polygons model box available models

model to contain the polygons.

Calculate button

create the polygons surrounding regions of different heights between the tins.

Polygons from Tin Colours
colour_analysis

Position of option on menu: Tins =>Tin analysis =>Polygons from colours

In the Polygons from colours option, polygons are created around the different coloured regions 
of the tin.

On selecting the Polygons from colours option, the Colour Analysis panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins
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name of the tin to calculate polygons around the coloured regions.

Model for boundaries input available models

model to contain the polygons.

Colour for boundaries input default colour available colours

colour for the polygons

Boundaries draped tick box

if tick. the z-values for the vertices for the boundary strings come from the vertices of the coloured 
triangles.
If not tick, the boundaries have constant z-values.

Colour for boundaries input default colour available colours

colour for the polygons

Create button

create the polygons surrounding regions of different colours on the tin.
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Inquire
tin_inquire

Position of menu: Tins =>Inquire

The inquire options are used to display at the current cursor position the height (z-value) on a tin, 
the colour of the triangle, the depth from a fixed height to a tin, and the depth between two tins,.

Once the user specifies which tin or tins are to be analysed, then as the cursor moves around in 
any plan view, the triangles below the cursor are examined and the appropriate information 
displayed.

The tin inquire walk-right menu is 

The options in the tin inquire menu will now be discussed.

For the options Aspect, please go to the section “Aspect Inquire” .
Colour “Colour Inquire” 
Depth from height “Depth from Height” 
Depth from string “Depth from String” 
Depth between tins “Depth Between Tins” 
Height “Height Inquire” 
Slope “Slope Inquire” 

Aspect Inquire
tin_aspect_inquire

Position of option on menu: Tins =>Inquire =>Aspect

The aspect inquire option calculates and displays the aspect (direction) of the triangles under the 
current plan view cursor position. The aspect is displayed in bearings in degrees, minutes and 
seconds.

On selecting the tin aspect inquire option, the tin aspect inquire panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input avail tins

name of the tin for which the aspect of the triangle that the cursor is above will be displayed in the 

report aspect of triangles
report colour of tin
calculate depth from height to tin
calculate depth from string to a tin
calculate depth between tins
report height on tin
report slope of triangles
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panel’s message area.
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Colour Inquire
tin_colour_inquire

Position of option on menu: Tins =>Inquire =>Colour

colour inquire displays the colour of the triangles under the current plan view cursor position.

On selecting the tin colour inquire option, the tin colour inquire panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the colour of the triangle at the current cursor position is displayed in the 
panel’s message area.

Depth from Height
depth_from_height_to_tin_inquire

Position of option on menu: Tins =>Inquire =>Depth from height

The depth from height option calculates and displays the difference between the z-value of a tin 
and a given height for the current plan view cursor position.

On selecting the depth from height option, the depth from height to tin inquire panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin used for calculating the distance from the tin to the given height at the cursor position.

Height input 0

the difference between the tin value and the value given in this field is displayed in the panel’s message 
area.
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Depth from String
depth_from_string_to_tin_inquire

Position of option on menu: Tins =>Inquire =>Depth from string

The depth from string option calculates and displays the difference between the z-value of a tin 
and the height of a selected string at the current plan or section view cursor position projected 
back onto the selected string.

The obvert (top of the string) value is also known as the cover above a string to a tin.

On selecting the Depth from string option, the Depth From String to Tin Inquire panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin used for calculating the z-value at the cursor position.

String string-select

if a string is selected, the difference between the tin value and the height of the selected string (to the 
invert, centre and obvert of the string) at the current plan or section view cursor position, projected 
back onto the selected string, is displayed in the panel’s message areas.

Invert/Centre/Obvert output

displays the distance between the tin and the invert (bottom), centre and obvert (top) of the selected 
string 

Depth Between Tins
depth_between_tins_inquire

Position of option on menu: Tins =>Inquire =>Depth between tins

The depth between tins option calculates and displays the difference between the z-values of two 
given tins at the current plan view cursor position.

On selecting the depth between tins option, the depth between tins inquire panel is displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Original/new tin input available tins

name of the two tins or which the z-value is to be calculated at the current plan view cursor position 
and the difference between the z-values (z_new - z_original) is displayed in the panel’s message area.
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Height Inquire
tin_height_inquire

Position of option on menu: Tins =>Inquire =>Height

The height inquire option calculates and displays the height (z-value) of triangles from a tin at the 
current plan view cursor position.

On selecting the tin height inquire option, the tin height inquire panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the z-value at the current plan view cursor position is displayed in the panel’s 
message area.

Slope Inquire
tin_slope_inquire

Position of option on menu: Tins =>Inquire =>Slope

The slope inquire option calculates and displays the slope of triangles from a tin at the current 
plan view cursor position. The slope is displayed as a percent cross fall, a “1v in “slope and as an 
angle in degrees, minutes and seconds.

On selecting the tin slope inquire option, the tin slope inquire panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input avail tins

name of the tin for which the slope of the triangle that the cursor is above is displayed in the panel’s 
message area.
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Null
tin_null

Position of menu: Tins =>Null

The triangulation process forms triangles throughout the convex polygon enclosing the data set. 
This means that triangles may cross regions where there is very little data and may produce 
strange results in the ill-defined regions.

In 12d Model, it is possible to make triangles invisible (called nulling triangles) so that they are 
not used in any options.

Note - nulled triangles are not deleted and can be made visible again at any time. 

The null walk-right menu is 

The three options in the tin colouring menu will now be discussed.

For the options Include/exclude, please go to the section “Include/Exclude Boundaries” .
Null  “Null” 
Reset “Reset” 
by length “Null by Length” 
by angle/length “Null by Angle and Length” 
by centroids “Null by Centroids” 
by string  “Null by Strings” 
by points  “Null by Points” 
by polygons “Null by polygons” 

Include/Exclude Boundaries
tin_include_exclude_boundaries

Position of option on menu: Tins =>Null =>Include/excludes

The Include/exclude option is used to tag a polygon that is part of the data set for a Tin so that all 
the triangles inside the polygon are either set to null or non-null.

On selecting the Include/exclude option, the Tin Include/Exclude Boundaries panel is displayed.

set a polygon to include/exclude all triangles inside th
null triangles outside a polygon
reset all null triangles
null triangles by length of sides
null triangles by length of sides and angle
null/reset triangle under the centroid of strings
null triangles that are crossed by strings
pick triangles to null/reset
null/reset triangles inside/outside polygons
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Boundary mode choice box none none, include, exclude

mode to set the polygon to.

If the mode is exclude, then any triangles inside the polygon are set to null.
If the mode is include, then any triangles inside the polygon are reset so that they aren’t null.
If the mode is none, then the polygon is not used for automatically nulling/resetting triangles.

Pick button

select the polygon to define a boundary mode for.

Set button

set the boundary mode for the selected polygon.

Null
null_triangles_outside_polygon

Position of option on menu: Tins =>Null =>Null

The null option is used to null any triangle whose centroid is outside a user selected polygon.

On selecting the Null option, the Null Triangles Outside Polygon panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to null triangles in.

Null on accept of polygon tick box

if tick, the triangles will be nulled as soon as the string is accepted.
If not tick, the triangles will not be nulled until the Set button is selected. 
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Polygon button

the string to be used as the polygon is selected after choosing this button. If Null on accept of polygon is 
set, then the polygon is processed immediately.

Set button

process the selected string/. Any triangle whose centroid is outside the selected boundary polygon is set 
to null.
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Reset
null_triangles_reset

Position of option on menu: Tins =>Null =>Reset

The reset option is used to change all the nulled triangles in a tin back to the visible triangles.

On selecting the reset option, the Null Triangles Reset panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to have any nulled triangles reset to being visible triangles.

Reset button

the reset button resets all null triangles in the tin to the base colour.

Null by Length
null_triangles_by_length_of_side

Position of option on menu: Tins =>Null =>by length

The null by length option is used to null any triangle with a side of length greater than a user 
specified length.

Warning - this option will null out internal triangles. The next option, Null by angle/length will 
only null triangles on the outer shell.

On selecting the by length option, the null triangles by length of side panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to null triangles in.

Length input



Chapter 15  Triangles

March 2007 Page 1237Null

length to check triangle sides against.

Set button

after selecting the set button, the tin will be processed and any triangle with a side of length greater 
than the value given in the length panel field, will be nulled.
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Null by Angle and Length
null_triangles_by_angle_and_length

Position of option on menu: Tins =>Null =>by angle/length

The null by angle/length option is a more powerful nulling option which tries to remove most of 
the external triangles that one expects should be removed. For example, for a T-intersection, all 
the long, thin outer triangles should be removed. The option has two sets of tests - one to remove 
long thin triangles and the other which uses a combined test to remove squat triangles.

Unlike the null by length option, null by angle/length only works on triangles which have an outer 
null triangle on one or two sides (it does not work on internal holes). These triangles are called 
external triangles and sides with an outer null triangle on them are called external sides.

The null by angle and length option does not remove triangles whose external side is a breakline. 
Hence, as expected, breaklines will stop the nulling process.

Note that null by angle and length keeps processing the remaining non-nulled triangles until no 
more can be nulled or are stopped by breaklines. Hence the nulling works inwards as outer 
triangles are nulled revealing new external triangles to be tested. The nulling process is like 
peeling off layers of an onion.

Important note - the setting for this option are stored by the triangulation and the option is 
automatically re-run if the triangulation is re-run. To turn off the tests, just set the panel fields to 
blank.

Warning - this option should be the first nulling option used because all null triangles are first 
reset to valid triangles before this option is applied.

On selecting the null by angle/length option, the Null Triangles by Angle and Length panel is 
displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin to null input available tins

name of the tin to have triangles nulled. If this option has been previously run on the tin, the previous 
panel values are written into the panel fields.

Angle input 5

if a triangle has an external side (that is not a breakline) with an angle on it less than Angle, then the 
triangle is nulled. The default value works most of the time.
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If blank then no triangles are nulled by this test.

Length input 100

if a triangle has an external side (that is not a breakline) greater than Length, the triangle is nulled.

If blank then no triangles are nulled by this test.

Combined angle input 60

Combined length input 20

For the Combined case, a triangle is nulled if it:

has an external side (that is not a breakline) and the sum of the two angles on it is less than Combined 
angle (the default value works most of the time)
and

has an external side (that is not a breakline) whose length is greater than Combined length. A 
suggested value is one third to one half of Length.

If either Combined angle or Combined angle is blank, then no triangles are nulled by this test.

Null button

after selecting the Null button, all nulled triangles are reset to be valid triangles and the tin then 
processed and triangles nulled.

Null by Centroids
null_triangles_by_centroids_of_strings
Position of option on menu: Tins =>Null =>by centroids
null by centroids is used to null/reset any triangle that lies under the centroid of a string.
On selecting the by centroids option, the null triangles by centroids of strings panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to null/reset triangles in.

Model of strings input available models

model of strings to be used to select triangles that are under a centroid of one of the model’s strings.

Null mode input Reset Reset, Null

if null, any triangle under the centroid of a string from the model of strings, will be nulled.
   reset, any triangle under the centroid of a string from the model of strings, will be made visible again.

Set button
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after selecting the set button, the tin will be processed and any triangle under the centroid of a string 
will be set according to the null mode panel field.
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Null by Strings
null_triangles_by_strings
Position of option on menu: Tins =>Null =>by strings
The null by strings option is used to null any triangle that is cut by a string.
On selecting the by strings option, the null triangles by strings panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to null triangles in.

Use a string radio button

if set, strings will be selected and used to null any triangle that the string passes through.

Null on accept of string tick box

if tick, the triangles will be nulled as soon as the string is accepted.
If not tick, the triangles will not be nulled until the Set button is selected. 

String string select existing string string pop-up

if string, a strings will be selected and used to null any triangle that the string 
passes through.
If line, a temporary two point line is drawn and used to null any triangle that the line 
passes through 
If polyline, a temporary polyline is drawn and used to null any triangle that the 
string passes through 
If closed polyline, a temporary closed polyline is drawn and used to null any triangle that the string 
passes through 

Use a model of strings radio button

if set, a model of strings is used and a triangle is nulled if it is cut by any one of the strings.

Model input available models

model of strings to cut the triangles.

Set button

after selecting the set button, the tin will be processed and any triangle that is cut by a string from the 
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Model, or a selected string for the User a string case, will be nulled.

Null by Points
null_triangles_by_points

Position of option on menu: Tins =>Null =>by points

The null by points option is used to null/reset any triangle that the user selected with the mouse.

On selecting the by points option, the null triangles by points panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to null/reset triangles in.

Null mode input Null Reset, Null

if null, any triangles under a cursor pick will be nulled.
    reset, any nulled triangles under a cursor pick will be turned back on.

Pick button

any triangle under the cursor select will be processing according to the null mode panel field.

Null by polygons
null_triangles_by_polygons

Position of option on menu: Tins =>Null =>by polygons

The null by polygons option is used to null/reset any triangles that are inside or outside a user 
selected polygon, or model of polygons.

If a string is selected to use and it is not closed, then a polygon is formed by joining the first and 
the last points of the string.

On selecting the by polygons option, the null triangles by polygons panel is displayed
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.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to null/reset triangles in.

Null mode input Null Reset, Null

if null, any triangles selected will be nulled.
    reset, any nulled triangles selected will be turned back on.

Poly mode input inside inside, outside

mode to select whether the triangles with centroids inside or outside the selected polygons are to be 
nulled.

Use a polygon radio button

if set, strings will be selected and used as the polygon to null/reset all triangles with centroids inside/
outside the polygon.

Null on accept of polygon tick box

if tick, the triangles will be nulled/reset as soon as the polygon (string) is accepted.

If not tick, the triangles will not be nulled/reset until the Set button is selected. 

Use a model of polygons radio button

if set, a model of strings will be used as the polygons to null/reset triangles whose centroids are inside/
outside one of the polygons.

Model input available models

model of strings to provide the polygons for nulling/resetting triangles.

Set button

each string in the model of polygons is used to null/reset the triangles in the tin given in the tin field 
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according to the null mode and poly mode panel field.
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Utilities
tin_utilities

Position of option on menu: Tins =>Utilities =>Tin Utilities

The triangles=>utilities menu contains miscellaneous options involving tins.

The utilities walk-right menu is 

Each option will now be described.

For the options Add, go to the section  “Add” 
Copy “Copy” 
Copy project tin  “Copy Project Tin” 
Grid DTM “Grid DTM” 
Rotated grid DTM  “Rotated Grid” 
DEMs  “DEMs” 
Remove “Remove” 
Rename “Rename” 
Report  “Report” 
Save  “Save” 
Tin to strings “Tin to Strings” 
Translate/copy “Translate/Copy” 
Weed  “Weed” 
Z diffs from tins “Z Differences from Tins” 
Z diffs from string to tin “Z Differences from String to Tin” 

add tins to project and models
create a copy of a tin
copy a tin from another project
create regular grid of points on a tin
create a rotated grid of points on a tin
create Digital Elevation Models 
remove tins from project and models
rename a tin
create report of a tin
save tins to disk
create points and breaklines from a tin
translate/copy a tin
weed duplicate points from the tin database
create vertices with z-difference between two tins
create vertices with z-difference between string and a tin
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Add
tin_adds

Position of menu: Tins =>Utilities =>Add

Tins can be added to the project and to models.

The tin adds walk-right menu is 

The options in this menu will now be described.

Add to Project
add_tin_to_the_project

Position of option on menu: Tins =>Utilities =>Add =>Add to project

The add to project option is used to add a removed tin back into the project.

On selecting the add tin to project option, the add tin to the project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Removed tin input available tins

name of the tin to be added to the working project. The tin must exist on the disk in the project area and 
not already be in the project.

Model for tin input available models

if non-blank, the loaded tin will be added to the model given in this field.

Add button

Add the tin given in the Tin field to the working project.
If the model for tin field is non-blank, the tin will be added to the model given in that field - if the model 
does not exist, it will be created.

Add All To Project
add_all_tins_to_project

Position of option on menu: Tins =>Utilities =>Add =>Add all to project

The add all tins option is used to add all the removed tins back into the project.

On selecting the add all to project option, the add all tins to project panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Add button

after selecting this button, all removed tins in the working project will be added to the project.

Add to Model
add_tin_to_a_model
Position of option on menu: Tins =>Utilities =>Add =>Add to model
On selecting the add to model output option, the add tin to a model panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to be added to a model.

Add to model input available models

name of the model to which the tin given in the tin field will be added.

Add button

add the tin given in the tin field to the model given by the add to model field.
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Copy
tin_copy

Position of option on menu: Tins =>Utilities =>Copy

A copy of an existing tin can be made using the copy option.

A SuperTin can also be copied and what is created is a new super tin with a new name but 
exactly the same tins making it up.

On selecting copy, the tin copy panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Old tin input available tins

name of the tin to be copied.

New tin input available tins

name of the copy of the tin - this can’t be the same as any existing tin in the project.

Colour of tin input available colours

if non-blank, the colour of the new tin. If blank, use the old tin colour

Model for tin input available models

if non-blank, the name of the model for the new tin. If blank, the tin is not put in any model.

Copy button

after selecting this button, the tin given in the old tin field will be copied and the copy given the name in 
the new tin field and placed in the model given in the model for tin field.
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Copy Project Tin
copy_project_tin
Position of option on menu: Tins =>Utilities =>Add =>Copy project tin
On selecting the copy project tin option, the copy project tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder input current directories

name of the folder that the project to get the tin from, is in.

Project input current projects

name of the project in the folder given in the folder field, that the tin is to be copied from.

Tin input available tins

name of the tin to be copied.

New name input

if non-blank, the new name to be given to the copied tin which must be different to all the exiting tins 
names in the working project. If blank, keep the name of the original tin (as long as it is different to the 
existing tins). 

New model input available models

if non-blank, the tin will be placed in this model.

Copy button

copy to this project, the tin given in the tin field from the project given in the project field. 



12d Model Reference Manual

Page 1250 March 2007Utilities

Grid DTM
regular_grid_of_tin

Position of option on menu: Tins =>Utilities =>Grid

The grid option calculates heights at points at regular x and y increments between given 
minimum and maximum x and y values. If a polygon is given, a z-value is only calculated for 
points inside the polygon.

Also see the “DEMs”  options for creating a file of a regular grid to different formats (Arc View, 
Quantm, Sokkia).

On selecting the Grid option, the Regular Grid of Tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin tin box available tins

name of the tin on which the spot heights will be calculated.

Min x/y input

minimum x/y values to calculate spot heights for.

Max x/y input

maximum x/y values to calculate spot heights for.

Delta x/y input

difference between the x/y-values for the grid.

Model for points input available models

if blank, no point strings will be created.
If non-blank, points strings of the spots heights will be created and stored in this model.

Colour for points input default colour available colours

colour to make the point strings.

Poly poly-select
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if a polygon is selected, then the spot heights will be restricted to within the polygon.
If no polygon is selected, the spot heights will be calculated over the entire tin.

Grid button

calculate the spot heights at regular points over the area given by the min and maximum x and y values 
and restricted to be inside the polygon.
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Rotated Grid
rotated_grid_panel

Position of option on menu: Tins =>Utilities =>Rotated Grid

This panel is used to create a grid of points with z-values from a given tin. The grid can be 
rotated and a polygon can be used to restrict the created points. A report of grid points can also 
be calculated in either simple x y z (one point per line) form or if no polygon is used, in a format 
accepted by Quantm (formerly Align 3D).

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Tin to drape on to tin box available tins

Tin to get the z-values from.

Fence (opt) string select

Optional – if selected, the grid is restricted to being inside the polygon.

Model for grid model box available models

Model for the created grid.

Colour for grid colour box dark green available colours

Colour for the created grid

Point on grid input box

The selected point is on the grid. The other grid points are integer multiples of the “Grid X increment” 
and “Grid Y increment” (with the bearing “Bearing of grid”) from this point.
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Bearing on grid input box

Bearing of the side of the grid.

Grid X increment input box

The grid is made up of points of integer multiple of “Delta X” in the X direction.

Grid Y increment input box

The grid is made up of points of integer multiple of “Delta Y” in the Y direction.

Keep grid null value pointstick box

If tick, the “Output null value” is written out for any null z-values. 

Report file type radio button align 3d/xyz xyz

If xyz – the grid is written out as x y z with one point per line. The” Output null value” is used for 
any null z-values in the grid. 
If align 3d – the grid is written out in a format suitable for align 3d. The” Output null value” is used 
for any null z-values in the grid.

Output null value input box -9999

The z-value to write out if any grid z-value is null.

Output file name file box *.rpt files

Name of the output file for the grid data.

Process button

Run the option

Undo button

Undo the last grid created whilst the panel is up.
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DEMs
tin_dems

Position of menu: Tins =>Utilities =>Dems

DEMS (Digital Elevation Models) can be created from a tin. DEMS are only regular arrays of z-
values, rather than the random values and break lines supported by Tins.

Unfortunately there is not just one formats for DEMs.

The DEMS walk-right menu is 

For the option Arc View, go to the section  “Write Arc View DEM” 
Arc View Act/Min/Max/Avg “Write Arc View DEM (Actual, Min, Max, Av)” 
Quantm “Quantm” 
Sokkia “Sokkia” 

Write Arc View DEM 
write_Arc_View_DEM

Position of option on menu: Tins =>Utilities =>DEM =>Arc View

The Arc View option calculates heights at points at regular x and y increments (cell size) between 
given minimum and maximum x and y values and writes out the data in the Arc View DEM 
format.

On selecting the Arc View option, the Write Arc View DEM panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin on which the DEM heights will be calculated.
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Min x/y input

minimum x/y values to calculate spot heights for.

Max x/y input

maximum x/y values to calculate spot heights for.

Cell size input

size of the delta x and delta y - cell is a square.

Null value for file input -9999

value to use when writing null z-values out to the file.

File input *.grd

the file name for the spot height values in Arc View DEM format.

Grid button

calculate the spot heights at regular points over the area given by the min and maximum x and y values 
and write out the file.

Write Arc View DEM (Actual, Min, Max, Av)
Write_Arc_View_DEM__Act_Min_Max_Avg_

Position of option on menu: Tins =>Utilities =>DEM =>Arc View Act/Min/Max/Avg

The Arc View Act/Min/Max/Agg option calculates heights at points at regular x and y increments 
(cell size) between given minimum and maximum x and y values, and also the minimum, 
maximum and average values for the cell. The data is written out in the Arc View DEM format.

On selecting the Arc View Act/Min/Max/Avg option, the Write Arc View DEM (Act/Min/Max/Avg) 
panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin on which the DEM heights will be calculated.

Cell size input

size of the delta x and delta y - cell is a square.

Null value for file input -9999

value to use when writing null z-values out to the file.

Grid button

calculate the spot heights at regular points over the area given by the min and maximum x and y values 
and write out the file.

Quantm 
write_quantm_DEM

Position of option on menu: Tins =>Utilities =>DEM =>Quantm

The Quantm option calculates heights at points at regular x and y increments between given 
minimum and maximum x and y values. If a polygon is given, a z-value is only calculated for 
points inside the polygon.
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Actual point strings and/or a file of heights at the points in Quantm (formerly Align 3D) format 
can be generated. For Quantm no polygon should be used and if there is no z-value (no tin) at a 
point, then a null z-value is written to the output file.

On selecting the Quantm option, the Write Quantm DEM panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin tin box available tins

name of the tin on which the spot heights will be calculated.

One row tick box

If tick, null points are added in for any missing (x,y) so that there is only one row of data (one string) 
for each x-value.

Min x/y input

minimum x/y values to calculate spot heights for.

Max x/y input

maximum x/y values to calculate spot heights for.

Delta x/y input

difference between the x/y-values.

Model for points input available models

if blank, no point strings will be created.
If non-blank, points strings of the spots heights will be created and stored in this model.

Colour for points input default colour available colours

colour to make the point strings.

Null value for file input -3200
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value to use when writing null z-values out to the file.

File input *.grd

If non-blank, a file of the spot height values in Quantm format is created.

Poly poly-select

if a polygon is selected, then the spot heights will be restricted to within the polygon.
If no polygon is selected, the spot heights will be calculated over the entire tin.

Grid button

calculate the spot heights at regular points over the area given by the min and maximum x and y values 
and restricted to be inside the polygon.

Sokkia 
write_Sokkia_DEM

Position of option on menu: Tins =>Utilities =>DEM =>Sokkia

The Sokkia option calculates heights at points at regular x and y increments between given 
minimum and maximum x and y values. If a polygon is given, a z-value is only calculated for 
points inside the polygon. A file of heights at the points in Sokkia format is generated.

On selecting the Sokkia option, the Write Sokkia DEM panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin tin box available tins

name of the tin on which the spot heights will be calculated.

Min x/y input

minimum x/y values to calculate spot heights for.

Max x/y input

maximum x/y values to calculate spot heights for.

Delta x/y input
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difference between the x/y-values.

Poly poly-select

if a polygon is selected, then the spot heights will be restricted to within the polygon.
If no polygon is selected, the spot heights will be calculated over the entire tin.

File input *.grd

If non-blank, a file of the spot height values in Sokkia format is created.

Grid button

calculate and write a file of the spot heights at regular points over the area given by the min and 
maximum x and y values and restricted to be inside the polygon.
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Remove
tin_removes

Position of menu: Tins =>Utilities =>Remove

Tins can be removed from models and from the project. Remove tins are not deleted but simply 
taken off the tin list in the project. Removed tins are left in the project area and can be added in 
again using the add option.

The tin removes walk-right menu is 

The options in the menu will now be described.

Remove From Project
remove_tin_from_the_project
Position of option on menu: Tins =>Utilities =>Remove =>Remove from project

On selecting the remove from project option, the remove tin from the project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to be removed from the working project.

Remove button

remove the tin given in the tin field from the project.

Remove All From Project
remove_all_tins_from_the_project
Position of option on menu: Tins =>Utilities =>Remove =>Remove all from project

On selecting the remove all from project option, the remove all tins from project panel is displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Remove button

remove all the tins from the working project. If no errors occur, the panel will be removed after the tins 
have been removed.

Remove From Model
remove_tin_from_a_model
Position of option on menu: Tins =>Utilities =>Remove =>Remove from model

On selecting the remove from model option, the remove tin from a model panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to be removed from a model.

Model input available models

name of the model from which the tin given in the tin field will be removed.

Remove button

remove the tin given in the tin field from the model given in the model field.

Rename
tin_rename

Position of option on menu: Tins =>Utilities =>Rename

On selecting the rename option, the tin rename panel is displayed.

This panel can be used to change the names of existing tins

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Old tin input available tins
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name of the tin to be renamed.

New tin input

new name for the tin

Rename button

change the name of the tin in the old tin field to the name given in the new tin field.

Report
report_tin

Position of option on menu: Tins =>Utilities =>Report

This panel produces a report on the tin including the models making up the tin and all the settings used 
when creating the tin.

On selecting the Tin report option, the Report Tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins or super tins

name of the tin to create report for.

File file box *.rpt files

name of the report file

Report button

create the tin report.

Save
tin_saves

Position of menu: Tins =>Utilities =>Save

Tins are automatically saved on disk when they are first created but various operations can then 
be applied to tins which may not be immediately updated on disk.

The tin saves walk-right menu is 

The options in the menu will now be described.
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Save a Tin
save_tin
On selecting the save a tin option, the save tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to be saved to disk.

Save button

after selecting this button, the tin given in the tin field will be saved to disk.

Save/Forced Save All Tins
save_all_tins
forced_save_all_tins
Position of option on menu: Tins =>Utilities =>Save =>Save all tins

Position of option on menu: Tins =>Utilities =>Save =>Forced Save all tins

On selecting the save/force save all tins option, the save/forced save all tins panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Save button

for save all tins: after selecting this button, all tins in the working project that have been modified since 
their last save, will be saved to disk. Unless an error occurs, the panel will be removed after the saving 
is completed.

for force save all tins: after selecting this button, all tins in the working project will be saved to disk. 
Unless an error occurs, the panel will be removed after the saving is completed.
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Tin to Strings
tin_to_strings

Position of option on menu: Tins =>Utilities =>Tin to strings

The points and breaklines of an existing tin can be extracted using the Tin to stings option.

Note that only the final points and breaklines used in creating the tin are extracted. Original string name, 
colours etc. are not obtainable.

, Selecting Tin to strings displays the Tin to Strings panel:

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin to extract strings tin box available tins

name of the tin to extract points and breaklines from.

Model for strings input available models

model to hold the extracted point and breakline strings.

Colour for point strings colour box available colours

colour of the extracted point strings.

Colour for breakline strings colour box available colours

colour of the extracted breakline strings.

Extract button

extract the points and breaklines that make up a tin.
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Translate/Copy
tin_translate_copy

Position of option on menu: Tins =>Utilities =>Translate/copy

An existing tin can be translated and/or copied using the Translate/copy option.

Selecting Translate/copy, displays the Tin Translate/Copy panel:

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Old tin input available tins

name of the tin to be copied/translated.

Copy the tin tick box tick

if tick, the New tin, Model for Tin and Colour for tin fields are activated and supply the information for 
the new tin.

New tin input available tins

name of the copy of the tin - this can’t be the same as any existing tin in the project.

Model for tin input available models

if non-blank, the name of the model for the new tin. If blank, the tin is not put in any model.

Colour of tin input available colours

if non-blank, the colour of the new tin. If blank, use the old tin colour

Translate the tin tick box tick

if tick, the dx, dy and dz fields are activated and supply the information for translating the tin

dx, dy, dz real box 0

the delta amounts to translate the tine by.

Process button

translate/copy the tin.
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Weed
tin_weed

Position of option on menu: Tins =>Utilities =>Weed

When a tin is created, a copy of all the points and lines used in creating the tin is saved with the 
tin, including any duplicate points and lines.

The weed option will remove all the duplicate points and lines from the tin database. 

On selecting the Weed option, the tin weed panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to weed.

Weed button

remove all duplicate points and lines from the tin database.
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Z Differences from Tins
tin_diffs_to_z_panel

Position of option on menu: Tins =>Utilities =>Z diffs from tins

This option takes a data source and for each point in the data source, creates a new point whose 
z-value is the difference in z-values from two given tins at the plan position of the data source 
point.

On selecting the Z diffs from Tins option, the Create Z-Values from Tin Differences panel is displayed.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source type Model

data selection type

Data source input

data to be processed.

Original tin tin box available tins

name of the tin to get the z-value from.

New tin tin box available tins

name of the tin to get the z-value from.

Model for tin differences input available models

model to place the strings containing the z values with the difference between the tins.

Process button

for all strings in the data source, calculate the difference in the z-values from the two tins at the string 
vertices.
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Z Differences from String to Tin
Tin_diffs_to_string_z_panel

Position of option on menu: Tins =>Utilities =>Z diffs from string to tin

This option takes a data source and for each string in the data source, creates a plan copy o fthe 
string and for each vertex in the new string, the z-value at a vertex is the difference in z-values 
from the original string vertex and the z-value of the tin at the (x,y) position of the vertex.

On selecting the Z diffs from string to tin option, the Create Z-Values from String to Tin Differences 
panel is displayed.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source type Model

data selection type

Data source input

data to be processed.

Tin tin box available tins

name of the tin to get the z-value from.

Model for tin differences input available models

model to place the strings containing the z values with the difference between the original string and 
the tin.

Process button

for all strings in the data source, calculate the difference in the z-values from the string to the tin.
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Sections
tin_sections

Position of menu: Tins =>Sections

The triangles=>sections menu contains options involving sections through the tin.

The sections walk-right menu is 

For the option Long section, please go to the section “Long Sections” .
Mesh, “Mesh” 
Polygon sections  “Polygon Sections” 
X-sections “X-Sections” 

Long Sections
long_section_along_a_string

Position of option on menu: Tins =>Sections =>Long Section

The long section option calculates the section through a tin along a particular string. This option 
is rarely used because tins are automatically profiled through on the section view and in long 
section and x-section plots.

On selecting the long section option, the long section along a string panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin that the string will be sectioned against.

Section name input

name to give the long section string

Colour for section input default colour available colours

colour to make the long section string

Model for section input available models

section along a string
create sets of sections through tin at right angles
limit sections to a polygon
x-sections along a string
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name of the model to contain the long section string.

Pick string-select

select he string to be sectioned along.

Section button

calculate the long section along the string selected by the pick button, against the tin given in the tin 
field. The resulting section string is added to the model given in the Model for Section field.
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Mesh
mesh_over_tin

Position of option on menu: Tins =>Sections =>Mesh

A 12d Model mesh is simply a series of lines cutting through the tin (sections) at a given angle 
and spacing, and at right angles to the given angle with the same spacing.

A mesh is an effective method of visualizing a triangulation when displayed in a perspective 
view and for hidden views.

On selecting the mesh option, the mesh over tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin that the mesh sections will be calculated through.

Angle for mesh sections input 90.0 0,45,90

angle (in degrees) of the lines to section along. The sections are also created at rights angles to this 
angle as well.

Dist between mesh sections input 10.0 1,10,100

distance between the lines to section along

Colour for mesh sections input default colour available colours

colour to make the calculated sections

Model for mesh sections input available models

name of the model to contain the calculated sections.

Clean sections model beforehand tick box

if tick, the model of sections is cleaned out before the option runs.

Poly button

if a polygon is selected, then the sections are restricted to remaining within the polygon.

Mesh button

two sets of sections through the tin given in the tin field are created within the selected polygon, or if no 
polygon is selected, the bounding polygon for the tin. One set of sections are calculated along straight 
lines at the angle given by the angle field and at a separation given by the dist field and the second set 
at right angles to the first set.
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<esc> can be used to abort the mesh option.
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Polygon Sections
sections_within_a_polygon

Position of option on menu: Tins =>Sections =>Polygon sections

In the polygon sections option, sections are calculated for a series of parallel lines covering the 
polygon, or if no polygon is given, the tin. The angle of the parallel lines and the distance 
between them are set by the user.

This option provides a quick method for producing a one directional set of sections covering a 
polygonal region on a tin.

On selecting the polygon sections option, the sections within a polygon panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin that the sections will be calculated through

Angle for sections input 90.0 0,45,90

angle (in degrees) of the lines to section along

Dist between sections input 10.0 1,10,100

distance between the lines to section along

Colour for sections input default colour available colours

colour to make the calculated sections

Model for section input available models

name of the model to contain the calculated sections.

Clean sections model beforehand tick box

if tick, the model of sections is cleaned out before the option runs.

Poly string-select

A string is selected from a view. The string will be used as the polygon for this option.If no polygon is 
selected, sections are created over the entire tin.

Section button

Sections within the polygon selected by poly will be calculated along parallel straight lines at the angle 
given by the angle field and at a separation given by the dist field. The sections are made against the tin 
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given by the Tin field. The sections colour is that given in the colour field and the section strings are 
placed in the model given in the model field.
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X-Sections
x_sections_along_a_string

Position of option on menu: Tins =>Sections =>X Sections

The X-sections (cross sections) option calculates cross sections at a given interval along a string.

On selecting the x-section option, the x-sections along a string panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin that the x-sections will be calculated through.

Dist between x-sections input 10

the distance between points on the selected string where the x-sections are calculated.

Regular interval only yes-no no yes, no

if yes, sections are only calculated at points at the given distance apart.
If no, extra sections are created at horizontal tangent points and horizontal IPs.

Left x-section length input 100

the plan distance for the left side of the x-section - that is, the distance that the x-section extends to the 
left of the selected string.

Right x-section length input 100

the plan distance for the right side of the x-section - that is, the distance that the x-section extends to 
the right of the selected string.

X-sections colour input default colour available colours

colour to make the x- sections

Model for x-sections input available models
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name of the model to contain the x-sections.

Start/End chainage input

the string chainage to start/end the x-sections. If blank, the start/end chainage is taken to be the 
chainage at the beginning/finish of the string.

Pick string-select

select the string to calculate the x-sections along.

Section button

calculate the x-sections along the string selected by the pick button, against the tin given in the tin 
field. The resulting x-section strings are added to the model given in the model for x-sections field.
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Sharing
shared_tins

Position of menu: Tins =>Sharing

Sharing allows tins from a project (the server project) to be added to other projects (client 
projects). 

Before any tins can be added to a client project, they must first be tagged in the server project as 
allowed to be shared.

The Sharing walk-right menu is 

For the option Share, go to “Share Tins” 
Add “Add Shared Tins” 
Remove “Remove Shared Tins” 
Synchronize “Synchronize Shared Tins” 

Share Tins
share_project_tins
Position of option on menu: Tins =>Sharing =>Share

Before tins in a server project can be added to client projects, the tins must be made available for 
sharing in the server project by using the Share option.

Selecting Share displays the Share Project Tins panel.

allow tins in this project to used by other projects 
add a tin from another project 
remove a shared tin
updated shared tins
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The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

All the models in the project are listed in the Share Project Tins panel and if a tin has been 
tagged for Sharing, a tick will be displayed in the Share column of the grid.

Pattern

if a pattern is typed then all the tins matching the pattern will have a tick placed in the Share 
column. If * is typed then all tin are ticked for sharing.

Share grid column

tick if the tin is to be made available for sharing when the Set button is pressed.

Clicking RB on Share at the top of the column brings up a menu to Toggle the ticks, Set all 
the ticks on, Clear to turn all the ticks off.

Tin grid column

this column lists all the tins in the project

Set button

clicking Set tags all the tins with a tick in the Tick column as being available for sharing. 
Those tins without a tick will not be available for sharing.

Add Shared Tins
add_shared_tins_to_project
Position of option on menu: Tins =>Sharing =>Add

The Add option is used to add shared tins (from a server project) to this project (a client project).

Selecting Add displays the Add Shared Tins to Project panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder folder box select folder

folder to look for 12d Model projects. When a folder is selected, all the 12d Model projects in 
the folder will be displayed in a Projects pop-up list.

Project folder box select folder

12d Model project to search for tins that can be shared.

Search and Replace section:

Match sub strings tick box

if tick, the Search expression is used to match against part of each tin name.
If not tick, the Search expression is used to match against the entire tin name.

Pattern expressions or Regular expressions can be used to create New Tin Names when 
a shared tin is added to the project

Search - type in the expression
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Replace - type in the expression to replace the Search expression.

Copy tick boxes in grid column

if tick, the tin will be added to the project when the Add button is pressed.

Clicking RB on Copy at the top of the column brings up a menu to Toggle the ticks, Set all 
the ticks on, Clear to turn all the ticks off.

Note - a shared tin that has been previously added can only be removed by using the Tins 
=>Sharing =>Remove option. 

Original Tin Name grid column

this column lists all the tins in the server project that are available for adding to this client 
project.

New Tin Name grid column

if non blank, the name to use instead of the Original Tin Name when the tin is added t the 
project.
If blank, the Original Tin Name is used for the tin when it is added to the project.

Model for Tin grid column

if non blank, the model name to use in the client project for this tin added to the project
If blank, the model name is the same as that in the server project.

Status output grid column

displays if there is a match or no match when a pattern or regular expression is used

Add button

clicking Add adds all the tins with a tick to this project (a client project).

Refresh button

clicking Refresh refreshes the list of all tins available for sharing in the selected 12d Model 
project (server project).
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Remove Shared Tins
remove_shared_tins_from_project
Position of option on menu: Tins =>Sharing =>Remove

The Remove option is used to remove shared tins from the.project. The shared tins would have 
been previously added to the project with the Tins =>Sharing =>Add option.

Selecting Remove displays the Remove Shared Tins from Project panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Search and Replace section:

Match sub strings tick box

if tick, the Search expression is used to match against part of each tin name.
If not tick, the Search expression is used to match against the entire tin name.

Pattern expressions or Regular expressions can be used to select and tick shared tin.

Remove tick boxes in grid column

if tick, the tin will be removed from the project when the Remove button is pressed.
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Clicking RB on Copy at the top of the column brings up a menu to Toggle the ticks, Set all 
the ticks on, Clear to turn all the ticks off.

Tin Name grid column

this column lists all the tins in this project that have been added from other (server) projects

Ref path

this column lists the full path name to the server project and the original tin name in the server 
project

Remove button

clicking Remove removes all the tins with a tick from this project (a client project).

Refresh button

clicking Refresh refreshes the list of all shared tins previously added to the project
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Synchronize Shared Tins
synchronize_shared_tins
Position of option on menu: Tins =>Sharing =>Synchronize

The Synchronize option is used to updated any added shared tins. The shared tins would have 
been previously added to the project with the Tins =>Sharing =>Add option.

Three environment variables control the synchronization of updates of added shared models 
and tins. For more information on synchronizing, go to the section “Share Settings” .

Selecting Synchronize displays the Synchronize Shared Tins panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Synchronize tick boxes in grid column

if tick and the tin has changed in the server project, then it will be re-copied from the server 
project when the Synchronize button is pressed.

Clicking RB on Copy at the top of the column brings up a menu to Toggle the ticks, Set all 
the ticks on, Clear to turn all the ticks off.

Tin grid column

this column lists all the tins in this project that have been added from other (server) projects

Synchronize button

clicking Synchronize re-copies any tins with a tick from the server projects

Refresh button

clicking Refresh refreshes the list of all shared tins previously added to the project
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Delete
tin_deletes

Position of menu: Tins =>Delete

The delete option is used to delete tins from the project and from the computer disk so that they 
no longer can be accessed or take up disk space.

To help protect against disasters, a yes-no pop-up menu is used to confirm that the user did 
intend deleting the tin. If deletion is confirmed, the selected tin is removed from the project (if its 
in the project) and deleted from the disk.

The tin Deletes walk-right menu is 

For the option Delete a tin, please go to the section “Delete a Tin” .
Delete all tins “Delete All” .

Delete a Tin
delete_tin

Position of option on menu: Tins =>Delete =>Delete a tin

The delete a tin option can be used to delete a tin in the project.

On selecting the delete a tin option, the delete tin panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input project tins

name of the tin to be deleted from the computer disk.

Delete tin models if empty tick box

if tick then the models containing the tin are also deleted if they are empty after the tin is deleted.

Delete button

after selecting this button, the tin given in the tin field will be deleted from the computer disk. A yes-no 
pop-up is used to confirm that deletion is required.

Delete All
delete_all_tins

Position of option on menu: Tins =>Delete =>Delete all tins
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The delete all option will delete all tins in the working project. It does not delete tins that are in 
the working project area but not yet added to the project.

On selecting the delete all option, the delete all tins panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Delete tin models if empty tick box

if tick then the models containing the tins are also deleted if they are empty after the tins are deleted.

Delete button

after selecting this button, a yes-no pop-up is used to confirm that deletion is required. If it is, all tins 
in the working project will be deleted from disk. Unless an error occurs, the panel will be removed.
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16  Survey
survey
Position of menu: Survey

The Survey walk-right menu is laid out to reflect the normal sequence of operations when 
handling field survey data.

The description of the options on the Survey menu assumes that the reader is familiar with 
surveying, the 12d Model method of field coding for their particular data collector, data collector 
definitions and the 12d Model field file. A description of the 12d Model field coding and data 
collector definitions is given in the Appendix “12D Survey Guide” 

.

For the option Setup, go to the section “Setup” 
Download raw “Download Raw” 
Convert raw “Convert Raw” 
Create “Create Survey Function” 
Edit “Edit Survey Function” 
Report “Report” 
Adjustments “Adjustments” 
Conversions “Conversions” 
Geodetics “Geodetic Measures and Entry” 
Traverse Spreadsheet “Traverse Spreadsheet” 
Conformance “Conformance” 
Extras “Extras” 
Leica

create floating Survey menu
select data collector (DC)
transfer data from DC to 12d field file
convert raw data collector data to 12d field file
create 12d Survey function
edit 12d Survey function - text and graphically
report on 12d Survey function
bowditch, least squares etc.
conversion functions
Geodetic measure functions
traverse spreadsheet functions
conformance reporting options
extra survey functions - bd entry etc.
outputs for various Leica instruments
setout macros
create upload file & upload to data collectors
create field 12d file from map file
compile Field 12d code
Mick Gunter’s TP Stakeout/Setout macros
test for ADAC read
test for ADAC write

on Main menu on 12d Model menu
and floating menu
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Setout “Setout” 
Upload “Upload” 
Mapfile to Field 12d “Mapfile to Field 12d” 
Field 12d “Field 12d” 
Adac read “Read Adac XML File” 
Adac write “Create Adac XML File” 
TP Stakeout/Setout “TP Stakeout/Setout” 

Setup
survey_data_setup
Position of option on menu: Survey =>Setup

Selecting setup brings up the survey data setup panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data collector input available data collectors

name of the data collector definition used to define how to read and interpret the raw survey data file. 
The list of available data collectors definitions is given in the file pointed to by the environment variable 
DATA_COLLECTORS_4D.

A data collector definition can be created/edited edited by 

(a) clicking on the choice button at the end of the Data collector panel field and selecting [Edit] at the 
bottom of the pop-up list of defined data collectors to bring up the Survey.4d Edit/Create panel.

(b) using Project=>Browse=>Survey data collectors the create/edit the Survey.4d file.   

Please see the “Data Collector Definitions”  of Appendix “12D Survey Guide” for more information on 
setting up a data collector definition.

Station prefix input

if non-blank, the prefix to be used for any text given for new instrument stations.

Set button

store the selected data collector as being the currently selected one.

Note: Selecting [Edit] at the bottom of the pop-up list of data collectors will bring up the 
Survey.4d Create/Edit panel.
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Download Raw
survey_data_download

Position of option on menu: Survey =>Download raw

The download raw option will read data from the data collector connected to the computer’s 
serial port, save it in a file (the raw data file) and once the download is completed, automatically 
convert the raw data file into a 12d field file using the currently defined data collector. 

Hence the download option downloads data from the data recorder and creates a data collector 
raw file and an equivalent 12d field file.

Selecting download raw brings up the Survey Data Download panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Port input from configuration file

name of the computer serial port that the data collector is connected to. The default port is specified in 
the data collector configuration file. 

Data bits input from configuration file 5,6,7,8

number of bits

Baud rate input from configuration file

speed of the serial port

Stop bits input from configuration file

number of stop bits

Parity input from configuration file

parity

DTR/DSR tick from configuration file

if tick, use DTR/DSR flow control

RTS/CTS tick from configuration file

if tick, use RTS/CTS flow control
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XON/XOFF tick from configuration file

if tick, use Xon/Xoff

ACK/NAK tick from configuration file

if tick, use ACK/NAK

12d Field file input *.fld files

name of the 12d field file that the raw file is to be converted to. The raw file is given the same name but 
with the extension specified in the configuration file, e.g., “.gre”.

Download button

On clicking the download button, the software will read a data stream from the serial port and store the 
raw data into a file. The extension of this file, will be specified in the configuration file. The name will 
be the same as the field file, with any “.fld” removed.

On completion of the download, the raw data file is automatically converted to a 12d field file of name 
given in the field file field.
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Convert Raw
survey_data_convert_raw

Position of option on menu: Survey =>Convert raw

The convert raw option is used to convert an existing raw data file of the type given by the data 
collector setup, into a 12d field file.

The raw data file may have been previously down loaded by 12d Model or obtained via another 
mechanism.

Selecting convert raw brings up the survey data convert raw panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Raw file input available raw files

name of the raw data file to be converted to a 12d field file. The popup will contain all files with the 
extension specified in the configuration file for raw data files, e.g. “.gre”.

Field file input *.fld files

name of the 12d field file that the raw file is to be converted to. When the raw file name is given, the file 
of the same name but with the extension .fld is automatically piped into the field file field. 

Convert button

convert the raw data given in the raw file field into the 12d field file format and save it in the file given 
in the field file field.
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Create Survey Function
create_reduction

Position of menu: Survey =>Create

The create walk-right menu contains options to create a 12d Model Survey function from either a 
12d field file or from scratch using Survey Reduction edit commands.

Basically, a Survey function keeps track of the field data, the information involved in the survey 
reduction and all the strings and models created by the Survey function. The field data for the 
Survey function can be edited and the reduction re-run and all the old reduced strings 
automatically deleted and replaced by the updated reduced strings.

The create walk-right menu is:

.

For the option Field file, go to the section “Field File” 
Typed entry “Typed Entry” 

create survey reduction function from a 12d field file - reduces data
create survey reduction function by typed entry into 12d field file.
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Field File
survey_data_reduction_function

survey_data_edit

Position of option on menu: Survey =>Create =>Field file

The field file option creates a Survey function from a 12d field file

Selecting field file brings up the survey data reduction function panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input available Survey functions

name of the 12d Survey function. If the Survey function exists, then it is loaded into the panel. If the 
Survey function does not exist, then a new Survey function is created.

Default model input available models

if a feature code is not found in the map file, or no map file is selected, the strings and points of that 
feature code will be placed in the default model. The colour used will be the default line or point colour 
for 12d Model. The default model field is compulsory. Check measurements will be always placed in the 
default model if a check model is not given (on the Advanced tab).

Report file input *.rpt

if non-blank, a log of the reduction steps, including new instrument stations, new target heights, scale 
factors, backsights and check measurements is created. Any errors are also logged.

Field Files tab
list of field files to read in

Field file input *.fld files

name of the 12d field file to be read into the function as its initial field data, and then reduced. The field 
data in the Survey function can be edited either by command or graphically.
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Attachment wildcards input

not yet used

Button at Bottom

Reduce button

On clicking the reduce button, the software converts the field measurements in the selected 12d field 
file, using coordinates from the control model if necessary, and produces super strings. The super 
strings will be assigned names and models using the name library and map file.

Map File tab

Map file input *.mf files

if non-blank, the map file is used to map feature codes to string names, models, colours, line styles, 
etc. In general, strings will be created as line strings by assigning a non-zero string number in the 
field, and strings will be created as point strings by assigning a zero string number in the field. This 
behaviour may be overridden with field codes 92, 93 and 94.

Pre*postfix for models input available models

the pre*postfix for models text is applied to all model names in the map file.

Use pt/line mapping tick

if tick and a map file is used, the column in the map file that specifies the point/line type of the string 
is be used to set the point/line type of the string.
If not tick and a map file is used, the column is ignored (not used for setting point/line type of the 
string).

Libraries tab

Name library input *.nl files

if non-blank, the name library can be used to automatically create vertex text for the string if no vertex 
text is given in the field. A name library file contains two columns separated by one or more spaces. 
The text in the first column is matched against the feature code (wild cards * and ? can be used). The 
second column contains the vertex text to use if a match occurs.

Note that if vertex text is given in the field then it is used instead of the text in the name library.

Pre-super strings: if non-blank, the name library will be used to automatically create 4d strings and to 
assign text to 4d strings. Name library files will contain two columns. The first column in the name 
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library will be matched against the feature code. Note that if a match is found, a 4d string is always 
created, as opposed to another string type. The second column will contain the text for the 4d string.

Attribute library input *.al files

if non-blank, the attribute library is used to give names to any unnamed attributes. The first word of 
each line in the file is the code to define the attribute for (can include wild cards) and the next n words 
are the names for each unnamed attributes in order. If the attribute library is mission, then the 
unnamed attributes will be given the names "unnamed attribute i" for 1=1, .... .

Advanced tab

Control model input available models

if non blank, name of the model containing instrument and backsight stations that can be referenced 
during the reduction. The name of the string is taken as the station name and if the string contains 
more than one point, the first point in the string is used for the co-ordinates of the station.

Heights model input available models

in non blank, name of the model containing points that are used for the heights of points during 
reduction. The points in the heights model have the point id of required point and a height which is 
used whenever that point id is found in the reduction. The (x,y) co-ordinates of the point are ignored.

Check model input available models

if non-blank, then all check shots will go to this model.
If blank then check shots go to the default model.

Curvature/refraction correction      tick box tick

if tick, during the reduction, each EDM tacheometry measurement (field code 7) has a correction for 
earth curvature and refraction applied to the measurement.

Job swing

if non-blank, then the job is swung through this value. The rotation is in a clockwise direction and the 
value is in hp dms format.

Use GIS post processing tick box tick

if tick, run the given 12d macro to process attribute blocks

Join strings across field files tick box tick

if tick, points with the same code and string number will be included in the same string in any of the 
field files. The order that the points are placed in the string is the order of the field files in the Field File 
tab.
If not tick, any strings will terminate at the end of a field file. Even if the string has the same name and 
string number is any following field file, a new string is started in the following field files.
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Traverse tab

Do traverse calcs tick box not tick  

if tick, the traverse coded points are placed into a network model, and an adjustment done at the time of 
reduction.

Traverse code input

if valid, this code will be used to identify traverse data. This will effectively be the same as stringing 
features in the field except the user has the option of isolating the model, adjusting the strings etc. 

E.g. TL. The reduction function will look at the field file and extract any observations involving field 
codes with the TL code. Only backsights and measurements with the point name field populated will be 
processed.

Each traverse will have a separate string number. i.e. The main traverse with a feature code/string 
number of e.g. TL7 and a side traverse having a feature code/string number of e.g. TL3. Note the string 
numbers do not have to be in any particular order. The reduction will determine the order on which the 
separate traverses will be processed (by dependencies).

Adjustment method choice bowditch, compass, 
transit, least square, none

method of adjustment. The adjustment will be made to the extracted traverse strings from known point 
to known point. If a traverse string goes through a number of known points (known 
coordinates), the adjustment will made from known point to known point rather than the 
first known to the last known point.

Network model model box  

if non blank, any valid traverse strings are placed in this model

Geodetics tab

Projection projection box current projection available projections
the projection of the data to be reduced. If a valid projection is specified, the reduction will be done 
taking into account the projection scale factors. If this method is used it is paramount that the 
known coordinates(e.g station setups) are in terms of the projection coordinates and are not 
truncated (i.e. full coordinate values). These coordinates will allow the calculation of the relative 
longitude and latitude values which are used to compute coordinates from observations from the setup 
points. For more information about how to setup different projections see the section “Projections” .
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N values choice box currently set method Available n value methods

the N value method allows the conversion of non-ellipsoid heights to ellipsoid. The methods are defined 
in the project n value settings. For more information on the n value settings see the section “N values” 

The N value will be used to convert a geoid height (e.g. AHD) into an ellipsoid height. Ellipsoid height 
= geoid height + N value. The conversion is used for the calculations only. The original z value for the 
point will remain unchanged

For more information about geodetic terminology including projections and N values, see the 
Appendix “Geodetics Summary” .

Others tab

Explode 4d strings tick box

if tick, any 4d strings created during the reduction process will have only one vertex (point), i.e., no 
stringing of 4d strings will occur.

Explode point strings tick box

if tick, point strings are created as one vertex (point) strings i.e., no stringing of any point strings will 
occur.

Use named points as measurements tick box

if tick, named points are also created as measurements.

Reprompt all

if tick, all check measurements are redisplayed on recalcs. Also if Backsight prompt mode is set to 
prompt, then backsights are redisplayed on recalcs.
if not tick, check measurements are not redisplayed on a recalc and backsights depend on the backsight 
prompt mode.

Show check measurements tick box

if tick, when a check measurement is processed a panel is displayed showing the calculated (x,y,z) for 
the check measurement.

Backsight prompt mode choice box prompt, assume yes
 assume no

if prompt, then the backsight panel is brought up in a command has not been answered adequately pre-
viously or if something has changed that warrants a redisplay of the panel.
If assume yes, then yes is assumes for all the backsights and the panel is not brought up.
If assume no, then no is assumes for all the backsights and the panel is not brought up.

Attachments tab
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Wildcards(s)

space delimited list of wildcards for attaching files to shots. For example, photo images taken in the 
field.

Tolerance (seconds) input 600

the shot must be taken first and then any files with time less than this number of seconds after the shot, 
but before any subsequent shots, are attached to the shot

Photos to plan images tick box

if tick, 12d plan images are created for ay attached image in jpeg, tiff, bmp or png format

During the reduction, the coordinates of a point may need to be supplied. This occurs when:

▲ an undefined point is named as the new instrument point (field code 3)

▲ backsight measurements are made to an undefined point (field code 4)

▲ check measurements are made to an undefined point (field code 6)

In this situation, a define station coordinate panel will pop up:

The coordinates may be typed in, or selected from existing strings. The station may also be 
added to a model to allow it to be used as a station later.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Station name output

the station name
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Use control model radio button

if ticked, the point is added to the control model.
if not ticked, the point is created but is not placed in the control model.

Easting/Northing/Height input xyz ops menu

the easting (x)/northing (y)/height (z) co-ordinates for the station.

Station prefix input

if non-blank, the created station name will be prefixed by this value.

Add to model input control model available models

if non-blank, a 4d string is created using the Easting/Northing/Height values as co-ordinates, and the 
station name (with a possible prefix) as the text and name of the 4d string. The station can then be 
referred to later in the reduction.

Pick button

pick a point whose co-ordinates are piped into the Easting/Northing/Height fields.

OK button

on selecting ok, the coordinates entered in the station xyz field are used as the station co-ordinates and 
if the add to model field is non-blank, a 4d string created. 

Edit button

on selecting Edit, the next new instrument station entry is shown which allows the station number and 
associated fields to be edited.

Cancel button

the cancel button will remove the panel and terminate the reduction.

If the Backsight prompt mode is set on, then at each backsight measurement, the bearing datum 
difference panel is displayed
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:

If yes button is selected, the bearing datum difference is applied to this horizontal circle reading.

If yes to all button is selected, the bearing datum difference is applied to all subsequent 
horizontal circle readings.

The cancel button terminates the reduction.

If no is selected, this horizontal circle reading is treated as actual bearing.

If no to all is selected, all the horizontal circle reading are treated as actual bearings.

This facility allows the horizontal circle to have any orientation during data capture.

At each check measurement, the check measurement panel is displayed giving information 
about the measurement, the point it was a check measurement for and the differences between 
the two.
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:

If the Continue button is selected, the reduction continues.

The Cancel button terminates the reduction
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 Typed Entry
survey_data_typed_entry_function

Position of option on menu: Survey =>Create =>Typed entry

The Typed entry option creates a Survey function from scratch using the edit commands.

Selecting Typed entry brings up the survey Data Typed Entry Function panel

The fields and buttons are identical to those in the Survey Data Reduction Function panel in 
the previous section “Field File” .
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Edit Survey Function
edit_reduction

Position of menu: Survey =>Edit =>Edit Reduction

The edit reduction walk-right menu contains options to create a 12d Model Survey function from 
either a 12d field file or from scratch using Survey Reduction edit commands.

Basically, a Survey function keeps track of all the information involved in the survey data 
reduction and all the strings and models created by the Survey function. The Survey function can 
be re-run and all the old information automatically deleted and replaced by the updated 
information.

Once the Survey function is created, it then reduces the data according to the information 
supplied and stored with the Survey function. As with other 12d Model functions, the Survey 
function information can be modified and the function recalculated. 

Many errors in a raw data file are only detected after the reduction has taken place These are 
then corrected and the function recalculated to re-reduce the data. 

Some of the types of problems that regularly occur during electronic field surveys are:

▲ Instrument height incorrectly entered
▲ Target height incorrectly entered
▲ Change of target height not entered
▲ Backsight station incorrectly named
▲ Instrument station incorrectly named
▲ Feature code and string number errors

The 12d Survey edits allow for all commands in the field data to be modified and new commands 
added. Selection for some edits can be done graphically (for example incorrect target height) and 
others through interactive editing of the Survey field data. In all cases, once the edit is 
completed, the effect is immediately calculated and displayed.

The edit walk-right menu is

.

Each option will now be described in detail.

For the option Function, please go to the section “Function” 
Field data “Field Data” 
Field data by string “Field Data by String” 
Coding “Coding” 
Order  “Order” 
Points  “SDR Point Edits” 
Stringing  “SDR Strings Edit” 
Target height “Target Height” 

edit 12d Survey function
edit field data for a 12d Survey function
edit 12d Survey function by selecting a string
point code correction
re-order points
graphically selected field edits for individual shots
graphically selected field edits for strings
insert and/or modify target heights
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Function
Position of option on menu: Survey =>Edit =>Function

The function option is used to edit the set-up panel values for a Survey function.

Note - to edit the field data rather than the set-up panel, the Field data option is used.

Selecting function brings up the Survey Data Reduction Function panel (which is the same 
panel used to create the function in the Survey =>Create =>Field file option).

A Survey function is selected for editing by choosing the survey function from the Function name 
pop-up list which loads up the panel information for that function.

The panel information is then modified and the new values stored and used by selecting the 
Reduce button. This recalcs the function and hence re-reduces the data using the new panel 
fields.

For more information on the fields in the panel, go to the section “Edit Survey Function” .

For information on the Survey Field Data Editor, go to the section “Survey Field Data Editor” .

Field Data
edit_survey_field_data

Position of option on menu: Survey =>Edit =>Field data

The field data option is used to edit the field data from a Survey function. As the changes are 
made, the field data is automatically reduced to reflect the changes.

Selecting Field data brings up the Edit Survey Field Data panel:
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name function box all survey functions

name of the Survey function to have the field data modified.

Edit button

clicking edit will start the Survey Field Data Editor for the given Survey function. This will be 
documented in the section Survey Field Data Editor.

For information on the Survey Field Data Editor, go to the section “Survey Field Data Editor” .

Field Data by String
edit_mtf_survey_function_data

Position of option on menu: Survey =>Edit =>Field data by string

The Field data by string option is used to edit the field data by selecting a string created from a 
Survey function. 

Selecting Field data by string brings up the Edit MTF/Survey Function Data panel:

After selecting the Pick Edit button, a string created by Survey function is selected and the 
Survey Field Data Editor is started for the given Survey function.

For information on the Survey Field Data Editor, go to the section “Survey Field Data Editor” .
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Coding
sdr_code_edits

Position of menu: Survey =>Edit =>Coding

The coding options are used to modify the feature code and/or string number of selected 
points. The 12d field file is automatically updated.

The coding walk-right menu is

.

Each option will now be described in detail.

For the option Change, go to the section “Change” 
Quick change “Quick Change” 
Quick multi-code “Quick Multi Coding” 

Change
sdr_change_code_string

Position of option on menu: Survey =>Edit =>Coding =>Change

Change is used to modify a points feature code and/or string number. When a point is selected, 
its point id, station name and target height are displayed as well as feature code and string 
number.

If either the feature code or string number is then modified in the panel, selecting the set button 
will give the selected point the new values for feature code and/or string number.

Selecting Change brings up the SDR Change Code/String panel:

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick button

select a point whose information will be displayed in the panel fields. A highlighted line joining the 
point to the station that it was surveyed from is also displayed. 

Prev button

change for feature code, string number
same of change feature code, string number for many point
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move to the previous point in the string.

Next button

move to the next point in the string.

Point id display only

point id of the selected point.

Station name display only

name of the station that the point was surveyed from.

Target height display only

height of the target when the point was surveyed.

Feature code input/output

when a point is selected, its feature code is displayed in this field. The value can then be changed by the 
user and if set is selected, the point is given the new feature code.

String number input/output

when a point is selected, its string number is displayed in this field. The value can then be changed by 
the user and if set is selected, the point is given the new string.

Same as button

after selecting same as, a point is selected and its feature code and string number are piped into the 
panel fields.

Set button

selecting set gives the selected point the values in the panel fields.

Reset button

reset undoes the changes.

Quick Change
sdr_quick_change_code_string

Position of option on menu: Survey =>Edit =>Coding =>Quick change

The quick change option is for more advanced users wishing to modify the same feature code 
and/or string number for many points.

The new feature code and/or string number is entered into the panel and whenever a point is 
selected and accepted, it is given the new feature code and/string number. The picking of points 
continues until the picking is cancelled from the pick ops menu.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Feature code input/output
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if not blank, when a point is accepted its feature code is changed to the value in this field.

String number input

if not blank, when a point is accepted its string number is changed to the value in this field.

Same as button

after selecting same as, a point is selected and its feature code and string number are piped into the 
panel fields.

Pick button

selecting pick starts the picking sequence and any accepted point will have its feature code and/or 
string number modified if the corresponding panel field is not blank. The pick is terminated by selecting 
cancel from the pick ops menu.

Quick Multi Coding
sdr_multiple_coding

Position of option on menu: Survey =>Edit =>Coding =>Quick multi-code

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick button

after selecting Pick, pick the vertex that you want to multi-code, and then pick a string and the code 
and string number from the string will be added to the selected vertex as a multi-code.

The sequence start again and continues until the pick is terminated by selecting Cancel from the Pick 
ops menu.
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Survey Field Data Editor
survey_field_data_editor

The Survey Field Data Editor is used to interactively edit the field data of a Survey function. All 
the commands in the field data can be modified or deleted, or new commands added. When 
changes are made, the field data is automatically re-reduced so the effects can be immediately 
checked.

If the Editor is opened using the Survey=>Create=>Typed Entry option the editor will appear 
blank.

For information on using things inside the panel, go to “Using the Survey Field Data Panel” 

For information on the field commands, go to “List of Field Data Commands and Panels” 

For information on the icons and buttons on the panel:

  - Insert go to “Insert  and Batch Add button” 

  - Delete “Delete” 

  - Go to “Goto” 

  - Find “Find” 

  - Find/Replace “Find/Replace” 

  - Find by Pick “Find by Pick” 

  - Toggle “Toggle” 

  - Make backsight “Make Measurement into a Backsight” 

  - Make check measurement “Make Measurement into a Check Measurement” 

  - Change to measurement “Make into a Measurement” 

  - Autopan “Autopan” 

Insert
field
command

Delete

Go to

Find

Find/Replace

Find by pick

Toggle
original
readings
on

Turn
measurement
into
backsight

Turn
measurement
into
check measurement

Turn
backsight or check
back into 
measurement

Autopan
to make selection
centre of view

Insert
many field
command
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- Batch add “Insert  and Batch Add button” 

Using the Survey Field Data Panel

Colour Coding of the Field Data
Normally data has been loaded into the Survey function by a raw data file being downloaded 
from a data collector, converted to a 12d field file and then loaded into a Survey function.

When 12d Model converts the raw file to a 12d field file, all the raw data can be included in the 
12d field file as comments.

All comments lines are displayed in green.

Each line (or lines if necessary) of raw data is converted into one or more equivalent 12d field file 
commands. These field file commands are placed straight after the commented line containing 
the raw data lines so it is easy to see what the raw data was converted to.

 The original 12d field commands converted form the raw data are displayed in black.

If a field command has been inserted, it is coloured in blue. If a comment has been inserted, it 
will still be displayed in green but the word ": added" will be appended to the end of the 
comment.

 If a field command has been modified, it is displayed in magenta.

If an original command has been deleted, the original command is left in the file but it has a 
large red cross placed on the left hand side of the line to indicate that it has been deleted. Any 
original command that has been deleted can be undeleted by simply deleting the command 
again.

Modifying the Field Data
To modify an existing command in the field data, double click on the line to be modified and the 
appropriate panel for the line of field data is displayed. The data in the panel can then be 

raw data commented

original field data
converted from the
raw data (black)

modified commands
(magenta)

deleted original field added command (blue)

(green)

Colour Coding in the Survey Field Data Editor
command (red cross)
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modified and stored by selecting either the OK or Apply buttons. The colour of the line of 
modified field data is then magenta.

For example, double clicking on target height command in the field file brings up the Target 
Height panel with the values loaded into the appropriate panel field. The data in the panel can 
be modified and saved by clicking OK.

Deleting Field Data  
To delete a line from the field data, simply highlight the data by clicking in the line and then 
delete key on the keyboard or select the delete icon from the top of the panel. If the line was an 
original command, a red cross is placed

If an original command has been deleted, the original command is left in the file but it has a 
large red cross placed on the left hand side of the line to indicate that it has been deleted. Any 
original command that has been deleted can be undeleted by simply highlighting the deleting 
command and pressing the delete icon or delete key again.

If an inserted command has been deleted, the command is removed from the field data.

More than one line can be selected for deletion by using the standing Windows selection 
commands to highlight the commands and then press the delete key on the keyboard or select 
the delete icon from the top of the panel. Similarly to undelete multiple commands.

For information on the field commands, go to “List of Field Data Commands and Panels” 

For information on the icons and buttons on the Survey Field Data panel, go to “Icons and 
Buttons on the Survey Field Data Editing Panel” 
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Icons and Buttons on the Survey Field Data Editing Panel
The use of the buttons at the bottom of the survey field data editing panel will now be described.

new_field_data_command

Insert  and Batch Add button
To insert a new command into the field data, simply click on the line where the data is to be 
inserted and press the Batch Add button or select the Insert icon from the top of the panel.

The difference between the button and the icon, is that the button allows multiple entries whilst 
the icon allows one entry at a time.

Selecting either the icon or the Batch Add button, displays the New Field Data Command panel.

By clicking on the Command choice box selector, a full list of field commands is displayed and the 
required command is selected from the list.

Clicking Create then brings up the panel for the selected command type. The description of the 
field data commands panels is given in the section“List of Field Data Commands and Panels” 

Alternatively, if the 12d Field Data Op Code is known, this can be entered into the choice box 
instead of selecting from the list. For example, to enter a Measurement EDM field data command, 
the number 7 can be inserted in the choice box field.

When using Batch Add, once a command is selected, it will remain as a default for subsequent 
entries until another type is chosen. This allows a number of the same command to be quickly 
entered such as in the case of Measurement EDM by entering data into the appropriate fields and 
continuing to press <enter> through the default choices

For a more detailed explanation on each of the fields within the panels and the appropriate field 
12d Field File Op Codes see the section “Full Description of 12d Field File Op Codes” .

For a summary of just the field file op codes, see the section “Summary of 12d Field File Op 
Codes” 

Delete  

To delete a line from the field data, highlight the data by clicking in the line and then either use 
the Delete key on the keyboard or select the Delete icon from the top of the panel.

If an original command has been deleted, the original command is left in the file but has a large 
red cross placed on the left hand side of the line to indicate that it has been deleted. Any original 
command that has been deleted can be undeleted by simply highlighting the deleted command 
and pressing the Delete icon or Delete key again.

If an inserted command has been deleted, the command is removed from the field data.

More than one line can be selected for deletion by using the standing Windows selection 
commands to highlight the commands and then press the Delete key on the keyboard or the 
Delete icon from the top of the panel. Similarly to undelete multiple commands.

Field_Data_Goto
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Goto   

Selecting the Goto icon brings up the Field Data Goto panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Line number

line number to go to

Goto button

go to the given line number

field_data_find

Find   

Selecting Find brings up the Field Data Find panel.

Each of the tabs sets the panel for the required data.

Named find given code, string number, point id etc.
Numbers find numbers between given minimum and maximum.
State find a field command in a given modification state (added, changed,

 deleted, field)
Text find text containing given text.
Type find a field command of a given type. For example "New String".

The up/down radio button define which direction to search in the field data.
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Field_Data_Find_Replace

Find/Replace   

Selecting the Find/replace icon brings up the Field Data Find/Replace panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

The user specifies the old and new Code and old and new String number fields, and the search 
and replace is done using those parameters.

The Up/Down radio button define which direction to search in the field data.

Find by Pick   

After selecting Find by pick, the user selects a point created by the Survey function and the field 
data editor will scroll to the line of the field data that created the point.

Toggle  

The toggle button allows commented information to be shown/ not shown. Simply press the 
Toggle icon to move from one state to another.

Make Measurement into a Backsight   

The Make Backsight icon is visible when a measurement line has been selected (highlighted) in 
the field data.
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When the measurement line is highlighted, clicking on the Make Backsight icon brings up the 
Backsight panel with the highlighted measurement details filled in.

The Azimuth and Backsight point fields are filled in and the OK or Apply button selected.

The original measurement will then be shown as deleted and a new Backsight record created.

Highlighting a 
Measurement 
then displays the 
Make Backsight 

and

Make Check 
Measurement 
icons
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Make Measurement into a Check Measurement   

The Make Check Measurement icon is only visible when a measurement or backsight line has 
been selected (highlighted) in the field data.

When the measurement line is highlighted, clicking on the Make Check Measurement icon brings 
up the Check Measurement panel with the details from the highlighted measurement filled in.

Highlighting a 
Measurement or 
Backsight then 
displays the Make 
Check Sight 

and

Make Check 
Measurement 
icons
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The Check point is then filled in and the OK or Apply button selected.

The original measurement will then be shown as deleted and a new Check measurement record 
created.

Note - if the Check point does not exist, a Define Station Coordinate panel is displayed for the 
user to enter the coordinates for the Check point.
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 Make into a Measurement   

The Make into a Measurement icon is visible when a backsight or check measurement line has 
been selected (highlighted) in the field data.

When the measurement line is highlighted, clicking on the Make Measurement icon brings up the 
EDM Measurement panel with the highlighted backsight or check measurement details filled in.

Highlighting a 
Backsight or 
Check 
Measurement 
then displays the 
Make 
Measurement
icon
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The String number field may need to be filled in and the OK or Apply button selected.

The original backsight or check measurement will then be shown as deleted and a new 
Measurement record created.

Autopan  

Ticked on - when a line is selected (highlighted) in the survey data editor panel, if the point is not 
visible in a plan view that the model for the data is on, the view is modified so that the selected 
point is at the centre of the view (keeping the same scale for the view).
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 List of Field Data Commands and Panels
Panel buttons
The buttons that appear on the bottom of the panels used in this section have the following 
functions.

OK - Changes field data and closes the panel

Apply - Changes the field data but keeps the panel in view

Reset - If the record was an original field record (i.e. the command was not inserted manually) 
pressing the reset button will revert the record back to the original values.

Help and Finish are standard 12d buttons.

Existing point search
Some commands such as Backsight, New instrument, Check etc. allow the user to enter existing 
point names (i.e. backsight point, Setup point and Check point) or in the case of measurements 
from a data collector, both point name and point ids. The difference between point names and point 
ids is that point names are usually specified by the user and should be a unique identifier for a 
point, whilst for that same physical point a number of measurements (and hence point ids) may 
be assigned (usually by the data collector). This may be particularly true of control station 
measurements where measurements are made to a given point name but each measurement is 
given a different point id by the data collector.

In most instances, a measurement to a point has a point id (from the data collector) and 12d 
automatically gives it the same point name as it is rare to measure a non-control point more than 
once (the point name can be over ridden by the user). 

The names allow the reduction routine to search for the details of that point (eg coordinates) to 
allow for the reduction of further measurements. The order in which this searching takes place is 
as follows:

First search the Control model (if it exists):

1. A search is made of the control model for a string whose name is the same as the specified 
point name. If a string is found, the first point of the string is used for the (x,y,z) co-ordinates.

2. A search is made of the control model for a vertex of a string whose point id is the same as the 
specified point name. If a vertex is found its (x,y,z) co-ordinates are used.

3.  If only a point id was specified, a search is made of the control model for a vertex of a string 
whose point id is the same as the specified point id. If a vertex is found its (x,y,z) co-ordinates 
are used.

Next search the already entered directly entered co-ordinates (DEC) in the field file:

4. A search is made of previously entered directly entered co-ordinates in the field file for a 
directly entered co-ordinate whose point name is the same as the specified point name. If a DEC 
is found, its (x,y,z) co-ordinates are used.

5. A search is made of previously entered directly entered co-ordinates in the field file for a 
directly entered co-ordinate whose point id is the same as the specified point name. If a DEC is 
found, its (x,y,z) co-ordinates are used.

6. A search is made of previously entered directly entered co-ordinates in the field file for a 
directly entered co-ordinate whose point id is the same as the specified point id. If a DEC is 
found, its (x,y,z) co-ordinates are used.

Next search the previous measurements in the field file:

7. A search is made of previous measurements in the field file for a measurement whose point 
name is the same as the specified point name. If a measurement is found, its (x,y,z) co-ordinates 
are used.

8. A search is made of previous measurements in the field file for a measurement whose point id 
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is the same as the specified point name. If a measurement is found, its (x,y,z) co-ordinates are 
used.

9. A search is made of previous measurements in the field file for a measurement whose point id 
is the same as the specified point id. If a measurement is found, its (x,y,z) co-ordinates are 
used.

 Finally 

10. If no match is found, the user will be prompted for the details of the previously undefined 
point. The user is asked to type in the (x,y,z) co-ordinates in the Define Station coordinate panel. 
If a model is specified in the Add to model field of the panel, then a new one point super string is 
created with the name point name, and as the vertex text for the point, the Station label prefix field value 
followed by point name

Field Data commands
The list of field commands in the pop-up from Insert or Batch Add are:

For a summary of the field file op codes see the section “Summary of 12d Field File Op Codes” 

For details on each option in the pop-up:

Arc fitting end go to “Arc Fitting” 
Arc fitting start “Arc Fitting” 
Arc through last 3 points “Arc Fitting” 
Arc through next 3 points “Arc Fitting” 

Attachment “Attachment” 

Attribute for next segment (integer) “Attributes” 
Attribute for next segment (measurement) “Attributes” 
Attribute for next segment (real) “Attributes” 
Attribute for next segment (text) “Attributes” 
Attribute for previous segment (integer) “Attributes” 
Attribute for previous segment (measurement) “Attributes” 
Attribute for previous segment (real) “Attributes” 
Attribute for previous segment (text) “Attributes” 
Attribute for string segment (integer) “Attributes” 
Attribute for string segment (measurement) “Attributes” 
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Attribute for string segment (real) “Attributes” 
Attribute for string segment (text) “Attributes” 
Attribute for vertex segment (integer) “Attributes” 
Attribute for vertex segment (measurement) “Attributes” 
Attribute for vertex segment (real) “Attributes” 
Attribute for vertex segment (text) “Attributes” 
Attribute set start) “Attributes” 
Attribute set end) “Attributes” 

Backsight “Backsight” 

Backsight reference “Backsight Reference” 

Building start “Buildings” 
Building end “Buildings” 

Check measurement “Check Measurement” 

Circle feature “Feature” 

Comment “Comment” 

Coordinate “Coordinate” 

Delta height “Height Or Depth” 

Description “Job Data” 

Distances “Coordinate” 

Error “Error” 

File end “End File” 

Invisible next segment “Invisible” 
Invisible point “Invisible” 
Invisible previous segment “Invisible” 

Join first points of strings “Strings Join” 
Join first to last point of strings “Strings Join” 
Join last points of strings “Strings Join” 
Join last to first point of strings “Strings Join” 

Measure EDM “EDM Measurement” 

Measure EDM HT “EDM Measurement (HA,HD,HT)” 

Measure EDM VD “Edm measurement (HA,HD,Diff HT)” 

Measure Stadia “Stadia Measurement” 

Multiple coding “Multiple Coding” 

New instrument “New Instrument” 

Non tinable next segment “Tinable” 
Non tinable point “Tinable” 
Non tinable previous segment “Tinable” 

Note “Note” 

Offset height “Offset Measurement” 
Offset radial “Offset Measurement” 
Offset tangential “Offset Measurement” 

Pipe axial “Pipe Justification” 
Pipe invert “Pipe Justification” 
Pipe obvert “Pipe Justification” 

Remove height “Remove Height” 

Resection start “Resection Start” 
Resection end “Resection End” 
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Scale factor “Scale Factor” 

Shape end “Shaping” 
Shape extrude “Shaping” 
Shape parallel “Shaping” 
Shape record “Shaping” 

String close “String Close” 

String end “String End” 

String rectangle “Rectangle” 

String rectangle by 2 points “Rectangle By 2 Points” 

String reverse “String Reverse” 

String start “String Start” 

String tinable “Breakline String” 

String type 2d “String Type” 
String type 3d “String Type” 
String type 4d “String Type” 

String type culvert “Culvert” 

String type pipe “Pipe Diameter” 

Target height “Target Height” 

Template change “Templating” 
Template continue “Templating” 
Template delete “Templating” 
Template end “Templating” 
Template insert “Templating” 
Template pause “Templating” 
Template record “Templating” 
Template skip “Templating” 
Template start “Templating” 

Text “Additional Text For Point” 

Units “Units” 

Vertical circle correction “Vertical Circle Correction” 

arc_fitting

Arc Fitting
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Arc mode choice box Arc through last 3 pts Arc thro last 3 pts
Arc thro next 3 pts
Start arc fitting
End arc fitting

Arc through last 3 pts

Named point is not used.

If no feature code, string number, named point or point id is given, then the current measurement 
point and the two previous points with the same feature code and string number as the current 
measurement point, are joined by an arc. If there is less than three such points, no arc is fitted.

If the feature code and string number exist, the last three previous measurement points of the same 
feature code and string number are joined by an arc. If the current measurement point has that feature 
code and string number, then it is the third of the three points used. If there is less than three points, no 
arc is fitted.

If a point id exists, then the feature code and string number are taken from the previous measurement 
point with that point id. That point and two measurement points previous to the predefined point of 
the same feature code and string number, are joined by an arc. If there is less than three points, no arc 
is fitted

Arc through next 3 pts

Named point is not used.

If no feature code, string number, named point or point id is given, an arc is inserted through the 
current measurement point and the next two measured points with the same feature code and string 
number as the current measurement point. If there is less than three points, no arc is fitted.

If a feature code, string number or point id exists, then either the feature code and/or string number 
and/or the point id section of the point description can be used. 

If the feature code or string number exist, a search is made for a previously defined measurement with 
the same feature code or string number. An arc is inserted through this previous measurement and the 
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next two measured points following this previous measurement with the same feature code and string 
number. If the current point has that feature code and string number, then it is the first of the three 
points. If there is less than three points, no arc fitted.

If the point id exists, then the feature code and string number are taken from the previous 
measurement point with that point id, and an arc is inserted through that point and the next two 
measurement points with the same feature code and string number. If there is less than three points, 
no arc is fitted

Start arc fitting

Named point is not used.

If no feature code, string number, named point or point id is given, arcs are inserted through the 
following sets of measurement points with the same feature code and string number as the current 
measurement point. The current measurement point is the first of the points.

The arcs are fitted as follows - the first arc is fitted through points one, two and three, the next arc 
through points three, four and five etc. If the current point has that feature code and string number, 
then it is the first of the points. If there is less than three points, then no arc is fitted.

If the feature code and string number exist, a search is made for a previously defined measurement 
with the same feature code or string number. An arc is inserted through the following measured points 
with the same feature code and string number as given. If the current point has that feature code and 
string number, then it is the first of the points. 

 If the point id exists, then the feature code and string number are taken from the previous 
measurement point with that point id, and arcs are inserted through that point and the following 
measured points with the same feature code and string number.

End arc fitting

Named point is not used.

If no feature code, string number, named point or point id is given, the fitting of arcs through the 
current string is stopped. The current measurement point is the last of the points used in the arc fitting.

If the feature code and string number exist, then the fitting of arcs through the points of the previous 
string with the same feature code and string number is stopped. If the current measurement point has 
that feature code and string number, then it is the last point used in the arc fitting.

 If the point id from the point description exists, then the point with that point id is the last point used 
in the arc fitting.

If 12d Model encounters an End Arcs (62) but no Start Arcs through sets of three points (61) 
command for the string, then a Start Arcs through sets of three points (61) is assumed to apply at the 
beginning of the string and hence arc fitting will be applied to the entire string.

Code

feature code. See the description of the panel field Arc mode for usage

String number

string number. See the description of the panel field Arc mode for usage

Named point

not used

Point id

point id. See the description of the panel field Arc mode for usage

Comment
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comment for the command within the field file.

OK, Apply, Reset, Finish, Help See the description for the panel buttons in the section“Panel 
buttons” 

attachment

Attachment

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File name

file to attach to the measurement

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, Help See the description for the panel buttons in the 
section“Panel buttons” 

attributes

Attributes
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mode choice box String (integer) String (integer)
String (real)
String (text)
Vertex (integer)
Vertex (real)
Vertex (text)
Next segment (integer)
Next segment (real)
Next segment (text)
Previous segment (integer)
Previous segment (real)
Previous segment (text)

String (integer)

Add an user defined integer attribute to the current string.

String (real)

Add a real (floating point) user defined attribute to the current string.

String (text)

Add a text user defined attribute to the current string.

Vertex (integer)

Add an integer user defined attribute to the current measurement point.

Vertex (real)

Add a real (floating point) user defined attribute to the current measurement point.
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Vertex (text)

Add a text user defined attribute to the current measurement point.

Next segment (integer)

Add an integer user defined attribute to the next segment from the current measurement point.

Next segment (real)

Add a real (floating point) user defined attribute to the next segment from the current measurement 
point.

Next segment (text)

Add a text user defined attribute to the next segment from the current measurement point.

Previous segment (integer)

Add an integer user defined attribute to the previous segment for the current measurement point.

Previous segment (real)

Add a real (floating point) user defined attribute to the previous segment for the current measurement 
point.

Previous segment (text)

Add a text user defined attribute to the previous segment for the current measurement point.

Name

The name of the attribute.

Value

The attribute data in the form specified by the mode.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

backsight

Backsight
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Individual backsight measurements can be entered or they can exist of pairs of Face1/Face2 
measurements. To enter a Face1/face2 measurement the backsight command should be entered twice, 
with the appropriate values entered into the panel each time.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Horizontal angle

the horizontal angle to the backsight in dd.mmss format.

Vertical angle

the vertical angle to the backsight in dd.mmss format. If the value is in the range 0 -180 degrees the 
measurement is considered a Face 1 measurement, and for measurements in the range 180-360 degrees 
they are considered Face2. 

Slope distance

the slope distance to the measurement to the backsight. If a pair of face1/face2 measurements exist, the 
mean value of the slope distance is used for reduction purposes.

Value

the azimuth to the backsight in dd.mmss format. This allows backsights to be specified by azimuth only. 
In the case of a differing azimuth and horizontal angle, a swing will be computed by the subtraction of 
the azimuth value and the horizontal angle. 
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Code

the feature code of the measurement. 

String number

the string number of the measurement.

Backsight point

point name.of the backsight point. This can be an integer, real, text or alphanumeric. For a more 
detailed description of how the reduction finds/uses the appropriate point see the section “Existing 
point search” 

Point id

point id.of the backsight point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” . If a new backsight entry is inserted into the file, this field will be non-editable since only the 
backsight point is required.

Attribute

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

backsight_reference

Backsight Reference

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Bearing swing

the angle (measured positive, clockwise from north) to swing following measurements. It is equivalent 
to the bearing datum difference. Note, this swing is only current for measurements following the 
command and for that particular station setup. It also negates any previous swings calculated from 
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backsight measurements (bearing datum difference) for that station setup. Therefore, measurements 
after the command will use the new swing value. The direction of the swing is positive in the clockwise 
direction

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

buildings

Buildings

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mode Buildings end
Buildings start

Building end

If no name exists, the current building face observation set is finished (including the current 
measurement point).

Buildings start

Start recording a field template with the given name. If name is non-blank, then the default building 
face is defined by the feature code and string number of the following measurements until a Finish 
code (111) are stored as the building face. There is no limit to the number of points in a building face.

Name 

Name has the meaning as outlined above in Building end/start definition.

Time surveyed

time when the command (op code) was created

Comment
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insert a comment within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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check_measurement

Check Measurement

Individual check measurements can be entered or they can exist of pairs of Face1/Face2 measurements. 
To enter a Face1/face2 measurement the check command should be entered twice, with the appropriate 
values entered into the panel each time.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Horizontal angle

the horizontal angle to the check point in dd.mmss format.

Vertical angle

the vertical angle to the check point in dd.mmss format. If the value is in the range 0 -180 degrees the 
measurement is considered a Face 1 measurement, and for measurements in the range 180-360 degrees 
they are considered Face2. 

Slope distance

the slope distance to the measurement to the check point. If a pair of face1/face2 measurements exist, the 
mean value of the slope distance is used for reduction purposes.

Code

the feature code of the measurement. 

String number

the string number of the measurement.
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Check point

point name.of the check point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the check point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” . If a new check point entry is inserted into the file, this field will be non-editable since only the 
check point is required.

Attribute

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

feature

Feature

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Radius

the radius of the circle to be drawn around the current measurement point.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
comment
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Comment

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Comment

insert a comment within the field file.

Time surveyed

time when the command (op code) was created

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
direct_coordinate

Coordinate
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

X coordinate double box

the x coordinate value of the nominated point.

Y coordinate double box

the y coordinate value of the nominated point.

Z coordinate double box

the z coordinate value of the nominated point.

Code

the feature code of the nominated point. 

String number

the string number of the nominated point.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
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check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Attribute

Time surveyed

time when the command (op code) was created

Comment

insert a comment within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
height_or_depth

Height Or Depth
Note - this option does not alter heights. It just adds a text comment of the given height value.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Value

value is converted to text and added to the string name as specified in the description fields.

Code, String number, Named point

Named point is not used.

If no feature code, string number, named point or point id is given, the value is added to all string 
names with the same code and string number as the current measurement. This applies to the entire 
field file.

If the feature code and string number exist, then the value is added to all string names with the same 
code and string number. This applies to the entire field file.

If the point id exists, then the value is added to all string names with the same code and string number 
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as the point defined by the point id. This applies to the entire field file.

Time surveyed

time when the command (op code) was created

Comment

insert a comment within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

job_data

Job Data

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data

extra text to be added as header information

Time surveyed

time when the command (op code) was created

Comment

insert a comment within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

error

Error
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data

extra text to be added as error information. If the field file was reduced from a raw data collector file, 
any records that can’t be parsed correctly will have an error comment.

Time surveyed

time when the command (op code) was created

Comment

insert a comment within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

end_file

End File

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Time surveyed

time when the command (op code) was created
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Comment

Stop processing the 12d field file at this line. Useful for debugging errors.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

invisible

Invisible

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tinable mode Last segment of point invisible
Next segment of point invisible

Point invisible

Make the previous segment invisible

If no description is given, the previous segment containing the current measurement point is set to 
invisible.

If a description exists, then either the feature code and string number or the point id section of the 
description can be used. 

If the feature code and string number exist, then the last segment of the previous string with that feature 
code and string number is set to invisible.

If the point id exists, then the segment containing the point with that point id as an end point, is set to 
invisible.

Make the next segment invisible

If no description is given, the next segment containing the current measurement point as a starting 
point is set to invisible. That is, it will not be treated as a breakline in triangulations.

If a description exists, then either the feature code and string number or the point id section of the 
description can be used. 
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If the feature code and string number exist, then the segment that is created in the future from the last 
point of the previous string with that feature code and string number is set to invisible.

If the point id exists, then the segment containing the point with that point id as a start point, is set to 
invisible.

Make a point invisible

If no description is given, the current measurement point is set to invisible. That is, it will not be 
included in triangulations.

If a description exists, then either the feature code and string number or the point id section of the 
description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number is set to invisible.

If the point id exists, then the point with that point id is set to invisible.

Code

the feature code of the nominated point. 

String number

the string number of the nominated point.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” .

strings_join

Strings Join
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Join mode Last points of strings
First to last points of strings
Join first points of strings
Last to first points of strings

Join last points of strings

In the final reduction, the last point of the string with the given feature code and string_number_1 is 
joined to the last point of the string with given feature code and string_number_2. The created string 
has the given feature code (no string number is needed since it is the final phase of reduction when the 
string numbers are dropped).

Join first to last point of strings

In the final reduction, the first point of the string with the given feature code and string_number_1 is 
joined to the last point of the string with given feature code and string_number_2. The created string 
has the given feature code (no string number is needed since it is the final phase of reduction when the 
string numbers are dropped).

Join first points of strings

In the final reduction, the first point of the string with the given feature code and string number 1 is 
joined to the fist point of the string with given feature code and string number 2. The created string has 
the given feature code (no string number is needed since it is the final reduction when the string 
numbers are then dropped).

Join last to first point of strings

In the final reduction, the last point of the string with the given feature code and string_number_1 is 
joined to the first point of the string with given feature code and string_number_2. The created string 
has the given feature code (no string number is needed since it is the final phase of reduction when the 
string numbers are dropped).

Code

the feature code of the strings to be joined 

String number 1

the string number of the first string
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String number 2

the string number of the second string

Time surveyed

time when the command (op code) was created

Comment

insert a comment within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
edm_measurement

EDM Measurement

Individual measurements can be entered or they can exist of pairs of Face1/Face2 measurements. To 
enter a Face1/face2 measurement the command should be entered twice, with the appropriate values 
entered into the panel each time.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Horizontal angle

the horizontal angle to the point in dd.mmss format.

Vertical angle

the vertical angle to the point in dd.mmss format. If the value is in the range 0 -180 degrees the 
measurement is considered a Face 1 measurement, and for measurements in the range 180-360 degrees 
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they are considered Face2. 

Slope distance

the slope distance to the measurement to the point. If a pair of face1/face2 measurements exist, the mean 
value of the slope distance is used for reduction purposes.

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Attribute

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
edm_measurement_HT

EDM Measurement (HA,HD,HT)
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Horizontal angle

the horizontal angle to the point in dd.mmss format.

Horizontal distance

the reduced horizontal distance.

Height

the height of the observation point.

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.
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Attribute

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

edm_measurement_VD

Edm measurement (HA,HD,Diff HT)

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Horizontal angle

the horizontal angle to the point in dd.mmss format.

Horizontal distance

the reduced horizontal distance.

Vertical distance

the change in height as measured from the collimation height of the instrument to the target point 
(usually centre of target).

Code
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the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Attribute

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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stadia_measurement

Stadia Measurement

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Horizontal angle

the horizontal angle to the point in dd.mmss format.

Vertical angle

the vertical angle to the point in dd.mmss format. 

Top

the top hair reading.

Middle

the middle hair reading.

Bottom

the bottom hair reading.

Code

the feature code of the measurement. 

String number
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the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Attribute

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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multiple_coding

Multiple Coding

A new measurement point is created at the same position as the current measurement point but with the 
feature code and string number if specified.

The point id and text are recorded as the point id and text for that vertex of the super string.

If a point name exists, then it is a named measurement and a 4d point string of name point name is 
created and mapped using the mapping file. The 4d text is the station prefix followed by point name. 
The point name is added to the internal list of named points for searching for co-ordinates.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Attribute

Time surveyed

time when the command (op code) was created
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Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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new_instrument

New Instrument

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Instrument ht

the height of the instrument setup. 

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
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required.

Easting

this field is non-editable and is populated if a valid coordinate exists for the nominated setup point.

Northing

this field is non-editable and is populated if a valid coordinate exists for the nominated setup point.

Height

this field is non-editable and is populated if a valid coordinate exists for the nominated setup point.

Attribute

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

tinable

Tinable

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tinable mode Last segment of point non-
tinable

Next segment of point non-
tinable

Point non-tinable
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Make the previous segment non-tinable

If no description is given, the previous segment containing the current measurement point is set to non-
tinable. That is, it will not be treated as a breakline in triangulations.

If a description exists, then either the feature code and string number or the point id section of the 
description can be used. 

If the feature code and string number exist, then the last segment of the previous string with that feature 
code and string number is set to non-tinable.

If the point id exists, then the segment containing the point with that point id as an end point, is set to 
non-tinable.

Make the next segment non-tinable

If no description is given, the next segment containing the current measurement point as a starting 
point is set to non-tinable. That is, it will not be treated as a breakline in triangulations.

If a description exists, then either the feature code and string number or the point id section of the 
description can be used. 

If the feature code and string number exist, then the segment that is created in the future from the last 
point of the previous string with that feature code and string number is set to non-tinable.

If the point id exists, then the segment containing the point with that point id as a start point, is set to 
non-tinable.

Make a point non-tinable

If no description is given, the current measurement point is set to non-tinable. That is, it will not be 
included in triangulations.

If a description exists, then either the feature code and string number or the point id section of the 
description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number is set to non-tinable.

If the point id exists, then the point with that point id is set to non-tinable.

Attribute

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
memo

Note
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data

extra text to be added as information in the field file.

Time surveyed

time when the command (op code) was created

Comment

insert a comment within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
offset_measurement

Offset Measurement
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Offset mode radial
tangential
height

radial

The radial offset is used to adjust the position of the specified point by a plan distance from the 
specified points original position, along the plan line joining the current station to the specified point. A 
positive offset is away from the station, negative is toward the station.

If no point description is given, the offset is used to adjust the position of the current measured point.

If a point description exists, then either the feature code and string number or the point id section of the 
point description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number is adjusted.

If the point id exists, then the point with that point id is adjusted.

tangential

The tangential offset is used to adjust the position of the specified point by a plan distance from the 
specified points original position, at rights angles to the plan line joining the current station to the 
specified point. A negative offset is to the left (looking from the station), and positive is to the right 
(looking from the station).

If no point description is given, the offset is used to adjust the position of the current measured point.

If a point description exists, then either the feature code and string number or the point id section of the 
point description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number is adjusted.
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If the point id exists, then the point with that point id is adjusted.

height

If the height of the specified point is not null, then the height offset adjusts the height of the point. A 
positive offset adds to the height, a negative offset reduces the height.

If no point description is given, the offset is used to adjust the position of the current measured point.

If a point description exists, then either the feature code and string number or the point id section of the 
point description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number is adjusted.

If the point id exists, then the point with that point id is adjusted.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

pipe_justification

Pipe Justification

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pipe mode Invert
Axial
Obvert
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Invert 

If no point description is given, the current measurement point is on the invert (bottom) of a pipe. This 
is the default for measurements to points on pipe strings. If the point is not part of a pipe string, it is 
ignored.

If the feature code and string number exist, the last point of the previous string with the same feature 
code and string number as given in point description is on the invert (bottom) of a pipe. If the point is 
not part of a pipe string, it is ignored.

If the point id exists, then the point with that point id is on the invert (bottom) of a pipe. If the point is 
not part of a pipe string, it is ignored.

Axial

If no point description is given, the current measurement point is on the axis (centre) of a pipe. If the 
point is not part of a pipe string, it is ignored.

If the feature code and string number exist, the last point of the previous string with the same feature 
code and string number as given in point description is on the axis (centre) of a pipe. If the point is not 
part of a pipe string, it is ignored.

If the point id exists, then the point with that point id is on the axis (centre) of a pipe. If the point is not 
part of a pipe string, it is ignored.

Obvert

If no point description is given, the current measurement point is on the obvert (top) of a pipe. If the 
point is not part of a pipe string, it is ignored.

If the feature code and string number exist, the last point of the previous string with the same feature 
code and string number as given in point description is on the obvert (top) of a pipe. If the point is not 
part of a pipe string, it is ignored.

If the point id exists, then the point with that point id is on the obvert (top) of a pipe. If the point is not 
part of a pipe string, it is ignored.

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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remove_height

Remove Height

If no point description is given, the height of the current measurement point is set to null.

If the feature code and string number exist, then the height of the last point of the previous string with 
that feature code and string number is set to null.

If the point id exists, then the height of the point with that point id is set to null.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.
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OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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resection_start

Resection Start
This option is under development.
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resection_end

Resection End
This option is under development.
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scale_factor

Scale Factor

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Scale factor

the scale factor to be applied to subsequent distance measurements. It is applied by multiplying raw 
distances by the scale factor to give the corrected distance.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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shaping

Shaping

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mode Shape end
Shape record
Shape extrude
Shape parallel

Shape end 

Stops using the current shape or stops recording a shape.

Shape record

Start recording a shape with the shape name. If Shape_name is non-blank, then the default field Shape 
is defined by the feature_code and string_number of the following measurements until a shape end co. 
There is no limit to the number of points in a shape.

Shape extrude

extrude the current shape along the specified super string.

Shape parallel

parallel the current shape along the specified super string. This creates a number of strings to represent 
each feature code of the shape record. In the case of shapes which contain curves, a number of strings 
will be created according to an arc/chord tolerance.

Name

the name of the shape. 

Time surveyed

time when the command (op code) was created
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Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 



12d Model Reference Manual

Page 1366 April 2007Edit Survey Function

string_close

String Close

If no point description is given, the current string is closed.

If the feature code and string number from the point description exist, the last previous string with that 
feature code and string number is closed.

If the point id from the point description exists, then the string containing that point id will be closed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.
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OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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string_end

String End

If no Description exists, the current string is terminated (including the current measurement point).

If Code (feature code) and String number exist, then the last point of the previous string with that 
feature code and string number becomes the last point of that string.

If Point id exists, then the previous string containing the point with that point id is terminated after the 
point id point

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.
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OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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rectangle

Rectangle

If no Description is given, the current measurement point and the two previous points from the current 
string are used and a fourth point is created to form a parallelogram (squashed rectangle) and the height 
of the fourth point is set to null. The string is then closed.

If the feature code and string number exist, the last three points with that feature code and string 
number are used and a fourth point is created to form a parallelogram (squashed rectangle) and the 
height of the fourth point is set to null. The string is then closed.

If the point id exists, then the feature code and string number of the point with that point id are used 
and processed as above. Note that the point with the point id is not necessarily used.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed
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time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

rectangle_by_2_points

Rectangle By 2 Points

The rectangle is defined by two points (reference side) and a offset.

If a positive offset value is given, two points will be created to the right of the reference side.

If a negative offset value is given, two points will be created to the left of the reference side.

If no Description is given, the two new points will be joined to the given points in a closed rectangular 
string, and will have the same feature code as the points given.

If the feature code and string number exist, then a search is made for the last occurrence of two points 
with the same feature code and string number. If found, then these points are used to define the 
reference side of the rectangle.

If the point id exists, then a search is made for the last occurrence of two points with the same feature 
code and string number as the point given by the point id. If found, then these points are used to define 
the reference side of the rectangle.

Two consecutive rectangles are unable to be defined side by side. In other words if the two points given 
are part of string of greater than two vertices, the command will only work for sets of two points that 
are exclusively defined. i.e. For a 5 point string, a rectangle can be defined by points 1 and 2, and 4 and 
5. 

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up



12d Model Reference Manual

Page 1372 April 2007Edit Survey Function

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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string_reverse

String Reverse

If no point description is given, the current string is reversed.

If the feature code and string number from the point description exist, the last previous string with that 
feature code and string number is reversed.

If the point id from the point description exists, then the string containing that point id will be reversed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.
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OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

string_start

String Start

If no Description is given, the current string is terminated (without including the current measurement 
point) and the current measurement point becomes the first point of a new string with the same feature 
code and string number. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number becomes the first point of a new string with the same feature code and string 
number.

If the point id exists, then the previous string containing the point with that point id is terminated before 
the point id point, and the point becomes the first point of a new string with the same feature code and 
string number.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
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check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

breakline_string

Breakline String

The point description is used to select a string and the mode is used specify if the string is a breakline or 
not.

If no point description is given, the current string is selected.

If the feature code and string number exist, the last string with that feature code and string number is 
selected.

If the point id exists, then the string containing the point with that point id is selected.

If no mode is given, the selected string is set as a point string (that is, not a breakline).

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Breakline mode not a breakline
breakline
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Not a breakline

the selected string is set to a point string and hence is not a breakline.

Breakline

the selected string is set to a line string and is therefore a breakline

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
string_type

String Type
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

String type 2d 2d
3d
4d

2d - the string has one height for the entire string
3d - the string can have different heights at each vertex
4d - the string can have different heights and text at each vertex

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
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buttons” 

culvert

Culvert

Culvert strings are always line strings and are stored with the justification of the majority of the string 
points. Individual culvert points are picked up either top (obvert), centre (axial) or bottom (invert) of 
the culvert using op codes 80, 81 and 82.

If no point_description is given, the current string is created as a culvert string with the given width and 
height. 

If a point_description exists, then either the feature code and string number or the point id section of 
the point_description can be used. 

If the feature code and string number exist, the last string with the same feature code and string number 
is created as a culvert with the given width and height.

If the point id exists, then the string containing that point id is created as a culvert string with the given 
width and height.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Width

the width of the culvert 

Height

the height of the culvert 

Code

the feature code of the measurement
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String number

the string number of the measurement

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

pipe_diameter

Pipe Diameter

Pipe strings are always line strings and are stored with the justification of the majority of the string 
points. Individual pipe points are picked up either top (obvert), centre (axial) or bottom (invert) of the 
pipe using op codes 80, 81 and 82.

If no point_description is given, the current string is created as a pipe string with the given diameter. 

If a point_description exists, then either the feature code and string number or the point id section of 
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the point_description can be used. 

If the feature code and string number exist, the last string with the same feature code and string number 
is created as a pipe with the given diameter.

If the point id exists, then the string containing that point id is created as a pipe string with the given 
diameter.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Diameter

the diameter of the pipe. 

Code

the feature code of the measurement. 

String number

the string number of the measurement.

Named point

point name.of the point. This can be an integer, real, text or alphanumeric. For a more detailed 
description of how the reduction finds/uses the appropriate point see the section “Existing point 
search” 

Point id

point id.of the point. This can be an integer, real, text or alphanumeric. For a more detailed description 
of how the reduction finds/uses the appropriate point see the section “Existing point search” . If a new 
check point entry is inserted into the file, this field will be non-editable since only the check point is 
required.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

target_height

Target Height
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Target height

target height of following measurements.

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

templating

Templating
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mode Template start
Template end
Template pause
Template continue
Template record
Template skip
Template insert
Template delete

Template start 

Start using the field template Template_name. If Template_name is blank, the default field template is 
used.
If mode is for, then the field template is used as a forward template.

rev, then the field template is used as a reverse template.
zig, then the field template is used as a zig_zag template and is used in the forward definition 

direction first (that is starts on a zig).
zag, then the template is used as a zig_zag template and is used in the reverse direction first 

(that is, starts on a zag).
If mode is blank, or anything other than for, rev, or zag then the field template is used as a zig-zag 
template starting on a zig.

Template end 

Stops using the current field template or stops recording a field template.

Template pause 

Pause using the current field template or defining a field template, until a continue field template (54) 
or a finish field template (52) code is given.

Template continue 

Continue using or defining the current field template, which has been stopped by a Pause field template 
command (53). The Continue command only needs to be given once and applies to all following 
measurements until another Pause or Finish command is given.

Template record 

Start recording a field template with the name Template_name. If Template_name is blank, then it is the 
default field template that is defined. The feature_code and string_number of the following 
measurements until a Finish code (52) are stored as the field template. There is no limit to the number 
of points in a field template.

Template skip 

Allows the user to skip picking up one or more points from the field template currently being used. The 
next measurement takes the feature_code and string_number from the next point of the field template 
definition. If num_skipped_points is missing, then only one point is skipped otherwise 
num_skipped_points are skipped.

Template insert 

Allows the user to insert new string definitions into the template. These may be new strings or multiple 
coded strings.

Template delete 

Allows the user to delete 1 or more points on the template. Picking up will use the updated template 
definition.

Time surveyed
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time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

Additional_text_for_point

Additional Text For Point

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data

The given text is added to the end of any existing text for the current measurement point. 

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 

Units

Units
This option is still under development.

vertical_circle

Vertical Circle Correction
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Vertical circle

the vertical circle (in decimal degrees) is subtracted from the vertical circle value in any 
measurements

Time surveyed

time when the command (op code) was created

Comment

comment for the command within the field file.

OK, Apply, Reset, Finish, HelpSee the description for the panel buttons in the section“Panel 
buttons” 
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Order
SDR_string_ordering

Position of menu: Survey =>Edit =>Order

This option is still under development.

The order option re-orders points in a string.

The Order walk-right menu is

.

By Points
sdr_order_string

Position of option on menu: Survey =>Edit =>Order =>by points

This option is still under development.

.

By CL
sdr_order_string_by_CL

Position of option on menu: Survey =>Edit =>Order =>by CL

This option is still under development.

.

Auto Order
sdr_auto_order_string

Position of option on menu: Survey =>Edit =>Order =>Auto order

This option is still under development.
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Remove Order
sdr_remove_order_string

Position of option on menu: Survey =>Edit =>Order =>Remove

This option is still under development.

.
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SDR Point Edits
SDR_points_edit

Position of menu: Survey =>Edit =>Points

The Points walk-right menu contains options that work on individual points (vertices).

Note - a point may be individual point (one vertex strings) or a vertex of a string.

The Points walk-right menu is:

.

For the option Additional text, go to the section “Additional Text” 
Attachment “Attach a File” 
Arc next 3 points “Arc Through Next Three Points” 
Arc last 3 points “Arc Through Last Three Points” 
Arc fitting start “Start Arc Fitting” 
Arc fitting end “End Arc Fitting” 
Circle feature “Create a Feature String” 
Invisible “Make a Vertex Invisible” 
Invisible last seg “Make the Previous Segment Invisible” 
Invisible next seg “Make the Next Segment Invisible” 
Non tinable “Make a Vertex Non Tinable” 
Non tinable last seg “Make the Previous Segment Non Tinable” 
Non tinable next seg “Make the Next Segment Non Tinable” 
Pipe invert “Make a Vertex an Invert Level of a Pipe” 
Pipe axial “Make a Vertex an Axial Level of a Pipe” 
Pipe obvert “Make a Vertex an Obvert Level of a Pipe” 
Rectangle last 3 points “Make a Parallelogram from the Last Three Points” 
Rectangle last 2 points “Make a Rectangle from the Last Two Points” 
Remove point “Delete a Vertex” 
Remove height “Set a Vertex Height to Null” 

add text to the vertex
attach an image to the vertex
put an arc through the next 3 points
put an arc through the preceding 3 points
start arc fitting
end arc fitting
make the vertex a feature
make the vertex invisible
make the last segment invisible
make the next segment invisible
make the vertex non tinable
make the last segment non tinable
make the next segment non tinable
the z-value is the invert of a pipe
the z-value is the centre of a pipe
the z-value is the overt of a pipe
make a rectangle of the last 3 points
make a rectangle of the last two points
delete a point
make the height null
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Additional Text
sdr_additional_text

Position of option on menu: Survey =>Edit =>Points =>Additional text

Additional text adds text to selected vertices. The user selects the vertex to add text to, and then 
types in the text.

Selecting Additional text brings up the SDR Additional Text panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, an Additional text typed input panel is displayed to type 
the text into. A Text code is then inserted into the 12d field file.

The option continues until the Finish button is selected.

If the pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Attach a File
sdr_attachment

Position of option on menu: Survey =>Edit =>Points =>Attachment

Attachment adds files to selected vertices. The user selects the vertex to add an attachment to, 
and then enters the name of the file to attach.

Selecting Attachment brings up the SDR Attachment panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, an Attachment file name typed input panel is displayed to 
enter the file name into. An Attachment field code is then inserted into the 12d field file.

The option continues until the Finish button is selected.

If the pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Arc Through Next Three Points
sdr_arc_next_3_points

Position of option on menu: Survey =>Edit =>Points =>Arc next 3 points

Arc next 3 points adds an arc through the selected vertex and the next two vertices of the same 
string. 
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Selecting Arc next 3 points brings up the SDR Arc Next 3 Points panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, an arc is placed through the selected vertex and the next two 
vertices of the same string by inserting an Arc through next 3 points field code.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Arc Through Last Three Points
sdr_arc_last_3_points

Position of option on menu: Survey =>Edit =>Points =>Arc last 3 points

Arc last 3 points adds an arc through the selected vertex and the previous two vertices of the 
same string.

Selecting Arc last 3 points brings up the SDR Arc Last 3 Points panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, an arc is placed through the selected vertex and the previous 
two vertices of the same string by inserting an Arc through last 3 points field code.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Start Arc Fitting
sdr_arc_fitting_start

Position of option on menu: Survey =>Edit =>Points =>Arc fitting start

Arc fitting start starts arc fitting through from the selected vertex until the end of the string or an 
stop arc fitting field code is encountered for that string.

Selecting Arc fitting start brings up the SDR Arc Fitting Start panel:
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Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, arc fitting is started at the selected vertex by inserting an 
Arc fitting start field code.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

End Arc Fitting
sdr_arc_fitting_end

Position of option on menu: Survey =>Edit =>Points =>Arc fitting end

Arc fitting end ends any arc fitting for that string at the selected vertex.

Selecting Arc fitting end brings up the SDR Arc Fitting End panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, any arc fitting for the string is stopped at the selected vertex 
by inserting an Arc fitting end field code.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Create a Feature String
sdr_feature

Position of option on menu: Survey =>Edit =>Points =>Circle feature

Circle feature creates a feature string of a given radius at the selected vertex.

Selecting Circle feature brings up the SDR Feature panel:
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Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, an Feature radius typed input panel is displayed to type the 
radius into. A Feature code is then inserted into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a Vertex Invisible
sdr_invisible_point

Position of option on menu: Survey =>Edit =>Points =>Invisible

Invisible turns the selected vertex invisible. 

Even if the segments on either side of the invisible vertex are tagged as visible, the segments can 
not be drawn because the start/end point of the segment is invisible.

Selecting Invisible brings up the SDR Invisible Point panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the vertex is turned invisible by inserting an Invisible 
Point code into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make the Previous Segment Invisible
sdr_invisible_previous_segment

Position of option on menu: Survey =>Edit =>Points =>Invisible previous segment

Invisible previous segment turns the segment ending on the selected vertex invisible. The 
vertex itself is not invisible.

Selecting Invisible previous segment brings up the SDR Invisible Previous Segment panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the segment ending on the vertex is turned invisible by 
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inserting an Invisible Previous Segment code into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make the Next Segment Invisible
sdr_invisible_next_segment

Position of option on menu: Survey =>Edit =>Points =>Invisible next segment

Invisible next segment turns the segment starting on the selected vertex invisible. The vertex 
itself is not invisible.

Selecting Invisible next segment brings up the SDR Invisible Next Segment panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the segment starting on the vertex is turned invisible by 
inserting an Invisible Next Segment code into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a Vertex Non Tinable
sdr_non_tinable_point

Position of option on menu: Survey =>Edit =>Points =>Non tinable

Non tinable sets the selected vertex to be non tinable (that is, the vertex is not included in any 
triangulation).

Even if the segments on either side of the non tinable vertex are tinable, the segments can not be 
included in any triangulation because the start/end point of the segment is non tinable.

Selecting Non tinable brings up the SDR Non Tinable Point panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the vertex is set to non tinable (that is, the vertex is not 
included in any triangulations) by inserting a Non tinable point code into the 12d field file.

The option then repeats and continues until the Finish button is selected.
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If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make the Previous Segment Non Tinable
sdr_non_tinable_previous_segment

Position of option on menu: Survey =>Edit =>Points =>Non tinable previous segment

Non tinable previous segment sets the segment ending on the selected vertex non tinable. 
That is, the segment is not included as a breakline in any tins (triangulations) The vertex itself 
can be tinable.

Selecting Non tinable previous segment brings up the SDR Non Tinable Previous Segment 
panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the segment ending on the vertex is set to non tinable by 
inserting a Non tinable previous segment code into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make the Next Segment Non Tinable
sdr_non_tinable_next_segment

Position of option on menu: Survey =>Edit =>Points =>Non tinable next segment

Non tinable next segment sets the segment starting on the selected vertex non tinable. That is, 
the segment is not included as a breakline in any tins (triangulations) The vertex itself can be 
tinable.

Selecting Non tinable next segment brings up the SDR Non Tinable Next Segment panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the segment starting on the vertex is set to non tinable by 
inserting an Non tinable next segment code into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.
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Make a Vertex an Invert Level of a Pipe
sdr_pipe_invert_justification

Position of option on menu: Survey =>Edit =>Points =>Pipe invert

Pipe invert sets the z-value of the selected vertex to be used as an invert level (pipe top) when 
the vertex is in a pipe string.

Selecting Pipe invert brings up the SDR Pipe Invert Justification panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the vertex is set to be an invert level (top of the pipe) for any 
pipe string it is in by inserting a Pipe invert code into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a Vertex an Axial Level of a Pipe
sdr_pipe_axial_justification

Position of option on menu: Survey =>Edit =>Points =>Pipe axial

Pipe axial sets the z-value of the selected vertex to be used as an axial level (pipe centre) when 
the vertex is in a pipe string.

Selecting Pipe axial brings up the SDR Pipe Axial Justification panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the vertex is set to be an axial level (centre of the pipe) for 
any pipe string it is in by inserting a Pipe axial code into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a Vertex an Obvert Level of a Pipe
sdr_pipe_obvert_justification

Position of option on menu: Survey =>Edit =>Points =>Pipe obvert

Pipe obvert sets the z-value of the selected vertex to be used as an obvert level (bottom of pipe) 
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when the vertex is in a pipe string.

Selecting Pipe obvert brings up the SDR Pipe Obvert Justification panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the vertex is set to be an obvert level (bottom of the pipe) for 
any pipe string it is in by inserting a Pipe obvert code into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a Parallelogram from the Last Three Points
sdr_rectangle

Position of option on menu: Survey =>Edit =>Points =>Rectangle last 3 points

Rectangle last 3 points creates a parallelogram (squashed rectangle) from the selected vertex 
and the previous two vertices in the same string.

Selecting Rectangle last 3 points brings up the SDR Rectangle panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, a parallelogram (squashed rectangle) is created using the 
selected vertex and the previous two vertices of the same string (three vertices in total) and creating a 
four vertex to form the parallelogram of four vertices. The three vertices are removed from the original 
string and any following vertices are used in a new string.

A String rectangle code is inserted into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a Rectangle from the Last Two Points
sdr_rectangle_by_2_points

Position of option on menu: Survey =>Edit =>Points =>Rectangle last 2 points

Rectangle last 2 points creates a rectangle from the selected vertex and the previous vertex in 
the same string, and a width supplied by the user.

The rectangle is formed by using the two vertices as the base of the rectangle and using the given 
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width as the length of the other side of the rectangle. Two new vertices are created to from the 
rectangle.

Selecting Rectangle last 2 points brings up the SDR Rectangle by 2 Points panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, a Rectangle width type input box is displayed and filled in.

The rectangle is formed by using the two vertices as the base of the rectangle and using the given width 
as the length of the other side of the rectangle. Two new vertices are created to from the rectangle.

 The two vertices are removed from the original string and any following vertices are used in a new 
string.

A String rectangle by 2 points code is inserted into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Delete a Vertex
sdr_delete_point

Position of option on menu: Survey =>Edit =>Points =>Remove point

Remove point deleted the selected vertex.

The adjacent vertices in the string containing the deleted vertex will then be joined together.

Selecting Remove point brings up the SDR Delete Point panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the vertex deleted from the field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Set a Vertex Height to Null
sdr_remove_height

Position of option on menu: Survey =>Edit =>Points =>Remove height

Remove height sets the height of the selected vertex to null.
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Selecting Remove height brings up the SDR Remove Height panel:

Pick button

As soon as the option is selected, the Pick is active and vertices can be selected. 

Each time a vertex is picked and accepted, the height of the selected vertex is set to null by inserting a 
Remove height code into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.
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SDR Strings Edit
SDR_points_edit

Position of menu: Survey =>Edit =>Stringing

The Stringing walk-right menu contains options that work on strings rather than individual 
points.

The Stringing walk-right menu is:

.

For the option New string, go to the section “New String” 
End string “End String” 
Close “Close String” 
Join “Join Two Strings of Same Feature Code” 
Reverse “Reverse String Direction” 
2d string “Make a 2d String” 
3d string “Make a 3d String” 
4d string “Make a 4d String” 
Pipe string “Make a Pipe String” 
Culvert string “Make a Culvert String” 

New String
sdr_start_new_string

Position of option on menu: Survey =>Edit =>Stringing =>New string

New string corrects the problem of not changing string numbers which creates the error of the 
last point of one string being joined to the first point of what should have been the next string. 
Hence there is a link between the two points that should not exist.

With new string, the user selects the incorrect link and a new string command is inserted into the 
12d field file which removes the link by starting a new string at the end point of the link.

Selecting New string brings up the SDR Start New String panel:

Pick button

As soon as the option is selected, the Pick is active and string links can be selected. If the pick is 

start a new string
end a string
close a string
join two strings
reverse a string
make a string 2d
make a string 3d
make a string 4d
make a string a pipe
make a string a culvert
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cancelled for some reason, the Pick button can be used to restart the option.

Each time a string segment is picked and accepted, a string start command is inserted into the 12d 
field file which removes the link by starting a new string at the end point of the link.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

End String
sdr_end_string

Position of option on menu: Survey =>Edit =>Stringing =>End string

End string corrects the problem of not changing string numbers which creates the error of the 
last point of one string being joined to the first point of what should have been the next string. 
Hence there is a link between the two points that should not exist.

With end string, the user selects the incorrect link and a end string command is inserted into the 
12d field file which removes the link by starting a new string at the end point of the link.

Selecting End string brings up the SDR End String panel:

Pick button

As soon as the option is selected, the Pick is active and string links can be selected. If the pick is 
cancelled for some reason, the Pick button can be used to restart the option.

Each time a string segment is picked and accepted, an string end command is inserted into the 12d 
field file which removes the link by starting a new string at the end point of the link.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Close String
sdr_close_string

Position of option on menu: Survey =>Edit =>Stringing =>Close

With Close, the user selects any part of the string to be closed and a close string command is 
inserted into the 12d field file.

Selecting Close brings up the SDR Close String panel:

Pick button

As soon as the option is selected, the Pick is active and string can be selected. If the pick is cancelled for 
some reason, the Pick button can be used to restart the option.
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Each time a string is picked and accepted, a string close command is inserted in the 12d field file 
which closes the selected string.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Join Two Strings of Same Feature Code
sdr_join_strings

Position of option on menu: Survey =>Edit =>Stringing =>Join

With Join, the two strings of the same name (code) are selected with direction and the strings are 
joined by inserting the appropriate join string command in the 12d field file.

Selecting Join brings up the SDR Join Strings panel:

Pick button

As soon as the option is selected, the Pick is active and string can be selected. If the pick is cancelled for 
some reason, the Pick button can be used to restart the option.

Each time two strings of the same name (code) are picked with direction, the appropriate join string 
field code (Join first points of strings, Join first to last point of strings, Join last points of 
strings, Join last to first point of strings) is inserted into the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Reverse String Direction
sdr_reverse_string

Position of option on menu: Survey =>Edit =>Stringing =>Reverse

With Reverse, the selected strings is reversed by inserting the String reverse command into the 
12d field file.

Selecting Reverse brings up the SDR Reverse String panel:

Pick button

As soon as the option is selected, the Pick is active and string can be selected. If the pick is cancelled for 
some reason, the Pick button can be used to restart the option.

Each time a string is selected, a String reverse field code is inserted into the 12d field file.

The option then repeats and continues until the Finish button is selected.
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If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a 2d String
sdr_string_type_2d

Position of option on menu: Survey =>Edit =>Stringing =>2d string

With 2d string the user selects any vertex of a string and a string type 2d command is then 
inserted into the 12d field file.

Selecting 2d string brings up the SDR String Type 2d panel:

Pick button

As soon as the option is selected, the Pick is active and string can be selected. If the pick is cancelled for 
some reason, the Pick button can be used to restart the option.

Each time a string is picked and accepted, a String type 2d command is inserted in the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a 3d String
sdr_string_type_3d

Position of option on menu: Survey =>Edit =>Stringing =>3d string

With 3d string the user selects any vertex of a string and a string type 3d command is then 
inserted into the 12d field file.

Selecting 3d string brings up the SDR String Type 3d panel:

Pick button

As soon as the option is selected, the Pick is active and string can be selected. If the pick is cancelled for 
some reason, the Pick button can be used to restart the option.

Each time a string is picked and accepted, a String type 3d command is inserted in the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a 4d String
sdr_string_type_4d
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Position of option on menu: Survey =>Edit =>Stringing =>4d string

With 4d string the user selects any vertex of a string and a string type 4d command is then 
inserted into the 12d field file.

Selecting 4d string brings up the SDR String Type 4d panel:

Pick button

As soon as the option is selected, the Pick is active and string can be selected. If the pick is cancelled for 
some reason, the Pick button can be used to restart the option.

Each time a string is picked and accepted, a String type 4d command is inserted in the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a Pipe String
sdr_pipe_diameter

Position of option on menu: Survey =>Edit =>Stringing =>Pipe string

With Pipe string, the user selects any vertex of a string, gives a pipe diameter and then a string 
type pipe command is inserted into the 12d field file.

Selecting Pipe string brings up the SDR Pipe Diameter panel:

Pick button

As soon as the option is selected, the Pick is active and string can be selected. If the pick is cancelled for 
some reason, the Pick button can be used to restart the option.

Each time a string is picked and accepted, a Pipe diameter text input is displayed and after a value is 
typed in, a String type pipe command is inserted in the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.

Make a Culvert String
sdr_culvert

Position of option on menu: Survey =>Edit =>Stringing =>Culvert string

With Culvert string, the user selects any vertex of a string, gives a culvert width and height and 
then a string type culvert command is inserted into the 12d field file.

Selecting Culvert string brings up the SDR Culvert panel:
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Pick button

As soon as the option is selected, the Pick is active and string can be selected. If the pick is cancelled for 
some reason, the Pick button can be used to restart the option.

Each time a string is picked and accepted, Culvert width and Culvert height text inputs are 
displayed and after values are typed in, a String type culvert command is inserted in the 12d field file.

The option then repeats and continues until the Finish button is selected.

If the Pick is cancelled by hitting the <Esc> key or selecting Cancel from the Pick Ops menu, the 
Pick button can be used to restart the option.
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Target Height
SDR_target_edits

Position of menu: Survey =>Edit =>Target height

The Target height option is used to correct target height errors. This includes giving an incorrect 
value for a target height or forgetting to change the target height.

The Target height walk-right menu is

.

Each option will now be described in detail.

Insert Target Height
insert_target_height

Position of option on menu: Survey =>Edit =>Target height =>Insert

The insert option inserts a new target height command into the 12d field file at a user selected 
point. The user can choose whether the new target height only applied for that one point or for 
all following points until a new target height is set.

Selecting insert brings up the insert target height panel:

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Target height input/output

when a point is selected, the target height for that point is displayed. The value can then be changed by 
the user and if set is selected, the target height is modified and all affected points updated.

Just one point tick

if tick, the new target height only applied for that one point and then reverts pack to the previous target 
height.
if not tick, the new target height applies for all following points until a new target height is set.

Pick button

pick the point to insert a new target height.

Set button

selecting set inserts the new target height command into the 12d field file.

insert an new target height
change existing target height
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Change Target Height
change_target_height

Position of option on menu: Survey =>Edit =>Target height =>Change

The change option changes an existing target height to a new value.

Selecting change brings up the change target height panel:

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick button

select a point whose information will be displayed in the panel fields. A highlighted line joining the 
point to the station that it was surveyed from is also displayed. 

Prev button

move to the previous point in the string.

Next button

move to the next point in the string.

Point id display only

point id of the selected point.

Station name display only

name of the station that the point was surveyed from.

Target height input/output

when a point is selected, the target height for that point is displayed. The value can then be changed by 
the user and if set is selected, the target height is modified and all affected points updated.

Pick button

pick the point to change the target height.

Set button

selecting set changes the target height command in the 12d field file and updates affected points.

Reset button

reset undoes the changes.
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Report
survey_reduction_report

Position of option on menu: Survey =>Report

Report produces a report on the field data from a Survey function.

Selecting report brings up the survey reduction report panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input available Survey functions

name of the 12d Survey function to report on.

Report file input *.rpt

name of the file for the Survey function report.

Report button

create the Survey report.
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Adjustments
survey_adjustments

Position of menu: Survey =>Adjustments

The Adjustments walk-right menu is

.

For the option 2D Helmert, go to the section “2D Helmert” in the chapter “Utilities” 
Least squares network “Least Squares Network” 
Level network “Level Network” 
Height adjustment “Height Adjustment” 
Traverse Adjustment “Traverse Adjustment” 
Traverse Adjustment (new) “Traverse Adjustment” 

2D Helmert
Position of option on menu: Survey =>Adjustments =>2D Helmert

The 2D Helmert option performs a 2D helmert transformation on selected data. This 
transformation includes a rotation, scale and two translation parameters.

The Helmert Transformation has already been documented in the section “2D Helmert” in the 
chapter “Utilities” 

2D helmert transformation
least squares network adjustment
least squares level adjustment
adjustment of levels
traverse adjustment
traverse adjustment (new)
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Least Squares Network
least_squares_horizontal_network_adjustment

Position of option on menu: Survey =>Adjustments =>Least squares network

The Least square network option performs a least square adjustment on a set of observations 
that can be manually entered into predefined grid box columns or by reading an existing input 
file. These observations can be of the form of distances, angles, azimuths or a combination of 
these.

SelectingLeast squares network brings up the Least squares horizontal network adjustment 
panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Input file input box *.in

a pre existing .in input file can be specified. For the format of the .in file, go to “Format of the LSA .in 
File” 

Read button

on selection of the read button, if a valid .in input file has been specified, the relevant parameters will be 
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read into the grid controls.

Distance tab

The fields and buttons used in this tab have the following functions.

Field Description Type Defaults Pop-Up

S(in mm) input box

standard deviation of a single distance measurement in mm. If entered the value will be used for all 
lines in the grid. This eliminates the need to put the standard deviation on each line. 

ppm button

parts per million error. If entered the value will be used for all lines in the grid. This eliminates the need 
to put the ppm on each line. 

the grid control values can be entered using valid inputs into the various fields:

Use - if tick, the row is used in the adjustment. If not ticked then the row is ignored

From point id which represents the point from which the distance was read

To point id which represents the point to which the distance was read

Distance (horizontal) with all corrections having been made except for that of scale.

S(in mm) - if non blank, the standard deviation to use for this single distance measurement in 
millimetres. If blank, the default value in the panel field S(in mm) is used.

ppm - if non blank, the parts per million (ppm) error to use for this single distance measurement. If 
blank, the default value in the panel field Pmm is used.

Angle tab

The fields and buttons used in this tab have the following functions.

Field Description Type Defaults Pop-Up

S(in sec) input box

standard deviation for a single angle measurement in seconds of arc. If entered the value will be used 
for all lines in the grid. This eliminates the need to put the standard deviation on each line. 

the grid control values can be entered using valid inputs into the various fields. Angle input must be in 
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the form of degrees minutes and seconds in hp notation (e.g. 12.1055) 
Use - if tick, the row is used in the adjustment. If not ticked then the row is ignored

Backsight - the backsight point id is entered. 

Instrument - the point id of the instrument or observation station is entered. 

Foresight - the point id of the foresight station is entered into the Foresight column.

Angle(dms) -. the angle defined by the clockwise measurement from the backsight to foresight station 
as observed from the instrument station.Valid ranges of 0 -360 degrees.

S(in second) - if non blank, the standard deviation of the angular measurement in seconds of arc to use 
for this single angle measurement. If blank, the default value in the panel field S (in sec) is used.

Azimuth tab

The fields and buttons used in this tab have the following functions.

Field Description Type Defaults Pop-Up

S(in sec) input box

standard deviation for a single azimuth measurement in seconds of arc. If entered the value will be used 
for all lines in the grid. This eliminates the need to put the standard deviation on each line. 

the grid control values can be entered using valid inputs into the various fields. 
Use - if tick, the row is used in the adjustment. If not ticked then the row is ignored

From - the instrument station point id should be entered. 

To - the point id of the observed station is entered. 

Azimuth - the true azimuth to the observed point is entered. Azimuth input should be in the form of 
degrees minutes and seconds (e.g. 12.1055) Valid ranges of 0 -360 degrees.

S(in second) - if non blank, the standard deviation of the azimuth in seconds of arc to use for this 
single angle measurement. If blank, the default value in the panel field S (in sec) is used.

Fixed tab

the grid control values can be entered using valid inputs into the various fields. 

Use - if tick, the row is used in the adjustment. If not ticked then the row is ignored

Point name - the point id of the fixed stations 

X coord - the fixed x coordinate value is entered 

Y coord - the fixed y coordinate value is entered

Z coord - the fixed z coordinate value is entered 

Initial tab
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12d Model will try and calculate initial position for each point from the entered measurement but for 
some points this is not possible and then the user must enter an initial position.

the grid control values can be entered using valid inputs into the various fields. 
Use - if tick, the row is used in the adjustment. If not ticked then the row is ignored

Point name - the point id of a free or floating station should be entered. 

X coord - the initial x coordinate estimate is entered. 

Y coord - the initial y coordinate estimate is entered. 

Z coord - the initial z coordinate estimate is entered. 

NB. It is very important that the initial values are approximately equal to the true values. A 
solution will still be generated for rubbish values. 

Draw tab

the following values can be entered to enable the production of a user defined plot of the adjustment.   

Field Description Type Defaults Pop-Up

Name name box defined names from
names.4d file

if non-blank, the name of the new string

Model model box available models

 if non-blank, the model of the new string (including error ellipse and station symbol if specified). 

Colour colour box red available colours

 if non-blank, the colour of the new string. If blank, the original string colour is used.

Fixed station style input Station available line styles

line style of the station symbol. These will be placed at all of the fixed stations if specified. 

Fixed station size input 1

size of symbol in world units.
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Fixed station colour colour box green available colours

 if non-blank, the colour of the station symbols

Scale for error ellipses input 1000

this value will be applied to any error ellipses to enable an exaggerated view of the ellipse geometry

Symbol for given init points input 1 available line styles

line style of the given initial point symbols

Symbol for calc init points input 1 available line styles

line style of the calculated initial point symbols

Clear draw model beforehand tick box

if ticked, the draw model will be cleaned before the new strings are created

Output tab

The fields in this panel define the output parameters.

Field Description Type Defaults Pop-Up

Output file input box *.in

if non blank, an output file is produced that can be read in the future.

Report file input box *.rpt

if non blank, a report file of this name is creating giving the calculation specific parameters and result.

No. decimal places for output input box 5

the number of decimal place to use in the report

Report standard error ellipse tick box ticked

if tick, error ellipses for each new point are created

Control Model tab

Model model box

a new model or an existing model containing some control points an be entered.
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If a new model, the calculated points will placed into that control model.
 If an existing model, if there is a point in the model with the same point id as a point being calculated, 
then that rather than a new point being created, the coordinates of the existing point can be updated 
after the reduction is complete (depends on the Update existing controls points tick box).

Colour model box

colour used for control station symbol

Style linestyle box

style for control stations.

Update existing control points tick box ticked

if ticked, any existing coordinate positions from the adjustment will be updated in the given control 
model.

Update button

if pressed, the updating of changed level values in the given control model will be carried out.

The remaining fields refer to those located below the grid control

Scale factor input box project central meridian scale factor

a scale factor can be defined which will be applied to any entered distances. Final distances used in 
calculations are derived by multiplying the entered distance by the scale factor.

Add calculated initial values tick box tick

if this box is checked, then the initial values will be included in the report

Maximum number of iterations input box 10

the calculation of the adjustment can be aborted if a solution is not found after the specified number of 
iterations

Stop when coords differ... input box 0.0001

the calculation of the adjustment is stopped when the difference between successive calculations meet 
the defined tolerance

Stop when the variance increases tick box tick

if tick, the calculation of the adjustment is stopped when the variance between successive calculations 
increases

Process button

run the adjustment
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Format of the LSA .in File
The data in each line of the .in file is space delimited. That is, each piece of data on the line is 
separated by one or more spaces.

Line 1:
The layout of the data on the first line is as follows:

Example: 

63 71 0 16 35 5.00000 5.00000 15.00000 5.00000 1.00000

Next N-Stn lines:
The next N-Fix lines are control station records, followed by (N-Stn - N-Fix) station records.

The layout of the line of a station record is as follows:

Example:

1 9338 3889.23700 5341.54800

….

….

0 9712a 4007.45700 5168.68700

….

Next N-Dist lines
The next N-Dist lines are distance observation records.

The layout of the line of a distance observation record is as follows:

 
Position Description Variable Type 
1 Number of distance observations N-Dist Integer 
2 Number of angle observations N-Ang Integer 
3 Number of true azimuth observations N-Azi Integer 
4 Number of control (fixed) stations N-Fix Integer 
5 Number of stations (including control stations) N-Stn Integer 
6 Distance standard deviation (positive if used) D-Std Double 
7 Distance part per million (non-negative if used) D-Ppm Double 
8 Angle standard deviation (positive if used) A-Std Double 
9 Azimuth standard deviation (positive if used) Z-Std Double 
10 Scale factor  Double 

 
Note: D-Std,  is in millimetres, A-Std and Z-Std are in seconds. 

 
Position Description Type 
1 Flag (1 if the station is used, otherwise 0) Integer 
2 Point number Text 
3 X-coord Double 
4 Y-coord Double 
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Note: * Part per million is different to D-Ppm by a factor of 1000. That is, if you want a ppm value 
of 5, the number in the file should be 0.005

Example:

1 9542 9702 100.20200 0.00300 0.00200

1 9542 9703 142.98200 -1.00000 -1.00000

0 9700 9506 72.10700 -1.00000 -1.00000

….

Next N-Ang lines
The next N-Ang lines are angle observation records.

The layout of the line of a angle observation record is as follows:

Example:

1 19206 9506 9701 174 29 20.00000 -1000.00000

….

 

Next N-Azi lines
The next N-Azi lines are true azimuth observation records.

The layout of the line of a true azimuth observation record is as follows:

 
Position Description Type 
1 Flag (1 if the observation is used, otherwise 0) Integer 
2 Start point number Text 
3 End point number Text 
4 Distance Double 
5 Standard deviation (in meter, negative if not used) Double 
6 Part per million* Double 

 
Position Description Type 
1 Flag (1 if the observation is used, otherwise 0) Integer 
2 Backsight point number  Text 
3 Instrument point number Text 
4 Foresight point number Text 
5 Degree Integer 
6 Minute Integer 
7 Second Double 
8 Standard deviation (in mm, negative if not used) Double 
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Example:

1 19206 9506 174 29 20.00000 3.00000

….

That is the end of data in the file.

 
Position Description Type 
1 Flag (1 if the observation is used, otherwise 0) Integer 
2 Backsight point number  Text 
3 Instrument point number Text 
4 Foresight point number Text 
5 Degree Integer 
6 Minute Integer 
7 Second Double 
8 Standard deviation (in mm, negative if not used) Double 
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Level Network
adjustment_of_level_nets

Position of option on menu: Survey =>Adjustments =>Level network

The level network option performs a least square adjustment on a set of level observations that 
can be manually entered into predefined grid box columns or by reading an existing input file.

Selecting Level network brings up the Adjustment of Level Nets panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Input file input box *.in

a pre existing input file can be specified. 

Read button

on selection of the read button, if a valid input file has been specified, the relevant parameters will be 
read into the grid controls.

Use weight choice box none none, distance, standard
deviation

a weighting per observation can be made according to the none, distance, and standard deviation 
choices
None - no weighting will be applied.

Distance - if the distance of the level network legs are to be used. The horizontal distance is entered 
into the weight field. eg 101.23

Standard deviation - to define a standard deviation. e.g. 0.005
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Note: The method of defining the weight should be kept consistent. i.e. one of the 3 options.

Output file input box *.in

an output file can be defined which will allow for the reading of the file in the future.

Report file *.rpt files

 a report using the nominated file name is created.

No. decimal places for out,,,input box 5

the number of decimal places for the new levels can be defined.

Observation tab

the grid control values can be entered using valid inputs into the various fields:
From point id which represents the first point of the level difference
To point id which represents the second point to which the level difference refers
Difference the difference between the levels defined by the From point and the To point. i.e. the 
difference = (to point) level - (from point) level

Benchmark tab

the grid control values can be entered using valid inputs into the various fields. 
Station. The point id of a fixed level station should be entered. 
Level. The corresponding level value of the fixed station. 

Unknown tab

the grid control values can be entered using valid inputs into the various fields. 
Station. The point id of any free or floating level stations should be entered. 
Level. The corresponding approximate level value of free or floating level station. 

 a report using the nominated file name is created.
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Control Model tab

Model model box

an existing control model can be entered so that changes to level values can be updated.

Update existing control points tick box ticked

if ticked, any new level values from the adjustment will be updated in the given control model.

Update button

if pressed, the updating of changed level values in the given control model will be carried out.
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Height Adjustment
height_adjustment

Position of option on menu: Survey =>Adjustments =>Height adjustment

The Height adjustment option adjusts the selected data using either a constant z value, a plane 
defined by parameters, a plane defined by points (least square fit) or a tin of height differences.

Selecting Height adjustment brings up the Height Adjustment panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File file box *.haf files

a filename can be specified for reading or writing a file.

Read button

if a valid file exists, the file contents can be loaded into the panel.

Write button
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if a valid name is specified, the user can write the input data to a file.

Data to adjust input

the source of the data to be adjusted is selected using the data source box. For more information on the 
data source box see “Data Source” 

Adjustment method choice box Constant Constant
Plane parameters 
Plane by points
Difference tin

the adjustment method should be selected from the list. A description of each method is given below.

Report file *.rpt files

 a report using the nominated file name is created.

Target target

the target for the adjusted data should be specified. For more information on how to use a data target 
box see the section “Data Target” 

Transform button

perform the transformation.

Constant adjustment method

Corr constant input box

the value to be added to the selected data.This method is the same as a translation in the z values only.

Plane parameters adjustment method

Corr constant input box

the value to be added to the selected data.
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Corr per unit N input box

the z value correction per unit nothing.

Corr per unit E input box

the z value correction per unit easting.

Origin point string select [same as]

the name of the string of the origin pt.

North coord input box

the northing value of the origin point.

East coord input box

the easting value of the origin point.

Plane by points adjustment method

the grid control values can be entered to build up the bench mark points from which the plane will be 
fitted to. 
Use pt. the point (bench mark point) can be included in the derivation of the parameters by selecting the 

Use pt option. If the point is not to be included, then uncheck the box.

Point. The point id of the bench mark 

Northing. The northing value of the bench mark 

Easting. The Easting value of the bench mark 

Current_Ht. The current level value of the bench mark 

Correct_Ht. The correct height in the adjusted level plane. 

Adjusted_Ht. This field shows the adjusted height after the adjustment is performed. 
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Residual. This field shows the difference between the correct height and the adjusted height. This value 
is shown after the adjustment is performed. 

The Add pt button used in this panel can be used to add points into the grid control from 
selecting points from a current view. After the button is selected, consequent selection and 
acceptance of points from the view will add the value into the grid. The Correct_Ht parameter 
will then have to be filled out by the user.

The Calculate button can be used to calculate the adjustment parameters and residuals so that 
they can be inspected before the adjustment is made.

Difference tin adjustment method

This option allows a difference tin to be specified as the adjustment reference. The selected 
points to be adjusted will be projected onto the difference tin to establish an interpolated 
adjustment value. This value is then applied to the data according to the add or subtract options. 
The fields used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Difference tin tin box available tins

the difference tin to be used to interpolate adjustment values.

Add difference tin values radio button

if the button Add difference tin values is checked the interpolated value from the difference tin will 
be added to the existing levels of the adjusted points.

Subtract difference tin values radio button

if the button Subtract difference tin values is checked the interpolated value from the difference tin 
will be subtracted from the existing levels of the adjusted points.

if Constant, a given value is subtracted from each z-value

Corr constant

 the value to be subtracted from all z-values

Origin points

 the value to be added to all z-values

if Plan parameters, a 3d-plane is defined and the z-value of the plane subtracted from any 
points

Corr constant

 z-correction at the original point
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Corr per unit N

 z-correction per unit is the North (y) direction abut the origin point

Corr per unit E

 z-correction per unit is the East (x) direction

Origin point 2d select box

 pick box for selected a pint to use for North and East coordinates about the origin point

North coordinate

East coordinate

if Constant, a given value is subtracted from each z-value

Corr constant

 the value to be subtracted from all z-values

Origin points

 the value to be added to all z-values

if Plan by points a 3d-plane is fitted using least squares adjustment to selecting points. The z-
value of the plane is then subtracted from any points.

Corr constant

 z-correction at the original point

Corr per unit N

 z-correction per unit is the North (y) direction abut the origin point

Corr per unit E

 z-correction per unit is the East (x) direction

Origin point 2d select box

 pick box for selected a pint to use for North and East coordinates about the origin point

North coordinate

East coordinate

if Difference tin, the z-value from a triangulation is added/subtracted from any points

Difference tin tin box available tins

 tin of values to be added/subtracted from the z-values of points

Add difference tin values radio button

 if on, the values of the tin are added to the selected points

Subtract difference tin values radio button

 if on, the values of the tin are subtracted to the selected points
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Traverse Adjustment
traverse_adjustment

Position of option on menu: Survey =>Adjustments =>Traverse adjustment

The traverse adjustment option performs a Bowditch, transit, compass or least square 
adjustment on a selected string. The adjustment can be for a closed string (loop) or an open 
string (non-loop).

Selecting traverse adjustment brings up the traverse adjustment panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Adjust Settings tab

Traverse type choice box loop loop, non-loop

the traverse can be a closed loop or a non loop.

Last point coord xyz

co-ordinates of the last point of the traverse. Only applicable for a non-loop traverse.

Adjustment method choice box transit transit, bowditch, 
compass, least square

method of adjustment.

Distribute angular misclose tick box unticked
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if ticked, the closing azimuth and bearing fields are enabled, allowing the entry of the values so that a 
calculation of an angular misclose can be made. i.e. angular misclose = closing azimuth - closing 
bearing.

This requires a closing observation to be recorded separately to the adjustment string chosen. 

This angular misclose can be distributed around the traverse before adjustment. The distribution 
follows standard survey practice, calculating a misclose value per setup station and then adding this 
constant to every traverse leg in a accumulative manner.

 i.e. The 1st leg angle adjusted bearing = orig bearing 1st leg + 1*misclose/setup stn. 

The 2nd leg angle adjusted bearing = orig bearing 1st leg + 2*misclose/setup stn. and so forth.

The closing observation is not taken from the traverse string to be adjusted, but by direct entry into the 
closing azimuth and bearing fields. 

Closing azimuth angle box

 The closing azimuth is the bearing as calculated from the last point (known coordinate; equal to the 
start point if a loop traverse) to the closing station (known coordinate or bearing). 

Closing bearing angle box

The closing bearing is the observation from the last traverse point to the closing station (known 
coordinate or bearing)

Tolerance (relative acc) 1:

The accuracy can be set which will be used to assess the misclose value before the adjustment is made. If 
the misclose is out of tolerance, a message box will appear notifying the user that the linear tolerance 
has not been met and prompting for further action. This may force the adjustment to continue or the 
exit of the process. 

New String Settings tab

Create new string tick box tick

if tick, a new adjusted string is created. If not tick, the selected string is adjusted.

Name name box

 if non-blank, the name of the new string. If blank, the original string name is used.

Model model box available models

 if non-blank, the model of the new string. If blank, the original string model is used.



Chapter 16  Survey

April 2007 Page 1427Adjustments

Colour colour box available colours

 if non-blank, the colour of the new string. If blank, the original string colour is used.

if the least square method is chosen the following parameters can be set in the Least Sq. Settings tab. If a 
different method is chosen the least square parameters are shown greyed out indicating that they are not 
used in the adjustment.
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Least Sq. Settings tab

Direction obs std (sec)

standard deviation of a single angular measurement in seconds of arc.

Distance obs std (mm)

standard deviation of a single distance measurement.

Distance ppm

distance error in parts per million.

This value is defined by the edm scale error which is dependant on the length of line measured (e.g. 
5ppm = 5mm error over a 1km distance)

Iterations input box 10

the calculation of the adjustment can be aborted if a solution is not found after the specified number of 
iterations.

Coords differ input box 0.0001

the calculation of the adjustment can stopped when the difference between successive calculations meet 
the defined tolerance.

Variance increase tick box ticked

the calculation of the adjustment can stopped when the variance between successive calculations 
increases

The remaining values are as follows:

Report file *.rpt files

 if non-blank, a report for the adjustment is created with this name. If non-blank, no report is created.

Partial tick box

if tick, only part of the selected string is adjusted.

Pick button

select the string to adjust.

Adjust button

perform the adjustment.
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Conversions
survey_conversions

Position of menu: Survey =>Conversions

The Conversions walk-right menu contains survey transformations for converting between most 
projections (or longitude, latitude) including Transverse Mercator, UTM etc.conversion options.

Conversions can involve the same ellipsoid or different ellipsoid. When using different 
ellipsoids, either a 7-parameter transformation or NTVT2 grids can be used to convert between 
the ellipsoids.

The Conversion walk-right menu is

.

For converting between projections using the same ellipsoid:
For the option Australian conversions, go to the section “Australian Conversions” .

Cartographic,  “Cartographic” 
NZ conversions,  “NZ Conversions” 

For converting between projections with different ellipsoids:
For the option AGD66/84<-->GDA94, go to the section “AGD66/84 <---> GDA94” .

General transformations  “General Transformations” 
IGN72<->RGNC1991,  “IGN72 <---> RGNC1991” 
NZ49<->NZ2000,  “NZ49 <---> NZ2000” 

For more information about terminology used in these sections, see the Appendix “Geodetics 
Summary” .

Australian conversions (eg zone to zone) fro the same datum
Cartographic conversion from one projection to another (same datum)
NZ conversions (eg circuit to circuit) for the same datum

AGD 66/84 <--> GDA94 conversions (AMG <-> MGA
General conversions with ellipsoid change
IGN72 <-->RGN1991 conversions
NZ49 <--> NZ2000 conversions
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Australian Conversions
Australian_conversions

Position of option on menu: Survey =>Conversions =>Australian conversions

The Australian conversions option converts data from one form (AMG/MGA, Long Lat, Global 
XYZ) to another for the same common datum (AGD66/84 or GDA94). The option also allows for 
the conversion from one zone to another for a common datum. (e.g. from zone 54 to 55 in MGA).

For converting ISG co-ordinates in the same datum, use the option

Survey =>Conversions =>Cartographic (see “Cartographic” ).

For converting between the different datums AGD66/84 and GDA94, use the option

 Survey =>Conversions =>AGD66/84 <-> GDA94 (see “AGD66/84 <---> GDA94” ).

For more information, go to the section “Converting Between AMG, ISG and MGA”  in the 
Appendix “Geodetics Summary” .

Selecting Australian conversions brings up the Australian conversions panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Datum choice box AGD66/84 AGD66/84, GDA94

either AGD66/84 or MGA94 is selected.

Input data type choice box AMG/MGA AMG/MGA, Long Lat
Global XYZ

type of the input data type.

Input Lat/Long unit choice box degrees radians, degrees,
decimal degrees

if Lat/Long was selected, the Lat-Long coords have the selected units.

Output data type choice box AMG/MGA AMG/MGA, Long Lat
Global XYZ

type of the input data type. 

Output Lat/Long unit choice box degrees radians, degrees,
decimal degrees

if Lat/Long was selected, the Lat-Long coords have the selected units.

From zone no. 49 -> 59

if AMG/MGA was selected for the input data type, the AMG/MGA zone is given is this field.

To zone no. 49 -> 59
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if AMG/MGA was selected for the output data type, the AMG/MGA zone is given is this field.

Use data source tick box tick

if tick, a data source is used to select the data to be transformed. If not tick, a given co-ordinate is 
transformed.

Data source input

if use data source is ticked, the source of data to transform. The source of the data to be adjusted is 
selected using the data source box. For more information on the data source box see “Data Source” 

Target target

if use data source in the data source is ticked, the target of the transformed data should be specified. 
The target for the data is selected using the data target box. For more information on the data target box 
see “Data Target” 

Input coordinates XYZ box

if use data source is not ticked, the co-ordinates in this field is transformed.

Output coordinates XYZ box

if use data source is not ticked, the transformed co-ordinates are displayed in this field.

Transform button

perform the transformation.
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Cartographic
cartographic

Position of option on menu: Survey =>Conversions =>Cartographic

Position of option on menu: Utilities =>A-G =>Cartographic

The Cartographic option is used to transform data based on the same datum between 

(a) two different cartographic projections (based on the same datum)

(b) longitude and latitude and a cartographic projection (based on the same datum)

(c) a cartographic projection and longitude and latitude (based on the same datum).

The datum, relates to the ellipsoid model used. This should be the same for both the to and from 
fields. i.e. a transform between data based on the ANS ellipsoid, to data based on the WGS84 
ellipsoid would be incorrect.

(a) Transforming Between Two Cartographic Projections
For the first case, the data starts in one cartographic projection and is to be transformed into 
another cartographic projection.

This is achieved by converting the data in (x,y) co-ordinates in the original projection, to 
(longitude, latitude) and then converting from (longitude, latitude) to (x,y) in the new projection.

For example, to transform from MGA zone 50 to MGA zone 51, the original data starts in MGA 
zone 50, is transformed to (longitude, latitude) and then transformed from (longitude, latitude) 
to MGA zone 51.

Note that to make the transformation, the two cartographic projection must already be defined. 
That is in the example above, the two projections MGA zone 50 and MGA zone 51 must already 
be defined.

In 12d Model, a Cartographic projection is defined by the option 

Project => Projections =>Create/edit

and is documented in the section “Create/Edit Projection” of the chapter “Projects” .

The two cartographic projection definitions for the conversion are given in the Cartographic 
panel.

(b) Transform Between Longitude-Latitude and a Cartographic Projection
For the second case, the data starts in (longitude, latitude) is to be transformed into (x,y) co-
ordinates in a cartographic projection.

For example, to transform (longitude, latitude) to MGA zone 51.

To make the transformation, the required cartographic projection must already be defined by the 
option 

Project => Projections =>Create/edit

which is documented in the section “Create/Edit Projection” of the chapter “Projects” .

Notes
1. In the southern hemisphere, the latitude values are negative. If the latitude is given as posi-

original projection new projection(longitude, latitude)

cartographic projection(longitude, latitude)
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tive rather than negative, then the option Factor can be used to multiply the latitude by -1.

2. If the information is given in (latitude, longitude) rather than the required 
(longitude, latitude), then the option Swap XY can be used to swap the order of the co-
ordinates.

(c) Transform Between a Cartographic Projection and Longitude-Latitude
For the third case, the data starts in (x,y) co-ordinates in a cartographic projection and need to be 
transformed to (longitude, latitude).

For example, to transform from MGA zone 51 to (longitude, latitude).

To make the transformation, the required cartographic projection must already be defined by the 
option 

Project => Projections =>Create/edit

which is documented in the section “Create/Edit Projection” of the chapter “Projects” .

Notes
1. In the southern hemisphere, the latitude values are negative. If a positive value for latitude is 

required, then the option Factor can be used to multiply the latitude by -1.

2. If the information is required to be given in (latitude, longitude) rather than the 
(longitude, latitude) produced by the transformation, then the option Swap XY can be used to 
swap the order of the co-ordinates.

On selecting the Cartographic option, the Cartographic panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

(longitude, latitude)cartographic projection
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data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

X/Y Coordinates to Long/Lat input available projections

if non-blank, the name of the cartographic projection to map the selected string co-ordinates into 
longitude-latitude values.
If blank, the initial co-ordinates are not transformed from (x,y) to (longitude, latitude). Hence the 
initial co-ordinates are then assumed to be in (longitude, latitude) form ready to be transformed to (x,y) 
by the transformation given in the Long/Lat to x/y coordinates field. Note that in the southern 
hemisphere, the latitude values must be given as negative.

Long/Lat to X/Y Coordinates input available projections

if non-blank, the cartographic projection to apply to the longitude-latitude values.
If blank, the co-ordinates are not transformed from (longitude, latitude) to (x,y). Hence the initial(x,y) 
co-ordinates are transformed to (longitude, latitude) by the transformation given in the x/y co-ordinates 
to Long/Lat field and then left in (longitude, latitude). Note that in the southern hemisphere, the latitude 
values are negative.

Long/Lat stored as input degrees radians
degrees

decimal 
degrees

format for the longitude and latitudes - either radians, degrees (in hp notation for degrees, minutes and 
seconds) or decimal degrees.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Transform button

transform the selected strings to longitude-latitude co-ordinates using the x/y coordinates to long/lat 
(radians) transformation, and then project those longitude-latitude co-ordinates into the new co-
ordinate system using the long/lat (radians) to x/y coordinates transformation.

Note

The Cartographic option can be used to transform just x/y coordinates to long/lat or long/lat to x/y 
coordinates by simply leaving the appropriate panel field blank. The units for longitude and 
latitude are either degrees (dms), decimal degrees or radians.
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NZ Conversions
New_Zealand_conversions

Position of option on menu: Survey =>Conversions =>NZ conversions

The NZ conversions option converts data from one form (NZMG/NZTM2000, Long Lat) to 
another for the same ellipsoid (i.e. datum NZ49 or NZ2000).

For converting between the different datums NZ 49 and NZ 2000, use the option

 Survey =>Conversions =>NZ49 <-> NZ2000 (see “NZ49 <---> NZ2000” ).

Selecting NZ conversions brings up the New Zealand Conversions panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Datum choice box NZ49 NZ49, NZ2000

either NZ49 or NZ2000 is selected.

Input data type choice box NZMG/NZTM2000NZMG. Circuit, Long Lat

type of the input data type.

Input Lat/Long unit choice box degrees radians, degrees,
decimal degrees

if Lat/Long was selected, the Lat-Long coords have the selected units.

Output data type choice box NZMG/NZTM2000NZMG. Circuit, Long Lat



Chapter 16  Survey

April 2007 Page 1437Conversions

type of the input data type.

Output Lat/Long unit choice box degrees radians, degrees,
decimal degrees

if Lat/Long was selected, the Lat-Long coords have the selected units.

From Circuit

if Circuit was selected for the input data type, the NZ Circuit is given is this field.

To Circuit

if Circuit was selected for the output data type, the NZ Circuit is given is this field.

Use data source tick box tick

if tick, a data source is used to select the data to be transformed. If not tick, a given co-ordinate is 
transformed.

Data source type Model

if use data source is ticked, the data selection type

Data source input

if use data source is ticked, the source of data to transform. The source of the data to be adjusted is 
selected using the data source box. For more information on the data source box see “Data Source” 

Target target

if use data source in the data source is ticked, the target of the transformed data should be specified. 
The target for the data is selected using the data target box. For more information on the data target box 
see “Data Target” 

Input coordinates XYZ box

if use data source is not ticked, the co-ordinates in this field is transformed.

Output coordinates XYZ box

if use data source is not ticked, the transformed co-ordinates are displayed in this field.

Transform button

perform the transformation.
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AGD66/84 <---> GDA94
agd66_84_______gda94

Position of option on menu: Survey =>Conversions =>AGD66/84 <-> GDA94

This option converts data between the two Australian Datums, AGD 66/84 and GDA 94. The 
transformation between the two datums can be by either a seven parameter similarity 
transformation for a State, or a NTv2 grid for either a State or Australia.

12d Model is GDA compliant for both the similarity transformations and NTv2 grids.

The AGD 66/84 data can be either longitude and latitude, co-ordinates in an AMG Zone or co-
ordinates in an ISG Zone.

The GDA 94 data can be either longitude and latitude, Global XYZ or co-ordinates in a MGA 
Zone.

Hence the option will converts data from AMG 66/84 or ISG 66/84 to MGA 94 and vice-versa.

For more information, go to the section “Converting Between AMG, ISG and MGA”  in the 
Appendix “Geodetics Summary” 

Selecting agd66/84 <---> gda94 brings up the agd66/84 <---> gda94 panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

AGD Settings

AGD66   AGD84 radio button

either AGD66 or AGD84 is selected.(AGD = Australian Geodetic datum)

AMG   Lat/Long ISG radio button

either AMG, Lat/Long or ISG is selected.(AMG = Australian Map Grid, ISG = Integrated Survey 
Grid). The ISG relates to the state of New South Wales

AMG Zone no. choice box 49 -> 59

if AMG was selected, the AMG zone is given is this field.

Lat/Long unit choice box degrees radians, degrees,
decimal degrees

if Lat/Long was selected, the Lat-Long coords have the selected units.

ISG Zone no. choice box ISG54/2 -> ISG56/3

if ISG was selected, the ISG zone is given is this field.

GDA Settings
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

MGA Lat/Long Global XYZ radio button

one of the three choices is selected.

MGA Zone no. choice box 49 -> 59

if MGA was selected, the MGA zone is given is this field.

Lat/Long unit choice box degrees radians, degrees,
decimal degrees

if Lat/Long was selected, the Lat-Long coordinates have the selected units.

Transformation Settings
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

AGD66/84 --> GDA94 GDA94 --> AGD66/84radio button

one of the two choices is selected.

Medium accuracy radio box tick

if tick, a seven parameter similarity transformation for the selected Australian State is used.

High accuracy radio button

if tick, the NT V2 grid shift file is used.

Select State choice box ACT, NSW,TAS, VIC

if the AGD66 datum has been selected, and the 7 parameter transformation is to be used, the seven 
parameter transformation parameters are different for each state. (i.e the states which adopted the 
AGD66 datum) By selecting the appropriate state, the corresponding values will be used.

If the AGD84 datum has been selected, the parameters used are the australian wide values and 
therefore the state selection is not appropriate.

Grid shift file file box *gsb

for high accuracy, the NTv2 grid shift files can be used.

Data Source

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Use data source tick box tick

if tick, a data source is used to select the data to be transformed. If not tick, a given co-ordinate is 
transformed.

Data source input
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if use data source is ticked, the source of data to transform. The source of the data to be adjusted is 
selected using the data source box. For more information on the data source box see “Data Source” 

Input coordinates XYZ box

if use data source is not ticked, the co-ordinates in this field is transformed.

Output coordinates XYZ box

if use data source is not ticked, the transformed co-ordinates are displayed in this field.

Transform button

perform the transformation.

Target

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Target target

if use data source in the data source is ticked, the target of the transformed data should be specified 
The target for the data is selected using the data target box. For more information on the data target box 
see “Data Target” 
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NZ49 <---> NZ2000
nz49_______nz2000

Position of option on menu: Survey =>Conversions =>NZ49 <-> NZ2000

This option converts data from the NZ 49 datum to the NZ 2000 datum and vice-versa.

The transformation between the two datums can be by either the NZ seven parameter similarity 
transformation or a NTv2 grid.

The data to be converted can be longitude and latitude, NZMG, circuits or Global XYZ.

Selecting NZ49<---> NZ2000 brings up the NZ49 <---> NZ2000 panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

NZ 49 Settings

Circuit (49) radio button

if the data in the NZ49 datum is of circuit type the circuit radio button is selected.

NZMG radio button

if the data in the NZ49 datum is of NZMG type the radio button is selected.

Lat/Long radio button

if the data in the NZ49 datum is of Lat/Long type the radio button is selected.

Global XYZ radio button

if the data in the NZ49 datum is of Global XYZ type the radio button is selected.

Circuit name choice box All NZ 1949 circuits

if Circuit (49) was selected, the specific NZ Circuit should be selected.

Lat/Long unit choice box degrees radians, degrees,
decimal degrees
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if Lat/Long was selected, the Lat-Long coords have the selected units.

NZ 2000 Settings

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Circuit (2000) radio button

if the data in the NZ2000 datum is of circuit type the circuit radio button is selected.

NZTM2000 radio button

if the data in the NZ2000 datum is of NZTM2000 type the radio button is selected.

Lat/Long radio button

if the data in the NZ2000 datum is of Lat/Long type the radio button is selected.

Global XYZ radio button

if the data in the NZ2000 datum is of Global XYZ type the radio button is selected.

Circuit name choice box All NZ 1949 circuits

if Circuit (2000) was selected, the specific NZ Circuit should be selected.

Lat/Long unit choice box degrees radians, degrees,
decimal degrees

if Lat/Long was selected, the Lat-Long coords have the selected units.

Transformation Settings
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

NZ49 --> NZ2000 NZ2000 --> NZ49radio button

the direction of the transformation is specified by the selection of one of the two choices.

Medium accuracy tick box tick

if tick, a seven parameter similarity transformation for NZ is used.

High accuracy tick box

if tick, the NT V2 grid shift file is used.

Grid shift file file box

if High accuracy is ticked, a NTv2 grid shift should be selected. A single file for New Zealand can be 
used.

Ellipsoid Height input box

this is only required if the data to be transformed contains null values and when 

1) The 7 parameter similarity transformation is used and/or

2) When either the input or output types are of Global XYZ type

An approximate ellipsoid level needs only to be +/- 100 m from the true value for most accuracy 
requirements. (An error in estimation of the ellipsoid height of a few hundred metres will introduce an 
error in the transformed horizontal position in the order of millimetres only).

Data Source
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Use data source tick box tick

if tick, a data source is used to select the data to be transformed. If not tick, a given co-ordinate is 
transformed.

Data source input

if use data source is ticked, the source of data to transform. The source of the data to be adjusted is 
selected using the data source box. For more information on the data source box see “Data Source” 

Input coordinates XYZ box

if use data source is not ticked, the co-ordinates in this field is transformed.

Output coordinates XYZ box

if use data source is not ticked, the transformed co-ordinates are displayed in this field.

Target
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Target target

if use data source in the data source is ticked, the target of the transformed data should be specified. 
The target for the data is selected using the data target box. For more information on the data target box 
see “Data Target” 

Transform button

perform the transformation.
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General Transformations
general_transformations

Position of option on menu: Survey =>Conversions =>General transformations

This option converts data between two datums (i.e. different ellipsoids).

The transformation between the two datums can be by either a seven parameter similarity 
transformation or a NTv2 grid.

The data to be converted ca be longitude and latitude, a 12d supported projection (eg TM, UTM) 
or Global XYZ.

Selecting General transformations brings up the General Transformations panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Datum A Settings, Datum B Settings

Data format choice box Global XYZ
Easting Northing
Long Lat - radians
Long Lat - degrees (dms)
Long Lat - decimal degrees

the type of data to be transformed/ transformed to.

if Easting, Northing, the data is co-ordinates in the projection defined by the Projection field.
if Long Lat - radians, the data is (longitude, latitude) with the angles given in radians.
if Long Lat - degrees (dms), the data is (long,lat) with the angles given in hp format (i.e. 
ddd.mmssss).
if Long Lat - decimal degrees, the data is (long,lat) with the angles given decimal degrees.
if Global XYZ, the data is in the Global XYZ system.
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Projection projection box defined projections

the name of the cartographic projection that the data is in.

Transformation Settings

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Datum A --> Datum B Datum B --> Datum A radio button

the direction of the transformation is specified by the selection of one of the two choices.

Medium accuracy tick box tick

if tick, a seven parameter similarity transformation is used.

High accuracy tick box

if tick, a NT V2 grid shift file is used.

Seven parameters file box available 7 param definitions

if Medium accuracy is ticked, a seven parameter similarity transformation is selected.

Grid shift file file box available gsb files

if High accuracy is ticked, a NTv2 grid shift is selected.

Ellipsoid Height input box

this is only required if the data to be transformed contains null values and when 

1) The 7 parameter similarity transformation is used and/or



12d Model Reference Manual

Page 1450 April 2007Conversions

2) When either the input or output types are of Global XYZ type

An approximate ellipsoid level needs only to be +/- 100 m from the true value for most accuracy 
requirements. (An error in estimation of the ellipsoid height of a few hundred metres will introduce an 
error in the transformed horizontal position in the order of millimetres only).

Data Source

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Use data source tick box tick

if tick, a data source is used to select the data to be transformed. If not tick, a given co-ordinate is 
transformed.

Data source input

if use data source is ticked, the source of data to transform. The source of the data to be adjusted is 
selected using the data source box. For more information on the data source box see “Data Source” 

Input coordinates XYZ box

if use data source is not ticked, the co-ordinates in this field is transformed.

Output coordinates XYZ box

if use data source is not ticked, the transformed co-ordinates are displayed in this field.



Chapter 16  Survey

April 2007 Page 1451Conversions

Target

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Target target

if use data source in the data source is ticked, the target of the transformed data should be specified. 
The target for the data is selected using the data target box. For more information on the data target box 
see “Data Target” 

Process button

perform the transformation.



12d Model Reference Manual

Page 1452 April 2007Conversions

IGN72 <---> RGNC1991
ign72_______rgnc1991

Position of option on menu: Survey =>Conversions =>IGN72 <->RGNC1991

This option converts data between the old and new datums for Noumea.

The transformation between the two datums can be by either a seven parameter similarity 
transformation or a NTv2 grid.

The data to be converted to/from can be (longitude, latitude) or (Easting, Northing).
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Geodetic Measures and Entry
geodetics_measure

Position of menu: Survey =>Geodetics

The Geodetics walk-right menu is

.

For the option Projection bearing /distance entry please continue to the section “Projection 
Bearing/Distance Entry” 

E,N calc from ellip dist, plane brg, “E,N from Ellipsoid Distance and Plane Bearing” .
Plane bearing /distance measure, “Bearing and Distance”  in the chapter “Utilities” 
Projection bearing/distance measure, “Projection Bearing and Distance Measure” 
GDA94/AGD66-84 bearing/distance measure, “GDA94/AGD66-84 Bearing and Distance 

Measure” 
Long, lat from grid coordinates,  “Longitude, Latitude from Grid Coordinates” 
GDA94/AGD66-84 Point scale factor, “GDA94/AGD66-84 Point Scale Factor” 
Non-projection to projection coordinates, “Non-Projection to Projection Coordinates” 
Projection to non-projection coordinates,  “Projection to Non-Projection Coordinates” 
Bearing/distance label, “Bearing/Distance Label” 
Projection bearing/distance label, “Bearing/Distance Label” 
Geodetic reporting, “Geodetic reporting” 
Solar reduction, “Solar Reduction” 
Star reduction, “Star Reduction” 

For more information about terminology used in these sections, see the Appendix “Geodetics 
Summary” .

Bearing distance entry for a projection
Use ellipsoid dist, plane brg to create point
Measure bearing, distance, with user input for scale
Measure plane brg, ellip dist, given projection
Bearing dist between 2 pts for GDA/AGD
Long and lat from projection (grid) co-ords
Point scale factor at a grid point for GDA/AGD
Non- projection to projection coordinate conversion
Projection to non-projection coordinate conversion
Bearing distance label for selected string/segment
Projection brg-dist label for selected string/segment
Create a report based on projection coordinates
Reduce solar observations
Reduce star observations
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Projection Bearing/Distance Entry
projection_bearing_distance_entry

Position of option on menu: Survey =>Geodetics =>Projection bearing/distance entry

The projection bearing/distance entry option allows the input of a traverse by manual input 
of projection bearings (the plane bearing) and ellipsoid distances or by selecting an existing 
string.

For each point, the projection co-ordinates are used with the projection bearing and ellipsoid 
distance from that point to calculate the projection co-ordinates for the new point taking the map 
projection into account.

Selecting Projecion bearing/distance entry brings up the Projection Bearing/Distance Entry 
panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Name name box defined names from
names.4d file

this field is optional. If non-blank, the name of the new string.

Model model box available models

 if non-blank, the model of the new string. If blank, the original string model is used.

Colour colour box red available colours

 if non-blank, the colour of the new string. If blank, the original string colour is used.
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Linestyle input 1 available line styles

line style of the string.

Projection input project projection available projections

This is the projection that is used for calculating the (Easting, Northing) values.

Use z- value tick box transit

if tick, the z-values for each point are entered.
If no tick then z-values are not entered and are not displayed in the grid.

Point id input typed none, auto increment, typed

if none, no point ids are entered and the grid control will not show a column for point ids. 

If auto increment then the values of point ids will be incremented by a value of 1 starting from the 
specified Start point id. If no Start point id is specified then no point ids will be allocated. No 
column for point ids is shown in the grid control.

if typed then the values of point ids will be incremented by a value of 1, starting from the specified 
Start point id. If no Start point id is specified then no point ids will be allocated unless a value is 
entered in the grid control on which time the next value in the grid will have a incremented value. The 
column for point ids is shown in the grid control.

VALUES IN GRID grid box

The columns shown in the grid will depend on the selection of the Use z- value and Point id fields.

To Pt. input

if none is selected for the Point id field, this column will not be displayed.

if auto increment is selected for the Point id field, this column will not be displayed.

if typed is selected for the Point id field, this column will be displayed. In this case, the point id will 
increment automatically by entering over the field. I f a new value is typed into the To Pt. field, the next 
line will increment from that number.

Proj.Brg angle box

The user should enter the projection bearing for the segment into this field. The projection bearing can 
be defined as the bearing resulting from plane geometry calculations between the two projection 
coordinates. This is sometimes called the grid bearing in some countries (e.g. New Zealand) and the 
plane bearing in others such as Australia as defined in the GDA technical manual (ICSM)).

Ellip Dist input box

the user should enter the ellipsoid distance. This distance is the measured horizontal distance that has 
been reduced onto the ellipsoid taking into account the heights above the ellipsoid at each end of the 
measured line. This reduction may be by the use of a height scale factor for example. Distances that are 
measured near mean sea level approximate the ellipsoid distance (since the MSL approximates the 
ellipsoid in many reference ellipsoids (eg AGD)). The amount of correction will be dependant on the 
length of line, the heights above the ellipsoid and the reference ellipsoid being used.

Height input box

This column will only be visible in the grid if the Use z- value tickbox has been ticked. The user should 
enter the height of the point. This value will not be used for calculation of the segment. It will simply be 
assigned to the newly created vertex.
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Select button

on pressing the select button, a user is able to pick an existing string from the current view.    If a non-
traverse type string is selected an option to convert it to a traverse string will be given. The grid 
control will be filled with the relevant information for the traverse string. 

If a traverse string has been modified by some other process (e.g. move) an option will be given to adopt 
the new characteristics of the string as displayed or revert back to the information that originally 
defined the traverse string. Depending on which option is selected, the grid will be filled with the 
relevant information. 

Process button

changes to the traverse can be made in the grid control for lines already defined. For example, a distance 
entry may be incorrectly typed in and edited some time later. By using the process button the traverse 
string is re-calculated using the current values in the grid control.
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E,N from Ellipsoid Distance and Plane Bearing
projection_coords_from_plane_brg_and_ellipsoid_dist

Position of option on menu: Survey =>Geodetics =>E,N from ellip dist, plane bearing

The E,N calc from ellip dist, plane brg option allows users to calculate projection coordinates 
given the projection, start coordinate, plane bearing and ellipsoid distance. The results are given 
inside the panel.

On selecting the E,N calc from ellip dist, plane brg option, the Projection Coords from plane 
brg and ellipsoid dist panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Projection choice current projection available projections

the projection of the data to be used. 

Easting input

the easting value of the start coordinate.

Northing input

the northing value of the start coordinate.

Select Pt button

if the point exists in a view, the coordinate can be entered by selecting the button and then on the 
required point. The selected points coordinates will be returned to the relevant coordinate boxes.

Plane bearing input

the plane bearing (or Projection brg) of the line from the nominated start coordinate. The projection 
bearing can be defined as the bearing resulting from plane geometry calculations between the two 
projection coordinates. This is sometimes called the grid bearing in some countries (e.g. New Zealand) 
and the plane bearing in others (eg Australia as defined in the GDA technical manual (ICSM)).



12d Model Reference Manual

Page 1458 April 2007Geodetic Measures and Entry

Ellipsoid distance input

the ellipsoid distance of the line from the nominated start coordinate

Easting input

the calculated easting value of the 2nd point.

Northing input

the calculated northing value of the 2nd point.

Process button

perform the calculation.

Clear button

clear the input fields

Plane Bearing and Distance Measure
Position of option on menu: Survey =>Geodetics =>Plane bearing/distance measure

Measures the plane angle and plane distance between two selected points.

This option has already been documented in section “Bearing and Distance” of chapter 
“Utilities” .
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Projection Bearing and Distance Measure
measure_projection_plane_bearing_and_ellipsoid_dist

Position of option on menu: Survey =>Geodetics =>Projection bearing/distance measure

The Projection bearing and dist option allows users to measure projection plane bearing, 
plane distance, ellipsoid distance, arc-to chord values and a line scale factor.

On selecting the Projection bearing and dist option, the Measure Projection Plane bearing 
and ellipsoid dist panel is displayed.

This panel is principally used to display the distances between, and bearing of the line joining, 
pairs of user selected points.

message area 1: point selection comment
message area 2: dx =   dy = 
message area 3: plane brg =   plane dist =   ellipsoid dist = 
message area 4: t-T fwd =   t-T rev =   l.s.f = 

where dx is the x coordinate difference between the points, dy is the y coordinate difference 
between the points

plane brg is the angle measured clockwise from north and is calculated using the coordinate 
values (Inverse value)

plane dist is the distance calculated using the coordinate values (Inverse value)

ellipsoid dist is the ellipsoid distance calculated using the specified projection and coordinate 
values.

t-T fwd is the forward arc-to chord correction.

t-T rev is the reverse arc-to chord correction.

l.s.f is the line scale factor. It is calculated by plane distance/ellipsoid distance.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mode input disjoint disjoint, continuous

In disjoint mode, only the distance between the two points and the bearing (in degrees, minutes and 
seconds) of the (imaginary) line connecting the two points are displayed. 

In continuous mode, after the initial reporting of the bearing/distance, the user is prompted to select the 
next point(2nd point). In this case the previously selected second point becomes the first point. 

Projection choice current projection available projections

message area 1

message area 2

message area 3

message area 4
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the projection of the data to be used. 

Clear button

when this button is selected, the selection sequence is re-initialised.
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GDA94/AGD66-84 Bearing and Distance Measure
measure_bearing_and_distance__gda94_agd66_84_

Position of option on menu: Survey =>Geodetics =>GDA94/AGD66-84 bearing/distance measure

The Bearing and distance (GDA94/AGD66-84) is specifically for Australian use. It allows users to 
select two AMG/MGA coordinates and return the calculated geodetic parameters.

On selecting the Bearing and distance (GDA94/AGD66-84) option, the Bearing and distance 
(GDA94/AGD66-84) panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mode input disjoint disjoint, continuous

In disjoint mode, the geodetic parameters between the two points are displayed. After the first 
calculation, further selections must include both the first and second points.

In continuous mode, after the initial reporting of the values, the user is prompted to select the next 
point(2nd point). In this case the previously selected second point becomes the first point. 

Datum choice current projection AGD66/84

GDA94

the datum of the data to be used. 
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l

Zone choice current zone 49

50
51
52
53
54
55
56
57
58
59

the zone of the data to be used.

Select N value setting
radio button selected

if the data has non-ellipsoid heights then a conversion to ellipsoid heights is available using a method 
defined in the N value interpolation method choice box.

Note: The ellipsoid height is required to calculate the values. However most level datums, 
such as AHD approximate geoid heights. Therefore, one of the selected points should at least 
have a non-null value and a means for computing a ellipsoid height. If one point has a valid 
height and the other does not, an option will be given to assume the other point has the same 
value.

Various options of converting non-ellipsoid geoid heights to ellipsoid are given by the N 
value interpolation method choice box or the user can enter N values for the first and second 
points.

N value interpolation methodchoice box currently set method Available n value methods

the N value method allows the conversion of non-ellipsoid heights to ellipsoid. The methods are define d 
in the project n value settings. For more information on the n value settings see the section “N values” 

The N value will be used to convert a geoid height (e.g. AHD) into an ellipsoid height. Ellipsoid height 
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= geoid height + N value. The conversion is used for the calculation only. The original z value for the 
point will remain unchanged

Input N values radio button unselected

if an N value is known for the area or for the selected points, it will be used to convert a geoid height 
(e.g. AHD) into an ellipsoid height. Ellipsoid height = geoid height + N value. The conversion is used 
for the calculation only. The original z value for the point will remain unchanged

1st pt N value input box

if the Input N value option is chosen, an N value is entered for the first point.

2nd pt N value input box

if the Input N value option is chosen, an N value is entered for the second point.

How to Use the Panel and Panel Messages

The results are returned to the panel in the following format:
message area 1 Messages
message area 2 plane brg =, plane dist, dx =, dy =
measure area 3 grid brg =, ellipsoid dist =, line scale factor = 
message area 4 Mean height factor =, (Plane dist/level terrain dist) scale factor =
measure area 5 Mean level terrain distance = 

Note: Mean height factor is the factor to apply to a measured horizontal distance (usually 
measured at a height above or below the ellipsoid) to reduce it down to an ellipsoid distance. 
The other geodetic values and terminology are clearly defined in the GDA technical manual. 
See http://www.anzlic.org.au/icsm/gdatm/

The cycle can then be repeated for another point by simply selecting another point without leav-
ing the option. The clear button resets the message areas.
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Longitude, Latitude from Grid Coordinates
long__lat_from_grid_coordinates

Position of option on menu: Survey =>Geodetics =>Long, lat from grid coordinates

The Longitude, latitude from grid coordinates option allows a user to calculate Longitude, latitude 
and convergence of a point, given a projection and selection of a grid coordinate.

On selecting the Longitude, latitude from grid coordinates option, the Longitude, latitude from grid 
coordinates panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Projection choice current projection available projections

the projection of the data to be used. 

The cycle can then be repeated for another point by simply selecting another point without leav-
ing the option. The clear button resets the message areas.
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GDA94/AGD66-84 Point Scale Factor
point_scale_factor__gda94_agd66_84_

Position of option on menu: Survey =>Geodetics =>GDA94/AGD66-84 point scale factor

The Point scale factor (GDA94/AGD66-84) is specifically for Australian use. It allows users to 
select AMG/MGA coordinates and return the point scale factor and latitude and longitude of the 
point.

On selecting the Point scale factor (GDA94/AGD66-84) option, the Point scale factor (GDA94/
AGD66-84) panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Datum choice current projection AGD66/84

GDA94

the datum of the data to be used. 

l

message area 1

message area 2
message area 3

message area 4
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Zone choice current zone 49

50
51
52
53
54
55
56
57
58
59

the zone of the data to be used.

Note: The ellipsoid height is required to calculate the point scale factor. However most level 
datums, such as the AHD approximate geoid heights. Therefore, selected points should at 
least have a non-null value and a means for computing a ellipsoid height. Various options of 
converting non-ellipsoid geoid heights to ellipsoid are given.

Select N value setting

radio button selected

if the data has non-ellipsoid heights then a conversion to ellipsoid heights is available using a method 
defined in the N value interpolation method choice box.

N value interpolation method choice box currently set method Available n value methods

the N value method allows the conversion of non-ellipsoid heights to ellipsoid. The methods are define d 
in the project n value settings. For more information on the n value settings see the section “N values” 

The N value will be used to convert a geoid height (e.g. AHD) into an ellipsoid height. Ellipsoid height 
= geoid height + N value. The conversion is used for the calculation only. The original z value for the 
point will remain unchanged

Input N value radio button unselected

if an N value is known for the area or for the selected point, it will be used to convert a geoid height (e.g. 
AHD) into an ellipsoid height. Ellipsoid height = geoid height + N value. The conversion is used for the 
calculation only. The original z value for the point will remain unchanged

Enter N value input box

if the Input N value option is chosen, an N value is entered.

How to Use the Panel and Panel Messages

The results are returned to the panel in the following format:
message area 1 Messages
message area 2 Point scale = , Interpolated or entered N value = (if applicable)
measure area 3 Combined point scale/height factor = 
message area 4 Longitude = Latitude =

The cycle can then be repeated for another point by simply selecting another point without leav-
ing the option. The clear button resets the message areas.
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Non-Projection to Projection Coordinates
Non_projection_to_projection_coordinate_conversion

Position of option on menu: Survey =>Geodetics =>Non-projection to projection coordinate 
conversion

The Non-projection to projection coordinate conversion is for the conversion of non-projection 
coordinates (plane) to a specified projection system. This is done by calculating a series of vectors 
from an origin point. The origin coordinates in both the plane and projection are known. The 
plane vector is calculated between the origin and other selected points. Then using the projection 
coordinates of the origin and the plane vector a projection vector is calculated which allows the 
projection coordinates of the selected points to be calculated. The azimuth orientation should 
be the same in both systems, i.e. no swing should be required. 

The process will convert the vertex of straight segments very effectively. However, care 
should be taken when trying to convert non-linear segments such as curves. These may have 
construction entities such as TP’s that no longer have the same relationship with a centre 
point after conversion for example. This is due to differing scale factors of points due to the 
projection.

On selecting the Non-projection to projection coordinates option, the Non-projection to 
projection coordinate conversion panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data to change source box model

the source of objects to be converted are selected using the data source box. For more information on the 
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data source box see “Data Source” 

Projection projection box current projection available projections

the projection to which the data is to be converted to is specified in the projection box.

Plane easting input box

the plane easting value of the origin point. 

Plane northing input box

the plane northing value of the origin point. 

Select Plane Pt button

selection of the button allows the point to picked from a view. The user selects and accepts the point and 
then the values are placed into the relevant input boxes.

Projection easting input box

the projection easting value of the origin point. 

Projection northing input box

the projection northing value of the origin point. 

Select Projection Pt button

selection of the button allows the point to picked from a view. The user selects and accepts the point and 
then the values are placed into the relevant input boxes.

Target target

the target of the transformed data should be specified. The target for the data is selected using the data 
target box. For more information on the data target box see “Data Target” 
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Projection to Non-Projection Coordinates
Projection_to_non_projection_coordinate_conversion

Position of option on menu: Survey =>Geodetics => Projection to non-projection coordinate 
conversion

The Projection to non-projection coordinate conversion is for the conversion of projection 
coordinates to plane coordinates. This is done by calculating a series of vectors from an origin 
point. The origin coordinates in both the plane and projection are known. The projection vector 
is calculated between the origin and other selected points. Then using the plane coordinates of 
the origin and the projection vector a plane vector is calculated which allows the projection 
coordinates of the selected points to be calculated. The azimuth orientation should be the same 
in both systems, i.e. no swing should be required. 

The process will convert the vertex of straight segments very effectively. However, care 
should be taken when trying to convert non-linear segments such as curves. These may have 
construction entities such as TP’s that no longer have the same relationship with a centre 
point after conversion for example. This is due to differing scale factors of points due to the 
projection.

On selecting the Projection to non-projection coordinates option, the Projection to non-projection 
coordinate conversion panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data to change source box model

the source of objects to be converted are selected using the data source box. For more information on the 
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data source box see “Data Source” 

Projection projection box current projection available projections

the projection to which the data is to be converted from is specified in the projection box.

Plane easting input box

the plane easting value of the origin point. 

Plane northing input box

the plane northing value of the origin point. 

Select Plane Pt button

selection of the button allows the point to picked from a view. The user selects and accepts the point and 
then the values are placed into the relevant input boxes.

Projection easting input box

the projection easting value of the origin point. 

Projection northing input box

the projection northing value of the origin point. 

Select Projection Pt button

selection of the button allows the point to picked from a view. The user selects and accepts the point and 
then the values are placed into the relevant input boxes.

Target target

the target of the transformed data should be specified. The target for the data is selected using the data 
target box. For more information on the data target box see “Data Target” 
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Bearing/Distance Label
Bearing_Distance_Label

Position of option on menu: Survey =>Geodetics => Bearing/distance label

The Bearing/distance label is for the labelling of a selected string with bearing and distance 
information. It allows a parameter file to be setup (*.lbf) which can be written and read into the 
option. This file allows the setting of panel parameters such as rounding, textstyle data etc.

The pick should be with direction. This will effect the bearing that is labelled (+/-180 degrees).

On selecting the Bearing/distance label option, the Bearing/distance label panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Parameter file file box *.lbf files

the parameter file can be read in which will fill in the remaining values within the panel. The user can 
make changes and save the choices as a different file, thus enabling a library of labelling options to be 
created.

Read button

if a valid parameter file is entered into the parameter file field, the user can press the read button to load 
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the information in the file into the panel.

Write button

if a valid parameter file name is entered into the parameter file field, the user can press the write button 
to save the edited panel information into a file so that it can be read in at a later date.

Scale factor input box Current Scale factor at Central meridian if set

if a scale factor is specified, the distance values labelled will use the scale factor to compute the label 
distance. This scale factor will be applied to the calculated plane distance from coordinates in the 
following manner:

label distance = plane distance /scale factor. 

Label style choice box bearing and distancebearing and distance

bearing distance
distance bearing

the label style. 

Bearing and distance equates to having the bearing and distance justification point at the same point 
on the midpoint of the segment (the text justification can make the bearing bottom-middle and the 
distance top-middle for example to show the bearing above the line and the distance below)

Bearing distance equates to having the bearing and distance justification point along side. For example, 
a label may be a bearing on the left and a distance on the right

Distance bearing equates to having the distance and bearing justification point along side. For 
example, a label may be a distance on the left and a bearing on the right

Label all segments tick box unticked

if ticked all the segments of the selected string will be labelled.

Bearing tab 

the following fields are located on the bearing tab.

Field Description Type Defaults Pop-Up

Model model box current models

if a valid model name is specified, the bearing text will be created in that model.



Chapter 16  Survey

April 2007 Page 1473Geodetic Measures and Entry

Textstyle data textstyle box current textstyle names

on pressing the textstyle data button a list of available textdata predefined names read from the 
texstyles_name.4d file are displayed. 

If no names exist, the user can edit the current settings by selecting the edit button and bring up the 
textstyle data panel. This allows for definition of textstyle, units, height offset raise etc.

The textstyle data panel enables the user to define multiple text parameters.

Zero padding tick box unticked

if ticked, the labels will have zero’s inserted so that at least 2 characters exist for the minutes and second 
part of the label. For example, A bearing of 10o 6’ 5" would become 10o 06’ 05" with padding.

The values in the grid relate to the rounding of bearings for labelling. Many different ranges can 
be specified in the grid with each line representing a valid rounding range.

To(m) input box

the rounding upper range limit in meters. This value together with the rounding specified, allow the 
bearings between certain distance ranges to be rounded to a certain value. The first line in the grid is 
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from 0 to the specified distance range. Any following lines in the grid use the To(m) value in the 
previous line for the lower limit to the To(m) value in that line.

Rounding(sec) input box

the rounding value given relates to the distance range. Any bearing within the distance range specified 
will be rounded to the value in seconds. e.g for a rounding value of 60 seconds the bearing will be 
rounded to the nearest minute.

Distance tab 

the following fields are located on the distance tab.

Field Description Type Defaults Pop-Up

Model model box current models

if a valid model name is specified, the distance text will be created in that model.

Textstyle data textstyle box current textstyle names

on pressing the textstyle data button a list of available textdata predefined names read from the 
texstyles_name.4d file are displayed. 

If no names exist, the user can edit the current settings by selecting the edit button and bring up the 
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textstyle data panel. This allows for definition of textstyle, units, height offset raise etc.

The textstyle data panel enables the user to define multiple text parameters.

Suffix input box

if entered, this suffix will be appended to the end of the distance label.

The values in the grid relate to the rounding of distances for labelling. Many different ranges can 
be specified in the grid with each line representing a valid rounding range.

To(m) input box

the rounding upper range limit in meters. This value together with the rounding and number of 
decimals specified, allow the distance to be rounded to a certain value. The first line in the grid is from 
0 to the specified distance range. Any following lines in the grid use the To(m) value in the previous 
line for the lower limit to the To(m) value in that line.

Rounding(m) input box

the rounding value given relates to the distance range. Any distance within the distance range specified 
will be rounded to the value in metres. e.g for a rounding value of 0.05 a distance of 125.261 will be 
rounded to a value of 125.25 

Decimals input box

the number of decimal places can be specified. For a distance of 125.261, rounding of 0.05 and Decimals 
equal to 3, the label will be 125.250.

Short segment tab 

the following fields are located on the short segment tab.
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Field Description Type Defaults Pop-Up

Model model box current models

if a valid model name is specified, the short segment text will be created in that model.

Textstyle data textstyle box current textstyle names

on pressing the textstyle data button a list of available textdata predefined names read from the 
texstyles_name.4d file are displayed. 

If no names exist, the user can edit the current settings by selecting the edit button and bring up the 
textstyle data panel. This allows for definition of textstyle, units, height offset raise etc.
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The textstyle data panel enables the user to define multiple text parameters.

Max. length input box

if entered, this value will be compared with the selected segment distance. If the selected distance is less 
than this distance, the short line labelling will override any bearing and distance labelling.

Number input box

if entered, this value will be used for the short segment text.

Pick button

on selection the user can then select a segment/line from a view with direction. The direction will give 
the bearing direction which is usually +/- 180 degrees different. eg a segment with a bearing of 24 
degrees can be labelled with a bearing of 204 by picking in a south west direction.
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Projection Bearing/Distance Label
Projection_Bearing_Distance_Label

Position of option on menu: Survey =>Geodetics => Projection bearing/distance label

The Projection bearing/distance label is for the labelling of a selected string with plane bearing 
and ellipsoid distance information that is in terms of a selected projection. It allows a parameter 
file to be setup (*.lbf) which can be written and read into the option. This file allows the setting of 
panel parameters such as rounding, textstyle data etc.

The pick should be with direction. This will effect the bearing that is labelled (+/-180 degrees of 
actual direction).

On selecting the Projection bearing/distance label option, the Projection bearing/distance 
label panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Parameter file file box *.lbf files

the parameter file can be read in which will fill in the remaining values within the panel. The user can 
make changes and save the choices as a different file, thus enabling a library of labelling options to be 
created.
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Read button

if a valid parameter file is entered into the parameter file field, the user can press the read button to load 
the information in the file into the panel.

Write button

if a valid parameter file name is entered into the parameter file field, the user can press the write button 
to save the edited panel information into a file so that it can be read in at a later date.

Projection choice current projection available projections

the projection of the data to be used for labelling. 

Label style choice box bearing and distancebearing and distance

bearing distance

distance bearing

the label style. 

Bearing and distance equates to having the bearing and distance justification point at the same point 
on the midpoint of the segment (the text justification can make the bearing bottom-middle and the 
distance top-middle for example to show the bearing above the line and the distance below)

Bearing distance equates to having the bearing and distance justification point along side. For example, 
a label may be a bearing on the left and a distance on the right

Distance bearing equates to having the distance and bearing justification point along side. For 
example, a label may be a distance on the left and a bearing on the right

Label all segments tick box unticked

if ticked all the segments of the selected string will be labelled.

Bearing tab 

the following fields are located on the bearing tab.

Field Description Type Defaults Pop-Up

Model model box current models

if a valid model name is specified, the bearing text will be created in that model.
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Textstyle data textstyle box current textstyle names

on pressing the textstyle data button a list of available textdata predefined names read from the 
texstyles_name.4d file are displayed. 

If no names exist, the user can edit the current settings by selecting the edit button and bring up the 
textstyle data panel. This allows for definition of textstyle, units, height offset raise etc.

The textstyle data panel enables the user to define multiple text parameters.

Zero padding tick box unticked

if ticked, the labels will have zero’s inserted so that at least 2 characters exist for the minutes and second 
part of the label. For example, A bearing of 10o 6’ 5" would become 10o 06’ 05" with padding.

The values in the grid relate to the rounding of bearings for labelling. Many different ranges can 
be specified in the grid with each line representing a valid rounding range.

To(m) input box

the rounding upper range limit in meters. This value together with the rounding specified, allow the 
bearings between certain distance ranges to be rounded to a certain value. The first line in the grid is 
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from 0 to the specified distance range. Any following lines in the grid use the To(m) value in the 
previous line for the lower limit to the To(m) value in that line.

Rounding(sec) input box

the rounding value given relates to the distance range. Any bearing within the distance range specified 
will be rounded to the value in seconds. e.g for a rounding value of 60 seconds the bearing will be 
rounded to the nearest minute.

Distance tab 

the following fields are located on the distance tab.

Field Description Type Defaults Pop-Up

Model model box current models

if a valid model name is specified, the distance text will be created in that model.

Textstyle data textstyle box current textstyle names

on pressing the textstyle data button a list of available textdata predefined names read from the 
texstyles_name.4d file are displayed. 

If no names exist, the user can edit the current settings by selecting the edit button and bring up the 
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textstyle data panel. This allows for definition of textstyle, units, height offset raise etc.

The textstyle data panel enables the user to define multiple text parameters.

Suffix input box

if entered, this suffix will be appended to the end of the distance label.

The values in the grid relate to the rounding of distances for labelling. Many different ranges can 
be specified in the grid with each line representing a valid rounding range.

To(m) input box

the rounding upper range limit in meters. This value together with the rounding and number of 
decimals specified, allow the distance to be rounded to a certain value. The first line in the grid is from 
0 to the specified distance range. Any following lines in the grid use the To(m) value in the previous 
line for the lower limit to the To(m) value in that line.

Rounding(m) input box

the rounding value given relates to the distance range. Any distance within the distance range specified 
will be rounded to the value in metres. e.g for a rounding value of 0.05 a distance of 125.261 will be 
rounded to a value of 125.25 

Decimals input box

the number of decimal places can be specified. For a distance of 125.261, rounding of 0.05 and Decimals 
equal to 3, the label will be 125.250.

Short segment tab 

the following fields are located on the short segment tab.
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Field Description Type Defaults Pop-Up

Model model box current models

if a valid model name is specified, the short segment text will be created in that model.

Textstyle data textstyle box current textstyle names

on pressing the textstyle data button a list of available textdata predefined names read from the 
texstyles_name.4d file are displayed. 

If no names exist, the user can edit the current settings by selecting the edit button and bring up the 
textstyle data panel. This allows for definition of textstyle, units, height offset raise etc.
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The textstyle data panel enables the user to define multiple text parameters.

Max. length input box

if entered, this value will be compared with the selected segment distance. If the selected distance is less 
than this distance, the short line labelling will override any bearing and distance labelling.

Number input box

if entered, this value will be used for the short segment text.

Pick button

on selection the user can then select a segment/line from a view with direction. The direction will give 
the bearing direction which is usually +/- 180 degrees different. eg a segment with a bearing of 24 
degrees can be labelled with a bearing of 204 by picking in a south west direction.



Chapter 16  Survey

April 2007 Page 1485Geodetic Measures and Entry

Geodetic reporting
Geodetic_Reporting

Position of option on menu: Survey =>Geodetics => Geodetic reporting

The Geodetic reporting option is for the reporting of selected data (projection coordinates) in 
terms of geodetic positions and variables. The user can choose from a number of different 
reporting options including, point scale factor, Longitude and latitude, point ids etc.

On selecting the Geodetic reporting option, the Geodetic reporting panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data to report source box model

the source of objects to be reported are selected using the data source box. For more information on the 
data source box see “Data Source” . The selected data must be in terms of the selected map 
projection.coordinate system.

Projection choice current projection available projections

the projection of the data to be reported. 

N value interpolation methodchoice box currently set method Available n value methods

the N value method allows the conversion of non-ellipsoid heights to ellipsoid. The methods are define d 
in the project n value settings. For more information on the n value settings see the section “N values” 

The N value will be used to convert a geoid height (e.g. AHD) into an ellipsoid height. Ellipsoid height 
= geoid height + N value. The conversion is used for the reporting only. The original z value for the 
point will remain unchanged

String name tick box

if selected, any valid string names will be shown in the report.
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Point Ids tick box

if selected, any valid point ids will be shown in the report.

Vertex Numbers tick box

if selected, vertex numbers will be shown in the report.

X,Y coordinates tick box ticked

if ticked, the coordinates of the selected data will be reported.

Z coord tick box

if selected, any valid z values will be shown in the report.

N values tick box

if ticked, the N value calculated for the given point will be reported (if valid).

Ellipsoid heights tick box

if selected, the calculated ellipsoid height will be reported. If no N values are calculated, this will be the 
same as the Z value.

Long, Lat tick box

if selected, the calculated longitude and latitude will be reported. 

Point scale tick box

if selected, the point scale for each point will be reported.

Combined point scale tick box

if selected, the combined point scale for each point will be reported. This combined scale factor is the 
product of the point scale factor and a height scale factor. The height scale factor is computed from the 
ellipsoid height of the point.

Text tick box

if selected, any valid text values will be shown in the report.

Report file input *.rpt

name of the file to report to.
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Solar Reduction
Solar_Observations

Position of option on menu: Survey =>Geodetics => Solar reduction

The Solar reduction option allows the reduction of observations to the sun by the hour angle 
method. The user can specify either limb or the centre of the sun, and a number of observations 
can be processed together. The option does not require almanac details as these are processed 
internally using algorithms supplied by the US naval observatory. These algorithms will 
produce accuracy in the order of 2 arc seconds in azimuth for the period AD1800 - 2050

On selecting the Solar reduction option, the Solar Observations panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File file box *.ast files

a filename can be specified for reading or writing a file.

Read button

if a valid file exists, the file contents can be loaded into the panel.

Write button

if a valid name is specified and the valid values are entered into all of the fields, the user can write the 
input data to a file.

Projection choice current projection available projections

a projection can be specified so that a grid convergence value can be computed. This value will be used 
to compute the grid or projection bearing to the RO. If left blank, only the True azimuth will be 
reported.

Report file input *.rpt
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name of the file to report to.

Origin station input

name of the origin station

RO station input

name of the reference object station

Origin longitude input

the observation station’s longitude should be specified in DMS format.

Origin latitude input

the observation station’s latitude should be specified in DMS format.

Date date box current system date

the date of the observations as at the observers position should be entered. This can be by direct entry 
into the date field or by selecting the day, month, year from a date pop-up panel. The user can scroll 
through different months by selecting the arrow buttons on the pop-up date panel.

Time zone time zone box major time zones

a valid time zone for the observers position and local time should be selected from the pop-up list.

Timing corr.(hh.mmss) input

the correction to apply for any timing error including stopwatch corrections should be entered. The 
value should be in a hours, minutes seconds in hp format.

GRID VALUES: input

Local time input

the local time of the observation specified in 24 hour time in HMS. eg. 18.121002

Horiz obs to RO input

the horizontal angle (bearing) observed to the RO for the set of measurements. A set in this case 
includes a pointing to the RO and sun (at a certain time) in the same face.

Horiz obs to SUN input

the horizontal angle (bearing) observed to the Sun for the set of measurements.(The observation should 
not be corrected for the suns semi diameter as this is done internally by the reduction process)

If observation s are made on both faces, a separate line should be entered for each face. e.g Face 1 to RO 
may be 0.0000 and the face 1 to the sun may be 50.0000 which would be on the same line, then the 
observer may change face to face 2 and observe to the sun again followed by the RO. The face 2 
observations should appear on the next line eg 180.0004 230.0110. 

Limb of sun choice box Centre

Left limb
Right limb

the limb of the sun observed should be specified. This enables the suns semi diameter correction to be 
applied. This also allows the observations to be read in any order.

Az to cen. SUN output
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the true azimuth to the sun will be displayed in this field on successful reduction of the observations.

Az to RO output

the true azimuth to the RO will be displayed in this field on successful reduction of the observations.

Conv. angle output

the convergence angle at the observation point will be displayed in this field if a valid projection is 
specified and there is a successful reduction of the observations.

Grid brg to RO output

the grid bearing to the RO will be displayed in this field if a valid convergence angle is calculated and 
there is a successful reduction of the observations. The grid bearing is calculated by:

Grid brg = True azimuth + convergence

The fields and buttons used in this panel below the grid have the following functions.

Field Description Type Defaults Pop-Up

Average RO azimuth output

if there is as successful reduction, the average RO azimuth value will be reported in this field.

Average RO grid bearing output

if there is as successful reduction, and the projection given, the average RO grid bearing value will be 
reported in this field.

Standard deviation in the mean output

this is a statistical measure of the reduced observations.
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Star Reduction
Star_Observations

Position of option on menu: Survey =>Geodetics => Star reduction

The Star reduction option allows the reduction of observations to the nominated star by the hour 
angle method. A number of observations can be processed together. The option does not 
require almanac details as these are processed internally using algorithms supplied by the US 
naval observatory. These algorithms will produce accuracy in the order of 2 arc seconds in 
azimuth for the period AD1800 - 2050

On selecting the Star reduction option, the Star Observations panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File file box *.ast files

a filename can be specified for reading or writing a file. 

Read button

if a valid file exists, the file contents can be loaded into the panel.

Write button

if a valid name is specified and the valid values are entered into all of the fields, the user can write the 
input data to a file.

Star id by button FK5 number General name

Constellation Bayer/
      Flamsteed number
FK5 number
SAO number
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the star can be identified by a number of different means. The stars available are based on the Fifth 
Fundamental Catalogue(FK5) catalogue. Cross matching of id’s are not possible in some instances. e.g 
A star may have no known general name. 

The selection of an id method will force the changing of the id list so the particular star can be selected.

Star id choice 1st star id in list available id’s for that type

the star id can be selected from the list.

Report file input *.rpt

name of the file to report to.

Origin station input

name of the origin station

RO station input

name of the reference object station

Origin longitude input

the observation station’s longitude should be specified in DMS format.

Origin latitude input

the observation station’s latitude should be specified in DMS format.

Date date box current system date

the date of the observations as at the observers position should be entered. This can be by direct entry 
into the date field or by selecting the day, month, year from a date pop-up panel. The user can scroll 
through different months by selecting the arrow buttons on the pop-up date panel.

Time zone time zone box major time zones

a valid time zone for the observers position and local time should be selected from the pop-up list.

Timing corr.(hh.mmss) input

the correction to apply for any timing error including stopwatch corrections should be entered. The 
value should be in a hours, minutes seconds in hp format.

GRID VALUES: input

Local time input

the local time of the observation specified in 24 hour time in HMS. eg. 18.121002

Horiz obs to RO input

the horizontal angle (bearing) observed to the RO for the set of measurements. A set in this case 
includes a pointing to the RO and star (at a certain time) in the same face.

If observation s are made on both faces, a separate line should be entered for each face. e.g Face 1 to RO 
may be 0.0000 and the face 1 to the star may be 50.0000 which would be on the same line, then the 
observer may change face to face 2 and observe to the star again followed by the RO. The face 2 
observations should appear on the next line eg 180.0004 230.0110.

Horiz obs to Star input
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the horizontal angle (bearing) observed to the Star for the set of measurements.

Az to Star output

the true azimuth to the sun will be displayed in this field on successful reduction of the observations.

Az to RO output

the true azimuth to the RO will be displayed in this field on successful reduction of the observations.

Conv. angle output

the convergence angle at the observation point will be displayed in this field if a valid projection is 
specified and there is a successful reduction of the observations.

Grid brg to RO output

the grid bearing to the RO will be displayed in this field if a valid convergence angle is calculated and 
there is a successful reduction of the observations. The grid bearing is calculated by:

Grid brg = True azimuth + convergence

The fields and buttons used in this panel below the grid have the following functions.

Field Description Type Defaults Pop-Up

Average RO azimuth output

if there is as successful reduction, the average RO azimuth value will be reported in this field.

Average RO grid bearing output

if there is as successful reduction, and the projection given, the average RO grid bearing value will be 
reported in this field.

Standard deviation in the mean output

this is a statistical measure of the reduced observations.
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Traverse Spreadsheet
traverse_spreadsheet

Position of menu: Survey =>Traverse spreadsheet

The Traverse Spreadsheet options allow the entry of traverse and radiation blocks from the 
keyboard, selection of strings from the current view or by reading from a file. Adjustments can 
then be made including transit, Bowditch, compass or least square adjustment. The adjustment 
can be for a closed string (loop) or an open string (non-loop). Traverse Spreadsheet will often be 
abbreviated as TSS.

There are two types of traverse spreadsheets (TSS) - Plane and Projection.

For the Plane TSS, entered distances are multiplied by the scale factor to give final distances and 
hence calculate co-ordinates, whereas for the Projection TSS, ellipsoid distances are entered and 
12d Model calculates the correct co-ordinate position using full projection calculations.

The Traverse spreadsheet walk-right menu contains the traverse spreadsheet options.

.

For the option Parameters please continue to the section “TSS Parameters” 
Create  “TSS Create” 
Edit   “TSS Edit” 
Utilities  “TSS Utilities” 
Lot check “Lot Check” 
NZ report  “NZ TSS Report” 
Standard report “Standard TSS Report” 
Drafting “TSS Drafting” 
Radiation table “TSS Radiation Table Drafting” 
Landonline XML read “Landonline XML Read” 
Landonline XML write “Landonline XML Write” 

Setting parameters for the traverse spreadsheet option
Create a TSS - Plane or Projection
Edit an existing TSS
Utilities for use with existing TSS’s
Run lot checks on typed bearing/distance data
NZ traverse spreadsheet report
Standard traverse spreadsheet report
Traverse spreadsheet drafting
Creating radiation tables from a TSS
Reading LINZ XML data
Writing LINZ XML data



12d Model Reference Manual

Page 1494 April 2007Traverse Spreadsheet

TSS Parameters
traverse_spreadsheet_parameters

Position of option on menu: Survey =>Parameters

The Traverse Spreadsheet Parameters sets the parameters for defining the look and feel of the 
TSS create and edit panels, reports and drafting.

Selecting Parameters brings up the Traverse Spreadsheet Parameters panel:
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TSS Create
create_traverse_spreadsheet

Position of option on menu: Survey =>Traverse spreadsheet =>Create

A traverse spreadsheet (TSS) can either use a constant scale factor or a cartographic projection to 
define the relationship between bearings/distances and the (x,y) co-ordinates.

The Traverse Spreadsheet Create option allows the entry of traverse and radiation blocks 
from the keyboard, selection of strings from the current view or by reading from a file. 
Adjustments can then be made including transit, Bowditch, compass or least square adjustment. 
The adjustment can be for a closed string (loop) or an open string (non-loop).

Selecting Traverse Spreadsheet Create brings up the Create Traverse Spreadsheet panel:

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Projection spreadsheet radio button

if selected then the Projection field must be filled in.

Projection projection box first projection project projections

the cartographic projection used in the TSS. For more information on projections go to “Projections”  
in the chapter “Projects” . This is a Projection TSS.

Scaled spreadsheet radio button
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if selected then the Scale factor field must be filled in.

Scale factor real box

the constant scale factor used in the TSS. This is a Plane TSS.

Details section

Spreadsheet name text box

the name for the TSS

File name text box

name of the *.tf file to store all the TSS data in. The TSS can be brought back for editing by giving this 
filename.

Create button

 create a new traverse spreadsheet using the parameters entered in the above panel field. The 
appropriate editor (either for a Projection Traverse Spreadsheet or a Plane Traverse 
Spreadsheet panel) is then brought up for the TSS data to be entered and/or edited.
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TSS Edit
edit_traverse_spreadsheet

Position of option on menu: Survey =>Traverse spreadsheet =>Edit

The traverse spreadsheet editor reads in an existing TSS file and loads the information into either 
the Projection Traverse Spreadsheet or the Plane Traverse Spreadsheet panel.

Selecting Traverse Spreadsheet Edit brings up the Edit Traverse Spreadsheet panel:

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

File name file box *.ts files

name of the file containing the traverse spreadsheet information to be edited.

Edit button

 read the information in the traverse spreadsheet file and load it into either a Projection Traverse 
Spreadsheet or a Plane Traverse Spreadsheet panel.

For entering/editing either a Projection TSS or Plane TT, please go to the section “Traverse 
Spreadsheets” 

Traverse Spreadsheets
plane_traverse_spreadsheet

projection_traverse_spreadsheet

The Projection and Plane TSS panels allows the entry of traverse and radiation blocks from the 
keyboard, selection of strings from the current view or by reading from a file. Adjustments can 
then be made including transit, Bowditch, compass or least square adjustment. The adjustment 
can be for a closed string (loop) or an open string (non-loop).

The two panels are very similar and only the top section is different. The Projection Traverse 
Spreadsheet requires a Projection rather than a Scale factor.



12d Model Reference Manual

Page 1498 April 2007Traverse Spreadsheet

For more information about terminology used in the projection option, see the Appendix 
“Geodetics Summary” .

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Network name display only

the entire spreadsheet can be given a name for identification purposes. This was defined when the TSS 
was created and can only be changed using the TSS Utilities option.
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File name display only

the file name containing the TSS information. This was defined when the TSS was created and can 
only be changed using the TSS Utilities option.

The only visible difference between the Plane and Projections Traverse Spreadsheet panel is that the Scale 
or Projection is given at the top of the panel. All the panel fields are the same.

Of course the calculations are different for the two types of spreadsheets. For the Plane TSS, entered 
distances are multiplied by the scale factor to give final distances and hence calculated co-ordinates, 
whereas for the Projection TSS, ellipsoid distances are entered and 12d Model calculates the correct co-
ordinate position using full projection calculations.

Block Settings

Position input

the order of a block within the spreadsheet can be specified by nominating the block position. 
Numbering within the list starts at 1. This parameter is used for inserting new blocks into the list. If a 
user nominates to insert in position 5 and there is only 2 blocks already defined, the block will be placed 
at the end of the list (i.e. position 3)

Count input

the number of blocks within the spreadsheet.

Type choice traverse traverse, radiation, radiation 
backsight, parcel, irregular
trace, balance 

the type of a block within the spreadsheet can be specified by nominating the block type. 

The traverse block is for the entry of loop and non-loop traverses starting and ending at points with 
known coordinate values.

For a hanging traverse, i.e. a traverse that does not close onto a known point, the data can be entered by 
entering a 0 (zero) in the point id field of the grid control, as well as the end point - point id field. 

 The radiation block consists of a number of radiations or side shots from a point with known 
coordinates. This point may be defined in a previous traverse block or it may be from a known point. A 
valid coordinate must exist for the radiation start point for the radiation block to be used.

A radiation backsight block is the same a s a radiation block except that the value set to the backsight 
is included. After adjustment of previous blocks, the coordinates of setup and backsight points often 
change. This will introduce swing errors into calculations if not accounted for. By entering the 
backsight value as set in the field, a comparison is made between what was set and the adjusted value. 
The difference is then applied to the radiations in the block to reflect the corrected angle measurements.

XXXX - need 12d NZ documentation on TSS

Name input

a spreadsheet can consist of a number of different blocks. For each block, a name can be given which can 
help identify a particular traverse/radiation block within the spreadsheet.

Flag input

the adjustment mode of the current block. The mode is either adjusted or unadjust. All blocks are set to 
unadjusted on reading of a file, and the user specifies which blocks are to be adjusted.

Prev button

allows the navigation to the previous block in the list. 
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Next button

allows the navigation to the next block in the list. 

New button

allows for the definition and entry of a new block in the list. 

Update button

allows for the updating of entries when changes have been made. For example, if a distance 
measurement were to be changed, pushing the update button will ensure the new value will be used in 
further calculations and adjustments

Insert button

allows for the insertion of a block into the list in the position defined by the Block position entry.

Append button

allows for the insertion of a block at the end of the list.

Delete button

allows for the deletion of the currently displayed block.

Show EN tick box ticked

if ticked the easting and northing columns will be shown in the grid. If unticked the columns will not 
be shown.

Copy b dsc tick box ticked

if ticked the bearing and description from the previous line in the grid will automatically be copied 
down to the next entered line.

Pick string button

allows for the loading of the current block by selecting a string from the current view.

Adjustment method choice  bowditch, compass, transit, 
least square

method of adjustment.

Loop tick box unticked

For loop traverses the tick box should be checked. This assumes that the start and end points are the 
same.

The fields in this panel define the start and end point details. If the loop option is chosen the end 
point details are assumed to be the same as the start point In this case the end point group is 
disabled.

Least square tab

The fields in this panel define the values to be used for least square adjustments. 

Field Description Type Defaults Pop-Up

Angular std (sec).
 The standard deviation of a single angular measurement in seconds of arc.

Linear std (mm)

this value is defined by the standard deviation of a single distance measurement (e.g. 5 mm)

ppm

this value is defined by the edm scale error which is dependant on the length of line measured (e.g. 
5ppm = 5mm error over a 1km distance)

Iterations input box 10
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the calculation of the adjustment can be aborted if a solution is not found after the specified number of 
iterations.

Coords differ input box 0.0001

the calculation of the adjustment can stopped when the difference between successive calculations meet 
the defined tolerance.

variance increase tick box ticked

the calculation of the adjustment can stopped when the variance between successive calculations 
increases

The fields in start point group specify the start point parameters

Start point button/input

the start point can be selected by selecting the button and then selection and acceptance of a point in an 
open view. If valid a point id, easting, northing and description of the selected point will be copied into 
the appropriate fields.

If the start point is to be entered manually, the point id should be entered into the field adjacent to the 
start point button.

N input

the start point’s northing value.

E input

the start point’s easting value.

Desc input

the start point’s description.

the grid control values can be entered using valid inputs into the various fields. 

To Point. The point id of the next traverse station. 
Bearing(dms). The bearing of the traverse line. 
Distance. The distance of the traverse line. 
Point Desc. The description of the traverse point
Easting The easting coordinate of the traverse point. NB. This field is only displayed when the calc or 

adjust buttons are selected.
Northing The northing coordinate of the traverse point. NB. This field is only displayed when the calc or 

adjust buttons are selected.

The fields in end point group specify the end point parameters

end point button/input

the end point can be selected by selecting the button and then selection and acceptance of a point in an 
open view. If valid a point id, easting, northing and description of the selected point will be copied into 
the appropriate fields.

If the end point is to be entered manually, the point id should be entered into the field adjacent to the 
end point button.

N input

the end point’s northing value.

E input
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the end point’s easting value.

Desc input

the end point’s description.

the misclose line near the bottom of the panel have the following functions. 

Bearing input box

the closing bearing for the traverses.

Distance input box

the closing distance of the traverse

Delta east input box

the closing vector’s delta east component

Delta east input box

the closing vector’s delta east component

Misclosure input box

the ratio of the closing distance to the total traverse distance.

the buttons at the bottom of the panel have the following function. 

Calc button

the calc button is used to calculate coordinate values based on the information input into the grid 
control and the points tab. The block has to be inserted or appended into the list before this can be done.

Adjust button

the adjustment of the current block can be done after the calc stage has been reached. This will use the 
method of adjustment as stipulated by the user.

Adjust All button

the adjustment of all of the blocks in the list can be done after the calc stage has been reached in 
each of the individual blocks. This will use the method of adjustment as stipulated by the user.

Save button

saves the current data in the panel to the TSS file (displayed in the file name box). 
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TSS Utilities
traverse_spreadsheet_utilities

Position of option on menu: Survey =>Traverse spreadsheet =>Utilities

The traverse spreadsheet utilities are used to change the file containing a TSS, change the name 
(TSS), change between Plane (constant scale) or Projection type,

Selecting Traverse Spreadsheet Utilities brings up the Traverse Spreadsheet Utilities panel:
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Lot Check
lot_check

Position of option on menu: Survey =>Traverse spreadsheet =>Lot check

The Lot check option allows the entry of traverse and radiation blocks from the keyboard, 
selection of strings from the current view or by reading from a file. Adjustments can then be 
made including transit, Bowditch, compass or least square adjustment. This option can be used 
to enter existing plan dimensions to check area calculations as well as ensuring lots are closed to 
prescribed limits.

Selecting Lot check brings up the Lot Check panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

The scale and datum fields are the only difference between the plane and datum lot check panels. 

Scale factor input project scale factor

a scale factor can be defined which will be applied to any entered distances. Final distances used in 
calculations are derived by multiplying the entered distance by the scale factor.
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Block count input

the number of blocks within the spreadsheet.

Desc. input

a spreadsheet can consist of a number of different blocks. For each block, a block description can be 
given which can help identify a particular traverse/radiation block within the spreadsheet.

Block flag input

the adjustment mode of the current block. The mode is either adjusted or unadjust. All blocks are set to 
unadjusted on reading of a file, and the user specifies which blocks are to be adjusted.

Prev button

allows the navigation to the previous block in the list. 

Next button

allows the navigation to the next block in the list. 

New button

allows for the definition and entry of a new block in the list. 

Update button

allows for the updating of entries when changes have been made. For example, if a distance 
measurement were to be changed, pushing the update button will ensure the new value will be used in 
further calculations and adjustments

Insert button

allows for the insertion of a block into the list in the position defined by the Block position entry.

Append button

allows for the insertion of a block at the end of the list.

Delete button

allows for the deletion of the currently displayed block.

File name input box *.ts

a file name can be defined which will allow for the reading of an existing file and for defining a new file 
name for reading in the future.

Read button

the read button allows for the loading of an existing file as specified by the file name box. 

Write button

the write button allows for the saving of the current file as specified in the file name box. 

Pick string button

allows for the loading of the current block by selecting a string from the current view.

Adjust method choice  bowditch, compass, transit, 
least square, none

method of adjustment.

Show EN tickbox ticked

if ticked the easting and northing columns will be shown in the grid. If unticked the columns will not 
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be shown.

Copy b dsc tickbox ticked

if ticked the bearing and description from the previous line in the grid will automatically be copied 
down to the next entered line.

The fields in this panel define the start and end point details. If the loop option is chosen the end 
point details are assumed to be the same as the start point In this case the end point group is 
disabled.

Least square tab

The fields in this panel define the values to be used for least square adjustments. 

Field Description Type Defaults Pop-Up

Angular std (sec).
 The standard deviation of a single angular measurement in seconds of arc.

Linear std (mm)

this value is defined by the standard deviation of a single distance measurement (e.g. 5 mm)

ppm

this value is defined by the edm scale error which is dependant on the length of line measured (e.g. 
5ppm = 5mm error over a 1km distance)

Iterations input box 10

the calculation of the adjustment can be aborted if a solution is not found after the specified number of 
iterations.

Coords differ input box 0.0001

the calculation of the adjustment can stopped when the difference between successive calculations meet 
the defined tolerance.

variance increase tick box ticked

the calculation of the adjustment can stopped when the variance between successive calculations 
increases

The fields in start point group specify the start point parameters

Start point button/input

the start point can be selected by selecting the button and then selection and acceptance of a point in an 
open view. If valid a point id, easting, northing and description of the selected point will be copied into 
the appropriate fields.

If the start point is to be entered manually, the point id should be entered into the field adjacent to the 
start point button.

N input

the start point’s northing value.

E input

the start point’s easting value.

Desc input

the start point’s description.
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the grid control values can be entered using valid inputs into the various fields. 

To Point. The point id of the next traverse station. 
Bearing(dms). The bearing of the traverse line. 
Distance. The distance of the traverse line. 
Point Desc. The description of the traverse point
Easting The easting coordinate of the traverse point. NB. This field is only displayed when the calc or 

adjust buttons are selected.
Northing The northing coordinate of the traverse point. NB. This field is only displayed when the calc or 

adjust buttons are selected.

The fields in end point group specify the end point parameters

end point button/input

the end point can be selected by selecting the button and then selection and acceptance of a point in an 
open view. If valid a point id, easting, northing and description of the selected point will be copied into 
the appropriate fields.

If the end point is to be entered manually, the point id should be entered into the field adjacent to the 
end point button.

N input

the end point’s northing value.

E input

the end point’s easting value.

Desc input

the end point’s description.

the misclose line near the bottom of the panel have the following functions. 

Bearing input box

the closing bearing for the traverses.

Distance input box

the closing distance of the traverse

Delta east input box

the closing vector’s delta east component

Delta east input box

the closing vector’s delta east component

Misclosure input box

the ratio of the closing distance to the total traverse distance.

the buttons at the bottom of the panel have the following function. 

Calc button

the calc button is used to calculate coordinate values based on the information input into the grid 
control and the points tab. The block has to be inserted or appended into the list before this can be done.

Adjust button
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the adjustment of the current block can be done after the calc stage has been reached. This will use the 
method of adjustment as stipulated by the user.

Adjust All button

the adjustment of all of the blocks in the list can be done after the calc stage has been reached in 
each of the individual blocks. This will use the method of adjustment as stipulated by the user.

Report button

on selecting this button the NZ traverse spreadsheet report panel appears.
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NZ TSS Report
nz_traverse_spreadsheet_report

Position of option on menu: Survey =>Traverse spreadsheet =>NZ report

The NZ report option allows the user to define the report header etc. so as to produce a 
spreadsheet report which can be printed to a pre-printed NZ sheet.

Selecting NZ report brings up the NZ Traverse Spreadsheet Report panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Input format choice box *.ts *.ts, *.lch

either a TSS file (*.ts) or a lot check file (*.lch) can be reported.
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Input file input box *.ts

name of the TSS or lot check file.

Print choice box TS sheet TS sheet, Calc sheet, Other

either TS sheet.

Report parcels tick box

If tick, parcel block types are included in the report.

Traverse Title section
Traverses of, line 2, line 3, line 4

The title of the traverses can be entered into the traverses of box as well as the following line 2, line 3 
and line 4 input boxes. Due to the limitation of space on the pre-printed forms supplied by LINZ the 
number of characters should be limited to 20 characters (inclusive of space characters) for the traverse 
of line and 33 characters (inclusive of space characters) for lines 2 to 4.

The input into the traverses for line is compulsory but for lines 2 to 4 it is optional.

Datum Information section

NZ Circuit choice box existing NZ circuits

the circuit in which the current spreadsheet file relates to should be specified.

Projection choice box Geodetic 1949
Geodetic 2000
Old Cadastral

the appropriate NZ geodetic datum should be selected.

Coords in terms of section
these parameters are only required to be entered for the Old cadastral datum case. For other datums, the 
values are automatically updated.

Point name input box

the name of the origin point should be entered.

Northing input box

the nothing coordinate of the origin point should be entered.

Easting input box

the easting coordinate of the origin point should be entered.

Other Details section

Field book input box

the name of the field book used.

Plan no input box

the plan no to be created if known.

NZ Land District choice box Existing NZ land districts

the appropriate NZ land district should be selected.

Report file files box *.rpt files

file name for the report.
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Report file button

 a report using the nominated file name is created.



12d Model Reference Manual

Page 1512 April 2007Traverse Spreadsheet

Standard TSS Report
standard_spreadsheet_traverse_report

Position of option on menu: Survey =>Traverse spreadsheet =>Standard report

The Standard report allows the user to define the report header etc. so as to produce a standard 
TSS report which can be printed, saved or edited.

Selecting Standard report brings up the Standard Traverse Spreadsheet Report panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Input format choice box *.ts *.ts, *.lch

either a TSS file (*.ts) or a lot check file (*.lch) can be reported.

Input file input box *.ts

name of the TSS or lot check file.

Print choice box TS sheet TS sheet, Calc sheet, Other

either TS sheet.

Report parcels tick box

If tick, parcel block types are included in the report.

Traverse Title section

Job id text input box

text to use as the Job id.
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Traverses of, line 2, line 3, line 4

The title of the traverses can be entered into the traverses of box as well as the following line 2, line 3 
and line 4 input boxes. Due to the limitation of space on the pre-printed forms supplied by LINZ the 
number of characters should be limited to 20 characters (inclusive of space characters) for the traverse 
of line and 33 characters (inclusive of space characters) for lines 2 to 4.

The input into the traverses for line is compulsory but for lines 2 to 4 it is optional.

Surveyor id text input box

text to use as the Surveyor id.

Computer operator text input box

text to use as the Computer operator.

Report file files box *.rpt files

file name for the report.

Report file button

 a report using the nominated file name is created.
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TSS Drafting
traverse_spreadsheet_drafting

Position of option on menu: Survey => Traverse spreadsheet=> Drafting

The Traverse spreadsheet drafting produce models, linestyles and colours for data within the 
TSS.

Selecting Drafting brings up the Traverse Spreadsheet Drafting panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Input file file box *.ts

name of the existing spreadsheet file to create drafting for.

Draft mode choice box adjusted adjusted
initial

the draft mode will determine if adjusted strings are used for drafting or if the unadjusted 
values(initial) values are used

Draft TS sheet tick box

if tick, 

Draft calc sheet tick box

if tick, 

Draft other tick box

if tick, 

Mapping file mapping file box *.mf

mapping file to define the drafting

Pre*postfix for models text input box

pre and post text to add to the model names given in the mapping file
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Short segment max length real input box

maximum size for a segment to be considered a short segment. Short segments are labelled with a 
number and the details placed in a table.

Short segment start no. integer input box

start number for any short segments.

Table location xyz box

world position for the short segment table.

Process button

process the traverse spreadsheet and create the drafting and short segment table.
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TSS Radiation Table Drafting
radiation_table_drafting

Position of option on menu: Survey => Traverse spreadsheet=> Radiation table

The Traverse spreadsheet radiation table option produces radiation tables for the radiation 
data in a traverse spreadsheet.

Selecting Radiation table brings up the Radiation Table Drafting panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Input file file box *.ts

name of the existing spreadsheet file to create radiation tables for.

Draft TS sheet tick box

if tick, 

Draft calc sheet tick box

if tick, 

Draft other tick box

if tick, 

Mapping file mapping file box *.mf

mapping file to define the drafting

Pre*postfix for models text input box

pre and post text to add to the model names given in the mapping file

Pre*postfix for headers text input box

pre and post text to add to the header names for the radiation tables.

Process button

process the traverse spreadsheet and create the radiation tables.
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Landonline XML Read
read_Landonline_xml_file

Position of menu: Survey =>Traverse spreadsheet => Landonline XML read

The Landonline XML Read option reads in data in the XML format for Landonline New 
Zealand.

Selecting Landonline XML read brings up the Read Landonline XML File panel

Documentation is available from 12d NZ Ltd.
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Landonline XML Write
read_Landonline_xml_file

Position of menu: Survey =>Traverse spreadsheet => Landonline XML write

The Landonline XML Write option writes out data in the XML format for Landonline New 
Zealand.

Selecting Landonline XML write brings up the Write Landonline XML File panel

Documentation is available from 12d NZ Ltd.
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Conformance
survey_conformance

Position of menu: Survey =>Conformance

The Conformance walk-right menu contains survey options for generating conformance reports 
and models on surveyed points representing as-built batter slopes and pavements, compared 
against string data representing designed batter slopes and pavements.

The Conformance walk-right menu is

.

For the option Batter slope report, go to the section:“Batter slope report” 
Pavement report, go to the section:“Pavement report” 

Generate batter slope conformance report
Generate pavement conformance report
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Batter slope report
Conformance_Report_Batters_panel

Position of option on menu: Survey =>Conformance =>Batter slope report

The Batter slope report option generates a conformance report on surveyed points representing 
an as-built batter slope, compared against string data representing a designed batter slope.

In addition to the conformance report, an output results model of the surveyed points can be 
generated, grouping the points by colour into their conformance zones (i.e. within tolerance, above 
tolerance, below tolerance, and not tested). The points in the results model can have z-values and 
vertex text set to show various combinations of point level, point conformance, and point error.

Note1: the term point conformance is used here to refer to a point’s distance from design (distance 
from the conformance line on diagram below), while the term point error refers to a point’s 
distance out of tolerance. As such, a point that is within tolerance (i.e. a conformant point) will, in 
general, have a non-zero conformance and a zero error, while a point that is out of tolerance (i.e. 
a non-conformant point) will have both a non-zero conformance and a non-zero error.

Note2: the point conformances and errors can be measured either vertically or perpendicular to 
the conformance line. It is perhaps worthwhile to note, especially in the case of the sliding critical 
zone, that the perpendicular measurements are determined from the vertical measurements, and 
not vice versa. That is, if the slope of the conformance line, measured from horizontal, is denoted 
by the angle A, then a surveyed point Q, has a perpendicular conformance Qcp, and error Qep, 
determined from the point’s vertical conformance Qcv, and error Qev, via the following 
relationships:

Qcp = Qcv.cosA
Qep = Qev.cosA

Note3: the conformance line is the line from which all point conformances and tolerances are 
measured, and is always parallel to the design batter slope line. When testing a sub-grade 
survey, the conformance line will normally be below the design batter slope line, but when 
testing a completed-construction survey, the two lines should normally coincide.
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Typical sections through excavation and embankment batters are shown in the diagram below, 
along with schematics showing how the surveyed points are tested for conformance:
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Selecting Batter slope report brings up the Batter Slope Conformance Report panel

The first tab on this panel is the Batters Tab:

The fields and buttons on the Batters Tab have the following functions:

Field Description Type Defaults Pop-Up

Survey data

Data source of points source box

all points selected with this source box (whether they exist in point-string form or line-string form) 
will be considered as the set of surveyed points to be tested for conformance.

Note: the data for the Point Description column in the report will be taken from the string names of 
the selected points. If all the string names are blank, however, the point description data in the report 
will show point ids representing the sequential order that the points are reported in. The results model 
(if generated) will always have the string names of each point set to match the reported point 
description.

Design data

Control string string box

the string selected with this box should normally represent the road centreline, and will be used to 
determine the chainage and offset of each surveyed point
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Slope control string string box

the Slope control string is optional (and is not shown on the diagram above). If no string is selected, 
the Primary string, below, will be used as the Slope control string. The line that is formed in plan, 
from a surveyed point to the nearest point on the Slope control string, defines the vertical plane used 
to conform that surveyed point. The slope formed between the primary and secondary strings on this 
vertical plane, is the design slope for that surveyed point.

Primary string string box

the string selected with this box should represent one edge of the designed batter (normally the edge 
closer to the road - i.e. the toe string of an excavation batter, or the crest string of an embankment 
batter).

The Primary string represents the start of the Critical Zone, which continues horizontally in the 
direction of the Secondary string, for a distance specified in the Critical zone range field (on the 
Tolerances Tab).

Secondary string string box

the string selected with this box should represent the other edge of the designed batter (normally the 
edge further away from the road - i.e. the interface string)

Constraints

Start chainage real box

the start chainage of the surveyed points to be conformed. Any point with a chainage less than the start 
chainage will not be tested. By default, the start chainage is set when the Control string is selected, but 
a different value can be typed in.

End chainage real box

the end chainage of the surveyed points to be conformed. Any point with a chainage greater than the 
end chainage will not be tested. By default, the end chainage is set when the Control string is selected, 
but a different value can be typed in.

Chainage bandwidth real box 5.0

if zero or blank, the surveyed points are simply sorted in ascending chainage order. However, if a value 
greater than zero is entered, the surveyed points will also be sub-sorted into chainage bands, in 
ascending offset order. Within each chainage band, the difference between the maximum and minimum 
chainage will be less than the Chainage bandwidth. This is a useful feature if the surveyed points are 
set out in rows of roughly equivalent chainage.

Results

Report file file box *.rpt

the name of the conformance report file to be created. If no extension is given, it will be given an 
extension of ".rpt".

Results model model box available models

the name of the results model to be created. If blank, the results model is not created.

Buttons

Report button

generates the conformance report file and the results model. This button can be activated regardless of 
which panel tab is currently active.

Finish button

exits the option and closes the panel. This button can be activated regardless of which panel tab is 
currently active.
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The next tab on the panel is the Tolerances Tab:

The fields and buttons on the Tolerances Tab have the following functions:

Field Description Type Defaults Pop-Up

Tolerance file file box *.tol

the name of the tolerance file used to load and/or save the details of the conformance. If no extension is 
given, it will be given an extension of ".tol". The tolerance file stores the details of every field on the 
Tolerances Tab, the Report File Tab, and the Results Model Tab. The tolerance file itself is not 
required to run a conformance test - it is merely provided as a convenience.

Read button

Pressing this button will populate the panel fields on the last three panel tabs, with the data stored in 
the tolerance file. If data for a particular field is not found, that field remains unaffected.

Write button

Pressing this button will create a new tolerance file or replace an existing one. The contents of all non-
blank fields on the last three panel tabs, are written to the file at this time.

Sub-grade depth from design batter

Depth is measured choice box perpendicular perpendicular to batter
vertical
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whether the sub-grade depth is measured perpendicular to the batter or vertically (refer to parameters 
Dp and Dv on the diagram above)

Sub-grade depth real box 0.0

the depth of the conformance line from the design batter (refer to parameters Dp and Dv on the diagram 
above). If testing a sub-grade survey, this value will normally be greater than zero. If testing a 
completed-construction survey, however, this value will normally be zero, and the conformance line 
will coincide with the design batter slope line.

Critical zone range

Zone is defined as choice box sliding sliding
fixed

determines whether the Critical Zone is defined as sliding or fixed (refer to diagram above). For 
excavation batters, the zone is normally sliding, whilst for embankment batters, it is normally fixed.

Range is measured choice box vertical along batter
vertical
horizontal

determines how the size of the Critical Zone is measured (refer to parameters Cb, Cv, and Ch on the 
diagram above)

Range real box

the size of the Critical Zone, measured in the specified direction (refer to parameters Cb, Cv, and Ch on 
the diagram above). This distance must be zero or greater.

Tolerance details

Points inside road choice box do not test do not test
test with zero tolerance
test with fixed crit. tolerance

determines what to do with any surveyed points found inside the road. If such points are found, and 
this field is set to do not test, the points will be classified as untested, and in the results model, will 
have their vertex text set to INR.

Note: untested points do not appear in the conformance report.

Tolerances measured choice box perpendicular perpendicular to batter
vertical

whether the conformance tolerances are measured perpendicular to the batter or vertically (refer to 
parameters T**p and T**v on the diagram above). This field also determines whether the reported point 
conformances and point errors are measured perpendiculary or vertically.

Flat-to-Steep transition slope: 1v in
real box

It is possible to use two different sets of batter slope tolerances, when producing the conformance 
report. The Flat slope tolerance set will be used whenever the design slope is equal to the transition 
slope or flatter, and the Steep slope tolerance set will be used whenever the design slope is steeper 
than the transition slope. The transition slope must be specified as a positive number, and will be 
interpreted as a slope in the form
1[v] : transition slope[h]. Leaving this field blank will disable the Steep slope tolerance set, 
ensuring that only the Flat slope tolerance set will ever be used.

Flat slope tolerances
The following four tolerances are used if the transition slope is not specified, or whenever the 
design slope is equal to the transition slope or flatter.
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1 Upper critical real box

refer to parameters Tucp and Tucv on the diagram above. This value is normally zero or greater.

2 Lower critical real box

refer to parameters Tlcp and Tlcv on the diagram above. This value is normally zero or less.

3 Upper main real box

the upper allowable distance that a surveyed point, found to be in the Main Zone, may be from the 
conformance line, in order to be conformant (refer to parameters Tump and Tumv on the diagram 
above). This value is normally zero or greater.

4 Lower main real box

the lower allowable distance that a surveyed point, found to be in the Main Zone, may be from the 
conformance line, in order to be conformant (refer to parameters Tlmp and Tlmv on the diagram 
above). This value is normally zero or less.

Steep slope tolerances
The following four tolerances are used only if the transition slope is specified, and the design 
slope is steeper than the transition slope.

5 Upper critical real box

refer to parameters Tucp and Tucv on the diagram above. This value is normally zero or greater.

6 Lower critical real box

refer to parameters Tlcp and Tlcv on the diagram above. This value is normally zero or less.

7 Upper main real box

the upper allowable distance that a surveyed point, found to be in the Main Zone, may be from the 
conformance line, in order to be conformant (refer to parameters Tump and Tumv on the diagram 
above). This value is normally zero or greater.

8 Lower main real box

the lower allowable distance that a surveyed point, found to be in the Main Zone, may be from the 
conformance line, in order to be conformant (refer to parameters Tlmp and Tlmv on the diagram 
above). This value is normally zero or less.
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The next tab on the panel is the Report File Tab:

The fields on the Report File Tab have the following functions:

Field Description Type Defaults Pop-Up

Max lines per page integer box 70

the maximum number of report lines that can fit on a printed page. This number is needed so that page 
breaks (form feed characters) can be inserted into the report file at the appropriate places. The number of 
lines per page will vary depending on the editor/word-processor used for printing, the desired page size 
and margin widths, the desired page layout (portrait or landscape), and the desired font and font size. 
As such, the number needs to be tuned for the user’s particular report specifications/requirements. 

Note1: you may find that MS Notepad is not a good program for printing out the report file (Notepad 
doesn’t seem to interpret form feed characters).

Note2: if Max lines per page is set to a large enough number, there will be no page breaks in the 
report file.

Header information

Original survey file input box

optional line of text in the report header to identify the original survey data file
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Lot number input box

optional line of text in the report header to identify the lot number

Lot location input box

optional line of text in the report header to identify the lot location

Lot description input box

optional line of text in the report header to identify the lot description

Table options

Show design levels tick box off

whether to show the design levels in the column after the point levels

Note: the design levels are always vertically above or below the point levels, even if the tolerances 
are measured perpendicular to the design slope.

Show non-conformance errors
tick box off

whether to show the point errors for non-conformant points (i.e. the distances the points are out of 
tolerance). If turned on, the point errors will appear in parentheses, ( =, after the conformance and 
tolerance details.

Show non-conformance slopes
tick box off

whether to show the surveyed slopes at non-conformant points. The surveyed slope is the slope 
between the previous and current point in the report, within a single, offset-sorted chainage band. The 
slope is calculated as though the previous point lies in the same vertical plane as that of the current 
point’s design slope. As such, the slope is adjusted for any differences in bearing direction between the 
two design slopes, and for any incline in the road, as shown in the diagram, below:
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If turned on, the surveyed slopes will appear in square brackets, [ =, after the conformance, tolerance 
and point error details.

Note: if the Chainage bandwidth on the Batters Tab is zero or blank, then the points will only be 
sorted by chainage, and not sub-sorted by offset within chainage bands. In this case, surveyed slopes 
will never be reported.

Footer information

Surveyor name input box

name of the person required to sign the report (optional)

Surveyor title input box

title of the person required to sign the report (optional)

The last tab on the panel is the Results Model Tab:

The fields on the Results Model Tab have the following functions:

Field Description Type Defaults Pop-Up

Clean results model beforehand
tick box off

whether to clean the contents of an existing results model before re-running the option
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Z values are choice box levels levels
conformances
errors

determines what z values to give the points generated in the results model

Note: any untested points in the model will have their z values set to their original point levels, 
regardless.

Vertex text shows choice box conformances levels
conformances
errors

determines what values to show in the vertex text of the points generated in the results model

Note1: any points within tolerance will have a zero error. For these points, if the vertex text is set to 
errors, no text will be set.

Note2: any untested points in the model will have the vertex text set to show one of four possible error 
codes, explaining why the point was not tested. The error codes are NUL (invalid z-value), OCR 
(outside chainage range), ERR (intersection error or similar), and INR (inside road).

Vertex textstyle data textdata box user textdata favourites

controls the appearance of the vertex text for the points generated in the results model

Colours

Points within tolerance colour box green available colours

colour for points within tolerance

Points above tolerance colour box red available colours

colour for points above tolerance

Points below tolerance colour box cyan available colours

colour for points below tolerance

Untested points colour box grey available colours

colour for untested points

Note: untested points do not appear in the conformance report.

Create tin of tested results model points

Tin name tin box available tins

name of the tin to create. If the tin already exists, a prompt will ask if it should be replaced. If this field 
is blank, or if the Results model field (on the Batters Tab) is blank, no tin will be created.

Note: the tin will be created only with the set of tested points created in the Results model, and can be 
used to quickly display contour maps of the results. When creating the tin, an attempt is made to null 
any triangles outside the "shrink-wrapped" boundary of the tested points. The boundary polygon used 
for this nulling procedure is determined from the extremity points of each offset-sorted chainage band 
(see Chainage bandwidth on the Batters Tab).

Model for tin model box available models

model for tin to be placed in, for viewing purposes. If blank, the tin is not placed into a model.

Tin colour colour box available colours

colour for tin. If blank, the tin will adopt the colour selected for Points within tolerance.
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Pavement report
Conformance_Report_Pavement_panel

Position of option on menu: Survey =>Conformance =>Pavement report

The Pavement report option generates a conformance report on surveyed points representing 
the top of an as-built pavement, compared against string data representing the top of a designed 
pavement (level conformance), and compared against tin data representing the bottom of an as-
built pavement (thickness conformance).

In addition to the conformance report, an output results model of the surveyed points can be 
generated, grouping the points by colour into their conformance zones (i.e. within tolerance, above 
tolerance, below tolerance, and not tested). The points in the results model can have z-values and 
vertex text set to show various combinations of point level, point conformance, point error, 
pavement thickness and pavement thickness error.

Note1: the term point conformance is used here to refer to a point’s distance from design (distance 
from the conformance line on diagram below), while the term point error refers to a point’s 
distance out of tolerance. As such, a point that is within tolerance (i.e. a conformant point) will, in 
general, have a non-zero conformance and a zero error, while a point that is out of tolerance (i.e. 
a non-conformant point) will have both a non-zero conformance and a non-zero error.

Note2: the point conformances and errors can be measured either vertically or perpendicular to 
the conformance line. The conformance line is the line from which all point conformances and 
tolerances are measured, and is always parallel to the design pavement line. When testing a sub-
grade survey, the conformance line will normally be below the design pavement line, but when 
testing a completed-construction survey, the two lines should normally coincide.

Note3: the optional pavement thickness measurements are always made vertically downwards 
from the surveyed points, to the tin representing the bottom of pavement. Pavement thickness 
errors will be non-zero wherever the pavement is found to be too thick or too thin. When testing 
for both level conformance and thickness conformance, both tests must pass for a point to be 
considered conformant.
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A typical section of pavement is shown in the diagram below, along with a schematic showing 
how the surveyed points are tested for level conformance:
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Selecting Pavement report brings up the Pavement Conformance Report panel

The first tab on this panel is the Pavement Tab:

The fields and buttons on the Pavement Tab have the following functions:

Field Description Type Defaults Pop-Up

Survey data

Data source of points source box

all points selected with this source box (whether they exist in point-string form or line-string form) 
will be considered as the set of surveyed points to be tested for conformance.

Note: the data for the Point Description column in the report will be taken from the string names of 
the selected points. If all the string names are blank, however, the point description data in the report 
will show point ids representing the sequential order that the points are reported in. The results model 
(if generated) will always have the string names of each point set to match the reported point 
description.

Design data

Control string string box

the string selected with this box should normally represent the road centreline, and will be used to 
determine the chainage and offset of each surveyed point
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Slope control string string box

the Slope control string is optional. If no string is selected, the Control string, above, will be used as 
the Slope control string. The line that is formed in plan, from a surveyed point to the nearest point on 
the Slope control string, defines the vertical plane used to conform that surveyed point. The slope 
formed between the primary and secondary strings on this vertical plane, is the design slope for that 
surveyed point.

Primary string string box

the string selected with this box should represent one edge of the designed pavement (normally the edge 
that is closer to the Control string)

Secondary string string box

the string selected with this box should represent the other edge of the designed pavement (normally the 
edge that is further away from the Control string).

Note: If the selected string is the same as the Primary string, or if no string is selected, then the 
pavement is defined by one string and is considered to be flat (i.e. zero cross-fall), and to have a width 
defined by the Primary and Secondary edge offsets (on the Tolerances Tab). This feature can be 
useful for identifying any surveyed points that are close to an edge line.

Data for thickness measurements

Bottom of pavement tin tin box available tins

the Bottom of pavement tin is optional. If not selected, the pavement is not tested for thickness 
conformance. The tin selected with this box should represent the as-built bottom surface of the 
pavement currently being tested.

Constraints

Start chainage real box

the start chainage of the surveyed points to be conformed. Any point with a chainage less than the start 
chainage will not be tested. By default, the start chainage is set when the Control string is selected, but 
a different value can be typed in.

End chainage real box

the end chainage of the surveyed points to be conformed. Any point with a chainage greater than the 
end chainage will not be tested. By default, the end chainage is set when the Control string is selected, 
but a different value can be typed in.

Chainage bandwidth real box 5.0

if zero or blank, the surveyed points are simply sorted in ascending chainage order. However, if a value 
greater than zero is entered, the surveyed points will also be sub-sorted into chainage bands, in 
ascending offset order. Within each chainage band, the difference between the maximum and minimum 
chainage will be less than the Chainage bandwidth. This is a useful feature if the surveyed points are 
set out in rows of roughly equivalent chainage.

Results

Report file file box *.rpt

the name of the conformance report file to be created. If no extension is given, it will be given an 
extension of .rpt.

Results model model box available models

the name of the results model to be created. If blank, the results model is not created.
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Buttons

Report button

generates the conformance report file and the results model. This button can be activated regardless of 
which panel tab is currently active.

Finish button

exits the option and closes the panel. This button can be activated regardless of which panel tab is 
currently active.

The next tab on the panel is the Tolerances Tab:

The fields and buttons on the Tolerances Tab have the following functions:

Field Description Type Defaults Pop-Up

Tolerance file file box *.tol

the name of the tolerance file used to load and/or save the details of the conformance. If no extension is 
given, it will be given an extension of ".tol". The tolerance file stores the details of every field on the 
Tolerances Tab, the Report File Tab, and the Results Model Tab. The tolerance file itself is not 
required to run a conformance test - it is merely provided as a convenience.

Read button

Pressing this button will populate the panel fields on the last three panel tabs, with the data stored in 
the tolerance file. If data for a particular field is not found, that field remains unaffected.
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Write button

Pressing this button will create a new tolerance file or replace an existing one. The contents of all non-
blank fields on the last three panel tabs, are written to the file at this time.

Sub-grade depth from design pavement

Depth is measured choice box vertical perpendicular to pavement
vertical

whether the sub-grade depth is measured perpendicular to the pavement or vertically (refer to 
parameter D on the diagram above)

Note: since pavements typically have cross-fall slopes of less than 7%, the value of this setting should 
make very little difference to the results.

Sub-grade depth real box 0.0

the depth of the conformance line from the design pavement (refer to parameter D on the diagram 
above). If testing a sub-grade survey, this value will normally be greater than zero. If testing a 
completed-construction survey, however, this value will normally be zero, and the conformance line 
will coincide with the design pavement line.

Pavement edge details

Points outside pavement choice box do not test do not test
test with zero tolerance
test with normal tolerance

determines what to do with any surveyed points found outside the pavement. If such points are found, 
and this field is set to do not test, the points will be classified as untested, and in the results model, 
will have their vertex text set to EDG.

Note: untested points do not appear in the conformance report.

Primary edge offset real box 0.0

the amount to horizontally increase or decrease the width of the design pavement at the Primary 
string edge (refer to parameter P on the diagram above). A negative value decreases the width, which is 
the more common case, since surveyed points near a pavement edge are normally ignored for the 
purposes of conformance.

Secondary edge offset real box 0.0

the amount to horizontally increase or decrease the width of the design pavement at the Secondary 
string edge (refer to parameter S on the diagram above). A negative value decreases the width, which is 
the more common case, since surveyed points near a pavement edge are normally ignored for the 
purposes of conformance.

Tolerance details

Tolerances measured choice box vertical perpendicular to pavement
vertical

whether the conformance tolerances are measured perpendicular to the pavement or vertically (refer to 
parameters Tu and Tl on the diagram above). This field also determines whether the reported point 
conformances and point errors are measured perpendiculary or vertically.

Note: since pavements typically have cross-fall slopes of less than 7%, the value of this setting should 
make very little difference to the results.

Upper tolerance real box

the upper allowable distance that a surveyed point may be from the conformance line, in order to be 
conformant (refer to parameter Tu on the diagram above). This value is normally zero or greater.



Chapter 16  Survey

April 2007 Page 1537Conformance

Lower tolerance real box

the lower allowable distance that a surveyed point may be from the conformance line, in order to be 
conformant (refer to parameter Tl on the diagram above). This value is normally zero or less.

Thickness details

Maximum thickness real box

the maximum allowable vertical distance that a surveyed point may be above the Bottom of pavement 
tin, in order to be conformant. If blank, there will be no upper limit to the pavement thickness.

Minimum thickness real box

the minimum allowable vertical distance that a surveyed point may be above the Bottom of pavement 
tin, in order to be conformant. If blank, there will be no lower limit to the pavement thickness.

The next tab on the panel is the Report File Tab:

The fields on the Report File Tab have the following functions:

Field Description Type Defaults Pop-Up

Max lines per page integer box 70

the maximum number of report lines that can fit on a printed page. This number is needed so that page 
breaks (form feed characters) can be inserted into the report file at the appropriate places. The number of 
lines per page will vary depending on the editor/word-processor used for printing, the desired page size 
and margin widths, the desired page layout (portrait or landscape), and the desired font and font size. 
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As such, the number needs to be tuned for the user’s particular report specifications/requirements. 

Note1: you may find that MS Notepad is not a good program for printing out the report file (Notepad 
doesn’t seem to interpret form feed characters).

Note2: if Max lines per page is set to a large enough number, there will be no page breaks in the 
report file.

Header information

Original survey file input box

optional line of text in the report header to identify the original survey data file

Lot number input box

optional line of text in the report header to identify the lot number

Lot location input box

optional line of text in the report header to identify the lot location

Lot description input box

optional line of text in the report header to identify the lot description

Table options

Show design levels tick box off

whether to show the design levels in the column after the point levels

Note: the design levels are always vertically above or below the point levels, even if the tolerances 
are measured perpendicular to the design slope.

Show non-conformance errors
tick box off

whether to show the point errors and thickness errors for non-conformant points (i.e. the distances 
the points are out of level and thickness conformance, respectively). If turned on, the point errors will 
appear in parentheses, ( ), after the conformance and tolerance details, and the thickness errors will 
appear in parentheses, ( ), after the thickness and max/min thickness details.

Footer information

Surveyor name input box

name of the person required to sign the report (optional)

Surveyor title input box

title of the person required to sign the report (optional)
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The last tab on the panel is the Results Model Tab:

The fields on the Results Model Tab have the following functions:

Field Description Type Defaults Pop-Up

Clean results model beforehand
tick box off

whether to clean the contents of an existing results model before re-running the option

Z values are choice box levels levels
conformances
errors
thicknesses
thickness errors

determines what z values to give the points generated in the results model

Note: any untested points in the model will have their z values set to their original point levels, 
regardless.

Vertex text shows choice box conformances levels
conformances
errors
thicknesses
thickness errors
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determines what values to show in the vertex text of the points generated in the results model

Note1: any points that pass the level conformance test will have a zero error. For these points, if the 
vertex text is set to errors, no text will be set. Likewise, any points that pass the thickness conformance 
test will have a zero thickness error. For these points, if the vertex text is set to thickness errors, no 
text will be set.

Note2: any untested points in the model will have the vertex text set to show one of five possible error 
codes, explaining why the point was not tested. The error codes are NUL (invalid z-value), OCR 
(outside chainage range), ERR (intersection error or similar), EDG (outside pavement edge), and 
NTN (bottom of pavement tin not defined at point).

Vertex textstyle data textdata box user textdata favorites

controls the appearance of the vertex text for the points generated in the results model

Colours

Points within tolerance colour box green available colours

colour for points within tolerance (i.e. points that pass both the level and thickness conformance tests)

Points above tolerance colour box red available colours

colour for points above tolerance (i.e. points that are above the Upper tolerance or points where the 
pavement is thicker than the Maximum thickness)

Points below tolerance colour box cyan available colours

colour for points below tolerance (i.e. points that are below the Lower tolerance or points where the 
pavement is thinner than the Minimum thickness)

Untested points colour box grey available colours

colour for untested points

Note: untested points do not appear in the conformance report.

Create tin of tested results model points

Tin name tin box available tins

name of the tin to create. If the tin already exists, a prompt will ask if it should be replaced. If this field 
is blank, or if the Results model field (on the Pavement Tab) is blank, no tin will be created.

Note: the tin will be created only with the set of tested points created in the Results model, and 
(depending on what the points’ z-values are set to in the Results model) can be used to quickly display 
contour maps of the results, or to create a Bottom of pavement tin for the next pavement layer to be 
tested. When creating the tin, an attempt is made to null any triangles outside the "shrink-wrapped" 
boundary of the tested points. The boundary polygon used for this nulling procedure is determined 
from the extremity points of each offset-sorted chainage band (see Chainage bandwidth on the 
Pavement Tab).

Model for tin model box available models

model for tin to be placed in, for viewing purposes. If blank, the tin is not placed into a model.

Tin colour colour box available colours

colour for tin. If blank, the tin will adopt the colour selected for Points within tolerance.
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Extras
survey_extras

Position of menu: Survey =>Extras

The extras walk-right menu contains extra survey options. some of which are still being 
developed.

The extras walk-right menu is

.

For the option Auslig AusGeoid98 *.dat ->xyz, go to the section “AusGeoid98 *.dat -> xyz” 
Bearing/Distance entry “Plane Bearing/Distance Entry” 
Traverse/Radiation “Bearing/Distance Entry for Traverse/Radiation” 
Catenary measurement “Catenary Measurement” 
Create Control Station “Create Control Stations” 
Check control model “Check Control Model” 
Linear regression “Linear Regression” 
Reduction to field file “Survey Function to Field File” 
On grade “On Grade” 

Convert AusGeoid98 file into XYZ format
entry and edit by plane bearing and plane distance
bearing distannce entry to produce traverse or radiations
create points in a vertical plane
create control stations
check unique point id in control model
Linear regression
write out a field file from a survey function
create an on-grade string
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AusGeoid98 *.dat -> xyz
auslig_ausgeoid98___dat____xyz

Position of option on menu: Survey =>Extras =>Auslig AusGeoid98 *.dat->xyz

The Ausgeoid98 *.dat -> xyz option allows the conversion of a standard AusGeoid98 *.dat file 
into a XYZ format. This format can then be read into 12d. The values in the XYZ file will have the 
following meaning

X value will represent the Longitude

Y value will represent the Latitude

Z value will represent the N value

Selecting Ausgeoid98 *.dat -> xyz brings up the Ausgeoid98 *.dat -> xyz panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Input file file box *.dat

this filename of the AusGeoid file. The .dat extension is added by default.

Output file file box

this filename of the XYZ file to be produced.

Ignore header tickbox ticked

 if ticked, the first line in the *.dat file is ignored (usually the header)

Convert button

convert the file.

For more information about terminology used in this option, see the Appendix “Geodetics 
Summary” .
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Plane Bearing/Distance Entry
bearing_distance_entry

Position of option on menu: Survey =>Extras =>Bearing/distance entry

The bearing/distance entry option allows the input of a traverse by manual input of plane 
bearings and plane distances or by selecting an existing string.

Selecting Bearing/distance entry brings up the Bearing/Distance Entry panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Name name box defined names from
names.4d file

this field is optional. If non-blank, the name of the new string.

Model model box available models

 if non-blank, the model of the new string. If blank, the original string model is used.

Colour colour box red available colours

 if non-blank, the colour of the new string. If blank, the original string colour is used.

Linestyle input 1 available line styles

line style of the string.

Scale factor input projection scale

This value will be applied to any entered distances. i.e. final distance = entered distance * scale factor
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The scale factor could be a point scale factor, a line scale factor or a combined scale factor.
The final distance will be used for coordinate calculations.

Use z- value tick box transit

if tick, the z-values for each point can be entered.
If no tick then z-values are not entered.

Point id input typed none, auto increment, typed

if none, no point ids are entered and the grid control will not show a column for point ids. 

If auto increment then the values of point ids will be incremented by a value of 1 starting from the 
specified Start point id. If no Start point id is specified then no point ids will be allocated. No 
column for point ids is shown in the grid control.

if typed then the values of point ids will be incremented by a value of 1, starting from the specified 
Start point id. If no Start point id is specified then no point ids will be allocated unless a value is 
entered in the grid control on which time the next value in the grid will have a incremented value. The 
column for point ids is shown in the grid control.

VALUES IN GRID grid box

The columns shown in the grid will depend on the selection of the Use z- value and Point id fields.

To Pt. input

if none is selected for the Point id field, this column will not be displayed.

if auto increment is selected for the Point id field, this column will not be displayed.

if typed is selected for the Point id field, this column will be displayed. In this case, the point id will 
increment automatically by entering over the field. I f a new value is typed into the To Pt. field, the next 
line will increment from that number.

Bearing (dms) angle box

The user should enter the bearing for the segment into this field.

Distance input box

the user should enter the distance of the segment.

Height input box

This column will only be visible in the grid if the Use z- value tickbox has been ticked. The user should 
enter the height of the point. This value will not be used for calculation of the segment. It will simply be 
assigned to the newly created vertex.

Select button

on pressing the select button, a user is able to pick an existing string from the current view.    If a non-
traverse type string is selected an option to convert it to a traverse string will be given. The grid 
control will be filled with the relevant information for the traverse string. 

If a traverse string has been modified by some other process (e.g. move) an option will be given to adopt 
the new characteristics of the string as displayed or revert back to the information that originally 
defined the traverse string. Depending on which option is selected, the grid will be filled with the 
relevant information. 
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Process button

changes to the traverse can be made in the grid control for lines already defined. For example, a distance 
entry may be incorrectly typed in and edited some time later. By using the process button the traverse 
string is re-calculated using the current values in the grid control.
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Bearing/Distance Entry for Traverse/Radiation
bearing_distance_traverse_radiation_entry

Position of option on menu: Survey =>Extras =>Traverse/Radiation

The Traverse/radiation option allows the input of a traverse or radiations by manual input of 
plane bearings and plane distances or by selecting an existing string.

Bearing/Distance Traverse/Radiation Entry

Selecting Traverse/Radiation brings up the Bearing/Distance Traverse/Radiation Entry panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Name name box defined names from
names.4d file

this field is optional. If non-blank, the name of the new string/strings.

Model model box available models

 if non-blank, the model of the new string. If blank, the original string model is used.

Colour colour box red available colours

 if non-blank, the colour of the new string. If blank, the original string colour is used.

Linestyle input 1 available line styles

line style of the string.

Scale factor input projection scale



Chapter 16  Survey

April 2007 Page 1547Extras

This value will be applied to any entered distances. i.e. final distance = entered distance * scale factor
The scale factor could be a point scale factor, a line scale factor or a combined scale factor.
The final distance will be used for coordinate calculations.

Start point coords xyz pick box

coordinates of the first point. The bearing/distances start from this point.

Start point id input

if Point ids is auto increment, point id of the first point.

Point id input typed none, auto increment, typed

if none, no point ids are entered and the grid control will not show a column for point ids. 

If auto increment then the values of point ids will be incremented by a value of 1 starting from the 
specified Start point id. If no Start point id is specified then no point ids will be allocated. No 
column for point ids is shown in the grid control.

if typed then the values of point ids will be incremented by a value of 1, starting from the specified 
Start point id. If no Start point id is specified then no point ids will be allocated unless a value is 
entered in the grid control on which time the next value in the grid will have a incremented value. The 
column for point ids is shown in the grid control.

Use z- value tick box

if tick, the z-values for each point can be entered.
If no tick then z-values are not entered.

Radiation tick box

if tick, the bearing distances are used to create points that are radiations from the start point.
If no tick the bearing/distances are used to create a traerse string beginning at the start point.

VALUES IN GRID grid box

The columns shown in the grid will depend on the selection of the Use z- value and Point id fields.

To Pt. input

if none is selected for the Point id field, this column will not be displayed.

if auto increment is selected for the Point id field, this column will not be displayed.

if typed is selected for the Point id field, this column will be displayed. In this case, the point id will 
increment automatically by entering over the field. I f a new value is typed into the To Pt. field, the next 
line will increment from that number.

Bearing (dms) angle box

The user should enter the bearing for the segment into this field.

Distance input box

the user should enter the distance of the segment.

Height input box

This column will only be visible in the grid if the Use z- value tickbox has been ticked. The user should 
enter the height of the point. This value will not be used for calculation of the segment. It will simply be 
assigned to the newly created vertex.
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Select button

on pressing the select button, a user is able to pick an existing string from the current view.    If a non-
traverse type string is selected an option to convert it to a traverse string will be given. The grid 
control will be filled with the relevant information for the traverse string. 

If a traverse string has been modified by some other process (e.g. move) an option will be given to adopt 
the new characteristics of the string as displayed or revert back to the information that originally 
defined the traverse string. Depending on which option is selected, the grid will be filled with the 
relevant information. 

Process button

changes to the traverse can be made in the grid control for lines already defined. For example, a distance 
entry may be incorrectly typed in and edited some time later. By using the process button the traverse 
string is re-calculated using the current values in the grid control.

Catenary Measurement
catenary_measurement

Position of option on menu: Survey =>Extras =>Catenary measurement

The Catenary measurements option allows for the picking up of data in the vertical plane 
between two known points using only a bearing and a vertical angle. For example, picking up 
wires between towers where a distance measurement to the cable is not possible.

Selecting Catenary measurements brings up the Catenary Measurements panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Instrument setup

Coords xyz box

the xyz coordinates of the instrument.

Id input box

the vertex id (point id) of the instrument.
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Height input box

the height of the instrument.

1st Attachment

Coords xyz box

the xyz coordinates of the attachment point of the cable on the first tower.

Id input box

the vertex id (point id) of the first tower.

2nd Attachment

Coords xyz box

the xyz coordinates of the attachment point of the cable on the second tower.

Id input box

the vertex id (point id) of the second tower.

Reading

Horizontal angle correction angle box

angle to be subtracted from the Horizontal Angle reading to give true bearing.

Reading No input box

number for the reading.

Horz. Angle angle box

Horizontal Angle reading. The Horizontal angle correction is subtracted from this to give the true 
bearing.

Vert. Angle angle box

Vertical Angle reading.

Results

Create string tick box ticked

 if ticked, a string of the observed points is created.

Name input box

name of the created string.

Model model box available models

name of the model for the created string.

Colour colour box red available colours

the colour of the created string.

Linestyle input 1 available linestyles

linestyle of the created string.

Report file file box *.rpt files

 if non-blank, the name of the file to write the report to.

Process button

reduce the angle readings.
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Create Control Stations
create_control_stations

Position of option on menu: Survey =>Extras =>Create Control stations

Position of option on menu: Strings =>Create =>Create Control Stations

A control station (for surveying) consists of a one point string. For V6, the point name is the name 
of the control station. For V5 and before, the string name is used as name of the control station.

Control stations are used when reducing 12d field files in the Survey Reduction module.

The Create Control Stations options allows the user to define control stations in a given model. 
The option checks that the point ids are unique in the control model.

Selecting Create Control Stations brings up the Create Control Station panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model model box available models

name of the model for the control stations.

Colour colour box red available colours

the colour of the new control stations.

Line style input 1 available line styles

line style of the control station.

Use z-value tick box ticked

 if ticked, the height value must be specified for all of the stations.

Use point id as control point name tick box ticked
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 if ticked, the point names are used as the names of the control points and the point names are checked 
for uniqueness.
If not ticked, the name of the string is used as the names of the control points and the string names are 
checked for uniqueness. This is only for compatibility in pre 12d Model V6.0.

Station name Easting Northing Height Remark

the information for stations to be created is entered into the grid. The stations are created by selecting 
the Process button.

If a station name is typed in and the <enter> key pressed then the Model is searched and if a control 
station already exists of the same name (either point name or string name depending on the Use point 
id as control point name flag), the co-ordinates are displayed in the grid.

The grid control values can be entered/displayed using valid inputs into the various fields. 

Station name. The associated text that identifies the control point.
Easting The easting coordinate of the control point.
Northing The northing coordinate of the control point.
Height The height of the station. (Only displayed if the use z-value tickbox is selected.)
Remark The description of the control station.

Process button

After the Process button is chosen, the control stations in the grid are created. If a station of the given 
name already exists in the control Model, the user is asked if the co-ordinates of the station are to be 
updated by the values given in the grid.

Same as button

After the Same as button is chosen, another string is selected and information about it is used for the 
Model, Colour and Point style fields in this panel.

Check Control Model
check_control_model

Position of option on menu: Survey =>Extras =>Check Control model

The Check control model option checks that there are no points in the control model with the 
same point id. A report of all the points in the control models, or only those with clashing point 
ids, is created.

Selecting Check control model brings up the Check Control Model panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Control model model box available models

 the model the check for unique point ids.
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Report file file box *.rpt files

 if non-blank, the name of the file to write the report to.

Report only duplicated point(s)tick box ticked

 if ticked, only those points with duplicated point ids are reported.
If not ticked, all points in the control model are written out.

Process button

check the Control model for duplicated point ids.
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Linear Regression
linear_regression

Position of option on menu: Survey =>Extras =>Linear regression

The linear regression option will create a line, circle or arc of best fit through points on a string. 
The line can be constrained to go through a selected point or have a given bearing.

Selecting linear regression brings up the linear regression panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Regression for choice box line line, circle, arc

 if line/circle/arc, the line/circle/arc of best fit through the points is created.

Constraints tick box

if tick, the regression line can be restrained to go through a selected point or be given a selected bearing.

Keep z-values tick box tick

if tick, the z-values of the selected string are used on the regression string.

Create new string tick box tick

if tick, a new adjusted string is created. If not tick, the selected string is adjusted.

Constraints

Thro point tick box

if tick, the regression line is constrained to go through the point with co-ordinates given in the 
Coordinates field.

Coordinates

if thro point is ticked, the regression line is constrained to go through the point given in this field.
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Fixed bearing tick box

if tick, the regression line is constrained to have the bearing given in the Bearing value field.

Bearing value

if thro point is ticked, the regression line is constrained to have the bearing given in this field.

Name name box

 if non-blank, the name of the new string. If blank, the original string name is used.

Model model box available models

 if non-blank, the model of the new string. If blank, the original string model is used.

Colour colour box available colours

 if non-blank, the colour of the new string. If blank, the original string colour is used.

Report file *.rpt files

 if non-blank, a report for the adjustment is created with this name. If non-blank, no report is created.

Partial tick box

if tick, only part of the string is used in the regression.

Pick button

select the string to create a regression line/circle/arc from.

Regression button

perform the regression.

Survey Function to Field File
survey_reduction_function_export

Position of option on menu: Survey =>Extras =>Reduction to field file

The reduction to field file option writes out the field data from a Survey function to a file in the 
standard 12d field file format.

Selecting reduction to field file brings up the survey reduction function export panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input available Survey functions
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name of the 12d Survey function to write out a 12d field file for.

Field file input *.fld

name of the 12d field file to write out the Survey field data to.

Export button

create the 12d field file.

On Grade
on_grade_string

Position of option on menu: Survey =>Extras =>On grade

The on grade option produces a string that is a fixed horizontal distance from a selected string 
with z-values produced by extrapolating the grade from two strings or from a tin.

Selecting On grade brings up the On Grade String panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Primary string string select

string to produce the on grade string from

Horizontal offset input

horizontal distance to offset the on grade string from the primary string

Vertical offset input
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vertical distance to offset the on grade string from the primary string

Search distance input

Control string string select

if selected, the horizontal distance is measured at right angles to the control string. In this case, the 
on-grade may not be parallel to the primary string.
If not selected, the horizontal distance is measured at right angles to the primary string.

String points choice box Primary string points
Chainage interval
Special chainage file

if Primary string points, the on-grade string has vertices on it where ever there is a vertex on the 
primary string. Extra points will also be include for the given arc tolerance. 

Arc tolerance input

if non zero, chord to arc tolerance to use for adding additional vertices

Use proper parallel tick box

if tick, the primary string is parallelled to from the on-grade string

If Chainage interval, vertices are created on the on-grade string corresponding to the given chainage 
interval along the primary/control string.

Interval input

the chainage interval the use along the primary/control string for creating on-grade vertices.

If Special chainage file, vertices are created on the on-grade string from chainages on the primary or 
control string, corresponding to the special chainages file.

Special chainages file box .spc files

the chainage interval the use along the primary/control string for creating on-grade vertices.

Grade control choice box Secondary string
Tin

if Secondary string, the grade to use to create z-values on the on-grade string is the grade between the 
secondary string and the primary string.

Secondary string string select

the grade to use is taken from the secondary to the primary string

If Tin, .

Tin tin box

the tin to use

Offset input

the offset.

Results model model box available models

the model for the created on-grade string

Run button

create the on grade string
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Setout
setout

Position of menu: Survey =>Setout

Options still under development.

The setout walk-right menu contains options for creating points numbers and files for uploading 
to data recorders.

The setout walk-right menu is

.

For Create centres of string curves, go to the section “Create Centre Points for Curves of Strings” 
Create x,y,z,text of centres of HIPs “Create X Y Text for Centre Points of Alignments” .
Setout lip line “Setout Lip Line” .
Setout points  “Create Setout Points” .
Setout points using super string  “Create Setout Points Using Super String” .

setout centres of string curves
create text at centre of HIP’s
setout lip line
create setout points
Create setout points using super strings
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Create Centre Points for Curves of Strings
create_centre_points_for_curves_of_strings

Position of option on menu: Survey =>Setout =>Create centres of string curves

This option is used to create points at the centres of arcs in alignment strings, polylines, arcs or 
circles.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

data source for strings to process

Model for centre points input box

model for the created points

Colour colour box available colours

colour of centre points

Create button

create the points
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Create X Y Text for Centre Points of Alignments
mark_centre_panel

Position of option on menu: Survey =>Setout =>Create x y text of centres of HIPs

This option creates text for the x and y co-ordinates of the horizontal arcs on an alignment string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model for text input box

model for the text of the x and y co-ordinates 

Text size (w) input box

size of text in world units.

Text colour input box

colour of text

Pick a string button

select string to create text for.
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Setout Lip Line
qtrpts_panel

Position of option on menu: Survey =>Setout =>Setout lip line

This panel is used to create bubbles and/or a report for the critical horizontal and vertical points 
and quarter points (by chord or by chainage) for any arcs in an alignment string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Select a lip string string select

pick the alignment string to have bubbles created for.

Select point type:

hcp tick box

if tick, the horizontal tangent points are included.

vcp tick box

if tick, the vertical tangent points are included.

Quarter point type:

Chord tick box tick

if tick, the quarter points by chord distance are included.

Chainage tick box

if tick, the quarter points by chainage distance are included.

Report file input box

name of the report file.

Create bubbles tick box tick

if tick, bubbles are created with the string name and bubble number inside.
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Model for bubbles/text input box

model for the bubbles and text.

Text size (w) input box

size (in world units) for the text inside the bubble.

Colour for text input box

Colour for the bubble and bubble text.

Bubble offset input box

offset distance from the alignment string to place the bubble.

Process button

run the option.
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Create Setout Points
setout_panel

Position of option on menu: Survey =>Setout =>Setout points

This panel is used to create points with numbers for use in setting out data. This option is usually 
run before the option to create an instrument upload file. The setout point is created as a 4d 
string with the point at the data point and with the point id as the text for the 4d string, with a 
text size of zero.

Separate text for the numbers and circles surrounding the data points and the text numbers are 
also created. By default, a file called "defaults.sof" is read in containing settings required for the 
option.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Textstyle input box 1

textstyle for the created point ids

Model for setout points input box 0

model to place the setout points in

Model for points labels input box 0 

model to place the setout point ids and circles in.

Individual points tick box
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if tick, the setout points are created as point strings
If not tick, individual one point strings are created.

Use super strings tick box tick

if not tick, super strings are created for the setout points. The super string point id is set to the setout 
point id.
If not tick, 4d strings are created for the setout points strings with the 4d text as the setout point id 
(with text size set to zero).

The next number input box 1 or highest number in model for setout points

next numeric point id to use for creating point ids. If a Model for setout points is given, the model is 
searched for any super strings or 4d strings with numbers as text and the The next number is set to 
one more than the highest numeric point id in the model.

Reset button

reset the The next number to the highest point in the model for setout points.

Data to label input box string string, model, view, point

type of data source.

Model/View/String/Point to output box

data to create point ids for.

Many points/strings tick box tick

if tick, the each time a string/point is selected, the string/point is processed without having to click on 
the Label button. After a string/point is processed, another string/point can then be selected.
If not tick, the Label button must be clicked before the selected string/point is processed.

Label button

create setout points and circles for the selected data.

Undo button

undo the last setout points and s created whilst the panel has been up.

Default settings button

default settings for the s. These can be read in from a file.



Chapter 16  Survey

April 2007 Page 1565Setout

Create Setout Points Using Super String
super_setout_panel

Position of option on menu: Survey =>Setout =>Setout points using super string

This panel is used to create points with numbers for use in setting out data. This option is usually 
run before the option to create an instrument upload file
.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Not yet documented.
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Upload
survey_upload

Position of menu: Survey =>Upload

The Survey Upload walk-right menu contains survey options to upload data the most survey 
instruments. There are options to upload points, triangulations and road geometry.

The Survey Upload walk-right menu is

.

For the option Create triangle upload file go to “Create Triangle Upload File” 
Create points upload file “Create Points Upload File” 
Create road upload file “Create Road Upload File” 
Create points upload file (new) “Create Points Upload File (New)” 
Create road upload file (new) “Create Road Upload File (New)” 
Upload “Survey Data Upload” 

Create triangle upload file
Create points upload file
Create roads upload file
Create points upload file (new) - only for Trimble Link
Create roads upload file (new) - only for Leica XML and Trimble Link
Upload data to instrument/device



Chapter 16  Survey

April 2007 Page 1567Upload

Create Triangle Upload File
create_triangle_upload_file

Position of option on menu: Survey =>Upload => Create triangle upload file

The Create triangle upload file option allows the creation of a triangle file based on a tin. 
Various file formats can be selected

Selecting Create triangle upload file brings up the Create triangle upload file panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Common parameters at bottom:

Tin input

name of tin from which the triangle file will be based.

Tin polygon selection selection

allows the user to select a specific area of the tin to be exported as a triangle file.

Write button

On clicking the write button, 12d Model will write the specified file.

File type choice box Trimble binary *.ttm

Leica DTM *.gsi
12d xyzs *.dat
Ortho 12d *.T12
Sokkia *.tri
TP Setout/Stakeout *.tsa
LandXML *.xml

file type to be produced.

For Trimble *.ttm format:
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.

Use Trimble Link tick box

if tick, Trimble Link is used to create the data

Upload directly to Trimble device tick box

if tick, the data is uploaded to the Trimble instrument

Job name input

Trimble job name

TTM output file input

name of file to be produced.

For Leica DTM *.gsi format:

.

Job id input

job id to be included in file. (max 8 characters)

Leica output file input

name of file to be produced

Easting offset input

easting offset to be applied to data. This is important where large coordinate values are used, such as in 
map projections.

Northing offset input

northing offset to be applied to data. This is important where large coordinate values are used, such as 
in map projections.

For 12D xyzs *.dat format:

.
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12d output file input

name of file to be produced

For Ortho 12d *.T12 format:

.

Ortho 12d output file input

name of file to be produced

For Sokkia *.tri format:

.

Sokkia output file input

name of file to be produced

For TPSetout/Stakeout *.tsa format:

.

Tp Setout/Stakeout file input

name of file to be produced

For TPSetout/Stakeout *.tsa format:

.

LandXML file input

name of file to be produced
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Create Points Upload File
instrument_points_upload_panel

Position of option on menu: Survey =>Upload => Create points upload file

The Create points upload file option allows the creation of a file of point ids, x, y and z, for 
string data (super strings and 4d strings only). Various file formats can be selected

Selecting Create points upload file brings up the Create Instrument Points Upload File 
panel.

Upload files for points can be created for various Leica, Geodimeter, Sokkia, Topcon, UPL, 
QuikDraw, Trimble XYZ formats as well as a text file of point id, x,y,z data.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Instrument choices choice box report_xyz available instruments

type of output format

Output z values tick box

if tick, z-values are output - only used for Geodimeter formats

Create new job on SDR 33 tick box

if tick, create a new job on SDR33 - only used for Sokkia formats

Left justify fields tick box
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if tick, each field is left justified - only used for Sokkia formats

User definable terminator input box &

terminator to use - only used for Geodimeter formats.

Default char for blank name input box z

character used for blank names - only used for Geodimeter formats.

Data source of setout points Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

data source of setout points to create the upload file from.

Number of decimal places input box 3

number of decimal places for x, y and z values.

Default for null value input box -9999

value to write for null z-values.

Start point id input box

point id to start creating upload file from.

End point id input box

last point id to write to upload file.

Note: Start and End point ids may be left blank, and all point ids (whether numeric or alpha-numeric) will 
be written to the upload file.

Origin x/Origin y input box

If non-zero, subtract the value from the x/y value before writing out.

Upload file file box

name of the upload file to create.

Get Point Range button

pressing this button will populate the Start and End point id fields with the minimum and maximum 
(numeric) point ids found in the selected source data. If the selected source data contains a mix of 
numeric and alpha-numeric point ids, the alpha-numeric point ids are considered to have a numeric 
value of zero (0), but are ignored when determining the range. If the selected source data contains 
alpha-numeric point ids only, then the Start and End point id fields will both be set to zero (0).

Write File button

create the upload file



12d Model Reference Manual

Page 1572 April 2007Upload

Create Road Upload File
instrument_roads_upload_panel

Position of option on menu: Survey =>Upload => Create roads upload file

The Create roads upload file option allows the creation of a specific roading file. Files can be 
created for various Leica (8 & 16 formats), Geodimeter, Sokkia, Topcon and Trimble Roading 
formats.

Selecting Create road upload file brings up the Create Roading Upload File panel

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Instrument choices choice box Geodimeter Roadline 3d

Leica Road Plus 8
Leica Road Plus 16
LMGS - D45

Sokkia Roading - Alignment Road
Sokkia Roading - String Road

Topcon MS2000
Topcon GTS-700 Roads
Trimble Roading

For choice of Geodimeter Roadline 3d, go to the “Geodimeter Roadline 3D file” 
Leica Road Plus 8 “Leica road plus 8 / 16 file” .
Leica Road Plus 16 “Leica road plus 8 / 16 file” .
LMGS - D45 file “LMGS - D45 file” .
Sokkia Roading - Alignment road “Sokkia Roading - Alignment Road file” .
Sokkia Roading - String road “Sokkia Roading - String Road file” .
Topcon MS2000 “Topcon MS2000 Roading file” .
Topcon GTS-700 Roads “Topcon GT700 Roading File” .
Trimble Roading “Trimble Roading File” .

Geodimeter Roadline 3D file
Position of option on menu: Survey =>Upload => Create roads upload file, Instrument choice = 
Geodimeter Roadline 3d

The Geodimeter Roadline 3d option allows the creation of a specific roading file. 

Selecting Geodimeter Roadline 3d brings up the Report Geodimeter Roadline 3D panel
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The Geodimeter (trimble), has certain limitations and criteria associated with the 3d file. These 
include:

1. Each section template (i.e. right or left) has a max number of 12 points.

2. The first and last segments of the alignment must be a straight (for both horizontal and 
vertical).

3. The start and end chainages of the horizontal alignment should be the same for the vertical 
alignment.

4. The alignment string must exist on the xsec’s. This allows the calculation of the "zero pt" so 
we can split the section into left and right templates.

5. The xsec model should be representative of the alignment string used in the macro. i.e. not 
generated from a different alignment. Therefore the alignment string should have a 0 offset 
on the xsections.

6. The alignment string cannot exist above or below the xsection. I.e. it should be on the section 
as per 4)

7. The number of points on assuasive section templates (left and right) should be the same. i.e. if 
5 points are on the LHS template for ch0 then the same number of points should exist for the 
LHS template for ch20. The instruments using this file, cannot handle transitions between 
different number of points effectively and can give incorrect results. The user should limit the 
file by using the chainage range between areas where the number of points on each side of the 
cross sections is the same. 

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Select H-Align Select box

select valid alignment string.

Report vertical alignment tick box no

write vertical alignment details to file mode. If yes vertical alignment details written to the specified 
file.

Report cross sections tick box no
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if selected, the cross section model box will be enabled.

Cross section model model box

 This will ask for the model of cross sections. These sections will be written out to the file.

XSec start ch input box min alignment ch

chainage value to start writing cross sections.

XSec end ch input box max alignment ch

chainage value to end writing cross sections.

Ignore points on RHS/LHS sections >12

tick box ticked

if ticked, where there are more than 12 points in either the RHS or LHS template (derived from the 
xsection) the outlying points are ignored. e.g. if there was 14 points on the RHS template, only 12 will 
be written to the file with 2 pts being ignored. 

File name input box

the name to be used for file creation

Write button

write appropriate files.

Leica road plus 8 / 16 file
Position of option on menu: Survey =>Upload => Create roads upload file, Instrument choice = 
Leica roadplus 8 or Leica roadplus 16

The Leica roadplus 8 and Leica roadplus 16 options allow the creation of specific Leica roading 
files. 

Selecting Leica roadplus 8 brings up the Report Leica roadplus 8 panel.
Selecting Leica roadplus 16 brings up the Report Leica roadplus 16 panel.

The 8 and 16 formats are different file formats for the leica range of instruments. The user should 
be aware of the required format for the particular instrument. Please refer to the Leica documen-
tation for specifications

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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Job id input box

job id (max 8 characters).

Select alignment String select box

select valid alignment string.

Report vertical alignment tick box no

write vertical alignment details to file mode. If yes vertical alignment details written to appropriate file. 
i.e. (PRF*****.gsi)

Report cross sections tick box no

if selected, the cross section model box will be enabled.

Cross section model model box

 This will ask for the model of cross sections. These sections will be written out to the appropriate file.

i.e. (CRS*****.gsi)

XSec start ch input box min alignment ch

chainage value to start writing cross sections.

XSec end ch input box max alignment ch

chainage value to end writing cross sections.

Report cross section assignmenttick box no

If ticked, a cross section assignment file (STA*****.gsi) file will be made.

File name input box

the name to be used for file creation. NB depending on what files are specified, the name given 
will be appended with the correct prefix eg ALN for alignment file. As Leica only takes 8 
character file names, the name may be truncated.

Write button

write appropriate files.

LMGS - D45 file
Position of option on menu: Survey =>Upload => Create roads upload file, Instrument choice = 
LMGS - D45 file

The LMGS - D45 file option allows the creation of a specific file format suitable for upload to 
Leica’a grader and paver control systems. The format has a number of rules that must be 
satisfied for correct file creation. These include:

1. There must be an equal number of points on each section

2. Points should not be closer than 5cm in both directions

3. Azimuth changes between cross section points should not be greater than 20gon (18 degrees). 

Selecting LMGS - D45 file brings up the LMGS - D45 file panel
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Cross section model model box

 the model of cross sections. These sections will be written out to the file.

XSec start ch input box min alignment ch

chainage value to start writing cross sections.

XSec end ch input box max alignment ch

chainage value to end writing cross sections.

File name input box

the name to be used for the file creation. The file will automatically be given a .D45 extension.

Write button

write appropriate file.

Sokkia Roading - Alignment Road file
Position of option on menu: Survey =>Upload => Create roads upload file, Instrument choice = 
Sokkia Roading - Alignment road

The Sokkia Roading - Alignment road option allows the creation of a specific roading file. 

Selecting Sokkia Roading - Alignment road brings up the SDR Roading - Alignment Road panel
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The sdr33 roading file has certain limitations and criteria. These include:

1. The alignment string must exist on the xsec’s. This allows us to calculate the "zero pt" so we 
can split the template into left and right.

2. The xsec model should be representative of the alignment string used in the macro. i.e. not 
generated from a different alignment. Therefore the alignment string should have a 0 offset 
on the xsections.

3. The alignment string cannot exist above or below the xsection. I.e. it should be on the section 
as per 1).

4. The number of points on adjacent section templates (left and right) should be the same. i.e. if 
5 points are on the LHS template for ch0 then the same number of points should exist for the 
LHS template for ch20. The instruments using this file, may not handle transitions between 
different number of points effectively and can give incorrect results. The user should limit the 
file by using the chainage range between areas where the number of points on each side of the 
cross sections are the same. 

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Select H-Align Select box

select valid alignment string.

Road Name input box Name of selected alignment string

input road name. If a valid alignment is selected, the name of that alignment will be the default road 
name.

Report vertical alignment tick box no

write vertical alignment details to file mode. If yes vertical alignment details written to the specified 
file. 

Assume last XSec segment is sideslope
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tick box ticked

if box is selected, the last segments left and right of 0.0 offset are considered to be side slopes, and the 
default cut and fill slope fields are enabled.

Default cut slope (%) input box

this field is optional. From the section data it is only possible to calculate either the cut or fill sideslope. 
A default value can be specified to be used for the non calculated value. 

When the segment is rising (i.e has a positive slope) it is considered a cut slope. Similarly, if the grade 
is negative the sideslope is considered a fill. If a fill sideslope is calculated, the cut sideslope definition in 
the file will be given the value as entered into the default cut slope field. If no value is set for the 
default, the cut slope in this instance will be given a null value. The default value if entered, should be 
in whole percent e.g. 50.0 for a 1v in 2h slope.

Default fill slope (%) input box

this field is optional. From the section data it is only possible to calculate either the cut or fill sideslope. 
A default value can be specified to be used for the non calculated value. 

When the segment is rising (i.e has a positive slope) it is considered a cut slope. Similarly, if the grade 
is negative the sideslope is considered a fill. If a cut sideslope is calculated, the fill sideslope definition in 
the file will be given the value as entered into the default fill slope field. If no value is set for the 
default, the fill slope in this instance will be given a null value. The default value if entered, should be 
in whole percent e.g. 50.0 for a 1v in 2h slope.

Cross section model model box

 This will ask for the model of cross sections. These sections will be written out to the file.

XSec start ch input box min alignment ch

chainage value to start writing cross sections

XSec end ch input box max alignment ch

chainage value to end writing cross sections

File name input box

the name to be used for file creation

Write button

write appropriate file

Sokkia Roading - String Road file
Position of option on menu: Survey =>Upload => Create roads upload file, Instrument choice = 
Sokkia Roading - String road

The Sokkia Roading - String road option allows the creation of a specific string roading file. 

Selecting Sokkia Roading - String road brings up the SDR Roading - String Road panel
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Road Name input box Name of selected alignment string

input road name. If a valid alignment is selected, the name of that alignment will be the default road 
name.

Cross section model Model box available models

model of cross sections to write out in SDR33 string format

XSec start ch. input box min alignment ch

chainage of the first cross sections to write out

XSec end ch. input box max alignment ch

chainage of the last cross sections to write out

File name file box

the name to be used for file creation

Write button

write appropriate file.

Topcon MS2000 Roading file
Position of option on menu: Survey =>Upload => Create roads upload file, Instrument choice = 
Topcon MS2000

The Topcon MS2000 option allows the creation of a specific roading file. 

Selecting Topcon MS2000 brings up the Report topcon MS2000 Roading panel
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Set button Set section for alignment panel

the set button will bring up the set sections for alignment panel. This panel allows the user to 
select multiple alignment/xsection combinations for the one file. The alignment is selected (using the 
Centreline selection button) followed by the Model of sections for that alignment. The Set button is 
pressed to accept the selection. This can be repeated for a number of alignments. Finish will close the 
set sections for alignment panel and return to the original panel

Data to setout choice box string model

view
string

the data to be included in the file can be selected by choosing a valid model, view or string. Depending 
on which data source is selected, the appropriate selection button will appear. The user then selects the 
button and then the items of interest.

File name input box

the name to be used for file creation

Write button

write appropriate files.

Topcon GT700 Roading File
Position of option on menu: Survey =>Upload => Create roads upload file, Instrument choice = 
Topcon GTS-700 Roads

The Topcon GTS-700 Roads option allows the creation of a specific roading file. 

Selecting Topcon GTS-700 Roads brings up the Report Topcon GT700 Roading panel
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

String to setout select button

after pressing the string to setout button, the user can select a valid string. This string will be used for 
setting out.

Model of sections model box

 the model of cross sections. These sections will be written out to the file.

File for horizontal input box

the name to be used for horizontal file creation. The file will automatically be given a .hg extension.

File for vertical input box

the name to be used for the vertical file creation. The file will automatically be given a .vg extension.

File for sections input box

the name to be used for the section file creation. The file will automatically be given a .xs extension.

Write button

write appropriate files.

Trimble Roading File
Position of option on menu: Survey =>Upload => Create roads upload file, Instrument choice = 
Trimble Roading

The Trimble Roading option allows the creation of a specific roading file. 

Selecting Trimble Roading brings up the Report Trimble Roading panel
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The trimble DC file has certain limitations and criteria. These include:

1. The alignment string must exist on the xsec’s. This allows us to calculate the "zero pt" so we 
can split the template into left and right.

2. The xsec model should be representative of the alignment string used in the macro. i.e. not 
generated from a different alignment. Therefore the alignment string should have a 0 offset 
on the xsections.

3. The alignment string cannot exist above or below the xsection. I.e. it should be on the section 
as per 1).

4. The number of points on assuasive section templates (left and right) should be the same. i.e. if 
5 points are on the LHS template for ch0 then the same number of points should exist for the 
LHS template for ch20. The instruments using this file, may not handle transitions between 
different number of points effectively and can give incorrect results. The user should limit the 
file by using the chainage range between areas where the number of points on each side of the 
cross sections are the same. 

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Select H-Align Select box

select valid alignment string.

Road Name input box Name of selected alignment string

input road name. If a valid alignment is selected, the name of that alignment will be the default road 
name.

Report vertical alignment tick box no

write vertical alignment details to file mode. If yes vertical alignment details written to the specified 
file. 

Assume last XSec segment is sideslopetick boxticked
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if box is selected, the last segments left and right of 0.0 offset are considered to be side slopes, and the 
default cut and fill slope fields are enabled.

Default cut slope (%) input box

this field is optional. From the section data it is only possible to calculate either the cut or fill sideslope. 
A default value can be specified to be used for the non calculated value. 

When the segment is rising (i.e has a positive slope) it is considered a cut slope. Similarly, if the grade 
is negative the sideslope is considered a fill. If a fill sideslope is calculated, the cut sideslope definition in 
the file will be given the value as entered into the default cut slope field. If no value is set for the 
default, the cut slope in this instance will be given a null value. The default value if entered, should be 
in whole percent e.g. 50.0 for a 1v in 2h slope.

Default fill slope (%) input box

this field is optional. From the section data it is only possible to calculate either the cut or fill sideslope. 
A default value can be specified to be used for the non calculated value. 

When the segment is rising (i.e has a positive slope) it is considered a cut slope. Similarly, if the grade 
is negative the sideslope is considered a fill. If a cut sideslope is calculated, the fill sideslope definition in 
the file will be given the value as entered into the default fill slope field. If no value is set for the 
default, the fill slope in this instance will be given a null value. The default value if entered, should be 
in whole percent e.g. 50.0 for a 1v in 2h slope.

Cross section model model box

 This will ask for the model of cross sections. These sections will be written out to the file.

XSec start ch input box min alignment ch

chainage value to start writing cross sections.

XSec end ch input box max alignment ch

chainage value to end writing cross sections.

File name input box

the name to be used for file creation

Write button

write appropriate files.
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Create Points Upload File (New)
create_points_upload_file

Position of option on menu: Survey =>Upload => Create points upload file (new)

This option is still under development.

The Create points upload file (new) option creates or uploads directly to a Trimble instrument a 
file of point ids, x, y and z, for string data (super strings and 4d strings only). 

Only Trimble file formats is supported as this stage - the option Create points upload file 
(“Create Points Upload File” ) is used to create files for most other instruments.

Selecting Create points upload file (new) brings up the Create Points Upload File panel.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Upload directly to Trimble device tick box

if tick, the points are uploaded to the attached Trimble instrument
if not tick, a dc file will be created.

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source Model

source of data is to be processed.

Default for null value input box 999

value to write for null z-values.

Only upload points with numeric point names tick box

if tick, only points with numeric (integer) point names are used.
if not tick, alphanumeric point names are used.

Start point id input box
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point id to start creating upload file from.

End point id input box

last point id to write to upload file.

Note: Start and End point ids may be left blank, and all point ids (whether numeric or alpha-numeric) will 
be written to the upload file.

Origin x/Origin y input box

If non-zero, subtract the value from the x/y value before writing out.

Upload File button

create the upload file
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Create Road Upload File (New)
create_road_upload_file

Position of option on menu: Survey =>Upload => Create road upload file (new)

This option is still under development.

The Create road upload file (new) option allows the creation of road files or uploads directly 
to a Trimble instrument and Leica using Leica XML format. 

Only Trimble and Leica LandXML file formats are supported as this stage- the option Create road 
upload file (“Create Road Upload File” ) is used to create files for most other instruments.

Selecting Create road upload file (new) brings up the Create Road Upload File panel

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

File type choice box Trimble Link
Leica X-sections LandXML

For the choice Trimble Link, go to “Trimble Link” 
Leica X-Sections LandXML “Leica X-Sections LandXML” 

Trimble Link
Position of option on menu: Survey =>Upload => Create roads upload file (new), File type = 
Trimble Link

The Trimble Link options creates a file in Trimble dc format or uploads the date directly to the 
instrument using Trimble Link.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Upload directly to Trimble device tick box

if tick, the points are uploaded to the attached Trimble instrument
if not tick, a dc file will be created.

Alignment string String select box

select valid alignment string.

Road Name input box Name of selected alignment string

input road name. If a valid alignment is selected, the name of that alignment will be the default road 
name.

Report vertical alignment tick box

 If tick, vertical alignment details written to file.

Report cross sections tick box

if tick, the cross section model box will be enabled.

X- sections model model box

 model of cross sections to be written out.

Start chainage for X-sections

chainage value to start writing cross sections. If blank, start with first x-section.

End chainage for X-sections

chainage value to stop writing cross sections. If blank, end with last x-section.

Assume X-sections left end-segment is sideslope tick box
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 If tick, left end segments are tagged as sideslopes.

Assume X-sections right end-segment is sideslope tick box

 If tick, right end segments are tagged as sideslopes.

Sideslope tolerance (%) input 0.01

 

Write button

write out or upload the date.

Leica X-Sections LandXML
Position of option on menu: Survey =>Upload => Create roads upload file (new), File type = Leica 
X-Sections LandXML

The Leica X-Sections LandXML options creates a file in LandXML format suitable for Leica 
instruments 

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

File name input box *.xml

the name of the Leica LandXML file.

Create database tick box

if tick, a DBX file is created

Alignment string string select

select valid alignment string.

Job Name input box name of selected alignment string
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input job name. If a valid alignment is selected, the name of that alignment will be the default job name.

Report vertical alignment tick box

 if tick, vertical alignment details written to file.

Report cross sections tick box

if tick, the cross section model box will be enabled.

X- sections model model box available models

 model of cross sections to be written out.

Start chainage for X-sections

chainage value to start writing cross sections. If blank, start with first x-section.

End chainage for X-sections

chainage value to stop writing cross sections. If blank, end with last x-section.

Assume X-sections left end-segment is sideslope tick box

 If tick, left end segments are tagged as sideslopes.

Assume X-sections right end-segment is sideslope tick box

 If tick, right end segments are tagged as sideslopes.

Write button

write out file.
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Survey Data Upload
survey_data_upload

Position of option on menu: Survey =>Upload

The upload option take data from the computer and sends it to the data collector connected to 
the computer’s serial port.

Selecting Upload brings up the Survey Data Upload panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Port input from configuration file

name of the computer serial port that the data collector is connected to. The default port is specified in 
the data collector configuration file. 

Baud rate input from configuration file

speed of the serial port

Data bits input from configuration file

number of data bits

Stop bits input from configuration file

number of stop bits

Parity input from configuration file

parity

DTR/DSR from configuration file

if tick, use DTR/DSR flow control

RTS/CTS from configuration file

if tick, use RTS/CTS flow control

XON/XOFF from configuration file

if tick, use Xon/Xoff

ACK/NAK from configuration file

if tick, use ACK/NAK
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Field file input *.fld files

name of the 12d field file that the raw file is to be converted to. The raw file is given the same name but 
with the extension specified in the configuration file, e.g., “.gre”.

Upload button

On clicking the upload button, 12d Model will send the specified file through the serial port and up to 
the data collector.
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Mapfile to Field 12d
mapfile_to_field12d

Position of option on menu: Survey =>Mapfile to Field 12d

The Mapfile to Field 12d option converts a 12d mapfile to an .att file used by Field 12d.

Selecting Mapfile to Field 12d brings up the Mapfile to Field12d panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mapfile file box *.mf

name of the 12d mapfile to convert to an .att file.

Coding file file box *.att

name of the attribute file to convert the mapfile to.

Create button

convert the file.
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Field 12d
compile_leica_field12d_coding_file

Position of option on menu: Survey =>Field 12d

The Field 12d option converts a Field 12d .att file to a .bin file for use on the Leica (with the Field 
12d software).

Selecting Field 12d brings up the Compile Leica Field 12d Coding File panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Coding file file box *.att

name of the attribute file to create the .bin file for

Allow gis features tick box

if tick, allow gis features in the .bin file

Create 12d macro tick box

if tick, a 12d Model macro is created

Compile 12d macro tick box

if tick, the 12d Model macro is compiled

Client locks tick box

if tick, the 12d Model macro is locked to a particular 12d Solutions client name

Client name input

the 12d Solutions client name that the macro is locked to

Start date calendar box

start date for running the macro

End date calendar box
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end date for running the macro

Compile button

create the .bin file and 12d macro (if required).
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Read Adac XML File
adac_reader_panel

Position of option on menu: Survey =>Adac read

This option is for reading the ADAC XML format. It is under development.

Selecting Adac read brings up the Adac Reader Panel panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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Create Adac XML File
create_adac_xml_file

Position of option on menu: Survey =>Adac write

This option is for writing the ADAC XML format. It is under development.

Selecting Adac write brings up the Write Adac XML File panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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TP Stakeout/Setout
tp_stakeout_setout

The TP Stakeout /Setout menu contains a variety of options provided by Mick Gunter for 
TP Stakeout and TP Setout users.

For further details, contact Mick Gunter at michael.gunter@bigpond.com

ch_os_input_panel

Cut_2_strings_panel

hatch_panel

list_models_panel
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conversions
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Conversions
The TP Stakeout /Setout menu contains a variety of options provided by Mick Gunter for 
TP Stakeout and TP Setout users.

For further details, contact Mick Gunter at michael.gunter@bigpond.com

tp_setout_conversions

4d_to_bta_panel

4d_to_bta_set_slope_panel

4d_to_cfa_panel

4d_to_clo_panel

4d_to_hla_panel

4d_to_hla_model_panel

4d_to_vta_panel

4d_tin_tsa_panel

TP Setout Conversions
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tp_stakeout_conversions

4d_to_vta_TP_stakeout_panel

4d_to_cfa_TP_stakeout_panel

4d_to_clo_TP_stakeout_panel

4d_to_hlaTP_stakeout__panel

4d_to_hla_model_TP_stakeout_panel

12d_to_hol_TP_stakeout_panel

4d_tin_tsa_TP_stakeout_panel_01

TP Stakeout Conversions
The TP Stakeout /Setout menu contains a variety of options provided by Mick Gunter for 
TP Stakeout and TP Setout users.

For further details, contact Mick Gunter at michael.gunter@bigpond.com
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piles_and_boxes_drafting

boxes_panel

boxes_centres_panel

piles_centres_panel

pilecentre_to_pta_panel
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Piles and Boxes Drafting
The TP Stakeout /Setout menu contains a variety of options provided by Mick Gunter for 
TP Stakeout and TP Setout users.

For further details, contact Mick Gunter at michael.gunter@bigpond.com



Chapter 16  Survey

April 2007 Page 1609TP Stakeout/Setout



12d Model Reference Manual

Page 1610 April 2007TP Stakeout/Setout

subgrade_strings

subgrade_intersections_panel

subgrade_parallel_panel
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Subgrade Strings
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tp_conformance

tin_conform_panel

TP Conformance

tp_data_output

TP Conformance

tp_models

list_models_panel

TP Models
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tp_triangles

4d_tin_to_tsa_panel

list_valid_triangles_panel

TP Triangles

contact_mick_gunter_panel



12d Model Reference Manual

Page 1614 April 2007TP Stakeout/Setout

Mick Gunter Details
For further details, contact Mick Gunter at michael.gunter@bigpond.com
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17  Design
design
Position of menu: Design

The design walk-right menu is

The options Drainage-Sewer, Pipeline, Volumes and Super alignment (parametric design) will be 
described in separate chapters of this Reference manual.

The other options in this menu will now be described.

For a description of the definition of a template in 12d Model, please go to the section “Templates 
in 12d Model” .

For the option Templates, please continue to the section “Templates” 
Apply “Apply” 
Boxing “Boxing” 
MTF “MTF” 
Drainage-Sewer, go to the chapter “Drainage and Sewer” 
Pipeline “Pipeline” 
Volumes “Volumes” 
Estate lots, go to the section “Estate Lots” 
Pads “Pads” 
Rivers “Rivers” 
Roads “Roads” 
Overlay “Overlay” 
X-Sections “X-Sections” 
More “More Design” 
Ortho “Ortho 12d” 

create floating Design menu
template creation and utilities
apply templates, interface, kerb return
apply boxing to sections
edit an mtf file
drainage-sewer options
pipeline option
volumes option
create estate lots
create pads
rivers options
 road creation
overlay design
cross-sections
more options
Ortho 12d output

on Main menu on 12d Model
Design floating men
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Templates in 12d Model
In 12d Model, Templates provide a quick and easy method for defining design details along a 
string for use in conceptual designs and visualizations and even detailed designs.

Any easy way of visualising a template is to look at is affect in a cross section.

 A template can be thought of as simply a number of links, which are ultimately defined by 
width and slope, and are connected sequentially (according to rules for each link type) to form a 
cross section. 

The point defined at the end of each link creates a string of the given link name when to template 
is used to create a design. The default colour of the string is the link colour and polygons created 
for each link are given the link colour.

For example, a template consisting of just the three links kerb, shoulder, verge could look like:

Templates are “applied” to a hinge string at right angles to a user selected reference string to 
produce a design model. That is, for a given string, specified templates are used as the cross-
sectional definition of the geometry at a regular chainage interval down the string.

Both design cross sections and longitudinal strings (created by joining together the same points 
from each cross section) are created. The longitudinal strings are given the name of the template 
points used to define them

12d Model supports templates with an unlimited number of fixed links, followed by either 

(a) a decisions table

or
(b) an unlimited number of variable cut and fill links and a cut/fill slope to be applied at the 

end of the last cut or fill template link.

The definition of a template with a fixed link table, a cut and fill tables and the final cut/fill links 
is discussed under the option create/edit template. The definition of the decision table is given 
in the chapter “Advanced Design” .

Fixed Template Links

ve
rg

e

Cross Section View of a Template
ke

rb

sh
ou

ld
er

verge string

kerb string
shoulder string

Plan View of a Template Applied to a String

string that the template 
was applied to
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The fixed template links are applied to the selected hinge string and are always used when 
applying the template regardless of whether the template points are in cut or fill. Each link is 
defined by two of the three variables, width, height and crossfall, and has a name and colour.

At the end of the fixed links, 12d Model checks to see if a decisions table exists.

If a decisions table exists, then it is used for the rest of the template.

If no decision table exist, then the cut, fill and final cut/fill tables are used.

Template Decisions
The decisions table is used for 

▲ complicated cut and fill requirements including multiple strata, decisions based on depth 
below one or more strata or strings, multi-level decisions (i.e. depth decisions followed by 
fixed links, more depth decision etc.); and

▲ extended battering including repetitive battering, fixed width batters, and battering rela-
tive to a string or strata.

The decisions table is documented in the chapter “Advanced Design” .

Cut and Fill Template Links and Final Cut/Fill
When there is no decisions table, the cut, fill, final cut/fill tables are used at the end of the fixed 
links.

If the end of the last link of the fixed template is in cut, the cut links are used and if the end of the 
fixed template is in fill, the fill links are used. There can be an unlimited number of cut and fill 
links and they are used sequentially starting with the first link.

If the surface tin is intersected when using a link, the section is terminated at that intersection 
point. Otherwise, the entire link is included in the section, and next link is then used. This is 
repeated until the surface is intersected or all the links have been used.

If there is still no intersection with the surface after using all of the cut or fill links, the final cut/
fill slope is used to try and intersect with the tin.

The unlimited cut/fill links are called variable template links because at each section, a different 
number of them may be needed - the number of links used varies from section to section.

Applying Templates
Once templates are defined, they can be “applied” to strings to produce the required design 
model. That is, for a given string, specified templates are used as the cross-sectional definition of 
the geometry at a regular chainage interval down the string.

Note

Around any curves, the string is approximated by chords spaced at the string's chainage interval 
or, if it is different, the section separation interval.
If the chord-to-arc distance is greater than the chord/arc tolerance given in the apply options 
panels, then extra points are inserted around the curve so that the chord/arc tolerance is met.

Templates
templates

Position of menu: Design =>Templates

The templates walk-right menu provides options create and edit templates, copy, rename and 
other template utilities.

For a description of the definition of a template in 12d Model, please go to the section “Templates 
in 12d Model” .
The templates walk- right menu is 
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For the option Templates, go to the section “Templates” .
Create/edit “Create/Edit” .
Copy “Copy” .
Rename “Rename” .
Utilities “Utilities” .
Delete “Delete” .

Templates
template_list

Position of option on menu: Design =>Templates =>Templates

The templates walk-right menu provides options to list all the templates added to the project 
(project templates) and all the templates in the project area but not in the project (removed 
templates).

The templates walk- right menu is 

Project Templates
The project templates walk-right menu provides a list of all the templates in the project.

Removed Templates
The removed templates walk-right menu provides a list of all the templates in the project area 
that have been removed from the project (using the removed from project option).

Create/Edit
template_create_edit

Position of option on menu: Design =>Templates =>Create/edit

12d Model supports templates with an unlimited number of fixed links, followed by either 

(a) a decisions table
or
(b) an unlimited number of cut and fill links and a final cut/fill slope the be applied at the end 

of the last template link.

To collect the different types of link information needed in the template, the template create/edit 
panel was designed with five buttons fixed, decisions, cut, fill and final cut/fill used to bring up 

list of templates
create/edit a design template
copy an existing template
rename a template
various template utilities

delete templates from disk
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and display the panels for creating and editing the fixed, decisions, cut, fill and final cut/fill 
tables. 

On selecting the create/edit option, the template create/edit panel is displayed.
 

The description of the fields and buttons used in the template create/edit panel now follows.

The associated panels created by the buttons fixed, cut, fill, final cut/fill will be described in the 
next four sections and the decisions panel will be described in the chapter “Advanced Design” .

Field Description Type Defaults Pop-Up

Template name input available templates

name of the template being created/edited. If the template already exists, then the associated panels will 
already contain the information for that template. The buttons fixed, decisions, cut, fill and final cut/fill 
can only be selected after the template name is given.

Fixed button

On selecting this button, the fixed template panel is displayed.

Decisions button

On selecting this button, the Decisions Template panel is displayed.
For the complete definition of decisions, please go to the section “Full Definition of Template 
Decisions”  in the Chapter “Advanced Design” .

Cut or Fill button

The variable cut or fill template panel is displayed on selecting this button.

Final Cut/Fill button

The final cut/fill template panel is displayed on selecting this button.

Note - the buttons can only be selected after the template name has been given in the 
template name panel field.

How to Use the Panel

(a) A new template is created, or an existing template modified, by first entering the template 
name into the template field (typed or picked from the pop-up).

(b) To define or edit the fixed sections of the template, select the fixed button and the fixed 
template panel will appear. 

Then either: 
(c) use the decisions button to define or edit the decisions table

or
(d) use the cut, fill and final cut/fill button to define or edit the variable cut, fill or final cut/fill 

sections of the template respectively.
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The four panels controlled by the buttons fixed, cut, fill and final cut/fill from the template create/
edit panel will now be described in detail. The decisions button will be described in the chapter 
“Advanced Design” .

Fixed Template
fixed_template

If the template already exists, the current fixed template links will be displayed in the panel. If 
the template is new, the panel will be empty.

The fixed template panel is

An unlimited number of fixed links can be defined in the template. For each link, any two of the 
three values of width, height and percent crossfall can be used to defined the link. The colour 
and name are also defined for the link.

The name is given to the sting created by the end of the link and the colour is used as either the 
string colour, or when a map file is used in the Apply Many option, is the colour of the created 
polygon joining the two ends of the link.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Width input/output

width of the link being defined
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Height input/output

height of the link being defined
NOTE - if height and cross-fall are being used to go down, then define height to be negative and cross-
fall to be negative.

X-fall % input/output

percent cross-fall of the link being defined - units are percent grade. Positive is up and negative down.
NOTE - if height and cross-fall are being used to go down, then define height to be negative and cross-
fall to be negative.

Colour input/output available colours

colour of the link being defined. If no colour is supplied, the default colour is used.

Name input/output

name of the link being defined - this is used as the name of the string created by the end point of the 
link.

OK/Apply button

OK stores the values in the fields and exists the panel. Apply stores the values but doesn’t exit the 
panel.
 
Warning - If the OK or Apply button is not selected, then no new information will be recorded.

Draw button

draws the fixed template at the bottom of the panel. Automatically does a fit.

NOTE - if height and cross-fall are being used to go down, then define height to be negative and 
cross-fall to be negative.

Variable Cut or Fill Template
variable_cut_template

variable_fill_template

The definition of the cut or fill template links are similar to the fixed template links except the 
slope is given as a “one vertical in a user given horizontal value” rather than a percent crossfall.

If the template already exists, the current cut (fill) template links will be displayed in the panel. If 
the template is new, the panel will be empty.

The variable cut template panel and the variable fill template panel are similar and look like -
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An unlimited number of links can be defined in the variable template. For each link, any two of 
the three values of width, height and slope can be used to define the link. The colour and name 
are also defined for the link.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Width input/output

width of the link being defined

Height input/output

height of the link being defined

Slope 1v in input/output

slope of the cut link being defined. The units are “one vertical in the given horizontal value”. The value 
0 is used to designate a horizontal slope - a vertical slope is not allowed.
For cut, positive is up and negative down
For fill, positive is down and negative is up.

NOTE -in cut: if height and slope are being used to go down, then define height to be negative and 
slope to be negative.

In fill: if height and slope are being used to go up, then define height to be negative and slope to be 
negative.

Colour input/output available colours

colour of the link being defined. If no colour is supplied, the default colour is used.

Name input/output

name of the link being defined - this is used as the name of the string created by the end point of the 
link.

OK/Apply button

OK stores the values in the fields and exists the panel. Apply stores the values but doesn’t exit the 
panel.

Warning - If the OK or Apply button is not selected, then no new information will be recorded.

NOTE -in cut: if height and slope are being used to go down, then define height to be negative 
and slope to be negative.
In fill: if height and slope are being used to go up, then define height to be negative and slope to 
be negative.

Final Cut/Fill Template
final_cut_fill_template

The final cut/fill template is used if the links in either the cut or fill templates are exhausted 
without an intersection with the tin being found.

If the template already exists, the current final cut/fill values will be displayed in the panel. If 
the template is new, the default values are displayed.

The final cut/fill template panel is
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Final cut slope 1 v in input/output 0 no slope, 0,1,2,3,4,5,10

cut slope for the interface calculation to be done at the end of the last link of the template. A cut slope of 
one vertical to the given value of horizontal units is used. The value 0 is used to designate a 
horizontal slope - vertical slopes are not allowed.
For final cut slope, positive is up and negative down

Final fill slope 1 v in input/output 0 no slope, 0,1,2,3,4,5,10

fill slope for the interface calculation to be done at the end of the last link of the template. A fill slope of 
one vertical to the given value of horizontal units is used. The value 0 is used to designate a 
horizontal slope - vertical slopes are not allowed.
For final fill slope, positive is down and negative is up

Maximum slope width input/output 100

the maximum width for the final slope.

Final name input/output int

name for the string created by this link (normally this string lies on the tin - the interface string).

OK/Apply button

OK stores the values in the fields and exists the panel. Apply stores the values but doesn’t exit the 
panel.

Warning - If the OK or Apply button is not selected, then no new information will be recorded.
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Copy
copy_template

Position of option on menu: Design =>Templates =>Copy

A copy of an existing template can be made using the copy option. This is often useful when a 
new template that is similar to an existing template is needed. The existing template can be 
copied and the copy then edited and modified.if

On selecting the copy option, the copy template panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Old template input available templates

name of the template to be copied.

New template input available templates

name of the template copy.

Copy button

after selecting this button, the template given in the old template field will be copied and the copy given 
the name in the new template field.

Rename
template_rename

Position of option on menu: Design =>Templates =>Templates =>Rename

On selecting the rename option, the template rename panel is displayed.

This panel can be used to change the names of existing templates

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Old template input available templates

name of the template to be renamed.

New template input

new name for the template

Rename button

Change the name of the template in the old template field to the name given in the new template field.
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Utilities
template_utilities

Position of menu: Design =>Templates =>Utilities

The utilities menu contains miscellaneous options involving templates.

The utilities walk-right menu is 

Each option will now be described.

For the option Add, go to the section “Add” 
Input, “Input” 
Output “Output” 
Remove “Remove” 
Save “Save” 

Add
template_adds

Position of menu: Design =>Templates =>Utilities =>Add

Removed templates can be added back into the project using the options in the add walk-right 
menu. The template adds walk-right menu is 

Add
add_template_to_the_project

Position of option on menu: Design =>Templates =>Utilities =>Add =>Add to project

Templates in the working project area but not yet in the project can be added to the project using 
this option.

On selecting the add option, the add template to the project panel is displayed.

The fields and buttons used in this panel have the following functions.

add templates to project
read in template file
write out templates
remove templates from project
save templates to disk
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Field Description Type Defaults Pop-Up

Removed template input available templates

name of the template to be added to the project.

Add button

add the template given in the template field to the working project.

Add All To Project
add_all_templates_to_project

Position of option on menu: Design =>Templates =>Utilities =>Add =>Add all to project

The add all to project option is used to add all the removed templates back into the project.

On selecting the add all to project option, the add all templates to project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Add button

after selecting this button, all removed templates in the working project will be added to the project.

Input
This input option is used to read in templates from files in this special 12d Model format.

The option has already been described under file i/o=>layout input.

Output
The output option writes out one or all templates in the 12d Model template format.

The option has already been described under file i/o=>layout output.

Remove
template_removes

Position of menu: Design =>Templates =>Utilities =>Remove

Templates can be removed from the project using the options in the remove walk-right menu. 
Removed templates are not deleted but remain in the project area and are no longer accessible in 
the project.

The template removes walk-right menu is 
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Remove Template from Project
remove_template_from_project

Position of option on menu: Design =>Templates =>Utilities =>Remove => Remove from project

Individual templates can be removed from the project using the remove from project option and 
on selecting the option, the remove template from project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Template input available templates

name of the template to be removed from the working project.

Remove button

after selecting this button, the template given in the template field will be removed from the working 
project.

Remove All Templates From Project
remove_all_templates_from_project

Position of option on menu: Design =>Templates =>Utilities =>Remove => Remove all from project

All templates can be removed from the project using the remove all option and on selecting the 
option, the remove all templates from project panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Remove button

after selecting this button, all templates in the working project will be removed.

Save
template_saves

Position of menu: Design =>Templates =>Utilities =>Save

Templates can be saved on disk. This is done automatically by the save option on the 12d Model 
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but this option allows the template alone to be saved.

The template saves walk-right menu is 

Save Template
save_template
Position of option on menu: Design =>Templates =>Utilities =>Save =>Save a template

On selecting the save a template option, the save template panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Template input available templates

name of the template to be saved.

Save button

after selecting this button, the template given in the template field will be saved to disk.

Save All Templates
save_all_templates
Position of option on menu: Design =>Templates =>Utilities =>Save =>Save all templates

On selecting the save all templates option, the save all templates panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Save button

after selecting this button, all templates in the working project will be saved to disk. Unless an error 
occurs, the panel will be removed after the saving is completed.
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Delete
template_deletes

Position of menu: Design =>Templates =>Delete

Using the delete option, templates can be deleted from the project and the computer disk so that 
they can no longer be accessed or take up disk space.

To help protect the user against disasters, when a template is selected for deletion, a yes-no pop-
up menu is used to confirm that the user did intend deleting the template.

The template deletes walk-right menu is 

Delete Template
delete_template

Position of option on menu: Design =>Templates =>Delete =>Delete a template

The delete a template option is used to delete individual template from the project.

On selecting the delete a template option, the delete template panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Template input    project templates

name of the template to be deleted.

Delete button

after selecting this button, the template given in the template field will be deleted from the computer 
disk. A yes-no pop-up is used to confirm that deletion is required.

Delete All
delete_all_templates

Position of option on menu: Design =>Templates =>Delete =>Delete all templates

The delete all option will delete all templates in the working project. It does not delete templates 
that are in the working project area but not yet added to the project.

On selecting the delete all option, the delete all templates panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Delete button

after selecting this button, a yes-no pop-up is used to confirm that deletion is required. If it is, all 
templates in the project will be deleted from disk. Unless an error occurs, the panel will be removed.
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Apply
design_functions

Position of menu: Design =>Apply

The apply options are for producing design strings using templates and modifiers to create 
strings along a reference or reference and hinge string - “applying the template to a string”. This 
method can be used to quickly produce roads, canals, trenches, site batters etc.

When applying the templates, design x-sections and strings are automatically produced, plus the 
cut and fill volumes for the design.

Creating a design in this way is the first job of the apply options.

However, after applying a template and examining the results, it is normally necessary to make 
changes to either the template, the string that the template was applied to or even the tin used 
for interfacing.

In all cases, the strings, sections and volumes created during the apply will no longer be valid 
and need to be replaced by new information.

Although this can be accomplished by deleting the incorrect models and replacing them with 
new ones by re-applying the template, this is would be a time consuming if repeated over and 
over again. Hence in 12dModel, a concept called Apply functions was introduced.

Basically, an apply function keeps track of all the information involved in applying a template 
and all the strings and models created during the apply/apply many. If either the template, the tin 
or the string that the template was applied to is subsequently modified, the apply functions can 
be re-run and all the old information automatically deleted and replaced by the updated 
information.

NOTES ABOUT THE STRING CHOSEN TO APPLY TEMPLATES TO

1. If vertical geometry does not exist for the entire length of the string, then the template(s) are 
only applied to the section of the string where vertical geometry exists.

2. If the horizontal or vertical geometry has overlapping tangent points at any section of the 
string, then the option terminates without any calculations being made.

3. Any curves will be approximated by chords spaced at chainage interval given by the section 
separation value. If the chord-to-arc distance for the chords is greater than the chord/arc 
tolerance given in the apply/apply many panel, then extra points are inserted around the curve 
so that the chord/arc tolerance is met.

4. The apply options create sections and strings using a reference string to define the chainage 
and what is perpendicular at each chainage, and a hinge string from where the template links 
are defined. The template defines a point name and colour for each template link.

 Cross sections can be created with point names corresponding to the template links, and 
strings formed by joining the same named points from consecutive cross sections.

reference string

hinge string

direction to apply template along 
(perpendicular to the reference string)

hinge point - the point to apply 
the template from
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The apply walk-right menu is

Each option in this menu will now be described.

For the option Apply/ Apply many defaults, go to the section “Apply and Apply Many Defaults” .
Apply,  “Apply” 
Apply many,  “Apply Many” 
Kerb return “Kerb Return” 
String modifiers  “String Modifiers” 
Interface “Interface” 
Alignment/super alignment table “Alignment & Super Alignment Table”  in

 the chapter “Drafting” 
Amend VG “Amend VG” 
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Apply and Apply Many Defaults
apply_template_defaults

apply_templates_defaults

Position of option on menu: Design =>Apply =>Apply defaults

Design =>Apply =>Apply many defaults

There are two files apply_defaults.4d and apply_many_defaults.4d which contain the pre or post text 
to be added to the name of the function to automatically create many entries in the panel fields 
for Apply and Apply Many plus default values for all the other panel fields.

After the name of a new function is typed in and an <enter> typed, all the fields mentioned in 
the default files are automatically filled in using the function name and the defined pre-post text 
as supplied in the file, plus setting any other panel fields from default values supplied in the file. 
If the files are missing, no panel fields are automatically filled in.

The files can be created and edited using the Apply defaults or Apply many defaults option which 
brings up the Apply Template Defaults or Apply Templates Defaults panels respectively.
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Apply
apply_template_function

Position of option on menu: Design =>Apply =>Apply

On selecting the Apply option, the Apply Template Function panel is displayed.

This panel is used to create the information for applying a new template function or to modify 
the information for an existing template function.

The Apply Template Function panel is

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Button at bottom

Views button

perspective views can be defined with respect to chainages on the string. This option is described in 
more detail in the section “Views” 

Apply button

apply the template information to the selected reference and hinge strings, between the start and end 
chainages. The cut, fill and balance volumes are also calculated and written to the message area.
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Main tab

Function name input available template functions

name of the function to define the apply for. If the function already exists and is picked from a pop-up 
or an <enter> is given at the end of the name, the information from the existing function will be placed 
in the appropriate panel fields.

Tin tin box available tins

if non-blank, the name of the tin to calculate the cut/fill interfaces against at the end of the fixed part of 
the templates given in the left and right template fields. 
If blank, then only the fixed part of the templates are used unless a tin is specified in the decisions 
section of the templates.

Left/right template template box available templates

name of the template to be applied to the left/right of the string. If a template is used on the left/right, 
the template definitions go from the hinge string out to the left/right.

LHS/RHS prefix input

prefix/postfix (pre*post) to be applied to the left/right template string names. If pretext only, just give 
the text. If post text is required, precede it by a *.

Reference string-select

the selected string is used to defined the meaning of chainage and bearing for each point in the apply. 
Sections are defined at right angles to the reference string at the appropriate chainage points on the 
reference string.

Hinge string-select

the reference string defines chainage and bearing but the templates are actually applied to the hinge 
string. For a given chainage, a line is taken at right angles to the point of that chainage on the reference 
string and extended until it cuts the hinge string. The templates are applied at that point on the hinge 
string along the direction of the line.
If no hinge string is selected, the reference string is also the hinge string.

Start/End chainage input

the reference string start/end chainage for applying the template. If blank, the start/end chainage of the 
reference string is used.

Section separation input 10.0

sections are created at right angles to points on the reference string that are the section separation 
chainage distance apart.

reference string

hinge string

direction to apply template along 
(perpendicular to the reference string)

hinge point - the point to apply 
the template from
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Report file file box *.rpt

if non-blank, the name of the file to contain the volume report for the template calculations. If the file 
already exists, the report will be appended to the file.
If blank, no report is produced.

Models tab

Model for strings model box available models

if non-blank, the name of the model to contain the template and interface strings. The string colour is 
the template link colour.
If blank, the strings will not be stored.

Model for sections model box available models

if non-blank, the name of the model to contain the design sections generated by the templates.
If blank, the sections will not be stored.

Section colour colour box default colour available colours

the colour for the sections strings

Model for polygons input available models

if non-blank, the name of the model to contain the polygons created for each link of the template. The 
polygon is given the colour of the template link.
If blank, the polygons will not be stored.

Difference model input available models

if non-blank, the sections which are the difference between the tin sections and the template x-sections 
are retained and placed in the model given in this field. If blank, the sections are not kept.

Difference colour input available colours

colour for the difference sections strings

Misc tab

Strip depth input 0

the stripping depth to be used on the tin before the apply is done. 

Create arcs input super arcs no arcs, alignment arcs,
polyline arcs, super arcs

if no arcs, the strings are created as 3d strings with no arcs.
   alignment arcs, the strings are created as alignment strings with arcs
   polyline arcs, the strings are created as polyline strings with arcs.
   super arcs, the strings are created as super strings with arcs.

Chord/arc tolerance input default chord/arc tolerance

the chord to arc tolerance to use on the reference string for determining how many sections are created 
around horizontal curves.

Volume correction for curves tick box

if tick, volume corrections are made when going around curves.

Sections as 4d tick tick
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if tick, the section strings will be created as 4d strings with the appropriate template string names as 
the text at each point of the section. These are needed for boxing and some options on x-section plots.

Copy hinge tick tick

if tick, a string with points at the apply chainages is created on top of the hinge string.

Tin tab

Create road tin tick box

if tick, the fields in this tab are used to create a road tin

Road tin tin box available tins

name for the tin created from the design strings and sections

Colour for tin colour box available colours

colour of the road tin

Model for tin model box available models

model for the road tin

Create depth range polygons tick box

if tick, depth polygons are created

Depth range file file box *.drf files

depth range file used when creating polygons

Model for polygons model box available models

model for the depth polygons

Filter tab

Filter cross-sections tick box

if tick, the fields in this tab are used to filter cross sections

Filter sections model model box available models

model for the filtered cross sections

Filtered sections colour colour box available colours

colour of the filtered cross sections

Regular filtering interval input

regular interval to use for filtering the cross sections

Regular culling tolerance input 0

tolerance to use when selecting a cross section

Include start sections tick box

if tick, a section at the start chainage is included even if the start chainage is not a regular interval

Include end sections tick box

if tick, a section at the end chainage is included even if the end chainage is not a regular interval

Include H tangent sections tick box

if tick, a sections at the horizontal tangent points are included even if they are not a regular interval

Include V create/sag sections tick box

if tick, a sections at the crest and sag points are included even if they are not a regular interval

Special chainage file file box *.spc files
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if non blank, a file of chainages to include sections at even if they are not a regular interval

Plot tab

Generate long section plots tick box

if tick, long section plots are created

Long section PPF file box *.lplotppf files

binary ppf file to use for the long section plots

Plotter type plotter box model available plotters

type of plotter to use for the long section plots

Plot stem

the name to use for the plots - a number will be added when more than one page is produced

Clean plot model beforehand tick box

if tick and the plotter type is model, the plot models are cleaned before the plots are created

Generate cross section plots tick box

if tick, cross section plots are created

Cross section PPF file box *.lplotppf files

binary ppf file to use for the cross section plots

Plotter type plotter box model available plotters

type of plotter to use for the cross section plots

Plot stem

the name to use for the plots - a number will be added when more than one page is produced

Clean plot model beforehand tick box

if tick and the plotter type is model, the plot models are cleaned before the plots are created
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Views
template_views

Position of option on menu: Design =>Apply =>Apply

Position of option on menu: Design =>Apply =>Apply many

This option locks perspective views to the reference string of the Apply/Apply Many function,

It defines the eye and target co-ordinates for the perspective views in terms of the chainage and 
height above an existing reference string (as in the perspective view-ops option, string-walk) 
rather than entering the (x,y,z) eye and target co-ordinates.

If the string is modified, then the perspective eye and target points will also change.

Selecting Views fires up the Template Views panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View view box available views

the perspective view to define the eye and target points for.

Eye chainage input

the string chainage of the eye viewing point.

Eye height input 1.3

height of the eye viewing point above the string.

Target chainage input

the string chainage the target viewing point.

Target height input 0.3

height of the target viewing point above the string.

Add View button

add the view to the template function and then redraw the view using the above eye and target 
parameters.

Remove View button

remove the view from the Apply/Apply Many function.
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Apply Many
apply_templates_function

Position of option on menu: Design =>Apply =>Apply many

The apply many option is used for more complex design work. It includes defining more than 
one template for defining strings along a string, template modifiers for advanced control of the 
strings created by the Apply Many, stripping depths and boxing, a road tin and depth polygons, 
sights lines, tadpoles, long section and cross section plots. The Apply Many can also create up to 
eight layers of boxing.

For Apply Many, the templates and all the modifiers are supplied in a file called the Many 
Templates File or mtf file. The definition of the mtf will follow after the description of the Apply 
many option.

Selecting Apply many displays the Apply Templates Function panel.

This panel can be used to create the information for applying a new template function or to 
modify the information for an existing template function. 

Field Description Type Defaults Pop-Up

Buttons from bottom

Views button

perspective views can be defined with respect to chainages on the string. This option is described in 
more detail in the next section.
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Apply button

apply the template information to the selected reference and hinge strings, between the start and end 
chainages. The cut, fill and balance volumes are also calculated and written to the message area.

Main tab

Function name input available template functions

name of the function to define the apply many for. If the function already exists and is picked from a 
pop-up or an <enter> is given at the end of the name, the information from the existing function will be 
placed in the appropriate panel fields.

Tin input available tins

if non-blank, the name of the tin to calculate the cut/fill interfaces against at the end of the fixed part of 
the templates given in the template file. 
If blank, then only the fixed part of the templates are used unless a tin is specified in the decisions 
section of the templates.

MTF file file box available mtf’s, edit mtf

name of the file containing the definitions of where and how templates are applied and modified along 
the string.
For more information on the MTF file, go to the section “Many Templates File” .

V6 compatible tick box

if tick, 

LHS/RHS prefix input

prefix/postfix (pre*post) to be applied to the left/right template string names. If pretext only, just give 
the text. If post text is required, precede it by a *.

Reference string-select

the selected string is used to defined the meaning of chainage and bearing for each point in the apply. 
Sections are defined at right angles to the reference string at the appropriate chainage points on the 
reference string.

Hinge string-select

the reference string defines chainage and bearing but the templates are actually applied to the hinge 
string. For a given chainage, a line is taken at right angles to the point of that chainage on the reference 
string and extended until it cuts the hinge string. The templates are applied at that point on the hinge 
string along the direction of the line.
If no hinge string is selected, the reference string is also the hinge string.

Start/End chainage input

the reference string start/end chainage for applying the template. If blank, the start/end chainage of the 

reference string

hinge string

direction to apply template along 
(perpendicular to the reference string)

hinge point - the point to apply 
the template from
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reference string is used.

Section separation input 10.0

sections are created at right angles to points on the reference string that are the section separation 
chainage distance apart.

Report file input *.rpt

if non-blank, the name of the file to contain the volume report for the template calculations. If the file 
already exists, the report will be automatically over written. If blank, no report is produced.

Also if boxing is included in the MTF file definition, the Volumes in the report reflect the cut and fill 
volumes to the boxing sections, not the road surface sections. This always happens even if you do not 
generate boxing sections.

Models tab
the model tab consists of a grid for defining the design strings forming the road surface and design 
cross section, up to eight layers of boxing and models for the difference sections between the design and 
the natural surface.
The last boxing layer is also referred to as the subgrade layer.

Road Surface:

Strings input available models

if non-blank, the name of the model to contain the design and interface strings. The default string 
colours are the template link colours but that can be overridden by a map file.
If blank, the strings are stored.

Sections input available models

if non-blank, the name of the model to contain the design sections generated by the apply.
If blank, no sections are stored.

 Colour input available colours

the colour for the design sections strings

Boxing Layer 1-8:
if non blank, boxing strings and sections will be created for that layer.
The last boxing layer is also referred to as the subgrade layer.

Strings input available models

if non-blank, the name of the model to contain the boxing strings for this layer.
If blank, the strings will not be stored.

Sections input available models

if non-blank, the name of the model to contain the boxing sections generated by the templates and 
boxing rules. If blank, the sections will not be stored.

 Colour input available colours

colour for the boxing sections for this layer

Difference

Sections input available models

if non-blank, the sections which are the difference between the tin sections and the template x-sections 
are retained and placed in the model given in this field. 
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If blank, the sections are not kept.

Colour input available colours

colour for the difference sections strings

Model for polygons input available models

if non-blank, the name of the model to contain the polygons created for each link of the template. The 
polygon is given the colour of the template link.
If blank, the polygons will not be stored.

Misc tab

Create arcs choice box super arcs no arcs, alignment arcs,
polyline arcs, super arcs

if no arcs, the strings are created as 3d strings with no arcs.
   alignment arcs, the strings are created as alignment strings with arcs
   polyline arcs, the strings are created as polyline strings with arcs.
   super arcs, the strings are created as super strings with arcs.

Chord/arc tolerance input default chord/arc tolerance

the chord to arc tolerance to use on the reference string for determining how many sections are created 
around horizontal curves.

Volume correction for curves tick box

if tick, volume corrections are made when going around curves.

Partial interfaces tick box tick

if tick, an interface string is not produced when no intersection is made with the tin. The interface may 
then be broken into a number of interface strings.
If not ticked, a yellow segment is created in the interface string when no intersection is made with the 
tin. Only one interface string will then be produced.

Sections as 4d tick box tick

if tick, the section strings will be created as 4d strings with the appropriate template string names as 
the text at each point of the section. These are needed for boxing and some options on x-section plots.

Copy hinge tick box tick

if tick, a string with points at the apply chainages is created on top of the hinge string.

Use stripping tick box tick

if tick, the stripping depths in the mtf file are used.

Show detailed stripping volumes tick box

if tick, end area stripping volumes are written to the report file

Calculate natural surface to design volumes tick box tick

if tick, end area volumes between the natural surface and the design strings are written to the report 
file
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Calculate natural surface to subgrade volume tick box tick

if tick, end area volumes between the natural surface to the subgrade (the last boxing layer) are written 
to the report file

Calculate road to subgrade volumes tick box tick

if tick, end area volumes between the design strings and the subgrade (the last boxing layer) are 
written to the report file.

Calculate inter-boxing layer volumes tick box tick

if tick, end area volumes between each of the boxing layers are written to the report file.

Map file file box *.mf files

if non blank, the given map file is applied to all the design strings created by the Apply Many. The 
map file overrides any default colours from the templates. The map file can colour strings, apply 
linestyles, apply hatch patterns to polygons, apply extrudes to super strings etc. For more details on the 
map file, see “Map File”  in the chapter “File I/O” .

Tin tab
the Tin tab controls the creation of a design tin and depth polygons

Create road tin tick box

if tick, the fields in this tab are used to create a road tin

Road tin tin box available tins

name for the tin created from the design strings and sections

Colour for tin colour box available colours

colour of the road tin

Model for tin model box available models

model for the road tin

Create depth range polygons tick box

if tick, depth polygons are created

Depth range file file box *.drf files

depth range file used when creating polygons

Model for polygons model box available models

model for the depth polygons

Sight tab
the Sight tab controls the reporting of sight distance lines between the reference line and a super tin 
formed from the natural surface tin and the design tin, and barrier lines on the reference line if it is a 
super alignment. For more information on sight distance calculations and for the option that will also 
create sight lines/no-lines and take bridge tins into consideration, go to the section “Sight Distance” . 

Calculate sight distance tick box

if tick, sight distance lines are created and barrier lines calculated and applied to the reference string if 
it is a super alignment.

Min sight distance input 100

minimum chainage distance to use for placing the test target point.

Max sight distance input 3000
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maximum chainage distance to use for placing the test target point.

Eye height input 1.3

height of the eye point above the picked string

Eye offset input 1.3

offset of the eye point from the picked string.

Target height input 0.3

height of the test target point above the picked string

Target offset input 1.3

offset of the target point from the picked string.

Calc interval input 20

chainage increment to move the eye point for the next sight distance calculation.

Trial interval input 10

chainage increment to move to test target point.

Report file file box *.rpt files

if non blank, a sight distance report is produced and written out to this file name.

Create separation/barrier lines tick box

if tick, and the reference string is a super alignment, barrier and separation lines are created and 
defined in the super alignment.

Barrier distance input

Min barrier road length input

Max barrier road length input

Min between barriers input

Filter tab
the Tin tab controls the filtering of cross sections

Filter cross-sections tick box

if tick, the fields in this tab are used to filter cross sections

Filter sections model model box available models

model for the filtered cross sections

Filtered sections colour colour box available colours

colour of the filtered cross sections

Regular filtering interval input

regular interval to use for filtering the cross sections

Regular culling tolerance input 0

tolerance to use when selecting a cross section

Include start sections tick box
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if tick, a section at the start chainage is included even if the start chainage is not a regular interval

Include end sections tick box

if tick, a section at the end chainage is included even if the end chainage is not a regular interval

Include H tangent sections tick box

if tick, a sections at the horizontal tangent points are included even if they are not a regular interval

Include V create/sag sections tick box

if tick, a sections at the crest and sag points are included even if they are not a regular interval

Special chainage file file box *.spc files

if non blank, a file of chainages to include sections at even if they are not a regular interval

Resume tab
still under development

Plot tab
the Plot tab controls the generation of long section and cross section plots

Generate long section plots tick box

if tick, long section plots are created

Long section PPF file box *.lplotppf files

binary ppf file to use for the long section plots

Plotter type plotter box model available plotters

type of plotter to use for the long section plots

Plot stem

the name to use for the plots - a number will be added when more than one page is produced

Clean plot model beforehand tick box

if tick and the plotter type is model, the plot models are cleaned before the plots are created

Generate cross section plots tick box

if tick, cross section plots are created

Cross section PPF file box *.lplotppf files

binary ppf file to use for the cross section plots

Plotter type plotter box model available plotters

type of plotter to use for the cross section plots

Plot stem

the name to use for the plots - a number will be added when more than one page is produced

Clean plot model beforehand tick box

if tick and the plotter type is model, the plot models are cleaned before the plots are created

Tadpoles tab
the Tadpole tab controls the generation of batters ticks and tadpoles (hachure notation). For more 
information see the section “Create Cut/Fill Symbols”  in the chapter “Drafting” .

Create tadpoles tick box

if tick, cut/fill symbols are created between given strings

Tadpole model model box available models
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model for the created cut-fill symbols 

Interval input 10

chainage distance between the symbols

Search width input 50

maximum distance to search to cut the strings for creating symbols. This is important for cases such as 
a bend in a road where multiple sets of string may then exist even when only searching out on one side 
of the road

Search side choice box both both, left side only
right side only

side of the reference string to search for strings to apply symbols to. 

String 1 input 50

name of the point on the template to start symbol. 

String 2 input 50

name of the point on the template to stop symbol. 

Start Ch. input

if blank, use the start chainage of the apply many.
If non blank, the chainage to start applying this symbol to.

End Ch. input

if blank, use the end chainage of the apply many.
If non blank, the chainage to stop applying this symbol to.

Symbol 1 symbol data

definition of the symbol to create at the given interval, or at twice the given interval if Symbol 2 is 
defined

Symbol 1 % input

if non-blank, percentage of the distance between String 1 and String 2 to apply the symbol.
If blank, the symbol is applied to the full distance between String 1 and String 2 (i.e. 100%)

Symbol 2 symbol data

definition of a second symbol to create at twice the given interval

Symbol 2 % input

if non-blank, percentage of the distance between String 1 and String 2 to apply the symbol.
If blank, the symbol is applied to the full distance between String 1 and String 2 (i.e. 100%)
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Many Templates File
The many templates file includes the definition of

1. chainage ranges for the use of templates on the left and right side of the hinge

2. interpolation between templates

3. templates at special chainages

4. template modifiers to further change the hinge and template strings

5. stripping depths along the job

6. boxing 

The documentation for chainage ranges and template interpolation (1 and 2) will be given now 
and the documentation for 3-6 will be given in the later chapter “Advanced Design” .

The templates on the left and right hand sides of the centre line are specified separately in the 
many templates file. Apart from a key word denoting whether the following part of the 
definition is for the left side or the right side, the set out for the left-side is identical to the right-
side. Hence, only the left-side will be described in detail.

The left-side definition begins with the key words

left_side =

A list of chainages (in ascending order, one per line) with corresponding template names then 
follows. This list of chainages and templates is enclosed in curly braces { }.

Note if the template name includes spaces, then the name must be enclosed in quotes “. For 
example, “left 1".

The chainage-template lists are assembled as follows

(a) To represent a template starting at a given chainage, the chainage value followed by the 
template name is given. The chainage and name are separated by one or more spaces. For 
example, the template std starting at chainage 150 is represented by

150 std

The template is assumed to apply until the chainage given on the next line of the left-side 
definition.

 If the template is to go to the end of the centre-line, add a line with a chainage greater than 
or equal to the end chainage. For example,

150 std

99999

(b) if no template exists from a chainage, simply include the chainage with no template name 
following it. For example, if there is no template from chainage 250, this is represented by

250

The non-existence of a template is assumed to apply until the chainage given on the next 
line of the left-side definition

(c) the case of a linear change from one template to another template over a specified chainage 
range is represented by giving the start chainage of the linear change, followed on the same 
line by the start template, a comma, and the end template. For example, if the template is to 
vary linearly between the template std and the template left, beginning at the chainage 350, 
then the line in the file would be

350 std, left

The linear change takes place over the interval beginning at the chainage given on the defin-
ing line and ending at the chainage given on the next line of the left-side. Distances and per-
cent cross-falls are interpolated linearly and slopes are interpolated on the radian value of 
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the slope angles.

Combining these rules, the following lines in a template file 

left_side = {
100 std
200 std , "left 1"
250 "left 1"
300
350 std
99999

}

describes the situation

1. the left-hand side of the centre-line has no template from the beginning of the centre-line until 
chainage 100.

2. at chainage 100, the template std begins and continues until chainage 200.

3. there is a linear change from the template std to the template left 1 between chainage 200 and 
chainage 250.

4. the template left 1 goes from chainage 250 to chainage 300.

5. there is a gap between chainage 300 and chainage 350.

6. the template std goes from chainage 350 to chainage 99999, or if the end chainage is smaller 
than 99999, to the end of the centre-line.

The right-side template definition begins with the key word right_side. The rest of the definition 
follows the same rules at the left hand side of the centre-line. For example,

right_side = {
100 std
200 std , right
250 right
300 right , std
350 std
400

}

The left and right sides can vary independently.

Restrictions on the Template File Definitions

1. If one template stops at the same chainage that another template begins, then the two 
templates must have the same number of fixed and variable links. The templates will be 
varied linearly from the stopping template to the starting template over one section 
separation distance.

2. If there is a linear variation between two templates, the two templates must have the same 
number of fixed and variable links.

3. If two templates do not have the same number of links, they must be separated by a gap, that 
is, by a region with no template.
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Kerb Return
apply_kerb_return_function

Position of option on menu: Design =>Apply =>Kerb return

The kerb return option is used to help create the vertical geometry for an alignment string being 
used as a kerb return.

The standard situation is that in the plan view, the kerb return joins two kerb lines which already 
have z-values.

It is then necessary to define vertical geometry for the kerb return, usually taking into 
consideration the z-values and incoming grades from selected strings (often the centre lines and 
kerb strings).

A standard first guess at the kerb return vertical geometry is known as the quarter point vertical 
geometry and it is defined by 

(a) break the section along the kerb return into four equal pieces

(b) project the incoming grade from a selected start grade string to intersect the first quarter 
point line

(c) project back the outgoing grade from a selected end grade string to intersect the last quarter 
point line

(d) join the two projected intersection points

(e) define vertical intersection points (VIP’s) at the intersection points

(f) create back to back vertical curves for the VIP’s

centre line 1

centre line 2

kerb line 1

kerb line 2

kerb return

Plan View of the Horizontal Geometry of the Kerb Return

direction of kerb return

end grade from 
selected string

start grade from 
selected string

start height from 
selected string

end height from 
selected string

vertical geometry of the kerb return

Section View of the Quarter-Point Vertical Geometry for the Kerb Return

vertical tangent point (VIP)

VIP

vertical curves
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The kerb return option creates a function which will automatically create the quarter-point 
vertical geometry for the kerb return and will recalculate it as required.

Note: the actual direction of the kerb is important - start grade and start height apply to the start 
of the kerb and end grade and end height apply to the end of the kerb where start and end are 
determined by the actual direction of the kerb (not the picking direction).

On selecting the kerb return option, the apply kerb return function panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input available kerb functions

name of the function to define the apply for. If the function already exists and is picked from a pop-up 
or an <enter> is given at the end of the name, the information from the existing function will be placed 
in the appropriate panel fields.

Start grade string string-select

select the string to be used for the in grade at the start of the kerb return.

End grade string string-select

select the string to be used for the out grade at the end of the kerb return.

Start height string string-select

select the string to be used for the height at the start of the kerb return - this is used for the z-value at 
the start of the kerb return.

End height string string-select

select the string to be used for the height at the end of the kerb return - this is used for the z-value at the 
end of the kerb return.

Kerb return string-select

select the alignment string that is the kerb return.
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Clear vertical geometry tick box

if tick, the vertical geometry of the kerb return string is cleared as soon as the apply button is selected, 
or a recalc done.

Pick all button

if pick all is selected, the user is asked to sequentially select the four strings: the Start grade string, End 
grade string, Start height string and End height string. The strings are automatically assigned to the 
appropriate string-select panel fields.

HG button

brings up the kerb return function create HG panel. This option is currently under development.

Apply button

if the kerb return has no vertical geometry (it will be automatically be deleted if the clear vertical 
geometry is set to tick) or the vertical geometry is the quarter-point geometry for the previous apply, 
then new quarter-point vertical geometry is created for the kerb return string.
Otherwize, nothing happens when the apply button is selected. That is, if the kerb return already has 
vertical geometry which is not the quarter-point geometry for the previous apply, and the clear vertical 
geometry is set to no tick, then nothing happens when the apply button is selected.

Note

kerb_return_function_create_hg
The experimental kerb return function create HG panel is
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String Modifiers
string_modifiers_function

Position of option on menu: Design =>Apply =>String modifiers

The String Modifiers option is used to create vertical intersection points for an alignment string, or 
heights for a 2d, 3d, 4d, polyline or super string, using projection of heights from a selected 
string and user given cross-falls or cross-fall between two selected strings.

The String Modifier commands are actually part of an mtf file and are documented in 
“Advanced Design” chapter of this manual.

This option allows the user to run just the string_modifiers section of the mtf file.

On selecting the String Modifiers option, the String Modifiers Function panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input available template functions

name of the function to define the apply for. If the function already exists and is picked from a pop-up 
or an <enter> is given at the end of the name, the information from the existing function will be placed 
in the appropriate panel fields.

Template file input available mtf files

the name of the many template file to use the string_modifiers section from.

Apply button

apply the string_modifiers section of the many template file.

Interface
interface_function

Position of option on menu: Design =>Apply =>Interface

An interface string is where the design meets the natural terrain - it shows the extent of the 
design. The method used for calculating the interface string for a given string, tin and cut and 
fill slopes, is as follows:

For a point on a string, an interface point is calculated by going off at right angles to the string 
along a line of fixed slope until either the tin is cut or a fixed (plan) distance is travelled. The 
slope of the line is either the cut or fill slope depending on whether the string point is below 
the tin (cut point) or above the tin (fill point).

The interface string for a string is constructed by calculating the interface points at regular 
intervals along the string and then joining the interface points together to form the interface 
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string.

After calculating an interface string and examining the results, it is often necessary to make 
changes to either the original string, the cut and fill slopes used, or even the tin used for 
interfacing against. The interface string and slope strings created during the interface would no 
longer be valid and need to be replaced by new information.

Although this can be accomplished by deleting the incorrect models and replacing them by new 
ones by re-applying the interface, this is would be time consuming if repeated over and over 
again. The interface function has been introduced to help reduce the work involved when re-
calculating an interface string.

Basically, an interface function keeps track of all the information involved in creating an 
interface string and all the strings and models created during the interface. If either the original 
string, the cut and fill slope or the tin is subsequently modified, the interface functions can be re-
run and all the old information automatically deleted and replaced by the updated information.

On selecting interface, the interface function panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function function box available interface functions

name of the function to define the interface for. If the function already exists and is picked from a 
popup or and an <enter> is given at the end of the name, the information from the existing function 
will be placed in the appropriate panel fields.

String interface string select box

select the string to calculate the interface from.

Cut slope 1 v in input 1.0

the slope of the interface line if a point is in cut. A cut slope of one vertical to the given value of 
horizontal units is used. Positive is up for a cut slope. A value 0 is used to designate a horizontal line.

Fill slope 1 v in input 1.0

the slope of the interface line if the point is in fill. A fill slope of one vertical to the given value of 
horizontal units is used. Positive is down for a fill slope. A value 0 is used for a horizontal line.
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Section separation input 10

the distance between the points on the selected string that interface points will be calculated from.

Search distance input 100

the (plan) distance to search along the interface line to see if the tin has been intersected. If the tin has 
not been intersected then the z-value at the end of the interface line is taken as the interface point z-
value.

Left or right input left left, right

the interface point is calculated by going out at right angles to the selected string. It is possible to go to 
either the left or the right depending on the value of this field.

Tin tin box available tins

name of the tin that the interface points will be calculated against.

Model for interface model box available models

name of the model to contain the calculated interface string.

Model for slope lines model box available models

name of the model to contain the lines connecting the string points with the interface points (the slope 
lines). If the field is blank, no slope lines are recorded.

Interface button

An interface string is calculated using the selected string and the parameters defined in the panel. The 
interface string points are coloured red if the original string point was in cut and green if the original 
string point was in fill.

<esc> can be used to abort the interface option.

Amend VG
amend_vg

amend_linear

amend_cubic

amend_vg_linear

amend_extend_xfall

Position of option on menu: Design =>Apply =>Amend VG

Amend VG is used to modify the vertical geometry of an alignment string using a variety of 
methods including linear interpolation cubic reverse and circular reverse interpolating or by 
extending crossfall between two given strings.

Selecting Amend VG, the Amend VG panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Amend mode choice box linear, cubic reverse, 
circular reverse, VG linear,
Extend Xfall

if linear, a panel to input the values for Start offset/height/crossfall %, End offset/height/
crossfall % and Absolute height is displayed and filled in to define how to modifying the vertical 
geometry of the Amend string

If cubic reverse, a panel to input the values for Start offset/height/crossfall %, End offset/height/
crossfall % and Absolute height is displayed and filled in to define how to modifying the vertical 
geometry of the Amend string

If circular reverse, no extra information is needed to define how to modifying the vertical geometry of 
the Amend string

If VG linear, a panel to input the values for Start height/crossfall %, End height/crossfall % and 
Absolute height is displayed and filled in to define how to modifying the vertical geometry of the 
Amend string

If Extend Xfall, a panel to select the two strings to extend the crossfall from is displayed and filled in 
to define how to modifying the vertical geometry of the Amend string
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Start chainage input

chainage to start modifying the vertical geometry of a string

End chainage input

chainage to stop modifying the vertical geometry of a string

Chainage interval input 10

chainage interval to apply the vertical geometry modification

Reference string select box

select the reference string to define chainage and perpendicular. If there is no Hinge string, then z-
values are only taken from the Reference string.

chainage interval to apply the vertical geometry modification

Amend string select box

select the reference string to define chainage and perpendicular. If there is no Hinge string, then z-
values are only taken from the Reference string.

Hinge string select box

if selected, the string to take z-values from

Amend string select box

the string to have its vertical geometry amended

Amend button

amend the vertical geometry of the Amend string between the start and end chainages
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Boxing
template_boxing

Position of menu: Design =>Boxing

In the Apply many option, boxing can be applied at the same time as applying templates by 
special commands in the many templates file.

However, it is also possible to apply boxing as a post process to a model of x-sections as long as 
the x-sections were generated in the 4d string format (this can be done by both apply options).

The definition of boxing is given in the chapter “Advanced Design” . The boxing walk-right menu is

For the option Create, please continue to the section “Create” 
Create file “Create File” 
Edit “Edit” 
Edit file “Edit File” 
Boxing “Boxing” 
Boxing many “Boxing Many” 
Boxing many (function) “Boxing Many Function” 

Create
create_boxing_file

Position of option on menu: Design =>Boxing =>Create

The boxing=>create option is used to create a new boxing file (*.bf) and add new boxing 
definitions to the file using 12d Model panels. The created file is written to disk and can be 
edited using a standard file editor, or using the boxing=>edit option.

Selecting Create brings up the create boxing file panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Boxing file input *.bf files
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name of the boxing file to create.

Create button

create a boxing file with name given by the boxing file panel fields.
If the file given in the boxing file field does not exist, then the edit boxing file panel is placed on the 
screen and is used to created and edit the boxing definitions for the boxing file.
If the file already exists, then nothing will happen on selecting create.

edit_boxing_definitions

When Create is selected from the Create Boxing File panel, it brings up the Edit Boxing Definitions 
panel which is used to create and edit the boxing definitions to be saved in the boxing file.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Boxing definition input boxing definitions in file

name of the boxing definition (in the current boxing file) to create or edit.

Create button

create a boxing definition with name given by the boxing definition panel field
If the boxing definition given in the boxing definition field does not exist, then the boxing rules panel 
is placed on the screen and is used to created the new boxing definitions for the boxing file.
If the boxing definition already exists, then nothing will happen on selecting create.

Edit button

edit an existing boxing definition with name given by the boxing definition panel field
If the boxing definition given in the boxing definition field exists, then the boxing rules panel is placed 
on the screen and is used to edit the existing boxing definitions for the boxing file.
If the boxing definition does not exist exists, then nothing will happen on selecting edit.

Delete button

delete an existing boxing definition with name given by the boxing definition panel field
A yes-no panel confirms the deletion.

Save file button

save the boxing file with the boxing definitions to disk.

The Edit Boxing Definitions panel is described in the section “Edit Boxing File” of chapter 
“Advanced Design” .

Create File
create_boxing_file___bf
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Position of option on menu: Design =>Boxing =>Create file

The boxing=>create file option is used to create a new boxing file (*.bf) with the editor pointed to 
by the EDIT_4D environment variable.

The created file will already have a section header set up for a boxing called “1”(key word and 
opening and closing brackets).

Selecting create file brings up the create boxing file *.bf panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder input current folder

name of the folder for the .bf file.

File to create input *.bf files

name of the file to create.

Create button

create a boxing file given by the folder and file to create panel fields. If the file given in the file to edit 
field does not exist, then a new file is created which already has a section header set up.

The format for the boxing file is described in the chapter “Advanced Design” .
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Edit
edit_boxing_file

Position of option on menu: Design =>Boxing =>Edit

The boxing=>edit option is used to edit boxing files (*.bf) using 12d Model panels.

The boxing=>edit option has two modes of operation - selecting the boxing=>edit itself, or by 
activating the boxing=>edit option’s walk-right menu, folder *.bf.

Selecting boxing=>edit itself brings up the edit boxing file panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Boxing file input *.bf files

name of the boxing file to edit.

Edit button

edit the file given by boxing file panel field.
If the file given in the boxing file field exists, then the edit boxing definitions panel is brought up to 
create/edit the boxing definitions in the boxing file.

The edit boxing definitions panel is described in the “Edit Boxing File” from the chapter “Advanced 
Design” .

The boxing=>edit walk-right menu provides a list all the boxing files (files ending in .bf) in the 
current folder. When a file is selected from the list, the edit boxing definitions panel is brought up 
to create/edit the boxing definitions in the boxing file. The edit boxing definitions panel is 
described in the “Edit Boxing File” from the chapter “Advanced Design” .

Edit File
edit_boxing_file___bf

Position of option on menu: Design =>Boxing =>Edit file

The boxing=>edit file option is used to edit boxing files (*.bf) with the editor pointed to by the 
EDIT_4D environment variable.

The boxing=>edit file option has two modes of operation - selecting the boxing=>edit file itself, or 
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by activating the boxing=>edit file option’s walk-right menu, folder *.bf.

Selecting boxing=>edit file itself brings up the edit boxing file *.bf panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder input current folder

name of the folder for the .bf file.

File to edit input *.bf files

name of the file, in folder, to edit.

Edit button

edit the file given by the folder and file to edit panel fields. If the file given in the file to edit field does not 
exist, then a new file is created which already has a section header set up.

The boxing=>edit file walk-right menu provides a list all the boxing files (files ending in .bf) in 
the current folder. When a file is selected from the list, it is automatically loaded into the editor.

The format for the boxing file is described in the “Boxing File Format” section of the chapter 
“Advanced Design” .
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Boxing
apply_boxing

Position of option on menu: Design =>Boxing =>Boxing

On selecting the boxing option, the apply boxing panel is displayed.

This panel can be used to create boxing sections by applying the boxing definition to a selected 
4d string or model of sections created as 4d strings. Only the one boxing definition is used for all 
of the sections.

The apply boxing panel is

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model to box input available models

model of sections (in 4d string format) to apply the boxing definition to.

Boxing file input *.bf files

name of the file containing the boxing definition to be applied to the sections in the model to box.

Start/End chainage input

the start/end string chainage for applying boxing. If blank, then the start/end chainage is taken to be 
the chainage at the beginning/end of the picked string.

Model for boxing input available models

model for the created boxing x-sections

Pick button

after picking the pick button, any selected strings will have the boxing applied to them.

Box button

apply the boxing definition given in the boxing file to the sections in the model to box. between the 
given start chainage and end chainage.
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Boxing Many
apply_many_boxing

Position of option on menu: Design =>Boxing =>Boxing many

This panel can be used to create boxing sections by applying the boxing definitions as specified 
in a boxing file to a selected 4d string or to a model of sections. If an individual section 4d string 
is picked, the option uses the boxing defined for the chainage where the section 4d string was 
created.

The boxing file allows the use of more than one boxing definition.

Selecting boxing many displays the Apply Many Boxing panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model to box input available models

model of sections (in 4d string format) to apply the boxing definition to.

Templates file input *.mtf files

name of the many templates file which contains the application of the boxing definitions to the sections 
given in the model to box panel field.

If Boxing file is non-blank, then all the boxing definitions referred to in the template file are taken from 
the Boxing file. If Boxing file is blank, use the boxing file given in the template file.

The format of the templates file is the same as the left_boxing and the right_boxing sections in the apply 
many templates file. 

Boxing file input *.bf files

The file of boxing definition to be applied to the sections in the model given by the model to box panel 
field

if non-blank, the name of the file containing all the boxing definitions referred to in file given in the 
template file panel field. The format of the template file is the same as the boxing in the apply many 
template file. If blank, use the boxing file given in the template file.

Model for boxing input available models

model for the created boxing x-sections

Pick button
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after picking the pick button, any selected strings will have the boxing applied to them.

Box button

apply the boxing as given by the template file, using the boxing definitions is the boxing file, to the 4d 
sections in the model for boxing field. The new boxing sections are added to the model for boxing.
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Boxing Many Function
boxing_many

Position of option on menu: Design =>Boxing =>Boxing many (function)

This option is used to cut strings to create sections and then apply up to eight layers of boxing to 
the cut sections.

Selecting Boxing many (function), the Boxing Many panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function function box available boxing functions

name of the boxing function

Boxing file input *.bf files

The file of boxing definition that may be applied to the cut sections
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Centreline string select

string to use for chainage and perpendicular for cutting crass sections to apply boxing to

Sections tab

Model to cut through model box available models

model of strings to cut sections through

Section separation input 10

the distance along the selected centre line to generate plan section lines to be used to cut through the 
model or view.

Left/Right cut width input 50

the left/right distance to go out from the centre line for creating a section to cut through the strings.

Chord/arc tolerance input default chord/arc tolerance

the chord to arc tolerance to use on the selected string for determining how many plan sections are cre-
ated around horizontal curves.

Start/End chainage input

if non-blank then sections for the cuts are restricted to between the given start and end chainage of the 
selected centreline string

Special chainages file file box *.spf files

a file containing chainages, one per line, that are also used as extra chainages to create cross sections at

Model for sections model box available models

model for the cut cross sections

Colour colour box available colours

colour for the cut cross sections

Create tin for sections tick box

if tick, then a tin of the cross sections is created

Tin for sections tin box available tins

name of the tin of cross sections

Model for tin model box available models

model for the cross sections tin

Layers tab
the layers tab consists of a grid for defining up to eight layers of boxing strings and sections.
The last boxing layer is also referred to as the subgrade layer.

Boxing Layer 1-8:
if non blank, boxing strings and sections will be created for that layer.

Strings input

if non-blank, pre*post text to use with the function name to create the name of the model for the boxing 
strings for this layer.
If blank, the boxing strings will not be stored for this layer.

Sections input available models

if non-blank, pre*post text to use with the function name to create the name of the model for the boxing 
sections for this layer.
If blank, the boxing sections will not be stored for this layer.

 Colour input available colours

colour for the boxing sections for this layer
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Create subgrade tin tick box

if tick, then a tin of the subgrade strings and sections is created. Note - the subgrade is the last boxing 
layer.

Subgrade tin tin box available tins

name for the subgrade tin

Subgrade tin model model box available models

model for the subgrade tin

Left Boxing tab
tab for applying left boxing - gives the chainage range and boxing definitions to use for each of the eight 
layers of boxing

Layer choice box Layer 1, Layer 2 ... Layer 8

as each layer is selected, a grid for defining the chainages and boxing definition that applies to that 
chainage are given in the grid

For each selected layer:

Chainage input available models

for the selected boxing layer, the chainage range to apply the boxing definition to

Boxing boxing definition box boxing definitions

the boxing definition to use with the given chainage range. The pop-up lists all the boxing definitions 
in the Boxing file

Comment

record a comment

Right Boxing tab
tab for applying right boxing - gives the chainage range and boxing definitions to use for each of the 
eight layers of boxing

Layer choice box Layer 1, Layer 2 ... Layer 8

as each layer is selected, a grid for defining the chainages and boxing definition that applies to that 
chainage are given in the grid

For each selected layer:

Chainage input available models

for the selected boxing layer, the chainage range to apply the boxing definition to

Boxing boxing definition box boxing definitions

the boxing definition to use with the given chainage range. The pop-up lists all the boxing definitions 
in the Boxing file

Comment

record a comment
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Volumes tab

Calculate volumes tick box

if tick, then end area volumes are created

Tin tin box available tins

name of the natural surface tin - required if volumes to the natural surface are calculated

Model for tin sections model box available models

if non blank, model to put the natural surface sections into

Report file file box *.rpt

if non-blank, the name of the file to contain the volume report. If the file already exists, the report will 
be appended to the file.
If blank, no report is produced.

Report model choice box Summary, Full

if Summary, the report only contains the final volumes.
If Full, the report contains sections by section areas and volumes as well as the summary of volumes.

Calculate natural surface to design volumes tick box tick

if tick, end area volumes between the natural surface and the design strings are written to the report 
file

Calculate natural surface to subgrade volume tick box tick

if tick, end area volumes between the natural surface to the subgrade (the last boxing layer) are written 
to the report file

Calculate design to subgrade volumes tick box tick

if tick, end area volumes between the design strings and the subgrade (the last boxing layer) are 
written to the report file.

Calculate inter-boxing layer volumes tick box tick

if tick, end area volumes between each of the boxing layers are written to the report file.

Run button

run the option
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MTF
mtf
Position of menu: Design =>MTF

In the apply many option, a many template file is used to control the application of templates to 
the hinge string.
The full definition for the mtf file is given in the chapter “Advanced Design” .

The mtf walk-right menu is

Each option in this menu will now be described.

For the option Create, go to the section “Create MTF” 
Create file “Create File” 
Edit “Edit” 
Edit file “Edit File” 
Rename “Rename MTF” 
Apply many “Apply Many” 
Edit by string “Edit by String” 
Copy MTF “Copy MTF” 
Delete MTF “Delete MTF” 

Create MTF
create_mtf_file
Position of option on menu: Design =>MTF =>Create

The mtf=>create option is used to create a new mtf file (*.mtf) using 12d Model panels. The 
created file is written to disk and can be edited using a standard file editor, or using the 
MTF=>Edit option.
Selecting Create brings up the Create MTF File panel.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

MTF file file box *.mtf files

name of the mtf file to create.

Create button

create an mtf file with name given by the mtf file panel fields.
If the file given in the mtf file field does not exist, then the mtf edit menu is placed on the screen and is 
used to created and edit the mtf sections in the mtf file.
If the file already exists, then nothing will happen on selecting Create.

MTF Edit

mtf_edit

When Create is selected from the Create MTF File panel, it brings up the MTF Edit menu which is 
used to create and edit the mtf sections to be saved in the mtf file.

 

The MTF Edit menu is described in the chapter “Advanced Design” .

Create File
create_mtf_file___mtf

Position of option on menu: Design =>MTF =>Create file

The mtf=>create file option is used to create a new many templates files (*.mtf) with the editor 
pointed to by the EDIT_4D environment variable.

The created file will already have all the section headers (key words and opening and closing 
brackets) in it.

Selecting create file brings up the create mtf file *.mtf panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder input current folder

name of the folder for the .mtf file.

name of mtf file being edited
create/edit template table
 "      "      " special chainages
create/edit hinge modifiers
 "      "      " modifiers table
 "      "      " stripping depths
 "      "      " boxing table
create/edit width modifiers
create/edit string modifiers
save the mtf information to a file
recalc the Apply many with this mtf
apply a delta chainage to the mtf
quit without saving the information
finish, remove the menu
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File to create input *.mtf files

name of the file to create.

Create button

create an mtf file given by the folder and file to create panel fields. If the file given in the file to edit field 
does not exist, then a new file is created which already has each of the section headers set up.

The format for the mtf file is described in the chapter “Advanced Design” .

Edit
edit_mtf_file

Position of option on menu: Design =>MTF =>Edit

The mtf=>edit option is used to edit mtf files (*.mtf) using 12d Model panels.

The mtf=>edit option has two modes of operation - selecting the mtf=>edit itself, or by activating 
the mtf=>edit option's walk-right menu, folder *.mtf.

Selecting mtf=>edit itself brings up the edit mtf file panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

MTF file input *.mtf files

name of the mtf file to edit.

Edit button

edit the file given by mtf file panel field.
If the file given in the mtf file field exists, then the mtf edit menu is brought up to create/edit the mtf 
sections in the mtf file.
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The MTF edit menu is described in the chapter “Advanced Design” .

The mtf=>edit walk-right menu provides a list all the mtf files (files ending in .mtf) in the current 
folder. When a file is selected from the list, the edit mtf file panel is brought up to create/edit the 
mtf sections in the mtf file.

The MTF edit menu is described in the chapter “Advanced Design” .

Edit File
edit_mtf_file___mtf

Position of option on menu: Design =>MTF =>Edit file

The mtf=>edit file option is used to edit many templates files (*.mtf) with the editor pointed to by 
the EDIT_4D environment variable.

The mtf=>edit file option has two modes of operation - selecting the mtf=>edit file itself, or by 
activating the mtf=>edit file option's walk-right menu, folder *.mtf.

Selecting mtf=>edit file itself brings up the edit a file *.mtf panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder input current folder

name of the folder for the .mtf file.

File to edit input *.mtf files

name of the file, in folder, to edit.

Edit button

name of mtf file being edited
create/edit template table
 "      "      " special chainages
create/edit hinge modifiers
 "      "      " modifiers table
 "      "      " stripping depths
 "      "      " boxing table
create/edit width modifiers
create/edit string modifiers
save the mtf information to a file
recalc the Apply many with this mtf
apply a delta chainage to the mtf
quit without saving the information
finish, remove the menu
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edit the file given by the folder and file to edit panel fields. If the file given in the file to edit field does not 
exist, then a new file is created which already has each of the section headers set up.
The format for the mtf file is described in the chapter “Advanced Design” .

The mtf=>edit file walk-right menu provides a list all the many template files (files ending in .mtf) 
in the current folder. When a file is selected from the list, it is automatically loaded into the 
editor.

The format for the mtf file is described in the chapter “Advanced Design” .
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Rename MTF
mtf_rename
Position of option on menu: Design =>MTF =>Rename

Selecting Rename brings up the MTF Rename panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

MTF to rename file box *.mtf files

name of the mtf file to rename

New name

new name for the mtf file

Change MTF name is associated Apply Many functions tick box

if tick, rename the mtf in all functions that include it

Rename button

rename the mtf file with the new name
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Apply Many
Position of option on menu: Design =>MTF =>Apply many

The Apply many option is used to apply a mtf file to a selected hinge string.

The option has already been described under Design=>Apply=>Apply many.

For the option Apply many, please go to the section “Apply Many” .

Edit by String
Position of option on menu: Design =>MTF =>Edit by string

The Edit by string option is used to edit the MTF by selecting a string created from using the 
MTF in an Apply Many. 

Selecting Edit by string brings up the Edit MTF/Survey Function Data panel:

After selecting the Pick Edit button, a string created by MTF function is selected and the MTF 
editor is started for the MTF.

For information on the MTF Editor, go to the section “MTF Edit” .
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Copy MTF
copy_an_mtf
Position of option on menu: Design =>MTF =>Copy

Selecting Copy brings up the Copy an MTF panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

MTF to copy file box *.mtf files

name of the mtf file to rename

Target MTF

new name for the mtf file

Copy all backups tick box

if tick, copy all the backup files of the mtf as well

Copy button

copy the mtf file to the new name
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Delete MTF
delete_an_mtf
Position of option on menu: Design =>MTF =>Delete

Selecting Delete brings up the Delete an MTF panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

MTF to delete file box *.mtf files

name of the mtf file to delete

Delete all backups tick box

if tick, delete all the backup files of the mtf as well

Delete button

delete the mtf file



12d Model Reference Manual

Page 1682 March 2007Barwon Sewer

Barwon Sewer
This is a separate chargeable module. 

Documentation will be provided when the module is purchased.

The Barwon sewer option is used to place waste water reticulation networks within a subdivision 
and produce plots and reports to Barwon Water format. The network is placed in three 
dimensions including manholes and house connections.

If used in conjunction with the services on a section view, interference with neighbouring pipe 
strings can be taken into consideration when placing the network.

The waste water process consists of a number of steps.

▲ creating the sewer network

▲ checking that residential blocks are controlled by the network

▲ creating the house connections for the sewer

▲ producing plots and reports

Note

The "barwon sewer" string can only have straights between manholes. The drainage string 
described in the chapter, Drainage and Sewer, is a generalization of the sewer string and can 
have arcs between manholes. 
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Estate Lots
Position of menu: Design =>Estate/Lots

estate_lots

This module is currently under development.

The Estate Lots module is for creating house lots for an Estate (Subdivision).

There are options to create and edit lots by a variety of methods. Once the lots are created they 
can be numbered, given a lot type (see “Lot types” ) and labelled.

The labelling includes labelling the side of lots with bearing and distances, lots with areas and lot 
numbers.

Reports of lot areas and types can be created and lots coloured according to areas.

Finally options exist to create point numbers and reports for setting out the lots.

The Estate/Lots walk-right menu is:

For the option Create lots, please continue to the section “Create Lots” .
Edit lots  “Edit Lots” 
Filter lots  “Filter Lots” 
Number lots  “Number Lots” 
Label lots “Label Lots” 
Delete lot attributes/text “Delete Lot Attributes and Text” 
Setout lots “Setout Lots” .
Report lots “Report Lots” .
Lot utilities “Lot Utilities” .

Lot types
Lots can have a type which is used in reports. The lot types are defined in a text file called 
lottypes.4d which is searched for in the standard library areas (see “Library, User Library” ).

For example of lottypes.4d is

park
road
other
surround
McDonalds

Create Lots
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create_lots

Position of menu: Design =>Estate/Lots => Create lots

For the option Create lot, please continue to the section “Create Lot” .
 Create lot from boundaries  “Create Lot from Picking” .
 Create lot by picking segments  “Create Lot from Picking Segments” .
 Create lot from polygon  “Create Lot from Polygon” .
 Read geocomp lots file  “Read Geocomp Lots File” .

Create Lot
lot_creation_panel

Position of option on menu: Design =>Estate/Lots => Create lots =>Create lot

This option creates lots of a user given area using the front and back strings for a number of lots 
and an initial straight line edge of a lot. The final edge of the lot then needs to be determined.

The methods of creating the final edge of lot are:

(a) parallel the existing side - parallel edge. See “Parallel Edge” 

(b) having the same bearing as a selected line - parallel pick. See “Parallel Pick” 

(c) having a given bearing - parallel bear. See “Parallel Bearing” 

(d) perpendicular to either the front string or the back string - perpendicular. See “Perpendicular 
and Perpendicular Pick” 

(e) perpendicular to either the front string or the back string but starting from a user selected 
point - perpen start pt. See “Perpendicular and Perpendicular Pick” See “Perpendicular and 
Perpendicular Pick” 

(f)  pivoting about a selected point - pivot pick. See “Pivot Pick and Pivot Frontage” 

Front string - selected with direction to 
indicate which way the lots are created.

Back string - selected with direction to 
indicate which way the lots are created.

First edge
of the lot

?Final edge
of the lot is
to be determined
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(g)  pivoting about the point at minimum frontage - pivot frontage. See “Pivot Pick and Pivot 
Frontage” 

(h) closing a selected string - close string. See “Close String” 

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model for lot model box available models

model for the created lot.

View for lot view box available views

view to add model of created lot to.

Lot colour colour box available colours

colour for the created lot.

Min area double box

required area of the created lot.

Min frontage input box

required minimum frontage of the created lot.

Area tolerance double box

lot to be created can be within this tolerance of the minimum area.required area of the created lot.
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Pick front string select

pick the string to form the front of the created lot.

Pick back string select

pick the string to form the back of the created lot.

Pick edge string select

pick the straight line to form the edge of the created lot.
The front, back and edge form three sides of the lot to be created.

Method choice box parallel edge parallel edge, parallel pick
parallel bear, perpendicular
pivot pick, pivot frontage
close string

pick the string to form the back of the created lot.

Process button

use the selected front, back and edged and then create the final side of the lot by the selected method.

Continue to the next section “Creating Lots from a Front and Back String and an Edge” for a full 
description of each method of creating the lots.

Creating Lots from a Front and Back String and an Edge

Parallel Edge

This method creates a lot of a user specified area using user selected front and back strings and a 
user selected initial edge. The final edge then needs to be determined to define the lot.

The front and back strings must be selected with direction to indicate which direction to move 
along them to form the lot. The front and back strings can not be closed strings and must be 
different strings. The front and back strings can have more than one segment and can have 
straight or arc segments.

The initial edge must cut or be very close to cutting the front and back strings. The initial edge 
must be one straight line segment. It can not be an arc.

For Parallel Edge, the final edge is created parallel to the initial edge and is positioned along the 
front and back strings in their selected direction so that the lot has the user given area (to within 
the area tolerance). 

The lot is only created if the new edge is at least the minimum frontage distance along the front 
string.

When the lot is created, the final edge is automatically set as the initial edge for the calculation of 
the next lot.
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Parallel Bearing

This method creates a lot of a user specified area using user selected front and back strings and a 
user selected initial edge. The final edge then needs to be determined to define the lot.

The front and back strings must be selected with direction to indicate which direction to move 
along them to form the lot. The front and back strings can not be closed strings and must be 
different strings. The front and back strings can have more than one segment and can have 
straight or arc segments.

The initial edge must cut or be very close to cutting the front and back strings. The initial edge 
must be one straight line segment. It can not be an arc.

For Parallel Bear, the final edge is created with a user specified bearing and is positioned along the 
front and back strings in their selected direction so that the lot has the user given area (to within 
the area tolerance). 

The lot is only created if the new edge is at least the minimum frontage distance along the front 
string.

When the lot is created, the final edge is automatically set as the initial edge for the calculation of 
the next lot.

Front string - selected with direction to 
indicate which way the lot is created.

Back string - selected with direction to 
indicate which way the lot is created.

First edge
of the lot

Final edge
parallel to theCreated lot

Parallel Edge

first edge

Front string - selected with direction to 
indicate which way the lot is created.

Back string - selected with direction to 
indicate which way the lot is created.

First edge
of the lot

Final edge
has aCreated lot

Parallel Bearing

given bearing
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Parallel Pick

This method creates a lot of a user specified area using user selected front and back strings and a 
user selected initial edge. The final edge then needs to be determined to define the lot.

The front and back strings must be selected with direction to indicate which direction to move 
along them to form the lot. The front and back strings can not be closed strings and must be 
different strings. The front and back strings can have more than one segment and can have 
straight or arc segments.

The initial edge must cut or be very close to cutting the front and back strings. The initial edge 
must be one straight line segment. It can not be an arc.

For Parallel Pick, the final edge is created with the bearing of a user selected segment and is 
positioned along the front and back strings in their selected direction so that the lot has the user 
given area (to within the area tolerance). 

The lot is only created if the new edge is at least the minimum frontage distance along the front 
string.

When the lot is created, the final edge is automatically set as the initial edge for the calculation of 
the next lot.

Perpendicular and Perpendicular Pick

This method creates a lot of a user specified area using user selected front and back strings and a 
user selected initial edge. The final edge then needs to be determined to define the lot.

The front and back strings must be selected with direction to indicate which direction to move 
along them to form the lot. The front and back strings can not be closed strings and must be 
different strings. The front and back strings can have more than one segment and can have 
straight or arc segments.

The initial edge must cut or be very close to cutting the front and back strings. The initial edge 
must be one straight line segment. It can not be an arc.

For Perpendicular, the final edge is constrained to be perpendicular to either the front or the back 
string and is positioned along the front and back strings in their selected direction so that the lot 
has the user given area (to within the area tolerance). 

For Perpendicular Pick, a start point is selected on the front/back string and the final edge is 
created past the start point. This option only needs to be used when Perpendicular has problems 
finding a solution due to sharp changes of bearing along the front/back string.

The lot is only created if the new edge is at least the minimum frontage distance along the front 
string.

Front string - selected with direction to 
indicate which way the lot is created.

Back string - selected with direction to 
indicate which way the lot is created.

First edge
of the lot

Final edge
has the sameCreated lot

Parallel Pick

bearing as a
selected segment
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When the lot is created, the final edge is automatically set as the initial edge for the calculation of 
the next lot.

Pivot Pick and Pivot Frontage

This method creates a lot of a user specified area using user selected front and back strings and a 
user selected initial edge. The final edge then needs to be determined to define the lot.

The front and back strings must be selected with direction to indicate which direction to move 
along them to form the lot. The front and back strings can not be closed strings and must be 
different strings. The front and back strings can have more than one segment and can have 
straight or arc segments.

The initial edge must cut or be very close to cutting the front and back strings. The initial edge 
must be one straight line segment. It can not be an arc.

For Pivot Pick, a position is selected on either the front or back string to be one point of the final 
edge. The other point of the final edge is determined so that the lot has the required given area (to 
within the area tolerance).

For Pivot Frontage, the pivot point is taken to be the position on the front string that is the 
minimum frontage distance along the front string from the initial edge.

The lot is only created if the new edge is at least the minimum frontage distance along the front 
string.

When the lot is created, the final edge is automatically set as the initial edge for the calculation of 
the next lot.

Front string - selected with direction to 
indicate which way the lot is created.

Back string - selected with direction to 
indicate which way the lot is created.

First edge
of the lot

Final edge
is perpendicular

Created lot

Perpendicular and Perpendicular Pick

to front or back 
string
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Close String

This method simply closes the string that is selected by the user.

Create Lot from Picking 
boundary_polyline_panel

Position of option on menu: Design =>Estate/Lots => Create lots =>Picking point inside

This option creates a lot by a picking inside a collection of strings and the lot is created from the 
closest strings to the picked position. The picked position must be selected so that all sides of the 
lot can be "seen" from the picked position. That is, a straight line can be drawn from the picked 
position to the lot side without cutting any other segment.

On selecting the Create lot by picking point inside option, the Create Lot - Pick Point Inside panel is 
displayed.

Front string - selected with direction to 
indicate which way the lot is created.

Back string - selected with direction to 
indicate which way the lot is created.

First edge
of the lot

Position for
this point of theCreated lot

Pivot Pick and Pivot Frontage

final edge is user
selected

Select a position that is
inside the lot to be created

Created lot

Creating a Lot by Picking Inside the Lot
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View for lot view box available views

view to add model of created lot to.

Model for lot model box available models

model for the created lot.

Lot colour/colour for polygoncolour box available colours

colour for the created lot.

Search distance double box 20

maximum distance to search from the selected point for sides of the lot

Pick string select

pick the position to try and form a lot around.

Create Lot from Picking Segments
lot_creation_pick_panel

Position of option on menu: Design =>Estate/Lots => Create lots =>by picking segments

This option creates a lot by a picking each segment in its order (and with direction) around the 
lot. Segments will be automatically extended or clipped to form the lot.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model for lot model box available models

model for the created lot.

Lot colour colour box available colours

colour for the created lot.

Join first and last segment tick box

if tick, join the end of the last selected segment to the start of the first selected segment to form the final 
side of the lot.

Pick sides string select

pick, with direction, the segments to be joined together to form the sides of the lot.

Select each segment (with direction)
in the order that they are to form
the segments of the lot.

Created lot

Creating a Lot by Picking the Lot Segments

1

2

3

4

5

6

7

The segments will be automatically
clipped.
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Process button

create the lot from the selected segments.

Create Lot from Polygon
lot_polygon_panel

Position of option on menu: Design =>Estate/Lots => Create lots =>Lots from polygons

This option converts strings to a lot. The strings can be open.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type

data source type.

Data source

data source for strings to convert to lots.

Model for lot model box available models

model for the created lot.

Lot model model box available models

model for the created lots.

Lot colour colour box available colours

colour for the created lots.

Include open strings tick box

if tick, open strings are used to from lots by making then closed strings.
If not tick, open strings are ignored.

Process button

create lots from the selected strings.

Read Geocomp Lots File
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lot_geocomp_panel

Position of option on menu: Design =>Estate/Lots => Create lots =>Read geocomp lots file

This option reads a Geocomp lots file and creates 12d Model lots.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Points file *.pts files

name of the Geocomp points file.

Lots file *.pts files

name of the Geocomp lots file - is uses points from the given Geocomp points file.

Model for lot model box available models

model for the created lot.

Process button

read in the given Geocomp points and lots file and created 12d Model lots.

Edit Lots
edit_lots

Position of menu: Design =>Estate/Lots =>Edit lots

For the menu Adjust area, please continue to the section “Adjust Area” .
Subdivide area  “Subdivide Area” .

Adjust Area
adjust_area

Position of menu: Design =>Estate/Lots =>Edit lots =>Adjust area



Chapter 17  Design

March 2007 Page 1695Estate Lots

For the option Pivot, please continue to the section “Adjust Lot by Pivot” .
Parallel edge  “Adjust Lot by Parallel Edge” 
Parallel bearing  “Adjust Lot by Parallel Bearing” .
Perpendicular  “Adjust Lot by Perpendicular” .

adjust_lot_by_pivot

Adjust Lot by Pivot
Position of option on menu: Design =>Estate/Lots =>Edit lots =>Adjust area =>Pivot

This option adjusts the size of a lot by pivoting one side about one of its end points until the lot 
area has a new given area.

The fields and buttons used in this panel have the following functions.

area
700

Select the side to be swung
and the pivot point
by picking the side with

Pivot point

Side to swing about
the pivot point

area
700 direction going away from

the required pivot point

area
800

Adjusted lot
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Field Description Type Defaults Pop-Up

Pick lot edge string select

pick the lot to adjust by picking a side of the lot with direction. The start of the selected side will be the 
pivot point.

Lot area output box

area of the selected lot.

New area input box

required area of the adjusted lot. The area can be larger or smaller than the existing lot area.

Process button

adjust the lot by pivoting the side.

adjust_lot_by_parallel_edge

Adjust Lot by Parallel Edge
Position of option on menu: Design =>Estate/Lots =>Edit lots =>Adjust area =>Parallel edge

This option adjusts the size of a lot by moving a side parallel to itself until the lot area has a new 
given area.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

area
700

Select the side to be
paralleled

area
800

Adjusted lot
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Pick lot edge string select

pick the lot to adjust by picking the edge of the lot that is to be paralleled.

Lot area output box

area of the selected lot.

New area input box

required area of the adjusted lot. The area can be larger or smaller than the existing lot area.

Process button

adjust the lot by paralleling the selected edge.

adjust_lot_by_parallel_bearing

Adjust Lot by Parallel Bearing
Position of option on menu: Design =>Estate/Lots =>Edit lots =>Adjust area =>Parallel bearing

This option adjusts the size of a lot by moving a side parallel to a given bearing until the lot area 
has a new given area.

The fields and buttons used in this panel have the following functions.

area
700

Select the corner for the 
new side to go through

area
800

Adjusted lot

Bearing to make
the selected side
parallel to



12d Model Reference Manual

Page 1698 March 2007Estate Lots

Field Description Type Defaults Pop-Up

Pick lot corner string select

pick the lot to adjust by picking the corner of the lot that the side goes through and has the given 
bearing.

Lot area output box

area of the selected lot.

New area input box

required area of the adjusted lot. The area can be larger or smaller than the existing lot area.

Bearing bearing box

the bearing used for the selected edge.

Process button

adjust the lot by paralleling the selected edge with the given bearing.

adjust_lot_by_perpendicular

Adjust Lot by Perpendicular
Position of option on menu: Design =>Estate/Lots =>Edit lots =>Adjust area =>Perpendicular

This option adjusts the size of a lot by creating a new side perpendicular to a selected side and 
then moving the new side until the created lot area has a given area.

Note -the new area must be less than the original area.

area
700

Select the side to create the
new side perpendicular to
and the corner to start from

area
600

direction going to the 

start

Adjusted lot

by picking the side with

start corner

area
600

New side perpendicular
to top

corner
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick lot edge string select

pick the side of the lot that a new side will created perpendicular to

Lot area output box

area of the selected lot.

New area input box

required area of the adjusted lot. The area must be smaller than the existing lot area.

Process button

adjust the lot by moving the side whilst keeping it perpendicular to another side.

subdivide_area

Subdivide Area
Position of menu: Design =>Estate/Lots =>Edit lots =>Subdivide area

For the option Pivot, please continue to the section “Subdivide Lot by Pivot” .
Parallel edge  “Subdivide Lot by Parallel Edge” 
Parallel bearing  “Subdivide Lot by Parallel Bearing” .
Perpendicular  “Subdivide Lot by Perpendicular” .

subdivide_lot_by_pivot

Subdivide Lot by Pivot
Position of option on menu: Design =>Estate/Lots =>Edit lots =>Subdivide area =>Pivot
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This option reduces the size of a lot by pivoting one side about one of its end points until the lot 
area has a new smaller area. A second lot is created from the remainder of the original lot.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick lot string select

pick the lot to adjust by picking a side of the lot with direction. The start of the selected side will be the 
pivot point.

Lot area output box

area of the selected lot.

New area input box

required area of the adjusted lot. The area must be smaller than the existing lot area.

Process button

Select the side to be swung
and the pivot point
by picking the side with

Pivot point

Side to swing about
the pivot point

direction going away from
the required pivot point

area
800

new lots

area
800

area
500

area
300
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adjust the lot by pivoting the side. A second lot is created from the remainder of the original lot.

subdivide_lot_by_parallel_edge

Subdivide Lot by Parallel Edge
Position of option on menu: Design =>Estate/Lots =>Edit lots =>Subdivide area =>Parallel edge

This option adjusts the size of a lot by moving a side parallel to itself until the lot area has a new 
smaller area. A second lot is created from the remainder of the original lot.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick lot edge string select

pick the lot to adjust by picking the edge of the lot that is to be paralleled.

Lot area output box

area of the selected lot.

New area input box

required area of the adjusted lot. The area must be than the existing lot area.

Process button

Select the side to be
paralleled

area
800

new lotsarea
500

area
300
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adjust the lot by paralleling the selected edge. A second lot is created from the remainder of the original 
lot.

subdivide_lot_by_parallel_bearing

Subdivide Lot by Parallel Bearing
Position of option on menu: Design =>Estate/Lots =>Edit lots =>Subdivide area =>Parallel bearing

This option adjusts the size of a lot by moving a side parallel to a given bearing until the lot area 
has a new smaller area. A second lot is created from the remainder of the original lot.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick lot corner string select

pick the lot to adjust by picking the edge of the lot that is to be paralleled.

Lot area output box

area of the selected lot.

New area input box

required area of the adjusted lot. The area must be smaller than the existing lot area.

Select the side to be
modified

area
800

new lots

Bearing to make
the selected side
parallel to

area
600

area
200
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Bearing bearing box

the bearing used for the selected edge.

Process button

adjust the lot by paralleling the selected edge with the given bearing. A second lot is created from the 
remainder of the original lot.

subdivide_lot_by_perpendicular

Subdivide Lot by Perpendicular
Position of option on menu: Design =>Estate/Lots =>Edit lots =>Subdivide area =>Perpendicular

This option adjusts the size of a lot by creating a new side perpendicular to a selected side and 
then moving the new side until the created lot area has a given smaller area. A second lot is cre-
ated from the remainder of the original lot.

Note -the new area must be less than the original area.

The fields and buttons used in this panel have the following functions.

area
700

Select the side to create the
new side perpendicular to
and the corner to start from

area
600

direction going to the 

start

new lots

by picking the side with

start corner

New side
perpendicular

corner

area
600

to selected side

area 100
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Field Description Type Defaults Pop-Up

Pick lot edge string select

pick the side of the lot that a new side will created perpendicular to

Lot area output box

area of the selected lot.

New area input box

required area of the adjusted lot. The area must be smaller than the existing lot area.

Process button

adjust the lot by moving a side whilst keeping it perpendicular to another side. A second lot is created 
from the remainder of the original lot.
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Filter Lots
polyline_filter_panel

Position of option on menu: Design =>Estate/Lots => Filter lots

This option is used to remove adjacent duplicate points from lots.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type

data source type.

Data source

data source for strings to convert to lots.

Model for filtered lots model box available models

model for the filtered lots.

Colour colour box available colours

if non-blank, the filtered lots are given this colour.
Otherwise a filtered lot has the same colour as the non-filtered lot.

Process button

filter the selected lots.

Number Lots
number_lots

After lots are created, they are then numbered. The lot numbers are stored with the lot 

Position of menu: Design =>Estate/Lots => Number lots

For the option Create lot numbers, please continue to the section “Create Lot Numbers” .
Change lot numbers  “Change Lot Numbers” 



12d Model Reference Manual

Page 1706 March 2007Estate Lots

Create Lot Numbers
lot_numbering_panel

Position of option on menu: Design =>Estate/Lots => Number lots =>Create lot numbers

This option creates lot numbers.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type

data source type.

Data source

data source for lots that have been numbered. A new lot number cannot be the same as an existing one 
in the data source.

Next lot no.

the number to give the next lot that is numbered.

Lot type choice box user defined user defined

type of the lot. The choices are defined by the user in the file. See “Lot types” 

New lot colour colour box available colours

colour to created the numbered lot. This is done so that numbered and non-numbered lots can be easily 
distinguished.

Auto increment tick box tick

if tick, the Next lot no. is incremented after the lot is numbered.

Lot increment integer box 1

amount to increment the Next lot no if the Auto increment flag is tick.

Display lot numbers tick box tick

if tick, the lot number is temporarily displayed. Permanent lot numbers are created using the Label Lots 
options.
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Pick string select

pick the lot the be numbered. After accepting the lot, it is given the Next lot no.

Change Lot Numbers
lot_change_number_panel

Position of option on menu: Design =>Estate/Lots => Number lots =>Change lot numbers

This option changes the lot numbers stored with the lot.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Lot number text box number of selected lot

when a lot is selected, its lot number is displayed in this field. This can be changed and the selected lot 
will get the new Lot number when the Set button is selected.

Lot type choice box type of selected lot

when a lot is selected, its lot type is displayed in this field. This can be changed and the selected lot will 
get the new Lot type when the Set button is selected. See “Lot types” 

Display lot numbers tick box

if tick, the lot numbers are displayed for the selected lots.

View to display view box available views

view to temporarily display the lot numbers.

Pick lot button

select the lot to change either the lot number or the lot type.

Set button

set the lot number and the lot type of the selected lot to the values given in the Lot number and Lot type 
fields.

Label Lots
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label_lots

After lots are numbers, text for the lot numbers and areas can be displayed.

Position of menu: Design =>Estate/Lots => Label lots

For the option Lot labelling, please continue to the section “Create Lot Annotation” .
String b/d labelling  “String Bearing Distance Labelling” 

Create Lot Annotation
lot_labelling_panel

Position of option on menu: Design =>Estate/Lots => Number lots =>Lot labelling

This option creates annotation of the lot numbers, lot areas, bearings of the sides and lengths of 
the sides.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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Input/Output parameters

Lot annotation file *.laf files

file of defaults for labelling the lots.

Read button

read in a given lot annotation file.

Save button

write out the current parameters to the given lot annotation file.

Save as button

write out the current parameters to a different lot annotation file.

Text parameters

Area parameters

parameters for labelling the area of a lot.

Create area text tick box tick

if tick, annotation for the areas is created using the Area parameters.

Lot number parameters

parameters for labelling the lot numbers.

Create lot no. text tick box tick

if tick, annotation for the lot numbers is created using the Lot number parameters.

Bearing parameters

parameters for labelling the bearings of the sides of the lots.

Create bearing text tick box tick

if tick, annotation for the lot bearings is created using the Bearing parameters.

Distance parameters

parameters for labelling the lengths of the sides of the lots.

Create distance text tick box tick

if tick, annotation for the lengths of the sides is created using the Distance parameters.

Short segment parameters

parameters for specifying what is a "short Segment" and the parameters for labelling sides of the lots 
that are short segments.

Create short segment text tick box tick

if tick, annotation for short segments is created using the Short segment parameters.

Data

Data source type

data source type.

Data source

data source for lots to be annotated.
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Lot type choice box user defined user defined

of the lots selected by the data source, only lots of this type are labelled. See “Lot types” .

Process button

select all the lots given by the Data source and Lot type and create annotations according the Text 
parameters.

String Bearing Distance Labelling
Position of option on menu: Design =>Estate/Lots => Label lots =>String b/d labelling

Option to label the bearing and lengths of segments of strings.

This option is described in the section “Bearing/Distance Labelling” in the chapter “Drafting” 

Delete Lot Attributes and Text
lot_delete_number_panel

Position of option on menu: Design =>Estate/Lots => Delete lot attributes/text

This option is used to remove the attributes for a lot which store the lot number, area etc. It can 
also delete the annotation text that has been created for the lot.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Delete choice box  lot text lot text, lot attributes

when a lot is selected, its lot type is displayed in this field. This can be changed and the selected lot will 
get the new Lot type when the Set button is selected.

Data source type

data source type.

Data source

data source for lot to delete either the lot text or lot attributes.

Display lot numbers tick box

if tick, the lot numbers are displayed for the selected lots.

View to display view box available views

view to temporarily display the lot numbers.
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Process button

delete the selected attributes from the selected lots.

Setout Lots
setout_lots

Options to create unique point numbers for the vertices at the ends of each segment of the lots, 
and to create z-values from a given tin for the vertices of the lots.

Position of menu: Design =>Estate/Lots => Setout lots

For the option Create lot point numbers, please continue to the section “Create Lot Point 
Numbers” 

Drape points  “Drape Points” 

Create Lot Point Numbers
lot_setout_panel

Position of option on menu: Design =>Estate/Lots => Setout lots =>Create lot points numbers

This option creates unique point numbers for the vertices at the ends of each segment of the lots. 
Duplicate vertices are only given one point number.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Lot type choice box user defined user defined

of the lots selected by the data source, only lots of this type have point numbers created. See “Lot types” 
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Data source type

data source type.

Data source

data source for lots to have point numbers created.

Model for setout points model box available models

model for the set out points.

Text colour colour box available colours

colour of the point numbers.

Text units choice box world screen, paper, world

units for text size.

Text size double box

Size of the text for the point numbers.

Add points to lot views tick box tick

if tick, add the model of point numbers to the views that the lots are displayed on.

Create short segment text tick box tick

if tick, annotation for short segments is created using the Short segment parameters.

Filter redundant points tick box tick

if tick, then if two adjacent line have the same bearing then the two segments are replaced by one 
segment. And if two adjacent arc segments could be the one arc, then they are replaced by one arc.

Process button

select all the lots given by the Data source and Lot type and create annotations according the Text 
parameters.

Drape Points
Position of option on menu: Design =>Estate/Lots => Setout lots =>Drape points

Position of option on menu: Tins =>Drape =>String heights from tin

Option for setting the z-value of points to the z-value from a specified tin.

This option is described in the section “Update Z-values from Tin” in the chapter “Triangles” 

Report Lots
lot_report_panel

Position of option on menu: Design =>Estate/Lots => Report lots



Chapter 17  Design

March 2007 Page 1713Estate Lots

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type

data source type.

Data source

data source for lots to be reported.

Include point numbers tick box

if tick, include the point number for each vertex around the lot.

Model of point numbers model box available models

model of the point numbers for the vertices of the lots.

Report type choice box sort by type, sort by number
sort by area, setout

type of report for the selected lots.

Boundary string select optional

if selected, the boundary string for the lots.If selected then the area of the boundary string is calculated 
and the total area of the lots compared to the area of the boundary string.

No. decimals integer box

Number of decimal places for co-ordinates and lengths in the report.

No. dec for bearings integer box

Number of decimal places for bearings in the report.

Report file file box

Name of the file for the report.
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Process button

Create the report.

Lot Utilities
lot_utilities

Various lot options.

Position of menu: Design =>Estate/Lots => Lot utilities

For the option Colour lots by range file, please continue to the section “Colour Lots by Range 
File” 

Remove lot colour  “Remove Lot Colour” 
Reverse bearing  “Reverse Bearing” 
Short line/arc table  “Short Line/Arc Table” 
Short line/arc report  “Short Line/Arc Report” 

Table utilities  “Short Segment Utilities” 

Colour Lots by Range File
colour_lot_by_range_file_panel

Position of option on menu: Design =>Estate/Lots => Lot utilities =>Colour lots by range file

The option colours lots by area using a lot range file (.lrf) to define the colour for each minimum 
and maximum area. It also creates a table of the statistics for the area ranges.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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Range file file box *.lrf

range file for colouring lots.

Data source type

data source type.

Data source

data source for lots to be coloured.

Table location position select box

position of the table.

Model for table model box available models

model for the table of statistics on the lot areas.

Text colour colour box available colours

colour of the text.

Text size (w) double box

size of the text for the table.

Process button

select all the lots given by the Data source and Lot type and colour them according to the lot range file.

Remove Lot Colour
remove_lot_colour_panel

Position of option on menu: Design =>Estate/Lots => Lot utilities =>Remove lot colour

The option removes the colour of all the selected lots.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type

data source type.

Data source

data source for lots to have their colour removed.

Process button

select all the lots given by the Data source and remove the lot colour.
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Reverse Bearing
reverse_bearing

Position of option on menu: Design =>Estate/Lots => Lot utilities =>Reverse bearing

Option to change the value of the bearing text created by the lot labelling option by adding 180 
degrees to the bearing.This is then the bearing of a line in the reversed direction to that repre-
sented by the original bearing text. The rounding for the reversed bearing is done according to 
the lot parameters.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Zero padding tick box tick

if tick, if the minutes and/or seconds are zero then two zeros are written out.
If not tick, if the minutes and/or seconds are zero then they are left out.

Pick button

pick the bearing text that is to be modified.

Short Line/Arc Table
Position of option on menu: Design =>Estate/Lots => Lot utilities =>Short line/arc table

Position of option on menu: Drafting =>Text and Tables =>Short segment table

Option to create a table of all the short segments and/or short arcs.

This option is described in the section “Short Segments Table” of the chapter “Drafting” 

Short Line/Arc Report
Position of option on menu: Design =>Estate/Lots => Lot utilities =>Short line/arc report

Position of option on menu: Drafting =>Text and Tables =>Short segment report

Option to create a report of all the short segments and/or short arcs.

This option is described in the section “Short Segment Report” of the chapter “Drafting” 

Short Segment Utilities
Position of option on menu: Design =>Estate/Lots => Lot utilities =>Table utilities

Position of option on menu: Drafting =>Text and Tables =>Short segment table utilities

This panel is used modify an existing short segments table.

This option is described in the section “Short Segments Table Utilities” of the chapter “Drafting” 
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Pads
pads

Position of menu: Design =>Pads

The Pads walk-right menu is

For the option Balance a pad, go to the section “Balance a Pad” 
Dynamic pad “Dynamic Pad Interface” 
Create/grade pad “Allotment Pad Create” 
Edit/grade pad “Allotment Pad Edit” 
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Balance a Pad
balance_panel

Position of option on menu: Design =>Pads =>Balance a pad

This option takes a pad formed by a string and user given slopes and batters from the pad to a 
given tin. The pad is moved up or down until a balance is found.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Select polygon string select
select the string to batter from

Tin to interface tin box
tin to batter to.

Fill slope 1v in
fill slope for interfacing.

Cut slope 1v in
cut slope for interfacing.

Section separation
interval to calculate cut and fill batters.

Search distance
distance for the batter to search to find intersection with the triangles.

Which side choice box left left, right
batter to the left or right of the selected string.

Model model box available models
model to add the batter strings to.

Process button
run the option

Undo
undo the last set of batter strings created whilst the panel has been up.
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Dynamic Pad Interface
dynamic_pad_panel

Position of option on menu: Design =>Pads =>Dynamic pad

This option is to create a pad by interfacing from a selected string and calculated the volume for 
the pad. The pad can be moved up or down and the new volumes are calculated.

The pad can also be moved in plan and the new interface and volumes are dynamically 
calculated.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

View name view box
name of the view to display the pad interface strings.

Cut slope 1v in 1
cut slope for interfacing.

Fill slope 1v in 2
fill slope for interfacing.

Section separation 10
interval to calculate cut and fill batters.

Search distance 100
distance for the batter to search to find intersection with the triangles.

Left or right choice box left left, right
batter to the left or right of the selected string.

Tin to interface tin box
tin to batter to.

Height increment 0
when process is selected, the pad height is adjusted by the value in this panel field and the new interface 
and volumes are calculated.
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Select string select
select string to batter from

Process button
adjust the height of the pad by the Height increment and recalculate the new interface and volumes.

Translate
when selected the pad will move to the cursor position and dynamically calculate the interface and 
volumes.

Reset button
reset the pad height to its original value.
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Allotment Pad Create
super_allot_create_panel

Position of option on menu: Design =>Pads =>Create/grade pad

This option and the next Design =>Pads =>Edit/grade pad are used to create a pad from 
surrounding lines, grade the created pad and edit pads already created with this option.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

General tab

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is used to create a pad.

Name input

the name of the new pad.

Model model box available models

name of the model that the new pad is in.

Colour colour box default colour available colours

the colour of the new pad.

Pad texture choice box None None, some textures

the colour of the new pad.

Use solid fill tick box

if tick, solid fill the pad
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Display button

brings up the Display Text Defaults panel 

Offsets tab

Global offset input

if other offsets are not given, the distance to offset the sides of the pad from the strings used to create 
the pad

Offsets model model box

model for the offset lines

Offsets type choice box Segment Segment, Point to Point

if Segment, define the offset line by picking a segment.
If Point to Point, define the offset line by picking two points.

Select button

select an offset line

Creation tab

Pad level type choice box Typed input, Use tin level
Use bdy/ht, Use bdy/slope

if typed input, all vertices of the pad are given the height in the Lot level field.
If use tin level, the height of each vertex of the pad is taken from the tin given in the Tin field.

If typed input:

Pad level input

the height to use for all the vertices of the pad.

If Use tin level:

Tin tin box available tins

the tin used to give heights to the vertices of the pad.

If Bdy/ht:

Height

the height to be above the selected boundary string

Reference boundary

the selected boundary string for the pad to be a given height above/below

If Use/slope:

Slope 1 in

the slope to be above the selected boundary string

Reference boundary

the selected boundary string for the pad to be a given slope above/below

Single/ Along a string radio buttons single

if single, a single pad is created from the strings surrounded the selected point.
If along a string, pads are created surrounding each vertex of selected string.

Centroid/search distance string select
if single, a point is selected and then a circle is rubber banded until a second point is selected. The pad 
is created from segments within the circle.

Search dist input
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if along a string, then for each vertex, all segments within the distance are processed to create the pad.

Select string select
if along a string, select the string to use. Pads are created surrounding each vertex of this string.

Process button
run the option



12d Model Reference Manual

Page 1724 March 2007Pads

Allotment Pad Edit
super_allot_edit_panel

Position of option on menu: Design =>Pads =>Edit/grade pad

This option is used to grade a pad created with the previous option, Design =>Pads =>Create/
grade pad.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Display tab

Level dec places input

the number of decimal places used to display the height (level) of the pad vertices.

Grade dec places input

the number of decimal places used to display the grade of the pad sides.

Grade arrow size input

size of the grade arrows

Level textstyle data textstyle data box

the textstyle data used for the displaying the level (height).

Grade textstyle data textstyle data box

the textstyle data used for the displaying the grade.

Pad texture choice box None None, some textures

the colour of the new pad.

Show solid fill tick box

if tick, solid fill the pad
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Show levels and grades tick box

if tick, turn on the level and grades

Pick button
select the pad to edit

Offset tab

Maintain level/Maintain level on Grade radio buttons

if Maintain level, keep the level when a new offset/boundary is selected
If Maintain level on grade, keep the level on grade when a new offset/boundary is selected

Select new offset string select
select a new offset string

Select new boundary string select
select a new boundary string

Grading tab

Level and/or grade button

Level entire pad button

Level by str/ht button

Level by str/slope button

Level by seg/ht button

Level by seg/slope button

Batter slope button

Surface grading button

Ht
heights to increment the selected pad by

Up button
move the pad up by the give height

Down button
move the pad down by the give height

Pick (ht) string select
select a pad

Batter slope model model box available models
model for the batter slopes

Global tab

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is used to create a pad.
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Roads
roads
Position of menu: Design =>Roads

The road options include road network creation options and a number of other options for 
creating road details.
Some of the options are currently under development.

The roads walk-right menu is

Each option in this menu will now be described.

For the option Create, please continue to the section “Create Roads” 
Sight distance “Sight Distance” 
Trarr output “Trarr Output” 
Trarr input “Trarr input” 
Vehicle path “Vehicle Path” 
Mass haul “Mass Haul String and Report” 
Traffic island “Create Combined Traffic Island” 
More “More Roads” 

Create Roads
create_roads
Position of menu: Design =>Roads =>Create

The Create roads function allow the user to start with a model of road centrelines with vertical 
geometry, and unique string name.
The centrelines can then be tagged with the width of the roads, left and right turn radii for any 
intersections and the definitions of any culdesacs at the end of a centreline.

The Create option will then create the left and right edges of the roads, create kerb returns and 
any intersections and the appropriate culdesacs.
For example

setup and create road network
sight distance calcs
output to TRARR
input from TRARR
output to VPATH
create mass haul string 
check traffic island
more roads macros
 user macros
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Initial Network of Centrelines

Road Network After Running the Roads Option
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The Roads walk-right menu is

Each option in this menu will now be described.

For the option Create Roads - Manager, go to the section “Create Roads - Manager” .
Create Roads - Setup “Create Roads - Setup” .

Create Roads - Setup
create_roads_setup
In the Create Roads - Manager panel there are default values for the road width and road crossfall 
and turn radius.

If a different road width or crossfall, or a different left turn radius or right hand radius is 
required, the Create Roads - Setup option is used to define the different information for any 
centreline. Create Roads - Setup is also used to define culdesacs.

Blow Up of an Intersection

construct the roads network
setups for road network
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Road Setup tab

Centreline string select

used to set the left and right turn radii, and the width of the road. This option is used twice to set the 
different radii for each end of a road by picking the centreline close to the end that is to have the left and 
right turn radii defined. The left and right turn radii can be different for each end of an alignment.

Road width

width of one side of the road for the selected centreline.

LHS turn radius

radius to use for filleting between any centrelines on the left.

RHS turn radius

radius to use for filleting between any centrelines on the right.

Set button

store the given values in the panel with the selected centreline.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Culdesac Setup tab

Left fillet input

radius of the fillet between the road and the bulb on the left hand side

Bulb radius input

radius of the culdesac bulb

Bulb offset input

offset of the culdesac bulb

Right fillet input

radius of the fillet between the bulb and the right had side of the road

Left straight input

distance between the left fillet and the bulb
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Right straight input

distance between the right fillet and the bulb

Set button

store the panel values the selected centreline.

Create Roads - Manager
create_roads_manager
This option takes all the centrelines in a model and uses road widths and left and right turn radii 
to form roads on each centreline.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function function box available roads functions

name of the create roads function

Input tab

Model of centrelines model box available models

model of the centreline lines that are to processed to create roads, intersections and culdesac. Each 
centreline must have a unique name and vertical geometry
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Templates

Full width template box available templates

template with one fixed link and then cut and fill definitions to use for creating the roads. If a centreline 
has a road width defined, then the template is modified to use those values. The cut/fill section of the 
template are used to batter as normal.

Carriageway template box available templates

a template with only a fixed part to the end of the carriageway which is applied across any 
intersections - going from the chainage of the start of the kerb return on one side of the intersection to 
the chainage at the end of kerb return on the other side of the intersection.

Kerb only template box available templates

a template with no carriageway part. It is applied to any kerb returns

Lip line name

name of the lip line that must exist in each of the full width template and the road template. The kerb 
returns are created from the lip line on each road and the start height and grades are taken from the lip 
lines.

Road Defaults

Width

width of the road to be used if one hasn’t been defined for any centrelines

Turn radius

radius to use for filleting between any centrelines that don’t have a left or right radius defined

Design separation

chainage distance to use in the Applies for creating the roads along the centrelines

Default chord/arc

chord to arc tolerance to use on curves

   Natural surface tin tin box available tins

if non blank, the tin to use as the natural surface for battering in the Applies.
If blank, no battering is done.

Output tab

Model stems

Road strings input

pre*post text to use with the function name in the created Applies for the design string models for each 
centreline

Road sections input

pre*post text to use with the function name and the created Applies for the design cross section models 
for each centreline

Polygons choice box One model One model, No Polygons
Model for Centreline

if One model, all the polygons created by the applies are place in one model.
If Model for Centreline, different models are created for the polygons in each apply.
If No Polygons, no polygons are created by the applies.

Model model box available models

when One model, model for all the polygons created by the Applies.

Road polygons input

pre*post text to use with the function name in the created Applies for polygon models for each 
centreline
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Kerb Returns

Turn separation

chord/arc tolerance for use in the kerb return Applies

Turn chord/arc

chord to arc tolerance to use on kerb return

Model for kerb returns model box available models

model for all the kerb returns

Naming choice box  Follow Road Names - LHS driving
 Follow Road Names - RHS driving

Use Numbers
Use Letters

method of naming the kerb returns

Just create kerb returns tick box

if tick, only create the kerb returns. Usually only run at the beginning to see if the kerbs look correct.

Just create kerb returns tick box

if tick, only create the kerb returns. Usually only run at the beginning to see if the kerbs look correct.

Kerb return strings and sections in one model tick box

if tick, then all the kerb return strings and sections are place in the one model. The model names are 
given in the next two fields.

Model for kerb return strings model box available models

model for all the kerb return strings

Model for kerb return sections model box available models

model for all the kerb return sections

Delete frozen apply many functions tick box

if tick, the apply many functions are deleted for all the frozen roads. Normally not used

View for models view box available views

if non blank, view to add all the created models onto.

Error report file box *.rpt files

file for error messages

Boxing tab
boxing can be created for all the road and kerb return strings. The boxing definitions must have a 
common centreline name in them which will be replaced by the name of each of the road/kerb return 
centrelines.

Create boxing tick box

if tick, boxing is applied for all the road and kerb returns. The boxing definitions must have a common 
centreline name in them which will be replaced by the name of each of the road centrelines or kerb 
returns.

Default boxing file file box *.blf files

file of boxing file definitions

Default boxing CL delimiter input

common name in each boxing definition which will be replaced by the name of each road/kerb return 
centreline

Model stem for boxing strings input

pre*post text to use with the road/kerb return function name for boxing string models
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Boxing sections input

pre*post text to use with the road/kerb return function name for boxing section models

Boxing kerb return sections and strings in one model tick box

if tick, the strings for all the kerb return Applies are place in one model rather than one model for each 
kerb return. Similarly, the sections for all the kerb return Applies are placed in the one model.
If not tick, the model names are created in the same way as for the road centrelines. That is, the Model 
stem for boxing strings and sections are used with the kerb return function name and the layer stems to 
produce the kerb return boxing strings and sections models. 

Model name for boxing kerb strings input

when only one model (per layer) for the box kerb strings is used - the base name for the model of kerb 
strings created for each boxing layer. The pre*post text in the Layer Stem is applied to this name.

Model name for boxing kerb sections input

when only one model (per layer) for the box kerb sections is used - the base name for the model of kerb 
sections created for each boxing layer. The pre*post text in the Layer Stem is applied to this name.

Boxing Layer 1-8 in the grid:
if non blank, boxing strings and sections will be created for that layer.
The last boxing layer is also referred to as the subgrade layer.

Layer stem input

for this boxing layer, the pre*post text used when naming models for boxing sections and strings.

Road - LHS input

for this boxing layer, the boxing definition to use on the left hand side of road centrelines

Road - RHS input

for this boxing layer, the boxing definition to use on the right hand side of road centrelines

Kerb return input

for this boxing layer, the boxing definition to use on the kerb returns

Intersection - LHS input

for this boxing layer, the boxing definition to use on the left hand side of the road though an 
intersection. The strings and sections are place in the models for the road centreline going through the 
intersection.

Intersection - RHS input

for this boxing layer, the boxing definition to use on the right hand side of the road though an 
intersection. The strings and sections are place in the models for the road centreline going through the 
intersection.

Tins tab

Create tin tick box

if tick, create a tin for all the roads, kerb returns and culdesacs

Road tin tin box available tins

name for the tin created from the all the strings and sections

Road tin colour colour box available colours

colour of the road tin
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Subgrade tin tin box available tins

if non blank, a subgrade tin of this name is created 

Subgrade tin colour colour box available colours

colour of the subgrade tin

Nulling angle input

angle for nulling the triangles

Nulling length input

length for nulling the triangles

Null Seed points:

Seed X/Y input

X/Y coordinate of a nulling seed point

Seed Point button

select a seed point for nulling the tins. The X and Y coordinates are written to the Seed X/Y grid

Visualisation tab

Create visualisation tick box

if tick, the road tin is processed for visualisation

Apply texture map to tin tick box

if tick, the texture map is applied to the road tin

Draw road tin as solid on view tick box

if tick, 

Tin colour to use for cut polygons colour box available colours

colour to use for all the cut polygons

Tin colour to use for fill polygons colour box available colours

colour to use for all the fill polygons

Tin colour to use for transition polygons colour box available colours

colour to use for all the polygons in neither cut nor fill

Freezing tab

Colour for the frozen sections colour box available colours

colour to use for the sections of frozen strings. In any view, this gives a quick way of identifying frozen 
roads.

Road grid - list of all the centrelines

Element available colours

centreline name

Frozen tick box

if tick, the centreline is frozen out of the automatic Create Roads process. 

For a frozen centreline, when the Create Roads function is run, the Apply Many for that centreline is 
deleted and re-created. However any existing Apply Many for that centreline will be run. Kerb returns 
are still calculated using the lip line create by running the existing Apply Many for the frozen 
centreline. Hence the mtf for a frozen centreline can be modified and the changes will not be deleted 
when the Create Roads function is recalced.
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Note - if the two roads used to define a kerb return are both frozen, then the kerb return is automatically 
frozen and the kerb return is not deleted and recreated when the Create Roads function is recalced. 
However the existing Apply Many for the frozen kerb return is run on each recalc.

Buttons at bottom

Create button

run the option and create the road network.

Sight Distance
sight_distance

Position of option on menu: Design =>Roads =>Sight distance

The sight distance option calculates the maximum distance that can be seen from an eye point, 
along a string, against a tin (including a supertin).

In the option, a string and a tin are selected and then an eye point is positioned at the given 
eye height, at the given start chainage on the selected string.

From the eye point, a target point is placed at a chainage distance equal to the given minimum 
sight distance along the string, at the given target height above the string.

The target point is then tested for visibility from the eye point, against the given tin. That is, a test 
is made to see if the target point can be seen from the eye point, against the surface given by the 
tin.

If the target point is visible, it is moved the given chainage distance, trial interval, further along the 
string and the visibility test redone.

The process is repeated until either the target point is invisible, or the target point is the given 
maximum sight distance (in chainage) away from the eye point.

 A line joining the eye and final target point position is created and placed in the model for sight 
lines. The chainage distance between the eye and the final target point is placed as a text string in 
the model for sight text, positioned at the eye point.

The eye point is then moved the given chainage distance interval along the string, and the process 
repeated until the eye point is past the given end chainage.

The eye point is then place at the end chainage and the negative of the trial interval and interval 
values used to calculate sight distance for the reverse direction along the string.

On selecting the sight distance option, the sight distance panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin to use as the surface for testing visibility.

Report file file box *.rpt files

if non blank, a report is produced and written out to this file name.

Centreline tab

Centreline string-select

A string to be used for placing the eye and target points, is selected from a view.

Interval input 100

chainage increment to move to eye point for the next sight distance calculation.

Start/end chainage input

the sight distance is calculated for points on the selected string covering the chainage range given by 
the start and end chainage fields. If the start/end chainage is blank, the star/end chainage of the selected 
string is used.

Trial interval input 10

chainage increment to move to test target point.

Minimum sight distance input 100

minimum chainage distance to use for placing the test target point.

Maximum sight distance input 3000

maximum chainage distance to use for placing the test target point.
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Eye tab

Height input 1.3

height of the eye point above the picked string

Offset input 1.3

offset of the eye point from the picked string.

Target tab

Height input 0.3

height of the test target point above the picked string

Offset input 1.3

offset of the target point from the picked string.

Bridge Tins tab

Tin grid available tins

name of the tins to use as vertical obstructions when testing visibility.

Forward Direction tab

Sight lines model box available models

if non-blank, the name of the model to contain the sight lines.
If blank, the sight lines are not created.

Good colour colour box default colour available colours

when the minimum sight distance is achieved, sight lines are created in the good colour

Bad colour colour box default colour available colours

when the minimum sight distance is not achieved, sight lines are created in the Bad colour

Sight text model box available models

if non-blank, the name of the model to contain the sight distance text.
If blank, the sight distance text is not created.

Sight text info text info

definition of the sight text.

Backward Direction tab

Sight lines model box available models

if non-blank, the name of the model to contain the sight lines when going down the string in the reverse 
direction Note that the eye and target offsets are then applied in the reverse direction of the string.
If blank, the sight lines are not created.

Good colour colour box default colour available colours

when the minimum sight distance is achieved, sight lines are created in the good colour

Bad colour colour box default colour available colours

when the minimum sight distance is not achieved, sight lines are created in the Bad colour

Sight text model box available models

if non-blank, the name of the model to contain the sight distance text.
If blank, the sight distance text is not created.

Sight text info text info
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definition of the sight text.

Sight button

sight lines and text will be calculated for the given string and tin, and placed in the sight line and text 
models.
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Trarr Output
trarr_output_generation

Position of option on menu: Design =>Roads =>Trarr output

Options to create a file for use with TRARR.

Please contact 12d Solutions if you wish to use this options.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Road tin tin box available tins

tin of the road design

Terrain tin tin box available tins

tin of the terrain

Interval input

interval to calculate sight lines

Start chainage

if non blank, start chainage for producing the Trarr file.
If blank, start at the beginning of the centreline string.

End chainage

if non blank, end chainage for producing the Trarr file.
If blank, go to the end of the centreline string.
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Maximum sight distance input

maximum distance to try and calculate sight lines

Trial interval input

interval to move ahead to test sight distance to

Barrier distance input

if sight distance is less than this value then a barrier line is required

85%le speed input

85 percentile speed (to write to the Trarr file)

Eye height input 1.3

height of the eye point above the picked string

Target height input 0.3

height of the target point above the picked string

Model for sight lines model box available models

if non blank, the sight lines are kept and placed in this model

Colour colour box available colours

colour of the sight lines

Trarr file file box *.rpt files

if non blank, a Trarr file of this name is produced

Centreline string-select

string to be used for placing the eye and target points and calculating sight distance, is selected from a 
view.

Polygon string-select

boundary polygon for the road tin

Sight button

calculate sight lines and write out a Trarr file
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Trarr input
read_trarr_data

Position of option on menu: Design =>Roads =>Trarr input

Options to read in a TRARR file.

Note - this option is under development.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Trarr file file box *.traffic files

the Trarr file to read in

Centreline string-select

string that the Trarr file is for

Model for data model box available models

model to read the Trarr data into

Colour colour box available colours

colour for the Trarr data strings

Start time (sec) input

start time in seconds for replaying the data in the Trarr file

Final time (sec) input

end time in seconds for replaying the data in the Trarr file

Sight button

calculate sight lines and write out a Trarr file
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Vehicle Path
vehicle_path

Position of menu: Design =>Roads =>Vehicle Path

The vehicle path option is used to interface with the vehicle path program, vpath, written by 
Queensland Department of Main Roads.

The Vpath program is a separate chargeable program and is fully described in its own Manual.

To run vpath from within 12d Model, either the environment variable VEHICLE_PATH_4D must 
be set to point to the folder where the DOS vpath executable is located or 
WINDOWS_VEHICLE_PATH_4D is set to point to the folder where the Windows vpath 
executable is located. 

VEHICLE_PATH_4D folder-path

or

WINDOWS_VEHICLE_PATH_4D folder-path

Vpath is the Vehicle Turning Path program written by Main Roads Queensland and is a separate 
chargeable program.

The vehicle path menu currently contains just one option, steering path.

steering_path      steering_path__windows_version_

On selecting the steering path option, the steering path panel is displayed

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Vehicle type input Design Semi available vehicles in the
 vehicles.std file

the vehicle type used for generating the swept path.
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Friction coefficient input 0.3

the coefficient of friction to be used for the vehicle.

Vehicle on side input Left Left, Right

the side of the vehicle that the selecting steering path represents.

Draw interval (=none) input 20

if non-zero, the position of the vehicle on the steering path is draw the position at this interval.

Steering path model input available models

if non-blank, the steering path including the marking of the tangent points and centres of each circular 
curve are created and placed in this model.

Vehicle position model input available models

if non-blank, the strings tracing out the vehicle position are placed in this model.

Swept path model input available models

if non-blank, the strings tracing out the swept path of the vehicle are placed in this model.

Pick button

pick

Run Vehicle Path button

run the vpath program and load the results back into the models given in the panel fields.
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Mass Haul String and Report
mass_haul_reportl

Position of option on menu: Design =>Roads =>Mass haul

This panel is used to read in a volumes report and optionally a cut/fill compaction parameter 
file and creates a mass haul string and a new volumes report with the compaction volumes.

The compaction parameter file simply contains the compaction factor for given chainage ranges. 
Either the cut volumes are multiplied by the compaction factor or the fill volumes are divided by 
the compaction factor, to give the compacted volumes in the new volumes report.

If the existing volume report contains an alignment string and that string can be found in the 
project then a new alignment string is created with the same horizontal geometry but with the 
accumulated volumes as the z-values.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Existing volume report file file box *.rpt files

name of the existing volumes report.

Compaction parameter file input *.mhf files

file containing compaction factors to be used. See “Format of the Compaction Parameter File” .

Cut/fill compaction factor input 1

cut/fill compaction factor for any chainages not in the compaction parameter file or if there is no file.

Apply compaction factor to choice box cut cut, fill

if cut, the cut volumes are multiplied by the compaction factors.
If fill, the fill volumes are divided by the compaction factors.

Model for mass haul string model box available models

model for the created mass haul string.
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Colour for mass haul string colour box available colours

colour of the created mass haul string.

Report file input box

if non-blank, a mass haul volumes file is created.

Process button

run the option.

Format of the Compaction Parameter File
Format of the
// Sample cut/fill compaction parameter file – the file ending 
is .mhf
// All lines starting with // are comments and blank lines are 
ignored
//
// A range is specified by a start and end chainage and a compaction 
factor.
// A compaction factor of 1.0 means there is no compaction.
// A compaction factor of 0.9 means that 1.0 cubic metres of cut is 
equivalent
// to 0.9 cubic metres of fill due to compaction.

// format is    
// Start_ch End_ch Compaction_factor

0 100 0.9
100 500 1.0
500 2000 1.1
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Create Combined Traffic Island
island_combined_panel

Position of option on menu: Design =>Roads =>Traffic Island

Create an alignment string for a traffic island between user selected strings and with user 
defined offsets from the strings and nose radii. Drape the island onto a tin to give is z-values and 
then apply a kerb profile to complete the island.

On selecting the traffic island option, the traffic island alignment creation panel is displayed.

The position of the panel fields indicate what the values are for. Tool tips appear when the cursor 
is passed over the panel.fields.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

offset from travel line 2
offset from travel line 3
radius at nose

offset from travel line 1
offset from travel line 3
radius at nose

offset from travel line 1
offset from travel line 2
radius at nose
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Buttons at bottom

Select strings select

select in order and with direction, the three strings to use in creating the traffic island. Terminate by 
clicking RB and selecting cancel from the pick ops menu.

Preview string select

draw the traffic island with the given parameters in the panel draw box.

Process button

create the alignment string

Island Create tab

Offset from travel lines input box

offset distance from the selected travel lines.

Radius at nose input box

radius of the corner of the traffic island between the selected travel lines

Name name box available names

name of the created alignment string.

Model model box available models

model for the created alignment string.

Colour colour box available colours

colour of the created alignment string.

Create as super alignment tick box

if tick, create the string as a super alignment.
If not tick, create the string as an alignment.

Quick Island tab
the quick island tab produces a traffic island of fixed sides but with the given nose radii. The traffic 
island can be created as a super alignment that can then be easily moved around and modified.

Radius at nose input box

radius of the corner of the traffic island

Name name box available names

name of the created alignment string

Model model box available models

model for the created alignment string

Colour colour box available colours

colour of the created alignment string

Create as super alignment tick box

if tick, create the string as a super alignment.
If not tick, create the string as an alignment.

Position xyz select box

 pick two points to indicate the direction that the island will be created.

Then click on Process to create the Traffic Island.

Kerb Profile tab

Use island alignment levels instead of Tin tick box
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if tick, use the alignments own z-value instead of draping the alignment onto the tin.
If not tick, drape the alignment onto the tin to get z-values.

Offset kerb face/top/back input box

offset for kerb face/top/back for the selected kerb type.

Height kerb face/top/back input box

height for kerb face/top/back.

Tin tin box available tins

triangulation to drape the traffic island strings onto.

Kerb type input box

type of kerb to apply to the reference string of the traffic island. If type User is selected from the pop-up 
list, a file which defines the kerb profile can be selected and used.

File file box *.ukt files

file to read/write the user defined kerb type to.

Read button

read the given File to define a kerb type.

Save button

save the kerb parameters to the given File.



12d Model Reference Manual

Page 1750 March 2007Roads

More Roads
more_roads
Position of menu: Design =>Roads =>More

The more roads menu contains macros to create road details such as traffic islands, line marking, 
mass haul strings.
The more roads walk-right menu is

For New island create, go to the section “Create Combined Traffic Island” 
For Traffic island alignment creation, go to “Alignments” in the chapter “Strings” 

Island profile/tin “Traffic Island Profile and Triangulation Creation” 
Drape alignment string “Drape Alignment (Macro)”  in the chapter “Triangles” 
Line marking “Line Marking”  in the chapter “Drafting” 
Mass haul “Mass Haul String and Report” 
Road polygons “Polygons from Sections” 
Road widening “Road Widening with Minimum and Maximum Crossfall” 
Roundabout “Create Roundabout” 
Kerbs special chainage file “Kerb Special Chainages File” 
Special chainage file “Special Chainages File” 
Table drain “Table Drain - Intersection of Slopes from Two Strings” 

Traffic Island Alignment Creation
Position of option on menu: Design =>Roads =>More =>Traffic island alignment creation

This option creates an alignment string for a traffic island and has already been documented as

Strings => Create => Alignment => Traffic island

For the option Traffic island, please continue to the section “Create - Traffic Island” in the chapter 
“Design” .

Traffic Island Profile and Triangulation Creation
island_panel

Position of option on menu: Design =>Roads =>More =>Island profile/tin

This option creates strings by offsetting from a selected string using a kerb profile. The resultant 
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strings are draped onto a given tin and then triangulated to form a traffic island.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Offset kerb face/top/back input box

offset for kerb face/top/back for the selected kerb type.

Height kerb face/top/back input box

height for kerb face/top/back.

Tin tin box available tins

triangulation to drape the traffic island strings onto.

Kerb type input box

type of kerb to apply to the reference string of the traffic island. If type User is selected from the pop-up 

offset and heights fo
the selected kerb

redraw the kerb
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list, a file which defines the kerb profile can be selected and used.

File file box *.ukt files

file to read/write the user defined kerb type to.

Read button

read the given File to define a kerb type.

Save button

save the kerb parameters to the given File.

Select button

select the string representing the traffic island.

Process button

create the traffic island strings and tin.

Undo button

undo the last traffic island created whilst the option was running.

Drape Alignment
Position of option on menu: Design =>Roads =>More =>Drape alignment string

This option has already been documented in Tins => Drape=> Drape align.

For the option Drape align, please continue to the section “Drape Alignment (Macro)” in the 
chapter “Triangles” .

Line Marking
Position of option on menu: Design =>Roads =>More =>Line marking

This option creates an alignment string for a traffic island and has already been documented as

Drafting => Line marking

For more information on the option Line marking, please continue to the section “Line Marking”  
in the chapter “Drafting” .



Chapter 17  Design

March 2007 Page 1753Roads

Create Mass Haul String and Report
masshaul_panel

Position of option on menu: Design =>Roads =>More =>Mass haul

This options has been replaced by “Mass Haul String and Report” .

This panel is used to read in a volumes report and optionally a cut/fill compaction parameter 
file and creates a mass haul string and a new volumes report with the compaction volumes.

The compaction parameter file simply contains the compaction factor for given chainage ranges. 
Either the cut volumes are multiplied by the compaction factor or the fill volumes are divided by 
the compaction factor, to give the compacted volumes in the new volumes report.

If the existing volume report contains an alignment string and that string can be found in the 
project then a new alignment string is created with the same horizontal geometry but with the 
accumulated volumes as the z-values.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Existing volume report file file box *.rpt files

name of the existing volumes report.

Cut/fill compaction factor input 1.0

cut/fill compaction factor for any chainages not in the compaction parameter file or if there is no file.

Compaction parameter file input *.mhf files

file containing compaction factors to be used.

Apply compaction factor to  cut fillcut

if cut, the cut volumes are multiplied by the compaction factors.
If fill, the fill volumes are divided by the compaction factors.

Model for mass haul stringinput

model for the created mass haul string.
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Colour for mass haul stringinput

colour of the created mass haul string.

Mass haul report file input box

if non-blank, a mass haul volumes file is created.

Process button

run the option.

// Sample cut/fill compaction parameter file – the file ending 
is .mhf
// All lines starting with // are comments and blank lines are 
ignored
//
// A range is specified by a start and end chainage and a compaction 
factor.
// A compaction factor of 1.0 means there is no compaction.
// A compaction factor of 0.9 means that 1.0 cubic metres of cut is 
equivalent
// to 0.9 cubic metres of fill due to compaction.

// format is    
// Start_ch End_ch Compaction_factor

0 100 0.9
100 500 1.0
500 2000 1.1

Road Polygons
Position of option on menu: Design =>Roads =>More =>Road polygons

This option takes a model of cross-sections and create polygons between specified points on the 
cross-sections. This option is already documented under

Design => X-Sections =>Polygons from sections

For more information on the option Polygons from sections, please continue to the section 
“Polygons from Sections” in the this chapter

Road Widening with Minimum and Maximum Crossfall
widen_panel

Position of option on menu: Design =>Roads =>More =>Road widening

This option creates cross sections using the minimum and maximum cross-fall when going out 
from a selected reference string (usually and alignment string).

Adding these cross sections to a section view when designing the vertical geometry gives an 
envelope of maximum and minimum crossfall points.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model name min/max xfall model box

model for minimum/maximum cross fall cross sections.

Min xfall input box -2

minimum cross-fall (in %)

Max xfall input box -5

maximum cross-fall (in %)

Max width input box 10

maximum width to go out at the minimum and maximum cross falls.

Chg interval input box 20

chainage interval for calculating the minimum and maximum cross fall cross sections.

View to add view box

view to add the created cross sections to.
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Reference string select

pick the reference string with direction for the x-sections to go out from. The cross sections are created 
to the right of the reference string as defined by the direction that the Reference string is picked. To get 
the sections on the other side, pick the reference string in the opposite direction.

Process button

create the minimum and maximum cross fall cross sections.

Create Roundabout
roundabout_panel

Position of option on menu: Design =>Roads =>More =>Roundabout

This option creates a roundabout between two alignment strings. The road widths for the two 
roads (the distance from the road centre line to the edge of the road) plus the roundabout radius 
(the distance from the centre of the roundabout to the centreline of the roundabout road), the 
roundabout width (added and subtracted from the roundabout width to give the inner and outer 
edges of the roundabout roadway - the inner and outer roundabout radii) and the fillet radius for 
the turning lanes.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Select 1st road string select

first alignment string for the roundabout.

Select 2nd road string select

second alignment string for the roundabout.

1st road width input box

distance from the first alignment string to the edge of the road.

2nd road width input box
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distance from the second alignment string to the edge of the road.

Roundabout radius input box

distance from the centre of the roundabout to the centreline of the roundabout road.

Roundabout width input box

distance to add and subtract from the roundabout width to give the inner and outer edges of the 
roundabout roadway (the roundabout radii).

Fillet radius input box

fillet radius of the turning lanes.

Create roundabout centreline tick box

if tick, an alignment string is created for the centreline of the roundabout.

Model for roundabout input box

model for the created roundabout.

Process button

run the option.

Kerb Special Chainages File
qtr_spec_panel

Position of option on menu: Design =>Roads =>More =>Kerb special chainage file

This option is used to create a special chainage file for an alignment string. The method of creat-
ing the chainages is defined differently for each segment of the alignment string.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

By number tick box tick

if tick, break the selected segment of the selected string into the number of pieces given by the Value 
field.

By distance tick box

if tick, break the selected segment of the selected string into pieces of length given by the Value field.

Value tick box tick

the number of pieces or the chainage length to break the selected segment into.

Special chg file file box

file to write chainages to

Select button
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pick the alignment string to create chainages for. The alignment string is then drawn in the panel draw 
box. Each segment of the alignment string is selected by clicking MB over it in the panel draw box. The 
special chainages are then defined for that segment.

Add button

add the chainages given by number of length to the special chainages list

View button

view the special chainages list. The special chainages list can be edited

Write button

write the special chainages list to the special chainages file

Special Chainages File
special_chg_panel

Position of option on menu: Design =>Roads =>More =>Special chainage file

This option is used to create a special chainage file for an alignment string.

The chainages are created for a selected reference string but can then be defined by dropping 
strings and/or individual points onto the reference string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source choice box Special chainages Special chainages
String
Points
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Regular

Special

String string select

Reference string select

select the string to create special chainages for.

View list button

view the special chainage list.

Undo last button

undo the last set of created chainages.

Clear list button

clear the chainages list.

Special chng file file box

file to read chainages from or write chainages to

read button

read in a file of special chainages.

Write button

write the chainages list to the special chainages file.

Table Drain - Intersection of Slopes from Two Strings
slopes_intersect_panel

Position of option on menu: Design =>Roads =>More =>Table drain

This option is used to create a string which is the intersection of slopes from a left and right 
string.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Select the left string string select

select the left hand side string

Select the right string string select

select the right hand side string

Cross fall (1 in..) from left/right stringinput box 3

batter slope to go from left/right string

Separation distance input box 10

distance to create batter lines and find intersection

Intersection search distance input box 100

distance to search to find an intersection of the batter slopes

Name for intersection strings input box

name for the strings created by the intersection of the batters

Model/Colour for intersection strings intersection available models/colours

model/colour for the intersection strings

Create button

Create the intersection strings by battering of the left and right strings
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Intersection MTF Update
kret_control_chgs_panel

Position of option on menu: Design =>Roads =>More =>Intersection MTF updates

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name function box available functions

name for the function

Ref MTF file box *.mtf files

Reference string select

select the reference string

Left kerb string select

select the left kerb string

Right kerb string select

select the right kerb string

Left template chainage input

Right template chainage input

Process button

Update button
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Overlay
overlay

Position of menu: Design =>Overlay

The overlay options are for the design and optimisation of pavement overlay design.

The Overlay options is available to all users with the Detailed Alignment Design and Volumes 
modules.

 The Optimal Overlay is under development and has not been released.

The Overlay walk-right menu is

For the option Overlay, please continue to the section “Overlay Design” .

Overlay Design
overlay_design

Position of option on menu: Design =>Overlay =>Overlay design

Selecting Overlay brings up the Overlay Design panel.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data file file box *.ovd files

file with all the settings used in the Overlay panel. Used for storing information between runs.

Read button

read in a data file of settings for the panel

Write button

write out a data file of the settings in the panel

Buttons at bottom of panel

Overlay button

run the overlay.
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Setup

   Radio buttons
radio buttons to define how cross sections for existing road are produced

From Tin radio button

if selected, the road x-sections are created by taking sections though a tin. The following fields are 
displayed

Tin tin box available tins

sections are created through this tin to represent the existing road

Separation input

chainage distance between cross sections

Left/Right extension input

Left/Right distance to define the limits of the cross sections

Model for tin x-sections model box available models

model for the created cross sections

From Cuts radio button

if selected, the road x-sections are created by taking cuts through strings. The following fields are 
displayed

Strings model model box available models

sections are created by taking cuts through the strings in this model

Separation input

chainage distance between cross sections

Model for cuts model box available models

model for the created cross sections

From X-sections radio button

if selected, the road x-sections already exist. The following fields are displayed

X-sections model model box available models

existing model of x-sections to use for the road

Overlay mode choice box Normal Normal, Use Crossfalls Only
Use Reference Z Values and Crossfalls only

if Normal, at each section the left/right z-value is calculated so that the left/right crossfall and 
minimum overlay is obeyed. The z-value for the section is the maximum of the calculated z-values for 
the left and right.
If User Crossfalls only, the crossfalls from the Left and Right Setups tabs are used and no minimum 
overlay applied.
If Reference Z values and Crossfalls only, no overlay calculations are performed and the crossfalls 
in the Left and Rights Setups tabs are applied to the actual z-values on the reference string.

Reference string string select box
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select the string for the centreline of the road

Ignore reference z values in calculations tick box

if not tick, when the z-value is calculated at each section obeying just the minimum overlay criteria 
then use the maximum of the and the calculated z-value and the reference z-value at that section.
If tick, use the calculated z-value at each section. 

Start chainage input

chainage to start the overlay calculations

End chainage input

chainage to end the overlay calculations

Special chainages file box

special chainage file to define additional cross sections for overlay processing

Left/Right Setup tab
 setup for the left/right side sections

 Radio buttons
radio buttons to define how cross sections for existing road are produced

By offset radio button

if selected, the width of the left/right cross sections is given in the Offset field

Offset input

left/right offset distance to define the edge of the left/fight section

By String radio button

if selected, the width of the left/right cross section is defined by a selected Edge string minus the Cut 
Back/Extension value. The following fields are displayed

Edge string string select

select the left/right edge string

Cut Back/Extension input

value to subtract from the distance to the edge string to define the left/right section

When By String is selected, the Chainage-Minimum X-Fall grid can also be automatically filled in by 
using the crossfall between the Road Crown and the Edge String.

Road crown string select

select the road crown the use for calculating the cross fall to the Edge string

Only critical points tick box

if tick, the crossfall between the Road crown and the Edge string is only calculated at the tangent 
points of the Reference string.
If not tick, the crossfall between the Road crown and the Edge string is calculated at the regular 
interval given by Xfall Load Interval and also at the tangent points of the Reference string.

Xfall load interval input

regular interval to calculate crossfall
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Load Xfalls from Strings button

when selected, the Chainage-Minimum X-Fall grid is automatically filled in by using the crossfall 
between the Road Crown and the Edge String

By name radio button

if selected, the width of the left/right cross section is defined by the name of a given string minus the 
Cut Back/Extension value. The following fields are displayed

Name

name of the string to select as the left/right edge string

Cut Back/Extension input

value to subtract from the distance to the edge string to define the left/right section

Default Xfall input

if non blank, the default crossfall to use for the left/right cross section.
If blank, the Chainage-Minimum X-fall grid is used.

Chainage- Minimum Xfall grid

this grid is only used if the Default Xfall is blank

Chainage input

chainage to use the Min xfall

Min X-fall input

minimum X-fall to use at that chainage

Min. Depth tab
 there can be one minimum depth value for the entire job or the minimum depth can vary between 
chainages

Default depth input

if non blank, the default minimum depth to use for the left and right cross section.
If blank, the Chainage-Minimum Depth grid is used.

Chainage- Minimum Depth grid

this grid is only used if the Default depth is blank

Chainage input

chainage to start the minimum depth

Min Depth input

minimum depth to start at this chainage and either go to the next chainage or if there is a Min Depth 
2, interpolate to Min Depth 2 from this chainage to the next chainage

Min Depth 2 input

minimum depth to end with at the next chainage 

Results tab

Transfer Z-values to reference string tick box

if tick, the calculated z-values are used to update the z-values on the reference string
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Clean models before overlay tick box

if tick, the models of results are cleaned before the overlay option is run

Model for overlay x-sections model box available models
model for the created overlay x-sections

Model for overlay strings model box available models
model for the created overlay strings

Colour colour box available colours
colour for the created overlay strings

Model for xfall strings model box available models

if non blank, left and right strings with z-value equal to the left/right crossfall are created and placed 
in this model

Model for min/max points model box available models

if non blank, points for the minimum and the maximum of the calculated z-values for the left and 
right sections are created and placed in this model

X-sections depth range file file box available depth range files
a depth range file used for colouring x-sections by the depth between the overlay and the road tin

Overlay report file box *.rpt files
report on the overlay

Volumes report file box *.rpt files

volumes of overlay report

Write volumes as CSV tick box

if tick, the volume report is written as a CSV file (for Excel(

Overlay Tin tab
the Overlay Tin tab controls the creation of an overlay tin and depth polygons

Create overlay tin tick box

if tick, the fields in this tab are used to create an overlay tin

Tin name tin box available tins

name for the tin created from the overlay strings and sections

Tin colour colour box available colours

colour of the overlay tin

Model for tin model box available models

model for the overlay tin

Create depth polygons tick box

if tick, depth polygons are created between the road tin and the overlay tin

Depth range file file box *.drf files

depth range file used when creating polygons

Model for depth polygons model box available models

model for the depth polygons

Scarification tab
the Scarification tab controls any scarification to be applied to the road sections before calculating 
overlays
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Perform scarification tick box

if tick, scarification is performed on the road sections before overlay is calculated

Model for scarified x-sections model box available models

if non blank, road x-sections after scarification are created and placed in this model

Colour colour box available colours

colour of the scarified sections

Clean scarification x-sections model tick box

if tick, the clean the model of scarified sections before running calculations

Default scarification depth input

if non blank, the default scarification depth to use for road cross section.
If blank, the Overlay-Depth grid is used.

Chainage- Minimum Depth grid

this grid is only used if the Default scarification depth is blank

Chainage input

chainage to start the scarification depth

 Depth input

scarification depth to start at this chainage and either go to the next chainage or if there is a Depth 2, 
interpolate to Min Depth 2 from this chainage to the next chainage

Depth 2 input

scarification depth to end with at the next chainage 

Plots tab

Generate long section plots tick box

if tick, long section plots are created

Long section PPF file box *.lplotppf files

binary ppf file to use for the long section plots

Plotter type plotter box model available plotters

type of plotter to use for the long section plots

Plot stem

the name to use for the plots - a number will be added when more than one page is produced

Clean plot model beforehand tick box

if tick and the plotter type is model, the plot models are cleaned before the plots are created

Generate cross section plots tick box

if tick, cross section plots are created

Cross section PPF file box *.lplotppf files

binary ppf file to use for the cross section plots

Plotter type plotter box model available plotters

type of plotter to use for the cross section plots

Plot stem

the name to use for the plots - a number will be added when more than one page is produced

Clean plot model beforehand tick box

if tick and the plotter type is model, the plot models are cleaned before the plots are created
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Optimal Overlay
optimal_paver

Position of option on menu: Design =>Overlay =>Optimal overlay

This option is under development and has not been released.
Selecting Optimal overlay brings up the Optimal Paver panel.
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X-Sections
x_sections

Position of menu: Design =>X-Sections

Cross sections can be created in a variety of ways including

(a) sections through triangulations created with the options in the menu Tins =>Sections.

(b)  sections generated by cutting through strings with the options Utilities =>A-G =>Cuts.

(c) design sections generated from options on the menu Design =Apply

(d) sections generated by the end area volumes options Design =>Volumes =>End area

 The x-sections menu contains options to read cross-sections in from a file and for working with 
cross sections in a variety of way. 

Walking right on X-Sections bring up the X-Sections menu:

For the option Cut/fill polygons from sections, go to the section “lCut/Fill Polygons from Sections” 
Name cross sections by chainage “Name Cross Sections by Chainage” 

. Polygons from sections  “Polygons from Sections” 
Read x-section file  “Read X-Section Data” 
Sort cross-section mode “Sort X-Sections in a Model” 
Strings from sections,  “Strings from Sections” 
X-section filter  “X Section Filter (Sections at Even Chainages)” 
X-sections along a string  “X-Sections”  in the Chapter “Triangles” 
X-sections from cuts thru strings  “Cuts by Centreline” in the Chapter “Utilities” 
X-sections from points  “Sections from Points” 
Report x-sections “X-Sections Report”  in the chaper “Reports” 

lCut/Fill Polygons from Sections
cutfill_polygons_panel

Position of option on menu: Design =>X-Sections =>Cut/fill polygons from sections

This option takes cross sections and by using the user-supplied names of points on the cross 
section, cut and fill polygons for the strings joining the named points in successive cross sections.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model of x-sections model box available models
model containing the cross sections used to define the cut and fill polygons.

Name of last fixed for LHS polygons input verge
Name of the cross section point to be the inner point of the left hand side polygons.

Name of last fixed for RHS polygons input verge
name of the cross section point to be the inner point of the right hand side polygons.

Name of interface point for LHS polygons input int
name of the cross section point to be the outer point of the left hand side polygons.

Name of interface point for RHS polygons input int
name of the cross section point to be the outer point of the right hand side polygons.

Colour for cut polygons input red available colours
colour for the cut polygons.

Colour for fill polygons input green available colours
colour for the fill polygons.

Colour for other polygons input blue      available colours
colour for the polygons that are neither cut or fill – they are either flat or change from cut to fill.

Model for cut polygons input cut   available models
model for the cut polygons.

Model for fill polygons input fill       available models
model for the fill polygons.

Model for other polygons input other available models
model for the polygons that are neither cut or fill – they are either flat or change from cut to fill.
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View to add polygons input available views
if non-blank, the models of polygons are added to the view.

Create all button
run the option and create left and right polygons.

Create left button
run the option and only create the left polygons.

Create right button
run the option and only create the right polygons.

Undo button
undo the last set of polygons created whilst the panel has been up.

Finish button
end the option and remove the panel. The undo capability for the polygons is terminated.
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Name Cross Sections by Chainage
xs_name_by_chainage_panel

Position of option on menu: Design =>X-Sections =>Name cross sections by chainage

This option names cross-sections with the chainage from a selected string.

Note that the chainage from the string that the cross section comes from is in the name of the 
cross section so this option effectively gives the chainage to the cross section.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Cross sections source choice box model string, model, view
type of data source.

Model/String/View of x-sections  source box
source of the cross section data.

Number of decimals input box 3
number of decimal places to use in the chainage label.

Scale factor input box 1
factor to multiply the chainage by before creating the label.

Prefix choice box sect sect, design, none
prefix for the chainage value - for cross-section options to work, this should be sect or design.

Pick centreline string output box
select the string that is used to find a chainage for the cross sections.

Process button
run the option.
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Polygons from Sections
road_polygons_panel

Position of option on menu: Design =>X-Sections =>Polygons from sections

Option to take a model of cross-sections and create polygons between specified points on the 
cross-sections.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model that contains the cross sections model box

model of cross sections

Name of first/last point for lhs polygons  input box

name of the first/last point on left hand side of the cross-section to creating polygon for.

Name of first/last point for rhs polygons input box

name of the first/last point on right hand side of the cross-section to creating polygon for.

Model/colour for polygons  input box

model/colour of the created polygons.

Create button

create polygons between the first and last points on the left and right side of the cross-sections.

Undo button

undo the last set of polygons created whilst the panel was up.
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Read X-Section Data
read_xsc_panel

Position of option on menu: Design =>X-Sections =>Read x-section file

This option is used to read in cross section data from a file and convert it to x-section strings (4d 
strings). 

The data in the file is only centre-line chainage values, offset, heights and text (Code) so an 
alignment string needs to be selected to give an (x,y) position for the centre-line chainage and a 
direction (at right angles to the alignment string at the chainage) to convert the (offset, height) 
values into (x,y,z) points on a string.

NOTE - after reading i the x-section data and hence creating 4d strings, the

 Design =>X-Sections =>Strings from sections

option can be run to create 3d strings by joining points with the same Code from adjacent x-
sections. The created 3d strings are given the string name of the Code that they joined.

 Selecting Read x-section file brings up the Read X-Section Data panel:

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

File format input box 12d Model 12d Model, Alg, Moss, 
Chainage/Offset/Height/Text

format of the x-section data in the file.

12d Model Format

The 12d Model format is a simple text file format with the text CH followed by one or more spaces and 
then the alignment chainage (centre line chainage) of the x-section, and then on the following lines, the 
Offset value followed by one or more spaces, the height at that offset followed by one or more spaces, 
and then the text (Code) for that point on the x-section. The x-section continues until the next Ch line. 
For example, the following defines two x-sections at chainage 10 and 20 respectively.

 ch 10
 -3 5 A
 0 6 "Second label"
 4 7 C
 ch 20
 -3.5 5.5 A
 0 6 D
 4.5 7.5 ""

Note that if the Code includes a space, then it must be enclosed in quotes.For example "Second label". 
Also the Code is not optional - if there is no code, put "".
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Chainage/Offset/Height/Text Format

The Chainage/Offset/Height/Text format is a very simple text file format with each line containing 
the alignment chainage (centre line chainage) for the x-section followed by one or more spaces and then 
on the same line the Offset value followed by one or more spaces, the height at that offset followed by 
one or more spaces, and then optionally, the text (Code) for that point on the x-section. The x-section 
continues until the alignment chainage changes. For example, the following defines two x-sections at 
chainage 10 and 20 respectively.

10  -3 5 A
10  0 6 "Second label"
10 4    7  C
20  -3.5  5.5 A
20  0 6 D
20  4.5     7.5 E

Note that if the Code includes a space, then it must be enclosed in quotes.For example "Second label". 
Also the Code is optional (whereas it was compulsory for the 12d Model format).

Moss (MX) Format

Please refer to Moss (MX) documentation or ask the group who supplied the data.

Alg Format

Not documented.

X-section file input box
file of x-section data.

String names on line 4 tick box
ONLY used for the ALG format which is not documented

Select al string string select
select the string that is used to define the (x,y) position of the zero offset of the x-section and also the 
bearing for the x-section.

Model for x-secs model box available models
model for the created x-sections

Process button
read the file and create the x-sections

Undo button
undo the last set of x-sections created since the panel has been active

Sort X-Sections in a Model
xs_sort_panel

Position of option on menu: Design =>X-Sections =>Sort cross section model

This option is used to sort cross sections in a model so that they are in the order of the chainages 
embedded in the cross section name.

 Selecting Sort cross section model brings up the Sort X-Sections in a Model panel:
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model of x-sections model box available models

model containing the cross sections to be sorted into chainage order.

Sort button

run the option.

Strings from Sections
strings_from_sections

Position of option on menu: Design =>X-Sections =>Strings from sections

The strings from sections option creates strings by joining the common named points on 
successive 4d strings (usually generated as sections).

 Selecting strings from sections fires up the strings from sections panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model of sections input available models

model of the 4d strings (sections) to try and join common points from to form strings.

Model for string input available models

model for the created strings to go to.

Process button

try and join points with the same name from successive sections to form strings.

Sections from Points
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sections_from_points

Position of option on menu: Design =>X-Sections =>X-sections from points

The X-sections from points option creates a cross section by first defining s section line and then 
dropping all selected points in a user defined offset distance from the section line, onto the 
section line. 

(a) The z-value for the dropped point is the same as for the original point.

(b) The Point number (Vertex id) of the dropped point is the Point number (Vertex id) of the 
original point.

(c) The Vertex text of the dropped is the code (string name) of the original point.

The user specifies the start chainage for the created section and the value for the "centreline 
chainage" of the section. 

 Selecting Sections from points fires up the Sections from points panel.

Section line

All selected points within the offset distance 
are projected onto the Section Line

The z-value of the projected point is the same 
as the original point

this point is not used since it is outside the 
offset distance from the section line.

offset
distance

offset
distance
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type

data source type.

Data source

data source for points to create sections from.

Point mode choice box 2 points 2 points,
1 point and bearing
point on centreline

if 2 points, then the Start point and End point are selected. The section goes through the two points.
If 1 point and bearing, then the Start point is selected and a Bearing given. The section goes 
through the start point with the given bearing.
If point on centreline, then a Centreline is selected and a point on the centreline selected. The 
section goes through the selected point on the centreline and is perpendicular to the selected centreline 
at the selected point.

If Point mode is 2 points: 
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Start point string select

End point string select

If Point mode is 1 point and bearing: 

Start point string select

Bearing angle box

If Point mode is point on centreline 

Centreline string select

depends on Point mode.

Point on cl string select

depends on Point mode.

Cl chainage input

the chainage to give to the created section

Start chainage input

the start chainage to give to the created section.

Offset distance input

distance to search either side of the section for points to project onto the section

Include contrl points(s) tick box

if tick, the selected start and end points are included as part of the section.

Create super string tick box

if tick, then the created section is a super string.

Model model box available models

model for created sections.

Colour colour box available colours

colour for the created sections.

Linestyle linestyle box available linestyles

linestyle for the created sections.

Report file file box

a report.

Process button

create a cross section from the selected points.
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X Section Filter (Sections at Even Chainages)
xs_filter_func_panel

Position of option on menu: Design =>X-Sections =>X-section filter

This panel selects user specified cross-sections from a model of cross-sections and copies them 
into another model. The cross sections must already exist - no new cross-sections are created. 

It is a function so can be recalced when the cross-section model is changed.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Function name

name of the function.

Model of sections string select

model of existing cross sections to select some cross sections from.

Filter model name model box

model for the selected cross sections

Filter section colour colour box cyan

colour for the filtered cross sections

Filter chainage interval input 20
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chainage interval to select cross sections. Sections are selected which are multiples of the filter 
chainage interval.

Design/Existing sections radio button design sections

cross sections are 3d strings with the name 
Design and the chainage of the cross-section (usually created by an Apply), 

or  Sect and the chainage of the cross-section (usually created by Tins =>Section =>X section)

If Design sections is selected, then sections starting with the name Design are selected.
If Existing sections is selected, then sections starting with the name Sect are selected.

Include TC_CT sections tick box

if tick, include cross sections at tangent points from the reference string.

Include start/end section tick box

include a cross section at the start/end chainage of the reference string

TC_CT tolerance +/- input box

if non-zero, then regular cross sections (i.e. those selected by the filter chainage interval) are not 
included if they are closer than the given tolerance distance to a tangent point.

Special chainage file input box

include cross sections with chainages given in the given special chainage file.

Reference output box

select reference string to use for the filter options requiring tangent points and start/end chainages.

Process button

copy the specified cross-sections to the Filtered Model.

X-Sections Along a String
Position of option on menu: Design =>X-Sections =>X-Sections along a string

This option has already been documented in Tins => Sections=> X-Sections

For the option X-Sections along a string, please continue to the section  “X-Sections”  in the 
Chapter “Triangles” .

X-Sections from Cuts Through Strings
Position of option on menu: Design =>X-Sections =>X-Sections from cuts thru strings

This option has already been documented in Utilities =>A-G =>Cuts =>by centreline

For the option X-Sections along a string, please continue to the section  “Cuts by Centreline” in 
the Chapter “Utilities” .
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More Design
more_design
Position of menu: Design =>More

The more design menu contains extra design options.
The more design walk-right menu is

For the option Culverts from file, please continue to the section “Culverts from File” .
 Settlement “Settlement” 
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Culverts from File
12d_culvert_panel

Position of option on menu: Design =>More =>Culverts from file

This option is currently under development.
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Settlement
settlement_panel

Position of option on menu: Design =>More =>Settlement

This option uses a tin of settlement values to adjust the z-values of strings.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source choice box model/view
type of data source.

Model/View name
source of the data to process. Only 2d, 3d, 4d and super strings from the data source are processed.

Settlement tin available tins
tin of values (settlement values) to be used to reduce/increase the z-values of strings by.

Settlement on choice box relative points relative points
relative strings
absolute points
absolute strings

if Settlement on is "relative points" then for each point of a string, the value of the settlement string at 
that (x,y) position is added/subtracted from the z value at the point.

is "relative string" then for each point of a string, the value of the settlement string 
at that (x,y) position is added/subtracted from the z value at the point plus for each visible segment 
joining points of the strings then if the segment crosses any edges of triangles from the settlement tin, a 
new point is inserted into the string which then has the settlement value applied to it (the initial z-
value for the inserted point is interpolated from its adjacent points in the string).

is "absolute points" then for each point of a string, the value of the settlement string 
at that (x,y) position is taken to be the z value at the point.

is "absolute string" then for each point of a string, the value of the settlement string 
at that (x,y) position is taken to be the z value at the point plus for each visible segment joining points 
of the strings then if the segment crosses any edges of triangles from the settlement tin, a new point is 
inserted into the string which is given the settlement value at that point.

Apply tin values by choice box add tin values add tin values
subtract tin values

if "add tin values", then the tin values are added to the string values.
If "subtract tin values", then the tin values are subtracted from the string values.



Chapter 17  Design

March 2007 Page 1787More Design

Prefix for models
prefix to apply to the name of each model in the data source to create new models for the processed data.

Process button
adjust the heights of the selected data.
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Ortho 12d
ortho_12d
Position of menu: Design =>Ortho 12d

The Ortho 12d menu contains the option to write out tins in a format suitable for the Ortho 32 
rectification software.
The Ortho 12d walk-right menu is

For the option Create triangles, please continue to the section “Create Triangles” 

Create Triangles
create_ortho_12d_triangle_file

Position of option on menu: Design =>Ortho 12d =>Create triangles

This option writes out a 12d Model tin in a format suitable for the software Ortho12d software 
from Digital Mapping Systems (www.digmapsys.com).

Ortho12d is an image rectification package which can be used for ortho-rectifying photographs.

For more information on Ortho12d, please contact Ian Hall from Digital Mapping Systems on 
ian.hall@digmapsys.com

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin tin box available tins
tin to write out in Ortho12d format

Tin polygon selection Polygon select box
if used, only triangles whose centroid is inside the polygon are written out.

Ortho12d output file file box *.T12 files
file to write the tin out to

Write button
write the tin out in the Ortho12d format
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18  Drainage and Sewer
drainage

Position of menu: Design =>Drainage-Sewer

The Drainage-Sewer option is used to place drainage and sewer networks within a subdivision. The 
network is placed in three dimensions including manholes (maintenance holes), and for sewer work, lot 
controls and house connections can be defined.

If used in conjunction with the services on a section view, interference with neighbouring pipe strings can 
be taken into consideration when placing the network.

Note that the drainage string and plots is only available with the drainage and sewer options and the sewer 
extensions (property control, house controls and Melbourne Water plots) are only available with the sewer 
option.

The drainage string is based on a polyline string so that arcs can exist between manholes (maintenance 
holes).

The use of the drainage string for drainage is only a subset of its use for sewer so the steps for the sewer 
will be given since they cover drainage as well.

The sewer process consists of a number of steps (the drainage process does not use steps 2 and 3):

1. creating the drainage or sewer network

2. checking that residential blocks are controlled by the sewer network

3. creating the house connections for the sewer

4. network design using custom routines, spread sheets or advanced network analysis packages

5. producing plots (plan and long section), material quantity reports, excavation volumes and manhole 
construction reports

These steps are described in the rest of this chapter.

The Drainage walk-right menu is laid out to reflect the standard sequence of placing drainage and 
wastewater pipes, i.e., creating, editing and plotting.

For a description of the drainage string in 12d Model, please go to the section “Drainage Strings” 

For a definition of a drainage network and a junction in 12d Model, please go to the section “Networks and 
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Junctions” .

For a description of the drainage defaults in 12d Model, please go to the section “Drainage Definitions” 

For a description of the drainage design import/export interface, please go to the section "Drainage 
import/export"

For the option Defaults, please continue to the section “Defaults” .

 Create, please continue to the section “Create” .

 Editor, please continue to the section “Editor” .

 Plots, please continue to the section “Drainage Plots” .

 Reports, please continue to the section “Reports” .

 More, please continue to the section "More Drainage".
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Drainage Strings
A drainage string consists of a series of manholes (maintenance holes) at user selected (x,y,z) positions. 
The manholes can be joined by either straight or curve pipes.

Like all 12d Model strings, the drainage string has an implied direction, starting at the first manhole and 
going in the direction towards the next manhole in the drainage string. This order is normally determined 
by the creation order of the manholes.

The chainage of the drainage string starts at the first manhole and then increases along the direction of the 
drainage string.

In 12d Model, drainage strings can be entered such that

(a)  the most upstream manhole is entered as the first point of the string and hence the water flows in the 
direction of ascending string chainage. The flow direction is said to be in ascending chainage.

or

(b)  the most downstream manhole is entered as the first point of the string and hence the water flows in 
the direction of descending chainage. The flow direction is said to be in descending chainage)

When a drainage string with flow direction in ascending order is profiled in a section view, the left hand 
side of a manhole is normally upstream and the right hand side of a manhole downstream.

It is recommended that drainage strings are entered with the flow direction in ascending chainage so that 
the minimum grade and cover can be satisfied as the drainage string is being placed.

That is, if the drainage string flow is in ascending chainage direction, then as manholes are appended, 
minimum cover and minimum grade can be automatically maintained.

Please continue to the next section “Networks and Junctions” .

flow direction in ascending chainage flow direction in descending chainage

SECTION VIEW

PLAN VIEWPit 1
Pit 2

Pit 3
Pit 4

Pit 5 Pit 6 Pit 7

Pit 1
Pit 1

DRAINAGE_FLOW_DIR_4D = 1 DRAINAGE_FLOW_DIR_4D = 0
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Networks and Junctions
In 12d Model, a drainage network consists of one or more drainage strings in the same model. 
Consequently, all the drainage strings in the same model are considered to be part of the same drainage 
network.

WARNING - All drainage strings in a network must be entered with the same flow direction.

If two drainage strings from the same model have a manhole at exactly the same (x,y) location, then 
12d Model assumes that the co-incident manholes are the same manhole and that the situation represents a 
junction.

Also for a network, if all the drainage strings are entered with the flow direction in ascending chainage, not 
only can minimum cover and minimum grade be maintained as manholes are appended, but if the branches 
are laid down before the trunk, then as you connect each branch to the trunk, the invert level for the trunk 
will be set to below the invert level of the branch line (less the default drop for the manholes).

Please continue to the next section “Drainage Definitions” .

SECTION VIEW

PLAN VIEW

Pit AB1
Pit AB2

Pit AB3

Pit A1

Pit A2

Pit A1

Branch AB

Trunk or main line A

Pit A2

placing pit A3
on AB3

the level of pit A3
is set below AB3

output level of AB3
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Drainage Definitions
A file of definitions of pipe and manhole (maintenance hole) types can be given to allow tailoring for a 
particular project.

When 12d Model starts up, it checks to see if an environment variable called DRAINAGE_4D exists and if 
it does, then the file it points to is used to provide the available types of manholes (maintenance holes) and 
pits.

If the environment variable is not set, then 12d Model searches for a file called drainage.4d in the 
standard 12d Model search sequence for set up files.

 
The drainage definitions file format is a simple ascii format and consists of one or more pipe and manhole 
definitions. Each definition in the file begins with the key word Pipe or Manhole, followed by the pipe or 
manhole type and then curly braces { }. 

Note

In future versions of 12d Model, this definition will be extended to include special Pipe and Manhole 
commands within the curly braces.

An example of a typical drainage definitions file is:

// -------------------------------------------------------------
// drainage.4d 1/6/96
// Used to define the types of Pipes and Manholes
// -------------------------------------------------------------
Pipe   "PVC"   {
}

Pipe   "VC"   {
}
Pipe   "PVC Extra Heavy"   {
}
Pipe   "Plastic" {
}

Manhole   "CONC COVER" {
}
Manhole "Gatic"   {
}
Manhole   "Rubber"   {
}

Notes

1. spaces in text - any text string that includes spaces or only numbers, must be enclosed in double quotes 
".

2. comments - anything after // until the end of the line is ignored.

3. blank lines - blank lines are ignored

Please continue to the next section “Defaults” .
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Defaults
drainage_defaults

Position of menu: Design =>Drainage-Sewer =>Defaults

The defaults menu sets default tin, manhole (maintenance hole) information, drainage pipe information, 
property control (sewer module only) and house connection (sewer module only) defaults which are all 
used when defining drainage networks.

The Defaults walk-right menu is

For the option Tins (fs), please continue to the section “Tin (fs)” .

 Manholes, please continue to the section “Manholes (Maintenance Holes)” .

 Pipes, please continue to the section “Pipes” .

 Property controls, please continue to the section “Property Controls” .

 House connections, please continue to the chapter  “House Connections” .

Tin (fs)
drainage_tin_defaults
Position of option on menu: Design =>Drainage-Sewer =>Defaults =>Tin (fs)

On selecting the Tin (fs) option, the Drainage Tin Defaults panel is displayed.

This panel is for setting the default finished surface tin in the Create Drainage Strings panel which is used 
for creating a new drainage string. 

For the drainage string, the finished surface tin is used as the surface that manholes automatically sit on 
when z float is set on, and for defining cover when placing controls and connections.

Manholes (Maintenance Holes)
drainage_manhole_defaults
Position of option on menu: Design =>Drainage-Sewer =>Defaults =>Manholes

On selecting the Manholes option, the Drainage Manhole Defaults panel is displayed.



Chapter 18  Drainage and Sewer

April 2003 Page 1795Defaults

These defaults are used when creating a manhole in a drainage string. The fields and buttons used in this 
panel have the following functions.

Field Description Type Defaults Pop-Up

Diameter input 1.1

default diameter of a drainage manhole

Drop input 0.02

drop (metres) through the manhole

Name input MH.

default name for the manhole Note that if a manhole name is EOL or eol, then the diameter of the 
manhole is forced to be zero.

Type input CONC COVER CONC COVER, GATIC

the default cover or lid type of the manholes

Set button

set the drainage manhole defaults to the values in the above fields.

Pipes
drainage_pipe_defaults

Position of option on menu: Design =>Drainage-Sewer =>Defaults =>Pipes

On selecting the Pipes option, the Drainage Pipes Defaults panel is displayed.

This panel is for setting the default drainage pipe diameter, grade, cover and type. These defaults are used 
when creating a pipe in a drainage string.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Diameter input 0.1

default diameter of the pipe.

Minimum grade input 1.0

the minimum grade (measured as 1: value) used when laying down the pipe.

Minimum cover input 1.0

the minimum cover, measured in world units from the surface to the top of the pipe (obvert); used when 
laying down the pipe.

Type input PVC PVC, VC,
PVC X/HEAVY

the default type of the pipe

Set button

set the drainage pipe defaults to the values in the above fields.

IMPORTANT NOTE. 

If the drainage string is laid down in the direction of flow (and hence the flow direction is in ascending 
chainage), then the minimum grade and minimum cover along the pipe are maintained as the drainage 
string is created. Otherwise the minimum grade and cover cannot be maintained.

Cover for the pipe segment can also be calculated and/or set afterwards by the pipe=>cover option in the 
drainage string editor.

Minimum cover and minimum grade for the pipe segment to the end of the line can be set afterwards by 
the pipe=>default grading option in the drainage string editor.

Property Controls
drainage_property_control_defaults

Position of option on menu: Design =>Drainage-Sewer =>Defaults =>Property Controls

On selecting the Property controls option, the Drainage Property Control Defaults panel is displayed.

On a section view, the Profile =>One substring and Profile =>Many substrings options will profile the 
property control. Note that the centre (axis) of the property control is drawn on the section view, not the 
invert (bottom) or the obvert (top).
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Diameter input 0.1

default diameter of the property control.

Grade 1v in input 60

grade (units are "1v in" given value) to use for the property control

Cover input 1.0

cover measured from the surface to the top of the property control (world units) to be maintained from 
the end of the property control in the house block to the drainage string.

Colour input cyan available colours

colour to use to draw the property control

Name input Lot

name for the property control - usually the lot number

Set button

set the property control defaults to the values in the above fields.
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House Connections
drainage_house_connection_defaults
Position of option on menu: Design =>Drainage-Sewer =>Defaults =>House connections

On selecting the House connections option, the Drainage House Connection Defaults panel is displayed.

This panel is for setting the default information used for connections from the drainage pipe to the house 
blocks.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin (fs) input drainage tin available tins

name of the tin to automatically add to the section view used for drawing the profile along the house 
connection.

Section view input

the section view used to profile along the house connections as they are placed in plan view.

Diameter input 0.1

default diameter of the house connection.

Grade 1v in input 60

grade (units are "1v in") to use for the house connection

Cover input 1.0

cover (world units) to use for the house connection

Length input 2.0

length (metres) to use for some types of house connections

Colour input cyan available colours

default colour used for the house connection

Name input Lot

name for the house connection - usually the lot number
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Connection type input A special A, A special, B, C, OB,
Special Jump Up

the default type of house connection, Please continue to the section “House Connection Types” for a 
description of each connection type

Set button

set the house connection defaults to the values in the above fields.

House Connection Types
All house connection calculations do not take into account any thickness of pipe, joint sizes or actual entry 
points into the sewer. Hence they are approximate only and should only ever be used as a guide. Any 
quantities calculations should allow for a suitable margin of error.

House Connection -Type A 

House Connection - Type A Special 

Connection level
is the height
at this point

Connection length

House Connection: Type A 
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House Connection - Type B 

House Connection - Type C 

Connection level
is the height
at this point

Connection length

House Connection: Type A Special

Connection level
is the height
at this point

House Connection: Type B
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House Connection - Type Special Jump Up 

House Connection - Type OB (Oblique)

Please continue to the next section “Create” .

House Connection: Type C

Connection length

Connection level
is the height
at this point

Connection length

House Connection: Type Special Jump Up

House Connection: Type OB
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Create
create_drainage_string

Position of option on menu: Design =>Drainage-Sewer =>Create

The Create option is used to produce new drainage strings and networks. If a drainage string already exists, 
the Editor option is used to modify it.

On selecting the Create option, the Create Drainage String panel is displayed.

To create a new drainage string, the name, colour, model and style of the new string are entered into the 
appropriate fields, plus the finished surface triangulation that the manholes are normally flush with, the 
natural surface triangulation, and the Create button selected.

The new fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Flow direction input ascending chainage ascending chainage
descending chainage

if ascending chainage, then the flow direction is in ascending chainage (recommended)
if descending chainage, then the flow direction is in descending chainage.

Tin (fs) input drainage=>defaults=>tinavailable tins

the finished surface tin. If manholes are "floating", the top of the manhole is automatically place on the 
tin surface ("floated" on the surface).

Tin (ns) input available tins

the natural surface tin used in longsection plots.

The Create Drainage String panel is then removed and the Drainage Edit menu and Drainage Edit Info 
panel fired up.

As for a 3d string, to create a new drainage string with some of the same name, colour, model and style as 
an existing string (not necessarily a drainage), the Same as button is chosen and the appropriate string 
selected.

The Drainage Edit menu contains all the available options for editing a drainage string and its associated 
block controls and house connections. The Drainage Edit Info panel contains information areas. The 
Drainage Edit menu and Drainage Edit Info panel are



Chapter 18  Drainage and Sewer

April 2003 Page 1803Editor

To create a new drainage string, the user selects the Append option from the Edits walk right menu on the 
Drainage Edit menu.

Since the Drainage Edit menu and Drainage Edit Info panel are the same as those used when editing a 
drainage string, the options will be discussed under the drainage Edit option.

For documentation on editing Drainage string, please continue to the next section “Editor” .

For drainage utilities and import/export see More Drainage 

Editor
Position of option on menu: Design =>Drainage-Sewer =>Editor

This is the same option as Editor from the Strings walk-right menu on the 12dModel menu.

The string editor is used to modify any 12dModel strings. After selecting the Editor option, the Edit 
String panel is placed on the screen to record any error messages.

The option is already in the pick mode (the pick & edit button only needs to be selected if the pick was 
cancelled) and the user simply picks and accepts the string to be edited.

From the picked string's type, the editor is able to determine the edits that apply to the string and list them 
in the string's edit menu.

If a drainage string is selected, the Drainage Edit menu and Drainage Edit panel (as shown in the previous 
section) are placed on the screen.

The individual edit operations for a drainage string will now be discussed in detail.

Please continue to the next section “Drainage Edit” .
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Drainage Edit
drainage_edit
drainage_edit_info
On picking a drainage string when in the string Editor option, or by selecting Create in the Create 
Drainage String panel, the Drainage Edit menu and panel are placed on the screen.

The edit is cancelled by selecting the Quit. No changes to the string are recorded and the Drainage Edit 
option terminates.

The edit is finished and the changes recorded when the Finish is chosen. The Drainage Edit option then 
terminates.

When either button is selected, a Yes-No-Cancel panel is displayed and the user must confirm the 
selection.

The Drainage Edit Info panel is principally used to display information and messages during the creation 
and editing of the drainage string. It is toggled on and off by Info on the Drainage Edit menu.

The main message area indicates the purpose of the mouse buttons at each step.

Message area 1 displays the current Drainage Edit option and message area 4 indicate the next step in the 
edit option.
Message areas 2 and 3 are used to display information about the string as the cursor is moved near the 
drainage string and the drainage manholes.

Each of the options in the Drainage Edit menu will now be described.

For the option Edits, please continue to the section “Edits” .

 Manholes, please continue to the section “Manhole (Maintenance Hole)” .

 Pipes, please continue to the section “Pipe” .

 Controls, please continue to the section “House Connections” .

 Connections, please continue to the chapter  “House Connections” .

 Utilities, please continue to the chapter  “Utilities” .

 Z float, please continue to the chapter  “Z Float” .

Edits

edits

The options in the Edits menu are used for placing the initial manholes of a new drainage string, editing a 
new drainage string once the initial manholes are placed or editing an existing drainage string.

The Edits walk-right menu is
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Append, Append+Radius
The Append, Append+Radius operations for a drainage string are similar to the Append options for a 
polyline string except that manholes are also automatically placed at each added point.

Note - a manhole can be removed from the point afterwards using the Manhole=>Remove option. The point 
will still be there but without a manhole on it.

If the Append + Radius option selected, then before each point is appended, an enter radius typed-input box 
is placed on the screen.

The enter radius typed-input box looks like

The radius is entered into the typed-input box, terminated with <enter>. The entered value is taken as the 
radius of the arc to the next drainage string point and the arc will be drawn correctly as the cursor is moved 
to the next point.

A radius value of 0 is taken to mean no arc.

If z Float is set to tick, then the top of the manhole is automatically placed on the terrain given in the tin 
field for the drainage string.

If height snap is toggled on in the Snaps menu, the height will be displayed an a new height entered but the 
new height will only be used if z Float is turned off for the manhole.

Each manhole in the string is connected by a drainage pipe. The diameter, type and cover at each end of the 
drainage pipe are taken from the Drainage Pipe Defaults panel.

The Append options are terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, 
Finish, or a new option from the Drainage Edit menu.

Move
If used in a plan view, the Move option is used to move the (x,y) position of a manhole.

If used in a section view, the Move option can be used to change the height of the top of any manhole or the 
height of either end of the drainage pipe connecting adjacent manholes in the drainage string.

After the Move option is chosen, the user selects either a manhole in a plan view or the top of a manhole or 
a pipe end in a section view.

If a manhole is selected from a plan view, then the plan position of the selected manhole will move with 
the cursor. The new position for the top of the manhole can be chosen by either cursor selection or typed 
input in exactly the same way as for moving a point on a 3d string.

If the top of a manhole or the end of a pipe connecting adjacent manholes is chosen in a section view, then 
only the height of the selected point can be modified. That is, if a point is selected in a section view, then it 
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is constrained to move in the z-direction only.

The Move option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, or 
a new option from the Drainage Edit menu.

Insert
The Insert option is designed to place a new manhole between two adjacent manholes (note that the 
inserted manhole does not have to be on the line joining the two adjacent manholes).

To insert a new manhole, the two adjacent manholes are chosen by selecting the line connecting the two 
manholes. Once the line is selected, the new manhole is assumed to be at the current cursor position. As 
the cursor is moved, the drainage string is redrawn reflecting the changing position of the inserted 
manhole.

The Insert option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Between
The Between option is similar to the Insert option except that the inserted manhole does have to be on the 
line joining the two adjacent manholes. To accomplish this, the cursor position is projected onto the 
manhole-manhole line to give the new manhole position.

Note - once the manhole is placed, it is no longer constrained to be on the one straight or arc joining 
adjacent manholes. If this is required, then the manhole is placed using the Manhole=>Add option.

The Between option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Delete
The Delete option is used to delete manholes/and or points from the drainage string.

The manhole/point to be deleted is selected with the cursor and when the selection is accepted (MB), it is 
deleted.

Once a manhole/point has been deleted, the delete option is still current and can be repeated without re-
selecting the Delete option.

The string, minus the deleted manhole/point, is redrawn after each deletion.

The Delete option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Extend
The Extend option is used to move a manhole/point along the line joining the manhole/point to one of its 
adjacent manhole/point.

That is, the bearing of the manhole/point-manhole/point line is kept constant and the manhole/point moved 
along that line either towards or away from its neighbouring manhole/point.

Extending, like moving a manhole/point, is a two step process.

Step (a) - selecting the manhole/point-manhole/point line and the manhole/point to be moved along that 
line
Step (b) - selecting the final position for the manhole

Both steps are identical to extending an point in a polyline string.

Once the extend is completed, the extend option is still current and can be repeated without re-selecting the 
extend option.

The Extend option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Note - Extend can be used on the end manholes of the drainage string 
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Height
The Height option is used to modify the height (z value) of the top of any manhole, or the height of the 
ends of the pipes connecting adjacent manholes in the drainage string.

The top of the manhole can be selected in either a plan or a section view. The pipe ends can only be 
selected in a section view.

After the Height option is chosen, the user must select the manhole top or pipe end that is going to have its 
height modified.

Once the manhole or pipe end has been selected, an New height typed-input box is displayed on the screen 
with the items current height (z value) in it.

The required height is entered into the typed-input box, terminated with <enter>. The entered value is 
taken as the height of the manhole or pipe and the string redrawn with the new height at that point. The 
typed-input box then disappears.

The Height option is terminated by selecting Quit, Finish, or a new option from the Drainage Edit menu.

Radius

change_radius 
Selecting Radius brings up the Change Radius panel which is used to modify the radius of any arc/line 
joining adjacent manhole points.

After selecting the Radius option, the user selects the arc/straight to be modified and the current arc radius 
and bulge setting will be displayed in the Change Radius panel.

New values can then be entered and the arc modified by selecting the Set button.

If the radius is positive, the arc is drawn from the start point to the next point on the polyline in a clockwise 
direction. If the radius is negative, the arc is drawn from the start point to the next point on the polyline in 
a counter-clockwise direction. 

For a given radius (positive or negative), there are two possible cases for the arc- one where the arc is less 
than a semi-circle, the other when the arc is greater than a semi-circle.

If bulge is turned on, the larger arc is used. The default is bulge turned off.
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Arc with bulge on

Arc with bulge off (default)

Arcs with same radius but  with bulge on or off
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Manhole (Maintenance Hole)

manhole

The options in the Manhole menu are used to modify information about individual manholes in the 
drainage string.

The Manhole walk-right menu is

Add
The add option is similar to the Edits=>Between option in that a new manhole is created that must be on the 
line or arc between two adjacent manholes.

However, once the manhole is placed, it is always constrained to be on the one straight or arc joining its 
adjacent manholes.

To add a new manhole, the two adjacent manholes are chosen by selecting the line connecting the two 
manholes. Once the line is selected, the new manhole is assumed to be at the current cursor position. As 
the cursor is moved, the drainage string is redrawn reflecting the changing position of the inserted 
manhole.

The add option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, or 
a new option from the Drainage Edit menu.

Remove
The Remove option is used to remove manholes from the drainage string but unlike the Edits=>Delete 
option, the underlying point on the drainage string remains. Hence only the manhole is deleted, but not the 
polyline point underneath.

The manhole to be removed is selected with the cursor and when the selection is accepted (MB), it is 
removed.

Once a manhole has been removed, the Remove option is still current and can be repeated without re-
selecting the Remove option.

The string, minus the deleted manhole/point, is redrawn after each removal.

The Remove option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Name
The Name option is used to change a manhole’s label.

After selecting the option, the mouse is used to pick the manhole to have a name change.

Once a manhole has been selected, an Enter text typed-input box is displayed on the screen containing the 
selected manhole’s name.
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The new name is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears.

The Name option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

NOTE - if the name of the manhole is EOL or eol then the diameter of the manhole is forced to zero.

Diameter

The Diameter option is used to change a manhole’s diameter.

After selecting the option, the mouse is used to pick the manhole to have its diameter modified.

Once a manhole has been selected, an Enter value typed-input box is placed on the screen displaying the 
selected manhole’s current diameter.

The new diameter is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears.

The Diameter option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, 
Finish, or a new option from the Drainage Edit menu.

Type

The Type option is used to change the type of the cover (lid) placed on a manhole.

After selecting the option, the mouse is used to pick the manhole to have its cover type modified.

Once a manhole has been selected, a Manhole type typed-input box is displayed on the screen containing 
the selected manhole’s cover type.

The list of common covers for the manhole can be obtained by clicking the [+] in the Manhole type input 
box and getting a menu of valid cover types.

The new cover type is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears.

The Type option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, or 
a new option from the Drainage Edit menu.

Drop

The Drop option is used to change the vertical distance between the bottom of the pipes on either side of a 
manhole, i.e., the difference in the invert levels of the pipe.

Since the drop in simply the difference in vertical distance between two pipes on either side of a manhole, 
the actual value of the drop can be changed by moving either of the pipes up or down the manhole.
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After selecting the option, the end of the pipe to be moved is selected with the mouse.

Once the pipe end been selected, an enter value typed-input box is displayed containing the drop across the 
manhole that the pipe end connects into.

The new drop type is entered into the typed-input box, terminated with <enter>.

If the end of the pipe was on the upstream side of the manhole (normally the right hand side of a manhole 
in a section view), the end of the pipe will be moved upward until the drop across the manhole equals the 
entered value.

If the end of the pipe was on the downstream side of the manhole (normally the left hand side of a manhole 
in a section view), the end of the pipe will be moved down until the drop across the manhole equals the 
entered value.

The typed-input box then disappears.

The Drop option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, or 
a new option from the Drainage Edit menu.

Z Float

manhole_z_float

A floating manhole takes the z-value for the top of the manhole from the tin selected for the drainage 
string. Hence as a floating manhole moves around in a plan view, the top of manhole will automatically 
change to suit the new z-value of the drainage string tin.

Selecting Z float brings up the Manhole Z Float panel which is used to change a manhole from floating to 
non-floating and vice-versa.

After selecting the Z Float option, the user selects the manhole to be modified and the current floating z 
status is displayed in the Manhole Z Float panel.

The tick-cross can then be changed and the manhole modified by then selecting the Set button.

Road Name

manhole_road_name

A road name can be set for a manhole of the line.

Selecting Road name brings up the Manhole Road Name panel which is used to give and change a road 
name for a manhole.
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The option is running as soon as the panel is on the screen and the user is asked to selected a manhole.

<Select manhole> [picks][][Menu]

When the manhole is selected, any existing road name and the manhole number is placed in the road name 
and vertex no. fields respectively of the Manhole Road Name panel.

A new road name is then typed into the road name panel field and the Set button selected to record the 
road name with the manhole.

Road Chainage

manhole_road_chainage

A road chainage can be set for a manhole of the line.

Selecting Road ch brings up the Manhole Road Chainage panel which is used to give and change a road 
chainage for a manhole.

The option is running as soon as the panel is on the screen and the user is asked to selected a manhole.

<Select manhole> [picks][][Menu]

When the manhole is selected, any existing road chainage and the manhole number is placed in the road 
chainage and vertex no. fields respectively of the Manhole Road Chainage panel.

A new road chainage is then typed into the road chainage panel field and the Set button selected to record 
the road chainage with the manhole.

Outfall Height

When a drainage string is created, the furthest downstream is often an outfall and the height of the outfall 
known.

When the furthest downstream manhole is considered to be an outfall, the Outfall ht option is used to set 
and change the outfall height. Once set, the outfall height is taken to be the height at the bottom of the 
furthest downstream manhole.

If this option is not used, the outfall height is left undefined.

After selecting the option, an enter value typed-input box is displayed on the screen containing the existing 
outfall height or null if no outfall height has been set.

The new outfall height is entered into the typed-input box, terminated with <enter>.
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The height of the bottom of the furthest downstream manhole in the drainage string is then set to the given 
height and the typed-input box removed.

The Outfall ht option automatically terminates after use.

Note:

For a drainage string with flow direction in ascending chainage, the furthest downstream manhole is the 
last manhole.

For a drainage string with flow direction in descending chainage, the furthest downstream manhole is the 
first manhole.

the Outfall height

the outfall height

flow direction in
ascending chainage

flow direction in
descending chainage

last pit or manhole

first pit or manhole
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Pipe

pipe

The options in the Pipe menu are used to modify information about the pipes joining adjacent manholes in 
the drainage string.

The Pipe walk-right menu is

Move

The Move option is used to move a pipe connecting two manholes whilst keeping the grade of the pipe 
constant.

After selecting the option, the mouse is used to pick the pipe to be moved.

Once a pipe has been selected, the pipe will be moved up or down so that the cursor remains on the pipe (or 
on the extension of the pipe if the cursor is on the other side of the manholes at either end of the pipe). The 
grade of the pipe is kept constant.

The manholes at either end of the pipe will also be extended if necessary so that the pipe still connects into 
the adjacent manholes.

The Move option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, or 
a new option from the Drainage Edit menu.

Name

The Name option is used to change a pipe’s label.

After selecting the option, the mouse is used to pick the pipe to have a name change.

Once a pipe has been selected, an Enter text typed-input box is displayed on the screen containing the 
selected pipe’s name.

The new name is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears.

The Name option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Cover

The Cover option is used to place the selected pipe so that minimum cover is maintained along the top of 
the pipe (obvert) with respect to the finished surface tin (tin (fs)).

After selecting the option, the pipe to set the cover for is selected with the mouse.

Once a pipe has been selected, an Enter value typed-input box is displayed on the screen containing the 
existing cover.
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The new cover is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears and the pipe is adjusted so that the specified cover is maintained for the full length of the pipe at 
the pipes existing grade.

The Cover option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Diameter

The Diameter option is used to change a drainage pipe’s diameter.

After selecting the option, the mouse is used to pick the pipe to be modified.

Once a drainage pipe has been selected, an Enter value typed-input box is placed on the screen displaying 
the selected pipe’s current diameter.

The new diameter is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears

The Diameter option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, 
Finish, or a new option from the Drainage Edit menu.

Type

The Type option is used to change the type of material that the pipe is made of.

After selecting the option, the mouse is used to pick the pipe to have its material type modified.

Once a pipe has been selected, a Pipe type typed-input box is placed on the screen displaying the selected 
pipes material type.

The list of common materials for the pipe can be obtained by clicking B3 in the type input box and getting 
a menu of valid material types.

The new material type is entered into the typed-input box, terminated with <enter>. The typed-input box 
then disappears.

The Type option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, or 
a new option from the Drainage Edit menu.

Grade

The Grade option is used to specify an exact grade for a drainage pipe. The value for the grade is entered 
using typed input and is in the units "1v in".

In this option, the new grade is given to a pipe by keeping one end fixed and raising or lowering the other 
end by the amount required to give the pipe the new grade.

After the Grade option is selected, the pipe whose grade is to be modified is selected at the end that is 
going to be moved.

Once the pipe end has been selected, an enter value typed-input box is displayed on the screen containing 
the current grade of the pipe. The new grade is entered into the typed-input box, terminated with <enter>.

The selected end of the drainage pipe is then moved up or down so that the pipe has the new grade.
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If necessary, the manhole at the moved end of the pipe will be lengthened so that the pipe still connects 
into the adjacent manholes.

The Grade option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Grade to End

The Grade to end option is used to specify a fixed grade for all the drainage pipes from a selected pipe to 
the low chainage end (beginning) of the line. That is, it grades from right to left on a long section of the 
drainage string.

The value for the grade is entered using typed input and is in the units "1v in".

This option was originally written for pipes with flow direction in descending chainage direction which is 
the reason why it works from the selected pipe back towards the beginning of the line.

Hence Grade to end should only be run on pipes with flow in descending chainage direction. If the flow is 
in ascending chainage direction, use the reverse string option (string=>strings edit=>reverse) before using 
this option, and then reverse the string again after the option is run. Note that the Default grading option 
looks at maintaining minimum grade and minimum cover for flow in either ascending or descending 
chainage direction and supersedes Grade to end.

In this option, the new grade is given to a pipe by keeping the high chainage end of the selected pipe fixed 
and raising or lowering the low chainage end by the amount required to give the pipe the new grade. The 
minimum cover is over ridden during this process. If necessary, the bottom of the manhole will be lowered 
so that the pipe still connects into its adjacent manholes.

The next lower chainage pipe is then dropped through the default drop and given the new grade. The drop 
is measured from the lowest pipe invert of all pipes in the network entering the manhole.

This process is repeated until the low chainage end (beginning) of the line is reached.

After the Grade to end option is selected, the first pipe whose grade is to be modified is selected.

Once the pipe end has been selected, an enter value typed-input box is displayed on the screen containing 
the current grade of the selected pipe. The new grade is entered into the typed-input box, terminated with 
<enter>. The option then does the grading.

The Grade to end option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, 
Finish, or a new option from the Drainage Edit menu.

Default Grading

default_grading

The Default grading option starts at the given pipe and then works to the end of the line when the flow 
direction is in ascending chainage, or the beginning of the line when the flow direction is in descending 
chainage. The Default grading option maintains minimum grade and minimum cover.

Default grading is not designed to optimise the placement of the pipes but provides one solution preserving 
minimum grade and cover.
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Property Controls

controls

Property, block or lot controls are trial connections from a sewer line (drainage string) to a user specified 
plan point.

The property controls are used as checks that selected house blocks can be serviced by the sewer line. That 
is, they are used to test if the house block is under the control of the sewer line.

For the trial connection, once the cover (measured from the finished surface to the top of the property 
connection line) that the property connection must maintain and the grade are specified, the position and 
depth that the trial property connection must have at the sewer line can be calculated, and where the height 
of the centre line of the property control when it reaches the sewer line is displayed in any section view 
containing a profile of the sewer line.

If the calculated depth of the trial property connection at the sewer line (drainage string) is below the sewer 
pipe, then no such connection would be feasible and the house block would not be totally controlled by the 
sewer line.

On a section view, the Profile =>One substring and Profile =>Many substrings options will profile the 
property control. Note that the centre line (axis) of the property control is drawn on the section view, not 
the invert (bottom) or the obvert (top).

NOTE - property controls are only accessible by the Sewer module.

The options in the Controls menu are used to place and modify the trial connections. The Controls walk-
right menu is

Add

The Add option is used to create a new trial control line going from a selected drainage pipe to a user 
specified plan position (the free end of the connection).

After selecting the option, the mouse is used to pick the plan position of the connection point on the 
drainage pipe, and then the points defining the path to the plan position of the free end of the trial 
connection.

After the free end has been selected, the property name typed-input box is displayed on the screen so that a 
label for the control can be entered (this usually consists of the lot number).

When the property name box is placed on the screen, it will already have some text in it. This text comes 
from the name field in the Drainage Property Control Defaults panel.

A z-value equal to the drainage tin value minus the default control cover depth is automatically given to 
the free end of the control. The default control grade is then used to define z-values along the trial path 
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(ensuring that the default control cover depth is always observed) to give a z-value back at the drainage 
pipe (the connection height of the control).

A cross at the calculated connection height is displayed whenever the drainage string is profiled on a 
section view.

The colour for the new control is taken from the Drainage Property Control Defaults panel.

The Add option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, or 
a new option from the Drainage Edit menu.

Include

The Include option is used to make a control out of an existing polyline string.

The polyline string must start at the connection point on the drainage string and end at the free end (use 
Strings=>Strings Edit=>Reverse if the string’s direction is incorrect).

After selecting the option, the mouse is used to pick the polyline string and its plan position is copied and 
used to define a new control.

A z-value equal to the default drainage tin at that point, minus the default control cover depth is 
automatically given to the free end of the new control. The default control grade is then used to define z-
values along the trial path (ensuring that the default control cover depth is always observed) to give a z-
value back at the drainage pipe.

The Include option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Delete

The Delete option is used to delete a control.

After selecting the option, the mouse is used to pick the block control to be deleted.

Once a block control has been selected, it will deleted and removed from the screen.

The Delete option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Name

The Name option is used to change the Property name of a control.

After selecting the option, the mouse is used to pick the control that will have a name change.

Once a control has been selected, an enter text typed- input box is displayed on the screen containing the 
selected control's name.

The new name is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears.

The Name option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Diameter

The Diameter option is used to change the diameter of a control.

After selecting the option, the mouse is used to pick the control that will have its diameter modified.

Once a control has been selected, an Enter value typed- input box is placed on the screen displaying the 
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selected control’s current diameter.

The new diameter is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears.

The Diameter option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, 
Finish, or a new option from the Drainage Edit menu.

Cover

The Cover option is used to change the distance that the control is below the tin (fs) for the drainage string.

After selecting the option, the cursor is used to pick the control whose cover will be modified.

Once a control has been selected, an Enter value typed- input box is placed on the screen displaying the 
selected block control’s current cover.

The new cover is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears and the new connection height using the new cover calculated. 

The Cover option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Grade

The Grade option is used to change the grade of a control (units "1v in").

After selecting the option, the mouse is used to pick the control whose grade will be modified.

Once a control has been selected, an enter value typed- input box is placed on the screen displaying the 
selected control’s grade.

The new grade is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears and the new connection height using the new grade calculated.

The Grade option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, Finish, 
or a new option from the Drainage Edit menu.

Boundary

The Boundary option is used to specify a boundary trap depth which is used as a final drop at the drainage 
pipe end of the control.

After selecting the option, the mouse is used to pick the control whose boundary depth will be modified.

Once a control has been selected, an Enter value typed- input box is placed on the screen displaying the 
selected boundary depth.

The new boundary trap depth is entered into the typed-input box, terminated with <enter>. The typed-input 
box then disappears and the new connection height using the new boundary trap depth is calculated.

The Boundary option is terminated by selecting Cancel from the Pick Ops menu, or by selecting Quit, 
Finish, or a new option from the Drainage Edit menu.

Calc all

The Calc all option is used to re-calculate the connection heights for all controls of the drainage line.

The calculation uses the plan layout of the control, the control’s cover, grade and boundary trap depth and 
the default tin for the drainage line.
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The Calc bc’s option automatically terminates after use.

Delete All
The Delete all option is used to remove all the controls defined for the drainage line being edited.

The Delete all option automatically terminates after use.
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House Connections

connections

The Connections option is used to create the connections from the sewer line (drainage string) to the house 
blocks in a subdivision.

When placing a house connection, the user indicates the two corners of the frontage of the block to allow 
the cross-fall of the block to be calculated and allow the frontage to be used in positioning the house 
connection.

When placing house connections, a section view is used to automatically display the connection to 
facilitate checking the type of connection used and any obstructions that may need to be avoided.

NOTES

1. House connections are only accessible by the Sewer module.

2. All house connection calculations do not take into account any thickness of pipe, joint sizes or actual 
entry points into the sewer. Hence they are approximate only and should only ever be used as a guide. 
Any quantities calculations should allow for a suitable margin of error.

The Connections walk-right menu is

The process for creating a house connection will now be described in detail.

Create from Controls

default_house_connections__drainage__drainage_

The Create from Controls option is used to create a new house connection from existing controls.

or modify an existing house connection.

After selecting the Create from Controls option, the Default House Connections panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mode input update all remove existing first,
update new, update all

if remove existing first, all the existing connections are deleted before new ones are created from the 
controls.
if update new, connections are only created from controls with names different from any existing 
connection.
if update all, connections are created from all controls.
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Factor of safety input 0.15

the connection height for the control is adjust by this depth from the control connection depth.

Create button

after selecting Create, the connections are created from the selected controls.
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Create/Edit

house_connections_edit_panel

The Create/edit option is used to create a new house connection or modify an existing house connection.

After selecting the Create/edit option, the House Connections panel is displayed.

The process for creating a house connection will now be described in detail.

Creating A House Connection

Step 1 Select Create

To create a new house connection, the Create button is selected from the House Connections menu.

drainage_house_connection_basic_defaullts

If either the default drainage tin or section view have not be defined, the Drainage House Connec-
tion Basic Defaults panel will be placed on the screen after the Create button is selected.

The missing values need to be filled in and the Set selected. This information is needed so that the 
house connections can be drawn up in a section view as soon as they are created.

pipe
flow

frontage points
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Step 2 Selecting the Sewer (drainage) Pipe to Connect to

The user is then asked to select the sewer pipe to connect into.

Step 3 Selecting the House Lot Frontage

Next the user indicates the two frontage points for the house block.

Step 4 Positioning the House Connection on the Sewer Pipe

From the two frontage points and the default drainage tin, the program calculates the crossfall for the 
block frontage.

The crossfall is displayed in the name of the enter distance up line typed-input box which is now placed 
on the screen. The distance up line is the distance along the frontage that the house connection will be 
placed.

crossfall_enter_distance_up_line

pipe
flow

Block to create house
connection for

Step 2 pick this sewer pipe to connect to

pipe
flow Step 3 pick the position of

the two frontage points of
the lot
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Depending on the crossfall, a default value for the distance up line is displayed. If the ground crossfall 
is greater than 1% the lot mid point is the suggested connection location. For crossfalls less than 1%, 
the connection is located 3m off the lowest lot boundary. 

A pop-up also exists for placing the connection point at the distance 2.0, 3.0, 5.0 along the frontage, the 
mid point of the frontage, and the distances 2.0, 3.0 and 5.0 from the other end of the frontage.

The distance up line value is entered into the typed-input box, terminated with <enter>. The typed-
input box is then removed from the screen.

Step 5 Defining the House Connection Type

house_connection_edit__drain
Next the House Connection Edit panel is placed on the screen.

Most of the values in the field come from the drainage house connection defaults.

pipe
flow

Step 4 distance up line

Chainage up line is the
chainage on the sewer string
of the house connection point

House connection
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Chainage up line input/output chainage of connection

the chainage on the sewer string where the house connection is attached to the sewer line.

Lot name input from drainage defaults

name of the house block

HCB # input

a user supplied house connection branch (HCB) number

Material input               from drainage defaults PVC, PVC X/HEAVY, VC

the material used for the house connection.

Bush required input no bush no bush, PVC to VC

the type of bush used

Connection type input               from drainage defaults A, A Special, B, C,
OB, Special jump up

the type of connection used. Go to the section “House Connection Types” for a description of each 
connection type

Connection side input right side right side, left side

the side of the line to make the connection

Connection length input from drainage defaults

length of pipe for the house connection

Connection level input calculated

height of the house connection. When this is first displayed, it is calculated using the invert level of the 
sewer pipe where the house connection is attached, the house connection type and connection length (if 
required by the house connection type), the default house connection grade, the default house 
connection cover and the surface level at the end of the house connection.

Try button

using the parameters in the panel fields, create the house connection. Also calculate a section along the 
house connection and draw it in the drainage default section view.

Finish button

end the option, remove the panel.

Step 5 Continued

After entering the appropriate values in the House Connection Edit panel and then selecting the Try 
button, the house connection will created.

To help check the house connection parameters, a section along the house connection will automati-
cally be calculated and displayed in the section view given in the drainage defaults panel. Any tins or 
models on the section view will be included in the section.

Step 6 Modifying the Connection

If any of the fields in the House Connection Edit panel are changed, selecting the Try button will 
modify the house connection and redraw the section in the default drainage section view.

Editing A House Connection
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To edit an existing house connection, the Edit button is selected from the House Connections menu and 
then the appropriate house connection selected.

The House Connection Edit panel will then be placed on the screen with the details of the selected 
house connection.

If any of the fields in the House Connection Edit panel are changed, the Try is used button to modify 
the house connection and redraw the section in the default drainage section view.

Delete

The Delete option is used to delete a connection.

After selecting the option, the mouse is used to pick the house connection to be deleted.

Once a house connection has been selected and accepted, it is deleted and removed from the screen.

The Delete option is terminated by selecting Cancel from the Pick Ops menu, by selecting a new option 
from the Drainage Edit menu.

Delete all

The Delete all option is used to delete all connections.

After selecting the option, all the connections are deleted and the option terminates.
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Utilities

drainage_utilities

The options in the Utilities menu are used to modify default drainage tin, the name, colour, style and start 
chainage of the drainage string, and the size, angle, and offsets used when displaying the text for the names 
of all the manholes.

The Drainage Utilities walk-right menu is

Tin (fs)

FS_tin_for_drainage

The Tin (fs) option changes the default finished surface tin (tin (fs)) for the drainage string.

After selecting the option, the FS Tin for Drainage panel is displayed.

The existing default tin is displayed in the tin panel field. If a new tin is required, simply enter the new tin 
name into the tin (fs) field and select the Set button.

Tin (ns)

ns_tin_for_drainage

The Tin (ns) option changes the default natural surface tin (tin (ns)) for the drainage string.

After selecting the option, the NS Tin for Drainage panel is displayed.

The existing default tin is displayed in the tin (ns) panel field. If a new tin is required, simply enter the new 
tin name into the tin field and select the Set button.

Angle

The Angle option changes the angle of the text for manhole labels.

After selecting the option, an enter angle typed-input box is displayed on the screen containing the current 
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text angle.

The new angle is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears.

The Angle option then terminates.

Size

The Size option is used to change the size of the text for manhole labels.

After selecting the option, an enter value typed-input box is displayed on the screen containing the current 
text size.

The new size is entered into the typed-input box, terminated with <enter>. The typed-input box then 
disappears.

The Size option then terminates.

Properties

drainage_string_properties

The Properties option brings up the Drainage String Properties panel for the current drainage string.

Any of the data in the panel fields can be modified and then set for the drainage string by selecting the OK 
or Apply button.

Z Float
The status of Z Float is used each time a new manhole is created.

If Z Float is set to tick, then the top of the manhole is set to z float which means that automatically sits on 
the default drainage tin.

If Z Float is not set to tick, then the top of the manhole is given a set z value when it is created.

The z float status of the manhole can be changed after it has been created by using the 
Drainage Edit=>Manhole=>Z Float option.
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Reports
drainage_reports

Position of menu: Design =>Drainage-Sewer=>Reports

Reports menu contains an option to report on the property controls for the drainage strings and an option 
produce network quantities.

The Reports walk-right menu is 

For the option Network quantities, please continue to the section “Network Quantities” .

 Network report, please continue to the section “Network Report” .

 Property control, please continue to the section “Property Controls” .

 Barwon quantities, please continue to the section “Barwon Quantities” .

 Barwon HC’s, please continue to the section “Barwon House Connections” .

 Barwon design checks, please continue to the section “Barwon Design Checks” .

 Barwon services reports, please continue to the section “Barwon Services Report” 

Network Quantities
drainage_quantities_panel

The Network quantities report contains information about the manholes and pipes that make up the selected 
drainage strings. Configuration files allow the user to specify the depth ranges and sizes of pipes to report 
on 

On selecting Network quantities, the drainage quantities panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data to check choice box Model Model, View

data source type.

Model/View to check

data source for the drainage strings to process.

Quantities config file file box

file giving the size ranges etc. to report on.

Report file file box

name of the file for the report.

Report unused ranges tick box

if tick, any size ranges given in the config file that have no pipes are reported.

Report types tick box tick

if tick, the manhole types are reported.

Count button

run the option.

Network Report
After selecting the Network report option, the Report on Selected Items panel is displayed.

This is the same as the option Reports =>Co-ord/ Brd-dst on the main menu.

For the given model, it prints out the string information for each string in the model.

If a sewer network model is given, each sewer string in the network model is reported on.
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For further information, go to “Coordinates or Bearing-Distance” .

Property Controls
property_controls_report

Position of menu: Design =>Drainage-Sewer=>Reports=>Property Controls

The property controls report contains information about all the property controls for the selected drainage strings, and 
if required, denote the critical property control for a lot.

On selecting property controls, the property controls report panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type

data source type.

Data source

data source for the drainage strings to process.

Format choice box ascii ascii, excel spread sheet

format for the property control report.

Report file file box

name of the file for the report.

Critical property controls onlytick box tick

if tick, only the critical property controls are reported.

Process button

run the option.

Barwon Quantities
sewer_network_quantities_report

The report generated from this option includes
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s the lengths of each pipe type for each line and the total length for each pipe type for all pipes in the 
network.

s the quantity of concrete used for the manholes in the network.

s the number and type of house connections in the network, including caps, bends and bushes.

After selecting the Barwon quantities option, the Sewer Network Quantities Report panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Network model available models

model containing the sewer strings.

Report file file box

name of the file for the report.

Report button

run the option.

Barwon House Connections
sewer_house_connections_report

Position of menu: Design =>Drainage-Sewer=>Reports=>House connections

The house connections report contains information about all the house connections for the selected drainage 
(sewer) strings.

The house connection report includes for each house connection (branch) the

s name of the sewer line

s downstream manhole for the house connection

s lot name

s house connection number and type

s chainage of the house connection

s the invert level at the end of the house connection (IL branch)

s the invert level of the house connection at the sewer pipe (IL sewer)

s the drop over the house connection (branch depth)

On selecting House connections, the Sewer House Connections Report panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Network model available models

model containing the sewer strings.

Report file file box

name of the file for the report.

Report button

run the option.

Barwon Design Checks
sewer_design_checks_report

The report generated from this option includes the design checks

s network validations (checks that there are strings, no closed loops)

s manholes don’t have negative drops

s other sewer lines connecting in don’t have negative drops

s sewers flows downhill with a minimum grade

s manholes are not too close together (i.e. on top of each other)

s a minimum cover for each sewer line

s block controls are above the pipe invert level

After selecting the Design checks option, the Sewer Design Checks Report panel is displayed

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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Network model available models

model containing the sewer strings.

Tin available tins

tin used for checking minimum cover against.

Report file file box

name of the file for the report.

Report button

run the option.

Barwon Services Report
sewer_services_report

For each sewer string in the network, this option generates a report which includes the 

s section through any tins on the section view

s name and model of any services in the corridor defined by the section view

s co-ordinates and chainages of the parts of the service in the corridor, and the chainage and offset for 
each of the point of the parts projected onto the sewer centre-line.

s clearance at the point where any service goes under or over the sewer string.

After selecting the Services report option, the Sewer Services Report panel is displayed

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Network model available models

model containing the sewer strings.

Section view available section views

section view defining the corridor and service models.

Report file file box

name of the file for the report.

Report button

run the option.
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Drainage Plots
drainage_network_plots

Position of menu: Design =>Drainage-Sewer=>Plots

Currently the Plots menu contains an option to produce a long section including any HGL values, flows 
and user defined attributes read in from other sources, and a second option to output the network to 
Melbourne Water’s sewer format.

The Plots walk-right menu is 

The options Longsections and Melbourne Water will now be described in more detail.

For the option Long sections, please continue to the section “Drainage Longsections” .

 Melbourne Water, please continue to the section “Melbourne Water” .

Drainage Longsections
new_plot_drainage_network drainage_plot_title

Position of menu: Design =>Drainage-Sewer=>Plots=>Longsections

The Longsections option is used to generate the longsection plots for all lines in a drainage network.

Given the plot sheet size and the horizontal and vertical scales, the longsections for the drainage lines are 
plotted starting at the top of the sheet and moving across the sheet. Once one row is full, if there is room 
the plot moves down the page and begins a new row. When a plot sheet is full, a new plot sheet is 
automatically begun.

Hence the drainage lines are plotted one after another on one or more plotter sheets.

The drainage lines are plotted in string name alphabetical order.

The drainage longsection plot includes 

s the manholes, drainage pipe and any house connections

s the height of the finished surface at the manhole

s manhole names and cover types

s distances between manholes

s the invert depth of the pipe on either side of a manhole

s the grades and types of the pipes

s any services in the corridor - including their name, invert level and distance from the nearest down-
stream manhole 

s if the information exists, the velocity, flow, HGL values and diagram

After selecting the longsections option, the new plot drainage network panel is displayed.

The drainage long section plot is tailored by using the plot parameter file (.ppf file) given in the 
plot parameters field. A default .ppf file is set by pointing to it with the environment variable

DRAINAGE_PPF_4D path name of default .ppf file 
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In the path name to the default .ppf file, $LIB is used to stand for the library folder set by LIB_4D. For 
example, "$LIB/drainage.ppf" is the file drainage.ppf in the library area.

The title button on the bottom of this panel controls the use of a title block file and the plotting of a border 
and two lines of title. If the title button is selected, the drainage plot title panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Plot parameters input *.ppf

file of plot parameters used for extra control of the long section plot.

Plotter type input hp model, windows, hp, dxf,
 postscript etc.

format for the plot output.

Network model input

the model containing all the drainage lines for the network.

Section view input

the section view to be used to define the vertical exaggeration, corridor widths, tins to section through, 
services models to section etc.

Plot file stem input

since more than one plot page may be produced, the plot file names are constructed from the stem plus 
a plot page sequence number, followed by the appropriate plotter type ending.

Scale 1: input
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horizontal scale for plotting the drainage long section. The vertical exaggeration is taken from the 
section view given in the section view field.

Sheet size wd ht (mm) input available sheet sizes

the width and height values (separated by space) or the name of a user defined sheet size.

X origin (mm) input

the x position on the plot sheet for the bottom left hand corner of the longsection plots. Same as 
left_margin in the plot parameter file.

Y origin (mm) input

the y position on the plot sheet for the bottom left hand corner of the longsection plots. Same as 
bottom_margin in the plot parameter file.

Text style input 1 available text styles

the default text style to use in the longsection plot.

Plot ht (mm) input

the maximum allowable height for a longsection plot for a drainage line. Datum breaks are applied to 
any part of the longsection that will not fit into the plot ht

Box text size (mm) input 3

size (in millimetres) to plot the chainages, heights etc. in the boxes in the plots of the drainage 
longsections

Box colour input cyan available colours

colour used for the text and the boxes.

Velocity tick-cross tick

if tick, the velocity values for the pipes are drawn on the longsection plot.

Flow tick-cross tick

if tick, the flow values for the pipes are drawn on the longsection plot.

Centre CH. tick-cross tick

if tick, the road centre line chainages are drawn on the longsection plot.

HGL vals tick-cross tick

if tick, the HGL values for the pipes are drawn on the longsection plot.

HGL diag tick-cross tick

if tick, lines joining the HGL values for the pipes are drawn on the longsection plot.

Drain No. tick-cross tick

if tick, the drainage line names are drawn on the longsection plot.

Plot button

plot the drainage longsections for the drainage lines in the model given in the network model field.

The fields and buttons in the title tab are 

Use title file tick-cross

if tick, a user defined title block file is used.

Standard Title tick-cross tick

if tick, the standard 12d Model border and two lines of title are placed on the bottom of the plot

Title file input *.tf
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if non-blank and use title file is set to tick, then the file given in this field is used to generate a user 
defined title block for the plot.

Title line 1/2 input

first/second line of title information

Title height (mm) input 5

height (in millimetres) to draw the characters in the two lines of title information.

Title colour input cyan available colours

colour used for the border and the title information.

Please continue to the next section “Drainage Longsection Plot Parameter File” .

Drainage Longsection Plot Parameter File

The Longsections plot option is used to make special long section plots for a network of drainage strings.

Some of the look of the drainage long section plot can be controlled from the plot drainage network 
panel itself, however a wider selection of control parameters is available by using a drainage long plot, plot 
parameter file.

The drainage long section plot parameters are placed in a file with ending.ppf.

Each parameter consists of a parameter name followed by one or more spaces and then the parameter 
value. There is only one parameter per line.

Anything on a line after a double forward slash // is considered to be a comment.

The set of all parameters for the drainage long section plot is enclosed within a set of curly brackets { } 
with the header

drainage_long_plot    "plot set name"

before the curly brackets.

That is,

drainage_long_plot   "plot set name"   {

plot parameters
one per line

}

If there is more than one drainage_long_plot parameter set in the file, only the first set is used.

There may also be parameter sets for other plot types such as section_x_plot in the same file. The other sets 
will be ignored when doing a drainage long section plot.

The plot parameters are documented in following groups: 

For the Plot Sheet layout, please continue to the section “Plot Sheet Layout” .

Labelling the drainage string name, please continue to the section “Labelling the Drainage String 
Name on the Plot” .

Boxes area, please continue to the section “Boxes Area” .

Chainages and uprights, please continue to the section “Chainages and Uprights” .

Staggering, please continue to the section “Staggering of Chainages and Uprights” .

Below datum area, please continue to the section “Below Datum Area” .

Arrows area, please continue to the section “Arrow Areas” .

Grade arrows parameters, please continue to the section “Parameters for the Arrows for Grades of the 
Pipes” .

Pipe diameter arrows parameters, please continue to the section “Parameters for the Arrows for 
Diameters of the Pipes” .
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Pipe velocity arrows parameters, please continue to the section “Parameters for the Arrows for 
Velocity in the Pipes” .

Pipe flow arrows parameters, please continue to the section “Parameters for the Arrows for Flow in 
the Pipes” .

Drainage line name arrows parameters, please continue to the section “Parameters for the Arrows 
giving the Drainage Line Name” .

User defined pipe arrows parameters, please continue to the section “Parameters for the Arrows for 
User Defined Pipe Attributes” .

Graph area parameters, please continue to the section “Graph Area” .

Top area parameters, please continue to the section “Top Area” .

Bubbles area parameters, please continue to the section “Manhole name, Manhole Types and 
Surrounding Bubbles” .

Change of direction parameters, please continue to the section “Change of Direction Through Pits and 
Junctions” .

Symbols at manhole parameters, please continue to the section “Symbols at Manholes” .

House connection parameters, please continue to the section “Labelling House Connections” 

Symbols at Property controls parameters, please continue to the section “Symbols at Property 
Controls” .

Property controls parameters, please continue to the section “Labelling Property Controls” .

Hatching cut and fill parameters, please continue to the section “Hatching Cut and Fill Areas” .

Labelling cuts parameters, please continue to the section “Labelling Cuts of Drainage Through 
Strings in a Model” .

Title block parameters, please continue to the section “Title Block Information” .

Panel modifying parameters, please continue to the section “Parameters that Modify Fields In the Plot 
Drainage Network Panel” .

Plot Sheet Layout

The plot sheet is considered to have only positive co-ordinates with the origin (0,0) in the left hand corner. 
The units for the plot are millimetres.

The overall size of the plot sheet is given by either a defined sheet size, or by the width and height of the 
plot given in millimetres and separated by one or more spaces.

sheet_size text // sheet name, or
"mm  mm" // sheet size: width height

The sheet size name and width and heights can be specified by the user in a file named sheets.4d which is 
in the normal set up areas, or is pointed to by the environment variable

SHEET_SIZES_4D file // file of plotter sheets sizes

The plotting area is restricted to within the plot sheet by giving the margins

left_margin mm
right_margin mm
top_margin mm
bottom_margin mm

The drainage long section plot will break an individual plot up if it doesn't fit across the sheet. There can be 
one or more rows of plot on the same sheet.

The top row is done first, followed by the second top row, then the third and so on until the bottom row. If 
there is only one row, it is considered to be the bottom row.

When a sheet is full, a follow on sheet is created.

As soon as one drainage string is completed, the next drainage string in the network model is plotted 
beginning on the same row as the previous drainage string and with a horizontal gap of size 
horizontal_plot_gap between the plots. If there is not enough room on the row to start the next plot, it will 
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begin on a new row.

The position of the left hand bottom corner of the first plot in the bottom row is given by the parameters, 
x_origin and y_origin which are the same as left_margin and bottom_margin respectively.

If there are two or more rows of plots, the position of the first plot in each row is given by adding multiples 
of the plot_height to the y_origin (bottom_margin).

network_model text // model of drainage strings

x_origin mm // Position of the left hand bottom,
// same as left_margin.

y_origin mm // corner of first plot in the bottom row,
// same as bottom_margin.

only_one_line 0 // more than one row on a sheet
1 // only one row of plot on a sheet

plot_height mm // total height of a plot row.
// It includes the vertical_plot_gap.

horizontal_plot_gap mm // gap between plots on same row
vertical_plot_gap mm // gap between rows of plots,

// also the size of the top area

The drainage long plot itself consists of eleven areas. From the bottom up, they are

drainage string name, boxes, below datum, arrow 1, bottom stagger, arrow 2, graph, arrow 3, top stagger, 
arrow 4, top.

The drainage string name area is where the name of the drainage string can be plotted.

The boxes area is where the chainages and various values for the drainage strings are labelled.

The below datum area is a region between the boxes area and the datum line.
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The arrow 1 area is for drawing arrows where the arrows go between the staggered uprights and below 
the graph area. The datum line is at the bottom of the arrow 1 area.

The bottom stagger area is where the upright line staggers occur before going up from the boxes area to 
the graph area.

The arrow 2 area is for drawing arrows below the graph but where the arrows go between non-staggered 
uprights.

The graph area is the area where the actual plots of the strings are drawn.

The arrow 3 area is for drawing arrows above the graph area and where the arrows go between non-
staggered uprights.

The top stagger area is where the upright line staggers occur above the graph area.

The arrow 4 area is for drawing arrows where the arrows go between the staggered uprights and above the 
graph area.

The top area is an annotation area above the arrow 4 area and is used for bubbles, manhole names (pit 
names), junctions, deflection angles etc.

The areas and the information in them will now be described in more detail.

drainage long section plot

boxes area

below datum area
arrow area 1
bottom stagger area
arrow area 2

graph area

arrow area 3
top stagger area

arrow area 4
top area

title
area

drainage string name area

values
area

Line B
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Labelling the Drainage String Name on the Plot

The plot can be labelled with the name of the drainage string under the boxes area.

The name is made up of concatenation the text strings:

plot_name_pre_text           drainage-string-name              plot_name_post_text

The plot name is positioned under the boxes.

plot_name_mode 0 // don’t use the drainage string name
1 // use the drainage string name in the

// label
plot_name_pre_text text
plot_name_post_text text
plot_name_textstyle textstyle
plot_name_text_size mm
plot_name_text_colour colour
plot_name_x mm
plot_name_y mm

The plot_name_x is measured from the beginning of the height boxes.

The default for plot_name_x is centred on the values area.

The plot_name_y is measured from the bottom of the box area with positive being down.

Example of Labelling Drainage String Name

 plot_name_pre_text      “Drainage Long Section Plot for String”
plot_name_mode 1
plot_name_post_text  “”
plot_name_text_size 15
plot_name_text_colour red
plot_name_textstyle ISO
plot_name_y 30

labelling drainage string name on drainage long section plots

plot_name_x

plot_name_y
plot name text

values areatitle area
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Boxes Area

Many of the drainage string values (invert levels and depth, hgl values, natural and finished surface etc.) 
can be labelled in the boxes area at the bottom of the drainage long section plot.

 Each type of information is plotter in a row made up of a title, and the actual values given at the chainage 
of each pit in the drainage string.

Each row of information is surrounded by lines to form a box, and the stacked boxes form the boxes area at 
the bottom of the drainage plot.

The title for the information, is drawn in the title area of the boxes area and the values are drawn in the 
values area of the boxes area.

Consequently the boxes area is made up of rows of text consisting of:

title followed by the values along the drainage string.

The titles area for the left plot in the bottom row starts at the co-ordinate (x_origin,y_origin) and each row 
is begun by adding the distance plot_height to the y_origin (see previous section).

The width of the title area is given by the box_width parameter and the height of each box is given by 
box_height.

box_width mm // width of the label boxes.
box_height mm // height of each box

The colour of the box line work is given by:

box_colour colour // colour of the lines in the boxes

A default text size and colour can be specified for the title text and the values, or sizes, colours and text 
styles can be given for each individual box (given later in this section).

title_box_text_size mm // size of title text in boxes
title_box_text_colour colour // colour of title text in boxes
box_text_size mm // size of value text in boxes
box_text_colour colour // colour of values in boxes

The values text is written at right angles to the bottom of the boxes. It can be either top or bottom justified 
with respect to the box (box_text_left_justify).

The values text can be on the left, right or centred on the uprights and is given by the parameter 
box_text_side.

The width of the values area is determined by the number of chainages to be labelled and whether the 
values are staggered to prevent over writing (see next section).

boxes area of a drainage long section plotbox_width
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box_text_left_justify 0 // top justify text in values area
1 // bottom justify text in values area 

box_text_side 0 // left (default)
1 // right
2 // centre

The default order of the boxes from the bottom up is

0. drainage string chainages

1. road centre line chainages - user choice

2. natural surface heights - user choice

3. finished surface heights - user choice

4. before pit and after pit invert levels

5. before pit and after pit hgl values - user choice

6. before pit and after pit depth to inverts - user choice

There are parameters to change the order for 1-6.
Drainage string chainages is fixed at the bottom (box 0) but what is in the boxes above box 0 is can be set 
by the box_n parameters:

box_n number_from_list // the n’th box above the drainage string
// chainages will contain given item number
// form the list. 

For example, to have finished surface heights in the first box the drainage string chainages, use:

box_1 3 // the (1) will be replaced by (3)

chainage_box_size mm // box height for chainage box 
centre_chainage_box_size mm // box height for centre chainage box
surface_box_size mm) // box height for surface box
f_surface_box_size mm // box height for finished surface box
invert_height_box_size mm // box height for invert height box
hgl_box_size mm // box height for hgl box
invert_depth_box_size mm // box height for invert depth box

The default for each box size is box_height

The boxes (1), (2), (3) and (5) can be suppressed by the parameters

draw_centre_chainage 0/1 // 0 = don't have centre line chainages

drainage long section plot
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area
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natural surface title
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//        box
draw_ns_text 0/1 // 0 = don’t draw ns values from

//       ns tin for drainage string
draw_fs_text 0/1 // 0 = don’t draw fs values from

//        fs tin or top of manhole 
//        for drainage string

draw_fs_mode 0 // 0 = fs_text is from fs tin
1 // 1 = fs_text is top of manhole 

draw_hgl_value 0/1 // 0 = don’t have hgl value boxes

The definition of depth to invert and whether box (6) is suppressed or not, are given by the parameter 
depth_mode:

depth_mode 0 //don’t draw depth to invert values
1 // draw depth to invert values to fs tin 

// for drainage string
2 // draw depth to invert values to top of 

// manhole for drainage string
3 // draw depth to invert values to ns tin

// for drainage string

The default for the number of decimal places used in the values in the boxes is:

number_of_decimals integer // default number of decimal places

The text, size, colour and textstyle for the title text and values text for each box can be set by

(0) drainage string chainages
plot_title_chainage_name text // first line of title for chainages box
plot_title_chainage_name_2 text // second line of title for chainages box
chainage_title_colour colour // colour of text
chainage_title_text_size mm // size of title in chainage box
chainage_title_textstyle textstyle // textstyle for title in chainage box
chainage_text_colour colour // colour of chainage values
chainage_text_size mm // size of values
chainage_textstyle textstyle // textstyle of values
chainage_decimals integer // number of decimal places in chainage

(1) road centreline chainages
plot_title_centre_chainage_name text // title for road centre

// line chainages box
plot_title_centre_chainage_name_2text // second line of title for road 

// centre line chainages box
chainage_title_colour_cl colour  // colour of text
chainage_title_text_size_cl mm // size of title in cl box
chainage_title_textstyle_cl textstyle // textstyle for title
chainage_text_colour_cl colour // colour of cl values
chainage_text_size_cl mm // size of values
chainage_textstyle_cl textstyle // textstyle of values
chainage_cl_decimals integer // number of decimal places in chainage cl

(2) natural surface values
plot_title_surface_name text // title for the drainage ns values box
plot_title_surface_name_2 text // second line of title for drainage ns values
ns_title_colour colour // colour of text
ns_title_text_size mm // size of title in ns box
ns_title_textstyle textstyle // textstyle for title
ns_text_colour colour // colour of ns values
ns_text_size mm // size of values
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ns_textstyle textstyle // textstyle of values
ns_decimals integer // number of decimal places in ns

(3) finished surface values
plot_title_finished_name text // title for the drainage fs values box
plot_title_finished_name_2 text // second line of title for drainage fs values 
fs_title_colour colour // colour of text
fs_title_text_size mm // size of title in fs box
fs_title_textstyle textstyle // textstyle for title
fs_text_colour colour // colour of ns values
fs_text_size mm // size of values
fs_textstyle textstyle // textstyle of values
fs_decimals integer // number of decimal place in fs

(4) invert levels
plot_title_invert_name text // title for the invert levels box
plot_title_invert_name_2 text // second line of title for the invert levels box
il_title_colour colour // colour of text
il_title_text_size mm // size of title in il box
il_title_textstyle textstyle // textstyle for title
il_text_colour colour // colour of il values
il_text_size mm // size of values
il_textstyle textstyle // textstyle of values
il_decimals integer // number of decimal places in il

(5) hgl values
plot_title_hgl_name text // title for hgl values box
plot_title_hgl_name_2 text // second line of title for hgl values box
hgl_title_colour colour // colour of text
hgl_title_text_size mm // size of title in hgl box
hgl_title_textstyle textstyle // textstyle for title
hgl_text_colour colour  // colour of hgl values
hgl_text_size mm // size of values
hgl_textstyle textstyle // textstyle of values
hgl_decimals integer // number of decimal places in hgl

(6) depths
plot_title_depth_name text // title for depth of inverts box
plot_title_depth_name_2 text // second line of title for depth of inverts box
depth_title_colour colour // colour of text
depth_title_text_size mm // size of title in depth box
depth_title_textstyle textstyle // textstyle for title
depth_text_colour colour // colour of depth values
depth_text_size mm // size of values
depth_textstyle textstyle // textstyle of values
depth_decimals integer // number of decimal places in depth
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Drawing the Boxes
The bottom line from the boxes can be drawn or not drawn:

chainage_box_mode 0 // don’t draw the bottom line
1 // draw all the box line work - default

A box can be drawn/not drawn around the title area of the boxes area.

draw_box_mode 0 // don’t draw the title area box
1 // draw the title area box, no lines - default
2 // draw title box area with lines

chainage title
road chainages title
natural surface title
finished surface title
inverts level title
hgl title
depths title

values
area

chainage title
road chainages title
natural surface title
finished surface title
inverts level title
hgl title
depths title

values
area

chainage_box_mode = 0

chainage_box_mode = 1

draw_box_mode = 0

draw_box_mode = 1

title area

draw_box_mode = 2

values areatitle area

values areatitle area

values area
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Chainages and Uprights

The chainage box contains drainage string chainages for

(a) the chainages of each pit in the drainage string

(b) the chainages on the drainage string where any strings in models on the section view are cut by the 
drainage string (crossing services)

For a pit, the invert levels, depths, finished and natural surface levels,  and hgl of pipes at a pit can all 
labelled at the chainage of the pit.

For a crossing service, the level of the crossing service and the chainage on the drainage string where the 
crossing occurs are labelled.

Note - crossing services can also be labelled using cuts of drainage line through strings. However, this 
does not create a chainage in the chainage box.

Uprights, or leader lines, can be drawn from the chainage values at the bottom of the boxes to the pit in the 
graph area, and from the top of the pit to the top area.

Using the parameters uprights_top_mode and uprights_bottom_mode, it is possible to suppress the 
drawing from the top of the pit to the top area, and also from the top of the boxes to the bottom of the 
boxes.

uprights_top_mode 0 // stop at top of pit
1 // go to top area (default)

uprights_bottom_mode 0 // stop at top of boxes
1 // go to bottom of boxes (default)

Also uprights can be drawn from the chainage values bottom of the boxes to the crossing service in the graph 
area.

uprights for pits and crossing services

uprights at pit

uprights at
crossing service

uprights_top_mode = 1 uprights_top_mode = 0

uprights_bottom_mode = 0

uprights_bottom_mode = 1
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The chainage values at the uprights  for the pits can be running chainage along the drainage string, pipe 
length chainages (i.e. the chainage starts at zero for each pipe) or both.

chainage_mode 0 //pipe length chainage
1 // running chainage
2 // both pipe length and running

If the chainage_mode includes "pipe length chainage" (modes 0 and 2), the pipe length can either be 
labelled with a 0.0 chainage at the start pit for the pipe and the pipe length at the end pit, or just have the 
length centred between the two pits.

centre_pipe_length 0 // default - 0 at start pit, length at end pit
1 // centre pipe length

The chainage values for the crossing services can be running chainage along the drainage string, chainage 
length from the previous pit (i.e. the chainage starts at zero at the previous pit) or both.

service_chainage_mode 0 //pipe length chainage
1 // running chainage
2 // both pipe length and running

The colour of the uprights for the pits and crossing services are given by:

manhole_line_colour colour // colour of uprights to the pits
service_line_colour colour // colour of upright to the crossing

// services

The crossing services are labelled with the drainage string chainage of the crossing point, the invert level 
of the service at the crossing and the name of the service which is made up of:

service diameter name of service invert level at the service at the crossing.

The service label is drawn the distance service_name_y below the crossing point:

service_name_y mm // def 1, distance of label below crossing point

The colours, text styles and sizes of the service information is specified by:

service_ch_text_colour colour // colour of services ch text
service_ch_text_size mm // size of services ch text
service_ch_textstyle mm // textstyle of services ch text

service_il_text_colour colour // colour of services il text
service_il_text_size mm // size of services il text
service_il_textstyle mm // textstyle of services il text

service_name_text_colour colour // colour of services name
service_name_text_size mm // size of services name
service_name_textstyle mm // textstyle of services name
service_name_decimals integer // number of decimal is il in name

A finished surface value or top of manhole value can also be written vertically along the uprights.
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Whether the value is finished surface level or top of manhole level, the values position, size, colour etc. is 
controlled by the parameters:

draw_fs_vertical 0 // don’t draw fs vertical values
1 // always draw values
2 // only draw values when different -see

// draw_fs_vertical_mode

draw_fs_vertical_mode 0 // the fs value is the value from the fs tin
// for the drainage string.
// When draw_fs_vertical is 1, 
// always draw the fs value.
// When draw_fs_vertical is 2,

 // only draw fs value when it is
// different from the top of manhole value

1 // the fs value is the top of manhole
// for the drainage string.
// When draw_fs_vertical is 1, 
// always draw the fs value.
// When draw_fs_vertical is 2,

 // only draw fs value when it is
// different from the value of the fs tin.

fs_vertical_pre_text text // text before the vertical fs value
fs_vertical_post_text text // text after the vertical fs value
fs_vertical_decimals integer // number of decimals in vertical fs
fs_vertical_colour colour // colour of the vertical fs text 
fs_vertical_size mm // size of the vertical fs text 
fs_vertical_textstyle textstyle // textstyle of the vertical fs
fs_vertical_x mm // x adjustment to position of text
fs_vertical_y mm // y adjustment to position of text
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Staggering of Chainages and Uprights

If the text values are placed at the real chainage positions at the bottom of the plot, text over writing can 
easily occur if the chainages are very close together.

To prevent such over writing, the text can be staggered.

That is, if the text is going to over write a previous text value, the next text value is actually moved along 
until there is no over writing.

Since the text is no longer at the correct chainage position, the uprights to the pits and services start at the 
text position and then bend back to the correct chainage position on the plot. The region where the bending 
occurs is called the stagger area.

For the drainage plot, there is an area below the graph where the uprights bend backwards from the 
staggered text position to the real chainage position (bottom stagger area).

And there is a second area above the graph where the uprights bend forwards from the real chainage 
position to the staggered text position (top stagger area).

Hence annotation above the top stagger area will line up with the staggered values below the bottom 
stagger area.

The stagger area below the graph area is defined by

stagger_height_1 mm // distance from the top of arrow_area_1
// to the start of the staggers

stagger_height_2 mm // distance over which stagger occurs
stagger_gap_bottom mm // distance from end of staggers to the

// bottom of arrow_area_2
The stagger area above the graph area is defined

stagger_gap_top mm // distance from the top of arrow_area_3
// to the start of the staggers

stagger_height_3 mm // distance over which stagger occurs
stagger_height_4 mm // distance from end of staggers to the

// bottom of arrow_area_4
The distance to be left for text to avoid over writing is:

horizontal_text_gap mm // minimum distance to leave for text
// after pit values

service_text_gap mm // minimum distance to leave for text
// after service values

When staggering occurs, it is possible for the values area to be longer than the graph area.
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Below Datum Area

The below datum area is the region between the boxes area and the arrow_1 area. The datum line is 
drawn at the top of the below datum area.

The size of the below datum area is

datum_gap mm // height of the below datum area

The datum value is placed above the datum line, preceded by a datum name on the left hand side of the title 
area.

Since the datum value is automatically calculated to try and fit the plot vertically into the graph area, the 
datum value can change along the plot. When a datum change occurs, the new datum value is written on 
the datum line at the relevant chainage position.

The datum name, text size, colour and position are controlled by:

datum_name text // datum title
datum_title_x mm // distance to write name from lhs
datum_title_y mm // distance above datum line
datum_title_textstyle textstyle // textstyle of name
datum_title_text_size mm // text size
datum_title_colour colour // text colour

The datum value, number of decimal places, text size, colour and position are controlled by:

datum_decimals integer // number of decimal places in datum value
// >0 drop trailing zeros after decimal point
// < 0 keep trailing zeros 

datum_x mm // x dist. to write value from manhole
datum_y mm // y dist. to write value above datum line
datum_text_size mm // size of datum value
datum_textstyle textstyle // textstyle for datum
datum_text_colour colour // colour of the datum text and line

drainage long section plot
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below datum area
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title
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values
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Arrow Areas

Apart from information labelled in the boxes and top areas, the drainage long section plot can place arrows 
between pits for other information such as

(a) pipe grade or slope

(b) pipe diameter

(c) velocity

(d) flow

(e) drainage line name

(f) user defined pipe attributes

A specific arrow area is defined for each set of arrows.

The arrow areas are designed for drawing and labelling arrows between pits.

All the values refer to pipes connecting adjacent pits and the relevant pipe is indicated by drawing an arrow 
between the uprights from the chainage text to the pits.

Because staggering of the chainage text can occur, the position of the uprights to draw the arrows between 
can vary depending on whether the arrow is above or below a stagger area.

Hence, there are four arrow areas:

arrow area 1  which is below the graph and the bottom stagger area. The arrows go between the stag-
gered chainage positions of the pits.

The datum line is at the bottom of  arrow 1 area.

arrow area 2 which below the graph but above the bottom stagger area. Hence the arrows go between 
the non-staggered chainage positions of the pits.

arrow area 3 which is above the graph but below the top stagger area. The arrows go between the non-
staggered chainage positions of the pits.

arrow area 4 is above the graph and the top stagger area. The arrows go between the staggered chain-
age positions of the pits.

The heights of the four areas (which can be zero) are defined by:

arrow_area_1 mm // height of arrow_1 area
arrow_area_2 mm // height of arrow_2 area
arrow_area_3 mm // height of arrow_3 area
arrow_area_4 mm // height of arrow_4 area

boxes area

below datum area

arrow area 1
bottom stagger area

arrow area 2

graph area

arrow area 3
top stagger area

arrow area 4

top area

arrow_area_1

arrow_area_2

arrow_area_3

arrow_area_4
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The parameters for controlling the arrows between manholes and associated text for the values of pipe 
slope, pipe diameter, flow, velocity, drainage line name and user defined pipe attributes are now given. 

Each set of parameters has an arrow_mode with the following values:

..._arrow_mode 0 // no arrow
1 // arrow
2 // line
3 // line with uprights at ends
4 // uprights, no line
5 // line with downrights
6 // downrights, no line
7 // line with up and downrights at ends
8 // up and downrights, no line

0

1

2

3

4

5

6

7

8
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Parameters for the Arrows for Grades of the Pipes

Parameters specifying the arrow area used and the position of the arrows.

draw_pipe_grade 0 // don’t draw pipe grade
1 // draw pipe grade

pipe_grade_arrow_area m // the arrow area for the arrows
// m = 1,2,3 or 4

pipe_grade_y mm // distance that the arrow is above the
// bottom of the arrow area.

For the arrow, the value of the grade can be specified as either 1 in or percent grade:

percentage_grade 0 // the value is a "1 in" grade
1 // the value is a percent grade

Parameters for the title text on the left hand side of the plot:

pipe_grade_title text //title on the left hand side of the arrow
pipe_grade_title_textstyle textstyle // textstyle of the title
pipe_grade_title_text_size mm // size of the title
pipe_grade_title_text_colour colour // colour of the title
pipe_grade_title_offset mm //distance to raise or lower the text

// from the arrow position
pipe_grade_title_x mm // distance from the left hand side of the

// plot
Parameters for the arrow type:

pipe_grade_arrow_mode 0 // no arrow
1 // arrow
2 // line
3 // line with uprights at ends
4 // uprights, no line
5 // line with downrights
6 // downrights, no line
7 // line with up and downrights at ends
8 // up and downrights, no line

pipe_grade_arrow_colour colour // colour of the arrow
pipe_grade_arrow_size mm // height of the arrow
pipe_grade_arrow_gap 0 // no gap in arrow

1 // leave gap in arrow for text
Parameters for the text on the arrow:

pipe_grade_arrow_pre_text text // text before the arrows text
pipe_grade_arrow_post_text text // text after the arrows text
pipe_grade_arrow_decimals integer // The number of decimal places used

// when writing out the pipe grade
// If > 0, all trailing zeros after the
// decimal place are removed.
// If < 0, the absolute value is taken as
// the number of decimal places and no 
// trailing zeros are removed after the
//decimal point.

pipe_grade_arrow_textstyle textstyle // textstyle of arrow text
pipe_grade_arrow_text_size mm // size of the text
pipe_grade_arrow_text_colour colour // colour of the text
pipe_grade_arrow_text_offset mm // distance to raise or lower the text

// from the arrow position
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Parameters for the Arrows for Diameters of the Pipes

The diameter of the drainage pipes can be plotted between each pit.

Inside 12d Model, the pipe diameter is given a world units (usually metres), but on the diameter arrow, the 
diameter is multiplied by 1000 and written out as an integer value. This is normally millimetres.

For diameters entered in feet and the plot diameter to be in inches, the following parameter should be set

pipe_diameter_scale_factor 12. // default is 1000.

Parameters specifying the arrow area used and the position of the pipe diameter arrows.

draw_pipe_diameter 0 // don’t draw pipe diameter
1 // draw pipe diameter

pipe_diameter_arrow_area m // the arrow area for the arrows
// m = 1,2,3 or 4

pipe_diameter_y mm // distance that the arrow is above the
// bottom of the arrow area.

Parameters for the title text on the left hand side of the plot:

pipe_diameter_title text // title on the left hand side of the arrow
pipe_diameter_title_textstyle textstyle // textstyle of the title
pipe_diameter_title_text_size mm // size of the title
pipe_diameter_title_text_colour colour // colour of the title
pipe_diameter_title_offset mm // distance to raise or lower the text

// from the arrow position
pipe_diameter_title_x mm // distance from the left hand side of the

// plot
Parameters for the arrow type:

pipe_diameter_arrow_mode 0 // no arrow
1 // arrow
2 // line
3 // line with uprights at ends
4 // uprights, no line
5 // line with downrights
6 // downrights, no line
7 // line with up and downrights at ends
8 // up and downrights, no line

pipe_diameter_arrow_colour colour // colour of the arrow
pipe_diameter_arrow_size mm // height of the arrow
pipe_diameter_arrow_gap 0 // no gap in arrow

1 // leave gap in arrow for text
Parameters for the text on the arrow:

pipe_diameter_arrow_pre_text text // text before the arrows text
pipe_diameter_arrow_post_text text // text after the arrows text

On the arrow, the pipe type can be also plotted after the pipe_diameter_arrow_post_text:

pipe_type_mode 0 // don’t include the pipe type
1 // include the pipe type after the

// post_text
pipe_diameter_arrow_textstyle textstyle // textstyle of arrow text
pipe_diameter_arrow_text_size mm // size of the text
pipe_diameter_arrow_text_colourcolour // colour of the text
pipe_diameter_arrow_text_offset mm // distance to raise or lower the text

// from the arrow position
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Parameters for the Arrows for Velocity in the Pipes

Parameters specifying the arrow area used and the position of the arrows.

draw_pipe_velocity 0 // don’t draw pipe velocity
1 // draw pipe velocity

pipe_velocity_arrow_area m // the arrow area for the arrows
// m = 1,2,3 or 4

pipe_velocity_y mm // distance that the arrow is above the
// bottom of the arrow area.

Parameters for the title text on the left hand side of the plot:

pipe_velocity_title text //title on the left hand side of the arrow
pipe_velocity_title_textstyle textstyle // textstyle of the title
pipe_velocity_title_text_size mm // size of the title
pipe_velocity_title_text_colour colour // colour of the title
pipe_velocity_title_offset mm //distance to raise or lower the text

// from the arrow position
pipe_velocity_title_x mm // distance from the left hand side of

 // the plot
Parameters for the arrow type:

pipe_velocity_arrow_mode 0 // no arrow
1 // arrow
2 // line
3 // line with uprights at ends
4 // uprights, no line
5 // line with downrights
6 // downrights, no line
7 // line with up and downrights at ends
8 // up and downrights, no line

pipe_velocity_arrow_colour colour // colour of the arrow
pipe_velocity_arrow_size mm // height of the arrow
pipe_velocity_arrow_gap 0 // no gap in arrow

1 // leave gap in arrow for text

Parameters for the text on the arrow:

pipe_velocity_arrow_pre_text text // text before the arrows text
pipe_velocity_arrow_post_text text // text after the arrows text
pipe_velocity_arrow_decimals integer // The number of decimal places used

// when writing out the pipe velocity
// If > 0, all trailing zeros after the
// decimal place are removed.
// If < 0, the absolute value is taken as
// the number of decimal places and no 
// trailing zeros are removed after the
// decimal point.

pipe_velocity_arrow_textstyle textstyle // textstyle of arrow text
pipe_velocity_arrow_text_size mm // size of the text
pipe_velocity_arrow_text_colour colour // colour of the text
pipe_velocity_arrow_text_offset mm // distance to raise or lower the text

// from the arrow position
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Parameters for the Arrows for Flow in the Pipes

Parameters specifying the arrow area used and the position of the arrows.

draw_pipe_flow 0 // don’t draw pipe flow
1 // draw pipe flow

pipe_flow_arrow_area m // the arrow area for the arrows
// m = 1,2,3 or 4

pipe_flow_y mm // distance that the arrow is above the
// bottom of the arrow area.

Parameters for the title text on the left hand side of the plot:

pipe_flow_title text // title on the left hand side of the arrow
pipe_flow_title_textstyle textstyle // textstyle of the title
pipe_flow_title_text_size mm // size of the title
pipe_flow_title_text_colour colour // colour of the title
pipe_flow_title_offset mm // distance to raise or lower the text

// from the arrow position
pipe_flow_title_x mm // distance from the left hand side of

 // the plot
Parameters for the arrow type:

pipe_flow_arrow_mode 0 // no arrow
1 // arrow
2 // line
3 // line with uprights at ends
4 // uprights, no line
5 // line with downrights
6 // downrights, no line
7 // line with up and downrights at ends
8 // up and downrights, no line

pipe_flow_arrow_colour colour // colour of the arrow
pipe_flow_arrow_size mm // height of the arrow
pipe_flow_arrow_gap 0 // no gap in arrow

1 // leave gap in arrow for text
Parameters for the text on the arrow:

pipe_flow_arrow_pre_text text // text before the arrows text
pipe_flow_arrow_post_text text // text after the arrows text
pipe_flow_arrow_decimals integer // The number of decimal places used

// when writing out the pipe flow
// If > 0, all trailing zeros after the
// decimal place are removed.
// If < 0, the absolute value is taken as
// the number of decimal places and no 
// trailing zeros are removed after the
// decimal point.

pipe_flow_arrow_textstyle textstyle // textstyle of arrow text
pipe_flow_arrow_text_size mm // size of the text
pipe_flow_arrow_text_colour colour // colour of the text
pipe_flow_arrow_text_offset mm //distance to raise or lower the text

// from the arrow position
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Parameters for the Arrows giving the Drainage Line Name

Parameters specifying the arrow area used and the position of the arrows.

draw_drainage_line 0 // don’t draw drainage line arrow
1 // draw drainage line arrow

drainage_line_arrow_area m // the arrow area for the arrows
// m = 1,2,3 or 4

drainage_line_y mm // distance that the arrow is above the
// bottom of the arrow area.

Parameters for the title text on the left hand side of the plot:

drainage_line_title text // title on the left hand side of the arrow
drainage_line_title_textstyle textstyle // textstyle of the title
drainage_line_title_text_size mm // size of the title
drainage_line_title_text_colour colour // colour of the title
drainage_line_title_offset mm // distance to raise or lower the text

// from the arrow position
drainage_line_title_x mm // distance from the left hand side of

// the plot
Parameters for the arrow type:

drainage_line_arrow_mode 0 // no arrow
1 // arrow
2 // line
3 // line with uprights at ends
4 // uprights, no line
5 // line with downrights
6 // downrights, no line
7 // line with up and downrights at ends
8 // up and downrights, no line

drainage_line_arrow_colour colour // colour of the arrow
drainage_line_arrow_size mm // height of the arrow
drainage_line_arrow_gap 0 // no gap in arrow

1 // leave gap in arrow for text

Parameters for the text on the arrow:

drainage_line_arrow_pre_text text // text before the arrows text
drainage_line_arrow_post_text text // text after the arrows text

drainage_line_arrow_textstyle textstyle // textstyle of arrow text
drainage_line_arrow_text_size mm // size of the text
drainage_line_arrow_text_colour colour // colour of the text
drainage_line_arrow_text_offset mm // distance to raise or lower the text

// from the arrow position
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Parameters for the Arrows for User Defined Pipe Attributes

There can be up to twenty sets of parameters which are used to define arrows for user defined attributes on 
the pipes.

Each user defined attribute is referred to by a given user name and it is this user name that is specified by 
a parameter and links the set of parameters to the information in the drainage string.

Note: user defined attributes on drainage pipes are usually set by special macros.

The parameters for the n’th set (n=1,2,    20) are:

Parameters specifying the pipe attribute used for this set of arrows and the arrow area used.

draw_pipe_attr_n 0 // don’t draw nth set of arrows
1 // draw the nth set of arrows

pipe_attr_n_name text // the name of the attribute to be labelled
//  on the n’th set of arrows

pipe_attr_n_arrow_area m // the arrow area for the arrows
// m = 1,2,3 or 4

pipe_attr_n_y mm // distance that the arrow is above the
// bottom of the arrow area.

Parameters for the title text on the left hand side of the plot:

pipe_attr_n_title text //title on the left hand side of the arrow
pipe_attr_n_title_textstyle textstyle // textstyle of the nth attribute’s title
pipe_attr_n_title_text_size mm // size of the nth attribute’s title
pipe_attr_n_title_text_colour colour // colour of the nth attribute’s title
pipe_attr_n_title_offset mm //distance to raise or lower the text

// from the nth arrow position
pipe_attr_n_title_x mm // distance from the left hand side of the

// plot

Parameters for the arrow type:

pipe_attr_n_arrow_mode 0 // no arrow
1 // arrow
2 // line
3 // line with uprights at ends
4 // uprights, no line
5 // line with downrights
6 // downrights, no line
7 // line with up and downrights at ends
8 // up and downrights, no line

pipe_attr_n_arrow_colour colour // colour of the nth arrow
pipe_attr_n_arrow_size mm // height of the nth arrow
pipe_attr_n_arrow_gap 0 // no gap in arrow

1 // leave gap in arrow for text
Parameters for the text on the arrow:

pipe_attr_n_arrow_pre_text text // text before the arrows text
pipe_attr_n_arrow_post_text text // text after the arrows text
pipe_attr_n_arrow_decimals integer // Only if the attribute is a real number.

// The number of decimal places used
// when writing out the value of the
// attribute.
// If > 0, all trailing zeros after the
// decimal place are removed.
// If < 0, the absolute value is taken as
// the number of decimal places and no 
// trailing zeros are removed after the
// decimal point.
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pipe_attr_n_arrow_textstyle textstyle // textstyle of arrow text
pipe_attr_n_arrow_text_size mm // size of the text
pipe_attr_n_arrow_text_colour colour // colour of the text
pipe_attr_n_arrow_text_offset mm // distance to raise or lower the text

// form the nth attribute’s arrow position
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Graph Area

The graph area is the area where the actual plots of the drainage strings are drawn.

The length of the graph area is determined by the length of the drainage string to be plotted, the horizontal 
scale (given by scale) of the plot and the sheet width.

scale value // 1:value - horizontal scale
// The vertical scale is determined by the
// horizontal scale and the vertical
// exaggeration for the section view.

The vertical exaggeration is taken from the section view specified for the plot by the parameter:

view_name text

The tins to be sectioned through by the drainage strings and any service models and corridor settings for 
the graph area are also taken from the specified section view.

The height of the graph is calculated by subtracting the height of the other nine boxes from the plot height.

If the plot will not fit horizontally into a row on the sheet, then the plot will be broken at an appropriate pit 
and the plot continued on another row.

Datum breaks at pits are used to try and fit the plot vertically into the graph area but if the plot still cannot 
fit, then it will be truncated at the bottom.

The types of strings that can be drawn in the graph area of the drainage long section plot are:

(a) drainage string the strings from the network model

(b) tins sections of the drainage string through any tins on the
section view.

(c) hgl hydraulic grade line values from the drainage string

(d) services parts of strings from any models on the section view
that cut the corridor for the section view.

Whether to draw the hydraulic grade line is controlled by:

draw_hgl_diag 0/1 // 1 = draw hydraulic grade line

The colour of the strings in the plot is the actual string colour for case (a) and (d), the colour of the tin used 
for the section in case (b) and user specified colour for (c).

hgl_colour colour

drainage long section plot

boxes area

below datum area

arrow area 1
bottom stagger area
arrow area 2

graph area
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Top Area

The top area is an annotation area above the arrow_4_area at the top of the plot.

It can be used for pit names, pit types, line names, junctions and deflection angles through pits.

The height of the top area is given by

vertical_plot_gap mm // size of the top area. If it is not large
// enough, the text will over write the
// plot in the row above.

A line can be drawn at the bottom of the top area:

draw_top_line 0/1 // 1= draw line at bottom of top area
// (i.e. top of arrow_4_area)
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Manhole name, Manhole Types and Surrounding Bubbles

The drainage string name, the manhole name (pit number) and manhole type (pit type) can be drawn on the 
drainage long section plot, with or without a bubble around it.

The bubble text is made up of

line_name / pit_name    pit_type

where the bits actually used are controlled by

draw_line_name 0/1 // 1 = include line name. The "/" is only
// included if the line_name is drawn.

draw_pit_name 0/1 // 1 = include pit_name
draw_pit_type 0/1 // 1 = include pit type

The  size, colour and text style of the bubble text is given by:

bubble_text_size mm // size of text in bubble def angled_text_size
bubble_text_colour colour // colour of text def angled_text_colour
bubble_textstyle textstyle // textstyle for text def angled_text_textstyle
bubble_text_x mm // horizontal distance from the default 

// position (at the pit or in top area)
bubble_text_y mm // vertical distance from the default 

// position (at the pit or in top area) 
bubble_pre_text text // default ""
bubble_post_text text // default ""
bubble_text_angle value // default 0
bubble_text_justify value // the default is centre justified

A bubble is drawn of radius bubble_radius is drawn around the bubble text. 

If bubble_radius is zero, then no bubble is drawn.

If the bubble_radius is zero, the bubble text is still drawn but without the enclosing bubble.

bubble_radius mm // if non-zero a bubble of this radius is
// drawn around the text

bubble_colour colour // colour of bubbles

The "bubble" can be drawn as two semi-circles and two straight lines

bubble_length mm // length of the straight line in between
// the semi-circles

The bubble text (and bubble) can be positioned at the bottom of the top area, or can be placed a fixed 
distance above the top of the corresponding manhole.

If the bubble text is drawn at the bottom of the top area, the upright is automatically drawn up to the bubble 
text.

If the bubble text is drawn above the pit, it is positioned by the distance_above_pit parameter plus the top 
stagger distances, stagger_gap_top, stagger_height_3 and stagger_height_4.

This is necessary because the bubble text may need to be staggered.

draw_text_at_pit 0 // draw bubble and/or text in the top

bubble_radius

bubble_length bubble_length = 0
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// area.
1 // draw it above the pit

distance_above_pit mm // distance to add to the top stagger area 
// heights to draw the bubble above the
// pit.

uprights_top_mode 0/1 // 1 = draw line from pit to bubble. Used to be
// draw_line_to_text
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Change of Direction Through Pits and Junctions

If there is a change of direction of the pipes of the plotted drainage string going through the pit, the 
deflection angle (in degrees, minutes and seconds) is drawn above the bubble text.

The deflection angle text is made up:

angled_pre_text deflection angle angled_post_text

Also any junctions at a pit in the plotted drainage string can be labelled with the name of the drainage 
strings coming into the pit, and the angle of the pipes at the junction.

Hence the junction text is made up of two lines:

junction_pre_text line_name junction_post_text
junction_angle_pre_text junction angle junction_angle_post_text

If bubbles are drawn, the deflection angle and junction name and angle are drawn at the distance 
angled_text_offset above the bubble and with the distance angled_text_gap between the lines of 
information.

If bubbles are not drawn, the bubble text and the deflection angle and junction name and angle is placed 
the distance angled_text_offset above bottom of the top area. Each line of text is separated by the distance 
angled_text_gap.

The deflection angle and junction name and angle are drawn at an angle of angled_text_angle.

angled_text_offset mm // distance of text above bubble text
// or above bottom of top area

angled_text_gap mm // distance between text to the right
// of bubble text.

angled_text_angle value // angle of text

The pre and post text, colour, size and text style for the deflection angle of the drainage string pipes going 
through the pit are controlled by:

angled_pre_text text //  default " "
angled_post_text text // default " "
angled_text_colour colour // colour of deflection angle text
angled_text_size mm // size of deflection angle text
angled_textstyle textstyle // textstyle of deflection angle text
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The junction drainage string name can be included/not included in the first line of junction information:

junction_name_mode 0 // don’t include the junction string name
1 // default - use junction string name

The pre and post text, colour, size and text style for the junction name and the angle that the junction 
makes at the pit are controlled by:

junction_pre_text text // default "JUNCTION "
junction_post_text text // default " "
junction_text_colour colour // colour of junction name text
junction_text_size mm // size of junction name text
junction_textstyle textstyle // textstyle for junction name text
junction_angle_pre_text text // default " "
junction_angle_post_text text // default " "
junction_angle_text_colour colour // colour of junction angle text
junction_angle_text_size mm // size of junction angle text
junction_angle_textstyle textstyle // textstyle for junction angle text
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Symbols at Manholes

Manholes can be labelled with symbols which depend on the manhole type. There can be up to twenty (20) 
sets of manhole symbols.

manhole_symbol_n_type mh_type // manhole type to have symbols
manhole_symbol_n_mode 0 // cross

1 // up from centre of box
2 // up and down from centre of box
3 // square
4 // triangle, base at bottom
5 // circle
6 // use a 12d symbol

manhole_symbol_n_position 1 // at top of manhole - default
 3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

manhole_symbol_n_size mm // size
manhole_symbol_n_x mm // x adjustment to position - default 0
manhole_symbol_n_y mm // y adjustment to position - default is 0
manhole_symbol_n_style text // the name of the linestyle (symbol)
manhole_symbol_n_angle value // default value is 0
manhole_symbol_n_colour colour //

For example:

manhole_symbol_1_type "CONC COVER" // manhole type to use
manhole_symbol_1_position 1 // on top of manhole
manhole_symbol_1_mode 6 // use 12d symbol
manhole_symbol_1__style "shrub" // name of 12d symbol
manhole_symbol_1_size 1
manhole_symbol_1_x 0
manhole_symbol_1_y 0

Labelling House Connections

NOTE - house connections are only accessible by the Sewer module.

The house connections can be drawn from the pipe to the house connection level, with a line across the top 
(a T). The full width the T can be specified by the user.

draw_house_connections yes/no
house_connection_width value

The lot name for the house connection and the connection type can be labelled above the house 
connection. The house connection label is made up as:

connection_pre_text lot_name connection_mid_text connection_type connection_post_text

where lot_name and connection_type are stored with the house connection on the drainage string.

The parameters controlling the drawing of the house connection label are

0 1 2 3 4 5

predefined symbols for manhole_symbol_n_modes 0 to 5
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house_connection_mode 0 // don’t label the house connection
1 // label the house connection with name

// and type(default)
2 // label the house connection with name only

connection_pre_text text // default " "
connection_mid_text text // default " "
connection_post_text text // default " "
connection_text_colour colour // colour of connection label
connection_text_size mm // size of connection label
connection_textstyle textstyle // textstyle connection label
connection_text_x mm // x adjustment to position of text - def 0
connection_text_y mm // y adjustment to position of text - def 0
connection_text_justify text // default is Bottom_left
connection_text_angle value // default vertical 90
connection_text_position 1 // above point height value

3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

Label connection type: 

(this is used when the house_connection_mode is turned off, only the connection type is labelled)

house_connection_type_mode 0 // default, don’t label connection type
 1 // label connection type

connection_type_text_x mm // x adjustment to position of text - def 0
connection_type_text_y mm // y adjustment to position of text - def 0
connection_type_pre_text text // text before type - def " "
connection_type_post_text text // text after type - def " "
connection_type_text_size mm // def box_text_size
connection_type_text_colour colour // def box_text_colour
connection_type_textstyle text // 
connection_type_text_justify text // 
connection_type_text_angle value // def vertical 90
connection_type_text_position 1 // above point height value - default

3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

Label the distance from the down stream pit to the house connection

house_connection_ds_pit_mode0 // default, don’t label chainage
1 // label from down stream
2 // label from up stream
3 // label from left
4 // label from right

connection_ds_pit_text_x mm // x adjustment to position of text
connection_ds_pit_text_y mm // y adjustment to position of text
connection_ds_pit_pre_text text // ("") text before type
connection_ds_pit_post_text text // ("") text after type
connection_ds_pit_text_size mm // def box_text_size
connection_ds_pit_text_colour colour //def (box_text_colour
connection_ds_pit_textstyle text //
connection_ds_pit_text_justify text // default Bottom_Left
connection_ds_pit_text_angle value // default is vertical (90)
connection_ds_pit_text_position 1 // above point height value - default

   3 // above top of boxes
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4 // above highest point
100 // to primary string
101 // to first found tin

connection_ds_pit_decimals value // def number_of_decimals

Label the connection depth from the finished surface

house_connection_depth_mode 1 //default, label house connection depth
0 // don’t label house connection depth

connection_depth_text_x mm // x adjustment to position of text - def 0
connection_depth_text_y mm // y adjustment to position of text - def 0
connection_depth_pre_text text // text before type - def " "
connection_depth_post_text text // text after type - def " "
connection_depth_text_size mm // default box_text_size
connection_depth_text_colour colour // default box_text_colour
connection_depth_textstyle text //
connection_depth_text_justify text // default Bottom_left
connection_depth_text_angle value // default is vertical (90)
connection_depth_text_position 1 // above point height value - default

3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

connection_depth_decimals value // default number_of_decimals

Label the finished surface:

house_connection_fs_mode 1 //default, label house connection finished
// surface

0 // don’t label house con finished surface
connection_fs_text_x mm // x adjustment to position of text - def 0
connection_fs_text_y mm // y adjustment to position of text - def 0
connection_fs_pre_text text // text before type -def " "
connection_fs_post_text text // text after type - def " "
connection_fs_text_size mm // default box_text_size
connection_fs_text_colour colour // default box_text_colour
connection_fs_textstyle text //
connection_fs_text_justify text // default Bottom_left
connection_fs_text_angle value // default (vertical 90)
connection_fs_text_position 1 // above point height value - default

3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

connection_fs_decimals integer  // default number_of_decimals
// If > 0, all trailing zeros after the
// decimal place are removed.
// If < 0, the absolute value is taken as
// the number of decimal places and no 
// trailing zeros are removed after the
// decimal point.

The invert level of the house connection can also be plotted. The house connection invert level label is 
made up as:

connection_il_pre_text connection_invert_level connection_il_post_text

The parameters controlling the drawing of the house connection invert level label are:

house_connection_il_mode 1 // default, label the house connection il
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0 // don’t label the house connection il
connection_il_text_position  1 // above point height value - default

3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

connection_il_text_x mm // x adjustment to position of text - def 0
connection_il_text_y mm // y adjustment to position of text - def 0
connection_text_gap mm // distance from connection label and il label
connection_il_decimals integer // def -3, number of decimal places in il value

// >0 drop trailing zeros after decimal point
// < 0 keep trailing zeros 

connection_il_pre_text text // default " ", text before type
connection_il_post_text text // default " ", text after type
connection_il_text_colour colour // colour of connection il -def box_text_colour
connection_il_text_size mm // size of connection il - def box_text_size
connection_il_textstyle textstyle // textstyle connection il
connection_il_text_justify text // 
connection_il_text_angle value // (vertical 90)

 Symbols at Property Controls

NOTE - property controls and house connections are only accessible by the Sewer module.

The position of the property controls can be drawn as circles (which will display as an oval depending on 
the vertical exaggeration) with the diameter of the property control.

draw_property_controls yes/no

The position of the property control can also be indicated by placing a symbol at the property control.

The position of the property control at the drainage string can be labelled with symbols. There can be up to 
twenty (20) sets of property control symbols.

property_control_symbol_n_mode0 // cross
1 // up from centre of box
2 // up and down from centre of box
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3 // square
4 // triangle, base at bottom
5 // circle
6 // use a 12d symbol

property_control_symbol_n_position 0 // at bottom (invert) of property control
1 // at top (obvert) of property control
2 // at centre (axis) of property control

property_control_symbol_n_size mm // size
property_controle_symbol_n_x mm // x adjustment to position - default 0
property_control_symbol_n_y mm // y adjustment to position - default is 0
property_control_symbol_n_style text // the name of the 12d symbol
property_control_symbol_n_angle value // default value is 0
property_control_symbol_n_colour colour //colour of the symbol

For example:

property_control_symbol_1_position 0 // at bottom of prop control
property_control_symbol_1_mode 6 // use 12d symbol
property_control_symbol_1__style "shrub" // name of 12d symbol
property_control_symbol_1_size 1
property_control_symbol_1_x 0
property_control_symbol_1_y 0

Labelling Property Controls

NOTE - property controls and house connections are only accessible by the Sewer module.

The property control can be labelled with its name where the property control is at the drainage string. The 
property control name label is made up as:

property_control_pre_text property_control_name property_control_pre_post_text

where property_control_name is the stored with the property control on the drainage string.

The parameters controlling the labelling the property control are

property_control_mode 0 // don’t label the property control with name
1 // label the property control with name

property_control_pre_text text // default " "
property_control_post_text text // default " "
property_control_text_colour colour // colour of label
property_control_text_size mm // size of label
property_control_textstyle textstyle // textstyle label
property_control_text_x mm // x adjustment to position of text - def 0
property_control_text_y mm // y adjustment to position of text - def 0
property_control_text_justify text // default is Bottom_left
property_control_text_angle value // default vertical 90
property_control_text_position 1 // above pc centre height value

3 // above top of boxes
4 // above highest point
100 // to primary string

0 1 2 3 4 5

predefined symbols for property_control_symbol_n_modes 0 to 5
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101 // to first found tin

Label the distance from the down stream pit to the property control

property_control_ds_pit_mode 0 // default, don’t label chainage
1 // label from down stream
2 // label from up stream
3 // label from left
4 // label from right

property_control_ds_pit_text_x mm // x adjustment to position of text
property_control_ds_pit_text_y mm // y adjustment to position of text
property_control_ds_pit_pre_text text // ("") text before type
property_control_ds_pit_post_text text // ("") text after type
property_control_ds_pit_text_size   mm // def box_text_size
property_control_ds_pit_text_colour  colour //def (box_text_colour
property_control_ds_pit_textstyle text //
property_control_ds_pit_text_justify text // default Bottom_Left
property_control_ds_pit_text_angle value // default is vertical (90)
property_control_ds_pit_text_position 1 // above pc centre height value - default

   3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

property_control_ds_pit_decimalsvalue // def number_of_decimals

Label the depth from the finished surface to the invert level of the property control:

property_control_depth_mode 1 //default, label property control depth
0 // don’t label pc depth

property_control_depth_text_x mm // x adjustment to position of text - def 0
property_control_depth_text_y mm // y adjustment to position of text - def 0
property_control_depth_pre_text text // text before type - def " "
property_control_depth_post_texttext // text after type - def " "
property_control_depth_text_size mm // default box_text_size
property_control_depth_text_colourcolour // default box_text_colour
property_control_textstyle text //
property_control_depth_text_justify text // default Bottom_left
property_control_depth_text_angle value // default is vertical (90)
property_control_depth_text_position1 // above pc centre height value - default

3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

property_control_depth_decimals value // default number_of_decimals

Label the finished surface:

property_control_fs_mode 1 //default, label pc finished surface
0 // don’t label pc finished surface

property_control_fs_text_x mm // x adjustment to position of text - def 0
property_control_fs_text_y mm // y adjustment to position of text - def 0
property_control_fs_pre_text text // text before type -def " "
property_control_fs_post_text text // text after type - def " "
property_control_fs_text_size mm // default box_text_size
property_control_fs_text_colour colour // default box_text_colour
property_control_fs_textstyle text //
property_control_fs_text_justify text // default Bottom_left
property_control_fs_text_angle value // default (vertical 90)
property_control_fs_text_position1 // above pc centre height value - default

3 // above top of boxes
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4 // above highest point
100 // to primary string
101 // to first found tin

property_control_fs_decimals integer  // default number_of_decimals
// If > 0, all trailing zeros after the
// decimal place are removed.
// If < 0, the absolute value is taken as
// the number of decimal places and no 
// trailing zeros are removed after the
// decimal point.

The invert level of the property control at the drainage string can also be plotted. The property control 
invert level label is made up as:

property_control_il_pre_text property_control_invert_level property_control_il_post_text

The parameters controlling the drawing of the property control invert level label are:

property_control_il_mode 1 // default, label the pc il
0 // don’t label the pc il

property_control_il_text_position  1 // above pc centre height value - default
3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

property_control_il_text_x mm // x adjustment to position of text - def 0
property_control_il_text_y mm // y adjustment to position of text - def 0
property_control_text_gap mm // distance from pc name label and il label
property_control_il_decimals integer // def -3, number of decimal places in il value

// >0 drop trailing zeros after decimal point
// < 0 keep trailing zeros 

property_control_il_pre_text text // default " ", text before type
property_control_il_post_text text // default " ", text after type
property_control_il_text_colour colour // colour of pc il -def box_text_colour
property_control_il_text_size mm // size of pc il - def box_text_size
property_control_il_textstyle textstyle // textstyle pc il
property_control_il_text_justify text // 
property_control_il_text_angle value // (vertical 90)
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Hatching Cut and Fill Areas

This option is used to hatch cut and/or fill areas between sets of tins.

For each set, the name of the two tins, the hatch linestyle, colour and separation and whether cut and/or fill 
regions are required are all user definable.

Up to twenty (20) separate sets of tins be hatched.

The parameters for labelling cuts and/or fill regions between tins are given by:

hatch_original_tin_n tin_name // tin_name for original surface
hatch_new_tin_n tin_name // tin_name for final surface

hatch_cut_separation_n mm // distance between cut hatch lines
0 // don’t do cut hatching

hatch_cut_angle_n degrees // angle in degrees of cut hatching
hatch_cut_colour_n colour // colour of the cut hatching
hatch_cut_linestyle_n linestyle // linestyle for cut hatching
hatch_cut_draw_sides_n 1/0 // 1 = draw sides of cut regions
hatch_cut_draw_original_n 1/0 // 1 = draw original tin in cut regions
hatch_cut_draw_new_n 1/0 // 1 = draw new tin in cut regions

hatch_fill_separation_n mm // distance between fill hatch line
0 // don’t do fill hatching

hatch_fill_angle_n degrees // angle in degrees of fill hatching
hatch_fill_colour_n colour // colour of the fill hatching
hatch_fill_linestyle_n linestyle // linestyle for fill hatching
hatch_fill_draw_sides_n 1/0 // 1 = draw sides of fill regions
hatch_fill_draw_original_n 1/0 // 1 = draw original tin in fill regions
hatch_fill_draw_new_n 1/0 // 1 = draw new tin in fill regions

Notes

(a) cut is when the new tin is below the original tin.
fill is when the new tin is above the original tin.

(b) cut hatching is turned off by setting hatch_cut_separation_n to 0.0.
fill hatching is turned off by setting hatch_fill_separation_n to 0.0.

section viewtin (natural surface)

design x- section

cut

fill
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Labelling Cuts of Drainage Through Strings in a Model

The cuts that the drainage string makes though any strings in user given models can be automatically 
labelled on the long section plots.

The height, chainage and name of the cut string can be labelled as well as a symbol drawn. The height of 
tins at the same offset value can also be labelled.

The chainage position for the labelling is the chainage of the cut string.

The height position for the labelling can be specified as the

(a) top of the boxes on the long section

(b) height value of the cut string

(c) height of the primary string

(d) height of a tin.

The actual position of the label is defined relative to the above point.

Note: 

Only case (b) involves the actual height of the cut string. For all other cases, only the chainage of the cut 
string is used. Hence for all cases except (b), the string does need to have a sensible height to be used for 
cuts through strings. 

For example, a boundary string may have null heights but only the chainage is required and the height of 
the tin at that chainage can be used as the height (case (d)).

Text justification refers to the actual position and is given by

“top-left” “top-centre”                   “top-right”
“middle-left” “middle-centre”            “middle-right”
“bottom-left” “bottom-centre”            “bottom-right”

A choice of six special symbols and/or or any 12d symbols can be drawn at the cut point.

The special 12dModel symbols of size one millimetre are drawn in a square box centred on (0,0) with 
sides of length two millimetres. That is, the box co-ordinates are (-1,-1), (1,1), (1,-1), (-1,-1).

The six special shapes are

Up to twenty five (25) separate models of strings can be cut and labelled.

drainage string

strings to label where they are cut by the drainage string

plan view

tin (natural surface)

drainage long section

points where strings are cut
in plan by the long section

section view
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Parameters for Labelling Where the Drainage Line Cuts Strings in a Model

The method for specifying which strings are to be checked for cuts is by first specifying the model which 
contains the strings, and then a name mask which is used to restrict the strings in the model to only those 
whose name matches the name mask.

Up to twenty five different sets of models and name masks can be used so that different cut sets can be 
labelled in different ways.

The parameters for selecting and labelling the n’th set (where n can be from 1 to 25) of cuts of the design 
string with the strings in the model are given by:

cuts_n_model model_name                        // model of strings to be cut

The selection of the strings from the model model_name whose cut points are to be labelled is all the 
strings whose name satisfies the name mask cuts_n_mask:

cuts_n_mask name_mask                       // strings to check for cuts
// and if a cut occurs,

// parameters show how to
// label the cut

where name_mask is a text string containing the name masks, each separated by one or more spaces, to test 
the string name against. Each mast can include wild cards and wild characters.

For example

cuts_1_mask "ke*"
or cuts_1_mask "?bank*"

or, if both masks are required,
cuts_1_mask "ke*  ?bank*"

If cuts_n_mask is missing, then all strings in the model are used. This is equivalent to name_mask being 
"*".

All strings in the model cuts_n_model whose name satisfy the name mask cuts_n_mask are then checked 
for cuts with the drainage strings, and if a cut occurs, the cut point will be labelled according to the rest of 
the parameters in the n’th set.

The parameters for drawing a symbol at the cut points are 

cuts_symbol_n_mode 0 // cross
1 // up from centre of box
2 // up and down from centre of box
3 // square
4 // triangle, base at bottom
5 // circle
6 // use a 12d symbol

If cuts_symbol_n_mode is 6, then the 12d symbol is given by

cuts_symbol_n_style plotsymbol // 12d symbol to draw at cut

Important Note

 The plot symbol of name plotsymbol is defined in the file given by:

(a) the parameter plot_symbols in the ppf file

0 1 2 3 4 5

predefined symbols for cut_symbol_n_modes 0 to 5
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plot_symbols filename

or if plot_symbols is not defined, then

(b) in the file pointed to by the environment variable PLOT_SYMBOLS_4D

PLOT_SYMBOLS_4D filename // default plotsym.4d

or if PLOT_SYMBOLS_4D is not defined, then

(c) in the file plotsym.4d

which is searched for in the standard set up file sequence

If none of the above files are defined, or if the symbol does not exist in the above files, then it will be 
searched for in the standard 12d symbols file which is:

(d) either pointed to by the environment variable SYMBOLS_4D

SYMBOLS_4D filename // default symbols.4d

or if the environment variable SYMBOLS_4D does not exist, in the file, symbols.4d 

The position of the symbol or plot symbol is given by:

cuts_symbol_n_position    1 // above point height value
   3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

The symbol can be adjusted by the parameters:

cuts_symbol_n_x mm // offset adjustment to position
cuts_symbol_n_y mm // height adjustment to position
cuts_symbol_n_angle degrees // rotation about point
cuts_symbol_n_colour colour // colour of symbol

and for all values of cuts_symbol_n_mode other than 6:

cuts_symbol_n_size mm // size of symbol, 0 don’t draw

The value of the chainage of the cut string can be labelled using the parameters

cuts_chainage_n_position 1 // above cut strings height value
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_chainage_n_x mm // chainage adjustment to position
cuts_chainage_n_y mm // height adjustment to position
cuts_chainage_n_angle degrees // rotation about point
cuts_chainage_n_size mm // size of text, 0 don’t label
cuts_chainage_n_colour colour // colour of text
cuts_chainage_n_textstyle text // textstyle of text chainage
cuts_chainage_n_pre_text text // text before the chainage value
cuts_chainage_n_post_text text // text after the chainage value
cuts_chainage_n_justification justification // justification of the text
cuts_chainage_n_no_decimals integer // number of decimals in chainage
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The value of a height at the chainage of the point can be calculated and labelled using the parameters

cuts_height_n_mode 1 // use height of cut point itself
3 // use real world height of position

// above boxes
100 // height of primary string
101-500 // use height of to tin1 or tin2 etc.

cuts_height_n_position 1 // at points position
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_height_n_x mm // chainage adjustment to position
cuts_height_n_y mm // height adjustment to position
cuts_height_n_angle degrees // rotation about point
cuts_height_n_size mm // size of text, 0 don’t label
cuts_height_n_colour colour // colour of text
cuts_height_n_textstyle text // textstyle of text height
cuts_height_n_pre_text text // text before the height value
cuts_height_n_post_text  text // text after the height value
cuts_height_n_justification justification // justification of the text
cuts_height_n_no_decimals integer // number of decimals in height

A label which can include the name of the cut string is drawn by using the parameters

cuts_label_n_position 1 // above cut strings height value
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_label_n_mode 0 // don’t include cut string name
1 // include cut string name in label

cuts_label_n_x mm // chainage adjustment to position
cuts_label_n_y mm // height adjustment to position
cuts_label_n_angle degrees // rotation about point
cuts_label_n_size mm // size of text, 0 don’t label
cuts_label_n_colour colour // colour of text
cuts_label_n_textstyle text // textstyle of text label
cuts_label_n_pre_text     text // text before the string name
cuts_label_n_post_text     text // text after the string name
cuts_label_n_justification          justification // justification of the text

drainage long section

section view

point where the drainage
cuts a string 

The cut point can be labelled with
chainage of the cut point
height of the cut point
height of the x-section or tins at this offset
name of the string for the cut point

Any 12d symbol can be drawn at the cut point
the cut point

tin (natural surface)
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Title Block Information

The plot can have a standard 12d Model title block or a user defined title block.

The standard title block consists of a simple border around the plot and two lines of text in a box 
underneath the plot. For a user defined title block, all the line work and text is defined by the user.

Standard Title Block

For the standard 12d Model title block, there are extra parameters for two lines of text and text size and 
colour. The standard title block is turned on or off by the parameter plot_border.

plot_border yes/no // yes plots a standard title block
// default yes

title_1 text
title_2 text
title_text_size value
title_colour colour

User Title Block

For the user defined title block, the title block drawing commands are kept in a file whose name is supplied 
by the user. The title block drawing commands are almost identical to the linestyle drawing commands and 
is given at the beginning of chapter Advanced Plotting.

Hence for a user defined title block, there are just two parameters - one to say a title block file is being used 
and the other to give the name of the title block file. The plot_border parameter should also be set to no so 
that the standard title block is not also drawn.

use_title_file yes/no // yes draws the title block given in title_file
// default no

title_file filename
plot_border no // turn off standard title block

Some special plot parameters are used to pass information down to variables in a user defined title block

For example, inside the title block file it is possible to have runtime user defined text variables. The actual 
text values for these text variables are passed down to the title block file from the plot parameter file via 
the parameters user_text_n (n = 1,2,... 1000)

user_text_n text

The special plot parameters are:

time_format text // format for $time
user_text_n text // where n = 1,2,... 1000

// passed down to $user_text_n
title_1 text // passed down to $title_1
title_2 text // passed down to $title_2
start_page_number integer // used as the starting value for

//   $page_number. If missing, 
//   $page_number starts at 1.

start_drawing_number integer // added to $drawing_number in title
// block file. If missing,
// $drawing_number starts at 1.

drawing_number_prefix text // passed down to
//   $drawing_number_prefix

drawing_number_postfix text // passed down to
// $drawing_number_postfix
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Parameters that Modify Fields In the Plot Drainage Network Panel

A number of parameters match those in the plot drainage network panel.

When the plot parameter file is first read, any parameters in the panel will be replaced by the values of any 
corresponding parameters from the parameter file.

However, if the parameter is subsequently modified in the panel, the panel value will be the value used for 
the parameter.

The plot parameters that also occur in the plot drainage network panel are:

network_model text
scale value
plotter_type text
plot_stem text
view_name text
sheet_size text     or    "width     height"
plot_height mm
x_origin mm
y_origin mm
global_textstyle textstyle
box_text_size mm
box_colour colour
plot_border yes/no
title_1 text
title_2 text
title_text_size value
title_text_colour colour
use_title_file yes/no
title_file filename
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Melbourne Water
Position of menu: Design =>Drainage-Sewer=>Plots=>Melbourne Water

The Melbourne Water option is used to generate the longsection plots for all lines in a drainage network to 
the Melbourne Water sewer standards.

Given the plot sheet size and the horizontal and vertical scales, the longsections for the drainage lines are 
plotted starting at the top of the sheet and moving across the sheet. Once one row is full, if there is room 
the plot moves down the page and begins a new row. When a plot sheet is full, a new plot sheet is 
automatically begun.

Hence the drainage lines are plotted one after another on one or more plotter sheets.

The drainage lines are plotted in string name alphabeti1cal order.

The drainage longsection plot includes 

s the manholes, drainage pipe and any house connections

s the height of the natural surface at the manhole

s manhole names and cover types

s distances between manholes

s the invert depth of the pipe on either side of a manhole

s the grades and types of the pipes

s any services in the corridor - including their name, invert level and distance from the nearest 
downstream manhole 

melbourne_water_sewer_plot melb_water_plot_title
After selecting the Melbourne Water option, the Melb plot drainage network panel is displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Plot parameters input *.ppf

file of plot parameters used for extra control of the long section plot.

Plotter type input hp hp, dxf, postscript etc.

format for the plot output.

Network model input

the model containing all the drainage lines for the network.

Section view input

the section view to be used to define the vertical exaggeration, corridor widths, tins to section through, 
services models to section etc.

Plot file stem input

since more than one plot page may be produced, the plot file names are constructed from the stem plus 
a plot page sequence number, followed by the appropriate plotter type ending.

Scale 1: input

horizontal scale for plotting the drainage long section. The vertical exaggeration is taken from the 
section view given in the section view field.

Sheet size wd ht (mm) input available sheet sizes

the width and height values (separated by space) or the name of a user defined sheet size.

X origin (mm) input

the x position on the plot sheet for the bottom left hand corner of the longsection plots.

Y origin (mm) input

the y position on the plot sheet for the bottom left hand corner of the longsection plots.

Drainage line ht (mm) input boxes  boxes, centreline

the maximum allowable height for a longsection plot for a drainage line. Datum breaks are applied to 
any part of the longsection that will not fit into the drainage line ht.

Box text size (mm) input 3

size (in millimetres) to plot the chainages, heights etc. in the boxes in the plots of the drainage 
longsections

Box colour input cyan available colours

colour used for the text and the boxes.

Plot button

plot the drainage longsections for the drainage lines in the model given in the network model field.

The fields and buttons in title tab are:

Use title file tick-cross

if tick, a user defined title block file is used.

Standard Title tick-cross tick

if tick, the standard 12d Model border and two lines of title are placed on the bottom of the plot

Title file input *.tf

if non-blank and use title file is set to tick, then the file given in this field is used to generate a user 
defined title block for the plot.
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Title line 1/2 input

first/second line of title information

Title height (mm) input 5

height (in millimetres) to draw the characters in the two lines of title information.

Title colour input cyan available colours

colour used for the border and the title information.

Please continue to the next section “Melbourne Water Plot Parameter File” .

Melbourne Water Plot Parameter File

The Melbourne Water plot option is used to make special long section plots for a network of new 
drainage strings to Melbourne Water sewer standards.

Some of the look of the long section plot can be controlled from the Melb plot drainage network panel 
itself, however a wider selection of control parameters is available by using a Melbourne Water long plot, 
plot parameter file.

Because the Melbourne Water format is so fixed, most of the parameter have sensible default values and 
can be left out. However, for completeness, all the parameters are given.

The Melbourne Water Sewer (MWS) long section plot parameters are placed in a file with ending.ppf.

Each parameter consists of a parameter name followed by one or more spaces and then the parameter 
value. There is only one parameter per line.

Anything on a line after a double forward slash // is considered to be a comment.

The set of all parameters for the Melbourne Water sewer long section plot is enclosed within a set of curly 
brackets { } with the header

melb_water_sewer_long_plot      "plot set name"

before the curly brackets.

That is,

melb_water_sewer_long_plot   "plot set name" {

plot parameters
one per line

}

If there is more than one melb_water_sewer_long_plot parameter set in the file, only the first set is used.

There may also be parameter sets for other plot types such as section_x_plot in the same file. The other 
sets will be ignored when doing a Melbourne Water long section plot.

The plot parameters are documented in following groups: 

For the Plot Sheet layout, please continue to the section “Plot Sheet Layout” .

Chainages, staggering and uprights, please continue to the section “Chainages, Staggering and 
Uprights” .

Boxes area, please continue to the section “Boxes Area” .

Datum area, please continue to the section “Datum Value” .

Arrows area, please continue to the section “Arrow Areas” .

Graph area parameters, please continue to the section “Graph Area” .

Top area parameters, please continue to the section “Top Area” .

Manhole parameters, please continue to the section “Manholes” .

Junctions parameters, please continue to the section “Junctions” .

Services parameters, please continue to the section “Services” .
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Property controls and house connection parameters, please continue to the section “Property Controls 
and House Connections” .

Symbols at manhole parameters, please continue to the section “Symbols at Manholes” .

Hatching cut and fill parameters, please continue to the section “Hatching Cut and Fill Areas” .

Labelling cuts parameters, please continue to the section “Labelling Cuts of Drainage Through 
Strings in a Model” .

Title block parameters, please continue to the section “Title Block Information” .

Panel modifying parameters, please continue to the section “Parameters that Modify Fields In the 
Melbourne Water Network Panel” .

Plot Sheet Layout

The plot sheet is considered to have only positive co-ordinates with the origin (0,0) in the left hand corner. 
The units for the plot are millimetres.

The overall size of the plot sheet is given by either a defined sheet size, or by the width and height of the 
plot given in millimetres and separated by one or more spaces.

sheet_size text // sheet name, or
"mm mm" // sheet size: width height

The sheet size name and width and heights can be specified by the user in a file named sheets.4d which is 
in the normal set up areas, or is pointed to by the environment variable

SHEET_SIZES_4D file // file of plotter sheets sizes

The Melbourne Water long section plot will break an individual plot up if it doesn't fit across the sheet. 
There can be one or more rows of plot on the same sheet.

The top row is done first, followed by the second top row, then the third and so on until the bottom row. If 
there is only one row, it is considered to be the bottom row.

When a sheet is full, a follow on sheet is created.

As soon as one drainage string is completed, the next drainage string in the network model is plotted 
beginning on the same row as the previous drainage string and with a horizontal gap of size 
horizontal_plot_gap between the plots. If there is not enough room on the row to start the next plot, it will 
begin on a new row.

The position of the left hand bottom corner of the first plot in the bottom row is given by the parameters, 
x_origin and y_origin.

If there are two or more rows of plots, the position of the first plot in each row is given by adding multiples 
of the plot_height to the y_origin.

network_model text // model of sewer strings

x_origin mm // Position of the left hand bottom
y_origin mm // corner of first plot in the bottom row.

only_one_line 0 // more than one row on a sheet
1 // only one row of plot on a sheet

plot_height mm // total height of a plot row.
// It includes the vertical_plot_gap.

horizontal_plot_gap mm // gap between plots on same row
vertical_plot_gap mm // gap between rows of plots

A textstyle can be specified which is used for all the text in the plot.

global_textstyle textstyle //used for all plot text

The Melbourne Water long plot itself consists of nine areas. From the bottom up, they are

boxes, arrow 1, bottom stagger, arrow 2, graph, arrow 3, top stagger, arrow 4, top.
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The boxes area is where the chainages and various values for the drainage strings are labelled.

The arrow 1 area is for drawing arrows where the arrows go between the staggered uprights and below 
the graph area. The datum line is at the bottom of the arrow 1 area.

The bottom stagger area is where the upright line staggers occur before going up from the boxes area to 
the graph area.

The arrow 2 area is for drawing arrows below the graph but where the arrows go between non-staggered 
uprights.

The graph area is the area where the actual plots of the strings are drawn.

The arrow 3 area is for drawing arrows above the graph area and where the arrows go between non-
staggered uprights.

The top stagger area is where the upright line staggers occur above the graph area.

The arrow 4 area is for drawing arrows where the arrows go between the staggered uprights and above the 
graph area.

The top area is an annotation area above the arrow 4 area and is used for manhole names, junctions, 
deflection angles etc.

Although the arrow areas exist, the Melbourne Water plot does not have any arrows in them.
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Chainages, Staggering and Uprights

All of the labelling of the Melbourne Water sewer plot is done at the chainages of the manholes on the 
drainage line. For example, the invert levels, depths and natural surface of pipes at a manhole are all 
labelled at the chainage of the manhole.

The labels for these values are done at an angle of zero degrees rather than ninety degrees for the sewer 
plots.

Uprights, or leader lines, are drawn from the values at the bottom of the plot to the manhole in the graph 
area.

If the text values are placed at the real chainage positions at the bottom of the plot, text over writing can 
easily occur if the chainages are very close together.

To prevent such over writing, the text can be staggered. That is, if the text is going to over write a previous 
text value, the next text value is actually moved along until there is no over writing.

Since the text is no longer at the correct chainage position, the uprights to the manholes and services start 
at the text position and then bend back to the correct chainage position on the plot. The region where the 
bending occurs is called the stagger area.

For the Melbourne Water plot, there is an area below the graph where the uprights bend backwards from 
the staggered text position to the real chainage position (bottom stagger area).

And there is a second area above the graph where the uprights bend forwards from the real chainage 
position to the staggered text position (top stagger area).

Hence annotation above the top stagger area will line up with the staggered values below the bottom 
stagger area.

The stagger area below the graph area is defined by

stagger_height_1 mm // distance from the top of arrow_area_1
// to the start of the staggers

stagger_height_2 mm // distance over which stagger occurs
stagger_gap_bottom mm // distance from end of staggers to the

// bottom of arrow_area_2

The stagger area above the graph area is defined

stagger_gap_top mm // distance from the top of arrow_area_3
// to the start of the staggers

stagger_height_3 mm // distance over which stagger occurs
stagger_height_4 mm // distance from end of staggers to the

// bottom of arrow_area_4

The distance to be left for text to avoid over writing is:

horizontal_text_gap mm // minimum distance to leave for text
// after manhole values

services_text_gap mm // minimum distance to leave for text
// after service values

When staggering occurs, it is possible for the values area to be longer than the graph area.

The colour of the uprights that are drawn from the text to the manholes is given by:

manhole_line_colour colour // colour of uprights to the manholes
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Boxes Area

The drainage string values invert level, depth to invert and surface level can be labelled in the Melbourne 
Water plot with one line of title, and the actual values given at the chainage of each manhole in the 
drainage string.

The title or label for the strings, is drawn in the labels area of the boxes area and the values are drawn in 
the values area of the boxes area.

Consequently the boxes area is made up of rows of text consisting of:

labels followed by the values along the string.

Thus the boxes area is built up as a series of individual boxes and the boxes area is made up of two areas 
side by side - the labels area and the values area.

The order of the boxes from the bottom up is

(a) chainage values

(b) upstream and downstream depth to inverts

(c) upstream and downstream invert levels

(d) natural surface heights

The label text size and colour are specified by

plot_title_text_size mm // size of label text in boxes
plot_title_text_colour colour // colour of label text in boxes

The width of the label box is given by the box_width parameter and the height of each box is given by 
box_height.

box_width mm // width of the label boxes.
box_height mm // height of each box

The label text for each box can be set by

plot_title_chainage_name      text // label for chainages box
plot_title_surface_name      text // label for the sewer ns values
plot_title_invert_name      text // label for the invert levels
plot_title_depth_name      text // label for depth of inverts

For the Melbourne Water plots, there are also additional parameters for special Melbourne Water labels. 
They are

plot_title_item_name     text // label for item line
plot_title_d_and_g_name     text // label for diameter and grade
plot_title_detail_name     text // label for detail line at top of plot

The pipe type can also be included with the diameter and grade values

label_pipe_type yes/no

The labels area for the left plot in the bottom row starts at the co-ordinate (x_origin,y_origin) and each 
row is begun by adding the distance plot_height to the y_origin.

x_origin mm // x coord of bottom lh corner of bot row
y_origin mm // y coord of bottom lh corner of bot row

The values area starts at the end of the label area.

As for the label boxes, the height of each individual box area is given by the box_height parameter.

The width of the heights area is determined by the number of chainages to be labelled and whether the 
values are staggered to prevent over writing.

box_text_size mm // size of value text
box_text_colour colour // colour of values in boxes

The colour of the box line work is given by:

box_colour colour // colour of the lines in the boxes
The total height of the boxes area is simply given by number of boxes drawn multiplied by the height of 
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one box).

The total width of the boxes area is the width of the labels area plus the width of the values area which 
depends on the amount of staggering that occurs.

Datum Value

The datum value is placed above the top of the natural surface heights box.

Since the datum value is automatically calculated to try and fit the plot vertically into the graph area, the 
datum value can change along the plot. When a datum change occurs, the new datum value is written on 
the datum line at the relevant chainage position.

The datum name, text size and colour are controlled by:

datum_name text // text to write before the datum value
datum_text_size mm // size of datum text and value
datum_colour colour // colour of the datum text and line
datum_value_pre_text text // text before the datum value
datum_value_post_text text // text after the datum value

// (default " m")
datum_value_decimals integer // number of decimal places in the

// datum value.
// If  > 0, trailing zeros are removed.
// If  < 0, the absolute value is taken as
//   the number of decimal places and no
//   trailing zeros are removed.

Arrow Areas

The arrow areas were designed for drawing arrows between manholes and labelling them with values 
such as pipe slope, pipe diameter, flow, velocity and drainage line name.

These are not required for the Melbourne Water sewer plot.

However, values can still be given to defined the sizes of the arrow areas.

There are four arrow areas:

arrow_1_area which is below the graph and the bottom stagger area. The arrows go between the 
staggered positions of the manhole chainages.

The datum line is at the bottom of the arrow 1 area.

arrow_2_area which below the graph but above the bottom stagger area. Hence the arrows go between the 
non-staggered chainage positions of the manholes.

arrow_3_area which is above the graph but below the top stagger area. The arrows go between the non-
staggered chainage positions of the manholes.

arrow_4_area is above the graph and the top stagger area. The arrows go between the staggered chainage 
positions of the manholes.

The heights of the four areas (which can be zero) are defined by:

arrow_area_1 mm // height of arrow_1 area
arrow_area_2 mm // height of arrow_2 area
arrow_area_3 mm // height of arrow_3 area
arrow_area_4 mm // height of arrow_4 area
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Graph Area

The graph area is the area where the actual plots of the drainage strings are drawn.

The length of the graph area is determined by the length of the drainage string to be plotted, the horizontal 
scale (given by scale) of the plot and the sheet width.

scale value // 1:value - horizontal scale
// The vertical scale is determined by the
// horizontal scale and the vertical
// exaggeration for the section view.

The vertical exaggeration is taken from the section view specified for the plot by the parameter:

view_name text

The tins to be sectioned through by the sewer strings and any service models and corridor settings for the 
graph area are also taken from the specified section view.

The height of the graph is calculated by subtracting the height of the other nine boxes from the plot height.

If the plot will not fit horizontally into a row on the sheet, then the plot will be broken at an appropriate 
manhole and the plot continued on another row.

Datum breaks at manholes are used to try and fit the plot vertically into the graph area but if the plot still 
cannot fit, then it will be truncated at the bottom.

The types of strings that can be drawn in the graph area of the sewer long section plot are:

(a) drainage string the strings from the network model

(b) tins sections of the drainage string through any tins on the section view.

(c) services parts of strings from any models on the section view that cut the
corridor for the section view.

The colour of the strings in the plot is the actual string colour for cases (a) and (c), and the colour of the tin 
used for the section in case (b).

Top Area

The top area is an annotation area above the arrow_4_area at the top of the plot.

It can be used for manhole names, manhole types, pegs, junctions and deflection angles through manholes.

The height of the top area is given by

vertical_plot_gap mm // size of the top area. If it is not large
// enough the text will over write the
// plot in the row above.
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Manholes

The manhole name, manhole type, special manhole symbol and the change of direction of the pipes going 
through the manhole can all be displayed at the top of the plot.

The manhole name and type are drawn first, followed by the angle of any change of direction of the pipes 
going through the manhole (the angle is in degrees, minutes and seconds) and finally any junction 
information.

The text is drawn at the distance angled_text_y_offset above the top of the plot, angled_text_x_offset to 
the right of the manhole position and each piece of information is spaced horizontally by the distance 
angled_text_gap to the right of the manhole name if the angled_text_angle is zero, or the distance 
angled_text_gap below the previous text if angled_text_angle is non-zero.

The size of the manhole names and type is given by angle_text_size and the size of the change of direction 
angle is given by manhole_angle_text_size.

The colour of the manhole names, type and change of direction angle is given by angle_text_colour. 

label_manhole_type yes/no          // include manhole type
angled_text_size mm              // size of manhole name text

manhole_angle_text_size mm              // size of text for change of
                      //   angle through manhole

angled_text_x_offset mm // distance of text above top of the plot
angled_text_y_offset mm // distance of text to the right of manhole
angled_text_gap mm // distance of text to the right of previous

//   text
angled_text_angle value // angle of text
angled_text_colour colour // colour of text

The symbol at the manhole is controlled by the manhole name.

manhole_symbol_n_size mm
manhole_symbol_n_colour colour
manhole_symbol_n_y mm               // distance above top line
manhole_symbol_n_repeats integer         // draw the symbol this

                      //   many times with a
                      //   decreasing size)

manhole_line_colour colour          // colour of line through
                      //   manhole

Junctions

Any junctions at the manhole are also labelled with the name of the lines coming into the manhole.

The junction text is made up of two lines:

JUNCTION LINE        line_name

angle of the junction

The junction text is at the same height as the manhole and angle text and at a distance angled_text_gap to 
the right of the manhole and angle text, or a previous junction label. The size of the text is given by

junction_angle_text_size mm

When a junction does occur, the incoming pipe is drawn at the correct position on the manhole of the main 
line.
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Services

Any services in the corridor are drawn on the plot and if the service actually cuts the drainage string, then 
a line is drawn to the cut point and the line labelled with the service name. The name is drawn below the 
cut point and is right justified.

service_text_size mm // size of the text for the service name
service_text_x_offset mm // adjustment to the drawing position
service_text_y_offset mm // for the service name
service_text_colour colour // colour of the service name
service_line_colour colour // colour of the line to the cut point

Property Controls and House Connections

The position of the property controls can be drawn on the plot and can have a user specified diameter.

draw_property_controls yes/no
property_control_diameter value

The house connections can be drawn from the pipe to the house connection level, with a line across the top 
(a T). The full width the T can be specified by the user.

draw_house_connections yes/no
house_connection_width value
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Symbols at Manholes

Manholes can be labelled with symbols which depend on the manhole type. There can be up to twenty (20) 
sets of manhole symbols.

manhole_symbol_n_type mh_type // manhole type to have symbols
manhole_symbol_n_mode 0 // cross

1 // up from centre of box
2 // up and down from centre of box
3 // square
4 // triangle, base at bottom
5 // circle
6 // use a 12d symbol

manhole_symbol_n_position 1 // at top of manhole - default
 3 // above top of boxes
4 // above highest point
100 // to primary string
101 // to first found tin

manhole_symbol_n_size mm // size
manhole_symbol_n_x mm // x adjustment to position - default 0
manhole_symbol_n_y mm // y adjustment to position - default is 0
manhole_symbol_n_style text // the name of the 12d symbol
manhole_symbol_n_angle value // default value is 0
manhole_symbol_n_colour colour //

For example:

manhole_symbol_1_type "CONC COVER" // manhole type to use
manhole_symbol_1_position 1 // on top of manhole
manhole_symbol_1_mode 6 // use 12d symbol
manhole_symbol_1__style "shrub" // name of 12d symbol
manhole_symbol_1_size 1
manhole_symbol_1_x 0
manhole_symbol_1_y 0

0 1 2 3 4 5

predefined symbols for manhole_symbol_n_modes 0 to 5
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Hatching Cut and Fill Areas

This option is used to hatch cut and/or fill areas between sets of tins.

For each set, the name of the two tins, the hatch linestyle, colour and separation and whether cut and/or fill 
regions are required are all user definable.

Up to twenty (20) separate sets of tins be hatched.

The parameters for labelling cuts and/or fill regions between tins are given by:

hatch_original_tin_n tin_name // tin_name for original surface
hatch_new_tin_n tin_name // tin_name for final surface

hatch_cut_separation_n mm // distance between cut hatch lines
0 // don’t do cut hatching

hatch_cut_angle_n degrees // angle in degrees of cut hatching
hatch_cut_colour_n colour // colour of the cut hatching
hatch_cut_linestyle_n linestyle // linestyle for cut hatching
hatch_cut_draw_sides_n            1/0 // 1 = draw sides of cut regions
hatch_cut_draw_original_n        1/0 // 1 = draw original tin in cut regions
hatch_cut_draw_new_n              1/0 // 1 = draw new tin in cut regions

hatch_fill_separation_n                 mm // distance between fill hatch line
             0 // don’t do fill hatching

hatch_fill_angle_n degrees // angle in degrees of fill hatching
hatch_fill_colour_n colour // colour of the fill hatching
hatch_fill_linestyle_n linestyle // linestyle for fill hatching
hatch_fill_draw_sides_n         1/0 // 1 = draw sides of fill regions
hatch_fill_draw_original_n      1/0 // 1 = draw original tin in fill regions
hatch_fill_draw_new_n             1/0 // 1 = draw new tin in fill regions

Notes

(a) cut is when the new tin is below the original tin.
fill is when the new tin is above the original tin.

(b) cut hatching is turned off by setting hatch_cut_separation_n to 0.0.
fill hatching is turned off by setting hatch_fill_separation_n to 0.0.

section viewtin (natural surface)

design x- section

cut

fill
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Labelling Cuts of Drainage Through Strings in a Model

The cuts that the drainage string makes though any strings in user given models can be automatically 
labelled on the long section plots.

The height, chainage and name of the cut string can be labelled as well as a symbol drawn. The height of 
tins at the same offset value can also be labelled.

The chainage position for the labelling is the chainage of the cut string.

The height position for the labelling can be specified as the

(a) top of the boxes on the long section

(b) height value of the cut string

(c) height of the primary string

(d) height of a tin.

The actual position of the label is defined relative to the above point.

Note: 

Only case (b) involves the actual height of the cut string. For all other cases, only the chainage of the cut 
string is used. Hence for all cases except (b), the string does need to have a sensible height to be used for 
cuts through strings. 

For example, a boundary string may have null heights but only the chainage is required and the height of 
the tin at that chainage can be used as the height (case (d)).

Text justification refers to the actual position and is given by

“top-left” “top-centre”                   “top-right”
“middle-left” “middle-centre”            “middle-right”
“bottom-left” “bottom-centre”            “bottom-right”

A choice of six special symbols and/or or any 12d symbols can be drawn at the cut point.

The special 12dModel symbols of size one millimetre are drawn in a square box centred on (0,0) with 
sides of length two millimetres. That is, the box co-ordinates are (-1,-1), (1,1), (1,-1), (-1,-1).

The six special shapes are

Up to twenty five (25) separate models of strings can be cut and labelled.

drainage string

strings to label where they are cut by the drainage string

plan view

tin (natural surface)

drainage long section

points where strings are cut
in plan by the long section

section view
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Parameters for Labelling Where the Drainage Line Cuts Strings in a Model

The method for specifying which strings are to be checked for cuts is by first specifying the model which 
contains the strings, and then a name mask which is used to restrict the strings in the model to only those 
whose name matches the name mask.

Up to twenty five different sets of models and name masks can be used so that different cut sets can be 
labelled in different ways.

The parameters for selecting and labelling the n’th set (where n can be from 1 to 25) of cuts of the design 
string with the strings in the model are given by:

cuts_n_model model_name                        // model of strings to be cut

The selection of the strings from the model model_name whose cut points are to be labelled is all the 
strings whose name satisfies the name mask cuts_n_mask:

cuts_n_mask name_mask                       // strings to check for cuts
// and if a cut occurs,

// parameters show how to
// label the cut

where name_mask is a text string containing the name masks, each separated by one or more spaces, to test 
the string name against. Each mast can include wild cards and wild characters.

For example

cuts_1_mask "ke*"
or cuts_1_mask "?bank*"

or, if both masks are required,
cuts_1_mask "ke*  ?bank*"

If cuts_n_mask is missing, then all strings in the model are used. This is equivalent to name_mask being 
"*".

All strings in the model cuts_n_model whose name satisfy the name mask cuts_n_mask are then checked 
for cuts with the drainage strings, and if a cut occurs, the cut point will be labelled according to the rest of 
the parameters in the n’th set.

The parameters for drawing a symbol at the cut points are 

cuts_symbol_n_mode 0 // cross
1 // up from centre of box
2 // up and down from centre of box
3 // square
4 // triangle, base at bottom
5 // circle
6 // use a 12d symbol

If cuts_symbol_n_mode is 6, then the 12d symbol is given by

cuts_symbol_n_style plotsymbol // 12d symbol to draw at cut

Important Note

0 1 2 3 4 5

predefined symbols for cut_symbol_n_modes 0 to 5
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 The plot symbol of name plotsymbol is defined in the file given by:

(a) the parameter plot_symbols in the ppf file

plot_symbols filename

or if plot_symbols is not defined, then

(b) in the file pointed to by the environment variable PLOT_SYMBOLS_4D

PLOT_SYMBOLS_4D filename // default plotsym.4d

or if PLOT_SYMBOLS_4D is not defined, then

(c) in the file plotsym.4d

which is searched for in the standard set up file sequence

If none of the above files are defined, or if the symbol does not exist in the above files, then it will be 
searched for in the standard 12d symbols file which is:

(d) either pointed to by the environment variable SYMBOLS_4D

SYMBOLS_4D filename // default symbols.4d

or if the environment variable SYMBOLS_4D does not exist, in the file, symbols.4d 

The position of the symbol is given by:

cuts_symbol_n_position    1 // above point height value
   3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

The symbol can be adjusted by the parameters:

cuts_symbol_n_x mm // offset adjustment to position
cuts_symbol_n_y mm // height adjustment to position
cuts_symbol_n_angle degrees // rotation about point
cuts_symbol_n_colour colour // colour of symbol

and for all values of cuts_symbol_n_mode other than 6:

cuts_symbol_n_size mm // size of symbol, 0 don’t draw

The value of the chainage of the cut string can be labelled using the parameters

cuts_chainage_n_position 1 // above cut strings height value
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_chainage_n_x mm // chainage adjustment to position
cuts_chainage_n_y mm // height adjustment to position
cuts_chainage_n_angle degrees // rotation about point
cuts_chainage_n_size mm // size of text, 0 don’t label
cuts_chainage_n_colour colour // colour of text
cuts_chainage_n_textstyle text // textstyle of text chainage
cuts_chainage_n_pre_text text // text before the chainage value
cuts_chainage_n_post_text text // text after the chainage value
cuts_chainage_n_justification  justification // justification of the text
cuts_chainage_n_no_decimals integer  // number of decimals in chainage
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The value of a height at the chainage of the point can be calculated and labelled using the parameters

cuts_height_n_mode 1 // use height of cut point itself
3 // use real world height of position

// above boxes
100 // height of primary string
101-500 // use height of to tin1 or tin2 etc.

cuts_height_n_position 1 // at points position
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_height_n_x mm // chainage adjustment to position
cuts_height_n_y mm // height adjustment to position
cuts_height_n_angle degrees // rotation about point
cuts_height_n_size mm // size of text, 0 don’t label
cuts_height_n_colour colour // colour of text
cuts_height_n_textstyle text // textstyle of text height
cuts_height_n_pre_text text // text before the height value
cuts_height_n_post_text text // text after the height value
cuts_height_n_justification justification // justification of the text
cuts_height_n_no_decimals integer  // number of decimals in height

A label which can include the name of the cut string is drawn by using the parameters

cuts_label_n_position 1 // above cut strings height value
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_label_n_mode 0 // don’t include cut string name
1 // include cut string name in label

cuts_label_n_x mm // chainage adjustment to position
cuts_label_n_y mm // height adjustment to position
cuts_label_n_angle degrees // rotation about point
cuts_label_n_size mm // size of text, 0 don’t label
cuts_label_n_colour colour // colour of text
cuts_label_n_textstyle text // textstyle of text label
cuts_label_n_pre_text     text // text before the string name
cuts_label_n_post_text     text // text after the string name
cuts_label_n_justification justification // justification of the text

drainage long section

section view

point where the drainage
cuts a string 

The cut point can be labelled with
chainage of the cut point
height of the cut point
height of the x-section or tins at this offset
name of the string for the cut point

User defined symbols can also be drawn
at the cut point

tin (natural surface)
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Title Block Information

The plot can have a standard 12d Model title block or a user defined title block.

The standard title block consists of a simple border around the plot and two lines of text in a box 
underneath the plot. For a user defined title block, all the line work and text is defined by the user.

Standard Title Block

For the standard 12d Model title block, there are extra parameters for two lines of text and text size and 
colour. The standard title block is turned on or off by the parameter plot_border.

plot_border yes/no // yes plots a standard title block
// default yes

title_1 text
title_2 text
title_text_size value
title_colour colour

User Title Block

For the user defined title block, the title block drawing commands are kept in a file whose name is supplied 
by the user. The title block drawing commands are almost identical to the linestyle drawing commands and 
is given at the beginning of chapter Advanced Plotting.

Hence for a user defined title block, there are just two parameters - one to say a title block file is being used 
and the other to give the name of the title block file. The plot_border parameter should also be set to no so 
that the standard title block is not also drawn.

use_title_file yes/no // yes draws the title block given in title_file
// default no

title_file filename
plot_border no // turn off standard title block

Some special plot parameters are used to pass information down to variables in a user defined title block

For example, inside the title block file it is possible to have runtime user defined text variables. The actual 
text values for these text variables are passed down to the title block file from the plot parameter file via 
the parameters user_text_n (n = 1,2,... 1000)

user_text_n text

The special plot parameters are:

time_format text // format for $time
user_text_n text // where n = 1,2,... 1000

// passed down to $user_text_n
title_1 text // passed down to $title_1
title_2 text // passed down to $title_2
start_page_number integer // used as the starting value for

//   $page_number. If missing, 
//   $page_number starts at 1.

start_drawing_number integer // added to $drawing_number in title
// block file. If missing,
// $drawing_number starts at 1.

drawing_number_prefix text // passed down to
//   $drawing_number_prefix

drawing_number_postfix text // passed down to
// $drawing_number_postfix
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Parameters that Modify Fields In the Melbourne Water Network Panel

A number of parameters match those in the New Melb Plot Drainage Network panel.

When the plot parameter file is first read, any parameters in the panel will be replaced by the values of any 
corresponding parameters from the parameter file.

However, if the parameter is subsequently modified in the panel, the panel value will be the value used for 
the parameter.

The plot parameters that also occur in the Melb plot drainage network panel are:

network_model text
scale value
plotter_type text
plot_stem text
view_name text
sheet_size text     or    "width     height"
plot_height mm
x_origin mm
y_origin mm
global_textstyle textstyle
box_text_size mm
box_colour colour
plot_border yes/no
title_1 text
title_2 text
title_text_size value
title_text_colour colour
use_title_file yes/no
title_file filename
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More Drainage
more_drainage

Position of menu: Design =>Drainage-Sewer=>More

The More Drainage menu items contain the drainage import export routines and tools that enhance the 
basic drainage functions on the Drainage Sewer menu.

The more drainage walk-right menu is:

Frequently Asked Questions (FAQ)

Drainage Overview
The following are the basic steps from creating a urban drainage network to producing your plan/drainage 
longsection drawings and pit layout table. The optional catchment area models and bypass flow model will 
be discussed afterwards.

Set drainage defaults

Draw the drainage strings

Set zero chainage to downstream end of the pipe string (Reverse drainage strings) (optional)

Automatically assign pit names

Define catchment areas (optional)

Define Pit/manhole Inlet Capacities via Overland flow strings (optional)

Hydraulic/hydrology calcs via spreadsheets, Drains, RAT2000, PCdrain, XP SWMM or ILSAX

Drainage longsection plots

Pit layout/construction schedules

Manhole and Pipe Table of Quantities (summarise by type, depth and size)

Drainage line excavation volume calculations

Roadway flooded width calculations

Drainage Export and Import to Design Software
Copy/Paste from spreadsheets

Running Drains

Running PCdrain (Windows)
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Running Micro Drainage - Win DES

Running XPSWMM

Running RAT2000

Training Course Notes

Drainage and Advanced Drainage training course notes (Adobe PDF format for printing) and sample 12d 
data sets are available on the installation CD. The training course moves through a worked example in 
detail. The course notes are also included below for your reference.

Drainage Course Notes

Advanced Drainage Course Notes
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Drainage FAQ
Why do the obvert/invert levels not change when I import data via the "pit/pipe interface"?

On the interface panel there is an Options button that displays a panel with the "hold obverts on 
import" option. The default is off but if it is selected the pipe obverts will not change even if import 
data has new levels. Note that the invert levels will change is the pipe diameters change.

Can I manually enter catchment areas in the drainage design programs?

Yes. The catchment strings are optional in 12d. If no catchment string has been linked to a manholes 
and there has been no manhole "area" attribute a default area of 0.0001 will be sent. When results are 
imported back into 12d the total areas from the design package will be saved in the manhole "area" 
attribute.

How do I include/exclude the hydraulic grade line on drainage longsections. .

First, there must be HGL results. These may come from the 12d rational drainage design, imported 
from another design package (including spreadsheets) or manually entered as manhole/pipe attributes. 
If HGL results exists then they may be viewed in the section view of the drainage line.

Second, the HGL results may be added to the drainage longsection drawings by editting the plot param-
eter file (ppf) as shown below.
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Creating Drainage Strings
Drainage strings may be created in 12d in a number of ways.

1. Import 2d strings from other drawing packages and convert them to drainage string inside 12d.

2. draw the string in 12d using a design tin to the manhole cover levels and pipe inverts.

3. Enter the details in a spreadsheet format and paste the spreadsheet into 12d.

Regardless of the method, take the time to set your defaults before you start. You can always change the 
data later.
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Creating a drainage.4d file from the Drains database dump
Drainage_drains_to_drainage4d_panel

Position of option on menu: Design =>Drainage-Sewer =>More=>Drains to drainage.4d

On selecting the Drains to drainage.4doption, the Drains to drainage.4d panel is displayed.

Key Points
1. Select Read Drains database (12d will search the usual locations for the Drains database)

2. Review the Drains pit families list to identify the pit group separator and then enter it in the Pit group 
separator field. PRESS THE ENTER KEY!

3. Check the 12d pit groups and if they are acceptable select Create drainage.4d.

The Details

The Drains database dump file Drains Connection Data.txt is copied into the 12d working folder and 
read. The choices for the Pit families, Pipe types and Overflow Route Cross Section Shapes are loaded 
into the panel. The user must select a Pit group separator to separate the road grades and crossfalls from 
the pit family names. The resulting 12d Pit Groups will be calculated and displayed in the choice box. 
Create drainge.4d will create a drainage.4d file that may then be edited to specify the road grade and 
crossfall threshold values. Once the file is created you may review/edit it by selecting the More Info icon 
then Edit on the Drainage.4d field. The Overland route shapes are not exported to the drainage.4d file 
and are presented for your information only.

YOU MUST RESTART 12D FOR THE NEW DRAINAGE.4D FILE TO BECOME ACTIVE!

Field Description Type Defaults Pop-Up

Drains database file file Drains Connection Data.txt

You must update this file from Drains before each use of this panel. Inside Drains select 
Project=>Overflow Route database. Then select OK and then YES. This will cause Drains to export 
the database to the file “Drains Connection Data.txt”.

Selecting Enter in this field or selecting Read Drains database will cause the panel to search for the 
database dump in the folders C:\Program Files\Drains\Program and C:\Program 
Files\Drains\Demo\Program. If the Drains program is installed in another folder then you must 
browse for the file. After reading the file choice boxes below will be populated. Drains Connection 
Data.txt will be copied into the 12d working folder.
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Drainage.4d file drainage.4d

The drainage.4d will be created in the 12d working folder unless otherwise specified. It will only be 
used for 12d projects in this folder.

Pit families choice Drains pit families

These are the Drains pit families that will be exported to the drainage.4d file. The 12d pit groups will 
be created from this list.

Pipe type choice Drains pipe types

These are the Drains pipe types that will be exported to the drainage.4d file.

Overflow Route Shapes choice Drains Route Shapes

These are the Drains Route Shapes and are for information only.

Pit group separator input

These characters will be used to remove the road grade crossfall data from the Pit families above. The 
data before this character will become the 12d pit groups. Press Enter or select Read Drains 
database to create a new list of 12d pit groups.

12d pit groups choice 12d pit groups

These are created from the Pit family list above by deleting all text after the Pit group separator. This 
should delete all of the road grade and crossfall information from the pit group names.

Read Drains database button

Searches for the Drains database (see general description above) and populates the choices fields.

Create drainage.4d button

Create a local copy of the drainage.4d file.
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Editing a drainage.4d file
Drainage_Edit_drainage4d_panel

Position of option on menu: Design =>Drainage-Sewer =>More=>Edit drainage.4d

On selecting the Edit drainage.4d option, the Edit drainage.4d panel is displayed.

Select the Find button to search the 12d path for the 
current drainage.4d file. Select the More info button 
and then Edit to edit the file.
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Drainage IO Defaults
Drainage_io_defaults_panel

Position of option on menu: Design =>Drainage-Sewer =>More=>Drainage IO Defaults

On selecting the Drainage IO Defaults option, the Drainage IO Defaults panel is displayed.

The routine changes ALL of your manhole and pipe types in a model to a single value. If you have 
changed your drainage.4d file after creating you drainage network, the manhole and pipe types you 
originally selected may no longer be valid (i.e. in the drainage.4d file).

Field Description Type Defaults Pop-Up

Design Program choice Drains Drains,PCdrain

The drainge model to be updated.

Drainage model file

The drainge model to be updated.

12d pipe types choice values from drainage.4d

Set all pipe types will set all pipes in the model to this value

12d manhole types choice values from drainage.4d

Set all pit types will set all manholes in the model to this value

Default pit groups choice values from drainage.4d

manhole definitions in the drainage.4d file that have group as a prefix are included.

Default road shape choice values from drainage.4d

type the desired name or if using Drains select the desired shape from the Drains Overflow route 
shapes.

Drains Tab
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Drains database file file

pressing enter in this field will start a search for the Drains database dump. The search path is the 
specified folder, C:\Program Files\Drains\Program then C:\Program Files\Drains\Demo\Program. If 
the file is found the choice fields below are populated. It is highly recommended that this file be in the 
12d working folder.

Drains pipe types choice l values from Drains file

the pipe types are retreived from the last Drains database dump. Changing this value will update the 12 
pipe types above.

Drains Overflow Route Shapes choice values from Drains file

the overflow route shapes are retreived from the last Drains database dump. Changing this value will 
update the Default road shape above.

Set all pipe types button

all pipe types in model are set to this value

Set all pit types button

all pit types in model are set to this value

Set defaults button

the defaults for the Drains Overflow Route Shapes and 12d pit group are set

Finish button

removes the panel
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Drainage Network Editor
Drainage_Network_Editor

Position of option on menu: Design =>Drainage-Sewer =>Drainage Network=>Drainage network 
editor

The drainage network editor enables the user to edit all of the drainage strings in a model (a network). 
There are five main tabs and plus function buttons on the bottom of the panel.

Using the Drainage Network Editor

Recommended order to use the tabs and Buttons.

(This is not required but it will lead you through the process in an systematic method.)

Tab Function Buttons

1. Global tab 3. Set Pit Names

2. Defaults tab 4. Set Catchments

5. Pipe tab 8. Set Pit Details

6. Pit tab 9. Regrade Network

7. Catchment     Storm Analysis

    Import/Export

On selecting the Drainage network editor option, the Drainage network editor panel is displayed.
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Global Tab

Design values for the hydrology and hydraulics calculations are set either globally (one value for the entire 
network) or via Defaults for the manholes or pipes. Defaults values may be overridden by explicit settings 
found on the catchment, pits or pipes tab. Explicit manhole/pipe settings need only be specified if the 
default value is not desired.

There are 2 sub tabs. See Main tab and Utility Models tab

Main tab

The Global surface data. The Finished surface tin is used for determining pipe cover and surface levels 
for the manholes. The Natural surface tin is specified so that it can be included on the drainage 
longsection plots.
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For Global catchment data see Coefficients of Runoff

For Global pipe data see Pipe Friction Method.

Utility Models tab

The utility models tab is used to specify the following data:

Catchment polygons, the catchment slope strings, catchment labelling data

Bypass flow strings

Road setout strings., road centre line strings and crossfall/grade offsets

Service/utility models and the allowable clearances

Additional details

Catchments Areas

Bypass flow

Manhole setout via setout strings

Service and Utility Clashes
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Defaults tab

See Default Settings

Pit tab

Pipe tab

Catchment tab

Regrade Network

Set Pit Details

Set Pit Names

Drainage_Network_Editor__Set_Pit_Names

The Set pit name selection names the pits and pipes for the drainage model (both pits and pipes can be 
named). Three numbering schemes are available:



12d Model Reference Manual

Page  1916 June 2002More Drainage

drainage strings names are used as the prefix followed by the pit number (ex A-1)

drainage strings names are used as the suffix followed by the pit number (ex 1/A)

the pits are sequentially numbered. (ex 1,2,3....)

The names can have pre-text added to the beginning of the pit name and a separator between the string 
name and the pit number (/- etc.) if desired.

Design Program Notes:

PCdrain users: Since catchments contain only 3 characters do not use separators. Using the letters A-Z 
for strings and numbers 1-99 will give you 26 strings and up to 99 pits on each string. Using the numbered 
stem works very well in PC Drain.

Micro Drainage users: Pits and pipes are numbered separately in Micro drainage. The pipes must use the 
numbered sequence with the most upstream pipes numbered with the smallest numbers. Number of digits 
must be set to 3.

ILSAX users: You must use alphabetic characters for your string names and no more than 3 characters

See Also

Labelling a drainage network

Displaying the Auto Pit Names

Drainage overview

Usage

The selection is found on the drainage network editor and is accessed through the main menu by selecting

 Design=>Drainage-Sewer=>Drainage Network=>Drainage=>Network editor

Select the Set Pit Names button and the following panel will appear.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model Model box drainage model
from main dialogue

Naming Method Choice box

Pit num - String name for string A manhole 1 the name is 1A
String name - Pit num for string A manhole 1 the name is A1
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Sequential numbering the strings names are sorted alpha-numerically and the manholes are num-
bered starting at First pit number

Pre text input box

this text will precede the pit name  (ex Pit A01)

String/pit separator input box

the character that separates the string name from the pit number. For example if pit names A/01, A/02 
etc. where desired a  "/"  would be entered. You may omit the separator if none is desired. 

First Pit Number integer box

the starting pit number on the drainage lines. For drainage strings with the flow direction set as 
descending chainage the first pit is the junction pit.

Min digits in pit numbers integer box

a non zero value will pad the pit numbers with leading zeros. (ex if 2 is entered, pit 1 is not A/1 but 
rather A/01)

Reverse numbering order tick box

Unselected, pit First pit number  is at the low chainage end of the line. Selected, pit First pit number  
is the second pit from the high chainage end of the line.

Number pits tick box

the pits are assigned names. This allows the pit and pipes to be names differently.

Number pipes tick box

the pipes are assigned names. This allows the pit and pipes to be names differently.

Run button

  name the pits/pipes. The pit at the high chainage of the string is not labelled. The only time you will 
need to name this pit is when it is the outlet from the system.

Back to Editor button

return to the network editor.

Help button

display this page.

Plot

Drainage_Network_Editor__Plot
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See Using Drainage Network Plot Button

Import/Export

Drainage_Network_Editor__Import_Export
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See Drainage Export and Import to Design Software
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Drainage Rainfall File Editor
Rainfall_file_editor

Position of option on menu: Design =>Drainage-Sewer =>Drainage Network=>Drainage Rainfall 
Editor

Also see Using Rainfall Editor

On selecting the Drainage Rainfall Editor option, the Drainage Rainfall Editor panel is displayed.

These defaults are used when creating a manhole in a drainage string. The fields and buttons used in this 
panel have the following functions.

Field Description Type Defaults Pop-Up

Rainfall location file file

Each file contains the rainfall data for a specific location. Browse to the 12s library for examples.

Read button

You must select this to load the selected Rainfall location file.

Write button

Select this to save the changes you have made to the Rainfall location file.

Find button

not used in this editor

Finish button

removes the panel

Help button

launches this help screen
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Drainage Network Design
Drainage_Network_Editor__Storm_Analysis

See Also Using Drainage Design in 12d Drainage Design

On selecting the Storm Analysis button, the Drainage Network Design panel is displayed.

Field Description Type Defaults Pop-Up

Run button

Run 12d hydrology and hydraulic check routine

Edit button

return to the Drainage Network Editor

Finish button

removes the panel

Help button

displays this help page
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Convert to drainage strings
drainage_create_from_strings_panel

Position of option on menu: Design =>Drainage-Sewer=>More=>Create drainage from strings

This function converts 2d strings to 12d drainage strings.

See Also
Drainage overview

Usage

From the menu select

Design->Drainage-Sewer->More->Create drainage from strings

The following panel will appear.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source choice box model view,model,string

data source for strings to be converted

Select input box

Model containing strings to be converted

Drainage model model box

The new drainage strings will be added to this model. If it does not exist it will be created.

Finished surface tin tin box

This tin should be the same as your tin default for the drainage strings.

Outfall manhole number real input box

The network will be numbered using a numerical method. The most upstream manhole of the outlet line 
will be assigned this manhole number. This numbering system can be changed if desired. 

Process button

Coverts the strings to the drainage strings.
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Finish button

Removes the panel from the screen.

Important notes:

The imported strings must be drawn in the direction the water flows.

Manholes are created at all vertices on the strings. 

Trunk lines must have a vertex where the branch lines join.

Integer string names can be used to control the order in when the drainage lines are numbered. These 
names will be transfered to the 12d drainage strings. Naming the strings is highly encouraged.

The drainage lines must have string names to use the Set Pit Names feature on the network editor.

Manholes can always be renamed in 12d after the import is complete.

Set zero chainage to downstream end of line (Reversing the strings)

string_reverse_panel

Position of options on menu: Design =>Drainage-Sewer=>More=>Reverse all strings

For drainage direction of flow see Reversing the strings

If desired, the reverse function may be used to move the zero chainage to the downstream end of the line. 
This should be done after entering all of the drainage strings and before naming the pits. From the main 
menu select

Design=>Drainage-sewer=>More=>Reverse all strings

This will also change the drainage flow direction attribute from 
ascending chainage to descending chainage.

Leave the Increment as 1.

Displaying the Auto Pit Names
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Importing and Exporting
See Also

Drainage overview
Drainage Misc Utilities
Spreadsheet clipboard
Running Drains
Running PCdrain (Windows)
Running Micro Drainage - Win DES
Running XPSWMM
Running RAT2000

Spreadsheet clipboard

Spreadsheets are an effective method to manage the numerous variables urban drainage designers create in 
the modelling process. Spreadsheet data can be transferred to and from 12d in tab delimited files and 
stored within 12d as “user definable attributes”. These attributes are linked to the pit and pipes within a 
network. Drainage long section plots can display the pipe attributes in the “arrows” data area and pit 
attributes in the bubbles area. Drainage plan drawing can also show these pit and pipe attributes.

Drainage strings will be created if they do not exist in the model but manholes cannot be added to existing 
strings.

See also

12d to spreadsheet transfers

Spreadsheet to 12d update and create

Spreadsheet options

12d to spreadsheet transfers

This interface is accessed the Import/Export button on the Drainage Network Editor.
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Options

The Spreadsheet Options section allows the user to define the amount of data exported.

Select Export

Select Spreadsheet clipboard

These options are not used for 
spreadsheet export.

Usually leave this off! Select to 
export the junction pit at the end of all 
drainage lines (very rarely needed).

You may also select to limit the output 
if desired. If you like using 
spreadsheets for data entry, the 
PCdrain data and ILSAX data formats 
are useful for adding data for the first 
time for either program.

Select Run to place the data on the 
clipboard.
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All Data: All of the 12d drainage string data and the user defined attributes will be exported to the 
clipboard in a tab delimited format. The 12d data names and the user defined attribute names will appear at 
the top of the spreadsheets columns.

ILSAX: For the ILSAX program, the spreadsheet column headings will change depending on the pipe and 
catchment indicators (P2 card) and the inlet type (P3 card). Therefore, use the ILSAX pipe editor macro to 
set up one pit/catchment for the type of data you wish to enter. Now when you export the pipe network data 
the column headings will include the names of the relevant parameters.

User defined below: The Customised list file name is used to define the drainage values, their order and 
format you desire.

The customised list file is a text file where each line contains a drainage variable or a spreadsheet IO 
command (blank lines are ignored unless preceded by the header command). The spreadsheet IO 
commands available are:

header to define a line of text to be exported
blank to leave a blank column in the output
pipe data to specify the following user defined attributes are pipe data
pit data to specify the following user defined attributes are pit data.
variable name a 12d drainage variable names
factor the following variable is multiplied by this factor

The simplest way to create your own customised tab delimited file is to set the Preset Output field to All 
data and leave the customised list file name field blank. Selecting Set, Finish and then Copy from the 
main dialogue. The data will be placed on the clipboard and a customised list file, named output_list.txt 
will be created containing the names of all of the drainage variables in the 12d model. Use a text editor to 
add/or delete the variable names, change their order and/or add spreadsheet IO commands. Save the file 
with a new name! The output_list.txt file is overwitten on every export.

A listing of a customised list file follows. Note the words in the header file have a “tab” between them so 
that they will be spaces across the spreadsheet columns.

Export all 
junction pits when 
selected will repeat 
the data for the 
junction pit at the 
end of each branch 
line.

Preset Output this 
choice box offers 
the following 
choices:
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After creating your customised list file, select Options again and change the Preset Output field to User 
Defined below and enter the new customised list file name that you saved above. Select Set then Finish 
and finally Copy to put the formatted data onto the clipboard.

The data can be pasted into a spreadsheet program for checking or additional formatting.

CUSTOM FORMATED DATA MIGHT NOT BE PASTED BACK INTO 12d!

The data must be in the “12d drainage spreadsheet” format to be read into 12d.

Caution with manhole names in the form 1-1 or 1/1. Some spreadsheets will interpret these values as dates. 
If you use these formats for your manhole names you will have to paste command them in once, format the 
columns that contain the manholes names as text data and then paste the information in again.

One final word on using the copy/paste commands in the Microsoft Excel program. The Paste Special 
command using the “Skip Blanks” option will allow you to copy a large block of 12d data (with blanks in 
it) on top your data so that your data is preserved where it coincides with the blanks. To use this option 
paste the data into a blank spreadsheet and then select copy again. The Paste special option with “Skip 
Blanks” will now be available.

Spreadsheet to 12d Update and Create

This item is accessed from the Import/Export button on the Drainage Network Editor.

The following panel will appear.

header

Pipe Details

header
Name Length   U/S IL   D/S IL   Slope(%)   Class   Dia I.D.   Rough   Pipe Is   No. Pipes

pit data
*pit name

pipe data
*length
low ch invert
high ch invert

factor
100
*grade

pipe type

factor
1000
diameter
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Tab delimited, “12d drainage spreadsheet” format or “from to” format data must be on the clipboard in 
order to update a 12d drainage model or create a new model. These format are described below.

Updating an Existing Model

The data usually is generated by 12d using the Export option, pasted into a spreadsheet and then copied 
back to the clipboard so that 12d can be updated. 

When 12d exports the drainage model to a spreadsheet it includes a column for the unique string identifier 
and a unique manhole identier (unique to the drainage model not the 12d project). The names of the strings 
and manholes may be changed via the spreadsheet if these columns are present at import time.

If the manhole id column is not present, 12d will search the drainage model for a matching manhole name. 
When the manhole is a junction between drainage lines, only the trunk line will be the data updated.

Creating a New Model

It is possible to create a new string or an entire drainage network using this format. However, manholes 
cannot be added to an existing string. The entire drainage string must be created at once. Two formats are 
availabe, the “from-to manhole” format and the “12d drainage spreadsheet” format. 

At present the network editor must select a drainage string to become active. Therefore, if you are not 

Select Import

Select the Spreadsheet 
clipboard format.

The file field is ignored.

This is ignored on spreadsheet 
imports.

Select Run to update the 
drainage model.



Chapter

June 2002 Page  1929More Drainage

adding strings to a network, you will have to great a drainge network with one “dummy” manhole. Select 
this one “dummy” manhole to activate the editor. After importing the data and the new drainage lines are 
created the “dummy” manhole may be deleted.

12d drainage spreadsheet Format
The top left cell in the clipboard data must be the text “12d” to specify this format. The minimum amount 
of data required to create a new string is the string name, manhole name, x and y coordinates. You can add 
as much additional data as you have available. This would include pipe diameters inverts etc. The 
manholes must be listed from upstream to downstream order. If the string is to join a trunk line, the 
junction manhole must be included for both the tributary and the trunk line.

An example file exists called new_network.txt is supplied in the library. Open this file in a spreadsheet or 
a text editor and copy it to the clipboard. Set the I/O Action to Import and select Run. The new drainage 
lines will exist in the model currently being editted.

From-to Manhole Format
The top left cell in the clipboard data must be the text “from to” to specify this format. The minimum 
amount of data required to create a new string is the upstream pit name "*pit name) , the downstream pit 
name (*ds pit name) and the x(x location) and y(y location) coordinates of the upstream pit. If the string is 
to join a trunk line, the junction manhole must be included for both the tributary and the trunk line. 

An optional column for the manhole cover elev (cover elev) may be specified. Once the network has been 
created additional pipe and mnahole data may be added using the “12d drainage spreadsheet” format 
described above.

An example file exists called new_from_to_network.txt is supplied in the library. It is shown below. 
Open this file in a spreadsheet or a text editor and copy it to the clipboard. Enter a new model name in the 
Drainage model field and select paste. The new drainage model will now exist. 

“12d drainage spreadsheet” Format

Each column of data is used for a 12d drainage variable or a user defined attribute. Each row represents a 
manhole and the downstream pipe (controlled by the direction of flow variable) within the drainage 
network. A sample is shown below.
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Duplicate Definitions
Strings Variables such as “direction” are may be defined for numerous manholes on the same string. 
Searching in a top down direction through the file, the last definition found for the string will be set.

Invert levels may be set via pipe data or pit data or combined. It is recommended that the user only use one 
method and not combine them. Both are exported so delete the ones you are not going to use. The variables 
are processed from left to right, so if duplicate definitions of an invert level or found the right most data 
will be set.

The format definition
1.Row1, column 1 must contain either “12d”, or “from to”. Therefore, the first column must be a 12d 

drainage variable (cannot be a user defined attribute).

2.Row 1. The text <pit> at the top of the column indicates the column contains a user defined pit attribute 
and similarly <pipe> indicates a user defined pipe attribute.

3.Row 2. This row contains the names of the 12d drainage variable names and the pit/pipe attributes. All 
names are case sensitive so be careful where you use capital letters. A list of 12d drainage variables is 
found below.

Names beginning with an asterix (*) will not be processed (except pit/string names when unique iden-
tifiers are present in the data). 12d drainage variables names beginning with an asterix indicate that this 
data was calculated at export time and cannot be read back into 12d (for example, pipe length, pipe 
grade and deflection angle). 

Prefixing an user defined attribute name with “DELETE ” (no quotes, note the space after the 
DELETE) will cause the attribute to be deleted from all pits/pipes within the model.

4.Row 3. The text in this row define the type of attribute to be stored within 12d. The only valid choices 
are;
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integer
real
text

If you want to change an attribute type you must delete the attribute and create it again. If you simply 
change the attribute type in the third row then that attribute will not be updated.

5.Blank lines may be inserted as desired.

6.You are not required to fill in all of the cells in the spreadsheets. Blank cells are ignored (you must use a 
space to remove all data from text attributes (the space will not be stored).

7.Pipe names are included in the data so that they can be changed but they are not used to identify the pipe. 
Pipe data will always be assigned to the pipe following the pit in the direction of ascending chainage. 
If flow directions is ascending then the pipe data will be for the downstream pipe. If the flow direction 
is descending then the pipe data will apply to the upstream pipe.

12d Drainage Variable Names
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Quick Check Lists for Drainage Design Software
The drainage design software packages each have their specific requirements regarding the manhole types, 
names and then method they use to model pit inlet capacities. The following section details the specific 
requirement for each package.

Drains Version 2+ Requirements and Notes

Drains clipboard - Ver 5 Rational

Drains clipboard - Ver 5 ILSAX

See also Drainage overview

Basic Check List
1. All manholes must have a unique name (Manhole names cannot begin with "O ")

2. The pipe type used in 12d must exist in the Drains pipe database

Overland flow with Inlet Capacity Check List
1. Make sure you are using Drains Version 2-5 clipboard data. Inside Drains select Project=>Pit data-

base. The pit family selection should be available. (CAP1 etc. is Version 1).

2. All Overflow route shapes, pit families and pit types used in 12d must exist in the Drains pit database

3. Overland flow lines must be within 1.0 metres/feet of the manhole
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Running Drains - Version 2+

Key Points
1. The Drains database (each project has its own) and the12d database (drainage.4d) must be syncronised 

(More).

2. For bypass flow, 12d selects pit families for Drains in the following way

The users selects pit group in 12d and at export the pit group is scanned in the drainage.4d file using the 
road data to select the Drains pit families

3. Data is copied from 12d to the Windows clipboard and then pasted into Drains. 12d can not delete any 
objects in Drains, it can only add and update.

4. When updating 12d from Drains, always copy the DATA to 12d before the results. 12d will update the 
network but will not add or delete manholes.

Drains Interface Overview
The Drains program performs the rational and ILSAX hydrology calculations as well as hydraulic grade 
line calculations that determine pipe sizes and pipe invert levels.

The data sent to Drains includes

s manhole names and types, easting and northing data with surface levels

s finished surface profile along the centre line of the pipes

s optional - bypass manholes, road grades/crossfalls and SAG inlet ponding volumes and depths. Pit 
family selection usig road grade and crossfall data.

s optional - composite catchment area create from three12d areas per manhole

s optional - default catchment characteristics, k values and overland travel times

s optional - pipe sizes, type and invert levels

Data is copied from 12d to the Windows clipboard and then pasted into Drains (Edit=>Paste data from 
spreadsheet). 12d can not delete any objects in Drains, it can only add and update.

The Drains menu selection Run=>Design is used to design the network. Once the drainage network has 
been designed in Drains the updated design data (Edit=>Copy data to spreadsheet) and/or the hydraulic 
results (Edit=>Copy results to spreadsheet) are sent back to 12d via the clipboard. 

Always copy the DATA to 12d before the results as the results are deleted inside 12d with every 
update of the data!

A demonstration version of the Drains program is included on the 12d distribution CD in the directory

Other_Software\Drains

The version is limited in the number of pits allowed.

Syncronising the Drains database and the drainage.4d file.
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The Drains database and the 12d drainage.4d file must be syncronised as follows.

Every Drains file begins with a default database and uses that database for the life of the project. This 
database must by syncronised with the drainage.4d file in 12d to ensure the Drains pit families, pit sizes, 
pipe types and overflow route types. 

The following 5 steps will help ensure 12d is syncronised with Drains. More details are given in the 
sections below.

1)Export the Drains database from your Drains file
Inside Drains select Project=>Overflow Route database. Then select OK and then YES. This will cause 
Drains to export the database to the file “Drains Connection Data.txt”.

2)Create a drainage.4d file from the Drains file
s From the 12d menu select Design->Drainage-Sewer->More->Drains to drainage.4d. 

s Select Read Drains database,

s review the Drains pit families list to identify the character (usually a comma or -) that separates the 
pit group from the road data and then enter it in the Pit group separator field.

s Check the 12d pit groups and if they are acceptable

s select Create drainage.4d. The Drains database dump file is copied to the 12d working folder and 
a drainage.4d file is created in the 12d working folder.

s More details below.

3)Edit the drainage.4d file
From the 12d menu select Design->Drainage-Sewer->More->Edit drainage.4d. Select Find then edit 
from the file more info button. Set the road grade and crossfalls for the 12d manhole groups.More details 
below. 

4)Restart 12d
From the 12d menu select Project->Restart.

5)Set the Overflow shape, Update Manhole and Pipe type.
A single global overflow route shape can be specified in 12d via the following routine and then it can be 
modified in the Drains program. The import operation of the interface will read modified values and store 
them so that the next export operation will export the modified values.

If the network has already been created, using manhole and pipe types that no longer exist in the 
drainage.4d file, they will have to be updated before the export to Drains can occur. You may update them 
using the drainage network editor or you may set all of the manhole and pipes types to one value using this 

Drains database drainage.4d
Pipe type Pipe type entries

Drains database drainage.4d
Pit famly 12d manhole group with road data

to lookup Drains pit family

Overland route database One default value set (not in drainage.4d)

All Cases

Only if bypass flow  is required
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routine.Later you may change them individually using the Drainage network editor

From the 12d menu select Design->Drainage-Sewer->More->Drainage io defaults.

More details below.

Drains to drainage.4d file

Position of option on menu: Design =>Drainage-Sewer =>More=>Drains to drainage.4d

On selecting the Drains to drainage.4doption, the Drains to drainage.4d panel is displayed.

Key Points
1. Select Read Drains database (12d will search the usual locations for the Drains database)

2. Review the Drains pit families list to identify the pit group separator and then enter it in the Pit group 
separator field. PRESS THE ENTER KEY!

3. Check the 12d pit groups and if they are acceptable select Create drainage.4d.

The Details

The Drains database dump file Drains Connection Data.txt is copied into the 12d working folder and 
read. The choices for the Pit families, Pipe types and Overflow Route Cross Section Shapes are loaded 
into the panel. The user must select a Pit group separator to separate the road grades and crossfalls from 
the pit family names. The resulting 12d Pit Groups will be calculated and displayed in the choice box. 
Create drainge.4d will create a drainage.4d file that may then be edited to specify the road grade and 
crossfall threshold values. Once the file is created you may review/edit it by selecting the More Info icon 
then Edit on the Drainage.4d field. The Overland route shapes are not exported to the drainage.4d file 
and are presented for your information only.

YOU MUST RESTART 12D FOR THE NEW DRAINAGE.4D FILE TO BECOME ACTIVE!

Field Description Type Defaults Pop-Up

Drains database file file Drains Connection Data.txt

You must update this file from Drains before each use of this panel. Inside Drains select 
Project=>Overflow Route database. Then select OK and then YES. This will cause Drains to export 
the database to the file “Drains Connection Data.txt”.

Selecting Enter in this field or selecting Read Drains database will cause the panel to search for the 
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database dump in the folders C:\Program Files\Drains\Program and C:\Program 
Files\Drains\Demo\Program. If the Drains program is installed in another folder then you must 
browse for the file. After reading the file choice boxes below will be populated. Drains Connection 
Data.txt will be copied into the 12d working folder.

Drainage.4d file drainage.4d

The drainage.4d will be created in the 12d working folder unless otherwise specified. It will only be 
used for 12d projects in this folder.

Pit families choice Drains pit families

These are the Drains pit families that will be exported to the drainage.4d file. The 12d pit groups will 
be created from this list.

Pipe type choice Drains pipe types

These are the Drains pipe types that will be exported to the drainage.4d file.

Overflow Route Shapes choice Drains Route Shapes

These are the Drains Route Shapes and are for information only.

Pit group separator input

These characters will be used to remove the road grade crossfall data from the Pit families above. The 
data before this character will become the 12d pit groups. Press Enter or select Read Drains 
database to create a new list of 12d pit groups.

12d pit groups choice 12d pit groups

These are created from the Pit family list above by deleting all text after the Pit group separator. This 
should delete all of the road grade and crossfall information from the pit group names.

Read Drains database button

Searches for the Drains database (see general description above) and populates the choices fields.

Create drainage.4d button

Create a local copy of the drainage.4d file.

Editing the Drainage.4d file

Position of option on menu: Design =>Drainage-Sewer =>More=>Edit drainage.4d

On selecting the Edit drainage.4d option, the Edit drainage.4d panel is displayed.

The drainage.4d file contains Manhole and Pipe commands. 12d also uses the Manhole commands to 
specify a manhole group by using the prefix “group”. Details follow.

Select the Find button to search the 12d path for the 
current drainage.4d file. Select the More info button 
and then Edit to edit the file.
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Pit Families and Manhole Groups
Version 2+ of the Drains clipboard interface uses a pit family to describe the kerb shape. Optionally, the 
Drains pit families also have the road crossfall and/or grade attached as a suffix to the name with a special 
character between them (pit group separator). Therefore there may be many pit families that have the same 
kerb shape but different road grades and cross falls. All of these pit families with the same prefix are 
brought together in 12d as a manhole group. 

An example manhole group is the drainage.4d file is shown below. The 12d group is called NSW RTA 
Pits and 12d uses the road grade to select which pit family should be sent to Drains. In this example the 
road crossfall would not be used in selecting the pit family. 

The pit group separator is a “-”. This character separates the pit group from the road data.

It is up to the user to decide the grade when the next pit family should be used. In this case the threshold 
value for the gutter grade is set midway between the published values of the inlet curves. For example at a 
gutter grade of 2% 12d starts sending the NSW RTA Pits - 3% slope pit family.

This pit families listed on the right must match exactly with those in the Drains pit database.

Manhole "group NSW RTA Pits" {

//       cross fall,   gutter grade,  cap1,   cap2,   cap3,   cap4pit family

//4d          0,             1,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% slope

//4d          0,             2,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% slope

//4d          0,             4,        0,       0,    0.0,    1.0 NSW RTA Pits - 5% slope

//4d          0,             6,        0,       0,    0.0,    1.0 NSW RTA Pits - 7% slope

//4d          0,             8,        0,       0,    0.0,    1.0 NSW RTA Pits - 9% slope

}

An example with crossfalls follows. 

Manhole "group NSW RTA Pits" {

//       cross fall,   gutter grade,  cap1,   cap2,   cap3,   cap4

//4d          1,             1,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 1% 
slope

//4d          1,             3,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 3% 
slope

//4d          1,             5,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 5% 
slope

//4d          1,             7,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 7% 
slope

//4d          1,             9,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 9% 
slope

//4d          3,             1,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 1% 
slope

//4d          3,             3,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 3% 
slope

//4d          3,             5,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 5% 
slope

//4d          3,             7,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 7% 
slope

//4d          3,             9,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 9% 
slope
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}

The Drains pit family names must match the names in the last column EXACTLY! 

Manhole Types and Pit Sizes
Each Drains pit family has several pit sizes. The Drains pit sizes link to the12d manhole types and 
therefore all Drains pit sizes should exist in the 12d drainage.4d file.

The pit size will be read back from Drains into 12d as the pit type so that it can be placed on the drainage 
long sections and pit schedules.

Pipe Types
The pipe type selected in 12d must exist in the pipe database inside Drains. Simple “2” for class 2 or “RCP 
“do not exist in Drains.

Setting the Overflow Route, the Pit and Pipe types

Position of option on menu: Design =>Drainage-Sewer =>More=>Drainage IO Defaults

On selecting the Drainage IO Defaults option, the Drainage IO Defaults panel is displayed.

The routine changes ALL of your manhole and pipe types in a model to a single value. If you have 
changed your drainage.4d file after creating you drainage network, the manhole and pipe types you 
originally selected may no longer be valid (i.e. in the drainage.4d file).

Field Description Type Defaults Pop-Up

Design Program choice Drains Drains,PCdrain

The drainge model to be updated.

Drainage model file

The drainge model to be updated.

12d pipe types choice values from drainage.4d
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Set all pipe types will set all pipes in the model to this value

12d manhole types choice values from drainage.4d

Set all pit types will set all manholes in the model to this value

Default pit groups choice values from drainage.4d

manhole definitions in the drainage.4d file that have group as a prefix are included.

Default road shape choice values from drainage.4d

type the desired name or if using Drains select the desired shape from the Drains Overflow route 
shapes.

Drains Tab

Drains database file file

pressing enter in this field will start a search for the Drains database dump. The search path is the 
specified folder, C:\Program Files\Drains\Program then C:\Program Files\Drains\Demo\Program. If 
the file is found the choice fields below are populated. It is highly recommended that this file be in the 
12d working folder.

Drains pipe types choice l values from Drains file

the pipe types are retreived from the last Drains database dump. Changing this value will update the 12 
pipe types above.

Drains Overflow Route Shapes choice values from Drains file

the overflow route shapes are retreived from the last Drains database dump. Changing this value will 
update the Default road shape above.

Set all pipe types button

all pipe types in model are set to this value

Set all pit types button

all pit types in model are set to this value

Set defaults button

the defaults for the Drains Overflow Route Shapes and 12d pit group are set

Finish button

removes the panel

Drains Version 2+ Requirements

Manhole Names
The 12d manhole names cannot be more than 9 characters long. 12d uses 2 additional characters to the 
manhole name at export time create names for the pipes, overflow routes and catchments. For example 
manhole “A-1” will have a bypass route “F A-1”, a catchment “C A-1” and a downstream pipe “P A-1”.

Bypass Flow (Overland Flow Routes)
There are 3 requirements for Drains bypass flow.

1. Select Default pit group (Network editor->Defaults->Pits->Pit group). The Drains and 12d databases 
must be in sync.
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2. Bypass strings in the Bypass route model specified (Network editor->Global->Utiltiy Models-
>Bypass flow model. For more details see Bypass Flow.

3. Road grade and crossfall calculated (Network editor->Global->Utiltiy Models->Road design file)

The overland flow strings are not allowed to pass through the outlet pit on the network.

SAG Inlet Calculations
SAG inlets are manholes where the water ponds at the surface rather than flowing past. If a SAG inlet has 
a catchment string the overflow depth and volume are calculated. The catchment string from Set #1 is 
draped onto the design tin and the lowest point in found on the draped string (stored as a 12d pit attribute 
overflow level. The storage volume inside the string up to this point is measured and stored as a 12d pit 
attribute overflow volume from level. The pit cover level and Setout to grate offset are subtracted from 
the lowest point on the catchment string to determine the Max Ponding Depth.

Results
Drains exports the maximum data from all of the rainfall events analysed. Therefore, ensure you analyse 
only the rainfall events desired before coping the results to the clipboard. To verify the data that is being 
sent to 12d, copy the data into a spreadsheet so you can view it there first. The pit sizes selected in Drains 
will be stored in 12d as the manhole type. Therefore the pit sizes in Drains should exist as manhole types in 
the drainage.4d file. If pit families are changed in Drains the pit group in 12d will be updated by search for 
the pit family in the drainage.4d file.

12d to Drains

Setup your drainage network models and ensure they have been assigned pit names.

1. Copy the data to the clipboard

The following interfaces dialogues will appear.

From the Drainage net-
work editor select the 
Import/Export button.
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2. From within the Drains program select Edit =>Paste data from spreadsheet. If you paste the data into 
a Drains project that has a hydrological model and rainfall data already defined the project will be 
ready to run.

3. Use the Drains Run=>Standard design to design your pipe sizes and invert levels. The 
Run=>Advanced Design will select the size of the manholes as well.

Drains to 12d Update

The following steps are required to update the 12d model with the Drains hydraulic results and changes to 
the pipe sizes and inverts.

1. To update the pipes and invert levels in 12d, select Edit->Copy Data to Spreadsheet from the Drains 
menu.

2. From within the 12d Drainage network editor select Import/Export.

This should be filled in from the edi-
tor.

Enter the units.

Select Export.

Select Drains clipboard -Ver 5 
Ilsax or Rational.

Data is stored in this file as well as 
on the clipboard.

Not used by Drains

Use the Run button to copy to the 
clipboard.
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IMPORTANT: THE DATA MUST BE PASTED BEFORE THE RESULTS!

12d erases the hydraulic and hydrology data when the physical data is updated. Therefore, always 
paste the data before the results.

This should be filled in by the editor.

Not used on import.

Select Import

Select Drains clipboard - Version 5

Leave as clipboaard.txt

This will ignore the invert levels read 
from Drains and the current pipe obverts 
will remain fixed.

Plan and long section drawings may be 
created at the import time so that you can 
see the results on the drawings.

Select Run to update the drainage model. 
To see the changes in the section views 
you will have to select Regen on the sec-
tion view toolbar.

To return to the network editor select Edit
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PCdrain Requirements
PC Drain Int (Windows)

See also Drainage overview

Basic Check List
1. All manholes must have a unique name

2. Only one outlet allowed in the drainage model

3. First export should have “Export default catchment/pit/overland parameters” selected

4. Pit types in used in 12d must exist in the PCdrain Inlet gully file selected.

Overland flow with Inlet Capacity Check List
1. A gutter profile named “4d” must exist in PCdrain before the interchange file is read. This gutter pro-

file may be created in PCdrain from the menu selection Data=>Gutter profiles then New.

2. Overland flow lines must be within 1.0 metres/feet of the manhole

Data is exchanged to and from PCdrain via the interchange (*.int) file. Gutter profiles and inlet type must 
be specified in PCdrain before the interchange file is read into PCdrain.

The data sent to PCdrain includes

s manhole names and types, easting and northing data with surface levels

s pipe deflection angles at manholes

s finished surface profile along the centre line of the pipes

s optional - crossing services - level, size and location along the pipes

s optional - bypass manholes, road grades and SAG inlet ponding depths

s optional - up to 2 catchment areas per manhole

s optional - default catchment characteristics, k values and overland travel times

s optional - pipe sizes and invert levels

PCdrain Requirements

Manhole names
The manhole name from 12d is assigned to both the structure and catchment name in PCdrain. These 
names cannot exceed 7 characters.

Manhole type
The 12d manhole type is transferred to the structure type in PCdrain. These names must match those 
specified in the PCdrain Inlet charts selected (Data=>Inlet charts). Select the desired inlet charts 
BEFORE importing the interchange file.

12d manhole types with an “S” in the name are treated by 12d and PCdrain as a SAG inlet pit. 12d will 
strip off all characters after the “S” before adding the ponding depth. If a catchment string in set #1 is 
available for the SAG pit then the ponding depth will be calculated.The12d manhole type will remain 
unchanged. A typical example would be a manhole type “1TC” with the sag tick box on would become 
“1TC0.100” if a ponding depth of 0.1 was calculated.

Bypass Flow
When a catchment string is specified for the manhole, the maximum depth before bypass flow commences 
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is calculated. The lowest point on the catchment string is determined by draping it onto the drainage strings 
tin. The maximum depth before bypass is calculated manhole setout level less the setout to grate offset less 
the lowest point on the catchment string.

PCdrain differentiates between manholes (no surface inflow) and gully pits via the 12d manhole type. The 
bypass flow strings can only be drawn within 1 manhole diameter of the gully pits. Keep the bypass flow 
strings away from the PCdrain manholes.

Catchments
Again, since PCdrain differentiates between inlets and manholes (using the 12d manhole type), ensure that 
catchments are only drawn for gully inlet and NOT manholes.

12d to PCdrain

1. Export the data to PCdrain selected via the Network editor

Design=>Drainage-Sewer=>Drainage Network Editor

After selecting the drainage network, select the Import/Export button and the following dialogue will 
appear.

Select the Run button and the interface file will be created.

2. Launch the PCdrain for Windows program. If you have a project set up with the design parameters, 
rainfall data, inlet charts and gutter profiles then open it now and skip to step 8. Otherwise continue 
with step 5.

3. The Design Parameters can be set as desired with the menu selection Data=>Design Parameters.

4. Select the rainfall data using the Data=>Rainfall menu selection.

5. Select the inlet charts using the Data=>Inlet Charts menu selection. The manhole types specified in 
12d must be included in these settings. More - PCdrain to 12d pit converter

6. At least one gutter profile in PCdrain needs to be defined. These are set through the menu selection 
Data=>Gutter Profiles. The default gutter section name (Road ID) from 12d is 4d and therefore it is 
recommended you create a profile with this name and your own description. If you have changed the 
profile names in 12d (through the spreadsheet interface or the Attribute editor) these new profile names 
will have to exist in PCdrain.

7. Save this file now so that you can retrieve it later if required. It can be used as a starting template for 
new jobs.

8. File=>Import from the menu. Select the file exported in step 1. The information from 12d may be 
viewed by selecting Data=>Network and then selecting the desired tabs.

9. The HGL level and the pipe elevation at the outlet should be set using the menu selection Data=>Out-
let.

10. If you have not exported pipe data then the pipe size must be determined. Use the menu selection Proc-

The drainage model will be completed 
by the editor.

Select Export.

Select PCdrain Int (Windows) from 
the drop down list.

Enter the name of the int file to be cre-
ated.



Chapter

June 2002 Page  1945More Drainage

ess=>Select Pipe Sizes.

PCdrain data values

Some PCdrain data values are not available in the 12d network editor. Prior to an import from PCdrain, 
initial export values are used. On the first import from PCdrain, 12d attributes are created to hold the 
PCdrain variables for subsequent exports to PCdrain. These data values are usually changed in the PCdrain 
menus but may by changed in 12d using the Attribute editor.

PCdrain to 12d

Export the results to 12d using the File=>Export menu selection. Note the name of the interchange file 
you are creating as you will need to enter it inside 12d.

Return to 12d and select Import/Export from the network editor and the following dialogue will appear,

PCdrain 12d editor 12d attribute
initial export 

value

Kw not available kw 12d ku value

Minor Coef Catch Set 1 - Pervious C (minor) c minor pervious default

Major Coef Catch Set 1 - Pervious C (major) c major pervious default

Minor Coef2 Catch Set 2- Pervious C (minor) c minor pervious2 default

Major Coef2 Catch Set 2- Pervious C (major) c major pervious2 default

Tc overrider Catch Set 1 - Pervious Tc (minor) tc minor pervious default

Length of 
overland flow

Catch Set 1 - Pervious length catchment length 
pervious

default

Grade of overland 
flow

Catch Set 1 - Pervious slope (%) catchment grade 
pervious

default

Length of gutter 
flow

Catch Set 1 - Impervious length catchment length 
impervious

default

Grade of gutter 
flow

Catch Set 1 - Impervious slope (%) catchment grade 
impervious

default

Road XSections 
left

not available overland profile name 4d

Road XSections 
right

not available overland profile name 
right

4d
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A listing of the data imported is stored on the 12d output window.

Manholes that have been specified as SAG inlets will have the ponding depth removed from the end of the 
PCdrain structure type before the data is stored as the12d manhole type.

RAT2000 Requirements

RAT2000

See also Drainage overview

Basic Check List
1. All manholes must have a unique name (they become nodes in RAT2000)

2. Only one outlet allowed in the drainage model

3. First export should have “Export default catchment/pit/overland parameters” selected

4. First export should have “Export pipe diameters and Inverts”  selected

5. Outlet conditions must be set in RAT2000.

Select Import

Select PCdrain Int (Windows)  from 
the drop down list.

Select the output file name you created 
in PCdrain.

Select Run and the file will be read 
into 12d and the drainage network will 
be updated. To see the changes in a 
section view, select Regen.
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6. Start-up data may be specified in the file drainage startup.xpx (the standard 12d system file path will 
be searched).

Overland flow with Inlet Capacity Check List
1. Overland flow lines must be within 1.0 metres/feet of the manhole

2. If inlet capacity curves are to be used then the curve name must match the 12d pit type with the road 
grade/crossfall data added.
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Running RAT2000
Data is exchanged to and from RAT2000 via the interchange (*.xpx) file. The data exported from the 12d 
drainage model is appended to the xpx startup data specified in the file drainage startup.xpx (the standard 
12d system file path will be searched). This file may be edited using a text editor or you may create your 
own default file by exporting your RAT2000 global data this file.

RAT2000 Requirements

Manhole names
All manholes will become nodes in RAT2000 and therefore they must have a unique name inside 12d.

Manhole Types
The manhole types are used to determine the pit inlet capacities if overland flow routes are selected. Fixed 
inlet capacities values may be set in the drainage.4d file while inlet capacites curves must be included in 
the drainage_startup.xpx file. The range of available curves for 12d to choose from are set in the 
drainage.4d file and the curves are determined using the pit type, road grade and road crossfall.

Pipe Types
Pipe types are not transfered to RAT2000.

Overland Flow
When an overland flow model is selected the pit inlet capacities and bypass routes are calculated.

12d to RAT2000

1. Export the data to RAT2000 by selecting 

Design=>Drainage-Sewer=>More=>Pit/Pipe Design Interface

The following dialogue will appear.
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The Export Pipe Diameters and inverts option should be ticked for if you want the 12d pipe sizes sent to 
RAT2000. This should always be selected the the first time you create the RAT2000 file. RAT2000 will 
increase pipe sizes but will not decrease them.

The Export default catchment/pit parameters will instruct 12d to export default catchment parameters. 
This is usually only done on the first export. Catchment areas will always be sent if a catchment string 
exists for the manhole.

Select the Write button and several checks will be made on the drainage network at this time. CAUTION 
notes will be given… read them. If asked, fix any errors that are reported. The interface file will be created.

Updating an existing RAT2000 file

Adding new Nodes and Pipes
If new manholes and pipes have been added to 12d then these new entities will now be included in the xpx 
file and imported into the RAT2000 project. 12d identifies the nodes in XP by the node names. Therefore if 
nodes names are changed in either program then they must be manually changed in both programs.

If a manhole is to be inserted in an existing link then the existing link must be deleted in RAT2000 so that 
the new links and manholes may be created in the void.

WARNING! If the tick box Export catchment/pit/overland flow default data is selected for the update then 
any changes to these defaults in RAT2000 will be lost. Two options are available to the user.

Option 1 - Preferred method if updating pipe lengths, invert levels for your design.

De select the tick box and export the data. The new node and links created in RAT2000 will not have all 

Select RAT2000 from the drop 
down list.

Select your drainage model

Enter the name of the xpx file to
be created.

Optional. 

Specify catchment units acres o
ha.

Not supported in RAT2000.

See overland flow section

Usually leave this selected

See notes below on Updating
an existing RAT2000 
file 

Used to set default data and 
calculations at export time.
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the defaults set but the existing nodes and links will not have revisions to defaults overwritten.

Option 2 - Preferred method if you have created numerous new links and nodes.

Leave the tick box selected but export the RAT2000 to a temporary xpx fle first. This will save the existing 
setting. After RAT2000 is launched and loaded with the new data, import your temporary xpx file you just 
created to restore the original data. 

Deleting Nodes and Pipes
If a node or link is to be deleted then delete the entity from both 12d and RAT2000.

RAT2000 Results to update 12d

If RAT2000 is lauched automatically using option 1 above then as soon as RAT2000 is exited an interface 
file is automatically created (using the same name as the import xpx file). This file will now be read back 
into 12d to update the pipe network and import hydraulic results for drainage longsection plots.

Return to 12d and select

Design=>Drainage-Sewer=>More=>Pit/Pipe Design Interface

The following dialogue will appear,

A listing of the data imported is stored in the file printout.txt which can be found in the directory above 
the project.

Select RAT2000from the drop 
down list.

Select the model containing the 
drainage network.

Select the output file name you 
created in RAT2000.

The remaining fields are not 
used for the import process.

Select Read and the file will be 
read into 12d and the drainage 
network will be updated. To see 
the changes in a section view, 
select Regen.
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XP SWMM Program Requirements

XP SWMM

See also Drainage overview

Basic Check List
1. All manholes must have a unique name (they become nodes in XP SWMM)

2. Only one outlet allowed in the drainage model

3. First export should have “Export default catchment/pit/overland parameters” selected

4. First export should have “Export pipe diameters and Inverts”  selected

5. Outlet conditions must be set in XP SWMM.

6. Start-up data (run times and hydrology data) may be specified in the file master_drainage.xp (the 
standard 12d system file path will be searched).
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Running RATHGL/RAT2000 and XP-SWMM
The drainage design with all three of the XP software programs follows the same methodology. The 
process is substantially automated with the XP-SWMM program so that the XPX file is automatically read 
by XP-SWMM and automatically created when leaving XP-SWMM.

Drainage design with XP programs includes the following steps.

1. 12d creates an XPX file that is read by the XP programs.

2. The XP program is then run in the design mode to determine the pipe sizes and invert levels.

3. If bypass and overland flows are to be modelled then the inlet capacities need to be defined and then 
run the XP program in the Full Analysis Model.

4. The XP program creates an XPX file for 12d to import.

XP Program Requirements

12d to the XP Programs

The x,y pit layouts and the cover/surface levels are obtained from your drainage network while the 
catchment and overland flow data comes from the models specified in the drainage interface dialogue.

The steps required to transfer the data to the XP programs are as follows.

1. Setup your drainage network models.

2. To create the XPX file for XP programs start the Drainage Network Editor and select Import/Export

The following interfaces dialogues will appear.

If exporting to RAT-HGL the following dialogue will appear.

3. The XP SWMM program will automatically startup and load the XPX file. 

From within RAT-HGL, either select File =>New and follow the input prompt or load a file that con-
tains all of the pit inlet rating curves, hydrological and design data without a pipe network. Many users 

Select Export

Select XPSWMM or RAT HGL 
from the drop down list.

Enter the name of the xpx file to 
be created.

Not used at this time.

Finally, Select the Run button to 
create the file.

If you are using old versions of RAT-HGL (1996 or 
earlier) select use Local otherwise select 4D units 
(eastings and northings). 

Select process.
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have such RAT-HGL files setup so as to streamline the design process.

The xpx file for RAT2000 will have the file startup.xpx added to it so that you may include all the star-
tup global data that you require. The 
Fixed inlet capacities and rating curve names indicating road grade and crossfall may be set in the 
drainage.4d file. The format for these names is pit name-crossfall-road grade (ex SA2-3-4). These 
curves must exist in this file. 

4. To read in the pipe file created above, select Special =>Import Data and select the xpx data file. 
Warnings will be given stating that several fields are inactive. This is expected as more data is sent to 
RAT-HGL than is needed at this time. Select the Close Square on the Help title area and the pipe net-
work and catchments should now appear on the screen.

5. If you want RAT-HGL to redesign you network, change the analysis mode to Design mode by selecting 
Special=>Job Control and Select Design mode. Do not do this if you want to analyse the network you 
layed out in 12d (used for existing systems).

6. Select the rainfall events to design/analyse and the LB (twice) on OK to return to the layout. Now 
select the outlet and enter the starting tailwater levels.

7. Now you can run RAT-HGL (Special =>Solve).

XP Programs to 12d

Once you have your design finished, the following steps are required to update your 12d model. Your 
design may contain several return periods in the analysis (Rp1 to Rp7) but 12d reads only the results from 
Rp1. The following table is taken from the RATHGL output file (*.out extension) and the results indicated 
are read back into 12d via the xpx file.
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In addition to the results, the following input data is read back into the 12d model so that it may be 
exported back to RATHGL in the future (if required). 100% of your RATHGL data is not included in the 
XPX formats and the contents of the XPX file will depend upon your design mode. Therefore, use caution 
if you read an XPX file into an existing RATHGL model and check your data once inside RATHGL. 

1. From within RAT-HGL, produce an XPX file for 12d to read by selecting Special=>Export Data and 
following the default prompts.

2. From within 12d, select the Import/Export button on the Drainage Network Editor.The following 
panel will appear.

HGL  PIPE  NETWORK  ANALYSIS  SUMMARY    RETURN PERIOD   5 YEARS

        PROJECT:12d DRAINAGE LAYOUT                                       

 ---------------------------------------------------------

 |ITEM DIM| RESULT                                                               

 ---------------------------------------------------------

 RN       -       1       2       3       4       5       6

 NN       -     1-1     2-1     1-2     3-1     1-3     1-4

 DN       -     1-2     1-2     1-3     1-3     1-4     1-4

 MT       -      99      99      99      99      99       0

 DHGL     M  29.258  29.258  28.139  28.139  27.269    .000    DS HGL

 DD       M    .225    .375    .375    .300    .450    .000    Diameter

 DCTL           HGL     HGL     HGL     HGL     HGL        

 DO       M    .225    .375    .375    .300    .450    .450

 QO    M3/S    .033    .181    .237    .075    .334    .353    Flow

 VELD   M/S    .826   1.639   2.148   1.065   2.100    .000

 NORM     M    .106    .264    .271    .153    .289    .000

 CRIT     M    .152    .314    .345    .215    .396    .000

 KP       -     .00     .00     .00     .00     .00     .00

 SF     M/M   .0040   .0082   .0140   .0046   .0107   .0000

 LEN      M   45.93   18.44   54.65   31.31   49.91     .00

 HGLP     M  29.444  29.409  28.905  28.284  27.802    .000   US HGL

 DU       M    .225    .375    .375    .300    .450    .000

 VELU   M/S    .826   1.639   2.148   1.065   2.100    .000   Velocity

 UCTL           HGL     HGL     HGL     HGL     HGL        

 KU       -    1.50    1.50    1.50    1.50    1.50     .00   Ku

 KL       -    1.50    1.50    1.50    1.50    1.50     .00

 KR       -    1.50    1.50    1.50    1.50    1.50     .00

 KW       -    1.50    1.50    1.50    1.50    1.50     .00   Kw

 UHGL     M  29.496  29.615  29.258  28.370  28.139  27.269

 LHGL     M  29.496  29.615  29.258  28.370  28.139  27.269

 RHGL     M  29.496  29.615  29.258  28.370  28.139  27.269
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Select Import.

Select to select RATHGL or XP-
SWMM.

Select the file name specified in 
step 1

Select Run to update the drainage 
model and import hydraulic/
hydrological results.
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Running Micro Drainage - Win Des
Micro Drainage (*.sws)

Micro Drainage (*.fws)

See also Drainage overview

Basic Check List
1. All manholes must have a unique name (they become nodes)

2. Only one outlet allowed in the drainage model

3. First export should have “Export default catchment/pit/overland parameters” selected

4. First export should have “Export pipe diameters and Inverts”  selected

5. Outlet conditions must be set in Win DES.

Micro Drainage - WinDes Requirements

Manhole - Pipe names
The pipe names are used in the WinDes interface NOT the manhole names. Therefore the pipes are often 
named separately to follow the WinDES required naming convention. 

The pipes must use the numbered sequence with the most upstream pipes numbered with the smallest 
numbers starting at 0. Number of digits must be set to 3. If this numbering system is not followed 12d will 
renumber the strings and request the user to run the drainage misc utilities to rename the pipes and 
manholes. The panel below shows the naming convention used in misc utilities.

The *.sws or *.fws files may be open directly inside WinDes.

Open channel drainage design.

Win Des can (hydraulically) model any shape of conduit. The conduits are given numbers between 1 and 
100. 12d selects these coduits by setting the pipe type to WINDES (case sensitive) and pipe diameter to 
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the WinDes conduit number divided by 1000. (examples 0.032 indicates WinDes conduit 32).

12d can create the conduit shape by applying a template to the drainage string. The user must create a 
template with the same name as the WinDes shape number (32 for example). The templates are created 
from the main menu

Design->Template->Create Edit

For more information about template design please refer to the 12d training manual.

Once the template has been created it is applied to the drainage string to create the cross sections and 
strings to represent the conduit shape..

From the main menu Design=>Drainage-Sewer=>User=>Drainage Volume Calculations 

For more information see Drainage line excavation volume calculations.
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Drainage Excavation Quantities
Drainage_excavation_volumes_panel

Position of option on menu: Design => Drainage => Reports => Excavation Quantities

See Also

Drainage overview

This routine calculates the excavation volume for all of the drainage strings in a model. Since templates are 
used for the calculations trench shapes can be customised by depth and over excavation for bedding mate-
rials can be included. Net area calculations to exclude pipe area is not supported.
Key points
1. One template for each pipe size (mm)

2. Carefully consider the tin selected.

3. Box culverts should have their own pipe type

A template must exist for each pipe size in the model (pipe size x 1000). For example a 0.3m pipe will 
require a template to exist named 300. A 0.5ft pipe would require a template named 500. Sample templates 
are included in the courses section of 12djobs (\12djobs\courses\7.00\drainage). These may be copied to 
your *.project directory and then added to your project using Design=>Templates=>Utili-
ties=>Add=>All all to project.
The templates are run along the strings and the total volumes are reported. Volumes for each strings are 
given in the report file. An example follows.

If a tin is created from these strings then volumes by depth can be determined using Design=>Vol-
umes=>Exact=>Tin to tin

Usage

This panel is accessed from the menu selection 

Design => Drainage => Reports => Excavation Quantities

 ----------------------------- BEGIN APPLY TEMPLATE REPORT ------------------------------

  apply template to string report - 

    string         E

    tin            design

    separation         10.000

    left template  375

    right template 375

    cut volumes and areas are negative

    fill volumes and areas are positive

 chainage- ------sectional  information------  ------intermediate  information----    ---------accumulative  
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

drainage string sourve model choice box model View,model,string

drainage string selection

drainage model input box

Model to contain all of the pit and pipe network to be worked on.

Strings model model box

Strings generated from the templates will be stored in this model

Sections model model box

Sections generated from the templates will be stored in this model

Report name input box

cut and fill volumes will ne sent to this report

Ground Surface Tin tin box

tins from which the volumes will be calculated

Section separation real box

distance between the sections

Sections colour colour box

Sections generated from the templates will be assigned this colour (strings colours are defined in the 
templates)
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Pit Schedules
drainage_pit_schedule_combined_v7_panel

See Also

Selecting design string or tin?
Drainage overview

Usage

This panel is accessed from the menu selection

Design => Drainage => More Drainage => Pit schedule

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Drainage model name input box drainage network

model containing the drainage strings

Pit schedule file name input box pit report

file to be created

Report Format choice box Road chainge..,Easting...

file format

Data delimiter choice box Tab, Space

tab delimiters are best for spreadsheets and space for some text editors

Repeat header for each line tick box selected

when selected, the column headings will be printed each drainage line 

Calculate road chainage/offsetstick box selected

only used for road chainage-offset format. When selected, the road chainages and offset calculation 
panel will be displayed so that the this data can be updated before the report is generated. (see below)
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Easting Northing Location choice box pit centre, road design string

easting northing data can be from the manhole centre or the x,y location on the road design string that 
the manhole has been linked to

Cover elevation location choice box pit centre, road design string

the cover level elevation can be from the manhole centre or the elevation on the road design string that 
the manhole has been linked to (if a link has been made then these values should be the same). Note 
that the road design string data is NOT caclulated at this time. These are the vaules calculated from 
the Drainage Misc Utilities or the last drainage data export.

Process button

Create the pit report

Finish button

remove the panel from the screen

Notes:
The columns of data may be separated by spaces or a tab. (tab is used for spreadsheet transfers). The 
internal width and length data are retrieved from the drainage.4d file for the pit type specified. If you want 
a longer description for the pit then the type used inside 12d this can also be entered in the drainage.4d file. 
The remarks for each pit are entered as user defined pit attribute named remarks and may be set using the 
attribute editor (on the drainage menu) or via a spreadsheet.

Easting Northing Sample
.PIT SCHEDULE                                                             
  Pit                                INTERNAL           INLET          OUTLET                  PIT   
  No    TYPE    EASTING NORTHING    WD       LEN     DIA   INV LEV   DIA   INV LEV  FIN RL    DEPTH         
REMARKS       
   B1   SA2    5302.458 7336.936  450.000  900.000                    375   28.210   29.387    1.177                      
   A2   SA2    5264.372 7322.036  450.000  900.000    375   27.470                   28.646    1.226                      
   C1   SA2    5224.155 7336.936  450.000  900.000                    375   26.690   27.863    1.173                      
   A3   SA2    5187.910 7322.036  450.000  900.000    375   25.930                   27.158    3.628                      
   A1   SA2    5309.458 7321.100  450.000  900.000                    225   28.550   29.577    1.027                      
   A2   SA2     5264.372 7322.036  450.000  900.000    225   27.470    375   27.420   28.646    1.226                      
   A3   SA2     5187.910 7322.036  450.000  900.000    375   25.930    375   23.530   27.158    3.628                      
  A4   SA2   5157.411 7321.332  450.000  900.000   375   23.090                26.714    3.624 
outlet to existing system 
NOTE:
1. ALL SETOUT POINTS QUOTED TO CENTRE OF PIT

Road Chainage Offset Example

DRAINAGE LINE A

PITPIT LOCATION LOCATION OFFSETS

No.EASTING NORTHING STATION CTRL OFFS TYPE REMARKS

A/15354.629 7336.936 231.171 d002 -7.450

A/25340.691 7320.911 217.233 d002 8.575

A/35293.458 7320.886 170.000 d002 8.600

A/45250.131 7320.886 126.673 d002 8.600

A/55217.194 7322.036 93.736 d002 7.450
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A/65183.458 7322.036 60.000 d002 7.450

A/75152.699 7322.036 29.241 d002 7.450

Notes

The Set pit details must be run at least once to before printing the report. If the pits are moved or the 
designed strings changed then this option must re rerun.

The Road Chainage and Offset Pit Schedules use two user defined attributes for each pit. The first is ctrl 
string which identifies the string that the pit will be offset from and the second is ctrl model which 
contains the model name for the control string. These may be manually created/modified using a 
spreadsheet or the attribute editor.

The easting northing data obtained for the road design string option is obtained by dropping the manhole 
centre perpendicular onto the selected road design string. This data is stored as pit attributes setout x and 
setout y. It is calculated when the manhole cover levels are recalculated (drainage misc utulities and 
during drainage export (recalc level option must not be turned off)).

The cover elevation data obtained for the road design string option is obtained by dropping the manhole 
centre perpendicular onto the selected road design string and obtaining the elevation at this point. This data 
is stored as pit attribute level z. It is calculated when the manhole cover levels are recalculated (drainage 
misc utulities and during drainage export (recalc level option must not be turned off)).
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Attribute Editor
attribute_edit_panel 

Position of option on menu: Design => Drainage => More => Top Ten attributes editor

Most of the detailed catchment data is stored within 12d as user defined attributes. These attributes are 
automatically created by 12d when required but you are free to change them or add more as desired. The 
attributes may be exported to a spreadsheet and edited and then imported back into 12d or edited inside 
12d using this panel.

See Also

Drainage overview

Usage

From the menu select Design => Drainage => More => Top ten attribute editor

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

pick string button

used to pick the initial string in a model

string-pit-pipe choice box string,pit,pipe

select the type of attribute to be displayed. Pit and pipe attributes are only available for drainage 
strings.

attribute name input box

3 top 10 attributes lists are maintained (pit, pipe and string). The attributes that you can select from are 

First Select Pick to select the string 
that contains the user attributes (the 
drainage string). The strings will be 
highlighted in white when they are 
selected.
All catchment data is store with the 
pits in drainage strings. To access 
the pit attributes, select the drop 
down icon and then select Pit. A 
circle will be drawn around the pit 
selected. Next and Prev will now 
move you from pit to pit.
Select the drop down icon and then 
select the Attribute Name from 
the list of existing user defined 
attributes. These attributes include 
all of the attributes in the model 
that the string exists in. 
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all of the attributes that exist on all of the strings in the model. If the attribute does not exist for the 
string/pit/pipe that you are displaying the data field will display Not found.

type choice box Text, Real, Integer

for existing attributes this will display Text, Real or Integer.
When defining a new attribute select the type of data to be stored in the attribute

data input box

the data stored in the attribute is displayed/edited/created in this field. 

<= prev button

move to next string in the model
pit on the string
pipe on the string

next => button

move to next string in the model
pit on the string
pipe on the string

process button

updates the attributes displayed in the dialogue.

Notes:

First LB select Pick to select the string that contains the user attributes. All catchment data is stored with 
the pits in drainage strings. The strings will be highlighted in white when they are selected.

To access the pit attributes LB this field then select Pit. A circle will be drawn around the pit selected.

LB the Attribute Name field and then select from the list of existing user defined attributes. These 
attributes include all of the attributes in the model that the string exists in. They may not be defined for the 
string you are editing. If the string does not have that attribute defined not found will be displayed in the 
Data field.

To change the value for the attribute enter the new value in the data field. If the attribute does not exist, 
deleting the not found text and adding data will create it. The following message will be displayed 
whenever you are creating a new attribute.
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Delete All Attributes in a Model
drainage_att_delete_panel

Position of option on menu: Design => Drainage => More => Delete all attributes in a model

See Also

Drainage overview

This option deletes all model, string, pit and pipe attributes in the model specified. This option allows the 
user to "start from scratch" while maintaining the drainage, catchment and bypass flow strings.

Usage

From the menu select Design => Drainage => More => delete all attributes in a model

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

model name input box

the model specified will have all of its attributes and all of the strings attributes deleted

process button

Deletes all of the attributes

Notes: THERE IS NO UNDO!
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Flooded Width Flow Analysis and HEC-RAS
drainage_utilities_panel analyse flooded width

The Calculate Flooded width procedure creates cross sections along the bypass flow paths and then 
calculates the flooded width at each section using Manning’s normal depth calculations. A HEC-RAS 
project (same name as the bypass flow string) is also created for each line. The flooded width is indicated 
on each section as a blue line if it is less than a user defined width and a red line if the flooded width 
exceeds the limit. Details of the calculations such as the velocity, depth, wetted perimeter and slope can be 
exported to a spreadsheet for further analyse (velocity times depth calculations for example). The 
discharges imports from the urban stormwater design packages are shown in the following table.

The user defines the length of these sections and the interval at which they are to be spaced. 12d calculates 
the normal flow depth interpolating the pit approach and bypass flows from the hydrology models 
(ILSAX, Drains, PC Drains or RAT HGL). The cross sections are taken perpendicular to the flow line and 
the slope is for the normal depth calculations is determined using the distance along the flow line and the 
change in elevation between the two lowest points in the primary flow channel. The flow line need not 
intersect the low points on the section but the flow line does mark the primary flow channel. If  the depth 
of the flow exceeds the banks of the primary channel, then all adjacent flow channels will be considered as 
active flow area.

Limitations where overland flow lines join

Where overland flow lines converge at a manhole, 12d does not know the flow split between the 2 
approaching paths. Therefore, 12d uses the total flow from all lines as the flow at the manhole for each 
line. This may overestimate the flooded width along the flow lines at these points.

Limitations at SAG pits

The flow width are not shown adjacent the sag inlets. The depth of flow due to ponding and the approach 
flow coming from several directions may overestimated flooded width in these areas. Therefore not flood 
depths are caclulated approaching SAG inlets.

Design 
Program

Discharge Event

PCdrain Minor ARI
Drains Maximum flow event 

analysed
ILSAX Maximum flow event 

analysed
RAT HGL First return period analysed
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Manning’s n is the n value to be used in the normal depth calculations.

The Flow correction factor is the factor described in ARR 1987 for calculating depths of flow in gutter 
channels.

Distance between sections specifies the interval at which cross sections and therefore flooded width will 
be calculated along the flow path.

Section Length defines the length of each cross section. The cross section will be centred on the overland 
flow path.

Trim HEC-RAS sections at levee is used for super critical flow calculations in HEC-RAS. If you plan to 
do super critical flow calculations then check this box. A levee point is the crest in the cross section found 
as you move away from the flow line location. If a levee point is encountered then the section is trimmed 
here. This is a feature because HEC-RAS has problems with cross sections with levees.

Cross Sections and Discharges

The analyse flooded width will proceed along each flow path and identify every pit on the line. Cross 
sections will be constructed in the model with the length and interval entered in the input dialogue. These 
cross sections may be plotted using the main menu selection Plot=>X plot=>X plot . The Sort Sections 
must not be selected for these sections to be plotted.

Discharges will be determined for each cross section by pro-rating the discharge dependant on the distance 
between the pits. The bypass discharge will be taken from the upstream pit and the approach discharge of 
the downstream pit.

12d will give warning messages in the output window when it encounters the following conditions and 
these messages will be stored as string attributes on the flooded width strings. Descriptions of these 
messages follow.

Inverts do not go downhill

12d locates the lowest point (adjacent to the flow line without moving over a local crest) on each cross 
section to calculate the slope between the cross sections. This message indicates that the downstream 
minimum elevation is higher than the upstream minimum elevation.

Sometimes flow lines will go uphill. If you have specified an overflow from a SAG location then the flow 
line will go uphill until it crosses the overflow crest.

If the flow line is not supposed to be going uphill at this section, check to see where the flow line intersects 
the cross section located upstream of the one identified in the warning message. If it is in a local sag point 

Enter the drainage network model.

Enter the model that will contain the actual flooded width 
lines.

Enter the model that will contain the cross sections. The 
calculated values such as velocity and slope are stored with
these lines.

Select the tin that will be used to create the cross sections.

The flooded width will be drawn in blue in the results 
model when it is less than the  Max flooded width. If  the 
flooded width exceeds this value it will be drawn in red.
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that is not the lowest point on the section, move the flow line.

The program will use a slope of 0.5% to calculate a width at this location. This results in very wide flooded 
width sections to draw the user’s attention to the problem area.

Vertical Walls Assumed at the Ends of the Cross Sections

If the depth of flow exceeds the ground surface elevation at the ends of the cross section a warning 
message the warning message shown above is shown. The cross sections causing the warning follows.

The vertical wall is placed at cross section chainage –20. Note that the flow line is always at chainage 0
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Convert Drainage String to Polyline
drainage_drainage_to_polyline_panel

Position of option on menu: Design => Drainage => More=> Convert drainage string to polyline

See Also

Drainage overview

All drainage strings in the specified model are exported to a 4d ascii file. When this ascii file is imported 
back into 12d model the strings will be converted to polylines. Import the strings using

File_io=>Data Input=>12da/4da data

Specify a prefix for the model when it is read back 
in. Otherwise the strings will be placed in the 
same model as the originals.

Usage

From the menu select Design => Drainage => More=> Convert drainage string to polyline

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

drainage model name input box

Drainage model containing the drainage strings

4D ascii file name input box drainage data.4da

A temporary file that will hold the converted string data.

process button

Exports the drainage strings and converts the file to polylines.
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Drainage.4d file

A sample pit entry in the drainage.4d file is as follows:
Enhancements have been made if exporting to the Drains program. See Pit Families and Pit Groups
The drainage.4d file controls many of the settings for the pit and pipes types inside 12d. This section 
details the format of the drainage.4d file. Changes to this model take effect only after 12dmodel has been 
restarted. 

The original drainage.4d file is found in the “program file\12d\12dmodel\7.00\set_ups” directory. Do 
NOT change this file. Copy it into “program file\12d\12dmodel\7.00\user” directory and edit it there. Files 
in the user directory are used by preference and they are never over written by a 12d update.

The format of the entries is a follows.

1. All lines are to be blank or begin with //. This is not the normal 12d convention.

2. //SIZE indicates the values to be read and stored in the user defined pit attributes 
pit internal width and pit internal length when the pit schedule macro is run. A comma is used to 
separate the two values.

3. //DESC indicates that the following quoted text will be read and stored in the user defined pit attribute 
pit type description when the pit schedule macro is run.

4. The pit inlet capacity table data must begin //4d and commas are used to separate the data (comma 
delimited).

5. SAG pit names must begin with the 3 letters SAG.

6. The sample data provided is taken from the paper, “Mathematical Description of Pit Entry Capacities”, 
Feb 1992, by Geoffrey O’Loughlin et al. 

Manhole "SA2" {// internal pit size data (width, length)
//SIZE   100, 200
//DESC  "2m lintel - grate and side entry"
// pit inlet capacities from Mathematical Description of Pit Entry Capacities Feb 1992
//       cross fall,   gutter grade,  cap1,   cap2,   cap3,   cap4
//4d          1,             1,        0,       0,    0.230,  .621 
//4d          1,             3,        0,       0,    0.225,  .604 
//4d          1,             5,        0,       0,    0.215,  .577 
//4d          1,             7,        0,       0,    0.200,  .538 
//4d          1,             9,        0,       0,    0.235,  .593
 
//4d          3,             1,        0,       0,    0.495,  .819 
//4d          3,             3,        0,       0,    0.270,  .568 
//4d          3,             5,        0,       0,    0.290,  .599 
//4d          3,             7,        0,       0,    0.400,  .727 
//4d          3,             9,        0,       0,    0.330,  .649

//4d          5,             1,        0,       0,    0.540,  .793 
//4d          5,             3,        0,       0,    0.480,  .747 
//4d          5,             5,        0,       0,    0.460,  .744 
//4d          5,             7,        0,       0,    0.450,  .729 
//4d          5,             9,        0,       0,    0.420,  .704
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Two Point Dynamic Profiles
If at any time you want to obtain a temporary section view, 12d has a dynamic profiling capability (2 point 
profile). First, add your tin design model to the section view.

Next RB on the section view title area and then LB select 2 points. The following panel will appear.

Select Start_End pts to begin and then 
pick/accept a point on a Plan View Now 
as you move your cursor the section 
view will be dynamically updated (the 
dynamic box should be checked on and a 
surface tin model added to the section 
view). When you obtain the cross 
section you want LB select then accept 
(MB) the second point.

LB select Finish when done.
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ILSAX Editors
ilsax_editors

Position of menu: Design => Drainage => More => ILSAX Editors

The ILSAX editors walk-right menu is 

ILSAX Pipe/Catchment Editor

drainage_ilsax_pipe_editor_panel

Position of option on menu: Design => Drainage => More=> ILSAX editor=>ILSAX pipe editor

See Also

ILSAX Rainfall File Editor
Drainage overview

The ILSAX pipe data editor allows the user to edit pipe and catchment parameters. Most commonly used 
functions are supported but some of the less used functions are not included at this time. The same names 
have been used as those in the ILSAX drainage manual for easy reference.
Unlike the rainfall editor, all of the data in the pipe data editor is stored with the drainage string as user 
attributes. These user attributes can be changed using the editor (recommended for the novice user) or they 
may be output to a spreadsheet, changed and then read back into 12d.
CAUTION: If the drainage string is deleted then all of the attributes are deleted at the same time.

Usage

The ILSAX pipe data editor is accessed by selecting Design=>Drainage-Sewer=>More=>ILSAX Edi-
tors=>ILSAX Pipe file editor. The following dialogue will appear.
.

There are two ways to move between pits. The Prev pit and Next pit will move the user between the pits 

The panel to the left is only 
and example of what the edi-
tor panel may look like. This 
dialogue will change in size 
and complexity depending 
on the check boxes selected. 
The left side of the dialogue 
is reserved for pipe and pit 
data while the right side con-
tains catchment data. The 
first step is to select the 
drainage string to be edited. 
Click on Pick drainage 
string and then select the 
drainage string from one of 
the views.
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with the current pit name been shown in the Change pit name field. Do not use the Change pit name 
field to move between pits. It will not work! This field is used to manually change the pit name. Entering 
the pit number and pressing Enter is the second method for selecting pits. This is a good way to move 
between pits on long drainage lines (from pit 20 to pit 1 for example).
The pipe diameter will change the diameter of the pipe leaving the pit in the direction of increasing chain-
age. Note that the invert level of the pipe will remain fixed as the obvert level changes.
The most common Design mode is 1 for design. This ignores the present pipe size and resizes the pipe as 
required.
When the Inlet capacity and Bypass pit tick boxes are checked, additional fields are added to the dia-
logue. These will be discussed in the section 5.0 above
The Catchment Detailed and Comprehensive tic boxes also add additional fields to the dialogue. Again, 
the ILSAX drainage manual contains detailed descriptions of these parameters.
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ILSAX Rainfall File Editor

drainage_ilsax_rainfall_editor_panel

Position of option on menu: Design => Drainage => More => ILSAX Editor=>ILSAX rainfall file editor

The ILSAX rainfall file editor assists in the creation and editing of the ILSAX rainfall files. It is truly a file 
editor and no data is stored inside the 12d model. Most common features of the ILSAX rainfall file are 
included but some have been omitted as they have been rarely used. The files can be created using the 
editor and then manually edited using a word processor if required.

See Also

ILSAX pipe editor
Drainage overview

Usage

This panel is accessed from the menu selection Design => Drainage => More=> ILSAX editors => Ilsax 
rainfall file editor

The Rainfall file name must be specified before the Read or Write buttons will operate. If you want to 
create a file, fill in the Rainfall file name field and then LB select Write to save the data.

Intermediate Files and Separate Rain/pipe files must be ticked to have ILSAX run within 12d.

The minimum value for Num Rainfall Events is 1.

The remaining data in the left column is the data for the ILSAX R3 and R4 cards and the data in the right 
column is the data for the ILSAX R2,R6, R6B and R8 cards. Please refer to the ILSAX manual for a 
description of these values. The fields are not in the same order as the ILSAX files but instead the fields at 
the top of the column are those changed most frequently between rainfall events.

The Prev Rainfall and Next Rainfall buttons select the rainfall events up to the number specified in Num 
rainfall events. If you wish to add or decrease the number of events analysed change the Num rainfall 
events value.
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CAUTION: the Finish button does not perform a save so make sure you click Write before Finish.

The fields and buttons used in this panel are described in the ILSAX users manual.
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PCdrain to 12d pit converter
Drainage_pits_pcdrain_to_12d_panel

Position of option on menu: Design => Drainage Sewer => More=>Create Pit type from PC Drain gully 
files

This option is used to read a PCdrain gully file and create the same pit type in the 12d drainage.4d file. The 
sag pits in the gully file have an "S" added as a suffix as they are imported.

Important: 12d must be restarted to see the new pit types.

See Also

Drainage overview

Usage

This panel is accessed from the menu selection Design => Drainage Sewer => More=>Create Pit type 
from PC Drain gully files

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

PCdrain pit file file box

the PCdrain gully file to be imported into 12d

Process button

import the data file

Finish button

removes the dialogue from the screen
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Drainage Network Quantities
Drainage_quantities_panel

Position of option on menu: Design => Drainage => Reports=> Network Quantities

This option creates quantity tables for manholes, pipes and house connections.

The manholes/pipes/house connections are summarised by user defined depths and types.

See Also

Drainage overview

Usage

This panel is accessed from the menu selection 

Design => Drainage Sewer => Reports=> Network Quantities

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data String Source Choice

usually the entire model is selected but view is also available for combining models

MH config file file box

This file specifies the types and depth ranges for the manholes. Details of this file are contained below.

Pipe config file file box

This file specifies the types and depth ranges for the pipes. Details of this file are contained below.

HC config file file box
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This file specifies the types and depth ranges for the house connections. Details of this file are con-
tained below.

HC pit config file file box

This file specifies the types and depth ranges for the HC pits. Details of this file are contained below.

HC jump ups file file box

This file specifies the types and depth ranges for the house connections jump ups. Details of this file are 
contained below.

Report file file box

a sample report file is given below.

Report unused ranges tick box

the depth ranges for the manhole/pipe/house connections are defined in the *.4d files. Selecting this 
option will cause the depth ranges in the file to be printed even if there are no manhole/pipe/house con-
nections in these depth ranges (zero quantity values will be shown).

Report types tick box

Selecting this option will cause the manhole/pipe/house connection types used in the model types to be 
listed (even if quantities are not requested in the *.4d files). Since this is a complete of the type used in 
the model, the list informs the user what types have not been included in the quantity calculation.

Count button

executes the option.

Finish button

removes the dialogue from the screen

The *.4d files listed above are contained in the 12d library directory. Each line is the file performs a count 
(count lines). No items are counted twice. Therefore, if an item is counted its type and then a count line is 
found the wild card is used for the type, the type already counted will not be included in the count.

The format for a count line is three or four values (space delimited) per line. Size is optional.

<type (from drainage.4d)>  <size> <starting depth>   <ending depth>

Notes:
All types with spaces in the name must be enclosed in quotes The wild card * may be used.

The size is optional and if omitted the all sizes will be counted in this group (do not use the * for a wild 
card). 

The starting depth and ending depth are required for all count lines.

Sample count lines for manholes follow. 
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// sum concrete cover manholes is various ranges

"CONC COVER" 0.0 1.6
"CONC COVER" 1.5 3.0
"CONC COVER" 3.0 999.9  // this is expected to be zero
"CONC COVER" -999.0 0.0 // trap errors

// any that are not Concrete cover will be counted here

* 0.0 1.6
* 1.6 3.0
* 3.0 999.9

Sample count lines for pipes follow. 

Manhole Quantities
====================================

CONC COVER          0.00    1.60    13      16.506
CONC COVER          1.60    3.00     1       1.510
CONC COVER          3.00   999.9     0       0.000
CONC COVER        -999.0     0.0     0       0.000

*                     0.00  1.60     0       0.000
*                     1.60  3.00     0       0.000
*                     3.00 999.9     0       0.000

  total length = 18.016

  Types Used
  ----------

  CONC COVER

  Diameters Used
  ----------

  1.100

 

Since the Report unused ranges 
tick box was selected, these lines 
were printed even though there 
were no manholes in the data 
ranges.

This data results from selecting the 
Report types tick box.
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// sum class 2 pipes by diameter and for various ranges

// count 375

2 0.375 0.0 2.0
2 0.375 2.0 5.0
2 0.375 5.0 999.

// count 450

2 0.450 0.0 2.0
2 0.450 2.0 5.0
2 0.450 5.0 999.

// count 525

2 0.525 0.0 2.0
2 0.525 2.0 5.0
2 0.525 5.0 999.

// count pipe sizes that were missed

2 * 0.0 2.0
2 * 2.0 5.0
2 * 5.0 999.

// count all other missed pipes

* 0.0 999.
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Calc pit overflow areas
Drainage_pit_volume_panel

Position of option on menu: Design => Drainage Sewer => More=>Calc pit overflow areas

This option is used to graphically display the overflow storage volume at a sag pit. The following pit 
attributes must exist for the flood extents to be calculated.

overflow volume value greater than zero required.

sag pit must be equal to 1.

catchment model id set by labelling catchments

catchment string id set by labelling catchments

The maximum storage volume is read from the drainage pit attribute "overflow volume". This may be 
entered manually using the Attribute Editor or it will be created when data is read from the drainage 
design programs Drains or XP SWMM design programs.

This routine locates the lowest point on the catchment string by draping the string on the tin specified and 
adds the overflow limit specified to this value. This becomes the overflow limit.

The volume at this level is calculated and the compared to the overflow volume read from the user defined 
attribute.If the overflow volume is less than the volume in the catchment then the routine iterates to find 
the flood level for the overflow volume.

If the overflow volume is greater than the volume in the catchment, the results repend of the  Use overflow 
limit tick box. 

If the box is selected, the overflow limit (calcuated above)is reported at the flood level in the catchment.

If the tick box is not selected the routine iterates to find the flood level where the storage equals the 
overflow volume read. This option allows the user to see the maximum flood level should the catchment 
low point become blocked.

See Also

Drainage overview

Usage

This panel is accessed from the menu selection Design => Drainage Sewer => More=>Calc pit overflow 
areas

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Drainage model model box

all pits in this model that have a non zero "overflow volume" and "sag pit" set to 1 will be processed

Flood limits model model box

flood limits strings will be created in this model

Surface Tin tin box

ground surface tin used to calculate the volumes and flood limits

Flood limits colour colour box

flood limits strings will be created using this colour

Clean limits model tick box

if selected all strings in the Flood limits model will be deleted before the calculations commence.

Use overflow limit tick box

if the elevation calculated from the storage volume is higher than the lowest point on the catchment 
string then the allowable surcharge value below will be added to the lowest point on the catchment 
string and this elevation will be used to determine the flooding limits

Allowable surcharge real box

this value is used only if Use overflow limit is ticked. Its purpose is described in the field above.

Process button

executes the option.

Finish button

removes the dialogue from the screen
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Stormwater Design - Introduction
The 12d drainage module contains functions to perform the following steps in the drainage design and 
documentation process:

s set drainage defaults and layout a drainage network,

s use the powerful 12d drainage network editor to avoid service clashes, grade pipes, align oberts, 
minimise depth and many other design tools,

s automatically assign names to the pit/pipes in the network,

s designate catchment areas and produce catchment plans,

s transfer data to and from electronic spreadsheets to enable the user to easily review the data and add 
user defined data to the 12d pipe network. This data may include such data as pipe bedding types 
and trench width,

s create pit layout schedules to export to spreadsheets or word processors for final formatting.

s produce long section drainage profiles including HGL data, flows, invert levels, service crossings

s create plan drawings with pipe sizes, flows, manhole symbols, linestyles for pipe sizes, design 
parameters for manhole and pipes and user defined data

s locate pits/manholes at exact chainage and offset locations

This user manual will lead the user through the steps itemised above.

In addition to this manual there is the Advanced Stormwater Design training manual which includes the 
following topics.

s drainage trench exvavation volume calculations

s pipe and manhole quantity calculation

s customising the drainage.4d file

s design or evaluate the drainage system using 12d Drainage or create input files for the XP SWMM/
RAT2000, Micro drainage, Drains and PCdrain drainage design packages,

s read the output from the drainage design packages (automatic if using 12d Drainage), update the 
drainage network and store the hydraulic data, such as hgl (hydraulic grade line) levels, peak pipe 
flows and pipe capacities,

s pit inlet capacity calculations and over land flow

s flooded width analysis

s surcharge volumes at SAG pits

s and detailed drainage plan labelling

The terms pit, catch basin and manhole are used interchangeably throughout this document. The type, 
dimensions and inlet capacities of the structures are set in the drainage.4d file.
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Setup Files and Their Locations
The drainage module consists of the optional 12d Drainage engine, utilities, startup configuration files for 
RAT2000, XP SWMM and the 12d drainage configuration file (drainage.4d). Demonstration versions of 
Drains, RAT2000 and PCdrain have been included on the CD along with a copy of the ILSAX hydrology 
package. Manuals for the ILSAX program may be obtained from the Civil Engineering Department at the 
University of Technology Sydney.

All setup files have been configured for the training version. However, when you start working on real 
projects you may want customise the drainage module. More - Customising the drainage module

The drainage.4d file contains pipe types (RCP, Class 2 etc.) and example pit inlet capacity tables for RTA 
(NSW Road and Traffic Authority) standard pits. Detailed pit type descriptions and internal pit dimensions 
can be included in this file to be inserted into your pit schedules. For PCdrain users there is a routine to 
read your gully pit file and include these pit types in 12d More.

REVIEW THIS DATA CAREFULLY! The drainage.4d file may be customised for any additional inlet 
capacity data you may have.

To edit the drainage.4d file, from the main menu select

Design->Drainage-Sewer->More->Edit drainage.4d

Select the Find button to search the 12d path for the 
current drainage.4d file. Select the More info button 
and then Edit to edit the file.
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Survey data and design surfaces (TINs)
We will begin a 12d project from scratch by first creating the project and then reading in the survey design 
data. The design can then be triangulated so that we have a final surface profile to design the drainage for.

Start up the 12d model by selecting the courses icon from your desktop.

The project selection panel will appear. The bottom corner of the panel is shown below

Note: If you are using the practice version the folder will be: 

C:\12d Model v7.00 Practise\courses\7.00

12d works with a folder NOT a single file. Therefore, to open the folder we are going to work in, double 
click the Drainage folder and then select Open.

LB select the icon and the following panel will appear.
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In the Project field type the name for your new project an then select Proceed. 12d will create a sub folder 
with this name. All of the 12d files that you should not touch will be created in this sub folder. Please stay 
out of the sub folder. All files created for the user will be kept in the folder that you opened (i.e. 
c:\12jobs\Courses\7.00\Drainage).

Importing the Raw Survey Data

You have created a new project into which we will import the survey data. From the main menu select.

File I/O => Data input => 12da/4da data

To add all of the data to the view select Menu icon in the plan view title area and then from the drop 
down menu select

LB select to display the file list. 
Select the file existing survey.

Select Read to read the data 
then Select Finish to remove 
the panel

Models=> Add all models

or

select this “+” icon and select existing survey data.
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The view will contain survey data.

Creating the existing Ground Surface

From the main menu select

Tins=>Create=> Triangulate data

Next select Fit on the plan view title area. You should see the following data. 
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Now we are ready to look at the existing surface tin. Place you pointer over the “+” sign on the plan view 
title area and press the t key. All of the models beginning with lower case t will appear. Double click on 
tin existing survey to add it to the view.

The tin will be shown with the tin edges turned on. This is the default when you have all tin display modes 
turned off. Let us now turn on the fast contours and the fast flow arrows. Select Toggle on the plan view 
title area and then LB on Tin contours. The contours will be shown on the view. LB Toggle on the plan 
view title area and then LB on Tin flow. Now the flow arrows will be shown on the view.

To change the contour intervals and the contour colours select the Menu button on the plan view title area 
and then select.

Settings=>Tins=>Contours and the following dialog will appear.

Select the View button

LB select then LB the view to be triangulated. 

Type a new tin name, not the model for the tin. 
Remember a tin is like a string and it must reside in a 
model. Press enter and the Model for tin field will be 
filled in for you.

Select if creating a tin with contour data.

Preserve strings will make the string one side of the 
triangle thereby preserving the levels along the string

all duplicate points are removed from the tin database

The cell method is a good enhancement for data that is 
in a grid type pattern but it is not required.

Select Triangulate to create the tin. 

Select Finish to remove the panel from the screen.
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To change the length and the colour of the flow arrows select the Menu button on the plan view title area 
and then select.

Settings=>Tins=>Flow Arrows and the following dialog will appear.

Inquiring about Heights on the Surface

The elevation anywhere on the tin can be obtained by simply moving the pointer over the desired spot. To 
obtain the tin elevations select,

Tins=>Inquire=>Height

You will see that data in the panel change as you move the pointer around the screen,

Turns the contours on or off

Minor contour interval.

Value for first bold contour (usually 0)

Minor contour colour.

Major interval.

Major contour colour.

LB to observe the new settings on the view.

If you like the settings LB on finish to remove 
the select.

A length of about 2 units looks very small 
now but it is good when you are zooming 
into the actual catchments.

LB to observe the new settings on the view. 

If you like the settings LB on Finish to 
remove the panel.
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Viewing the Surface Tin in a 3d Perspective

To create a 3d perspective view select

View=>New=>Perspective and a persective view will appear.

Add the model tin existing surface to the view and then toggle the shading on. You may also want to 
toggle the contours on as well.

Now remove the tin from the view as it is not needed for the next steps (Hint: use the “-” button).

Reducing the number of points for the 12d Practice Version

We can delete the survey data to save space for those using the practice version of 12d. If you have a full 
version of 12d this is not required. From the main menu select.

Models=>Delete=>Delete a Model and the following dialog will appear.

Importing the Road Design Data and Creating the Design TIN

Repeat the process of importing the 12da data.

File I/O => Data input => 12d ascii

(file is road design.12da).

Remove all of the models from the view and then add the road design models onto the view.

Road Centrelines
Road Strings
Road sections

Now create a new tin called design using the TINS->Create->Triangulate data option.

Nulling the long Triangles

Add the tin that you just created onto the view. Toggle the tin contours off and the tin flow off. Now 
toggle the tin edges on. Notice the long triangles around the edge of the design.

To remove the long triangles select

Tins->Null->by angle/length

LB then select the model existing survey data and then
LB to delete the model and then Select yes to
confirm the deletion.
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Select the design tin and then select Null. Using the default values removes most of the long triangles. 
Note that this option removes triangles from the outside inwards and it stops whenever it reaches a 
breakline.

Now reduce the Length value to 1 and then select Null again. Any exterior triangles with a length greater 
than 1 have now been removed!

Creating a Super Tin from the Survey and Design Data.

To create a tin that is the combination of the survey data and the design data you will need to create a super 
tin. From the main menu

Tins=>Create=>supertin
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Changing the Colour of a Tin

Enter a name for the super tin and press Enter.

The model field will be auto completed for you 
because you pressed Enter above. A new model 
will be created.

Now select the tins to combine. Tin 1 is the tin 
on the bottom (like the levels in a building) and 
tin 2 is above. i.e. wherever tin 2 exists it will be 
used. If there is no tin 2 at a location then tin 
1will be used.

Select the tins using the icon and then 

click Create to create the supertin.

To change the colour of the design tin use

Tins->Colour->Colour of tin

Select the design tin and choose a new colour and then select Col-
our to change the tin colour (you may have to do a Menu-
>redraw on the view to see the new colour).
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Drainage Layout
Where a drainage designer chooses to start their design is a depends a great deal on the project and the 
designer. Identifying overland flow routes is essential because it is on these routes that the manholes are to 
be placed. Inlet manholes are then placed at critical locations (sag points, upstream of pedestrian crossings 
etc.). and then the spacing of additional manholes is determined by the size of the catchments. Finally, the 
pipe drainage system can be created linking the drainage manholes.

However, during training, most users want to get straight to the manhole and pipes. Therefore, lets import 
a pipe layout that was drawn in AutoCAD along with the overland flow routes and catchment areas (These 
could have been created in 12d as well). When these were drawn the following rules were followed.

1.polylines were used
2.lines drawn from upstream to downstream (direction of flow)
3.a vertex was placed at every manhole location

From the main menu select

File IO->Data Input=>DWG/DXF.

The models that have been created are,

dwg d catchments
dwg d overland flow
dwg drainage network

Remove all of the models from the view and add the model dwg drainage network. This is a 2d drainage 
layout that we will use to locate the manholes in our drainage design.

Setting Drainage Defaults

The defaults for the drainage network are accessed through three panels; pipe defaults, manhole defaults 
and Tin defaults. They may be accessed through the menu system as 

Design =>Drainage-Sewer =>Defaults

Verify setting as dwg

Select the dwg file (drainage data.dwg)

Entering a prefix for the models will help organise the 
layers that will be read from AutoCAD. Every layer goes 
into a separate model in 12d. If you specify a prefix then 
all of the layer names will be prefixed with this text.The 
prefix used is dwg<space>.

There are many optional settings not required at this 
time.

The rest of the data can remain as the default value. Refer 
to the Help button if more detail is desired.

Select Read to import the data.The data will not imme-
diately appear on the plan view. The new models have 
to be added to the view using the “+”  on the view tool 
bar. Every time you press the Read button the data will 
be imported again and you will get duplicate, tripli-
cate...etc data. 
All of the models imported will begin with dwg.
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Warning! You must click the Set button to set the default values. Finish alone will not set the defaults. If 
you plan to export to other drainage software packages you will have additional defaults to set before you 
export. See Drainage Import/Export.

Tin Default

Warnings about using tins. If you place a manhole outside the tin boundary:

s then no elevation will be set for the top of manhole, (it can be set later manually or by linking it to a 
design string).

s Pipe invert levels cannot be set using the default cover. Pipe invert levels must be set manually as 
12d cannot automatically determine cover levels without a TIN.

s Finally, if your drainage design package accepts surface levels along the string, then an error mes-
sage will be displayed at export time. The message will say that the surface level string is shorter 
than the pipe length.

Manhole Defaults

The drop will be used to set the invert level of the outlet pipe relative to the invert level of the inlet pipe. 
The drop should always be entered as a positive value.The network editor has many more options for 
aligning the pipe inverts at the manholes.

Generally, do not use a default name. Leave all of the manholes unnamed and then use the Set Pit Names 
function on the drainage network editor.

The manhole type is selected from a list by selecting the icon beside the Type. This list is obtained from 
the drainage.4d file. This manhole type will be used by ILSAX, PCdrain and RAT-HGL, RAT2000 and 
XP SWMM to identify the inlet capacity of the manholes. This value is not exported to the Drains program 
but it will be imported after a Drains design run. See Drainage Import/Export. It is best to set this to the 
most common manhole type and then change the few that are different later in the network editor.

You must click the Set button to set the default values. Finish alone will not set the defaults.

The default TIN is used to set the initial setout level of 
the manhole and the pipe invert levels. Super tins may be
used if you want to place manholes on both the existing 
and the design ground surface (see Creating Super tins).
Select the icon to choose from a list of existing TINS. 
Note that the panel will list the tins not the models that 
contain the tin. Remember a tin is like a string. It has a 
name and is stored in a model.

The manhole diameter is specified in metres/feet 
not mm/inches. Although most stormwater man-
holes are rectangular, 12d uses circular manholes to 
eliminate problems showing the alignment of the 
manhole. If the actual size and orientation of the 
manhole need to be drawn on the final construction 
drawings a symbol may be used in the use drainage 
plot annotations. The actual internal manhole 
dimensions and a detailed manhole description can 
be added to your drainage.4d file so that they can be 
added to your manhole schedules.
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Pipe Defaults

Allowing for Pipe Thickness

When 12d set the pipe inverts it checks the minimum cover from the obvert of the pipe to the finished 
ground surface at both manholes. If the grade of the pipe is less than the minimum grade, the grade of the 
pipe is increased. Finally, 12d checks if there is anywhere along the pipe length that has less than the 
minimum cover. If there is such a low point in the design surface, the pipe is shifted vertically downwards 
to achieve the cover required. 12 defines cover as

Cover = surface level - diameter - invert

Therefore, an allowance for pipe thickness may be added to the minimum cover.

When using the network editors to change the pipe diameters the invert levels will remain fixed and the 
obverts will change. The inverts may be reset using Regrade Network on the network editor.

Select the drop down icon beside the Type field to select from a list of pipe types. These pipe types will be 
sent to your drainage design package so make sure you use the same names in 12d as you plan on using in 
the design package. The list of available pipe types is set in the drainage.4d file.

You must click the Set button to set the default values. Finish alone will not set the defaults.

String Colour and manhole Label Text Size/location (string defaults)

12d can automatically label the manholes at a fixed offset from the manhole using view text OR you can 
use the network editor Set Catchments to create text labels that can be moved/rotated etc.

For view text, the default line colour and text size are set by selecting Utilities =>Defaults. The following 
panel will appear.

The pipe diameter is set in metres or feet not mm or 
inches. Set this to a minimum pipe diameter for your 
project and then your drainage design package can 
increase them if required. To model an existing system 
enter the most common pipe size and then alter as 
required in the network editor.
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Create the drainage strings from the dwg strings

12d will convert the import strings into 12d drainage strings. The default pipe, manhole and tin data will be 
used to set the levels for the network

LB to set the colour of the drainage string and man-
hole labels.

The default size of the text is set in the Text height 
(pixels) field. A text size of 6 to 8 pixels is generally 
adequate. Your choice will depend on your screen res
olution and the age of your eyes.

Select Set
Select Write
the following panel will appear.

Selecting Current folder will save ALL 
these defaults for projects in this working 
folder only. The defaults set in the user or 
setups directories will not be used if you 
select this option.

Selecting User folder will save your 
defaults so that all other 12d projects will 
use this defaults. This is the most common 
option (unless your network administrator 
has not given you write access to this area 
(check Properties).

Select Write then Finish
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From the menu select

Design->Drainage-Sewer->More->Create drainage from strings

The following panel will appear.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source choice box model view,model,string

data source for strings to be converted

Select input box

Model containing strings to be converted

Drainage model model box

The new drainage strings will be added to this model. If it does not exist it will be created.

Finished surface tin tin box

This tin should be the same as your tin default for the drainage strings.

Outfall manhole number real input box

The network will be numbered using a numerical method. The most upstream manhole of the outlet line 
will be assigned this manhole number. This numbering system can be changed if desired. 

Process button

Coverts the strings to the drainage strings.

Finish button

Removes the panel from the screen.

Important notes:

The imported strings must be drawn in the direction the water flows.

Manholes are created at all vertices on the strings. 

Trunk lines must have a vertex where the branch lines join.

Integer string names can be used to control the order in when the drainage lines are numbered. These 
names will be transfered to the 12d drainage strings. Naming the strings is highly encouraged.

The drainage lines must have string names to use the Set Pit Names feature on the network editor.
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Manholes can always be renamed in 12d after the import is complete.

 Drawing the Drainage Network in 12d

The following method of drawing the drainage pipe systems has proved very efficient in the past. 
However, many people will have their own, “tricks of the trade”. Therefore, the rational behind the 
following procedure will be important for the user to understand when they want to try out their own 
procedures.

Key Points

1. Draw the pipes where they actually are! Do not place the manhole centres at the setout point and have 
the pipes in the wrong location (pipe cover will be affected). Use setout strings for setout points!

2. Draw all drainage lines in the same direction. Either all uphill to downhill (flow in the direction of 
increasing/ascending chainage) or downhill to uphill (flow in the direction of decreasing/descending 
chainage). You choose but they all must be the same.

If you choose descending chainage then you must select Pipe=>Default Grading then Grade to have 
the grading applied to the drainage string.

The 12d drainage network editor and the drainage design software packages have sophisticated algo-
rithms to set pipe inverts as well. Consider this grading a preliminary estimate.

3. Begin creating the smaller branch lines before the trunk lines and terminate the branch lines where you 
plan to join the trunk line. This method ensures that when the trunk line is laid down, it will be low 
enough to accept flows from the branch lines. If you decide to create the trunk line first, you will have 
to select the Regrade Network later to adjust its levels.

Flow in the Wrong Direction

The direction of flow is used by 12d to determine where the outlet is on the drainage line. 

Also, the Drainage=>Plot=>Plan annotation option can be used to label the network with the direction 
of flow.

The direction of flow will be indicated with the arrow when using the Drainage Network Editor 
and you have selected an manhole (all but the outlet). 
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If one of the arrows in the plan annotations is going in the wrong direction then the direction of flow flag 
must be changed. From the main menu select

Strings=>Properties=>String

and change the Flow direction to the other value (there are only 2 options). You may replot the 
annotations if you want to confirm the change.

Manhole Setout Point, setout strings and selecting the location for the manhole centre

The centre of the manhole (x,y and z) need not be the manhole setout point used in the setout tables.The 
setout location can also be set independently of the level. It is recommended that you place the manhole so 
that the pipes are shown in the desired location and then use the desired option for setout. The default 
settings for the manhole setout location are found on the network editor-defaults-pits-setout data.

Key Points in Using Setout Strings

1. Enter the road models and the strings names (identifies) via the Network Editor, Global-Utility Mod-
els tab, Road design file.

2. Specify that these strings are to be used. Select Setout string for the XY or Z setout modes on the 
Defaults->Pits setout area or Pits->Setout tab.

3. Select the Set Pit Details button.

Select the 
drainage 
model.

Enter a model 
for the plan 
annotations.

Select Plot on 
the bottom of 
the panel and 
then add the 
model to a 
new plan 
view.
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X,Y Option 1 Manhole Centre

The x,y location will be the centre of the manhole.

X,Y Option 2 Road Centre Line

The road chainage and offset are measured perpendicular to the road centre line out to the manhole centre 
or setout point.

X,Y Option 3 Setout string

The manhole centre is dropped perpendicular onto the set out string to obtain the x and y.

Z Option 1 FS tin

The manhole setout level is obtained from the finished surface tin at the manhole centre.

Z Option 2Setout String

The manhole centre is dropped perpendicular onto the setout string and the level is obtained from the 
elevation on the string.

Example

In the diagram below the setout point is lip of kerb. The setout x,y location level z will be obtained from 
the setout string and the pipe will be shown at its proper position.

Location

Road Centre Line

Road Chainage and offset

Setout String

x y from setout string

Manhole Centre

x y at manhole centre
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Creating the Drainage Strings in 12d

Drainage strings can also be created in 12d. A drainage string is created by selecting 

Design =>Drainage-Sewer =>Create

Each drainage string in the model must have a unique Name if you plan on using the Set Pit Names option 
after all of the strings have been drawn. The name of the string should be kept short, <B> for example, as 
it will be used as the prefix or suffix for the manhole names. Examples of manhole naming schemes 
available for a string labelled, <B>, are B1, B2, B3 … ,or 1B, 2B,3B…or 1/B,2/B, 3/B… etc.

Sequential numbering all of the manholes (1,2,3 etc.) is also an option. The manholes on the string named 
1 will be labelled first and then 2 and so on. If you insert a new string with a name in the middle an existing 
series (i.e. add a new string 2 when strings 1,2 and 3 already exist) then name the new string 1.1 (for this 
example) and then use the Strings=>User=>Set String Name by number command.

Drainage String Create Panel

Flow direction should be ascending chainage if drawing uphill to downhill or descending chainage if 
drawing downsteam to upstream. All of the strings in the model can have their direction changed later 
using the Design=>Drainage-Sewer=>More=>Reverse all strings command.To graphically check the 
flow direction of all strings see Flow in the Wrong Direction.

The Tin (fs) field will be completed for you with the default value you entered in Design=>Drainage-
Sewer=>Defaults=>Tin(fs). The finished surface levels on your long section plots will be obtained from 

TIP: If you have already created a drainage string, click 
the Same as button and select the drainage string to 
obtain the panel values from that string. After selecting 
the string, change the string Name. 

For auto manhole naming, every drainage string must 
have a different name.

All drainage strings for the one outlet should be in the 
same model. Only drainage strings should be created in 
this model. If the model does not exist it will be created.

Colour will be the colour used in the drainage longsec-
tion drawings.
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this tin.

The Tin (ns) field is optional. By specifying a natural surface tin, natural surface levels can be shown on 
your drainage long section profiles.

Selecting Many strings will have the panel re-appear, ready to go again, after creating each string.

Click the Create button to begin creating the drainage string. The following panel will appear.

Click and accept the point labelled B-1 and then click and accept the point labelled A-2. Since this is the 
end of the branch line, select Finish from the Drainage Edit panel. If you have other edits to make to the 
string do not select Finish yet (i.e. set some specific invert levels) RB then select Cancel from the menu. 
This will leave the edit menu active for further changes.

The Create Drainage String panel will appear again for you to create additional drainage strings. 

Create line C in a similar fashion. When this line is finished, start on line A but only place the first 
manhole, A-1. manhole A-2 is a junction manhole and requires some special attention.

Exact Methods for Placing Manholes

To place your manholes on a kerb line string, turn the line snap on and the point snap off,. Keep the 
height snap off.

For locating manholes at specific x, y coordinates, simply start typing the x coordinate instead of clicking 
onto a location. An input panel will appear for you to enter the x and y coordinate separated by a space.

To create your first manhole, select Edits =>Append. A + will appear with 
your pointer.

We are going to place our manholes on the vertices of the layout that we 
imported. Toggle the vertices on (just to help you see where the manholes are 
going to be placed), turn your line snap off and the point snap on.

The first line we will create is the branch line on the east (Line B) then the 
branch line to the west (Line C) and finally the trunk line running from east to 
west (Line A). The drawing below shows the manhole names. You will not see 
these as you draw the strings but we will create them later.
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To place the manholes at a specified distance from a point use the RB and select SNAPS 
COGO=>Locate=>Offset. Follow the prompts given in the message area (bottom left corner of the 
screen). You will need experience with the 12d “directional pick” to use this capability.

Junction manholes on Trunk Drainage Lines

Key Points

1. The branch line must Point Snap onto the centre of a manhole on the trunk line.

2. All strings must be in the same model.

Trunk drainage lines are created the same way as the branch lines except special care must be used when 
placing the junction manholes. When placing the junction manhole on top of the branch line turn the point 
snap on and the line snap off (the F3 and F4 keys are convenient for this). Zoom into the branch line 
junction manhole so that you can snap onto the centre of the manhole. 

A manhole contains three points; one at each point where the pipes join (invert level points) and the one 
you want to snap onto at the centre of the manhole (setout level point). In the figure below, the blue line is 
being placed to join the magenta line. Note that the diamond indicates that there is a point snap and the 
information panel indicates that we are snapping to line 2. The information panel also indicates the snap 
was a point snap.

After snapping onto the branch line manhole click Prev on the plan view title area to return to the 
previous view and continue appending manholes.

You can tell that you have created a junction manhole correctly when you profile the trunk line and you 
can see the branch lines joining at the junction manhole. If the branch lines are not shown then one of three 
things have gone wrong.

1) centre of the manholes did not align, Use Strings=>Points Edit=>Move to move the 
branch string manhole

2) the “downstream end” of the branch line must be the junction manhole. With the direction 
of flow for the string set to “Ascending” the junction manhole must be at the high chainage 
end of the string. If the direction of flow for the string set to “Descending” the junction 
manhole must be at the low chainage end of the string. To check the flow direction see Flow 
in the Wrong Direction.

3) The branch string and the trunk string have not been created in the same drainage model. 
From the main menu select Strings->Inquire (F2) and select the strings to check their 
models. If this is the problem, use Strings=>Edit=>Change and specify the correct drain-
age model (enter the model BEFORE picking the string) or Strings=>Edit=>Duplicate to 
duplicate one of the strings into the correct model.
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Drainage Section Views and Plots in the Wrong Direction

If the section views and the profile plots are running downhill in the wrong direction, the reverse function 
may be used to change the direction.

To reverse only one string, from the main menu select

Strings =>Strings Edit =>Reverse

and pick the drainage strings to reverse. This will also change the drainage flow direction attribute from 
ascending chainage to descending chainage. 

To reverse all of the strings in a model select the Strings Reverse option,

Design =>Drainage-Sewer =>More=>Reverse all strings

To confirm the direction of flow see Flow in the Wrong Direction
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Drainage Network Editor
The drainage network editor is used to automatically or manually change the attributes of your drainage 
network. These abilities include:

General

s Setting manhole names

Hydrology

s Catchment Areas

s Checking the Automatic Catchment Linking

s Global and Defaults Tab

s Drainage Templates

Hydraulics

s Outlet and Tailwater Conditions

s

The drainage network editor is accessed through the main menu by selecting 

Design=>Drainage-Sewer=>Network Editor.

The bottom section of the network editor panel is shown below.

The manhole that was selected is highlighted with a circle and an arrow shows the direction of flow (see 
image below).

To begin select a 12d drainage manhole that is in your drainage model. 
You must pick and accept the manhole and not the pipe! Pipes cannot be used to pick the 
network!
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The option buttons on the drainage editor now become active.

Setting manholes names (and pipes)

If your network was created from 2d strings the manholes will be named incrementally using integer 
numbers. Use the drainage network editor to manually change explicit ones or quickly change all the 
names using a different naming method. 

The manhole names are based on the string names so make sure the string names are set. To view string 
names on the plan view, go to the Plan View tool bar and select Toggle=>Names. If they do not appear see 
Displaying View Text. The string names may be changed using String->Strings Edit->Change. When 
using this function always....

Enter the new name BEFORE selecting the string!

Select Set Pit Names and 
the following panel will 
appear.
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Displaying View Text

After you have named the manholes in your network, the names should appear beside each manhole in the 
plan views. If they do not appear check the following. 

After you have named the pits in your network, the names should appear beside each pit in plan. You can 
change the text size for each string by selecting Strings=>Editor and then pick-accept the drainage string. 
The text size is set from the selection Utilities=>Size.

The offset from the pit is set by selecting Strings=>Properties=>Strings, picking the drainage string and 
setting the values for Delta x, and Delta y.

Note: Auto pit names are NOT shown in the section view.

Trouble shooting auto pit names not being displayed
Problem Solution

Plan text is toggled offselect Toggle on the plan view title area 

Small text is turned offselect the Menu button on the plan view title area and select Settings =>Text => 
Text

 - if these values are too large the text will not appear on the screen. Either decrease these 

Field descriptions

After selecting the desired naming method 
and options.

Select Run to change/assign the manhole 
names. These names should be visible on the 
plan view with the drainage network model. If 
they do not appear, see the section below: Dis-
playing View Text

To create larger text labels that can be moved 
see Labelling the Manholes

Select Back to Editor to remove the panel.

Check that the Text is toggles on. If it is on then walk right and ensure the 
text is turned on or n/a for your drainage network.



12d Model Reference Manual

Page  2008 June 2002More Drainage

values or increase the text size.

string text size is 0Each drainage line can have its own size of the text. To change it, select 
Strings=>Editor then pick-accept the drainage string. The text size is set from the 
selection Utilities=>Size. If this is set to zero the labels are not drawn.

Labelling the Manholes and Pipes

To label the manholes and the pipes use Drainage Plan Annotations. This may be accessed from one of 
three locations. From the plan toolbar

or Design->Drainage-Sewer->Plots->Plan annotations
or Plot->Plot and ppf editors->Drainage plans
or from the Drainage Network Editor - Plot Button

Note (The following panel has been reduced in size).

Select drop down and change to full

Quick threshold and None threshold if these values are too 
large the text will not appear on the screen. Either decrease 
these values or increase the text size.

Select the plot button and 
then Drainage plan
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Option 2 is to select the Drainage Network Plot Button, the following panel will be displayed.

Select your 
drainage 
model

Enter a model 
name for the 
new labels

Select Plot

Now add the 
drainage 
labels model 
onto the plan 
view.

This plot will plot both the long section 
and plan at the same time. Select a ppf 
file from the library.

Enter a model for the plan annotations.

Select Clean model beforehand if you 
have not manually moved any of your 
manhole labels.

Turn off the long section plot for now.

Select Plot.

Now add the Model for plan 
annotations onto the plan view.
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By default, the manholes are labelled with the name, chainage, depth and size. The pipes are labelled with 
their size in mm, the invert levels and the normal direction of flow. The text properties can all be 
customised using the plot parameter file but this will be discussed later in the plotting section.

These labels are not automatically updated when you change the names or pipe diameters. You must rerun 
the labelling routine to update the labels.

Turn off View Text Manhole Labels

To turn off the automatic view text manhole labels for this view select Toggle=>Text and then walk right to 
select the drainage model. Do not click on Text, rather walk right. If you click Text you will toggle on/off 
all of your text on the view. Not just the drainage model.

Moving Text

The labels created may be manually moved using the CAD toolbar but if the model is relabelled the text 
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will return to its original location! Text moved via the Drafting->Multi string translate will remain in the 
moved position when Smart Clean is selected in the Plan Annotation panel.

To move a pre-defined Group of text select

Drafting->Multi string translate

Catchment Areas

Key Points

1. Start near the manhole for auto linking.

2. Manual linking available via Network Editor->Catchments->Pick button.
Disable the auto selection of a string via Right mouse on pick button then select Clear.

Catchment areas for your hydrological model may be defined using a Super, 2d, 3d or polyline string to set 
the catchment boundaries. Other ways to set the areas are: manual entry in the network editor, via a 
spread sheet program, the Top 10 Attribute Editor or the ILSAX pipe editor.

Note that if a catchment string is created to define the area for a manhole then all other data entry types 
will be ignored and the area from the string will be used.

There are 3 sets of catchments and it is up to the user to decide how they are to be used. Often set 1 will be 
all the impervious areas and set 2 the pervious and set 3 for special areas. Each set of catchments has its 
own model. Another option is to have only one set of catchments and to use the percent impervious field.

If exporting to external drainage design programs they may note accept all three sets so check the interface 
notes before defining the catchments.

Before selecting text turn on your teXt snap.

To move a single line a text use the CAD 
toolbar. Select the Move text justify but-
ton. To use this toolbar you must DRAG 
the Create text button to the right 

and then release when the pointer is on the 
Move Text Justify Point.

Select Group and then pick and accept one of the 
text items in the group. Move it to its new location 
and accept.

Note: To move another group you must select the 
Group button again.



12d Model Reference Manual

Page  2012 June 2002More Drainage

In each set/model, 12d will automatically link the catchment string to the manhole that is closest to the first 
point on your catchment string. This is the preferred method. If this is not possible, then a manhole may be 
manually linked to a catchment string using the Catchment manual link. 

Also see Checking the Automatic Catchment Linking

Drawing Catchment Strings in 12d

Before creating the catchment string set the CAD control bar data.

Now to create the catchment string use the Create line string button on the CAD toolbar. 

The first point should always be placed near the manhole. 12d will assume that the catchment will drain to 
the manhole closest to this first point.

There is no need to go “overboard” with the accuracy of the catchment strings (except maybe with SAG pit 
catchments near the low points). From experience, it is more important to spend time verifying catchments 
in the field than spending a lot of time getting them “exactly” placed on the catchment plan. If you want to 
use the drawing as a catchment plan submission then the extra care in creating the strings may be 
warranted. Continue selecting and accepting the points on the catchment string.

Type the name of a model for the catchment strings

DRAG the Create line button and release at 
he Create Line String button.

SAG inlet catchments: DO NOT START AT THE INLET, 
just start nearer to this inlet than any other! If you start at 
the inlet then move out to the crest of the catchment, the catch-
ment overflow level cannot be determined from the catchment 
string.

For the last point on your catchment line select Close from the 
CAD toolbar. This function places the last point on the string 
over the first point on the string forming a closed polygon.

Once the catchments are drawn they become linked to the 
drainage network in the Drainage network editor. We will 
label the catchment with the manhole name and area at the 
same time.

Start the Drainage network editor and move to the Global 
Tab and then the Utility Models sub tab.
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We now need to create a label textstyle if you do not have any favourites defined.

Enter a filename 
for the catchment 
models.

Select More info 
button.

Select Edit.

RB click to 
select the model 
of the catchments 
used in the CAD 
control bar 
above. Every 
manhole can 
have 3 catch-
ments, row 1 is 
catchment set 1, 
row2 for catch-
ment set 2 and 
row 3 for catch-
ment set 3.
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Select the textstyle button and then the drop down for Favourites. Now select Edit.

Select Set to store the textstyle favourite for this session only. To permanently save this text-
style favourite and have access to it in all of your projects select Write and the following 

Enter the data as show. Some data you will have to type on the keyboard (type) and other 
you may use the right mouse button (RB) and then select browse.

Type RB RBTypeRBType RB
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Label Catchments

There are some cases where linking the closest manhole to vertex 1 is not feasible. In these cases you may 
manually link the manhole to a catchment.

Select the User folder.

Select Write to save the favourite to the 
User folder.

If you are in a network environment and 
want to see if you have write access to 
this files select the Properties button.

Finally select Set catch-
ments. This will link the 
catchments to the manholes 
and label the catchments. Now 
add the model labels onto the 
plan view.
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Catchment manual link
The manual links are used when the first point on the catchment string is closest to the wring manhole. 
Note that the following restrictions still apply.

1. The string selected for catchment 1 must be in the model for set 1. To check if you have selected a valid 
string select the Set Catchments button.

2. If the catchment string has already been linked to another manhole (automatic or manual) then the new 
link will be created and the old link erased.

3. If you change the catchment model for one of the sets on the Network Editor->Global->Utility Mod-
els->catchments than all of the manual links in that set will be erased.

Checking the Automatic Catchment Linking

The automatic manhole-catchment linking is easily checked by specifying a Catchment labels model 
with Labels textstyle on the Global->Utility models tab and selecting the Set Catchments button on the 
network editor. Also once the Set Catchments has been selected, the catchment is indicated when the 

First change to the Catch-
ment tab.Now either use the 
Pick Edit button to select the
manhole or use the >> (next) 
or << (prev) buttons to move 
to the desired manhole. The 
manhole will be circled in the
plan view and its name shown
in the Current Pit field.

Now select the Catchment 
polygon button and pick the 
desired catchment string.

NOTE! If you decide to enter
a value and NOT use the 
selected string RB on the but
ton and select Clear.

If the Auto apply tick box is 
not selected then you will 
have to select the Apply but-
ton for the manual link to 
become active.

After the Set Catchment but
ton is selected the measured 
catchment area will be shown
in the Catchment area field 
using the units specified in 
the Global-Utility models-
Units field.
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manhole is selected using the network editor. Since there may be three catchments per manhole the 
catchment data last viewed in the editor is the catchment that is highlighted.

The catchment strings may be drawn in a CAD package and then imported into 12d or drawn inside 12d. 
The strings may be easily drawn in 12d with the tin contours and/or flow arrows displayed in the plan 
view.

Network Editor - Global, Default Settings and Explicit Settings

Design values for the hydrology and hydraulics calculations are set either globally (one value for the entire 
network) or via Defaults for the manholes or pipes. Defaults values may be overridden by explicit settings 
found on the catchment, pits or pipes tab. Explicit manhole/pipe settings need only be specified if the 
default value is not desired.

Drainage Templates

The default and global settings may be saved as a template for other projects/networks. Set the defaults for 
a network and then export the model using File IO->Data output->12da/4da data. This file may now be 
imported to another project via File IO->Data input->12da/4da data. Since the global and default values 
are stored as model attributes, they will be imported with the network.

Tip: If you do not want the drainage system imported then delete them from the model before exporting 
the 12da file.

Network Editor - Hydrology

The network editor edits both the network and catchment data and it has already been introduced in the 
previous sections. This section will discuss the Hydrology Global, Defaults and explicit setting for the 
hydrology parameters. The parameters described on the defaults tab will also be found on the Catchment 
or Pit tabs.

Catchment Areas

The catchment areas have already been discussed in the previous section. There is no default catchment 
area to apply to all catchments (as would be expected).

Note! If a catchment string is linked to the manhole and the Set catchments button is selected, this 
string area will override any manual value that you type into the drainage area field. To ensure manual 
entry is maintained, RB select the string selection button and select Clear.

Coefficients of Runoff
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Runoff C methods 
include Direct and ARR 
1987. For the ARR 
1987.

Direct: There is a global 
impervious C value for 
both the minor and major 
storms.

ARR 1987: The com-
posite C value is calcu-
lated using the 1hr-10yr 
intensity, the percent 
impervious, ARR fre-
quency factors and the 
return period specified 
when hydrology runs are 
made.

The ARR 1987 has no 
explicit settings. The 
Direct method has both 
defaults and explicit settings 
on Catchment tabs (see 
below).



Chapter

June 2002 Page  2019More Drainage

Percent Impervious

The default percent impervious for the network is set on the Defaults->Catchment Defaults tab and the 
explicit settings are on the Catchment tab (see above). The percent impervious is used to determine the 
area for the impervious and pervious components and the composite C value if using the ARR 1987 
method for calculating runoff coefficients.

Times of Concentration

There are several methods for entering times of concentration for the catchment areas (see list below). 
Default and explicit settings (catchment tabs) are entered/calculated for both the methods and values for 
the pervious and impervious areas. Since each catchment may use a different tc method all of the tc 
parameter fields on the defaults tab are active. They must be filled in even if you do not plan on using that 
value.
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1. Direct method requires minor and major tc values.

2. Friend, Kinematic Wave and QDUM methods require the retardance, length and slope of the catch-
ments to be entered. Default values must be entered but the optional explicit settings for slope and 
length can be entered on the catchment tabs or a catchment characteristic strings may be drawn (see 
Catchment Tc path strings). The length of this string is used for the length parameter and the design 
tin is used with the string to calculate the slope using the equal area method.

3. Data for the remaining methods is entered in a similar fashion.

Tc Path Strings

These strings are used to calculate the time of concentration for the impervious and pervious areas. They 
are drawn in two models; one for the impervious paths and one for pervious paths. The models are 
specified using the Catchment file field on the network editor (Global->Utility model tab). The 3 rows in 
the catchment file correspond to the 3 catchments available for each manhole. Therefore it is possible to 
have a maximum of 6 Tc paths models!

Key Points

1. Each Catchment set may have 2 Tc paths models. Pervious and impervious paths are kept in separate 
models.

2. End the Tc path string at the manhole that it is to be linked to.

3. Enter the paths models via Catchment file field on the network editor (Global->Utility model tab)

4. You must select a Tc method (explicit or implicit) via the Defaults->Catchments tab or the Catch-
ments Tabs. Just specifying the models is NOT enough!
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Catchment slope (equal area)

The length of this string is used for the length parameter and the design tin is used with the string to 
calculate the slope using the equal area method. These strings are drawn from upstream to downstream, 
finishing nearest to the manhole they are to be linked to. The line style for these strings must be the flow 
line style found under Drainage 12d in the linestyle drop down list.

The equal area slope is calculated at export time. After the export the slope string, it may be profiled to see 
the slope (see below).
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Network Editor - Hydraulics

This section will discuss the hydraulic Global, Defaults and explicit settings for the hydraulic parameters. 
The explicit settings for the parameters described on the defaults tab will also be found on the Pit or Pipe 
tabs.

Pipe Friction Method

Pit Losses Ku, and Direct Flow

The Global friction loss 
method for the pipe 
roughness method is set 
here (Colebrook or Man-
ning). The default pipe 
friction values values are set 
on the Defaults->Pipes 
tab.

The ranges for pipe peak 
velocities are used for 
checking purposes only. If 
the velocities are outside 
this range, warning mes-
sages will be given in the 
output window.
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Pipe Friction Values and Freeboard Limit

Outlet and Tailwater Conditions

The most downstream manhole on each network requires tailwater conditions. Often the invert level on the 
downstream end of the last pipe also needs to have the level locked to either discharge into a waterway or 
join into an existing drainage system. When the most downstream manhole is selected the following fields 
will become active on the Network Editor - Pit - Main tab. If these field are not active and you think you 
are at the outlet see Flow in the Wrong Direction.

If the setout point was on top 
of the kerb, enter the Setout 
to grate offset so that the 
overflow level of the man-
hole can be determined.

The Direct flow (cms/cfs) is 
water flowing into the man-
hole. It is not added to the 
approach flow and therefore 
is not affected by manhole 
inlet capacity.

The Pit loss Ku is used to 
model the energy losses 
through the manholes.

The global pipe friction 
method on the Global tab 
determines which fields are 
active, Colebrook k or 
Mannings. The default 
value for the selected 
method is entered here.

The Freeboard limit is the 
limit for the upstream man-
hole (after the ku has been 
applied). The freeboard is 
measured from the grate 
level (setout level minus 
setout to grate offset).
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Pipe Design Parameters - Sizes, Invert alignment, Min Cover, Max Height

The invert levels during design are controlled by the pipe sizes, max pipe height, min pipe cover and 
invert alignment mode.

Invert Alignment Modes

NOTE! Invert design parameters are set on the Pipe-Design tab not the Pit tab. The Alignment mode 
refers to the DOWNSTREAM INVERT ONLY.

1. The initial pipe grade is set as the Minimum grade (Minimum Grade mode) or the grade between the 
ground levels at the manholes (Minimum Depth mode). Even in the Minimum depth mode the mini-
mum grade constraint is checked.

2. 12d shifts the pipe down so that there is at least the Pipe cover limit along the pipe. The Pipe cover 
limit should include an amount for the pipe thickness.

Minimum will use the 
least of the Critical or 
Normal depths. If a 
fixed level is available 
for the minor and/or 
major storms, these 
value may be entered 
here.The Pit sump 
level is used to enter 
the sump level of the 
network that is being 
connected to 
(Optional).

12d has 3 design modes for 
setting the pipe inverts 
upstream and downstream of 
the manholes. These work 
together with the 2 pipe cover 
modes as follows. 

The tin specified in the Glo-
bal-Main Finished Surface 
Tin field is used for these cal-
culations. The description 
below assumes that none of 
the inverts have been manu-
ally locked.
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3. Inverts are moved down if required according to the setting in Alignment mode. 
Obverts are aligned using Obvert Drop  with a zero Alignment drop and similarly the inverts are 
aligned with the Invert drop mode. Minimum drop ensure that the inverts drop a minimum of the 
specified drop but the drop may well be more than the Alignment drop specified. As the inverts are 
moved down the minimum pipe grade is maintained.

NOTE! If Obvert Drop is selected and the downstream pipe is a smaller pipe then the inverts will be 
aligned!

Pipe sizes, Max pipe height and Multiple Pipes and Box Culverts

The 12d design engine will select pipe sizes from the file specified on the Drainage Network Design 
panel, Preferred pipes file field list. See selecting pipe sizes. However, the maximum pipe height allowed 
before multiple pipes are used and the selection of box culverts is set on the pipe->main and pipe 
>design tabs respectively.

For box culverts, the design engine increases the widths and maintains the height through the available 
sizes. Once the maximum height has been reached, the next culvert height and minimum width is checked.

On the Pipe->Design tab the max pipe height can be set for each pipe segment (there is no default for this 
value). If the 12d design engine requires a larger pipe, then multiple pipes will be selected.

Road Design File for Pit Setout - x,y, level, road chainage and setout offset

The road design file is used to automatically link the manhole to a road setout string and a road centre line 

To specify a box culvert in 
your network, select the 
pipe segment and enter a 
width for the pipe.
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string. Explicit picking of these strings may be found on Pits->Setout->String selection. These strings may 
be used calculate road grades and crossfalls (bypass model required) and/or construction setout data.

The construction setout point defines the location on the manhole to be printed in the manhole schedules, 
plotted on the plan annotations or listed on the drainage long sections. The setout point and level can be 
set to the centre of the manhole or it can be linked to a road design string. The setout level plus the Setout 
to grate offset determines the grate level for surcharging calculations.

The centre of the manhole or setout point can also be dropped perpendicular onto the road centre line to 
obtain the road chainage and offset distance.

Pit centre is the centre point of the manhole (the intersection of the joining pipes). Often the setout point 
for a manhole or catch basin is not the centre of the manhole but rather a point on the kerb or back on the 
foot path. The setout string option will drop the centre point of the manhole onto the closest string in the 
Road design model list specified on the Global->Utility models tab. The manhole cover level will be set 
to level on this string.
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The Centre string ID is used in the same way to find the centre line string. If needed, this string 
is used for road chainage and to determine which direction to measure the crossfall (between the 
setout string and the centre string).

The distances and searches are optional. The setout and centre search distances are the maxi-
mum distance that the routine will look when trying to locate the setout and centre line strings 
respectively. 

The grade offset it the distance upstream from the setout point that the road grade measurement 
will start and the Xfall offset is the distance from the setout point to the start of the crossfall meas-
urement. The measurements will be taken over a distance of slope measurement distance with 
the actual levels taken from the finished surface tin specified on the Global-Main tab.

Repeat this for each road string model used in the design. Remember to select Write when fin-
ished!

Select the Set Pit Details button on the bottom of the panel the calculate these values.

Type a file name, select the 
folder icon and then select 
Edit from the drop down. 
NOT Edit file.

The following editor will 
appear.

RB select this box and 
choose the models con-
taining the setout strings. 
In the Setout string ID 
box enter the string name 
prefix (wild card * 
allowed) to limit the 
selection for setout string. 
If no ID is entered then 
this model will NOT be 
searched! 
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Explicit settings for the setout strings and the auto calculated values are found on the Pit-Setout tab. If the 
manual mode is selected the Easting and Northing locations may be picked in plan view or typed into the 
input boxes.

The setout level defines the level on the manhole to be printed in the manhole setout tables and in the 
drainage longsection plots. The FS Tin selection obtains the level from the FS tin, specified on the Global-
Main tab, at the centre point of the manhole.The Setout String location obtains the z level from the setout 
string as described in the section above. Explicit settings and the auto calculated value are found on the 
Pit-Setout tab.

If Road chainage mode is set to Centre string, then the Centre String ID in the Road design file (shown 
above) is used to select the road string to measure the chainage and offset from. The values and explicit 
settings for the road chainage and offset are found on the Pit->Setout tab.

Setout to Grate Offset

The grate level is used by 12d when determining the freeboard and when calculating depth of flooding at 
SAG pits. The grate level is often exported to other design packages. The grate level is calculated as

Grate Level = Setout z + Setout to grate offset

The setout to grate offset is generally zero or negative and implicitly set on Network Editor->Defaults-
>Pits->Setout to grate offset or explicitly on Pits->Main->Setout to grate offset.

Calculate Bypass flow routes

This option is required for manhole inlet capacity calculations and is covered in the advanced drainage 
training.

As an introduction, the overland flow parameter routine determines the road grade, crossfall, manhole inlet 
capacity and downstream bypass manhole for each manhole. To achieve accurate measurements for the 
road grade and crossfall, the manhole is linked to a setout string (see below).
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Service and Utility Clashes
WARNING!

12d service clash routines notify the user of crossing services but not parallel services that are close to each 
other. To view parallel services, add the services model onto a section view, profile a drainage string and 
then set the corridor value for the section view.

The service clash model list is entered on the Global-Utilities Model field.

Settings->Corridor and 
then set the Width left and 
Width Right to the desired 
clearance. If the service can 
be seen then it is within the 
tolerance. 11 is used in this 
example only so that you 
can see the service on the 
other side of the road.

Use the Next and Prev but-
ton to switch drainage 
strings.

To obtain a report of all strings 
inside or crossing the drainage 
string profiled, select the View 
menu button then Utilities-
>Report
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Service clashes are listed in the output when the Set pipe inverts is selected on the Drainage Network 
Editor. If the output window is not visible then from the main menu select

Window->Output Window

and make sure it is selected.

To create a list enter a list name, select the folder 
icon and then select edit.

In the Service model column RB to select the 
model. Enter Minimum Clearance for the serv-
ices in this model. If different clearances are 
required for different services then place the 
services in different model. Warnings will be 
issued at design time. Cover levels or fixed 
inverts can be used to avoid the services.
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Once the invert levels have been reset the output window will indicate the final clearance.

After a pipe design run details of the service clash data will again be listed in the output window.

The most common method 
to avoid the clash is to 
increase the Pipe cover 
limit for this pipe segment 
so that the pipe is pushed 
down. If the clash problem 
is above the pipe then the 
Max pipe height may be 
used and multiple pipes are 
selected.

This method is preferred 
over locking the inverts as 
this leaves more flexibility 
for aligning the inverts.
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Drainage Design in 12d Drainage Design
12d has a sophisticated rational method hydrology and hydraulic grade line pipe design engine. In addition 
it has the capability to export this data to several other popular drainage packages. Regardless of the design 
method selected the drainage network in 12d is updated from the design so that drainage plans, long 
sections and manhole schedules can be quickly produced.

12d Rational Method Hydrology - Drainage Rainfall Editor

The Drainage Rainfall Editor is used to input rainfall IFD data using several methods. The data is stored 
in Meteorology files (each file is for a specific location) that can be shared between 12d projects. The data 
is edited using an editor similar to those used for the plot parameter files (ppf). Seven methods for 
entering/calculating the rainfall intensities are shown in the panel below. From the main menu select,

Design->Drainage-Sewer->Rainfall Editor

Data is entered using one (or more if desired) input methods and then saved by entering a Meteorology 
file name and selecting Write. The standard 12d system file search paths are used (project folder, user 
library folder and then library folder).

IFD Tables

IFD tables are often available from meteorological services. The table input format follows. The first row 
is used to define up to 9 return periods and the following rows list the rainfall intensities for the duration 
entered in the first column.

Hint: to increase the size of the grid control select another method, ARR 1987 for example, and then 
select IFD table again.

Select the folder icon and then walk right on the Lib item to display a list of sample files. Select a file 
the select Read. YOU MUST SELECT THE READ BUTTON!
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Australian Rainfall and Runoff 1987 Method

The rainfall intensities and other factors from Volume 2 of ARR 1987 are entered in this table.
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Australian Rainfall and Runoff 1977 Method

The seven coefficients for each return period from ARR 1977 are entered in this table.

Drainage Network Design

The Storm Analysis button on the Network Editor executes the 12d drainage design, plots the drainage 
long section and plan annotation and prepares the hydrology and hydraulic design tables. 

From the Drainage Net-
work Editor select 
Storm Analysis. The 
following design panel 
will appear.
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In general the Analyse network is always selected. If you only want to plot or create the reports then 
remove the tick.

Storm Factors

Select the folder icon on the Rainfall location file and then walk right on the Lib line to select one of the 
rainfall files in the 12d library. If the file has only one type of rainfall definition then the Rainfall method 
field will be completed. Otherwise select the Rainfall method desired. The valid Return period will 
depend of the method selected but you cannot extrapolate beyond your data.

Event type determines which set of design values (minor or major) will be used for this run. Enable the 
12d rational method engine partial area calculations by selecting the Partial area effects box.

Network Design Factors
Selecting Pipe Sizes

These values control the values to be designed in the run. If Design pipe sizes is selected then a files 
containing the available pipe sizes must be supplied. The pipe sizes in this file are in the Units specified in 
the drainage network editor. To create a new file, enter the file name and then select the folder icon 
followed by the Edit line. The following panel will appear.
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The Upsize only selection will stop pipes in the system from being reduced in the design. Regardless of 
this selection, the 12d design engine will not allow a smaller pipe to be selected in the downstream 
direction.

Generate Results in Plan

This selection automatically runs the drainage plot annotation function. A Drainage plan ppf must be 
entered and samples are supplied in the 12d library. A Model for plan results is required if this option is 
selected. The Clean model before hand tick box forces the model to be cleaned before the labels are 
created. When not selected a “Smart clean” is performed.

Generate Results in Long Section

This selection automatically runs the drainage long section plotter. A Drainage long section ppf is 
required and examples are found in the 12d library. A Model stem for long section results is required if 
this option is selected. In almost all cases the Clean model before hand tick box should be selected.

Generate hydrology report

The Run Button and HGL data on the Section View

When the Run button is selected the discharges are calculated, the HGL check is performed and the pipes 
sizes and inverts are designed (if selected). The plan and long section drawings will also be updated with 

The diameters/heights are required and the 
width is optional to specify a box culvert.

YOU MUST SELECT THE WRITE BUT-
TON!

The hydrology report may be 
formatted for inserting into a 
12d model/text editor (format-
ted) or spreadsheet (comma or 
tab delimited). In almost all 
cases Overwrite existing 
report file will be selected.
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the new data (if selected). 

Importing Text into a 12d model

Formatted text may be inserted into a 12d model by selecting

Drafting->Text and Tables->Create edit paragraph text

The HGL values will also be available on the 12d section views when profiling the drainage 
strings. The colour of the HGL line may be changed via the view’s menu button then Settings-
>Drainage.

Change to File.

Select the folder icon and then pick the formatted 
text file. It will be displayed then select Set. 

Next select the location in plan for the text.

The font selected must be a fixed space font or the 
data will not align properly.

Select the Font to display the following panel.
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Generate hydraulic report

If you want both the hydrology and hydraulic report in the same file, enter the same file name in both file 
fields but turn of the Overwrite existing report file for the hydraulic report.

Design Results

Results from the design runs are shown in several forms:

1. Hydrology and hydraulic reports

2. Drainage plan annotations

3. Drainage longsections

4. Hydraulic Grade line on the Section view

5. Output window data - Service/utility clashes

Samples of the hydrology and hydraulics report are shown below.

Enter a Text Model for the report.

The Text Style must be a fixed space font.

Select Set then Finish.

Now add the Text Model onto the 

The hydraulic report may be 
formatted for inserting into a 
12d model/text editor (format-
ted) or spreadsheet (comma or 
tab delimited). In almost all 
cases Overwrite existing 
report file will be selected.
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Drainage Data Input and Output to Spreadsheets
Spreadsheets are an effective method to manage the numerous variables urban drainage designers create in 
the modelling process. Spreadsheet data can be transferred to and from 12d in tab delimited files and 
stored within 12d as “user definable attributes”. These attributes are linked to the pit and pipes within a 
network. Drainage long section plots can display the pipe attributes in the “arrows” data area and pit 
attributes in the bubbles area. Drainage plan drawing can also show these pit and pipe attributes.

Drainage strings will be created if they do not exist in the model but manholes cannot be added to existing 
strings.

See also

12d to spreadsheet transfers

Spreadsheet to 12d update and create

Spreadsheet options

12d to spreadsheet transfers

This interface is accessed the Import/Export button on the Drainage Network Editor.
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Spreadsheet to 12d transfers

This item is accessed from the Import/Export button on the Drainage Network Editor.

The following panel will appear.

Select Export

Select Spreadsheet clipboard

These options are not used for 
spreadsheet export.

Usually leave this off! Select to 
export the junction pit at the end of all 
drainage lines (very rarely needed).

You may also select to limit the output 
if desired. If you like using 
spreadsheets for data entry, the 
PCdrain data and ILSAX data formats 
are useful for adding data for the first 
time for either program.

Select Run to place the data on the 
clipboard.
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Tab delimited, “12d drainage spreadsheet” format or “from to” format data must be on the clipboard in 
order to update a 12d drainage model or create a new model. These format are described below.

Updating an Existing Model

The data usually is generated by 12d using the Export option, pasted into a spreadsheet and then copied 
back to the clipboard so that 12d can be updated. 

When 12d exports the drainage model to a spreadsheet it includes a column for the unique string identifier 
and a unique manhole identier (unique to the drainage model not the 12d project). The names of the strings 
and manholes may be changed via the spreadsheet if these columns are present at import time.

If the manhole id column is not present, 12d will search the drainage model for a matching manhole name. 
When the manhole is a junction between drainage lines, only the trunk line will be the data updated.

Creating a New Model

It is possible to create a new string or an entire drainage network using this format. However, manholes 
cannot be added to an existing string. The entire drainage string must be created at once. Two formats are 
availabe, the “from-to manhole” format and the “12d drainage spreadsheet” format. 

At present the network editor must select a drainage string to become active. Therefore, if you are not 

Select Import

Select the Spreadsheet 
clipboard format.

The file field is ignored.

This is ignored on spreadsheet 
imports.

Select Run to update the 
drainage model.
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adding strings to a network, you will have to great a drainge network with one “dummy” manhole. Select 
this one “dummy” manhole to activate the editor. After importing the data and the new drainage lines are 
created the “dummy” manhole may be deleted.

12d drainage spreadsheet Format
The top left cell in the clipboard data must be the text “12d” to specify this format. The minimum amount of 
data required to create a new string is the string name, manhole name, x and y coordinates. You can add as 
much additional data as you have available. This would include pipe diameters inverts etc. The manholes must 
be listed from upstream to downstream order. If the string is to join a trunk line, the junction manhole must be 
included for both the tributary and the trunk line.

An example file exists called new_network.txt is supplied in the library. Open this file in a spreadsheet or a 
text editor and copy it to the clipboard. Set the I/O Action to Import and select Run. The new drainage lines 
will exist in the model currently being editted.

From-to Manhole Format
The top left cell in the clipboard data must be the text “from to” to specify this format. The minimum amount 
of data required to create a new string is the upstream pit name "*pit name) , the downstream pit name (*ds pit 
name) and the x(x location) and y(y location) coordinates of the upstream pit. If the string is to join a trunk 
line, the junction manhole must be included for both the tributary and the trunk line. 

An optional column for the manhole cover elev (cover elev) may be specified. Once the network has been 
created additional pipe and mnahole data may be added using the “12d drainage spreadsheet” format 
described above.

An example file exists called new_from_to_network.txt is supplied in the library. It is shown below. Open 
this file in a spreadsheet or a text editor and copy it to the clipboard. Enter a new model name in the Drainage 
model field and select paste. The new drainage model will now exist. 

“12d drainage spreadsheet” Format

Each column of data is used for a 12d drainage variable or a user defined attribute. Each row represents a 
manhole and the downstream pipe (controlled by the direction of flow variable) within the drainage 
network. A sample is shown below.
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Duplicate Definitions
Strings Variables such as “direction” are may be defined for numerous manholes on the same string. 
Searching in a top down direction through the file, the last definition found for the string will be set.

Invert levels may be set via pipe data or pit data or combined. It is recommended that the user only use one 
method and not combine them. Both are exported so delete the ones you are not going to use. The variables 
are processed from left to right, so if duplicate definitions of an invert level or found the right most data 
will be set.

The format definition
1.Row1, column 1 must contain either “12d”, or “from to”. Therefore, the first column must be a 12d 

drainage variable (cannot be a user defined attribute).

2.Row 1. The text <pit> at the top of the column indicates the column contains a user defined pit attribute 
and similarly <pipe> indicates a user defined pipe attribute.

3.Row 2. This row contains the names of the 12d drainage variable names and the pit/pipe attributes. All 
names are case sensitive so be careful where you use capital letters. A list of 12d drainage variables is 
found below.

Names beginning with an asterix (*) will not be processed (except pit/string names when unique iden-
tifiers are present in the data). 12d drainage variables names beginning with an asterix indicate that this 
data was calculated at export time and cannot be read back into 12d (for example, pipe length, pipe 
grade and deflection angle). 

Prefixing an user defined attribute name with “DELETE ” (no quotes, note the space after the 
DELETE) will cause the attribute to be deleted from all pits/pipes within the model.

4.Row 3. The text in this row define the type of attribute to be stored within 12d. The only valid choices 
are;
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integer
real
text

If you want to change an attribute type you must delete the attribute and create it again. If you simply 
change the attribute type in the third row then that attribute will not be updated.

5.Blank lines may be inserted as desired.

6.You are not required to fill in all of the cells in the spreadsheets. Blank cells are ignored (you must use a 
space to remove all data from text attributes (the space will not be stored).

7.Pipe names are included in the data so that they can be changed but they are not used to identify the pipe. 
Pipe data will always be assigned to the pipe following the pit in the direction of ascending chainage. 
If flow directions is ascending then the pipe data will be for the downstream pipe. If the flow direction 
is descending then the pipe data will apply to the upstream pipe.

12d Drainage Variable Names
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Reviewing, Changing and Creating User Defined Attributes
The catchment data is stored within 12d as user defined attributes. These attributes are automatically 
created by 12d when required but you are free to change them or add more as desired. The attributes may 
be exported to a spreadsheet and edited and then imported back into 12d. To work with the user defined 
attributes within 12d select

Design=>Drainage-Sewer=>More=>Top 10 Attribute Editor. 

.

They may not be defined for the manhole you are editing. Not found will be displayed in the Data field if 
the manhole does not have that attribute defined.

To change the value for the attribute 
enter the new value in the data field. 
If the attribute does not exist, 
deleting the not found text and 
adding data will create it. The 
message on the right will be 
displayed whenever you are creating 
a new attribute.

First Select Pick to select the string 
that contains the user attributes (the 
drainage string). The strings will be 
highlighted in white when they are 
selected.

All catchment data is store with the 
manholes in drainage strings. To 
access the manhole attributes, select 
the drop down icon and then select 
manhole. A circle will be drawn 
around the manhole selected. Next 
and Prev will now move you from 
manhole to manhole.

Select the drop down icon and then 
select the Attribute Name from the 
list of existing user defined attributes. 
These attributes include all of the 
attributes in the model that the string 
exists in. 
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Manhole/Pit Schedules
Manhole/pit schedules or construction tables are generated in tab or space delimited formats.

This panel is accessed from the menu selection

Design => Drainage => More Drainage => Pit schedule

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Drainage model name input box drainage network

model containing the drainage strings

Pit schedule file name input box pit report

file to be created

Report Format choice box Road chainge..,Easting...

file format

Data delimiter choice box Tab, Space

tab delimiters are best for spreadsheets and space for some text editors

Repeat header for each line tick box selected

when selected, the column headings will be printed each drainage line 

Calculate road chainage/offsetstick box selected

only used for road chainage-offset format. When selected, the road chainages and offset calculation 
panel will be displayed so that the this data can be updated before the report is generated. (see below)

Easting Northing Location choice box pit centre, road design string

easting northing data can be from the manhole centre or the x,y location on the road design string that 
the manhole has been linked to

Cover elevation location choice box pit centre, road design string

the cover level elevation can be from the manhole centre or the elevation on the road design string that 
the manhole has been linked to (if a link has been made then these values should be the same). Note 
that the road design string data is NOT caclulated at this time. These are the vaules calculated from 
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the Drainage Misc Utilities or the last drainage data export.

Process button

Create the pit report

Finish button

remove the panel from the screen

Notes:
The columns of data may be separated by spaces or a tab. (tab is used for spreadsheet transfers). The 
internal width and length data are retrieved from the drainage.4d file for the pit type specified. If you want 
a longer description for the pit then the type used inside 12d this can also be entered in the drainage.4d file. 
The remarks for each pit are entered as user defined pit attribute named remarks and may be set using the 
attribute editor (on the drainage menu) or via a spreadsheet.

Easting Northing Sample
.PIT SCHEDULE                                                             
  Pit                                INTERNAL           INLET          OUTLET                  PIT   
  No    TYPE    EASTING NORTHING    WD       LEN     DIA   INV LEV   DIA   INV LEV  FIN RL    DEPTH         
REMARKS       
   B1   SA2    5302.458 7336.936  450.000  900.000                    375   28.210   29.387    1.177                      
   A2   SA2    5264.372 7322.036  450.000  900.000    375   27.470                   28.646    1.226                      
   C1   SA2    5224.155 7336.936  450.000  900.000                    375   26.690   27.863    1.173                      
   A3   SA2    5187.910 7322.036  450.000  900.000    375   25.930                   27.158    3.628                      
   A1   SA2    5309.458 7321.100  450.000  900.000                    225   28.550   29.577    1.027                      
   A2   SA2     5264.372 7322.036  450.000  900.000    225   27.470    375   27.420   28.646    1.226                      
   A3   SA2     5187.910 7322.036  450.000  900.000    375   25.930    375   23.530   27.158    3.628                      
  A4   SA2   5157.411 7321.332  450.000  900.000   375   23.090                26.714    3.624 
outlet to existing system 
NOTE:
1. ALL SETOUT POINTS QUOTED TO CENTRE OF PIT

Road Chainage Offset Example

DRAINAGE LINE A
PITPIT LOCATION LOCATION OFFSETS
No.EASTING NORTHING STATION CTRL OFFS TYPE REMARKS

A/15354.629 7336.936 231.171 d002 -7.450
A/25340.691 7320.911 217.233 d002 8.575
A/35293.458 7320.886 170.000 d002 8.600
A/45250.131 7320.886 126.673 d002 8.600
A/55217.194 7322.036 93.736 d002 7.450
A/65183.458 7322.036 60.000 d002 7.450
A/75152.699 7322.036 29.241 d002 7.450

Notes

The Set pit details must be run at least once to before printing the report. If the pits are moved or the 
designed strings changed then this option must re rerun.

The Road Chainage and Offset Pit Schedules use two user defined attributes for each pit. The first is ctrl 
string which identifies the string that the pit will be offset from and the second is ctrl model which 
contains the model name for the control string. These may be manually created/modified using a 
spreadsheet or the attribute editor.
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The easting northing data obtained for the road design string option is obtained by dropping the manhole 
centre perpendicular onto the selected road design string. This data is stored as pit attributes setout x and 
setout y. It is calculated when the manhole cover levels are recalculated (drainage misc utulities and 
during drainage export (recalc level option must not be turned off)).

The cover elevation data obtained for the road design string option is obtained by dropping the manhole 
centre perpendicular onto the selected road design string and obtaining the elevation at this point. This data 
is stored as pit attribute level z. It is calculated when the manhole cover levels are recalculated (drainage 
misc utulities and during drainage export (recalc level option must not be turned off)).
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Long Section Plotting
Detailed description of the 12d drainage long section plotting may be found in the 12d Reference manual. 
The long section plots are customised using the drainage plot parameter files (drainppf). Title blocks, user 
defined text may be added and then plotted directly or to various file formats (dwg, dgn etc.). From the 
main menu

Design=>Drainage-Sewer=>Plots=>Longsections

See Also
manhole Schedules to set road chainage and name data

The network model field will be completed with the model of the string being profiled. If this is not your 
drainage network model then select it now.

When Plotter Type is set to model then plot file stem is the model name prefix for plots that will be created. The 
first sheet of plots will be in model plot1, the second in plot2 etc.

To access the 
drainppf files sup-
plied select the 
icon and then 
walk right on Lib 
to select this 
drainppf file.

Select Read

Enter a new name 
for this drawing 
and select Write. 
This will save the 
setting we are 
about to make 
should you want 
to replot this long 
section.

This section view 
determines the 
additional mod-
els (such as serv-
ices) to show plot. 
These are referred 
to as corridor 
models. The ver-
tical exaggera-
tion is also 
obtained from this 
view.
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The plot height determines how much room is left vertically for the actual plot. This specifies the total height of 
the plot. 12d then constructs the box area and arrow area on the bottom and then arrow area on the top. The 
amount left over is used for the long section itself. 

To stop datum breaks from occurring increase this height, increase your plot scale or decrease your vertical 
exaggeration. If there is too much white space in the graph area then reduce this value.
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The +Drainage plot+title block+User title info allow you to enter the text for the title block. The list displayed 
is retrieve from the title file selected above. Enter the data for the plot and then select Write to save the changed 
to the local drainppf file you entered earlier.

Select Plot and the plots will be send to the plot file stem entered. These models may be added (one at a time) to 
a plan view to inspect them before plotting to paper or exporting to other drawing packages.

If changes are to be made and then plotted again you must delete the drawings in the model. These models may be 
cleaned out using

Models->Clean
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The asterisk may follow the plot file stem to clean all of the 
models at once. You will be shown the model list before they 
are cleaned.
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Working with Kerb/Lip Strings
The reference point for kerb inlet manholes is usually on the kerb lip string or a fixed distance off the 
string. The rest of the strings only complicate the picture so we will take copies of the kerb strings to be 
placed in another model. Isolating the kerb strings into a separate model and joining them together is the 
recommended way to work with them. This may take a few minutes but sometimes you have even less 
time than that. So first lets look at how to pick kerb strings quickly.

Picking kerb strings - name snap

Strings generated by 12d have specific names attached to them. The lip string is often called “lok”. 
Therefore, if we could restrict our string selection to those strings named “lok” it would make placing the 
manholes very efficient. We are going to do this with the Name snap.

There are 3 types off snap tool bars available. Standard, vertical and horizontal. To obtain the standard 
snaps toolbar select, Utilities=>Snaps=>Snaps and the following snap toolbar will appear.

Leave the panel up to remind your erase the lok entry and select Set again so that you will once again be 
able to pick any string.

Placing a manhole at a Specific Control String Chainage

When appending or moving drainage manholes, the following steps will place the manhole at a specific 
chainage along the control string.

1. RB and then select Snaps cogo=>Create=>Perpend from the menu. Messages indicating 
what to be done next are given in the bottom left corner of the 12d window.

Select Name and the following panel will appear.

Enter lok and select Set. Now only strings with this name will be 
selected.



Chapter

June 2002 Page  2055More Drainage

2. LB select but do not accept the road centre line (control string).

3. To place the manhole across from chainage 2100 Type ch2100 then press enter.
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4. MB accept the inserted point. This identifies the point on the control string. Next

5. LB select the lip line then MB accept. The construction point will be displayed on the lip 
line

6. MB accept the construction point to place the manhole.

Placing a manhole at a Specific Distance/Offset along the kerb string

When appending drainage manholes, the following steps will place the manhole at a specified distance 
along a string and if desired an offset. 

1. RB and then select Snaps cogo=>Locate=>Offset from the menu. Messages indicating what 
to be done next are given in the bottom left corner of the 12d window.

2. When you select the string to measure the distance along, do not click but rather drag in the 
direction you want to offset. Next MB accept 

3. LB select then MB accept the control point to measure the distance from. (If this point is not 
on the string selected in step 2 the point will be dropped perpendicularly onto that string).

4. Type the distance along the string then press Enter (a negative value would go in the oppo-
site direction to the drag in step 2).

5. Type the offset distance from the string then press Enter (positive is defined using a right 
hand rule method from the direction in step 2).

6. MB accept the construction point to place the manhole.

Locating Crests and Sag Points

This step will place tick marks at the crest and sag points of your kerb strings. It is an optional step but it 
will help ensure that a drainage manhole is always placed at SAG manhole locations. 

If your road designer has given you kerb inverts strings split into numerous sections, use the “head to tail” 
feature described in section 4.2 above before using this section. The crests and sag locations along the 
design string can be identified using the selection

Strings =>Label => Chainages
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To get a clear picture of what the kerbs look like in profile lets create a section view and profile the kerb 
string.

To obtain more working area, hide the Output Window (Window=>Output window).

From the main menu select,

View=>New=>Section View

Now Select Profile on the section view title area and then pick the kerb string in the plan view. Your screen 

Enter the model name for the kerb strings.

Select crests/sags from drop down list.

Enter a model to contain the text labels. A ,1 
after the model name, requests that the model 
be added to view 1. This saves you adding the 
model to the view later to see the labels.

Select icon to define the text style.

Optionally select heights and not chainage.

Select the Marks property sheet 

Type the same model name as above for the 
tick marks.

LB to select ticks centred from the drop 
down list.

5m white marks stand out well on the screen.

Select Label to create the labels.

Select Finish to remove the panel.
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should now look like the following.

Place your pointer in the section view and notice how the cross in the plan view indicates your position in 
plan.

THE END
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Advanced Stormwater Design - Introduction
The Stormwater Design Course Notes and this manual, the Advanced Stormwater Design Course, 
describe the functions and processes of the 12d drainage module. 

The Stormwater Design Course Notes contain:

sset drainage defaults and layout a drainage network,

suse the powerful 12d drainage network editor to avoid service clashes, grade pipes, align oberts, mini-
mise depth and many other design tools,

sautomatically assign names to the pit/pipes in the network,

sdesignate catchment areas and produce catchment plans,

stransfer data to and from electronic spreadsheets to enable the user to easily review the data and add 
user defined data to the 12d pipe network. This data may include such data as pipe bedding types 
and trench width,

screate pit layout schedules to export to spreadsheets or word processors for final formatting.

sproduce long section drainage profiles including HGL data, flows, invert levels, service crossings

screate plan drawings with pipe sizes, flows, manhole symbols, linestyles for pipe sizes, design param-
eters for manhole and pipes and user defined data

slocate pits/manholes at exact chainage and offset locations

This manual, the Advanced Stormwater Design Course, is intended to describe the more advanced 
features 12d model drainage and discuss the customisation of the package. This will include

s drainage trench exvavation volume calculations

s pipe and manhole quantity calculation

s customising the drainage.4d file

sdesign or evaluate the drainage system using 12d Drainage or create input files for the XP SWMM/
RAT2000, Micro drainage, Drains and PCdrain drainage design packages,

sread the output from the drainage design packages (automatic if using 12d Drainage), update the 
drainage network and store the hydraulic data, such as hgl (hydraulic grade line) levels, peak pipe 
flows and pipe capacities,

s pit inlet capacity calculations and over land flow

s flooded width analysis

s surcharge volumes at SAG pits

s and detailed drainage plan labelling
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Setup Files and Their Locations
The drainage module consists of the optional 12d Drainage engine, utilities, startup configuration files for 
RAT2000, XP SWMM and the 12d drainage configuration file (drainage.4d). Demonstration versions of 
Drains, RAT2000 and PCdrain have been included on the CD along with a copy of the ILSAX hydrology 
package. Manuals for the ILSAX program may be obtained from the Civil Engineering Department at the 
University of Technology Sydney.

All setup files have been configured for the training version. However, when you start working on real 
projects you may want customise the drainage module. More - Customising the drainage module

The drainage.4d file contains pipe types (RCP, Class 2 etc.) and example pit inlet capacity tables for RTA 
(NSW Road and Traffic Authority) standard pits. Detailed pit type descriptions and internal pit dimensions 
can be included in this file to be inserted into your pit schedules. For PCdrain users there is a routine to 
read your gully pit file and include these pit types in 12d More.

See “The drainage.4d file” on page 2102.

REVIEW THIS DATA CAREFULLY! A detailed description of the pit inlet capacity tables in this file is 
given in “Pit Inlet Capacities” on page 2102. The drainage.4d file may be customised for any additional 
inlet capacity data you may have.
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Starting with a Basic Drainage Network
These course notes assume that you have completed the Stormwater Design Course and that you have 
experience creating 12d model drainage networks with catchments areas. This course will begin with a 
completed drainage design found in the directory

\12djobs\courses\7.00\drainage\local road complete

Drainage Volume Calculations
Sample templates are included in the courses section of 12djobs (\12djobs\courses\7.00\drainage\pipe 
template.tpl). The templates from this template library may be added to your project using 

Design=>Templates=>Utilities=>Input.

This routine calculates the excavation volume for all of the drainage strings in a model. Since templates are 
used for the calculations trench shapes can be customised by depth and over excavation for bedding mate-
rials can be included. Net area calculations to exclude pipe area is not supported.
Key points
1. One template for each pipe size (mm)

2. Carefully consider the tin selected.

3. Box culverts should have their own pipe type

A template must exist for each pipe size in the model (pipe size x 1000). For example a 0.3m pipe will 
require a template to exist named 300. A 0.5ft pipe would require a template named 500. Sample templates 
are included in the courses section of 12djobs (\12djobs\courses\7.00\drainage). These may be copied to 
your *.project directory and then added to your project using Design=>Templates=>Utili-
ties=>Add=>All all to project.
The templates are run along the strings and the total volumes are reported. Volumes for each strings are 
given in the report file. An example follows.

If a tin is created from these strings then volumes by depth can be determined using Design=>Vol-
umes=>Exact=>Tin to tin

Usage

 ----------------------------- BEGIN APPLY TEMPLATE REPORT ------------------------------

  apply template to string report - 

    string         E
    tin            design
    separation         10.000
    left template  375
    right template 375
    cut volumes and areas are negative
    fill volumes and areas are positive

 chainage- ------sectional  information------  ------intermediate  information----    ---------accumulative
information-------
           ---------- ---cut area --fill area ------------ ----cut vol ---fill vol    -cut volume-- -fill volume- -
--balance---

     0.000                 -1.434       0.000                                                 0.000         0.000         0.000
                                                                -0.771       0.000
     0.550                 -1.367       0.000                                               -0.771          0.000        -0.771
                                                               -14.222       0.000
    10.000                 -1.642       0.000                                              -14.992          0.000       -14.992
                                                               -15.293       0.000
    20.000                 -1.416       0.000                                              -30.286          0.000       -30.286
                                                                -1.845       0.000
    21.313                 -1.393       0.000                                              -32.130          0.000       -32.130
                                                                -0.794       0.000
    21.863                 -1.493       0.000                                              -32.924          0.000       -32.924

 total cut                         -32.924
 total fill                          0.000
 balance                           -32.924
 ie excess of cut over fill         32.924
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This panel is accessed from the menu selection 

Design => Drainage => Reports => Excavation Quantities

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

drainage string sourve model choice box model View,model,string

drainage string selection

drainage model input box

Model to contain all of the pit and pipe network to be worked on.

Strings model model box

Strings generated from the templates will be stored in this model

Sections model model box

Sections generated from the templates will be stored in this model

Report name input box

cut and fill volumes will ne sent to this report

Ground Surface Tin tin box

tins from which the volumes will be calculated

Section separation real box

distance between the sections

Sections colour colour box

Sections generated from the templates will be assigned this colour (strings colours are defined in the 
templates)
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Network Quantities Report
This panel is accessed from the menu selection 

Design => Drainage Sewer => Reports=> Network Quantities

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data String Source Choice

usually the entire model is selected but view is also available for combining models

MH config file file box

This file specifies the types and depth ranges for the manholes. Details of this file are contained below.

Pipe config file file box

This file specifies the types and depth ranges for the pipes. Details of this file are contained below.

HC config file file box

This file specifies the types and depth ranges for the house connections. Details of this file are con-
tained below.

HC pit config file file box

This file specifies the types and depth ranges for the HC pits. Details of this file are contained below.

HC jump ups file file box

This file specifies the types and depth ranges for the house connections jump ups. Details of this file are 
contained below.

Report file file box

a sample report file is given below.
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Report unused ranges tick box

the depth ranges for the manhole/pipe/house connections are defined in the *.4d files. Selecting this 
option will cause the depth ranges in the file to be printed even if there are no manhole/pipe/house con-
nections in these depth ranges (zero quantity values will be shown).

Report types tick box

Selecting this option will cause the manhole/pipe/house connection types used in the model types to be 
listed (even if quantities are not requested in the *.4d files). Since this is a complete of the type used in 
the model, the list informs the user what types have not been included in the quantity calculation.

Count button

executes the option.

Finish button

removes the dialogue from the screen

The *.4d files listed above are contained in the 12d library directory. Each line is the file performs a count 
(count lines). No items are counted twice. Therefore, if an item is counted its type and then a count line is 
found the wild card is used for the type, the type already counted will not be included in the count.

The format for a count line is three or four values (space delimited) per line. Size is optional.

<type (from drainage.4d)>  <size> <starting depth>   <ending depth>

Notes:
All types with spaces in the name must be enclosed in quotes The wild card * may be used.

The size is optional and if omitted the all sizes will be counted in this group (do not use the * for a wild 
card). 

The starting depth and ending depth are required for all count lines.

Sample count lines for manholes follow. 

// sum concrete cover manholes is various ranges

"CONC COVER" 0.0 1.6
"CONC COVER" 1.5 3.0
"CONC COVER" 3.0 999.9  // this is expected to be zero
"CONC COVER" -999.0 0.0 // trap errors

// any that are not Concrete cover will be counted here

* 0.0 1.6
* 1.6 3.0
* 3.0 999.9
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Sample count lines for pipes follow. 

// sum class 2 pipes by diameter and for various ranges

// count 375

2 0.375 0.0 2.0
2 0.375 2.0 5.0
2 0.375 5.0 999.

// count 450

2 0.450 0.0 2.0
2 0.450 2.0 5.0
2 0.450 5.0 999.

// count 525

2 0.525 0.0 2.0
2 0.525 2.0 5.0
2 0.525 5.0 999.

// count pipe sizes that were missed

2 * 0.0 2.0
2 * 2.0 5.0
2 * 5.0 999.

// count all other missed pipes

* 0.0 999.

Manhole Quantities
====================================

CONC COVER          0.00    1.60    13      16.506
CONC COVER          1.60    3.00     1       1.510
CONC COVER          3.00   999.9     0       0.000
CONC COVER        -999.0     0.0     0       0.000

*                     0.00  1.60     0       0.000
*                     1.60  3.00     0       0.000
*                     3.00 999.9     0       0.000

  total length = 18.016

  Types Used
  ----------

  CONC COVER

  Diameters Used
  ----------

  1.100

 

Since the Report 
unused ranges tick box 
was selected, these lines 
were printed even 
though there were no 
manholes in the data 
ranges.

This data results from 
selecting the Report 
types tick box.
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Exporting to Drainage Design Software Packages
12d contains most of the data required for your drainage design packages. However, each packages has 
specific design variables that 12d does not have access too. The design process is intended to export your 
data from 12d to the design package, design the drainage system and then read the results back into 12d for 
your long sections. 

If pits/pipes are to be added/deleted from your network during the design process you are safest to add/
delete the pit/pipe to 12d and to your design package separately.

Not recommended and as a poor alternative, you have the option of reading the results back into 12d, 
adding/deleting the pits/pipes and then exporting the data to a new drainage project in your drainage design 
software. As 12d does not have access to all of the data in the design packages this method is not 
recommended!

Some of the drainage design programs offer a third option that allows you to import data “on top of” an 
existing project thereby merging and over writing the existing data. Be sure to contact the drainage 
software supplier to obtain exact details of how the merging process is performed.

The interface is run by selecting Import/Export from the Drainage Network Editor

Design->Drainage-Sewer->Network Editor
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Export pipe diameters and inverts is generally select for existing systems only. If your design program 
will set invert levels and pipe sizes then turn this tick box off for new systems.Some design programs will 
require initial inverts and pipe sizes. In this case this box should be selected on the first export.

Export default catchment/pit parameters is generally selected for the first export. For subsequent 
exports turn this selection off and then only the catchment areas (if the model is supplied above) will be 
exported.

The Drainage model is the model 
currently being editted. The I/O 
action determines if data is exported 
or imported and enables/disables 
many of the fields below.

The I/O format selects which exter-
nal program the 12d is interfacing 
with. Some programs use the win-
dows clipboard and others use files. 
If the clipboard is used the data will 
also be written to a file by 12d in 
case you need to take the data to 
another computer.

The Export options have slightly 
different effects depending on the I/
O format (program) selected above. 
Therefore they will be discussed 
later with the various formats.
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Drainage Data Input and Output to Spreadsheets
Spreadsheets are an effective method to manage the numerous variables urban drainage designers create in 
the modelling process. Spreadsheet data can be transferred to and from 12d in tab delimited files and 
stored within 12d as “user definable attributes”. These attributes are linked to the pit and pipes within a 
network. Drainage long section plots can display the pipe attributes in the “arrows” data area and pit 
attributes in the bubbles area. Drainage plan drawing can also show these pit and pipe attributes.

Drainage strings will be created if they do not exist in the model but manholes cannot be added to existing 
strings.

See also

12d to spreadsheet transfers

Spreadsheet to 12d update and create

Spreadsheet options

12d to spreadsheet transfers

This interface is accessed the Import/Export button on the Drainage Network Editor.
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Options

The Spreadsheet Options section allows the user to define the amount of data exported.

Select Export

Select Spreadsheet clipboard

These options are not used for 
spreadsheet export.

Usually leave this off! Select to 
export the junction pit at the end of all 
drainage lines (very rarely needed).

You may also select to limit the output 
if desired. If you like using 
spreadsheets for data entry, the 
PCdrain data and ILSAX data formats 
are useful for adding data for the first 
time for either program.

Select Run to place the data on the 
clipboard.



12d Model Reference Manual

Page  2070 June 2002More Drainage

All Data: All of the 12d drainage string data and the user defined attributes will be exported to the 
clipboard in a tab delimited format. The 12d data names and the user defined attribute names will appear at 
the top of the spreadsheets columns.

ILSAX: For the ILSAX program, the spreadsheet column headings will change depending on the pipe and 
catchment indicators (P2 card) and the inlet type (P3 card). Therefore, use the ILSAX pipe editor macro to 
set up one pit/catchment for the type of data you wish to enter. Now when you export the pipe network data 
the column headings will include the names of the relevant parameters.

User defined below: The Customised list file name is used to define the drainage values, their order and 
format you desire.

The customised list file is a text file where each line contains a drainage variable or a spreadsheet IO 
command (blank lines are ignored unless preceded by the header command). The spreadsheet IO 
commands available are:

header to define a line of text to be exported
blank to leave a blank column in the output
pipe data to specify the following user defined attributes are pipe data
pit data to specify the following user defined attributes are pit data.
variable name a 12d drainage variable names
factor the following variable is multiplied by this factor

The simplest way to create your own customised tab delimited file is to set the Preset Output field to All 
data and leave the customised list file name field blank. Selecting Set, Finish and then Copy from the 
main dialogue. The data will be placed on the clipboard and a customised list file, named output_list.txt 
will be created containing the names of all of the drainage variables in the 12d model. Use a text editor to 
add/or delete the variable names, change their order and/or add spreadsheet IO commands. Save the file 
with a new name! The output_list.txt file is overwitten on every export.

A listing of a customised list file follows. Note the words in the header file have a “tab” between them so 
that they will be spaces across the spreadsheet columns.

Export all 
junction pits when 
selected will repeat 
the data for the 
junction pit at the 
end of each branch 
line.

Preset Output this 
choice box offers 
the following 
choices:
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After creating your customised list file, select Options again and change the Preset Output field to User 
Defined below and enter the new customised list file name that you saved above. Select Set then Finish 
and finally Copy to put the formatted data onto the clipboard.

The data can be pasted into a spreadsheet program for checking or additional formatting.

CUSTOM FORMATED DATA MIGHT NOT BE PASTED BACK INTO 12d!

The data must be in the “12d drainage spreadsheet” format to be read into 12d.

Caution with manhole names in the form 1-1 or 1/1. Some spreadsheets will interpret these values as dates. 
If you use these formats for your manhole names you will have to paste command them in once, format the 
columns that contain the manholes names as text data and then paste the information in again.

One final word on using the copy/paste commands in the Microsoft Excel program. The Paste Special 
command using the “Skip Blanks” option will allow you to copy a large block of 12d data (with blanks in 
it) on top your data so that your data is preserved where it coincides with the blanks. To use this option 
paste the data into a blank spreadsheet and then select copy again. The Paste special option with “Skip 
Blanks” will now be available.

Spreadsheet to 12d transfers

This item is accessed from the Import/Export button on the Drainage Network Editor.

The following panel will appear.

header

Pipe Details

header
Name Length   U/S IL   D/S IL   Slope(%)   Class   Dia I.D.   Rough   Pipe Is   No. Pipes

pit data
*pit name

pipe data
*length
low ch invert
high ch invert

factor
100
*grade

pipe type

factor
1000
diameter
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Tab delimited, “12d drainage spreadsheet” format or “from to” format data must be on the clipboard in 
order to update a 12d drainage model or create a new model. These format are described below.

Updating an Existing Model

The data usually is generated by 12d using the Export option, pasted into a spreadsheet and then copied 
back to the clipboard so that 12d can be updated. 

When 12d exports the drainage model to a spreadsheet it includes a column for the unique string identifier 
and a unique manhole identier (unique to the drainage model not the 12d project). The names of the strings 
and manholes may be changed via the spreadsheet if these columns are present at import time.

If the manhole id column is not present, 12d will search the drainage model for a matching manhole name. 
When the manhole is a junction between drainage lines, only the trunk line will be the data updated.

Creating a New Model

It is possible to create a new string or an entire drainage network using this format. However, manholes 
cannot be added to an existing string. The entire drainage string must be created at once. Two formats are 
availabe, the “from-to manhole” format and the “12d drainage spreadsheet” format. 

At present the network editor must select a drainage string to become active. Therefore, if you are not 

Select Import

Select the Spreadsheet 
clipboard format.

The file field is ignored.

This is ignored on spreadsheet 
imports.

Select Run to update the 
drainage model.
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adding strings to a network, you will have to great a drainge network with one “dummy” manhole. Select 
this one “dummy” manhole to activate the editor. After importing the data and the new drainage lines are 
created the “dummy” manhole may be deleted.

12d drainage spreadsheet Format
The top left cell in the clipboard data must be the text “12d” to specify this format. The minimum amount of 
data required to create a new string is the string name, manhole name, x and y coordinates. You can add as 
much additional data as you have available. This would include pipe diameters inverts etc. The manholes must 
be listed from upstream to downstream order. If the string is to join a trunk line, the junction manhole must be 
included for both the tributary and the trunk line.

An example file exists called new_network.txt is supplied in the library. Open this file in a spreadsheet or a 
text editor and copy it to the clipboard. Set the I/O Action to Import and select Run. The new drainage lines 
will exist in the model currently being editted.

From-to Manhole Format
The top left cell in the clipboard data must be the text “from to” to specify this format. The minimum amount 
of data required to create a new string is the upstream pit name "*pit name) , the downstream pit name (*ds pit 
name) and the x(x location) and y(y location) coordinates of the upstream pit. If the string is to join a trunk 
line, the junction manhole must be included for both the tributary and the trunk line. 

An optional column for the manhole cover elev (cover elev) may be specified. Once the network has been 
created additional pipe and mnahole data may be added using the “12d drainage spreadsheet” format 
described above.

An example file exists called new_from_to_network.txt is supplied in the library. It is shown below. Open 
this file in a spreadsheet or a text editor and copy it to the clipboard. Enter a new model name in the Drainage 
model field and select paste. The new drainage model will now exist. 

“12d drainage spreadsheet” Format

Each column of data is used for a 12d drainage variable or a user defined attribute. Each row represents a 
manhole and the downstream pipe (controlled by the direction of flow variable) within the drainage 
network. A sample is shown below.
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Duplicate Definitions
Strings Variables such as “direction” are may be defined for numerous manholes on the same string. 
Searching in a top down direction through the file, the last definition found for the string will be set.

Invert levels may be set via pipe data or pit data or combined. It is recommended that the user only use one 
method and not combine them. Both are exported so delete the ones you are not going to use. The variables 
are processed from left to right, so if duplicate definitions of an invert level or found the right most data 
will be set.

The format definition
1. Row1, column 1 must contain either “12d”, or “from to”. Therefore, the first column must be a 12d 

drainage variable (cannot be a user defined attribute).

2. Row 1. The text <pit> at the top of the column indicates the column contains a user defined pit attribute 
and similarly <pipe> indicates a user defined pipe attribute.

3. Row 2. This row contains the names of the 12d drainage variable names and the pit/pipe attributes. All 
names are case sensitive so be careful where you use capital letters. A list of 12d drainage variables is 
found below.

Names beginning with an asterix (*) will not be processed (except pit/string names when unique iden-
tifiers are present in the data). 12d drainage variables names beginning with an asterix indicate that this 
data was calculated at export time and cannot be read back into 12d (for example, pipe length, pipe 
grade and deflection angle). 

Prefixing an user defined attribute name with “DELETE ” (no quotes, note the space after the 
DELETE) will cause the attribute to be deleted from all pits/pipes within the model.

4. Row 3. The text in this row define the type of attribute to be stored within 12d. The only valid choices 
are;
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integer
real
text

If you want to change an attribute type you must delete the attribute and create it again. If you simply 
change the attribute type in the third row then that attribute will not be updated.

5. Blank lines may be inserted as desired.

6. You are not required to fill in all of the cells in the spreadsheets. Blank cells are ignored (you must use 
a space to remove all data from text attributes (the space will not be stored).

7. Pipe names are included in the data so that they can be changed but they are not used to identify the 
pipe. Pipe data will always be assigned to the pipe following the pit in the direction of ascending 
chainage. If flow directions is ascending then the pipe data will be for the downstream pipe. If the flow 
direction is descending then the pipe data will apply to the upstream pipe.

12d Drainage Variable Names
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Bypass Flow
Many of the design programs 12d exports to allow for bypass flow. Bypass flow involves the calculation of 
inlet capacity which is often based on the road grade upstream of the manhole.

The following steps are required to enable the export of bypass flow data and the required data is entered 
using the drainage Network Editor.

1. Set the manhole types to names that signify the inlet type in the program you are exporting to (Type on 
the Pit->Main tab).

2. Check that your grate level is correct (Setout z + Setout to grate offset)

3. Mark the manhole as a On grade or SAG inlet (Inlet data on the Pit->Main tab). On grade inlets cap-
ture the water as it passes the inlet while SAG inlet trap the water flowing in from both directions.

4. Draw an bypass flow string in the direction of flow so that it passes within 1 manhole diameter of the 
inlet. If flooded with calculations are to be done later, the bypass flow string should also be in the flow 
channel. Enter this model name (Bypass flow model on the Global->Utility Models tab). When 
bypass flow strings join they must join within 1 manhole diameter of a manhole.

5. Ensure a setout string is linked to the inlet so that the road grade may be calculated in its direction. If 
road crossfall is needed then the centre string is also required. These strings are specified using the 
(Road design file on the Global->Utility Models tab).

6. Press the Set Pit Details button. Road grades, crossfalls, ponding depths and bypass pits will now be 
found in the Inlet data section on the Pit->Main tab.

Drawing Bypass Flow Strings

The bypass flow string must be within 1. manhole diameter of the drainage pit in be considered on the 
bypass flow path. If the bypass flow string is to be used for flooded width calculations in the future, the 
string must also be drawn in the main flow area of the cross section.

Use the CAD toobar to create the bypass flow paths. A unique name is required if you plan to calculated 
flooded widths after the analysis is done.

Starting at the upstream end. LB select an insertion point and MB or press return to accept the selection. 
Continue this until you reach the end of the flow path. The string will not be shown in the new linestyle 
until the screen is redrawn. Press ESC to finish drawing the string. MB on the plan view title area to 
redraw the screen. The correct linestyle will now appear. 

If you reach a sag pit location you may terminate the string or continue defining the bypass flow path for a 
surcharging event out of the sag location.

To use the CAD toobar go to the CAD data bar and enter a 
string name and model name. Select the line style (optional).

DRAG the Create line button and release at 
the Create Line String button.

When finished drawing the string press ESC.
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Set Pit Details - Calculate the Bypass Flow Data

Once the first 4 steps above are complete you are ready to calculate the bypass flow data. Select Set Pit 
Details and then select a manhole on a bypass flow string. The downstream pit will now show in the 
Bypass pit field. 

If Pit on grade is selected and a setout string was found, the Road grade will appear in grey. You may 
override this value by selecting the tick box beside the value and entering your own value. If a road centre 
string was selected, the Road xfall field will also have a value.

If Sag pit was selected and a catchment string was selected in catchment set 1, the Pond depth would be 
displayed. The catchment string is draped onto the finish surface tin and the low point located. The Pond 
depth is calculated as 

Pond depth = min level - (setout level + setout to grate offset).

Negative Ponding Depths

Negative ponding depths are usually caused by two errors in input. The first may be that the grate level is 
too high. Often this happens when the setout point is on the top of the kerb and no Setout to grate offset 
has been entered.

The second is that the catchment string has not been drawn around the crest of the catchment. The lowest 
section of the catchment string must be drawn carefully because it is the lowest point on the string that 
determines the overflow elevation. If in doubt, profile the catchment string with the design tin shown in the 
section view. Double check were the low point is.

12d adds verification strings in the construction model to confirm the locations where the road and 
crossfall have been measured. To check these strings add the construction model to the plan view. The 
following image shows a close up of the verification strings at a pit.
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The blue line indicates where the road grade was measured and the red line indicates where the road cross 
fall was measured.

These are 3d super strings and therefore you may profile them in the section view. With the grades toggled 
on (check under Toggle) you can verify the slopes.

Important Notes

1. Pits with no pit type specified will not be processed by the overflow routine and the inlet capacity will 
be set to 100%.

2. For pits with road design string specified, the inlet capacity will be set to 100%.

3. If no bypass flow string is supplied for a pit, the inlet capacity is set to 100%.

4. If you have a problem with the inlet capacity factors (Drains Version 1 and ILSAX), check the calcu-

Note in the Section View Title
area that the string is named “C
>string”. The work string 
indicates that is was created fro
string data and not from the tin
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lated crossfall and grade.
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Running PCdrain for Windows
Data is exchanged to and from PCdrain via the interchange (*.int) file. Gutter profiles and inlet type must 
be specified in PCdrain before the interchange file is read into PCdrain.

The data sent to PCdrain includes

s manhole names and types, easting and northing data with surface levels

s pipe deflection angles at manholes

s finished surface profile along the centre line of the pipes

s optional - crossing services - level, size and location along the pipes

s optional - bypass manholes, road grades and SAG inlet ponding depths

s optional - up to 2 catchment areas per manhole

s optional - default catchment characteristics, k values and overland travel times

s optional - pipe sizes and invert levels

PCdrain Requirements

Manhole names
The manhole name from 12d is assigned to both the structure and catchment name in PCdrain. These 
names cannot exceed 7 characters.

Manhole type
The 12d manhole type is transferred to the structure type in PCdrain. These names must match those 
specified in the PCdrain Inlet charts selected (Data=>Inlet charts). Select the desired inlet charts 
BEFORE importing the interchange file.

12d manhole types with an “S” in the name are treated by 12d and PCdrain as a SAG inlet pit. 12d will 
strip off all characters after the “S” before adding the ponding depth. If a catchment string in set #1 is 
available for the SAG pit then the ponding depth will be calculated.The12d manhole type will remain 
unchanged. A typical example would be a manhole type “1TC” with the sag tick box on would become 
“1TC0.100” if a ponding depth of 0.1 was calculated.

Bypass Flow
When a catchment string is specified for the manhole, the maximum depth before bypass flow commences 
is calculated. The lowest point on the catchment string is determined by draping it onto the drainage strings 
tin. The maximum depth before bypass is calculated manhole setout level less the setout to grate offset less 
the lowest point on the catchment string.

PCdrain differentiates between manholes (no surface inflow) and gully pits via the 12d manhole type. The 
bypass flow strings can only be drawn within 1 manhole diameter of the gully pits. Keep the bypass flow 
strings away from the PCdrain manholes.

Catchments
Again, since PCdrain differentiates between inlets and manholes (using the 12d manhole type), ensure that 
catchments are only drawn for gully inlet and NOT manholes.

12d to PCdrain

1. Export the data to PCdrain selected via the Network editor

Design=>Drainage-Sewer=>Drainage Network Editor

After selecting the drainage network, select the Import/Export button and the following dialogue will 
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appear.

Select the Run button and the interface file will be created.

2. Launch the PCdrain for Windows program. If you have a project set up with the design parameters, 
rainfall data, inlet charts and gutter profiles then open it now and skip to step 8. Otherwise continue 
with step 5.

3. The Design Parameters can be set as desired with the menu selection Data=>Design Parameters.

4. Select the rainfall data using the Data=>Rainfall menu selection.

5. Select the inlet charts using the Data=>Inlet Charts menu selection. The manhole types specified in 
12d must be included in these settings. More - PCdrain to 12d pit converter

6. At least one gutter profile in PCdrain needs to be defined. These are set through the menu selection 
Data=>Gutter Profiles. The default gutter section name (Road ID) from 12d is 4d and therefore it is 
recommended you create a profile with this name and your own description. If you have changed the 
profile names in 12d (through the spreadsheet interface or the Attribute editor) these new profile names 
will have to exist in PCdrain.

7. Save this file now so that you can retrieve it later if required. It can be used as a starting template for 
new jobs.

8. File=>Import from the menu. Select the file exported in step 1. The information from 12d may be 
viewed by selecting Data=>Network and then selecting the desired tabs.

9. The HGL level and the pipe elevation at the outlet should be set using the menu selection Data=>Out-
let.

10. If you have not exported pipe data then the pipe size must be determined. Use the menu selection Proc-
ess=>Select Pipe Sizes.

PCdrain data values

Some PCdrain data values are not available in the 12d network editor. Prior to an import from PCdrain, 
initial export values are used. On the first import from PCdrain, 12d attributes are created to hold the 
PCdrain variables for subsequent exports to PCdrain. These data values are usually changed in the PCdrain 
menus but may by changed in 12d using the Attribute editor.

PCdrain 12d editor 12d attribute
initial export 

value

Kw not available kw 12d ku value

Minor Coef Catch Set 1 - Pervious C (minor) c minor pervious default

Major Coef Catch Set 1 - Pervious C (major) c major pervious default

Minor Coef2 Catch Set 2- Pervious C (minor) c minor pervious2 default

The drainage model will be completed 
by the editor.

Select Export.

Select PCdrain Int (Windows) from 
the drop down list.

Enter the name of the int file to be cre-
ated.
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PCdrain to 12d

Export the results to 12d using the File=>Export menu selection. Note the name of the interchange file 
you are creating as you will need to enter it inside 12d.

Return to 12d and select Import/Export from the network editor and the following dialogue will appear,

Major Coef2 Catch Set 2- Pervious C (major) c major pervious2 default

Tc overrider Catch Set 1 - Pervious Tc (minor) tc minor pervious default

Length of 
overland flow

Catch Set 1 - Pervious length catchment length 
pervious

default

Grade of overland 
flow

Catch Set 1 - Pervious slope (%) catchment grade 
pervious

default

Length of gutter 
flow

Catch Set 1 - Impervious length catchment length 
impervious

default

Grade of gutter 
flow

Catch Set 1 - Impervious slope (%) catchment grade 
impervious

default

Road XSections 
left

not available overland profile name 4d

Road XSections 
right

not available overland profile name 
right

4d

PCdrain 12d editor 12d attribute
initial export 

value
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A listing of the data imported is stored on the 12d output window.

Manholes that have been specified as SAG inlets will have the ponding depth removed from the end of the 
PCdrain structure type before the data is stored as the12d manhole type.

Select Import

Select PCdrain Int (Windows) from 
the drop down list.

Select the output file name you created 
in PCdrain.

Select Run and the file will be read 
into 12d and the drainage network will 
be updated. To see the changes in a 
section view, select Regen.
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Running Drains - Version 2 & 3

Key Points
1. The Drains database (each project has its own) and the12d database (drainage.4d) must be syncronised 

(More).

2. For bypass flow, 12d selects pit families for Drains in the following way

The users selects pit group in 12d and at export the pit group is scanned in the drainage.4d file using the 
road data to select the Drains pit families

3. Data is copied from 12d to the Windows clipboard and then pasted into Drains. 12d can not delete any 
objects in Drains, it can only add and update.

4. When updating 12d from Drains, always copy the DATA to 12d before the results. 12d will update the 
network but will not add or delete manholes.

Drains Interface Overview
The Drains program performs the rational and ILSAX hydrology calculations as well as hydraulic grade 
line calculations that determine pipe sizes and pipe invert levels.

The data sent to Drains includes

s manhole names and types, easting and northing data with surface levels

s finished surface profile along the centre line of the pipes

s optional - bypass manholes, road grades/crossfalls and SAG inlet ponding volumes and depths. Pit 
family selection usig road grade and crossfall data.

s optional - composite catchment area create from three12d areas per manhole

s optional - default catchment characteristics, k values and overland travel times

s optional - pipe sizes, type and invert levels

Data is copied from 12d to the Windows clipboard and then pasted into Drains (Edit=>Paste data from 
spreadsheet). 12d can not delete any objects in Drains, it can only add and update.

The Drains menu selection Run=>Design is used to design the network. Once the drainage network has 
been designed in Drains the updated design data (Edit=>Copy data to spreadsheet) and/or the hydraulic 
results (Edit=>Copy results to spreadsheet) are sent back to 12d via the clipboard. 

Always copy the DATA to 12d before the results as the results are deleted inside 12d with every 
update of the data!

A demonstration version of the Drains program is included on the 12d distribution CD in the directory

Other_Software\Drains

The version is limited in the number of pits allowed.

Syncronising the Drains database and the drainage.4d file.
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The Drains database and the 12d drainage.4d file must be syncronised as follows.

Every Drains file begins with a default database and uses that database for the life of the project. This 
database must by syncronised with the drainage.4d file in 12d to ensure the Drains pit families, pit sizes, 
pipe types and overflow route types. 

The following 5 steps will help ensure 12d is syncronised with Drains. More details are given in the 
sections below.

1)Export the Drains database from your Drains file
Inside Drains select Project=>Overflow Route database. Then select OK and then YES. This will cause 
Drains to export the database to the file “Drains Connection Data.txt”.

2)Create a drainage.4d file from the Drains file
s From the 12d menu select Design->Drainage-Sewer->More->Drains to drainage.4d. 

s Select Read Drains database,

s review the Drains pit families list to identify the character (usually a comma or -) that separates the 
pit group from the road data and then enter it in the Pit group separator field.

s Check the 12d pit groups and if they are acceptable

s select Create drainage.4d. The Drains database dump file is copied to the 12d working folder and 
a drainage.4d file is created in the 12d working folder.

s More details below.

3)Edit the drainage.4d file
From the 12d menu select Design->Drainage-Sewer->More->Edit drainage.4d. Select Find then edit 
from the file more info button. Set the road grade and crossfalls for the 12d manhole groups.More details 
below. 

4)Restart 12d
From the 12d menu select Project->Restart.

5)Set the Overflow shape, Update Manhole and Pipe type.
A single global overflow route shape can be specified in 12d via the following routine and then it can be 
modified in the Drains program. The import operation of the interface will read modified values and store 
them so that the next export operation will export the modified values.

If the network has already been created, using manhole and pipe types that no longer exist in the 
drainage.4d file, they will have to be updated before the export to Drains can occur. You may update them 
using the drainage network editor or you may set all of the manhole and pipes types to one value using this 

Drains database drainage.4d
Pipe type Pipe type entries

Drains database drainage.4d
Pit famly 12d manhole group with road data

to lookup Drains pit family

Overland route database One default value set (not in drainage.4d)

All Cases

Only if bypass flow  is required
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routine.Later you may change them individually using the Drainage network editor

From the 12d menu select Design->Drainage-Sewer->More->Drainage io defaults.

More details below.

Drains to drainage.4d file

Position of option on menu: Design =>Drainage-Sewer =>More=>Drains to drainage.4d

On selecting the Drains to drainage.4doption, the Drains to drainage.4d panel is displayed.

Key Points
1. Select Read Drains database (12d will search the usual locations for the Drains database)

2. Review the Drains pit families list to identify the pit group separator and then enter it in the Pit group 
separator field. PRESS THE ENTER KEY!

3. Check the 12d pit groups and if they are acceptable select Create drainage.4d.

The Details

The Drains database dump file Drains Connection Data.txt is copied into the 12d working folder and 
read. The choices for the Pit families, Pipe types and Overflow Route Cross Section Shapes are loaded 
into the panel. The user must select a Pit group separator to separate the road grades and crossfalls from 
the pit family names. The resulting 12d Pit Groups will be calculated and displayed in the choice box. 
Create drainge.4d will create a drainage.4d file that may then be edited to specify the road grade and 
crossfall threshold values. Once the file is created you may review/edit it by selecting the More Info icon 
then Edit on the Drainage.4d field. The Overland route shapes are not exported to the drainage.4d file 
and are presented for your information only.

YOU MUST RESTART 12D FOR THE NEW DRAINAGE.4D FILE TO BECOME ACTIVE!

Field Description Type Defaults Pop-Up

Drains database file file Drains Connection Data.txt

You must update this file from Drains before each use of this panel. Inside Drains select 
Project=>Overflow Route database. Then select OK and then YES. This will cause Drains to export 
the database to the file “Drains Connection Data.txt”.

Selecting Enter in this field or selecting Read Drains database will cause the panel to search for the 
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database dump in the folders C:\Program Files\Drains\Program and C:\Program 
Files\Drains\Demo\Program. If the Drains program is installed in another folder then you must 
browse for the file. After reading the file choice boxes below will be populated. Drains Connection 
Data.txt will be copied into the 12d working folder.

Drainage.4d file drainage.4d

The drainage.4d will be created in the 12d working folder unless otherwise specified. It will only be 
used for 12d projects in this folder.

Pit families choice Drains pit families

These are the Drains pit families that will be exported to the drainage.4d file. The 12d pit groups will 
be created from this list.

Pipe type choice Drains pipe types

These are the Drains pipe types that will be exported to the drainage.4d file.

Overflow Route Shapes choice Drains Route Shapes

These are the Drains Route Shapes and are for information only.

Pit group separator input

These characters will be used to remove the road grade crossfall data from the Pit families above. The 
data before this character will become the 12d pit groups. Press Enter or select Read Drains 
database to create a new list of 12d pit groups.

12d pit groups choice 12d pit groups

These are created from the Pit family list above by deleting all text after the Pit group separator. This 
should delete all of the road grade and crossfall information from the pit group names.

Read Drains database button

Searches for the Drains database (see general description above) and populates the choices fields.

Create drainage.4d button

Create a local copy of the drainage.4d file.

Editing the Drainage.4d file

Position of option on menu: Design =>Drainage-Sewer =>More=>Edit drainage.4d

On selecting the Edit drainage.4d option, the Edit drainage.4d panel is displayed.

The drainage.4d file contains Manhole and Pipe commands. 12d also uses the Manhole commands to 
specify a manhole group by using the prefix “group”. Details follow.

Select the Find button to search the 12d path for the 
current drainage.4d file. Select the More info button 
and then Edit to edit the file.
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Pit Families and Manhole Groups
Version 2+ of the Drains clipboard interface uses a pit family to describe the kerb shape. Optionally, the 
Drains pit families also have the road crossfall and/or grade attached as a suffix to the name with a special 
character between them (pit group separator). Therefore there may be many pit families that have the same 
kerb shape but different road grades and cross falls. All of these pit families with the same prefix are 
brought together in 12d as a manhole group. 

An example manhole group is the drainage.4d file is shown below. The 12d group is called NSW RTA 
Pits and 12d uses the road grade to select which pit family should be sent to Drains. In this example the 
road crossfall would not be used in selecting the pit family. 

The pit group separator is a “-”. This character separates the pit group from the road data.

It is up to the user to decide the grade when the next pit family should be used. In this case the threshold 
value for the gutter grade is set midway between the published values of the inlet curves. For example at a 
gutter grade of 2% 12d starts sending the NSW RTA Pits - 3% slope pit family.

This pit families listed on the right must match exactly with those in the Drains pit database.

Manhole "group NSW RTA Pits" {

//       cross fall,   gutter grade,  cap1,   cap2,   cap3,   cap4pit family

//4d          0,             1,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% slope

//4d          0,             2,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% slope

//4d          0,             4,        0,       0,    0.0,    1.0 NSW RTA Pits - 5% slope

//4d          0,             6,        0,       0,    0.0,    1.0 NSW RTA Pits - 7% slope

//4d          0,             8,        0,       0,    0.0,    1.0 NSW RTA Pits - 9% slope

}

An example with crossfalls follows. 

Manhole "group NSW RTA Pits" {

//       cross fall,   gutter grade,  cap1,   cap2,   cap3,   cap4

//4d          1,             1,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 1% 
slope

//4d          1,             3,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 3% 
slope

//4d          1,             5,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 5% 
slope

//4d          1,             7,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 7% 
slope

//4d          1,             9,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 9% 
slope

//4d          3,             1,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 1% 
slope

//4d          3,             3,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 3% 
slope

//4d          3,             5,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 5% 
slope

//4d          3,             7,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 7% 
slope

//4d          3,             9,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 9% 
slope
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}

The Drains pit family names must match the names in the last column EXACTLY! 

Manhole Types and Pit Sizes
Each Drains pit family has several pit sizes. The Drains pit sizes link to the12d manhole types and 
therefore all Drains pit sizes should exist in the 12d drainage.4d file.

The pit size will be read back from Drains into 12d as the pit type so that it can be placed on the drainage 
long sections and pit schedules.

Pipe Types
The pipe type selected in 12d must exist in the pipe database inside Drains. Simple “2” for class 2 or “RCP 
“do not exist in Drains.

Setting the Overflow Route, the Pit and Pipe types

Position of option on menu: Design =>Drainage-Sewer =>More=>Drainage IO Defaults

On selecting the Drainage IO Defaults option, the Drainage IO Defaults panel is displayed.

The routine changes ALL of your manhole and pipe types in a model to a single value. If you have 
changed your drainage.4d file after creating you drainage network, the manhole and pipe types you 
originally selected may no longer be valid (i.e. in the drainage.4d file).

Field Description Type Defaults Pop-Up

Design Program choice Drains Drains,PCdrain

The drainge model to be updated.

Drainage model file

The drainge model to be updated.

12d pipe types choice values from drainage.4d
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Set all pipe types will set all pipes in the model to this value

12d manhole types choice values from drainage.4d

Set all pit types will set all manholes in the model to this value

Default pit groups choice values from drainage.4d

manhole definitions in the drainage.4d file that have group as a prefix are included.

Default road shape choice values from drainage.4d

type the desired name or if using Drains select the desired shape from the Drains Overflow route 
shapes.

Drains Tab

Drains database file file

pressing enter in this field will start a search for the Drains database dump. The search path is the 
specified folder, C:\Program Files\Drains\Program then C:\Program Files\Drains\Demo\Program. If 
the file is found the choice fields below are populated. It is highly recommended that this file be in the 
12d working folder.

Drains pipe types choice l values from Drains file

the pipe types are retreived from the last Drains database dump. Changing this value will update the 12 
pipe types above.

Drains Overflow Route Shapes choice values from Drains file

the overflow route shapes are retreived from the last Drains database dump. Changing this value will 
update the Default road shape above.

Set all pipe types button

all pipe types in model are set to this value

Set all pit types button

all pit types in model are set to this value

Set defaults button

the defaults for the Drains Overflow Route Shapes and 12d pit group are set

Finish button

removes the panel

Drains Version 2+ Requirements

Manhole Names
The 12d manhole names cannot be more than 9 characters long. 12d uses 2 additional characters to the 
manhole name at export time create names for the pipes, overflow routes and catchments. For example 
manhole “A-1” will have a bypass route “F A-1”, a catchment “C A-1” and a downstream pipe “P A-1”.

Bypass Flow (Overland Flow Routes)
There are 3 requirements for Drains bypass flow.

1. Select Default pit group (Network editor->Defaults->Pits->Pit group). The Drains and 12d databases 
must be in sync.
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2. Bypass strings in the Bypass route model specified (Network editor->Global->Utiltiy Models-
>Bypass flow model. For more details see Bypass Flow.

3. Road grade and crossfall calculated (Network editor->Global->Utiltiy Models->Road design file)

The overland flow strings are not allowed to pass through the outlet pit on the network.

SAG Inlet Calculations
SAG inlets are manholes where the water ponds at the surface rather than flowing past. If a SAG inlet has 
a catchment string the overflow depth and volume are calculated. The catchment string from Set #1 is 
draped onto the design tin and the lowest point in found on the draped string (stored as a 12d pit attribute 
overflow level. The storage volume inside the string up to this point is measured and stored as a 12d pit 
attribute overflow volume from level. The pit cover level and Setout to grate offset are subtracted from 
the lowest point on the catchment string to determine the Max Ponding Depth.

Results
Drains exports the maximum data from all of the rainfall events analysed. Therefore, ensure you analyse 
only the rainfall events desired before coping the results to the clipboard. To verify the data that is being 
sent to 12d, copy the data into a spreadsheet so you can view it there first. The pit sizes selected in Drains 
will be stored in 12d as the manhole type. Therefore the pit sizes in Drains should exist as manhole types in 
the drainage.4d file. If pit families are changed in Drains the pit group in 12d will be updated by search for 
the pit family in the drainage.4d file.

12d to Drains

Setup your drainage network models and ensure they have been assigned pit names.

1. Copy the data to the clipboard

The following interfaces dialogues will appear.

From the Drainage net-
work editor select the 
Import/Export button.



12d Model Reference Manual

Page  2092 June 2002More Drainage

2. From within the Drains program select Edit =>Paste data from spreadsheet. If you paste the data into 
a Drains project that has a hydrological model and rainfall data already defined the project will be 
ready to run.

3. Use the Drains Run=>Standard design to design your pipe sizes and invert levels. The 
Run=>Advanced Design will select the size of the manholes as well.

Drains to 12d Update

The following steps are required to update the 12d model with the Drains hydraulic results and changes to 
the pipe sizes and inverts.

1. To update the pipes and invert levels in 12d, select Edit->Copy Data to Spreadsheet from the Drains 
menu.

2. From within the 12d Drainage network editor select Import/Export.

This should be filled in from the edi-
tor.

Enter the units.

Select Export.

Select Drains clipboard -Ver 5 
Ilsax or Rational.

Data is stored in this file as well as 
on the clipboard.

Not used by Drains

Use the Run button to copy to the 
clipboard.
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IMPORTANT: THE DATA MUST BE PASTED BEFORE THE RESULTS!

12d erases the hydraulic and hydrology data when the physical data is updated. Therefore, always 
paste the data before the results.

This should be filled in by the editor.

Not used on import.

Select Import

Select Drains clipboard - Version 5

Leave as clipboaard.txt

This will ignore the invert levels read 
from Drains and the current pipe obverts 
will remain fixed.

Plan and long section drawings may be 
created at the import time so that you can 
see the results on the drawings.

Select Run to update the drainage model. 
To see the changes in the section views 
you will have to select Regen on the sec-
tion view toolbar.

To return to the network editor select Edit
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Running XPSWMM and RAT2000
The drainage design with all three of the XP software programs follows the same methodology. The 
process is substantially automated with the XP-SWMM program so that the XPX file is automatically read 
by XP-SWMM and automatically created when leaving XP-SWMM.

Drainage design with XP programs includes the following steps.

1. 12d creates an XPX file that is read by the XP programs.

2. The XP program is then run in the design mode to determine the pipe sizes and invert levels.

3. If bypass and overland flows are to be modelled then the inlet capacities need to be defined and then 
run the XP program in the Full Analysis Model.

4. The XP program creates an XPX file for 12d to import.

XP Program Requirements

12d to the XP Programs

The x,y pit layouts and the cover/surface levels are obtained from your drainage network while the 
catchment and overland flow data comes from the models specified in the drainage interface dialogue.

The steps required to transfer the data to the XP programs are as follows.

1. Setup your drainage network models.

2. To create the XPX file for XP programs start the Drainage Network Editor and select Import/Export

The following interfaces dialogues will appear.

If exporting to RAT-HGL the following dialogue will appear.

3. The XP SWMM program will automatically startup and load the XPX file. 

From within RAT-HGL, either select File =>New and follow the input prompt or load a file that con-
tains all of the pit inlet rating curves, hydrological and design data without a pipe network. Many users 

Select Export

Select XPSWMM or RAT HGL from 
the drop down list.

Enter the name of the xpx file to be 
created.

Not used at this time.

Finally, Select the Run button to create 
the file.

If you are using old versions of RAT-HGL (1996 or 
earlier) select use Local otherwise select 4D units 
(eastings and northings). 

Select process.
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have such RAT-HGL files setup so as to streamline the design process.

The xpx file for RAT2000 will have the file startup.xpx added to it so that you may include all the star-
tup global data that you require. The 
Fixed inlet capacities and rating curve names indicating road grade and crossfall may be set in the 
drainage.4d file. The format for these names is pit name-crossfall-road grade (ex SA2-3-4). These 
curves must exist in this file. 

4. To read in the pipe file created above, select Special =>Import Data and select the xpx data file. 
Warnings will be given stating that several fields are inactive. This is expected as more data is sent to 
RAT-HGL than is needed at this time. Select the Close Square on the Help title area and the pipe net-
work and catchments should now appear on the screen.

5. If you want RAT-HGL to redesign you network, change the analysis mode to Design mode by selecting 
Special=>Job Control and Select Design mode. Do not do this if you want to analyse the network you 
layed out in 12d (used for existing systems).

6. Select the rainfall events to design/analyse and the LB (twice) on OK to return to the layout. Now 
select the outlet and enter the starting tailwater levels.

7. Now you can run RAT-HGL (Special =>Solve).

XP Programs to 12d

Once you have your design finished, the following steps are required to update your 12d model. Your 
design may contain several return periods in the analysis (Rp1 to Rp7) but 12d reads only the results from 
Rp1. The following table is taken from the RATHGL output file (*.out extension) and the results indicated 
are read back into 12d via the xpx file.
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In addition to the results, the following input data is read back into the 12d model so that it may be 
exported back to RATHGL in the future (if required). 100% of your RATHGL data is not included in the 
XPX formats and the contents of the XPX file will depend upon your design mode. Therefore, use caution 
if you read an XPX file into an existing RATHGL model and check your data once inside RATHGL. 

1. From within RAT-HGL, produce an XPX file for 12d to read by selecting Special=>Export Data and 
following the default prompts.

2. From within 12d, select the Import/Export button on the Drainage Network Editor.The following 
panel will appear.

HGL  PIPE  NETWORK  ANALYSIS  SUMMARY    RETURN PERIOD   5 YEARS
        PROJECT:12d DRAINAGE LAYOUT                                       

 ---------------------------------------------------------
 |ITEM DIM| RESULT                                                               
 ---------------------------------------------------------
 RN       -       1       2       3       4       5       6
 NN       -     1-1     2-1     1-2     3-1     1-3     1-4
 DN       -     1-2     1-2     1-3     1-3     1-4     1-4
 MT       -      99      99      99      99      99       0
 DHGL     M  29.258  29.258  28.139  28.139  27.269    .000    DS HGL
 DD       M    .225    .375    .375    .300    .450    .000    Diameter
 DCTL           HGL     HGL     HGL     HGL     HGL        
 DO       M    .225    .375    .375    .300    .450    .450
 QO    M3/S    .033    .181    .237    .075    .334    .353    Flow
 VELD   M/S    .826   1.639   2.148   1.065   2.100    .000
 NORM     M    .106    .264    .271    .153    .289    .000
 CRIT     M    .152    .314    .345    .215    .396    .000
 KP       -     .00     .00     .00     .00     .00     .00
 SF     M/M   .0040   .0082   .0140   .0046   .0107   .0000
 LEN      M   45.93   18.44   54.65   31.31   49.91     .00
 HGLP     M  29.444  29.409  28.905  28.284  27.802    .000   US HGL
 DU       M    .225    .375    .375    .300    .450    .000
 VELU   M/S    .826   1.639   2.148   1.065   2.100    .000   Velocity
 UCTL           HGL     HGL     HGL     HGL     HGL        
 KU       -    1.50    1.50    1.50    1.50    1.50     .00   Ku
 KL       -    1.50    1.50    1.50    1.50    1.50     .00
 KR       -    1.50    1.50    1.50    1.50    1.50     .00
 KW       -    1.50    1.50    1.50    1.50    1.50     .00   Kw
 UHGL     M  29.496  29.615  29.258  28.370  28.139  27.269
 LHGL     M  29.496  29.615  29.258  28.370  28.139  27.269
 RHGL     M  29.496  29.615  29.258  28.370  28.139  27.269
 UWSL     M  29.496  29.615  29.258  28.370  28.139  27.269   HGL PIT
 MWSL     M  30.297  29.615  29.403  28.875  28.340  27.369
 AF    M3/S    .033    .207    .023    .094    .040    .000
 IF    M3/S    .033    .181    .023    .076    .023    .023
 IC    M3/S    .036    .227    .026    .076    .023    .023
 BF    M3/S    .000    .026    .000    .019    .017    .000
 ID       M    .000    .000    .000    .000    .000    .000
 ITW      M    .000    .000    .000    .000    .000    .000
 IVEL   M/S    .000    .000    .000    .000    .000    .000
 IVD   M2/S    .000    .000    .000    .000    .000    .000
 FC       -               *               #       #       #
 ---------------------------------------------------------
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Select Import.

Select to select RATHGL or XP-
SWMM.

Select the file name specified in step 1

Select Run to update the drainage model 
and import hydraulic/hydrological 
results.
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Detailed Drainage Plan Drawing
12d drainage has the capability to create detailed drainage plan drawings with the following features:

s create symbols at the manholes and the type of symbol is controlled by the manhole type (given 
when you create the manhole).

s draw lines with line styles to represent pipe sizes

s create text labels for manhole types

s create text labels for pipe diameters and inverts

s create text labels for house connection types, invert levels and chainages

s indicate direction of flow on pipes.

An example is shown below

Usage

This option is accessed from the menu selection 

Design => Drainage-Sewer => Plots => Plan Annotations
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Plot parameter file file box

Optional - no dpf is required. The default settings will create a schematic drainage drawing. A custom 
dpf may be selected if desired.

Load design details from model box

data source for drainage strings to be labelled

Save plot annotations to model box

labels to be created are stored here, Undo will remove the labels created
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set colour as string name? tick box

when selected the string colour will be used for the string name (to be used for DWG/DXF export using 
map files)

Plot button

Creates the labels in the model specified

Find button

used to locate plot parameter input boxes using Version 5 plot parameter names

IMPORTANT! to turn off any data change the text height to zero.
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Reviewing, Changing and Creating User Defined Attributes
The catchment data is stored within 12d as user defined attributes. These attributes are automatically 
created by 12d when required but you are free to change them or add more as desired. The attributes may 
be exported to a spreadsheet and edited and then imported back into 12d. To work with the user defined 
attributes within 12d select

Design=>Drainage-Sewer=>More=>Top 10 Attribute Editor. 

The following dialogue will appear.

They may not be defined for the pit you are editing. Not found will be displayed in the Data field if the pit 
does not have that attribute defined.

To change the value for the attribute 
enter the new value in the data field. 
If the attribute does not exist, 
deleting the not found text and 
adding data will create it. The 
message on the right will be 
displayed whenever you are creating 
a new attribute.

First Select Pick to select the string that 
contains the user attributes (the drainage 
string). The strings will be highlighted in 
white when they are selected.

All catchment data is store with the pits in 
drainage strings. To access the pit 
attributes, select the drop down icon and 
then select Pit. A circle will be drawn 
around the pit selected. Next and Prev 
will now move you from pit to pit.

Select the drop down icon and then select 
the Attribute Name from the list of 
existing user defined attributes. These 
attributes include all of the attributes in 
the model that the string exists in. 
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The drainage.4d file
The drainage.4d file controls many of the settings for the pit and pipes types inside 12d. This section 
details the format of the drainage.4d file. Changes to this model take effect only after 12dmodel has been 
restarted. 

The original drainage.4d file is found in the “program file\12d\12dmodel\7.00\set_ups” directory. Do 
NOT change this file. Copy it into “program file\12d\12dmodel\7.00\user” directory and edit it there. 
Files in the user directory are used by preference and they are never over written by a 12d update.

The format of the entries is a follows.

1. All lines are to be blank or begin with //. This is not the normal 12d convention.

2. //SIZE indicates the values to be read and stored in the user defined pit attributes 
pit internal width and pit internal length when the pit schedule macro is run. A comma is used to 
separate the two values.

3. //DESC indicates that the following quoted text will be read and stored in the user defined pit attribute 
pit type description when the pit schedule macro is run.

4. The pit inlet capacity table data must begin //4d and commas are used to separate the data (comma 
delimited).

5. SAG pit names must begin with the 3 letters SAG.

6. The sample data provided is taken from the paper, “Mathematical Description of Pit Entry 
Capacities”, Feb 1992, by Geoffrey O’Loughlin et al. 

Pit Inlet Capacities

The pit inlet capacity tables contained within the drainage.4d file are used by the drainage design 
packages in different ways but with a common philosophy. An example entry may be found in the section 

Manhole "SA2" {// internal pit size data (width, length)
//SIZE   100, 200
//DESC  "2m lintel - grate and side entry"
// pit inlet capacities from Mathematical Description of Pit Entry Capacities Feb 1992
//       cross fall,   gutter grade,  cap1,   cap2,   cap3,   cap4
//4d          1,             1,        0,       0,    0.230,  .621 
//4d          1,             3,        0,       0,    0.225,  .604 
//4d          1,             5,        0,       0,    0.215,  .577 
//4d          1,             7,        0,       0,    0.200,  .538 
//4d          1,             9,        0,       0,    0.235,  .593
 
//4d          3,             1,        0,       0,    0.495,  .819 
//4d          3,             3,        0,       0,    0.270,  .568 
//4d          3,             5,        0,       0,    0.290,  .599 
//4d          3,             7,        0,       0,    0.400,  .727 
//4d          3,             9,        0,       0,    0.330,  .649

//4d          5,             1,        0,       0,    0.540,  .793 
//4d          5,             3,        0,       0,    0.480,  .747 
//4d          5,             5,        0,       0,    0.460,  .744 
//4d          5,             7,        0,       0,    0.450,  .729 
//4d          5,             9,        0,       0,    0.420,  .704
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“The drainage.4d file” on page 2102

On grade pits

Crossfall data must never decrease moving down the table while the gutter grade data must increase for a 
constant crossfall. When the tables are being read, the next set of capacity factors will not be used until the 
crossfall and grade are equal to or exceed the values in the tables. The factors are not interpolated!

Drains and ILSAX

The cap1, cap2, cap3 and cap4 values are used to describe the inlet capacity of the pit as described in their 
user manuals.

RAT-HGL

If cap2, cap3 and cap4 are all equal to zero then a fixed inlet capacity equal to cap1 will be exported to 
RAT-HGL. If the sum of these three values is greater than zero then a pit type will be created in the format 
of pit_type-crossfall-roadgrade. For example SA2-3-2 for a SA2 pit with a road crossfall of 3% and a 
road grade of 2%. A rating curve with this name will have to exist inside RAT-HGL. 12d has no way of 
transferring the rating curve itself into RAT-HGL.

PC Drain

Similar to RAT-HGL, PC Drain has it own rating curves defined internally. The road grade is sent as a 
separate piece of data to PC Drain so that the pit inlet capacity may be determined.

SAG Inlets

Sag inlets always have a manhole type that begins with the three letters SAG or for PCdrain they end in a 
S. Sag pits contain only one line of data and an example follows.

Manhole "SAG3" {

// pit inlet capacities from Mathematical Description of Pit Entry Feb 1992

// if zeros are entered Sc1 and Sc2 then calculated crossfalls (if available) are used for 
Drains and ILSAX

// Sc1 and Sc2 and the slope upstream on the overflow path is used for Sl1 and Sl2

//       Sc1   ,     Sc2      ,  Sl1    ,   Sl2  ,   lintel length,   max depth

//4d        3.0,           3.0,      0.5,     0.5,               3,        .150 

}

Special conditions exist for each of the following programs.

Drains and ILSAX

RAT-HGL, RAT 2000 and XP SWMM

No direct means of specifying SAG pits has been established. A fixed inlet capacity before bypass begins 
can be calculated and entered with the format of an on grade pit. Cap1 would represent the inlet capacity 
with cap2,cap3 and cap4 being set to zero.

PC Drain

PC Drain places a suffix code in the pit type to specify that the pit is a SAG pit. For example an 9S0.03 
indicates that pit type 9 is a sag pit and the maximum depth before bypassing is 30mm.
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Flooded Width Analysis and HEC RAS
The Calculate Flooded width procedure creates cross sections along the bypass flow paths and then 
calculates the flooded width at each section using Manning’s normal depth calculations. A HEC-RAS 
project (same name as the bypass flow string) is also created for each line. The flooded width is indicated 
on each section as a blue line if it is less than a user defined width and a red line if the flooded width 
exceeds the limit. Details of the calculations such as the velocity, depth, wetted perimeter and slope can be 
exported to a spreadsheet for further analyse (velocity times depth calculations for example). The 
discharges imports from the urban stormwater design packages are shown in the following table.

The user defines the length of these sections and the interval at which they are to be spaced. 12d calculates 
the normal flow depth interpolating the pit approach and bypass flows from the hydrology models 
(ILSAX, Drains, PC Drains or RAT HGL). The cross sections are taken perpendicular to the flow line and 
the slope is for the normal depth calculations is determined using the distance along the flow line and the 
change in elevation between the two lowest points in the primary flow channel. The flow line need not 
intersect the low points on the section but the flow line does mark the primary flow channel. If  the depth 
of the flow exceeds the banks of the primary channel, then all adjacent flow channels will be considered as 
active flow area.

Limitations where overland flow lines join

Where overland flow lines converge at a manhole, 12d does not know the flow split between the 2 
approaching paths. Therefore, 12d uses the total flow from all lines as the flow at the manhole for each 
line. This may overestimate the flooded width along the flow lines at these points.

Limitations at SAG pits

The flow width are not shown adjacent the sag inlets. The depth of flow due to ponding and the approach 
flow coming from several directions may overestimated flooded width in these areas. Therefore not flood 
depths are caclulated approaching SAG inlets.

Design 
Program

Discharge Event

PCdrain Minor ARI
Drains Maximum flow event 

analysed
ILSAX Maximum flow event 

analysed
RAT HGL First return period analysed



Chapter

June 2002 Page  2105More Drainage

Manning’s n is the n value to be used in the normal depth calculations.

The Flow correction factor is the factor described in ARR 1987 for calculating depths of flow in gutter 
channels.

Distance between sections specifies the interval at which cross sections and therefore flooded width will 
be calculated along the flow path.

Section Length defines the length of each cross section. The cross section will be centred on the overland 
flow path.

Trim HEC-RAS sections at levee is used for super critical flow calculations in HEC-RAS. If you plan to 
do super critical flow calculations then check this box. A levee point is the crest in the cross section found 
as you move away from the flow line location. If a levee point is encountered then the section is trimmed 
here. This is a feature because HEC-RAS has problems with cross sections with levees.

Cross Sections and Discharges

The analyse flooded width will proceed along each flow path and identify every pit on the line. Cross 
sections will be constructed in the model with the length and interval entered in the input dialogue. These 
cross sections may be plotted using the main menu selection Plot=>X plot=>X plot . The Sort Sections 
must not be selected for these sections to be plotted.

Discharges will be determined for each cross section by pro-rating the discharge dependant on the distance 
between the pits. The bypass discharge will be taken from the upstream pit and the approach discharge of 
the downstream pit.

12d will give warning messages in the output window when it encounters the following conditions and 
these messages will be stored as string attributes on the flooded width strings. Descriptions of these 
messages follow.

Inverts do not go downhill

12d locates the lowest point (adjacent to the flow line without moving over a local crest) on each cross 
section to calculate the slope between the cross sections. This message indicates that the downstream 
minimum elevation is higher than the upstream minimum elevation.

Sometimes flow lines will go uphill. If you have specified an overflow from a SAG location then the flow 
line will go uphill until it crosses the overflow crest.

If the flow line is not supposed to be going uphill at this section, check to see where the flow line intersects 
the cross section located upstream of the one identified in the warning message. If it is in a local sag point 

Enter the drainage network model.

Enter the model that will contain the actual flooded width 
lines.

Enter the model that will contain the cross sections. The 
calculated values such as velocity and slope are stored with
these lines.

Select the tin that will be used to create the cross sections.

The flooded width will be drawn in blue in the results 
model when it is less than the  Max flooded width. If  the 
flooded width exceeds this value it will be drawn in red.
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that is not the lowest point on the section, move the flow line.

The program will use a slope of 0.5% to calculate a width at this location. This results in very wide flooded 
width sections to draw the user’s attention to the problem area.

Vertical Walls Assumed at the Ends of the Cross Sections

If the depth of flow exceeds the ground surface elevation at the ends of the cross section a warning 
message the warning message shown above is shown. The cross sections causing the warning follows.

The vertical wall is placed at cross section chainage –20. Note that the flow line is always at chainage 0
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Drainage Overflow Areas from Volumes
This option is used to graphically display the overflow storage volume at a sag pit. The following pit 
attributes must exist for the flood extents to be calculated.

overflow volume value greater than zero required.

sag pit must be equal to 1.

catchment model id set by labelling catchments

catchment string id set by labelling catchments

The maximum storage volume is read from the drainage pit attribute "overflow volume". This may be 
entered manually using the Attribute Editor or it will be created when data is read from the drainage 
design programs Drains or XP SWMM design programs.

This routine locates the lowest point on the catchment string by draping the string on the tin specified and 
adds the overflow limit specified to this value. This becomes the overflow limit.

The volume at this level is calculated and the compared to the overflow volume read from the user defined 
attribute.If the overflow volume is less than the volume in the catchment then the routine iterates to find 
the flood level for the overflow volume.

If the overflow volume is greater than the volume in the catchment, the results repend of the  Use overflow 
limit tick box. 

If the box is selected, the overflow limit (calcuated above)is reported at the flood level in the catchment.

If the tick box is not selected the routine iterates to find the flood level where the storage equals the 
overflow volume read. This option allows the user to see the maximum flood level should the catchment 
low point become blocked.

See Also

Drainage overview

Usage

This panel is accessed from the menu selection Design => Drainage Sewer => More=>Calc pit overflow 
areas

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Drainage model model box
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all pits in this model that have a non zero "overflow volume" and "sag pit" set to 1 will be processed

Flood limits model model box

flood limits strings will be created in this model

Surface Tin tin box

ground surface tin used to calculate the volumes and flood limits

Flood limits colour colour box

flood limits strings will be created using this colour

Clean limits model tick box

if selected all strings in the Flood limits model will be deleted before the calculations commence.

Use overflow limit tick box

if the elevation calculated from the storage volume is higher than the lowest point on the catchment 
string then the allowable surcharge value below will be added to the lowest point on the catchment 
string and this elevation will be used to determine the flooding limits

Allowable surcharge real box

this value is used only if Use overflow limit is ticked. Its purpose is described in the field above.

Process button

executes the option.

Finish button

removes the dialogue from the screen
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Drainage Utility Program
utilities_panel

Position of option on menu: Design => Drainage-Sewer =>More => Misc. utilities

The Drainage utility program contains functions to significantly reduce the time required to perform 
drainage tasks. These tasks include

Assign Pit names

To use the export routines, every pit in 12d must have a pit name. This selection automatically creates the 
pit names for the entire model or selected strings. Examples of pit names are 1,2,3... A1,A2,A3....Pit 3-A, 
Pit 3-B.

Reset pit cover levels

This selection sets the cover levels for the manholes to the design tin or design strings. The user will be 
prompted for each manhole to select a tin level, a string level (if a design string model is supplied) or keep 
a manually set level. The tin/string/manual selection will be stored and the levels reset now and whenever 
the pit/pipe interfaces exports the data (unless this last option has been manually turned off).

Regrade pipe levels

The selection applies the default grading rules (cover level) to reset the pipe invert levels for the entire 
network. Manhole cover levels are not changed during this function

Label Catchments and Label drainage network

This selection quickly creates labels for a drainage and catchment plan. The pits are labelled with their 
name, the pipes with their diameters and the catchments with their area and the pit they drain to. These 
labels must be updated using this selection whenever the catchment or network is changed. To turn off the 
automatically drawn pit names in the current view select Menu=>Settings=>Text=>Toggle and select the 
drainage model.

Analyse Flooded Width

This is the only hydraulic calculation that takes place in 12d. The normal depth along the bypass flow 
paths is calculated using discharges imported from hydrology/hydraulic packages including spreadsheets. 
This flooded width is drawn to scale at intervals along the bypass flow path and colour coded (blue if less 
than a specified limit and red if greater than the limit).

See Also
Drainage overview

Usage

This panel is accessed from the menu selection 

Design => Drainage-Sewer => More => Misc. utilities
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

drainage model input box

Model to contain all of the pit and pipe network to be worked on.

catchment area model input box

Model to contain the catchments strings for the Drainage Model above

Assign pit names button

This button launches a dialogue for setting the names for the pit and pipes in the network model. 

design tin tin box

This optional field allows the user to specify a new tin for the surface levels of the pits. If you are using 
road grade and cross fall for pit inlet capacity it is preferable leave this blank and to link the pits to a 
string using the design model field below. If some or all of the pits are linked to strings in the design 
model below, they will still use the strings selected. more about design strings

design model model box

This model contains the strings for the pit cover levels (the string directions are also used for road 
grade and cross fall). If this model is changed you will be prompted to select new strings to link the pits 
to. more about design strings

Reset pit cover levels button
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This button will reset the pit levels to the design strings in design model or to the tin specified in design 
tin above. The first time this is selected you will be prompted to choose whether to set the pit cover 
level to the design tin or the a string in the design model. more about design strings

Regrade pipe levels button

The selection applies the default grading rules (cover level) to reset the pipe invert levels.

network labels model model box drainage labels network

Model to contain the network labels for the Drainage Model above. This model is cleaned out each 
time Label drainage network is selected.

catchment labels model model box drainage labels catchment

Model to contain the catchment labels for the Catchment Area Model above. This model is cleaned out 
each time Label catchments is selected

catchment units choice box ha, acres

Conversion factors of 10,000 will be used for ha and 43560 for acres.Not that not all design packages 
support both units.

text parameters input box

Select the + to access the text parameters (colour, size, alignment etc.) for the text created with Label 
Catchment or Label drainage network

label catchments button

This selection creates labels indicating the catchment name and area in the units specified above. 

CAUTION: If you change you catchment strings or rename you pits you must run this routine to 
update the labels.

label drainage network button

This selection creates labels indicating the pipe size and pit name for the network model. 

CAUTION: If you change you change the pipe sizes or rename you pits you must run this routine to 
update the labels.

analyse flooded width button

This selection launches the dialogue for analysing the flood along bypass flow paths. The bypass flows 
must be imported from your design package/spreadsheet before running this selection.

drainage_utilities_panel_assign_pit_names

Set Pit Names
The Set pit name selection names the pits and pipes for the drainage model (both pits and pipes can be 
named). Three numbering schemes are available:

drainage strings names are used as the prefix followed by the pit number (ex A-1)

drainage strings names are used as the suffix followed by the pit number (ex 1/A)

the pits are sequentially numbered. (ex 1,2,3....)

The names can have pre-text added to the beginning of the pit name and a separator between the string 
name and the pit number (/- etc.) if desired.
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Design Program Notes:

PCdrain users: Since catchments contain only 3 characters do not use separators. Using the letters A-Z 
for strings and numbers 1-99 will give you 26 strings and up to 99 pits on each string. Using the numbered 
stem works very well in PC Drain.

Micro Drainage users: Pits and pipes are numbered separately in Micro drainage. The pipes must use the 
numbered sequence with the most upstream pipes numbered with the smallest numbers. Number of digits 
must be set to 3.

ILSAX users: You must use alphabetic characters for your string names and no more than 3 characters

See Also

Labelling a drainage network

Displaying the Auto Pit Names

Drainage overview

Usage

The selection is found on the drainage network editor and is accessed through the main menu by selecting

 Design=>Drainage-Sewer=>Drainage Network=>Drainage=>Network editor

Select the Set Pit Names button and the following panel will appear.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model Model box drainage model
from main dialogue

Naming Method Choice box

Pit num - String name for string A manhole 1 the name is 1A
String name - Pit num for string A manhole 1 the name is A1
Sequential numbering the strings names are sorted alpha-numerically and the manholes are num-
bered starting at First pit number

Pre text input box

this text will precede the pit name  (ex Pit A01)
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String/pit separator input box

the character that separates the string name from the pit number. For example if pit names A/01, A/02 
etc. where desired a  "/"  would be entered. You may omit the separator if none is desired. 

First Pit Number integer box

the starting pit number on the drainage lines. For drainage strings with the flow direction set as 
descending chainage the first pit is the junction pit.

Min digits in pit numbers integer box

a non zero value will pad the pit numbers with leading zeros. (ex if 2 is entered, pit 1 is not A/1 but 
rather A/01)

Reverse numbering order tick box

Unselected, pit First pit number  is at the low chainage end of the line. Selected, pit First pit number  
is the second pit from the high chainage end of the line.

Number pits tick box

the pits are assigned names. This allows the pit and pipes to be names differently.

Number pipes tick box

the pipes are assigned names. This allows the pit and pipes to be names differently.

Run button

  name the pits/pipes. The pit at the high chainage of the string is not labelled. The only time you will 
need to name this pit is when it is the outlet from the system.

Back to Editor button

return to the network editor.

Help button

display this page.
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Drainage Input/Output Interface
Drainage_interfaces_panel

Position of option on menu: Design => Drainage => More=> pit/pipe design interface

See Also

Drainage overview
Drainage Misc Utilities
Spreadsheet clipboard
Running Drains
Running PCdrain (Windows)
Running Micro Drainage - Win DES
Running XPSWMM
Running RAT2000

Usage

This panel is accessed from the menu selection Design => Drainage => More=> pit/pipe design 
interface

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

import/export format <c> input box XP SWMM Spreadsheet clipboard,
Drains clipboard
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PCdrain Int (windows)
RAT2000
XP SWMM
Micro Drainage
Drains
PC Drain (DOS)
RAT HGL
ILSAX

select the drainage design program to export/import to.

drainage model input box

Required Model to contain all of the pit and pipe network to be exported/imported. Also see Drawing 
the Drainage Network

file name input box

Required file to be read or written to. If a clipboard format is chosen for import/export format above 
then the data will also be written to this file on a Copy selection

catchment area model input box

Optional model to contain the catchments strings for the Drainage Model above. Also see Designating 
Catchment Areas

catchment units <c> input box ha, acres

Conversion factors of 10,000 will be used for ha and 43560 for acres.Not that not all design packages 
support both units.

catchment characteristics modelinput box

Optional strings in this model will be used to define the catchment slope and width (XP SWMM only) 

bypass flow model input box

Optional model to contain the bypass flow strings for the Drainage Model above. Also see Creating 
Bypass Flow Strings

road design string model input box

Required if bypass flow model is specified above. Also see Pit Inlet Capacity, road grade/crossfall 
and Bypass routes

services model input box

Optional if the strings in this model cross the drainage network the crossing data (drainage chainage, 
invert elevation and thickness) will be sent to the design package

additional services model list (file)input box

Optional if your services lie in more than one model then enter a text file name here and then select edit 
from the fields file icons. Type the names of all of the service models and then save the file.

project description input box

Optional this description will be sent to the design program

export pipe diameters and invertstick box

Select this tick box to export the pipe diameters and inverts. see also Quick Check Lists for Drainage 
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Design Software

export default catchment/pit parameterstick box  tick

selected all default catchment parameters are exported
not selected only catchment area is exported if catchment area model is specified above. see also 
Quick Check Lists for Drainage Design Software

Options button

several calculations are preformed before all exports. Advanced users may turn some off for large 
models (100’s of pits). The option to re-link your pits to new design strings is also included here. 
More options

Write/Copy button

This will create/over write the file specified above in file name. If Copy button is present the data will 
also be placed on the windows clipboard as Tab delimited text.

Read/Paste button

Read will read the file specified above in file name. Paste read the data from the windows clipboard. 
Both selections will update the drainage strings in the model specified above in drainage model.If the 
Spreadsheet clipboard import is selected and the strings are not present in the model they will be cre-
ated.

Options
Drainage_interfaces_panel Drainage calculation options
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Selecting the Options but-
ton brings up the dialogue 
to the left. Additional 
choices may be present at 
the bottom of the dialogue 
depending on the Import/
Export Format that you 
selected on the main dia-
logue.:

Catchment areas when 
selected the catchment 
areas are linked to the 
drainage pits and the areas 
recalculated. See also Des-
ignating Catchment 
Areas

Re-link pits to road 
strings-tin when selected 
a dialogue for each pit will 
be presented asking which 
design string or tin to link 
the pit to. See also Select-
ing design string or tin

Calculate bypass flow 
routes when selected will 
calculate the downstream 
bypass pit, road grade and 
crossfall and inlet capaci-
ties. See also Pit Inlet 
Capacity, road grade/

crossfall and Bypass routes

Calculate now will calculate the selected option immediately and return the user to the main dialogue.

Set will set the options but no calculations will be performed until a Write or Copy is selected from the 
main dialogue.

Finish removes the panel from the screen.
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Drainage_

Position of option on menu: Design =>Drainage-Sewer =>

On selecting the xx option, the xx panel is displayed.

These defaults are used when creating a manhole in a drainage string. The fields and buttons used in this 
panel have the following functions.

Field Description Type Defaults Pop-Up

input

comment

Finish button

removes the panel

Help button

displays this help page
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19  Rivers
rivers

Position of menu: Design=>Rivers

The Rivers option is used to prepare data for analysis packages and examine the results from the analysis.

The Rivers walk-right menu is:

See Also
Frequently Asked Questions (Rivers)

River Interface Models

HEC-RAS Interface

XP-SWMM Interface

XP SWMM Culverts

MIKE11 Interface

UNET Interface

ISIS Interface

River Mapper

Presenting Water Level Results

How to for Rivers

Rivers beta menu
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River Interface Models
The River interface strings are split into different models depending on the strings function. Also the string 
names are used to define names of entities such as cross sections and reservoirs when they are exported. 
Following is a list of the river interface string types:

River strings

Source strings

Reservoir Strings

Spill Strings

River Strings
The river centre line and bank are defined by the strings in the River strings model. 

The centre line string is used to

s measure the centre line distance between the sections,

s mark to zero chainage (or starting chainage) on the cross section, and

s if automatic source strings are created they will be perpendicular to this string

s define culvert locations and sizes (XP SWMM only)

The left and right bank strings are used to

s measure the bank distances between the sections and

s mark the cross section chainage where the conveyance (usually roughness) changes

The names of the strings must be left bank, right bank and centre line river name,reach name (centre 
may be spelled center). 

The left bank is on the left side of the river looking downstream and the right bank is on the right (looking 
down stream). These strings need not touch each other and may extend from one river reach to another.

HEC RAS and UNET

The centre line string must begin at the downstream end of the river. The modelling convention for these 
programs is to have the low chainage at the downstream end. You may use super, 2D,3D or alignment 
strings in this model. If you put other strings in this model you will receive warning messages saying that 
these strings will not be used.

Each reach of the river MUST have its own centre line string and they must "touch" each other to create a 
river confluence. 

A sample of a river strings model for HEC RAS with one confluence is shown below. The line style for 
the centre line is not required. It is used only to show the direction of the centre line string.
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Notes:

left bank strings are shown in red, right bank in blue and centre line strings in yellow and green. The line 
style for the centre line strings is Drainage_4D->Flow line. This is not required but shows the direction of 
the string. The string labels were created with Strings->Label->User->Label strings with names.

Centre line string direction is very important!

HEC RAS, UNET, XP SWMM start at the DOWNstream end of the river

ISIS and Mike 11 start at the UPstream end of the river

ISIS and MIKE11

The centre line strings are drawn starting upstream for the ISIS and Mike 11 programs.
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Source Strings
Cross sections are created at the location of the source strings. These source strings are initially created at 
a user defined spacing and section length using any one of the river interfaces writers. The user may  alter 
these sections as desired. These may be shortened if they intersect at sharp bends in the river; they may be 
extended at extremely wide river sections or extra points may be added so that the section is no longer a 
straight line.

Source strings can be deleted and additional sections can be added by creating new source strings. The 
Create source strings tick box on the interface panel must NOT be selected to use the customised strings.

A sample of source strings (shown in magenta) is presented below. The source strings may run in any 
direction except for Mike11. In Mike11, the cross sections will be created in the same direction as the 
source strings. For all other interfaces the low chainage will be used for the left bank (section viewed 
looking downstream).

Reservoir Strings
The reservoir strings may define inline reservoirs or offline storage. The elevation of the first point on the 
string sets the maximum level to be used in the stage storage curve. 12d will determine the minimum level 
inside the reservoir string and then calculate the volumes at a 1m (2 foot for imperial units) increment. The 
default increment may be changed by creating a string attribute "stage increment" (see  stage increment).

Inline reservoirs are "touched" by centre line strings both upstream and downstream. Offline storage areas 

A quick way to manually create 2 point string is via the CAD tool 
bar.
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are linked to the cross sections via Spill strings.

Other features of the reservoir strings are

Auto height

XP SWMM catchment parameters

A sample drawing showing an inline reservoir in cyan (1-277) follows. Note that the river centre line 
touches the reservoir string both upstream and downstream. The left and right bank strings may continue 
straight through the reservoir.

A sample drawing of an offline reservoir follows (the reservoir string is shown in green). Note that the spill 
string (black) starts at the source string (point 1), then follows the section line to be cut and exported 
(points 2 to 5) and ends by touching the off line reservoir string at point 6. The rivers strings do not touch 
the offline storage strings.
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Spill strings
Spill strings are strings that link offline storage areas to a cross section (see drawing above). The string 
must begin by "touching" the source string and then proceed to the first point on the spill section. During 
the export the first point will NOT be exported as part of the spill section. After defining the end of the 
spill section the last point on the string must "touch" the reservoir string. Again this last point will NOT be 
exported as part of the spill section.

The default roughness for the spill section is the "left n" from the main export panel, the default slope is 
0.5% and the default length is 100. See the manual setting table for manual override settings.

Define Culvert Locations
12d allows culverts to be included as a segment of a super string. The XP SWMM rivers interface allows 
culverts in 2 models. In the spill string model, a two point superstring may cross a spill string  to indicate a 
culvert through the embankment. In the river string model a segment of the river centre line may marked as 
a culvert. If a source string crosses the same segment than a mulit-link with both the culvert and the natural 
section will be exported.

Adding a Culvert to a super string
1. Super strings only! 

Convert string to a super string (if  required) 
Strings->Convert

2. Mark the ends of the culvert.
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Add a vertex at the upstream and downstream end of the culvert (Toggle vertices on if desired)
String->Points Edit->Insert

3. Mark the segemnt as a culvert or pipe
Use the super string segment editor to set the culvert data.
Strings->Properties->Segments (all) and change Segment properties to use culvert each segment 
(box) or pipe each segment (round). Note that if there is one box culvert on the centre line then all 
must be box culverts. If you need pipes and box culverts combined, set the width to zero for pipes. 
Also set the Justify mode to indicate the type culvert levels you wish to specify.

If there are two (max is 7) culverts at this location that have different inverts or sizes add the following 
user defined attributes to the segment. The comment attributes are printed by the Culvert Table  routine 
and are used to label the culvert as well. If there are a number of identical culverts, the attributes 
"number of pipes" (integer) can be set to a value greater than 0. Additional attributes to customuse the 
culvert are listed at the end of this section. Default mannings n are 0.024 for pipes (corrigat metal) and 
0.012 for box (concrete).
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4. Set the upstream and downstream levels
Select a vertex at the end of segment, ensure the height mode is each vertex and set the height. Use the 
Next or Prev button to move to the other end of the culvert and set its height as well.

Culvert Segment Attributes

Purpose Attribute Name Type
Typical Data 

Value

Culvert entrance loss entrance loss Real 0.5

Culvert exit loss exit loss Real 1.0
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Culvert length length Real 8.0

Multiple identical culverts number of pipes Integer 2

Purpose Attribute Name Type
Typical Data 

Value
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Culvert Table
Culvert_table_panel

Position of option on menu: Design=>Rivers=>XP SWMM interface=>Culvert table

This option is used to create a table of the culverts created along the centre line of the river and to label the 
invert levels and comment for the first culvert on each segment (some segments may include attributes for 
more than on culvert). A sample is shown below.

See Also

Defining culvert locations

Usage

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

River string source input view string,model,view

the imported cross section strings will be stored in this model

String,Model,View various

centre line string selection

Output file File box

text file to contain the table

Culvert Listing
chainage Number US InverDS Inver Height Width QuantityX location Y location Comment Segment

Centre linecenter line 1
88444 1 125.28 124.95 11 7 1 683236 1389459 705
87269 1 127.58 127.24 6 1 683059 1390605 72/cmp 695
85983 1 123.13 123.72 6 1 682871 1391834 inv-72/cm 682
84317 1 124.15 123.47 6 1 681757 1392779 666
84317 2 124.59 125.15 6 0 1 681757 1392779 6ft cmp 666
83854 1 123.07 123.28 5 1 681319 1392820 60 inch co 659
83854 2 123.54 123.42 5 1 681319 1392820 60 inch co 659
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Include format codes tick box

format codes are used to format tables in 12d...not desired for other programs

Label string tick box

The invert labels and the pipe size will be added as vertex and segement text

Process button

executes the option.

Finish button

removes the dialogue from the screen
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HEC-RAS Interface
HEC_RAS_Interface

Position of menu: Design=>Rivers=>HEC-RAS interface

The HEC-RAS interface creates the HEC-RAS project files ready to open and run. This includes the 
project, plan, flow and geometry files. Water levels are read back into 12d where they may be viewed in a 
3D perspective view to easily identify extents of flooding.

The HEC-RAS walk right menu is,

See also

River and Source Strings

Create HEC-RAS files

Read HEC-RAS results

Presenting Water Level Results

Import cross sections (GIS file)

Read HECRAS Interp sections

Read HEC2 Data

How to for Rivers

Frequently Asked Questions (Rivers)

Exporting to HEC-RAS

The HEC-RAS project is created from a surface tin (representing the river bed and overbanks) and a model 
containing strings identified by their names  “left bank”, “right bank and the name prefix, “centre line”. 
Any additional strings in the specified model will be ignored (warning messages will be given when you 
run the macro that any additional strings are being ignored). The low chainage (often zero) of the centre 
line strings must be at the downstream end of the reaches.

Cross sections are created at the location of the source strings. These source strings are initially created 
using the HEC-RAS option at a user defined spacing and section length. The user may  alter these sections 
as desired. These may be shortened if they intersect at sharp bends in the river; they may be extended at 
extremely wide river sections or extra points may be added so that the section is no longer a straight line.

Source strings can be deleted and additional sections can be added by creating new source strings. The 
Create source strings tick box on the interface panel must NOT be selected to use the customised strings.

Presenting HEC-RAS Results in 12d

After the HEC-RAS analysis is complete the water level results are read back into 12d. Water level strings 
are created with the plan shape of the cross sections at the elevation retrieved from the HEC-RAS results. 
These strings are then triangulated to create a water surface tin from which the water level boundaries are 
determined. These results can then be shown in plan, long section, cross section and in 3D perspectives.

More details

HEC-RAS Write Panel
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Rivers_hecras_panel HEC-RAS Interface Writer

Position of option on menu: Design=> Rivers=>HEC-RAS interface=>Create HEC-RAS 
project

TheHEC-RAS interface creates the HEC-RAS project files ready to open and run. This includes the 
project, plan, flow and geometry files. Water levels are read back into 12d where they may be viewed in a 
three dimension perspective view to easily identify extents of flooding.

Rivers_hecras_panel_beta HEC-RAS Interface Writer

See also

River and Source Strings

HEC-RAS Interface overview

Read HEC-RAS results

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

The HEC-RAS panel for creating the HEC-RAS project follows.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

INPUT MODELS

River strings model Model box

Model containing the centre line, left bank and right bank strings. The centre line strings must begin 
downstream and proceed upstream. The name of the river may follow the words “Centre line “ (note 
the ending space). For example the centre line string may be named “Centre line Parramatta River, 
downstream reach”. The comma separates the river name from the reach name. If no comma is 
included then the river name is repeated for the reach name. 

Confluences are modelled by a using a separate string for all reaches. Thus a system with a branch is 
modelled with three strings. The branch will be one string and the main reach will have a downstream 
string and an upstream string. The reaches must touch at the confluence.

The distance from the start of the upstream strings to the first cross section is used to model the conflu-
ence length.
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The left and right bank strings need not be separate strings (see figure below). 

Source string model Model box

New source strings will be created in this model or existing source strings are contained in the model. 
See Create source strings tick box below.

Rename Source Strings Tick box not selected

If selected the source strings will be a name using the chainage along the river centre line. The number 
of decimals and the Centre line chainage factor (ft to miles or m to km) are specified below.

Centre Line Chainage Factor Real box

The cross section names are created by dividing the chainage on the centre line by this factor. Typically 
1000 is used to convert metres to kilometres and 5280 to convert feet to miles.

Number of decimals Real box

When Rename source strings is selected, the source strings name will have the specified number of 
decimals.

CREATE SOURCE STRNGS OPTIONS

Create Source Strings Tick box not selected

When selected existing source strings are deleted and new ones created perpendicular to the centre line 
at the specified spacing and length. Once you have created the sources strings they can be easily modi-
fied. On the Strings->Points Edit menu you will find the selections Move (to move the end points), 
Insert (to insert additional points). 

Distance between sections Real box

The distance between the cross sections. At present no check is made for overlapping cross sections 
around river bends.

Section Length Real box

The length of the cross section with zero chainage at the mid point.

CROSS SECTION DATA

Cross section model Model box

The cross sections created and exported are stored in this model.

Surface Tin (not the model) Tin box

Tin or super tin to create the cross sections from (remember a tin is like a string. It is placed in a 
model.).

Levee Tolerance Real box 

If the surface level drops more than this amount while moving away from the channel centre line then 
the crest is marked as a levee. A value of zero means that no levees are marked.

Delta Y tolerance Real box 

This value filters out points on the cross section. Imagine a tube of this diameter passing over  the cross 
section. The tube is elongated until one point lies outside the tube. The tube is shortened to the previous 
point and then all points inside the tube are deleted from the cross section. The tube then moves on to 
the next point. The filtered (smoothed) and original sections are kept for comparison. The final water 
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tin is created from the ground tin and therefore the boundary string is located using  the unfiltered 
section.

STARTUP DATA

Manning’s n Real box 

Manning’s n values for the left, right and centre channel sections.

Discharge Real box

This discharge is used at the upstream end of all reaches. If you have multiple river branches, you can 
set the flow for each branch inside HEC-RAS or inside 12d.  This can be changed at each section See 
manual settings

Units Choice box

This selection will set the default units for the project being created.

Project file name Input box

The HEC-RAS project name. Remember HEC-RAS (2.0 or earlier) is limited to 8 characters only. If the 
total path name is too long HEC-RAS will not analyse the project.

HEC-RAS Read Panel
Rivers_hecras_panel HEC-RAS Interface Reader

Position of option on menu: Design=>Rivers=>HEC-RAS interface=>Read HEC-RAS 
reports

After the HEC-RAS analysis is complete the water level results are read back into 12d. Water level strings 
are created with the plan shape of the cross sections at the elevation retrieved from the HEC-RAS results. 
These strings are then triangulated to create a water surface tin.

See also

HEC-RAS Interface overview

Create HEC-RAS files

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

The HEC-RAS read panel follows.
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EXISTNG DATA

River strings model Model box

The river strings model specified in the write panel.

Cross Section model Model box

The cross section model specified in the write panel. This must be specified but is only used when read-
ing the *.rep file types (see File format below). The interface will search the string names in this model 
for the cross sections specified in the HEC-RAS report. A match is successful if the HEC-RAS cross 
section chainage and the string name are within the tolerance specified below in Chainage tolerance.
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Shape string model Model box

For meandering rivers, the cross sections (shown in green above) may not be at a close enough spacing 
to create a water surface that follows the river. 2D shape strings (shown in red above) can be created  
to create a water surface (shown in blue above) to follow the river. Note that water levels are extended 
when the shape strings are in a junction area or past the end of a reach.

Ground surface tin Tin box

If a boundary string model is specified below, the intersection of this ground surface and the water 
surface will be determined. The strings will be stored in the model from the boundary string model 
field.

File format Choice box

The GIS format should be used in most cases. The rep format is used for reading the HECRAS report 
files with the “Standard Table 1” selected in HECRAS.

HEC-RAS report file name File box

The HEC-RAS report file (GIS format) is created using the HEC-RAS menu selection 

File=>Export GIS data

The HEC-RAS  report file (REP format) created using the HEC-RAS menu selection
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File=>Generate Report

The report must include the Standard Table 1.

RESULTS DATA

Water surface tin model Model box

The model to contain the new water surface tin.

Water surface tin Tin box

The name of the water surface tin to be created.

Water level results model Model box

The model where the water surface strings will be created at each cross section and shape string.

Boundary string model Model box

The model to contain the intersection strings between the water and ground surfaces specified above. If 
left blank no intersection strings will be calculated.

PARAMETERS

Chord Length Model box

This value set the spacing for the points on the water level strings (both cross section and shape 
strings). It is recommended that you use a length of no more than half of your average cross section 
and shape string lengths. A large value in this field may result in unexpected water level profiles for 
meandering rivers.

Centre line chainage factor Model box

This data is only required if the Shape string model is used. The shape string names are created by 
dividing the chainage on the centre line by this factor. Typically 1000 is used to convert metres to kilo-
metres and 5280 to convert feet to miles.

Chainage Tolerance Real box

This is the tolerance used when the cross section chainage from the HEC-RAS report is compared with 
the cross section string names. A value of 0.00001 is excellent if you have not altered the cross section 
names in 12d or HEC-RAS. 

However, if you have altered chainage names then you may have to increase the value of the tolerance. 
Suppose the tolerance is set to 0.001 and the water level for section 0.056 is read from the HEC-RAS 
report file. The interface will search for the first string with a name between 0.055 and 0.057. If you 
chose to great of a tolerance then more than one water level result will match a 12d cross section and a 
warning message will be given.

If you have one specific cross section that you would like to have a different tolerance set for (maybe 
only one section is giving you troubles), use the Attribute Editor 

(Strings->User->Attribute Editor), select the cross section string and create a real type attribute 
named tolerance set to the tolerance desired.

Import cross sections (GIS file)
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Rivers_hecras_gis_panel

Position of option on menu: Design=>Rivers=>HEC-RAS interface=>Import cross sec-
tions (gis file)

This option is used to import HEC RAS cross sections are HEC RAS interpolated cross section into 12d 
model. Note that the imported cross sections will be given the X,Y coordinates used in the HECRAS 
project.

See Also

River and Source Strings

HEC-RAS Interface

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

This panel is accessed from the menu selection 

Design => Rivers => HEC-RAS Interface=>Import cross sections (GIS file)

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Cross section model model box

the imported cross section strings will be stored in this model

HEC RAS GIS File File box

the GIS file generated from HEC RAS

Surface Tin tin box

ground surface tin used to calculate the volumes and flood limits

Section colour colour box

Cross sections will be created using this colour

Clean model tick box

if selected all strings in the Cross section model will be deleted before the cross sections are imported

Process button

executes the option.
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Finish button

removes the dialogue from the screen

Read HEC-RAS interp sections
Drainage_hecras_interp_panel

Position of option on menu: Design=>Rivers=>HEC-RAS interface=>Read HEC-RAS 
intep section

This option is used to import HEC RAS interpolated cross sections (names begin with *) based on their 
distance along the left and right bank strings.

The low chainage must be at the downstream end for both the "left bank" and "right bank" strings.

See Also

River and Source Strings

HEC-RAS Interface

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

This panel is accessed from the menu selection 

Design => Rivers => HEC-RAS Interface=>Read HEC RAS Interp sections

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

hec ras read panel River strings modelRiver strings modelmodel box

the centre line, left and right bank strings must exist in this model

Rivers_hecras_interp_panelChainage toleranceReal box

existing cross sections must be located in 12d model. This value is the tolerance used when the HEC 
RAS cross section names are compared to the 12d string names.

hec ras read panel Original Cross Section modelOriginal cross section modelmodel box
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the HEC RAS cross section names will be compared with the string names in this model

hec ras read panel Interp Cross Section modelInterp cross section modelmodel box

the imported cross section strings will be stored in this model

hec ras read panel HECRAS G01 fileHEC RAS G01 FileFile box

the G01 (geometry) file used by HEC RAS to store the data in raw format. This is not the GIS format.

Process button

executes the option.

Finish button

removes the dialogue from the screen

Read HEC2 Data
Drainage_hec2_panel

Position of option on menu: Design=>Rivers=>HEC-RAS interface=>Read HEC2 data

This option is used to import HEC2 cross sections into 12d. Since the file does not contain any easting and 
northing data, the cross sections will be lined up vertically and will have to be placed manually inside 12d.

See Also

River and Source Strings

HEC-RAS Interface

Moving Strings ragg

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

This panel is accessed from the menu selection 

Design => Rivers => HEC-RAS Interface=>Read HEC2 Data

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Cross section model model box

the cross section created will be placed in this model
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HEC2 cross section File boxbox

the  HEC2 cross section data file to be read

Process button

read the data and create the cross sections.

Finish button

removes the dialogue from the screen
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XP-SWMM Interface
XP_SWMM_interface

Position of menu: Design=>Rivers=>XP SWMM interface

The XP-SWMM interface launches your XP-SWMM program and loads either a default xp file from the 
set_ups path (master_rivers.xp) or your existing project. The 12d data is automatically imported in the XP-
SWMM project (via a *.xpx file) to either create a new river reach or update an existing reach. Water 
levels are read back into 12d where they may be viewed in a 3D perspective view to easily identify extents 
of flooding.

The XP-SWMM walk right menu is,

See also

River and Source Strings

Defining Culvert Locations

Hydrology Data

Create XP-SWMM files

Read XP-SWMM results

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Exporting to XP-SWMM

The XP-SWMM project is created from a surface tin (representing the river bed and overbanks) and a 
model containing strings identified by their names  “left bank”, “right bank and the name prefix, “centre 
line”. Any additional strings in the specified model will be ignored (warning messages will be given when 
you run the macro that any additional strings are being ignored). The low chainage (often zero) of the 
centre line strings must be at the downstream end of the reaches.

Cross sections are created at the location of the source strings. Source strings can be deleted and 
additional sections can be added by creating new source strings. The Create source strings tick box on the 
interface panel must NOT be selected to use the customised strings.

Presenting XP-SWMM Results in 12d

After the XP-SWMM analysis is complete the water level results are read back into 12d. Water level 
strings are created with the plan shape of the cross sections at the elevation retrieved from the XP-SWMM 
results (xpx file). These strings are then triangulated to create a water surface tin from which the water 
level boundaries are determined. These results can then be shown in plan, long section, cross section and in 
3D perspectives.

More details

XP-SWMM Write Panel
Rivers_xpswmm_panel XP SWMM Interface Writer

Position of option on menu: Design=>Rivers=>XP SWMM interface=>Create xpx file 
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and run XP SWMM

The XP-SWMM interface creates the XP-SWMM project files ready to open and run. This includes the 
project, plan, flow and geometry files. Water levels are read back into 12d where they may be viewed in a 
three dimension perspective view to easily identify extents of flooding.

Rivers_xpswmm_panel_beta XP SWMM Interface Writer

See also

River and Source Strings

Hydrology Data

XP-SWMM Interface overview

Read XP-SWMM results

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

The source strings define the location where cross sections are cut from the ground surface TIN. A node is 
created in XP-SWMM at this location and the cross section shape is used to the next downstream node (no 
cross section is created at the most downstream source string). 

The centre line and overbank channel lengths are mesured in the downstream direction. XP SWMM link 
and node input panels are displayed below with the relationship to the 12d model described.
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XP SWMM Link Data
cross section chainage at intersection of left and right bank strings

max elev - min elev at upstream cross section

Minimum cross section elev from 
upstream node.

Minimum cross section elev from 
downstream node

.

n values from 12d panel

channel lengths measured along 
river strings
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XP SWMM Node Data

XP SWMM Conduit Data

The slope of the conduit/link is calculated by assuming that its invert matches vertically with the invert of 
the downstream link. The overflow levels at the nodes are calculated by determining the lowest of the bank 
levels for the upstream and downstream links. The least of the overflow depths at the nodes is then used as 
the link diameter.

max 
top 
of 
bank 
from 
upstr
eam 
and 
down
strea
m 
links

mini
mum 
eleva
tion 
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Usage

The XP-SWMM panel for creating the XP-SWMM project follows.

spill crest from min top of  bank 
(up and down stream)

min elev from downstream node

spill crest from min top of bank (up and 
down stream)

min elev from upstream node

diameter is the least of the node overflow 
depths from the upstream and 
downstream nodes (less 0.010)

centre line length

centre line n from 12d panel
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

River strings model Model box

Model containing the centre line, left bank and right bank strings. The centre line strings must begin 
downstream and proceed upstream. The name of the river may follow the words “Centre line “ (note 
the ending space). For example the centre line string may be named “Centre line Parramatta River, 
downstream reach”. The comma separates the river name from the reach name. If no comma is 
included then the river name is repeated for the reach name. 

The left and right bank strings need not be separate strings (see figure below). 

Source string model Model box

New source strings will be created in this model or existing source strings are contained in the model. 
See Create source strings tick box below.

Create Source Strings Tick box not selected

When selected existing source strings are deleted and new ones created perpendicular to the centre line 
at the specified spacing and length. Once you have created the sources strings they can be easily modi-
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fied. On the Strings->Points Edit menu you will find the selections Move (to move the end points), 
Insert (to insert additional points). 

Distance between sections Real box

The distance between the cross sections. At present no check is made for overlapping cross sections 
around river bends.

Section Length Real box

The length of the cross section with zero chainage at the mid point.

Cross section model Model box

The cross sections created and exported are stored in this model.

Centre Line Chainage Factor Real box

The cross section names are created by dividing the chainage on the centre line by this factor. Typically 
1000 is used to convert metres to kilometres and 5280 to convert feet to miles.

Number of decimals Integer box

The cross section names are created with this many decimals. CAUTION XP SWMM only allows 10 
characters for the names and each link name begins with "Lx-" That leaves 7 characters for the chain-
ages.

Surface Tin (not the model) Tin box

Tin or super tin to create the cross sections from (remember a tin is like a string. It is placed in a 
model.).

Levee Tolerance Real box 

Not implemented in XP-SWMM.

Manning’s n Real box 

Manning’s n values for the left, right and centre channel sections.

Delta Y tolerance Real box 

This value filters out points on the cross section. Imagine a tube of this diameter passing over  the cross 
section. The tube is elongated until one point lies outside the tube. The tube is shortened to the previous 
point and then all points inside the tube are deleted from the cross section. The tube then moves on to 
the next point. The filtered (smoothed) and original sections are kept for comparison. The final water 
tin is created from the ground tin and therefore the boundary string is located using  the unfiltered 
section.

Discharge Real box

This discharge is used at the upstream end of all reaches. If you have multiple river branches, you can 
set the flow for each branch inside XP-SWMM or inside 12d.  This can be changed at each section See 
manual settings

Units Choice box

This selection will set the default units for the project being created.

Project file name Input box

The XP-SWMM *.xp name to be created or updated. An xpx file will also be created using this name to 
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transfer the data.

After selecting the Process button the cross section strings will be created and exported to a xpx file (using 
the project file name as the stem. Never included ".xpx" in the project file name) The xpx file will be 
over written without any warning. This is only used as a temporary transfer file. 

12d needs to know where XPSWMM program and the XP SWMM working directory are. The system file 
that contains these locations is called XPSWMM.4d. (See  System file path for its location). The file 
contents are as follows:

Line 1the XP SWMM working directory
Line 2the full path to the XP SWMM program
Line 3the destination of the hydro.ini file when it is created

IMPORTANT: include the final "\" on lines 1 and 3.

The XPSWMM.4d file as supplied follows;

c:\xps\xp-swmm\work\
c:\xps\xp-swmm\xpswmp32.exe
c:\xps\xp-swmm\

Next 12d  will check for an XP project in your XP SWMM work directory (project file name + ".xp"). If it 
does not exist the file Master_rivers.xp will be copied from the System file path to your XP SWMM 
working directory. If a wp file already exists in your working directory you will see the following options 
dialogue.

The default is to update the wp file. Nodes and links in the file with the same names as in the export will be 
updated. If they do not exist they will be added. The import will NOT delete any nodes or links inside XP 
SWMM. This option is often used to merge rivers data with urban drainage data.

The over write option will copy the Master_river.xp file into the working directory and over write the 
existing file.

In either of the two cases the xpx file will be imported after XP SWMM has started. When you exit your 
XP SWMM session regardless of whether or not you save the XP file the XPX file will be exported over 
writing the original export file from 12d.

Your third option if not to run XP-SWMM at all and work with the XPX file as you see fit.



12d Model Reference Manual

Page  2152 June 2002XP-SWMM Interface

Export Details

The following diagram displays how the values from 12d are exported to XP-SWMM

At every source string location a node is created in XP-SWMM. The cross section geometry is then used 
for the downstream reach and is exported looking in the downstream direction. 

The node name is set manually or calculated inside 12d by obtaining the centre line chainage at the 
intersection with section string. This value is divided by the Centre line chainage factor and rounded to 
the Number of decimals specified in the 12d export dialogue box. This value is then prefixed with the 
reach index followed by a dash. The downstream link name is set to the node name prefixed with "L". If 
you are planning to merge the river file with am XP SWMM drainage network then you will want to 
manually set the node names to the drainage pit names for the most upstream and most downstream source 
strings.

When selecting the Number of decimals in the 12d export dialogue, ensure that the total link name 
generated does not exceed the XP limit of 10 characters.

The section number variable is not exported to XP-SWMM.

Where the centre line cross the section in 12d is marked as zero chainage in XP-SWMM. The left 
overbank (-17.373) and the right overbank (9.898) are determined by the intersection of the left and right 
bank strings with the section. The n values are the values that are entered in the 12d export dialogue box. 
The maximum depth is calculated by subtracting the lowest elevation from the greatest elevation for both 
this cross section and the downstream cross section. The minimum of the two values is used.

The channel length is determined by subtracting the downstream section’s centre line chainage from the 
current section centre line chainage. The Centre line chainage factor is NOT used in this calculation.

Upstream elevation is obtained by calculating the minimum elevation at the current section and the 
downstream elevation is the same value for the downstream cross section. The channel slope is calculated 
using these elevations and the channel length above.

The horizontal distortion factor and section vertical shift are set to zero. A section coordinate point in 
generated every time the source string crosses a 12d triangle edge, at the centre line and the left/right bank 
locations.
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The spill crest level at the node is set to the maximum level on the cross section. Constant inflow is zero 
unless the node is the most upstream section on the reach are the flow value for the source string has been 
set manually see manual settings.

Hydrology Data

Hydrolgy data may be exported to the runoff layer of XP SWMM for both the reservoir strings and the 
source strings. There are 2 requirements to enable the hydrology.

Key Points

1. If you plan to use storage areas, you need to draw reservoir strings (all in one model) and each should 
have a name (to become the XP SWMM node name).

2. You must create a file named "hydrology.txt" and store it in the project working folder. This file will 
contain the default xpx variable names. These defaults may be over riden using the same xpx variable 
name as a string attribute on the source/reservoir string (see format below).

3. The reservoir or source string must have an integer string attribute named "xpx r rfcmnt" with a value 
greater than 0 (max of 5). Use the Strings->Properties->Attributes or Strings->User->Attribute Editor 
to create/change this attribute.

4. Total area for the reservoir strings is calculated at each export time.

Hydology.txt file format

The file is tab delimted and each line consists of three pieces of data: the XPSWMM variable name, the 
default value, and the type of data (integer, real or text).

You enter the xpx variable name 

Any of these default values may be specified using a string attribute on the reservoir or source string. The 
attribute name must be of the same type as defined in the hdrology.txt file. If data for a second XP SWMM 
catchment is desired add a " 2" to the end of the attribute name. Up to 5 catchments are allowed in XP 
SWMM.

A sample hydrology.txt file follows:
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// SCS hydrology screen

R_CN 85 real
R_TC 60 real
R_SHF 256 integer
R_SHAPE 0 integer

R_IADEPTH 0.04 real
R_IAFRACT 0.2 real
R_IA 1 integer
CNTLS 5 integer
R_FSCS 1 integer

// sub catchment screen

R_RAINSEL "SCS Type II FL Mod."text
R_INFILSEL ""text
R_GWTAG 0 integer

// runoff node screen

R_WAREA 1. real
R_WIMP 1. real
R_WIDTH 1. real
R_WSLOPE 1. real

Attribute name format for string attributes.

The attribute name is the XP variable name prefixed by "xpx " with the underscore character in the xpx 
variable replaced by a space. For example the xpx variable "R_RAINSEL" would be set using the attribute 
name "xpx R RAINSEL".

Exporting River Junctions

River junctions are defined by the intersection of the centre line strings in 12d. The cross section 
immediately downstream of the intersection becomes the junction node. It is used as the downstream cross 
section for all upstream branches. The channel length for the last link on the tributary is set to the distance 
the centre line string extends beyond the cross section. The distance downstream along the main branch is 
NOT INCLUDED!

XP-SWMM Read Panel
Rivers_xpswmm_panel XP-SWMM Interface Reader

Position of option on menu: Design=>Rivers=>XP SWMM interface=>Read XP SWMM 
xpx results file

After the XP-SWMM analysis is complete and the XP-SWMM program is closed the water level data is 
written to an xpx file that 12d will read. Water level strings are created with the plan shape of the cross 
sections at the elevation retrieved from the XP-SWMM results. These strings are then triangulated to 
create a water surface tin.

Rivers_xpswmm_panel_beta XP-SWMM Interface Reader

See also

XP-SWMM Interface overview
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Create XP-SWMM files

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

The XP-SWMM read panel follows.

River strings model Model box

The river strings model specified in the write panel.

Cross Section model Model box

The cross section model specified in the write panel. The interface will search the string names in this 
model for the cross sections specified in the XP-SWMM report. A match is successful if the XP-SWMM 
cross section chainage and the string name are within the tolerance specified below in Chainage toler-
ance.
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Shape string model Model box

For meandering rivers, the cross sections (shown in green above) may not be at a close enough spacing 
to create a water surface that follows the river. 2D shape strings (shown in red above) can be created to 
create a water surface (shown in blue above) to follow the river. Note that water levels are extended 
when the shape strings are in a junction area or past the end of a reach.

Centre line chainage factor Model box

This data is only required if the Shape string model is used. The shape string names are created by 
dividing the chainage on the centre line by this factor. Typically 1000 is used to convert metres to kilo-
metres and 5280 to convert feet to miles.

Ground surface tin Tin box

If a boundary string model is specified below, the intersection of this ground surface and the water 
surface will be determined. The strings will be stored in the model from the boundary string model 
field.

XP-SWMM report file name File box

The XP-SWMM  xpx file created automatically created when closing XP-SWMM or via the XP-SWMM 
menu selection

File=>Export Data
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Water surface tin model Model box

The model to contain the new water surface tin.

Water surface tin Tin box

The name of the water surface tin to be created.

Water level results model Model box

The model where the water surface strings will be created at each cross section and shape string.

Boundary string model Model box

The model to contain the intersection strings between the water and ground surfaces specified above. If 
left blank no intersection strings will be calculated.

Chord Length Model box

This value set the spacing for the points on the water level strings (both cross section and shape 
strings). It is recommended that you use a length of no more than half of your average cross section 
and shape string lengths. A large value in this field may result in unexpected water level profiles for 
meandering rivers.

Chainage Tolerance Real box

This is the tolerance used when the cross section chainage from the XP-SWMM report is compared 
with the cross section string names. A value of 0.00001 is excellent if you have not altered the cross 
section names in 12d or XP-SWMM. 

However, if you have altered chainage names then you may have to increase the value of the tolerance. 
Suppose the tolerance is set to 0.001 and the water level for section 0.056 is read from the XP-SWMM 
report file. The interface will search for the first string with a name between 0.055 and 0.057. If you 
chose to great of a tolerance then more than one water level result will match a 12d cross section and a 
warning message will be given.

If you have one specific cross section that you would like to have a different tolerance set for (maybe 
only one section is giving you troubles), use the Attribute Editor 

(Strings->User->Attribute Editor), select the cross section string and create a real type attribute 
named tolerance set to the tolerance desired.
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MIKE11 Interface
Mike11_interface

Position of menu: Design=>Rivers=>Mike11 interface

The MIKE 11 interface creates the MIKE 11 project files including *.bnd11, *.hd11, *.nwk11, sim11 and 
the cross section data text file (to be imported into *.xns11). Water levels are read back into 12d where they 
may be viewed in a 3D perspective view, on cross sections and on river profiles. Plan drawings easily 
identify extents of flooding and all data can be plotted onto engineering drawings.

The Mike11 walk right panel is,

See also

River and Source Strings

MIKE11 Interface Overview

MIKE 11 Write Panel

MIKE 11 Read Panel

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Exporting to MIKE 11

The MIKE 11 project is created from a surface tin (representing the river bed and overbanks) and a model 
containing river centre line strings (identified by the name prefix, “centre line”). The low chainage (often 
zero) of the centre line strings must be at the upstream end of the reaches.

Cross sections are created at the location of the source strings. These source strings are initially created 
using the MIKE 11 option at a user defined spacing and section length, imported from drawing packages or 
manually created in 12d. The user may alter these sections as desired. They may be shortened if they 
intersect at sharp bends in the river; they may be extended at extremely wide river sections or extra points 
may be added so that the section is no longer a straight line.

Source strings can be deleted and additional sections can be added by creating new source strings. The 
Create source strings tick box on the interface panel must NOT be selected to use the customised strings.

Presenting MIKE 11 Results in 12D

After the MIKE 11 analysis is complete the maximum water level results are read back into 12d. Water 
level strings are created with the plan shape of the cross sections at the elevation retrieved from the MIKE 
11 results. These strings are then triangulated to create a water surface tin.

How the water level boundaries are determined

MIKE 11 Write Panel
Rivers_mike11_panel Mike11 Interface Writer

Position of option on menu: Design=>Rivers=>Mike11 interface=>Create Mike11 files

The MIKE 11 interface creates the MIKE 11 project files including *.bnd11, *.hd11, *.nwk11, *.sim11 and 
the cross section data text file (to be imported into *.xns11). Water levels are read back into 12d where they 
may be viewed in a 3D perspective view to easily identify extents of flooding.
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Rivers_mike11_panel_beta Mike11 Interface Writer

See also

River and Source Strings

MIKE 11 Read Panel

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

12d creates most of the files necessary to run MIKE11. The exception to these are the time series files 
(both water level and discharge data).  The simulation file created assumes that these files will have the 
same name as the centre line strings used in 12d. For example, if you name your centre line string centre 
line Major River then your time series files will be named Major River-H.DFS0 for the tail water 
conditions and Major River-q.dfs0 for your discharges.

The *.bnd11, *.hd11, *.nwk11 and *.sim11 files are created by appending 12d data to default data found in 
the following files.

cross_sections.4d

hd11-end.4d

hd11-header.4d

nwk11-header.4d

nwk11-options.4d

sim11-header.4d

sim11-period.4d

The user need not modify these files unless they would like to change the default values used when first 
creating the MIKE11 project. If you plan to modify these files, they are found in the 12d setups directory.  
Before modifying they should be copied to the 12d user directory (global defaults) or into the current 
project directory if they are project specific.

The MIKE 11 panel for creating the MIKE 11 project follows.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

River strings model Model box

Model containing the river centre line strings. The centre line strings must begin upstream and pro-
ceed downstream. The name of the river must follow the words “centre line “ (note the ending space). 
The name of the river may follow the words “Centre line “ (note the ending space). For example the 
centre line string may be named “Centre line Parramatta River, downstream reach”. The comma sep-
arates the river name from the reach name. If no comma is included then the river name is repeated for 
the reach name. 

Confluences are modelled by a using a separate string for all reaches. Thus a system with a branch is 
modelled with three strings. The branch will be one string and the main reach will have a downstream 
string and an upstream string. The reaches must touch at the confluence.

Source string model Model box

New source strings will be created in this model or existing source strings are contained in the model. 
See Create source strings tick box below.

Create Source Strings Tick box not selected
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When selected existing source strings are deleted and new ones created perpendicular to the centre line 
at the specified spacing and length. Once you have created the sources strings they can be easily modi-
fied. On the Strings->Points Edit menu you will find the selections Move (to move the end points), 
Insert (to insert additional points). 

Distance between sections Real box

The distance between the cross sections. At present no check is made for overlapping cross sections 
around river bends.

Section Length Real box

The length of the cross section with zero chainage at the mid point.

Cross section model Model box

The cross sections created and exported are stored in this model.

Centre Line Chainage Factor Real box

The cross section names are created by dividing the chainage on the centre line by this factor. Typically 
1000 is used to convert metres to kilometres and 5280 to convert feet to miles.

Surface Tin (not the model) Tin box

Tin or super tin to create the cross sections from (remember a tin is like a string. It is placed in a 
model.).

Bank Marker Tolerance Real box

If the surface level drops more than this amount while moving away from the channel centre line then 
the crest is used as a Bank Marker. A value of zero means that no bank marks are created.

Delta Y tolerance Real box 

This value filters out points on the cross section. Imagine a tube of this diameter passing over  the cross 
section. The tube is elongated until one point lies outside the tube. The tube is shortened to the previous 
point and then all points inside the tube are deleted from the cross section. The tube then moves on to 
the next point. The final water tin is created from the ground tin and therefore the boundary string is 
located using  the unfiltered section.

Manning’s n Real box 

Manning’s n values for the channel sections.

Initial depth Real box

This depth is added to the minimum elevation on the cross section and is used as the starting water 
level for the cross section.

Units Choice box

This selection will set the default units for the project being created.

Project file name Input box

The MIKE11 project name.  All of the MIKE11 files will begin with this name and the appropriate 
extensions added.

Running MIKE11
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Three steps are required to run MIKE11 with the files 12d creates.

1. Create you time series files.

2. Inside MIKE11, create a new cross sections file and import the cross 
sections.

3. Open the simulation file, and load the network file to have the grid points 
calculated.

Creating Time Series Files
Your time series files must be named with the prefix of the river string name. For example if your centre 
line string in 12d was named centre line Major River your time series files need to named Major River-
H.DFS0 for the tail water conditions and Major River-q.dfs0 for your discharges. 

The standard time series dates are from 12:00 to 12:30 on  01 January 2000 with a one minute time step. If 
other periods are desired, you can either change the file sim11-period.4d in the 12d library before running 
the interface or change the dates inside MIKE11 after you read in the data. DO NOT USE THE 
ORIGINAL FILES! Copy the file you are changing into the 12d user directory and modify it there. 
12d will look for the file here first.

Importing Cross Sections
From the MIKE11 main menu select File->new and then under Mike11 select cross sections from the 
dialogue box.

From the main menu select File->Import->Import Raw data & Recompute. Select the *.txt file with the 
Project file stem you specified in the 12d-Mike11 Write Panel. Now save this file with the same Project 
file stem (MIKE11 adds the .xns11 extension).

Calculating Grid Points
From the main menu select File->Open and select the *.sim11 file with the Project file stem you have 
specified in 12d. On the Input tab property sheet select Edit beside the Network file. Press Ctrl+T to take 
you into the table editing mode and then select the Grid Points tab property sheet. On the sheet select 
Generate Grid Points and then save the file.

You should now get the “Green lights” on the Start property sheet of the simulation file editor.

MIKE 11 Read Panel
Rivers_Mike11_panel Mike 11 Interface Reader
Position of option on menu: Design=>Rivers=>Mike11 interface=>Read Mike11 results 
(max)
After the MIKE 11 analysis is complete the water level results are read back into 12d. Water level strings 
are created with the plan shape of the cross sections at the elevation retrieved from the MIKE 11 results 
(maximum water level). 

Water levels are interpolated to create water level strings at the shape string locations. Note that water lev-
els are extended when the shape strings are in a junction area or past the end of a reach. These strings are 
then triangulated to create a water surface tin. 

The MIKE11 executable file, res11read.exe must be found in the directory c:/mikezero/bin so that 12d can 
read the Mike11 binary data files.
Rivers_Mike11_panel_beta Mike 11 Interface Reader

See also
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MIKE11 Interface Overview

Presenting Water Level Results

MIKE 11 Write Panel

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

The MIKE 11 read panel follows.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

River strings model Model box

The river strings model specified in the write panel.

Cross Section model Model box

The cross section model specified in the write panel. The interface will search the string names in this 
model for the cross sections specified in the MIKE 11 report. A match is successful if the MIKE 11 cross 
section chainage and the string name are within the tolerance specified below in Chainage tolerance.
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 Shape string model Model box

For meandering rivers, the cross sections (shown in green above) may not be at a close enough spacing 
to create a water surface that follows the river. 2D shape strings (shown in red above) can be created to 
create a water surface (shown in blue above) to follow the river. Note that water levels are extended 
when the shape strings are in a junction area or past the end of a reach.

Centre line chainage factor Model box

This data is only required if the Shape string model is used. The shape string names are created by 
dividing the chainage on the centre line by this factor. Typically 1000 is used to convert metres to kilo-
metres and 5280 to convert feet to miles.

Ground surface tin Tin box

If a boundary string model is specified below, the intersection of this ground surface and the water 
surface will be determined. The strings will be stored in the model from the boundary string model 
field. Super tins cannot be used for this function. A composite tin is required for the tin-tin intersect.

MIKE 11 report file name Input box

This is the binary data file that will converted to an ASCII text file and read by 12d. The maximum 
water levels at each cross section will be extracted from the file.

Water surface tin Tin box
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The name of the water surface tin to be created.

Water surface tin model Model box

The model to contain the new water surface tin.

Water level results model Model box

The model where the water surface strings will be created at each cross section and shape string.

Boundary string model Model box

The model to contain the intersection strings between the water and ground surfaces specified above. If 
left blank no intersection strings will be calculated.

Chord Length Model box

This value set the spacing for the points on the water level strings (both cross section and shape 
strings). It is recommended that you use a length of no more than half of your average cross section 
and shape string lengths. A large value in this field may result in unexpected water level profiles for 
meandering rivers.

Centre Line Chainage Factor Real box

The cross section names are created by dividing the chainage on the centre line by this factor. Typically 
1000 is used to convert metres to kilometres and 5280 to convert feet to miles.

Chainage Tolerance Real box

This is the tolerance used when the cross section chainage from the MIKE 11 results file is compared 
with the cross section string names. If a Centre line chainage factor of 1 is used a value of 0.1 is 
appropriate. If a Centre line chainage factor of 1000 or 5280 is used a Chainage tolerance of  
0.00001 is more appropriate. 

However, if you have altered chainage names then you may have to increase the value of the tolerance. 
Suppose the tolerance is set to 0.001 and the water level for section 0.056 is read from the MIKE 11 
report file. The interface will search for the first string with a name between 0.055 and 0.057. If you 
chose to great of a tolerance then more than one water level result will match a 12d cross section and a 
warning message will be given.

If you have one specific cross section that you would like to have a different tolerance set for (maybe 
only one section is giving you troubles), use the Attribute Editor (Strings->User->Attribute Editor), 
select the cross section string and create a real type attribute named tolerance set to the tolerance 
desired.
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Presenting River Water Level Results
Topics

How the water level boundaries are determined

Defining the Water Surface Boundaries

Trimming the Water Surface Tin and Islands

Colouring the Ground Surface

Colour by Depth

Depth Contours

Colour the ground surface by elevation

See also
River and Source Strings

XP-SWMM Interface

HEC-RAS Interface

MIKE11 Interface

ISIS Interface

How to for Rivers

Frequently Asked Questions (Rivers)

How the water level boundaries are determined
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For meandering rivers, the cross sections (shown in green above) may not be at a close enough spacing to 
create a water surface that follows the river. 2D shape strings (shown in red above). Note that water levels 
are extended when the shape strings are in a junction area or past the end of a reach. can be created to 
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create a water surface (shown in blue above) to follow the river.

The water surface is draped over the ground surface and the boundary strings (strings defining the edges of 
the water surface – shown in yellow above) are created. They may be used to trim the water surface or 
shade your ground surface tin for flood inundation mapping. Boundary strings also include islands! 
Shading the river bed blue, in a 3D perspective view, is an effective way to show the water level extents 
and still view the shape of the river bottom (it has the effect of very clean water that you can see through!).

Sample Presentations and Drawings
The water surface may be 

s •contoured (elevation),

s • depth contours created,

s • water surface coloured by depth (shown above),

s • cross sections plotted

s • and longitudinal profiles drawn (shown below). 

s •All of these results can be plotted complete with your customised drawing sheets. 

s •Finally, you may walk down the water course in the perspective view (and record this to an Win-
dows AVI file).
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Close up view of cross section labels with water levels
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Close up of text (user chooses wording, size, colour, text style etc.)

The tin created can be viewed in a perspective view and sections taken where desired. A sample 
perspective view follows.
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Example of cross sections long sections and depth colouring see the HEC-RAS Interface topic.

Defining the Water Surface Boundaries
The water surface and its boundary is created by 12d. The first step is to trim the water surface back to the 
boundary strings. Since the water boundary does not generally form a closed polygon (the left and right 
river boundaries will need to be joined at one end of the river) use the Strings=>Strings Edit=>Join to 
connected strings.

If the water surface reached the edges of you cross sections then there will be numerous breaks in the 
boundary string. The best solution is to extend the cross sections and/or add additional shape strings. If it is 
not a major error in modelling then the break in the boundary can be joined using the Strings=>Strings 
Edit=>Join.

If boundary strings are created outside that water level boundaries they should not be used in this area. 
Boundary strings should only be used inside the area defined by your water level results.

Trimming the Water Surface Tin and Islands
Use the Triangle=>Null=>by polygons selection to null triangles inside the polygon you have created 
above.



Chapter 19  Rivers

June 2002 Page  2173Presenting River Water Level Results

Select your water surface tin and change the Poly mode to Outside. Now select the Poly button and pick 
the boundary string. The triangles outside the polygon will now be nulled.

If you have some islands in the model then change the Poly mode to Inside and select the islands.

If you have numerous islands, say more than 10 it may be easier to copy all of the islands into one model 
using the fence command (Utilities->Fence->Fence).

The Model to fence is the boundary strings model and the Model for fence inside is the new model to 
contain the islands. The Exclude model containing fence should not be ticked. Select Poly and then pick 
the boundary string. All of the islands inside the boundary string will not be copied to the islands model.

Colouring the Ground Surface with Flood Zones
The boundary strings can also be used to colour the ground surface. Colouring the river bed blue is an 
effective way to show the water level extents and still view the shape of the river bottom (the effect of very  
clean water that you can see through!).

First, define the water surface boundaries (see above). Next re-triangulate the ground tin so that it includes 
the boundary string model (Triangles=>Edit=>Tin). Next select Triangles=>Colour=>Colour within 
polygon. The following panel will appear.

Select your ground tin and the desired colour. Next select the Poly button and pick the boundary string to 
be coloured inside. If islands exist change, change the colour (to a ground colour) and then select the island 
string.

Colour by Depth
The water surface can be coloured by depth. This function calculates the depth between the water surface 
and the ground surface and creates “faces” of different colours. The colours to be used are specified in a 
depth range file. This option requires the purchase of the Volumes Option
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From the main menu select Options->Volumes->Exact->Tin to tin.

Original tin this is your ground survey tin

New tin this is your water surface tin

Range file two range files are supplied. One with a range from 0 to 5 and another 
from 0 to 50. The library contains a spreadsheet the can quickly create other range files or you 
may edit the using the built in range editor.

To use the built in range file editor select + beside you range file then edit.
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You may change the range value and the colours as desired. Be sure to select Write to save the changes 
before selecting Finish.

See also Range File Creation

Plan View to paint you can paint a current view without saving the face data. This is a good 
option if you wish to take a quick look at the depth colours in one area.

Model for faces the faces can be stored in a model. Note that faces consume a great deal 
of hard disk space. Therefore you may consider colouring one area at a time using the Poly 
option.

Poly If your water surface tin is very large than you may want to only colour a portion of the tin. You 
must create a polygon (Strings->Create->2d) and then pick this polygon. When your select Vol-
ume only the area inside the polygon will be coloured.

Volume select this button to colour the surface.

Depth Contours
Once you have the tin coloured by depth you might want to add depth contours. From the main menu 
select Options->Tin->Analysis->Depth Contours. This option requires the purchase of the tin Analysis 
module.
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Original tin this is your ground survey tin

New tinthis is your water surface tin

Model for depth strings this is the model for your depth contours

Colour for cut strings this must be selected but we will not use this colour

Colour for zero strings the zero string will be the same as our boundary strings

Colour for fill strings this is the colour for the depth contours

Start level enter a zero for this value

End level enter a level grater than the greatest depth

Intervalenter the contour interval as desired

2d/3d strings 2d strings

Calculate this will create you contour strings
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Adding Values to the Contours

Since there are numerous ways to label the contours it is performed as a separate step. From the main menu 
select Strings->Label->Contours.

Contour method the example above uses Line removal and Centred line read from below. 
This copies the contour lines themselves and inserts a break in the line.

Start distance this is usually left as zero. It changes the start point for the first label on 
each contour.

Separation this determines the spacing of the contour labels.

Colour the ground surface by elevation
With the water surface coloured by depth, you may want to colour the ground surface by elevation.
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This colouring may be done from either From the main menu select Options->Volumes->Exact->Tin to 
height or Triangles->Colour->Tin height colour.

Options->Volumes->Exact->Tin to height

Options->Volumes->Exact->Tin to height requires the purchase of the Volumes module. First select 
Triangles->Tin info from the main menu and then select you ground surface tin. You will want to copy the 
minimum z level from this pane.

Now from the main menu select Options->Volumes->Exact->Tin to height
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Select your ground surface to colour and enter the minimum elevation (from above) into the Height field. 
The Range file “$LIB/ground_colouring_green.drf” is found in the library. 

Plan View to paint you can paint a current view without saving the face data. This is rarely 
used in this case

Model for faces the faces can be stored in a model. Note that faces 
consume a great deal of hard disk space. Therefore you may consider colouring one area at a 
time using the Poly option.

Poly If your ground surface tin is very large than you may want to only colour a portion of the tin. You 
must create a polygon (Strings->Create->2d) and then pick this polygon. When your select Vol-
ume only the area inside the polygon will be coloured.

Volume select this button to colour the surface.
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 UNET Interface
UNET_interface

Position of menu: Design=>Rivers=>UNET interface

The UNET interface creates the *.cs file. Water levels are read back into 12d where they may be viewed in 
a 3D perspective view to easily identify extents of flooding.

The UNET walk right menu is,

See also

River and Source Strings

Reservoir Strings

Create UNET files

Read UNET results

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

UNET Write Panel
Rivers_unet_panel Unet Interface Writer

Position of option on menu: Design=>Rivers=>UNET interface=>Create UNET CSECT file

The UNET interface creates the UNET *.cs file. Water levels are read back into 12d where they may be 
viewed in a three dimension perspective view to easily identify extents of flooding.

Rivers_unet_panel_beta Unet Interface Writer

See also

River and Source Strings

UNET Interface Overview

Read UNET results

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

The UNET panel for creating the UNET project follows.
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UNET Read Panel
Rivers_unet_panel Unet Interface Reader

Position of option on menu: Design=>Rivers=>UNET interface=>Read UNET reports

After the UNET analysis is complete the water level results are read back into 12d. Water level strings are 
created with the plan shape of the cross sections at the elevation retrieved from the UNET results. These 
strings are then triangulated to create a water surface tin.

Rivers_unet_panel_beta Unet Interface Reader

See also

UNET Interface Overview

Create UNET files

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Usage
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The UNET read panel follows.

The UNET file format consists of a line number, section name and elevation  separated by at least 1 space. 
An example follows:

1     0.25       118.24

2     0.50       118.25

3     0.75       118.30

4     1.00       118.40
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ISIS Interface
ISIS_Interface

Position of menu: Design=>Rivers=>ISIS interface

The ISIS interface creates *.dat input file. Water levels are read back into 12d where they may be viewed 
in a 3D perspective view to easily identify extents of flooding.

The ISIS walk right menu is,

See also

River and Source Strings

Reservoir Strings

Spill strings

Create ISIS files

Read ISIS results

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Exporting to ISIS

The ISIS project is created from a surface tin (representing the river bed and overbanks) and a model 
containing river strings identified by their names  “left bank”, “right bank and the name prefix, “centre 
line”. Any additional strings in the specified model will be ignored (warning messages will be given when 
you run the macro that any additional strings are being ignored). The low chainage (often zero) of the 
centre line strings must be at the upstream end of the reaches.

Cross sections are created at the location of the source strings. These source strings are initially created 
using the ISIS option at a user defined spacing and section length. The user may  alter these sections as 
desired. These may be shortened if they intersect at sharp bends in the river; they may be extended at 
extremely wide river sections or extra points may be added so that the section is no longer a straight line.

Source strings can be deleted and additional sections can be added by creating new source strings. The 
Create source strings tick box on the interface panel must NOT be selected to use the customised strings.

Reservoir Strings are 2d strings that define the extents of the reservoir. The volume is calculated in 
increments of 1 or the value set in the attribute stage increment for this string. The volumes start from a 
level with zero volume to the level set for the 2d reservoir string.

The reservoir strings may define inline reservoirs or offside storage. Inline reservoirs are "touched" by 
centre line strings both upstream and downstream. Offline storage areas are linked to the cross sections via 
spill strings.

Spill strings are 2d strings that link offline storage areas to a cross section. The string must begin by 
"touching" the source string and then proceed to the first point on the spill section. During the export the 
first point will NOT be exported as part of the spill section. After defining the end of the spill section the 
last point on the string must "touch" the reservoir string. Again this last point will NOT be exported as part 
of the spill section.

Presenting ISIS Results in 12d

After the ISIS analysis is complete the water level results are read back into 12d. Water level strings are 
created with the plan shape of the cross sections at the elevation retrieved from the ISIS *.zzr file. These 
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strings are then triangulated to create a water surface tin from which the water level boundaries are 
determined. These results can then be shown in plan, long section, cross section and in 3D perspectives.

More details

ISIS Write Panel
Rivers_isis_panel ISIS Interface Writer

Position of option on menu: Design=>Rivers=>ISIS interface=>Create ISIS file

The ISIS interface creates the ISIS project files ready to open and run. This includes the project, plan, flow 
and geometry files. Water levels are read back into 12d where they may be viewed in a three dimension 
perspective view to easily identify extents of flooding.

Rivers_isis_panel_beta ISIS Interface Writer

See also

River and Source Strings

ISIS Interface overview

Read ISIS results

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

The ISIS panel for creating the ISIS project follows.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

River strings model Model box

Model containing the centre line, left bank and right bank strings. The centre line strings must begin 
downstream and proceed upstream. The name of the river may follow the words “Centre line “ (note 
the ending space). For example the centre line string may be named “Centre line Parramatta River, 
downstream reach”. The comma separates the river name from the reach name. If no comma is 
included then the river name is repeated for the reach name. 

Confluences are modelled by a using a separate string for all reaches. Thus a system with a branch is 
modelled with three strings. The branch will be one string and the main reach will have a downstream 
string and an upstream string. The reaches must touch at the confluence.
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The distance from the start of the upstream strings to the first cross section is used to model the conflu-
ence length.

The left and right bank strings need not be separate strings (see figure below). 

Source string model Model box

New source strings will be created in this model or existing source strings are contained in the model. 
See Create source strings tick box below.

Create Source Strings Tick box not selected

When selected existing source strings are deleted and new ones created perpendicular to the centre line 
at the specified spacing and length. Once you have created the sources strings they can be easily modi-
fied. On the Strings->Points Edit menu you will find the selections Move (to move the end points), 
Insert (to insert additional points). 

Distance between sections Real box

The distance between the cross sections. At present no check is made for overlapping cross sections 
around river bends.

Section Length Real box

The length of the cross section with zero chainage at the mid point.

Storage strings Real box

These 2d strings define the extents of the storage area. For more details see Reservoir strings.

Spill strings Real box

These 2d strings define the location to cut the spill section and start end points define the cross section 
and reservoir, respectively. For more details see Spill strings

Cross section model Model box

The cross sections created and exported are stored in this model.

Centre Line Chainage Factor Real box

The cross section names are created by dividing the chainage on the centre line by this factor. Typically 
1000 is used to convert metres to kilometres and 5280 to convert feet to miles.

Number of decimals Integer box

The cross section names are created with this many decimals. CAUTION XP SWMM only allows 10 
characters for the names and each link name begins with "Lx-" That leaves 7 characters for the chain-
ages.

Surface Tin (not the model) Tin box

Tin or super tin to create the cross sections from (remember a tin is like a string. It is placed in a 
model.).

Bank Marker Real box 

Not currently implemented in ISIS

Delta Y tolerance Real box 

This value filters out points on the cross section. Imagine a tube of this diameter passing over  the cross 
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section. The tube is elongated until one point lies outside the tube. The tube is shortened to the previous 
point and then all points inside the tube are deleted from the cross section. The tube then moves on to 
the next point. The filtered (smoothed) and original sections are kept for comparison. The final water 
tin is created from the ground tin and therefore the boundary string is located using  the unfiltered 
section.

Manning’s n Real box 

Manning’s n values for the left, right and centre channel sections.

Initial depth Real box 

Not currently implemented in ISIS.

Discharge Real box

This discharge is used at the upstream end of all reaches. If you have multiple river branches, you can 
set the flow for each branch inside ISIS or inside 12d.  This can be changed at each section See man-
ual settings

Units Choice box

This selection will set the default units for the project being created.

Project file name Input box

The ISIS project name. The extension ".dat" will automatically be added for you.

ISIS Read Panel
Rivers_isis_panel ISIS Interface Reader

Position of option on menu: Design=>Rivers=>ISIS interface=>Read ISIS results

After the ISIS analysis is complete the water level results are read back into 12d. Water level strings are 
created with the plan shape of the cross sections at the elevation retrieved from the ISIS results. These 
strings are then triangulated to create a water surface tin.

Rivers_isis_panel_beta ISIS Interface Reader

See also

ISIS Interface overview

Create ISIS files

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

The ISIS read panel follows.
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River strings model Model box

The same river strings model specified in the write panel. The river strings are used to sort the cross 
section and the shape strings. The left and right bank strings are used to check the direction of the 
strings.

Cross Section model Model box

The same cross section model specified in the write panel. The interface will match the ISIS label and 
the string name (without the "SECT "). If the ISIS labels were created by 12d then an exact match 
should result. 

However, if the ISIS file was not created by 12d, the file can still be mapped by manually creating cross 
section strings (2d or 3d strings).  See Mapping non 12d and historical water level data.
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Shape string model Model box

For meandering rivers, the cross sections (shown in green above) may not be at a close enough spacing 
to create a water surface that follows the river. 2D shape strings (shown in red above) can be created  
to create a water surface (shown in blue above) to follow the river. Note that water levels are extended 
when the shape strings are in a junction area or past the end of a reach.

Reservoir Model box

Reservoir strings are assigned elevations from the ISIS zzr file. This model is the same  as the storage 
area stings specified in the write panel.

Centre line chainage factor Model box

This data is only required if the Cross sections have been manually created and have no names yet. See 
Mapping non 12d and historical water level data.

ISIS results file name File box

The ISIS  zzr file is automatically generated by ISIS.

Ground surface tin Tin box

If a boundary string model is specified below, the intersection of this ground surface and the water 
surface will be determined. The strings will be stored in the model from the boundary string model 
field.
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Water surface tin model Model box

The model to contain the new water surface tin.

Water surface tin Tin box

The name of the water surface tin to be created.

Water level results model Model box

The model where the water surface strings will be created at each cross section and shape string.

Boundary string model Model box

The model to contain the intersection strings between the water and ground surfaces specified above. If 
left blank no intersection strings will be calculated.

Chord Length Model box

This value set the spacing for the points on the water level strings (both cross section and shape 
strings). It is recommended that you use a length of no more than half of your average cross section 
and shape string lengths. A large value in this field may result in unexpected water level profiles for 
meandering rivers.

Chainage Tolerance Real box

This tolerance is not used for the standard 12d cross section names. However, if the cross section 
names have been created manually and they can be converted to a real number then this is the toler-
ance used to match the  cross section label from the ISIS report to the cross section string names. A 
value of 1.0  to 10. is common. See Mapping non 12d and historical water level data for more 
details.

A sample of the *.zzr file that is read by 12d follows.

A sample of the zzr file that is read follows.

Maxima and minima of all variables from

 time      0.000 hours to time     30.000 hours

 

*************************

 maxima of all variables

*************************

 

 Label12            Flow     Stage Froude no  Velocity     Umode    Ustate

WY201013     y     0.470    87.305     0.033     0.076     7.916     0.000

WY202013     y     0.470    87.288     0.162     0.297     2.335     0.000

WY203013     y     0.470    87.054     0.682     0.794     4.000     0.800

WY204013     y     0.470    86.804     0.671     1.002     0.562     0.000
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How to for Rivers
This section lists specific tasks for the rivers interface. Worked examples are contained in the courses 
directory of 12jobs and training manuals are found in the documentation directory on the 12d model 
distribution CD.

Change manual override settings for river strings via attributes

ragg write this Export/import string attributes to a spreadsheet

Manually set a cross section name

Specify a local inflow at a cross section

Change the stage increment for reservoir strings

Boundary Strings are broken. How do I stop this?

Manual Override settings
Many of the automatic settings can be overridden using string attributes via the String Attribute Editor. 
To use the editor

1. Select the river or source string to add/edit the attribute for

2. In the Attribute Name column use the selection list to find the attribute to change. If it is not listed 
then type the attribute name into on of the boxes.

3. Change the attribute Type to Integer/Real/Text as required

4. Type the attribute value into the Data field (erase the not found if required).

5. Select Process, Next, Previous or Pick string. Selecting Finish will NOT save the attribute.

You will be prompted that you will create a new attribute if you have typed in a new attribute for that string

Purpose String Type Attribute Name Type
Typical Data 

Value

Node/cross section name source strings node name Text A1

Set a local inflow for this 
section

source string flow Real 10.2

Storage curve increment storage area 
strings

stage increment Real 1.0

Water level string tolerance 
when comparing numeric string 
names to data file names

cross sections 
before importing

tolerance Real 0.01

Custom n values source strings left n, right n, centre n Real 0.03

Culvert n value centre line and 
culverts in spill

roughness Real .013

Culvert entrance loss centre line and 
culverts in spill

entrance loss Real 0.5

Culvert exit loss centre line and 
culverts in spill

exit loss Real 1.0
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Export/import string attributes to a spreadsheet

Boundary Strings are broken. How do I stop this?
The boundary strings will be broken into sections when the boundary string goes outside the area defined 
by the cross sections. See below

In these two cases the water level has not exceeded the extents of the cross sections but the boundary 
strings (black) has gone outside the limits of the water level strings (magenta). Shape strings are used to 
expand the area of the water levels between the sections. The water level assigned to the shape string is a 
linear interpolation between the upstream and downstream cross section water levels. The interpolation is 
prorated using the distance along the centre line of the river. 

Important! water levels are extended when the shape strings are in a junction area or past the end of a 
reach.

Shape strings are 2d strings. The direction is not important except for Mike11 models. For Mike11 they 
must be in the same direction as the cross section strings (usually left bank to right bank). The following 

Culvert length centre line and 
culverts in spill

length Real 8.0

Multiple identical culverts centre line and 
culverts in spill

number of pipes Integer 2

Chanel length of a spill string spill strings length Real 30

Channel roughness spill strings roughness Real 0.02

Channel slope % spill strings slope Real 0.5

Purpose String Type Attribute Name Type
Typical Data 

Value
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drawing shows the boundary string when 2 shape strings have been added (green).



12d Model Reference Manual

Page  2194 June 2002Mapping non 12d and historical water level data

Mapping non 12d and historical water level data
12d can map water levels from river engineering models that were not created by 12d. If the water level 
results are in the standard HECRAS GIS, HECRAS report, ISIS zzr, UNET, XP SWMM xpx or Mike11 
binary file then the standard 12d readers can be used. If the data is historical or not in any of the standard 
format the River Mapper feature can be used.

River Mapper
Rivers_mapper_panel_beta River Mapper 

Position of option on menu: Design=>Rivers=>River Mapper

River cross section water level data in an text file may be mapped and displayed using the 12d River 
Mapper interface. 2d strings are created by the user with the plan shape of the cross sections. 12d assigns 
water levels from a text file to these strings. These strings are then triangulated to create a water surface 
tin.

Rivers_mapper_panel River Mapper 

See also

Presenting Water Level Results

How to for Rivers

Frequently Asked Questions (Rivers)

Usage

The steps are as follows:

1. Create the river strings (centre line, left bank and right bank).

2. Create 2d source strings. Use your name for the cross section as the string name. 12d will match the 
water levels in the file to this string using the name as the key.  If you do not assign a name the interface 
will assign names to strings according to the chainage along the centreline and the value of .Centre 
line chainage factor.

3. From the Design->Rivers menu select River Mapper.

4. Fill in the fields in the dialogue for the rivers strings (step 1 above) and the cross sections (step 2 
above).
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River strings model Model box

The river strings model specified in the write panel.

Cross Section model Model box

The cross section model specified in the write panel. The interface will search the string names in this 
model for the cross sections specified in the HEC-RAS report. A match is successful if the HEC-RAS 
cross section chainage and the string name are within the tolerance specified below in Chainage toler-
ance.

Shape string model Model box

For meandering rivers, the cross sections may not be at a close enough spacing to create a water sur-
face that follows the river. 2D shape strings can be created (automatically or manually) to create a 
water surface to follow the river. Note that water levels are extended when the shape strings are in a 
junction area or past the end of a reach.

Centre line chainage factor Model box

If you assigned the source/cross section string a name in Step 2 this field is not used. Otherwise, the 
centre line chainage and the  Centre line chainage factor are used to name your source string/cross 
sections in 12d. The cross sections will be named in the same units as the 12d data if a Centre line 
chainage factor of 1 is specified. If your existing data uses cross section names in your data file are in 
kilometres and your 12d data in meters, you will want to use a Centre line chainage factor of 1000. If 
your existing data cross section names are in miles and your 12d data is in feet then a Centre line 
chainage factor of 5280 would be used.

Mapper results file name File box
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The report is a tab (or space) delimited text file (usually created by a text editor or spreadsheet). The 
format is

cross section name <tab> water level elevation

each section name with its water level must be on a separate line. For example.

Section A 2.31
Section B 2.32

If the names contain letters (abc..) then the section name must match the 12d string names exactly 
(case sensitive). If the names are real numbers than a tolerance for the matching (global and string 
specific) can be set (see parameters).
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12d System Path
When looking for system files 12d first checks your local project directory (the directory that hold the 
*.project folder), and then the system folders. Unless you have changed these folders in your env.4d file 
the path is first "program files\12d\12dmodel\5.00\user" and then  "program 
files\12d\12dmodel\5.00\set_ups". In summary:

1. local project directory (the directory that hold the *.project folder

2. program files\12d\12dmodel\5.00\user

3. program files\12d\12dmodel\5.00\set_ups

Never modify the files in set_ups. Copy them to the user directory and make your changes there. Here they 
are safe from being changed during future 12d updates. The only time you will want files in the local 
project directory is when you have some project specific data. Master_drainage.xp and Master_rivers.xp 
are good examples of such cases.

More on System files
Attribute Editor

Rivers beta menu
Rivers_beta
The Rivers beta menu contains the latest beta test versions of the Rivers interfaces. These versions will 
have the newest features in 12d but they will also be under testing. They should not be used unless you 
have read an signed a 4d Solutions beta test site agreement.

FAQ Rivers
XP SWMM does not start or gives errors when starting from 12d
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20  Pipeline
pipeline

Position of menu: Design =>Pipeline

The Pipeline option is used to place large diameter pipelines.

The pipeline is very similar to an alignment string in that it is defined by separate horizontal and 
vertical geometries.

The major differences between a pipeline and an alignment is that a pipeline has a diameter and 
normally uses circular curves in the vertical geometry rather than the parabolic curves used for 
alignments.

The pipeline is entered by placing the invert (bottom) of the pipe. Hence in a plan view, the 
horizontal geometry places the centre of the pipeline. The vertical geometry of the pipeline is for 
the invert (bottom) of the pipeline.

Note

A pipeline string is not the same as a pipe string. A pipe string is only a 3d string with a 
diameter.

The Pipeline walk-right menu is 

For the option Create, go to the section “Create” .
Editor  “Editor” .

 Defaults  “Defaults” .
 Plots  “Plots” .
 Reports “Reports” .
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Create
create_pipeline_string

Position of option on menu: Design =>Pipeline =>Create

The Create option is used to produce new pipelines. If a pipeline string already exists, the Edit 
option is used to modify it.

On selecting the Create option, the Create Pipeline String panel is displayed.

To create a new pipeline string, the pipeline’s name, model, colour, style, spiral type and pipe 
diameter, plus the standard length of pipes used to make up the pipeline are entered into the 
appropriate fields and the Create button selected.

As for a 3d string, to create a new pipeline string with some of the same name, colour, model, 
style etc. as an existing string (not necessarily a pipeline), the same as button is chosen and the 
appropriate string selected.

The Create Pipeline String panel is then removed and the Pipeline Edit menu and Pipeline Edit Info 
panel fired up.

The Pipeline Edit menu contains all the options for creating/editing a pipeline string. The Pipeline 
Edit Info panel contains information areas.

The Pipeline Edit menu and Pipeline Edit Info panel are
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As for an alignment string, to create a new pipeline string the user selects the Append=>HIP’s 
option from the Pipeline Edit menu and start placing points in a plan view.

Since the Pipeline Edit menu and Pipeline Edit Info panel are the same as those used when editing 
a pipeline string, the options will be discussed in the following sections under the pipeline Edit 
option.

For information on pipeline editing, please continue to the section “Pipeline Editor” .
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Editor
Position of option on menu: Design =>Pipeline =>Editor

This is the same option as Editor from the Strings walk-right menu on the 12d Model menu.

The string editor is used to modify any 12d Model strings. After selecting the Editor option, the 
Edit String panel is placed on the screen to record any error messages.

The option is already in the Pick mode (the Pick & Edit button only needs to be selected if the 
pick was cancelled) and the user simply picks and accepts the string to be edited.

From the picked string’s type, the editor is able to determine the edits that apply to the string and 
list them in the string’s Edit menu.

If a pipeline string is selected, the Pipeline Edit menu and Pipeline Edit Info panel (as shown in the 
previous section) are placed on the screen.

The individual edit operations for a pipeline string will now be discussed in detail.

Please continue to the next section “Pipeline Editor” .

Pipeline Editor
pipeline_edit_info  pipeline_edit

Position of option on menu: Design =>Pipeline =>Editor

A pipeline string is defined by specifying both the horizontal and vertical geometry of the invert 
(bottom of the pipeline) as separate operations.

The horizontal geometry consists of a series of (x,y) points (called horizontal intersection points) 
and circular curves applied to the intersection points.

Vertical geometry also consists of a series of points but they are defined with respect to the plan 
length of the string (chainage) and height. Hence, the vertical geometry is defined by a series of 
(chainage,height) points (called vertical intersection points) and circular curves applied to the 
vertical intersection points.

The horizontal geometry is usually defined in a plan view and the vertical geometry in a section 
view. Hence the pipeline string editor can edit information for the string on both plan and 
section views.

Note: the string can only be edited on a section view if the string is also profiled on the section 
view.

On selecting a pipeline string the Pipeline Edit menu and Pipeline Edit Info panel are placed on the 
screen.

The Pipeline Edit menu is
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and the pipeline edit info panel is

To edit the selected pipeline string, simply select the required edit option from the list of all 
possible edits in the pipeline edit menu.

The edit is cancelled by selecting the cancel option. The edited string is restored to its pre-edit 
state and the option terminated.

The edit is finished and the new string placed in the given model when the finish option is 
chosen. The edit option then terminates.

When either quit or finish is selected, a yes-no-cancel panel is displayed and the user must 
confirm the selection.

The pipeline edit info panel is used to display information and messages during editing of the 
pipeline string.

The main message area indicates the purpose of the mouse buttons at each step.

Message area 1 displays the current pipeline edit option and message area 5 indicate the next 
step in the edit option.

Message areas 2 and 3 are used to display information about the string as the cursor is moved 
near the string and the string points. For example, for the closest IP, the (x,y,z) position and 
radius of the IP is displayed in area 2, and in area 3 the bearing-in, bearing-out and deflection 
angle for the adjacent IPs.

Message area 4 displays the cover above the pipeline and the vertical, horizontal and combined 
joint deflection.

Most of the options are identical to the edit options for an alignment string and will not be 
discussed in detail again. The options that are only applicable to a pipeline string will be fully 
described.

append or prepend an IP
move an IP or TP
insert an IP
insert on IP-IP line
delete an IP
extend an IP
modify the strings z-value
circular curves, spirals
VG only, radius or length
interval, start chainage, validate, clear etc.
set diameter and pipe length
toggle edit info panel
undo and redo
quit the edit session
finish the create
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Append

HIPs
In a plan view, the append=>HIPs option is used to create the first horizontal point in a new 
pipeline string, to append a new horizontal intersect point to the end of the string or to prepend 
a new horizontal intersection point to the beginning of the string. The horizontal geometry is for 
the centre of the pipe in plan.

VIPs
In a section view, the append=>VIPs option can be used to create and edit the vertical geometry 
of the picked string if the string is a primary string on any section view. This can be achieved by 
using either the VG edit or the profile option from the section view View ops menu. The vertical 
geometry is for the invert (bottom) of the pipe.

The append option is the same as append for an alignment string and will not be described 
further.

Move
The move option can be used for moving individual horizontal and vertical intersection and 
tangent points.

The option acts on the horizontal geometry if the point to move is selected in a plan view, or the 
vertical geometry if the point to move is selected in a section view.

The move option is the same as move for an alignment string and will not be described again.

Insert
The insert option is designed to place a new intersection point in a string between two adjacent 
horizontal or vertical intersection points (note that the inserted point does not have to be on the 
line joining the two intersection points).

The insert option is the same as insert for an alignment string and will not be described again.

Between
The between option is similar to the insert option except the inserted point does have to be on 
the line joining the two intersection points. To accomplish this, the cursor position is 
automatically projected onto the IP-IP line to give the new IP point position.

The between option is the same as between for an alignment string and will not be described 
again.

Delete
The delete option is used to delete horizontal or vertical intersection points from the string.

The delete option is the same as delete for an alignment string and will not be described again.

Extend
The extend option is used to move an intersection point along the line joining the intersection 
point to its neighbouring intersection point.

The extend option is the same as extend for an alignment string and will not be described again.

Height
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The height option is used to modify the height of a vertical intersection point in the string.

The height option is the same as height for an alignment string and will not be described again.

Curves
curves

The curves option allows the user to add circular curves of a given radius to a either horizontal 
or vertical intersection points.

The curve option is the same as curve for an alignment string and will not be described again.

Parabolas
parabolas

The parabolas option is for adding parabolic curves to the vertical geometry.

For pipelines, circular curves are normally used on vertical curves.

The parabolas option is the same as parabolas for an alignment string and will not be described 
again.

Utilities
alignment_utilities

The utilities walk-right menu contains a number of useful miscellaneous option for the pipeline 
string. The menu is

Each of these options is the same as for an alignment string and will not be discussed again.
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Utilities 2
pipeline_utilities

The utilities 2 walk-right menu contains options to modify the diameter of the pipeline and to set 
the standard length of the pipes used to construct the pipeline.

The utilities 2 walk-right brings up the pipeline utilities menu:

Diameter
The diameter option is used to change the diameter of the pipeline string.

After selecting the option, an enter value typed-input box is displayed on the screen containing 
the pipeline’s current diameter.

The new diameter is entered into the typed-input box, terminated with <return>.

The typed-input box then disappears and the option terminates.

Length
The length option is used to change the length of the standard pipe used to construct the pipeline 
string.

The length of the pipes used in constructing the pipeline string is used for calculating joint 
deflections along the pipeline.

After selecting the option, an enter value typed-input box is displayed the pipeline’s current 
standard pipe length.

The new length is entered into the typed-input box, terminated with <return>.

The typed-input box then disappears and the option terminates.

Info
The pipeline edit info panel is toggled on/off by the info option in the pipeline edit menu.

Quit and Finish
Even after points are created for the new string, the create process can be aborted by selecting the 
quit option from the pipeline edit menu. The option then terminates and no string is created.

The create process is completed and the new string created and placed in the given model when 
the finish option is chosen from the pipeline edit menu.

When either the finish or quit option is selected, a yes-no-cancel panel is displayed and the user 
must confirm the selection.
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Defaults
pipeline_defaults

Position of menu: Design =>Pipeline =>Defaults

The defaults menu sets default depth to tin and joint deflection angle.

The default walk-right menu is

Depth to Tin
pipeline_tin_defaults

Position of option on menu: Design =>Pipeline =>Defaults =>Depth to tin

On selecting the tin option, the pipeline tin defaults panel is displayed.

This panel is for setting the default terrain tin which is used to calculated the cover above the 
pipeline.

Joints
pipeline_joint_defaults

Position of option on menu: Design =>Pipeline =>Defaults =>Joints

On selecting the joints option, the pipeline joint defaults panel is displayed.

This panel is for setting the maximum joint deflection for the individual pipes that make up the 
pipeline.
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Plots
pipeline_plots

Position of menu: Design =>Pipeline =>Plots

Currently the plots menu contains only one option and it is used for producing longsection plots 
of major pipelines.

The plots walk-right brings up the pipeline plots menu:

This option will now be described in more detail.

Please continue to the next section “Longsections” .

Longsections
plot_pipeline_network plot_pipeline_network_margins plot_pipeline_network_title

Position of option on menu: Design =>Pipeline =>Plots

The longsections option is used to generate longsection plots for all the pipeline strings in a 
given model.

Given the plot sheet size and the horizontal and vertical scales, the longsections for the pipelines 
are plotted starting at the top of the sheet and moving across the sheet. Once one row is full, if 
there is room the plot moves down the page and begins a new row. When a plot sheet is full, a 
new plot sheet is automatically begun.

The pipeline plots include 

▲ the horizontal and vertical joint deflection at any vertical intersection points which have 
no curves on them

▲ the natural surface height and chainage at any pegs or positions from the specials model, 
plus the invert level and depth to pipe at the position

▲ for any services which cuts the pipeline, the name, diameter, invert level, the distance 
along the pipeline of the cutpoint plus the invert level and depth of the invert for the pipe-
line and the cut point.

After selecting the Longsections option, the Plot Pipeline Network panel is displayed.



Chapter 20  Pipeline

April 2003 Page 2209Plots



12d Model Reference Manual

Page 2210 April 2003Plots

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Plot parameters input *.ppf

file of plot parameters used for extra control of the long section plot.

Plotter type input hp hp, dxf, postscript etc.

format for the plot output.

Network model input

the model containing the pipelines to be plotted.

Section view input

the section view to be used to define the vertical exaggeration, corridor widths, tins to section through, 
services models to section etc.

Plot file stem input

since more that one plot page may be produced, the plot file stem plus a plot page sequence number fol-
lowed by .plt is used as the plot file names.

Specials model input

model of text strings which are used as extra labels for the plots.

Peg interval input 50

if the specials model is blank, the pipelines are labelled with the text peg at the peg interval along the 
pipeline.

Scale 1: input

horizontal scale for plotting the pipeline long sections. The vertical exaggeration is taken from the sec-
tion view given in the section view field.

Sheet size wd ht (mm) input available sheet sizes

if non-blank, the width and height values in millimetres (separated by space) or the name of a user 
defined sheet size.
If blank, the sheets size is calculated to fit the long section plot.

Pipeline line ht (mm) input

the maximum allowable height for a longsection plot for a pipeline line. Datum breaks are applied to 
any part of the longsection that will not fit into the pipeline line ht.

Start plot chainage input

If blank, the start chainage of the pipelines is used; if non blank, the plots start at this chainage for each 
pipeline.

End plot chainage input

If blank, the end chainage of the pipelines is used; if non blank, the plots finishes at this chainage for 
each pipeline.

Plot button

write out the pipeline longsection plots for the pipelines in the model given in the network model field.
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The fields and buttons for margin tab:

Left/right margin (mm) 10.0

the left/right hand side margin between the sheet and the plotting area inside the sheet.

Bottom/top margin (mm) 10.0

the bottom/top margin between the sheet and the plotting area inside the sheet.

The fields and buttons for the title tab:

Use title file tick-cross

if tick, a user defined title block file is used.

Use Standard title tick-cross tick

if tick, the standard border and two lines of title are placed on the bottom of the plot

Title file input *.tf

if non-blank and use title file is set to tick, then the file given in this field is used to generate a user 
defined title block for the plot.

Title line 1/2 input

first/second line of title information

Title height (mm) input 5

height (in millimetres) to draw the characters in the two lines of title information.

Title colour input cyan available colours

colour used for the border and the title information.

For a description of the pipeline plot parameters, please go to the section “Pipeline Plot 
Parameters” .
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Pipeline Plot Parameters
The pipeline plot option is used to make special long section plots for a network of pipeline 
strings.

Some of the look of the pipeline long section plot can be controlled from the plot pipeline 
network panel itself, however a wider selection of control parameters is available by using a 
pipeline long plot, plot parameter file.

The pipeline long section plot parameters are placed in a file with ending .ppf.

Each parameter consists of a parameter name followed by one or more spaces and then the 
parameter value. There is only one parameter per line.

Anything on a line after a double forward slash // is considered to be a comment.

The set of all parameters for the pipeline long section plot is enclosed within a set of curly 
brackets { } with the header

pipeline_long_plot     “plot set name”

before the curly brackets.

That is,
pipeline_long_plot    “plot set name”    {

plot parameters
one per line

}

If there is more than one pipeline_long_plot parameter set in the file, only the first set is used.

There may also be parameter sets for other plot types such as section_x_plot in the same file.

The other sets will be ignored when doing a pipeline long section plot.

Plot Sheet Layout
The plot sheet is considered to have only positive co-ordinates with the origin (0,0) in the left 
hand corner. The units for the plot are millimetres.

The overall size of the plot sheet is given by either a defined sheet size, or by the width and 
height of the plot given in millimetres and separated by one or more spaces.

sheet_size text         // sheet name, or
“mm mm”          // sheet size: width height

The sheet size name and width and heights can be specified by the user in a file named 
sheet_sizes_definitions which is in the normal set up areas, or is pointed to by the environment 
variable

SHEET_SIZES_4D file // file of plotter sheets sizes
The long plot is then positioned within the plot sheet by giving the margins

left_margin mm
right_margin mm
top_margin mm
bottom_margin mm

The (left_margin,bottom_margin) defines the left hand corner position of the long plot on the 
plot sheet.

The right_margin and top_margin need not be set and if missing, will be calculated from the 
other plot parameters defining the plot layout.

The pipeline long section plot will break an individual plot up if it doesn’t fit across the sheet. 
There can be one or more rows of plot on the same sheet.

The top row is done first, followed by the second top row, then the third and so on until the 
bottom row. If there is only one row, it is considered to be the bottom row.

When a sheet is full, a follow on sheet is created.
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As soon as one pipeline string is completed, the next pipeline string in the network model is 
plotted beginning on the same row as the previous pipeline string and with a horizontal gap of 
size horizontal_plot_gap between the plots. If there is not enough room on the row to start the 
next plot, it will begin on a new row.

The position of the left hand bottom corner of the first plot in the bottom row is given by the 
parameters, left_margin and bottom_margin.

If there are two or more rows of plots, the position of the first plot in each row is given by adding 
multiples of the (plot_height+vertical_plot_gap) to the bottom_margin.

network_model text // model of pipeline strings
left_margin mm // Position of the left hand bottom
bottom_margin mm // corner of first plot in the bottom row.

only_one_line 0 // more than one row on a sheet
1 // only one row of plot on a sheet

plot_height mm // total height of a plot row. It doesn’t
// includes the vertical_plot_gap.

horizontal_plot_gap mm // gap between plots on same row
vertical_plot_gap mm // gap between rows of plots

The pipeline long plot itself consists of seven areas. From the bottom up, they are

boxes, below datum, bottom stagger, graph, top stagger, arrow 4 area and top.

The boxes area is where the chainages and various values for the pipeline strings are labelled.

The below datum area is a region between the boxes area and the datum line.

The bottom stagger area is where the upright line staggers occur before going up from the boxes 
area to the graph area.

The graph area is the area where the actual plots of the strings are drawn.
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The top stagger area is where the upright line staggers occur above the graph area.

The arrow 4 area is an extension of the uprights above the top stagger area to allow for the 
drawing of arrows where the arrows go between the staggered uprights above the graph area.

The top area is an annotation area above the arrow 4 area (the top of the plot) and is used for 
pegs and deflection angles.

Apart from information labelled in the boxes and top areas, the pipeline long section plot can 
place arrows between ips for other information such as

(a) pipe grade
(b) vertical geometry
(c) horizontal geometry

Also the chainages where services cross the pipeline line are automatically labelled.

Chainages, Staggering and Uprights
For the pipeline plot, the labelling of pipe invert levels, pipe invert, depth to invert, pipe grade 
and natural surface level are done at the chainages:

(a) pegs given by the peg_interval
(b) horizontal and vertical defection points
(c) points in the specials model
(d) crossing services

The points in the specials model are projected onto the pipeline string and the chainages used for 
labelling. If the point is a 4d string, then the text at the point is used as a text label at the top of 
the plot.

pipeline long section plot

boxes area

below datum area

bottom stagger area

graph area

top stagger area

arrow area 4
top area

title
area

values
area
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The peg interval and specials model are given by the parameters

peg_interval world-units              // distance between pegs
specials_model text              // model name

Uprights, or leader lines, are drawn from the values at the bottom of the plot to the top of the 
plot for cases (a), (b) and (c), or to the crossing service in the graph area for case (d).

If the text values are placed at the real chainage positions at the bottom of the plot, text 
overwriting can easily occur if the chainages are very close together.

To prevent such overwriting, the text can be staggered.

That is, if the text is going to overwrite a previous text value, the next text value is actually 
moved along until there is no overwriting.

Since the text is no longer at the correct chainage position, the uprights to the pegs and services 
start at the text position and then bend back to the correct chainage position on the plot. The 
region where the bending occurs is called the stagger area.

For the pipeline plot, there is an area below the graph where the uprights bend backwards from 
the staggered text position to the real chainage position (bottom stagger area).

There is a second area above the graph where the uprights bend forwards from the real chainage 
position to the staggered text position (top stagger area).

Hence annotation above the top stagger area will line up with the staggered values below the 
bottom stagger area.

The stagger area below the graph area is defined by

stagger_height_1 mm // distance from the top of datum to the
// start of the staggers

stagger_height_2 mm // distance over which stagger occurs

stagger_gap_bottom mm // distance from end of staggers to the
// bottom of the graph area

The stagger area above the graph area is defined

stagger_gap_top mm // distance from top of the graph area to
// the start of the staggers

stagger_height_3 mm // distance over which stagger occurs
stagger_height_4 mm // distance from end of staggers to the

// bottom of above upper staggers area
The distance to be left for text to avoid overwriting is:

horizontal_text_gap mm // minimum distance to leave for text
// after peg values

services_text_gap mm // minimum distance to leave for text
// after service values

When staggering occurs, it is possible for the values area to be longer than the graph area.

For the uprights that are drawn from the text to the pegs, specials and services:

line_colour colour // colour of uprights to the pegs and
// specials

service_line_colour colour // colour of upright to the crossing
// services

service_text_colour colour // colour of the name of the service.
service_text_size mm // size of the service text.

service_il_text_size mm // size of the service invert level text.
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service_il_textstyle text // textstyle of the service il text
service_il_text_colourcolour // colour of the service il text

Label vertical geometry:

v_g_text_size mm // size of the vertical geometry text
v_g_textstyle text // text style of the vertical geometry text
v_g_text_colour colour // colour of the vertical geometry text

Label horizontal geometry:

h_g_text_size mm // size of the horizontal geometry text
h_g_textstyle text // textstyle of the horizontal geometry text
h_g_text_colour colour // colour of the horizontal geometry text

Label pegs:

peg_text_size mm // size of the peg label
peg_textstyle text // text style of the peg label
peg_text_colour colour // colour of the peg label

Label special chainage:

chainage_special_text_size mm // size of the special chainage text
chainage_special_textstyle text //textstyle of the special chainage text
chainage_special_text_colour colour // colour of the special chainage text



Chapter 20  Pipeline

April 2003 Page 2217Plots

Boxes Area
The pipeline string values of chainage, invert level, depth to pipe invert or depth to top of pipe, 
grade and natural surface level can be labelled in the pipeline long section plot with one line of 
title, and the actual values given at the chainage of each peg in the pipeline string.

The titles for the string values, are drawn in the titles area of the boxes area and the values are 
drawn in the values area of the boxes area.

Consequently the boxes area is made up of rows of text consisting of:

title followed by the values along the string.

Each row is surrounded by lines to form a box.

The titles area for the left plot in the bottom row starts at the co-ordinate (left_margin, 
bottom_margin) and each row is begun by adding the distance (plot_height + vertical_plot_gap) 
to the bottom_margin.
The width of the title box is given by the plot_title_width parameter and the height of each box 
is given by plot_title_height.

plot_title_width mm // width of the label boxes.
plot_title_height mm // height of each box

box_titles_x mm // the distance between the left of the
// title box and the title

The values area starts at the end of the label area and the values text is written at right angles to 
the bottom of the boxes.

The colour of the box line work is given by:

plot_title_line_colour colour // colour of the lines in the boxes

A default text size and colour can be specified for the title text, and the size and colour of the 
values. These can be overridden by parameters (given later in this section).

plot_title_text_size mm // size of label text in boxes
plot_title_text_colour colour // colour of label text in boxes

text_size mm // size of value text
text_colour colour // colour of values in boxes

The width of the values area is determined by the number of chainages to be labelled and 
whether the values are staggered to prevent over writing.

The total width of the boxes area is the width of the labels area plus the width of the values area 
which depends on the amount of staggering that occurs.

boxes area of a pipeline long section plotplot_title_width
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The order of drawing and labelling the boxes from the bottom up is

(a) chainage values
(b) natural surface heights
(c) pipe invert levels
(d) depth to invert or depth to top of pipe
(e) grade of pipeline

The text, size, textstyle and colour for the title text and values text for each box can be set by:

(a) pipeline string chainages

plot_title_chainage_name text // label for chainages box
chainage_title_text_size mm // size of chainage title text in boxes
chainage_title_textstyle text // the textstyle of chainage title text in boxes
chainage_title_text_colour colour // colour of chainage title text in boxes

chainage_text_colour colour // colour of chainage text in boxes
chainage_text_size mm // size of chainage text in boxes
chainage_textstyle text // the textstyle of chainage text in boxes
chainage_decimals integer // number of decimal places 

// If > 0, trailing zeros are removed after
// the decimal point.
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

(b) natural surface values

plot_title_surface_name  text // label for the pipeline ns value
ns_title_text_size mm // size of ns title text in boxes
ns_title_textstyle text // the textstyle of ns title text in boxes
ns_title_text_colour colour // colour of ns title text in boxes

ns_text_colour colour // colour of ns text in boxes
ns_text_size mm // size of ns text in boxes

 ns_textstyle text // the textstyle of ns text in boxes
ns_decimals integer // number of decimal places 

// If > 0, trailing zeros are removed after
// the decimal point.
// If < 0, the absolute value is taken as the

pipeline long section plot
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// number of decimal places to report
// i.e. no trailing zeros are removed

(c) pipe invert values

plot_title_invert_name text // label for the invert level
il_title_text_size mm // size of il title text in boxes
il_title_textstyle text // the textstyle of il title text in boxes
il_title_text_colour colour // colour of il title text in boxes

il_text_colour colour // colour of il text in boxes
il_text_size mm // size of il text in boxes
il_textstyle text // the textstyle of il text in boxes
il_decimals integer // number of decimal places 

// If > 0, trailing zeros are removed after
// the decimal point.
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

(c) depth to invert or depth to top of pipe

depth_mode 0 // if 0, depth to invert of pipe - default 0
1 // if 1, depth to top of pipe (cover)

plot_title_depth_name text // label for depth of invert
depth_title_text_size mm // size of depth title text in boxes
depth_title_textstyle text // the textstyle of depth title text in boxes
depth_title_text_colour colour // colour of depth title text in boxes

depth_text_colour colour // colour of depth text in boxes
depth_text_size mm // size of depth text in boxes
depth_textstyle text // the textstyle of depth text in boxes
depth_decimals integer // number of decimal places 

// If > 0, trailing zeros are removed after
// the decimal point.
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

(d) grade of pipeline

plot_title_grade_name text // grade of pipe at the peg
grade_title_text_size mm // size of grade title text in boxes
grade_title_textstyle text // the textstyle of grade title text in boxes
grade_title_text_colour colour // colour of grade title text in boxes

grade_text_colour colour // colour of grade text in boxes
grade_text_size mm // size of grade text in boxes
grade_textstyle text // the textstyle of grade text in boxes
grade_decimals integer // number of decimal places 

// If > 0, trailing zeros are removed after
// the decimal point.
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed
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Below Datum Area
The below datum area is the region between the boxes area and the arrow_1 area. The datum 
line is drawn at the top of the below datum area.

 datum_title_text_size mm // size of datum title text and value
 datum_title_textstyle text // textstyle of datum title text and value
 datum_title_text_colour colour // colour of the datum title text and line

The size of the below datum area is

datum_gap mm // height of the below datum area

The datum value is placed above the datum line.

Since the datum value is automatically calculated to try and fit the plot vertically into the graph 
area, the datum value can change along the plot. When a datum change occurs, the new datum 
value is written on the datum line at the relevant chainage position.

The datum name, text size and colour are controlled by:

 datum_text_size mm // size of datum title text and value
 datum_textstyle text // textstyle of datum title text and value
 datum_text_colour colour // colour of the datum title text and line

datum_name text // text to write before the datum value
datum_text_size mm // size of datum text and value
datum_colour colour // colour of the datum text and line

Graph Area
The graph area is the area where the actual plots of the pipeline strings are drawn.

The length of the graph area is determined by the length of the pipelines string to be plotted 
(given by the start and end chainages) and the horizontal scale (given by scale) of the plot.

scale value // 1:value - horizontal scale
// The vertical scale is determined by the
// horizontal scale and the vertical
// exaggeration for the section view.

start_chainage value // “ “ means use start of pipeline strings
end_chainage value // “ “ means use end of pipeline strings

The vertical exaggeration is taken from the section view specified for the plot by the parameter:

view_name text

The tins to be sectioned through by the pipeline strings and any service models and corridor 
settings for the graph area are also taken from the specified section view.

The height of the graph is calculated by subtracting the height of the first five areas (i.e. don't 
include the top area) from the plot height.

If the plot will not fit horizontally into a row on the sheet, then the plot will be broken at an 
appropriate peg and the plot continued on another row.

Datum breaks at pegs are used to try and fit the plot vertically into the graph area but if the plot 
still cannot fit, then it will be truncated at the bottom.

The types of strings that can be drawn in the graph area of the pipeline long section plot are:

(a) pipeline string the strings from the network model
(b) tins sections of the pipeline string through any tins on the section view.
(c) services parts of strings from any models on the section view that cut the
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corridor for the section view.

The colour of the strings in the plot is the actual string colour for cases (a) and (c), the colour of 
the tin used for the section in case (b).

Arrow 4 Area
This is just an extension of the stagger lines before the top of the plot. It leaves an area that can be 
used for extra annotation after the plot is produced.

The height of the area is

plot_title_top_height mm // height of the arrow 4 area

Top Area
The top area is an annotation area at the top of the plot (above the arrow 4d area).

It can be used for peg names and horizontal and vertical deflection angles in the pipeline.

The height of the top area is given by

vertical_plot_gap mm // size of the top area. If it is not large
// enough, the text will overwrite the
// plot in the row above.

Change of Direction At Intersection Points
If there is a horizontal or vertical intersection point without a curve on it, the deflection angle at 
the intersection point is drawn in the top area.

The text is drawn at the distance angle_text_offset above the top of the plot and if there is more 
than one angle, they are spaced horizontally by the distance angled_text_gap to the right.

The size and colour of the deflections is given by text_size and text_colour.

angled_text_offset mm // distance of direction text above
// top of the plot

angled_text_gap mm // distance of direction text to the right
// of previous text.

angled_text_angle value // angle of direction text
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Hatching Cut and Fill Areas
This option is used to hatch cut and/or fill areas between sets of tins.

For each set, the name of the two tins, the hatch linestyle, colour and separation and whether cut 
and/or fill regions are required are all user definable.

Up to twenty (20) separate sets of tins be hatched.

The parameters for labelling cuts and/or fill regions between tins are given by:

hatch_original_tin_n tin_name // tin_name for original surface
hatch_new_tin_n tin_name // tin_name for final surface

hatch_cut_separation_n mm // distance between cut hatch lines
0 // don’t do cut hatching

hatch_cut_angle_n degrees // angle in degrees of cut hatching
hatch_cut_colour_n colour // colour of the cut hatching
hatch_cut_linestyle_n linestyle // linestyle for cut hatching

hatch_cut_draw_sides_n            1/0 // 1 = draw sides of cut regions
hatch_cut_draw_original_n        1/0 // 1 = draw original tin in cut regions
hatch_cut_draw_new_n              1/0 // 1 = draw new tin in cut regions

hatch_fill_separation_n                 mm // distance between fill hatch line

             0 // don’t do fill hatching

hatch_fill_angle_n degrees // angle in degrees of fill hatching
hatch_fill_colour_n colour // colour of the fill hatching
hatch_fill_linestyle_n linestyle // linestyle for fill hatching
hatch_fill_draw_sides_n         1/0 // 1 = draw sides of fill regions
hatch_fill_draw_original_n      1/0 // 1 = draw original tin in fill regions
hatch_fill_draw_new_n             1/0 // 1 = draw new tin in fill regions

Notes

(a) cut is when the new tin is below the original tin.
fill is when the new tin is above the original tin.

(b) cut hatching is turned off by setting hatch_cut_separation_n to 0.0.
fill hatching is turned off by setting hatch_fill_separation_n to 0.0.

section viewtin (natural surface)

design x- section

cut

fill
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Labelling Cuts of Pipeline Through Strings in a Model
The cuts that the pipeline string makes though any strings in user given models can be 
automatically labelled on the long section plots.

The height, chainage and name of the cut string can be labelled as well as a symbol drawn. The 
height of tins at the same offset value can also be labelled.

The chainage position for the labelling is the chainage of the cut string.

The height position for the labelling can be specified as the

(a) top of the boxes on the long section
(b) height value of the cut string
(c) height of the primary string
(d) height of a tin.

The actual position of the label is defined relative to the above point.

Note: 

Only case (b) involves the actual height of the cut string. For all other cases, only the chainage of 
the cut string is used. Hence for all cases except (b), the string does need to have a sensible height 
to be used for cuts through strings. 

For example, a boundary string may have null heights but only the chainage is required and the 
height of the tin at that chainage can be used as the height (case (d)).

Text justification refers to the actual position and is given by

“top-left” “top-centre”                   “top-right”
“middle-left” “middle-centre”            “middle-right”
“bottom-left” “bottom-centre”            “bottom-right”

A choice of six special symbols and/or or any 12d symbols can be drawn at the cut point.

The special 12d Model symbols of size one millimetre are drawn in a square box centred on (0,0) 
with sides of length two millimetres. That is, the box co-ordinates are (-1,-1), (1,1), (1,-1), (-1,-1).

The six special shapes are

Up to twenty five (25) separate models of strings can be cut and labelled.

pipeline string

strings to label where they are cut by the pipeline string

plan view

tin (natural surface)

pipeline long section

points where strings are cut
in plan by the long section

section view



12d Model Reference Manual

Page 2224 April 2003Plots

Parameters for Labelling Where the Pipeline Cuts Strings in a Model
The method for specifying which strings are to be checked for cuts is by first specifying the 
model which contains the strings, and then a name mask which is used to restrict the strings in 
the model to only those whose name matches the name mask.

Up to twenty five different sets of models and name masks can be used so that different cut sets 
can be labelled in different ways.

The parameters for selecting and labelling the n’th set (where n can be from 1 to 25) of cuts of the 
design string with the strings in the model are given by:

cuts_n_model model_name                        // model of strings to be cut

The selection of the strings from the model model_name whose cut points are to be labelled is all 
the strings whose name satisfies the name mask cuts_n_mask:

cuts_n_mask name_mask                       // strings to check for cuts
// and if a cut occurs,

// parameters show how to
// label the cut

where name_mask is a text string containing the name masks, each separated by one or more 
spaces, to test the string name against. Each mast can include wild cards and wild characters.

For example

cuts_1_mask "ke*"
or cuts_1_mask "?bank*"

or, if both masks are required,
cuts_1_mask "ke*  ?bank*"

If cuts_n_mask is missing, then all strings in the model are used. This is equivalent to name_mask 
being "*".

All strings in the model cuts_n_model whose name satisfy the name mask cuts_n_mask are then 
checked for cuts with the design string, and if a cut occurs, the cut point will be labelled 
according to the rest of the parameters in the n’th set.

The parameters for drawing a symbol at the cut points are 

cuts_symbol_n_mode 0 // cross
1 // up from centre of box
2 // up and down from centre of box
3 // square
4 // triangle, base at bottom
5 // circle
6 // use a 12d symbol

If cuts_symbol_n_mode is 6, then the 12d symbol is given by

cuts_symbol_n_style plotsymbol // 12d symbol to draw at cut

Important Note

 The plot symbol of name plotsymbol is defined in the file given by:

(a) the parameter plot_symbols in the ppf file

0 1 2 3 4 5

predefined symbols for cut_symbol_n_modes 0 to 5
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plot_symbols filename

or if plot_symbols is not defined, then

(b) in the file pointed to by the environment variable PLOT_SYMBOLS_4D

PLOT_SYMBOLS_4D filename // default plotsym.4d

or if PLOT_SYMBOLS_4D is not defined, then

(c) in the file plotsym.4d

which is searched for in the standard set up file sequence

If none of the above files are defined, or if the symbol does not exist in the above files, then it will be 
searched for in the standard 12d symbols file which is:

(d) either pointed to by the environment variable SYMBOLS_4D

SYMBOLS_4D filename // default symbols.4d

or if the environment variable SYMBOLS_4D does not exist, in the file, symbols.4d 

The position of the symbol is given by:

cuts_symbol_n_position    1 // above point height value
   3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

The symbol can be adjusted by the parameters:

cuts_symbol_n_x mm // offset adjustment to position
cuts_symbol_n_y mm // height adjustment to position
cuts_symbol_n_angle degrees // rotation about point
cuts_symbol_n_colour colour // colour of symbol

and for all values of cuts_symbol_n_mode other than 6:

cuts_symbol_n_size mm // size of symbol, 0 don’t draw

The value of the chainage of the cut string can be labelled using the parameters

cuts_chainage_n_position1 // above cut strings height value
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_chainage_n_x mm // chainage adjustment to position
cuts_chainage_n_y mm // height adjustment to position
cuts_chainage_n_angle degrees // rotation about point
cuts_chainage_n_size mm // size of text, 0 don’t label
cuts_chainage_n_colour colour // colour of text

cuts_chainage_n_textstyle text // textstyle of text chainage
cuts_chainage_n_pre_text text // text before the chainage value
cuts_chainage_n_post_text text // text after the chainage value

cuts_chainage_n_justification         justification         // justification of the text
cuts_chainage_n_no_decimals       integer         // number of decimals in chainage
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The value of a height at the chainage of the point can be calculated and labelled using the 
parameters

cuts_height_n_mode 1 // use height of cut point itself
3 // use real world height of position

// above boxes
100 // height of primary string
101-500 // use height of to tin1 or tin2 etc.

cuts_height_n_position 1 // at points position
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_height_n_x mm // chainage adjustment to position
cuts_height_n_y mm // height adjustment to position
cuts_height_n_angle degrees // rotation about point
cuts_height_n_size mm // size of text, 0 don’t label
cuts_height_n_colour colour // colour of text

cuts_height_n_textstyle text // textstyle of text height
cuts_height_n_pre_text        text // text before the height value
cuts_height_n_post_text        text // text after the height value

cuts_height_n_justification            justification    // justification of the text
cuts_height_n_no_decimals           integer           // number of decimals in height

A label which can include the name of the cut string is drawn by using the parameters

cuts_label_n_position 1 // above cut strings height value
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_label_n_mode 0 // don’t include cut string name
1 // include cut string name in label

cuts_label_n_x mm // chainage adjustment to position
cuts_label_n_y mm // height adjustment to position
cuts_label_n_angle degrees // rotation about point
cuts_label_n_size mm // size of text, 0 don’t label
cuts_label_n_colour colour // colour of text

cuts_label_n_textstyle text // textstyle of text label

cuts_label_n_pre_text     text // text before the string name
cuts_label_n_post_text     text // text after the string name

cuts_label_n_justification          justification            // justification of the text
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pipeline long section

section view

point where the pipeline
cuts a string 

The cut point can be labelled with
chainage of the cut point
height of the cut point
height of the x-section or tins at this offset
name of the string for the cut point

Any 12d symbols can be drawn at the cut point

tin (natural surface)
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Title Block Information
The plot can have a standard 12d Model title block or a user defined title block.

The standard title block consists of a simple border around the plot and two lines of text in a box 
underneath the plot. For a user defined title block, all the line work and text is defined by the 
user.

Standard Title Block

For the standard 12d Model title block, there are extra parameters for two lines of text and text 
size and colour. The standard title block is turned on or off by the parameter plot_border.

plot_border yes/no // yes plots a standard title block
// default yes

title_1 text
title_2 text
title_text_size value
title_colour colour

User Title Block

For the user defined title block, the title block drawing commands are kept in a file whose name 
is supplied by the user. The title block drawing commands are almost identical to the linestyle 
drawing commands and is given at the beginning of chapter Advanced Plotting.

Hence for a user defined title block, there are just two parameters - one to say a title block file is 
being used and the other to give the name of the title block file. The plot_border parameter should 
also be set to no so that the standard title block is not also drawn.

use_title_file yes/no // yes draws the title block given in title_file
// default no

title_file filename
plot_border no // turn off standard title block

Some special plot parameters are used to pass information down to variables in a user defined 
title block

For example, inside the title block file it is possible to have run time user defined text variables. 
The actual text values for these text variables are passed down to the title block file from the plot 
parameter file via the parameters user_text_n (n = 1,2,... 1000)

user_text_n text

The special plot parameters are:

time_format text // format for $time

user_text_n text // where n = 1,2,... 1000
// passed down to $user_text_n

title_1 text // passed down to $title_1
title_2 text // passed down to $title_2

start_page_number integer // used as the starting value for
//   $page_number. If missing, 
//   $page_number starts at 1.

start_drawing_number integer // added to $drawing_number in title
// block file. If missing,
// $drawing_number starts at 1.

drawing_number_prefix        text // passed down to
//   $drawing_number_prefix

drawing_number_postfix         text // passed down to
// $drawing_number_postfix
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Parameters that Modify Fields In the Plot Pipeline Network Panel
A number of parameters match those in the plot pipeline network panel.

When the plot parameter file is first read, any parameters in the panel will be replaced by the 
values of any corresponding parameters from the parameter file.

However, if the parameter is subsequently modified in the panel, the panel value will be the 
value used for the parameter.

The plot parameters that also occur in the plot pipeline network panel are:

network_model text
plotter_type text
plot_stem text

view_name text // name of section view for tins, services,
// vertical exaggeration etc.

specials_model text
peg_interval world-units
scale value

sheet_size text     or    “width     height”
plot_height mm

start_chainage world-units
end_chainage world-units

left_margin mm
right_margin mm
top_margin mm
bottom_margin mm

plot_border yes/no
title_1 text
title_2 text
title_text_size value
title_text_colour colour
use_title_file yes/no
title_file filename
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Reports
pipeline_reports
Position of menu: Design =>Pipeline =>Reports

The Reports walk-right menu contains reports for joint deflections along the pipeline and crest 
and sag points.

Deflection
pipeline_joint_deflection_report

Position of option on menu: Design =>Pipeline =>Reports=>Deflection

The deflection report gives the horizontal, vertical and combined joint deflections along the 
pipeline.

After selecting the Deflection option, the Pipeline Joint Deflection Report panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Report file input

name of the file for the report

Mode input interval interval,
critical, summary

if interval - reports the joint deflection at the interval given plus any horizontal or vertical intersection 
points without curves on them

If critical - only reports points where the deflection is greater than the value given in the pipeline joint 
defaults panel.

If summary - gives the maximum joint deflections

Interval input 10

the chainage distance between points along the pipeline where joint deflections are to be reported

Pick & Report button

pick the pipeline string to report on.
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Crest/Sag Points
Crest/sag points_reports
Position of option on menu: Design =>Pipeline =>Reports=>Crest/Sag Points

After selecting the Crest/sag points option, the String Crest/Sag Points Report panel is displayed.

This is the same option as the Reports=>Strings=>Crest/sag points in the main menu.

For each selected string, the string’s crest/sag points are written to the report file given in the 
report file field of the panel.



12d Model Reference Manual

Page 2232 April 2003Reports



April 2007 Page 2233

21  Volumes
12d Model provides two distinct methodologies for calculating volumes; end area and exact.

In all cases the volumes are broken up into cut and fill volumes.

Definition of Cut and Fill
Cut is defined to be where ever the new surface or given height is below the original surface. 
That is, you have to cut to get from the original surface to the new surface. The sign of cut 
quantities is set via the Cut volume sign field from the Default settings tab of the Defaults panel 
(Utilities=>Defaults) and the default for cut volume sign is positive.

Fill is defined to be where ever the new surface or given height is above the original surface. 
That is, you have to fill to get from the original surface to the new surface. The sign of fill 
quantities is the opposite to the value for cut and cut is set via the Cut volumes sign field from 
the Default settings tab of the Defaults panel (Utilities=>Defaults). The default for fill is negative.

End Area and Exact Volumes
In the end area method, sections are automatically created through tins. From the sections, cut 
and fill areas for the sections and the cut and fill volumes between the sections are calculated. 
For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” 

For exact volumes, the volume between a tin and a plane or between two tin is determined by 
working out the exact geometrical shapes between the tins and summing their volumes. For 
more information on the exact volume calculations, go to the section “Theory of Exact Volumes” 

It is often stated that exact volumes are more accurate than end area volumes. However, when 
the distance between sections is small in the end area volume calculations, the results are the 
same to any reasonable degree of accuracy.

The reason for having both methods available in 12d Model is

(a) to provide an independent check on the volumes produced

(b)  each method produces a different breakup of the volumes.

In the end area method, cut and fill volumes are produced on a section by section basis. This is 
needed for applications such as mass-haul calculations.

 For the exact method, cut and fill volumes are easily calculated between different depth values. 

Tin

Height

cutcut

fill

Cut and Fill Between a Tin and a Height

Original Tin

cutcut

fill

New Tin

Cut and Fill Between Two Tins
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This is useful for applications such as depth (isopach) analysis.

For both the end area and the exact method, 12d Model provides options to calculate the volume

(a)  between a surface (tin) and a fixed height (z-value)

 and 

(b) the volume between two surfaces (tins) - an original surface (tin) and a new surface (tin).

NOTE: For the end area volumes, sections are automatically generated and used for the 
calculations. You do not need to generate the sections separately.

For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” . For information on the end area options, please go to the section “End Area” .

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” . For information on the exact volume options, please go to the section “Exact” .
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Theory of End Area Volumes
In the end area method of calculating volumes, sections are automatically generated through the 
tins. For each section, cut and fill areas are calculated and then cut and fill volumes are calculated 
from the cut and fill areas. For the definition of cut and fill, please go to the section “Definition of 
Cut and Fill” .

For the end area method, 12d Model provides options to calculate the volume between a surface 
(tin) and a fixed height (z-value) and the volume between two surfaces (tins).

In the end area methods of calculating volumes, sections can be generated through a tin or tins at 
either a given angle or at right angles to a selected string.

When using the sections along a string options, it is possible for a generated section to be broken 
into more than one part and a parameter exists to only use those sections that contain the 
selected string.

For each generated section, the cut and fill areas are calculated and then the volumes between the 
two sections using either the average end (see “Average End Area Formula” ) or the two section 
prismoidal methods (see “Two Section Prismoidal Formula” ).

distance between
   two sections

Parallel Sections Sections along a Selected String

distance between
     two sections

selected

automatically generated
    parallel sections

string

automatically generated
sections perpendicular
to the selected string

Sections Generated along a Selected String
with "String segment only" turned off

sections without the
string passing through

no sections created

them

Sections Generated along a Selected String
with "String segment only" turned on
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NOTE: For the end area volumes, sections are automatically generated and used for the 
calculations. You do not need to generate the sections separately.

Tin

Height

cutcut

fill

Cut and Fill Areas Between a Tin and a Height

Original Tin

cutcut

fill

New Tin

Cut and Fill Areas Between Two Tins
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Average End Area Formula
Using the Average End Area method the volume between two consecutive sections is calculated by 
the formula

Volume of cut between the two sections = D  x (C1 + C2) / 2

where

D = distance between the two sections
C1 = area of cut for the first section
C2 = area of cut for the second section

The Total cut volume is the sum of the cut volumes between each pair of sections.

Similarly

Volume of fill between the two sections = D  x (F1 + F2) / 2

where

D = distance between the two sections
F1 = area of fill for the first section
F2 = area of fill for the second section

The Total fill volume is the sum of the fill volumes between each pair of sections.

Two Section Prismoidal Formula
The two section prismoidal method, as its name suggests, is a modification of the standard 
prismoidal method but it uses only two sections rather than the three sections required by the 
standard prismoidal method.

Using the Two Section Prismoidal method the volume between two consecutive sections is 
calculated by the formula

Volume of cut between the two sections = D  x (C1 + C2 + Sqrt(C1 x C2)) / 3

where

D = distance between the two sections
C1 = area of cut for the first section
C2 = area of cut for the second section

The Total cut volume is the sum of the cut volumes between each pair of sections.

Similarly

Volume of fill between the two sections = D  x (F1 + F2 + Sqrt(F1 + F2)) / 3

where

D = distance between the two sections
F1 = area of fill for the first section
F2 = area of fill for the second section

The Total fill volume is the sum of the fill volumes between each pair of sections.

For the definition of cut and fill, please go to the section “Definition of Cut and Fill” .

For information on the end area options, please go to the section “End Area” .

For information on the theory for exact volumes, please continue to the section “Theory of Exact 
Volumes” .
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Theory of Exact Volumes
This method calculates the exact volume between two triangulated surfaces (tins), or between 
one triangulated surface and a plane of constant height.

The volumes are calculated by mathematically subdividing the triangles from both tins into 
areas that contain only one triangle from each tin.

In three dimensions, these areas represent well defined polygons with the plane of the triangle 
from one tin as its top and the plane of the triangle from the other tin as its bottom.

For each small area, the cut and fill volume between the two tins can be calculated exactly.

The total cut and fill volume between the two tin is simply the sum of the cut and fill volumes for 
each small area.

For the definition of cut and fill, please go to the section “Definition of Cut and Fill” .

For information on the exact volume options, please go to the section “Exact” .

The calculated volumes by the exact method can be produced and reported on over user supplied 
depth ranges. Similarly, a view can be coloured on a depth basis using the same range file.

IMPORTANT NOTE - the volume totals are only calculated for the depths in the range file. If 
the depth ranges does not cover the entire depth difference between the tins then the totals 

Subdividing the Triangles for the Exact Method of Calculating Volumes

triangles from first tin triangle from second tin

area that is from only
one triangle from
each tin

Volume for the Small Common Area of Two Tins

3D-plane of the triangle

3D-plane of the triangle
area that is from only
one triangle from
each tin

from second tin

from first tin
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which are the sum of the different depth ranges will not be the same as the volumes between the 
two tins.

For information on the theory for end area volumes, please go to the section “Theory of End 
Area Volumes” .

Original Tin

positive depth

cutcut

fill

is down from

New Tin

New Tin

Original Tin

New Tin

5

5

volume for range -5 to 0 (cut)

volume for rangepositive depth
is down from
New Tin

0 to 5 (fill)
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Volumes Menu
volumes

Position of menu: Design =>Volumes

12d Model provides two distinct methodologies for calculating volumes; end area and exact.

For information and the theory on both these methods go to the section “Volumes” 

The Volume walk-right menu is

and each option in this menu will now be discussed.

For the option End area, please go to the section “End Area” 
Exact “Exact” 
Grid cell “Grid Cell” 
Stockpile “Stockpile” 
Tin to tin ht range “Tin to Tin by Height Range” 
Cut/fill text in poly “Create Cut/Fill Text Within Polygon” 
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End Area
end_area_volumes

Position of menu: Design =>Volumes =>End area

These volumes are calculated using the end area method. For more information on the end area 
volume calculations, go to the section “Theory of End Area Volumes” .

The options tin to height and tin to tin use parallel sections defined at a user supplied angle and 
separation distance, to calculate the end areas.

The options string tin to height and string tin to tin use sections defined at right angles to a user 
selected string, for their end area volume calculations. The distance between sections is supplied 
by the user.

The options sections to height and sections to sections use sections already created to calculate 
volumes using end areas.

In all the volume options, the sections are restricted to a user defined polygon.

12d Model reports on the cut, fill and balance for each of the sections used in the calculations and 
also the total cut, fill and balance.

In the report, the sign for cut (negative or positive) is given by the cut volume sign from the 
Defaults panel (fill will have the opposite sign).

The end area walk-right menu is

Each option in this menu will now be described.

For the option Tin to height, please go to the section “Tin to Height” .
Tin to tin “Tin to Tin” .
String tin to height  “String Tin to Height” .
String tin to tin “String Tin to Tin” .
Section to height “Sections to Height” .
Section to sections  “Sections to Sections” .
Tin to sections  “Sections to Sections” .

For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” .

end area volumes between surface and height
between surfaces
along string between surface and height
along string between surfaces

between a model of sections and height
between two models of sections
between a model of sections and a tin
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Tin to Height
end_area_volume_from_tin_to_a_height

Position of option on menu: Design =>Volumes =>End Area =>Tin to height

The Tin to height option is used to find volumes between an existing surface and a user supplied 
height. The volumes can only be calculated within a user supplied polygon.

For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” .

On selecting the tin to height option, the End Area Volume From Tin to a Height panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the volume between it and a height (z value) will be calculated.

Height input

the volume is calculated between the tin and the value in this field.

Angle for sections input 90.0 0,45,90

Tin

Height

cutcut

fill

Cut and Fill Areas Between and a Tin and a Height
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angle (in degrees) of the lines to section along.

Dist between sections input 10.0 1,10,100

distance between the lines to section along

Model for sections input available models

if non-blank, the sections though the tin used for the end area calculations are retained and placed in 
the model given in this field. The sections are given the same colour as the tin.
If blank, the sections are not kept.

Difference model input available models

if non-blank, the sections which are the difference between the tin sections and the height are retained 
and placed in the model given in this field.
If blank, the sections are not kept.

Difference colour input available colours

colour for the difference sections strings

Clean sections models beforehand tick box

if tick, the model of sections and difference sections are cleaned out before the option runs.

Poly poly string-select

if selected, the string, rectangle or lasso used as the bounding polygon for the volume calculations.

Report file input *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Report mode input summary summary, full

if full, the cut and fill details for every section are included.
If summary, just the cut and fill totals are given.

Volume mode choice box Average end area average end area,

 prismoidal - 2 sections

the two methods in 12d for calculating volumes using areas of sections. For more information on each 
method, go to “Average End Area Formula” 

Volume button

The volume between the tin and the height (z-value) within the selected bounding polygon is calculated 
by the end area method. The sections through the polygon will be calculated along straight lines at the 
angle given by the angle field and at a separation given by the dist field. The sections are made against 
the tin given in tin field.

How to Use the Panel and Panel Messages

(a) Select the bounding string by choosing Poly and picking the required string.

(b) Volume processing begins on selecting the Volume button.
Progress messages - sent to the panel message area

calculating volumes
Completion message - sent to the panel message area

c cut volume f fill volume bal total (balance) volume

<esc> can be used to terminate the option during volume calculations.
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Tin to Tin
end_area_volume_between_tins

Position of option on menu: Design =>Volumes =>End Area =>Tin to tin

The tin to tin option is used to find volumes between an existing and a new surface. The volumes 
can only be calculated within a user supplied polygon.

For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” .

On selecting the tin to tin option, the end area volume between tins panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original Tin

cutcut

fill

New Tin

Cut and Fill Areas Between Two Tins
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Original tin input available tins

name of the original tin for determining volumes.

New tin input available tins

name of the new tin for determining volumes.

Angle for sections input 90.0 0,45,90

angle (in degrees) of the lines to section along.

Dist between sections input 10.0 1,10,100

distance between the lines to section along

Original tin sections input available models

if non-blank, the sections though the original tin used for the end area calculations are retained and 
placed in the model given in this field. The sections are given the same colour at the original tin.
If blank, the sections are not kept.

New tin sections input available models

if non-blank, the sections though the new tin used for the end area calculations are retained and placed 
in the model given in this field. The sections are given the same colour as the new tin.
If blank, the sections are not kept.

Difference model input available models

if non-blank, the sections which are the difference of the original and the new sections are retained and 
placed in the model given in this field.
If blank, the sections are not kept.

Difference colour input available colours

colour for the difference sections strings

Use extrapolated areas tick box not tick

if not tick, areas (and hence volumes) are only calculated where both sections exist. Hence the sections 
are limited to where both occur.

If tick, when the sections are not the same length, the end points of the above and below sections are 
connected thereby extrapolating the smaller section. This method is not recommended since data does 
not exist.

Original extrapolated sections model model box available models

if non-blank, the extrapolated sections created from the Original sections are placed in this model.
If blank, the extrapolated sections for the original sections are not kept.

New extrapolated sections model model box available models

if non-blank, the extrapolated sections created from the New sections are placed in this model.
If blank, the extrapolated sections for the new sections are not kept.

Extrapolated colour colour box available colours

colour for the extrapolated sections

Clean sections models beforehand tick box

if tick, the model of sections and difference sections are cleaned out before the option runs.

Poly poly string-select

if selected, the string, rectangle or lasso used as the bounding polygon for the volume calculations.

Report file input *.rpt
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name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Report mode input summary summary, full

if full, the cut and fill details for every section are included.
If summary, just the cut and fill totals are given.

Volume mode choice box Average end area average end area,

 prismoidal - 2 sections

the two methods in 12d for calculating volumes using areas of sections. For more information on each 
method, go to “Average End Area Formula” 

Volume button

The volume between the new and the original tins within the selected polygon string is calculated by 
the end area method. The sections through the polygon selected by poly will be calculated along 
straight lines at the angle given by the angle field and at a separation given by the dist field. The 
sections are made against the tins given by the original and the new tin fields.

How to Use the Panel and Panel Messages

(a) Select the bounding polygon string by choosing Poly and picking the required string.

(b) Volume processing begins on selecting the volume button.

Progress messages - sent to the panel message area

calculating volumes

Completion message - sent to the panel message area

c cut volume f fill volume bal total (balance) volume

<esc> can be used to terminate the option during volume calculations.
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String Tin to Height
volume_along_a_string_to_a_height

Position of option on menu: Design =>Volumes =>End Area =>String tin to height

The volume options already described calculate the volumes by forming parallel sections 
through the tin and then using the end area method between adjacent sections.

In many situations, the sections to be used are defined to be at right angles to a user selected 
string. This method is commonly used in road calculations.

The options string tin to height and string tin to tin both use sections defined at right angles to a 
user selected string for the end area volume calculations. For both options, the volumes can only 
be calculated within a user supplied polygon.

It optionally uses the whole section within the polygon or only the part of the section that 
contains the string.

For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” .

On selecting the string tin to height option, the volume along a string to a height panel is displayed.

Sections Generated along a Selected String
with "String segment only" turned off

sections without the
string passing through

no sections created

them

Sections Generated along a Selected String
with "String segment only" turned on

selected
string
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The fields and buttons in this panel are used as follows.

Field Description Type Defaults Pop-Up

String for Tin to Ht string select

a string is selected to be used to define the sections used in the end area calculations. The sections are 
taken at right angles to this string.

Tin input available tins

name of the tin for which the volume between it and a height (z-value) will be calculated.

Use string height tick box

if tick, the height used for the area calculations is taken at each section from the user selected string.
If not tick, the height given in the height panel field is used in the area calculations.

Height input 0

if use string height is set to no tic, the volume is calculated between the tin and the value in this field.

Start chainage input

if non blank, the chainage of the first section to use for volume calculations.
If blank, start with the section with the lowest chainage.

End chainage input

if non blank, the chainage of the last section to use for volume calculations.
If blank, end with the section with the highest chainage.

Dist between sections input 10 1,10,100
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distance between the sections taken at right angles down the user selected string.

Model for sections input available models

if non-blank, the sections though the tin used for the end area calculations are retained and placed in 
the model given in this field. The sections are given the same colour as the tin.
If blank, the sections are not kept.

Difference model input available models

if non-blank, the sections which are the difference between the tin sections and the height are retained 
and placed in the model given in this field.
If blank, the sections are not kept.

Difference colour input available colours

colour for the difference sections strings

Clean sections models beforehand tick box

if tick, the model of sections and difference sections are cleaned out before the option runs.

Report file input *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Report mode input summary summary, full

if full, the cut and fill details for every section are included.
If summary, just the cut and fill totals are given.

Volume mode choice box Average end area average end area,

 prismoidal - 2 sections

the two methods in 12d for calculating volumes using areas of sections. For more information on each 
method, go to “Average End Area Formula” 

String segment only tick-cross tick

if tick, only the part of the section within the polygon that contains the selected string is used.
If not tick, the whole section within the polygon is used (see “Theory of End Area Volumes” ).

Volume correction for curves tick box

if tick, volume corrections are made when going around curves.

Poly poly string-select

if selected, the string, rectangle or lasso used as the bounding polygon for the volume calculations.

Volume button

The volume between the tin and the height (z-value) within the selected polygon is calculated by the 
end area method. The sections through the tin are calculated at right angles to the selected string at a 
separation given by the dist field. The section strings are placed in the model given in the model field.

How to Use the Panel and Panel Messages

(a) Select the bounding polygon string by choosing Poly and picking the required string.

(b) Select a string to define the sections string by choosing String button

(c) Volume processing begins on selecting the volume button.

Progress messages - sent to the panel message area

calculating volumes

Completion message - sent to the panel message area

c cut volume f fill volume bal total (balance) volume
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<esc> can be used to terminate the option during volume calculations.
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String Tin to Tin
volume_along_a_string_between_tins

Position of option on menu: Design =>Volumes =>End Area =>String tin to tin

In this option, the sections generated for collating areas and volumes are defined to be at right 
angles to a user selected string. This method is commonly used in road calculations.

It optionally uses the entire section within the polygon or only the sections or part of sections that 
contain the user selected string.

For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” .

On selecting the String Tin to Tin option, the Volume Along a String Between Tins panel is 
displayed.

Sections Generated along a Selected String
with "String segment only" turned off

sections without the
string passing through

no sections created

them

Sections Generated along a Selected String
with "String segment only" turned on

selected
string
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The fields and buttons in this panel are used as follows.

Field Description Type Defaults Pop-Up

String for tin to tin string select

the string for defining the sections used in the end area calculations. The sections are taken at right 
angles to this string.

Original tin input available tins

name of the original tin for determining volumes.

New tin input available tins

name of the new tin for determining volumes.

Start chainage input

if non blank, the chainage of the first section to use for volume calculations.
If blank, start with the section with the lowest chainage.

End chainage input

if non blank, the chainage of the last section to use for volume calculations.
If blank, end with the section with the highest chainage.
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Dist between sections input 10.0 1,10,100

distance between the lines to section along

Original tin sections input available models

if non-blank, the sections though the original tin used for the end area calculations are retained and 
placed in the model given in this field. The sections are given the same colour at the original tin.
If blank, the sections are not kept.

New tin sections input available models

if non-blank, the sections though the new tin used for the end area calculations are retained and placed 
in the model given in this field. The sections are given the same colour as the new tin.
If blank, the sections are not kept.

Use extrapolated areas tick box not tick

if not tick, areas (and hence volumes) are only calculated where both sections exist. Hence the sections 
are limited to where both occur.

If tick, when the sections are not the same length, the end points of the above and below sections are 
connected thereby extrapolating the smaller section. This method is not recommended since data does 
not exist.

Original extrapolated sections model model box available models

if non-blank, the extrapolated sections created from the Original sections are placed in this model.
If blank, the extrapolated sections for the original sections are not kept.

New extrapolated sections model model box available models

if non-blank, the extrapolated sections created from the New sections are placed in this model.
If blank, the extrapolated sections for the new sections are not kept.

Extrapolated colour colour box available colours

colour for the extrapolated sections

Difference model input available models

if non-blank, the sections which are the difference of the original and the new sections are retained and 
placed in the model given in this field.
If blank, the sections are not kept.

Difference colour input available colours

colour for the difference sections strings

Clean sections models beforehand tick box

if tick, the model of sections and difference sections are cleaned out before the option runs.

Report file input *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Report mode input summary summary, full

if full, the cut and fill details for every section are included.
If summary, just the cut and fill totals are given.

Volume mode choice box Average end area average end area,

 prismoidal - 2 sections

the two methods in 12d for calculating volumes using areas of sections. For more information on each 
method, go to “Average End Area Formula” 

String segment only tick-cross tick
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if tick, only the part of the section within the polygon that contains the selected string is used.
If not tick, the whole section within the polygon is used (see “Theory of End Area Volumes” ).

Volume correction for curves tick box

if tick, volume corrections are made when going around curves.

Poly poly string-select

if selected, the string, rectangle or lasso used as the bounding polygon for the volume calculations.

Volume button

The volume between the original and new tins within the selected bounding polygon is calculated by 
the end area method. The sections through the tins are calculated at right angles to the selected string at 
a separation given by the dist field.

How to Use the Panel and Panel Messages

(a) Select the bounding polygon string by choosing Poly and pick the required string.

(b) Select the string to define the sections string by choosing String for tin to tin

(c) Volume processing begins on selecting the Volume button.

Progress messages - sent to the panel message area

calculating volumes

Completion message - sent to the panel message area

c cut volume f fill volume bal total (balance) volume

<esc> can be used to terminate the option during volume calculations.
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Sections to Height
end_area_volume_from_sections_to_a_height

Position of option on menu: Design =>Volumes =>End Area =>Sections to height

The Sections to height option is used to find volumes between sections that already exist (in a 
given model) and a user supplied height. The volumes can be restricted to be within a user 
supplied polygon.

Normally the Sections to Height method is not used since if the tin exists, the option
          Design =>Volumes =>End Area =>Tin to height
automatically generates sections through the tin at the required interval. 

WARNING: The Sections to Height method can not be used when there are cases of two sections 
being on the same line.

For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” .

On selecting the Sections to height option, the End Area Volume from Tin to a Height panel is 
displayed.

sections that are
on the same line

WARNING - these sections
will give INCORRECT volumes.

These sections will give
correct volumes

Do not use the option for this case

no sections are
on the same line
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Sections input available models

name of the model containing the sections for which the volume between them and a height (z value) 
will be calculated.

Height input

the volume is calculated between the sections and the value in this field.

Difference model input available models

if non-blank, the sections which are the difference between the given sections and the height are retained 
and placed in the model given in this field.
If blank, the sections are not kept.

Difference colour input available colours

colour for the difference sections strings

Clean sections models beforehand tick box

if tick, the model of sections and difference sections are cleaned out before the option runs.

Poly poly string-select

if selected, the string, rectangle or lasso used as the bounding polygon for the volume calculations.

Report file input *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Report mode input summary summary, full

if full, the cut and fill details for every section are included.
In summary, just the totals are given.

Volume mode choice box Average end area average end area,

 prismoidal - 2 sections

the two methods in 12d for calculating volumes using areas of sections. For more information on each 
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method, go to “Average End Area Formula” 

Volume correction for curves tick box

if tick, volume corrections are made when going around curves.

Volume button

the volume between the model of sections and the height (z-value) within the selected bounding 
polygon is calculated by the end area method.

<esc> can be used to terminate the option during volume calculations.

Sections to Sections
end_area_volume_between_sections

Position of option on menu: Design =>Volumes =>End Area =>Sections to sections

The Sections to sections option is used to find volumes between two models of sections. The 
volumes can be restricted to be within a user supplied polygon. Note that there needs to be 
matching sections in the two models of section. 

Normally the Section to Sections method is not used since if the tin exists, the option
          Design =>Volumes =>End Area =>Tin to tin
automatically generates sections through the two tins at the required interval. 

WARNING: The Section to Sections method can not be used when there are cases of two 
sections being on the same line.

For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” .

On selecting the sections to sections option, the end area volume between sections panel is 
displayed.

sections that are
on the same line

WARNING - these sections
will give INCORRECT volumes.

These sections will give
correct volumes

Do not use the option for this case

no sections are
on the same line
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original sections input available models

name of the original model of sections for determining volumes.

New sections input available models

name of the new model of sections for determining volumes.

Difference model input available models

if non-blank, the sections which are the difference of the original and the new sections are retained and 
placed in the model given in this field. If blank, the sections are not kept.

Difference colour input available colours

colour for the difference sections strings

Use extrapolated areas tick box not tick

if not tick, areas (and hence volumes) are only calculated where both sections exist. Hence the sections 
are limited to where both occur.

If tick, when the sections are not the same length, the end points of the above and below sections are 
connected thereby extrapolating the smaller section. This method is not recommended since data does 
not exist.

Original extrapolated sections model model box available models

if non-blank, the extrapolated sections created from the Original sections are placed in this model.
If blank, the extrapolated sections for the original sections are not kept.

New extrapolated sections model model box available models

if non-blank, the extrapolated sections created from the New sections are placed in this model.
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If blank, the extrapolated sections for the new sections are not kept.

Extrapolated colour colour box available colours

colour for the extrapolated sections

Clean sections models beforehand tick box

if tick, the model of sections and difference sections are cleaned out before the option runs.

Poly poly string-select

if selected, the string, rectangle or lasso used as the bounding polygon for the volume calculations.

Report file input

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no file name is given, the report is not produced.

Report mode input summary summary, full

if full, the cut and fill details for every section are included.
If summary, just the cut and fill totals are given.

Volume mode choice box Average end area average end area,

 prismoidal - 2 sections

the two methods in 12d for calculating volumes using areas of sections. For more information on each 
method, go to “Average End Area Formula” 

Volume correction for curves tick box

if tick, volume corrections are made when going around curves.

Volume button

The volume between the original model of sections and the new model of sections within the selected 
bounding polygon is calculated by the end area method.

<esc> can be used to terminate the option during volume calculations.
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Tin to Sections
end_area_volume_from_tin_to_sections

Position of option on menu: Design =>Volumes =>End Area =>Tin to sections

The Sin to sections option is used to find volumes between a tin and a model of sections. The 
volumes can be restricted to be within a user supplied polygon.

Normally the Tin to Sections method is not used since if the tin for the sections exists, the option
          Design =>Volumes =>End Area =>Tin to tin
automatically generates sections through the two tins at the required interval. 

WARNING: The Tin to Sections method can not be used when there are cases of two sections 
being on the same line.

For more information on the end area volume calculations, go to the section “Theory of End Area 
Volumes” .

Selecting Tin to sections brings up the End Area Volume from Tin to Sections panel.

sections that are
on the same line

WARNING - these sections
will give INCORRECT volumes.

These sections will give
correct volumes

Do not use the option for this case

no sections are
on the same line



Chapter 21  Volumes

April 2007 Page 2261End Area

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original Tin tin box available tins

name of the original tin to use for determining volumes.

New sections model box available models

name of the new model of sections for determining volumes.

Difference model model box available models

if non-blank, the sections which are the difference of the original and the new sections are retained and 
placed in the model given in this field. If blank, the sections are not kept.

Difference colour colour box available colours

colour for the difference sections strings

Tin sections model box available models

if non-blank, the sections cut through the Original tin are placed in this model.
If blank, the sections through the Original tin are not kept.

Tin sections colour colour box available colours

colour for the sections cut through the Original tin

Use extrapolated areas tick box not tick

if not tick, areas (and hence volumes) are only calculated where both sections exist. Hence the sections 
are limited to where both occur.

If tick, when the sections are not the same length, the end points of the above and below sections are 
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connected thereby extrapolating the smaller section. This method is not recommended since data does 
not exist.

Original extrapolated sections model model box available models

if non-blank, the extrapolated sections created from the Original sections are placed in this model.
If blank, the extrapolated sections for the original sections are not kept.

New extrapolated sections model model box available models

if non-blank, the extrapolated sections created from the New sections are placed in this model.
If blank, the extrapolated sections for the new sections are not kept.

Extrapolated colour colour box available colours

colour for the extrapolated sections

Clean sections models beforehand tick box

if tick, the model of sections and difference sections are cleaned out before the option runs.

Poly poly string-select

if selected, the string, rectangle or lasso used as the bounding polygon for the volume calculations.

Report file input

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no file name is given, the report is not produced.

Report mode input summary summary, full

if full, the cut and fill details for every section are included.
If summary, just the cut and fill totals are given.

Volume mode choice box Average end area average end area,

 prismoidal - 2 sections

the two methods in 12d for calculating volumes using areas of sections. For more information on each 
method, go to “Average End Area Formula” 

Volume correction for curves tick box

if tick, volume corrections are made when going around curves.

Volume button

The volume between the original model of sections and the new model of sections within the selected 
bounding polygon is calculated by the end area method.

<esc> can be used to terminate the option during volume calculations.
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Exact
exact_volumes

Position of menu: Design =>Volumes =>Exact

These volumes are calculated by dividing the tins up into small prisms whose volumes can be 
calculated exactly. For more information on the exact volume calculations, go to the section 
“Theory of Exact Volumes” 

In the exact volume options, the volumes calculations can be restricted to a user defined polygon 
or if no polygon is provided, the volumes will be only be calculated for the regions where both 
the triangulations exist.

With the exact method, volumes can easily be calculated for depth bands from 

(a) the given height to the tin for "tin to height" volumes

or
(b) the new tin to the original tin for "tin to tin" volumes.

Hence for the calculations, a range file can be supplied giving depth pairs and 12d Model will 
report the cut, fill and balance for each of the depth pairs and also the total of the cut, fill and 
balance for all the pairs.

In the report, the sign for cut (negative or positive) is given by the cut volume sign from the 
default settings panel (fill will have the opposite sign).

The range file consists of a list of depth ranges and colours, one set per line, in the format

lower_depth       upper_depth       depth_colour

This line represents all depths satisfying

lower_depth <=   depth   < upper_depth.

For each range in the file, the total cut and fill volumes for the depth range will be reported on, 
and the depth_colour can be used to colour all areas on a plan view satisfying the range.

IMPORTANT NOTE - when are depth file is used, the volume totals are only calculated for the 
depths in the range file. If the depth ranges does not cover the entire depth difference between 
the tins then the totals which are the sum of the different depth ranges will not be the same as the 
volumes between the two tins or the volumes from a tin to a height.

Example of a Depth Range File

//   depth range file
// format: lower_depth upper_depth colour_for_depth_range
// depth is measured positive down and negative up.

-20 -10  red // colour red where the depth is greater or equal to -20 and less than -10
-10 0 magenta // colour magenta where the depth is greater or equal to -10 and less than 0
0 10 green // colour green where the depth is greater or equal to 0 and less than 10
10 20 "dark green" // colour dark green where depth is >=10 and less than 20

The exact walk-right menu is
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The options in this menu will now be described.

For the option Between heights, please go to the section “Between Heights” 
Removal calcs “Removal Calcs” 
Storage calcs “Storage Calcs” 
Tin to height “Tin to Height” 
Tin to height 2 “Tin to Height 2” 
Tin to height curve  “Tin to Height Curve” 
Tin to tin “Tin to Tin” 
Tin to tin 2  “Tin to Tin 2” 
Balanced volumes  “Balanced Volumes” 

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

volumes between two heights
cut/slope vol calcs for height range 
fill/slope vol calcs for height range
volumes between surface and a height
 "       "       " 

volumes between surfaces
"       "       " 
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Between Heights
exact_volume_between_heights

Position of option on menu: Design =>Volumes =>Exact =>Between heights

This panel is used to calculate the volume between two heights on a given tin.

The calculations can be restricted to within a polygon, or if no polygon is selected, the entire tin 
is used.

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

On selecting the between heights option, the exact volume between heights panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the volume between two heights will be calculated.

Type input fill cut, fill

if fill, the fill volume between the two heights is calculated.
If cut, the cut volume between the two heights is calculated.

Height min/max input

volume is calculated between the height min and the height max values.

Increment input

Tin

Height max

cut
cut

fill

Height min
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the volumes between the height min and height max are reported on and is broken up into intervals 
given by the increment value.

Plan view to paint input available views

if non-blank, the region used for calculations will be painted in the given plan view. The colour will be 
green if type is fill, or red if type is cut.

Report file input *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Poly poly string-select

if selected, this string is used as the bounding polygon for the volume calculations.

Volume button

The volume between the height min and height max for the tin within the selected bounding polygon is 
calculated by the exact method.

<esc> can be used to terminate the option during volume calculations.
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Removal Calcs
removal_calculations

Position of option on menu: Design =>Volumes =>Exact =>Removal calcs

For a user specified range of heights, this option will calculate the cut volume from each height 
to a given tin, plus the plan and slope areas for the region of the tin exposed by cutting to the 
height.

The calculations can be restricted to within a polygon, or if no polygon is selected, the entire tin 
is used.

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

On selecting the removal calcs option, the removal calculations panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin used in the volume calculations.

Height min/max input

if non-blank, the minimum/maximum value of the height range to calculate volumes to.
if blank, the tin’s minimum/maximum z-value is used.

Increment input

increment between the heights to calculate the volumes to.

Plan view to paint input available views

if non-blank, the region used for calculations will be painted red in the given plan view.

Report file input *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. if no name is given, no report is produced.

Poly poly string-select

if selected, this string is used as the bounding polygon for the volume calculations.

Volume button

calculate the cut volumes from the tin to the height for the required heights in the height min and height 
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max range.

<esc> can be used to terminate the option during volume calculations.
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Storage Calcs
storage_calculations

Position of option on menu: Design =>Volumes =>Exact =>Storage calcs

For a user specified range of heights, this option will calculate the fill volume from each height to 
a given tin, plus the plan and slope areas for the region of the tin covered by filling to the height.

The calculations can be restricted to within a polygon, or if no polygon is selected, the entire tin 
is used.

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

On selecting the storage calcs option, the storage calculations panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin tin box available tins

name of the tin used in the volume calculations.

Height min/max input

if non-blank, the minimum/maximum value of the height range to calculate volumes to.
if blank, the tin’s minimum/maximum z-value is used.

Increment input    1

increment between the heights to calculate the volumes to.

Plan view to paint view box available views

if non-blank, the region used for calculations will be painted green in the given plan view.

Report file file box *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Poly poly string-select

if selected, this string is used as the bounding polygon for the volume calculations.

Volume button

calculate the fill volumes from the tin to the height for the required heights in the height min and height 
max range.
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<esc> can be used to terminate the option during volume calculations.
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Tin to Height
exact_volume_from_tin_to_a_height

Position of option on menu: Design =>Volumes =>Exact =>Tin to height

This panel is used to calculate the volume between a tin and a given height.

The calculations can be restricted to within a polygon, or if no polygon is selected, the entire tin 
is used.

The calculated volumes can be produced and reported over user supplied depth ranges. 
Similarly, a view can be coloured on a depth basis using the same range file.

IMPORTANT NOTE - the volume totals are only calculated for the depths in the range file. If 
the depth ranges does not cover the entire depth difference between the tin and the height then 
the totals which are the sum of the different depth ranges will not be the same as the volume 
between the tin and the height.

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

On selecting the tin to height option, the Exact Volume From Tin to a Height panel is displayed.

Tin

Height

positive depth

cutcut

fill

is down from Height

Tin

Height

positive

fill

is down
depth

5

5

volume for range -5 to 0 (cut)

volume for range 0 to 5 (fill)

from Height
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin input available tins

name of the tin for which the volume between it and a height (z value) will be calculated.

Height input

the volume is calculated between the tin and the value in this field.

Range file input *.drf

if non-blank, the user supplied depth range file is used to split up the volumes report and define the 
depth colours used for painting a view.

Plan view to paint input available views

if non-blank, the given plan view will be painted according to the depth colours given in the range file.

Poly poly string-select

if selected, this string is used as the bounding polygon for the volume calculations.

Model for faces input available models

if non-blank, faces will be created with colours according to the range colours given in the range file.

Clean faces models beforehand tick box

if tick, the model of faces is cleaned out before the option runs.

Report file input *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Volume button

The volume between the tin and the height (z-value) for the given range file within the selected 
bounding polygon is calculated by the exact method. If a range file does not exist, the volumes between 
the tin and the height is calculated.

<esc> can be used to terminate the option during volume calculations.
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Tin to Height 2
exact_volumes_to_height_2

Position of option on menu: Design =>Volumes =>Exact =>Tin to height 2

This panel is used to calculate the volume between a tin and a given height but the calculations 
are restricted to only the regions defined by another tin rather than to a polygon.

The calculated volumes can be produced and reported over user supplied depth ranges. 
Similarly, a view can be coloured on a depth basis using the same range file.

IMPORTANT NOTE - the volume totals are only calculated for the depths in the range file. If 
the depth ranges does not cover the entire depth difference between the tin and the height then 
the totals which are the sum of the different depth ranges will not be the same as the volume 
between the tin and the height.

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

On selecting the tin to height 2 option, the Exact Volume Height 2 panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin tin box available tins

name of the tin for which the volume between it and a height (z value) will be calculated.

Height input

the volume is calculated between the tin and the value in this field.

Range file input *.drf

if non-blank, the user supplied depth range file is used to split up the volumes report and define the 
depth colours used for painting a view.

Plan view to paint view box available views

if non-blank, the given plan view will be painted according to the depth colours given in the range file.

Model for faces model box available models

if non-blank, faces will be created with colours according to the range colours given in the range file.
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Clean faces models beforehand tick box

if tick, the model of faces is cleaned out before the option runs.

Report file file box *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Poly tin tin box available tins

name of the tin to define the regions that the volume calculations are restricted to.

Volume button

The volume between the tin and the height (z-value) for the given range file within the selected 
bounding polygon is calculated by the exact method. If a range file does not exist, the volumes between 
the tin and the height is calculated.

<esc> can be used to terminate the option during volume calculations.
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Tin to Height Curve
volume_tin_to_ht_curve_panel

Position of option on menu: Design =>Volumes =>Exact =>Tin to ht curve

This panel is used to calculate the volume between a tin between heights and writes out a report 
on the volumes.

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

On selecting the Tin to ht curve option, the Tin to Height Curve panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin tin box available tins

name of the tin for which the volume between it and a height (z value) will be calculated.

Height min input

the start height for calculation volumes.

Height max input

the end height for calculation volumes.

increment input

the height increment.

Output file file box

the file for the volumes report.

Start Excel tick box tick

if tick, start Excel up with the report loaded into it.

Poly select

select the polygon which is used in plan only to restrict the area for calculating volumes over.

Volume button

calculate the volume between heights differing by the given increment, and write out a report.
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Tin to Tin
exact_volume_between_tins

Position of option on menu: Design =>Volumes =>Exact =>Tin to tin

This panel is used to calculate the volume between two tins using the exact method.

The calculations can be restricted to within a polygon, or if no polygon is selected, the 
overlapping sections of the two tins is used.

The calculated volumes can be produced and reported on over user supplied depth ranges. 
Similarly, a view can be coloured on a depth basis using the same range file.

IMPORTANT NOTE - the volume totals are only calculated for the depths in the range file. If 
the depth ranges does not cover the entire depth difference between the tins then the totals 
which are the sum of the different depth ranges will not be the same as the volumes between the 
two tins.

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

On selecting the tin to tin option, the Exact Volume Between Tins panel is displayed.

Original Tin

positive depth

cutcut

fill

is down from

New Tin

New Tin

Original Tin

New Tin

5

5

volume for range -5 to 0 (cut)

volume for rangepositive depth
is down from
New Tin

0 to 5 (fill)
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Cut is defined to be where ever the new tin is below the original tin. Fill is defined to be where 
ever the new tin is above the original tin.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original/New Tin tin box available tins

name of the original/new tin for determining volumes.

Range file input *.drf

if non-blank, the user supplied range file is used to split up the volumes report and define the depth 
colours used for painting a view.

Plan view to paint input available views

if non-blank, the given plan view will be painted according to the depth colours given in the range file.

Model for faces input available models

if non-blank, faces will be created with colours according to the range colours given in the range file.

Clean faces model beforehand tick box

if tick, the model of faces is cleaned out before the option runs.

Report file input *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Polygon options

Use a polygon radio button

Polygon poly string select

if Use a polygon is selected, then the selected string is used as the bounding polygon for the volume 
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calculations.

Use a model of polygons radio button

Model model box available models

if Use a model of polygons is selected, then this model is used and each string in the model is used as a 
bounding polygon and the volume calculated.

Volume button

The volume between the two tins for the given range file within the selected bounding polygon is 
calculated by the exact method. If a range file does not exist, the volumes between the two tins is 
calculated.

<esc> can be used to terminate the option during volume calculations.
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Tin to Tin 2
exact_volume_between_tins_2

Position of option on menu: Design =>Volumes =>Exact =>Tin to tin 2

This panel is used to calculate the volume between two tins using the exact method but the 
calculations are restricted to only the regions defined by another tin rather than to a polygon.

The calculated volumes can be produced and reported on over user supplied depth ranges. 
Similarly, a view can be coloured on a depth basis using the same range file.

IMPORTANT NOTE - the volume totals are only calculated for the depths in the range file. If 
the depth ranges does not cover the entire depth difference between the tins then the totals 
which are the sum of the different depth ranges will not be the same as the volumes between the 
two tins.

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

On selecting the tin to tin option, the Exact Volume Between Tins 2 panel is displayed.

Cut is defined to be where ever the new tin is below the original tin. Fill is defined to be where 
ever the new tin is above the original tin.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original/New Tin tin box available tins

name of the original/new tin for determining volumes.

Range file input *.drf

if non-blank, the user supplied range file is used to split up the volumes report and define the depth 
colours used for painting a view.

Plan view to paint input available views

if non-blank, the given plan view will be painted according to the depth colours given in the range file.

Model for faces input available models

if non-blank, faces will be created with colours according to the range colours given in the range file.

Clean faces model beforehand tick box
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if tick, the model of faces is cleaned out before the option runs.

Report file file box *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

Poly tin tin box available tins

name of the tin to define the regions that the volume calculations are restricted to.

Volume button

The volume between the two tins for the given range file within the selected bounding polygon is 
calculated by the exact method. If a range file does not exist, the volumes between the two tins is 
calculated.

<esc> can be used to terminate the option during volume calculations.

Balanced Volumes
balances_volumes

Position of option on menu: Design =>Volumes =>Exact =>Balanced volumes

This option is currently under development.

On selecting the Balanced volumes option, the Balances Volumes panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Tin tin box available tins

Balance button
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Grid Cell
grdvol_panel

Position of option on menu: Design =>Volumes =>Grid cell

This panel is used to calculate the cut and fill volume between two tins using the exact method 
and then creating text for each rectangular cells of user defined sides covering the tins.

The rectangular cells (grid) can be drawn and the text of the cut and fill values for each grid cell 
and z-values at the cell corners. The total cut and fill can also be created at the bottom of the grid. 

Cut is defined to be where ever the design tin is below the natural surface tin. Fill is defined to be 
where ever the design tin is above the natural surface tin.

For more information on the exact volume calculations, go to the section “Theory of Exact 
Volumes” 

On selecting the grid cell option, the grid volumes panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Natural surface/Design surface tin box available tins

name of the original/new tin for determining volumes.

Calculate tins min, max button

when selected, the minimum and maximum x and y values to define the grid cells are calculated and 
written to the grid x and y minimum and maximum panel fields.
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Grid xmin xmax input

the minimum and maximum x values to define the grid cells.The two values are separated by one or 
more spaces.

Grid ymin ymax input

the minimum and maximum y values to define the grid cells.The two values are separated by one or 
more spaces.

X/Y grid size input

the X/Y size of the grid cell.

Label tin z’s tick box tick

if tick, create text values for the z-values from the tins for each of the grid cell corners. The natural 
surface z value is followed by a N and is placed above and to the right of the corner point. The design 
surface z value is followed by a D and is placed below and to the right of the corner point.

Draw grid tick box tick

if tick, the grid is drawn.

Label total cut/fill tick box tick

if tick, label the total cut, fill and balance at the left hand bottom corner of the grid.

Cut/Fill/Grid/Z text colours colour box

colours to use for the cut, fill and z-values and the grid lines.

Num decimals for z’s input 3

number of decimal places in the z values.

Z text size (w) input

size in world units for the text of the z values.

Num decimals for volumes input 0

number of decimal places in the cut and fill volumes.

Volume text size (w) input

size in world units for the text of the volumes.

Model for grid and text model box available models

model to place all the text and grid lines in.

Report file input *.rpt

name of the file to contain the volume report. If the file already exists, the report will be appended to the 
file. If no name is given, no report is produced.

63.25 N

60.36 D

values are for
this cell corner
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Process button

calculate the grid volumes and grid lines.

Undo button

undo the last set of text and grid lines created whilst the panel was up.
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Stockpile
stockpile_vol_panel

Position of option on menu: Design =>Volumes =>Stockpiles

On selecting the Stockpile option, the Stockpile Calculations panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

data source for strings to create the stockpile.

Volumes tick box tick

if tick, calculate and report the volumes of the stockpiles.

Surface area tick box

if tick, calculate and report the surface area of the stockpiles

Model for tins model box available models

name of the model to place the stockpile tins in.

Model for text model box available models

name of the model to place the text in.

Base string code name box bsp available names
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Code (name) of the string to use as the base of the stockpile.

Report file file box *.rpt

name of the file to contain the volume report. 

View to add view box available views

view to add the model of text to.

Textstyle data textstyle data box text favourites

text setup - for a full description go to “Textstyle Info and Textstyle Data”  in the chapter “Tools and 
Concepts” .

Decimal places number box

number of decimal places for the volumes in the report.

Stockpile number number box

number of stockpile to use in the report.

Process button

calculate the volume and/or surface area of the stockpile.
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Tin to Tin by Height Range
tin_to_tin_by_height_range

Position of option on menu: Design =>Volumes =>Tin to tin ht range

This option is used to calculate the cut and fill volume between two tins breaking the cut and fill 
volumes up by height ranges.

An approximate method is used which uses the z-value of the tin at a point as the representative 
of the height for a cell of user specified size "delta x" by "delta y" centred on the point. By making 
delta x and delta y small, the volumes become more accurate but the computation time increases.

Please note that the volume totals are only for the heights in the range file. If the height ranges 
don’t cover the entire height difference, then the totals will not be the volumes between the two 
tins.

Cut is defined to be where ever the new tin is below the original tin. Fill is defined to be where 
ever the new tin is above the original tin.

In the volumes report, the sign for cut (negative or positive) is given by the cut volume sign from 
the default settings panel (fill will have the opposite sign).

The height range file consists of a list of height ranges and colours, one set per line, in the format

lower_height       upper_height       height_colour

This line represents all heights satisfying

lower_height <=   height   < upper_height.

For each range in the file, the total cut and fill volumes for the height range will be reported on. 
The colour is ignored in this option.

Example of a Height Range File

//   height range file
// format: lower_height upper_height colour_for_height_range

110 120 green // colour green where the height is greater or equal to 110 and less than 120
120 220 "dark green" // colour dark green where height is >= 120 and less than 220

On selecting the tin to tin ht range option, the tin to tin by height range panel is displayed.

Original Tin

New Tin

Upper height

fill volume

Lower height

cut volume cut volume
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Original/New tin tin box available tins

name of the original/new tin for determining volumes.

Delta x/Delta y input 1

x/y size of the cell to consider to be of the height.

Select polygon string select

optional. If selected, the volumes are restricted to being inside this polygon.

Range file input *.drf

if non-blank, the user supplied height range file is used to split up the volumes report. Note that the 
volume totals are only for the heights in the range file.

Report file report file *.rpt

if non-blank, the name of the file to contain the volume report. Note that the volume totals are only for 
the heights in the range file

Volume button

calculate the volumes.
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Create Cut/Fill Text Within Polygon
poly_text_volumes_panel

Position of option on menu: Design =>Volumes =>Cut/fill text in poly

This option is used to calculate the cut and fill volume between two tins within a polygon and 
writing the cut and fill values to a model. The Exact or End Area method can be used for the 
volume calculations.

Selecting Cut/fill text in poly brings up the Create Cut/Fill Text within Polygon panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Polygon poly string select

the volumes are restricted to being inside this polygon.

Original/New tin tin box available tins

name of the original/new tin for determining volumes.

Textstyle info textstyle info box

textstyle info to use for the cut and fill text

Units input

text to place after the cut/fill values

Precision input 3

number of decimal places to use for the cut/fill values

Calc. type choice box Exact Exact, End Area

use either Exact or End Area for the volume calculations
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Angle input

angle for sections when End Area is used

Separation input

distance between sections when End Area is used

Model for text model box available models

model to place to cut and fill text in.

Create button

calculate the volumes and text.
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22  Drafting
drafting

The drafting menu contains options to create data for plots.

The drafting menu is

For the option Bearing/distance labelling, go to the section “Bearing/Distance Labelling” 
Create line marking  “Line Marking” in the chapter “Views” 
Create title block  “Create/Edit Title Block File” in the chapter “Plots” 
Create crosses for strings  “Create Crosses at String Points” 
Create cut/fill symbols “Create Cut/Fill Symbols” 
Create world grid “Create World Grid” 
Create/edit dimensions “Create/Edit Dimensions” 
Chainage/offset label inquire  “Chainage/Offset Label Inquire” .
Display colours, text, linestyles  “Display Colours, Textstyles and Linestyles” .
Draw symbols for alignment “Draw Symbols for Alignment String” 
Hatch polygon “Polygon Hatching” 
Multi string translate “Text and Tables” 
North arrow “North Point Insertion” 
Quarter points bubbles and table “Setout Lip Line”  in chapter “Survey” 
Scale bar “Scalebar” 
Text and tables “Text and Tables” 

on Main menu on 12d Model menu
and floating menu
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Bearing/Distance Labelling
bearing_dist_labelling_panel

Position of option on menu: Drafting =>Bearing/distance labelling

This option is used to label a selected line or arc segment with bearing, distance information and 
arc length information. If the line or arc length is below a given value, the label information is 
added to a short segment table.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

bd annotation file file box *.bdf files

file containing values for the text parameters. 

Read button

read the file given in the “bd annotation file” field.

Save button

save the current text parameter settings to the file given in the “bd annotation file” field.

Save as button

save the current text parameter settings in a file. 

Bearing parameters input box none/complete bearing parameters
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incomplete

if none, don’t label bearings.
If complete, all the bearing parameters have been set.
If incomplete, not all the bearing parameters have been set so the labels can’t be created.

Create bearing text tick box tick

if tick, bearings are labelled.

Distance parameters input box none/complete bearing parameters

incomplete

if none, don’t label distances.
If complete, all the distance parameters have been set.
If incomplete, not all the distance parameters have been set so the labels can’t be created.

Create distance text tick box tick

if tick, distances are labelled.

Label all segments tick box

if tick, all segments of the selected element are labelled.
If not-tic, only the selected segment is labelled.

label style input box b/d, d/b, /bd b/d
/db, bd, db

defines how to label the bearing and distances. For example, d/b means distance above the line and 
bearing below the line. Bearing or distance is only labelled if the appropriate flags are set.

Add text models to view tick box tick

if tick, all models containing text are added to the view containing the selected segment.

Minimum length input box 0

if non-zero, then if the length of the segment is less than this value, then it is given a short segment 
number and added to the short segment table.

Next short segment no. input box 1

the next number to use for short segments.

Pick button

select the segment to be labelled.

Undo button

undo the last set of created labels.
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Line Marking
Position of option on menu: Drafting =>Create line marking

This option creates a title block file from a model of data. It has already been documented as

View => Visualisation => Line marking

in the section “Line Marking” in the chapter “Views” .
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Create Titleblock
Position of option on menu: Drafting =>Create title block

This option creates a title block file from a model of data. It has already been documented as

Plot => Create title block file

in the section “Create/Edit Title Block File” of the chapter “Plots” .
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Create Crosses at String Points
create_cross_panel

Position of option on menu: Drafting =>Create crosses for strings

This panel is used to create crosses at the points of strings. The cross is made up of two 2d strings 
with the intersection of the two strings being the (x,y) position of the point in the string.

The option is mainly used to created crosses to send to packages that don’t support a cross at a 
point.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source data source Model String, Model, View

type of data source.

Model/View/String data source

data source to create crosses for.

Model for crosses model box available models

model for the created crosses

Colour for crosses colour box available colours

colour for the crosses

Cross size (w) input box 5

size of the cross in world units.

Run button

run the option
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Undo button

undo the last set of crosses created whilst the panel has been up.



12d Model Reference Manual

Page 2298 January 2006Create Cut/Fill Symbols

Create Cut/Fill Symbols
tadpole_panel

Position of option on menu: Drafting =>Create cut/fill symbols

This option is used to create cut and fill symbols (tadpoles) between strings or the names of the 
points across x-sections. The choice of symbols and the points they go between is controlled by a 
parameter file.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Reference string string select

string used to define chainage and perpendicular 

Use x-section model tick box

if tick, the points on the cross-sections in the model are used as the names to create symbols between.

X-section model tick box available models

model of cross sections used if “Use X-section model” is ticked.

Model for symbols input available models

model for the created cut-fill symbols 

Colour for symbols Input available colours

colour for the created cut-fill symbols

Parameter file input

file specifying what symbols are drawn between what strings (or points on x-sections).

Use max symbol width tick box

if tick, the symbols are only stretched to the maximum size given in the “Max symbol width” field.
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Max symbol width input

maximum distance in world units to stretch the symbol.

Process button

Run the option.

Undo button

undo the last set of cut-fill symbols created by running the panel.The “Undo” function is lost once the 
option is finished.

Notes:

// Sample file for plotting symbols to denote cut/fill slopes
// All lines starting with // are comments. Blank lines are ignored
//
// The file layout is:

// ch_start ch_end ch_inc side str1   str2 symbol1 %1 symbol2   %2
//
// eg 110 150 10 L "trial1->c1" "trial->c2" tadpole 100 tadpole 50
//
// ch_start defines the start chainage
// ch_end defines the end chainage
// ch_inc defines the chainage increment
// side is one of L, R or LR (left, right, both)
// str1 is the name of the string (or point on x-section) to start tadpole
// str2 is the name of the string (or point on x-section) to end tadpole

// If strings are used, the string model name must be contained in the
// string definition i.e. in the format “model ->string_name”
//
// The symbols drawn between the strings (or points) alternate between
// symbol1 and symbol2 and the symbols are drawn as the
// given percentages %1 and %2 respective of the distance
//  between the strings (points).

// The symbol can be one of "
// tadpole  - predefined tadpole shape
// line - predefined batter tick
// "model=xxxxx" - where model "xxxxx" contains 3d strings
// defining the symbol shape. This is as per
// user -defined batter symbols in 4D.
// NB. only 3d strings are supported in the macro

// Example

0 700 10 LR "road str ->c2" "road str ->c3" tadpole 100 tadpole 50
0 700 10 LR "road str ->c4" "road str ->c5" line 90 line 50
0 700 10 LR "road str ->f2" "road str ->f3" "model=symbol" 100 tadpole 50
0 700 10 LR "road str ->f4" "road str ->f5" line 90 line 50
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Create World Grid
create_world_grid

Position of option on menu: Drafting =>Create world grid

This option is used to create a grid, identical to the one drawn on a plan view, but in world units. 
This can then be output to CAD systems that do not allow grids to be easily created.

Selecting the Create world grid option, brings up the Create World Grid panel:

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Clip mode choice box rectangle, view

if ’rectangle’, icons appear for drawing a rectangle, a rotated rectangle or selecting a plot frame.
selecting the ’rectangle’ and ’rotated rectangle’ icons require the user to draw the rectangle to define 

the area to produce the grid for.
selecting the ’plot frame’ icon requires the user to select a plot frame and the view area from the plot 

frame defines the area to produce the grid for.

If ’view’, a View Box appears and a view is selected to define the area to produce the grid for.
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Draw mode choice box full lines full lines, crosses, marks

the type of the grid being drawn - full lines, crosses or marks.
If full lines, then solid lines are drawn at the grid x and y spacing. 
If crosses, then crosses of size cross/mark size are drawn at the intersection of the grid x and y 
spacing.
If marks, then solid lines size cross/mark size are drawn at the beginning/end of the grid at the x and 
y spacing. 

Cross/mark size input

size in world units of the grid crosses/marks.

Grid East (x)

Interval input

the distance between the East (x) grid lines. If this value is zero, the x grid lines will not be drawn.

Text mode input bottom off,
top,
bottom,
top and bottom

the x (East) grid lines can be labelled with their x value. If the grid lines are labelled, the labels can be 
drawn on the top, the bottom or both ends of the x-grid lines.

Pre*postfix input

prefix/postfix (pre*post) to be applied to the value of x (East). If pretext only, just give the text. If post 
text is required, precede it by a *. For example E*m will place E before the x value and m after the 
number.

Grid North (y)

Interval input

the distance between the North (y) grid lines. If this value is zero, the y grid lines will not be drawn.

Text mode input bottom off,
top,
bottom,
top and bottom

the y (North) grid lines can be labelled with their y value. If the grid lines are labelled, the labels can be 
drawn on the top, the bottom or both ends of the y-grid lines.

Pre*postfix input

prefix/postfix (pre*post) to be applied to the value of y (North). If pretext only, just give the text. If post 
text is required, precede it by a *. 

Output settings

Grid colour colour box available colours

colour for the grid lines.

Textstyle data textstyle box

height, angle etc. of the text for the grid labels.

Grid model model box available models

model for the grid lines and text.

Create border tick box

if tick, a rectangle around the area to create the grid for, is created.

Create button

create the grid according to the values given in the panel.
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Create/Edit Dimensions
super_dim_panel

Position of option on menu: Drafting =>Create/edit dimensions

This option is used to create and edit dimensions.

This option is currently under development.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

read in an existing range file.

Write button

write out the data in the pages to the given range file.
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Chainage/Offset Label Inquire
chainage_offset_panel

Position of option on menu: Drafting =>Chainage/offset label inquire

This option is used to calculate and label the perpendicular distance from a selected point to a 
selected centreline, and the chainage of the point dropped perpendicularly onto the centreline.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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Model for labels model box Label chg off available models

if non-blank, create text for the calculated offset and chainage values and place it in this model.

Line colour yellow available colours

colour of the line drawn.

Linestyle linestyle box hidden2 available linestyles

text style for the text.

Symbol colour cyan available colours

colour of the symbol drawn at the point.
text style for the text.

Symbol size 0.5

size (in world units) of the symbol drawn at the point.

Label method choice box Chng/Offset Chng/Offset, Offset/Chng

method of labelling the line from a selected point to the dropped point.

Prefix chainage Ch

prefix for the chainage value.

Prefix offset Off

prefix for the offset value.

Textstyle data textstyle data box available text data

textstyle, size, colour etc. for the text.

Centreline string select

select the string to use for the calculation of chainage and offset.

Pick button

pick a position and the offset from the position to the position dropped perpendicularly onto the selected 
Centreline is calculated, plus the chainage on the Centreline of the dropped point. The values are 
reported in the panel’s message area and if Model for labels is non-blank, text of the values is created 
and place in the model.
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Display Colours, Textstyles and Linestyles
display_colour_text_and_line_styles_panel

Position of option on menu: Drafting =>Display colours, text and line styles

This option creates a model to display either all the colours, linestyles or textstyles defined for a 
project.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Display choice colours colours, textstyles,
linestyles

type of data to display.

Model for the display model box available modes

model to create the display in.

Number of rows input 20

the display is created by first doing a column of the given “Number of rows” and then moves on to 
another column until all the data is drawn.

Process button

run the option.
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Draw Symbols for Alignment String
alignment_symbols_panel

Position of option on menu: Drafting =>Draw symbols for alignment

This panel is used to create symbols (butterflies and dumbbells) at the spiral-tangent, spiral-
curve and curve tangent points.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source input box

type of data to create symbols for.

Model/View/String input box

data source to create symbols for.

Colour of symbols input box

colour to use for the created symbols.

Scale of symbols input box 1

scale of the created symbols.

Model for symbols input box

model to put the created symbols into.

Process button

run the option.

Undo button

undo the last set of symbols created whilst the panel has been up.
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Polygon Hatching
hatch_func_panel

Position of option on menu: Drafting =>Hatch polygon

This option is used to create hatching within a user selected string. A function is created so that 
the hatching can be recalced if the string is modified.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input box

name of the hatching function.model

Hatch model input box

model to place the hatching in.

Hatch colour colour box red

colour for the hatch lines

Hatch x/y spacing (m) input box 10

distance in world units between the x/y hatching lines.

Hatch angle input box 0

angle of the hatch lines.

Hatch linestyle input box 1

linestyle for the hatch lines.

Solid hatch tick box
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if tick, a solid fill of the given hatch colour is used.

Hatch polygon string select

select the string to hatch.

Preview button

draw the hatching to see if it is correct - the hatching function has not been defined.

Set button

define the hatching function with the values given in the panel fields.
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Translate Strings
trans_panel

Position of option on menu: Drafting =>Multi string translate

This panel is used to translate strings selected by name group of a window.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Single button

select a single string to translate.

Name button

select a string and all strings with the same name on the view will be translated.

Group button

select a string and all strings with the same group on the view will be translated.

Window button

click and release to define the first point of the window and then move the cursor and click and release 
to define the second point of the window. A position is then selected and as the cursor is moved, all 
strings in the view that are totally inside the window are translated and placed at the next selected 
position.

Undo button

undo the last set of strings translated whilst the panel has been up.
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North Point Insertion
4d_north_panel

Position of option on menu: Drafting =>North arrow

This option creates a point with a textstyle of the north point arrow.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Linestyle input box 4dnorth

Linestyle for the north point arrow - leave as 4dnorth.

Size factor input box 15

factor the north arrow by this value.

Location input box

either type in an x y position or click on "+" and use Pick xyz to locate the north arrow.

View to add input box

view to add the arrow to.

Process button

create the north point arrow in the model North Point.

Quarter Points
Position of option on menu: Drafting =>Quarter points bubbles and table
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This option is used to create bubbles and/or a report for the critical horizontal and vertical 
points and quarter points (by chord or by chainage) for any arcs in an alignment string.

This option has already been documented as 

Survey=>Setout=>Setout lip line

in the section “Setout Lip Line” of the chapter “Survey” .
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Scalebar
scalebar_panel

Position of option on menu: Drafting =>Scale bar

This option is used to create a scale bar.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model for scalebar model box available models

model to place the scalebar in.

Add to view input box available views

if non-blank, the model is added to this view.

Scale 1: input box

scale to create the scale bar at.

Scale description input box

description to write under the scale bar.

Insertion point pick ops pick ops

position to place the left hand bottom corner of the scale bar at.

Process button

run the option.
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Text and Tables
text_and_tables

Position of menu: Drafting =>Text and Tables

The text and tables menu contains options to create text data and tables for plots.

The test and tables menu is

For the option Defaults, go to the section “Defaults - Text” .
Create quick text  “Quick Text Input” .
Create/edit paragraph text “Text Creation/Edit” .
Table create/edit “Table Create/Edit” .
Leader create  “Leader Text Creation” .
Leader edit “Leader Edit” .
Replace text “Replace Text” .
Short segment table “Short Segments Table” .
Short segment report “Short Segment Report” .
Short segment table utilities “Short Segments Table Utilities” .
Alignment/super alignment table “Alignment & Super Alignment Table” .
Tabulate alignment - IP’s, TC’s “Tabulate Alignment - IP’s and CT’s” .
Tabulate alignment - elements “Tabulate Alignment - Elements” .
Tabulate kerb return “Tabulate Kerb Return” 
Tabulate range file “Tabulate Range File” 
Tabulate symbols/linestyle legend “Symbol / Linestyle Legend - Tabulation” 
Text input file same option as “Text Creation/Edit” 

Defaults - Text
text_defaults_panel

Position of option on menu: Drafting =>Text and Tables =>Defaults



12d Model Reference Manual

Page 2314 January 2006Text and Tables

This option is used to project text defaults that are used with the "Fonts" button on many of the 
text options.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Text model model box Text available models

default model to place the text in.

Text colour colour box cyan available colours

default colour for text.

Text size input box 3

default size for text.

Text width input box 1

default x-factor text.

Text angle input box 0

default angle for text.

Text style input box iso

default text style.

Text justify input box bottom-left

default text justification.

Set defaults button

set the project defaults.

Quick Text Input
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quick_text_panel

Position of option on menu: Drafting =>Text and Tables =>Create quick text

The quick text option creates lines of text using the text defaults. The text can be edited and 
modified using the create/edit paragraph text.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Text box button

type the text to be created into the text box.

Place text button

pick a position to become the justification point for the first line of text.
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Text Creation/Edit
para_panel

Position of option on menu: Drafting =>Text and Tables =>Create/edit paragraph text

The option creates and edits a paragraph of text created with this option or the quick text option.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Text input type choice box paragraph paragraph, file

method of creating text - type in a paragraph or read from a file

if Paragraph selected

Create button

select create to bring up the text box to type text into.

Edit button

select edit to pick and edit existing text.

if File selected

Text file file box

name of the file to read in.

Text parameters

Box/Shadow/None radio button box

if box is ticked, draw a box around the text.
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if shadow is ticked, draw shadowed box around the text.
if none is ticked, don’t draw a box around the text.

Box colour colour box orange

Colour of the box around the text

Shadow colour colour box orange

Colour of the shadow around the box around the text

Location x y z x,y,z box pick ops menu

pick the position for the text.

Font button

bring up the values for the text - e.g. model, colour, size etc.

Inquire button

xxxxx

Process button

create the text and place it at the given location.
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Table Create/Edit
table_create_edit

Position of option on menu: Drafting =>Text and Tables =>Table Create/edit

This option is currently under development

This option reads in a csv file and loads the data into a grid on the panel. The data can be edited 
in the grid and then a table produced in a model.

An existing table in a model can also be selected and the data read into the grid on the panel. The 
data can then be edited and the table updated.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

File file

file to read in and display in the grid on the panel.
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Read button

read the specified file in and display it in the grid on the panel.

Write button

write the data in the grid on the panel to the specified file.

Table settings

create the text and place it at the given location.

Leader Text Creation
leader_text_panel

Position of option on menu: Drafting =>Text and Tables =>Leader create

This option is used to create leader lines and text.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Leader arrow size input box 3

length (in world units) of the head of the arrow of the leader line.

Leader colour colour box cyan

colour of the leader line or arrow

Text side choice box Right Right, Left

side of the leader line to create the text.

Add cog tick box tick

if tick, add a cog to the leader line.

Font button

brings up panel for defining information about the text (size, model colour etc.).

Leader button

create the leader by firs picking the point for the arrow end and then the point for the opposite 
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end.where the text goes. Once the second point is place, the "Leader Text Input" panel is displayed for 
entering five lines of text.

Leader Edit
leader_edit_panel

Position of option on menu: Drafting =>Text and Tables =>Leader edit

This option is used to edit leader lines and text.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Line 1-5 input box

lines of text from the selected leader.

Leader arrow size input/output box

length (in world units) of the head of the arrow of the leader line.

Leader colour colour box cyan

colour of the leader line or arrow

Text side choice box Right Right, Left

side of the leader line to create the text.

Add cog tick box tick

if tick, add a cog to the leader line.

Rotate leader tick box tick

if tick, the leader arrow remains fixed when the leader is moved.
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If not tick, the whole leader line and text is moved.

Pick button

select the leader to be modified.

Font button

brings up panel for defining information about the text (size, model colour etc.).

Move button

move the select leader and its associated text. If "rotate leader" is ticked, then the leader arrow head is 
left fixed.

Set button

redefine the leader line and text with the current values in the panel fields.
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Replace Text
replace_text

Position of option on menu: Drafting =>Text and Tables =>Replace text

Position of option on menu: Utilities =>H-Z =>Find/replace text

This option is used to find and replace text in text strings, 4d string, super strings for vertex and 
segment text.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

data source for text to search and change.

Find what input box

text to search for.

Replace with input box

text to replace the searched text with

Match whole words tick box

if not tick, text is selected  if the "find text" is only part of the text.
If tick, only find the text when the text is exactly the same as the "find text", not just a part of the text.

Match case tick box

if not tick, case is ignored when trying to find a match.
If tick then case is not ignored when trying to find a match.
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Regular expressions tick box

if tick then the Find what text can contain regular expressions.
If not tick, the Find what text is not considered to contain regular expressions.

New button

after selecting new the parameters for the find and replace can be changed.

Find button

find the search text. The text is highlighted and centred in the view.

Find Next button

find the next occurrence of the search text.

Replace button

replace the text.

Replace all button

replace all occurrences of the text.
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Find and Replace Text
replace_text_panel

Position of option on menu: Drafting =>Text and Tables =>Replace text

This option is used to find and replace text.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source type input box string, model, view

data source type.

Data source input box

source of data to change text.

Search for input box

text to search for.

Replace with input box

if non-blank, text to replace the searched text with

Find button

find the search text

Next button

find the next occurrence of the search text.

Replace button

replace the text.

Replace all button

replace all occurrences of the text.
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Short Segments Table
short_segment_table_panel

Position of option on menu: Drafting =>Text and Tables =>Short segment table

This panel is used to create a short segment table.

This option is still under development

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source input box model model, string, view

type of data to process

Model/string/View of numbers

data to process and build a short segment table for.

Table for choice box lines lines, arcs, lines and arcs

type of short elements to tabulate.

Model for table model box Table

model to place the short segment table in.

Text size input box 1

text size.

Text colour colour box red

text colour
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Text units choice box world world, pixels

units for the text size - default is world units.

Text style input box 1

textstyle for the created text.

Table position input box

location for the top left hand corner of the table. Either type in an x y position or click on "+" and use 
"Pick xyz" to locate the table.

Add table to view tick box tick

if tick, add the model containing the table to the view.

View to add input box

view to add the table to.

Process button

create and place the short segment table

Undo button

undo the last short segment table created whilst the panel has been up.

Short Segment Report
short_segment_report_panel

Position of option on menu: Drafting =>Text and Tables =>Short segment report

This panel is used create a report on the short segments.

This option is still under development

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source input box model model, string, view

type of data to process

Model/string/View of numbers
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data to process and report on the short segments.

Report file report box

name of the report file.

Process button

create the short segment report
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Short Segments Table Utilities
table_utilities_panel

Position of option on menu: Drafting =>Text and Tables =>Short segment table utilities

This panel is used modify an existing short segments table.

This option is still under development

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Pick a table string select

select the short segments table to modify.

Text size input box 1

text size.

Text colour colour box red

text colour

Text units choice box world world, pixels

units for the text size - default is world units.

Text style input box 1

textstyle for the created text.

Table position input box

location for the top left hand corner of the table. Either type in an x y position or click on "+" and use 
"Pick xyz" to locate the table.

Move button

move the selected table to the new location.

Delete button

delete the selected table.
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Alignment & Super Alignment Table
alignment_super_alignment_table

Position of option on menu: Drafting =>Text and Tables =>Alignment/Super alignment table

This option is used to create a report and/or a table in a model for an alignment and super align-
ment string in an IP or element format.

This option is under development.
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Tabulate Alignment - IP’s and CT’s
align_ch_tps_func_panel

Position of option on menu: Drafting =>Text and Tables =>Tabulate alignment - IP’s TC’s

This option is used to create a report and/or a table in a model of an alignment string in an IP 
and tangent point format.

The table is created by a function so that if the alignment string changes, the table can be easily 
recalced.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input box

name of the function

Reference string string select

select the string to create the table and/or report for.

Chainage interval input box 0

if zero, only information on the tangent and intersection points is given.
If non-zero, the chainage interval to use to report the information about the reference string. The 
horizontal tangent and intersection points are included.

Start/End chainage input box 0

start/end chainage to use. If 0, the start/end chainage is used.

Location x y z input box

location for the top left hand corner of the table. Either type in an x y position or click on "+" and use 
"Pick xyz" to locate the table.

Report file file box
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if non blank, name of the report file.
If blank, don’t create the report.

Font button

brings up panel for defining information about the text (size, model colour etc.).

Process button

process the reference string and create the report. The table is not yet created.

Place text button

create the table and place it at the given location.
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Tabulate Alignment - Elements
moss_ch_tps_func_panel

Position of option on menu: Drafting =>Text and Tables =>Tabulate alignment - elements

This option is used to create a report and/or a table in a model of an alignment string in an hori-
zontal element format.

The table is created by a function so that if the alignment string changes, the table can be easily 
recalced.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input box

name of the function

Reference string string select

select the string to create the table and/or report for.

CTP IP tolerance +/- input box 0.002

xxxx.

Location x y z input box

location for the top left hand corner of the table. Either type in an x y position or click on "+" and use 
"Pick xyz" to locate the table.

Report file file box

if non blank, name of the report file.
If blank, don’t create the report.

Additional heading input box

additional information for the heading above the table.

Font button



12d Model Reference Manual

Page 2334 January 2006Text and Tables

brings up panel for defining information about the text (size, model colour etc.).

Process button

process the reference string and create the report. The table is not yet created.

Place text button

create the table and place it at the given location.
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Tabulate Kerb Return
kret_ch_tps_panel

Position of option on menu: Drafting =>Text and Tables =>Tabulate kerb return

This option creates a table for a kerb return.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function name input box

name of the function

Reference string select

select the string to create the kerb return table and/or report for.

Chg interval type choice box by number (Arc) by number (Arc)

by distance (Arc)

by special chg file

by number (Chord)

Interval number input box 4

number of points to divide the alignment into.

CTP IP tolerance +/- input box 0.002

xxxx.

Interval number input box 4

xxxx.
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Location x y z input box

location for the top left hand corner of the table. Either type in an x y position or click on "+" and use 
"Pick xyz" to locate the table.

Report file file box

if non blank, name of the report file.
If blank, don’t create the report.

 Heading input box

heading above the table.

Font button

brings up panel for defining information about the text (size, model colour etc.).

Process button

process the reference string and create the report. The table is not yet created.

Place text button

create the table and place it at the given location.
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Tabulate Range File
range_table_panel

Position of option on menu: Drafting =>Text and Tables =>Tabulate range file

This option creates a table for a range file.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Range type choice box slope percent xfall slope percent xfall
slope 1 v in, slope degrees
depth, aspect, height

type of range file to be created.

Range file file box

name of the range file.

Range units input box

text to place beside each line of upper and lower values.

Heading input box

heading to place at the top of the table.

Location x y z input box

location for the top left hand corner of the table. Either type in an x y position or click on "+" and use 
"Pick xyz" to locate the table.

Font button

brings up panel for defining information about the text (size, model colour etc.).

Process button

create and place the range table.
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Symbol / Linestyle Legend - Tabulation
sym_tab_panel

Position of option on menu: Drafting =>Text and Tables =>Tabulate symbol/linestyle legend

This panel is used to tabulate symbols and linestyles used in a model.

This option is still under development

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Text File Input
Position of option on menu: Drafting =>Text and Tables =>Text file input

This option has already been documented as“Text Creation/Edit” 

Drafting =>Text and Tables =>Create/edit paragraph text



January 2005 Page 2339Plot and PPF Editors

23  Plots
plots

Position of menu: It is on the main menu as Plot

The plots walk-right menu is

The options Plot binary ppf’s  and Edit binary ppf’s  are both walk-right menus which list all the 
binary ppf’s in the project and the when the ppf is double clicked, it is Plotted/Edited.

For the options Plot and PPF Editors, go to the section “Plot and PPF Editors”  
Plot frames “Plot Frames” 
Plotting setups “Plotting Setups” 
Old plotting “Old Plotting” 

Plot and PPF Editors
ppf_editors

Position of menu: Plot =>Plot and PPF editors

The Plot and PPF editor walk-right menu is

create floating Plots menu

plotting and ppf editors

plot an existing ppf
edit an existing ppf

create/edit/plot plot frames

plotting set ups
old plotting options

on 12d Model
Plots floating menu

on Main menu

cross section ppf editor
long section ppf editor
creating/editing plot frames
drainage long section ppf editor
drainage plan plot ppf editor
Melb water sewer long section ppf editor
pipeline long section ppf editor

convert old ppf files to new ppf files
copy title data
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For the option Cross sections, go to “X Plot PPF Editor” 
Long sections “Long Plot PPF Editor” 
Plot frames “Plot Frame and PPF Editor” 
Drainage “Drainage Plot PPF Editor” 
Drainage plan “Drainage Plan Plot PPF Editor” 
Melbourne Water “Melbourne Water Plot PPF Editor” 
Pipeline “Pipeline Plot PPF Editor” 
Convert ascii to binary “Convert Ascii PPF to Binary” 
Copy title data “Copy Title Data” 

Plot Frames
plot_frames

Position of menu: Plot =>Plot frames

Although plan view plots can be generated in 12d Model by plotting the contents of the plan 
view with the Plot option, the plot will only have a simple title block.

To create plan plots of an arbitrary size, rotation and scale and with complex title blocks, 
12d Model uses plot frames.

Basically a plot frame consists of a sheet size (in mm), margins within the sheet and a scale for 
the plot. This will define a plotting area in world co-ordinates (the plot frame).

The plot frame can be arbitrarily positioned and rotated on a plan view.

The plot frames walk-right menu is

For the option Create, go to the section “Create” 
Editor “Editor” 
Change “Change” 
Copy “Change” 
Plot “Plot Frame and PPF Editor” 
Rotate “Rotate” 
Translate “Translate” 
Delete “Delete” 
More “More Plot Frames” 

create a plot frame
edit an existing plot frame
change name, model and colour of a plot frame
copy a frame
plot one or many plot frames
rotate a plot frame
translate a plot frame
delete a plot frame
more plot frame options
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Create
new_plot_frame_create
Position of option on menu: Plot =>Plot frames =>Create

On selecting the Create option, the New Plot Frame Create panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Title file title file box all title files

name for the title file to use when plotting the plot frame. The title block file can contain default 
information for the rest of the panel fields. See “Values Used for Defaults when Creating Plot Frames”  
in the Chapter “PPF Editors” 

Name input

name for the plot frame.

Model input available model

the model for the plot frame.

Colour input available colours

the colour for the plot frame.

Scale 1: input

scale for the plot.

Sheet size wd ht (mm) input

the width and height values (separated by spaces) or the name of a user defined sheet size.

Rotation angle input 0

angle of rotation for the plot frame.

Origin input xyz ops menu

x_origin    y_origin    z_origin   
origin (in world units) for the corner of the plot frame - given as three values separated by spaces. The 
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values can either be typed in, or selected by clicking LB in the origin panel view and getting up the xyz 
ops menu and selecting the pick xyz option.

Draw viewport border tick-cross tick

if tick, plot the box around the plotting area (viewport).

Create button

create the plot frame and then put up the plot frame edit panel for the created plot frame.

Same as button

after picking the same as button, an existing plot frame is selected and its information is used to fill in 
the above panel fields.

Margins tab

Left/right margin (mm) 10.0

the left/right hand side margin between the sheet and the plotting area inside the sheet.

Bottom/top margin (mm) 10.0

the bottom/top margin between the sheet and the plotting area inside the sheet.

How To Use the Option

The plot frame contains all the information required to define the physical area in real world 
units to be plotted, the position on the sheet of the area being plotted, the plotter type and the 
plot file name.

Once the frame is created, the New Plot Frame Edit panel for the created plot frame is 
automatically placed on the screen so that the frame’s position can be adjusted using the 
Translate and Rotate buttons. 
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Editor
new_plot_frame_edit

Position of option on menu: Plot =>Plot frames =>Editor

The plot frame editor is used to edit existing plot frames. It is automatically placed on the screen 
when a plot frame is created so that the frame’s position can be adjusted using the Translate and 
Rotate buttons.

On selecting the Editor option, the New Plot Frame Edit panel is displayed.

Most of the fields and buttons used in this panel are the same as the New Plot Frame Create panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Title file title file box all title files

name for the title file to use when plotting the plot frame. The title block file can contain default 
information for the rest of the panel fields. See “Values Used for Defaults when Creating Plot Frames”  
in the Chapter “PPF Editors” 

Name input

name for the plot frame.

Model input available model

the model for the plot frame.

Colour input available colours

the colour for the plot frame.

Scale 1: input

scale for the plot.

Sheet size wd ht (mm) input

the width and height values (separated by spaces) or the name of a user defined sheet size.
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Rotation angle input 0

angle of rotation for the plot frame.

Origin input xyz ops menu

x_origin    y_origin    z_origin   
origin (in world units) for the corner of the plot frame - given as three values separated by spaces. The 
values can either be typed in, or selected by clicking LB in the origin panel view and getting up the xyz 
ops menu and selecting the pick xyz option.

Draw viewport border tick-cross tick

if tick, plot the box around the plotting area (viewport).

Pick button

select the plot frame to be edited.

Set button

update the plot frame with the information in the above panel fields.

Translate button

after picking the Translate button, the plot frame will move with the cursor until a point is selected to 
give the final position of the plot frame.

Rotate button

after picking the Rotate button, the plot frame is further rotated around the left hand corner of the 
sheet, by the angle made between the rotation point and the current cursor position.The plot frame will 
continue to rotate until a point is selected to fix the rotation angle.

Margin tab

Left/right margin (mm) 10.0

the left/right hand side margin between the sheet and the plotting area inside the sheet.

Bottom/top margin (mm) 10.0

the bottom/top margin between the sheet and the plotting area inside the sheet.
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Change
plot_frame_change

Position of option on menu: Plot =>Plot frames =>Change

The change option is used to modify a plot frame’s name, model or colour.

On selecting the change option, the plot frame change panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

New name input

if non-blank, then the name of the selected plot frame will be changed to the name given in the new 
name field.

New model input available model

if non-blank, then the selected plot frame will be moved to the model given in the new model field.

New colour input available colours

if non-blank, then the colour of the selected plot frame will be changed to the colour given in the new 
colour field.

Pick button

select the plot frame to be changed.

Change button

update the plot frame with the information in the above panel fields.

Copy
plot_frame_copy

Position of option on menu: Plot =>Plot frames =>Copy

The copy option is used to make a copy of a plot frame.

On selecting the copy option, the plot frame copy panel is displayed.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Model for frame input available models

if blank, then the model of the copied plot frame will be the same as that of the picked frame.
if non-blank, then the copied plot frame will be placed in the model given in the model for frame field.

dx dy input xyz ops menu

dx_val     dy _val
translation in world units to apply to the copied plot frame - given as two values separated by spaces.

Pick button

select the plot frame to be copied - the copy will be made as soon as the selected plot frame is accepted.

Rotate
plot_frame_rotate

Position of option on menu: Plot =>Plot frames =>Rotate

The rotate option is used to rotate a plot frame about a selected point.

On selecting the rotate option, the plot frame rotate panel is displayed.

The buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Rotate button

after picking the rotate button, the user is first asked to select a plot frame to rotate, and then to selected 
a point to rotate about. Once the rotation point has been selected, the plot frame is further rotated by the 
angle made between the rotation point and the current cursor position.The plot frame will continue to 
rotate until a point is selected to fix the rotation angle.
The option then repeats.

Translate
plot_frame_translate

Position of option on menu: Plot =>Plot frames =>Translate

The translate option is used to translate a plot frame.

On selecting the translate option, the plot frame translate panel is displayed.
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The button used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Move button

after picking the move button, the user is first asked to select a plot frame to translate. Once the plot 
frame has been selected, the plot frame will move with the cursor until a point is selected to give the 
final position of the plot frame.
The option then repeats.

Delete
Position of option on menu: Plot =>Plot frames =>Delete

The delete option just gets up the standard string delete panel which can be used to delete plot 
frames as well as strings.

See “Delete”  in the chapter “Strings” 

More Plot Frames
more_plot_frames

Position of menu: Plot =>Plot frames =>More

This menu contains options to create plot frame seeds, insert plot frame seeds into a view and 
create plot frames along a string.

The more plot frames walk-right menu is

Each option in this menu will now be described.

For the option Plot frames along string,go to the section “Create Plot Frames along String” 
Plot frame insert  “Insert Plot Frame Seed” 
Plot frame seed create “Create Plot Frame Seed” 

insert a plot frame seed
create plot frames along a string
create a plot frame seed
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Create Plot Frames along String
plot_frames_panel
Position of option on menu: Plot =>Plot frames =>More =>Plot frames along string

On selecting the plot frames along string option, the create plot frames along string panel is 
displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

String string select

string to create plot frame along.

Seed plot frame plot frame select

plot frame to create along the selected string.

Overlap chainage distance input 0

if non-zero, the next plot frame is started so that it includes this chainage distance of the selected string 
from previous plot frame.

Start/End chainage input 0

start/end chainage to restrict the amount of the selected string to place plot frames along.

Chainage increment input

if non-blank, the start of the next plot frame is placed this chainage distance along the string from the 
start of the previous plot frame. Used when you want to match the plot frames with the chainage 
interval on a long section plot.
If blank, the next plot frame is placed at the chainage point at the end of the previous plot frame (minus 
the overlap chainage distance).

Model for frames model box available models

model to place the created plot frames in.

Process button

create the plots frames along the selected string.

Undo button

undo the last set of plot frames created whilst this panel is up.
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Insert Plot Frame Seed
4d_pframe_panel
Position of option on menu: Plot =>Plot frames =>More =>Plot frame insert

On selecting the insert plot frame seed option, the plot frame insert panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Plot frame to insert plot frame seeds

plot frame from the seed library to insert.

Location xyz box xyz ops menu

the bottom left hand corner of the plot frame in inserted at this location.

Scale radio buttons 1: 250 1: 250, 1: 500, 1:1000, User

scale to use for the inserted plot frame.

User scale 1: tick box

if User is selected for Scale, then the required scale is entered here.

Plotter frame <0,0> tick box

if tick, the bottom left hand corner of the plot frame is placed at (0,0).

View to add view box available views

if non-blank, add to plot frame to this view.

Process button

insert the selected seed plot frame at the given location at the given scale.

How To Use the Option

The selected plot frame is inserted at the given location with the given scale.
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Create Plot Frame Seed
pframe_seed_panel
Position of option on menu: Plot =>Plot frames =>More =>Plot frame seed create

On selecting the plot frame seed create option, the plot frame seed create panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick string select

pick the plot frame to add to the plot frame seed library.

Add button available model

add the selected plot frame to the plot frame seed library.

How To Use the Option

The plot frame contains all the information required to define the physical area in real world 
units to be plotted, the position on the sheet of the area being plotted, the plotter type and the 
plot file name.

The create plot frame seed panel adds selected plot frames to a library of plot frame seeds.

The seeds from the library can be inserted in a plan view using the insert plot frame seed option.
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Plotting Setups
ppf_editors

Position of menu: Plot =>Plot and PPF editors

The Plot and PPF editor walk-right menu is

For the option Create/edit title block file, go to “Create/Edit Title Block File” 
Read title block file “Create/Edit Title Block File” 

Pen mapping  “Pen Mapping” 
Plotter mapping editor  “Plotter Mapping Editor” 
Plotter mapping  “Plotter Mapping” 
Pixels to mm “Pixels to mm” 
Hardware arcs “Hardware Arcs” 

ACAD plot map file “ACAD Plot Map File” 
Interface colours “Interface Colours” 
DGN plot seed file “DGN Plot Seed File” 
DWT plot template file “DWT Plot Template File” 

create/edit a title block file
read in a title block file

map colours to pens
create/edit plotter mapping file
set extended pen mapping
pixel size to mm on plots
use hardware arcs

create/edit AutoCAD map file
change cut/fill colours
seed file for writing .dgn
default DPI for raster plots
template file for writing .dwt
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Create/Edit Title Block File
create_edit_title_block_file

Position of option on menu: Plot =>Plotting setups =>Create/edit title block file

This option is used to create a title block file from string data in a model.

The data in the model should be set up with (0,0) representing the left hand bottom of the 
plotting sheet and the units in model represent millimetres on the paper.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data Model model box available models

model used to create a title block file.

Plot frame parameters

these parameters are written as attributes in the Data Model and are used as defaults for fields in the 
option Plots=>Plot frames=>Create

Name

name to use for the plot frame.

Model model box available models

model for the plot frame.
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Colour colour box available colours

colour for the plot frame.

Scale 1: input

scale for the plot frame

Sheet size input available sheet sizes

sheet size for the plot frame

Angle angle box

angle of the plot frame - measured anticlockwise from the positive x-axis

Left margin, Right margin, Top margin, Bottom margin

margins for the plot frame

Draw viewport border tick box tick

if tick, a border is drawn around the view port in the colour of the plot frame.

Title block file file box *.tbf files

name of the file to be created which defines a title block.

Set button

save the plot frame parameters as attributes in the data model.

Write button

run the option – create the title block file.
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Read Title Block
read_title_block_file

Position of option on menu: Plot =>Plotting setups =>Read title block file

The read title block file option is for reading in a title block file and placing the lines, arcs and 
text defined in the title block file into a given model.

On selecting the Read title block file option, the Read Title Block File panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Format choice box tbf, tf

specify if the format of the file is the V7 title block file (.tbf) or the older format (.tf).

Title block file name file box

name of title block file to read in.

Model for title block model box available models

model to place the title block in when it is read. The plot frame parameters are set as attributes for the 
model.

Read button

read in the title block file and place the information in the given model.
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Pen Mapping
This option brings up the Edit Colours panel.

For more information on this option, go to the section “Colours” in the Chapter “Tools and 
Concepts” 
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Plotter Mapping Editor
create_plotter_mapping_file

Position of option on menu: Plot =>Plotter mapping editor

The plotter mapping editor is used to create a plotter mapping file which is used when making a 
plot from 12d Model. The plotter mapping file defines:

(a) the mapping from 12d Model colours to the plotter pens and weights of the plotter pen

(b) the colours for the plotter pens

Different plotter mapping files are used for different plotter configurations.

For example, different plotter mapping files would be used when plotting the same plot in 12d 
Model to a mono-colour plotter or to a colour plotter.

For plotting to a mono-colour plotter, 12d Model colours would be mapped to the one black pen 
but with possible different weights for different colours. So only one pen colour would be 
needed and its colour would be set to black (Red 0, Green 0 and Blue 0).

For plotting to a colour plotter, 12d Model colours could be mapped to different colours and 
weights on the plotter.

The text definition of the plotter mapping file is given in the next section “Plotter Mapping” .

On selecting the plotter mapping editor option, the create plotter mapping file panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Map file file box     *.pmf file

the plotter mapping file to be created/edited.

Read button
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read in the plotter mapping file given in Map file

Write button

write out to plotter mapping information in the panel to the file given in Map file.

Default tab

Red/Green/Blue input

the value between 0 and 255 of red/green/blue to be used for the default pen colour.

Weight input

the default pen weight.

12d Colour mapping tab

12d Colour colour box

the 12d colour to define the pen mapping for.

Use Pen Number integer box

the number of the pen on the plotter for the 12d colour to be mapped to.

Weight real number box

the weight to use for the plotter pen for the given 12d colour.

Define Pen Colours tab

Pen Number integer box

the number of the plotter pen to define the colour for.

Red/Green/Blue input

the value between 0 and 255 of red/green/blue to be used for the colour of the plotter pen.
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Plotter Mapping
plotter_mapping_table

Position of option on menu: Plot =>Plotter mapping

The plotter mapping file can be used use with pen plotters but is more specifically designed for 
electostatic and inject plotters and allows the user to

(a) map the full 10,240 12d Model colours to particular plotter pens and also specify a width (or 
weight) to be used forPCL5, HPGL2 and postscript plotters.

(b) specify the red, green and blue mix for pens on HPGL2 and colour postscript plotters

There are also two special formats of the plotter mapping file which are used for plotting to 
Autocad dxf/dwg and Intergraph dgn. The special mapping files use the 12d Model colour as a 
key to tables which control how the information is passed to DXF/DWG and DGN.

(c) .tbl file used with plotting to Intergraph dgn

(d) .amf used with plotting to Autocad dxf and dwg 

The .tbl and .amf files are documented in the “Definition and Example of a .tbl File”  and 
“Definition and Example of a .amf File” sections in the Appendix “Plotters and Plotting” .

On selecting the plotter mapping option, the plotter mapping table panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mapping file input     *.pmf file

the plotter mapping file to be used when plotting. If no plotter mapping file is given, the pen mapping 
table is used.

Default colour input available colours

the rgb of this colour is used as the rgb for the default pen colour.

Default weight input

if not blank, the default pen weight.

Merge colour_map.def tick-cross tick

If tick, the rgb columns from the colour_map.def file are used to define the pen_colours (first row is pen 
0, second row is pen 1 etc.), and the pen mapping number is used to construct the pen_mapping table.

Set button

set the information in the panel
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Plotter Mapping File
The plotter mapping file (.pmf) consists of two sections and two default values:

(a) the pen_mapping table which defines the plotter pens that the 12d Model colours are 
mapped to, and the weights for each "12d Model colour to plotter pen" mapping.

The pen_mapping table consists of the key word pen_mapping followed by the mapping for 
each 12d Model colour to the appropriate plotter pen number and pen weight (one per line), 
all enclosed in curly braces ({ }).

pen_mapping   { // pen mapping and weight table

//12d Model colour number plotter pen number pen weight

0 1 0.15
1 2 0.25
3 1 0.5

// etc.
}

(b) the pen_colours table which defines the red, green and blue values to be used for the pens 
on the plotter.

The pen_colours table consists of the key word pen_colours followed by the red, green and 
blue values for the plotter pens (one per line), all enclosed in curly braces ({ }).

pen_colours { // pen colours table
//pen red green blue          values 0-255
      0 0 0 0                // pen 0 is black
      1 255 0 0               // pen 1 is red
// etc.
}

(c) the default_weight command that goes at the top of the file (not inside the pen_mapping or 
pen_colours table) which is used as the weight for any 12d Model colour used in the plot but 
not mapped and given a weight in the pen_mapping table.

default_weight weight

(d) the default_colour command that also goes at the top of the file (not inside the pen_mapping 
or pen_colours table) which defines the default red, green and blue for any pens used but not 
set in the pen_colours table. 

default_colour red green blue

Initialization of the plotter mapping file

When using the plotter mapping table panel:
When used with the plotter mapping table panel, the pen_mapping and pen_colours tables are 
initialised before the plotter mapping file is used. This is to ensure that any colours and/or pens 
not mentioned in the file but used in a plot, do have valid definitions.

Hence the initialisation sequence for the plotter mapping file used with the plotter mapping table 
panel is:

Before the plotter mapping file is used, a default pen_mapping table for colours 0 to 255 is set up 
by:

colour n    goes to   pen n    with the default weight from the plotter mapping table panel.

Before the plotter mapping file is used, a default pen_colours table for pens 0 to 255 is set up by:

pen n  is given the red, green and blue of the default colour from the plotter mapping table panel.
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If the merge colours.4d flag is set in the plotter mapping table panel, the rgb columns from the 
colours.4d file are used to define the pen_colours (first row is pen 0, second row is pen 1 etc.), 
and the pen mapping number is used to construct the pen_mapping table.

The plotter mapping file is then processed and over writes any of the above initial mapping 
values.

When using user defined plotters:
A plotter mapping file can be set for a user defined plotter in the file plotters.4d.

In this case, the plotter mapping table panel is not used and hence the initialisation sequence is 
slightly different. 

When used with the plotter mapping table panel, the pen_mapping and pen_colours tables are 
initialised before the plotter mapping file is used. This is to ensure that any colours and/or pens 
not mentioned in the file but used in a plot, do have valid definitions.

For a user defined plotter, the initialisation sequence for the plotter mapping file is:

Before the plotter mapping file is used, a default pen_mapping table for colours 0 to 255 is set up 
by:

colour n    goes to   pen n    with the default weight default_weight from the specified plotter 
mapping file, or zero if the default_weight does not exist.

Before the plotter mapping file is used, a default pen_colours table for pens 0 to 255 is set up by:

pen n  is given the red, green and blue of the default colour default_colour from the specified 
plotter mapping file, or rgb 0 0 0 if the default_colour does not exist 

The plotter mapping file is then processed and over writes any of the above initial mapping 
values.

An Example of a Plotter Mapping File
An example of a plotter mapping file (.pmf) is:

default_colour 100 0 100
default_weight 0.1

pen_mapping { // pen mapping and weight table

// colour pen weight

0 1 0.15 // map colour 0 to pen 1 with weight 0.15
1 2 0.25 // map colour 1 to pen 2 with weight 0.25 
3 1 0.5 // map colour 3 to pen 1 with weight 0.5

}
pen_colours { // pen colours table

//pen red green blue          values 0-255
      0 0 0 0                // pen 0 is black
      1 255 0 0               // pen 1 is red
      3 0 255 0               // pen 3 is green
}
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Pixels to mm
pixels_to_millimetres_plot_factor

Position of option on menu: Plot =>Pixels to mm

To plot an object, it must be possible to calculate the size in millimetres that the object will have 
in the plot. 

However, in 12d Model it is possible for text and linestyles to be defined in the screen unit pixels, 
and since the size of a pixel varies between screens, there is no direct millimetre equivalent for a 
pixel.

To allow text and linestyles with only a pixel size to be plotted, a factor to convert pixels to 
millimetres is used.

When plotting, all text and linestyles defined only in pixel units is multiplied by the pixels-to-
millimetre factor to determine its size in the plot.

On selecting the pixel to mm option, the pixels to millimetres plot factor panel is displayed.

To define a new factor, simply type the value into the factor field and select set.

The pixel-to-millimetres value is stored for the project.

For a new project, the initial value is loaded from the defaults file and is defined in the file by

PIXELS TO MM PLOT FACTOR value

Hardware Arcs
draw_hardware_arcs

Position of option on menu: Plot =>Hardware arcs

When plotting arcs, the arc can either be broken into a series of straight lines within 12d Model, 
or plotted using the arc command (if it exists) for the relevant plotter.

This option allows the user to choose whether 

(a) the plotter arc command is used (hardware arcs)

or 

(b) before plotting, the arc is broken into a series of lines.

On selecting the hardware arcs option, the draw hardware arcs panel is displayed.
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To use hardware arcs in plots, simply change the draw arcs in hardware tick-cross box to tick and 
select set.

ACAD Plot Map File
autocad_plot_map_file_create_edit

Position of option on menu: Plot =>Plotting setups =>ACAD plot map file

When plotting to AutoCAD, an Autocad map file can be used which uses the 12d Model colour 
of an entity in the plot as a key to mapping the entity into AutoCAD.

On selecting the ACAD plot map file option, the AutoCAD Map File Create/Edit panel is displayed.

Interface Colours
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plotting_colours_for_interface_strings

Position of option on menu: Plot =>Interface colours

When drawing interface strings in 12d Model, cut areas are denoted in red, fill areas in green and 
sections on the surface in yellow.

However, when plotting it is convenient to be able to map the interface colours to other colours.

This panel is used to define new colours for the interface colours, and the new colours are then 
mapped to pens using the pen mapping table or plotter mapping file.

On selecting the interface colours option, the plotting colours for interface string panel is 
displayed.

To define new colours, simply type the values into the appropriate panel fields and select set.

Note - the new interface colours are not used for displaying interface strings in 12d Model, only 
for plotting.

DGN Plot Seed File
dgn_plot_seed_file

Position of option on menu: Plot =>DGN plot seed file

When creating plot files in Intergraph DGN format, an Intergraph DGN seed file can be used.

On selecting the DGN plot seed file option, the DGN plot seed file panel is displayed.

To define an Intergraph IGDS plot seed file to use for Intergraph plotting, simply type the file 
name into the plot seed file panel field and select set.

Default DPI
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default_raster_dpi

Position of option on menu: Plot =>Default DPI

This defines the default DPI (dots per inch) when plotting rasters.

On selecting Default DPI, the Default Raster DPI panel is displayed.

The DPI value give the default dots per inch that is used for plotting rasters.

DWT Plot Template File
autocad_plotter_drawing_template_file

Position of option on menu: Plot =>DWG plot template file

When creating plot files in AutoCAD format, an AutoCAD template file can be used.

On selecting the DWT plot template file option, the AutoCAD Plotter Drawing Template File panel is 
displayed.

To define an AutoCAD plot seed file to use for AutoCAD plotting, simply select either DWG or 
DXF for the File format, type the file name into the plot seed file panel field and select set.



Chapter 23  Plots

January 2005 Page 2365Old Plotting

Old Plotting
old_plotting

Position of menu: Plot =>Plot =>Old plotting

The Old plotting walk-right menu is

For the option Edit a ppf, go to “Edit a ppf” 
 Plot a ppf  “Plot a ppf” 
X plot “X Plot” 
Long plot “Long Plot” 
Long section plot many “Plot Many Long Sections” 
Drainage/sewer “Drainage Longsections” in chapter “Drainage and Sewer” 
Melbourne Water “Melbourne Water” in chapter “Drainage and Sewer” .
Pipeline  “Plots” in chapter “Pipeline” .

Edit title block alias data “Title Block Data Editor” 
Create plot frame “Create Old Plot Frame” 
Edit plot frame “Editor Old Pot Frame” 
Plot plot frames “Plotting Old Plot Frames” 

Edit a ppf
directory___ppf

edit_a_file___ppf

Position of option on menu: Plot =>Old plotting =>Edit a ppf

The edit a ppf option is used to edit V5 ascii plot parameter files (*.ppf) with the editor pointed to 
by the EDITOR_4D environment variable.

The edit a ppf walk-right menu provides a list all the plot parameter files (files ending in .ppf) in 
the current folder.

When a file is selected from the list, it is loaded into the editor pointer to by the environment 
variable EDITOR_4D.

Plot a ppf

edit a V5ascii ppf
plot a V5 ascii ppf
V5 x-section plotting
V5 long section plotting
V5 plotting many long section plotting
V5 drainage long section plot
V5 Melb water sewer long section plot
V5 pipeline long section plot

Edit title block alias data for V5 ppfs

create a V5 plot frame
edit a V5 plot frame
plot a V5 plot frame
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directory___ppf

Position of option on menu: Plot =>Old plotting =>Plot a ppf

The V5 ascii ppf’s for long section, cross section and plot frames can have enough information in 
them to totally generate the plot from the ppf. The plot a ppf option is used to plot such a plot 
parameter file (*.ppf).

The plot a ppf walk-right menu provides a list all the plot parameter files (files ending in .ppf) in 
the current folder.

When a file is selected from the list, it is then used to generate a plot.

Note - the plot parameter file is defined in the chapter Advanced Plotting.

X Plot
cross_section_plot section_x_plot_title

Position of option on menu: Plot =>Old plotting =>X plot

The x plot option is used to make the traditional pages of cross-section plots, that is, stacked x-
sections, with offsets and elevations labelled for each cross section string, and elevations 
displayed for each of the tins on the section view.

For 12d Model V5, each string to be plotted is assumed to be on a straight line in plan. Hence the 
cross section is taken as a straight line from the first point of the string to the last point of the 
string. The chainage of the first point of the string is used as the offset.

For 12d Model V6 and above, sections do not have to be a straight line in plan. The chainage of 
the first point of the string is used as the offset.

The format of the x-section plot is partially controlled by fields in the Section X Plot panel but 
more extensive control is possible using a plot parameter file (*.ppf). The plot parameter file is 
fully documented in the “Cross Section Plot Parameter File” section of the Appendix, “Plot 
Parameters” .

The cross section plot is tailored by using the plot parameter file (.ppf file) given in the 
plot parameters field. A default .ppf file is set by pointing to it with the environment variable

X_SECTION_PPF_4D pathname of default .ppf file 

In the pathname to the default .ppf file, $LIB is used to stand for the library folder set by LIB_4D. 
For example, "$LIB/cross.ppf" is the file cross.ppf in the library area.

Which x-sections are to be plotted is specified by giving the model containing the appropriate 
cross sections. Sections are also drawn through any triangulations and service items on the 
section view. Vertical exaggeration, services and corridor settings are taken from a plot 
parameter file or from the settings for the section view.

X-sections can be labelled with either the offset from the centreline and heights for each of the x-
section points, or simply the position of the centre-line.

The required page size is given, plus the scale (the vertical exaggeration is taken from the view 
settings) and the sections are then plotted in columns on the plotter page. Once a page is full, a 
new plot page is automatically begun.

The stacked x-section plots in each column can be lined up by their centre-lines.

After selecting the x plot option, the section x plot panel is displayed.

The title button on the bottom of this panel controls the use of a title block file and the plotting of 
a border and two lines of title. If the title button is selected, the section x plot title panel is 
displayed.
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The fields and buttons used in the first panel have the following functions.

Field Description Type Defaults Pop-Up

Plot parameters input X_SECTION_PPF.4D*.ppf

file of plot parameters used for extra control of the x section plot. The default .ppf file is pointed to by 
the environment variable X_SECTION_PPF_4D.

For more information on the x section plot parameters, please go to the section “Cross Section Plot 
Parameter File” in the Appendix “Plot Parameters” 

Plot parameters write input *.ppf

file to write a copy of the plot parameters necessary to regenerate the plot.

Section view input/output current view available views

section view to use for plot definitions such as the tins to profile, the models of services, corridor width 
and vertical exaggeration.

Model of X-sections input available models

the model containing all the x-sections to be plotted. The x-sections are plotted in the same order as 
they are in the model.

Each string to be plotted is assumed to be on a straight line in plan. Hence the cross section is taken as 
a straight line from the first point of the string to the last point of the string. The chainage of the first 
point of the string is used as the offset.

Plotter type input hp hp, dxf, postscript etc.
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file format for the plot output.

Plot file stem input

since more that one plot page may be produced, the plot file stem plus a plot page sequence number 
followed by the ending for the plotter type is used as the plot file names.

Start/end chainage input

the plots cover the chainage range for the cross sections given by the start and end chainage fields. If the 
start/end chainage is blank, the star/end chainage of the x-section strings are used.

Sheet size wd ht (mm) input available sheet sizes

must contain the width and height values (separated by space) or the name of a user defined sheet size.

Scale 1: input

horizontal scale for plotting the x-sections.

Label type input boxes boxes, centreline

if boxes, the offset from the centreline and heights for each point in the x-section will be plotted in the 
traditional offset/height boxes.
if centre line, only the position of the centre-line and the height of the section at that point will be 
drawn.

Text style (mm) input 1

text style to be used in the x section plot boxes or centreline labelling.

Text ht (mm) input 3

height (in millimetres) to plot the offset and heights in the boxes in the plots of the x-sections

Offset colour input red available colours

colour used for the offset text and the boxes.

Primary string tick-cross tick

if tick, the string from the model of x-sections (the primary string) is plotted.

Sort sections tick-cross tick

if tick, the strings from the model of x-sections are sorted by chainage along the design string.

Absolute extensions tick-cross

If tick, the sections are only drawn from the centreline out to the left and right extension distances.
if no tick, the left and right extension values are added to the section left and right widths, and the 
section is taken between the extended values

Line up CL’s tick-cross tick

if tick, the centre-lines are lined up under each other for each plot in a column.

LHS extension input 0

distance to extend the x-section to the left.

RHS extension input 0

distance to extend the x-section to the right.

Title button

bring up the panel for defining information in the title block.

Plot button

write out the plots for the x-sections given in the model of x-sections field.

The fields and buttons in title tab are:

Use title file tick-cross

if tick, a user defined title block file is used.
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Standard Title tick-cross tick

if tick, the standard 4D Solutions border and two lines of title are placed on the bottom of the plot

Title file input *.tf

if non-blank and use title file is set to tick, then the file given in this field is used to generate a user 
defined title block for the plot.

Title line 1/2 input

first/second line of title information

Title height (mm) input 5

height (in millimetres) to draw the characters in the two lines of title information.

Title colour input cyan available colours

colour used for the border and the title information.

Long Plot
long_section_plot

section_long_plot_title

section_long_plot_title

section_long_plot_pagination

Position of option on menu: Plot =>Old plotting =>Long plot

The long plot option is used to make traditional long section plots with string chainages and 
elevations labelled for the primary string and elevations and depths displayed for each of the 
tins on the section view.

The format of the long section plot is partially controlled by fields in the section long plot panel 
but more extensive control is possible using a plot parameter file (*.ppf). The plot parameter file 
is fully documented in the “Long Section Plot Parameter File” section of the chapter, “Plot 
Parameters” .

After selecting the long plot, the section long plot panels respectively, is displayed.

The long section plot is tailored by using the plot parameter file (.ppf file) given in the 
plot parameters field. A default .ppf file is set by pointing to it with the environment variable

LONG_SECTION_PPF_4D pathname of default .ppf file 

In the pathname to the default .ppf file, $LIB is used to stand for the library folder set by LIB_4D. 
For example, "$LIB/long.ppf" is the file long.ppf in the library area.

The title button on the bottom of this panel controls the use of a title block file and the plotting of 
a border and two lines of title. If the title button is selected, the section long plot title panel is 
displayed.

The pagination button on the bottom of this panel controls whether the long section plot is 
broken into pages, by a chainage length or millimetres of plot.

If the pagination button is selected, the section long plot pagination panel is displayed.
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The fields and buttons used in the two panels have the following functions.

Field Description Type Defaults Pop-Up

Plot parameters input LONG_SECTION_PPF_4D*.ppf

file of plot parameters used for extra control of the long section plot. The default .ppf file is pointed to by 
the environment variable LONG_SECTION_PPF_4D.
For more information on the long section plot parameters, please go to the section “Long Section Plot 
Parameter File” in the Appendix “Plot Parameters” 

Plot parameters write input *.ppf

file to write a copy of the plot parameters necessary to regenerate the plot.

Section view input/output current view available section views

section view to use for plot definitions such as the tins to profile, the models of services, corridor width 
and vertical exaggeration.
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Plotter type input hp hp, dxf, postscript etc.

file format for the plot information.

Plot file input *.hp etc.

name of the file to write out the long section plot to.

Start/end chainage input

the plot covers the chainage range given by the start and end chainage fields. If the start/end chainage is 
blank, the star/end chainage of the primary string is used.

Chainage increment input 100

chainage increment to label the long plot with chainage and height values.

Sheet size wd ht (mm) input available sheet sizes

The width and height values (separated by space) or the name of a user defined sheet size.

Scale 1: input

horizontal scale for the plot. The vertical scale is taken from the ppf or the section view.

Plot primary string tick box tick

if tick, the primary string is plotted along with any horizontal geometry displayed in the section view.

Use HG VG for min, max tick box tick

if tick, the chainage range available for plotting is from the minimum of the horizontal geometry (HG) 
and the vertical geometry (VG) to the maximum of the HG and VG. Useful for kerb returns.
If no tick, the chainage range available for plotting is from the minimum of the horizontal geometry 
(HG) to the maximum of the HG.

Label depths tick box tick

if tick, label in boxes at the bottom of the plot, the distance between the primary string and the tins.

Text style input 1

text style to be used in the long section plot boxes.

Box text ht (mm) input 3

height (in millimetres) to plot the chainage and elevations in the boxes in the long section plot.

Box colour input cyan available colours

colour used for the chainage text and the boxes.

Datum value input

if non-blank, the value to be used as a datum. If blank, then a suitable datum value will be calculated.

Offset model input available models

if non-blank, then all the strings in the offset model will be projected onto the primary string and 
drawn and labelled on the long section plot.

Pagination button

button to bring up the section long plot pagination panel.

Title button

button to bring up the section long plot title panel.

Plot button

write out the plot for the long section plot between the chainages given in the start and end chainage 
fields. The format of the file is given by the plotter type

The fields and buttons in title tab are:



12d Model Reference Manual

Page 2372 January 2005Old Plotting

Use title file tick-cross

if tick, a use supplied title block file is used.

Standard Title tick-cross tick

if tick, the standard 4D Solutions border and two lines of title are placed on the bottom of the plot

Title file input *.tf

if non-blank and use title file is set to tick, then the file given in this field is used to generate a user 
defined title block for the plot.

Title line 1/2 input

first/second line of title information

Title height (mm) input 5

height (in millimetres) to draw the characters in the two lines of title information.

Title colour input cyan available colours

colour used for the border and the title information.

The fields and buttons in pagination tab are 

Pagination tick-cross tick

if tick, the long section plot is broken into separate plots of length given in the length field, from the 
start chainage to the end chainage. If the overlap field is non-zero, then each page of the long section 
plot also includes the overlap value of the end of the previous page of plot.

The units for length and overlap can be either chainage distance or millimetres on the plot page.

Hence apart from the first page and possibly the last page, the plot will have a total length given by the 
sum of the length and the overlap panel fields.

Pagination mode input chainage chainage, millimetres

the units for length and overlap can be either chainage distance or millimetres on the plot page.

If pagination mode is set to chainage, the units are chainage distance.
If pagination mode is set to millimetres, the units are millimetres on the plot.

Length input 600

if pagination is set to tick, the length of new plot to be included in the current plot.

Overlap input 25

if pagination is set to tick, the length of the previous plot page to be included in the current plot.

Plot Many Long Sections
section_long_plot_many

Position of option on menu: Plot =>Old plotting =>Longsection plot many

The Long section plot many option is used to plot individual long section plots for each string 
selected by the Data source.

On selecting the Long section plot many option, the Section Long Plot Many panel is displayed.
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The fields and buttons used in this panel have the following functions.

Field DescriptionType Defaults Pop-Up

Data to plot - Data source type

data source type.

Data source

when the plot button is selected, long section plots are created for all the strings selected by the data 
source.

Plot parameters input *.ppf files

file of plot parameters to be used for the long section plots.

Section view input available views

name of the section view for defining information for the long section plots. For example, tins to plot.

Plotter type input hp available plotters

type of plotter to plot to.

Plotter file input

stem of the name to use for the long section plots.

Plot button

when the Plot buttons is selected, individual long section plots will be created for all the strings 
selected in the data source field.

Drainage/Sewer Plot
Position of option on menu: Plot =>Old plotting =>Drainage/Sewer

The Drainage/sewer plot option is for creating drainage and/or sewer long-section plots.

 The option has already been described under Design=>Drainage-sewer =>Plots.

See “Drainage Longsections” in chapter “Drainage and Sewer” 

Melbourne Water Sewer Plot
Position of option on menu: Plot =>Old plotting =>Melbourne Water
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The Melbourne Water sewer plot option is for creating sewer long-section plots to Melbourne 
Water specifications.

 The option has already been described under Design =>Drainage-sewer =>Plots.

See “Melbourne Water” in chapter “Drainage and Sewer” 

Pipeline Plot
Position of option on menu: Plot =>Old plotting =>Pipeline

The Pipeline plot option is for creating pipeline long-section plots.

 The option has already been described under Design =>Pipeline =>Plots.

See “Plots” in chapter “Pipeline” 

Title Block Data Editor
title_file_alias_panel

Position of option on menu: Plot =>Old Plotting =>Edit title block data

NO LONGER USED IN V7

This panel is used to easily change to data in your drawing title blocks (set values for the 
user_text_n field in a title file).

The Title block ppf is the ppf that is created by the panel. You may want to create a title block ppf 
for every drawing you create. This way you can easily re-plot a drawing with the same title block 
data. This is the ppf name that you will use in the future plot panels when you are ready to plot 
using the title block. 

The Base ppf field is an existing ppf that includes all of your default plot parameters for creating 
your drawing. It must reference a title file.

12d marks the location of your title block data using the variables user_text_1, user_text_2 etc. 
Since it is difficult to remember what user_text_1 represents in the title block, 12d allows you to 
use a meaningful name reference (Main title for example) instead of user_text_1. The Alias button 
allows you to set these alias names for the title file referenced in your base ppf.

The Advanced button is only used if the same text data is to be used in another Title Block ppf 
(share the data between drawing).

The Set button creates/updates the title block ppf and the title file values that you entered.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Title block ppf

this is the ppf that is created by the panel. This is the ppf name that you will use in the future 
plot panels when you are ready to plot using the title block. The Title Block ppf is usually 
stored locally (in the current folder).

Base ppf

this ppf must exist (often in library or your user library). It will contain all of your default plot 
parameters for creating your drawing. It must reference a title file (see notes below).When 
you press enter, the ppf file is read to find the name of the title file you reference. Once the 
title file is found, the alias names are read from the title alias file if available.

To convert an existing ppf file into a Base ppf file use a text editor to delete all references to 
user_text_n variables in the file. 

Current page choice box available pages

if more than one page of data (10 fields) are required additional pages will be listed here.

Value input box

the data to be shown into your drawing title block is entered here. The description to the left 
is either $user_text_n (Note that there may be gaps in the numbering sequence) or an alias that 
has been set up using the alias button below.

Alias button

if the fields have the names $user_text_1, $user_text_2 etc. use the button to change the names 
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to a more meaningful description. These new names will be stored in the same folder as the 
with the title file specified in your base ppf file (the extension als will be added). The follow-
ing panel will be displayed.

Note that there may be gap in the $user_text_n sequence. Only the variable used in the title 
file will be listed.

Advanced button

this feature allows you to share text data between different title block ppf files. The actual text 
data in stored in a title file txt (*.tft) file. Selecting the button will bring up the following panel 
and allow you to change the *.tft file to be used. Generally you will select a *.tft file previously 
set up for another title block file.

Select the Set button to set your select. The text data will be read and the main panel updated 
when you select the Finish button.

Set button

creates/updates the Title block ppf file and *.tft file.

Notes:

Short-cuts:
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*.als and *.tft files can be copies, renamed and then edited using the Title Block Edit Panel or 
your own text editor.

Alias files (*.als) are kept in the same folder as the your title files. Once you have one alias file set 
up copy the alias file and rename the copy the same name as the title file but add the additional 
extension .als. For example:

title file 4d_drainage_long_section_a1.tf
alias file 4d_drainage_long_section_a1.tf.als

CAUTION: The user_text_n variables should represent the same data in both title files. For 
example user_text_1 should be the main title in both files.

Title file text files (*.tft see advanced) files are kept in the same folder as the your Title block ppf. 
If you choose not to share a tft between Title block ppf files you can simply copy and rename 
them. Once you have saved one *.tft file, copy the file and rename the copy the same name as the 
title block pp file but add the additional extension .tft

Title Block ppf file drawing 1.ppf
title file text filedrawing 1.ppf.tft

Title Block ppf 

The title block ppf file does not contain any data itself. Rather it references a *.tft file containing 
the text data and your base ppf file (file containing all of your default plot parameters). An exam-
ple ppf file follows:

The Title Block ppf file is a ppf file with the Base ppf and user text values (in the tft file) refer-
enced by #include statements.

#define ALIAS 1

section_long_plot "plot 2" {

// TITLE BLOCK PPF FILE

#include "Base_ljg.ppf"

#include "Title_block.ppf.tft"

}

Base ppf 

The Base ppf can be anywhere including local, Library and User Library. It must contain a refer-
ence to a title file in the use_title_file parameter. The user_title_file parameter must be in the file 
and can’t be in an #include file. 

The following is an example title file reference.

use_title_file yes
title_file "your title file.tf "

Note: If you already have user_text variables defined in your Base ppf these values will not be 
used and a warning message will be issued at plot time. It is best to remove all user_text varia-
bles from your existing ppfs before attempting to use them with this new 4d facility.

The panel scans the title file reference and records all of the user_text_n entries that are used. 
Only those used are displayed in the panel. Next a file with the ( is located. If found the alias 
values are used in the panel instead of $user_text_1, $user_text_2 etc.

If an alias file (same name as the title file PLUS the extension .als) has been previously created 
using the Alias button, the aliases for the user_text’s are used on the left hand side of the panel. If 
an alias file has not been found, they can be created by simply selecting the Alias button.
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The Base ppf is also checked to see if a 

#ifndef ALIAS 

and 

#endif 

exist around the opening "xxxxxxxx {" and closing "}" braces. If not, a Base PPF file update panel 
is displayed.

Select Automatically update ppf now and select the Process button. The extra lines then are added 
to the Base ppf.

For example, the beginning and end of the updated file will look like:

BEGINNING

#ifndef ALIAS

section_long_plot "plot 2" {

#endif

END

#ifndef ALIAS

}

#endif

Clicking on the Alias button brings up the Set Aliases panel. Simply fill in the names to use 
instead of the words $user_texts_n in the Title Block - User Text Data Editor panel. Selecting Set 
writes out an aliases file which has the same names as the title file but with the appended ending 
.als.

Set

After selecting Set, the values for the user_texts are written to a file specified under Advanced (if 
used) or of the same name as the Title block ppf but with .tft appended.
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Create Old Plot Frame
plot_frame_create plot_frame_title plot_frame_margins
Position of option on menu: Plot =>Old plotting =>Create plot frame

On selecting the Create old option, the plot frame create panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Name input

name for the plot frame.

Model input available model
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the model for the plot frame.

Colour input available colours

the colour for the plot frame.

Plotter type input hp hp, dxf, dwg, postscript etc.

format for the plot file.

Plot file input *.hp etc.

name of the file to write the plot of the plot frame to.

Scale 1: input

scale for the plot.

Sheet size wd ht (mm) input

the width and height values (separated by spaces) or the name of a user defined sheet size.

Rotation angle input 0

angle of rotation for the plot frame.

Origin input xyz ops menu

x_origin    y_origin    z_origin   
origin (in world units) for the corner of the plot frame - given as three values separated by spaces. The 
values can either be typed in, or selected by clicking LB in the origin panel view and getting up the xyz 
ops menu and selecting the pick xyz option.

Draw viewport border tick-cross tick

if tick, plot the box around the plotting area (viewport).

Create button

create the plot frame and then put up the plot frame edit panel for the created plot frame.

Same as button

after picking the same as button, an existing plot frame is selected and its information is used to fill in 
the above panel fields.

Title tab

Use title file tick-cross

if tick, use the file given in the title file field to generate a title block.

Standard Title tick-cross tick

if tick, plot the standard 12d Model title block with the text, height and colour given in the following 
panel fields.

Title line 1/2 input

first/second line of title information in the 12d titleblock or for the user defined title block.

Title height (mm) input 10

height (in millimetres) to draw the two lines of title information in the 12d titleblock.

Title colour input cyan available colours

colour used for the border and the title information in the 12d titleblock.

Title tab

Left/right margin (mm) 10.0

the left/right hand side margin between the sheet and the plotting area inside the sheet.

Bottom/top margin (mm) 10.0
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the bottom/top margin between the sheet and the plotting area inside the sheet.

How To Use the Option

The plot frame contains all the information required to define the physical area in real world 
units to be plotted, the position on the sheet of the area being plotted, the plotter type and the 
plot file name.

Once the frame is created, the plot frame edit panel for the created plot frame is automatically 
placed on the screen so that the frame’s position can be adjusted using the Translate and Rotate 
buttons. 
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Editor Old Pot Frame
plot_frame_edit

Position of option on menu: Plot =>Old plotting =>Editor plot frame

The plot frame editor is used to edit existing plot frames. It is automatically placed on the screen 
when a plot frame is created so that the frame’s position can be adjusted using the Translate and 
Rotate buttons.

On selecting the Editor old option, the plot frame edit panel is displayed.

Most of the fields and buttons used in this panel are the same as the plot frame create panel - see 
the previous section  “Create Old Plot Frame” . The different ones are

Field Description Type Defaults Pop-Up

Pick button

select the plot frame to be edited.

Set button

update the plot frame with the information in the above panel fields.

Translate button

after picking the translate button, the plot frame will move with the cursor until a point is selected to 
give the final position of the plot frame.

Rotate button

after picking the rotate button, the plot frame is further rotated around the left hand corner of the sheet, 
by the angle made between the rotation point and the current cursor position.The plot frame will 
continue to rotate until a point is selected to fix the rotation angle.

Plotting Old Plot Frames
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plot_frames_plot

Position of option on menu: Plot =>Old plotting =>Plot plot frame

The plot old option is used to make a plot of the data on a given plan view for all the selected plot 
frames (selected by the data source). Note that the plots are of a given plan view and the plot 
frames do not have to be on the plan view.

On selecting the plot old option, the plot frames plot panel is displayed.

The fields and buttons used in this panel have the following functions.

Field DescriptionType Defaults Pop-Up

Data to plot - Data source type

data source type.

Data source

when the plot button is selected, all the plot frames in the data source will be plotted.

Plot parameters input *.ppf files

file of plot parameters to be used for the plot frames.
For more information on the plot frame plot parameters, please go to the section “Plot Frame Plot 
Parameter File” in the Appendix “Plot Parameters” 

Plan view to plot input available views

the name of the view that is plotted when the plot frames are selected for plotting. Note that the plot 
frames do not have to be on the view.

Plot button

when the plot buttons is selected, all the plot frames in the data source field will be plotted.

Data source of plot frames
to plot 
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Pen Mapping Old
colours_to_pens

Position of option on menu:

NO LONGER USED

Although 12d Model uses up to 10,240 different colours, most plotters have a smaller number of 
pens. Consequently for any plot, it is necessary to define what pen number corresponds to each 
12d Model colour.

For all plotters types except Eagle, the pen mapping option can be used to define the 
correspondence between 12d Model colours and plotter pens for the first sixteen colours. The 
other colours are given in the colour_map.def file. For Eagle plots, the eagleplt.pmf file is used 
to map colours to pens.

The pen mapping option is only used if a plotter mapping is not being used (see next section).

On selecting the pen mapping option, the current pen mapping table is displayed in the colours 
to pens panel.

When starting a new project or entering an existing project, the default pen mapping table is 
defined by the colours.4d file.

Once inside the project, any pen number in the table can be modified by changing the 
appropriate pen field and then selecting the set button. The modified table is stored until 
12d Model is quit or the user changes to another project.

The pen mappings for colours above sixteen are given in the colours.4d file but can not be 
displayed or modified by the colour to pens panel.

Whenever a plot is created using non-eagle plotter types, the colours are mapped to the pen 
numbers given in the colours to pen table before writing out the plot file.

For Eagle plots, the eagleplt.pmf file is used to map colours to pens.

Note - when 12d Model is started up again or the user changes to a new project, the table reverts 
to its default settings as given in the colours.4d file.
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24  PPF Editors
Title Blocks

Title blocks used for plots generated by plot frames, long sections, cross sections, pipe line and drainage 
can be defined by the user.

A user defined title block is build up from lines, circles, arcs and text. The format of the commands to draw 
these objects is the same as the draw_commands for user defined linestyles given in the Appendix.

For the purpose of defining a title block, all plots are considered to have the origin (0,0) in the bottom left 
hand corner (i.e. the plot is in the positive quadrant only) and the units used in the title block drawing 
commands are millimetres.

The title block drawing commands are placed in a file with ending .tf

Inside the file, the set of all title block drawing commands is enclosed within a set of curly brackets { } 
with the header

linestyle   title_block

before the curly brackets.

That is,

     linestyle   title_block    {

title block drawing commands
one command per line

}

Title Block Variables
For title blocks, the text drawing command has been extended so that special information such as the 
current date and time, plotting scales etc. can be automatically inserted into the title block.

To achieve this, special title block variables have been defined and wherever these variables appear in a 
title block text command, they are expanded to their defined value.

Hence the title block variables are simply place markers which have text values substituted for them when 
the title block file is used.

The title block variables all begin with a $ and are followed by either another title block variable or a 
single space. For example

text     “text $variable more text”    angle    height    justification    textstyle

or

text     “text $variable_1$variable_2 more text”       angle    height   justification     textstyle

Note - xfactor, slant, offset_width and offset_height can also be given by using:
text text angle height "justification" textstyle xfactor slant offset_width offset_height

The title block variables which don’t involve plot parameters are:

$project // the current project
$plot_file // the current plot file
$scale // for plot frames, the current scale
$horizontal_scale // for section plots, the current horizontal scale
$vertical_scale // for section plots, the current vertical scale
$start_chainage // for section plots, the start chainage for the plot

// sheet
$end_chainage // for section plots, the end chainage of the plot sheet
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The following title block variables take values which are passed down from the plot parameter file for the 
plot (plot parameter files are described in more detail in the rest of this manual):

$time

The current date and time. The format for the date and time is given by the plot parameter 
time_format. See the next section for the description of the format. 

$title_1, $title_2

$title_1 takes the value from the panel field title line 1 from the section x plot title, section long plot 
title or plot frame title panels, or from the parameter title_ 1 in the plot parameter file. 
If title_1 doesn’t exist, then $title_1 is blank.

Similarly for $title_2.

$user_text_n where n=1,2,... 1000

$user_text_n takes the value of the parameter user_text_n in the plot parameter file. If user_text_n 
doesn’t exist, then $user_text_n is blank.

Aliases can also be defined for the $user_text_n which are used in the PPF editors. See the next 
section on aliases.

$page_number

$page_number has the starting value one, or the value given by the parameter start_page_number 
from the plot parameter file, and is incremented by one, for each plot produced by the plot option (for 
example, for each page of a long section plot, for each page of x-section plots or each plot generated 
from a model of plot frames).

$drawing_number_prefix, $drawing_number, $drawing_number_postfix

The values for $drawing_number_prefix and $drawing_number_postfix are passed down from the 
plot parameter file by the parameters drawing_number_prefix and drawing_number_postfix 
respectively.

$drawing_number has the starting value one, or the value given by the parameter 
start_drawing_number from the plot parameter file, and is incremented by one for each plot 
produced by the plot option (for example, for each page of a long section plot, for each page of x-
section plots or each plot generated from a model of plot frames).

Notes

1. For plot frames, the horizontal_scale and vertical_scale are given the current scale, and $start_chainage 
and $end_chainage are ignored.

2. For section plots, $scale is ignored.

Aliases for $User Text
12d Model user defined title blocks can include up to 1,000 markers for placing user defined text 
($user_text_n where n can be from 1 to 1000) which is only substituted for actual text at plotting 
time. Because of the difficulty of knowing exactly what $user_text_n stood for when the title 
block is being plotted, the concept of aliases has been introduced.

For example, instead of referring to $user_text_4, an alias can be defined to use the text 
"Engineers name:" instead.

The definition of $user_text_n in a title block file has been extended so that it also includes any 
alias for the $user_text_n.

To define an alias for the $user_text_n in the title block file, simply replace the

 "_n" by "<n,text for the alias>"

For example, if $user_text_1 is to have the alias "Engineers name", the title block file would now 
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contain:

     text "$user_text<1,Engineers name:>"  0.000000 2.500 "bottom-left" "1" 1.000 0.000000 0.0 0.0

The title file and aliases work seamlessly with the interactive PPF editors and Plotters (which are 
described in their own sections). In the Title block section of the interactive PPF editors and 
Plotters, the user defined title block file is scanned for any $user_text in it and it is presented as a 
grid containing all the $user_user_text’s in the title block with a column to fill in the values that 
the user wants to be plotted. 

If the format $user_text_n is in the title block file, it is displayed as "User text n"  in the PPF editor. 
If an alias exists, then the alias is displayed instead of "User text n".

For example, using the $user_text<1,Engineers name> in a title block file will give:

Values Used for Defaults when Creating Plot Frames
There are special parameters that are written as comments at the top of title block file that are used as 
defaults for fields in the option Plots=>Plot frames=>Create new. They are

// plot_frame_name text
// plot_frame_model text
// plot_frame_colour text
// plot_frame_scale real_number
// plot_frame_sheet_size text
// plot_frame_angle real_number
// plot_frame_left_margin real_number
// plot_frame_right_margin real_number
// plot_frame_top_margin real_number
// plot_frame_bottom_margin real_number
// plot_frame_viewport logical (yes or no)

user text with
an alias in the
title block file

user text without
an alias in the
title block file
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Specifying the Format for $time
The format for $time is passed down by the plot parameter time_format.

time_format format // format for $time

The format consists of one or more codes and the formatting codes are preceded by a percent sign (%). 
Characters that do not begin with a % are copied unchanged.

%a abbreviated weekday name

%A full weekday name

%b abbreviated month name

%B full month name

%c date and time representation for locale

%d day of month as decimal number (01 - 31)

%H hour in 24-hour format (00 - 23)

%I hour in 12-hour format (01 - 12)

%j day of year as decimal number (001 - 366)

%m month as decimal number (01 - 12)

%M minute as decimal number (00 - 59)

%p current locale’s A.M./P.M. indicator for 12-hour clock

%S second as decimal number (00 - 59)

%U week of year as decimal number, with Sunday as first day of week (00 - 51)

%w weekday as decimal number (0 - 6; Sunday is 0)

%W week of year as decimal number, with Monday as first day of week (00 - 51)

%x date representation for current locale

%X time representation for current locale

%y year without century, as decimal number (00 - 99)

%Y year with century, as decimal number

%z, %Z time-zone name or abbreviation; no characters if time zone is unknown

%% percent sign

The # flag may prefix any formatting code and the meaning of the format code is changed as follows

Format Code Meaning

%#c long date and time representation, appropriate for current locale.
For example, “Tuesday, March 16, 1993,12:41:29”

%#x long date, appropriate for current locale.
For example, “Tuesday, March 16"

%#d, %#H, %#I, %#, Remove leading zeros (if any).
%#m, %#M, %#S, %#U,
%#W, %#y, %#Y

%#a, %#A, %#b, %#B, # flag is ignored
%#p, %#X, %#z, %#Z,
%#%

Examples
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The format to give the date in the form dd/mm/yy (06/09/97) is “%d/%m/%y”

If you want to remove leading zeros from the day and month (6/9/97) “%#d/%#m/%y”
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Example of a Title Block File
// Information used for creating plot frames
// plot_frame_name "plot 17"
// plot_frame_model "plot frames"
// plot_frame_colour "green"
// plot_frame_scale 500.000
// plot_frame_sheet_size "A1"
// plot_frame_angle 0.000
// plot_frame_left_margin 10.000
// plot_frame_right_margin 20.000
// plot_frame_top_margin 50.000
// plot_frame_bottom_margin 100.000
// plot_frame_viewport yes
//
// Drawing the title block
//
linestyle    title_block   {

    colour yellow
    move   0.0 100.0
    text “Page No. $page_number ..." 45.0 45.0 “bottom-left”

    move 100.0 100.0
    text “Scale 1:$scale ..." 45.0 45.0 “bottom-left”

    move 200.0 100.0
    text “Horizontal Scale 1:$horizontal_scale ..." 45.0 45.0 “bottom-left”

    move 300.0 100.0
    text “Vertical Scale 1:$vertical_scale ..." 45.0 45.0 “bottom-left”

    move 400.0 100.0
    text “Time is $time ..." 45.0 45.0 “bottom-left”

    move 500.0 100.0
    text “Plot file:$plot_file Project:$project Time:$time ..." 45.0 45.0 “bottom-left”

    move 600.0 100.0
    text “Engineer: $user_text<1,Engineers name:> ..." 45.0 45.0 “bottom-left”

    move 700.0 100.0
    text “User 2: $user_text_3 ..." 45.0 45.0 “bottom-left”

    move 800.0 100.0
    text “Drawing No:$drawing_number_prefix$drawing_number$drawing_number_postfix ..."

 45.0 45.0 “bottom-left”

    move 900.0 100.0
    text “Chainage min:$start_chainage Chainage max:$end_chainage ..." 45.0 45.0 “bottom-left”

    colour green
    move    0.0    0.0
    draw 1200.0    0.0
    draw 1200.0 1000.0
    draw    0.0 1000.0
    draw    0.0    0.0
    move   10.0   10.0
    draw 1190.0   10.0
    draw 1190.0 990.0
    draw   10.0 990.0
    draw   10.0   10.0
}
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X Plot PPF Editor
section_x_plot_ppf_editor

Position of option on menu: Plot =>X Plot PPF Editor

The x section ppf editor is for creating and/or editing a (binary) x-section ppf file and for 
creating a cross section plot.

Note: binary ppf’s are stored within the project (not in the folder containing the project as the 
ascii ppf’s were).

On selecting the X plot ppf editor option, the Section X Plot PPF Editor panel is displayed.

Panel field Type

Plot parameter file file box
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name for the binary plot parameter file to read in or write out.

Read button

read the given plot parameter file in.

Write button

write out the plot parameters to the given plot parameter file. An ascii ppf file is also written out.

Plot button

use the plot parameters from the panel to create the plot.

Find button

brings up a search box. If a valid parameter name is keyed in followed by the enter key, the cursor will 
be placed in the appropriate field on the appropriate page.

Section X Plot
Section_X_Plot

Section X Plot
Section: View to load details from

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

View section view box

on selection of an existing section view, the vertical exaggeration, model of x-sections to plot, corridor 
model and corridor settings from the section view are loaded into the ppf editor.

Section: Global Variables

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Text style global_textstyle text box

default text style

Plot Symbols plot_symbols file box

specify a plot symbol file if it exists.

Section: Global Area Width

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Horizontal Scale scale input

horizontal scale to be used for X section plots

Vertical exaggeration vertical_exaggeration input

vertical scale to be used for X section plots

Section: Primary Model X-Sections To Plot
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The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Model of xsec to plot model_to_plot model box

model of X sections to plot

Start chainage start_chainage input

start chainage of X sections to plot

End chainage end_chainage input

start chainage of X sections to plot

Section: Boxes/Centre lines

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Label type label_type choice box centre line

boxes

the label type to be used for plotting.

Draw and label the primary string

primary_string tick box

if ticked, the primary string will be labelled and drawn.

Sort sections sort_sections tick box

if ticked, the X sections will be sorted in increasing chainage. This is important if individual cross 
sections are added after an apply function for example. 

Section: Sheet Size Setup

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Sheet size wd ht (mm) sheet_size sheet size box

a valid sheet size is selected.

Section: Plotter parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Plotter type plotter_type plotter box

a valid plotting option is selected.

Plot file stem plot_stem plotter box

plot file name. The appropriate extension is added dependant on the plotter type selected.

Clean plot models beforehand

plot_model_clean choice box do not clean
prompt for clean



12d Model Reference Manual

Page 2394 November 2002X Plot PPF Editor

always clean

whether to clean (delete the elements in) any resultant plot models that may already exist, before 
generating the plot(s). This parameter is only applicable if plotting to a model or models. Note that if 
the models are cleaned using this parameter, any non-plot or locked elements found in the models will 
not be cleaned from the models, and the plot job will be cancelled.

Title Block
Section_X_Plot_Title_block

Common title block parameters
Panel field Parameter name Type

Standard title plot_border tick box

if ticked, a standard 12d title block will be used.

Use title file use_title_file tick box

if ticked, a user defined title file is used.

Title line 1 title_1 input

if  Standard title is ticked, Title line 1 is the first line of title text. If  Use title file is ticked, Title line 1 
is substituted for the title block variable $title_1.

Title line 2 title_2 input

if  Standard title is ticked, Title line 2 is the second line of title text. If  Use title file is ticked, Title line 
2 is substituted for the title block variable $title_2.

12d default title block parameters
Panel field Parameter name Type Pop-Up

Text size title_text_size input

text size of title text.

Text colour title_colour colour available colours

colour of title text.

Section_X_Plot_Title_block_User_title_info

User title info
The parameters shown below are subject to the appropriate title block variables existing in the title file. For 
more information on these variables see the section “Title Block Variables” .

Panel field Parameter name Type Pop-Up

Title file title_file file box available title files

specifies the name of the title file to use. If a valid title file exists, the specified Name values will be 
filled out in the grid using the title block variable $user_text_n.

Name output

the alias for the nth user text specified in the title file.

Value user_text_n input

the alias text to be substituted in for the user text specified.

Time format time_format input

the time format relates to the $time title block variable. For more information on the time formats see 
the section “Specifying the Format for $time” .



Chapter 24  PPF Editors

November 2002 Page 2395X Plot PPF Editor

Start page number start_page_number input

used as the starting value for the title block variable $page_number. If missing, $page_number starts at 
1.

Start drawing number start_drawing_number input

used as the starting value for the title block variable $drawing_number. If missing, $drawing_number 
starts at 1.

Drawing number prefix drawing_number_prefix input

the value entered is used for the title block variable $drawing_number_prefix.

Drawing number postfix drawing_number_postfix input

the value entered is used for the title block variable $drawing_number_postfix.

Extra X Sections To Plot
Section_X_Plot_Extra_X_sections_to_plot

Extra X Sections To plot
Section: Extra Models of X-Sections To Plot

The order and centreline chainages of the x-section subplots for the x-section plot are defined by the 
sections from the primary model of cross sections.

The sections through any specified triangulations and service models, and offsets for labelling are fully 
defined by these primary x-sections.

However it is also possible to plot extra x-sections on each of the sub-plots by supplying extra models of x-
sections which are at the same plan positions as the primary x-section strings.

Only those x-sections from the extra models that are within a user specified tolerance of a primary x-
section are plotted.

The extra models of x-sections and the plan tolerance for checking that the extra cross-sections are the 
same position as the primary x-sections are

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Model tolerance extra_model_tolerance_1input

user defined distance

Model name extra_model_n input

extra models of x-sections to plot.

Plot Sheet Layout
Section_X_Plot_Plot_sheet_layout

X-sections are normally generated at chainages along a given centreline. This centreline chainage is stored 
with each x-section string.

The chainages of the actual x-sections are referred to as offsets from the centreline position rather than x-
section chainages. The offsets of the x-section are set up so that the zero offset occurs where the x-section 
crossed the centreline string.

The x-sections along the centreline are stored in the one model (the primary model) which is then used to 
generate the cross section plot.



12d Model Reference Manual

Page 2396 November 2002X Plot PPF Editor

The x-sections are plotted in the order they occur in the x-section model and start being plotted at the 
bottom left hand corner of the sheet (left_margin,bottom_margin).

The individual x-section plots are then drawn going up the column, and when the column is full, start from 
the bottom of the next column.

When a sheet is full, a follow on sheet is created.

Each x-section from the primary model of x-sections generates its own sub-plot for which the x-section is 
the primary string. Hence the cross section plot consists of many individual plots drawn on one or more 
plot sheets.

Each plot sheet is considered to have only positive co-ordinates with the origin (0,0) in the left hand 
corner. The units for the plot are millimetres.

Plot Sheet Layout
Section: Plot Width Parameters

The width of the plot can be a fixed distance left or right of the centre line (zero offset) or for the full 
section plus an extra left and right distance:

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Absolute extensions absolute_extensions tick box

if ticked, the section goes from the left_extension offset on the left to the right_extension offset on the 
right. If unticked the section goes for the entire section length plus the left and right extension 
distances.

Left extension left_extension input

The left_extension value in world units.

Right extension right_extension input

The right_extension value in world units

Section: Align Section Parameters

If required, all the sub-plots in a column can be automatically positioned so that the zero offsets (the 
centrelines) of each x-section line up.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Line up centrelines line_up_cl tick box

if ticked, each sub plot will be aligned on the plot using the centreline of each x section.

Section_X_Plot_Plot_sheet_layout_Margins

Margins
Section: Margins For Standard 12d Title File - Border gaps

If the default 12d title block is used, then the size of the bottom of title block depends on the text size. The 
following parameters are used in the default title block case and the bottom_border_gap is added to the 
calculated height of the bottom of the title block.

The fields and buttons used in this section have the following functions.
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Field Description Parameter name Type Pop-Up

Left (mm) left_border_gap input

left border gap (in millimetres).

Right (mm) right_border_gap input

right border gap (in millimetres).

Top (mm) top_border_gap input

top border gap (in millimetres).

Bottom (mm) bottom_border_gap input

bottom border gap (in millimetres). 
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Section: Margins For User Title File

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Left (mm) left_margin input

left margin (in millimetres).

Right (mm) right_margin input

right margin (in millimetres).

Top (mm) top_margin input

top margin (in millimetres).

Bottom (mm) bottom_margin input

bottom margin (in millimetres).
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Definition of Plotting Areas for Default 12d Title Block

size depends on text size in the default 12d title block
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Because the user can easily select from the plotting panel whether a User Defined Title Block or the 
default 12d title block is used, both sets of margin and gap parameters can exist in the one plot parameter 
file.

The x-sections are plotted in the order they occur in the x-section model and start being plotted at the 
bottom left hand corner of the cross section plotting area.

The individual x-section plots are then drawn going up the column, and when the column is full, 
start from the bottom of the next column.

When a sheet is full, a follow on sheet is created.

Section_X_Plot_Plot_sheet_layout_Sub_plot_gaps

Sub Plot Gaps
Section: Sub Plot Gaps Parameters

The gaps between the sub plots is restricted to those specified below.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Left (mm) left_sub_plot_gap input

left margin (in millimetres).

Right (mm) right_sub_plot_gap input
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Definition of Plotting Areas for User Defined Title Blocks

cross section plot area is inside the dashed lines
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right margin (in millimetres).

Top (mm) top_sub_plot_gap input

top margin (in millimetres).

Bottom (mm) bottom_sub_plot_gap input

bottom margin (in millimetres).

The x-section sub-plot itself consists of the three regions - boxes, datum and graph.

The boxes area is where the offset values and the heights for the strings drawn on the x-section plot are 
labelled.

The datum area is the region between the boxes area and the graph area.

The graph area is the area where the actual plots of the strings are drawn.

Apart from information labelled in the boxes area, the x-section sub-plot can label other information such 
as

(a) grades across the x-section

(b) points across the x- section

(c) cuts the x-section makes through strings

(d) cut and fill areas
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Please continue to the next section “Boxes/ Centreline Labels” .
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Boxes/ Centreline Labels
Section_X_Plot_Boxes_Centreline_labels

Boxes/ Centreline Labels
Section: Boxes or Centreline Labels

The x-section can be labelled with either

(a) an upright, and the offset and height value at the zero offset (normally the centre line position) - 
Centre line

(b) the heights of the x-section and the tins at all the x-section points. - Boxes 

The choice is given by the parameter label_type defined in the section “Section: Boxes/Centre lines” .

A datum line exists for both cases.

For the boxes case, a box area for the offset and heights is created below the datum line. The available 
parameters for tailoring the box area will be given after describing the datum line parameters.

For the centre line case, the centre line and offset and height of the centre line are shown.

In both cases, the actual cross section plot is drawn above the datum line in the graph area.

Common Parameters
Section_X_Plot_Boxes_Centreline_labels_Common_parameters

The parameters defined below, are common to both label types

Common Parameters
Section: Common Datum Line Label Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Datum roundoff datum_roundoff input

value to roundoff the datum value to e.g. 0.5, 0.2, 1.0 (default 1.0)

The roundoff for the datum value is specified by the user (default 1.0) and the datum is automatically 
calculated for each sub-plot, and labelled.

Datum places for datum datum_decimals input

number of decimal places to display the datum value (default 1). If > 0, trailing zeros are removed after 
the decimal point. If <0, the absolute value is taken as the number of decimal places to report i.e. no 
trailing zeros are removed

Datum linestyle datum_linestyle linestyle box

boxes plotcentre line plot

graph area

datum line

boxes area

centre line
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datum line linestyle (default solid)

Datum name datum_name input

 text to write before the datum value

Datum textstyle datum_textstyle text box

textstyle for datum information

Datum text size (mm) datum_text_size input

size of datum text and value (mm)

Datum colour datum_colour colour box

colour of the datum text

Datum line colour datum_line_colour colour box

 colour of the datum line

Section_X_Plot_Boxes_Centreline_labels_Common_parameters_Tins_to_label

Tins To Label
Section: Common Parameters for Tins To Label 

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Define tin set # input

where n = 1 to.... The set enables the specification of a number of parameters for a number of specified 
tin names.

Tin name tin_n_name tin box available tins

the name of the nth tin to be used for labelling.

 If a tin of the name given by tin_n_name does not exist, then the plot is not produced and an error 
message is given.

Section_X_Plot_Boxes_Centreline_labels_Common_parameters_Centreline_chainage

Centreline Chainage
Section: Common Centreline Chainage Label Parameters

Each x-section sub-plot can be labelled with the centreline chainage of the x-section string.

This CHAINAGE INFO label is made up of the text strings:

"chainage_title" followed by the chainage-value

and is drawn under the datum line.
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The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Label subplot with centreline chainage

chainage_label tick box

if ticked, label sub-plot with centreline

Chainage title chainage_title input

text before the chainage value

Chainage Decimal places chainage_decimals input

 number of decimals in the chainage value. If <0, the absolute value is taken as the number of decimal 
places i.e. no trailing zeros are removed for the values in the chainage values.

Chainage colour chainage_colour colour box

colour of the text

Chainage text size (mm) chainage_size input

size of the text

Chainage textstyle chainage_textstyle text box

textstyle for the chainage label

Chainage text x position (mm)

chainage_x_offset input

 x position of text (mm)

Chainage text y position (mm)

chainage_y_offset input

 y position of text (mm)

The chainage_x_offset is measured from the beginning of the datum line.

The chainage_y_offset is measured from the bottom of the datum line with positive being down.

graph area

datum_above_gap_cl

centre line case

DATUM INFO

datum_y_cl

datum_x_cl

DATUM INFO

CHAINAGE INFO

chainage info and datum info
can be on the left, middle or right of the
datum line 

chainage_y_offset

CHAINAGE INFO
chainage_x_offset
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The values of the height and X and Y co-ordinates of the primary string (usually the design cross section) 
at the zero offset can be labelled. Note that zero offset is normally where the alignment string cuts the cross 
section.

The heights of any tins (such as the natural surface) at the zero offset can also be labelled.

The labels are made up of:

pre_text    value    post_text

where value is either a height or a co-ordinate.

The label is positioned at either the left, right or middle of the datum line, with an x and y adjustment and a 
rotation.

Section_X_Plot_Boxes_Centreline_labels_Common_parameters_X_coordinate_at_0_offset

X Coordinate At 0 Offset
Section: Common Labelling For X Coord At 0 Offset

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

boxes - offset and height area

graph area

datum_below_gap

datum_above_gap

boxes case

DATUM INFO

datum_y

da
tu

m
_x

DATUM INFO

chainage_y_offset

CHAINAGE INFO
chainage_x_offset

graph area

Labe
l

label_y

 datum_line

label_x
label_angle
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Draw Label primary_x0_draw_mode tick box

if ticked draw the label -default

Pre text primary_x0_pre_text input

pre-text for label - def " "

Post text primary_x0_post_text input

post-text for label - def " "

Decimal places primary_x0_decimals input

number of decimal places to display - def 1. If > 0, trailing zeros are removed after the decimal point 
If < 0, the absolute value is taken as the number of decimal places to report i.e. no trailing zeros are 
removed

X adjustment (mm) primary_x0_x input

 x adjustment to position of label - def 0

Y adjustment (mm) primary_x0_y input

 y adjustment to position of label - def 0

Angle (dms) primary_x0_angle angle box

 angle of label - def 0

Colour primary_x0_colour colour box

colour of the label

Size (mm) primary_x0_size input

size (in mm) of the label

Textstyle primary_x0_textstyle text box

textstyle of the label

Justification primary_x0_justify justification box

justification of the label

Section_X_Plot_Boxes_Centreline_labels_Common_parameters_Y_coordinate_at_0_offset

Y Coordinate At 0 Offset
Section: Common Labelling For Y Coord At 0 Offset

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Draw Label primary_y0_draw_mode tick box

if ticked draw the label -default

Pre text primary_y0_pre_text input

pre-text for label - def " "

Post text primary_y0_post_text input

post-text for label - def " "

Decimal places primary_y0_decimals input

number of decimal places to display - def 1. If > 0, trailing zeros are removed after the decimal point 
If < 0, the absolute value is taken as the number of decimal places to report i.e. no trailing zeros are 
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removed

X adjustment (mm) primary_y0_x input

 x adjustment to position of label - def 0

Y adjustment (mm) primary_y0_y input

 y adjustment to position of label - def 0

Angle (dms) primary_y0_angle angle box

 angle of label - def 0

Colour primary_y0_colour colour box

colour of the label

Size (mm) primary_y0_size input

size (in mm) of the label

Textstyle primary_y0_textstyle text box

textstyle of the label

Justification primary_y0_justify justification box

justification of the label

Section_X_Plot_Boxes_Centreline_labels_Common_parameters_Height_of_primary_string_at_0
_offset

Height Of Primary String At 0 Offset
Section: Common Labelling For Height Of Primary String At 0 Offset

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Draw Label primary_height_draw_mode tick box

if ticked draw the label -default

Pre text primary_height_pre_text input

pre-text for label - def " "

Post text primary_height_post_text input

post-text for label - def " "

Decimal places primary_height_decimals input

number of decimal places to display - def 1. If > 0, trailing zeros are removed after the decimal point 
If < 0, the absolute value is taken as the number of decimal places to report i.e. no trailing zeros are 
removed

X adjustment (mm) primary_height_x input

 x adjustment to position of label - def 0

Y adjustment (mm) primary_height_y input

 y adjustment to position of label - def 0

Angle (dms) primary_height_angle angle box

 angle of label - def 0

Colour primary_height_colour colour box
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colour of the label

Size (mm) primary_height_size input

size (in mm) of the label

Textstyle primary_height_textstyle text box

textstyle of the label

Justification primary_height_justify justification box

justification of the label

Section_X_Plot_Boxes_Centreline_labels_Common_parameters_Text_placement

Text Placement
Section: Common Parameters For Text Labelling

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Draw Label extra_text_draw_mode tick box

if ticked draw the label -default

Text extra_text input

text for label - def " "

X adjustment (mm) extra_text_x input

 x adjustment to position of label - def 0

Y adjustment (mm) extra_text_y input

 y adjustment to position of label - def 0

Angle (dms) extra_text_angle angle box

 angle of label - def 0

Colour extra_text_colour colour box

colour of the label

Size (mm) extra_text_size input

size (in mm) of the label

Textstyle extra_text_textstyle text box

textstyle of the label

Justification extra_text_justify justification box

justification of the label

Boxes
When boxes is selected for label_type, the primary string (usually the design cross section) and each tin in 
the x-section sub-plot can be labelled with one or two lines of title, and the height at the offset position for 
each point in the primary string.

The title for the strings, is drawn in the title area of the boxes area.

The offsets/heights are drawn in the heights area of the boxes area.
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Consequently the boxes area is made up of rows of text consisting of:

       string/tin titles followed by the offset/height values across the string/tin.

Each row is surrounded by lines to form a box.

The default order of the boxes from the bottom up is

(a) offset title and values

(b) tin title and heights - natural surface etc. (optional)

(c) primary string title and heights - design x-section (optional)

The title area starts at the relative position (left_sub_plot_gap,bottom_sub_plot_gap).

Section_X_Plot_Boxes_Centreline_labels_Boxes

Boxes
Section: Default Box Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Colour box_colour colour box

the default box colour

Insert 0 offset offset_insert_zero tick box

if ticked, a zero offset will be calculated if not already defined on the x section.

Draw box mode draw_box_mode choice box Do not draw any box lines

Draw box lines around

height area only

Draw box lines around

title and height area only

Use parameters defined in

boxes - heights

mode for drawing the boxes for the x section plot.

Section_X_Plot_Boxes_Centreline_labels_Boxes_Datum_lines

Datum Lines
Section: Boxes - Datum Line Parameters

boxes cross section plot

title
area

heights
area

offsets values

tin heights

primary (design)

(optional)

heights

offset title
tin title

primary string title
tin title
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For the boxes case, the datum line is positioned the distance datum_below_gap above the top of the boxes 
area and the graph area is then positioned the distance datum_above_gap above the datum line.

Hence the graph area is distance (datum_below_gap + datum_above_gap) above the top of the boxes area.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Graph area to datum line gap (mm) datum_above_gap input

dist from datum line to bottom of the

Datum line gap to top of boxes (mm) datum_below_gap input

dist from datum line to the top of the boxes

X adjustment (mm) datum_x input

distance to move the datum text along the datum line

Y adjustment (mm) datum_y input

distance to raise the datum text above the datum line (used to be called datum_offset) The datum_x and 
datum_y can be positive, zero or negative.

Section_X_Plot_Boxes_Centreline_labels_Boxes_Centreline_chainage

Centreline Chainage
Section: Boxes - Centre Line Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Justification of chainage text chainage_text_justification justification box bottom-left

bottom-centre

bottom-right

bottom-decimal

middle-left

middle-centre

middle-right

middle-decimal

top-left

top-centre

top-right

top-decimal

decimal-left

decimal-centre

decimal-right

decimal-point

justification of the chainage text.
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Section_X_Plot_Boxes_Centreline_labels_Boxes_Title_area

Title Area
Many distance definitions in the plot parameter file are given in terms of distance above the top of the 
boxes area.

Section: Boxes - Title Area Parameters

The size of the title text is given by the title_box_text_size parameter.

The width of the title area is either given by the space_for_titles parameter, or if omitted, the required 
width is automatically calculated.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Size of titles (mm) title_box_text_size input

size of offset, height label and values

Space for titles (mm) space_for_titles input

size of title area.

There can be two lines of title text and the title text, textstyle and colour can be set independently for the 
primary string and each tin.

The x position of the title text is the same for all the lines of title text and can be set to be a fixed distance 
from the left hand side of the boxes.

X adjustment (mm) box_titles_x input

distance to move the title text from the left hand side of the boxes

The text in the title area is the same for each cross section plot on the sheet so it is possible to restrict the 
title area to be only on the first cross section on the sheet or the first column of cross sections.

Title area mode label_first_only choice box on all sections

on first x-sec of page only

on x-sec’s in first column 

 it is possible to restrict the title area to be only on the first cross section on the sheet or the first column 
of cross sections

Section_X_Plot_Boxes_Centreline_labels_Boxes_Heights_area

boxes cross section plot

heights

area

space_for_titles

horizontal_line_spacing

bottom_sub_plot_gap

le
ft

_s
ub

_p
lo

t_
ga

p

offset title

tin title

primary string title

box_titles_x
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Heights Area

The heights area starts at the end of the title area.

The height text is written at right angles to the bottom of the boxes. It can be either top or bottom justified 
with respect to the box (box_text_justification).

The number of decimal places and the size of the heights text can also be specified.

The height of each individual box area is either given by the horizontal_line_spacing parameter, or if 
omitted, the required height is automatically calculated.

Section: Boxes - Height Area Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Number of decimals number_of_decimals input

number of decimal places in the offset height boxes. If <0, the absolute value is taken as the number of 
decimal places i.e. no trailing zeros are removed for the values in the offset, heights area.

Text size (mm) text_size input

size of the height values

Justification box_text_justification choice box bottom of individual boxes

top of individual boxes

justification of box text.

Horizontal line spacing (mm) horizontal_line_spacinginput

height of each individual box area of title area. Calculated if omitted

The total height of the boxes area is simply given by number of boxes drawn multiplied by the height of 
one box (they all have the same height).

The width of the heights area is determined by the number of chainages to be labelled and whether the 
values are staggered to prevent over writing.

Hence the total width of the boxes area is the width of the labels area plus the width of the heights area.

Section_X_Plot_Boxes_Centreline_labels_Boxes_Outside_linework

Outside Linework
Section: Boxes - Outside Linework Parameters

heights

area

space_for_titles

horizontal_line_spacing or

box 1

box 2

box n

1

2

4

5

6

8

7

lines to draw for draw_box_side_1 to draw_box_side_8

title

area
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The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Draw the left side of title area(1)

draw_box_side_1 tick box

if ticked, draw the left side of the title area (def).

Draw the top line of title area(2)

draw_box_side_2 tick box

if ticked, draw the top line of the title area (def).

Draw the bottom line of title area(4)

draw_box_side_4 tick box

if ticked, draw the bottom line of the title area (def).

Draw the left side of heights area(5)

draw_box_side_5 tick box

if ticked, draw the left side of the heights area (def).

Draw the top line of heights area(6)

draw_box_side_6 tick box

if ticked, draw the top line of the heights area (def).

Draw right side of heights area(7)

draw_box_side_7 tick box

if ticked, draw right side of the heights area (def).

Draw bottom side of heights area(8)

draw_box_side_8 tick box

if ticked, draw bottom side of the heights area (def).

Colour (1) box_side_colour_1 colour box

colour to draw left side of title area

Colour (2) box_side_colour_2 colour box

colour to draw top of title area

Colour (4) box_side_colour_4 colour box

colour to draw bottom of title area

Colour (5) box_side_colour_5 colour box

colour to draw left side of heights area

Colour (6) box_side_colour_6 colour box

colour to draw top of heights area

Colour (7) box_side_colour_7 colour box

colour for right side of heights area

Colour (8) box_side_colour_8 colour box

colour for bottom of heights area
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Section_X_Plot_Boxes_Centreline_labels_Boxes_Inside_linework

Inside Linework
Section: Boxes - Inside Linework Parameters

The lines at the top of the individual boxes inside the title area and heights area (separation lines) are 
controlled by the parameters box_line_draw_mode and box_line_mode_n. 

The separation lines can be drawn just in the title area, just in the heights area or in both areas.

The parameter box_line_draw_mode can be set to control all the separation lines but there are additional 
parameters, box_line_mode_n, which override box_line_draw_mode for each of the individual boxes 
where n = 1, ... number of boxes -1. 

The top of the top box is not controlled by box_line_mode_n but is controlled by the parameters 
draw_box_side_2 and draw_box_side_6.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Separation line mode box_line_draw_mode choice box Do not draw any separation

lines                

Draw the separation lines in 

both areas 

Draw the separation lines in

the title area only

Draw the separation lines in

 the heights area only

the separation line draw mode.

Box # input

Where box # = 1 to number of boxes(n). Box 1 is the bottom box, increasing upwards.

Line mode box_line_mode_n choice box No top line for title or height

area (mode=0)

Draw top line for title or

height area (mode=1) 

Draw top line for title area

only (mode=2)

Draw top line for height area

only (mode=3)

line mode for top of title and height areas for box number specified.
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Section_X_Plot_Boxes_Centreline_labels_Boxes_Extension_mode

Extension Mode
Section: Boxes - Extension Mode Parameters

The right hand end of the boxes can stop at the end of the design x-section or extend to the end 
of the right_extension distance.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Extension mode box_extension_mode choice box extend boxes to end of

 design x-section (mode=0)

extend boxes to end of right

 extension distance 
(mode=1)

Section_X_Plot_Boxes_Centreline_labels_Boxes_Offset_titles_values

Offset Titles/Values
Section: Boxes - Offset Title/Value Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

First line of offset title offset_title input

first line of offset title

heights

area

draw this line for box_line_mode_1 = 1 or 3

values for box_line_mode_n

title

area

draw this line for box_line_mode_2 = 1 or 3

draw this line for
box_line_mode_1 = 1 or 2

title
area

left
extension

right
extension

if box_extension_mode = 1 then the boxes extend to the end of the right extension 
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Second line of offset title offset_title_2 input

second line of offset title

Offset title textstyle offset_title_textstyle text box

offset title textstyle

Offset title colour offset_title_colour colour box

offset title colour

Offset title size (mm) offset_title_size input

offset title size

Offset value colour offset_colour colour box

offset value colour

Offset value textstyle offset_textstyle text box

offset value textstyle

Offset value size (mm) offset_size input

offset value size

Section_X_Plot_Boxes_Centreline_labels_Boxes_Primary_string_titles_values

Primary String Titles/Values
Section: Boxes - Primary String Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

First line primary_title input

first line of primary string title

Second line primary_title_2 input

second line of primary string title

Textstyle primary_title_textstyle text box

primary string title textstyle

Colour primary_title_colour colour box

primary string title colour

Size (mm) primary_title_size input

primary string title size

Y position (mm) primary_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the primary string title text is drawn. If 
not set, then the text is placed at a height that puts it inside the default box for the primary string title.

Section: Boxes - Primary String Value Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Colour primary_colour colour box

primary string value colour



Chapter 24  PPF Editors

November 2002 Page 2417X Plot PPF Editor

Textstyle primary_textstyle text box

primary string value textstyle

Size (mm) primary_size input

primary string value size

Y position (mm) primary_y_pos input

if set, the height in mm above the bottom of all the boxes that the primary string value text is drawn. If 
not set, then the text is placed at a height that puts it inside the default box for the primary string 
values.

Decimals primary_decimals input

 number of dec places in primary string height. < 0 to keep all trailing zeros

Section_X_Plot_Boxes_Centreline_labels_Boxes_Tin_titles_values

Tin Titles/Values
Section: Tin Titles/Values - Tin Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use tin set # input

set number to be used to define sets of tin parameters i.e. n value

Tin draw mode tin_n_draw_mode choice box Draw the tin

Do not draw the tin

draw tin mode for the nth tin specified by set #.

Tin colour tin_n_draw_colour colour box

tin colour mode for the nth tin specified by set #.

Tin label mode tin_n_label choice box Label the tin

Do not label the tin

tin label mode for the nth tin specified by set #.

Section_X_Plot_Boxes_Centreline_labels_Boxes_Tin_titles_values_Tin_Titles

Tin Titles
Section: Tin Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use tin set # input

set number to be used to define sets of tin parameters i.e. n value

First line of tin title tin_n_title input

first line of nth tin title

Second line of tin title tin_n_title_2 input

second line of nth tin title

Tin title textstyle tin_n_title_textstyle text box
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nth tin title textstyle

Tin title colour tin_n_title_colour colour box

nth tin title colour

Tin title size (mm) tin_n_title_size input

nth tin title size

Title Y position (mm) tin_n_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the nth tin title text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the tin heights.

Section_X_Plot_Boxes_Centreline_labels_Boxes_Tin_labels_values_Tin_heights

Tin Heights
Section: Tin Height Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use tin set # input

set number to be used to define sets of tin parameters i.e. n value

Decimals tin_n_decimals input

 number of dec places in nth tin height. < 0 to keep all trailing zeros

Textstyle tin_n_textstyle text box

textstyle of nth tin height

Colour tin_n_colour colour box

nth tin height and depth colour

Size (mm) tin_n_size input

nth tin height size

Y pos (mm) tin_n_y_pos input

if set, the height in mm above the bottom of all the boxes that the tin height text is drawn.If not set, then 
the text is placed at a height that puts it inside the default box for the tin heights.

Section_X_Plot_Boxes_Centreline_labels_Boxes_Tin_labels_values_Tin_depths

Tin Depths
Section: Tin Depth Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use tin set # input

set number to be used to define sets of tin parameters i.e. n value

Depth label mode tin_n_depth_label choice box Label depths

Do not label depths

depth label mode for the nth tin specified by set #.

First line of tin depth title tin_n_depth_title input

first line of nth tin depth title
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Second line of tin depth title

tin_n_depth_title_2 input

second line of nth tin depth title

Depth title textstyle tin_n_depth_title_textstyle text box

nth tin depth title textstyle

Depth title colour tin_n_depth_title_colour colour box

nth tin depth title colour

Depth title size (mm) tin_n_depth_title_size input

nth tin depth title size

Depth title Y position (mm) tin_n_depth_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the tin depth title text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the tin heights. 

Decimals in depth value tin_n_depth_decimals input

 number of dec places in tin height. < 0 to keep all trailing zeros

Depth value textstyle tin_n_depth_textstyle text box

nth tin depth textstyle

Depth value colour tin_n_depth_colour colour box

nth tin depth colour

Depth value size (mm) tin_n_depth_size input

nth tin depth size

Depth value Y position (mm) tin_n_depth_y_pos input

if set, the height in mm above the bottom of all the boxes that the tin depth text is drawn. If not set, then 
the text is placed at a height that puts it inside the default box for the tin heights.

Multiplier for positive depths depth_positive_factorinput

if set, this value will be used to multiply positive depth values.

Multiplier for negative depths depth_negative_factorinput

if set, this value will be used to multiply negative depth values.

The depth from the primary string to a tin, at a particular offset is defined as

depth = tin height value - height of the primary string

That is, the depth that the primary string is below the tin.

Before plotting, the value of depth is multiplied by either the depth_positive_factor or 
depth_negative_factor.

if (depth >= 0) plotted_depth_value = depth * depth_positive_factor

if (depth < 0) plotted_depth_value = depth * depth_negative_factor

Hence the definition of depth can be modified by the parameters:

depth_positive_factor value // multiplier for positive depths

depth_negative_factor value // multiplier for negative depths

For example, if the opposite sign is required for depth, that is,

depth     =     height of the primary string   -   tin height value

simply set

depth_positive_factor -1
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depth_negative_factor- 1

Section_X_Plot_Boxes_Centreline_labels_Boxes_Upright_offset_staggering_parameters

Upright Offset/Staggering Parameters
Section: Upright Offset/Staggering Parameters

For each sub-plot, the offsets of the points across the x-section string (primary string) are used for 
positioning uprights (leader lines), and the offset and height labels for the uprights.

By default, there is an upright at each point across the primary string.

However, if the primary string is a 4d string, then the text at the points on the 4d string can be used as a key 
to suppress the labelling and upright at that point. See “Section: Exclude Uprights At Nominated X-Sec 
Points” 

If the real offset position is used for the horizontal position of the offset/height text, text over writing can 
easily occur. To prevent over writing, the text is automatically staggered.

When staggering occurs, the real offset position is then indicated by the offset markers which are drawn at 
the top of the text boxes from the staggered text position back to the actual offset position of the text.

The size and position of the staggers are given by:

The fields and buttons used in this section have the following functions.

Field Description  Parameter name TypePop-Up

Offset label tolerance  offset_label_tolerance input

 weed out offset values closer together (in offset units) than this value.

Top of stagger to boxes distance (mm)  stagger_gap_top input

distance from boxes to top of stagger.

Bottom of stagger to boxes distance (mm) stagger_gap_bottom input

distance from boxes to bottom of stagger.

Stagger gap factor stagger_gap_factor input

distance between staggers is box_text_size * stagger_gap_factor

Section_X_Plot_Boxes_Centreline_labels_Boxes_Upright_offset_staggering_parameters_Uprights_to_exclude

Uprights To Exclude
Section: Exclude Uprights At Nominated X-Sec Points

For each sub-plot, the offsets of the points across the x-section string (primary string) are used for 
positioning uprights (leader lines), and the offset and height labels for the uprights.

boxes cross section plot

title
area top of boxes

stagger_gap_bottom
stagger_gap_top
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By default, there is an upright at each point across the primary string.

However, if the primary string is a 4d string, then the text at the points on the 4d string can be used as a key 
to suppress the labelling and upright at that point.

The parameters to stop labelling and uprights are:

mask_name_n 4d_string_point_text                where n=1,100

After any name masks have been applied, it is often desirable to weed out offset values that are too close 
together before doing any labelling.

The fields and buttons used in this section have the following functions.

Field Description  Parameter name TypePop-Up

Set # input

set number to be used to define a number of uprights to suppress

X-sec points to exclude mask_name_n input

the string name to be excluded. Note -the name can include wild cards (*) and characters (?). n is the 
value from the Set # provided. 

Section_X_Plot_Boxes_Centreline_labels_Boxes_Uprights

Uprights
Section: Uprights

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Uprights draw mode uprights_draw_mode choice box none

ticks to stagger height

to uprights_y above boxes

to primary string

to tin 1

to tin 2

to tin 3

to tin 4

to tin 5

to tin 6

to tin 7

to tin 8

to tin 9

to tin 10

Upright draw mode above boxes.

Uprights Y distance (mm)  uprights_y input

distance to draw the uprights for uprights_draw_mode = "to uprights_y above boxes"

Uprights colour  uprights_colour colour box

uprights colour. Default is box_colour
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Uprights bottom mode uprights_bottom_mode choice box stop at top of boxes

draw to bottom of boxes

draw to uprights_bottom_y 

below top of boxes

draw to uprights_bottom_y

 above bottom of boxes

ticks at chainage

Upright draw mode below top of boxes.

Uprights bottom Y distance (mm) uprights_bottom_y input

distance in mm.

Uprights text offset factor  uprights_text_offset_factor input

move the text by this factor*size.

When uprights go below the top of the boxes, the height and offset text is moved to the left so that the 
upright does not go through the text. The left hand side of the heights boxes also moves to the left to leave 
room for the height text.

Centreline
Section_X_Plot_Boxes_Centreline_labels_Centreline

Centreline
Section: Centreline Linestyle

boxes cross section plot

title
area

title
area

uprights can go to the

some where in between

bottom of the boxes

3.
0

6.
0

5.
0

4.
0

3.
0

6.
0

5.
0

4.
0

text is to the left
of the upright 

uprights can stop at the
top of the boxes, or

text is centred
on the upright 
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The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Linestyle of centreline  cl_linestyle linetype box

linestyle to be used for drawing centreline

Section_X_Plot_Boxes_Centreline_labels_Centreline_Datum_lines

Datum Lines
Section: Centreline - Datum Line Parameters

For the centreline case, the graph area is positioned the distance datum_above_gap_cl above the datum 
line.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Graph area - datum line gap (mm) datum_above_gap_cl input

dist from datum line to bottom of the graph area

Position of text datum_side_cl choice box Middle of datum line

Left of datum line

Right of datum line

side of centreline to position text.

Text justification datum_text_justification_cl just. box bottom-left

bottom-centre

bottom-right

bottom-decimal

middle-left

middle-centre

middle-right

middle-decimal

graph area

datum_above_gap_cl

centre line case

DATUM INFO

datum_y_cl

datum_x_cl

DATUM INFO

datum info
can be on the left, middle or right of the
datum line 
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top-left

top-centre

top-right

top-decimal

decimal-left

decimal-centre

decimal-right

decimal-point

justification of the datum text. NOTE : - this is not normally required since by default the text justification is 
set to match datum_side_cl. 

Text justification datum_text_justification_cl just. box bottom-left

Datum text position along datum line (mm)

datum_x_cl input

distance to move the datum text along the datum line

Datum text position above datum line (mm)

datum_y_cl input

distance to move the datum text above the datum line

The datum_x_cl and datum_y_cl can be positive, zero or negative.

Section_X_Plot_Boxes_Centreline_labels_Centreline_Position_of_ch_x_y_ht_text

Position Of Ch, X, Y, Ht, Text
Section: Centreline - Chainage Text Position

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Position of chainage value chainage_side_cl choice box Middle of datum line

Left of datum line

Right of datum line

side of centreline to position chainage text.

Justification of chainage text

chainage_text_justification_cl just. boxbottom-left

bottom-centre

bottom-right

bottom-decimal

middle-left

middle-centre

middle-right

middle-decimal

top-left
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top-centre

top-right

top-decimal

decimal-left

decimal-centre

decimal-right

decimal-point

justification of the chainage text.

Section: Labelling for X Coord At 0 Offset

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Position of text primary_x0_position choice box Middle of datum line

Left of datum line

Right of datum line

side of centreline to position x coord text.

Section: Labelling for Y Coord At 0 Offset

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Position of text primary_y0_position choice box Middle of datum line

Left of datum line

Right of datum line

side of centreline to position y coord text.

Section: Labelling for height of primary string at 0 offset

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Position of text primary_height_position choice box Middle of datum line

Left of datum line

Right of datum line

side of centreline to position height text.

Section: Parameters for text labelling

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Position of text primary_height_position choice box Middle of datum line

Left of datum line
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Right of datum line

side of centreline to position text.

Section_X_Plot_Boxes_Centreline_labels_Centreline_Height_of_tin_at_0_offset

Height Of Tin At 0 Offset
Section: Parameters For Labelling The Height Of Tin At 0 Offset

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use tin set # input

set number to be used to define sets of tin parameters i.e. n value

Depth label mode tin_n_height_draw_modechoice box Do not draw the label

Draw the label

label mode for the nth tin specified by set #.

Position of text tin_n_height_position choice box Middle of datum line

Left of datum line

Right of datum line

side of datum line to position text.

Pre text tin_n_height_pre_text input

pre text for label

Post text tin_n_height_post_text input

post text for label

Decimals tin_n_height_decimals input

number of decimal places to display - def 1. If > 0, trailing zeros are removed after the decimal point. 
If < 0, the absolute value is taken as the number of decimal places to report i.e. no trailing zeros are 
removed

X adjustment (mm) tin_n_height_x input

x adjustment to position of label

Y adjustment (mm) tin_n_height_y input

y adjustment to position of label

Y adjustment (mm) tin_n_height_angle angle box

angle of label

Colour tin_n_height_colour colour box

colour of label

Size (mm) tin_n_height_size input

size of label

Textstyle tin_n_height_textstyle text box

textstyle of label of label

Section_X_Plot_Boxes_Centreline_labels_Centreline_Labelling_offset_height__Superseded_
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Labelling Offset/Height (Superseded)
Section: Centreline - Labelling Offset/Height Parameters

In the centre line case, the value of the height of the primary string (usually the design cross section) at 
the zero offset can be labelled. This is normally where the alignment string cuts the cross section.

The label is made up of the texts:

primary_title    offset_title     offset_value     height_text       height_value

NOTE: These parameters have now been superseded. The parameters for labelling the height of the 
primary string at zero offset covers this case. To use the zero offset parameters instead, the 
primary_height_pre_text would include all text required for the Primary_title, offset_title, offset_value 
and height_text (offset_value is always 0.0).

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Include primary title in label

primary_mode_cl Tick box

The parameter primary_mode_cl controls whether the primary_title is included in the label.

Include height in label

height_mode_cl Tick box

The parameter height_mode_cl controls whether the height_title and height_value are included in the 
label.

Include offset in label

offset_mode_cl Tick box

The parameter offset_mode_cl controls whether the offset_title and offset_value are included in the 
label.

Position of text offset_height_side_cl Choice 0

Choice 1

Choice 2

The label can be placed on the left, centre of right side of the datum line.

Justification of text offset_height_text_justification_cl

justification of the text.justification of the offset height text. NOTE : - this is not normally required 
since by default the text justification is set to match offset_height_side_cl 

Height text label height_text Input

height text.

Distance to move text position along datum line (mm)

offset_x_cl Input

distance to move the text along the datum line.

Distance to move text position below datum line (mm)

offset_y_cl Input

distance to move the text below the datum line.
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Graph Area
Section_X_Plot_Graph_area

Graph area
The graph area for each section sub-plot is the area where the actual plot of the x-section string is drawn.

The width of the graph area is determined by the width of the x-section string being plotted, the left and 
right extensions and horizontal scale (scale) given by the parameters.

Section: Graph Area - Extra Space Parameters

The size of the graph area can be extended to allow for symbols by the following parameters:

The types of strings that are drawn in the graph area of a cross section plot are:

(a) primary string    the x-section string from the x-section model that is being drawn.
Called the primary string and is usually the design x-section.

(b) tins sections of the primary string through any tins in models in the 

graph area

datum_above_gap_cl

centre line case

DATUM INFO

datum_y_cl

datum_x_cl

DATUM INFO

CHAINAGE INFO

datum, chainage and offset/height info
can be on the left, middle or right of the
datum line 

chainage_y_offset

CHAINAGE INFO
chainage_x_offset

Primary Offset 0.0 Height 13.1 

offset, height of
the centre line

offset_y_cloffset_x_cl

title
area

extra_space_top

left
extension

right
extension

final graph box taking extensions
and extra space into consideration 

extra_space_bottom

ex
tr
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sp

ac
e_

le
ft
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e_
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gh
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corridor models.

(c) services parts of strings (from models in corridor models)
that cut the defined corridor.

The colour of the strings in the plot is the actual string colour for cases (a) and (c), and the colour of the tin 
used for the section in case (b).

Although all the strings are plotted, the plot parameter file can be used to select which ones are labelled 
with heights.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Extra space units extra_space_units choice box world units

millimetres

units for specifying extra space.

Extra space left (units) extra_space_left input

distance to subtract from left of plot area

Extra space right (units) extra_space_right input

distance to add to right of plot area

Extra space top (units) extra_space_top input

distance to add to top of plot area

Extra space bottom (units) extra_space_bottom input

distance to subtract from bottom of plot area

Corridors
Section_X_Plot_Corridors

A corridor around the primary string is defined by giving a left and right corridor width.

Any string in a model added to the section view is checked to see if it appears in the corridor, and if it does, 
it is drawn on the cross-section plot.

To be drawn, strings do not have to cross the primary string, but just be in the corridor.
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Panel field Parameter name Type

Left corridor width (world units)
corridor_width_left input

left corridor width

Right corridor width (world units)
corridor_width_right input

right corridor width

Left corridor overlap (world units)
corridor_overlap_left input

left corridor overlap

Right corridor overlap (world units)
corridor_overlap_right input

right corridor overlap

Chord-arc tolerance (world units)
corridor_chord_arc input

chord-arc tolerance used near any bends in the corridor.

Section_X_Plot_Corridors_Model_selectionModel selection
Panel field Parameter name Type

Corridor model corridor_model_n model box

models containing tins and service strings to be drawn on the section. Where n = 1, 2, ... ,100 given by 
line number on grid.

Grades
Section_X_Plot_Grades

Grades
Section: Corridor - Grade Parameters

The plot of the x-section string is made up of straight lines joining the individual points of the x-section.

primary string

corridor_width_left

corridor_width_right

pipe string
strings (no diameter)

plan view

(design x- section)

left_extension

right_extension

section viewtin (natural surface)

design x- section

services in the corridor
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The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Label grades grade_label tick box

if ticked, label grades.

Either the individual lines can be used as the segments to be labelled for grade, or adjacent lines of the 
same grade can be considered to be just one segment and labelled only once.

Hence the segments to be labelled for grade can be the individual lines of the x-section, or the segments 
defined by changes of grade.

Label change of grade segments

grade_change_only tick box

if ticked, label change of grade segments. If not, label individual lines.

It is also possible to ignore segments smaller that a given minimum width on the plot.

Minimum segment width grade_minimum_width input

segments smaller than specified value (in mm) are not labelled

The grade labels are drawn parallel to the segment, centred about the segments end points, and a distance 
grade_offset above the segment. The size, colour and number of decimal places can all be set.

Decimal places for grades grade_decimals input

number of decimal places in grade

Size for grade text (mm) grade_size input

size of the grade label

Textstyle for grades grade_textstyle text box

textstyle of the grade label

Colour for grades grade_colour colour box

number of decimal places in grade

Grade offset (mm) grade_offset input

distance above the segment for label

Show grade sign grade_offset tick box

if ticked, the sign of the grade is labelled.

The grade can be labelled as percent cross-fall, 1 in slope, m/m or VicRoads x:1.

Also a threshold value can be set and any grades whose absolute value are below the threshold can be 
labelled in one way, and those above the threshold labelled a different way.

Hence, if the absolute value of the grade is less that or equal to the absolute value of grade_threshold, then 
grade_mode is used, otherwise grade_upper_mode is used.

Grade mode grade_mode choice box % grade

1 in

m/m
VicRoads x:1

type of grade value

Grade threshold grade_threshold input

grade threshold for type of grade labelling
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Grade threshold mode grade_threshold_mode choice box % grade

1 in

m/m
VicRoads x:1

type of grade value

Grade upper mode grade_upper_mode choice box % grade

1 in

m/m
VicRoads x:1

type of grade value

Decimal places for grades above threshold value

grade_upper_decimals input

number dec places in grades above threshold value

X-Section Points
Section_X_Plot_X_section_points

X-Section Points
The points across each x-section can be automatically labelled on the x-section plots.

The offset, height and name of the point can be labelled as well as a symbol drawn. The height of tins at 
the same offset value can also be labelled.

The offset position for the labelling is the offset of the point.

The height position for the labelling can be specified as the

(a) top of the boxes for the x-section

(b) above the maximum height of the strings on the plot

(c) height of the point on the x-section string (primary string)

(d) height of a tin.

The actual position of the label is defined relative to the above point.

section view
tin (natural surface)

design x- section
3% 3%

1:2
1:3
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Note: 

Only case (b) involves the actual height of the point on the cross section string. For all other cases, only the 
offset of the cut string is used.

Other heights, for example, the height of the tin at that offset can be used as the height (case (d)).

Section: X-Section Point Mask Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Define Set # input

set number to be used to define a number of points to include

Point mask points_n_mask input

The points of the x-section to be labelled for the nth set of parameters is restricted to all the points 
whose name satisfying the points_n_mask. For example

points_1_mask = "ke*"

or points_1_mask = "?bank*"

or, if both masks are required,

points_1_mask  = "ke* ?bank*"

 

Section_X_Plot_X_section_points_Offsets

Offsets
Section: X-Section - Offset Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#

Position points_offset_n_position choice box above point value

above top of boxes

above top of graph area

section viewtin (natural surface)

design x- section

denotes points on the x-section

 

for labelling

The x-section point can be labelled with
offset of the point
height of the point
height of any tin at this offset
name of the point

any 12d symbol can be drawn at the point
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to primary string

to tin 1

to tin 2

to tin 3

to tin 4

to tin 5

to tin 6

to tin 7

to tin 8

to tin 9

to tin 10

above point value.

X (mm) points_offset_n_x input

horizontal adjustment to position of offset text.

Y (mm) points_offset_n_y input

height adjustment to position of offset text.

Angle (dms) points_offset_n_angle input

rotation of offset text about point.

Colour points_offset_n_colour colour box

colour of offset text

Size (mm) points_offset_n_size input

size of offset text. A value of 0 = no label

Textstyle points_offset_n_textstyle text box

textstyle of offset text

Pre-text points_offset_n_pre_text input

text before offset text

Post-text points_offset_n_post_textinput

text after offset text

Justification points_offset_n_justification

justification box bottom-left

bottom-centre

bottom-right

bottom-decimal

middle-left

middle-centre

middle-right

middle-decimal

top-left

top-centre
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top-right

top-decimal

decimal-left

decimal-centre

decimal-right

decimal-point

justification of the offset text.

Decimals points_offset_n_no_decimals input

number of decimals in offset

Section_X_Plot_X_section_points_Heights

Heights
Section: X-Section - Height Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#

Mode points_height_n_mode choice box use height of cut point

use real height above boxes

height of primary string

use height of tin 1

use height of tin 2

use height of tin 3

use height of tin 4

use height of tin 5

use height of tin 6

use height of tin 7

use height of tin 8

use height of tin 9

use height of tin 10 

height mode above point value.

Position points_height_n_position choice box above point value

above top of boxes

above top of graph area

to primary string

to tin 1

to tin 2

to tin 3

to tin 4
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to tin 5

to tin 6

to tin 7

to tin 8

to tin 9

to tin 10

above point position.

X (mm) points_height_n_x input

horizontal adjustment to position of height text.

Y (mm) points_height_n_y input

height adjustment to position of height text.

Angle (dms) points_height_n_angle input

rotation of height text about point.

Colour points_height_n_colour colour box

colour of height text

Size (mm) points_height_n_size input

size of height text. A value of 0 = no label

Textstyle points_height_n_textstyle text box

textstyle of height text

Pre-text points_height_n_pre_text input

text before height text

Post-text points_height_n_post_text input

text after height text

Justification points_height_n_justification just. box bottom-left

bottom-centre

bottom-right

bottom-decimal

middle-left

middle-centre

middle-right

middle-decimal

top-left

top-centre

top-right

top-decimal

decimal-left

decimal-centre

decimal-right
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decimal-point

justification of the height text.

Decimals points_height_n_no_decimals input

number of decimals in height

Section_X_Plot_X_section_points_Labels

Labels
Section: X-Section - Label Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#

Position points_label_n_position choice box above point value

above top of boxes

above top of graph area

to primary string

to tin 1

to tin 2

to tin 3

to tin 4

to tin 5

to tin 6

to tin 7

to tin 8

to tin 9

to tin 10

above point position.

Mode points_label_n_mode choice box don’t include point name

include point name in label

label mode.

X (mm) points_label_n_x input

horizontal adjustment to position of label.

Y (mm) points_label_n_y input

height adjustment to position of label.

Angle (dms) points_label_n_angle input

rotation of label about point.

Colour points_label_n_colour colour box

colour of label

Size (mm) points_label_n_size input

size of label. A value of 0 = no label
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Textstyle points_label_n_textstyle text box

textstyle of label

Pre-text points_label_n_pre_text input

text before label

Post-text points_label_n_post_text input

text after label

Justification points_label_n_justification just. box bottom-left

bottom-centre

bottom-right

bottom-decimal

middle-left

middle-centre

middle-right

middle-decimal

top-left

top-centre

top-right

top-decimal

decimal-left

decimal-centre

decimal-right

decimal-point

justification of the label.

Section_X_Plot_X_section_points_Symbols

Symbols
Section: X-Section - Symbol Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#

Mode points_symbol_n_mode choice box cross (0)

up from centre of box (1)

up and down from centre of

box (2)

square (3)

triangle, base at bottom (4)

circle (5)

use a plot symbol
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symbol mode.

if a plot symbol is to be used, the points_symbol_n_style parameter must be specified.

Symbol points_symbol_n_style plot symbols

a valid plot symbol can be selected.

Position points_symbol_n_position choice box above point value

above top of boxes

above top of graph area

to primary string 

to tin 1

to tin 2

to tin 3

to tin 4

to tin 5

to tin 6

to tin 7

to tin 8

to tin 9

to tin 10

above point position.

X (mm) points_symbol_n_x input

horizontal adjustment to position of symbol.

Y (mm) points_symbol_n_y input

height adjustment to position of symbol.

Angle (dms) points_symbol_n_angle input

rotation of symbol about point.

Colour points_symbol_n_colour colour box

colour of symbol

Size (mm) points_symbol_n_size input

size of symbol. A value of 0 = no symbol

Hatching Cut/Fill
Section_X_Plot_Hatching_cut_fill

This option is used to hatch cut and/or fill areas between sets of tins.

For each set, the name of the two tins, the hatch linestyle, colour and separation and whether cut and/or fill 
regions are required are all user definable.

Up to twenty (20) separate sets of tins may be hatched.

0 1 2 3 4 5

predefined symbols 0 to 5
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Panel Field Parameter name Type

Define Set # input

set number to be used to define different original/new tin sets.

Original tin hatch_original_tin_n tin box

tin_name for original surface

New tin hatch_new_tin_n tin box

tin_name for final surface

Notes

(a) cut is when the new tin is below the original tin.
fill is when the new tin is above the original tin.

(b) cut hatching is turned off by setting hatch_cut_separation_n to 0.0.
fill hatching is turned off by setting hatch_fill_separation_n to 0.0.

Section_X_Plot_Hatching_cut_fill_Cut

Cut
Panel Field Parameter name Type

Use Set # input

set number as specified in the Define set#.

Cut separation (mm) hatch_cut_separation_n input

distance between cut hatch lines. If 0, no hatching.

Cut hatch angle (dms) hatch_cut_angle_n input

angle of hatching.

Cut colour hatch_cut_colour_n colour box

colour of the hatching.

Cut linestyle hatch_cut_linestyle_n linestyle box

linestyle of the hatching.

Draw sides of cuts hatch_cut_draw_sides_n choice box

draw mode for sides of cut regions.

Draw original tin hatch_cut_draw_original_n choice box

draw mode for sides of original tin in cut.

Draw new tin hatch_cut_draw_new_n choice box

draw mode for sides of new tin in cut.

Section_X_Plot_Hatching_cut_fill_Fill

Fill

section viewtin (natural surface)

design x- section

cut

fill
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Panel Field Parameter name Type

Use Set # input

set number as specified in the Define set#.

Fill separation (mm) hatch_fill_separation_n input

distance between fill hatch lines. If 0, no hatching.

Fill hatch angle (dms) hatch_fill_angle_n input

angle of hatching.

Fill colour hatch_fill_colour_n colour box

colour of the hatching.

Fill linestyle hatch_fill_linestyle_n linestyle box

linestyle of the hatching.

Draw sides of fills hatch_fill_draw_sides_n choice box

draw mode for sides of fill regions.

Draw original tin hatch_fill_draw_original_n choice box

draw mode for sides of original tin in fill.

Draw new tin hatch_fill_draw_new_n choice box

draw mode for sides of new tin in fill.

Cuts
Section_X_Plot_Cuts

The cuts that each x-section string makes though strings in any user-specified model, can be automatically 
labelled on the x-section plots.

The height, offset and name of the cut string can be labelled as well as a symbol drawn. The height of tins 
at the same offset value can also be labelled.

The offset position for the labelling is the offset of the cut string.

The height position for the labelling can be specified as the:

(a) top of the boxes on the x-section,

(b) above the maximum height of the strings on the plot,

(c) height value of the cut string,

(d) height of the x-section string (the primary string),

(e) height of a tin.

The actual position of the label is defined relative to the above point.
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Note: Only case (c) involves the actual height of the cut string. For all other cases, only the offset of the cut 
string is used. Hence, for all cases except (c), the string does need to have a sensible height to be used for 
cuts through strings. For example, a boundary string may have null heights but only the offset is required 
and the height of the tin at that offset can be used as the height (case (e)).

The method for specifying which strings are to be checked for cuts is by first specifying the model which 
contains the strings, and then a name mask which is used to restrict the strings in the model to only those 
whose names match the name mask.

Up to twenty five different sets of models and name masks can be used so that different cut sets can be 
labelled in different ways.

Panel Field Parameter name Type

Define Set # input

set number to be used to define different model/mask sets.

Model cuts_n_model model box

model from which cut masks are derived

Name mask cuts_n_mask input

text string containing the name masks, each separated by one or more spaces, to test the string name 
against. Each mask can include wild cards and wild characters.
For example: "ke*" or,

"?bank*" or, if both masks are required,
"ke* ?bank*"

If cuts_n_mask is blank, then all strings in the model are used. This is equivalent to name mask being 
set to "*".

All strings in the model cuts_n_model whose name satisfy the name mask cuts_n_mask are then checked 
for cuts with the x-sections, and if a cut occurs, the cut point will be labelled according to the rest of the 

primary string

plan view

(design x- section)

left_extension

right_extension

section viewtin (natural surface)

design x- section

strings to label where they are cut by the cross section

points where strings are
cut in plan by the x-section 
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parameters in the nth set.

Section_X_Plot_Cuts_Offsets

Offsets
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Position cuts_offset_n_position choice box at cut string height
above top of boxes
above top of graph area
to primary string 
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of offset label.

X (mm) cuts_offset_n_x input

horizontal adjustment to position of offset text.

Y (mm) cuts_offset_n_y input

vertical adjustment to position of offset text.

Angle (dms) cuts_offset_n_angle input

rotation of offset text about position.

Colour cuts_offset_n_colour colour box

colour of offset text.

Size (mm) cuts_offset_n_size input

size of offset text. A value of 0 means no label.

Textstyle cuts_offset_n_textstyle text box

textstyle of offset text.

section viewtin (natural surface)

design x- section

point where the x-section
cuts a string 

The cut point can be labelled with
offset of the cut point
height of the cut point
height of the x-section or tins at this offset
name of the string for the cut point

User defined symbols can also be drawn at the 
cut point
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Pre-text cuts_offset_n_pre_text input

text before offset text.

Post-text cuts_offset_n_post_text input

text after offset text.

Justification cuts_offset_n_justification
justification box

bottom-left
bottom-centre
bottom-right
bottom-decimal
middle-left
middle-centre
middle-right
middle-decimal
top-left
top-centre
top-right
top-decimal
decimal-left
decimal-centre
decimal-right
decimal-point

justification of the offset text.

Decimals cuts_offset_n_no_decimals
input

number of decimals in offset.

Section_X_Plot_Cuts_Heights

Heights
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Mode cuts_height_n_mode choice box use height of cut point
use real height above boxes
height of primary string
use height of tin 1
use height of tin 2
use height of tin 3
use height of tin 4
use height of tin 5
use height of tin 6
use height of tin 7
use height of tin 8
use height of tin 9
use height of tin 10

determines which height value is labelled.

Position cuts_height_n_position choice box at cut string
above top of boxes 
above top of graph area
to primary string 
to tin 1
to tin 2
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to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of height label.

X (mm) cuts_height_n_x input

horizontal adjustment to position of height text.

Y (mm) cuts_height_n_y input

vertical adjustment to position of height text.

Angle (dms) cuts_height_n_angle input

rotation of height text about position.

Colour cuts_height_n_colour colour box

colour of height text.

Size (mm) cuts_height_n_size input

size of height text. A value of 0 means no label.

Textstyle cuts_height_n_textstyle text box

textstyle of height text.

Pre-text cuts_height_n_pre_text input

text before height text.

Post-text cuts_height_n_post_text input

text after height text.

Justification points_height_n_justification
justification box

bottom-left
bottom-centre
bottom-right
bottom-decimal
middle-left
middle-centre
middle-right
middle-decimal
top-left
top-centre
top-right
top-decimal
decimal-left
decimal-centre
decimal-right
decimal-point

justification of the height text.

Decimals cuts_height_n_no_decimals
input

number of decimals in height.
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Section_X_Plot_Cuts_Labels

Labels
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Position cuts_label_n_position choice box at cut string height
above top of boxes
above top of graph area
to primary string
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of label text.

Mode cuts_label_n_mode choice box don’t include string name
include cut string name

determines whether the label includes the cut string name.

X (mm) cuts_label_n_x input

horizontal adjustment to position of label.

Y (mm) cuts_label_n_y input

vertical adjustment to position of label.

Angle (dms) cuts_label_n_angle input

rotation of label about position.

Colour cuts_label_n_colour colour box

colour of label.

Size (mm) cuts_label_n_size input

size of label. A value of 0 means no label.

Textstyle cuts_label_n_textstyle text box

textstyle of label.

Pre-text cuts_label_n_pre_text input

text before label.

Post-text cuts_label_n_post_text input

text after label.

Justification cuts_label_n_justification
justification box

bottom-left
bottom-centre
bottom-right
bottom-decimal
middle-left
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middle-centre
middle-right
middle-decimal
top-left
top-centre
top-right
top-decimal
decimal-left
decimal-centre
decimal-right
decimal-point

justification of the label.

Section_X_Plot_Cuts_Symbols

Symbols
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Mode cuts_symbol_n_mode choice box cross (0)
up from centre of box (1)
up&down from box centre(2)
square (3)
triangle, base at bottom (4)
circle (5)
use a plot symbol

symbol mode.

Note: If a plot symbol is to be used, the cuts_symbol_n_style parameter must be specified.

Symbol cuts_symbol_n_style plot symbols

a valid plot symbol can be selected.

Position cuts_symbol_n_position choice box at cut string height
above top of boxes
above top of graph area
to primary string 
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of symbol.

X (mm) cuts_symbol_n_x input

horizontal adjustment to position of symbol.

0 1 2 3 4 5

predefined symbols 0 to 5
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Y (mm) cuts_symbol_n_y input

vertical adjustment to position of symbol.

Angle (dms) cuts_symbol_n_angle input

rotation of symbol about point.

Colour cuts_symbol_n_colour colour box

colour of symbol.

Size (mm) cuts_symbol_n_size input

size of symbol. A value of 0 means no symbol.

PPF’s To Include
Section_X_Plot_PPF_s_to_include

Panel Field Parameter name Type Pop-Up

PPF files input

by including pre existing PPF files, the user can build up a modified version without having to set all 
the parameters.
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Long Plot PPF Editor
section_long_plot_ppf_editor

Position of option on menu: Plot =>Long Plot PPF Editor

The long section ppf editor is for creating and/or editing a (binary) long-section ppf file and for 
creating a long section plot.

Note: binary ppf’s are stored within the project (not in the folder containing the project as the 
ascii ppf’s were).

On selecting the Long plot ppf editor option, the Section Long Plot PPF Editor panel is displayed.

Panel field Type

Plot parameter file file box
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name for the binary plot parameter file to read in or write out.

Read button

read the given plot parameter file in.

Write button

write out the plot parameters to the given plot parameter file. An ascii ppf file is also written out.

Plot button

use the plot parameters from the panel to create the plot.

Find button

brings up a search box. If a valid parameter name is keyed in followed by the enter key, the cursor will 
be placed in the appropriate field on the appropriate page.

Section Long Plot
Section_Long_Plot

Section Long Plot
The long plot itself consists of the three regions - boxes, datum and graph areas.

The boxes area is where the titles and the chainage values and the heights/depths for the strings drawn on 
the long plot are labelled.

The datum area is the region between the boxes area and the graph area.

The graph area is the area where the actual plots of the strings are drawn.

Apart from information labelled in the boxes area, the long section plot can label other information such as

(a) horizontal geometry

(b) vertical geometry

(c) chainage, heights at special points

(d) symbols at special points

(e) bubbles at special chainages

(f) cuts the design string makes through strings

(g) cut and fill areas

Section: View to load details from

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

View section view box

on selection of an existing section view, the vertical exaggeration, string to profile, corridor model and 
corridor settings from the section view are loaded into the ppf editor.

Section: Global Variables

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Text style global_textstyle text box

default text style
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Plot Symbols plot_symbols file box

specify a plot symbol file if it exists.

Section: Section Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Name of string to profile string_to_plot string box

model of long sections to plot

Horizontal Scale scale input

horizontal scale to be used for long section plots

Vertical exaggeration vertical_exaggeration input

vertical scale to be used for long section plots

Start chainage start_chainage input

start chainage of long sections to plot

End chainage end_chainage input

start chainage of long sections to plot

Section: Sheet Size Setup

The plot page or sheet is considered to have only positive co-ordinates with the origin (0,0) in the left hand 
corner. The units for the plot are millimetres.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Sheet size wd ht (mm) sheet_size sheet size box

a valid sheet size is selected.

Section: Plotter Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Plotter type plotter_type plotter box

a valid plotting option is selected.

Plot file stem plot_stem file box

plot file name. The appropriate extension is added dependant on the plotter type selected.

Clean plot models beforehand

plot_model_clean choice box do not clean
prompt for clean
always clean

whether to clean (delete the elements in) any resultant plot models that may already exist, before 
generating the plot(s). This parameter is only applicable if plotting to a model or models. Note that if 
the models are cleaned using this parameter, any non-plot or locked elements found in the models will 
not be cleaned from the models, and the plot job will be cancelled.
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Section: Chainage Range

Use HG VG for min, max determines whether the horizontal geometry (HG) and the vertical 
geometry (VG) are both used to determine the minimum and maximum chainages for drawing. 
This allows the vertical geometry to be plotted when it is outside the horizontal geometry (e.g. 
kerb returns).

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use HG and VG to determine min/max chainage

use_hg_vg_for_min_max tick box

if ticked, the min/max chainage will be determined by the Horizontal and Vertical geometry.

Title Block
Section_Long_Plot_Title_block

Common title block parameters
Panel field Parameter name Type

Standard title plot_border tick box

if ticked, a standard 12d title block will be used.

Use title file use_title_file tick box

if ticked, a user defined title file is used.

Title line 1 title_1 input

if  Standard title is ticked, Title line 1 is the first line of title text. If  Use title file is ticked, Title line 1 
is substituted for the title block variable $title_1.

Title line 2 title_2 input

if  Standard title is ticked, Title line 2 is the second line of title text. If  Use title file is ticked, Title line 
2 is substituted for the title block variable $title_2.

12d default title block parameters
Panel field Parameter name Type Pop-Up

Text size title_text_size input

text size of title text.

Text colour title_colour colour available colours

colour of title text.

Section_Long_Plot_Title_block_User_title_info

User title info
The parameters shown below are subject to the appropriate title block variables existing in the title file. For 
more information on these variables see the section “Title Block Variables” .

Panel field Parameter name Type Pop-Up

Title file title_file file box available title files

specifies the name of the title file to use. If a valid title file exists, the specified Name values will be 
filled out in the grid using the title block variable $user_text_n.

Name output
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the alias for the nth user text specified in the title file.

Value user_text_n input

the alias text to be substituted in for the user text specified.

Time format time_format input

the time format relates to the $time title block variable. For more information on the time formats see 
the section “Specifying the Format for $time” .

Start page number start_page_number input

used as the starting value for the title block variable $page_number. If missing, $page_number starts at 
1.

Start drawing number start_drawing_number input

used as the starting value for the title block variable $drawing_number. If missing, $drawing_number 
starts at 1.

Drawing number prefix drawing_number_prefix input

the value entered is used for the title block variable $drawing_number_prefix.

Drawing number postfix drawing_number_postfix input

the value entered is used for the title block variable $drawing_number_postfix.

Plot Sheet Layout
Section_Long_Plot_Plot_sheet_layout

Section_long_Plot_Plot_sheet_layout_Margins

Margins
Section: Margins For Standard 12d Title File - Border gaps

If the default 12d title block is used, then the size of the bottom of title block depends on the text size. The 
following parameters are used in the default title block case and the bottom_border_gap is added to the 
calculated height of the bottom of the title block.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Left (mm) left_border_gap input

left border gap (in millimetres).

Right (mm) right_border_gap input

right border gap (in millimetres).

Top (mm) top_border_gap input

top border gap (in millimetres).

Bottom (mm) bottom_border_gap input

bottom border gap (in millimetres). 
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Section: Margins For User Title File

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Left (mm) left_margin input

left margin (in millimetres).

Right (mm) right_margin input

right margin (in millimetres).

Top (mm) top_margin input

top margin (in millimetres).

Bottom (mm) bottom_margin input

bottom margin (in millimetres).

top_border_gap

bottom_border_gap
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sheet width

(0,0)

long section plot area is inside the dashed lines

Definition of Plotting Areas for Default 12d Title Block

(left_border_gap,bottom_border_gap + title block)

size depends on text size in the default 12d title block
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Because the user can easily select from the plotting panel whether a User Defined Title Block or the 
default 12d title block is used, both sets of margin and gap parameters can exist in the one plot parameter 
file.

The (left_margin,bottom_margin) defines the left hand corner position of the long plot on the plot sheet.

The right_margin and top_margin need not be set and if missing, will be calculated from the other plot 
parameters defining the plot layout.

If the sheet sizes are missing, they will also be automatically calculated.

Pagination
Section_Long_Plot_Pagination

Pagination
If the long section plot is too long to fit on one page, it can be broken into a number of pages (sheets).

The parameter, pagination_length, controls the amount of new chainage length on each plot page. Each 
page of the long section plot can also included a set chainage amount from the end of the previous plot.

Hence apart from the first page and possibly the last page, the plot will have a chainage length given by the 
sum of the pagination_length and pagination_overlap.

Section: Pagination Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use pagination pagination tick box

if ticked, then break the plot into pages.

Pagination mode pagination_mode choice chainage

top_margin

bottom_margin
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sheet width

(left_margin,bottom_margin)

(0,0)

long section plot area is inside the dashed lines

Definition of Plotting Areas for User Defined Title Blocks
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millimetres

length and overlap units.

Chainage length pagination_length input

 new chainage range on each page.

Chainage overlap pagination_overlap input

overlap between pages.

Note
The pagination_length and pagination_overlap are given in chainage units or millimetres.The user must 
choose values which will fit on the selected sheet size or the end of each plot will be truncated by the sheet.
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Boxes
Section_Long_Plot_Boxes

Boxes
Each string in the long section plot can be labelled with one or two lines of title, and the chainages/heights/
depths at the user specified chainages for the strings.

The title for the strings, is drawn in the title area of the boxes area.

The chainages/heights/depths are drawn in the heights area of the boxes area.

Consequently the boxes area is made up of rows of text consisting of:

 string/tin titles followed by the chainage/height/depth values along the string.

Each row is surrounded by lines to form a box.

The default order of the boxes from the bottom up is

(a) optional super-elevation diagram

(b) chainage values

(c) can be primary string heights - user choice

(d) tin heights and depths

(e) offset heights and depths

(f) optional volumes or earth works

(g) can be primary string heights - user choice

(h) zero or more blank boxes

Section: Linework Parameters

Field Description Parameter name Type Pop-Up

Draw box mode draw_box_mode choice box Do not draw any box lines

Draw box lines around

height area only

Draw box lines around

title and height area only

Use parameters defined in

boxes - heights

mode for drawing the boxes for the long section plot.

Default box colour box_colour colour box

boxes for long section plot

title
area

heights
area

chainage values

tin depths

primary (design)
heights

chainage title
tin title

primary string title
tin depth title

tin heights
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 default box colour

Number of blank boxes number_of_blank_boxes input

 number of boxes to be left blank

The blank boxes are used to place other information in (such as horizontal or vertical geometry) or for 
other user supplied information. 

Section: Primary String Parameters

The primary string (the design string) is used to define

(a) the design long section

(b) the chainage positions for labelling heights and drawing uprights

(c) the section line used for sectioning through tins

(d) the section line for defining the corridor for services

Although the primary string is used to set up most of the information for the long section plot, it doesn’t 
have to be drawn on the long section. 

The drawing or not drawing of the primary string on each cross section plot is controlled by the parameter 
primary_string.

The colour of the primary string in the plot is the actual primary string colour.

Sometimes the primary string is only required to define chainages or the horizontal path for tin sections. In 
this case, the primary string would not be drawn on the long section plot.

If the primary string is drawn, it is automatically labelled.

Also the drawing of crosses at the vertical intersection points can be controlled from the ppf file.

Draw and label the primary stringprimary_string tick box

 if ticked, the primary string will be drawn and labelled.

Draw crosses at VIP’s primary_draw_vips tick box

 if ticked, crosses will be draw at the vertical intersection points.

The position of the primary string label box can be either straight after the chainage box, or after the tin 
and offset boxes but before the blank boxes.

Placing the primary string label before the bank boxes or just after the chainage box in controlled by the 
parameter primary_label_mode.

Primary string location primary_label_mode choice box in last box before blank

 boxes

in first box above chainages

 position of the primary string label.

Although the order of the boxes may appear to be fixed, in practice they can be in any order. This is 
possible because for each box, there is a parameter to set the height in millimetres from the bottom of all 
the boxes that the text in the box is drawn at (the _y_pos parameters).

The roundoff for the datum value is specified by the user (default 1.0) and the datum is automatically 
calculated for each sub-plot, and labelled.

Section_Long_Plot_Boxes_Title_area

Title Area
Section: Boxes - Title Area Parameters
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The title area starts at the co-ordinate (left_margin,bottom_margin).

The size of the title text is given by the title_box_text_size parameter.

The width of the title area is either given by the space_for_titles parameter, or if omitted, the required 
width is automatically calculated.

Field Description Parameter name Type Pop-Up

Size of titles (mm) title_box_text_size input

size of offset, height label and values

Space for titles (mm) space_for_titles input

size of title area.

The x position of the title text is the same for all the lines of title text and can be set to be a fixed distance 
from the left hand side of the boxes.

X adjustment (mm) box_titles_x input

distance to move the title text from the left hand side of the boxes

The y position of the title text can be set separately for each type of title. The parameters are given later 
under each of the title types (e.g. chainages, primary string, tins, depths etc.).

After the title area there can be a user defined gap, followed by the heights area

Distance between title and heights area (mm)box_gap input

distance between title and heights area in mm.

The height text is written at right angles to the bottom of the boxes. It can be either top or bottom justified 
with respect to the box (box_text_justification).

Section_Long_Plot_Boxes_Heights_area

Heights Area
Section: Boxes - Height Parameters

The heights area starts at the end of the title area.

The height text is written at right angles to the bottom of the boxes. It can be either top or bottom justified 
with respect to the box (box_text_justification).

The number of decimal places (number_of_decimals), and the size of the heights text (box_text_size) can 
be specified globally but there is a parameter for each box which overrides these defaults for each box of 
heights.

Field Description Parameter name Type Pop-Up

Justification box_text_justification choice box bottom of individual boxes

top of individual boxes

justification of height text.

Number of decimals number_of_decimals input

number of decimal places in the height boxes. If <0, the absolute value is taken as the number of 
decimal places i.e. no trailing zeros are removed for the values in the heights area.

Text size (mm) box_text_size input

distance to move the title text from the left hand side of the boxes

Horizontal line spacing (mm)

horizontal_line_spacing input
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height of the individual height boxes.

A global height for the individual boxes is either given by the horizontal_line_spacing parameter, or if 
omitted, a height to fit the largest height or depth value is calculated and used as the default box height.

However, the height of each box can be individually set by parameters box_size_n where the boxing 
numbering, n. starts from the bottom box. The value of horizontal_line_spacing is used for any of the 
box_size_n parameters not specified.

Box # input

specifying the nth value

Size (mm) box_size_n input

height of the nth box, numbered from bottom up.

The total height of the boxes area is simply given by the sum of the heights of each box.

The width of the heights area is determined by the number of chainages to be labelled and whether the 
values are staggered to prevent over writing.

Hence the total width of the boxes area is the width of the title area plus box_gap, plus the width of the 
heights area.

Many distance definitions in the plot parameter file are given in terms of distance above the top of the 
boxes area so that the distances are independent of the number of boxes and box sizes.

Section_Long_Plot_Boxes_Outside_linework

Outside Linework

The drawing of the box line work, the box colour, the position of the primary string labels and the number 
of blank boxes are all set by parameters.

Section: Boxes - Outside Linework Parameters

Field Description Parameter name Type Pop-Up

Draw the left side of title area(1)

draw_box_side_1 tick box

if ticked, draw the left side of the title area (def).

Draw the top line of title area(2)

draw_box_side_2 tick box

boxes for long section plot

heights

area

space_for_titles

horizontal_line_spacing

bottom_margin

le
ft

_m
ar

gi
n

chainage title

tin title

primary string title

or

box_size_1

box_size_2

box_size_n

...
...

box_gap

box_titles_x
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if ticked, draw the top line of the title area (def).

Draw the top line of title area(3)

draw_box_side_3 tick box

if ticked, draw right side of the title area (def).

Draw the bottom line of title area(4)

draw_box_side_4 tick box

if ticked, draw the bottom line of the title area (def).

Draw the left side of heights area(5)

draw_box_side_5 tick box

if ticked, draw the left side of the heights area (def).

Draw the top line of heights area(6)

draw_box_side_6 tick box

if ticked, draw the top line of the heights area (def).

Draw right side of heights area(7)

draw_box_side_7 tick box

if ticked, draw right side of the heights area (def).

Draw bottom side of heights area(8)

draw_box_side_8 tick box

if ticked, draw bottom side of the heights area (def).

Colour (1) box_side_colour_1 colour box

colour to draw left side of title area

Colour (2) box_side_colour_2 colour box

colour to draw top of title area

Colour (3) box_side_colour_3 colour box

colour to draw right side of title area

Colour (4) box_side_colour_4 colour box

colour to draw bottom of title area

Colour (5) box_side_colour_5 colour box

colour to draw left side of heights area

Colour (6) box_side_colour_6 colour box

colour to draw top of heights area

Colour (7) box_side_colour_7 colour box

colour for right side of heights area

Colour (8) box_side_colour_8 colour box

colour for bottom of heights area
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Section_Long_Plot_Boxes_Inside_linework

Inside Linework
Section: Boxes - Inside Linework Parameters

The lines at the top of the individual boxes inside the title area and heights area (separation lines) are 
controlled by the parameters box_line_draw_mode and box_line_mode_n. 

The separation lines can be drawn just in the title area, just in the heights area or in both areas.

The parameter box_line_draw_mode can be set to control all the separation lines but there are additional 
parameters, box_line_mode_n, which override box_line_draw_mode for each of the individual boxes 
where n = 1, ... number of boxes -1. 

The top of the top box is not controlled by box_line_mode_n but is controlled by the parameters 
draw_box_side_2 and draw_box_side_6.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Separation line mode box_line_draw_mode choice box Do not draw any separation

lines                

Draw the separation lines in 

both areas 

Draw the separation lines in

the title area only

Draw the separation lines in

 the heights area only

the separation line draw mode.

Box # input

Where box # = 1 to number of boxes(n). Box 1 is the bottom box, increasing upwards.

Line mode box_line_mode_n choice box No top line for title or height

area (mode=0)

Draw top line for title or

height area (mode=1) 

Draw top line for title area

heights

area

space_for_titles

horizontal_line_spacing or

box_size_1

box_size_2

box_size_n

...
...

box_gap

1 3

2

4

5

6

8

7

lines to draw for draw_box_side_1 to draw_box_side_8

title

area
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only (mode=2)

Draw top line for height area

only (mode=3)

line mode for top of title and height areas for box number specified.

Section_Long_Plot_Boxes_Chainage_titles_values

Chainage Titles/Values
Section: Chainage Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Title line 1 chainage_title input

1st line of chainage title.

Title line 2 chainage_title_2 input

 second line of chainage title.

Textstyle chainage_title_textstyle text box

textstyle for the chainage title

Colour chainage_title_colour colour box

colour of the chainage title

Text size (mm) chainage_title_size input

size of the chainage title

Text y position (mm) chainage_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the chainage title text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the chainage.

Section: Chainage Value Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Decimal places chainage_decimals input

number of decimal places for chainages

heights

area

draw this line for box_line_mode_1 = 1 or 3

values for box_line_mode_n

title

area

draw this line for box_line_mode_2 = 1 or 3

draw this line for
box_line_mode_1 = 1 or 2
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Textstyle chainage_textstyle text box

textstyle for the chainage values

Colour chainage_colour colour box

colour of the chainage values

Text size (mm) chainage_size input

size of the chainage values

Text y position (mm) chainage_y_pos input

if set, the height in mm above the bottom of all the boxes that the chainage values are drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the chainage.

Section_Long_Plot_Boxes_Primary_string_titles_heights

Primary String Titles/Heights
Sometimes the primary string is only required to define chainages or the horizontal path for tin sections. In 
this case, the primary string would not be drawn on the long section plot.

If the primary string is drawn, it is automatically labelled.

Also the drawing of crosses at the vertical intersection points can be controlled from the ppf file.

Section: Primary String Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Title line primary_title input

1st line of string title.

Title line 2 primary_title_2 input

 second line of string title. Default is primary string name.

Textstyle primary_title_textstyle text box

textstyle for the primary string title

Colour primary_title_colour colour box

colour of the primary string title

Text size (mm) primary_title_size input

size of the string title

Text y position (mm) primary_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the primary string title text is drawn. If 
not set, then the text is placed at a height that puts it inside the default box for the primary string.

Section: Primary String Height Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Decimal places primary_decimals input

number of decimal places for height values.

Textstyle primary_textstyle text box

textstyle for the height values
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Colour primary_colour colour box

colour of the height values

Text size (mm) primary_size input

size of the height values

Text y position (mm) primary_y_pos input

if set, the height in mm above the bottom of all the boxes that the primary string height values are 
drawn. If not set, then the text is placed at a height that puts it inside the default box for the primary 
string.

Search dist when no z (m) primary_ch_tolerance input

for a given chainage, if no z value exists, this distance is added to/subtracted from the chainage to 
search for a valid z value.
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Tin Titles/Heights/Depths
Section_Long_Plot_Boxes_Tin_titles_heights_depths

Tin Titles/Heights/Depths
Section: Tin Titles/Heights/Depths Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Label depth default label_depths tick box

if ticked, the depths are labelled.

Define tin set # input

where n = 1 to.... The set enables the specification of a number of parameters for a number of specified 
tin names.

Tin name tin_n_name tin box available tins

the name of the nth tin to be used for labelling.

 If a tin of the name given by tin_n_name does not exist, then the plot is not produced and an error 
message is given.

Tin draw mode tin_n_draw_mode choice box Draw the tin

Do not draw the tin

draw tin mode for the nth tin specified by tin set #.

Tin colour tin_n_draw_colour colour box

tin colour mode for the nth tin specified by tin set #.

Tin label mode tin_n_label choice box Label the tin

Do not label the tin

tin label mode for the nth tin specified by tin set #.

Section_Long_Plot_Boxes_Tin_titles_heights_depths_Titles

Titles
Section: Tin - Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use tin set # input

set number to be used to define sets of tin parameters i.e. n value

First line of tin title tin_n_title input

first line of nth tin title

Second line of tin title tin_n_title_2 input

second line of nth tin title

Tin title textstyle tin_n_title_textstyle text box

nth tin title textstyle

Tin title colour tin_n_title_colour colour box

nth tin title colour
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Tin title size (mm) tin_n_title_size input

nth tin title size

Title Y position (mm) tin_n_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the nth tin title text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the tin heights.

Section_Long_Plot_Boxes_Tin_titles_heights_depths_Heights

Heights
Section: Tin - Height Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use tin set # input

set number to be used to define sets of tin parameters i.e. n value

Decimals tin_n_decimals input

 number of dec places in nth tin height. < 0 to keep all trailing zeros

Textstyle tin_n_textstyle text box

textstyle of nth tin height

Colour tin_n_colour colour box

nth tin height and depth colour

Size (mm) tin_n_size input

nth tin height size

Y pos (mm) tin_n_y_pos input

if set, the height in mm above the bottom of all the boxes that the tin height text is drawn.If not set, then 
the text is placed at a height that puts it inside the default box for the tin heights.

Section_Long_Plot_Boxes_Tin_titles_heights_depths_Depths

Tin Depths
Section: Tin Depth Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use tin set # input

set number to be used to define sets of tin parameters i.e. n value

Depth label mode tin_n_depth_label choice box Label depths

Do not label depths

depth label mode for the nth tin specified by set #.

First line of tin depth title tin_n_depth_title input

first line of nth tin depth title

Second line of tin depth title tin_n_depth_title_2 input

second line of nth tin depth title

Depth title textstyle tin_n_depth_title_textstyletext box
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nth tin depth title textstyle

Depth title colour tin_n_depth_title_colour colour box

nth tin depth title colour

Depth title size (mm) tin_n_depth_title_size input

nth tin depth title size

Depth title Y position (mm) tin_n_depth_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the tin depth title text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the tin heights. 

Decimals in depth value tin_n_depth_decimals input

 number of dec places in tin height. < 0 to keep all trailing zeros

Depth value textstyle tin_n_depth_textstyle text box

nth tin depth textstyle

Depth value colour tin_n_depth_colour colour box

nth tin depth colour

Depth value size (mm) tin_n_depth_size input

nth tin depth size

Depth value Y position (mm) tin_n_depth_y_pos input

if set, the height in mm above the bottom of all the boxes that the tin depth text is drawn. If not set, then 
the text is placed at a height that puts it inside the default box for the tin heights.

Multiplier for positive depths depth_positive_factor input

if set, this value will be used to multiply positive depth values.

Multiplier for negative depths depth_negative_factorinput

if set, this value will be used to multiply negative depth values.

The depth from the primary string to a tin, at a particular offset is defined as

depth = tin height value - height of the primary string

That is, the depth that the primary string is below the tin.

Before plotting, the value of depth is multiplied by either the depth_positive_factor or 
depth_negative_factor.

if (depth >= 0) plotted_depth_value = depth * depth_positive_factor

if (depth < 0) plotted_depth_value = depth * depth_negative_factor

Hence the definition of depth can be modified by the parameters:

depth_positive_factor value // multiplier for positive depths

depth_negative_factor value // multiplier for negative depths

For example, if the opposite sign is required for depth, that is,

depth     =     height of the primary string   -   tin height value

simply set

depth_positive_factor -1

depth_negative_factor- 1
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Offset String Titles/Heights/Depths
Section_Long_Plot_Boxes_Offset_string_titles_heights_depths

Offset String Titles/Heights/Depths
Section: Offset Titles/Heights/Depths Parameters

Each string in the offset model given can be automatically projected onto the primary string and drawn on 
the long section plot.

The offset model has been modified to allow strings to be projected onto the primary string to be specified 
by model and name, rather than just projecting all the strings in a given model. The string can also be 
labelled with either the string name, its model name or both.

The string is specified by 

offset_n_mask "model_name->string_name"

For each n, a set of plot parameters determine if the string’s heights and/or depths from the primary string 
are labelled in the boxes area.

If only the string_name is given, then the model given in the Offset model field of the Section Long Plot 
panel. 

If there is more than one string with the given model and name, then it will be considered to be one string 
and at any primary string chainage, the closest of the strings will be the part used for projecting. For 
example, strings of the same name on either side of a road intersection will be considered to be the one 
string for projecting.

If any offset_n_mask is used, then the Offset option expects all the strings to be specified by an 
offset_n_mask. Then if no mask exists for any value of n, then that parameter set is ignored and no string 
projected.

If no offset masks are used (that is, no offset_n_mask’s are used), then the plot parameters determine 
whether each string in the offset model is drawn, and if the string’s heights and depths from the primary 
string are labelled in the boxes area. The order that the strings are then plotted and labelled is the same as 
the order of the strings in the Offset model.

For the following sets of parameters, n takes the value 1 to 100 and specifies that the parameter set applies 
to the nth string given by offset_n_mask or, if no offset masks are given, the nth string in the Offset model.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Default offset model offset_model model box

default offset model.

Define set # input

where n = 1 to.... The set enables the specification of a number of parameters for a number of specified 
tin names.

Offset mask offset_n_mask input

the value specified by model_name->string_name.

Offset draw mode offset_n_draw_mode choice box Draw the offset string

Do not draw the offset string

draw mode for offset string.

Left search distance offset_n_lw input

default 1000. Distance to search to the left of the primary string for the offset string. If 0, don’t search 
to the left.
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Right search distance offset_n_rw input

default 1000. Distance to search to the right of the primary string for the offset string. If 0, don’t search 
to the right.

Offset colour offset_n_draw_colour colour box

default offset string colour.

Offset label mode offset_n_label choice box Label the strings heights

Do not label the strings 
heights

offset string label mode.

Section_Long_Plot_Boxes_Offset_string_titles_heights_depths_Titles

Titles
Section: Offset String - Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

The default title for each set each parameter set, is the string name but this can be changed to just the 
model name or the model and string name:

Offset string mode offset_title_mode choice box Label with string name

Label with model name

Label with model->string as

name

offset string title mode.

Use set # input

set number to be used to define sets of offset parameters i.e. n value

or, for any set, the offset_title_mode can be replaced by two lines of user defined title:

First line of offset title offset_n_title input

first line of nth offset title

Second line of offset title offset_n_title_2 input

second line of nth offset title

title textstyle offset_n_title_textstyle text box

nth offset title textstyle

Title colour offset_n_title_colour colour box

nth offset title colour

Title size (mm) offset_n_title_size input

nth offset title size

Title Y position (mm) offset_n_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the offset title text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the offset heights.

Section_Long_Plot_Boxes_Offset_string_titles_heights_depths_Heights
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Heights
Section: Offset String - Height Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set number to be used to define sets of offset parameters i.e. n value

Decimals offset_n_decimals input

 number of dec places in nth offset height. < 0 to keep all trailing zeros

Textstyle offset_n_textstyle text box

textstyle of nth offset height

Colour offset_n_colour colour box

nth offset height and depth colour

Size (mm) offset_n_size input

nth offset height size

Y pos (mm) offset_n_y_pos input

if set, the height in mm above the bottom of all the boxes that the offset height text is drawn.If not set, 
then the text is placed at a height that puts it inside the default box for the offset heights.

Section_Long_Plot_Boxes_Offset_string_titles_heights_depths_Depths

Depths
Section: Offset String - Depth Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set number to be used to define sets of offset parameters i.e. n value

Depth label mode offset_n_depth_label choice box Label depths

Do not label depths

depth label mode for the nth offset specified by set #.

First line of depth title offset_n_depth_title input

first line of nth offset depth title

Second line of depth title offset_n_depth_title_2 input

second line of nth offset depth title

Depth title textstyle offset_n_depth_title_textstyle text box

nth offset depth title textstyle

Depth title colour offset_n_depth_title_colour colour box

nth offset depth title colour

Depth title size (mm) offset_n_depth_title_size input

nth offset depth title size

Depth title Y position (mm) offset_n_depth_title_y_pos input
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if set, the height in mm above the bottom of all the boxes that the offset depth title text is drawn. If not 
set, then the text is placed at a height that puts it inside the default box for the offset heights.

Decimals in depth value offset_n_depth_decimals input

 number of dec places in offset height. < 0 to keep all trailing zeros

Depth value textstyle offset_n_depth_textstyle text box

nth offset depth textstyle

Depth value colour offset_n_depth_colour colour box

nth offset depth colour

Depth value size (mm) offset_n_size input

nth offset depth size

Depth value Y position (mm) offset_n_depth_y_pos input

if set, the height in mm above the bottom of all the boxes that the offset depth text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the offset heights.
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Offset String chainages
Section_Long_Plot_Boxes_Offset_string_chainages

Offset String Chainages
Section: Offset String - Chainage Parameters

The fields and buttons used in this section have the following functions for the nth defined offset 
string.

Field Description Parameter name Type Pop-Up

Use String chainage_n_offset_mode tick box

if ticked, use offset string.

Offset String chainage_n_offset_string select box

the value specified by model_name->string_name.

Title line 1 chainage_n_title input

1st line of offset chainage title.

Title line 2 chainage_n_title_2 input

 second line of offset chainage title.

Textstyle chainage_n_title_textstyletext box

textstyle for the offset chainage title

Colour chainage_n_title_colour colour box

colour of the offset chainage title

Text size (mm) chainage_n_title_size input

size of the offset chainage title

Text y position (mm) chainage_n_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the offset chainage title text is drawn. If 
not set, then the text is placed at a height that puts it inside the default box for the chainage.

Decimal places chainage_n_decimals input

number of decimal places for offset chainages

Textstyle chainage_n_textstyle text box

textstyle for the offset chainage values

Colour chainage_n_colour colour box

colour of the offset chainage values

Text size (mm) chainage_n_size input

size of the offset chainage values

Text y position (mm) chainage_n_y_pos input

if set, the height in mm above the bottom of all the boxes that the offset chainage values are drawn. If 
not set, then the text is placed at a height that puts it inside the default box for the chainage.
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Super Elevation Diagram
Section_Long_Plot_Boxes_Super_elevation_diagram

Super Elevation Diagram
Section: Super Elevation Diagram Parameters

The optional super-elevation diagram draws the values of the cross-fall (x-fall) between two strings using 
the primary string as the reference string. The cross-fall at a given chainage on the primary string is 
calculated by sectioning perpendicular to the reference string at that chainage and cutting the two strings. 
The cross-fall is defined as the cross-fall between the two cuts points on the strings.

The diagram has levels for the cross fall for a pair of strings on the left of the primary string, and a pair of 
strings on the right of the primary string. The diagram also has uprights in the super-elevation box with 
chainage values at the change of super values.

For the left hand side, the cross-fall is calculated at right angles to the primary string between the user 
given left hinge string and the left edge string.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Super elevation diagram draw mode

super_draw_mode choice box don’t draw diagram

mode = 1 draw diagram using super

sample interval

mode = 2 sample super using 

chainages of x-sec’s

mode = 3 sample super using 

chainages from a string

super elevation diagram draw mode.

Super sample interval super_sample_interval input

if mode = 1, Chainage distance to sample x-fall. (default 20)

Super sample name super_sample_name input

name to be used in sampling. If mode = 2, name = model_name.

Super Elevation

super_title_y_pos

Bottom of the boxes

box_title_x
LHS 3%

RHS -5%

RHS 5%

LHS 1%

LHS and RHS 5%

0.
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super_ch_x

super_ch_y

super_xfall_y

super_xfall_x

super uprights

super cl

super common linesuper left line super right lineTitle area

super chainage
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If mode = 3, name = model_name->string_name

Super tolerance super_tolerance input

If super_draw_mode is 1, the change of super is greater than super_tolerance, draw uprights

Section_Long_Plot_Boxes_Super_elevation_diagram_Titles

Titles
Section: Super Elevation Diagram - Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

 First line of super title super_title input

1st line of the super title

Super title textstyle super_title_textstyle text box

textstyle of super title

Super title colour super_title_colour colour box

colour of super title

Super title size (mm) super_title_size input

size of super title

Super title Y position (mm) super_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the super title text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the super.

Section_Long_Plot_Boxes_Super_elevation_diagram_X_fall

X-Fall
Section: Super Elevation Diagram - X-Fall Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

X-fall textstyle super_xfall_textstyle text box

textstyle of super title

X-fall colour super_xfall_colour colour box

colour of super title

X-fall size (mm) super_xfall_size input

size of super title

X-fall X position (mm) super_xfall_x input

the distance to the right from the super chainage uprights to the start of the x-fall text.

X-fall Y position (mm) super_xfall_y input

if set, the height in mm above the bottom of all the boxes that the super x-fall text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the super.

Section_Long_Plot_Boxes_Super_elevation_diagram_Chainage
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Chainage
Section: Super Elevation Diagram - Chainage Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Chainage textstyle super_ch_textstyle text box

textstyle of super chainage title

Chainage colour super_ch_colour colour box

colour of super chainage title

Chainage size (mm) super_ch_size input

size of super chainage title

Chainage X position (mm) super_ch_x input

the distance to the right from the super chainage uprights to the start of the super chainage text.

Chainage Y position (mm) super_ch_y input

if set, the height in mm below the bottom of all the boxes that the super chainage is finished.

Chainage decimal places super_ch_decimals input

 number of dec places in super chainage

Section_Long_Plot_Boxes_Super_elevation_diagram_Left_side

Left Side
Section: Super Elevation Diagram - Left Side Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Left hinge string super_hinge_name_left select box

left hinge string. (model_name->string_name)

Left edge string super_edge_name_left select box

left edge string. (model_name->string_name)

Super left linestyle super_left_linestyle linestyle box

linestyle of super left line.

Super left line colour super_left_line_colour colour box

colour of super left line.

Super left decimal places super_left_decimals input

 number of dec places in super left x-fall value

Text before left X-fall value super_left_pre input

text before super left x-fall value.

Text after left X-fall value super_left_post input

text after super left x-fall value.

Section_Long_Plot_Boxes_Super_elevation_diagram_Right_side
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Right Side
Section: Super Elevation Diagram - Right Side Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Right hinge string super_hinge_name_right select box

right hinge string. (model_name->string_name)

Right edge string super_edge_name_right select box

right edge string. (model_name->string_name)

Super right linestyle super_right_linestyle linestyle box

linestyle of super right line.

Super right line colour super_right_line_colour colour box

colour of super right line.

Super right decimal places super_right_decimals input

 number of dec places in super right x-fall value

Text before right X-fall value super_right_pre input

text before super right x-fall value.

Text after right X-fall value super_right_post input

text after super right x-fall value.

Section_Long_Plot_Boxes_Super_elevation_diagram_Centre_line

Centre Line
Section: Super Elevation Diagram - Centre line Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Super centre linestyle super_cl_linestyle linestyle box

super centre line linestyle.

Super centre line colour super_cl_line_colour colour box

super centre line colour.

Section_Long_Plot_Boxes_Super_elevation_diagram_Common_X_fall

Common X-Fall
Section: Super Elevation Diagram - Common X-Fall Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Text before common X-fall value

super_common_pre input

text before super common x-fall value.

Text after common X-fall value
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super_common_post input

text after super common x-fall value.

Super common linestyle super_common_linestyle linestyle box

super common linestyle.

Super common line colour

super_common_line_colour colour box

super common colour.

Super common decimal places

super_common_decimals input

 number of decimal places in super common x-fall value

Section_Long_Plot_Boxes_Super_elevation_diagram_Uprights

Uprights
Section: Super Elevation Diagram - Upright Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Upright mode super_upright_mode choice box for left string only

for right string only

for both strings

upright mode for super elevation diagram.

Super uprights colour super_upright_colour colour box

super upright colour.
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Volume Cut/Fill
Section_Long_Plot_Boxes_Volume_cut_fill

Volume Cut/Fill
Section: Volume Cut/Fill Parameters

The values of calculated cut and fill volumes (cut and fill earth works) can be read from a file and then 
interpolated to produce cut and fill volumes for a given interval along the primary string.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Draw a volume diagram volume_draw_mode tick box

if ticked, draw a volume diagram.

Cut and fill text position volume_text_centre_modechoice box along the uprights

between the uprights

position of cut and fill text relative to the uprights.

Sample interval volume_sample_interval input

interval to display volumes.

Report file volume_file_name report box

name of volumes report file.

Box Y position (mm) volume_y_pos input

if set, the volume box is positioned at this height from the bottom of the first box

Box size (mm) volume_box_size input

if set, upright, volumes and titles box height.

Horizontal cut/fill dividing line linestyle

volume_cl_linestyle linestyle box

linestyle of the cut/fill dividing line.

Horizontal cut/fill dividing line colour

volume_cl_line_colour colour box

colour of the cut/fill dividing line.

Section_Long_Plot_Boxes_Volume_cut_fill_Titles

Titles
Section: Volumes Cut/Fill - Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

 First line of volume title volume_title input

1st line of the volume title

Volume title textstyle volume_title_textstyle text box

textstyle of volume title

Volume title colour volume_title_colour colour box

colour of volume title
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Volume title size (mm) volume_title_size input

size of volume title

Volume title Y position (mm) volume_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the volume title text is drawn. If not set, 
then the text is placed at a height that puts it inside the default box for the volumes.

Section_Long_Plot_Boxes_Volume_cut_fill_Titles_Cut

Cut
Section: Volumes Cut/Fill - Title Cut Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

 First line of volume cut title volume_cut_title input

1st line of the cut volume title

Volume cut title textstyle volume_cut_title_textstyle text box

textstyle of cut volume title

Volume cut title colour volume_cut_title_colour colour box

colour of cut volume title

Volume cut title size (mm) volume_cut_title_size input

size of cut volume title

Volume cut title Y position (mm) volume_cut_title_y input

if set, the height in mm above the default position. If not set, then the text is placed at a height that puts 
it inside the default box for the cut volumes.

Section_Long_Plot_Boxes_Volume_cut_fill_Titles_Fill

Fill
Section: Volumes Cut/Fill - Title Fill Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

 First line of volume fill title volume_fill_title input

1st line of the fill volume title

Volume fill title textstyle volume_fill_title_textstyle text box

textstyle of fill volume title

Volume fill title colour volume_fill_title_colour colour box

colour of fill volume title

Volume fill title size (mm) volume_fill_title_size input

size of fill volume title

Volume fill title Y position (mm) volume_fill_title_y input

if set, the height in mm above the default position. If not set, then the text is placed at a height that puts 
it inside the default box for the fill volumes.
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Section_Long_Plot_Boxes_Volume_cut_fill_Values

Values
Section: Volumes Cut/Fill - Cut Value Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Textstyle volume_cut_textstyle text box

textstyle of the cut values.

Colour volume_cut_text_colour colour box

colour of cut values

Size (mm) volume_cut_text_size input

size of cut values

X position (mm) volume_cut_text_x input

the x distance to move the cut text from the default cut text position, def 0, it is not used if 
volume_text_centre_mode= between the uprights

Y position (mm) volume_cut_text_y input

the y distance to move the cut text from the default cut text position

Decimal places volume_cut_decimals input

 number of dec places in cut values.

Section: Volumes Cut/Fill - Fill Value Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Textstyle volume_fill_textstyle text box

textstyle of the fill values.

Colour volume_fill_text_colour colour box

colour of fill values

Size (mm) volume_fill_text_size input

size of fill values

X position (mm) volume_fill_text_x input

the x distance to move the fill text from the default fill text position, def 0, it is not used if 
volume_text_centre_mode= between the uprights

Y position (mm) volume_fill_text_y input

the y distance to move the fill text from the default fill text position

Decimal places volume_fill_decimals input

 number of dec places in fill values.

Section_Long_Plot_Boxes_Volume_cut_fill_Uprights_Sub_uprights

Uprights/Sub Uprights
Section: Volumes Cut/Fill - Upright Parameters
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The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Draw cut/fill uprights volume_uprights_draw_mode

choice box don’t draw cut/fill uprights

draw cut/fill uprights

upright draw mode.

Colour of uprights volume_uprights_line_colour colour box

colour of uprights

Section: Volumes Cut/Fill - Sub Upright Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Colour of sub uprights volume_sub_upright_colourcolour box

colour of sub uprights line

Sub upright X position (mm) volume_sub_uprights_x input

the x distance to move from the default sub uprights position.

Sub upright title X position (mm) volume_sub_title_x input

the distance to move the sub title text from the volume sub uprights

Section_Long_Plot_Boxes_X_Y

X, Y
Section: X, Y Parameters

The values of the X and Y coordinate for selected chainages can be labelled as separate boxes.

The chainages specified are limited to the base set of chainages already defined in the chainage 
selection and staggering section. i.e. an upright must exist for the X and Y value to be labelled. 
Not all of the uprights have to be labelled, just those specified in this section.

Volume
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32
2.

87

975.45

533.24

40
3.

00

403.00

322.87

97
5.

45
53

3.
24

volume_sub_uprights_x

volume_title_y_pos

Bottom of the boxes

volume_y_pos

volume_cut_text_y
volume_cut_text_x

volume_fill_text_y

volume_cut_title_y

volume_cut_title_y

volume_fill_text_x

box_title_x

volume_sub_title_x



Chapter 24  PPF Editors

November 2002 Page 2483Long Plot PPF Editor

There are plot parameters to control all aspects of the X and Y labelling.

Chainages are used for positioning X and Y labels.

The chainages for the long section plot relate to the primary string and are controlled by a set of 
parameters.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

X, Y order xy_order choice box X before Y

Y before X

order to place X and Y boxes. X before Y indicates that the X box will appear closest to the bottom of 
the boxes and the Y box will be on top of it. Note: The boxes are placed from bottom to top.

Chord/arc chainage mode xy_chord_arc choice box Do not use chord/arc 
chainages

Use chord/arc chainages

mode to include chord/arc chainages.

Start chainage xy_start_chainage input box

start chainage of chainage range to be labelled.

End chainage xy_end_chainage input box

end chainage of chainage range to be labelled.

Chainage interval xy_interval input

the regular interval (0=no regulars).

Include tangents, spirals xy_label_hcp tick box

if ticked, include the tangents and spirals.

Include hip points xy_label_hip tick box

if ticked, include horizontal intersection points.

Include vip points xy_label_vip tick box

if ticked, include vertical intersection points.

Include tangent points xy_label_vtp tick box

if ticked, include tangent points.

Include crest points xy_label_crest tick box

if ticked, include crest points.

Include sag points xy_label_sag tick box

if ticked, include sag points.

Include change of vertical grade

xy_label_grade_change tick box

if ticked, include changes in vertical grade.

Chainage weeding tolerance

xy_label_tolerance input

if >0 then use as a weeding tolerance, if <=0 don’t weed.

Files of special chainages

xy_special_n_file file box
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 n = 1 to 20 - include chainages from the file (one chainage per line)

Section_Long_Plot_Boxes_X_Y_X_parameters

X Parameters
Section: X Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Label X values/titles x_label tick box

if ticked, the X values/titles will be labelled.

Section: X Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Title line 1 x_title input

1st line of X title.

Title line 2 x_title_2 input

 second line of X title.

Textstyle x_title_textstyle text box

textstyle for the X title

Colour x_title_colour colour box

colour of the X title

Text size (mm) x_title_size input

size of the X title

Text y position (mm) x_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the X title text is drawn. If not set, then the 
text is placed at a height that puts it inside the default box for the X labels.

Section: X Value Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Decimal places x_label_decimals input

number of decimal places for X values

Textstyle x_label_textstyle text box

textstyle for the X values

Colour x_label_colour colour box

colour of the X values

Text size (mm) x_label_size input

size of the X values
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Text y position (mm) x_label_y_pos input

if set, the height in mm above the bottom of all the boxes that the X values are drawn. If not set, then the 
text is placed at a height that puts it inside the default box for the X labels.

Section_Long_Plot_Boxes_X_Y_Y_parameters

Y Parameters
Section: Y Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Label Y values/titles y_label tick box

if ticked, the Y values/titles will be labelled.

Section: Y Title Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Title line 1 y_title input

1st line of Y title.

Title line 2 y_title_2 input

 second line of Y title.

Textstyle y_title_textstyle text box

textstyle for the Y title

Colour y_title_colour colour box

colour of the Y title

Text size (mm) y_title_size input

size of the Y title

Text y position (mm) y_title_y_pos input

if set, the height in mm above the bottom of all the boxes that the Y title text is drawn. If not set, then the 
text is placed at a height that puts it inside the default box for the Y labels.

Section: Y Value Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Decimal places y_label_decimals input

number of decimal places for Y values

Textstyle y_label_textstyle text box

textstyle for the Y values

Colour y_label_colour colour box

colour of the Y values

Text size (mm) y_label_size input
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size of the Y values

Text y position (mm) y_label_y_pos input

if set, the height in mm above the bottom of all the boxes that the Y values are drawn. If not set, then the 
text is placed at a height that puts it inside the default box for the Y labels.

Chainage/Staggering
Section_Long_Plot_Chainage_Staggering

Chainage/Staggering
Section: Chainage/Staggering - Chainage Parameters

Chainages are used for positioning height labels, uprights (leader lines) and bubbles. The chainages for the 
long section plot relate to the primary string

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Chord/arc chainage mode chord_arc choice box Do not use chord/arc 
chainages

Use chord/arc chainages

mode to include chord/arc chainages.

Chainage interval chainage_interval input

the regular interval (0=no regulars).

Include start and end chainages

chainage_label_ends tick box

if ticked, include the start and end chainages.

Include tangents, spirals chainage_label_hcp tick box

if ticked, include the tangents and spirals.

Include hip points chainage_label_hip tick box

if ticked, include horizontal intersection points.

Include vip points chainage_label_vip tick box

if ticked, include vertical intersection points.

Include tangent points chainage_label_vtp tick box

if ticked, include tangent points.

Include crest points chainage_label_crest tick box

if ticked, include crest points.

Include sag points chainage_label_sag tick box

if ticked, include sag points.

Include change of vertical grade chainage_label_grade_change tick box

if ticked, include changes in vertical grade.

Chainage weeding tolerance chainage_label_tolerance input

if >0 then use as a weeding tolerance, if <=0 don’t weed.

Merge in bubble chainages chainage_merge_bubbles tick box

if ticked, merge in bubble chainages.
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Weeding tolerance after bubble merge chainage_merge_tolerance input

if > 0, weed after merge using specified weeding tolerance. If <= 0, don’t weed after merge.

Files of special chainages chainage_special_n_file file box

 n = 1 to 20 - include chainages from the file (one chainage per line)

Section_Long_Plot_Chainage_Staggering_Staggering

Staggering
Section: Chainage/Staggering - Staggering Parameters

If the real chainage position is used for the horizontal position of the chainage/height/depth text, text over 
writing can easily occur.

To prevent over writing, the text can be staggered.

If the stagger_mode parameter is set to 1, the text position is adjusted so that the text does not over write.

The real chainage position is then indicated by the chainage markers which are drawn at the top of the text 
boxes from the staggered text position back to the actual chainage position of the text.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Stagger mode stagger_mode choice box no staggering, allow over

 writing

Stagger text

stagger mode.

Distance from boxes to top of staggers (mm)

stagger_gap_top input

distance from the top of boxes to top of staggers in mm.

Distance from boxes to bottom of staggers (mm)

stagger_gap_bottom input

distance from the top of boxes to bottom of staggers in mm.

Stagger gap factor stagger_gap_factor input

distance between staggers is box_text_size * stagger_gap_factor

When staggering occurs, it is possible for the heights area to be longer than the graph area.

long section plot

title
area top of boxes

stagger_gap_bottom
stagger_gap_top
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Uprights
Section_Long_Plot_Uprights

Uprights
Section: Upright Parameters

Uprights, or leader lines, can be drawn from the top of the staggers to the strings drawn on the plot.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Upright draw mode uprights_draw_mode choice box none

max string height

to stagger height

uprights_y above boxes

to primary string

tin 1

tin 2

tin 3

tin 4

tin 5

tin 6

tin 7

tin 8

tin 9

tin 10

to offset 1

to offset 2

to offset 3

to offset 4

to offset 5

to offset 6

to offset 7

to offset 8

to offset 9

to offset 10

upright draw mode.

Uprights Y distance (mm)  uprights_y input

distance to draw the uprights for uprights_draw_mode = "to uprights_y above boxes"

Uprights colour  uprights_colour colour box

uprights colour. Default is box_colour

Uprights bottom mode uprights_bottom_mode choice box stop at top of boxes

draw to bottom of boxes

draw to uprights_bottom_y 
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below top of boxes

draw to uprights_bottom_y

 above bottom of boxes

ticks at chainage

Upright draw mode below top of boxes.

Uprights bottom Y distance (mm)  uprights_bottom_y input

distance in mm.

Uprights text offset factor  uprights_text_offset_factor input

move the text by this factor*size.

When uprights go below the top of the boxes, the height and offset text is moved to the left so that the 
upright does not go through the text. The left hand side of the heights boxes also moves to the left to leave 
room for the height text.

long section plot

title
area

title
area

uprights can go to the

some where in between

bottom of the boxes

3.
0

6.
0

5.
0

4.
0

3.
0

6.
0

5.
0

4.
0

text is to the left
of the upright 

uprights can stop at the
top of the boxes, or

text is centred
on the upright 
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Datum Area
Section_Long_Plot_Datum_area

Datum Area
The datum area is the region between the boxes area and the graph area.

Section: Datum Area - Datum Value Mode

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use manual datum  manual_datum tick box

if ticked the datum will be calculated internally, else use the datum_value parameter for the datum.

Datum value  datum_value input

the value to be used for the datum.

Datum roundoff  datum_roundoff input

the value to roundoff the datum value.

Decimal places for datum  datum_decimals input

If > 0, trailing zeros are removed after the decimal point. If <0, the absolute value is taken as the 
number of decimal places to report i.e. no trailing zeros are removed

Section: Datum Area - Other Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Datum name datum_name input

 text to write before the datum value

Graph area to datum line gap (mm)

datum_above_gap input

 distance from the bottom of the graph area to the datum line.

Datum line gap to top of boxes (mm)

datum_below_gap input

 distance from datum line to top of boxes.

The datum line is positioned the distance datum_below_gap above the top of the boxes area and the graph 
area is positioned the distance datum_above_gap above the datum line.

Hence the graph area is distance (datum_below_gap + datum_above_gap) above the top of the boxes area.

The datum_below_gap and datum_above_gap can be zero or positive.

Datum linestyle datum_linestyle linestyle box

datum line linestyle (default solid)

Datum textstyle datum_textstyle text box

textstyle for datum information

Datum text size (mm) datum_text_size input

size of datum text and value (mm)

Datum colour datum_colour colour box
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colour of the datum text and line.

X adjustment (mm) datum_x input

distance to move the datum text along the datum line

Y adjustment (mm) datum_y input

distance to raise the datum text above the datum line 

boxes area

graph area

datum_below_gap

datum_above_gap

DATUM INFO

datum_y

da
tu

m
_x

DATUM INFO
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Graph Area
Section_Long_Plot_Graph_area

Graph Area
The graph area sits on top of the boxes and datum areas, so there may not be enough room left on the sheet 
for the full plot height. In this case, the plot will be truncated at the top of the allowed graph area.

Section: Graph Area - Extra space parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Extra space units extra_space_units choice box world units

millimetres

units for specifying extra space.

Extra space left (units) extra_space_left input

distance to subtract from left of plot area

Extra space right (units) extra_space_right input

distance to add to right of plot area

Extra space top (units) extra_space_top input

distance to add to top of plot area

Extra space bottom (units) extra_space_bottom input

distance to subtract from bottom of plot area

title
area

extra_space_top

final graph box taking
extra space into consideration 

extra_space_bottom

ex
tr

a_
sp

ac
e_

le
ft

ex
tr

a_
sp

ac
e_

ri
gh

t
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Corridors
Section_Long_Plot_Corridors

A corridor around the primary string is defined by giving a left and right corridor width.

Any string in a model added to the section view is checked to see if it appears in the corridor, and if it does, 
it is drawn on the long section plot.

To be drawn, strings do not have to cross the primary string, but just be in the corridor.

Panel field Parameter name Type

Left corridor width (world units)
corridor_width_left input

left corridor width

Right corridor width (world units)
corridor_width_right input

right corridor width

Left corridor overlap (world units)
corridor_overlap_left input

left corridor overlap

Right corridor overlap (world units)
corridor_overlap_right input

right corridor overlap

Chord-arc tolerance (world units)
corridor_chord_arc input

chord-arc tolerance used near any bends in the corridor.

Section_Long_Plot_Corridors_Model_selectionModel selection
Panel field Parameter name Type

Corridor model corridor_model_n model box

models containing tins and service strings to be drawn on the section. Where n = 1, 2, ... ,100 given by 
line number on grid.

primary string corridor_width_left

corridor_width_right

pipe string
strings (no diameter)

plan view

(design long section)

tin (natural surface)

design long section

services in
the corridor

section view
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Bubbles
Section_Long_Plot_Bubbles

Bubbles
Section: Bubble Definition Parameters

Circles with the string name and a unique number (bubbles) can be drawn on the long section plot. 
Bubbles are normally used for lip profiles.

The chainages used for the bubbles are given by a set of parameters similar to the chainage parameters. 
The resulting set of bubbles are sequentially numbered (starting with one) in chainage order.

Although many bubbles can be defined by the bubble parameters, a bubble is only drawn on the plot if 
there is a labelled chainage to draw it above.

Hence not all bubbles given by the bubble chainage parameters are drawn but for the ones that are drawn, 
the bubble number is taken from the full bubble set.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Bubble draw mode chainage_bubbles choice box Do not draw bubbles

 Draw bubbles

draw bubble mode

Bubble radius bubble_radius input

radius of the bubbles

Bubble colour bubble_colour colour box

colour of the bubbles

Bubble upright mode bubble_draw_upright choice box Do not draw bubble upright

  Draw bubble upright

draw bubble upright mode

Bubble start chainage bubble_start_chainage input

start chainage bubbles

Bubble end chainage bubble_end_chainage input

end chainage bubbles

Chord/arc chainage mode bubble_chord_arc choice box Do not use chord/arc

chainages

Use chord/arc chainages

chord/arc chainage mode

Bubble interval bubble_interval input

include regular interval for bubbles

Section_Long_Plot_Bubbles_Text

Text
Section: Bubble Definition - Text Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up
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Bubble text string name mode

bubble_text_string_name_mode

choice box Do not label with string

name

Label with string name

Label with model->string

name

mode of bubble text string name.

Pre text bubble_pre_text input

pre text for label

Post text bubble_post_text input

post text for label

Textstyle bubble_textstyle text box

textstyle of label of label

Size (mm) bubble_text_size input

size of label

Colour bubble_text_colour colour box

colour of label

Offset (mm) bubble_text_offset input

offset value for bubbles.

Upright distance (mm) bubble_upright_distance angle box

distance bubbles are above boxes/uprights

Bubble upright distance mode bubble_mode choice box Distance is above boxes

Distance is above uprights

mode of bubble upright distance.

Section_Long_Plot_Bubbles_Label

Label
Section: Bubble Definition - Label Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Include tangents, spirals bubble_label_hcp tick box

if ticked, include the tangents and spirals.

Include hip points bubble_label_hip tick box

if ticked, include horizontal intersection points.

Include vip points bubble_label_vip tick box

if ticked, include vertical intersection points.

Include tangent points bubble_label_vtp tick box
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if ticked, include tangent points.

Include crest points bubble_label_crest tick box

if ticked, include crest points.

Include sag points bubble_label_sag tick box

if ticked, include sag points.

Include change of vertical grade

bubble_label_grade_change tick box

if ticked, include changes in vertical grade.

Bubble weeding tolerance

bubble_label_tolerance input

if >0 then use as a weeding tolerance, if <=0 don’t weed.

Files of special chainages

bubble_special_n_file file box

 n = 1 to 20 - include chainages from the file (one chainage per line)
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Quick Horizontal Geometry
Section_Long_Plot_Quick_horizontal_geometry

Quick Horizontal Geometry
Section: Quick Horizontal Geometry

The standard horizontal geometry arrows can be drawn at a given distance above the top of the boxes area.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Distance above boxes (mm) horizontal_geometry_y input

distance above boxes for drawing of arrows

Section: Quick Horizontal Geometry - Left Side Label Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type

Text horizontal_geometry_label_text input

text for label

Textstyle horizontal_geometry_label_textstyle text box

textstyle of label

Text colour horizontal_geometry_label_text_colour colour box

colour of label

Text size (mm) horizontal_geometry_label_text_size input

size of label

Section: Quick Horizontal Geometry - Arrow and text Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type

Text colour horizontal_geometry_arrow_text_colour colour box

colour of arrow text

Textstyle horizontal_geometry_arrow_textstyle text box

textstyle of arrow text

Text size (mm) horizontal_geometry_arrow_text_size input

size of arrow text

Decimal places horizontal_geometry_label_decimals input

number of decimal places in arrow text

Arrow colour horizontal_geometry_arrow_colour colour box

colour of arrow

Arrow height (mm) horizontal_geometry_arrow_height input

size of arrow
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Extensive Horizontal Geometry
Section_Long_Plot_Extensive_horizontal_geometry

Extensive Horizontal Geometry
Section: Extensive Horizontal Geometry Parameters

The standard horizontal geometry arrows can be drawn at a given distance above the top of the boxes area.

For complicated horizontal geometry labelling, there are sets of horizontal geometry labelling parameters 
which give tight control over the position and types of labels.

It is also possible to label the horizontal geometry of alignment strings other than the primary string. To 
plot such a string on the same plot, the chainage position of the horizontal geometry for the non-primary 
alignment strings is projected onto the primary string to give a primary string chainage for plotting. The 
values of the horizontal geometry (such as radius and spiral length) that are plotted are taken from the other 
string. Independently graded offset strings (such as a left and right kerbs) are the type of additional 
alignment strings that may need to be plotted on the same long section plot as the reference string (primary 
string).

For plotting horizontal geometry, the user can give up to twenty sets of these labels and they can be used to 
label spirals, curves and tangent information for the primary string and/or additional alignment strings.

Each label set consists of three parts:

(a) a text label on the left hand side of the plot
(b) an arrow
(c) text on the arrows.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Define set # input

where n = 1 to....20. The set enables the specification of a number of parameters for a number of 
specified extensive horizontal geometry.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Geometry to label h_g_n_type choice box label spirals

label horizontal curves

label horizontal tangents

specifies what geometry is to be labelled for the nominated set. If h_g_n_type is missing, then the set is 
ignored.

Value to label h_g_n_value_mode choice box nothing

length

radius (for curve labelling)

 or radius*length (for spiral)

specifies the value to label.

Y offset (mm) h_g_n_label_y input

distance of arrow line above top of the boxes.

If the set of parameters is to apply to the horizontal geometry of an alignment string other than the primary 
string, then the offset string can be specified.

Offset string h_g_n_offset_string select box

the name of the non-primary string. i.e.
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h_g_n_offset_string "model->string_name"
or

h_g_n_offset_string "string_name" 

and the model is the defined by offset_model. offset_model has been defined in the section “Offset String 
Titles/Heights/Depths” . 

If the h_g_n_offset_string parameter does not exist, then the set of horizontal geometry parameters is 
applied to the primary string. 

Section_Long_Plot_Extensive_horizontal_geometry_Left_hand_labels

Section: Extensive Horizontal Geometry - Left Hand Labels Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set #, as specified by the define set # parameter.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Label X (mm) h_g_n_label_x input

distance from the left hand side of the labels area to start the left hand label text.

Offset (mm) h_g_n_label_offset input

 distance to raise the left hand label text above arrow line.

Text size (mm) h_g_n_label_text_size input

 size of the left hand label text.

Text colour h_g_n_label_text_colour colour box

 size of the left hand label text.

Text h_g_n_label_text input

 left hand label text.

Textstyle h_g_n_label_textstyle text box

 textstyle for the left hand label text.

Section_Long_Plot_Extensive_horizontal_geometry_Arrow_type

Section: Extensive Horizontal Geometry- Arrow Type Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set #, as specified by the define set # parameter.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Arrow type mode h_g_n_draw_mode choice box arrow (1)

line (2) 

line with uprights at ends (3)

uprights with no lines (4) 

line with downrights (5) 
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downrights with no lines (6) 

line with up and downrights

at ends (7)

up and downrights with no

 line (8) 

draw curve (9)

radius*length curve (11)

specifies the arrow type to be drawn.

Left arrow gap (mm) h_g_n_left_gap input

size of gap for left side of arrow.

Right arrow gap (mm) h_g_n_right_gap input

size of gap for right side of arrow.

Arrow colour h_g_n_colour colour box

colour of arrow text

Arrow height (mm) h_g_n_height input

height of arrow in mm.

Leave gap in arrow for text h_g_n_gap tick box

if ticked, a gap will be left for text.

Section_Long_Plot_Extensive_horizontal_geometry_Arrow_text

Section: Extensive Horizontal Geometry - Arrow Text Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set #, as specified by the define set # parameter.

Text colour h_g_n_text_colour colour box

colour of arrow text

Text size (mm) h_g_n_text_size input

size of arrow text

0

1

2

3

4

5

6

7

8

9

11
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Text offset (mm) h_g_n_text_offset input

distance to raise the text above the arrow line.

Arrow text pre-text h_g_n_pre_text input

text before the arrow text

Arrow text post-text h_g_n_post_text input

text after the arrow text

Textstyle h_g_n_textstyle text box

textstyle of arrow text

Decimal places h_g_n_no_decimals input

number of decimal places in arrow text. If > 0, all trailing zeros after the decimal place are removed. If 
< 0, the absolute value is taken as the number of decimal places and no trailing zeros are removed 
after the decimal point.

Rotate text to fit h_g_n_rotate tick box

if ticked, the text on the arrows will be rotated to fit.
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Quick Vertical Geometry
Section_Long_Plot_Quick_vertical_geometry

Quick Vertical Geometry
Section: Quick Vertical Geometry - Grade

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Distance above boxes (mm)

vertical_geometry_grade_y input

distance above boxes. If 0, don’t draw.

Section: Quick Vertical Geometry - Length

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Distance above boxes (mm)

vertical_geometry_length_y input

distance above boxes. If 0, don’t draw.

Section: Quick Vertical Geometry - Common Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Arrow mode vertical_geometry_arrow_mode

input ticks

arrows

arrow mode.

Arrow colour vertical_geometry_arrow_colour

colour box

arrow colour.

Arrow height (mm) vertical_geometry_arrow_height

input

height of arrow in mm.

Section_Long_Plot_Quick_vertical_geometry_Grade_labels

Grade Labels
Section: Quick Vertical Geometry - Grade Left Hand Label Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Text vertical_geometry_label_grade_text

input
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text for left hand grade label.

Textstyle vertical_geometry_label_grade_textstyle

textstyle box

textstyle for left hand grade label.

Text colour vertical_geometry_label_grade_text_colour

colour box

colour of left hand grade label text

Text size (mm) vertical_geometry_label_grade_text_size

input

size of left hand grade label text

Section: Quick Vertical Geometry - Grade Arrow And Text Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Grade mode vertical_geometry_grade_mode

choice box %

1 in

mode of grade for grade arrow text.

Grade decimal places vertical_geometry_label_grade_decimals

input

number of decimal places for grade arrow text.

Grade arrow textstyle vertical_geometry_arrow_grade_textstyle

textstyle box

textstyle for grade arrow text.

Grade arrow text colour vertical_geometry_arrow_grade_text_colour

colour box

colour of grade arrow text.

Grade arrow text size (mm)

vertical_geometry_arrowl_grade_text_size

input

size of grade arrow text

Section_Long_Plot_Quick_vertical_geometry_Length_labels

Length Labels
Section: Quick Vertical Geometry - Length Left Hand Label Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Text vertical_geometry_label_length_text

input
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text for left hand length label.

Textstyle vertical_geometry_label_length_textstyle

textstyle box

textstyle for left hand length label.

Text colour vertical_geometry_label_length_text_colour

colour box

colour of left hand length label

Text size (mm) vertical_geometry_label_length_text_size

input

size of left hand length label

Section: Quick Vertical Geometry - Grade Arrow And Text Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Length mode vertical_geometry_length_mode

choice box length

radius

k value

mixed - length for parabolic,

 radius for circular

mode of length for length labels.

Length decimal places vertical_geometry_label_length_decimals

input

number of decimal places for length arrow labels.

Length arrow textstyle vertical_geometry_arrow_length_textstyle

textstyle box

textstyle for length arrow labels.

Length arrow text colour vertical_geometry_arrow_length_text_colour

colour box

colour of length arrow labels.

Length arrow text size (mm)

vertical_geometry_arrow_length_text_size

input

size of length arrow labels
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Extensive Vertical Geometry
Section_Long_Plot_Extensive_vertical_geometry

Extensive Vertical Geometry
Section: Extensive Vertical Geometry Parameters

For complicated vertical geometry labelling of the primary alignment string, there are sets of vertical 
geometry labelling parameters which give tight control over the position and types of labels.

It is also possible to label the vertical geometry of alignment strings other than the primary string. To plot 
such a string on the same plot, the chainage position of the vertical geometry for the non-primary 
alignment strings is projected onto the primary string to give a primary string chainage for plotting. The 
values of the vertical geometry (such as grade and curve length) that are plotted are taken from the other 
string. Independently graded offset strings (such as a left and right kerbs) are the type of additional 
alignment strings that may need to be plotted on the same long section plot as the reference string (primary 
string).

For plotting vertical geometry, the user can give up to twenty sets of these labels and they can be used to 
label grades or vertical curve information for the primary string and/or additional alignment strings.

Each label set consists of three parts:

(a) a text label on the left hand side of the plot
(b) an arrow
(c) text on the arrows.

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Define set # input

where n = 1 to....20. The set enables the specification of a number of parameters for a number of 
specified extensive horizontal geometry.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Geometry to label v_g_n_type choice box label grades

label vg curve information

specifies what geometry is to be labelled for the nominated set. If v_g_n_type is missing, then the set is 
ignored.

Value to label v_g_n_value_mode choice box nothing

%grade |or| parab

length, arc length

1 in grade |or| radius

mm grade |or| K value

ch length between curve 
points

per chord(QR) |or| curve

 constant (QR).

specifies the value to label. This will be dependant on the v_g_n_type chosen.

Vertical curve points to draw the arrows between (for grade labelling only)

Points to draw arrows between
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v_g_n_between_mode choice box between chainages at the

 vips

between chainages at the

 vtps

specifies where to draw the arrows between (for grade labelling only).

Y offset (mm) v_g_n_label_y input

distance of arrow line above top of the boxes. This value can be negative

If the set of parameters is to apply to the vertical geometry of an alignment string other than the primary 
string, then the following parameter can define the other alignment string 

Offset string v_g_n_offset_string select box

the name of the non-primary string. i.e.

 v_g_n_offset_string "model->string_name"
or

v_g_n_offset_string "string_name" 

and the model is the defined by offset_model. offset_model has been defined in the section “Offset String 
Titles/Heights/Depths” . 

If the v_g_n_offset_string parameter does not exist, then the set of vertical geometry parameters is applied 
to the primary string. 

Section_Long_Plot_Extensive_vertical_geometry_Left_hand_labels

Section: Extensive Vertical Geometry - Left Hand Labels Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set #, as specified by the define set # parameter.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Label X (mm) v_g_n_label_x input

distance from the left hand side of the labels area to start the left hand label text.

Offset (mm) v_g_n_label_offset input

 distance to raise the left hand label text above arrow line.

Text size (mm) v_g_n_label_text_size input

 size of the left hand label text.

Text colour v_g_n_label_text_colour colour box

 size of the left hand label text.

Text v_g_n_label_text input

 left hand label text.

Textstyle v_g_n_label_textstyle text box

 textstyle for the left hand label text.
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Section_Long_Plot_Extensive_vertical_geometry_Arrow_type

Section: Extensive Vertical Geometry - Arrow Type Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set #, as specified by the define set # parameter.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Arrow type mode v_g_n_draw_mode choice box arrow (1)

line (2) 

line with uprights at ends (3)

uprights with no lines (4) 

line with downrights (5) 

downrights with no lines (6) 

line with up and downrights 
at ends (7)

up and downrights with no

 line (8) 

draw curve (9)

draw grade (10)

specifies the arrow type to be drawn.

Left arrow gap (mm) v_g_n_left_gap input

size of gap for left side for arrow.

Right arrow gap (mm) v_g_n_right_gap input

size of gap for right side of arrow.

Arrow colour v_g_n_colour colour box

colour of arrow text

Arrow height (mm) v_g_n_height input

height of arrow in mm.

Leave gap in arrow for text v_g_n_gap tick box

if ticked, a gap will be left for text.

0

1

2

3

4

5

6

7

8

9

10
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Section_Long_Plot_Extensive_vertical_geometry_Arrow_text

Section: Extensive Vertical Geometry - Arrow Text Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set #, as specified by the define set # parameter.

Text colour v_g_n_text_colour colour box

colour of arrow text

Text size (mm) v_g_n_text_size input

size of arrow text

Text offset (mm) v_g_n_text_offset input

distance to raise the text above the arrow line.

Arrow text pre-text v_g_n_pre_text input

text before the arrow text

Arrow text post-text v_g_n_post_text input

text after the arrow text

Textstyle v_g_n_textstyle text box

textstyle of arrow text

Decimal places v_g_n_no_decimals input

number of decimal places in arrow text. If > 0, all trailing zeros after the decimal place are removed. If 
< 0, the absolute value is taken as the number of decimal places and no trailing zeros are removed 
after the decimal point.

Rotate text to fit v_g_n_rotate tick box

if ticked, the text on the arrows will be rotated to fit.
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Labelling Points With Chainage, Height
Section_Long_Plot_Labelling_points_with_chainage_height

Labelling Points With Chainage, Height
Section: Labelling Points With Chainage, Height

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Define set # input

where n = 1 to....20. The set enables the specification of a number of parameters for a number of 
specified labels.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Label Type label_n_type choice box chainage of vip, height of vip

chainage of vip, height of

primary

crest

sag 

vtp

hcp

change of grade

mid-ordinate of the vertical

 curve

The chainage and/or height values for certain points (given by label_n_type) can be labelled.

If label_n_type is missing, then the set is ignored.

Label height mode label_n_y_mode choice box height above boxes (mm)

height above height value

 (mm)

height above primary height

 (mm)

specifies which reference point the label_n_y distance is measured from.

Section_Long_Plot_Labelling_points_with_chainage_height_Label_position

Labelling Position
Section: Chainage/Height Label Position Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set #, as specified by the Define set # parameter.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Distance above point (mm) label_n_y input
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distance above point.

Angle (dms) label_n_angle angle box

rotation about point.

Distance along from point (mm) label_n_x input

the distance along from the point in mm.

Text raise height (mm) label_n_offset input

the distance to raise the text in mm.

Justification label_n_justification choice box left end

middle

end

justification of the label.

Section_Long_Plot_Labelling_points_with_chainage_height_Label_text_type

Text Type
Section: Chainage/Height Label Text Type Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set #, as specified by the Define set # parameter.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Size (mm) label_n_size input

size of the text.

Colour label_n_colour colour box

colour of text.

Textstyle label_n_textstyle text box

the textstyle of the text.

Section_Long_Plot_Labelling_points_with_chainage_height_Label_text

Label Text
Section: Chainage/Height Label Text Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Use set # input

set #, as specified by the Define set # parameter.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Label type label_n_value_mode choice box no values labelled

val 1 = chainage

val 1 = height

val 1 = chainage, val2 =
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 height

val 1 = height, val2 =

 chainage

the value label mode.

Pre-text label_n_pre_text input

text before the label text

Mid-text label_n_mid_text input

text at mid position i.e. between val 1 and val 2.

Post-text label_n_post_text input

text after the label text

Decimal places val 1 label_n_no_decimals_1 input

number of decimal places in val 1.

Decimal places val 2 label_n_no_decimals_2 input

number of decimal places in val 2.

If the number of decimal places is greater than zero (> 0), then any trailing zeros after the decimal point 
are removed.

If the number of decimal places is less than zero (< 0), the absolute value is taken as the number of 
decimal places and no trailing zeros after the decimal point are removed.
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Labelling Points With Symbols
Section_Long_Plot_Labelling_points_with_symbols

Labelling Points With Symbols
Section: Labelling Points With Symbols

Symbols can be placed at certain points given by symbol_n_type.

The symbol is drawn in a square box centred on (0,0) with sides of length two millimetres. That is, the box 
co-ordinates are (-1,-1), (1,1), (1,-1), (-1,-1).

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Set # input

where n = 1 to....20. The set enables the specification of a number of parameters for a number of 
specified symbols.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

Symbol Type symbol_n_type choice box chainage of vip, height of vip

chainage of vip, height of

primary

crest

sag 

vtp

hcp

change of grade

mid-ordinate of the vertical

 curve

If symbol_n_type is missing, then the set is ignored.

Label height mode symbol_n_y_mode choice box height above boxes (mm)

height above height value

 (mm)

height above primary height

 (mm)

specifies which reference point the label_n_y distance is measured from.

Distance above point (mm) symbol_n_y input

distance above point given by mode.

Angle (dms) symbol_n_angle angle box

rotation about point.

Distance along from point (mm)symbol_n_x input

the distance along from the point in mm.

Size (mm) symbol_n_size input

the symbol size in mm.

Colour symbol_n_colour colour box

the symbol size in mm.
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Symbol draw mode symbol_n_draw_mode choice box height above boxes (mm)

cross (0)

upright from centre of box (1)

up and downright from 

centre of box (2)

square (3)

triangle, base at bottom (4)

circle (5)

draw mode for symbol

Hatching Cut/Fill
Section_Long_Plot_Hatching_cut_fill

This option is used to hatch cut and/or fill areas between sets of tins.

For each set, the name of the two tins, the hatch linestyle, colour and separation and whether cut and/or fill 
regions are required are all user definable.

Up to twenty (20) separate sets of tins may be hatched.

Panel Field Parameter name Type

Define Set # input

set number to be used to define different original/new tin sets.

Original tin hatch_original_tin_n tin box

tin_name for original surface

New tin hatch_new_tin_n tin box

tin_name for final surface

Notes

(a) cut is when the new tin is below the original tin.
fill is when the new tin is above the original tin.

(b) cut hatching is turned off by setting hatch_cut_separation_n to 0.0.
fill hatching is turned off by setting hatch_fill_separation_n to 0.0.

Section_Long_Plot_Hatching_cut_fill_Cut

0 1 2 3 4 5

section viewtin (natural surface)

design long section cut

fill



12d Model Reference Manual

Page 2514 November 2002Long Plot PPF Editor

Cut
Panel Field Parameter name Type

Use Set # input

set number as specified in the Define set#.

Cut separation (mm) hatch_cut_separation_n input

distance between cut hatch lines. If 0, no hatching.

Cut hatch angle (dms) hatch_cut_angle_n input

angle of hatching.

Cut colour hatch_cut_colour_n colour box

colour of the hatching.

Cut linestyle hatch_cut_linestyle_n linestyle box

linestyle of the hatching.

Draw sides of cuts hatch_cut_draw_sides_n choice box

draw mode for sides of cut regions.

Draw original tin hatch_cut_draw_original_n choice box

draw mode for sides of original tin in cut.

Draw new tin hatch_cut_draw_new_n choice box

draw mode for sides of new tin in cut.

Section_Long_Plot_Hatching_cut_fill_Fill

Fill
Panel Field Parameter name Type

Use Set # input

set number as specified in the Define set#.

Fill separation (mm) hatch_fill_separation_n input

distance between fill hatch lines. If 0, no hatching.

Fill hatch angle (dms) hatch_fill_angle_n input

angle of hatching.

Fill colour hatch_fill_colour_n colour box

colour of the hatching.

Fill linestyle hatch_fill_linestyle_n linestyle box

linestyle of the hatching.

Draw sides of fills hatch_fill_draw_sides_n choice box

draw mode for sides of fill regions.

Draw original tin hatch_fill_draw_original_n choice box

draw mode for sides of original tin in fill.

Draw new tin hatch_fill_draw_new_n choice box

draw mode for sides of new tin in fill.

Cuts
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Section_Long_Plot_Cuts
The cuts that the primary string (design line) makes though strings in any user-specified model can be 
automatically labelled on the long section plots.

The height, chainage and name of the cut string can be labelled as well as a symbol. The height of tins at 
the same offset value can also be labelled.

The chainage position for the labelling is the chainage of the cut string.

The height position for the labelling can be specified as the:

(a) top of the boxes on the long section,

(b) height value of the cut string,

(c) height of the primary string,

(d) height of a tin.

The actual position of the label is defined relative to the above point.

Note: Only case (b) involves the actual height of the cut string. For all other cases, only the chainage of the 
cut string is used. Hence for all cases except (b), the string does need to have a sensible height to be used 
for cuts through strings. For example, a boundary string may have null heights but only the chainage is 
required and the height of the tin at that chainage can be used as the height (case (d)).

The method for specifying which strings are to be checked for cuts is by first specifying the model which 
contains the strings, and then a name mask which is used to restrict the strings in the model to only those 
whose names match the name mask.

Up to twenty five different sets of models and name masks can be used so that different cut sets can be 
labelled in different ways.

Panel Field Parameter name Type

Define Set # input

set number to be used to define different model/mask sets.

Model cuts_n_model model box

model from which cut masks are derived

Name mask cuts_n_mask input

text string containing the name masks, each separated by one or more spaces, to test the string name 
against. Each mask can include wild cards and wild characters.
For example: "ke*" or,

"?bank*" or, if both masks are required,
"ke* ?bank*"

If cuts_n_mask is blank, then all strings in the model are used. This is equivalent to name mask being 

primary string

strings to label where they are cut by the design string

plan view

(design string)

tin (natural surface)

design long section

points where strings are cut
in plan by the long section

section view
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set to "*".

All strings in the model cuts_n_model whose name satisfy the name mask cuts_n_mask are then checked 
for cuts with the design string, and if a cut occurs, the cut point will be labelled according to the rest of the 
parameters in the nth set.

Section_Long_Plot_Cuts_Chainage

Chainage
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Position cuts_chainage_n_position
choice box above cut string height value

above top of boxes
to primary string 
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of chainage label.

X (mm) cuts_chainage_n_x input

horizontal adjustment to position of chainage text.

Y (mm) cuts_chainage_n_y input

vertical adjustment to position of chainage text.

Angle (dms) cuts_chainage_n_angle input

rotation of chainage text about position.

Colour cuts_chainage_n_colour colour box

colour of chainage text.

Size (mm) cuts_chainage_n_size input

design long section

section view

point where the design
cuts a string 

The cut point can be labelled with
chainage of the cut point
height of the cut point
height of the x-section or tins at this offset
name of the string for the cut point

User defined symbols can also be drawn at the cut 
point

tin (natural surface)
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size of chainage text. A value of 0 means no label.

Textstyle cuts_chainage_n_textstyle
text box

textstyle of chainage text.

Pre-text cuts_chainage_n_pre_text
input

text before chainage text.

Post-text cuts_chainage_n_post_text
input

text after chainage text.

Justification cuts_chainage_n_justification
justification box

bottom-left
bottom-centre
bottom-right
bottom-decimal
middle-left
middle-centre
middle-right
middle-decimal
top-left
top-centre
top-right
top-decimal
decimal-left
decimal-centre
decimal-right
decimal-point

justification of the chainage text.

Decimals cuts_chainage_n_no_decimals
input

number of decimals in chainage.

Section_Long_Plot_Cuts_Heights

Heights
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Mode cuts_height_n_mode choice box use height of cut point
use real height above boxes
height of primary string
use height of tin 1
use height of tin 2
use height of tin 3
use height of tin 4
use height of tin 5
use height of tin 6
use height of tin 7
use height of tin 8
use height of tin 9
use height of tin 10



12d Model Reference Manual

Page 2518 November 2002Long Plot PPF Editor

determines which height value is labelled.

Position cuts_height_n_position choice box at cut string
above top of boxes 
above top of graph area
to primary string 
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of height label.

X (mm) cuts_height_n_x input

horizontal adjustment to position of height text.

Y (mm) cuts_height_n_y input

vertical adjustment to position of height text.

Angle (dms) cuts_height_n_angle input

rotation of height text about position.

Colour cuts_height_n_colour colour box

colour of height text.

Size (mm) cuts_height_n_size input

size of height text. A value of 0 means no label.

Textstyle cuts_height_n_textstyle text box

textstyle of height text.

Pre-text cuts_height_n_pre_text input

text before height text.

Post-text cuts_height_n_post_text input

text after height text.

Justification points_height_n_justification
justification box

bottom-left
bottom-centre
bottom-right
bottom-decimal
middle-left
middle-centre
middle-right
middle-decimal
top-left
top-centre
top-right
top-decimal
decimal-left
decimal-centre
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decimal-right
decimal-point

justification of the height text.

Decimals cuts_height_n_no_decimals
input

number of decimals in height.

Section_Long_Plot_Cuts_Labels

Labels
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Position cuts_label_n_position choice box at cut string height
above top of boxes
above top of graph area
to primary string
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of label text.

Mode cuts_label_n_mode choice box don’t include string name
include cut string name

determines whether the label includes the cut string name.

X (mm) cuts_label_n_x input

horizontal adjustment to position of label.

Y (mm) cuts_label_n_y input

vertical adjustment to position of label.

Angle (dms) cuts_label_n_angle input

rotation of label about position.

Colour cuts_label_n_colour colour box

colour of label.

Size (mm) cuts_label_n_size input

size of label. A value of 0 means no label.

Textstyle cuts_label_n_textstyle text box

textstyle of label.

Pre-text cuts_label_n_pre_text input

text before label.

Post-text cuts_label_n_post_text input
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text after label.

Justification cuts_label_n_justification
justification box

bottom-left
bottom-centre
bottom-right
bottom-decimal
middle-left
middle-centre
middle-right
middle-decimal
top-left
top-centre
top-right
top-decimal
decimal-left
decimal-centre
decimal-right
decimal-point

justification of the label.

Section_Long_Plot_Cuts_Symbols

Symbols
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Mode cuts_symbol_n_mode choice box cross (0)
up from centre of box (1)
up&down from box centre(2)
square (3)
triangle, base at bottom (4)
circle (5)
use a plot symbol

symbol mode.

Note: If a plot symbol is to be used, the cuts_symbol_n_style parameter must be specified.

Symbol cuts_symbol_n_style plot symbols

a valid plot symbol can be selected.

Position cuts_symbol_n_position choice box at cut string height
above top of boxes
above top of graph area
to primary string 
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5

0 1 2 3 4 5

predefined symbols 0 to 5
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to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of symbol.

X (mm) cuts_symbol_n_x input

horizontal adjustment to position of symbol.

Y (mm) cuts_symbol_n_y input

vertical adjustment to position of symbol.

Angle (dms) cuts_symbol_n_angle input

rotation of symbol about point.

Colour cuts_symbol_n_colour colour box

colour of symbol.

Size (mm) cuts_symbol_n_size input

size of symbol. A value of 0 means no symbol.

Primary String Name Label
Section_Long_Plot_Primary_string_name_label

The plot can be labelled with a name under the boxes area.

The name is made up of a concatenation of the text string names:

Panel Field Parameter name Type

Name mode plot_name_string_name choice box

determines what text is placed in the name labels.

Pre-text plot_name_pre_text input

text before label.

Post-text plot_name_post_text input

text after label.

Textstyle plot_name_textstyle text box

textstyle of label.

Size (mm) plot_name_size input

size of label.

Colour plot_name_colour colour box

colour of label.

X offset (mm) plot_name_x_offset input

horizontal adjustment to position of label.

Y offset (mm) plot_name_y_offset input

vertical adjustment to position of label.

The plot name is positioned under the boxes.

The plot_name_x_offset is measured from the beginning of the height boxes.

The default for plot_name_x_offset is centred on heights area.
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The plot_name_y_offset is measured from the bottom of the box area with positive being down.

Scale labelling
The plot can be labelled with the horizontal and vertical scale under the boxes area.

The scale label is made up of concatenation the text strings:

           scale_horizontal_pre_text         horizontal scale value         scale_horizontal_post_text

and
           scale_vertical_pre_text              vertical scale value               scale_vertical_post_text

The horizontal scale value is the value given by the scale parameter.

The scales are positioned under the boxes.

Section_Long_Plot_Scale_labelling
Section_Long_Plot_Scale_labelling_Horizontal

Horizontal
Section: Scale Labelling - Horizontal Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Pre-text scale_horizontal_pre_text input

text before label

Post-text scale_horizontal_post_text input

text after label

Textstyle scale_horizontal_textstyle text box

textstyle of label

Size (mm) scale_horizontal_size input

size of label

Colour scale_horizontal_colour colour box

colour of label

X offset (mm) scale_horizontal_x_offset input

horizontal adjustment to position of label.

Y offset (mm) scale_horizontal_y_offset input

height adjustment to position of label.

Decimal places scale_horizontal_decimals input

labelling primary string name on long section plots

plot_name_x_offset

plot_name_y_offset
plot name text

heights areatitle area
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height adjustment to position of label.

Section_Long_Plot_Scale_labelling_Vertical

Vertical
Section: Scale Labelling - Vertical Parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Pre-text scale_vertical_pre_text input

text before label

Post-text scale_vertical_post_text input

text after label

Textstyle scale_vertical_textstyle text box

textstyle of label

Size (mm) scale_vertical_size input

size of label

Colour scale_vertical_colour colour box

colour of label

X offset (mm) scale_vertical_x_offset input

horizontal adjustment to position of label.

Y offset (mm) scale_vertical_y_offset input

height adjustment to position of label.

Decimal places scale_vertical_decimals input

height adjustment to position of label.

The scale_vertical_x_offset and scale_horizontal_x_offset are measured from the beginning of the heights 
area.

The default for scale_vertical_x_offset and scale_horizontal_x_offset are centred on the heights area.

The scale_vertical_y_offset and scale_horizontal_y_offset are measured from the bottom of the box area 
with positive being down.

If the number of decimal places is greater than zero (> 0), then any trailing zeros after the decimal point 
are removed.

If the number of decimal places is less than zero (< 0), the absolute value is taken as the number of 
decimal places and no trailing zeros after the decimal point are removed.
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PPF’s To Include
Section_Long_Plot_PPF_s_to_include

Panel Field Parameter name Type Pop-Up

PPF files input

by including pre existing PPF files, the user can build up a modified version without having to set all 
the parameters.

labelling of scales on the long section plots

scale_vertical_x_offset

scale_vertical_y_offset
vertical_scale text

heights areatitle area

scale_horizontal_x_offset

scale_horizontal_y_offset
horizontal_scale text

heights areatitle area
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Drainage Plot PPF Editor
drainage_plot_ppf_editor

Position of option on menu: Plot =>Drainage Plot PPF Editor

The drainage plot ppf editor is for creating and/or editing a (binary) drainage and sewer long 
section ppf file and for creating a drainage and/or sewer long section plot. An ascii version of 
the file is also produced.

Note: binary and ascii ppf’s are stored within the project (not in the folder containing the project).

On selecting the Drainage plot ppf editor option, the Drainage Plot PPF Editor panel is displayed.

Panel field Type

Plot parameter file file box
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name for the binary plot parameter file to read in or write out.

Read button

read the given plot parameter file in.

Write button

write out the plot parameters to the given plot parameter file. An ascii ppf file is also written out.

Plot button

use the plot parameters from the panel to create the plot.

Find button

brings up a search box. If a valid parameter name is keyed in followed by the enter key, the cursor will 
be placed in the appropriate field on the appropriate page.

Drainage Plot
Drainage_Plot

View to load details from
Panel field Type Pop-Up

View view box existing section views

on selection of an existing section view, the vertical exaggeration, network model to profile, corridor 
models and corridor settings from that section view are loaded into the ppf editor. The section view 
itself is not stored as a parameter in the ppf editor. It is only for convenience, in order to populate 
certain other parameters easily in the ppf editor, based on a particular section view that may currently 
exist.

Global variables
Panel field Parameter name Type Pop-Up

Text style global_textstyle textstyle available fonts

default text style.

Plot Symbols plot_symbols file box available symbol files

specify a plot symbol file if it exists.

Section parameters
Panel field Parameter name Type Pop-Up

Network model network_model model box available models

model containing the drainage strings to plot.

Horizontal scale scale input

horizontal scale to be used for the plot.

Vertical exaggeration vertical_exaggeration input

vertical exaggeration to be used for the plot.

Sheet size setup
The plot page or sheet is considered to have only positive co-ordinates with the origin (0,0) in the left hand 
corner. The units for the plot are millimetres.

Panel field Parameter name Type Pop-Up

Sheet size wd ht (mm) sheet_size sheet size available sheet sizes
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sheet size to plot on.

Plotter parameters
Panel field Parameter name Type Pop-Up

Plotter type plotter_type plotter box available plotter types

plotter type to plot to.

Plot file stem plot_stem input

plot file name stem. A number is appended to the stem for each sheet plotted. The appropriate file 
extension is added dependant on the plotter type selected.

Clean plot models beforehand

plot_model_clean choice box do not clean
prompt for clean
always clean

whether to clean (delete the elements in) any resultant plot models that may already exist, before 
generating the plot(s). This parameter is only applicable if plotting to a model or models. Note that if 
the models are cleaned using this parameter, any non-plot or locked elements found in the models will 
not be cleaned from the models, and the plot job will be cancelled.

Title block
Drainage_Plot_Title_block

Common title block parameters
Panel field Parameter name Type

Standard title plot_border tick box

if ticked, a standard 12d title block will be used.

Use title file use_title_file tick box

if ticked, a user defined title file is used.

Title line 1 title_1 input

if  Standard title is ticked, Title line 1 is the first line of title text. If  Use title file is ticked, Title line 1 
is substituted for the title block variable $title_1.

Title line 2 title_2 input

if  Standard title is ticked, Title line 2 is the second line of title text. If  Use title file is ticked, Title line 
2 is substituted for the title block variable $title_2.

12d default title block parameters
Panel field Parameter name Type Pop-Up

Text size title_text_size input

text size of title text.

Text colour title_colour colour available colours

colour of title text.

Drainage_Plot_Title_block_User_title_info

User title info
The parameters shown below are subject to the appropriate title block variables existing in the title file. For 
more information on these variables see the section “Title Block Variables” .
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Panel field Parameter name Type Pop-Up

Title file title_file file box available title files

specifies the name of the title file to use. If a valid title file exists, the specified Name values will be 
filled out in the grid using the title block variable $user_text_n.

Name output

the alias for the nth user text specified in the title file.

Value user_text_n input

the alias text to be substituted in for the user text specified.

Time format time_format input

the time format relates to the $time title block variable. For more information on the time formats see 
the section “Specifying the Format for $time” .

Start page number start_page_number input

used as the starting value for the title block variable $page_number. If missing, $page_number starts at 
1.

Start drawing number start_drawing_number input

used as the starting value for the title block variable $drawing_number. If missing, $drawing_number 
starts at 1.

Drawing number prefix drawing_number_prefix input

the value entered is used for the title block variable $drawing_number_prefix.

Drawing number postfix drawing_number_postfix input

the value entered is used for the title block variable $drawing_number_postfix.

Plot sheet layout
Drainage_Plot_Plot_sheet_layout



Chapter 24  PPF Editors

November 2002 Page 2529Drainage Plot PPF Editor

Drainage_Plot_Plot_sheet_layout_Margins

Margins
Panel field Parameter name Type

Left (mm) left_border_gap input

left border gap (in millimetres).

Right (mm) right_border_gap input

right border gap (in millimetres).

Top (mm) top_border_gap input

top border gap (in millimetres).

Bottom (mm) bottom_border_gap input

bottom border gap (in millimetres). 

Drainage_Plot_Plot_sheet_layout_Other_parameters

Other parameters
Panel field Parameter name Type Pop-Up

Row per sheet mode only_one_line choice box more than one row on sheet
only one row on sheet

whether to allow multiple rows on a sheet.

Plot height (mm) plot_height input

height of plot row (in millimetres).

Horizontal plot gap (mm) horizontal_plot_gap input

gap between plot columns (in millimetres).

Vertical plot gap (mm) vertical_plot_gap input
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gap between plot rows (in millimetres). 

Boxes
Drainage_Plot_Boxes

The Boxes Area on the drainage long section plot, is used to label points on the drainage strings with the 
following information: chainages, road centre line chainages, natural surface heights, finished surface 
heights, before pit and after pit invert levels, before pit and after pit hgl values, and before pit and after pit 
depths to inverts.

The default order of the boxes is as shown in the diagram, below.

The chainage box is hardwired to always appear first (at the bottom) in the order of boxes. If, you wish to 
change the order of any of the other boxes, or wish to omit any of the other boxes, you can do so by 
specifying the following box order parameters.

Panel Field Parameter name Type Pop-Up

Box # box_n_set input

 order (from 1 to 6) of the nth box type. 

List # box_n choice box road centre line chainages
natural surface heights
finished surface heights
invert levels
hgl values
depths to inverts

box type for the nth set of box order parameters.

Drainage_Plot_Boxes_Title_area

Title area
Panel Field Parameter name Type Pop-Up

Box width (mm) box_width input

 width of the box title area.

Box height (mm) box_height input

default height of each box.

Colour of box line work box_colour colour box available colours
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colour of box line work.

Size of titles (mm) title_box_text_size input

default text size of box titles.

Colour of titles title_box_text_colour colour box available colours

default text colour of box titles.

Drainage_Plot_Boxes_Values_area

Values area
Panel Field Parameter name Type Pop-Up

Size of values (mm) box_text_size input

 default text size of box values.

Colour of values box_text_colour colour box available colours

default text colour of box values.

Justification mode box_text_left_justify choice box top justify values
bottom justify values

whether to justify the (vertical) value text with the top or the bottom of the box.

Text side mode box_text_side choice box left
right
centre

whether to place the (vertical) value text to the left of, to the right of, or on the chainage uprights.

Decimal places of values number_of_decimals input

default number of decimal places for box values.

Drainage_Plot_Boxes_Chainage

Chainage
Panel Field Parameter name Type Pop-Up

Box height (mm) chainage_box_size input

height of chainage box (only required if different from default box_height).

Title parameters
Line 1 plot_title_chainage_name

input

first line of text for chainage box title.

Line 2 plot_title_chainage_name_2
input

optional second line of text for chainage box title.

Colour chainage_title_colour colour box available colours

text colour of chainage box title (required only if different from default title_box_text_colour).

Text size (mm) chainage_title_text_size input

text size of chainage box title (required only if different from default title_box_text_size).

Textstyle chainage_title_textstyle font box available fonts

font of chainage box title (required only if different from default global_textstyle).

Value parameters
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Colour chainage_text_colour colour box available colours

text colour of chainage box values (required only if different from default box_text_colour).

Text size (mm) chainage_text_size input

text size of chainage box values (required only if different from default box_text_size).

Textstyle chainage_textstyle font box available fonts

font of chainage box values (required only if different from default global_textstyle).

Decimal places chainage_decimals input

decimal places for chainage box values (required only if different from default number_of_decimals).

Drainage_Plot_Boxes_Road_centre_line_chainage

Road centreline chainage
Panel Field Parameter name Type Pop-Up

Include centre line chainage box
draw_centre_chainage check box

whether to include the road centreline chainage box in the boxes area.

Box height (mm) centre_chainage_box_size
input

height of road centreline chainage box (only required if different from default box_height).

Title parameters
Line 1 plot_title_centre_chainage_name

input

first line of text for road centreline chainage box title.

Line 2 plot_title_centre_chainage_name_2
input

optional second line of text for road centreline chainage box title.

Colour chainage_title_colour_cl colour box available colours

text colour of road centreline chainage box title (required only if different from default 
title_box_text_colour).

Text size (mm) chainage_title_text_size_cl
input

text size of road centreline chainage box title (required only if different from default 
title_box_text_size).

Textstyle chainage_title_textstyle_cl
font box available fonts

font of road centreline chainage box title (required only if different from default global_textstyle).

Value parameters
Colour chainage_text_colour_cl colour box available colours

text colour of road centreline chainage box values (required only if different from default 
box_text_colour).

Text size (mm) chainage_text_size_cl input

text size of road centreline chainage box values (required only if different from default box_text_size).

Textstyle chainage_textstyle_cl font box available fonts

font of road centreline chainage box values (required only if different from default global_textstyle).
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Decimal places chainage_cl_decimals input

decimal places for road centreline chainage box values (required only if different from default 
number_of_decimals).

Drainage_Plot_Boxes_Natural_surface

Natural surface
Panel Field Parameter name Type Pop-Up

Draw text mode draw_ns_text choice box don’t include ns box
include ns box

whether to include the natural surface box in the boxes area.

Box height (mm) surface_box_size input

height of natural surface box (only required if different from default box_height).

Title parameters
Line 1 plot_title_surface_name

input

first line of text for natural surface box title.

Line 2 plot_title_surface_name_2
input

optional second line of text for natural surface box title.

Colour ns_title_colour colour box available colours

text colour of natural surface box title (required only if different from default title_box_text_colour).

Text size (mm) ns_title_text_size input

text size of natural surface box title (required only if different from default title_box_text_size).

Textstyle ns_title_textstyle font box available fonts

font of natural surface box title (required only if different from default global_textstyle).

Value parameters
Colour ns_text_colour colour box available colours

text colour of natural surface box values (required only if different from default box_text_colour).

Text size (mm) ns_text_size input

text size of natural surface box values (required only if different from default box_text_size).

Textstyle ns_textstyle font box available fonts

font of natural surface box values (required only if different from default global_textstyle).

Decimal places ns_decimals input

decimal places for natural surface box values (required only if different from default 
number_of_decimals).

Drainage_Plot_Boxes_Finished_surface

Finished surface
Panel Field Parameter name Type Pop-Up

Draw text mode draw_fs_text choice box don’t include fs box
include fs box

whether to include the finished surface box in the boxes area.



12d Model Reference Manual

Page 2534 November 2002Drainage Plot PPF Editor

FS tin/Top of MH mode draw_fs_mode choice box height from fs tin
height from top of MH

whether the finished surface height values come from the finished surface tin, or from the tops of the 
maintenance holes.

Box height (mm) f_surface_box_size input

height of finished surface box (only required if different from default box_height).

Title parameters
Line 1 plot_title_finished_name

input

first line of text for finished surface box title.

Line 2 plot_title_finished_name_2
input

optional second line of text for finished surface box title.

Colour fs_title_colour colour box available colours

text colour of finished surface box title (required only if different from default title_box_text_colour).

Text size (mm) fs_title_text_size input

text size of finished surface box title (required only if different from default title_box_text_size).

Textstyle fs_title_textstyle font box available fonts

font of finished surface box title (required only if different from default global_textstyle).

Value parameters
Colour fs_text_colour colour box available colours

text colour of finished surface box values (required only if different from default box_text_colour).

Text size (mm) fs_text_size input

text size of finished surface box values (required only if different from default box_text_size).

Textstyle fs_textstyle font box available fonts

font of finished surface box values (required only if different from default global_textstyle).

Decimal places fs_decimals input

decimal places for finished surface box values (required only if different from default 
number_of_decimals).

Drainage_Plot_Boxes_Invert_levels

Invert levels
Panel Field Parameter name Type Pop-Up

Box height (mm) invert_height_box_size input

height of invert level box (only required if different from default box_height).

Title parameters
Line 1 plot_title_invert_name input

first line of text for invert level box title.

Line 2 plot_title_invert_name_2 input

optional second line of text for invert level box title.

Colour il_title_colour colour box available colours
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text colour of invert level box title (required only if different from default title_box_text_colour).

Text size (mm) il_title_text_size input

text size of invert level box title (required only if different from default title_box_text_size).

Textstyle il_title_textstyle font box available fonts

font of invert level box title (required only if different from default global_textstyle).

Value parameters
Colour il_text_colour colour box available colours

text colour of invert level box values (required only if different from default box_text_colour).

Text size (mm) il_text_size input

text size of invert level box values (required only if different from default box_text_size).

Textstyle il_textstyle font box available fonts

font of invert level box values (required only if different from default global_textstyle).

Decimal places il_decimals input

decimal places for invert level box values (required only if different from default 
number_of_decimals).

Drainage_Plot_Boxes_HGL

HGL
Panel Field Parameter name Type Pop-Up

Include HGL box
draw_hgl_value check box

whether to include the HGL box in the boxes area.

Box height (mm) hgl_box_size input

height of HGL box (only required if different from default box_height).

Title parameters
Line 1 plot_title_hgl_name input

first line of text for HGL box title.

Line 2 plot_title_hgl_name_2 input

optional second line of text for HGL box title.

Colour hgl_title_colour colour box available colours

text colour of HGL box title (required only if different from default title_box_text_colour).

Text size (mm) hgl_title_text_size input

text size of HGL box title (required only if different from default title_box_text_size).

Textstyle hgl_title_textstyle font box available fonts

font of HGL box title (required only if different from default global_textstyle).

Value parameters
Colour hgl_text_colour colour box available colours

text colour of HGL box values (required only if different from default box_text_colour).

Text size (mm) hgl_text_size input

text size of HGL box values (required only if different from default box_text_size).
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Textstyle hgl_textstyle font box available fonts

font of HGL box values (required only if different from default global_textstyle).

Decimal places hgl_decimals input

decimal places for HGL box values (required only if different from default number_of_decimals).

Drainage_Plot_Boxes_Depths

Depths
Panel Field Parameter name Type Pop-Up

Depth box mode depth_mode choice box don’t include depths box
depths from fs tin
depths from top of MH
depths from ns tin

whether to include the depths (to inverts) box in the boxes area, and if so, whether the depths are 
measured from the finished surface tin, the tops of the maintenance holes, or the natural surface tin.

Box height (mm) invert_depth_box_size input

height of depths box (only required if different from default box_height).

Title parameters
Line 1 plot_title_depth_name input

first line of text for depths box title.

Line 2 plot_title_depth_name_2 input

optional second line of text for depths box title.

Colour depth_title_colour colour box available colours

text colour of depths box title (required only if different from default title_box_text_colour).

Text size (mm) depth_title_text_size input

text size of depths box title (required only if different from default title_box_text_size).

Textstyle depth_title_textstyle font box available fonts

font of depths box title (required only if different from default global_textstyle).

Value parameters
Colour depth_text_colour colour box available colours

text colour of depths box values (required only if different from default box_text_colour).

Text size (mm) depth_text_size input

text size of depths box values (required only if different from default box_text_size).

Textstyle depth_textstyle font box available fonts

font of depths box values (required only if different from default global_textstyle).

Decimal places depth_decimals input

decimal places for depths box values (required only if different from default number_of_decimals).

Drainage_Plot_Boxes_Chainage_box_mode

Chainage box mode
Panel Field Parameter name Type Pop-Up

Chainage box mode chainage_box_mode choice box don’t draw the chainage box
draw the chainage box
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whether to draw the line work around the chainage box.

Drainage_Plot_Boxes_Title_area_box_mode

Title area box mode
Panel Field Parameter name Type Pop-Up

Title area box mode draw_box_mode choice box do not draw title area box
draw title area box, no lines
draw title area box with lines

whether to draw the line work around the titles area, and if so, whether to draw lines separating each 
title as well.

Chainages/Uprights
Drainage_Plot_Chainages_Uprights

Uprights, or leader lines, can be drawn through the points on the drainage strings, anywhere from the top 
area to the bottom of the boxes area.

Upright parameters
Panel Field Parameter name Type Pop-Up

Top of uprights mode uprights_top_mode choice box stop at top of pit
go to top area

determines how high on the plot, the uprights are drawn.

Bottom of uprights mode uprights_bottom_mode choice box stop at top of boxes
go to bottom of boxes

determines how low on the plot, the uprights are drawn.

Colour of uprights to pits manhole_line_colour colour box available colours

colour of the uprights.

Chainage parameters
Panel Field Parameter name Type Pop-Up

Chainage values at uprights
chainage_mode choice box pipe length chainage

running chainage
both pipe length and running

whether the chainage values represent the individual pipe lengths, the running chainages, or both.

Pipe length label position centre_pipe_length choice box 0 at start pit, length at end pit
centre of pipe length

determines how pipe length chainages are displayed. Note: if the centre of pipe length option is 
chosen, the pipe length chainage text is drawn horizontally, rather than vertically.

Drainage_Plot_Chainages_Uprights_Services

Services
Any services crossing the drainage strings (defined by specifying corridor service models in the Corridors 
section) can be automatically labelled with an upright, chainage and invert level labels (of the drainage 
string, placed within the appropriate boxes in the Boxes area), and a name label (that includes the crossing 
service string name, its diameter, and its invert level at the point of crossing).

Note: crossing services may also be labelled (independently) by utilising the parameters in the Cuts 
section.

Panel Field Parameter name Type Pop-Up
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Service chainage values at uprights
service_chainage_mode choice box pipe length chainage

running chainage
both pipe length and running

whether the crossing service chainage values represent the chainages from the previous pits, the 
running chainages, or both.

Colour of uprights to crossing services
service_line_colour colour box available colours

colour of the crossing service uprights.

Service chainage text parameters
Panel Field Parameter name Type Pop-Up

Colour service_ch_text_colour colour box available colours

text colour of crossing service chainage box values (required only if different from default 
box_text_colour).

Text size (mm) service_ch_text_size input

text size of crossing service chainage box values (required only if different from default 
box_text_size).

Textstyle service_ch_textstyle font box available fonts

font of crossing service chainage box values (required only if different from default global_textstyle).

Decimal places service_ch_decimals input

decimal places for crossing service chainage box values (required only if different from default 
number_of_decimals).

Service invert level text parameters
Panel Field Parameter name Type Pop-Up

Colour service_il_text_colour colour box available colours

text colour of crossing service invert level box values (required only if different from default 
box_text_colour).

Text size (mm) service_il_text_size input

text size of crossing service invert level box values (required only if different from default 
box_text_size).

Textstyle service_il_textstyle font box available fonts

font of crossing service invert level box values (required only if different from default 
global_textstyle).

Decimal places service_il_decimals input

decimal places for crossing service invert level box values (required only if different from default 
number_of_decimals).

Service label text parameters
Panel Field Parameter name Type Pop-Up

Distance of label below crossing point (mm)
service_name_y input

distance (in millimetres) of crossing service name labels below crossing points.

Colour service_name_text_colour
colour box available colours
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text colour of crossing service name labels (required only if different from default box_text_colour).

Text size (mm) service_name_text_size input

text size of crossing service name labels (required only if different from default box_text_size).

Textstyle service_name_textstyle font box available fonts

font of crossing service name labels (required only if different from default global_textstyle).

Decimal places service_name_decimals input

decimal places for the crossing service invert levels that make up part of the crossing service name 
labels (required only if different from default number_of_decimals).

Drainage_Plot_Chainages_Uprights_Finished_surface_Top_of_MH_values

Finished surface/Top of MH values
In addition to the finished surface level labels within the Boxes area, more detailed vertical labels 
representing finished surface levels at the pits, can be added to accompany the pit uprights within the 
Graph area.

Panel Field Parameter name Type Pop-Up

Finished surface draw mode
draw_fs_vertical choice box do not draw fs values

always draw fs values
only draw if different

whether to label the finished surface levels within the Graph area. Additional control is provided to 
only draw the labels if the finished surface level is different from the level at the top of the maintenance 
hole.

Finished surface value mode
draw_fs_vertical_mode choice box value from fs tin

value from top of mh

whether the finished surface level label values come from the fs tin or the top of the maintenance holes.

Pre text fs_vertical_pre_text input

label text before the finished surface level.

Post text fs_vertical_post_text input

label text after the finished surface level.

Decimal places fs_vertical_decimals input

decimal places for finished surface level values (required only if different from default 
number_of_decimals).

Colour fs_vertical_colour colour box available colours

text colour of finished surface level labels (required only if different from default box_text_colour).

Size (mm) fs_vertical_size input

text size of finished surface level labels (required only if different from default box_text_size).

Textstyle fs_vertical_textstyle font box available fonts

font of finished surface level labels (required only if different from default global_textstyle).

X adjustment (mm) fs_vertical_x input

horizontal adjustment to position of finished surface level labels.

Y adjustment (mm) fs_vertical_y input

vertical adjustment to position of finished surface level labels.
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Drainage_Plot_Chainages_Uprights_Staggering

Staggering
Because the pit and service uprights are sometimes too close together to fit all the desired information in 
the Boxes and Arrows areas, the uprights can be staggered (widened) in such a way as to provide more 
space in these areas, below and above the Graph area, whilst still maintaining the correct upright spacing 
within the Graph area itself. Specifically, the staggering of the uprights occurs below the Graph area 
between Arrow areas 1 and 2, and above the Graph area between Arrow areas 3 and 4. As such, it is 
recommended that Arrow areas 2 and 3 be used only for information requiring minimal space.

Stagger area below graph area parameters
Panel Field Parameter name Type

Top of arrow area 1 to start of the staggers (mm)
stagger_height_1 input

refer to stagger_height_1 on above diagram.

Distance over which stagger occurs (mm)
stagger_height_2 input

refer to stagger_height_2 on above diagram.

End of the staggers to bottom of arrow area 2 (mm)
stagger_gap_bottom input

refer to stagger_gap_bottom on above diagram.

Stagger area above graph area parameters
Panel Field Parameter name Type

Top of arrow area 3 to start of the staggers (mm)
stagger_gap_top input

refer to stagger_gap_top on above diagram.

Distance over which stagger occurs (mm)
stagger_height_3 input

refer to stagger_height_3 on above diagram.

End of the staggers to bottom of arrow area 4 (mm)
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stagger_height_4 input

refer to stagger_height_4 on above diagram.

Text offset parameters
Panel Field Parameter name Type

Minimum distance for text after pit values (mm)
horizontal_text_gap input

refer to horizontal_text_gap on above diagram.

Minimum distance for text after service values (mm)
service_text_gap input

refer to service_text_gap on above diagram.

Datum area
Drainage_Plot_Datum_area

The Datum area is where each long section plot’s datum value is drawn. The datum line for each long 
section plot is defined at the bottom of Arrow area 1.

Panel Field Parameter name Type

Below datum area gap (mm)
datum_gap input

distance from the top of the Boxes area to the bottom of Arrow area 1.

Drainage_Plot_Datum_area_Name

Name
The datum name (or title) is drawn at the datum line, above the Boxes title area.

Panel Field Parameter name Type Pop-Up

Datum name datum_name input

title for the datum area.

X offset (mm) datum_title_x input

horizontal adjustment to position of datum name.

Y offset (mm) datum_title_y input

vertical adjustment to position of datum name.

Textstyle datum_title_textstyle font box available fonts

font of datum name (required only if different from default global_textstyle).

Text size (mm) datum_title_text_size input

text size of datum name (required only if different from default box_text_size).

Colour datum_title_colour colour box available colours

text colour of datum name (required only if different from default box_text_colour).

Drainage_Plot_Datum_area_Values

Values
The datum values are drawn at the datum lines, above the Box values areas.

Panel Field Parameter name Type Pop-Up

Decimal places datum_decimals input
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number of decimal places for datum values.

X offset (mm) datum_x input

horizontal adjustment to position of datum values.

Y offset (mm) datum_y input

vertical adjustment to position of datum values.

Textstyle datum_textstyle font box available fonts

font of datum values (required only if different from default global_textstyle).

Text size (mm) datum_text_size input

text size of datum values (required only if different from default box_text_size).

Colour datum_text_colour colour box available colours

text colour of datum values (required only if different from default box_text_colour).

Arrows
Drainage_Plot_Arrows

The Arrow areas on the drainage long section plot, are used to label segments (individual pipes) on the 
drainage strings with the following information: grades, diameters and types, flow velocities, flow 
volumes, drainage line names, and any user-defined pipe attribute values.

There are four separate Arrow areas on the plot, any of which can be used to label the above information. 
From plot bottom to top, the Arrow areas are:

Arrow area 1: staggered arrows below the Graph area,
Arrow area 2: unstaggered arrows below the Graph area,
Arrow area 3: unstaggered arrows above the Graph area,
Arrow area 4: staggered arrows above the Graph area.

Panel Field Parameter name Type

Height of arrow area 1 (mm)
arrow_area_1 input

refer to arrow_area_1 on the above diagram.
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Height of arrow area 2 (mm)
arrow_area_2 input

refer to arrow_area_2 on the above diagram.

Height of arrow area 3 (mm)
arrow_area_3 input

refer to arrow_area_3 on the above diagram.

Height of arrow area 4 (mm)
arrow_area_4 input

refer to arrow_area_4 on the above diagram.

Drainage_Plot_Arrows_Grades

Grades
Panel Field Parameter name Type Pop-Up

Draw pipe grade draw_pipe_grade check box

whether to draw the pipe grades in one of the Arrow areas.

Arrow area for the arrow pipe_grade_arrow_area choice box Area 1
Area 2
Area 3
Area 4

the desired Arrow area for the pipe grade information.

Y offset (mm) pipe_grade_y input

vertical offset of pipe grade information, measured upwards from the bottom of the selected Arrow 
area.

Grade mode percentage_grade choice box 1 in grade
% grade

determines the format of the pipe grade information.

Drainage_Plot_Arrows_Grades_Title_text

Grades: Title text
Panel Field Parameter name Type Pop-Up

Text pipe_grade_title input

title for the pipe grade information.

Textstyle pipe_grade_title_textstyle
font box available fonts

font of pipe grade title.

Size (mm) pipe_grade_title_text_size
input

text size of pipe grade title.

Colour pipe_grade_title_text_colour
colour box available colours

text colour of pipe grade title.

Offset (mm) pipe_grade_title_offset input

vertical adjustment to position of pipe grade title.

X offset (mm) pipe_grade_title_x input
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horizontal adjustment to position of pipe grade title.

Drainage_Plot_Arrows_Grades_Arrow_type

Grades: Arrow type
Panel Field Parameter name Type Pop-Up

Arrow type pipe_grade_arrow_mode choice box available arrow types

arrow type (0 to 8) for the pipe grade information.

Colour pipe_grade_arrow_colour
colour box available colours

arrow colour for pipe grade information.

Size (mm) pipe_grade_arrow_size input

arrow size for pipe grade information.

Arrow gap mode pipe_grade_arrow_gap choice box no gap in arrow
leave gap in arrow for text

whether to put text gaps in the arrows, for pipe grade information.

Drainage_Plot_Arrows_Grades_Arrow_text

Grades: Arrow text
Panel Field Parameter name Type Pop-Up

Pre text pipe_grade_arrow_pre_text
input

label text before the pipe grade values.

Post text pipe_grade_arrow_post_text
input

label text after the pipe grade values.

Decimal places pipe_grade_arrow_decimals
input

decimal places for pipe grade values.

Colour pipe_grade_arrow_text_colour
colour box available colours

text colour for pipe grade values.

Size (mm) pipe_grade_arrow_text_size
input

text size for pipe grade values.

Textstyle pipe_grade_arrow_textstyle
font box available fonts

font of pipe grade values.

Offset (mm) pipe_grade_arrow_text_offset
input

vertical adjustment to position of pipe grade values.

Drainage_Plot_Arrows_Diameters

Diameters
Panel Field Parameter name Type Pop-Up

Pipe diameter scale factor
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pipe_diameter_scale_factor
input

multiplier of pipe diameter values.

Draw pipe diameter mode
draw_pipe_diameter choice box don’t draw pipe diameter

draw pipe diameter

whether to draw the pipe diameters in one of the Arrow areas.

Arrow area for the arrow pipe_diameter_arrow_area
choice box Area 1

Area 2
Area 3
Area 4

the desired Arrow area for the pipe diameter information.

Y offset (mm) pipe_diameter_y input

vertical offset of pipe diameter information, measured upwards from the bottom of the selected Arrow 
area.

Drainage_Plot_Arrows_Diameters_Title_text

Diameters: Title text
Panel Field Parameter name Type Pop-Up

Text pipe_diameter_title input

title for the pipe diameter information.

Textstyle pipe_diameter_title_textstyle
font box available fonts

font of pipe diameter title.

Size (mm) pipe_diameter_title_text_size
input

text size of pipe diameter title.

Colour pipe_diameter_title_text_colour
colour box available colours

text colour of pipe diameter title.

Offset (mm) pipe_diameter_title_offset
input

vertical adjustment to position of pipe diameter title.

X offset (mm) pipe_diameter_title_x input

horizontal adjustment to position of pipe diameter title.

Drainage_Plot_Arrows_Diameters_Arrow_type

Diameters: Arrow type
Panel Field Parameter name Type Pop-Up

Arrow type pipe_diameter_arrow_mode
choice box available arrow types

arrow type (0 to 8) for the pipe diameter information.

Colour pipe_diameter_arrow_colour
colour box available colours
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arrow colour for pipe diameter information.

Size (mm) pipe_diameter_arrow_size
input

arrow size for pipe diameter information.

Arrow gap mode pipe_diameter_arrow_gap
choice box no gap in arrow

leave gap in arrow for text

whether to put text gaps in the arrows, for pipe diameter information.

Drainage_Plot_Arrows_Diameters_Arrow_text

Diameters: Arrow text
Panel Field Parameter name Type Pop-Up

Pre text pipe_diameter_arrow_pre_text
input

label text before the pipe diameter values.

Post text pipe_diameter_arrow_post_text
input

label text after the pipe diameter values.

Pipe type mode pipe_type_mode choice box don’t include the pipe type
include the pipe type

whether to include the pipe type after the post text in the pipe diameter labels.

Colour pipe_diameter_arrow_text_colour
colour box available colours

text colour for pipe diameter values.

Size (mm) pipe_diameter_arrow_text_size
input

text size for pipe diameter values.

Textstyle pipe_diameter_arrow_textstyle
font box available fonts

font of pipe diameter values.

Offset (mm) pipe_diameter_arrow_text_offset
input

vertical adjustment to position of pipe diameter values.

Drainage_Plot_Arrows_Velocities

Velocities
Panel Field Parameter name Type Pop-Up

Draw pipe velocity draw_pipe_velocity check box

whether to draw the flow velocities in one of the Arrow areas.

Arrow area for the arrow pipe_velocity_arrow_areachoice box Area 1
Area 2
Area 3
Area 4

the desired Arrow area for the flow velocity information.

Y offset (mm) pipe_velocity_y input
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vertical offset of flow velocity information, measured upwards from the bottom of the selected Arrow 
area.

Drainage_Plot_Arrows_Velocities_Title_text

Velocities: Title text
Panel Field Parameter name Type Pop-Up

Text pipe_velocity_title input

title for the flow velocity information.

Textstyle pipe_velocity_title_textstyle
font box available fonts

font of flow velocity title.

Size (mm) pipe_velocity_title_text_size
input

text size of flow velocity title.

Colour pipe_velocity_title_text_colour
colour box available colours

text colour of flow velocity title.

Offset (mm) pipe_velocity_title_offset input

vertical adjustment to position of flow velocity title.

X offset (mm) pipe_velocity_title_x input

horizontal adjustment to position of flow velocity title.

Drainage_Plot_Arrows_Velocities_Arrow_type

Velocities: Arrow type
Panel Field Parameter name Type Pop-Up

Arrow type pipe_velocity_arrow_mode
choice box available arrow types

arrow type (0 to 8) for the flow velocity information.

Colour pipe_velocity_arrow_colour
colour box available colours

arrow colour for flow velocity information.

Size (mm) pipe_velocity_arrow_size input

arrow size for flow velocity information.

Arrow gap mode pipe_velocity_arrow_gap choice box no gap in arrow
leave gap in arrow for text

whether to put text gaps in the arrows, for flow velocity information.

Drainage_Plot_Arrows_Velocities_Arrow_text

Velocities: Arrow text
Panel Field Parameter name Type Pop-Up

Pre text pipe_velocity_arrow_pre_text
input

label text before the flow velocity values.

Post text pipe_velocity_arrow_post_text
input
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label text after the flow velocity values.

Decimal places pipe_velocity_arrow_decimals
input

decimal places for flow velocity values.

Colour pipe_velocity_arrow_text_colour
colour box available colours

text colour for flow velocity values.

Size (mm) pipe_velocity_arrow_text_size
input

text size for flow velocity values.

Textstyle pipe_velocity_arrow_textstyle
font box available fonts

font of flow velocity values.

Offset (mm) pipe_velocity_arrow_text_offset
input

vertical adjustment to position of flow velocity values.

Drainage_Plot_Arrows_Flow

Flow
Panel Field Parameter name Type Pop-Up

Draw pipe flow draw_pipe_flow check box

whether to draw the flow volumes in one of the Arrow areas.

Arrow area for the arrow pipe_flow_arrow_area choice box Area 1
Area 2
Area 3
Area 4

the desired Arrow area for the flow volume information.

Y offset (mm) pipe_flow_y input

vertical offset of flow volume information, measured upwards from the bottom of the selected Arrow 
area.

Drainage_Plot_Arrows_Flow_Title_text

Flow: Title text
Panel Field Parameter name Type Pop-Up

Text pipe_flow_title input

title for the flow volume information.

Textstyle pipe_flow_title_textstyle font box available fonts

font of flow volume title.

Size (mm) pipe_flow_title_text_size input

text size of flow volume title.

Colour pipe_flow_title_text_colour
colour box available colours

text colour of flow volume title.

Offset (mm) pipe_flow_title_offset input
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vertical adjustment to position of flow volume title.

X offset (mm) pipe_flow_title_x input

horizontal adjustment to position of flow volume title.

Drainage_Plot_Arrows_Flow_Arrow_type

Flow: Arrow type
Panel Field Parameter name Type Pop-Up

Arrow type pipe_flow_arrow_mode choice box available arrow types

arrow type (0 to 8) for the flow volume information.

Colour pipe_flow_arrow_colour colour box available colours

arrow colour for flow volume information.

Size (mm) pipe_flow_arrow_size input

arrow size for flow volume information.

Arrow gap mode pipe_flow_arrow_gap choice box no gap in arrow
leave gap in arrow for text

whether to put text gaps in the arrows, for flow volume information.

Drainage_Plot_Arrows_Flow_Arrow_text

Flow: Arrow text
Panel Field Parameter name Type Pop-Up

Pre text pipe_flow_arrow_pre_text
input

label text before the flow volume values.

Post text pipe_flow_arrow_post_text
input

label text after the flow volume values.

Decimal places pipe_flow_arrow_decimals
input

decimal places for flow volume values.

Colour pipe_flow_arrow_text_colour
colour box available colours

text colour for flow volume values.

Size (mm) pipe_flow_arrow_text_size
input

text size for flow volume values.

Textstyle pipe_flow_arrow_textstyle
font box available fonts

font of flow volume values.

Offset (mm) pipe_flow_arrow_text_offset
input

vertical adjustment to position of flow volume values.

Drainage_Plot_Arrows_Drainage_line_name

Drainage line name
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Panel Field Parameter name Type Pop-Up

Draw drainage line draw_drainage_line check box

whether to draw the drainage line names in one of the Arrow areas.

Arrow area for the arrow drainage_line_arrow_area
choice box Area 1

Area 2
Area 3
Area 4

the desired Arrow area for the drainage line name information.

Y offset (mm) drainage_line_y input

vertical offset of drainage line name information, measured upwards from the bottom of the selected 
Arrow area.

Drainage_Plot_Arrows_Drainage_line_name_Title_text

Drainage line name: Title text
Panel Field Parameter name Type Pop-Up

Text drainage_line_title input

title for the drainage line name information.

Textstyle drainage_line_title_textstyle
font box available fonts

font of drainage line name title.

Size (mm) drainage_line_title_text_size
input

text size of drainage line name title.

Colour drainage_line_title_text_colour
colour box available colours

text colour of drainage line name title.

Offset (mm) drainage_line_title_offset input

vertical adjustment to position of drainage line name title.

X offset (mm) drainage_line_title_x input

horizontal adjustment to position of drainage line name title.

Drainage_Plot_Arrows_Drainage_line_name_Arrow_type

Drainage line name: Arrow type
Panel Field Parameter name Type Pop-Up

Arrow type drainage_line_arrow_mode
choice box available arrow types

arrow type (0 to 8) for the drainage line name information.

Colour drainage_line_arrow_colour
colour box available colours

arrow colour for drainage line name information.

Size (mm) drainage_line_arrow_size
input

arrow size for drainage line name information.
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Arrow gap mode drainage_line_arrow_gapchoice box no gap in arrow
leave gap in arrow for text

whether to put text gaps in the arrows, for drainage line name information.

Drainage_Plot_Arrows_Drainage_line_name_Arrow_text

Drainage line name: Arrow text
Panel Field Parameter name Type Pop-Up

Pre text drainage_line_arrow_pre_text
input

label text before the drainage line names.

Post text drainage_line_arrow_post_text
input

label text after the drainage line names.

Colour drainage_line_arrow_text_colour
colour box available colours

text colour for drainage line names.

Size (mm) drainage_line_arrow_text_size
input

text size for drainage line names.

Textstyle drainage_line_arrow_textstyle
font box available fonts

font of drainage line names.

Offset (mm) drainage_line_arrow_text_offset
input

vertical adjustment to position of drainage line names.

Drainage_Plot_Arrows_User_defined_pipe_attributes

User defined pipe attributes
User defined pipe attribute data can be drawn in the Arrow areas.

The following fields are required for each desired pipe attribute (set). Each set of fields forms one row of a 
grid.

Panel Field Parameter name Type Pop-Up

Set # input

a unique integer n, greater than 0, to identify the nth set of pipe attribute plot parameters.

Draw pipe attribute mode draw_pipe_attr_n choice box don’t draw pipe attribute
draw pipe attribute

whether to draw the nth set of pipe attribute data in one of the Arrow areas.

Attribute name pipe_attr_n_name input

name of the nth pipe attribute.

Arrow area for the arrow pipe_attr_n_arrow_area choice box Area 1
Area 2
Area 3
Area 4

the desired Arrow area for the nth set of pipe attribute data.

Y offset (mm) pipe_attr_n_y input
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vertical offset of the nth set of pipe attribute data, measured upwards from the bottom of the selected 
Arrow area.

Drainage_Plot_Arrows_User_defined_pipe_attributes_Title_text

User defined pipe attributes: Title text
The following fields are required for each desired pipe attribute (set). Each set of fields forms one row of a 
grid.

Panel Field Parameter name Type Pop-Up

Set # input

a unique integer n, greater than 0, to identify the nth set of pipe attribute plot parameters. The Set # 
should match one of the Set #’s from the grid in the parent node: "User defined pipe attributes".

Text pipe_attr_n_title input

title for the nth set of pipe attribute data.

Textstyle pipe_attr_n_title_textstyle
font box available fonts

font of the title for the nth set of pipe attribute data.

Size (mm) pipe_attr_n_title_text_size
input

text size of the title for the nth set of pipe attribute data.

Colour pipe_attr_n_title_text_colour
colour box available colours

text colour of the title for the nth set of pipe attribute data.

Offset (mm) pipe_attr_n_title_offset input

vertical adjustment to position of the title for the nth set of pipe attribute data.

X offset (mm) pipe_attr_n_title_x input

horizontal adjustment to position of the title for the nth set of pipe attribute data.

Drainage_Plot_Arrows_User_defined_pipe_attributes_Arrow_type

User defined pipe attributes: Arrow type
The following fields are required for each desired pipe attribute (set). Each set of fields forms one row of a 
grid.

Panel Field Parameter name Type Pop-Up

Set # input

a unique integer n, greater than 0, to identify the nth set of pipe attribute plot parameters. The Set # 
should match one of the Set #’s from the grid in the parent node: "User defined pipe attributes".

Arrow type pipe_attr_n_arrow_mode choice box available arrow types

arrow type (0 to 8) for the nth set of pipe attribute data.

Colour pipe_attr_n_arrow_colourcolour box available colours

arrow colour for the nth set of pipe attribute data.

Size (mm) pipe_attr_n_arrow_size input

arrow size for the nth set of pipe attribute data.

Arrow gap mode pipe_attr_n_arrow_gap choice box no gap in arrow
leave gap in arrow for text

whether to put text gaps in the arrows, for the nth set of pipe attribute data.
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Drainage_Plot_Arrows_User_defined_pipe_attributes_Arrow_text

User defined pipe attributes: Arrow text
The following fields are required for each desired pipe attribute (set). Each set of fields forms one row of a 
grid.

Panel Field Parameter name Type Pop-Up

Set # input

a unique integer n, greater than 0, to identify the nth set of pipe attribute plot parameters. The Set # 
should match one of the Set #’s from the grid in the parent node: "User defined pipe attributes".

Pre text pipe_attr_n_arrow_pre_text
input

label text before the values of the nth set of pipe attribute data.

Post text pipe_attr_n_arrow_post_text
input

label text after the values of the nth set of pipe attribute data.

Decimal places pipe_attr_n_arrow_decimals
input

decimal places the values of the nth set of pipe attribute data.

Colour pipe_attr_n_arrow_text_colour
colour box available colours

text colour for the values of the nth set of pipe attribute data.

Size (mm) pipe_attr_n_arrow_text_size
input

text size for the values of the nth set of pipe attribute data.

Textstyle pipe_attr_n_arrow_textstyle
font box available fonts

font for the values of the nth set of pipe attribute data.

Offset (mm) pipe_attr_n_arrow_text_offset
input

vertical adjustment to position of values of the nth set of pipe attribute data.

Graph area
Drainage_Plot_Graph_area

The Graph area is where the diagram of the drainage line, in long-section, is drawn. In addition, if 
Hydraulic Grade Line (HGL) information is set, the HGL can also be drawn in the Graph area.

Panel Field Parameter name Type Pop-Up

Draw hgl diag draw_hgl_diag check box

whether to draw the HGL in the Graph area.

Colour of hgl hgl_colour colour box available colours

colour of HGL.

Top area
Drainage_Plot_Top_area
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Panel Field Parameter name Type Pop-Up

Line at the bottom of the top area mode
draw_top_line choice box don’t draw line

draw line

whether to draw a horizontal line at the bottom of the Top area.

Corridors
Drainage_Plot_Corridors

A corridor around the primary string is defined by giving a left and right corridor width.

Any string in a model added to the section view is checked to see if it appears in the corridor, and if it does, 
it is drawn on the long section plot.

To be drawn, strings do not have to cross the primary string, but just be in the corridor.

Panel field Parameter name Type

Left corridor width (world units)
corridor_width_left input

left corridor width

Right corridor width (world units)
corridor_width_right input

right corridor width

Left corridor overlap (world units)
corridor_overlap_left input

left corridor overlap

Right corridor overlap (world units)
corridor_overlap_right input

right corridor overlap

Chord-arc tolerance (world units)
corridor_chord_arc input

chord-arc tolerance used near any bends in the corridor.

primary string corridor_width_left

corridor_width_right

pipe string
strings (no diameter)

plan view

(design long section)

tin (natural surface)

design long section

services in
the corridor

section view
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Drainage_Plot_Corridors_Model_selectionModel selection
Panel field Parameter name Type

Corridor model corridor_model_n model box

models containing tins and service strings to be drawn on the section. Where n = 1, 2, ... ,100 given by 
line number on grid.

Maintenance hole symbols
Drainage_Plot_Maintenance_hole_symbols

Symbols representing the different types of maintenance holes used, can be drawn on the plots. 

The following fields form one set (grid row) of controls for the placement of MH symbols on the plot. 
Normally, the grid will contain one row for each MH type/symbol used.

Panel Field Parameter name Type Pop-Up

Set # input

a unique integer n, greater than 0, to identify the nth set of MH symbol plot parameters.

MH type manhole_symbol_n_type
choice box available MH types

the MH type to associate with the Set #, n.

MH symbol mode manhole_symbol_n_mode
choice box cross (0)

up from centre of box (1)
up&down from box centre(2)
square (3)
triangle, base at bottom (4)
circle (5)
use a symbol

for the nth MH type, whether to use one of the hard-wired symbols (1-5), or a symbol from the defined 
symbols list.

MH symbol position manhole_symbol_n_position
choice box at top of mh

above top of boxes
above highest point
to primary string
to first found tin

for the nth MH type, the desired position of the symbol.

Size (mm) manhole_symbol_n_size
input

for the nth MH type, the symbol size.

X (mm) manhole_symbol_n_x input

for the nth MH type, the horizontal adjustment to the selected MH symbol position.

Y (mm) manhole_symbol_n_y input

for the nth MH type, the vertical adjustment to the selected MH symbol position.

Symbol manhole_symbol_n_style
choice box available symbols

for the nth MH type, and with manhole_symbol_n_mode set to use a symbol, the symbol to use 
from the defined symbols list.
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Angle (dms) manhole_symbol_n_angle
angle box

for the nth MH type, the symbol angle.

Colour manhole_symbol_n_colour
colour box available colours

for the nth MH type, the symbol colour.

Maintenance hole names/types/bubbles
Drainage_Plot_Maintenance_hole_names_types_bubbles

Panel Field Parameter name Type Pop-Up

Include line name mode draw_line_name choice box don’t include line name
include line name

whether to include the drainage line name in the MH name label.

Include pit name mode draw_pit_name choice box don’t include pit name
include pit name

whether to include the MH name in the MH name label.

Include pit type mode draw_pit_type choice box don’t include pit type
include pit type

whether to include the MH type in the MH name label.

Size (mm) bubble_text_size input

text size of MH name label.

Colour bubble_text_colour colour box available colours

text colour of MH name label.

Textstyle bubble_textstyle font box available fonts

font of MH name label.

X adjustment (mm) bubble_text_x input

horizontal adjustment to position of MH name label.

Y adjustment (mm) bubble_text_y input

vertical adjustment to position of MH name label.

Pre text bubble_pre_text input

text to go before MH name label.

Post text bubble_post_text input

text to go after MH name label.

Text angle (dms) bubble_text_angle angle box

text angle of MH name label.

Text justification bubble_text_justify justification box

text justification of MH name label.

Bubble radius (mm) bubble_radius input

radius of bubble around MH name label. Zero (0) for no bubble.

Bubble colour bubble_colour colour box available colours

colour of bubble around MH name label.
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Bubble length (mm) bubble_length input

length of bubble around MH name label. Zero (0) for circular bubble.

Bubble text position draw_text_at_pit choice box draw bubble&text in top area
draw bubble&text above pit

whether to position the MH name labels and bubbles in the Top area, or directly above the pits.

Distance to add to place bubble above the pit (mm)
distance_above_pit input

for draw_text_at_pit set to draw bubble & text above pit, distance to add between top of pit and 
bottom of bubble.

Pits/Junctions direction changes
Drainage_Plot_Pits_Junctions_direction_changes

Drainage_Plot_Pits_Junctions_direction_changes_Junction_name

Junction name
Drainage_Plot_Pits_Junctions_direction_changes_Junction_angle

Junction angle

Property controls/House connections
Drainage_Plot_Property_controls_House_connections

Property control parameters

House connection parameters
Drainage_Plot_Property_controls_House_connections_House_connection_labels

House connection labels
Drainage_Plot_Property_controls_House_connections_House_connection_labels_House_conne
ction_type

House connection labels: House connection type
Drainage_Plot_Property_controls_House_connections_House_connection_labels_Distance

House connection labels: Distance
Drainage_Plot_Property_controls_House_connections_House_connection_labels_Depths

House connection labels: Depths
Drainage_Plot_Property_controls_House_connections_House_connection_labels_Finished_surf
ace

House connection labels: Finished surface
Drainage_Plot_Property_controls_House_connections_Property_control_labels_Invert_levels

House connection labels: Invert levels
Drainage_Plot_Property_controls_House_connections_Property_control_labels

Property control labels
Drainage_Plot_Property_controls_House_connections_Property_control_labels_Symbols

Property control labels: Symbols
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Drainage_Plot_Property_controls_House_connections_Property_control_labels_Distance

Property control labels: Distance
Drainage_Plot_Property_controls_House_connections_Property_control_labels_Depths

Property control labels: Depths
Drainage_Plot_Property_controls_House_connections_Property_control_labels_Finished_surfac
e

Property control labels: Finished surface
Drainage_Plot_Property_controls_House_connections_Property_control_labels_Invert_levels

Property control labels: Invert levels

Hatching cut/fill
Drainage_Plot_Hatching_cut_fill

This option is used to hatch cut and/or fill areas between sets of tins.

For each set, the name of the two tins, the hatch linestyle, colour and separation and whether cut and/or fill 
regions are required are all user definable.

Up to twenty (20) separate sets of tins may be hatched.

Panel Field Parameter name Type

Define Set # input

set number to be used to define different original/new tin sets.

Original tin hatch_original_tin_n tin box

tin_name for original surface

New tin hatch_new_tin_n tin box

tin_name for final surface

Notes

(a) cut is when the new tin is below the original tin.
fill is when the new tin is above the original tin.

(b) cut hatching is turned off by setting hatch_cut_separation_n to 0.0.
fill hatching is turned off by setting hatch_fill_separation_n to 0.0.

Drainage_Plot_Hatching_cut_fill_Cut

Cut
Panel Field Parameter name Type

Use Set # input

set number as specified in the Define set#.

section viewtin (natural surface)

design long section cut

fill
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Cut separation (mm) hatch_cut_separation_n input

distance between cut hatch lines. If 0, no hatching.

Cut hatch angle (dms) hatch_cut_angle_n input

angle of hatching.

Cut colour hatch_cut_colour_n colour box

colour of the hatching.

Cut linestyle hatch_cut_linestyle_n linestyle box

linestyle of the hatching.

Draw sides of cuts hatch_cut_draw_sides_n choice box

draw mode for sides of cut regions.

Draw original tin hatch_cut_draw_original_n choice box

draw mode for sides of original tin in cut.

Draw new tin hatch_cut_draw_new_n choice box

draw mode for sides of new tin in cut.

Drainage_Plot_Hatching_cut_fill_Fill

Fill
Panel Field Parameter name Type

Use Set # input

set number as specified in the Define set#.

Fill separation (mm) hatch_fill_separation_n input

distance between fill hatch lines. If 0, no hatching.

Fill hatch angle (dms) hatch_fill_angle_n input

angle of hatching.

Fill colour hatch_fill_colour_n colour box

colour of the hatching.

Fill linestyle hatch_fill_linestyle_n linestyle box

linestyle of the hatching.

Draw sides of fills hatch_fill_draw_sides_n choice box

draw mode for sides of fill regions.

Draw original tin hatch_fill_draw_original_n choice box

draw mode for sides of original tin in fill.

Draw new tin hatch_fill_draw_new_n choice box

draw mode for sides of new tin in fill.

Cuts
Drainage_Plot_Cuts

The cuts that the primary string (design line) makes though strings in any user-specified model can be 
automatically labelled on the long section plots.

The height, chainage and name of the cut string can be labelled as well as a symbol. The height of tins at 
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the same offset value can also be labelled.

The chainage position for the labelling is the chainage of the cut string.

The height position for the labelling can be specified as the:

(a) top of the boxes on the long section,

(b) height value of the cut string,

(c) height of the primary string,

(d) height of a tin.

The actual position of the label is defined relative to the above point.

Note: Only case (b) involves the actual height of the cut string. For all other cases, only the chainage of the 
cut string is used. Hence for all cases except (b), the string does need to have a sensible height to be used 
for cuts through strings. For example, a boundary string may have null heights but only the chainage is 
required and the height of the tin at that chainage can be used as the height (case (d)).

The method for specifying which strings are to be checked for cuts is by first specifying the model which 
contains the strings, and then a name mask which is used to restrict the strings in the model to only those 
whose names match the name mask.

Up to twenty five different sets of models and name masks can be used so that different cut sets can be 
labelled in different ways.

Panel Field Parameter name Type

Define Set # input

set number to be used to define different model/mask sets.

Model cuts_n_model model box

model from which cut masks are derived

Name mask cuts_n_mask input

text string containing the name masks, each separated by one or more spaces, to test the string name 
against. Each mask can include wild cards and wild characters.
For example: "ke*" or,

"?bank*" or, if both masks are required,
"ke* ?bank*"

If cuts_n_mask is blank, then all strings in the model are used. This is equivalent to name mask being 
set to "*".

All strings in the model cuts_n_model whose name satisfy the name mask cuts_n_mask are then checked 
for cuts with the design string, and if a cut occurs, the cut point will be labelled according to the rest of the 
parameters in the nth set.

primary string

strings to label where they are cut by the design string

plan view

(design string)

tin (natural surface)

design long section

points where strings are cut
in plan by the long section

section view
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Drainage_Plot_Cuts_Chainage

Chainage
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Position cuts_chainage_n_position
choice box above cut string height value

above top of boxes
to primary string 
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of chainage label.

X (mm) cuts_chainage_n_x input

horizontal adjustment to position of chainage text.

Y (mm) cuts_chainage_n_y input

vertical adjustment to position of chainage text.

Angle (dms) cuts_chainage_n_angle input

rotation of chainage text about position.

Colour cuts_chainage_n_colour colour box

colour of chainage text.

Size (mm) cuts_chainage_n_size input

size of chainage text. A value of 0 means no label.

Textstyle cuts_chainage_n_textstyle
text box

textstyle of chainage text.

design long section

section view

point where the design
cuts a string 

The cut point can be labelled with
chainage of the cut point
height of the cut point
height of the x-section or tins at this offset
name of the string for the cut point

User defined symbols can also be drawn at the cut 
point

tin (natural surface)
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Pre-text cuts_chainage_n_pre_text
input

text before chainage text.

Post-text cuts_chainage_n_post_text
input

text after chainage text.

Justification cuts_chainage_n_justification
justification box

bottom-left
bottom-centre
bottom-right
bottom-decimal
middle-left
middle-centre
middle-right
middle-decimal
top-left
top-centre
top-right
top-decimal
decimal-left
decimal-centre
decimal-right
decimal-point

justification of the chainage text.

Decimals cuts_chainage_n_no_decimals
input

number of decimals in chainage.

Drainage_Plot_Cuts_Heights

Heights
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Mode cuts_height_n_mode choice box use height of cut point
use real height above boxes
height of primary string
use height of tin 1
use height of tin 2
use height of tin 3
use height of tin 4
use height of tin 5
use height of tin 6
use height of tin 7
use height of tin 8
use height of tin 9
use height of tin 10

determines which height value is labelled.

Position cuts_height_n_position choice box at cut string
above top of boxes 
above top of graph area
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to primary string 
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of height label.

X (mm) cuts_height_n_x input

horizontal adjustment to position of height text.

Y (mm) cuts_height_n_y input

vertical adjustment to position of height text.

Angle (dms) cuts_height_n_angle input

rotation of height text about position.

Colour cuts_height_n_colour colour box

colour of height text.

Size (mm) cuts_height_n_size input

size of height text. A value of 0 means no label.

Textstyle cuts_height_n_textstyle text box

textstyle of height text.

Pre-text cuts_height_n_pre_text input

text before height text.

Post-text cuts_height_n_post_text input

text after height text.

Justification points_height_n_justification
justification box

bottom-left
bottom-centre
bottom-right
bottom-decimal
middle-left
middle-centre
middle-right
middle-decimal
top-left
top-centre
top-right
top-decimal
decimal-left
decimal-centre
decimal-right
decimal-point

justification of the height text.

Decimals cuts_height_n_no_decimals
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input

number of decimals in height.

Drainage_Plot_Cuts_Labels

Labels
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Position cuts_label_n_position choice box at cut string height
above top of boxes
above top of graph area
to primary string
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

position of label text.

Mode cuts_label_n_mode choice box don’t include string name
include cut string name

determines whether the label includes the cut string name.

X (mm) cuts_label_n_x input

horizontal adjustment to position of label.

Y (mm) cuts_label_n_y input

vertical adjustment to position of label.

Angle (dms) cuts_label_n_angle input

rotation of label about position.

Colour cuts_label_n_colour colour box

colour of label.

Size (mm) cuts_label_n_size input

size of label. A value of 0 means no label.

Textstyle cuts_label_n_textstyle text box

textstyle of label.

Pre-text cuts_label_n_pre_text input

text before label.

Post-text cuts_label_n_post_text input

text after label.

Justification cuts_label_n_justification
justification box

bottom-left
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bottom-centre
bottom-right
bottom-decimal
middle-left
middle-centre
middle-right
middle-decimal
top-left
top-centre
top-right
top-decimal
decimal-left
decimal-centre
decimal-right
decimal-point

justification of the label.

Drainage_Plot_Cuts_Symbols

Symbols
Panel Field Parameter name Type Pop-Up

Use Set # input

set number as specified in the Define set#.

Mode cuts_symbol_n_mode choice box cross (0)
up from centre of box (1)
up&down from box centre(2)
square (3)
triangle, base at bottom (4)
circle (5)
use a plot symbol

symbol mode.

Note: If a plot symbol is to be used, the cuts_symbol_n_style parameter must be specified.

Symbol cuts_symbol_n_style plot symbols

a valid plot symbol can be selected.

Position cuts_symbol_n_position choice box at cut string height
above top of boxes
above top of graph area
to primary string 
to tin 1
to tin 2
to tin 3
to tin 4
to tin 5
to tin 6
to tin 7
to tin 8
to tin 9
to tin 10

0 1 2 3 4 5

predefined symbols 0 to 5
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position of symbol.

X (mm) cuts_symbol_n_x input

horizontal adjustment to position of symbol.

Y (mm) cuts_symbol_n_y input

vertical adjustment to position of symbol.

Angle (dms) cuts_symbol_n_angle input

rotation of symbol about point.

Colour cuts_symbol_n_colour colour box

colour of symbol.

Size (mm) cuts_symbol_n_size input

size of symbol. A value of 0 means no symbol.

Primary string name label
Drainage_Plot_Primary_string_name_label

The plot can be labelled with a name under the boxes area.

The name is made up of a concatenation of the text string names:

Panel Field Parameter name Type

Name mode plot_name_string_name choice box

determines what text is placed in the name labels.

Pre-text plot_name_pre_text input

text before label.

Post-text plot_name_post_text input

text after label.

Textstyle plot_name_textstyle text box

textstyle of label.

Size (mm) plot_name_size input

size of label.

Colour plot_name_colour colour box

colour of label.

X offset (mm) plot_name_x_offset input

horizontal adjustment to position of label.

Y offset (mm) plot_name_y_offset input

vertical adjustment to position of label.

The plot name is positioned under the boxes.

The plot_name_x_offset is measured from the beginning of the height boxes.

The default for plot_name_x_offset is centred on heights area.

The plot_name_y_offset is measured from the bottom of the box area with positive being down.
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PPF’s to include
Drainage_Plot_PPF_s_to_include

Panel Field Parameter name Type Pop-Up

PPF files input

by including pre existing PPF files, the user can build up a modified version without having to set all 
the parameters.

labelling primary string name on long section plots

plot_name_x_offset

plot_name_y_offset
plot name text

heights areatitle area
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Melbourne Water Plot PPF Editor
sewer_plot_melbourne_water_ppf_editor

Position of option on menu: Plot =>Melb Water Plot PPF Editor

The Melb Water plot ppf editor is for creating and/or editing a (binary) Melbourne Water sewer 
long section ppf file and for creating a Melbourne Water sewer long section plot. An ascii version 
of the file is also produced.

Note: binary and ascii ppf’s are stored within the project (not in the folder containing the project).

On selecting the Melb Water plot ppf editor option, the Sewer Plot Melbourne Water PPF Editor 
panel is displayed.

Panel field Type

Plot parameter file file box



Chapter 24  PPF Editors

November 2002 Page 2569Melbourne Water Plot PPF Editor

name for the binary plot parameter file to read in or write out.

Read button

read the given plot parameter file in.

Write button

write out the plot parameters to the given plot parameter file. An ascii ppf file is also written out.

Plot button

use the plot parameters from the panel to create the plot.

Find button

brings up a search box. If a valid parameter name is keyed in followed by the enter key, the cursor will 
be placed in the appropriate field on the appropriate page.
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Pipeline Plot PPF Editor
pipeline_plot_ppf_editor

Position of option on menu: Plot =>Pipeline Plot PPF Editor

The pipeline plot ppf editor is for creating and/or editing a (binary) pipeline long section ppf 
file and for creating a pipeline long section plot.

Note: binary ppf’s are stored within the project (not in the folder containing the project as the 
ascii ppf’s were).

On selecting the pipeline plot ppf editor option, the Pipeline PPF Editor panel is displayed.

Panel field Type

Plot parameter file file box
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name for the binary plot parameter file to read in or write out.

Read button

read the given plot parameter file in.

Write button

write out the plot parameters to the given plot parameter file. An ascii ppf file is also written out.

Plot button

use the plot parameters from the panel to create the plot.

Find button

brings up a search box. If a valid parameter name is keyed in followed by the enter key, the cursor will 
be placed in the appropriate field on the appropriate page.
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Drainage Plan Plot PPF Editor
Drainage_Plan_Plot_PPF_Editor

Position of option on menu: Plot =>Drainage Plan Plot PPF Editor

The drainage plan plot ppf editor is for creating and/or editing a (binary) drainage and sewer 
plan plot ppf file and for creating a drainage and/or sewer plan annotation overlay model. An 
ascii version of the file is also produced.

Note: binary and ascii ppf’s are stored within the project (not in the folder containing the project).

On selecting the Drainage plan plot ppf editor option, the Drainage Plan Plot PPF Editor panel is 
displayed.

Panel field Type

Plot parameter file file box
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name for the binary plot parameter file to read in or write out.

Read button

read the given plot parameter file in.

Write button

write out the plot parameters to the given plot parameter file. An ascii ppf file is also written out.

Plot button

use the plot parameters from the panel to create the plot.

Find button

brings up a search box. If a valid parameter name is keyed in followed by the enter key, the cursor will 
be placed in the appropriate field on the appropriate page.

Drainage Plan Plot
Drainage_Plan_Plot

Note: When creating Drainage Plan Plot overlays, all distances and sizes (including text sizes, offsets, 
rises, etc.) are specified in world units.

Load design details from
Panel field Parameter name Type Pop-Up

Model input_model model available models

input model containing the drainage design strings.

Save plot annotations to
Panel field Parameter name Type Pop-Up

Model output_model model available models

output model to which the plot annotations are saved.

Clean plot model beforehand

plot_model_clean choice box smart clean
full clean

determines how to clean (delete the elements in) the output model, if it exists, before generating the plot 
annotations. In the case of a smart clean, any existing text, flow arrow and bubble annotation 
elements found that match the annotations about to be generated, will retain their pre-existing 
positions. In the case of a full clean, no information about the pre-existing plot annotation is used, and 
the new plot annotation is created from scratch.

Set colours as string colour_string_ tick box
names naming_mode

names all created plot annotation strings by their colour names. This will override any user specified 
string names defined in other sections.
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Pipes
Drainage_Plan_Plot_Pipes

Pipe representation

The fields in this section are grid column fields that may each have up to 20 sets (rows) defined.

Panel field Parameter name Type Pop-Up

Min pipe diam (m) pipe_dia_min_n input

minimum pipe diameter in metres for the nth set of pipe representations.

Max pipe diam (m) pipe_dia_max_n input

maximum pipe diameter in metres for the nth set of pipe representations. All pipes with diameters that 
fall between the min and max diameters of this set (row), will be represented according to the values of 
the other fields in this set. Pipe diameters are defined in the drainage design strings.

Representation mode pipe_dia_mode choice box none
linestyle
pipe
linestyle and pipe

determines whether to represent pipes as linestyles and/or solid pipes for the nth set of pipe 
representations.

Trim mode trim_edge_mode choice box don’t trim strings
trim pipes
trim linestyles
trim pipes and linestyles

determines whether to trim pipe and/or linestyle strings around maintenance holes for the nth set of 
pipe representations.

Colour pipe_dia_colour_n colour available colours

colour to use for the nth set of pipe representations.

Linestyle pipe_dia_linestyle_n linestyle available linestyles

MH symbol

MH name label

MH chainage label

MH depth label

MH diameter label

Pipe IL label

House connection

Flow arrow

Pipe diameter label

HC additional text label

HC chainage label

HC IL label

HC type label

Pipe
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linestyle to use for the nth set of pipe representations.

Linestyle string name pipe_dia_name_n input

string name of linestyles for the nth set of pipe representations.

Pipe string name pipe_edge_name_n input

string name of pipes for the nth set of pipe representations.

Pipe labels
Panel field Parameter name Type Pop-Up

Rise mode rise_mode choice box rise from centre of pipe
rise from edge of pipe

determines where all pipe label text rise values are measured from.

Drainage_Plan_Plot_Pipes_Pipe_diameter_labels

Pipe diameter labels
Panel field Parameter name Type Pop-Up

Label mode pipe_label_mode choice box none
pre dia post
pre dia post grade
pre dia post type grade

determines what text is to be placed for the pipe diameter labels. Pipe types and grades can be 
included, in addition to diameters. Pipe diameters, types and grades are all defined in the drainage 
design strings. Note: if a pipe attribute of real type named "width" exists and is greater than zero, the 
pipe is considered to be rectangular and is labelled <width x height>, where the height takes the value 
of the pipe diameter.

Text size pipe_label_size input

text size of the pipe diameter labels. The labels will only be created if the size is greater than zero.

Text offset pipe_label_offset input

distance to move the pipe diameter labels along the pipe, from the mid position of the pipe segment. 
Positive values are to the right.

Text rise pipe_label_rise input

distance to move the pipe diameter labels away from the pipe centreline or edge (depending on setting 
of rise_mode). A negative value will place the labels on the other side of the pipes.

Text colour pipe_label_colour colour available colours

colour of the pipe diameter labels.

Text style pipe_label_textstyle textstyle available fonts

font of the pipe diameter labels.

Pre text pipe_label_pre_text input

text to be placed before the diameter in the pipe diameter labels.

Post text pipe_label_post_text input

text to be placed after the diameter in the pipe diameter labels.

Units factor pipe_label_factor input

multiplier of diameter values. A Units factor of 1000 will result in the diameters being labelled in mm.

Decimal places pipe_label_decimals input

number of decimal places in labelled diameter values.
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Text string name pipe_label_name input

string name of the pipe diameter labels.

Drainage_Plan_Plot_Pipes_Pipe_IL_labels

Pipe IL labels
Panel field Parameter name Type Pop-Up

Text size pipe_text_size_il input

text size of the pipe IL (Invert Level) labels. The labels will only be created if the size is greater than 
zero.

Text offset pipe_text_offset_il input

distance to move the pipe IL labels along the pipe, from the ends of the pipe. Positive values are 
towards the mid position of the pipe segment.

Text rise pipe_text_rise_il input

distance to move the pipe IL labels away from the pipe centreline or edge (depending on setting of 
rise_mode). A negative value will place the labels on the other side of the pipes.

Text colour pipe_text_colour_il colour available colours

colour of the pipe IL labels.

Text style pipe_text_textstyle_il textstyle available fonts

font of the pipe IL labels.

Pre text pipe_text_pre_text_il input

text to be placed before the IL in the pipe IL labels.

Post text pipe_text_post_text_il input

text to be placed after the IL in the pipe IL labels.

Units factor pipe_text_factor_il input

multiplier of IL values. A Units factor of 3.281 will result in the ILs being labelled in feet.

Decimal places pipe_text_decimals_il input

number of decimal places in labelled IL values.

Text string name pipe_text_name_il input

string name of the pipe IL labels.

Maintenance holes
Drainage_Plan_Plot_Maintenance_holes

Maintenance hole representation
Panel field Parameter name Type Pop-Up

MH symbol direction mh_symbol_dir_mode choice box
mode use symbol angle

left
right
average

determines what mode of direction is used to place the MH symbols.

MH symbol angle (dms) mh_symbol_angle angle

angle of MH symbol placement. This is only used depending on the setting of mh_symbol_dir_mode.
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The remaining fields in this section are grid column fields that may each have up to 20 sets 
(rows) defined.

Panel field Parameter name Type Pop-Up

MH type mh_type_n input

MH type of the nth set of maintenance holes. All MHs of this type will be represented according to the 
values of the other fields in this set (row). MH types are defined in the drainage design strings.

MH mode mh_mode_n choice box none
text
symbol
circle

determines whether a text string, a symbol, or a circle is to be used to represent the nth set of 
maintenance holes. 

MH Symbol or Text mh_symbol_n symbol available symbols

symbol or text string to use to represent the nth set of maintenance holes. If mh_mode_n is set to 
"text", a text string can be typed in. If mh_mode_n is set to "symbol", the symbol name can be 
chosen from the pop-up list. Ignored if mh_mode_n is set to "circle".

Justification mh_symbol_justify_n choice box left bottom
left middle
left top
centre bottom
centre middle
centre top
right bottom
right middle
right top

justification mode of the MH text for the nth set of maintenance holes, relative to the centres of the 
MHs. This will only be relevant if mh_mode_n is set to "text".

Size mh_symbol_size_n input

size of the MH symbols or text strings for the nth set of maintenance holes. The symbols, circles or text 
strings will only be created if the size is greater than zero. In the case of a circle, the size is determined 
to match the diameter of the MH.

Offset mh_symbol_offset_n input

distance to move the MH symbols, circles or text strings to the left or right of the MH centres, for the 
nth set of maintenance holes. Positive values are to the right. The direction of movement is parallel to 
the angle of the MH symbols (see mh_symbol_dir_mode and mh_symbol_angle).

Rise mh_symbol_rise_n input

distance to move the MH symbols, circles or text strings above or below of the MH centres, for the nth 
set of maintenance holes. Positive values are upwards. The direction of movement is perpendicular to 
the angle of the MH symbols (see mh_symbol_dir_mode and mh_symbol_angle).

Colour mh_symbol_colour_n colour available colours

colour of the MH symbols, circles or text strings, for the nth set maintenance holes.

Text style mh_symbol_textstyle_n textstyle available fonts

font of the MH text for the nth set of maintenance holes. This will only be relevant if mh_mode_n is 
set to "text".

MH Symbol string name mh_symbol_name_n input

string name of the MH symbols, circles or text strings for the nth set of maintenance holes.

Maintenance hole labels
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Panel field Parameter name Type Pop-Up

MH label direction mode mh_text_mode choice box use label angle
use pipe angle

determines what angle is to be used to position the maintenance hole label text.

MH label angle mh_text_angle angle

angle of MH label text. This is only used depending on the setting of mh_text_mode.

MH label justification mh_text_justify choice box left bottom
left middle
left top
centre bottom
centre middle
centre top
right bottom
right middle
right top

justification mode of all MH label text strings, relative to the MH centres.

Drainage_Plan_Plot_Maintenance_holes_MH_name_labels

MH name labels
Panel field Parameter name Type Pop-Up

Text size mh_text_size input

text size of the MH name labels. The labels will only be created if the size is greater than zero. MH 
names are defined in the drainage design strings.

Text offset mh_text_offset input

distance to move the MH name labels to the left or right of the MH centres. Positive values are to the 
right. The direction of movement is parallel to the angle of the text, specified by parameters 
mh_text_mode and mh_text_angle. The justification of the text is specified by parameter 
mh_text_justify.

Text rise mh_text_rise input

distance to move the MH name labels above or below the MH centres. Positive values are above. The 
direction of movement is perpendicular to the angle of the text, specified by parameters 
mh_text_mode and mh_text_angle. The justification of the text is specified by parameter 
mh_text_justify.

Text colour mh_text_colour colour available colours

colour of the MH name labels.

Text style mh_text_textstyle textstyle available fonts

font of the MH name labels.

Pre text mh_text_pre input

text to be placed before the MH name in the MH name labels.

Post text mh_text_post input

text to be placed after the MH name in the MH name labels.

Text string name mh_text_name input

string name of the MH name labels.

Drainage_Plan_Plot_Maintenance_holes_MH_diameter_labels

MH diameter labels
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Only label if diameter is outside range:

Panel field Parameter name Type

Min mh_text_min_dia input
Max mh_text_max_dia input

range of MH diameters for which the MH diameter labels will not be created. Both Min and Max are 
entered in metres.

Panel field Parameter name Type Pop-Up

Text size mh_text_size_dia input

text size of the MH diameter labels. The labels will only be created if the size is greater than zero. MH 
diameters are defined in the drainage design strings.

Text offset mh_text_offset_dia input

distance to move the MH diameter labels to the left or right of the MH centres. Positive values are to 
the right. The direction of movement is parallel to the angle of the text, specified by parameters 
mh_text_mode and mh_text_angle. The justification of the text is specified by parameter 
mh_text_justify.

Text rise mh_text_rise_dia input

distance to move the MH diameter labels above or below the MH centres. Positive values are above. 
The direction of movement is perpendicular to the angle of the text, specified by parameters 
mh_text_mode and mh_text_angle. The justification of the text is specified by parameter 
mh_text_justify.

Text colour mh_text_colour_dia colour available colours

colour of the MH diameter labels.

Text style mh_text_textstyle_dia textstyle available fonts

font of the MH diameter labels.

Pre text mh_text_pre_dia input

text to be placed before the diameter in the MH diameter labels.

Post text mh_text_post_dia input

text to be placed after the diameter in the MH diameter labels.

Units factor mh_text_factor_dia input

multiplier of diameter values. A Units factor of 1000 will result in the diameters being labelled in mm.

Decimal places mh_text_decimals_dia input

number of decimal places in labelled diameter values.

Text string name mh_text_name_dia input

string name of the MH diameter labels.

Drainage_Plan_Plot_Maintenance_holes_MH_depth_labels

MH depth labels
Panel field Parameter name Type Pop-Up

Text size mh_text_size_depth input

text size of the MH depth labels. The labels will only be created if the size is greater than zero. MH 
depths are defined in the drainage design strings.

Text offset mh_text_offset_depth input

distance to move the MH depth labels to the left or right of the MH centres. Positive values are to the 
right. The direction of movement is parallel to the angle of the text, specified by parameters 
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mh_text_mode and mh_text_angle. The justification of the text is specified by parameter 
mh_text_justify.

Text rise mh_text_rise_depth input

distance to move the MH depth labels above or below the MH centres. Positive values are above. The 
direction of movement is perpendicular to the angle of the text, specified by parameters 
mh_text_mode and mh_text_angle. The justification of the text is specified by parameter 
mh_text_justify.

Text colour mh_text_colour_depth colour available colours

colour of the MH depth labels.

Text style mh_text_textstyle_depth textstyle available fonts

font of the MH depth labels.

Pre text mh_text_pre_depth input

text to be placed before the depth in the MH depth labels.

Post text mh_text_post_depth input

text to be placed after the depth in the MH depth labels.

Units factor mh_text_factor_depth input

multiplier of depth values. A Units factor of 3.281 will result in the depths being labelled in feet.

Decimal places mh_text_decimals_depth input

number of decimal places in labelled depth values.

Text string name mh_text_name_depth input

string name of the MH depth labels.

Drainage_Plan_Plot_Maintenance_holes_MH_chainage_labels

MH chainage labels
Panel field Parameter name Type Pop-Up

Chainage mode mh_text_mode_ch choice box running chainage
previous chainage
next chainage

determines what chainage values will be labelled at the MHs. The "running chainage" option refers 
to the start of the drainage design string. The "previous chainage" and "next chainage" options 
refer to the previous and next MHs respectively. 

Text size mh_text_size_ch input

text size of the MH chainage labels. The labels will only be created if the size is greater than zero.

Text offset mh_text_offset_ch input

distance to move the MH chainage labels to the left or right of the MH centres. Positive values are to 
the right. The direction of movement is parallel to the angle of the text, specified by parameters 
mh_text_mode and mh_text_angle. The justification of the text is specified by parameter 
mh_text_justify.

Text rise mh_text_rise_ch input

distance to move the MH chainage labels above or below the MH centres. Positive values are above. 
The direction of movement is perpendicular to the angle of the text, specified by parameters 
mh_text_mode and mh_text_angle. The justification of the text is specified by parameter 
mh_text_justify.

Text colour mh_text_colour_ch colour available colours
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colour of the MH chainage labels.

Text style mh_text_textstyle_ch textstyle available fonts

font of the MH chainage labels.

Pre text mh_text_pre_ch input

text to be placed before the chainage in the MH chainage labels.

Post text mh_text_post_ch input

text to be placed after the chainage in the MH chainage labels.

Units factor mh_text_factor_ch input

multiplier of chainage values. A Units factor of 3.281 will result in the chainages being labelled in feet.

Decimal places mh_text_decimals_ch input

number of decimal places in labelled chainage values.

Text string name mh_text_name_ch input

string name of the MH chainage labels.

House Connections
Drainage_Plan_Plot_House_conections

House connection representation
Panel field Parameter name Type Pop-Up

HC linestyle hc_line_style linestyle available linestyles

linestyle with which to represent the house connections to the pipes. The HCs will be represented as 
lines perpendicular to the pipe, from the pipe centreline, to the sides of the pipe that the HCs are on.

HC colour hc_colour colour available colours

colour of the house connection linestyles

HC string name hc_line_name input

string name of the HC lines.

The remaining fields in this section are grid column fields that may each have up to 6 sets (rows) 
defined.

Panel field Parameter name Type Pop-Up

HC Type hc_types_n input

HC type of the nth set of house connections. All HCs of this type will be represented according to the 
values of the other fields in this set (row). HC types are defined in the drainage design strings. There 
are only 6 different HC types used in 12d Model.

HC Type label hc_type_text_n input

text label to be associated with the HC type of the nth set of house connections.

Label HC Type hc_type_tp_n tick box

label the types of the HCs of the nth set of house connections. Depending on the HC type, it may not be 
desired to label the type.

Label HC IL hc_type_il_n tick box

label the ILs of the HCs of the nth set of house connections. Depending on the HC type, it may not make 
sense to label the IL.

Label HC Chainage hc_type_ch_n tick box
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label the chainages of the HCs of the nth set of house connections. Depending on the HC type, it may 
not make sense to label the chainages.

Label HC Additional text hc_type_at_n tick box

label the Additional text of the HCs of the nth set of house connections. Depending on the HC type, it 
may not be desired to label the Additional text.

Drainage_Plan_Plot_House_conections_HC_type_labels

HC type labels
Panel field Parameter name Type Pop-Up

Text size hc_type_size input

text size of the HC type labels. The labels will only be created if the size is greater than zero and the 
parameter hc_type_tp_n is set to "on" for the nth set of house connections. The HC type labels are 
associated with the HC types are defined by the parameter set hc_type_text_n.

Text offset hc_type_offset input

distance to move the HC type labels away from the pipe centreline. Negative values are converted to 
positive. HC label text is always placed perpendicular to the pipe (or parallel to the HC line) and on 
the same side of the pipe as the HC. The text will be automatically left justified or right justified, 
depending on the side.

Text rise hc_type_rise input

distance to move the HC type labels above or below the HC lines. Positive values are above. The 
direction of movement is parallel to the pipe (or perpendicular to the HC line). The text will be 
automatically bottom justified.

Text colour hc_type_colour colour available colours

colour of the HC type labels.

Text style hc_type_textstyle textstyle available fonts

font of the HC type labels.

Text string name hc_type_name input

string name of the HC type labels.

Drainage_Plan_Plot_House_conections_HC_IL_labels

HC IL labels
Panel field Parameter name Type Pop-Up

Text size hc_il_size input

text size of the HC IL (Invert Level) labels. The labels will only be created if the size is greater than 
zero and the parameter hc_type_il_n is set to "on" for the nth set of house connections.

Text offset hc_il_offset input

distance to move the HC IL labels away from the pipe centreline. Negative values are converted to 
positive. HC label text is always placed perpendicular to the pipe (or parallel to the HC line) and on 
the same side of the pipe as the HC. The text will be automatically left justified or right justified, 
depending on the side.

Text rise hc_il_rise input

distance to move the HC IL labels above or below the HC lines. Positive values are above. The 
direction of movement is parallel to the pipe (or perpendicular to the HC line). The text will be 
automatically bottom justified.

Text colour hc_il_colour colour available colours

colour of the HC IL labels.
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Text style hc_il_textstyle textstyle available fonts

font of the HC IL labels.

Pre text hc_il_pre input

text to be placed before the IL in the HC IL labels.

Post text hc_il_post input

text to be placed after the IL in the HC IL labels.

Units factor hc_il_factor input

multiplier of IL values. A Units factor of 3.281 will result in the ILs being labelled in feet.

Decimal places hc_il_decimals input

number of decimal places in labelled IL values.

Text string name hc_il_name input

string name of the HC IL labels.

Drainage_Plan_Plot_House_conections_HC_chainage_labels

HC chainage labels
Panel field Parameter name Type Pop-Up

Chainage mode hc_chain_mode choice box hc lot offset
running chainage
previous chainage
next chainage

determines what chainage values will be labelled at the HCs. The "running chainage" option refers to 
the start of the drainage design string. The "previous chainage" and "next chainage" options refer 
to the previous and next MHs respectively. The "hc lot offset" option is a special one that looks for a 
user-defined attribute called "<hc_name> hc lot offset" in the house connections along the drainage 
design strings. If the attribute is found, its value is set as the HC chainage label. If the attribute is not 
found, the value of the HC chainage label is set to a default HC Lot Offset of 5.0.

Text size hc_chain_size input

text size of the HC chainage labels. The labels will only be created if the size is greater than zero and 
the parameter hc_type_ch_n is set to "on" for the nth set of house connections.

Text offset hc_chain_offset input

distance to move the HC chainage labels away from the pipe centreline. Negative values are converted 
to positive. HC label text is always placed perpendicular to the pipe (or parallel to the HC line) and on 
the same side of the pipe as the HC. The text will be automatically left justified or right justified, 
depending on the side.

Text rise hc_chain_rise input

distance to move the HC chainage labels above or below the HC lines. Positive values are above. The 
direction of movement is parallel to the pipe (or perpendicular to the HC line). The text will be 
automatically bottom justified.

Text colour hc_chain_colour colour available colours

colour of the HC chainage labels.

Text style hc_chain_textstyle textstyle available fonts

font of the HC chainage labels.

Pre text hc_chain_pre input

text to be placed before the chainage in the HC chainage labels.
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Post text hc_chain_post input

text to be placed after the chainage in the HC chainage labels.

Units factor hc_chain_factor input

multiplier of chainage values. A Units factor of 3.281 will result in the chainages being labelled in feet.

Decimal places hc_chain_decimals input

number of decimal places in labelled chainage values.

Text string name hc_chain_name input

string name of the HC chainage labels.

Drainage_Plan_Plot_House_conections_HC_additional_text_labels

HC additional text labels
Panel field Parameter name Type Pop-Up

Additional text hc_text input

the additional text to place near the HCs.

Text size hc_text_size input

text size of the HC additional text labels. The labels will only be created if the size is greater than zero 
and the parameter hc_type_at_n is set to "on" for the nth set of house connections.

Text offset hc_text_offset input

distance to move the HC additional text labels away from the pipe centreline. Negative values are 
converted to positive. HC label text is always placed perpendicular to the pipe (or parallel to the HC 
line) and on the same side of the pipe as the HC. The text will be automatically left justified or right 
justified, depending on the side.

Text rise hc_text_rise input

distance to move the HC additional text labels above or below the HC lines. Positive values are above. 
The direction of movement is parallel to the pipe (or perpendicular to the HC line). The text will be 
automatically bottom justified.

Text colour hc_text_colour colour available colours

colour of the HC additional text labels.

Text style hc_text_textstyle textstyle available fonts

font of the HC additional text labels.

Text string name hc_text_name input

string name of the HC additional text labels.

Bubbles
Drainage_Plan_Plot_Bubbles

Panel field Parameter name Type Pop-Up

Draw bubbles bubble_draw_mode tick box

draw bubbles (circles) around the MH name labels.

Bubble colour bubble_colour colours available colours

colour of the bubbles.

Bubble factor bubble_factor input

the initial radius of the bubble is calculated as half the text length of the MH name label. The bubble 
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factor is used to multiply the initial radius to give the final bubble radius. Factors greater than 1 will 
increase the bubble size.

Bubble string name bubble_name input

string name of the bubbles.

Flow arrows
Drainage_Plan_Plot_Flow_arrows

Panel field Parameter name Type Pop-Up

Draw flow arrows flow_arrow_mode tick box

draw flow arrows near the pipe diameter labels, showing the direction of flow in the pipes.

Arrow colour flow_arrow_colour colour box

colour of the flow arrows.

Arrow length flow_arrow_length input

length of the flow arrows. Setting the length to a negative number will place the arrow on the other side 
of the pipe (whilst still maintaining the correct arrow direction).

Arrow string name flow_arrow_name input

string name of the flow arrows.
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Plot Frame and PPF Editor
Plot_Frame_PPF_Editor

Position of option on menu: Plot =>Plot Frame and PPF Editor

The Plot frame ppf editor is for creating and/or editing a (binary) plot frame ppf file and for 
creating a cross section plot.

Note: binary ppf’s are stored within the project (not in the folder containing the project as the 
ascii ppf’s were).

On selecting the Plot frame and ppf editor option, the Plot Frame PPF Editor panel is displayed.

Panel field Type

Plot parameter file file box



Chapter 24  PPF Editors

November 2002 Page 2587Plot Frame and PPF Editor

name for the binary plot parameter file to read in or write out.

Read button

read the given plot parameter file in.

Write button

write out the plot parameters to the given plot parameter file. An ascii ppf file is also written out.

Plot button

use the plot parameters from the panel to create the plot.

Find button

brings up a search box. If a valid parameter name is keyed in followed by the enter key, the cursor will 
be placed in the appropriate field on the appropriate page.

Plot Frame
Plot_Frame

Plot frame
Section: Single Plot Frame

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Plot frame  single_frame string select box

select the plot frame to be plotted.

Section: Model of Plot Frames

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Model of frames  model_of_frames model box

model of plot frames to plot.

Section: View To Plot

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

View to plot view_name model box

view in which data to plot resides.

Section: Plotter parameters

The fields and buttons used in this section have the following functions.

Field Description Parameter name Type Pop-Up

Plotter type plotter_type plotter box

a valid plotting option is selected.

Plot file stem plot_stem plotter box
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plot file name. The appropriate extension is added dependant on the plotter type selected.

Clean plot models beforehand

plot_model_clean choice box do not clean
prompt for clean
always clean

whether to clean (delete the elements in) any resultant plot models that may already exist, before 
generating the plot(s). This parameter is only applicable if plotting to a model or models. Note that if 
the models are cleaned using this parameter, any non-plot or locked elements found in the models will 
not be cleaned from the models, and the plot job will be cancelled.

Title Block
Plot_Frame_Title_block

Common title block parameters
Panel field Parameter name Type

Standard title plot_border tick box

if ticked, a standard 12d title block will be used.

Use title file use_title_file tick box

if ticked, a user defined title file is used.

Title line 1 title_1 input

if  Standard title is ticked, Title line 1 is the first line of title text. If  Use title file is ticked, Title line 1 
is substituted for the title block variable $title_1.

Title line 2 title_2 input

if  Standard title is ticked, Title line 2 is the second line of title text. If  Use title file is ticked, Title line 
2 is substituted for the title block variable $title_2.

12d default title block parameters
Panel field Parameter name Type Pop-Up

Text size title_text_size input

text size of title text.

Text colour title_colour colour available colours

colour of title text.

Plot_Frame_Title_block_User_title_info

User title info
The parameters shown below are subject to the appropriate title block variables existing in the title file. For 
more information on these variables see the section “Title Block Variables” .

Panel field Parameter name Type Pop-Up

Title file title_file file box available title files

specifies the name of the title file to use. If a valid title file exists, the specified Name values will be 
filled out in the grid using the title block variable $user_text_n.

Name output

the alias for the nth user text specified in the title file.
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Value user_text_n input

the alias text to be substituted in for the user text specified.

Time format time_format input

the time format relates to the $time title block variable. For more information on the time formats see 
the section “Specifying the Format for $time” .

Start page number start_page_number input

used as the starting value for the title block variable $page_number. If missing, $page_number starts at 
1.

Start drawing number start_drawing_number input

used as the starting value for the title block variable $drawing_number. If missing, $drawing_number 
starts at 1.

Drawing number prefix drawing_number_prefix input

the value entered is used for the title block variable $drawing_number_prefix.

Drawing number postfix drawing_number_postfix input

the value entered is used for the title block variable $drawing_number_postfix.

User title info
The parameters shown below are subject to the appropriate title block variables existing in the title file. For 
more information on these variables see the section “Title Block Variables” .

Panel field Parameter name Type Pop-Up

Title file title_file file box available title files

specifies the name of the title file to use. If a valid title file exists, the specified Name values will be 
filled out in the grid using the title block variable $user_text_n.

Name output

the alias for the nth user text specified in the title file.

Value user_text_n input

the alias text to be substituted in for the user text specified.

Time format time_format input

the time format relates to the $time title block variable. For more information on the time formats see 
the section “Specifying the Format for $time” .

Start page number start_page_number input

used as the starting value for the title block variable $page_number. If missing, $page_number starts at 
1.

Start drawing number start_drawing_number input

used as the starting value for the title block variable $drawing_number. If missing, $drawing_number 
starts at 1.

Drawing number prefix drawing_number_prefix input

the value entered is used for the title block variable $drawing_number_prefix.

Drawing number postfix drawing_number_postfix input

the value entered is used for the title block variable $drawing_number_postfix.
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Convert Ascii PPF to Binary
ppf_convert_ascii_to_binary

Position of option on menu: Plot =>Plot and PPF Editors =>PPF Convert Ascii to Binary

The convert ascii ppf to binary option is for converting the old ascii plot parameter files to the 
new binary plot parameter file format.

Note: binary ppf’s are stored within the project (not in the folder containing the project as the 
ascii ppf’s were).

On selecting the ppf convert ascii to binary option, the ppf Convert Ascii to Binary panel is 
displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Ascii ppf file box

name of the ascii plot parameter file to convert.

Binary ppf button

convert the ascii ppf to the equivalent binary ppf. The binary ppf file will be stored in the current 
project.

Convert button

convert the ascii ppf to a binary ppf.
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Copy Title Data
ppf_copy_title_data

Position of option on menu: Plot =>Plot and PPF Editors =>Copy title data

The copy title data option is for copying the title data in one binary plot parameter to another 
binary plot parameter file format.

On selecting the Copy title data option, the PPF Copy Title Data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Old plot parameter file file box

name of the plot parameter file to copy the title data from.

New plot parameter file button

name of the plot parameter file to copy the title data to.

Copy button

copy the title data from one ppf file to another.
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25  Reports
reports

Position of menu: It is on the main menu as Report

The Reports menu contains options to report on the strings in a model, polygon details (area, 
centroid), string set outs, string names, crest and sag points and x-falls. 

The Reports menu is

For the option/menu Edit, go to the section“Edit” 
Strings “Strings” 
Functions “Functions” 
Length/area “Length and Area” 
Set-out “Set-Out Reports” 
Quantities “Quantities” 
X-fall “X-Fall and Offset Report” 
QA reports “QA Reports” 
More “More Reports” 

Each menu option will now be discussed. 

create floating Reports menu

edit a .rpt file
report on strings, crest/sag points, names
report on functions
length, area, centroid of strings
point and string set-out information
calculations of quantities
report x-fall between two strings
QA reports
further reports

on Main menu on 12d Model menu
and floating menu
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Edit
edit_a_file___rpt

Position on menu: Report =>Edit

The Edit option is used to edit any (printer) reports ending in *.rpt.

On walking right on Edit, the list of files ending in *.rpt are displayed.

Double clicking on the report name will bring up the report in the system editor.

Clicking on the Edit at the top of the menu brings up the Edit a file panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder folder box current folder folder browser

the folder to look for the report file.

File to edit file box *.rpt

name of the file to bring up in the system editor.
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Strings
string_reports

Position of menu: Report =>Strings

The Strings menu contains options to report on selected strings, report the crest/sag points for a 
string and create a list of all the unique string names in a model or view.

The Strings walk-right menu is

For the option Coords/Brg-Dst, go to the section “Coordinates or Bearing-Distance” .
Crest/sag points “Crest/Sag Points” .
Names “Names” .
Super alignment “Super Alignment” 
Super strings “Report for Super Strings” 
More “More Strings Reports” .
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Coordinates or Bearing-Distance
report_on_selected_item

Position of option on menu: Report =>Strings =>Coords/Brg-Dst

The Coords/Brg-Dst option is used to generate a report on selected items defined by a source 
box. The report can be of the form of coordinates of each point of a string, or the co-ordinates of 
the first point of a string and the bearings and distances from each other point of the string to the 
first point of the string.

For an alignment string it will report on the HIP’s and VIPS. If there is a non-zero separation 
value, then at each chainages that are multiples of the separation value, the report also includes 
the chainage, x, y, z, bearing for horizontal and chainage, height (z), grade for vertical.

On selecting the Coords/Brg-Dst option, the Report on Selected Item panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Report file input *.rpt

name of the file to report to.

Coordinates(x,y) tick box tick

if tick, the coordinate report parameters will be displayed which will determine what other information 
as well as the coordinate values will be placed in the report. NOTE: If an alignment string is part of 
the selection, the report will include all relevant details about the alignment. In this case the report will 
not use the coordinate report parameters as specified, for the alignment string. 
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Bearing and Distances tick box

if tick, the bearing and distance report parameters will be displayed which will determine what other 
information as well as the bearing and distance values will be placed in the report.

Coordinate report parameters

if the Coordinates(x,y) option is selected, the following parameters will be displayed

Point ids tick box

if selected, any valid point ids will be shown in the report.

Vertex indices tick box

if selected, vertex indices will be shown in the report.

Z Values tick box

if selected, any valid z values will be shown in the report.

Radius values tick box

if selected, any valid radius values will be shown in the report.

Vertex Text tick box

if selected, any valid vertex text values will be shown in the report.

Separation for Alignment tick box

if selected, the separation for alignment box will be enabled.

Separation input box 10

if enabled by ticking the previous tick box, the alignment string information will be reported at a 
chainage interval given by the separation value.

Report button

run the option and create the report.
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Crest/Sag Points
string_crest_sag_points_report

Position of option on menu: Report =>Strings =>Crest sag points

The crest/sag points option is used to generate a (printer) report on the crests and sags points of 
a string.

A number of strings can be reported on by selecting them in turn

On selecting the crest/sag points option, the string crest/sag points report panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Report file input *.rpt

name of the file to contain the reports on the crest and sag points of strings.

Pick & Report button

as strings are selected, the crest and sag points report is generated and appended to the report file.
The cycle is terminated by clicking RB to raise the pick ops menu and selecting cancel from it.

Names
string_names_report_for

Position of option on menu: Report =>Strings =>Names

The names option is used to report on all the unique strings in a model or on a view.

Selecting Names displays the String Names Report for panel.

If the report button is selected, then all the strings in the model/view given by the model/view to 
report field will be checked and all unique names, plus a frequency count, will be written to the 
report file.

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

type of data source.

# chars to check input

if non blank, the number of characters to be used in the string name when checking for uniqueness.
If blank, then the entire string name is used.

Report file file box *.rpt files

name of the file for the report.

Report button

report on all the unique string names in model/view.
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Super Alignment
super_alignment_report

Position of option on menu: Report =>Strings =>Super alignment

Report on the super alignment that gives information on the horizontal and vertical components.

This option is under development.

On selecting the Super alignment option, the Super Alignment Report panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

type of data source.

Report file input *.rpt

name of the file to report to.

Report button

run the option and create the report.
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Report for Super Strings
report_super_string_panel

Position of option on menu: Report =>Strings =>Super strings

This option reports on information in the super string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

type of data source.

Vertex index tick box tick

if tick, vertex indices are reported.

Point id tick box tick

if tick, point ids are reported.

Report XY tick box tick

if tick, x and y values are reported.

Report Z tick box tick

if tick, z values are reported.

Report file header input box tick

if tick, a header including the date and model name and string names is included.

Report file name input box

name of the report.

Report button

Run the option.
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More Strings Reports
more_string_reports

There are currently no options on this menu.
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Functions
function_reports

Position of menu: Report =>Functions

A report can be made on a function. The function walk-right menu is 

Report a Function, Report all Functions
report_all_functions    function_report
Position of option on menu: Report =>Functions =>One

Position of option on menu: Report =>Functions =>All

On selecting the report or report all option, the function report/ report all functions panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function function box available functions

name of the function to be reported.

Report file file box *.rpt files

name of the file to write the report to.

Report button

after selecting this button, a report on the function/ all functions is produced.
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Length and Area
polygon_report_for

Position of option on menu: Report =>Length/Area

The Length/area (Polygons) option creates a report containing the following information for each 
selected string:

▲ string name
▲ if the string is closed or not
▲ length of the string
▲ area of the string (if not closed, join first and last points)
▲ centroid co-ordinates

On selecting the Length/Area option, the Polygon Report for panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

type of data source.

Report file input *.rpt

file for the polygon reports.

Report button

produce a polygon report for all strings selected in the Data source.
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Set-Out Reports
set_out_report

Position of menu: Report =>Set-out

The Set out report options are for reporting the bearing and distance from a selected instrument 
station to individual points, strings, models of strings or views of strings.

In the Setout report, a backsight stations can be selected and the bearing of the line from the 
instrument station to the backsight station reported. Individual backsight points or strings of 
backsight points can be selected for reporting.

In the Radial report, the report can be sorted by point number, bearing or distance.

The set outs walk-right menu is

For the option Old setout report, go to the section “Old Setout Report” .
Setout report “Setout Report” .
Radial report “Radial Report” .

The menu options will now be discussed. 

old set out report fro V5.0
set out report for strings
set out report sorted by name, distance or bearing
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Old Setout Report
old_setout_report

Position of option on menu: Report =>Set out =>Old setout report

The setout report from 12d Model V5. This option has been rewritten for 12d Model V6 and is 
called Setout Report.

On selecting the Old setout report option, the Old Setout Report panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

type of data source.

Report mode input report points, report string

if report points, report selected points. Otherwise report on all points in the selected string.

Maximum distance input

if non-blank, any points further that the maximum distance from the instrument station will not be 
reported on. If blank, all selected points will be reported on

Report file input

file for the backsight and setout reports

Instrument XYZ/name output

co-ordinates/name of the current instrument station
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Bearing decimal places input

number of decimal places to report the bearings to

Instrument button

the required instrument station is selected and its name and position are reported in the instrument XYZ 
and instrument name panel fields.

Backsight button

a backsight is selected and written to the report file.

Pick button

After pick is chosen, a set out report is written to the report file for any selected strings. If the report 
mode is report point, only the individual point is reported. If the report mode is report string, all the 
points in the string are reported.
The cycle is terminated by clicking RB to raise the pick ops menu and selecting cancel from it.

Setouts button

produce a set out report for all the strings in the model/view given in the model/view field.

How to Use the Panel and Panel Messages

(a) Enter the report file name and maximum distance.

(b) The instrument station is chosen by activating the station button and selecting the required 
station point. It will then be reported in the file

(c) Any backsight points to be reported can then be chosen by picking the backsight button and 
selecting the backsight point.

(d) To report on individual strings or points, set the report mode to either point or string. The 
pick button is then activated and the individual points or strings selected. The cycle is termi-
nated by clicking RB to raise the pick ops menu and selecting cancel from it.

 To report on all the strings in a model/view, give the model/view in the model/view field, 
and select the setout button.

Note

The instrument station can be changed at any time by selecting the station button and picking the 
new station.

All backsight and set outs will then be taken from the new instrument station.
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Setout Report
setout_report

Position of option on menu: Report =>Set out =>Setout report

In the Setout report, a backsight stations can be selected and the bearing of the line from the 
instrument station to the backsight station reported. Individual backsight points or strings of 
backsight points can be selected for reporting.

The instrument station can be changed at any time and new backsight and set outs reported.

The set out option prints the following information:

instrument station

string name, point number, x, y, z

backsight point

string name, point number, x, y, z, bearing to the line joining the instrument and backsight, 
horizontal distance, height difference between instrument station and the backsight 

point set-out point

string name, point number, x, y, z, bearing, horizontal distance, height difference between 
instrument station and the point

On selecting the Setout report option, the Setout Report panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 
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Data source

type of data source.

Report mode choice box report points, report string

if report points, report selected points. Otherwise report on all points in the selected string.

Maximum distance input

if non-blank, any points further that the maximum distance from the instrument station will not be 
reported on. If blank, all selected points will be reported on

Report file file box

file for the backsight and setout reports

Instrument XYZ/name output

co-ordinates/name of the current instrument station

Bearing decimal places input

number of decimal places to report the bearings to

Instrument button

the required instrument station is selected and its name and position are reported in the instrument XYZ 
and instrument name panel fields.

Backsight button

a backsight is selected and written to the report file.

Pick button

After pick is chosen, a set out report is written to the report file for any selected strings. If the report 
mode is report point, only the individual point is reported. If the report mode is report string, all the 
points in the string are reported.
The cycle is terminated by clicking RB to raise the Pick ops menu and selecting Cancel from it.

Setouts button

produce a set out report for all the strings in the model/view given in the model/view field.

How to Use the Panel and Panel Messages

(a) Enter the report file name and maximum distance.

(b) The instrument station is chosen by activating the station button and selecting the required 
station point. It will then be reported in the file

(c) Any backsight points to be reported can then be chosen by picking the backsight button and 
selecting the backsight point.

(d) To report on individual strings or points, set the report mode to either point or string. The 
pick button is then activated and the individual points or strings selected. The cycle is termi-
nated by clicking RB to raise the pick ops menu and selecting cancel from it.

 To report on all the strings in a model/view, give the model/view in the model/view field, 
and select the setout button.

Note

The instrument station can be changed at any time by selecting the station button and picking the 
new station.

All backsight and set outs will then be taken from the new instrument station.
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Radial Report
radial_report

Position of option on menu: Report =>Set out =>Radial report

The radial report reports the bearing and distance from the Instrument to selected vertices. the 
report can be sorted by point id, bearing or distance.

Selecting Radial report brings up the Radial Report panel.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

type of data source.

Scaled radial radio button

if selected, the report uses a fixed scale factor.

Scale factor input 1

if scaled radial is selected, the fixed scale factor to use
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Projection radial radio button

if selected, the report uses a projection for calculating distances

Projection projection box available projections

if projection radial is selected, the selected projection is used when calculating distances

Instrument setup

when the instrument point is selected, the Instrument co-ordinates and name is displayed n the 
Instrument xyz and Instrument name fields.

Report settings

Include points without id tick box

if tick, vertices with a non blank point id are included in the report.
if not tick, only vertices with non blank point id are included in the report.

Zero padding for bearing tick box

if tick, include extra zeros for minutes and seconds.

Sort by choice box point id point id, bearing, distance

if point id, the report is sorted by the point id’s on the vertex.
bearing , the report is sorted by the bearing to the point.
distance , the report is sorted by the distance to the point.

Number of decimals input 3

number of decimal places for reporting co-ordinates

Maximum distance input

if non-blank, any vertices further that the maximum distance from the instrument station will not be 
reported on. If blank, all vertices points will be reported on

Search tolerance input

when a vertex is found, any vertices with the same point id within the search distance of the vertex are 
not reported. Also no vertices closer to the instrument point that this distance will be reported.

Report file file box

file for the setout reports

Report button

produce the report
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Quantities
quantities

Position of option on menu: Report =>Quantities

Selecting Quantities brings up the Quantities panel.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

type of data source.

Data file file box

set up file for the costing data - file is read/written using the Read/Write buttons.
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Costing tabs

Points tab and grid

By name By colour

for any string selected by the key/name or colour, the number of vertices in the string is multiplied by 
the cost and the total added to the quantities report.

Lengths tab and grid

By name By colour

for any string selected by the key/name or colour, the plan or 3d length of the string is multiplied by the 
cost and the total added to the quantities report.

Plan Areas tab and grid

By name By colour

for any string selected by the key/name or colour, the plan area of the string is multiplied by the cost 
and the total added to the quantities report.

Surface Areas tab and grid

By name By colour

for any string selected by the key/name or colour, the surface area of the string within the given tin is 
multiplied by the cost and the total added to the quantities report.

Report mode choice box Summary Summary, Full

produce the quantity report.

Report costs tick box

if tick, the cost used for each calculation is included in the report.

Report to CSV file tick box

if tick, the report is written as a CSV file

Report file box

name of the quantities report file

Quantify button

produce the quantity report.
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X-Fall and Offset Report
x_fall_report

Position of option on menu: Report =>Xfall/offset

The x-fall report option reports on the horizontal and vertical offsets and the cross-fall between 
two strings.

The offsets are calculated as follows:

(a) a reference string is selected which is used to define chainages.
(b) lines perpendicular to the reference string are taken at regular chainages and intersected (in 

plan) with the first and second strings.
(c) the horizontal and vertical offsets and the cross-fall between the two strings is calculated at 

the intersection points.
On selecting the X-fall option, the X-Fall Report panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Start/End chainage input

if blank, the start/end chainage of the reference string is used.
if non-blank, the given chainage is used as the start/end chainage.

Interval input

chainage interval to calculate values at.

Maximum offset input

if non-blank, the maximum distance to search from the reference string to find the 1st and 2nd strings.

Report file file box *.rpt

file for the x-fall report

Ref/1st/2nd button

select the reference/first/second string.

Report button

produce a offset and x-fall report between the first and second strings.
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QA Reports
qa_reports

Position of menu: Report =>QA Reports

The QA options are for checking surveyed strings against design strings or tins.

For Check asbuilt string vs design string, go to the section “Check Asbuilt String vs Design String” 
Check asbuilt string vs wall tin “Check Asbuilt String vs Wall Tin” 
Check points above tin  “Check Points Above a Tin” 
Check points vs tin  “Check Points vs Tin” 
Check survey points vs design points “Check Survey Points vs Design Points” .
Check survey points vs design points (2) “Check Survey Points vs Design Points 

(2)” .

The menu options will now be discussed. 
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Check Asbuilt String vs Design String
asbuilt_vs_design_h_z_dif_panel

Position of option on menu: Report =>QA Reports =>Check asbuilt string vs design string

This panel is used to check the horizontal and vertical differences between two strings (usually 
“as built” and design). A control string is selected to provide the chainage and line to cut the two 
strings and calculate the difference along. The control string can be one of the two strings.

Selecting the Check asbuilt string vs design string brings up the Check As Built String vs Design 
String panel.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

As built string string select

string to compare

Design string string select

string to compare

Control string string select

string to use to define chainage and right angles. The line at right angles cuts the “as built” and 
“design” strings and is used to calculate the horizontal and vertical differences.

Report horizontal difference tick box tick

if tick, the horizontal differences are reported.

Report vertical difference tick box tick

if tick, the vertical differences are reported.

Report at as built string’s vertices tick box tick
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if tick, the differences are reported at the vertices of the as built string.

Report at regular control line intervaltick box tick

if tick, the differences are reported at the chainage interval given in the “Report interval” box.

Report interval input box 5

chainage interval of the control string to report the differences at.

Start chainage input box

start chainage of the control string to start reporting differences.

End chainage input box

end chainage of the control string to stop reporting differences.

Report file input box

name of the report file.

Report button

run the option.
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Check Asbuilt String vs Wall Tin
asbuilt_vs_tin_h_dif_panel

Position of option on menu: Report =>QA Reports =>Check asbuilt string vs wall tin

This panel is used to check the horizontal difference between a string (usually the “as built”) and 
a tin (usually a wall tin). A control string is selected to provide the chainage and bearing to 
project a horizontal line to cut the string and the tin and calculate the horizontal difference along. 
The control string can be the “as built” string.

Points that are different by a given inner and outer tolerance are flagged in the report.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

As built string string select

string to compare against the wall tin.

Control string string select

string to use to define chainage and right angles. The horizontal line at right angles cuts the “as built” 
string and “tin to check against” tin that is used to calculate the horizontal differences.

Start chainage input box

start chainage of the control string to start reporting differences.

End chainage input box

end chainage of the control string to stop reporting differences.

Tin to check against input box available tins

tin to compare the as built string with.

Report at as built string’s vertices tick box tick

if tick, the differences are reported at the vertices of the as built string.
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Report at regular control line intervaltick box tick

if tick, the differences are reported at the chainage interval given in the “Report interval” box.

Report interval input box 5

chainage interval of the control string to report the differences at.

Inner tolerance (mm) input box 100

if the inner horizontal distance between the string and the wall is greater that this value (in units times 
1000) then it is flagged in the report.

Outer tolerance (mm) input box 100

if the outer horizontal distance between the string and the wall is greater that this value (in units times 
1000) then it is flagged in the report.

Report File input box

name of the report file.

Report button

run the option.
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Check Points Above a Tin
Position of option on menu: Report =>QA Reports =>Check points above tin

This panel is used to check the z-value of points against the z-value of a tin at the same (x,y) 
locations and only report on those above the tin. To check points above and below a tin, go to the 
next section “Check Points vs Tin” .

A z-tolerance above the tin is given and all points above the tin and outside the tolerance are 
especially flagged in the report.

Optionally the report can also include the chainage and offset of the points from a selected 
alignment string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model of shots model box

model of points to check the z-value against the tin.

Tin to check against tin box

tin to check the z-values against

Above tolerance (mm) input box 175

if the z-value of the point is above the tin and the difference of the z-value of the point and the tin 
(times 1000), is greater than this amount then it is flagged in the report.

Report file file box

name of the report file.

Report ch/off to centre linetick box

if tick, the chainage and offset of the points from the selected alignment string are included in the 
report.

Select align string select

select the alignment string to calculate offset and chainage from.

Report

run the option.
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Check Points vs Tin
points_vs_tin_z_dif_panel

Position of option on menu: Report =>QA Reports =>Check points vs tin

For Check points above tin, go to “Check Points Above a Tin” .

This panel is used to check the z-value of points against the z-value of a tin at the same (x,y) 
locations, or if a Layer depth is given, the z-values of points are checked against the tin minus the 
layer depth.

Separate z-tolerances are supplied for above and below the tin and points outside either 
tolerance are especially flagged in the report.

Optionally the report can also include the chainage and offset of the points from a selected 
alignment string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model of shots model box

model of points to check the z-value against the tin.

Tin to check against tin box

tin to check the z-values against

Above tolerance (mm) input box 175

if the z-value of the point is above the tin and the difference of the z-value of the point and the tin 
(times 1000), is greater than this amount then it is flagged in the report.

Below tolerance (mm) input box 175

if the z-value of the point is below the tin and the absolute value of the difference of the z-value of the 
point and the tin (times 1000), is greater than this amount then it is flagged in the report.

Layer depth input box 0

this value is subtracted form the z-value of the tin before the comparison is made with the z-value of the 
point.

Report file file box
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name of the report file.

Report ch/off to centre linetick box

if tick, the chainage and offset of the points from the selected alignment string are included in the 
report.

Select align string select

select the alignment string to calculate offset and chainage from.

Report

run the option.
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Check Survey Points vs Design Points
survey_qa_panel

Position of option on menu: Report =>QA Reports =>Check survey points vs design points

This option is used to check surveyed points against the design points.

Separate tolerances are given for Eastings (x), Northings (y) and Elevations (z).

Any design points that have not been surveyed are noted and copies of points out of tolerance 
and/or points not surveyed can be automatically made.

NOTE - if a radial search distance is required in (x,y), go to the next section “Check Survey 
Points vs Design Points (2)” .

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Survey data model model box available models

model of points to be compared against the design points.

Design data model model box available models

points to be compared against.

Out of tolerance model model box available models

copies of any points out of tolerance are added to this model.

Points not surveyed model input box

copies of any points from the design model that have not been surveyed.

Report file name input box

name of the report.5

Easting tolerance input box 0.001

tolerance in the x direction.

Northing tolerance input box 0.001

tolerance in the y-direction.

Elevation tolerance input box 0
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tolerance in the z-direction.

Min reporting dist input box 0

xxxxx

Process button

run the option.
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Check Survey Points vs Design Points (2)
survey_qa_panel

Position of option on menu: Report =>QA Reports =>Check survey points vs design points (2)

This option is used to check surveyed points against the design points.

The (x,y) search distance can be either one radial distance or a separate x and y distance.

Any design points that have not been surveyed are noted and can be optionally copied to a 
model.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Design data model model box available models

points to be compared against.

Points not surveyed modelinput box

copies of any points from the design model that have not been surveyed.

Report file name file box

name of the report.5
copies of any points from the design model that have not been surveyed.

Tolerance method check box Easting-Northing Easting-Northing, Distance

if Easting-Northing, separate Easting (x) and Northing (y) tolerances are given to check against.
If Distance, the test is for a radial distance, not a separate Easting (x) and Northing (y) tolerances.

if Easting-Northing
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Easting tolerance input box 0.001

tolerance in the x direction.

Northing tolerance input box 0.001

tolerance in the y-direction.

if Distance

Distance tolerance input box 0.001

radial tolerance for (x,y).

Elevation tolerance input box 0

tolerance in the z-direction.

Process button

run the option.
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More Reports
more_reports

Position of menu: Report =>More

More miscellaneous reports.

For the option/menu 4d string, go to the section “Report for 4d Strings” 
Alignment - strings cut “Alignment - Strings Cut” 
Alignment z diff from tin “Report Z Differences from Alignment to Tin” 
Alignment string  “Alignment Report” 
Alignment table - IP’s TC’s  “Tabulate Alignment - IP’s and CT’s”  in chapter “Drafting” 
Alignment table - elements “Tabulate Alignment - Elements”  in chapter “Drafting” 
Area by string colour  “Total of Plan Area by String Colour” 
Diff elev between x-sections and tin “Report Z Differences From X-Sections to a Tin” 
Quarter points bubble and table  “Setout Lip Line” from the chapter “Survey” 
Report min z  “Report Minimums Z-Value on a Cross Section” 
Rough areas between sections “Report Rough Areas” 
Super string “Report for Super Strings” 
X-section CivilCAD/Moss/Qld MRD format “X-Sections Report” 

The menu options will now be discussed. 

report on 4d strings
report the strings that an alignment cuts
give the differences from a tin to a string
report on an alignment string
create alignment report and/or table giving IP’s and CT’s
create alignment report and/or table giving elements
give plan areas summed by string colour
give the differences from the points on a section to a tin
report and/or table of quarter points for an arc
report the minimum values on a x-section
report of areas between sections
report of a super string
write out x-sections in a variety of formats
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Report for 4d Strings
report_4d_panel

Position of option on menu: Report =>More =>Report for 4d strings

This panel is used to create a report for 4d strings where the x y and z values are printed out for 
each point plus either the 4d text for the point or the name of the string (repeated for each point).

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source choice box model string, model, view

data source type.

Model/View/String data source

Data source to do report of 4d strings on.

Report as text file 4d text string name
4d text

if 4d text, the 4d text for the point is written out after the x, y and z values.
If string name, the string name is written out after the x, y and z values.

No decimal places input 3

number of decimal places to use in the x, y and z values.

Report file file

name of the report file.

Process button

run the option.
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Alignment - Strings Cut
alignment_cut_strings_panel

Position of option on menu: Report =>More =>Alignment - strings cut

This option is used to create a report of the position and angle that strings make where they cut a 
selected alignment string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Road centreline string select

select the alignment string to report the cuts for.

Data source choice box Model String/Model/View

source of the data

Data

method a specifying data

Report file input box *.rpt files

name of the report file.

Process button

run the option.
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Report Z Differences from Alignment to Tin
aligndiff_panel

Position of option on menu: Report =>More =>Report z differences from alignment to tin

This panel is used to create a report of the difference in z-values between an alignment string and 
a tin. The differences are reported at a given chainage interval along the alignment string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Select alignment string string select

select the alignment string to report z-differences for.

Chainage interval input box

interval to report on.

Tin input box available tins

tin to get z-values from.

Report file name input box *.rpt files

name of the report file.

Process button

run the option.
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Alignment Report
align_report_panel

Position of option on menu: Report =>More =>Alignment string

This panel is used to report the tangent points and centres of arcs for an alignment string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Select alignment string string select

select the alignment string to report on.

Report file name input box

name of the report file.

Report button

run the option.

Alignment Table - IP’s, TC’s
Position of option on menu: Report =>More =>Alignment table - IP’s and TC’s

Create table of IP and CT points for an alignment string.

This panel has already been documented.

See “Tabulate Alignment - IP’s and CT’s”  in chapter “Drafting” 

Alignment Table - Elements
Position of option on menu: Report =>More =>Alignment table - elements

Create table of horizontal elements for an alignment string.

This panel has already been documented.

See “Tabulate Alignment - Elements”  in chapter “Drafting” 
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Total of Plan Area by String Colour
plan_areas_panel

Position of option on menu: Report =>More =>Area by string colour

This panel is used to calculate the sum of the plan area of all strings of the same colour. This is 
especially useful for calculating the plan areas of faces produced for slope areas, volumes etc.

A report giving the total plan area for each different colour is produced.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source data source model model, view
Type of data to calculate areas for.

Model/View data source
Data source to calculate the areas and sum by colour.

Report file input box
Report giving the total plan areas of the strings for each colour.

Process button
Run the option
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Report Z Differences From X-Sections to a Tin
xdiff_panel

Position of option on menu: Report =>More =>Diff elev between x-section and tin

This panel is used to report the z differences between the points on cross sections and the corre-
sponding z-values from a tin.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model of X-Sections model box available models

model of cross sections to report on.

Tin tin box

tin to get z-values from.

Report file name file box

name of the report file.

Process button

run the option.

Quarter Points Report
Position of option on menu: Report =>More =>Quarter points bubbles and table

This option is used to create bubbles and/or a report for the critical horizontal and vertical 
points and quarter points (by chord or by chainage) for any arcs in an alignment string.

This option has already been documented as 

Survey =>Setout =>Setout lip line

in the section “Setout Lip Line” of the chapter “Survey” .
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Report Minimums Z-Value on a Cross Section
minimum_section_level_panel

Position of option on menu: Report =>More =>Report min z

This panel creates a report giving the minimum z-value on a cross section. 

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Cross section model model box

model of cross sections to report on.

Output file file box *.txt files

file to write section names and minimum z-values to.

Process button

run the option.
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Report Rough Areas
rough_area_panel

Position of option on menu: Report =>More =>Rough areas between sections

This panel is used to 

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model of x-sections input box

xxxxx

Start chainage input box

xxxxx

End chainage input box

xxxxx

Report file name input box

name of the report file.

Report button

run the option.
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X-Sections Report
xreport_panel

Position of option on menu: Report =>More =>X-section CivilCAD/Moss/QLD MR format

This panel is used to write out cross sections in a variety of formats.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Model of x-sections input box available models

model of cross sections to write out.

Report type file box CivilCAD CivilCAD, Moss
MainRoad Qld, Brief

format of the report. 

Report file name input box

name of the report file.

Report button

run the option.
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26  Utilities
utilities

Position of menu: It is on the main menu as Utilities

The utilities menus contains a collection of useful operations that don’t easily fit under any of the 
other menus.

For ease of selection, the frequently used utilities are placed on the first level of the menu. All the other 
utilities are split alphabetically between two walk-right menus - the utilities walk-right menus for A-G and 
H-Z.

For the option/menu Snaps, go to the section “Snaps” 
Chains “Chains” 
Functions  “Functions” 
Macros “Macros” 
Measure  “Measure” 
Recalc  “Recalc” 
Fence  “Fence” 
Super strings  “Super Strings” in the chapter “Strings” 
A-G  “Utilities A-G” 
H-Z  “Utilities H-Z” 

Utilities A-G
utilities_a_g

Position on menu: Utilities =>A-G

create floating Utilities menu
snaps

edit, create, delete etc. for chains
edit, create, delete etc. for functions
compiling and running macros.
measure distances, angles etc.
re-calc functions

find inside and outside of a polygon
super string options
utilities from A to G
utilities from H to Z

on Main menu
on 12d Model menu
and floating menu
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For the option Affine, go to the section “2D Affine” 

Cartographic “Cartographic Projections” 
Change “Change” 
Change string chainage “Change String Chainage” 
Check breaklines “Check Breaklines” in the chapter “Triangles” 
Check strings “Check Strings” 
Convert “Convert” 
Create centres of string curves “Create Centre Points for Curves of Strings” 

in the chapter “Survey” 
Cuts “Cuts” 
Delete “Delete” 
Duplicate “Duplicate” 
Explode “Explode” 
Explode (text) “Explode Text” 
Factor “Factor” 
Filter “Filter” 
Create Grid “Create Grid” 

Utilities H-Z
utilities_h_z

Position of menu: Utilities =>H-Z

perform 2D affine transformation
perform cartographic projections
change colour, model etc. of strings
change string chainage
check breaklines
check strings
convert 2d to 3d, 3d to 2d etc.
create centres of curves
calculate cuts through strings
delete strings
duplicate strings
explode strings into lines and arcs
explode text into lines and arcs
multiply the x,y,z values by factors
data filters
create a world grid
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For the option Head to tail, go to the section “Head to Tail” 
Height “Set Height” 
Helmert 2D “2D Helmert” 
Inquire “Inquire” 
Map “Map” 
Null heights “Null Heights” 
Rename strings “Rename Strings” 
Rotate “Rotate” 
Set heights for 2d/super strings “Set Heights for 2d/Super Strings” 
Smooth strings “Smooth Strings” 
Swap XY “Swap XY” 
Text “Text” 
Find/replace text “Replace Text”  in the Chapter “Drafting” 
Translate “Translate” 
Text wildcards “Test Wildcards” 

join strings with common ends
give strings new height
2D Helmert transformation
highlight strings 
use mapping file on strings
set heights to null value
form unions/intersections etc. of polygons
rotate strings in model/view
rename strings
set heights for 2d/3d super strings
smooth strings
swap x and y co-ordinates of strings
modify text parameters
find and replace text
translate strings in model/view
testing pattern and expression matching
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Snaps
snaps_ops

Position of menu: Utilities =>Snaps

The snaps option allows the user to set snapping modes for use during pick operations. The 
snapping modes have been discussed in detail in the “Snaps” section in the chapter “Tools and 
Concepts” .

The Snaps walk-right menu provides a full snap menu, abbreviated snap menus laid out either 
horizontally or vertically, and a snaps cogo menu for creating special point positions using co-
ordinate geometry commands.

For the option Snaps, go to the section “Snaps” .
Snaps (Vert) “Snaps (Vert)” .
Cogo  “Snaps Cogo” .

Snaps
snaps

Position of option on menu: Utilities =>Snaps =>Snaps

The Snaps menu provides tick boxes to turn the various snap modes on or off and options to set 
tin, string and model names. Any combination of snap modes and names can be set.

The snaps point, line, grid, cursor, tin and info are all set on or off using the tick boxes.

full snaps menu
brief snaps laid out vertically
snaps cogo
under development

point snap on/off
line snap on/off
text snap on/off
grid snap on/off
allow cursor point on/off
ask for z value at each point in edits
name of tin to snap to
tin snap on/off
turn segment snap on/off
restriction on string names
restriction on model names
set snap tolerance
set point snap tolerance
bring up info panel on/off
turns data tips on/off
turns fast pick on/off
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The snap tolerance is displayed on the Tolerance line on the menu.

The point snap tolerance is displayed on the Pt tolerance line on the menu.

For more information on snaps, go to the “Snaps” section in the chapter “Tools and Concepts” .

snap_tin

Tin Snap

Tin snap means that when an (x,y) point is selected, the z-value for the point is taken to be the z-
value on the tin at the same (x,y) position.

To use tin snap, the name of the tin to snap to must first be set. Then, snapping to that tin is 
controlled by the state of the tin snap tick box.

If the tick box is on (a tick), snapping to the tin is used.If the tick box is off (a cross or nothing), no 
tin snaps are used.

The name of the tin to snap to is set by selecting the tin option and entering the tin name in the 
Snap Tin panel and selecting the set button.

When a name is set, the tin tick box is automatically set to on.

For more information on snaps, go to the “Snaps” section in the chapter “Tools and Concepts” .

snap_name

snap_model

Name and Model Snap

The user can restrict the snap to specific strings and/or models by selecting the name or model 
option. This brings up the snap name or Snap Model panel. The string name (model name) used 
to restrict the snap is entered into the name (model) field. The values are then set by selecting the 
set button.

When 12d Model creates a new project, line and point snap are set to on and all other snaps set 
off.

For more information on snaps, go to the “Snaps” section in the chapter “Tools and Concepts” .

point_snap_tolerance

Point Snap Tolerance

Point snap tolerance is not a tick box but a menu item. The point snap tolerance value is the 
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distance to be used for considering vertices over anything else when point snap is on.

The point snap tolerance distance is given in screen units (pixels). There are one thousand pixels 
per screen width, hence a point snap tolerance of say 10 means that the point snap distance about 
a vertex is one hundredth of the screen width.

The point snap tolerance is given in terms of screen units rather than world units because it is a 
distance on the screen, independent of any co-ordinate system being used in a view.

The current point snap tolerance value is displayed as Pt tolerance on the Snap menu.

The Point snap tolerance is modified by selecting the Pt tolerance item on the Snaps menu to bring 
up the Point Snap Tolerance panel.

The point snap tolerance to be used to restrict the point snap is entered into the panel and then 
the Set button selected. The default tolerance is 10.

For more information on snaps, go to the “Snaps” section in the chapter “Tools and Concepts” .

snap_tolerance

Snap Tolerance

Snap tolerance is not a tick box but a menu item. The snap tolerance value is the distance to be 
used for considering data when snaps are on.

The snap tolerance distance is given in screen units (pixels). There are one thousand pixels per 
screen width, hence a snap tolerance of say 50 means that the snap distance about a point, line 
etc. is one twentieth of the screen width.

Snap tolerance is given in terms of screen units rather than world units because it is a distance on 
the screen, independent of any co-ordinate system being used in a view.

The current snap tolerance value is displayed as Tolerance on the Snap menu.

The Snap tolerance is modified by selecting the Tolerance item on the Snaps menu to bring up the 
Snap Tolerance panel.

The change the snap tolerance, type a new value into the Tolerance panel field and then click LB on the Set 
button.

For more information on snaps, go to the “Snaps” section in the chapter “Tools and Concepts” .

Info Snap

If info snap is set, then the information panel comes up whenever a string is picked.
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Summarising, the available snap modes are

▲ point - diamond cursor

▲ line - square

▲ grid - circle

▲ cursor - circle

▲ tin - squiggles under a line

▲ name

▲ model

▲ info

On starting up a new project, point and line snap are on, all others off and tolerance is set to 50.

When an existing project is saved, the snap settings, snap tolerance and positions of any snaps 
menus on the screen, are also saved.

For more information on snaps, go to the “Snaps” section in the chapter “Tools and Concepts” .
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Snaps (Vert)
h vertical_snaps

Position of option on menu: Utilities =>Snaps =>Snaps (Vert)

The snaps (vert) menu provides the same tick boxes as the snaps menu to turn the various snap 
modes on or off, however the snap descriptions are abbreviated to one character to reduce the 
menu size.

The Snaps and Snaps (vert) menu are 

For more information on snaps, go to the “Snaps” section in the chapter “Tools and Concepts” .

P Point snap (on)
L Line snap (on)
X Text snap (off)

The Snaps are G Grid snap (off)
C Cursor snap (on)
H Height snap (off)
T Tin snap (off)
S Segment snap (off)
I Info snap (on)
D Data tip (off)
F Fast accept (on)
A Fast accept (off)
K Construction snap (on)
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Snaps Cogo
snaps_cogo

snap_create

snap_fillet

snap_locate

snap_divide

snap_intersect

Position of menu: Utilities =>Snaps =>Cogo

The snaps cogo options are used to create the point required for any 12d Model select operation. 
For example, selecting the next point in append in an editor. The result of the snaps cogo is 
returned to the select operation as the selected point.

Walking right on the cogo option brings up the snaps cogo menu

and the walk-right menus for each of the snaps cogo menu items are

 

Note on Combining Snaps Cogos

When using a snaps cogo option, another select is often required and it is permissible to use 
other snaps cogo option to create the point for that select.

 For example, the required point is the point halfway between two other points dropped 
perpendicularly onto an arc. 

Such a combined result can be achieved using snaps cogo however the order of selecting the 
snaps cogo options may at first seem to be the reverse of what is required.

For the above example, the snaps cogo perpen must be selected before the between option.

This is because when the perpen snap cogo option is selected, it asks the user to select the point 
to drop and it is then that the snaps cogo between option is used to find the midpoint of two 
selected point. The result of the between then becomes the point to drop for the perpen.

If the between option had been selected first, the resultant midpoint would have been returned 



12d Model Reference Manual

Page 2646 April 2007Snaps

as the selected point and that select completed. 

Snaps New
xtra_snaps

Position of menu: Utilities =>Snaps =>New

The xtra snaps menu is currently under development.
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Chains
chains

Position of menu: Utilities =>Chains

A Chain is a list of items that are run in the order that they appear in the list.

Things that can be run in a Chain are:

(a) functions

(b) other chains

(c) super alignment resolves

(d) plot parameter files

(e) some 12d Model options

(f) some screen layout files

(g) macro that don’t have a panel

(h) an external command line

(i) some special hardwired commands such as delete a tin, delete all tins, delete a model, delete 
all models, clean a model, delete a file, compare files, redraw all views, comments

So in its simplest form, a chain can run a user specified list of functions.

The Chains walk-right menu is

For the option Create, go to the section “Create/Edit a Chain” 
Edit “Edit a Chain” 
Copy “Copy a Chain” 
Rename “Rename Chains” 
Run “Run a Chain” 
Delete “Delete a Chain” 

create a chain
edit a chain
copy a chain
rename a chain
run a chain
delete a chain
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Create/Edit a Chain
Position of option on menu: Utilities =>Chains =>Create

create_edit_chain

Selecting Create brings up the Create/Edit Chain panel which is used to create, edit and run 
chains.

To create a new chain, a unique name is typed into the Chain file box (say new chain) and the 
Write button selected.

The chain is then built up by inserting commands using the Insert icon.

Write
out the

Run
the chain

chain

The icons across 
the top are: Insert

command

Delete
command

Move
command

Move
command
down

Recorder
option

up

unique name of the chain

The buttons down 
the bottom are

Read
in a
chain
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Inserting a Command: 
Clicking on the Insert icon insert a new command into the chain and on the right hand side of 
the panel, has the information for defining the new command.

Click on the Type pop-up to 
see what Chain commands 
can be inserted

The information displayed on 
the right is then modified to 
suit the selected command.

Each of the groups of 
comets can be expanded 
by clicking on the + to 
see the individual 
commands
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The Chain commands are:

Under Execution

Option – run a 12d Model option. Note - only some options can be run.
Screen layout file – run an existing screen layout file. Note - only some slf’s can be run.
Function – recalc a 12d function
Chain – run an existing chain
Macro – run a 12d Model macro that doesn’t have a panel
Plot- run a plot parameter file
Shell command - run an external program, Microsoft command line etc.

Under Elements

Resolve SA – resolve a selected super alignment
Clean model

Delete tin

Delete model

Delete all tins

Delete all models

Delete all templates

Delete all empty models

Under Files

Delete file

Compare - compare two text files
Under Other

Comment

Redraw all views

Selecting a command will update the right hand side of the panel with information for that 
particular command. For example, for the Resolve SA command

The common fields used in the right hand side are:

Command name - each command is given a default Command name composed of the command 
and the extra information such as the name of the super alignment. The Command name does not 
have to be unique and can be changed at any time.

information on the 
right hand side for the 
Resolve SA command
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Active - if ticked on then the command is run when the chain is run. If not ticked, the command is 
not run.

Continue on failure - if ticked on, the chain will continue running if an error occurs with this 
command. If not ticked, the chain will stop running if an error occurs in this command.

Comments - comments recorded for the options.

When a chain is running, message and error messages are written to the Output window.

Important Note - each time a command is inserted or modified, the Write button must be clicked 
to write out the modified chain. 
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Special Chain Commands

Option
Selecting the Option command modifies the information on the right side of the panel to suit the 
Option command.

Clicking on the Record button starts a “one option” record cycle.

The Recorder panel is placed on the screen and you run the 12d Model panel option that you 
wish to record (not 12d macro options, user macros or CAD commands)

Once the option is run, the Recorder panel is automatically removed and the Option in the 
Create/Edit Chain panel given the name of the 12d Model panel that was run.

The information displayed on 
the right is modified to suit 
the Option command

Pause
recording

Stop
recording

Cancel
recording

options
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Click on the Write button at the bottom of the Create/Edit Chain panel to update the chain 
information.

Important Note - the Preview button brings up the recorded panel with all the information filled 
in that can be validated by the panel fields. So sometimes Preview can not display the recorded 
information. Also Preview is for display only and can’t be used to modify Option.

Important Fudge - often this will work to change the information in Option. Select Preview to 
bring up the recorded panel with all the information filled in. Then hit the Record button on the 
Option, make the changes you want and run the panel. This will record the new information in 
place of the existing information.

Plot
Selecting the Plot command modifies the information on the right side of the panel to suit the Plot 
command.

Name of the
panel run and
recorded
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Clicking on the Write button at the bottom of the Create/Edit Chain panel names the command 
and updates the chain information.

Click on Plot type and select
the required plot type

Then type or select the PPF file

.

 

.

 

Clicking on the Write 
button at the bottom 
of the Create/Edit 
Chain panel 
automatically names 
the command and 
updates the chain.
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How to use the Recorder Icon
The Recorder option is like the Macro option in Word – it records the running of many 12d Model 
panel options so that they can be replayed. Note that it can not record running 12d Macros or 
CAD commands. The Recorder creates an Option command for each 12d Model option recorded

Clicking on the Recorder icon brings up the Recorder toolbar with icons to Pause, Stop and 
Cancel the recording.

Simply run the 12d Model panel options that you wish to record (not 12d macro options, user 
macros or CAD commands) until you hit the Stop icon. Each 12d Model option that is run will be 
added as a Run Option command to current chain.

Important Notes

1. Macros or CAD commands can not be recorded, and not all non-macro 12d panel options can 
be recorded. For example, if a screen layout file can not be created for an option, then it can’t 
be recorded.

2. When recording, the 12d Model panel option must be filled in and run. This may restrict what 
can be done.

Saving a Chain
After each item is added to the chain, click on Write to save the chain.

Running a Chain
There is a Run button on the Create/Edit Chain panel to run a chain.

However a chain can also be run simply by clicking on the name of the chain in the list created by 
walking right on 

Recalc =>Run chain

Similarly editing an existing chain can easily be done by clicking on the name of the chain in the 
list created by walking right on

Recalc =>Edit chain

This brings up the Create/Edit Chain panel with the selected chain in the editor.

Aside - the Recalc Chain Panel
recalc_chain

The Recalc Chain panel comes up if you click on Utilities =>Chains =>Edit without walking 
right or Utilities =>Recalc =>Edit chain without walking right.

Pause
recording

Stop
recording

Cancel
recording

options
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Special Notes on Recording Options
1. Use Unique String Names for String Selects

String selects on panels record the id and the name of the string, and the model id and the name 
of the model containing the string. 

When the option is run in the chain, the string is first searched for using the model and string id’s 
but if that fails then a string of the recorded name is searched for in the recorded model name.

If the string name is unique in the model then the correct string will be selected. If there is more 
than one string with the same name in the model, then the first string of that name that is found 
will be used.

2. Polygon Selects

String selects can be recorded for a Polygon box but Rectangle, Parallelogram or Lasso can not be 
recorded.

Edit a Chain
Position of option on menu: Utilities =>Chains =>Edit

The Edit walk-right menu displays all the chains in the project and double clicking on a chain in 
the list will bring up the Create/Edit a Chain panel (see “Create/Edit a Chain” ).

Run a Chain
Position of option on menu: Utilities =>Chains =>Run

The Run walk-right menu displays all the chains in the project and double clicking on a chain in 
the list will run the chain.

Rename Chains
rename_a_chain

Position of option on menu: Utilities =>Chains =>Rename

to create a chain, type in a new name for the chain (the 
.rcn will automatically be added)

and then click on Edit.

This will bring up the Create/Edit Chain panel.

string select - will record

rectangle - won’t record

parallelogram - won’t record

lasso - won’t record
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On selecting the Rename option, the Rename a Chain panel is displayed and is used to change 
the names of existing chains.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Chain to rename folder box available *.rcn files

chain to be renamed.

New name input

new name for the chain

Rename button

Change the name of the chain

Copy a Chain
copy_a_chain

Position of option on menu: Utilities =>Chains =>Copy

On selecting the Copy option, the Rename a Chain panel is displayed and is copy chains.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Chain to copy folder box available *.rcn files

chain to be renamed

New name input

new name for the chain

Copy button

Copy the chain

Delete a Chain
delete_a_chain
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Position of option on menu: Utilities =>Chains =>Delete

On selecting the Delete option, the Delete a Chain panel is displayed and is used to delete chains.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Chain to delete folder box available *.rcn files

name of the chain to delete

Delete button

Delete the chain given in the Chain to delete field.
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Functions
functions

Position of menu: Utilities =>Functions

Functions are used in the template and interface options to collect special data together. This 
allows 12d Model to recognize when some of the data has been modified and that some of the 
data is no longer valid. It is then possible to re-run the functions (re-calc the functions) and 
update the modified data.

The functions walk-right menu is

The Functions walk-right simply lists all the functions that have been defined in the project. The 
other options in this menu will now be described in more detail.

For the option Editor, go to the section “Editor” 
Lock “Lock” 
Order “Order” 
Recalc “Recalc” 
Rename “Rename” 
Add “Add” 
Save “Save” 
Delete “Delete” 

Editor
On walking right on the editor menu option, a list of defined functions appears. 

By selecting the highlighted name of a function to be edited, the appropriate function panel filled 
with the information from the selected function, is displayed

The information in the selected function can then be modified.

Important Note
The defined functions menu also has a [Same as] option which is used to select the function to be 
edited by simply picking any string that was created by the function.

Lock
function_lock_status
Position of option on menu: Utilities =>Functions =>Lock

The function lock option is used to lock a function so that it can’t be re-calculated.

list of functions in the project
modify an existing function
lock a function so it won’t recalc
modify the recalc order of functions
recalculate functions
rename a function
add functions to the project
save a functions to disk

delete functions from disk
delete many functions from disk
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On selecting the lock option, the function lock status panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function input available functions

name of the function to lock/unlock.

Lock model tick box

display and modifies the lock status for the given function.
If tick, the function is locked an won’t re-calculate.

Set button

set the lock mode for the selected function.

Order
function_recalc_order

Position of option on menu: Utilities =>Functions =>Order

The default recalculation order for functions is the order in which the functions were created 
however the order option is used to modify the function recalc order.

On selecting the order or option, the function recalc order panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Functions table available functions

list of functions in their recalculation order. Functions should only appear once in the list.

Set button

record the order of functions in the table.
Note - all functions must still exist somewhere in the re-arranged recalc order.
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Recalc
Position of option on menu: Utilities =>Functions =>Recalc

The recalc menu is the same as the menu.

Utilities =>Recalc

For more information, please go to the section “Recalc” of this chapter.

Rename
function_rename

Position of option on menu: Utilities =>Functions =>Rename

On selecting the rename option, the function rename panel is displayed.

This panel can be used to change the names of existing functions

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Old function input available functions

name of the function to be renamed.

New function input

new name for the function

Rename button

Change the name of the function in the old function field to the name given in the new function field.

Add
function_adds
Position of menu: Utilities =>Functions =>Add

The function add option brings up the walk-right menu, function adds

add_all_functions_to_project

Position of option on menu: Utilities =>Functions =>Add =>Add all to project

On selecting the add all to project option, the add all functions to project panel is displayed.

This panel is used to add all removed functions to the project.
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Save
function_saves

Position of menu: Utilities =>Functions =>Save

Functions can be saved on disk so that they can be used for future project work.

The function save walk-right menu is 

Note - Modified or new functions are automatically saved when a project is saved.

Save a Function
save_function
Position of option on menu: Utilities =>Functions =>Save =>Save a function

On selecting the save a function option, the save function panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function input available functions

name of the function to be saved.

Save button

after selecting this button, the function given in the function field will be saved to disk.

Save All Functions
save_all_functions
Position of option on menu: Utilities =>Functions =>Save =>Save all functions

On selecting the save all option, the save all functions panel is displayed.

By selecting the save button, all functions in the working project will be saved to disk. Unless an 
error occurs, the panel will be removed after the saving is completed.
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Delete
function_deletes

Position of menu: Utilities =>Functions =>Delete

Using the delete option, functions can be deleted from disk so that they no longer can be 
accessed or take up disk space.

To help protect the user against disasters, when a function is selected for deletion, a yes-no pop-
up menu is used to confirm that the user did intend deleting the function.

If deletion is confirmed, the selected function is removed from the project and deleted from the disk.
The function delete walk-right menu is 

Delete a Function
delete_function

Position of option on menu: Utilities =>Functions =>Delete =>Delete a function

The delete a function option can be used to delete a function in the working project.

On selecting the delete a function option, the delete function panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function function box all project functions

name of the function to be deleted.

Clean function strings tick box

if tick, delete all the strings created by the function

Delete button

after selecting this button, the function given in the function field will be deleted from the computer 
disk. A yes-no pop-up is used to confirm that deletion is required.

Delete All Functions
delete_all_functions

Position of option on menu: Utilities =>Functions =>Delete =>Delete all functions

The delete all functions option will delete all of the functions in the working project.

On selecting the delete all functions option, the delete all functions panel is displayed.
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Clean function strings tick box

if tick, delete all the strings created by all the function

After selecting the Delete button, a yes-no pop-up is used to confirm that deletion is required. If 
it is, all functions in the working project will be deleted from disk and unless an error occurs, the 
panel will be removed.
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Delete Many Functions
delete_many_functions

Position of menu: Utilities =>Functions =>Delete many

The Delete many option deletes one or more functions in the working project.

Selecting the Delete many, displays the Delete Many Functions panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Delete tick box

if tick, delete the selected function listed after the tick

Function input all project functions

name of all the functions in the project

Delete function strings tick box

if tick, delete all the strings created by the selected functions

Delete button

delete all the ticked functions in the function field
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Macros
macros

Position of menu: Utilities =>Macros

The 4D Solutions Macro Language (4DML) is a powerful programming language designed to 
run from within 12d Model. Its main purpose is to allow users to enhance the existing 12d Model 
package by writing their own programs (4DML’s or macros).

4DML’s can be compiled from within or outside 12d Model but can only be run from within 
12d Model.

The macros menu has options to compile macros, compile and run macros or just run macros. A 
full description of macros is given in the 12d Model Macro Language manual.

 The macros walk- right menu is

For the option Compile, go to the section “Compile” 
Compile/run “Compile and Run” 
Create “Create” 
Edit “Edit” 
Run “Run” 
Version “Version” 

The options will now be described.

Compile
compile_a_macro

Position of option on menu: Utilities =>Macros =>Compile

The compile option is used to compile the macro source code into a executable program which 
can then be run from within 12d Model.

On selecting the option, the compile a macro panel is placed on the screen.

The fields and buttons used in this panel have the following functions.

compile a macro
compile and run a macro
create a macro
edit a macro
run a macro
version of macro executable



12d Model Reference Manual

Page 2668 April 2007Macros

Field Description Type Defaults Pop-Up

Macro source input *.4dm files

the name of the macro source file.

Compile button

compile the code file given in the macro source field.
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Compile and Run
compile_run_a_macro

Position of option on menu: Utilities =>Macros =>Compile/Run

The compile and run option compiles the macro source code into a executable program, and if 
there are no errors, runs the program.

When a macro is run, a macro console panel is placed on the screen to provide an i/o and 
message area for the macro. It is possible to bring up the macro console with or without the 
restart, abort and finish buttons.

When the macro finishes, the macro console can be left on the screen or removed.

Selecting the compile & run menu option, brings up the compile/run a macro panel:

The fields and buttons used in these panels have the following functions.

Field Description Type Defaults Pop-Up

Macro source input *.4dm files

the name of the macro source file.

Macro arguments input

if non-blank, a text line which is passed to the program as an argument line.

Show buttons tick box

if tick, the macro console panel has abort, restart and finish buttons on it.

Retain on exit tick box tick

if tick, the macro console panel remains on the screen after the macro has finished running.

Show console tick box tick

if tick, the macro console panel is placed on the screen.
if non-tick, the macro console panel is not displayed - used mainly with panels.

Allow defaults tick box

if tick, the default value for a prompt is displayed in the macro console panel.

Compile/Run button

compile the code file given in the macro source field and if the compile is successful, run the program.
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Create
create_macro_file___4dm

Position of option on menu: Utilities =>Macros =>Create

The macros=>create option is used to create macro files (*.4dm) with the editor pointed to by the 
EDIT_4D environment variable.

Selecting macros=>create brings up the create macro file *.4dm panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder input current folder

name of the folder to create the .4dm file in.

File to create input *.4dm files

name of the file, in folder, to create.

Create button

create the file given by the folder and file to create panel fields. A macro header is set up in the file.
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Edit
edit_macro_file___4dm

Position of option on menu: Utilities =>Macros =>Edit

The macros=>edit option is used to edit macro files (*.4dm) with the editor pointed to by the 
EDIT_4D environment variable.

The macros=>edit option has two modes of operation - selecting the macros=>edit itself, or by 
activating the macros=>edit option’s walk-right menu, folder *.4dm.

Selecting macros=>edit itself brings up the edit macro file *.4dm panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Folder input current folder

name of the folder for the .4dm file.

File to edit input *.4dm files

name of the file, in folder, to edit.

Edit button

edit the file given by the folder and file to edit panel fields. If the file given in the file to edit field does not 
exist, then a new file is created which already has each of the macro header set up.

The macros=>edit walk-right menu provides a list all the many template files (files ending 
in .mtf) in the current folder. When a file is selected from the list, it is automatically loaded into 
the editor.
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Run
run_a_macro

Position of option on menu: Utilities =>Macros =>Run

The run option runs an existing macro executable program (produced by the compile process).

Like the compile and run option, the run options can run the macro executable with or without 
buttons on the macro console, and leave or remove the macro console once the macro has been 
executed.

Selecting the run menu option, brings up the run a macro panel:

The fields and buttons used in these panels have the following functions.

Field Description Type Defaults Pop-Up

Macro object input *.4dm files

the name of the macro object or executable program.

Macro arguments input

if non-blank, a text line which is passed to the program as an argument line.

Show buttons tick box

if tick, the macro console panel has abort, restart and finish buttons on it.

Retain on exit tick box tick

if tick, the macro console panel remains on the screen after the macro has finished running.

Show console tick box tick

if tick, the macro console panel is placed on the screen.
if non-tick, the macro console panel is not displayed - used mainly with panels.

Allow defaults tick box

if tick, the default value for a prompt is displayed in the macro console panel.

Run button

run the executable given in the macro object field.

Version
macro_version
Position of option on menu: Utilities =>Macros =>Version

The version option simply brings up a panel giving information about the macro process.
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Measure
measure

Position of menu: Utilities =>Measure

The measure menu contains two options to display the 

delta x, delta y, horizontal distance, angle and bearing

between points, and for a section view, the 

delta chainage, delta height, slope distance and % grade

between points are calculated and displayed.

There are also options to calculate the plan area of polygons, the surface area of a tin within a 
polygon, run measures and dynamic measures and dynamically calculate and display the x-fall 
between two strings.

 The measure walk- right menu is

Note

The measure option has another mode of operation. Rather than moving onto the walk-right 
arrow, if LB is clicked when the measure button is highlighted on the 12d Model=>utilities menu, 
the distance/bearing panel is displayed on the screen.

For the option Angle x 3 pts, go to the section “Angle by 3 Points” 
Bearing/distance        “Bearing and Distance” 
Plan area        “Plan Area” 
Surface area        “Surface Area”  in the chapter “Triangles” 
Value        “Value” 
Xfall by strings        “X Fall by Strings” 

The options in the menu will now be described.

measure angle by 3 points
distance/bearing with scale option
plan areas
surface area for a tin
any measures
dynamic x-fall between strings
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Angle by 3 Points
measure_angle

Position of option on menu: Utilities =>Measure =>Angle x 3 pts

The angle by 3 pts option is used to calculate the angle formed by selected three positions. the 
angle can be expressed as a clockwise or anti-clockwise angle.

On selecting the angle x 3 pts option, the measure angle panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mode input disjoint disjoint, continuous

In disjoint mode, only the angle between the three selected positions is reported. After the angle is 
reported, the user can select the 1st point in the sequence.

In continuous mode, after the initial reporting of the angle, the user is prompted for the 3rd point of the 
new angle to be measured. By default, the previous 2nd point becomes the first point and the previous 
3rd point becomes the 2nd point. This allows just one point (the third point) to be selected and the 
angle reported will change accordingly.

Clockwise angle tick box

if tick, then the angle is measured in the clockwise (forward) direction.

Anti-clockwise angle tick box

if tick, then the angle is measured in the anti-clockwise direction.

Clear button

when this button is selected, the sequence is re-initialised.

Note - after two positions are selected, the angle to the cursor position is dynamically calculated 
and displayed as the cursor moves around the view.
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Bearing and Distance
measure_bearing_distance

Position of option on menu: Utilities =>Measure =>Bearing/Distance

The distance/bearing option is used to calculate the

(a) the bearing measured in a clockwise direction between the positive y-axis and the 
(imaginary) line joining two selected points (when the bearing tick box is selected) 

or 

the bearing measured in an anticlockwise direction between the positive x-axis and the 
(imaginary) line joining two selected points (when the math angle tick box is selected) 

(b) the distance between two user selected points.

On selecting the distance/bearing option, the measure distance/bearing panel is displayed.

This panel is principally used to display the distances between, and bearing of the line joining, 
pairs of user selected points.

message area 1 : brg =   plane dist =      ellipsoid dist = 
where brg is the angle measured clockwise from north and is calculated using the coordinate 
values (Inverse value)

plane dist is the distance calculated using the coordinate values (Inverse value)

ellipsoid dist is the distance calculated by dividing the plane distance by the current scale factor

message area 2: dx =    dy =    dht = (if applicable)
where dx is the difference in x value between the two coordinates

dy is the difference in y value between the two coordinates

dz is the difference in z value between the two coordinates

If valid height values exist for two consecutive points the grade and slope is also reported

message area 3:   grade % =     slope =

If the measurement mode is set to continuous, the sum distances will be shown for the route 
taken

message area 4:    Sum plane dist =     Sum ellip dist =

where Sum plane dist, is the accumulative length of the route taken calculated using plane 
distances.

Sum ellip dist, is the Sum plane dist / scale factor.

The fields and buttons used in this panel have the following functions.

message area 1

message area 2

message area 3

message area 4
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Field Description Type Defaults Pop-Up

Mode input disjoint disjoint, continuous

In disjoint mode, only the distance between the two points and the bearing (in degrees, minutes and 
seconds) of the (imaginary) line connecting the two points are displayed. 

In continuous mode, after the initial reporting of the bearing/distance, the user is prompted to select 
the next point (2nd point). In this case the previously selected second point becomes the first point. 

Scale input/output 1.0

the scale factor which will be used to convert plane distances to ellipsoid distances. 
i.e ellipsoid distance = plane distance / scale factor

Bearing tick box ticked

if ticked, the measured vectors can be displayed as bearings (angles measured from north, clockwise)

Math angle tick box un-ticked

if ticked, the measured vectors can be displayed as a mathematical angle (measured from east in a anti-
clockwise direction.

Clear button

when this button is selected, the selection sequence is re-initialised.

Plan Area
measure_plan_area

Position of option on menu: Utilities =>Measure =>Plan area

The plan area option is used to calculate the plan areas enclosed by strings.

If a string is not closed, the first and last points are considered to be connected to form a polygon.

On selecting the option, the measure plan area panel is placed on the screen.

This panel is principally used to display the plan areas of strings selected by the user.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Mode input disjoint disjoint, continuous

If disjoint, only the area of the selected string is displayed. If continuous, the total of the areas is also 
displayed.

Clear button

when this button is selected, the total-to-date of the area is reset to zero and the selection sequence 
begun.

How to Use the Panel and Panel Messages

The measure area cycle consists is as follows:

(a) the string is selected with the mouse.
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message area 1 select string for area calcs
message area 2

(b) repeat step (a) to find more areas and accumulate them. If the accumulator is to be zeroed, 
simply select the clear button again.

The area of the selected string is displayed in message area 2.

 If the mode is set to continuous, the accumulated areas (sum) of the selected strings is also 
displayed.

message area 1 select string for area calcs
message area 2 area = value   sum = value

The cycle can then be repeated for as many strings as needed without leaving the option.

The accumulated total is reset to zero (cleared) by selecting the clear button again.

Surface Area
Position of option on menu: Utilities =>Measure =>Surface area

The surface area option calculates and reports the surface area of a tin restricted to a user 
specified polygon.

This option has already been documented as Tins=>Tin analysis=>Surface area.

See the section “Surface Area”  n the chapter “Triangles” .

Value
measure_value

Position of option on menu: Utilities =>Measure =>Value

The value option is used to calculate and display any of the measures available in the measures 
pop-up menu.

The measures are documented under “Measures”  in the chapter “Tools and Concepts” .

On selecting the option, the measure value area panel and the measures menu is placed on the screen.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Value output

the value calculated by the selected measure option.
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X Fall by Strings
xfall_between_2_strings_inquire

Position of option on menu: Utilities =>Measure =>XFall by strings

In this option, the user selects a reference string to define what is meant by chainage and right 
angles, and then selects two strings to calculate the x-fall between.

Once the three strings are selected, as the cursor moves around in a plan view, the cursor 
position is dropped perpendicularly onto the reference string. 

 At the dropped chainage, a line is taken at right angles to the reference point and extended until 
it cuts the two selected strings. The xfall is then calculated between the cut points on the strings.

 Then the chainage and the xfall are dynamically displayed in the panel message area.

The line joining the two strings is dynamically displayed on the plan view.

On selecting the Xfall by strings option, the xfall between 2 strings inquire panel is displayed.

The fields and buttons used in the two panel have the following functions.

Field Description Type Defaults Pop-Up

Reference string-select

the selected string is used to defined the meaning of chainage and bearing for the inquire. The cursor is 
dropped perpendicularly onto the reference string and at the dropped chainage, a line is taken at right 
angles to the reference point and extended until it cuts string 1 and string 2. The xfall is then calculate 
and displayed for the two cut points.

String 1/2 string-select

the two strings to calculate x-fall between.

Pick all button

if pick all is selected, the user is asked to sequentially select the three strings: reference string, string 1 
and string 2. The strings are automatically assigned to the appropriate string-select panel fields.

reference string

the line between the two cut points is used 
to calculate xfall, and is displayed

string 1

string 2

cursor

direction perpendicular to the reference string
to use to cut strings 1 and 2

 

point to use for chainage and bearing
 on the reference string

Plan View
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Recalc
recalc

Position of menu: Utilities =>Recalc

Once a function has been applied, the calculated information is only correct whilst the initial 
data is not modified in any way. If any modifications are made to the data, then the function 
must be re-run and all the associated information recalculated and redrawn, and any perspective 
views associated with the function set with the new eye and target positions, and redrawn.

There are date and time stamps for all string, tin and template information in 12d Model and this 
enables 12d Model to determine what information has been modified since a function was last 
run and what re-calculations are required.

The recalc option is designed to re-run functions

If LB is clicked whilst the recalc menu option is highlighted, all the template functions with auto 
recalc set on, and that have had their initial data modified since their last re-run, will be 
recalculated and all appropriate information updated. The data will be redrawn on any views 
that is was on before the recalc.

The Recalc walk-right menu has four options:

For the option Auto, go to the section “Auto” 
Editor “Editor” 
Edit data “Edit Data from String” 
Recalc “Recalc” 
Recalc all “Recalc All” 

Edit chain “Edit Chain” 
Run chain “Run Chain” 

Auto
function_auto

Position of option on menu: Utilities =>Recalc =>Auto

The auto option allows the user to specify whether a function is automatically recalced if another 
function, tin, template or string that it depends upon, is modified or recalced.

Individual functions or all functions can have auto-recalc mode turned on or off and the default for a new 
function is off.
The function auto menu is
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auto_recalc_mode_for_a_function auto_recalc_mode_for_all_functions
Position of option on menu: Utilities =>Recalc =>Auto =>Auto

Position of option on menu: Utilities =>Recalc =>Auto =>Auto all

The auto and auto all menu options bring up the auto recalc mode for a function and auto recalc mode 
for all functions panels respectively. 

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Function input available functions

name of the function to be have auto recalc mode set on/off.

Auto recalc tick box tick

if tick, the function is set to auto-recalculate. Otherwize auto recalc is set off.

Set button

Set the auto recalc mode for the selected function/all functions.

Editor
edit_function

Position of option on menu: Utilities =>Recalc =>Editor

The recalc=>editor option is used to edit function.

The recalc=>editor walk-right menu provides a list all the defined functions in the project.

When a function is selected from the list, it is automatically loaded into the appropriate function 
panel for the selected function, and displayed

The information in the selected function can then be modified.

Important Note
The defined functions menu also has a [Same as] option which is used to select the function to be 
edited by simply picking any string that was created by the function. This is documented in the 
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next section “Edit Function from String” 

Edit Function from String
edit_function_from_string

Position of option on menu: Utilities =>Recalc =>Editor =>[Same as]

Position of option on menu: Utilities =>Recalc =>Recalc =>[Same as]

The Edit Function from String option allows the user to start up the Function editor by simply 
selecting a string that was created by the function.

On selecting the option, the Edit Function from String panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick Edit button

select data that was created by a function and the appropriate function editor is then opened.

Edit Data from String
edit_MTF_survey_function_data

Position of option on menu: Utilities =>Recalc =>Edit data

The Edit data option allows the user to start up the MTF editor by simply selecting a string that 
was created using an Apply Templates function (and hence an MTF file). The MTF file used in 
the Apply Templates function is automatically loaded into MTF editor (go to “MTF Edit” ).

Similarly the Edit data option also allows the user to start up the Survey Field Data editor by 
simply selecting a string that was created using a Survey Data Reduction function. All the data 
produced by the Survey Data Reduction function is automatically loaded into the Survey Field Data 
editor (go to the section “Survey Field Data Editor” ).

On selecting the Edit data option, the Edit MTF/Survey Function Data panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick Edit button

select data that was created by applying an MTF file or a Survey Data Reduction function. The 
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appropriate MTF editor or Survey Field Data editor that created the selected data, is then opened.

For information on the Survey Field Data Editor, go to the section “Survey Field Data Editor” .

For information on the MTF Editor, go to “MTF Edit” .

Recalc
recalc_function

Position of menu: Utilities =>Recalc =>Recalc

The Recalc option is used to recalculate a user selected function, and all functions that depend 
on the function that have auto recalc set on.

The Recalc walk-right menu lists all the existing functions and by selecting a function name, the 
function will be forced to re-run and all appropriate information and views for that function will 
be updated.

The existing functions menu also has a [Changed] option which recalcs all changed functions.

The existing functions menu has a [Same as] option which is used to select the function to be 
recalced by simply picking any string that was created by the function. This is documented in 
the next section “Recalc Function from String” 

Recalc Function from String
recalc_function_from_string

Position of option on menu: Utilities =>Recalc =>Recalc =>[Same as]

The Recalc Function from String option allows the user to recalc a function by simply selecting a 
string that was created by the function.

On selecting the option, the Recalc Function from String panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Pick Edit button

select data that was created by a function and the appropriate function will be recalced.

Recalc All
recalc_all_functions

Position of option on menu: Utilities =>Recalc  =>Recalc all

The recalc all option re-runs all functions regardless of their date and time stamps.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Ignore auto recalc tick box

if not tick, all functions that have the auto-recalc flag set on are re-calculated.
If tick, the auto-recalc flag is ignored and all functions are re-calculated.

Edit Chain
folder___rcn   folder___rcn

Position of option on menu: Utilities =>Recalc =>Edit chain

The Recalc=>Edit chain option is used to edit chains.

The Recalc=>Edit chain walk-right menu provides a list all the defined chains in the project.

When a chain is selected from the list, it is automatically loaded into the Edit/Create Chain panel 
ready for editing.

Run Chain
Position of option on menu: Utilities =>Recalc =>Run chain

The Recalc=>Run chain option is used to run chains.

The Recalc=>Run chain walk-right menu provides a list all the defined chains in the project.

When a chain is selected from the list, it is automatically run.
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Fence
fence

Position of menu: Utilities =>Fence

It is often necessary to divide strings into those parts that are within a certain region and those 
parts that are outside the region. In 12d Model, the fence option is the method of achieving this 
result.

Given a string to be used as a fence, the 12d Model fencing options will process strings in a 
model/view against the fence and break the strings into the parts inside the fence string and 
those parts outside the fence string.

Any 2d, 3d or interface line-strings that cut the fence polygon will have points inserted at the 
intersections with the fence polygon. The z-value at the intersection point will be interpolated 
from the adjacent points in the line-string.

Point strings do not have any extra points added to them.

Restrictions

▲ only 2d, 3d and interface strings can be split using the fence option.

▲ 4d strings are treated as though they were point strings.

▲ arcs are considered to be inside the fence if the minimum bounding rectangles of the fence 
and arc overlap.

▲ alignment, pipeline, drainage, sewer strings are not processed by the fence option

Notes

1.  if the fence string is not closed, the first and last points are joined together to form a closed 
polygon as the fence.

2.  a string may be broken into a number of pieces if it wanders in and out of the fence string.

3. the fence string is not processed against itself even if it is in the model or view being fenced.

4. unpredictable results will occur if any strings being fenced lie on top of the fence. If problems 
occur, parallel the fence in or out by a millimetre.

The fence options allows the user to choose a single string to be used as the polygon fence or a 
number of strings to be used as polygons and process the data against all the strings in one 
operation.

The fence walk-right menu is

For the option Fence, go to the section “Fence” 
Fence stem “Fence Stem” 
Multi fence “Multi Fence” 
Multi fence stem “Multi Fence Stem” 

Fence
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fence_for

Position of option on menu: Utilities =>Fence =>Fence

In this option, the user selects a single string to be used as a polygon fence. If the string is not 
closed, the first and last points are joined together to form a polygon.

The Fence option will process a selected string or all the strings in a model/view/string against 
this fence and break the strings into the parts inside the fence string and those parts outside the 
fence string.

On selecting the Fence option and then the appropriate Data Source in the panel, the Fence for panel is 
displayed.

The fields and buttons used in the two panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

data source for strings to fence.

Polygon for fence string-select

the selected string will be used as the polygon to act as a fence to separate data into an inside and an 
outside.

Exclude model containing fence tick box tick

if tick, no data in the model containing the fence string will be fenced.
if not tick, all the appropriate data in the model containing the fence string will be fenced.

Model for fence inside input available models

if non-blank, name of the model to contain the data inside of the fence string.
If blank, then no fence inside will be calculated.

Model for fence outside input available models

if non-blank, name of the model to contain the data outside of the fence string.
If blank, then no fence outside will be calculated.
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Fence button

on selecting fence, the appropriate strings in the data source will be divided by the fence string 
(selected by the poly button) into the parts of the strings inside the fence string and the parts of the 
string outside the fence string. Any line-strings that cut the fence string will have a point inserted at the 
intersection with the fence string and the z-value for this point interpolated from the points on either 
side of it in the line-string.

How to Use the Panel and Panel Messages

(a) Select a fence polygon string by choosing Polygon to fence

(b) Fence processing begins on selecting the Fence button.
Progress messages - sent to the panel message area

calculating inside-outside
calculating inside
calculating outside
fencing string name

Completion message - sent to the panel message area
finished fence

<esc> can be used to abort the fence option.

Fence Stem
fence_stem

Position of option on menu: Utilities =>Fence =>Fence stem

As for the Fence option, the user selects a single string to be used as a polygon fence. If the string 
is not closed, the first and last points are joined together to form a polygon.

The Fence Stem option will process a selected string or all the strings in a model/view against 
this fence and break the strings into the parts inside the fence string and those parts outside the 
fence string. The inside and outside will then be put into models of the same name as the original 
model modified by a prefix and/or postfix. 

This means that unlike the fence option, when fencing a view with the Fence Stem option, the 
inside/outside for each model on the view goes to distinct models using the prefix/postfix for 
the inside/outside model names.

On selecting the Fence Stem option and then the appropriate Data Source in the panel, the Fence Stem 
panel is displayed.
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The fields and buttons used in the two panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

data source for strings to fence.

Prefix for fence inside input available models

if non-blank, prefix*postfix to adjust the data model name to be the model to contain the data inside of 
the fence string.
If blank, then no fence inside will be calculated.

Prefix for fence outside input available models

if non-blank, prefix*postfix to adjust the data model name to be the model to contain the data outside 
of the fence string.
If blank, then no fence outside will be calculated.

Polygon for fence string-select

the selected string will be used as the polygon to act as a fence to separate data into an inside and an 
outside.

Exclude model containing fence tick box tick

if tick, no data in the model containing the fence string will be fenced.
if not tick, all the appropriate data in the model containing the fence string will be fenced.

Fence button

on selecting Fence, the appropriate strings in the data source will be divided by the fence string into 
the parts of the strings inside the fence string and the parts of the string outside the fence string. Any 
line-strings that cut the fence string will have a point inserted at the intersection with the fence string 
and the z-value for this point interpolated from the points on either side of it in the line-string.

<esc> can be used to abort the fence option.
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Multi Fence
multi_fence

Position of option on menu: Utilities =>Fence =>Multi fence

It is often necessary to fence data against more than one polygon.

In the Multi-fence option, the user provides a model containing all the polygons to be used as 
fences. The Multi-fence option will process the selected string or all the strings in a model/view 
against all the polygons in the polygon model. 

The data will be clipped and the outside is considered to be those bits are outside all of the 
polygons and the inside is the remainder, i.e. the bits inside any one of the polygon.

On selecting the Multi fence option and then the appropriate Data Source in the panel, the Multi Fence 
String/Model/View panel is displayed.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

data source for strings to fence.

Model of fences input available models

name of the model that contains the polygons to be used as fences.

Model for fence inside input available models

name of the model to contain the data that is inside any one of the fences. If this field is blank, then no 
fence inside will be calculated.

Model for fence outside input available models

name of the model to contain the data outside all of the fences. If this field is blank, then no fence 
outside will be calculated.

Exclude model containing fence tick box tick

if tick, no data in the model containing the fence string will be fenced.
if not tick, all the appropriate data in the model containing the fence string will be fenced.
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Fence button

the appropriate strings in the data source will be divided by the fence polygons (from the model of 
fences) into the parts of the strings inside any one fence and the parts of the string outside all of the 
fences. Any line-strings that cut the fences will have a point inserted at the intersection with each fence 
and the z-value for this point interpolated from the points on either side of it in the line-string.

<esc> can be used to abort the multi- fence option.
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Multi Fence Stem
multi_fence_stem

Position of option on menu: Utilities =>Fence =>Multi fence stem

It is often necessary to fence data against more than one polygon.

In the multi-fence stem option, the user provides a model containing all the polygons to be used 
as fences. The multi-fence stem option will process selected strings or all the strings in a model/
view against all the polygons in the polygon model.

The data will be clipped and the outside is considered to be those bits are outside all of the 
polygons and the inside is the remainder, i.e. the bits inside any one of the polygon.

On selecting the Multi fence stem option and then the appropriate Data Source in the panel, the Multi 
Fence Stem String/Model/View panel is displayed.

The fields and buttons have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source

data source for strings to fence.

Model of fences input available models

name of the model that contains the polygons to be used as fences.

Prefix for fence inside input available models

if non-blank, prefix*postfix to adjust the data model name to be the model to contain the data inside of 
the fence string.
If blank, then no fence inside will be calculated.

Prefix for fence outside input available models

if non-blank, prefix*postfix to adjust the data model name to be the model to contain the data outside 
of the fence string.
If blank, then no fence outside will be calculated.
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Exclude model containing fence tick box tick

if tick, no data in the model containing the fence string will be fenced.
if not tick, all the appropriate data in the model containing the fence string will be fenced.

Fence button

the appropriate strings in the data source will be divided by the fence polygons (from the model of 
fences) into the parts of the strings inside any one fence and the parts of the string outside all of the 
fences. Any line-strings that cut the fences will have a point inserted at the intersection with each fence 
and the z-value for this point interpolated from the points on either side of it in the line-string.

<esc> can be used to abort the multi- fence option.
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2D Affine
affine_2d

Position of option on menu: Utilities =>A-G =>Affine

A affine transformation is a two dimensional linear transformation consisting of a 2D-translation 
(shift) of the data, a rotation and scaling of the data in two perpendicular directions. Hence there 
are six parameters to be specified. 

The most frequent method of defining an affine transformation is not by explicitly giving the 
affine transformation parameters but by specifying the final (transformed) and existing 
(observed) coordinates for three or more user selected points. The six parameters are then 
calculated using least squares.

These special user selected points in the final co-ordinate system are known as control points 
and observed points in the un-transformed system.

The affine transformation (for going from the observed points to the control points) can be 
calculated and used to convert the existing co-ordinates of items to their new transformed co- 
ordinates.

IMPORTANT NOTE - make certain that the control and observed points are not selected so that 
all the control points are not on a straight line or all the observed points are not on a straight line.

On selecting Affine, the Affine Transformation of panel is displayed.

control points
observed points

transformed pointsobserved points
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The main purpose of this panel is to display the affine transformation parameters. The fields and 
buttons used in the Affine Transformation of panel will be discussed after describing how to select 
the affine control points.

After selecting Affine option, the Affine Transformation of panel is placed on the screen and the 
option then sits waiting for the user to define how the affine parameters will be determined. The 
user selects the Affine parameters by choice box to choose if entry is by way of selecting points (default) 
or if the parameters are to be entered manually.

If the pt selection option is chosen, the user can start the selection of points by selecting the 
Control button. The selection should start with the control point, accepting that point then 
selecting the corresponding observed point. The control points are shown as triangles and the 
observed points are shown as circles. Lines are drawn between the control-observed pair for 
clarity.

Accepting the 2nd point (observed point) re-initialises the selection sequence so any further sets 
of points can be selected by selecting a control point and so on. The co-ordinates of the control 
points and observed points are added to the grid on the selection of two valid points. The use pt 
field is ticked by default.

The calculate button calculates the affine transformation parameters based all the control points 
in the grid control with the use pt field tick box ticked on. The residuals are then placed into the 
grid. The calculated parameters are placed into the parameters section of the panel.

If the direct entry method is chosen, the grid will disappear leaving only the parameter section. 
The user then fills out the relevant information.
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The affine parameters are

(a) the x-scale factor for the existing co-ordinates with respect to the new coordinates

(b) the y-scale factor for the existing co-ordinates with respect to the new coordinates

(c) the rotation of the x-axis of the existing co-ordinates to align it with the new x co-ordinates 
axis

(d) the rotation of the y-axis of the existing co-ordinates to align it with the new y co-ordinates 
axis

(e) the x and y translation of the existing co-ordinates after the scalings and rotations have been 
applied

The fields and buttons in the panel have the following functions

Field Description Type Defaults Pop-Up

File file box *.aaf files

a filename can be specified for reading or writing a file.

Read button

if a valid file exists, the file contents can be loaded into the panel.

Write button

if a valid name is specified, the user can write the input data to a file.

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Affine parameters by choice pt selection pt selection

direct entry

the parameter entry method.

Report file *.rpt files

if not blank, write a report on the Affine transformation.

Rotation x input/output

the rotation of the x-axes of the existing points with respect to the transformed x-axis.

Rotation y input/output

the rotation of the y-axes of the existing points with respect to the transformed y-axis.

Scale x input/output

the x-scale factor for the existing co-ordinates with respect to the transformed coordinates

Scale y input/output

the x-scale factor for the existing co-ordinates with respect to the transformed coordinates

 X Translation input/output

the x translation of the existing co-ordinates with respect to the transformed coordinates

 Y Translation input/output

the y translation of the existing co-ordinates with respect to the transformed coordinates

Control button

restarts the selection process for choosing more control points.

Calculate button

calculate the Affine parameters from the selected points shown in the grid.
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Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Affine button

apply the affine transformation to the data specified in the source box, and put it into the appropriate 
target area.
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Cartographic Projections
Position of option on menu: Utilities =>A-G =>Cartographic

The Cartographic option is used to transform data based on the same datum between

(a) two different cartographic projections (based on the same datum)

(b) longitude and latitude and a cartographic projection (based on the same datum)

(c) a cartographic projection and longitude and latitude (based on the same datum).

The Cartographic option has already been documented in the section “Cartographic” in the 
chapter “Survey” 
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Change
change_string_info

Position of option on menu: Utilities =>A-G =>Change

This Change option is similar to the Change option from the Strings edits menu.

For the selected strings, Change can modify the colour, name, breakline type, style and model of 
each string.

On selecting the Change option, the Change string info panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

New name input

if non-blank, then the name of the selected strings will be changed to the name given in the new name 
field.

New colour input available colours

if non-blank, then the colour of the selected strings will be changed to the colour given in the new 
colour field.

New style input

if non-blank, then the linestyle of the selected strings will be changed to the 
 given in the new style field.
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New pt-line type input leave as is leave as is, point, line

if leave as is, then the point-line type of the selected string will be not be changed.
If point string or line string, then the point-line type of the selected string will be changed to that type.

New weight input leave as is leave as is, point, line

if non-blank, then the weight of the selected strings will be changed to the 
 given in the new weight field.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected string
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Change String Chainage
change_string_chainage

Position of option on menu: Utilities =>A-G =>Change string chainage

This Change string chainage sets the start chainage of the selected strings to a given chainage 
value.

Selecting the Change string chainage brings up the Change string chainage panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

New chainage input

value to set the start chainage of all the selected strings to.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

process the selected string
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Check Strings
check_strings

Position of option on menu: Utilities =>A-G =>Check strings

Check strings compares selected strings against a mapping file and also checks distances 
between vertices on strings.

Selecting Check strings brings up the Check Strings panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Map file map file box

if a map file is picked then each selected string is compared against the map file keys and if any 
matches occur, the string attributes must agree with the map file fields of the matched key. Any 
differences will be reported to the Output window and the Report file.

Min length input

report if any distances between string vertices is less than Min length.

Max length input

report if any distances between string vertices is greater than Max length.

Min height input

report if any vertex height is less than Min height.

Max height input

report if any vertex height is greater than Max height.

Report file

if non blank, any failures are reported in this file.
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Check button

process the selected strings
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Convert
convert

Position of menu: Utilities =>A-G =>Convert

The convert options is designed to convert large numbers of strings between string types. There 
is also a global convert option which will convert even more string types.

The convert walk-right menu is

For the option Convert, go to the section “Convert” 
2d to 3d “2d to 3d” 
3d to 2d “3d to 2d” 
4d to 3d “4d to 3d” 
Text to 3d “Text to 3d” 
Poly to alignment “Poly to Alignment” 
Same start/end point strings “Same Start/End Point Strings” 

Convert
convert_string_types

Position of option on menu: Utilities =>A-G =>Convert =>Convert

The Convert option converts strings to a selected string type.

On selecting the Convert option, the Convert String Types panel is displayed.

The fields and buttons in this panel are used as follows

convert bulk strings
convert 2d strings to 3d strings
convert 3d strings to 2d strings
convert 4d strings to 3d strings
convert text to 3d points
convert polylines to alignments
convert closed strings to closed super strings
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Field DescriptionType Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

New type string type box all string types

the type of string to try and convert the data to.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Convert button

convert all the selected strings to the type given in the New type field.

2d to 3d
convert_2d_to_3d_strings_in

Position of option on menu: Utilities =>A-G =>Convert =>2d to 3d

The main difference between a 2d and a 3d string is that all the points in a 2d string have the 
same height. Hence to modify the z-values at individual points, a string must be 3d.

The 2d to 3d option is used to turn 2d (contour) strings into 3d strings.

This option is especially useful when a large number of strings have been read in with constant 
z-values (for example, cadastre) and the user then wants to modify the heights at each point on 
the string.

On selecting 2d to 3d and then the appropriate Data Source in the panel, the Convert 2d to 3d Strings in 
panel is displayed.

The fields and buttons in this panel are used as follows

Field DescriptionType Defaults Pop-Up

Data source type Model
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data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Pass other strings tick box tick

if tick, copies of all other strings are passed through to the model for converted strings

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Convert button

convert all the 2d string in the model/view given in the data source to 3d strings.

3d to 2d
convert_3d_to_2d_strings_in

Position of option on menu: Utilities =>A-G =>Convert =>3d to 2d

The difference between a 3d and a 2d string is that all the points in a 2d string have the same 
height. The 3d to 2d option turns 3d string with a constant height into 2d strings. That is, it only 
converts 3d strings that have the same height at each point.

This option is useful when contours strings have come from another system as 3d strings, not 2d 
strings.

On selecting 3d to 2d and then the appropriate Data Source in the panel, the Convert 3d to 2d Strings in 
panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.
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Pass other strings tick box tick

if tick, copies of all other strings are passed through to the model for 2d strings

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Convert button

convert all the 3d strings with constant height in the model/view given in the model/view field, to 2d 
strings.

4d to 3d
convert_4d_to_3d_strings_in

Position of option on menu: Utilities =>A-G =>Convert =>4d to 3d

The difference between a 4d and a 3d string is that a 4d string can have a text label at each point 
on the string. The 4d to 3d option turns 4d string into 3d strings by stripping off the text labels at 
each point of the 4d string.

On selecting 4d to 3d and then the appropriate Data Source in the panel, the Convert 4d to 3d Strings in 
panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Pass other strings tick tick

if tick, copy all other strings and pass them through to the model for 3d strings

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 
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Target info input

extra information required for the target.

Convert button

convert all the 4d strings in the model/view to 3d strings.

Text to 3d
text_to3d_panel

Position of option on menu: Utilities =>A-G =>Convert =>Text to 3d

Sometimes when data for points is received from a CAD systems, all that is received is the text of 
the z-value of the point and no actual point.

The Text to 3d option will find text representing a z-value and create a new point using the 
justification point of the text as the (x,y) position and the value of the text as the z-value.

On selecting Text to 3d, the Convert Text Strings to 3d Strings panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data of the text to be processed.

Model for 3d points model box available models

model to place the 3d points in.

Horizontal offset (dx) input 0

the x-value for created point is the text justification point less the horizontal offset.

Vertical offset (dy) input 0

the y-value for created point is the text justification point less the vertical offset.

Min z value input

if non-blank, only convert text with z-value greater than Min z value.

Max z value input

if non-blank, only convert text with z-value less than Max z value.
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Process button

convert all the selected text strings to 3d strings.

Poly to Alignment
Cad_polylines_to_alignment_convert

Position of option on menu: Utilities =>A-G =>Convert =>Poly to alignment

Selecting Poly to alignment brings up the CAD Polyline to Alignment Convert panel.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data of the text to be processed.

New name name box available names

if non blank, new name for the converted strings

New model model box available models

new model for the converted strings

New colour colour box available colours

if non blank, new colour for the converted strings

IP/TP chg tolerance input 0.001

Delete original tick box tick

if tick, the original strings are deleted.

Process button

convert all the selected alignments.
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Same Start/End Point Strings
convert_same_start_end_point_strings

Position of option on menu: Utilities =>A-G =>Convert =>Same start/end point strings

When non super string strings are closed, an extra vertex identical to the first vertex is added to 
the end of the string. For super strings, there is a closed string flag and no duplication of the first 
and last vertices is required.

This options converts closed non super strings to closed super strings and deletes the duplicated 
vertex.

Selecting Same string/end point strings brings up the Convert Same Start/End Point Strings panel.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Pass other strings tick tick

if tick, copy all other strings and pass them through to the target model

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Convert button

convert all the closed strings to closed super strings.
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Cuts
cuts

Position of menu: Utilities =>A-G =>Cuts

The cuts option is used to create intersections through string data rather than tins.

That is, it calculates the cuts that a plan string makes with each of the strings in a model or view, 
at creates cut points with the z-value from the cut strings.

The cut points that the plan string creates are connected as a 4d string - the x-section of cuts 
through a model or view - with the z value coming from the cut string, and the text at the point 
being the name of string that was cut.

There are two methods for generating the cuts x-sections

(a) by taking sections along selected strings or all the strings in a model or view

(b) by taking sections at regular intervals and perpendicular to a selected centre line string.

The cuts walk-right menu contains these two methods

For the option by strings, go to the section “Cuts by Strings” .
by centreline “Cuts by Centreline” .
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Cuts by Strings
cuts_through

Position of option on menu: Utilities =>A-G =>Cuts =>by strings

For this method of generating cuts through strings, either individual strings are selected or a 
model or view of strings is specified by the user. These strings are then

For each of the selected strings, the plan representation of the string is cut through the model or 
view of strings to generate cut x-sections.

On selecting the by strings option and then the appropriate Data Source in the panel, the Cuts Through 
panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Model of strings input available models

each string in this model will be processed against all the strings in the view/model to cut through. Not 
used with the pick button.

Model for cuts input available models

model to place the cut x-sections into.

Colour for cuts input available colours

colour for the cut x- section strings

Cut button

each string in the model of strings is processed against all the strings in the view/model to cut through. 
The 4d strings of cuts are placed in the model for cuts.
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Cuts by Centreline
cuts_from_cl_for

Position of option on menu: Utilities =>A-G =>Cuts =>by centreline

For by centreline, a centre line string is selected by the user and section lines are created in plan 
at regular intervals perpendicular to the selected string. Cut x-sections are then generated for the 
plan section lines by taking cuts through the model or view of strings, by the plan sections.

On selecting the by centreline option, the Cuts from CL for panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Section separation input 10.0

the distance along the selected centre line to generate plan section lines to be used to cut through the 
model or view.

Special chainages input *.spf files

a file containing chainages, one per line, that are also used as chainages to create cross sections at.
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Chord/arc tolerance input default chord/arc tolerance

the chord to arc tolerance to use on the selected string for determining how many plan sections are cre-
ated around horizontal curves.

Left/Right cut width input 50

the left/right distance to go out from the centre line for creating a section to cut through the strings.

Model for cuts input available models

model to place the cut x-section strings into.

Clean cuts model beforehand tick box

if tick, the model is cleaned of all data before new sections are created.

Colour for cuts colour box available colours

colour for the cut section strings

Keep null levels tick box

if tick, then if a null level exists on the string being cut, then a null level point is created.

Select cl string-select

the selected cl string is used to create plan section lines at regular intervals and perpendicular to the 
centre line string. These strings are cut though the model/view of strings.

Start/End chainage input

if non-blank then sections for the cuts are restricted to between the given start and end chainage of the 
selected cl string.

End Area Calculations

Tin tin box available tins

if non-blank, the cut and fill areas for the section against the tin are calculated and added as attributes 
to the section.

Strip depth input

if non-zero, then a strip depth is removed from the tin before the cut and fill areas for the section 
against the tin are calculated.

Cut button

each plan section line generated down the selected centre line string is processed against all the strings 
in the view/model. The 4d strings of cuts are placed in the model for cuts.
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Delete
delete

Position of option on menu: Utilities =>A-G =>Delete

The Delete option deletes all the selected strings.

On selecting the Delete option, the Delete panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Delete button

delete the selected strings.
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Duplicate
duplicate

Position of option on menu: Utilities =>A-G =>Duplicate

The duplicate option is used to make a duplicate of a string, an entire model or duplicates of all 
the models on a view.

On selecting Duplicate and then the appropriate Data Source in the panel, the Duplicate panel is 
displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

New model input available models

name of the model to place the duplicated strings into.

Duplicate button

duplicate all the strings in the model/view given in the model/view field and add them to the model 
given in the new model field.

<esc> can be used to abort the duplicate option.
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Explode
explode_strings_in

Position of option on menu: Utilities =>A-G =>Explode

The explode option is used to explode line strings and polylines into two point lines and 
polylines and point strings into individual points. Alignment, pipeline, sewer and drainage 
strings are not exploded.

The option can be used in three ways - an individual string can be selected for exploding, the 
name of the model to be exploded can be entered or a view name entered and all the models in 
the view will be exploded and placed in one new model.

On selecting Explode and then the appropriate Data Source in the panel, the Explode Strings in panel is 
displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Pass other strings tick box tick

if tick, copies of all other strings and passed through to the exploded model.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Explode button

explode all the strings in the data source and process them according to the target box.
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Explode Text
explode_text_in

Position of option on menu: Utilities =>A-G =>Explode (text)

The explode text option is used to explodes text in text strings and the text from 4d strings, into 
its component arcs and lines.

Like explode, the option can be used in three ways - individual strings can be selected for 
exploding, the name of the model to be exploded can be entered or a view name entered and all 
the models in the view will be exploded and placed in one new model.

On selecting Explode Text and then the appropriate Data Source in the panel, the Explode Text in panel is 
displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Exploded model input available models

name of the model to place the exploded text strings and text of 4d strings into.

Explode button

explode all the selected text and add them to the model given in the exploded model field.
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Factor
factor

Position of option on menu: Utilities =>A-G =>Factor

The factor option is used to multiply the x,y and z values of a selected string, or for all the strings 
in a given model or view, by user supplied factors.

The option is useful for changing the units of any data in a model (e.g. imperial to metric).

On selecting Factor and then the appropriate Data Source in the panel, the Factor panel is displayed.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

x/y/z factor input 1.0

factor to multiply the x/y/z-values of a string by.

Origin x y z input xyz ops menu

field with x y z value to be used as (x,y,z) origin for the factor.
if blank, an origin of (0,0,0) is used.

Factor text size tick box tick

if tick, the size of text is factored.
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Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Factor button

multiply the (x,y,z) values of the selected strings by the x,y and z factors given in the appropriate panel 
fields.

WARNING - if the x factor and y factor are not equal, then arcs in arcs, circles, alignment and 
polyline strings can not be factored. For these cases, the y factor will be set the x-factor and then 
applied to the arcs.
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Filter
filter

Position of menu: Utilities =>A-G =>Filter

The filter options are used to remove surplus points from strings. Three types of filters are 
currently supported in 12d Model 

▲ a string filter, which removes points from 2d and/or 3d line strings that do not deviate by 
more than a specified offset tolerance from straight lines joining successive string points 
(in three dimensions for 3d strings)

▲ a vertex-filter which removes adjacent vertices closer than a given user defined (x,y) and z 
distance

▲ a z-filter which eliminates points not contained within a specified z-range

The filter walk-right menu is

For the option String filter, go to the section “String Filter” .
Vertex filter “Vertex Filter” .
z filter “Z Filter” .

String Filter
filter_strings_in

Position of option on menu: Utilities =>A-G =>Filter =>String filter

The String filter option is used to remove surplus vertices from 2d strings (contours) and 3d 
strings. 

Using a user defined tolerance, string vertices that are within an offset tolerance (in three 
dimensions) of straight lines are removed. The tolerance value used normally depends on the 
data set and the job that the data is being used for.

That is, the string filter removes vertices from 2d and/or 3d line strings that do not deviate by 
more than a specified offset tolerance from straight lines joining successive string vertices (in 
three dimensions for 3d strings)

NOTE - string filer does not apply to point strings.

filter 2d and 3d strings
removes close adjacent vertices
filter z values

These vertices are removedTolerance tube

line string
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On selecting String filter the Filter Strings in panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

String type input 2d 2d, 2d & 3d

string types to be filtered

Filter tolerance input 1

tolerance to be used in filtering

Pass other strings tick box tick

if tick, pass all other strings through to the model for filtered strings

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Filter button

filter all the selected strings.

Vertex Filter
filter_adjacent_vertices_in

Position of option on menu: Utilities =>A-G =>Filter =>Vertex filter

The Vertex filter option is used to remove close adjacent vertices from selected strings. The strings 
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can be point or line strings.

The option can remove adjacent string vertices that are equal to a given tolerance either in plan 
position only (i.e. have similar x and y co-ordinates) or equal to a given tolerance for x, y and z 
co-ordinates.

On selecting Vertex filter the Filter Adjacent Vertices in panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Dimension input 2d 2d,3d

if 2d, adjacent string vertices with equal x and y co-ordinates are filtered.
If 3d, adjacent string vertices with equal x, y and z co-ordinates are filtered.

xy tolerance input

the distance to use for checking if adjacent vertices are too close in (x,y)

z tolerance input

the delta-z to use for checking if adjacent vertices are too close in z

Vertices with attributes choice box Ignore/skip Ignore/skip, Merge attributes
Lose attributes

if Ignore/skip, don’t drop any vertices with attributes.
If Merge attributes, merge the attributes from a dropped vertex with the kept vertex.
If Lose attributes, drop the attributes from a dropped vertex.

Segments with attributes choice box Ignore/skip Ignore/skip, Merge attributes
Lose attributes



Chapter 26  Utilities

April 2007 Page 2723Filter

if Ignore/skip, don’t drop any vertices of segments with attributes.
If Merge attributes, merge the attributes from a dropped segment with the kept segment.
If Lose attributes, drop the attributes from a dropped segment.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Filter button

filter the selected strings.
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Z Filter
z_filter_strings_in

Position of option on menu: Utilities =>A-G =>Filter =>Z filter

It is often necessary to remove data which is not within a certain z range. For example, all points 
with z-values below 0.0. The z filter option allows the user to define a z-range by specifying a 
minimum and maximum z value.

Strings of type 2d, 3d and 4d can then be processed against the z-range and new strings created 
containing only those points that are

(a) within the z-range - accepted points
or
(b) outside the z-range - rejected points

For all other string types, the entire string is accepted if any part of the string is within the z-
range, otherwise it is rejected.

On selecting Z filter and then the appropriate Data Source in the panel, the Z Filter Strings in panel is 
displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

z min input

minimum z value to be accepted, If this field is blank, all string z-values pass the minimum test.

z max input

maximum z value to be accepted, If this field is blank, all string z-values pass the maximum test.

Filtered model input available models

if non-blank, the name of the model to place the accepted string points in. The string has the same 
name as the original string. If blank, the accepted point strings are not saved.

Rejects model input available models

if non-blank, then strings containing the rejected points are placed in this model. The strings of rejected 
points have the same name as the original strings. If blank, the rejected point strings are not saved.
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Filter button

z filter the selected strings by the z minimum and z maximum values.
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Create Grid
create_world_grid

Position of option on menu: Utilities =>A-F =>Create grid

Create Grid is used to create the line work for a grid in world units. Mainly used for output to 
other packages that don’t create grids.

Selecting Create Grid brings up the Create World Grid panel.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Clip mode choice box View View, Rectangle

if View, a view is used to define extents of the grid.
If Rectangle, a rectangle is drawn and used to define extents of the grid.

Draw mode choice box full lines full lines, crosses, marks

type of line work for the grid

Grid East (x) settings:

Interval input

x-delta to use for the grid lines

Text mode choice box bottom off, bottom, top, top & bottom 
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if off, no text is created for the x-grid lines.
If bottom, text is created only at the bottom of the x-grid lines.
If top, text is created only at the top of the x-grid lines.
If top & bottom, text is created at the top and bottom of the x-grid lines.

Pre*postfix text

if non blank, pre*post text to use for the labels on the x-grid lines

Grid North (y) settings:

Interval input

y-delta to use for the grid lines

Text mode choice box left off, left, right, left & right 

if off, no text is created for the y-grid lines.
If left, text is created only at the left of the y-grid lines.
If right, text is created only at the right of the y-grid lines.
If left & right, text is created at the left and right of the y-grid lines.

Pre*postfix text

if non blank, pre*post text to use for the labels on the y-grid lines

Grid colour colour box available colours

colour for the grid lines

Textstyle data  textstyle data

textstyle data to use for the grid text

Grid model model box available models

model for the grid lines and text

Create border tick box tick

if tick, create a rectangle border around the area

Create button

create the grid
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Head to Tail
head_to_tail_strings

Position of option on menu: Utilities =>H-Z =>Head to tail

The head to tail option is used to process a model or view of strings and join strings with 
common end points together.

If requested, strings are only joined if they have matching names as well as matching end points.

On selecting the Head to tail and then the appropriate Data Source in the panel, the Head to Tail Strings 
in panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

One string or Many strings radio button

if One String is selected, then a Base string is selected and only the head-to-tailed string containing the 
Base string is created.
If Many strings is selected, then head to tailing occurs for all the strings in the Data source.

Head to tail across models tick box

if tick, then strings can be created from head to tailing strings from any of the selected models.
If not tick, then strings will only be head to tailed with strings from the same model.
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Use string names tick box

if tick, the string names must also match for the strings to be joined.

Pass other strings tick box tick

if tick, any string not joined will also copied to the joined model.

Tolerance  input 0.0005

If the distance between two end points is less than tolerance, then the points are considered the same 
and the strings may be joined.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Process button

check all the strings in the given model/view and join them together if they have common end points 
and, if use string names is tick, the same name.
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Set Height
set_height

Position of option on menu: Utilities =>H-Z =>Height

For the selected strings, Height will set all the z-values to the given height.

Selecting Height displays the Set Height panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

New height input 0

the new height to set all the z-values in the selected strings to.

Do null heights tick box

if tick, null heights are set to the new height.
If not tick, null heights are not modified.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Set button

process the selected string
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2D Helmert
helmert_2d
Position of option on menu: Utilities =>H-Z =>Helmert 2D

A Helmert transformation is a two dimensional linear transformation consisting of a scaling, 
rotation and translation (shift) of data. This type of transformation is often required for 
converting data between a local and another co-ordinate system.

The most frequent method of defining a Helmert transformation is not by explicitly giving the 
Helmert transformation parameters but by specifying the final (transformed) and existing 
(observed) coordinates for two or more user selected points.

These special user selected points in the final co-ordinate system are known as control points 
and observed points in the un-transformed system.

The Helmert transformation (for going from the observed points to the control points) can be 
calculated and used to convert the existing co-ordinates of items to their new transformed co- 
ordinates

See example after the panel description.

On selecting the Helmert option, the Helmert 2D panel is displayed.

control points
observed points

transformed pointsobserved points
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The main purpose of this panel is to display the helmert transformation parameters. The fields 
and buttons used in the Helmert 2D panel will be discussed after describing how to select the 
helmert control points.

After selecting Helmert 2D option, the Helmert 2D panel is placed on the screen and the option 
then sits waiting for the user to define how the helmert parameters will be determined. The user 
selects the parameters by choice box to choose if entry is by way of selecting points (default) or if 
the parameters are to be entered manually.

If the pt selection option is chosen, the user can start the selection of points by selecting the 
Control button. The selection should start with the control point, accepting that point then 
selecting the corresponding observed point. The control points are shown as triangles and the 
observed points are shown as circles. Lines are drawn between the control-observed pair for 
clarity.

Accepting the 2nd point (observed point) re-initialises the selection sequence so any further sets 
of points can be selected by selecting a control point and so on. The co-ordinates of the control 
points and observed points are added to the grid on the selection of two valid points. The use pt 
field is ticked by default.

The calculate button calculates the helmert transformation parameters based all the control 
points in the grid control with the use pt field tick box ticked on. The residuals are then placed 
into the grid. The calculated parameters are placed into the parameters section of the panel.

If the direct entry method is chosen, the grid will disappear leaving only the parameter section. 
The user then fills out the relevant information.

The helmert parameters are

(a) the scale factor for the existing co-ordinates with respect to the new coordinates
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(b) the rotation of the existing co-ordinates to align it with the new co-ordinates axis

(c) the x and y translation of the existing co-ordinates after the scalings and rotations have been 
applied

The fields and buttons in the panel have the following functions

Field Description Type Defaults Pop-Up

File file box *.hel files

a file name can be specified for reading or writing a file.

Read button

if a valid file exists, the file contents can be loaded into the panel.

Write button

if a valid name is specified, the user can write the input data to a file.

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Helmert parameters by choice pt selection pt selection

direct entry

the parameter entry method.

Report file *.rpt files

if not blank, write a report on the Helmert transformation.

Rotation input/output

the rotation of the axes of the existing points with respect to the transformed axes.

Scale input/output

the scale factor for the existing co-ordinates with respect to the transformed coordinates

 X Translation input/output

the x translation of the existing co-ordinates with respect to the transformed x coordinates

 Y Translation input/output

the y translation of the existing co-ordinates with respect to the transformed y coordinates

Control button

restarts the selection process for choosing more control points.

Calculate button

calculate the helmert parameters from the selected points shown in the grid.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Helmert button

apply the helmert transformation to the data specified in the source box, and put it into the appropriate 
target area.

Finish button

end the option, remove this panel and the Helmert control points table from the screen.
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controlobserved

B (2.6,7.2)

C (5.4,4.4)

D (4,3)

A
(1.2,5.8) B (2,3)

C (2,1)
D(1,1)

A (1,3)

For Example

The Helmert parameters fo
the example are:
Scale 0.5
Clockwise rotation 45 deg
X translation -1.5
Y translation 1.38

after clockwiseafter scale about (0,0)

B (1.3,3.6)

C (2.7,2.2)

D (2,1.5)

A
(0.6,2.9)

B 

CD

A 

rotation about (0,0)

transformed data

B (2,3)

C (2,1)
D(1,1)

A (1,3)

after translation
by (-1.5,1.38)

by 45 deg
by 0.5 
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Inquire
inquire

Position of option on menu: Utilities =>H-Z =>Inquire

The Inquire option simply highlights all the selected strings.

On selecting the Inquire option, the Inquire panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.
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Map
map_file_apply

Position of option on menu: Utilities =>H-Z =>Map

The map option applies a 12d Model input mapping file to the selected strings. The map file can 
be used to change string attributes such as string names, models, colours, breakline type and 
style, apply extrudes, apply polygon fills etc.

The layout and operation of a mapping file is described in the section “Map File” in the chapter 
“File I/O” .

Selecting Map displays the Map File Apply panel.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Use map file models tick box

if tick, use the models from the map file.
If not tick, use the models from the Target.

Map file map file box *.mf files

the map file to use.

Prefix for models input available models

If non-blank, the prefix for models field gives the characters to be prepended and appended to the 
model names given in the mapping file. The prepended and appended characters are entered into the 
prefix for models field, separated by a *. For example, pre*pos would add pre before each model name 
and pos after each model name. For prepend only, no * is required.

Target type
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data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Map button

run the option - process the selected strings
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Null Heights
null_height_ops

Position of option on menu: Utilities =>H-Z =>Null heights

A null value is used as a z-value (height) when no actual z-value exists at the point. That is, the 
point has valid x and y co- ordinates but no valid z-value.

The null heights walk-right menu is

For the option Height, go to the section “Heights” .
Height range “Height Range” .
Null to height “Null to Height” .

Heights
null_height_of

Position of option on menu: Utilities =>H-Z =>Null heights =>Height

The null heights option is used to set z-values of a user given value to 12d Model’s null value. It 
can be applied to all the strings in a given model or view.

On selecting Heights and then the appropriate Data Source in the panel, the Null Heights of panel is 
displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input
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source of data is to be processed.

Height to null input

height value to set to the null value.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Null button

test all the z-values in the selected strings and if the value is equal to the height to null value, set the z-
value to null.
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Height Range
null_height_range_of

Position of option on menu: Utilities =>H-Z =>Null heights =>Null range

The null height range option is used to set z-values within a user given range to 12d Model’s null 
value. It can be applied to selected strings, or all the strings in a given model or view.

On selecting Height range and then the appropriate Data Source in the panel, the Null Height Range of 
panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Height min input

minimum value of the heights to be set as null values.

Height max input

maximum value of the heights to be set as null values.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Null button

test all the z-values in the selected strings and if the value is between the height min and height max 
value, set the z-value to null.
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Null to Height
null_to_height_of

Position of option on menu: Utilities =>H-Z =>Null heights =>Null to height

The null to height option is used to set null z-values to a user given value. It can be applied 
selected strings or to all the strings in a given model or view.

On selecting Null to height range and then the appropriate Data Source in the panel, the Null to Height of 
panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

New height input

height value to change null values to.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Change button

Change all the null z-values in all the strings in the model/view given in the model/view to change field 
to the value given in the new height field.
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Rename Strings
global_string_rename

Position of option on menu: Utilities =>H-Z =>Rename strings

Selecting Rename strings brings up the Global String Rename panel.

The fields and buttons used in the rotate panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Input

method of selecting strings

Output

method of changing strings

Use regular expressions tick box

if tick, Input is a regular expressions.
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Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Rename button

rename the selected data.
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Rotate
rotate

Position of option on menu: Utilities =>H-Z =>Rotate

The rotate option is used to rotate all the strings in a model or on a view about a central point 
(the rotation centre). The strings are rotated through a user supplied angle and can be moved or 
copied to their new rotated position.

The difference between a copy and a move is that if a string is copied, a copy of the string is 
rotated and the original string left untouched, whereas for a move, the actual string is moved 
from its original position to the new rotated position.

The rotated strings can either be placed in their original models, or moved/copied to a new 
model.

On selecting Rotate and then the appropriate Data Source in the panel, the Rotate String/Model/View 
panel is displayed.

The centre of the rotation is defined by selecting the Centre button and picking a point as the new 
centre. The centre can be changed at any time by using the Centre button to select another centre.

The fields and buttons used in the rotate panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Rotation centre xyz ops

select the centre of the rotation. The centre can be changed at any time.
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Rotation angle (dms) angle box

the angle in degrees to rotate the string through. The angle is measured about the rotation centre point 
in either a clockwise or anticlockwise direction.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Rotate button

rotate the selected data.
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Set Heights for 2d/Super Strings
set_heights_for_2d_super_stringsl

Position of option on menu: Utilities =>H-Z =>Set heights for 2d/super strings

This panel is used to quickly change the height of 2d strings or 2d super strings (super strings 
with a constant z value). An initial height and increment is given. As each string is processed, it 
is given the height and the height then incremented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Height input
Height to use for the next selected string. This is incremented by the “Height increment” after each 
string is accepted.

Height increment input
As each string is accepted, the “Height” value is incremented by this value.

Colour input available colours
If non-blank, the selected strings are given this colour when their z-value is changed.

Target type

place to put the processed string. Data target type - for a full description go to “Data Target”  in the 
chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Update string string select

After clicking on the select arrow, 2d strings are selected and when accepted, have their z-value 
changed to the value in the Height field. The height value is then automatically incremented. The next 
string is then selected and accepted (without needing to click on Pick again). This continues until Can-
cel is selected from the “Pick Ops” menu.
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Smooth Strings
smooth_strings

Position of option on menu: Utilities =>H-Z =>Smooth strings

The smooth options are used to add extra points into 2d or 3d strings to make a smoother string.

 On selecting Smooth strings and then the appropriate Data Source in the panel, the Smooth Strings 
panel is displayed.

The fields and buttons in this panel are used as follows

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input
data source to be smoothed.

Model for smoothed strings   input available models

model for the smoothed strings to go to

Preserve string points tick box

if tick, the smoothed strings will still contain all the original points.
if not tick, the smoothed strings may deviate from the original string points

Pass other strings tick box tick

if tick, any strings that can’t be smoothed are copied and added to the smoothed strings model.

Smooth button

smooth the selected strings.
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Swap XY
swap_xy

Position of option on menu: Utilities =>H-Z =>Swap XY

The swap xy option is used to swap the (x,y) co-ordinates of selected strings, or all strings in a 
model or view.

On selecting Swap XY and then the appropriate Data Source in the panel, the Swap XY String/Model/
View panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Swap XY button

swap the selected strings and add them to the target.
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Text
change_text_info

Position of option on menu: Utilities =>H-Z =>Text

The Text option is used to change the text style, units, height, offset, justification, angle and text 
for text, 4d strings and super strings.

For this option the selection process is extended.

After the data is selected as defined by the Data source, the two extra parameters, Old text and Old 
info, are used to further specify which text is to be modified.

On selecting the Text option, the Change Text Info panel is displayed.

The fields and buttons used in the panel have the following functions.

Field Description Type

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

Old text input

if the old text field is non-blank, then any text in 4d or text strings will be checked for a match against 
this value. Wild cards and characters can be used.

Old text info input

if non-blank, then only strings with matching text info will be selected.

New text input
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if non-blank, then any selected text the selected strings will be modified to this value. Wild cards and 
characters can be used.

New text info input

if non-blank, then the select text on the selected strings will be set the given text info.

Target type

data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

Convert button

run the option and change the selected text.
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Translate
translate

Position of option on menu: Utilities =>H-Z =>Translate

The translate option is used to translate through a user supplied translation vector (dx,dy,dz) any 
selected strings, or all the strings in a model or on a view.

The strings can be translated in the x,y and z directions and be moved or copied to their new 
translated positions.

The difference between a copy and a move is that if a string is copied, a copy of the string is 
translated and the original string left untouched, whereas for a move, the actual string is moved 
from its original position to the new translated position.

The translated strings can be left in their original models, or moved/copied to a new model.

On selecting Translate, the translate panel is displayed.

The translation (dx dy dx) can be typing into the dx dy dz field or by picking the dx dy dx button 
and then selecting two points with the cursor. When two points are selected, the difference 
vector of the two selected points is taken as the translation vector (dx,dy,dz). The (dx,dy,dz) 
value is piped into the dx dy dz field.

The fields and buttons used in the translate panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type Model

data selection type - for a full description go to “Data Source”  in the chapter “Tools and Concepts” 

Data source input

source of data is to be processed.

dx dy dz input

the translation vector (dx,dy,dz). This vector is added to all points in the strings.

Target type
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data target type - for a full description go to “Data Target”  in the chapter “Tools and Concepts” 

Target info input

extra information required for the target.

dx dy dx button

after selecting dx dy dx, two points are selected by the uses and the difference between the points is 
placed in the dx dy dz field.

Translate button

translate the selected strings and add them to the model given in the new model field.

How to Use the Panel

(a) Enter the Data source for the strings are to translated.

(b) Define the translation vector (dx dy dz) by either typing the value into the dx dy dz field or 
by selecting the dx dy dz button and picking two points to define the translation vector. The 
resulting (dx dy dz) values are piped into the dx dy dz field.

(c) Select the target mode.

(d) Selecting the Translate button then does the required translations (moves or copies).
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Test Wildcards
pattern_regular_expression_tester

Position of option on menu: Utilities =>H-Z =>Test wildcards

The test wildcards option is used to test the effect of pattern expressions and regular expressions 
on text.

On selecting the Test wildcards option, the Pattern/Regular Expression Tester panel is displayed.

The Search/Replace criteria and the Pattern expression or Regular expression is applied to the 
data in the Input column and the results are placed in the Output column.
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27  User

User Defined Menus
The User walk-right menu is

To help customise 12d Model, there is a pull down menu User on the Main menu and User menus 
on many of the pull down menus on the Main menu. All the User menus are totally defined from 
the files Usermenu.4d, created by the user, and Xtramenu.4d, supplied by 12D Solutions.

The User menus can run 12d Model macros, external programs, and bring up 12d Model screen 
layout files, panels and menus.

The User menus can have their own walk-right menus, with walk-rights menus etc. and so can be 
used to build sophisticated tailored additions to 12d Model. Each of the user defined menus are 
floating (tear away) menus.

The User menus are divided in two with any menu options supplied by the user (in Usermenu.4d) 
on the top with the 12D Solutions options (in Xtramenu.4d) underneath.

All the options under User and User menus are either customers own macros or unsupported 
macros from 12D Solutions which may not be documented.

create floating User menu
miscellaneous macros
beta macros
console macros
polygon macros

on Main menu on 12d Model
User floating me
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The default name for the user definition file for User is

usermenu.4d

which is searched for in the standard set up areas (local, USER_4D, user, set_ups etc.) or set by 
the environment variable

USER_OPTIONS_4D file // Customers User menu definition

The format for the user defined menu is given in the Appendix, Function Keys, Menus.

The default name for the 12D Solutions definition file which includes some macro for User is

xtramenu.4d

which is also searched for in the standard set up areas (local, USER_4D, user, set_ups etc.) or set 
by the environment variable

EXTRA_OPTIONS_4D file // 12D Solutions User menu definitions

The format for the user defined menu is also given in the Appendix, Function Keys, Menus.

Important Note

The file xtramenu.4d is for use by 12D Solutions only. Please do not modify it because it may be 
over written in future updates. The file usermenu.4d is for Customer use.

For quick reference, most of the unsupported macros provided by 12D Solutions on any of the 
User menus are on the menu User =>Miscellaneous on the main menu.

All the options under User and User menus are either customers own macros or unsupported 
macros from 12D Solutions which may not be documented.
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User
user

All the options under User and User menus are either customers own macros or unsupported 
macros from 12D Solutions which may not be documented. For more information on User 
menus, go to “User Defined Menus” 

The User walk-right menu is

For Miscellaneous, go to the section “Miscellaneous” 
Beta “Beta” 
Console “Console”  
Polygon  “Polygon” 

create floating User menu
miscellaneous macros
beta macros
console macros
polygon macros

on Main menu on 12d Model
User floating me
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Miscellaneous
miscellaneous

a_to_c

d_to_k

l_to_q

r_to_z

All the options under User and User menus are either customers own macros or unsupported 
macros from 12D Solutions which may not be documented. For more information on User 
menus, go to “User Defined Menus” 

The walk rights User =>Miscellaneous menu is:

and the walk rights on the Miscellaneous menus are:
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For Attribute Editor, go to the section 
Chainage/offset label inquire  
Change names of strings “XXX New Name” 
Contour levels “Set Heights for 2d (contour) Strings” 
Create buildings for TINS “XXX Create Building for a Tin” 
Create points for circle centres “Create Points for Centre of Circles” 
Create control stations “XXX Create Control Stations” 
Create 2 point - 2D strings “XXX Create 2d String from Two Points” 
Create 3 point - 2D strings (name from label) “XXX Create 3 Point 2d Strings” 
Draw cross at IPs “Create Crosses at String Points”  in the chapter 

“Drafting” 
Drop bubbles “XXX Drop Bubbles” 
Drop points onto centreline “XXX Drop Points onto Alignment” 
Drop Z values of points onto centre lines “XXX Drop z-value onto Centreline” 
Extrapolate “Extrapolate Point” 
Extend pipe “XXX Create VicRoad Pipe” 
Fencing models “XXX Fencing Models” 
Get length in 3d “Length in 3d” 
Head to tail closest points “XXX Head to Tail Closest Points” 
Label alignment this is a console macro
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Label alignment radius/ip (rail) “XXX Label Alignment Radius” 
Label curve this is a console macro
Label curve radii this is a console macro
Label sewer plan “XXX Label Sewer Plan (old)” 
Label strings with name “XXX Name Strings by Nearby Text” 
Model to name “XXX Name Strings by Model Name” 
Name strings using text strings “XXX Name Section Strings by Picking Text” 
Overlay Optomiser “XXX Pavement Overlay Optomiser” 
Polygon from 2 string names “Polygons from Sections” in the chapter “Design” 
Quarter points bubbles and table “Setout Lip Line” in the chapter “Survey” 
Read EEBY sections
Read USGS DEM data “XXX Read USGS DEM Data” 
Remove null VIPs “Remove Null VIP Points” 
Remove tinability “XXX Remove Tinability” 
Restore fenced model “XXX Restore Fenced Model” 
Restore model list “Models Save/Restore” in the chapter “Views” 
Scale text values “XXX Scale Text Values” 
Scale string names “XXX Scale String Names” 
Set string names by number “XXX Set String Names by Number” 
Set string properties “XXX String Operations” 
Set contour levels from contour names “Set Contour Levels from String Names” 
Set contour names from contour levels “Set Contour Names From Contour 

Levels” 
Sort xyzs data file “XXX Sort XYZs Data File” 
String attributes properties to-from clipboard “XXX String Attributes To-From Clipboard” 
Sum length of all strings model/view “Polygon” 
Super string dimension occurrences “XXX Super String Dimension Occurrences” 
Super string to V3.2 strings “XXX Transform V4 to V3.2” 
Translate string in section view “XXX Section Move” 
Text (elev) to 3d point “Text to 3d” in the chapter “Utilities” 
Tin elev differences to points “Z Differences from Tins” in the chapter “Triangles” 
XYZ chainage
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XXX New Name
newname_panel

Position of option on menu: User =>A to C =>Change name of strings

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source Model string, model, view

Model/View/String of circles
type of source of the data to process.

Model for centres model box available models
source of data to process.

Name stem input

Process button

Set Heights for 2d (contour) Strings
contour_levels_panel

Position of option on menu: User =>A to C =>Contour levels

Note - This is an unsupported option which may not be fully documented.

This panel is used to quickly change the height of contour strings. An initial height and 
increment is given. As each string is accepted, it is given the height and the height then 
incremented.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Height input
Height to use for the next selected string. This is incremented by the “Height increment” after each 
string is accepted.

Height increment input
As each string is accepted, the “Height” value is incremented by this value.

New colour input available colours
If non-blank, the selected strings are given this colour when their z-value is changed.

Pick input
After clicking on Pick, 2d strings are selected and when accepted, have their z-value changed to the 
value in the Height field. The height value is then automatically incremented. The next string is then 
selected and accepted (without needing to click on Pick again). This continues until Cancel is selected 
from the “Pick Ops” menu.

Undo button
Undo the last height change. This can be selected up to 200 times.

XXX Create Building for a Tin
buildings_panel

Position of option on menu: User =>A to C =>Create buildings for tin

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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Create Points for Centre of Circles
circles_centres_panel

Position of option on menu: User =>A to C =>Convert circles to points

Note - This is an unsupported option which may not be fully documented.

This options creates points at the centres of circles.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source Model string, model, view

Model/View/string of circles
source of the circles to create centre points for.

Model for centres model box available models
model to place the created centre points in.

Run button
run the option.

XXX Create Control Stations
buildings_panel

Position of option on menu: User =>A to C =>Create control stations

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:
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Field Description Type Defaults Pop-Up

XXX Create 2d String from Two Points
rivers_shape_string_create_panel

Position of option on menu: User =>A to C =>Create 2 point - 2d strings

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Create 3 Point 2d Strings
rivers_source_string_create_panel

Position of option on menu: User =>A to C =>Create 3 point - 2d strings

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Drop Bubbles
drop_bubble_panel

Position of option on menu: User =>D to K =>Drop bubbles

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source model
xxxxx

Model name
xxxxx

Select centreline
xxxxx

Model for chainages
xxxxx

Size
xxxxx

Text unit pixels
xxxxx

Colour
xxxxx

Angle
xxxxx

Justification bottom-left
xxxxx
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Report file
xxxxx

Process
xxxxx

XXX Drop Points onto Alignment
drop_points_panel

Position of option on menu: User =>D to K =>Drop points onto alignment

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Pick Centreline
xxxxx

Data source model
xxxxx

Model of strings
xxxxx

Model for text
xxxxx

Size
xxxxx

Angle
xxxxx
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Colour
xxxxx

Tin 1 for levels
xxxxx

Tin 2 for levels
xxxxx

Report file
xxxxx

Process button
xxxxx

Undo button
xxxxx

XXX Drop z-value onto Centreline
drop_zvalue_onto_centreline_panel

Position of option on menu: User =>D to K =>Drop points on centreline

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source model
xxxxx

Model name
xxxxx

Select centreline
xxxxx

Drop info file
xxxxx

Process button
xxxxx
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Extrapolate Point
extrapolate_panel

Position of option on menu: User =>D to K =>Extrapolate

Note - This is an unsupported option which may not be fully documented.

This option is used to select two point and then creates a new point a given distance from the 
second point along the line from the first point to the second point. The z-value for the point is 
the extrapolated z-value from the two selected points.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Select first point string select
select the first point to use in the extrapolation.

and second point string select
select the second point to use in the extrapolation.

Distance output box
distance to project from the second point along the line from the first to the second point.

Process button
run the option.

Undo button
undo the last extrapolated point created since the panel has been up.

XXX Create VicRoad Pipe
vicpipe_panel

Position of option on menu: User =>D to K =>Extend pipe

Note - This is an unsupported option which may not be fully documented.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Fencing Models
mod_fence_panel

Position of option on menu: User =>D to K =>Fencing models

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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Length in 3d
length_3d_panel

Position of option on menu: User =>D to K =>Get length in 3d

Note - This is an unsupported option which may not be fully documented.

This panel is used to calculate the 3d length of a selected string.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Pick button
select the string to calculated the 3d length for.

XXX Head to Tail Closest Points
head_to_tail_closest_panel

Position of option on menu: User =>D to K =>Head to tail closest points

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Label Alignment
Position of option on menu: User =>L to Q =>Label alignment

Note - This is an unsupported option which may not be fully documented.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Label Alignment Radius
rail_align_panel

Position of option on menu: User =>L to Q =>Label alignment radius/ip (rail)

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Label Sewer Plan (old)
sewer_plan_panel

Position of option on menu: User =>L to Q =>Label sewer plan

Note - This is an unsupported option which may not be fully documented.

This option has been superseded.
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XXX Name Strings by Nearby Text
label_string_by_name_panel

Position of option on menu: User =>L to Q =>Label strings with name

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Name Strings by Model Name
model_to_name_panel

Position of option on menu: User =>L to Q =>Model to name

Note - This is an unsupported option which may not be fully documented.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Name Section Strings by Picking Text
string_names_from_strings_panel

Position of option on menu: User =>L to Q =>Name strings using text strings

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Pavement Overlay Optomiser
Position of option on menu: User =>L to Q =>Overlay optimiser

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:
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Field Description Type Defaults Pop-Up

XXX Read USGS DEM Data
rivers_dem_reader_panel

Position of option on menu: User =>R to Z =>Read USGS DEM data

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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Remove Null VIP Points
remove_null_vips_panel

Position of option on menu: User =>R to Z =>Remove null VIP’s

Note - This is an unsupported option which may not be fully documented.

This option is used to remove any null vertical intersection points from alignment strings.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source data source Model String, Model, View
Type of data to remove null vips for.

Model/View/String data source
Data source for all the alignment strings to remove all null vips from.

Process button
Run the option.

XXX Remove Tinability
super_remove_tinability_panel

Position of option on menu: User =>R to Z =>Remove tinability

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Restore Fenced Model
mod_res_panel
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Position of option on menu: User =>R to Z =>Restore fenced model

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Scale Text Values
text_convert_panel

Position of option on menu: User =>R to Z=>Scale text values

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Text model input box labels
xxxxx

Scale factor input box 1000
xxxxx

Decimals input box 3
xxxxx

Process button
xxxxx

XXX Scale String Names
string_name_convert_panel

Position of option on menu: User =>R to Z=>Scale string names

Note - This is an unsupported option which may not be fully documented.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

XXX Set String Names by Number
string_name_by_number_panel

Position of option on menu: User =>R to Z=>Set string names by number

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX String Operations
string_ops_panel

Position of option on menu: User =>R to Z=>Set string properties

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

new name input box
xxxxx

new model input box
xxxxx

new colour input box
xxxxx

new-point-line input box ignore
xxxxx

new style input box
xxxxx

window button
xxxxx

select button
xxxxx

group button
xxxxx

delete button
xxxxx

window button
xxxxx
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Set Contour Levels from String Names
level_from_name_panel

Position of option on menu: User =>R to Z=>Set contour level from contour name

Note - This is an unsupported option which may not be fully documented.

This operates on contour strings and sets the contour z-value to be the value of the name of the 
contour string. The z-values may need to be factored to bring them into the correct units.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source data source Model Model, View
Type of data to set contour z-values for.

Model/View data source
Data source to of contours to set z-values for.

Process button
Run the option

Undo button
Undo the last set of contours labelled since the panel was up.
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Set Contour Names From Contour Levels
name_contour_panel

Position of option on menu: User =>R to Z=>Set contour names from contour levels

Note - This is an unsupported option which may not be fully documented.

This option operates on contours only and sets the string name to be the contour z value 
multiplied by the given factor.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source data source Model String, Model, View
Type of data to label contours strings for.

Model/View/String data source
Data source to calculate label the contours for.

Z factor input 1
Value to multiply the z values by before creating the string name.

No of decimals input 3
Number of decimals places to use in the string name.

Process button
Run the option.
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XXX Sort XYZs Data File
xyzs_sort_panel

Position of option on menu: User =>R to Z=>Sort xyz data file

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Xyzs data file input box
xxxxx

Sort button
xxxxx

XXX String Attributes To-From Clipboard
string_to_panel

Position of option on menu: User =>R to Z =>String attributes to-from clipboard

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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Total Length of Strings
totallengths_panel

Position of option on menu: User =>R to Z=>Sum length of all strings

Note - This is an unsupported option which may not be fully documented.

This panel is used to calculate the total length of the strings in a selected model or view.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source model, view, string
data source type

Data source
data source to calculate lengths for.

Length in 2d/3d radio button 2d
if 2d, the lengths are only calculated in 2d.
If 3d, the lengths are calculated in 3d.

Ignore null length string(s) tick box tick
if tick, strings of null length are ignored in the string count and hence don’t affect the average length.

Process button
run the option
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XXX Super String Dimension Occurrences
super_remove_radius_panel

Position of option on menu: User =>R to Z=>Super string dimension occurrences

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

data to check input box
xxxxx

model to check input box
xxxxx

count button
xxxxx
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XXX Transform V4 to V3.2
super_to_v32_panel

Position of option on menu: User =>R to Z=>Super string to V3.2 strings

Note - This is an unsupported option which may not be fully documented.

This panel convert a super string from 12d Model V4.0 format to V3.2 strings.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data to transform input box model
xxxxx

Model to transform input box
xxxxx

Replace data tick box tick
xxxxx

Tinable prefix input box tinable
xxxxx

Non tinable prefix input box non tinable
xxxxx

Transform button
xxxxx
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XXX Section Move
section_move_panel

Position of option on menu: User =>R to Z=>Translate string in section view

Note - This is an unsupported option which may not be fully documented.

This panel is used to translate a string on a section view.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

section view input box 2
xxxxx

chainage shift tick box tick
xxxxx

z shift tick box
xxxxx

select string button
xxxxx

process button
xxxxx

XXX Output XYZ and Chainage
xyz_chainage_output_panel

Position of option on menu: User =>R to Z=>XYZ chainage

Note - This is an unsupported option which may not be fully documented.
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The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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Beta
beta

All the options under User and User menus are either customers own macros or unsupported 
macros from 12D Solutions which may not be documented. For more information on User 
menus, go to “User Defined Menus” 

The walk rights Beta menu is:

For Alignment labels, go to the section “XXX Alignment Labels” 
Alignment label table “XXX Table of Alignment Labels” 
Catchment definer “XXX Catchment Definer” 
Check duplicate point numbers “XXX Check Duplicate Point Numbers” 
Create culverts “XXX Create Culvert” 
Liquid measure “XXX Liquid Measure” 
Make cuts “XXX Make Cuts Through Strings” 
Plot symbol/title block “XXX Plot Symbol and Title Block Creation (old)” 
Read SDRMap feature codes “XXX Read SDRMap Feature Code” 
Read SDRMap symbols “XXX Read SDRMap Symbols” 
Reformat CivilCAD Ascii 5 file “XXX Reformat CivilCAD Ascii 5 file” 
Remove super string tinability “XXX Remove Super String Tinability” 
Triangulate by selection set “XXX Triangulate by Selection Set” 
Update z values from points “XXX Update Z Values from Points” 
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XXX Alignment Labels
align_label_panel

Position of option on menu: User =>Beta =>Alignment labels

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Table of Alignment Labels
Align_label_table_panel

Position of option on menu: User =>Beta =>Alignment label table

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Catchment Definer
Catchment_areas_panel

Position of option on menu: User =>Beta =>Catchment definer

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Check Duplicate Point Numbers
Dup_pt_nos_panel

Position of option on menu: User =>Beta =>Check duplicate point numbers

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Create Culvert
3d_culvert_panel

Position of option on menu: User =>Beta =>Create culvert

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Liquid Measure
liquid_meas_panel

Position of option on menu: User =>Beta =>Liquid measure

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Make Cuts Through Strings
Make_Cuts_panel

Position of option on menu: User =>Beta =>Make cuts

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Plot Symbol and Title Block Creation (old)
psym_drawbox_panel

Position of option on menu: User =>Beta =>Plot symbol/title block creation

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Read SDRMap Feature Code
SDRMap_Read_Feature_Codes_panel

Position of option on menu: User =>Beta =>Read SDRMap feature codes

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up



Chapter 27  User

January 2005 Page 2799Beta

XXX Read SDRMap Symbols
SDRMap_Read_Symbols_panel

Position of option on menu: User =>Beta =>Read SDRMap symbols

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Reformat CivilCAD Ascii 5 file
reformat_as5_panel

Position of option on menu: User =>Beta =>Reformat CivilCAD Ascii 5 file

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Remove Super String Tinability
super_remove_tinability_panel

Position of option on menu: User =>Beta =>Remove super string tinability

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Triangulate by Selection Set
tri_drawbox_panel

Position of option on menu: User =>Beta =>Triangulation by selection set

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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XXX Update Z Values from Points
Update_z_value_from_point_panel

Position of option on menu: User =>Beta =>Update z value from points

Note - This is an unsupported option which may not be fully documented.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up
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Console
console

All the options under User and User menus are either customers own macros or unsupported 
macros from 12D Solutions which may not be documented. For more information on User 
menus, go to “User Defined Menus” 

All the macros on the Console menu only use the console panel and so do not support a F1 key 
for help.

The User =>Console rights menu is:
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Polygon
The Polygon walk-right menu is

and each option in this menu will now be discussed.

For the option Create polygon by picking point inside area, go to the section “Surrounding Polygon”  
in the chapter “Strings” 
For the option Create polygon by picking sides, go to the section “Create Polygon by Picking Sides” 

Colour polygons from range file “Colour Polygons by Range File” 
Remove polygon colour “Remove Polygon Colour”  
Road polygons  “Road Polygons” in the chapter “Design” 

create polygon by picking point inside
create polygon by picking sides
colour polygon by range file
remove polygon colour
road polygons



12d Model Reference Manual

Page 2806 January 2005Polygon

Create Polygon by Picking Sides
polygon_creation_pick_panel

Position of option on menu: User =>Polygon =>Create polygon by picking sides

This option creates a polygon by a picking each segment in its order (and with direction) around 
the polygon. Segments will be automatically extended or clipped to form the polygon.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Model for polygon model box available models
model for the created polygon

Lot colour colour box available colours
colour for the created polygon

Join first and last segment tick box
if tick, join the end of the last selected segment to the start of the first selected segment to form the final 

Select each segment (with direction)
in the order that they are to form
the segments of the polygon.

Created polygon

Creating a Polygon by Picking String Segments

1

2

3

4

5

6

7

The segments will be automatically
extended/clipped.
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side of the polygon. The segments may be automatically trimmed/extended.

Pick sides string select
pick, with direction, the segments to be joined together to form the sides of the polygon.

Process button
create the polygon from the selected segments.
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Colour Polygons by Range File
colour_polygon_by_range_file_panel

Position of option on menu: User =>Polygon =>Colour polygons by range file

This option creates a polygon by a picking each segment in its order (and with direction) around 
the polygon. Segments will be automatically extended or clipped to form the polygon.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Range file file box *.lrf
range file for colouring polygons.

Data source type model model, view

data source type.

Data source

data source for polygons to be coloured.

Table location position select box
position of the table.

Model for table model box available models
model for the table of statistics on the polygon areas.

Text colour colour box available colours
colour of the text.

Text size (w) double box
size of the text for the table.

Process button
select all the polygons given by the Data source and colour them according to the lot range file.
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Remove Polygon Colour
remove_polygon_colour_panel

Position of option on menu: Design =>Estate/Lots =>Lot utilities =>Remove polygon colour

Note - This is an unsupported option which may not be fully documented.

This option removes the colour of all the selected polygons.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data source type model model, view

data source type.

Data source

data source for polygons to have their colour removed.

Process button
select all the polygons given by the Data source and remove the polygon colour.
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Undocumented User Menus
user_model_utilites user_models user_strings_create user_create_circles user_create_arcs 
user_points_edit user_strings_edit user_string_labelling

user_strings user_tin_create user_tin_colouring user_tin_inquire user_tin_null user_tin_utilities 
user_triangles user_survey

user_templates_utilities user_templates user_design_functions user_template_boxing user_mtf 
user_end_area_volumes user_exact_volumes user_volumes

user_roads user_plots user_reports user_fence user_functions user_macros user_measure 
user_recalc

user_utilities_a-g user_utilities_h-z user_utilities 

user_projects

user_data_input

user_file_i_o

The options on a User menu are either customer’s macros or unsupported macros from 
12D Solutions and may not be documented.
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28  Window

Window
window

The 12d Model window menu contains options to cascade, tile horizontally and vertically.

The Output window can also be toggled on and off.

The Window on main menu and walk-right menus are

cascade the non-minimized views
horizontally tile the non-minimized views
vertically tile the non-minimized views
place all minimized view icons at the bottom of the views area

toggle the output window on/off

list of existing views

on Main menu
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29  Help
help

Position of menu: It is on the main menu as Help

From 12d Model V5.0 onwards, the two-volume paper Reference Manual has been replaced by 
electronic help accessed from within 12d Model.

The entire 12d Model Help manual can be accessed by selecting 12d Model on the Help menu item 
on the main 12d Model menu.

Alternatively, individual topics for a panel or menu can be invoked by pressing the F1 key 
whenever the focus is on the menu or panel, or by clicking on the Help button on any 12d Model 
panel.

The 12d Model help menu contains options to access Microsoft’s Help on Microsoft’s Help, the 
12d Model Help and the 12d Model Macro Programming Language Help, plus links to the 
12D Solutions web site www.12d.com.

The help on main menu and walk-right menus are

For the option On help, go to the section “On Help” .
12d Model “12d Model Contents” .
12d Macro manual “12d Model Macro Manual” .
12d on the web “12d on the Web” .
About 12d Model “About 12d Model” .
Email info to 12d “Email Info to 12d” .

More information on the Help system will now be given.

create floating Help menu
help on Microsoft’s help system
contents of 12d Model help
help on 12d macro programming language

links to www.12d.com
donlge number, 12d Model modules
email information about 12d Model to 12D Solutions
dongle testing panel

on Main menu  floating Help menu
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On Help
Position of option on menu: Help =>On help

Help on Microsoft’s Help system.

Please continue to the next section “12d Model Contents” .
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12d Model Contents
Position of option on menu: Help =>12d Model

The 12d Model option allows you to look at the overall structure of the 12d Model Help and 
access any part of it.

Warning - only topics in the Help can be accessed through the Contents list so any folders in the 
Content folders must be expanded until topics are displayed. Topics can be easily identified 
because they have a question mark beside them indicating that Help is available.

For example, double clicking on ’Tools and Concepts’ expands the next level of ’Tools and Contents’.
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Double clicking on the topic ’Picking Strings’ will then display the topic in the Help.

The Contents then disappear leaving Help open at the selected topic.
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Double clicking on ’Contents’ on the top of the Help will bring the Contents listing back up.

For information on the Index tab, please continue to the next section “Index” .

For information on the Find tab, please continue to the next section “Find” .

For information on the Help button on a panel, please continue to the section “Panel Help 
Button” .

Index
The Index option searches through all entries in the Index of the Help.

As the first few characters of the required entry are typed in, the matching index entries are 
displayed.

Double clicking on the displayed entries will go to the topic in the Help containing the selected 
index entry. If more than one topic includes the index entry, then the list of topics is displayed.

If the index has sub-indices, they can be searched by first typing in the main index followed by a 
comma, then a space and the first few characters of the sub-index.

For information on the Find tab, please continue to the next section “Find” .

Find
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The most powerful searching method for the Help system is Find. 

Simply click on the Find tab to search for words or phrases that may be contained in a Help topic.

If Find is being invoked for the first time, the ’Find Setup Wizard’ runs to create an index of every 
word in the Help.

From then on, selecting the Find tab goes straight to the Find screen.
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Please continue to the next section “Panel Help Button” .

Panel Help Button
Every panel has a Help button which when selected goes to the topic describing that panel.

Please continue to the next section “F1 Key” .

Help button to go
directly to the Help
topic for the panel.
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F1 Key
Another method of invoking Help is by using the F1 key as follows: 

when a menu or panel is on the screen and has focus (the menu or panel title area will be 
highlighted), pressing F1 will bring up the help for that menu or panel.

Warning - some of the items on the Strings menu automatically start up a string select and 
change the focus from the panel to a View. This means that pressing F1 will bring up the Help for 
the View and not the Help for the panel. 

To get Help for such a panel, click on the panel to bring the focus back to the panel before 
pressing F1. The top of the panel will highlight showing that it has focus.

Please continue to the next section “Navigating in Help” .

Navigating in Help
Once at a topic in the Help, the <<  and  >> buttons at the top of the Help topic will go to the 
previous and next Help topics respectively. 

Individual Help topics can be printed by clicking Print at the top of the Help page.

go back one topic go to next topicprint the
current topic



Chapter 29  Help

April 2007 Page 282112d Model Contents

Because it is difficult to print large sections in Microsoft’s Help system, a PDF file of the entire 
12d Model Reference Manual has been created and can be used to print out large sections of the 
manual.

The 12d Model Reference Manual PDF file is on the 12d Model Installation CD in the folder 
Documentation\Reference_Manual.
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12d Model Macro Manual
Position of option on menu: Help =>12d Macro manual

12d Model includes a powerful programming language (macro language 4DML).
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About 12d Model
12d_model_information

Position of option on menu: Help =>About 12d Model

The About 12d Model option displays information about the current authorization 12d Model 
such as the Client name, dongle number and authorized modules.

On selecting the About 12d Model option, the 12d Model Information panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Client

name of the authorized client.
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Dongle

number of the dongle.

Version

12d Model version number.

Days remaining

number of days left for the authorisation.

Module information

Base module

number of allowed points in the base module.

Alignment tick box

if tick, the Alignment design module is authorized.

...
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Email Info to 12d
email_information_on_12d_model_to_12d_solutions

Position of option on menu: Help =>Email info to 12d

The Email info to 12d option emails information about the current version of 12d Model to 12d 
Solutions Pty Ltd. This is usually used for debugging authorization problems.

On selecting the Email info to 12d option, the 12d Model Information panel is displayed.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

First name/Last name/Company name ....

information about the user and the Company owning the license of 12d Model.

Email button

try to send an email containing information about 12d Model and the user to 12d Solutions Pty Ltd.

Save button

if the Email button does not send an email, the Save button can be used to write the information out to 
a file called 12d_auth.txt. This file can then be emailed to support@12d.com.
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12d on the Web
web_help

Position of menu: Help =>12d on the web

The 12d on the web walk-right menu contains links to the 12DSolutions web site www.12d.com.

link to “www.12d.com/model”
link to 12d Model foruml
link to FAQs
support contacts

sales contacts
on-line bugs and enhancement form
send email to 12D Solutions
link to Google

12D Solutions home page
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30  Save and Exit
save_project_reminder

Save and Exit are available from both the Main Menu under Project or on the floating 12d Model 
menu.

Save and Exit from Main Menu
Selecting Save from the Main Menu=>Projects menu simply saves all data in the project modified 
since the last save.

When Exit is selected from the bottom of the Main Menu=>Projects menu and a save is not 
needed, 12d Model exits the project.

If Exit is selected from the bottom of the Main Menu=>Projects menu and a save is needed, then 
the Save Project ? yes-no panel is placed on the screen.
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If Yes is selected, then 12d Model saves the project and exits.

If No is selected, then 12d Model does not save the project and exits.

If Cancel is selected, then the Exit is aborted and 12d Model stays in the project.

Note: when exiting 12d Model, the user is reminded if any mtf files modified by the 12d Model 
mtf editor have not been saved, or any string editors are still running.

Save and Exit from 12d Model Menu
exit_12d_model

When Save is selected from the left hand side of the bottom of the 12d Model menu (Save / Exit 
menu option), all the information modified since the last save is written to disk.

When Exit is selected from the right hand side of the bottom of the 12d Model menu (Save / Exit 
menu option), an Exit12d Model panel is fired up.

Selecting No removes the yes-no pop-up and leaves the user in 12d Model.

If Yes is selected and a modification to the project has been made since the last project save, a 
Save Project panel is fired up.

If yes is selected, the project is saved and 12d Model terminates.

If no is selected, the project is not saved and 12d Model terminates.

If cancel is selected, the exit option is aborted and the user is left in 12d Model.

Note: When exiting 12d Model, the user is reminded if any mtf files modified by the 12d Model 
mtf editor have not been saved, or any string editors are still running.
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31  Advanced Design
mtf_edit

12d Model uses templates as a quick and easy method for defining design details along a string.

The apply options are used to create strings and sections using the reference string to define the 
chainage and what is perpendicular at each chainage, and a hinge string from where the 
template links are defined. The template defines a point name and colour for each template link.

Cross sections can be created with point names corresponding to the template links, and strings 
formed by joining the same named points from consecutive cross sections.

For simple work, the Design=>Apply=> Apply option cuts a left and right template into a surface 
to produce a design.

For more complex work, the Design=>Apply=> Apply many option allows more detailed control 
over the design process. In fact, it is actually string design and it is not necessary to have any 
templates at all for apply many.

The apply many option uses a file (the many templates file or mtf) to describe

(a) which templates are applied to the left and right side of the hinge string (with linear 
interpolation between templates and gaps allowed)

(b) special chainages for creating extra cross sections

(c)  hinge modifiers for adjusting the hinge string

(d)  template modifiers for extra adjustment of the points created by the templates

(e)  stripping depths

(f)  boxing

(g) width to define the limit of searches for strings

(h) modify the z-values of strings

The mtf can be created and edited interactively from within 12d Model or it can be created and 
edited from a text editor such as PFE, or any combination of the two methods.

A simple method for creating and/or editing an mtf is from the apply many option itself. 

Once the apply many option has been selected and the Apply Templates Function panel is on the 
screen, simply enter the name of the mtf file into the templates file field of the Apply Templates 
Function panel, click on [+] to bring up the pop-up menu and select [Edit] from the pop-up.

If the mtf file does not exist, then the Create MTF File panel (with the mtf file name already filled 
in) is placed on the screen and the user simply selects the Create button. 

Alternatively, an mtf can be created inside 12d Model using the Create MTF File panel and edited 

reference string

hinge string

direction to apply template along 
(perpendicular to the reference string)

hinge point - the point to apply 
the template from
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using the MTF Edit menu.

Finally, a text editor such as PFE can be used to create and/or edit an mtf.

When interactively creating the mtf, the mtf edit menu contains all the options for (a) to (h). For 
example, the MTF Edit menu for the mtf file "Road1.mtf" is:

The documentation order will be the same as the order on the above MTF Edit menu.

 The interactive commands for each of (a) to (h) will be described in the following sections.

The format of the text version of the MTF file is given in the section “Text Version of the MTF” . 
Unlike the interactive commands, the text form of the MTF file allows substitutions (see the 
section “Substitutions in the Many Templates File” ).

For documentation on the option/menus on the MTF Edit menu:

for Templates, go to the section “Templates” 

Specials “Specials” 
Hinge  “Hinge Modifiers” 
Modifiers  “Template Modifiers” 
Stripping “Stripping” 
Boxing “Boxing” 
Width  “Width” 
Strings  “String Modifiers” 
Shift  “Shift” 

Following the documentation of the MTF editor, the full definition of boxing is given in the 
section “Full Definition of Boxing”  and the full definition of the Decisions button on Template 
Create/Edit panel is given in the section “Full Definition of Template Decisions” 

Please continue to the next section “Templates” .

name of the mtf
(a) templates to apply left and right
(b) special chainages
(c) hinge modifiers
(d) template modifiers
(e) stripping depths
(f) boxing
(g) width for limiting searches
(h) modify the z-values of a string
save the mtf to a file
recalc the apply many for the mtf
modify all the chainages by a delta amount
quit without saving
save and finish
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Templates
mtf_edit_templates

The templates walk-right brings up the templates menu with options to create the left_side and 
right_side sections of the mtf file.

mtf_edit_templates

Selecting the left side or right side option brings up the left side templates or left side templates 
panels respectively.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Chainage column header sort by chainage
for the field - measure

list of chainages for applying templates on the left/right hand side of the hinge string.

Template 1 column header
for the field - available templates

template to start applying at the chainage on the same row. If template 2 is blank, then template 1 is 
applied until the next chainage in the chainage column.

Template 2 column header
for the field - available templates
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template to linearly interpolate to and finish with at the next chainage in the chainage column.
In the file, the two templates will be separated by a comma.

Note - template 2 must have the same number of fixed and variable links as template 1 otherwise a gap 
of the section separation length will be left between the end of template 1 and the start of template 2.

Comment column header

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Specials” .
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Specials
mtf_edit_special_chainages

The apply many option automatically creates sections at a number of chainages including the 
supplied chainage interval, horizontal critical points and template change points.

However it is also possible to add extra sections at special chainages using the specials keyword 
in the many template file or the specials option from the mtf edit menu.

Walking right on the specials menu brings up the special chainages walk-right menu:

mtf_edit_special_chainage_values

Selecting the values option brings up the special chainage values panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Special chainages column header sort by chainage
for the fields - measure

list of special chainages for creating sections at.

Comment column header

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button
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OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_special_chainage_files

Selecting the files option brings up the special chainage files panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Special chainage files column header size menu
for the fields -*.spc files

list of files of special chainages for creating sections at.

Comment column header

comment to add to the end of the line. In the file, the comment will be preceded by //.

Wild card input *.spc

the wild card used for pop-ups in the special chainage files fields.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Hinge Modifiers” .
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Hinge Modifiers
mtf_edit_hinge_modifiers

The hinge string is selected using the hinge panel field in either the apply template function or 
apply templates function panels.

Hinge modifiers are used to modify the position of the point on the hinge string that the 
template is applied to (the hinge point).

Selecting Hinge from the MTF Edit menu brings up the Hinge Modifiers panel.

 The Hinge Modifiers panel consists of a scrolling command fields and an OK or Apply button to 
record the results.

The width of the command area in the Hinge Modifiers panel is controlled by the environment 
variable DEFAULT_TABLE_WIDTH_4D.

The commands in the hinge modifier field can be offset, height, offset to string, heights to 
string, coord to string, no hinge and comment.

mtf_edit_hinge_create

reference string

 

direction to apply template along 
(perpendicular to the reference string)

hinge point - the point to apply 
the template from

hinge string
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If the command line is empty, clicking LB in the command line will bring up the Create menu which 
contains all the available hinge commands.

Selecting a menu item will bring up an associated panel which displays the information required 
for the hinge command.

When the panel is filled in and OK or Apply selected, the panel information is written out to the 
command line in the correct format for that hinge command.

If the command line is not empty, clicking LB in the command line will bring up the associated 
panel for the hinge command in the command line.

The information in the panel can be modified and if OK or Apply is selected, the modified panel 
information is written out to the command line in the correct format for that hinge command.

Each of the panels created by selecting the command from the Create menu, will now be 
described.

The typed form of the command will be given in the section “Hinge Modifier File Format”  and 
an example is given in the section “A Hinge Modifier Example” 

For documentation on the option on the Hinge modifier Create menus:

for  Offset, go to the section “Offset” 

Height “Height” 
 Offset to string “Offset to String” 
 Height to string  “Height to String” 
 Coord to sting “Coord to String” 
 No hinge “No Hinge” 
Comment  “Comment” 

mtf_edit_hinge_hinge_offset

Offset
The offset modifier will move the hinge point a given offset distance (perpendicular to the 
reference string) from its current plan position. A positive offset is to the right of the hinge string 
and a negative offset to the left.
.

Selecting the offset option brings up the hinge offset panel

adjust offset of hinge string
 " height " " "

use offset to a string
use height from a string
take coords from a string
stop the apply
comment

reference string

hinge string

direction to apply template along 
(perpendicular to the reference string)

original point to apply 
template from (hinge

offset moves the hinge point along 
the line perpendicular to the 
reference string



Chapter 31  Advanced Design

May 2007 Page 2839Hinge Modifiers

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Start/End chainage input measures menu

start/end chainages for modifying the offset from the hinge string.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End offset input measures menu

start/end offset.

Extra start/end tick box tick

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Absolute tick box tick

if tick, the offset is set to the values given in the start and end value fields.
if not tick, the values given in the start and end value fields are added to the existing offsets.

Cubic tick box

if tick, the offset is varied as a reverse cubic between the start and end chainages.
if not tick, the offset is varied linearly between the start and end chainages.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_hinge_hinge_height

Height
The height modifier varies the height of the hinge point between the given chainages.

Selecting the height option brings up the hinge height panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Start/End chainage input measures menu

start/end chainages for modifying the height of the hinge string.

Start/End height input measures menu

start/end height.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box tick

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Absolute tick box tick

if tick, the height is set to the values given in the start and end value fields.
if not tick, the values given in the start and end value fields are added to the existing heights.

Cubic tick box

if tick, the height is varied as a reverse cubic between the start and end chainages.
if not tick, the height is varied linearly between the start and end chainages.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_hinge_hinge_offset_to_string

Offset to String
Selecting the offset to string option brings up the hinge offset to string panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Start/End chainage input measures menu

if non blank, start/end chainages for modifying the offset of the hinge string.
If blank, the modifier is applied for the length of the selected string.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

String string-select

select string to use for defining offset from hinge.

Extra start/end tick box tick

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_hinge_hinge_height_to_string

Height to String
The height of the hinge point can also be specified by taking the height from another 12d Model 
string.

Selecting the height to string option brings up the hinge height to string panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Start/End chainage input measures menu

if non blank, start/end chainages for modifying the height of the hinge string.
If blank, the modifier is applied for the length of the selected string.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

String string-select

select string to use for defining height of hinge.

Extra start/end tick box tick

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_hinge_hinge_coord_to_string

Coord to String
The coord modifier is used to replace the x, y and z position of the hinge point by the x, y and z 
position of another 12d Model string between given chainages. Hence coord replaces the hinge 
string by another string between the given chainages.

Selecting the Coord to string option brings up the hinge coord to string panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Start/End chainage input measures menu

if non blank, start/end chainages for modifying the coordinates of the hinge string.
If blank, the modifier is applied for the length of the selected string. 

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

String string-select

select string to use for defining the coordinates of the hinge string.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_hinge_no_hinge

No Hinge
The nohinge modifier is used to stop the hinge string (and hence the apply) between given 
chainages. This will leave a gap in the strings created by the apply between the given chainages.

Selecting the no hinge option brings up the no hinge panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Start/End chainage input measures menu

start/end chainages to stop the apply.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_hinge_hinge_comment

Comment
The comment option inserts a comment line.

Selecting the Comment option brings up the Hinge Comment panel

The fields and buttons used in this panel have the following functions.

Comment input

comment line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
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Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Template Modifiers” .
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Template Modifiers
The standard many templates file (mtf) is used to define what templates are used on either side 
of the hinge and defines where the templates stop and start, and allows for linearly interpolation 
between two templates over a chainage range. The information is given in the left_side and 
right_side blocks of information in the many templates file and/or the templates section of the 
mtf edit menu.

Template modifiers are used to modify the definitions in the left_side and right_side definitions 
and are given as left_side_modifier and right_side_modifier in the mtf file and/or the modifiers 
section of the mtf edit menu.

That is, for the left side say, the application of templates is first defined in the left_side command 
section and then modified by commands in the left_side_modifier section. In this case, the 
left_side set must be before the left_side_modifier in the many templates file.

However, the modifiers also include commands to insert and remove template links 
independently of whether a template has been used or not.

Hence the left side modifiers can be self contained without needing a left_side command. 

Similarly for the right side.

The template modifiers can be used to

insert a fixed, cut or fill link
remove a fixed, cut of fill link

and change the

width of a fixed link
height of a fixed link
xfall of a fixed link
width of a variable cut link
height of a variable cut link
slope of a variable cut link

width of a variable fill link
height of a variable fill link
slope of a variable fill link

width of the final link
cut slope of the final link
fill slope of the final link

Most of the modifiers have a common methodology:

(a) a link from a template (referenced by its name from the template definition) is created, 
removed or modified between a start and end chainage.

(b) values being modified are given for the start chainage and the end chainage. How the 
values are interpreted depends on other parameters for the command.

(c) more than one modifier may exist for a link at a given chainage and are applied in the order 
that they appear.

(d) if no modifier exists for a link at a given chainage, the link reverts back to the template 
definition given by left_side or right_side

Notes
1. When a fixed link is defined, it is given as two of the three variables width, height and xfall. 

Only the two variables used to define the link can be changed by template modifiers.
2. Similarly, when a variable cut or fill link is defined, it is given as two of the three variables 

width, height and slope. Only the two variables used to define the link can be changed by 
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template modifiers.

Please continue to the next section “Template Modifiers in MTF Edit” .

Template Modifiers in MTF Edit
mtf_edit_modifiers

The modifiers walk-right brings up the modifiers menu with options to modify the left_side and 
right_side sections of the mtf file.

The left side modifier option will be described in detail. The right side is exactly the same so will 
not be described.

Selecting left side from the mtf edit=>left side menu brings up the left side modifiers panel.

 The left side modifiers panel consists of a scrolling command fields and a OK or Apply button to 
record the results.

The width of the command area in the Left Side Modifiers panel is controlled by the environment 
variable DEFAULT_TABLE_WIDTH_4D.

mtf_edit_modify_create

If the command line is empty, clicking LB in the command line will bring up the Create menu which 
contains all the available hinge commands.
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Selecting a menu item will bring up an associated panel which displays the information required 
for the modifier command.

When the panel is filled in and OK or Apply selected, the panel information is written out to the 
command line in the correct format for that modifier command.

If the command line is not empty, clicking LB in the command line will bring up the associated 
panel for the modifier command in the command line.

The information in the panel can be changed and if OK or Apply is selected, the changed panel 
information is written out to the command line in the correct format for that modifier command.

Each of the panels created by selecting a command from the Create menu, will now be 
described. 

The command itself, and its typed format, has already been described in the previous section on 
the template modifier file format.

The typed format of the command will be given for each panel.

For documentation on the option on the Left/Right Side modifier Create menu:

for Fixed, go to the section “Fixed Modifiers” 

Decision “Decision” 
Cut “Cut Modifiers” 
Fill “Fill Modifiers” 
Final “Final Modifiers” 

The text form of the Left/Right side template modifiers is given in the section “Template 
Modifiers File Format” 

Please continue to the next section “Fixed Modifiers” .

Fixed Modifiers
mtf_edit_modify_create_fixed

The fixed walk-right brings up the fixed menu with options to modify the fixed links of the 
template.

modify fixed section
change the decisions used
modify the cut section
modify the fill section
modify the final cut and fill
comment
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To go straight to the documentation on each of the options on the Fixed modifier menu:

For Insert, go to the section“Fixed Insert” .

Remove “Fixed Remove” 
Width/Height “Fixed Width and Height” 
Xfall from link “Fixed Xfall” 
Xfall CRC “Fixed Xfall CRC” 
Width/Height/Xfall from link “Fixed Width, Height and Xfall from a Link” 
Width/Height/Xfall to string “Fixed Width, Height and Xfall to a String” 
Height/Xfall to tin “Fixed Height to Tin and Xfall to Tin” 
Width/Height/Xfall to 2 strings “Fixed Width, Height and Xfall between Two Strings” 

Each of the options from this menu will now described.

mtf_edit_modify_fixed_insert_

Fixed Insert
Fixed links can be inserted by specifying either width and height, width and xfall, or height and 
xfall.

Selecting the insert option brings up the fixed insert panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to create.

Colour input available colours

colour of the link being created.

Width /height/xfall input measures menu

width/ height/ crossfall of the link being created - only use two of the three.

Before input select name menu

if non-blank, the name of the string to insert the new string before.
If blank, the link is appended to the end of the fixed part of the template.

Start/End chainage input measures menu

start/end chainages for inserting the new template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.
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OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fixed_remove

Fixed Remove
Fixed links can be deleted between given chainages by using the fixed remove option.

Selecting the remove option brings up the fixed remove panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to removed.

Start/End chainage input measures menu

start/end chainages for removing the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fixed_width mtf_edit_modify_fixed_height
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Fixed Width and Height
The width modifier is used to modify the width of fixed links originally defined by width. The 
height modifier is used to modify the height of fixed links originally defined by height.

Selecting the width and height option brings up the fixed width and fixed height panels 
respectively.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End width/height input measures menu

start/end width/height for modifying the template link.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Absolute tick box tick

if tick, the width/height is set to the values given in the start and end value fields.
if not tick, the values given in the start and end value fields are added to the existing widths/heights.

Cubic tick box

if tick, the width/height is varied as a reverse cubic between the start and end chainages.
if not tick, the width/height is varied linearly between the start and end chainages.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.
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Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fixed_xfall

Fixed Xfall
The xfall modifier is used to modify the cross fall of fixed links originally defined by cross fall.

Selecting the xfall option brings up the fixed xfall panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End xfall input measures menu

start/end crossfall for modifying the template link.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.
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Absolute tick box tick

if tick, the xfall is set to the values given in the start and end xfall fields.
if not tick, the values given in the start and end xfall fields are added to the existing xfall.

Cubic and Rotate tick boxes:

Only none or one of Cubic and Rotate can be set to tick. 
The default is none - that is, neither is ticked and in the default case, the crossfall is varied linearly 
with respect to crossfall between the start and end chainages.

Cubic tick box

if tick, the crossfall is varied as a reverse cubic between the start and end chainages.

Rotate tick box

if tick, the xfall is varied linearly with respect to the angle, between the start and end chainages.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fixed_xfall_0

Fixed Xfall CRC
The xfall_crc modifier is used to modify the cross fall of fixed links originally defined by xfall 
and uses the circular reverse curve formula to modify the cross fall.

Selecting the xfall crc option brings up the fixed xfall circular reverse curves panel

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End xfall input measures menu

start/end crossfall for modifying the template link.

Start/End length input measures menu

start/end length for circular arcs.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fixed_width_from_link mtf_edit_modify_fixed_height_from_link 
mtf_edit_modify_fixed_xfall_from_link

Fixed Width, Height and Xfall from a Link
The width from link modifier is used to modify the width of fixed links originally defined by 
width to be the same width as another link. That is, the width of the link is a copy of the width of 
another link.

The height from link modifier is used to modify the height of fixed links originally defined by 
height to be the same height as another link. That is, the height of the link is a copy of the height 
of another link.

The xfall from link modifier is used to modify the cross fall of fixed links originally defined by 
xfall to be the same xfall as another link. That is, the cross fall of the link is a copy of the cross fall 
of another link. The link to copy cross fall from can be defined in terms of cross fall or slope. If 
the link to copy is defined by slope, then the cross fall is calculated to match the slope.

Selecting the width from link,   height from link or xfall from link option brings up the fixed width 
from link, fixed height from link and fixed xfall from link panels respectively.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

From link name input select name menu

template link to take width/height/xfall from.

From zone input fixed fixed, cut, fill

zone that the template link to take width/height/xfall from, comes from.
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Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fixed_width_to_string mtf_edit_modify_fixed_height_to_string 
mtf_edit_modify_fixed_xfall_to_string

Fixed Width, Height and Xfall to a String
The width for a link can be varied by going out to another 12d Model string.

The height for a link can be varied by taking the height from another 12d Model string.

The xfall of a link can be defined by using the xfall from the beginning of the link (i.e. the end of 
the previous link or the hinge string if it is the first link) to another 12d Model string.

Using two of the above modifiers together and with the same string will place the end point of 
the link on the selected string. For example, using width to string and xfall to string with the same 
string will place the end of the link on that string.

Selecting the width to string,   height to string or xfall to string option brings up the fixed width to 
string, fixed height to string and fixed xfall to string panels respectively.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

if non blank, start/end chainages for modifying the template link.
If blank, the modifier is applied for the length of the selected string.

Start/End chainage input measures menu

if non blank, start/end chainages for modifying the template link.
If blank, the modifier is applied for the length of the selected string.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

String string-select
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select string to use for defining width/height/crossfall for the link.

Side to search input left side left side, right side, both sides

side of the hinge string to start searching to find the string to define width/height/crossfall.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fixed_height_to_tin mtf_edit_modify_fixed_xfall_to_tin

Fixed Height to Tin and Xfall to Tin
The height to tin modifier is used to modify the height of the link so that the link will sit on the 
tin at the given width. Note that height to tin can only be used for a fixed link defined by width 
and height.

The xfall to tin modifier is used to modify the xfall of the link so that the link will sit on the tin at 
the given width. Note that xfall to tin can only be used for a fixed link defined by width and xfall.

Selecting the height to tin or xfall to tin option brings up the fixed height to tin and fixed xfall to tin 
panels respectively.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu
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start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Tin input available tins

the tin to use for defining the height/xfall

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fixed_width_to_2_strings mtf_edit_modify_fixed_height_to_2_strings 
mtf_edit_modify_fixed_xfall_to_2_strings

Fixed Width, Height and Xfall between Two Strings
The width for a link can be defined by taking the width between two existing 12d Model 
strings.

The height for a link can be defined by taking the height between two existing 12d Model 
strings.

The xfall for a link can be defined by taking the xfall between two existing 12d Model strings.

Selecting the width to 2 strings,   height to 2 strings or xfall to 2 strings option brings up the fixed 
width to 2 strings, fixed height to 2 strings, and fixed xfall to 2 strings panels respectively.



Chapter 31  Advanced Design

May 2007 Page 2861Template Modifiers

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

String 1 string-select
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select the first string to use for defining width/height/crossfall for the link.

String 2 string-select

select the second string to use for defining width/height/crossfall for the link.

Side 1 to search input left side left side, right side, both 
sides

side of the hinge string to start searching to find string 1 to use in defining width/height/crossfall.

Side 2 to search input left side left side, right side, both 
sides

side of the hinge string to start searching to find string 2 to use in defining width/height/crossfall.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Decision” .
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Decision
mtf_edit_modify_create_decision

mtf_edit_decision_change

Decision Change
Each template is made up of the sections fixed, decisions, cut, fill and final cut/fill. If a template 
has a decisions section then by default the decisions section it is used instead of the cut, fill and 
final cut/fill sections.

Hence by default, if the decisions section of a template exists then it is used but if the decisions 
section does not exist, then the cut, fill and final cut/fill sections of the template are used over the 
chainage range.

For an Apply Many, the template specified for a chainage range in the Templates section of the 
MTF (see “Templates” ) is called the original template for that chainage range. 

Using the decision modifier, it is possible to override the defaults for the original template, and 
for a given chainage range:

use the decisions section from another template instead of the decisions or cut/fill sections of 
the original template.

or
use the cut, fill and final cut/fill sections of the original template instead of the decisions 
section of the original template.

The fixed part of the original template is still used in either case.

The decision walk-right brings up the decision menu with the change option which nominates 
what decision templates are used for what chainage ranges.

Selecting the change option brings up the Decision Change panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Decision template input available templates
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if non-blank, this is the template whose decisions section is used over the given chainage range.
If blank, the cut, fill and final cut/fill sections of the original template are used over the chainage range 
instead of the decision section of the original template.

Note that if the new template has no decisions, then the cut and fill section of the original template is 
used instead of the decisions section of the original template. That is, it is equivalent to leaving the 
Decisions template field blank.

Start/End chainage input measures menu

start/end chainages for using the decisions.

Interval input

if non blank, the interval to use to create cross sections and vertices of the strings over the given 
chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Cut Modifiers” .
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Cut Modifiers
mtf_edit_modify_create_cut

The Cut walk-right brings up the Cut menu with options to modify the cut links of the template.

For Insert, go to the section “Cut Insert” 

Remove “Cut Remove” 
Width/Height “Cut Width and Height” 

Slope “Cut Slope” 
Width/Height/Slope from link “Cut Width, Height and Slope from a Link” 
Width/Height/Slope to string “Cut Width, Height and Slope to a String” 
Height/Slope to tin “Cut Height to Tin and Slope to Tin” 
Width/Height/Slope to 2 strings “Cut Width, Height and Slope between Two Strings” 

Each of the options from this menu will now described.

mtf_edit_modify_cut_insert

Cut Insert
Cut links can be created by the cut insert modifier and by specifying either the width and height, 
width and slope or height and slope.

Selecting the insert option brings up the Cut Insert panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to create.

Colour input available colours

colour of the link being created.

Width /height/slope input measures menu

width/ height/slope of the link being created - only use two of the three.

Before input select name menu

if non-blank, the name of the string to insert the new string before.
If blank, the link is appended to the end of the fixed part of the template.

Start/End chainage input measures menu

start/end chainages for inserting the new template link.

Interval input

if non blank, the interval to use to create cross sections and vertices of the strings over the given 
chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.
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OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_cut_remove

Cut Remove
Cut links can be deleted between given chainages by using the cut remove modifier.

Selecting the remove option brings up the cut remove panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to removed.

Start/End chainage input measures menu

start/end chainages for removing the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_cut_width mtf_edit_modify_cut_height
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Cut Width and Height
The cut width modifier is used to modify the width of variable cut links originally defined by 
width. Similarly the cut height modifier is used to modify the height of variable cut links 
originally defined by height.

Selecting the width and height option brings up the cut width and cut height panels respectively.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End width/height input measures menu

start/end width/height for modifying the template link.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Absolute tick box tick

if tick, the width/height is set to the values given in the start and end value fields.
if not tick, the values given in the start and end value fields are added to the existing widths/heights.

Cubic tick box

if tick, the width/height is varied as a reverse cubic between the start and end chainages.
if not tick, the width/height is varied linearly between the start and end chainages.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.
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Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_cut_slope

Cut Slope
The cut slope modifier is used to modify the slope of variable cut links originally defined by 
slope.

Selecting the slope option brings up the cut slope panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End slope input measures menu

start/end slope for modifying the template link.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.
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Absolute tick box tick

if tick, the slope is set to the values given in the start and end slope fields.
if not tick, the slopes given in the start and end value fields are added to the existing slopes.

Cubic and Rotate tick boxes:

Only none or one of Cubic and Rotate can be set to tick. 
The default is none - that is, neither is ticked and in the default case, the slope is varied linearly 
with respect to slope between the start and end chainages.

Cubic tick box

if tick, the slope is varied as a reverse cubic between the start and end chainages.

Rotate tick box

if tick, the slope is varied linearly with respect to the angle, between the start and end chainages.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_cut_width_from_link mtf_edit_modify_cut_height_from_link 
mtf_edit_modify_cut_slope_from_link

Cut Width, Height and Slope from a Link
The width from link modifier is used to modify the width of cut links originally defined by 
width to be the same width as another link. That is, the width of the link is a copy of the width of 
another link.

The height from link modifier is used to modify the height of cut links originally defined by 
height to be the same height as another link. That is, the height of the link is a copy of the height 
of another link.

The slope from link modifier is used to modify the slope of cut links originally defined by slope 
to be the same slope as another link. That is, the slope of the link is a copy of the slope of another 
link. The link to copy slope from can be defined in terms of slope or cross fall. If the link to copy 
is defined by cross fall, then the slope is calculated to match the cross fall.

Selecting the width from link, height from link or slope from link option brings up the cut width from 
link, cut height from link and cut slope from link panels respectively.



Chapter 31  Advanced Design

May 2007 Page 2871Template Modifiers

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

From link name input select name menu

template link to take width/height/slope from.

From zone input fixed fixed, cut, fill

zone that the template link to take width/height/slope from, comes from.
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Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_cut_width_to_string mtf_edit_modify_cut_height_to_string 
mtf_edit_modify_cut_slope_to_string

Cut Width, Height and Slope to a String
The width for a cut link can be varied by going out to another existing string.

The height for a cut link can be varied by taking the height from another existing string.

The slope of a cut link can be defined by using the slope from the beginning of the link (i.e. the 
end of the previous link or the hinge string if it is the first link) to another existing string.

Selecting the width to string,   height to string or slope to string option brings up the cut width to 
string, cut height to string and cut slope to string panels respectively.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

if non blank, start/end chainages for modifying the template link.
If blank, the modifier is applied for the length of the selected string.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

String string-select

select string to use for defining width/height/slope for the link.

Side to search input left side left side, right side, both 
sides
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side of the hinge string to start searching to find the string to define width/height/slope.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_cut_height_to_tin mtf_edit_modify_cut_slope_to_tin

Cut Height to Tin and Slope to Tin
The height to tin modifier is used to modify the height of the cut link so that the link will sit on 
the tin at the given width. Note that height to tin can only be used for a cut link defined by width 
and height.

The slope to tin modifier is used to modify the slope of the link so that the link will sit on the tin 
at the given width. Note that slope to tin can only be used for a cut link defined by width and 
slope.

Selecting the height to tin or slope to tin option brings up the cut height to tin and cut slope to tin 
panels respectively.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.
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Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Tin input available tins

the tin to use for defining the height/slope

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_cut_width_to_2_strings mtf_edit_modify_cut_height_to_2_strings 
mtf_edit_modify_cut_slope_to_2_strings

Cut Width, Height and Slope between Two Strings
The width for a cut link can be defined by taking the width between two existing strings.

The height for a cut link can be defined by taking the height between two existing strings.

The slope for a cut link can be defined by taking the slope between two existing strings.

Selecting the width to 2 strings,   height to 2 strings or slope to 2 strings option brings up the cut 
width to 2 strings, cut height to 2 strings and   cut slope to 2 string panels respectively.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

String 1 string-select



Chapter 31  Advanced Design

May 2007 Page 2877Template Modifiers

select the first string to use for defining width/height/slope for the link.

String 2 string-select

select the second string to use for defining width/height/slope for the link.

Side 1 to search input left side left side, right side, both sides

side of the hinge string to start searching to find string 1 to use in defining width/height/slope.

Side 2 to search input left side left side, right side, both sides

side of the hinge string to start searching to find string 2 to use in defining width/height/slope.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Fill Modifiers” .
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Fill Modifiers
mtf_edit_modify_create_fill

The fill walk-right brings up the fill menu with options to modify the fill links of the template.

For Insert, go to the section “Fill Insert” 

Remove “Fill Remove” 
Width/Height “Fill Width and Height” 
Slope “Fill Slope” 
Width/Height/Slope from link “Fill Width, Height and Slope from a Link” 
Width/Height/Slope to string “Fill Width, Height and Slope to a String” 
Height/Slope to tin “Fill Height to Tin and Slope to Tin” 
Width/Height/Slope to 2 strings “Fill Width, Height and Slope between Two Strings” 

Each of the options from this menu will now described.

mtf_edit_modify_fill_insert

Fill Insert
Fill links can be created by the fill insert modifier and by specifying either the width and height, 
width and slope or height and slope.

Selecting the insert option brings up the fill insert panel
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to create.

Colour input available colours

colour of the link being created.

Width /height/slope input measures menu

width/ height/slope of the link being created - only use two of the three.

Before input select name menu

if non-blank, the name of the string to insert the new string before.
If blank, the link is appended to the end of the fixed part of the template.

Start/End chainage input measures menu

start/end chainages for inserting the new template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.
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OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fill_remove

Fill Remove
Fill links can be deleted between given chainages by using the fill remove modifier.

Selecting the remove option brings up the fill remove panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to removed.

Start/End chainage input measures menu

start/end chainages for removing the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fill_width mtf_edit_modify_fill_height



Chapter 31  Advanced Design

May 2007 Page 2881Template Modifiers

Fill Width and Height
The fill width modifier is used to modify the width of variable fill links originally defined by 
width. Similarly the fill height modifier is used to modify the height of variable fill links 
originally defined by height.

Selecting the width and height option brings up the fill width and fill height panels respectively.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End width/height input measures menu

start/end width/height for modifying the template link.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Absolute tick box tick

if tick, the width/height is set to the values given in the start and end width/height fields.
if not tick, the values given in the start and end height/width fields are added to the existing widths/
heights.

Cubic tick box

if tick, the width/height is varied as a reverse cubic between the start and end chainages.
if not tick, the width/height is varied linearly between the start and end chainages.

Comment input
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comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fill_slope

Fill Slope
The fill slope modifier is used to modify the slope of variable fill links originally defined by 
slope.

Selecting the slope option brings up the fill slope panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End slope input measures menu

start/end slope for modifying the template link.

Extra start/end tick box
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if tick, add an extra x-section 0.1 mm before the start/end chainage.

Absolute tick box tick

if tick, the slope is set to the values given in the start and end slope fields.
if not tick, the values given in the start and end slope fields are added to the existing slopes.

Cubic and Rotate tick boxes:

Only none or one of Cubic and Rotate can be set to tick. 
The default is none - that is, neither is ticked and in the default case, the slope is varied linearly 
with respect to slope between the start and end chainages.

Cubic tick box

if tick, the slope is varied as a reverse cubic between the start and end chainages.

Rotate tick box

if tick, the slope is varied linearly with respect to the angle, between the start and end chainages.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fill_width_from_link mtf_edit_modify_fill_height_from_link 
mtf_edit_modify_fill_slope_from_link

Fill Width, Height and Slope from a Link
The width from link modifier is used to modify the width of fill links originally defined by 
width to be the same width as another link. That is, the width of the link is a copy of the width of 
another link.

The height from link modifier is used to modify the height of fill links originally defined by 
height to be the same height as another link. That is, the height of the link is a copy of the height 
of another link.

The slope from link modifier is used to modify the slope of fill links originally defined by slope 
to be the same slope as another link. That is, the slope of the link is a copy of the slope of another 
link. The link to copy slope from can be defined in terms of slope or cross fall. If the link to copy 
is defined by cross fall, then the slope is calculated to match the cross fall.

Selecting the width from link, height from link or slope from link option brings up the fill width from 
link, fill height from link and fill slope from link panels respectively.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

From link name input select name menu

template link to take width/height/slope from.

From zone input fixed fixed, cut, fill

zone that the template link to take width/height/slope from, comes from.
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Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fill_width_to_string mtf_edit_modify_fill_height_to_string 
mtf_edit_modify_fill_slope_to_string

Fill Width, Height and Slope to a String
The width for a fill link can be varied by going out to another existing string.

The height for a fill link can be varied by taking the height from another existing string.

The slope of a fill link can be defined by using the slope from the beginning of the link (i.e. the 
end of the previous link or the hinge string if it is the first link) to another existing string.

Selecting the width to string,   height to string or slope to string option brings up the fill width to 
string, fill height to string and fill slope to string panels respectively.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

if non blank, start/end chainages for modifying the template link.
If blank, the modifier is applied for the length of the selected string.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

String string-select

select string to use for defining width/height/slope for the link.

Side to search input left side left side, right side, both sides
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side of the hinge string to start searching to find the string to define width/height/slope.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

The typed formats of the width to a string, height to a string and slope to a string command for a 
mtf_edit_modify_fill_height_to_tin mtf_edit_modify_fill_slope_to_tin

Fill Height to Tin and Slope to Tin
The height to tin modifier is used to modify the height of the fill link so that the link will sit on 
the tin at the given width. Note that height to tin can only be used for a fill link defined by width 
and height.

The slope to tin modifier is used to modify the slope of the link so that the link will sit on the tin 
at the given width. Note that slope to tin can only be used for a cut link defined by width and 
slope.

Selecting the height to tin or slope to tin option brings up the fill height to tin and fill slope to tin 
panels respectively.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu



12d Model Reference Manual

Page 2888 May 2007Template Modifiers

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Tin input available tins

the tin to use for defining the height/slope

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_fill_width_to_2_strings mtf_edit_modify_fill_height_to_2_strings 
mtf_edit_modify_fill_slope_to_2_strings

Fill Width, Height and Slope between Two Strings
The width for a fill link can be defined by taking the width between two existing strings.

The height for a fill link can be defined by taking the height between two existing strings.

The slope for a fill link can be defined by taking the slope between two existing strings.

Selecting the width to 2 strings,   height to 2 strings or slope to 2 strings option brings up the fill 
width to 2 strings, fill height to 2 strings and   fill slope to 2 string panels respectively.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

String 1 string-select



12d Model Reference Manual

Page 2890 May 2007Template Modifiers

select the first string to use for defining width/height/slope for the link.

String 2 string-select

select the second string to use for defining width/height/slope for the link.

Side 1 to search input left side left side, right side, both sides

side of the hinge string to start searching to find string 1 to use in defining width/height/slope.

Side 2 to search input left side left side, right side, both sides

side of the hinge string to start searching to find string 2 to use in defining width/height/slope.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Final Modifiers” .
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Final Modifiers
mtf_edit_modify_create_final

The final walk-right brings up the final menu with options to modify the final cut and fill links of 
the template.

For Width, go to the section “Final Width” 

Cut slope “Final Cut or Final Fill Slope” 
Fill slope “Final Cut or Final Fill Slope” 
No cut slope “Final No Cut Slope and/or Final No Fill Slope” 
No fill slope “Final No Cut Slope and/or Final No Fill Slope” 
No cut/fill slope “Final No Cut Slope and/or Final No Fill Slope” 

Each of the options from this menu will now described.

mtf_edit_modify_final_width

Final Width
The final width modifier varies the width of the final link of the template.

Selecting the width option brings up the final width panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu
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name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End value input measures menu

start/end width for modifying the template link.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Absolute tick box tick

if tick, the width is set to the values given in the start and end width fields.
if not tick, the width given in the start and end width fields are added to the existing widths.

Cubic tick box

if tick, the width is varied as a reverse cubic between the start and end chainages.
if not tick, the width is varied linearly between the start and end chainages.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_final_cut_slope mtf_edit_modify_final_fill_slope

Final Cut or Final Fill Slope
The final cut slope modifier varies the cut slope of the final link of the template and the final fill 
slope modifier varies the fill slope of the final link of the template.

Selecting the cut slope or fill slope options brings up the cut slope and fill slope panels 
respectively.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for modifying the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Start/End slope input measures menu

start/end slope for modifying the template link.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Absolute tick box tick

if tick, the slope is set to the values given in the start and end slope fields.
if not tick, the values given in the start and end slope fields are added to the existing slope.

Cubic tick box

if tick, the slope is varied as a reverse cubic between the start and end chainages.

Rotate tick box

if tick, the slope is varied linearly with respect to the angle, between the start and end chainages.

Note - 
Only one of cubic and rotate can be set to tick.
If both are set to not tick, then the slope is varied linearly respect to slope between the start and end 
chainages (the default).

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.
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Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_modify_final_no_cut

mtf_edit_modify_final_no_fill

mtf_edit_modify_final_no_cut_fill

Final No Cut Slope and/or Final No Fill Slope
The final link can be stopped altogether in either cut or fill or both. The no cut slope modifier 
stops the final link when it is in cut, the no fill slope modifier stops the final link when it is in fill 
and the no cut/fill fill slope modifier stops the final link when it is in cut and fill.

Selecting the No cut slope, No fill slope or No cut/fill slope options brings up the Final No Cut, Final 
No Fill or Final No Cut/Fill panels or respectively.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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Link name input select name menu

name of the link to modify.

Start/End chainage input measures menu

start/end chainages for stopping the template link.

Interval input

if non blank, the interval to use to create cross sections and strings over the given chainage range.
If blank, the Section separation value from the Apply Many panel is used.

Extra start/end tick box

if tick, add an extra x-section 0.1 mm before the start/end chainage.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Stripping” .
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Stripping
mtf_edit_stripping_changes

A fixed stripping depth can be specified in the apply option whilst the apply many option allows 
for stripping depths which can vary along the design.

If a non-zero stripping depth exists at a chainage, the cut and fill calculations are done with 
respect to the section through the tin dropped in height by the stripping depth.

However, the design strings are generated by battering into the unstripped surface, and the 
stripping volume is the volume between the stripped and unstripped surface for the design.

Stripping depths are defined for chainages along the reference string and can be linearly 
interpolated between chainages.

NOTE: Cut and fill areas and volumes are adjusted for the stripping depths. The total stripping 
volume is given at the end of the volumes report.

Selecting the stripping option on the MTF edit menu brings up the stripping changes panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Chainage column header

list of chainages for defining stripping depth.

Strip depth 1 column header for the field - measures menu

strip depth to apply at the chainage given for this row of information. If strip depth 2 is blank, then 
strip depth 1 is applied until the next chainage in the chainage column.
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Strip depth 2 column header
for the field - measures 

menu

if non-blank, the strip depth to linearly interpolate to and finish with at the next chainage in the 
chainage column.
if blank, then strip depth 1 applies to the next chainage in the chainage column.
In the mtf file, the two depths will be separated by a comma.

Comment column header

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Boxing” .
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Boxing
mtf_edit_boxing

In the many templates file, up to eight (8) layers of boxing can be defined.

For each layer, the boxing is defined in one or two parts - the left boxing and the right boxing.

The left boxing or the right boxing can define the boxing for the entire template and then only 
one is needed.

If left and right boxing are both defined at a section, then the last point of the left boxing is 
automatically connected to the first point of the right boxing.

Warning - the left boxing must end before the right boxing begins. If there is an overlap, the right 
boxing will be pushed to the end of the left boxing.

Warning - no interpolation or modifiers exist for boxing.

For the definition of boxing, go to the section “Full Definition of Boxing” 

When boxing is used in the Apply many, the cut and fill areas and volumes are also calculated 
for all the inter-boxing layers. The last layer defined is also referred to as the subgrade layer and 
volumes are also given for the natural surface to the subgrade and the design to the subgrade. 

 The boxing walk-right in the mtf edit menu brings up the boxing menu with options to specify 
the file supplying the boxing definitions and options to apply the definitions to the right and left 
side of the template.

For File, go to the section “Boxing File” 

Left/Right side “Left Side and Right Side Boxing” 
Left/Right side for each layer “Left Side and Right Side Boxing” 

Each of the options from this menu will now described.

mtf_edit_boxing_file
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Boxing File
Selecting file from the boxing menu brings up the boxing file panel for defining the boxing 
definitions to be used in this apply many.
For the definition of boxing, go to the section “Full Definition of Boxing” 

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Boxing file input *.bf files

name of the file containing the boxing definitions to bed used for the mtf.

Comment column header

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

mtf_edit_boxing_changes

Left Side and Right Side Boxing
The panels brought up by selecting Left side or Right side from the Boxing menu brings up the Left 
Side Boxing and Right Side Boxing panels respectively. This is for the first layer of boxing.

The left side and right side panels define for each boxing layer, what boxing definitions (from the 
boxing file) are applied to chainages along the reference string.

For the definition of boxing, go to the section “Full Definition of Boxing” 

The panels brought up by selecting Left side or Right side for Layer 2 to Layer 8 from the Boxing 
menu brings ups up similar panels for each of the layers and so won’t be documented separately.
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up
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Chainage column header

chainage to start applying the boxing definition at.

Boxing rule column header                        for the fields - available boxing

boxing definition to apply from this chainage to the next in the chainage list.

Comment column header

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Width” .
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Width
mtf_edit_section_width

A section width is used to limit the distance to search along a section when trying to find strings 
used in any of the mtf commands.

Selecting width from the mtf edit men brings up the section width panel for setting the width.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Section width input 10000

Section width defines the perpendicular offset from the Hinge string. It is used to limit the search 
distance for strings when performing MTF modifier commands.

Comment column header

comment to add to the end of the line. In the file, the comment will be preceded by //.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “String Modifiers” .
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String Modifiers
Unlike the other MTF options, the string modifier options modify the heights on an existing 
string called the amend string.

Like the apply options, a reference string is used to define chainage and what is perpendicular at 
each chainage. A hinge string is used to define offsets and heights. If no hinge string is selected, 
the reference string is also used as the hinge string.

For a given chainage on the reference string (chainage point), a line perpendicular to the 
reference string is constructed to cut through the hinge string and the amend string (the cut 
points are called the hinge point and the amend point).

Horizontal offset is defined as the offset value from the hinge point, and the height of the amend 
point is a modification of the height at the hinge point.

The string modifier options create and/or modify the heights of the amend points on the amend 
string.

The height of the amend point is derived from the hinge point by starting with the height of the 
hinge point and applying a crossfall to it across the offset distance from the hinge string to the 
amend string.

The cross fall can be defined by either:

(a) giving the cross fall

or

(b) using the cross fall between two user selected strings.

For the string options, the length of string being modified is restricted by giving a start and end 
reference chainage. A chainage interval can also be specified to define extra reference chainage 
points to use between the start and end chainages.

How and where the amend string is modified depends on the type of string and whether the 
chainage interval is blank (null) or not.

reference string

hinge string

direction perpendicular to the reference string 
to use to cut the hinge and amend strings.

hinge point - the point used to measure 
offset distance and calculate height fromamend string

offset distance measured perpendicular to the 
reference string and from the hinge pointsamend point - point on amend 

string where height is modified

chainage point

reference string

hinge string

amend string

start chainage

end chainage

chainage interval

chainage points
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What Points are Modified
For 3d, 4d, polyline and super strings:

If the chainage interval is not blank:

(a) The start and end chainage points are projected from the reference string and inserted into the 
amend string. The heights of the inserted points are defined by the string modifier 
command. 

(b) The chainage points at the given chainage interval are also projected from the reference 
string and inserted into the amend string. The heights of the inserted points are defined by 
the string modifier command.

(c) Finally, the vertices of the amend string are dropped perpendicularly back onto the hinge and 
reference string and then those points used to modify the heights of the same vertices of the 
amend string.

If the chainage interval is blank:

(a) The start and end chainage points are projected from the reference string and inserted into the 
amend string. The heights of the inserted points are defined by the string modifier 
command. 

(b) The vertices of the amend string are dropped perpendicular back onto the hinge and 
reference string and then those points used to modify the heights of the same vertices of the 
amend string.

For Alignment strings:

If the chainage interval is not blank:

(a) All the vertical geometry is removed between the start and end chainages. That is, the 
vertical intersection points (VIP’s) and their associated vertical curves are removed.

(b) The start and end chainage points are projected from the reference string and vertical 
intersection points (VIP’s) inserted into the amend string. The height of the inserted VIP 
points are defined by the string modifier command. 

If the chainage interval is blank:

(a) The start and end chainage points are projected from the reference string and vertical 
intersection points (VIP’s) inserted into the amend string. The heights of the inserted VIP 
points are defined by the string modifier command.

(b) The vertical intersection points (VIP’s) of the amend string are dropped perpendicularly 
back onto the hinge and reference strings and then those points used to modify the heights of 
the same VIP’s of the amend string. The vertical curves for the VIP’s are not changed.

string_modifiers
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String Modifiers in MTF Edit
For information on how the String Modifiers in the MTF editor work, please go to the previous 
section “String Modifiers” .

Selecting Strings from the MTF Edit menu brings up the String Modifiers panel.

 The String Modifiers panel consists of a scrolling command fields and an OK or Apply button to 
record the results.

The width of the command area in the String Modifiers panel is controlled by the environment 
variable DEFAULT_TABLE_WIDTH_4D.

create_mtf_string_modifiers

If the command line is empty, clicking LB in the command line will bring up the Create menu which 
contains the available String commands.

Selecting a menu item will bring up an associated panel which displays the information required 
for the modifier command.

When the panel is filled in and OK or Apply selected, the panel information is written out to the 
command line in the correct format for that modifier command.

modify by xfall and height
modify by 2-strings
comment
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If the command line is not empty, clicking LB in the command line will bring up the associated 
panel for the modifier command in the command line.

The information in the panel can be changed and if OK or Apply is selected, the changed panel 
information is written out to the command line in the correct format for that modifier command.

Each of the panels created by selecting a command from the Create menu, will now be 
described. 

mtf_edit_string_modify_by_xfall_height

Height
The height the Height string modifier calculates for the amend point is given by:

(a) if the absolute flag is not set, the height of the hinge point, otherwize zero.

plus

(b) the interpolated height for the user given heights at the start and end chainages

plus

(c) the interpolated height for the user given cross falls at the start and end chainage.

That is, if the absolute flag is not set:

 new height = hinge height + (interpolated height) + (interpolated xfall) x (offset distance)

If the absolute flag is set:

 

new height = (interpolated height) + (interpolated xfall) x (offset distance)

Selecting the Height option brings up the String Modify by Xfall Height panel

The fields and buttons used in this panel have the following functions.
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Field Description Type Defaults Pop-Up

Amend string string-select

select string to have heights amended.

Reference string string-select

select reference string.

Hinge string string-select

select hinge string.

Start/End chainage input measures menu

start/end chainage on the reference string for applying the modifier.

Interval input

if non blank, the chainage separation to apply the modifier.
If blank, the Section separation value from the Apply Many panel is used.

Start/End xfall input measures menu

start/end crossfall for the modifier.

Start/End height input measures menu

start/end height for modifier.

Absolute height tick box

if tick, the calculated height does not include the hinge height.
if not tick, the calculated height includes the hinge height.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

For more information on how the String Modifiers in the MTF editor work, please go to the 
section “String Modifiers” .

mtf_edit_string_modify_by_2_strings

Height 2X
The height the Height 2x string modifier calculates for the amend point is given by:

(a) the height of the hinge point

plus

(b) the offset distance multiplied by the cross fall between two user selected strings.

 new height = hinge height + (xfall between string 1 and string 2) x (offset distance)
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Selecting the Height 2x option brings up the String Modify by 2 Strings panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Amend string string-select

select string to have heights amended.

Reference string string-select

select reference string.

Hinge string string-select

select hinge string.

Start/End chainage input measures menu

start/end chainage on the reference string for applying the modifier.

Interval input

if non blank, the chainage separation to apply the modifier.
If blank, the Section separation value from the Apply Many panel is used.

Crossfall string 1 string-select

select first string to define crossfall by.

Crossfall string 2 string-select

select second string to define crossfall by.

Comment input

comment to add to the end of the line. In the file, the comment will be preceded by //.

Active tick box tick

if tick, use this modifier.
if not tick, don’t use this modifier.

OK/Apply button

OK stores the values in the fields and removes the panel.
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Apply stores the values and leaves the panel on the screen.

For more information on how the String Modifiers in the MTF editor work, please go to the 
section “String Modifiers” .
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Shift
mtf_edit_shift_chainages

In an mtf, many modifiers are defined in terms of chainage on the reference string. For example, 
the width modifier is defined to apply between a given start and end chainage on the reference 
string.

If the horizontal geometry of the reference string is modified, many of the reference chainages in 
the mtf will be incorrect. Shift can help correct the chainages in the mtf file when modifications 
are made to the reference string horizontal geometry after the mtf has been defined.

For the mtf and all special chainage files referred to in the mtf, Shift adds a delta chainage (the 
shift distance) to chainages within a user specified range.

However depending on the type of modifications made to the reference string, shift may have to 
be applied a number of times over a number of different chainage ranges. And apart from a 
simple change of start chainage, there may be chainages that can not be corrected with Shift.

Before using Shift, it is necessary to know how the reference string has changed from its original 
position so to use shift it is advantageous to make a copy of the reference string before any 
changes are made.

Examples Using Shift:

1. If only the start chainage of the reference string was modified, shift would be applied to the 
mtf for the entire original reference string and end chainages, with a shift distance equal to the 
difference between the new and the old start chainages for the reference string. For this case 
the horizontal geometry has not changed, just the chainages.

2. If the radius of a horizontal curve is changed in the middle of the reference string, all 
chainages from the beginning of the string up to point where the horizontal geometry starts 
to change would stay the same. At some point after the modified curve, the horizontal 
geometry of the string is unchanged and for this section of the mtf, a shift distance equal to 
the difference between the new and the old chainages of a non-modified point.

In all areas where the horizontal geometry has been modified, the chainages in the mtf would 
have to be carefully examined to see what changes are required.

Warning: Shift option is very powerful but is also very dangerous.

Selecting Shift brings up the Shift Chainages panel.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Chainage to shift from chainage box measure chainage

chainage in the mtf to start adding the Shift distance
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Any chainages in the mtf file (and any associated special chainage files) between the Chainage to shift 
from and the Chainage to shift to will have Shift distance added to them.

Chainage to shift to chainage box measure chainage

chainage in the mtf to stop adding the Shift distance

Any chainages in the mtf file (and any associated special chainage files) between the Chainage to shift 
from and the Chainage to shift to will have Shift distance added to them.

Shift distance input

delta chainage to add to all the chainages in the mtf file and any special chainages that are between the 
Chainage to shift from and the Chainage to shift to

OK/Apply button

OK applies the shift and removes the panel.
Apply applies the shift and leaves the panel on the screen.
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Text Version of the MTF
In the text version of the mtf file, most of (a) to (h) begin with a key word, following by an equals 
sign (=) and then special commands enclosed in { }.

key_word = {
commands

}

The key words for each case above are

(a) left_side, right_side

(b) specials

(c) hinge_modifier

(d) left_side_modifier, right_side_modifier

(e) stripping

(f) boxing_file, left_boxing, right_boxing

(g) section_width

(h) string_modifiers

If any of the key words exist, then they must be in the following order in the mtf file:

left_side = { ... }
right_side = { ... }
specials = { ... }
hinge_modifier = { ... }
left_side_modifier = { ... }
right_side_modifier = { ... }
stripping = { ... }
boxing_file =  “something.bf”
left_boxing = { ... }
right_boxing = { ... }
section_width = value

string_modifiers = { ... }

The format for boxing_file is simply

boxing_file = "something.bf"

where something.bf is the name of a file containing boxing definitions to use for the mtf.

The format for (g) is simply

section_width = value // default is 10000

where value is the distance to search from the hinge string for strings required in some options. If 
section_width is missing, then it takes the default value of 10000.

The key words, left_side and right_side which are for initially applying templates (for part(a)), 
have already been described under the Design=>Apply=>Apply many option but will be 
summarised in the next section “Templates” .

The documentation for the text file syntax of the MTF file now follows.
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Left Side, Right Side File Format
The file format for the left_side and right_side sections of the mtf file has been given in the 
section Apply Many of the chapter, Templates.

Summarizing, the templates on the left and right hand sides of the centre line are specified 
separately in the many templates file.

The left-side (right-side) definition begins with the key words

left_side = right_side =

with a list of chainages (in ascending order, one per line) with template names. This list of 
chainages and templates is enclosed in curly braces { }.

The chainage-template lists are assembled as follows

(a) To represent a template starting at a given chainage, the chainage value followed by the 
template name is given. The chainage and name are separated by one or more spaces. For 
example, the template std starting at chainage 150 is represented by

150 std

The template is assumed to apply until the chainage given on the next line of the left-side 
definition.

 If the template is to go to the end of the centre-line, add a line with a chainage greater than 
or equal to the end chainage. For example,

150 std

99999

(b) if no template exists from a chainage, simply include the chainage with no template name 
following it. For example, if there is no template from chainage 250, this is represented by

250

The non-existence of a template is assumed to apply until the chainage given on the next 
line of the left-side definition

(c) the case of a linear change from one template to another template over a specified chainage 
range is represented by giving the start chainage of the linear change, followed on the same 
line by the start template, a comma, and the end template. For example, if the template is to 
vary linearly between the template std and the template left, beginning at the chainage 350, 
then the line in the file would be

350 std, left

The linear change takes place over the interval beginning at the chainage given on the defin-
ing line and ending at the chainage given on the next line of the left-side. Distances and per-
cent cross-falls are interpolated linearly and slopes are interpolated on the radian value of 
the slope angles.

A Left and Right Side File Example
left_side = {

100 std
200 std , "left 1"
250 "left 1"
300
350 std
99999

}
right_side = {

100 std
200 std , right
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250 right
300 right , std
350 std
400

}

The left_side describes the situation:

1. the left-hand side of the centre-line has no template from the beginning of the centre-line until 
chainage 100.

2. at chainage 100, the template std begins and continues until chainage 200.

3. there is a linear change from the template std to the template left 1 between chainage 200 and 
chainage 250.

4. the template left 1 goes from chainage 250 to chainage 300.

5. there is a gap between chainage 300 and chainage 350.

6. the template std goes from chainage 350 to chainage 99999, or if the end chainage is smaller 
than 99999, to the end of the centre-line.

Specials File Format
In the many templates file, the specials definition begins with the key word

specials  = 

This is followed by a list of 

(a) chainages, in any order, one per line

and/or

(b) the names of files (enclosed in quotes “) which include lists of chainages (The default 
ending for a special chainage file is *.spc)

The list of chainages and/or file names is enclosed in curly braces {}.

A Specials Example
specials = {

125.3
1925.4
“fred”                        // file of chainages to read in
3007
“joe”

}
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Hinge Modifier File Format
In the many templates file, the hinge modifier definition begins with the key word

hinge_modifier  = 

followed by one or more of the hinge modifier commands offset, height, coord and nohinge 
enclosing curly braces {}.

hinge_modifier = {
hinge modifier commands

}

The definition of the hinge modifier commands will now be given.

Offset
The offset modifier will move the hinge point a given offset distance (perpendicular to the 
reference string) from its current plan position. A positive offset is to the right of the hinge string 
and a negative offset to the left.

The format of the modifier to vary the offset is

offset st_ch end_ch st_offset end_offset absrel type extra_start extra_end

where
st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_offset offset to be used at the start modifier chainage, st_ch
end_offset offset to be used at the end modifier chainage, end_ch.
absrel relative (default) or absolute
type linear (default) or cubic
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage
If absrel is relative (the default) then

the st_offset is added to the current position of the hinge point at chainage st_ch.
the end_offset is added to the current position of the hinge point at chainage end_ch.

If absrel is absolute, then
the offset of the hinge point is taken with respect to the original position of the hinge

string at chainage st_ch.
the offset of the hinge point is taken with respect to the original position of the hinge

 string at chainage end_ch.

If type is linear (the default), then the offset is varied linearly (with respect to the reference 
chainage) between the offsets at chainage st_ch and chainage end_ch.

If type is cubic, then the offset is varied as a reverse cubic (with respect to the reference chainage) 
between the offsets at chainage st_ch and chainage end_ch.
.

reference string

hinge string

direction to apply template along 
(perpendicular to the reference string)

original point to apply 
template from (hinge

offset moves the hinge point along 
the line perpendicular to the 
reference string
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Offset to String
The offset for the hinge point can also be varied by going out to another 12d Model string.

offset st_ch end_ch   full_string_name   extra_start   extra_end

where

st_ch start chainage for the modifier
end_ch end chainage for the modifier
full_string_name name of a 12d Model string to take the hinge point out to. The

format of the string name is “model_name->string_name”.
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Height
The height modifier varies the height of the hinge point between the given chainages.

height st_ch  end_ch st_height end_height absrel type extra_start extra_end

where

st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_height height to be used at the start modifier chainage, st_ch
end_height height to be used at the end modifier chainage, end_ch.
absrel relative (default) or absolute
type linear (default) or cubic

extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage
If absrel is relative (the default) then

the st_height is added to the current height of the hinge point at chainage st_ch.
the end_height is added to the current height of the hinge point at chainage

end_ch.

If absrel is absolute, then

the height of the hinge point is set to st_height above the original hinge string at
chainage st_ch.

the height of the hinge point is set to end_height above the original hinge string
at chainage end_ch.

If type is linear (the default), then the height is varied linearly (with respect to the reference 
chainage) between the height at chainage st_ch and chainage end_ch.

If type is cubic, then the height is varied as a reverse cubic (with respect to the reference 
chainage) between the height at chainage st_ch and chainage end_ch.

Height to String
The height of the hinge point can also be specified by taking the height from another 12d Model 
string.

height st_ch end_ch full_string_name  extra_start extra_end

where

st_ch start chainage for the modifier
end_ch end chainage for the modifier
full_string_name name of a 12d Model string to take the hinge point height from. The

format of the string name is “model_name->string_name”.
extra_start optional - adds in an extra x-section 0.1mm before start chainage
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extra_end optional - adds in an extra x-section 0.1mm before end chainage

Coord to String
The coord modifier is used to replace the x, y and z position of the hinge point by the x, y and z 
position of another 12d Model string between given chainages. Hence coord replaces the hinge 
string by another string between the given chainages.

coord st_ch end_ch   full_string_name   extra_start   extra_end

where

st_ch start chainage for the modifier
end_ch end chainage for the modifier
full_string_name name of the 12d Model string used to replace the hinge string

between the chainages st_ch and end_ch. The format of the string
name is “model_name->string_name”.

extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Nohinge
The nohinge modifier is used to stop the hinge string (and hence the apply) between given 
chainages. This will leave a gap in the strings created by the apply between the given chainages.

nohinge st_ch end_ch extra_start extra_end

where

st_ch start chainage to stop the apply
end_ch end chainage for stopping the apply
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Please continue to the next section “A Hinge Modifier Example” .

A Hinge Modifier Example
 hinge_modifier = {

offset 0 250 0 3 // linearly offset the hinge by 0 to 3
// over the chainage range 0 to 250.

height 125 300 2 2 // add 2 to the hinge height
// over the chainage range 125 to 300.

coord 300 400 “mod->new_string”       // use the position of the string
         // new_string over the chainage
         // range 300 to 400.

nohinge 400 500 2 2 // stop the apply between the chainages
// over the chainage range 400 to 500.

}

Please continue to the next section “Template Modifiers” .
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Template Modifiers File Format
In the many templates file, the template modifier definition begins with the key word

left_side_modifier  = 

and/or

right_side_modifier  = 

followed by one or more of the template modifier commands enclosing curly braces { })

(a) insert commands

 insert, insert_cut, insert_fill

(b) remove commands

remove, remove_cut, remove_fill 
(c) fixed link modifiers

width, height, xfall, xfall_crc, copy_width, copy_height, copy_xfall,
 tin_height, tin_xfall

(d) stop and start decisions commands

decision

(e) variable cut and fill link modifiers

 cut_width, cut_height, cut_slope, copy_cut_width, copy_cut_height,
 copy_cut_slope, tin_cut_height, tin_cut_slope

fill_width, fill_height, fill_slope, copy_fill_width, copy_fill_height,
 copy_fill_slope, tin_fill_height, tin_fill_slope

 

(f) final cut/fill link modifiers

 final_width, final_cut_slope, final_no_cut_slope

 final_fill_slope, final_no_fill_slope 

That is, 
left_side_modifier = {

template modifier commands
}

and/or
right_side_modifier = {

template modifier commands
}

The definition of the template modifier commands and their file format will now be given.

Please continue to the next section “Insert Modifiers” .
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Insert Modifiers

Fixed Link Insert
Fixed links can be created by one of three insert commands by specifying either width and 
height, width and xfall, or height and xfall.

insert link_name colour width height unknown st_ch end_ch optional// use width, height

insert link_name colour width unknown xfall st_ch end_ch optional// use width, xfall

insert link_name colour unknown height xfall st_ch end_ch optional// use height, xfall

where unknown takes the place of the one of width, height or xfall not being used, and

link_name name of the link being created
colour colour of the link being created
width, height, xfall width, height or xfall of the created link
st_ch start chainage for creating the link
end_ch end chainage for creating the link

and optional can be none, one or more of the following

name if non-blank, insert before the link name in the template
if blank, then append after the last link of the fixed template table

extra_start optional - adds in an extra x-section 0.1 mm before start chainage
extra_end optional - adds in an extra x-section 0.1 mm before end chainage

Cut and Fill Link Insert
Cut and fill links can be created by one of three insert commands by specifying either width and 
height, width and slope, or height and slope.

insert_cut link_name colour width height unknown st_ch end_ch optional// width, ht

insert_fill link_name colour width height unknown st_ch end_ch optional// width, ht

insert_cut link_name colour width unknown slope st_ch end_ch optional// width, slope

insert_fill link_name colour width unknown slope st_ch end_ch optional// width, slope

insert_cut link_name colour unknown height slope st_ch end_ch optional// ht, slope

insert_fill link_name colour unknown height slope st_ch end_ch optional// ht, slope

where unknown takes the place of the one of width, height or slope not being used, and

link_name name of the link being created
colour colour of the link being created
width, height, slope width, height or slope of the created link
st_ch start chainage for creating the link
end_ch end chainage for creating the link

and optional can be none, one or more of the following

name if non-blank, insert before the link name in the template
if blank, then append after the last link of the fixed template table

extra_start optional - adds in an extra x-section 0.1 mm before start chainage
extra_end optional - adds in an extra x-section 0.1 mm before end chainage

Please continue to the next section “Remove Modifiers” .
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Remove Modifiers
Fixed, cut and fill links can be deleted by one of three remove commands:

remove link_list st_ch end_ch optional

remove_cut link_list st_ch end_ch optional

remove_fill link_list st_ch end_ch optional

where

link_list one or more names of links to be removed, in the form
name1 name2 ... namei

st_ch start chainage for removing the link
end_ch end chainage for removing the link

and optional can be none, one or two of

extra_start optional - adds in an extra x-section 0.1 mm before start chainage
extra_end optional - adds in an extra x-section 0.1 mm before end chainage

Please continue to the next section “Fixed Link Modifiers” .

Fixed Link Modifiers

Width
The width modifier is used to modify the width of fixed links originally defined by width.

The format of the modifier to vary the width of the fixed links given by link_list is

width link_list st_ch end_ch st_wid end_wid absrel type extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_wid width to be used at the start modifier chainage, st_ch
end_wid width to be used at the end modifier chainage, end_ch.
absrel relative (default) or absolute
type linear (default) or cubic
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

If absrel is relative (the default) then

the st_wid is added to the current width of links in link_list at chainage st_ch.
the end_wid is added to the current width of links in link_list at chainage
 end_ch.

If absrel is absolute, then

the width of links in link_list are set to st_wid at chainage st_ch.
the width of links in link_list are set to end_wid at chainage end_ch.

If type is linear (the default), then the width of links in link_list are varied linearly (with respect 
to the reference chainage) between the width at chainage st_ch and chainage end_ch.

If type is cubic, then the width of links in link_list is varied as a reverse cubic (with respect to the 
reference chainage) between the width at chainage st_ch and chainage end_ch.
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The width for a link can also be varied by going out to another 12d Model string or by taking the 
width between two 12d Model strings.

width link_list st_ch end_ch full_string_name side ext_start ext_end
width link_list st_ch end_ch str_name_1 side_1 str_name_2 side_2  ext_start ext_end

where

link_list one or more names of fixed links given in the template definition;
 with format name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
full_string_name name of a 12d Model string to take links in link_list out to.

The format of the string name is “model_name->string_name”.
side side to search for string: -1 for left, 0 for left and right, 1 for right
ext_start optional - adds in an extra x-section 0.1mm before start chainage
ext_end optional - adds in an extra x-section 0.1mm before end chainage

str_name_1 name of the first 12d Model string. The format of the string name is
 “model_name->string_name”.

side_1 side to search for string_1:
-1 for left, 0 for left and right, 1 for right

str_name_2 name of the second 12d Model string. The format of the string name
 is “model_name->string_name”.

side_2 side to search for string_2:
-1 for left, 0 for left and right, 1 for right

The width of links in link_list are taken to be the distance between str_name_1 and str_name_2.

Width from Link
The width from link modifier is used to modify the width of fixed links originally defined by 
width to be the same as another link. That is, the width of the link is a copy of the width of 
another link.

The format of the modifier to vary the width from link of the fixed links given by link_list is

copy_width link_list st_ch end_ch from_link zone extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
from_link name of link to take the width from
zone section of the template that the from_link is from (i.e. fixed, cut or fill)
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Height
The height modifier is used to modify the height of fixed links originally defined by height.

The format of the modifier to vary the height of the fixed links in the link_list is almost identical 
to varying the width and is:
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height link_list st_ch end_ch st_ht end_ht absrel type extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_ht height to be used at the start modifier chainage, st_ch
end_wid height to be used at the end modifier chainage, end_ch.
absrel relative (default) or absolute
type linear (default) or cubic
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

If absrel is relative (the default) then

the st_ht is added to the current height of links in link_list at chainage st_ch.
the end_ht is added to the current height of links in link_list at chainage
 end_ch.

If absrel is absolute, then

the height of links in link_list are set to st_ht at chainage st_ch.
the height of links in link_list are set to end_ht at chainage end_ch.

If type is linear (the default), then the height of links in link_list are varied linearly (with respect 
to the reference chainage) between the height at chainage st_ch and chainage end_ch.

If type is cubic, then the height of links in link_list is varied as a reverse cubic (with respect to the 
reference chainage) between the height at chainage st_ch and chainage end_ch.

The height for a link can also be varied by taking the height from a 12d Model string or by 
taking the height between two 12d Model strings.

height   link_list   st_ch   end_ch   full_string_name side  extra_start   extra_end
height   link_list   st_ch end_ch str_name_1 side1 str_name_2 side2 extra_start extra_end

where

link_list one or more names of fixed links given in the template definition;
 with format name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
full_string_name name of a 12d Model string to take links in link_list out to.

The format of the string name is “model_name->string_name”.
side side to search for string: -1 for left, 0 for left and right, 1 for right
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage
str_name_1 name of the first 12d Model string. The format of the string name is

 “model_name->string_name”.

side2 side to search for string: -1 for left, 0 for left and right, 1 for right
str_name_2 name of the second 12d Model string. The format of the string name

 is “model_name->string_name”.

side2 side to search for string: -1 for left, 0 for left and right, 1 for right
The height of links in link_list are taken to be the height between str_name_1 and str_name_2.
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Height from Link
The height from link modifier is used to modify the height of fixed links originally defined by 
height to be the same height as another link. That is, the height of the link is a copy of the height 
of another link.

The format of the modifier to vary the height from link of the fixed links given by link_list is

copy_height link_list st_ch end_ch from_link zone extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
from_link name of link to take the height from
zone section of the template that the from_ link is from (i.e. fixed, cut or fill)
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Cross Fall
The xfall modifier is used to modify the cross fall of fixed links originally defined by xfall.

The format of the modifier to vary the cross-fall of the fixed links in the link_list is almost 
identical to varying the width and is:.

xfall link_list st_ch end_ch st_xfall end_xfall absrel type extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_xfall xfall to be used at the start modifier chainage, st_ch
end_xfall xfall to be used at the end modifier chainage, end_ch.
absrel relative (default) or absolute
type linear (default) or cubic
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage
If absrel is relative (the default) then

the st_xfall is added to the current xfall of links in link_list at chainage st_ch.
the end_xfall is added to the current xfall of links in link_list at chainage end_ch.

If absrel is absolute, then

the xfall of links in link_list are set to st_xfall at chainage st_ch.
the xfall of links in link_list are set to end_xfall at chainage end_ch.

If type is linear (the default), then the xfall of links in link_list are varied linearly (with respect to 
the reference chainage) between the xfall at chainage st_ch and chainage end_ch.

cubic, then the xfall of links in link_list are varied as a reverse cubic (with respect to the 
reference chainage) between the xfall at chainage st_ch and chainage end_ch.

rotate, then the angle of the xfall of the links in link_list is varied linearly (with respect to 
the reference chainage) between the angle of the xfall at chainage st_ch and chainage end_ch.
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The xfall of a link can be defined by using the xfall from the beginning of the link (i.e. the end of 
the previous link or the hinge string if it is the first link) to another 12d Model string, or by 
taking the xfall between two 12d Model strings.

xfall link_list st_ch end_ch full_string_name side extra_start extra_end
xfall link_list st_ch end_ch str_name_1 side1 str_name_2 side2 extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
full_string_name name of a 12d Model string to use to calculate xfall. The format of

 the string name is “model_name->string_name”.
side side to search for string: -1 for left, 0 for left and right, 1 for right
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage
str_name_1 name of the first 12d Model string. The format of the string name is

 “model_name->string_name”.
side1 side to search for string_1:

-1 for left, 0 for left and right, 1 for right

str_name_2 name of the second 12d Model string.

side2 side to search for string_2:
-1 for left, 0 for left and right, 1 for right

The xfall of links in link_list are taken to be the xfall between str_name_1 and str_name_2.

Cross Fall Circular Reverse Curve
The xfall_crc modifier is used to modify the cross fall of fixed links originally defined by xfall 
using the circular reverse curve formula.

The format of the modifier to vary the cross-fall of the fixed links (using circular reverse curves) 
in the link_list is:

xfall_crc link_list st_ch end_ch st_xfall end_xfall st_len end_len extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_xfall xfall to be used at the start modifier chainage, st_ch
end_xfall xfall to be used at the end modifier chainage, end_ch.
st_len length of the start circular arc to be used at the start modifier chainage, st_ch.
end_len length of the end circular arc to finish at the end modifier chainage, st_ch.
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Xfall from Link
The xfall from link modifier is used to modify the xfall of fixed links originally defined by xfall 
to be the same xfall as another link. That is, the xfall of the link is a copy of the xfall of another 
link.

The format of the modifier to vary the xfall from link of the fixed links given by link_list is
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copy_xfall link_list  st_ch end_ch from_link zone extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
from_link name of the link to take the xfall from
zone section of the template that the from_link is from (i.e. fixed, cut or fill)
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Important Note

The link to copy cross fall from can be defined in terms of cross fall or slope.
If the link to copy is defined by slope, then the cross fall is calculated to match the slope.

Tin Height
The tin height modifier is used to modify the height of the link so that the link will sit on the tin 
at the given width.

The tin height can only be used for a fixed link defined by width and height.

The format of the modifier to vary the tin height of the fixed links in the link_list is:

tin_height link_list st_ch end_ch tin_name extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
tin_name name of the tin to be used in defining the height.
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Tin Xfall
The tin xfall modifier is used to modify the xfall of the link so that the link will sit on the tin at 
the given width.

The tin xfall can only be used for a fixed link defined by width and xfall.

The format of the modifier to vary the tin xfall of the fixed links in the link_list is:

tin_xfall link_list st_ch end_ch tin_name extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
tin_name name of the tin to be used in defining the xfall.
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Please continue to the next section “Decision” .
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Decision
Each template is made up of the sections fixed, decisions, cut, fill and final cut/fill. If a template 
has a decisions section then by default it is used instead of the cut, fill and final cut/fill sections.

Hence by default, either the 
decisions section

 or 
the cut, fill and final cut/fill sections

from the template being used over the chainage range.

Using the decision modifier, it is possible to override the default and for a given chainage range 
use the cut, fill and final cut/fill sections instead of the decisions section

or
use the decisions section from another template instead of the current templates sections. 

The format of the decision modifier is

decision template_name st_ch end_ch optional

decision " " st_ch end_ch optional

where

template_name name of template to take the decision section from.

If the template name is given as " ", then the decision section for the template being used in the 
chainage range is ignored, and the cut, fill and final cut/fill tables for the template are used 
instead. Hence this overrides the default of using the decisions section in preference to the cut, 
fill and final cut/fill sections of the template.

st_ch start chainage for applying/removing the decision
end_ch end chainage for applying/removing the decision

and optional can be none, one or two of

extra_start optional - adds in an extra x-section 0.1 mm before start chainage
extra_end optional - adds in an extra x-section 0.1 mm before end chainage

Note

The full description of the decisions section of a template is given later in this chapter.

Please continue to the next section “Variable Link Modifiers” .

Variable Link Modifiers

Cut and Fill Width
The cut_width modifier is used to modify the width of variable cut links originally defined by 
width. Similarly the fill_width modifier is used to modify the width of variable fill links 
originally defined by width.

The format of the modifier to vary the width of the variable cut/fill links in link_list is

cut_width link_list st_ch end_ch st_wid end_wid absrel type extra_start   extra_end
fill_width link_list st_ch end_ch st_wid end_wid absrel type extra_start   extra_end

where
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link_list one or more names of cut/fill links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_wid width to be used at the start modifier chainage, st_ch
end_wid width to be used at the end modifier chainage, end_ch.
absrel relative (default) or absolute
type linear (default) or cubic
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

If absrel is relative (the default) then

the st_wid is added to the current width of links in link_list at chainage st_ch.
the end_wid is added to the current width of links in link_list at chainage
 end_ch.

If absrel is absolute, then

the width of links in link_list are set to st_wid at chainage st_ch.
the width of links in link_list are set to end_wid at chainage end_ch.

If type is linear (the default), then the width of links in link_list are varied linearly (with respect 
to the reference chainage) between the width at chainage st_ch and chainage end_ch.

If type is cubic, then the width of links in link_list are varied as a reverse cubic (with respect to 
the reference chainage) between the width at chainage st_ch and chainage end_ch.

The width for a variable link can also be varied by going out to another 12d Model string.

cut_width   link_list   st_ch   end_ch   full_string_name side extra_start   extra_end
fill_width   link_list   st_ch   end_ch   full_string_name side extra_start   extra_end

where

link_list one or more names of cut/fill links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
full_string_name name of a 12d Model string to take links in link_list out to. The

format of the string name is “model_name->string_name”.
side side to search for string: -1 for left, 0 for left and right, 1 for right
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

The width for a link can also be varied by using the width between two 12d Model strings 
str_name_1 and str_name_2.

cut_width link_list st_ch end_ch str_name_1 side1 str_name_2 side2 extra_start extra_end
fill_width link_list st_ch end_ch str_name_1 side1 str_name_2 side2 extra_start extra_end

Cut and Fill Width from Link
The cut and fill width from link modifiers are used to modify the width of cut and fill links 
originally defined by width, to be the same as another link. That is, the width of the link is a copy 
of the width of another link.

The format of the modifier to vary the cut and fill width from link of the fixed links given by 
link_list is
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copy_cut_width link_list st_ch end_ch from_link zone extra_start extra_end
copy_fill_width link_list st_ch end_ch from_link zone extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
from_link  name of the link to take the width from
zone section of the template that the from_link is from (i.e. fixed, cut or fill)
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Cut and Fill Height
The cut_height modifier is used to modify the height of variable cut links originally defined by 
height. Similarly the fill_height modifier is used to modify the height of variable fill links 
originally defined by height.

The format of the modifier to vary the height of the variable cut/fill links in link_list is

cut_height link_list st_ch end_ch st_ht end_ht absrel type extra_start extra_end
fill_height link_list st_ch end_ch st_ht end_ht absrel type extra_start extra_end

where

link_list one or more names of cut/fill links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_ht height to be used at the start modifier chainage, st_ch
end_ht height to be used at the end modifier chainage, end_ch.
absrel relative (default) or absolute
type linear (default) or cubic
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

If absrel is relative (the default) then

the st_ht is added to the current height of links in link_list at chainage st_ch.
the end_ht is added to the current height of links in link_list at chainage
 end_ch.

If absrel is absolute, then

the height of links in link_list are set to st_ht at chainage st_ch.
the height of links in link_list are set to end_ht at chainage end_ch.

If type is linear (the default), then the height of links in link_list are varied linearly (with respect 
to the reference chainage) between the height at chainage st_ch and chainage end_ch.

If type is cubic, then the height of links in link_list are varied as a reverse cubic (with respect to 
the reference chainage) between the height at chainage st_ch and chainage end_ch.

The height for a variable link can also be varied by taking the height from a 12d Model string.

cut_height   link_list   st_ch   end_ch   full_string_name side extra_start   extra_end
fill_height   link_list   st_ch   end_ch   full_string_name side extra_start   extra_end

where
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link_list one or more names of cut/fill links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
full_string_name name of a 12d Model string to take links in link_list out to. The

format of the string name is “model_name->string_name”.
side side to search for string: -1 for left, 0 for left and right, 1 for right
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

The height for a link can also be varied by using the height between two 12d Model strings 
str_name_1 and str_name_2.

cut_height link_list st_ch end_ch str_name_1 side1 str_name_2 side2 extra_start extra_end
fill_height link_list st_ch end_ch str_name_1 side1 str_name_2 side2 extra_start extra_end

Cut and Fill Height from Link
The cut and fill height from link modifiers are used to modify the height of cut and fill links 
originally defined by height, to be the same as another link. That is, the height of the link is a 
copy of the height of another link.

The format of the modifier to vary the cut and fill height from link of the fixed links given by 
link_list is

copy_cut_height link_list st_ch end_ch from_link zone extra_start extra_end
copy_fill_height link_list st_ch end_ch from_link zone extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
from_link name of the link to take the height from
zone section of the template that the from_link is from (i.e. fixed, cut or fill)
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage
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Cut and Fill Slope
The cut_slope modifier is used to modify the slope of variable cut links originally defined by 
slope. Similarly the fill_slope modifier is used to modify the slope of variable fill links originally 
defined by slope.

The format of the modifier to vary the cut/fill slope of the variable links in link_list is

cut_slope link_list st_ch end_ch st_slope end_slope absrel type extra_start extra_end
fill_slope link_list st_ch end_ch st_slope end_slope absrel type extra_start extra_end

where

link_list one or more names of cut/fill links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_slope slope to be used at the start modifier chainage, st_ch
end_slope slope to be used at the end modifier chainage, end_ch.
absrel relative (default) or absolute
type linear (default) or cubic
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

If absrel is relative (the default) then

the st_slope is added to the current slope of links in link_list at chainage st_ch.
the end_slope is added to the current slope of links in link_list at chainage
 end_ch.

If absrel is absolute, then

the slope of links in link_list is set to st_slope at chainage st_ch.
the slope of links in link_list is set to end_slope at chainage end_ch.

If type is linear (the default), then the slope of links in link_list is varied linearly (with respect to 
the reference chainage) between the slope at chainage st_ch and chainage end_ch.

cubic, then the angle of the slope of links in link_list are varied as a reverse cubic (with 
respect to the reference chainage) between the angle of the slope at chainage st_ch and chainage 
end_ch.

rotate, then the angle of the slope of the links in link_list are varied linearly (with respect 
to the reference chainage) between the angle of the slope at chainage st_ch and chainage end_ch.

The slope of a link can also be defined by using the slope from the beginning of the link (i.e. the 
end of the previous link or the hinge string if its the first link) to a given 12d Model string.

cut_slope   link_list   st_ch   end_ch   full_string_name side extra_start   extra_end
fill_slope   link_list   st_ch   end_ch   full_string_name side extra_start   extra_end

where

link_list one or more names of cut/fill links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
full_string_name name of a 12d Model string to use to calculate slope. The format of

 the string name is “model_name->string_name”.
side side to search for string: -1 for left, 0 for left and right, 1 for right
extra_start optional - adds in an extra x-section 0.1mm before start chainage
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extra_end optional - adds in an extra x-section 0.1mm before end chainage

The slope of a link can also be defined by using the slope between two 12d Model strings 
str_name_1 and str_name_2.

cut_slope link_list st_ch end_ch str_name_1 side1 str_name_2 side2 extra_start extra_end
fill_slope link_list st_ch end_ch str_name_1 side1 str_name_2 side2 extra_start extra_end

Cut and Fill Slope from Link
The cut and fill slope from link modifiers are used to modify the slope of cut and fill links 
originally defined by slope, to be the same slope or xfall as another link. That is, the slope of the 
link is a copy of the slope of another link.

The format of the modifier to vary the cut and fill slope from link of the fixed links given by 
link_list is

copy_cut_slope link_list st_ch end_ch from_link zone extra_start extra_end
copy_fill_slope link_list st_ch end_ch from_link zone extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
from_link name of the link to take the slope or xfall from
zone section of the template that the from_link is from (i.e. fixed, cut or fill)
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Important Note

The link to copy slope from can be defined in terms of slope or cross fall.
If the link to copy is defined by cross fall, then the slope is calculated to match the cross fall.
Hence this command can be used with cut and fill slopes to match to rotation of cross fall of fixed 
links for super-elevation. 

Cut and Fill Tin Height
The cut and fill tin height modifiers are used to modify the height of the link so that the link will 
sit on the tin at the given width.

The tin height can only be used for a cut or fill link defined by width and height.

The format of the modifiers to vary the cut and fill tin height of the links in the link_list are:

tin_cut_height link_list st_ch end_ch tin_name extra_start extra_end
tin_fill_height link_list st_ch end_ch tin_name extra_start extra_end

where

link_list one or more names of cut/fill links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
tin_name name of the tin to be used in defining the height.
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage
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Cut and Fill Tin Slope
The cut and fill tin slope modifier is used to modify the slope of the link so that the link will sit 
on the tin at the given width.

The cut and fill tin slope can only be used for a cut/fill link defined by width and slope.

The format of the modifiers to vary the cut and fill tin slope of the links in the link_list are:

tin_cut_slope link_list st_ch end_ch tin_name extra_start extra_end
tin_fill_slope link_list st_ch end_ch tin_name extra_start extra_end

where

link_list one or more names of fixed links given in the template definition; with format
name1 name2 ... namei

st_ch start chainage for the modifier
end_ch end chainage for the modifier
tin_name name of the tin to be used in defining the slope.
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Please continue to the next section “Final Link Modifiers” .

Final Link Modifiers

Final Width
The format of the modifier to vary the width of the final cut and fill link link_name is

final_width link_name st_ch end_ch st_wid end_wid absrel type extra_start extra_end

where

link_name name of final link given in the template definition
st_ch start chainage for the modifier
end_ch end chainage for the modifier
st_wid width to be used at the start modifier chainage, st_ch
end_wid width to be used at the end modifier chainage, end_ch.
absrel relative (default) or absolute
type linear (default) or cubic
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

If absrel is relative (the default) then

the st_wid is added to the current width of link_name at chainage st_ch.
the end_wid is added to the current width of link_name at chainage end_ch.

If absrel is absolute, then

the width of link_name is set to st_wid at chainage st_ch.
the width of link_name is set to end_wid at chainage end_ch.

If type is linear (the default), then the width of link_name is varied linearly (with respect to the 
reference chainage) between the width at chainage st_ch and chainage end_ch.

If type is cubic, then the width of link_name is varied as a reverse cubic (with respect to the 
reference chainage) between the width at chainage st_ch and chainage end_ch.

Final Cut and Fill Slope
The format of the modifier to vary the cut/fill slope of the final link link_name is
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final_cut_slope link_name st_ch end_ch st_slope end_slope absrel type ext_st ext_end
final_fill_slope link_name st_ch end_ch st_slope end_slope absrel type ext_st ext_end

where

link_name name of final link given in the template definition

st_ch start chainage for the modifier
end_ch end chainage for the modifier

st_slope slope to be used at the start modifier chainage, st_ch
end_slope slope to be used at the end modifier chainage, end_ch.

absrel relative (default) or absolute
type linear (default) or cubic

ext_st optional - adds in an extra x-section 0.1mm before start chainage
ext_end optional - adds in an extra x-section 0.1mm before end chainage

If absrel is relative (the default) then

the st_slope is added to the current slope of link_name at chainage st_ch.

the end_slope is added to the current slope of link_name at chainage end_ch.

If absrel is absolute, then

the slope of link_name is set to st_slope at chainage st_ch.

the slope of link_name is set to end_slope at chainage end_ch.

If type is linear (the default), then the slope of link_name is varied linearly (with respect to the 
reference chainage) between the slope at chainage st_ch and chainage end_ch.

cubic, then the angle of the slope of link_name is varied as a reverse cubic (with respect 
to the reference chainage) between the angle of the slope at chainage st_ch and chainage end_ch.

Stopping Final Cut and Fill Slope
The final link can be stopped altogether in either cut or fill.

The format of the modifier to stop the cut/fill slope of the final link link_name is

final_no_cut_slope   link_name   st_ch   end_ch   extra_start   extra_end
final_no_fill_slope    link_name   st__ch   end_ch   extra_start   extra_end

where

link_name name of final link given in the template definition
st_ch start chainage for the final link to stop
end_ch end chainage for the final link to stop
extra_start optional - adds in an extra x-section 0.1mm before start chainage
extra_end optional - adds in an extra x-section 0.1mm before end chainage

Please continue to the next section “A Template Modifier File Example” .

A Template Modifier File Example
left_side   =   {
    -99999.9      “std”
     99999.9

}

right_side   =   {
   -99999.9      “std”
    99999.9

}
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// -- assumes ---

left_side_modifier   =   {

    width   “kerb”   103   203.0   0.0   3.0   absolute linear// widen from width 0 to width 3 - linear
    width    “kerb”   203.0   303.0   3.0   3.0   absolute // keep width at 3
    width   “kerb”   303.0   403.0   3.0   0.0   absolute // widen from width 3 to width 0 - linear
    width   “kerb”   153.0   253.0   0.0   9.0   cubic   relative
    width   “kerb”   253.0   353.0   9.0   0.0   cubic // relative is default
    xfall   “kerb”    53.0   153.0   0.0   6.0   relative   linear
    xfall    “kerb”   153.0   353.0   6.0   6.0   relative // linear
    xfall    “kerb”   353.0   453.0   6.0   0.0 // relative & linear
    width    “kerb”   440.0   480.0   “table drain->table drain”   extra_start   extra_end
    xfall    “kerb”   440.0   480.0   “table drain->table drain”   extra_start   extra_end
    width   “kerb”   440.0   480.0   1.0   1.0   relative
    cut_width   “a”   103.0   203.0    0.0    9.0
    cut_width   “a”   203.0   303.0    9.0    9.0
    cut_width   “a”   303.0   403.0    9.0    0.0
    cut_slope   “a”   103.0   203.0    0.0    3.0
    cut_slope   “a”   203.0   303.0    3.0    3.0
    cut_slope   “a”   303.0   403.0    3.0    0.0
    cut_width   “a”   500.0   520.0   “table drain->table drain”   extra_start   extra_end
    cut_slope   “a”   500.0   520.0   “table drain->table drain”   extra_start   extra_end

    fill_width   “a”   103.0   203.0    0.0   9.0
    fill_width   “a”   203.0   303.0    9.0    9.0
    fill_width   “a”   303.0   403.0    9.0    0.0
    fill_slope   “a”   103.0   203.0    0.0    3.0
    fill_slope   “a”   203.0   303.0    3.0    3.0
    fill_slope   “a”   303.0   403.0    3.0    0.0
    fill_width   “a”   560.0   610.0   “table drain->table drain”   extra_start   extra_end
    fill_slope   “a”   560.0   610.0   “table drain->table drain”   extra_start   extra_end
    final_width   “final”   103.0   403.0    100.0    50.0
    final_cut_slope    “final”   103.0   403.0    0.0   3.0
    final_fill_slope    “final”    103.0   403.0    0.0   2.0
    final_no_cut_slope    “final”   190.0   310.0    extra_start    extra_end
    final_no_fill_slope     “final”   190.0   310.0    extra_start    extra_end
}

right_side_modifier = {

}

Stripping File Format
The stripping depth is given in the many templates file (*.mtf) and is similar to the format for 
applying templates except there is no separate left and right side.

The stripping definition begins with the key words

stripping   = 

A list of chainages (in ascending order, one per line) with corresponding stripping depth then 
follows. The list of chainages and stripping depths is enclosed in curly braces {}.
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The chainage-stripping lists are assembled as follows

(a) to represent a stripping depth starting at a given chainage, the chainage value followed by 
the stripping depth is given. The chainage and stripping depth are separated by one or 
more spaces. For example, the stripping depth 0.03 starting at chainage 150 is represented 
by

150 0.03

The stripping depth is assumed to apply until the chainage given on the next line of the 
stripping definition.

If the stripping depth is to go to the end of the reference string, add a line with a chainage 
greater than or equal to the end chainage. For example

150 0.03
9999 0.0

Warning - unlike applying templates, a stripping depth must exist after a chainage, 
however the stripping depth can be zero.

(b) linearly varying stripping depth between chainages is represented by giving the start 
chainage for the variation followed on the same line by the start depth and the end depth 
separated by a comma.

The linear change takes place over the interval beginning at this chainage and ending at the 
chainage given on the next line of the stripping definition.

For example, to linearly vary the stripping depth from 0.02 to 0.03 between the chainages 
350 and 500, use

350 0.02 , 0.03
500 0.03

A Stripping Example
An example of a stripping command is

stripping = {

-999 0.03

30 0.0

70 0.03,0.05

110.5 0.05

999 0.05

}

Boxing File Format
Apart from a key word specifying whether the following part of the definition is for the left or 
the right, the set out for the left boxing is identical to the right boxing. Hence only the left boxing 
will be described in detail.

The left boxing definition begins with the key words

left_boxing =

A list of chainages (in ascending order, one per line) with corresponding boxing names then 
follows. The list of chainages and boxing is enclosed in curly braces { }.

The chainage-boxing lists are assembled as follows

(a) to represent a boxing starting at a given chainage, the chainage value followed by the 
boxing name is given. The chainage and boxing name are separated by one or more spaces. 
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For example, the boxing left starting at chainage 150 is represented by

150 left

The boxing is assumed to apply until the chainage given on the next line of the left_boxing 
definition.

(b) if no boxing exists from a chainage, simply include the chainage with no boxing name 
following it. For example, if there is no boxing from chainage 250, this is represented by

250

The non-existence of boxing is assumed until the chainage given on the next line of the 
left_side definition.

If the boxing is to go to the end of the reference string, add a line with a chainage greater 
than or equal to the end chainage. For example

150 left
9999

When using the apply many option, the name of the boxing definitions file is given by a 
boxing_file command in the many templates file.

boxing_file = boxing_definitions_file

When using the boxing many option, if a file name is given in the boxing file panel field, it is 
used for the boxing definitions file, otherwise the boxing_file command in the many templates 
file is used.

Note - if the boxing name includes spaces, then the name must be enclosed in quotes “. For 
example, “left 1".

An Applying Boxing Example
boxing_file =  “boxing_for_client.bf”

left_boxing  = {

-999 left
30
70 “left narrow”
110.5 left
999

}

right_boxing = {

-999 right
30
70 “right narrow”
110.5 right
999

}

Warning - no interpolation or modifiers exist for boxing.

Width File Format
The format for section width in the mtf file is simply

section_width = value // default is 10000

where value is the distance to search from the hinge string for strings required in some options. If 
section_width is missing, then it takes the default value of 10000.
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For example

section_width = 100.0

String Modifiers File Format
In the many templates file, the string modifiers definition begins with the key word

string_modifiers  = 

followed by one or more occurrences of the string modifier command height enclosed by curly 
braces { })

The definition of the string modifier commands will now be given.

Height
The height the Height string modifier calculates for the amend point is given by:

(a) if the absolute flag is not set, the height of the hinge point, otherwize zero.

plus

(b) the interpolated height for the user given heights at the start and end chainages

plus

(c) the interpolated height for the user given cross falls at the start and end chainage.

That is, if the absolute flag is not set:

 new height = hinge height + (interpolated height) + (interpolated xfall) x (offset distance)

If the absolute flag is set:

 new height = (interpolated height) + (interpolated xfall) x (offset distance)

The format of the Height string modifier is

height amend_str ref_str hinge_str st_ch end_ch ch_int st_xfall end_xfall st_ht end_ht  absolute

where
amend_str name of a 12d Model string to take the hinge point out to. The

format of the string name is “model_name->string_name”.
ref_str name of reference string. The format of the string name is

“model_name->string_name”.
hinge_str name of hinge string. The format of the string name is

“model_name->string_name”.
st_ch start chainage for the modifier
end_ch end chainage for the modifier
ch_int interval between chainage points - can be the word null

st_xfall xfall to be used at the start modifier chainage, st_ch
end_xfall xfall to be used at the end modifier chainage, end_ch.
st_ht height to be used at the start modifier chainage, st_ch
end_ht height to be used at the end modifier chainage, end_ch.
absolute optional - if it exists, include the height of the hinge string
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Height and Two Strings
The height the Height 2x string modifier calculates for the amend point is given by:

(a) the height of the hinge point

plus

(b) the offset distance multiplied by the cross fall between two user selected strings.

 new height = hinge height + (xfall between string 1 and string 2) x (offset distance)

The format of the Height 2x string modifier is

height amend_str ref_str hinge_str st_ch end_ch ch_int xfall_str1 xfall_str2

where
amend_str name of a 12d Model string to take the hinge point out to. The

format of the string name is “model_name->string_name”.
ref_str name of reference string. The format of the string name is

“model_name->string_name”.
hinge_str name of hinge string. The format of the string name is

“model_name->string_name”.
st_ch start chainage for the modifier
end_ch end chainage for the modifier
ch_int interval between chainage points - can be the word null

xfall_str_1 name of first string to calculate cross fall between. The format of the string name
is “model_name->string_name”.

xfall_str_2 name of second string to calculate cross fall between. The format of the string
name is “model_name->string_name”.
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Substitutions in the Many Templates File
The many template variables are special variables standing for information about the reference 
string used in the apply many operation.

The many template variables are only evaluated when the many template file is used in an apply 
many operation and provide a mechanism to generalize the many template file.

The many template file also recognizes the CCCP preprocessor rules including #include, #define, 
#if etc.

Many Template Variables
The list of the many template variables is:

$tangent_curve_n chainage of the tangent curve point for the nth HIP
$tangent_spiral_n tangent spiral
$curve_spiral_n curve spiral
$spiral_curve_n spiral curve
$curve_spiral_n curve spiral
$spiral_tangent_n spiral tangent
$curve_tangent_n curve tangent

 
$start_spiral_n length of the start spiral on the nth HIP point
$end_spiral_n length of the end spiral
$radius_n absolute radius of the curve

$signed_radius_n signed radius of the curve

$vertical_tangent_curve_n chainage of the tangent curve point for the nth VIP

$vertical_curve_tangent_n chainage of the curve tangent point for the nth VIP

$vertical_sag_n chainage of the sag point for the nth HIP

$vertical_crest_n crest

$vertical_crest_sag_n crest or sag

For example, 

$tangent_spiral_3      get the chainage for the tangent spiral on HIP 3.

The variables can be used in expressions with the arithmetic operations +, -, * and / as long as 
the expression is surrounded by round brackets ( ).

For example, in the width command:

width E ($tangent_spiral_2 - 50) ($tangent_spiral_2 + 50) 3 5 absolute

the expression ($tangent_spiral_2 - 50) will yield the chainage of fifty metres before the tangent 
spiral point of the second HIP point.

The variables can also be used in #define’s and #include’s according to the following CCCP 
rules.

(a) #define NAME Expansion of NAME

if the #define is longer than one line, the backslash character \ is added to the end of each 
line that has another line of the #define following to indicate that the #define continues to 
the next line.
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(b) #define can be used to define a block of things with more than one argument

For example,

#define SUPER(name,ip,xf1,xf2) \

\
xfall name START_TAPER(ip) xf1 xf2 absolute \
xfall name FIXED_TAPER(ip) xf2 xf2 absolute \
xfall name END_TAPER(ip) xf2 xf1 absolute

means that SUPER("EB",3,-3.0,3.0) will be expanded to the three lines:

xfall "EB" START_TAPER(3) -3.0 3.0 absolute
xfall "EB" FIXED_TAPER(3) 3.0 3.0 absolute
xfall "EB" END_TAPER(3) 3.0 -3.0 absolute

Note that \  is used to indicate that the #define continues to the next line.

(c) (if (express) {expression1 } else {expression 2})

is an expression express, which evaluates to
if express is true, then the value of the expression is expression1 otherwize expression 2. 

(d) word##p 

is equivalent to wordp

(e) #include file_name 

A number of #defines can be placed in a file and included in the mtf by using the #include.

As an example combining the above rules, the meaning of

 LEADING_TAPER_START(2)

given by the following $define:

#define LEADING_TAPER_START(ip) ( if($radius_##ip < 75) {$tangent_spiral_##ip - 50)\
else { $tangent_spiral_##ip - 75 } )

is

if the radius of the second HIP is less than 75, then set LEADING_TAPER_START(2) to the 
chainage of the tangent spiral point of the second HIP point, less fifty metres, otherwize 
LEADING_TAPER_START(2) is set to the chainage of the tangent spiral point of the second 
HIP point, less seventy five metres

A more complicated example now follows which shows how #defines can be used to easily 
apply super-elevation according to rules involving leading and trailing spirals.

// ---------------------------------------------------
#define LEADING_TAPER_START(ip)    ( if($radius_##ip < 75)\
 { $tangent_spiral_##ip - 50 } else { $tangent_spiral_##ip - 75 })

// Note: LEADING_TAPER_START evaluates to a chainage.

#define LEADING_TAPER_END(ip)    ( if($radius_##ip < 75)\
 { $tangent_spiral_##ip + 10 } else { $tangent_spiral_##ip + 25 })

// Note: LEADING_TAPER_END evaluates to a chainage.

#define TRAILING_TAPER_START(ip) ( if($radius_##ip < 75)\
 { $spiral_tangent_##ip - 10 } else { $spiral_tangent_##ip - 25 })

// Note: TRAILING_TAPER_START evaluates to a chainage.

#define TRAILING_TAPER_END(ip)   ( if($radius_##ip < 75)\
 { $spiral_tangent_##ip + 50 } else { $spiral_tangent_##ip + 75 })
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// Note: TRAILING_TAPER_END evaluates to a chainage.

#define START_TAPER(ip) LEADING_TAPER_START(ip)\
LEADING_TAPER_END(ip)

// Note: START_TAPER evaluates to two chainages:  chainge1 chainage2.

#define FIXED_TAPER(ip) LEADING_TAPER_END(ip)\
TRAILING_TAPER_START(ip)

// Note: FIXED_TAPER evaluates to two chainages:  chainge1 chainage2.

#define END_TAPER(ip)   TRAILING_TAPER_START(ip)\
TRAILING_TAPER_END(ip)

// Note: TRAILING_TAPER evaluates to two chainages:  chainge1 chainage2.

#define SUPER(name,ip,x1,x2) \
\

xfall name START_TAPER(ip) x1 x2 absolute \
xfall name FIXED_TAPER(ip) x2 x2 absolute \
xfall name END_TAPER(ip)   x2 x1 absolute

With the above #defines, SUPER evaluates to three lines of xfall template modifiers which rotates 
cross-fall, keeps it constant and then counter-rotates the cross-fall about leading and trailing 
spirals for an HIP point.

For example, 

SUPER(EB,2,-3,3)

would give expand to the following three lines of xfall commands for link EB which will rotate 
xfall from -3 to 3, hold it at 3 and then rotate it back form 3 to -3, all about the leading and trailing 
spirals for horizontal intersection point number two:

xfall EB begin_chainage_for_start_taper end_chainage_for_start_taper -3 3 absolute
xfall EB begin_chainage_for_fixed_taper end_chainage_for_fixed_taper_ch 3 3 absolute
xfall EB begin_chainage_for_end_taper end_chainage_for_end_taper 3 -3 absolute

The above definitions of SUPER could be placed in a file, say

 f:\12d\12dmodel\library\super_mtf.def

and then simply included into a mtf file using the a #include:

#include  f:\12d\12dmodel\library\super_mtf.def
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Examples of Substitutions in the Many Templates File
The following example shows how #defines can be used to easily apply super-elevation 
according to rules involving leading and trailing spirals.

The definition of SUPER is given in the file, f:\12d\12dmodel\library\super_mtf.def, which is 
simply included in the mtf file using a #include.

// ----------------------------------------------------------------
// include the file containing the definition of SUPER
// ----------------------------------------------------------------

#include "f:\12d\12dmodel\library\super_mtf.def"

// ----------------------------------------------------------------
// apply templates left and right and then modifier them
// -----------------------------------------------------------------

left_side = {
-999999 std
999999

}

right_side = {
-999999 std
999999

}

specials = {
}

hinge_modifier = {
}

left_side_modifier = {
// linearly widen the link EB by 12 metres and bring it back
// in again.

width EB ($tangent_spiral_2 - 50) ($tangent_spiral_2 + 50) 0 12
width EB ($tangent_spiral_2 + 50) ($spiral_tangent_7 - 50) 12 12
width EB ($spiral_tangent_7 - 50) ($spiral_tangent_7 + 50) 12 0

// define superelevation 

 SUPER(EB,2,-3,3)
 SUPER(EB,4,-3,3)
 SUPER(EB,5,-3,3)
 SUPER(EB,6,-3,3)
}

right_side_modifier = {

 SUPER(EB,3,-3,3)
 SUPER(EB,7,-3,3)
}
stripping = {
}
//boxing_file = "yourfile.bf"
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left_boxing = {
}
right_boxing = {
}
string_modifiers = {
}
//section_width = 10000.0
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Full Definition of Boxing
Defining and applying boxing is similar to applying templates.

First there needs to be a file defining the boxing across a section (the boxing definition file, 
ending in .bf) and then there are commands for applying the boxing definitions along the 
reference string.

The boxing can be applied using any of the commands

(a) apply many
(b) boxing
(c) boxing many.

For the apply many command, the boxing is defined in terms of the string names from the 
applied templates (after the LHS and RHS prefix adjustments).

For both the boxing and boxing many commands, the boxing is applied to a model of 4d strings 
representing x-sections across the whole road.

These labelled 4d strings can be generated by either

(a) cuts through strings

(b) apply many with the flag “sections as 4d” set

and the text at each point in the 4d string (point text) is the name of the string that the section 
cuts through at that point.

For the boxing to work properly, the string names created by the apply many, or the point names 
across the 4d string, must be unique for that section.

Note - in an apply many, the LHS, RHS prefix flag can be used to give strings different names 
even when the same template is used on the left and the right side.

Boxing sections are generated by the apply many, boxing and boxing commands but boxing 
strings are only generated by the apply many command. For the other cases, the option 
Strings=>Utilities=>Strings from sections can be used to create the boxing strings from the boxing 
sections.

Boxing Definitions
Boxing is defined by a series of commands going from left to right across the points of a cross 
section. (Cross sections are generated as 4d strings or super strings by options such as apply and 
cuts).

The definitions of boxing cross sections are set up in a file ending in .bf (called the boxing file) 
and any number of boxing definitions can be placed in the boxing file as long as each boxing 
definition is given a unique name.

The boxing file can be created with an editor or interactively from within 4d.
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The interactive definition will now be described and the definition of the actual commands 
written to the file will be given later.

The boxing commands apply from the offset specified at the beginning of that command (start 
offset for the command) to the start offset of the next boxing command (like chainages and 
templates in the mtf). Hence the end offset for a command is the start offset of the following 
command in the file.

The offsets can be fixed values or can be specified relative to a point name on the super string or 
4d string representing the x-section. One restriction is that all the points mentioned in a boxing 
definition, must be present in each x-section the boxing definition is applied to.

The terminology used to specify an offset relative to a point name is "relative point offset" and is 
defined to be the offset at a given named point on the cross section, plus a given offset value.

That is

take the offset at the 4d point or super string point called "point name" and add "offset 
value" to it (the offset value can be positive of negative).

If the "point name" is blank, then the "offset value" is taken to be the actual offset on the super 
string.

Hence the offset can be specified as either an actual offset value or given relative to the name of a 
a point on the super string (relative offset). For convenience, the offset will be denoted by 
relative point offset.

The major advantage of defining boxing in terms of point names is that whenever the points are 
modified using template modifiers, the boxing across the section is also automatically modified.

A boxing definition may be used in either a left_boxing or right_boxing mtf command (see the 
section, creating boxing), however unlike the case for templates, the boxing definition is applied 
to the point names going from left to right regardless of whether the boxing definition is used on 
the left or the right.

In practice, the definitions for left and right boxing are usually different because of the necessity 
of having unique point names across the entire cross section.

Vertical Walls
If a boxing definition creates two different height values at the one offset (i.e. a wall), then extra 
offset points are automatically inserted into the boxing x-section (at 0.1 mm from the previous 
point) so that no points are on top of each other.

So in effect a vertical wall is created but since no points are created that are directly above each 
other, the data can be triangulated.

Please continue to the next section “Edit Boxing File” .
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Edit Boxing File
edit_boxing_definitions

The option Design =>Boxing =>Create creates a boxing definition file and then brings up the Edit 
Boxing Definitions panel to create the actual boxing definitions (rules) to save in the boxing 
definitions file.

Similarly selecting a boxing file from the walk-right list of Design =>Boxing =>Edit also brings up 
the Edit Boxing Definitions panel to create/edit boxing definitions from the selected definitions 
file.

The Edit Boxing Definitions panel is

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Boxing definition input boxing definitions in file

name of the boxing definition (in the current boxing file) to create or edit.

Create button

create a boxing definition with name given by the boxing definition panel field
If the boxing definition given in the boxing definition field does not exist, then the boxing rules panel 
is placed on the screen and is used to created the new boxing definitions for the boxing file.
If the boxing definition already exists, then nothing will happen on selecting create.

Edit button

edit an existing boxing definition with name given by the boxing definition panel field
If the boxing definition given in the boxing definition field exists, then the boxing rules panel is placed 
on the screen and is used to edit the existing boxing definitions for the boxing file.
If the boxing definition does not exist exists, then nothing will happen on selecting edit.

Delete button

delete an existing boxing definition with name given by the boxing definition panel field
A yes-no panel confirms the deletion.

Save file button

save the boxing file with the boxing definitions to disk.

For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

boxing_rules_for

Selecting the Create or Edit button brings up the Boxing Rules panel which is used to build up the 
boxing definition from the rules described in the following sections.
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 The Boxing Rules panel consists of a scrolling command field, LHS and RHS xfall buttons, LHS 
and RHS slope fields, LHS and RHS copy tick box boxes and an OK or Apply button to record the 
results. The Commands and the LHS xfall and RHS xfall options will be described separately

The other fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Commands Scrolling table

commands for defining the boxing. The commands will be described in the next section.

Left Hand Side

LHS Xfall button

brings up the LHS Xfall panel which is described in the later section “LHS Xfall” .

or

LHS slope input

If non-zero, a batter with the given slope is applied to the left at the beginning of the boxing and goes 
until it intersects the design section. The intersection point is added as the first point in the boxing. If 
no intersection is made, nothing is added to the boxing. A positive slope is up and negative down.

LHS copy tick box

if tick, then the design section from the beginning of the design section to the beginning of the boxing 
section is copied to the beginning of the boxing section. Hence the LHS copy flag is used to begin the 
boxing section with the start of the design section (a full width left side boxing section).

If not tick, nothing is done

Right Hand Side

RHS Xfall button



12d Model Reference Manual

Page 2948 May 2007Full Definition of Boxing

brings up the RHS Xfall panel which is described in the later section “RHS Xfall” .

or

RHS slope input

if non-zero, a batter with the given slope is applied to the right at the right end of the boxing and goes 
until it intersects the design section. The intersection point is used as the next point in the boxing. If no 
intersection is made, nothing is added to the boxing. A positive slope is up and negative down.

RHS copy tick box

if tick, then the design section from the from the last boxing point to the last point on the design section 
is copied to the end of the boxing section. Hence the RHS copy flag is used to continue the boxing 
section from the intersection point with the design section to the end of the design section (a full width 
right side boxing section).

If not tick, nothing is done

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Notes
1. The Left xfall command takes precedence over the Left slope command. That is, if both 

commands exist then only the Left xfall command is used. Both Left xfall and Left slope can be 
missing. Similarly for the Right xfall and Right slope commands.

2. When a boxing definition is applied on the left side in the mtf, any Right xfall, Right slope or 
Right copy is ignored. Similarly, when a boxing definition is applied on the right side in a mtf, 
any Left xfall, Left slope or Left copy is ignored.

Hence a boxing definition can have all of Left xfall, Left slope, Left copy, Right xfall, Right slope 
and Right copy but which set is used depends on whether the boxing definition is used on the 
left or the right.

When the Boxing panel is used to create the boxing it is applied to a complete section at once 
so only one boxing definition is needed and all of the Left xfall, Left slope, Left copy, Right xfall, 
Right slope and Right copy commands are used.

For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

boxing_rule_create

Commands for Boxing Rules Panel
If the command line is empty, clicking LB in the command line will bring up the Create menu which 
contains all the available boxing commands.

Selecting a menu item will bring up an associated panel which displays the information required 
for the modifier command.

When the panel is filled in and OK or Apply selected, the panel information is written out to the 
command line in the correct format for that modifier command.

If the command line is not empty, clicking LB in the command line will bring up the associated 
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panel for the modifier command in the command line.

The information in the panel can be changed and if OK or Apply is selected, the changed panel 
information is written out to the command line in the correct format for that modifier command.

Each of the panels created by selecting a command from the Create menu, will now be 
described. For reference purposes, the typed format of the command will be given for each panel 
although the typed format will not be described until later in the manual.

For documentation on the option/menus on the boxing Create menu:

for Copy, go to the section “Copy” .

X-fall “Xfall - line through a point with a given crossfall” .
 X-fall 1 “Xfall 1 - line through a point with a crossfall taken from a point” .
 Line  “Line - line through two points” .
 End “End” .

For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

The text file definition of the boxing file is given in the section “Format of Boxing Definitions 
File” 

boxing_copy

Copy

The Copy command copies the links of the template (or parts of links) from the start offset (the 
offset of the given point plus the given point offset value), to the start offset of the next boxing 
command, keeping the present slope of each link but adjusting the height of each link by height. 
Height may be zero.

Selecting the copy option brings up the boxing copy panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Point offset start offset of next command

Height
Point

start offset

Copy Option
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Point name input

name of the point on the cross section (when adjusted by "point offset") to start the copy at.

Point offset input null

offset from the point given in the point name field.

Height input 0

Height to adjust the links of the template being copied.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

The typed formats of the copy and copy with height adjustment commands created by this 
panel are:

point_name + point_offsetcopy

and

point_name + point_offset,copy, delta_height

For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

boxing_xfall

Xfall - line through a point with a given crossfall

The Xfall command creates a link from the start offset (the offset of the given point plus the given 
Point offset), to the start offset on the next boxing command, with a

(a) user given cross fall (Xfall)

(b) start height given by projecting to the start offset, the line with a given xfall and going 
through a given control point.

Selecting the xfall option brings up the boxing xfall panel

Point

Control

Point offset

start offset start offset of next command

relative control offset

height

control point the line
goes through

Xfall Option

cross fall Xfall
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Point name input

name of the point on the cross section (when adjusted by point_offset) to start the line from.

Point offset input null

offset from the point given in the point name field.

Control name/offset/heightinput

the control point that the line goes through has: 
offset of (control_name + control_offset)
height of the above point on the template, + control_height

Xfall input 0

crossfall of the line going through the control point.

OK/Apply button
OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

The typed formats of the xfall commands created by this panel is:

point_name + point_offset, xfall, control_name + control_offset, control_height, xfall

For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

boxing_xfall_1

Xfall 1 - line through a point with a crossfall taken from a point

The Xfall 1 command creates a link from the start offset (the offset of the given point plus the 
given Point offset), to the start offset on the next boxing command, with a

(a) a cross fall which is the cross fall at a given point plus an additional cross fall (Xfall delta)

(b) start height given by projecting to the start offset, the line with the specified cross fall and 
going through a given control point.
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Selecting the Xfall 1 option brings up the Boxing Xfall 1 panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Point name input

name of the point on the cross section (when adjusted by point_offset) to start the line from.

Point offset input null

offset from the point given in the point name field.

Control name/offset/heightinput

the control point that the line goes through has: 
offset of (control_name + control_offset)
height of the above point on the template, + control_height

Xfall name/offset input

the crossfall is taken from the point on the template which has the 
offset of (control_name +  control_offset)

Xfall delta input 0

adjust the crossfall at the xfall point by the xfall_delta.

OK/Apply button

OK stores the values in the fields and removes the panel.

Point

Control

Point offset

start offset
start offset of next command

relative control offset

height

control point the line
goes throughXfall 1 Option

cross fall as at

Xfall delta

relative xfall offset

relative xfall offset
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Apply stores the values and leaves the panel on the screen.

For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

The typed formats of the xfall1 commands created by this panel is:

point_name + point_offset, xfall1, control_name + control_offset, control_height,
xfall_name + xfall_offset, xfall_delta

boxing_line

Line - line through two points
The Line command creates a line from the start offset (the offset of the given point plus the given 
Point offset value), to the start offset of the next boxing command, with a

(a) slope given by two points

(b) start height given by projecting to the start offset, the line through the two points.

The first point defining the line has the offset of "Point 1" plus the given "Point 1 offset" and a 
height given by the height of the design x-section at the offset adjusted by "Point 1 height".

The second point defining the line has the offset of "Point 2" plus the given "Point 2 offset" and a 
height given by the height of the design x-section at the offset adjusted by "Point 2 height".

Selecting the line option brings up the boxing line panel

The fields and buttons used in this panel have the following functions.

relative offset 1

Point

Point 2

Point 1

Point offset

start offset start offset of next command

relative offset 2

height

height

second point the line
goes through

first point the line
goes through

Line Option
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Field Description Type Defaults Pop-Up

Point name input

name of the point on the cross section (when adjusted by point_offset) to start the line from.

Point offset input null

offset from the point given in the point name field.

Point 1 name/offset/height input

the first point that the line goes through has: 
offset of (point_1 + point_1_offset)
height of the above point on the template + point_1_height

Point 2 name/offset/height input

the second point that the line goes through has: 
offset of (point_2 +  point_2_offset)
height of the above point on the template + point_2_height

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

The typed format of the line commands created by this panel is (all on one line):

point_name + point_offset,line, point_1_name + point_1_offset,delta_height_1,
point_2_name + point_2_offset,delta_height_2

boxing_end

End
Selecting the end option brings up the boxing end panel

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Point name input

name of the point on the cross section (when adjusted by point_offset) to finish the previous command 
at.

Point offset input null

offset from the point given in the point name field.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.
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For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

The typed format of the line commands created by this panel is:

point_name + point_offset, end

boxing_lhs_xfall_for

LHS Xfall

The LHS Xfall command creates a line from the left hand end of the boxing already defined and 
then batters to the left at a specified cross fall until it intersects the design surface. The cross fall 
of the batter is defined as

(a) the cross fall at the relative xfall offset (the offset at the given point "Point name" plus "Xfall 
offset")

plus
(b) the additional cross fall value "Xfall delta"

If the design surface is not intersected, then no extra line is created.

If Copy is toggle on in the Left Hand Side section of the Boxing Rules panel, then the part of the 
design section from beginning of the design section to the LHS cross fall intersection point is 
copied to the start of the boxing section.

In the left xfall command, the xfall is percent cross-fall and a positive xfall is up and negative 
down.

Note that the LHS xfall command creates a line at the beginning of the boxing. It is actually 
applied after all the other boxing commands have been run.

Selecting the LHS xfall button on the boxing rules panel brings up the Boxing LHS Xfall panel

The fields and buttons used in this panel have the following functions.

left hand end of boxing surface

design surface

LHS Xfall Option

already defined

relative xfall offset

cross fall as at
relative xfall offset

intersection of the line
with the design surface

end of boxing is at the

boxing surface already defined

Xfall delta
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Field Description Type Defaults Pop-Up

Xfall name/offset input

the crossfall is taken from the point on the template which has the 
offset of Xfall_name + xfall_offset

Xfall delta input 0

adjust the crossfall at the xfall point by the value Xfall_delta.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

The typed formats of the left_xfall commands created by this panel is:

left_xfall, xfall_name + xfall_offset, xfall_delta

boxing_rhs_xfall_for

RHS Xfall

The RHS Xfall command creates a line beginning at the right hand end of the boxing already 
defined and then batters to the right at a specified cross fall until it intersects the design surface. 
The cross fall of the batter is defined as

(a) the cross fall at the relative xfall offset (the offset at the given point "Point name" plus "Xfall 
offset")

plus
(b) the additional cross fall value "Xfall delta"

If the design surface is not intersected, then no extra line is created.

If Copy is toggle on in the Right Hand Side section of the Boxing Rules panel, then the part of the 
design section from the RHS cross fall intersection point to the last point of the design section is 
copied to the end of the boxing section.

In the right xfall command, the xfall is percent cross-fall and a positive xfall is up and negative 
down.

Selecting the RHS xfall button on the boxing rules panel brings up the Boxing RHS Xfall panel

Xfall delta

right hand end of boxing surface

design surface

RHS Xfall Option

already defined

relative xfall offset

cross fall as at
relative xfall offset

intersection of the line
with the design surface

end of boxing is at the

boxing surface already defined
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Xfall name/offset input

the crossfall is taken from the point on the template which has the 
offset of Xfall_name + xfall_offset

Xfall delta input 0

adjust the crossfall at the xfall point by the value Xfall_delta.

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

For more information on how Boxing works in 12d Model, please go to the section “Boxing” .

The typed formats of the right_xfall commands created by this panel is:

right_xfall, xfall_name + xfall_offset, xfall_delta
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Boxing Definitions Examples

boxing “1” {

“Linterface”, copy // line 1
“Lpath2”, copy, -0.075 // line 2
“Lpath1”, copy // line 3
“Lbok” - 0.15, xfall, “Llok”, -0.3, 0 // line 4
“Llok”, copy, -0.3 // line 5
“Rlok”, xfall, “Rlok”,  -0.3, 0 // line 6
“Rbok” + 0.15, copy // line 7
“Rpath1”, copy -0.095 // line 8
“Rpath2”, copy // line 9
“Rinterface”, end // line 10

 }

Description

Line 1 copy from “Linterface” to “Lpath2”
Line 2 copy and drop by 0.075 from “Lpath 2" to “Lpath 1"
Line 3 copy from “Lpath1” to 0.15 before “Lbok”
Line 4 go from 0.15 before “Lbok” to “Llok” at depth 0.3 below “Llok”, with cross fall 0
Line 5 copy and drop by 0.3 from “Llok” to “Rlok”
Line 6 go from “Rlok” to 0.15 past “Rbok” at depth 0.3 below “Rlok”, with cross fall 0
Line 7 copy from 0.15 past “Rbok” to “Rpath1”
Line 8 copy and drop by 0.095 from “Rpath1” to “Rpath2”
Line 9 copy from “Rpath2” to “Rinterface”
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boxing “left narrow” {                 // boxing defined from just before lkerb to m001

“lkerb”  - 0.7 , copy
“m001”  - 1.0, copy ,      -0.6
"m001", end

}

boxing “left” { // boxing defined from the left start of the section to m001 (the centreline say)

“lkerb”, copy,  -0.6
“m001”, end
left_slope      5.0
left_copy         1

}

boxing “right” { // boxing defined from m001 to the far right of the section

“m001”, copy, 0.6
“rkerb”, end
right_slope    5.0
right_copy 1

}

boxing “full” { // a full width boxing - defines the entire boxing going from left to right

“lkerb”, copy, -0.6
“rkerb”, end
left_slope      5.0
left_copy 1

right_slope -5.0
right_copy 1

}
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Format of Boxing Definitions File
The interactive editor for creating the boxing definition file has been given in the previous 
sections “Edit Boxing File” .

This section will describe the layout of the text boxing file.

Boxing is defined by a series of commands going from left to right across the points of a cross 
section. (Cross sections are generated as 4d strings by options such as apply and cuts).

The definitions of boxing cross sections are set up in a file ending in .bf (called the boxing file) 
and any number of boxing definitions can be placed in the boxing file as long as each boxing 
definition is given a unique name.

In the boxing file, a boxing definition with name boxing_name is set out as

boxing boxing_name    {
boxing commands

}

The boxing commands apply from the offset specified at the beginning of that command (start 
offset for the command) to the start offset of the next command in the file (like chainages and 
templates in the apply many file).Hence the end offset for a command is the start offset of the 
following command in the file.

For example, in the sequence

offset1, command1
offset2, command2

command1 goes from offset1 (the start offset for command1) to offset2 (the end offset for 
command1). 

The offsets can be fixed values or can be specified relative to a point name on the 4d string 
representing the x-section. One restriction is that all the points mentioned in a boxing definition, 
must be present in each x-section the boxing definition is applied to.

The notation used to specify an actual offset, or offset relative to a point name is

offset_value
or “point_name”
or “point_name”   +/-    offset_value

and means in the first case

take the specified offset value (offset_value can be positive or negative).

and for the other two relative cases

take the offset at the string or 4d point called point_name and add offset_value to it 
(offset_value can be positive of negative).

Hence the offset can be specified as either a value or given relative to point_name (relative 
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offset). For convenience, the offset will be denoted by rel_off.

The major advantage of defining boxing in terms of point names is that whenever the points are 
modified using template modifiers, the boxing across the section is also automatically modified.

Since the offset part of a command can consist of text plus or minus a number, commas are used 
to separate each field of the command.

A boxing definition may be used in either a left_boxing or right_boxing mtf command (see the 
section, creating boxing), however unlike the case for templates, the boxing definition is applied 
to the point names going from left to right regardless of whether the boxing definition is used on 
the left or the right.

In practice, the definitions for left and right boxing are usually different because of the necessity 
of having unique point names across the entire cross section.

The commands in the boxing definition are

Copy
rel_off, copy

This copies the links (or parts of links) from the start offset rel_off to the offset on the next line, 
keeping the present crossfall and height of each link

.

Copy with Height Adjustment
rel_off, copy, delta_height

This copies the links (or parts of links) from the start offset rel_off to the offset on the next line, 
keeping the present slope of each link but adjusting the height of each link by delta_height.

rel_off,        copy
next_off, ...

rel_off next_off

rel_off,        copy,     delta_height
next_off, ...

rel_off
next_offdelta_height
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Line Through Two Given Points
rel_off, line, rel_off_1, delta_height_1,      rel_off_2,           delta_height_2

This creates a link from the start offset rel_off to the offset on the next line, with a

(a) slope given by two points

(b) start height given by projecting to the start offset, the line through the two points.

The first point defining the line has an offset rel_off_1 and a height given by the height of the 
design x-section at offset rel_off_1 adjusted by delta_height_1.

The second point defining the line has an offset rel_off_2 and a height given by the height of the 
design x-section at offset rel_off_2 adjusted by delta_height_2.

Xfall - Line Through a Given Point with a Given Crossfall
rel_off, xfall, rel_off_1, delta_height_1,           xfall_value

This creates a link from the start offset to the offset on the next line, with a

(a) user given xfall

(b) start height given by projecting to the start offset, the line with a given xfall and going 
through a given point.

The point defining the line has an offset rel_off_1 and a height given by the height of the design 
x-section at offset rel_off_1 adjusted by delta_height_1.

The crossfall of the line is given by xfall_value

rel_off,        line,   rel_off_1, delta_height_1,   rel_off_2,   delta_height_2
next_off, ...

rel_off
rel_off_1 next_off

rel_off_2

delta_height_2
delta_height_1

rel_off,        xfall, rel_off_1, delta_height_1, xfall_value
next_off, ...

rel_off next_off

rel_off_1

delta_height_1

xfall_value
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Xfall1 - Line Through a Given Point with Crossfall Taken from a Point
rel_off, xfall1, rel_off_1,         delta_height_1,      rel_off_2,           delta_xfall

This creates a link from the start offset rel_off to the offset on the next line, with a

(a) xfall which is the xfall at a given offset plus an addition given xfall 

and

(b) start height given by projecting to the start offset, the line with the given xfall and going 
through a given point.

The point defining the line has offset rel_off_1 and a height given by the height of the design 
x-section at offset rel_off_1 adjusted by delta_height_1

The xfall of the line is delta_xfall added to the xfall on the design x-section at the offset rel_off_2

End
rel_off, end

This command in used to give an end offset for any of the above commands when no command 
follows to use for the end offset. That is, the offset rel_off is used as the end offset for the 
previous command.

end doesn’t begin another command and none of the above commands can follow an end 
command.

All of the above boxing commands are known as standard commands. Hence the end command 
is the last standard command.

rel_off,        xfall1, rel_off_1, delta_height_1,   rel_off_2, delta_xfall
next_off, ...

rel_off next_off

rel_off_1
delta_height_1

delta_xfall

rel_off_2

xfall of rel_off_2
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Right_Xfall - Batter off Right End of Boxing with Crossfall Taken from a Point

The right_xfall command has two versions - providing a fixed cross fall or using the crossfall 
from part of the design x-section.

right_xfall rel_off,                 delta_xfall

right_xfall                xfall_value

For the first case, the right_xfall command batters off the right end of the boxing using the xfall 
from the design section at a given offset rel_off plus an additional given xfall delta_xfall, until the 
design section is intersected. The intersection point is used as the next point in the boxing.

Hence the xfall of the batter is delta_xfall added to the xfall on the design x-section at the offset 
rel_off

For the second case, the right_xfall command batters off to the right end of the boxing at the 
given xfall xfall_value until the design section is intersected. The intersection point is used as the 
next point in the boxing. 

 In the right_xfall command, the xfall is percent cross-fall and a positive xfall is up and negative 
down.

Right_slope - Batter Off the Right End of Boxing with a Given Crossfall
right_slope slope_value

The right_slope commands batter off to the right end of the boxing at the given slope 
slope_value until the design section is intersected. The intersection point is used as the next 
point in the boxing. In this command, a positive slope is up and negative down.

Right_copy - Copy from the Last Boxing Point to the end of Design Section
right_copy value

If value is non-zero, the right_copy command copies from the last boxing point to the last point 
on the design section. Hence the right_copy command is used to continue the boxing section 
from the intersection point with the design section to the end of the design section (a full width 
boxing section).

Note
The right_xfall command takes precedence over the right_slope command. That is, if both 
commands exist then only the right_xfall command is used.

right_xfall1 rel_off, delta_xfall

delta_xfall
rel_off

xfall at rel_off

boxing surface

design surface
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Left_Xfall
left_xfall rel_off,                 delta_xfall

left_xfall                xfall_value

The left_xfall is identical to the right_xfall command except that it is applied at the beginning of 
the boxing definition and batters off to the left rather than to the right.

 In the left_xfall command, the xfall is percent cross-fall and a positive xfall is up and negative 
down.

Left_slope
left_slope slope_value

The left_slope is identical to the right_slope command except that it is applied at the beginning 
of the boxing definition and batters off to the left rather than to the right. In this command, a 
positive slope is up and negative down.

The left_slope and left_copy are identical to the right_slope and right_copy except that they are 
applied at the beginning of the boxing definition and batter off and copy to the left rather than to 
the right. In this command, a positive slope is up and negative down.

The left_copy command must come before the left_slope command but they both come after all 
of the standard commands.

Note
The left_xfall command takes precedence over the left_slope command. That is, if both 
commands exist then only the left_xfall command is used.

Left_copy
left_copy value

The left_copy is identical to the right_copy except that it is applied at the beginning of the boxing 
definition and copies to the left rather than to the right.

If value is non-zero, the left_copy command copies from the last boxing point to the last point on 
the design section. Hence the left_copy command is used to continue the boxing section from the 
first boxing point to the start of the design section (a full width boxing section).

Note

The left_xfall, left_slope, left_copy, right_xfall, right_slope and right_copy commands should 
come after all of the standard commands.

When a boxing definition is applied on the left side, any right_xfall, right_slope or right_copy is 
ignored. Similarly, when a boxing definition is applied on the right side, any left_xfall, left_slope 
or left_copy is ignored.

Hence a boxing definition can have a left_xfall, left_slope, left_copy and a right_xfall, 
right_slope, right_copy but which set is used depends on whether the boxing definition is used 
on the left or the right.

When the boxing panel is used to create the boxing, only one boxing definition is needed and all 
of the right_xfall, right_slope, right_copy, left_xfall, left_slope and left_copy commands are used.
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Vertical Walls
If a boxing definition creates two different height values at the one offset (i.e. a wall), then extra 
offset points are automatically inserted into the boxing x-section (at 0.1 mm from the previous 
point) so that no points are on top of each other.

So in effect a vertical wall is created but since no points are created that are directly above each 
other, the data can be triangulated.

Boxing Definitions Examples

boxing “1” {

“Linterface”, copy // line 1
“Lpath2”, copy, -0.075 // line 2
“Lpath1”, copy // line 3
“Lbok” - 0.15, xfall, “Llok”, -0.3, 0 // line 4
“Llok”, copy, -0.3 // line 5
“Rlok”, xfall, “Rlok”,  -0.3, 0 // line 6
“Rbok” + 0.15, copy // line 7
“Rpath1”, copy -0.095 // line 8
“Rpath2”, copy // line 9
“Rinterface”, end // line 10

 }

Description

Line 1 copy from “Linterface” to “Lpath2”
Line 2 copy and drop by 0.075 from “Lpath 2" to “Lpath 1"
Line 3 copy from “Lpath1” to 0.15 before “Lbok”
Line 4 go from 0.15 before “Lbok” to “Llok” at depth 0.3 below “Llok”, with cross fall 0
Line 5 copy and drop by 0.3 from “Llok” to “Rlok”
Line 6 go from “Rlok” to 0.15 past “Rbok” at depth 0.3 below “Rlok”, with cross fall 0
Line 7 copy from 0.15 past “Rbok” to “Rpath1”
Line 8 copy and drop by 0.095 from “Rpath1” to “Rpath2”
Line 9 copy from “Rpath2” to “Rinterface”
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boxing “left narrow” {                 // boxing defined from just before lkerb to m001

“lkerb”  - 0.7 , copy
“m001”  - 1.0, copy ,      -0.6
"m001", end

}

boxing “left” { // boxing defined from the left start of the section to m001 (the centreline say)

“lkerb”, copy,  -0.6
“m001”, end
left_slope      5.0
left_copy         1

}

boxing “right” { // boxing defined from m001 to the far right of the section

“m001”, copy, 0.6
“rkerb”, end
right_slope    5.0
right_copy 1

}

boxing “full” { // a full width boxing - defines the entire boxing going from left to right

“lkerb”, copy, -0.6
“rkerb”, end
left_slope      5.0
left_copy 1

right_slope -5.0
right_copy 1

}

Please continue to the next section “Applying Boxing” .
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Applying Boxing
There are four options to apply boxing rules and hence create boxing strings and sections.

(a) Templates => Apply => Apply many
(b) Templates => Boxing => Boxing

with panel fields

model to box model of design x-sections
boxing file file containing one boxing definition
start chainage
end chainage
model for boxing i.e. model for created boxing x-sections

(c) Templates => Boxing => Boxing many

with panel fields

model to box model of design x-sections
templates file many template file, *.mtf
boxing file file of boxing definitions, *.bf
model for boxing i.e. model for created boxing x-sections

(d) Templates => Boxing => Boxing many (function)

The panels for these options have been described in an earlier chapter.

When using the boxing option Boxing, only one boxing definition is used from the boxing 
definitions file given boxing file panel field.

For the Apply many, Boxing many and Boxing many (function) options, the application of the 
boxing definitions is given in the many templates file (*.mtf) and is similar in format to applying 
templates (except interpolating between boxing is not allowed).

In the mtf (many templates file), for the Apply many, there can be up to with layers of boxing 
and each layer is defined in two parts - the left boxing and the right boxing. If both left and right 
boxing are both defined at a section, then the last point of the left boxing is automatically 
connected to the first point of the right boxing.

Warning - the left boxing must end before the right boxing begins. If there is an overlap, the right 
boxing will be pushed to the end of the left boxing.

Apart from a key word specifying whether the following part of the definition is for the left or 
the right, the set out for the left boxing is identical to the right boxing. Hence only the left boxing 
will be described in detail.

The left boxing definition begins with the key words

left_boxing =

A list of chainages (in ascending order, one per line) with corresponding boxing names then 
follows. The list of chainages and boxing is enclosed in curly braces { }.

The chainage-boxing lists are assembled as follows

(a) to represent a boxing starting at a given chainage, the chainage value followed by the 
boxing name is given. The chainage and boxing name are separated by one or more spaces. 
For example, the boxing left starting at chainage 150 is represented by

150 left

The boxing is assumed to apply until the chainage given on the next line of the left_boxing 
definition.
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(b) if no boxing exists from a chainage, simply include the chainage with no boxing name 
following it. For example, if there is no boxing from chainage 250, this is represented by

250

The non-existence of boxing is assumed until the chainage given on the next line of the 
left_side definition.

If the boxing is to go to the end of the reference string, add a line with a chainage greater 
than or equal to the end chainage. For example

150 left
9999

When using the apply many option, the name of the boxing definitions file is given by a 
boxing_file command in the many templates file.

boxing_file = boxing_definitions_file

When using the boxing many option, if a file name is given in the boxing file panel field, it is 
used for the boxing definitions file, otherwise the boxing_file command in the many templates 
file is used.

Note - if the boxing name includes spaces, then the name must be enclosed in quotes “. For 
example, “left 1".

An Applying Boxing Example
boxing_file =  “boxing_for_client.bf”

left_boxing  = {

-999 left
30
70 “left narrow”
110.5 left
999

}

right_boxing = {

-999 right
30
70 “right narrow”
110.5 right
999

}

Warning - no interpolation or modifiers exist for boxing.

Please continue to the next section “Boxing and Volumes” .

Boxing and Volumes
For the Apply many option, the cut and fill areas and volumes are calculated from the bottom of 
the boxing to the stripped surface.
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Full Definition of Template Decisions
decisions_template

12d Model supports templates with an unlimited number of fixed links, followed by either 

(a) a decisions table
or
(b) an unlimited number of cut and fill links and a final cut/fill slope the be applied at the end 

of the last template link.

Templates are created and edited using the Templates=>Create/edit option which brings up the 
Template Create/Edit panel.
 

The description of the fields and the buttons Fixed, Cut, Fill, Final Cut/Fill in this panel were 
given in the chapter “Design” .

 The Decisions button and its associated panel, Decisions Template, which is created when the 
Decisions button is selected, will now be described.

 The Decisions Template panel consists of scrolling command fields and a OK or Apply button to 
record the results.



Chapter 31  Advanced Design

May 2007 Page 2971Full Definition of Template Decisions

The width of the command area in the Decisions Template panel is controlled by the environment 
variable DEFAULT_TABLE_WIDTH_4D.

The commands in the decision template form a simple language where the commands are 
processed sequentially unless control is passed to a labelled line from where sequential 
processing continues, or the processing is terminated by an end command. 

The decision template commands can:

(a) create a fixed link - fixed xfall and fixed slope

(b) create a link of fixed width but with a slope automatically selected so that the link reaches a 
given tin in the width - tin width

(c)  create a link that goes within an offset of a given string  string offset 

(d) test for being between two depths below a tin, and transfer control if true - tin decision

(e) test that a link would get within a given depth from a tin at a given offset, and transfer 
control if true - batter decision

(f) create a link of set slope that batters to a depth below a tin at a given offset - batter

(g) create a label which can have processing passed to - label

(h)  transfer processing to a given label -goto

(i) end the processing of commands - end

decision_create_rule

The template decision commands can be typed into an text (ascii) file defining a template 
(template file .tpl), or can be created and edited through panels.

If the command line is empty, clicking LB in the command line will bring up the Create Rule menu 
which contains all the available decisions commands.

Selecting a menu item will bring up an associated panel which displays the information required 
for the decisions command.

When the panel is filled in and OK or Apply selected, the panel information is written out to the 
command line in the correct format for that template decision command.

If the command line is not empty, clicking LB in the command line will bring up the associated 
panel for the template decisions command in the command line.

The information in the panel can be modified and if OK or Apply is selected, the modified panel 
information is written out to the command line in the correct format for that template decisions 
command.

If the template is written out using File I/O=>Templates output or Templates=>Utilities=>Output, 
the template decisions will be written out as they are displayed in the command fields. 

fixed width and xfall
fixed width and slope
fixed width, up to a tin
go to an offset from a string
test depth below a tin
test if a batter cuts a tin
batter to a tin
create a label
goto a label
undo links
add comment line
terminate the decisions
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Any of the commands in the templates file can be edited and the file read back into 12d Model.

Each of the template decision commands will now be described and the associated panels 
created by selecting the command from the Create Rule menu.

The format of the decision commands that are written to the panel are given, as are the typed 
form of the command which is used in the templates file.

For examples of a using decisions, please go to the section “Decisions Examples” .

For documentation on the option/menus on the Create Rule menu:

for Fixed xfall,  go to the section “Fixed Xfall” 

Fixed slope “Fixed Slope” 
Tin width “Tin Width” 
String offset “String Offset” 
Tin decision “Tin Decision” 
Batter decision “Batter Decision” 
Batter “Batter” 
Label “Label” 
Goto “Goto” 
Undo links “Undo” 
Comment “Comment” .
End “End” 

Please continue to the next section “Fixed Xfall” .
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Fixed Xfall
decision_fixed_xfall

Selecting Fixed xfall brings up the Fixed Xfall panel which is used to constructed the command for 
a fixed link. The fixed link is defined by specifying values for two of the three fields width, 
height and x-fall.

The format of the Fixed Xfall command in the panel is

Fixed Xfall Width value Height value XFall value Name text Colour colour // comment

where only two of the three commands Width, Height and Xfall are used.

The format of the command typed into the template file is

Fixed_Xfall width_value height_value xfall_value name colour // comment

where one of width_value, height_value or xfall_value is the key word unknown.

The panel brought up when Fixed xfall is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Width input

the width for the link.

Height input

the height for the link.

Xfall % input

width

height

percent crossfall

start of fixed link

end of fixed link with name and colour 
given by the fixed xfall command

fixed xfall link defined by any two of width, percent crossfall or height.



12d Model Reference Manual

Page 2974 May 2007Full Definition of Template Decisions

the x-fall, in percent cross-fall, of the link. Positive is up and negative down.

Name input

the name to be used for the created point and string.

Colour input cyan available colours

the colour to be used for the created string

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Fixed Slope” .
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Fixed Slope
decision_fixed_slope

Selecting Fixed slope brings up the Fixed Slope panel which is used to constructed a fixed link. 
The fixed link is defined by specifying values for two of the three fields width, height and slope.

The format of the Fixed Slope command in the panel is

Fixed Slope Width value Height value Slope value Name text Colour colour // comment

where only two of the three commands Width, Height and Slope are used.

The format of the command typed into the template file is

Fixed_Slope width_value height_value slope_value name colour // comment

where one of width_value, height_value or slope_value is the key word unknown

The panel brought up when Fixed slope is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Width input

the width for the link.

Height input

the height for the link.

Slope 1v in input

width

height

slope

start of fixed link

end of fixed link with name and colour 
given by the fixed slope command

fixed slope link defined by any two of width, slope or height.
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the slope, in 1v in, of the link. Positive is up and negative down.

Name input

the name to be used for the created point and string.

Colour input cyan available colours

the colour to be used for the created string

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Tin Width” .
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Tin Width
decision_tin_width

Selecting Tin width brings up the Tin Width panel which is used to construct a link which has a 
given width and stops at the depth strip below the tin. Control then passes to the next line of the 
table.

strip can be positive (end point is below the tin) or negative (end point is above the tin).

The format of the Tin Width command in the panel is

Tin Width tin_name Strip value Width value Name text Colour colour // comment

The format of the command typed into the template file is

Tin_Width tin_name strip_value width_value name colour // comment

The panel brought up when Tin width is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Tin input available tins

tin to batter to.

Strip input 0

distance below the tin to stop at (strip depth). strip can be positive (point is below the tin) or negative 
(point is above the tin).

Width input 1

width

strip
given tin

start of tin width link

end of tin width link with name and 
colour given by the tin width command.

The slope is calculated so that the end is 
the given strip depth from the tin. Strip 
can be positive or negative.

tin width link defined by the tin, width and strip depth.

depth
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width of the link

Name input

the name to be used for the created point and string.

Colour input cyan available colours
the colour to be used for the created string

Comment input
user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “String Offset” .
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String Offset
decision_string_offset

Selecting String offset brings up the String Offset panel which is used to construct a link which 
goes to a given offset from string and stops at the depth strip below the string. Control then 
passes to the next line of the table.

offset and string can be positive or negative.

The format of the String Offset command in the panel is

String Offset string_name Strip value Offset value Name text Colour colour // comment

The format of the command typed into the template file is

String_Offset string_name strip_value offset_value name colour // comment

The panel brought up when String offset is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

String string select

string to batter to.

Strip input 0

distance below the string to stop at.

Offset input 1

offset from the string to stop at.

offsetstrip
given string (in section)

start of string

end of string offset link with name and colour 
given by the string offset command.

The slope is calculated so that the end is the given 
strip depth and offset from the string. Strip and 
offset can be positive or negative.

string offset link defined by the string, offset and strip depth.

depth

offset link
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Name input

the name to be used for the created point and string.

Colour input cyan available colours

the colour to be used for the created string

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Tin Decision” .
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Tin Decision
decision_tin_decision

Selecting Tin decision brings up the Tin Decision panel which tests to see if the depth from the end 
of the previous link, offset by the amount given in the offset field, is between the two values 
given in the minimum depth and maximum depth fields. If the depth is between the values, then 
control is transferred to the line with the label given by the goto field. Otherwise, control passes 
to the next line of the table.

offset, minimum and maximum depth can be positive or negative.

The format of the Tin Decision command in the panel is

Tin Decision tin_name Offset value Min value Max value Goto label // comment

The format of the command typed into the template file is

Tin_Decision tin_name offset_value min_value max_value goto_label // comment

The panel brought up when Tin decision is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Tin input available tins

the tin to calculate the depth to.

Offset input 0

the depth is calculate at an offset distance of offset from the end of the previous link.

Minimum depth input 0

if the depth is between the minimum and maximum depth, then control is passed to the line with the 

offset

minimum

the tin must pass through the solid area

end of

tin decision given by offset and minimum and maximum 

depth

maximum
depth

tin not in the depth range

for the goto to be performed tin in the depth range

previous link
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label given in the goto field, otherwise control passes onto the next line of the table.

Maximum depth input 1000

see previous field.

Goto input

label to go to if the depth is between the minimum and maximum depths.

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Batter Decision” .
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Batter Decision
decision_batter_decision

Selecting Batter decision brings up the Batter Decision panel which is used to test whether a 
given link comes within

(a) a strip depth of a tin

(b) an offset distance from a tin.

(c) a strip depth of a tin calculated at a given offset from the link.

If the test is satisfied, then control is transferred via a goto, otherwise control continues onto the 
next line in the table.

The test link is defined by specifying values for two of the three fields width, height and slope.

Notes
1. no link is created, just the test is performed

2. cases (a) and (b) are just special cases of (c)

3. the batter decision is mainly used to test if a batter will stop without performing the batter.

width

strip

given tin

start of

The batter link ends if the tin is cut 
at the strip depth below the tin. 

The goto is performed.

batter link defined by any two of width, height and slope and the test is meeting the tin at the strip depth.

depth

batter link

Case (a)

width

given tin

start of

The batter link ends if the tin is cut 
at the offset distance from the link. 

The goto is performed.

batter link defined by any two of width, height and slope and the test is meeting the tin at the offset distance.

offset

batter link

Case (b)
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The format of the Batter Decision command in the panel is

Batter Decision tin_name Strip value Offset value Width value Height value
Slope value Goto label // comment

where only two of the three commands Width, Height and Slope are used.

The format of the command typed into the template file is

Batter_Decision tin_name strip_value offset_value width_value height_value slope_value
goto_label // comment

where one of width_value, height_value or slope_value is the key word unknown

width

given tin

start of

The batter link ends if the tin is cut at the strip depth 
calculated at the offset distance from the link. 

The goto is performed.

batter link defined by any two of width, height and slope and the test is 
meeting the tin at the strip depth at the given offset distance from the link.

offset

batter link

strip

Case (c)

width

given tin

start of

batter link defined by any two of width, height and slope and the test (failed) is 
meeting the tin at the strip depth calculated at the given offset distance from the link.

offset
batter link

strip

The batter link does not cut at the strip depth below the tin, 
calculated at the offset distance from the link. 

The goto is not performed and control goes to the next line. 

Failure of the batter decision
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The panel brought up when Batter decision is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Tin input available tins

tin to test the batter to.

Strip input1 0

distance below the tin to stop at.

Offset input1 0

offset distance from the link to check strip depth

Width input

the width for the link.

Height input

the height for the link.

Slope 1v in input

the slope, in 1v in, of the link. Positive is up and negative down.

Goto input

label to goto if the test link comes within the strip depth of the tin at the given offset distance.

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Batter” .
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Batter
decision_batter

Selecting Batter brings up the Batter panel which is used to construct a link which stops if it 
comes within

(a) a strip depth of a tin

(b) an offset distance from a tin.

(c) a strip depth of a tin calculated at a given offset from the link.

If the link does stop, control is transferred via a goto, otherwise control continues onto the next 
line in the table.

The batter link is defined by specifying values for two of the three fields width, height and slope.

Notes
1. cases (a) and (b) are just special cases of (c)

2. strip and offset can be used to stop the link to allow for a fixed structure (such as a drain) to 
be inserted so that it ends up on the tin.

width

strip

given tin

start of

The batter link ends if the tin is cu
at the strip depth below the tin. 

A point is created at the cut point 
with name and colour given in th
batter command.

The goto is performed.

batter link defined by any two of width, height and slope and stops if it meets the tin at the strip depth.

depth

batter link

Case (a)

width

given tin

start of

The batter link ends if the tin is cut 
at the offset distance from the tin. 

A point is created at the cut point 
with name and colour given in the 
batter command.

The goto is performed.

batter link defined by any two of width, height and slope and stops if it meets the tin at the offset distance.

offset

batter link

Case (b)
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The format of the Batter command in the panel is

Batter tin_name Strip value Width value Height value Slope value Name text
Colour colour Goto label // comment

where only two of the three commands Width, Height and Slope are used.

The format of the command typed into the template file is

Batter tin_name strip_value width_value height_value slope_value
name colour goto_label // comment

where one of width_value, height_value or slope_value is the key word unknown

width

given tin

start of

The batter link ends if the tin is cut at the strip depth 
calculated at the offset distance from the link. 

A point is created at the cut point with name and 
colour given in the batter command.

The goto is performed.

batter link defined by any two of width, height and slope and stops if it meets 
the tin at the strip depth calculated at the given offset distance from the link.

offset

batter link

strip

Case (c)

width

given tin

start of

batter link defined by any two of width, height and slope and fails to meet the tin at 
the strip depth calculated at the given offset distance from the link.

offset
batter link

strip

The batter link does not cut at the strip depth below the tin, 
calculated at the offset distance from the link. 

A point is created at the end of the batter link with name 
and colour given in the batter command.

The goto is not performed and control goes to the next line.

Failure of the batter
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The panel brought up when Batter is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Tin input available tins

tin to batter to.

Strip input1 0

distance below the tin to stop at.

Offset input1 0

offset distance from the link to check strip depth

Width input

the width for the link.

Height input

the height for the link.

Slope 1v in input

the slope, in 1v in, of the link. Positive is up and negative down.

Name input

the name to be used for the created point and string.

Colour input cyan available colours

the colour to be used for the created string

Goto input

label to goto if the batter link comes within the depth strip of the tin.

Comment input

user comment - for information purposes only 

OK/Apply button
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OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Label” .
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Label
decision_label

Selecting Label brings up the Label panel which is used to define a label for the line for which 
control can be passed to via a goto.

The format of the Label command in the panel is

Label label_name // comment

The format of the command typed into the template file is

Label label_name // comment

The panel brought up when Label is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Label input

name of the label for the line in the table.

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Goto” .

Goto
decision_goto

Selecting Goto brings up the Goto panel which is used to transfer control to the line with the 
label given in the goto field of the panel.

The format of the Goto command in the panel is

Goto label_name // comment

The format of the command typed into the template file is

Goto label_name // comment

The panel brought up when Goto is selected from the Create Rule menu is:
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The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Goto input

name of the label to transfer control to.

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Undo” .
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Undo
decision_undo

Selecting undo brings up the Undo Decision panel which is used to delete a given number of 
points (and hence links) from the template being constructed.

The format of the Label command in the panel is

Undo number_of_points // comment

The format of the command typed into the template file is

Undo number_of_links // comment

The panel brought up when Undo is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Undo npts input 0

number of points to delete from the template.

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Comment” .

Comment
decision_comment

Selecting Comment brings up the Commend panel and inserts an comment into the line of the 
table. Comments are ignored by the decisions calculations.

The panel brought up when Comment is selected from the Create Rule menu is:
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The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “End” .

End
decision_end

Selecting End brings up the End panel and inserts an end command into the line of the table. 
When control reaches an end command, the decisions calculations are terminated.

The format of the End command in the panel is

End // comment

The format of the command typed into the template file is

End // comment

The panel brought up when End is selected from the Create Rule menu is:

The fields and buttons used in this panel have the following functions.

Field Description Type Default Pop-Up

Comment input

user comment - for information purposes only 

OK/Apply button

OK stores the values in the fields and removes the panel.
Apply stores the values and leaves the panel on the screen.

Please continue to the next section “Decisions Examples” .
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Decisions Examples

One Tin Example
//From: 12D Solutions
//Date: 11/07/97
//
//Basic Decisional Template for cut in 9m depth, 5m depth, and less
//Note the Tin Used is "SURVEY"
//
//
template "std" {

fixed {
    link 5 unknown -3 cyan "eb"

}
decisional {

// if at offset 1m it is below "SURVEY" then goto drain
    Tin_Decision      "SURVEY" 1 0 1000 "drain"

    Fixed_Xfall       1 unknown -3 "edge1" cyan
    Batter            "SURVEY" 0 100 unknown -3 "fill" cyan "done"

// label drain
// create a table drain 
    Label             "drain"
    Fixed_Slope       1 -0.5 unknown "invert" cyan
    Fixed_Slope       1 0.5 unknown "edge" cyan

// now at end of table drain, check depth of 5, 9
    Tin_Decision      "SURVEY" 0 0 5 "smallestcut"
    Tin_Decision      "SURVEY" 0 0 9 "smallcut"

// deeper than 9m, batter to within 9m of surface
    Batter            "SURVEY" 9 100 unknown 0.75 "cut1" cyan "bench"

// label smallcut - 
    Label             "smallcut"
    Batter            "SURVEY" 5 100 unknown 0.75 "small" cyan "bench2"

// label smallestcut - 
    Label             "smallestcut"
    Batter            "SURVEY" 0 100 unknown 2 "smallcut" cyan "done"

// label bench
    Label             "bench"
    Fixed_Slope       3 -0.3 unknown "bench1" cyan
    Batter            "SURVEY" 5 100 unknown 1.5 "cut2" cyan "bench2"

// label bench2 - 
    Label             "bench2"
    Fixed_Slope       3 -0.3 unknown "bench2" cyan
    Batter            "SURVEY" 0 100 unknown 2 "cut3" cyan "done"

// label done - 

    Label             "done"
    End



Chapter 31  Advanced Design

May 2007 Page 2995Full Definition of Template Decisions

}
final {

    cut_slope na fill_slope na search_distance 100
}

}

Three Tins Example
//From: 4D Solutions
//Date: 11/07/97
//
// Example with three surfaces - rock, shale, terrain
// Assume that rock is below shale is below terrain

template "std" {
fixed {

    link 3 unknown -3 cyan "kerb"
    link 1 unknown -4 magenta "shoulder"
    link 2 unknown -5 purple "verge"

}
decisional {

// test if in rock
    Tin_Decision  "rock" 0 0 1000 "cut_rock"

// not in rock, test if in shale
    Tin_Decision  "shale" 0 0 1000 "cut_shale"

// not in rock or shale, test if below or above terrain
    Tin_Decision  "terrain" 0 0 1000 "cut_terrain"

// fill terrain - loop on creating some benches 
    Label    "fill_terrain"
    Batter   "terrain" 0 0 8 unknown -3 "f1" blue "alldone"
     Batter  "terrain" 0 0 1 unknown 0 "f2" "dark green" "alldone"
    Goto     "fill_terrain"

// cut rock
    Label             "cut_rock"
    Tin_Decision      "rock" 0 0 0.3 "cut_rock_done"
    Batter            "rock" 0.3 0 5 unknown 0.5 "r1" cyan "cut_rock_done"
    Batter            "rock" 0 0 2.5 unknown 0 "r2" yellow "cut_rock_done"
    Goto              "cut_rock"

// cut rock done - work on shale
    Label             "cut_rock_done"
    Tin_Decision      "shale" 0 0 1000 "cut_shale"
    Goto              "cut_shale_done"

// cut shale
    Label           "cut_shale"
    Tin_Decision    "shale" 0 0 0.6 "cut_shale_done"
    Batter        "shale" 0.6 0 6 unknown 1 "s1" magenta "cut_shale_done"
    Batter        "shale" 0 0 3 unknown 0 "s2" "dark red" "cut_shale_done"
    Goto              "cut_shale"
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// cut shale done - work on terrain
    Label             "cut_shale_done"
    Tin_Decision      "terrain" 0 0 1000 "cut_terrain"
    Goto              "alldone"

// cut terrain
    Label             "cut_terrain"
    Batter            "terrain" 0 0 3 unknown 1.5 "t1" red "alldone"
    Batter            "terrain" 0 0 2 unknown 0 "t2" green "alldone"
    Goto              "cut_terrain"

// all done - end of decisional
    Label             "alldone"

}
final {

    cut_slope 1 fill_slope 2 search_distance 100
}

}
template "headwall" {

fixed {
    link 3 unknown -3 cyan "kerb"
    link 1 unknown -4 magenta "shoulder"
    link 2 unknown -5 purple "verge"

}
decisional {

    Tin_Decision      "" 0 0 1000 "done" // should never happen
    Batter            "" 0 0 10 -100 unknown "int" cyan "done"
    Label             "done"

}
final {

    cut_slope na fill_slope na search_distance 100
}

}
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Placing Elements for Super Alignments
Placing a super alignment, like the alignment strings, consists of:

(a) defining the horizontal geometry

(b) defining the vertical geometry

Unlike the alignment which uses IP methods only, the super alignment allows the user to 
partially define elements making up the super alignment. The position and types of elements, 
and the condition that each element is tangential to the adjacent elements, may allow 12d Model 
to calculate for all the unknowns in the element definitions to be solved and the super alignment 
be fully defined.

Horizontal elements consist of lines, arcs and transition spirals.

Normally these elements can be combined in the super alignment and defined so that adjacent 
elements are tangential to each other.

When placing horizontal elements, 12d Model often only requires some of the information 
defining the element and the configuration of the elements and enforcing tangentiality of 
adjacent elements, allows 12d Model to calculate the rest of the information.

Vertical elements consist of lines, parabolas and arcs.

These elements can be combined in the super alignment and defined so that adjacent elements 
are tangential to each other.

When placing vertical elements, 12d Model often only requires some of the information defining 
the element and the configuration of the elements and enforcing tangentiality of adjacent 
elements, allows 12d Model to calculate the rest of the information.

Horizontal IP’s
No curve, go to No curve - known horizontal intersection point with no arc on it
Alignment speed, go to Alignment speed - known horizontal intersection point with arcs and 

spirals defined by the design parameters and default speed for the super alignment
Curve speed, go to Curve speed - known horizontal intersection point with known speed with 

the arcs and spirals are defined by design parameters for that speed
Curve length, go to Curve length - known horizontal intersection point with an arc of a known 

length
Curve radius, go to Curve radius - known horizontal intersection point with an arc of a known 

radius
Curve spiral, go to Curve spiral - known horizontal intersection point with an arc of a known 

radius and leading and trailing spirals of known lengths.

Horizontal Lines
Fixed, go to Fixed - line passes through two known points
Fixed direction, go to Fixed direction - the line passes through a known point with a known 

bearing. An offset is allowed.
Floating point, go to Floating point - the line passes through a known point but the bearing is 

unknown bearing
Floating direction, go to Floating direction - the line has a known bearing but nothing else is 

known



12d Model Reference Manual

Page 2998 May 2007Placing Elements for Super Alignments

Floating end, go to Floating end - the line has a known length and goes from the end of a 
previous element

Free, go to Free - the line is not constrained in any way

Horizontal Arcs
Fixed, go to Fixed - the arc centre is known as well as the radius and start and end points. An 

offset is allowed.
Fixed 3 points, go to Fixed 3 points- the arc passes through three known points
Fixed direction, go to Fixed direction- known point, known radius and known bearing at the 

known point

Floating radius, go to Floating radius - the radius of the arc is known and the arc passes through 
a known point

Floating direction, go to Floating direction - the arc passes through a known point with a known 
bearing at the point

Floating 2 pts, go to Floating 2 points- the arc passes through two known points
Floating end and point, go to Floating end and point- the arc passes through one known point 

and is attached to either previous or next element
Floating end, radius and length, go to Floating end, radius and length- the arc has a known 

radius and a known length

Free radius, go to Free radius - the arc has a known radius

Free point, go to Free point - the arc passes through a known point
Free length, go to Free length - the arc has a known length

Horizontal Transitions
Free spiral, go to Free spiral - the transition spiral is unconstrained
Spiral, go to Spiral - the spiral has a known length
Back to back, go to Back to back- back to back spirals of known lengths between two fixed lines
Arc to arc, go to Arc to arc- back to back spirals between known arcs. One spiral length is 

needed.
Taper, go to Taper - known length and known ratio
None, go to None - no transition
3 centred, go to 3 centred - three centred curve - three arcs with given radii and offsets
2 centred, go to 2 centred - two centred curve- two arcs with given radii
Compound spiral, go to Compound spiral - compound spirals of known lengths
Compound line, go to Compound line - compound spirals with one known length with a line of 

known length
Compound arc, go to Compound arc - compound arcs of known radii

Vertical IP’s
No VC, go to No VC - known vertical intersection point with no parabola or arc on it
Alignment speed, go to Alignment speed - known vertical intersection point with parabola 

defined by the design parameters and default speed for the super alignment
Speed, go to Speed - known vertical intersection point with a known speed and the parabolic 

curve defined by the design parameters
Length, go to Length - known vertical intersection point with a parabola of a known length
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Radius, go to Radius - known vertical intersection point with a parabola of a known effective 
radius

K value, go to K-value - known vertical intersection point with a parabola of a known k-value
Max length, go to Max length - known vertical intersection point with a parabola of maximum 

length
Asymmetric, go to Asymmetric - known vertical intersection point with asymmetric parabolas 

of known lengths
Circular arc, go to Circular arc - known vertical intersection point with an arc of a known radius

Vertical Lines
Fixed, go to Fixed - two known points
Fixed grade, go to Fixed grade - known point and know grade
Floating point, go to Floating point - known point (unknown grade)
Floating grade, go to Floating grade - known grade (unknown point)
Free, go to Free - not constrained at all

Vertical Arcs
Fixed, go to Fixed - known centre, known radius and known start and end points of the arc
Fixed 3 points, go to Fixed 3 points- three known points on the arc
Fixed direction, go to Fixed direction- known point, known radius and known bearing at the 

known point
Floating radius, go to Floating radius - known point and known radius of the arc
Floating grade, go to Floating grade - known point and known tangential grade of the arc at the 

known point
Floating 2 points, go to Floating 2 points- two known points on the arc
Free radius, go to Free radius - known radius of the arc
Free point, go to Free point - known point on the arc
Free length, go to Free length - known length of the arc

Vertical Parabolas
Fixed 3 points, go to Fixed 3 points- three known points on the parabola
Fixed apex radius, go to Fixed apex radius- known apex point and known effective radius of the 

parabola
Floating 2 points, go to Floating 2 points- two known points on the parabola
Floating apex, go to Floating apex- known apex point of the parabola
Floating radius, go to Floating radius - known point and known effective radius of the parabola
Floating grade, go to Floating grade - known point and known grade at the known point
Floating k value, go to Floating k value - known point and known k value of the parabola
Free point, go to Free point - known point on the parabola
Free length, go to Free length - known length of the parabola
Free radius, go to Free radius - known effective radius of the parabola
Free rl, go to Free rl - known height of the parabola
Free k value, go to Free k value- known k value of the parabola
Free max length, go to Free max length- fit a parabola of maximum length
Free asymmetric, go to Free asymmetric- asymmetric parabolas of known lengths
Free compound, go to Free compound- compound parabolas with a percentage length of the 

first parabola and an optional total length
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Super Alignment Horizontal Elements

Horizontal IP’s
No curve - known horizontal intersection point with no arc on it



Chapter 31  Advanced Design

May 2007 Page 3001Placing Elements for Super Alignments

Horizontal IP’s
Alignment speed - known horizontal intersection point with arcs and spirals defined by the 
design parameters and default speed for the super alignment
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Horizontal IP’s
Curve speed - known horizontal intersection point with known speed with the arcs and spirals 
are defined by design parameters for that speed
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Horizontal IP’s
Curve length - known horizontal intersection point with an arc of a known length
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Horizontal IP’s
Curve radius - known horizontal intersection point with an arc of a known radius
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Horizontal IP’s
Curve spiral - known horizontal intersection point with an arc of a known radius and leading 
and trailing spirals of known lengths.
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Horizontal Lines
Fixed - line passes through two known points



Chapter 31  Advanced Design

May 2007 Page 3007Placing Elements for Super Alignments

Horizontal Lines
Fixed direction - the line passes through a known point with a known bearing. An offset is 
allowed.
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Horizontal Lines
Floating point - the line passes through a known point but the bearing is unknown bearing
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Horizontal Lines
Floating direction - the line has a known bearing but nothing else is known
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Horizontal Lines
Floating end - the line has a known length and goes from the end of a previous element
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Horizontal Lines
Free - the line is not constrained in any way
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Horizontal Arcs
Fixed - the arc centre is known as well as the radius and start and end points. An offset is 
allowed.
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Horizontal Arcs
Fixed 3 points- the arc passes through three known points
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Horizontal Arcs
Fixed direction- known point, known radius and known bearing at the known point
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Horizontal Arcs
Floating radius - the radius of the arc is known and the arc passes through a known point



12d Model Reference Manual

Page 3016 May 2007Placing Elements for Super Alignments

Horizontal Arcs
Floating direction - the arc passes through a known point with a known bearing at the point
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Horizontal Arcs
Floating 2 points- the arc passes through two known points
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Horizontal Arcs
Floating end and point- the arc passes through one known point and is attached to either 
previous or next element
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Horizontal Arcs
Floating end, radius and length- the arc has a known radius and a known length
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Horizontal Arcs
Free radius - the arc has a known radius
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Horizontal Arcs
Free point - the arc passes through a known point
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Horizontal Arcs
Free length - the arc has a known length



Chapter 31  Advanced Design

May 2007 Page 3023Placing Elements for Super Alignments

Horizontal Transitions
Free spiral - the transition spiral is unconstrained



12d Model Reference Manual

Page 3024 May 2007Placing Elements for Super Alignments

Horizontal Transitions
Spiral - the spiral has a known length
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Horizontal Transitions
Back to back- back to back spirals of known lengths between two fixed lines
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Horizontal Transitions
Arc to arc- back to back spirals between known arcs. One spiral length is needed.
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Horizontal Transitions
Taper - known length and known ratio
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Horizontal Transitions
None - no transition
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Horizontal Transitions
3 centred - three centred curve - three arcs with given radii and offsets
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Horizontal Transitions
2 centred - two centred curve- two arcs with given radii
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Horizontal Transitions
Compound spiral - compound spirals of known lengths
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Horizontal Transitions
Compound line - compound spirals with one known length with a line of known length
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Horizontal Transitions
Compound arc - compound arcs of known radii
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Super Alignment Vertical Element Examples

Vertical IP’s
No VC - known vertical intersection point with no parabola or arc on it
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Vertical IP’s
Alignment speed - known vertical intersection point with parabola defined by the design 
parameters and default speed for the super alignment



12d Model Reference Manual

Page 3036 May 2007Placing Elements for Super Alignments

Vertical IP’s
Speed - known vertical intersection point with a known speed and the parabolic curve defined 
by the design parameters
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Vertical IP’s
Length - known vertical intersection point with a parabola of a known length
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Vertical IP’s
Radius - known vertical intersection point with a parabola of a known effective radius
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Vertical IP’s
K-value - known vertical intersection point with a parabola of a known k-value
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Vertical IP’s
Max length - known vertical intersection point with a parabola of maximum length
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Vertical IP’s
Asymmetric - known vertical intersection point with asymmetric parabolas of known lengths
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Vertical IP’s
Circular arc - known vertical intersection point with an arc of a known radius
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Vertical Lines
Fixed - two known points
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Vertical Lines
Fixed grade - known point and know grade
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Vertical Lines
Floating point - known point (unknown grade)
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Vertical Lines
Floating grade - known grade (unknown point)



Chapter 31  Advanced Design

May 2007 Page 3047Placing Elements for Super Alignments

Vertical Lines
Free - not constrained at all
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Vertical Arcs
Fixed - known centre, known radius and known start and end points of the arc
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Vertical Arcs
Fixed 3 points- three known points on the arc
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Vertical Arcs
Fixed direction- known point, known radius and known bearing at the known point
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Vertical Arcs
Floating radius - known point and known radius of the arc



12d Model Reference Manual

Page 3052 May 2007Placing Elements for Super Alignments

Vertical Arcs
Floating grade - known point and known tangential grade of the arc at the known point
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Vertical Arcs
Floating 2 points- two known points on the arc
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Vertical Arcs
Free radius - known radius of the arc
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Vertical Arcs
Free point - known point on the arc
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Vertical Arcs
Free length - known length of the arc
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Vertical Parabolas
Fixed 3 points- three known points on the parabola
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Vertical Parabolas
Fixed apex radius- known apex point and known effective radius of the parabola
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Vertical Parabolas
Floating 2 points- two known points on the parabola
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Vertical Parabolas
Floating apex- known apex point of the parabola
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Vertical Parabolas
Floating radius - known point and known effective radius of the parabola
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Vertical Parabolas
Floating grade - known point and known grade at the known point
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Vertical Parabolas
Floating k value - known point and known k value of the parabola
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Vertical Parabolas
Free point - known point on the parabola
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Vertical Parabolas
Free length - known length of the parabola
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Vertical Parabolas
Free radius - known effective radius of the parabola
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Vertical Parabolas
Free rl - known height of the parabola



12d Model Reference Manual

Page 3068 May 2007Placing Elements for Super Alignments

Vertical Parabolas
Free k value- known k value of the parabola
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Vertical Parabolas
Free max length- fit a parabola of maximum length
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Vertical Parabolas
Free asymmetric- asymmetric parabolas of known lengths
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Vertical Parabolas
Free compound- compound parabolas with a percentage length of the first parabola and an 
optional total length
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Fixed and Floating
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A 12D Survey Guide
The information contained in this appendix outlines the general options, terminology, 
definitions and methods used by 12d Model for the purpose of the input, reduction and output 
of survey information. It is a general guide, with the appendices following relating to specific 
instruments and the interactions with 12d Model.

Please continue to the next section “Guide to Survey Reduction in 12d Model” .

Guide to Survey Reduction in 12d Model
The 12d Model survey options are used to reduce electronically recorded survey information and 
produce 12d Model strings, a process called survey reduction.

In the most general case, there are three steps involved:

1.  12d Model downloads raw data from a data collector and stores it on the computer.

2. The raw data file is converted to a standard 12d Model raw field file format, normally with 
extension of “.fld”. For simplicity, the standard 12d Model raw field file is called the "12d 
field file".

3. The 12d field file is read into a 12d Model Survey Reduction function (12d Survey function) 
and reduced. If errors occur, the field data for 12d Survey function can be interactively and/
or graphically edited. The reduction produces 12d Model super strings in one or many 12d 
Model models.

In some circumstances, not all steps are necessary.

For example, Step 1 is not necessary when the raw data file is already on the computer (and 
hence doesn’t need downloading).

This often occurs when data collectors have PCMCIA cards and PCMCIA card readers on the 
computer. Another example is when the raw data file has already been downloaded to the 
computer using another package such as HyperTerminal. Or maybe the raw data file has already 
been downloaded in a previous 12d Model session.

Steps 1 and 2 are not necessary when the data is already in the form of a 12d field file. 

This occurs when other software packages, such as TP Setout, can produce a 12d field file. Or the 
12d field file was created in a previous 12d Model session, maybe even on a different computer.

A data flow diagram for the survey reduction process is:
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Please continue to the next section “Guide to Survey Coding in 12d Model” .

12d Survey Function
(Data Reduction and Editing Engine)

• field data
• reduction
• interactive field data edits and auto reduction
• graphical field data edits and auto reduction
• produce 12d Model strings

Download and

Downloading raw data Already have raw file Already have 12d field file

12d field

no conversion

on the computer on the computerfrom data collector

A B C

file

Data Flow for Survey Reduction

convert to 12d field file

convert to
12d field file

required

load into 12d Survey function
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Guide to Survey Coding in 12d Model
At first the whole process may seem confusing because there are a multitude of methods of 
setting up coding in the field. Why isn’t there just one way of doing things?

Firstly, each brand of survey instrument has a totally different format for recording information. 
Unfortunately there is no industry standard. In fact, different instruments from the same survey 
instrument manufacturer can have different formats for recording data.

Secondly, many of our customers were already familiar with another survey package and if 
possible, wished to continue field coding in the same way. Where possible, 12d Model has tried 
to accommodate this wish. Since 12d Model has replaced a number of survey packages, this led 
to yet more possible configurations.

12d Model has also been developing its own preferred method of field coding for each 
instrument. It is not compulsory to use the 12d method but of course it is the only way of taking 
advantage of features that are not available in other coding systems. For example, defining and 
using field templates and recording user-defined attributes on points and segments.

So to make help guide you through survey coding section:

(a) There are field coding concepts used in 12d Model that are common to all instruments. For 
example, feature codes and string numbers, offset, close strings etc.

These are described in “Field Coding” 

(b) There are template field coding concepts used in 12d Model that are common to all 
instruments. These are described in “Field Templates” 

(c) There are shape field coding concepts used in 12d Model that are common to all 
instruments. These are described in “Shape field coding” 

(d) There are traverse field coding concepts used in 12d Model that are common to all 
instruments. These are described in “Traverse coding” 

(e) For leica instruments, the coding methods are different from most other types. These are 
described in “Field Coding for Leica Instruments” 

(f) For non-leica instruments, the concepts used in coding are similar for each type. These are 
described in “Field Coding for Non Leica Instruments” 
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Field Coding
EDM equipment is used to make readings of points in the field.

However, rather than just collecting points, it is usually desirable to add extra information by 
coding the readings in a way that can be interpreted during the data reduction process and 
produce more valuable information.

Unfortunately, there is no industry standard for this extra coding and it is software specific.

In 12d Model, the extra information is included in one or both of 

▲ a feature code and string number

▲  extra commands called field codes

How the feature codes, string number and field codes are added in the field depends on the data 
collector being used and the coding convention set up by the user in 12d Model.

For example, some surveyors like to enter the feature code before the string number, others like to 
enter the feature code after the string number. Other surveyors don’t use string numbers at all but 
prefer to use a New String command to start new strings (mainly ex SDR Map users).

In 12d Model, a particular field coding convention is defined by the user and stored with a unique 
name as a data collector definition in the file survey.4d. New data collector definitions can be 
created and existing ones modified using the Survey Data Collectors section of Project=>Browse.

 12d Model converts all the raw data files from the different survey instruments and data 
recorders with different coding conventions, into the one 12d Model standard field file format 
before being loaded into a 12d Model Survey Reduction function and reduced. The 12d Model 
standard field file will simply be referred to as the 12d field file or just the field file.

The use of many of the commands allowed in the 12d  field file will now be described. The 
complete definition of all the 12d field file commands will be described later.

The coding methodology for specific data recorders will be described in separate Sections.

Please continue to the next section “Stringing in the Field” .

Stringing in the Field
In the coding convention, it is possible to specify that 

(a) feature codes and string numbers are used
 or
(b)  just feature codes.

Case (a) feature codes and string numbers

If feature codes and string numbers are entered with measurements in the field, a coding 
methodology is used so that strings are automatically created during the reduction process.

To allow this stringing, the feature code and string number are interpreted in the following 
manner:

During reduction, 12d Model connects measurement points with the same feature code and 
string number in the order they are measured in. That is, the feature code and string number 
determines which points are joined together to form the vertices of a super string. At the end 
of the reduction, the string number is dropped and just the feature code remains as the name for 
the super string.

Hence the feature code and string number combination allows any number of different super 
strings with the same name (feature code) to be produced.

 If the string number is zero, then the point-line type of the super string is set to point. If the 
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string number is non-zero, the point-line type of the super string is set to line.

Finally, during reduction, the feature code can be used as the key to a mapping file to specify 
the name, model, colour, point-line type, linestyle, tinability and other details for the super 
string.

Note that the measurements of points with different feature codes and string numbers can be 
intertwined. That is, not all the points in one super string need to be measured before the 
points in a different super string.

Hence at the end of the reduction, 12d Model super strings are created for each unique feature 
code and string number combination in the input data.

Note - if the string number is blank, the string number defaults to 0

Case (b) just feature codes

 If just feature codes are used then a New String command is used to start a new super string rather 
than giving a new string number.

During reduction, 12d Model connects measurement points with the same feature code in the 
order they are measured in until a New String command is found. That is, just the feature code 
determines which points are joined together to form a super string and the New String 
command defines when a new super string begins.

At the end of the reduction, the feature code remains as the name for the super string.

Also during reduction, the feature code can be used as the key to a mapping file to specify the 
name, model, colour, point-line type, linestyle, tinability and other details for the super string.

Note that the measurements of points with different feature codes can be intertwined. That is, 
not all the points in one super string need to be measured before the points in a different 
super string.

An Example of Coding to String Points Together
Two super strings are to be created, one joining points a and c, the other joining points b and d.

Points may be measured and assigned feature codes and string numbers as follows:

Alternatively, the points could have been measured in the order a, c, b, d as long as the correct 

Measurement to 
point

Feature code String Number

a 123 01

b ABC 01

c 123 01

d ABC 01

a

b d

cFeature code 123

Feature code ABC

String number 01

String number 01
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feature codes and string numbers were entered.

Because the string numbers are non-zero, the default point-line type for both super strings is line.

Please continue to the next section “Offsets” .

Offsets
It is not always possible to measure a point directly but it may be possible to measure a point 
nearby and then measure an offset to adjust the measured point by and so produce the co-
ordinates of the required point.

The three offsets that are allowed in the 12d field file are:

Height - The height offset adjusts the height of a non-null point. A positive offset adds to the height and 
a negative offset reduces the height.

Radial - The radial offset adjusts the position of the specified point by a plan distance from the 
specified points original position, along the plan line joining the current station to the specified point. A 
positive offset is away from the station and a negative offset is toward the station.

Tangential - The tangential offset adjusts the position of the specified point by a plan distance from the 
specified points original position, at rights angles to the plan line joining the current station to the 
specified point. A positive offset is to the right (looking from the station to the point) and a negative 
offset is to the left.

Please continue to the next section “Start New String” .

Measurement to 
point

Feature code String Number

a 123 01

c 123 01

b ABC 01

d ABC 01

measured point

Station

positive radialpositive height
directiondirection

positive tangential
direction

Offset Directions

In 3 dimensions In Plan

Station

measured point
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Start New String
A new string is automatically started whenever a different string number is used. However there 
is also a start new string command which begins a new super string even if the string number is 
the same as the string number for previous points.

The New String command is particularly useful for correcting the field error of forgetting to 
change the string number.

Please continue to the next section “Close String” .

Close String
The close string command closes a super string by joining the first and last points of the super 
string. If a super string is already closed, then the close has no effect. The string closed command 
can be given at the recording of any point of the string, and the entire string is closed.

Please continue to the next section “Rectangle” .

EB 01 EB 01 EB 01 EB 01

or use the start new
string command

ES 01 ES 01 ES 01 ES 02

change string number
to start new string,

ES 02

Close String

first point

last point

add link to join
first and last points
to close the string
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Rectangle
The rectangle command acts on last three points of a string and adds a new point after the last 
point to form a parallelogram (squashed rectangle). The string is then closed.

 The height of the added point is set to null.

Please continue to the next section “Rectangle by 2 Points” .

Form Rectangle

point 1

point 2

point 3

construct point 4 to
form a parallelogram.
Its height is null.
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Rectangle by 2 Points
The rectangle by 2 pts command acts on last two points of a string and adds two new points at a 
given offset after the last point to form a rectangle. The string is then closed.

 The height of the added points are set to null.

Please continue to the next section “Feature” .

Form Rectangle By 2 Points

point 1

point 2 point 3

Points 3 and 4
constructed from a given

point 4

offset relative to the reference 
line from 1 to 2.(Positive
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Feature
A feature string is a circle with a z-value at the centre but only null values on the circumference of 
the circle.

The feature commands creates a feature string with the picked up point as its centre and the 
radius/diameter being set by the feature command.

If a feature string is given a world line style, then the style is centred on the centre point of the 
feature string and scaled up to the radius of the feature string. 

If a feature string is given a screen or paper line style, then the style is wrapped around the 
circumference of the feature string.

Please continue to the next section “Joining Strings” .

Feature String

centre point of the
feature string is the
picked up point.

there are no valid
points on the circumference.
They are for drawing purposes
only.
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Joining Strings
There are three commands for joining two strings together.

Join last points of strings - the last point of the first string is joined to the last point of the second 
string. The direction of the final string is along the forward direction of the first string, across to 
the end of the second string and then in the reversed direction of the second string.

Join first to last points of strings - the first point of the first string is joined to the last point of the 
second string. The direction of the final string is in the reverse direction of the first string, across 
to the start of the second string and then in the forward direction of the second string.

Join first points of strings - the first point of the first string is joined to the first point of the 
second string. The direction of the final string is in the reverse direction of the first string, across 
to the start of the second string and then in the forward direction of the second string.

Please continue to the next section “Arcs Through Points” .

first point

last point

First string
first point

last point

Second string Join last points of strings

Join first to last point
Join first points of strings

Join Strings
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Arcs Through Points
There are a number of commands to fit arcs through sequences of three or more points. Note that 
this is an arc in plan, with different z-values at each of the three points. The z-values are linearly 
interpolated around the arc between the points.

Hence it is a helix and not a circle in the plane containing the three points. Note that an 3d-arc in 
a plane not parallel to the x-y plane does not project onto an arc in the x-y plane.

There are arc commands to

(a) fit an arc through the next three points

(b) fit an arc through the previous three points.

(c) fit arcs to sets of three points until stopped.

The first two cases need no explanation but in the final case, a arc is fitted to the first three points, 
and then another arc to points 3, 4 and 5 and then an arc through 5,6 and 7 and so on. If at any 
stage there is only one point left, then no arc can be fitted and a straight line is drawn to the final 
point.

Please continue to the next section “Field Templates” .

Pt 1

Pt 2
Pt 3

Pt 4

Pt 5

Pt 6

arc through points 1,2,3

arc through points 3,4,5

not enough points
to fit a final arc

Arcs through Points
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Field Templates
If a series of points are being picked up along the one string then the feature code and string 
number only need to be entered once since the default for a measurement is to use the last feature 
code and string number if no new ones are given. However it is often much more efficient to pick 
up one point from a number of strings before moving onto the next point of the each string (cross 
section pick up).

For example when picking up a road, it would be preferable to pick up the points for a section 
across the road and then move onto the next section rather than picking up all of one string at a 
time. In the diagram below, this means picking up one point from each of the strings LV, LS, LK, 
Cl, RK, RS, RV and then moving onto the next cross section rather than picking up all of LV and 
then all of LS and so on. 

Normally if each measurement is from a different string, then the feature code and string 
number would need to be re-entered with each measurement which is a very time consuming 
process. To simplify the coding for section pick up, 12d Model uses field templates.

Basically, a 12d Model field template consists of defining a sequence of feature codes and string 
numbers for the field template. The field template can be given a unique name or have no name at 
all.

When a field template is used, measurements are taken without entering a feature code and string 
number and the feature code and string number for the measurement come from the field template 
definition.

CL

LV
LS

LK

RK
RS

RV

Cross section pick up

pic
k up
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e po
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fro
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ch
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For example, a field template could be defined as the sequence:

LV 01, LS 01, LK 01, CL 01, RK 01, RS 01, RV 01

When the field template is used, measurements are taken without giving a feature code or string 
number and the measurements will be sequentially given the codes LV 01, LS 01, LK 01 etc.

To define a 12d Model field template, there is a command to start recording the field template. The 
feature codes and string numbers for the next series of measurements until the stop recording 
command is given, are stored as the field template. There are also commands to insert and delete a 
point in the template when picking up.

When a field template is used, the feature code and string number from the field template can be 
used:

(a) in the same order as the codes are defined in the field template (forward direction).

(b) in the opposite order to how the codes are defined in the field template (reverse direction).

(c) in an alternating same and opposite order that the codes are defined in field template (zig-
zag)

These three modes of usage of a field template will be described in the following sections.

Please continue to the next section “Forward Direction” .

LV 01

LV 01

LV 01

LS 01

LS 01

LS 01

LK 01

LK 01

LK 01

CL 01

CL 01

CL 01

RK 01

RK 01

RK 01

RS 01

RS 01

RS 01

RV 01

RV 01

RV 01

Start defining
field template

Stop defining
field template
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Forward Direction
If the field template is used in the forward direction, then the feature codes and string numbers 
are used in the same order that they were defined to be in the field template. Once the end of the 
field template is reached, the feature codes and string numbers re-start at the beginning of the 
field template.

Please continue to the next section “Reverse Direction” .

Reverse Direction
If the field template is used in the reverse direction, then the feature codes and string numbers are 
used in the reverse order to what they were defined to be in the field template. That is the feature 
codes and string numbers start at the end of the field template definition and are used in the 
reverse order. Once the beginning of the field template is reached, the feature codes and string 
numbers re-start at the end of the field template and are used in the reverse order.

LV 01

LV 01

LS 01

LS 01

LK 01

LK 01

CL 01

CL 01

RK 01

RK 01

RS 01

RS 01

RV 01

RV 01

Start picking up

end section

section

end section

start next
section

Forward Pick Up

direction of pick up

direction for defining the field template
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Please continue to the next section “Zig-Zag” .

Zig-Zag
When picking up a road in sections, it is often quickest to pick up the first section going from one 
side of the road to the other side, and then move onto to the next section point on the other side 
of the road and pick up points coming back across the road. Hence the points for the second 
section are in the reverse order to those in the first section. This process is known as zig-zagging.

This situation can be covered in two ways. A field template could be defined containing all the 
points for two sections and the field template used in the forward (or reverse) direction. For 
example, the field template to be used in the forward mode could be defined as:

LV 01, LS 01 LK 01, CL 01, RK 01, RS 01, RV 01, RV 01, RS 01, RK 01, CL 01, LK 01, LS 01, LV 01

However, in 12d Model it is only necessary to define the one section

LV 01, LS 01 LK 01, CL 01, RK 01, RS 01, RV 01

LV 01

LV 01

LS 01

LS 01

LK 01

LK 01

CL 01

CL 01

RK 01

RK 01

RS 01

RS 01

RV 01

RV 01

start picking upend picking up
section

end
section

Reverse Pick Up

direction of pick up

direction for defining the field template

section

Start picking up
next section

LV 01

LV 01

LS 01

LS 01

LK 01

LK 01

CL 01

CL 01

RK 01

RK 01

RS 01

RS 01

RV 01

RV 01

Start picking up

end section

section

end section

start next
section

Zig-Zag Pick Up

zig

zag
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and when the field template is used, it is specified that it is being used as a zig-zag field template 
starting on either the zig (the forward direction of the field template) or the zag (the reverse 
direction of the field template).

Once a zig is completed, 12d Model automatically uses the reverse order of the field template 
and hence produces a zag. Similar, once a zag is completed, 12d Model uses the forward order of 
the field template and produces a zig.

Thus a zag automatically follows a zig and a zig follows a zag.

Hence if a field template is used in the zig-zag mode, it can be used as either:

(a) a zig-zag field template starting on the zig

(b) a zig-zag field template starting on the zag.

Please continue to the next section “Skipping Field Template Points” .
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Skipping Field Template Points
When picking up points using a field template, 12d Model allows for one or more points to be 
skipped. By default, the points on the strings on either side of the skipped points will then be 
joined together.

By combining skipping points and start new string commands, points can be skipped and new 
strings started on the other side of the skipped points.

Please continue to the next section “Insert Template Points” .

LV 01

LV 01

LV 01

LS 01

LS 01

LK 01

LK 01

CL 01

CL 01

RK 01

RK 01

RK 01

RS 01

RS 01

RS 01

RV 01

RV 01

RV 01

LS 01

skipped
points

Skipping Points

LV 01

LV 01

LV 01

LS 01

LS 01

LK 01

LK 01

CL 01

CL 01

RK 01

RK 01

RK 01

RS 01

RS 01

RS 01

RV 01

RV 01

RV 01

LS 01

skipped
points

Skipping Points

start new
string
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Insert Template Points
When picking up points using a field template, 12d Model allows for one or more points to be 
inserted. The inserted points change the template from that point onwards so that extra strings 
can be picked up as they arise.

If the insert point command is given after the last point of a template, a flag should also be 
applied to specify which template pick-up the inserted point is to be added. i.e. The last series of 
points or the next series. This flag is called the "insert special" flag. If ticked on the insert panel or 
if the flag given in the offset code is 1, the point will be added to the current pick-up template. In 
the case shown below, the insert special flag should be set to on so that the next picked up point 
will be on the current template. The insert would have been made after the last LV 01 
observation in the last pick-up direction. The following pick-up will use the redefined template 
definition.

It is also possible to multiple code points such that more than one code can be assigned to the 
one pick-up point. In the case shown below, an insert was made on the next pick-up direction 
after the LV 01 observation. The multiple code tick box or flag was set on so that the last picked 
up point will be assigned the extra code specified, in this case DR 01. The template will be 
applied to all subsequent measurements such that the observed LV_01 string will also be coded 
DR 01.

Please continue to the next section “Delete Template Points” .

LV 01

LV 01

LV 01

LS 01

LS 01

LK 01

LK 01

CL 01

CL 01

RK 01

RK 01

RK 01

RS 01

RS 01

RS 01

RV 01

RV 01

RV 01

LS 01

Inserting Points

SH 01

RV 01RS 01
RK 01

CL 01LK 01LS 01
LV 01

last pick-up direction
 

DR 01

LS 01SH 01 LV 01
next pick-up direction



12d Model Reference Manual

Page 3102 February 2004Field Templates

Delete Template Points
When picking up points using a field template, 12d Model allows for one or more points to be 
deleted. The deleted points change the template from the next specified number of points 
inclusive of the current point. i.e. They are removed from the template.

If a template delete command was given after the LS 01 string in the next pick-up direction, and 
the number of specified points were 3, the template will be altered such that the next observed 
string will be RS 01.

LV 01

LV 01

LV 01

LS 01

LS 01

LK 01

LK 01

CL 01

CL 01

RK 01

RK 01

RK 01

RS 01

RS 01

RS 01

RV 01

RV 01

RV 01

LS 01

Deleting Points

SH 01

RV 01RS 01
RK 01

CL 01LK 01LS 01
LV 01

last pick-up direction
 

DR 01

LS 01SH 01 LV 01
next pick-up direction

RS 01
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Shape field coding
If a an object of a standard section is to picked up such as a length of kerb, a shape can be defined 
and extruded/parallelled along a single pick-up string related to that shape.

For example, a kerb shape can be defined by observing all points on a typical section of the kerb 
and assigned a shape name. Then when picking up the length of kerb, only one reference string 
to the shape (defined when recording the shape) has to be picked up e.g. lip of kerb. On 
reduction, 12d can extrude or parallel the shape such that the strings/shape of the kerb are 
produced for the entire kerb pick-up.

Normally if each measurement is from a different string e.g back of kerb, lip kerb etc., then the 
feature code and string number would need to be re-entered with each measurement which is a 
very time consuming process. To simplify the coding for section pick up, 12d Model uses shape 
field coding.

Basically, a 12d Model shape consists of observing a number of points on a given section of an 
object. The shape can be given a unique name or have no name at all.

For example, a shape can be defined by observations shown in order above

1- being the reference point, 2- 7 being the shape points. In this case, the 1st point of the shape 
pick-up coincides with the reference point.

To define a 12d Model shape, there is a command to start and end the recording of the shape. The 
feature codes and string numbers for the next series of measurements until the stop recording 
command is given, are stored in the final shape.

As the shape is defined, other field codes can be used in conjunction such as offset. In this 
example an observation may be made at 5 for the position of 6 using a vertical offset. Similarly 
for point 7 using the observation at a point near point 2. In addition, points 6 and 7 can be made 
non-tinable so that formation of a tin is constrained to the surface of the kerb.

The next step is to pick up the entire length of the kerb at the reference string position using the 
same feature code and string number used for the reference string in the shape pick-up. In this 
example the lip of kerb.

Once completed, the shape can be extruded or parallelled using the extrude or parallel 
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commands. The parallel command will create a number of strings according to the number of 
points on the shape. The extrude will create a super string with a shape defined like a pipe 
string.
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Traverse coding
If a traverse is undertaken as part of a survey, a traverse code and string number can be coded so 
that 12d can extract the traverse information. The specific traverse code can be supplied in the 
survey reduction panel under the traverse tab. An example is shown below:

In this case, the feature code of TL will be searched in the field file on reduction, so that a traverse 
string can be extracted. The user is required to nominate the foresight measurement with the TL 
code in this example. If they also include the TL code in a backsight to a previously defined 
traverse leg, a reciprocal calculation will be made. It uses the pair of observations (Foresight and 
Backsight observations of the same line e.g. Foresight 1001 to 1002 and backsight from 1002 to 
1001). This reciprocal calculation takes the mean of the distance and vertical angles eliminating 
the effects of refraction.

A number of separate but interrelated traverses can be extracted using differing string numbers 
in the field.

The traverse code also allows for adjustments to be made between known stations. This 
adjustment maybe be chosen in the reduction panel. This field is optional.
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Field Coding for Leica Instruments
For Leica instruments, the Leica GSI format breaks lines of data into fixed length ’words’ and 
cannot use the same encoding method as the other instruments. The 12d Model coding system 
for the Leica TPS instruments is covered in the section “12D and Leica TPS Instruments” .
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Field Coding for Non Leica Instruments
EDM equipment is used to make readings of points in the field.

Rather than just collecting points, it is usually desirable to add extra information by coding the 
readings in a way that can be interpreted during the data reduction process and produce more 
valuable information. Unfortunately, this extra coding is non-standard and software specific.

In 12d Model, all the raw data files from different data collectors are converted into the one 
standard field file format (the 12d Model field file) before being loaded into a 12d Model Survey 
Reduction function and reduced. Hence the method for coding information in the data collector 
in the field needs to be well defined so that it can be sensibly converted into a 12d Model field 
file (the section “The 12d Field File Format”  contains the complete description of the 12d field 
file).

When a measurement is taken, most data collectors (Sokkia, Geodimeter, Topcon, Nikon etc.) 
allow the user to enter text which is then output with the measurement data. Depending on the 
data collector, the total number of characters of text may be strictly limited and may also be 
restricted to only one line of text. In 12d Model, a coding system has evolved so the text can be 
interpreted in a meaningful way.

Blocks and the Block (Command) Delimiter
To allow the one line of text to hold a variety of different information, the line of text is broken up 
into smaller blocks and each block is processed separately.

The character (or characters) used as the block separator is called the command delimiter or block 
delimiter.

Obviously the command delimiter can not appear in any of the commands inside a block. 

What is used for the command delimiter is user defined in the data collector definition and is 
found on the Delimiters tab of the Survey.4d Create/Edit panel in the section “Data Collector 
Definitions” .

The default command delimiter is * and this will be used in the examples in this appendix.

Hence using the command delimiter, the text line is broken into separate blocks for processing.

For example, the text string 

EB01*XA.road 

breaks into the separate blocks.

EB01

XA.road
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A block can be either a control code block or a feature code block.

A control code block is any block that start with a valid control code.

Valid control codes are simply the one or more characters of text designated in the Delimiters, 
Features, Templating, Pipes/Culverts, Not Tinable and Strings tabs in the Survey.4d Create/Edit panel 
for the selected data collector definition.

If no control code appears at the start of the block, then the block is taken to be a feature code block.

For example, for the Sokkia Feature String data collector definition which is installed with 12d 
Model, the valid control codes are *, dot (.), space,+, BS, CHK, X, C, R, S, E, ST, XA, XB, XC, XD, 
XE, XF, NH, XP, XL, XN, I, O and A

Any block starting with any of above control codes is a control code block. Blocks that aren’t 
control code blocks are feature code blocks.

Block or command delimiter -

Comment delimiter -

Offset code delimiter -

String delimiter - can be used
to separate feature code and
string number 

separates blocks 

defines the start of a comment 

separates offset codes 
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Blocks can include comments and how a comment in specified is given in the next section 
“Comments in a Block” . 

The feature code block is discussed in the section “Feature Code Blocks” .

The explanation of each control code is given in the section “Control Code Blocks” .

Please continue to the next section “Comments in a Block” .

Tabs on the Sokkia Feature String data collector definition which define Control Codes
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Comments in a Block
Comments are supported in a block. There is a Comment delimiter and all characters after the 
comment delimiter to the end of the block are treated as a comment.

Comments are attached to the measurement point as text.

Hence the measurement will create a vertex on a super string and the comment will create text at 
that vertex of the super string.

The default for the Comment delimiter is / and it is defined by the Comment field on the Delimiters 
tab of the Survey.4d Create/Edit panel.

For example, if * is the command (block) delimiter and / is the comment delimiter, then in

EB01/first point of a template*XA.road 

there are two blocks   EB01/first point of a template    and   XA.road 

and the text "first point of a template" in the first block is a comment and will be added to the 
super string as vertex text.

Another common character to use as a comment delimiter is a space (’ ’). For example, if * is the 
command delimiter and space is the comment delimiter, then in

EB01 first point of a template*XA.road

"first point of a template" is a comment.

The comment delimiter for the Sokkia Feature String data collector is a space

Please continue to the next section “Feature Code Blocks” .

Feature Code Blocks
Feature Code, String Number and String Delimiter
In a feature code block, the feature codes and string numbers are given so that strings are 
automatically created during the reduction process.

The feature code and string number appear at the start of the feature code block and can be entered 
in a variety of ways.

Some surveyors like to enter the string number before the feature code and other surveyors prefer 
to enter the string number after the feature code. Some surveyors prefer to use no string numbers at 
all (SDRmap users) and use a new string control code to start a new string.

All three methods are supported in 12d. The setting is made on the String number position field on 
the Feature Coding tab of the Survey.4d Create/Edit panel. The default is ’before feature code’.



Appendix A

February 2004 Page 3111Field Coding for Non Leica Instruments

If string numbers are going to be used (either before feature code or after feature code) then there are 
rules for determining what is the feature code and what is the string number. Note that the string 
number is always numeric and can be any length.

Firstly, the feature code and string numbers can be separated by an optional String delimiter given 
by the String field on the Delimiters tab of the Survey.4d Create/Edit panel. The default character 
for the string delimiter is +.

For example, 20+110KVA is interpreted as string number ’20’ and feature code 
’110KVA’ if the string number comes before the feature code.

If a String delimiter is not used, then there are some restrictions on the feature code so that the 
feature code and string number can be split apart. Note that the string number is always numeric 
and can be any length.

If a string delimiter is not used, then either

(a) the feature code must be purely alpha and then the feature code can be of any length.

Delimiters Tab on the Survey.4d Create/Edit Panel
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or

(b) the feature code is purely numeric. Then the feature code must the fixed length given by the 
Numeric feature coding field on the Feature Coding tab of the Survey.4d Create/Edit panel. If the 
Numeric feature coding field is not set and the feature code is numeric, then the whole thing is 
interpreted as a feature code with a string number of 0.

If a feature code is a mixture of alpha and numeric, then a string delimiter must be used to separate 
the feature code from the string number. Once a string delimiter is used, feature code can be any 
length.

Tinability as Part of the String Number
For compatibility with other software coding schemes, the tinability of a point can be included as 
part of the string number. This is not normally recommended since 12d has more flexible 
methods of defining tinability.

The field Tinability position on the Feature Coding tab of the Survey.4d Create/Edit panel controls 
whether it is used or not. The default is ’no tinability’ as part of the string number.

If tinability is used as part of the string number, then it consists of either a 0 or a 1.

If Tinability position is set to before string, the first character of the string number is stripped off and 
taken as the tinability flag. A value of 1 means the point is tinable and 0 is non-tinable.

If Tinability position is set to after string, the last character of the string number is stripped off and 
taken as the tinability flag. A value of 1 means the point is tinable and 0 is non-tinable.

Offset Codes
It is not always possible to measure a point directly but it may be possible to measure a point 
nearby and then measure an offset to adjust the measured point by and so produce the co-
ordinates of the required point. The three offsets that are allowed in 12d Model are height, radial 
and tangential. See the Section  “Offsets” for more information.

The three offsets height, radial and tangential have the codes H, R and T respectively.

The offset codes come after the feature code-string number combination and are separated by the 
Offset code delimiter whose default value is a decimal point (.) and is defined by the Offset code 
field on the Delimiters tab of the Survey.4d Create/Edit panel.

After the offset code delimiter, the offset code is given as either H, R or T and then a real value for 
the offset (with no spaces in between). The offset can be positive or negative with the sign only 
being recorded if negative. A second and third offset code (H, R or T) can follow the first but no 
offset code delimiter is used for the second or third offset codes. The offset code delimiter is only 
used to separate the field code-point number from the offset codes.

In the example 20+110KVA.H2.1T0.5 there is a horizontal offset of 2.1 and a 
tangential offset of 0.5.

Multiply Coded Points
It is possible to have more than one Feature code block and this will create a multiply coded point.
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For example, if the command delimiter is *, then EB01*PP would have the two 
feature code blocks ’EB01’ and ’PP’.

Please continue to the next section “Control Code Blocks” .
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Control Code Blocks

Control Codes on the Delimiters tab

Extra Coding
This code is only for the instruments supporting the Sokkia SDR format.

The default for the extra coding control code is X and it is defined by the Extra coding field on the 
Delimiters tab of the Survey.4d Create/Edit panel.

For some instruments, extra lines of information can be entered after a measurement. For 
example on a Sokkia by using the note (13NM) to add more information to the previous 
measurement line (07).

The extra coding control code is used to append this additional information to the information on 
the measurement line. Hence it is then possible to have extra blocks of information on the line (or 
lines) following the measurement line.

The block containing the extra coding control code must be the last block on the measurement 
line.

For example,

EB01/first point of a template*XA.road*X
/ this is some extra info that happens to be a comment

is the same as 

EB01/first point of a template*XA.road*/ this is some extra info that happens to be a comment

Note that there must be a feature code block on the measurement line otherwise a point will be 
created with no name. 

Backsight
The default for the backsight control code is BS and it is defined by the Backsight field on the 
Delimiters tab of the Survey.4d Create/Edit panel.

The rest of the block after the backsight control code is the name of the station that the backsight 
was to, or the point number that the backsight was to. 

For example, if BS is the backsight control code

BSPSM3

would designate a backsight to the station PSM3.

Delimiters Tab on the Survey.4d Create/Edit Panel
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If only the backsight control code exists, the point number from the reading is taken as the point 
number for the backsight. This may be data collector dependent.

Warning for feature codes starting with the backsight control code.

If the feature codes comes before the string number, then feature codes for ordinary 
measurements can not start with the backsight control code because they would be interpreted 
as backsight measurements and no measurement point would be created.

If the feature codes comes after the string number, then whenever a feature codes for ordinary 
measurements is used that starts with the backsight control code, a string number (which may be 
zero for a point string) must be used otherwise the feature code will be interpreted as a backsight 
measurement and no measurement point would be created.

Foresight
There is no default for the foresight control code. It is defined by the Foresight field on the 
Delimiters tab of the Survey.4d Create/Edit panel.

The rest of the block after the foresight control code is the name of the station that the foresight was 
to, or the point number that the foresight was to. 

For example, if FS is the backsight control code

FSPSM3

would designate a backsight to the station PSM3.

If only the foresight control code exists, the point number from the reading is taken as the point 
number for the foresight. This may be data collector dependent.

Warning for feature codes starting with the foresight control code if the Allow point numbers as 
stations flag is not set on the Advanced tab of the Survey.4d Create/Edit panel.

If the feature codes comes before the string number, then feature codes for ordinary 
measurements can not start with the foresight control code because they would be interpreted as 
foresight measurements and no measurement point would be created.

If the feature codes comes after the string number, then whenever a feature codes for ordinary 
measurements is used that starts with the check measurement control code, a string number 
(which may be zero for a point string) must be used otherwise the feature code will be 
interpreted as a foresight measurement.

If the Allow point numbers as stations flag is set on, then a point number used as a foresight will 
create a measurement point for that point number.

Check Measurement
The default for the check measurement control code is CHK and it is defined by the Check 
measurement field on the Delimiters tab of the Survey.4d Create/Edit panel.

The rest of the block after the check measurement control code is the name of the station that the 

Advanced tab on the Survey.4d Create/Edit Panel
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check measurement was to, or the point number that the check measurement was to. 

For example, if CHK is the check measurement control code

CHKPSM3

would designate a check measurement to the station PSM3.

If only the check measurement control code exists, the point number from the reading is taken as 
the point number that the check measurement is made to. This may be data collector dependent.

Warning for feature codes starting with the check measurement control code.

If the feature codes comes before the string number, then feature codes for ordinary 
measurements can not start with the check measurement control code because they would be 
interpreted as check measurements and no measurement point would be created.

If the feature codes comes after the string number, then whenever a feature codes for ordinary 
measurements is used that starts with the check measurement control code, a string number 
(which may be zero for a point string) must be used otherwise the feature code will be 
interpreted as a check measurement and no measurement point would be created.

Control Codes on the Strings tab

Close String
The default for the close string control code is C and it is defined by the Close field on the Strings 
tab of the Survey.4d Create/Edit panel.

The close string control code closes the string that the measurement is a point of.

See the Section  “Close String” for more information on closing a string.

Rectangle
The default for the rectangle control code is R and it is defined by the Rectangle field on the Strings 
tab of the Survey.4d Create/Edit panel.

The rectangle control code uses the current point and the previous two points in the same string 
(three points total) and creates a new point to form a parallelogram.

 See the Section  “Rectangle” for more information on forming a rectangle.

Rectangle by 2 Pts
A rectangle_2 control code can be defined by the Rectangle by 2 pts field on the Strings tab of the 
Survey.4d Create/Edit panel.

The rectangle_2  control code uses the current point, last point and an offset. The rectangle is 

Strings tab on the Survey.4d Create/Edit Panel

Strings tab on the Survey.4d Create/Edit Panel
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defined by two points (reference side) and a offset.

If a positive offset value is given, two points will be created to the right of the reference side.

If a negative offset value is given, two points will be created to the left of the reference side.

If no Description is given, the two new points will be joined to the given points in a closed 
rectangular string, and will have the same feature code as the points given.

If the feature code and string number exist, then a search is made for the last occurrence of two 
points with the same feature code and string number. If found, then these points are used to 
define the reference side of the rectangle.

If the point number exists, then a search is made for the last occurrence of two points with the 
same feature code and string number as the point given by the point number. If found, then 
these points are used to define the reference side of the rectangle.

Two consecutive rectangles are unable to be defined side by side. In other words if the two points 
given are part of string of greater than two vertices, the command will only work for sets of two 
points that are exclusively defined. i.e. For a 5 point string, a rectangle can be defined by points 1 
and 2, and 4 and 5. 

 See the Section  “Rectangle by 2 Points” for more information on forming a rectangle by 2 points.

Start Arc Fitting
The default for the start arc fitting control code is S and it is defined by the Start arc fitting field on 
the Strings tab of the Survey.4d Create/Edit panel.

The start arc fitting control code starts arc fitting with the current point.

See the Section  “Arcs Through Points” for more information on arc fitting.

End Arc Fitting
 The default for the end arc fitting control code is E and it is defined by the End arc fitting field on 
the Strings tab of the Survey.4d Create/Edit panel.

The end arc fitting control code ends arc fitting at the current point. That is, the current point is 
included in the arc fitting but it is the last point used in the arc fitting.

See the Section  “Arcs Through Points” for more information on arc fitting.

New String
The default for the new string control code is ST and it is defined by the New string field on the 
Strings tab of the Survey.4d Create/Edit panel.

The new string control code starts a new string with the current point even if the feature code and 
string number haven’t changed.

See the Section  “Start New String” for more information on starting a new string.

End String
The end string control code ends the current string even if the feature code and string number 
haven’t changed for the next point.

Control Codes on the Features tab
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Feature by Radius
 There is no default for the feature by radius control code. It it is defined by the by radius field on 
the Features tab of the Survey.4d Create/Edit panel.

The feature by radius control code denotes that the feature has a given radius. For example, if RA 
was used then TRE*RA2 would denote a feature code TRE with a radius of 2 units.

See the Section  “Feature” for more information on feature strings.

Feature by Diameter
 There is no default for the feature by diameter control code. It it is defined by the by diameter field 
on the Features tab of the Survey.4d Create/Edit panel.

The feature by diameter control code denotes that the feature has a given diameter. For example, if 
DI was used then TRE*DI2 would denote a feature code TRE with a diameter of 2 units .

See the Section  “Feature” for more information on feature strings.

Control Codes on the Pipes/Culverts tab

Invert Point for Pipe or Culvert
The default for the invert level control code is I and it is defined by the Invert field on the Pipe/
Culverts tab of the Survey.4d Create/Edit panel.

The invert level control code denotes that the point is an invert level (bottom).

The invert commands can also denote the diameter of a pipe or width and height of a culvert. 
For example, I.3 denotes the measurement was an invert level and it was a pipe of diameter 0.3 
units. I.3x.4 denotes the measurement was an invert level and it was a box culvert of width 0.3 
and height 0.4 units.

Obvert Point for Pipe or Culvert
The default for the obvert level control code is O and it is defined by the Obvert field on the Pipe/
Culverts tab of the Survey.4d Create/Edit panel.

The obvert level control code denotes that point is an obvert level (top).

Features tab on the Survey.4d Create/Edit Panel

Pipes/Culvert tab on the Survey.4d Create/Edit Panel
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The obvert command can also define the diameter of a pipe or width and height of a culvert. For 
example, O.3 denotes the measurement was an invert level and it was a pipe of diameter 0.3 
units. O.3x.4 denotes the measurement was an invert level and it was a box culvert of width 0.3 
and height 0.4 units.

Centre Point for Pipe or Culvert
The default for the centre level control code is A and it is defined by the Centre field on the Pipe/
Culverts tab of the Survey.4d Create/Edit panel.

The centre level control code denotes that point is an centre level (axial).

The centre command can also define the diameter of a pipe or width and height of a culvert. For 
example, A.3 denotes the measurement was an invert level and it was a pipe of diameter 0.3 
units. A.3x.4 denotes the measurement was an invert level and it was a box culvert of width 0.3 
and height 0.4 units.

Control Codes on the Non Tinable tab

Remove Height
The control code to set the height of the current point to null.

The default for the remove height from point control code is NH and it is defined by the Remove 
height field on the Non-Tinable tab of the Survey.4d Create/Edit panel.

Point
The default for the make point non-tinable control code is XP and it is defined by the Point field on 
the Non-Tinable tab of the Survey.4d Create/Edit panel.

The make point non-tinable control code makes the current point non-tinable. That is, the point is 
not used in tins (triangulations).

Previous Segment
The default for the make previous segment non-tinable control code is XL and it is defined by the 
Previous segment field on the Non-Tinable tab of the Survey.4d Create/Edit panel.

The make previous segment non-tinable control code makes the previous segment non-tinable. That 
is, the segment that the current point is the end of is non-tinable and hence not used as a 
breakline in tins (triangulations).

Next Segment
The default for the make next segment non-tinable control code is XN and it is defined by the Next 
segment field on the Non-Tinable tab of the Survey.4d Create/Edit panel.

The make next segment non-tinable control code makes the next segment point non-tinable. That is, 
the segment that the current point is the start of is non-tinable and hence not used as a breakline 

Non tinable tab on the Survey.4d Create/Edit Panel
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in tins (triangulations).

Control Codes on the Templating tab

Record
The control code to denote that this is the first point of a new field template definition. The field 
template definition continues until the next stop recording a field template control code or a start 
using a field template control code.

If the field template is to have a name, then the start recording control code is followed by the 
offset code delimiter and then the name for the field template. If no name is given, then the field 
template defines the default field template.

For example, if XA starts recording for the default template, XA.road starts recording the field 
template called road

The default for the start recording a field template control code is XA and it is defined by the Record 
field on the Templating tab of the Survey.4d Create/Edit panel.

See the Section  “Field Templates” for more information on field templates.

Start
The control code to denote that a field template is being used. This point takes the feature code 
and string number from the field template. If it is a named field template, then the control code is 
followed by the offset code delimiter and then the name of the field template.

The field template can also be used as a forward template, a reverse template or as a zig-zag 
template starting on either a zig or on a zag.

The denote using the field template as a forward template, add the offset code delimiter and for.

To denote using the field template as a reverse template, add the offset code delimiter and rev.

To denote zig-zag mode starting on a zig, add the offset code delimiter and zig.

To denote zig-zag mode starting on a zag, add the offset code delimiter and zag.

If anything other than ’for’, ’rev’ or ’zag’ is given, the field template is used as a zig-zag template 
starting on a zig.

For example, if XB starts using the default template, XB.road.zag starts using the field template 
called road as a zig-zag field template starting on a zag.

The default for the start using a template control code is XB and it is defined by the Start field on 

Templating tab on the Survey.4d Create/Edit Panel
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the Templating tab of the Survey.4d Create/Edit panel.

See the Section  “Field Templates” for more information on field templates.

End
The control code to end the use of the current field template after the current point. That is, the 
current point uses the field template but subsequent measurements don’t.

The default for the stop using a template control code is XC and it is defined by the End field on the 
Templating tab of the Survey.4d Create/Edit panel.

See the Section  “Field Templates” for more information on field templates.

Pause
The control code to pause using the current field template. The current point does not use the 
field template.

The default for the pause using a template control code is XD and it is defined by the Pause field on 
the Templating tab of the Survey.4d Create/Edit panel.

See the Section  “Field Templates” for more information on field templates.

Pause after
The control code to pause using the current field template and the current point does use the 
field template.

There is no default for the pause after control code and it is defined by the Pause after field on the 
Templating tab of the Survey.4d Create/Edit panel.

See the Section  “Field Templates” for more information on field templates.

Continue
The control code to continue the use of a paused field template. The current point uses the field 
template.

The default for the continuing using a field template control code is XE and it is defined by the 
Continue field on the Templating tab of the Survey.4d Create/Edit panel.

See the Section  “Field Templates” for more information on field templates.

Skip
The control code to skip point one or more points of the field template. The current point uses 
the next point after the skipped points from field template.

 If more than one point is to be skipped then the control code is followed by the offset code 
delimiter and then number of points to be skipped.

For example, if XF is the skip points control code, XF.2 skips two points. Note that just XF skips 
one point and the ’.1’ is not required.

The default for the skipping field template points control code is XF and it is defined by the Skip 
field on the Templating tab of the Survey.4d Create/Edit panel.

See the Section  “Field Templates” for more information on field templates.

Insert
A default control code to insert a point in the field template can be added to this field. The point 
in inserted after the last point. 

See the Section  “Field Templates” for more information on field templates.
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Delete
A default control code to delete a point in the field template can be added to this field. a number 
of points can be nominated for deletion.

See the Section  “Field Templates” for more information on field templates.

Feature coding for traverse extraction (Non- Leica 
instruments)

In the example shown above, three distinct traverses were observed. The main traverse between 
stations 900 and 901 were given a feature code of TL and a string number of 1 (TL1). A typical 
observation description follows:

Setup on station 900. A foresight measurement was taken from 900 to 1001. A typical feature 
code may be:

TL1 FS1001. Where the block delimiter is a space(" ") breaking the feature code up into TL1 and 
FS1001. This tells the reduction that the observation was a traverse because it has a feature code 
of TL as specified in the traverse tab of the reduction panel. The foresight control code may be FS, 
telling the reduction that the observation is a foresight observation to a named point

Setup on station 1001. A backsight to station 900 was observed. A typical feature code may be:

TL1 BS900. Where BS is the backsight control code

A foresight to 1002 may be coded as:

TL1 FS1002. 

And so forth.

The observation to station 1013 may be made at the same time as when observing to station 1007 
from the setup station 1006. Simply changing the string number to 2 for the observation to 1013 
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will ensure that it is treated as a different traverse. i.e. TL2 FS1013.

The second traverse between stations 1006 and 902 were given a feature code of TL and a string 
number of 2 whilst the traverse between stations 1010 and 903 were given a feature code of TL 
and a string number of 3.

The feature code/ string number needs to be present for at least the foresight or measured leg of 
each of the traverse legs. If they are also present for the backsight, then foresight/backsight pairs 
will be grouped together and reciprocal calculations done for that leg. 



12d Model Reference Manual

Page 3124 February 2004Data Collector Definitions

Data Collector Definitions
Unfortunately, each brand of data collector has its own method of communicating with a 
computer and a software package.

To allow for a variety of data collectors, 12d Model lets the user create and edit data collector 
definitions which are simply user defined sets of data collector parameters stored under user 
specified names.

The set of data collector definitions are stored in a file but are created and edited using the 12d 
Model panel Survey.4d Create/Edit.

The Survey.4d Create/Edit panel is accessed via Project => Browse.

First select Project => Browse and then click on the + beside the Project name to expand the list of 
available information for the project. Then click on the + beside Survey data collectors to see the list of 
existing 12d data collector definitions.

Double click LB on Create data collector to create a new data collector definition, or double click LB on 
an existing data collector definition to examine and/or modify it.

The Survey.4d Create/Edit panel will then appear.

survey_4d_create_edit
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Collector input available data collectors
name of the data collector to create/edit.

Defaults button
set all the panel fields to default values.

Clear button
clear the values in the panel fields in all the tabs.

Set button
set the values in the panel fields for the given data collector for this session of 12d Model. 

WARNING - Set does not save the changes to the survey.4d file. To save the changes, click on the 
’Save’ button.

Save button
store the data collector definitions to the survey.4d file.

For descriptions of each of the tabs on the panel, go to:
Translation “Translation tab” .

 Feature coding  “Feature Code tab” .
 Delimiters  “Delimiters tab” .
 Download “Download tab” .
 Advanced  “Advanced tab” .
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 Upload “Upload tab” .
 Instrument  “Instrument tab” .
 V4 Columns  “V4 Columns tab” .
 Templating  “Templating tab” .
 Shapes  “Shapes tab” .
 Pipe/Culverts  “Pipes/Culverts tab” .
 Non tinable  “Non visible tab” .
 Non visible  “Non visible tab” .
 Strings  “Strings tab” .
 Others  “Others tab” .
 Features  “Features tab” .

Translation tab

Instrument input Geodimeter, Leica
 Nikon DR1, Nikon AP700, Sokkia 20/33

 Topcon GT700, Topcon FC5

type of data collector format.

Raw file extension input
file ending to use for the raw file when it is downloaded.

Macro tick box tick
if tick, then the Translator pop-up list only shows 12d Model macros.
If not ticked, then the Translator pop-up list only shows programs.

Translator input list of translators in library
name of the macro/program to translate the raw survey file into the 12d field file format.

Vertical circle input zenith zenith, nadir
define the vertical circle zero.

Feature Code tab

String number position input before before feature code
no string number
after feature code
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defines if the string number is before or after the feature code or is not used at all (no string number). 
When ’no string number’ then the New string command is used to start new strings with the same 
feature code.

Tinability position input no tinability before string
no tinability
after string

defines the position or absence, of the tinability flag. This should only be used for compatibility with 
data coded for other systems such as CivilCAD. 12d has more flexible methods of defining tinability.

Numeric feature coding integer
if ’no string number’ is given for String number position then Number feature coding is ignored.
If a number is given, then the feature code must be numeric and the given number is the length of the 
feature code (that is, the number of digits in the feature code).
If no number is given, then feature codes are alphabetical characters only except when a String code is 
used to separate the feature code and string number.

Delimiters tab

Command input *

defines the separator between the feature code/string number and op code commands. The delimiter 
characters can not be used in any other part of the command line.

Comment input /

defines the separator for comments. Note that this can be a space.

Offset code input dot (.)
defines the beginning of the offset code block. If the offset code block exists, it must come immediately 
after the Feature code/string number/tinability block. The offset code used R for radial, T for tangential, 
H for height.

String input +
separates the feature code from the string number. Used when the feature code includes numbers. For 
example 110KVA+20   would be a feature code of 110KVA and a string number of 20.

Backsight input BS
if the feature code is this control code then the measurement is to a backsight and not a point.

Foresight input
if the feature code is this control code then the measurement is to a foresight and not a point.

Check measurement input CHK
if the feature code is this control code then the measurement is a check measurement and not a point.

Extra coding input X
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denotes that the information following is appended to the previous information for the measurement. 
This allows extra coding than may be allowed for on the measurement line. Mainly for Sokkia using the 
note (13NM) to add more information to the previous measurement line (07).

A feature code block must be on the measurement line or a measurement with no name will be created. 
Also a command block can’t be split between two lines.

Download tab

Port input COM1 COM1 to COM4

port on the computer to use to communicate with the data collector for downloads.

Baud rate input 9600 110, 300 ... 256000

baud rate to use for the computer port.

Data bits input 7 5, 6, 7, 8

number of data bits to use.

Stop bits input 1 0, 1, 1.5, 2

number of stop bits to use.

Parity input none none, even, odd, mark, space

parity to use.

DTR/DSR, RTS/CTS, XON/XOFF,ACK/NAK tick boxes
flow control settings.

Advanced tab

Comment raw files tick box

if tick, include the data from the raw survey file as comments in the 12d field file.

Report header tick box

if tick, include some header information as comments in the 12d field file.

Allow bad line lengths tick box
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if tick, ignore the fact that the length of the line from the data collector is incorrect. This may lead to 
other errors so it should be used sparingly.

Verbose tick box

if tick, then extra information may be written to the Output window.

Allow point numbers as stations tick box

if tick, the point numbers for previous measurements can be used as stations for instrument setups, 
backsights, foresights and check measurements.

Note

When 12d Model starts up, it checks to see if an environment variable called 
DATA_COLLECTORS_4D exists and if it does, then the file it points to is used to provide the 
definitions for the data collectors.

If the environment variable is not set, then 12d Model searches for a file called survey.4d (this 
was data_collectors_definitions in V3.0) in the standard 12d Model search sequence for set up 
files.

Upload tab

Port input COM1 COM1 to COM4

port on the computer to use to communicate with the data collector for uploads.

Baud rate input 9600 110, 300 ... 256000

baud rate to use for the computer port.

Data bits input 7 5, 6, 7, 8

number of data bits to use.

Stop bits input 1 0, 1, 1.5, 2

number of stop bits to use.

Parity input none none, even, odd, mark, space

parity to use.

DTR/DSR, RTS/CTS, XON/XOFF,ACK/NAK tick boxes
flow control settings.

Extension input
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ending of  the file that will be uploaded. For example, typing in sdr means the file to upload ends in 
".sdr"

CR/LF ? input cr, lf, crlf, lfcr,none

end of line characters - characters needed by the data recorder to denote the end of a line of data being 
uploaded to the data recorder.

Delay 1 input

the time between sending lines of data to the data recorder.

Process input

for some data recorders after a data line is sent, a text string needs to be sent to the data recorder to 
make it process the data line (e.g. GRE3 used a P). 

Delay 2 input

the time between sending the process string and sending the next data line.

Ignore comms errors tick box

if tick, ignore any communication errors whilst uploading to the data recorder.

Instrument tab

Measurement/code order input after measurement code before measurement
 code after measurement

For Leica only where the feature code/string number record is separate to the measurement record. For 
all other data recorders the feature code block is in the same record as the measurement.

If ’code before measurement’, then the feature code/ string number record for a measurement is entered 
before taking the measurement.
If ’code after measurement’, then the feature code/ string number record for a measurement is entered 
after taking the measurement.

Sokkia 08KI as GPS points tick box

if tick, when converting reading an Sokkia SDR file, the "08KI" records are treated as points and no 
directly entered station co-ordinates.

V4 Columns tab



Appendix A

February 2004 Page 3131Data Collector Definitions

The V4 columns tab is for compatibility with 12d Model V4 field files which were of fixed 
column widths.

Feature code start/end input 1/6

the start and end column position for the feature code in the field file record.

String number start/end input 7/9

the start and end column position for the string number in the field file record.

Point name/Attribute/Point number start/endinput 22/30, 10/16, 17/20

the start and end column position for the point name/Attribute/Point number in the field file record.

Total length input

the total length of line expected.

Templating tab

Record input XA text

characters to denote the start of recording a field template. For example XA starts recording for the 
default template, XA.road starts recording the field template called road.

Start input XB text

characters to denote the start of using a field template. For example XB starts using the blank field 
template, XB.road starts using the field template called ’road’. XB.road.zig starts using ’road’ a zig-zag 
field template and begins as a zag.

End input XC text

characters to denote stop using the current field template.

Pause input XD text

characters to denote temporarily stop using the current field template to take other measurements. The 
current point does not use the field template.

Pause after input XD text

characters to denote temporarily stop using the current field template to take other measurements. The 
current point does use the field template.

Continue input XE text

characters to denote continuing to use the current field template after a pause.
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Skip input XF text

characters to denote that template points are to be skipped. For example XF means skip one field 
template point, XF.3 means skip three field template points.

Insert input XI text

characters to denote that template points are to be inserted. For example XI.FE01 means insert a 
template point of FE01 into the template after the last measured template point

Delete input XQ text

characters to denote that template points are to be deleted. For example XQ.3 means delete the next 3 
pts from the template after the last measured template point

Shapes tab

Record input text

characters to denote the start of recording a shape. For example if RS was used, the code
RS starts recording for the default shape, RS.shape_name defines the recording of a shape of name 
shape_name.

End input text

characters to denote stop using the current shape.

Parallel input text

characters to denote the application of a shape by parallelling to the shape reference string. The code 
may be LK01*PS.shape_name
Where the Parallel command is PS, the shape reference string is LK01 and the shape name = 
shape_name.

Extrude input text

characters to denote the application of a shape by extrusion to the shape reference string. The code may 
be LK01*ES.shape_name
Where the Extrusion command is ES, the shape reference string is LK01 and the shape name = 
shape_name.

Pipes/Culverts tab

Invert input I text

characters to denote that the measurement was the an invert level.
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Obvert input O text

characters to denote that the measurement was the an obvert level.

Centre input C text

characters to denote that the measurement was the a centreline level.

Note that these commands can also denote the diameter of a pipe or width and height of a 
culvert. For example, I.3 denotes the measurement was an invert level and it was a pipe of 
diameter 0.3 units. I.3x.4 denotes the measurement was an invert level and it was a box culvert of 
width 0.3 and height 0.4 units.

Strings tab

Close input C text

characters to denote that the string is closed. That is the current measurement is joined to the first 
point of the string.

Rectangle input R text

characters to denote that the string is a rectangle. That is the current measurement and the previous 
two points of the string are three points of a parallelogram and the fourth point is automatically created 
(and given a null height).

Start arc fitting input S text

characters to denote the start of arc fitting.

End arc fitting input E text

characters to denote the end of arc fitting.

New string input ST text

characters to denote the that the current measurement is the start of a new string, even if the string 
number has not changed.

Non visible tab

Point input text

characters to denote that the measurement is a non-visible point. That is, the point is not visible and is 
not included in a triangulation.



12d Model Reference Manual

Page 3134 February 2004Data Collector Definitions

Previous segment input text

characters to denote that the measurement is the end of a non-visible segment. That is, the previous 
segment is not used as a breakline in a triangulation and it is not visible.

Next segment input text

characters to denote that the measurement is the start of a non-visible segment. That is, the next 
segment is not used as a breakline in a triangulation and is not visible.

Strings tab

Close input C text

characters to denote that the string is closed. That is the current measurement is joined to the first 
point of the string.

Rectangle input R text

characters to denote that the string is a rectangle. That is the current measurement and the previous 
two points of the string are three points of a parallelogram and the fourth point is automatically created 
(and given a null height).

Rectangle by 2 pts input text

characters to denote that the string is a rectangle. That is the previous two points of the string define 
one side and a offset defines the opposite side. Positive being to the right. The created points are given 
null height.

Start arc fitting input S text

characters to denote the start of arc fitting.

End arc fitting input E text

characters to denote the end of arc fitting.

New string input ST text

characters to denote the that the current measurement is the start of a new string, even if the string 
number has not changed.

End string input text

characters to denote the that the current measurement is at the end of a string, even if the string 
number has not changed on the next measurement.

Others tab

Under development

Features tab
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By radius input text

characters to denote that the feature has a given radius. For example, if RA was used then TRE*RA2 
would denote a feature code TRE with a radius of 2 units.
There can be more than one set of characters that define ’By radius’. The sets are entered into the By 
radius field separated by a space. For example

RA RAD RD
would specify that RA and RAD and RD can be used to denote that the feature is defined by radius.

By diameter input text

characters to denote that the feature has a given diameter. For example, if DI was used then TRE*DI2 
would denote a feature code TRE with a diameter of 2 units.
There can be more than one set of characters that define ’By diameter’. The sets are entered into the By 
diameter field separated by a space. For example

DI DIA DR
would specify that DI and DIA and DR can be used to denote that the feature is defined by diameter.
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The 12d Field File Format
The detailed definition of the standardised 12d Field File will now be given. This is the file that 
all raw files are converted to before reduction in 12d Model.

A few definitions will be given, followed by the complete description of the 12d Field File.

The raw data files from different data collectors are all converted to the 12d field file format.

The 12d field file is ascii and has a name ending in .fld

Each line in the 12d field file is called a record and consists of an operation code (or op code for 
short) followed by zero or more tabs and pieces of information.

(a) zero fields

What actually follows the fixed header depends on the op code.

Hence the 12d field file record is:

or

A number of conventions and definitions will be now given, followed by the complete 
description of the 12d Field File.

Important Note

 Op codes are not the same as field codes. Field codes are entered by the surveyor in the field and 
may lead to one or more op codes being created in the 12d field file.

Please continue to the next section “Point Description” .

Point Description
The feature codes and string numbers are entered by the surveyor whilst surveying in the field and 
the point numbers are usually automatically created by the surveying instrument but may 
sometimes be entered into the instrument by the surveyor.

Other information can also be entered by the surveyor using field codes and associated 
information. How each field code and associated information is entered in the field depends on the 
data recorder and the coding convention being used. This is set up in the Data Collector definitions in 
12d Model.

The data file from the instrument or data collector (raw file) is first converted in 12d Model to the 
12d field file ready for loading into a 12d Model Survey Reduction function for reduction.

In most lines of the 12d field file, a feature code, string number, point number, point name and point 
text are given and are stored next to each other separated by tabs.

op code

99

op code tab value ... tab value

02 abcS fred
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The feature code and string number have already been described.

The point number is the EDM tacheometry measurement point number which is not normally 
entered by the user but is written in the raw data file by the data collector. This is stored as the 
point number for the vertex of the super string.

The point name is used to store the name of a station (see the next section on named 
measurements) and is supplied by the user with certain op codes. It is also used by some op codes 
that do not require an actual point name but have other special information that needs to be 
stored.

The point text is stored as vertex text for that vertex of the super string.

In the 12d field file, the feature code, string number, point number, point name and point text are given 
in this order and are separated by tabs. Each can be up to sixty-three characters in length. If the 
item is missing then a tab is still needed so there may be two or more sequential tabs.

For simplicity in describing the 12d field file, the feature code, string number, point number, 
point name and point text are grouped together and called the point description.

Hence the point description consists of the following pieces of information separated by tabs:

▲ feature code (string name)
▲ string number
▲ point number
▲ point name
▲ point text

So it is convenient to think of the point description record as five columns of information:

Please continue to the next section “Measurements and Named Measurements” .

Measurements and Named Measurements
The 12d field file allows five types of measurements that create points (vertices) in super strings. They are

(a) directly entered co-ordinates measurement

(b) EDM measurement ( HA,VA,SD, + point_description.)

(c) EDM measurement VD (HA,HD,VD + point_description.)

(d) EDM measurement HT (HA,HD,HT, + point_description.) 

(e) three hair stadia measurement

Each type of measurement creates a new point which is appended to the previous points with the same 
feature code and string number.

The last such measurement is referred to as the current measurement point or current point and the string it 
is appended to is the current string.

If a point_name exists in the point_description for any of the three types of measurements, then it is 
called a named measurement and a one point super string of name point_name is created and 
mapped using the mapping file. The vertex text for the one point super string is the station prefix 
followed by point_name. The point_name is added to an internal list of named points for searching 
for co-ordinates.

Please continue to the next section “Existing Station Co-ordinates” .

feature 
code

string 
number

point
number

point  
name

text

abc 01 1002 STN 4 freddie
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Existing Station Co-ordinates
When setting up a new instrument, measuring to a backsight, doing a check measurement or manually 
entering a bearing to use as the bearing datum difference, the point_name or point number from the 
point_description is used to specify a point. The (x,y,z) co-ordinates for point_name are found by 
searching in the following order:

The difference between point names and point numbers is that point names are usually given by the 
user and should be a unique identifier for a point whilst for that same physical point a number of 
measurements (and hence point numbers) may be assigned (usually by the data collector). This 
may be particularly true of control station measurements where measurements are made to a 
given point name but each measurement is given a different point number by the data collector.

In most instances, a measurement to a point has a point number (from the data collector) and 12d 
automatically gives it the same point name as it is rare to measure a non-control point more than 
once (the point name can be over ridden by the user). 

The names allow the reduction routine to search for the details of that point (e.g. coordinates) to 
allow for the reduction of further measurements. The order in which this searching takes place is 
as follows:

First search the Control model (if it exists):

1. A search is made of the control model for a string whose name is the same as the specified 
point name. If a string is found, the first point of the string is used for the (x,y,z) co-ordinates.

2. A search is made of the control model for a vertex of a string whose point number is the same 
as the specified point name. If a vertex is found its (x,y,z) co-ordinates are used.

3.  If only a point number was specified, a search is made of the control model for a vertex of a 
string whose point number is the same as the specified point number. If a vertex is found its 
(x,y,z) co-ordinates are used.

Next search the already entered directly entered co-ordinates (DEC) in the field file:

4. A search is made of previously entered directly entered co-ordinates in the field file for a 
directly entered co-ordinate whose point name is the same as the specified point name. If a DEC 
is found, its (x,y,z) co-ordinates are used.

5. A search is made of previously entered directly entered co-ordinates in the field file for a 
directly entered co-ordinate whose point number is the same as the specified point name. If a 
DEC is found, its (x,y,z) co-ordinates are used.

6. A search is made of previously entered directly entered co-ordinates in the field file for a 
directly entered co-ordinate whose point number is the same as the specified point number. If a 
DEC is found, its (x,y,z) co-ordinates are used.

Next search the previous measurements in the field file:

7. A search is made of previous measurements in the field file for a measurement whose point 
name is the same as the specified point name. If a measurement is found, its (x,y,z) co-ordinates 
are used.

8. A search is made of previous measurements in the field file for a measurement whose point 
number is the same as the specified point name. If a measurement is found, its (x,y,z) co-
ordinates are used.

9. A search is made of previous measurements in the field file for a measurement whose point 
number is the same as the specified point number. If a measurement is found, its (x,y,z) co-
ordinates are used.

10. or finally, the user is asked to type in the (x,y,z) co-ordinates in a Survey Data Define Station panel. If 
a model is specified in the Add to model field of the panel, then a new one point super string is created 
with the name point_name, and as the vertex text for the point, the Station label prefix field value 
followed by point_name.

For a summary of the 12d Field File Op Codes, go to the section “Summary of 12d Field File Op 
Codes” 
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For the full description of the 12d Field File Op Codes, go to the section “Full Description of 12d 
Field File Op Codes” 
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Full Description of 12d Field File Op Codes
For a summary of the 12d Field File Op Codes, go to the section “Summary of 12d Field File Op 
Codes” 

The record for each op code allowed in the 12d field file will now be described in detail.

For each op code record, two lines and a paragraph of description are given:

▲ The first line consists of the op code and a short description of the purpose of the code.

▲ The second line gives the full syntax of the record for that op code.

▲ The paragraph gives a detailed description of the op code record.

Optional information is enclosed in the square brackets [ ]

All angles in the 12d field file are given in decimal degrees.

Important Note

 Op codes are not the same as field codes. Field codes are entered by the surveyor in the field and 
may lead to one or more op codes being created in the 12d field file.

Op Description of Record
Code

1 Four 10 character information blocks
01 block1 block2 block3 block4

This information is ignored.

2 Directly entered coordinate measurement
02 Point_description X Y Z

A measurement point is created with the feature code and string number from the point_description 
and given (x, y,z) co-ordinates. No reduction is needed.

The point_number and text from the point_description are recorded as the point number and text for 
that vertex of the super string.

If a point_name exists in the point_description, then it is a named measurement and a 4d point string 
of name point_name is created and mapped using the mapping file. The 4d text is the station prefix 
followed by point_name. The point_name is added to the internal list of named points for searching for 
co-ordinates.

3 New instrument point
03 Point_description instrument_height

Setting up an instrument at the point with name given in the point_name section of the 
point_description. The (x,y,z) co-ordinates for point_name are found by first searching the control 
model, then the list of previously named point in the reduction, point numbers of previous 
measurements and finally if point_name is still not found, the user is asked to type in the (x,y,z) co-
ordinates. A record is written to the report file.

4 Measurement to backsight
04 Point_description horizontal_circle vertical_circle slope_distance azimuth

Measurement to a backsight whose name is given in the point_name section of the point_description. If 
the Display panel for backsights field in the Survey Data Reduce panel is tick, then the Survey Data 
Bearing Datum Difference panel shows the bearing datum difference and the horizontal distance 
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difference. A record is written to the report file. The units for horizontal_circle and vertical_circle are 
decimal degrees. The azimuth may be specified where no coordinate for the backsight point exists in 
decimal degrees. 

5 New target height
05 Target_height

Set a new target height.

6 Check measurement
06 Point_description horizontal_circle vertical_circle slope_distance

A check measurement is made to the station given in the point_name section of the point_description. 
A two point super string (with name point_name) from the instrument point to the measured point is 
created in the default model for the check measurement. The instrument point name, the station name 
and the differences between the measurement point co-ordinates and the station co-ordinates are 
written as text along the super string. The differences between the measurement and the known point is 
also written to the report file. The units for horizontal_circle and vertical_circle are decimal degrees.

7 Measurement - HA, VA, SD
07 Point_description horizontal_circle vertical_circle slope_distance

Measurement made by the instrument. A measurement point is created with the feature code and string 
number from the point_description. The units for horizontal_circle and vertical_circle are decimal 
degrees.

The point_number and text from the point_description are recorded as the point number and text for 
that vertex of the super string.

If a point_name exists in the point_description, then it is a named measurement and a 4d point string 
of name point_name is created and mapped using the mapping file. The 4d text is the station prefix 
followed by point_name. The point_name is added to the internal list of named points for searching for 
co-ordinates.

9 Scale factor for subsequent distances
09 Scale_factor

Scale factor to apply to subsequent slope distances.

10 Three hair stadia measurement
10 Point_description horizontal_circle vertical_circle bottom middle top

Manual measurement. A measurement point is created with the feature code and string number from 
the point_description. The units for horizontal_circle and vertical_circle are decimal degrees.

The point_number and text from the point_description are recorded as the point number and text for 
that vertex of the super string.

If a point_name exists in the point_description, then it is a named measurement and a 4d point string 
of name point_name is created and mapped using the mapping file. The 4d text is the station prefix 
followed by point_name. The point_name is added to the internal list of named points for searching for 
co-ordinates.

11 Measurement - HA, HD, Height
11 Point_description horizontal_circle horizontal_distance height

Measurement made by the instrument. A measurement point is created with the feature code and string 
number from the point_description. The unit for horizontal_circle is decimal degrees.

The point_number and text from the point_description are recorded as the point number and text for 
that vertex of the super string.

If a point_name exists in the point_description, then it is a named measurement and a 4d point string 
of name point_name is created and mapped using the mapping file. The 4d text is the station prefix 
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followed by point_name. The point_name is added to the internal list of named points for searching for 
co-ordinates.

12 Measurement - HA, HD, Height difference
11 Point_description horizontal_circle horizontal_distance height_difference

Measurement made by the instrument. A measurement point is created with the feature code and string 
number from the point_description. The unit for horizontal_circle is decimal degrees.

The point_number and text from the point_description are recorded as the point number and text for 
that vertex of the super string.

If a point_name exists in the point_description, then it is a named measurement and a 4d point string 
of name point_name is created and mapped using the mapping file. The 4d text is the station prefix 
followed by point_name. The point_name is added to the internal list of named points for searching for 
co-ordinates.

15 Vertical circle correction
09 Vertical_circle_in_decimal_degrees

The vertical_circle_in_decimal_degrees is subtracted from the vertical circle value in any 
measurements. The units for vertical_circle_in_decimal_degrees is decimal degrees.

16 Multiply coded point
16 Point_description

Additional coding for the current measurement point created by op codes 02, 07 or 10. A new 
measurement point is created at the same position as the current measurement point but with the feature 
code and string number from the point_description for this op code.

The point_number and text from the point_description are recorded as the point number and text for 
that vertex of the super string.

If a point_name exists in the point_description, then it is a named measurement and a 4d point string 
of name point_name is created and mapped using the mapping file. The 4d text is the station prefix 
followed by point_name. The point_name is added to the internal list of named points for searching for 
co-ordinates.

17 Arc through previous three points
17 [Point_description]

If no point_description is given, then the current measurement point and the two previous points with 
the same feature code and string number as the current measurement point, are joined by an arc. If there 
is less than three such points, no arc is fitted.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number from the point_description exist, the last three previous 
measurement points of the same feature code and string number are joined by an arc. If the current 
measurement point has that feature code and string number, then it is the third of the three points used. 
If there is less than three points, no arc is fitted.

If Point_number exists, then the feature code and string number are taken from the previous 
measurement point with that point number. That point and the two measurement points previous to the 
predefined point of the same feature code and string number, are joined by an arc. If there is less than 
three points, no arc is fitted

18 Circle Feature
18 Radius

Creates a feature string with the given radius and centred on the current measurement point.
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20 Close string
20 [Point_description]

If no point_description is given, the current string is closed.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number from the point_description exist, the last previous string with that 
feature code and string number is closed.

If the point number from the point_description exists, then the string containing that point number will 
be closed.

21 Join last points of strings
21 Feature_code string_number_1 string_number_2

In the final reduction, the last point of the string with the given feature_code and string_number_1 is 
joined to the last point of the string with given feature_code and string_number_2. The created string 
has the given feature_code (no string number is needed since it is the final phase of reduction when the 
string numbers are dropped).

22 Join first to last point of strings
22 Feature_code string_number_1 string_number_2

In the final reduction, the first point of the string with the given feature_code and string_number_1 is 
joined to the last point of the string with given feature_code and string_number_2. The created string 
has the given feature_code (no string number is needed since it is the final phase of reduction when the 
string numbers are dropped).

23 Join first points of strings
23 Feature code string number_1  string number_2

In the final reduction, the first point of the string with the given feature code and string number 1 is 
joined to the fist point of the string with given feature code and string number 2. The created string has 
the given feature code (no string number is needed since it is the final reduction when the string 
numbers are then dropped).

28 Add text to the string name
28 [Point_description] Text

Text is appended to the string name. For example, if 1.200 is entered, “1.200” is appended to the string 
name.

If no point_description is given, Text is appended to the string name of the current string.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then the last previous string with that feature code and 
string number has Text appended to the string name.

If the point number exists, then the string containing that point number has Text appended to the string 
name.

29 Note or memo
29 Comments

Any text may be entered and will be added to the check measurements model at the position of the 
current measurement point.

30 Remove height from a point - that is make it a null height
30 [Point_description]

If no point_description is given, the height of the current measurement point is set to null.
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If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then the height of the last point of the previous string with 
that feature code and string number is set to null.

If the point number exists, then the height of the point with that point number is set to null.

37 Rectangle by two points
37 [Point_description] offset_in_metres

The rectangle is defined by two points (reference side) and a offset.

If a positive offset value is given, two points will be created to the right of the reference side.

If a negative offset value is given, two points will be created to the left of the reference side.

If no point_description is given, the two new points will be joined to the given points in a closed 
rectangular string, and will have the same feature code as the points given.

If the feature code and string number exist, then a search is made for the last occurrence of two points 
with the same feature code and string number. If found, then these points are used to define the 
reference side of the rectangle.

If the point number exists, then a search is made for the last occurrence of two points with the same 
feature code and string number as the point given by the point number. If found, then these points are 
used to define the reference side of the rectangle.

Two consecutive rectangles are unable to be defined side by side. In other words if the two points given 
are part of string of greater than two vertices, the command will only work for sets of two points that 
are exclusively defined. i.e. For a 5 point string, a rectangle can be defined by points 1 and 2, and 4 and 
5. 

38 Make the previous segment non-tinable
38 [Point_description]

If no point_description is given, the previous segment containing the current measurement point is set 
to non-tinable. That is, it will not be treated as a breakline in triangulations.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then the last segment of the previous string with that feature 
code and string number is set to non-tinable.

If the point number exists, then the segment containing the point with that point number as an end 
point, is set to non-tinable.

39 Make the next segment non-tinable
39 [Point_description]

If no point_description is given, the next segment containing the current measurement point as a 
starting point is set to non-tinable. That is, it will not be treated as a breakline in triangulations.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then the segment that is created in the future from the last 
point of the previous string with that feature code and string number is set to non-tinable.

If the point number exists, then the segment containing the point with that point number as a start point, 
is set to non-tinable.

40 Make a point non-tinable
40 [Point_description]

If no point_description is given, the current measurement point is set to non-tinable. That is, it will not 
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be included in triangulations.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number is set to non-tinable.

If the point number exists, then the point with that point number is set to non-tinable.

41 Add additional text for the current measurement point 
41 Text

The given text is added to the end of any existing text for the current measurement point. Any spaces 
from column four onwards will be part of the text.

42 Add a radial offset
42 [Point_description] Radial_offset_in_metres

The radial_offset_in_metres is used to adjust the position of the specified point by a plan distance from 
the specified points original position, along the plan line joining the current station to the specified 
point. A positive offset is away from the station, negative is toward the station.

If no point_description is given, the offset is used to adjust the position of the current measured point.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number is adjusted.

If the point number exists, then the point with that point number is adjusted.

43 Add a tangential offset
43 [Point_description] Tangential_offset_in_metres

The tangential_offset_in_metres is used to adjust the position of the specified point by a plan distance 
from the specified points original position, at rights angles to the plan line joining the current station to 
the specified point. A negative offset is to the left (looking from the station), and positive is to the right 
(looking from the station).

If no point_description is given, the offset is used to adjust the position of the current measured point.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number is adjusted.

If the point number exists, then the point with that point number is adjusted.

44 Add a height offset
44 [Point_description] Height_offset_in_metres

If the height of the specified point is not null, then the height_offset_in_metres adjusts the height of the 
point. A positive offset adds to the height, a negative offset reduces the height.

If no point_description is given, the offset is used to adjust the position of the current measured point.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number is adjusted.

If the point number exists, then the point with that point number is adjusted.
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45 Make a parallelogram from the last three measurement points
45 [Point_description]

If no point_description is given, the current measurement point and the two previous points from the 
current string are used and a fourth point is created to form a parallelogram (squashed rectangle) and 
the height of the fourth point is set to null. The string is then closed.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, the last three points with that feature code and string 
number are used and a fourth point is created to form a parallelogram (squashed rectangle) and the 
height of the fourth point is set to null. The string is then closed.

If the point number exists, then the feature code and string number of the point with that point number 
are used and processed as above. Note that the point with the point number is not necessarily used.

46 Make the string a breakline or not
46 [Point_description] [mode]

The point_description is used to select a string and the mode is used specify if the string is a breakline 
or not.

point_description:

If no point_description is given, the current string is selected.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, the last string with that feature code and string number is 
selected.

If the point number exists, then the string containing the point with that point number is selected.

mode:

If no mode is given, the selected string is set as a point string (that is, not a breakline).

If mode is given, then

if mode is 0, the selected string is set to a point string and hence is not a breakline.

if mode is 1, the selected string is set to a line string and is therefore a breakline

47 Start a new string using the same feature code and string number
47 [Point_description]

If no point_description is given, the current string is terminated (without including the current 
measurement point) and the current measurement point becomes the first point of a new string with the 
same feature code and string number. 

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then the last point of the previous string with that feature 
code and string number becomes the first point of a new string with the same feature code and string 
number.

If the point number exists, then the previous string containing the point with that point number is 
terminated before the point number point, and the point becomes the first point of a new string with the 
same feature code and string number.

48 End a string - 
48 [Point_description]

If no Point_description exists, the current string is terminated (including the current measurement 
point).
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If Feature_code and String_number exist, then the last point of the previous string with that feature 
code and string number becomes the last point of that string.

If Point_number exists, then the previous string containing the point with that point number is 
terminated after the point number point

50 Specify the bearing to correct for true north - used as the bearing datum difference
50 Point_description bearing_in_decimal_degrees

The bearing_in_decimal_degrees is used as the bearing datum difference for the current instrument set 
up. The point_name in the point_description and the bearing_in_decimal_degrees are written to the 
report file.

51 Start using an existing field template
51 Template_name zig_zag_mode

Start using the field template Template_name. If Template_name is blank, the default field template is 
used.
If mode is "for", then the field template is used as a forward template.

"rev", then the field template is used as a reverse template.
"zig", then the field template is used as a zig_zag template and is used in the forward 

definition direction first (that is starts on a zig).
"zag", then the template is used as a zig_zag template and is used in the reverse direction 

first (that is, starts on a zag).
If mode is blank, or anything other than "for", "rev", or "zag" then the field template is used as a zig-
zag template starting on a zig.

52 Finish using a field template or finish recording a field template
52

Stops using the current field template or stops recording a field template.

53 Pause using the current field template
53

Pause using the current field template or defining a field template, until a continue field template (54) 
or a finish field template (52) code is given.

54 Continue the current field template
54

Continue using or defining the current field template, which has been stopped by a Pause field template 
command (53). The Continue command only needs to be given once and applies to all following 
measurements until another Pause or Finish command is given.

55 Start recording a field template
55 [Template_name]

Start recording a field template with the name Template_name. If Template_name is blank, then it is the 
default field template that is defined. The feature_code and string_number of the following 
measurements until a Finish code (52) are stored as the field template. There is no limit to the number 
of points in a field template.

56 Skipping picking up points when using a field template
56 [num_skipped_points]

Allows the user to skip picking up one or more points from the field template currently being used. The 
next measurement takes the feature_code and string_number from the next point of the field template 
definition. If num_skipped_points is missing, then only one point is skipped otherwise 
num_skipped_points are skipped.
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57 Delete points on a field template - after the measurement of last point
57 [num_points_to_delete]

Allows the user to delete one or more points from the field template currently being used. The next 
measurement takes the feature_code and string_number from the next point of the field template 
definition. 

58 Insert points when using a field template - after the measurement of last point
58 Feature_code String_number Multiple_code_flag Insert_special_flag

Allows the user to insert points into the field template currently being used. The next measurement 
takes the feature_code and string_number from the next point of the field template definition.

If the Multiple_code_flag = 1, then the feature code will be added to the previous defined template 
point else if Multiple_code_flag = 0 (default), it will be added to the template as a separate point. 

If the insert is done at the end of a section and the Insert_special_flag = 1 the point will be added to the 
end of the current template section else it will be at the start of the next section.

60 Arc through next three points
60 [Point_description]

If no point_description is given, an arc is inserted through the current measurement point and the next 
two measured points with the same feature code and string number as the current measurement point. If 
there is less than three points, no arc is fitted.

If a point_description exists, then either the feature code and/or string number and/or the point number 
section of the point_description can be used. 

If the feature code or string number from the point_description exist, a search is made for a previously 
defined measurement with the same feature code or string number. An arc is inserted through this 
previous measurement and the next two measured points following this previous measurement with the 
same feature code and string number, as given in point_description. If the current point has that feature 
code and string number, then it is the first of the three points. If there is less than three points, no arc 
fitted.

If the point number exists, then the feature code and string number are taken from the previous 
measurement point with that point number, and an arc is inserted through that point and the next two 
measurement points with the same feature code and string number. If there is less than three points, no 
arc is fitted

61 Start of arc through sets of three points until end of string, or a 62 occurs
61 [Point_description]

If no point_description is given, arcs are inserted through the following sets of measurement points 
with the same feature code and string number as the current measurement point. The current 
measurement point is the first of the points.

The arcs are fitted as follows - the first arc is fitted through points one, two and three, the next arc 
through points three, four and five etc. If the current point has that feature code and string number, then 
it is the first of the points. If there is less than three points, then no arc is fitted.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, a search is made for a previously defined measurement with 
the same feature code or string number. An arc is inserted through the following measured points with 
the same feature code and string number as given in point_description. If the current point has that 
feature code and string number, then it is the first of the points. 

 If the point number exists, then the feature code and string number are taken from the previous 
measurement point with that point number, and arcs are inserted through that point and the following 
measured points with the same feature code and string number.
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62 End the arcs begun by a 61 command
62 [Point_description]

If no point_description is given, then the fitting of arcs through the points of the current string is 
stopped. The current measurement point is the last of the points used in the arc fitting.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number from the point_description exist, then the fitting of arcs through 
the points of the previous string with the same feature code and string number is stopped. If the current 
measurement point has that feature code and string number, then it is the last point used in the arc 
fitting.

 If the point number from the point_description exists, then the point with that point number is the last 
point used in the arc fitting.

If 12d Model encounters an End Arcs (62) but no Start Arcs through sets of three points (61) command 
for the string, then a Start Arcs through sets of three points (61) is assumed to apply at the beginning of 
the string and hence arc fitting will be applied to the entire string.

There are op codes for adding user defined attributes to:

(a) the current string being measured (i.e. the string containing the current measurement point)

(b) the current measurement point

(c) the next segment from the current measurement point (i.e. the segment joining the current 
measurement point and the next measured point of the same feature code and string number)

 or

(d) the previous segment to the current measurement point (i.e. the segment joining the current 
measurement point to the previous measured point of the same feature code and string 
number).

If there is no name for the attribute (name is just spaces or a tab), then the attribute is unnamed. 
The attributes are coded in the following way:

68 Add an integer user defined attribute to the current string
68 Name Integer

Add an user defined integer attribute to the current string.

69 Add a real user defined attribute to the current string
69 Name Real

Add a real (floating point) user defined attribute to the current string.

70 Add text user defined attribute to the current string
70 Name Text

Add a text user defined attribute to the current string.

71 Add integer user defined attribute to the current point
71 Name Integer

Add an integer user defined attribute to the current measurement point.

72 Add real user defined attribute to the current point
72 Name Real

Add a real (floating point) user defined attribute to the current measurement point.
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73 Add text user defined attribute to the current point
73 Name Text

Add a text user defined attribute to the current measurement point.

74 Add integer user defined attribute to the next segment
74 Name Integer

Add an integer user defined attribute to the next segment from the current measurement point.

75 Add real user defined attribute to the next segment
75 Name Real

Add a real (floating point) user defined attribute to the next segment from the current measurement 
point.

76 Add text user defined attribute to the next segment
76 Name Text

Add a text user defined attribute to the next segment from the current measurement point.

77 Add integer user defined attribute to the previous segment
77 Name Integer

Add an integer user defined attribute to the previous segment for the current measurement point.

78 Add real user defined attribute for the previous segment
78 Name Real

Add a real (floating point) user defined attribute to the previous segment for the current measurement 
point.

79 Add text user defined attribute to the previous segment
79 Name Text

Add a text user defined attribute to the previous segment for the current measurement point.

In addition, extra codes allow special 12d Model pipe strings to be coded in the field

80 Pipe invert point (bottom of the pipe)
80 [Point_description]

If no point_description is given, the current measurement point is on the invert (bottom) of a pipe. This 
is the default for measurements to points on pipe strings. If the point is not part of a pipe string, it is 
ignored.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, the last point of the previous string with the same feature 
code and string number as given in point_description is on the invert (bottom) of a pipe. If the point is 
not part of a pipe string, it is ignored.

If the point number exists, then the point with that point number is on the invert (bottom) of a pipe. If 
the point is not part of a pipe string, it is ignored.

81 Pipe axial point (centre of the pipe)
81 [Point_description]

If no point_description is given, the current measurement point is on the axis (centre) of a pipe. If the 
point is not part of a pipe string, it is ignored.
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If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, the last point of the previous string with the same feature 
code and string number as given in point_description is on the axis (centre) of a pipe. If the point is not 
part of a pipe string, it is ignored.

If the point number exists, then the point with that point number is on the axis (centre) of a pipe. If the 
point is not part of a pipe string, it is ignored.

82 Pipe obvert point (top of the pipe)
82 [Point_description]

If no point_description is given, the current measurement point is on the obvert (top) of a pipe. If the 
point is not part of a pipe string, it is ignored.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, the last point of the previous string with the same feature 
code and string number as given in point_description is on the obvert (top) of a pipe. If the point is not 
part of a pipe string, it is ignored.

If the point number exists, then the point with that point number is on the obvert (top) of a pipe. If the 
point is not part of a pipe string, it is ignored.

83 Start recording a shape - before the measurement
83 [Shape_name]

Start recording a shape with the name Shape_name. If Shape_name is non-blank, then the default field 
Shape is defined by the feature_code and string_number of the following measurements until a Finish 
code (84) are stored as the shape. There is no limit to the number of points in a shape.

See the Section  “Field Templates” for more information on field templates.

84 Finish using a shape definition or finish recording a shape - after the measurement

Stops using the current shape or stops recording a shape.

85 Shape parallel 

85 [Shape_name] [Point_description]

Takes all the points on the defined shape of Shape_name and parallels them the entire length of the 
string. Once paralleled, a number of strings are created.

If Feature_code and String_number exist, the last string with the same feature code and string number 
has the shape applied to the entire length of the string.

If Point_number exists, then the string containing that point number has the shape applied to the entire 
length of the string.

86 Shape extrude

86 [Shape_name] [Point_description]

Takes the defined shape of Shape_name and extrudes it along the entire length of the string. Once 
extruded, only one strings is created which contains all the shape information.

If Feature_code and String_number exist, the last string with the same feature code and string number 
has the shape applied to the entire length of the string.

If Point_number exists, then the string containing that point number has the shape applied to the entire 
length of the string.

92 Remove all z-values for a string (i.e. make all z-values null)
92 [Point_description]
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If no point_description is given, all z-values for the current string are removed.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, the last string with the same feature code and string number 
has all its z-values removed.

A point-line type can be embedding as a 0 or 1 in the point name part of the point description field. A 
zero value specifies a point string, and a non-zero value specifies a line string. If the field was omitted, 
a line string is assumed.

The point-line type may be overridden by the mapping file.

93  Set the Point-line type
93 [Point_description]

A point-line type can be embedding as a 0 or 1 in the point name part of the point description field. A 
zero value specifies a point string, and a non-zero value specifies a line string. If the field was omitted, 
a line string is assumed.

If no point_description is given, the point-line type for the current string is set to line.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, the point-line type is set for the last previous string with the 
same feature code and string number.

If the point number exists, then the point-line type is set for the string containing that point number.

The point-line type may be overridden by the mapping file.

94 Use name library file/ mapping file for vertex text on the string - name mapping
94 [Point_description]

If this op code exists then during reduction, vertex text is creating using either the name library, or if 
the name library doesn’t exist, the map file. If neither exist then the op code is ignored.

if a name library is used and the feature code of the string is found in the first column of the 
name library, then the entry from the second column of that row will be used as text for all 
vertices of the string that don’t already have vertex text. As a default, the string is set as a point 
string.

if the map file is used and the feature code of the string is found in the first column of the map 
file, then the string name field of the map file is used as vertex text for all vertices that don’t 
already have text. As a default, the string is set as a point string.

If no point_description is given, then name mapping is applied to the current string.

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, then name mapping is applied to the last previous string 
with the same feature code and string number.

If the point number from the point_description exists, then name mapping is applied to the string 
containing that point number.

A point-line type can be embedding as a 0 or 1 in the point name part of the point description field. A 
zero value specifies a point string, and a non-zero value specifies a line string. If the field was omitted, 
a line string is assumed.

The point-line type may be overridden by the mapping file.

95 Pipe string
95 [Point_description] diameter
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Pipe strings are always line strings and are stored with the justification of the majority of the string 
points. Individual pipe points are picked up either top (obvert), centre (axial) or bottom (invert) of the 
pipe using op codes 80, 81 and 82.

If no point_description is given, the current string is created as a pipe string with the given diameter. 

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, the last string with the same feature code and string number 
is created as a pipe with the given diameter.

If the point number exists, then the string containing that point number is created as a pipe string with 
the given diameter.

96 Culvert string
96 [Point_description] width height

Culvert strings are always line strings and are stored with the justification of the majority of the string 
points. Individual culvert points are picked up either top (obvert), centre (axial) or bottom (invert) of 
the culvert using op codes 80, 81 and 82.

If no point_description is given, the current string is created as a culvert string with the given width and 
height. 

If a point_description exists, then either the feature code and string number or the point number section 
of the point_description can be used. 

If the feature code and string number exist, the last string with the same feature code and string number 
is created as a culvert with the given width and height.

If the point number exists, then the string containing that point number is created as a culvert string 
with the given width and height.

99 Terminate processing
99

Stop processing the 12d field file at this line. Useful for debugging errors.

107 Make the previous segment invisible - after the measurement

107 [Point_description]

If no Point_description exists, the previous segment containing the current measurement point is set to 
invisible.

If the Feature_code and String_number exist, then the last segment of the previous string with that 
feature code and string number is set to invisible.

If Point_number exists, then the segment containing the point with that point number as an end point, is 
set to invisible.

108 Make the next segment invisible - after the measurement for the first
point of the segment

108 [Point_description]

If no Point_description exists, the next segment containing the current measurement point as a starting 
point is set to invisible.

If the Feature_code and String_number exist, then the segment that is created in the future from the last 
point of the previous string with that feature code and string number is set to invisible.

If Point_number exists, then the segment containing the point with that point number as a start point, is 
set to invisible.

109 Make a point invisible - after the measurement
109 [Point_description]
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If no Point_description exists, the current measurement point is set to invisible.

If Feature_code and String_number exist, then the last point of the previous string with that feature 
code and string number is set to invisible.

If Point_number exists, then the point with that point number is set to invisible.

110 Start buildings face observations - before the measurements
110 [Building_name]

Start recording a field template with the name Building_name. If Building_name is non-blank, then the 
default building face is defined. The feature_code and string_number of the following measurements 
until a Finish code (111) are stored as the building face. There is no limit to the number of points in a 
building face.

111 End building face observations
111 [Building_name]

If no Building_name exists, the current building face observation set is finished (including the current 
measurement point).

Notes

1. Arc fitting is applied after the Joins are processed. Hence the new joined strings are created 
and then curve fitting is applied according to the arc codes (start arc, end arc, fit arcs, stop fit-
ting arcs etc.) on any vertex of the string.

2. The point description has several pieces of information embedded in it and has been described 
in the previous section. For some op codes, the point name section of the point description is 
used to hold other information.

For a summary of the 12d Field File Op Codes, go to the section “Summary of 12d Field File Op 
Codes” 
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Summary of 12d Field File Op Codes
Op Code Description of Record
-2 Comment
-1 Error
01 Header Information
02 Directly entered coordinate measurement
03 New instrument setup point
04 Measurement to backsight
05 New target height
06 Check measurement
07 Measurement - HA, VA, SD
09 Scale factor for subsequent distances
10 Three hair stadia measurement
11 Measurement - HA, HD, Ht
12 Measurement - HA, HD, Ht diff
15 Vertical circle correction
16 Multiply coded point
17 Arc through previous three points
18 Circle Feature
20 Close string
21 Join last points of strings
22 Join first to last point of strings
23 Join first points of strings
28 Add text to the string name
29 Note or memo
30 Remove height from a point - that is make it a null height
37 Rectangle by two points
38 Make the previous segment non-tinable
39 Make the next segment non-tinable
40 Make a point non-tinable
41 Add additional text for the current measurement point 
42 Add a radial offset
43 Add a tangential offset
44 Add a height offset
45 Make a parallelogram from the last three measurement points
46 Make the string a breakline or not
47 Start a new string using the same feature code and string number
48 String end
50 Specify the bearing to correct for true north - used as the bearing datum difference
51 Start using an existing field template
52 Finish a field template or finish recording a field template
53 Pause the current field template until a continue op code (54) or a finish template (52)
54 Continue the current field template
55 Start recording a field template
56 Skip picking up one or more points from a field template
57 Delete one or more points from a field template
58 Insert a point into a field template
60 Arc through next three points
61 Start of arc through sets of three points until end of string, or a 62 occurs
62 End the arcs begun by a 61 command
68 Add an integer user defined attribute to the current string
69 Add a real user defined attribute to the current string
70 Add text user defined attribute to the current string
71 Add integer user defined attribute to the current point
72 Add real user defined attribute to the current point
73 Add text user defined attribute to the current point
74 Add integer user defined attribute to the next segment
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75 Add real user defined attribute to the next segment
76 Add text user defined attribute to the next segment
77 Add integer user defined attribute to the previous segment
78 Add real user defined attribute for the previous segment
79 Add text user defined attribute to the previous segment
80 Pipe or culvert invert point (bottom of the pipe or culvert)
81 Pipe or culvert axial point (centre of the pipe or culvert)
82 Pipe or culvert obvert point (top of the pipe or culvert)
83 Start recording/measuring a shape
84 End measuring a shape
85 Parallel an existing shape
86 Extrude an existing shape
92 Remove all z-values for a string (i.e. make all z-values null)
93  Set the Point-line type
94 Use name library file/ mapping file for vertex text on the string - name mapping
95 Pipe string
96 Culvert string
99 Terminate processing
107 Last segment of point invisible
108 Next segment of point invisible
109 Point invisible
110 Building face start recording
111 Building face end recording
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Batch Typed Entry
Typed entry can be used to enter survey data into a 12d Field File and reduced using the Survey 
data Editor.

12d Model uses the following 12d field file ops code:

Op Code Description of Record
-2 Comment
-1 Error
01 Header Information
02 Directly entered coordinate measurement
03 New instrument setup point
04 Measurement to backsight
05 New target height
06 Check measurement
07 Measurement - HA, VA, SD
09 Scale factor for subsequent distances
10 Three hair stadia measurement
11 Measurement - HA, HD, Ht
12 Measurement - HA, HD, Ht diff
15 Vertical circle correction
16 Multiply coded point
17 Arc through previous three points
18 Circle Feature
20 Close string
21 Join last points of strings
22 Join first to last point of strings
23 Join first points of strings
28 Add text to the string name
29 Note or memo
30 Remove height from a point - that is make it a null height
37 Rectangle by two points
38 Make the previous segment non-tinable
39 Make the next segment non-tinable
40 Make a point non-tinable
41 Add additional text for the current measurement point 
42 Add a radial offset
43 Add a tangential offset
44 Add a height offset
45 Make a parallelogram from the last three measurement points
46 Make the string a breakline or not
47 Start a new string using the same feature code and string number
48 String end
50 Specify the bearing to correct for true north - used as the bearing datum difference
51 Start using an existing field template
52 Finish a field template or finish recording a field template
53 Pause the current field template until a continue op code (54) or a finish template (52)
54 Continue the current field template
55 Start recording a field template
56 Skip picking up one or more points from a field template
57 Delete points from a field template
58 Insert points in a field template
60 Arc through next three points
61 Start of arc through sets of three points until end of string, or a 62 occurs
62 End the arcs begun by a 61 command
68 Add an integer user defined attribute to the current string
69 Add a real user defined attribute to the current string
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70 Add text user defined attribute to the current string
71 Add integer user defined attribute to the current point
72 Add real user defined attribute to the current point
73 Add text user defined attribute to the current point
74 Add integer user defined attribute to the next segment
75 Add real user defined attribute to the next segment
76 Add text user defined attribute to the next segment
77 Add integer user defined attribute to the previous segment
78 Add real user defined attribute for the previous segment
79 Add text user defined attribute to the previous segment
80 Pipe or culvert invert point (bottom of the pipe or culvert)
81 Pipe or culvert axial point (centre of the pipe or culvert)
82 Pipe or culvert obvert point (top of the pipe or culvert)
83 Start recording/measuring a shape
84 End measuring a shape
85 Parallel an existing shape
86 Extrude an existing shape
92 Remove all z-values for a string (i.e. make all z-values null)
93  Set the Point-line type
94 Use name library file/ mapping file for vertex text on the string - name mapping
95 Pipe string
96 Culvert string
99 Terminate processing
107 Last segment of point invisible
108 Next segment of point invisible
109 Point invisible
110 Building face start recording
111 Building face end recording

Users can enter text for each measurement (observation 09 record or position 08 record) which is 
appended to the end of the record and this is used as the text of blocks that are interpreted 
according to the descriptions given in the earlier section “Field Coding for Non Leica 
Instruments” .

The ’13’ record can also be used after a measurement record to add additional information to the 
preceding blocks using the extra coding control code at the end of the previous line (see  “Extra 
Coding” in the section “Control Code Blocks” 

Strictly speaking the Sokkia SDR20/33 formats use fixed length lines and if the lengths are 
incorrect, an error message will be written to the Output Window. For example,

’Line 248 line incorrect length. required length is 58. received length is 50.’

These messages often appear after a raw file has been manually edited because most editors 
remove space padding at the end of a line.

For the full description of the 12d Field File Op Codes, go to the section “Full Description of 12d 
Field File Op Codes” 
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B  12D and Sokkia 
Instruments (SDR Files)

This Section deals with interfacing 12d with Sokkia SDR20/33 data formats specifically with the SDR33 
electronic field book (Controller). Other controllers and instruments such as the powerset range of total 
stations also use these formats. 

A large number of instruments support the Sokkia SDR data format including (Trimble Total 
Station ACU), not just those from Sokkia. 

For the topic:

1. Field Coding see the section “Coding For SDR Files” 

2. Sending raw file from controller to 12d “Downloading SDR File To 12d” 

3. Converting raw data to field file see the section “Converting SDR Raw File To Field File” 

4. Creating Points upload file see the section “Creating SDR Point Upload File” 

5. Creating Road upload file see the section “Creating SDR Roads Upload File” 

6. Creating Tin upload file see the section “Create Tin upload file” 

Coding For SDR Files
The Sokkia SDR20/33 data formats are used as raw data files by 12d Model and are converted 
into a 12d Field File before reduction. 12d Model uses the following Sokkia records:

01 Record header - SDR format
02 Station details
03 Target height
07 Back bearing details
08 Position - directly entered co-ordinates
09 Observation - measurement
13 Comment or continuation of blocks
15 RTK station details
16 RTK observation - measurement
57 RTK antenna height

Users can enter text for each measurement (observation 09 record or position 08 record) which is 
appended to the end of the record and this is used as the text of blocks that are interpreted 
according to the descriptions given in the earlier section “Field Coding for Non Leica 
Instruments” .

The ’13’ record can also be used after a measurement record to add additional information to the 
preceding blocks using the extra coding control code at the end of the previous line (see  “Extra 
Coding” in the section “Control Code Blocks” 

Strictly speaking the Sokkia SDR20/33 formats use fixed length lines and if the lengths are 
incorrect, an error message will be written to the Output Window. For example,

’Line 248 line incorrect length. required length is 58. received length is 50.’

These messages often appear after a raw file has been manually edited because most editors 
remove space padding at the end of a line.

To ignore such error messages, there is a setting Allow bad line lengths on the Advanced tab of the 
Survey.4d Create/Edit panel. If this is set for a data collector, then lines of incorrect length will not 
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be rejected.

For non SDRmap users, please proceed to the section “Example of Sokkia SDR File” .

SDRmap users, please continue to the next section “Special Notes for SDRmap Users” .
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Special Notes for SDRmap Users
SDRmap does not use String numbers - only Feature codes are used and a New String command 
to denote the start of a new string. 12d Model supports only using a Feature code by setting the 
String number position on the Feature Coding tab to ’no string number’.

If no string number is set for the data collector (and so no string numbers are used in the field), 
then there is no way of telling from the field data whether the string is a point string or a line 
string (setting the pt-line type for the string).

For the no string number case, the method of defining the point-line type is to:

(a)  use a map file during the reduction

and

(b) have a key in the map file to match the feature code and have the pt-line type set for that key. 
If the feature code does not match any key in the map file, the string defaults to a point string.

and

(c) because by default the pt-string column in the map file is ignored during reduction (the 
string number usually defines the pt-line type), the Use pt/line mapping tick box in the Survey 
Data Reduction Function panel must be set to tick to force the pt-line column in the mapping 
file to be used.

Please continue to the next section “Example of Sokkia SDR File” .

Feature Coding tab on the Survey.4d Create/Edit panel

set to no string number
to emulate SDRmap field

string numbers are used
coding where no string 

toggle on to force the
pt-line column from
the map file to be used
to define the pt-line
type of the string
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Downloading SDR File To 12d
Raw SDR files can be input to 12d for reduction by two basic methods:

1. Download directly from the instrument

2. Copy the SDR file to the working folder directly from a PCMCIA card or by using a data 
transfer product such as "HyperTerminal" or "Wincomms" etc. For this method, see the 
following section “Converting SDR Raw File To Field File” .

An option exists within 12d to download the raw SDR file from the instrument. This option has 
the added functionality that is reduces the raw propriety format (SDR file) to a 12d field file 
format at the same time. This conversion requires that the data collector definition be set before 
the download of the file is commenced. 

Select the data collector type
Select option Survey=>Setup

Select the Data collector choice icon

Double click on appropriate data collector

Select set and finish
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Select Survey=>Download

The raw file will be converted to 
the 12d field file format using the 
specified translator macro



12d Model Reference Manual

Page 3164 March 2003

 

Prepare the data collector for download by connecting to appropriate port, selecting file to 
download etc.

Ensure that the correct values 
are set for the comms settings 
i.e. they match the data 
collector parameters

Enter a name for the field file

Press download

The 12d download window is shown.

From the Data collector main 
menu select the FUNC 
(function) menu
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Toggle down to the 
Communications menu

Press OK to select 
menu

Select the Options 
menu to view the 
current settings



12d Model Reference Manual

Page 3166 March 2003

Select the Current view to 
Yes only. If the POS view 
were set to Yes also, the 
POS points would be sent 
also and eventually 
reduced twice in 12d (once 
from observations and the 
other from the POS record). 
Press Clear to leave menu

Select the COM menu to 
view the current comms 
settings



Appendix B

March 2003 Page 3167

Ensure the comms settings are 
as per the values set in the 12d 
download option.

Select Clear to leave the menu

Select the SEND menu
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Select the file to download

Press OK to send

The file is shown downloading line by line in the 12d download window.

When the download is finished select the stop button and then finish
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Converting SDR Raw File To Field File
If a raw SDR file is copied to the working folder from a PCMCIA card or other means such as 
transferring it from a third party software package, it must be converted to a 12d field file for 
reduction inside 12d.

Select the data collector type
Select option Survey=>Setup

Select option Survey=>Convert raw

Select the Data collector choice icon

Double click on appropriate data collector

Select set and finish
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Any errors will be listed in the Output window. If the Output window is not shown, it can be opened using 
the option Window=>Output Window

Select the Raw file choice icon

Select the file to be converted 
(extension should be .sdr)

Pick Select

The Field file name will be generated

Select Convert
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Creating SDR Point Upload File
Create upload file in 12d
After creating the setout points an upload file can be created for the sdr format

Select option Survey=>Upload=>Create points upload file

Fill in the rest of the screen as per normal

Select Write File

A SDR33 file is created ready to send to the instrument directly using the upload facility or by copying 
the file to PCMCIA cards etc.

Select Instrument choices 
icon

Select Sokkia SDR33
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Loading file into controller using 12d upload facility
The points upload file can be transferred to the controller for setout using the upload panel.

Connect the controller to the PC 

Select option Survey=>Upload=>Upload

Prepare the data collector for uploading.

Ensure that the correct 
values are set for the 
comms settings i.e. they 
match the data collector 
parameters

Select the upload file by 
selecting the folder icon 
and selecting the 
appropriate file
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From the communication 
menu, select the receive 
button

Once the data collector is 
ready, the data can be sent 
from 12d
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Select upload to start 
uploading the file
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Creating SDR Roads Upload File
Create upload file in 12d
After creating the road alignment an upload file can be created for the SDR33 format

Select option Survey=>Upload=>Create roads upload file

Select Instrument choice icon

Select Sokkia Roading - Alignment Road

A SDR33 file is created ready to send to the instrument directly using the upload facility or by copying 
the file to PCMCIA cards etc. The steps involved in uploading the file to the controller using the 12d 
upload facility can be seen is the previous section “Loading file into controller using 12d upload 
facility” on page 3172.

Select Select H-Align

Pick and accept the alignment 
string

Type in a road name. (Filled out 
if it exists

To include Vertical geometry 
tick check box

To include Cross sections tick 
check box

To assume last segment of each 
section is a batter tick check 
box then type in default cut and 
fill grades

Select Cross section model

Type in a file name

Select Write then Finish
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Example of Sokkia SDR File
The raw Sokkia SDR file ’detail1.sdr’ has been coded in accordance with the data collector 
definition Sokkia String Feature which is shipped with 12d Model.

The data collector Sokkia String Feature is set using the option Survey=>Setup
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For the Sokkia String Feature data collector definition, the string number is given before the feature 
code.

Some of the control codes defined for the Sokkia String Feature data collector that are used in the 
example are:

* is used as the Command (Block) delimiter
space is used as the comment delimiter
S and E are used to start arc fitting and end arc fitting respectively
R is the Rectangle (make a parallelogram) command
the template commands XA, XB, XC and XD are used 
the invert I and obvert O commands are used.
XN for the next segment to be non-tinable (that is, not a breakline).

The listing of the raw file ’Detail1.sdr’ is now given, followed by a dump of a 12d Model view 
displaying the job. No mapping file has been used in the reduction so no line styles appear on 
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the view.

WARNING - The raw file ’Detail1.sdr’ is in the Survey area of the training data but the file has 
been manually edited and if read in with the standard Sokkia String Feature data collector, will 
have bad line lengths and the data ignored. To read the file in, the Allow bad line lengths on the 
Advanced tab of the Sokkia String Feature data collector will need to be set before converting the 
raw file to a 12d field file.

need to tick on to read in
raw files with invalid
line lengths
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Description

00 - SDR format

02 - station details for pt 902
02 - station details for pt 901
07 - back bearing from pt 901 to 902
03 - target height

check shot from pt 901 to pt 902
measurement FC TBL SN 1 Pt 1003

FC TBL SN 1 Pt 1003

FC BB SN 1 Pt 1006

FC ES SN 3 Pt 1009 start template
FC CR SN 4 Pt 1010
FC ES SN 5 Pt 1011

start using template in zig mode
using template

pause template - meas FC PP SN 0
continue with template
start arc through 3 points
start arc through 3 points
start arc through 3 points

end arc through 3 points
end arc through 3 points
end arc, stop template
FC BB SN 6 Pt 1030

FC SWUG SN 7 Pt 1032 obv 0.225 dia
FC SWUG SN 7 Pt 1033 invert meas

FC BB SN 8 Pt 1034

FC WA SN 11 Pt 1040

Sokkia SDR 20 File

00NMSDR20     V03-05    03-Aug-00 09:00 111121
10NM1697 DETAIL
13CPSea level crn: N
13CPC and R crn: N
13CPAtmos crn: N
06NM1.00000000
13OOCurrent view
13TS02-Aug-00 08:23
13JS10000
13TS02-Aug-00 08:25
01NM:                000000                00000031                    0.00000000
13PCP.C. mm Applied: 0.000
02TP09020982.770005096.700000115.7500001.7400000STN                                               
02TP09011000.000005000.000000100.000001.66500000STN
07TP09010902349.895000349.895000
03NM1.44000000
09F109011001099.43000081.0180555349.893611CHK902
09F109011003046.93700089.5425000119.69972201TBL
09F109011004037.34200089.7522222125.31527701TBL
09F109011005026.44500089.9869444138.51611101TBL
09F109011006045.68200089.8705555114.79527702BB
09F109011007032.72000090.2769444122.23361102BB
09F109011008020.06200090.9736111147.16833302BB
09F109011009033.47400090.0641666118.03777703ES*XA
09F109011010032.98200089.8936111113.25027704CR
09F109011011031.88200090.0369444108.80138805ES
09F109011012022.46200090.2811111130.749722XB
09F109011013021.56900090.1400000124.623055
09F109011014019.30400090.5197222118.459722
09F109011015011.35800091.0744444136.851388S
09F109011016013.58000090.5797222144.980000S
09F109011017015.06100090.5494444154.349722S
09F109011018012.79200090.7638888201.297500
09F10901101909.757000091.1033333201.376944
09F109011110043.58500089.6561111118.780000PP*XD
09F10901102006.659000092.5538888198.245000XE
09F109011021014.70100091.2202777256.936111S
09F109011022015.55300090.8763888248.602222S
09F109011023018.16300090.6650000240.646111S
09F109011024027.42900090.5169444260.969444
09F109011025025.37600090.5413888266.748055
09F109011026026.05000090.6897222272.995833
09F109011027032.16700090.5105555277.837500E
09F109011028036.58100090.2566666276.025833E
09F109011029038.06400090.1986111272.082777E*XC
09F109011030019.76600091.8072222275.24777706BB
09F10901103107.245000093.9725000266.13777706BB
09F10901103207.044000094.6780555265.51250007SWUG*O.225
09F10901103303.441000097.8750000242.44805507SWUG*I
09F10901103402.973000099.2075000239.99916608BB
09F10901103509.678000092.9816666114.81555508BB
09F109011036010.50700090.6511111104.50611109TBR
09F10901103701.155000095.167500082.357777809TBR
09F10901103805.969000090.5472222291.73500010TBR
09F109011039013.82100090.8102777288.00027710TBR
09F10901104008.206000091.0138888290.96333311WA
09F10901104108.476000091.0427777293.60750011WA
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FC WA SN 11 Pt 1042
FC WA SN 11  Pt 1043- close string
FC WA SN 12 Pt 1044
FC WA SN 12 Pt 1045
FC WA SN 12 Pt 1046 - create rect
FC PL SN 13 Pt 1048

omit part of file
FC TBL SN 21 Pt 1103
FC TR0306 SN 0 - comment GUM
FC TR0309 SN 0 - comment GUM
FC TR0306 SN 0 - comment GUM
FC TR0309 SN 0 - comment GUM
FC TR0308 SN 0 - comment GUM

02 - station details pt 902
07 - back bearing from pt 902 to 901
03 - target height

check measurement to pt 901
FN DW SN 21 Pt 1202
 FC DW SN 21 Pt 1203

omit part of file
FC FE SN 25 Pt 1346 - non tin segm 
FC FE SN 25 Pt 1347

.omit part of file 
Pt 2135 FC DW SN 25 start arc

and also FC WA SN 28

09F10901104206.213000089.7200000305.83194411WA
09F10901104306.116000090.3575000300.03777711WA*C
09F10901104403.100000090.0911111314.07277712WA
09F10901104502.970000089.6530555327.17166612WA
09F10901104600.760000099.5219444351.28472212WA*R
09F109011048027.45200090.7930555258.30333313PL

.omit part of file 
09F109011103021.21900088.8433333293.53222221TBL
09F109011105012.69000087.209444438.3036111TR0306 GUM
09F109011106017.95900086.573333336.3436111TR0309 GUM
09F109011107019.97400086.607777723.2163889TR0306 GUM
09F109011108026.78400086.450833323.7155556TR0309 GUM
09F109011109027.38900085.6861111358.734166TR0608 GUM
02TP09020982.770005096.710000115.7500001.7100000STN
07TP090209010169.895000169.895000
03NM1.440000000
09F109021201099.43000099.2611111169.893611CHK901 
09F109021202038.369000100.2900000182.1266621DW*S
09F109021203033.80100099.7461111190.31638821DW

.omit part of file
09F10902134604.867000085.22555555.8144444025FE*XN
09F109021347010.66400085.510000060.870277825FE

.omit part of file 
09F10902135708.003000085.01361113.5244444027DW*S*28WA

.omit to end of file
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Plan View with of the Reduced Sokkia Data Displayed
Note that no linestyles or symbols have been turned on. 
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C   12d and the Trimble 
Total Station ACU

This Section deals with interfacing 12d with the Trimble Total Station ACU unit data formats

These notes are not meant to take the place of the operations manuals for the Trimble ACU but rather to act 
as a guide for ensuring the correct file types are used between the two systems. 

Coding
On the ACU the user can either manually type in a code for field readings or use a code library to pre-
define codes which can then be selected from a list

To use a code library the user should select the relevant library when creating the job
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If using string numbers the Feature library can be set to None and the string number, feature code, field 
code and delimiters can be manually typed in 

 

Codes are typed in to the ACU in the MEASURE POINTS option
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Sending Raw file to 12d
The raw file can be transferred from the ACU as a format similar to the SDR33. This is called the SDR33 
DC file format.

Connect the ACU to the PC using TRIMBLE DATA TRANSFER
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Select Receive tab then select Add

Select the Job to download using the format SDR33 FORMAT DC FILE
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Select Transfer All to transfer the file
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Converting raw file to field file
Create new data collector type
We will create a specific name for the Trimble data collector even though it is similar to the SDR33 format

Select Project=>Browse

Select the Survey data collectors branch

Double click on Sokkia String Feature
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Select Finish back in the previous panel

To set the changes the project has to be restarted by selecting Project=>Restart

Select the data collector type

This loads up the default parameters for 
the SDR33 format.

Type in the new name Trimble String 
Feature

Select Set then Save

Select User directory

Select Save then Finish
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Select option Survey=>Setup

Select the Data collector choice icon

Double click on Trimble String Feature

Select Set then Finish
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Convert raw file
To convert raw file to field file select option Survey=>Convert raw 

Any errors can be listed by opening the Output window using option Window=>Output Window

 

Select the Raw file choice icon

Select the Trimble file (extension 
should be .sdr)

Pick Select

The Field file name will be generated

Select Convert
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Close the Error panel

Select Finish 

The field file can now be reduced in the normal manner
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Creating point upload file

Create upload file in 12d
After creating the setout points an upload file has to be created for the trimble format

Select option Survey=>Upload=>Create points upload file

Fill in the rest of the screen as per normal

Select Write File

A standard comma delimited file is created ready to send to the ACU

Select Instrument choices 
icon

Select Trimble XYZ
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Loading file into job in ACU
The points upload file can be transferred to the ACU for setout.

Connect the ACU to the PC using TRIMBLE DATA TRANSFER

Select Send tab then select Add
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Select the file to upload using format Comma delimited coordinate file
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Select Transfer All to transfer the file

To load the file into the current job on the ACU select Menu=>Files

Select Import / Export



12d Model Reference Manual

Page 3196 March 2003

Select Receive ASCII data

Select File format choice icon then pick Comma Delimited (*.CSV, *.TXT)

Select Receive from choice icon and pick Trimble Data

Select From file choice icon and select file
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Select the field order for the file as (1) Point number, (2) Easting, (3) Northing, (4) Level and (5) Code

Select the Next page icon 

Select Receive
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Select OK to finish

The points can be displayed by selecting Map and zooming all of the job
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Create Roads upload file
Create upload file in 12d
After creating the road alignment an upload file has to be created for the trimble format

Select option Survey=>Upload=>Create roads upload file

Select Instrument choice icon

Select Trimble Roading

Select Select H-Align

Pick and accept the alignment 
string

Type in a road name

To include Vertical geometry 
tick check box

To include Cross sections tick 
check box

To assume last segment of each 
section is a batter tick check 
box then type in default cut and 
fill grades

Select Cross section model

Type in a file name

Select Write then Finish
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Loading file to the ACU
The road upload file can be transferred to the ACU for setout.

Connect the ACU to the PC using TRIMBLE DATA TRANSFER

Select Send tab then select Add



Appendix C

March 2003 Page 3201

Select the road file to upload using format Survey Controller file
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Select Transfer All to transfer the file

Once the road file has been copied into the ACU it can be setout using option Survey=>Stakeout=>Roads
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Create Tin upload file

Create upload file in 12d
After creating the triangulation an upload file has to be created for the trimble format

Select option Survey=>Upload=>Create triangle upload file

Select Yes to create the file

Select the File Type choice 
icon and select Trimble

Type in Job name

Type in output file name

Select the tin to list

Select the boundary string 
for the tin

Select Write then Finish



Appendix C

March 2003 Page 3205

Loading and using the file in the ACU
The tin upload file can be transferred to the ACU for setout.

Connect the ACU to the PC using TRIMBLE DATA TRANSFER

Select Send tab then select Add
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Select the tin file to upload using format Triangulated Terrain model
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Select Transfer All to transfer the file

Once the tin has been copied into the ACU it can be called up when using the Stakeout option 
Survey=>Stakeout=>DTM

Select the uploaded tin file 
to setout
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The cut to the tin is calculated and displayed
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D 12D and Trimble GPS 
Controllers

The Trimble Geomatics Office software which comes with most Trimble GPS units can produce a 
Sokkia SDR file which is used by 12d Model as a raw data file.

However, the Trimble software writes out the (x,y,z) co-ordinates of GPS points as a "08KI" 
record which is normally treated by 12d Model as directly entered co-ordinates for a Station.

To overcome this problem, there is a flag in the data collector definitions to treat the Sokkia 08KI 
records as GPS points.

So before converting a Sokkia SDR file from a Trimble GPS unit, define a data collector which has 
a tick for the field Sokkia 08KI as GPS points on the Instrument tab of the Survey.4d Create/Edit 
panel.

The code information that is entered on the Trimble in the field is appended the Sokkia 08KI 
record and is processed as blocks of information as given in the section “Field Coding for Non 
Leica Instruments” and the appendix “12D and Sokkia Instruments (SDR Files)” .

This flag needs to be ticked 
on for reducing the SDR files 
created by Trimble GPS units
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E  12D and Geodimeter 
Instruments

12d UDS’s
The geodimeter allows the recording of information in a format specified by the user. Data for 
each label can be prompted for and measurements from the instrument can be registered. The 
user can assign a certain series of labels to a User Defined Sequence or UDS.

For 12d to reduce files from the geodimeter instruments, the recorded information from the 
instrument must be in a specific format that 12d can understand. A number of Geodimeter UDS 
files are supplied on the 12d Model Installation CD in the folder ’Other_Software\Geodimeter’.

For uploading or direct entry of UDS’s to your particular instrument see you instrument 
manual.

These UDS’s have been set up so that 12d can convert the raw files from the instrument in a 12d field file. 
These UDS’s should be installed prior to undertaking surveys that are to be reduced by 12d. The standard 
UDS that 12d supply is as follows:

UDS 1 - used within UDS 8 to record 12d field op codes.

UDS 2 - prompts for additional data for a 12d field op code.

UDS 5 - job administration at the start of a job

UDS 6 - station co-ordinates entry

UDS 7 - station set up - name and instrument height

UDS 8 - data pick-up

UDS 5 is run at the beginning of the job and it runs UDS 6, which runs UDS 7 which runs UDS 8.

UDS 1 can be run as required from within UDS8 to give 12d field file op codes.
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The Geodimeter data format is used as a raw data file by 12d Model and is converted into a 12d 
Field File before reduction by potentially 2 different macros:

1) geodat4d.4do (default) for use with the 12d standard UDS’s.

2) geodat_qmrd.4do (Specialised reduction) for use with Queensland MRD UDS’s.

For the geodat4d.4do macro (default) 12d Model uses the following Geodimeter labels:

0= Information
1= Attributes
2= Station name or named point
3= Instrument height
4= Blocks
5= Point number
6= Target (signal) height
7= Horizontal angle
8= Vertical angle
9= Slope distance
37= Northing (X) value
38= Easting (Y) value
39= Height (Z) value
51= Date
53= Operator
90= End of record, flush buffer
91= 12d Model field file op code
92= Parameters for the previous 12d op code
95=

UDS 1 - used within 
UDS 8 to record 12d field 
op codes
-------------------------------

42=1
43=OP-CODE-SELECT
91=1
79=7/2
-------------------------------
UDS 2 - used for 
additional data for 12d 
field ops codes
-------------------------------

42=2
43=OP-CODE DATA
92=1
79=5

UDS 5 - job admin at 
start of day
-------------------------------

42=5
43=TCC-ADMIN
79=10
0=1
53=1
51=0
79=7/6
-------------------------------
UDS 6 - station co-
ordinates entry
-------------------------------

42=6
43=TCC-COORD-
ENTRY
79=10
38=1
39=1
37=1
79=7/7

UDS 7 - station set up - 
name and instrument 
height
-------------------------------

42=7
43=TCC-STN-ID
79=10
3=1
95=1
2=1
4=1
1=1
5=2
6=2
79=7/8

UDS 8 - data pick-up
-------------------------------

42=8
43=TCC-DATA-PICKUP
5=4
4=8
6=8
39=8
8=0
9=0
7=0
6=8
5=8
4=8
38=8
37=8
39=8
6=3
4=3
1=3
90=3
79=5

12d standard UDS’s for pick-up with Geodimeter
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In particular, the Geodimeter PCode label block (4=) is used as the text of blocks that are 
interpreted according to the descriptions given in the earlier section “Field Coding for Non Leica 
Instruments” .

A new conversion macro for V6.0, geodat_qmrd.4do recognises geodimeter Program 22 and 
Program 32 commands if the following setup/procedures are used:

1. The geodimeter should be set to record program numbers. This is shown by the label 0=Pn in 
the raw file, where n is the program number and is assigned by the instrument. To set this up 
on the instrument use MENU 6 1(Switches) and turn Prg_Num on.

2. For 12d to convert raw files using geodimeter programs such as P22 and P32 the data must 
contain a label 61=n each time an UDS or onboard program is started (Where n is the 
program number). This allows 12d to be able to determine when one program is finished and 
another started. Queensland MRD have created there own UDS’s which utilise the 61= label 
so that it is prompted for within the UDS’s. They have also set up a UDS (UDS 6) which is 
used to place the label at the commencement of an onboard program such as program 22.

12d Field Ops Codes
In additional to the commands accessible from the blocks, most of the 12d field file op codes are 
accessible directly from the Geodimeter.

The label ’91=’ label is used to specify a 12d field file op code and any following ’92=’ labels 
provide any additional information required by the 12d op code.

The 12d field file ops codes apply to the measurement before the op code.

For a complete definition of the 12d Model field file and the 12d Model field file op codes, see the 
section “The 12d Field File Format” 

Please continue to the next section “Example of Geodimeter File” .
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Example of Geodimeter File
The raw file ’Geodimeter.job’ has been coded in accordance with the data collector definition 
Geodimeter 12D which is shipped with 12d Model. The 12d Model Geodimeter UDS’s were used 
in the field pick-up.

The data collector Geodimeter 12D is set using the option Survey=>Setup

Some of the tabs on the Geodimeter 12D data collection definition as show below. Note that * is 
used as the Command (Block) delimiter, the string number is given after the feature code, S is used 
to start arc fitting and R is the Rectangle (make a parallelogram) command.

The listing of the raw file is now given, followed by a dump of a 12d Model view displaying the 

Some Tabs on the data collector definition for Geodimeter 12D
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job with string names (feature codes) and point numbers toggled on. The raw file 
’Geodimeter.job’ is in the Survey area of the training data. It can be converted into a 12d field file 
by using the default conversion macro geodat4d.4do.
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run UDS 5 job name
operator
date

UDS 6 station
co-ordinates

UDS 7 instrument ht

Feature code (FC) PISP

UDS 8 point no 1000
vertical angle
slope distance
horizontal
target (signal) height
FC PSHT

*note that the string no. 
(SN) defaults to 0

point no 1001
vertical angle
slope distance
horizontal
target height

 FC EP  SN 1   start arc

point no 1002
vertical angle
slope distance
horizontal
target height
FC RC  SN 1    start arc

0=OP CODE TEST
53=DAD
51=2001.0525
38=5000.000
39=10.000
37=10000.000
3=1.654
95=0
2=1
4=PISP
1=Peg
5=1000
8=90.1219
9=5.80
7=119.4705
6=1.500
4=PSHT
1=
90=0
5=1001
8=90.1207
9=15.80
7=119.4708
6=1.500
4=EP1*S
1=
90=0
5=1002
8=90.1215
9=25.80
7=119.4705
6=1.500
4=RC1*S
1=
90=0
5=1003
8=90.1158
9=35.80
7=119.4705
6=1.500
4=EP2
1=
90=0
5=1004
8=90.1209
9=45.80
7=119.4706
6=1.500
4=DL1
1=
90=0

Description

point no 1005
vertical angle
slope distance
horizontal
target height
FC DL  SN 1

point no 1006
vertical angle
slope distance
horizontal
target height
FC DL  SN1

UDS 1 12d op code 45
UDS 1 12d op code 41
UDS 2  parameters
        for op code 45
        (additional text)
UDS 8  point no 1007
vertical angle
slope distance
horizontal
target height
FC EP  SN 2

 *note that 12d op code 45  
is ’make a parallelogram 
from the last three points’ 
and it is applies to the 
measurement before the 
command. The rectangle 
R could have been 
instead as part of the 
feature code block.
That is " 4=DL1*R" 
instead of the "91=45"

*Also note that the 12d 
op code 41 is ’additional 
text’ and the additional 
text is given by the "92=" 
lines. Again the op code 
applies to the 
measurement before the 
command..

5=1005
8=90.1203
9=45.80
7=149.4706
6=1.500
4=DL1
1=
90=0
5=1006
8=90.1159
9=65.80
7=149.4706
6=1.500
4=DL1
1=
90=0
91=45
91=41
92=THIS IS TO CHECK
92= HOW TO USE THE
92= OP CODE FN
5=1007
8=90.1219
9=35.80
7=139.4711
6=1.500
4=EP2
1=
90=0
5=1008
8=90.1214
9=25.80
7=139.4706
6=1.500
4=RC1
1=
90=0
5=1009
8=90.1211
9=15.80
7=139.4706
6=1.500
4=EP1
1=
90=0
 continue on next page

Geodimeter file Description Geodimeter file
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point no 1010
vertical angle
slope distance
horizontal
target height
FC PSHT  SN 0

point no 1014
vertical angle
slope distance
horizontal
target height
FC EP  SN 2

UDS 1 12d op code 17
 which is ’arc through 
previous three points’

5=1010
8=90.1209
9=5.80
7=139.4709
6=1.500
4=PSHT
1=
90=0
5=1011
8=90.1141
9=5.80
7=159.4714
6=1.500
4=PSHT
1=
90=0
5=1012
8=90.1138
9=15.80
7=159.4711
6=1.500
4=EP1
1=
90=0
5=1013
8=90.1141
9=25.80
7=159.4709
6=1.500
4=RC1
1=
90=0
5=1014
8=90.1141
9=35.80
7=159.4713
6=1.500
4=EP2
1=
90=0
91=17
continued in next 
column

Description

point no 1015
vertical angle
slope distance
horizontal
target height
FC TR  SN 1

UDS 1 12d op code 18
UDS 2  Radius 5
which is ’circle feature’ 
with a radius of 5

point no 1018
vertical angle
slope distance
horizontal
target height
FC PFPP  SN 1

UDS 1 12d op code 40
which is ’make a point 
non-tinable’ This applied 
to the previous point 
(1018)

5=1015
8=90.1141
9=75.80
7=119.4709
6=1.500
4=TR1
1=
90=0
91=18
92=5
5=1016
8=90.1146
9=35.80
7=179.4713
6=1.500
4=EP2
1=
90=0
91=47
5=1017
8=90.1145
9=35.80
7=189.4714
6=1.500
4=EP2
1=
90=0
5=1018
8=90.1145
9=55.80
7=119.4713
6=1.500
4=PFPP
1=
90=0
91=40

Geodimeter file Description Geodimeter file
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Plan View with of the Reduced Geodimeter Data Displayed

with Point Numbers and String Names (Feature Codes) Turned On
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The following raw field file has been taken from an QMRD Geodimeter 610 which has the 
QMRD UDS’s installed. The file can be converted into a 12d field file by using the 
geodat_qmrd.4do. Note the inclusion of the activity codes (61=) that have been added to the file 
with the use of the UDS’s. It also shows the use program 22 and the traverse extraction facility. 
For more information on traverse extraction see the section “Traverse coding” .
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Activity code from UDS

Run UDS 6 to place
activity code (61=) before
program 22

foresight to STN1,
 traverse line(TL), string 1

UDS 6 run to label
 activity code

Backsight(RO)
 reading,trav line 1 to
 PSM45026

foresight to STN2,
 traverse line(TL), string 1
 

and so forth....

50=030602
61=1
6=1.458
54=ROGER-RANGER 
STN
0=OVERLAY
53=RAF
51=03-06-2002
61=22
0=P22
2=PSM45026 PBMK
3=1.561
5=STN1
4=TL1 FSSTN1
6=1.475
7=213.0004
8=89.1413
9=98.297
17=33.0014
18=270.4550
24=213.0009
25=89.1417
61=22
0=P22
2=STN1 PISP
3=1.570
5=PSM45026
4=TL1 ROPSM45026
6=1.468
7=32.5955
8=90.5246
9=98.300
17=212.5956
18=269.0716
24=32.5955
25=90.5249
5=STN2
4=TL1 FSSTN2
6=1.448
7=182.1037
8=89.4211
9=162.715
17=2.1040
18=270.1759
24=182.1032
25=89.4221
61=22
0=P22
2=STN2 PISP
3=1.542
5=STN1

Description

4=TL1 ROSTN1
6=1.475
7=10.1654
8=90.2218
9=162.710
17=190.1657
18=269.3740
24=10.1652
25=90.2216
5=STN3
4=TL1 FSSTN3
6=1.486
7=195.4510
8=90.0511
9=257.710
17=15.4508
18=269.5452
24=195.4513
25=90.0514
61=22
0=P22
2=STN3 PISP
3=1.581
5=STN2
4=TL1 ROSTN2
6=1.448
7=187.1306
8=89.5740
9=257.710
17=7.1306
18=270.0232
24=187.1306
25=89.5752
5=STN4
4=TL1 FSSTN4
6=1.400
7=23.1437
8=87.3949
9=173.958
17=203.1434
18=272.2031
24=23.1440
25=87.4008
61=22
0=P22
2=STN4 PISP
3=1.546
5=STN3
4=TL1 ROSTN3
6=1.487
 continue on next page

Geodimeter file Description Geodimeter file
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7=199.0404
8=92.2432
9=173.963
17=19.0353
18=267.3552
24=199.0414
25=92.2456
5=STN5
4=TL1 FSSTN5
6=1.457
7=34.4057
8=88.1846
9=151.526
17=214.4059
18=271.4140
24=34.4055
25=88.1912
61=22
0=P22
2=STN5 PISP
3=1.552
5=STN4
4=TL1 ROSTN4
6=1.452
7=184.4113
8=91.4601
9=151.527
17=4.4111
18=268.1402
24=184.4114
25=91.4603
5=STN6
4=TL1 FSSTN6
6=1.496
7=19.0418
8=89.5731
9=179.824
17=199.0420
18=270.0229
24=19.0416
25=89.5730
61=22
continued in next 
column

Description

0=P22
2=STN6 PISP
3=1.591
5=STN5
4=TL1 ROSTN5
6=1.458
7=179.5456
8=90.0633
9=179.821
17=359.5457
18=269.5333
24=179.5456
25=90.0639
5=STN7
4=TL1 FSSTN7
6=1.453
7=7.5532
8=91.2051
9=149.687
17=187.5533
18=268.3914
24=7.5531
25=91.2056
61=22
0=P22
2=STN7 PISP
3=1.547
5=STN6
4=TL1 ROSTN6
6=1.496
7=196.4115
8=88.4357
9=149.679
17=16.4116
18=271.1600
24=196.4115
25=88.4353
5=STN8
4=TL1 FSSTN8
6=1.478
7=8.1420
8=91.5307
9=205.948
 continue on next page

Geodimeter file Description Geodimeter file
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17=188.1422
18=268.0657
24=8.1418
25=91.5310
61=22
0=P22
2=STN8 PISP
3=1.574
5=STN7
4=TL1 ROSTN7
6=1.453
7=181.1643
8=88.1026
9=205.939
17=1.1647
18=271.4934
24=181.1638
25=88.1026
5=STN9
4=TL1 FSSTN9
6=1.517
7=359.0523
8=89.1311
9=199.132
17=179.0523
18=270.4648
24=359.0523
25=89.1310
61=22
0=P22
2=STN9 PISP
3=1.614
5=STN8
4=TL1 ROSTN8
6=1.478
7=173.0014
8=90.5031
9=199.132
17=353.0017
18=269.0934
24=173.0011
25=90.5037
continued in next
 column

Description

5=STN10
4=TL1 FSSTN10
6=1.400
7=345.0918
8=86.2903
9=221.043
17=165.0917
18=273.3103
24=345.0920
25=86.2908
61=22
0=P22
2=STN10 PISP
3=1.583
5=STN9
4=TL1 ROSTN9
6=1.517
7=165.4152
8=93.3413
9=221.053
17=345.4122
18=266.2600
24=165.4221
25=93.3425
5=STN11
4=TL1 FSSTN11
6=1.460
7=0.2903
8=86.1535
9=215.241
17=180.2930
18=273.4438
24=0.2836
25=86.1548
50=ERICC
61=1
6=1.443
54=ROGER-RANGER 
STN
0=A
53=ECB
51=04-06-2002
61=22
 continue on next page

Geodimeter file Description Geodimeter file
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0=P22
2=STN11 PISP
3=1.573
5=STN10
4=TL1 ROSTN10
6=1.520
7=131.1633
8=93.4738
9=215.253
17=311.1639
18=266.1222
24=131.1626
25=93.4738
5=STN12
4=TL1 FSSTN12
6=1.465
7=307.3035
8=87.2924
9=191.435
17=127.3037
18=272.3034
24=307.3033
25=87.2922
61=22
0=P22
2=STN12 PISP
3=1.558
5=STN11
4=TL1 ROSTN11
6=1.477
7=11.1452
8=92.3416
9=191.448
17=191.1454
18=267.2611
24=11.1449
25=92.3443
5=STN13
4=TL1 FSSTN13
6=1.443
7=180.1114
8=89.1045
continued in next
 column

Description

9=222.450
17=0.1114
18=270.4942
24=180.1113
25=89.1113
 

Geodimeter file Description Geodimeter file
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F  12D and Topcon 
Instruments

The Topcon data format is used as a raw data file by 12d Model and is converted into a 12d Field 
File before reduction.
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G  12D and Leica TPS 
Instruments

The Leica GSI data format produced by the Leica TPS is used as a raw data file by 12d Model and 
is converted into a 12d Field File. The contents of the recorded data can be manipulated by use of 
the Leica’s recording masks. The setup of which is explained in the section “Setup of Leica 1100 
instrument for detail pickup and use with 12d” .

Each line (data block) of the Leica GSI file consists of between 1 and 12 words, with the words 
containing either 16 (8 characters for data) or 24 (16 characters for data) characters. The two 
formats will be referred to as the 8 format and 16 format respectively.

Measurement lines in the 8 format start with 11 and code lines start with 41.

For the 16 format, measurement lines start with *11 and code lines start with *41.

For an example of a GSI file in the 8 format, go to the section “Example of Leica GSI File” .

When using a Leica, the Leica screen can be standard or controlled by using a code.hex file on the 
1000 series or a Geobasic program or Leica Codelist (.crf file) on the 1100 series.

4D Solutions provide a basic code.hex, Geobasic program and various Codelists(.crf files) on the 
12d Model Installation CD in the folder ’Other_Software\Leica’. These can be customised to 
your requirements - please contact 4D Solutions for more information.

For an example of a Leica screen with standard set-up, Codelist and Geobasic program, please go 
to the section “Examples of Leica Screens” .

Please continue to the next section “Feature Codes and String Numbers” .

Feature Codes and String Numbers
The feature code and string number for a measurement are entered in the Leica by giving the feature 
code in the first word and the string number as the second word of a code line. The feature codes 
and string numbers can be alpha or numeric and up to 8 (16) characters long.

For example, the feature code ABC with string number 1 is recorded as:

410003+00000ABC 42....+00000001 for the 8 format

or

*410003+0000000000000ABC 42....+0000000000000001 for the 16 format.

Some surveyors like to define the feature code and string number before they make a measurement. 
Other surveyors prefer to define the feature code and string number after they make a 
measurement.

When defining a Data Collector setup, 12d Model allows the user to specify whether the feature 
code comes before or after a measurement:

code before measurement

The given feature code and string number applies to the next measurement and all subsequent 
measurements until another feature code and string number is entered.

code after measurement

The given feature code and string number applies to the last measurement and all subsequent 
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measurements until another feature code and string number is entered.

However, for a particular data collector setup, it can be only be defined as one of the two choices. 
That is you can’t change between having feature codes before or after measurements in the one 
raw file.
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Summarising: 

Whether feature code definitions come before or after the measurements is defined in the Survey 
Data Collector definition and is set by the Measurement/Code order field on the Instrument tab of the 
Surevy.4d Create/Edit panel. 

Please continue to the next section “Leica Field Codes” .

For a data collector definition, there is the
choice of code before or after the measureme

Pop-up list of data collector definitions
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Leica Field Codes
12d Model also uses code lines to supply extra information using field codes.

All field codes are entered as the first word of the code line and to differentiated it from a feature 
code, the field code is proceeded by a ".". Depending on the field code, more information may be 
required and it is entered in words 2 and above in the code line.

Each field code will now be described in detail.

For each field code, two lines and a paragraph of description are given:

▲ The first line consists of the field code and a short description of the purpose of the code.

▲ The second line gives the full syntax of the record for that field code.

▲ The paragraph gives a detailed description of the field code.

A 12d Model code list containing 12d Model field codes is available for the TPS to help coding in 
the field.

Field Code Conventions
In the syntax for the field codes, optional Words or groups of Words are enclosed in the square 
brackets [ ].

However, when the Leica TPS creates the Leica GSI format, the data in all Words is right justified 
and left filled with zeros. Consequently, 12d Model strips leading zeros from all Words before 
processing the data.

This means that 

(a) an optional Word still exists in the file but its data field is simply filled with zeros.

(b) any text in a Word cannot start with a zero. You would need to start with a space and then a 
zero.

In the field code descriptions, the point just measured is referred to as the current measurement 
point, the current point or the last measurement point.

The string that the current measurement point belongs to is called the current string.

For a summary of the Leica Field Codes, go to the section “Summary of Leica Field Codes” 

For the full description of the Leica Field Codes, go to the section “Full Description of Leica Field 
Codes” .

For an example of a raw Leica file, please go to the section  “Example of Leica GSI File” .
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Full Description of Leica Field Codes
For a summary of the Leica Field Codes, go to the section “Summary of Leica Field Codes” 

Field Description of Record
Code

.2 Directly entered coordinates
Word 1 .2 Word 2 X Word 3 Y Word 4 Z Word 5 Feature_code

Word 6 String_number [Word 7 Point_number Word 8 Point_name]

A measurement point is created with the given feature code and string number and given (x, y, z) co-
ordinates. No reduction is needed.

If a Point_name exists, then it is a named measurement and in the reduction, a 4d point string of name 
Point_name is created and mapped using the mapping file. The 4d text is the station prefix followed by 
Point_name. The Point_name is added to the internal list of named points for searching for co-
ordinates.

Note that the Leica GSI format includes directly entered coordinates in a code line by data blocks with 
word indices 81, 82, 83 (Easting, Northing and Elevation).

.3 New instrument point - before the measurement
Word 1 .3 Word 2 Point_name Word 3 Instrument_height

Set up an instrument at the point with name Point_name. In the reduction, the (x, y, z) co-ordinates for 
Point_name are found by first searching the control model, then the list of previously named points in 
the reduction, point numbers of previous measurements and finally if Point_name is still not found, the 
user is asked to type in the (x, y, z) co-ordinates.

Note that the Leica GSI format includes setting up on a station in a measurement line by data blocks 
with word indices 84, 85, 86 (Station easting, Station northing and Station elevation) and 88 
(Instrument height).

.4 Next measurement is a backsight - before the measurement
Word 1 .4 Word 2 Station_name [Word 3 Feature_code Word 4 String_number Word 
5 Target_height]

The next measurement is to a backsight with name Station_name.

For traverse reduction, if the traverse code specified in the reduction panel matches the Feature code 
given in Word 3, the data will be included in a traverse reduction, string number can also be specified. 
Also the target height to the backsight can be given in the backsight command.

.5 New target height for subsequent measurements - before the measurement
Word 1 .5 Word 2 Target_height

Set a new target height to be used for all subsequent measurement points.

Note that the Leica GSI format can include the target height on each measurement line (word index 
97).

.6 Next measurement is a Check measurement - before the measurement
Word 1 .6 Word 2 Station_name

The next measurement is a check measurement made to the station Station_name.

During reduction a two point super string (with name Station_name) from the instrument point to the 
measured point is created in the default model for the check measurement. The instrument point name, 
the station name and the differences between the measurement point co-ordinates and station co-
ordinates are written as text along the super string. The differences between the measurement and the 
known point is also written to the report file.
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.9 Scale factor for subsequent distances
Word 1 .9 Word 2 Scale_factor

Scale factor to apply to subsequent slope distances.

.11 Next measurement is to a named station - before the measurement
Word 1 .11 Word 2 Station_name [Word 3 Feature_code Word 4 String_number Word 
5 Target_height]

This field code gives a name to a measurement so that it can be used in other field codes for setting up 
an instrument on, backsighting to or doing a check measurement to.

The next measurement locates a new instrument station with the name Station_name. A point with 
vertex text of Station_name is created. The Station_name is added to the internal list of named points 
for searching for co-ordinates.

If Feature_code exists, the point is given that Feature_code, otherwise the current feature code is used.

For traverse reduction, if the traverse code specified in the reduction panel matches the Feature code 
given in Word 3, the data will be included in a traverse reduction, string number can also be specified. 
Also the target height to the foresight can be given in this command.

.14 Feature code and string number - before or after measurement depends on the data collector
 definition

Word 1 .14 Word 2 Feature_code Word 3 String_number [Word 5 text Word 6 text] ...

A field code for entering the feature code and string number rather than using the standard method of 
using word 1 and word 2 This is for use with Leica quick codes which must put out a fixed first word. 
Any additional text is added to the end of any existing vertex text for the current measurement point. 
Any leading zeros in the text words will be ignored.

This field code is used always before or always after measurements depending on the Measurement/
code field on the Instrument tab of the Survey.4d Create/Edit panel for the selected data collector 
definition.

.15 Vertical circle correction for subsequent measurements - before the measurement
Word 1 .15 Word 2 Vertical_circle_in_decimal_degrees

The vertical_circle_in_decimal_degrees is subtracted from the vertical circle value in any subsequent 
measurements.

.16 Additional code for point (multiply coded point) - after the measurement
Word 1 .16 Word 2 Feature_code Word 3 String_number [Word 4 Point_name] [Word 
5 Point_text]

Additional coding for the current measurement point. A new measurement point is created at the same 
position as the current measurement point but with the Feature_code and String_number from this field 
code. The same point number is used as for the current measurement point.

If Point_text exists, it is used as the vertex text for that vertex of the super string.

If Point_name exists, then it is a named measurement and during reduction, a 4d point string of name 
Point_name is created and mapped using the mapping file. The 4d text is the station prefix followed by 
Point_name. The Point_name is added to the internal list of named points for searching for co-
ordinates.

.17 Arc through previous three points - after the measurement of last point of arc
Word 1 .17 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, then the current measurement point and the two previous points with the same 
feature code and string number as the current measurement point, are joined by an arc. If there is less 
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than three such points, no arc is fitted.

If the Feature_code and String_number exist, the last three previous three measurement points of the 
same feature code and string number are joined by an arc. If the current measurement point has that 
feature code and string number, then it is the third of the three points used. If there is less than three 
points, no arc is fitted.

If Point_number exists, then the feature code and string number are taken from the previous 
measurement point with that point number, and that point and the two measurement points previous to 
the pre-defined point of the same feature code and string number, are joined by an arc. If there is less 
than three points, no arc is fitted

See the Section  “Arcs Through Points” for more information on arc fitting.

.18 Circle Feature - after the measurement
Word 1 .18 Word 2 Radius [Word 2 Radius ...]

Creates a feature string with the given radius and centred on the current measurement point. If there is 
more than one radius, then separate feature strings are created each with one of the radii.

.20 Close string - after the measurement
Word 1 .20 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exits, the current string is closed.

If the Feature_code and String_number exist, the last previous string with that feature code and string 
number is closed.

If Point_number exists, then the string containing that point number is closed.

See the Section  “Close String” for more information on closing a string.

.21 Join last points of strings
Word 1 .21 Word 2 Feature_code Word 3 String_number_1 Word 4 String_number_2

In the final reduction, the last point of the string with the given Feature_code and String_number_1 is 
joined to the last point of the string with given Feature_code and String_number_2. The created string 
has the given Feature_code (no string number is needed since it is the final phase of reduction when the 
string numbers are dropped).

See the Section  “Joining Strings” for more information on joining strings.

.22 Join first to last point of strings
Word 1 .22 Word 2 Feature_code Word 3 String_number_1 Word 4 String_number_2

In the final reduction, the first point of the string with the given Feature_code and String_number_1 is 
joined to the last point of the string with given Feature_code and String_number_2. The created string 
has the given Feature_code (no string number is needed since it is the final phase of reduction when the 
string numbers are dropped).

See the Section  “Joining Strings” for more information on joining strings.

.23 Join first points of strings
Word 1 .23 Word 2 Feature_code Word 3 String_number_1 Word 4 String_number_2

In the final reduction, the first point of the string with the given Feature_code and String_number 1 is 
joined to the fist point of the string with given Feature_code and String_number_2. The created string 
has the given Feature_code (no string number is needed since it is the final reduction when the string 
numbers are then dropped).

See the Section  “Joining Strings” for more information on joining strings.

.28 Text appended to a string name
Word 1 .28 Word 2 Text [Word 3 Feature_code Word 4 String_number] [Word 
5 Point_number]
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Text is appended to the string name. For example, if 1.200 is entered, “ 1.200” is appended to the string 
name.

If only Text is given, Text is appended to the string name of the current string.

If the Feature_code and String_number exist, then the last previous string with that feature code and 
string number has Text appended to the string name.

If Point_number exists, then the string containing that point number has Text appended to the string 
name.

.29 Note or memo - after the measurement
Word 1 .29 [Word 2 text] [Word 3 text] ...

Any text may be entered and will be added to the check measurements model at the position of the 
current measurement point.

.30 Remove height from a point - that is make it a null height - after the measurement
Word 1 .30 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the height of the current measurement point is set to null.

If Feature_code and String_number exist, then the height of the last point of the previous string with 
that feature code and string number is set to null.

If Point_number exists, then the height of the point with that point number is set to null.

.37 Rectangle by two points
Word 1 .37 Word 2 offset_in_metres [Word 3 Feature_code Word 
4 String_number] [Word 5 Point_number]

The rectangle is defined by two points (reference side) and a offset.

If a positive offset value is given, two points will be created to the right of the reference side.

If a negative offset value is given, two points will be created to the left of the reference side.

If Feature_code and String_number exist, the last two points with that feature code and string number 
are used and a fourth points are created to form a rectangle. The height of the two new points are set to 
null. The string is then closed.

If Point_number exists, then the feature code and string number of the point with that point number are 
used and processed as above. Note that the point with the point number is not necessarily used.

Two consecutive rectangles are unable to be defined side by side. In other words if the two points given 
are part of string of greater than two vertices, the command will only work for sets of two points that 
are exclusively defined. i.e. For a 5 point string, a rectangle can be defined by points 1 and 2, and 4 and 
5. 

See the Section  “Rectangle” for more information.

.38 Make the previous segment non-tinable (not a breakline) - after the measurement
Word 1 .38 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the previous segment containing the current measurement point is set to non-
tinable. That is, it will not be treated as a breakline in triangulations.

If the Feature_code and String_number exist, then the last segment of the previous string with that 
feature code and string number is set to non-tinable.

If Point_number exists, then the segment containing the point with that point number as an end point, is 
set to non-tinable.

.39 Make the next segment non-tinable (i.e. not a breakline) - after the measurement for the first
point of the segment

Word 1 .39 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]
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If only Word 1 exists, the next segment containing the current measurement point as a starting point is 
set to non-tinable. That is, it will not be treated as a breakline in triangulations.

If the Feature_code and String_number exist, then the segment that is created in the future from the last 
point of the previous string with that feature code and string number is set to non-tinable.

If Point_number exists, then the segment containing the point with that point number as a start point, is 
set to non-tinable.

.40 Make a point non-tinable - after the measurement
Word 1 .40 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the current measurement point is set to non-tinable. That is, it will not be 
included in triangulations.

If Feature_code and String_number exist, then the last point of the previous string with that feature 
code and string number is set to non-tinable.

If Point_number exists, then the point with that point number is set to non-tinable.

.41 Add additional text to the current measurement point - after the measurement
Word 1 .41 Word 2 text [Word 3 text] ...

The given text is added to the end of any existing vertex text for the current measurement point. Any 
leading zeros in the text words will be ignored.

.42 Add a radial offset - after the measurement
Word 1 .42 Word 2 Radial_offset_in_metres [Word 3 Feature_code Word 
4 String_number] [Word 5 Point_number]

The Radial_offset_in_metres is used to adjust the position of the specified point by a plan distance from 
the specified points original position, along the plan line joining the current station to the specified 
point. A positive offset is away from the station, negative is toward the station.

If only Word 1 and 2 exist, the offset is used to adjust the position of the current measured point.

If Feature_code and String_number exist, then the last point of the previous string with that feature 
code and string number is adjusted.

If Point_number exists, then the point with that point number is adjusted.

 See the Section  “Offsets” for more information on offsets.

.43 Add a tangential offset - after the measurement
Word 1 .43 Word 2 Tangential_offset_in_metres [Word 3 Feature_code Word 
4 String_number] [Word 5 Point_number]

The Tangential_offset_in_metres is used to adjust the position of the specified point by a plan distance 
from the specified points original position, at rights angles to the plan line joining the current station to 
the specified point. A negative offset is to the left (looking from the station), and positive is to the right 
(looking from the station).

If only Word 1 and 2 exist, the offset is used to adjust the position of the current measured point.

If Feature_code and String_number exist, then the last point of the previous string with that feature 
code and string number is adjusted.

If Point_number exists, then the point with that point number is adjusted.

 See the Section  “Offsets” for more information on offsets.

.44 Add a height offset - after the measurement
Word 1 .44 Word 2 Height_offset_in_metres [Word 3 Feature_code Word 
4 String_number] [Word 5 Point_number]

If the height of the specified point is not null, then the Height_offset_in_metres adjusts the height of the 
point. A positive offset adds to the height, a negative offset reduces the height.
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If only Word 1 and 2 exist, the offset is used to adjust the position of the current measured point.

If Feature_code and String_number exist, then the last point of the previous string with that feature 
code and string number is adjusted.

If Point_number exists, then the point with that point number is adjusted.

 See the Section  “Offsets” for more information on offsets.

.45 Make a parallelogram from the last three measurement points - after the measurement
Word 1 .45 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the current measurement point and the two previous points from the current 
string are used and a fourth point is created to form a parallelogram (squashed rectangle) and the height 
of the fourth point is set to null. The string is then closed.

If Feature_code and String_number exist, the last three points with that feature code and string number 
are used and a fourth point is created to form a parallelogram (squashed rectangle) and the height of the 
fourth point is set to null. The string is then closed.

If Point_number exists, then the feature code and string number of the point with that point number are 
used and processed as above. Note that the point with the point number is not necessarily used.

 See the Section  “Rectangle” for more information on forming a parallelogram.

.46 Make the entire string a breakline or not (tinable or non-tinable)
Word 1 .46 [Word 2 Breakline_type] [Word 3 Feature_code Word 4 String_number] 

[Word 5 Point_number]

Word 2: Breakline_type:

If Breakline_type is 0, the selected string is set to a point string and hence is not a breakline (non-
tinable).

If Breakline_type is 1, the selected string is set to a line string and is therefore a breakline (tinable).

Words 3, 4, and 5:

If none of Words 3, 4 and 5 exist, the Breakline_type is applied to the current string.

If Feature_code and String_number exist, the Breakline_type is applied to the last string with that 
feature code and string number.

If Point_number exists, then the Breakline_type is applied to the string containing the point with that 
point number.

.47 Start a new string using the same feature code and string number - after the measurement of the
first point of the new string

Word 1 .47 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the current string is terminated (without including the current measurement 
point) and the current measurement point becomes the first point of a new string with the same feature 
code and string number. 

If Feature_code and String_number exist, then the last point of the previous string with that feature 
code and string number becomes the first point of a new string with the same feature code and string 
number.

If Point_number exists, then the previous string containing the point with that point number is 
terminated before the point number point, and the point becomes the first point of a new string with the 
same feature code and string number.

.48 End a string 
Word 1 .48 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the current string is terminated (including the current measurement point).

If Feature_code and String_number exist, then the last point of the previous string with that feature 
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code and string number becomes the last point of that string.

If Point_number exists, then the previous string containing the point with that point number is 
terminated after the point number point

.50 Specify the bearing to correct for true north - used as the bearing datum difference
Word 1 .50 Word 2 Bearing_in_decimal_degrees [Word 3 Text]

The Bearing_in_decimal_degrees is used as the bearing datum difference for the current instrument set 
up. The Text and the Bearing_in_decimal_degrees are written to the reduction report file.

.51 Start using an existing field template - before the measurement
Word 1 .51 Word 2 [Template_name] [mode]

Start using the template Template_name. If Template_name is blank, the default template is used 
If mode is "for", then the field template is used as a forward template.

"rev", then the field template is used as a reverse template.
"zig", then the field template is used as a zig_zag template and is used in the forward 

definition direction first.
"zag", then the field template is used as a zig_zag template and is used in the reverse 

direction first
If mode is blank, or 0, or anything other than "for", "rev", or "zag", then the field template is used as a 
zig-zag field template starting on a zig.

See the Section  “Field Templates” for more information on field templates.

.52 Finish using a field template or finish recording a field template - after the measurement
Word 1 .52

Stops using the current field template or stops recording a field template.

.53 Pause using the current field template - after the measurement
Word 1 .53

Pause using the current field template or defining a field template, until a continue template (54) or a 
finish field template (52) code is given.

.54 Continue the current field template - before the measurement
Word 1 .54

Continue using the current field template or defining the current field template, which has been stopped 
by a Pause command (53). The Continue command only needs to be given once and applies to all 
following measurements until another Pause or Finish command is given.

.55 Start recording a field template - before the measurement
Word 1 .55 Word 2 [Template_name]

Start recording a field template with the name Template_name. If Template_name is non-blank, then 
the default field template is defined. The feature_code and string_number of the following 
measurements until a Finish code (52) are stored as the field template. There is no limit to the number 
of points in a field template.

See the Section  “Field Templates” for more information on field templates.

.56 Skipping picking up points when using a field template - after the measurement of last point
 before skipping points

Word 1 .56 Word 2 [num_skipped_points]

Allows the user to skip picking up one or more points from the field template currently being used. The 
next measurement takes the feature_code and string_number from the next point of the field template 
definition. If num_skipped_points is missing, then only one point is skipped otherwise 
num_skipped_points are skipped.
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.57 Delete points on a field template - after the measurement of last point
Word 1 .57 Word 2 [num_points_to_delete]

Allows the user to delete one or more points from the field template currently being used. The next 
measurement takes the feature_code and string_number from the next point of the field template 
definition. 

.58 Insert points when using a field template - after the measurement of last point
 before inserting points

Word 1 .58 Word 2 Feature_code Word 3 String_number Word 
4 Multiple_code_flag Word 5 Insert_special_flag

Allows the user to insert points into the field template currently being used. The next measurement 
takes the feature_code and string_number from the next point of the field template definition.

If the Multiple_code_flag = 1, then the feature code will be added to the previous defined template 
point else if Multiple_code_flag = 0 (default), it will be added to the template as a separate point. 

If the insert is done at the end of a section and the Insert_special_flag = 1 the point will be added to the 
end of the current template section else it will be at the start of the next section.

.60 Start of arc through next three points - after the measurement of the first point of the arc
Word 1 .60 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, an arc is inserted through the current measurement point and the next two 
measured points with the same feature code and string number as the current measurement point. If 
there is less than three points, no arc is fitted.

If Feature_code and String_number exist, a search is made for a previously defined measurement with 
the same feature code or string number. An arc is inserted through the previous measurement and the 
next two measured points following this previous measurement with the same feature code and string 
number. If the current point has that feature code and string number, then it is the first of the three 
point. If there is less than three points, no arc is fitted.

If Point_number exists, then the feature code and string number are taken from the previous 
measurement point with that point number, and an arc is inserted through that point and the next two 
measurement points with the same feature code and string number. If there is less than three points, no 
arc is fitted

See the Section  “Arcs Through Points” for more information on arc fitting.

.61 Start of arc through sets of three points until end of string, or a 62 occurs - after the
 measurement of the first point of the arc

Word 1 .61 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

The arcs are fitted as follows - the first arc is fitted through points one, two and three, the next arc 
through points three, four and five etc. If there is less than three points remaining at the end, then no arc 
is fitted to the end points.

If only Word 1 exists, arcs are inserted through the following sets of measurement points with the same 
feature code and string number as the current measurement point. The current measurement point is the 
first of the points.

If the current point has that feature code and string number, then it is the first of the points. If there is 
less than three points, then no arc is fitted.

If the feature code and string number exist, a search is made for a previously defined measurement with 
the same feature code or string number. An arc is inserted through the following measured points with 
the same feature code and string number as given in point_description. If the current point has that 
feature code and string number, then it is the first of the points. 

 If Point_number exists, then the feature code and string number are taken from the previous 
measurement point with that point number, and arcs are inserted through that point and the following 
measured points with the same feature code and string number.
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If 12d Model encounters a Start Arcs through sets of three points but no End Arcs command for the 
string, then an End Arcs is assumed at the end of the string.

See the Section  “Arcs Through Points” for more information on arc fitting.

.62 End the arcs begun by a 61 command - after the measurement of the last point of the arcs
Word 1 .62 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, then the fitting of arcs through the points of the current string is stopped. The 
current measurement point is the last of the points used in the arc fitting.

If Feature_code and String_number exist, then the fitting of arcs through the points of the previous 
string with the same feature code and string number is stopped. If the current measurement point has 
that feature code and string number, then it is the last point used in the arc fitting.

 If Point_number exists, then the point with that point number is the last point used in the arc fitting.

If 12d Model encounters an End Arcs (62) but no Start Arcs through sets of three points (61) command 
for the string, then an Start Arcs through sets of three points (61) is assumed to apply at the beginning 
of the string and hence arc fitting will be applied to the entire string.

See the section  “Arcs Through Points” for more information on arc fitting.

There are field codes for adding user defined attributes to:

(a) the current string being measured (i.e. the string containing the current measurement point)

(b) the current measurement point

(c) the next segment from the current measurement point (i.e. the segment joining the current 
measurement point and the next measured point of the same feature code and string number)

 or

(d) the previous segment to the current measurement point (i.e. the segment joining the current 
measurement point to the previous measured point of the same feature code and string 
number).

The attributes can be named or unnamed and are coded in the following way:

If Word 2 is missing (i.e. all zeros), then the attribute is an un-named attribute and the rest of the 
Words on the line is the attribute value. The attribute is given the special name "unnamed 
attribute n" for n=1, 2, ... .

.68 Add an integer user defined attribute to the current string
Word 1 .68 [Word 2 Name] Word 3 Integer

Add an user defined integer attribute to the current string.

.69 Add a real user defined attribute to the current string
Word 1 .69 ]Word 2 Name] Word 3 Real

Add a real (floating point) user defined attribute to the current string.

.70 Add text user defined attribute to the current string
Word 1 .70 [Word 2 Name] Word 3 Text [Word 4 Text] ...

Add a text user defined attribute to the current string.

.71 Add integer user defined attribute to the current point
Word 1 .71 [Word 2 Name] Word 3 Integer
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Add an integer user defined attribute to the current measurement point.

.72 Add real user defined attribute to the current point
Word 1 .72 [Word 2 Name] Word 3 Real

Add a real (floating point) user defined attribute to the current measurement point.

.73 Add text user defined attribute to the current point
Word 1 .73 [Word 2 Name] Word 3 Text [Word 4 Text] ...

Add a text user defined attribute to the current measurement point.

.74 Add integer user defined attribute to the next segment
Word 1 .74 [Word 2 Name] Word 3 Integer

Add an integer user defined attribute to the next segment from the current measurement point.

.75 Add real user defined attribute to the next segment
Word 1 .75 [Word 2 Name] Word 3 Real

Add a real (floating point) user defined attribute to the next segment from the current measurement 
point.

.76 Add text user defined attribute to the next segment
Word 1 .76 [Word 2 Name] Word 3 Text [Word 4 Text] ...

Add a text user defined attribute to the next segment from the current measurement point.

.77 Add integer user defined attribute to the previous segment
Word 1 .77 [Word 2 Name] Word 3 Integer

Add an integer user defined attribute to the previous segment for the current measurement point.

.78 Add real user defined attribute for the previous segment
Word 1 .78 [Word 2 Name] Word 3 Real

Add a real (floating point) user defined attribute to the previous segment for the current measurement 
point.

.79 Add text user defined attribute to the previous segment
Word 1 .79 [Word 2 Name] Word 3 Text [Word 4 text] ...

Add a text user defined attribute to the previous segment for the current measurement point.

In addition, extra codes allow 12d Model pipe strings to be coded in the field.

.80 Pipe invert point (bottom of the pipe) - after the measurement
Word 1 .80 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the current measurement point is on the invert (bottom) of a pipe. This is the 
default for measurements to points on pipe strings. If the point is not part of a pipe string, it is ignored.

If Feature_code and String_number exist, the last point of the previous string with the same feature 
code and string number is on the invert (bottom) of a pipe. If the point is not part of a pipe string, it is 
ignored.

If Point_number exists, then the point with that point number is on the invert (bottom) of a pipe. If the 
point is not part of a pipe string, it is ignored.

.81 Pipe axial point (centre of the pipe)   - after the measurement
Word 1 .81 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]
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If only Word 1 exists, the current measurement point is on the axis (centre) of a pipe. If the point is not 
part of a pipe string, it is ignored.

If Feature_code and String_number exist, the last point of the previous string with the same feature 
code and string number is on the axis (centre) of a pipe. If the point is not part of a pipe string, it is 
ignored.

If Point_number exists, then the point with that point number is on the axis (centre) of a pipe. If the 
point is not part of a pipe string, it is ignored.

.82 Pipe obvert point (top of the pipe) - after the measurement
Word 1 .82 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the current measurement point is on the obvert (top) of a pipe. If the point is not 
part of a pipe string, it is ignored.

If Feature_code and String_number exist, the last point of the previous string with the same feature 
code and string number is on the obvert (top) of a pipe. If the point is not part of a pipe string, it is 
ignored.

If Point_number exists, then the point with that point number is on the obvert (top) of a pipe. If the 
point is not part of a pipe string, it is ignored.

.83 Start recording a shape - before the measurement
Word 1 .83 [Word 2 Shape_name]

Start recording a shape with the name Shape_name. If Shape_name is non-blank, then the default field 
Shape is defined by the feature_code and string_number of the following measurements until a Finish 
code (84) are stored as the shape. There is no limit to the number of points in a shape.

See the Section  “Field Templates” for more information on field templates.

.84 Finish using a shape definition or finish recording a shape - after the measurement
Word 1 .84

Stops using the current shape or stops recording a shape.

.85 Shape parallel 
Word 1 .85 Word 2 Shape_name [Word 3 Feature_code Word 4 String_number] [Word 
5 Point_number]

If Feature_code and String_number exist, the last string with the same feature code and string number 
has the shape applied to the entire length of the string.

If Point_number exists, then the string containing that point number has the shape applied to the entire 
length of the string.

Parallelling the shape will produce separate strings for each point of the shape.

.86 Shape extrude 
Word 1 .86

Word 1 .85 Word 2 Shape_name [Word 3 Feature_code Word 4 String_number] [Word 
5 Point_number]

If Feature_code and String_number exist, the last string with the same feature code and string number 
has the shape applied to the entire length of the string.

If Point_number exists, then the string containing that point number has the shape applied to the entire 
length of the string.

Extruding the shape will produce a single string for the shape.
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.92 Remove all z-values for a string (i.e. make all z-values null)   - after the measurement
Word 1 .92 [Word 2 Point_line_type] [Word 3 Feature_code Word 
4 String_number] [Word 5 Point_number]

If only Word 1 exists, all z-values for the current string are removed.

If Feature_code and String_number exist, the last string with the same feature code and string number 
has all its z-values removed.

If Point_number exists, then the string containing that point number has all its z-values removed.

If Point_line_type is 0, the selected string is set to a point string.
If Point_line_type is 1, the selected string is set to a line string.

.93 Set the Point-line type - after the measurement
Word 1 .93 [Word 2 Point_line_type] [Word 3 Feature_code Word 
4 String_number] [Word 5 Point_number]

If only Word 1 exists, the current string is created as a point string.

If Feature_code and String_number exist, the last previous string with the same feature code and string 
number has its point-line type modified.

If the point number exists, then the string containing that point number has its point-line type modified.

If Point_line_type is 0, the selected string is set to a point string.
If Point_line_type is 1, the selected string is set to a line string.

.94 Use name library/mapping file for vertex text on the string - name mapping - after the
measurement

Word 1 .94 [Word 2 Point_line_type] [Word 3 Feature_code Word 
4 String_number] [Word 5 Point_number]

If this field code exists then during reduction, vertex text is creating using either the name library, or if 
the name library doesn’t exist, the map file. If neither exist then the field code is ignored.

if a name library is used and the feature code of the string is found in the first column of the 
name library, then the entry from the second column of that row will be used as text for all 
vertices of the string that don’t already have vertex text. As a default, the string is set as a point 
string.

if the map file is used and the feature code of the string is found in the first column of the map 
file, then the string name field of the map file is used as vertex text for all vertices that don’t 
already have text. As a default, the string is set as a point string.

If only Word 1 exists, then name mapping is applied to the current string.

If Feature_code and String_number exist, then name mapping is applied to the last previous string with 
the same feature code and string number.

If Point_number exists, then name mapping is applied to the string containing that point number.

If Point_line_type is 0, the selected string is set to a point string.
If Point_line_type is 1, the selected string is set to a line string.

.95 Circular Pipe string   - after the measurement
Word 1 .95 Word 2 Diameter [Word 3 Feature_code Word 4 String_number] [Word 
5 Point_number]

Pipe strings are always line strings and are stored with the justification of the majority of the string 
points. Individual pipe points are picked up either top (obvert), centre (axial) or bottom (invert) of the 
pipe using field codes 80, 81 and 82.

If only Word 1 and 2 exists, the current string is created as a pipe string with the given diameter. 

If Feature_code and String_number exist, the last string with the same feature code and string number 
is created as a pipe with the given diameter.
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If Point_number exists, then the string containing that point number is created as a pipe string with the 
given diameter.

.96 Box Culvert string   - after the measurement
Word 1 .95 Word 2 Width Word 3 Height [Word 4 Feature_code Word 
5 String_number] [Word 6 Point_number]

Culvert strings are always line strings and are stored with the justification of the majority of the string 
points. Individual culvert points are picked up either top (obvert), centre (axial) or bottom (invert) of 
the culvert using field codes 80, 81 and 82.

If only Word 1, 2 and 3 exists, the current string is created as a culvert string with the given width and 
height. 

If Feature_code and String_number exist, the last string with the same feature code and string number 
is created as a culvert with the given width and height.

If Point_number exists, then the string containing that point number is created as a culvert string with 
the given width and height.

.99 Terminate processing
Word 1 .99

Stop processing the field file at this line. Useful for debugging errors.

.107 Make the previous segment invisible - after the measurement
Word 1 .107 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the previous segment containing the current measurement point is set to 
invisible.

If the Feature_code and String_number exist, then the last segment of the previous string with that 
feature code and string number is set to invisible.

If Point_number exists, then the segment containing the point with that point number as an end point, is 
set to invisible.

.108 Make the next segment invisible - after the measurement for the first
point of the segment

Word 1 .108 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the next segment containing the current measurement point as a starting point is 
set to invisible.

If the Feature_code and String_number exist, then the segment that is created in the future from the last 
point of the previous string with that feature code and string number is set to invisible.

If Point_number exists, then the segment containing the point with that point number as a start point, is 
set to invisible.

.109 Make a point invisible - after the measurement
Word 1 .109 [Word 2 Feature_code Word 3 String_number] [Word 4 Point_number]

If only Word 1 exists, the current measurement point is set to invisible.

If Feature_code and String_number exist, then the last point of the previous string with that feature 
code and string number is set to invisible.

If Point_number exists, then the point with that point number is set to invisible.

.110 Start buildings face observations - before the measurements
Word 1 .110 Word 2 [Building_name]

Start recording a field template with the name Building_name. If Building_name is non-blank, then the 
default building face is defined. The feature_code and string_number of the following measurements 
until a Finish code (111) are stored as the building face. There is no limit to the number of points in a 
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building face.

.111 End building face observations
Word 1 .111 Word 2 [Building_name]

If only Word 1 exists, the current building face observation set is finished (including the current 
measurement point).

Notes

1. Arc fitting is applied after the Joins are processed. Hence the new joined strings are created 
and then curve fitting is applied according to the arc codes (start arc, end arc, fit arcs, stop fit-
ting arcs etc.) on any vertex of the string.

For a summary of the Leica Field Codes, go to the section “Summary of Leica Field Codes” 
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Summary of Leica Field Codes
Most of the field codes are entered after the measurement is taken and they will have a (AM) 
after the description. Some of the field codes are entered before the measurement is taken 
(mainly set up codes) and will have a (BM) after the description.

Field Code Description of Record

 .2 Directly entered coordinate measurement
 .3 New instrument setup point (BM)
 .4 Measurement to backsight (BM)
 .5 New target height (BM)
 .6 Check measurement (BM)
 .9 Scale factor for subsequent distances (BM)
.10 Three hair stadia measurement
.11 Measurement to a named station (BM)
.15 Vertical circle correction (BM)
.14 A field code for entering Feature code and String number - BM or AM depends on data 

collector definition
.16 Multiply coded point (AM)
.17 Arc through previous three points (AM of last point of arc)
.18 Circle Feature (AM)
.20 Close string (AM)
.21 Join last points of strings
.22 Join first to last point of strings
.23 Join first points of strings
.28 Add text to the string name (AM)
.29 Note or memo (AM)
.30 Remove height from a point - that is make it a null height (AM)
.37 Rectangle by two points
.38 Make the previous segment non-tinable (AM of end point of segment)
.39 Make the next segment non-tinable (AM of first point of segment)
.40 Make a point non-tinable (AM)
.41 Add additional text (AM)
.42 Add a radial offset (AM)
.43 Add a tangential offset (AM)
.44 Add a height offset (AM)
.45 Make a parallelogram from the last three measurement points (AM)
.46 Make the string a breakline or not 
.47 Start a new string using the same feature code and string number (AM of first point of new 

string).
.48 End a string  - 
.50 Specify the bearing to correct for true north - used as the bearing datum difference
.51 Start using an existing field template (BM)
.52 Finish using a field template or finish recording a field template (AM)
.53 Pause the current field template until a continue op code (54) or a finish template (52)
.54 Continue the current field template (BM)
.55 Start recording a field template (BM)
.56 Skip picking up one or more points from a field template (AM of last point before skipping)
.57 Delete one or more points from a field template (AM)
.58 Insert a point into a field template (BM)
.60 Arc through next three points (AM of first point of arc)
.61 Start of arc through sets of three points until end of string, or a 62 occurs (AM of first point of 

arc)
.62 End the arcs begun by a 61 command (AM of last point of arcs)
.68 Add an integer user defined attribute to the current string (AM of any point of the string)
.69 Add a real user defined attribute to the current string (AM of any point of the string)
.70 Add text user defined attribute to the current string (AM of any point of the string)
.71 Add integer user defined attribute to the current point (AM)
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.72 Add real user defined attribute to the current point (AM)

.73 Add text user defined attribute to the current point (AM)

.74 Add integer user defined attribute to the next segment (AM of first point of the segment)

.75 Add real user defined attribute to the next segment (AM of first point of the segment)

.76 Add text user defined attribute to the next segment (AM of first point of the segment)

.77 Add integer user defined attribute to the previous segment (AM of last point of the segment)

.78 Add real user defined attribute for the previous segment (AM of last point of the segment)

.79 Add text user defined attribute to the previous segment (AM of last point of the segment)

.80 Pipe invert point (bottom of the pipe) (AM)

.81 Pipe axial point (centre of the pipe) (AM)

.82 Pipe obvert point (top of the pipe) (AM)

.83 Start recording a shape - before the measurement

.84 Finish using a shape definition or finish recording a shape - after the measurement

.85 Shape parallel 

.86 Shape extrude 

.92 Remove all z-values for a string (i.e. make all z-values null) (AM of point of the string)

.93  Set the Point-line type

.94 Use name library file/ mapping file for vertex text on the string - name mapping

.95 Circular pipe string with diameter (AM)

.96 Box culvert string with dimensions (AM)

.99 Terminate processing

.107 Make the previous segment invisible - after the measurement

.108 Make the next segment invisible - after the measurement for the first
point of the segment

.109 Make a point invisible - after the measurement

.110 Start buildings face observations - before the measurements

.111 End building face observations

For a full description of the Leica codes, please go to the section “Full Description of Leica Field 
Codes” .

For an example of a raw Leica file, please go to the section  “Example of Leica GSI File” .
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Examples of Leica Screens

Standard Screen
When using a Leica instrument with no code.hex on the 1000 series, or Geobasic program or 
Codelist (.crf file) on the 1100 series, hitting the Code button brings up the standard Leica screen:
 

The information entered in Code goes to Word 1 of the line written to the Leica GSI file.

The information in Info 1 to Info 8 go to Word 2 to Word 9 respectively of the line written to the 
GSI file.

As an example, to enter a directly entered co-ordinate (the 2 field code), 

".2" is entered in the Code field 
X, Y and Z in Info 1, Info 2 and Info 3 respectively.
the feature code (STN) is entered into Info 4
the station name "10" is entered into Info 7
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To enter a feature code and string number to be used for measurements 

the feature code is entered into the Code field 
the string number is entered into Info 1.
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Leica Geobasic Program
A Leica Geobasic program gives the programmer full control over the Leica screen.

WARNING

 Only one Geobasic program can exist on the Leica at any one time. Loading a Geobasic program 
will over write the existing Geobasic program on the instrument. Make sure you have a backup 
copy of the existing Geobasic program on your computer before loading a new one onto the 
instrument.
If you do not have a backup copy of the existing Geobasic program, do not load a new one.

The front screen of the 4D Solutions supplied Geobasic program 
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Leica Codelist
A Leica Codelist (.crf file) controls what is displayed and validated on the Leica screen and what 
values are recorded whenever the Code button is selected. For example, when using the 4D 
Solutions supplied Codelists , a list of defined feature codes and descriptions are displayed.

The Codelist controls what codes are displayed and whenever a code is selected, what 
information is required for that code. The Codelist also specifies what information is written out 
to the GSI file for that code.

After hitting the Code button, the list of codes from the Codelist is displayed in alphanumeric 
order. Because the 12d Model field codes start with a ".", they will appear at the top of the list.

A code can be typed in or the list can be scrolled through using the arrow keys.

The highlighted code is selected by pressing the Leica Enter Key. The menu for the selected code 
then appears. The line of data is written out to the GSI file when the F1 (REC) button is selected.

Scrolling through the 12d Model Codelist

Leica Enter key

The menu after selecting .21 from the 12d Model Codelist
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Setup of Leica 1100 instrument for detail pickup and 
use with 12d

The following relates to the setup of a Leica 1100 series instrument for topographic/detail 
pickup and use with 12d.

Setting up the Instrument

Copying the CRF file
A number of example .crf files are include on the installation CD. These can be found in the 
directory Other_Software\Leica\ . For the purpose of this documentation, we will use the file 
12D_DS.CRF which is designed for detail pickup. This file should be copied from the 12d CD to 
the folder “Code” on the Leica card.

This file contains all of the field codes used in 12d model along with a sample code listing

Set up the display and record masks
Turn on and level instrument

Press F1 to Continue
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Press 5 to configure the instrument

Press 1 for instrument configuration
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 Press 05 for Display and Record mask setup

Display mask:

Press F3 to set up display mask
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Type in the description DETAIL SURVEY for the Mask name

Select the following settings:

1st  Word…….Point Id

2nd Word…….Code

3rd Word…….Info 1

4th Word…….Refl. Ht.

5th Word…….Hz

6th Word…….Horiz. Dist

7th Word…….East

8th Word…….North

9th Word…….Elev

Press F1 
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Record mask:

Press F4 to set up record mask

Type in the description DETAIL SURVEY for the Mask name

Select the following settings:

REC format….GSI16 (16 char)

1st  Word…….Point Id       (11)

2nd Word…….Hz              (21)

3rd Word……..V                (22)

4th Word…….Slope Dist   (31)

5th Word…….Ref. Ht.       (87)

6th Word…….East            (81)

7th Word…….North          (82)
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8th Word…….Elev            (83)

Press F1 

Press F1

Press F1 to exit menu
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Press F1 to exit menu

Leica field codes
It is important to know when the code is entered into the instrument as some codes should 
precede a reading (BM) and some come after (AM). In this manual if a code is related to the 
current string then it is placed before the reading.

Below is a list of the commonly used codes to be used

.2 Directly entered coordinates

.3 New instrument station

.4 Backsight reading (BM)

.5 Height of target (BM)

.6 Check measurement (BM)
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.9 Scale factor (BM)

.11 Foresight station (BM)

.14 Feature code and string number (Use for Leica quick codes only)

.15 Vertical circle correction (d.dddd) (BM)

.16 Additional code for point (AM)

.17 Arc thru last 3 points (AM)

.18 Circle (AM)

.20 Close string  (AM)

.29 Note (AM)

.30 Remove height from point (AM)

.37 Rectangle by two points (AM)

.38 Make last segment non tinable (AM)

.39 Make next segment non tinable (AM)

.40 Make point non tinable (AM)

.42 Add radial offset (AM)

.43 Add tangential offset (AM)

.44 Add height offset (AM)

.45 Create parallelogram from last three points (AM)

.47 Start new string with same code and string no. as previous string (AM)

.48 End string (AM)….Not generally used

Templates

.51 Start template readings (BM)

.52 Finish template readings (AM)

.53 Pause template (AM)

.54 Continue a template (BM)

.55 Start recording template (BM)

.56 Skip points on template (BM)

Arcs

.60 Arc thru next 3 points (AM)…..See also .17

.61 Arc through sets of 3 points until .62 code entered (BM)

.62 End of arc from .61 (AM)

Pipes

.80 Reading taken to invert level of pipe (AM)

.81 Reading taken to centre of pipe (AM)

.82 Reading taken to obvert level of pipe (AM)

.95 Circular pipe diameter (AM)

.96 Box culvert dimensions (AM)
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.92 Remove heights from string (AM)

.107 Make previous segment invisible (AM)

.108 Make next segment invisible (AM)

Setting up files
The existing station coordinates for a pickup can be entered into the Leica by hand or they can be 
uploaded using 12d. The 12d upload sequence will be described here.

Uploading coordinate file
Select option Survey=>Upload=>Create points upload file

 

Copy the upload file
The file upload file should be copied to the folder “GSI” on the Leica card

Data file setup
Turn on and level instrument

Select the 
instrument Leica 
GSI 16

Select the model of 
station points

Type the start and 
end point if 
applicable

Type in the file 
name to create

Select Write file
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Press F1 to Continue

Press 2 to select Data job file. 

This is the file containing the control points if uploaded or if entered during the survey. Keep the 
file name separate from the measured data file name
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Select the file to use followed by the F1 key or press F2 to create a new file

Press F1 to continue 

Measured file setup

Select 1 to set up Measured job file. This is the file that will contain the detail survey readings
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Select F2 to create new file

Type in new job name

Press F1 to continue

Press F1 to continue
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Code list selection
Press 3 to select code list
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Select the code list 12D_DS.CRF

Press F1 to continue

Station setup
We can use Quick set (See the section“Setup using Quick set (QSET)” ) for the station setup or 
manually select the Station

The following notes assume that the data file contains station coordinates

If not the user will have to follow prompts to insert the coordinates

Manual setup
Press F5 for set up
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Press F1 to select station

Type in setup station number
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Type in the instrument height

Press F5 to read the coordinates from the data file
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To view the bearing between the setup station and backsight station select FNC

Press 4 to check orientation

 

Type in the backsight station number

 

The Azimuth is displayed

Type in the reflector height of the backsight
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Sight to the backsight station and press F4 to set the bearing

 

The Bearing is set. Notice that the Azimuth and HZ values are set to the same value.

Press F2 to take a distance to the backsight station
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Arrow down to view the distance error

 

If acceptable press F1 to continue

To save the station information press F3 then F1 to continue
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Take Backsight reading:

Type in the start point number of the survey

Type in the reflector height. This can also be done as part of the backsight measurement as 
shown below.

Select CODE

 

Type in .4 for backsight code followed by the enter key

 



12d Model Reference Manual

Page 3268 March 2003

Type in backsight station number

Type in traverse code and traverse no. string number if using traverse coding. For more 
information about traverse coding see the section “Traverse coding” .

 

Press F1 to record the code

Point to backsight station and press F1 to take and record reading

Scroll down using the arrow keys to show other parameters
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Setup using Quick set (QSET)
IMPORTANT NOTE: If using QSET, you MUST take a check reading to your backsight 
station as described below.

Press F5 for set up

Press F4 for Quick set
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Type in setup station number

Type in the backsight station number
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Type in instrument height

Type in height of target then Press F2 to take reading to backsight to initialise the QSET function.



Appendix G

March 2003 Page 3273

Press F4 to continue

Press F3 to record the station setup information.

IMPORTANT NOTE: If using QSET, you MUST take a check reading to your backsight 
station as described below.
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Take Check reading (Mandatory):

Type in reflector height

Select CODE

Type in .6 for check measurement code followed by the enter key



Appendix G

March 2003 Page 3275

Type in the check station number 

Type in the description

Press F1 to record code
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Type in the reflector height

Select F1 to take reading
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Normal readings
Always change the code prior to starting a new feature and ensure the reflector height is correct

Select Code
Type in the required code and string number

Press F1
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Example of Leica GSI File
The following GSI file has been coded with the Feature Code being recorded after the 
measurement. The Feature code definition is then applied to all subsequent measurements until 
another measurement with a following Feature Code definition is found.

The data collector definition Leica GSI 12D which is shipped with 12d Model, is an appropriate 
data collector definition for converting the example GSI file to a 12d Field File ready for 
processing. 

The data collector definition Leica 12D which is shipped with 12d Model is selected using the 
option Survey=>Setup

For the data collector definition Leica GSI 12D,
the feature code comes after the measurement 
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32
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00

3

Directly entered co-ords for station 10

Instrument set-up on 10 with instrument

         height of 1.715

Next measurement is backsight to 931

Measurement to backsight - 

      has point number 1765

New target height of 1.338

Measurement FC  DHW SN 0 - Pt no 1766

   (the FC and SN is given on the next line)

Set feature code DHW  string number 0

Measurement - FC RDG SN 1

      has point number 1767

Set feature code RDG  string number 1

Measurement - FC RDG SN 1

      has point number 1768

Measurement - FC RDG SN 1

      has point number 1769

Measurement - FC RDG SN 1

      has point number 1770

Close the previous string RDG

410001+000000.2 42....+10000000 43....+10000000 44....+00010000 45....+00000STN 46....+00000000 47....+00000000 48....+00000010 

410002+000000.3 42....+00000010 43....+0001.715 

410003+000000.4 42....+00000931 

110004+00001765 21.324+19135130 22.324+09010170 31..00+00091100 51..1.+0007+000 

410005+000000.5 42....+0001.338 

110006+00001766 21.324+19316250 22.324+08955240 31..00+00074468 51..1.+0007+000 

410007+00000DHW 42....+00000000 

110008+00001767 21.324+21458540 22.324+09150580 31..00+00019501 51..1.+0007+000 

410009+00000RDG 42....+00000001 

110010+00001768 21.324+21820190 22.324+09137140 31..00+00020397 51..1.+0007+000 

110011+00001769 21.324+22104470 22.324+09155360 31..00+00019241 51..1.+0007+000 

110012+00001770 21.324+21747290 22.324+09208580 31..00+00018299 51..1.+0007+000 

410013+00000.20 

Description Leica GSI File in 8 Format using 12d Model Field Coding and
 Giving Feature Codes After a Measurement
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H Geodetics Summary
Various options in 12d Model version 7.0, use geodetic calculations to present and change data. 
These options use terminology that are common to the field of geodetics, which will be defined 
here. 

Most of the terminology adopted follows definitions given in the Australian “GDA Technical 
Manual” which is published by the Intergovernmental Committee on Surveying and Mapping 
(ICSM). This publication is a valuable reference document and the reader is encouraged to obtain 
a copy for a full understanding of the topic. The document can be accessed on the internet at the 
following address http://www.anzlic.org.au/icsm/gdatm/

Please continue to the next section “Shape Of The Earth” .
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Shape Of The Earth
The determination of the Earth’s shape is a science known as Geodesy. Today, it is widely 
accepted that the Earth’s shape best approximates an ellipsoid that has been revolved around 
the Earth’s polar axis. Put another way, the shape is a sphere that has been squashed at the north 
and south poles. The non-spherical shape is due to gravity.

A number of ellipsoids have been calculated to best approximate the Earth’s shape at local 
locations and the earth as a whole. The best fit is concerned with matching the Earth’s 
equipotential gravity field (the Geoid that is best approximated by Mean Sea Level), to a 
geometric ellipsoid shape. As such, there a wide number of definitions.

The most common way of defining an ellipsoid is by describing the semi-major axis value and 
an inverse flattening value (this parameter describes the “squashing” of the ellipse).

Some commonly used ellipsoids are:

Ellipsoid Semi-major axis Inverse flattening

GRS80 6,378,137.0 298.257222101

Diagram from: A guide to coordinate systems in Great Britain. 
See http://www.gps.gov.uk/guidecontents.asp

From GDA 
Technical 
Manual 
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This ellipsoid is used for Australia’s GDA definition (Geocentric Datum of Australia GDA 94) 
used for MGA (Map Grid of Australia) calculations, New Zealand’s NZGD2000 datum as well as 
other geocentric earth model datums around the world.

Ellipsoid Semi-major axis Inverse flattening

ANS 638160 298.25

This was the ellipsoid used to define the Australian Geodetic datum (AGD 84) used for AMG 
(Australian Map Grid) calculations and ISG (Integrated Survey Grid) co-ordinates.

Ellipsoid Semi-major axis Inverse flattening

NZ Geodetic 49 6378399.065 297.0

This was the ellipsoid used to define the NZ 1949 Geodetic datum. The semi-major axis given 
here has been adjusted to compensate for errors in units conversion from links to meters.

Please continue to the next section “Geodetic Coordinates” .
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Geodetic Coordinates
Once an ellipsoid or Geodetic Datum is defined, a position on the earths surface can be 
described in terms of Geodetic coordinates. These coordinates are Longitude, Latitude and 
Ellipsoid height. 

Longitude is a angular quantity measured from the Greenwich meridian. It is most commonly 
described in terms of degrees, minutes, seconds East or west of the Greenwich meridian.

Latitude is a angular quantity measured from the equatorial plane, to the plane defined by the 
point position and the plumb line to the ellipsoid surface. It is most commonly described in 
terms of degrees, minutes, seconds South or North to the equator.

The ellipsoid height, h is the height above the reference ellipsoid.

From GDA 
Technical 
Manual 

From GDA 
Technical 
Manual 
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 Most height datums are not based on ellipsoid height but are based on the geoid.e.g. AHD in 
Australia.

As such, levels from GPS observations (which are ellipsoid heights) need to be corrected to a 
geoidal or orthometric height. To do this, we require the separation or gap distance between the 
two different surfaces. This separation is known as the N value. 

The Ellipsoid height = Geoid height + N value, or

h = H + N

N values can be defined in a geoidal model such as Ausgeoid98 which represents grids of N 
values over all of Australia. For a given Geodetic coordinate, an N value can be interpolated 
from the model and applied to the ellipsoid height to give a geoidal height. Similarly, the N 
value can be used to convert a geoidal height to an ellipsoid height.

Since most geodetic calculations are made on the ellipsoid, the ellipsoid height is required for 
precise calculations.

Please continue to the next section “Projections” .

Earths surface

Geoid

Ellipsoid

A
B

Ellipsoid height, h
Geoid height, H

N value
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Projections
In order to represent ellipsoid data on a flat surface for mapping, it is necessary to use a 
projection. A projection enables points on the earths surface to be mathematically projected onto 
an imaginary developable surface. This surface can then be developed or “rolled flat”. Typically, 
this surface is a cylinder or cone. 

The Transverse Mercator system (TM) projects coordinates onto a cylinder that is tangent to the 
equator and the entire length of a meridian of Longitude.

 

 12d Model version 6.0 and above, allows a number of projections to be specified including, 
Universal Transverse Mercator (UTM), Transverse Mercator (TM) and Rectified Skew 
Orthomorphic (RSO). There are many more available using the General type.

Within 12d Model, a projection can be defined that specifies both the reference ellipsoid and 
projection type. This then can be used for geodetic calculations.

A projection has various parameters that define it. These are specific to the projection and are 
clearly defined for major mapping systems. For example MGA94 zone 56 projection is defined as 
follows:

From GDA 
Technical 
Manual Meridian

of Longitude

Equator
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Please continue to the next section “Terminology” .
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Terminology
The various geodetic options in 12d Model mostly use standard geodetic terminology as 
defined in the Australian GDA technical manual. For clarity, they will be defined again here. 
For some options it is important to note that some terminology used in Australia has quite a 
differing meaning in other countries.

Ellipsoid Distance
The ellipsoid distance is the reduced distance along the surface of the ellipsoid. Standard survey 
measurements are reduced to the horizontal but require a correction due to the height above the 
ellipsoid. This is usually done by a height scale factor which takes into account the ellipsoid 
height at each end of the measured line. i.e. 

Where:

hM = Mean terrain height (mean of the two ellipsoid heights at either end of the measured line)

R = Radius of the earth in the azimuth of the line.

Note: An error of 60 meters in the value of hM will introduce an error of 10 ppm in the reduced 
ellipsoid distance. With the introduction of the Australian Geocentric datums, the N values have 
increased markedly over Australia. So even if a survey is undertaken at sea level (Geoid height 
approximately 0.0), the ellipsoid heights may very well be greater than 60 meters. As The 
Ellipsoid height = Geoid height + N value, N values should be considered when reducing 
measured distances to these datums. 

For older Australian ellipsoids, Mean seal level approximated the surface of the ellipsoid (i.e. N 
value approximately 0.0), so corrections could use geoidal heights to bring the distances down 
onto the reference surface.

The ellipsoid distance can be calculated using the calculated height factor: 

Ellipsoid Distance = Reduced Horizontal Distance x height scale factor.

HeightScaleFactor 1
hM

R hM+
------------------–=
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From GDA 
Technical 
Manual 
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Bearings and Distances - Plane and Grid
If you have a point on an ellipsoid and a Transverse Mercator projection (such as UTM), the 
projection co-ordinates are known as the grid co-ordinates of the point (Easting and Northing).

On an ellipsoid, the straight line joining two points is the Great circle between the two points. If 
each point along the Great circle is projected onto the grid, the path that is traced out is an arc 
between the points.

 That is, the straight lines on an ellipsoid project onto the TM grid as arcs. 

In the diagram below, the Great circle arc through points A and B on the ellipse projects onto the 
arc shown through Points A and B in grid co-ordinates.

So the straight line joining the two points in the plane is different from the projection of the great 
circle (straight line on the ellipse) joining the two points on the ellipse.

A

B

Point A (E1, N1)

Point B (E2, N2)

Projection of the Great Circle between 
A and B onto the UTM Grid.

 

not a straight line in the plane.
It is an arc between A and B and

UTM Projection

UTM grid (Eastings and Northings)
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Plane Bearing, Projection Bearing
If a straight line is drawn in the plane between two points on a grid, the angle between grid 
north and this line in equal to the plane bearing.

In other words, if the two point’s coordinates are known, standard plane trigonometry can be 
used to calculate the bearing of the line.

tan (plane bearing) = (E2 - E1) / (N2 - N1)
Projection bearing and plane bearing is used interchangeably in 12d Model.

Australian Grid Bearing, Ellipsoid Bearing
In Australia, the grid bearing is the angle between grid north and the tangent to arc at a point on 
the arc. e.g Point A. The grid bearing at point A is not equal to the reverse grid bearing from 
point B.

This term is also known as the ellipsoid bearing in some countries.

Warning: In some countries, including New Zealand and the US, the term Grid bearing is used 
for the previously defined term Plane bearing. However, as defined in the Australian GDA 
technical manual, the definition of Grid bearing is different to that of a plane bearing.

To avoid confusion, we will use the term ellipsoid bearing.

Plane Distance
The plane distance is the length in the plane of the straight line joining two points on a grid - that 
is, the standard distance between two points in a plane

plane distance = square root [(E2-E1)*(E2-E1) + (N2-N1)*(N2-N1)]

Australian Grid Distance
On an ellipsoid, the straight line joining two points on the ellipsoid is the Great circle between the 
two points. The straight lines on an ellipsoid project onto the UTM grid as arcs. In the diagram 
below, the arc shown through points A and B is the projection of the Great circle arc through 
points A and B on the ellipse. 

In Australia, the grid distance is the distance on this arc from point A to B.

The difference between the plane distance and the grid distance is usually negligible.

Warning: In some countries, the term grid distance is used for the definition of plane distance 
here.
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Datum
Within the Geodetic sections of 12d Model, the term datum relates to the reference ellipsoid 
adopted by countries/organisations for mapping projects. 

For example AGD is the Australian Geodetic Datum, using the ANS ellipsoid parameters. GDA 
refers to the Geodetic Datum of australia, using the GRS80 ellipsoid as the basis for defining 
geodetic coordinates. 

In New Zealand, the NZGD49 datum refers to the NZ Geodetic 49 ellipsoid. The NZGD2000 
datum is the New Zealand geodetic datum which again refers to the GRS80 ellipsoid.

Zone
The meaning of zone is specific to the UTM projection type which is commonly used around the 
world as a mapping projection. This includes AMG and MGA in Australia.

The Universal Transverse Mercator projection splits the world into 60 zones of 6 degrees of 
longitude. The zone numbering starts at 180 degrees West, longitude. Each zone has a specific 
central meridian and range of longitude that defines it. As such, by supplying a zone number, a 
number of parameters about a projection can be deduced.

For example, Australia is covered by the UTM zones 49 to 56.

Grid North

Point A (E1,N1)

Point B (E2,N2)Plane Bearing

Plane Distance

Great Circle

UTM grid

Ellipsoid Australian Grid distance

Bearing
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Arc-to-Chord Correction (t-T correction)
The arc-to-chord correction is the quantity to be added algebraically to a ellipsoid bearing 
(Australian grid bearing) to obtain a plane bearing. 

Plane Bearing = Ellipsoid Bearing + Arc-To-Chord Correction

Plane Bearing = Australian Grid Bearing + Arc-To-Chord Correction

This correction is only really applicable for lines over 10 km but it is included in calculations for 
completeness. The correction shown in the example below is negative in sign but it can also be 
positive.

Point Scale Factor
The point scale factor is the ratio of an infinitesimal plan distance at a point on a grid to a 
corresponding ellipsoid distance. 

It can be used as an approximation to convert (factor) measured ellipsoid distances to plane 
distances.

Line Scale Factor
The line scale factor is the ratio of the plane distance on a grid to a corresponding ellipsoid 
distance. i.e. 

This factor can be used to calculate either the plane or ellipsoid distance given the Line Scale 
Factor and the other distance. i.e. 

Plane distance = Ellipsoid distance x Line scale factor,

Similarly,

Ellipsoid distance = Plane distance / Line scale factor.

Grid North

Point A

Point BPlane Bearing

Great Circle

UTM grid
Ellipsoid Bearing (Australian Grid Bearing)

Arc-To-Chord
Correction

LineScaleFactor PlanDist·

EllipsoidDist·
------------------------------------=
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Combined Point Scale Factor
The combined point scale factor is the product of the point scale factor and the height scale 
factor. i.e. 

Combined Scale Factor = Point Scale Factor x Height Scale Factor.

Azimuth and Convergence
Azimuth is the horizontal angle measured from an ellipsoidal meridian clockwise from north and the 
great circle between measured points. 

It is also known as the True Azimuth. In general, this value will be calculated internally in   
12d Model.

Convergence or Grid Convergence is the angular quantity to be added algebraically to an Azimuth 
to obtain an ellipsoid bearing (Australian grid bearing). i.e.

Ellipsoid Bearing = Azimuth + Grid Convergence

Australian Grid Bearing = Azimuth + Grid Convergence

Warning: In some countries, the Grid Convergence has the opposite sign.

Combining

Ellipsoid Bearing = Azimuth + Grid Convergence

Australian Grid Bearing = Azimuth + Grid Convergence

and

Plane Bearing = Ellipsoid Bearing + Arc-To-Chord Correction

Grid North

Point A

Point B

Plane

Great Circle

UTM grid

Ellipsoid Bearing

Arc-To-Chord

Longitude meridian

Convergence

Bearing

Azimuth

Correction

(Australian Grid Bearing)

(True Azimuth)
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Plane Bearing = Australian Grid Bearing + Arc-To-Chord Correction

produces the equation

Plane Bearing =  Azimuth + Grid Convergence + Arc-To-Chord Correction

or

Azimuth = Plane Bearing - Grid Convergence - Arc-To-Chord Correction

 True Azimuth = Plane Bearing - Grid Convergence - Arc-To-Chord Correction

Warning: In some countries, the Grid Convergence has the opposite sign.

Please continue to the next section “Converting Between AMG, ISG and MGA” .
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Converting Between AMG, ISG and MGA
In Australia the ellipsoid used to represent the shape of the earth used to be defined by AGD 84 
but it has now has been changed to an ellipsoid that has its centre at the centre of mass of the 
earth (geocentric - GDA 94). See “Shape Of The Earth” .

This is to fit in with GPS because satellites orbits are centred on the centre of mass.

This means that the Latitude and Longitude of every point has changed.

The use of UTM projections (Universal Transverse Mercator - see “Projections” ) and Zones still 
apply but because the latitude and longitude of each point has change, its Easting and Northing 
for a UTM zone has also changed.

AMG 84 Zones are the co-ordinates for the UTM Projections defined for six degree zones using 
the ellipsoid defined by AGD 84.

MGA 94 Zones are the co-ordinates for the UTM Projections defined for six degree zones using 
ellipsoid define by GDA 94.

Note - ISG 84 Zones are the co-ordinates for the TM Projections defined for two degree zones 
using the ellipsoid defined by AGD 84.

For converting between the different datums AGD66/84 and GDA94 (i.e. AMG, ISG, Long Lat  
<-> MGA, Long Lat), use the option

 Survey =>Conversions =>AGD66/84 <-> GDA94 (see “AGD66/84 <---> GDA94”  in

 the chapter “Survey” )

For converting between different AMG Zones (AMG <->AMG) or different MGA Zones (MGA<-
>MGA) use the option

Survey =>Conversions =>Australian conversions see “Australian Conversions” 

AMG 84 co-ordinates (Easting 
and Northing) of a point for a 
given UTM Zone - 6 degree zones

UTM Projection
Latitude and Longitude from 
the Earth model AGD 84

Latitude and Longitude from the 
Geocentric Earth model GDA 94

UTM ProjectionMGA co-ordinates (Easting and 
Northing) of a point for a given 
UTM Zone - 6 degree zones

ISG 84 co-ordinates (Easting and 
Northing) of a point for a given 2 
degree Zone

TM Projection

NTV2 grids or seven 
parameter transformations are 
used to convert between 
different models of the earth
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 in the chapter “Survey” ).

For converting between different ISG/AMG Zones (AMG,ISG <->AMG, ISG)

Survey =>Conversions =>Cartographic see “Cartographic” 

 in the chapter “Survey” ).
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I 12d Ascii File Format
The 12d Ascii file format (called 4D Ascii in Version 4 and earlier) is a text file definition from 
12D Solutions which is used for reading and writing out string data from 12d Model. 12d Ascii 
files normally end in ’.12da’

This document is for the  12d Ascii file format used in 12d Model Version 7.

General Comments about 12d Ascii File
//

Anything after // until the end of the line is ignored. This is used to place comments in the file.

Blank lines

Unless they are part of a text string, blank lines are ignored.

Spaces

Unless enclosed in quotes ("), more than one consecutive space or tab is treated as one space. 
Except when it is the delimiter after a //, an end of line (<enter>) is also considered a space.

Spaces and special characters in text strings

Any text string that includes spaces and any characters other than a to z, A to Z or 0 to 9 
(alphanumeric), must be enclosed in double quotes. In text strings, double quotes " and 
backslash \ must be preceded by a \. For example, \" and \\ define a " and a \ respectively 
in a text string.

Names of models, tins, styles, colours and attributes

Models, tins, styles (linestyles), colours and attributes can include the characters a to z, A to 
Z, 0 to 9 (alphanumeric characters) and space. Leading and trailing spaces are ignored. The 
names can be up to 255 characters in length. If the name includes spaces, the name must be 
enclosed in double quotes ("). 

The names for models, tins, styles, colours or attributes can not be blank.

The names for models, tins, styles and colours can contain upper and lower alpha characters 
which are stored, but the set of model names, tin names, style names, colour names or 
attribute names for an object must be unique when case is ignored. For example, the model name 
"Fred" will be stored as "Fred" but "FRED" is considered to be the same model name as "Fred".

String names

String names can include the characters a to z, A to Z, 0 to 9 (alphanumeric characters), space, 
decimal point (.), plus (+), minus (-), comma (,), open and closed round brackets and equals 
(=). Leading and trailing spaces are ignored. String names can be up to 255 characters in 
length. If the string name includes anything other than alphanumeric characters, then the 
name must be enclosed in double quotes (").

String can contain upper and lower alpha characters which are retained but case is ignored 
when selecting by string name. That is, the string name "Fred" will be stored as "Fred" but 
"FRED" is not considered to be a different name.

String names do not have to be unique and can be blank.

Please continue to the next section “Attributes” .
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Attributes
Many 12d Model objects (such as individual strings, models and tins) can have an unlimited 
number of named attributes of type integer (numbers), real and text. Within an object, the 
attribute names must all be different.

The attributes for an object are given inside the curly braces of the object definition. The 
attributes are preceded by the attributes keyword followed by the named attributes enclosed in 
curly braces { and }.

The format for each named attribute is

attribute_type attribute_name attribute_value

where attribute_type  is integer, real or text
attribute_name is the unique attribute name for the object

and attribute_value is the either a number, a real or a text string.

That is the attributes are defined in a block:

attributes {
  integer att_name number
  real att_name value
  text att_name text
}

The text for a text attribute can be blank an if so, is defined as "".

An example of defining attributes is:

attributes {
  text "pole id" "QMR-37"
  text  street "477 Boundary St"
  real "pole height" 5.25
  integer "pole wires" 3
}

Please continue to the next section “Commands” .
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Commands
Commands consist of a keyword followed by a space and then a value (a keyword and its value 
is often referred to as a keyword pair). A value must always exist.

keyword value // a keyword pair

There can be more than on command keyword pair per line as long as each keyword pair is 
separated by a space. In fact, the keyword can be on one line and the value on the next line. 

Although the names of commands are only shown in lower case in these notes, commands 
are case insensitive and all combinations of case are recognised as the same command. That is 
’model’, ’MODEL’ and ’ModeL’ are all recognised as the command ’model’.

The commands in the 12d Ascii file are:

model model_name // system default   data

All strings following until the next model keyword are placed in the model model_name. This 
can be overridden for a string by a model command inside the string definition.

If the model includes attributes, the following model definition must be used.

model {
  name model_name
 ...
}

All 12d Model models can have an unlimited number of named attributes of type integer 
(numbers), real and text. Within a model, the attribute names must all be different.

The definition for a model with attributes is the model keyword followed by information 
enclosed in curly braces { and }. The keyword name followed by the model_name must be 
included inside the curly braces.

name model_name

The attributes for the model are also specified inside the curly braces of the model definition. 
As described previously, the attributes are preceded by the attribute keyword followed by 
the named attributes enclosed in curly braces { and }.

Hence the model definition with attributes is: 

model {

  name model_name
  attributes {
    attribute_type attribute_name attribute_value
    attribute_type attribute_name attribute_value
     ...
    attribute_type attribute_name attribute_value
  }

}

For example:

model {
name "telegraph poles"

attributes {
text "pole id" "QMR-37"
text "street" "477 Boundary St"
real "pole height" 5.25
integer "pole wires" 3

}
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}

colour colour_name // system default   red

All strings following until the next colour keyword have colour colour_name. This can be 
overridden for a string by a colour command in the string definition.

style style_name // system default   1

All strings following until the next style keyword have style style_name. This can be 
overridden for a string by a style command in the string definition.

breakline point or line // system default   line

All strings following that requires a breakline point-line type until the next breakline 
keyword, have this point-line type. This may be overridden for the string by a breakline in the 
string definition.

null value // system default   -999

All z-values equal to value in strings following until the next null keyword, are considered to 
be null z-values.

string string_type {
      ...
}

The string_type is compulsory and must be followed by all the string information enclosed in 
curly braces { and }.

Thus if a string type or possibly information inside the string is not recognised, the 12d Ascii 
reader has a chance of being able to jump over the string by looking for the end marker }.

Inside the braces are string commands as keyword pairs defining some information for the 
string.

There can be more than one string command keyword pair per line as long as each keyword 
pair is separated by a space. In fact, the keyword can be on one line and the value on the next 
line. 

Any unrecognized string commands are ignored.

The string command keyword pairs include model, colour, style and breakline which are all 
optional inside the string definition. However if any of them exist inside a string definition, 
then the string command keyword overrides any model, colour, style or breakline commands but 
only for that particular string.

For some string types (e.g. 2d, 3d, pipe) there is more data required than just the string 
command keyword pairs.

This extra data is contained is blocks consisting of a keyword followed by the required 
information enclosed in curly braces { and }. For example attributes for all string types and 
(x,y) data for a 2d string.

For all string types, if there is not enough recognised information to define the string, the 
string is ignored.

The definition of each string type and the allowed string commands and extra data for that 
string type will be given after the next section on string attributes.

string attributes
 All 12d Model strings can have an unlimited number of named attributes of type integer 
(numbers), real and text. Within a string, the attribute names must all be different.
The attributes for a string are given inside the curly braces of the string definition. As 
described previously, the attributes are preceded by the attributes keyword followed by the 
named attributes enclosed in curly braces { and }.

Please continue to the next section “12d Ascii Definition for each String Type” .
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12d Ascii Definition for each String Type

2d String
string 2d {
  z value chainage start_chainage
  model model_name name string_name
  colour colour_name style style_name
  breakline point or line
  data { // keyword
    x-value   y-value
      "      "
      "      "
  }
}

3d String
string 3d {
  chainage start_chainage
  model model_name  name string_name
  colour colour_name  style style_name
  breakline point or line
  data { // keyword
    x-value   y-value   z-value
      "      "      "
      "      "      "
  }
}

4d String
string 4d {
  angle value  offset value  raise value
  worldsize value or papersize value or screensize value
  chainage start_chainage
  model model_name  name string_name
  colour colour_name  style style_name
  breakline point or line
  textstyle text  slant degrees   xfactor value
  justify  "top|middle|bottom-left|centre|right"
data {       // keyword
    x-value  y-value   z-value    text       // text can not be blank
      "      "      "     "       // use "" for no text.
      "      "      "     "
  }
}



12d Model Reference Manual

Page 3304 June 200612d Ascii Definition for each String Type

Alignment String
In an alignment string the horizontal and vertical geometry are given separately and both can 
only be efined by the intersection point method (IP’s).

For the horizontal geometry, the (x,y) position of the horizontal intersection points (HIPs) are 
given in the order that they appear in the string, plus the circular radius and left and right spirals 
length on each HIP.

Hence a horizontal intersection point is given by either

x-value     y-value    radius // circular curve, no spirals
or

x-value   y-value   radius   spil1   left-spiral-length   spil2 right-spiral-length 

radius, left-spiral-length, right-spiral-length can be zero (meaning they don't exist).

For the vertical geometry, the (chainage,height) position of the vertical intersection points (VIPs) 
are given in increasing chainage order, plus either the radius of the circular arc or the length of 
the parabolic curve on each VIP. 

Hence for a vertical intersection point is given by either

ch_value    z-value    length  parabola
 or

ch_value    z-value    radius    circle
where

the word parabola is optional. length and radius can be zero, meaning that the parabola or arc 
doesn't exist.

string alignment {
  model model_name  name string_name
  colour colour_name  style style_name
  chainage start_chainage  interval value
  draw_mode value // 1 to draw crosses at HIPs and VIPs, 0 don’t draw 
  spiral_type text
  hipdata { // some hips must exist and precede the VIP data
    x-value    y-value    radius  // or
    x-value    y-value    radius    spil1 left-spiral-length   spil2  right-spiral-length
      "       "       "      "   "             "       "
  }
  vipdata { // vips optional
    ch_value    z-value    parabolic-length // or
    ch_value    z-value    parabolic-length parabola // or
    ch_value    z-value    radius  circle
       "       "       "       "
  }
}
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Arc String
string arc {
  model model_name  name string_name
  colour colour_name  style style_name
  chainage start_chainage  interval value  radius value
  xcentre value  ycentre value  zcentre value
  xstart value  ystart value  zstart value 
  xend value  yend value  zend value 
}

Circle String
string circle {
  model model_name  name string_name
  colour colour_name  style style_name
  chainage start_chainage  interval value  radius value
  zcentre   value  xcentre value  ycentre  value
}

Drainage String
string drainage {

chainage start_chainage
model model_name name string_name
colour colour_name style style_name
breakline point or line
attributes {

  text  Tin  finished_surface_tin
  text  NSTin  natural_surface_tin
  integer  "_floating"  1|0 // 1 for floating, 0 not floating

}
outfall   outfall_value // z-value at the outfall
flow_direction   0|1 // 0 drainage line is defined from downstream

// to upstream

  data { // key word - geometry of the drainage string
    x-value   y-value   z-value   radius   bulge
      "      "      "
      "      "      "
  }
  pit { // pit/manhole - one pit record for each pit/manhole

// in the order along the string
    name text // pit name
    type text // pit type
    road_name text // road name
    road_chainage chainage // road chainage
    diameter value // pit diameter
    floating yes|no // is pit floating or not
    chainage pit_chainage // internal use only
   ip value // internal use only
    ratio value // internal use only
    x x-value // x-value of top of pit
    y y-value // y-value of top of pit
    z z-value // z-value of top of pit

}
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pipe { // one pipe record for each pipe connecting pits/manholes
// in the order they occur along the string

    name text // pipe name
    type text // pipe type
    diameter value // pit diameter
    us_level value // 
    ds_level value // 
    us_hgl value // 
    ds_hgl value // 
    flow_velocity value // 
    flow_volume value // 
  }
  property_control {
    name text // lot name
    colour colour_name
    grade value // grade of pipe in units of "1v in"
    cover value // cover of the of pipe
    diameter value // diameter of the of pipe
    boundary value // boundary trap value
    chainage chainage // internal use only
    ip value // internal use only
    ratio value // internal use only
    x x-value // x value of where pipe connects to sewer
    y y-value // y value of where pipe connects to sewer
    z z-value // internal use only

    data { // key word - geometry of the property control
    x-value   y-value   z-value   radius   bulge
      "      "      "
      "      "      "
  }
  house_connection { // warning - house connections may change in future versions 
    name text // house connection name
    hcb integer // user given integer
    colour colour_name
    grade value // grade of connection in units of "1v in"
    depth value
    diameter value
    side left or right
    length value
    type text // connection type
    material text // material type
    bush text // bush type
    level value
    adopted_level value
    chainage chainage // internal use only
    ip value // internal use only
    ratio value // internal use only
    x x-value // x value of where pipe connects to sewer
    y y-value // y value of where pipe connects to sewer
    z z-value // internal use only
  }

} // end of drainage-sewer data

Face String
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string face {
  model model_name name string_name
  colour colour_name style style_name
  chainage start_chainage    breakline point or line
  hatch_angle value
  hatch_distance value
  hatch_colour colour
  edge_colour colour
  fill_mode 0 or 1
  edge_mode 0 or 1
  data { // keyword
     x-value   y-value   z-value
      "      "      "
  }
}

Feature String
string feature {
  model model_name name string_name
  colour colour_name style style_name
  chainage start_chainage  interval value  radius value
  zcentre   value  xcentre value  ycentre  value
}

Interface String
string interface {
  chainage start_chainage
  model model_name  name string_name
  colour colour_name  style style_name
  breakline point or line
  data { // keyword
    x-value   y-value   z-value mode
      "      "      " " // mode = -1 cut
       "      "      " " //         0 surface
  } //         1 fill
}

Pipe String
string pipe {
  diameter value  chainage start_chainage
  model model_name  name string_name
  colour colour_name  style style_name
  breakline point or line
  data { // keyword
    x-value  y-value  z-value
      "      "      "
      "      "      "
  }
}

Pipeline String
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This is the same as an alignment string except that it has the additional keywords
 diameter, which gives the diameter of the pipeline in world units

and
length of the typical pipe making up the pipeline (used for deflections).

string pipeline {
  model model_name  name string_name
  colour colour_name  style style_name
  diameter  diameter   length  pipe-length
  chainage start_chainage  interval value
  spiral_type value
  hipdata { // some hips must exist and precede vips
    x-value    y-value    radius  // or
    x-value    y-value    radius    spil1 left-spiral-length   spil2  right-spiral-length
      "       "       "      "   "             "       "
  }
  vipdata { // vips optional
    ch-value    z-value    parabolic-length // or
    ch-value    z-value    parabolic-length parabola // or
    ch-value    z-value    radius  circle
       "       "       "       "
  }
}

Polyline String
The definition of a closed string has been refined for polyline and super strings. For other string 
types, closing a string simply meant having the first vertex the same as the last vertex. Hence the 
vertex was duplicated.

For a polyline string, being closed is a property of the string and no extra vertex is needed - the 
first and the last vertices are not the same and the polyline string knows there is an additional 
segment from the last vertex back to the first vertex.

In the 12d ascii format, there is a new closed flag for the polyline string:

 closed true or false

where true can be 1 or T or t or Y or y (or words starting with T, t, Y or y))
and false is 0 or F or  f or N or n (or words starting with F, f, N or n.

string polyline {
chainage start_chainage
model model_name  name string_name
colour colour_name  style style_name
breakline point or line
closed true or false

  
data {  // keyword
    x-value   y-value   z-value   radius   bulge_flag
      "      "      "
      "      "      "
  }
}

Text String
string text {
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x value y value z value
model model_name name string_name colour colour_name
text text_value
angle value offset value raise value
textstyle textstyle_name slant degrees xfactor value

  worldsize value or papersize value or screensize value
justify "top|middle|bottom-left|centre|right"

}
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Super String
Because the super string is so versatile, its 12d Ascii format looks complicated but it is very 
logical and actually quite simple.

In its most primitive form, the super string is simply a set of (x,y) values as in a 2d string, or 
(x,y,z) values as in a 3d string, or (x,y,z,radius,bulge_flag) as for a polyline string or even lines, 
arcs and transition spirals.

Additional blocks of information can extend the definition of the super string. For example, text, 
pipe diameters and visibility.

Some of the properties of the super string extend what were constant properties for the entire 
string in other string types. For example, breakline type for the string extends to tinability of 
vertices and segments. One colour for the string extends to individual colours for each segment.

Other properties such as vertex id’s (point numbers), visibility and culvert data are entirely new.

For user attributes, the super string still has the standard user attributes defined for the entire 
string, but user attributes for each vertex and segment are also supported.

The definition of a closed string has been refined for polyline and super strings. For other string 
types, closing a string simply meant having the first vertex the same as the last vertex. Hence the 
vertex was duplicated.

For a super string, being closed is a property of the string and no extra vertex is needed. That is, 
the first and the last vertices are not the same for a closed super string and the super string 
knows there is an additional segment from the last vertex back to the first vertex.

Hence in the 12d ascii format, there is a closed flag for the super string:

 closed true or false

where true can be 1 or T or t or Y or y (or words starting with T, t, Y or y))
and false is 0 or F or  f or N or n (or words starting with F, f, N or n.

Thus if a string has n vertices, then an open string has n-1 segments joining the vertices and a 
closed string has n segments since there is an additional segment from the last to the first vertex.

With the additional data for vertices and segments in the super string, the data is in vertex or 
segment order. So for a string with n vertices, there must be n bits of vertex data. For segments, if 
the string is open then there only needs to be n-1 bits of segment data but for closed strings, there 
must be n bits of data. For an open string, n bits of segment data can be specified and the nth bit 
will be read in and stored. If the string is then closed, the nth bit of data will be used for the extra 
segment.
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The full 12d Ascii definition of the super string is:

string super {
chainage start_chainage
model model_name name string_name
colour colour_name style style_name
breakline point or line
closed true or false
interval {

chord_arc   value // chord-to-arc tolerance for curves
distance    value // chainage interval to break the geometry up

}

block of info {       
}

block of info {       
}

block of info {       
}

}

The blocks of info can be broken up into four types.

(a) blocks defining the position of the vertices in z, y and z

data_2d or data_3d

Vertices and Segments Forming the Super String

first
second

vertex 3

vertex 4

vertex 5
vertex 6

vertex n-1

vertex n

vertex

first segment
(a straight)

second segment
(an arc)

segment 3
(a straight)

segment 4
(a spiral)

segment 5
(an arc)

segment n-1
(a straight)

vertex

segment n
(only if the string is closed) 
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(b) blocks defining the geometry of the segments

radius_data and major_data or geometry_data

(c) a superseded block defining vertices and segment geometry

data

(d) extra information for the vertices and/or segments

pipe diameters - diameter_value or diameter_data
culvert dimensions - culvert_value or culvert_data
pipe/culvert justification - justify
colour - colour or colour_data
vertex ids (point numbers) at each vertex- point_data
tinability - breakline or vertex_tinability_data and segment_tinability_data
visibility - vertex_visible_data and segment_visible_data
vertex text and annotation - vertex_text_data and vertex_annotation_data
segment text and annotation - segment_text_data and segment_annotation_data
symbols at vertices - symbol_value or symbol_data
vertex attributes - vertex_attribute_data
segment attributes - segment_attribute_data
extrudes
image data
holes

The definition for the blocks of each type now follows.

(a) Blocks Defining the Position of the Vertices

For (x, y) Values with a Constant z
If there is only (x,y) values at each vertex (like a 2d string):

  data_2d { // keyword
             x-value   y-value
               "      "
               "      "
          }
and if there is a non-null constant z for the string

  z value

For (x, y,z) Values
If there is (x,y,z) values at each vertex (like a 3d string):

data_3d { // keyword
    x-value   y-value   z-value
      "      "      "
      "      "      "
  }

(b) Blocks Defining the Geometry of the Segments

Straights and Arcs Only for the Segments
If data_2d or data_3d was used, it is possible to add radius and bulge_flag data:

  radius_data {  // keyword
                 radius for first segment
                 radius for second segment
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                  ...
                      radius for last segment
              }

  major_data {  // keyword
               bulge flag for first segment
               bulge flag for second segment
                    ...
                                 bulge flag for last segment
             }

Straights, Arcs and Transitions for the Segments
If data_2d or data_3d was used, it is possible to specify if the segments are straight, arcs or 
spirals using a geometry_data block.

geometry_data {
segment_info_1 {

information on the first segment
}
segment_info_2 {

information on the second segment
}

" "
" "

segment_info_n-1 { // the last segment if it is open
information on the (n-1) segment

}
segment_info_n { // the last segment if it is closed

information on the n-th segment
}

where the segment_info blocks are from the following:

(a) Straight

No parameters are needed for defining a straight segment. The straight block is simply:

straight { // no parameters are needed for a straight
}

(b) Arc

There are four possibilities for an arc of a given radius placed between two vertices.

We use positive and negative radius, and a flag major which can be set to 1 (on) or off (0) to 
differentiate between the four possibilities.

So the arc block is:

arc {
radius value // radius of the arc (+ve is above the line connecting the vertices)
major 0 or 1 // 0 is the smaller arc, 1 the larger arc).

}

(c) Spiral

There can be a partial spiral between adjacent vertices. The partial spiral is defined by the 
parameters

l1     length of the full spiral up to the start vertex
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r1     radius at the start vertex
a1     angle in decimal degrees of the tangent to the spiral at the start vertex
l2     length of the full spiral up to the end vertex
r2     radius at the end vertex
a2     angle in decimal degrees of the tangent to the spiral at the end vertex

Since a radius can not be zero, a radius of infinity is denoted by zero.

The spiral is said to be a leading spiral if the absolute value of the radius is increasing along 
the direction of the spiral (the spiral will tighten). Otherwise it is a trailing spiral.

If a leading spiral is a full spiral then r1 = 0 and l1 = 0. Similarly if a trailing spiral is a full 
spiral then r2 = 0 and l2 = 0.

For a partial spiral, if the coordinates of the start of the full spiral are needed then they can be 
calculated from l1,r1,a1, l2,r2,a2 and the co-ordinates of the start and end vertices. 

Note that the radii can be positive or negative. If the radii’s are positive then a leading spiral 
will curl to the right (and will be above the line joining the start and end vertices). 

The parameters for the spiral block are:

spiral {
type value // any of the spirals supported in spirals.4d
leading 1 or 0 // 1 denotes a leading spiral, 0 a trailing spiral
l1 value // length of the full spiral at start vertex
r1 value // radius at the start vertex
a1 value // angle in decimal degrees of the tangent to the spiral

// at the start vertex

Arc with major 1 (on)

Arc with major 0 (off) (default)

Arcs with same radius but with major on or off

start
vertex

end
vertex

Arc with major 1 (on)

Arc with major 0 (off) (default)

Arcs with +ve radius

Arcs with -ve radius 

l2 - l1 = the length of spiral
from the start vertex to
the end vertex

start
vertex

end
vertex

partial spiral segment between
the super alignment vertices

Example of a Leading Partial Spiral with Positive Radii
i.e. radius increases along the spiral

start of full spiral
( radius of "infinity"
but will be denoted
as a radius of 0)

l1 = length of the
full spiral before
the start vertex

r1 = radius at
start vertex

r2 = radius at
end vertex

l2 = length of the
full spiral up to
end vertex

a2 = angle of the tangent
to the spiral at end vertex

a1 = angle of the tangent
to the spiral at start vertex
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l2 value // length of the full spiral at end vertex
r2 value // radius at end vertex
a2 value // angle in decimal degrees of the tangent to the spiral

// at the end vertex
}

(c) Block Defining the Vertices and Segments
For compatibility with the polyline, the data block gives the (x,y,z,radius,bulge) values at each 
vertex of the string and so defines both the vertices and the geometry of the segments in the one 
block.

  data {  // keyword
           x-value   y-value   z-value   radius   bulge
             "      "      "
             "      "      "
       }

(d) Other Blocks

Pipe Diameters
There can be one pipe diameter value for the entire super string or the pipe diameter varies for 
each segment of the super string. 

  diameter_value value
or

  diameter_data {  // keyword
                  pipe diameter for first segment
                  pipe diameter for second segment
                     ...
                                        pipe diameter for last segment
                }

Culvert Dimensions
There can be one culvert width and height for the entire super string or the culvert width and 
height vary for each segment of the super string. 

  culvert_value {  width value
                                           height value
                                         }

or

  culvert_data {  properties {width value             // width and height for first segment
                                                           height value
                                                           }
                 properties {width value             // width and height for second segment
                                                            height value
                                                            }

...
                                                                 }
                  properties {width value             // width and height for last segment
                                                            height value
                                                            }
              } 
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Justification for Pipe or Culverts
There can be only one justification for the pipe or culvert for the entire super string.

  justify   justification // "bottom" or "invert"
// "top" or "obvert"
// "centre" (default)

Colour
There can be one colour for the entire super string which is given by the colour command at 
the beginning of the string definitions (before the blocks of information) or the colour varies for 
each segment of the super string and is specified in a colour_data block. 

  colour_data {  // keyword
                colour for first segment
                colour for second segment
                  ...
                                          colour for last segment
              }

Vertex Id’s (Point Numbers)
Each vertex can have a vertex id (point number). This is not the order number of the vertex in the 
string but is a separate id which is usually different for every vertex in every string. The vertex id 
can be alphanumeric.

  point_data {  // keyword
                vertex id or first vertex // alphanumeric
                vertex id for second vertex
                  ...
                                          vertex id for last vertex
             }

Tinability
For a super string, the concept of breakline has been extended to a property called tinable which 
can be set independently for each vertex and each segment of the super string.

If a vertex is tinable, then the vertex is used in triangulations. If the vertex is not tinable, then the 
vertex is ignored when triangulating.

If a segment is tinable, then the segment is used as a side of a triangle during triangulation. This 
may not be possible if there are crossing tinable segments.

  vertex_tinable_data {  // keyword
                         tinable flag for first vertex           //  1  for tinable
                         tinable flag for second vertex  //  0 for not tinable
                             ...
                              tinable flag for last vertex
                      }

  segment_tinable_data {  // keyword
                         tinable flag for first segment           //  1  for tinable
                         tinable flag for second segment              //  0 for not tinable
                          ...
                               tinable flag for last segment
                      }

Note that even if a segment is set to tinable, is can only be used if both its end vertices are also 
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tinable.

Visibility
For a super string, the concept of visibility and invisibility for vertices and segments has been 
introduced.

  vertex_visible_data {  // keyword
                         visibility flag for first vertex           //  1  for visible
                         visibility flag for second vertex              //  0 for invisible
                              ...
                              visibility flag for last vertex
                      }

  segment_visible_data {  // keyword
                         visibility flag for first segment           //  1  for visible
                         visibility flag for second segment              //  0 for invisible
                            ...
                              visibility flag for last segment
                      }

Vertex Text and Vertex Annotation
There can be the same piece of text for every vertex in the super string or a different text for each 
vertex of the super string. How the text is drawn is specified by vertex annotation values. Note 
that in vertex annotations, all vertices must be either worldsize or all vertices papersize. That is, 
worldsize and papersize can not be mixed - the first one found is used for all vertices.

  vertex_text_value      text
or

  vertex_text_data {  // keyword
                  text for first vertex // text string, enclose
                  text for second vertex // by "" if there are any
                    ... // spaces in the text string
                                        text for last vertex
                }

  vertex_annotate_value {  // keyword
 angle value offset value raise value
 textstyle textstyle_name slant degrees xfactor value

worldsize value or papersize value or screensize value
 justify "top|middle|bottom-left|centre|right"

colour colour_name
                }

or

  vertex_annotate_data {  // keyword
     properties { angle value offset value raise value 
              textstyle textstyle slant degrees xfactor value

 worldsize value or papersize value or screensize value
    justify "top|middle|bottom-left|centre|right"

   colour colour_name
                     }
    properties { text properties second vertex
                     }
      properties {    ...   
                     }
       properties { text properties for last vertex
                      }
              }
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 Segment Text and Segment Annotation
There can be the same piece of text for every segment in the super string or a different text for 
each segment of the super string. How the text is drawn is specified by segment annotation 
values. Note that in segment annotations, all segments must be either worldsize or all segments 
papersize. That is, worldsize and papersize can not be mixed - the first one found is used for all 
segments. However, vertex text and segment text do not both have to be papersize or worldsize.

 segment_text_value      text
or

 segment_text_data {  // keyword
                  text for first segment // text string, enclose
                  text for second segment // by "" if there are any
                  ... // spaces in the text string
                                        text for last segment
                }

 segment_annotate_value {  // keyword
 angle value offset value raise value
 textstyle textstyle slant degrees xfactor value

worldsize value or papersize value or screensize value
 justify "top|middle|bottom-left|centre|right"

colour colour_name
                }

or

 segment_annotate_data {  // keyword
    properties { angle value offset value raise value 
              textstyle textstyle slant degrees xfactor value

worldsize value or papersize value or screensize value
    justify "top|middle|bottom-left|centre|right"

   colour colour_name
                     }
    properties { text properties second segment
                     }
      properties {    ...   
                     }
           properties { text properties for last segment
                     }
              }

Symbols
There can be the same symbol (defined as a linestyle) for every vertex in the super string or a 
different symbol for each vertex of the super string. If a symbol does not have a colour, then it 
uses the string colour or the segment colour.

  symbol_value {  // keyword
 style linestyle_name colour colour_name size value
 rotation value                  // in dms

offset value raise value
                }

or

 symbol_data {  // keyword
    properties { style linestyle_name colour colour_name size value
   style linestyle colour colour size value
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 rotation value                  // in dms
offset value raise value

                     }
    properties { symbol and properties for second vertex
                     }
      properties {  ...
                     }
       properties { symbol and properties for last vertex
                     }
              }

Vertex Attributes
Each vertex can have one or more user defined named attributes.

 vertex_attribute_data {  // key word
    attributes { attribute_type attribute_name attribute_value
         attribute_type attribute_name attribute_value
       ...

      attribute_type attribute_name attribute_value
                     }
    attributes { named attributes for second vertex
                     }
      attributes {    ...   
                     }
       attributes { named attributes for last vertex
                     }
              }

Segment Attributes
Each segment can have one or more user defined named attributes.

  segment_attribute_data {  // keyword
     attributes {  attribute_type attribute_name attribute_value
          attribute_type attribute_name attribute_value
       ...

        attribute_type attribute_name attribute_value
                     }
    attributes { named attributes for second segment
                     }
      attributes {    ...   
                     }
       attributes { named attributes for last segment
                     }
              }
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Super Alignment String
In an alignment string, the horizontal and vertical geometry are defined separately and only the 
intersection point method (IP’s) could be used. The IP definition is actually a constructive 
definition and the tangents points and segments between the tangent points (lines, arcs etc.) are 
calculated from the IP definition. For an alignment string, only the IP definitions was included in 
the 12d ascii file, not the calculated segments.

For a super alignment, the horizontal and vertical geometry are also defined separately and with 
construction definitions but the construction definition can be much more complex than just IP’s.

 Unlike the alignment, the super alignment stores both the constructive methods (parts) and the 
resulting vertices and segments (lines, arcs, transitions etc.) that make up the horizontal and 
vertical geometry.

For many applications such as uploading to survey data collectors or machine control devices, 
only the horizontal data and the vertical data are required, not the constructive information.

Note that segments meeting at a common vertex do not have to be tangential although for most 
road applications, they should be.

Vertices and Segments forming the 
Horizontal Data for a Super Alignment

first
second

vertex 3

vertex 4

vertex 5
vertex 6

vertex n-1

vertex n

vertex

first segment
(a straight)

second segment
(an arc)

segment 3
(a straight)

segment 4
(a spiral)

segment 5
(an arc)

segment n-1
(a straight)

vertex

segment n
(only if the string is closed) 
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The full 12d Ascii definition of the super alignment is:

string super_alignment {
//

name string_name
chainage start_chainage
colour colour_name
style style_name
breakline point or line
closed true or false
spiral_type transition_type // currently only "Clothoid"
valid_horizontal true or false
valid_vertical true or false

block of info {       
}

block of info {       
}

block of info {       
}

} // end of super alignment

where the block of info can be one of more of:

attributes, horizontal_parts, horizontal_data, vertical_parts, vertical_data.

The attributes block has been described in the earlier section “Attributes” .

The structure of the blocks horizontal_parts, horizontal_data, vertical_parts and vertical_data will 
now be described in more detail.

Horizontal Geometry
The horizontal geometry is described by two blocks - the horizontal_parts block and the 
horizontal_data block. The horizontal_parts block contains the methods to construct the horizontal 
geometry such as float (fillet) an arc of a certain radius between two given lines or create a 
transition spiral between a line and an arc.

If the horizontal construction methods are consistent, then they can be solved to form a string 
made up of lines, arcs and transitions. The horizontal_data block is simply a list of the vertices and 
segments (lines, arcs etc.) that make up the solved geometry.

If the geometry in the horizontal_parts can be solved and produces a valid horizontal_data block, 
then a flag valid_horizontal is set to true.

valid_horizontal true or false///true if the horizontal geometry can be solved and
// hence create a valid horizontal_data

horizontal_parts {/ / methods for creating the horizontal geometry
....

}

horizontal_data { // the horizontal geometry
....

}

Horizontal_parts
The horizontal_parts block describes the methods used to construct the horizontal geometry of the 
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super alignment. Unless another software package supports all the construction methods 
allowed in 12d Model, this block should be skipped.

The horizontal_parts block is undocumented.

Horizontal_data
The horizontal_data block contains the solved horizontal geometry of the super alignment.

The solved horizontal geometry is made up of a series of (x,y) vertices given in a data_2d block 
followed by a geometry_data block specifying the geometry of the segments between adjacent 
vertices. The segment can be a straight line, an arc or a transition (e.g. spiral).

If the horizontal geometry has n vertices, then there will be (n-1) segments for an open super 
alignment or n segments if the super alignment is closed.

The format of the horizontal_data block is:

horizontal_data {
name ""
chainage value
breakline line or point
colour colour
style linestyle
closed 0 or 1 // 0 if the string is open, 1 if it is closed

interval {
chord_arc   value // chord-to-arc tolerance for curves
distance    value // chainage interval to break the geometry up

}

data_2d {
             x1-value   y1-value // co-ordinates of the first vertex
             x2-value   y2-value // co-ordinates of the second vertex
               "      "
               "      "
             xn-value   yn-value // co-ordinates of the n-th vertex
}

geometry_data {
segment_info_1 {

information on the first segment
}
segment_info_2 {

information on the second segment
}

" "
" "

segment_info_n-1 { // the last segment if it is open
information on the (n-1) segment

}
segment_info_n { // the last segment if it is closed

information on the n-th segment
}

where the segment_info blocks are from the following:

(a) Straight

No parameters are needed for defining a straight segment. The straight block is simply:

straight { // no parameters are needed for a straight
}
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(b) Arc

There are four possibilities for an arc of a given radius placed between two vertices.

We use positive and negative radius, and a flag major which can be set to 1 (on) or off (0) to 
differentiate between the four possibilities.

So the arc block is:

arc {
radius value // radius of the arc (+ve is above the line connecting the vertices)
major 0 or 1 // 0 is the smaller arc, 1 the larger arc).

}

(c) Spiral

There can be a partial spiral between adjacent vertices. The partial spiral is defined by the 
parameters

l1     length of the full spiral up to the start vertex
r1     radius at the start vertex
a1     angle in decimal degrees of the tangent to the spiral at the start vertex
l2     length of the full spiral up to the end vertex
r2     radius at the end vertex
a2     angle in decimal degrees of the tangent to the spiral at the end vertex

Since a radius can not be zero, a radius of infinity is denoted by zero.

The spiral is said to be a leading spiral if the absolute value of the radius is increasing along 
the direction of the spiral (the spiral will tighten). Otherwise it is a trailing spiral.

If a leading spiral is a full spiral then r1 = 0 and l1 = 0. Similarly if a trailing spiral is a full 
spiral then r2 = 0 and l2 = 0.

For a partial spiral, if the coordinates of the start of the full spiral are needed then they can be 
calculated from l1,r1,a1, l2,r2,a2 and the co-ordinates of the start and end vertices. 

Note that the radii can be positive or negative. If the radii’s are positive then a leading spiral 
will curl to the right (and will be above the line joining the start and end vertices). 

Arc with major 1 (on)

Arc with major 0 (off) (default)

Arcs with same radius but with major on or off

start
vertex

end
vertex

Arc with major 1 (on)

Arc with major 0 (off) (default)

Arcs with +ve radius

Arcs with -ve radius 
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The super alignment currently only supports a transition type of clothoid spiral, but in future 
releases more transition types will be supported.

The parameters for the spiral block are:

spiral {
type "clothoid" // only clothoid is currently supported
leading 1 or 0 // 1 denotes a leading spiral, 0 a trailing spiral
l1 value // length of the full spiral at start vertex
r1 value // radius at the start vertex
a1 value // angle in decimal degrees of the tangent to the spiral

// at the start vertex
l2 value // length of the full spiral at end vertex
r2 value // radius at end vertex
a2 value // angle in decimal degrees of the tangent to the spiral

// at the end vertex
}

Vertical Geometry
The vertical geometry is described by two blocks - the vertical_parts block and the vertical_data 
block. The vertical_parts block contains the methods to construct the vertical geometry such as 
float (fit) a parabola of a certain length between two given lines.

If the vertical construction methods are consistent, then they can be solved to form a string made 
up of lines, parabolas and arcs. The vertical_data block is simply a list of the vertices and 
segments (lines, parabolas and arcs) that make up the solved geometry.

If the geometry in the vertical_parts can be solved and produces a valid vertical_data block, then a 
flag valid_vertical is set to true.

valid_vertical true or false///true if the vertical geometry can be solved and
// hence create a valid vertical_data

vertical_parts { // methods for creating the vertical geometry
....

}

vertical_data { // the vertical geometry
....

}

Vertical_parts

l2 - l1 = the length of spiral
from the start vertex to
the end vertex

start
vertex

end
vertex

partial spiral segment between
the super alignment vertices

Example of a Leading Partial Spiral with Positive Radii
i.e. radius increases along the spiral

start of full spiral
( radius of "infinity"
but will be denoted
as a radius of 0)

l1 = length of the
full spiral before
the start vertex

r1 = radius at
start vertex

r2 = radius at
end vertex

l2 = length of the
full spiral up to
end vertex

a2 = angle of the tangent
to the spiral at end vertex

a1 = angle of the tangent
to the spiral at start vertex



Appendix I

June 2006 Page 332512d Ascii Definition for each String Type

The vertical_parts block describes the methods used to construct the vertical geometry of the 
super alignment. Unless another software package supports all the construction methods 
allowed in 12d Model, this block should be skipped.

The vertical_parts block is undocumented.

Vertical_data
The vertical_data block contains the solved vertical geometry of the super alignment.

The solved vertical geometry is made up of a series of (chainage,height) vertices given in a data_2d 
block followed by a geometry_data block specifying the geometry of the segments between 
adjacent vertices. The segment can be a straight line, a parabola or an arc.

If the vertical geometry has n vertices, then there will be (n-1) segments for an open super 
alignment or n segments if the super alignment is closed.

The format of the vertical_data block is:

vertical_data {
name      ""
chainage value
breakline line or point
colour colour
style linestyle
closed 0 or 1 // 0 if the string is open, 1 if it is closed
interval {

chord_arc   value // chord-to-arc tolerance for curves
distance    value // chainage interval to break the geometry up

}

data_2d {
             ch1-value   ht1-value // co-ordinates of the first vertex
             ch2-value   ht2-value // co-ordinates of the second vertex
               "      "
               "      "
             chn-value   htn-value // co-ordinates of the n-th vertex

}

geometry_data {
segment_info_1 {

information on the first segment
}
segment_info_2 {

information on the second segment
}

" "
" "

segment_info_n-1 { // the last segment if it is open
information on the (n-1) segment

}
segment_info_n { // the last segment if it is closed

information on the n-th segment
}

where the segment_info blocks are from the following:

(a) Straight

No parameters are needed for defining a straight segment. The straight block is simply:

straight { // no parameters are needed for a straight
}
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(b) Arc

Since vertical geometry can’t go backwards in chainage value, the majors arcs can not be used 
and hence there are only possibilities for an arc of a given radius placed between two vertices.

We use positive and negative radius to differentiate between the four possibilities.

So the arc block is:

arc {
radius value // radius of the arc (+ve is above the line connecting vertices)
major value // this is ignored since only minor arcs are used

}

(c) Parabola

There can be a parabola between adjacent vertices. The parabola is defined by giving the co-
ordinates of the vertical intersection point for the parabola

chainage chainage of the VIP of the parabola
height height of the VIP of the parabola

The parameters for the parabola block are:

parabola {
chainage value // chainage of the VIP of the parabola
height value // height of the VIP of the parabola
}

Please continue to the next section “12d Ascii Definition for Tins” 

only arc with major 0 (off) is allowe

Arcs with same absolute radius

start
vertex

end
vertex

only the arc with major 0 (off) is allowe

Arc with +ve radius

Arc with -ve radius 

(chainage,height)

start
vertex

end
vertex

Vertical intersection point given by 

Example of a Parabola
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12d Ascii Definition for Tins
Tins (triangulated irregular networks) and Super Tins can be written out and read in from a 12d 
Ascii file.

Tins
tin {

name tin_name // MANDATORY name of the tin when created in 12d Model

time_created text // optional - time tin first created
time_updated text // optional - time tin last modified

 
// Attributes Block:

// This is mainly information used by 12d Model to create the tin.
// The attributes this block and the Attributes block itself are optional.
// When a tin is read into 12d Model from a 12da file, the style is used
// as the Tin style.

attributes {
text "style" text // name of line style for the tin
integer "faces 0/1 // 0 non triangle data, 1 triangle data
real "null_length" value  // values for null by angle/length
real "null_angle" value // angle in radians
real "null_combined_length" value
real "null_combined_angle" value // angle in radians

//                    any other attributes
} // end of attributes block

// Points Block
//
// Co-ordinates of the points at the vertices of the triangles
// The points are implicitly numbered by the order in the list (starting at point 1).
//
// The Points Block is MANDATORY

points { // x y z for each point in the tin
x-value y-value -value // point 1

      "      "      " // point 2
      "      "      "

} // end of points block

// Triangles Block
//
// Each triangle is given as a triplet of the point numbers that make up
// the triangle vertices (the point numbers are the implicit position of the points
// given in the Points Block.
// The order of the triangles is unimportant
//
// The Triangles Block is MANDATORY
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triangles { // points making up each triangle
    T1-1 T1-2 T1-3 // point numbers of the 3 vertices of first triangle.
    T2-1 T2-2 T-33 // point numbers of the 3 vertices of second triangle.
      "      " 
      "      "      "
} // end of triangles block

// Base Colour
// The tin has a base colour that is the default colour for all triangles

colour tin_base_colour // optional - base colour of the tin

// Colours Block
//
// Triangles can be given colours other than the base colour by including
// a "colours" block. The colour for each triangle in then individually given
// (-1 means base colour). The order is the same as the order of the triangles in 
// the Triangles Block.
//
// If all the triangles are the base colour, then simply omit the Colours Block

colours {
    C1 C2 C3 // colour for each triangle given in triangle order
    C4 C5 C6 C7 // colour "-1" means use the base tin colour.
      " " "
      " " "
} // end of colours block

// Input Block
//
// More information about how the tin was created by 12d Model.
// None of this information is needed when reading a tin into 12d Model.
// This block can be omitted

input { // data for reconstructing tin from strings
preserve_strings  true/false // if true, preserve breaklines etc.
remove_bubbles  true/false // 
weed_tin  true/false
triangle_data  true/false
sort_tin true/false
cell_method true/false

models {
"model_name_1" // name of the first model making up the tin
"model_name_2" // name of the second model making up the tin
" " "
" " "

} // end of models block

} // end of input block
} // end of tin ascii definition
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Super Tins
super_tin {

name tin_name // MANDATORY name of the super tin

time_created text // optional - time super tin first created
time_updated text // optional - time super tin last modified

 
// Attributes Block:

// This is mainly information used by 12d Model to create the super tin.
// The attributes in this block and the Attributes block itself are optional.
// When a super tin is read into 12d Model from a 12da file, the style is used
// as the Super Tin style.

attributes {
text "style" text // name of line style for the tin

//                    any other attributes
} // end of attributes block

// Super Tin Colour
// The super tin has a base colour

colour tin_base_colour // optional - base colour of the super tin

// Tins Block
//
// This is the list of tins that make up the super tin.
// This block is MANDATORY

tins { // list of tins for the super tin
"tin_name_1" // name of the first tin making up the super tin
"tin_name_2" // name of the second tin making up the super tin
" " "
" " "

} // end of tins block

} // end of super tin ascii definition

Please continue to the next section “12d Ascii Definition for Plot Frames” .
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12d Ascii Definition for Plot Frames
Plot frames can be written out and read in from a 12d Ascii file.

string plot_frame {
  name frame_name
  title_file filename
  border 0 or 1  
  viewport 0 or 1  
  user_title_file 0 or 1  
  title_1 text
  title_2 text
  plot_file filename
  text_size mm  
  sheet_code text  
  width value  
  height value  
  scale value  
  rotation value  
  xorigin value  
  yorigin value  
  left_margin mm  
  right_margin mm  
  top_margin mm  
  bottom_margin mm  
  plotter text  
  colour colour  
  textstyle textstyle_name 
}
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J Set Ups
Set Up Files

When 12d Model fires up, it looks for special files (called set up files) to define many of its features. 
Hence the set up files can be used to customize 12d Model for a site or a user.

Two set up files, setups.4d and defaults.4d, are only used when creating a new project. After the project is 
created, the information supplied in the two set up files is stored with the project and is then modified from 
within the project.

Similarly the file macros.4d is a file of macros (one per line) that are run when a new project is created.

defaults.4d // define the defaults for a new project
(Defaults panel from the Utilities =>Defaults option).
Once a project is created, the defaults can be modified inside 12d Model.
The defaults are then saved with the project.

For more information go to the section “Defaults” 

setups.4d // define the layout of views on the screen for a new project. Once a project is created, 

the view layout can be modified inside 12d Model. The view layout is then saved
with the project. 

For more information go to the section “Set Ups” 

macros.4d // a file of macros (one per line) that are run when a new project is created.

The other set up files are searched for each time a project is opened and hence can be modified between 
access to the project. The complete list of set up files that 12d Model searches for each time a project is 
opened is:

colours.4d // sets the colour names and red, green, blue mix; also defines the default pens
that the colours map to (as displayed in the panel colours to pens). See 
“Colours” .

digitize.4d // list and defines the digitizers available in 12d Model. See “Digitizer Definitions 
File” .

env.4d // contains values for environment variables See “Environment Variables” .

fonts.4d // defines the fonts used in text styles. See “Textstyles and Fonts” .

gui.4d // define the fonts and colours used in panels and menus, spacing between
items in panels and menus and the maximum pop-up length. See “GUI” .

layout.4d // a screen layout file that is used every time a project is opened. A screen layout 
file can have most menus and panels in it. See “Screen Layout File”  in the 
appendix “Special File Formats” .

linestyl.4d // defines the line styles (linestyles, worldstyles, groupstyles and twoptstyles). 
See “Line Styles” .

names.4d // a special mapping file which is used to fill out information such as colours,
model etc. for given string names.

plotters.4d // defines the plotters that appear in the pop-up for the plotter type panel field. 
See “User Defined Plotters” .

pmf.4d // plotter mapping file for defining mapping of 12d Model colours to pens with
thicknesses, and the rgb for the pens See “Plotter Mapping File” 

sheets.4d // gives sheet sizes and names used in the pop-up for the sheet size panel field. 
See “Sheet Sizes” 
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spirals.4d // defines the transition curves (spirals). See “Spirals” .

survey.4d // lists and defines the data collectors available in 12d Model See “Survey Data 
Collectors” 

symbols.4d // defines the symbols. See “Symbols” 

textstyl.4d // defines the text styles. See “Textstyles and Fonts” .

textstyle_names.4d // defines the textstyle favourites

toolbars.4d // defines the toolbars See “User Defined Toolbars” 

userkeys.4d // defines the action of function keys. See “User Defined Function Keys” 

usermenu.4d // defines the user defined walk-right menus for User on 12d Model menus. See 
“User Defined Menus” .

xtramenu.4d // defines the 12D Solutions defined walk-right menus for User on 12d Model 
menus. See “User Defined Menus” .

When 12d Model creates a new project, or changes to another project, it searches for set up files in a 
number of set folders. For each file, these folders are searched in a specific order until the file is found. 
Consequently the set up files do not all have to be in the same folder.

This greatly increase the tailorability of 12d Model.

For set up files, the folders searched and their search order will now be described in the next section 
“Folders Searched for Set Up Files” .
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Folders Searched for Set Up Files

Set_Ups

When 12d Model V7.0 is installed on a computer, it is placed in a folder called 7.00 in the folder 
12d\12dmodel.

The 12d Model installation creates a number of specific folders such as the operating system-cpu specific 
folder (for example nt.x86 for Windows NT on Intel chips), and areas for set up files: namely an o/s-cpu 
specific set_ups under the o/s-specific folder and a set_ups under 7.00.

User

Although users can place their site specific set up files in the set_ups folders, it is not recommend since 
they may be overwritten during future 12d Model installations.

To overcome this problem, there is a special folder (reserved for customers) called user which is searched 
before set_ups for any set up files. Consequently any site specific set up files should be placed in user and 
they will be used in preference to the files in set_ups (user may contain o/s-cpu specific folders). By 
default, user is under 7.00.

When a new 12d  Model version is issued (e.g. V7.0), user can then be copied over to the new installation 
area.

There is also an environment variable which can be set to point to another user defined folder which will 
be searched for set up files before the default user is searched.

USER_4D folder // users own folder for set up info

Note - both user and the folder pointed to by USER_4D can exist.

Current and Home

The folder that a project is in (the current folder) and the users home folder are also searched for set up 
files.

12dmodel other 4D
products

12D Solutions
folder

products folder

version folders

cpu dir set_ups

set_ups

user user_lib

12D supplied folders

7.00

library

12d Model

12d

5.00
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Searching Order for Set Up Files
When 12d Model creates a new project, or changes to another project, it searches for set up files in a 
number of set folders. For each file, these folders are searched in a specific order until the file is found. 
Consequently the set up files do not all have to be in the same folder.

The folder search order for the set up files is

0. the appropriate environment variable defining where the file is

1. the projects current folder

2. the users home folder

3. specific cpu folder in USER_4D e.g. nt.x86 for Intel

4. USER_4D

5. specific cpu folder in user

6. user

7. SET_UPS_4D

8. set_ups folder under the specific cpu folder in 7.00

9. set_ups folder under 7.00

Notes

(a) When an existing project is opened by 12d Model, the set up files setups.4d and defaults.4d are not 
used.

(b) The file, eagleplt.emf, is not pointed to by an environment variable but is searched for.

12dmodel other 12D
products

12D Solutions
folder

product folders

version folders

cpu dir
set_ups

set_ups

user user_lib

user supplied folders

6

7

8

1
current

2
home USER_4D

User folders

12D Solutions supplied folders

4

3
cpu dir

5
cpu dir

7.00

library

12d

12d  Model
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Writing Set Up Files
Most of the set up files can be created and edited totally within 12d Model using panels such as 
Defaults which is accessed via the Utilities =>Defaults option.

When the Write button is selected on the panels, a Write Setup File panel comes up to specify 
where the file is to be written out to.

The choices on the panel allow the file to be written out to:

Found folder - the folder where the file currently being used by 12d Model resides. This will be 
unavailable (greyed out) if the user doesn’t have access to the folder.

Current folder - the folder where the project currently being used by 12d Model resides. This will be 
unavailable (greyed out) if the user doesn’t have access to the folder.

User folder - the User folder. This will be unavailable (greyed out) if the user doesn’t have access to the 
folder.

Other folder - any folder can be selected.

If you are having problems writing to the file, click on the Properties button to bring up the Properties 
panel for the selected file (if it exists) and check the Security for the file.
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Library, User Library
Apart from set up files which are only accessed when a project is opened or first created, there are two 
special library areas, one supplied by 12D Solutions Pty Ltd and the other for the user, which are searched 
for files with the appropriate file ending whenever the folder icon at the end of a panel file field is selected.

For example, clicking on the folder icon for a plot parameter file panel field would display a list of files 
ending in .ppf.

Library
The first library is the folder pointed to by the environment variable 

LIB_4D

or if that doesn’t exist, in a folder called library directly under 7.00.

 The files in library are listed under the [Lib] walk right of pop-ups.

Although users can place their files in the library folder, it is not recommend since they may be 
overwritten during future 12d Model installations.

Consequently there is a special user library folder called user_lib where user specific files should be 
placed.

User Library
The second library, the user library, is also a folder and is pointed to by the environment variable

USER_LIB_4D

or if that doesn’t exist, in a folder called user_lib directly under 7.00.

The files from the user library are listed under the [User Lib] walk right of the pop-up.

Note
1. The list of special endings for files is given in the Appendix, Special File Formats.

2. A full list of environment variables is given in the later section “Environment Variables” .
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Environment Variables
When 12d Model is invoked for a new or existing project, it uses environment variables to tailor the 
system.

In Windows, environment variables can be set for each User from the Control Panel, but a much easier 
method to set the environment variables used by 12d Model is to include them in a special file which is 
read in each time a project (new or existing) is opened by 12d Model.

The environment variables that 12d Model recognises can be broken into two types - one type where the 
environment variable is only a flag setting a mode, and a second type which point to a file, program or 
folder. For the environment variables of the second type, a default file/program is often searched for if the 
environment variable is not defined.

The folder search order for the default files for the type group of environment variables is given in the 
previous sections.

The list of environment variables will just be given in alphabetical order but it will be obvious from the 
documentation which type the environment variable is.

For environment variables that simply set a flag or value is (the default value is shown in bold) the 
documentation will be:

Variable Name Value Description Default

For environment variables that point to a file, program or folder, and their associated default files/
programs, the documentation will be:

Environment Variable Name Type Default

Alphabetical Environmental Variables List
AUTHORIZATION_4D full path name HOME_4D\nodes.4d

The authorization file is normally called nodes.4d, and is under the folder 12d model. However, the file 
name and path can be set by the user with the environment variable. The full path-name of the file is given.

The default is HOME_4D\nodes.4d.

AUTO_DELETE_WALKRIGHTS_4D 0 Use old method from V3.1 32

pixels Distance in pixels to move 
past the end of the last menu
before the cascade collapses

If non zero, the environment variable AUTO_DELETE_WALKRIGHTS_4D sets the distance in pixels 
that is used to collapse the cascade of walk-right menus when the cursor moves that distance past the end 
of the last walk-right menu.

The default value is 32.

AUTO_RESET_SELECT_4D 0 Don’t use auto-reset reselect

1 Use auto-reset reselect default 1

The reset mechanism for picking has ben modified for V5.0 and above. Reset is now done automatically if 
the cursor is moved a user specified distance (given by AUTO_RESET_TOLERANCE_4D) after a pick 
(without accepting), and a separate user specified distance (given by 
AUTO_RESET_DRAG_TOLERANCE_4D) after a directional pick (without accepting).

The default value is 1.

 AUTO_RESET_DRAG_TOLERANCE_4Dvalue Reset distance for default 50
directional picks
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If auto-reselect is set on (see AUTO_RESET_SELECT_4D) then this is the distance in pixels to move the 
cursor to reset the picking rejection list for a directional pick.

The default value is 50.

 AUTO_RESET_TOLERANCE_4D value Reset distance for 
non-directional picks default 5

If auto-reselect is set on (see AUTO_RESET_SELECT_4D) then this is the distance in pixels to move the 
cursor to reset the picking rejection list for a non-directional pick.

The default value is 5.

 BISECTORS_4D 0 Don’t use bisector section default 0
use two sections instead.

1 Use bisector section

When applying templates to a horizontal intersection point with a sharp change of direction, (that is, it is 
not and end point and the HIP has no curve on it and there is a change of direction at the HIP), either two 
sections can be applied at the HIP point (applied perpendicular to the line on either side of the HIP point) 
or just a single bisector section applied to the bisector of the change of angle through the HIP.

The default value is 0.

CIVILCAD_PATH_4D folder no default

the full path-name of the folder for CivilCAD files.

There is no default.

COLOURS_4D filename default colours.4d

file of colour rgb definitions and names. See “Colours” .

The default is colours.4d.

CUBED_CHARACTER_4D integer (base 10) default 179

The integer (base 10) value of the character to use as the cubed symbol.

DATA_COLLECTOR_4D data collect name

the data collector that is used if no data collector is set for a project.

There is no default.

DATA_COLLECTORS_4D filename default survey.4d

file of definitions of available data collectors

The default is survey.4d.

DATA_TIPS_4D 0 Don’t show data tips default 0
1 Show data tips

When set, data tips are displayed when the cursor moves over point in a plan view.

The default value is 0.

DEFAULTS_4D filename default defaults.4d

file of defaults - only used for new project

The default is defaults.4d. See “Defaults” .

DEFAULT_PLAN_SCALE_4D value Value is the scale (1:value) for new plan views

If a value is given, then it is used the default scale for any new plan view created in a project. Note that the 
scale is only used for displaying text defined in paper units in the plan view.

DEFAULT_VIEW_COLOUR_4D colour_number default 0
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The default background colour for views.

DEFAULT_TABLE_WIDTH_4D number_of_characters default 32

Gives the number of characters displayed in tables such as decisionals and mtf editor.

The default value is 32.

DEGREES_CHARACTER_4D integer (base 10) default 176

The integer (base 10) value of the character to use as the degrees symbol.

DIAMETER_LARGE_CHARACTER_4D integer (base 10) default 216

The integer (base 10) value of the character to use as the large diameter symbol.

DIAMETER_SMALL_CHARACTER_4D integer (base 10) default 248

The integer (base 10) value of the character to use as the small diameter symbol.

DIGITIZERS_4D filename default digitize.4d

file of digitizer definitions

The default is digitize.4d. See “Digitizer Definitions File” .

DISABLE_MTF_WARNINGS_4D 0 Display the mtf warnings in the text editor default 0
1 Write mtf warnings to the background window

Controls whether the mtf warnings go to a file or to the output window.

The default value is 0.

DONGLE_4D parameters

used for network dongles. See the separate notes on installing a network dongle for more details.

DOUBLE_CONFIRM_DELETE_4D 0 Confirm deletes/cleans without undos once
1 Confirm deletes/cleans without undos twice. default 1

Controls whether or not the user is asked once or twice to confirm that deletes and cleans that do not have 
undos are to be done.

The default value is 1.

DRAINAGE_4D filename default drainage.4d

file of definitions for drainage option

The default is drainage.4d.

DRAINAGE_PPF_4D full path name of .ppf file no default

Points to the file used as the default plot parameter file (.ppf) for the panel New Plot Drainage Network.

The path name to the .ppf file can contain $LIB which expands out to the path of the library area. For 
example, "$LIB/drainage.ppf" points to the file drainage.ppf in the area defined by $LIB_4D.

DRAINAGE_FLOW_DIR_4D 0 Flow direction is in descending chainage default 0
1 Flow direction is in ascending chainage

Defines the default flow direction used in the creating a drainage string.

The environment variable DRAINAGE_FLOW_DIR_4D specified whether the default flow direction that 
appears in the Create Drainage String panel is that the flow direction in the line is in ascending chainage 
(that is, the flow is in the same direction as the direction of the drainage string) or that the flow direction in 
the drainage line is in descending chainage (that is, the flow is in the opposite direction to the direction of 
the drainage string).

The default value is 0.
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EDITOR_4D script/program 7.00\cpu_area\te

the script or program that is fired up when a report is created. It usually points to an editor.

If the parameter display reports in the panel sys default settings (given by the menu option Utilities => 
Default=>Sys defaults) is set to yes, the editor displays each report as it is created.

The default is ’7.00\cpu_area\te’.

ENVIRONMENT_4D full path name of file default env.4d

It is possible to set all the environment variables from a file normally called env.4d. The environment 
variable file is searched for in the standard set up areas (local, USER_4D, user, set_ups) or is set by the 
environment variable ENVIRONMENT_4D.

The default is env.4d.

The format of the environment variable file is given in the section “Setting Environment Variables” .

EXTRA_OPTIONS_4D file default xtramenu.4d

Xtra menu definition

The default is xtramenu.4d. See “User Defined Menus” 

FAST_ACCEPT_4D 0 don’t use fast accept default 0
1 use fast accept

Used for picking items - if fast accept is turned on (1), then when an item is picked and there is only one 
item in the selection list, that item is automatically selected without a MB being needed.

The default value is 0.

FONTS_4D filename default fonts.4d

font definitions

The default is fonts.4d. See “Textstyles and Fonts” 

FUNCTION_KEYS_4D filename default userkeys.4d

function key definitions

The default is userkeys.4d. See “User Defined Function Keys” 

GENIO_WILDCARD_4D text default "*.mos"

Sets the ending of the files selected for the pop-up list for the File field in the Read Genio Data panel.

The default value is "*.mos".

GUI_4D Standard default Standard
Non Standard

Defines the mouse button usage within 12d Model.

The default value is Standard.

GUI_COLOURS_4D filename default gui.4d

file of colour definitions used in the GUI

The default is gui.4d. See “GUI” 

HARDWARE_ARCS_4D 1 Use hardware arcs default 1
0 Hardware arcs are not used

The default value is 1.

HEIGHT_MAX_DEFAULT_4D integer

set the default value to use in Plan Settings panels that have a Height max (w) field.
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The default value is 0.

HELP_4D folder default 7.00\help

folder containing the 12d Model help files.

The default is ’7.00\help’.

HELP_BUTTONS_4D 0 Disable help buttons on panels default 0
1 Enable help buttons on panels.

The default value is 0.

HIMETRIC_4D 0 Printer resolution of 0.04 mm - for Win 95,98,ME
default 0

1 Printer resolution of 0.01 mm - for Win NT, 2000, XP

For Windows 95, 98 and ME, the printer resolution can only be 0.04 mm when covering an A0 sheet.

Under Windows NT, 2000 and XP, no such restriction exists and the full resolution of 0.01 mm can be used 
so the environment variable HIMETRIC_4D allows access to the higher resolution for Windows NT, 2000 
and XP.

The default value is 0.

See also WINDOWS_PRINTERS_4D for enabling access to Windows printers.

HOME_4D folder three folder levels up
 from where 12d.exe is

12d Model home folder

LIB_4D folder HOME_4D\7.00\library

12D Solutions library folder for input files such as mapping, template and macros (4DML’s).

The default is ’HOME_4D\7.00\library’.

LINESTYLES_4D filename default linestyl.4d

file of linestyle definitions

The default is linestyl.4d. See “Line Styles” 

LIST_POPUPS_4D 1 Pop-up lists as scrolling lists default 1
0 Pop-up lists as menus as in versions up to V3.2

Defines the look of pop-up lists.

The default value is 1.

LOOK3D_4D 1 3D look and greenish background default 1
0 Original 12d  gui colours

The default value is 1.

LOG_DIR_4D folder-path-name default is local folder

An error log file is created each time 12d Model is invoked. The error log name automatically created by 
12d Model and has the form:

log?????.4de

 where ????? is a hashed number using your login name, process id & the current time.

The folder that the error log file is created in is given by the environment variable LOG_DIR_4D. The full 
path-name of the folder is given.

If LOG_DIR_4D is not used, 12d Model tries to create the log file in the current folder, the HOME folder, 
the TMP folder and the TEMP folder.

If creating an error log file fails in all these ares, 12d Model does not create an error log file.
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LONG_SECTION_PPF_4D path name to .ppf file no default

This environment points to the file used as the default plot parameter file (.ppf) for the panel section long 
plot.

The path name to the .ppf file can contain $LIB which expands out to the path of the library area. For 
example, "$LIB/long.ppf" points to the file long.ppf in the area defined by $LIB_4D.

MACRO_INPUT_MODE_4D 0 Don’t put current value into the console default 0
1 Put current value into console.

Controls whether or not the value passed down in the variable to receive the answer for any macro prompt, 
is actually placed into the console panel as the default answer so that it can be accepted by just typing 
<enter> into the console panel.

The default value is 0.

MIDDLE_DOT_CHARACTER_4D integer (base 10) default 183

The integer (base 10) value of the character to use as the squared symbol.

MODEL_FOR_TIN_PREFIX_4D "pre*pos" default is "tin "

This environment variable is used to customize the default model for the tin in the panels for creating 
triangulations. Text can be defined for prepending and/or appending to tin name to create a default model 
name from the tin name.

The text for prefixing and postfixing is given in a special form: "pre-text*post-text"

If pretext only, just give the text. If post text is required, precede it by a *.

If the environment variable is not set, the default "tin " is used.

MODEL_VIEW_WALKRIGHTS_4D 0 Use data source in options default 0
1 Walk-rights for model/view as in up to 

V3.2

Defines whether the Data source field is used instead of model/view walk-rights used in V3.2.

The default value is 0.

MOVIE_4D executable default xanim

X-Windows only - program for running perspective movie

MS_SEEDFILES_4D folder no default

folder of Microstation seed files

MTF_TMP_4D anything not defined

If defined, then the temporary files for mtf calculations go to the Windows temp folder. This is to get over 
a bug in Novell under Windows 95.

NAME_MAPPINGS_4D filename default names.4d

A mapping file can be specified which is used to fill out information such as colour, model etc. for given 
string names.

The mapping works in two ways. After typing part or all of a string name,

(a) if <enter> is entered, the map file is searched for a match in the first column.
If a match is found, the name, colour, model, style etc. from the other columns in the mapping file are 
used to fill out the panel fields.

(b) if a <tab> is entered, the second column is searched for a list of completions (if a * is found, the first 
column is used for that check) which are displayed in a pop-up. When an entry is selected from the 
completion list, the name, colour, model, style etc. from the columns in the mapping file are used to 
fill out the panel fields.
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NEVER_SNAP_ITSELF_4D 1 Try to stop a string snapping to itself during editing
default

0 Let a string snap to itself - behaviour in V3.2

Tries to stop a string snapping to itself during editing.

The default value is 1.

NEW_DRAINAGE_PPF_4D full path name of binary ppf file no default

Points to the file used as the default binary plot parameter file (.drainppf) for the long section plot 
produced by the panel Drainage Plot PPF Editor.

The path name to the binary ppf file can contain $LIB which expands out to the path of the library area. 
For example, "$LIB/drainage_long.drainppf" points to the file drainage_long.drainppf in the area defined 
by $LIB_4D.

NEW_DRAINAGE_MELB_PPF_4D full path name of binary ppf file no default

Points to the file used as the default binary plot parameter file (.melbppf) for the long section plot produced 
by the panel Sewer Plot Melbourne Water PPF Editor.

The path name to the binary ppf file can contain $LIB which expands out to the path of the library area. 
For example, "$LIB/melb_water.melbppf" points to the file melb_water.melbppf in the area defined by 
$LIB_4D.

NEW_DRAINAGE_PLAN_PPF_4D full path name of binary ppf file no default

Points to the file used as the default binary parameter file (.drainplanppf) for the plan annotation produced 
by the panel Drainage Plan Plot PPF Editor.

The path name to the binary ppf file can contain $LIB which expands out to the path of the library area. 
For example, "$LIB/drainage_plan.drainplanppf" points to the file drainage_plan.drainplanppf in the area 
defined by $LIB_4D.

NEW_LONG_SECTION_PPF_4D full path name of binary ppf file no default

Points to the file used as the default binary plot parameter file (.lplotppf) for the long section plot produced 
by the panel Section Long Plot PPF Editor.

The path name to the binary ppf file can contain $LIB which expands out to the path of the library area. 
For example, "$LIB/long_section.lplotppf" points to the file long_section.lplotppf in the area defined by 
$LIB_4D.

NEW_PLOT_FRAME_PPF_4D full path name of binary ppf file no default

Points to the file used as the default binary parameter file (.plotframeppf) for the plan plot produced by the 
panel Plot Frame PPF Editor.

The path name to the binary ppf file can contain $LIB which expands out to the path of the library area. 
For example, "$LIB/plot_frame.plotframeppf" points to the file plot_frame.plotframeppf in the area 
defined by $LIB_4D.

NEW_X_SECTION_PPF_4D full path name of binary ppf file no default

Points to the file used as the default binary plot parameter file (.xplotppf) for the cross section plots 
produced by the panel Section X Plot PPF Editor.

The path name to the binary ppf file can contain $LIB which expands out to the path of the library area. 
For example, "$LIB/cross_section.xplotppf" points to the file cross_section.xplotppf in the area defined by 
$LIB_4D.

PAN_MODE_4D 0 Use pan for pan, pans default 0
on views

1 Use pan deltas for pan, pans
on views

Sets whether pan or pan delta is used for the pan and pans buttons on views.
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The default value is 0.

PLAN_TABLE_SETTINGS_4D 0 Don’t allow setting by model default 0
1          Allow setting by model

Trial only - allow the drawing of z-values, vertices etc. on the plan view to be set by individual models 
rather than for all models on the view.

The default value is 0.

PLOTTER_4D script/program no default

This environment variable points to a script/program which can be fired up whenever a plot is generated. 
The name of the plot is given as the first script parameter of the script.

If the parameter Send plots on the ’System Settings’ tab of the menu option Utilities => Defaults is set to 
yes, the plotter script is run as each plot is created.

If more than one plot is created by an option (e.g. x plot) then the script is called separately for each of the 
plots.

An example of a script to send the plot to port lpt1 for Windows NT would be

@echo off
copy %1 lpt1

An example for Windows NT which looks for hp files is

@echo off

echo.
echo ----------------------------------------------------

:next_file

if "%1" == "" goto done

echo %1 | find /I ".hp" > nul
if ERRORLEVEL 0 if not ERRORLEVEL 1 goto hp_plotter

echo Plotting file %1
shift
goto next_file

:hp_plotter

echo Plotting %1 to HP plotter
shift
goto next_file

:done
echo ----------------------------------------------------

PLOTTER_MAPPING_4D filename default pmf.4d

This points to the file which is used as the default plotter mapping file. The format for the plotter mapping 
file is described in the section “Mapping Colours to Plotter Pens”  in the Appendix “Set Ups” .

The default is pmf.4d.

PLOTTERS_4D filename default plotters.4d

This points to the file which contains user defined plotters. The format for the file of user defined plotters 
is described in the section “User Defined Plotters” in the Appendix “Set Ups” .

The default is plotters.4d.

PLOT_SYMBOLS_4D filename default plotsymb.4d

Points to the file used to define the symbols used in long and cross section plots.

The default is plotsymb.4d.

POLYPOLYLINES_4D 0 Don’t use speed ups default 0
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1 Intermediate speed ups
2 Faster speed ups.

A few experimental techniques are available for speeding up the drawing on the screen.

For some specific things such as fast contours, fast mesh and point crosses, the techniques can result in 
some redraws being up to three times faster. 

The default value is 2.

PRINTER_4D script/program no default

Points to a script or program which can be fired up whenever a report is generated. The name of the report 
is given as the first parameter of the script.

If the parameter Print reports on the ’System Settings’ tab on the menu option Utilities => Defaults is set to 
yes, the printer script is run as each report is created.

PROJECT_NAMES_4D 0 Use long filenames for internal files default 0
as used by all versions up to and
including V3.0

1 Use short names

The use of long or short extension names for internal 12d Model files for items such as models, tins, 
templates etc. is controlled by the environment variable PROJECT_NAMES_4D.

Opening a new project with the short name format, project-name.4dp, will automatically create a short 
name project (i.e. a project using the short extension names).

The default value is 0.

RECENT_PROJECTS_4D positive integer default 20

The maximum number of accessed projects displayed when 12d Model starts up.

REPORT_HEADER_4D 0 Report files have no header page
1 Some header information is used

 2 A full header page is produced. default 2

Controls the amount of header information in reports.

For the cases 1 and 2, the header information includes

(a) the 12d Model Project

(b) the name of the user

(c) the organization

(d) the current date

(e) the current report file name

The default value is 2.

RUN_MACROS_FILE_4D filename default macros.4d

file of macros (one per line) that are run when a new project is created - only for new projects

The default is macros.4d

SETUPS_FILE_4D filename default setups.4d

file setting up the initial screen layout for new projects

The default is setups.4d. See “Set Ups” .

SET_UPS_4D folder HOME_4D\7.00\set_ups 

folder for storing the standard set up files installed by 12D Solutions.

The default is ’HOME_4D\7.00\set_ups’.
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SEWER_PPF_4D path name to .ppf file no default

points to the file used as the default plot parameter file (.ppf) for the panel new plot sewer network.

SHEET_SIZES_4D filename default sheets.4d

For plot frames, long and x plots, the overall size of the plot sheet can be given by a pop-up containing 
defined sheet size.

The sheet size name and width and heights can be specified by the user in a file named sheets.4d which is 
in the normal set up areas, or is pointed to by the environment variable SHEET_SIZES_4D.

The default is sheets.4d. See “Sheet Sizes” .

SHOW_PATHS_4D anything

If defined, then when 12d Model fires up the actual file names defined by any environment variables are 
written to the output window. This is useful for debugging.

SHOW_TITLE_VARIABLES_4D 0 Any $variable not used is left as blank
1 Any " not used is shown as $variable
2 All " are plotted with no substitution

For debugging the title block file.

The default value is 0.

SPIRALS_4D filename default spirals.4d
file of spiral definitions

The default is spirals.4d. See “Spirals” .

SQUARED_CHARACTER_4D integer (base 10) default 178

The integer (base 10) value of the character to use as the squared symbol.

STATION_PREFIX_4D
There is no default.

The default prefix to use in the Survey Data Setup panel or to use if prefix has been set for the project.

There is no default value.

SUPER_STRING_4D 1 Use the super string default 1
0 Don’t use the super string.

Controls whether the super string is accessible or not.

The default value is 1.

SYMBOLS_4D filename default symbols.4d

Points to the file used to define the symbols used for super strings.

The default is symbols.4d.

SYSTEM_NAMES_4D 1 Only use the old longer names
2 Only use the 8.3 file names 
3 Use short names first, default 3

then look for a long name.

From 12d Model V3.1 onwards, the default names for all set up files fit in with the DOS 8.3 format. For 
compatibility, it is possible to use both the old longer names and the new short file names.

The default value is 3.

TEXTSTYLE_MAPPINGS_4D filename default textstyle_names.4d

file of textstyles favourites definitions

The default is textstyle_names.4d
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TEXTSTYLES_4D filename default textstyl.4d

file of textstyles definitions

The default is textstyl.4d. See “Textstyles and Fonts” .

TICK_DRAW_CROSS_4D 0 Nothing for off default 0
1 Cross for off

The default value is 0.

TIN_VIEWPORT_CLIP_4D 0 Drawing tins, fast contours as per V3.1default 0
1 A speed up for drawing tins, fast contours

Use some experimental techniques for speeding up the drawing of tins, fast contours.

The default value is 0.

TOOLBARS_4D filename default toolbars.4d

file of toolbar definitions and names

The default is toolbars.4d. See “User Defined Toolbars” 

TYPED_UNITS_MODE_4D 0 International units only e.g. f and F are both
   International feet default 0

1 USA units only e.g. f and F are both US feet
2 Mixed e.g. f is International feet and F is US feet.

Controls the typed input units for feet - international and/or US. The default value is 0.

UNDO_4D 0 Don’t allow undo’s
1 Allow undo/redos. default 1

Undo and Redo is available for most operations from 12d Model V3.1 onwards. The availability of Undo/
Redo facility is controlled by the environment variable:

The default value is 1.

USAGE_LOG_4D folder no default

when set, log files of the form

<log file folder>\(<dongle> <user> <computer> <time stamp> <process ID>.log)

will be created in the given folder.

USAGE_LOGS_4D folder no default

when set, log files of the form

<log file folder>\<dongle>\<user>\<computer>\(<time stamp> <process ID>.log)

will be created in the given folder.

USER_4D folder HOME_4D\7.00\user

user folder containing set up files

The default is ’HOME_4D\7.00\user’.

USER_LIB_4D folder HOME_4D\7.00\user_lib

user library folder for input files such as mapping, template and macros (4DML’s).

The default is ’HOME_4D\7.00\user_lib’.

USER_OPTIONS_4D file default usermenu.4d

To help customise 12d Model, the walk-right menu User on the main 12d Model menu, can be user 
defined. The text for each button of User, plus the action taken when the button is selected is user specified. 
Any of the buttons can include further walk-right menus.
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The definition for User is given in a file with the default name usermenu.4d which is searched for in the 
standard set up areas (local, USER_4D, user, set_ups) or set by the environment variable 
USER_OPTIONS_4D.

The default is usermenu.4d. See “User Defined Menus” 

VEHICLE_PATH_4D folder no default

Vpath is the Vehicle Turning Path program written by Main Roads Queensland and is a separate 
chargeable program.

The environment variable VEHICLE_PATH_4D points to the folder where the Dos version of the Vpath 
executable is located. Note that WINDOWS_VEHICLE_PATH_4D points to the Windows version.

VIEW_BITMAP_BUTTONS_4D 0 User text for view buttons
1 Use icons for view buttons default 1

The default value is 1

VIEW_BUTTONS_4D 0 No view buttons are displayed
1 The view buttons are displayed default 1

The default value is 1

WARP_CURSOR_HIDE_4D 0 Don’t hide the cursor before moving it default 0
1 Hides the cursor before moving it

Controls whether the cursor is hidden before moving - only needed on some computers.

The default value is 0.

WEB_4D search engine web address www.google.com

web address of the search engine that is fired up from the 12d option

Help =>12d on the Web =>Search the web.

WEED_TOLERANCE_4D 0 Don’t weed
real Weed tolerance

used in Alignment and Super strings so that when arcs have been chord-to-arc’d, the resulting points are 
weeded so that no point is closer than the weed tolerance. Is is also used in Apply and Apply Many so that 
no cross sections are closer than the weed tolerance.

WINDOWS_PRINTERS_4D 0 Don’t allow Windows printers
1 Enable Windows printers default 1

The default value is 1.

 WINDOWS_VEHICLE_PATH_4D folder no default

Vpath is the Vehicle Turning Path program written by Main Roads Queensland and is a separate 
chargeable program.

The environment variable WINDOWS_VEHICLE_PATH_4D points to the folder where the Windows 
version of the Vpath executable is located.

WINTER_4D path name to WINTER program

points to the WINTER program for calculation N-values for Australia.

WINTER_DATA_4D folder no default

Folder containing the Winter data of N-values for Australia.

WRITE_ALL_PLOT_PARAMETERS_4D 0 Only write out the plot parameters
that are used in the ppf.

1 Write out all plot parameters
default 1
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Controls whether all plot parameters are written out or just those that have been used in the ppf file.

The default value is 1.

X_SECTION_PPF_4D path name to .ppf file no default

points to the file used as the default plot parameter file (.ppf) for the panel section X plot.

The path name to the .ppf file can contain $LIB which expands out to the path of the library area. For 
example, "$LIB/cross.ppf" points to the file cross.ppf in the area defined by $LIB_4D.

ZOOM_ORIGIN_DYNAMIC_4D 0 The centre of the view is the zoom centre point default 0
1 The point you pick is the zoom centre point

Controls the origin of the dynamic zoom. If set then the point selected in the view to indicate which view 
to dynamically zoom (and to be the zoom in-zoom out definition point) becomes the point to dynamically 
zoom about. Whilst the dynamic zoom is running, another point can be selected to become the new zoom 
origin.

The default value is 0.

ZOOM_PAN_DYNAMIC_4D 0 Dynamic pan is not the default default 0
1 Dynamic pan is the default for pan

If set then dynamic pan is the default for the pan options. The middle mouse button (or ’d’) is not required 
to place the pan option in dynamic mode. In fact, it would then toggle it off.

The default value is 0.

Notes

(a) If any of the environment variables (pointing to files) are not set, or the file pointed to does not exist, 
then 12d Model searches for the default files in a number of locations. The search order is given at 
the beginning of this Appendix.

(b) The eagle pen mapping file, eagleplt.emf is also searched for in the same order as the default files.

(c) When an existing project is opened by 12d Model, the setups.4d and defaults.4d are not used.
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Setting Environment Variables
The simplest method for setting the required environment used in 12d Model is to place then into a file, 
called the environmental file (default name env.4d).

Environment Variables File

It is possible to define a file which sets the value for one or more environment variables.

The file format consists of one line for each environment variable being set and each line contains the 
environment variable name, followed by one or more spaces and then the value for the environment 
variable:

environment_variable_name value

The value of any environment variable given in the environment variable file overrides any other 
definition for that environment variable.

The file used as the environmental variable file is checked for in the following order - as soon as a file is 
found, the search terminates and that file is used:

1. as a command line argument when 12d Model is fired up. The syntax is

12d -env path_name

where path_name is the full path name of the file

2. pointed to by the environment variable ENVIRONMENT_4D

ENVIRONMENT_4D file // file of environment variables
// default env.4d

3. a file called env.4d which is searched for in the standard set up areas (local, USER_4D, user, set_ups).

An example of an environment variable file is

EDITOR_4D te // set the text editor used

SHOW_PATHS_4D 1 // show file names set by environment variables 

SHEET_SIZES_4D c:\standards\shfile

Setting Environment Variables not in a File

Environment variables can be set in Windows NT for a user from the Environment tab on the System 
Properties panel brought up by clicking on the System icon in the Control Panel of Windows.

To bring up the Control Panel, click on Start in the Windows Task bar, walk right on Settings and then 
click on Control Panel.
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Set Ups
The set up file, setups.4d, is used to define the initial screen set-ups. It can be used for

s the system font used for text

s the size of the initial window

s the position of the main menu, header menu, function menu, function recalc menu, snaps menu, 
volumes menu, geometry menu, sewer menu, pipeline menu

s the position of the screen message box, xyz message box

s the position of the save project panel (now redundant)

s the position, size, name and viewing parameters for the initial views

The co-ordinate system used for specifying the position of the left hand top corner of items on the screen is 
by column and row. For items which include an area of the screen (such as the window and views), a width 
and depth are also specified.

The column value is measured from the left hand size of the screen and the row value is measured from the 
top of the screen.

The units for row, column, width and depth are screen pixels.

Note - If any views are defined in the set_up_file, then the position of the screen message box must be 
also be defined and it must be before the definition of any view.

The format of the commands in the file setups.4d is

WINDOW             column_value row_value width     depth // main window

MAIN MENU column_value row_value

FUNCTION MENU column_value row_value
FUNCTION RECALC MENU column_value row_value
GEOMETRY MENU column_value row_value
PIPELINE MENU column_value row_value
SEWER MENU column_value row_value
SURVEY MENU column_value row_value
VOLUMES MENU column_value row_value

SNAPS MENU column_value row_value
SNAPS BUTTONS HORIZONTAL column_value row_value
SNAPS BUTTONS VERTICAL column_value row_value

PROJECT SAVE PANEL column_value row_value

// Views

PLAN VIEW column_value         row_value     width        depth name

columns

rows

depth

width   
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SECTION VIEW column_value         row_value     width        depth name

PERSPECTIVE VIEW column_value        row_value     width    depth name

reference point 0.0 750.0 120.0 // x y  z
view plane normal 1.0 0.0 0.0 // dx dy dz
view up vector 0.0 0.0 1.0 // dx dy dz
view distance 10.0 // distance

The following parameters were used for V5.00 but are ignored for V5.0 onward:

SCREEN MESSAGE BOX column_value row_value
XYZ MESSAGE BOX column_value row_value
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Colours
12d Model allows the use of up to 10,240 distinct colours for drawing in any view.

The colours are numbered from 0 to 10,239 and the user defines the red, green and blue mix (RGB) for 
each colour and what name is used throughout the program when referring to the colour.

The colour names and RGB mix associated with each colour number is defined in the file colours.4d.

The format for each line of the colours.4d file is:

red_value green_value blue_value pen_num col_name col_num pop-up_num col_group

Each colour is defined in terms of its red, green and blue intensity (RGB). The intensity value is between 0 
and 255, where 0 represents no colour and 255 full colour. The RGB values for the colour are red_value, 
green_value and blue_value.

When plotting, the default plotter pen number used to plot a colour is given in the file as pen_num. The 
pen number is an integer that is positive or zero.

The actual colour name used to describe the colour is given in quotes after the default plotter pen number 
- col_name. Colour names can be alphanumeric although upper and lower case are considered the same. 
Each colour must have a unique colour name. If an underscore "_" is used in a colour name in the 
colours.4d file then a space is inserted in 12d Model. The colour name must be enclosed within quotes. For 
example,  "dark red".

The colour number is what is actually stored in 12d Model and it is given after the colour name - 
col_num. A colour number is an integer that is positive or zero. Colour numbers can only occur once in the 
colours.4d file but there can be gaps in the colour numbers.

The colour pop-up number, pop-up_num is the next item in the colours.4d file.

The colour pop-up number is an integer that can be negative, zero or positive. Colour pop-up numbers can 
only occur once in the colours.4d file but there can be gaps in the colour pop-up numbers.

The colour pop-up number is used to decide which colours are should in the Colour box. If Display 
colours is set to n in Utilities =>Defaults, then the colours with the n smallest pop-up numbers are 
displayed in the Colour box pop-up. So the order that the colours are chosen to appear in the colour pop-up 
is independent of the colour number.

The colour group, col_group, is the last item in the colours.4d file. The colour group is simply text and 
does not have to be unique. The colour group is enclosed in quotes. For example,  "vis". 

The colour group is not currently used in 12d Model but is expected to be used to group colours together in 
a colours pop-up.

The colours.4d file is displayed and modified by using the Edit Colours panel brought up form the [Edit} 
item on the colours pop-up, Select Colour. For more information, go to the section “Colours” of the 
Chapter  “Tools and Concepts” .
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Defaults
The defaults file, defaults.4d, defines the initial default settings used in the 12d Model default and the 
systems defaults panels.

The defaults file can contain:

// general defaults

DEFAULT COLOUR red
DEFAULT POINT COLOUR yellow
DEFAULT TIN COLOUR brown
DEFAULT CONTOUR COLOUR cyan
DEFAULT CONTOUR INDEX COLOUR magenta
DEFAULT TEXT SIZE 8

// view settings

DEFAULT CULLING OFF/ON
DEFAULT CULLING SIZE 1.0
DEFAULT SECTION VIEW EXAGGERATION 10.0
DEFAULT PERSPECTIVE VIEW EXAGGERATION 1.0

DEFAULT FAST TEXT CULL SIZE 4.5             // if not specified assumes 4.5
DEFAULT NONE TEXT CULL SIZE 2.0             // if not specified assumes 2.0

// highlighting

DEFAULT ANGLE MODE BEARINGS/DEGREES
DEFAULT HIGHLIGHT COLOUR white
DEFAULT HIGHLIGHT CROSS COLOUR yellow
DEFAULT HIGHLIGHT CROSS SIZE 2.0

// drawing points

DEFAULT CHORD ARC TOLERANCE 0.1
DEFAULT POINT CROSS SIZE MMS 2.0
DEFAULT POINT CROSS SIZE PIXELS 3

// trash model and mode

DEFAULT TRASH MODEL model_name // model for trash
DEFAULT TRASH MODE trash string // send used strings to trash

delete string // delete used strings
keep string // keep used strings

// miscellaneous

DEFAULT NAME SETTINGS file_name // names.4d file

The information panel for each editor can be toggled on/off and the initial state when a new edit operation 
is begun is given by

DEFAULT EDIT INFORMATION 1 // show info panel on editor start-up
0 // don’t show info panel

When output report are created, the scripts/programs pointed to by EDITOR_4D and PRINTER_4D will 
be run depending on the values of the defaults display reports and print reports.

DEFAULT DISPLAY REPORT FILES 1 // run EDITOR_4D
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0 // don’t run "

DEFAULT PRINT REPORT FILES 1 // run PRINTER_4D
0 // don’t run "

Similarly when plots are created, the script/program pointed to by PLOTTER_4D and will be run 
depending on the value of the default send plots.

DEFAULT SEND PLOT FILES 1 // run PLOTTER_4D
0 // don’t run "

The number of minutes between displays of the save project yes-no box is given by

DEFAULT SAVE INTERVAL minutes // 0 for never

The file defining string colours can have up to 10,240 colours in it however this number is usually 
inconvenient to display in the standard colour pop-up so there is a setting to set how many colours are 
displayed from the list.

DEFAULT POPUP COLOURS number_of_colours // default 16

The precision for displaying real numbers in the information panel and in boxes and panel fields can be set.

DEFAULT PRECISION integer // info panel - default 3
DEFAULT BOX PRECISION integer // boxes & panels -default 4

The sign for cut areas and volumes can be positive or negative (fill is the opposite) and is given by

DEFAULT CUT VOLUME SIGN -1 // negative for cut (default)
1 // positive for cut

Text in text string, 4d strings and linestyles may be in pixels and must be given a millimetre size for 
plotting. Pixel text is multiplied by a factor to convert it to a millimetre size. The pixels to mm plot 

DEFAULT PIXELS TO MM PLOT FACTOR real // default 1.0
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GUI
Note - this section is only for versions earlier than V4.0

The file gui.4ddefined the colours used for screen objects (the graphical user interface objects), screen 
fonts, maximum pop-up length, and spacing in the menus and panels.

The gui.4d file is read every time a project (new or old) is opened.

GUI Colours
The colours associated with each screen object are given in terms of intensity values of red, green and blue. 
The intensity values are between 0 and 255, where 0 represents no colour and 255 full colour.

The layout for screen colours in the gui.4d file is:

//   object RGB values- red green blue

VIEW BACKGROUND COLOUR           0      0        0 // black
VIEW BORDER COLOUR                        255   255    0 // yellow

BUTTON HIGHLIGHT COLOUR        255     255     0 // yellow
BUTTON TEXT COLOUR                      127    127     127 // grey
BUTTON BACKGROUND COLOUR        60     60    200 // dark blue

MENU BACKGROUND COLOUR         150     90      0 // brown
MENU BORDER COLOUR                      255       255   0 // yellow

PANEL BACKGROUND COLOUR        150     90     0  // brown
PANEL BORDER COLOUR                      255     255   0 // yellow

FRONT SCREEN LOGO COLOUR          255      255     0 // yellow
FRONT SCREEN TEXT COLOUR            0          255     0 // green
FRONT SCREEN BACKGROUND COLOUR    60     60    200 // dark blue

WINDOW BACKGROUND COLOUR 1      64       128         0 // half green
WINDOW BACKGROUND COLOUR 2       0        128        196 // cyan

Maximum Pop-Up Length
The maximum number of items in a pop-up list before splitting into walk-right pop-ups is given by 
(necessary when using VGA screens on PC’s) 

POPUP LENGTH integer //maximum number of items in a pop-up

Fonts for Menus and Panels
A font can be defined for use in the menu and panel titles areas and a separate font for the rest of the text in 
the menus and panels.

The fonts are defined in the gui.4d file as:

SYSTEM TITLE FONT font_name // font for titles
SYSTEM FONT font_name // font used elsewhere

For X-Windows, the font_name is the name of the required font from the font list given by the command 
xlsfonts.
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For Windows NT, the font_name is made up of the Windows font name plus zero or more parameter values 
for the font.

The font name and parameter values are given as one text name, font_name, by concatenating the font 
name and values with only a minus separating them.

If the font name consists of more than one word, the font name is enclosed in double quotes(").

Hence for NT, an example of defining fonts is:

Parameter Possible Values

Font font name (less than 32 characters)

Height number

italic

underline

strikeout

Weight thin extralight light normal medium semibold bold extrabold heavy

Quality draft proof

Pitch default_pitch fixed_pitch variable_pitch

Family decorative modern roman script swiss 

Defaults

Height 14
Weights fw_dontcare (family weight don’t care)
Pitch font default pitch
Family ff_dontcare (font family don’t care)
Quality default_quality
italic false
underline false
strikeout false

For example

Arial-14-bold-italic is the fond Arial, of height 14 and bold and italic

"Courier New"-16-italic is the font Courier New, of height 16 and bold.

Under NT, if the font is not properly defined or doesn’t exist, then the system font is used.

Under X-Windows, if the font does not exist, the font fixed is tried. If fixed does not exist, 12d Model will 
not start up.

Spacing for Borders and Panels
There are parameter to control the amount of space in border, between items etc. for menus and borders. 
These are normally set by 12D Solutions and should not need to be modified.

SCREEN TEXT BORDER X pixels

SCREEN TEXT BORDER Y pixels

SCREEN TEXT EXTRA X pixels

SCREEN TEXT EXTRA Y pixels

EDIT BOX BORDER X pixels

EDIT BOX BORDER Y pixels

PANEL BORDER X pixels
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PANEL BORDER Y pixels

PANEL GAP Y pixels

VERTICAL BORDER X pixels

VERTICAL BORDER Y pixels

VERTICAL GAP Y pixels

HORIZONTAL BORDER X pixels

HORIZONTAL BORDER Y pixels

HORIZONTAL GAP Y pixels

INPUT BOX BORDER X pixels

INPUT BOX BORDER Y pixels
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Sheet Sizes
For plot frames, long and x plots, the overall size of the plot sheet can be given by a pop-up containing 
defined sheet size.

The sheet size names, width and heights can be specified by the user in a file named sheets.4d which is in 
the normal set up areas, or is pointed to by the environment variable

SHEET_SIZES_4D file // file of plotter sheets sizes

The layout of the sheet sizes file is

// User definition file for sheets sizes in 12d Model
// Heights and widths are in mm.

// sheet name width height

A0 1189 841
A1 841 594
A2 594 420
A3 420 297
A4 297 210

B1 1000 707



Appendix J

January 2005 Page 3361Spirals

Spirals
A spiral curve can be uniquely defined in terms of a start tangent vector, a final radius of curvature (R) and 
a total spiral length (L).

Traditionally, the equation for this spiral is given in terms of a local co-ordinate system where the origin is 
at the start of the spiral and the x-direction (abscissa) is along the tangent vector at the start of the spiral. 
The y-direction (ordinate) is given as the offset from the x-axis of the point on the spiral.

Formulae for the local co-ordinates of a point on the spiral can then be derived in terms of the distance of 
the point along the spiral (the spiral length to the point) and the given constants L (the total spiral length) 
and R (the final radius of curvature of the spiral).

These formulae for the local co-ordinates of a point on the spiral are polynomial series in terms of the 
spiral length to that point.

For use in calculations, the local co-ordinates can be approximated by restricting the polynomial series to 
a fixed number of terms.

For example, the cubic spiral only uses the first term for the polynomials for x and y.

                     number of terms for the 

cubic Westrail cubic clothoid

abscissa x 1 2 5

offset y 1 1 4

In 12d Model, the names and the x and y coefficients used for spiral definitions are given in the file 
spirals.4d or in the file pointed to by the SPIRALS_4D environment variable.

The format for each spiral definition in the file is

spiral "spiral-name" {
   data {
       x coefficient y coefficient for the first term
       x coefficient y coefficient for second term
       x coefficient y coefficient for third term
       ... for a total of up to ten terms
   }
}

For example, 

spiral "westrail-cubic" {
   data {
      1.0     0.16666666666666
      0.025   0.0

}
}
spiral "cubic" {
   data {
       1.0     0.16666666666666

}
}

Note - the clothoid spiral is the default spiral used in 12d Model and does not have to be defined in the file.
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12d Model Options Map
The 12d Model menu map shows the menu structure for all the sub-menus on the main 12d Model menu 
and the menus on the views.

The map is designed to be printed out for users who wish to affix it to a wall.

The PDF file of the menu map on the 12d Model Installation CD in the folder

 Documentation\12d Model menu map

Or in the Updates section of the web site www.12d.com
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Monitoring 12d Model Usage

Overview
12d Model usage can be monitored for single-user and network licenses (or a mix of both), whether 
installed on a single computer, a local-area network, or a wide-area network across different time zones.

Monitoring the usage is a 3 stage procedure:

1. Generating individual .log files for each 12d Model session run.

2. Consolidating all the completed .log files into a CSV file.

3. Reporting the usage details, using the CSV file as input.

The 1st stage is achieved by setting an environment variable in your env.4d file(s).

The last 2 stages are achieved by running the supplied program: 12d_usage.exe.

Generating the .log files
By setting one of two possible environment variables in the env.4d file(s) used for your 12d Model 
sessions, uniquely named .log files can be generated in a specified folder on your network. 

For example, by adding the lines:

usage_log_4d  F:\12d model usage

or

usage_logs_4d F:\12d model usage

to your env.4d file(s), then each time a 12d Model session is run, a .log file will be created in the “F:\12d 
model usage” folder. This folder, referred to as the <log file folder>, can be anywhere on your network and 
can have any name, but it must be created beforehand, and all 12d Model users must have write-access to 
it.

In the first case, using variable “usage_log_4d”, log files will be generated in the form:

<log file folder>\(<dongle> <user> <computer> <time stamp> <process ID>.log)

In the second case, using variable “usage_logs_4d”, log files will be generated within sub-folders of the 
form:

<log file folder>\<dongle>\<user>\<computer>\(<time stamp> <process ID>.log)

Note that the <time stamp> represents the start time of the 12d Model session in GMT (also known as 
UTC or Zulu Time).

It does not matter which variable you decide to use, and you can even use a mix of the variables, if you 
have more than one env.4d file. However, regardless of which variable you use, it is recommended that the 
<log file folder> is the same for all 12d Model users on your network so that all 12d Model sessions can be 
easily included in the reports.

The .log file generated in the <log file folder> for each individual 12d Model session run on your network, 
contains all the information required about that session. While the session is still running, the log file will 
be updated at a minimum of every 75 seconds, with the time that the session has been active. At the close 
of the 12d Model session, the log file is again updated and is set as “completed”.
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Installing 12d_usage.exe
You can put the 12d_usage.exe program wherever you like on your network. Then, simply create a 
shortcut to the program on your desktop, making sure the shortcut properties are set as follows:

Target: <path to program location>\12d_usage.exe

Start in: <path to Working Folder>

The Working Folder is the folder that you run the 12d_usage.exe program from (it does not have to be the 
same as the location of the 12d_usage.exe file). After running the program for the first time, a file named 
12d_usage.defaults will be created in the Working Folder. This file is used to save your settings from the 
last run of the program and to load your settings for the next run of the program. In addition, you might 
also wish to use the Working Folder to store your 12d Model Usage report files (although you are free to 
store them elsewhere).

Running 12d_usage.exe
To run the 12d_usage program, simply double-click on the shortcut icon you created at install time. This 
will open up a DOS window from where the program’s keyboard-driven menu system can be run.

From the Main menu within the 12d_usage program, your keyboard-driven menu options are:

C Bring up the Consolidate menu

R Bring up the Report menu

Q Exit (quit) the 12d_usage program

Consolidating the .log files
After a while, you should notice that a lot of .log files are being generated in your specified <log file 
folder>. To consolidate all these .log files into a single Comma-Separated-Variable (CSV) file, you will 
need to run the 12d_usage.exe program, and press the “C” key to bring up the Consolidate menu.

From the Consolidate menu, your keyboard-driven menu options are:

F Specify the <log file folder>

O Specify the output CSV file name

T Toggle whether to delete or rename consolidated log files

C Consolidate 12d Model session log files

Q Exit the Consolidate menu and return to the Main menu

When specifying the name of the CSV file you wish to consolidate your log files to (using the “O” key), if 
you want a .csv file extension (to allow the file to be easily loaded into MS?Excel for your own custom 
reports, for example), you must include the .csv in the file name. It is recommended that all users of the 
12d_usage program consolidate log files to the same CSV file every time. Newly consolidated logs are 
always appended to an existing CSV file. If there is to be more than one user of the 12d_usage program, it 
might be a good idea to specify the CSV file to be in the <log file folder> or the Working Folder (or at 
least, some folder that all 12d_usage users can access).

You also need to specify how to tidy up the log files, after they have been consolidated, so that they are not 
consolidated more than once. Your options here are to rename or to delete the log files (the “T” key toggles 
between rename and delete). If you choose to rename them, they will be renamed with a .logc extension. If 
you choose to delete them, they will be lost forever, and the only record you will have of your consolidated 
sessions will be contained in the CSV file. As such, you should be very careful not to delete your CSV file.

Pressing the “C” key will then go ahead and consolidate the log files. Note that consolidation will only 
take place on “completed” log files (or on log files that have not been updated for more than 24 hours - to 
handle the case of a power failure, for instance).
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Reporting on 12d Model Usage
After creating or adding to your consolidated CSV file, you can press the “R” key from the Main menu, in 
order to bring up the Report menu.

From the Report menu, your keyboard-driven menu options are:

 I Specify the input CSV file name (generated from the Consolidate menu)

O Specify the output report file name

M Toggle whether to overwrite or append to existing report file

D Add/Remove Dongle constraints

C Add/Remove Computer constraints

U Add/Remove User constraints

F Add/Remove Folder constraints

P Add/Remove Project constraints

E Add/Remove Program constraints

V Add/Remove Version constraints

T Specify Start and End times for report (in Local Time of 12d_usage User*)

S Specify which summary tables you want in the report

R Generate the 12d Model Usage report

Q Exit the Report menu and return to the Main menu

After generating the report (using the “R” key), you will be asked if you want to view the report file. If you 
answer yes (using the “Y” key), the report file will be opened using Notepad.exe as the default file editor. 
If you would prefer to use a different file editor, you can specify it by manually editing the 
12d_usage.defaults file (see Installing 12d_usage.exe), and replacing the word “notepad” (last line of the 
file), with the command to start your preferred editor.

*Note: In general, if reporting on 12d Model sessions running on a WAN across different time zones, 
Local Time of 12d Model User and Local Time of 12d_usage User may be different.
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K Line styles, Symbols and 
Textstyles

Line Styles
Users can define their own line styles to use when drawing 12d Model strings. The definition of 
linestyles are stored in a file called linestyl.4d.

Linestyles in the file can be created/edited/deleted using the Linestyle Create/Edit/Delete panel 
which is brought up by double clicking on Create linestyle in the Linestyles expansion of the Project 
Tree (see “Linestyles” in the chapter “Projects” ) brought up by the Project=>Browse option.

The Linestyle Create/Edit/Delete panel acts as an interactive editor to a text file which contains the 
linestyle definitions. 

The user defined line styles can be 

(a) applied at each vertex of the string - vertex mode

(b) repeated along the string - continuous mode

(c) stretched between adjacent vertices of the string

(d) any combination of the above. 



12d Model Reference Manual

Page 3368 October 2002Line Styles

Each line style can be made up of lines, arcs, circles and text.

For cases (a) and (b), the units for the line style can be in pixels, millimetres or world units. 

The line style with one origin is called a
 linestyle if the definition of the style is given in pixel units
 paperstyle if the definition of the style is given in paper units
 worldstyle if the definition of the style is given in world units

and line style with two origins is called a twoptstyle.

For case (c) the style is stretched between two adjacent points and is called a twoptstyle style.

Finally, case (d) is called a groupstyle and is a combined style made up of one or more linestyles, 
paperstyles, worldstyles or twoptstyles.

Note:
The words linestyle or line style are often used in the manual to refer to either a linestyle, 
paperstyle, worldstyle, twoptstyle or groupstyle.

Defining Line Styles
A line style is defined in a (x,y) co-ordinate system as a series of moves, drawn, arcs, circles and 
text commands.
The bounding box of the line style is the smallest rectangle parallel to the (x,y) axis which 
contains all the moves, draws, circles and arcs of the line style. Note that moves are included in 
the bounding box even if a line isn’t drawn to the point.

The default origin of the line style is defined to be the midpoint of the bounding box 
surrounding the line style. The bounding box includes the points moved to and drawn to, but 
does not automatically include (0,0). Hence the calculated origin may not be (0,0).

There are xorigin and yorigin commands to override the default origin of the line style.

 If a yorigin is set, then it is used as the y-coordinate of the line style. If the xorigin isn’t given, 
then the xorigin is the midpoint of the x-extent of the bounding box of the line style.

A linestyle, worldstyle or paperstyle can be drawn at each point or repeated along the string.

A twoptstyle stretches between two points in one or both directions.

A groupstyle made up of a vertex and a continuous line style.
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 Similarly, if a xorigin is set, then it is used as the x-coordinate of the line style. If the yorigin isn’t 
given, then the yorigin is the midpoint of the y-extent of the bounding box of the line style.

The default length of the line style is the horizontal size of the bounding box.

There is a length commands to override the default length of the line style. The length must 
always be positive but it can be larger or smaller than the line styles’s calculated horizontal 
length. 

The origin and the length of the line style are both used in positioning and redrawing the line 
style.

For vertex mode, the origin of the line style is placed at each point of the string and the line style 
drawn around the origin.

For continuous mode, the origin of the line style is initially placed at a distance of half of the length 
of the line style along the first link in the string, and then moved the distance length along the 
string and redrawn.This is repeated along the string until the end of the string is reached. 

Hence for continuous mode, the style is continually repeated along the string.
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Linestyl.4d
The definitions for the available linestyles are normally stored in a file called linestyl.4d which is 
read in each time 12d Model opens an existing project or creates a new project. Linestyl.4d is 
searched for in the standard set up paths, or is pointed to by the environment variable

LINESTYLES_4D filename

The definition of the line styles will be given in the following section “Line Style Definitions” .
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Line Style Definitions

Linestyles, Paperstyles and Worldstyles
The line style with one origin is called a

 linestyle if the definition of the style is given in pixel units
 paperstyle if the definition of the style is given in paper units
 worldstyle if the definition of the style is given in world units

and line style with two origins is called a twoptstyle.

The line style can be drawn at each point of a string (vertex mode) or redrawn regularly along 
the lines joining string points (continuous mode).

The definition of a linestyle of a given name name is

linestyle   name {

    set_up_commands

    draw_commands

}

a paperstyle is

paperstyle   name {

    set_up_commands

    draw_commands

}

and a worldstyle is

worldstyle   name {

    set_up_commands

    draw_commands

}

where the set_up_commands must be before the draw_commands.

The linestyle/paper/worldstyle must have a name and if the name includes imbedded spaces, it 
must be enclosed in double quotes “.

The line style itself is defined inside the braces where there can be zero or more 
set_up_commands from the list

length value
group name
mode value
factor value
xorigin value
yorigin value

followed by zero or more draw_commands from the list

move x-value y-value
draw x-value y-value
rmove dx-value dy-value
rdraw dx-value dy-value
colour colour_name
circle radius
arc radius start-angle end-angle
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text "text" angle    height   "justification"
text "text" angle    height   "justification" "textstyle"
text "text" angle height "justification" "textstyle" xfactor slant offset _width offset_height
repeat num_repeats{ repeat_commands repeat_draw_commands}

The repeat command is a positive integer num_repeats

and zero or more repeat_commands from the list

xpos x-value
ypos y-value
rfactor value

and zero or more repeat_draw_commands where repeat_draw_commands include all the 
draw_commands except repeat.

The set_up commands for linestyles, paperstyles and worldstyles will now be described. The 
draw_commands will be described after the definition of a groupstyle since they are the same for 
linestyles, paperstyles, worldstyles and twoptstyles.

set_up_commands for Linestyles, Paperstyles and Worldstyles

group
The group is used to associate line styles in pop-up menus.

If the group is not defined, the style is placed in a default (blank) group.

If the group name includes imbedded spaces, then it must be enclosed in double quotes ".

mode
mode specifies whether the linestyle, paperstyle or worldstyle is drawn at the individual points 
on a string (vertex mode) or it is to be redrawn regularly along the lines joining the points on the 
string (continuous mode).

If the mode is not specified, the mode used for a string depends on the breakline type of the 
string and the number of points on the string.

NOTE: in early versions of 12d Model, mode was known as pointline and had the values point 
instead of vertex, and line instead of continuous.

factor
This command factors up/down the drawing co-ordinates, heights and radii.

xorigin, yorigin
The default origin of the line style is defined to be the midpoint of the bounding box of the line 
style. The bounding box includes the points moved to and drawn to but does not automatically 
include (0,0). Hence the calculated origin may not be (0,0).

The xorigin and yorigin commands are used to override the default origin of the line style.

Breakline
Type

Number
of Points

mode:
vertex

mode: 
continuous

mode:
not-given

point 1 vertex cross vertex

>1 vertex continuous vertex

line 1 vertex cross vertex

>1 vertex continuous continuous
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length
If length is omitted, then length is taken to be the horizontal size of the calculated bounding box 
of the style.

The length must always be positive but it can be larger or smaller than the line style’s calculated 
horizontal size.

The origin of the line style and the length are both used in positioning and redrawing the line 
style.

In vertex mode, the origin of the line style is placed at the string points.

In continuous mode, the origin is initially placed at a distance of half of length along the first 
line in the string, and then moved the distance length along the string for each redraw.

Examples

// Fence1
worldstyle "FENCE1"{
  group SWCS
  factor 20
  move 0 0
  rdraw 1 0
  rmove 0.25 -0.25
  rdraw 0.25 0.50
  rmove 0.25 -0.25
  rdraw 1 0
}

// Drainage

worldstyle drainage {
  group "4d" 
  factor 0.1
  colour green

  move  .0 -2.0  draw 30 -2.0

  move 30 -1.5  draw 15 -1.5
  move 15 -1.0  draw 30 -1.0
  move 30 -0.5  draw 15 -0.5

Linestyles and Worldstyles

vertices
used
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  move 15  0.0  draw 30  0.0

  move 30  0.5  draw 15  0.5
  move 15  1.0  draw 30  1.0
  move 30  1.5  draw 15  1.5

  move 30  2.0  draw  0  2.0
}
// Floolight
worldstyle FLOODLIGHT {
 group "Energex"
 mode vertex
 xorigin 0
 yorigin 0
 colour "yellow"
 circle 0.225 
 move  -.45 0 
 draw  -0.225 0 
 move .45 0
 draw 0.225 0
 move 0 -.45
 draw  0 -0.225
 move  0 .45
 draw  0 0.225
 move -.159 0.159 
 draw -0.318 0.318 
 move 0.159 0.159
 draw 0.318 0.318
 move 0.159 -0.159
 draw 0.318 -0.318 
 move -0.159 -0.159
 draw -0.318 -0.318
 move 0 0.8
 text "FL" 0 0.5 "centre-middle"
}

Twoptstyles
A twoptstyle is a line style which is stretched so that one cycle fits between consecutive points 
on a string (line or arc segments). This is achieved by defining two origins for the twoptstyle and 
the first and second origins are mapped to the consecutive points on the string.

Hence the mapping of the two origins defines the final size of the size in world units.

The twoptstyle can stretch in just the direction along the string, or both along and perpendicular 
to the direction of the string.

Also the twoptstyle can be drawn for each line/arc on the string, or for every second line/arc of 
the string.

For a feature/circle string, the first origin is placed at the centre of the feature/circle and the 
second origin is placed on the circumference of the feature/circle. Hence the size of the twoptstyle 
is determined by the radius of the feature/circle string.

The definition of a twoptstyle of a given name is

twoptstyle   name {

    set_up_commands

    draw_commands

}
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where the set_up_commands must be before the draw_commands.

The twoptstyle must have a name and if the name includes imbedded spaces, it must be enclosed 
in double quotes “.

The twoptstyle itself is defined inside the braces where there can be zero or more 
set_up_commands from the list

group name
stretch_mode value
cycle_mode value
xorigin1 value
yorigin1 value
xorigin2 value
yorigin2 value

followed by zero or more draw_commands from the list

move x-value y-value
draw x-value y-value
rmove dx-value dy-value
rdraw dx-value dy-value
colour colour_name
circle radius
arc radius start-angle end-angle
text "text" angle    height   "justification"
text "text" angle    height   "justification" "textstyle"
text "text" angle height "justification" "textstyle" xfactor slant offset width offset_height
repeat num_repeats{ repeat_commands repeat_draw_commands}

The repeat command is a positive integer num_repeats and zero or more repeat_commands from 
the list

xpos x-value
ypos y-value
rfactor value

and zero or more repeat_draw_commands where repeat_draw_commands include all the 
draw_commands except repeat.

The set_up commands for a twoptstyle will now be described. The draw_commands will be 
described after the definition of a groupstyle since they are the same for linestyles, paperstyles, 
worldstyles and twoptstyles.

set_up_commands for Twoptstyles

group
The group is used to associate line styles in pop-up menus.

If the group is not defined, the line style is placed in a default (blank) group.

If the group name includes imbedded spaces, then it must be enclosed in double quotes ".

stretch_mode
stretch_mode controls whether the symbol stretches in just the direction along the string, or both 
along and perpendicular to the direction of the string

stretch_mode 1 // stretch in one direction only (default)
 2 // stretch in both directions



12d Model Reference Manual

Page 3376 October 2002Line Style Definitions

cycle_mode
cycle_mode controls whether the symbol is drawn for each line/arc on the string, or for every 
second line/arc of the string.

cycle_mode 1 // draws on every line/arc (default)
 2 // draws every second line/arc

xorigin1, yorigin1
The point (xorigin1, yorigin1) is mapped to the first point that the twoptstyle is being applied to.

The default first point of origin of the twoptstyle is defined to be the minimum x value and the 
average of the minimum and maximum y values (x_min,(y_min+y_max)/2).

The xorigin1 and yorigin1 commands are used to override the default first origin of the 
twoptstyle.

xorigin2, yorigin2
The point (xorigin2, yorigin2) is mapped to the second point that the twoptstyle is being applied 
to.

The default second point of origin of the twoptstyle is defined to be the maximum x value and 
the average of the minimum and maximum y values (x_max,(y_min+y_max)/2).

The xorigin2 and yorigin2 commands are used to override the default second origin of the 
twoptstyle.

Examples

A twoptstyle stretches between two points in one or both directions.

twoptstyle stretch in one direction stretch in both directions

A twoptstyle draws on each line/arc or every second line/arc

draw on every line/arc draw on every second line/arc
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// Gate
twoptstyle GATE {
  group "Two Points"
  stretch_mode 2
  cycle_mode   2
  colour red
  move 100   105
  draw 140    95
  draw 140   105
  draw 100    95
  draw 100   105
}
// two point tree
twoptstyle 2PT_TREE {
 group     "4d_standards"
 stretch_mode 2
 cycle_mode   2
 xorigin10
 yorigin10
// xorigin22.5
// yorigin2 1.25

 colour "green"
 move 0 0
 circle 2.5
 move 2.48 0.2
 draw 0.5 0
 draw 2.48 -0.2
 move 2.2 -1.2
 draw 1.2 -0.9
 draw 1.8 -1.7
 move 0.7 -2.4
 draw 0.2 -1
 draw 0.3 -2.45
 move -0.2 2.45
 draw 0 1
 draw 0.2 2.45
 move 1.2 2.2

vertices

Two Point Styles

used

Gate

2 pt tree

Culv
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 draw 0.9 1.2
 draw 1.7 1.8
 move -2.48 0.2
 draw -0.5 0
 draw -2.48 -0.2
 move -1.8 1.6
 draw -0.8 0.6
 draw -2.1 1.3
 move -1.6 -1.9
 draw -1.1 -0.8
 draw -1.3 -2.1
}
// Culvert
twoptstyle CULV {
  group "Two Points"
  stretch_mode 2
  cycle_mode   2

  move   8    12
  draw  10    10
  draw  14    10
  move  16    10
  draw  20    10
  move  22    10
  draw  26    10
  move  28    10
  draw  32    10
  move  34    10
  draw  38    10
  move  40    10
  draw  44    10
  move  46    10
  draw  50    10
  move  52    10
  draw  56    10
  draw  58    12
  move  58     6
  draw  56     8
  draw  56    10
  move  10    10
  draw  10     8
  draw   8     6
  move  10     8
  draw  14     8
  move  16     8
  draw  20     8
  move  22     8
  draw  26     8
  move  28     8
  draw  32     8
  move  34     8
  draw  38     8
  move  40     8
  draw  44     8
  move  46     8
  draw  50     8
  move  52     8
  draw  56     8
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  }



12d Model Reference Manual

Page 3380 October 2002Line Style Definitions

Groupstyles
A groupstyle is a combined line style which is made up of one or more linestyles, paperstyles, 
worldstyles and/or twoptstyles. 

The definition of a groupstyle is simply an optional group for the line style to belong to, and a 
list of linestyle, paperstyles, worldstyle and twoptstyle names which must have already been 
defined in the file. 

groupstyle   name {

group name

style_name_1
style_name_2

...

}

If the groupstyle name contains spaces, then it must be enclosed in double quotes “. For example, 
“style 1".

Example

// POLE
worldstyle POLE {
  group "Electricity"
  mode vertex
  circle 0.5
}
// FN
worldstyle FN {
 group "Fences"
 length 5
 draw 4 0
 move 4.4 0.6
 draw 4.6 -0.6
}
// PF
}groupstyle "PF" {
  group "Miscellaneous"
  "POLE"
  "FN"
}

vertices

Group Style

used

Pole

FN

PF
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Description of the draw_commands
move x-value y-value

move the pen from the current pen position to the new position (x-value, y-value).

draw x-value y-value

draw from the current pen position to the new position (x- value, y-value)

rmove dx-value dy-value

move relative from the current pen position through the distance (dx-value, dy-value)

rdraw dx-value dy-value

draw relative from the current pen position through the distance (dx-value, dy-value)

colour colour-name

change colour (line styles can contains more than one colour).

If colour is not defined, the line style is drawn in the colour of the string that the line style is 
applied to. If the colour-name includes imbedded spaces, then it must be enclosed within double 
quotes ".

circle radius

draw a circle of the given radius at the current pen position.

After drawing a circle, the current pen position is left at the centre of the circle.

arc radius start-angle end-angle

draw an arc of the given radius from the start angle to the end angle. A positive radius denotes 
that the arc is drawn in a clockwise direction, a negative radius means anti-clockwise. Angles are 
given in degrees, minutes and seconds in the ddd.mmssfff format.

After drawing an arc, the current pen position is left at the centre of the arc.

text text angle height "justification"
text text angle height "justification" textstyle
    or
text text angle height "justification" textstyle xfactor slant offset_width offset_height

the characters text are drawn at the current pen position with the given angle, height, 
justification and possibly textstyle, xfactor, slant, offset_width and offset_height. Angle and slant 
are given in degrees, minutes and seconds in the ddd.mmssfff format. Slant is between -45 and 
45 degrees.

The allowed justifications are

top-left top-centre top-right

middle-left middle-centre middle-right

bottom-left bottom-centre bottom-right

and the value is enclosed inside double quotes (").

After drawing text, the current pen position is left where it was before the text was drawn.

repeat num_repeats { repeat_commands   repeat_draw_commands }

The repeat command allows the set of repeat_draw_commands inside the braces (the repeat-
style) to be re-drawn a number of times (num_repeats), and with each redraw, the size of the 
repeat-style is modified.

In the definition of repeat, there can be zero or more repeat_commands from the list

xpos x-value



12d Model Reference Manual

Page 3382 October 2002Line Style Definitions

ypos y-value

rfactor value

and zero or repeat_draw_commands where repeat_draw_commands include all 
draw_commands except repeat.

Unlike style, the repeat-style is defined in terms of a local origin at (0,0). The repeat-style is 
actually drawn with this origin at the position given by the values of xpos and ypos.

The repeat-style is drawn num_repeats times and on each redraw, the distances, heights and radii 
are factored by the amount

repeat_factor = (1 - i*rfactor)

where i = 0,1,...num_repeats-1

If rfactor is not specified, it is given the default value of 1/num_repeats. The factor is then

repeat_factor = (num_repeats - i)/num_repeats

where i = 0,1,...num_repeats-1

Examples of the Repeat Command

1. To produce circles of radius 10,9,8,...1 about the origin.

repeat 10 { circle 10}

2. To produce circles of radius 10,9.5,9,...5.5 about the origin

repeat 10 { rfactor 0.05 circle 10}

More Examples of Line,  Paper and World Styles

1. draw a circle of radius 20. The origin of the style is (0,0)

worldstyle "circle" {
move 0 0
circle 20

}

2. draw a circle of radius 20. The origin of the style is (100,100)

paperstyle "circle" {
move 100 100
circle 20

}

3. draw a circle of radius 20. The origin of the style is (0,0)

linestyle "circle" {
xorigin 0
yorigin 0
move 100 100
circle 20

}

4. draw a gate symbol as a twoptstyle.

worldstyle "circle" {
group "fences"
stretch_mode 1 // one direction stretch
cycle_mode 2 // draw every second line

move 0 0
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draw 0 0.1
draw 1 0
draw 1 0.1
draw 0 0

}

5. draw concentric circles of centre (0,0) inside a box

linestyle "dot" {
xorigin 0
yorigin 0
move -5 -5
draw -5 25
draw 25 25
draw 25 -5
draw -5 -5
repeat 10 {

 move 0 0
 circle 10

}
}

6. draw an arc of absolute radius 10 in the clockwise direction from the angle 45 to the angle -45.

linestyle "arc" {
move 0 0
arc 10 45 -45

}

7. draw an arc of absolute radius 10 in the anti-clockwise direction from the angle 45 to the 
angle -45.

worldstyle "arc 1" {
 move 0 0
arc -10 45 -45

}

8. top-left justified text with a circle centred on the actual text position

linestyle "top-left" {
group text
move 0 0
circle 4
text   "<top left>" 0 10 "top-left"

}
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Symbols
Users can define their own symbols to draw at vertices of 12d Model strings. The definition of 
symbols are stored in a file called symbols.4d.

Symbols in the file can be created/edited using the Symbols Create/Edit/Delete panel which is 
brought up by double clicking on Create symbol in the Symbols expansion of the Project Tree (see 
“Symbols” in the chapter “Projects” ) brought up by the Project=>Browse option.

The Symbol Create/Edit/Delete panel acts as an interactive editor to a text file which contains the 
symbol definitions. 

The user defined symbols can be applied to each vertex of a string.  Each symbol can be made up 
of lines, arcs, circles and text. 

The units for the symbol can be in pixels, millimetres or world units. The symbol is called a

 paperstyle if the definition of the symbol is given in paper units
 worldstyle if the definition of the symbol is given in world units

A symbol applied to vertices.
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Defining Symbols
A symbol is defined in a (x,y) co-ordinate system as a series of moves, drawn, arcs, circles and text 
commands.
The bounding box of the line style is the smallest rectangle parallel to the (x,y) axis which 
contains all the moves, draws, circles and arcs of the line style. Note that moves are included in 
the bounding box even if a line isn’t drawn to the point.

The default origin of the symbol is defined to be the midpoint of the bounding box surrounding 
the symbol. The bounding box includes the points moved to and drawn to, but does not 
automatically include (0,0). Hence the calculated origin may not be (0,0).

There are xorigin and yorigin commands to override the default origin of the symbol.

 If a yorigin is set, then it is used as the y-coordinate of the symbol. If the xorigin isn’t given, then 
the xorigin is the midpoint of the x-extent of the bounding box of the symbol.

 Similarly, if a xorigin is set, then it is used as the x-coordinate of the symbol. If the yorigin isn’t 
given, then the yorigin is the midpoint of the y-extent of the bounding box of the symbol.

The default length of the line style is the horizontal size of the bounding box.

There is a length commands to override the default length of the symbol. The length must always 
be positive but it can be larger or smaller than the symbols calculated horizontal length. 
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The origin and the length of the symbol are both used in positioning and sizing the symbol.

Symbol.4d
The definitions for the available symbols are normally stored in a file called symbols.4d which is 
read in each time 12d Model opens an existing project or creates a new project. Symbol.4d is 
searched for in the standard set up paths, or is pointed to by the environment variable

SYMBOLS_4D filename

The definition of the symbols will be given in the following section “Symbol Definition” .
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Symbol Definition
The definition of a worldstyle symbol of a given name name is

worldstyle   name {

    set_up_commands

    draw_commands

}

where the set_up_commands must be before the draw_commands.

The linestyle/paper/worldstyle must have a name and if the name includes imbedded spaces, it 
must be enclosed in double quotes “.

The symbol itself is defined inside the braces where there can be zero or more set_up_commands 
from the list

length value
group name
factor value
xorigin value
yorigin value

followed by zero or more draw_commands from the list

move x-value y-value
draw x-value y-value
rmove dx-value dy-value
rdraw dx-value dy-value
colour colour_name
circle radius
arc radius start-angle end-angle
text "text" angle    height   "justification"
text "text" angle    height   "justification" "textstyle"
text "text" angle height "justification" "textstyle" xfactor slant offset _width offset_height
repeat num_repeats{ repeat_commands repeat_draw_commands}

The repeat command is a positive integer num_repeats

and zero or more repeat_commands from the list

xpos x-value
ypos y-value
rfactor value

and zero or more repeat_draw_commands where repeat_draw_commands include all the 
draw_commands except repeat.

The set_up commands for symbols will now be described followed by the  draw_commands.

set_up_commands for symbols

group
The group is used to associate symbols in pop-up menus.

If the group is not defined, the symbol is placed in a default (blank) group.

If the group name includes imbedded spaces, then it must be enclosed in double quotes ".

factor
This command factors up/down the drawing co-ordinates, heights and radii.
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xorigin, yorigin
The default origin of the symbol is defined to be the midpoint of the bounding box of the line 
style. The bounding box includes the points moved to and drawn to but does not automatically 
include (0,0). Hence the calculated origin may not be (0,0).

The xorigin and yorigin commands are used to override the default origin of the symbol.

length
If length is omitted, then length is taken to be the horizontal size of the calculated bounding box 
of the symbol.

The length must always be positive but it can be larger or smaller than the symbols calculated 
horizontal size.

The origin of the symbol and the length are both used in positioning and sizing of the symbol.

Examples

// Floolight
worldstyle FLOODLIGHT {
 group "Energex"
 mode vertex
 xorigin 0
 yorigin 0
 colour "yellow"
 circle 0.225 
 move  -.45 0 
 draw  -0.225 0 
 move .45 0
 draw 0.225 0
 move 0 -.45
 draw  0 -0.225
 move  0 .45
 draw  0 0.225
 move -.159 0.159 
 draw -0.318 0.318 
 move 0.159 0.159
 draw 0.318 0.318
 move 0.159 -0.159
 draw 0.318 -0.318 
 move -0.159 -0.159
 draw -0.318 -0.318
 move 0 0.8
 text "FL" 0 0.5 "centre-middle"
}

 Description of the draw_commands
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move x-value y-value

move the pen from the current pen position to the new position (x-value, y-value).

draw x-value y-value

draw from the current pen position to the new position (x- value, y-value)

rmove dx-value dy-value

move relative from the current pen position through the distance (dx-value, dy-value)

rdraw dx-value dy-value

draw relative from the current pen position through the distance (dx-value, dy-value)

colour colour-name

change colour (line styles can contains more than one colour).

If colour is not defined, the symbol is drawn in the colour of the string that the symbol is applied 
to. If the colour-name includes imbedded spaces, then it must be enclosed within double quotes 
".

circle radius

draw a circle of the given radius at the current pen position.

After drawing a circle, the current pen position is left at the centre of the circle.

arc radius start-angle end-angle

draw an arc of the given radius from the start angle to the end angle. A positive radius denotes 
that the arc is drawn in a clockwise direction, a negative radius means anti-clockwise. Angles are 
given in degrees, minutes and seconds in the ddd.mmssfff format.

After drawing an arc, the current pen position is left at the centre of the arc.

text text angle height "justification"
text text angle height "justification" textstyle
    or
text text angle height "justification" textstyle xfactor slant offset_width offset_height

the characters text are drawn at the current pen position with the given angle, height, 
justification and possibly textstyle, xfactor, slant, offset_width and offset_height. Angle and slant 
are given in degrees, minutes and seconds in the ddd.mmssfff format. Slant is between -45 and 
45 degrees.

The allowed justifications are

top-left top-centre top-right

middle-left middle-centre middle-right

bottom-left bottom-centre bottom-right

and the value is enclosed inside double quotes (").

After drawing text, the current pen position is left where it was before the text was drawn.

repeat num_repeats { repeat_commands   repeat_draw_commands }

The repeat command allows the set of repeat_draw_commands inside the braces (the repeat-
style) to be re-drawn a number of times (num_repeats), and with each redraw, the size of the 
repeat-style is modified.

In the definition of repeat, there can be zero or more repeat_commands from the list

xpos x-value

ypos y-value
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rfactor value

and zero or repeat_draw_commands where repeat_draw_commands include all 
draw_commands except repeat.

Unlike symbol, the repeat-style is defined in terms of a local origin at (0,0). The repeat-style is 
actually drawn with this origin at the position given by the values of xpos and ypos.

The repeat-style is drawn num_repeats times and on each redraw, the distances, heights and radii 
are factored by the amount

repeat_factor = (1 - i*rfactor)

where i = 0,1,...num_repeats-1

If rfactor is not specified, it is given the default value of 1/num_repeats. The factor is then

repeat_factor = (num_repeats - i)/num_repeats

where i = 0,1,...num_repeats-1

Examples of the Repeat Command

1. To produce circles of radius 10,9,8,...1 about the origin.

repeat 10 { circle 10}

2. To produce circles of radius 10,9.5,9,...5.5 about the origin

repeat 10 { rfactor 0.05 circle 10}

More Examples of World Styles

1. draw a circle of radius 20. The origin of the style is (0,0)

worldstyle "circle" {
move 0 0
circle 20

}

2. draw a circle of radius 20. The origin of the style is (100,100)

worldstyle "circle" {
move 100 100
circle 20

}

3. draw a circle of radius 20. The origin of the style is (0,0)

worldstyle "circle" {
xorigin 0
yorigin 0
move 100 100
circle 20

}

4. draw concentric circles of centre (0,0) inside a box

worldstyle "dot" {
xorigin 0
yorigin 0
move -5 -5
draw -5 25
draw 25 25
draw 25 -5
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draw -5 -5
repeat 10 {

 move 0 0
 circle 10

}
}

5. draw an arc of absolute radius 10 in the clockwise direction from the angle 45 to the angle -45.

worldstyle "arc" {
move 0 0
arc 10 45 -45

}

6. draw an arc of absolute radius 10 in the anti-clockwise direction from the angle 45 to the 
angle -45.

worldstyle "arc 1" {
 move 0 0
arc -10 45 -45

}

7. top-left justified text with a circle centred on the actual text position

worldstyle "top-left" {
group text
move 0 0
circle 4
text   "<top left>" 0 10 "top-left"

}
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Textstyles and Fonts
Users can define any number of textstyles and specify how they are mapped to AutoCAD style 
names or Microstation (DGN, Intergraph) font numbers.

There is one fixed spaced textstyle called "1" (the default) which is identical to the textstyle used 
in earlier versions of 12d Model.

Each textstyle has a font definition (or font 1 as the default) which defines the stroking for each 
character in the font. True Type fonts are supported and most AutoCAD SHP files can be used to 
define the fonts.

Textstyles using True Type fonts or shape file which do not use arcs in their font definition, can 
also have a slant and a x_factor.

Textstyles can be used in text strings, 4d strings, super strings, linestyles, plots and user defined 
title blocks.

Textstyles Definitions File
Textstyles can be created/edited using the Create/Edit Textstyle panel which is brought up by 
double clicking on Create textstyle in the Textstyles expansion of the Project Tree (see “Textstyles” in 
the chapter “Projects” ) brought up by the Project=>Browse option.
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The Create/Edit Textstyle panel acts as an interactive editor to a text file which contains the 
textstyle definitions. The full description of the text file will now be given. 

The definitions for the available textstyles are normally stored in a file called textstyl.4d which is 
read in each time 12d Model opens an existing project or created a new project. Textstyl.4d is 
searched for in the standard set up paths, or is pointed to by the environment variable

TEXTSTYLES_4D filename

Inside textstyl.4d, a textstyle of a given name is defined by

textstyle    textstyle_name    {

textstyle commands

}

Each textstyle must have a name and if the name includes imbedded spaces, it must be enclosed 
in double quotes ".

The textstyle itself is defined inside the braces where there can be zero or textstyle commands 
from the list

font_name text

hardware_text_dxf
or stroked_text_dxf

output_name_dxf text
input_name_dxf text

hardware_text_dgn
or stroked_text_dgn

output_name_dgn integer
input_name_dgn integer

hardware_text_model
or stroked_text_model

stroked_text
or hardware_text

fixed_height value
variable_height

fixed_slant value
variable_slant

fixed_xfactor value
variable_xfactor

The description of each command is
font_name text

Name of the font to be used to draw the characters of the textstyle. The stroking of the font 
characters can be defined in the file fonts.4d. If no font_name is given, or the stroking is not 
given in the font file, then the standard 12d Model font is used ("1").

hardware_text_dxf or stroked_text_dxf

If stroked_text_dxf appears, then any text in this textstyle written out to dxf will be stroked - that 
is, broken into straights, lines and curves.

If hardware_text_dxf is in the file, then any text in this textstyle sent to dxf will be given as actual 
dxf text (not stroked).
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output_name_dxf dxf_style_name

If text is sent to dxf as hardware text, the dxf style of the text will be dxf_style_name.

input_name_dxf dxf_style_name

When reading in dxf files, any text of style dxf_style_name will be given the 12d Model textstyle 
name textstyle_name.

The commands for reading and writing dgn files are similar to those for dxf except that dgn has 
font numbers.

hardware_text_dgn or software_text_dgn

output_name_dgn dgn_font_number
input_name_dgn dgn_font_number

hardware_text_model or stroked_text_model

Similarly, when writing out to a 12d Model model. For hardware_text_model, text will be sent to 
text with the same textstyle.

stroked_text or hardware_text

If stroked_text appears in the definition and there is no other hardware_text flag set, then the text 
will be stroked - that is, broken into straights, lines and curves.

If hardware_text appears in the definition, then the text is written out as hardware text.

By default, the height, slant and xfactor for the text can be set when text is defined however it is 
possible to set each of height, slant and xfactor to a fixed value.

fixed_height valueor
variable_height

If fixed_height and a value are specified, then all text in this textstyle is drawn at a fixed height. If 
fixed_height is missing or variable_height (the default) appears, then each text string in the 
textstyle has its own height.

fixed_slant valueor
variable_slant

If fixed_slant and a value are specified, then all text in this textstyle is drawn at a fixed slant. If 
fixed_slant is missing or variable_slant (the default) appears, then each text string in the textstyle 
has its own slant. Slant is given in degrees, minutes and seconds in the ddd.mmssfff format and 
must be between -45 and 45 degrees.

fixed_xfactor valueor
variable_xfactor

If fixed_xfactor and a value are specified, then all text in this textstyle is drawn at a fixed xfactor. 
If fixed_xfactor is missing or variable_xfactor (the default) appears, then each text string in the 
textstyle has its own xfactor.

Example of a Textstyle File

textstyle  "1" { // DGN FONT 0 ACAD FONT STANDARD

output_name_dxf STANDARD
input_name_dxf STANDARD
input_name_dgn "0"
output_name_dgn "0"
stroked_text
hardware_text_model
hardware_text_dgn
hardware_text_dxf

}



Appendix K

October 2002 Page 3395Textstyles and Fonts

textstyle ISO { // DGN FONT 1 ACAD FONT ISO

font_name ISO
input_name_dxf ISO
output_name_dxf ISO
input_name_dgn "1"
output_name_dgn "1"
stroked_text
hardware_text_model
hardware_text_dgn
hardware_text_dxf

}

textstyle MONO { // DGN FONT 2 ACAD FONT MONO

font_name         MONO
output_name_dxf   MONOTXT
input_name_dxf    MONOTXT
input_name_dgn    "2"
output_name_dgn   "2"
stroked_text
hardware_text_model
hardware_text_dgn
hardware_text_dxf 

}

textstyle SCRIPT { // DGN FONT 3 ACAD FONT SCRIPTC

font_name         SCRIPT
output_name_dxf   SCRIPTC
input_name_dxf    SRCIPTC
input_name_dgn    "3"
output_name_dgn   "3"
stroked_text
hardware_text_model
hardware_text_dgn
hardware_text_dxf 

}

Please see the next section “Fonts Definitions File” for a description of the fonts file.

Fonts Definitions File
The definition of any fonts referred to in the textstyl.4d file are given in the fonts.4d file which is 
searched for in the standard 12d Model set up paths, or is pointed to by the environment variable

FONTS_4D filename

The stroking for each character in the font (which is used when drawing the text on the screen 
and when required, stroking the text for outputs and plots) can be given in a separate file in the 
Autocad shape file format.

Inside fonts.4d, a font of a given name is defined by

font font_name {

font commands

}

Each font must have a name and if the name includes imbedded spaces, it must be enclosed in 
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double quotes  ".

The font itself is defined inside the braces where there can be zero or more font commands from 
the list

stroke_file filename

proportional

or fixed

The description of each command is

stroke_file stroke_file_name

The name of the file containing the stroking for each character in the font in Autocad ascii shape 
file format (.shp). The stroke_file_name is searched for in the standard 12d Model set up paths. 

If the stroking for a character is not defined, the standard 12d Model character is used instead.

proportional or fixed

If a stroke file is not given, then the font could be a fixed (mono) or proportional font.

Example of a Font File

font ISO {

proportional
stroke_file "ISO"

}

font GOTHIC {
 

proportional
stroke_file "GOTHICE.SHP"

}

font MONO {

proportional
stroke_file "MONOTXT.SHP"

}
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L Functions Keys, Menus, Toolbars

User Defined Function Keys
The user can define function keys (with possible modifiers) to be used to 

(a) bring up most 12d Model menus or panels

(b) toggle certain snaps on or off.

(c) start some geometry snaps

(d) read a layout file

(e) execute a batch file or a program (system call).

(f) run users 12d Model macros

The function key definitions are given in the file 

userkeys.4d

which is searched for in the standard set up areas (local, USER_4D, user, set_ups etc.) or is pointed to by 
the environment variable

FUNCTION_KEYS_4D file // function key definitions

The format of the function_keys file is simply a list of function key definitions with only one per lines. 
Blank lines in the file are ignored and anything on a line after a // is a comment.

The function key definition is

MODIFIERS FUNCTION_KEY OPERATION

where MODIFIERS can be totally missing or any combination of

shift
control

or alt

 FUNCTION_KEY is one of

f1, f2,...f12 (f7 should be avoided since it is used in 12d Model for typed input,
f1 & f10 should be avoided since they are reserved by Windows NT)

and OPERATION is one of

menu menu_name // raise a menu 
panel panel_name // raise a panel
snap toggle_snap // list of toggle_snaps given below
snap cogo_snap // list of cogo_ snaps given below
cogo_command // list of cogo_ commands given below
layout layout_file_name // run a screen layout file
system batch_file // run a batch file
system program // run a program

or for macros
macro options user_macro_name macro_arguments

where the macros options are:

-no_console // don’t display macro console
-close_on_exit // remove console when macro terminates
-buttons // have buttons for finish, restart and quit on console
-allow_defaults // allow default answers for console questions
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The default when there are no macro options is to run the macro with a console but without buttons, and to 
leave the macro console on the screen when the macro terminates.

Menus and Panels

Menus and panels can be programmed by functions keys by simply giving the name of the menu and panel 
after the menu and panel command respectively.

For example,

f5 panel "String Inquire"
f6 menu "String Create"

View Menus and Panels

Menus and panels for views can be programmed by functions keys by substituting the text $PLAN_VIEW, 
$SECTION_VIEW or $PERSPECTIVE_VIEW in place of the view name in the panel name or menu 
name.

For example,

f9 panel "Plan Plot $PLAN_VIEW".

A panel for each view type can be programmed for the same modifier and function key combination. If the 
cursor is over the appropriate view type when the function key is selected, then the panel is fired up.

For example, the three definitions for f5

f5 panel "Section Plot $SECTION_VIEW"
f5 panel "Plan Plot $PLAN_VIEW"
f5 panel "Perspective Plot $PERSPECTIVE_VIEW"

means that a panel will come up when f5 is selected over any of the three view types.

View Toggle Menus

The toggle menus available on each view can be set to a function key by

MODIFIERS FUNCTION_KEY menu "Toggle $PLAN_VIEW"
MODIFIERS FUNCTION_KEY menu "Toggle $SECTION_VIEW"
MODIFIERS FUNCTION_KEY menu "Toggle $PERSPECTIVE_VIEW"

As for the view menus, the cursor must be over the appropriate view type when the function key is 
selected.

For example,
shift f8 menu  "Toggle $PLAN_VIEW"

brings up the plan view toggle menu if   shift f8 is selected when in a plan view.

Available Snaps to be Toggled

toggle_point_snap
toggle_line_snap
toggle_grid_snap
toggle_cursor_snap
toggle_tin_snap
toggle_input_height_snap
toggle_show_information

For example,
control f2         toggle_point_snap

Available Cogo Snaps

snap create_edit
snap line_create_edit
snap tangent_items_edit
snap fillet_3_points_edit
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snap fillet_item_item_cp_edit
snap fillet_item_item_radius_cp_edit
snap locate_divide_edit
snap locate_divide_distance_edit
snap parallel_edit
snap intersect_edit
snap intersect_offset_edit
snap bearings_intersect_edit
snap between_points_edit
snap locate_edit
snap locate_chainage_edit
snap locate_offset_edit
snap locate_deflection_edit
snap locate_drop_perpendicular_edit
snap locate_projection_edit
snap locate_two_point_distances_edit

For example,
shift f1 snap locate_chainage_edit

Available Cogo Commands

All the new cogo commands can be activated by a function key.

create_edit
line_create_edit
tangent_items_edit
fillet_3_points_edit
fillet_item_item_cp_edit
fillet_item_item_radius_cp_edit
locate_divide_edit
locate_divide_distance_edit
parallel_edit
intersect_edit
intersect_offset_edit
bearings_intersect_edit
between_points_edit
locate_edit
locate_chainage_edit
locate_offset_edit
locate_deflection_edit
locate_drop_perpendicular_edit
locate_projection_edit
locate_two_point_distances_edit

For example,
f2 between_points_edit

Layout Files

Layout files can be called up using the layout command.
For example,

f8 layout "/temp/contours.slf"

System Calls

Programs and batch files can be called up using the system command. The directories defined by the 
environment variables $LIB_4D and $USER_4D are included in the PATH environment variables so that 
any batch files or executables in these areas will be accessible without including any path name in the 
system call.

For example,
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f4 system special.exe // run the program special.exe
shift f4 system batch.bat // run a batch file
control f4 system "start cmd /k  dir" // do a dir in a command shell

Macros

User macros can be run and the macros brought up with or without buttons, and with leaving or removing 
the macro console when the macro has finished.

The macro command structure and options are:

macro options user_macro_name macro_arguments

where the macros options are:

-no_console // don’t display macro console
-close_on_exit // remove console when macro terminates
-buttons // have buttons for finish, restart and quit on console
-allow_defaults // allow default answers for console questions

The default when there are no macro options is to run the macro with a console but without buttons, and to 
leave the macro console on the screen when the macro terminates.

For example,

f8 macro -no_console -close_on_exit"/area/drape_align.4do"
f9 macro -buttons "/games/lots.4do"

For compatibility with earlier versions of 12d Model, the following macro commands are also supported:
macro user_macro_name // run macro without buttons,

// leave console panel on exit
macro_2 user_macro_name // run macro without buttons, 

// remove console panel on exit
macro_with_buttons user_macro_name // run macro with buttons,

// leave console panel on exit
macro_with_buttons_2 user_macro_name // run macro with buttons,

// remove console panel on exit

$LIB and $USER_LIB

The variable $LIB and $USER_LIB can be used as part of the layout_file_name and user_macro_name to 
pick up files from either the library or user library.

For example,

f7 macro "$LIB/drape_align.4do"
f8 macro "$USER_LIB/lots.4do"
f9 layout "$LIB/contours.slf"

Note - if $LIB_4D is not defined, then 12dmodel/6.00/libarary is used. If $USER_LIB_4D is not defined, 
then 12dmodel/6.00/user_lib is used

Example of a User Function Key File

// File to define function key usage
// Note: f1, f6 & f10 are reserved by Windows NT
//  f7 is reserved by 4D Solutions for typed input
// Available function key modifiers are

// shift control alt

// Note: some alt key combinations are reserved by Windows NT

// Some sample lines may be

// f5 toggle_point_snap
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// shift f5 toggle_line_snap
// control shift f7 toggle_input_height_snap

// Note that all function key modifiers must come before the function key itself.

// -----------------------------------------------------

// snaps

f3         toggle_point_snap
f4         toggle_line_snap
f5         toggle_grid_snap
f5         toggle_cursor_snap
f8         toggle_input_height_snap
// snaps cogo

f9      snap intersect_offset_edit
f11     snap locate_chainage_edit
f12     snap locate_drop_perpendicular_edit

// panels

f2 panel "String Inquire"

shift f1   panel "Edit String"
shift f2   panel "String Delete"
shift f3   panel "Clean Model"
shift f4   panel "Delete Model"
shift f5   panel "Strings Edit Ops"
shift f6   panel "Points Edit Ops"
shift f7   panel "String Attributes"
shift f8   panel "Toggle $PLAN_VIEW"

// layout files

control f4 layout "$LIB/tri_contour_clean.slf"

// user macros

control f5 macro -no_console -close_on_exit "$LIB/Culd.4do"

// -----------------------------------------------------
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User Defined Menus
To help customise 12d Model, there is a pull down menu User on the Main menu and User menus on each 
of the pull down menus on the Main menu.

The user menus are made up of buttons which have text on them and when the left hand mouse button 
(LB) is pushed down and released on a button, a command is executed.

A button can also have a walk-right menu which appears when the left hand mouse button (LB) is moved 
over the arrow on the right had side of the button. Walk-right menus can have walk-right menus.

All the User menus can be created by the user and are defined in the file Usermenu.4d. Some items on the 
User menus are supplied by 4D Solutions and these are defined in the file Xtramenu.4d.

The text for each button of User, plus the action taken when the button is selected is user specified. Any of 
the buttons can include further walk-right menus.

When a button is selected, the action can be to

(a) run a 12d Model macro

(b) bring up a 12d Model menu

(c) bring up a 12d Model panel

(d) read a layout file

(e) execute a batch file or program (system call)

Full Definition of User Menus
The definition for the User menus is given in a file called

Usermenu.4d

which is searched for in the standard set up areas (local, USER_4D, user, set_ups etc.) or set by the 
environment variable

button on user menu

User menu

walk-right arrow on a menu
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USER_OPTIONS_4D file // User menu definition

In the Usermenu.4d file, a menu is defined by:

Menu menu_name {
button_1
button_2
...
button_n

}

where a button can include one or both of the commands Command and Walk_Right, and the syntax for 
button is

Button button_name {
Walk_Right menu_name_1

and/or Command command_name
} 

The text displayed on the button is button_name and the definitions of the Walk_Right and Command 
commands are:

Walk_Right

The Walk_Right command specifies that there is a walk-right menu for the button and gives the name of 
the menu that is displayed when LB is moved over the walk-right arrow on the button.

The Walk_Right command consists of the word Walk_Right followed by one or more spaces and then the 
name of the menu that is displayed when over the walk-right arrow.

Walk_Right menu_name

where menu_name is the name of another menu defined elsewhere in the usermenu.4d file.

When the Walk_Right command exists, a walk-right arrow is created on the button. If there is no 
Walk_Right command, then there is no walk right arrow on the button.

The Walk_Right command is optional.

NOTE - walk-right menus can contain walk-right menus.

Command

The Command command defines what action occurs if LB is clicked on the button. The Command 
consists of the word Command followed by one or more spaces and then the name of the command and 
any arguments it requires.

Command command_name

The Command can bring up any one of

(a) user defined 12d Model macro

Command "macro macro_options user_macro_name macro_parameters" // run macro

where the macros options are:

-no_console // don’t display macro console
-close_on_exit // remove console when macro terminates
-buttons // have buttons for finish, restart and quit on console
-allow_defaults // allow default answers for console questions

The default when there are no macro options is to run the macro with a console but without buttons, and to 
leave the macro console on the screen when the macro terminates.
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(b) 12d Model menu

Command "4d_model_menu_name"

(c) 12d Model panel

Command "4d_model_panel_name"

(d) user defined layout file

Command "layout   layout_file_name"

(e) execute a batch file or program

Command "system   program_or_batch_file_name"

The Command command is optional.

$LIB and $USER_LIB

The variable $LIB and $USER_LIB can be used as part of the layout_file_name and user_macro_name to 
pick up files from either the library or user library.

Note - if $LIB_4D is not defined, then 12dmodel/6.00/libarary is used. If $USER_LIB_4D is not defined, 
then 12dmodel/6.00/user_lib is used

For example, the definition of a menu called "Lots" could be:

Menu "Lots" {
Button "Create lots" { // button called "Create lots" which

Command "macro -close_on_exit $USER_LIB/subdiv.4do" // fires up a 12d Model macro
}
Button "Roads" { // button with walk-right menu "Roads" and layout file

Walk_Right "Roads" // walk-right menu "Roads"
Command "layout $USER_LIB/road.slf" // button invokes a layout file if selected

}
}

If a menu called User exists in the file, it defines the walk-right menu for User on the Main menu.

Since all menus and sub-menus on the Main menu have a unique name, it is also possible to defined a User 
menu for any of them by simply having a menu called "User menu_name" in Usermenu.4d. 

For example, the menu for the option Strings=>Create is called String Create (String not Strings) so the 
User menu for Strings=>Create would be called "User String Create":

Menu "User String Create" {
Button "Create 4d strings" {

Command "macro  -close_on_exit  $USER_LIB/ref_points.4do"
}
Button "Create point strings" {

Command "macro  -close_on_exit  $USER_LIB/x_sects.4do"
}

}
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All other menu names in Usermenu.4d are user specified and can be used to define walk-right menus.

Any menu referred to in the file Usermenu.4d must be either the name of a standard 12d Model menu, a 
User menu or must be defined somewhere in the file.

Notes

(a) The variables $LIB and $USER_LIB can be used as part of the layout_file_name and 
user_macro_name to pick up files from either of the libraries.

(b)  blank lines are ignored and anything on a line after a // is a comment

Example of a User Defined Menu

// the definition of Main menu option "User"

Menu "User" { // User menu on Main menu
Button "Triangulate" { // button called Triangulate which brings up

Command "Triangulate a View" // the "Triangulate a View" panel
}
Button "Lots" { // button called Lots with its 

Walk_Right "Lots" // own walk-right menu called Lots
}
Button "Roads" { // button with walk-right menu "Roads"

Walk_Right "Roads"
Command "layout $LIB/road.slf" // button invokes a layout file if selected

}
}

// the definition of the walk-right menu Lots

Menu "Lots" {
Button "Create lots" {

Command "macro $LIB/subdiv9.4do"
}
Button "Label lots" {

Command "macro $LIB/subnum3.4do"
}  



12d Model Reference Manual

Page 3406 February 2003User Defined Menus

Button "Write Lot Levels" {
Command "macro $LIB/Tinval.4do"

}
}

// the definition of the walk-right menu Roads

Menu "Roads" {
Button "Roundabout" {

Command "macro $LIB/Round.4do"
}
Button "Culdesac bulb" {

Command "macro $LIB/Culd.4do"
}
Button "Drape alignment string" {

Command "macro $LIB/Drape_al.4do"
}
Button "Create Table drain" {

Command "macro $LIB/Table_dr.4do"
}

}

// the definition of User on the Main menu option Strings=>Create"

Menu "User String Create" { // User menu on option Strings=>Create
  Button "Create ref points" {

Command "macro  -close_on_exit  $LIB/ref_points.4do"
}
Button "Create X-sections" {

Command "macro  -close_on_exit  $LIB/x-Sects.4do"
}

}
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User Defined Toolbars
A toolbar is made up of buttons which can have a picture on them (icons) and when the left hand mouse 
button (LB) is pushed down and released on the button, a command is executed.

A button can also have a flyout toolbar which appears when the left hand mouse button (LB) is held down 
on the button (note that there can only be one level of flyouts).

The definitions for toolbars in 12d Model are stored in a file called toolbars.4d. When 12d Model is 
installed, toolbars.4d is installed in the 12d Model folder Set_Ups.

To customise 12d Model toolbars, a user can modify toobars.4d and save the modified version in the 
folder Users.

The icon for each button on a toolbar, plus the action taken when the button is selected is user specified. A 
button can include a fly-out toolbar but flyouts can only be to one level (i.e. no flyouts on flyouts).

When a button is selected, the action can be to

(a) run a 12d Model macro

(b) bring up a 12d Model menu

(c) bring up a 12d Model panel

(d) read a layout file

(e) execute a batch file or program (system call)

When 12d Model starts up, any toolbars defined in toolbars.4d that are not called as flyouts by another 
toolbar in toolbars.4d, are displayed in the main toolbar on the left hand side of the 12d Model screen.

For 12d Model V6.0, toolbars can be moved around but the new positions are not saved with the project. 
Also there is no way within 12d Model to select which toolbars are used for a project - all the ones defined 
in toolbars.4d are used whenever a new or existing project is loaded into 12d Model V6.0.

Full Definition of Toolbars
The definition for Toolbars is given in a file called

Toolbars.4d

which is searched for in the standard set up areas (local, USER_4D, user, set_ups etc.) or set by the 
environment variable

TOOLBARS_4D file // Toolbars definition

main toolbar

flyout toolbar

icon (pictures)
on the buttons
on the toolbar
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In the toolbars.4d file, a toolbar is defined by:

Toolbar toolbar_name {
button_1
button_2
...
button_n

}

where a button can include none or more the commands Icon, Command and Flyout, and the syntax for 
button is:

Button button_name {
Icon icon_name_1
Command command_name_1
Flyout toolbar_name_1 // only used if a flyout toolbar is required

} 

The definitions of the Icon, Command and Flyout commands are:

Icon

The Icon command defines the bitmap that is displayed for the button in the toolbar. The format of the 
bitmap is a bmp file (.bmp) of size 16x16. The Icon command consists of the word Icon followed by one or 
more spaces and then the name of the bitmap, icon_name.

Icon icon_name

The icon_name can include a pathname but if no pathname is present, the bitmap is searched for in the 
folder Images under the folders User or Set_Ups.

If the Icon command is missing then a default Icon command is used with the icon_name 
button_name.bmp

Icon button_name.bmp

Command

The Command command defines what action occurs if LB is clicked on the button. The Command 
command consists of the word Command followed by one or more spaces and then the name of the 
command and any arguments it requires.

Command command_name

The Command can bring up any one of

(a) user defined 12d Model macro

Command "macro macro_options user_macro_name macro_parameters" // run macro

where the macros options are:

-no_console // don’t display macro console
-close_on_exit // remove console when macro terminates
-buttons // have buttons for finish, restart and quit on console
-allow_defaults // allow default answers for console questions

The default when there are no macro options is to run the macro with a console but without buttons, and to 
leave the macro console on the screen when the macro terminates.

(b) 12d Model menu

Command "4d_model_menu_name"

(c) 12d Model panel
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Command "4d_model_panel_name"

(d) user defined layout file

Command "layout   layout_file_name"

(e) execute a batch file or program

Command "system   program_or_batch_file_name"

If the Command command is missing then a default Command is used with the command name 
button_name with no arguments

Command button_name

Flyout

The Flyout command defines what toolbar is displayed when LB is help down on the button. The Flyout 
command consists of the word Flyout followed by one or more spaces and then the name of the toolbar 
that is displayed.

Flyout flyout_toolbar_name

where flyout_toolbar_name is the name of another toolbar defined elsewhere in the toolbars file.

When the Flyout command exists, Icon and Command are not required and if they are present, are ignored.

The icon on the Flyout button is the Icon from the first button in the flyout toolbar.

The command executed if LB is pressed and released on the Flyout button is the Command from the first 
button in the flyout toolbar.

NOTE - flyouts can not be nested so the toolbar flyout_toolbar_name can not contain a Flyout command.

NOTE - when 12d Model starts up, any toolbars defined in toolbars.4d that are not called as flyouts by 
another toolbar in toolbars.4d, are displayed in the main toolbar on the left hand side of the 12d Model 
screen.

Example of a User Defined Toolbar

// ---------------------------------------------
// WARNING: you cannot have the same command using different icons
// ALSO: when using a flyout, the Command & Icon are ignored
//       and the details are taken from the first button
//       on the flyout
// ---------------------------------------------

Toolbar "Cad" {
Button "Points" {

Command "Create Point"  // this is ignore since it is a flyout
Icon    "Create Point.bmp" // this is ignore since it is a flyout

Flyout  "Cad Points"
}
Button "Change String" {

Flyout  "Change String"
}

Toolbar "Cad Points" { // used as a flyout toolbar
Button "Create Point" {

Command "Create Point"
Icon    "Create Point.bmp"

}
Button "Chainage" {

Command "Locate Chainage"
Icon    "Chainage.bmp"

}
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}  // end of "Cad Points" toolbar

Toolbar "Change String" { // used as a flyout toolbar
Button "String Close" {

Command "String Close"
Icon    "String Close.bmp"

}
Button "String Reverse" {

Command "String Reverse"
Icon    "String Reverse.bmp"

}
Button "String Trim" {

Command "String Trim"
Icon    "String Trim.bmp"

}
}  // end of "Change String" toolbar

$LIB and $USER_LIB

The variable $LIB and $USER_LIB can be used as part of the layout_file_name and user_macro_name to 
pick up files from either the library or user library.

Note - if $LIB_4D is not defined, then 12dmodel/6.00/libarary is used. If $USER_LIB_4D is not defined, 
then 12dmodel/6.00/user_lib is used

For example, the definition of a toolbar called "Lots" could be:

Toolbar  "Lots" {
Button "Create lots" { // button called "Create lots" which

Command "macro -close_on_exit $USER_LIB/subdiv.4do" // fires up a 12d Model macro
}
Button "Roads" { // button with walk-right menu "Roads" and layout file

Walk_Right "Roads" // walk-right menu "Roads"
Command "layout $USER_LIB/road.slf" // button invokes a layout file if selected

}
}

Notes

(a) The variables $LIB and $USER_LIB can be used as part of the layout_file_name and 
user_macro_name to pick up files from either of the libraries.

(b)  blank lines in the toolbars file are ignored and anything on a line after a // is a comment

Another Example of a Toolbar

Toolbar "Cogo" {

// in this case, the Command is assumed to be "Create Line"

// the icon is "Create Line.bmp"

// Command is normally the name of the panel/menu

  Button "Create Line" {

  }

// this is a spacer

  Button "" {

  }
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// this is a command and also has a flyout capability

// calling the toolbar called Flyout

// flyouts cannot be nested

  Button "Create Fillet by radius" {

    Command "Create Fillet by radius"

    Icon    "Create Fillet by radius.bmp"

    Flyout  "Flyout"

  }

}

// The flyout toolbar for above (and a normal toolbar as well)

Toolbar "Flyout" {

  Button "Create Line" {

  }

  Button "" {

  }

  Button "Create Arc by Centre Radius" {

    Command "Create Arc by Centre Radius End Points"

    Icon    "Create Arc by Centre Radius End Points.bmp"

  }

  Button "Create Fillet by radius" {

    Command "Create Fillet by radius"

    Icon    "Create Fillet by radius.bmp"

  }

}
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Default File Ending
In any panel pop-up requiring a file name to be displayed, default file endings are used to restrict the 
names of the files selected from the current folder and if they exist, from the library and user library areas.

Whilst a panel is up, the extension being searched for can be changed by typing say "*.xyz" into the panel 
field requiring a file name, and then pressing <enter>. The list of files ending in .xyz will be displayed and 
clicking B3 in the panel field will also bring up a list of all files ending in ".xyz". When a new panel is 
created, the panel fields revert to the default file ending.

A full list of the default files used in 12d Model pop-ups and their endings is:

File Type Default Ending

Miscellaneous Files

boxing definitions file .bf
digitizer registration .aff
eagle mapping .emf
many templates .mtf
mapping .mf
reports .rpt
screen layout file .slf
templates .tpl
text style file .tsf

Survey Files

12d Model field file .fld
reduction history .rh

Input/Output Files

4D ascii .4da
12d ascii .12da
AutoCAD .dxf
BCC Epson dat files .dat
BCC Epson sur files .sur
CivilCad V4 .asc
CivilCad V5 .as5
Eagle command .cmd
Eagle binary .mod
Geocomp .pts
Keays .trf
Microstation,
Intergraph binary .dgn
Moss .mos
TP Setout .pta
xyzs data .dat

Range Files

aspect range .arf
depth range .drf
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slope range .srf

Plot Files

AutoCAD .dxf
CalComp .cal
DGN (Microstation,
Intergraph) .dgn
Dogs .par
Eagle .mod
Frame maker .mif
HP GL .hp
HP 7475 .hpa
HP GL 7600 .hpm
HP GL 2 (colour) .hpc
pcl5 .pcl5
PostScript .ps

Display Files - dumps, movies

gif .gif
jpeg .jpg
Windows bitmap .bmp
Tiff .tif
PostScript .ps
screen layout file .slf

4DML’s - 12D Solutions programming/macro language

macro source file .4dm
macro object/executable .4do
macro listing .4dl

Note

This list is for the default files used in 12d Model panel fields. It does not include 12d Model setup files 
which are given in the Appendix Set Ups.
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Special 12D Solutions File Formats
12D Solutions has a number of special file formats, most of which have already been specified. The 
remaining formats will now be given.

In any of the files, blank lines ignored and any information after // until the end of that line is ignored. 
Hence comments can easily be inserted into the files by preceding them by //.

Unless enclosed in quotes ("), more than one consecutive space or tab are treated as one space.

Eagle Map File
An eagle map file is a user created file consisting of a list of 12d Model colours and the Eagle pen, dash 
style, pen thickness and frag to be used for the colour.

The map file is set out with one 12d Model colour per line. The line begins with the 12d Model colour 
followed by the Eagle pen number, dash style, thickness and frag to be used for the 12d Model colour. 
Each item is separated by one or more spaces.

For example, if the 12d Model colour red is to be mapped to Eagle pen 3, dash style 4, thickness 2 and 
frag 1, then the line in the eagle map file would be 

red 3 4 2 1

An eagle map file can be used for writing out three dimensional data to Eagle, or when producing plots in 
Eagle format.

For plotting, the map file must be called eagleplt.emf.

When writing three dimensional data out to Eagle, a user specified file name is allowed.

In the output case, as each string is written out, the map file is searched sequentially until a colour match is 
made. If no match is found, the colour of the string is used as a pen number and default values used for 
dash, thickness and frag.

Comments can be included in the map file by preceding the comment with a double forward slash (i.e. //). 
Anything on the line following the // will be ignored.

An example of an Eagle map file is,

//12d Model colour to Eagle mapping file
//
//12d Model colour eagle pen dash thickness frag

black  0  1 1   1
red 2  0 1   5
green 4  1 1   1
blue 4  2 1  11
cyan 5  1 1   1
yellow 6  1 1   1
magenta 7  1 1   1
white  1  1 1   1
orange  15  1 1   1
purple 14  1 1   1
grey  13  1 1   1
"dark green" 12  1 1   1
"dark red" 11  1 1   1
"off yellow" 4  1 1   1
"dark blue" 8  1 1   1
brown  11  1 1   1
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Template File
The 12D Solutions Template file format is a simple ascii file definition for reading and writing out 
template definitions for use in the apply options in 12d Model.

The template definition begins with the key word template followed by the template name and then the 
definitions of 

fixed, cut, fill and final parts of the template

or fixed and decision parts

 all enclosed within curly braces { }.

template fred { template fred {

fixed { fixed {
 ...  or    ...
} }

  cut { decisional {
    ...     ...

}
  fill {
    ...
  }
  final {
    ...
  }
}

The definition of the fixed part of the template begins with the key word fixed followed by a list of the 
links enclosed in curly braces {}.

The links are defined one per line in order from the centre-line. Each link begins with the keyword link 
followed by the width, percent cross-fall, colour and name for each link. For the percent cross-fall, positive 
means up, negative is down and zero horizontal.

For example,

fixed {
link 3.5 -3 cyan kerb
link 1 -4 magenta shoulder
link 2 -5 blue verge

}

describes a fixed template with three links, the first of width 3.5 with a 3% cross-fall downwards, the next 
link of width 1 with 4% cross-fall downwards and the third link of width 2 and 5% cross-fall downwards.

The definition of the cut part of the template begins with the key word cut followed by a list of the links 
enclosed in curly braces {}.

The links are defined one per line in order from the end of the fixed template (or centre-line if no fixed part 
exists). Each link begins with the keyword link followed by the width, one in slope, colour and name for 
each link. For cut, the one in slope is positive for up, negative for down, and zero for horizontal.
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For example,

cut {
link 3 2 yellow a
link 2 0 magenta b
link 3 -1 yellow c
link 2 0 magenta d

}

describes a cut template with four links, the first of width 3 with 1:2 slope upwards, the next link of width 
2 horizontally, the third link of width 3 and 1:1 slope downwards and width 2 horizontally.

The definition of the fill part of the template begins with the key word fill followed by a list of the links 
enclosed in curly braces {}.

The links are defined one per line in order from the end of the fixed template (or centre-line if no fixed part 
exists). Each link begins with the keyword link followed by the width, one in slope, colour and name for 
each link. For fill, the one in slope is positive for down, negative for up, and zero for horizontal. Please 
note that this is the opposite to cut.

For example,

fill {
link 5 2 yellow e
link 1 0 magenta f
link 10 -1 yellow g

}

describes a fill template with three links, the first of width 5 with 1:2 slope downwards, the next link of 
width 1 horizontally, and the third link of width 10 and 1:1 slope upwards.

The definition of the final part of the template begins with the key word final followed the cut slope, fill 
slope and search distance enclosed in curly braces {}. The key words for the three values are cut_slope, 
fill_slope and search_distance.

For example,

final {
cut_slope  1  fill_slope  2  search_distance  100

}

describes a final cut slope of 1:1 (upwards), fill slope of 1:2 downwards and template with three links, the 
first of width 5 with 1:2 slope downwards, both going for a maximum distance of 100.

The definition of the decisions part of the template begins with the key word decisional followed by a list 
of the decision commands enclosed in curly braces { }.

The decision commands are defined one per line and have the format:

Fixed Xfall Width value Height value XFall value Name text Colour colour

Fixed Slope Width value Height value Slope value Name text Colour colour

Tin Width tin_name Strip value width value Name text Colour colour

String Offset string_name Strip value Offset value Name text Colour colour

Batter tin_name Strip value Width value Height value Slope value Name text
Colour colour Goto label

Tin Decision tin_name Offset value Min value Max value Goto label

Label label_name
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Goto label_name

End

For example,

template "std" {
fixed {

link 3 unknown -3 cyan "kerb"
link 1 unknown -4 magenta "shoulder"
link 2 unknown -5 purple "verge"

}
decisional {

    Tin_Decision "rock" 0 0 1000 "cut_rock"
    Tin_Decision "shale" 0 0 1000 "cut_shale"
    Tin_Decision "terrain" 0 0 1000 "cut_terrain"
    Label "fill_terrain"
    Batter "terrain" 0 8 unknown -3 "f1" blue "alldone"
    Batter "terrain" 0 1 unknown 0 "f2" "dark green" "alldone"
    Goto "fill_terrain"
    Label "cut_rock"
    Tin_Decision "rock" 0 0 0.3 "cut_rock_done"
    Batter "rock" 0.3 5 unknown 0.5 "r1" cyan "cut_rock_done"
    Batter "rock" 0 2.5 unknown 0 "r2" yellow "cut_rock_done"
    Goto "cut_rock"
    Label "cut_rock_done"
    Tin_Decision "shale" 0 0 1000 "cut_shale"
    Goto "cut_shale_done"
    Label "cut_shale"
    Tin_Decision "shale" 0 0 0.6 "cut_shale_done"
    Batter "shale" 0.6 6 unknown 1 "s1" magenta "cut_shale_done"
    Batter "shale" 0 3 unknown 0 "s2" "dark red" "cut_shale_done"
    Goto "cut_shale"
    Label "cut_shale_done"
    Tin_Decision "terrain" 0 0 1000 "cut_terrain"
    Goto "alldone"
    Label "cut_terrain"
    Batter "terrain" 0 3 unknown 1.5 "t1" red "alldone"
    Batter "terrain" 0 2 unknown 0 "t2" green "alldone"
    Goto "cut_terrain"
    Label "alldone"
}

}

Notes

1. spaces in text - any text string that includes spaces or only numbers, must be enclosed in double quotes 
".

2. comments - anything after // until the end of the line is ignored.

3. blank lines - blank lines are ignored
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Screen Layout File
The 12d Model screen layout file is a simple text file definition for reading and writing out the 
information about 12d Model panels and menus.

The definition includes a screen position for the panel or menu, and for panels, the values for any of the 
panel fields.

At any time, the layout of the menus and panels on the screen in a 12d Model session can be written out 
using the menu option

 File i/o=>Layout output.

Also, the layout for an individual panel or menu can be created by clicking RB in the menu/view title area 
and selecting the dump option to bring up the Menu/Panel Dump panel.

An example of a screen layout file is:

Panel "Read x y z s Data" {
Position 116 187
Field "File" "faces.dat"
Field "Map file" ""
Field "Prefix for models" ""
Field "Default line colour" "magenta"
Field "Default point colour" "yellow"
Field "Default model for data" "faces"
Field "Add to view" "1"

}
Panel "Triangulate a Model" {

Position 397 187
Field "Model to triangulate" "faces"
Field "New tin name" "faces"
Field "Tin colour" "green"
Field "Tin style" "1"
Field "Model for tin" "tin faces,1,2"
Field "Preserve strings" "true
Field "Weed tin" "true"
Field "Remove bubbles" "true"   // for a tick-cross box

//case sensitive
Field "Face data" "true" // true, false, yes,

// no, 0 ,1
Run "Triangulate"

}
Menu "Triangles" {

Position 300 400
}

Map File for 12d Model V4.0
Up to 12d Model V4.0, the map file format consisted of one or more lines. Each line begins with a 
key (entity-mask) followed by a string name, model name, colour, breakline type (point or line), 
and line style separated by one or more spaces. The key can contain wild cards (*) and wild 
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characters (?).

When a string is read in and satisfies a key, the key’s corresponding string name, model, colour, 
breakline type and style is used for that string.

For example, any entity name beginning with 31 can be created as a 12d Model string with the 
name picket, colour cyan, breakline type line, line style 1 and model fences by the map file line

31* picket fences cyan line 1

If a map file is used, as each entity is read in, the map file is searched sequentially until a match 
with a key is made and the key’s name, colour etc. used. If no match is found, the default colours 
and model (given in the read panel) are used.

Notes

1. If the entity-name is to be used as the new string name, use an asterisk (*) in place of the 
string name. For example,

fred * fences cyan line 1

2. If the default model for the reader is to be used as the model name, use an asterisk in place of 
the model name. For example,

31 31 * cyan line 1

3. A * for colour, breakline type and linestyle means that if the entity has a colour, breakline style 
or linestyle, then it is used rather than be mapped to another one.

4. All model names used in the map file can be given an extra (common) prefix by typing the 
prefix into the prefix for models field in the read panel.

5. If any information includes a space, then it must be enclosed in quotes ". For example, the 
model name may be "trial 1" or a style "large tanks".

6. Comments can be included in the map file by preceding them with a double forward slash //. 
Anything on the line after the // is ignored.

An example of a 12d Model map file is

// 12d Model map file
// key name model colour pt-line linestyle

102 break breaks red line solid
305 fence caddast green point dash
998 bdry bound cyan line solid
spots * spot yellow point 1
PS* * * yellow point 1

Map File for 12d Model V5.0 and Above

For 12d Model V5.0, the map file was extended to allow for defining properties such as tinability, 
symbols at vertices, vertex and segment text and pipe and culverts.

To allow for all the different type of mapping in the one file, the map file is broken up into 
sections (one section for each tab of the map file editor) and each section begins with a header 
record which is the section name enclosed in braces ({ }). For example, the symbols section has 
the header 

{symbol_data}

Inside each section, the data is similar to the V4.0 map file with lines consisting of a key (entity-
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mask) followed by the data required for that section. The key can contain wild cards (*) and wild 
characters (?).

The exact format for the map file is not required since they are created and edited from within 
12d Model by the option

 File i/o => Map file
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N Plotters and Plotting
The method of creating plots and sending them to a plotter or a Cad system such as AutoCad or 
Microstation, varies from site to site.

12d Model provides an array of set ups and options to enable the user to tailor the plotting 
system.

Since the plotting set ups and options are scattered throughout 12d Model, the rationale behind 
the plotting set ups will be summarized in this chapter.

Supported Plotters
When creating a plot, 12d Model can either use a Windows printer driver to plot directly, or 
instead of driving the plotter directly, create a computer disk file (the plot file) containing the 
relevant plotter instructions for producing the plot (which is then sent to the plotter), or in the 
case of the plotter type model, create a 12d Model model.

The plot file can be written in a variety of formats. Currently, 12d Model supports the formats:

windows Windows colour printer, or grey scale on mono printers

windows_mono Windows mono printer - uses black, not grey scale
hp standard HPGL with all of one pen being plotted

before the next pen is used

hp (no sort) standard HPGL with no pen sorting
hp 7475 small HP plotter, common hp emulation mode for lasers
hpgl 2 7600 HPGL 2 for HP 7600 mono plotter
hpgl 2 (colour) standard HPGL 2 for colour plotters
hpgl 2 (colour mapping) standard HPGL 2 for colour plotters using a plotter mapping file
dxf 2d DXF file
dwg 2d DWG file
pcl5 pcl5 format
eagle single Eagle single precision binary model (not in the base module)
eagle double Eagle double precision binary model (not in the base module)
postscript Postscript format (generally for laser printers)
postscript (colour) colour postscript format (generally for laser printers)
postscript (colour mapping) colour postscript format using a plotter mapping file
dgn 2d Intergraph/Microstation binary model (.dgn file)
dogs Dogs parametric format
calcomp Calcomp plot format
mif frame maker interface format.
model creates a 12d Model model

By default, this list of plotters appears when RB is clicked in a plotter panel field
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However, a user defined list of available plotters, with user definable names and properties, can 
be set up and used instead of the default list. User defined plotters will be documented later in 
the section “User Defined Plotters” .

Please continue to the next section “Sending Plots to a Plotter” .

windows colour plotter
windows mono plotter
12d Model model
hpgl2 plotter using a mapping file
hp pen plotter
hp 7475 A3 plotter
AutoCAD dwg file

AutoCAD dxf file

postscript plotter
A3 postscript
postscript plotter using a mapping file
Intergraph/Microstation dgn file
DOGS file
Calcomp plotter
FrameMaker file
PCL5 printer
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Sending Plots to a Plotter
When plots are created, 12d Model can fire up a user supplied script/program with the plot file 
as the first argument. By checking the plot name suffix, the script could for example, decide 
which plotter the plot must be sent to.

The environment variable

PLOTTER_4D points_to_script/program

points to the script/program which can be fired up whenever a plot is generated. The name of 
the plot is given as the first script parameter of the script.

If the tick box Send plots in the panel tab System Settings of the panel Defaults (given by the 
menu option Utilities => Default) is set to on, the plotter script is run as each plot is created.

If more than one plot is created by an option (e.g. x plot) then the script is called separately for 
each of the plots.

An example of a script to send the plot to port lpt1 for Windows NT would be

@echo off
copy %1 lpt1

An example for Windows NT which looks for hp files is

@echo off
echo.
echo ----------------------------------------------------
:next_file
if "%1" == "" goto done
echo %1 | find /I ".hp" > nul
if ERRORLEVEL 0 if not ERRORLEVEL 1 goto hp_plotter
echo Plotting file %1
shift
goto next_file
:hp_plotter
echo Plotting %1 to HP plotter
copy %1 \\server_name\printer_name
shift
goto next_file
:done
echo ----------------------------------------------------

Environment variables are fully defined in the section “Environment Variables” of the Appendix 
“Set Ups” 

Please continue to the next section “Mapping Colours to Plotter Pens” .
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Mapping Colours to Plotter Pens
12d Model uses up to 10,240 different colours and when it comes to plotting, it must be decided 
how these colours are mapped for the particular plotter being used.

For some plotters, colours may be used whereas for mono plotters, line thickness and linestyles 
may be needed.

When plotting to CAD systems such as AutoCad and Microstation, no physical plot is created 
but the plot image may need to be send to special colours, layers and styles in the Cad system.

For plotting to actual plotters, there are two methods of specifying the colour to pen mappings.

(a) pen mapping - a simple colour to pen mapping, mainly used for pen plotters

(b) plotter mapping - a colour to pen mapping plus the red, green, blue definition for colours 
used on the plotter. This is mainly for electrostatic, inkjet and bubblejet plotters.

Plotter mapping is an extension of pen mapping and only one of the two is used for a plot.

Pen Mapping
For all plotters types except Eagle, the Plots=>Pen mapping option can be used to define the 
correspondence between 12d Model colours and plotter pens for the first sixteen colours.

The other colours are given in the colours.4d file. For Eagle plots, the eagleplt.pmf file is used to 
map colours to pens.

The pen mapping option is only used if a plotter mapping is not being used (see next section).

When starting a new project or entering an existing project, the default pen mapping table is 
defined by the colours.4d file.

Once inside the project, any pen number in the table can be modified by changing the 
appropriate pen field and then selecting the set button. The modified table is stored until 
12d Model is quit or the user changes to another project.

The pen mappings for colours above sixteen are given in the colours.4d file but can not be 
displayed or modified by the colour to pens panel.

Whenever a plot is created using non-eagle plotter types, the colours are mapped to the pen 
numbers given in the colours to pen table before writing out the plot file.

For Eagle plots, the eagle_plotter.emf file is used to map colours to pens.

Note - when 12d Model is started up again or the user changes to a new project, the table reverts 
to its default settings as given in the colours.4d file.

Colours.4d
The colours.4d file defines the distinct colours for drawing in any 12d Model view.

The colours.4d file is also used to define the default plotter pen associated with the colour.

See “Colours”  in the Appendix  “Set Ups” 

Plotter Mapping
The plotter mapping file can be used use with pen plotters but is more specifically designed for 
electrostatic and inject plotters and allows the user to

(a) map 12d Model colours to particular plotter pens and also specify a width (or weight) to be 
used forPCL5, HPGL2, postscript and all Windows plotters.

(b) specify the red, green and blue mix for pens on HPGL2, colour postscript and all Windows 
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plotters

The plotter mapping file to be used can be set using

(a) the option Plots=>Plotter mapping

(b) set by the environment variable PLOTTER_MAPPING_4D, or the file pmf.4d 

(c) defined for a particular plotter in the user defined plotters file.

There are also two special formats of the plotter mapping file which are used for plotting to 
Autocad dxf and Intergraph dgn. The special mapping files use the 12d Model colour as a key to 
tables which control how the information is passed to DXF and DGN.

(d) .tbl file used with plotting to Intergraph dgn

(e) .amf used with plotting to Autocad dxf 

The plotter mapping file to be used can be set using

(a) the option Plots=>Plotter mapping

(b) set by the environment variable PLOTTER_MAPPING_4D, or the file pmf.4d 

(c) defined for a particular plotter in the user defined plotters file.

Plotter Mapping File
The plotter mapping file (.pmf) consists of two sections:

(a) pen_mapping table to define the which pen a 12d Model colour is mapped to, and the 
weight for the pen.

(b) pen_colour table which defines the red, green and blue values to be used for the pens on the 
plotter.

The format of the plotter mapping file (.pmf) is

pen_mapping { // pen mapping and weight table

// 12d plotter weight
// colour pen no for pen

0 1 0.15
1 2 0.25
3 1 0.5

// etc.
}
pen_colours { // pen colours table

// plotter
// pen red green blue          values 0-255
      0 0 0 0                // pen 0 is black
      1 255 0 0               // pen 1 is red
// etc.
}

The colour n and pen n and the default weight for n=0,1...255 is used to initially fill up the 10,240 
positions of the pen_mapping weight table.

The pen n and the rgb of the default colour (take its rgb from the colour_map.def file) for 
n=0,1...10,240 is used to fill up the 0,240 rgb positions of the pen_colours table before the plotter 
mapping file is used.

If the Plots =>Plotter mapping option is used, and the merge colours.4d flag is set, the rgb columns 
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from the colours.4d file are used to define the pen_colours (first row is pen 0, second row is pen 1 
etc.), and the pen mapping number is used to construct the pen_mapping table.

The plotter mapping file is then processed and overwrites any of the above initial mapping 
values.

If the plotter type is dgn and the map file is a table file with the extension of .tbl, the plotter will 
use the colour being plotted as the key in the table file and so allows the mapping from the plot 
colour directly into dgn level, weight, style and colour. See the next section for an example of a 
table file.

If the plotter type is dxf and the map file is an AutoCAD mapping file with the extension of .amf, 
the plotter will use the colour being plotted as the key in the mapping file and so allows the 
mapping from plot colour directly into layer name, Autocad colour and linestyle. Note that if 
Autocad colour or linetype is BYLAYER, then 12d Model uses the correct values in Autocad. The 
* character means that the field is ignored. See the next section for an example of an Autocad 
mapping file.
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User Defined Plotters
A file can be set up to define the plotters that appear in the plotter type panel field, and the 
properties of the plotters.

It is possible to customize:

(a) the name of the plotter

(b) the start and end sequence that is sent to the plotter

(c) for each plotter, whether pen or plotter mapping occurs.

The full set of user defined plotters is given in a file called plotters.4d which is searched for in 
the standard set up paths, or is pointed to by the environment variable

PLOTTERS_4D filename

In the plotter file, the definition of a plotter of a given name plotter_name is set out as:

plotter   plotter_name {

    set_up_commands

}

plotter_name must not be blank and if it includes imbedded spaces, it must be enclosed in double 
quotes “.

The plotter itself is defined inside the braces where there can be zero or more plotter set up 
commands from the list:

colours
engine
extension
footer
header
map_file
map_pens
output_cmd
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Description of the Plotter Set Up Commands
engine windows|dxf_4d|dxf_12|dxf_13|dxf_14|dxf_2000|

dwg_4d|dwg_12|dwg_13|dwg_14|dwg_2000
dgn|dogs|hpgl|hpgl2|hpgl_7475|
calcomp|model|mif|postscript

extension ".???"

extension added to the file name used for the plot file written out by this plotter.

map_file plotter_mapping_file_name

points to a plotter mapping file which is used to redirect colours for any plotter. For hpgl2 and 
postscript, it also defines the pen weights (widths).

If map_file is not set and a global mapping file is specified, then it will be used as the plotter 
mapping file. Otherwize the pen mapping table is used.

If the engine is dgn and the map_file is a table file with the extension of .tbl, the plotter will use 
the colour being plotted as the key in the table file. This allows the mapping from the plot colour 
directly into dgn level, weight, style and colour.

If the engine is dxf and the map_file is an Autocad mapping file with the extension of .amf, the 
plotter will use the colour being plotted as the key in the mapping file. This allows the mapping 
from plot colour directly into layer name, Autocad colour and linestyle. Note that if Autocad 
colour or linetype is BYLAYER, then 12d Model uses the correct values in Autocad. The * 
character means that the field is ignored.

map_pens true|false 

if true, it uses the specified map_file, or if map_file is false, it doesn’t use any mappings 
(map_file, global plotter mapping file or pen mapping table). It leaves the pen number 
untouched. This was used in the hpgl2 colour and postscript colour - the screen colours were 
preserved. This can now be done for any plotter.

This is ignored when the map_file is used as a tbl file (plotter engine is dgn and the map_file has 
an extension of .dgn - any mapping is occurring via the tbl file where colour is the key).

This is ignored when the map_file is used as a amf file (plotter engine is dxf and the map_file has 
an extension of .dxf - any mapping is occurring via the .dxf file where colour is the key).

output_cmd path to a script or program

for this plotter, the given script or program is used on the created plot file. This replaces the 
PLOTTER_4D definition of script or program for this plotter.

colour true|false

used in hpgl2 and postscript.
If false, then for postscript don’t send the rgb for colours and for hpgl2, it doesn’t send down the 
block of information with the number of pens and the rgb for each pen. That is, if false, it stops 
hpgl2 and postscript writing out the colour definition commands.

header and footer

The header information in placed in the plot file before any plot commands and the footer 
information is placed at the end of plot file after all the plot commands.

The format for the for the header of footer is:

header { // this information in placed in the plot file before any plot commands
lines of text which can include plotter variables

}
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or
footer { // this information is placed at the end of the plot file, after the plot commands

lines of text which can include plotter variables
}

Each line of text is surrounded by quotes. For example, "this is some stuff".

The plotter_variables used in the header or footer are: 

username
filename
date
time
sheet_width
sheet_height
page_number - not used
minimum_x, minimum_y// plotter dependent
maximum_x, maximum_y// plotter dependent

and are included in the text by preceding them by a + and also following them by a cross if more 
text follows. For example:

"the user is " + username+"of 4D Solutions"

The appropriate information is substituted for the plotter_variables when a plot is created.

Hence
"the user is "+ username+" of 4D Solutions"

would give
"the user is fred of 4D Solutions"

A plotter_variable may not be appropriate for a particular plotter and if a plotter_variable is 
specified but not used for a plotter, it is substituted by blank.

If header or footer is not specified, then appropriate default information for the plotter is used.

The header and footer set_up_commands are not used by all plotters. If they are not used for a 
particular plotter, the header or footer command is ignored.

At present, only the plotters hpgl, hpgl2, postscript and dxf use header and footer.

minimum_x etc for postscript, it is the extent of the plot in mm
sheet_width, sheet_height for postscript in mm

For hpgl2

sheet_width, sheet_height in mm/40.
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Example of a Plotters.4d File

An example of a plotters.4d file is:

// -------------------------------------------------------------------
// File: plotters.4d
// Date: 25 January 1997
// Use: User definable plotter names
// -------------------------------------------------------------------

plotter "Windows" { // Windows printer drivers
engine windows
colour true
map_pens true
map_file "windows_colour.pmf"

}
plotter "Windows mono" { // Windows printer drivers
engine windows
colour false
map_pens true
map_file "windows_mono.pmf"

}
plotter "HP Colour" { // hp plotter using hpgl2
engine hpgl2
colour true
map_pens true
map_file "jetcolor.pmf"
output_cmd "print -s://melba/jet_design"
extension ".hp2"

}

plotter "HPGL Pen plotter" { // hp pen plotter using hpgl
engine hpgl
map_file "jetcolor.pmf"
output_cmd "print -s://melba/devel_hp4v"
extension ".hp"

}

plotter "Model" { // plot to a 12d Model model
engine model
extension ""
map_pens false // don’t map colours

}

plotter "DGN" { // output toa Microstation dgn file
  engine dgn
  extension ".dgn"
}

plotter "DGN with tbl" {// define a dgn plotter using an output table file
engine dgn
extension ".dgn"
map_pens true // ignored where the map_file is used as a tbl file
map_file "vicplot.tbl"

}
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plotter "DXF 2000" { // output to a dxf file
engine dxf_2000
extension ".dxf"

}
plotter "DXF 2000 with amf" {// output to a dxf file using an autocad map file
engine dxf_2000
extension ".dxf_2000"
map_file "acadplot.amf"

}
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Definition and Example of a .tbl File
An example of an output mapping file for use with an Microstation (Intergraph) dgn plotter:

// -------------------------------------------------------------------
// File: vicplot.tbl
// -------------------------------------------------------------------
// column 112d colour name (any length - but only 1st four characters passed)
// column 2Vic roads code (only 1st four characters passed)
// column 3AS2482 feature code
// column 4description (any length but if embedded spaces then must be quoted)
// column 5line level (between 1 and 64)
// column 6line colour (between 1 and 256)
// column 7line weight (between 1 and ?)
// column 8line style
//
// notes: if column 2 is a * then the 12d name is transmitted (up to 4 characters that is)
//         columns 9 through 16 are only used for point strings which map into characters

1  PM    38010000  "Permanent Survey Mark    " 49  0  1 0
2  BM    38020000  "Bench Mark               " 49  0  1 0
3  TPEG  31000001  "Title peg                " 50  0  1 0
4  STN   38100000  "Instrument Station       " 50  0  1 0
5  SM    38000000  "Survey mark (general)    " 50  0  1 0
6  PCON  38040001  "Photo control point      " 50  0  1 0
7  CHEK  38000001  "Check profile/point      " 52 10  3 0
8  TRIG  38010000  "Trigonometric Station    " 50  0  3 0
9  BMQS  38020001  "Bench Mark QS-1          " 49 11  1 0
10 BMS   38020002  "Bench Mark S-2           " 49 11  1 0
11 BMSH  38020003  "Bench Mark SH-1          " 49 11  1 0
12 RM    38000001  "Reference Mark - General " 50 11  1 0
* ROD   38000002  "Reference Mark - Rod     " 50 11  1 0         // everything else

Definition and Example of a .amf File
An example of an AutoCad output mapping file for use with an Autocad plotter:

// -------------------------------------------------------------------
// File: acadplot.amf
// -------------------------------------------------------------------
// column 1 match colour- can include wild chards * and wild characters ?
// column 2 new name - not output to DXF
// column 3 ACD layer - 
// column 4 ACD colour- * for 12d Model colour (mapped to ACD), 
// BYLAYER for ACD BYLAYER
// column 5 ACD line type- * for 12d Model linestyle,
//  BYLAYER for ACD BYLAYER
// column 6 ACD text style- not yet used, * for 12d Model text style 
//
// Notes:
// 1. column 5 (ACD colour) can only be a number between 0 and 256, or * or BYLAYER
// 2. The DXF file produced needs to be loaded into an existing Autocad drawing
//    which has the ACD layers and linestyles defined.
// column 1        2              3          4                          5                           6
//
             1     CONT       ljg1        1                          1                         *
             2     TOP          ljg2        2                    CONTINUOUS  *
             3     TOP           *           3                         *                           *
             4     TOP          ljg4        *                      BYLAYER             *
             5     TOP          ljg5      BYLAYER         DASH                   *
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Microstation (DGN) Plot Seed File
When creating dgn plot files in Microstation (Intergraph) DGN format, a Microstation 
(Intergraph) DGN seed file can be used.

The folder containing the seed files can be pointed to with the environment variable 
MS_SEEDFILES_4D:

MS_SEEDFILES_4D folder

The Microstation seed file is set by the Plots=>DGN plot seed file option.

Sheet Sizes
For plot frames, long and x plots, the overall size of the plot sheet can be given by a pop-up 
containing defined sheet size.

The sheet size names, width and heights can be specified by the user in a file named sheets.4d 
which is in the normal set up areas, or is pointed to by the environment variable

SHEET_SIZES_4D file // file of plotter sheets sizes

The layout of the sheet sizes file is given in the section “Sheet Sizes” in the Appendix “Set Ups” 

Environment variables are fully defined in the section “Environment Variables” of the Appendix 
“Set Ups” 

Hardware Arcs
When plotting arcs, the arc can either be broken into a series of straight lines within 12d Model, 
or plotted using the arc command (if it exists) for the relevant plotter.

The initial default for hardware arcs is set by the environment variable HARDWARE_ARCS_4D:

HARDWARE_ARCS_4D 1 use hardware arcs default
0 hardware arcs are not used

but this can be overridden by the option Plots=>Hardware arcs.

Environment variables are fully defined in the section “Environment Variables” of the Appendix 
“Set Ups” 
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Interface Colours
When drawing interface strings in 12d Model, cut areas are denoted in red, fill areas in green and 
sections on the surface in yellow.

However, when plotting it is convenient to be able to map the interface colours to other colours.

This panel is used to define new colours for the interface colours, and the new colours are then 
mapped to pens using the pen mapping table or plotter mapping file.

The colours used for plotting the interface colours is set from the option plots=>interface colours

Text Units
Text occurs in 12d Model plots in a number of ways -

▲ plotting text strings and 4d strings

▲ automatic text such as grid values, x-section and long-section plot annotation.

▲ text within linestyles.

The most difficult thing about text is that because of the different uses of text, there needs to be 
more than one systems of units to define text heights.

The height of text for a given textstyle is defined to be the height of a capital A. However, in 
12d Model, there are three methods of defining the units for measuring this height.

▲ world units - the units used for data
▲ screen units - pixels (the screen is 1000 pixels wide)
▲ plot paper units - millimetres.

World Units

World units are the units of user data. For most users, the base unit for user data is metres. 
However 12d Model is a dimensionless system and the base unit is totally dependent on the 
user.

The height of world text when displayed in a view depends upon on the text height and the scale 
of the view.

When plotted, the height that world text appears on a plot sheet is the same as for any data 
defined in world units - the height depends on the scale used for the plot.

Text heights that are only given in world units have (w) after them.

For some text, the choice of units is either world or pixels. The text parameters then have a (u) 
after them.

Screen Units - pixels

When screen units (pixels) are used, the text is a fixed height on the screen. If the user zooms in 
on text given in pixels, the text remains the same height.

To have a height on a plot, screen unit text needs a height defined in millimetres.

For some screen text, both a pixel and a millimetre height is supplied when the text is defined.

For text with only a pixel height, there is a plotting multiplication parameter called pixels-to-
millimetres which is used to convert pixel heights to plot paper heights. The value of pixels-to-
millimetres is set using the plots=>pixels to mm option and is stored for the project.

Text heights that are only given in pixels have a (pix) or (p) after them.

For some text, the choice of units is either world or pixels. These text parameters then have a (u) 
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after them.

Plot Paper Units - millimetres

Text defined in plot paper units (millimetres) has a well defined height on a plot sheet.

Text heights that are only given in millimetres have (mm) after them.

Pixels to mm
To allow text and linestyles with only a pixel size to be plotted, a factor to convert pixels to 
millimetres is used.

When plotting, any text and linestyle defined only in pixel units is multiplied by the pixels-to-
millimetre factor to determine its size in the plot.

For a new project, the initial value is loaded from the defaults file and is defined in this file by

PIXELS TO MM PLOT FACTOR value

See “Defaults”  in the Appendix  “Set Ups” 

The pixels-to-mm factor can be modified by the Plots=>Pixel to mm option.

The pixel-to-millimetres value is stored for the project

Environment variables are fully defined in the section “Environment Variables” of the Appendix 
“Set Ups” .
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O Plot Parameters

Plot Frame Plot Parameter File
The plot frame section plot parameters are placed in a file with ending .ppf

Each parameter consists of a parameter name followed by one or more spaces and then the 
parameter value. There is only one parameter per line.

Anything on a line after a double forward slash // is considered to be a comment.

The set of all parameters for the plot frame plot is enclosed within a set of curly brackets { } with 
the header

plot_frame_plot     “plot set name”

before the curly brackets.

That is,

plot_frame_plot   “plot set name”   {

plot parameters
one per line

}

If there is more than one plot_frame_plot parameter set in the file, only the first set is used.

There may also be parameter sets for other plot types such as section_long_plot in the same file. 
The other sets will be ignored when doing plot frame plots.

The only parameters not connected with title block file are

view_name view_name // name of view used for information
// on the plot

single_frames frame_name // name of plot frame to be plotted 

model_of_frames model_name // model of plot frames which may be
// plotted as a group

Both these parameters exist in the plot frames plot panel and when the parameter file is first read, 
if either of these parameters exist in the plot parameter file then they will be used to replace the 
corresponding parameters in the panel.

However, if the parameters are subsequently modified in the panel, the new panel value will be 
the value used for plotting.
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Title Block Information
A plot frame plot can have a standard 12d Model title block or a user defined title block.

For a user defined title block, the title block drawing commands are kept in a file whose name is 
given by the user when setting up the plot frame. The title block drawing commands are almost 
identical to the linestyle drawing commands.

If a user defined title block has been set for the plot frame, plot frame parameters can be used to 
pass information though to the title block.

User Title Block

Some of the plot parameters are used to pass information down to variables in a user defined 
title block specified in the plot frame.

The parameters are:

time_format text // format for $time

title_1 text // passed down to $title_1
title_2 text // passed down to $title_2

user_text_n text // where n = 1,2,... 1000
// passed down to $user_text_n

start_page_number integer // used as the starting value for $page_number.
// if missing, $page_number starts at 1.

start_drawing_number integer // added to $drawing_number in title block file
// if missing, $drawing_number starts at 1.

drawing_number_prefix text // passed down to $drawing_number_prefix
drawing_number_postfix text // passed down to $drawing_number_postfix

Notes

1. A warning is given if the keyword in a plot parameter file does not exist.

2. A warning is also given if the key word pair is defined more than once in a ppf.
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Cross Section Plot Parameter File
The cross section plot parameters are placed in a file with ending .ppf

Each parameter consists of a parameter name followed by one or more spaces and then the 
parameter value. There is only one parameter per line.

Anything on a line after a double forward slash // is considered to be a comment.

The set of all parameters for the cross section plot is enclosed within a set of curly brackets { } 
with the header

section_x_plot      “plot set name”

before the curly brackets.

That is,

     section_x_plot   “plot set name”    {

plot parameters
one per line

}

If there is more than one section_x_plot parameter set in the file, only the first set is used.

There may also be parameter sets for other plot types such as section_long_plot in the same file. 
The other sets will be ignored when doing cross section plots.

The plot parameters are documented in following groups: 

For the Plot Sheet layout, please continue to the section “Plot Sheet Layout” .
Boxes and datum area, please continue to the section “Boxes and Datum Area” .

Only for the Centre line case:
Datum area, please continue to the section “Datum Line” .
Labelling the centreline, style etc., please continue to the section “Labelling the Centreline 

Chainage” .

Only for the Boxes case:
Datum area, please continue to the section “Datum Line” .
Labelling the centreline chainages, please continue to the section “Labelling the Centreline 

Chainage” .
Defining boxes and what is labelled in them, please continue to the section “Defining Boxes” .

For Both the Centre Line and Boxes case:
Graph area parameters, please continue to the section “Graph Area” .
Grade labelling, please continue to the section “Grade Labelling” .
Labelling points on x-sections, please continue to the section “Labelling Points of the X-Sections” 
Labelling cuts, please continue to the section “Labelling Cuts of X-Sections Through Strings in a 

Model” .
Hatching cut/fill, please continue to the section “Hatching Cut and Fill Areas” .
Drawing extra x-sections, please continue to the section “Extra Models of X-Sections” .
Sorting x-sections, please continue to the section “Sorting X-Sections by Chainage” .
Title block information, please continue to the section “Title Block Information” .
Panel modifying parameters, please continue to the section “Parameters that Modify Fields In the 

Cross Plot Panel” .
Example, please continue to the section “Example of a Cross Section Plot Parameter File” .
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Plot Sheet Layout
X-sections are normally generated at chainages along a given centreline. This centreline chainage 
is stored with each x-section string.

The chainages of the actual x-sections are referred to as offsets from the centreline position 
rather than x-section chainages. The offsets of the x-section are set up so that the zero offset 
occurs where the x-section crossed the centreline string.

The x-sections along the centreline are stored in the one model (the primary model) which is then 
used to generate the cross section plot.

model_to_plot text // name of the model of x-sections

Each x-section from the primary model of x-sections generates its own sub-plot for which the x-section is 
the primary string. Hence the cross section plot consists of many individual plots drawn on one or more 
plot sheets.

Each plot sheet is considered to have only positive co-ordinates with the origin (0,0) in the left 
hand corner. The units for the plot are millimetres.

The overall size of the plot sheet is given by either a defined sheet size, or by the width and 
height of the plot given in millimetres and separated by one or more spaces.

sheet_size text // sheet name, or
“mm mm” // sheet size: width height

The sheet size name, width and heights can be specified by the user in a file named sheets.4d which is in 
the normal set up areas, or is pointed to by the environment variable

SHEET_SIZES_4D file // file of plotter sheets sizes

The plotting area is restricted to within the plot sheet by giving margins which are:

If a User Defined Title Block is used:

left_margin mm
right_margin mm
top_margin mm
bottom_margin mm

If the default 12d title block is used, then the size of the bottom of title block depends on the text size. The 
following parameters are used in the default title block case and the bottom_border_gap is added to the 
calculated height of the bottom of the title block.

left_border_gap mm
right_border_gap mm
top_border_gap mm
bottom_border_gap mm

Because the user can easily select from the plotting panel whether a User Defined Title Block or the 
default 12d title block is used, both sets of margin and gap parameters can exist in the one plot parameter 
file.
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The x-sections are plotted in the order they occur in the x-section model and start being plotted at the 
bottom left hand corner of the cross section plotting area.

The individual x-section plots are then drawn going up the column, and when the column is full, 
start from the bottom of the next column.

When a sheet is full, a follow on sheet is created.

Each individual x-section sub-plot is positioned with the surrounding gaps:

left_sub_plot_gap mm
right_sub_plot_gap mm
top_sub_plot_gap mm
bottom_sub_plot_gap mm
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If required, all the sub-plots in a column can be automatically positioned up so that the zero 
offsets (the centrelines) of each x-section line up.

line_up_cl yes/no // yes - line up zero offsets

The width of the plot can be a fixed distance left or right of the centre line (zero offset) or for the full 
section plus an extra left and right distance:

absolute_extensions yes // The section goes from the
// left_extension offset on the left to the
// right_extension offset on the right.

no // The section goes for the entire section
// length plus the left and right extension
// distances.

left_extension world-units                // left extension value
right_extension world-units             // right extension value

The x-section can be drawn and labelled with either

(a) centreline case - the x-section is plotted and an upright, and the offset and height value at the zero 
offset (normally the centre line position) 

(b) boxes case - the x-section is plotted and the heights of the x-section and the tins at all the x-section 
points are labelled in boxes under the plot of the x-section.
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The x-section sub-plot itself consists of the three regions - graph, datum and boxes.

The graph area is the area where the actual plots of the strings are drawn. This exists for both the 
centreline and boxes case.

The datum area is the region between graph area and the datum line. This exists for both the 
centreline and boxes cases.

The boxes area is where the offset values and the heights for the strings drawn on the x-section 
plot are labelled. This only exists for the boxes case.

For both cases, the x-section sub-plot can be labelled with other information such as

(a) grades across the x-section

(b) points across the x- section

(c) cuts the x-section makes through strings

(d) cut and fill areas

All the required parameters will be described in the following sections.

Please continue to the next section “Boxes and Datum Area” .

boxes casecentre line case

x-section plotcentre line

boxes plotcentre line plot

graph area

datum line

boxes area

centre line
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Boxes and Datum Area
The x-section can be labelled with either

(a) an upright, and the offset and height value at the zero offset (normally the centre line position)

(b) the heights of the x-section and the tins at all the x-section points.

The choice is given by the parameter label_type:

label_type “centre line” // type (a)
boxes // type (b)

A datum line exists for both cases.

For the boxes case, a box area for the offset and heights is created below the datum line. The 
available parameters for tailoring the box area will be given after describing the datum line 
parameters.

For the centre line case, the centre line and offset and height of the centre line are shown.

In both cases, the actual cross section plot is drawn above the datum line in the graph area.

Please continue to the next section “Centre Line Case”  for the centre line parameters.

Please continue to the section “Boxes Case”  for the boxes parameters.

Centre Line Case

Datum Line

Each x-section sub-plot can be labelled with the datum value for the plot of the x-section string.

This DATUM INFO label is made up of the text strings:

"datum_name" followed by the datum-value
and is above the datum line.

boxes plotcentre line plot

graph area

datum line

boxes area

centre line
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For the centreline case, the graph area is positioned the distance datum_above_gap_cl above the 
datum line.

datum_above_gap_cl mm // dist from datum line to bottom of the
// graph area

The datum_above_gap_cl can be zero or positive.

The roundoff for the datum value is specified by the user (default 1.0) and the datum is 
automatically calculated for each sub-plot, and labelled.

The datum value can be placed on the left, centre or right side of the datum line.

datum_roundoff 1.0 // value to roundoff the datum value to 
// e.g. 0.5, 0.2, 1.0 (default 1.0)

datum_decimals integer // number of decimal places to display
// the datum value (default 1). 
// If > 0, trailing zeros are removed after
// the decimal point.
// If <0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

datum_side_cl 0 // datum text in middle of datum line
1 // " " " " left of datum line (default)
2 // " " " " right of datum line

datum_linestyle linestyle // datum line linestyle (default solid)
datum_name text // text to write before the datum value
datum_textstyle text // textstyle for datum information
datum_text_size mm // size of datum text and value
datum_colour colour // colour of the datum text
datum_line_colour colour // colour of the datum line
datum_text_justification_cl just // justification for datum text

// NOTE - this is not normally required since
// by default the text justification is set to
// match datum_side_cl 

datum_x_cl mm // distance to move the datum text
// along the datum line

datum_y_cl mm // distance to raise the datum text
// above the datum line (used to be
//    called datum_offset)

The datum_x_cl and datum_y_cl can be positive, zero or negative.

graph area

datum_above_gap_cl

centre line case

DATUM INFO

datum_y_cl

datum_x_cl

DATUM INFO

datum info
can be on the left, middle or right of the
datum line 
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Labelling the Centreline Chainage

Each x-section sub-plot can be labelled with the centreline chainage of the x-section string.

This CHAINAGE INFO label is made up of the text strings:

"chainage_title" followed by the chainage-value
and is drawn under the datum line.

The chainage value can be placed on the left, centre of right side of the datum line.

chainage_side_cl 0 // text in middle of datum line (default)
1 // " " " " left of datum line
2 // " " " " right of datum line

The parameters controlling the labelling are:

chainage_label 0/1 // 1 = label sub-plot with centreline
 // chainage, 0 don’t label.

chainage_title text // text before the chainage value
chainage_decimals integer // number of decimals in the chainage

// value. If <0, the absolute value
// is taken as the number of decimal
// places i.e. no trailing zeros are
// removed for the values in the
// chainage values.

chainage_colour colour // colour of the text
chainage_size mm // size of the text
chainage_textstyle colour // textstyle for the chainage label
chainage_text_justification_cl just // justification of the chainage text 
chainage_x_offset mm // x position of text
chainage_y_offset mm // y position of text

The chainage_x_offset is measured from the beginning of the datum line.

The chainage_y_offset is measured from the bottom of the datum line with positive being down.

Centre Line Linestyle

graph area

datum_above_gap_cl

centre line case

DATUM INFO

datum_y_cl

datum_x_cl

DATUM INFO

CHAINAGE INFO

chainage info and datum info
can be on the left, middle or right of the
datum line 

chainage_y_offset

CHAINAGE INFO
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The upright at the centre line position can have its own linestyle.

cl_linestyle linestyle //linestyle for centreline



Appendix O  Plot Parameters

November 2002 Page 3451Cross Section Plot Parameter File

Labelling the Design Height, X and Y Co-ordinates and Tin Heights at Offset Zero

The values of the height and X and Y co-ordinates of the primary string (usually the design cross 
section) at the zero offset can be labelled. Note that zero offset is normally where the alignment 
string cuts the cross section.

The heights of any tins (such as the natural surface) at the zero offset can also be labelled.

The labels are made up of:

pre_text    value    post_text

where value is either a height or a co-ordinate.

The label is positioned at either the left, right or middle of the datum line, with an x and y 
adjustment and a rotation.

Parameters for labelling the X Co-ordinate at Zero Offset:
primary_x0_draw_mode 0 // don’t draw the label -default

1 // draw the label
primary_x0_position 0 // label in middle of datum line (default)

1 // " " " " left of datum line
2 // " " " " right of datum line

primary_x0_pre_text text // pre-text for label - def " "
primary_x0_post_text text // post-text for label - def " "
primary_x0_decimals integer // number of decimal places to display - def 1

// If > 0, trailing zeros are removed after
// the decimal point
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

primary_x0_x mm // x adjustment to position of label - def 0
primary_x0_y mm // y adjustment to position of label - def 0
primary_x0_angle degrees // angle of the label - def 0
primary_x0_colour colour // colour of the label
primary_x0_size mm // size (in mm) of the label
primary_x0_textstyle textstyle // textstyle of the label
primary_x0_justify just // justification for text

Parameters for Labelling the Y Co-ordinate at Zero Offset:

primary_y0_draw_mode 0 // don’t draw the label -default
1 // draw the label

primary_y0_position 0 // label in middle of datum line (default)
1 // " " " " left of datum line

graph area

Labe
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label_y

 datum_line

label_x
label_angle
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2 // " " " " right of datum line
primary_y0_pre_text text // pre-text for label - def " "
primary_y0_post_text text // post-text for label - def " "
primary_y0_decimals integer // number of decimal places to display - def 1

// If > 0, trailing zeros are removed after
// the decimal point
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

primary_y0_x mm // x adjustment to position of label - def 0
primary_y0_y mm // y adjustment to position of label - def 0
primary_y0_angle degrees // angle of the label - def 0
primary_y0_colour colour // colour of the label
primary_y0_size mm // size (in mm) of the label
primary_y0_textstyle textstyle // textstyle of the label
primary_y0_justify just // justification for text

Parameters for Labelling the Height of Primary String at Zero Offset:

primary_height_draw_mode 0 // don’t draw the label -default
1 // draw the label

primary_height_position 0 // label in middle of datum line (default)
1 // " " " " left of datum line
2 // " " " " right of datum line

primary_height_pre_text text // pre-text for label - def " "
primary_height_post_text text // post-text for label - def " "
primary_height_decimals integer // number of decimal places to display - def 1

// If > 0, trailing zeros are removed after
// the decimal point
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

primary_height_x mm // x adjustment to position of label - def 0
primary_height_y mm // y adjustment to position of label - def 0
primary_height_angle degrees // angle of the label - def 0
primary_height_colour colour // colour of the label
primary_height_size mm // size (in mm) of the label
primary_height_textstyle textstyle // textstyle of the label
primary_height_justify just // justification for text

Parameters for Placing Some Text:

extra_text_draw_mode 0 // don’t draw the label -default
1 // draw the label

extra_text_position 0 // label in middle of datum line (default)
1 // " " " " left of datum line
2 // " " " " right of datum line

extra_text text // text for label - def " "
extra_text_x mm // x adjustment to position of label - def 0
extra_text_y mm // y adjustment to position of label - def 0
extra_text_angle degrees // angle of the label - def 0
extra_text_colour colour // colour of the label
extra_text_size mm // size (in mm) of the label
extra_text_textstyle textstyle // textstyle of the label
extra_text_justify just // justification for text

Parameters for Labelling the Height of a Tin at Zero Offset:

A section along the primary string through each tin on the section view is automatically drawn 
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on the cross section plot but the user can specify whether the tin height at the zero offset is 
labelled or not.

Hence although there may be a number of tins drawn on the section plot, not all of them need to 
have their height at zero offset labelled.

The default order for labelling the tins is the order that they were added to the view but it is 
possible to specify which tin is used for labelling by giving the tin name rather than just using 
the tin on the section view. 

In fact, it is possible to use any tin in the project to label the height at zero offset, not just those 
drawn on the section view.

tin_n_name text // n=1, ... no of tins on the section view.
// use the tin called text to label the nth
// row of tin heights.

 If a tin of the name given by tin_n_name does not exist, then the plot is not produced and an 
error message is given.

The parameters for labelling the height of the tin at zero offset are:

tin_n_height_draw_mode 0 // don’t draw the label -default
1 // draw the label

tin_n_height_position 0 // label in middle of datum line (default)
1 // " " " " left of datum line
2 // " " " " right of datum line

tin_n_height_pre_text text // pre-text for label - def " "
tin_n_height_post_text text // post-text for label - def " "
tin_n_height_decimals integer // number of decimal places to display - def 1

// If > 0, trailing zeros are removed after
// the decimal point
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

tin_n_height_x mm // x adjustment to position of label - def 0
tin_n_height_y mm // y adjustment to position of label - def 0
tin_n_height_angle degrees // angle of the label - def 0
tin_n_height_colour colour // colour of the label
tin_n_height_size mm // size (in mm) of the label
tin_n_height_textstyle textstyle // textstyle of the label
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Labelling the Centre Line Offset and Height

In the centre line case, the value of the height of the primary string (usually the design cross 
section) at the zero offset can be labelled. This is normally where the alignment string cuts the 
cross section.

The label is made up of the texts:

primary_title    offset_title     offset_value     height_text       height_value

NOTE: These parameters have now been superseded. The parameters for labelling the height of the 
primary string at zero offset covers this case. To use the zero offset parameters instead, the 
primary_height_pre_text would include all text required for the Primary_title, offset_title, offset_value 
and height_text (offset_value is always 0.0).

The parameter primary_mode_cl controls whether the primary_title is included in the label.

primary_mode_cl 0 // don’t include primary_title, primary_value
1 // incl. primary_title, primary_value default

The parameter height_mode_cl controls whether the height_title and height_value are included in the 
label.

height_mode_cl 0 // don’t include height_title, height_value
1 // include height_title, height_value default

The parameter offset_mode_cl controls whether the offset_title and offset_value are included in the label.

offset_mode_cl 0 // don’t include offset_title, offset_value
1 // include offset_title, offset_value default

The label can be placed on the left, centre of right side of the datum line.

offset_height_side_cl 0 // text in middle of datum line (default)
1 // " " " " left of datum line
2 // " " " " right of datum line

The size, colour, text justification and text style for the label is given by:

primary_title text //primary title
offset_title text // offset label (default "Offset")
height_text text // height text label (default "Height")
primary_textstyle textstyle // textstyle used for offset and height

// label
primary_colour colour //colour for offset and height label
primary_size mm //size of the offset and height label
offset_height_text_justification_cl justif // text justification

// NOTE - this is not normally required since
// by default the text justification is set to
// match offset_height_side_cl 

The number of decimals in the offset-value and height-value is controlled by:

number_of_decimals integer // number of decimal places in the offset,
// height boxes. If <0, the absolute value
// is taken as the number of decimal
// places i.e. no trailing zeros are
// removed for the values in the offset,
// heights area.

The label is placed an distance offset_x_cl along the datum line and a distance offset_y_cl below the datum 
line of the plot.
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offset_x_cl mm // distance to move the text along the
// datum line

offset_y_cl mm // distance to shift the text below the
// datum line

The offset_y_cl is measured from the datum line with positive being down.

Please continue to the next section “Boxes Case”  for the boxes parameters.

Please continue to the section “Graph Area”  if you are not using boxes parameters.

graph area

datum_above_gap_cl

centre line case

DATUM INFO

datum_y_cl

datum_x_cl

DATUM INFO

CHAINAGE INFO

datum, chainage and offset/height info
can be on the left, middle or right of the
datum line 

chainage_y_offset

CHAINAGE INFO
chainage_x_offset

Primary Offset 0.0 Height 13.1 

offset, height of
the centre line

offset_y_cloffset_x_cl



12d Model Reference Manual

Page 3456 November 2002Cross Section Plot Parameter File

Boxes Case

Datum Line

For the boxes case, the datum line is positioned the distance datum_below_gap above the top of 
the boxes area and the graph area is then positioned the distance datum_above_gap above the 
datum line.

Hence the graph area is distance (datum_below_gap + datum_above_gap) above the top of the 
boxes area.

datum_above_gap mm // dist from datum line to bottom of the
// graph area

datum_below_gap mm // dist from datum line to the top of the
//   boxes

datum_linestyle linestyle //linestyle for the datum line
The datum_below_gap and datum_above_gap can be zero or positive.

The roundoff for the datum value is specified by the user (default 1.0) and the datum is 
automatically calculated for each sub-plot, and labelled.

datum_roundoff 1.0 // value to roundoff the datum value to 
// e.g. 0.5, 0.2, 1.0 (default 1.0)

datum_decimals integer // number of decimal places to display
// the datum value (default 1). 
// If > 0, trailing zeros are removed after
// the decimal point.
// If <0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

datum_name text // text to write before the datum value
datum_textstyle text // textstyle for datum information
datum_text_size mm // size of datum text and value
datum_colour colour // colour of the datum text
datum_line_colour colour // colour of the datum line
datum_x mm // distance to move the datum text

// along the datum line
datum_y mm // distance to raise the datum text

// above the datum line (used to be
//    called datum_offset)

The datum_x and datum_y can be positive, zero or negative.

Labelling the Centreline Chainage

Each x-section sub-plot can be labelled with the centreline chainage of the x-section string.

This CHAINAGE INFO label is made up of the text strings:

"chainage_title" followed by the chainage-value
and is drawn under the boxes area.

The parameters controlling the labelling are:

chainage_label 0/1 // 1 = label sub-plot with centreline
 // chainage, 0 don’t label.

chainage_title text // text before the chainage value
chainage_decimals integer // number of decimals in the chainage

// value. If <0, the absolute value
// is taken as the number of decimal
// places i.e. no trailing zeros are
// removed for the values in the
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// chainage values.
chainage_size mm // size of the text
chainage_textstyle colour // textstyle for the chainage label
chainage_text_justification just // justification of the chainage text 
chainage_colour colour // colour of the text
chainage_x_offset mm // x position of text
chainage_y_offset mm // y position of text

The chainage_x_offset is measured from the beginning of the height boxes.

If chainage_x_offset is omitted, the text is centred on heights area.

The chainage_y_offset is measured from the bottom of the box area with positive being down.

Defining Boxes
When boxes is selected for label_type, the primary string (usually the design cross section) and 
each tin in the x-section sub-plot can be labelled with one or two lines of title, and the height at 
the offset position for each point in the primary string.

The title for the strings, is drawn in the title area of the boxes area.

The offsets/heights are drawn in the heights area of the boxes area.

Consequently the boxes area is made up of rows of text consisting of:

       string/tin titles followed by the offset/height values across the string/tin.

Each row is surrounded by lines to form a box.

The default order of the boxes from the bottom up is

(a) offset title and values

(b) tin title and heights - natural surface etc. (optional)

(c) primary string title and heights - design x-section (optional)

boxes - offset and height area

graph area

datum_below_gap

datum_above_gap

boxes case
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chainage_y_offset
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The title area starts at the relative position (left_sub_plot_gap,bottom_sub_plot_gap).

The size of the title text is given by the title_box_text_size parameter.

The width of the title area is either given by the space_for_titles parameter, or if omitted, the 
required width is automatically calculated.

title_box_text_size mm // size of the titles in the boxes
space_for_titles mm // calculated if omitted

There can be two lines of title text and the title text, textstyle and colour can be set independently 
for the primary string and each tin.

The x position of the title text is the same for all the lines of title text and can be set to be a fixed 
distance from the left hand side of the boxes.

box_titles_x mm // distance to move the title text from the
// left hand side of the boxes

The heights area starts at the end of the title area.

The height text is written at right angles to the bottom of the boxes. It can be either top or bottom 
justified with respect to the box (box_text_justification).

The number of decimal places and the size of the heights text can also be specified.

The height of each individual box area is either given by the horizontal_line_spacing parameter, or 
if omitted, the required height is automatically calculated.

number_of_decimals integer // number of decimal places in the
// height boxes. If <0, the absolute value
// is taken as the number of decimal
//   places i.e. no trailing zeros are
//   removed for the values in the heights
//   area.

text_size mm // size of the height values
offset_textstyle textstyle // textstyle for height text
offset_colour colour // colour of height text

box_text_justification 0 // bottom of individual boxes
1 // top of individual boxes

horizontal_line_spacing mm // calculated if omitted

The total height of the boxes area is simply given by number of boxes drawn multiplied by the height of 
one box (they all have the same height).

The width of the heights area is determined by the number of chainages to be labelled and 
whether the values are staggered to prevent over writing.

Hence the total width of the boxes area is the width of the labels area plus the width of the 

boxes cross section plot

title
area

heights
area

offsets values

tin heights

primary (design)

(optional)

heights

offset title
tin title

primary string title
tin title
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heights area.

Many distance definitions in the plot parameter file are given in terms of distance above the top 
of the boxes area.

The text in the title area is the same for each cross section plot on the sheet so it is possible to restrict the 
title area to be only on the first cross section on the sheet or the first column of cross sections.

label_first_only 0 //title area on all x-sections (default)
1 // title area on first x-sect of page only
2 // title area on x-sects in first column

The drawing of the box line work is user defined. This has been extended from V3.1 although 
draw_box_mode has been left in for upward compatibility. 

draw_box_mode 0 // don’t draw box lines
1 // draw box lines around heights area

// only
2 // draw box lines around title and

// heights areas
3 // use draw_box_side_n,

// box_line_draw_mode and
// box_line_mode_n

box_colour  colour // colour of the boxes

For V3.2, the line work for the outside of the title and heights boxes is controlled by the parameters 
draw_box_side_n and box_side_colour_n, and the separation lines inside the boxes are controlled by the 
parameters box_line_draw_mode and box_line_mode_n where the box numbering, n, starts from the 
bottom box.

Note: The following parameters are only used if draw_box_mode is set to 3.

draw_box_side_1 1 // draw the left side of the title area (def)
0 // don’t draw the left side

box_side_colour_1 colour // colour to draw left side of title area
// default box_colour

draw_box_side_2 1 // draw top of the title area (default)
0 // don’t draw the top

box_side_colour_2 colour // colour to draw top of title area
// default box_colour

draw_box_side_4 1 // draw bottom of the title area (default)

boxes cross section plot
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0 // don’t draw the bottom
box_side_colour_4 colour // colour to draw bottom of title area

// default box_colour
draw_box_side_5 1 // draw left side of the heights area (def)

0 // don’t draw the left side
box_side_colour_5 colour // colour to draw left side of heights area

// default box_colour
draw_box_side_6 1 // draw top of the heights area (default)

0 // don’t draw the top
box_side_colour_6 colour // colour to draw top of heights area

// default box_colour
draw_box_side_7 1 // draw right side of the heights area def

0 // don’t draw the right side
box_side_colour_7 colour // colour for right side of heights area

// default box_colour
draw_box_side_8 1 // draw bottom of the heights area (def)

0 // don’t draw the bottom
box_side_colour_8 colour // colour for bottom of heights area

// default box_colour

The lines at the top of the individual boxes inside the title area and heights area (separation lines) are 
controlled by the parameters box_line_draw_mode and box_line_mode_n. 

The separation lines can be drawn just in the title area, just in the heights area or in both areas.

The parameter box_line_draw_mode can be set to control all the separation lines but there are 
additional parameters, box_line_mode_n, which override box_line_draw_mode for each of the 
individual boxes where n = 1, ... number of boxes -1. 

The top of the top box is not controlled by box_line_mode_n but is controlled by the parameters 
draw_box_side_2 and draw_box_side_6.

box_line_draw_mode 0 // don’t draw any separation lines inside
// the title and heights areas

1 // draw the separation lines inside the
// title and heights areas (default)

2 // draw the separation lines inside the
// title area only

3 // draw the separation lines inside the
// heights area only

box_line_mode_n 0 // for the nth box, don’t draw any
// line at the top of the box for either
// the title or the heights areas

1 // for the nth box, draw the line at the 
// top of the box for both the

heights

area
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// title and heights areas
2 // for the nth box, draw the line at the 

// top of the box for the title area only
3 // for the nth box, draw the line at the 

// top of the box for the heights area only

Finally, the right hand end of the boxes can stop at the end of the design x-section or extend to the end of 
the right_extension distance.

box_extension_mode 0 // default - stop right end of boxes at the
// end of design x-section

1 // extend right end of boxes to the end of
// the right_extension distance.

heights

area

draw this line for box_line_mode_1 = 1 or 3

values for box_line_mode_n

title

area

draw this line for box_line_mode_2 = 1 or 3

draw this line for
box_line_mode_1 = 1 or 2

title
area

left
extension

right
extension

if box_extension_mode = 1 then the boxes extend to the end of the right extension 
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Offset Titles and Values

If the label_type is set to boxes, the offsets of the points across the primary string (usually the 
design cross section) are always labelled.

offset_title text // first line of offset title (def offsets)
offset_title_2 text // second line of offset title
offset_title_textstyle textstyle // textstyle for offset title
offset_title_colour colour // offset title text colour
offset_title_size mm // offset title text size
offset_colour colour // colour of offset values
offset_textstyle textstyle // textstyle for offset values
offset_size mm // size for offset values

Example of Offset Titles Parameters

//    offset titles and values

 offset_title                       “Offset”
 offset_title_2                   “metres”
 offset_title_colour           grey

Primary String Titles and Heights

Sometimes the primary string (the design cross section) is only required to define the offset 
positions to label and the section line for the tin sections. In this case, the primary string would 
not be drawn on the cross section plot.

The drawing or not drawing of the primary string on each cross section plot is controlled by the 
parameter primary_string.

If the primary string is drawn, by default a row of labelling is included in the boxes area with up 
to two lines of title information and heights for each point across the cross section. 

primary_string yes // draw and label the primary string
no // don't draw or label the primary string

primary_title text // first line of string title
primary_title_2 text // second line of string title
primary_title_textstyle textstyle // textstyle for primary string titles
primary_title_colour colour // colour of the string titles
primary_title_size mm // primary title text size
primary_textstyle textstyle // textstyle for primary string heights
primary_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// primary title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the primary title.

primary_colour colour // colour of the primary string heights
primary_size mm // primary text size
primary_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// primary height text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the primary height text.

primary_decimals integer // number of dec places in primary height
// < 0 to keep all trailing zeros

Example of Labelling Primary String Titles



Appendix O  Plot Parameters

November 2002 Page 3463Cross Section Plot Parameter File

 primary_title                            “Design”
// primary_title_2                       “primary2” // not being used - commented out
 primary_colour                       “purple”
 primary_title_colour               “red”
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Tin Titles, Heights and Depths

A section along the primary string through each tin on the section view is automatically drawn 
on the cross section plot, but the user can specify whether the tin heights and depths are labelled 
or not in the boxes area.

Hence although there may be a number of tins drawn on the section plot, not all of them need to 
be labelled or have their depths labelled.

The default order for labelling the tins and depths is the order that they were added to the view 
but it is possible to specify which tin is used for labelling each row of tin heights and depths by 
giving the tin name rather than just using the tin order on the section view. 

In fact, it is possible to use any tin in the project to label a row, not just those drawn on the 
section view.

tin_n_name text // n=1, ... no of tins on the section view.
// use the tin called text to label the nth
// row of tin heights.

 If a tin of the name given by tin_n_name does not exist, then the plot is not produced and an 
error message is given.

For the following parameters, n takes the value 1 to 100 and specifies that the parameter set 
applies to the nth tin on the section view or if tin_n_name is set, by the tin specified by 
tin_n_name.

tin_n_draw_mode 1 // draw the nth tin (default))
0 // don’t draw the nth tin

tin_n_draw_colour colour // colour to draw the nth tin
// if omitted then use the tin colour

tin_n_label 1 // label the nth tin (default)
0 // don’t label the nth tin

tin_n_title text // first line of nth tin title
tin_n_title_2 text // second line of nth tin title
tin_n_title_textstyle textstyle // textstyle for nth tin titles
tin_n_title_colour colour // colour for nth tin titles
tin_n_title_size mm // size for nth tin titles
tin_n_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// tin title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the tin heights.

tin_n_decimals integer // number of dec places in tin height
// < 0 to keep all trailing zeros

tin_n_textstyle textstyle // textstyle of the tin heights
tin_n_colour colour // colour for heights and depths
tin_n_size mm // default nth tin’s title size
tin_n_y_pos mm //if set, the height in mm above the

//bottom of all the boxes that the
// tin height text is drawn.
//If not set, then the text is placed at a
//height that puts it inside the default
// box for the tin heights.

tin_n_depth_label 1/0 // 1 to label, 0 don't label depths
tin_n_depth_title text // first line of tin depth title
tin_n_depth_title_2 text // second line of tin depth title
tin_n_depth_title_textstyle textstyle // textstyle of the tin depth titles



Appendix O  Plot Parameters

November 2002 Page 3465Cross Section Plot Parameter File

tin_n_depth_title_colour colour // colour for titles of depths
tin_n_depth_title_size mm // size for title of depths
tin_n_depth_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// tin depth title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the tin heights.

tin_n_depth_decimals integer // number of dec places in tin height
// < 0 to keep all trailing zeros

tin_n_depth_textstyle textstyle // textstyle of the tin depths 
tin_n_depth_colour colour // colour for depths
tin_n_depth_size mm // size for depths
tin_n_depth_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// tin depth text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the tin heights.

Definition of Depth to a Tin or to Offset Strings 

The depth from the primary string to a tin, at a particular offset is defined as

depth = tin height value - height of the primary string

That is, the depth that the primary string is below the tin.

Before plotting, the value of depth is multiplied by either the depth_positive_factor or 
depth_negative_factor.

if (depth >= 0) plotted_depth_value = depth * depth_positive_factor

if (depth < 0) plotted_depth_value = depth * depth_negative_factor

Hence the definition of depth can be modified by the parameters:

depth_positive_factor value // multiplier for positive depths

depth_negative_factor value // multiplier for negative depths

For example, if the opposite sign is required for depth, that is,

depth     =     height of the primary string   -   tin height value

simply set

depth_positive_factor -1

depth_negative_factor- 1

Example of Labelling Tins

//    tin label 1 for on
// 0 for off

 tin_1_label                            1

 tin_1_title                            “Natural”
// tin_1_title_2                      “Surface”
 tin_1_colour                         grey
 tin_1_title_colour                 red
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 tin_2_label                            1
 tin_2_title                            “Water table”
 tin_2_colour                          grey
 tin_2_title_colour                 red

 Labelling the Design Height, X and Y Co-ordinates and Tin Heights at Offset Zero

The values of the height and X and Y co-ordinates of the primary string (usually the design cross 
section) at the zero offset can be labelled. Note that zero offset is normally where the alignment 
string cuts the cross section.

The heights of any tins (such as the natural surface) at the zero offset can also be labelled.

The labels are made up of:

pre_text    value    post_text

where value is either a height or a co-ordinate.

The label is positioned at either the left, right or middle of the datum line, with an x and y 
adjustment and a rotation.

Parameters for labelling the X Co-ordinate at Zero Offset:

primary_x0_draw_mode 0 // don’t draw the label -default
1 // draw the label

primary_x0_pre_text text // pre-text for label - def " "
primary_x0_post_text text // post-text for label - def " "
primary_x0_decimals integer // number of decimal places to display - def 1

// If > 0, trailing zeros are removed after
// the decimal point
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

primary_x0_x mm // x adjustment to position of label - def 0
primary_x0_y mm // y adjustment to position of label - def 0
primary_x0_angle degrees // angle of the label - def 0
primary_x0_colour colour // colour of the label
primary_x0_size mm // size (in mm) of the label
primary_x0_textstyle textstyle // textstyle of the label
primary_x0_justify just // justification for text

Parameters for Labelling the Y Co-ordinate at Zero Offset:

primary_y0_draw_mode 0 // don’t draw the label -default
1 // draw the label

primary_y0_pre_text text // pre-text for label - def " "
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primary_y0_post_text text // post-text for label - def " "
primary_y0_decimals integer // number of decimal places to display - def 1

// If > 0, trailing zeros are removed after
// the decimal point
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

primary_y0_x mm // x adjustment to position of label - def 0
primary_y0_y mm // y adjustment to position of label - def 0
primary_y0_angle degrees // angle of the label - def 0
primary_y0_colour colour // colour of the label
primary_y0_size mm // size (in mm) of the label
primary_y0_textstyle textstyle // textstyle of the label
primary_y0_justify just // justification for text

Parameters for Labelling the Height of Primary String at Zero Offset:

primary_height_draw_mode 0 // don’t draw the label -default
1 // draw the label

primary_height_pre_text text // pre-text for label - def " "
primary_height_post_text text // post-text for label - def " "
primary_height_decimals integer // number of decimal places to display - def 1

// If > 0, trailing zeros are removed after
// the decimal point
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

primary_height_x mm // x adjustment to position of label - def 0
primary_height_y mm // y adjustment to position of label - def 0
primary_height_angle degrees // angle of the label - def 0
primary_height_colour colour // colour of the label
primary_height_size mm // size (in mm) of the label
primary_height_textstyle textstyle // textstyle of the label
primary_height_justify just // justification for text

Parameters for Placing Some Text:

extra_text_draw_mode 0 // don’t draw the label -default
1 // draw the label

extra_text_pre_text text // pre-text for label - def " "
extra_text_post_text text // post-text for label - def " "
extra_text_decimals integer // number of decimal places to display - def 1

// If > 0, trailing zeros are removed after
// the decimal point
// If < 0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

extra_text_x mm // x adjustment to position of label - def 0
extra_text_y mm // y adjustment to position of label - def 0
extra_text_angle degrees // angle of the label - def 0
extra_text_colour colour // colour of the label
extra_text_size mm // size (in mm) of the label
extra_text_textstyle textstyle // textstyle of the label
extra_text_justify just // justification for text
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Offset Selection for Uprights and Staggering of Heights

For each sub-plot, the offsets of the points across the x-section string (primary string) are used for 
positioning uprights (leader lines), and the offset and height labels for the uprights.

By default, there is an upright at each point across the primary string.

However, if the primary string is a 4d string, then the text at the points on the 4d string can be 
used as a key to suppress the labelling and upright at that point.

The parameters to stop labelling and uprights are:

mask_name_n 4d_string_point_text                where n=1,100

Note -the text 4d_string_point_text can include wild cards (*) and characters (?).

After any name masks have been applied, it is often desirable to weed out offset values that are 
too close together before doing any labelling.

offset_label_tolerance value // weed out offset values closer together
// (in offset units) than this value

If the real offset position is used for the horizontal position of the offset/height text, text over 
writing can easily occur. To prevent over writing, the text is automatically staggered.

When staggering occurs, the real offset position is then indicated by the offset markers which are 
drawn at the top of the text boxes from the staggered text position back to the actual offset 
position of the text.

The size and position of the staggers are given by:

stagger_gap_top mm // distance from boxes to top of stagger
stagger_gap_bottom mm // distance from boxes to bottom of 

// stagger
stagger_gap_factor value // distance between staggers is

// box_text_size * stagger_gap_factor
When staggering occurs, it is possible for the heights area to be wider than the graph area.

boxes cross section plot

title
area top of boxes

stagger_gap_bottom
stagger_gap_top
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Uprights

Uprights (leader lines) can be drawn from the top of the staggers to strings drawn on the plot.

The height of the uprights is given by the uprights_draw_mode:

uprights_draw_mode 0 // none
1 // to maximum string height at that

// chainage
2 // ticks, to stagger height
3 // to uprights_y above the boxes
100 // to the primary string
101-500 // to tin1 or tin2 etc.

uprights_y mm // distance to draw the uprights for
// mode 3

uprights_colour colour // uprights colour (def boxes colour)
The uprights can go below the top of the boxes.

uprights_bottom_mode 0 // stop at top of boxes (default)
1 // draw to bottom of boxes
2 // draw to uprights_bottom_y below the

// top of the boxes
3 // draw to uprights_bottom_y above the

// bottom of the boxes
4 // ticks at chainage

uprights_bottom_y mm //distance
uprights_text_offset_factor value // move the text by this factor*size 

When uprights go below the top of the boxes, the height and offset text is moved to the left so that the 
upright does not go through the text. The left hand side of the heights boxes also moves to the left to leave 
room for the height text.
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Please continue to the next section “Graph Area” .
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Graph Area 
The graph area for each section sub-plot is the area where the actual plot of the x-section string is 
drawn.

The width of the graph area is determined by the width of the x-section string being plotted, the 
left and right extensions and horizontal scale (scale) given by parameters or in the section x plot 
panel, and the vertical exaggeration given by the section view or a parameter.

view_name text // default is section view in panel.
vertical_exaggeration value // default is vertical exag for view
scale value // 1:value - horizontal scale, default is 

// scale 1: in panel.
left_extension world-units                // left extension value
right_extension world-units             // right extension value

The vertical scale is determined by the horizontal scale and the vertical exaggeration.

The height of the graph area is determined by the vertical scale (given by the horizontal scale 
and the vertical exaggeration) and the minimum and maximum values of the data being plotted. 
Hence the graph height is a calculated rather than a given value.

The size of the graph area can also be extended to allow for symbols by the parameters:

extra_space_units 0 // extra space values are world units - default
1 // " " " are millimetres on plot page

extra_space_left units // subtract from left of plot area, def 0
extra_space_right units // add to right of plot area, default 0
extra_space_top units // add to top of plot area, default 0
extra_space_bottom units // subtract from bottom of plot area,

// default 0

The types of strings that are drawn in the graph area of a cross section plot are:

(a) primary string    the x-section string from the x-section model that is being drawn.
Called the primary string and is usually the design x-section.

(b) tins sections of the primary string through any tins either in models on the section
view or in corridor models.

(c) services parts of strings (from either models on the section view or in corridor models)
that cut the defined corridor.

The colour of the strings in the plot is the actual string colour for cases (a) and (c), and the colour 
of the tin used for the section in case (b).

Although all the strings are plotted, the plot parameter file can be used to select which ones are 
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labelled with heights.

Primary String (Design Cross Section)

The primary string (the design cross section) is used to define

(a) the design cross section

(b) the chainage of the section

(c) the offset positions for labelling heights and drawing uprights

(d) the section line used for sectioning through tins

(e) the section line for defining the corridor for services

Although the primary string is used to set up most of the information for the cross section plot, it doesn’t 
have to be drawn on the cross section. 

The drawing or not drawing of the primary string on each cross section plot is controlled by the 
parameter primary_string which was described earlier.

The colour of the primary string in the plot is the actual primary string colour.

Tins

A section along the primary string through each tin on the specified section view is 
automatically drawn on the cross section plot.

The colour and linestyle of the tin section in the plot is the actual tin colour and tin linestyle.

Whether the tin heights are labelled or not in the boxes area is controlled by parameters and has 
been described earlier

Corridor and Services

A corridor around the primary string is defined by giving a left and right corridor width and a 
left and right extension.

Any string in a model added to the section view is checked to see if it appears in the corridor, 
and if it does, then it is drawn on the cross section plot.

Strings do not have to cross the primary string, but just be in the corridor.

The corridor defining parameters are 

primary string

corridor_width_left

corridor_width_right

pipe string
strings (no diameter)

plan view

(design x- section)

left_extension

right_extension

section viewtin (natural surface)

design x- section

services in the corridor
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left_extension world-units                // left extension value
right_extension world-units             // right extension value
corridor_width_left world-units // corridor left and right widths
corridor_width_right world-units // defaults are the section view values
corridor_overlap_left world-units // corridor left and right overlaps.
corridor_overlap_right world-units // defaults are the section view values 
corridor_chord_arc world-units // chord-arc tolerance used to

// approximate arcs in the corridor.
// default is the section view value

The models containing tins for sectioning and strings for services are taken from the section view or given 
by the parameters

corridor_model_n model // n = 1, 2 ... 100
// models containing tins and service
// strings to be drawn on the view.

If any corridor_model_n parameters are defined, then only the models given by the parameters are used. If 
no corridor_model_n parameters are set, then the models added to the given section view are used.

That is, either the corridor_model_n parameters are used or if none exist, then the models added to 
the section view are used for tins and service strings.

The colour and diameter of the service strings drawn in the plot are the actual strings colour and 
diameter.

Please continue to the next section “Grade Labelling” .

Grade Labelling
The plot of the x-section string is made up of straight lines joining the individual points of the x-
section.

The grades of these lines can be labelled:

grade_label 0 // don’t label grades (default)
1 // label grades

Either the individual lines can be used as the segments to be labelled for grade, or adjacent lines of the 
same grade can be considered to be just one segment and labelled only once.

Hence the segments to be labelled for grade can be the individual lines of the x-section, or the 
segments defined by changes of grade.

grade_change_only 0 // label individual lines 
1 // label change of grade segments

It is also possible to ignore segments smaller that a given minimum width on the plot.

grade_minimum_width       mm // segments smaller are not labelled
The grade labels are drawn parallel to the segment, centred about the segments end points, and a 
distance grade_offset above the segment. The size, colour and number of decimal places can all be 
set.

grade_decimals integer // number of decimal places in grade
grade_size mm // size of the grade label
grade_textstyle text // textstyle of the grade label
grade_colour colour // colour of the grade label
grade_offset mm // distance above the segment for label
grade_signed yes // default - grades are signed

no // absolute value of grades

The grade can be labelled as percent cross-fall, 1 in slope, m/m or VicRoads x:1.

Also a threshold value can be set and any grades whose absolute value are below the threshold 
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can be labelled in one way, and those above the threshold labelled a different way.

Hence, if the absolute value of the grade is less that or equal to the absolute value of 
grade_threshold, then grade_mode is used, otherwise grade_upper_mode is used.

grade_mode 0 // % grade
1 // 1 in
2 // m/m
3 // VicRoads x:1

grade_threshold value // grade threshold for type of grade
// labelling

grade_threshold_mode 0-3 // type of grade value given in
// grade_threshold types are the same as
// grade_mode

grade_upper_mode 0 // % grade
1 // 1 in
2 // m/m
3 // VicRoads x:1

grade_upper_decimals integer // number dec places in grades above
//   threshold value

Example of Grade Labelling

 grade_label                            1 // turn grade labels on 
 grade_mode                             0 // percent grade
 grade_decimals                         1 // one decimal place, no trailing zeros
 grade_change_only                     1 // only label when change of grade

// text size for grade annotations

 grade_size                                 2
 grade_colour                            yellow

// how far the annotation is (perpendicularly)
//  from the string itself

 grade_offset                               1

// label all annotations separated by more than
// the minimum width in plot units

 grade_minimum_width                0

// threshold and threshold mode describe the value
//  at which the grade labelling changes
//  mode to grade_upper_mode

 grade_threshold                          7 // change labelling when over 7%
 grade_threshold_mode                0 // units for threshold - %
 grade_upper_mode                      1 // label as 1:x

Please continue to the next section “Labelling Points of the X-Sections” .

section view
tin (natural surface)

design x- section
3% 3%

1:2
1:3
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Labelling Points of the X-Sections 
The points across each x-section can be automatically labelled on the x-section plots.

The height, offset and name of the point can be labelled as well as a symbol drawn. The height 
of tins at the same offset value can also be labelled.

The offset position for the labelling is the offset of the point.

The height position for the labelling can be specified as the

(a) top of the boxes for the x-section

(b) above the maximum height of the strings on the plot

(c) height of the point on the x-section string (primary string)

(d) height of a tin.

The actual position of the label is defined relative to the above point.

Note: 

Only case (b) involves the actual height of the point on the cross section string. For all other 
cases, only the offset of the cut string is used.

Other heights, for example, the height of the tin at that offset can be used as the height (case (d)).

Text justification refers to the actual position and is given by

“top-left” “top-centre”                   “top-right”
“middle-left” “middle-centre”            “middle-right”
“bottom-left” “bottom-centre”            “bottom-right”

A choice of six special symbols and/or or any of the 12d symbols can be drawn at the cut point.

The special 12d Model symbols of size one millimetre are drawn in a square box centred on (0,0) 
with sides of length two millimetres. That is, the box co-ordinates are (-1,-1), (1,1), (1,-1), (-1,-1).

The six special shapes are

Up to twenty five (25) separate sets of points can be labelled.

section viewtin (natural surface)

design x- section

denotes points on the x-section

 

for labelling

The x-section point can be labelled with

offset of the point

height of the point

height of any tin at this offset
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Parameters for Labelling Points of X-Sections

The points of the x-section to be for labelled for the nth set of parameters is restricted to all the 
points whose name satisfying the points_n_mask:

points_n_mask point_names                        // points to be labelled

where point_names is a text string containing the name masks, each separated by one or more 
spaces, to test the point name against. Each mast can include wild cards and wild characters.

For example

points_1_mask "ke*"

or points_1_mask "?bank*"

or, if both masks are required,

points_1_mask "ke* ?bank*"

The parameters for drawing a symbol are 

points_symbol_n_mode 0 // cross
1 // up from centre of box
2 // up and down from centre of box
3 // square
4 // triangle, base at bottom
5 //circle
6 // use a 12d symbol

If points_symbol_n_mode is 6, then the plot symbol is given by

points_symbol_n_style plotsymbol // name of the 12d symbol to draw at 
point

Important Note

 The plot symbol of name plotsymbol is defined in the file given by:

(a) the parameter plot_symbols in the ppf file

plot_symbols filename

or if plot_symbols is not defined, then

(b) in the file pointed to by the environment variable PLOT_SYMBOLS_4D

PLOT_SYMBOLS_4D filename // default plotsym.4d

or if PLOT_SYMBOLS_4D is not defined, then

(c) in the file plotsym.4d

which is searched for in the standard set up file sequence

If none of the above files are defined, or if the symbol does not exist in the above files, then it will 
be searched for in the standard 12d symbols file which is:

(d) either pointed to by the environment variable SYMBOLS_4D

SYMBOLS_4D filename // default symbols.4d

or if the environment variable SYMBOLS_4D does not exist, in the file, symbols.4d 

0 1 2 3 4 5

predefined symbols for 
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The position of the symbol is given by:

points_symbol_n_position 1 // above point height value
3 // above top of boxes
4 // above top of graph area but not including

// the extra_space_top 
100 // to primary string (same as 1)
101-500 // to tin1 or tin2 etc.

The symbol can be adjusted by the parameters:

points_symbol_n_x mm // offset adjustment to position
points_symbol_n_y mm // height adjustment to position
points_symbol_n_angle degrees // rotation about point
points_symbol_n_colour colour // colour of symbol

and for all values of points_symbol_n_mode other than 6:

points_symbol_n_size mm // size of symbol, 0 don’t draw

The value of the offset of the point can be labelled using the parameters

points_offset_n_position 1 // above point height value
3 // above top of boxes
4 // above top of graph area but not including

// the extra_space_top 
100 // to primary string
101-500 // to tin1 or tin2 etc.

points_offset_n_x mm // offset adjustment to position
points_offset_n_y mm // height adjustment to position
points_offset_n_angle degrees // rotation about point
points_offset_n_size mm // size of text, 0 don’t label
points_offset_n_colour colour // colour of text
points_offset_n_textstyle textstyle // textstyle to use for points offset text.
points_offset_n_pre_text text // text before the offset value
points_offset_n_post_text text // text after the offset value
points_offset_n_justification  justification            // justification of the text
points_offset_n_no_decimals       integer                  // number of decimals in offset

The value of a height at the offset of the point can be calculated and labelled using the parameters

points_height_n_mode 1 // use height of point itself
3 // use real world height of position

// above boxes
100 // height of primary string (same as 1)
101-500 // use height of to tin1 or tin2 etc.

points_height_n_position 1 // at points position
3 // above top of boxes
4 // above top of graph area but not including

// the extra_space_top 
100 // to primary string (same as 1)
101-500 // to tin1 or tin2 etc.

points_height_n_x mm // offset adjustment to position
points_height_n_y mm // height adjustment to position
points_height_n_angle degrees // rotation about point
points_height_n_size mm // size of text, 0 don’t label
points_height_n_colour colour // colour of text
points_height_n_textstyle textstyle // textstyle to use for points height text.
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points_height_n_pre_text        text // text before the height value
points_height_n_post_text        text // text after the height value
points_height_n_justification justification    // justification of the text
points_height_n_no_decimals          integer           // number of decimals in height

A label which can include the name of the point is drawn by using the parameters

points_label_n_position 1 // at the points position
3 // above top of boxes
4 // above top of graph area but not including

// the extra_space_top 
100 // to primary string (same as 1)
101-500 // to tin1 or tin2 etc.

points_label_n_mode 0 // don’t include point name
1 // include point name in label

points_label_n_x mm // offset adjustment to position
points_label_n_y mm // height adjustment to position
points_label_n_angle degrees // rotation about point
points_label_n_size mm // size of text, 0 don’t label
points_label_n_colour colour // colour of text
points_label_n_textstyle textstyle // textstyle to use for points label text.
points_label_n_pre_text     text // text before the point name
points_label_n_post_text     text // text after the point name
points_label_n_justification         justification         // justification of the text

Please continue to the next section “Labelling Cuts of X-Sections Through Strings in a Model” .
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Labelling Cuts of X-Sections Through Strings in a Model
The cuts that each x-section string makes though any strings in user given models can be 
automatically labelled on the x-section plots.

The height, offset and name of the cut string can be labelled as well as a symbol drawn. The 
height of tins at the same offset value can also be labelled.

The offset position for the labelling is the offset of the cut string.

The height position for the labelling can be specified as the

(a) top of the boxes on the x-section

(b) above the maximum height of the strings on the plot

(c) height value of the cut string

(d) height of the x-section string (the primary string)

(e) height of a tin.

The actual position of the label is defined relative to the above point.

Note: 

Only case (b) involves the actual height of the cut string. For all other cases, only the offset of the 
cut string is used. Hence for all cases except (b), the string does need to have a sensible height to 
be used for cuts through strings. 

For example, a boundary string may have null heights but only the offset is required and the 
height of the tin at that offset can be used as the height (case (d)).

Text justification refers to the actual position and is given by

“top-left” “top-centre”                   “top-right”
“middle-left” “middle-centre”            “middle-right”
“bottom-left” “bottom-centre”            “bottom-right”

A choice of six special symbols and/or or any 12d symbols can be drawn at the cut point.

The special 12d Model symbols of size one millimetre are drawn in a square box centred on (0,0) 
with sides of length two millimetres. That is, the box co-ordinates are (-1,-1), (1,1), (1,-1), (-1,-1).

The six special shapes are

Up to twenty five (25) separate models of strings can be cut and labelled.

primary string

plan view

(design x- section)

left_extension

right_extension

section viewtin (natural surface)

design x- section

strings to label where they are cut by the cross section

points where strings are
cut in plan by the x-section 
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Parameters for Labelling Cuts of X-Sections Through Strings in a Model

The method for specifying which strings are to be checked for cuts is by first specifying the 
model which contains the strings, and then a name mask which is used to restrict the strings in 
the model to only those whose name matches the name mask.

Up to twenty five different sets of models and name masks can be used so that different cut sets 
can be labelled in different ways.

The parameters for selecting and labelling the nth set (where n can be from 1 to 25) of cuts of the x-
sections with the strings in the model are given by:

cuts_n_model model_name                        // model of strings to be cut

The selection of the strings from the model model_name whose cut points are to be labelled is all the 
strings whose name satisfies the name mask cuts_n_mask:

cuts_n_mask name_mask                       // strings to check for cuts
// and if a cut occurs,

// parameters show how to
// label the cut

where name_mask is a text string containing the name masks, each separated by one or more 
spaces, to test the string name against. Each mast can include wild cards and wild characters.

For example

cuts_1_mask "ke*"

or cuts_1_mask "?bank*"

or, if both masks are required,

cuts_1_mask "ke* ?bank*"

If cuts_n_mask is missing, then all strings in the model are used. This is equivalent to name_mask being 
"*".

All strings in the model cuts_n_model whose name satisfy the name mask cuts_n_mask are then 
checked for cuts with the x-sections, and if a cut occurs, the cut point will be labelled according 
to the rest of the parameters in the nth set.

The parameters for drawing a symbol at the cut points are: 

cuts_symbol_n_mode 0 // cross
1 // up from centre of box
2 // up and down from centre of box
3 // square
4 // triangle, base at bottom
5 // circle
6 // use a 12d symbol

If cuts_symbol_n_mode is 6, then the plot symbol is given by

cuts_symbol_n_style plotsymbol // 12d symbol to draw at cut

Important Note

 The plot symbol of name plotsymbol is defined in the file given by:

(a) the parameter plot_symbols in the ppf file

plot_symbols filename

0 1 2 3 4 5

predefined symbols for 
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or if plot_symbols is not defined, then

(b) in the file pointed to by the environment variable PLOT_SYMBOLS_4D

PLOT_SYMBOLS_4D filename // default plotsym.4d

or if PLOT_SYMBOLS_4D is not defined, then

(c) in the file plotsym.4d

which is searched for in the standard set up file sequence

If none of the above files are defined, or if the symbol does not exist in the above files, then it will 
be searched for in the standard 12d symbols file which is:

(d) either pointed to by the environment variable SYMBOLS_4D

SYMBOLS_4D filename // default symbols.4d

or if the environment variable SYMBOLS_4D does not exist, in the file, symbols.4d 

The position of the symbol is given by:

cuts_symbol_n_position 1 // above point height value
3 // above top of boxes
4 // above top of graph area but not including

// the extra_space_top 
100 // to primary string 
101-500 // to tin1 or tin2 etc.

The symbol can be adjusted by the parameters:

cuts_symbol_n_x mm // offset adjustment to position
cuts_symbol_n_y mm // height adjustment to position
cuts_symbol_n_angle degrees // rotation about point
cuts_symbol_n_colour colour // colour of symbol

and for all values of cuts_symbol_n_mode other than 6:

cuts_symbol_n_size mm // size of symbol, 0 don’t draw

The value of the offset of the cut string can be labelled using the parameters

cuts_offset_n_position 1 // above cut strings height value
3 // above top of boxes
4 // above top of graph area but not including

// the extra_space_top 
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_offset_n_x mm // offset adjustment to position
cuts_offset_n_y mm // height adjustment to position
cuts_offset_n_angle degrees // rotation about point
cuts_offset_n_size mm // size of text, 0 don’t label
cuts_offset_n_colour colour // colour of text
cuts_offset_n_textstyle textstyle // textstyle to use for cuts offset text.
cuts_offset_n_pre_text text // text before the offset value
cuts_offset_n_post_text text // text after the offset value
cuts_offset_n_justification  justification            // justification of the text
cuts_offset_n_no_decimals integer                    // number of decimals in offset

The value of a height at the offset of the point can be calculated and labelled using the parameters

cuts_height_n_mode 1 // use height of cut point itself
3 // use real world height of position

// above boxes
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100 // height of primary string
101-500 // use height of to tin1 or tin2 etc.

cuts_height_n_position 1 // at points position
3 // above top of boxes
4 // above top of graph area but not including

// the extra_space_top 
100 // to primary string 
101-500 // to tin1 or tin2 etc.

cuts_height_n_x mm // offset adjustment to position
cuts_height_n_y mm // height adjustment to position
cuts_height_n_angle degrees // rotation about point
cuts_height_n_size mm // size of text, 0 don’t label
cuts_height_n_colour colour // colour of text
cuts_height_n_textstyle textstyle // textstyle to use for cuts heights text.
cuts_height_n_pre_text text // text before the height value
cuts_height_n_post_text text // text after the height value
cuts_height_n_justification justification // justification of the text
cuts_height_n_no_decimals integer // number of decimals in height

A label which can include the name of the cut string is drawn by using the parameters:

cuts_label_n_position 1 // above cut strings height value
3 // above top of boxes
4 // above top of graph area but not including

// the extra_space_top 
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_label_n_mode 0 // don’t include cut string name
1 // include cut string name in label

cuts_label_n_x mm // offset adjustment to position
cuts_label_n_y mm // height adjustment to position
cuts_label_n_angle degrees // rotation about point
cuts_label_n_size mm // size of text, 0 don’t label
cuts_label_n_colour colour // colour of text

cuts_label_n_textstyle textstyle // textstyle to use for cuts label text.

cuts_label_n_pre_text text // text before the string name
cuts_label_n_post_text text // text after the string name

cuts_label_n_justification justification // justification of the text

section viewtin (natural surface)

design x- section

point where the x-section
cuts a string 

The cut point can be labelled with

offset of the cut point

height of the cut point

height of the x-section or tins at 
this offset

name of the string for the cut 



Appendix O  Plot Parameters

November 2002 Page 3483Cross Section Plot Parameter File

Please continue to the next section “Hatching Cut and Fill Areas” .
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Hatching Cut and Fill Areas
This option is used to hatch cut and/or fill areas between sets of tins.

For each set, the name of the two tins, the hatch linestyle, colour and separation and whether cut 
and/or fill regions are required are all user definable.

Up to twenty (20) separate sets of tins be hatched.

The parameters for labelling cuts and/or fill regions between tins are given by:

hatch_original_tin_n tin_name // tin_name for original surface
hatch_new_tin_n tin_name // tin_name for final surface

hatch_cut_separation_n mm // distance between cut hatch lines
0 // don’t do cut hatching

hatch_cut_angle_n degrees // angle in degrees of cut hatching
hatch_cut_colour_n colour // colour of the cut hatching
hatch_cut_linestyle_n linestyle // linestyle for cut hatching
hatch_cut_draw_sides_n 1/0 // 1 = draw sides of cut regions
hatch_cut_draw_original_n 1/0 // 1 = draw original tin in cut regions
hatch_cut_draw_new_n 1/0 // 1 = draw new tin in cut regions
hatch_fill_separation_n mm // distance between fill hatch line

0 // don’t do fill hatching
hatch_fill_angle_n degrees // angle in degrees of fill hatching
hatch_fill_colour_n colour // colour of the fill hatching
hatch_fill_linestyle_n linestyle // linestyle for fill hatching
hatch_fill_draw_sides_n 1/0 // 1 = draw sides of fill regions
hatch_fill_draw_original_n 1/0 // 1 = draw original tin in fill regions
hatch_fill_draw_new_n 1/0 // 1 = draw new tin in fill regions

Notes

(a) cut is when the new tin is below the original tin.
fill is when the new tin is above the original tin.

(b) cut hatching is turned off by setting hatch_cut_separation_n to 0.0.
fill hatching is turned off by setting hatch_fill_separation_n to 0.0.

Please continue to the next section “Extra Models of X-Sections” .

section viewtin (natural surface)

design x- section

cut

fill
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Extra Models of X-Sections
The order and centreline chainages of the x-section subplots for the x-section plot are defined by 
the sections from the primary model of cross sections.

The sections through any specified triangulations and service models, and offsets for labelling 
are fully defined by these primary x-sections.

However it is also possible to plot extra x-sections on each of the sub-plots by supplying extra 
models of x-sections which are at the same plan positions as the primary x-section strings.

Only those x-sections from the extra models that are within a user specified tolerance of a 
primary x-section are plotted.

The extra models of x-sections and the plan tolerance for checking that the extra cross-sections 
are the same position as the primary x-sections are

extra_model_tolerance_1        value                  // tolerance in 12d Model units

extra_model_n       model_name              // where n=1, ... 100
                 // extra models of x-sections 

The actual colour of the extra x-sections is used as their plotting colour.

Please continue to the next section “Sorting X-Sections by Chainage” .

Sorting X-Sections by Chainage
The chainage on the design string that the x-section is created at is stored with the cross-section.

When the x-sections are created by the apply functions, they are created in the order of 
increasing chainage and added to the model for sections in that order.

Hence if the cross sections are plotted, the natural order would be in increasing chainage order.

However, it is possible to upset the order in the model by manually adding in extra sections.

Hence there is a parameter in both the section x plot panel and the plot parameter file to ensure 
that the cross sections are sorted in increasing chainage order before they are plotted.

sort_sections 1 // sort sections by design chainage
0 // use order of sections in model

Please continue to the next section “Title Block Information” .
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Title Block Information
The plot can have a standard 12d Model title block or a user defined title block.

The standard title block consists of a simple border around the plot and two lines of text in a box 
underneath the plot. For a user defined title block, all the line work and text is defined by the 
user.

Standard Title Block

For the standard 12d Model title block, there are extra parameters for two lines of text and text 
size and colour. The standard title block is turned on or off by the parameter plot_border.

plot_border yes/no // yes plots a standard title block
// default yes

title_1 text
title_2 text
title_text_size value
title_colour colour

User Title Block

For the user defined title block, the title block drawing commands are kept in a file whose name 
is supplied by the user. The title block drawing commands are almost identical to the linestyle 
drawing commands and is given at the beginning of this chapter.

Hence for a user defined title block, there are just two parameters - one to say a title block file is 
being used and the other to give the name of the title block file. The plot_border parameter should 
also be set to no so that the standard title block is not also drawn.

use_title_file yes/no // yes draws the title block given in title_file
// default no

title_file filename
plot_border no // turn off standard title block

Some special plot parameters are used to pass information down to variables in a user defined title block. 
For example, inside the title block file it is possible to have runtime user defined text variables. The actual 
text values for these text variables are passed down to the title block file from the plot parameter file via 
the parameters user_text_n (n = 1,2,... 1000)

user_text_n text
The special plot parameters are:

time_format text // format for $time
user_text_n text // where n = 1,2,... 1000

// passed down to $user_text_n
title_1 text // passed down to $title_1
title_2 text // passed down to $title_2
start_page_number integer // used as the starting value for

//   $page_number. If missing, 
//   $page_number starts at 1.

start_drawing_number integer // added to $drawing_number in title
// block file. If missing,
// $drawing_number starts at 1.

drawing_number_prefix text // passed down to
//   $drawing_number_prefix

drawing_number_postfix text // passed down to
// $drawing_number_postfix

Please continue to the next section “Parameters that Modify Fields In the Cross Plot Panel” .
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Parameters that Modify Fields In the Cross Plot Panel
A number of parameters match those in the section x plot panel.

When the plot parameter file is first read, any parameters in the panel will be replaced by the 
values of any corresponding parameters in the parameter file.

However, if the parameter is subsequently modified in the panel, the panel value will be the 
value used for any plots.

The plot parameters that also occur in the section x plot panel are:

view_name text
plotter_type text
model_to_plot text
plot_stem text

start_chainage chainage
end_chainage chainage

sheet_size text         or    “width height”
scale value

absolute_extensions yes/no
left_extension world-units
right_extension world-units

line_up_cl yes/no
primary_string yes/no
label_type yes/no
box_colour colour
text_size mm

sort_sections yes/no

use_title_file yes/no
title_file filename
plot_border yes/no
title_1 text
title_2 text
title_text_size value
title_colour colour

global_textstyle textstyle
Please continue to the next section “Generating Cross Section Plots Without a View” .

Generating Cross Section Plots Without a View
The cross section plot parameters are comprehensive enough that it is possible to completely 
generate a cross section plot without referencing a section view, or even using the section X plot 
panel. 

Such a ppf can be run using the plots=>plot a ppf option or from the 4D Solutions programming 
language, 4DL.

When generating a cross section plot using the section X plot panel, a plot parameter file 
containing all the parameters needed to regenerate the plot using plots=>plot a ppf can be written 
out by simply giving a name for the ppf file in the plot parameters write field of the section X plot 
panel.

Notes

1. A warning is given if the keyword in a plot parameter file does not exist.

2. A warning is also given if the key word pair is defined more than once in a ppf.

Please continue to the next section “Example of a Cross Section Plot Parameter File” .



12d Model Reference Manual

Page 3488 November 2002Cross Section Plot Parameter File

Example of a Cross Section Plot Parameter File
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// ppf file to generate x-section example

section_x_plot “plot 2” {

// plot margins

 left_margin                             0.0
 right_margin                          0.0
 top_margin                             0.0
 bottom_margin                      0.0

// white space surrounding each cross section

 left_sub_plot_gap                       20.0
 right_sub_plot_gap                    20.0
 top_sub_plot_gap                      20.0
 bottom_sub_plot_gap                20.0

// these are only used with title boxes

 ‘                         10.0
 right_border_gap                      10.0
 top_border_gap                        10.0
 bottom_border_gap                  10.0

// annotation for boxes area 

//    height text on centre line plot

 height_text                           “Height”

// mode for drawing boxes around
//  0 = none
//  1 = heights area 
// 2 = heights and labels area

 draw_box_mode                          1     
 box_line_draw_mode                  3   
 box_colour                             grey

// size of title text in title box

 title_box_text_size                            5

// title text box size - automatically calculated if missing
// space_for_titles                        30
// horizontal_line_spacing              15

//   number of decimal places for height and offset values

 number_of_decimals                      1

// 0 for bottom justification of values
//  1 for top justification of values

 box_text_justification                    1

//    offset titles and values

 offset_title                       “Offset”

// offset_title_2                “Offset 2”
// offset_colour                  brown // also in panel

 offset_title_colour           grey

//   primary string titles and heights
//   defaults to string name and colour

 primary_title                            “primary”
// primary_title_2                     “primary2”
 primary_colour                       “purple”
 primary_title_colour               “red”
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//    tin titles and heights

//    tin label 1 for on
// 0 for off
//    tin text is the annotation text for that tin
//    tin colour is the annotation colour for that tin
//    range from tin_1_X to tin_100_X

 tin_1_label                            1
 tin_1_title                            “1st tin”
// tin_1_title_2                        “1st tin 2”
 tin_1_colour                         grey
 tin_1_titlel_colour                 red

 tin_2_label                            1
 tin_2_title                            “2nd tin”
 tin_2_colour                          grey
 tin_2_title_colour                 red

//   staggers definitions

 stagger_gap_factor                    1.3
 stagger_gap_top                        5.0
 stagger_gap_bottom                  2.0

//   uprights definitions

// mode 0 = none
// 1 = full
// 2 = ticks
// 3 = height above boxes
// 100 = primary
// 101 = 1st tin
// 102 = 2nd tin
//...
// 500 = 400th tin

 uprights_colour                        red
 uprights_draw_mode               100
 uprights_y                                100

// datum area

 datum_name                            “Datum”
 datum_colour                           orange
 datum_text_size                        4
 datum_below_gap                    10.0

// gap above datum to graph area for box and
//  centre line plots

 datum_above_gap                       20
 datum_above_gap_cl                  20

// grade_label of 0 turns the labels off
// 1 turns it on

 grade_label                            1

// mode 0 for percent grade,
// 1 for one in x,
// 2 for grade in m/m

 grade_mode                             0
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// grade decimal places

 grade_decimals                         1

// text size for grade annotations

 grade_size                                 2
 grade_colour                            yellow

// how far the annotation is (perpendicularly)
//  from the string itself

 grade_offset                               1

// label all annotations separated by more than
// the minimum width in plot units

 grade_minimum_width                0

// threshold and threshold mode describe the value
//  at which the grade labelling changes
//  mode to grade_upper_mode

 grade_threshold                        0.2
 grade_threshold_mode                2
 grade_upper_mode                      1
 grade_change_only                     1

// labelling of sub-plots

// centreline chainage: 1 for on, 0 for off

 chainage_label                             1

//   distance below box to print annotation

 chainage_y_offset                      12

//   distance from start of string to label - default centred

// chainage_x_offset                     10

//   chainage text label parameters

 chainage_text                         “Chainage”
 chainage_size                         6
 chainage_colour                    cyan
 chainage_decimals                2

// ******** panel data ********

 view_name                            “4”

 plotter_type                         “model”
 model_to_plot                     “single xsec”
 plot_stem                            “pp”

 sheet_size                          “1000 800”
 scale                                   1000.0

 absolute_extensions             “no”
 left_extension                        5
 right_extension                      5

 line_up_cl                           "yes”
 primary_string                     “yes”
 label_type                           “boxes”
 offset_colour                        “cyan”
 text_size                                3.0
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 use_title_file                         “no”
 title_file                                “titles.tf”
 plot_border                          “no”
 title_1                                   ““
 title_2                                   ““
 title_text_size                       4.0
 title_colour                          magenta

}
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Long Section Plot Parameter File
The long section plot parameters are placed in a file with ending .ppf

Each parameter consists of a parameter name followed by one or more spaces and then the 
parameter value. There is only one parameter per line.

Anything on a line after a double forward slash // is considered to be a comment.

The set of all parameters for the long section plot is enclosed within a set of curly brackets { } 
with the header

section_long_plot       “plot set name”

before the curly brackets.

That is,

     section_long_plot   “plot set name”    {

plot parameters
one per line

}

If there is more than one section_long_plot parameter set in the file, only the first set is used.

There may also be parameter sets for other plot types such as section_x_plot in the same file. The 
other sets will be ignored when doing a long section plot.

The plot parameters are documented in following groups: 

For Defining chainage range, go to the section “Possible Chainage Range” .
Breaking the plot into pages, go to the section “Pagination” .
Plot Sheet layout, go to the section “Plot Sheet Layout” .
Boxes area, go to the section “Boxes Area” .
Defining chainages and staggering, go to the section “Chainage Selection and Staggering” .
Defining uprights, go to the section “Uprights” .
Datum area, go to the section “Datum Area” .
Graph (drawing) area, go to the section “Graph Area” .
Defining bubbles, go to the section “Bubbles Definitions” .
Quick HG, go to the section “Quick Horizontal Geometry Labelling” .
Extensive HG, go to the section “Extensive Horizontal Geometry Labelling” .
Quick VG, go to the section “Quick Vertical Geometry Labelling” .
Extensive VG, go to the section “Extensive Vertical Geometry Labelling” .
Labelling heights, go to the section “Labelling Chainages and Heights in the Graph Area” .
Symbols, go to the section “Labelling With Symbols” .
Hatching cut/fill, go to the section “Hatching Cut and Fill Areas” .
Labelling cuts, go to the section “Labelling Cuts of Design Through Strings in a Model” .
Labelling string name, go to the section “Labelling the Primary String Name on the Plot” .
Labelling with scale, go to the section “Labelling the Scale on the Plot” .
Title block information, please continue to the section “Title Block Information” .
Panel modifying parameters, please continue to the section “Parameters that Modify Fields In the 

Long Plot Panel” .
Example, please continue to the section “Example of a Long Section Plot Parameter File” .

Possible Chainage Range
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In the panel, the field Use HG VG for min, max determines whether the horizontal geometry 
(HG) and the vertical geometry (VG) are both used to determine the minimum and maximum 
chainages for drawing. This allows the vertical geometry to be plotted when it is outside the 
horizontal geometry (e.g. kerb returns).

The equivalent parameter in the ppf is 

use_vg_hg_for_min_max 1 // the chainage range available for plotting
// is from the minimum of the horizontal 
// geometry (HG) and the vertical geometry
// (VG) to the maximum of the HG and VG.
// This is useful for kerb returns

0 // the chainage range available for
// plotting is from the minimum of the
// horizontal geometry (HG) to the
// maximum of the HG.

Pagination
If the long section plot is too long to fit on one page, it can be broken into a number of pages 
(sheets).

The parameter, pagination_length, controls the amount of new chainage length on each plot page. 
Each page of the long section plot can also included a set chainage amount from the end of the 
previous plot.

Hence apart from the first page and possibly the last page, the plot will have a chainage length 
given by the sum of the pagination_length and pagination_overlap.

pagination yes/no // if yes, then break the plot into pages
pagination_mode chainage // length and overlap in chainage units

millimetre // length and overlap in millimetres
pagination_length chainage or

millimetres // new chainage range on each page
pagination_overlap chainage or

 millimetres // overlap between pages
Note

The pagination_length and pagination_overlap are given in chainage units or millimetres.The user 
must choose values which will fit on the selected sheet size or the end of each plot will be 
truncated by the sheet.

Plot Sheet Layout
The plot page or sheet is considered to have only positive co-ordinates with the origin (0,0) in the 
left hand corner. The units for the plot are millimetres.

The overall size of the plot sheet is given by either a defined sheet size, or by the width and 
height of the plot given in millimetres and separated by one or more spaces.

sheet_size text // sheet name, or
“mm mm” // sheet size: width height

The sheet size name and width and heights can be specified by the user in a file named sheets.4d which is 
in the normal set up areas, or is pointed to by the environment variable

SHEET_SIZES_4D file // file of plotter sheets sizes

The plotting area is restricted to within the plot sheet by giving margins which are:

If a User Defined Title Block is used:

left_margin mm
right_margin mm
top_margin mm
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bottom_margin mm

If the default 12d title block is used, then the size of the bottom of title block depends on the text size. The 
following parameters are used in the default title block case and the bottom_border_gap is added to the 
calculated height of the bottom of the title block.

left_border_gap mm
right_border_gap mm
top_border_gap mm
bottom_border_gap mm

Because the user can easily select from the plotting panel whether a User Defined Title Block or the 
default 12d title block is used, both sets of margins and gap parameters can exist in the one plot parameter 
file.

The long plot itself consists of the three regions - boxes, datum and graph areas.

The boxes area is where the titles and the chainage values and the heights/depths for the strings 
drawn on the long plot are labelled.

The datum area is the region between the boxes area and the graph area.

The graph area is the area where the actual plots of the strings are drawn.

Apart from information labelled in the boxes area, the long section plot can label other 
information such as

(a) horizontal geometry

(b) vertical geometry

(c) chainage, heights at special points
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(d) symbols at special points

(e) bubbles at special chainages

(f) cuts the design string makes through strings

(g) cut and fill areas

The size of the graph area can also be extended to allow for plot symbols by the parameters:

extra_space_units 0 // extra space values are world units - default
1 // " " " are millimetres on plot page

extra_space_left units // subtract from left of plot area, def 0
extra_space_right units // add to right of plot area, default 0
extra_space_top units // add to top of plot area, default 0
extra_space_bottom units // subtract from bottom of plot area,

// default 0

Please continue to the next section “Boxes Area” .

Boxes Area
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Each string in the long section plot can be labelled with one or two lines of title, and the 
chainages/heights/depths at the user specified chainages for the strings.

The title for the strings, is drawn in the title area of the boxes area.

The chainages/heights/depths are drawn in the heights area of the boxes area.

Consequently the boxes area is made up of rows of text consisting of:

 string/tin titles followed by the chainage/height/depth values along the string.

Each row is surrounded by lines to form a box.

The default order of the boxes from the bottom up is

(a) optional super-elevation diagram

(b) chainage values

(c) can be primary string heights - user choice

(d) tin heights and depths

(e) offset heights and depths

(f) optional volumes or earth works

(g) can be primary string heights - user choice

(h) zero or more blank boxes

The blank boxes are used to place other information in (such as horizontal or vertical geometry) or for 
other user supplied information. 

Placing the primary string label before the bank boxes or just after the chainage box in controlled 
by the parameter primary_label_mode.

number_of_blank_boxes integer // integer > 0

primary_label_mode 0 //put primary string labels in last box
// before blank boxes

1 // or first box above the chainages

Although the order of the boxes may appear to be fixed, in practice they can be in any order. This is 
possible because for each box, there is a parameter to set the height in millimetres from the bottom of all 
the boxes that the text in the box is drawn at (the _y_pos parameters).

The title area starts at the co-ordinate (left_margin,bottom_margin).

The size of the title text is given by the title_box_text_size parameter.

The width of the title area is either given by the space_for_titles parameter, or if omitted, the 
required width is automatically calculated.

boxes for long section plot

title
area

heights
area

chainage values

tin depths

primary (design)
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chainage title
tin title

primary string title
tin depth title

tin heights
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title_box_text_size mm // size of the title text for boxes
space_for_titles mm // calculated if omitted

There can be two lines of title text and the title text, textstyle and colour can be set independently for each 
box.

The x position of the title text is the same for all the lines of title text and can be set to be a fixed 
distance from the left hand side of the boxes.

box_titles_x mm // distance to move the title text from the
// left hand side of the boxes

The y position of the title text can be set separately for each type of title. The parameters are 
given later under each of the title types (e.g. chainages, primary string, tins, depths etc.).

After the title area there can be a user defined gap, followed by the heights area

box_gap mm // blank area between the title area
// and the heights area default 0

The heights area starts at the end of the title area.

The height text is written at right angles to the bottom of the boxes. It can be either top or bottom 
justified with respect to the box (box_text_justification).

The number of decimal places (number_of_decimals), and the size of the heights text (box_text_size) can 
be specified globally but there is a parameter for each box which overrides these defaults for each box of 
heights.

box_text_justification 0 // bottom of individual boxes
1 // top of individual boxes

number_of_decimals integer // number of decimal places in the
//   height boxes. If <0, the absolute value
//   is taken as the number of decimal
//   places i.e. no trailing zeros are
//   removed for the values in the heights
// area.

box_text_size mm // size of the height text values

A global height for the individual boxes is either given by the horizontal_line_spacing parameter, or if 
omitted, a height to fit the largest height or depth value is calculated and used as the default box height.

horizontal_line_spacing mm // calculated if omitted

However, the height of each box can be individually set by parameters box_size_n where the boxing 
numbering, n. starts from the bottom box. The value of horizontal_line_spacing is used for any of the 
box_size_n parameters not specified.

box_size_n mm // height of the nth box, numbered from
// bottom up.

The total height of the boxes area is simply given by the sum of the heights of each box.
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The width of the heights area is determined by the number of chainages to be labelled and whether the 
values are staggered to prevent over writing.

Hence the total width of the boxes area is the width of the title area plus box_gap, plus the width 
of the heights area.

Many distance definitions in the plot parameter file are given in terms of distance above the top 
of the boxes area so that the distances are independent of the number of boxes and box sizes.

The drawing of the box line work, the box colour, the position of the primary string labels and the number 
of blank boxes are all set by parameters.

First, all the line work for the box itself is user defined. This has been extended from V3.1 although 
draw_box_mode has been left in for upward compatibility. 

draw_box_mode 0 // don’t draw box lines
1 // draw box lines around heights area

// only
2 // draw box lines around title and

// heights areas
3 // use draw_box_side_n,

// box_line_draw_mode and
// box_line_mode_n

box_colour  colour // colour of the boxes

For V3.2, the line work for the outside of the title and heights boxes is controlled by the parameters 
draw_box_side_n and box_side_colour_n, and the separation lines inside the boxes are controlled by the 
parameters box_line_draw_mode and box_line_mode_n where the box numbering, n, starts from the 
bottom box.

Note: The following parameters are only used if draw_box_mode is set to 3.

draw_box_side_1 1 // draw the left side of the title area (def)
0 // don’t draw the left side

box_side_colour_1 colour // colour to draw left side of title area
// default box_colour

draw_box_side_2 1 // draw top of the title area (default)
0 // don’t draw the top

box_side_colour_2 colour // colour to draw top of title area
// default box_colour

draw_box_side_3 1 // draw right side of the title area 
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// (default if box_gap is non-zero)
0 // don’t draw the right side

// (default if box_gap is zero)
box_side_colour_3 colour // colour to draw right side of title area

// default box_colour
draw_box_side_4 1 // draw bottom of the title area (default)

0 // don’t draw the bottom
box_side_colour_4 colour // colour to draw bottom of title area

// default box_colour
draw_box_side_5 1 // draw left side of the heights area (def)

0 // don’t draw the left side
box_side_colour_5 colour // colour to draw left side of heights area

// default box_colour
draw_box_side_6 1 // draw top of the heights area (default)

0 // don’t draw the top
box_side_colour_6 colour // colour to draw top of heights area

// default box_colour
draw_box_side_7 1 // draw right side of the heights area def

0 // don’t draw the right side
box_side_colour_7 colour // colour for right side of heights area

// default box_colour
draw_box_side_8 1 // draw bottom of the heights area (def)

0 // don’t draw the bottom
box_side_colour_8 colour // colour for bottom of heights area

// default box_colour

The lines at the top of the individual boxes inside the title area and heights area (separation lines) are 
controlled by the parameters box_line_draw_mode and box_line_mode_n. 

The separation lines can be drawn in just the title area, just the heights area or in both areas.

The parameter box_line_draw_mode can be set to control all the separation lines but there are 
additional parameters, box_line_mode_n, which override box_line_draw_mode for each of the 
individual boxes where n = 1, ... number of boxes -1. 

The top of the top box is not controlled by box_line_mode_n but is controlled by the parameters 
draw_box_side_2 and draw_box_side_6.

box_line_draw_mode 0 // don’t draw any separation lines inside
// the title and heights areas

1 // draw the separation lines inside the
// title and heights areas (default)

2 // draw the separation lines inside the
// title area only

heights

area

space_for_titles

horizontal_line_spacing or

box_size_1

box_size_2

box_size_n

...
...

box_gap

1 3

2

4

5

6

8

7

lines to draw for draw_box_side_1 to draw_box_side_8

title

area



Appendix O  Plot Parameters

November 2002 Page 3501Long Section Plot Parameter File

3 // draw the separation lines inside the
// heights area only

box_line_mode_n 0 // for the nth box, don’t draw any
// line at the top of the box for either
// the title or the heights areas

1 // for the nth box, draw the line at the 
// top of the box for both the
// title and heights areas

2 // for the nth box, draw the line at the 
// top of the box for the title area only

3 // for the nth box, draw the line at the 
// top of the box for the heights area only

Chainage Titles and Values

The chainages are always labelled

chainage_title text // first line of chainage title
// (default chainages)

chainage_title_2 text // second line of chainage title
chainage_title_textstyle textstyle // textstyle of the chainage titles
chainage_title_colour colour // default chainage title colour
chainage_title_size mm // default chainage title size
chainage_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// chainage title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the chainage.

chainage_decimals integer // number of decim places for chainages
chainage_textstyle textstyle // textstyle of the chainage values
chainage_colour colour // colour of chainages, def is box_colour
chainage_size mm // size of chainages, def is box_text_size
chainage_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// chainage values text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the chainage.

Example of Chainage Titles

 chainage_title                       “DESIGN”
 chainage_title_2                   “CHAINAGE”

heights

area

draw this line for box_line_mode_1 = 1 or 3

values for box_line_mode_n

title

area

draw this line for box_line_mode_2 = 1 or 3

draw this line for
box_line_mode_1 = 1 or 2
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 chainage_title_colour          “yellow”
 chainage_colour                   “grey” // colour of chainage text
 chainage_decimals -3 // 3 decimal places - leave trailing zeros
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Primary String Title and Heights

Sometimes the primary string is only required to define chainages or the horizontal path for tin 
sections. In this case, the primary string would not be drawn on the long section plot.

If the primary string is drawn, it is automatically labelled.

Also the drawing of crosses at the vertical intersection points can be controlled from the ppf file.

primary_draw_vips 1 // draw crosses at VIPS (default)
0 // don’t draw VIP crosses

The position of the primary string label box can be either straight after the chainage box, or after the tin 
and offset boxes but before the blank boxes.

primary_string yes // draw and label the primary string
no // don't draw or label the primary string

primary_label_mode 0 // last box before blank boxes
1 // first box above the chainages

primary_title text // first line of string title
primary_title_2 text // second line of string title, default is

// the primary string name.
primary_title_textstyle textstyle // textstyle of the primary string titles

primary_title_colour colour // colour of the string titles

primary_title_size mm // default primary title size
primary_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// primary string title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the primary string.

primary_decimals integer // number of decimal places
primary_textstyle textstyle // textstyle of the primary string heights
primary_colour colour // colour of the heights 
primary_size mm // default primary value size
primary_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// primary string height text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the primary string.

primary_ch_tolerance mm // for a given chainage, if no z value exists,
 // this distance is added to/subtracted from the

// chainage to search for a valid z value.

Example of Primary String Titles

 primary_title                       “DESIGN”
 primary_title_2                   “CENTRELINE”
 primary_title_colour          “yellow”
 primary_colour                   “grey” // colour of height text
 primary_decimals -2 // 2 decimal places - leave trailing zeros
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Tin Titles and Heights

A section along the primary string through each tin on the section view can be automatically drawn on the 
long plot, and the user can specify whether the tin heights and depths are labelled or not in the boxes area.

Hence although there may be a number of tins drawn on the section plot, not all of them need to 
be labelled or have their depths labelled.

The default order for labelling the tins and depths is the order that the tins were added to the 
view however it is possible to specify which tin is used for labelling each row of tin heights and 
depths by giving the tin name rather than just using the tin order on the section view. 

In fact, it is possible to use any tin in the project to label a row, not just those drawn on the 
section view.

The parameter to define the nth tin by name is tin_n_name:

tin_n_name text // n=1, ... no of tins on the section view.
// use the tin named text to label the nth
// row of tin heights and depths.

 If a tin of the name tin_n_name does not exist, then the plot is not produced and an error message is 
given.

For the following parameters, n takes the value 1 to 100 and specifies that the parameter set 
applies to the nth tin on the section view, or if tin_n_name is set, for the tin specified by 
tin_n_name.

tin_n_draw_mode 1 // draw the nth tin (default)
0 // don’t draw the nth tin

tin_n_draw_colour colour // colour to draw the nth tin.
// If omitted, then use the tin colour

tin_n_label 1 //label the tin’s heights (default)
0 // don't label the tin’s heights

tin_n_title text // first line of tin title
tin_n_title_2 text // second line of tin title
tin_n_title_textstyle textstyle // textstyle of the tin titles
tin_n_title_colour colour // colour for titles of heights
tin_n_title_size mm // default nth tin’s title size
tin_n_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// tin title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the tin heights.

tin_n_decimals integer // number of dec places in tin height
tin_n_textstyle textstyle // textstyle of the tin heights
tin_n_colour colour // colour for heights and depths
tin_n_size mm // default nth tin’s title size
tin_n_y_pos mm //if set, the height in mm above the

//bottom of all the boxes that the
// tin height text is drawn.
//If not set, then the text is placed at a
//height that puts it inside the default
// box for the tin heights.

tin_n_depth_label 1/0 // 1 to label, 0 don't label depths
tin_n_depth_title text // first line of tin depth title
tin_n_depth_title_2 text // second line of tin depth title
tin_n_depth_title_textstyle textstyle // textstyle of the tin depth titles
tin_n_depth_title_colour colour // colour for titles of depths
tin_n_depth_title_size colour // size for title of depths
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tin_n_depth_title_y_pos mm // if set, the height in mm above the
// bottom of all the boxes that the
// tin depth title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the tin depths.

tin_n_depth_decimals integer // number of dec places in tin depth
tin_n_depth_textstyle textstyle // textstyle of the tin depths 
tin_n_depth_colour colour // colour for depths
tin_n_depth_size mm // size for depths
tin_n_depth_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// tin depth text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the tin depths.

Offset Model Titles and Heights

For 12d Model V3.2, Each string in the offset model given in the section long plot panel can be 
automatically projected onto the primary string and drawn on the long section plot.

For 12d Model V4.0, the idea of an offset model has been modified to allow strings to be projected onto 
the primary string to be specified by model and name, rather than just projecting all the strings in a given 
model. The string can also be labelled with either the string name, its model name or both.

The string is specified by 

offset_n_mask "model_name->string_name"

For each n, a set of plot parameters determine if the string’s heights and/or depths from the primary string 
are labelled in the boxes area.

If only the string_name is given, then the model given in the Offset model field of the Section Long Plot 
panel. 

If there is more than one string with the given model and name, then it will be considered to be 
one string and at any primary string chainage, the closest of the strings will be the part used for 
projecting. For example, strings of the same name on either side of a road intersection will be 
considered to be the one string for projecting.

If any offset_n_mask is used, then the Offset option expects all the strings to be specified by an 
offset_n_mask. Then if no mask exists for any value of n, then that parameter set is ignored and 
no string projected.

If no offset masks are used (that is, no offset_n_mask’s are used), then the Offset option works as it 
did in 12d Model V3.0. That is, plot parameters determine whether each string in the offset 
model is drawn, and if the string’s heights and depths from the primary string are labelled in the 
boxes area. The order that the strings are then plotted and labelled is the same as the order of the 
strings in the Offset model.

For the following sets of parameters, n takes the value 1 to 100 and specifies that the parameter set applies 
to the nth string given by offset_n_mask or, if no offset masks are given, the nth string in the Offset model.

offset_n_mask "model_name->string_name"

offset_n_draw_mode 1 // draw the nth offset string (default)
0 // don’t draw the nth offset string

offset_n_lw value // default 1000. Distance to search to the left
// of the primary string for the offset string.
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// If 0, don’t search to the left.

offset_n_rw value // default 1000. Distance to search to the right
// of the primary string for the offset string.
// If 0, don’t search to the right.

offset_n_draw_colour colour // colour to draw the nth offset string.
// If omitted, then use the string colour

offset_n_label 1 //label the string’s heights (default)
0 // don't label the string’s heights

The default title for each set each parameter set, is the string name but this can be changed to just the 
model name or the model and string name:

offset_title_mode 0 // label with string name (default)
1 // label with model name
2 // label with model->string as name

or, for any set, the offset_title_mode can be replaced by two lines of user defined title:

offset_n_title text // first line of title
offset_n_title_2 text // second line of title
offset_n_title_textstyle textstyle // textstyle of the offset titles

The rest of the parameters for the set are:

offset_n_title_colour colour // colour for titles of heights

offset_n_title_size size // colour for titles of heights
offset_n_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// offset title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the offset heights.

offset_n_decimals integer // number of dec places in offset height
offset_n_textstyle textstyle // textstyle of the offset heights
offset_n_colour colour // colour for heights

offset_n_size size // size for heights

offset_n_y_pos mm // if set, the height in mm above the
// bottom of all the boxes that the
// offset height text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the offset heights.

offset_n_depth_label 1/0 // 1 to label, 0 don't label depths
offset_n_depth_title text // first line of offset depth title
offset_n_depth_title_2 text // second line of offset depth title
offset_n_depth_title_textstyle textstyle // textstyle of the offset depth titles
offset_n_depth_title_colour  colour // colour for titles of depths
offset_n_depth_title_size mm // size for titles of depths
offset_n_depth_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// offset depth title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the offset depths.

offset_n_depth_decimals integer // number of dec places in offset depth
offset_n_depth_textstyle textstyle // textstyle of the offset depths
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offset_n_depth_colour colour // colour for depths
offset_n_size size // size for depths
offset_n_depth_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// offset depth text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the offset depths.
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Chainages of Offset Strings - Offset Chainages

For a string other than the primary string, it is possible to label the chainages that are obtained 
from the other string by going out perpendicular to the primary string at a chainage, cutting the 
other string and then calculating the chainage from the other string at the cut point.

The other string is known as an offset string and the chainage from the offset string 
corresponding to a primary chainage is called the offset chainage.

 

Up to twenty sets of offset chainages can be labelled - each is defined by its own set of 
parameters:

Note no box is automatically created for the offset chainages. An empty box must be defined and the 
appropriate values set for chainage_n_title_y_pos and chainage_n_y_pos

chainage_n_offset_mode tick box // if ticked, use nth offset string for 
calculations
chainage_n_offset_string "model_name->string_name" // string to calculate offset chainages for

chainage_n_title text // first line of offset chainage title
chainage_n_title_2 text // second line of offset chainage title
chainage_n_title_textstyle textstyle // textstyle of the offset chainage titles
chainage_n_title_colour colour // offset chainage title colour
chainage_n_title_size mm // offset chainage title size
chainage_n_title_y_pos mm // the height in mm above the

// bottom of all the boxes that the
// offset chainage title text is drawn.

chainage_n_decimals integer // number of decim places for offset chainages
chainage_n_textstyle textstyle // textstyle of the offset chainage values
chainage_n_colour colour // colour of offset chainages
chainage_n_size mm // size of offset chainages
chainage_n_y_pos mm // the height in mm above the

// bottom of all the boxes that the
// chainage values text is drawn.

Example of Offset Chainage and Titles

 chainage_1__offset_string “Design->RKERB”
 chainage_1__title “RIGHT KERB”
 chainage_1_title_2 “CHAINAGE”
 chainage_1_title_colour “yellow”
 chainage_1_colour “grey” // colour of offset chainage text
 chainage_1_decimals -3 // 3 decimal places - leave trailing zeros

primary string

offset string

chainage point on the 

the offset chainage is the 
chainage on the offset string 
where the perpendicular cuts Plan View

go out perpendicular to 
the primary string at the 
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Definition of Depth to a Tin or to Offset Strings 

The depth from the primary string to a tin or to a string from the offset model, at a particular 
chainage is defined as

depth = tin height value - height of the primary string

or

depth = offset string height value - height of the primary string

That is, the depth that the primary string is below the tin or a string from the offset model.

Before plotting, the value of depth is multiplied by either the depth_positive_factor or 
depth_negative_factor.

if (depth >= 0) plotted_depth_value   =   depth * depth_positive_factor

if (depth < 0) plotted_depth_value   =   depth * depth_negative_factor

Hence the definition of depth can be modified by the parameters:

depth_positive_factor value // multiplier for positive depths
depth_negative_factor value // multiplier for negative depths

For example, if the opposite sign is required for depth, that is,

depth     =     height of the primary string   -   tin/offset string height value

simply set

depth_positive_factor          -1
depth_negative_factor           -1
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Super-Elevation Diagram

The optional super-elevation diagram draws the values of the cross-fall (x-fall) between two strings 
using the primary string as the reference string. The cross-fall at a given chainage on the primary 
string is calculated by sectioning perpendicular to the reference string at that chainage and 
cutting the two strings. The cross-fall is defined as the cross-fall between the two cuts points on 
the strings.

The diagram has levels for the cross fall for a pair of strings on the left of the primary string, and 
a pair of strings on the right of the primary string. The diagram also has uprights in the super-
elevation box with chainage values at the change of super values.

For the left hand side, the cross-fall is calculated at right angles to the primary string between the 
user given left hinge string and the left edge string.

There are plot parameters to control all aspects of the super diagram.

super_draw_mode 0 // default, don’t draw a super diagram
1 // draw super using super_sample_interval
2 // sample super using chainages of x-sections
3 // sample super using chainages from a string

super_sample_interval value // if super_draw_mode = 1, default 20
// chainage distance to sample x-fall

super_sample_name model_name // if super_draw_mode = 2
model_name->string_name // if super_draw_mode = 3

super_tolerance value // If super_draw_mode is 1, the change
// of super is greater than super_tolerance,
// draw uprights

super_title text // first line of super title
// def Super elevation

super_title_textstyle textstyle // textstyle of the super titles
super_title_colour colour // super title colour, def box_colour
super_title_size mm // super title size, def label_text_size
super_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// super title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the super.

super_xfall_textstyle textstyle // textstyle of the super x-fall labels
super_xfall_colour colour // super x-fall colour, def box_colour
super_xfall_size mm // super x-fall size, def label_text_size
super_xfall_x mm // def 0
super_xfall_y mm // def 0.5
super_ch_textstyle textstyle // textstyle of the super chainages
super_ch_colour colour // super chainage colour, def box_colour
super_ch_size mm // super chainage size, def label_text_size
super_ch_x mm // def 0
super_ch_y mm // def -1
super_ch_decimals integer // number decimal places in chainage

// def number_of_decimals
super_hinge_name_left model_name->string_name // left hinge string
super_edge_name_left model_name->string_name // left edge string
super_left_linestyle linestyle // default DASHED
super_left_line_colour colour // default box_colour
super_left_decimals integer // number decimal places in left x-fall

//def 0
super_left_pre text // text before left x-fall value
super_left_post text // text after left x-fall value
super_hinge_name_right model_name->string_name // right hinge string
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super_edge_name_right model_name->string_name // right edge string
super_right_linestyle linestyle // default DASHED2
super_right_line_colour colour // default box_colour
super_right_decimals integer // number decimal places in right x-fall

//def 0
super_right_pre text // text before right x-fall value
super_right_post text // text after right x-fall value
super_cl_linestyle linestyle // default 1
super_cl_line_colour colour // default box_colour

super_common_pre text // text before common x-fall value
super_common_post text // text after common x-fall value
super_common_linestyle linestyle // default 1
super_common_line_colour colour // default box_colour
super_common_decimals integer // number decimal places in common xfall

//def 0
super_upright_mode 0 // uprights for left string only (default)

1 //                       right
2 //                      left and right

super_upright_colour colour // default box_colour

Example of Super

 super_hinge_name_left "super->lkerb"
 super_edge_name_left "super->lshoulder"

 super_hinge_name_right "super->rkerb"
 super_edge_name_right "super->rshoulder"

 super_draw_mode 3
 super_sample_interval 10
 super_sample_name "super->lkerb"

 super_title_size 5
 super_title_colour ORANGE
 super_title_textstyle GOTHIC
 super_title_y_pos 10
 super_title "Super EL"

 super_xfall_size 1.5
 super_xfall_colour GREY
 super_xfall_textstyle HELV

Super Elevation

super_title_y_pos

Bottom of the boxes

box_title_x
LHS 3%

RHS -5%

RHS 5%

LHS 1%

LHS and RHS 5%

0.
00

53
.2

4

78
.6

5

10
1.

20

16
4.

18

super_ch_x

super_ch_y

super_xfall_y

super_xfall_x

super uprights

super cl

super common linesuper left line super right lineTitle area

super chainage
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// super_xfall_y 0.5
// super_xfall_x 2

 super_ch_size 3
 super_ch_colour YELLOW
 super_ch_textstyle ISO
 super_ch_y -2
 super_ch_x -0.5
 super_ch_decimals -2

 super_left_linestyle DIVIDE
 super_right_linestyle PHANTOM2
 super_cl_linestyle  PHANTOM
// super_common_linestyle thick

 super_left_line_colour RED
 super_right_line_colour YELLOW
 super_cl_line_colour CYAN
 super_common_line_colour MAGENTA
 super_upright_colour BLUE

// super_common_pre "Pre "
// super_common_post "% Post"

// super_common_decimals -1
 super_right_decimals 1
 super_left_decimals 1
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Volume Cut and Fill Values

The values of calculated cut and fill volumes (cut and fill earth works) can be read from a file and 
then interpolated to produce cut and fill volumes for a given interval along the primary string.

There are plot parameters to control all aspects of the volume diagram.

volume_draw_mode 0 // default, don’t draw a volume diagram
1 // draw a volume diagram

volume_text_centre_mode 0 // default, the text of cut and fill are labelled
// along the uprights

1 // the text are centred in between the uprights
volume_sample_interval value // interval to display volumes, default 20
volume_file_name file_name // the volumes report file
volume_y_pos mm // if set, the volume box is positioned at this

// height from the bottom of the first box
volume_box_size mm // if set, the uprights and volume and titles

// are plotted in accordance with this heights
volume_title text // first line of volume title

// default Earthworks
volume_title_textstyle textstyle // textstyle of the volume titles
volume_title_colour colour // volume title colour, def box_colour
volume_title_size mm // volume title size, def label_text_size
volume_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// volume title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the volumes.

volume_cut_title text // first line of volume sub title
// default cut

volume_cut_title_textstyle textstyle // textstyle of the cut volume titles
volume_cut_title_colour colour // cut volume title colour, def box_colour
volume_cut_title_size mm // cut volume title size, def label_text_size
volume_cut_title_y mm // if set, the height in mm above the

// default position.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the cut volumes.

volume_fill_title text // first line of volume sub title
// default fill

volume_fill_title_textstyle textstyle // textstyle of the fill volume titles
volume_fill_title_colour colour // fill volume title colour, def box_colour
volume_fill_title_size mm // fill volume title size, def label_text_size
volume_fill_title_y mm // if set, the height in mm above the

// default position.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the fill volumes.

volume_cut_textstyle textstyle // textstyle of the cut values
volume_cut_text_colour colour // cut value colour, def box_colour
volume_cut_text_size mm // cut value size, def label_text_size
volume_cut_text_x mm // the x distance to move the cut text from the

// default cut text position, def 0, it is not used
// if volume_text_centre_mode=1

volume_cut_text_y mm // the y distance to move the cut text from the
// default cut text position, def 0

volume_cut_decimals integer // number decimal places in cut values
//def   number_of_decimals
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volume_fill_textstyle textstyle // textstyle of the fill values
volume_fill_text_colour colour // fill value colour, def box_colour
volume_fill_text_size mm // fill value size, def label_text_size
volume_fill_text_x mm // the x distance to move the fill text from the

// default fill text position, def 0, it is not used 
// if volume_text_centre_mode=1

volume_fill_text_y mm // the y distance to move the fill text from the
// default fill text position, def 0

volume_fill_decimals integer // number decimal places in fill values
//def   number_of_decimals

volume_cl_linestyle linestyle // linestyle of horizontal cut/fill dividing line
volume_cl_line_colour colour // colour of horizontal cut/fill dividing line

 volume_uprights_draw_mode 0 // default, don’t draw cut/fill uprights
1 // draw cut/fill uprights

volume_uprights_line_colour colour // colour of uprights

volume_sub_upright_colour colour // colour of sub uprights line
volume_sub_uprights_x mm // the distance to move from the default

// sub uprights position, def 0

volume_sub_title_x mm // the distance to move the sub title text
// from the volume sub uprights

Example of Volumes

 volume_draw_mode 1
  volume_sample_interval 25

 volume_file_name "volume.rpt"
 volume_text_centre_mode 0
 volume_y_pos  150
 volume_box_size 40

  volume_title "Volumes"
 volume_title_size 5
 volume_title_colour grey

Volume
Cut

Fill

32
2.

87

975.45

533.24

40
3.

00

403.00

322.87

97
5.

45
53

3.
24

volume_sub_uprights_x

volume_title_y_pos

Bottom of the boxes

volume_y_pos

volume_cut_text_y
volume_cut_text_x

volume_fill_text_y

volume_cut_title_y

volume_cut_title_y

volume_fill_text_x

box_title_x

volume_sub_title_x
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//  volume_title_textstyle
 volume_title_y_pos  165

  volume_cut_title "cut"
//  volume_cut_title_size
//  volume_cut_title_colour
//  volume_cut_title_textstyle

 volume_cut_title_y 3

 volume_fill_title "fill"
//  volume_fill_title_text_size
//  volume_fill_title_text_colour
//  volume_fill_title_textstyle

 volume_fill_title_y         -3

  volume_cut_text_size  3
//  volume_cut_text_colour
//  volume_cut_textstyle

 volume_cut_text_y 5
//  volume_cut_text_x

 volume_cut_decimals 0
 volume_fill_text_size 3

//  volume_fill_text_colour
//  volume_fill_textstyle

 volume_fill_text_y 245
//  volume_fill_text_x

 volume_fill_decimals 0

 volume_cl_linestyle "PHANTOM"
 volume_cl_line_colour  red

 volume_uprights_draw_mode 1
 volume_uprights_line_colour "purple"

  volume_sub_upright_colour 23
 volume_sub_uprights_x 10

 volume_sub_title_x 3
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X,Y Values

The values of the X and Y coordinate for selected chainages can be labelled as seperate boxes. 
The chainages specified are limited to the base set of chainages already defined in the chainage 
selection and staggering section. i.e. an upright must exist for the X and Y value to be labelled. 
Not all of the uprights have to be labelled, just those specified in this section.

There are plot parameters to control all aspects of the X and Y labelling.

Chainages are used for positioning X and Y labels.

The chainages for the long section plot relate to the primary string and are controlled by a set of 
parameters.

xy_order 0 // 0 = X on bottom, Y on top
1 // 1 = Y on bottom, X on top

xy_chord_arc 0 // don’t use chord/arc chainages
1 // include chainages for chord/arc

xy_start_chainage value // start chainage of labelling range
xy_end_chainage value // end chainage of labelling range
xy_interval value // regular interval (0 = no regulars)
xy_label_hcp 0/1 // 1 = include tangents, spirals
xy_label_hip 0/1 // 1 = include hip points
xy_label_vip 0/1 // 1 = include vip points
xy_label_vtp 0/1 // 1 = include tangent points
xy_label_crest 0/1 // 1 = include crest points
xy_label_sag 0/1 // 1 = include sag points
xy_label_grade_change    0/1 // 1 = include change of vertical grade
xy_special_n_file  filename // n = 1 to 20 - include chainages from

// the file (one chainage per line)
xy_label_tolerance       value //   > 0 use as weeding tolerance

//   <= 0, don’t weed

For X parameters:
x_label 0/1 // 0 = Don’t label X values/titles

// 1 = Label X values/titles
x_title text // first line of X title

// (default "Easting")
x_title_2 text // second line of X title
x_title_textstyle textstyle // textstyle of the X titles
x_title_colour colour // default X title colour
x_title_size mm // default X title size
x_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// X title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the X.

x_label_decimals integer // number of decim places for X values
x_label_textstyle textstyle // textstyle of the X values
x_label_colour colour // colour of X values, def is box_colour
x_label_size mm // size of X values, def is box_text_size
x_label_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// X value text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the X value.
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For Y parameters:
y_label 0/1 // 0 = Don’t label Y values/titles

// 1 = Label Y values/titles
y_title text // first line of Y title

// (default "Easting")
y_title_2 text // second line of Y title
y_title_textstyle textstyle // textstyle of the Y titles
y_title_colour colour // default Y title colour
y_title_size mm // default Y title size
y_title_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// Y title text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the Y.

y_label_decimals integer // number of decim places for Y values
y_label_textstyle textstyle // textstyle of the Y values
y_label_colour colour // colour of Y values, def is box_colour
y_label_size mm // size of Y values, def is box_text_size
y_label_y_pos mm // if set, the height in mm above the

// bottom of all the boxes that the
// Y value text is drawn.
// If not set, then the text is placed at a
// height that puts it inside the default
// box for the Y value.

Please continue to the next section “Chainage Selection and Staggering” .
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Chainage Selection and Staggering
Chainages are used for positioning height labels, uprights (leader lines) and bubbles.

The chainages for the long section plot relate to the primary string and are controlled by a set of 
parameters.

chord_arc 0 // don’t use chord/arc chainages
1 // include chainages for chord/arc

chainage_interval value // regular interval (0 = no regulars)
chainage_label_ends 0/1 // 1 = include start and end chainages
chainage_label_hcp 0/1 // 1 = include tangents, spirals
chainage_label_hip 0/1 // 1 = include hip points
chainage_label_vip 0/1 // 1 = include vip points
chainage_label_vtp 0/1 // 1 = include tangent points
chainage_label_crest 0/1 // 1 = include crest points
chainage_label_sag 0/1 // 1 = include sag points
chainage_label_grade_change    0/1 // 1 = include change of vertical grade
chainage_special_n_file  filename // n = 1 to 20 - include chainages from

// the file (one chainage per line)
chainage_label_tolerance       value //   > 0 use as weeding tolerance

//   <= 0, don’t weed
chainage_merge_bubbles        0/1 //   1 = merge in the bubble chainages
chainage_merge_tolerance       value //   > 0, weeding tol after bubble merge

//   <= 0, don’t weed after merge
Default values

chainage_label_tolerance      =   1.0 exp -4 (world units)
chainage_merge_tolerance   =   1.0 exp -8 (world units)

If a tolerance is zero or negative, no weeding is performed.

The format of a chainage special file is simply a list of chainage values, one value per lines. Blank 
lines in the file are ignored and anything on a line after a // is a comment.

If the real chainage position is used for the horizontal position of the chainage/height/depth 
text, text over writing can easily occur.

To prevent over writing, the text can be staggered.

If the stagger_mode parameter is set to 1, the text position is adjusted so that the text does not 
over write.

The real chainage position is then indicated by the chainage markers which are drawn at the top 
of the text boxes from the staggered text position back to the actual chainage position of the text.

stagger_mode 0 // no staggering, allow over writing
1 // stagger text to prevent over writing

stagger_gap_top mm // distance from boxes to top of stagger
stagger_gap_bottom mm // distance from boxes to bottom of

//   stagger
stagger_gap_factor value // distance between staggers is

// box_text_size * stagger_gap_factor

When staggering occurs, it is possible for the heights area to be longer than the graph area.
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Please continue to the next section “Uprights” .

Uprights
Uprights, or leader lines, can be drawn from the top of the staggers to the strings drawn on the 
plot.

The height of the uprights is given by the uprights_draw_mode:

uprights_draw_mode 0 // none
1 // to maximum string height at that

// chainage
2 // ticks, to stagger height
3 // to uprights_y above the boxes
100 // to the primary string
101-500 // to tin1 or tin2 etc.
501-900 // to offset1 or offset2 etc.

uprights_y mm // distance to draw the uprights for
// mode 3

uprights_colour colour // uprights colour (default boxes_colour)

The uprights can go below the top of the boxes.

uprights_bottom_mode 0 // stop at top of boxes (default)
1 // draw to bottom of boxes
2 // draw to uprights_bottom_y below the

// top of the boxes
3 // draw to uprights_bottom_y above the

// bottom of the boxes
4 // ticks at chainage

uprights_bottom_y mm //distance
uprights_text_offset_factor value // move the text by this factor*size 

When uprights go below the top of the boxes, the height and offset text is moved to the left so that the 
upright does not go through the text. The left hand side of the heights boxes also moves to the left to leave 
room for the height text.

long section plot

title
area top of boxes

stagger_gap_bottom
stagger_gap_top
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Please continue to the next section “Datum Area” .
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Datum Area
The datum area is the region between the boxes area and the graph area.

The datum line is positioned the distance datum_below_gap above the top of the boxes area and 
the graph area is positioned the distance datum_above_gap above the datum line.

Hence the graph area is distance (datum_below_gap + datum_above_gap) above the top of the 
boxes area.

datum_above_gap mm // distance from datum line to the
// bottom of the graph area

datum_below_gap mm // distance from datum line to the top of
//   the boxes

datum_linestyle linestyle // linestyle for datum line (default solid)

The datum_below_gap and datum_above_gap can be zero or positive.

A value for the datum can be specified by the parameter datum_value or if the datum_value is not 
set, a datum value is automatically calculated for the long section using a roundoff specified by 
the user (default 1.0).

datum_value value // if set, the value to use for datum.
//If not set, the datum is automatically
// calculated (using datum_roundoff)

 
datum_roundoff 1.0 // value to roundoff the datum value to 

// e.g. 0.5, 0.2, 1.0 (default 1.0)
datum_decimals integer // number of decimal places to display

// the datum value (default 1). 
// If > 0, trailing zeros are removed after
// the decimal point.
// If <0, the absolute value is taken as the
// number of decimal places to report
// i.e. no trailing zeros are removed

datum_name text // text to write before the datum value
datum_textstyle textstyle // textstyle for the datum text
datum_text_size mm // size of datum text and value
datum_colour colour // colour of the datum text and line
datum_x mm // distance to move the datum text

// along the datum line
datum_y mm // distance to raise the datum text

// above the datum line (used to be
//    called datum_offset)

Please continue to the next section “Graph Area” .
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Graph Area
The graph area is the area where the actual plots of the strings are drawn.

The string used to define the horizontal position and chainage of the plot is called the primary 
string and is either 

(a) the string being profiled on the given section view
or

(b)  the string given by the parameter

string_to_plot “model->string_name”       // name of string to profile
When the primary string is being written out to a plot parameter file by 12d Model, a 
string_to_plot parameter and special parameters recording the internal id’s for the string and it’s 
model are all written out.

primary_model_id integer // internal 12d Model parameter
primary_string_id integer // internal 12d Model parameter 

The length of the graph area is determined by the length of the primary string being plotted (restricted to 
the specified start and end chainages) and the horizontal scale (scale) given by parameters or in the section 
long plot panel, and the vertical exaggeration given by the section view or a parameter.

view_name text // default is section view in panel.
vertical_exaggeration value // default is vertical exag for the view
scale value // 1:value - horizontal scale, default is

// scale 1:   in panel
start_chainage value // “ “ means use start of primary string
end_chainage value // “ “ means use end of primary string

The vertical scale is determined by the horizontal scale and the vertical exaggeration.

The height of the graph area is determined by the vertical scale (given by the horizontal scale 
and the vertical exaggeration) and the minimum and maximum values of the data being plotted. 
Hence the graph height is a calculated rather than a given value.

The types of strings that can be drawn in the graph area of a long section plot are:

(a) primary string the string being profiled (usually the design string).

(b) tins sections of the primary string through any tins either in models on
 the section view or in corridor models.

(c) offset strings strings in the offset model that are projected back onto the
 primary string

(d) services parts of strings (from either models on the section view or in
corridor models) that cut the defined corridor.

The colour of the strings in the plot is the actual string colour for cases (a), (c) and (d), and the 
colour of the tin used for the section in case (b).

Although all the strings are plotted, the plot parameter file can be used to select which ones are 
labelled with heights and/or depths.

Primary String (Design String)

The primary string (the design string) is used to define

(a) the design long section

(b) the chainage positions for labelling heights and drawing uprights

(c) the section line used for sectioning through tins

(d) the section line for defining the corridor for services

Although the primary string is used to set up most of the information for the long section plot, it doesn’t 
have to be drawn on the long section. 
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The drawing or not drawing of the primary string on each cross section plot is controlled by the 
parameter primary_string which was described earlier.

The colour of the primary string in the plot is the actual primary string colour.

Tins

A section along the primary string through each tin on the specified section view is 
automatically drawn on the cross section plot.

The colour and linestyle of the tin section in the plot is the actual tin colour and tin linestyle.

Whether the tin heights are labelled or not in the boxes area is controlled by parameters and has 
been described earlier

Corridor and Services

A corridor around the primary string is defined by giving a left and right corridor width.

Any string in a model added to the section view is checked to see if it appears in the corridor, 
and if it does, then it is drawn on the long section plot.

To be drawn, strings do not have to cross the primary string, but just be in the corridor.

The corridor defining parameters are 

corridor_width_left world-units // corridor left and right widths
corridor_width_right world-units // defaults are the section view values
corridor_overlap_left world-units // corridor left and right overlaps.
corridor_overlap_right world-units // defaults are the section view values 
corridor_chord_arc world-units // chord-arc tolerance used to

// approximate arcs in the corridor.
// default is the section view value

The models containing tins for sectioning and strings for services are taken from the section view 
or given by the parameters

corridor_model_n model // n = 1, 2 ... 100
// models containing tins and service
// strings to be drawn on the view.

If any corridor_model_n parameters are defined, then only the models given by the parameters are 
used. If no corridor_model_n parameters are set, then the models added to the given section view 

primary string corridor_width_left

corridor_width_right

pipe string
strings (no diameter)

plan view

(design long section)

tin (natural surface)

design long section

services in
the corridor

section view
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are used.

That is, either the corridor_model_n parameters are used or if none exist, then the models added to 
the section view are used for tins and service strings.

The colour and diameter of the service strings drawn in the plot are the actual strings colour and 
diameter.

The graph area sits on top of the boxes and datum areas, so there may not be enough room left 
on the sheet for the full plot height. In this case, the plot will be truncated at the top of the 
allowed graph area.

Please continue to the next section “Bubbles Definitions” .
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Bubbles Definitions
Circles with the string name and a unique number (bubbles) can be drawn on the long section 
plot. Bubbles are normally used for lip profiles.

The chainages used for the bubbles are given by a set of parameters similar to the chainage 
parameters. The resulting set of bubbles are sequentially numbered (starting with one) in 
chainage order.

Although many bubbles can be defined by the bubble parameters, a bubble is only drawn on the 
plot if there is a labelled chainage to draw it above.

Hence not all bubbles given by the bubble chainage parameters are drawn but for the ones that 
are drawn, the bubble number is taken from the full bubble set.

chainage_bubbles 0 // don’t drawn bubbles
1 // draw bubbles

bubble_radius mm // radius of the bubbles
bubble_colour colour // colour for the bubbles

bubble_text_string_name_mode0 // do not label with string name
1 // label string name
2 // label with model->string name

bubble_pre_text text
bubble_post_text text
bubble_textstyle textstyle
bubble_text_size mm
bubble_text_colour colour
bubble_text_offset mm
bubble_upright_distance mm // distance bubbles are above boxes/uprights
bubble_mode 0 // bubble_upright_distance is above boxes

1 // bubble_upright_distance is above
// uprights

bubble_draw_upright 0/1 // 1 = draw extra upright if
// bubble_mode = 1

bubble_start_chainage value // start chainage for bubbles
bubble_end_chainage value // end chainage for bubbles
bubble_chord_arc 0/1 // 1 = use chord-arc chainages
bubble_interval value // include regular interval

//   (0 = no regulars)
bubble_label_ends 0/1 // 1 = include start and end chainages
bubble_label_hcp 0/1 // 1 = include tangents, spirals
bubble_label_hip 0/1 // 1 = include hip points
bubble_label_vip 0/1 // 1 = include vip points
bubble_label_vtp 0/1 // 1 = include tangent points
bubble_label_crest 0/1 // 1 = include crests
bubble_label_sag 0/1 // 1 = include sags
bubble_label_grade_change 0/1 // 1 = include change of grade
bubble_special_n_file filename // n = 1 to 20 include chainages from the

// file
bubble_label_tolerance value // > 0 use as weeding tolerance

// <= 0, don’t weed

Defaults

bubble_label_tolerance   =    1.0 exp -4 (world units)

If a tolerance is zero or negative, no weeding is performed.

The format of a bubble special file is simply a list of chainage values, one value per lines. Blank 
lines in the file are ignored and anything on a line after a // is a comment.
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Please continue to the next section “Quick Horizontal Geometry Labelling” .

Quick Horizontal Geometry Labelling
The standard horizontal geometry arrows can be drawn at a given distance above the top of the 
boxes area.

horizontal_geometry_y‘  mm                         // dist above boxes
                                //     0 = don't draw

horizontal_geometry_arrow_text_colour          colour
horizontal_geometry_arrow_textstyle               textstyle
horizontal_geometry_arrow_text_size              mm
horizontal_geometry_arrow_colour                  colour
horizontal_geometry_arrow_height                  mm
horizontal_geometry_label_text                        text
horizontal_geometry_label_textstyle                 textstyle
horizontal_geometry_label_text_colour            colour
horizontal_geometry_label_text_size                  mm
horizontal_geometry_label_decimals                  number

Please continue to the next section “Extensive Horizontal Geometry Labelling” .

Extensive Horizontal Geometry Labelling
For complicated horizontal geometry labelling, there are sets of horizontal geometry labelling 
parameters which give tight control over the position and types of labels.

It is also possible to label the horizontal geometry of alignment strings other than the primary 
string. To plot such a string on the same plot, the chainage position of the horizontal geometry 
for the non-primary alignment strings is projected onto the primary string to give a primary 
string chainage for plotting. The values of the horizontal geometry (such as radius and spiral 
length) that are plotted are taken from the other string. Independently graded offset strings (such 
as a left and right kerbs) are the type of additional alignment strings that may need to be plotted 
on the same long section plot as the reference string (primary string).

For plotting horizontal geometry, the user can give up to twenty sets of these labels and they can be used to 
label spirals, curves and tangent information for the primary string and/or additional alignment strings.

Each label set consists of three parts:

(a) a text label on the left hand side of the plot
(b) an arrow
(c) text on the arrows.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

h_g_n_type 0 // label spirals
1 // label horizontal curves
2 // label horizontal tangents

If h_g_n_type is missing, then the set is ignored.

h_g_n_value_mode
   for spiral labelling 0 // nothing

1 // length
   for curve labelling 0 // nothing

1 // length
2 // radius

   for tangent labelling 0 // nothing
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1 // length
   for spiral labelling 0 // nothing

1 // length
2 // radius*length

h_g_n_label_y mm // distance of arrow line above the top of
// the boxes

Parameters for the left hand label of the line of the horizontal geometry arrows:

h_g_n_label_x mm // distance from the left hand side of the 
// labels area

h_g_n_label_offset mm // distance to raise the label_text above
// arrow line

h_g_n_label_text_size mm
h_g_n_label_text_colour colour
h_g_n_label_text text
h_g_n_label_textstyle textstyle // textstyle used

Parameters for arrow type

h_g_n_draw_mode 0 // no arrow
1 // arrow
2 // line
3 // line with uprights at ends
4 // uprights, no line
5 // line with downrights
6 // downrights, no line
7 // line with up and downrights at ends
8 // up and downrights, no line
9 // draw curve
11 // radius*length curve

h_g_n_left_gap mm // size of gap for left side of arrow
h_g_n_right_gap mm // size of gap for right side of arrow
h_g_n_colour colour // colour of the arrow
h_g_n_height mm // height of the arrow
h_g_n_gap 0 // no gap

1 // leave gap in arrow for text
Parameters for text on the arrows

h_g_n_text_colour colour // colour of the text
h_g_n_text_size mm // size of the text
h_g_n_text_offset mm // distance to raise the text above the

// arrow line
h_g_n_pre_text text // text before the arrow text
h_g_n_post_text text // text after the arrow text
h_g_n_textstyle textstyle // textstyle used
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h_g_n_no_decimals integer // number of decimal places in arrow
// text.
// If > 0, all trailing zeros after the
// decimal place are removed.
// If < 0, the absolute value is taken as
// the number of decimal places and no 
// trailing zeros are removed after the
// decimal point.

h_g_n_rotate mm // if ticked, the text on the arrows will be
 rotated to fit.

If the set of parameters is to apply to the horizontal geometry of an alignment string other than the primary 
string, then simply add the following parameter to define the other alignment string 

h_g_n_offset_string "model->string_name"
or

h_g_n_offset_string "string_name" 

and the model is the Offsets model from the Section Long Plot panel. 

If the h_g_n_offset_string parameter does not exist, then the set of horizontal geometry parameters is 
applied to the primary string. 

Example of Extensive Horizontal Geometry

// Parameter to stop the drawing of the quick horizontal geometry

   horizontal_geometry_y         0

// Set 1 - Extensive Horizontal Geometry Labelling - label the horizontal curve radius

 h_g_1_type                               1 // label horizontal curve
 // if this param is missing then set is ignored

 h_g_1_value_mode                 2 // label curve radius
h_g_1_label_y                          45
h_g_1_label_x                           0
h_g_1_label_offset                  2
h_g_1_label_text_size             4
h_g_1_label_text_colour        YELLOW
h_g_1_label_text                      "Horiz Curve Data"

// Parameters for arrow type

h_g_1_draw_mode                  1
h_g_1_colour                           "white"
h_g_1_height                           1.5
h_g_1_gap                                0

// Parameters for text on the arrows

h_g_1_text_colour                  YELLOW
h_g_1_text_size                       3.5
h_g_1_text_offset                   2.5
h_g_1_pre_text                        "R"
h_g_1_post_text                      "m"
h_g_1_no_decimals                2

Example of Extensive Horizontal Geometry for use with a Non-primary Alignment 
String
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// Set 2 labels the horizontal curves radii of the kerb string projected onto primary stings

h_g_2_offset_string               "left offsets->kerb" // non-primary string to do VG of

h_g_2_type                               1 // label horizontal curve
 // if this param is missing then set is ignored

 h_g_2_value_mode                 2 // label curve radius
h_g_2_label_y                          55
h_g_2_label_x                           0
h_g_2_label_offset                  2
h_g_2_label_text_size             4
h_g_2_label_text_colour        GREEN
h_g_2_label_text                      "Left Kerb - Horiz Curve Data"

// Parameters for arrow type

h_g_2_draw_mode                  1
h_g_2_colour                           "white"
h_g_2_height                           1.5
h_g_2_gap                                0

// Parameters for text on the arrows

h_g_2_text_colour                  GREEN
h_g_2_text_size                       3.5
h_g_2_text_offset                   2.5
h_g_2_pre_text                        "R"
h_g_2_post_text                      "m"
h_g_2_no_decimals                2

Please continue to the next section “Quick Vertical Geometry Labelling” .
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Quick Vertical Geometry Labelling
The standard vertical geometry arrows can be drawn at a given distance above the top of the 
boxes area.

vertical_geometry_grade_y mm // dist above boxes
// 0 = don’t draw

vertical_geometry_grade_mode 0 // %
1 // 1 in

vertical_geometry_label_grade_text text
vertical_geometry_label_grade_textstyle textstyle // textstyle to use
vertical_geometry_label_grade_text_colour colour
vertical_geometry_label_grade_text_size mm
vertical_geometry_label_grade_decimals number
vertical_geometry_length_y mm // dist above boxes

// 0 = don’t draw
vertical_geometry_length_mode 0 // length

1 // radius
2 // k value
3 // mixed - length for parabolic

//                 radius for circular
vertical_geometry_label_length_text  text
vertical_geometry_label_length_textstyle  textstyle // textstyle to use
vertical_geometry_label_length_text_colour colour
vertical_geometry_label_length_text_size mm
vertical_geometry_label_length_decimals number
vertical_geometry_arrow_mode 0 // ticks

1 // arrows
vertical_geometry_arrow_grade_textstyle textstyle // textstyle to use
vertical_geometry_arrow_grade_text_colour colour
vertical_geometry_arrowl_grade_text_size mm

vertical_geometry_arrow_length_textstyle  textstyle // textstyle to use
vertical_geometry_arrow_length_text_colour colour
vertical_geometry_arrow_length_text_size mm

vertical_geometry_arrow_colour colour
vertical_geometry_arrow_height mm

Please continue to the next section “Extensive Vertical Geometry Labelling” .

Extensive Vertical Geometry Labelling
For complicated vertical geometry labelling of the primary alignment string, there are sets of 
vertical geometry labelling parameters which give tight control over the position and types of 
labels.

It is also possible to label the vertical geometry of alignment strings other than the primary 
string. To plot such a string on the same plot, the chainage position of the vertical geometry for 
the non-primary alignment strings is projected onto the primary string to give a primary string 
chainage for plotting. The values of the vertical geometry (such as grade and curve length) that 
are plotted are taken from the other string. Independently graded offset strings (such as a left 
and right kerbs) are the type of additional alignment strings that may need to be plotted on the 
same long section plot as the reference string (primary string).

For plotting vertical geometry, the user can give up to twenty sets of these labels and they can be used to 
label grades or vertical curve information for the primary string and/or additional alignment strings.
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Each label set consists of three parts:

(a) a text label on the left hand side of the plot
(b) an arrow
(c) text on the arrows.

For the following parameters, n takes the value 1 to 20 and specifies the nth parameter set.

 

v_g_n_type 0 // labelling grades
1 // labelling vg curve information

If v_g_n_type is missing, then the entire nth set is ignored.

The interpretation of the value of the 

parameter v_g_n_value_mode depends on whether the set is being used for grade labelling or 
curve labelling:

v_g_n_value_mode
for grade labelling 0 // nothing

1 // % grade
2 // 1 in grade
3 // m/m grade
4 // chainage length between vertical

// curve points
5 // per chord - Queensland Rail

for curve labelling 0 // nothing
1 // length - chainage for parabolic vc’s

//          arc length for circular vc’s
2 // radius
3 // K value
5 // curve constant - Queensland Rail

Vertical curve points to draw the arrows between (for grade labelling only)

v_g_n_between_mode 0 // between chainages at the vip’s
1 // between chainages at the vtp’s

Position of the Arrow Line

v_g_n_label_y mm // distance of arrow line above the top of
// the boxes this can be negative

Parameters for the left hand label of the whole line of the vg arrows:

v_g_n_label_x mm // distance from the left hand side of the 
// labels area

v_g_n_label_offset mm // distance to raise the label_text above
// arrow line

v_g_n_label_text text
v_g_n_label_textstyle textstyle
v_g_n_label_text_size mm
v_g_n_label_text_colour colour

Parameters for arrow type

v_g_n_draw_mode 0 // no arrow
1 // arrow
2 // line
3 // line with uprights at ends
4 // uprights, no line
5 // line with downrights
6 // downrights, no line
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7 // line with up and downrights at ends
8 // up and down rights, no line
9 // draw curve
10 // draw grade

v_g_n_left_gap mm // size of gap for left side of arrow
v_g_n_right_gap mm // size of gap for right side of arrow
v_g_n_colour colour // colour of the arrow
v_g_n_height mm // height of the arrow

v_g_n_gap 0 // no gap
1 // leave gap in arrow for text

Parameters for text on the arrows

v_g_n_text_colour colour // colour of the text
v_g_n_text_size mm // size of the text
v_g_n_text_offset mm // distance to raise the text above the

// arrow line

v_g_n_pre_text text // text before the arrow text
v_g_n_post_text text // text after the arrow text
v_g_n_textstyle textstyle // textstyle used
v_g_n_no_decimals integer // number of decimal places in arrow

// text.
// If > 0, all trailing zeros after the
// decimal place are removed.
// If < 0, the absolute value is taken as
// the number of decimal places and no 
// trailing zeros are removed after the
// decimal point.

v_g_n_rotate mm // if ticked, the text on the arrows will be
 rotated to fit.

If the set of parameters is to apply to the vertical geometry of an alignment string other than the primary 
string, then simply add the following parameter to define the other alignment string 

v_g_n_offset_string "model->string_name"
or

v_g_n_offset_string "string_name" 

and the model is the Offsets model from the Section Long Plot panel. 

If the v_g_n_offset_string parameter does not exist, then the set of vertical geometry parameters is applied 
to the primary string. 
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Example of Extensive Vertical Geometry

// Parameter to not to draw the quick vertical geometry

     vertical_geometry_grade_y        0

// Set 1 labels the vertical curves with length

 v_g_1_type                      1    // curve
 v_g_1_value_mode        1    // chainage length

 v_g_1_label_y                  45
 v_g_1_height                      4
 v_g_1_label_offset            -2
 v_g_1_label_text              “VG Curves”
 v_g_1_text_offset               2
 v_g_1_label_text_size         6
 v_g_1_pre_text                 ““
 v_g_1_post_text               “ L”
 v_g_1_gap                         0
 v_g_1_draw_mode             8
 v_g_1_text_size                  4

// Set 2 labels the vertical curves with K value

 v_g_2_type                     1     // curve
 v_g_2_value_mode         3     // K value

 v_g_2_label_y                  45
 v_g_2_height                   1.5
 v_g_2_label_text              ““
 v_g_2_text_offset             -5
 v_g_2_pre_text                ““
 v_g_2_post_text            “ K”
 v_g_2_gap                         0
 v_g_2_draw_mode            1
 v_g_2_text_size                 4

Example of Extensive Vertical Geometry for use with a Non-primary Alignment 
String

// Set 3 labels the vertical curves with length with the kerb string projected onto primary stings

v_g_3_offset_string               "left offsets->kerb" // non-primary string to do VG of
v_g_3_type                    1    // curve
 v_g_3_value_mode        1    // chainage length

 v_g_3_label_y                  55
 v_g_3_height                      4
 v_g_3_label_offset            -2
 v_g_3_label_text              “Left kerb - VG Curves”
 v_g_3_text_offset               2
 v_g_3_label_text_size         6
 v_g_3_pre_text                 ““
 v_g_3_post_text               “ L”
 v_g_3_gap                         0
 v_g_3_draw_mode             8
 v_g_3_text_size                  4
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Please continue to the next section “Labelling Chainages and Heights in the Graph Area” .
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Labelling Chainages and Heights in the Graph Area
The chainage and/or height values for certain points (given by label_n_type) can be labelled.

Up to twenty sets of chainage/height labels can be done.

label_n_type 0 // chainage of vip, height of vip
1 // chainage of vip, height of primary
2 // crest
3 // sag
4 // vtp
5 // hcp
6 // change of grade
7 // mid-ordinate of the vertical curve

If label_n_type is missing, then the set is ignored.

label_n_y_mode 0 // height in mm above boxes
1 //        above height value (default)
2 //        above primary height

label_n_y mm // distance above point
label_n_angle degrees // rotation about point
label_n_x mm // distance along from point
label_n_offset mm // text raise height
label_n_justification 0 // left end

1 // middle
2 // end

label_n_size mm
label_n_colour size
label_n_textstyle textstyle
label_n_value_mode 0 // no values labelled

1 // val 1 = chainage
2 // val 1 = height
3 // val 1 = chainage, val 2 = height
4 // val 1 = height, val 2 = chainage

label_n_pre_text text
label_n_mid_text text
label_n_post_text text
label_n_textstyle textstyle // textstyle to use
label_n_no_decimals_1 integer // number of decimal places in val 1
label_n_no_decimals_2 integer // number of decimal places in val 2

If the number of decimal places is greater than zero (> 0), then any trailing zeros after the decimal point 
are removed.

If the number of decimal places is less than zero (< 0), the absolute value is taken as the number 
of decimal places and no trailing zeros after the decimal point are removed.

Example of Labelling Chainage and Heights

// label the crests with chainage on one line
// and height (elevation) on the next

 label_1_type                         2    // crest
 label_1_y_mode                    2    // above string
 label_1_y                            10
 label_1_angle                        0
 label_1_justification               1    // centre
 label_1_size                           4
 label_1_colour                   red
 label_1_value_mode              1    // chainage 
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 label_1_pre_text               “CH “
 label_1_no_decimals_1          1

 label_2_type                       2    // crest
 label_2_y_mode                 2    // above string
 label_2_y                           2
 label_2_angle                    0
 label_2_justification            1    // centre
 label_2_size                       4
 label_2_colour                 red
 label_2_value_mode            2    // height 
 label_2_pre_text               “EL “
 label_2_no_decimals_1        1

Please continue to the next section “Labelling With Symbols” .

Labelling With Symbols
Symbols can be placed at certain points given by symbol_n_type.

The symbol is drawn in a square box centred on (0,0) with sides of length two millimetres. That 
is, the box co-ordinates are (-1,-1), (1,1), (1,-1), (-1,-1).

Up to twenty sets of symbol labelling can be done.

symbol_n_type 0 // chainage of vip, height of vip
1 // chainage of vip, height of primary
2 // crest
3 // sag
4 // vtp
5 // hcp
6 // change of grade

If symbol_n_type is missing, then the set is ignored.

symbol_n_y_mode 0 // height in mm above boxes
1 //        above height value (default)
2 //        above primary height

symbol_n_y mm // distance above point given by mode
symbol_n_angle degrees // rotation about point
symbol_n_x mm // distance along from point
symbol_n_size mm //
symbol_n_colour colour // colour of symbol

symbol_n_draw_mode 0 // cross
1 // upright from centre of box
2 // up and downright from centre of box
3 // square
4 // triangle, base at bottom
5 // circle

Example of Labelling with Symbols

// draw a triangle symbol at the crest

 symbol_1_type                       2    // crest

0 1 2 3 4 5
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 symbol_1_y_mode                 2    // above string
 symbol_1_y                            0
 symbol_1_angle                      0
 symbol_1_size                        2
 symbol_1_colour                 red
 symbol_1_draw_mode            4    // triangle 

Please continue to the next section “Hatching Cut and Fill Areas” .

Hatching Cut and Fill Areas
This option is used to hatch cut and/or fill areas between sets of tins.

For each set, the name of the two tins, the hatch linestyle, colour and separation and whether cut 
and/or fill regions are required are all user definable.

Up to twenty (20) separate sets of tins be hatched.

The parameters for labelling cuts and/or fill regions between tins are given by:

hatch_original_tin_n tin_name // tin_name for original surface
hatch_new_tin_n tin_name // tin_name for final surface
hatch_cut_separation_n mm // distance between cut hatch lines

0 // don’t do cut hatching
hatch_cut_angle_n degrees // angle in degrees of cut hatching
hatch_cut_colour_n colour // colour of the cut hatching
hatch_cut_linestyle_n linestyle // linestyle for cut hatching
hatch_cut_draw_sides_n            1/0 // 1 = draw sides of cut regions
hatch_cut_draw_original_n        1/0 // 1 = draw original tin in cut regions
hatch_cut_draw_new_n              1/0 // 1 = draw new tin in cut regions
hatch_fill_separation_n                 mm // distance between fill hatch line

             0 // don’t do fill hatching
hatch_fill_angle_n degrees // angle in degrees of fill hatching
hatch_fill_colour_n colour // colour of the fill hatching
hatch_fill_linestyle_n linestyle // linestyle for fill hatching
hatch_fill_draw_sides_n         1/0 // 1 = draw sides of fill regions
hatch_fill_draw_original_n      1/0 // 1 = draw original tin in fill regions
hatch_fill_draw_new_n             1/0 // 1 = draw new tin in fill regions

Notes

(a) cut is when the new tin is below the original tin.
fill is when the new tin is above the original tin.

(b) cut hatching is turned off by setting hatch_cut_separation_n to 0.0.
fill hatching is turned off by setting hatch_fill_separation_n to 0.0.

Please continue to the next section “Labelling Cuts of Design Through Strings in a Model” .

section viewtin (natural surface)

design long section cut

fill
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Labelling Cuts of Design Through Strings in a Model
The cuts that the primary string (design line) makes though any strings in user given models can 
be automatically labelled on the long section plots.

The height, chainage and name of the cut string can be labelled as well as a symbol. The height 
of tins at the same offset value can also be labelled.

The chainage position for the labelling is the chainage of the cut string.

The height position for the labelling can be specified as the

(a) top of the boxes on the long section

(b) height value of the cut string

(c) height of the primary string

(d) height of a tin.

The actual position of the label is defined relative to the above point.

Note: 

Only case (b) involves the actual height of the cut string. For all other cases, only the chainage of 
the cut string is used. Hence for all cases except (b), the string does need to have a sensible height 
to be used for cuts through strings. 

For example, a boundary string may have null heights but only the chainage is required and the 
height of the tin at that chainage can be used as the height (case (d)).

Text justification refers to the actual position and is given by

“top-left” “top-centre”                   “top-right”
“middle-left” “middle-centre”            “middle-right”
“bottom-left” “bottom-centre”            “bottom-right”

A choice of six special symbols and/or any 12d symbols can be drawn at the cut point.

The special 12d Model symbols of size one millimetre are drawn in a square box centred on (0,0) 
with sides of length two millimetres. That is, the box co-ordinates are (-1,-1), (1,1), (1,-1), (-1,-1).

The six special shapes are

Up to twenty five (25) separate models of strings can be cut and labelled.

primary string

strings to label where they are cut by the design string

plan view

(design string)

tin (natural surface)

design long section

points where strings are cut
in plan by the long section

section view
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Parameters for Labelling Where the Design Cuts Strings in a Model

The method for specifying which strings are to be checked for cuts is by first specifying the 
model which contains the strings, and then a name mask which is used to restrict the strings in 
the model to only those whose name matches the name mask.

Up to twenty five different sets of models and name masks can be used so that different cut sets 
can be labelled in different ways.

The parameters for selecting and labelling the nth set (where n can be from 1 to 25) of cuts of the design 
string with the strings in the model are given by:

cuts_n_model model_name                        // model of strings to be cut

The selection of the strings from the model model_name whose cut points are to be labelled is all the 
strings whose name satisfies the name mask cuts_n_mask:

cuts_n_mask name_mask                       // strings to check for cuts
// and if a cut occurs,

// parameters show how to
// label the cut

where name_mask is a text string containing the name masks, each separated by one or more spaces, to test 
the string name against. Each mast can include wild cards and wild characters.

For example

cuts_1_mask "ke*"
or cuts_1_mask "?bank*"

or, if both masks are required,

cuts_1_mask "ke* ?bank*"

If cuts_n_mask is missing, then all strings in the model are used. This is equivalent to name_mask being 
"*".

All strings in the model cuts_n_model whose name satisfy the name mask cuts_n_mask are then 
checked for cuts with the design string, and if a cut occurs, the cut point will be labelled 
according to the rest of the parameters in the nth set.

The parameters for drawing a symbol at the cut points are 

cuts_symbol_n_mode 0 // cross
1 // up from centre of box
2 // up and down from centre of box
3 // square
4 // triangle, base at bottom
5 // circle
6 // use a 12d symbol

If cuts_symbol_n_mode is 6, then the 12d symbol is given by

cuts_symbol_n_style plotsymbol // plot symbol to draw at cut

Important Note

 The plot symbol of name plotsymbol is defined in the file given by:

(a) the parameter plot_symbols in the ppf file

0 1 2 3 4 5

predefined symbols for 
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plot_symbols filename

or if plot_symbols is not defined, then

(b) in the file pointed to by the environment variable PLOT_SYMBOLS_4D

PLOT_SYMBOLS_4D filename // default plotsym.4d

or if PLOT_SYMBOLS_4D is not defined, then

(c) in the file plotsym.4d

which is searched for in the standard set up file sequence

If none of the above files are defined, or if the symbol does not exist in the above files, then it will 
be searched for in the standard 12d symbols file which is:

(d) either pointed to by the environment variable SYMBOLS_4D

SYMBOLS_4D filename // default symbols.4d

or if the environment variable SYMBOLS_4D does not exist, in the file, symbols.4d 

The position of the symbol is given by:

cuts_symbol_n_position 1 // above point height value
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

The symbol can be adjusted by the parameters:

cuts_symbol_n_x mm // offset adjustment to position
cuts_symbol_n_y mm // height adjustment to position
cuts_symbol_n_angle degrees // rotation about point
cuts_symbol_n_colour colour // colour of symbol

and for all values of cuts_symbol_n_mode other than 6:

cuts_symbol_n_size mm // size of symbol, 0 don’t draw

The value of the chainage of the cut string can be labelled using the parameters

cuts_chainage_n_position 1 // above cut strings height value
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_chainage_n_x mm // chainage adjustment to position
cuts_chainage_n_y mm // height adjustment to position
cuts_chainage_n_angle degrees // rotation about point
cuts_chainage_n_size mm // size of text, 0 don’t label
cuts_chainage_n_colour colour // colour of text

cuts_chainage_n_textstyle text // textstyle of text chainage
cuts_chainage_n_pre_text text // text before the chainage value
cuts_chainage_n_post_text text // text after the chainage value
cuts_chainage_n_justification justification // justification of the text
cuts_chainage_n_no_decimals       integer // number of decimals in chainage
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The value of a height at the chainage of the point can be calculated and labelled using the parameters

cuts_height_n_mode 1 // use height of cut point itself
3 // use real world height of the position

// of the label above the boxes
100 // height of primary string
101-500 // use height of to tin1 or tin2 etc.

cuts_height_n_position 1 // at points position
3 // above top of boxes
100 // to primary string 
101-500 // to tin1 or tin2 etc.

cuts_height_n_x mm // chainage adjustment to position
cuts_height_n_y mm // height adjustment to position
cuts_height_n_angle degrees // rotation about point
cuts_height_n_size mm // size of text, 0 don’t label
cuts_height_n_colour colour // colour of text
cuts_height_n_textstyle text // textstyle of text height
cuts_height_n_pre_text  text // text before the height value
cuts_height_n_post_text  text // text after the height value
cuts_height_n_justification justification    // justification of the text
cuts_height_n_no_decimals  integer           // number of decimals in height

A label which can include the name of the cut string is drawn by using the parameters

cuts_label_n_position 1 // above cut strings height value
3 // above top of boxes
100 // to primary string
101-500 // to tin1 or tin2 etc.

cuts_label_n_mode 0 // don’t include cut string name
1 // include cut string name in label

cuts_label_n_x mm // chainage adjustment to position
cuts_label_n_y mm // height adjustment to position
cuts_label_n_angle degrees // rotation about point
cuts_label_n_size mm // size of text, 0 don’t label
cuts_label_n_colour colour // colour of text
cuts_label_n_textstyle text // textstyle of text label
cuts_label_n_pre_text   text // text before the string name
cuts_label_n_post_text   text // text after the string name
cuts_label_n_justification          justification            // justification of the text
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Please continue to the next section “Labelling the Primary String Name on the Plot” .

design long section

section view

point where the design
cuts a string 

The cut point can be labelled with

chainage of the cut point

height of the cut point

height of the x-section or tins at 
this offset

name of the string for the cut point

tin (natural surface)
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Labelling the Primary String Name on the Plot
The plot can be labelled with a name under the boxes area.

The name is made up of concatenation the text strings:

plot_name_pre_text           primary-string-name              plot_name_post_text

The plot name is positioned under the boxes.

plot_name_string_name 0 // don’t use the primary string name
1 // use primary string name
2 // use model->string name

plot_name_pre_text text
plot_name_post_text text
plot_name_textstyle textstyle
plot_name_size mm
plot_name_colour colour
plot_name_x_offset mm
plot_name_y_offset mm

The plot_name_x_offset is measured from the beginning of the height boxes.

The default for plot_name_x_offset is centred on heights area.

The plot_name_y_offset is measured from the bottom of the box area with positive being down.

Example of Labelling Primary String Name

 plot_name_pre_text      “Long Section Plot for String”
plot_name_post_text               “”
plot_name_size                        15
plot_name_colour                    red
plot_name_string_name              1
plot_name_y_offset                  30

Please continue to the next section “Labelling the Scale on the Plot” .

labelling primary string name on long section plots

plot_name_x_offset

plot_name_y_offset
plot name text

heights areatitle area
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Labelling the Scale on the Plot
The plot can be labelled with the horizontal and vertical scale under the boxes area.

The scale label is made up of concatenation the text strings:

           scale_horizontal_pre_text         horizontal scale value         scale_horizontal_post_text

and

           scale_vertical_pre_text              vertical scale value               scale_vertical_post_text

The horizontal scale value is the value given by the scale parameter.

The vertical scale value is calculated from the horizontal scale and the vertical exaggeration for 
the section view.

The scales are positioned under the boxes.

scale_horizontal_pre_text text
scale_horizontal_post_text text
scale_horizontal_textstyle textstyle
scale_horizontal_size mm
scale_horizontal_colour colour
scale_horizontal_x_offset mm
scale_horizontal_y_offset mm
scale_horizontal_decimals integer
scale_vertical_pre_text text
scale_vertical_post_text text
scale_vertical_textstyle textstyle
scale_vertical_size mm
scale_vertical_colour colour
scale_vertical_x_offset mm
scale_vertical_y_offset mm
scale_vertical_decimals integer

The scale_vertical_x_offset and scale_horizontal_x_offset are measured from the beginning of the heights 
area.

The default for scale_vertical_x_offset and scale_horizontal_x_offset are centred on the heights area.

The scale_vertical_y_offset and scale_horizontal_y_offset are measured from the bottom of the box 
area with positive being down.

If the number of decimal places is greater than zero (> 0), then any trailing zeros after the decimal point 
are removed.

If the number of decimal places is less than zero (< 0), the absolute value is taken as the number 
of decimal places and no trailing zeros after the decimal point are removed.
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Example of Labelling Horizontal and Vertical Scales

 scale_horizontal_pre_text         “Horizontal Scale 1:”
scale_horizontal_post_text             ""
scale_horizontal_size                     15
scale_horizontal_colour             yellow
scale_horizontal_y_offset              60

 
 scale_vertical_pre_text          "Vertical Scale 1:"

scale_vertical_post_text           ""
scale_vertical_size                        15
scale_vertical_colour                green
scale_vertical_y_offset                 90

Please continue to the next section “Title Block Information” .

labelling of scales on the long section plots

scale_vertical_x_offset

scale_vertical_y_offset
vertical_scale text

heights areatitle area

scale_horizontal_x_offset

scale_horizontal_y_offset
horizontal_scale text

heights areatitle area
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Title Block Information
The plot can have a standard 12d Model title block or a user defined title block.

The standard title block consists of a simple border around the plot and two lines of text in a box 
underneath the plot. For a user defined title block, all the line work and text is defined by the 
user.

Standard Title Block

For the standard 12d Model title block, there are extra parameters for two lines of text and text 
size and colour. The standard title block is turned on or off by the parameter plot_border.

plot_border yes/no // yes plots a standard title block
// default yes

title_1 text
title_2 text
title_text_size value
title_colour colour

User Title Block

For the user defined title block, the title block drawing commands are kept in a file whose name 
is supplied by the user. The title block drawing commands are almost identical to the linestyle 
drawing commands and is given at the beginning of this chapter.

Hence for a user defined title block, there are just two parameters - one to say a title block file is 
being used and the other to give the name of the title block file. The plot_border parameter should 
also be set to no so that the standard title block is not also drawn.

use_title_file yes/no // yes draws the title block given in title_file
// default no

title_file filename
plot_border no // turn off standard title block

Some special plot parameters are used to pass information down to variables in a user defined title block. 
For example, inside the title block file it is possible to have runtime user defined text variables. The actual 
text values for these text variables are passed down to the title block file from the plot parameter file via 
the parameters user_text_n (n = 1,2,... 1000)

user_text_n text
The special plot parameters are:

time_format text // format for $time
user_text_n text // where n = 1,2,... 1000

// passed down to $user_text_n
title_1 text // passed down to $title_1
title_2 text // passed down to $title_2
start_page_number integer // used as the starting value for

//   $page_number. If missing, 
//   $page_number starts at 1.

start_drawing_number integer // added to $drawing_number in title
// block file. If missing,
// $drawing_number starts at 1.

drawing_number_prefix        text // passed down to
//   $drawing_number_prefix

drawing_number_postfix          text // passed down to
// $drawing_number_postfix

Please continue to the next section “Parameters that Modify Fields In the Long Plot Panel” .
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Parameters that Modify Fields In the Long Plot Panel
A number of parameters match those in the section long plot panel.

When the plot parameter file is first read, any parameters in the panel will be replaced by the 
values of any corresponding parameters from the parameter file.

However, if the parameter is subsequently modified in the panel, the panel value will be the 
value used for any plots.

The plot parameters that also occur in the section long plot panel are:

scale value
start_chainage value
end_chainage value
chainage_interval value
chord_arc 0/1
plotter_type text
plot_file text
view_name text
offset_model text
plot_border yes/no
label_depths yes/no
primary_string yes/no
datum_value value

sheet_size text     or    “width     height”
box_text_size mm
box_colour colour

use_title_file yes/no
title_file filename
plot_border yes/no
title_1 text
title_2 text
title_text_size value
title_colour colour
pagination yes/no
pagination_length value
pagination_overlap value
global_textstyle textstyle

Please continue to the next section “Generating Long Section Plots Without a View” .
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Generating Long Section Plots Without a View
The long section plot parameters are comprehensive enough that it is possible to completely 
generate a long section plot without referencing a section view, or even using the 
section long plot panel. 

Such a ppf can be run using the plots=>plot a ppf option or from the 4D Solutions programming 
language, 4DML.

When a long section plot is being generated entirely from a file, an extra parameter is needed to 
specify whether the datum value is calculated or the datum_value parameter is used.

manual_datum 1 // use the datum_value parameter for
// the datum

0 // ignore the datum_value and let
// 12d Model calculate the datum.

When generating a long section plot using the section long plot panel, a plot parameter file 
containing all the parameters needed to regenerate the plot using plots=>plot a ppf can be written 
out by simply giving a name for the ppf file in the plot parameters write field of the section long 
plot panel.

Notes

1. A warning is given if the keyword in a plot parameter file does not exist.

2. A warning is also given if the key word pair is defined more than once in a ppf.

Please continue to the next section “Example of a Long Section Plot Parameter File” .
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Example of a Long Section Plot Parameter File
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// ppf file to generate longsection example

section_long_plot  “diag2” {

// plot margins

 left_margin                  0
 right_margin                0
 top_margin                  0
 bottom_margin           30

number_of_decimals 2 // no dec places for heights

 title_box_text_size        7

// annotation for title text and heights etc.

// chainages

 chainage_title                    “DESIGN”
 chainage_title_2                 “CHAINAGE”
 chainage_colour                 “red”

// primary string

 primary_title                       “DESIGN”
 primary_title_2                   “CENTRELINE”
 primary_colour                   “grey”
 primary_title_colour          “yellow”

// primary label modes are
// 0 - last box before blank boxes
// 1 - after chainage annotations

 primary_label_mode             0

// uprights

 uprights_colour                   “yellow”

//uprights_draw_mode           0      // none

 uprights_draw_mode          100    // to primary
 uprights_y                           200

// gap factor for staggering

 stagger_gap_factor              1.3
 stagger_gap_top                  5.0
 stagger_gap_bottom            2.0

 stagger_mode                     1

// datum parameters

 datum_text_size                  6
 datum_colour                     brown
 datum_name                      “DATUM”
 datum_above_gap              15
 datum_below_gap              15
 datum_y                       -2

// 0 for bottom text justification
// 1 for top justification

 box_text_justification           1

// draw lines around annotation at bottom of plot
// 0 - don’t draw them
// 1 - do draw
// 2 - draw box around label text as well
// plus many others

 draw_box_mode                  2
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// tin titles and depth labels
// label = 0 for no label, 1 for label

 tin_1_label                    1              // label natural surface
 tin_1_title                      “NATURAL”
 tin_1_title_2                  “SURFACE”
 tin_1_title_colour          yellow
 tin_1_colour                   “green”
 tin_1_depth_label   0      // don’t label depth to natural surface
 tin_1_depth_title           “CUT / FILL”

 tin_2_label               0           // don’t label sub-surface
 tin_2_depth_label    1            // label depth to sub-surface
 tin_2_title                      “SUB”
 tin_2_title_2                  “SURFACE”
 tin_2_title_colour          yellow
 tin_2_colour                   “green”
 tin_2_depth_title             “CUT / FILL”
 tin_2_depth_title_2         “TO SUB-SURFACE”

// number of blank boxes at the top
// of the plot for user annotations

 number_of_blank_boxes          1

// chainages to include for heights labelling
//  0 don’t use, 1 use

// include the chord-arc points?

 chord_arc                                   0

// include the horizontal critical points?

 chainage_label_hcp                 1

// include horizontal ip’s with no curves?

 chainage_label_hip                  0

// include the vertical tangent points?

 chainage_label_vtp                  0

// include the vips?

 chainage_label_vip                  0

// include the crests?

 chainage_label_crest               0

// include the sags?

 chainage_label_sag                 0

// include change of grade

 chainage_label_grade_change            0

// don’t include bubble chainages

 chainage_merge_bubbles                    0
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// Quick geometry - by default the geometry annotation
// are those of the view
// if they are zero no annotations are performed

 horizontal_geometry_y                               60
 horizontal_geometry_arrow_text_size         4
 horizontal_geometry_arrow_height             3
 horizontal_geometry_arrow_colour          red
 horizontal_geometry_label_text               “Quick HG”
horizontal_geometry_label_text_colour        green
 horizontal_geometry_label_text_size           6

 vertical_geometry_grade_y                    0
 vertical_geometry_length_y                    0

// Extensive vertical geometry annotations

 v_g_1_type                    1    // curve
 v_g_1_value_mode        1    // chainage length

 v_g_1_label_y                  45
 v_g_1_height                      4
 v_g_1_label_offset            -2
 v_g_1_label_text              “VG Curves”
 v_g_1_text_offset               2
 v_g_1_label_text_size         6
 v_g_1_pre_text                 ““
 v_g_1_post_text               “ L”
 v_g_1_gap                         0
 v_g_1_draw_mode             8
 v_g_1_text_size                  4

 v_g_2_type                     1     // curve
 v_g_2_value_mode         3     // K value

 v_g_2_label_y                  45
 v_g_2_height                   1.5
 v_g_2_label_text              ““
 v_g_2_text_offset             -5
 v_g_2_pre_text                ““
 v_g_2_post_text            “ K”
 v_g_2_gap                         0
 v_g_2_draw_mode            1
 v_g_2_text_size                 4

 v_g_3_type                        0     // grade
 v_g_3_value_mode            2     // 1 in grade
 v_g_3_between_mode       1     // between vtp’s

 v_g_3_label_y                  30
 v_g_3_height                      4
 v_g_3_label_offset            -2 
 v_g_3_label_text              “VG Grades”
 v_g_3_label_text_size         6
 v_g_3_text_offset               2
 v_g_3_pre_text                “1 in “
 v_g_3_post_text               ““
 v_g_3_gap                         0
 v_g_3_draw_mode            8
 v_g_3_text_size                 4
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 v_g_4_type                         0     // grade
 v_g_4_value_mode             4     // chainage length
 v_g_4_between_mode        1     // between vtp’s

 v_g_4_label_y                  30
 v_g_4_height                   1.5
 v_g_4_label_text              ““
 v_g_4_text_offset             -5
 v_g_4_pre_text                ““
 v_g_4_post_text               “ L”
 v_g_4_gap                          0
 v_g_4_draw_mode              1
 v_g_4_text_size                   4

// label the crests with chainage on one line
// and height (elevation) on the next

 label_1_type                         2    // crest
 label_1_y_mode                    2    // above string
 label_1_y                            10
 label_1_angle                        0
 label_1_justification               1    // centre
 label_1_size                           4
 label_1_colour                   red
 label_1_value_mode              1    // chainage 
 label_1_pre_text               “CH “
 label_1_no_decimals_1          1

 label_2_type                       2    // crest
 label_2_y_mode                 2    // above string
 label_2_y                           2
 label_2_angle                    0
 label_2_justification            1    // centre
 label_2_size                       4
 label_2_colour                 red
 label_2_value_mode            2    // height 
 label_2_pre_text               “EL “
 label_2_no_decimals_1        1

 label_3_type                         2    // crest
 label_3_y_mode                    2    // above string
 label_3_y                            18
 label_3_angle                        0
 label_3_justification               1    // centre
 label_3_size                          4
 label_3_colour                  red
 label_3_value_mode              0    // no values 
 label_3_pre_text           CREST
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// Draw bubbles at the horizontal critical points:
// chainages to include for bubbles numbering 
// 0 don’t use, 1 use

 chainage_bubbles                       1
 bubble_label_hcp                       1
 bubble_label_hip                        0
 bubble_label_vtp                        0
 bubble_label_vip                        0
 bubble_label_crest                     0
 bubble_label_sag                       0
 bubble_label_grade_change       0

 bubble_radius                        10
 bubble_colour                        cyan
 bubble_text_size                    5
 bubble_text_colour                red

 bubble_upright_distance        30
 bubble_mode                         1
 bubble_draw_upright              1

 plot_name_pre_text      “Long Section Plot for String”
 plot_name_post_text               “”
 plot_name_size                        15
 plot_name_colour                    red
 plot_name_string_name              1
 plot_name_y_offset                  30

 scale_horizontal_pre_text         “Horizontal Scale 1:”
 scale_horizontal_post_text             ""
 scale_horizontal_size                     15
 scale_horizontal_colour             yellow
 scale_horizontal_y_offset              60
 
 scale_vertical_pre_text          "Vertical Scale 1:"
 scale_vertical_post_text           ""
 scale_vertical_size                        15
 scale_vertical_colour                green
 scale_vertical_y_offset                 90

// ******** panel data ********

 view_name                          4

 plotter_type                     model
 plot_file                           "diag2"

 start_chainage                          0
 end_chainage                       801

 chainage_interval                    25

 sheet_size                     "1000 800"
 scale                               1000.0

 primary_string                   yes
 label_depths                      no
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 box_text_size                     5
 box_colour                     green

 datum_value                      50
 offset_model                     ""

 plot_border                     "no"
 title_1                        "Title 1"
 title_2                        "Title 2"
 title_text_size                    2.5
 title_colour                  "magenta"
}
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#Include in Plot Parameter Files
The plot parameter file also recognizes the CCCP preprocessor rules including #include which 
can be used to include other files in the plot parameter file.

The format of the #include command is:

#include file_name 

Hence a block of plot parameters can be set up in a file and included in another file using 
#include rather than typing them all in again.

Any number of #include’s can be placed in the plot parameter file.
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P Glossary

Glossary of Common Terms

Arc
Part of the circumference of a circle.

Affine Transformation 2D
A two dimensional transformation where one set of points is fitted to another. The 
transformation is a five parameter transformation, i.e., x displacement, y displacement, x scale 
factor, y scale factor and rotation. If more variables exist than degrees of freedom, i.e., more than 
three control points are used, a least squares solution is calculated.

AGD
Australian Geodetic Datum.

AGD66
Australian Geodetic Datum 1966.

AGD84
Australian Geodetic Datum 1984.

AMG
Australian Map Grid.

Angle, Cartesian Angle, Mathematical Angle
The angle of a point is the counter-clockwise angle from the x-axis (horizontal or East line) to the 
line joining the point to the origin.

The angle of a line is the counter-clockwise angle measured from the x-axis to the line.

Batter
A steeply sloping surface (usually the wall of an earth bank).

Bearing
The bearing of a point is the clockwise angle from the y-axis (vertical or North line) to the line 
joining the point to the origin.

The bearing of a line is the clockwise angle measured from the y-axis to the line.
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Breakline
A line on a surface joining a series of points on a common change-of-grade line. For example, the 
ridge top or spur, top or toe of batter, creek bank. See also tinable segment.

Cartesian Angle
See Angle.

Chainage
Chainage is a measure of the plan length along a string. The chainage at a point on a string is the 
start chainage of the string plus the plan length of the string from the beginning of the string to 
that point.

Circular Curve
Curves defined as an arc.

Cross Fall
The lateral grade or slope of a surface (particularly of a road pavement); usually expressed as a 
percentage of the proportion of metres vertically to metres horizontally.

End Chainage
The chainage of the last point of a string.

Eye-Point
For a perspective view, it is the point where the observer of the perspective view looks from.

GDA
Geocentric Datum of Australia.

GDA94
Geocentric Datum of Australia 1994.

GPS
Global Positioning System.

Grade
The longitudinal slope of a surface (particularly of road pavement). Usually expressed as a cross 
fall percentage or as a ratio of one unit vertically to a number of units horizontally. For example, 
3% or 1:10.

GRS80
Geocentric Reference System 1980.
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Helmert Transformation 2D
A two dimensional transformation where one set of points is fitted to another. The 
transformation is a four parameter transformation, i.e., x displacement, y displacement, scale 
factor and rotation. If more variables exist than degrees of freedom, i.e., more than two control 
points are used, a least squares solution is calculated.

Hidden Line
Lines that are hidden between protruding landforms, etc. in perspective views.

Horizontal Alignment
The plan position of an alignment string (centre line) defined by intersection points, spirals and 
arcs.

Intersection Point (IP)
The point where two lines intersect. Usually horizontal intersection points (HIP) or vertical 
intersection points (VIP)

Invert
The lower inner surface of a drain or sewer pipe.

ISG
Integrated Survey Grid (NSW Australia).

MGA, MGA94
Map Grid of Australia 1994.

NTv2
National Transform Version 2. Special grid file format used in Australia, NZ and Canada for 
converting longitude and latitude.

Null Value
In three dimensional data, it is possible that a point can have a valid plan position but an 
undefined height. In 12d Model, there is a special null value which is used internally when 
height is undefined (-9.9e29).

Obvert
The upper inner surface of a drain or sewer pipe.

Parabolic Curve
Curves defined as a parabola.

Plot File
A file of plotting instructions in a format to suit a particular plotter. In 12d Model, HPGL is the 
default format for plot files.
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Polygon
A string where the first point and the last point have the same plan co-ordinate. That is, the 
string closes on itself.

Screen Units
The unit of resolution for the computer screen - usually called pixels.

Shade
For a shade for a perspective view, the colour of all triangle faces are adjusted depending on the 
angle they make with a specified light source.

Slope
The inclination or grade of a surface or line, usually expressed as a ratio between one unit 
vertically to a number of units horizontally. For example, 1:10.

Snapping
A process where the element to be selected does not have to be exactly located. A tolerance is 
specified (the snap tolerance) and if the cursor is placed within the tolerance distance of the 
element then the cursor is moved directly (“snaps”) to the element.

Different snap settings determine what parts of the element are considered for snapping to. For 
example, points on the string (point snap), drop perpendicular on the lines of an element (line 
snap) and grid points (grid snap).

Spiral
The special type of curve used for transitioning between straights and arcs in an alignment string 
(centre line). Also known as a transition curve or transition spiral.

Start Chainage
The chainage of the first point of a string.

String
A string is an ordered series of points.

Apart from the first and last point in a string, each point in a string has a unique next point 
(successor) and a unique previous point (predecessor). The previous and next points for a point 
are called its string neighbours. The lines joining a point with its neighbours are called string 
links.

A string which has the same first and last point is called a closed string otherwise a string is said 
to be open.

Strings are very useful in the modelling of terrain and design surfaces. 12d Model uses a number 
of different types of strings which as defined in the chapter Tools and Concepts.

Sweep Angle
For an arc, the sweep angle is the angle, measured in the clockwise direction, between the line 
joining the arc start point to the arc centre and the line joining the arc end point to the arc centre.
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Tangent Point
A point at which a curve touches a line or another curve such that the tangent vector at that point 
is the same for the two touching items.

Target-Point
For a perspective view, it is the point that the observer is looking at.

Template
Standardized cross-section which is applied to a string at defined chainage points.

Template Modifiers
12d Model commands which modify the definition of a template. Template modifiers are used in 
preference to defining hundreds of different templates.

TIN
Triangulated Irregular Network. A TIN is a set of triangles which do not non-overlap in plan. 
Each vertex of a triangle has a z-value so that the TIN represents a surface in three dimensional 
space made up of triangular faces. When a TIN is created from a data set, the triangles are 
formed so that all non-null points are vertices of triangles. If breaklines are preserved in the TIN, 
then triangles are constrained so that any link from a breakline string is a side of a triangle.

Tinable vertex or point
If a vertex or point is tinable, then the vertex/point is included in triangulations. If the vertex/
point is not tinable, then the vertex/point is ignored when triangulating.

Tinable segment or line

If a segment or line is tinable (and both the vertices at the ends of the segment/line are tinable 
and the z-values not null), then the segment/line is used as a side of a triangle during 
triangulation. This may not be possible if there are crossing tinable segments/lines.

A tinable segment is also known as a breakline.

Note that for a segment/line to be used as a side of a triangle, then its end vertices must be 
tinable and the z-values not null.

Triangulation
A set triangles, which do not overlap in a plan view, created from a set of data points. See TIN.

UTM
Universal Transverse Mercator.

View
The area in 12d Model used for displaying (drawing) graphical information. In 12d Model there 
are three types of views - plan, section and perspective.



12d Model   Manual

Page 3564 June 2002

Vertical Alignment
The long section position of an alignment string (centre line) defined by vertical intersection 
points (VIP’s) and parabolic or circular curves.

WGS84
World Geodetic System 1984.

World Units
The fundamental units used in 12d Model - usually metres.
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- on view  316, 319, 322

Symbols
#define  2939, 2940
#Include  3557
#include  2939, 2940, 3557
$drawing_number  2386
$drawing_number_postfix  2386
$drawing_number_prefix  2386
$end_chainage  2385
$horizontal_scale  2385
$page_number  2386
$plot_file  2385
$project  2385
$scale  2385
$start_chainage  2385
$time  2386
$title_1  2386
$title_2  2386
$user_text_n  2386
$vertical_scale  2385
* on view  316, 318, 319, 321, 322
+ on view  316, 318, 321
,  455

Numerics
12d Ascii  3299
12d ascii  436, 481
12d ascii input  436, 481
12d ascii output  495
12d field file  1289, 3083, 3136, 3137
12d Model Menu  403
2 points 2 distances  1074
2 points profile  305
2d edit menu  958
2D Helmert transformation  1407
2d string  99, 869, 949, 1401
2d string edit  961
2d super string  869, 950
2d to 3d  2704
3  882
3 centre curve  882
3d edit menu  958
3d string  99, 871, 952, 1401
3d string edit  967
3d to 2d  2705
4D ascii file  3299
4D ascii output  495
4d edit menu  958
4d string  99, 874, 954, 1402, 3436
4d string edit  969
4DML  2667
7 parameters  366

A
about 12d Model  2823
absolute_extensions  2396, 3445
Acad output map file  427
acadmf file  427
add 3pt curve  1042
add all functions to project  2661
add all models  185
add all models to project  580
add all tins to a project  1246
add function to project  2661
add model  184
add model to project  580
add model to view  581
add shared models  588
add shared tins  1278
add tin to a to model  1247
add tin to project  1246
add to a view  132
advanced templates  2831
affine transformation  2693, 3559
AGD  3559
AGD 84)  3283
AGD66  3559
agd66/84  gda94  1438
AGD84  3559
aliases  2386
alignment edit  972
alignment string  99, 877
amend vertical geometry  1658
amf file  3434
AMG  1438, 3283, 3559
AMG zone  357
angle  3559

cartesian  3559, 3560
mathematical  3559

angled_post_text  1868
angled_pre_text  1868
angled_text_angle  1868, 1893, 2221
angled_text_colour  1868, 1893
angled_text_gap  1868, 1893, 2221
angled_text_offset  1868, 2221
angled_text_size  1868, 1893
angled_text_x_offset  1893
angled_text_y_offset  1893
angled_textstyle  1868
angles  143
annotation

geometry  298
grade  301

ANS  356
append  1006, 1010

pipeline  2204
append point  1038
apply  1633, 1637, 2831

defaults  1635

Index
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many defaults  1635
apply function  1633
apply many  1643, 1679, 2831

specials  2835
apply many templates  1643, 2831
apply template  1633
Arc  3559
arc  100, 914, 3094, 3559
arc - centre, start point and sweep angle  917
arc between 3 points  1079
arc centres  235
arc edit  995
arc fitting end  1390
arc fitting start  1389
arc through last 3 points  1389
arc through next 3 points  1388
arc to chord  1061
Arc View Act/Min/Max/Avg DEM  1255
Arc View DEM  1254
arc-to-chord correction(t-T correction)  3294
ArcView shape file  496
ArcView SHP file  438
area

polygon  2604
string  2604
surface  2678

arf  1213
arrow_area_1  1855, 1891
arrow_area_2  1855, 1891
arrow_area_3  1855, 1891
arrow_area_4  1855, 1891
asbuilt string vs design string  2616
aspect analysis  1212, 1213
aspect analysis 2  1213
aspect colouring  1183
aspect inquire  1227
aspect range file  1212, 1213
at point  136
attachment  1388
atter

decision  2983
attributes  230, 1111

model  578
project  397, 578
string  1093

Ausgeoid98 conversion  1542
Australian conversions  1430
Australian Geodetic datum  3283
Australian Map Grid  357, 3283
Australian National Spheroid  356
AUTHORIZATION_4D  3338
auto recalc  2680
AUTO_DELETE_WALKRIGHTS_4D  3338
AUTO_RESET_DRAG_TOLERANCE_4D  3338
AUTO_RESET_SELECT_4D  3338
AUTO_RESET_TOLERANCE_4D  3339
AutoCAD output map file  427
Autocad output map file

create/edit  427
AutoCAD plotting map file  2362
autopan perspective view locked to a section view  251
autopan plan view  248, 250
Autopan section view locked to section view  250
autopan sectionview  248, 250
avi  287, 289
Azimuth  3295, 3296

B
back distance  267
background Colour  240
backsight measurement  1299
backspace  90
Barwon sewer option  1682
batter  2971, 2986, 3417, 3559
batter decision  2971, 2983
BCC Epson  450
BCC Epson input  450
bearing  2676, 3559

ellipsoid  3291
grid  3291

Bearing and distance (GDA94/AGD66-84)  1461
bearing/distance entry  1543, 1546
Bearing/distance label  1471
bearings  143
bearings intersect  1074
between point  1039
BISECTORS_4D  3339
block controls  1817
block delimeter  3107
bmp  1135
bold contours  1186
bottom_border_gap  2397, 2453, 3442, 3495
bottom_margin  1840, 2212, 2213, 2398, 2454, 3442,

3495
bottom_sub_plot_gap  2400, 3443
boundary  1175
Bowditch  1408, 1425, 1493, 1495, 1497, 1504
box

enter chainage  108
enter relative vertex number  109
enter vertex number  108
enter vip number  108

box_colour  1844, 1883, 1890, 1902, 2409, 2457, 3459,
3499

box_extension_mode  2415, 3461
box_gap  2459, 3498
box_height  1844, 1890
box_line_draw_mode  2414, 2462, 3460, 3500
box_line_mode_n  2414, 2462, 3460, 3501
box_side_colour_1  2413, 2461, 3459, 3499
box_side_colour_2  2413, 2461, 3459, 3499
box_side_colour_3  2461, 3500
box_side_colour_4  2413, 2461, 3460, 3500
box_side_colour_5  2413, 2461, 3460, 3500
box_side_colour_6  2413, 2461, 3460, 3500
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box_side_colour_7  2413, 2461, 3460, 3500
box_side_colour_8  2413, 2461, 3460, 3500
box_size_n  2460, 3498
box_text_colour  1844, 1890
box_text_justification  2412, 2459, 3458, 3498
box_text_left_justify  1845
box_text_side  1845
box_text_size  1844, 1883, 1890, 1902, 2459, 3498
box_titles_x  2217, 2411, 2459, 3458, 3498
box_width  1844, 1890
boxing  1643, 1661, 1666, 2831, 2898, 2944, 2945, 2960,

2968
copy  2949
end  2954
LHS xfall  2955
line  2953
RHS xfall  2956
xfall  2950
xfall 1  2952

boxing file  2899
boxing many  1667, 2944, 2968
boxing many (function)  2968
boxing many function  1669
breakline  101, 1173, 3560
breakline string  102
breakline type  101
browse  131
bubble_chord_arc  2494, 3526
bubble_colour  1866, 2494, 3526
bubble_draw_upright  2494, 3526
bubble_end_chainage  2494, 3526
bubble_interval  2494, 3526
bubble_label_crest  2496, 3526
bubble_label_ends  3526
bubble_label_grade_change  2496, 3526
bubble_label_hcp  2495, 3526
bubble_label_hip  2495, 3526
bubble_label_sag  2496, 3526
bubble_label_tolerance  2496, 3526
bubble_label_vip  2495, 3526
bubble_label_vtp  2495, 3526
bubble_length  1866
bubble_mode  2495, 3526
bubble_post_text  2495, 3526
bubble_pre_text  2495, 3526
bubble_radius  1866, 2494, 3526
bubble_special_n_file  2496, 3526
bubble_start_chainage  2494, 3526
bubble_text_colour  1866, 2495, 3526
bubble_text_offset  2495, 3526
bubble_text_size  1866, 2495, 3526
bubble_text_string_name_mode  2495, 3526
bubble_textstyle  1866, 2495, 3526
bubble_upright_distance  2495, 3526
buttons  77

view  315
by  402

C
Cad Control Bar  87, 638, 645, 678, 679
calc extents  189
cartesian angle  3559, 3560
cartographic projection  356
cartographic projections  1433
catenary measurements  1548
center_pipe_length  1850
centre_chainage_box_size  1845
chain  2647

option  2652
chainage  101, 1146, 3560

end  3560
special  2835
start  3562

chainage at a point  1146
chainage_box_mode  1848
chainage_box_size  1845
chainage_bubbles  2494, 3526
chainage_cl_decimals  1846
chainage_colour  2404, 2464, 3449, 3457, 3501
chainage_decimals  1846, 2218, 2404, 2463, 3449, 3456,

3501
chainage_interval  2486, 3519
chainage_label  2404, 3449, 3456
chainage_label_crest  2486, 3519
chainage_label_ends  2486, 3519
chainage_label_grade_change  2486, 3519
chainage_label_hcp  2486, 3519
chainage_label_hip  2486, 3519
chainage_label_sag  2486, 3519
chainage_label_tolerance  2486, 3519
chainage_label_vip  2486, 3519
chainage_label_vtp  2486, 3519
chainage_merge_bubbles  2486, 3519
chainage_merge_tolerance  2487, 3519
chainage_mode  1850
chainage_n_colour  2473, 3508
chainage_n_decimals  2473, 3508
chainage_n_offset_mode  2473, 3508
chainage_n_offset_string  2473, 3508
chainage_n_size  2473, 3508
chainage_n_textstyle  2473, 3508
chainage_n_title  2473, 3508
chainage_n_title_2  2473, 3508
chainage_n_title_colour  2473, 3508
chainage_n_title_size  2473, 3508
chainage_n_title_textstyle  2473, 3508
chainage_n_title_y_pos  2473, 3508
chainage_n_y_pos  2473, 3508
chainage_side_cl  2424, 3449
chainage_size  2404, 2464, 3449, 3457, 3501
chainage_special_n_file  2487, 3519
chainage_special_text_colour  2216
chainage_special_text_size  2216
chainage_special_textstyle  2216
chainage_text_colour  1846, 2218
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chainage_text_colour_cl  1846
chainage_text_justification  2410, 3457
chainage_text_justification_cl  2424, 3449
chainage_text_size  1846, 2218
chainage_text_size_cl  1846
chainage_textstyle  1846, 2218, 2404, 2464, 3449, 3457,

3501
chainage_textstyle_cl  1846
chainage_title  2403, 2404, 2463, 3449, 3456, 3501
chainage_title_2  2463, 3501
chainage_title_colour  1846, 2463, 3501
chainage_title_colour_cl  1846
chainage_title_size  2463, 3501
chainage_title_text_colour  2218
chainage_title_text_size  1846, 2218
chainage_title_text_size_cl  1846
chainage_title_textstyle  1846, 2218, 2463, 3501
chainage_title_textstyle_cl  1846
chainage_title_y_pos  2463, 3501
chainage_x_offset  2404, 3449, 3457
chainage_y_offset  2404, 3449, 3457
chainage_y_pos  2464, 3501
Chainge Height typed input box  111, 960
change contours  1197
change decision  2863
change plot frame  2345
change project  326
change string  1046, 2698
change string chainage  2700, 2701
change text  2749
character

British pound  142
copyright  142
cubed  142
degree  142
Japanese yen  142
large diameter  142
middle dot  142
registered  142
small diameter  142
squared  142

check asbuilt string vs design string  2616
check breakline  1159
check control model  1552
check measurement  1300
check points  328
choices  125
chord_arc  2486, 3519
circle  100, 914, 929, 930
circle edit  999
circle feature  1390
circular curve  3560
CivilCad  452
CivilCad input  452
civilcad output  524
CIVILCAD_PATH_4D  3339
cl_linestyle  2423, 3450
clashes  295

clean model  594
clip string  1046
clipping planes  267
close string  1048, 1399
clouds  634
code

operation  3136
cogo (co-ordinate geometry)  1067
color picker  147
colour  101, 102
colour inquire  1229
colour of tin  1176
colour picker  147
colour tin within polygon  1176, 1178
colour triangles  1176
colours  3354, 3357

view objects  145
colours.4d  145, 2384, 3331, 3354, 3426
COLOURS_4D  3339
column header  130
combined point scale factor  3295
command delimiter  3107
comment  2844
Comment delimiter  3110
compass  1408, 1425, 1493, 1495, 1497, 1504
compile  2667
conformance reports  1520, 1531
connection_il_decimals  1873
connection_il_post_text  1873
connection_il_pre_text  1873
connection_il_text_colour  1873
connection_il_text_size  1873
connection_il_textstyle  1873
connection_mid_text  1871
connection_post_text  1871
connection_pre_text  1871
connection_text_colour  1871
connection_text_gap  1873
connection_text_size  1871
connection_text_x  1871
connection_text_y  1871
connection_textstyle  1871
continuous mode  3367, 3371
contour colour  1199
contour increment  1186
contour reference  1186
contour string  99
contouring  1186
contours  203, 268, 1186

change  1197
fast  203
quick  203

Control bars  638
control station  100, 1551
controls  1817
convergence  3295
convert  2703

2d to 3d  2704
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3d to 2d  2705
4d to 3d  2706

convert ascii ppf to binary  2590
convert raw  1291
convert string  1082
convert strings  2703
coord modifier  2842, 2917
coord to string  2842
copy  2949
copy a chain  2657
copy plot frame  2345
copy project  327
copy project model  582
copy project tin  1249
copy string  1058
copy template  1625
copy tin  1248
copy tin from a project  1249
copy title data  2591
corner splays  1063
corridor  295, 303
corridor width  295
corridor_chord_arc  3473, 3524
corridor_model_n  3473, 3524
corridor_overlap_left  3473, 3524
corridor_overlap_right  3473, 3524
corridor_width_left  3473, 3524
corridor_width_right  3473, 3524
cover  1230
create

plot frame  2341
plot frame seed  2350
plot frames along string  2348

create 2d string  869, 949
create 3d string  871, 952
create 4d string  874, 954
create alignment string  877
create arc  914
create boxing  1661
create boxing file  1663
create circle  914, 929
Create Control Stations  1551
create data collector definition  383
create feature string  935
create grid  2726
create label map file  423, 427
create line  1068
create linestyle  384
create macro  2670
create map file  412
create model  574
create mtf file  1674
create pipe string  937
create point  1068
create point between points  1069
create polyline string  940
create project  398
create raster  259

create ridge and valley lines  1223
create string  867, 949

same as  957
create super alignment string  891
create super string  943
create symbol  388
create text string  947
create textstyle  392
create textstyle data favourite  395
create triangulation  1161, 1166
create/edit 7 parameter details  366
create/edit N value settings  361
create/edit projection  355
crest/sag points report  2598
cross fall modifier  2923, 2924
cross fall report  1147
cross section

name from string  1774
cross section filter  1782
cross section plot  310
cross section report  2636
cross sections  1275, 1771

sort  1777
cross sections through tin  1275
cross-fall  3560
cross-fall modifier  2923, 2924
cross-section plot  2366
CUBED_CHARACTER_4D  3339
cul-de-sac  880
culdesac  880
culling  194, 264
culvert string  1402
current measurement  3137
current point  3137
current string  3137, 3227
cursor snap  118, 119, 2640
curve  884
cut height  2868, 2929
cut height from link  2870
cut height modifier  2928, 2929
cut height to 2 strings  2875
cut height to string  2872
cut height to tin  2874
cut modifiers  2865
cut remove  2867
cut slope  2869, 2931
cut slope from link  2870
cut slope modifier  2930, 2931
cut slope to 2 strings  2875
cut slope to string  2872
cut slope to tin  2874
cut template  1618, 1621
cut template link  1617
cut tin height modifier  2931
cut tin slope modifier  2932
Cut volumes sign  2233
cut width  2868, 2927
cut width from link  2870
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cut width modifier  2926, 2927
cut width to 2 strings  2875
cut width to string  2872
cut/fill

tick marks  1127
cut/fill marks

tadpoles  1126
cuts  2710
cuts_chainage_n_angle  1880, 1899, 2225, 3541
cuts_chainage_n_colour  1880, 1899, 2225, 3541
cuts_chainage_n_justification  1880, 1899, 2225, 3541
cuts_chainage_n_no_decimals  1880, 1899, 2225, 3541
cuts_chainage_n_position  1880, 1899, 2225, 3541
cuts_chainage_n_post_text  1880, 1899, 2225, 3541
cuts_chainage_n_pre_text  1880, 1899, 2225, 3541
cuts_chainage_n_size  1880, 1899, 2225, 3541
cuts_chainage_n_textstyle  1880, 1899, 2225, 3541
cuts_chainage_n_x  1880, 1899, 2225, 3541
cuts_chainage_n_y  1880, 1899, 2225, 3541
cuts_height_n_angle  1881, 1900, 2226, 3482, 3542
cuts_height_n_colour  1881, 1900, 2226, 3482, 3542
cuts_height_n_justification  1881, 1900, 2226, 3542
cuts_height_n_mode  1881, 1900, 2226, 3481, 3542
cuts_height_n_no_decimals  1881, 1900, 2226, 3482,

3542
cuts_height_n_position  1881, 1900, 2226, 3482, 3542
cuts_height_n_post_text  1881, 1900, 2226, 3482, 3542
cuts_height_n_pre_text  1881, 1900, 2226, 3482, 3542
cuts_height_n_size  1881, 1900, 2226, 3482, 3542
cuts_height_n_textstyle  1881, 1900, 2226, 3482, 3542
cuts_height_n_x  1881, 1900, 2226, 3482, 3542
cuts_height_n_y  1881, 1900, 2226, 3482, 3542
cuts_label_n_angle  1881, 1900, 2226, 3482, 3542
cuts_label_n_colour  1881, 1900, 2226, 3482, 3542
cuts_label_n_justification  1881, 1900, 2226, 3482, 3542
cuts_label_n_mode  1881, 1900, 2226, 3482, 3542
cuts_label_n_position  1881, 1900, 2226, 3482, 3542
cuts_label_n_post_text  1881, 1900, 2226, 3482, 3542
cuts_label_n_pre_text  1881, 1900, 2226, 3482, 3542
cuts_label_n_size  1881, 1900, 2226, 3482, 3542
cuts_label_n_textstyle  1881, 1900, 2226, 3482, 3542
cuts_label_n_x  1881, 1900, 2226, 3482, 3542
cuts_label_n_y  1881, 1900, 2226, 3482, 3542
cuts_n_mask  1879, 1898, 2224, 3480, 3540
cuts_n_model  1879, 1898, 2224, 3480, 3540
cuts_offset_n_angle  3481
cuts_offset_n_colour  3481
cuts_offset_n_justification  3481
cuts_offset_n_no_decimals  3481
cuts_offset_n_position  3481
cuts_offset_n_post_text  3481
cuts_offset_n_pre_text  3481
cuts_offset_n_size  3481
cuts_offset_n_textstyle  3481
cuts_offset_n_x  3481
cuts_offset_n_y  3481
cuts_symbol_n_angle  1880, 1899, 2225, 3481, 3541
cuts_symbol_n_colour  1880, 1899, 2225, 3481, 3541

cuts_symbol_n_mode  1879, 1898, 2224, 3480, 3540
cuts_symbol_n_position  1880, 1899, 2225, 3481, 3541
cuts_symbol_n_size  1880, 1899, 2225, 3481, 3541
cuts_symbol_n_style  1879, 1898, 2224, 3480, 3540
cuts_symbol_n_x  1880, 1899, 2225, 3481, 3541
cuts_symbol_n_y  1880, 1899, 2225, 3481, 3541

D
data collector  3083, 3124

setup  1288
data collector definition  383
data collectors  383
data precision  144
data source  122
data target  123
data tip  120
DATA_COLLECTORS_4D  3339
DATA_TIPS_4D  3339
datum

Geodetic  3292
datum_above_gap  2410, 2490, 3456, 3522
datum_above_gap_cl  2423, 3448
datum_below_gap  2410, 2490, 3456, 3522
datum_colour  1854, 1891, 2220, 2403, 2490, 3448,

3456, 3522
datum_decimals  1854, 2402, 2490, 3448, 3456, 3522
datum_gap  1854, 2220
datum_line_colour  2403, 3448, 3456
datum_linestyle  2402, 2490, 3448, 3456, 3522
datum_name  1854, 1891, 2220, 2403, 2490, 3447, 3448,

3456, 3522
datum_roundoff  2402, 2490, 3448, 3456, 3522
datum_side_cl  2423, 2424, 3448
datum_text_justification_cl  2423, 2424, 3448
datum_text_size  1854, 1891, 2220, 2403, 2490, 3448,

3456, 3522
datum_textstyle  1854, 2220, 2403, 2490, 3448, 3456,

3522
datum_title_text_colour  1854, 2220
datum_title_text_size  1854, 2220
datum_title_textstyle  1854, 2220
datum_title_x  1854
datum_title_y  1854
datum_value  2490, 3522
datum_value_decimals  1891
datum_value_post_text  1891
datum_value_pre_text  1891
datum_x  1854, 2410, 2491, 3456, 3522
datum_x_cl  2424, 3448
datum_y  1854, 2410, 2491, 3456, 3522
datum_y_cl  2424, 3448
decision  2863, 2926

batter  3417
fixed slope  3417
fixed xfall  3417
goto  3418
label  3417
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string offset  3417
tin decision  3417
tin width  3417

decision table  1616
decisional  3417
decisions  2926, 3417

batter  2986
batter decision  2983
end  2993, 3418
fixed slope  2975
fixed xfall  2973
goto  2990
label  2990
string offset  2979
tin decision  2981
tin width  2977
undo  2992

decisions template  1618
default DPI  2364
default file endings  149, 3413
default settings  333, 335, 338, 339
default values  148
DEFAULT_PLAN_SCALE_4D  3339
DEFAULT_TABLE_WIDTH_4D  3340
DEFAULT_VIEW_COLOUR_4D  3339
defaults  148, 333

apply  1635
name settings  339
system settings  335
trash settings  338

defaults.4d  3331, 3355
DEFAULTS_4D  3339
define  2939
DEGREES_CHARACTER_4D  3340
del 3 pt curve  1008, 1033
delete  90, 190, 2714

function  2664
view  608

delete 3pt curve  1042
delete 7 parameter settings  367
delete all models  596
delete all tins  1285
delete chain  2658
delete function  2664
delete many function  2666
delete model  595
delete n value setting  364
delete N value settings  364
delete plot frame  2347
delete point  1039
delete projection  358
delete string  1049, 1153
delete template  1631
delete three point curve  1008, 1033
delete tin  1284
deleting a menu  84
deleting a panel  93
delimeter

block  3107
delimiter

command  3107
comment  3110
offset code  3112
string  3111

DEM  455
Arc View  1254
Arc View Act/Min/Max/Avg  1255
Quantm  1256
Sokkia  1258

depth between strings report  1147
depth between tins  1230
depth from height inquire  1229
depth from string  1230
depth range file  2263, 2286
depth_decimals  1847, 2219
depth_mode  1846, 2219
depth_negative_factor  2419, 2420, 2468, 3465, 3510
depth_positive_factor  2419, 2468, 3465, 3510
depth_text_colour  1847, 2219
depth_text_size  1847, 2219
depth_textstyle  1847, 2219
depth_title_colour  1847
depth_title_text_colour  2219
depth_title_text_size  1847, 2219
depth_title_textstyle  1847, 2219
design  1615
design parameters  902
design parameters table  902
DGN binary models  508
DGN complex elements input  458
dgn file  508
DGN format  456
DGN input  456, 457
DGN output  508
DGN output map file  510
DGN plot seed file  2363, 3435
DGN V8 input  460
DGN V8 output  511
dialog default file  92
DIAMETER_LARGE_CHARACTER_4D  3340
DIAMETER_SMALL_CHARACTER_4D  3340
dib  1135
digitize

2d strings  553
3d strings  554
4d strings  555
arc  557
circle  558

digitize.4d  3331
digitizer  543

buttons  560
defaults  550
register plan  546
resume plan  548
steps for digitizing  561
tolerance  551
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digitizer file  544
digitizers definition  562
DIGITIZERS_4D  3340
direction of string  99
directional pick  109
DISABLE_MTF_WARNINGS_4D  3340
distance_above_pit  1867
divide

distance between points  1071
number of points  1071

divide - dist  1071
divide - nos  1071
DONGLE_4D  3340
DOUBLE_CONFIRM_DELETE_4D  3340
download  1289
drafting  2291
dragging a menu  83
dragging a panel  93
dragging a view  97
Drainage

FAQ  1905
drainage  1792

programs
Win Des  1956

drainage annotations  297
drainage definitions  1793
drainage junction  1792
drainage network  1792
Drainage option  1789
Drainage plan plot ppf editor  2572
drainage plot ppf editor  2525
drainage ppf editor  2525
drainage quantities  1830
drainage string  100, 1789
drainage.4d  1793
DRAINAGE_4D  3340
DRAINAGE_FLOW_DIR_4D  3340
drainage_line_arrow_area  1861
drainage_line_arrow_colour  1861
drainage_line_arrow_gap  1861
drainage_line_arrow_mode  1861
drainage_line_arrow_post_text  1861
drainage_line_arrow_pre_text  1861
drainage_line_arrow_size  1861
drainage_line_arrow_text_colour  1861
drainage_line_arrow_text_offset  1861
drainage_line_arrow_text_size  1861
drainage_line_arrow_textstyle  1861
drainage_line_title  1861
drainage_line_title_offset  1861
drainage_line_title_text_colour  1861
drainage_line_title_text_size  1861
drainage_line_title_textstyle  1861
drainage_line_title_x  1861
drainage_line_y  1861
drainage_long_plot  1839
DRAINAGE_PPF_4D  1836, 3340
Drainage-Sewer option  1789

drape  1203
align  1203
alignment  1205
alignment (macro)  1207
strings  1203

draw tolerance  296
draw_box_mode  1848, 2409, 2457, 3459, 3499
draw_box_side_1  2413, 2460, 3459, 3499
draw_box_side_2  2413, 2460, 3459, 3499
draw_box_side_3  2461, 3499
draw_box_side_4  2413, 2461, 3459, 3500
draw_box_side_5  2413, 2461, 3460, 3500
draw_box_side_6  2413, 2461, 3460, 3500
draw_box_side_7  2413, 2461, 3460, 3500
draw_box_side_8  2413, 2461, 3460, 3500
draw_centre_chainage  1845
draw_commands  3371, 3372, 3381, 3387, 3388
draw_drainage_line  1861
draw_fs_mode  1846
draw_fs_text  1846
draw_fs_vertical  1851
draw_fs_vertical_mode  1851
draw_hgl_diag  1864
draw_hgl_value  1846
draw_house_connections  1870, 1894
draw_line_name  1866
draw_ns_text  1846
draw_pipe_attr_n  1862
draw_pipe_diameter  1858
draw_pipe_flow  1860
draw_pipe_grade  1857
draw_pipe_velocity  1859
draw_pit_name  1866
draw_pit_type  1866
draw_property_controls  1873, 1894
draw_text_at_pit  1866
draw_top_line  1865
drawing filter  240
drawing_number_postfix  1882, 1901, 2228, 3440, 3486,

3547
drawing_number_prefix  1882, 1901, 2228, 3440, 3486,

3547
drf  2263
drive  277, 320
drive along string  320
dump  255, 290, 314

screen  411
View  605

dumping a menu  83
dumping the panel  92
dumping the view  96
duplicate  2715
duplicate model  2715
duplicate string  1049
duplicate view  2715
DWG output  512
DWG/DXF input  462
DWT plot template file  2364
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DXF 12-14 output  531
DXF file  531
DXF input  490
DXF output  512, 534
dynamic pad  1719

E
E,N calc from ellip dist, plane brg  1457
Eagle binary models  541
Eagle binary output  541
eagle map file  541, 3415
Eagle output  539
eagle_plotter.emf  3426
eagleplt.pmf  2384, 3426
earth curvature and refraction correction  1295
ecw  1135
edges  204, 269
edit  131, 132

2d string  961
3d string  967
4d string  969
alignment  972
arc  995
circle  999
feature string  1004
MTF  1679
mtf  2832
pipe string  1004
polyline string  1006
super string  1010
text string  1035
vertical geometry  313

edit a chain  2656
edit a ppf  2365
edit AutoCAD output map file  427
edit boxing  1664
edit boxing file  1664
edit chain  2684
edit field data  1304, 1305
edit file  131
edit function  2659, 2681, 2684
edit info  959
edit label map file  423
edit macro  2671
edit map file  412
edit MTF  1679
edit mtf  1675, 2832
edit mtf file  1676
edit SuperTin  1169
edit tin  1166
edit tin function  1170
edit vertex  1043
editor  958, 2659

string  958
EDITOR_4D  3341
ellipsoid  3282
ellipsoid bearing  3291

Ellipsoid Distance  3288
Ellipsoid height  3284
email info to 12d  2825
end  2954, 2971, 2993, 3418
end arc fitting  1390
end area volumes  2241
end chainage  3560
end of line  1795
end_chainage  2220, 2393, 2451, 3523
Enter Ch Ht box  111, 960
enter chainage box  108
enter hip number box  108
enter relative vertex number box  109
enter vertex number box  108
enter vip number box  108
Enter X Y Z box  111, 960
entity-masks  412
env.4d  171, 343, 3331, 3341, 3351
environment variables  3338
ENVIRONMENT_4D  171, 3341
EOL  1795
error logging file  172
exact volumes  2263
exaggeration  268, 293, 302
Exit  403
exit  2827, 2828
explode  2716
explode text  2717
exported  104
extend  298, 1007, 1011
extend ht  1007, 1011
extend point  1040
extend point by ht  1040
external sides  1238
external triangles  1238
extra_model_n  2395, 3485
extra_model_tolerance_1  2395, 3485
EXTRA_OPTIONS_4D  3341
extra_space_bottom  2429, 2492, 3471, 3496
extra_space_left  2429, 2492, 3471, 3496
extra_space_right  2429, 2492, 3471, 3496
extra_space_top  2429, 2492, 3471, 3496
extra_space_units  2429, 2492, 3471, 3496
extra_text  2408, 3452
extra_text_angle  2408, 3452, 3467
extra_text_colour  2408, 3452, 3467
extra_text_decimals  3467
extra_text_draw_mode  2408, 3452, 3467
extra_text_justify  2408, 3452, 3467
extra_text_position  3452
extra_text_post_text  3467
extra_text_pre_text  3467
extra_text_size  2408, 3452, 3467
extra_text_textstyle  2408, 3452, 3467
extra_text_x  2408, 3452, 3467
extra_text_y  2408, 3452, 3467
eye  274
Eye/Target  271
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eye-point  3560
eye-target  319

F
f_surface_box_size  1845
faces  195, 264
Factor  244
factor  244, 1434, 2718
fast accept  106
fast contours  203, 268
fast pick  106
fast snap  120
FAST_ACCEPT_4D  3341
feature  1390
feature code  3086
feature string  100, 935
feature string edit  1004
fence  2685, 2686

multi  2689
multi stem  2691
stem  2687

fence stem  2687, 2691
fences  631
field codes  3086, 3136
field data

edit  1304, 1305
field file  1293, 1302
field templates  3095
file

screen layout  83, 92, 96
file box  131
file edit  431
file endings  149, 3413
file format

12d ascii  3299
4D ascii  3299
colours  3354
colours.4d  3354
defaults.4d  3355
digitize.4d - digitizer definitions  562
drainage definitions  1793
eagle map  3415
groupstyle  3371, 3374
gui colours  3357
gui.def  3357
linestyle  3371, 3374
paperstyle  3371
plotters  3429
plotters.4d  3429
screen colours  3357
set ups  3352
sheets.4d  3360, 3435
spirals.4d  3361
symbol  3387
templates  3416
worldstyle  3371, 3374
worldstyle symbol  3387

file panel field  131
files  2836
fill  1126
fill height  2881, 2929
fill height from link  2883
fill height modifier  2928, 2929
fill height to 2 strings  2888
fill height to string  2885
fill height to tin  2887
fill modifiers  2878
fill remove  2880
fill slope  2882, 2931
fill slope from link  2883
fill slope modifier  2930, 2931
fill slope to 2 strings  2888
fill slope to string  2885
fill slope to tin  2887
fill template  1617, 1618, 1621
fill tin slope modifier  2932
fill width  2881, 2927
fill width from link  2883
fill width modifier  2926, 2927
fill width to 2 strings  2888
fill width to string  2885
fillet  886, 1077

3 pts  1079
item item pt  1078
item item radius  1078

fillet (T)  1079
fillet (TJ)  1080
fillet and trim  1079
fillet, trim and join  1080
fills  1104
filter  2720

string  2720
vertices  2721
z  2724

final cut slope modifier  2932
final cut/fill  1617
final cut/fill template  1618, 1623
final fill slope modifier  2932
final modifiers  2891
final slope  2892
final width  2891
final width modifier  2932
finish  959
fit  190, 317, 319, 323
fit view  317, 319, 323
fixed  2848
fixed height  2852, 2923
fixed height from link  2855
fixed height to 2 strings  2860
fixed height to string  2857
fixed height to tin  2859
fixed slope  2971, 2975, 3417
fixed template  1617, 1618, 1620
fixed template links  1616
fixed width  2852, 2920, 2921
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fixed width from link  2855
fixed width to 2 strings  2860
fixed width to string  2857
fixed xfall  2853, 2924, 2971, 2973, 3417
fixed xfall crc  2854
fixed xfall from link  2855
fixed xfall to 2 strings  2860
fixed xfall to string  2857
fixed xfall to tin  2859
floating manhole  1811
floating menus  79, 81
flow arrows  204, 269, 1222
flow direction  1791, 1792
Flyout  85
focal distance  267
fonts  3395
fonts.4d  3331, 3395
FONTS_4D  3341, 3395
format

genio  465
frame  258, 2340
front distance  267
fs_decimals  1847
fs_text_colour  1847
fs_text_size  1847
fs_textstyle  1847
fs_title_colour  1847
fs_title_text_size  1847
fs_title_textstyle  1847
fs_vertical_colour  1851
fs_vertical_decimals  1851
fs_vertical_post_text  1851
fs_vertical_pre_text  1851
fs_vertical_size  1851
fs_vertical_textstyle  1851
fs_vertical_x  1851
fs_vertical_y  1851
function

delete  2664
editor  2659
order  2660
recalc  2661
rename  2661
report  2603
save  2663
tin  1165, 1170

function keys  3397
FUNCTION_KEYS_4D  3341
functions  2659

recalc  2680

G
GDA  3281, 3560
GDA 94  3283
GDA94  3560
genio format  465
genio input  467

genio output  517
genio v3.1 output  537
GENIO_WILDCARD_4D  3341
Geocentric Datum of Australia  3283
Geocomp format  471
Geocomp input  474
geocomp output  526
Geodesy  3282
Geodetic Datum  3284
Geodimeter  3161, 3211
Geodimeter Roadline 3d  1572
Geodometer  3107
Geoid  3282
geometry annotation  298
GIF  1135
global_textstyle  1883, 1887, 1902, 2392, 2450
goto  2971, 2990, 3418
GPS  3209, 3560
Grade  301
grade  3560
grade annotation  301
grade_change_only  2431, 3473
grade_colour  2431, 3473
grade_decimals  2219, 2431, 3473
grade_label  2431, 3473
grade_minimum_width  2431, 3473
grade_mode  2431, 3474
grade_offset  2431, 3473
grade_signed  3473
grade_size  2431, 3473
grade_text_colour  2219
grade_text_size  2219
grade_textstyle  2219, 2431, 3473
grade_threshold  2431, 3474
grade_threshold_mode  2432, 3474
grade_title_text_colour  2219
grade_title_text_size  2219
grade_title_textstyle  2219
grade_upper_decimals  2432, 3474
grade_upper_mode  2432, 3474
graph area  1864
greyed panel field  89
Grid  237
grid  237, 2726
grid a tin  1250
grid bearing  3291
grid distance  3291
grid snap  118, 2640
group  3372, 3387
groupstyle  3368, 3380
GRS80  356, 3560
gui.4d  3331
gui.def  3357
GUI_4D  3341
GUI_COLOURS_4D  3341
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H
h_g_n_colour  2500, 3528
h_g_n_draw_mode  2499, 3528
h_g_n_gap  2500, 3528
h_g_n_height  2500, 3528
h_g_n_label_offset  2499, 3528
h_g_n_label_text  2499, 3528
h_g_n_label_text_colour  2499, 3528
h_g_n_label_text_size  2499, 3528
h_g_n_label_textstyle  2499, 3528
h_g_n_label_x  2499, 3528
h_g_n_label_y  2498, 3528
h_g_n_no_decimals  2501, 3529
h_g_n_offset_string  2498, 2499, 3529
h_g_n_post_text  2501, 3528
h_g_n_pre_text  2501, 3528
h_g_n_rotate  2501, 3529
h_g_n_text_colour  2500, 3528
h_g_n_text_offset  2501, 3528
h_g_n_text_size  2500, 3528
h_g_n_textstyle  2501, 3528
h_g_n_type  2498, 3527
h_g_n_value_mode  2498, 3527
h_g_text_colour  2216
h_g_text_size  2216
h_g_textstyle  2216
hardware arcs  2361, 3435
HARDWARE_ARCS_4D  3341
hatch_cut_angle_n  1877, 1896, 2222, 3484, 3538
hatch_cut_colour_n  1877, 1896, 2222, 3484, 3538
hatch_cut_draw_new_n  1877, 1896, 2222, 3484, 3538
hatch_cut_draw_original_n  1877, 1896, 2222, 3484,

3538
hatch_cut_draw_sides_n  1877, 1896, 2222, 3484, 3538
hatch_cut_linestyle_n  1877, 1896, 2222, 3484, 3538
hatch_cut_separation_n  1877, 1896, 2222, 3484, 3538
hatch_fill_angle_n  1877, 1896, 2222, 3484, 3538
hatch_fill_colour_n  1877, 1896, 2222, 3484, 3538
hatch_fill_draw_new_n  1877, 1896, 2222, 3484, 3538
hatch_fill_draw_original_n  1877, 1896, 2222, 3484,

3538
hatch_fill_draw_sides_n  1877, 1896, 2222, 3484, 3538
hatch_fill_linestyle_n  1877, 1896, 2222, 3484, 3538
hatch_fill_separation_n  1877, 1896, 2222, 3484, 3538
hatch_new_tin_n  1877, 1896, 2222, 3484, 3538
hatch_original_tin_n  1877, 1896, 2222, 3484, 3538
head to tail  2728
height  1109, 2730, 2839, 2852, 2868, 2881

by plan  980
by section  981

height adjustment  1420
height from link  2855, 2870, 2883
height inquire  1232
height modifier  2839, 2916, 2921, 2923
height range file  2286
height scale factor  3288
height snap  119

height to 2 strings  2860, 2875, 2888
height to string  2841, 2857, 2872, 2885
height to tin  2859, 2874, 2887
HEIGHT_MAX_DEFAULT_4D  3341
height_mode_cl  2427, 3454
height_text  2427, 3454
helix  3094
Helmert transformation  2731
helmert transformation  3561
HELP_4D  3342
HELP_BUTTONS_4D  3342
hgl_box_size  1845
hgl_colour  1864
hgl_decimals  1847
hgl_text_colour  1847
hgl_text_size  1847
hgl_textstyle  1847
hgl_title_colour  1847
hgl_title_text_size  1847
hgl_title_textstyle  1847
hidden line  3561
hidden perspective view  79
hide  265
HIMETRIC_4D  3342
hinge  2837
hinge comment  2844
hinge modifier  2837
hinge modifiers  2831
hinge point  1638, 1644, 2837
hinge string  1633, 2831, 2837
HIP  3561
Historical Water Levels  2194
HOME_4D  3342
horizontal alignment  3561
horizontal scale  2368, 2371
horizontal_geometry_arrow_colour  2497, 3527
horizontal_geometry_arrow_height  2497, 3527
horizontal_geometry_arrow_text_colour  2497, 3527
horizontal_geometry_arrow_text_size  2497, 3527
horizontal_geometry_arrow_textstyle  2497, 3527
horizontal_geometry_label_decimals  2497, 3527
horizontal_geometry_label_text  2497, 3527
horizontal_geometry_label_text_colour  2497, 3527
horizontal_geometry_label_text_size  2497, 3527
horizontal_geometry_label_textstyle  2497, 3527
horizontal_geometry_y  2497, 3527
horizontal_line_spacing  2412, 2459, 3458, 3498
horizontal_plot_gap  1841, 1887, 2213
horizontal_text_gap  1852, 1889, 2215
house connection  1826

type A  1799
type A Special  1799
type B  1800
type C  1800
type OB (oblique)  1801
type Special Jump Up  1801

house_connection_il_mode  1872
house_connection_mode  1871
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house_connection_width  1870, 1894
houses  632
HP plot  489
hrf  2286

I
IGDS file  508
il_decimals  1847, 2219
il_text_colour  1847, 2219
il_text_size  1847, 2219
il_textstyle  1847, 2219
il_title_colour  1847
il_title_text_colour  2219
il_title_text_size  1847, 2219
il_title_textstyle  1847, 2219
imported  103
include  2939, 3557
index contours  1186
index cotours  1186
Info  959
info  2206
info snap  118, 120, 2640, 2642
input

12d ascii  436, 481
BCC Epson  450
CivilCad  452
DGN  457, 458, 460, 511
DWG/DXF  462
DXF  490
genio  467
Geocomp  474
Keays  476
LandXML  479, 521
template  1628
TP Setout  486, 488
typed  90
xyz general  446
xyzs  441
xyzs pt_no  443

input box
Manhole type  1810

input DGN  456
input map file  440, 452, 465, 472
input templates  409
inquire  1085, 2735

aspect  1227
colour  1229
depth between tins  1230
depth from height to tin  1229
depth from string to tin  1230
slope  1232
tin  1227
tin colour  1229
tin height inquire  1232

ins 3 pt curve  1008, 1033
insert  2849

plot frame seed  2349

insert 3pt curve  1042
insert cut  2865
insert fill  2878
insert point  1041
insert three point curve  1008, 1033
inside  2691
interface  1657
interface colours  2363, 3436
interface function  1657
interface string  100, 1656
Intergraph seed file  508, 512
intersect  1073

bearings  1074
offset  1073

intersect offset  1073
intersection  1072
intersection point (IP)  3561
inverse flattening  3282
invert  3561
invert_depth_box_size  1845
invert_height_box_size  1845
invisible  1391
invisible next segment  1392
invisible previous segment  1391
IP  3561
ISG  1438, 3283, 3561
isopachs  1192

J
join many strings  1052
join string  1400
join strings  1051
joy  273, 319
jpeg  1135
JPEG 2000  1135
jpg  1135
junction  1792
junction_angle_post_text  1869
junction_angle_pre_text  1869
junction_angle_text_colour  1869
junction_angle_text_size  1869, 1893
junction_angle_textstyle  1869
junction_name_mode  1869
junction_post_text  1869
junction_pre_text  1869
junction_text_colour  1869
junction_text_size  1869
junction_textstyle  1869

K
Keays input  476
kerb return  1653, 1654
keys  412
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L
label  2971, 2990, 3417
label chainages  1122
label contours  1194
label cut  1126
label cut/fill symbols  1129
label cut/fill ticks  1127
label map file  423
label names  1131
label string  1122
label vertices  1132
label_depths  2466
label_first_only  2411, 3459
label_manhole_type  1893
label_n_angle  2510, 3536
label_n_colour  2510, 3536
label_n_justification  2510, 3536
label_n_mid_text  2511, 3536
label_n_no_decimals_1  2511, 3536
label_n_no_decimals_2  2511, 3536
label_n_offset  2510, 3536
label_n_post_text  2511, 3536
label_n_pre_text  2511, 3536
label_n_size  2510, 3536
label_n_textstyle  2510, 3536
label_n_type  2509, 3536
label_n_value_mode  2510, 3536
label_n_x  2510, 3536
label_n_y  2509, 2512, 3536
label_n_y_mode  2509, 3536
label_pipe_type  1890
label_type  2393, 2408, 3447, 3457
Lambert Conformal Conic Projection  358
LandXML input  479, 521
Latitude  3284
latitude  1433, 2697
layout input  406
layout output  407
layout.4d  3331
least square adjustment  1408, 1425, 1493, 1495, 1497,

1504
least square network  1408
least squares adjustment  1408
left side  2833, 2913
left side modifier  2846
left side template modifiers  2847
left_border_gap  2397, 2453, 3442, 3495
left_extension  2396, 3445, 3471, 3473
left_margin  1840, 2212, 2213, 2398, 2454, 3442, 3494
left_side  2913
left_sub_plot_gap  2399, 3443
Leica  3224
Leica LandXML  1588
Leica roadplus 16  1574
Leica roadplus 8  1574
length  137, 140, 3369, 3385

string  2604

level network  1417
lib  131
LIB_4D  3342
library  3413

user  3413
line  2953
line scale factor  3294
line snap  118, 2640
line string  102
line strings  101
line style

continuous mode  3371
length  3369, 3385
origin  3368, 3385
vertex mode  3371

line style group  3372, 3387
line style mode  3372
line styles  3367, 3368
line_colour  2215
line_up_cl  2396, 3445
linear regression  1554
linestyl.4d  3331, 3370
linestyle  101, 102, 3368, 3371

continuous mode  3367
groupstyle  3368, 3380
vertex mode  3367
worldstyle  3371

linestyle darw commands  3381
linestyle draw commands  3371, 3387
linestyle set_up commands  3372, 3387
linestyles  195
LINESTYLES_4D  3342
link clip string  1053
link delete  1053
links  99
list

Models to Add  184, 316, 318, 321
Models to Remove  316, 319, 322

view  186
Tin Models to Add  186

LIST_POPUPS_4D  3342
lists  90
lmf file  423
locate  1076
locate chainage  1072
locate deflection  1070
locate offset  1069
lock

function  2660
LOG_DIR_4D  3342
long plot ppf editor  2449
long section along a string  1269
Long section plot

many  2372
long section ppf editor  2449
LONG_SECTION_PPF_4D  3343
Longitude  3284
longitude  1433, 2697
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Longitude, latitude from grid coordinates  1464
longsection plot  310, 2369

Melbourne Water  1884
LOOK3D_4D  3342
loop removal  1149
lot checks  1504
lot controls  1817

M
macro  2667

compile  2667
run  2669, 2672
version  2672

MACRO_INPUT_MODE  3343
macros.4d  3331
Main menu  79
manhole_angle_text_size  1893
manhole_line_colour  1850, 1889, 1893
manhole_symbol_colour  1893
manhole_symbol_n_angle  1870, 1895
manhole_symbol_n_colour  1870, 1895
manhole_symbol_n_mode  1870, 1895
manhole_symbol_n_position  1870, 1895
manhole_symbol_n_size  1870, 1895
manhole_symbol_n_style  1870, 1895
manhole_symbol_n_type  1870, 1895
manhole_symbol_n_x  1870, 1895
manhole_symbol_n_y  1870, 1895
manhole_symbol_repeats  1893
manhole_symbol_size  1893
manhole_symbol_y_offset  1893
manual_datum  2490, 3549
many pans  246
many pans delta  246, 247
many template file  1673
many template variables  2939
many templates file  1643, 1651, 2831, 2846
map  2736
map file  412

create/edit  412, 423
DGN  510
DXF output  516, 533, 536
Eagle  539
Eagle binary output  541
input  440, 452, 465, 472

Map Grid of Australia  357, 3283
MapInfo MID/MIF file  522
mapping colours to pens  2356, 2358
mask_name_n  2421, 3468
match  1121
mathematical angle  3559
maximizing a panel  93
measure  2674

at point  136
point to point  136
string from point  138
string to point  139

measure point  136
measure point to point  137
measure string from point  138
measure string to point  140
measure value  2678
measures  2678
meaures  2678
Melbourne Water  1884
Melbourne Water ppf editor  2568
menu  82

12d Model  85, 402, 403
2d edit  951, 958, 961
2d super edit  870
3d edit  953, 967
3d super edit  873, 875
4d append  969
4d edit  955, 969
4D Solutions  402
7 Parameter Setting  366
Add model  184
alignment edit  878, 972
alignment utilities  986, 2205
append  973
arc edit  917, 995
Attributes  230
Billboard  614, 624
Boxing  2899
boxing  2898, 2899
CAD  642
CAD arcs  721
CAD change points  822
CAD change strings  842
CAD cirlces  706
CAD fills  799, 802
CAD holes  796
CAD intersect  694
CAD lines  678
CAD modify  810
CAD Points  644, 864
CAD polygons  743
CAD segment edits  837
CAD symbol  779
CAD text  755
circle edit  999
cogo edit ops  1067
Connections  1821
Controls  1817
convert ops  2703
convert string to  1082
Create  2838, 2847, 2905, 2948
create  2645
create (for hinge modifiers)  2838
Create (for template modifiers)  2848, 2906, 2949
create arcs  914
create circles  929
create ops  1068
create reduction  1292
Create Rule  2971
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Create rule  2972
curves  2205
cut  2865
cut/fill marks  1126
cuts  2710
decision  2863
delete  84
delete all templates  1631
design  1615
digitizer buttons  560
digitizer capture  552
digitizer defaults  550
digitizer menu  543
digitizer setups  545
directory *.4dm  2671
directory *.bf  1664, 1665, 1675
directory *.mtf  1676, 1677
divide  2645
drafting  2291
dragging  83
Drainage  1789
Drainage Defaults  1794
Drainage Edit  1802, 1804
Drainage Network Plots  1836
drainage reports  1830
Drainage Utilities  1828
dumping  83
edit reduction  1303
edit sdr  1303
edits  1804
end area volumes  2241
errors  992
estate/lots  1683
exact volumes  2263
feature edit  936, 1004
fence  2685
file i/o  405
fill  2878
fillet  2645
fillet ops  1078
filter  2720
final  2891
fixed  2848
floating  81
function adds  2661
function auto  2680
function deletes  2664
function saves  2663
functions  2659
functions report  2603
height  980
help  2813
ILSAX editors  1972
Information  1085
information  106, 1085
intersect  2645
intersect ops  1072
locate  2645

macros  2667
Main  81
Manhole  1809
measure ops  2674
Measure Point  136
Measure Point to Point  137
Measure String from Point  138
Measure String to Point  140
measures  121, 135, 2678
model adds  579
model deletes  595
Model Ops  183
model removes  583
model saves  585
model text  199
model utilities  578
models  569, 570
models to add  1170
modifiers  2847
more design  1784, 1788
more drainage  1903
more plot frames  2347
more roads  1750
moving  83
mtf  1673
MTF Edit  2832
MTF edit  2896
mtf edit  1674, 1675, 1676, 2832, 2835, 2898, 2902
nd edit  958
null heights ops  2738
old plotting  2365
ortho 12d  1788
output  493
Overlay  1717, 1763
pan ops  246
Panel System  92
parabolas  2205
Pick Ops  111
pick ops  107
Pipe  1814
pipe edit  938, 1004
pipeline  2199
pipeline defaults  2207
pipeline edit  2200, 2202
pipeline plots  2208
pipeline reports  2230
pipeline utilities  2206
plan string names for plan view  188, 226
plot and ppf editors  2339, 2351
plot frames  2340
plot ops  2339
point/vertex id’s  213
points edit  1038
Polygon  2805
polyline append  1006
polyline edit  941, 1006
polyline utilities  1008
pop-up  90, 125
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profiling  303, 322
Project Details  329
Project Management  332
Project N values  360
Project Projections  354
Project Workspace  369
Project Workspace Load  370
projects  325, 398
Properties  1090
Rasters  1134
recalc  2661
Recalc Chains  2647
recalcs  2680
Rivers  2121
roads  1726, 1728
run chain  2684
SDR Code Edits  1306
SDR Point Edits  1387
SDR String Edits  1398
SDR String Ordering  1385
SDR Target Edits  1404
select textdat  127
setout  1558
set-out report  2605
shared tins  1277
sharing  587
snap modes  117
snaps  2640
snaps (horz)  2646
snaps (vert)  2644
snaps cogo  2645
snaps ops  2640
sort  572, 573
special chainages  2835
String Create Old  949
string create ops  867
string drive  277, 281, 285
string labelling  1122
string movie  285
string names  226
string ops  637
string reports  2595
string utilities  1146
string walk  281
Strings  2905
strings edit  1045
Super Append  1010
Super Edit  945, 1010
Super Segment  1022
super string utilities  1033
super strings  1096
Super Vertex  1011
survey  1287
survey adjustments  1407
survey conformance  1519
survey conversions  1429
survey extras  1541
tear away  81

template adds  1627
template boxing  1661
template deletes  1631
template functions  1634
template list  1617, 1618
template output  410
template removes  1628
template saves  1630
template utilities  1627
templates  2833
text and tables  2313
text edit  948, 1035
tin adds  1246
tin analysis  1211
tin aspect  1211
tin colouring  1176
tin contours  1185
tin create  1161, 1166
tin deletes  1284
Tin DEMs  1254
tin drape  1203
tin inquire  1227
tin list  1156
tin null  1233
tin removes  1260
tin saves  1262
tin sections  1269
tin settings  203, 268
tin slope  1215
tin utilities  1245
toggle  317, 319, 322, 323

perspective view  263
plan view  194
section view  295

traverse spreadsheet  1453, 1493
triangle ops  1155
Update z-values from tin  1210
User  2755, 2757, 3402
user  3348
utilities  2637
utilities (4d)  970
utilities A-G  2637
utilities H-Z  2637
vector  1075
vehicle path  1743
Vertices  208
View  97, 182, 183, 315, 316, 318, 321
view  315, 599

plan view  192
section view  293

View Create  603
view ops

perspective view  262
view plotting  317, 320, 323

section view  308
view settings

perspective view  262
plan view  192
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section view  294
view utilities  253, 277, 312, 1146
visualisation  611
Visualise Utilities  633
volumes  2240
walk-right  83
window  2811
X-Sections  1771
zoom ops  242, 243

menu map  3362
menu title area  82
menuview system  95
mesh  206, 269, 1271
meun

alignments  876
Super Alignments  890

mf file  412
mft shift  2910
MGA  1438, 3283, 3561
MGA zone  357
MGA94  3561
Microstation plot seed file  3435
MID/MIF file  522
MIDDLE_DOT_CHARACTER_4D  3343
minimizing a panel  93
minimizing a view  97
mode  3372
model  102, 569

add  184
clean  594
create  574
delete  595
global rename  576
remove  186
rename  574
save  585

model attributes  578
model field  132
model info  570
model info table  572
model order  188
model panel field  132
model sharing  587
model snap  2641
model strings  304
MODEL_FOR_TIN_PREFIX_4D  3343
model_of_frames  2587, 3439
model_to_plot  2393, 3442
MODEL_VIEW_WALKRIGHTS_4D  3343
models

add all  185
project  570
remove all  186
removed  570

models to back  189
models to front  189
models transfer  610
modifier

cross fall  2923
cross fall crc  2924
cut height  2928
cut height from link  2929
cut slope from link  2931
cut tin slope  2932
cut width  2926
cut width from link  2927
fill height  2928
fill height from link  2929
fill slope from link  2931
fill tin height  2931
fill tin slope  2932
fill width  2926
fill width from link  2927
height  2921
height from link  2923
string  2903
tin cut height  2931
tin cut slope  2932
tin fill slope  2932
tin height  2925, 2931
tin xfall  2925
width  2920
width from link  2921
xfall  2923
xfall crc  2924
xfall from link  2924

modifiers  2847
mouse  77
mouse buttons

LB  77
left  77
MB  77
middle  77
RB  77
right  77

move point  1041
move string  1058
movie  285, 288
MOVIE_4D  3343
moving a menu  83
moving a panel  93
moving a view  97
MS_SEEDFILES_4D  3343
mtf  1643, 1673

change decision  2863
comment  2844
cut height  2868
cut height from link  2870
cut height to 2 strings  2875
cut height to string  2872
cut height to tin  2874
cut remove  2867
cut slope  2869
cut slope from link  2870
cut slope to 2 strings  2875
cut slope to string  2872
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cut slope to tin  2874
cut width  2868
cut width from link  2870
cut width to 2 strings  2875
cut width to string  2872
fill height  2881
fill height from link  2883
fill height to 2 strings  2888
fill height to string  2885
fill height to tin  2887
fill remove  2880
fill slope  2882
fill slope from link  2883
fill slope to 2 strings  2888
fill slope to string  2885
fill slope to tin  2887
fill width  2881
fill width from link  2883
fill width to 2 strings  2888
fill width to string  2885
final cut slope  2892
final fill slope  2892
final width  2891
fixed height  2852
fixed height from link  2855
fixed height to 2 strings  2860
fixed height to string  2857
fixed tin height  2859
fixed tin xfall  2859
fixed width  2852
fixed width from link  2855
fixed width to 2 strings  2860
fixed width to string  2857
fixed xfall  2853
fixed xfall crc  2854
fixed xfall from link  2855
fixed xfall to 2 strings  2860
fixed xfall to string  2857
hinge coord to string  2842
hinge height  2839
hinge height to string  2841
hinge offset  2838
hinge offset to string  2840
insert  2849
insert cut  2865
insert fill  2878
no final cur and fill slope  2894
no final cut/fill slope  2894
no final fill slope  2894
no hinge  2843
remove  2851
specials  2835

mtf copy  1680, 1681
mtf create  1673
mtf edit  1675
mtf file  2831
mtf rename  1678
MTF_TMP_4D  3343

multi-fence  2689
multi-fence stem  2691

N
N value.  3285
name  102
name completion  91
name mapping  91, 377
name mapping file  91, 377
name snap  2641
NAME_MAPPINGS_4D  3343
named measurement  3137
names  226
names report  2598
names.4d  92, 3331
nd edit menu  958
network quantities  1830
network_model  1841, 1883, 1887, 1902, 2213
NEVER_SNAP_ITSELF_4D  3344
new view  253, 312
NEW_DRAINAGE_MELB_PPF_4D  3344
NEW_DRAINAGE_PLAN_PPF_4D  3344
NEW_DRAINAGE_PPF_4D  3344
NEW_LONG_SECTION_PPF_4D  3344
NEW_PLOT_FRAME_PPF_4D  3344
NEW_X_SECTION_PPF_4D  3344
Nikon  3107
no final cut slope  2894
no final fill slope  2894
no final slope  2894
no hinge  2843
No Option  82
nohinge modifier  2843, 2917
non tinable  1392
non tinable next segment  1393
non tinable previous segment  1393
Non-projection to projection coordinate conversion

1467
ns_decimals  1847, 2218
ns_text_colour  1846, 2218
ns_text_size  1846, 2218
ns_textstyle  1847, 2218
ns_title_colour  1846
ns_title_text_colour  2218
ns_title_text_size  1846, 2218
ns_title_textstyle  1846, 2218
NTv2  3561
null  1234, 2738
null exclude  1233
null height range  2740
null heights  2738
null include  1233
null tin by centroids  1239
null tin by picking  1242
null tin by polygons  1242
null tin by strings  1241
null to height  2741
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null triangles by angle and length  1238
null triangles by length  1236
Null Value  3561
null value  435, 494
nulling  1233
nulling triangles  1233
number_of_blank_boxes  2458, 3497
number_of_decimals  1846, 2412, 2459, 3454, 3458,

3498
NZ 2000  1443
NZ 49  1443
NZ conversions  1436
NZ TSS report  1509

O
obvert  3561
offset  2838
Offset code delimiter  3112
offset modifier  2838, 2915
offset to string  2840
offset_colour  2416, 3458, 3462
offset_height_side_cl  2427, 3454
offset_height_text_justification_cl  2427, 3454
offset_insert_zero  2409
offset_label_tolerance  2420, 3468
offset_mode_cl  2427, 3454
offset_model  2469
offset_n_colour  2471, 3506
offset_n_decimals  2471, 3506
offset_n_depth_colour  2472, 3507
offset_n_depth_decimals  2472, 3506
offset_n_depth_label  2471, 3506
offset_n_depth_textstyle  2472, 3506
offset_n_depth_title  2471, 3506
offset_n_depth_title_2  2471, 3506
offset_n_depth_title_colour  2471, 3506
offset_n_depth_title_size  2471, 3506
offset_n_depth_title_textstyle  2471, 3506
offset_n_depth_title_y_pos  2471, 3506
offset_n_depth_y_pos  2472, 3507
offset_n_draw_colour  2470, 3506
offset_n_draw_mode  2469, 3505
offset_n_label  2470, 3506
offset_n_lw  2469, 3505
offset_n_mask  2469, 3505
offset_n_rw  2470, 3506
offset_n_size  2471, 2472, 3506, 3507
offset_n_textstyle  2471, 3506
offset_n_title  2470, 3506
offset_n_title_2  2470, 3506
offset_n_title_colour  2470, 3506
offset_n_title_size  2470, 3506
offset_n_title_textstyle  2470, 3506
offset_n_title_y_pos  2470, 3506
offset_n_y_pos  2471, 3506
offset_size  2416, 3462
offset_textstyle  2416, 3458, 3462

offset_title  2415, 3454, 3462
offset_title_2  2416, 3462
offset_title_colour  2416, 3462
offset_title_mode  2470, 3506
offset_title_size  2416, 3462
offset_title_textstyle  2416, 3462
offset_x_cl  2427, 3455
offset_y_cl  2427, 3455
on grade  1556
only_one_line  1841, 1887, 2213
op code  3136
open string  1054
operation code  3136
optimal overlay  1770
option chain command  2652
optional panel field  89
orbit  275
order  1385
order functions  2660
origin  3368, 3385
output

12d ascii  495
civilcad  524
DGN  508
DWG  512
DXF  512, 531, 534
Eagle  539
Eagle binary  541
genio  517
geocomp  526
template  1628
xyz general  505
xyzch  501
xyzs  498, 499

output map file
DXF  516, 533, 536

output templates  410
Output Window  79, 98
outside  2691
overlay  1763, 1770

P
pad

dynamic  1719
pagination  2455, 3494
pagination_length  2456, 3494
pagination_mode  2455, 3494
pagination_overlap  2456, 3494
pan  245, 246, 317, 323
pan delta  246
PAN_MODE_4D  3344
pane

Create/Edit Chain  2655, 2656
write DXF 12-14 file for  531

Panel
Survey Upload  1566

paneL
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Defaults  144
panel  89

12d Model information  2823, 2825
2d edit info  951, 958, 961
2d String Properties  965
3 centred curve construction  882
3d edit info  953, 967
3d String Properties  968
3D Tree Insertion - Faces  621
4d edit info  955, 969
4d String Properties  970
ADAC Reader Panel  1595
add all functions to project  2661
add all templates to project  1628
add all tins to project  1246
add breakline  1173
Add Model to a View  185
add model to a view  581
add model to the project  580
Add Models to View by Pick  316, 318, 321
add models to view by pick  324
Add Shared Models to Project  588
Add Shared Tins to Project  1278
add template to the project  1627
add tin to a model  1247
add tin to the project  1246
Add/Modify Seven Parameter Details  366
Additional Text for Point  1383
Adjustment of Level Nets  1417
Affine Transformation of  2693, 2694
agd66/84  gda94  1438
alignment edit info  879, 972
Alignment String Properties  994, 998
Amend VG  1658
append point  1038
apply boxing  1666
apply kerb return function  1654
Apply Many Boxing  1667
Apply Template Defaults  1635
Apply Template Function  1637
Apply Templates Defaults  1635
Apply Templates Function  1643, 2831
arc - 3 points on arc  923
arc - centre, start and end points  919
arc - centre, start point and sweep angle  918
arc - radius, centre, start and end points  921
arc - start pt, radius, arc length, chord bear  927
arc - start pt, radius, arc length, start bear  925
Arc Centres for Plan View  235
arc edit info  917, 995
arc fitting  1323
arc to chords  1061
ArcView mapping  496
Aspect Analysis  1212
Aspect Analysis 2  1213
Aspect Analysis Colour  1183
Attachment  1326
attributes  1326

Attributes for Plan View  230
Attributes Table for Plan View  232
Ausgeoid98 *.dat -> xyz  1542
Australian conversions  1430
auto recalc mode for a function  2681
auto recalc mode for all functions  2681
Autocad Export Map File Create/Edit  427
AutoCAD Plot Map File Create/Edit  2362
AutoCAD plotter drawing template file  2364
Autopan Perspective View from Section View  251
Autopan Plan View from Plan View  248
Autopan Plan View from Section View  250
Autopan Section View from Plan View  248
Autopan Section View from Section View  250
backsight  1328
backsight reference  1330
balances volumes  2280
Batter  2988
Batter Decision  2985
Batter Slope Conformance Report  1522
Bearing and distance (GDA94/AGD66-84)  1461
Bearing/Distance Entry  1543
Bearing/distance label  1471
Bearing/Distance Traverse/Radiation Entry  1546
between point  1039
boxing copy  2949
boxing end  2954
boxing file  2899
Boxing LHS Xfall  2955
boxing line  2953
Boxing Many  1669
Boxing RHS Xfall  2956
Boxing Rules  2946
boxing rules  1662, 2946, 2955, 2956
boxing xfall  2950
Boxing Xfall 1  2952
breakline string  1375
buildings  1331
Cad Array  813
cad insert plan image  803
CAD Polyline to Alignment Convert  2708
capture  552
cartographic  1434
catenary measurements  1548
Ceate Polygon - Pick Point Inside  1065, 1690
centreline profile on section  307
chainage at point on string  1146
chainage insert VIP  988
change contours  1197
Change Library Extrude  626
Change Polygon Drape  611
change project  326
Change Radius  1807
change radius  1007
change string  1046
Change String Chainage  2700
change string chainage  2701
change string info  2698
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Change Super Alignment style  911
Change Super String Attributes  1111
Change Super String Billboard  616
change super string chainage interval  1097
change super string filling  1104
Change Super String Height  1109
Change Super String Pipe/Culvert  1115
Change Super String Segment Colour  1108
Change Super String Symbols  1106
Change Super String Text  1119
Change Super String Vertex Id  1113
change super string visibility  1099, 1101, 1102
change text info  2749
change textstyle info  1061
Check As Built String vs Design String  2616
Check Breklines for  1159
check control model  1552
check measurement  1300, 1333
check points  328
Check Strings  2701
circle - 3 points on circle  934
circle - centre point, point on circle  932
circle - centre point, radius  930
circle alignment construction  884
circle edit info  999
Circle String Properties  1002
clean model  594
clip string  1046
clipping planes for view  267
close string  1048
cogo edit  1067
colour analysis  1225
Colour Contours  1199
colour depth range for tins  1182
colour height range for tin  1180
colour triangles by polygons  1178
colours to pens  2384, 3331
Comment  2992
comment  1335
compile a macro  2667
compile Leica Field 12d coding file  1593
compile/run a macro  2669
contour a tin  1190
contour, smooth and label a tin  1200
Convert 2d to 3d Strings in  2704
Convert 3d to 2d Strings in  2705
Convert 4d to 3d Strings in  2706, 2709
Convert String  1082
Convert String Types  2703
convert text strings to 3d strings  2707
coordinate  1335
Copy an MTF  1680
copy project  327
copy project model  582
copy project tin  1249
copy template  1625
corner splays  1064, 1065
Create - Group Extrusions  629

create 2d string  950
create 3d string  952, 953
Create 3d Super String  872
create 4d string  954, 955
Create 4d Super String  874
create alignment string  878
Create and Place Billboards  614
create arc string  915
Create Boundaries for Tin  1175
create boxing file  1661, 1662
create boxing file *.bf  1663
Create Control Station  1551
Create Cut/Fill Text within Polygon  2288
Create Drainage String  1802
create drainage string  3340
Create Drainage Strings  1794
create feature string  935
Create Forest  618, 619
create instrument points upload  1570
Create Lot - Pick Point Inside  1690
create macro file *.4dm  2670
create model  574
Create MTF File  2831
create mtf file  1673, 1674
create mtf file *.mtf  1674
create pipe string  937, 938
create pipeline string  2200
create plot frame seed  2350
create plot frames along string  2348
create plotter mapping file  2356
create points upload  1584
create polyline string  940, 941, 945
Create Project  398
create raster element  1134
Create Raster from Plan View  259
Create Rasters from ECW Files  1138
Create Rasters from TAB Files  1139
Create Road Upload file  1586
Create Roading Upload File  1572
create same as  957
Create Super 2d String  869
create super alignment  892
Create Super String  943
create super tin  1164
create text string  947, 948
create traverse spreadsheet  1495
create triangle upload file  1567
Create World Grid  2300, 2726
Create Z-Values from String to Tin Differences

1268
Create Z-Values from Tin Differences  1267
Create/Edit Chain  2648
Create/Edit N value settings  361
Create/Edit Projection  355
Create/Edit Textstyle  392, 3392, 3393
Crosses at String Vertices for Plan View  208
Crosses at String Vertices Table for Plan View  210
Culdesac Alignment Creation  880
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culling perspective view  264
culling plan view  194
Culvert  1378
cut height  2868
cut height from link  2870
cut height to 2 strings  2875
cut height to string  2872
cut height to tin  2874
cut insert  2865
cut remove  2867
cut slope  2869
cut slope from link  2870
cut slope to 2 strings  2875
cut slope to string  2872
cut slope to tin  2874
cut width  2868
cut width from link  2870
cut width to 2 strings  2875
cut width to string  2872
Cuts from CL for  2712
Cuts Through  2711
decision change  2863
Decisions Template  2970
Default House Connections  1821
default raster DPI  2364
Defaults  148
defaults  3331
define station coordinate  1298
delete  93, 2714
delete 3pt curve  1042
Delete a Chain  2658
delete all functions  2664
delete all models  596
delete all tins  1285
Delete an MTF  1681
delete empty models  596
delete function  2664
Delete Many Functions  2666
delete model  595
Delete N value setting  364
delete point  1039
delete project  401
Delete Projection  358
Delete Seven Parameter Details  367
delete string  1049
delete template  1631
delete tin  1284
Delete View  608
delete view  191
depth between tins inquire  1230
Depth Contours  1192
depth from height to tin inquire  1229
depth from string to tin inquire  1230
depth string  1147
Dereference Super Alignment  904
DGN plot seed file  2363
digitize 2d string  553, 554
digitize 3d string  554

digitize 4d string  555
digitize arc  557
digitize circle  558
digitizer capture defaults  550
digitizer register plan  546, 547, 548
digitizer resume  548
digitizer selection  545
digitizer tolerance defaults  551
drag  93
draiange plan plot ppf editor  2572
Drainage Annotations  297
Drainage Edit Info  1802
Drainage House Connection Basic Defaults  1823
Drainage House Connection Defaults  1798
Drainage Manhole Defaults  1794
Drainage Pipes Defaults  1795
drainage plot ppf editor  2525, 2568
drainage plot title  1837
Drainage Property Control Defaults  1796
drainage quantities  1830
Drainage String Properties  1829
Drainage Tin Defaults  1794
drape  1203
drape alignment  1207
Drape Alignment Many  1205
draw hardware arcs  2361
Draw Rasters for Plan View  236
dump  92, 148
Duplicate  2715
duplicate string  1049
edit a file *.mtf  1676
Edit Boxing Definitions  1662, 2946
edit boxing definitions  1664
edit boxing file  1662, 1664
edit boxing file *.bf  1665
edit colours  145
edit environmental variables  343
edit function from string  2682
Edit Line n  130
edit macro file *.4dm  2671
edit mtf file  1675, 1676
edit MTF/survey function data  1305, 1679
edit mtf/survey function data  2682
edit raster element  1141
edit string  958
edit super tin  1169
edit survey field data  1304
edit traverse spreadsheet  1497
edm measurement ht  1344
edm measurement vd  1346
edm measurent  1343
End  2993
end area volume between sections  2257
end area volume between tins  2244
End Area Volume from Sections to a Height  2255
end area volume from tin to a height  2242
End Area Volume from Tin to Sections  2260
end file  1339
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Enter Project Details  330, 341
error  1338
error authorizing release version  53
exact volume between heights  2265
Exact Volume Between Tins  2276
Exact Volume From Tin to a Height  2271
Exact Volumes Between Tins 2  2279
Exact Volumes to Height 2  2273
Exit 12d Model  2828
Explode Strings in  2716
Explode Super Alignment Labels  912
ExplodeTetxt in String/Model/View  2717
extend point  1040
extend point by ht  1040
face flags for view  195, 264
Factor  2718
feature  1334
feature edit info  936, 1004
Fence for  2686
Fence Stem  2687
field

name mapping  91
Field Data Find  1313
Field Data Find/Replace  1314
Field Data Goto  1313
file

name completion  91
File Browse  431
fill height  2881
fill height from link  2883
fill height to 2 strings  2888
fill height to string  2885
fill height to tin  2887
fill insert  2878
fill remove  2880
fill slope  2882
fill slope from link  2883
fill slope to 2 strings  2888
fill slope to string  2885
fill slope to tin  2887
fill width  2881
fill width from link  2883
fill width to 2 strings  2888
fill width to string  2885
fillet alignment construction  886
Filter Adjacent Points in  2724
Filter Adjacent Vertices in  2722
Filter Strings in  2721
final cut/fill template  1623
final fill slope  2892
final no cut  2894
Final No Cut/Fill  2894
final no fill  2894
final width  2891
fixed height  2852
fixed height from link  2855
fixed height to 2 strings  2860
fixed height to string  2857

fixed height to tin  2859
fixed insert  2849
fixed remove  2851
Fixed Slope  2975
Fixed Template  130
fixed template  1620
fixed width  2852
fixed width from link  2855
fixed width to 2 strings  2860
fixed width to string  2857
Fixed Xfall  2973
fixed xfall  2853
fixed xfall crc  2854
fixed xfall from link  2855
fixed xfall to 2 strings  2860
fixed xfall to string  2857
fixed xfall to tin  2859
Fixed/floating to IPs  909
flip triangles  1173
flow arrows  1223
FS Tin for Drainage  1828
function lock status  2660
function recalc order  2660
function rename  2661
function report  2603
General Transformations  1448
Geodetic reporting  1485
global model rename  576
Global Set Height  2730
Global String Rename  2742
Goto  2990
grade insert VIP  989
grades intersect VIPs  989
grid on view  237
grid volumes  2281, 2286
Head to Tail Strings in  2728
height adjustment  1420
height or depth  1337
Helmert 2D  2731, 2732
hide view  265
hinge comment  2844
hinge coord to string  2842
hinge height  2839
Hinge Modifiers  2837
hinge offset  2838
hinge offset to string  2840, 2841
House Connection Edit  1825
House Connections  1823
Inquire  2735
insert 3pt curve  1042
insert point  1041
insert target height  1404, 1405
interface function  1657
invisible  1340
job data  1338
join many strings  1052
join strings  1051
Join Super Alignment  908
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joy view  273
kerb return function create HG  1655
Label  2990
label chainages on string  1122
label chainages on string (marks)  1123
label contours  1194
label data by label map file  429
label map file create/edit  423
label string names  1131
label tadpole marks  1126
label tick marks  1128, 1129
label vertices  1132
least squares horizontal network adjustment  1408
Left Side Boxing  2899
left side modifiers  2847
left side templates  2833
linear regression  1554
linestyle create/edit/delete  384
linestyles for view  196
link clip string  1053
LMGS - D45 file  1575
long section along a string  1269
Longitude, latitude from grid coordinates  1464
loop removal  1149
lot check  1504
macro version  2672
Manhole Road Chainage  1812
Manhole Road Name  1811
Manhole Z Float  1811
map file apply  2736
map file create/edit  412
mapfile to field 12d  1592
measure angle  2675
measure distance/bearing  2676
measure plan area  2677
Measure Projection Plane bearing and ellipsoid dist

1459
measure value  2678
Melb Water plot drainage network  1884
Menu/Panel Dump  83, 92
menu/panel dump  3419
mesh over tin  1271
minimize  93
model attributes  578
model information  570
Model Information Table  572
model rename  574
Model Text for Plan View  201
Model Text Plan View  199
Model Text Table for Plan View  201
models transfer  610
move  93
move point  1041
Move Super Alignment Point Settings  913
move VIPs  987
mtf edit  1674
MTF Rename  1678
Multi Fence Stem String/Model/View  2691

Multi Fence String/Model/View  2689
multiple coding  1350
Names.4d Create/Edit  377
nd edit info  958
New Field Data Command  1312
new instrument  1352
new perspective OpenGL view  605
new perspective view  605
new plan view  605
New Plot Drainage Network  3340
new plot drainage network  1836
new plot frame create  2341
new plot frame edit  2343
new plot sewer network  3347
new section view  605
New View  603
new view  603
New Zealand conversions  1436
no hinge  2843
No Option  82
Non-projection to projection coordinate conversion

1467
note  1354
NS Tin for Drainage  1828
Null Height Range of  2740
Null Heights of  2738
Null to Height of  2741
null triangles by centroids of strings  1239
null triangles by length of side  1236
null triangles by points  1242
null triangles by polygons  1242
null triangles by strings  1241
Null Triangles by Triangle Angle and Length  1238
null triangles outside polygon  1234
null triangles reset  1236
NZ traverse spreadsheet report  1509
NZ49  NZ2000  1443
offset measurement  1355
old setout report  2606
On Grade String  1556
open string  1054
Optimal Paver  1770
Orbit  275
Overlay Design  1763
parallel string  1055
Parallel Super Alignment  905
pattern/regular expression tester  2753
Pavement Conformance Report  1533
perspective plot  290
perspective view  271
perspective view exaggeration  268
pipe diameter  1379
pipe edit  1004
pipe edit info  938
Pipe Justification  1357
Pipe String Properties  1005
pipeline edit info  2200, 2202, 2203
pipeline joint defaults  2207
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pipeline joint deflection report  2230
pipeline plot ppf editor  2570
pipeline tin defaults  2207
pixels to millimetres plot factor  2361
plan plot  256
plan plotting scale  197
Plan String Names for Plan View  226
Plan Text  199, 200
plan view  253
Plan Viewing Information  261
Plan Zoom by Model  243
Plan Zoom by String  243
Plan Zoom by View  243
plot frame change  2345
plot frame copy  2345
plot frame create  2343, 2379, 2382
plot frame edit  2381, 2382
plot frame insert  2349
plot frame ppf editor  2586
plot frame rotate  2346
plot frame seed create  2350
plot frame title  2386
plot frame translate  2346
plot frames plot  2383
plot pipeline network  2208
plotter mapping table  2358, 2359, 2360
plotting colours for interface string  2363
point height  1041
Point Numbers for Plan View  213
Point scale factor (GDA94/AGD66-84)  1465
point snap tolerance  2642
Polygon Report for  2604
polyline edit info  941, 1006
Polyline String Properties  1008
ppf convert ascii to binary  2590
PPF Copy Title Data  2591
Profile Model on Section  304
project attributes  397
project description  329
Project Details Editor  341
Project Model Utilities  597
Project N value setting Reset  365
Project Projection Reset  359
Project Selection  53, 165, 166
project selection  170
Project Share Settings  371
project tree  374
projection bearing/distance entry  1454
Projection bearing/distance label  1478
Projection Coords from plane Brg and ellipsoid dist

1457
Projection to non-projection coordinate conversion

1469
properties match  1121
property controls report  1832
Quantities  2612
radial report  2610
radiation table drafting  1516

Raster Reset Boundary String  1144
Raster Set Boundary String  1144
Read 12d Solutions Ascii Data  436, 481
read 4D HP plot panel  489
Read ArcView Shape Data  438
Read BCC Epson Data  450
Read Civilcad Data  452
Read DEM  455
read DGN data  457
Read DGN Data (Complex Elements)  458
Read DGN V8 File  460
Read DWG/DXF Data  462
read dxf data  490
Read Genio Data  3341
read genio data  467
Read Geocomp Data  474
Read Keays Data  476
read Landonline XML file  1517
Read LandXML File  479, 521
read screen layout  406
Read SDR Map Data  484
read templates  409
read textstyles definitions  407
Read Title Block File  2354
read TP Setout data  486
read TP Stakeout binary strings  488
Read X-Section Data  1776
read xyzs data  441
read xyzs pt no  443, 446
rebuild project  399
Recalc Chain  2655
recalc function from string  2683
rectangle  1370
rectangle by 2 points  1371
regular grid of tin  1250
removal calculations  2267
remove all models from project  583
remove all templates from project  1629
remove all tins from project  1260
remove height  1359
Remove Model from a View  186
remove model from a view  584
remove model from project  583
Remove Models from View by Pick  316, 319, 322
remove models from view by pick  324
Remove Shared Models from Project  591
Remove Shared Tins from Project  1281
remove template from project  1629
remove tin from a model  1261
remove tin from the project  1260
Rename a Chain  2657
report all functions  2603
Report Geodimeter Roadline 3D  1572
Report Leica roadplus 16  1574
Report Leica roadplus 8  1574
Report on Selected Item  2594, 2596
report tin  1262
Report Topcon GT700 Roading  1580
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Report topcon MS2000 Roading  1579
Report Trimble Roading  1581
Resection End  1362
Resection Start  1361
reset colour of triangles  1179
Resolve Super Alignment  903
retriangulate function  1165, 1170
retriangulate tin  1166, 1170
Reverse IP  984
reverse string  1056
Right Side Boxing  2899
right side templates  2833
Road Design Parameters  902
Roadside Furniture  628
rotate plan view  196
Rotate String/Model/View  2744
run a macro  2672
save all functions  2663
save all models  585
save all templates  1630
save all tins  1263
save function  2663
save model  585
Save Project  2828
save project  373
save tin  1263
scale factor  1363
screen dump  411
SDR Additional Text  1388
SDR Arc Fitting End  1390
SDR Arc Fitting Start  1389
SDR Arc Last 3 Points  1389
SDR Arc Next 3 Points  1389
SDR Attachment  1388
SDR Change Code/String  1306
SDR Close String  1399
SDR Culvert  1402
SDR Delete Point  1396
SDR End String  1399
sdr export  1555
SDR Feature  1390
SDR Invisible Next Segment  1392
SDR Invisible Point  1391
SDR Invisible Previous Segment  1391
SDR Join String  1400
SDR Non Tinable Next Segment  1393
SDR Non Tinable Point  1392
SDR Non Tinable Previous Segment  1393
SDR Pipe Axial Justification  1394
SDR Pipe Diameter  1402
SDR Pipe Invert Justification  1394
SDR Pipe Obvert Justification  1395
SDR Rectangle  1395
SDR Rectangle by 2 Points  1396
SDR Remove Height  1397
SDR Reverse String  1400
SDR Roading - Alignment Road  1576
SDR Roading - String Road  1578

SDR Start New String  1398
SDR String Type 2d  1401
SDR String Type 3d  1401
SDR String Type 4d  1402
section corridor  295
section geometry annotations  298
section grade annotations  301
section long plot  2369, 3343, 3505
section long plot many  2372
section long plot pagination  2369
section long plot ppf editor  2449
section long plot title  2369, 2386
section plot panel  308
section profile extend  298
section view  312
section view exaggeration  302
section width  2902
section X plot  3350
section x plot  2366, 3471, 3485, 3487
section x plot ppf editor  2391
section x plot title  2366, 2386
sections from points  1779
sections within a polygon  1273
segment string  1062
service draw tolerance  296
service items report on section view  313
Set N value settings  360
Set Projection  354
set sections for alignment panel  1580
setout report  2608
sewer annotations for plan view  197
sewer design checks report  1834
sewer edit  1804
sewer house connections report  1833
sewer network quantities report  1833
sewer services report  1835
shade view  269
shaping  1364
Share Project Models  587, 588
Share Project Tins  1277, 1278
sheet sizes file  396
Shift Chainages  2910
sight distance  1736
Slope Analysis  1215
Slope Analysis 2  1217
Slope Analysis Colour  1184
Smooth Contours in  1196
smooth strings  2747
Snap Model  2641
Snap Name  2641
Snap Tin  2641
Snap Tolerance  2642
solar observations  1487
sort VIPs  988
Sort X-Sections in a Model  1777
special chainage files  2836
special chainage values  2835
split string  1057
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Split Super Alignment  907
stadia measurement  1348
Standard traverse spreadsheet report  1512
Star observations  1490
steering path  1743
Stockpile Calculations  2284
storage calculations  2269
string attributes  1093
string close  1366
string crest/sag points report  2231, 2598
string drive fixed target for view  280
string drive for view  277
string end  1368
string extrude  625
string information table  573
string inquire  637, 1085
String Modifiers  2905
String Modifiers Function  1656
String Modify by Xfall Height  2906
String Modify by2 Strings  2908
string movie fixed target for view  288
String Names Report for  2598
String Names Table for Plan View  228
String Offset  2979
String Properties  1090
String Reverse  1373
String Segment Properties  1092
string start  1374
string type  1376
String Vertex Properties  1091
String Vertex/Segment Properties  1093
string walk fixed target for view  283
string walk for view  281, 285
strings delete  1153
strings from sections  1778
strings join  1341
stripping changes  2896
Super Alignment Report  2600
Super Alignment Style Create/Edit  899
Super Edit Info  945, 1010
Super Segment Annotate  1028
Super Segment Colour  1022
Super Segment Pipe  1024, 1025
Super Segment Properties  1031, 1032
Super Segment Radius  1026
Super Segment Text  1027
super segment user attributes  1030, 1031
Super Segment Visible  1029
Super SegmentTinable  1023
Super String Properties  1033
Super Vertex Annotate  1016, 1017, 1018
Super Vertex Height  1011, 1012
Super Vertex Point Number  1014
Super Vertex Properties  1021, 1022
Super Vertex Text  1015, 1016
Super Vertex Tinable  1012, 1013
Super Vertex User Attributes  1019, 1020
Super Vertex Visible  1013, 1014, 1015

Surface Area Within a Model of Polygons  1220
surface area within a polygon  1220
survey data convert raw  1291
Survey Data Download  1289
survey data reduction panel  1293, 1302
survey data setup  1288
Survey Data Upload  1590
survey reduction report  1406
Survey.4d Create/Edit  383, 1288, 3124
Swap XY String/Model/View  2748
symbol create/edit/delete  388
Synchronize Shared Models  593
Synchronize Shared Tins  1283
system defaults  3331
target height  1380
Template Create/Edit  2970
template create/edit  1618, 1619
template rename  1625
Template Views  1642
Templating  1381
text edit  948, 1035
text edit info  948
Text String Properties  1036
textstyle data  127
textstyle info  127
Textstyle_names.4d Create/Edit  395
Texture Map Create/Edit/Delete  613
tin aspect inquire  1227
tin colour  1176
tin colour inquire  1229
tin copy  1248
Tin Decision  2981
Tin Draw Contours for View  203
tin draw edges for view  204
tin draw flow arrows for view  204
tin draw mesh for view  206
tin draw solid for view  207
tin height inquire  1232
tin include/exclude boundaries  1233
tin information  1158
tin linestyle  1170
tin rename  1261
tin render settings  1171
tin ridges and valleys  1223
tin shade view  289
tin slope inquire  1232
Tin Tin Depth Range Polygons  1224
Tin Tin Intersection  1219
Tin to Height Curve  2275
Tin to Strings  1264
tin translate/copy  1265
tin weed  1266
Tin Width  2977
tinable  1353
toolbars  600
traffic island alignment creation  888, 1747
translate  2751
traverse adjustment  1425
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traverse spreadsheet drafting  1514
traverse spreadsheet parameters  1494
traverse spreadsheet utilities  1503
Tree Interval  622
triangulate a data source  1161
Tutorial - Group Extrusions  630
two points profile on section  305
Undo Decision  2992
Units  1383
Update Z-values from Tin  1209, 1210
variable cut template  1621
variable fill template  1621
Vertex Editor  1043
Vertex ID’s for Plan View  213
Vertex Id’s for Plan View  212
Vertex ID’sTable for Plan View  214
Vertex Indices Table for Plan View  219
Vertex Numbers for Plan View  217
Vertical Circle  1383
VG edit string  313
View  316, 318, 319, 321, 322
View Background Colour  240
View Drawing Filter  240
View Dump  96
view dump  255
view information  602
View Rename  606
view save/restore models  609
Viewshed  1221
Visualisation 3D Buildings  632
Visualisation Clouds  634
Visualisation Fence Extrusions  631
Volume Along a String Between Tins  2251
volume along a string to a height  2247
work plane  235
Workspace Setup  369
Write 12d Solutions Ascii Data for  495
write a template  410
Write Adac XML File  1596
write all templates  410
Write Arc View DEM  1254
Write Arc View DEM (Act/Min/Max/Avg)  1255
write ArcView shape files for  496
Write CivilCAD ascii file  524
Write DGN File for  508
Write DGN V8 File  511
Write DWG/DXF file for  512
Write DXF file for  534
write Eagle binary file for  541
write Eagle command file for  539
Write Genio File for Model/View  518
write Genio file V31 for  537
write Geocomp ascii file  526
write Landonline XML file  1518
write MapInfo Tab/Mif files for  522
Write Quantm DEM  1257, 1258
write screen layout  407
write TP Stakeout binary triangles  528, 529

write x y z general file for  505
write XYZ file for  498
write XYZS pt_no file for  499
write XYZSCH file for  501
xfall between 2 strings inquire  2679
x-fall report  2614
x-sections along a string  1275
Z Value Table for Plan View  223
Z Values for Plan View  221
zip project  399
zoom plan view  244

panel buttons  90
panel field  89

model  132
name completion  91
plotter type  3429
pop- up list  90, 125
pop- up menu  90, 125
pop-up list  90
pop-up menu  90
string select  132
typed input  90
validation  92

panel message area  89
panel system menu  92
panel table  130
panel title area  89
panels  79
paper style

continuous mode  3371
paperstyle  3368, 3371, 3384
parabolic curve  3561
parallel  1077
parallel a string  1055
peg_interval  2215
peg_text_colour  2216
peg_text_size  2216
peg_textstyle  2216
pen colour  2359, 3427
pen mapping  2359, 2384, 3426, 3427
percentage_grade  1857
perpendicular  1071
perpendicular to centreline profile  303
perpendicular to cl profile  307
perspective plot  290, 293
perspective view  79
pick  106

fast accept  106
fast pick  106
tentative  106

pick ops  107
pick position  109
picking

sense of direction  1078
picking direction  109
picking sense  109
pipe axial  1394
pipe invert  1394
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pipe obvert  1394
pipe string  100, 937, 1402
pipe string edit  1004
pipe_attr_n_arrow_area  1862
pipe_attr_n_arrow_colour  1862
pipe_attr_n_arrow_decimals  1862
pipe_attr_n_arrow_gap  1862
pipe_attr_n_arrow_mode  1862
pipe_attr_n_arrow_post_text  1862
pipe_attr_n_arrow_pre_text  1862
pipe_attr_n_arrow_size  1862
pipe_attr_n_arrow_text_colour  1863
pipe_attr_n_arrow_text_offset  1863
pipe_attr_n_arrow_text_size  1863
pipe_attr_n_arrow_textstyle  1863
pipe_attr_n_name  1862
pipe_attr_n_title  1862
pipe_attr_n_title_offset  1862
pipe_attr_n_title_text_colour  1862
pipe_attr_n_title_text_size  1862
pipe_attr_n_title_textstyle  1862
pipe_attr_n_title_x  1862
pipe_attr_n_y  1862
pipe_diameter_arrow_area  1858
pipe_diameter_arrow_colour  1858
pipe_diameter_arrow_gap  1858
pipe_diameter_arrow_mode  1858
pipe_diameter_arrow_post_text  1858
pipe_diameter_arrow_pre_text  1858
pipe_diameter_arrow_size  1858
pipe_diameter_arrow_text_colour  1858
pipe_diameter_arrow_text_offset  1858
pipe_diameter_arrow_text_size  1858
pipe_diameter_arrow_textstyle  1858
pipe_diameter_title  1858
pipe_diameter_title_offset  1858
pipe_diameter_title_text_colour  1858
pipe_diameter_title_text_size  1858
pipe_diameter_title_textstyle  1858
pipe_diameter_title_x  1858
pipe_diameter_y  1858
pipe_flow_arrow_area  1860
pipe_flow_arrow_colour  1860
pipe_flow_arrow_decimals  1860
pipe_flow_arrow_gap  1860
pipe_flow_arrow_mode  1860
pipe_flow_arrow_post_text  1860
pipe_flow_arrow_pre_text  1860
pipe_flow_arrow_size  1860
pipe_flow_arrow_text_colour  1860
pipe_flow_arrow_text_offset  1860
pipe_flow_arrow_text_size  1860
pipe_flow_arrow_textstyle  1860
pipe_flow_title  1860
pipe_flow_title_offset  1860
pipe_flow_title_text_colour  1860
pipe_flow_title_text_size  1860
pipe_flow_title_textstyle  1860

pipe_flow_title_x  1860
pipe_flow_y  1860
pipe_grade_arrow_area  1857
pipe_grade_arrow_colour  1857
pipe_grade_arrow_decimals  1857
pipe_grade_arrow_gap  1857
pipe_grade_arrow_mode  1857
pipe_grade_arrow_post_text  1857
pipe_grade_arrow_pre_text  1857
pipe_grade_arrow_size  1857
pipe_grade_arrow_text_colour  1857
pipe_grade_arrow_text_offset  1857
pipe_grade_arrow_text_size  1857
pipe_grade_arrow_textstyle  1857
pipe_grade_title  1857
pipe_grade_title_offset  1857
pipe_grade_title_text_colour  1857
pipe_grade_title_text_size  1857
pipe_grade_title_textstyle  1857
pipe_grade_title_x  1857
pipe_grade_y  1857
pipe_type_mode  1858
pipe_velocity_arrow_area  1859
pipe_velocity_arrow_colour  1859
pipe_velocity_arrow_decimals  1859
pipe_velocity_arrow_gap  1859
pipe_velocity_arrow_mode  1859
pipe_velocity_arrow_post_text  1859
pipe_velocity_arrow_pre_text  1859
pipe_velocity_arrow_size  1859
pipe_velocity_arrow_text_colour  1859
pipe_velocity_arrow_text_offset  1859
pipe_velocity_arrow_text_size  1859
pipe_velocity_arrow_textstyle  1859
pipe_velocity_title  1859
pipe_velocity_title_offset  1859
pipe_velocity_title_text_colour  1859
pipe_velocity_title_text_size  1859
pipe_velocity_title_textstyle  1859
pipe_velocity_title_x  1859
pipe_velocity_y  1859
pipeline  2199

defaults  2207
pipeline plot parameters  2212
pipeline plot ppf editor  2570
pipeline plots  2208
pipeline string  100
pipeline utilities  2206
pipeline_long_plot  2212
pixel to mm  2361, 3437
pixels  141, 3436, 3562
plan area  2677
plan plot  256
plan view  79
PLAN_TABLE_SETTINGS_4D  3345
plane  267
plane bearing  3291
plane distance  3291
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plot  258, 317, 320, 323, 2340
cross section  310
perspective  290
plan  256
section  308
x-section  310

plot a ppf  2366
plot file  3561
plot frame  258, 2340, 2342, 2350, 2381, 3439

change  2345
copy  2345
create along string  2348
create new  2341
create old  2379
create seed  2350
delete  2347
editor  2343
editor old  2382
insert seed  2349
plot old  2383
rotate  2346
translate  2346

Plot frame and ppf editor  2586
Plot frame ppf editor  2586
plot parameter file  2366, 2369, 2386
plot parameters  3493

pipeline  2212
plot_border  1882, 1883, 1901, 1902, 2228, 2229, 3486,

3547
plot_file  2451
plot_height  1841, 1883, 1887, 1902, 2213
plot_model_clean  2393, 2451, 2527, 2573, 2588
plot_name_colour  3544
plot_name_mode  1843
plot_name_post_text  1843, 3544
plot_name_pre_text  1843, 3544
plot_name_size  3544
plot_name_string_name  3544
plot_name_text_colour  1843
plot_name_text_size  1843
plot_name_textstyle  1843, 3544
plot_name_x  1843
plot_name_x_offset  3544
plot_name_y  1843
plot_name_y_offset  3544
plot_stem  1883, 1902, 2393, 2587
plot_symbols  2392, 2451
PLOT_SYMBOLS_4D  3345
plot_title_centre_chainage_name  1846
plot_title_centre_chainage_name_2  1846
plot_title_chainage_name  1846, 1890, 2218
plot_title_chainage_name_2  1846
plot_title_d_and_g_name  1890
plot_title_depth_name  1847, 1890, 2219
plot_title_depth_name_2  1847
plot_title_detail_name  1890
plot_title_finished_name  1847
plot_title_finished_name_2  1847

plot_title_grade_name  2219
plot_title_height  2217
plot_title_hgl_name  1847
plot_title_hgl_name_2  1847
plot_title_invert_name  1847, 1890, 2219
plot_title_invert_name_2  1847
plot_title_item_name  1890
plot_title_line_colour  2217
plot_title_surface_name  1846, 1890, 2218
plot_title_surface_name_2  1846
plot_title_text_colour  1890, 2217
plot_title_text_size  1890, 2217
plot_title_top_height  2221
plot_title_width  2217
plots

pipeline  2208
plotter mapping  2358, 3426, 3427
plotter mapping editor  2356
plotter mapping file  2356, 2358, 2359, 3426, 3427
plotter panel field  3423
plotter type  3429
PLOTTER_4D  3345
PLOTTER_MAPPING_4D  3345
plotter_type  1883, 1902, 2393, 2451, 2587
plotters  150, 3423
plotters.4d  3331, 3429, 3432
PLOTTERS_4D  3345
plotting arcs  2361
plotting interface colours  2363, 3436
plotting scale  197
pmf file  2359, 3427
pmf.4d  3331, 3427
PNG  1135
point description  3137, 3154
point height  1041
point id’s

single  213
table  214

point name  3137
point number  3137
point numbers  212
point scale factor  3294
Point scale factor (GDA94/AGD66-84)  1465
point snap  118, 2640
point snap box  116
point snap tolerance  116, 118, 119, 2641
point string  102
point strings  101
point text  3137
points edit  1038
points_height_n_angle  2436, 3477
points_height_n_colour  2436, 3477
points_height_n_justification  2436, 3478
points_height_n_mode  2435, 3477
points_height_n_no_decimals  2437, 3478
points_height_n_position  2435, 3477
points_height_n_post_text  2436, 3478
points_height_n_pre_text  2436, 3478
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points_height_n_size  2436, 3477
points_height_n_textstyle  2436, 3477
points_height_n_x  2436, 3477
points_height_n_y  2436, 3477
points_label_n_angle  2437, 3478
points_label_n_colour  2437, 3478
points_label_n_justification  2438, 3478
points_label_n_mode  2437, 3478
points_label_n_position  2437, 3478
points_label_n_post_text  2438, 3478
points_label_n_pre_text  2438, 3478
points_label_n_size  2437, 3478
points_label_n_textstyle  2438, 3478
points_label_n_x  2437, 3478
points_label_n_y  2437, 3478
points_n_mask  3476
points_offset_n_angle  2434, 3477
points_offset_n_colour  2434, 3477
points_offset_n_justification  2434, 3477
points_offset_n_no_decimals  2435, 3477
points_offset_n_position  2433, 3477
points_offset_n_post_text  2434, 3477
points_offset_n_pre_text  2434, 3477
points_offset_n_size  2434, 3477
points_offset_n_textstyle  2434, 3477
points_offset_n_x  2434, 3477
points_offset_n_y  2434, 3477
points_symbol_n_angle  2439, 3477
points_symbol_n_colour  2439, 3477
points_symbol_n_mode  2438, 3476
points_symbol_n_position  2439, 3477
points_symbol_n_size  2439, 3477
points_symbol_n_style  2439, 3476
points_symbol_n_x  2439, 3477
points_symbol_n_y  2439, 3477
polygon  3562
polygon sections  1273
polygons from tin colours  1225
polygons from tin depth ranges  1224
polygons report  2604
polyline

append  1006
extend  1007
extend ht  1007
radius  1007

polyline string  100, 940
polyline string edit  1006
POLYPOLYLINES_4D  3345
pop-up list  90, 125
ppf  2365
ppf editor

drainage plan plot  2572
drainage plot  2525
long section plot  2449
Melbourne Water plot  2568
pipeline plot  2570
plot frame  2586
x section plot  2391

precision  144
previous  190, 317, 319, 323
previous view  317, 319, 323
primary  3462
primary string  293, 303
primary_ch_tolerance  2465, 3503
primary_colour  2416, 2465, 3454, 3462, 3503
primary_decimals  2417, 2464, 3462, 3503
primary_draw_vips  2458, 3503
primary_height_angle  2407, 3452, 3467
primary_height_colour  2407, 3452, 3467
primary_height_decimals  2407, 3452, 3467
primary_height_draw_mode  2407, 3452, 3467
primary_height_justify  2408, 3452, 3467
primary_height_position  2425, 3452
primary_height_post_text  2407, 3452, 3467
primary_height_pre_text  2407, 3452, 3467
primary_height_size  2408, 3452, 3467
primary_height_textstyle  2408, 3452, 3467
primary_height_x  2407, 3452, 3467
primary_height_y  2407, 3452, 3467
primary_label_mode  2458, 3497, 3503
primary_mode_cl  2427, 3454
primary_model_id  3523
primary_size  2417, 2465, 3454, 3462, 3503
primary_string  2393, 2458, 3462, 3503
primary_string_id  3523
primary_textstyle  2417, 2464, 3454, 3462, 3503
primary_title  2416, 2464, 3454, 3462, 3503
primary_title_2  2416, 2464, 3462, 3503
primary_title_colour  2416, 2464, 3462, 3503
primary_title_size  2416, 2464, 3462, 3503
primary_title_textstyle  2416, 2464, 3462, 3503
primary_title_y_pos  2416, 2464, 3462, 3503
primary_x0_angle  2406, 3451, 3466
primary_x0_colour  2406, 3451, 3466
primary_x0_decimals  2406, 3451, 3466
primary_x0_draw_mode  2406, 3451, 3466
primary_x0_justify  2406, 3451, 3466
primary_x0_position  2425, 3451
primary_x0_post_text  2406, 3451, 3466
primary_x0_pre_text  2406, 3451, 3466
primary_x0_size  2406, 3451, 3466
primary_x0_textstyle  2406, 3451, 3466
primary_x0_x  2406, 2407, 3451, 3466
primary_x0_y  2406, 2407, 3451, 3466
primary_y_pos  2417, 2465, 3462, 3503
primary_y0_angle  2407, 3452, 3467
primary_y0_colour  2407, 3452, 3467
primary_y0_decimals  2406, 3452, 3467
primary_y0_draw_mode  2406, 3451, 3466
primary_y0_justify  2407, 3452, 3467
primary_y0_position  2425, 3451
primary_y0_post_text  2406, 3452, 3467
primary_y0_pre_text  2406, 3452, 3466
primary_y0_size  2407, 3452, 3467
primary_y0_textstyle  2407, 3452, 3467
primary_y0_x  3452, 3467
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primary_y0_y  3452, 3467
PRINTER_4D  3346
profile  303, 322

model strings  303, 304
perpendicular to centreline  303
perpendicular to cl  307
two points  303, 305

project  103
project area  103, 169
project attributes  397, 578
project description  329
project details  329, 330, 341
project details editor  341
project mangement  332
project model utilities  597
project models  570
project n values  360
project projections  354
project tins  1157
project tree  374
project utilities  397
project workspace  369
project workspace load  370
PROJECT_NAMES_4D  3346
projection  1072

AMG  357
cartographic  356
delete  358
Lambert Conformal Conic  358
MGA  357
reset  359
Transverse Mercator  357
Universal Transverse Mercator  357
UTM  357

projection bearing  3291
Projection bearing and dist  1459
projection bearing/distance entry  1454
Projection bearing/distance label  1478
Projection to non-projection coordinate conversion

1469
projections

cartographic  1433
projects  103, 325
properties  1090
property controls  1832, 1833
property_control_depth_decimals  1875
property_control_depth_mode  1875
property_control_depth_post_text  1875
property_control_depth_pre_text  1875
property_control_depth_text_angle  1875
property_control_depth_text_colour  1875
property_control_depth_text_justify  1875
property_control_depth_text_position  1875
property_control_depth_text_size  1875
property_control_depth_text_x  1875
property_control_depth_text_y  1875
property_control_diameter  1894
property_control_ds_pit_mode  1875

property_control_ds_pit_post_text  1875
property_control_ds_pit_pre_text  1875
property_control_ds_pit_text_angle  1875
property_control_ds_pit_text_colour  1875
property_control_ds_pit_text_justify  1875
property_control_ds_pit_text_position  1875
property_control_ds_pit_text_size  1875
property_control_ds_pit_text_x  1875
property_control_ds_pit_text_y  1875
property_control_ds_pit_textstyle  1875
property_control_fs_decimals  1876
property_control_fs_mode  1875
property_control_fs_post_text  1875
property_control_fs_pre_text  1875
property_control_fs_text_angle  1875
property_control_fs_text_colour  1875
property_control_fs_text_justify  1875
property_control_fs_text_position  1875
property_control_fs_text_size  1875
property_control_fs_text_x  1875
property_control_fs_text_y  1875
property_control_fs_textstyle  1875
property_control_il_decimals  1876
property_control_il_mode  1876
property_control_il_post_text  1876
property_control_il_pre_text  1876
property_control_il_text_angle  1876
property_control_il_text_colour  1876
property_control_il_text_justify  1876
property_control_il_text_position  1876
property_control_il_text_size  1876
property_control_il_text_x  1876
property_control_il_text_y  1876
property_control_il_textstyle  1876
property_control_mode  1874
property_control_post_text  1874
property_control_pre_text  1874
property_control_symbol  1874
property_control_symbol_n_angle  1874
property_control_symbol_n_colour  1874
property_control_symbol_n_mode  1873
property_control_symbol_n_size  1874
property_control_symbol_n_style  1874
property_control_symbol_n_y  1874
property_control_text_angle  1874
property_control_text_colour  1874
property_control_text_gap  1876
property_control_text_justify  1874
property_control_text_position  1874
property_control_text_size  1874
property_control_text_x  1874
property_control_text_y  1874
property_control_textstyle  1874, 1875
property_controle_symbol_n_x  1874

Q
quantities  2612
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Quantm DEM  1256
quick contours  203

R
radial report  2610
radiation  1076, 1546
radiation backsight  1499
radiation block  1499
radius  1007, 1117
range file

aspect  1212, 1213
depth  2263
height  2286
slope  1217

raster  1134
rasters  236
raw data file  1291, 3086, 3107, 3136
read title block file  2354
rebuild project  399
re-calc  2659
recalc  2661, 2680, 2683
recalc all  2683
RECENT_PROJECTS_4D  3346
rectangle by last 2 points  1395
rectangle by last 3 points  1395
redo  959
redraw  190
reduce field file  1293, 1302
reduce with no field file  1302
reference string  1633, 2831
regen  322
regenerate  308, 322
regular grid on a tin  1250
remove  2851
remove all models  186
remove all models from project  583
remove all tins from project  1260
remove model  186
remove model from project  583
remove model from view  584
remove point  1396
remove shared models  591
remove shared tins  1281
remove tin from model  1261
remove tin from project  1260
remove tin models  187
removed models  570
rename

chain  2657
function  2661
template  1625
tin  1261, 1262, 1625
view  606

rename model  574
global  576

repicking  107
report

crest/sag points  2598
cross fall  1147
depth between strings  1147
function  2603
NZ TSS  1509
polygons  2604
section view  313
set-out  2605
string names  2598
survey  1406
tin  1262
x-fall  2614

report for SDR function  1406
REPORT_HEADER_4D  3346
reports  2593
reset N value settings  365
reset n value settings  365
reset null triangles  1236
reset projection  359
reset triangle colours  1179
resizable panel  326, 374
resizing a view  97
restart project  373
restore a panel  93
restore a view  97
restore view models  609
retriangulate  1170
reverse string  1056, 1400
ridge and valley lines  1223
ridge line  1223
right side  2833, 2913
right side modifier  2846
right side template modifiers  2847
right_border_gap  2397, 2453, 3442, 3495
right_extension  2396, 3445, 3471, 3473
right_margin  1840, 2212, 2398, 2454, 3442, 3494
right_side  2913
right_sub_plot_gap  2399, 3443
Rivers  2121
rivers

12d system search path  2197
an overview  2121
culverts  2126

summary table  2130
faq  2197
hec-ras interface

an overview  2132
export  2132
import  2136
importing cross sections GIS  2140
importing HEC2 data  2142
importing interpolated cross sections  2141

how to  2191
isis interface

an overview  2183
manual settings  2191
mapping historical water levels  2194
mike11 interface
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an overview  2158
exporting  2158
importing  2162

models  2122
presenting water level results  2166

colour ground surface by height  2177
colour ground surface with flood zones  2173
colour water by depth  2173
defining water surface boundaries  2172
depth contours  2175
sample drawings  2168
trimming the water surface tin  2172
water level boundaries  2166

reservoir strings  2124
river strings  2122
source strings  2124
spill strings  2126
unet interface

an overview  2180
exporting  2180, 2183
importing  2181, 2187

xp swmm interface
an overview  2144
exporting  2144
importing  2154

road chainage  1812
road chainage for manhole  1812
road name  1812
road name for manhole  1811
RoadPak  476
roadside furniture  628
Rotate  2342, 2343, 2381, 2382
rotate  196, 2342, 2343, 2346, 2381, 2382, 2744
rotate plot frame  2346
run  2669, 2672
run chain  2684
RUN_MACROS_FILE_4D  3346

S
same as  324, 869, 871, 874, 877, 891, 915, 935, 937,

940, 943, 947, 950, 952, 954, 957
view  324

Sameas  127
save  2827, 2828

function  2663
save a model  585
save a tin  1263
save all models  585
save all tins  1263
save function  2663
save project  373
save view models  609
scale  1864, 1883, 1892, 1902, 2220, 2392, 2451, 3471,

3523
horizontal  2368, 2371

scale factor  357
scale_horizontal_colour  2522, 3545

scale_horizontal_decimals  2522, 3545
scale_horizontal_post_text  2522, 3545
scale_horizontal_pre_text  2522, 3545
scale_horizontal_size  2522, 3545
scale_horizontal_textstyle  2522, 3545
scale_horizontal_x_offset  2522, 3545
scale_horizontal_y_offset  2522, 3545
scale_vertical_colour  2523, 3545
scale_vertical_decimals  2523, 3545
scale_vertical_post_text  2523, 3545
scale_vertical_pre_text  2523, 3545
scale_vertical_size  2523, 3545
scale_vertical_textstyle  2523, 3545
scale_vertical_x_offset  2523, 3545
scale_vertical_y_offset  2523, 3545
screen dump  411
screen layout file  83, 92, 96, 406, 3419
screen units  141, 3436, 3562
scrolling panel list  130
scrolling panel table  130
SDR arc fitting end  1390
SDR arc fitting start  1389
SDR arc through last 3 points  1389
SDR arc through next 3 points  1389
SDR attachment  1388
SDR circle feature  1390
SDR close string  1399
SDR culvert string  1402
SDR invisible  1391
SDR invisible next segment  1392
SDR invisible previous segment  1391
SDR join string  1400
SDR Map  484
SDR non tinable  1392
SDR non tinable next segment  1393
SDR non tinable previous segment  1393
SDR pipe axial  1394
SDR pipe invert  1394
SDR pipe obvert  1395
SDR pipe string  1402
SDR point edits  1387
SDR rectngle by last 2 points  1396
SDR rectngle by last 3 points  1395
SDR remove height  1397
SDR remove point  1396
SDR reverse string  1400
SDR string edits  1398
SDR string type 2d  1401
SDR string type 3d  1401
SDR string type 4d  1402
SDRmap  3110, 3160, 3161
section  1269, 1273
section long plot  3548
section view  79

utilities  312
section width  2902
sections from points  1779
sections within a polygon  1273
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seed file  508, 512
segment  1022

tinable  101
segment a string  1062
segment colour  1108
segment geometry  1118
segment snap  120
segments  99
semi-major axis  3282
sense of direction  1078
service items  293
service_ch_text_colour  1850
service_ch_text_size  1850
service_ch_textstyle  1850
service_chainage_mode  1850
service_il_text_colour  1850, 2216
service_il_text_size  1850, 2215
service_il_textstyle  1850, 2216
service_line_colour  1850, 1894, 2215
service_name_decimals  1850
service_name_text_colour  1850
service_name_text_size  1850
service_name_textstyle  1850
service_name_y  1850
service_text_colour  1894, 2215
service_text_gap  1852
service_text_size  1894, 2215
service_text_x_offset  1894
service_text_y_offset  1894
services_text_gap  1889, 2215
Set  354
set chainage at a point  1146
set n value settings  360
set projection  354
set up file  3352
set up files  3331, 3335

writing  3335
set_up commands  3372, 3387
SET_UPS_4D  3346
set-out report  2605
settings  262
settlement  1786
settlement tin  1786
setup

data collector  1288
setups.4d  3331, 3352
SETUPS_FILE_4D  3346
sewer  197
sewer (Barwon) option  1682
sewer junction  1792
Sewer option  1789
sewer string  100, 1791
SEWER_PPF_4D  3347
shade  269, 270, 289, 3562
shape field coding  3103
shape file  496
share settings  371
sharing of models  587

sharing of tins  1277
sharing tin  1277
sheet size  3442, 3494
sheet_size  1840, 1883, 1887, 1902, 2212, 2393, 2451,

3442, 3494
SHEET_SIZES_4D  1840, 1887, 2212, 3347, 3442,

3494
sheets.4d  3331, 3360, 3435
SHOW_PATHS_4D  3347
SHOW_TITLE_VARIABLES_4D  3347
Shrink  244
shrink  317, 323
side shots  1499
Side Tool Bar area  79
sides

external  1238
sight distance  1736
single

attributes  230
point id’s  213
string names  226
text  200
vertices  208
z values  221

single_frame  2587
slf file  406
slope  3562
slope analysis  1215
slope colouring  1184
slope from link  2870, 2883
slope inquire  1232
slope range file  1217
slope to 2 strings  2875, 2888
slope to string  2872, 2885
slope to tin  2874, 2887
smooth  1196, 2747
snap

data tip  120
fast  120
segment  120
text  120

snap box  115
snap tolerance  115, 118, 119, 2641, 2642

point  116
snapping  3562
snaps  117, 2640

cursor  118, 2640
grid  118, 2640
height  119
info  118, 120, 2640, 2642
line  118, 2640
model  2641
name  2641
point  118, 2640
point tolerance  119, 2641
tin  118, 2640
tolerance  119, 2642

snaps (vert)  2644
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snaps cogo  2645
Sokkia  3107, 3159
Sokkia DEM  1258
Sokkia Roading - alignment road  1576
Sokkia Roading - string road  1578
solar observations  1487
solid  207
sort cross sections  1777
sort VIPs  988
sort_sections  2393, 3485
space_for_titles  2411, 2459, 3458, 3498
special chainages  2831, 2835
special characters  142
Special File Formats  3337
specials  2835, 2836

values  2835
specials_model  2215
spiral  3562
spirals.4d  3332, 3361
SPIRALS_4D  3347
splays  1063
split string  1057
square  1408
SQUARED_CHARACTER_4D  3347
srf  1217
stagger_gap_bottom  1852, 1889, 2215, 2420, 2487,

3468, 3519
stagger_gap_factor  2420, 2487, 3468, 3519
stagger_gap_top  1852, 1889, 2215, 2420, 2487, 3468,

3519
stagger_height_1  1852, 1889, 2215
stagger_height_2  1852, 1889, 2215
stagger_height_3  1852, 1889, 2215
stagger_height_4  1852, 1889, 2215
stagger_mode  2487, 3519
staggering  2420, 3468
standard field file  3083
standard field file format  3086, 3107
Standard TSS report  1512
star reduction  1490
start arc fitting  1389
start chainage  3562
start_chainage  2220, 2393, 2451, 3523
start_drawing_number  1882, 1901, 2228, 3440, 3486,

3547
start_page_number  1882, 1901, 2228, 3440, 3486, 3547
station  3137
Status Bar  79, 98
steering path  1743
steering path option  1743
stopping final link  2933
storage calculations  2269
string  99, 277, 281, 285, 3562

2d  99, 869, 949
3d  99, 871, 952
4d  99, 874, 954, 3436
alignment  99, 100, 877
arc  100, 914

change  1046
circle  100, 914
clip  1046
close  1048
contour  99
convert  1082
delete  1049
drainage  100
duplicate  1049
feature  100, 935
interface  100
join  1051
label  1122
link clip  1053
open  1054
parallel  1055
pick  106
pipe  100, 937
pipeline  100, 2200
polyline  100, 940
primary  293, 303
sewer  100, 1791
split  1057
super  100, 943
super alignment  891
text  100, 141, 947, 3436
translate  1058

string attributes  1093
string chainage  101
string colour  102
string convert  1082
string delete  1153
string delimiter  3111
string direction  99
string drape  1203
string drive  277, 280
string editor  958
string filter  2720
string finish  959
string from point  138
string info table  573
string information  1085
string inquire  637, 1085
string links  99
string loop removal  1149
string model  102
string modifier  2903
string modifiers  1656
string movie  285, 286, 288
string name  102
string names  2598
string number  3086
string offset  2971, 2979, 3417
string properties  1090
string redo  959
string same as  957
string segments  99
string select field  132
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string select panel field  132
string typed input  960
string undo  959
string utilities  1146
string walk  281, 283
string_to_plot  2451, 3523
strings  637

convert  2703
join many  1052

strings edit  1045
strings from sections  1149, 1778
stripping  1643, 2831, 2896
stripping depths  2896
style

continuous mode  3371
vertex mode  3371

style for tin  1170
subgrade  1645, 1670, 1734, 2898
super

append  1010
extend  1011
extend ht  1011

super alignment design parameters  902
super alignment string  100, 891
super alignment style  899
super string  100, 943

2d  869, 950
attributes  1111
billboard  611, 616
chainage interval  1097
compress  1101
fill  1104
height  1109
library extrude  626
pipe/culvert  1115
segment

all information  1031

text  1027
colour  1022
diameter  1024
radius  1026
text info  1028
tinable  1023
visible  1029

segment colour  1108
symbols  1106
text  1119
tinable  1102
vertex

all information  1021
attributes  1019, 1030
height  1011
symbol info  1018
text  1015
text info  1016
tinable  1012

visible  1013, 1014
vertex id  1113
visibility  1099

super string edit  1010
super_ch_colour  2476, 3511
super_ch_decimals  2476, 3511
super_ch_size  2476, 3511
super_ch_textstyle  2476, 3511
super_ch_x  2476, 3511
super_ch_y  2476, 3511
super_cl_line_colour  2477, 3512
super_cl_linestyle  2477, 3512
super_common_decimals  2478, 3512
super_common_line_colour  2478, 3512
super_common_linestyle  2478, 3512
super_common_post  2478, 3512
super_common_pre  2477, 3512
super_draw_mode  2474, 3511
super_edge_name_left  2476, 3511
super_edge_name_right  2477, 3512
super_hinge_name_left  2476, 3511
super_hinge_name_right  2477, 3511
super_left_decimals  2476, 3511
super_left_line_colour  2476, 3511
super_left_linestyle  2476, 3511
super_left_post  2476, 3511
super_left_pre  2476, 3511
super_right_decimals  2477, 3512
super_right_line_colour  2477, 3512
super_right_linestyle  2477, 3512
super_right_post  2477, 3512
super_right_pre  2477, 3512
super_sample_interval  2474, 3511
super_sample_name  2474, 3511
SUPER_STRINGS_4D  3347
super_title  2475, 3511
super_title_colour  2475, 3511
super_title_size  2475, 3511
super_title_textstyle  2475, 3511
super_title_y_pos  2475, 3511
super_tolerance  2475, 3511
super_upright_colour  2478, 3512
super_upright_mode  2478, 3512
super_xfall_colour  2475, 3511
super_xfall_size  2475, 3511
super_xfall_textstyle  2475, 3511
super_xfall_x  2475, 3511
super_xfall_y  2475, 3511
super-elevation diagram  2474, 3511
SuperTin  1164

edit  1169
supertin  1164
suprt string

tinable  1102
surface area  1220, 2678
surface_box_size  1845
surrounding polygon  1065
survey  3083
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12d field file  1289
backsight measurement  1299
current measurement  3137
current point  3137
current string  3137
data collector  3124
named measurement  3137
order  1385
point name  3137
point number  3137
raw data file  1291, 3086, 3107
reduce field file  1293, 1302
standard field file  3086, 3107
text  3137
typed entry into field file  1302

survey data collectors  383
survey reduction  3083
survey.4d  3332
swap XY  1434
swap xy  2748
sweep angle  917, 3562
symbol  3384
symbol darw commands  3388
symbol_n_angle  2512, 3537
symbol_n_colour  2512, 3537
symbol_n_draw_mode  2513, 3537
symbol_n_size  2512, 3537
symbol_n_type  2512, 3537
symbol_n_x  2512, 3537
symbol_n_y  2512, 3537
symbol_n_y_mode  2512, 3537
symbols  1106
symbols.4d  3386
SYMBOLS_4D  3347
symbolsl.4d  3332
synchronize  593
synchronize shared models  593
synchronize shared tins  1283
synchronize tins  1283
System  92
system call  3397
System Settings  335, 338, 339
SYSTEM_NAMES_4D  3347

T
t  1158
table

attributes  232
point id’s  214
string names  228
text  201
vertices  210
z value  223

tables  2313
tadpoles  1126
tangent  1080
tangent point  3563

target  274
target-point  3563
tbl file  3434
tear away menus  81
template  1616, 3563

apply  1633, 2831
cut  1617, 1618
decisions  1617, 1618
fill  1617, 1618
final cut/fill  1617, 1618
fixed  1616, 1618

template decisions  1617
template delete  1631
template input  1628
template links  1617
template modifiers  1643, 2831, 2846, 3563
template name  1619
template output  1628
template rename  1625
template utilities  1627
templates  2833

apply many  1643, 2831
field  3095

templates file  2831
templates input  409
templates output  410
tentative pick  106
tentative typed input  112
test wildcards  2753
text  141, 199, 1119, 2313, 2749, 3436

change  2749
paper units  141, 3437
quick mode  199
screen units  141, 3436
single  200
table  201
world units  141, 3436

Text Control Bar  641
text ht  1036
text paper units  141, 3437
text snap  120
text string  100, 141, 947, 3436
text string edit  1035
text_colour  2217
text_size  2217, 2412, 3458
textstyl.4d  3332, 3393, 3395
textstyle data favourites  395
textstyle input  407
TEXTSTYLE_MAPPING_4D  3347
textstyle_names.4d  3332
TEXTSTYLES_4D  3348
TGA  1135
three state tick box  343
tick box

three states  343
tick marks  1127

tadpoles  1126
TICK_DRAW_CROSS_4D  3348
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ticks
user symbols  1129

tif  1135
TIFF  1135
tiff  1135
time_format  1882, 1901, 2228, 2388, 3440, 3486, 3547
TIN  3563
tin  103, 1155

copy  1248
create  1161, 1166
edit  1166, 1169
save  1263
tin to strings  1264
translate/copy  1265

tin analysis  1211
tin aspect  1211
tin aspect inquire  1227
tin boundary  1175
tin colour  1176
tin colour inquire  1229
tin colouring  1176
tin copy  1248
tin create  1161, 1166
tin cut slope modifier  2932
tin decision  2971, 2981, 3417
tin delete  1284
tin fill height modifier  2931
tin fill slope modifier  2932
tin function  1165, 1170
tin height colouring  1180
tin height inquire  1232
tin height modifier  2925, 2931
tin information  1158
tin inquire  1227
tin linestyle  1170
tin mesh  1271
tin null

by angle/length  1238
by centroids  1239
by length  1236
by points  1242
by polygons  1242
by strings  1241
null  1234
reset  1236

tin null by angle and length  1238
tin null by length  1236
tin rename  1261
tin report  1262
tin shade  289
tin sharing  1277
tin slope  1215
tin slope inquire  1232
tin snap  118, 119, 2640, 2641
tin style  1170
tin to strings  1264
tin utilities  1245, 1269
tin weed  1266

tin width  2971, 2977, 3417
tin xfall modifier  2925
tin_n_colour  2418, 2467, 3464, 3504
tin_n_decimals  2418, 2467, 3464, 3504
tin_n_depth_colour  2419, 2468, 3465, 3505
tin_n_depth_decimals  2419, 2468, 3465, 3505
tin_n_depth_label  2418, 2467, 3464, 3504
tin_n_depth_size  2419, 2468, 3465, 3505
tin_n_depth_textstyle  2419, 2468, 3465, 3505
tin_n_depth_title  2418, 2467, 3464, 3504
tin_n_depth_title_2  2419, 2467, 3464, 3504
tin_n_depth_title_colour  2419, 2468, 3465, 3504
tin_n_depth_title_size  2419, 2468, 3465, 3504
tin_n_depth_title_textstyle  2419, 2467, 3464, 3504
tin_n_depth_title_y_pos  2419, 2468, 3465, 3505
tin_n_depth_y_pos  2419, 2468, 3465, 3505
tin_n_draw_colour  2417, 2466, 3504
tin_n_draw_mode  2417, 2466, 3464, 3504
tin_n_height_angle  2426, 3453
tin_n_height_colour  2426, 3453
tin_n_height_decimals  2426, 3453
tin_n_height_draw_mode  2426, 3453
tin_n_height_position  2426, 3453
tin_n_height_post_text  2426, 3453
tin_n_height_pre_text  2426, 3453
tin_n_height_size  2426, 3453
tin_n_height_textstyle  2426, 3453
tin_n_height_x  2426, 3453
tin_n_height_y  2426, 3453
tin_n_label  2417, 2466, 3464, 3504
tin_n_name  2403, 2466, 3453, 3464, 3504
tin_n_size  2418, 2467, 3464, 3504
tin_n_textstyle  2418, 2467, 3464, 3504
tin_n_title  2417, 2466, 3464, 3504
tin_n_title_2  2417, 2466, 3464, 3504
tin_n_title_colour  2418, 2466, 3464, 3504
tin_n_title_size  2418, 2467, 3464, 3504
tin_n_title_textstyle  2417, 2466, 3464, 3504
tin_n_title_y_pos  2418, 2467, 3464, 3504
tin_n_y_pos  2418, 2467, 3464, 3504
TIN_VIEWPORT_CLIP_4D  3348
tinable  101, 1102

line  3563
point  3563
segment  101, 3563
vertex  101, 3563

tins  203, 268
tins depths colour  1182
title block  2385
title block variables  2385, 2386
title_1  1882, 1883, 1901, 1902, 2228, 2229, 3440, 3486,

3547
title_2  1882, 1883, 1901, 1902, 2228, 2229, 3440, 3486,

3547
title_box_text_colour  1844
title_box_text_size  1844, 2411, 2459, 3458, 3498
title_colour  1882, 1901, 2228, 3486, 3547
title_file  1882, 1883, 1901, 1902, 2228, 2229, 3486,
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3547
title_text_colour  1883, 1902, 2229
title_text_size  1882, 1883, 1901, 1902, 2228, 2229,

3486, 3547
toggle  192, 194, 262, 263, 294, 295
toggle view  317, 319, 323
tolerance  119, 2642
Tool bars  638
toolbar  3407

Measure Edits  155, 159
Road  156
String Edits  157
Super Alignment Tools  158
Tin Utility  161
Traverse Spreadsheet  162
Visualisation  163

toolbars.4d  3332, 3407
TOOLBARS_4D  3348
top area  1865, 1892
Top Tool Bar area  79
top_border_gap  2397, 2453, 3442, 3495
top_margin  1840, 2212, 2398, 2454, 3442, 3494
top_sub_plot_gap  2400, 3443
Topcon  3107, 3223
Topcon GTS-700 Roads  1580
Topcon MS2000  1579
TP Setout  1597, 1600, 1604, 1608
TP Setout input  486
TP Stakeout  528, 529, 1597, 1600, 1604, 1608
TP Stakeout strings  488
tpl file  409
traffic island  888, 1747
transformation

affine  3559
Helmert  3561

transit  1425, 1493, 1495, 1497, 1504
transition curve  3562
transition spiral  3562
translate  2346, 2751

translate string  1058
translate plot frame  2346
translate string  1058
translate/copy tin  1265
Transverse Mercator  3286
Transverse Mercator Projection  357
traverse  1076, 1546
traverse adjustment  1425
traverse block  1499
Traverse spreadsheet

parameters  1494
traverse spreadsheet  1493

create  1495
drafting  1514
edit  1497
radiation table drafting  1516
utilities  1503

Traverse spreadsheet drafting  1514, 1516, 1517, 1518
triangles

external  1238
triangulate  1161, 1166
triangulated irregular network  1155
triangulation  3563
Trimble  3209
Trimble Roading  1581
True Azimuth  3296
tsf file  407
TSS  1493

create  1495
drafting  1514
edit  1497
parameters  1494
radiation table drafting  1516
utilities  1503

two points profile  303, 305
two points two distances  1074
twoptstyle  3368, 3371, 3374
Typed Entry  1302
typed input  90, 111, 960

tentative  112
TYPED_UNITS_MODE_4D  3348

U
undo  959, 2992
UNDO_4D  3348
units

screen  3562
world  3564

Universal Transverse Mercator Projection  357
upload  1590
uprights_bottom_mode  1849, 2422, 2488, 3469, 3520
uprights_bottom_y  2422, 2489, 3469, 3520
uprights_colour  2421, 2488, 3469, 3520
uprights_draw_mode  2421, 2488, 3469, 3520
uprights_text_offset_factor  2422, 2489, 3469, 3520
uprights_top_mode  1849, 1867
uprights_y  2421, 2488, 3469, 3520
USAGE_LOG_4D  3348
USAGE_LOGS_4D  3348
use label map file  429
use_hg_vg_for_min_max  2452
use_title_file  1882, 1883, 1901, 1902, 2228, 2229, 3486,

3547
use_vg_hg_for_min_max  3494
user defined function keys  3397
user defined plotters  382
user lib  131
user library  3413
USER_4D  3348
USER_LIB_4D  3348
USER_OPTIONS_4D  3348
user_text_n  1882, 1901, 2228, 3440, 3486, 3547
userkeys.4d  3332, 3397
usermenu.4d  3332, 3402
utilities  253, 277, 2637

section view  312
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string  1146
template  1627
tin  1245, 1269

UTM  357, 3563

V
v_g_n_between_mode  2506, 3532
v_g_n_colour  2507, 3533
v_g_n_draw_mode  2507, 3532
v_g_n_gap  2507, 3533
v_g_n_height  2507, 3533
v_g_n_label_offset  2506, 3532
v_g_n_label_text  2506, 3532
v_g_n_label_text_colour  2506, 3532
v_g_n_label_text_size  2506, 3532
v_g_n_label_textstyle  2506, 3532
v_g_n_label_x  2506, 3532
v_g_n_label_y  2506, 3532
v_g_n_no_decimals  2508, 3533
v_g_n_offset_string  2506, 3533
v_g_n_post_text  2508, 3533
v_g_n_pre_text  2508, 3533
v_g_n_rotate  2508
v_g_n_text_colour  2508, 3533
v_g_n_text_offset  2508, 3533
v_g_n_text_size  2508, 3533
v_g_n_textstyle  2508, 3533
v_g_n_type  2505, 3532
v_g_n_value_mode  2505, 3532
v_g_text_colour  2216
v_g_text_size  2216
v_g_textstyle  2216
valley line  1223
value  2678
values  2835
variable template  1621
variables

many template  2939
vector  1075
vehicle turning path option  1743
VEHICLE_PATH_4D  3349
version  2672
vertex  1011

edit  1043
tinable  101

vertex filter  2721
vertex id  1113
vertex mode  3367, 3371
vertex no.s  216, 217
vertex numbers  216
vertical alignment  3564
vertical exaggeration  293, 302, 322
vertical geometry edit  313
vertical geometry plot  3531
vertical wall  2945, 2966
vertical_exaggeration  2392, 2451, 3471, 3523
vertical_geometry_arrow_colour  2502, 3531

vertical_geometry_arrow_grade_text_colour  2503,
3531

vertical_geometry_arrow_grade_textstyle  2503, 3531
vertical_geometry_arrow_height  2502, 3531
vertical_geometry_arrow_length_text_colour  2504,

3531
vertical_geometry_arrow_length_text_size  2504, 3531
vertical_geometry_arrow_length_textstyle  2504, 3531
vertical_geometry_arrow_mode  2502, 3531
vertical_geometry_arrowl_grade_text_size  2503, 3531
vertical_geometry_grade_mode  2503, 3531
vertical_geometry_grade_y  2502, 3531
vertical_geometry_label_grade_decimals  2503, 3531
vertical_geometry_label_grade_text  2502, 3531
vertical_geometry_label_grade_text_colour  2503, 3531
vertical_geometry_label_grade_text_size  2503, 3531
vertical_geometry_label_grade_textstyle  2503, 3531
vertical_geometry_label_length_decimals  2504, 3531
vertical_geometry_label_length_text  2503, 3531
vertical_geometry_label_length_text_colour  2504,

3531
vertical_geometry_label_length_text_size  2504, 3531
vertical_geometry_label_length_textstyle  2504, 3531
vertical_geometry_length_mode  2504, 3531
vertical_geometry_length_y  2502, 3531
vertical_plot_gap  1841, 1865, 1887, 1892, 2213, 2221
vertices  208

single  208
table  210

VG edit  313
view  317, 319, 323, 599, 3563

drag  97
dump  96
fit  317, 319, 323
minimize  97
move  97
previous  317, 319, 323
rename  606, 608
toggle  317, 319, 323

view buttons  95, 315
View dump  605
view dump  255, 290
view info  602
view text  199, 200
view utilities  253, 277
view workbook mode  96
VIEW_BITMAP_BUTTONS_4D  3349
VIEW_BUTTONS_4D  3349
view_name  1864, 1883, 1892, 1902, 2220, 2587, 3439,

3471, 3523
views  95, 181

same as  324
Views Area  79
viewshed  1221
view-title area  95
VIP  3561
visible  1099
volume_box_size  2479, 3514
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volume_cl_line_colour  2479, 3515
volume_cl_linestyle  2479, 3515
volume_cut_decimals  2481, 3514
volume_cut_text_colour  2481, 3514
volume_cut_text_size  2481, 3514
volume_cut_text_x  2481, 3514
volume_cut_text_y  2481, 3514
volume_cut_textstyle  2481, 3514
volume_cut_title  2480, 3514
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volume_file_name  2479, 3514
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volume_fill_textstyle  2481, 3515
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volume_sub_title_x  2482, 3515
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volume_title_textstyle  2479, 3514
volume_title_y_pos  2480, 3514
volume_uprights_draw_mode  2482, 3515
volume_uprights_line_colour  2482, 3515
volume_y_pos  2479, 3514
volumes

balances volumes  2280
between heights  2265
cut/fill text in poly  2288
end area  2233, 2235, 2241
exact  2233, 2263
grid cell  2281
removal calculations  2267
sections to height  2255
sections to sections  2257
stockpile  2284
storage calcs  2269
string tin to height  2247
string tin to tin  2251
tin to height  2242, 2271, 2273
tin to sections  2260
tin to tin  2244, 2276, 2279
tin to tin by height range  2286

Vpath  1743

W
walk  281, 320
walk along string  320
walk-right menu  83
WARP_CURSOR_HIDE_4D  3349
WEB_4D  3349
weed  1266
weed tin  1266
WEED_TOLERANCE_4D  3349
WGS84  356, 3564
width  2831, 2852, 2868, 2881, 2891

corridor  295
width from link  2855, 2870, 2883
width modifier  2920, 2921
width to 2 strings  2860, 2875, 2888
width to string  2857, 2872, 2885
wildcards

test  2753
WINDOWS_PRINTERS_4D  3349
WINDOWS_VEHICLE_PATH_4D  3349
WINTER_4D  3349
WINTER_DATA_4D  3349
work plane  235
workspace setup  369
world style

continuous mode  3371
vertex mode  3371

world units  141, 3436, 3564
worldstyle  3368, 3371, 3384
WRITE_ALL_PLOT_PARAMETERS_4D  3349

X
x plot  310, 2366
X plot ppf editor  2391
x section ppf editor  2391
x sections  1771
x y z general  446
x_label  2484, 3517
x_label_colour  2484, 3517
x_label_decimals  2484, 3517
x_label_size  2484, 3517
x_label_textstyle  2484, 3517
x_label_y_pos  2485, 3517
x_origin  1841, 1883, 1887, 1890, 1902
X_SECTION_PPF_4D  3350
x_title  2484, 3517
x_title_2  2484, 3517
x_title_colour  2484, 3517
x_title_size  2484, 3517
x_title_textstyle  2484, 3517
x_title_y_pos  2484, 3517
x-fall  2614
xfall  2853, 2854, 2950
xfall 1  2952
xfall from link  2855
xfall modifier  2923, 2924
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x-fall report  2614
xfall to 2 strings  2860
xfall to string  2857
xfall to tin  2859
x-section

name from string  1774
x-sections  1275
x-sections - see cross sections  2636
x-sections filter  1782
x-sections through tin  1275
xtramenu.4d  3332
xy_chord_arc  2483, 3517
xy_end_chainage  2483, 3517
xy_interval  2483, 3517
xy_label_crest  2483, 3517
xy_label_grade_change  2483, 3517
xy_label_hcp  2483, 3517
xy_label_hip  2483, 3517
xy_label_sag  2483, 3517
xy_label_tolerance  2483, 3517
xy_label_vip  2483, 3517
xy_label_vtp  2483, 3517
xy_order  2483, 3517
xy_special_n_file  2483, 3517
xy_start_chainage  2483, 3517
xyz general output  505
XYZ typed input box  111, 960
xyzch output  501
xyzs

format  440
xyzs format  440
xyzs input  441
xyzs output  498, 499
xyzspt_no input  443

Y
y_label  2485, 3518
y_label_colour  2485, 3518
y_label_decimals  2485, 3518
y_label_size  2485, 3518
y_label_textstyle  2485, 3518
y_label_y_pos  2486, 3518
y_origin  1841, 1883, 1887, 1890, 1902
y_title  2485, 3518
y_title_2  2485, 3518
y_title_colour  2485, 3518
y_title_size  2485, 3518
y_title_textstyle  2485, 3518
y_title_y_pos  2485, 3518

Z
Z diffs from tins  1267, 1268
z filter  2724
z value

table  223
z values  221

single  221
zag  3099
zig  3099
zig-zag  3098, 3099
zip project  399
zone  3292
zone to zone transformation  1430
zoom  242, 317, 323
zoom by Model  243
zoom by String  243
zoom by View  243
zoom factor  245
ZOOM_ORIGIN_DYNAMIC_4D  3350
ZOOM_PAN_DYNAMIC_4D  3350
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