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Preface
Why a ‘Getting Started for Surveyings’ Manual ?
12d Model is supplied with a comprehensive on-line Reference manual which describes the function of 
each menu option in detail. It is a Reference manual however and makes no attempt to describe how to use 
12d for production surveying and civil engineering work.

This Getting Started for Surveying manual is designed to show you how to install 12d Model, work with 
the on-line help system, and then as the first section of Training, help you start to learn how to use 12d to 
achieve typical surveying tasks. The Getting Started for Surveying manual uses examples where possible 
to clarify usage. It complements rather than replaces the on-line Reference manual. In general, information 
in the on-line Reference manual will not be duplicated here.

The Getting Started for Surveying manual is available as a printed manual and as a PDF file on the 12d 
Model Training DVD.

Training Material

The training tutorials assumes that a series of files are already on your hard disk. These tutorial files are 
automatically installed from the CD during installation of the 12d Model software. 

Getting Started for Design
There is also a Getting Started for Design manual which has the first seven chapters in common with the 
Getting Started for Surveying manual (on-line help and basic modelling) but then diverts to cover topics 
from the direction of a civil designer whereas the Getting Started for Surveying manual continues on with 
surveying techniques.

The Getting Started for Design manual is available as a printed manual and as a PDF file on the 12d Model 
Training DVD.

Using the Practise and Small Versions of 12d Model
The Practise version of 12d Model is limited to a maximum of 5,000 points. Following the procedures as 
stated in the Training Manual may create projects with more than 5,000 points. 

Where appropriate, the text will suggest how to vary the input for each instruction so that the example 
feature can be completed within the limits of the 12d Model Practise version. 

The number of points used at any time in the Practise and small versions can be displayed by the option

Projects => Check base points

The easiest way to reduce the current point count is to delete any unwanted models with 

Models => Delete

The installed icon on your desktop for running the practise version of 12d with these training files is 
labelled ‘12d v8.00 Practise Training’.

Please Note: Projects created by Practise versions of 12d Model cannot be accessed by Release versions of 
12d Model and vice-versa.



12d Model Getting Started and Training Manual

Page 10 July 2007



May 2007 Page 11

1 Installing 12d Model
The 12d Model 8 Installation CD can be used to install the Release and Practise versions of 12d Model 8.

The Practise version is limited to a maximum of 5,000 points and creates projects that cannot be accessed 
by the Release versions of 12d Model and vice-versa.

However the Practise version can be used free of charge by 12D Solutions customers and registered 
Practise Users.

Installing the Release Version for Sites Not Running 12d Model 7 or 12d Model 8

For a new installation of the Release version of 12d Model 8, the user is provided with

one dongle
one 12d Model 8 Installation CD
an email or a floppy with the file nodes.4d on it with the V8 authorisation in it.

Because most new computers do not have a floppy disk drive, the 12d Model 8 nodes.4d file will normally 
be emailed to you rather than sent on a floppy disk. Before installing 12d Model 8, you must copy the 12d 
Model 8 nodes.4d into a folder that can be accessed during the installation.

Please do not change the name of the nodes.4d file. The installation and 12d Model will only search for a 
file called nodes.4d. During the installation of 12d Model 8, you will be asked to browse to the folder 
containing the nodes.4d file.

Please check that you have all three items before commencing the installation.

The notes for a new install of  the Release version of 12d Model 8 are on the 12d Model 8 Installation CD 
or can be downloaded from the 12d web site www.12d.com under the Updates area.

Installing the Release Version for Sites Already Running 12d Model 7 or 12d Model 8

Existing 12d Model 7 or 12d Model 8 users upgrading to 12d Model 8 are provided with

one 12d Model 8 Installation CD
one What’s New in V8 DVD
an email or a floppy with the file nodes.4d on it with the V8 authorisation in it.

The dongle you already have will work with the new version of 12d Model 8.

Because most new computers do not have a floppy disk drive, the 12d Model 8 nodes.4d file will normally 
be emailed to you rather than sent on a floppy disk. Before installing 12d Model 8, you must copy the 12d 
Model 8 nodes.4d into a folder that can be accessed during the installation.

Please do not change the name of the nodes.4d file. The installation and 12d Model will only search for a 
file called nodes.4d. During the installation of 12d Model 8, you will be asked to browse to the folder 
containing the nodes.4d file.

The notes for upgrading to the Release version of 12d Model 8 are on the What’s New in V8 DVD or can 
be downloaded from the 12d web site www.12d.com under the Updates area.

Important Note

If 12d Model 8 is already running on your computer, please uninstall it before installing a new version of 
12d Model 8.

Installing the Practise Version:

For a Practise installation of 12d Model, all that is needed is:

one 12d Model Installation CD
or 12d Model Practise download from www.12d.com

The Practise version must be Registered with 12D Solutions once it is installed on a computer. A new 
Registration is required for each computer that the Practise version is run on.

The notes for installing the practise version of 12d Model are on the 12d Model 8 Installation CD or can be 
downloaded from the 12d web site www.12d.com under the 12d Model Practise area.
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2 Before You Begin the Training

2.1 Installing the Training Files
If you have installed Training from the 12d Model Installation CD, then the Training folder will have been 
automatically created for you but where the files reside on the disk depends on whether you installed the 
Release version or the Practise version of 12d Model.

The Training manual dialogue assumes that the working folder (i.e. shortcut) of your ‘12d Model 8 
Training’ or ’12d Model 8 Practise Training’ icon is set to

c:\12djobs\8.0\Training   for the Release version of 12d Model
and

c:\12 Model 8 Practise\Training   for the Practise version of 12d Model 

The training files can be installed in any sub-folder on your hard disk. 

For convenience in this manual, is assumed that the training files are installed in

c:\12djobs\8.00\Training

but it is very rare in the Training Manual that you ever need to know exactly where on disk the data resides. 
All the required material is already in the "Training" folder.

2.2 12d Icons on your Desktop
It is recommended that you use the ‘12d Model 8 Training’ icon for the Release version or ’12d Model 8 
Practise Training’ icon for the Practise version whilst initially working with this training manual. The 
reason for this is that the icon points directly to the folder containing the training files.

Be aware that there is a separate ‘12d Model 8’ icon recommended for 12d production work. The shortcut 
for this icon is generic and is set to

c:\12djobs or c:\12d Model 8 Practise    for the "12d Model 8 Practise" icon.

With a little extra button pushing to point to the right path, it is possible to access the ‘Training’ area from 
the ’12d Model 8’ icon

For convenience in this manual, is assumed that the ‘12d v8.00 Training’ icon is used.

2.3 Using the Practise Version
Remember that the Practise version of 12d Model is limited to a maximum of 5,000 points.

Following the procedures as stated in the Training Manual may create projects with more than 5,000 
points. Where appropriate, the text will suggest how to vary the input for each instruction so that the 
example feature can be completed within the limits of the 12d Model Practise version. 

2.4 Overview of 12d File and Folder Structures
Before you begin using 12d, it is useful to understand how 12d uses the file and folder structure under 
Windows 2000, XP and Vista.

12d recognises long filenames up to 256 characters so you are not limited to the old DOS convention of 8.3 
filenames. Whilst long filenames under Windows can contain spaces it is recommended that you use 
underscores ‘_’ in file and folder names created externally from 12d. 

The 12d program and its support files are installed on your hard disk, typically into folder c:\Program 
Files\12d and various subfolders below. When the software was installed, the ‘12d Model 8’ program icon 
will have been setup to point to a working folder where your data files will be stored - typically c:\12djobs.

As each job you work on will have different files, it is strongly recommended that you keep each job in a 
separate subfolder. This is done manually and can be anywhere on your hard disk or network. For 
convenience, you may prefer to keep them all under one major folder e.g. c:\12djobs. 
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The tutorial is about designing a road and the training the files have been set up in a folder 
c:\12djobs\8.00\Training\8.00\Design\Getting Started Basic.

In the general case for production work however, if you were about to start work on a new job by the name 
‘Highway’, you would begin by creating a new folder under 12djobs i.e. c:\12djobs\Highway. This is done 
either from the 12d Project Selection panel, or before starting 12d using Windows Explorer. Either numeric 
or alpha characters may be used in folder names so you may prefer to use job numbers rather than names. 
Also under Windows, 12d is not case sensitive for folder names, so ‘Highway’ is seen as the same name as 
‘highway’.

If you just accept the 12d default working folder (c:\12djobs) as the place to put your data files, 12d will 
still operate correctly but it will become difficult over time for you to separate which files belong to which 
jobs once you have multiple jobs on the go.

2.5 The 12d Concept of ‘Projects’
12d can have more than one project within the one Windows folder which can be worked on 
independently. For example, projects under ‘Highway’ might be ‘Stage 1’ and ‘Stage 2’ or ‘Fred’ and 
‘Bill’. Each project has its own data and configuration setup which controls the number of views, which 
models are on display etc.

New projects like these can be created from within 12d by pointing at the c:\12djobs\Highway folder and 
then typing a new project name. If this is done twice during separate 12d sessions, you will have created 
two unique projects. Internally, 12d handles this by creating two separate folders on disk in the Highway 
folder.

c:\12djobs\Highway\Stage_1.project

c:\12djobs\Highway\Stage_2.project

Because of this structure, the projects can be worked on independently. All internal files from one project 
are kept separate from the other internal files of another. However, all input and output files, mtf files, 
chains, plots and reports go into the folder containing the project (e.g. Highway) and are not held inside 
the project itself. Hence to prevent projects interfering with each other, it is best to create a separate folder 
and create each project in its own folder.

For example, create a folder “Highway\Stage1” and from within 12d, attach to that folder and then create 
the project “Stage 1”. 12d then creates a subfolder “Stage_1.project:

c:\12djobs\Highway\Stage1\Stage_1.project

Once inside 12d, from within any one project, it is possible to import any or all data from another project 
so there is some flexibility on a major job to move/copy survey or design data between stages if staging is 
used and then have multiple users perform parallel development. Model and tin sharing could later be used 
to subsequently assemble staged project data at the completion of a major job. Within any one project, 
model names must be unique so some planning is necessary if parallel development streams are 
subsequently to be reassembled. Models can be renamed at any time. Models are discussed in See Chapter 
3.11 (on page 37).

Provided no 12d user is currently accessing a particular project, it (the project folder) can be manipulated 
just like any folder i.e. copied, deleted etc. using Windows Explorer, obviously external from 12d. Such 
manipulation is very similar to how Windows Explorer might be used to copy and delete CAD files and 
folders. Copying and renaming is obviously a fast way of setting up a new development stream or new 
user.

However, information inside the project folder should not be manipulated except from within 12d Model 
since this will corrupt the project and data could be lost. For example, model names can only be renamed 
from within 12d Model. 

At any one time, a 12d session can only access one project. It is possible to change from one project to 
another without exiting 12d.

The creation of at least one ‘Project’ under any job is compulsory within 12d. Thus even if there is no 
concept of staging within the ‘Highway’ project, you must still define a Project. In this case you might use 
the same name for both the Job and the Project or name the Project just ‘proj’
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If you need to manually place any files on disk for this project (e.g. survey files from a total station or 
CAD files to get data into 12d), it is recommended that you place them in the folder. 

c:\12djobs\Highway

The user should never need to know about or manually access the files within the Project folder. To 
maintain the integrity of 12d, it is important that you never edit any of the ‘internal’ 12d files which are in 
(typically)

c:\12djobs\Highway\Stage_1.project

2.6 File Backup Procedures
To ensure that you can retrieve any job or project at any time from backup procedures, it is important that 
a complete ‘set’ of files is taken whenever backup is created. To backup the files associated with the 
‘Highway’, you would typically backup all files and sub-folders in and below

c:\12djobs\Highway

There are configuration files used that may be used in the Highway job, that are supplied by 12D Solutions 
and are automatically installed from the 12d Model CD. These files are in 

c:\Program Files\12d\12dmodel\8.00\set_ups

c:\Program Files\12d\12dmodel\8.00\library

There are other user configurable files that 12d may use and require to fully recreate all steps of a project. 
They are not supplied on the 12d installation CD. These files are typically in 

c:\Program Files\12d\12dmodel\8.00\user

c:\Program Files\12d\12dmodel\8.00\user_lib

These folders may contain files that have been configured specifically for your site e.g. your corporate 
standard mapping, template and plot parameter files, your particular Total Station survey macros and any 
user defined macros etc. In general, such files are not project specific, however because these files are user 
configurable they may be changed at any time and hence particular project specific versions of them may 
be needed as part of the complete file set of a project.

In the above case, the folders shown are for 12d version 8.0. As implied, the files in these folders will 
never be changed automatically by the installation process when you reinstall a later version of 12d. 

The above paths are indicative only. It is possible that folders have been setup at different places for your 
site. For more information on exactly where all library and user folders are located, refer to the following 
environment variables in Appendix A of the on-line Reference manual.

USER_4D

USER_LIB_4D

SET_UPS_4D

LIB_4D



12d Model Getting Started and Training Manual

Page 16 February 2007



Chapter 3  Basic Operations

February 2007 Page 17

3 Basic Operations

3.1 The ‘Mouse’
12d works best with a three button mouse (preferable a wheel mouse). 12d will work with a (Microsoft) 
two button mouse but the lack of the middle button means that you have extra mouse clicks to perform. 

All 12d Documentation uses the following notation for mouse functions.

LB = left mouse button  - used for picking screen items, menus etc.

MB = middle mouse button  - used to accept the highlighted item

RB = right mouse button  - used to pop up a list of alternatives

The left button is the ‘Select’ button – typically used to select graphic items or text. The middle button (or 
wheel) is the ‘Accept’ button, used to confirm a selection. The right button is the ‘Menu’ button. It is 
context sensitive and often displays a list of alternatives available at that instant. 

With a two button mouse you achieve this functionality by clicking the right mouse button to pop up the 
‘Pick Operations’ menu and then clicking LB on Accept or by simply pressing the <Enter> key

The term ‘clicking’ a button means pressing it down and releasing it again. The position of the mouse is 
taken at the time the button is released. In this tutorial manual, items that are selected by a mouse click are 
in bold.

As we get more experienced, we will also introduce the term ‘dragging’ the mouse for some advanced 12d 
operations. We do this by pressing down a button and whilst still holding it down, moving the mouse so 
that the screen cursor moves. Once a definite distance has been achieved, just a millimetre or two is 
sufficient, release the button. 12d notes the vector you defined and can use this information to detect the 
direction in which you dragged the mouse.

Finally, we will use the term ‘double clicking’. This is where we press the button twice in quick 
succession. This is often used for short-cuts.
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3.2 Starting Up - The Project Selection panel
If you installed 12d Model Training from the 12d Model Installation CD, then a ‘12d Model V8.0 
Training’ icon will have been created on your desktop. Double clicking on this icon will take you directly 
into the 12djobs\8.00\Training folder.

Once you are inside 12d, the Project Selection panel will appear. 

Firstly, click the LB over the folder icon at the right end of the Folder field to pop up a panel that allows 
you to see and point to your directory structure. 

In the ‘Select Folder’ panel that pops up, highlight Design 
and double click LB, highlight Getting Started Basic and 
double click.

 Click LB on Open to complete the selection and the list of projects in Getting Started Basic will be 
displayed.
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Notes:

1. It is important to select names that are meaningful to your job as you may have several projects 
associated with a large or complex job.

2. You only need to create a new project once. To access this project in subsequent 12d sessions, double 
click the LB on the project name from the pop up list. 12d will normally pop up the list automatically. 
If needed, you can use the          button to open the list manually.

RULES FOR ENTERING DATA INTO PANELS

Important: The cursor must be locked into the appropriate data entry field when typing data into a 12d 
panel. Often this will happen automatically. If you cannot see the cursor flashing in the data field in which 
you want to enter data, use the mouse to position the cursor anywhere over the data field and click the LB 
to lock the cursor into the field before typing any data. Terminate the data entry sequence by pressing the 
Enter key.

If you make a mistake, you can always select the erroneous entry by double clicking over it with the mouse 

Note the pop up list of projects will be empty because 
there are currently no projects in the folder 
GettingStarted Basic.

You must now supply a name for your new Project. Place the cursor into the Project field, click LB and 
type ‘Stage 1’.

To continue click LB on Proceed
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LB. The text should then appear highlighted. As you retype it, the old entry is deleted.

When filling in data in any 12d panel, it is not essential to terminate the entry of data by pressing the 
‘Enter’ key. You can use the ‘Tab’ and ‘BackTab’ keys to move from field to field. You can also use the 
mouse to jump between fields. If you do press the Enter key to terminate the entry of data into a field, 12d 
will immediately validate the data in that field and supply an error message if appropriate

. 

Click on Set to save the 
details and Finish to close 
the panel.

Once a project is selected, the graphics screen will display, with the Project Details panel open.  Fill in the 
panel with the relevant required details.

Note that you must use the LB to click between fields and cannot use the ‘Enter’ or ‘Tab’ keys.
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3.3 The Initial Screen Layout
The default background colour for a view is black. Black is the best colour for reducing eye strain, and for 
distinguishing colours displayed in the view. The names we use for the various parts of the screen are 
shown on the diagram below. Your screen may not appear exactly as shown as most components on the 
screen can be moved or turned off by user configuration options.

To make the Getting Started manuals easier to print on in-house printers, all of our illustrations have a 
white background colour.

If your screen appears fragmented (as shown in the above view), it is because the main 12d window is not 
maximised. To bring the various parts of 12d together such that it appears more orderly, click LB on the 
‘square’ Screen Maximise button in the top right hand corner of the window labelled ‘12d Model …Project 
“C:\12djobs\8.00\Training\Design\Getting Started Basic\Stage 1”.

Note that the View with the white background is headed ‘Plan 1’. Each View in 12d is assigned to a 
Window. Like all Windows, they can be Minimised, Maximised or Closed. 

The ‘Plan 1’ View can be maximised by clicking LB on the square button in the top right hand corner of 
the view menu.

    Snaps tool bar

Screen maximise
minimise button

Drop down
main menu bar

View titleView type
and name View button

Output

window

area

area

CAD control bar

Text control bar

CAD tool bar

view workbook tabs

Screen message box
View coordinates box

Snaps cogo toolbar Symbol control bar

Recalc Panel
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This then takes up the entire viewing area. Alternatively, you can double click LB on the plan view title 
area to maximise the view (The blue area to the left of the Minimise button). To reduce it back to its 
original size you can hit the restore icon.

The ‘Recalc’ panel is used to quickly rerun design calculations and will be discussed later. We will move 
the panel down to the bottom left of the screen.

The view should then look as shown below.

     Minimise
     Maximise

 Close

Restore icon
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3.4 How to Find Your Way Around 12d Menus
12d options are run by a number of methods. The ‘Drop Down’ menu system from the bar running across 
the top of the screen is the main way we access 12d programs.

In addition to the ‘Drop Down’ Main menu system, there is a ‘12d Model’ menu which is maintained for 
compatibility reasons with earlier versions of the software. This is found at Projects=>12d Model menu.

12d has a unique graphical user interface (GUI) involving hundreds of menu items. These are logically 
grouped by function in a ‘Walk Right’ and ‘Tear Off’ menu system. ‘Walk Right’ menus are menus 
designed such that if you move the mouse cursor right on a menu item containing a right arrow, a further 
menu will pop up, usually on the right hand side. ‘Tear Off’ menus means that a menu can be torn off it’s 
parent menu and relocated elsewhere on the screen for clarity of operation. In general, it is possible to have 
multiple copies of the same ‘Tear Off’ menu on the screen at one time.

Notice that the order of items left-to-right on the ‘Drop Down’ Main menu bar is the same as the top-to-
bottom order on the ‘Walk Right’ 12d Model menu. You can select menu items from either one of these 
sources – the end result is the same.

The ‘Drop Down’ menu bar conforms to normal Microsoft standards so it can be dragged and placed at 
any of the four sides of your desktop. It is probably most useable left at the top of your desktop. 

The following comments apply to ALL menus. To move any menu around on the screen, you ‘drag’ it by 
depressing the LB in the ‘blue’ coloured View Title area, anywhere other than over the ‘X’ in the top right 
hand corner. With the button still depressed, move the mouse to the desired location and release the button 
to repin the menu. The same procedures also apply when moving panels and views. When doing this just 
make sure that LB is clicked in the general heading area and not on a View button.

To ease the learning and usage process, a menu description system has been adopted in this manual that 
describes where to look to achieve a specific function. For instance, to import an AutoCAD DXF file of 
point and line data into 12d, you ‘Walk Right’ on the 12d Model menu or from the ‘Drop Down’ main 

click on 12d Model menu

 

brings up the old menu
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menu bar, through two submenus and select DWG/DXF. This instruction is documented as…

File I/O =>Data Input =>DWG/DXF/DXB 

To display submenus from the ‘Walk Right’, you do not need to use the mouse buttons. Simply position the 
mouse cursor over the 12d Model menu and once ‘File I/O’ is highlighted, slide the mouse right over the 
arrow and the ‘File I/O’ menu will pop up. Slide further right on the ‘Data Input’ menu item and the ‘Data 
Input’ menu will pop up. 

Your screen should appear as follows

Alternatively, you can use the ‘Drop Down’ menu bar to get to the same point …
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To get to this same point using the pull down system, you need to click LB on [File I/O] on the ‘Drop 
Down’ menu bar and then proceed as before on the walk rights as shown below.

Regardless of which menu selection method you used, place the cursor over the words ‘DWG/DXF/DXB’ 
and click the left mouse button (LB) once. The ‘Read DWG/DXF Data’ panel will appear.

Once the panel is selected, the Walk Right menu system should collapse and be removed from the screen. 
If you move and repin any of the menus however, they will not collapse automatically.

If a menu is in the way, you can move it as stated above. Any menu can be removed by clicking LB on the 
‘X’ button in the top right hand corner. 

You would normally now start entering data into the panel. At this time, we will not proceed further with 
this panel. Shut down the panel by clicking LB on the             in the top right hand corner or clicking LB on 
Finish at the base of the panel.

The panel is placed on the screen at the 
location where the mouse cursor was when 
LB was clicked.
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3.5 Toolbars and Controlbars

CAD Toolbar and CAD Contolbar
In 12d Model there are CAD options which are available under both the Strings =>CAD menu and on the 
CAD Toolbar on the left hand side of the 12d Model screen.

The CAD options create various elements using a number of methods. These options make use of Tool 
bars and Control bars. Tool bars just have icons on them but Control bars have icons and also controls 
such as a model box on them. The method groupings are shown on the toolbars (e.g. Points, Lines etc.). 

The user can select an icon on the tool bar and a Flyout for all options of the grouping are displayed. This 
can be done by selecting the appropriate group symbol by holding down the left mouse button on the icon. 
This shows all the different options for that grouping in a flyout panel. Whilst still holding down the left 
mouse button, the user can move along the flyout toolbar to the appropriate option. 

The elements created from the CAD options will have attributes as defined by the Cad Control Bar. This 
control bar is placed on the top left hand side of the screen under the main menu control bar on the creation 
of a project

The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

N name box names.4d names

name of string. If a valid name already exists in names.4d, the [N] button can be used to bring up a 
choice box of available names. On selection of a valid name, the rest of the values in the control bar 
will be filled out. e.g. colour, linetype etc.

CAD Controlbar

CAD toolbar

CAD Change String
flyout toolbar
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model box cogo existing models

this field can be recognised by the model icon button on the right hand side of the field. The user can 
select an existing model by selecting the model icon. If a new model is to be used, the user simply types 
the model name into the field.

colour box red standard 12d colours

this field can be recognised by the colour icon button on the right hand side of the field. The user can 
select a 12d standard colour model by selecting the colour icon

height input Measures menu

this field allows a height or z value to be assigned to the created elements. If a valid value exists, this 
value will be applied to the created element. This is regardless if the z value was specified in an XYZ 
box. 

If no value is specified, the level will be interpolated where possible. A value of null can be entered into 
the height field as well so that created points will be given a null height value.

linetype box 1 valid linestyles

this field can be recognised by the linestyle icon button on the right hand side of the field. The user 
can select a valid linestyle by selecting the linestyle icon

weight box

this field allows the user to type in a line weight for the cad item created

button

the Tinable field sets whether the vertices and segments are tinable (used in triangulations), not 
tinable (not used in triangulations) or only the vertices (points) are tinable.

button

the eye dropper allows the user to select an existing element which will define the cad control bar 
values.
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The CAD options are available from the CAD toolbar or from the CAD menu under Strings.

When options are chosen from the CAD Toolbar, help messages are written to the Screen Message Box at 
the bottom of the 12d Model screen. Since there is no panel or menu involved with the CAD toolbar 
options, there is nowhere for an F1 key to function for on-line help. 

Hence all the CAD options are documented under each of the walk-right menus for the

 Strings  =>CAD menu.

CAD Toolbar

Strings => CAD menu
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CAD Text Toolbar and Text Controlbar
The various Text options are:

Text can occur as a text string, on vertices of a 4d string, and on vertices and segments of a super string. 
Each type of text has a vertex (these are displayed when Vertices are toggled on in a plan view), a 
justification point, a rotation, an offset and a raise value. The vertex and justification point only coincide if 
the offset and raise values are both zero. All text on a 4d string must have the same height, colour, angle, 
offset and raise. Each part of the text on a super string vertex segment can be independently modified 
depending on the settings for the super string.

For text options, the created elements will have attributes as defined by the Text Control Bar. This control 
bar is placed at the top right of the screen under the main menu control bar on the creation of a project

The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

Textstyle data box 

On pressing the button a list of available textdata with predefined names read from the 
texstyle_names.4d file are displayed.  

CAD Text Toolbar

Strings =>CAD =>Text menu
Text Controlbar



Chapter 3  Basic Operations

February 2007 Page 31

If you require a different textsyle, the user can edit the current settings by selecting the edit button to 
bring up the textstyle data panel. This allows for definition of textstyle, units, height offset raise etc.

textstyle box 1 available textstyles

the user can select an existing textstyle by selecting the textstyle icon or entering a value into the input 
box to the left of the button. 
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text height box 10

the user can measure a height by selecting the text height icon or entering a value into the input box to 
the left of the button. The value units are defaulted to world units. This can be changed in the textstyle 
data box
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Symbol Controlbar
The Symbol Controlbar is normally at the top right of the 12d Model screen.

Users can define their own symbols to draw at vertices of 12d Model strings. The definition of symbols are 
stored in a file called symbols.4d.

The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

Symbol data box 

On pressing the button a list of available symbols with predefined names read from the symbols.4d file 
are displayed. 

Symbol Control toolbar

If you require a 
different symbol, the 
user can edit the 
current settings by 
selecting the edit 
button to bring up the 
Symbol Information 
panel. This allows for 
definition of symbol, 
colour, size, rotation, 
offset and raise.
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Snaps Toolbar
The Snaps Toolbar is normally at the top right hand corner of the 12d Model screen.

Snaps are used when picking strings - see Chapter 7.4 ’Snap Settings’.

3.6 Status Bar
The Status Bar is an optional part of your desktop. It appears at the base of your desktop. The Status Bar 
contains the Screen Message Box and the View Coordinates Box. It is strongly recommended that you 
keep it turned ON. 

If desired, the Status Bar may be turned OFF at any time. From the View drop down menu bar, click LB on 
View, untick the Status Bar checkbox. To turn it back ON, repeat the selection but this time tick the 
checkbox.

3.7 Screen Message Box
The Screen Message Box contains messages that help you interact with the 12d menus. For instance, when 
importing a DWG/DXF/DXB file as shown previously, you have to select a file name to read. Let us 
investigate the messages 12d gives us to help us with this simple operation. 

If the DWG/DXF/DXB Data panel is not already showing, select it again as shown previously. Click in the 
‘File’ name entry data field. Observe that the following response appears in the Screen Message Box

File [Caret][Same As][Menu] select a button

You interpret this help message as follows. 12d is asking you to supply a file name. The three sets of 
square brackets [ ] correspond to your response via the three mouse buttons, LB, MB and RB. 

The LB message ‘Caret’ indicates the position of the cursor if you want to type an answer using the 
keyboard. 

To type an answer, you must first make sure that the cursor is locked onto the field you wish to modify. 
The cursor must appear as a flashing vertical bar before 12d will accept any data from the keyboard. You 
can reposition the caret anywhere in the existing word by using the LB. You could then edit it by using the 
‘Backspace’ key. Alternatively you can use the ‘Delete’ key to delete the character to the right of the 
cursor or the Arrow keys to move within the word. The ‘Home’ and ‘End’ keys take you to either end of 
the existing entry. To delete the entire entry, double click anywhere in the text to highlight it. Then press 
the delete key to erase the entry or just start typing to replace it.

The MB message ‘Same As’ indicates that you can point at any existing item on your desktop. This would 
not normally be used for a file name. 

The RB message ‘Menu’ puts up a menu. At this time, no items are available. If another filename was 
copied to the windows clipboard then the ‘Paste’ would be highlighted.

Or finally, you can click LB on the folder icon to locate the required file

The Screen Message Box area changes dynamically with the position of the cursor on the screen so watch 
it closely for helpful messages.

3.8 View Coordinates Box
Note the location of the View Coordinates Box at the bottom right of the desktop. This box displays the X-
Y coordinates of the cursor when in a Plan view and Chainage-Height when in a Section view.

3.9 The Output Window

Snaps toolbar
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Unlike previous versions, the Output Window by default no longer appears as a full desktop width white 
background window just above the Status Bar, but instead appears as a tab at the bottom left of the screen 
and flashes if there are any messages that need to be reviewed. This Window can be pinned to your 
desktop, but to maximise use of your desktop for 12d views etc., it is best to leave it as is. You can also  
convert the output window to a view, just like a 12d View. 

To turn the Output Window OFF at any time, you need to access the menu bar that appears across the top 
of your desktop. From the Window Drop Down menu bar, click LB on Window, untick the Output 
Window checkbox. To turn it back ON, repeat the selection but this time tick the checkbox.

To make the Output Window appear as a normal  Window on you desktop, place the cursor anywhere over 
the ‘white’ background area of the Output Window and click RB. In the pop up menu, click on the 
Convert to Window menu with the LB. The command Window will then appear somewhere on your 
desktop as a Window. It may be moved by clicking LB in the blue Output Window heading area, dragging 
the cursor to another part of your desktop and releasing the LB to pin it down. 

If you wish to close the "floating" Output Window just click on the            as you would with any other 
view.  

There are three view types available in 12d. They are Plan, Section and Perspective. It is possible to have 
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multiple plan, section and perspective views on the desktop at one time, each showing different 
information. There is no limit to the number of views you may create.

Each View has a View type and name such as ‘Plan 1’, ‘Section 2’ etc. The name appear in the View Title 
Area. This is the blue heading at the top of each view. Just below the name is the View Button Area which 
contains the most common View buttons (i.e. a subset of the complete list of view options). The View 
buttons appears horizontally after the view name. The View Button Area appears automatically with each 
view as the view is created and each view type has different view buttons that reflect it’s characteristics. 
The view name defaults to a number but can be over typed with any alphanumerics.

The view buttons on the Plan view are:

Each view also has its own menu (the view menu) which can be brought up by clicking the LB on the view 
button called ’Menu’.

The View menus can also be brought up in another special way:

if you click the RB in the View Button Area or the View Title Area, you will also get the View menu to 
pop up. Clicking RB again in the View Button Area or the View Title Area will remove the view menu.

So by using the RB, view menus can be accessed even if the ’Menu’ item is not visible in the View Button 
Area.

The View menu contain options available for that particular view type. It is a superset of the buttons that 
appear on the horizontal View Button Area. If the View is made very small or moved off the right hand 
side of the desktop, the various buttons on the horizontal View Button Area will not be selectable as they 
will not be visible. In such case, you have to use the RB in the View Button Area to get access to the 
various View menu items.

Views may be created, resized, overlapped, moved and deleted as required. When you create a view, 12d 
will automatically supply it an ascending number for reference purposes e.g. ‘Section 2’. Views can 
overlap Menus and Panels that are already on the desktop.

Hence there are four menu systems in 12d, one for each view type (plan, section and perspective) and an 
overall main menu.

Plan view buttons

Menu Fit
Pan

Zoom

Shrink

       Toggle

     Refresh
     PlotAdd

Remove
         Previous
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3.10 Basic View Operations
We will now practice some basic View operations

To create a new View, select Views=>New=>Plan from the main menu to create a view with the next 
view number.

Alternatively, you can use Views=>Create=>Plan View. Pick Create with the LB after first supplying a 
View name or accepting the ‘number’ supplied by 12d as the View name.

Once the View is on display, the following operations can be performed from the View Button Area at the 
‘top’ of the View. To move a View to a new location on your desktop, depress the LB in the View Title 
Area – the ‘blue’ area showing the words ‘Plan 1’. Whilst you still have the mouse button depressed, drag 
the mouse and you will see the View move. ‘Pin’ the View again by releasing the LB.

Use the standard Windows features to change the size of the View. Place the cursor near any corner or 
midside of the existing plan view and when the drag arrows popup, depress and hold down the LB and 
drag the mouse to see the Window size change. Pin the new location of the corner by releasing the LB.

To delete a View just click LB on the ‘X’ button in the top right hand corner of the view. You can also 
delete a view by clicking LB on the Menu button in the View Button area to popup the View menu and 
then click LB on Delete.

For the purpose of the tutorial, leave one large Plan View ‘1’ on the desktop. We will subsequently 
demonstrate how the various views are linked. Information in a Plan view can also appear in Section and 
Perspective views for instance.

3.11 Introduction to Models
Models are a 12d concept also present in most CAD systems. It is similar for instance to the layering 
concept in IntelliCAD and AutoCAD, or level in Microstation. Basically each Model represents a 
repository for data. Each point or line that is created or imported into 12d is put into a Model. By turning 
Models ‘On’ and ‘Off’, it is possible to change the amount of information that is displayed. This control is 
provided in each View so it is possible to have different Models on display in different Views.

It is important to note that the data in the various models is always permanently stored in 12d. It is a user 
controlled convention to only show a subset of models at any one time.

There is no limit to the number of models used in any one 12d Project.

If you want multiple copies of a certain line (i.e. string), it is possible for instance to copy the line from one 
Model to another. The lines can then be displayed independently. If both Models were on at once, the 
information will appear as one line instead of two since the strings are coincident. It is possible to 
selectively snap to and edit either line in such a case.

At any time, individual Models can be Renamed, Duplicated, Cleared (removes all points and lines but 
the name of the model is retained) or Deleted. 

Models can be temporarily Removed (from selection lists) and subsequently reinstated through the Add 
function. 

It is also possible to copy models between projects (See Models=>Utilities=>Copy Project Models). 
These are advanced features of 12d that we need not concern ourselves with at this time.

3.12 Introduction to Strings
12d is very much a ‘strings’ rather than ‘points’ based system. In it’s simplest form, a string is a line 
between two points or vertices. In fact a single vertex is also a special type of string known as a ‘point 
string’. A string may be made up of multiple straight line segments connecting many points (vertices). 
Strings may contain curves and arcs as well as straight lines. Strings vary in complexity from 2d (x,y and 
constant z value) to multidimensional (e.g. an alignment string has both horizontal and vertical geometry 
independently defined). In general, as well as x, y and z values, strings have properties such as string 
name, string type, string colour, line style, and chainage. Strings also have a ‘point/line’ property that can 
be set such that they appear as ‘disconnected points’ or ‘connected lines’. From a design point of view, 
strings are much more useful than points. 
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3.13 Introduction to Panels
A panel is simply a means of supplying multiple answers to 12d in a concise manner. Once a panel appears 
on the desktop, you can use the mouse or the Tab and BackTab keys to position the cursor over any data 
field. Remember, when typing data from the keyboard, the cursor must be flashing in the data field for 
characters to be accepted. 

When supplying data to a 12d panel, you do not need to terminate the entry of data into a field by pressing 
the Enter key. For instance, you can use the Tab and BackTab keys or the mouse to move to another field 
after entering data. If you do press the Enter key to terminate the entry of data into a field, 12d will 
immediately validate the data in that field and supply an error message if appropriate. 

When validating 12d supplied or previously entered data in other words, where you do not need to change 
the data in a field - it is not necessary to place the cursor in the data field. Just press the Enter key to pass 
through each field in the panel in turn. 

When typing data into a field, please observe that the ‘Delete’ key deletes a single character to the right of 
the cursor. The ‘Backspace’ key is also active. If you need to delete multiple characters, drag the LB across 
the characters to highlight them (or double click over a word) and press the ‘Delete’ key to delete them or 
start typing to replace them.

In general, 12d has been setup so that data can be selected from lists rather than typed from the keyboard. 
When entering data into a field, if there is a list of alternatives already known to 12d, pressing the LB at the 
icon the end of the field will display the list.

To practice this, bring up the ‘Read xyzs Data’ panel - .from the Main menu, click LB on 

File I/O =>Data Input =>xyzs

Set the ‘Default line colour’ in the above panel to ‘dark green’ by clicking LB on the colour icon (the little 
white box to the right of the word ‘white’ in the fourth data field). A list of available colours will pop up. 
Use the mouse to click LB on ‘dark green’ and then process it by clicking LB on the Select button at the 
base of the panel.

click LB on the colour icon to bring up the list of 
colours

colour 
icon
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Alternatives: You can double click LB on ‘dark green’ to short-cut this sequence. You could also have 
used the down arrow key to work your way down through the list to highlight the word ‘dark green’ and 
then pressed the Enter key.

In a manner similar to the colour panel field just discussed, most panel fields have a pop-up list of choices 
available and the list is activated by clicking on the icon at the right hand end of the panel field. Some 
times there will be a special icon such as the ’colour’ icon in the previous example or the file box icon at 
the end of the ’File’ field of the Read DWG/DXF Data panel.

Other icons that may be used are:

Note the message area at the base of the panel (just above the Read button in the ’Read xyzs Data’ panel). 
Each panel has its own message area to help you interact with 12d. If 12d does not appear to be working 
the way you think it should, you will often get helpful information in the Panel Message area if you make 
a mistake. Look in the Screen Message Box as well as it is also updated when interacting with panels.

If a panel is in the way, you can move it as stated above. Any panel can be removed (shut down) by 
clicking LB on the ‘X’ button in the top right hand corner or by clicking on the Finish button. 

If you want to keep a panel that is already filled in such that you can refer to it later, you may decide to 
temporarily minimise it by clicking LB on the ‘-‘ button. It can later be maximised again by clicking LB on 
the ‘overlapping windows’ button (where the ‘-‘ used to be).

As we don’t wish to proceed further with this panel click LB on Finish or click LB on the ‘X’  button in the 

message area

choice
icons

choicemodel

file tin textstyle info

line weight

colour colour when
none selected

view

line style polygon symbol
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top right hand corner of the panel.
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4 12d Model Help
The 12d Help can be accessed by selecting 12d Model on the Help menu item on the main 12d Model 
menu.

 

Alternatively, individual topics for a panel or menu can be invoked by using the F1 key or the Help button 
on any 12d Model panel.

More information on the Help system will now be given.

Contents
The Contents allows you to look at the overall structure of the Help and access any part of it.

Warning - only topics in the Help can be accessed through the Contents list so any folders in the Content 
folders must be expanded until topics are displayed. Topics can be easily identified because they have a 
question mark beside them indicating that Help is available.

For example, double clicking on ’Tools and Concepts’ expands the next level of ’Tools and Contents’.

Help on Microsoft’s help system
12d Model help
12d macro programming language help

links to web site www.12d.com
12d Model modules authorized
email details of your 12d Model to 12D Solutions
dongle testing panel



12d Model

Page 42 February 2007Contents

Double clicking on the topic ’Picking Strings’ will then display the topic.

The Contents then disappear leaving Help open at the selected topic.

Double clicking on ’Contents’ on the top of the Help will bring the Contents listing back up.
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Index
The Index option searches through all entries in the Index of the Help.

As the first few characters of the required entry are typed in, the matching index entries are displayed.

Double clicking on the displayed entries will go to the topic in the Help containing the selected index 
entry. If more than one topic includes the index entry, then the list of topics is displayed.

If the index has sub-indices, they can be searched by first typing in the main index followed by a comma, 
then a space and the first few characters of the sub-index.
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Find
The most powerful searching method for the Help system is Find. 

Simply click on the Find tab to search for words or phrases that may be contained in a Help topic.

If Find is being invoked for the first time, the ’Find Setup Wizard’ runs to create an index of every word in 
the Help.

From then on, selecting the Find tab goes straight to the Find screen.
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Panel Help Button
Every panel has a Help button which when selected goes to the topic describing that panel.

Help button to go
directly to the Help
topic for the panel.



12d Model

Page 46 February 2007F1 Key

F1 Key
Another method of invoking Help is by using the F1 key as follows: 

when a menu or panel is on the screen and has focus (the menu or panel title area will be highlighted), 
pressing F1 will bring up the help for that menu or panel.

Warning - some of the items on the Strings menu automatically start up a string select and change the 
focus from the panel to a View. This means that pressing F1 will bring up the Help for the View and not the 
Help for the panel. 

To get Help for such a panel, click on the panel to bring the focus back to the panel before pressing F1. The 
top of the panel will highlight showing that it has focus.

Navigating in Help
Once at a topic in the Help, the <<  and  >> buttons at the top of the Help topic will go to the previous 
and next Help topics respectively. 

Individual Help topics can be printed by clicking Print at the top of the Help page.

Because it is difficult to print large sections of Microsoft’s Help system, a PDF file of the entire 12d Model 
Reference Manual has been created and can be used to print out large sections of the manual.

The 12d Model Reference Manual PDF file is on the 12d Model 8 Installation CD in the folder 
Documentation\Reference_Manual.

go back one topic go to next topic
print the
current topic
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5 Starting the Tutorial
Before starting your tutorial, it is assumed that your overall desktop layout is as shown in Chapter 4.3,  i.e. 
one large plan view on display called ‘Plan 1’.

5.1 Importing Point Data into 12d
The easiest way to understand the use of Models and Panels is to import some data into 12d and see by 
example.

Point and Line data can be imported into 12d from a variety of sources. For the purposes of the tutorial, we 
will use the simplest of these - a simple ASCII file containing point number, x, y and z coordinates along 
with a code.

We will begin by reading in a Points file called ‘DETAIL SURVEY.dat’.

 

The format is one point per line containing a point number, x, y and z coordinate, string name and string 
number all separated by commas. 
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To read in the file, click LB on File I/O =>Data Input =>x y z general from the Main menu. 

12d gives you the ability to fill in 
this panel once and then save the 
setup to a parameter file.  This 
allows you, on subsequent 
occasions, to call up the parameter 
file and then you only need select the 
data to be read.

To make things easier we have 
already created a parameter file and 
stored it in the user library.

Click on the folder icon at the end of 
the Parameter file field.

A blank folder panel will pop up, but 
if you walk right on the [User Lib] 
directory at the bottom of the panel 
you will see the file 
PtNo,X,Y,Z,Str,StrNo.xyf  

Double click on the file and click on 
the Read icon to read it into the Read 
X Y Z General File panel.
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Your Plan View should now look as follows

You will now notice that the panel 
fills in most of the fields once the 
paramater file is read in.  However, 
you still need to set two fields 
yourself.  Firstly, the parameter file is 
a general file to read in comma 
delimitered data with the Point 
Number, X Coord, Y Coord, Z Value, 
String Name and String Number 
format, so we therefore need to select 
the data to be read in.  

Click on the folder icon next to the 
File  field and select the file DETAIL 
SURVEY.DAT

Next select the icon next to the 
Default text style field and select any 
textstyle.  As we have no text in our 
data, the default textstyle is 
unimportant.

Finally click on the icon at the end of 
Add to view field and select 1.  This 
will automatically add all the data in 
the Default model - unknown - onto 
view number 1.

Your finished panel should now look 
as shown. 

Click on the Read button at the bottom 
of the panel to read the data into 12d.
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You will notice that all of the data has been imported into ‘Plan 1’ in the model ‘unknown’ and that the line-
strings appear green in colour and the point-strings are brown as set in the import panel. 
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5.2 Plan View Operations
Now that we have some data, we can begin to look at some more of the Plan view features of 12d. 

Bring up the Plan view Menu.

In the Plan View Button Area, you will observe a ‘+’ and ‘-‘. This is a shorthand technique for turning 
models on and off. 

Remember in our View so far, we have just one model - ‘unknown’. At this stage it is on display.

Click on the ‘-’ sign button with LB. A list of available models to remove from the view pops up. Pick 
‘unknown’ and click LB on ‘Select’. You will observe the lines and points (crosses) in model ‘unknown’ 
are removed from the view. The ‘+‘ works in a similar way to add models to the View. Practice adding and 
removing models from the view with the + and -. Remember, the models are not being deleted with the ‘-‘, 
merely removed from the current View. Leave the View with ‘unknown’ on display.

After multiple pans and zooms, you sometimes wish to return to a point where all of your data appears in 
the view. This is equivalent to an AutoCAD Zoom-Extents. Click on Fit with LB to see all of your data.

This facility allows you to move the centre of the view but retain the current zoom factor. Click on Pan 
with LB. You then press down LB on a point in the View and then drag the mouse. The data in the view 
will move with the mouse until LB is released.

Select Zoom (to Zoom In) from the Plan View Button area with LB. Click LB on two diagonal points of a 
rectangle and then click LB once anywhere in the plan view. The information will appear enlarged based 
on the size of the rectangle.

If your mouse has a wheel as part of the middle button, then it can be used to dynamically zoom in or out. 
Simply click LB in the plan view at the point you want to zoom about and then roll the wheel forward to 
zoom in and backwards to zoom out.

This is equivalent to Zoom Out. It works just like Zoom but in reverse.

Menu

Adding/removing models

Fit

Dynamic Pan

Zoom

MB Wheel Zoom

Shrink

Previous
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If you click LB on Previous, the view will appear as it was prior to the Zoom. 12d always keeps the details 
of the previous view setting available so that you can return to it quickly. Only one level of previous view 
settings is kept.

There are multiple items under the Toggle Pop Up menu. At this time, we will try only one of them. Select 
Grid with the LB. A rectangular grid should appear. If you click LB on Toggle =>Grid again, the Grid 
will be removed from the display.
The appearance of the grid can be changed by clicking LB on the Menu button in the View Button Area 
and click LB on Settings =>Grid. You can change any of the settings in the panel. Try changing the grid 
spacing from 100 to 10 in both x and y directions and click LB on Set. You will notice that the Grid can be 
turned on and off from either the panel settings or the Toggle =>Grid switch. Click LB on Finish to 
terminate the panel.

All the information on the view will be redrawn. This can also be achieved by clicking MB anywhere in 
the View Title Area or anywhere in the View Button Area except over the ’+’ or ’-’ buttons.

Bring up the Plan view Plot Menu.

Toggle

Refresh

Plot
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5.3 Birds-Eye Views and ‘Throwing’ Between Views
We saw in Chapter 3.10 ’Basic View Operations’ how to create a new View. To introduce some new 
concepts in 12d, we need a second small Plan view on the desktop. Firstly resize your existing ‘Plan 1’ 
view to take up around 2/3 of the right hand side of your desktop.

From the main menu, click LB on Views=>New=>Plan and place a small view about 50mm square in the 
top left hand corner of your desktop. This will create View ‘Plan 2’. See Chapter 3.10 for full details on 
how to create and resize Views. 

Note that when creating a View using Views=>Create=>Plan View, 12d pops up the ‘New Plan View’ 
panel. The View Name field will already have a ‘number’ in it supplied by 12d. 12d will always supply 
you a View number that is not currently in use. If you want, you can overtype the number suggested by 12d 
provided the number you type does not currently exist (it may have been created earlier and then been 
deleted. It is OK to reuse a previous number). 

In the View ‘Plan 2’, use the ‘+’ sign button to display the ‘unknown’ model. From the ‘Plan 2’ View 
Button area, click LB on Zoom and click a point in the lower left corner of the View ‘Plan 2’. Before 
selecting the second point of the Zoom rectangle, move the cursor into the other View i.e. ‘Plan 1’.

Select the second point of the Zoom rectangle in either View. After selecting the second point of the Zoom 
rectangle, you will notice the following prompt in the View Message Box

<View Zoom>[Select][Dynamc][Cancel]Select Destination View - RB to cancel D toggles dynamic

12d is prompting you to select the View you want ‘zoomed’. Click LB in View ‘Plan 1’. The zooming will 
then take effect in View ‘Plan 1’.
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Notice that using this technique, it is possible to achieve a birds-eye effect where the smaller View displays 
the complete model whilst the larger ‘working’ view is zoomed to an extent where it displays only the 
detail that you are currently working on. You would typically do all of your zooming in View ‘Plan 2’ but 
have the detail updated in View ‘Plan 1’. You could even do this with different models turned on. In the 
birds-eye view, you would typically only turn on sufficient detail to enable you to zoom on known 
features.

It is suggested you practice zooming and throwing between Views as this is a powerful concept in 12d and 
you should feel comfortable at using it.

After completing this exercise, delete View ‘Plan 2’ as it is no longer needed. You will now see a second 
way to delete a View. Click LB in the View Menu button in the View Button Area of ’Plan 2’ and select 
Delete and Yes to confirm the deletion. The Delete View menu can also be brought up by clicking LB on 
the Menu button in the View Button Area of the View you wish to delete and select Delete and Yes to 
confirm the deletion.

It is suggested that you move View ‘Plan 1’ to the upper left corner of your desktop. Make the ‘Plan 1’ 
view fill the desktop by dragging the border. To do this, click and hold the LB somewhere near the lower 
right corner of the View to pick up the corner. Drag the mouse to stretch the View out to the lower right 
corner of your desktop and release the LB to set the new size of the view.
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5.4 Deleting a Model
As we now wish to proceed to better ways of importing data into 12d, we need to delete the model  
‘unknown’ as it is no longer required.

From the Main menu, click with LB on Models=>Delete=>Delete a model

5.5 Redraw - Fixing up a Modified or Erroneous View
Whenever data is removed from a View e.g. turning off the display of a model, the view does not 
automatically get refreshed. 12d typically removes a model by overdrawing the information using the 
background colour, usually ‘black’. This operation can leave the view looking speckled and unclear. 

You can force the view to refresh by clicking LB on the Refresh button, or click MB in the View Button 
Area anywhere other than over the ‘+’ or ‘-‘ view buttons. The whole View will be repainted instantly to 
display the corrected information. 

It is also possible that some of the menus may at times become corrupted. Windows is a very complex 
multitasking environment and the menus are stored in memory which is being updated continuously. If you 
ever get parts of your desktop that don’t look correct, you can force your entire desktop (all menus, views 
etc.) to be refreshed by typing Control-R at any time. Alternatively you can refresh just any one Menu by 
clicking MB in the menu title area.

5.6 View Coordinates Box
Note the location of the View Coordinates Box at the bottom of the desktop. If you move the cursor around 
in the Plan View area, you will notice that the x and y values are changing continuously. The values shown 
are those at the tip of the cursor. They are updated with every cursor movement. 

5.7 Work Book Mode
The 12d Desktop has various optional displays. One of those is Work Book Mode. In this mode, tabs are 
displayed on a bar just above the Status Bar at the bottom of your desktop. If you have the Output Window 
in the default position (across the base of your desktop), the tabs bar is displayed just above the Output 
Window.

Each tab corresponds to a 12d View. To set any 12d view as your active view just click LB on the 
appropriate Tab. Note that when a view is active, the View title highlights in blue.

Click LB on the Model field button to pop up a list of 
models to delete. Click on ‘unknown’ with LB.

Click LB on Delete and then Yes twice to confirm the 
deletion
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5.8 Saving a Project
The changes to the Project you are working on are currently only stored in memory. To make the changes 
permanent and update your files on disk you need to Save the Project. This can be done at any time by 
clicking LB on Save from the Projects Menu (Project =>Save).

12d will occasionally pop up a panel reminding you ‘Do you want to save the project? Click on Yes with 
LB to force a Save to occur. The timing at which this message appears is set from the Main menu in 
Project =>Management =>Defaults. See the data field ‘Save Interval (min)’ under the ‘System Settings’ 
tab. 

The default is every 15 minutes. You can set the time interval to zero to turn this feature off altogether.

If you ever crash out of 12d due to a power failure for instance, any changes since your last Save operation 
will be lost. 

5.9 Exit 
To terminate a 12d session, click LB on Exit from the Project menu (Project =>Exit). If you try to Exit 
12d after changes have been made to your Project, 12d will remind you of the changes by prompting you 
for a further Save operation. 

5.10 Restarting 12d with an Existing Project
When you restart 12d and return to an existing project, the appearance of the desktop will be just as you 
last left it. The number of Views, appearance of all models and user defined parameters are redisplayed 
using the settings that are stored with the Project data.

The next time you start 12d, 
the project ’Stage 1’ will 
appear in the previous projects 
list. 

Double clicking LB on ’Stage 
1’ in the list will take you into 
the project  ’Stage 1’.

previous projects list
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Alternatively, if you navigate to the folder containing the project ’Stage 
1’, you will automatically get a pop up list of all available projects in 
that folder to select from. 

Click LB on ‘Stage 1’ to highlight it and then click LB on the Select 
button. Alternatively, you can double click on ‘Stage 1’ to bypass the 
Select button.

If you have trouble restarting 12d, remember you called this Project 
‘Stage 1’. See Chapter 3.2 to remind yourself how to start 12d.



12d Model Getting Started and Training Manual

Page 58 February 2007



Chapter 6  Basic Modelling

February 2007 Page 59

6 Basic Modelling

6.1 Use of the Mapping File (.mf) and Linestyles
We will now repeat the process of importing data into 12d but this time we will use a mapping file to make 
12d place the information into a more convenient form for final design.

The previously created model has been deleted. We will import the file ‘DETAIL SURVEY.DAT’. To read 
in the file, click LB on File I/O=>Data Input=>x y z general from the Main menu. 

This time we are not automatically adding the data to a view as this feature only adds the Default model to 
the view.  However, the mapping file gives us the opportunity to import the point and line data into 
particular models with their own linestyles and colours.  To open the Mapping File click on the folder icon 
next to the Map file field and click on [Edit]. 

For instance, the entry in the mapping file for entity label ‘CG’ reads

In Chapter 5.1 we used the parameter file 
‘PtNo,x,y,z,Str,StrNo.xyf’, Recall this file 
by clicking on the folder icon to the right of 
the Parameter file field and selecting it 
from the list.  Click on the read button          
to fill in the panel.

You will still need to fill in some of the fields 
so click LB on the ’folder’ button at the right 
end of the File data field to popup a list of 
files. Double click LB on file ‘DETAIL 
SURVEY.dat’. This file has both points and 
strings with coding. A typical string code in 
the file is ‘CG’ for Change of grade.

This time, we will import the data using a 
mapping (mf) file. Use LB on the folder 
button for the Map file field.  You will 
notice that the pop up box is empty.  
However, if you walk right on the User Lib 
menu at the bottom of the panel, you can 
select the ‘DETAIL SURVEY.mf’ file.  We 
keep our map file, together with title blocks 
etc., in the library so that we can access them 
easily from all projects. 

A model prefix ‘survey ’ is typed in to group 
the survey models away from the future 
design models. Ensure that you place a 
<space> after the ‘survey’ so that the model 
names do not run together.

Any data not coded correctly will be placed 
in the Default model ‘unknown’

Click on Read to read the data into 12d 
Model.
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The CG string will be imported with a string name of CG, be placed in the model ‘TOPO CHANGE 
GRADE’, appear as an orange line with a dashed line style (DS BB). This is a user defined linestyle that 
will be used in the final plotted drawings. Note that in this file all line styles are in upper case to make them 
compatible with the line styles typically used in CAD programs.

Click LB on Finish to exit the Map file panel.

To see the various features that have just been created, we now need to add multiple models to the view. 
The easiest way to do this is to click LB on the ‘+’ sign button in the View Button Area to pop up the 
Models to Add panel.

6.2 Saving model listing to a file for future use
 We will now perform a function that is only meaningful later on when we are manipulating TINs. First we 
need to click on the ‘Plan 1’ view tab such that Plan View 1 is now our focus. The heading in view ‘Plan 1’ 
should appear coloured bright blue and it should be to the forefront.

The current thirteen models on the view are exactly the models that are used to create the ’natural surface’ 
tin. We will now see how to record these models in a form that can be used in the future to restore those 
same models to another view.

Click LB in the panel title area (over the words 
Models to Add), move the panel and repin it with LB 
so that it doesn’t collapse after each selection.

Now double click LB on each model in turn and watch 
them appear in view ‘Plan 1’. Leave the model 
‘unknown’ inactive

 Click LB on ‘X’  to shut down the panel.

Clearly by using the mapping file, we have seen how 
the information in each model can now be 
manipulated independently.
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From the Main menu click LB on View=>Models Save/Restore

This file can be read at any future time by use of the Restore option. This will add the same models to a 
view which need not necessarily view ’Plan1’. 

Type in the file name survey. Pressing 
[Enter] will add the extension .vml

Click LB on the view icon then select 
view 1

Click LB on Save

Click LB on Finish to exit the panel
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6.3 Triangulation
We will now use this point and line information to create a 3d surface or TIN (Triangulated Irregular 
Network). One of the concepts in 12d is that a TIN can be created from a single Model or a single View. In 
general, you will use Views to create models since you can control which models are on display in a View. 
It is important to understand that when creating a TIN from a View, only those models on display in the 
View will be used in creating the TIN and only then if they are set to be tinable in the map file. For 
instance, if you were forming a TIN to represent the natural surface, you could leave turned ON any 
models that represented underground surfaces prior to creating the TIN, because in the mapping file they 
would be set to be non tinable.

When using a mapping file to read in data, strings can be flagged as being tinable (Breaklines) or non-
tinable. Only tinable strings are used in the triangulation. Breaklines are used to pick up the topographical 
features accurately. When forming triangles, 12d ensures that every breakline has the sides of one or more 
triangles along the entire breakline i.e. triangles never cross breaklines (unless the breaklines themselves 
cross).

For the purposes of the ongoing tutorial, please ensure that all models in view ‘Plan 1’ are on display prior 
to creating the TIN. ‘Plan 1’ should look as shown above.
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From the Main menu, click LB on 
Tins=>Create=>Triangulate data 

The following panel pops up.

Fill in the first tab of the panel as shown.

The Retriangulate function option is used to construct a 
function which, when recalculated, will run a 
retriangulation on the tin. Place the cursor in the data 
field with the LB and type ‘TIN GROUND’

Each TIN requires a name. Position the cursor in the 
New tin name field and type in ‘GROUND’. If you press 
the Enter key, this name will also be used to fill in the 
Model for tin field but with the prefix ‘tin ’ (see panel). 
The TIN name is subsequently used to refer to this 
specific TIN.

Position the cursor in the ‘Model for Tin field’ and type 
in the suffix ‘,1’ after the name so that the model is 
displayed as the TIN is created. It is permissible to 
overtype this name but this is not recommended. 

Click on the Nulling tab.

Click on the Apply Nulling check mark.

There are two options here, you can either set the 
parameters to null the external triangles or you can use a 
polygon to null all triangles outside this polygon.  The 
DTMBDY string will be used as the boundary for the tin. 
Click LB on the Null polygon string icon then click LB 
on the DTMBDY string followed  by clicking middle 
button (MB) to accept the string.

Click LB on Triangulate to create the TIN. There will be 
a short delay and then your TIN will be created and on 
display as shown below.

 Click LB on Finish to terminate the panel. 

Click on the Data tab.

As we wish to triangulate all the data in plan view 1 and 
leave the mapping file to determine which data to use, 
click LB on the view         icon.  Select ‘1’ from the list. 
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Note that the TIN is clipped at the selected null polygon ensuring only the surveyed data is included. Now 
that we have a TIN we can display the TIN data in a variety of ways
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6.4 Tin inquire.

Click LB in the menu title area (where it says Tin Inquire), move the menu and 
Pin it with the LB. This operation is necessary to stop the menu from collapsing 
after the first menu pick.

Click LB on Aspect, and the Tin Aspect Inquire panel will pop up.

Move the cursor over the Tin icon button at right end of the 
‘Tin’ field and use the LB to pop up a list of Tins. Double 
click LB on GROUND. Then click LB in the menu title 
area (where it says Tin Aspect Inquire), move the panel to a 
clear area of your screen and pin it with the LB. Do not 
Click on the Finish button in the panel.

Repeat this procedure with both the Height and Slope menu 
items.

Once all three panels are on the screen, move the cursor 
anywhere over the TIN and observe what happens. When the 
cursor is positioned over any one triangle, the three point 
coordinates of the triangle are being used to linearly 
interpolate ‘on the fly’ to calculate the exact x,y,z coordinates 
of the cursor. Also the aspect and slope of the triangle is 
shown in the respective panels.

From the Main menu, click LB on Tins=>Inquire and the Tin Inquire panel pops up.

Click LB on Finish on all three panels to put them away. Also click LB on  ‘X’  on the Tin Inquire menu to 
shut it down. 

We will now look at the various ways information in TINs can be viewed.
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6.5 ‘Fast’ Contours
We now want to remove all of the models from the View except ‘tin GROUND’. From the View menu (in 
the View Button area), click LB on the ‘-‘ sign to pop up the Models to Remove panel. 

 

Click LB in the panel title area (over the words Models to 
Remove), move the panel and repin it with LB so that it 
doesn’t collapse after each selection.

Now click the LB on the first survey model.  Drag the mouse 
down the list to highlight all the survey models and click on 
‘Select’. Alternatively, you could double click LB on each 
model in turn except ‘tin natural surface’. Click LB on ‘X’  to 
shut down the panel.

Now from the View 
buttons, click LB on 
the Toggle button to 
bring up the Toggle 
menu.

Then click LB on Tin  
contours. You should 
see the following red 
and green contour lines 
appear.
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 If you click Toggle=>Tin contours again, the View will revert to the ‘green triangle’ display. 

The appearance of the contours can be changed by clicking LB on the Menu button in the View Button 
Area. Click LB on Settings=>Tins=>Contours and the following panel will pop up.

At the completion of experimenting it is suggested that you put the settings back to their default values (as 
above) at this time. 

Click LB on Finish to terminate the panel. Your new settings will remain in effect indefinitely until 
changed.

You can change any of the settings in the 
panel including colour. Click LB on the 
colour icon at the right end of the contour 
colour field to see a popup list of available 
colours. Select one by double clicking LB.

Try changing the contour increment (spacing) 
from 1 to 5 and the bold increment from 5 to 
25. Click LB on Set to activate the changes. 
You will notice that the ‘Fast’ contours can be 
turned on and off from either the ‘Draw 
triangles contours’ tick box panel setting or 
the Toggle=>Tin Contours switch.



12d Model Getting Started and Training Manual

Page 68 February 2007

6.6 ‘Fast’ Flow Arrows
It is recommended that you turn on the drainage models for this exercise. From the View menu (in the 
View Button area), click LB on the ‘+‘ sign button and double click LB on ‘survey TOPO BANK 
BOTTOM’, ‘survey TOPO BANK TOP’ and ‘survey TOPO DRAIN CLINE’. Make sure that the ‘tin 
GROUND’ model is also still turned on. The easiest way to confirm this is click LB on the ‘-‘ sign button 
in the View Button Area and look at the list of the models that could be turned off. Click LB on the ‘X’  
button to terminate the list.

Now from the View menu, click LB on Toggle=>Tin contours then Toggle=>Tin edges. The purpose of 
this is to outline each triangle. Then click LB on Toggle=>Tin flow. You should now see an arrow appear 
at the centre of each triangle representing the direction of water flow.

Try zooming in on a section of the model for a closer look. When you have finished zooming, click on Fit 
to again fill the View window.

Click both Toggle=>Tin edges and Toggle=>Tin flow again and the View will revert to the ‘green 
triangle’ display. 

The appearance of the flow arrows can be changed by clicking LB on the Menu button in the View Button 
Area. Click LB on Settings=>Tins=>Flow Arrows and the following panel will pop up.
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Click LB on Set to activate the changes. You will notice that the Flow arrows can be turned on and off 
from either the ‘Draw triangles flow’ tick box panel setting or the Toggle=>Tin Flow switch. 

Click LB on Finish to terminate the panel. Your new settings will remain in effect indefinitely until 
changed (for this project only).

You can change the size of the arrow 
heads and their colour. Click LB on the 
colour icon for the ‘Colour for arrows’ 
field to popup a list of available colours. 
Select one by double clicking LB.

Try changing the arrow length from 10 to 
5 world coordinates (in this case metres). 
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6.7 Perspective View
We will now look at the perspective view facilities in 12d to examine the surface we created above.

Firstly, move your existing Plan view off the right hand side of your screen. Do this by clicking LB at the 
left end of the View Title Area (over the words Plan 1). Move the cursor to the right of your screen and 
you will see the View move. ‘Pin’ the View again by clicking the LB such that just a small section of the 
View is on display.

Now create a new perspective view. Click LB on Views=>New=>Perspective OpenGL from the Main 
menu and a new view pops up. Alternatively by selecting Views=>Create=>Perspective OpenGL view 
from the Main menu, a panel pops up. 

Note the new view is created immediately and is placed over the top of your existing windows.

You should use the standard windows features to ‘Tile’ the views. Click in the view title area for ‘plan 
view 1’ then select Windows=>Tile Vertical

Your overall screen layout should now look something like this.

If necessary, put the cursor in the View 
name field, backspace over the existing 
entry (or use the Delete key) and type ‘2’. 

Click LB on Create. 
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The view buttons on the Perspective view are:

We now need to add the TIN to the perspective view. In the View Button Area of ‘Perspective 2’, click LB 
on the ‘+‘  sign button and double click LB on tin GROUND. Click LB on the Fit icon. Your Perspective 
view should now look as follows

Menu

Fit

Toggle

Refresh

Plot

Add

Remove

Previous

Eye

Walk

Drive

Pan

Window

Shrink Orbit

Joy
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6.8 Joy Panel
The Joy (short for Joystick) provides a quick way of orientating your eye in relation to your data when 
manipulating a Perspective view.

The Joy panel is accessed from the View Buttons Area. Click LB on the Joy button in the View Button 
Area of ‘Perspective OpenGL 2’ and the Joy View panel appears. 

Try clicking LB on In and Out icons 

and observe what is happening. You eye is moving inwards or 
outwards from the data.

Also try Up, Down, Left and Right. icons

If you get lost or zoom in too far, you can always start again by 
clicking LB on Fit in the View Button Area.

The angular step between each up or down step defaults to 15 degrees. You can change this if you want 
smaller increments by entering a new value in the Angular Step field.

Similarly, the Distance changed on each In/Out movement defaults to 100 (metres in our case as all data 
is in metres).

The easiest way to reset a view so that you can see all of the data is to click LB on Fit from the View 
Button Area.
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6.9 Orbit Panel
The Orbit is another way to  orient your eye in relation to your data when manipulating a Perspective view.

The Orbit panel is accessed from the View Buttons Area. Click LB on the Orbit button in the View Button 
Area of ‘Perspective OpenGL 2’ and the Orbit panel appears. 

With the ‘Orbit’ radio button selected use the LB to rotate the image in 
the perspective view.

You can use the middle button wheel at the same time to zoom in and out 
in the perspective view

If you get lost or zoom in too far, you can always start again by clicking 
LB on Fit in the View Button Area.

The easiest way to reset a view so that you can see all of the data is to 
click LB on Fit from the View Button Area.
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6.10 ‘Fast’ Meshes in Perspective view
We will now see how to quickly display the TIN in mesh form. 

From the Perspective View menu, click LB on Toggle=>Tin mesh. You should see a coarse rectangular 
grid of red and green mesh lines appear. 

The appearance of the mesh can be improved by reducing the mesh spacing. Click LB on the Menu button 
in the View Button Area of the ‘Perspective OpenGL 2’ view and then click LB on Settings=> 
Tins=>Mesh. The following panel will pop up.
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When toggled OFF the view will revert to displaying the green triangles. Your revised view should look as 
shown below. 

Click LB on Finish to terminate the Mesh settings panel.

The effect of the creeks superimposed on the TIN is created by turning on the Drainage model. Click LB 
on the ‘+’ sign button in the View Button Area and double click LB on ‘survey TOPO BANK BOTTOM’, 
‘survey TOPO BANK TOP’ and ‘survey TOPO DRAIN CLINE’.

Change the settings to those shown in the panel. 
Change the mesh spacing from 100 to 10 in both 
x and y directions and bold x and y spacing from 
1000 to 100. Click LB on Set to activate the 
settings.

You will notice that the Mesh can be turned ON 
and OFF from either the ‘Draw triangles mesh’ 
tick box in the panel or from the View menu via 
the Toggle=>Tin Mesh switch.
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Note that 12d always displays the models in the order that they are turned on with the ‘+’ and ‘-‘ buttons. 
Thus to get the effect of survey DRAIN Cline (and any other models) superimposed on your TIN, you first 
turn all models off, then turn the TIN on first and then any other models to be superimposed last. Note that 
clicking LB on the Menu button in the View Button Area for ‘Perspective OpenGL 2’ and selecting 
Models=>Remove all models is a fast way to turn all models off.

The above perspective view orientation will stay as set indefinitely unless changed by further Joy or 
equivalent perspective view operations. 
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6.11 Contours in Perspective Views
Sometimes it is useful to display contours in perspective views. You do this from the Toggle button. 
Simply click LB on Toggle=>Tin Contours as before. 

The contour spacing and colours of the Perspective view can be changed just as we did before in the Plan 
view. This time however you would click LB on the Menu button in the View Button Area of the 
‘Perspective Open GL 2’ view. As before then click LB on Settings=>Tins=>Contours. See Chapter 6.5 
for more details.

Click Toggle=>Tin contours again to revert to the ‘green triangles’ display.
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6.12 Shaded Views
It is also useful to view a perspective as a colour shaded view. 12d has the ability to define up to 10,000 
colours and use these to create a flat shaded view. During the shade, 12d will find and use the ‘colours.12d’ 
file supplied with the tutorial. The angle that each triangle makes with the sun (a point light source at 
infinity) is used to click LB on a different shade of green. The angle of the Sun can be varied but 45 
degrees (the default) gives the maximum contrast.

To quickly shade all the TINs on the perspective view, simply click LB on Toggle=>Shade. 

To access the Shade View panel to modify the shade settings, click LB on the Menu button in the View 
Button Area of ‘Perspective OpenGL 2 and then click LB on Settings=>Shade.

Now every time the view is refreshed or the view changed, the shaded view will reappear. 

To get back to a ‘green triangles’ rather than a shaded view, click LB on Toggle=>Shade to toggle the 
shade off. 

Clicking LB in the ‘Shade tins’ field tick box will toggle on and
off the shading. A tick indicates the shade is activated.

Click LB on Set to create the shaded view. All TINs in the view
will be shaded using the faces in order furthest to nearest the 
viewer. This has the effect of removing faces that are hidden 
from view.

Click LB on Finish to terminate the panel.
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7 String Picking Concepts
We will now investigate picking concepts and how the mouse is used to interact with 12d when pointing to 
and selecting items on your screen. Initially, do all picking (i.e. mouse clicking) with the LB. This uses the 
12d Model Tentative pick. Later we will look at Fast picking using MB.

In plan view ‘1’ turn on all the models except the triangulation (tin GROUND).

Zoom in to the left dam. Your overall screen layout including the ‘Plan 1’ view should now look as shown 
below.

Whilst the ‘string picking’ concepts are used throughout 12d, especially during construction of design 
features where we want to connect into existing geometry, we will learn about them by example through 
the relatively simple ‘String Inquire’ feature.
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7.1 String Inquire
String Inquire is used to inquire and view the details of a typical line (i.e. string) that is already present in 
the View. From the Main menu, click LB on Strings=>Inquire to bring up the following panel. 

NOTE: the String Inquire panel can also be brought up by pressing the F2 key. This has been defined in
the standard 12d Model function key short cuts.

Click LB on Pick and then move the cursor anywhere over 
one of the bank strings and click LB.

If you placed the cursor over a line:

If your Snap settings are still set to their 
default values, you should see the line go 
yellow (shown here as red) and a yellow 
(shown cyan) square box appear at the last 
location of your cursor when you clicked 
LB. 

If you placed the cursor over a point 
connecting the line segments: 

If you happened to snap to a point on the 
line rather than the line itself, you will see 
the line go yellow (shown red) and a 
yellow (shown cyan) diamond appear at 
the last location of the cursor when you 
clicked LB.
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The second pick couldn’t find any more strings to snap to (adjacent strings were outside snapping distance) 
and so no more information panels popped up. Instead, a circle showed at the pick location to indicate that 
a ‘snap to the cursor’ location had occurred i.e. the only thing that 12d could find at the pick location was 
the cursor.

The above sequence will only happen this way if the snap settings are in their default setting i.e. points, 
line and cursor ON. See below for more about snap settings.

Now if you try to click LB again on the same string, you will only get the yellow circle indicating a cursor 
snap. This happens even if you try to pick it multiple times.

The reason for this is that 12d only ever gives you one chance to snap to a string in any one picking 
sequence. Any strings already rejected during the pick sequence will be ignored. The purpose of this 
behaviour is so that if there are (say) three lines one on top of the other, it is possible to sequentially snap to 
each one in turn by looking at the Information panel details as you perform each LB mouse click. The fact 
that we could only snap to one string confirms that there is only one string present at this location.

A quick method of restarting a pick sequence when a string is highlighted, is to move the mouse (i.e. 
cursor) a short distance from the last pick point. All strings can then be picked again. The next section 
shows how the mouse buttons can also be used to restart a pick sequence.

To terminate the String Inquire i.e. this pick sequence, click LB on Finish in the String Inquire panel.

In either case, an Information panel will pop up as shown at right 
(provided the Info tickbox is set ON - see Chapter 7.4 ’Snap Settings’). 
It advises such information as the name of the Model which contains the 
selected string (survey TOPO BANK TOP), the string name (TBR), the 
type of string (Super). The colour, line style and number of points in the 
line are also returned along with it’s length. 

The x and y coordinates are those of the cursor at the time of the string 
‘pick’. 

In this case the panel shows that the string was accessed via a ‘Point 
snap’.

If you haven’t moved the cursor very far and now pick with the LB 
again, you will notice that the Information panel changes, the string 
goes back to its original brown colour and the cursor is now replaced 
with a yellow (shown cyan) circle. 

This sequence may seem strange at first. 
What has happened is that the first pick 
located a string within snapping distance 
of the cursor so the string ‘highlighted’ in 
yellow and the Information panel for this 
string popped up. The pick location 
showed a diamond to indicate that a ‘snap 
to the nearest point’ had occurred. 12d is in 
effect asking you ‘Is this the string you 
want?’. To reject the currently highlighted 
string, without moving your mouse, 
simply pick with LB again.
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7.2 Use of Mouse Buttons and Enter Key when using Tentative Picking
The three mouse buttons and the Enter key all have a function when picking strings. Those functions are

LB - Left Button Select the nearest string

MB - Middle button Accept the current ‘highlighted’ string. This will also terminate the

current pick sequence.

RB - Right button Bring up the Pick Ops menu

Enter key Accept the current ‘highlighted’ string. This will also terminate the

current pick sequence. This is the same as MB and is very useful when

you only have a two-button mouse.

7.3 Pick Operations Menu via the Right Mouse Button
We will now focus on the use of the RB. Repeat the above picking sequence (From the Main menu, click 
LB on Strings) but now after getting the yellow square cursor (i.e. picking the string), click the RB and the 
Pick Ops menu will pop up

The Accept menu item needs special mention. During a picking sequence, once you have located the string 
you are after, you normally terminate the sequence by clicking the MB. This accepts the current string and 
terminates the pick sequence. 

The Accept menu item has the same function as clicking the MB during the pick sequence i.e. it is used to 
indicate to 12d that the string found is the one that you wanted. If you are using a 2-button mouse, this is 
another way around the lack of the middle button (using the Enter key for accepting was described in the 
previous section). You can accept a string by using the RB to put up the Pick Ops menu and click LB on 
Accept. If you have a 3-button mouse, it is easier to use the MB to accept the string directly.

The Info menu item also has a special function. The Information panel that pops up when a string 
highlights is transitory. If you move the mouse cursor out of the panel, the information panel will 
disappear. This occurs even of you don’t click any mouse buttons. The Info menu item is used to pop up 
the Information panel (again) of the currently highlighted string.

The Cancel menu item is used to terminate many of the operations that are recursive. For instance when 
creating a string, 12d assumes that it will involve multiple line segments so it stays in create mode after 
each segment is placed. After the last point on the string is placed, use the RB to pop up the Pick Ops menu 
and click LB on Cancel to terminate the creation.

Click with LB on Restart. This resets the pick sequence to start over as if the 
previous pick sequence had never occurred. 

If you now try to click on the string with LB, you will notice that the string can now 
be picked again with the LB. The lesson here is that if you ever get confused during a 
picking sequence, the safest way to get operational again is to put up the Pick Ops 
menu, select Restart and start over from the beginning.
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7.4 Snap Settings
In the context of String Inquire, the snap settings are used to selectively choose from 12d data sets when 
inquiring on existing items. The snap settings can be toggled on and off from the snaps toolbar.

The snap settings can also be set from the Snaps menu under Utilities on the Main menu. Click with LB on 
Snaps Ops to pin up the Snaps Ops menu

As you use 12d you need to access the snap settings frequently, so it is convenient to leave the snaps menu 
on display at all times. To minimise menu clutter, the Snaps toolbar and Snaps (Vertical) are merely 
abbreviated forms of the full Snaps menu. They take up less room on your screen and hence are useful to 
the experienced user.

At any one time each snap setting is toggled either ON or OFF. For the Snaps toolbar and the Vertical 
snaps menu, the snap setting is ON when the button is depressed or appears clear and OFF when the button 
appears raised or blue. The settings shown are the default settings when starting 12d.

snaps toolbar

You can select either Snaps or Snaps (Vert).

Point
Line
Text

The Snaps (Vertical) menu Grid
Cursor
Height
Tin
Segment
Info
Data tip
Fast pick
Fast accept

Fast snaps cad accept

Snaps toolbar
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If you are new to 12d, it is easiest to use the full snaps menu until you get use to the abbreviations in the 
Snaps toolbar.

From the Main menu, click with LB on Utilities=>Snaps=>Snaps. Move the Snaps menu to the bottom 
left corner of your screen to get it out of the way.

On the Snaps menu, at any one time each snap setting is toggled either ON or OFF. If a tick appears, the 
snap setting is toggled ON. The settings shown are the default settings when starting 12d.

To change a snap setting, click LB in the snap setting box or on the text describing the snap (e.g. P). The 
setting will toggle ON or OFF.

As shown above, it is possible to have multiple snap settings on simultaneously. For instance, if you want 
to be able to select a line on either ‘the line’ or it’s ‘end points’, you need both Point and Line snap ON.

You can generally leave Cursor snap ON. Most times, if all other snaps fail or are not set, you want the 
mouse cursor position returned. This is useful when freehanding into 12d strings that are not connected to 
existing features e.g. the centreline of a new road. If you don’t have Cursor Snap ON, you will get a ‘Failed 
Snap’ error message whenever all other snap settings fail.

At the bottom of the Snaps menu is an ‘Information’ tickbox labelled Info. If this box is NOT ticked, the 
Information panel will NOT pop up as each string is selected.

Near the bottom of the Snaps menu is the menu item Pt tolerance 10. This figure indicates the current 
point snap tolerance setting is 10. To change the snap setting, click on Pt tolerance 10 with LB and the 
following panel pops up

To change the tolerance, lock the cursor in the Tolerance field by highlighting (double clicking on) the 
existing text, press the Delete key and type a new Tolerance value. Click LB on Set to activate the new 
setting. Click on Finish to terminate the panel.

At this stage we will focus on 4 of the first 5 boxes: Point, Line, Grid and Cursor. 
Upon a successful snap, each snap type returns a unique appearance.

Point Snap - diamond 
Snaps to the nearest point or end of line

Line Snap - square 
Snaps to the nearest line

Grid Snap - circle 
Snaps to the nearest grid intersection point

Cursor Snap – circle
Snaps to the mouse cursor (x,y) position. This is used when drawing freehand.

The point snap tolerance is measured in screen pixels. In 
1024 resolution, a point snap tolerance of 10 represents about 
one hundredth of your screen width. If point snap is set, then 
the closest vertex within this distance of the cursor will be 
selected.
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Similarly for the Tolerance menu item - click on Tolerance and the Snap Tolerance panel pops up

NOTE - When Point snap is set on, any vertex of a string within the point snap tolerance box around the 
cursor when LB is clicked, is considered for selection before any other type of snap is considered. Centres 
of circles, centres of arcs and arc end points are considered to be vertices.

When Line snap is set on, the cursor only needs to be within the snap tolerance distance of any visible 
segment of a string when LB is clicked, and that string is considered for selection. Also arcs and circles are 
considered for selection.

In the area between the point snap box and the snap box, vertices and line snap positions are treated 
equally and the closest one to the cursor is selected.

To practice this further, do a Fit on your current View. Pick a feature in the view where lots of lines meet 
and without moving the mouse, do a series of ‘String Inquires’ by repeated use of the LB and observe how 
12d will snap to adjacent items near to the mouse cursor. Note the cursor shapes returned that indicate that 
sometimes you are getting a ‘Point snap’ and sometimes a ‘Line snap’.

Remember points are just a special type of string..

7.5 Models and Snap Settings
Whilst it may appear obvious, it is important to remember that you can only snap to data that is currently 
on display. Models that are currently turned off will not participate in the selection process during 
snapping. If you find that you are snapping to unwanted items, consider turning off models that are 
irrelevant to your current operations

7.6 Fast Picking
To fast pick a string, simply move the cursor near the string and click MB or type <enter>. The nearest 
string to the cursor satisfying the snap conditions is selected.

Hence using MB alone replaces a LB followed by an MB.

snap tolerance

point snap
tolerance

line snap position

this vertex is selected rather
than the line snap position
because it is inside the
point snap box

Point Snap Box and Snap Box
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7.7 Modifying the String Highlighting Colour
12d has various default parameters for the display of data including the string highlighting colour. This is 
the colour a string is changed to whilst it is selected. 

The default highlight colour is white but this is not be very useful if you want to draw strings in white, or if 
you use a white background colour. In either case, it is important to change the highlight colour to a colour 
other than the white.

To check the highlight colour for the project, we select from the main menu Project => Management => 
Defaults and the Defaults panel pops up.

From this panel, the user can change various parameters for this project that 12d uses for calculations, 
display and data handling.

To change the default highlight colour, select the Systems Settings tab by clicking LB on the ’Systems 
Settings’ tab.
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The following should appear:

Note that the Highlight colour is set to yellow.

To change this, LB click on the colour icon adjacent to the Highlight colour input box and select another 
colour such as cyan from the colour choice box. Then press Select on the colour choice box panel. Colours 
can more quickly be selected from the choice box by double clicking LB on the desired colour - the Select 
button is not required. 

To set the current values for the defaults press the Set button.

NOTE: When a new project is created, the values in the Defaults panel are loaded from the set-ups file 
defaults.4d which 12d Model looks for on start up in the standard 12d location (for more information on 
the search order, see Appendix J ’Set Ups’ in the on-line Reference manual). For an existing project, all the 
values in the Defaults panel are saved with the project so if any have been changed in the project after the 
project was first created, then the defaults for the project will differ from those in the defaults.4d file.

If you wish to keep the current defaults for a project to use as the initial defaults for future new projects, 
you can save the file defaults.4d to a suitable location by clicking on the Write button to bring up the 
Write Setup File "defaults.4d"panel. 
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Specify where you wish the defaults.4d file to be saved and then click on Write.  If you want the changes to 
apply to any new project you create be sure to save the changes to the ‘User folder’  as shown above.

Click on Finish  to close the Save Setup File  panel, and then Finish  on the Defaults  panel.
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8 Creating Strings with CAD
We will now investigate creating strings using the CAD options. We will create points (one point strings), a 2 
point line (single segment string) and a line string (multiple segments in the string).

First we will create a new plan view to work in.

From the main menu, click LB on Views=>New=>Plan. This will create View ’Plan 3’.

Maximise the view by clicking on the Maximise icon on the top right hand corner of the view or by double 
clicking on the plan view title area.

8.1 Creating Points

The CAD options to create points, lines etc. can be done by using the main menu system or by the use of the 
CAD toolbar, which is displayed on the left of the screen at start-up. Regardless of the method used to 
activate the CAD commands, the CAD controlbar as outlined on in Chapter 4.5 will be used to define the 
characteristics of the created elements. We will change the values in the controlbar as follows.

Click LB in the model field and type in ‘cad’. Click LB on the colour icon and choose the colour dark blue 
from the choice box by double clicking on dark blue in the pop-up list of colours. Enter ’20’ into the height 
box and leave the linestyle type as 1.

To create a point string (i.e. one vertex string) we will use the CAD toolbar flyout. Pick the points section of 
the toolbar by clicking LB over the create point symbol and keep LB depressed.

The points flyout menu is displayed which has all the options in the points section of the CAD creation tools. 
This is displayed as a horizontal bar consisting of all the icons that make up all the options in the points section 
of the CAD tools. Whilst holding down LB move the cursor over each of the icons and the tooltip function 
tells what each of the options does. 

     Minimise      Maximise

 Close

                                   model                                            height                                      weight              same

         name                                                     colour                                        linestyle                         tinability
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To select an option, keep the LB depressed until the cursor is placed over the specific option you want and 
then release the LB. We will select the ’Create Point’ option which is the first icon in the flyout .

On selecting the Create Point option, or any other CAD option, the user is prompted for the relevant data in 
the screen message box located on the bottom left hand corner of the 12d Model application window

The user can select a position with the mouse and on accepting that point (Middle mouse button or enter) 
the point is created at the selected position. The model, colour, height etc. are defined in the Cad 
Controlbar .

The snap mode will influence the mouse selection. For example if cursor snap is on, the user can choose a 
position not yet defined. If point snap is on and the selection snaps to an existing point, the option will 
place another point at that location. Ensure that the cursor snap is activated in the snaps toolbar. Click LB 
at a position roughly in the middle of the view. 

Click MB to accept that position. The point is then created with the model ‘cad’ elements’ being added to 
the view automatically.

Message area
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To see the height of the point we must toggle on the Z values. To do this click LB on the toggle button on 
the view menu to bring up the toggle menu. Then click LB on the ’Z values[n/a]’ position. Don’t walk 
right on the arrow near this position. This is to specify individual models to turn the Z values on or off. By 
clicking LB on the Toggle menu, you turn on (or off) all Z values in that view for all models.

The default colour for the height text is yellow. To change the colour of the height text so it clearer we can 
click LB on the menu icon from the view menu to bring up the plan view menu. From that menu we can 
click LB on Settings=>Z values=>Single to bring up the Z values For Plan View panel. From this panel, 
select the colour icon and then select the colour red by double clicking LB on the red colour. It should like 
as above:

Click LB over ’Z values’

The Z value is then shown near the point that we created. 
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Then press Set on the panel to set that colour. Finally press Finish to close the panel. 

The change is made only for view 3. Any other points added to the view will now have their height text 
shown in the red colour. 

There are various ways of selecting a position when creating a point. Specification of a position can also be 
done by the direct input of the xyz coordinate of the point by pressing the space bar to bring up the enter 
XYZ panel or by typing of the value to bring up the XYZ panel. The user then enters the X, Y and Z value 
into the box separated by a space. e.g. 200 150 40. As we have already set a Z value in the CAD 
controlbar, you only have to specify a X and Y value into the box. NOTE: The Z value will default to the 
value entered into the CAD controlbar whether or not it is specified in the XYZ box. If no height value 
exists in the CAD controlbar or the XYZ box, then a value will be interpolated if possible, otherwise a 0 
value will be assigned.

We will again create a point by using the CAD toolbar. 

Firstly, change the Z value in the CAD controlbar to ’50’. Then repeat the steps outlined above to choose 
the Create Point option. Instead of selecting a point with the mouse we will type in the coordinate values. 
To pop up the XYZ box, press the spacebar. Then type into the box, 200 100 and then press the enter key. 
We did not have to specify a Z value in XYZ box as it was already defined in the CAD controlbar. 
NOTE: A space must be placed between the X and Y values.

A new point is created. Click LB on the Fit icon on the view menu  to fit the data in the view.

It should now look like as shown below:
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8.2 Creating Two Point Lines
We will now create a simple one segment line. To do this we will use the CAD toolbar flyout. Pick the 
lines section of the toolbar by clicking LB over the create line symbol and keep LB depressed.

The lines flyout menu is displayed which has all the options in the lines section of the CAD creation tool. 
Select the ’Create Line’ option which is the first icon in the flyout .

On selecting the Create Line option, the user is prompted for the relevant data in the screen message box 
located on the bottom left hand corner of the 12d Model application window

We will pick a position with the mouse to define the start of the line. Pick a position with LB about 
halfway between the two existing points and then MB to accept. After accepting the start point, the user is 
told in the message area to pick the end of the line. You will also notice when you move the mouse around 
that a line is drawn ’rubber banding’ to the cursor position. We now select a point going south east to 
define the end of the string with LB and MB to accept. The created string will be shown given the 
parameters given in the CAD controlbar at the time of construction. 

Lines section
of CAD toolbar 

Message area
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8.3 Creating Line Strings
We will now create a multi-segment string. To do this, we will use the CAD menu from the main menu 
system rather than from the CAD toolbar 

From the main menu, click LB on Strings=>CAD=>Lines=>Line string. The Create Line String option 
will now be running. NOTE: These options have no panel assigned to them. 

The same option can be started from the CAD toolbar as we did for the Create Line option except we 
choose the Create Line String icon from the flyout. 

On selecting the Create Line String the user is prompted for the relevant data in the screen message box 
located on the bottom left hand corner of the 12d Model application window

We will pick a position with the mouse to define the start of the line. Pick a position with LB any where on 
the view and accept with MB. Then move the cursor to a new position and pick and accept a second point. 
Pick and accept a third point and so on. To finish the string simply press the Esc Key on the keyboard or 
alternatively RB and then select cancel from the Pick Ops menu. The string will be created using the 
parameters given in the CAD controlbar at the time of construction. 

This has given a small introduction to the use of the CAD options. For a more detailed explanation of these 
tools see Chapter 14 ’Strings’ in the on-line reference manual and follow the links to the CAD options.

We will now finish this section by deleting the current view. As the view is maximised, select View => 
Delete and select view ‘3’.  Alternatively, we could have restored the view and click LB on the ‘X’ icon at 
the top right of the view.  This should then leave two views, Plan 1 and Perspective 2. If either Plan 1 or 
Perspective 2 are left maximised, select the restore button on the top right hand side of that view to leave 
two views as at the start of this chapter.

Clear the value for the default height in the Cad Controlbar.  Leaving the height there mat create problems 
when creating strings at a later stage.  Also change the default model to one of the existing survey models 

Message area
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as deleting the current model is not recommended.

Finally, we will delete the ’cad’ model. To do this we click LB on the delete model option from the main 
menu Models=>Delete=>Delete a Model. This brings up the Delete Model panel

. 

Select the model icon with LB and then double click LB on ’cad elements’. Then click on the Delete 
button, and answer yes to any warnings (after reading them). This then deletes the model from the project. 
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9 Survey Data Reduction

9.1 Coding

9.1.1 Feature Codes
Feature codes are used to define surveyed points in the field. The code will be used to assign properties 
such as model name, colour, symbol and linestyle via a mapping file. 

9.1.2 Field Codes

Field codes are used to enhance the effect of feature codes. 

Field codes are defined for each data collector and are set up in the Survey.4d Create/Edit panel.

Field codes are set up in the Survey Data Setup menu. We will look at how to bring up this panel later (see 
“Creating/Checking/Modifying a 12d Data Collector Definition” later in this chapter), but it looks 
like: 

In the Survey.4d Create/Edit panel, Field Coding 
is set up under the panel tabs: Templating, 
Shapes, Pipes/Culverts, Non Tinable, Feature 
Coding, Non Visible, Strings, Others and 
Features

The Field codes are user defined and can be any 
letters. It is advisable to ensure that the codes 
used are not the same as feature codes.

A list of Field codes can be found in the 
Reference manual.
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9.1.3 String numbers
Numbers can be used to differentiate separate strings using the same code.

The string number position 
is specified under the 
Survey Data Setup menu 
under the Feature Coding 
tab 

String numbers may be 
omitted and a New String 
command can be included 
after the code. This is set 
up under the Strings tab
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9.1.4 Delimiters
There are a number of delimiters used in 12d. Two commonly used ones are the code delimiter and the 
comment delimiter.

A Comment delimiter (space) 
is used to separate a feature 
code from a text description 

A code delimiter (*) is used to 
separate multiple feature 
codes and/or feature codes 
and field codes

The Delimiters can be defined 
under the delimiters tab of 
the Survey Data Setup menu
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9.2 Setting up a New Project
Before we can reduce the survey data, we first we need to create a project to read the survey data into. We 
will create a new project called ’DETAIL SURVEY’ in the Survey Getting Started training area.

First, double click on the ’12d Model 
V8.00 Training’ icon to bring up the 
Project Selection panel.

Select Folder icon to 
bring up the Select 
Folder panel.

Double click on the Survey folder
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Double click on the 
Getting Started folder 
then select Open

Type’DETAIL SURVEY’ in as the 
name of the new project

Select Proceed to create the new project 
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9.2.1 Screen Setup

When the project 
starts up for the first 
time the Project 
Details panel 
appears

The information 
typed in here can be 
used when plotting 
from this project

Fill in the various 
prompts if 
necessary

Select Set then 
Finish to save the 
settings and 
continue
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Maximise the plan view

Move the Recalc panel to the 
bottom left

If the Output window tab is 
highlighted blue you can move the 
cursor over the tab to display the 
error message if any. Normally 
when creating a new project there 
are optional file that are not found.
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9.2.2 Project description
It is useful to keep a record of operations performed in the project. 

Select option  
Project=>Details=>Description

Type in the details

Select Set then Finish

Alternatively after selecting Set 
the panel can be minimised for 
future use
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9.3 Survey Station Coordinate entry
Co-ordinates for the survey stations can be stored in the data collector file or created in the project by a 
number of methods. For this example we will read in an ascii file with the station co-ordinates. 

Select the option File I/O=>Data Input=>12da / 4da data

Select the File to read folder 
icon

Walk right on User Lib

then double click on the file 
CONTROL.12da

Select Read 

Note: As 12d does not display 
the data as it is read in it is 
important to turn on the 
models prior to finishing the 
panel

Select the Add Model to view 
icon then double click on the 
model SURV STATION
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 To display point id’s select 
the Toggle icon then select 
Point id’s



Chapter 9  Survey Data Reduction

February 2007 Page 107

9.4 Data collection reduction

The raw survey data is either

(a)  downloaded from an instrument

or

(b) copied to the working folder via a PCMCIA card or other communication package such as Hyper 
Terminal

To allow for a variety of data collectors and coding methodologies, 12d Model allows you to save a user-
specified set of data collector parameters away under a user supplied name.

9.4.1 Creating/Checking/Modifying a 12d Data Collector Definition
The data collectors defined within 12d Model include such information as:

(a) Instrument name, extension for the raw file and vertical circle information.

(b) Position of the feature code, tinability code and number of digits in the numeric code.

(c) Delimiters for commands, comments, offset codes, backsight and foresights, check measurements

(d) Field template codes.

(e) Communication settings for uploading and downloading.

(f) Coding for arcs, rectangles, closing strings, pipes and culverts.

Creating new or modify existing 12d data collectors can be done using option Project => Tree, 
Survey=>Setup or by picking the Survey Setup Data icon

The reduction of the data collector file is handled 
under the Survey menu or the Data reductions 
flyout toolbar
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We will use the option Project => Tree for this example

Select the + beside Project "DETAIL SURVEY" to expand the list of information for the project. Then 
select + beside Survey data collectors to see the list of existing data collectors.

Double click on Create data collector to create a new 12d data collector definition, or double click on an 
existing data collector in the list to examine or modify it. The Survey.4d Create/Edit panel will then 
appear. The example below is shown when selecting the Sokkia String Feature data collector type

To edit any of the parameters in 
the Survey.4d file select the 
relevant tab and change the 
values.

To save the edited file select Set

                                   Select Write 

Select User folder to store the file 
"survey.4d" in the "User" folder for use 
in the "Getting Started" project

Select Write then Finish

Select Finish back in the "Survey.4d 
Create /Edit” panel 

Select Finish back in the “Project 
Tree” panel 
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9.4.2 Selecting the Data Recorder type
Select Survey=>Setup or Survey Data Setup icon

Select the Data collector 
choice icon then double 
click on the data collector 
Sokkia String Feature 

Select Set and then Finish.
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9.4.3 Downloading a Raw Survey File from an Instrument
The raw survey file we require is already on the computer and does not have to be downloaded from a 
survey instrument.

NOTE - after doing a typical survey job, the raw file for the survey would still be in the data collector and 
would need to be downloaded using the following procedure:

Select Survey=>Download Raw or Survey Data Download icon

NOTE - you must have a data collector attached to the nominated COM port to be able to download data

The Comms Capture panel is automatically placed on the screen to display messages for the download.

The raw file is download and the field file is created. Both the raw file and the 12d field file are stored in 
the working folder. In this project the working folder is 

C:\12djobs\Training\8.00\Survey\Getting Started

The values for the communication parameters 
have come from the data collector definition 
Sokkia String Feature. 

If required, the communication parameters can be 
modified in the panel before commencing the 
download. For example, the Port is the port that 
you have the data collector connected to.

Type in a name to give the created Field file.

Select Download to commence downloading.

                                                     To stop the download press Stop

To restart the download press Reset

                                                                                              To finish the download select Finish
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9.4.4 Converting a Raw File to a 12d Field File
 If the field data was not downloaded from a data collector then the raw survey data needs to be converted 
to a 12d Field File before reduction.

For this training example a raw survey data file DETAIL1.SDR is already in the Survey folder, ready for 
converting.

However, in real situations, the raw survey data file may have been copied from a PCMCIA or Memory 
card.

To convert a raw file, select Survey=>Convert Raw or Survey Data Convert raw icon

 Note: The list of raw survey files are expected to have the extension  ".sdr" as specified in the data 
collector definition Sokkia String Feature. It is recommended that any files manually copied to the 
working folder have the correct extension. 

Click on the Raw file folder icon to list 
raw survey files ending in.SDR.

Double click on 
DETAIL1.SDR

The field file name DETAIL1.fld will 
automatically be filled in or can be user 
defined.

To create the field file select Convert then Finish

This will convert the raw Sokkia file to the 12d Field File format ready for reduction.
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9.4.5 Running the Survey Data Reduction Function
Select Survey => Create => Field File or select Survey Data Reduction Function icon

Type in the Function name 
DETAIL1

Type in unknown for the model 
name for strings that have 
unrecognised feature codes.

Type in report file name DETAIL1 
(when pressing [Enter] the file is 
given the extension.rpt).

Under the Field Files tab the newly 
created field file DETAIL1.fld is 
displayed as the default 
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Select the Map File tab

Select the map file DETAIL SURVEY V8.mf 
from the User_lib folder. This will be used to map 
the survey readings to their correct model and other 
features.

The reduced data can be separated from 
other surveyed data by using a prefix 
which goes in front of any model name 
created using the mapping file.
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Select the Advanced tab

12d can either reduce the survey 
readings from station information 
within the field file or by specifying the 
model containing the survey station 
points. In this case we have read survey 
points existing in the project.

Select the Control model choice icon

Double click on the 
model name 

SURV STATION

Select the Others tab

Tick Explode point strings check box 
to ensure individual survey points are 
kept separate from other points with 
the same code

 Tick Show check measurements 
check box to display check 
measurements during the reduction

Select the Backsight prompt 
mode choice icon and select 
Prompt to pause the reductions 
as each backsight reading is 
reduced
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Select Reduce to reduce the field file

Each time a Backsight 
measurement appears in the 
reduction a Bearing Datum 
Difference panel is displayed.

The user has a number of 
possible responses

Yes will apply the swing to the 
following readings until the next 
bearing difference panel appears

Yes to all will apply the swing to 
the following readings and 
bypass all following panels 
using yes as the default. 

This is not a good idea unless the 
file is being re-reduced

No will apply no swing to the 
following readings until the next 
bearing difference panel appears

No to all will apply no swing to 
the following readings and 
bypass all following panels 
using no as the default. 

This is not a good idea unless the 
file is being re-reduced

Edit is used to activate the field 
file to view the reading to the 
backsight point. This is useful if 
the wrong backsight point ID is 
entered. The new ID can be edited and 
the reduction continued

Cancel is used if there is a major 
problem with the reductions and the 
process has to be terminated in order to 
fix the error.

Note: By pressing Cancel the process 
stops at that point in the reduction 
and an incomplete survey may 
appear in the graphics

You have to rereduce the survey 
after pressing Cancel

For this exercise select Yes
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NOTE - When the survey data is being reduced, the Bearing Datum Difference panel and Check 
Measurement panels come up a number of times.

When the reduction is finished don’t press Finish until the report file has been checked for errors

If check readings are taken to known points a 
Check Measurement panel is displayed

Again the user has a number of possible 
responses

Continue will close the panel and the processing 
continues until the next check reading is 
encountered

Continue all will close the panel and the 
processing continues with all following check 
measurement panels not displayed

This is not a good idea unless the file is being 
rereduced

Edit  is used to activate the field file to view the 
check reading to the point. This is useful if the 
wrong check point ID is entered. The new ID can 
be edited and the reduction continued

Cancel is used if there is a major problem with 
the reductions and the process has to be 
terminated in order to fix the error.

Note: By pressing Cancel the process stops at 
that point in the reduction and an incomplete 
survey may appear in the graphics

You have to rereduce the survey after pressing 
Cancel

For this exercise select Continue each time the 
panel appears.
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9.4.6 Checking the Report File for Reduction Errors
We will now check the report for any errors found by the reduction process. This should be done prior to 
any other editing

Select the Report file choice 
icon

 

Select Open to display 
the report file in the 
default text editor.

If the Survey Data Reduction Function panel has 
accidentally been closed the file can be loaded 
into the text editor by selecting option Reports 
=> Edit or Edit a file *.rpt icon 

Select File to edit icon

Double click on DETAIL1.rpt.

Select Edit
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The file DETAIL1.rpt will then displayed in the default text editor.

 

Scroll down through the report file checking for any problems or errors.

At the end of the file is the list of Unknown Feature Codes.

These are the feature codes that appeared in the field file DETAIL1.fld but were not in the mapping file.

Quit from the text editor.

PUMP and TBK were codes found in the 
field file DETAIL1.fld but not in the 
mapping file DETAIL SURVEY V8.mf.

PUMP is the feature code for a water pump. 
TBK was entered in error for the code TBL
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9.4.7 Editing the Map File
We will now add the missing feature code PUMP into the map file.

The interactive map file editor will then start up with the mapping file DETAIL SURVEY V8.mf loaded.

Select the Map file tab

Select the Map file folder 
icon.

Select Open to Edit the 
mapping file within 12d
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.

If the Survey Data 
Reduction Function 
panel is not on the 
screen, the map file 
editor can be brought 
up by selecting 

File I/O=>Map file or 
by selecting Survey 
Data Reduction 
Function icon 

 We can also find the 
function by walking  
right on Editor on the 
Recalc panel 

Click on the Map file 
folder icon

 Select the map file 
DETAIL SURVEY 
V8.mf from the 
User_lib folder.

Click on Read to load 
the map file into the 
editor.
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The interactive map file editor with the mapping file DETAIL SURVEY V8.mf loaded looks like:

We will now add the feature code PUMP to as many tables as required.

PUMP is to be a point type (that is, a symbol at each string vertex) and is to be placed in the model 
WATER PUMP with colour cyan, linestyle 0 and symbol DS SC. 

The point PUMP is not to be included in the triangulation (Tin).
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Basic code

Select the Basic tab

Scroll down to the 
line you wish to 
insert the new 
feature code above.

Click Right button 
on the line number 
121 and select 
Insert above from 
the panel.

A blank line is 
inserted and the rest 
of the lines move 
down.

Type 
PUMP into 
the Key 
column.

Type 
WATER PUMP 
into the Model 
column.

.

Right click in the 
Colour icon and 
select cyan.

Right click in 
the Point 
column and 
select Point as 
the PUMP is a 
point feature.

Type in 0 in the Linestyle 
column as the point will 
have a symbol only and 
this will be applied in 
another section

Type the 
description 
WATER PUMP 
in the Comment 
column.
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Tinability

Select the Tinable tab

The tinable parameters define whether the points and/or segments of a string are used in a triangulation.

Note: Data in 12d is tinable by default so the tinable option "yes" is optional

The choice for the tinable flag are:

no or 0 for points and segments non tinable (points are not used when triangulating and 
strings are not breaklines)

yes or 1 for points and segments tinable (points are used when triangulating and strings are 
breaklines)

points or 2 for points tinable but segments non tinable (points are used when triangulating but 
strings not breaklines) 

Note that it makes no sense to have points not tinable and segments tinable, so that case doesn’t exist.

Editing the Tinable tab is similar to editing the 
Basic tab.

Click Right button on the line number 121 and 
select Insert above from the panel.

Type in PUMP into the Key column.

Since TAP is a non-tinable point symbol, select 
no for the Tinable type.
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Symbol

Select the Symbols tab.

Add a new line as shown under the Basic tab

Select Write to update the map file. 

Select Yes to overwrite the existing file

Select Finish to exit the map file editor

Type 
PUMP into 
the Key 
column.

Right click in 
symbol and select 
DS SC from the 
DETAIL SURVEY   
group

Type 1.5 as 
symbol size in 
millimetres

Right click in 
the Colour 
column and 
select Cyan

Type in 0 for angle, Delta 
X and Delta Y. This will 
put the symbol exactly at 
the insertion point with 
no rotation

Leave the Hide 
vertex check box 
unticked
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9.4.8 Re-Running the Survey Data Reduction Function
Now that the mapping file has been changed, the 12d field file DETAIL1.fld needs to be re-reduced.

Open the report file again to ensure the code PUMP is not an Unknown feature code. The code TBK will 
still be listed as unknown. We will fix this later.

After the report file has been closed, the Survey Data Reduction Function panel can be Finished

If the Survey Data Reduction 
Function panel is not on the 
screen, it can be brought up 
again by selecting the option
Survey=>Create=>Field file
or by selecting Survey Data 
Reduction Function icon

We can also find the function 
by walking right on Editor on 
the Recalc panel 

Click on the Function name 
icon and double click on the 
function DETAIL1.

All of the parameters 
previously entered for that 
function will be loaded into the 
panel.

If the Survey Data Reduction Function panel is 
still on the screen no entry is required

For both cases, simply click on Reduce 

This re-reduces the field file DETAIL1.fld 
using the modified map file DETAIL 
SURVEY V8.mf and updates the report file.
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9.5 Graphically Editing the Field File Data
The detail survey can be edited graphically whilst maintaining a dynamic link to the field file and the resulting 
report file. This ensures that if the field file is re-reduced any changes will be maintained.

As the manuals are produced with the view background colour as white string colours may appear 
different to those one your screen

9.5.1 View the Survey Data

Turn on all models featured in the 
survey by selecting Models to add 
icon

Highlight all of the models

Press Select
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With all the text turned on, the survey is hard to read

The toggled text can be given user defined settings to allow the text to be viewed only when zoomed in to a 
preset scale.

Select Fit icon 
to display the 
entire survey

Select Toggle icon

Select Z values to 
display levels at 
vertices

Select String names 
to display names 
(codes) at vertices
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9.5.2 Setup your text screen settings

Select Size max, Set and then Finish to set default Z value height to that shown on the current screen

Roll the wheel in and out to see the effect

Repeat this process for Names using option Menu=> Settings =>Names => Single

Now zoom out to a scale to define the point number display

Select Menu=> Settings =>Point/Vertex Id’s=>Single

Zoom into an area with a lot of text displayed.
Select the Menu icon from the view menu.
Walk right on Settings =>Z values => Single to bring up Z Values for Plan View panel
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9.5.3 Graphically Editing the Field File Data
As we move along the survey, errors are detected and need to be changed in the field file if possible.

There are options that can edit both the graphics and the field file but update the field file reduction after 
these edit

The Graphical edits are selected from the Survey=>Edit menu, the Detail Survey reductions flyout 
toolbar on the cad toolbar

Tiling field file editor with plan view

Open the filed file editor using option Survey=>Edit=>Field data or select Edit field file icon 

The advantage of having the field file editor active when editing the survey is the ability to "Undo" any 
edits that are performed either graphically of directly into the field file editor

Field file editor link to graphics

The pick icon shown above can be used to select a point in the graphics and if the point is associated with 
the field file function being edited then the relevant measurement line will be highlighted
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Alternatively once the Pick icon has been selected the point number can be typed in manually. This can be 
done by either typing in the point number or pressing [space] bar to activate the input panel then typing in 
the point number.

 The Pan check box can be ticked so that any point highlighted in the field file will be the centre of the 
plan view

WARNING. Field file edits are different from manual cad edits and you must not edit the survey 
data with cad edits while performing field file edits. The reason for this is that after each field file 
edit the function is rerun and the edits are remembered by the function. Manual cad edits are not 
linked to the function and will be lost if the function is re-reduced. Duplicate data can also result in 
the incorrect use of cad edits while the field file reduction is running

The point number will be highlighted.

If the point was not in the initial window then 12d 
pans to the point centring it in the view

If the point was in the initial view then the point is 
highlighted only

Once the point is confirmed the point is shown in 
the field file editor

NOTE. Always confirm the point selection as the 
string is "locked" until confirmation. An error 
will occur if the reduction is run with a locked 
string
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Find and Replace

When reducing the field file the code TBK was listed as incorrect in the report file

We will use the Find / Replace option in the field file editor to fix the error

Select Find/Replace icon

Type in the incorrect code 
listed in the report file

Type in the correct code 
or select TBL from the 
Code choice icon

Select Find

The first occurrence of the incorrect code is found and highlighted. If you have the Pan check box ticked the 
view will move to that point. To replace the code select Replace. Select Replace again until all corrections 
have been made. 
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When the code is corrected the line in the field file is coloured magenta indicating that the reading has been 
changed.

We will look a the audit trail options in more detail later in this chapter
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Changing codes

In addition to the Find/Replace option we can change a point’s code by simply locating the measurement in 
the field file editor and editing the point. We will go through the individual point edits later. In the mean 
time we will use a menu option to change the code from pick list or by matching another point with the 
required code

Select the option Survey=>Edit=>Coding=>Quick change or select Quick code edit icon 

Locate point 1267 by using the Pick icon in the field file editor

Select the correct code using 
the Feature code choice icon 
or by selecting Sameas button 
and selecting a point with the 
required code

Select Pick button then select 
the point to change

The function is rerun and the point 
now displays the properties of the 
new code.

The relevant line in the field file will 
also be highlighted magenta
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Target heights

Another common error made during a detail survey is to incorrectly record the target height.

Instead of amending the level of the reduced point, a new target height can be entered into the field file 
reduction either manually or graphically

Select the option Survey=>Edit=>Target height=>Insert or select Insert target height icon 

Locate point 1044 by using the Pick icon in the field file editor

Select Pick button then select 
the first point with the incorrect 
target

The target height is displayed at 
the bottom of the panel. 

Type in the correct target height

If only one point has an 
incorrect target height then tick 
the Just one point wrong check 
box prior to selecting Set

Otherwise select Set

The function is rerun and the 
point now has the correct 
height. All subsequent points 
will also be updated until the 
next height of target line occurs 

In the field file a new line 
appears stating the target height.

The line will be highlighted 
blue
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Joining strings

Version 8 has new options designed to join strings within the field file reduction. 

The first option we will look at is used to join strings with the same properties

Select the option Survey=>Edit=>Stringing=>Join

 

Pick the first string with direction

Pick the second string with direction

The function is rerun and the two strings 
are now joined as one.

All strings with the same properties can 
now be joined using this method. For 
strings with different properties or 
where the end of a string is to be joined 
to a corner (not the end) of another 
string other options are available and 
explained later in the chapter

At the end of the field file the Join 
command edit is listed in blue.
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Multiple coding joins

To join strings with different properties we can join the end of one string onto another point.This is done 
by giving the second point the same code as the end of the first string.

Note: This option only works where the second string was created after the first string 

Select the option Survey=>Edit=>Coding=>Quick multi code

 

Select Pick

The screen message box at 
the bottom left of the screen 
instructs the user to <Select 
point to add opcode to>. We 
pick the proposed end point 
of the string

We now select the point to obtain feature 
code and string number from as instructed in 
the screen message box

The function is rerun and the string is joined 
to the selected point.

Below the measurement line of the second 
point to will appear the Multiple coding line 
highlighted in blue
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Reversing strings

If a string is surveyed in the wrong direction it can be reversed using the following option.

Select the option Survey=>Edit=>Stringing=>Reverse

 

Pick the string to reverse

The function is rerun and the string is 
appended to the selected point.

A Reverse string command will be 
inserted at the measurement line and 
this will be highlighted in blue
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Re-order string

If a string has been surveyed incorrectly the string can be re-ordered using a number of options including 
Order by points

Zoom in to point 2357

In the example here the point 2357 
has been surveyed in the wrong 
order. Rather than stopping the 
string to take a single reading at 
point 2358 we simply string to 
point 2358 and then 2359 and so 
on.

To re-order the string by points use 
the option 
Survey=>Edit=>Order=>by points

or Order string icon

Select point 2356. Then pick point 
2358. At this point the string order 
is correct when reprocessed.

If the string order is done 
incorrectly the original order can be 
reinstated using the option 

Survey=>Edit=>Order=>Remove

or Remove order icon

Pick on the string to restore the 
order
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Start new string

If a string accidentally has the same string number as a previous string then crossing strings may result

To delete the segment of the crossing string select the option Survey=>Edit=>Stringing=>New String

Zoom in to point 2112

In the example here the point 
2112 has the same code and 
string number as the string 
ending at point 2106.

Select the segment from point 
2106 to 2112. Take care not to 
select the underlying drain 
string

The function is rerun and the 
string is appended to the 
selected point.

A New string command will be 
inserted at the measurement line 
and this will be highlighted in 
blue
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9.6 Direct Editing of the Field File
Although the previous options were graphical, each change has been recorded in the field file reduction.

Data in the field file that has 
been changed in any way is 
coloured magenta.

Data which has been entered 
directly into the field file or 
added via a command such as 
the New String option is 
coloured blue

This colour coding gives an 
audit trail of any field file 
editing
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9.6.1 To Find data in the Field File
The find option gives the user a number of methods to find data in the field file

NOTE: You have to clear the current Find values before commencing a new search.

Select the Find icon
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Named

A search can be performed on data in the field file using filters Code, String number, Named point, 
Point number or attribute.

Text

A search can be performed on data in the field file looking for text with defined characters.

Numbers

A search can be performed on data in the field file given a number range

To search for point 
number 2375

Select Named tab

Type in point 
number 2735

Select Find

The line in 
highlighted

This example is 
generally not used 
as the user can 
locate a point by 
simply clicking on 
the Find by Pick 
icon at the top of the 
panel and typing in 
the point number
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Type

A search can be performed on data in the field file given a particular command type 

To search for an Arc Fitting Start command

Select Type icon               Select Command choice Arc fitting start
 

Select Find

The line in highlighted
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State

A search can be performed on data in the field file given a change of state including added, changed, 
deleted or field. To search for a changed state 

                                               Select State icon               Select Command choice Changed

Select Find

The line in highlighted
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To Edit a Field File Line

Double click on the line in the Field File to edit.

A panel appears with editable fields

Any data can be changed

To set the changes press Apply. The field file reduction will rerun updating the graphics and 
the field file line will appear in a magenta colour.

Select Finish to save the change or select Reset to cancel the change and then Finish.
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 To Insert a command

A command can be placed in the field file. Often any graphical field file edit can be substituted with an 
Insert command. 

To insert a Vertical circle correction put the cursor on line where entry is to be made

Press Insert icon Select the Command choice and select the Command

Vertical circle correction. Select Create

Type in the correction as 0.0020 
as the decimal point is the degree 
marker and the minutes and 
seconds are typed together. Make 
sure you type in the trailing 
zeroes.

The correction is applied to all 
subsequent readings

Select OK to insert the command

The command is inserted in to 
the field file editor and is 
highlighted blue
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Deleting a Line

To delete a line in the field file put the cursor on the line to be deleted

Select the Delete icon

To undelete a line simply highlight the deleted line and select Delete again

When a line of data is 
deleted a red cross is 
displayed at the start of 
the line.

When the function is 
rerun, Backsight and 
Check measurement 
prompts will redisplay. 
Select Yes to all and 
Continue all to accept 
the default settings on 
the panels
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9.7 Printing the Report File
When the field file edits are complete print the Report file

.

 

The report file is displayed in your default text editor and can be printed to keep a record of the survey 
reductions

Select Report => Edit 

or Edit a file *.rpt icon

and select the relevant file
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9.7.1 Locking the Data Reduction Function
After all field file edits have been made it is important to ensure that the data reduction function can 
not be rerun.

This is because if any non-field file operations are performed on the reduced data and then the reduction is 
rerun, the non-field file operations will be lost

Once the function has been locked it can’t be rerun by mistake resulting in data integrity problems

To lock the Data reduction function

 Select 
Utilities=>Functions=>Lock

or Function lock status icon

Select the Function choice icon and 
highlight the function name 
DETAIL1

Press Select

Tick the Lock mode check box

Select Set and Finish
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If the function is rerun, the following 
error message occurs
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9.8 Graphical Edits
We now edit the survey graphically to perform tasks not covered in the field file editor

Most of the options used in the following examples are duplicated under the Strings=>Cad menu

9.8.1 Joining strings

Join

Select Strings=>Strings Edit=>Join 

or cad option String Join

Points can be joined in a 
number of ways. The first type 
of join will result in two strings 
of the same type being 
combined into one string. If the 
two strings are different, then 
the resulting string uses the 
properties of the first string 
selected

Zoom in to point number 2112

There strings were unable to be 
joined in the field file editor as 
they had different properties 
(TBL and TBR)

Select the right string with 
direction towards point number 
2112 and accept

Select the left string with 
direction away from point 1232 
and accept

The strings are joined to make 
one string. In this case the 
string will require reversing 
which is explained later
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Append

Select Strings=>Points Edit=>Append 

or cad option Append Point

This option is used to append 
the end of a string on to another 
point on a string

Zoom in to point number 1100

Select point 1116 and accept

Select point 1100 and accept

Press [Escape] to finish picking

The first strings is appended to 
point 1100

If the point id’s are turned on 
the appended string will 
duplicate the last point id. If 
you use the cad option no point 
id will appear on the appended 
point
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Cad Create Line

A line string taking its default properties from the Cad Controlbar can be created. This will create a 
single line string independent of the two points selected.

Firstly select the properties for the new string by manually changing options in the Cad Controlbar

The Cad control bar seen below has been placed on two lines due to screen resolution limitations. If 
running on higher resolution the cad control bar will appear on one line only

 

When editing a survey you should be 
using the Name icon to select the relevant 
code. Once the code is selected (in this 
case TBL) the rest of the cad control bar 
is filled in. The file names.4d is used to 
set up this process. It is very similar to a 
mapping file used to read in the survey 
initially

The other method of presetting the 
cad control car is to use the 
Sameas icon to pick a string with 
the properties required. 

This does not match the tinability 
or symbol 

Zoom in to point 1185

Select option Strings=>Cad=>Lines=>Line or select Create line icon

Select point1185 and accept

Select point 1163 and accept

A new string is created between the two 
points
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Close

If a gap appears between the end and the start point of a string then we join these points together (or close 
the string) to form a polygon. This option is also available in the field file editor. It should be noted that as 
many field file edits as possible should be used instead of manual edits as there is no audit trail in manual 
edits

Zoom in to point 1213

To close the string select option 
Strings=>Strings Edit=>Close

or the String Close icon

 

Select any where along the string and 
accept. 

When inquiring on a closed string, 
the area is displayed in the 
information panel
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9.8.2 Reverse String

If strings are created with the linestyle shown on the wrong side then the string can be reversed.

Zoom in to point 1238

Select option Strings=>String 
Edit=>Reverse

or String reverse icon

Select the string and accept

The string direction is reversed
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9.8.3 Add arc to curve
An arc can be placed in to a string by selecting the middle point of the curve.

Zoom in to point number 2286

Select option Strings=>Points Edit=>Add 3 
Pt curve

or Insert 3pt Curve icon

Select point 2286 and accept

A curve is created
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9.9 Triangulation
The survey is ready to form a triangulation from the tinable data that is displayed in the view.

Ensure that all models to be used in the triangulation are turned on.

9.9.1 Check for Crossing Breaklines
Prior to forming the triangulation we need to check for any overlapping breaklines.

If not corrected these will cause errors in the triangulation. 

Coloured diamond shapes can be created around the errors along with a report file 

The report is generated and displayed in the default text editor.

At the bottom of the report the intersections are listed giving the model names, co-ordinates and codes of 
the intersection strings

Print out the file and exit the text editor

Select option Tins=>Check Breaklines

We want to check all data in View 1 so select 
View icon

Select view number 1

Type in model name xbeaklines to create 
strings around the errors

Tick check box to Clean models beforehand

Select the colour red for the strings

The report file name xbeaklines is typed in. 
Press [Enter] after entering the text and the 
extension .rpt is added

NOTE - report files are not available in the
12d Model Practise Version

Leave all Crossing types ticked

Select Check
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Drag the Check breakline panel over to the edge of the screen as we will rerun the option at a later stage

Lastly delete the diamond string surrounding the crossing breakline. We delete the diamond string as it has 
levels at the vertices and if the "check Breakline" option is rerun without the "Clean models" option ticked, 
more crossing breaklines would result 

Select Strings=>Delete or String delete icon

Pick the diamond and accept

As the Crossing Breakline panel is still active rerun the option to confirm all crossing breakline have been 
fixed

Turn on the model xbeaklines

Zoom in to the red diamond at point 2275

A red diamond appears centred at the 
intersection of the two strings

To correct we will insert point 2275 into 
segment from point 2065 to point 2066

Select option Strings=>Points edit=>Insert

or Insert point icon

Pick and accept the string between point 2065 
and 2066

Pick and accept point 2275

The string now has a vertex at point 2275
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9.9.2 Delete empty models
Prior to creating the triangulation it is important to delete any empty models. 

Select option Models=>Delete=>Delete empty models

9.9.3 Triangulate data
All tinable data will now be triangulated. In this example we will triangulate a view of data. Turn off the 
model name Trash model if it exists. This model may have been created as a result of certain string edits. 
The edit panels may have given the user the option to send the affected string to the "Trash model"

Select option Tins=>Create=>Triangulate data

Select Delete All

This will delete the model xbeaklines and 
unknown which was created during the field 
file reduction

Select the General tab

Type in the function name TIN 
GROUND

Type in ground as the tin name. Press 
[Enter] and the Model for tin will use the 
same name prefixed with the word tin

Select a tin colour green

Tick the check box to Preserve strings. 
This will ensure that the triangles run 
along the edge of the breaklines
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Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

In version 8 this section combines a 
nulling option Null by angle / length

Type in a length of 50. This will delete 
any triangle with a side longer than 50

The angle and combined length / angles 
are explained by pressing "Help"

We are going to manually create a 
boundary at a later stage so there is no 
Null polygon

Select Triangulate

The panel changes to a Retriangulate 
Tin panel. 

We will use this panel again later to select 
the tin boundary, so it can be minimised 
or moved over to the edge of the screen 

Turn on the model tin ground
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9.9.4 Nulling Triangles
When deleting triangles it is import to be able to see the survey strings. As the tin was the last model turned 
on the green triangle lines cover the survey strings. We can put the green tin strings to the back by 
selecting Menu button on the plan view. Walk right on Models=>Models to back then select tin ground. 
This can also be done by walking right on Models=>Models Order and moving the tin model to the bottom 
of the list

The triangulation is shown with preliminary nulling around the edge
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The triangles around the edge of the data have been partially nulled by the Triangulation function but we 
need to trim the triangles even further to be able to create a boundary around the edge of the survey.

There are a number of ways to null triangles including Delete by angle/ length, by points and by strings

Null triangles by angle and length

This option has been included in the tin creation for version 8 so is not necessary if the relevant tab was 
filled in during the triangulation process

Null by strings

Triangles can also be deleted by dragging a line, polyline or lasso through the ones that are incorrect.

Select option Tins=>Null=>By strings

Select the Tin icon

Select tin existing

Select Use a string

Tick Null on accept of 
string

Select the String choice 
icon

Select Polyline icon

Zoom in to point 1482

These two triangles need to 
be nulled
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Holding down the left 
button, drag a polyline 
through the triangles as 
shown. Release the left 
button then press middle 
button to confirm the delete

The triangles will be 
deleted

Pan around the edge of the 
survey deleting triangles in 
this manner

Pay particular attention to 
the triangles where the 
creek beds meet the 
boundary. The triangles 
often cross from one top of 
bank to the other.

The final trimmed triangles 
should look like the 
example below
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Tin Solid

To ensure there have been no errors while deleting the triangles, the surface can be coloured with a solid fill. This 
enables any errors to be easily seen

Zoom to the extents of the survey data

Select Toggle icon 

Select Tin Solid
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Reset triangles

To “Undo” a wrongly deleted triangle select the option Tins=>Null=>By Points

Select tin ground

Change the Null mode to Reset

Turn off the Line and Point 
snap

Select Pick

Select and accept the centre of the triangle to reinstate

The triangle will be restored as seen by the solid fill
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9.9.5 Tin Boundary

Once the triangles have been trimmed around the edge of the survey a string can be created along the 
extent of the triangulation. This is then used to nominate a Null polygon for the triangulation.

Turn on both point and line snaps

Turn off Tin Solid

Select the option Tins=>Boundary

Select the tin ground 

Select tin model tin ground then 
add bdy to the model name

Leave check boxes ticked

Select Create

Turn on the model 
tin ground bdy

A cyan string is 
created around the 
extent of the 
triangulation
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Now we need to include the boundary string in the triangulation

Return to the Retriangulate Tin panel

Select the 
Nulling tab

Select Null 
Polygon pick 
icon

Select String 
icon

Pick and accept the boundary string

Select Retriangulate then Finish



Chapter 9  Survey Data Reduction

February 2007 Page 169

9.9.6 Viewing fast contours
We will now turn on the fast contours to analyse the triangulation.

Select Toggle=>Tin Contours

The contour increment can be changed for the view. Select the Menu icon

Walk right on Settings =>Tins =>Contours to bring up Tin Draw Contours panel

All features of the contours can be changed,

The contours 
should be 
checked for any 
errors
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To update the triangulation select Tins=>Edit=>Retriangulate=>ground 

Or recalc the function using the recalc panel

Walk right on Recalc then 
double click on TIN GROUND
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9.9.7 Perspective Views

To help analyse the triangulation a perspective view can be created. The surface can be shaded and viewed 
from any angle

To create a perspective view select View=>New=>Perspective OpenGL

Turn on all the 
models to be 
viewed
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Close the perspective view

Shade the 
triangulation

Select 
Toggle=>Shade

The triangulation 
is shaded.

To move around the view select the Orbit icon

The panel defaults to the 
Orbit mode

To use any of the options 
in this panel firstly select 
the option then simply 
move the cursor while 
holding down the left 
button
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9.9.8 Section views
A section view can be created to view profiles along existing strings or to create dynamic sections through 
the survey

Select View=>New=>Section

Place the section view beside the plan view by selecting Window=>Tile Vertical

In the section view turn on model tin ground
                                                                Select Profile icon
Select and accept the crown of the road string
The profile of the string is displayed
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Now turn on models DRNGE 375 PIPE and DRNGE 375 PIPE in the section view

Zoom in to point 2056 where the drainage pipe crosses the road

Select the Vertical exaggeration icon and set the vertical exaggeration to 2

Zoom into the part of the section view to see the pipe under the ground

Close the section view
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9.10 Plotting

9.10.1 Create New Plan View
We will firstly create a new plan view on which the data will be set up for plotting. 

Select option View=>Create=>Plan View

Type in the name Plot

Select Create

Maximise the view

Turn on all models to be plotted

Zoom to the 
extents of the 
survey data
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9.10.2 Feature labelling
The points in the survey can be labelled according to their names (codes). Labelling can be text such as 
heights, codes and point numbers

Firstly we will look at the label map file

Select option File I/O=>Label Map File

Select the Label map file folder 
icon

Select ReadSelect the file DETAIL V8.lmf 
from the User_lib folder
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For each code the feature can have user defined text parameters including text style, unit type, size, 
colour, rotation angle, offset from insertion point in x and y distances, slant, width, justification, 
number of decimal places and prefix or suffix text.

Select Finish to exit the editor

To label the data select File I/O=>Use Label Map File

Select the Height Text Data tab

Select the View icon

Select the View Plot 

Select the Label map file 

DETAIL V8.lmf from the User_lib folder

If the Use models for labels check box is 
clear then the user is prompted for a 
model prefix so that each label is placed in 
a separate model

Clear the check box

Type in txt ht as prefix for height models

Type in txt cd as prefix for code models

Note that a space was placed after the 
prefixes above

Select Label
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Prior to turning on the label models we need to delete any empty models (models with no data) created 
with this option. This is done by selecting option Models=>Delete=>Delete Empty Models

Turn on all the label models

The empty models can be viewed 
by selecting the List of empty 
models choice icon

To delete all of the models simply 
select Delete All
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9.10.3 Creating Contours
The contour lines displayed in plan view 1 are “fast contours”.

The fast contours are not editable features and don’t have labels

To create contours select Tins=>Contour=>Contour, Smooth and Label

Type in function name 
CONTOURS GROUND

Select Tin to contour choice icon 
then select tin ground

Select the Contours tab

Type in contours for Model name

Type in contour interval 1

Select colour red

Tick the Smooth contours box

Select the Major Contours tab

Type in contours major for Model 
name

Type in contour interval 5
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Select the Range tab

Leave this panel unaltered

Select the Labels tab

Tick check box to Label major 
contours only

Select label method Line removal and 
centred line facing uphill

Type in 0 for number of decimal places

Select textstyle Contour label 1:500

Type in start distance of 30

Type in separation of 30

Select Process

Don’t press Finish until you have 
verified the contour labelling
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Turn on the newly 
created models 
contours and contours 
major
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9.10.4  North Point

To place a North Point in the survey plot select option Drafting=>North arrow

The linestyle 4dnorth is 
set as the default

Type in a Size Factor of 
5

For Location select icon 
then pick and accept the 
position for the north 
point

Select view Plot for view 
to add North arrow

Select Process then 
Finish to create the north 
arrow
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9.10.5 Text Editing
In this section we will add new text and edit existing text 

Set Plot scale

Firstly we must set the default plot scale for the view as the text created by the label map file are in plan 
millimetres not world units

Select the Menu icon. Walk right on Settings=>Plotting Scale

Type in scale 500

Select Set then Finish

You will notice 
the height labels 
are now the same 
size as the 
contour labels
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Adding text

Text can be added to the view to describe features. 

Firstly we need to set the default text attributes. In version 8 we can now set a name for any text style. 

The text toolbar can be displayed and moved to the edge of the screen

Select View=>Toolbars

Select Names icon

Select .TEXT ROAD to set the 
properties to the cad control bar 
and the text control bar

Tick the Cad Text check 
box

Select Close
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Drag the text toolbar up to 
the top of the screen and dock 
in the menu area 

Select the Create simple text icon

Select and accept the insertion point of the text

Type in the required 
text SMITH ST then 
press [Enter]

The text appears on the 
screen with three nodes 
at the start of the text. 
These are used to 
move, rotate and scale 
the text
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Editing text

We will now look at editing the text using the nodes

Scaling

.

Select the Edit simple text icon

     Pick and accept the top 
left node

As you move the 
cursor the text is 
resized. Accept with 
middle button 

To type in a text size 
simply type in the 
value and press [Enter]

           



Chapter 9  Survey Data Reduction

February 2007 Page 187

Moving

.

     Pick and the bottom 
left node

As you move the 
cursor the text moves. 
Accept with middle 
button 
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Rotating

.

     Pick the bottom right 
node

As you move the 
cursor the text rotates. 
Accept with middle 
button 

To rotate to a set angle 
simply type in the 
value and press [Enter]

Additional keystrokes 
displayed at the bottom 
of the screen can be 
used to rotate 
tangential or 
perpendicular to a 
selected string

In the example here the 
key T was pressed and 
the fence string was 
picked to align the text 
to the fence line 

           



Chapter 9  Survey Data Reduction

February 2007 Page 189

9.10.6 Grid display
A grid can be displayed and plotted with user defined attributes such as grid type, spacing, text placement 
and prefix / postfix additions to values

Select Menu icon then walk right on Settings=>Grid

The grid can be turned on and off using the Toggle icon then selecting Grid

Select view Plot

Tick the grid draw check box

Select grid mode choice icon

Select full lines

Type in the grid x (width) value

Type in the grid y (height) value

Select grid colour

 Select text x choice icon

Select text at bottom and top

Select text y choice icon

Select text at left and right

Type in text to prefix/suffix the x values

Type in text to prefix/suffix the x values

Type in text height in pixels

Type in text plot height in mm

Select text colour

Type in cross size in pixels and mm

Select Set
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9.10.7 Screen dump
A section of the survey can be converted to an image using the format either jpg, tif or bmp

Zoom in to point 2722 

Select option View=>Dump

The image file is created in the working folder 

C:\12djobs\8.00\Training\Survey\Getting Started

This file can then be edited or pasted into documents

Select view Plot

 Select Format icon

and select jpeg

Type in the file name

Select Dump
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9.10.8 Quick Plot

A section of the survey can be easily plotted without the need to set up a plot frame

Zoom in to point 2722

           Select Print icon then select Plot

Select View plot

Select Plotter type icon 
and select windows to 
plot to your windows 
device

The default windows 
Print Setup panel 
appears. 

Select the required printer 
and preferences

Note This panel may 
differ depending on the 
operating system you are 
running on

Select Print
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If a window of data is to be 
plotted type in the scale

Select the Rectangle pick icon 
then pick and accept the extents of 
the window to plot

To show a generic title block tick 
the Title and border check box

Type in 3.5 for text height

Type in Title text Check plot for 
Dam over the two title lines

Select Plot
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9.10.9  Plotting Using Plot Frame

Create Plot Frame

User defined plot frames can be placed over the survey. These frames show both the sheet size and plot 
area borders.

Select option Plot=>Plot frames=>Create. 

Select title file A112DSURVEYL.tbf 
from the User_lib folder

The panel is filled with data read from the 
title block file

Type in the proposed plot scale

Select the Origin selection icon then 
select and accept a point at the lower left 
of the survey

Untick the Draw viewport border check 
box

Select Create

The panel is converted to an Edit panel
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Turn on the model pfa1survey

To move the plot frame over the survey select Translate 

and move the plot frame manually to the required position. 

Select and accept that position

To rotate the plot frame type in a rotation angle or select 
Rotate and use the cursor to change the rotation. Select 
and accept the position. 

Untick the Draw viewport border check box then select Set then Finish
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Create Plot Using Plot frame PPF Editor

Select option Plot=>Plot frames=>Plot or select the plan view plotting icon

Select the option Plot frames

This brings up the Plot frame PPF Editor panel.

The initial Plot Frame 
options appear

Select Plot frame pick 
icon

Select and accept a 
corner of the plot 
frame

Select View to plot 
icon and select view 
Plot

Select Plotter type 
icon and select model

Type in model name 
preview plan plot

Select Clean plot 
models choice icon 
and select prompt for 
clean

Now select the [+] symbol 
to expand the options
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Select Title block to 
specify title block type

We are going to use 
a title file so we tick 
the Use title file 
check box 

Select the [+] symbol to 
expand the next option

Select User title info to 
specify title file and title 
block text
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Select Title file folder icon then double click on file 
12DSURVEYL.tbf from the User_lib folder

User defined prompts inserted into the title file are displayed here

Fill in the values for each of the prompts

Select Plot to create a check plot in 
model preview plan plot.

DON’T PRESS FINISH YET
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Display and check the plot

Move the panel to the bottom of the screen

Create a new plan view by selecting View=>Create=>Plan view

Type in name PREVIEW

Select Create then maximise the new plan view

The plot has been created in the model called preview plan plot1

Turn on model preview plan plot1

The preview can be checked for errors prior to plotting to the plotter.



Chapter 9  Survey Data Reduction

February 2007 Page 199

Finally, to save the plot settings for any future plotting, type in a name for the plot settings

Type in PLANPLOT

When pressing Enter the file is given the extension ".plotframeppf". Select Write

This file can be called up in future when using the Plot Frame PPF Editor option

Select the Plotter type icon

Select the required plot device as shown previously

Select Plot to send the plot to the selected device

Once the preview model planplot1 has been checked bring up the Plot Frame PPF Editor 
panel and select Plot Frame
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10 Volumes
In this chapter we will look at various types of volume calculations including:

Stockpile volumes

Dam Capacity

Surface comparisons

Progressive volumes

10.1 Stockpile volume
This topic deals with calculating the volume of a stockpile given data for both the existing surface prior to 
the stockpiles creation and the surface of the stockpile

A volume will be calculated between the triangulation (tin) of the two surfaces

To begin create a new project called STOCKPILE in the Survey training area

At the windows desktop select 12D Training icon 

Select Folder icon to bring up the Select Folder panel.
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Double click on the Survey folder

Double click on the Volumes folder then 
select Open
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Type ’STOCKPILE’ in as the name of the new project

Select Proceed to create the new project 

When the project 
starts up for the first 
time the Project 
Details panel 
appears

The information 
typed in here can be 
used when plotting 
from this project

Fill in the various 
prompts if 
necessary

Select Set then 
Finish to save the 
settings and 
continue
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10.1.1 Existing surface
We will read in the data for the existing surface. The data is in the form of a 12d ascii file

Read in data

Select option File I/O=>Data Input=>12da/4da data

Type in "EXIST " for model 
prefix

This will help separate data from 
multiple files

Select Read

Select 12d ascii as Format

Select Ascii file choice icon

Select file STOCKPILE EXISTING 
SURFACE.12da from the User_lib folder

Turn on the new models

Select Add model icon

Select the model EXIST TOPO NS

Click Select
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Triangulate the existing surface

We now form a tin using the points from the existing surface.

Select Tins=>Create=>Triangulate data

A series of points 
are displayed on 
the existing 
surface

Type in the function name TIN EXISTING

Type in the tin name EXISTING [Enter] 

Select colour green for tin

Select tin style (line type) 1. This is a continuous 
line

When selecting [Enter] key after entering tin name 
the model name is automatically created with tin as 
the prefix

The only check box needed to be ticked is Preserve 
strings which will ensure breaklines are inserted at 
the time of triangulation
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Turn on the model tin existing to view the triangulation

Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

Leave this section unchanged

Select Triangulate

The panel changes to Retriangulate tin. Select 
Finish
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Select Tin contours

Turn on the contours

Select the Toggle icon
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10.1.2 Stockpile surface
We will now read in the data for the stockpile surface. The data is again in the form of a 12d ascii file

Firstly turn off all existing models

Read in data

Select option File I/O=>Data Input=>12da/4da data

Select 12d ascii as Format

Select Ascii file choice icon

Select file STOCKPILE.12da from 
User_lib folder

Turn on all stockpile models

Type in SPILE <space> 
for model prefix

Select Read to input data
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Triangulate the stockpile surface

Select Tins=>Create=>Triangulate data

The stockpile strings are 
displayed

Type in the function name TIN STOCKPILE

Type in the tin name STOCKPILE [Enter] 

Select colour magenta for tin

Select tin style (line type) 1. This is a continuous 
line

When selecting [Enter] key after entering tin name 
the model name is automatically created with tin as 
the prefix

The only check box needed to be ticked is Preserve 
strings which will ensure breaklines are inserted at 
the time of triangulation
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Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

Select the Null polygon choice icon

Select the String pick icon

Pick and accept the edge of the stockpile

Select Triangulate

The panel changes to Retriangulate tin. Select 
Finish

Turn on the model tin 
STOCKPILE to view the 
triangulation

The contours are displayed as the 
Toggle Contours option is still 
set from the previous tin
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10.1.3 Check stockpile tin lies within existing tin
We will now turn on both triangle models to check that the stockpile tin sits inside the tin created from the 
existing surface points. If this is not the case then the volume calculation will only cover the area 
where the two tins coincide.

Toggle off the contours

Turn on model tin EXISTING

Ensure the outline of the 
stockpile triangulation lies 
completely inside the existing 
surface triangulation
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10.1.4 Calculate volumes by exact method
The volume between the two tins can now be calculated and written to a report file

Select Design=>Volumes=>Exact=>Tin to tin

The report is activated in the default text editor (Notepad is the default)

Exit the text editor and select Finish on the Volume panel

Select EXISTING for original tin model

Select STOCKPILE for new tin model

Type in Stockpile for report file name 

NOTE - report files are not available in the 12d
Model Practise Version

Select Polygon choice icon

Select String pick icon then pick and accept 
the string around the edge of the stockpile

Select Volume to calculate the volume 
between the two surfaces

The volumes of cut and fill are displayed at 
the bottom of the panel

The two surfaces used are 
listed in the report header

The volume of cut is listed 
along with the fill volume 
and the balance (Fill - Cut) 

The polygon plan area is 
the horizontal area of the 
outline of the stockpile
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10.1.5 Calculate volumes by End area
Another type of volume calculation is the end area method. Volumes are calculated between cross sections 
generated through the stockpile. An alignment is not necessary to produce the sections.

Strings will be created at each cross section for viewing in the section view

Select option Design=>Volumes=>End area=>Tin to tin

 As per the previous option the report is displayed

Select EXISTING for original tin name

Select STOCKPILE for new tin name

Type in the angle 135 (direction) for the 
cross sections

Typed in 10 for the distance between 
sections

Type in xs exist as existing section 
model name

Type in xs stockpile as stockpile section 
model name

Tick check box to clean section models

Select the Poly icon

Select the String pick icon then 
pick and accept the string around 
the edge of the stockpile

Select Report mode icon then 
pick STOCKPILE.rpt 

Select Summary

Select Volume mode choice icon 
then select Average end area

Select Volume

Select Yes to append the volume results to the 
end of the previous report

NOTE - report files are not available in the 12d
Model Practise Version
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The original report is amended 
with the volume by end area 
placed at the end of the report

The distance between the 
sections is displayed

The direction of the section 
strings is displayed

The polygon plan area is the 
horizontal area of the outline of 
the stockpile

The volume of cut, fill and 
balance is listed
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Turn on the two cross section models

View stockpile sections

The cross sections can be viewed in a section view

To create a new section view select View=>New=>Section

To place the section view beside the plan view select Window=>Tile Vertical
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Turn on the two tin models tin EXISTING and tin STOCKPILE

To view the cross sections select the profile icon           then pick and accept one of the section strings
To move along the sections use the Prev and Next icons 
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10.2 Multiple stockpiles
In this example multiple stockpile volumes can be calculated with one option. This macro will 
automatically create all necessary tins of the bases and tops of the stockpiles.

A Volume report will be created for each stockpile and volume text will be placed over each pile

Create a new project as shown previously called MULTIPLE STOCKPILES in the folder

C:\12djobs\8.00\Training\Survey\Volumes

10.2.1 Read in Stockpile surface data
The surface data is in the form of a 12d ascii file

Select File I/O=>Data Input=>12da/4da data

Select 12 ascii format

Select Ascii file icon

Double click on file MULTIPLE 
STOCKPILES.12da in the User_lib 
folder

Select Read then Finish
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Turn on the stockpile models

The 5 stockpiles are displayed

For this program to work, the strings around the bases of the stockpiles MUST share a unique 
code. This code should not be used within the stockpile as it is used to determine the extent of each 
pile.
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10.2.2 Run Stockpile macro
Select option Design=>Volumes=>Stockpile

Select view icon

Select view 1

Tick check boxes for Volumes and Surface Area

Type in the model name for tins created. Although 
10 tins are created only one model is generated

Type in the model name for the volume text.

Type in the code for the stockpile bases. The bases 
must all have the same code. 

Type in the report file name

Select view 1 to add the tin and text

Select a text style

Type in the number of decimal places for the 
volume

Type in start stockpile number

Select Process to calculate the volumes
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To read the volume report select the report file icon then select Open

NOTE - report files are not available in the 

12d Model Practise Version
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After the final stockpile volume has been reported select Finish on the volumes report panel

To move the volume text outside each stockpile select option Drafting=>Multi string translate

Select Name

Pick and accept the text to move

Drag the text to the new position and accept
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10.3 Dam Capacity
In this example the storage capacity of a dam will be calculated

Create a new project as shown previously called DAM in the folder

C:\12djobs\8.00\Training\Survey\Volumes

10.3.1 Read in Dam surface data
The surface data is in the form of a 12d ascii file

Select File I/O=>Data Input=>12da/4da data

Select 12 ascii format

Select the Ascii file icon

Double click on ascii file DAM.12da 
from the User_lib folder

Select Read then Finish
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Turn on the dam models



Chapter 10  Volumes

February 2007 Page 225

10.3.2 Triangulate the dam surface
We will now triangulate the dam. 

Select Tins=>Create=>Triangulate data

Type in the function name TIN GROUND

Type in the tin name GROUND [Enter] 

Select colour green for tin

Select tin style (line type) 1. This is a continuous 
line

When selecting [Enter] key after entering tin name 
the model name is automatically created with tin as 
the prefix

The only check box needed to be ticked is Preserve 
strings which will ensure breaklines are inserted at 
the time of triangulation
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Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

Select the Null polygon choice icon

Select the String pick icon

Pick and accept the string at the top of the dam 
wall

Select Triangulate

The panel changes to Retriangulate tin. Select 
Finish

Turn on the model tin 
GROUND to view the 
triangulation
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Turn on the contours

Select toggle icon then select Tin contours 
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10.3.3 Calculate volumes by Storage Calcs method
The volume from the dam bottom surface up to a height can now be calculated

Select Design=>Volumes=>Exact=>Storage Calcs

The report file is opened in the default text editor and the volumes are listed in the specified slices

Select GROUND for tin

Leave the minimum height unaltered. This 
will calculate the volume from the lowest 
point of the tin

Type in 4.5 as the maximum height

Type in 0.5 for the height increment. The 
volume will be broken into 0.5 metre slices

Select view 1 to shade the extent of the 
volume area

Type in the report file DAM.

NOTE - report files are not available in the 

12d Model Practise Version 

Select the Poly icon

Select the String pick icon then pick 
and accept the string around the 
edge of the stockpile

Select Volume
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10.4 Surface Comparison
This topic deals with not only calculating the volume between two surfaces but also comparing the 
surfaces by depth contours and shading

Create a new project as shown previously called COMPARE in the folder

C:\12djobs\8.00\Training\Survey\Volumes

10.4.1 Existing Surface
We will read in the data for the existing surface. The data is in the form of a 12d ascii file

Read in data

Select option File I/O=>Data Input=>12da/4da data

Select 12 ascii format

Select the Ascii file icon

Double click on ascii file COMPARE 
EXISTING SURFACE.12da from the 
User_lib folder

Select Read then Finish
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Turn on the new models
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Triangulate existing surface

We now form a tin using the points from the existing surface.

Select Tins=>Create=>Triangulate data

Type in the function name TIN EXISTING

Type in the tin name EXISTING [Enter] 

Select colour green for tin

Select tin style (line type) 1. This is a continuous 
line

When selecting [Enter] key after entering tin name 
the model name is automatically created with tin as 
the prefix

The only check box needed to be ticked is Preserve 
strings which will ensure breaklines are inserted at 
the time of triangulation
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Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

Leave this section unchanged

Select the Null polygon choice icon

Select the String pick icon

Pick and accept the string at the edge of the 
existing survey

Select Triangulate

The panel changes to Retriangulate tin. Select 
Finish

Turn on the model tin EXISTING to view 
the triangulation
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Turn on the contours. The contours are not visible as the surface is very flat. We need to change the contour 
interval to a smaller increment 

Change the contour interval to 0.1

Select Menu. Walk right and select Settings=>Tins=>Contours 

This menu will allow the user to change the appearance of the fast contours displayed on the view

Tick check box to Draw triangle contours 

Change the contour increment to 0.1

Change bold increment to 0.2

Select Set then Finish
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10.4.2 Second surface
We will now read in the data for the second surface. The data is again in the form of a 12d ascii file

Read in data

Select option File I/O=>Data Input=>12da/4da data

Turn off all the models

Select 12 ascii format

Select the Ascii file icon

Double click on ascii file COMPARE 
STRIPPED SURFACE.12da from the 
User_lib folder

Type in prefix STRIP

Select Read
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Now turn on all stripping models
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Triangulate stripped surface

 We now form a tin using the data from the stripped surface.

Select Tins=>Create=>Triangulate data

Type in the function name TIN STRIP

Type in the tin name STRIP [Enter] 

Select colour magenta for tin

Select tin style (line type) 1. This is a continuous 
line

When selecting [Enter] key after entering tin name 
the model name is automatically created with tin as 
the prefix

The only check box needed to be ticked is Preserve 
strings which will ensure breaklines are inserted at 
the time of triangulation
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Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

Leave this section unchanged

Select the Null polygon choice icon

Select the String pick icon

Pick and accept the string at the edge of the 
strip survey

Select Triangulate

The panel changes to Retriangulate tin. Select 
Finish

Turn on the model tin 
STRIP to view the 
triangulation

The contours are 
displayed as the 
Toggle Contours 
option is still set from 
the previous tin
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10.4.3 Check Stripped tin lies within existing tin
We will now turn on both triangle models to check that the Stripped tin sits inside the tin created from the 
existing surface points. If this is not the case then the volume calculation will only cover the area where the 
two tins coincide.

Toggle off the contours

Turn on model tin EXISTING
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Ensure the outline of the stripping triangulation lies completely inside the existing surface triangulation
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10.4.4 Calculate volumes by exact method
The volume between the two tins can now be calculated and written to a report file

Select Design=>Volumes=>Exact=>Tin to tin

Select EXISTING for original tin model

Select STRIP for new tin model

Type in STRIPPING for report file name

NOTE - report files are not available in the 12d
Model Practise Version

Select Polygon icon then pick String icon

Select and accept the string around the edge of the 
stripping

Select Volume to calculate the volume between 
the two surfaces
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The report file is opened using the default text editor
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10.4.5 Create depth contours between the two surface
To analyse the amount of cut / fill between the two surfaces we will create depth contours (isopachs).

Select option Tins=>Contour=>Depth contours

Select tin EXISTING for the original tin

Select tin STRIPPED for the original tin

Type in model DEPTHS for the depth strings

Select colour Red for the cut strings

Select colour White for the Zero strings

Select colour Green for the fill strings

Leave the start level difference at -10

Leave the end level difference at 10

Type in the depth string interval as 0.01

Select the 2d/3d strings icon

Select 2d

This will give the depth contours levels based on 
the height difference

Select Calculate then Finish to generate the depth contours
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Turn off all models then turn on model DEPTHS
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10.4.6 Create labelled contours
Select option Tins=>Contour=>Label

.

Select model icon

Select model DEPTHS

Type in model name DEPTH LABELS 
for the model for the labelled contours

Select method Line removal and centred 
line read from below

Type in 2 for number of decimal places

Select text style Contour label 1:200

Type in 20 for the start distance

Type in 20 for the label separation

Select Label then Finish

Turn off model DEPTHS and turn on model DEPTHS LABEL
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10.4.7 Create depth shading
The two surfaces can also be compared by colouring the height differences

Turn off DEPTH LABELS model then turn on the Stripped surface models
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Select option Tins=>Colour=>Tins depths colours

Select EXISTING for original tin

Select STRIP for new tin

Select Range file icon then select file COMPARE.drf 
from the User_lib folder

Select view 1 to paint

Type in model FACES for the colouring model. 

DO NOT ENTER A MODEL NAME IF USING

PRACTICE VERSION AS A LARGE NUMBE OF
STRINGS ARE CREATED

Tick check box to clean faces model beforehand

Select Poly choice icon

Select the String icon then pick and accept the edge of 
the stripped surface

Select Colour

Turn on the model FACES

The proposed stripping depth over the 
site was 0.100 so the range file highlights 
where the stripping is over cut (red) or 
under cut (green). The yellow shows 
where the stripping is between 0.09 and 
0.11 (within 10 mm of the proposed 
value)
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10.4.8 Create tabulation of range file
A table will be created to tabulate the depth colours

Select Drafting=>Text and tables=>Tabulate range file

Select Range Type icon and select Depth

Select file COMPARE.drf from the User_lib 
folder

Type in metres for the range units

Select Position icon. The table will be placed 
in respect to a user defined position on the 
screen.

Pick and accept a point for the upper left 
corner of the propose table

Type in Stripping depths

Select Font

Type in model name for table Stripping table

Select the colour for the table

Type in an appropriate size for the text. Note 
that the text size is in world units

Select Set then Finish to return to the 
previous panel

Select Process

Turn on the model Stripping Table
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10.5 Progressive volumes
In this topic we will look at the use of fencing to update surfaces after each survey of an excavation. We 
will start with an existing surface and progressively update a combined surface after each survey

Create a new project called EXCAVATION in the folder

C:\12djobs\8.00\Training\Survey\Volumes

10.5.1 Original survey
We will read in the data for the original survey. The data has been given in the form of a 12d ascii file

Select option File I/O=>Data Input=>12da/4da data

Select 12 ascii format

Select the Ascii file icon

Double click on ascii file 
EXCAVATION APRIL06.12da from 
the User_lib folder

Type in prefix APR06<space>

Select Read
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Turn on the new models
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Triangulate the original surface

Select Tins=>Create=>Triangulate data

Type in the function name TIN APRIL06

Type in the tin name APRIL06 [Enter] 

Select colour green for tin

Select tin style (line type) 1. This is a continuous 
line

When selecting [Enter] key after entering tin name 
the model name is automatically created with tin as 
the prefix

The only check box needed to be ticked is Preserve 
strings which will ensure breaklines are inserted at 
the time of triangulation
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Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

Leave this section unchanged

Select the Null polygon choice icon

Select the String pick icon

Pick and accept the boundary string at the edge 
of the survey

Select Triangulate

The panel changes to Retriangulate tin. Select 
Finish

Turn on the model tin 
APRIL06 to view 
the triangulation
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Toggle on the contours

Turn off all models prior to reading in 
the next survey



12d Model Getting Started for Surveyors Manual

Page 254 February 2007

10.5.2 May survey
We will now read in the data for the excavation survey in May. The data is again in the form of a 12d ascii 
file

Read in data

Select option File I/O=>Data Input=>12da/4da data

Select 12 ascii format

Select the Ascii file icon

Double click on ascii file 
EXCAVATION MAY06.12da from the 
User_lib folder

Type in prefix MAY06

Select Read

Turn on the may survey models
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Triangulate the May surface

Select Tins=>Create=>Triangulate data

Type in the function name TIN MAY06

Type in the tin name MAY06 [Enter] 

Select colour magenta for tin

Select tin style (line type) 1. This is a continuous 
line

When selecting [Enter] key after entering tin name 
the model name is automatically created with tin as 
the prefix

The only check box needed to be ticked is Preserve 
strings which will ensure breaklines are inserted at 
the time of triangulation
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Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

Type in the length 1

As there are two distinct areas this will trim the 
triangles against the edge of the excavations

Select Triangulate

The panel changes to Retriangulate tin. Select 
Finish

Turn on the model 
tin MAY06 to view 
the triangulation
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Now toggle off the contours

Toggle on the 
contours
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10.5.3 Check May survey lies within original surface
We will now turn on both triangle models to check that the May survey tin sits inside the tin created from 
the original surface points. If this is not the case then the volume calculation will only cover the area where 
the two tins coincide.

Turn on model tin APRIL06
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10.5.4 Calculate volumes by exact method
The volume between the two tins can now be calculated and written to a report file

Select Design=>Volumes=>Exact=>Tin to tin

Select APRIL06 for original tin model

Select MAY06 for new tin model

Type in MAY 06 for report file name

NOTE - report files are not available in the 12d
Model Practise Version

Select Use a model of polygons

Select model MAY06 TOPO TBL for the 
edge of the excavations

Select Volume to calculate the volume 
between the two surfaces

The volume report is opened in the default text 
editor with separate volumes for each pit
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Combine the May survey with the original surface to form an updated surface

 We will use the fencing routine to save the data outside the limit of the May survey excavations to a new 
model. 

Turn off all models

Turn on the APR06 models along with 
the MAY06 top of excavations
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Select Utilities=>Fence=>Multi Fence

Select view icon

Select view 1

Select the model MAY06 TOPO TBL as the 
model name for the excavation edges

Tick check box to Exclude model 
containing fence

We only want to combine the data outside the 
excavation edges so leave Models for fence 
inside blank

Type in new model name MAYAPRIL06 for 
data outside the excavations

Select Fence then Finish to create the data

Turn off all April models 

Turn on all MAY06 
models including the new 
model MAYAPRIL06

The combined surface for 
may is displayed. The 
original strings are cut 
where the may survey 
strings cross them
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Checking edge strings

Where strings are trimmed against the fence boundaries there is normally a height difference that should be 
corrected. This is done by inserting the end of the trimmed string into the fence string

Select the cad option Insert point

Select the fence string

Select the point at the end of 
the trimmed string

A new vertex is created on the 
green string at the intersection 
of the trimmed string

This is repeated for all trimmed 
strings
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Triangulate the May combined surface

Select Tins=>Create=>Triangulate data

Type in the function name TIN MAY06 COMBINED

Type in the tin name MAY06 COMBINED [Enter] 

Select colour orange for tin

Select tin style (line type) 1. This is a continuous line

When selecting [Enter] key after entering tin name the 
model name is automatically created with tin as the 
prefix

The only check box needed to be ticked is Preserve 
strings which will ensure breaklines are inserted at the 
time of triangulation



Chapter 10  Volumes

February 2007 Page 265

Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

Select the Null polygon choice icon

Select the String pick icon

Pick and accept the edge of the stockpile

Select Triangulate

The panel changes to Retriangulate tin. Select 
Finish

Turn on the model tin MAY06 
COMBINED to view the triangulation
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Toggle on the 
contours
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At any time we can view the updated surface in a perspective view.

Select option View=>New=>Perspective

As the volumes are calculated monthly the procedure for importing and reducing the subsequent surveys is 
the same

Maximise the view and turn on the 
tin models tin MAY06 
COMBINED

Toggle on the shading
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11 Setout
In this chapter we will look at various types of setout calculations where the feature is constructed in the 
graphics and a setout file is created for upload to a data collector. The types of setout include:

Building creation and setout

Imported building from cad file

Setout for evenly graded string 

Creating 3d setout for imported 2d cad strings

Road setout from imported strings

Triangulation setout

QA Reporting of point, string and tin setout

11.1 Building setout
In this topic we will create a lot outline and position a building on the lot for setout. 

To begin create a new project called SETOUT1 in the folder

C:\12djobs\8.00\Training\Survey\Setout

11.1.1 Create the lot outline
The lot outline will be created in a model called LOT

Select option Strings=>Cad=>Lines=>Traverse Create

or Traverse Create icon

 

Press the Space bar to activate the coordinate entry panel

Type in the name and model name LOT in the CAD controlbar. Select the colour Red 
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Press the Space bar to activate the bearing input panel

Press the Space bar to activate the distance input panel

Type in the coordinates 1000 5000 [Enter]

Type in the bearing 12.1810 [Enter]

NOTE - This is the dms method for 
entering the bearing 12°18’10".

Type in the distance 35.818 [Enter]

When pressing the space key for the next bearing input the previous 
bearing is shown in the panel. Backspace over the previous bearing to 
input the new bearing.

Other options to amend the previous bearing will be discussed when 
entering the house outline

Repeat the entry of bearing and 
distance using the following 
dimensions

90°00’00"   23.870

192°18’10"   35.818

After typing this line press [Esc] to exit 
option

NOTE - 90°00’00" is entered as 
90.0000.

192°18’10" is entered as 
192.1810. Remember to input the 
trailing zeroes. 
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If correct, close the string by using option Strings=>Cad=>Change strings=>Close

or select Close String icon

From this point in the manual we will be using the cad icons only. The menu options are available under 
the option Strings=>Cad 

Check the misclose of the last line by selecting option Utilities=>Measure=>Bearing/Distance

or Measure Bearing/Distance icon

Select and accept the start and end points of the lot traverse

The bearing and distance are displayed
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Select and accept 
anywhere on the string

The string will be closed
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11.1.2 Create building outline
In this option we will create the outline of the building using the previous traverse routine and explore 
some other traverse editing features

Select option Traverse Create icon

 

We are going to start the house corner 7.0 metres up from the lower left corner of the lot and offset 1.8 
metres in from the side boundary

 

Type in the name and model name as HOUSE in the CAD controlbar. Select the colour blue 

   7.0

Prior to picking the start 
point select the Snaps 
offset icon from the snaps 
toolbar

Select the left boundary 
with direction dragging 
towards the top

Select the bottom left corner 
of the lot as the control 
point. This will be the point 
where the measurement is 
taken from

Type in the distance 7 
[Enter]

Type in the offset 1.8 
[Enter]

1.8
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Press the Space bar to activate the bearing input panel

Press the Space bar to activate the distance input panel

We will now look at some options to speed up the traversing process. 

For the next bearing we are going to traverse at right angle to the previous bearing

Press the Space bar to activate the bearing input panel

Press the Space bar to activate the distance input panel

The construction point is 
shown for confirmation

Press [Enter]

Type in the bearing 12.1810 [Enter]

 

Type in the distance 15.40 [Enter]

The previous bearing appears. Press [Page 
Up] to add 90 degrees to the bearing. To 
subtract 90 degrees press [Page Down]. 

Press [Enter] to confirm the bearing

Type in the distance 11.1  [Enter]
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For the next bearing we will traverse tangential to the left boundary line

At the bottom of the screen there are a number of options that can be activated by selecting the letter 
following the option

To traverse tangential select [T] then pick the left boundary line

The proposed direction is highlighted. 
This may be in the opposite direction to 
that required so simply select [N] to 
reverse the direction line.

Select [Enter] to confirm the direction
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Sometimes an error occurs when entering the traverse so the traverse has to be stopped and restarted.

Press [Escape] to exit the traverse.

Select option Traverse Append icon

 

Pick and accept the end of the house string

The traverse can continue

The remaining lines are:

Bearing 192.1810 (or tangential to left boundary) Distance 3.0

Bearing 102.1810 (or [Page Down] after last bearing) Distance 6.0

Bearing 192.1810 (or [Page Up] after last bearing) Distance 5.0

Bearing 282.1810 (or [Page Up] after last bearing) Distance 8.2

Bearing 192.1810 (or [Page Down] after last bearing) Distance 7.6

Press [Escape]



Chapter 11  Setout

February 2007 Page  277

The last line has an incorrect distance and this can be edited using the following

Select option Traverse Edit icon

 

Pick and accept the last traverse line

The bearing is displayed. As the error is in the distance press [Enter] to accept the bearing

Type in 7.4 for the corrected distance
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We can now check the misclose of the house by selecting Measure Bearing/Distance icon

Select and accept the start and end points of the house traverse

The bearing and distance are displayed

If correct, close the string by using the String Close icon as done previously on the lot string
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We can now check offsets from the boundaries to the building corners. To ensure the offsets are from the 
selected segment only, we turn on the segment snap 

Zoom in to the left side of the building

Select the Measure Value icon

Turn on the segment snap

Walk right on String to Point=>Length

Select and accept the left boundary line

Select and accept the front left corner of the house

The offset distance is displayed

Select Measure and repeat for all corner points
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11.1.3 Create dimensioned offset lines from house corners to boundaries

In this topic we will use an option to create the offset line and annotate the lines

Firstly we will use a name in the cad control bar to set the model, colour, linestyle and text for the offset 
lines and dimension text

We will now create the dimensioned offset lines 

Select the Name icon then select .TEXT OFFSET 1 200 

The rest of the cad control bar is populated 
from the settings associated with the name

Select the Label Perpendicular Offset cad icon 

Pick and accept the boundary string. Pick and accept the house corner.

Repeat for all corners
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11.1.4 Create dimensions for lot, offset lines and building
We will add bearing and distances to the lot edges and distances only to the building edges

Lot dimensions

Select option Drafting=>Bearing/Distance labelling (2)

Select Parameter file icon

Select file DETAIL.lbf from the User_lib 
folder 

Select Read

Select the Model icon

Select model LOT

Change Label style to bearing and distance

Tick check box to label all segments

Select Process

Turn on the bearing and distance 
models
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The text is displayed at a default scale of 1:1000. 

To change the scale to 1:200 

Select Menu icon

Walk right on Settings then select Plotting scale

Type in scale 200 then select Set

The bearing and distances which were in paper 
units are now at the same scale as the offset text 
which are in world units
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To annotate the house outline

Pick the Model icon

Pick the model house

Delete the Bearing model name in the Bearing tab

Select Process 
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11.1.5 Setout points
Up until now the strings created around the lot boundary and building do not have point numbers

We will now generate point numbers for the vertices for the building and lot boundaries

Turn off all models except for HOUSE and LOT 

Select option Survey=>Setout=>Setout point using super strings

Prior to running the option we 
will set up some parameters

Select Setout Options button

Tick the check box to Use 
Highest Project Vertex ID

Select the Textstyle data icon 
and select

CO-ORDINATES 1:200. 
This will ensure the text is the 
right height for a 1:200 plot

Select Set then Finish to 
close the panel
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Select the Data Source icon 
and select View. 

Select view 1

Select Label to close the 
panel

Turn on the model Setout
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To move the point numbers from overlapping other text

Any or all of the numbers can be moved in this to make the text readable

Select the Edit Pts tab

Select Pick then pick and 
accept the circle at the corner 
point where the point number 
text is linked. Usually it 
requires two picks to 
highlight the circle.

Select Move then move the 
text to the new position

Select Add to add a line from the setout 
point to the number
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11.1.6 Create upload file
To create the upload file 

Select option Survey=>Upload=>Create points upload file

Select the data collector type

Select the Model icon

Select model Setout

Select Get Point Range to calculate 
point range

The start and end point are displayed

Type in the file name SETOUT

Select Write File to create file

Select Finish
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11.1.7 Uploading file to data collector
The upload file can now be transferred to the data collector in a number of ways

We will look at uploading a file to the Sokkia SDR33 Data collector

To upload to a data collector firstly select the data collector type

Select Survey=>Setup

or Survey Data Setup icon

 

   Select the Data collector choice icon

 Double click on the required data collector

Select Set then Finish
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To upload the file select Survey=>Upload=>Upload

NOTE - You need a data collector connected to proceed.

The data being uploaded will be displayed on the screen

When all data has been transferred select Finish

Select the required communication parameters 
to match those set on the data collector. For 
example, the Port is the port that you have the 
data collector connected to.

Select the Upload file choice icon

Double click on the required file to upload

Get the instrument ready to 
receive the upload file

Select Upload
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11.2 Importing house file
In this example we will import a house file created in a cad package and saved as a dwg file. In version 8 
we can now "Share" models from another project. So we will use the previous project to share the LOT 
model. Prior to creating a new project the relevant model has to be flagged as being available for sharing in 
the source project. In the source project select Models=>Share=>Share

To begin create a new project called SETOUT2 in the folder

C:\12djobs\8.00\Training\Survey\Setout

Tick the Share check box for model LOT



12d Model Training Manual

Page  292 February 2007

11.2.1 Share the lot outline from the previous project
Select option Models=>Sharing=>Add

Select Project icon

Select SETOUT1
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The model is referenced to the project

Turn on the model LOT

Tick the Copy check 
box for model LOT

Select REF to 
reference the model

Select Finish
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11.2.2 Read in the CAD file
Select option File I/O=>Data Input=>DWG/DXF/DXB

Select format DWG

Select the File icon

Walk right on User_lib and 
select HOUSE.DWG

Type in DWG<space> as 
the prefix for the loaded 
models

Type in 0 to ensure any 2d 
data is nulled

The rest of the panel can 
remain unchanged

Select Read then Finish
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Although this panel won’t pop 
up in our example an overview 
is given below

When reading some DWG files 
new textstyles and fonts found in 
the file can be read and saved in 
12d Model.

12d Model can add the new 
textstyles and fonts to its existing 
definition files by clicking yes on 
the Save New Definition(s) panel.

If you select Yes to save the definitions then you can select which area to write the definition files to.
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The house outline has been created in plan millimetres and will result in the house being scaled by 1000 if opened in 
the same view as the lot. We will therefore create a new plan view 

Select option View=>New=>Plan

In plan view 2 turn on the house models. Zoom all to display the house strings
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11.2.3 Scale the house models
The imported building has its base units in millimetres rather than metres and is located a large distance from the 
lot. We will firstly scale the building from millimetres to metres

Select option Utilities=>A-G=>Factor

Select View icon

Select view 2

Type in an x factor of 0.001

Type in a y factor of 0.001

Leave the z factor as 1

Select origin icon then pick and accept any point on 
the building outline. 

Note that the Origin centre point is not necessary as 
the house will be shifted to the correct position in 
the next option

Tick check box to Factor text size

Select Move to original model
icon

Select Factor then Finish

Zoom all of the house models
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11.2.4  Rotate the building
We will now position the house into the lot and place the corner at a predefined position

Select the option Utilities=>H-Z=>Rotate

Select View icon

Select view 2

Select Rotation centre icon then pick and 
accept any point on the building outline. 

Note that the rotation centre point is not 
necessary as the house will be shifted to the 
correct position in the next option

Type in the rotation. In this example we 
have typed in the bearing of the house edge 
and subtracted the bearing of the left side 
boundary line

Tick Anticlockwise check box

Select Move to original model icon

Select Rotate
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11.2.5 Translate the house
We will now position the house into the lot and place the corner at a predefined position

Select the option Utilities=>H-Z=>Translate

Select View icon

Select view 2

Select Move to original model icon

To calculate the shift parameters select dx dy dz

Select and accept the top left corner of the house 
in plan view 2. In plan view 1 pick a point 7 
metres up from the front left corner and in 1.8 
metres in from the left boundary. This is 
explained in the previous setout option

Select Translate
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In plan view 1 turn on the house models
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11.2.6 Create outline of house for setout
We will now create a string around the outside edge of the cad house. This is done in a model HOUSE

Select option Strings=>Cad=>Lines=>Line string

or Create Line String icon

 

The dimensioning and setout numbers can be created as per the previous chapter

Type in the name and model name HOUSE in the CAD controlbar. Select the colour Green and linestyle 1 

Pick and accept the corner points of the cad 
house

Don’t create the string back onto the start 
point. Press [Escape] to exit the string 
option

To close the string select Strings=>Strings 
edit=>Close

or String Close icon
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11.3 Setout for evenly graded string
In this exercise we will manually import a polyline from cad, regrade the string and create setout points for 
uploading.

To begin create a new project called SETOUT3 in the folder

C:\12djobs\8.00\Training\Survey\Setout

11.3.1 Read in the polyline from cad
Select option File I/O=>Data Input=>DWG/DXF/DXB

Select format DWG

Select the File icon

Walk right on User_lib and 
select DRAIN.DWG

Type in DWG* as the prefix 
for the loaded models

Type in 0 to ensure any 2d 
data is nulled

The rest of the panel can 
remain unchanged

Select Read then Finish
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11.3.2  Convert the polyline to an alignment string
The imported polyline has no height but the string is to be evenly graded from level 20.0 to level 25.0

We will convert the polyline to an alignment to grade the string. The option to be used will filter any 
duplicate points normally created at tangent points due to rounding errors. 

Select Utilities=>A-G=>Convert=>Poly to alignment

Turn on the model DWG DRAIN

Select the String pick icon

Pick and accept the polyline

Type in a new name and model 
name for the alignment

Select a different colour

Tick the Delete original check box

Select Process
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11.3.3  Create heights for each end of the alignment
We need to firstly create a section view to profile the alignment

Select View=>New=>Section

Select the profile icon then pick and accept the alignment string in the plan view

To edit the alignment string select Strings=>Editor or [F6]

Pick and accept the alignment string

Turn on the model 
DRAIN CL
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The alignment editor is displayed

Walk right on Append and select VIPs

Press the [Space] bar in the section view and type in 0 20 [Enter] to 
input the chainage of 0 and the height of 20

For the end chainage select [F2] and pick on the end point in the plan 
view. Record the chainage 
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Press the [Space] bar in the section view and type in 414.116 
25 [Enter] to input the end chainage and height

Press [Escape] key to exit VIP entry
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11.3.4  Create special chainage file for setout points
The string is to be setout every 10 metres with tangent points included so we need to create a file of 
chainages that will be used in the setout option

Select Design=>Roads=>More=>Special chainage file

or Special Chainage File icon 

Change the Data Source 
option to Align str / curve

Tick check box to Add IP’s 
and Tangents 

Type in the straight spacing 10 
and the Curve spacing as 5

Select Add to List

Select View List

The chainages are listed. 
Duplicate and very close 
chainages can be deleted in this 
list

Select Set to close the file

Press Reference 
and pick the 
alignment string
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11.3.5 Create chainages for the alignment string
Chainages will be created to identify the setout points

Select Strings=>Label=>Chainages (Function)

 

Type in the file name Setout

Select Write then Finish

Type in function name SETOUT CH

Select the String to label pick icon then 
select the alignment string

Select Label mode choice icon and 
select end points only

Select Setout.spc as the special 
chainage file

Select the Labels tab

Type in CH LABELS for the text 
model name

Select the text favourite CHAINAGE

 

Select the Marks tab

Type in CH MARKS as model for 
marks

Select Ticks centred for mark mode

Type in appropriate height for text

Select colour for marks

Select Label



Chapter 11  Setout

February 2007 Page  309

Turn on the CH models

Set the plot scale to 1:200 as shown in chapter 11.1.4
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11.3.6 Create setout points
We will now generate point numbers for the alignment

Select option Survey=>Setout=>Setout point using super strings

Prior to running the option we 
will set up some parameters

Select Setout Options button

The Setout Options panel 
will appear

Tick the check box to Use 
Highest Project Vertex ID

Select the Textstyle data icon 
and select Co-ordinates 
1:200. This will ensure the 
text is the right height for a 
1:200 plot

Select Set Finish to close the 
panel
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Select String to label

Pick and accept the alignment 
string

The Alignment Setout panel 
appears

Select the Chg Interval Type 
icon

Select by special chg file

Select the file Setout.spc

Select Set then Finish

Select Label
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The point numbers can be moved using the Edit tab. This is described in chapter 11.1.5

Type on the Setout model
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11.4 Setout for polyline culdesac string
In this exercise we will import a 2d lip of kerb polyline from cad and create heights from a provided layout 
drawing

To begin create a new project called SETOUT4 in the folder

C:\12djobs\8.00\Training\Survey\Setout
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11.4.1 Read in the polyline from cad
Select option File I/O=>Data Input=>DWG/DXF/DXB

Select format DWG

Select the File icon

Walk right on User_lib and 
select Culdesac.DWG

Type in DWG<space> as 
the prefix for the loaded 
models

Type in 0 to ensure any 2d 
data is nulled

The rest of the panel can 
remain unchanged

Select Read then Finish

Turn on the model DWG 
KERB LIP model
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11.4.2 Filter the imported string to ensure there are no duplicate vertices at the 
tangent points

Select option Utilities=>A=G=>Filter=>Vertex filter

Turn on the vertex indices

Occasionally duplicate vertices will 
occur. These are highlighted by the 
overlapping numbers

Select the String icon

Select the String pick icon then select 
the string

Select Dimension 3d

Type in tolerance 0.001

Set target to Move to original model/
replace
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11.4.3 Segment the string
We now segment the string into the equal parts shown in the diagram at the start of this topic

Select option Strings=>Strings edit=>Segment strings

The duplicate vertices are removed. Now remove the vertex indices

Select Pick then select the first segment

Type in 5 as number of parts

Select Process

.Repeat for each segment of the string



Chapter 11  Setout

February 2007 Page  317

6 parts

8 parts

4 parts
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11.4.4 Add heights to string
Heights will be added from the diagram

Toggle on the Z values

To edit the string select option Strings=>Editor

or Edit String icon

Pick the string to bring up the String edit toolbar

To change the heights of individual vertices we need to select the Advanced mode

Select the Vertex Height icon
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Select each vertex as the Height mode

The first point on the string is highlighted

Type in the height of the point then select Apply

Select Next to move to next point on string. Repeat the input of levels
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Exit the String editor panel by selecting Process Exit icon

11.4.5 Parallel the lip string for setout
The lip will be paralleled to create setout points. The heights will be raised 0.11 be relate to the kerb level 
and the offset will be 0.5 behind the back of kerb

Select option Strings=>Cad=>Change strings=>Parallel

or String Parallel icon

 

Add a new model KB OFFSET to the cad control bar

Select and accept with direction the kerb in a 
clockwise direction

Select No to parallel whole string 

Type in offset -1.1 [Enter]

Type in offset height 0.11 [Enter]
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The creation of the point numbers for upload is discussed in the previous chapters
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11.5 Triangulation setout
In this topic we will use a triangulation of a surface to create an upload file to be used in a data collector

To begin create a new project called SETOUT5 in the folder

C:\12djobs\8.00\Training\Survey\Setout

11.5.1 Import file
Read in the road surface data

Select option File I/O=>Data Input=>12da/4da data

Select Read then Finish

Select 12d ascii as Format

Select Ascii file icon then double click on file 
Road Setout.12da from the User_lib folder

Select Read 



Chapter 11  Setout

February 2007 Page  323

11.5.2 Create upload file of the triangles
The triangles can be written to an upload file. We will use the option to upload the triangles to the Trimble 
instrument

Select option Survey=>Upload=>Create triangle upload file

Turn on the model tin SMITH ST

Select File Type choice icon

Select Trimble binary *.ttm

Tick the check box to Use Trimble Link

Tick the check box to Upload direct to Trimble Device

Note: Trimble Link has to be installed to use this option

Type in a job name for the tin

Type in a file name

Select the tin SMITH ST

Select Write to create the file

The number of triangles selected are 
displayed

Select Yes to continue 

The file is created
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Select Read then Finish

The device can be selected for uploading

Once uploaded to the instrument the tin can be used in setout options

Triangulation setout

Road setout with tin used for heights
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11.6 Road Setout
In this topic we will create an upload file of the horizontal and vertical alignment along with the strings or 
cross sections. We will use the previous Project otherwise create a new project and read in the ascii file 
described in the previous chapter

11.6.1 Create upload file of road alignment for Leica 1200
The Leica 1200 Road Runner program can accept the alignment and strings for a road setout

Select option Survey=>Leica=>1200=>Roads

Turn off the model tin SMITH ST 
then turn on models on the road models

Type in SMITH ST as job name

The file SMITH ST.xml will be created along 
with the database files

Tick the check box to Create database

The road will be a simple one with only the 
finished surface layer to be uploaded

There is a string at the crown so the alignment 
won’t be used in the layer

Select the model of the strings

Select Write
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11.6.2 Create upload file of road alignment for Trimble
The Trimble instruments can accept the alignment and sections for a road setout

Select option Survey=>Upload=>Create road upload file (new)

On board the Leica the strings are cut at the 
required chainage and a section can be 
viewed

Select Trimble Link

Tick the check box to Upload direct to Trimble 
Device

Note: Trimble Link has to be installed to use this 
option

Select the Alignment pick icon then select the 
alignment string

Tick the check box to Report vertical alignment and 
to Report X-sections

Select SMITH ST SECTIONS for the section model

Select Write
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Select Read then Finish

The device can be selected for uploading

On board the Trimble the road sections 
can be setout



12d Model Training Manual

Page  328 February 2007

11.7 Setout reports
The final position of the Setout points can be checked against the design positions in a number of ways

We will look at three ways

11.7.1 Check setout points against design points
To begin create a new project called SETOUT6 in the folder

C:\12djobs\8.00\Training\Survey\Setout

r

Read in the design data

We will read in an ascii file of the house we created setout points for previously

Select option File I/O=>Data Input=>12da/4da data

Select Read then Finish

Select 12d ascii as Format

Select Ascii file icon then double click on file 
House.12da from the User_lib folder

Select Read 
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Read in the as-constructed data

We need to import the as-constructed points

Select option File I/O=>Data Input=>12da/4da data

Turn on all of the models. The plan scale has to be set to 1:200. This process is explained in chapter 11.1.4

Select Read then Finish

Select 12d ascii as Format

Select Ascii file icon then double click on file 
House Ascon.12da from the User_lib folder

Select Read 
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Calculate the differences between the design and as constructed data

Select option Report=>QA Reports=>Check survey points vs design points (2)

Turn on the as-constructed data

Select the model ASCON for the survey 
model

Select the model HOUSE for the design 
data

Type in model name not surveyed to create 
points that represent data not surveyed

Type in report name HOUSE ASCON

Type in distance from the design point to 
look for a corresponding as-constructed 
point

Select Distance as the tolerance method

Type in the tolerance

Select Run
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To view the report file select the Report file 
folder icon

Select Open
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11.7.2 Check asbuilt strings against design strings
To begin create a new project called SETOUT7 in the folder

C:\12djobs\8.00\Training\Survey\Setout

r

Read in the road strings data

Select option File I/O=>Data Input=>12da/4da data

Select Read then Finish

Select 12d ascii as Format

Select Ascii file icon then double click on file 
Road Setout.12da from the User_lib folder

Select Read 
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Read in the as-constructed strings

Select option File I/O=>Data Input=>12da/4da data

Turn on the alignment and road 
strings

Select 12d ascii as Format

Select Ascii file icon then double click on file 
Road String Ascon.12da from the User_lib 

folder

Select Read 
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Calculate the difference between the ascon string and the design string

Select option Report=>QA Reports=>Check asbuilt string vs design string

Turn on the model EOB ASCON

Select As built string button then pick 
and accept the red EOB ascon string

Select Design string button then pick and 
accept the design EOB string

Select Control string button then pick 
and accept the alignment string

Tick all of the check boxes

Type in 5 for the report interval

The start chainage is kept as 0 but the end 
chainage is changed to 40

Type in report name EOB ASCON

Select Report
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To view the report file select the Report file 
folder icon

Select Open
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11.7.3 Check as constructed points against the design tin
To begin create a new project called SETOUT8 in the folder

C:\12djobs\8.00\Training\Survey\Setout

r

Read in the road strings data

Select option File I/O=>Data Input=>12da/4da data

Select Read then Finish

Select 12d ascii as Format

Select Ascii file icon then double click on file 
Road Setout.12da from the User_lib folder

Select Read 
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Read in the as-constructed points

Select option File I/O=>Data Input=>12da/4da data

Turn on the tin 
model

Select 12d ascii as Format

Select Ascii file icon then double click on file 
Pavement Ascon.12da from the User_lib folder

Select Read 
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Calculate the difference between the ascon points and the design tin

Select option Report=>QA Reports=>Check points vs tin

Turn on the model PAVEMENT 
ASCON

Select PAVEMENT ASCON as the 
model of shots

Select SMITH ST tin to check against

Type in above and below tolerances in 
mms

Type in 0 as the layer depth

Type in report name PAVE ASCON

To reference the points to a control line 
tick the check box

Pick Select Align then pick and accept 
the alignment string

Select Report
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To view the report file select the Report 
file folder icon

Select Open
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12 Subdivision Design
In this exercise we will create a subdivision using a defined outline and explore the various options 
involved in creating and reporting lot layouts
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12.1 Setting up a New Project
To begin create a new project called LOTS in the folder

C:\12djobs\8.00\Training\Survey\Subdivision

12.2 Create the surrounding boundary
We will firstly create the string around the edge of the subdivision

Select option Survey=>Extras=>Bearing/Distance Entry

We are now able to type in the bearing and distances around the edge of the boundary

Type in a model name SURROUND

Select the colour purple

Select linestyle 1

Type in Scale Factor 1

We will not be using point numbers so select 
none

Type in start co-ordinates 1000 5000

We will not be using heights so untick the 
check box
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Type in the bearing and distance of the string around the 
surround boundary

Select the Enter or Tab key to move between cells.

After typing in the distance press Enter to create the next 
line

Use the bearing and distances as shown in the example 
on the right

When all lines have been entered select Process then 
Finish

Turn on the model SURROUND
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Zoom all of the job

The surround string should appear on the screen

To check the distance between the start and end point select Utility=>Measure=>Bearing/Distance

or Measure Bearing/Distance icon

Zoom in to the start point then select and accept the start and end point
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If an error is found the relevant line can be corrected in the Bearing/Distance Entry panel and re-
processed

Select Finish to exit the panel

The string now needs to be closed to form a polygon

Select the option Strings=>Cad=>Change strings=>Close

or Cad string close icon

Select and accept the surround string

12.3 Duplicate the surround
The surround string is to be duplicated in a new model called BOUNDARY. This new model will be used 
in the subsequent lot calculations

Select Strings=>Strings Edit=>Duplicate

Select and accept anywhere on the surround string

Now turn off the model SURROUND and turn on model BOUNDARY

Type in new model name 
BOUNDARY

Select colour Red

Select Start
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12.4 Open the Surround string
To help with future calculations using the boundary string we open the string at this point.

Select option Strings=>Cad=>Change Strings=>Open 

or Cad string open icon

then pick and accept the boundary string at the bottom right corner

12.5 Create Road Centreline
The centreline of the road reserve will now be created

Create a new model called CL in the cad control bar and change the colour to blue

Select the option Strings=>Cad=>Lines=>Traverse create

or Traverse icon

 

Type in the next bearing as 273.45 [Enter] and the distance as 103 [Enter]

Press [Esc] key to exit the traverse entry

Press the Space bar and type in 965 4998 [Enter]

Press the Space bar and type in the bearing 350.3000 [Enter] 

Press the Space bar and type in the distance 90 [Enter]
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To insert a curve into the centreline string select option Strings=>Cad=>Change strings=>Join fillet

or select the String Join fillet icon

Select up the first straight with 
direction and accept. Pick along the 
second straight with direction and 
accept

Type in the radius -20 [Enter]

The curve is inserted



Chapter 12  Subdivision Design

February 2007 Page  349

12.6 Create Road boundaries

12.6.1 Parallel centreline string
The road boundaries will be created parallel to the road centreline

Select the model BOUNDARY and the colour Red in the Cad Control bar

Select the option Strings=>Cad=>Change Strings=>Parallel

or String parallel icon

Select the string with direction 
and accept

Select No. This will parallel the 
whole string

Type in the offset for the left as -7.5 [Enter]

Type in the offset for the height as 0 [Enter]
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The centreline string is 
paralleled

Repeat this for the other 
side of the road using 
offset 7.5

Both sides are paralleled
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12.6.2 Convert arcs to chords
The arcs along the road boundary are to be converted to chords. These are created on the outside of the 
right hand curve and inside the left hand curve

Select the option Strings=>Strings Edit=>Arc to chords

Select Pick

Select and accept the inside curve

Set the Convert Method to inside

Set the Method to no. of chords

Type in 2 for No. of chords

Select Process

The arc is converted to 
two chords
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Repeat the process for the outside arc creating three chords on the outside

Turn on the vertices and vertex indices

Select Pick

Select and accept the outside curve

Set the Convert Method to outside

Set the Method to no. of chords

Type in 3 for No. of chords

Select Process

Select the Toggle icon

Select Vertices to turn on 
crosses at vertices

Select Vertex indices to 
turn on vertex numbers



Chapter 12  Subdivision Design

February 2007 Page  353

Two vertices are now redundant

To delete these points select 
Strings=>Cad=>Delete=>Points

or Vertex Delete icon

Select and accept the two points

The points are now 
deleted
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12.6.3 Splay the road intersection boundaries

The road intersection boundaries have to be splayed using 3 chord truncations. 

Zoom in to the road intersection

Trim and delete boundary lines

We will use an option to split the strings at the intersection points

Select option Strings=>Cad=>Change Strings=>Cad Cross Split

or String Trim icon

 

Select and accept the two 
intersecting lines

Repeat for the other side of the 
road

The strings are split at the 
intersections
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We will now delete the redundant strings

Select option Strings=>Cad=>Delete=>Strings or String Delete icon

 

Pick the three strings
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Fillet corners

Before splaying the corners the segments have to be joined to create one string. Filleting the strings with a 
zero radius will join the strings and remove any duplicate points

Select Strings=>Cad=>Change Strings=>Join fillet 

or String Join Fillet icon

 

Select with direction and accept the 
first segment

Select with direction and accept the 
second segment

Type in radius 0 [ENTER]

Repeat for the other side
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Create corner splays

Select the option Strings=>String Edit=>Corner Splays

Type in 3 for the number of chords

From the Convert mode choice list 
select tangent length

Type in a tangent length of 8

Untick the Keep original string 
check box

Select Pick

Select and accept the left side 
intersection point

The truncations are created
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12.6.4 Create Cul de sac head
We will now create a cul de sac head manually. Before continuing ensure the current model is 
BOUNDARY and set the default colour in the Cad Control bar to red

Create Circle

Zoom in to the end of the subdivision road

Select option Strings=>Cad=>Circles=>Centre, Radius

or Centre and Radius icon

Repeat for the other side of the road 

Select Finish

Select and accept the point at the end 
of the road
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Press the space bar and type in the radius of 12.5 [Enter]

The circle is created
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Create boundary lines around cul de sac head

Prior to creating the trapezoid around the circle we need to create an offset point for the orientation of the 
trapezoid

Select option Strings=>Cad=>Points=>Offset

or Cad Offset Locate icon

Select top edge of the road boundary 
string with direction

Select and accept the end point of the 
string

Type in the distance 0 [Enter]

Type in the offset -5 [Enter]

The offset point is created at the edge 
of the circle
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We now create an 8 sided trapezoid about the circle

Select option Strings=>Cad=>Polygons=>Polygon Circumscribed

or Polygon Circumscribed icon

 

Select and accept the point at the 
centre of the circle

Type in the number of sides as 8 
[Enter]

Select and accept the offset point 
to position the shape
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Delete the circle and right segment of the trapezoid using delete options Strings=>Cad=>Delete Strings 
and Strings=>Cad=>Delete=>Segments

or String Delete icon and Segment Delete icon

 

The trapezoid is created around 
the outside of the circle

Delete the offset point used to 
create the trapezoid
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Fillet the trapezoid to the road boundary strings

Select option Strings=>Cad=>Change strings=Join fillet

or String Join Fillet icon

Pick and accept the two strings 
with direction

Type in the radius 0 [Enter]

Repeat for the lower edge
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12.7 Create lots

12.7.1 Split string at starting edge
Before we start creating lots the front and rear boundaries should be separated. This is achieved by 
splitting the string either end of the start and end edges of the lots

Select Strings=>Cad=>Change Strings=>Split

or String Split icon

Zoom in to bottom right 
of the subdivision

We will split the 
string at vertex 2, 24 
and 25

Select and accept 
string from 1 to 2

Select and accept 
point at vertex 2

Select and accept 
string from 24 to 25

Select and accept 
point at vertex 25

Repick previous 
string then select 
and accept point at 
vertex 24

Select Finish on 
panel

Toggle off the vertex 
numbers
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12.7.2 Create lots by different methods
The first three lots will be created by specifying a minimum area for the new lots

Select option Design=>Estate/Lots=>Create lots=>Create lots

Type in model name LOTS

Select view 1

Select colour purple

Type in 800 as minimum area

Type in 8 as the minimum frontage

Select Pick front and select and accept the front boundary 
string with direction

Select Pick back then select and 
accept the rear boundary string with 
direction

Select Pick edge then select and 
accept the start edge

Select Method for lot choice icon then select 
perpendicular

Select Pick front/back then select and accept the front 
boundary line. Pick somewhere along the main along away 
from the corner splays

Select Process to create lot
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The first lot is created with the new 
edge perpendicular to the road frontage

Select Process again

A second lot is created
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Select Process again

The third lot is created

The new lot edge is not parallel to the 
previous edges as the front boundary 
line has an angle.

Select Undo to remove the last lot

Select Method for lot choice icon

Select parallel edge

Select Process
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The next lot to be created will not have a minimum area but will have a new edge bound by two

existing vertices on the front and rear boundaries. We will use a new option to create this lot.

 

The third lot is now created with the 
new edge parallel to the previous edge

Minimise the Create Lot panel
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Select option Design=>Estate/Lots=>Create lots=>Create lots by picking segments

Pan up to the top right of the 
subdivision

The new boundary edge will be created 
from the shown vertices

Select model LOTS

Select colour purple

Tick the check box to Join first and 
last segment

Select Pick sides
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To inquire on the area select Strings=>Inquire

or String Inquire icon

Pick and accept the 
segments with direction 
clockwise from top right 
vertex

Take care to zoom into 
the small segment at 
the front

The no. of segments: is 
shown

Select Process to create 
lot

Select Finish to exit

The new lot is created
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The next lots will be created using the minimum area panel again

Pan left from the last created lot

Maximise the Create Lot panel

Select anywhere on the lot edge but do 
not confirm

If the lot polygon is highlighted the area 
is displayed in the Information panel

Press Escape key to exit the Inquire 
option
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Change the Min area to 1100

Select Pick edge then select and accept the 
last side boundary line

Select Method for lot 
choice icon then select pivot 
pick

Select Pick a point then select and accept the 
next vertex

Select Process

The new lot is created with the new edge 
pivoting about the selected vertex
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Select Process three times to create three new lots

Now change the minimum area back to 800

Set the Method for lot to perpendicular

Select Pick front/back

The three new lots are created with new edges perpendicular to the front boundary
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Zoom in to the end of the cul de sac

The next lot will be created 
with area of 900 and the 
new boundary edge to pivot 
from this vertex

Change the minimum area to 900

Set the Method for lot to pivot 
pick

Select Pick a point

Select and accept the pivot 
point

Select Process then Finish
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Pan around to the bottom of the cul de sac

A new lot is created

The next lot will be a park 
lot.

We will use the option to 
create lot by selecting the 
sides.

The final edge will lie 
between these vertices
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Select option Design=>Estate/Lots=>Create lots=>Create lots by picking segments

Minimise the Create Lot panel

Select model PARK

Select colour dark green

Tick the check box to Join 
first and last segment

Select Pick sides

Select and accept the sides with direction in a 
clockwise direction from this vertex

After accepting last line 

select Process then Finish
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For the next six lots we will use the previous Create lots option

Pan along the right as per the example below 

Turn on the model PARK
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Maximise the Create Lot panel

The new lot is created

Select Process three times

Type in 800 as minimum area

Select Pick edge then select and accept the front boundary 
line

Select Method for lot choice icon then select pivot pick

      Select and accept point at next vertex

For the next three lots we 
change the Method for lot 
to parallel bearing 

Type in the bearing 3.45



Chapter 12  Subdivision Design

February 2007 Page  379

The three new lots 
are created with the 
new side at bearing 
3°45’

Pan down to the last section 
of the subdivision

The next lot will have its 
new edge pivot from a rear 
vertex

Change Method for lot to 
pivot pick

Select Pick a point then select and 
accept the next vertex on the rear 
boundary

Select Process to create new lot
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To create the last lot we will use an option to form a lot polygon from picking the centre of a series of strings. A 
search distance is entered to find all strings within the search distance radius

Pan down to the last lot

Select Design=>Estate/lots=>Create lots=>Create lots by picking point inside

The new lot is created

Select Finish on Create Lot 
panel

Select view 1

Select model name LOTS

Select colour purple

Type in search distance 50

Select Pick and select and 
accept a point inside the area 
to create the lot. Ensure the 
position you pick can see to 
each vertex of the lot
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The new lot is created

This completes the house lot creation

We now create a lot for the road. 

Zoom the whole of the subdivision 

Turn off models LOTS and PARK

Turn on the model SURROUND mode

Turn off the vertices
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Zoom in to the road intersection

The string around the road has to be extended 
to follow the surround string across the road

Select Strings=>Cad=>Change points=>Point 
append

or Append Point icon

Select the point at the left of the road

Ensure that the road string is highlighted. 

If the other string is highlighted select the 
point again

Accept the point

Select and accept on the first point along 
the surround string
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We now close the road string

To save this closed string as a road lot select Design=>Estate/lots=>Create lots=>Create lots from polygons

Select Strings=>Cad=>Change strings=>Close

or String Close icon

Select and accept the road string

Zoom the whole of the 
subdivision
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Turn on the model ROAD

Select String for Data source from 
choice icon

Select String to convert

Select and accept a point on the road 
string

Type in ROAD for model name

Select colour blue

Leave check boxes as per the default 
values

Select Process

Select Finish

The road lot is shown 
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12.8 Lot numbering
The lots can now be numbered according to the type of lot.

 Lots, parks and roads will be numbered separately

Zoom all of the subdivision and ensure that only models LOTS, PARK and ROAD are turned on
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12.8.1 Create lot numbers
Select option Design=>Estate/Lots=>Number Lots=>Create lot numbers

 

Select the Data source icon then select view

Select view 1

Type in 1 for Next lot no.

Select Lot type choice icon

Select lot

Select colour purple

Tick Auto increment check 
box

Type in 1 as Lot increment

Tick Display lot number check box

Select Pick

Select and accept a segment of 
the first lot

1

Repeat 
numbering lots 
until reaching 
the park

Continue 
numbering the 
lots from the 
other side of the 
park

1

2

3

4

56789

10 11 12 13
14

15
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To create the description for the park change the following settings

To number the road change the following settings

Type in PARK as Next lot number

Select Lot type choice icon and select park

Change the colour to dark green

Type in PARK as Next lot number

Select Lot type choice icon and select park

Change the colour to dark green

Select Pick

Pick and accept the park string

Type in ROAD as Next lot number

Select Lot type choice icon and select road

Change the colour to blue

Select Pick

Pick and accept the road string

Select Finish to exit the panel. The 
temporary numbers will disappear
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12.9 Lot labelling
The lot annotation can now be created. Features such as bearings, distances, lot numbers and areas are 
created for each lot

The annotation settings can be stored in a Lot annotation file which is loaded prior to creating the 
annotation

Ensure that the models LOTS, PARK and ROAD are the only models active

Zoom all of the subdivision

Select option Design=>Estate/Lots=>Label Lots=>Lot labelling

Select the Lot annotation file 
choice icon

Double click on the file 
DETAIL.laf from the 
User_lib folder

Select Read
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Each type of annotation can be edited by selecting the 
edit icon

To create the different text types tick the relevant check 
boxes

A short line table can be created which will tabulate any 
line where the distance of the line is less than a user 
defined value

Select Lot type choice icon and select ALL TYPES

Select Data source icon and select view

Select view 1

Select Process

Turn on the annotation models
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Set the plot scale to 1:500

Select Menu icon

Walk right on 
Settings=>Ploting scale

Select view 1

Type in scale 500

Select Set then 

Finish
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12.9.1 Edit the annotation
The annotation text can now be edited by using option on the text flyout toolbar

Reverse Bearing

To reverse the direction of a bearing label select option Design=>Estate/Lots=>Lot Utilities=>Reverse 
Bearing

Select and accept the bearing to be reversed. You may need to turn on the vertices to see the insertion point 
of the text or you can turn on the text snap [X] from the snaps toolbar to click anywhere in the text 
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12.9.2 Create Short Line table
The short lines have been identified with a circled number 

We now need to create the short line table

Select option Design=>Estate/Lots=>Lot Utilities=>Short line/arc table

Select the Model of numbers 
choice icon

Select model 
textShortsegments

Select the Table position icon

Select and accept a point on the screen representing the top left corner of the 
table

Select view 1 to show the table

Select Process to create the table
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The bearing and distances of the short lines are displayed along with the relevant lot number

To move the table select option Drafting=>Multi strings translate

Select and accept a piece of text in the table

Move the table to a new location and accept the position

Select Finish to exit the option

Select Name 
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12.10 Create colour table of lot areas
Lots can be coloured and a table created based on the size of the lot.

Select option Design=>Estate/Lots=>Lot Utilities=>Colour lots by range file

Select Range file icon

Select range file LOT AREA.lrf from the User_lib 
folder

Set the Data source to 
model

Select LOTS as the Model 
of lots

Select the Table location 
icon and select Pick xyz

Select and accept a point on 
the screen representing the 
top left corner of the table

Type in txt colour table as 
model name

Type in 1 as the text size

Select Red as text colour

Select Process then Finish to 
colour the lots and create the table

Turn on the colour table model
 txt colour table
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The lots are coloured based on the mapping file

Zoom in to the colour table

The lot sizes are listed along with the number of lots in each category and the average area
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12.11 Lot Reporting
We will now generate a report on the subdivision

Select option Design=>Estate/Lots=>Report Lots

Turn on the SURROUND 
models to use as the Boundary

Select Data source icon 
then select view

Select view 1

Select Report type icon then 
select sort by type

      

Select Boundary then 
select and accept part of 
the SURROUND string

Type in 3 for number of 
decimal places

Type in 0 for number of 
decimals for the seconds 
in the bearing

Type in report file name 
LOTS

Select Process

      Select Report file folder 
icon

Select Open
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The first section of the report deals with the lots

The number, area and dimensions are displayed along with the vertex co-ordinates

After the last lot is displayed, the number of lots along with the total area, average area and percentage of 
the boundary (SURROUND) are listed
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The park is listed

The road is listed
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At the end of the report the total number of lots are listed along with the area

Any errors in the lot creations should yield a percentage difference to the boundary

Exit the report file
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