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1.0 Advanced Stormwater Design - Introduction

The Stormwater Design Course Notes and this manual, the Advanced Stormwater Design 

Course, describe the functions and processes of the 12d drainage module. 

The Stormwater Design Course Notes contain:

s set drainage defaults and layout a drainage network,

s use the powerful 12d drainage network editor to avoid service clashes, grade pipes, 

align obverts, minimise depth and many other design tools,

s automatically assign names to the pit/pipes in the network,

s designate catchment areas and produce catchment plans,

s transfer data to and from electronic spreadsheets to enable the user to easily review 

the data and add user defined data to the 12d pipe network. This data may include 

such data as pipe bedding types and trench width,

s create pit layout schedules to export to spreadsheets or word processors for final for-

matting.

s produce long section drainage profiles including HGL data, flows, invert levels, serv-

ice crossings

s create plan drawings with pipe sizes, flows, manhole symbols, linestyles for pipe 

sizes, design parameters for manhole and pipes and user defined data

s locate pits/manholes at exact chainage and offset locations

This manual, the Advanced Stormwater Design Course, is intended to describe the more 

advanced features 12d model drainage and discuss the customisation of the package. This will 

include

s drainage trench excavation volume calculations

s pipe and manhole quantity calculation

s customising the drainage.4d file

s design or evaluate the drainage system using 12d Drainage or create input files for the 

XP SWMM/RAT2000, Micro drainage, Drains and PCdrain drainage design pack-

ages,

s read the output from the drainage design packages (automatic if using 12d Drainage), 

update the drainage network and store the hydraulic data, such as hgl (hydraulic grade 

line) levels, peak pipe flows and pipe capacities,

s pit inlet capacity calculations and over land flow

s flooded width analysis

s surcharge volumes at SAG pits

s and detailed drainage plan labelling
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2.0 Setup Files and Their Locations

The drainage module consists of the optional 12d Drainage engine, utilities, startup configuration 

files for RAT2000, XP SWMM and the 12d drainage configuration file (drainage.4d). Demonstration 

versions of Drains, RAT2000 and PCdrain have been included on the CD along with a copy of the 

ILSAX hydrology package. Manuals for the ILSAX program may be obtained from the Civil Engi-

neering Department at the University of Technology Sydney.

All setup files have been configured for the training version. However, when you start working on 

real projects you may want customise the drainage module. More - Customising the drainage 

module

The drainage.4d file contains pipe types (RCP, Class 2 etc.) and example pit inlet capacity tables for 

RTA (NSW Road and Traffic Authority) standard pits. Detailed pit type descriptions and internal pit 

dimensions can be included in this file to be inserted into your pit schedules. For PCdrain users there 

is a routine to read your gully pit file and include these pit types in 12d More.

See “The drainage.4d file” on page 62.

REVIEW THIS DATA CAREFULLY! A detailed description of the pit inlet capacity tables in this 

file is given in “Pit Inlet Capacities” on page 63. The drainage.4d file may be customised for any 

additional inlet capacity data you may have.
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3.0 Starting with a Basic Drainage Network

These course notes assume that you have completed the Stormwater Design Course and that you 

have experience creating 12d model drainage networks with catchments areas. This course will 

begin with a completed drainage design found in the directory

\12djobs\courses\7.00\drainage\local road complete

4.0 Excavation Quantities

Sample templates are included in the courses section of 12djobs (\12djobs\courses\7.00\drain-

age\pipe template.tpl). The templates from this template library may be added to your project 

using 

Design=>Templates=>Utilities=>Input.

This routine uses 12d templates to calculate the excavation volume for all of the drainage strings 

in a model. An option to create section for a tin on top of the pipe is also available so that the 

drainage long sections can include hatching between the obvert of the pipe and the design tin 

under roads.

Templates with names set to the pipe diameters (times 1000) are used for the calculations, thus 

trench shapes can be customised and over excavation for bedding materials can be included. Net 

area calculations to exclude pipe area are not supported.

Key points

1. One template for each pipe size (mm) 

2. If obvert templates are used, add the prefix “obvert “ to the pipe size

3. Carefully consider the tin selected.

A template must exist for each pipe size in the model (pipe size x 1000). For example a 0.3m pipe 

will require a template to exist named 300. A 0.5ft pipe would require a template named 500. 

Sample templates are included in the courses section of 12djobs (\12djobs\courses\7.00\drainage). 

These may be copied to your *.project directory and then added to your project using 

Design=>Templates=>Utilities=>Add=>All all to project.

The templates are run along the strings and the total volumes are reported. Volumes for each 

strings are given in the report file. An example follows.
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If a tin is created from these strings then volumes by depth can be determined using Design=>Vol-

umes=>Exact=>Tin to tin

Usage

Access this panel from the menu selection 

Design => Drainage => Reports => Excavation Quantities

 ----------------------------- BEGIN APPLY TEMPLATE REPORT ------------------------------

  apply template to string report - 

    string         E

    tin            design

    separation         10.000

    left template  375

    right template 375

    cut volumes and areas are negative

    fill volumes and areas are positive

 chainage- ------sectional  information------  ------intermediate  information----    ---------accumulative  information-------

           ---------- ---cut area --fill area ------------ ----cut vol ---fill vol    -cut volume-- -fill volume- ---balance---

     0.000                 -1.434       0.000                                                 0.000         0.000         0.000

                                                                -0.771       0.000

     0.550                 -1.367       0.000                                               -0.771          0.000        -0.771

                                                               -14.222       0.000

    10.000                 -1.642       0.000                                              -14.992          0.000       -14.992

                                                               -15.293       0.000

    20.000                 -1.416       0.000                                              -30.286          0.000       -30.286

                                                                -1.845       0.000

    21.313                 -1.393       0.000                                              -32.130          0.000       -32.130

                                                                -0.794       0.000

    21.863                 -1.493       0.000                                              -32.924          0.000       -32.924

 total cut                         -32.924

 total fill                          0.000

 balance                           -32.924

 ie excess of cut over fill         32.924

 ----------------------------- END APPLY TEMPLATE REPORT ------------------------------
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Drainage model input box

Model to contain all of the pit and pipe network to be worked on.

Strings model model box

Strings generated from the templates will be stored in this model

Sections model model box

Sections generated from the templates will be stored in this model

Report name input box

cut and fill volumes will ne sent to this report

Ground Surface Tin tin box

tins from which the volumes will be calculated

Separation real box

distance between the sections

Sections colour colour box

Sections generated from the templates will be assigned this colour (strings colours are defined in the 

templates)

Clean section/strings model tick box

Delete the strings in these models before processing.

Stop section at edge of manhole tick box

Template are run from manhole centre to centre if this is not selected. The templates stop at the edge of 

the manhole if selected. This is often selected with the following option Use obvert templates.

Use obvert templates tick box

Templates must be named with the prefix “obvert”. i.e. obvert 300. The template is still run along the 

invert of the pipe but the user now has a section “set” of templates that can be used to create a tin on 

top of the pipe as well as below.
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5.0 Network Quantities Report

This panel is accessed from the menu selection 

Design => Drainage Sewer => Reports=> Network Quantities

Key points

1. Items are counted/totalled by depth and optionally type.

1. The routine will not "double count" items even if the ranges overlap. 

2. Types are case sensitive, types with spaces in the name must be enclosed in quotes and the wild 

card * may be used.

3. Use vertically offset tins and "banded" depth ranges to get quantities under roads, foot paths etc. 

This is discussed later in detail.

4. Erase count file fields if the items are not to be counted.

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Data String Source Choice

usually the entire model is selected but view is also available for combining models

MH config file file box

This file specifies the types and depth ranges for the manholes. Details of this file are contained below.
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Pipe config file file box

This file specifies the types and depth ranges for the pipes. Details of this file are contained below.

HC config file file box

This file specifies the types and depth ranges for the house connections. Details of this file are con-

tained below.

HC pit config file file box

This file specifies the types and depth ranges for the HC pits. Details of this file are contained below.

HC jump ups file file box

This file specifies the types and depth ranges for the house connections jump ups. Details of this file are 

contained below.

Report file file box

a sample report file is given below.

Report unused ranges tick box

the depth ranges for the manhole/pipe/house connections are defined in the *.4d files. Selecting this 

option will cause the depth ranges in the file to be printed even if there are no manhole/pipe/house con-

nections in these depth ranges (zero quantity values will be shown).

Report types tick box

Selecting this option will cause the manhole/pipe/house connection types used in the model types to be 

listed (even if quantities are not requested in the *.4d files). Since this is a complete of the type used in 

the model, the list informs the user what types have not been included in the quantity calculation.

Count button

executes the option.

Finish button

removes the dialogue from the screen

The *.4d files listed above are contained in the 12d library directory. Each line is the file per-

forms a count (count lines). No items are counted twice. Therefore, if an item is counted its type 

and then a count line is found the wild card is used for the type, the type already counted will not 

be included in the count.

The format for a count line is three or four values (space delimited) per line. Size is optional.

<type (from drainage.4d)>  <size> <starting depth>   <ending depth>

Notes:
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All types with spaces in the name must be enclosed in quotes The wild card * may be used.

The size is optional and if omitted the all sizes will be counted in this group (do not use the * for a 

wild card). 

The starting depth and ending depth are required for all count lines.

Quantities Under Roads and Footpaths

By creating super tins with vertically offset sections, quantities under roads, footpaths etc. can be 

determined. for example.

Offset your road design tin up by 1000m (Tins->Utility->Translate/Copy) and then use the depth 

range 1000-1999 for pipes under roads.

Create a tin from the footpaths only, null by angle length with a small length to remove the road and 

then offset it vertically by 2000m. the depth range 2000-2999 is not the quantities under the footpath.

Sample count lines

// sum concrete cover manholes is various ranges

"CONC COVER" 0.0 1.6

"CONC COVER" 1.5 3.0

"CONC COVER" 3.0 999.9  // this is expected to be zero

"CONC COVER" -999.0 0.0 // trap errors

// any that are not Concrete cover will be counted here

* 0.0 1.6

* 1.6 3.0

* 3.0 999.9
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Sample count lines for pipes follow. 

Manhole Quantities

====================================

CONC COVER          0.00    1.60    13      16.506

CONC COVER          1.60    3.00     1       1.510

CONC COVER          3.00   999.9     0       0.000

CONC COVER        -999.0     0.0     0       0.000

*                     0.00  1.60     0       0.000

*                     1.60  3.00     0       0.000

*                     3.00 999.9     0       0.000

  total length = 18.016

  Types Used

  ----------

  CONC COVER

  Diameters Used

  ----------

  1.100

 

Since the Report unused 

ranges tick box was selected, 

these lines were printed even 

though there were no man-

holes in the data ranges.

This data results from select-

ing the Report types tick 

box.
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// sum class 2 pipes by diameter and for various ranges

// count 375

2 0.375 0.0 2.0

2 0.375 2.0 5.0

2 0.375 5.0 999.

// count 450

2 0.450 0.0 2.0

2 0.450 2.0 5.0

2 0.450 5.0 999.

// count 525

2 0.525 0.0 2.0

2 0.525 2.0 5.0

2 0.525 5.0 999.

// count pipe sizes that were missed

2 * 0.0 2.0

2 * 2.0 5.0

2 * 5.0 999.

// count all other missed pipes

* 0.0 999.
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6.0 Exporting to Drainage Design Software Packages

12d contains most of the data required for your drainage design packages. However, each pack-

ages has specific design variables that 12d does not have access too. The design process is 

intended to export your data from 12d to the design package, design the drainage system and then 

read the results back into 12d for your long sections. 

If pits/pipes are to be added/deleted from your network during the design process you are safest to 

add/delete the pit/pipe to 12d and to your design package separately.

Not recommended and as a poor alternative, you have the option of reading the results back into 

12d, adding/deleting the pits/pipes and then exporting the data to a new drainage project in your 

drainage design software. As 12d does not have access to all of the data in the design packages 

this method is not recommended!

Some of the drainage design programs offer a third option that allows you to import data “on top 

of” an existing project thereby merging and over writing the existing data. Be sure to contact the 

drainage software supplier to obtain exact details of how the merging process is performed.

The interface is run by selecting Import/Export from the Drainage Network Editor

Design->Drainage-Sewer->Network Editor
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Export pipe diameters and inverts is generally select for existing systems only. If your design pro-

gram will set invert levels and pipe sizes then turn this tick box off for new systems.Some design 

programs will require initial inverts and pipe sizes. In this case this box should be selected on the 

first export.

Export default catchment/pit parameters is generally selected for the first export. For subsequent 

exports turn this selection off and then only the catchment areas (if the model is supplied above) will 

be exported.

The Drainage model is the model 

currently being edited. The I/O 

action determines if data is exported 

or imported and enables/disables 

many of the fields below.

The I/O format selects which exter-

nal program the 12d is interfacing 

with. Some programs use the win-

dows clipboard and others use files. 

If the clipboard is used the data will 

also be written to a file by 12d in 

case you need to take the data to 

another computer.

The Export options have slightly 

different effects depending on the I/

O format (program) selected above. 

Therefore they will be discussed 

later with the various formats.
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7.0 Drainage Data Input and Output to Spreadsheets

Spreadsheets are an effective method to manage the numerous variables urban drainage designers 

create in the modelling process. Spreadsheet data can be transferred to and from 12d in tab delim-

ited files and stored within 12d as “user definable attributes”. These attributes are linked to the pit 

and pipes within a network. Drainage long section plots can display the pipe attributes in the 

“arrows” data area and pit attributes in the bubbles area. Drainage plan drawing can also show 

these pit and pipe attributes.

Drainage strings will be created if they do not exist in the model but manholes cannot be added to 

existing strings.

See also

12d to spreadsheet transfers

Spreadsheet to 12d update and create

Spreadsheet options

7.1 12d to spreadsheet transfers

This interface is accessed the Import/Export button on the Drainage Network Editor.
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7.1.1 Options

The Spreadsheet Options section allows the user to define the amount of data exported.

Select Export

Select Spreadsheet clipboard

These options are not used for 

spreadsheet export.

Usually leave this off! Select 

to export the junction pit at the 

end of all drainage lines (very 

rarely needed).

You may also select to limit the 

output if desired. If you like 

using spreadsheets for data 

entry, the PCdrain data and 

ILSAX data formats are useful 

for adding data for the first time 

for either program.

Select Run to place the data on 

the clipboard.
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All Data: All of the 12d drainage string data and the user defined attributes will be exported to the 

clipboard in a tab delimited format. The 12d data names and the user defined attribute names will 

appear at the top of the spreadsheets columns.

ILSAX: For the ILSAX program, the spreadsheet column headings will change depending on the 

pipe and catchment indicators (P2 card) and the inlet type (P3 card). Therefore, use the ILSAX 

pipe editor macro to set up one pit/catchment for the type of data you wish to enter. Now when 

you export the pipe network data the column headings will include the names of the relevant 

parameters.

User defined below: The Customised list file name is used to define the drainage values, their 

order and format you desire.

The customised list file is a text file where each line contains a drainage variable or a spreadsheet 

IO command (blank lines are ignored unless preceded by the header command). The spreadsheet 

IO commands available are:

header to define a line of text to be exported

blank to leave a blank column in the output

pipe data to specify the following user defined attributes are pipe data

pit data to specify the following user defined attributes are pit data.

variable name a 12d drainage variable names

factor the following variable is multiplied by this factor

Export all junction pits 

when selected will repeat 

the data for the junction 

pit at the end of each 

branch line.

Preset Output this 

choice box offers the fol-

lowing choices:
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The simplest way to create your own customised tab delimited file is to set the Preset Output field 

to All data and leave the customised list file name field blank. Selecting Set, Finish and then Copy 

from the main dialogue. The data will be placed on the clipboard and a customised list file, named 

output_list.txt will be created containing the names of all of the drainage variables in the 12d 

model. Use a text editor to add/or delete the variable names, change their order and/or add spread-

sheet IO commands. Save the file with a new name! The output_list.txt file is overwitten on every 

export.

A listing of a customised list file follows. Note the words in the header file have a “tab” between 

them so that they will be spaces across the spreadsheet columns.

After creating your customised list file, select Options again and change the Preset Output field to 

User Defined below and enter the new customised list file name that you saved above. Select Set 

then Finish and finally Copy to put the formatted data onto the clipboard.

The data can be pasted into a spreadsheet program for checking or additional formatting.

CUSTOM FORMATED DATA MIGHT NOT BE PASTED BACK INTO 12d!

The data must be in the “12d drainage spreadsheet” format to be read into 12d.

Caution with manhole names in the form 1-1 or 1/1. Some spreadsheets will interpret these values as 

dates. If you use these formats for your manhole names you will have to paste command them in 

once, format the columns that contain the manholes names as text data and then paste the informa-

tion in again.

One final word on using the copy/paste commands in the Microsoft Excel program. The Paste Spe-

cial command using the “Skip Blanks” option will allow you to copy a large block of 12d data (with 

blanks in it) on top your data so that your data is preserved where it coincides with the blanks. To use 

this option paste the data into a blank spreadsheet and then select copy again. The Paste special 

header

Pipe Details

header

Name Length   U/S IL   D/S IL   Slope(%)   Class   Dia I.D.   Rough   Pipe Is   No. Pipes

pit data

*pit name

pipe data

*length

low ch invert

high ch invert

factor

100

*grade

pipe type

factor

1000

diameter
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option with “Skip Blanks” will now be available.

7.1.2 Spreadsheet to 12d transfers

This item is accessed from the Import/Export button on the Drainage Network Editor.

The following panel will appear.

Tab delimited, “12d drainage spreadsheet” format or “from to” format data must be on the clip-

board in order to update a 12d drainage model or create a new model. These format are described 

below.

7.1.3 Updating an Existing Model

The data usually is generated by 12d using the Export option, pasted into a spreadsheet and then 

copied back to the clipboard so that 12d can be updated. 

Select Import

Select the Spreadsheet clipboard 

format.

The file field is ignored.

This is ignored on spreadsheet 

imports.

Select Run to update the drainage 

model.
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When 12d exports the drainage model to a spreadsheet it includes a column for the unique string 

identifier and a unique manhole identifier (unique to the drainage model not the 12d project). The 

names of the strings and manholes may be changed via the spreadsheet if these columns are present 

at import time.

If the manhole id column is not present, 12d will search the drainage model for a matching manhole 

name. When the manhole is a junction between drainage lines, only the trunk line will be the data 

updated.

7.1.4 Creating a New Model

It is possible to create a new string or an entire drainage network using this format. However, man-

holes cannot be added to an existing string. The entire drainage string must be created at once. Two 

formats are available, the “from-to manhole” format and the “12d drainage spreadsheet” format. 

At present the network editor must select a drainage string to become active. Therefore, if you are 

not adding strings to a network, you will have to great a drainage network with one “dummy” man-

hole. Select this one “dummy” manhole to activate the editor. After importing the data and the new 

drainage lines are created the “dummy” manhole may be deleted.

12d drainage spreadsheet Format

The top left cell in the clipboard data must be the text “12d” to specify this format. The mini-

mum amount of data required to create a new string is the string name, manhole name, x and y 

coordinates. You can add as much additional data as you have available. This would include 

pipe diameters inverts etc. The manholes must be listed from upstream to downstream order. If 

the string is to join a trunk line, the junction manhole must be included for both the tributary 

and the trunk line.

An example file exists called new_network.txt is supplied in the library. Open this file in a 

spreadsheet or a text editor and copy it to the clipboard. Set the I/O Action to Import and 

select Run. The new drainage lines will exist in the model currently being edited.

From-to Manhole Format

The top left cell in the clipboard data must be the text “from to” to specify this format. The 

minimum amount of data required to create a new string is the upstream pit name "*pit name), 

the downstream pit name (*ds pit name) and the x(x location) and y(y location) coordinates of 

the upstream pit. If the string is to join a trunk line, the junction manhole must be included for 

both the tributary and the trunk line. 

An optional column for the manhole cover elev (cover elev) may be specified. Once the net-

work has been created additional pipe and manhole data may be added using the “12d drainage 

spreadsheet” format described above.

An example file exists called new_from_to_network.txt is supplied in the library. It is shown 

below. Open this file in a spreadsheet or a text editor and copy it to the clipboard. Enter a new 

model name in the Drainage model field and select paste. The new drainage model will now 

exist. 
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7.2 “12d drainage spreadsheet” Format

Each column of data is used for a 12d drainage variable or a user defined attribute. Each row rep-

resents a manhole and the downstream pipe (controlled by the direction of flow variable) within 

the drainage network. A sample is shown below.
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Duplicate Definitions

Strings Variables such as “direction” are may be defined for numerous manholes on the same string. 

Searching in a top down direction through the file, the last definition found for the string will be set.

Invert levels may be set via pipe data or pit data or combined. It is recommended that the user only 

use one method and not combine them. Both are exported so delete the ones you are not going to use. 

The variables are processed from left to right, so if duplicate definitions of an invert level or found 

the right most data will be set.

The format definition

1. Row1, column 1 must contain either “12d”, or “from to”. Therefore, the first column must be a 

12d drainage variable (cannot be a user defined attribute).

2. Row 1. The text <pit> at the top of the column indicates the column contains a user defined pit 

attribute and similarly <pipe> indicates a user defined pipe attribute.

3. Row 2. This row contains the names of the 12d drainage variable names and the pit/pipe 

attributes. All names are case sensitive so be careful where you use capital letters. A list of 12d 

drainage variables is found below.

Names beginning with an asterix (*) will not be processed (except pit/string names when unique 

identifiers are present in the data). 12d drainage variables names beginning with an asterix indi-

cate that this data was calculated at export time and cannot be read back into 12d (for example, 

pipe length, pipe grade and deflection angle). 
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Prefixing an user defined attribute name with “DELETE ” (no quotes, note the space after the 

DELETE) will cause the attribute to be deleted from all pits/pipes within the model.

4. Row 3. The text in this row define the type of attribute to be stored within 12d. The only valid 

choices are;

integer

real

text

If you want to change an attribute type you must delete the attribute and create it again. If you 

simply change the attribute type in the third row then that attribute will not be updated.

5. Blank lines may be inserted as desired.

6. You are not required to fill in all of the cells in the spreadsheets. Blank cells are ignored (you 

must use a space to remove all data from text attributes (the space will not be stored).

7. Pipe names are included in the data so that they can be changed but they are not used to iden-

tify the pipe. Pipe data will always be assigned to the pipe following the pit in the direction of 

ascending chainage. If flow directions is ascending then the pipe data will be for the down-

stream pipe. If the flow direction is descending then the pipe data will apply to the upstream 

pipe.

7.3 12d Drainage Variable Names
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8.0 Bypass Flow

Bypass flow strings are used to trigger the bypass calculations in the network editor and are used as a 

centre line for flooded width calculations. The later requires unique names for the bypass flow 

strings.

Many of the design programs 12d exports to allow for bypass flow. Bypass flow involves the calcu-

lation of inlet capacity which is often based on the road grade upstream of the manhole.

Key Points

1. Set the manhole types to names that signify the inlet type in the program you are exporting to 

(Type on the Pit->Main tab).

2. Check that your grate level is correct (Setout z + Setout to grate offset)

3. Mark the manhole as a On grade or SAG inlet (Inlet data on the Pit->Main tab). On grade inlets 

capture the water as it passes the inlet while SAG inlet trap the water flowing in from all direc-

tions.

4. Draw an bypass flow string in the direction of flow so that it passes within 1 manhole diameter of 

the inlet. When bypass flow strings join they must join within 1 manhole diameter of a manhole. 

If flooded with calculations are to be done later, the bypass flow string must have a unique name 

and the string should located in the flow channel.

Enter the model name in the Bypass flow model field on the Global->Utility Models tab.

5. Ensure a setout string is linked to the inlet so that the road grade may be calculated in its direction. 

If road crossfall is needed then the centre string is also required. These strings are specified using 

the Road design file on the Global->Utility Models tab.

6. Press the Set Pit Details button. Road grades, crossfalls, ponding depths and bypass pits will now 

be found in the Inlet data section on the Pit->Main tab. The bypass data may be verified on the 

Pit-Main tab of the Network Editor.

8.1 Drawing Bypass Flow Strings

The bypass flow string must be within 1. manhole diameter of the drainage pit in be considered on 

the bypass flow path. If the bypass flow string is to be used for flooded width calculations in the 

future, the string must also be drawn in the main flow area of the cross section.

Use the CAD toobar to create the bypass flow paths. A unique name is required if you plan to calcu-

lated flooded widths after the analysis is done.

To use the CAD toolbar go to the CAD data bar and enter a 

string name and model name. Select the line style (optional).
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Starting at the upstream end. LB select an insertion point and MB or press return to accept the 

selection. Continue this until you reach the end of the flow path. The string will not be shown in 

the new linestyle until the screen is redrawn. Press ESC to finish drawing the string. MB on the 

plan view title area to redraw the screen. The correct linestyle will now appear. 

If you reach a sag pit location you may terminate the string or continue defining the bypass flow 

path for a surcharging event out of the sag location.

8.2 Set Pit Details - Calculate the Bypass Flow Data

Once the first 4 steps above are complete you are ready to calculate the bypass flow data. Select 

Set Pit Details and then select a manhole on a bypass flow string. The downstream pit will now 

show in the Bypass pit field. 

If Pit on grade is selected and a setout string was found, the Road grade will appear in grey. You 

may override this value by selecting the tick box beside the value and entering your own value. If 

a road centre string was selected, the Road xfall field will also have a value.

If Sag pit was selected and a catchment string was selected in catchment set 1, the Pond depth 

would be displayed. The catchment string is draped onto the finish surface tin and the low point 

located. The Pond depth is calculated as 

Pond depth = min level - (setout level + setout to grate offset).

Negative Ponding Depths

Negative ponding depths are usually caused by two errors in input. The first may be that the grate 

level is too high. Often this happens when the setout point is on the top of the kerb and no Setout 

to grate offset has been entered.

The second is that the catchment string has not been drawn around the crest of the catchment. The 

lowest section of the catchment string must be drawn carefully because it is the lowest point on 

the string that determines the overflow elevation. If in doubt, profile the catchment string with the 

design tin shown in the section view. Double check were the low point is.

DRAG the Create line button and release at 

the Create Line String button.

When finished drawing the string press ESC.



Revised February 2006 12d Advanced Stormwater Course Notes Page 28 of 72

4D Solutions Pty Ltd

COURSE NOTES

ADVANCED STORMWATER DESIGN

12d adds verification strings in the construction model to confirm the locations where the road and 

crossfall have been measured. To check these strings add the construction model to the plan view. 

The following image shows a close up of the verification strings at a pit.

The blue line indicates where the road grade was measured and the red line indicates where the road 

cross fall was measured.

These are 3d super strings and therefore you may profile them in the section view. With the grades 

toggled on (check under Toggle) you can verify the slopes.
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Important Notes

1. Pits with no pit type specified will not be processed by the overflow routine and the inlet 

capacity will be set to 100%.

2. For pits with no road design string specified, the inlet capacity will be set to 100%.

3. If no bypass flow string is supplied for a pit, the inlet capacity is set to 100%.

4. If you have a problem with the inlet capacity factors (Drains Version 1 and ILSAX), check the 

calculated crossfall and grade.

Note in the Section View 

Title area that the string is 

named “C1->string”. The 

work string indicates that is 

was created from string data 

and not from the tin.
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9.0 Running PCdrain for Windows

Data is exchanged to and from PCdrain via the interchange (*.int) file. Gutter profiles and inlet type 

must be specified in PCdrain before the interchange file is read into PCdrain.

The data sent to PCdrain includes

s manhole names and types, easting and northing data with surface levels

s pipe deflection angles at manholes

s finished surface profile along the centre line of the pipes

s optional - crossing services - level, size and location along the pipes

s optional - bypass manholes, road grades and SAG inlet ponding depths

s optional - up to 2 catchment areas per manhole

s optional - default catchment characteristics, k values and overland travel times

s optional - pipe sizes and invert levels

9.1 PCdrain Requirements

Manhole names

The manhole name from 12d is assigned to both the structure and catchment name in PCdrain. These 

names cannot exceed 7 characters.

Manhole type

The 12d manhole type is transferred to the structure type in PCdrain. These names must match those 

specified in the PCdrain Inlet charts selected (Data=>Inlet charts). Select the desired inlet charts 

BEFORE importing the interchange file.

12d manhole types with an “S” in the name are treated by 12d and PCdrain as a SAG inlet pit. 12d 

will strip off all characters after the “S” before adding the ponding depth. If a catchment string in set 

#1 is available for the SAG pit then the ponding depth will be calculated.The12d manhole type will 

remain unchanged. A typical example would be a manhole type “1TC” with the sag tick box on 

would become “1TC0.100” if a ponding depth of 0.1 was calculated.

Bypass Flow

When a catchment string is specified for the manhole, the maximum depth before bypass flow com-

mences is calculated. The lowest point on the catchment string is determined by draping it onto the 

drainage strings tin. The maximum depth before bypass is calculated manhole setout level less the 

setout to grate offset less the lowest point on the catchment string.

PCdrain differentiates between manholes (no surface inflow) and gully pits via the 12d manhole 

type. The bypass flow strings can only be drawn within 1 manhole diameter of the gully pits. Keep 

the bypass flow strings away from the PCdrain manholes.
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Catchments

Again, since PCdrain differentiates between inlets and manholes (using the 12d manhole type), 

ensure that catchments are only drawn for gully inlet and NOT manholes.

9.2 12d to PCdrain

1. Export the data to PCdrain selected via the Network editor

Design=>Drainage-Sewer=>Drainage Network Editor

After selecting the drainage network, select the Import/Export button and the following dialogue 

will appear.

Select the Run button and the interface file will be created.

2. Launch the PCdrain for Windows program. If you have a project set up with the design param-

eters, rainfall data, inlet charts and gutter profiles then open it now and skip to step 8. Other-

wise continue with step 5.

3. The Design Parameters can be set as desired with the menu selection 

Data=>Design Parameters.

4. Select the rainfall data using the Data=>Rainfall menu selection.

5. Select the inlet charts using the Data=>Inlet Charts menu selection. The manhole types spec-

ified in 12d must be included in these settings. More - PCdrain to 12d pit converter

6. At least one gutter profile in PCdrain needs to be defined. These are set through the menu 

selection Data=>Gutter Profiles. The default gutter section name (Road ID) from 12d is 4d 

and therefore it is recommended you create a profile with this name and your own description. 

If you have changed the profile names in 12d (through the spreadsheet interface or the 

Attribute editor) these new profile names will have to exist in PCdrain.

7. Save this file now so that you can retrieve it later if required. It can be used as a starting tem-

plate for new jobs.

8. File=>Import from the menu. Select the file exported in step 1. The information from 12d 

may be viewed by selecting Data=>Network and then selecting the desired tabs.

9. The HGL level and the pipe elevation at the outlet should be set using the menu selection 

The drainage model will be completed 

by the editor.

Select Export.

Select PCdrain Int (Windows) from 

the drop down list.

Enter the name of the int file to be cre-

ated.



Revised February 2006 12d Advanced Stormwater Course Notes Page 32 of 72

4D Solutions Pty Ltd

COURSE NOTES

ADVANCED STORMWATER DESIGN

Data=>Outlet.

10.If you have not exported pipe data then the pipe size must be determined. Use the menu selection 

Process=>Select Pipe Sizes.

PCdrain data values

Some PCdrain data values are not available in the 12d network editor. Prior to an import from PCd-

rain, initial export values are used. On the first import from PCdrain, 12d attributes are created to 

hold the PCdrain variables for subsequent exports to PCdrain. These data values are usually changed 

in the PCdrain menus but may by changed in 12d using the Attribute editor.

9.3 PCdrain to 12d

Export the results to 12d using the File=>Export menu selection. Note the name of the interchange 

file you are creating as you will need to enter it inside 12d.

Return to 12d and select Import/Export from the network editor and the following dialogue will 

PCdrain 12d editor 12d attribute
initial export 

value

Kw not available kw 12d ku value

Minor Coef Catch Set 1 - Pervious C (minor) c minor pervious default

Major Coef Catch Set 1 - Pervious C (major) c major pervious default

Minor Coef2 Catch Set 2- Pervious C (minor) c minor pervious2 default

Major Coef2 Catch Set 2- Pervious C (major) c major pervious2 default

Tc overrider Catch Set 1 - Pervious Tc (minor) tc minor pervious default

Length of 

overland flow

Catch Set 1 - Pervious length catchment length 

pervious

default

Grade of 

overland flow

Catch Set 1 - Pervious slope (%) catchment grade 

pervious

default

Length of gutter 

flow

Catch Set 1 - Impervious length catchment length 

impervious

default

Grade of gutter 

flow

Catch Set 1 - Impervious slope (%) catchment grade 

impervious

default

Road XSections 

left

not available overland profile name 4d

Road XSections 

right

not available overland profile name 

right

4d
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appear,

A listing of the data imported is stored on the 12d output window.

Manholes that have been specified as SAG inlets will have the ponding depth removed from the 

end of the PCdrain structure type before the data is stored as the12d manhole type.

Select Import

Select PCdrain Int (Windows) 

from the drop down list.

Select the output file name you 

created in PCdrain.

Select Run and the file will be 

read into 12d and the drainage 

network will be updated. To see 

the changes in a section view, 

select Regen.
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10.0 Running Drains - Version 2 onwards

Key Points

1. The Drains database (each project has its own) and the12d database (drainage.4d) must be syn-

chronised (More).

2. For bypass flow, 12d selects pit families for Drains in the following way

The users selects pit group in 12d and at export the pit group is scanned in the drainage.4d file 

using the road data to select the Drains pit families

3. Data is copied from 12d to the Windows clipboard and then pasted into Drains. 12d can not delete 

any objects in Drains, it can only add and update.

4. When updating 12d from Drains, always copy the DATA to 12d before the results. 12d will 

update the network but will not add or delete manholes.

Drains Interface Overview

The Drains program performs the rational and ILSAX hydrology calculations as well as hydraulic 

grade line calculations that determine pipe sizes and pipe invert levels.

The data sent to Drains includes

s manhole names and types, easting and northing data with surface levels

s finished surface profile along the centre line of the pipes

s Headwalls and their levels

s optional - bypass manholes, road grades/crossfalls and SAG Inlet Calculations (pond-

ing volumes and depths). Pit family selection using road grade and crossfall data.

s optional - composite catchment area create from three12d areas per manhole

s optional - default catchment characteristics, k values and overland travel times

s optional - pipe sizes, type and invert levels

Data is copied from 12d to the Windows clipboard and then pasted into Drains (Edit=>Paste data 

from spreadsheet). 12d can not delete any objects in Drains, it can only add and update.

The Drains menu selection Run=>Design is used to design the network. Once the drainage network 

has been designed in Drains the updated design data (Edit=>Copy data to spreadsheet) and/or the 

hydraulic results (Edit=>Copy results to spreadsheet) are sent back to 12d via the clipboard. 

Always copy the DATA to 12d before the results as the results are deleted inside 12d with every 

update of the data!

A demonstration version of the Drains program is included on the 12d distribution CD in the direc-

tory

Other_Software\Drains

The version is limited in the number of pits allowed.
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10.1 Synchronising the Drains database and the drainage.4d file.

The Drains database and the 12d drainage.4d file must be synchronised as follows.

Every Drains file begins with a default database and uses that database for the life of the project. 

This database must by synchronised with the drainage.4d file in 12d to ensure the Drains pit fam-

ilies, pit sizes, pipe types and overflow route types. 

The following 5 steps will help ensure 12d is synchronised with Drains. More details are given in 

the sections below.

1)Export the Drains database from your Drains file

Inside Drains select Project=>Overflow Route database. Then select OK and then YES. This 

will cause Drains to export the database to the file “Drains Connection Data.txt”.

2)Create a drainage.4d file from the Drains file

s From the 12d menu select Design->Drainage-Sewer->More->Drains to drain-

age.4d. 

s Select Read Drains database,

s review the Drains pit families list to identify the character (usually a comma or -) that 

separates the pit group from the road data and then enter it in the Pit group separator 

field.

s Check the 12d pit groups and if they are acceptable

s select Create drainage.4d. The Drains database dump file is copied to the 12d work-

ing folder and a drainage.4d file is created in the 12d working folder.

s More details below.

3)Edit the drainage.4d file

From the 12d menu select Design->Drainage-Sewer->More->Edit drainage.4d. Select Find 

then edit from the file more info button. Set the road grade and crossfalls for the 12d manhole 

groups.More details below. 

Drains database drainage.4d

Pipe type Pipe type entries

Drains database drainage.4d

Pit famly 12d manhole group with road data

to lookup Drains pit family

Overland route database One default value set (not in drainage.4d)

All Cases

Only if bypass flow  is required
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4)Restart 12d

From the 12d menu select Project->Restart.

5)Set the Overflow shape, Update Manhole and Pipe type.

A single global overflow route shape can be specified in 12d via the following routine and then it can 

be modified in the Drains program. The import operation of the interface will read modified values 

and store them so that the next export operation will export the modified values.

If the network has already been created, using manhole and pipe types that no longer exist in the 

drainage.4d file, they will have to be updated before the export to Drains can occur. You may update 

them using the drainage network editor or you may set all of the manhole and pipes types to one 

value using this routine.Later you may change them individually using the Drainage network edi-

tor

From the 12d menu select Design->Drainage-Sewer->More->Drainage io defaults.

More details below.

10.2 Drains to drainage.4d file

Position of option on menu: Design =>Drainage-Sewer =>More=>Drains to drainage.4d

On selecting the Drains to drainage.4doption, the Drains to drainage.4d panel is displayed.

Key Points

1. Select Read Drains database (12d will search the usual locations for the Drains database)

2. Review the Drains pit families list to identify the pit group separator and then enter it in the Pit 

group separator field. PRESS THE ENTER KEY!

3. Check the 12d pit groups and if they are acceptable select Create drainage.4d.

The Details
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The Drains database dump file Drains Connection Data.txt is copied into the 12d working folder and 

read. The choices for the Pit families, Pipe types and Overflow Route Cross Section Shapes are loaded 

into the panel. The user must select a Pit group separator to separate the road grades and crossfalls from 

the pit family names. The resulting 12d Pit Groups will be calculated and displayed in the choice box. 

Create drainge.4d will create a drainage.4d file that may then be edited to specify the road grade and 

crossfall threshold values. Once the file is created you may review/edit it by selecting the More Info icon 

then Edit on the Drainage.4d field. The Overland route shapes are not exported to the drainage.4d file 

and are presented for your information only.

YOU MUST RESTART 12D FOR THE NEW DRAINAGE.4D FILE TO BECOME ACTIVE!

Field DescriptionType Defaults Pop-Up

Drains database filefile Drains Connection Data.txt

You must update this file from Drains before each use of this panel. Inside Drains select 

Project=>Overflow Route database. Then select OK and then YES. This will cause Drains to export 

the database to the file “Drains Connection Data.txt”.

Selecting Enter in this field or selecting Read Drains database will cause the panel to search for the 

database dump in the folders C:\Program Files\Drains\Program and C:\Program 

Files\Drains\Demo\Program. If the Drains program is installed in another folder then you must 

browse for the file. After reading the file choice boxes below will be populated. Drains Connection 

Data.txt will be copied into the 12d working folder.

Drainage.4d file drainage.4d

The drainage.4d will be created in the 12d working folder unless otherwise specified. It will only be 

used for 12d projects in this folder.

Pit families choice Drains pit families

These are the Drains pit families that will be exported to the drainage.4d file. The 12d pit groups will 

be created from this list.

Pipe type choice Drains pipe types

These are the Drains pipe types that will be exported to the drainage.4d file.

Overflow Route Shapeschoice Drains Route Shapes

These are the Drains Route Shapes and are for information only.

Pit group separatorinput

These characters will be used to remove the road grade crossfall data from the Pit families above. The 

data before this character will become the 12d pit groups. Press Enter or select Read Drains 

database to create a new list of 12d pit groups.

12d pit groups choice 12d pit groups

These are created from the Pit family list above by deleting all text after the Pit group separator. This 

should delete all of the road grade and crossfall information from the pit group names.

Read Drains databasebutton

Searches for the Drains database (see general description above) and populates the choices fields.

Create drainage.4dbutton

Create a local copy of the drainage.4d file.
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10.3 Editing the Drainage.4d file

Position of option on menu: Design =>Drainage-Sewer =>More=>Edit drainage.4d

On selecting the Edit drainage.4d option, the Edit drainage.4d panel is displayed.

The drainage.4d file contains Manhole and Pipe commands. 12d also uses the Manhole commands to 

specify a manhole group by using the prefix “group”. Details follow.

Headwalls

The manhole type “Headwall” (case sensitive for Drains) is reserved for the inlet headwall for a con-

duit. Drains does not use this for an outlet headwall. 

If the inlet type is On Grade or there is no bypass pit, the setout z level + the setout to grate offset is 

exported as the Drains surface level. If the Inlet type is marked as a SAG pit then the surface level 

will be calculated from the low point on the catchment string (catchment set #1). The ponding depth 

will often be negative in this case. Also see SAG Inlet Calculations.

Pit Families and Manhole Groups

Version 2+ of the Drains clipboard interface uses a pit family to describe the kerb shape. Optionally, 

the Drains pit families also have the road crossfall and/or grade attached as a suffix to the name with 

a special character between them (pit group separator). Therefore there may be many pit families that 

have the same kerb shape but different road grades and cross falls. All of these pit families with the 

same prefix are brought together in 12d as a manhole group. 

An example manhole group is the drainage.4d file is shown below. The 12d group is called NSW 

RTA Pits and 12d uses the road grade to select which pit family should be sent to Drains. In this 

example the road crossfall would not be used in selecting the pit family. 

The pit group separator is a “-”. This character separates the pit group from the road data.

It is up to the user to decide the grade when the next pit family should be used. In this case the 

threshold value for the gutter grade is set midway between the published values of the inlet curves. 

For example at a gutter grade of 2% 12d starts sending the NSW RTA Pits - 3% slope pit family.

This pit families listed on the right must match exactly with those in the Drains pit database.

Manhole "group NSW RTA Pits" {

//       cross fall,   gutter grade,  cap1,   cap2,   cap3,   cap4pit family

//4d          0,             1,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% slope

Select the Find button to search the 12d path for the 

current drainage.4d file. Select the More info button 

and then Edit to edit the file.
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//4d          0,             2,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% slope

//4d          0,             4,        0,       0,    0.0,    1.0 NSW RTA Pits - 5% slope

//4d          0,             6,        0,       0,    0.0,    1.0 NSW RTA Pits - 7% slope

//4d          0,             8,        0,       0,    0.0,    1.0 NSW RTA Pits - 9% slope

}

An example with crossfalls follows. 

Manhole "group NSW RTA Pits" {

//       cross fall,   gutter grade,  cap1,   cap2,   cap3,   cap4

//4d          1,             1,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 1% 
slope

//4d          1,             3,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 3% 
slope

//4d          1,             5,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 5% 
slope

//4d          1,             7,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 7% 
slope

//4d          1,             9,        0,       0,    0.0,    1.0 NSW RTA Pits - 1% crossfall, 9% 
slope

//4d          3,             1,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 1% 
slope

//4d          3,             3,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 3% 
slope

//4d          3,             5,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 5% 
slope

//4d          3,             7,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 7% 
slope

//4d          3,             9,        0,       0,    0.0,    1.0 NSW RTA Pits - 3% crossfall, 9% 
slope

}

The Drains pit family names must match the names in the last column EXACTLY! 

Manhole Types and Pit Sizes

Each Drains pit family has several pit sizes. The Drains pit sizes link to the12d manhole types 

and therefore all Drains pit sizes should exist in the 12d drainage.4d file.

The pit size will be read back from Drains into 12d as the pit type so that it can be placed on the 

drainage long sections and pit schedules.

Pipe Types

The pipe type selected in 12d must exist in the pipe database inside Drains. Simple “2” for class 2 

or “RCP “do not exist in Drains.
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10.4 Setting the Overflow Route, the Pit and Pipe types

Position of option on menu: Design =>Drainage-Sewer =>More=>Drainage IO Defaults

On selecting the Drainage IO Defaults option, the Drainage IO Defaults panel is displayed.

The routine changes ALL of your manhole and pipe types in a model to a single value. If you have changed 

your drainage.4d file after creating you drainage network, the manhole and pipe types you originally selected 

may no longer be valid (i.e. in the drainage.4d file).

Field Description Type Defaults Pop-Up

Design Program choice Drains Drains, PCdrain

The drainage model to be updated.

Drainage model file

The drainage model to be updated.

12d pipe types choice values from drainage.4d

Set all pipe types will set all pipes in the model to this value

12d manhole typeschoice values from drainage.4d

Set all pit types will set all manholes in the model to this value

Default pit groupschoice values from drainage.4d

manhole definitions in the drainage.4d file that have group as a prefix are included.

Default road shapechoice values from drainage.4d

type the desired name or if using Drains select the desired shape from the Drains Overflow route shapes.

Drains Tab
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Drains database filefile

pressing enter in this field will start a search for the Drains database dump. The search path is the 

specified folder, C:\Program Files\Drains\Program then C:\Program Files\Drains\Demo\Program. If 

the file is found the choice fields below are populated. It is highly recommended that this file be in the 

12d working folder.

Drains pipe typeschoice l values from Drains file

the pipe types are retrieved from the last Drains database dump. Changing this value will update the 12 

pipe types above.

Drains Overflow Route Shapeschoice values from Drains file

the overflow route shapes are retrieved from the last Drains database dump. Changing this value will 

update the Default road shape above.

Set all pipe types button

all pipe types in model are set to this value

Set all pit types button

all pit types in model are set to this value

Set defaults button

the defaults for the Drains Overflow Route Shapes and 12d pit group are set

Finish button

removes the panel

10.5 Drains Version 2+ Requirements

Manhole Names

The 12d manhole names cannot be more than 9 characters long. 12d uses 2 additional characters 

to the manhole name at export time create names for the pipes, overflow routes and catchments. 

For example manhole “A-1” will have a bypass route “F A-1”, a catchment “C A-1” and a down-

stream pipe “P A-1”.

Bypass Flow (Overland Flow Routes)

There are 3 requirements for Drains bypass flow.

1. Select Default pit group (Network editor->Defaults->Pits->Pit group). The Drains and 12d 

databases must be in sync.

2. Bypass strings in the Bypass route model specified (Network editor->Global->Utility Mod-

els->Bypass flow model. For more details see Bypass Flow.

3. Road grade and crossfall calculated (Network editor->Global->Utility Models->Road design 

file)

The overland flow strings are not allowed to pass through the outlet pit on the network.
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SAG Inlet Calculations

SAG inlets are manholes where the water ponds at the surface rather than flowing past. If a SAG 

inlet has a catchment string the overflow depth and volume are calculated. The catchment string 

from Set #1 is draped onto the design tin and the lowest point in found on the draped string (stored as 

a 12d pit attribute overflow level. The storage volume inside the string up to this point is measured 

and stored as a 12d pit attribute overflow volume from level. and are subtracted from the to deter-

mine 

The Max Ponding Depth = lowest point on the catchment string - 

(pit setout level + Setout to grate offset)

If the manual flag is selected for the "sag pit pond depth", 12d NOT calculate the value but will use 

the value entered by the user. 12d will check if a volume has been calculated before or imported from 

Drains. If the volume exists then it is exported. If it does not exist, this ponding depth will be used 

calculate the ponding level (setout z + depth + grate to setout offset) and this level will be used to 

calculate a ponding volume from the design tin and the catchment boundary. 

If you want to manually delete this volume and force 12d to recalc to volume using the user defined 

level, delete the pit attribute, "overflow volume from level". To delete the attribute use Strings-

>Properties->Attributes, select the pit, go to the pit tab, right mouse select the row with this attribute 

and select delete).

Results

Drains exports the maximum data from all of the rainfall events analysed. Therefore, ensure you ana-

lyse only the rainfall events desired before coping the results to the clipboard. To verify the data that 

is being sent to 12d, copy the data into a spreadsheet so you can view it there first. The pit sizes 

selected in Drains will be stored in 12d as the manhole type. Therefore the pit sizes in Drains should 

exist as manhole types in the drainage.4d file. If pit families are changed in Drains the pit group in 

12d will be updated by search for the pit family in the drainage.4d file.

10.6 12d to Drains

Setup your drainage network models and ensure they have been assigned pit names.

1. Copy the data to the clipboard
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The following interfaces dialogues will appear.

2. From within the Drains program select Edit =>Paste data from spreadsheet. If you paste the 

data into a Drains project that has a hydrological model and rainfall data already defined the 

project will be ready to run.

3. Use the Drains Run=>Standard design to design your pipe sizes and invert levels. The 

Run=>Advanced Design will select the size of the manholes as well.

10.7 Drains to 12d Update

The following steps are required to update the 12d model with the Drains hydraulic results and 

changes to the pipe sizes and inverts.

1. To update the pipes and invert levels in 12d, select Edit->Copy Data to Spreadsheet from the 

Drains menu.

2. From within the 12d Drainage network editor select Import/Export.

From the Drainage net-

work editor select the 

Import/Export button.

This should be filled in from the edi-

tor.

Enter the units.

Select Export.

Select Drains clipboard -Ver 5 

Ilsax or Rational.

Data is stored in this file as well as 

on the clipboard.

Not used by Drains

Use the Run button to copy to the 

clipboard.
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IMPORTANT: THE DATA MUST BE PASTED BEFORE THE RESULTS!

12d erases the hydraulic and hydrology data when the physical data is updated. Therefore, 

always paste the data before the results.

This should be filled in by the editor.

Not used on import.

Select Import

Select Drains clipboard - Version 5

Leave as clipboaard.txt

This will ignore the invert levels read 

from Drains and the current pipe obverts 

will remain fixed.

Plan and long section drawings may be 

created at the import time so that you can 

see the results on the drawings.

Select Run to update the drainage model. 

To see the changes in the section views 

you will have to select Regen on the sec-

tion view toolbar.

To return to the network editor select Edit
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11.0 Running XPSWMM and RAT2000

The drainage design with all three of the XP software programs follows the same methodology. 

The process is substantially automated with the XP-SWMM program so that the XPX file is auto-

matically read by XP-SWMM and automatically created when leaving XP-SWMM.

Drainage design with XP programs includes the following steps.

1. 12d creates an XPX file that is read by the XP programs.

2. The XP program is then run in the design mode to determine the pipe sizes and invert levels.

3. If bypass and overland flows are to be modelled then the inlet capacities need to be defined and 

then run the XP program in the Full Analysis Model.

4. The XP program creates an XPX file for 12d to import.

11.1 XP Program Requirements

11.2 12d to the XP Programs

The x,y pit layouts and the cover/surface levels are obtained from your drainage network while 

the catchment and overland flow data comes from the models specified in the drainage interface 

dialogue.

The steps required to transfer the data to the XP programs are as follows.

1. Setup your drainage network models.

2. To create the XPX file for XP programs start the Drainage Network Editor and select Import/

Export

The following interfaces dialogues will appear.

If exporting to RAT-HGL the following dialogue will appear.

Select Export

Select XPSWMM or RAT HGL 

from the drop down list.

Enter the name of the xpx file to 

be created.

Not used at this time.

Finally, Select the Run button to 

create the file.
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3. The XP SWMM program will automatically startup and load the XPX file. 

From within RAT-HGL, either select File =>New and follow the input prompt or load a file that 

contains all of the pit inlet rating curves, hydrological and design data without a pipe network. 

Many users have such RAT-HGL files setup so as to streamline the design process.

The xpx file for RAT2000 will have the file startup.xpx added to it so that you may include all the 

startup global data that you require. The 

Fixed inlet capacities and rating curve names indicating road grade and crossfall may be set in the 

drainage.4d file. The format for these names is pit name-crossfall-road grade (ex SA2-3-4). 

These curves must exist in this file. 

4. To read in the pipe file created above, select Special =>Import Data and select the xpx data file. 

Warnings will be given stating that several fields are inactive. This is expected as more data is 

sent to RAT-HGL than is needed at this time. Select the Close Square on the Help title area and 

the pipe network and catchments should now appear on the screen.

5. If you want RAT-HGL to redesign you network, change the analysis mode to Design mode by 

selecting Special=>Job Control and Select Design mode. Do not do this if you want to analyse 

the network you layed out in 12d (used for existing systems).

6. Select the rainfall events to design/analyse and the LB (twice) on OK to return to the layout. Now 

select the outlet and enter the starting tailwater levels.

7. Now you can run RAT-HGL (Special =>Solve).

11.3 XP Programs to 12d

Once you have your design finished, the following steps are required to update your 12d model. Your 

design may contain several return periods in the analysis (Rp1 to Rp7) but 12d reads only the results 

from Rp1. The following table is taken from the RATHGL output file (*.out extension) and the 

results indicated are read back into 12d via the xpx file.

If you are using old versions of RAT-HGL (1996 or 

earlier) select use Local otherwise select 4D units 

(eastings and northings). 

Select process.
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In addition to the results, the following input data is read back into the 12d model so that it may be 

exported back to RATHGL in the future (if required). 100% of your RATHGL data is not included 

in the XPX formats and the contents of the XPX file will depend upon your design mode. There-

fore, use caution if you read an XPX file into an existing RATHGL model and check your data 

once inside RATHGL. 

1. From within RAT-HGL, produce an XPX file for 12d to read by selecting Special=>Export 

HGL  PIPE  NETWORK  ANALYSIS  SUMMARY    RETURN PERIOD   5 YEARS

        PROJECT:12d DRAINAGE LAYOUT                                       

 ---------------------------------------------------------

 |ITEM DIM| RESULT                                                               

 ---------------------------------------------------------

 RN       -       1       2       3       4       5       6

 NN       -     1-1     2-1     1-2     3-1     1-3     1-4

 DN       -     1-2     1-2     1-3     1-3     1-4     1-4

 MT       -      99      99      99      99      99       0

 DHGL     M  29.258  29.258  28.139  28.139  27.269    .000    DS HGL

 DD       M    .225    .375    .375    .300    .450    .000    Diameter

 DCTL           HGL     HGL     HGL     HGL     HGL        

 DO       M    .225    .375    .375    .300    .450    .450

 QO    M3/S    .033    .181    .237    .075    .334    .353    Flow

 VELD   M/S    .826   1.639   2.148   1.065   2.100    .000

 NORM     M    .106    .264    .271    .153    .289    .000

 CRIT     M    .152    .314    .345    .215    .396    .000

 KP       -     .00     .00     .00     .00     .00     .00

 SF     M/M   .0040   .0082   .0140   .0046   .0107   .0000

 LEN      M   45.93   18.44   54.65   31.31   49.91     .00

 HGLP     M  29.444  29.409  28.905  28.284  27.802    .000   US HGL

 DU       M    .225    .375    .375    .300    .450    .000

 VELU   M/S    .826   1.639   2.148   1.065   2.100    .000   Velocity

 UCTL           HGL     HGL     HGL     HGL     HGL        

 KU       -    1.50    1.50    1.50    1.50    1.50     .00   Ku

 KL       -    1.50    1.50    1.50    1.50    1.50     .00

 KR       -    1.50    1.50    1.50    1.50    1.50     .00

 KW       -    1.50    1.50    1.50    1.50    1.50     .00   Kw

 UHGL     M  29.496  29.615  29.258  28.370  28.139  27.269

 LHGL     M  29.496  29.615  29.258  28.370  28.139  27.269

 RHGL     M  29.496  29.615  29.258  28.370  28.139  27.269

 UWSL     M  29.496  29.615  29.258  28.370  28.139  27.269   HGL PIT

 MWSL     M  30.297  29.615  29.403  28.875  28.340  27.369

 AF    M3/S    .033    .207    .023    .094    .040    .000

 IF    M3/S    .033    .181    .023    .076    .023    .023

 IC    M3/S    .036    .227    .026    .076    .023    .023

 BF    M3/S    .000    .026    .000    .019    .017    .000

 ID       M    .000    .000    .000    .000    .000    .000

 ITW      M    .000    .000    .000    .000    .000    .000

 IVEL   M/S    .000    .000    .000    .000    .000    .000

 IVD   M2/S    .000    .000    .000    .000    .000    .000

 FC       -               *               #       #       #

 ---------------------------------------------------------
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Data and following the default prompts.

2. From within 12d, select the Import/Export button on the Drainage Network Editor.The follow-

ing panel will appear.

Select Import.

Select to select RATHGL or XP-

SWMM.

Select the file name specified in 

step 1

Select Run to update the drainage 

model and import hydraulic/

hydrological results.



Revised February 2006 12d Advanced Stormwater Course Notes Page 49 of 72

12d Solutions Pty Ltd

COURSE NOTES

ADVANCED STORMWATER DESIGN

12.0 Reviewing, Changing and Creating User Defined Attributes

The catchment data is stored within 12d as user defined attributes. These attributes are automati-

cally created by 12d when required but you are free to change them or add more as desired. The 

attributes may be exported to a spreadsheet and edited and then imported back into 12d. To work 

with the user defined attributes within 12d select

Design=>Drainage-Sewer=>More=>Top 10 Attribute Editor. 

The following dialogue will appear.

They may not be defined for the pit you are editing. Not found will be displayed in the Data field 

if the pit does not have that attribute defined.

To change the value for the attribute 

enter the new value in the data field. If 

the attribute does not exist, deleting the 

not found text and adding data will cre-

ate it. The message on the right will be 

displayed whenever you are creating a 

new attribute.

First Select Pick to select the string 

that contains the user attributes (the 

drainage string). The strings will be 

highlighted in white when they are 

selected.

All catchment data is store with the 

pits in drainage strings. To access 

the pit attributes, select the drop 

down icon and then select Pit. A 

circle will be drawn around the pit 

selected. Next and Prev will now 

move you from pit to pit.

Select the drop down icon and then 

select the Attribute Name from 

the list of existing user defined 

attributes. These attributes include 

all of the attributes in the model 

that the string exists in. 
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13.0 Detailed Drainage Plan Drawing

12d drainage has the capability to create detailed drainage plan drawings with the following features:

screate symbols at the manholes and the type of symbol is controlled by the manhole type (given when you 

create the manhole).

screate text labels for manhole types and user defined pit attributes

sdraw lines with line styles and colours to represent pipe sizes

screate text labels for pipe diameters, inverts and user defined pipe attributes

screate text labels for house connection types, invert levels and chainages

sindicate direction of flow on pipes.

An example is shown below

Usage

This option is accessed from the menu selection 

Design => Drainage-Sewer => Plots => Plan Annotations
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Plot parameter file file box

Optional - no dpf is required. The default settings will create a schematic drainage drawing. A custom 

dpf may be selected if desired.

Load design details from model box

data source for drainage strings to be labelled

Save plot annotations to modelmodel box
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labels to be created are stored here, Undo will remove the labels created

Clean plot model before handchoice box

smart clean will update text that has been moved and clean the rest. Full clean will all text from the plan 

annotations model.

Set colour as string name tick box

when selected the string colour will be used for the string name (to be used for DWG/DXF export using 

map files)

Plot button

Creates the labels in the model specified

Find button

used to locate plot parameter input boxes using Version 5 plot parameter names

IMPORTANT! to turn off any data change the text height to zero.
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14.0 Drainage Long Section Plotting - Hatching Under Roads

The drainage long section plotting has been discussed in the Intro Drainage Course. Here we will 

discuss the technique for hatching under roads and/or footpaths. 

The following steps are required.

1. Run the Excavation volumes routine using the obvert templates to create sections and strings 

for a tin on top of the pipe (obvert tin). Select Stop section at end of manhole to prevent the 

manholes from being hatched

2. Create the obvert tin from the strings and sections then and null by angle length with a small 

length value so that the tin is nulled near the manholes.

3. Create a design tin that extends to the limit of the roads.

4. Use the hatching section of the drainage long section plot to select the hatching style.

14.1 Creating the Obvert sections and strings.

Run the Excavation volumes routine by selecting

Design->Drainage-Sewer->Reports->Excavation Quantaties

Use obvert templates should be selected. This option allow required all templates to be prefixed 

with “obvert “ before the pipe size (times 1000). An example template name would be “obvert 

375” for a 375mm pipe. This allows the user to have one set of templates for the excavation vol-

umes and another set for the obvert calcs. A completed set of templates for metric pipes should 

have been imported when you performed the excavation quantities calcs. If you skipped this sec-

tions then import the templates by selecting.

Design->Templates->Utilities->Input

Select your Drainage model.

Enter new model names for the strings model and 

the section models.

No Report name is required.

The Ground surface tin need to be selected but it 

does not matter what it is as long as it exists for the 

drainage network.

Separation may be a large number as there will 

always be a section at each manhole. If the pipe is 

curved then you will want a smaller separation.

Stop section at edge of manhole will prevent sec-

tions from being created inside the manhole diam-

eter. This will later stop the hatching from 

occurring on top of the manholes.
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and import the file PIpe templates.tpl.

14.2 Create and Null the Obvert tin

The tin will now only exist on top of the pipe and it is ready to use for hatching.

To create the obvert tin select.

Tins->Create->Triangulate Data

Select the obvert strings models created in step 1.

Enter a New tin name as desired.

Select Triangulate

Note that the sections are not used as they contain 

the hinge string that lies on the pipe invert.

Now select

Tins->Null->by angle/length

Select the tin created above for Tin to 

null.

Enter a small value for Length.

Select Null.
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14.3 Create a Roads Only Tin

The design tin is already nulled to remove the long triangles. If the footpaths were to be excluded 

from the tin then they should be removed from the road design strings. You could run a template 

that did not include the footpath and has a Final Maximum slope width of zero or just copy the 

desired road strings to one model and remove unwanted strings. We will use the later techniques.

Add all of the road string and kerb return models onto one view and then select

Utilities->A-G->Change

View select the view that contains all of the road 

strings

Copy to model type the name of a model for all of 

the road strings.

Select Change copy the strings.
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Select the Filter icon at the end of 

the selection strip. Now select the 

Model tab and select the Name of 

the model that holds all of your road 

and kerb strings road strings only 

(tab not shown here).

Select the String Info tab and enter 

the name of the strings that you 

want to remove from the road only 

model. In this case it is path.

Select Filter Select to select these 

strings.

Select the second Target button 

Move to model and select the 

model trash and then select 

Change.

We are now ready to triangulate the 

road only tin.
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14.4 Use the Hatching Feature in Drainage Longsections

We are now ready to create the drainage longsection plots. Set up a section view with the a string 

in the drainage model profiled, the vertical exaggeration set, the desired tins displayed and the 

service models added. From the main menu select,

Design->Drainage-Sewer->Plots->Longsections

Select Tins->Create->Triangulate data

Model - Select the model containing the road only 

strings.

New tin name Type a name for the road only tin.

Select Triangulate

Remove the long exterior triangle by 

selecting Tins->Null->by angle/length.

Tin to null select the road only tin.

Length select a value slightly greater than 

the road width (you may have to manually 

null a few triangles near the intersections).

select Null.
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From the Plot parameter file field select a drainage longsection ppf from the library and then select 

Read.

In the View to load details from field select the section view you have setup for the drainage long 

section.

Now select Hatching cut/fill
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Now select the + beside the Hatching cut/fill and then select fill.

Define set is set to 1.

Original tin is set to 

the obvert tin.

New tin is set to the 

road only tin.
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Use set # is entered as 1. Fill separation, hatch angle, colour and linestyle selected as desired. 

Draw sides of tin, Draw original tin and Draw new tin are not required unless you want these 

extra line in the drawing.

Select Plot and add the plot model drainage LS plot1 onto a PLAN view to preview the drawing.
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The hatch-

ing is shown 

to the left at 

a 2mm spac-

ing with the 

tins and 

sides not 

drawn.
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15.0 The drainage.4d file

The drainage.4d file controls many of the settings for the pit and pipes types inside 12d. This section 

details the format of the drainage.4d file. Changes to this model take effect only after 12dmodel has 

been restarted. 

The original drainage.4d file is found in the “program file\12d\12dmodel\7.00\set_ups” directory. 

Do NOT change this file. Copy it into “program file\12d\12dmodel\7.00\user” directory and edit it 

there. Files in the user directory are used by preference and they are never over written by a 12d 

update.

The format of the entries is a follows.

1. All lines are to be blank or begin with //. This is not the normal 12d convention.

2. //SIZE indicates the values to be read and stored in the user defined pit attributes 

pit internal width and pit internal length when the pit schedule macro is run. A comma is used 

to separate the two values.

3. //DESC indicates that the following quoted text will be read and stored in the user defined pit 

attribute pit type description when the pit schedule macro is run.

4. The pit inlet capacity table data must begin //4d and commas are used to separate the data (comma 

delimited).

5. SAG pit names must begin with the 3 letters SAG.

Manhole "SA2" {// internal pit size data (width, length)

//SIZE   100, 200

//DESC  "2m lintel - grate and side entry"

// pit inlet capacities from Mathematical Description of Pit Entry Capacities Feb 1992

//       cross fall,   gutter grade,  cap1,   cap2,   cap3,   cap4

//4d          1,             1,        0,       0,    0.230,  .621 

//4d          1,             3,        0,       0,    0.225,  .604 

//4d          1,             5,        0,       0,    0.215,  .577 

//4d          1,             7,        0,       0,    0.200,  .538 

//4d          1,             9,        0,       0,    0.235,  .593

 

//4d          3,             1,        0,       0,    0.495,  .819 

//4d          3,             3,        0,       0,    0.270,  .568 

//4d          3,             5,        0,       0,    0.290,  .599 

//4d          3,             7,        0,       0,    0.400,  .727 

//4d          3,             9,        0,       0,    0.330,  .649

//4d          5,             1,        0,       0,    0.540,  .793 

//4d          5,             3,        0,       0,    0.480,  .747 

//4d          5,             5,        0,       0,    0.460,  .744 

//4d          5,             7,        0,       0,    0.450,  .729 

//4d          5,             9,        0,       0,    0.420,  .704
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6. The sample data provided is taken from the paper, “Mathematical Description of Pit Entry 

Capacities”, Feb 1992, by Geoffrey O’Loughlin et al. 

15.1 Pit Inlet Capacities

The pit inlet capacity tables contained within the drainage.4d file are used by the drainage design 

packages in different ways but with a common philosophy. An example entry may be found in the 

section “The drainage.4d file” on page 62

15.1.1 On grade pits

Crossfall data must never decrease moving down the table while the gutter grade data must 

increase for a constant crossfall. When the tables are being read, the next set of capacity factors 

will not be used until the crossfall and grade are equal to or exceed the values in the tables. The 

factors are not interpolated!

Drains and ILSAX

The cap1, cap2, cap3 and cap4 values are used to describe the inlet capacity of the pit as described 

in their user manuals.

RAT-HGL

If cap2, cap3 and cap4 are all equal to zero then a fixed inlet capacity equal to cap1 will be 

exported to RAT-HGL. If the sum of these three values is greater than zero then a pit type will be 

created in the format of pit_type-crossfall-roadgrade. For example SA2-3-2 for a SA2 pit with a 

road crossfall of 3% and a road grade of 2%. A rating curve with this name will have to exist 

inside RAT-HGL. 12d has no way of transferring the rating curve itself into RAT-HGL.

PC Drain

Similar to RAT-HGL, PC Drain has it own rating curves defined internally. The road grade is sent 

as a separate piece of data to PC Drain so that the pit inlet capacity may be determined.

15.1.2 SAG Inlets

Sag inlets always have a manhole type that begins with the three letters SAG or for PCdrain they 

end in a S. Sag pits contain only one line of data and an example follows.

Manhole "SAG3" {

// pit inlet capacities from Mathematical Description of Pit Entry Feb 1992

// if zeros are entered Sc1 and Sc2 then calculated crossfalls (if available) are used for Drains 

and ILSAX

// Sc1 and Sc2 and the slope upstream on the overflow path is used for Sl1 and Sl2

//       Sc1   ,     Sc2      ,  Sl1    ,   Sl2  ,   lintel length,   max depth

//4d        3.0,           3.0,      0.5,     0.5,               3,        .150 

}

Special conditions exist for each of the following programs.

Drains and ILSAX

RAT-HGL, RAT 2000 and XP SWMM

No direct means of specifying SAG pits has been established. A fixed inlet capacity before bypass 
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begins can be calculated and entered with the format of an on grade pit. Cap1 would represent the 

inlet capacity with cap2,cap3 and cap4 being set to zero.

PC Drain

PC Drain places a suffix code in the pit type to specify that the pit is a SAG pit. For example an 

9S0.03 indicates that pit type 9 is a sag pit and the maximum depth before bypassing is 30mm.
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16.0 Flooded Width Analysis and HEC RAS

The Calculate Flooded width procedure creates cross sections along the bypass flow paths and 

then calculates the flooded width at each section using Manning’s normal depth calculations. A 

HEC-RAS project (same name as the bypass flow string) is also created for each line. The flooded 

width is indicated on each section as a blue line if it is less than a user defined width and a red line 

if the flooded width exceeds the limit. Details of the calculations such as the velocity, depth, wet-

ted perimeter and slope can be exported to a spreadsheet for further analyse (velocity times depth 

calculations for example). The discharges imports from the urban stormwater design packages are 

shown in the following table.

The user defines the length of these sections and the interval at which they are to be spaced. 12d 

calculates the normal flow depth interpolating the pit approach and bypass flows from the hydrol-

ogy models (ILSAX, Drains, PC Drains or RAT HGL). The cross sections are taken perpendicular 

to the flow line and the slope is for the normal depth calculations is determined using the distance 

along the flow line and the change in elevation between the two lowest points in the primary flow 

channel. The flow line need not intersect the low points on the section but the flow line does mark 

the primary flow channel. If the depth of the flow exceeds the banks of the primary channel, then 

all adjacent flow channels will be considered as active flow area.

16.1 Limitations where overland flow lines join

Where overland flow lines converge at a manhole, 12d does not know the flow split between the 2 

approaching paths. Therefore, 12d uses the total flow from all lines as the flow at the manhole for 

each line. This may overestimate the flooded width along the flow lines at these points.

16.2 Limitations at SAG pits

The flow width are not shown adjacent the sag inlets. The depth of flow due to ponding and the 

approach flow coming from several directions may overestimated flooded width in these areas. 

Therefore not flood depths are calculated approaching SAG inlets.

Design Program Discharge Event
PCdrain Minor ARI
Drains Maximum flow event analysed
ILSAX Maximum flow event analysed
RAT HGL First return period analysed
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Trim sections at levee is used to create a cross section that stops at the crest on either side of the 

flow channel. A levee point is the crest in the cross section found as you move away from the flow 

line location. If a levee point is encountered then the section is trimmed here.

Levee tolerance is the amount the cross section needs to drop as you move away from the centre line 

in order to call this local crest a levee.

VxD warning limit is the velocity times depth limit that when exceeded will cause a flooded width 

Enter the drainage network model.

Enter the bypass flow model.

Enter the model that will contain the actual flooded 

width lines.

Select the tin that will be used to create the cross 

sections.

Enter the model that will contain the cross sections. 

The calculated values such as velocity and slope 

are stored with these lines.

The flooded width will be drawn in blue in the 

results model when it is less than the Max flooded 

width (Variables tab). If the flooded width exceeds 

this value it will be drawn in red.

If warnings are give for a section a yellow bar will 

be placed in this model.

Max flooded width is the limit where the blue 

flooded width bars turn red.

Manning’s n is the n value to be used in the normal 

depth calculations.

The Flow correction factor is the factor described in 

ARR 1987 for calculating depths of flow in gutter 

channels.

Distance between sections specifies the interval at 

which cross sections and therefore flooded width will 

be calculated along the flow path.

Section Length defines the length of each cross sec-

tion. The cross section will be centred on the over-

land flow path.
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bar to be generated in the warning bars model.

VxD warning colour is the colour of the bars mentioned above.

Process will always clean the sections, string and warning bars model before process.

Summary Tables

The hydraulic calculations and warning messages are stored as string attributes on the flooded 

width bars. If these attributes are exported to a spreadsheet via the clipboard a summary table my 

be created. To copy these attributes to the clipboard select

File IO->User->String attributes-properties to/from clipboard

16.3 Cross Sections, Discharges and Warnings

The analyse flooded width will proceed along each flow path and identify every pit on the line. 

Cross sections will be constructed in the model with the length and interval entered in the input 

dialogue. These cross sections may be plotted using the main menu selection 

Plot=>X plot=>X plot. The Sort Sections must not be selected for these sections to be plotted.

Discharges will be determined for each cross section by linearly interpolating the discharge using 

distance between the pits. The bypass discharge (pit attribute - calculated bypass flow) will be 

taken from the upstream pit and the approach discharge (pit attribute - calculated approach flow) 

from the downstream pit. 

The slope is calculated by subtracting the lowest points nearest to the centre line and dividing the 

cross section separation. The levee tolerance is NOT used for locating this point thus any rise in 

section moving away from the centre line marks the end of the low point search in that direction.

12d will give warning messages in the output window when it encounters the following condi-

tions and these messages will be stored as string attributes on the flooded width strings. Descrip-

tions of these messages follow.

Inverts do not go downhill

12d locates the lowest point (adjacent to the flow line without moving over a local crest) on each 

cross section to calculate the slope between the cross sections. This message indicates that the 

downstream minimum elevation is higher than the upstream minimum elevation.

Sometimes flow lines will go uphill. If you have specified an overflow from a SAG location then 

The string model may be either the flooded width bars 

or the warning bars. Both models of strings contain 

attributes on the strings.

The prefix selection and prefix exclusion are filters for 

reducing the number attributes that are exported to the 

clipboard.
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the flow line will go uphill until it crosses the overflow crest.

If the flow line is not supposed to be going uphill at this section, check to see where the flow line 

intersects the cross section located upstream of the one identified in the warning message. If it is in a 

local sag point that is not the lowest point on the section, move the flow line.

The program will use a slope of 0.5% to calculate a width at this location. This results in very wide 

flooded width sections to draw the user’s attention to the problem area.

Vertical Walls Assumed at the Ends of the Cross Sections

If the depth of flow exceeds the ground surface elevation at the ends of the cross section a warning 

message the warning message shown above is shown. The cross sections causing the warning fol-

lows.

The vertical wall is placed at cross section chainage –20. Note that the flow line is always at chain-

age 0
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17.0 Drainage Overflow Areas from Volumes

This option is used to graphically display the overflow storage volume at a sag pit. The following 

pit attributes must exist for the flood extents to be calculated.

overflow volume value greater than zero required.

sag pit must be equal to 1.

catchment model id set by labelling catchments

catchment string id set by labelling catchments

The maximum storage volume is read from the drainage pit attribute "overflow volume". This 

may be entered manually using the Attribute Editor or it will be created when data is read from the 

drainage design programs Drains or XP SWMM design programs.

This routine locates the lowest point on the catchment string by draping the string on the tin spec-

ified and adds the overflow limit specified to this value. This becomes the overflow limit.

The volume at this level is calculated and the compared to the overflow volume read from the 

user defined attribute.If the overflow volume is less than the volume in the catchment then the 

routine iterates to find the flood level for the overflow volume.

If the overflow volume is greater than the volume in the catchment, the results depend on the Use 

overflow limit tick box. 

If the box is selected, the overflow limit (calculated above) is reported at the flood level in the 

catchment.

If the tick box is not selected the routine iterates to find the flood level where the storage equals 

the overflow volume read. This option allows the user to see the maximum flood level should the 

catchment low point become blocked.

See Also

Drainage overview

Usage

This panel is accessed from the menu selection Design => Drainage Sewer => More=>Calc pit 

overflow areas
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The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Drainage model model box

all pits in this model that have a non zero "overflow volume" and "sag pit" set to 1 will be processed

Flood limits model model box

flood limits strings will be created in this model

Surface Tin tin box

ground surface tin used to calculate the volumes and flood limits

Flood limits colour colour box

flood limits strings will be created using this colour

Clean limits model tick box

if selected all strings in the Flood limits model will be deleted before the calculations commence.

Use overflow limit tick box

if the elevation calculated from the storage volume is higher than the lowest point on the catchment string 

then the allowable surcharge value below will be added to the lowest point on the catchment string and 

this elevation will be used to determine the flooding limits

Allowable surcharge real box

this value is used only if Use overflow limit is ticked. Its purpose is described in the field above.

Process button

executes the option.

Finish button



Revised February 2006 12d Advanced Stormwater Course Notes Page 71 of 72

12d Solutions Pty Ltd

COURSE NOTES

ADVANCED STORMWATER DESIGN

removes the dialogue from the screen



Revised February 2006 12d Advanced Stormwater Course Notes Page 72 of 72

4D Solutions Pty Ltd

COURSE NOTES

ADVANCED STORMWATER DESIGN


	1.0 Advanced Stormwater Design - Introduction
	2.0 Setup Files and Their Locations
	3.0 Starting with a Basic Drainage Network
	4.0 Excavation Quantities
	5.0 Network Quantities Report
	6.0 Exporting to Drainage Design Software Packages
	7.0 Drainage Data Input and Output to Spreadsheets
	7.1 12d to spreadsheet transfers
	7.2 “12d drainage spreadsheet” Format
	7.3 12d Drainage Variable Names

	8.0 Bypass Flow
	8.1 Drawing Bypass Flow Strings
	8.2 Set Pit Details - Calculate the Bypass Flow Data

	9.0 Running PCdrain for Windows
	9.1 PCdrain Requirements
	9.2 12d to PCdrain
	9.3 PCdrain to 12d

	10.0 Running Drains - Version 2 onwards
	10.1 Synchronising the Drains database and the drainage.4d file.
	10.2 Drains to drainage.4d file
	10.3 Editing the Drainage.4d file
	10.4 Setting the Overflow Route, the Pit and Pipe types
	10.5 Drains Version 2+ Requirements
	10.6 12d to Drains
	10.7 Drains to 12d Update

	11.0 Running XPSWMM and RAT2000
	11.1 XP Program Requirements
	11.2 12d to the XP Programs
	11.3 XP Programs to 12d

	12.0 Reviewing, Changing and Creating User Defined Attributes
	13.0 Detailed Drainage Plan Drawing
	14.0 Drainage Long Section Plotting - Hatching Under Roads
	14.1 Creating the Obvert sections and strings.
	14.2 Create and Null the Obvert tin
	14.3 Create a Roads Only Tin
	14.4 Use the Hatching Feature in Drainage Longsections

	15.0 The drainage.4d file
	15.1 Pit Inlet Capacities

	16.0 Flooded Width Analysis and HEC RAS
	16.1 Limitations where overland flow lines join
	16.2 Limitations at SAG pits
	16.3 Cross Sections, Discharges and Warnings

	17.0 Drainage Overflow Areas from Volumes

