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1.0 Stormwater Design - Introduction

The 12d drainage module contains functions to perform the following steps in the drainage design 

and documentation process:

s set drainage defaults and layout a drainage network,

s use the powerful 12d drainage network editor to avoid service clashes, grade pipes, 

align obverts, minimise depth and many other design tools,

s automatically assign names to the pit/pipes in the network,

s designate catchment areas and produce catchment plans,

s transfer data to and from electronic spreadsheets to enable the user to easily review 

the data and add user defined data to the 12d pipe network. This data may include 

such data as pipe bedding types and trench width,

s create pit layout schedules to export to spreadsheets or word processors for final for-

matting.

s produce long section drainage profiles including HGL data, flows, invert levels, serv-

ice crossings

s create plan drawings with pipe sizes, flows, manhole symbols, linestyles for pipe 

sizes, design parameters for manhole and pipes and user defined data

s locate pits/manholes at exact chainage and offset locations

This user manual will lead the user through the steps itemised above.

In addition to this manual there is the Advanced Stormwater Design training manual which 

includes the following topics.

s drainage trench excavation volume calculations

s pipe and manhole quantity calculation

s customising the drainage.4d file

s design or evaluate the drainage system using 12d Drainage or create input files for the 

XP SWMM/RAT2000, Micro drainage, Drains and PCdrain drainage design pack-

ages,

s read the output from the drainage design packages (automatic if using 12d Drainage), 

update the drainage network and store the hydraulic data, such as hgl (hydraulic grade 

line) levels, peak pipe flows and pipe capacities,

s pit inlet capacity calculations and over land flow

s flooded width analysis

s surcharge volumes at SAG pits

s and detailed drainage plan labelling

The terms pit, catch basin and manhole are used interchangeably throughout this document. The 

type, dimensions and inlet capacities of the structures are set in the drainage.4d file.
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2.0 Setup Files and Their Locations

The drainage module consists of the optional 12d Drainage engine, utilities, startup configuration 

files for RAT2000, XP SWMM and the 12d drainage configuration file (drainage.4d). Demonstration 

versions of Drains, RAT2000 and PCdrain have been included on the CD along with a copy of the 

ILSAX hydrology package. Manuals for the ILSAX program may be obtained from the Civil Engi-

neering Department at the University of Technology Sydney.

All setup files have been configured for the training version. However, when you start working on 

real projects you may want customise the drainage module. More - Customising the drainage 

module

The drainage.4d file contains pipe types (RCP, Class 2 etc.) and example pit inlet capacity tables for 

RTA (NSW Road and Traffic Authority) standard pits. Detailed pit type descriptions and internal pit 

dimensions can be included in this file to be inserted into your pit schedules. For PCdrain users there 

is a routine to read your gully pit file and include these pit types in 12d More.

REVIEW THIS DATA CAREFULLY! The drainage.4d file may be customised for any additional 

inlet capacity data you may have.

To edit the drainage.4d file, from the main menu select

Design->Drainage-Sewer->More->Edit drainage.4d

You must restart 12d for these changes to become active. Select Project->Restart!

Select the Find button to search the 12d path for the 

current drainage.4d file. Select the More info button 

and then Edit to edit the file.
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3.0 Survey data and design surfaces (TINs)

We will begin a 12d project from scratch by first creating the project and then reading in the sur-

vey design data. The design can then be triangulated so that we have a final surface profile to 

design the drainage for.

Start up the 12d model by selecting the courses icon from your desktop.

The project selection panel will appear. The bottom corner of the panel is shown below

Note: If you are using the practice version the folder will be: 

C:\12d Model v7.00 Practise\courses\7.00

LB select the icon and the following panel will appear.
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12d works with a folder NOT a single file. Therefore, to open the folder we are going to work in, 

double click the Drainage folder and then select Open.

In the Project field type the name for your new project an then select Proceed. 12d will create a sub 

folder with this name. All of the 12d files that you should not touch will be created in this sub folder. 

Please stay out of the sub folder. All files created for the user will be kept in the folder that you 

opened (i.e. c:\12jobs\Courses\7.00\Drainage).

3.1 Importing the Raw Survey Data

You have created a new project into which we will import the survey data. From the main menu 

select.

File I/O => Data input => 12da/4da data



Revised February 2006 12d Stormwater Design Course Notes Page 9 of 94

12d Solutions Pty Ltd

COURSE NOTES

STORMWATER DESIGN

To add all of the data to the view select Menu icon in the plan view title area and then from the 

drop down menu select

LB select to display the file list. 

Select the file existing survey.

Select Read to read the data then 

Select Finish to remove the panel

Models=> Add all models

or

select this “+” icon and select existing survey data.
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The view will contain survey data.

3.2 Creating the existing Ground Surface

From the main menu select

Tins=>Create=> Triangulate data

Next select Fit on the plan view title area. You should see the following data. 
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Now we are ready to look at the existing surface tin. Place you pointer over the “+” sign on the 

plan view title area and press the t key. All of the models beginning with lower case t will 

appear. Double click on tin existing survey to add it to the view.

The tin will be shown with the tin edges turned on. This is the default when you have all tin dis-

play modes turned off. Let us now turn on the fast contours and the fast flow arrows. Select Tog-

gle on the plan view title area and then LB on Tin contours. The contours will be shown on the 

view. LB Toggle on the plan view title area and then LB on Tin flow. Now the flow arrows will 

be shown on the view.

To change the contour intervals and the contour colours select the Menu button on the plan view 

title area and then select.

Settings=>Tins=>Contours and the following dialog will appear.

Select the View button

LB select then LB the view to be triangulated. 

Type a new tin name, not the model for the tin. Remem-

ber a tin is like a string and it must reside in a model. 

Press enter and the Model for tin field will be filled in 

for you.

Select if creating a tin with contour data.

Preserve strings will make the string one side of the tri-

angle thereby preserving the levels along the string

all duplicate points are removed from the tin database

The cell method is a good enhancement for data that is 

in a grid type pattern but it is not required.

Select Triangulate to create the tin. 

Select Finish to remove the panel from the screen.
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To change the length and the colour of the flow arrows select the Menu button on the plan view title 

area and then select.

Settings=>Tins=>Flow Arrows and the following dialog will appear.

3.3 Inquiring about Heights on the Surface

The elevation anywhere on the tin can be obtained by simply moving the pointer over the desired 

spot. To obtain the tin elevations select,

Tins=>Inquire=>Height

Turns the contours on or off

Minor contour interval.

Value for first bold contour (usually 0)

Minor contour colour.

Major interval.

Major contour colour.

LB to observe the new settings on the view.

If you like the settings LB on finish to remove 

the select.

A length of about 2 units looks very small 

now but it is good when you are zooming 

into the actual catchments.

LB to observe the new settings on the 

view. 

When you like the settings LB on Finish to 

remove the panel.
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You will see that data in the panel change as you move the pointer around the screen,

3.4 Viewing the Surface Tin in a 3d Perspective

To create a 3d perspective view select

View=>New=>Perspective and a persective view will appear.

Add the model tin existing surface to the view and then toggle the shading on. You may also 

want to toggle the contours on as well.

Now remove the tin from the view as it is not needed for the next steps (Hint: use the “-” button).

3.5 Reducing the number of points for the 12d Practice Version

We can delete the survey data to save space for those using the practice version of 12d. If you 

have a full version of 12d this is not required. From the main menu select.

Models=>Delete=>Delete a Model and the following dialog will appear.

3.6 Importing the Road Design Data and Creating the Design TIN

Repeat the process of importing the 12da data.

File I/O => Data input => 12d ascii

(file is road design.12da).

Remove all of the models from the view and then add the road design models onto the view.

LB then select the model existing survey data and then

LB to delete the model and then Select yes to

confirm the deletion.
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Road Centrelines

Road Strings

Road sections

Now create a new tin called design using the TINS->Create->Triangulate data option.

3.7 Nulling the long Triangles

Add the tin that you just created onto the view. Toggle the tin contours off and the tin flow off. Now 

toggle the tin edges on. Notice the long triangles around the edge of the design.

To remove the long triangles select

Tins->Null->by angle/length

Select the design tin and then select Null. Using the default values removes most of the long trian-

gles. Note that this option removes triangles from the outside inwards and it stops whenever it 

reaches a breakline.

Now reduce the Length value to 1 and then select Null again. Any exterior triangles with a length 

greater than 1 have now been removed!
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3.8 Creating a Super Tin from the Survey and Design Data.

To create a tin that is the combination of the survey data and the design data you will need to cre-

ate a super tin. From the main menu

Tins=>Create=>supertin

3.9 Changing the Colour of a Tin

Enter a name for the super tin and press Enter.

Used only in section views.

The model field will be auto completed for you 

because you pressed Enter above. A new model 

will be created.

Now select the tins to combine. Tin 1 is the tin 

on the bottom (like the levels in a building) and 

tin 2 is above. i.e. wherever tin 2 exists it will be 

used. If there is no tin 2 at a location then tin 

1will be used.

Select the tins using the icon and then 

click Create to create the supertin.

To change the colour of the design tin use

Tins->Colour->Colour of tin

Select the design tin and choose a new colour and then select Col-

our to change the tin colour (you may have to do a Menu-

>redraw on the view to see the new colour).
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4.0 Drainage Layout

Where a drainage designer chooses to start their design is a depends a great deal on the project and 

the designer. Identifying overland flow routes is essential because it is on these routes that the man-

holes are to be placed. Inlet manholes are then placed at critical locations (sag points, upstream of 

pedestrian crossings etc.). and then the spacing of additional manholes is determined by the size of 

the catchments. Finally, the pipe drainage system can be created linking the drainage manholes.

However, during training, most users want to get straight to the manhole and pipes. Therefore, lets 

import a pipe layout that was drawn in AutoCAD along with the overland flow routes and catchment 

areas (These could have been created in 12d as well). When these were drawn the following rules 

were followed.

1.polylines were used

2.lines drawn from upstream to downstream (direction of flow)

3.a vertex was placed at every manhole location

From the main menu select

File IO->Data Input=>DWG/DXF.

Verify setting as dwg

Select the dwg file (drainage data.dwg)

Entering a prefix for the models will help organise the 

layers that will be read from AutoCAD. Every layer 

goes into a separate model in 12d. If you specify a 

prefix then all of the layer names will be prefixed with 

this text.The prefix used is dwg<space>.

The rest of the data can remain as the default value. 

Refer to the Help button if more detail is desired.

Select Read to import the data.The data will not 

immediately appear on the plan view. The new 

models have to be added to the view using the “+” on 

the view tool bar. Every time you press the Read but-

ton the data will be imported again and you will get 

duplicate, triplicate...etc data. 

All of the models imported will begin with dwg.
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The models that have been created are,

dwg d catchments

dwg d overland flow

dwg drainage network

Remove all of the models from the view and add the model dwg drainage network. This is a 2d 

drainage layout that we will use to locate the manholes in our drainage design.

4.1 Setting Drainage Defaults

The defaults for the drainage network are accessed through three panels; pipe defaults, manhole 

defaults and Tin defaults. They may be accessed through the menu system as 

Design =>Drainage-Sewer =>Defaults

Warning! You must click the Set button to set the default values. Finish alone will not set the 

defaults. If you plan to export to other drainage software packages you will have additional 

defaults to set before you export. See Drainage Import/Export.

4.1.1 Tin Default

Warnings about using tins. If you place a manhole outside the tin boundary:

s then no elevation will be set for the top of manhole, (it can be set later manually or by 

linking it to a design string).

s Pipe invert levels cannot be set using the default cover. Pipe invert levels must be set 

manually as 12d cannot automatically determine cover levels without a TIN.

s Finally, if your drainage design package accepts surface levels along the string, then 

an error message will be displayed at export time. The message will say that the sur-

face level string is shorter than the pipe length.

The default TIN is used to set the initial setout level of 

the manhole and the pipe invert levels. Super tins may be 

used if you want to place manholes on both the existing 

and the design ground surface (see Creating Super tins). 

Select the icon to choose from a list of existing TINS. 

Note that the panel will list the tins not the models that 

contain the tin. Remember a tin is like a string. It has a 

name and is stored in a model.
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4.1.2 Manhole Defaults

The actual internal manhole dimensions and a detailed manhole description can be added to your 

drainage.4d file so that they can be added to your manhole schedules.

The Diameter is used:

1. for visual service clash identification is long section drawings,

2. to clip the pipe lines drawn in the plan annotations,

3. maximum distance the bypass flow strings can be drawn from an inlet.

The drop will be used to set the invert level of the outlet pipe relative to the invert level of the inlet 

pipe. The drop should always be entered as a positive value.The network editor has many more 

options for aligning the pipe inverts at the manholes.

Generally, do not use a default name. Leave all of the manholes unnamed and then use the Set Pit 

Names function on the drainage network editor.

The manhole type is selected from a list by selecting the icon beside the Type. This list is obtained 

from the drainage.4d file. This manhole type will be used by ILSAX, PCdrain and RAT-HGL, 

RAT2000 and XP SWMM to identify the inlet capacity of the manholes. This value is not exported 

to the Drains program but it will be imported after a Drains design run. See Drainage Import/

Export. It is best to set this to the most common manhole type and then change the few that are dif-

ferent later in the network editor.

You must click the Set button to set the default values. Finish alone will not set the defaults.

The manhole diameter is specified in metres/feet 

not mm/inches. Although most stormwater man-

holes are rectangular, 12d uses circular manholes to 

eliminate problems showing the alignment of the 

manhole. If the actual dimensions and orientation 

of the manhole need to be drawn on the final con-

struction drawings, a symbol may be used in the 

drainage plot annotations.
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4.1.3 Pipe Defaults

Allowing for Pipe Thickness

When 12d set the pipe inverts it checks the minimum cover from the obvert of the pipe to the fin-

ished ground surface at both manholes. If the grade of the pipe is less than the minimum grade, 

the grade of the pipe is increased. Finally, 12d checks if there is anywhere along the pipe length 

that has less than the minimum cover. If there is such a low point in the design surface, the pipe 

is shifted vertically downwards to achieve the cover required. 12 defines cover as

Cover = surface level - diameter - invert

Therefore, an allowance for pipe thickness may be added to the minimum cover.

When using the network editors to change the pipe diameters the invert levels will remain fixed 

and the obverts will change. The inverts may be reset using Regrade Network on the network 

editor.

Select the drop down icon beside the Type field to select from a list of pipe types. These pipe 

types will be sent to your drainage design package so make sure you use the same names in 12d as 

you plan on using in the design package. The list of available pipe types is set in the drainage.4d 

file.

You must click the Set button to set the default values. Finish alone will not set the defaults.

4.2 String Colour and manhole Label Text Size/location (string defaults)

12d can automatically label the manholes at a fixed offset from the manhole using view text OR 

you can use the network editor Set Catchments to create text labels that can be moved/rotated 

etc.

For view text, the default line colour and text size are set by selecting Utilities =>Defaults. The 

following panel will appear.

The pipe diameter is set in metres or feet not mm or 

inches. Set this to a minimum pipe diameter for your 

project and then your drainage design package can 

increase them if required. To model an existing system 

enter the most common pipe size and then alter as 

required in the network editor.
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LB to set the colour of the drainage string and man-

hole labels.

The default size of the text is set in the Text height 

(pixels) field. A text size of 6 to 8 pixels is generally 

adequate. Your choice will depend on your screen res-

olution and the age of your eyes.

Select Set

Select Write

the following panel will appear.

Selecting Current folder will save ALL 

these defaults for projects in this working 

folder only. The defaults set in the user or 

setups directories will not be used if you 

select this option.

Selecting User folder will save your 

defaults so that all other 12d projects will 

use this defaults. This is the most common 

option (unless your network administrator 

has not given you write access to this area 

(check Properties).

Select Write then Finish
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4.3 Create the drainage strings from the dwg strings

12d will convert the import strings into 12d drainage strings. The default pipe, manhole and tin 

data will be used to set the levels for the network

From the menu select

Design->Drainage-Sewer->Create drainage from strings

The following panel will appear.

The fields and buttons used in this panel have the following functions:

Field Description Type Defaults Pop-Up

Data source choice box model view,model,string

data source for strings to be converted

Select input box

Model containing strings to be converted

Drainage model model box

The new drainage strings will be added to this model. If it does not exist it will be created.

Finished surface tin tin box

This tin should be the same as your tin default for the drainage strings.

Outfall manhole number real input box

The network will be numbered using a numerical method. The most upstream manhole of the outlet line 

will be assigned this manhole number. This numbering system can be changed if desired. 

Process button

Coverts the strings to the drainage strings.
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Finish button

Removes the panel from the screen.

Important notes:

The imported strings must be drawn in the direction the water flows.

Manholes are created at all vertices on the strings. 

Trunk lines must have a vertex where the branch lines join.

Integer string names can be used to control the order in when the drainage lines are numbered. These 

names will be transferred to the 12d drainage strings. Naming the strings is highly encouraged.

The drainage lines must have string names to use the Set Pit Names feature on the network editor.

Manholes can always be renamed in 12d after the import is complete.

4.4  Drawing the Drainage Network in 12d

The following method of drawing the drainage pipe systems has proved very efficient in the past. 

However, many people will have their own, “tricks of the trade”. Therefore, the rational behind the 

following procedure will be important for the user to understand when they want to try out their own 

procedures.

Key Points

1. Draw the pipes where they actually are! Do not place the manhole centres at the setout point and 

have the pipes in the wrong location (pipe cover will be affected). Use setout strings for setout 

points!

2. Draw all drainage lines in the same direction. Either all uphill to downhill (flow in the direction of 

increasing/ascending chainage) or downhill to uphill (flow in the direction of decreasing/descend-

ing chainage). You choose but they all must be the same.

If you choose descending chainage then you must select Pipe=>Default Grading then Grade to 

have the grading applied to the drainage string.

The 12d drainage network editor and the drainage design software packages have sophisticated 

algorithms to set pipe inverts as well. Consider this grading a preliminary estimate.

3. If you create the trunk lines before the branch lines, you will have to select the Regrade Network 

later to adjust the trunk line levels.

4.5 Manhole Setout Point, setout strings and selecting the location for the manhole 
centre

The centre of the manhole (x,y and z) need not be the manhole setout point used in the setout 

tables.The setout location can also be set independently of the level. It is recommended that you 

place the manhole so that the pipes are shown in the desired location and then use the desired option 

for setout. With the pipe in their proper location the pie cover and service clashes will be calculated 

correctly. The default settings for the manhole setout location are found on the network editor-

defaults-pits-setout data.
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Key Points in Using Setout Strings

1. Enter the road models and the strings names (identifies) via the Network Editor, Global-Util-

ity Models tab, Road design file.

2. Specify that these strings are to be used. Select Setout string for the XY or Z setout modes on 

the Defaults->Pits setout area or Pits->Setout tab.

3. Select the Set Pit Details button.

X,Y Option 1 Manhole Centre

The x,y location will be the centre of the manhole.

X,Y Option 2 Road Centre Line

The road chainage and offset are measured perpendicular to the road centre line out to the man-

hole centre or setout point.

Location

Road Centre Line

Road Chainage and offset

Setout String

x y from setout string

Manhole Centre

x y at manhole centre
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X,Y Option 3 Setout string

The manhole centre is dropped perpendicular onto the set out string to obtain the x and y.

Z Option 1 FS tin

The manhole setout level is obtained from the finished surface tin at the manhole centre.

Z Option 2Setout String

The manhole centre is dropped perpendicular onto the setout string and the level is obtained from the 

elevation on the string.

Example

In the diagram below the setout point is lip of kerb. The setout x,y location level z will be obtained 

from the setout string and the pipe will be shown at its proper position.

4.6 Creating the Drainage Strings in 12d

Drainage strings can also be created in 12d. A drainage string is created by selecting 

Design =>Drainage-Sewer =>Create
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Each drainage string in the model must have a unique Name if you plan on using the Set Pit 

Names option after all of the strings have been drawn. The name of the string should be kept 

short, <B> for example, as it will be used as the prefix or suffix for the manhole names. Examples 

of manhole naming schemes available for a string labelled, <B>, are B1, B2, B3 … ,or 1B, 

2B,3B…or 1/B,2/B, 3/B… etc.

Sequential numbering all of the manholes (1,2,3 etc.) is also an option. The manholes on the 

string named 1 will be labelled first and then 2 and so on. If you insert a new string with a name in 

the middle an existing series (i.e. add a new string 2 when strings 1,2 and 3 already exist) then 

name the new string 1.1 (for this example) and then use the Strings=>User=>Set String Name 

by number command.

Drainage String Create Panel

Flow direction should be ascending chainage if drawing uphill to downhill or descending 

chainage if drawing downsteam to upstream. All of the strings in the model can have their direc-

tion changed later using the Design=>Drainage-Sewer=>More=>Reverse all strings com-

TIP: If you have already created a drainage string, click 

the Same as button and select the drainage string to 

obtain the panel values from that string. After selecting 

the string, change the string Name. 

For auto manhole naming, every drainage string must 

have a different name.

All drainage strings for the one outlet should be in the 

same model. Only drainage strings should be created in 

this model. If the model does not exist it will be created.

Colour will be the colour used in the drainage longsec-

tion drawings.
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mand.To graphically check the flow direction of all strings see Flow in the Wrong Direction.

The Tin (fs) field will be completed for you with the default value you entered in Design=>Drain-

age-Sewer=>Defaults=>Tin(fs). The finished surface levels on your long section plots will be 

obtained from this tin.

The Tin (ns) field is optional. By specifying a natural surface tin, natural surface levels can be 

shown on your drainage long section profiles.

Selecting Many strings will have the panel re-appear, ready to go again, after creating each string.

Click the Create button to begin creating the drainage string. The following panel will appear.

Click and accept the point labelled B-1 and then click and accept the point labelled A-2. Since this is 

the end of the branch line, select Finish from the Drainage Edit panel. If you have other edits to 

make to the string do not select Finish yet (i.e. set some specific invert levels) RB then select Cancel 

from the menu. This will leave the edit menu active for further changes.

The Create Drainage String panel will appear again for you to create additional drainage strings. 

Create line C in a similar fashion. When this line is finished, start on line A but only place the first 

manhole, A-1. manhole A-2 is a junction manhole and requires some special attention.

To create your first manhole, select Edits =>Append. A + will appear with 

your pointer.

We are going to place our manholes on the vertices of the layout that we 

imported. Toggle the vertices on (just to help you see where the manholes are 

going to be placed), turn your line snap off and the point snap on.

The first line we will create is the branch line on the east (Line B) then the 

branch line to the west (Line C) and finally the trunk line running from east to 

west (Line A). The drawing below shows the manhole names. You will not see 

these as you draw the strings but we will create them later.
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4.7 Exact Methods for Placing Manholes

To place your manholes on a kerb line string, turn the line snap on and the point snap off,. Keep 

the height snap off.

For locating manholes at specific x, y coordinates, simply start typing the x coordinate instead of 

clicking onto a location. An input panel will appear for you to enter the x and y coordinate sepa-

rated by a space.

To place the manholes at a specified distance from a point use the RB and select SNAPS 

COGO=>Locate=>Offset. Follow the prompts given in the message area (bottom left corner of 

the screen). You will need experience with the 12d “directional pick” to use this capability.

4.8 Junction manholes on Trunk Drainage Lines

Key Points

1. The branch line must Point Snap onto the centre of a manhole on the trunk line.

2. All strings must be in the same model.

Trunk drainage lines are created the same way as the branch lines except special care must be 

used when placing the junction manholes. When placing the junction manhole on top of the 

branch line turn the point snap on and the line snap off (the F3 and F4 keys are convenient for 

this). Zoom into the branch line junction manhole so that you can snap onto the centre of the man-

hole. 

A manhole contains three points; one at each point where the pipes join (invert level points) and 

the one you want to snap onto at the centre of the manhole (setout level point). In the figure 

below, the blue line is being placed to join the magenta line. Note that the diamond indicates that 

there is a point snap and the information panel indicates that we are snapping to line 2. The infor-

mation panel also indicates the snap was a point snap.

After snapping onto the branch line manhole click Prev on the plan view title area to return to 

the previous view and continue appending manholes.

You can tell that you have created a junction manhole correctly when you profile the trunk line 
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and you can see the branch lines joining at the junction manhole. If the branch lines are not shown 

then one of three things have gone wrong.

1) centre of the manholes did not align, Use Strings=>Points Edit=>Move to move the branch 

string manhole

2) the “downstream end” of the branch line must be the junction manhole. With the direction of 

flow for the string set to “Ascending” the junction manhole must be at the high chainage end of 

the string. If the direction of flow for the string set to “Descending” the junction manhole must 

be at the low chainage end of the string. To check the flow direction see Flow in the Wrong 

Direction.

3) The branch string and the trunk string have not been created in the same drainage model. From 

the main menu select Strings->Inquire (F2) and select the strings to check their models. If 

this is the problem, use Strings=>Edit=>Change and specify the correct drainage model 

(enter the model BEFORE picking the string) or Strings=>Edit=>Duplicate to duplicate one 

of the strings into the correct model.

4.9 Flow in the Wrong Direction

The direction of flow is used by 12d to determine where the outlet is on the drainage line. 

Also, the Drainage=>Plot=>Plan annotation option can be used to label the network with the 

direction of flow.

The direction of flow will be indicated with the arrow when using the Drainage Network 

Editor and you have selected an manhole (all but the outlet). 
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If one of the arrows in the plan annotations is going in the wrong direction then the direction of 

flow flag must be changed. From the main menu select

Strings=>Properties=>String

and change the Flow direction to the other value (there are only 2 options). You may replot the 

annotations if you want to confirm the change.

4.10 Drainage Section Views and Plots in the Wrong Direction

If the section views and the profile plots are running downhill in the wrong direction, the reverse 

function may be used to change the direction.

To reverse only one string, from the main menu select

Strings =>Strings Edit =>Reverse

and pick the drainage strings to reverse. This will also change the drainage flow direction attribute 

from ascending chainage to descending chainage. 

To reverse all of the strings in a model select the Strings Reverse option,

Design =>Drainage-Sewer =>More=>Reverse all strings

To confirm the direction of flow see Flow in the Wrong Direction

4.11 Moving, Adding and Deleting Manholes

The best way to edit the plan layout of the drainage is via the Strings->Points Edit commands.

Select the 

drainage 

model.

Enter a model 

for the plan 

annotations.

Select Plot on 

the bottom of 

the panel and 

then add the 

model to a 

new plan 

view.
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The Append, Between, Delete, Insert and 

Move commands are the most common.

The Move command has an extra option for 

moving junction pits. Selecting All points with 

the same coordinate will move all points on the 

view that are at the same x,y coordinate. The 

point selected will move first and the others will 

follow after the new location has been accepted.
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5.0 Drainage Network Editor

The drainage network editor is used to automatically or manually change the attributes of your 

drainage network. These abilities include:

General

s Changing the vertical alignment of the network

s Setting manhole names

s Service Clash Checking

Hydrology

s Catchment Areas

s Checking the Automatic Catchment Linking

s Global and Defaults Tab for C values and Tc calcs

s Drainage Templates

s Bypass flow routes

Hydraulics

s Outlet and Tailwater Conditions

The drainage network editor is accessed through the main menu by selecting 

Design=>Drainage-Sewer=>Network Editor.

The bottom section of the network editor panel is shown below.

The manhole that was selected is highlighted with a circle and an arrow shows the direction of 

flow (see image below).

To begin select a 12d drainage manhole that is in your drainage model. In plan, you must pick 

and accept the manhole and not the pipe! Pipes may be selected only in the section views.
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The option buttons on the drainage editor now become active.

5.1 Setting manholes names (and pipes)

If your network was created from 2d strings the manholes will be named incrementally using integer 

numbers. Use the drainage network editor to manually change explicit ones or quickly change all 

the names using a different naming method. 

The manhole names are based on the string names so make sure the string names are set. To view 

string names on the plan view, go to the Plan View tool bar and select Toggle=>Names. If they do 

not appear see Displaying View Text. 

The string names may be 

changed String field.

Select Set Pit Names and 

the following panel will 

appear.
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5.1.1 Displaying View Text

After you have named the manholes in your network, the names should appear beside each man-

hole in the plan views. If they do not appear check the following. 

After you have named the pits in your network, the names should appear beside each pit in plan. 

You can change the text size for each string by selecting Strings->Editor and then pick-accept 

the drainage string. The text size is set from the selection Utilities->Size.

The offset from the pit is set by selecting Strings->Properties->Strings, picking the drainage 

string and setting the values for Delta x, and Delta y.

Note: Auto pit names are NOT shown in the section view.

Trouble shooting auto pit names not being displayed

Problem: Plan text is toggled off

Solution: select Toggle on the plan view title area 

Field descriptions

After selecting the desired naming method 

and options.

Select Run to change/assign the manhole 

names. These names should be visible on the 

plan view with the drainage network model. If 

they do not appear, see the section below: 

Displaying View Text

To create larger text labels that can be moved 

see Labelling the Manholes

Select Back to Editor to remove the panel.
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Problem: Small text is turned off

Solution: select the Menu button on the plan view title area and select Settings 

=>Text => Text

 - if these values are too large the text will not appear on the screen. Either 

decrease these values or increase the text size.

Problem: string text size is 0

Solution: Each drainage line can have its own size of the text. To change it, select 

Strings=>Editor then pick-accept the drainage string. The text size is set 

from the selection Utilities=>Size. If this is set to zero the labels are not 

drawn.

5.2 Labelling the Manholes and Pipes

To label the manholes and the pipes use Drainage Plan Annotations. This may be accessed from one 

of three locations. 

Location 1: From the plan toolbar

Check that the Text is toggles on. If it is on then walk right and ensure the 

text is turned on or n/a for your drainage network.

Select drop down and change to full

Quick threshold and None threshold if these values are too 

large the text will not appear on the screen. Either decrease 

these values or increase the text size.
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Note (The following panel has been reduced in size).

Location 2: The Plot Button on the Drainage Network Editor

The following panel will be displayed.

Select the plot button and 

then Drainage plan

Select your 

drainage 

model

Enter a model 

name for the 

new labels

Select Plot

Now add the 

drainage 

labels model 

onto the plan 

view.
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The text properties can all be customised using the plot parameter file but this will be discussed later 

in the plotting section. These labels are not automatically updated when you change the names or 

pipe diameters. You must rerun the labelling routine to update the labels.

5.2.1 Turn off View Text Manhole Labels

To turn off the automatic view text manhole labels for this view select Toggle=>Text and then walk 

right to select the drainage model. Do not click on Text, rather walk right. If you click Text you will 

toggle on/off all of your text on the view. Not just the drainage model.

This option can plot both the long section 

and plan at the same time. Select a ppf file 

from the library.

Enter a model for the plan annotations.

Select Clean model beforehand if you 

have not manually moved any of your 

manhole labels.

Turn off the long section plot for now.

Select Plot.

Now add the Model for plan annotations 

onto the plan view.



Revised February 2006 12d Stormwater Design Course Notes Page 37 of 94

12d Solutions Pty Ltd

COURSE NOTES

STORMWATER DESIGN

5.2.2 Moving Text

The labels created may be manually moved using the CAD toolbar but if the model is relabelled 

the text will return to its original location! Text moved via the Drafting->Multi string 

translate will remain in the moved position when Smart Clean is selected in the Plan Annotation 

panel.

To move a pre-defined Group of text select

Drafting->Multi string translate

Before selecting text turn on your teXt snap.

To move a single line a text use the CAD 

toolbar. Select the Move text justify but-

ton. To use this toolbar you must DRAG 

the Create text button to the right 

and then release when the pointer is on the 

Move Text Justify Point.
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5.3 Catchment Areas

Key Points

1. Start near the manhole for auto linking.

2. Manual linking available via Network Editor->Catchments->Pick button.

3. Close the string for SAG pits.

4. You may fill the strings using “Utilities->Super strings->Fills”

5. You can disable the auto selection of a string via Right mouse on the pick button then select 

Clear.

Catchment areas for your hydrological model may be defined using a Super, 2d, 3d or polyline string 

to set the catchment boundaries. Other ways to set the areas are: manual entry in the network editor, 

via a spread sheet program, the Top 10 Attribute Editor or the ILSAX pipe editor.

Note that if a catchment string is created to define the area for a manhole then all other data entry 

types will be ignored and the area from the string will be used.

There are 3 sets of catchments and it is up to the user to decide how they are to be used. Often set 1 

will be all the impervious areas and set 2 the pervious and set 3 for special areas. Each set has its own 

percent impervious. The 3 catchment sets are drawn in three different models.

If exporting to external drainage design programs they may note accept all three sets so check the 

interface notes before defining the catchments.

In each set/model, 12d will automatically link the catchment string to the manhole that is closest to 

the first point on your catchment string. This is the preferred method. If this is not possible, then a 

manhole may be manually linked to a catchment string using the Catchment manual link. 

Also see Checking the Automatic Catchment Linking

Drawing Catchment Strings in 12d

Before creating the catchment string set the CAD control bar data.

Select Group and then pick and accept one of the 

text items in the group. Move it to its new location 

and accept.

Note: To move another group you must select the 

Group button again.

Type the name of a model for the catchment strings
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Now to create the catchment string use the Create line string button on the CAD toolbar. 

The first point should always be placed near the manhole. 12d will assume that the catchment will 

drain to the manhole closest to this first point.

There is no need to go “overboard” with the accuracy of the catchment strings (except maybe with 

SAG pit catchments near the low points). From experience, it is more important to spend time 

verifying catchments in the field than spending a lot of time getting them “exactly” placed on the 

catchment plan. If you want to use the drawing as a catchment plan submission then the extra care 

in creating the strings may be warranted. Continue selecting and accepting the points on the 

catchment string and the press ESC to finish creating this string. You are now ready to create the 

next catchment string.

DRAG the Create line button and release at 

the Create Line String button.

SAG inlet catchments: DO NOT START AT THE INLET, 

just start nearer to this inlet than any other! If you start at 

the inlet then move out to the crest of the catchment, the catch-

ment overflow level cannot be determined from the catchment 

string.

For the last point on your catchment line select Close from the 

CAD toolbar. This function places the last point on the string 

over the first point on the string forming a closed polygon.

Once the catchments are drawn they become linked to the 

drainage network in the Drainage network editor. We will 

label the catchment with the manhole name and area at the 

same time.

Start the Drainage network editor and move to the Global 

Tab and then the Utility Models sub tab.
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Every manhole can have 3 catchments, row 1 is catchment set 1, row2 for catchment set 2 and row 3 

for catchment set 3. 

The Auto-rename catchment polygons will set the name of the catchment string to the pit name 

that it is linked to. If it is not linked to any manhole it will be named “not used”. The model can be 

checked for not used strings by selecting Models->String Info Table.

To label the catchment areas with the names of the manholes they are linked to we need a catchment 

labels model and a textstyle favourite. We need to create a label textstyle favourite if you do not have 

any favourites defined.

Enter a 

filename 

for the 

catch-

ment 

models.

Select 

More 

info but-

ton.

Select 

Edit.

RB click 

to select 

the 

model of 

the 

catch-

ments 

used in 

the CAD 

control 

bar 

above.
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Select the textstyle button and then the drop down for Favourites. Now select Edit.

Select Set to store the textstyle favourite for this session only. To permanently save this text-

style favourite and have access to it in all of your projects select Write and the following 

Enter the data as show. Some data you will have to type on the keyboard (type) and other 

you may use the right mouse button (RB) and then select browse.

Type RB RBTypeRBType RB
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Label Catchments

Select the User folder.

Select Write to save the favourite to the 

User folder.

If you are in a network environment and 

want to see if you have write access to 

this files select the Properties button.

Finally select Set catch-

ments. This will link the 

catchments to the man-

holes and label the catch-

ments. Now add the model 

labels onto the plan view.
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There are some cases where linking the closest manhole to vertex 1 is not feasible. In these cases 

you may manually link the manhole to a catchment.

Catchment manual link

The manual links are used when the first point on the catchment string is closest to the wring man-

hole. Note that the following restrictions still apply.

1. The string selected for catchment 1 must be in the model for set 1. To check if you have 

selected a valid string select the Set Catchments button.

2. If the catchment string has already been linked to another manhole (automatic or manual) then 

the new link will be created and the old link erased.

3. If you change the catchment model for one of the sets on the Network Editor->Global->Util-

ity Models->catchments than all of the manual links in that set will be erased.
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Checking the Automatic Catchment Linking

The automatic manhole-catchment linking is easily checked by specifying a Catchment labels 

model with Labels textstyle on the Global->Utility models tab and selecting the Set Catchments 

button on the network editor. Also once the Set Catchments has been selected, the catchment is 

indicated when the manhole is selected using the network editor. Since there may be three catch-

ments per manhole the catchment data last viewed in the editor is the catchment that is highlighted.

The catchment strings may be drawn in a CAD package and then imported into 12d or drawn inside 

12d. The strings may be easily drawn in 12d with the tin contours and/or flow arrows displayed in 

the plan view.

First change to the Catch-

ment tab.Now either use the 

Pick Edit button to select the 

manhole or use the >> (next) 

or << (prev) buttons to move 

to the desired manhole. The 

manhole will be circled in the 

plan view and its name shown 

in the Current Pit field.

Now select the Catchment 

polygon button and pick the 

desired catchment string.

NOTE! If you decide to enter 

a value and NOT use the 

selected string RB on the but-

ton and select Clear.

If the Auto apply tick box is 

not selected then you will 

have to select the Apply but-

ton for the manual link to 

become active.

After the Set Catchment but-

ton is selected the measured 

catchment area will be shown 

in the Catchment area field 

using the units specified in 

the Global-Utility models-

Units field.
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5.4 Network Editor - Global, Default Settings and Explicit Settings

Design values for the hydrology and hydraulics calculations are set either globally (one value for 

the entire network) or via Defaults for the manholes or pipes. Defaults values may be overridden 

by explicit settings found on the catchment, pits or pipes tab. Explicit manhole/pipe settings 

need only be specified if the default value is not desired.

5.5 Drainage Templates

The default and global settings may be saved as a template for other projects/networks. After set-

ting the defaults for a network follow these steps.

1. Save the project. We are going to do a clean where there is no undo.

2. Clean the drainage model so that all of the strings are deleted but the model attributes will 

remain. DO NOT SAVE YOUR PROJECT.

3. Export the model using File IO->Data output->12da/4da data. 

4. Restart 12d, Project->Restart and DO NOT SAVE because you have cleaned your drainage 

network.

The 12d ascii file may now be imported to another project via File IO->Data input->12da/4da 

data. Since the global and default values are stored as model attributes, they will be imported 

with the network.

5.6 Network Editor - Hydrology

The network editor edits both the network and catchment data and it has already been introduced 

in the previous sections. This section will discuss the Hydrology Global, Defaults and explicit 

setting for the hydrology parameters. The parameters described on the defaults tab will also be 

found on the Catchment or Pit tabs.

5.6.1 Catchment Areas

The catchment areas have already been discussed in the previous section. There is no default 

catchment area to apply to all catchments (as would be expected).

Note! If a catchment string is linked to the manhole and the Set catchments button is 

selected, this string area will override any manual value that you type into the drain-

age area field. To ensure manual entry is maintained, RB select the string selection 

button and select Clear.
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5.6.2 Coefficients of Runoff

Global Settings

Default Settings

Runoff C methods 

include Direct and ARR 

1987. For the ARR 

1987.

Direct: There is a global 

impervious C value for 

both the minor and major 

storms.

ARR 1987: The com-

posite C value is calcu-

lated using the 1hr-10yr 

intensity, the percent 

impervious, ARR fre-

quency factors and the 

return period specified 

when hydrology runs are 

made. No C values are 

entered if this method is 

used!

The Direct method has 

both defaults and explicit 

settings on Catchment 

tabs (see below).
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Implicit Settings

5.6.3 Percent Impervious

The default percent impervious for the network is set on the Defaults->Catchment Defaults tab 

and the explicit settings are on the Catchment tab (see above). The percent impervious is used to 

determine the area for the impervious and pervious components and the composite C value if 

using the ARR 1987 method for calculating runoff coefficients.

5.6.4 Times of Concentration

There are several methods for entering times of concentration for the catchment areas (see list 

below). Default and explicit settings (catchment tabs) are entered/calculated for both the methods 

and values for the pervious and impervious areas. Since each catchment may use a different tc 

method all of the tc parameter fields on the defaults tab are active. They must be filled in even if 

you do not plan on using that value.
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1. Direct method requires minor and major tc values.

2. Friend, Kinematic Wave, Bransby Williams and QDUM methods require the retardance, 

length and slope of the catchments to be entered. Default values must be entered but the optional 

explicit settings for slope and length can be entered on the catchment tabs or a catchment charac-

teristic strings may be drawn (see Catchment Tc path strings). The length of this string is used 

for the length parameter and the design tin is used with the string to calculate the slope using the 

equal area method.

3. Data for the remaining methods is entered in a similar fashion.

5.7 Tc Path Strings

These strings are used to calculate the time of concentration for the impervious and pervious areas. 

They are drawn in two models; one for the impervious paths and one for pervious paths. The models 

are specified using the Catchment file field on the network editor (Global->Utility model tab). The 

3 rows in the catchment file correspond to the 3 catchments available for each manhole. Therefore it 

is possible to have a maximum of 6 Tc paths models!

Key Points

1. Each Catchment set may have 2 Tc paths models. Pervious and impervious paths are kept in sepa-

rate models.

2. End the Tc path string at the manhole that it is to be linked to.

3. Enter the paths models via Catchment file field on the network editor (Global->Utility model 

tab)

4. You must select a Tc method (explicit or implicit) via the Defaults->Catchments tab or the 

Catchments Tabs. Just specifying the models is NOT enough!
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The tc strings can be drawn in the same way as the catchment strings but make sure that you 

change the model name first! The tc string model is then entered in either the impervious or pervi-

ous paths model columns (You could have up to 6 tc string models!).

5.7.1 Catchment slope (equal area)

The length of this string is used for the length parameter and the design tin is used with the string 

to calculate the slope using the equal area method. These strings are drawn from upstream to 

downstream, finishing nearest to the manhole they are to be linked to. The line style for these 

strings must be the flow line style found under Drainage 12d in the linestyle drop down list.
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The equal area slope is calculated at export time. After the export the slope string, it may be profiled 

to see the slope (see below).

5.8 Network Editor - Hydraulics

This section will discuss the hydraulic Global, Defaults and explicit settings for the hydraulic 

parameters. The explicit settings for the parameters described on the defaults tab will also be found 

on the Pit or Pipe tabs.

5.8.1 Setout to Grate Offset

The grate level is used by 12d when determining the freeboard and when calculating depth of flood-

ing at SAG pits. The grate level is often exported to other design packages. The grate level is calcu-

lated as

Grate Level = Setout z + Setout to grate offset

The setout to grate offset is generally zero or negative and implicitly set on Network Editor-

>Defaults->Pits->Setout to grate offset or explicitly on Pits->Main->Setout to grate offset.
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5.8.2 Pit Losses Ku, and Direct Flow

5.8.3 Pipe Friction Method

If the setout point was on top 

of the kerb, enter the Setout 

to grate offset so that the 

overflow level of the man-

hole can be determined.

The Direct flow (cms/cfs) is 

water flowing into the man-

hole. It is not added to the 

approach flow and therefore 

is not affected by manhole 

inlet capacity.

The Pit loss Ku is used to 

model the energy losses 

through the manholes.

The Global friction loss 

method for the pipe 

roughness method is set 

here (Colebrook or Man-

ning). The default pipe 

friction values are set on 

the Defaults->Pipes tab.

The ranges for pipe peak 

velocities are used for 

checking purposes only. If 

the velocities are outside 

this range, warning mes-

sages will be given in the 

output window.
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5.8.4 Pipe Friction Values and Freeboard Limit

The global pipe friction 

method on the Global tab 

determines which fields are 

active, Colebrook k or 

Mannings. The default 

roughness values are 

entered on the following 

Defaults-Pipe tab.
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Part-full Pipe: Flow-depth Design is the similar to option 2 except the pipe sizes are selected by 

checking the normal depth in the pipe against this value. Freeboard is also checked in this mode 

and if required the pipe will increase in size.

Open Channel: Freeboard Design is similar to option 2 except depths at the upstream end of the 

pipe may be less than critical depth for steep pipes (supercritical flow at the entrance).

The Freeboard limit is used for all Design modes. The freeboard is measured down from the 

grate level (setout level minus setout to grate offset).

The Flow-depth limit at pipe entrance (%) is used in Design mode 3. If the normal depth in the 

pipe is greater than this value the pipe size is increased.

5.8.5 Outlet and Tailwater Conditions

The most downstream manhole on each network requires tailwater conditions. Often the invert 

level on the downstream end of the last pipe also needs to have the level locked to either discharge 

into a waterway or join into an existing drainage system. When the most downstream manhole is 

selected the following fields will become active on the Network Editor - Pit - Main tab. If these 

field are not active and you think you are at the outlet see Flow in the Wrong Direction.

The Design mode has 4 

options.

Pressurised Pipe: Free-

board Design does not 

use partial depths in the 

pipes and pipe sizes 

selected by checking the 

pit freeboard.

Part-full Pipe: Free-

board Design is similar 

to option 1 except grad-

ual varied flow and 

hydraulic jumps are cal-

culated in the pipes. 

Critical depth is the min-

imum depth at the 

upstream end of the 

pipe.
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5.9 Pipe Design Parameters - Sizes, Invert alignment, Min Cover, Max Height

The invert levels during design are controlled by the pipe sizes, max pipe height, min pipe cover 

and invert alignment mode.

5.9.1 Invert Alignment Modes

NOTE! Invert design parameters are set on the Pipe-Design tab not the Pit tab. The Alignment 

mode refers to the DOWNSTREAM INVERT ONLY.

1. The initial pipe grade is set as the Minimum grade (Minimum Grade mode) or the grade 

Minimum will use the 

least of the Critical or 

Normal depths. If a fixed 

level is available for the 

minor and/or major storms, 

these value may be entered 

here.The Pit sump level is 

used to enter the sump level 

of the network that is being 

connected to (Optional).

12d has 3 design modes for 

setting the pipe inverts 

upstream and downstream of 

the manholes. These work 

together with the 2 pipe cover 

modes as follows. 

The tin specified in the Glo-

bal-Main Finished Surface 

Tin field is used for these cal-

culations. The description 

below assumes that none of 

the inverts have been manu-

ally locked.
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between the ground levels at the manholes (Minimum Depth mode). Even in the Minimum 

depth mode the minimum grade constraint is checked.

2. 12d shifts the pipe down so that there is at least the Pipe cover limit along the pipe. The Pipe 

cover limit should include an amount for the pipe thickness.

3. Inverts are moved down if required according to the setting in Alignment mode. 

Obverts are aligned using Obvert Drop  with a zero Alignment drop and similarly the inverts 

are aligned with the Invert drop mode. Minimum drop ensure that the inverts drop a mini-

mum of the specified drop but the drop may well be more than the Alignment drop specified. 

As the inverts are moved down the minimum pipe grade is maintained.

NOTE! If Obvert Drop is selected and the downstream pipe is a smaller pipe then the inverts 

will be aligned!

5.9.2 Pipe sizes, Max pipe height and Multiple Pipes and Box Culverts

The 12d design engine will select pipe sizes from the file specified on the Drainage Network 

Design panel, Preferred pipes file field list. See selecting pipe sizes. However, the maximum 

pipe height allowed before multiple pipes are used and the selection of box culverts is set on the 

pipe->main and pipe >design tabs respectively.

For box culverts, the design engine increases the widths and maintains the height through the 

available sizes. Once the maximum height has been reached, the next culvert height and minimum 

width is checked.

5.9.3 Pipe Size Design

On the Pipe->Design tab the Lock Pipe size prevents the 12d design engine from resizing the 

pipe. Max pipe height can be set for each pipe segment (there is no default for this value). If the 

12d design engine requires a larger pipe, then multiple pipes will be selected.

To specify a box culvert in 

your network, select the 

pipe segment and enter a 

width for the pipe.
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The figure above shows the 12d pipe design modes. 

Pressurized Pipe: Freeboard Design 

When solving the gradually-varied-flow equations in the upstream direction of a pipe, if the HGL is 

ever below the obvert, the US-pipe HGL is set to the obvert. This is the simple and conservative 

method in the example shown in the ARR 1987. The pipe-size design/analysis is based only on the 

resulting Freeboard in the US-pit. 

Part-full Pipe: Freeboard Design 

When solving the gradually-varied-flow equations in the upstream direction of a pipe, if a hydraulic 

jump occurs the US-pipe HGL is set to critical depth. This method is good where part-full pipe anal-

ysis is allowed, but pressurized pipes are also acceptable. The pipe-size design/analysis is based only 

on the resulting Freeboard in the US-pit. 

Part-full Pipe: Flow-depth Design 

Same as above but pressurized pipes are NOT acceptable. The pipe-size design/analysis is based 

BOTH on the resulting percentage depth of flow in the pipe entrance, and the resulting Freeboard in 

the US-pit. 

Open Channels: Freeboard Design 

When solving the gradually-varied-flow equations in the upstream direction of a pipe or open chan-

nel, if a hydraulic jump occurs the US-pipe HGL is set to normal depth. This method is good for 

open channels or pipes where the “pit” directly upstream is a dummy pit with minimal losses. The 

pipe-size/channel size design/analysis is based only on the resulting Freeboard in the US-pit.

5.10 Road Design File for Pit Setout - x,y, level, road chainage and setout offset

The road design file is used to automatically link the manhole to a road setout string and a road cen-

tre line string. Explicit picking of these strings may be found on Pits->Setout->String selection. 

These strings may be used calculate road grades and crossfalls (bypass model required) and/or con-

struction setout data.

The construction setout point defines the location on the manhole to be printed in the manhole 

schedules, plotted on the plan annotations or listed on the drainage long sections. The setout point 

and level can be set to the centre of the manhole or it can be linked to a road design string. The setout 

level plus the Setout to grate offset determines the grate level for surcharging calculations.
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The centre of the manhole or setout point can also be dropped perpendicular onto the road centre 

line to obtain the road chainage and offset distance.

Pit centre is the centre point of the manhole (the intersection of the joining pipes). Often the 

setout point for a manhole or catch basin is not the centre of the manhole but rather a point on the 

kerb or back on the foot path. The setout string option will drop the centre point of the manhole 

onto the closest string in the Road design model list specified on the Global->Utility models tab. 

The manhole cover level will be set to level on this string.
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The Centre string ID is used in the same way to find the centre line string. If needed, this string is 

used for road chainage and to determine which direction to measure the crossfall (between the setout 

string and the centre string).

The distances and searches are optional. The setout and centre search distances are the maximum 

distance that the routine will look when trying to locate the setout and centre line strings respectively. 

The grade offset it the distance upstream from the setout point that the road grade measurement will 

start and the Xfall offset is the distance from the setout point to the start of the crossfall measure-

ment. The measurements will be taken over a distance of slope measurement distance with the 

actual levels taken from the finished surface tin specified on the Global-Main tab.

Repeat this for each road string model used in the design. Remember to select Write when fin-

Type a file name, select the 

folder icon and then select 

Edit from the drop down. 

NOT Edit file.

The following editor will 

appear.

RB select this box and 

choose the models con-

taining the setout strings. 

In the Setout string ID 

box enter the string name 

prefix (wild card * 

allowed) to limit the 

selection for setout string. 

If no ID is entered then 

this model will NOT be 

searched! 
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ished!

Select the Set Pit Details button on the bottom of the panel the calculate these values.

Explicit settings for the setout strings and the auto calculated values are found on the Pit-Setout 

tab. If the manual mode is selected the Easting and Northing locations may be picked in plan 

view or typed into the input boxes.

The setout level defines the level on the manhole to be printed in the manhole setout tables and in 

the drainage longsection plots. The FS Tin selection obtains the level from the FS tin, specified 

on the Global-Main tab, at the centre point of the manhole.The Setout String location obtains 

the z level from the setout string as described in the section above. Explicit settings and the auto 

calculated value are found on the Pit-Setout tab.

If Road chainage mode is set to Centre string, then the Centre String ID in the Road design 

file (shown above) is used to select the road string to measure the chainage and offset from. The 

values and explicit settings for the road chainage and offset are found on the Pit->Setout tab.

5.11 Calculate Bypass flow routes

This option is required for manhole inlet capacity calculations and is covered in the advanced 

drainage training.

As an introduction, the overland flow parameter routine determines the road grade, crossfall, 

manhole inlet capacity and downstream bypass manhole for each manhole. To achieve accurate 

measurements for the road grade and crossfall, the manhole is linked to a setout string (see 

below).
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6.0 Service and Utility Clashes

WARNING!

12d service clash routines notify the user of crossing services but not parallel services that are close 

to each other. To view parallel services, add the services model onto a section view, profile a drain-

age string and then set the corridor value for the section view.

The service clash model list is entered on the Global-Utilities Model field.

Settings->Corridor and 

then set the Width left and 

Width Right to the desired 

clearance. If the service can 

be seen then it is within the 

tolerance. 11 is used in this 

example only so that you 

can see the service on the 

other side of the road.

Use the Next and Prev but-

ton to switch drainage 

strings.

To obtain a report of all strings 

inside or crossing the drainage 

string profiled, select the View 

menu button then Utilities-

>Report
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Service clashes are listed in the output when the Set pipe inverts is selected on the Drainage 

Network Editor. If the output window is not visible then from the main menu select

Window->Output Window

and make sure it is selected.

To create a list enter a list name, select the folder 

icon and then select edit.

In the Service model column RB to select the 

model. Enter Minimum Clearance for the serv-

ices in this model. If different clearances are 

required for different services then place the 

services in different model. Warnings will be 

issued at design time. Cover levels or fixed 

inverts can be used to avoid the services.
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Once the invert levels have been reset by selecting Regrade pipes, the output window will indicate 

the final clearance.

After a pipe design run in Storm Analysis, details of the service clash data will again be listed in the 

output window.

The most common method 

to avoid the clash is to 

increase the Pipe cover 

limit for this pipe segment 

so that the pipe is pushed 

down. If the clash problem 

is above the pipe then the 

Max pipe height may be 

used and multiple pipes are 

selected.

This method is preferred 

over locking the inverts as 

this leaves more flexibility 

for aligning the inverts.
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7.0 Drainage Design in 12d Drainage Design

12d has a sophisticated rational method hydrology and hydraulic grade line pipe design engine. In 

addition it has the capability to export this data to several other popular drainage packages. 

Regardless of the design method selected the drainage network in 12d is updated from the design 

so that drainage plans, long sections and manhole schedules can be quickly produced.

7.1 12d Rational Method Hydrology - Drainage Rainfall Editor

The Drainage Rainfall Editor is used to input rainfall IFD data using several methods. The data 

is stored in Meteorology files (each file is for a specific location) that can be shared between 12d 

projects. The data is edited using an editor similar to those used for the plot parameter files (ppf). 

Seven methods for entering/calculating the rainfall intensities are shown in the panel below. From 

the main menu select,

Design->Drainage-Sewer->Rainfall Editor

Data is entered using one (or more if desired) input methods and then saved by entering a Mete-

orology file name and selecting Write. The standard 12d system file search paths are used 

(project folder, user library folder and then library folder).

7.1.1 IFD Tables

IFD tables are often available from meteorological services. The table input format follows. The 

first row is used to define up to 9 return periods and the following rows list the rainfall intensities 

Select the folder icon and then walk right on the Lib item to display a list of sample files. 

Select a file the select Read. YOU MUST SELECT THE READ BUTTON!
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for the duration entered in the first column.

Hint: to increase the size of the grid control select another method, ARR 1987 for example, and 

then select IFD table again.

7.1.2 Australian Rainfall and Runoff 1987 Method

The rainfall intensities and other factors from Volume 2 of ARR 1987 are entered in this table.
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7.1.3 Australian Rainfall and Runoff 1977 Method

The seven coefficients for each return period from ARR 1977 are entered in this table.
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7.2 Drainage Network Design

The Storm Analysis button on the Network Editor executes the 12d drainage design, plots the 

drainage long section and plan annotation and prepares the hydrology and hydraulic design tables. 

From the Drainage 

Network Editor select 

Storm Analysis. The 

following design panel 

will appear.
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In general the Analyse network is always selected. If you only want to plot or create the reports 

then remove the tick.

Storm Factors

Select the folder icon on the Rainfall location file and then walk right on the Lib line to select 

one of the rainfall files in the 12d library. If the file has only one type of rainfall definition then 

the Rainfall method field will be completed. Otherwise select the Rainfall method desired. The 

valid Return period will depend of the method selected but you cannot extrapolate beyond your 

data.

Event type determines which set of design values (minor or major) will be used for this run. 

Enable the 12d rational method engine partial area calculations by selecting the Partial area 

effects box.

Network Design Factors

Selecting Pipe Sizes

These values control the values to be designed in the run. If Design pipe sizes is selected then a 

files containing the available pipe sizes must be supplied. The pipe sizes in this file are in the 
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Units specified in the drainage network editor. To create a new file, enter the file name and then 

select the folder icon followed by the Edit line. The following panel will appear.

The Upsize only selection will stop pipes in the system from being reduced in the design. Regardless 

of this selection, the 12d design engine will not allow a smaller pipe to be selected in the downstream 

direction.

Generate Results in Plan

This selection automatically runs the drainage plot annotation function. A Drainage plan ppf must 

be entered and samples are supplied in the 12d library. A Model for plan results is required if this 

option is selected. The Clean model before hand tick box forces the model to be cleaned before the 

labels are created. When not selected a “Smart clean” is performed.

Generate Results in Long Section

This selection automatically runs the drainage long section plotter. A Drainage long section ppf is 

required and examples are found in the 12d library. A Model stem for long section results is 

required if this option is selected. In almost all cases the Clean model before hand tick box should 

be selected.

Generate hydrology report

The diameters/heights are required and the 

width is optional to specify a box culvert.

YOU MUST SELECT THE WRITE BUT-

TON!

The hydrology report may be 

formatted for inserting into a 

12d model/text editor (format-

ted) or spreadsheet (comma or 

tab delimited). In almost all 

cases Overwrite existing 

report file will be selected.
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7.3 The Run Button and HGL data on the Section View

When the Run button is selected the discharges are calculated, the HGL check is performed and 

the pipes sizes and inverts are designed (if selected). The plan and long section drawings will also 

be updated with the new data (if selected). 

7.4 Importing Text into a 12d model

Formatted text may be inserted into a 12d model by selecting

Drafting->Text and Tables->Create edit paragraph text

The HGL values will also be available on the 12d section views when profiling the drain-

age strings. The colour of the HGL line may be changed via the view’s menu button then 

Settings->Drainage.
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Generate hydraulic report

Change to File.

Select the folder icon and then pick the formatted 

text file. It will be displayed then select Set. 

Next select the location in plan for the text.

The font selected must be a fixed space font or the 

data will not align properly.

Select the Font to display the following panel.

Enter a Text Model for the report.

The Text Style must be a fixed space font.

Select Set then Finish.

Now add the Text Model onto the 

The hydraulic report may be 

formatted for inserting into a 

12d model/text editor (format-

ted) or spreadsheet (comma or 

tab delimited). In almost all 

cases Overwrite existing 

report file will be selected.
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If you want both the hydrology and hydraulic report in the same file, enter the same file name in 

both file fields but turn of the Overwrite existing report file for the hydraulic report.

7.4.1 Design Results

Results from the design runs are shown in several forms:

1. Hydrology and hydraulic reports

2. Drainage plan annotations

3. Drainage longsections

4. Hydraulic Grade line on the Section view

5. Output window data - Service/utility clashes

Samples of the hydrology and hydraulics report are shown below.
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8.0 Drainage Data Input and Output to Spreadsheets

Spreadsheets are an effective method to manage the numerous variables urban drainage designers 

create in the modelling process. Spreadsheet data can be transferred to and from 12d in tab delim-

ited files and stored within 12d as “user definable attributes”. These attributes are linked to the pit 

and pipes within a network. Drainage long section plots can display the pipe attributes in the 

“arrows” data area and pit attributes in the bubbles area. Drainage plan drawing can also show 

these pit and pipe attributes.

Drainage strings will be created if they do not exist in the model but manholes cannot be added to 

existing strings.

See also

12d to spreadsheet transfers

Spreadsheet to 12d update and create

Spreadsheet options

8.1 12d to spreadsheet transfers

This interface is accessed the Import/Export button on the Drainage Network Editor.
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8.2 Spreadsheet to 12d transfers

This item is accessed from the Import/Export button on the Drainage Network Editor.

The following panel will appear.

Select Export

Select Spreadsheet clipboard

These options are not used for 

spreadsheet export.

Usually leave this off! Select 

to export the junction pit at the 

end of all drainage lines (very 

rarely needed).

You may also select to limit the 

output if desired. If you like 

using spreadsheets for data 

entry, the PCdrain data and 

ILSAX data formats are useful 

for adding data for the first time 

for either program.

Select Run to place the data on 

the clipboard.
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Tab delimited, “12d drainage spreadsheet” format or “from to” format data must be on the clip-

board in order to update a 12d drainage model or create a new model. These format are described 

below.

8.2.1 Updating an Existing Model

The data usually is generated by 12d using the Export option, pasted into a spreadsheet and then 

copied back to the clipboard so that 12d can be updated. 

When 12d exports the drainage model to a spreadsheet it includes a column for the unique string 

identifier and a unique manhole identifier (unique to the drainage model not the 12d project). The 

names of the strings and manholes may be changed via the spreadsheet if these columns are 

present at import time.

If the manhole id column is not present, 12d will search the drainage model for a matching man-

Select Import

Select the Spreadsheet clipboard 

format.

The file field is ignored.

This is ignored on spreadsheet 

imports.

Select Run to update the drainage 

model.
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hole name. When the manhole is a junction between drainage lines, only the trunk line will be the 

data updated.

8.2.2 Creating a New Model

It is possible to create a new string or an entire drainage network using this format. However, man-

holes cannot be added to an existing string. The entire drainage string must be created at once. Two 

formats are available, the “from-to manhole” format and the “12d drainage spreadsheet” format. 

At present the network editor must select a drainage string to become active. Therefore, if you are 

not adding strings to a network, you will have to great a drainage network with one “dummy” man-

hole. Select this one “dummy” manhole to activate the editor. After importing the data and the new 

drainage lines are created the “dummy” manhole may be deleted.

12d drainage spreadsheet Format

The top left cell in the clipboard data must be the text “12d” to specify this format. The mini-

mum amount of data required to create a new string is the string name, manhole name, x and y 

coordinates. You can add as much additional data as you have available. This would include 

pipe diameters inverts etc. The manholes must be listed from upstream to downstream order. If 

the string is to join a trunk line, the junction manhole must be included for both the tributary 

and the trunk line.

An example file exists called new_network.txt is supplied in the library. Open this file in a 

spreadsheet or a text editor and copy it to the clipboard. Set the I/O Action to Import and 

select Run. The new drainage lines will exist in the model currently being edited.

From-to Manhole Format

The top left cell in the clipboard data must be the text “from to” to specify this format. The 

minimum amount of data required to create a new string is the upstream pit name "*pit name), 

the downstream pit name (*ds pit name) and the x(x location) and y(y location) coordinates of 

the upstream pit. If the string is to join a trunk line, the junction manhole must be included for 

both the tributary and the trunk line. 

An optional column for the manhole cover elev (cover elev) may be specified. Once the net-

work has been created additional pipe and manhole data may be added using the “12d drainage 

spreadsheet” format described above.

An example file exists called new_from_to_network.txt is supplied in the library. It is shown 

below. Open this file in a spreadsheet or a text editor and copy it to the clipboard. Enter a new 

model name in the Drainage model field and select paste. The new drainage model will now 

exist. 
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8.3 “12d drainage spreadsheet” Format

Each column of data is used for a 12d drainage variable or a user defined attribute. Each row rep-

resents a manhole and the downstream pipe (controlled by the direction of flow variable) within 

the drainage network. A sample is shown below.
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Duplicate Definitions

Strings Variables such as “direction” are may be defined for numerous manholes on the same string. 

Searching in a top down direction through the file, the last definition found for the string will be set.

Invert levels may be set via pipe data or pit data or combined. It is recommended that the user only 

use one method and not combine them. Both are exported so delete the ones you are not going to use. 

The variables are processed from left to right, so if duplicate definitions of an invert level or found 

the right most data will be set.

The format definition

1. Row1, column 1 must contain either “12d”, or “from to”. Therefore, the first column must be a 

12d drainage variable (cannot be a user defined attribute).

2. Row 1. The text <pit> at the top of the column indicates the column contains a user defined pit 

attribute and similarly <pipe> indicates a user defined pipe attribute.

3. Row 2. This row contains the names of the 12d drainage variable names and the pit/pipe 

attributes. All names are case sensitive so be careful where you use capital letters. A list of 12d 

drainage variables is found below.

Names beginning with an asterix (*) will not be processed (except pit/string names when unique 

identifiers are present in the data). 12d drainage variables names beginning with an asterix indi-

cate that this data was calculated at export time and cannot be read back into 12d (for example, 

pipe length, pipe grade and deflection angle). 
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Prefixing an user defined attribute name with “DELETE ” (no quotes, note the space after the 

DELETE) will cause the attribute to be deleted from all pits/pipes within the model.

4. Row 3. The text in this row define the type of attribute to be stored within 12d. The only valid 

choices are;

integer

real

text

If you want to change an attribute type you must delete the attribute and create it again. If you 

simply change the attribute type in the third row then that attribute will not be updated.

5. Blank lines may be inserted as desired.

6. You are not required to fill in all of the cells in the spreadsheets. Blank cells are ignored (you 

must use a space to remove all data from text attributes (the space will not be stored).

7. Pipe names are included in the data so that they can be changed but they are not used to iden-

tify the pipe. Pipe data will always be assigned to the pipe following the pit in the direction of 

ascending chainage. If flow directions is ascending then the pipe data will be for the down-

stream pipe. If the flow direction is descending then the pipe data will apply to the upstream 

pipe.

8.4 12d Drainage Variable Names
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9.0 Reviewing, Changing and Creating User Defined Attributes

The catchment data is stored within 12d as user defined attributes. These attributes are automatically 

created by 12d when required but you are free to change them or add more as desired. The attributes 

may be exported to a spreadsheet and edited and then imported back into 12d. To work with the user 

defined attributes within 12d select

Design=>Drainage-Sewer=>More=>Top 10 Attribute Editor. 

.

They may not be defined for the manhole you are editing. Not found will be displayed in the Data 

field if the manhole does not have that attribute defined.

To change the value for the attribute enter 

the new value in the data field. If the 

attribute does not exist, deleting the not 

found text and adding data will create it. 

The message on the right will be displayed 

whenever you are creating a new attribute.

First Select Pick to select the string 

that contains the user attributes (the 

drainage string). The strings will be 

highlighted in white when they are 

selected.

All catchment data is store with the 

manholes in drainage strings. To 

access the manhole attributes, select 

the drop down icon and then select 

manhole. A circle will be drawn 

around the manhole selected. Next 

and Prev will now move you from 

manhole to manhole.

Select the drop down icon and then 

select the Attribute Name from the 

list of existing user defined attributes. 

These attributes include all of the 

attributes in the model that the string 

exists in. 
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10.0 Manhole/Pit Schedules

Manhole/pit schedules or construction tables are generated in tab or space delimited formats.

This panel is accessed from the menu selection

Design => Drainage => More Drainage => Pit schedule

The fields and buttons used in this panel have the following functions.

Field Description Type Defaults Pop-Up

Drainage model name input box drainage network

model containing the drainage strings

Pit schedule file name input box pit report

file to be created

Report Format choice box Road chainge.,Easting...

file format

Data delimiter choice box Tab, Space

tab delimiters are best for spreadsheets and space for some text editors

Repeat header for each line tick box selected

when selected, the column headings will be printed each drainage line 

Calculate road chainage/offsetstick box selected

only used for road chainage-offset format. When selected, the road chainages and offset calculation 

panel will be displayed so that the this data can be updated before the report is generated. (see below)

Easting Northing Location choice box pit centre, road design string
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easting northing data can be from the manhole centre or the x,y location on the road design string that the 

manhole has been linked to

Cover elevation location choice box pit centre, road design string

the cover level elevation can be from the manhole centre or the elevation on the road design string that the 

manhole has been linked to (if a link has been made then these values should be the same). Note that the 

road design string data is NOT calculated at this time. These are the values calculated from the Drainage 

Misc Utilities or the last drainage data export.

Process button

Create the pit report

Finish button

remove the panel from the screen

Notes:

The columns of data may be separated by spaces or a tab. (tab is used for spreadsheet transfers). The 

internal width and length data are retrieved from the drainage.4d file for the pit type specified. If 

you want a longer description for the pit then the type used inside 12d this can also be entered in the 

drainage.4d file. The remarks for each pit are entered as user defined pit attribute named remarks 

and may be set using the attribute editor (on the drainage menu) or via a spreadsheet.

Easting Northing Sample

.PIT SCHEDULE                                                             

  Pit                                INTERNAL           INLET          OUTLET                  PIT   

  No    TYPE    EASTING NORTHING    WD       LEN     DIA   INV LEV   DIA   INV LEV  FIN RL    

DEPTH         REMARKS       

   B1   SA2    5302.458 7336.936  450.000  900.000                    375   28.210   29.387    1.177                      

   A2   SA2    5264.372 7322.036  450.000  900.000    375   27.470                   28.646    1.226                      

   C1   SA2    5224.155 7336.936  450.000  900.000                    375   26.690   27.863    1.173                      

   A3   SA2    5187.910 7322.036  450.000  900.000    375   25.930                   27.158    3.628                      

   A1   SA2    5309.458 7321.100  450.000  900.000                    225   28.550   29.577    1.027                      

   A2   SA2     5264.372 7322.036  450.000  900.000    225   27.470    375   27.420   28.646    1.226                      

   A3   SA2     5187.910 7322.036  450.000  900.000    375   25.930    375   23.530   27.158    3.628                      

  A4   SA2   5157.411 7321.332  450.000  900.000   375   23.090                26.714    3.624 outlet to 

existing system 

NOTE:

1. ALL SETOUT POINTS QUOTED TO CENTRE OF PIT

Road Chainage Offset Example

DRAINAGE LINE A

PIT PIT LOCATION LOCATION OFFSETS

No. EASTING NORTHINGSTATION CTRL OFFS TYPE REMARKS
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A/1 5354.629 7336.936 231.171 d002 -7.450

A/2 5340.691 7320.911 217.233 d002 8.575

A/3 5293.458 7320.886 170.000 d002 8.600

A/4 5250.131 7320.886 126.673 d002 8.600

A/5 5217.194 7322.036 93.736 d002 7.450

A/6 5183.458 7322.036 60.000 d002 7.450

A/7 5152.699 7322.036 29.241 d002 7.450

Notes

The Set pit details must be run at least once to before printing the report. If the pits are moved or the 

designed strings changed then this option must re rerun.

The Road Chainage and Offset Pit Schedules use two user defined attributes for each pit. The first is ctrl 

string which identifies the string that the pit will be offset from and the second is ctrl model which 

contains the model name for the control string. These may be manually created/modified using a 

spreadsheet or the attribute editor.

The easting northing data obtained for the road design string option is obtained by dropping the manhole 

centre perpendicular onto the selected road design string. This data is stored as pit attributes setout x and 

setout y. It is calculated when the manhole cover levels are recalculated (drainage misc utilities and during 

drainage export (recalc level option must not be turned off)).

The cover elevation data obtained for the road design string option is obtained by dropping the manhole 

centre perpendicular onto the selected road design string and obtaining the elevation at this point. This data 

is stored as pit attribute level z. It is calculated when the manhole cover levels are recalculated (drainage 

misc utilities and during drainage export (recalc level option must not be turned off)).
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11.0 Long Section Plotting

Detailed description of the 12d drainage long section plotting may be found in the 12d Reference 

manual. The long section plots are customised using the drainage plot parameter files (drainppf). 

Title blocks, user defined text may be added and then plotted directly or to various file formats (dwg, 

dgn etc.). From the main menu

Design=>Drainage-Sewer=>Plots=>Longsections

See Also

manhole Schedules to set road chainage and name data

To access the 

drainppf files sup-

plied select the 

icon and then 

walk right on Lib 

to select this 

drainppf file.

Select Read

Enter a new name 

for this drawing 

and select Write. 

This will save the 

setting we are 

about to make 

should you want 

to replot this long 

section.

This section view 

determines the 

additional mod-

els (such as serv-

ices) to show plot. 

These are referred 

to as corridor 

models. The ver-

tical exaggera-

tion is also 

obtained from this 

view.
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The network model field will be completed with the model of the string being profiled. If this 

is not your drainage network model then select it now.

When Plotter Type is set to model then plot file stem is the model name prefix for plots that 

will be created. The first sheet of plots will be in model plot1, the second in plot2 etc.

The plot height determines how much room is left vertically for the actual plot. This specifies 

the total height of the plot. 12d then constructs the box area and arrow area on the bottom and 

then arrow area on the top. The amount left over is used for the long section itself. 

To stop datum breaks from occurring increase this height, increase your plot scale or decrease 

your vertical exaggeration. If there is too much white space in the graph area then reduce this 

value.
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The +Drainage plot+title block+User title info allow you to enter the text for the title block. 

The list displayed is retrieve from the title file selected above. Enter the data for the plot and then 

select Write to save the changed to the local drainppf file you entered earlier.

Select Plot and the plots will be send to the plot file stem entered. These models may be added 

(one at a time) to a plan view to inspect them before plotting to paper or exporting to other draw-

ing packages.

If changes are to be made and then plotted again you must delete the drawings in the model. 

These models may be cleaned out using

Models->Clean
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The asterisk may follow the plot file stem to clean all of the 

models at once. You will be shown the model list before they 

are cleaned.
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12.0 Working with Kerb/Lip Strings

The reference point for kerb inlet manholes is usually on the kerb lip string or a fixed distance off the 

string. The rest of the strings only complicate the picture so we will take copies of the kerb strings to 

be placed in another model. Isolating the kerb strings into a separate model and joining them together 

is the recommended way to work with them. This may take a few minutes but sometimes you have 

even less time than that. So first lets look at how to pick kerb strings quickly.

12.1 Picking kerb strings - name snap

Strings generated by 12d have specific names attached to them. The lip string is often called “lok”. 

Therefore, if we could restrict our string selection to those strings named “lok” it would make plac-

ing the manholes very efficient. We are going to do this with the Name snap.

There are 3 types off snap tool bars available. Standard, vertical and horizontal. To obtain the stand-

ard snaps toolbar select, Utilities=>Snaps=>Snaps and the following snap toolbar will appear.

Leave the panel up to remind your erase the lok entry and select Set again so that you will once again 

be able to pick any string.

12.1.1 Placing a manhole at a Specific Control String Chainage

When appending or moving drainage manholes, the following steps will place the manhole at a spe-

cific chainage along the control string.

1. RB and then select Snaps cogo=>Create=>Perpend from the menu. Messages indicating 

what to be done next are given in the bottom left corner of the 12d window.

Select Name and the following panel will appear.

Enter lok and select Set. Now only strings with this name will be 

selected.
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2. LB select but do not accept the road centre line (control string).

3. To place the manhole across from chainage 2100 Type ch2100 then press enter.
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4. MB accept the inserted point. This identifies the point on the control string. Next

5. LB select the lip line then MB accept. The construction point will be displayed on the lip line

6. MB accept the construction point to place the manhole.

12.1.2 Placing a manhole at a Specific Distance/Offset along the kerb string

When appending drainage manholes, the following steps will place the manhole at a specified dis-

tance along a string and if desired an offset. 

1. RB and then select Snaps cogo=>Locate=>Offset from the menu. Messages indicating what to 
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be done next are given in the bottom left corner of the 12d window.

2. When you select the string to measure the distance along, do not click but rather drag in the 

direction you want to offset. Next MB accept 

3. LB select then MB accept the control point to measure the distance from. (If this point is not 

on the string selected in step 2 the point will be dropped perpendicularly onto that string).

4. Type the distance along the string then press Enter (a negative value would go in the oppo-

site direction to the drag in step 2).

5. Type the offset distance from the string then press Enter (positive is defined using a right 

hand rule method from the direction in step 2).

6. MB accept the construction point to place the manhole.

12.2 Locating Crests and Sag Points

This step will place tick marks at the crest and sag points of your kerb strings. It is an optional 

step but it will help ensure that a drainage manhole is always placed at SAG manhole locations. 

If your road designer has given you kerb inverts strings split into numerous sections, use the 

“head to tail” feature described in section 4.2 above before using this section. The crests and sag 

locations along the design string can be identified using the selection

Strings =>Label => Chainages



Revised February 2006 12d Stormwater Design Course Notes Page 92 of 94

12d Solutions Pty Ltd

COURSE NOTES

STORMWATER DESIGN

To get a clear picture of what the kerbs look like in profile lets create a section view and profile the 

kerb string.

To obtain more working area, hide the Output Window (Window=>Output window).

From the main menu select,

Enter the model name for the kerb strings.

Select crests/sags from drop down list.

Enter a model to contain the text labels. A ,1 

after the model name, requests that the model 

be added to view 1. This saves you adding the 

model to the view later to see the labels.

Select icon to define the text style.

Optionally select heights and not chainage.

Select the Marks property sheet 

Type the same model name as above for the 

tick marks.

LB to select ticks centred from the drop 

down list.

5m white marks stand out well on the screen.

Select Label to create the labels.

Select Finish to remove the panel.
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View=>New=>Section View

Now Select Profile on the section view title area and then pick the kerb string in the plan 

view. Your screen should now look like the following.

x

Place your pointer in the section view and notice how the cross in the plan view indicates your 

position in plan.
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THE END


