River Interfaces
HEC RAS, ISIS, Mike11 and XP SWMM
12D Model Course Notes

These course notes assume that the trainee has the basic 12D Model skills usually obtained from the “12D Model Training Manual”

These notes are intended to cover basic River Interface work and plotting. For more information regarding training courses contact 4D Solutions training Manager.

These notes were prepared by
Robert Graham

Revised August 2003

Copyright © 4D Solutions Pty Limited 2003

These notes may be copied and distributed freely.

Disclaimer

12D Model is supplied without any express or implied warranties whatsoever.
No warranty of fitness for a particular purpose is offered.
No liabilities in respect of engineering details and quantities produced by 12D Model are accepted.

Every effort has been taken to ensure that the advice given in these notes and the program 12D Model is correct, however, no warranty is expressed or implied by 4D Solutions.

Copyright © 4D Solutions Pty Limited 2003
COURSE NOTES

River Interfaces

1.0 Introduction ................................................................. 5
1.1 Creating the HEC RAS, ISIS, Mike11 or XP-SWMM Projects ................................................................. 5
1.2 Reading Water levels Results into 12d Model ....................................................................................... 5

2.0 Topographic Data to Ground Surface (TIN) ....................................................................................... 6
2.1 Assembling the Data ....................................................................................... 6
2.2 Cross Section Soundings ....................................................................................... 6
2.3 Topographic Survey Data ....................................................................................... 6
2.4 Creating the Ground Surface “TIN” ....................................................................................... 7
2.5 Nulling the Long Triangles ....................................................................................... 7
2.6 Adding Buildings to the Ground Surface “TIN” ....................................................................................... 8
2.7 Reviewing the Data (3D Perspective View) ....................................................................................... 12

3.0 Adding Aerial Photographs ....................................................................................... 14

4.0 River Strings ....................................................................................... 16

5.0 Source Strings ....................................................................................... 22
5.1 Creating Regularly Spaced Source Strings ....................................................................................... 23
5.2 Duplicating, Modifying and Deleting the Source Strings ....................................................................................... 24
5.3 Drawing Source Strings ....................................................................................... 24

6.0 Creating the HEC RAS/ISIS/Mike11 XP-SWMM Projects ................................................................. 26

7.0 Reservoir Strings ....................................................................................... 27

8.0 Spill strings ....................................................................................... 29

9.0 Mike 11 Export Notes ....................................................................................... 30
9.1 Inside 12d ....................................................................................... 30
9.2 Running MIKE11 ....................................................................................... 33
9.3 Creating Time Series Files ....................................................................................... 33
9.4 Importing Cross Sections ....................................................................................... 33
9.5 Calculating Grid Points ....................................................................................... 33

10.0 Presenting Water Level Results in 12d Model ....................................................................................... 34
10.1 Overview ....................................................................................... 34
10.2 Generating the water level files from HEC RAS ....................................................................................... 38
10.3 Generating the water level files from XP-SWMM ....................................................................................... 38
10.4 Reading in the River Analysis Program Results ....................................................................................... 39
10.5 Defining the Water Surface Boundaries ....................................................................................... 42
10.6 Trimming the Water Surface Tin and Islands ....................................................................................... 42
10.7 Colouring the Ground Surface ....................................................................................... 43
10.8 Colour by Depth ....................................................................................... 44
10.9 Depth Contours ....................................................................................... 47
10.10 Adding Values to the Contours ....................................................................................... 48
10.11 Labelling the Cross Sections ....................................................................................... 50
10.12 Colour the ground surface by elevation ....................................................................................... 51

11.0 Plotting - Plan, Long Section and Cross Section ....................................................................................... 55
11.1 Preparing Inundation Maps ....................................................................................... 55
11.2 River Long Section Plotting ....................................................................................... 59
11.3 Cross Section Plotting ....................................................................................... 61

12.0 Presenting Images ....................................................................................... 63
12.1 Screen Captures ....................................................................................... 63
12.2 Perspective View and the “Walk Down the River” ....................................................................................... 63
12.3 Creating a Movie AVI File ....................................................................................... 64

13.0 Advanced Topics ....................................................................................... 65
13.1 Reading in HEC RAS Interpolated Cross Sections ....................................................................................... 65
1.0 Introduction

The 12d - Rivers Interface modules are designed to create HEC RAS, ISIS, Mike11 and XP-SWMM projects from ground surface “TINs” and to present the water results from these packages as cross sections, long sections and 3D perspective views.

The interface contains the following capabilities:

1.1 Creating the HEC RAS, ISIS, Mike11 or XP-SWMM Projects

- Create regularly spaced cross sections along a defined river centre line.
- Cross sections can easily include buildings and channel improvements.
- Automatically label the cross sections with their centre line chainage.
- Mark left and right over bank locations from user defined bank strings.
- Set initial Manning “n” values for the sections.
- Define levee points using a user defined tolerance (HEC RAS only)
- Eliminate cross section points if they lie within a user specified linear corridor.
- Create elevation-storage curves and spill sections (ISIS and XP SWMM)

1.2 Reading Water levels Results into 12d Model

- Create water level surfaces from the HEC RAS/ISIS/Mike11/XP SWMM files
- Prepare inundation maps that detail the water level boundary (flood) limits between the cross sections.
- Prepare inundation maps overlaying flood limits from several flood discharges.
- Colour the ground surface for different flood events. Colouring the bottom of the riverbed, blue for example, allows the modeller to see the extents of flooding and the shape of the riverbed.

These course notes assume that the trainee has the basic 12d Model skills usually obtained from the “12d Model Training Manual”. These notes will outline the steps required to obtain these results but the details of the procedures are supplied as video presentations on the HEC RAS or XP SWMM training Cds so that the user can see the actual steps and the results in real time. This “live” training medium combined with the 12d Help system create a power reference resource for the 12d model user.
2.0 Topographic Data to Ground Surface (TIN)

12d model creates the HEC RAS/ISIS/Mike11/XP SWMM project from a ground surface. Survey data, cross section soundings and topographic map information can all be combined to create the ground surface TIN. 12d model focuses on the preparation of ground surface information in the HEC RAS/ISIS/Mike11/XP SWMM project expecting the river modeller to add bridge data, culverts and ineffective flow areas to the project. Although the actual bridges and culverts are not modelled in 12d, the water levels upstream and downstream of these structures become part of the presentation of results.

2.1 Assembling the Data

Data to create the ground surface TIN generally comes from aerial photography, LIDAR, cross section soundings, river bank and cadastral survey supplemented with topographic mapping information.

2.2 Cross Section Soundings

Cross section soundings are required when the riverbed may not be surveyed in the dry. If cross sections are to be generated between these cross sections then the ground surface TIN needs to be carefully modelled. The following points should be considered when using cross section soundings.

- A string, connecting the ends of the cross section, can be used to create a break line preventing triangles extending across the river section. This string can also be used to create a boundary string for later fencing other survey data.

- Cross section data should not be separate points but rather break lines. Often, the cross sections do not create a perfectly straight line. Therefore, to prevent a triangle being created from data on the one cross section, the Remove bubbles option should be selected.

2.3 Topographic Survey Data

Common formats for Topographic mapping data are,

- xyz string
- AutoCAD dxf or dwg format
- several DEM formats (USGS for example)
- EE BY survey

The data for this project in stored in xyzs format.

From the main menu File I/O->Data Input->xyzs
2.4 Creating the Ground Surface “TIN”

Add only the models you want to include in the tin onto a view (survey data). If your data comes from several sources you would add additional models onto the view.

From the main menu  **Tins=>Create=>View**

Short-cuts  press Enter after typing the **New tin name** and the **Model for tin** field will be completed for you.

2.5 Nulling the Long Triangles

Long triangles outside the data area should be turned off (nulled) so that the user is aware that the data in these external zones is not valid.
Remove the “survey data” model from the plan view and add the “tin ground surface” model. Note the long external triangles. Now null these triangles

From the main menu **Tins=>Null=>by angle/length**

Use the default values. This option nulls from the outside inwards and stops at all breaklines. The values are stored with the TIN and are re-applied if the tin is re-triangulated.

### 2.6 Adding Buildings to the Ground Surface “TIN”

Building lines in cadastral survey data often does not include the top of building elevations. Therefore to create a building in 3D the following steps can be followed.

1. The building outline is read into 12d. In this case it is from a DWG file.

   From the main menu **FILE I/O->Data Input->DWG/DXF**
It is recommended that you always use a Prefix for models. Every layer in the dwg file becomes a model in 12d. When a prefix is used all of the layers will be grouped together in the 12d model popup lists. It is a good idea to include a space at the end of the prefix.

Help tip the data does not immediately appear on the view. You must add the model to your plan view.

2. The building line must be a 2D string. Now create a 3d building from the 2D string.

From the main menu select Tins=>User=>Create buildings for tins.
The building boundaries are paralleled inwards by the amount specified as offset tolerance. The outer most string (blue) is draped onto the ground surface and assigned the wall colour. The inner string (white) remains a 2d string with its height set to the building height above the highest point on the draped string. These strings can now be used to define the building in a design tin.

3. Before retriangulating the data, remove all of the ground survey data from within the buildings. From the main menu Utilities=>Fence=>Multi Fence.
4. The “houses 3d” and the “survey data fenced” are ready to be triangulated. Now edit the tin.

From the main menu **Tins->Edit->Tin**

Change the “survey data” to “survey data fenced” and add the houses to the model list.
5. Finally, you can colour the tin using the colours of the strings in the model “houses 3d”.

From the main menu **Tins=>Colour=>Colour within polygon**

![Colour Triangles by Polygons](image)

Use **model of polygons** is used so that all of the buildings (roof and walls) are coloured at once.

**2.7 Reviewing the Data (3D Perspective View)**

Once the ground surface has been created it can be viewed by adding it to the perspective view. The Open GL perspective view has the greatest capabilities but requires a graphic cards to support the open GL language and your operating system must be NT, 2000 or more current.

From the main menu **View->New->Perspective Open GL**

Add the “tin ground survey” onto the view and then toggle the shading on.
1 - add the model “tin ground surface” to the view
2 - Toggle shading on
3 - uses the Joy controls to zoom in

Help hint: Your graphics card must be set to 24 bit true colour or better to view in Open GL. If you must change them then restart 12d to view the correct colours.

The Joy controls can be used to closely investigate different areas of the ground surface.
## 3.0 Adding Aerial Photographs

12d can use Geo-reference images inside 12d. These images may be used in plan view or draped over the ground surface (requires the 12d visualisation module). Version 6.0 does not print these images but they may be “dumped” to image files and movie files can be created.

From the main menu **Strings->Create->Raster**

The size and location of the photo is often stored with the image (a geo-reference tif file). In that case select only the **Raster file** and the **Raw data** will be filled in automatically. If the image does not have any location information that it may be read in from a separate file (ESRI world file in our case).

If you have more than one image they may be stored in one model. However, you may want separate models so that they may be turned on and off as individually.

The **Tin** field is used to drape the image onto the tin so it may be viewed in the Open GL perspective view.

When your select **Create**, 12d decodes the file so that is may be processed efficiently. Images greater than 1 Gigabyte are common.

Return to your Open GL perspective view and you will see the image draped onto the tin.
**HELP Hint** The houses do not have the image draped onto them because they are coloured differently than the original tin colour (green).
4.0 River Strings

The river centre line and bank are defined by the strings in the River strings model.

The centre line string is used to:
- measure the centre line distance between the sections,
- mark to zero chainage on the cross section, and
- if automatic source strings are created they will be perpendicular to this string.

The left and right bank strings are used to:
- measure the bank distances between the sections and
- mark the cross section chainage where the conveyance (usually roughness) changes.

The names of the strings must be left bank, right bank and centre line river name, reach name (centre may be spelled center).

The left bank is on the left side of the river looking downstream and the right bank is on the right (looking down stream). These strings need not touch each other and may extend from one river reach to another.

HEC RAS and UNET

The centre line string must begin at the downstream end of the river. The modelling convention for these programs is to have the low chainage at the downstream end. You may use super, 2D, 3D or alignment strings in this model. If you put other strings in this model you will receive warning messages saying that these strings will not be used.

Each reach of the river MUST have its own centre line string and they must "touch" each other to create a river confluence.

A sample of a river strings model for HEC RAS with one confluence is shown below. The line style for the centre line is not required. It is used only to show the direction of the centre line string. Note that the main centre line has been split into two strings. This is because HEC-RAS works with separate reaches. The Strings=>Strings Edit=>Split command makes the splitting of the centre line string easy and keeps the chainage consecutive.
Notes:

left bank strings are shown in red, right bank in blue and centre line strings in yellow, green and magenta. The line style for the centre line strings is Drainage_4D->Flow line. This is not required but shows the direction of the string. The string labels were created with Strings->Label->User->Label strings with names.

Centre line string direction is very important!

HEC RAS, UNET, XP SWMM start at the DOWNstream end of the river
ISIS and Mike 11 start at the UPstream end of the river

XP SWMM, ISIS and MIKE11

Unlike HEC RAS, XP SWMM, ISIS and MIKE11 the centre line strings do not have to be broken into separate reaches. Note in the figure below that the main river reach is one string (the blue colour is used to show the continuous string).

4.1 Duplicating the strings from Survey, GIS or drawing packages

The river strings may be copied from survey data, imported from a drawing/GIS package or drawn in 12d. First we will duplicating them into the river strings model

We are going to duplicate the strings from the survey data so we will add only this model onto the plan view and then zoom into the north west corner.
From the main menu select **Strings->Strings edit->duplicate**

The name and model must be entered but the new colour is optional.

Once the centre line has been selected and accepted, change the name to left bank and lick the left bank string that has been surveyed. Now repeat this again for the right bank.

**Help hint:** To ensure you have type the names correctly

From the main menu select **Models->string info table**
Select the river strings model

<table>
<thead>
<tr>
<th>Model</th>
<th>Type</th>
<th>Colour</th>
<th>Linestyle</th>
<th>Chainage</th>
<th>Length</th>
<th>Pt</th>
<th>Line</th>
<th>Points</th>
<th>Min X</th>
<th>Max X</th>
</tr>
</thead>
<tbody>
<tr>
<td>left bank</td>
<td>3d</td>
<td>magenta</td>
<td>1</td>
<td>0</td>
<td>911.0407</td>
<td>line</td>
<td>73</td>
<td>742551.651</td>
<td>5737077.2</td>
<td></td>
</tr>
<tr>
<td>right bank</td>
<td>3d</td>
<td>magenta</td>
<td>1</td>
<td>0</td>
<td>904.9064</td>
<td>line</td>
<td>68</td>
<td>742567.984</td>
<td>5737076.3</td>
<td></td>
</tr>
<tr>
<td>centre line main</td>
<td>3d</td>
<td>magenta</td>
<td>1</td>
<td>0</td>
<td>874.6835</td>
<td>line</td>
<td>83</td>
<td>742565.431</td>
<td>5737079.4</td>
<td></td>
</tr>
</tbody>
</table>

The string name can be changed if you have incorrectly named one of the strings.

From the main menu Strings->String Edit->Change

Type the name first and then select the string to be renamed.

4.2 Drawing the River Strings in 12d

The river strings may be created with the option 2d string create option or the super string drawing toolbar. In this case we will use the drawing toolbar.

First complete the string details,
If you are drawing the centre line “freehand”, turn off your point and line snaps and turn your cursor snap on. Press ESC or right mouse and select cancel to stop adding points.

**HELP hint** If you accidentally hit ESC and want to add more points to the string then
From the main menu  
**Strings->points edit->append**
Select and accept the end of the rivers string and then continue.

Now to create the left and right bank using the same process. Be sure to change the string name.

The direction of the left and right bank strings is not important. However, **the left and right bank strings must be continuous along a reach**. The chainages on the strings are used to calculate the distance. If the string starts and stops then the distance will not correct.
5.0 Source Strings

Cross sections are created at the location of the source strings. These source strings are initially created at a user defined spacing and section length using any one of the river interfaces writers. The user may alter these sections as desired. These may be shortened if they intersect at sharp bends in the river; they may be extended at extremely wide river sections or extra points may be added so that the section is no longer a straight line.

Source strings can be deleted and additional sections can be added by creating new source strings. The Create source strings tick box on the interface panel must NOT be selected to use the customised strings.

A quick way to manually create 2D strings with only 2 points on them is to use

Strings=>Create=>User=<Create 2 pt - 2D strings.

A sample of source strings (shown in magenta) is presented below. The source strings may run in any direction except for Mike11. In Mike11, the cross sections will be created in the same direction as the source strings. For all other interfaces the low chainage will be used for the left bank (section viewed looking downstream).
5.1 Creating Regularly Spaced Source Strings

The River Interfaces use source strings to specify the locations and shape of cross sections. The Interface panels can be used to create regularly spaced source strings perpendicular to the centre line. If your survey data includes cross section soundings then you will likely want to use these cross section strings as source strings. In this case skip this step. Select the panel using Design=>Rivers=> and then your desired interface and then the create option. To create these source strings, the Create source strings box must be selected. The spacing and the total length of the source strings are specified in the panel.

Add the “source strings” model onto the plan view.

Note that even though these strings are very random in placement the HECRAS project has been created.

When the centre line of the river is irregular in direction the resulting source strings may have many errors. These are noted below.
5.2 Duplicating, Modifying and Deleting the Source Strings

Once the source strings are created they may be duplicated, deleted or modified. The menu selections used for this process include:

- Strings=>Delete
- Strings=>Points Edit=>move
- Strings=>Points Edit=>insert
- Strings=>Strings Edit=>parallel
- Drafting=>Multi string translate

5.3 Drawing Source Strings

Source strings may be drawn quickly using the drawing toolbar.

String name is not important  Set model name
Most source strings are straight lines with only 2 points. You may have numerous points forming “bent” cross sections if desired.

The quickly draw 2 point string select the 2 point button from the toolbar.

Do not press ESC after placing the second point. Just proceed onto the next string. For drawing “freehand” turn your point and line snaps off and your cursor snap on.

You can use the drawing toolbar edit buttons on the strings as long as they are super strings (Strings drawn using the button above are always super strings).
6.0 Creating the HEC RAS/ISIS/Mike11 XP-SWMM Projects

Once you are satisfied with the source string location and shape then you are ready to create the HEC RAS/ISIS/Mike11/XP-SWMM project.

From the main menu

Design=>Rivers=> and then your desired interface and then the create option.

The **Create source strings** option should now turned off.

**YOUR SOURCE STRINGS WILL BE DELETED IF YOU DO NOT REMOVE THE TICK MARK!**
COURSE NOTES

River Interfaces

7.0 Reservoir Strings

The reservoir strings may define inline reservoirs or offline storage. The string must be a 2d string with the level set to the maximum level to be used in the stage storage curve. 12d will determine the minimum level inside the reservoir string and then calculate the volumes at a 1 m (foot) increment. The default increment may be changed by creating a string attribute "stage increment" (see stage increment).

Inline reservoirs are "touched" by centre line strings both upstream and downstream. Offline storage areas are linked to the cross sections via Spill strings.

A sample drawing showing an inline reservoir in cyan (1-277) follows. Note that the river centre line touches the reservoir string both upstream and downstream. The left and right bank strings may continue straight through the reservoir.

A sample drawing of an offline reservoir follows (the reservoir string is shown in green). Note that the spill string (black) starts at the source string (point 1), then follows the section line to be cut and exported (points 2 to 5) and ends by touching the off line reservoir string at point 6. The rivers strings do not touch the offline storage strings.
8.0 Spill strings

Spill strings are strings that link offline storage areas to a cross section (see drawing above). The string must begin by "touching" the source string and then proceed to the first point on the spill section. During the export the first point will NOT be exported as part of the spill section. After defining the end of the spill section the last point on the string must "touch" the reservoir string. Again this last point will NOT be exported as part of the spill section.
9.0 Mike 11 Export Notes

9.1 Inside 12d

12d creates most of the files necessary to run MIKE11. The exception to these are the time series files (both water level and discharge data). The simulation file created assumes that these files will have the same name as the centre line strings used in 12d. For example, if you name your centre line string centre line Major River then your time series files will be named Major River-H.DFS0 for the tail water conditions and Major River-q.dfs0 for your discharges.

The *.bnd11, *.hd11, *.nwk11 and *.sim11 files are created by appending 12d data to default data found in the following files.

- cross_sections.4d
- hd11-end.4d
- hd11-header.4d
- nwk11-header.4d
- nwk11-options.4d
- sim11-header.4d
- sim11-period.4d

The user need not modify these files unless they would like to change the default values used when first creating the MIKE11 project. If you plan to modify these files, they are found in the 12d setups directory. Before modifying they should be copied to the 12d user directory (global defaults) or into the current project directory if they are project specific.

The MIKE 11 panel for creating the MIKE 11 project follows.
The fields and buttons used in this panel have the following functions:

<table>
<thead>
<tr>
<th>Field Description</th>
<th>Type</th>
<th>Defaults</th>
<th>Pop-Up</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>River strings model</strong></td>
<td>Model box</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Model containing the river centre line strings. **The centre line strings must begin upstream and proceed downstream.** The name of the river must follow the words “centre line “ (note the ending space). The name of the river may follow the words “Centre line “ (note the ending space). For example the centre line string may be named “Centre line Parramatta River, downstream reach”. The comma separates the river name from the reach name. If no comma is included then the river name is repeated for the reach name.

Confluences are modelled by a using a separate string for all reaches. Thus a system with a branch is modelled with three strings. The branch will be one string and the main reach will have a downstream string and an upstream string. The reaches must touch at the confluence.

| Source strings model   | Model box |          |        |

New source strings will be created in this model or existing source strings are contained in the model.
See Create source strings tick box below.

Create Source Strings

- **Tick box**
- **not selected**

When selected existing source strings are deleted and new ones created perpendicular to the centre line at the specified spacing and length. Once you have created the sources strings they can be easily modified. On the Strings->Points Edit menu you will find the selections **Move** (to move the end points), **Insert** (to insert additional points).

Distance between sections

- **Real box**

The distance between the cross sections. At present no check is made for overlapping cross sections around river bends.

Section Length

- **Real box**

The length of the cross section with zero chainage at the mid point.

Cross section model

- **Model box**

The cross sections created and exported are stored in this model.

Centre Line Chainage Factor

- **Real box**

The cross section names are created by dividing the chainage on the centre line by this factor. Typically 1000 is used to convert metres to kilometres and 5280 to convert feet to miles.

Surface Tin (not the model)

- **Tin box**

Tin or super tin to create the cross sections from (remember a tin is like a string. It is placed in a model.).

Bank Marker Tolerance

- **Real box**

If the surface level drops more than this amount while moving away from the channel centre line then the crest is used as a Bank Marker. A value of zero means that no bank marks are created.

Delta Y tolerance

- **Real box**

This value filters out points on the cross section. Imagine a tube of this diameter passing over the cross section. The tube is elongated until one point lies outside the tube. The tube is shortened to the previous point and then all points inside the tube are deleted from the cross section. The tube then moves on to the next point. The final water tin is created from the ground tin and therefore the boundary string is located using the unfiltered section.

Manning’s n

- **Real box**

Manning’s n values for the channel sections.

Initial depth

- **Real box**

This depth is added to the minimum elevation on the cross section and is used as the starting water level for the cross section.

Units

- **Choice box**

This selection will set the default units for the project being created.

Project file name

- **Input box**
COURSE NOTES

River Interfaces

The MIKE11 project name. All of the MIKE11 files will begin with this name and the appropriate extensions added.

9.2 Running MIKE11

Three steps are required to run MIKE11 with the files 12d creates.

1. Create your time series files.
2. Inside MIKE11, create a new cross sections file and import the cross sections.
3. Open the simulation file, and load the network file to have the grid points calculated.

9.3 Creating Time Series Files

Your time series files must be named with the prefix of the river string name. For example if your centre line string in 12d was named centre line Major River your time series files need to named Major River-H.DFS0 for the tail water conditions and Major River-q.dfs0 for your discharges.

The standard time series dates are from 12:00 to 12:30 on 01 January 2000 with a one minute time step. If other periods are desired, you can either change the file sim11-period.4d in the 12d library before running the interface or change the dates inside MIKE11 after you read in the data. DO NOT USE THE ORIGINAL FILES! Copy the file you are changing into the 12d user directory and modify it there. 12d will look for the file here first.

9.4 Importing Cross Sections

From the MIKE11 main menu select File->new and then under Mike11 select cross sections from the dialogue box.

From the main menu select File->Import->Import Raw data & Recompute. Select the *.txt file with the Project file stem you specified in the 12d-Mike11 Write Panel. Now save this file with the same Project file stem (MIKE11 adds the .xns11 extension).

9.5 Calculating Grid Points

From the main menu select File->Open and select the *.sim11 file with the Project file stem you have specified in 12d. On the Input tab property sheet select Edit beside the Network file. Press Ctrl+T to take you into the table editing mode and then select the Grid Points tab property sheet. On the sheet select Generate Grid Points and then save the file.

You should now get the “Green lights” on the Start property sheet of the simulation file editor.
10.0 Presenting Water Level Results in 12d Model

Once you have completed your river modelling in your river analysis package you can use the presentation tools within 12d model to view the results in plan, section and 3D perspective views. Finally, you can even create flights down the river and store them in AVI files so that they may be used in public presentation.

10.1 Overview

After the river modelling in your river analysis package is complete the water level results are read back into 12d. Water level strings are created with the plan shape of the cross sections at the elevation retrieved from your river analysis package results. These strings are then triangulated to create a water surface tin.

For meandering rivers, the cross sections (shown in green above) may not be at a close enough spacing to create a water surface that follows the river. 2D shape strings (shown in red above) can be created (automatically or manually) to create a water surface (shown in blue above) to follow the river.
The water surface is draped over the ground surface and the boundary strings (strings defining the edges of the water surface – shown in yellow above) are created. They may be used to trim the water surface or shade your ground surface tin for flood inundation mapping. Boundary strings also include islands! Shading the river bed blue, in a 3D perspective view, is an effective way to show the water level extents and still view the shape of the river bottom (it has the effect of very clean water that you can see through!).

The water surface may be

- contoured (elevation),
- depth contours created,
- water surface coloured by depth (shown above),
- cross sections plotted
- and longitudinal profiles drawn (shown below).

All of these results can be plotted complete with your customised drawing sheets.

Finally, you may walk down the water course in the perspective view (and record this
COURSE NOTES

*River Interfaces*

to an Windows AVI file).
COURSE NOTES

River Interfaces
10.2 Generating the water level files from HEC RAS

The water level results are transferred back to 12d using the HEC RAS menu selection File=>Export GIS Data. The Export water surfaces and Use version 2.2 export format tick boxes must be selected.

10.3 Generating the water level files from XP-SWMM

When you exit XP SWMM the water level data is automatically written to the same xpx file as you exported to earlier. This xpx data file is now ready to be read into 12d.
**10.4 Reading in the River Analysis Program Results**

To read the water level results, select the panel using **Design=>Rivers=>** and then your **desired interface** and then the **Read** option. For example, the HEC RAS panel is shown to the left.

**EXISTING DATA**

**River strings model** Model box

The river strings model specified in the write panel.

**Cross Section model** Model box

The cross section model specified in the write panel. This must be specified but is only used when reading the *.rep file types (no longer supported).
Shape string model  Model box

For meandering rivers, the cross sections (shown in green above) may not be at a close enough spacing to create a water surface that follows the river. 2D shape strings (shown in red above) can be created (automatically or manually) to create a water surface (shown in blue above) to follow the river.

A quick way to manually create 2D strings with only 2 points on them is to use

\[
\text{Strings}=>\text{Create}=>\text{User}=<\text{Create 2 pt - 2D strings}.\]

Ground surface tin  Tin box

If a boundary string model is specified below, the intersection of this ground surface and the water surface will be determined. The strings will be stored in the boundary string model.

File format  Choice box

The GIS format should be used in most cases. The rep format is used for reading the HECRAS report files with the “Standard Table 1” selected in HECRAS.

HEC-RAS/Mike11/XP SWMM report file name  File box
COURSE NOTES

**River Interfaces**

The HEC-RAS report file (GIS format) is created using the HEC-RAS menu selection
**File=>Export GIS data**

or
the xpx file that you used while exporting the data to XP-SWMM.

or
the *.res11 binary file generated by Mike11. It will convert these files to ASCII and extract the maximum water levels for the time period analysed.

**RESULT DATA**

*Water surface tin model* Model box
The model to contain the new water surface tin.

*Water surface tin* Tin box
The name of the water surface tin to be created.

*Water level results model* Model box
The model where the water surface strings will be created at each cross section and shape string.

*Boundary string model* Model box
The model to contain the intersection strings between the water and ground surfaces specified above. If left blank no intersection strings will be calculated.

**PARAMETERS**

*Chord Length* Model box
This value sets the spacing for the points on the water level strings (both cross section and shape strings). It is recommended that you use a length of no more than half of your average cross section and shape string lengths. A large value in this field may result in unexpected water level profiles for meandering rivers.

*Chainage Tolerance* Real box

**HECRAS Note**
This field must contain a value but is only used for reading the Mike11 results and the *.rep files for HEC-RAS (use with caution). This is the tolerance used when the cross section chainage from the HEC-RAS/Mike11 report/files is compared with the cross section string names. A value of 0.0001 is excellent if you have not altered the cross section names in 12d or Mike11/HEC-RAS.

However, if you have altered chainage names then you may have to increase the value of the tolerance. Suppose the tolerance is set to 0.01 and the water level for section 0.056 is read from the HEC-RAS report file. The interface will search for the first string with a name between 0.055 and
0.057. If you chose to great of a tolerance then more than one water level result will match a 12d cross section and a warning message will be given.

If you have one specific cross section that you would like to have a different tolerance set for (maybe only one section is giving you troubles), use the Attribute Editor (Strings->User->Attribute Editor), select the cross section string and create a real type attribute named tolerance set to the tolerance desired.

### 10.5 Defining the Water Surface Boundaries

If a **boundary string model** is specified, a tin-tin intersect will be performed to determine the boundary strings for water surface. These boundary strings (usually one for the left bank and one for the right bank) will be stored in the model **Boundary strings model**.

The first step is to trim the water surface back to the boundary strings. Since the water boundary does not generally form a closed polygon (the left and right river boundaries will need to be joined at the upstream end) use the **Strings=>User=>Head to tail closest points** or **Strings=>Strings Edit=>Join** to connected strings.

If the water surface reached the edges of you cross sections then there will be numerous breaks in the boundary string. The best solution is to extend the cross sections and/or add additional shape strings. If it is not a major error in modelling then the break in the boundary can be joined inside 12d.

### 10.6 Trimming the Water Surface Tin and Islands

From the main menu **Tins=>Null=>by polygons**

This selection will null triangles inside the polygon you have created above.
If you have numerous islands, say more than 10 it may be easier to copy all of the islands into one model using the fence command Utilities->Fence->Fence.

The Model is the boundary strings model. Select the icon to the right of Polygon for fence and then pick the boundary string.

The Exclude model containing fence should NOT be ticked.

The Model for fence inside is the new model to contain the islands. Select Fence and all of the islands inside the boundary string will be copied to the islands model.

### 10.7 Colouring the Ground Surface

The boundary strings can also be used to colour the ground surface. Colouring the river bed blue is an effective way to show the water level extents and still view the shape of the river bottom (the effect of very clean water that you can see through!).

Select your water surface tin

**Null mode** should be null.

**Poly mode to Outside.**

**Null on accept of polygon** when selected means you do not have to press **Set**

Select the **Polygon** button and select the top pointer from the fly out.

Now pick the boundary string. The triangles outside the polygon will now be nulled.

If you have some islands in the model then change the **Poly mode** to **Inside** and select the islands.
First, define the water surface boundaries (see above). Next re-triangulate the ground tin so that it includes the boundary string model (Tins=>Edit=>Tin). The panel is shown to the left.

Next select Tins=>Colour=>Colour within polygon. The following panel will appear.

Select your ground tin and the desired colour. Next select the Poly button and pick the boundary string to be coloured inside. If islands exist, change the colour to the colour for the island and then select the island string. If you have used the fence function above to separate the islands into a separate model then specify the model containing the islands in the Model of polygons field and then select Colour.

**10.8 Colour by Depth**

The water surface can be coloured by depth. This function calculates the depth between the water surface and the ground surface and creates “faces” of different colours. The colours to be used are specified in a depth range file.

From the main menu Tins=>Colour=>Tins depth colour.
### Original tin

This is your ground survey tin.

### New tin

This is your water surface tin.

### Range file

The range file `river_depth_colouring` is supplied (select the folder icon and browse the library). The library contains a spreadsheet that can quickly create other range files or you may edit the using the built-in range editor.
**Built in Range File Editor**

To use the built in range file editor select the folder icon beside your range file then select **edit**.

You may change the range value and the colours as desired. Be sure to select **Write** to save the changes before selecting **Finish**.

---

**Plan View to paint** you can paint a current view without saving the face data. This is a good option if you wish to take a quick look at the depth colours in one area.

**Model for faces** the faces can be stored in a model. Note that faces consume a great deal of hard disk space. Therefore you may consider colouring one area at a time using the **Poly** option.

**Select Polygon** If your water surface tin is very large than you may want to only colour a portion of the tin. If no polygon is selected then all of the area below the water surface tin will be coloured (note that if there are no negative depth colours in the range file then areas above the water surface will not be coloured).

**Poly Choices**

select an existing polygon

select a rectangular area (dynamically by 2 corner points)

select a trapezoidal area (dynamically by 2 corner points)

dynamically define a freehand boundary with numerous points
10.9 Depth Contours

Once you have the tin coloured by depth you might want to add depth contours. From the main menu select Tins->Contours->Depth Contours.
10.10 Adding Values to the Contours

Since there are numerous label formats for the contours, adding labels is performed as a separate step.

From the main menu  **Tins->Contour->Label.**
**Start distance** specifies the chainage of the first label along the contour. Usually left as zero.

**Separation** this determines the spacing of the contour labels.

**Label start and end** selected the ends of the contours will always be labelled

**Model** the model containing the depth contours created above

**Model for labels** the depth labels will be created in this model.

**Contour method** the example above uses *Line removal and Centred line read from below*. This copies the contour lines themselves and inserts a break in the line.

**Num dec places** specify the number of decimal places for the labels.

**Textstyle data** select the icon to the right to determine the textstyle for the labels. Select an entry or after selecting the icon select **edit** and the panel below will appear.
**10.11 Labelling the Cross Sections**

The cross sections may be labelled with their names.

From the main menu, Strings->Label->User->Label strings with names.

**Favorites** Favorites may be selected and modified. They are created via Project->Browse+Project+Text style data Favorites+Create text style data favourite

**Text Style** as desired

**Colour** as desired

**Text units** world units scale with your drawings and pixel do not.

**Height** as desired

**Offset** as desired (usually 0)

**Raise** distance to raise the label above or below the contour line

**Justify** set the insertion point of the text

**Angle** this angle is added to the orientation of the contour line (usually 0)

**Slant** as desired

**X factor** as desired

**Name** usually blank

Select SET before Finish!
**10.12 Colour the ground surface by elevation**

With the water surface coloured by depth, you may want to colour the ground surface by elevation.

From the main menu Design->Colour->Tin height colour.

Model to label is your cross section or source string model.

Label model is the model to contain the new labels

Text parameters use favorites as discussed above

Text locations presents a number of options for the location of the test along the string

Angle type specified is the labels are always in the same direction (absolute) or the same angle as the string (relative).

Clean text model cleans the Label model before processing.
Select your tin to colour

**Range file** \"$LIB/height colours green 0 by 1.hrf\" is found in the library. Select this file and we will edit it soon.

**Plan View to paint** you can paint a current view without saving the face data.

**Model for faces** the faces can be stored in a model. Note that faces consume a great deal of hard disk space. Therefore you may consider colouring one area at a time using the **Poly** option.

**Poly** If your ground surface tin is very large than you may want to only colour a portion of the tin. You may select an existing polygon or use the polygon tools from the drop down. When your select **Volume** only the area inside the polygon will be coloured.

**Poly Choices**

- select an existing polygon
- select a rectangular area (dynamically by 2 corner points)
- select a trapezoidal area (dynamically by 2 corner points)
- dynamically define a freehand boundary with numerous points

**Colour** select this button to colour the surface.

**Editing the Range file**

The range file may be changed manually or copied to a spreadsheet to change. To edit select the browse icon and then select **Edit NOT Edit file**
Select **Read** to load the file

Select the top corner of the table

Right mouse click then select copy (Ctrl C does not work).

You are now ready to paste the data into a spreadsheet.
Once the data has been copied into the spreadsheet you may quickly change the interval data. Select all data and then copy it onto the clipboard.

Once back in 12d select the top left corner of the table and right mouse select - paste (Ctrl P does not work).

Finally save the file.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>156</td>
<td>156</td>
<td>green</td>
<td>0.32</td>
</tr>
<tr>
<td>2</td>
<td>156</td>
<td>157</td>
<td>green</td>
<td>0.40</td>
</tr>
<tr>
<td>3</td>
<td>157</td>
<td>158</td>
<td>green</td>
<td>0.48</td>
</tr>
<tr>
<td>4</td>
<td>158</td>
<td>159</td>
<td>green</td>
<td>0.56</td>
</tr>
<tr>
<td>5</td>
<td>159</td>
<td>160</td>
<td>green</td>
<td>0.64</td>
</tr>
<tr>
<td>6</td>
<td>160</td>
<td>161</td>
<td>green</td>
<td>0.72</td>
</tr>
<tr>
<td>7</td>
<td>161</td>
<td>162</td>
<td>green</td>
<td>0.80</td>
</tr>
<tr>
<td>8</td>
<td>162</td>
<td>163</td>
<td>green</td>
<td>0.88</td>
</tr>
<tr>
<td>9</td>
<td>163</td>
<td>164</td>
<td>green</td>
<td>0.96</td>
</tr>
<tr>
<td>10</td>
<td>164</td>
<td>165</td>
<td>green</td>
<td>1.04</td>
</tr>
<tr>
<td>11</td>
<td>165</td>
<td>166</td>
<td>green</td>
<td>1.12</td>
</tr>
<tr>
<td>12</td>
<td>166</td>
<td>167</td>
<td>green</td>
<td>1.20</td>
</tr>
<tr>
<td>13</td>
<td>167</td>
<td>168</td>
<td>green</td>
<td>1.28</td>
</tr>
<tr>
<td>14</td>
<td>168</td>
<td>169</td>
<td>green</td>
<td>1.36</td>
</tr>
<tr>
<td>15</td>
<td>169</td>
<td>170</td>
<td>green</td>
<td>1.44</td>
</tr>
<tr>
<td>16</td>
<td>170</td>
<td>171</td>
<td>green</td>
<td>1.52</td>
</tr>
<tr>
<td>17</td>
<td>171</td>
<td>172</td>
<td>green</td>
<td>1.60</td>
</tr>
<tr>
<td>18</td>
<td>172</td>
<td>173</td>
<td>green</td>
<td>1.68</td>
</tr>
<tr>
<td>19</td>
<td>173</td>
<td>174</td>
<td>green</td>
<td>1.76</td>
</tr>
<tr>
<td>20</td>
<td>174</td>
<td>175</td>
<td>green</td>
<td>1.84</td>
</tr>
<tr>
<td>21</td>
<td>175</td>
<td>176</td>
<td>green</td>
<td>1.92</td>
</tr>
<tr>
<td>22</td>
<td>176</td>
<td>177</td>
<td>green</td>
<td>2.00</td>
</tr>
<tr>
<td>23</td>
<td>177</td>
<td>178</td>
<td>green</td>
<td>2.08</td>
</tr>
<tr>
<td>24</td>
<td>178</td>
<td>179</td>
<td>green</td>
<td>2.16</td>
</tr>
<tr>
<td>25</td>
<td>179</td>
<td>180</td>
<td>green</td>
<td>2.24</td>
</tr>
<tr>
<td>26</td>
<td>180</td>
<td>181</td>
<td>green</td>
<td>2.32</td>
</tr>
<tr>
<td>27</td>
<td>181</td>
<td>182</td>
<td>green</td>
<td>2.40</td>
</tr>
<tr>
<td>28</td>
<td>182</td>
<td>183</td>
<td>green</td>
<td>2.48</td>
</tr>
<tr>
<td>29</td>
<td>183</td>
<td>1000</td>
<td>red</td>
<td></td>
</tr>
</tbody>
</table>
11.0 Plotting - Plan, Long Section and Cross Section

11.1 Preparing Inundation Maps

The inundation maps for the entire river can be plotted at one time. A series of plot frames are created along the river and these plot frames are then sent to the plotter.

The first step is to create a “plot frame seed” or template. The template is used to create multiple plot frames along a string. Title block data is then entered and the plots are made.

From the main menu Plot->Plot frames->Create. The plot frame seed will be kept in a model separate from the rest of the plot frames. It is the scale of this plot frame that determines the size of the plot frame shown on the screen.

The origin and rotation of the frame are not important for the seed as these values are set for each plot frame created later.

If you are going to use the “intelligent title blocks” then make sure you enter the title block name using the Title button. A 12d title block may be found on the library. The title block file contains the default model for the plot frames (you may change this), the sheet size and the margin information. These fields are all completed when the title block is selected.

Draw viewport border copies the inside border of the view port to the final drawing.

Select Create and then add the plot frame seed model to the plan view to see what has been created.
The **Plot frame Edit** panel will now be on the screen. To edit the panel select **Pick** and pick the from. You may now change the scale etc. to obtain the from size desired.

Once the plot frame seed has been created it is duplicated along an alignment string.

From the main menu **Strings->Create->Alignment->Alignment.**

Enter a **Model** for the string and select **Create**

From the edit menu select **Append->HIP**

Draw the line indicating the centre line of the plot frames to be created (the red line is the picture above). Select **Finish** from the edit menu, then **Yes** to the confirm.

Once the string has been created select **Plot->Plot Frames->More->Plot Frames along a string.** The panel to the right will appear.

After selecting the **Alignment string** and **Seed plot frame** enter the data in the lower fields and then select **Process.** This will create the plot frames along the string.

The location and angle of these frames may now be changed by selecting editing commands:

**Plot->Plot Frame->Editor new**

**Plot->Plot Frame->Rotate**

and

**Plot->Plot Frame->Translate**

Finally the plot frames are sent to the plotter. The desired models are added to a view. The plot frames themselves are not added to the view.

From the main menu **Plot->Plot Frame and ppf editor.**
Enter a **Plot parameter file** to store the title block data and the plot frame selection.

You may use the **Single plot frame** button to plot only one plot frame or use the **Model of plot frames**.

**View to plot** is the view you have set up. This view should not include your plot frames in it.

**Plotter type** is the plotter that is to be used. **Model** may be selected for plot preview.

**Plot file stem** is the prefix for the model. An incremental number is added as a suffix for each plot frame.
The **Title block** page selects a **standard title** block or an “intelligent” **title file**. If you select a title file then proceed to the **User title info** to select the **title file**.
Select one of the title files from the library. When the file is selected the names of the user defined text locations are loaded and you may enter the data for your title block.

Select the Write button to store the data you have entered and then select Plot to plot the plot frames selected.

11.2 River Long Section Plotting

Multiple flood events may be shown on long section drawings. Generally, the centre line of the river used for the modelling is also used for the long section plots. Vertical data on the centre line is not required as the elevation data is retrieved from the ground surface tin.
From the main menu, Plot->Long plot and ppf editor

Retrieve a Plot parameter file from the library and select Read. $LIB\text{river}\_\text{long\_section single.lplotppf}$ is an example for only one flood event and $LIB\text{river}\_\text{long\_section multiple.lplotppf}$ is used for numerous events (water levels are shown on the water surface).

Select the arrow button beside Name of string to profile and pick your river centre line. Now enter the Horizontal scale and vertical exaggeration. The sheet size will be loaded from the ppf file as it will match the title block file reference in the ppf.

Enter a Plot file if you are planning to plot to a model for a plot preview. Otherwise, select your windows printer using Plotter type.
COURSE NOTES

River Interfaces

The ppf editor now needs to know the tins to show and the cross section strings so that the levels can be shown at these locations.

Select Section long plot+Boxes+Tin titles/heights/depths and change the name of the ground surface and water surface tins as required. Set 1 must be the ground and Set 2 must be the water. For multiple events copy the second set and enter the name of the next water level tin.

Select Section long plot+Cuts and change the name of the cross section model in both sets.

Lastly select Section long plot+Title block+User title info to enter the user defined data for the title block area.

Select the Plot button and then add the models specified in Plot file to a plan view (one at a time).

If the river bed overlap your section names you may increase the gap using Section long plot+Datum area and entering a large value for Graph area to datum line gap.

Finally, change the name of the plot parameter file to the drawing name. This was the plot may be easily regenerated at a later date.

11.3 Cross Section Plotting

Multiple flood events may be shown on cross section drawings. Vertical data from the cross section is used and water level tins are specified.

From the main menu Plot->X plot and ppf editor

Retrieve a Plot parameter file from the library and select Read. $LIB\river_xsection.xplotppf is the example supplied.

Enter the Horizontal scale and vertical exaggeration. The sheet size below will be loaded from the ppf file as it will match the title block file reference in the ppf.

Model of x sec to plot. These sections must have the names in the standard 12d format SECT xxx. where xxx is a number. Since the rivers have a prefix the marks the river reach SECT n-xxx the cross sections have to be split into separate models and then plotted.

From the main menu Design->Rivers->Rename move cross sections

Enter the model that contains all of you cross sections. These will be moved to new models using this name as the prefix and the reach number as the suffix. The models will be cleaned in the tick box is selected.

Now select the Model of x sec to plot as one of the new models created.

The water level tins to be plotted are entered in Section X plot+Corridors+Model selection.

If more than water level tin is desired then additional cut commands must be entered in 2 place. Section X plot+Cuts. Copy and paste as many lines as you have tins.
COURSE NOTES

**River Interfaces**

**Section X plot+Cuts+Heights.** Copy and paste as many lines as you have tins. Then change the **use height of tin 1** to the height of the next tin. For example **use height of tin 2**.

Lastly select **Section X plot+Title block+User title info** to enter the user defined data for the title block area.

Select the **Plot** button and then add the models specified in **Plot file** to a plan view (one at a time).

Finally, change the name of the **plot parameter file** to the drawing name. This was the plot may be easily regenerated at a later date.
12.0 Presenting Images

12.1 Screen Captures

Any screen may be “dumped” to a file using the Menu button on the view toolbar.

From the menu select **Utilities->Dump**

The **Format** may be **bmp, tif** or **jpeg**.
Select **Dump** and the image transferred to file.

12.2 Perspective View and the “Walk Down the River”

From a perspective view select the **Walk** button

. A string is used to define the path and elevation of your walk down the river. The elevation of the string determines the height of your eye and target. The string should be kept close to the ground for a steady view as you walk or fly.

The viewer’s height is adjusted using the **Eye Height** value. How far you look ahead and down is controller using the **Target height** and **Target dist** values. These three values can dramatically change the appearance of your walk.
**12.3 Creating a Movie AVI File**

The walk down the river can be stored in an AVI file format and played on a computer with a Multi-media player. The presentations are excellent for public presentations displays and conceptual presentations to clients.

Select the **Menu** button on the perspective view tool bar and then select **Utilities=>String movie=>along string.**

![String Movie for View](image)

The **Speed** will determine the speed the movie is played at. During the record you may expect it to be much slower.

**Frames per second** determines how smooth the final presentation is. 5 is slightly “jumpy”, 10 is smooth but very large files.

The **Movie file stem** becomes the name of the movie. You will be prompted the type of video compression you desire. The compression modes can greatly reduce the size of these files. However, many are unstable and have been known to crash the system. Try uncompressed first and then test out video compressors both in recording and play back with your client.
13.0 Advanced Topics

13.1 Reading in HEC RAS Interpolated Cross Sections

HEC RAS has advanced methods for interpolating cross sections. These cross sections may be read back into 12d to enhance the river bed definition between cross sections. The ground surface can then be re-triangulated using these new sections. There are two methods that 12d can use to read in the interpolated cross sections.

Centre line - left bank Method

When the HEC RAS project is saved the interpolated cross sections are stored in the project file with the *.g01 extension.

1. 12D automatically positions the cross sections by first locating the upstream cross section created by 12d.
2. The distance downstream along the left bank is read from HEC RAS and used to position the cross section’s left bank marker on the left bank string.
3. The distance down the right bank is read and the interpolated cross section is rotated to pass through this point on the right bank string.

Note that the right bank marker from HECRAS will likely not lie on the 12d right bank string.

From the main menu select, Design=>Rivers=>HEC RAS Interface =>Read HEC RAS interpolations. These new interpolated cross section strings are stored in the Interp Cross Sections Model.
HECRAS GIS Format

This method uses the location of the HEC RAS sections as specified in the GIS file. From the HEC RAS main menu select **File=>Export GIS Data**.

The Export Interpolated Cross Sections must be selected. If Export User Defined Cross Sections is selected then these will be created in 12d as well.

From the 12d main menu select **Design=>Rivers=>HEC RAS Interface =>Import cross sections (GIS file)**.

The cross section model **IS NOT** your original cross section model used by the HEC RAS interface. All of the new cross sections created will be stored in this model. The **Clean model** selection will delete all of the strings in the model before creating the new cross sections.
Note in the figure to the left that the cross sections do not follow the centre line of the river. HEC RAS aligns the ends of the interpolated cross sections along a straight line between the ends of the original cross sections.